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MapInfo Professional 11.5.2 New 
Feature Documentation

This document describes the new features added to MapInfo Professional 11.5.2 maintenance 
and software release. Unlike past maintenance releases, 11.5.2 is a full software update that 
includes fixes and new feature work.

For a listing of what is fixed in 11.5.2, see the MapInfo Professional 11.5.2 Release Notes and 
MapBasic 11.5.2 Release Notes. 

For a description of the new features in 11.5.2, refer to the information in this document, which 
supplements the MapInfo Professional User Guide and Help System and to the MapBasic 
Reference. The information in this document will be included in the software documentation 
delivered with MapInfo Professional 12.0.
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Displaying Your SQLite (*.sqlite) Data
MapInfo Professional supports SQLite databases through OSGeo FDO Data Access Technology, so that you can work 
with spatial data stored in SQLite database files. This means that:

• you can display your existing SQLite data on a map in MapInfo Professional;
• you can save your MapInfo tables to your existing SQLite database to take advantage of the capabilities provided 

by a transactional SQL database engine (you cannot create a new SQLite database from MapInfo Professional); 
• you can share spatial data with other applications, such as Autodesk products: AutoCAD Map 3D, Civil 3D, and 

Autodesk Infrastructure Modeler.

To start working with your data stored in a SQLite database, see Opening SQLite Tables and Opening SQLite 
Tables Using Column and Row Filters. 

FDO (Feature Data Object) is an interface for storing, retrieving, updating, and analyzing spatial data. MapInfo 
Professional installs an FDO Provider for SQLite (spatial), so that you can work with SQLite database files. The 
OSGeo FDO Data Access Technology stores geometry data to a SQLite database as FGF (Feature Geometry Format) 
objects. For information on how MapInfo objects map to FGF objects for SQLite database connections, see Mapping 
FGF Objects in a SQLite Database to MapInfo Objects on page 6.

MapInfo Professional works with data created in Autodesk products, such as AutoCAD Map 3D, Civil 3D, and 
Infrastructure Modeler, that has been stored in SQLite database format. You can view this data in MapInfo 
Professional, save changes made to the data, and then continue to work on the data in the Autodesk products. Note 
that there are some limitations reading and writing text layers created in AutoCAD Map 3D, which are outlined under 
Sharing Data with Autodesk's AutoCAD Map 3D on page 9.

For background information:

• about SQLite, see http://www.sqlite.org;
• about FDO, see http://fdo.osgeo.org.

Opening SQLite Tables
MapInfo Professional lets you select which tables in a SQLite database to open, and gives you the option to set display 
styles, and column and row filters for the tables.

MapInfo Professional works with existing SQLite databases. It cannot create a new SQLite database. You can open a 
table in a SQLite database and save your edits, and you can save your existing MapInfo tables to a SQLite database. 

To open one or more tables in a SQLite database:

1. Select File > Open.

2. From the Files of type list, select SQLite Database (*.sqlite).

3. From the Look in list, select the folder location of the SQLite database that you want to access.

4. From the files list, select the SQLite database to open.
To select more than one SQLite database file in the Open dialog box, press the Ctrl or Shift key while selecting 
files.

5. Click Open.
The Select One or More Tables to Open dialog box opens.

6. In the Database Tables list, select a table to open by adding a check mark beside the table name.
You can select one or more tables. Only the tables that have a check mark beside them will open.
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7. Optionally, select how you want the data to display on the map by selecting (highlighting) the table name and 
clicking Style.
This opens the Change Table Object Style dialog box where you can specify the display style for geometry (spatial 
object types), such as symbols, lines, and regions in the table. The custom styles that you set only apply to the 
table that you highlighted (whether it has a check mark beside it or not).
To select more than one table, press CTRL while selecting table names. Your style choices are made to all of the 
tables that you select (that are highlighted in the Database Tables list).

8. From the View list, select how you want to open the tables.
Select New Mapper or Current Mapper to open them in a Map window, or Brower to open them in a Browser 
window to see the table contents.

9. Click OK.

The table, or tables, from your selection open in MapInfo Professional.

If you choose to open more than one SQLite database (.sqlite file) in the Open dialog box, then each database opens 
a Select One or More Tables to Open dialog box. Repeat the previous steps for each database.

Applying Custom Options when Opening SQLite Database Tables

When opening a SQLite database table, as described under Opening SQLite Tables on page 2, you can select 
custom options for display styles, filters, and how to access the data (with live or linked access). The options you select 
are specific to how the table opens in MapInfo Professional, and they override any common options set for opening 
SQLite tables.

When working with a SQLite table in MapInfo Professional, you make display style changes on the map, but you 
cannot save these changes back to the SQLite table. The only way to set how SQLite table data displays on a MapInfo 
Professional map is to set custom display options when opening the SQLite table.

To apply custom options to a SQLite table, open the table by following the instructions under Opening SQLite Tables 
on page 2. Highlight the table name in the Select One or More Tables to Open dialog box and then click Style or 
Options. You can apply the following types of custom options to the table:

• To customize how the geometry (spatial object types, such as symbols, lines, and regions) in the table display on a 
map, click Style. This opens the Open DBMS Table Options dialog box where you can choose the display styles, 
such as: symbol type, color, and size, and label font; line color and pattern; region fill color and pattern, and border 
color and pattern.

• To set filters to fetch specific columns and rows from a table, click Options. This opens the Open DBMS Table 
Options dialog box where you can choose column and row filters on the table. Filters reduce the amount of 
information that you will work with and reduce the time it takes to fetch and save the data. For more information, 
see Opening SQLite Tables Using Column and Row Filters on page 4.

• To select how to access the table data, by using live access or linked access, click Options. This opens the Open 
DBMS Table Options dialog box where you can choose either Download Data (Linked Table) or Live Access. 
The selection you make here overrides any common options made for tables in the Select One or More Tables to 
Open dialog box. For information about the linked, live, and cached options, see Setting Live or Linked Access 
when Opening SQLite Tables on page 6.

You can apply custom options to multiple tables at the same time, by highlighting the table names in the Select One or 
More Tables to Open dialog box and then clicking Styles or Options. To select multiple tables, press CTRL while 
selecting table names. To select all of the tables, click Select All. 

After applying custom options to a table, the table name display an asterisk (*) beside it. When you move the mouse 
over the table name, it displays a summary of the custom options applied to it.

Changing the Folder Location of the MapInfo TAB File for a SQLite Database Table

When MapInfo Professional opens a SQLite database table for the first time, it creates a MapInfo TAB file (with the 
same name as the table) where it stores information about how to display the SQLite table. Any custom options you 
select when opening a SQLite table save to the TAB file. MapInfo Professional reads the TAB file every time you open 
the SQLite table and applies any custom options that you set for the table.
MapInfo Professional 11.5.2 New Feature Documentation 3



The TAB file for a SQLite table saves to the Windows %UserProfile%\My Documents folder. The %UserProfile% 
folder is set by default to:

Windows XP: C:\Documents and Settings\<username>
Windows 7, 2008: C:\Users\<username>

When opening a SQLite table, as described under Opening SQLite Tables on page 2, you can set where to save the 
TAB file for a table. To do this in the Select One or More Tables to Open dialog box, select the table name to highlight it 
and then click Folder. The Browse for Folder dialog box opens where you can browse for a new folder location to save 
the TAB file to. The new folder location displays under the Folder button in the Select One or More Tables to Open 
dialog box.

Mapping FDO (SQLite) Coordinate Systems to MapInfo Coordinate Systems

If MapInfo Professional has an issue identifying a coordinate system when it opens a table in a SQLite database, then 
it opens the Choose Projection dialog box. In this dialog box, you would associate a coordinate system with the table. 
MapInfo Professional then saves this information to the TAB file for the table and reads it every time you open the 
table.

For very experienced users who understand how to work with MapBasic strings and coordinate systems, there is an 
advanced customization option. When MapInfo Professional opens a SQLite table, it converts the SQLite coordinate 
system definition into a MapBasic CoordSys (coordinate system) string. MapInfo Professional installs with a file called 
MapInfoCoordinateSystemSet.xml where you can customize the translations from SQLite Well Known Text (WKT) 
coordinate system definitions to MapBasic CoordSys (coordinate system) strings and back. 

Opening SQLite Tables Using Column and Row Filters
You can apply column and row filters on a SQLite database table before opening it in MapInfo Professional. Filters let 
you choose which columns and rows to fetch from the data source. You would do this to reduce the amount of 
information that you will work with and reduce the time it takes to fetch and save the data.

To apply column and row filters on a SQLite table when opening it:

1. Select File > Open.

2. From the Files of type list, select SQLite Database (*.sqlite).

3. From the Look in list, select the folder location of the SQLite database that you want to access.

4. From the files list, select the SQLite database to open.

5. Click Open.
The Select One or More Tables to Open dialog box opens.

6. In the Database Tables list, select one or more tables to open.

7. Click Options.

8. In the Open DBMS Table Options dialog box, select Standard Mode and then click Column Filters.
The Column Picker dialog box opens. 

9. Choose which columns to fetch from the table and then click OK.
For information about setting column filters, see Setting the Column Filter.

10. Select Row Filter.

11. In the Row Picker dialog box, choose which rows to fetch from the table and then click OK.
For information about setting row filters, see Setting the Row Filter.

12. Click OK to close the Open DBMS Table Options dialog box.

13. From the View list, select how you want to open the tables.
Select New Mapper or Current Mapper to open them in a Map window, or Brower to open them in a Browser 
window to see the table contents.
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14. Click OK.

The table opens in MapInfo Professional with only the columns and rows that you selected to fetch.

To create your own table filter in standard SQL syntax, see Creating Your Own Table Filter on page 5.

Setting the Column Filter

Click Column Filter to specify the columns to download. The Column Picker dialog box opens. An asterisk (*) appears 
in the Selected list when you first open this dialog box. If you leave the asterisk, MapInfo Professional retrieves all the 
columns in the table from the remote database. Otherwise:

• Move the columns you want to display from the table from the Available group to the Selected group using the 
arrow buttons. The single arrow keys move one selected column at a time. The double arrow buttons move all the 
columns at once from one list to the other. You can also double click the column to move it from one list to another.

• Change the order of the selected columns in the Selected list by highlighting the column you want to move and 
clicking Up and Down until the column is positioned correctly.

Click OK to complete your selections. 

If the table is mappable, the Available list displays an additional column called OBJECT, which refers to the 
spatial column. You can select it to download spatial objects from the table.

Setting the Row Filter

Click Row Filter to select the row data that you want MapInfo Professional to download. The Row Picker dialog box 
opens. To retrieve all of the rows pertaining to the columns you selected, leave this dialog box as it is. Otherwise, 
select the column, operator, and value entries that match the data you want to retrieve from the selected table. 

• In the Column list, choose the column(s) from which you want to filter rows. (This is the same as specifying the 
WHERE clause in a SQL query.) If you are filtering rows for one column, select a column, operator, and value. If 
filtering rows on more than one column, select a column from the next drop-down list. This also activates the next 
row of fields for data entry.

• Use the Operator and Value boxes to choose how you would like to filter the rows. 

For assistance in completing these entries the way you want them, see Notes for Completing the Row Picker Query in 
the Help System.

Click OK when you have finished filtering the rows.

Creating Your Own Table Filter

To create your own filter when opening SQLite database tables, follow the instructions under Opening SQLite Tables 
Using Column and Row Filters on page 4 to open a SQLite database and view its tables in the Select One or More 
Tables to Open dialog box.

1. Select the table that you want to open from the list.

2. Click Options.
The Open DBMS Table Options dialog box opens.

3. Select Expert Mode. 

4. Click SQL View.
The SQL Query dialog box opens.

5. In the SQL Query field, enter your query in standard SQL syntax, or click Load and open a SQL Query (*.sql) file.
To type in multi-line formatted SQL do the following:
• To get a new line press Enter.
• To tab, press Ctrl Tab.
• To cut and paste from the clipboard, press Ctrl X to cut, Ctrl C to copy, and Ctrl V to paste.

6. Click OK to apply your query and close the dialog boxes.
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Setting Live or Linked Access when Opening SQLite Tables
When opening a SQLite database table, as described under Opening SQLite Tables on page 2, you can select the 
Live or Linked options in the Select One or More Tables to Open dialog box. By default, the table opens with live 
access with caching turned on, so that you access it directly from its source location with the additional speed that 
caching provides. To change how you access an already open table, you must close it and open it again. 

Working with Live Access SQLite Tables

By default, MapInfo Professional opens SQLite database tables using live access. A live connection to a SQLite table 
lets you read data from the SQLite database as required. This is helpful when sharing the data with another 
application, to ensure that you are always working with the latest updates.

You would consider choosing the Live option for accessing a table when:

• Reading and editing dynamically changing data.
• You want to maintain data security (the data must remain only in a single secure location).

For a full list of considerations, see Comparing and Contrasting Live and Linked Access to a Table in the MapInfo 
Professional Help System.

To improve the data access speed with live access tables, you can specify that data be locally cached. MapInfo 
Professional then reads the table data from the cache. The life of the cache is limited to the current session. Access 
time to data is faster, but you are not working with the most current version. The table refreshes when you zoom, pan, 
or select the table data in a Map window, or when you edit the data in a Browser window. 

Working with Linked Access SQLite Tables

You have the option to open a SQLite database table as a linked access table. A linked table is a MapInfo Professional 
table that is a replica of a table downloaded from a remote database and retains links to its remote database table. 
(The remote table is the SQLite database table.) When MapInfo Professional downloads a table, it copies the entire 
contents of the table to the local machine. Any changes you make to the copy can be committed to the SQLite 
database table at any time. Linked tables can be used stand-alone or remain linked to the original SQLite database. 
After editing data in a linked table, MapInfo Professional saves it to the SQLite database in a manner that resolves any 
multi-user editing conflicts. Saving the edits made to a linked table commits them to the SQLite database as well as to 
the linked table.

You would consider choosing the Linked option for accessing when:

• Using the table contents as backdrop display data, or data that does not change much. Linked tables are editable, 
as long as the base tables they are based on are editable.

• Tables are very large. As the data is entirely local, there is a one-time cost of downloading the data, but subsequent 
access is fast, comparable to native table access, since the user does not incur the cost of network traffic every 
time the data needs to be accessed for mapping, or for analysis.

Linked tables are limited to 2 GB per data file.

For a full list of considerations, see Comparing and Contrasting Live and Linked Access to a Table in the MapInfo 
Professional Help System.

Mapping FGF Objects in a SQLite Database to MapInfo Objects
The OSGeo FDO Data Access Technology stores geometry data to a SQLite database as FGF (Feature Geometry 
Format) objects. This section lists the object mappings between FGF (Feature Geometry Format) objects in a SQLite 
database to MapInfo objects. This information is helpful when creating object data that you plan to share with other 
applications, because it will help you understand how an object will be handled in another application.
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The mappings between FGF object types and MapInfo Object types are:

The mappings between MapInfo object types and FGF object types are:

Unsupported MapInfo objects are:

• P_NULL
• P_TEXT
• P_WINDOWPORT

FGF Object MapInfo Object

FGF_Geom_None P_NULL

FGF_Geom_Point P_POINT

FGF_Geom_MultiPoint P_MPOINT

FGF_Geom_LineString P_PLINE

FGF_Geom_MultiLineString P_PLINE with multiple parts

FGF_Geom_Polygon P_REGION with zero or more holes

FGF_Geom_MultiPolygon P_REGION with multiple parts, each with zero or more holes

FGF_Geom_MultiGeometry P_COLLECTION

FGF_Geom_CurveString P_PLINE

FGF_Geom_MultiCurveString P_PLINE with multiple parts

FGF_Geom_CurvePolygon P_REGION

FGF_Geom_MultiCurvePolygon P_REGION with multiple parts

MapInfo Object FGF Object

P_POINT FGF_Geom_Point

P_LINE FGF_Geom_LineString

P_ARC FGF_Geom_LineString

P_PLINE FGF_Geom_LineString or FGF_Geom_MultiLineString if multiple parts

P_REGION FGF_Geom_Polygon – One exterior polygon. If it has multiple parts then each part is 
defined in a ring.

FGF_Geom_MultiPolygon – More than one exterior polygon. If each exterior polygon 
has multiple parts then each part is defined in a ring

P_RECT FGF_Geom_Polygon

P_ROUNDRECT FGF_Geom_Polygon

P_ELLIPSE FGF_Geom_Polygon

P_MPOINT FGF_Geom_MultiPoint

P_COLLECTION FGF_Geom_MultiGeometry
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• P_PIECHART
• P_BARCHART

When creating arcs, ellipses, or rounded rectangles in MapInfo Professional and then saving them back to a SQLite 
table, you may be asked to convert them to supported FGF object types. The MapInfo objects convert from arc to 
polyline, ellipse to polygon, and rounded rectangle to polygon.

Using a MapInfo Map Catalog with a SQLite Database
MapInfo Professional opens SQLite database tables as mappable without requiring a MapInfo Map Catalog. With other 
types of databases, such as Oracle or SQL Server, MapInfo Professional stores information about spatial tables and 
views in the database in a special table. The table file is called MAPINFO_MAPCATALOG (the Map Catalog). MapInfo 
Professional does not need to do this with a SQLite database.

The only reason to create a Map Catalog with SQLite tables would be to store default information, such as view, style, 
and per row style. If you choose to create a Map Catalog, then it must be named MAPINFO_MAPCATALOG (all 
uppercase).

For instructions on how to create a Map Catalog, see Manually Creating a MapInfo_MapCatalog in the MapInfo 
Professional Help System.

Opening a Map Catalog Stored in a SQLite Database

MapInfo Professional treats the Map Catalog as a system table. To open a Map Catalog in MapInfo Professional, you 
must select to view system tables when opening a SQLite database. 

To open a Map Catalog in a SQLite database:

1. Select File > Open.
The Open dialog box opens.

2. From the Files of type list, select SQLite Database (*.sqlite).

3. From the Look in list, select the folder location of the SQLite database that you want to access.

4. From the files list, select the SQLite database to open.

5. Click Open.
The Select One or More Tables to Open dialog box opens.

6. Click Filter Tables.
The Filter Tables dialog box opens.

7. Select the System Tables check box and then click OK.

8. In the Database Tables list, select one or more tables to open.

9. From the View list, select how you want to open the tables.
Select New Mapper or Current Mapper to open them in a Map window, or Brower to open them in a Browser 
window to see the table contents.

10. Click OK.

How to Process Map Bounds for SQLite Database Tables Faster

MapInfo Professional calculates the map boundary for spatial data tables before displaying table data on a map. This 
calculation can be slow for large tables. Advanced users may want to improve table processing times by having 
MapInfo Professional use the FDO coordinate system information for map bounds instead of MapInfo Professional 
performing the calculation.
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MapInfo Professional saves a .TAB file the first time it opens a SQLite database table and stores default display 
settings and database connection settings to the .TAB file. MapInfo Professional then reads the TAB file every time it 
opens the SQLite table. The TAB file can be modified to specify whether to read map bounds from the FDO coordinate 
system information or from a Map Catalog that you create for your SQLite database. By default, these TAB files are 
saved to the %userprofile%\My Documents folder. The default location is:

Windows XP: C:\Documents and Settings\<username>\My Documents

Windows 7, 2008: C:\Users\<username>\My Documents

To have MapInfo Professional use the FDO coordinate system information for the map bounds for a SQLite table, open 
the corresponding TAB file in a text editor. Add UseCoordSysBounds=TRUE to the end of the following connection 
string using a semicolon ( ; ) as a separator:

"\DATALINK\ConnectionString" = "File=C:\Program 
Files\MapInfo\Data\SQLite\databasename.sqlite;PROVIDER=OSGeo.SQLite;UseFdoMetadata=TRU
E;UseCoordSysBounds=TRUE"

How to Override Using the Map Catalog

By default, MapInfo Professional uses a Map Catalog for the map bounds for a SQLite table if it is present in the 
database. To override this default, add UseMapCatalog=FALSE to the end of the following connection string using a 
semicolon ( ; ) as a separator:

"\DATALINK\ConnectionString" = "File=C:\Program 
Files\MapInfo\Data\SQLite\databasename.sqlite;PROVIDER=OSGeo.SQLite;UseFdoMetadata=TRU
E;UseMapCatalog=FALSE"

For information on how to create a Map Catalog for your SQLite database, see Manually Creating a MapInfo_
MapCatalog in the MapInfo Professional Help System.

Open Source Attribution Notice for FDO

FDO 3.7.0

This product contains FDO (Feature Data Objects), which is licensed under the Lesser General Public License (LGPL), 
©2012, Open Source Geospatial Foundation, All rights reserved. The license can be downloaded from http://
fdo.osgeo.org/lgpl.html. The source code for this software is available from http://fdo.osgeo.org/content/
downloads.

Sharing Data with other Applications
This section discusses how to work with data in MapInfo Professional that is shared by other users and applications in 
your organization.

• Sharing Data with Autodesk's AutoCAD Map 3D
• Sharing Custom Symbols with Other Applications

Sharing Data with Autodesk's AutoCAD Map 3D
MapInfo Professional works with data created in Autodesk's AutoCAD Map 3D and stored in SQLite or in Oracle. You 
can view this data in MapInfo Professional, save changes made to the data, and then continue to work on the data in 
Map 3D. However, there are considerations and limitations when reading and writing text layers created in Autodesk's 
AutoCAD Map 3D. 

For more information about Map 3D text layers, refer to the Map 3D product documentation.
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Accessing Map 3D Text Layers

Map 3D text layers must be stored either in SQLite or in Oracle. There is no support for reading text layers stored in 
other formats, such as SDF files. 

SQLite users:

To display a Map 3D text layer stored a SQLite database, you open it in MapInfo Professional like any other SQLite 
table. For instructions on how to open a table in a SQLite database, see Opening SQLite Tables on page 2. 

You do not require a MapInfo Map Catalog to open tables in a SQLite database. With other types of databases, 
such as Oracle or SQL Server, MapInfo Professional stores information about spatial tables and views in the 
database in a special table. MapInfo Professional opens SQLite tables as mappable without requiring a Map 
Catalog. For more information, see Using a MapInfo Map Catalog with a SQLite Database on page 8.

Oracle users:

To display a Map 3D text layer stored in Oracle, it must first be made mappable. For more information, see the section 
Making a DBMS Table Mappable to Display it on a Map in the MapInfo Professional Help System. For text layers 
stored in SQLite, this step is not necessary.

To open a text layer, first create a data source connection (see Creating a Data Source Connection in the MapInfo 
Professional Help System), and then select the text layer table you wish to open. MapInfo Professional recognizes the 
table as a text layer based upon the table structure. You do not need to indicate to MapInfo Professional that it is a text 
table.

Working with Map 3D Text Layers

When displaying a text layer in MapInfo Professional, MapInfo Professional uses default settings for text objects unless 
there is explicit formatting information for individual text objects (see Using a MapInfo Map Catalog with a SQLite 
Database on page 8). Note that the default settings in MapInfo Professional may differ from that in Map 3D. To change 
the MapInfo Professional text style defaults, select Options > Preferences > Styles > Text.

Support for Map 3D Text Formatting

MapInfo Professional supports both plain text and a limited subset of MText (AutoCAD multi-line text) formatting. 
Supported MText formatting includes font name, color, bold, italic, underline, and multi-line text. MapInfo Professional 
applies formatting to the entire text object. It does not support partial formatting of the text object. When editing a text 
object in MapInfo Professional and saving it back to the database, any existing formatting for that object is overwritten.

Limitations Working with Map 3D Text 

Not all of the style information associated with a Map 3D text layer is stored in the database tables. This includes the 
default style settings for the Map 3D feature class, as well as advanced functionality such as the use of expressions in 
the creation of the text object. As a result, the content and appearance of text layers in MapInfo Professional may differ 
considerably compared to the same layer in Map 3D. 

Viewing AutoCAD Text Object Columns in a Table

When MapInfo Professional finds the following columns in a SQLite or Oracle table, it recognizes that they contain data 
for AutoCAD Text Objects:

• FeatID
• Label_Text
• Geometry
• Size (Size1 for Oracle)
• Orientation
• Horizontal_Alignment
• Vertical_Alignment
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Map_3D stores text objects as point geometries and associated label text. MapInfo Professional converts the point 
geometries to text geometries and text specifications are read from the Label_Text, Size, Orientation, Vertical_
Alignment, and Horizontal_Alignment columns. MapInfo Professional assigns default font style preferences to the 
legend text unless there is specific formatting applied to the individual text objects.

MapInfo Professional processes the label text information, but does not let you work with the label text columns. Only 
the FeatID column is visible in a Browser window, and the label text and text specification columns are hidden. 

If an Oracle table includes ClassID and RevisionNumber columns, then these are hidden.

Sharing Custom Symbols with Other Applications
If you have symbols that are unique to your organization and you wish to share them with all MapInfo Professional 
users, you can either distribute the symbols to these users or share the symbol files in a workgroup directory. You may 
want to have your System Administrator assisting with this.

Considerations:

Your symbols must be raster files in one of the formats that MapInfo Professional supports. The most common formats 
are Graphics Interchange Format (.gif), Joint Photographic Experts Group (.jpeg), Portable Network Graphics (.png), 
Tagged Image File Format (.tiff), and Windows bitmap (.bmp). For a full list of supported formats, see File Format 
Types Supported in the MapInfo Professional Help System. Note that MapInfo Professional does not support Arc/Info 
Binary Grid format (*.adf).

MapInfo Professional imposes a limitation of 31 characters on the length of the file name for a custom symbol. 

Your symbol files must have unique names. If more than one symbol file has the same name, because the files are in 
different subfolders under the search location (a folder called CustSymb), then MapInfo Professional uses the first 
symbol file that it finds.

MapInfo Professional installs with symbols. The first time MapInfo Professional starts, it copies its CustSymb folder 
from its install location to under the user’s %appdata% folder and then searches the %appdata% location. (It does not 
search in the MapInfo Professional install location.)

Distributing Custom Symbols to MapInfo Professional Users

If you choose to distribute your organization’s custom symbols to all MapInfo Professional users, then have these 
users put the symbol files in to the directory named CustSymb located in their Application Data (%appdata%):

%appdata%\MapInfo\MapInfo\Professional\<versionum>\CustSymb

To determine your %appdata% folder location, from the Start menu select Run and in the Run dialog box type 
%appdata%.

You can organize the symbol files in to subdirectories under CustSymb and MapInfo Professional will search the 
subdirectories.

Symbol files must have unique names even if they are organized into subfolders under the CustSymb folder.

Sharing Custom Symbols in a Workgroup Directory

Before you begin, take note of the considerations outlined under Sharing Custom Symbols with Other 
Applications.

If you choose to use a MapInfo Professional network share workgroup, then add your organization’s custom symbols 
to the CustSymb folder located under the Application Data (%appdata%) folder of the workgroup. You would then 
point your MapInfo Professional installation to the workgroup directory. This is already setup correctly for you if you 
have a MapInfo Professional workgroup installation. If not, then see Pointing a MapInfo Professional Installation to 
the Workgroup Directory. For details about a workgroup installation, see the chapter titled Workgroup Installations in 
the MapInfo Professional Install Guide.
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You can organize your symbol files into subdirectories under the workgroup's CustSymb folder and MapInfo 
Professional will search the subdirectories. Symbol files must have unique names even if they are organized into 
subfolders under the CustSymb folder.

Pointing a MapInfo Professional Installation to the Workgroup Directory

To point a MapInfo Professional installation to the shared data files, such as custom symbols, located in a Workgroup 
folder:

1. Choose Options > Preferences > Directories.

2. In the Directory Preferences dialog box, in the Workgroup Directory pane, select the Use when searching for 

application data files check box and type the path, or click  to select the path, to the workgroup directory. 

You can use named drives or UNC paths in the Workgroup Directory field.

3. Click OK to confirm your change. The application saves this new path to your registry. Each time you open MapInfo 
Professional after this, the application uses this new path to access the Application Data Files.

To switch back to using your local files only and stop sharing common data files, such as symbols, repeat the above 
steps and clear the Use when searching for application data files check box.

Using Your Organization’s Symbols on a Map

To view and use your organization’s symbols on your map:

1. In the Map window, double click on a map symbol on your map. Or, instead of setting a per-object style, use a layer 
style override.

The map layer must be editable, which can be set in the Layer Control by clicking the Editable  icon for the 
map layer. 

2. In the Point Object dialog, click the symbol Style button.

3. In the Symbol Style dialog, from the Font drop-down list, select your custom symbols. From the list of available 
symbols, select one to view the symbol style.

Working with Web Feature Service (WFS) 1.1
MapInfo Professional 11.5.2 supports servers that work with version 1.1 of the Open Geospatial Consortium (OGC) 
Web Feature Service Interface Standard. A Web Feature Service (WFS) provides an interface allowing requests for 
geographical features across the web using platform-independent calls. 

The following sections describe situations and conditions to be aware of when working with a WFS 1.1 server.

• Applying a Coordinate Order Override to Correct how Objects Display on the Map
• Testing the Coordinate Order of a WFS Table
• Spatial Row Filters
• No Support for WFS-T with WFS 1.1
• How to determine which version of WFS you are using?
• Working with WFS Tables that have Nested Structures
• Setting the Number of Records (Features) that a WFS Server Returns

For more information about the Open Geospatial Consortium (OGC) and Web Feature Service Interface Standard, see 
http://www.opengeospatial.org.
MapInfo Professional 11.5.2 New Feature Documentation 12

http://www.opengeospatial.org


Applying a Coordinate Order Override to Correct how Objects Display on the Map
After creating a Web Feature Service (WFS) table, the geographic objects might not be located properly or rotated 90 
degrees due to the coordinate order. If this occurs, you can use MapInfo Professional to override coordinate order at 
either the server or table level when working with WFS 1.1 servers.

Server Override

If the coordinate order is incorrect for a WFS table retrieved from a server, then it may also be incorrect for other tables 
retrieved from that server. In this case, you can override the coordinate order at the server level.

Information about WFS servers is stored in a file called MIWFSServers.xml. By default this file is located in the 
%APPDATA%\MapInfo\MapInfo\Professional\1150 folder. More information on where this file is located can be 
found in Advanced Configuration Options for System Administrators in the MapInfo Professional Install Guide.

You can make changes to the XML file in an XML editor, and then restart MapInfo Professional to apply the changes.

In the MIWFSServers.xml file, each server specification begins with a <Server> node. This node will have child nodes 
for the URL <HTTP> and a description <Description>. There may also be other child nodes as well. To override the 
coordinate order for a server, you will add a new child node <OverrideCoordinateOrder> with the value true.

For example:

<Server>
   <HTTP>server URL</HTTP>
   <Description>server description</Description>
   <OverrideCoordinateOrder>true</OverrideCoordinateOrder>
</Server>

If you have a local copy of the table you can refresh it, or download the table again, to apply the coordinate order 
override.

Table Override

If the coordinate order is incorrect for only some tables retrieved from a server, you can apply a coordinate order 
override at the table level instead of at the server level. A clause has been added to the MapBasic WFS Refresh Table 
statement so you need not edit an XML file to apply the override. This command can be issued via the MapBasic 
window or can be included in a MapBasic application. The syntax is:

WFS Refresh Table alias [Override Coordinate Order { On | Off } ]

The new clause can be used in conjunction with other optional clauses on the WFS Refresh Table command, for 
example, the Using Map clause.

Testing the Coordinate Order of a WFS Table
Before applying any spatial filters, you can download a table to see if the data is in the correct coordinate order. If the 
data on the WFS server contains thousands of records, use the Max Features preference described under Setting the 
Number of Records (Features) that a WFS Server Returns to limit the number of records that the server returns. 
This lets you test a small subset of the data and avoid long download and processing times. If the coordinate order is 
incorrect, then use WFS Refresh Table to fetch the data switching the coordinate order.

Once you are happy with the coordinate order, select Table > WFS Table Properties and disable or change the Max 
Features value and add a spatial filter.
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Spatial Row Filters
One of the main purposes of spatial filtering is to limit the size of the data that the WFS server returns, because large 
amounts of data can take a long time to download and process. After downloading a smaller subset of data to MapInfo 
Professional, you can use a local query to obtain the exact subset of data you need.

MapInfo Professional sends spatial row filters with geometry to the server. If a server does not follow the OGC 
specification regarding coordinate order, then MapInfo Professional uses the overrides as discussed under Applying a 
Coordinate Order Override to Correct how Objects Display on the Map. When opening a table for the first time, 
MapInfo Professional uses any override that exists from the MIWFSServers.xml file for that server. If no Table XML file 
exists yet to retrieve an override from, then you can add the table override via the WFS Refresh Table command (as 
described under Applying a Coordinate Order Override to Correct how Objects Display on the Map).

When using a WFS 1.1 server, MapInfo Professional only supports the BBOX spatial filter (with WFS 1.0, it uses any 
filter). A WFS 1.1 server defines the types of GML (Geographic Markup Language) Geometry objects that it supports. 
That list is limited to a predefined subset of all GML Geometry types. The GML Geometry type that maps closest to 
MapInfo Professional’s region (MultiSurface) and polyline (MultiCurve) object type are not part of this predefined list, 
so MapInfo Professional uses the BBOX spatial filter.

The BBOX filter is useful with complicated spatial queries, such as when you want all of the data that is within a region. 
For this query, you would pick the region and do a BBOX filter. This returns data that is outside of the region, but it is 
less data then everything that is outside the region. When this data is in MapInfo Professional, you would then do a 
query to get everything that is inside the region.

There are no limitations for WFS 1.1 and non-spatial row filters.

No Support for WFS-T with WFS 1.1
There is no support for a Web Feature Service with transactions (WFS-T) within MapInfo Professional’s support for the 
Web Feature Service (WFS) 1.1. A WFS-T lets WFS clients apply edits (inserts, deletes, and updates) to the data in 
the source database through the WFS service. If you are using the WFS 1.1 protocol when communicating with a 
server, then you are unable to use a WFS-T.

For existing WFS-T users, MapInfo Professional continues to support WFS-T when using WFS 1.0. To set a 
preference to continue using WFS 1.0 and continue supporting WFS-T, do the following:

1. From the menu select Options > Preferences and click Web Services.

2. In the Web Services Preferences dialog box, select the WFS tab and then click Servers.

3. In the WFS Servers List, highlight the server you are working with (a checkmark displays beside the server name in 
the list) and then click Edit.

4. In the WFS Server Information dialog box, select Prefer Version 1.0.
Existing WFS-T users should choose Prefer Version 1.0 to continue to use WFS-T with the servers you are using.

5. Click OK to save this setting.

After selecting Prefer Version 1.0, MapInfo Professional communicates with the WFS server using WFS 1.0. If the 
server does not support 1.0, but does support other versions, then MapInfo Professional switches to another version 
that both the server and MapInfo Professional support (such as 1.1).

If you select the Automatic option instead of the Prefer Version 1.0 option, MapInfo Professional communicates with 
the server using the highest version of WFS that both MapInfo Professional and the server support.

How to determine which version of WFS you are using?
Since there is a version negotiation process between the Web Feature Service (WFS) server and MapInfo 
Professional, It is not always clear what version of WFS is in use with the server. To determine the WFS version in use: 

1. Select File > Open Web Service > Open WFS.

2. In the Open WFS Table dialog box, click Details.
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3. In the WFS Server Details dialog box, the Version section provides the version number of the WFS server.

The WFS Server Details dialog box provides information for the server URL location, name, and version number. If the 
server has an abstract, then there is also a brief description of the server’s purpose.

Working with WFS Tables that have Nested Structures
Web Feature Service (WFS) table definitions can contain nested structures. The following example shows a Parcel 
table that contains a column called Occupant.

Parcel Information Table
Street_Address
City
State
Zip_Code
Occupant

Person
Name_First
Name_Last
Age

The Occupant column refers to a structure or table called Person. The Person structure contains columns called 
First_Name, Last_Name, and Age. Depending on how the schema of the table is defined, the column (Occupant) 
can occur multiple times per row (record). To address nested structures, the column names in WFS tables may use 
delimiters (such as Occupant/Person/Name_First), and may be lengthy.

MapInfo Professional has limitations on column names: it truncates column names that are longer than 32 characters, 
and it does not support the back-slash ( / ) character in column names (so it would not recognize Occupant/Person/
Name_First as a valid column name). When MapInfo Professional encounters a WFS table with column names that 
conflict with these limitations, it uses the first and last names in the nested structure with a hash character (#) as a 
delimiter. As an example, MapInfo Professional creates the previous Parcel table with the following column names:

Street_Address
City
State
Zip_Code
Name_First#Occupant
Name_Last#Occupant
Age#Occupant

The hash character (#) in the column name indicates that it is a nested structure. If the data from the server contains 
more than one Occupant column per row, then MapInfo Professional brings in the last value it encounters.

MapInfo Professional ensures that all new column names are unique. If there are identical column names, then 
MapInfo Professional applies a numeric value as the last character of each of the identical column names (such as 
Age#Occupant1 and Age#Occupant2). 

MapInfo Professional converts any unrecognized characters in a column name to an underscore ( _ ).

The nested structure schema is more common among WFS 1.1 servers than WFS 1.0 servers. MapInfo Professional 
processes the schema for both WFS 1.0 and WFS 1.1, but only populates WFS 1.1 columns.
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Setting the Number of Records (Features) that a WFS Server Returns
A WFS server can limit the number of records it returns to a client (such as MapInfo Professional) by using a default 
setting called DefaultMaxFeatures. If a server does not limit the number of records it returns, so that it returns all of the 
records from a layer, then you can specify the number it returns.

You would consider limiting the number of records (features) to reduce the time it takes to download and display a table 
when a table is very large (and contains many features). This lets you quickly judge the value of the data. However, 
you cannot control which features are downloaded.

While the OGS WFS Specification mandates that WFS servers must support Max Features, some WFS servers 
do not seem to support it.

To specify the number of records that a WFS server returns:

1. Select File > Open Web Service > Open WFS. 
The Open WFS Table dialog box opens.

2. Select the server from the WFS Server drop-down list.
To add the server to the list, click Servers.

3. Select the Max Features check box and enter the number of records you want the server to return.
If the Max Features check box is disabled, then you cannot specify a Max Features value for this server. The WFS 
server has set the maximum number of records it will return and the field beside the check box shows the 
maximum number that the server has set.

4. In the WFS Layers list, select the layer you want to open.

5. Click OK.

Correcting the Display of Web Map Service (WMS) Images
After creating a Web Map Service (WFS) table, the map image might not display or might be in the wrong location and 
distorted due to the coordinate order in use by the server. Coordinate values are listed in the axis order as specified by 
the referenced coordinate reference system (CRS). However, not all servers follow the Open Geospatial Consortium 
(OGC) Web Map Service Interface Standard. As a result, coordinates for coordinate systems, such as latitude/
longitude systems, may be in reverse order from what is expected when retrieving or saving map images with a WMS 
server. If after creating a WMS table, the map image does not display or is in the wrong location and distorted, then you 
may need to override the coordinate order.

The following sections describe how to apply a coordinate order override and correct the display of WMS map images:

• Applying a Coordinate Order Override to a WMS Table or Server
• Testing the Coordinate Order of a WMS Table

For more information about the Open Geospatial Consortium (OGC) and Web Map Service Interface Standard, see 
http://www.opengeospatial.org.
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Applying a Coordinate Order Override to a WMS Table or Server
After creating a Web Map Service (WFS) table, the map image might not display or might be in the wrong location and 
distorted due to the coordinate order. If this occurs, you can use MapInfo Professional to override coordinate order at 
either the server or table level when working with WMS servers.

Server Override

If the coordinate order is incorrect for a WMS table retrieved from a server, then it may also be incorrect for other tables 
retrieved from that server. In this case, you can override the coordinate order at the server level.

Information about WMS servers is stored in a file called MIWMSServers.xml. By default this file is located in the 
%APPDATA%\MapInfo\MapInfo\Professional\1150 folder. More information on where this file is located can be 
found in Advanced Configuration Options for System Administrators in the MapInfo Professional Install Guide.

You can make changes to the XML file in an XML editor, and then restart MapInfo Professional to apply the changes.

In the MIWMSServers.xml file, each server specification begins with a <Server> node. This node will have child nodes 
for the URL <HTTP> and a description <Description>. There may also be other child nodes as well. To override the 
coordinate order for a server, you will add a new child node <OverrideCoordinateOrder> with the value true.

For example:

<Server>
   <HTTP>server URL</HTTP>
   <Description>server description</Description>
   <OverrideCoordinateOrder>true</OverrideCoordinateOrder>
</Server>

If you have a local copy of the table, download the table again to apply the coordinate order override. If you do not want 
to download the table again, you can use the Table Override described in the next section.

Table Override

If the coordinate order is incorrect for only some tables retrieved from a server, you can apply a coordinate order 
override at the table level instead of at the server level. When creating a WMS table you specify the name and location 
of the TAB file that contains some of the information about the table. Additional information is stored in an XML file with 
the same name and located in the same folder. You will need to edit this xml file.

The XML file for the WMS table has is a <SRS> node with a value of the coordinate system code for the table. To 
override the coordinate order for the table, you must add an OverrideCoordinateOrder attribute with a value of true to 
this node.

For example:

<SRS OverrideCoordinateOrder="true">EPSG:4326</SRS>

To have the coordinate override take effect after changing and saving the XML file, close and re-open the WMS table.

Testing the Coordinate Order of a WMS Table
You can check a WMS table to see if the data is in the correct coordinate order using the MapBasic TableInfo function. 
This function includes an attribute called TAB_INFO_OVERRIDE_COORDINATE_ORDER (43) that returns TRUE 
when the table is a WFS or WMS table with the coordinate order override turned on. This command can be issued via 
the MapBasic window or can be included in a MapBasic application.

The syntax is:

TableInfo(MyWMSTable, TAB_INFO_OVERRIDE_COORDINATE_ORDER)

Where MyWMSTable is the name of the table you are checking the coordinate order for.
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New Dialog Box Descriptions
The following are new or updated dialog boxes in the 11.5.2 release:

• Select One or More Tables to Open dialog box
• Select SQLite Database File dialog box
• WFS Server Information dialog box

Select One or More Tables to Open dialog box
In the Select One or More Table to Open dialog box, you can select the tables to open from a data source. The tables 
you select open with the options that you set in this dialog box; you can customize tables by picking column or row 
filters or to set a default display styles. When opening tables from a SQLite database that has no Map Catalog, setting 
the display style ensures that the table always opens with an appropriate style.

To access the Select One or More Tables to Open dialog box, select File > Open and then select SQLite Database 
(*.sqlite) from the Files of type list. Select a SQLite database from the list of files and click Open.

Database
Shows the name of the database for the connection that you selected in the Open dialog box.

Schema
Select a schema (owner) to display tables for. The Schema list only displays when the connection supports multiple 
schemas (owners).

Database Tables

Style
Opens the Change Table Object Style dialog box where you can specify the display style for geometry (spatial 
object types), such as symbols, lines, and regions, and for label text in the table.

Options
Opens the Open DBMS Table Options dialog box where you can apply column and row filters on the table. 
Filters let you choose which columns and rows to fetch from the data source. You would do this to reduce the 
amount of information that you will work with and reduce the time it takes to fetch and save the data.

Select All
Select all the tables in the table list.

Unselect All
Clear all table selections from the table list.

Filter Tables
Select which types of tables appear in the table list.

Common Options
The common options apply to all selected tables, unless a table has been customized to use different options.

Linked
Select to use as a linked table. A linked table is a special kind of MapInfo table that is downloaded from a 
remote database and retains connections to its remote database table. You can perform most operations on a 
linked table that you do for a regular MapInfo table.

Live
Select to access the table directly from its source location.

Cached
This option enables after selecting the Live option. Select to save the table to the local buffer and then read the 
table data from the buffer. Access time to data is faster but you are not working with the most current version. 
Refresh occurs when you zoom, pan, or select.

Unselect to read the table directly from the data source, which is the current version.
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Read Only
Opens the table in read-only mode. You are unable to edit the table and you cannot save the table back to the 
database.

Folder
This option enables after selecting the Linked option. Select to save the linked table to a specific location on 
your machine. Selecting this opens the Browse for Folder dialog box, where you can select a folder to save the 
linked file to.

View
MapInfo Professional displays your data in a window based on your selection. If you select Automatic, MapInfo 
Professional picks the window that is most appropriate for your data. MapInfo Professional remembers your selection 
and uses it for every subsequent selection until you change it.

OK
Accept dialog box options.

Cancel
Cancels selections and closes the dialog box.

Select SQLite Database File dialog box
You can select which SQLite databases to open in the Select SQLite Database File dialog box. To select more than 
one SQLite database file, press the Ctrl or Shift key while selecting files. To access the Select SQLite Database File 
dialog box, select File > Open DBMS Connection, select FDO (SQLite) from the list, and then click New.

Look in
Lists the available folders and files. To see how the current folder fits in the hierarchy on your computer, click the down 
arrow. To see what's inside a folder, click it.

Go To Last Folder Visited button
Displays the directory that you last visited.

Up One Level button
Displays the directory one level up form the current directory.

Create New Folder button
Displays a new folder with a temporary name.

View Menu button
Lists view options for the files in the list, so you can view the list as Thumbnails, Tiles, Icons, List, or by Details. List 
displays the list of files and folders without details, such as file size. Details displays the list of files and folders with 
details, such as name, size, type, and modified date.

Description Box
This shows the folders and files in the selected location. You can also double-click a folder or file in that box to open it.

Places Bar
The four buttons on the MapInfo Places Bar are associated with the following directory preferences: Tables, Remote 
Tables, Import Files, and Workspaces. Pressing one of these buttons switches the current directory of the dialog box to 
the directory associated with the button.

By default, MapInfo Places Bar is always displayed, even where there is no standard Places Bar. On systems that 
support a standard Places Bar, a set of option buttons, labeled MapInfo Places and Standard Places, allows you to 
toggle between the two.

File name:
Provides a space for you to type the name of the file. You can use * as a wildcard. For example, you can type *.* to see 
a list of all files. You can also type the full path of a file. For example, you can type C:\mymaps\landuse.sqlite.
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Files of type:
This is useful for narrowing the list of files displayed to only those files you're interested in. The tables that display are 
tables in MapInfo format or non-MapInfo files that have previously been opened in MapInfo Professional. Select the 
SQLite Database (*.sqlite) file format.

Open
Opens the file with the name, file type, and location you specified.

Cancel
Closes this dialog box without saving any changes you have made. 

WFS Server Information dialog box
You can add and edit WFS Server information in the WFS Server Information dialog box, which includes new options 
for version negotiation. To access the WFS Server Information dialog box, select Table > WFS Table Properties and 
click Server. 

Version Negotiation
If you are using the WFS 1.1 protocol when communicating with a server, then you are unable to use WFS-T. To work 
with WFS-T, you must select the Prefer Version 1.0 preference and work with WFS 1.0.

Automatic
MapInfo Professional communicates with the WFS server using the highest version of WFS that both MapInfo 
Professional and the server support.

Prefer Version 1.0
MapInfo Professional communicates with the WFS server using WFS 1.0. If the server does not support 1.0, 
but does support other versions, then MapInfo Professional switches to another version that both the server 
and MapInfo Professional support (such as 1.1).
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