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MapInfo Professional 10.5.2 
Release Notes

This document provides information on new and enhanced features that have been introduced 
into MapInfo Professional since version 10.5. It also contains sections on resolved customer 
issues and some remaining known issues that are important for users to be aware of.
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Upgrading MapInfo Professional
Your computer must be connected to the Internet to download the 10.5.2 
Maintenance Release.

You may install this Maintenance Release provided one of the following products 
is already installed:

• MapInfo Professional 10.5 or 10.5.1
• MapInfo Professional Runtime 10.5 or 10.5.1

If you have more than one of these products installed, the installer will upgrade 
them at the same time. You do not need to run this installer multiple times. 

To upgrade MapInfo Professional to version 10.5.2 Maintenance Release:

1. Create a temporary folder on your hard drive, such as C:\temp\mipro1052.

2. From the MapInfo Professional Main menu, select Help > Check for Update. 
The Maintenance Releases for MapInfo Professional web page displays.

3. On the web page, click the download link to display the File Download dialog 
box.

4. Choose the Save button and save the file to the temporary folder you created 
in step 2.

5. After the download is complete, double-click the executable file called 
MapInfoProfessional10.5.2MaintenanceRelease.exe to start the installation 
process. Follow the instructions to complete the upgrade. 

It is important to wait until the installation completes. It may take some time.

http://www.pbinsight.com
http://www.pbinsight.ca
http://www.pbinsight.co.uk
http://www.mapinfo.com.au


64-bit Editions of Office 2010
Microsoft recommends installing a 32-bit version of Microsoft Office when you are dependent on using 32-bit 
applications that interact with Office. In this case, MapInfo Professional is 32-bit application that requires 32-bit drivers 
to work with Microsoft Office data, such as Access and Excel.

Microsoft offers detailed information at http://technet.microsoft.com/en-us/library/ee681792.aspx. This web posting 
includes the following recommendations for which edition of Office 2010 to install:

• If users in your organization depend on existing extensions to Office, such as ActiveX controls, third-party add-ins, 
in-house solutions built on previous versions of Office, or 32-bit versions of programs that interface directly with 
Office, we recommend that you install 32-bit Office 2010 (the default installation) on computers that are running 
both 32-bit and 64-bit supported Windows operating systems. 

• If some users in your organization are Excel expert users who work with Excel spreadsheets that are larger than 2 
gigabytes (GB), they can install the 64-bit edition of Office 2010. In addition, if you have in-house solution 
developers, we recommend that those developers have access to the 64-bit edition of Office 2010 so that they can 
test and update your in-house solutions on the 64-bit edition of Office 2010.

If you already have the 64-bit Microsoft Office driver installed, then MapInfo Professional 10.5.2 uses the Microsoft 
Office 2007 32-bit driver installed with MapInfo Professional 10.5. You can still work with Microsoft Access and Excel 
2010, but you may see an error message if an incompatibility occurs.

If you want to install an Office 64-bit application after installing MapInfo Professional 10.5.2, you must remove the 2010 
Access database engine that was installed with MapInfo Professional 10.5.2. Follow the instructions provided in the 
error message that you see from Microsoft:

To install the 64-bit Office 2010 application and then install the 32-bit Office 2007 driver:

1. From the Start menu, select Control Panel and then depending on your operating system select Add or Remove 
Programs or Programs and Features.

2. From the list, select the Microsoft Access Database Engine 2010 driver and click Remove.

3. Install the 64-bit Office 2010 application on your computer.

4. Install the 32-bit Office 2007 driver on your computer. 
You can downloaded this driver from: http://www.microsoft.com/downloads/en/
details.aspx?familyid=7554f536-8c28-4598-9b72-ef94e038c891&displaylang=en

You can now open all versions of Access and Excel files until version 2007 (Office 12) without issue. You can still work 
with Access and Excel 2010 files, but you may see an error message if an incompatibility occurs.

Setup Error

You cannot install the 64-bit version of Office 2010, because you have 32-bit Office 
products installed. These 32-bit products are not supported with 64-bit installations:

Microsoft Access database engine 2010 (English)

If you want to install 64-bit Office 2010, you must uninstall all 32-bit Office products first, 
and then run setup.exe in the x64 folder. If you want to install 32-bit Office 2010, close 
this Setup program and either go to the x86 folder at the root of your CD or DVD and run 
setup.exe, or get the 32-bit Office 2010 from the same place you purchased 64-bit 
Office 2010.
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Advanced Installation for System Administrators
This section is for the system administrator installing this Maintenance Release using a commandline, and the network 
system administrator installing this Maintenance Release across the network using a Microsoft Patch (MSP) file.

Upgrading in Silent Mode
To run the MapInfo Professional Maintenance Release installer in silent mode, from a command prompt, type:

MapInfoProfessional10.5.2MaintenanceRelease.exe /s /v"SILINST=True"

Where:

/s = runs the setup.exe silently

/v = passes the parameter "" into the setup.exe to suppress the GUI.

A progress dialog may display during the installation. 

Vista and Windows 7 users may see a prompt for permission to continue. Click OK to proceed. 

Upgrading Using a MSP File
The MapInfo Professional Maintenance Release installer MSP file updates the English version of MapInfo Professional 
10.5 or 10.5.1. It does not update MapInfo Professional Runtime, or the MapInfo PDF Printer. It does not install the 
Microsoft Office 2010 driver, which you must install separately and before upgrading MapInfo Professional.

Before you begin, you will need:

1. The MSP file, which is available on request from Technical Support, see http://www.pbinsight.com/support/
contact-support.

2. The Microsoft Access 2010 database engine (32 bit version), which is available for download from Microsoft at:
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=c06b8369-60dd-4b64-a44b-
84b371ede16d&displaylang=en

On Vista and Windows 7, install this Maintenance Release with elevated privileges. To do this, right-click on the 
Command-Line Interpreter (cmd.exe) and select Run as Administrator from the popup menu, then continue with the 
following instructions.

Install the Microsoft Office 2010 Driver

To install the Microsoft Office 2010 driver:

1. Close MapInfo Professional.

2. Install the Microsoft Access 2010 database engine (32 bit version).

3. Restart MapInfo Professional to have the change take effect.

Close MapInfo Professional and continue with the upgrade.

Upgrading MapInfo Professional 10.5 software

To run the Maintenance Release installer MSP file, type:

msiexec /p <path to the MapInfoProfessional10.5.2MaintenanceRelease.msp file> 
REINSTALL=ALL REINSTALLMODE=omus 

Where:
/p = path to the MapinfoProfessional10.5.2MaintenanceRelease.msp file (include file name in path)

On Vista and Windows 7, a prompt for permission to continue displays. Click Allow or Yes to proceed (if you do 
not respond and the message times-out, then the upgrade is unsuccessful).
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You can upgrade silently by adding a silent parameter switch to the command, such as /qb, /qn, /qr, or /q. For example:

msiexec /p <path to the MapInfoProfessional10.5.2MaintenanceRelease.msp file> /qb 
REINSTALL=ALL REINSTALLMODE=omus 

Where:
/qb = to see a progress dialog at the end of the installation

MapInfo Professional 10.5.2 Release Notes
MapInfo Professional 10.5.2 is a cumulative update that includes everything that was updated with 10.5.1 plus 
additional fixes. This section describes these additional fixes..

Opening 10.5.1 Workspaces that contain only Microsoft Access Files
Workspaces saved in MapInfo Professional 10.5.1 that only contain Microsoft Access files (*.mdb only) do not open in 
MapInfo Professional 10.5.2, because they were saved with a truncated Open Table command.

To open this workspace in MapInfo Professional 10.5.2, do the following:

1. Open your 10.5.1 workspace file in a text editor. 

2. Search for the statement beginning with “n Table”. It is located immediately after a version statement.

3. Replace “n Table” with “Open Table”.

4. Save the file.

The workspace now opens in MapInfo Professional 10.5.2.

MapInfo Professional 10.5.1 Release Notes
MapInfo Professional 10.5.2 is a cumulative update that includes everything that was updated with 10.5.1 plus 
additional fixes. This section describes the updates included from 10.5.1.

If you have already installed the 10.5.1 update, then this 10.5.2 update adds the fixes described under MapInfo 
Professional 10.5.2 Release Notes on page 4 to your installation.

Support for Microsoft Office 2010
MapInfo Professional now supports Microsoft Access and Excel 2010 formats. The minimum operating systems and 
patches that support this driver are:

• Windows XP Professional Service Pack 3
• Windows Vista Service Pack 1
• Windows 7
• Windows 2008 Server R2, Windows 2008 Server Service Pack 2

Issue Number Description and Resolution

MIPRO-13362 MapInfo Professional 10.5.1 is not saving workspaces properly with Access tables that are pre-version 2007; the 
open table statement is truncated.

Resolution: Fixed. Workspace version is no longer dependent upon the tab versions of Access and Excel tables, 
so that versions do not upgrade to 10.5 for workspaces created with Access or Excel 2010 tables in MapInfo 
Professional 10.5.
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Check the MapInfo Professional Install Guide for a list of operating systems an patches that MapInfo Professional 
supports.

Microsoft Warning for 64-Bit Version of Office

If you do not have Microsoft Office installed on your machine, then MapInfo Professional 10.5.1 installs a Microsoft 
Office 2010 32-bit driver, so that MapInfo Professional can open Microsoft Access and Excel 2010 files.

If you already have the 64-bit Microsoft Office driver installed, then MapInfo Professional uses the Microsoft Office 
2007 32-bit driver that installed with MapInfo Professional 10.5. You can still work with Microsoft Access and Excel 
2010, but you may see an error message if an incompatibility occurs. 

Microsoft strongly recommends using the 32-bit (x86) versions of Office 2010, Project 2010, Visio 2010, and 
SharePoint Designer 2010 applications as the default option for all platforms (including on a 64-bit operating 
system). 

Refer to MapInfo Professional 10.5.2 Release Notes on page 4 for more details.

Performance Improvements Accessing DBMS Tables
This update improves performance when accessing remote databases:

• SQL Server 2008 users will see a dramatic improvement when accessing large tables, because MapInfo 
Professional now automatically uses the Multiple Active Result Sets (MARS) connection with SQL Server tables.

• Save Copy As is now 2-3 times faster when you save tables as PostGIS tables and 20 times faster when you save 
as SQL Server tables.

• Operations that use the cache, such as Find and creating or modifying a thematic map, have a significant 
performance gain on large data sets that have more than several thousand records. These operations could be 2-3 
times faster on first use, even though data needs to be cached, and as fast as working with a native table on 
subsequent use.

Database performance depends upon a number of factors, such as server capacity, data bandwidth, and size of data 
being retrieved. 

Accessing Large DBMS Tables Live with Cache

When you access large DBMS live with CACHE ON, MapInfo Professional stores the data in a progressive way (the 
contents of the cache grow as you zoom and pan the map). MapInfo Professional 10.5 closes unexpectedly when 
cache files exceeded the 2 GB system limit.

Prior to this release, MapInfo Professional used to close unexpectedly when one of the data files reached the limit of 2 
GB. This MapInfo Professional update handles many of these cases to switch seamlessly to "live without cache" 
mode. However, in some cases it may still close unexpectedly when the file limit is reached.  If this happens, you can 
work around it by:

• Closing and reopening the table.
• Restarting MapInfo Professional to clear the cache when panning and zooming a large table.
• Dividing the table you are working with, to make smaller tables.
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Progress of Outstanding Issues
The following issues have been corrected for this maintenance release of MapInfo Professional.

Issue Number Description and Resolution

C15857 Raster Overrides for a Tile Server layer are applied to a new Mapper window.

Resolution: Fixed.

IN15122 MapInfo Professional closes unexpectedly when working with a thematic after recalculating ranges using a 
Quantile method for Date and Time values.

Resolution: Fixed.

S10044  When zooming in on a map, translucency disappears when the Statistics window covers Layout Frames.

Resolution: Fixed.

S10045 Printing with PrintOSBM enabled in the registry produces thin polylines that appear very faint as a result.

Resolution: Fixed. When printing using PrintOSBM method, one pixel lines now scale up to the correct size. 
Previously, one pixel lines would display very faintly, because they were very thin.

S10058 Layout templates are not creating a frame when a Dynamic Scale bar exists in the Map window.

Resolution: Fixed.

T21005 A workspace read error occurs when saving a thematic map that is based on a Query table as Base or Join table.

Resolution: Fixed. MapInfo Professional now writes dynamically added columns to the workspace when the 
columns are in query tables.

T26821 The Info Tool fails to return a complete set of results.

Resolution: Fixed.

T28001 The Layout Templates tool is looking for the TEMPLATE.TAB file in the wrong place.

Resolution: Fixed.

T28396 The Update Column statement updates the whole column when the ending double quotes are missing.

Resolution: Fixed. When the closing end quote was missing in the command, MapInfo Professional would 
generate a warning and execute the command. Now MapInfo Professional generates an error and does not 
execute the command.

T28434 MapInfo Professional does not open GeoTIFF correctly, it displays in grayscale when it should be in color.

Resolution: Fixed. A provision was added to MapInfo Professional to check a GeoTIFF file to determine if it is in 
RGB or Grayscale and then display it accordingly.

T28782 Message window text truncated when saving a Layout window as an image.

Resolution: Fixed.

T28854 After enabling enhanced rendering, points that are placed on top of a grid file shift. This happens when zooming 
in very close on a raster image, which would cause each raster image pixel to display at a larger size.

Resolution: Fixed. 

T29236 The map does not display after turning on clip region while Enhanced Rendering is set to on.

Resolution: Fixed. Internally, Polygon Mode is now set to off when creating polygons for clip regions. When 
polygon mode was set to on, it could create polygons that do not convert to a clip region, which would then cause 
the entire map to display blank.
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T29238 Object selection is not rendered correctly on a screen. When an object is unselected edit handles are drawn 
around it.

This issue occurs when copying and pasting an object from an editable layer that has Enhanced Rendering set to 
off and the layer has a theme with Replace Layer Style turned on. As a result, the edit handles are not drawn. 
Changing the selection may cause the edit handles to appear or disappear at the wrong time.

Resolution: Fixed.

T29315 Opening a MBX through a hotlink is slower on VISTA than on Microsoft XP.

Resolution: Fixed. This fix also improves the speed of opening a .TAB or a .WOR file through a hotlink on XP.

T29457 Selecting Save Window As with a custom size does not resize all layers or features. As a result, exporting a map 
to smaller size with symbols in it does not resize the symbols.

Resolution: Works as designed. This behavior is by design, so that symbols do not go away when resizing a 
map window, zooming out of a map, or saving a map to a bitmap after making it smaller. This issue will be 
considered as a new feature request.

T29591 MapInfo Professional does not recognize the default Find symbol after changing it to something else.

Resolution: Fixed.

T29738 When displaying a thematic layer on the map, a node may not display on the map after moving it.

This issue occurs when drawing selected, editable, objects while Enhanced Rendering is off and the object is 
from a layer that has a theme using Replace Layer Style. Edit handles and/or reshape nodes may not draw at the 
correct time, making them appear at the wrong time or not appear when they should be shown. Moving a node 
causes reshaped nodes to disappear.

Resolution: Fixed.

T29744 Saving/Removing the default theme view does not store the change when applied through the Layer Control.

Resolution: Fixed.

T29745 Nodes persist in the Thematic layer after removing them in the underlying layer.

This issue occurs when displaying nodes for a layer that has a theme associated with it and the theme uses 
Replace Layer Style on. Toggling Show Nodes for a layer on/off may result in either nodes displaying when they 
should not or not displaying when they should.

Resolution: Fixed.

T29766 Grid layers misalign in a Map window with translucency set to on.

Resolution: Fixed.

T29769, 
T29783

Reshape feature does not show region nodes correctly.

Resolution: Fixed.

T29806  The Layout Templates tool generates an error message of "Found [] while searching for [bounds]”

Resolution: Fixed. There was an issue with how MapInfo Professional would detect the type of coordinate 
system as NonEarth.

T29850 After making changes and then clicking the Cancel button in the Layer Properties dialog box, style overrides for a 
Tile Server layer do not revert back to their original style.

Resolution: Fixed.

Issue Number Description and Resolution
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Progress of Outstanding Issues: Layer Control

T30106 Docking tool bars and the Layer Control window affects Window positions.

Resolution: Fixed.

T30107 The label placement control for Label Display does not highlight the selected button.

Resolution: Fixed.

T30135 Aggregate queries do not appear in the Table List window.

Resolution: Fixed.

T30187 Setting the Background checkbox and setting the region style color for new objects did not reflect correctly in the 
draw operations. Also, after selecting the Background check box and then reopening the Region Style dialog box, 
the Background check box was not checked. 

Resolution: Fixed. 

T30245 When combining objects in the same table, the resulting combined object does not have the same style as either 
of the objects being combined. Instead, the combined object uses the default style.

Resolution: Fixed. 

U11716 MapInfo Professional closes unexpectedly when saving a file to a full disk.

Resolution: Fixed. MapInfo Professional now halts the procedure and displays an error message when the disk 
is full.

Issue Number Description and Resolution

IN15542 MapInfo Professional closes unexpectedly after double-clicking a thematic layer in the Layer Control.

Resolution: Fixed.

T29416 Selecting several group layers in the Layer Control list and then right-clicking displays the pop-up (context) menu 
for a layer not for a group layer.

Resolution: Fixed. The current release does not have context menu options that work on multiple group layers 
so, the correct context menu displays, but its options are disabled.

T29710 In the Layer Control window, raster translucency does not persist when style override is is turned off and then 
turned on.

Resolution: Fixed.

T30190 In the Layer Control, a legend does not retain the information set after toggling the layer display off and on with a 
grid thematic.

Resolution: Fixed.

T30260 Opening a region table does not display it in the map window if there is a group layer in the Layer Control. 

This is due to a map redraw issue.

Resolution: Fixed.

Issue Number Description and Resolution
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Progress of Outstanding Issues: Accessing DBMS Tables and Web Services

Issue Number Description and Resolution

C15868 Some polygons appear to be missing  after opening a SQL Server 2008 or Oracle table with Live Cache set to 
ON. This is occurs when panning and zooming a table that is open with a small default view.

Resolution: Fixed. 

MIPRO-12339 When accessing a Web Map Service (WMS) GetFeatureInfo returns incorrect results when raster re-projection is 
set on.

Resolution: Fixed.

MIPRO-12594 When accessing a Web Map Service (WMS) the CentrusWMS layer and Bing maps do not line up. Everything 
lines up when using a WMS server with vector street data, but there is a shift between aerial imagery and parcel 
data after adding a Bing layer.

Resolution: Fixed.

T29409 Live access from SQL Server 2008 is slow with a large table.

Resolution: Fixed. To improve performance, the MARS connection setting is set to yes by default for all SQL 
Server Spatial 2008 connections. MapInfo Professional sets this when opening a new linked or live SQL Server 
Table. The setting is written to existing tab files when re-saving to the disk.

1) A MARS connection does not work for SpatialWare tables—a connection that opens a SpatialWare 
table does not set MARS connections. 2) A MARS connection setting is only valid for SQL Native Client or 
SQL Server Native Client 10 ODBC drivers. 

T29547 Save Copy As is very slow when uploading a table of 100K records of Points to either SQL Server 2008 or 
POSTGIS.

Resolution: Fixed. Save Copy As performance is dramatically improved: for an 8K table it may be five to eight 
times faster to upload to SQL Server 2008 and two times faster to upload to PostGIS.

T30188 WFS-T Integer values with more than four digits truncate to four digits when making insert and update 
transactions to a WFS-T server.

Resolution: Fixed.

T30191 MapInfo Professional may close unexpectedly during a Web Feature Server (WFS) refresh when the WFS 
Preference Update Mapper Filters With Current Mapper is checked, a Mapper is present, and the name of the 
WFS table being refreshed is greater than 22 characters in length.

Resolution: Fixed.

T30201 After reverting changes made to a Web Feature Service table (WFS-T), you can no longer edit the table—it is 
locked in read-only mode.

Resolution: Fixed.
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Progress of Outstanding Issues: Labels and Styles

Issue Number Description and Resolution

IN14229 When creating new custom symbols with a specific style and then changing that style to create additional custom 
symbols the style icon displays blank in the Insert Style dialog (in the Layer Control click the Properties button 
and then in the Layer Properties dialog, click the Styles for New Objects button).

Resolution: Fixed.

IN14689 Text style does not handle double byte characters and they display as garbled.

Resolution: Fixed. MapInfo Professional now supports double byte languages with Expanded and All Caps 
styles.

MIPro-12609 It is difficult to select and edit labels on the map when the map is also in a Layout.

Resolution: Fixed. The label override logic was too aggressive in determining whether there were changes to 
overrides and was clearing the label cache when it didn't need to.

T27737 Labels from offscreen objects overlap other objects.

When an object is not visible in a map but its bounding box overlaps the map, then MapInfo Professional 
sometimes snaps the autolabel to a different visible object. This creates the appearance of overlapping labels.

Resolution: Fixed in version 10.5 and tested in version 10.5.1.

T29256 There is a label position issue with “Label partial objects'”. When an object is off-screen, but it's minimum 
bounding rectangle (MBR) still overlaps with current view, then its label may drawn at a random position.

Resolution: Fixed. MapInfo Professional now draws the label at the centroid.

T29708 Turning off style override for a raster layer causes the layer to improperly redraw styles.

Resolution: Fixed.

T30207 Object labels that have a halo appear very grainy after turning on Enhanced Rendering.

Resolution: Works as designed. Labels and text objects drawn with Enhanced Rendering set to on may appear 
grainy or rough especially if text displays with a halo. For best results when using Enhanced Rendering, select 
Map > Options from the menu and set the Smooth Text & Labels option to Anti-Alias. To save this setting as a 
preference, select Options > Preferences > Styles.

T30211 Translucent labels appear grainy, or rough, after applying the halo text style to it.

Resolution: Fixed.
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Progress of Outstanding Issues: Tools

Progress of Outstanding Issues: MapBasic

Known Issues

MapInfo Error: Microsoft Jet Engine is not available...

The MapInfo Professional 10.5.1 .msp file does not install the Microsoft Office 2010 driver. If you run the .msp on 
MapInfo Professional 10.5 and do not run the Microsoft Office 2010 driver afterwards, you may see a message stating 
that the Microsoft Jet Engine is not available:

To correct this:

1. Close MapInfo Professional.

2. Install the Microsoft Access 2010 database engine (32 bit version), which is available for download from Microsoft 
at:
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=c06b8369-60dd-4b64-a44b-
84b371ede16d&displaylang=en

3. Restart MapInfo Professional to have the change take effect.

Microsoft Access Error: Unrecognized database format

MapInfo Professional 10.5.1 may not recognize the Microsoft Access 2010 (14.0) format and display an error 
message:

Microsoft Access Error: Unrecognized database format.

Issue Number Description and Resolution

IN15425 When working with the GELink tool, zooming out from a vector map and then exporting it to Google Earth as 
raster (as a KML image) does not open the map at its correct position in Google Earth.

Resolution: Fixed. If zooming or panning beyond the Earth bounds, the exported KML image was not correct. 
Now, if the coordinates coincides with World bounds, then MapInfo Professional temporarily zooms the entire 
map before exporting the image. Otherwise, it exports the existing image.

The GELink tool is available after selecting Tools > Tool Manager and then checking the GELink checkbox. To 
work with the North Arrow tool, select Tools > GELink.

T29365 When using the North Arrow tool, its brush style inherits the pen style choice set in the Region Style dialog box 
(available from the Options menu by selecting Region Style).

Resolution: Not reproducible.

The North Arrow tool is available after selecting Tools > Tool Manager and then checking the North Arrow 
checkbox. To work with the North Arrow tool, select Tools > North Arrow.

T29382 Objects are not exporting width in pixels to points properly as supported by Google Earth.

Resolution: Fixed.

Issue Number Description and Resolution

MIPRO-12525 Toolbar jumps after an MBX error.

Resolution: Fixed. Toolbar position and state does not change.
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This may occur if Microsoft Office 2010 was installed on your computer first and then MapInfo Professional 10.5 was 
installed, which also installs a Microsoft Office 2007 driver. In this case, the MapInfo Professional 10.5.1 Maintenance 
Release does not install a Microsoft Office 2010 driver, because one is already detected in the system registry. 
Microsoft Office 2007 and 2010 drivers share the same GUID interface, so whichever driver is installed later is the one 
an application uses to open Microsoft Office files. As a result, MapInfo Professional 10.5.1 uses the Microsoft Office 
2007 driver to open Access files and is unable to read Access 2010 (version 14.0) files even though the Microsoft 
Office 2010 driver is installed on your machine.

If you see this error message, repair your Microsoft Office 2010 driver installation by doing either of the following:

• Running the Microsoft Access 2010 application. If the Microsoft Office 2010 Suite is installed on your computer, it 
will repair and run the Microsoft Access 2010 database engine.

• Reinstalling the Microsoft Access 2010 database engine (32 bit version), which is available for download from 
Microsoft at:
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=c06b8369-60dd-4b64-a44b-
84b371ede16d&displaylang=en

Restart MapInfo Professional to have the change take effect.

Microsoft Access Calculated Field Data Type has Read Only Support

Microsoft Access 2010 introduces a new Calculated field data type that depends in some part on the entries in the 
permanent fields; it generates the information you require at run time.

MapInfo Professional 10.5.1 reads and displays Calculated field values correctly, but is unable to create or save the 
Calculated field data type.

Microsoft .NET 3.5 Leaves Temporary Files after Installing

The Microsoft .NET 3.5 install wizard may not remove all of its temporary files after the installation completes. This is a 
known issue when installing .NET to a Windows XP operating system. To clean up the temporary files, you must delete 
the temporary folder that remains after the .NET installation. The folder name is a random set of 18 numbers and 
characters, such as 1851056e8ca35c6a64, that is located under the drive with the most free space available at the 
beginning of the installation.  If your computer has only one drive then it will usually be the C:\ drive on your installation 
machine.

Leaving the folder causes no adverse affects other than taking up space on your machine.

Microsoft Excel Mixed Data Type Columns Process as Text

When working with an Excel 2007 or Excel 2010 table in MapInfo Professional if there are mixed types of data in one 
column, such as float, text, date, and time, then MapInfo Professional treats all the data in the column as text. If 
MapInfo Professional treats the data type of the column as something other than text, this can be corrected by 
updating a Microsoft ACE (Access Connectivity Engine) registry key.

MapInfo Professional detects when an Excel 2007 or Excel 2010 table has a column with mixed data types using the 
ACE setting in the registry. This registry key is called ImportMixedTypes and is in the registry under:

32 bit systems:
HKEY_LOCAL_ MACHINE\SOFTWARE\Microsoft\Office\14.0\Access Connectivity Engine\Engines\Excel
64 bit system:
HKEY_LOCAL_ MACHINE \SOFTWARE\Wow6432Node\Microsoft\Office\14.0\Access Connectivity 
Engine\Engines\Excel

It decides how to import mixed data; by default, it is set to text value. A secondary registry key called TypeGuessRows 
determines how many rows to scan for each column before the ACE decides that a column has mixed data types. A 
value of zero (0) scans all the rows to determine if a column has mixed data types. The default setting is eight (8) to 
scan eight rows.
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To ensure that the data types of all columns are detected correctly, change the TypeGuessRows key in the registry to 
zero (0) as explained below. 

Scanning all of the rows by setting TypeGuessRows to 0 in a large spreadsheet can be slow. 

Modifying the TypeGuessRows Option

Editing the registry requires Administrator privileges for the machine. If you do not have the required privileges, contact 
your System Administrator for assistance.

This is not a MapInfo-specific setting. Changing the TypeGuessRows setting affects all applications that use 
ACE to open Excel files, such as Microsoft Access.

Before modifying the TypeGuessRows key in the registry, make a backup of the Excel registry keys and settings:

1. Close any programs that are running. 

2. Choose Start > Run and type the command regedit. Click OK to display the Registry Editor window.

3. In the HKEY_LOCAL_MACHINE entry, navigate to one of the following:
32 bit systems: 
Software > Microsoft > Office > 14.0 > Access Connectivity Engine > Engines > Excel
64 bit systems: 
Software > Wow6432Node > Microsoft > Office > 14.0 > Access Connectivity Engine > Engines > Excel

4. Highlight the Excel folder and then select File > Export.

5. In the Export Registry File dialog, specify a location and file name to backup to and then click Save.

6. Continue to the next set of instructions to set the TypeGuessRows key.

To set the TypeGuessRows key:

1. Select TypeGuessRows and on the Edit menu click Modify to display the Edit DWORD Value dialog box.

2. In the Value data field, type 0 (zero) and click OK.

This option takes effect the next time MapInfo Professional opens.

This issue is specific to Microsoft's Jet Database Engine. MapInfo Professional 10.0 and later uses Microsoft's 
Office-specific version of the Jet engine to access data from Excel 2007 tables. Microsoft has also proposed the 
above solution in their Knowledge Base for another symptom of this problem: http://support.microsoft.com/
default.aspx/kb/189897.

Repairing MapInfo Professional from the .MSI File

On Windows Vista, Windows 7, and Windows Server 2008, the repair process fails using the .msi file when the 
Microsoft User Account Control (UAC) is turned on. Depending on the installation conditions one of two error 
messages displays and the repair stops:

You have MapInfo Professional running, please close it and run setup again.

Or

MDAC 2.8 cannot be installed on this machine. MDAC 2.8 requires any one of the following configurations...

To work around this issue, do one of the following three things:

• Shut off the UAC (this requires System Administrative privileges), reboot the machine, and rerun the repair.
• Run the original setup.exe file and then run the repair from maintenance mode.
• Run the installed copy of the MapInfo Professional 10.5.1.msi file as an administrator:
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a. Go to C:\Windows\Installer and search for the MapInfo Professional 10.5.1 .msi file. it will have a name 
similar to 8e95f1.msi, where the name is different for each machine.

b. Go to C:\Windows\System32 and find the cmd.exe file. Right click this file and select Run as Administrator 
(this may require an administrator password).

c. Run the command C:\Windows\Installer\<nameofMiPro10.5.msi> and select Repair from maintenance 
mode.

Disabling User Account Control (UAC) on Windows 7 and VISTA

To disable UAC:

1. Launch MSCONFIG by from the Run menu.

2. In the System Configuration dialog box, click the Tools tab.

3. Scroll through the tools list to locate and then select Disable UAC. 

4. Click Launch.

5. Click OK to close the dialog box.

6. Reboot the machine to have this change take effect.

After repairing MapInfo Professional, follow the previous steps to turn UAC on again. We strongly recommend this 
Windows security feature remain activate (remain turned on).
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