Introdução

  • Visão Geral do Portrait Miner
© 2015 Pitney Bowes Software Inc. Email: software.support@pb.com


Visão Geral do Portrait Miner

O Portrait Miner é uma solução analítica preditiva e poderosa que permite aos profissionais de customer insight e usuários empresariais terem uma imagem clara de seus clientes para que possuam um entendimento superior dos clientes, descobrindo áreas de oportunidade, atingindo uma segmentação ótima e prevendo comportamentos futuros.

Preenchendo a lacuna entre as ferramentas padrão de Inteligência Empresarial com um escopo limitado para explorar dados e soluções para cálculos numéricos, que requerem programadores estatísticos para criar consultas e produzir modelos, o Portrait Customer Analytics é uma solução de próxima geração, projetada para uma facilidade de uso inédita – e um entendimento prático rápido.

A solução usa a visualização de dados em 3D e automatização de modelagem rápida para descobrir relacionamentos de dados importantes e entregar resultados de propensão clicando em um botão, melhorando a precisão do modelo preditivo e aumentando a velocidade dos resultados analíticos.

O Portrait Miner pode ser usado para prever comportamentos e tendências que têm impacto nos lucros, incluindo desistência de clientes, oportunidades de venda incrementada e venda cruzada, planejamento e segmentação de campanha, satisfação e lealdade do cliente e valor permanente do cliente.

Tópico pai: Introdução


Primeiros passos

  • Iniciar o Portrait Miner
  • Adicionar ou remover detalhes dos servidores do Portrait Miner
  • Navegar para abrir ou salvar um arquivo, sessão ou tabela de banco de dados
  • Trabalhar com arquivos em discos locais
  • Manipular arquivos de focus no Portrait Miner
  • Visualizar e editar arquivos de texto no Portrait Miner
  • Sobre codificação de texto
  • Trabalhar com arquivos de sessão


Iniciar o Portrait Miner

  1. Faça uma das seguintes ações:
    • Clique duas vezes no ícone de atalho do Portrait Miner em seu desktop. O Portrait Miner inicia.
    • Vá ao menu Iniciar do Windows em Programas>Portrait Miner, escolha Portrait Miner.
  2. Se aparecer uma janela de logon, insira seu nome de usuário e senha para o servidor do Portrait Miner e clique em OK.

    Seu administrador de sistema deve ser capaz de lhe dizer qual servidor usar (se houver escolha) e qual seu nome de usuário e senha para esse servidor. (Se o sistema operacional de seu servidor for Windows, é necessário que seu nome de usuário e senha sejam apropriados para o domínio Windows configurado nos detalhes do servidor.)

    Se nunca usou o Portrait Miner e o menu Servidor estiver vazio, consulte Adicionar ou remover detalhes dos servidores do Portrait Miner.

    Assim que estiver conectado ao servidor do Portrait Miner, é possível executar mais aplicativos do Portrait Miner, esses se conectam ao mesmo servidor e não pedem novo login. Você permanecerá conectado ao servidor do Portrait Miner até que faça um logout (selecionando Arquivo>Logout em qualquer aplicativo do Portrait Miner) ou saia do último aplicativo do Portrait Miner aberto (selecionando Arquivo>Sair, ou clicando em [image] na janela principal do aplicativo).

Tópico pai: Primeiros passos


Adicionar ou remover detalhes dos servidores do Portrait Miner

A primeira vez que o Portrait Miner é usado, o menu Servidor na janela de logon está vazio (a menos que seu administrador de sistema o tenha configurado para você).

Se quiser adicionar uma entrada ao menu Servidor, é necessário saber o nome da rede do servidor do Portrait Miner e o número da porta. Seu administrador de sistema deve ser capaz de fornecer essa informação.

Tópico pai: Primeiros passos

Para adicionar um servidor ao menu Servidor

  1. Na janela de login, clique em Servidores para apresentar a caixa de diálogo Servidores:

  2. Clique em Adicionar para apresentar a caixa de diálogo Adicionar Configuração do Servidor:

  3. Na caixa Nome introduza a descrição do servidor usada na lista do Servidor na janela de login.
  4. Na caixa Servidor, introduza o nome da rede para o servidor do Portrait Miner (por exemplo, yourserver.yourco.com).
  5. Selecione Unix ou Windows de acordo com o sistema operacional do servidor do Portrait Miner. Se selecionar Windows, especifique o domínio Windows ao qual irá se conectar, ou use a configuração padrão ("Local"), para especificar a conta local no servidor.
  6. Na caixa Porta, digite o número da porta para a qual o servidor foi configurado.
  7. Clique em OK para adicionar novos detalhes ao servidor.
  8. Na caixa de diálogo Servidores clique em Fechar para regressar à janela de login.

Editar os detalhes para um servidor

  1. Clique no botão Servidores.
  2. Selecione um servidor disponível e clique em Editar.

    A caixa de diálogo Editar Configuração do Servidor é exibida, que é basicamente igual à caixa de diálogo Adicionar Configuração do Servidor [consulte Para adicionar um servidor ao menu Servidor].

  3. Corrija o nome, servidor ou porta conforme necessário e clique em OK.
  4. Clique em Fechar, para fechar a caixa de diálogo Servidores.

Remover um servidor do menu Servidores

  1. Clique no botão Servidores.
  2. Selecione o servidor que pretende remover e clique em Remover.
  3. Clique em Fechar.


Navegar para abrir ou salvar um arquivo, sessão ou tabela de banco de dados

No Portrait Miner, sempre que se abre ou salva um arquivo, sessão ou tabela de banco de dados, é exibido um navegador de arquivos do Portrait Miner. Ele é semelhante aos navegadores de arquivos em outros aplicativos do Windows, mas apresenta variantes que permitem procurar arquivos em seu PC, arquivos em seu servidor do Portrait Miner (na versão cliente-servidor do software) e tabelas em seus bancos de dados.

Ao abrir ou salvar um conjunto de dados, o navegador de arquivos contém até três guias, chamadas "Quadstone," "Todos os Arquivos" e "RDBMS," como no exemplo abaixo:

Tópico pai: Primeiros passos

Procurar arquivos no Portrait Miner

As guias "Quadstone" e "Todos os Arquivos" mostram arquivos e pastas no Portrait Miner, mas o primeiro é ligeiramente mais restrito:
 | guia "Quadstone" | guia "Todos os Arquivos"
Pastas mostradas | Todas as pastas exceto: pastas com as extensões de nome de arquivo .rdx e .xtr, que contêm arquivos de dados de focus; pastas cujos nomes começam com um ponto (.) | Todas as pastas
Arquivos mostrados quando Arquivos de Tipo é configurado para Todos os Arquivos | Todos os arquivos exceto: arquivos com extensões de nome de arquivo .fcs, .mid, .mdh, .spa e .x86; arquivos cujos nomes acabam com um til (~); arquivos cujos nomes começam com um ponto (.) | Todos os arquivos
Arquivos mostrados quando Arquivos de Tipo é configurado para um determinado tipo de arquivo | Apenas arquivos com a(s) extensão(ões) de nome de arquivo específica(s) | Como "Quadstone"

Caso esteja salvando um conjunto de dados como um arquivo simples ou focus, escolha o tipo indicado no seletor Arquivos de Tipo.

Nota:
  • O Portrait Miner normalmente mostra os mesmos arquivos e pastas que um navegador de arquivos mostra na guia Quadstone. É possível exibir os arquivos e pastas que um navegador de arquivos mostra com a guia Todos os Arquivos selecionando Exibir>Exibir Arquivos Escondidos.
  • O Portrait Miner gera arquivos de log para fins administrativos. Para ir à pasta que contém esses arquivos de log, clique em [image] na barra de ferramentas.
  • Para ir à pasta anterior, seguinte ou principal, clique em [image], [image], ou [image] na barra de ferramentas.
  • Para ir diretamente à pasta padrão (a configuração de preferência do início do qsexplorer), clique em
  • É possível ir diretamente a qualquer pasta ao selecionar Exibir>Ir Para... e digitar o nome da pasta.

Navegar bancos de dados, namespaces e tabelas

É possível navegar bancos de dados se usar a guia "RDBMS", quando existe. ("RDBMS" significa "Sistema de Gerenciamento de Banco de Dados Relacional.") A guia mostra inicialmente uma lista de bancos de dados disponíveis. É possível navegar em uma hierarquia de banco de dados, até ao nível das tabelas individuais, da mesma forma que navega no sistema de arquivos.

Consulte também

Configurar uma vinculação de banco de dados

Procurar sessões em seu PC

É possível localizar sessões salvas anteriormente (arquivos .pms) usando o menu Arquivo > Abrir Sessão. Nesse caso, o navegador de arquivos mostra apenas uma guia, chamada "Meu Computador" com a extensão de arquivo .pms pré-selecionada.

Nesses casos, o navegador de arquivos mostra apenas uma guia, chamada "Meu Computador":

É possível procurar e salvar arquivos em seu PC como em qualquer aplicativo do Windows.

Procurar arquivos em seu PC

É possível salvar alguns tipos de arquivos em seu PC (ou em uma unidade da rede acessível a partir de seu PC). Esses arquivos incluem gráficos exportados e tabelas de referência cruzada.

Nesses casos, o navegador de arquivos mostra apenas uma guia, chamada "Meu Computador":

É possível procurar e salvar arquivos em seu PC como em qualquer aplicativo do Windows.


Trabalhar com arquivos em discos locais

Mesmo sem ter acesso direto a seu computador servidor do Portrait Miner, é possível salvar e abrir alguns arquivos (como scripts, imagens e tabelas de referência cruzada) em seu PC. Para usar um arquivo de dados em seu PC (ou uma unidade de rede acessível), é possível arrastar um arquivo de dados do Windows Explorer para uma pasta no Portrait Miner.

É exibida uma cópia do arquivo na pasta no servidor do Portrait Miner, que pode ser usada diretamente.

Nota: Além de arrastar arquivos do Windows Explorer para o Portrait Miner, é possível arrastar arquivos na direção oposta, para copiá-los do servidor do Portrait Miner para um disco local.

Consulte também

Visualizar e editar arquivos de texto no Portrait Miner
Tópico pai: Primeiros passos


Manipular arquivos de focus no Portrait Miner

Um focus é armazenado em disco como um arquivo .ftr (o "arquivo de focus") juntamente com um conjunto de arquivos de dados e outros arquivos em duas pastas, com nomes com as extensões .rdx ("Raw Data eXtract") e .xtr ("eXTRa"). Normalmente, as pastas não estarão visíveis no Portrait Miner e na guia "Quadstone" dos navegadores de arquivos do Portrait Miner [consulte Navegar para abrir ou salvar um arquivo, sessão ou tabela de banco de dados].

Um novo focus que é criado por meio de cópia de um focus existente ou pela importação de dados de outro tipo de conjunto de dados (ou como resultado de execução de um script TML) é independente de outros focus. Por outro lado, um focus que é salvo no Decision Studio com novo nome ou um que seja criado através de uma cópia vinculada é dependente das pastas de dados de outros focus.

Devido à potencial interdependência dos focus, não se deve copiar, mover, renomear ou excluir os arquivos e as pastas de focus que usam utilitários padrão do sistema operacional, por exemplo, as ferramentas da linha de comando do Windows Explorer ou do UNIX. Em vez disso, sempre deve ser usado o Portrait Miner (ou os comandos de compilação de dados do Portrait Miner).
Tópico pai: Primeiros passos

Copiar ou mover um arquivo de focus para outra pasta

  1. No Portrait Miner, clique no arquivo de focus que pretende copiar ou mover.
  2. Faça uma das seguintes ações:
    se for copiar o arquivo | se for mover o arquivo
    Escolha Editar>Copiar. | Escolha Editar>Recortar.
    Clique com o botão direito do mouse e escolha Copiar. | Clique com o botão direito do mouse e escolha Recortar.
    Clique em [image] na barra de ferramentas. | Clique em [image] na barra de ferramentas.
    Pressione CTRL+C. | Pressione CTRL+X.
  3. Navegue até a pasta de destino.
  4. Escolha Editar>Colar, clique com o botão direito do mouse e escolha Colar, clique em [image] na barra de ferramentas ou pressione CTRL+V.
Nota:
  • É possível copiar um arquivo de focus como um focus independente (como acima), nesse caso, os próprios dados são duplicados; ou criar uma cópia vinculada, que compartilha dados com o focus original. É possível fazer isso usando Colar Link em vez de Colar. (Não existe um atalho da barra de ferramentas para isso.) Não é possível criar uma cópia vinculada ao mover o arquivo de focus.
  • Também é possível escolher um novo nome para um focus que está sendo movido ou copiado ao escolher Colar Como ou (ao copiar) Colar Link Como.
  • Essa interface do usuário é uma forma de acessar muitas das funcionalidades fornecidas pelos comandos de compilação de dados qscopy, qslink e qsmove do Portrait Miner.
  • Também é possível copiar ou mover um arquivo que não seja de focus (mas não é possível criar cópias vinculadas) da mesma forma.

Consulte também

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Renomear um arquivo de focus

  1. No Portrait Miner, clique no arquivo que pretende renomear.
  2. Escolha Editar>Renomear, clique com o botão direito do mouse e escolha Renomear ou simplesmente clique uma segunda vez no nome do arquivo.

    O nome do arquivo fica editável.

Nota:
  • Essa interface do usuário é uma forma de acessar muitas das funcionalidades fornecidas pelo comando de compilação de dados qsmove do Portrait Miner.
  • Também é possível renomear arquivos e pastas que não sejam de focus da mesma forma.

Consulte também

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Excluir um focus

É possível usar o Portrait Miner para excluir repetidamente uma cadeia completa de focus: selecione o focus a excluir e todos os focus que dependem do mesmo serão igualmente excluídos. É apresentada a confirmação de quais focus serão excluídos e há a opção de continuar ou parar completamente a operação de exclusão.

  1. No Portrait Miner, clique no arquivo de focus que pretende excluir.
  2. Escolha Editar>Excluir, clique com o botão direito do mouse e escolha Excluir, clique em [image] na barra de ferramentas ou pressione Delete.
Nota:
  • Essa interface do usuário acessa a maior parte das funcionalidades fornecidas pelo comando de compilação de dados qsremove do Portrait Miner.
  • Também é possível excluir arquivos e pastas que não sejam de focus da mesma forma. Antes de excluir uma pasta, é necessário excluir primeiro quaisquer arquivos de focus nessa pasta.

Consulte também

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Criar um arquivo compactado

É possível criar um arquivo compactado a partir de um focus ou de uma pasta que apresente um conjunto de focus ou de subpastas relacionados.

No Portrait Miner, clique com o botão direito do mouse no arquivo ou na pasta que pretende compactar e escolha Arquivo para uma pasta ou Exportar>para Arquivar para um focus.

Na caixa de diálogo Arquivar para arquivo ZIP, especifique um nome do arquivo de saída.

Nota:
  • Se for criado um arquivo compactado a partir de uma pasta que contém focus ligados a dados fora da pasta, os dados externos são copiados para o arquivo. Isso garante que se obtenha sempre um conjunto consistente de focus relacionados ao extrair um arquivo compactado.
  • Essa interface do usuário é uma forma de acessar muitas das funcionalidades fornecidas pelo comando de compilação de dados qsarchive do Portrait Miner.

Consulte também

Sobre os assistentes do Portrait Miner

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Extrair um arquivo compactado

No Portrait Miner, clique com o botão direito do mouse no arquivo compactado e escolha Extrair.

Na caixa de diálogo Extrair de arquivo compactado ZIP, escolha uma pasta de saída e se os arquivos existentes devem ser substituídos.

Nota: Essa interface do usuário é uma forma de acessar muitas das funcionalidades fornecidas pelo comando de compilação de dados qsunzip do Portrait Miner.

Consulte também

Sobre os assistentes do Portrait Miner

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados


Visualizar e editar arquivos de texto no Portrait Miner

A forma de edição ou visualização de um arquivo do Portrait Miner depende do tipo desse arquivo. Pode ser possível:
  • clicar com o botão direito do mouse no arquivo e escolher Editar, para editar (ou visualizar) o arquivo no Bloco de Notas;
  • clicar com o botão direito do mouse no arquivo e escolher Exibir, para visualizar o arquivo em uma aplicação apropriada;
  • clicar duas vezes no arquivo como uma alternativa a uma das opções anteriores.
Tipo de arquivo | Editar | Exibir | Dois cliques
Arquivo de dados de texto (.txt, .dat, .csv, .tab, .fdf), arquivo de descrição de dado simples (.fdd) |  |  | — (Abrir [consulte Criar um focus de dados a partir de um arquivo de texto])
Arquivo SQL (.sql) |  |  | — (Abrir)
Bloco de Notas. Arquivo script TML (.tml), arquivo de derivação FDL (.fdl), arquivo de hierarquia de binning categórica (.hrc) |  |  | Editar
Arquivo de log (.log) |  |  | Exibir
Arquivo XML (.xml, .qmml, etc.) |  |  | Exibir
Nota:
  • Mesmo sem ter acesso direto a sua máquina servidor do Portrait Miner, ainda é possível exibir e, se for apropriado, editar arquivos de texto no servidor. Existem duas versões do Portrait Miner: uma versão de cliente-servidor e o Portrait Miner Desktop. Se você usa a versão cliente-servidor, ao usar o Portrait Miner para ver ou editar um arquivo de texto no Bloco de Notas, está, na realidade, trabalhando com uma cópia local do arquivo. Se salvar o arquivo mas o Bloco de Notas permanecer aberto, a versão no servidor permanece inalterada; o Portrait Miner só copia a versão atualizada em seu computador para o servidor após fechar o Bloco de Notas.
  • Deve ser usada uma codificação ISO-8859-1 (Latim-1) ao salvar arquivos de texto.

Consulte também

Manipular arquivos de focus no Portrait Miner

Trabalhar com arquivos em discos locais

XML no Portrait Miner

Tópico pai: Primeiros passos


Sobre codificação de texto

O arquivos de texto no Portrait Miner podem estar codificados em Unicode conforme definido pela marca de ordem de byte do arquivo (BOM). Se um arquivo no Windows não tiver uma BOM, assume-se ser o que o Windows descreve como "ANSI" relativamente ao local do computador, por exemplo, Windows 1215 na Europa e nos EUA, CP932 no Japão. Em Solaris, assume-se que um arquivo sem BOM é latim-1 codificado.

Tópico pai: Primeiros passos


Trabalhar com arquivos de sessão

Se estiver trabalhando com uma das ferramentas de visualizador individual do Portrait Miner (Crosstab, 3D, Profile ou Visualizador de Mapas) e pretender salvar sua vista atual, pode fazê-lo usando a opção Arquivo > Salvar Sessão na janela do Decision Studio. Os arquivos são salvos com a extensão de arquivo (.pms) e são pré-fixos por padrão com o nome do arquivo de focus.
As sessões salvas podem ser carregadas a partir do Decision Studio ou, alternativamente, é possível carregar duas vezes no arquivo .pms na janela do explorador do Portrait Miner.
Nota:
Session files are directly linked to the associated focus file and must reside in the same directory.

Carregar ou abrir uma sessão salva

É possível carregar sessões salvas para as seguintes ferramentas do Portrait Miner:

  • Visualizador de Crosstab
  • 3D viewer
  • Visualizador de Perfil
  • Visualizador de Mapas
    Nota: Todos os arquivos de sessão salvos estão diretamente ligados ao arquivo de focus a partir do qual foram criados.
Para carregar uma sessão salva do Portrait Miner
  1. Abra o Portrait Miner e navegue para seu diretório de sessão salva.
  2. Clique duas vezes no arquivo de sessão salva (.pms). A sessão irá carregar os dados de focus associados e a sessão salva.
Para abrir uma sessão salva do Decision Studio
  1. Abra o Decision Studio.
  2. Selecione Arquivo > Abrir Sessão e procure o arquivo de sessão relevante (.pms). A sessão irá carregar os dados de focus associados e a sessão salva.

Salvar uma sessão

É possível salvar informações sobre uma sessão individual para as seguintes ferramentas do Portrait Miner:

  • Visualizador de Crosstab
  • 3D viewer
  • Visualizador de Perfil
  • Visualizador de Mapas
Para salvar uma sessão
  1. Com sua sessão aberta, altere para a janela do Decision Studio e selecione Arquivo>Salvar Sessão.
  2. Na caixa de diálogo Salvar Sessão, adicione o nome de seu arquivo ao prefixo padrão. Observação: O prefixo identifica o arquivo de focus relacionado com a sessão.
Tópico pai: Primeiros passos


Trabalhar com arquivos simples, tabelas de bancos de dados e focus

  • Sobre os assistentes do Portrait Miner
  • Abrir um focus para visualizar, segmentar e modelar
  • Para classificar um focus
  • Para converter um focus orientado para a transação em um focus orientado para cliente
  • Criar um focus de dados a partir de um arquivo de texto
  • Criando um focus de dados em um banco de dados
  • Criar um focus a partir de um conjunto de dados SAS ou de terceiros
  • Exportar registros para um arquivo de dados, tabela de banco de dados ou focus
  • Sobre combinar focus
  • Para juntar campos de um focus a outro focus por meio do Portrait Miner
  • Juntar campos de um focus a outro focus usando o Decision Studio
  • Mesclar registros de dois focus
  • Configurar uma vinculação de banco de dados
  • Como o Portrait Miner importa tipos de banco de dados
  • Usar o Data Build Manager para importar, processar e exportar dados
  • Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados


Sobre os assistentes do Portrait Miner

Os assistentes do Portrait Miner são abertos a partir do Portrait Miner, após selecionar um focus ou outro arquivo, e fornecem acesso de interface do usuário aos comandos de compilação de dados do Portrait Miner.

Cada assistente exibe os parâmetros de comando na guia Parâmetros. É possível alterar os valores na guia Parâmetros digitando diretamente no campo ou clicando em Navegar [image] para exibir uma outra caixa de texto onde é possível escolher um valor.

Quando todos os parâmetros obrigatórios — indicados por um asterisco vermelho no campo de parâmetros — tiverem sido selecionados, clique em Ir para executar o comando de compilação de dados associado. Se necessário, é possível parar o comando clicando no botão Parar; por exemplo, se forem selecionados os parâmetros errados.

Após o comando ser concluído, os resultados são exibidos na guia Saída. Se existir algum erro associado ao processamento do comando, é exibida uma mensagem de erro na guia Erro.

Consulte também

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados
Tópico pai: Trabalhar com arquivos simples, tabelas de bancos de dados e focus


Abrir um focus para visualizar, segmentar e modelar

Assim que tiver os dados do cliente como um focus, é possível abrir o focus no Decision Studio para análise, usando diversas ferramentas [consulte Ferramentas do Decision Studio] para visualizar, segmentar e modelar.

É possível abrir um focus usando uma das seguintes opções:

  • No Portrait Miner, clique duas vezes no focus que pretende abrir ou clique com o botão direito do mouse no focus e escolha Abrir.
  • Em uma janela do Decision Studio com um focus atualmente aberto, selecione Arquivo>Fechar, para fechar o focus existente. Em seguida, escolha Arquivo>Abrir ou clique em [image] na barra de ferramentas e navegue até ao focus que pretende abrir.

    (Se um focus tiver sido modificado depois de ser criado ou aberto, o Decision Studio oferece a oportunidade para salvar suas mudanças antes de o fechar.)

Nota:
  • Se você foi avisado que o focus é somente de leitura, use Arquivo>Salvar como ou clique em [image] na barra de ferramentas e escolha um novo nome ou localização para seu focus, ou copie o focus para uma nova localização. Algumas funcionalidades e opções do produto não funcionam com um focus somente de leitura.
  • Apenas um focus pode ser aberto por vez em uma sessão específica do Decision Studio.

    (No entanto, é possível ter mais de uma sessão por vez no Decision Studio.)

  • Dois ou mais usuários podem abrir e trabalhar simultaneamente com o mesmo focus no Decision Studio. (Porém, é preciso ter certeza de que ao salvar o focus isso não é feito sobre o trabalho de outro usuário).

Consulte também

Criando um focus de dados em um banco de dados

Criar um focus de dados a partir de um arquivo de texto

Iniciar o Portrait Miner

Tópico pai: Trabalhar com arquivos simples, tabelas de bancos de dados e focus


Para classificar um focus

É possível classificar os registros em um
Para classificar um focus:
  • No Portrait Miner, clique com o botão direito do mouse no focus que pretende classificar e escolha Transformar>Ordenar.

Na caixa de diálogo Ordenar Focus, escolha até três campos-chave para determinar a ordem do focus classificado. Além do mais, é possível alterar a localização do novo focus ou escolher substituir um focus de saída criado anteriormente.

Nota:
  • Se for escolhido mais de um campo, a chave de classificação primária será o campo selecionado que aparece primeiro no focus e a chave de classificação secundária será o campo selecionado que aparece em segundo lugar. (Se forem escolhidos três campos, o outro campo será a chave de classificação terciária.)
  • Essa interface do usuário é uma forma de acessar muitas das funcionalidades fornecidas pelo comando de compilação de dados qssort do Portrait Miner.

Consulte também

Sobre os assistentes do Portrait Miner

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Tópico pai: Trabalhar com arquivos simples, tabelas de bancos de dados e focus

Para verificar a ordem da classificação de um focus

No Portrait Miner, clique com o botão direito do mouse no focus que pretende verificar e escolha Transformar>Verificar Ordem.

Na caixa de diálogo Verificar Ordem, escolha os campos-chave; o Portrait Miner verificará se o focus é classificado segundo esses campos.


Para converter um focus orientado para a transação em um focus orientado para cliente

Para uma análise de dados ao nível do cliente, são necessários dados orientados para o cliente. Se tiver um focus orientado para a transação — ou seja, um focus no qual cada registro represente uma transação do cliente — é possível computar estatísticas agregadas por cliente para criar campos em um novo focus orientado para o cliente. É possível usar de imediato o novo focus para análise ou junção [consulte Sobre combinar focus] a outros focus orientados para o cliente.
Para converter um focus:
  • No Portrait Miner, clique com o botão direito do mouse no focus orientado para a transação e escolha Transformar>Dados Agregados.

Na caixa de diálogo Dados Agregados, escolha o arquivo que contém definições de campo e os campos-chave que identificam um cliente de forma exclusiva. Também é possível alterar a localização do novo focus ou escolher substituir um focus de saída criado anteriormente.

Nota:
  • Essa interface do usuário é uma forma de acessar muitas das funcionalidades fornecidas pelo comando de compilação de dados qsmeasure do Portrait Miner.
  • Para rastrear mudanças de estado em um fluxo de transação, deve-se usar o comando de compilação de dados qstrack do Portrait Miner.

Consulte também

Sobre os assistentes do Portrait Miner

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Visualizar e editar arquivos de texto no Portrait Miner

Tópico pai: Trabalhar com arquivos simples, tabelas de bancos de dados e focus


Criar um focus de dados a partir de um arquivo de texto

Para usar o Portrait Miner para analisar um conjunto de dados no formulário de um arquivo de texto, é necessário criar antes um focus a partir do arquivo de dados.
Para criar um focus:
  • No Portrait Miner, clique duas vezes no arquivo ou clique com o botão direito do mouse no arquivo e escolha Abrir.
Duas janelas aparecem:
  • A janela Informação de formato de arquivo simples mostra a tentativa inicial do Decision Studio de entender os dados, selecionando quaisquer problemas encontrados.

    É possível fechar essa janela a qualquer momento.

  • A outra janela é o assistente de Novo focus, que inicialmente mostra o passo 1 de um processo de importação de cinco passos:

    É possível se mover entre os passos usando os botões Próximo e Anterior. A qualquer instante é possível clicar em Concluir para aceitar as escolhas feitas até o momento e criar um novo focus a partir de seu conjunto de dados.

    Antes de clicar em Concluir, é possível escolher onde salvar seu focus, clicando no botão Navegar no painel Salvar focus como e navegando [consulte Navegar para abrir ou salvar um arquivo, sessão ou tabela de banco de dados] para escolher uma localização.

    Em cada passo, o assistente de Novo focus exibe a interpretação atual do Decision Studio dos nomes e tipos de campos do arquivo simples com uma pequena amostra dos dados apresentados com essa interpretação.

Passo 1: Escolha um formato delimitado ou de largura fixa No painel Selecionar formato, escolha Delimitado se os valores de campo estiverem separados por vírgulas, barra horizontal (|) ou por qualquer outro delimitador; escolha Largura fixa se os valores de campo começarem e terminar nas mesmas posições de caractere fixas em cada linha do arquivo.

Passo 2: Definir detalhes de formato de arquivo simples O painel das opções de Formato apresenta os detalhes de formato que estão atualmente definidas.

Se o Decision Studio interpretou o formato de arquivo simples incorretamente (por exemplo, se escolheu o separador de campo errado), clique em Definir Formato no painel das opções de Formato para abrir a janela Definir formato de arquivo plano (e também uma janela de visualização Dados não processados):

A versão apresentada à esquerda é para os dados de campos delimitados; a versão à direita é para campos com largura fixa.

(Ao escolher campos com largura fixa e passar do Passo 1 para o Passo 2, as janelas Definir formato de arquivo plano e Dados não processados aparecem automaticamente.)

Se a primeira fila de seu arquivo consiste em nomes de campo em vez de dados, marque a opção Cabeçalhos de Coluna.

As configurações Separador de Campo, Ler Nulo Como, Ler Datas Como, Ler Marcador de Data Como, e Ler Strings Como permitem especificar aspectos detalhados do formato do arquivo simples, com opções comuns disponíveis nos menus suspensos. Defina o Separador de Campo para "nothing" para um arquivo simples com campos de largura fixa.

Para campos de largura fixa, use a tabela para especificar os nomes de campo e suas posições iniciais e finais. É possível usar a janela Dados não processados como um guia para isso: a "régua" no topo apresenta posições de caracteres e enquanto o ponteiro do mouse é movido sobre os dados de amostra, o texto de localização apresenta a posição do caractere atualmente sob o ponteiro.

Passo 3: Definir os detalhes de formato de campo A tabela dos detalhes de campo se expande para incluir três linhas editáveis (com fundos):

As primeiras duas linhas contêm cada uma o nome atual do campo e o tipo. Para um campo de string, a terceira linha contém seu comprimento (máximo) em caracteres. Para um campo de dados, a terceira linha contém um formato de dados.

É possível escrever um nome de campo novo, o comprimento de string ou um formato de dados customizado [consulte Formatos de data personalizados] diretamente.

Se clicar em um tipo de campo, é exibido um menu, mostrando os quatro tipos de dados disponíveis [consulte Tipos de Dados]. Para os campos de dados, está disponível um menu de três formatos de dados padrão [consulte Formatos de data padrão].

Passo 4: Salvar detalhes de formato Se precisar reusar seus detalhes de formato posteriormente, é possível criar um arquivo de descrição de dados simples (FDD) se clicar em Exportar Formato e escolher uma localização.

Passo 5: Selecionar os campos a importar Por padrão, o Decision Studio importa todos os campos em um arquivo simples. Se não forem necessários todos os campos, clique em Selecionar Campos no painel Selecionar Campos. A caixa de diálogo Selecionar Campos aparece com todos os campos da fonte de dados externa inicialmente no painel Incluir:

Use os botões de setas entre os painéis Excluir e Incluir para escolher os campos do arquivo simples que quer incluir em seu focus.

Os botões [image] e [image] movem campos realçados, enquanto os botões [image] e [image] movem todos os campos de um painel para outro.

Use os botões [image] e [image] à direita da janela para organizar campos realçados no painel Incluir.

Nota:
  • É possível clicar em Mostrar Dados no assistente de Novo focus para visualizar os dados como aparecem no arquivo. Isso pode ser útil se o Decision Studio for incapaz de determinar o formato do arquivo.
  • Para ajudar na configuração dos detalhes de formato de arquivo para um arquivo simples com campos de largura fixa, é possível copiar e colar ou arrastar uma descrição externa dos dados para a tabela na caixa de diálogo Definir formato de arquivo plano.

    A descrição também pode estar no formato de uma planilha Excel ou em texto simples, com duas ou três colunas de valores separados por guia. A primeira coluna de dados, que é opcional, contém os nomes do campo; as duas seguintes (ou somente duas) colunas contêm as posições iniciais ou finais para os campos.

  • O Decision Studio baseia sua interpretação inicial de um arquivo simples em um subconjunto de registros. Para modificar o número de registros que o Decision Studio usa para isso, modifique as definições da preferência tamanho de amostra de formato de dado para modificar a sensibilidade do Decision Studio para dados mal formatados, modifique a definição da preferência percentagem de corte grande.

    Se o Decision Studio necessitar de mais informações para interpretar o arquivo simples corretamente, ele lê um subconjunto maior de registros. Para modificar o número de registros que o Decision Studio usa nesse caso, mude a definição da preferência tamanho de amostra de dados.

  • Quando o Decision Studio terminar a importação do arquivo simples, ele criará um arquivo de log apropriado. Deve-se examinar esse arquivo se o Decision Studio reportar qualquer erro ou aviso durante o processo de importação.

    No Portrait Miner, é possível você clicar em [image] para ir para o diretório contendo os arquivos de log% — o subdiretório shared/logs (UNIX) ou shared\logs (Windows) do diretório de instalação do Portrait Miner.

    O arquivo de log pedido é o arquivo de log mais recente cujo nome começa com o nome do arquivo. (É possível classificar os arquivos de log por ordem de tempo/data no cabeçalho da coluna Modificado.)

  • O Decision Studio modifica quaisquer campos de nomes inválidos para nomes de campo válidos.
  • Se um arquivo simples tiver uma descrição de dados simples associada (FDD), é possível usá-lo para definir o formato de arquivo inicial: clique em Importar Formato no Passo 1 do processo de importação. (É possível agora fazer mudanças ao formato de forma normal).

    Se preferir, é possível iniciar o assistente de Novo focus clicando duas vezes no arquivo FDD no Portrait Miner.

  • Um valor integer é qualificado como "pequeno" no assistente de Novo focus se estiver especificado como smallinteger [consulte Tipos de Dados] em um arquivo FDD. Um campo de smallinteger ocupa menos espaço em disco que um campo integer normal, mas só é possível ter um intervalo limitado de valores.
  • Essa interface do usuário é uma forma de acessar a maior parte das funcionalidades fornecidas pelos comandos de compilação de dados do Portrait Miner qsgenfdd e qsimportflat.

Consulte também

Criando um focus de dados em um banco de dados

linhas vazias

extração de máximos erros

extração de máximos avisos

ignore avisos de extração

permitir erros de formato de dado

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Tópico pai: Trabalhar com arquivos simples, tabelas de bancos de dados e focus


Criando um focus de dados em um banco de dados

Para usar o Portrait Miner para analisar um conjunto de dados no formato de uma tabela de banco de dados – ou alguma combinação de tabelas e visualizações – antes é necessário criar um focus a partir dos dados no banco de dados.
Tópico pai: Trabalhar com arquivos simples, tabelas de bancos de dados e focus

Importar dados de uma tabela de banco de dados

Para importar dados:
  • No Portrait Miner, navegue até à guia Banco de Dados e abra uma conexão do banco de dados. Para obter informações adicionais, consulte Configurar uma vinculação de banco de dados.
  • Clique duas vezes na tabela de banco de dados ou clique com o botão direito do mouse e escolha Abrir.

A caixa de diálogo Novo focus exibe:

Essa caixa de diálogo Novo focus apresenta uma visualização dos dados, incluindo os nomes e tipos dos campos.
  • No painel Salvar focus como, clique em Navegar e navegue [consulte Navegar para abrir ou salvar um arquivo, sessão ou tabela de banco de dados] para escolher a localização para o focus.
  • Clique em OK para criar o novo focus.

Se não deseja importar todos os campos da tabela, clique em Selecionar Campos. A caixa de diálogo Selecionar Campos exibe:

Todos os campos da fonte de dados externa que possam ser importados são inicialmente exibidos no painel Incluir.
  • Use os botões de seta para escolher os campos da tabela que quer incluir em seu focus.

    Os botões [image] e [image] movem campos realçados, enquanto os botões [image] e [image] movem todos os campos de um painel para outro.

    Use os botões [image] e [image] à direita da janela para organizar campos realçados no painel Incluir.

  • Quando concluir a seleção dos campos necessários, clique em OK para regressar à caixa de diálogo Novo focus.
Nota:
  • Não é possível importar uma coluna dessa forma se seu nome não for um identificador válido em FDL [consulte Expressões básicas].
  • Os campos de números reais com precisão superior a 15 dígitos em um banco de dados são tratados por padrão como campos de string no Portrait Miner. Ao mudar a preferência preservar tipos numéricos durante a importação, é possível forçá-los a serem tratados como campos reais (com precisão truncada).

Consulte também

Criar um focus de dados a partir de um arquivo de texto

Configurar uma vinculação de banco de dados

Importar dados consultando um banco de dados

É possível criar um focus de uma combinação de tabelas e visualizações em um banco de dados, se for especificada uma consulta SQL que selecione os dados que você necessita.
  • No Portrait Miner, clique duas vezes num arquivo SQL que contenha uma consulta que queira usar ou clique com o botão direito do mouse no arquivo e escolha Abrir.

Na caixa de diálogo Importar de Consulta, escolha uma localização para o focus que deseja criar; insira e modifique a consulta SQL se necessário e escolha uma vinculação do banco de dados [consulte Configurar uma vinculação de banco de dados].

Nota:
  • Se a caixa de diálogo Importar de Consulta for aberta usando um arquivo SQL, o Portrait Miner deriva um nome de focus a partir do nome do arquivo e usa os conteúdos do arquivo como a consulta SQL inicial. Porém, assim que a caixa de diálogo estiver aberta, o arquivo em si já não é relevante: na verdade, a consulta é executada na caixa de diálogo, não no arquivo.
  • O SQL é passado como está para o banco de dados, como uma instrução única; não é necessário um ponto e vírgula final (e pode ser de sintaxe inválida para alguns sistemas de bancos de dados).
  • Essa interface do usuário é uma forma de acessar a maior parte das funcionalidades fornecidas pelo comando de compilação de dados do Portrait Miner qsimportdb.

Consulte também

Sobre os assistentes do Portrait Miner

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados


Criar um focus a partir de um conjunto de dados SAS ou de terceiros

Para usar o Portrait Miner para analisar um conjunto de dados de terceiros é necessário criar um focus a partir do conjunto de dados. O Portrait Miner pode importar dados a partir de vários conjuntos de dados de terceiros, incluindo aqueles criados pelo SAS, SPSS e pelo Excel. (Consulte http://support.quadstone.com/info/requirements/ para uma lista completa de formatos suportados.)
Tópico pai: Trabalhar com arquivos simples, tabelas de bancos de dados e focus

Criar um focus a partir de um conjunto de dados SAS

  • No Portrait Miner, clique duas vezes no arquivo do conjunto de dados que pretende importar ou clique com o botão direito do mouse e escolha Abrir.

Na caixa de diálogo Importação de focus, é possível escolher os campos que se pretende importar (por padrão, todos os campos são importados) e escolher importar os metadados do campo e da etiqueta de valor para o focus criado. Além disso é possível alterar a localização do novo focus ou escolher substituir o focus de saída.

Nota:
  • Os metadados SAS são lidos a partir de um arquivo de catálogo SAS format.sas7bcat que deve estar presente na mesma pasta do conjunto de dados SAS de origem.
  • Essa interface do usuário é uma forma de acessar muitas das funcionalidades fornecidas pelo comando de compilação de dados qsimportstat do Portrait Miner.
  • É possível auditar [consulte Criar um Perfil e Auditoria de um focus] um conjunto de dados de terceiros sem antes criar um focus: simplesmente clique com o botão direito do mouse no conjunto de dados no Portrait Miner e escolha Auditoria.

Criar um focus a partir do Excel ou de outro conjunto de dados de terceiros

  • No Portrait Miner, clique duas vezes no arquivo do conjunto de dados que pretende importar ou clique com o botão direito do mouse e escolha Abrir.

Na caixa de diálogo Importação de focus, é possível escolher os campos que se pretende importar (por padrão, todos os campos são importados). Além disso é possível alterar a localização do novo focus ou escolher substituir o focus de saída.

Nota:
  • Essa interface do usuário é uma forma de acessar muitas das funcionalidades fornecidas pelo comando de compilação de dados qsimportstat do Portrait Miner.
  • É possível auditar [consulte Criar um Perfil e Auditoria de um focus] um conjunto de dados de terceiros sem antes criar um focus: simplesmente clique com o botão direito do mouse no conjunto de dados no Portrait Miner e escolha Auditoria.
  • É possível abrir uma pasta de trabalho no Excel clicando nela no Portrait Miner com o botão direito do mouse e escolhendo Enviar para o Excel.

Consulte também

Sobre os assistentes do Portrait Miner

Criando um focus de dados em um banco de dados

Criar um focus de dados a partir de um arquivo de texto

Exportar registros para um arquivo SAS ou para outros conjuntos de dados de terceiros.


Exportar registros para um arquivo de dados, tabela de banco de dados ou focus

É possível exportar registros de um focus para um arquivo simples, para uma tabela de banco de dados ou para outro focus do Decision Studio ou para um arquivo simples [consulte Exportar registros para um arquivo simples usando Portrait Miner], um outro focus [consulte Exportar os registros para um focus usando o Portrait Miner] ou para um conjunto de dados SAS ou de terceiros [consulte Exportar registros para um arquivo SAS ou para outros conjuntos de dados de terceiros.] usando o Portrait Miner.
Tópico pai: Trabalhar com arquivos simples, tabelas de bancos de dados e focus

Exportar registros do Decision Studio para um arquivo simples, para uma tabela de banco de dados ou focus

É possível exportar registros de um focus ou de segmentos selecionados em um visualizador gráfico para um arquivo simples, para uma tabela de banco de dados ou para outro focus.
  1. Faça uma das seguintes ações:
    • Na janela do Decision Studio escolha Focus>Exportar Dados.
    • No Visualizador de Perfil, Visualizador de Distribuição Cruzada, Visualizador de Mapas ou Construtor de Árvore de Decisão, selecione os segmentos [consulte Selecionar segmentos em uma exibição gráfica] que pretende exportar e escolha, em seguida, Segmentos ou clique em [image] na barra de ferramentas.

    É exibida a caixa de diálogo Exportar Registros:

  2. Clique no botão Navegar.
  3. Navegue até a localização [consulte Navegar para abrir ou salvar um arquivo, sessão ou tabela de banco de dados necessária e escolha um nome e o tipo para o conjunto de dados exportado.
  4. Se pretender escolher um subconjunto dos campos no focus, clique no botão Selecionar.

    É exibida uma caixa de diálogo de seleção de campo, com todos os campos inicialmente no painel Segmentos (a menos que alguns dos campos no focus tenham sido interpretados como campos de exportação [consulte Para configurar ou limpar uma interpretação de candidato de análise, categórica, geográfica, de exportação ou de chave], nesse caso, esses campos estão selecionados):

    Use os botões de seta entre os painéis Não Selecionado e Segmentos para escolher os campos a serem exibidos no conjunto de dados exportado.

    Os botões [image] e [image] movem campos realçados, enquanto os botões [image] e [image] movem todos os campos de um painel para outro.

    Use os botões [image] e [image] à direita da janela para organizar campos realçados no painel Segmentos.

  5. Se estiver criando um arquivo simples, clique opcionalmente em Formato para controlar o formato de exportação. [consulte Controlar o formato de exportação de arquivo simples].
  6. Clique em OK para exportar os dados.

Exportar registros para um arquivo simples usando Portrait Miner

Para exportar registros:
  • No Portrait Miner, clique com o botão direito do mouse no focus que pretende exportar e escolha Exportar>Como Texto.

Na caixa de diálogo Exportar Texto, é possível escolher os campos do focus que serão exportados e alterar o nome e a localização do arquivo de saída. Clique em Próximo para apresentar a guia Formato e escolha as opções de exportação, semelhantes às da caixa de diálogo Exportar Opções [consulte Controlar o formato de exportação de arquivo simples], para o arquivo de saída.

Nota:
  • É possível escolher quais campos exportar selecionando os nomes do campo ou escolhendo uma ou mais etiquetas [consulte Trabalhar com grupos de campo].
  • Essa interface do usuário é uma forma de acessar muitas das funcionalidades fornecidas pelo comando de compilação de dados qsexportflat do Portrait Miner.

Consulte também

Sobre os assistentes do Portrait Miner

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Controlar o formato de exportação de arquivo simples

No Decision Studio, se clicar em Formato na caixa de diálogo Exportar Registros ao exportar dados para um arquivo simples, aparece a caixa de diálogo Exportar Opções:

Aqui é possível especificar um separador de campo, uma string para usar no lugar do valor nulo [consulte O valor nulo], o formato a usar para valores de datas e se são usadas aspas simples ou duplas (ou nenhuma) nos valores de string. Se forem escolhidas as aspas duplas nos valores de string, existe a opção de usar essas aspas para todos os valores (em vez de usá-las somente quando o conteúdo do valor exigir).

Se for escolhido um arquivo de texto como seu arquivo de exportação, existe a opção de gerar um arquivo de descrição de dados simples (FDD) para acompanhá-lo. Se for escolhido um arquivo FDD como seu arquivo de exportação (nesse caso, o Portrait Miner cria automaticamente um ou mais arquivos de dados associados), a opção de gerar um arquivo FDD já será selecionada.

É possível incluir nomes de campos no topo de seus arquivos de dados marcando a opção Cabeçalhos de Coluna.

É possível exportar dados em um formato de largura fixa, marcando a opção Largura de Coluna Fixa. As larguras de colunas nesse formato dependem do tipo e do tamanho de cada campo.

Exportar registros para um arquivo SAS ou para outros conjuntos de dados de terceiros.

O Portrait Miner pode exportar dados em vários formatos estatísticos de terceiros, incluindo os do SAS, do SPSS e do Excel.

No Portrait Miner, clique com o botão direito do mouse no focus que pretende exportar e escolha Exportar>para Outro Programa.

Na caixa de diálogo Exportar para Outro Programa, é possível escolher os campos a exportar, para qual programa exportar e alterar a localização do arquivo de saída.

Nota:
  • É possível escolher quais campos exportar selecionando os nomes do campo ou escolhendo uma ou mais etiquetas [consulte Trabalhar com grupos de campo].
  • Se não forem especificados quais campos devem ser exportados, o Portrait Miner exporta todos os campos no focus.
  • Essa interface do usuário é uma forma de acessar muitas das funcionalidades fornecidas pelo comando de compilação de dados qsexportstat do Portrait Miner.

Consulte também

Sobre os assistentes do Portrait Miner

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Exportar os registros para um focus usando o Portrait Miner

É possível exportar um subconjunto dos campos ou registros a partir de um focus existente para um novo focus.

No Portrait Miner, clique com o botão direito do mouse no focus que pretende exportar e escolha Exportar>Como focus. Na caixa de diálogo Exportar como focus, é possível escolher os campos a exportar e onde salvar os focus exportados. Também é possível selecionar um subconjunto de registros no focus usando uma expressão FDL [consulte Expressões].

Nota:
  • É possível escolher quais campos exportar selecionando os nomes do campo ou escolhendo uma ou mais etiquetas [consulte Trabalhar com grupos de campo].
  • Se não forem especificados quais campos devem ser exportados, o Portrait Miner exporta todos os campos no focus.
  • Essa interface do usuário é uma forma de acessar muitas das funcionalidades fornecidas pelo comando de compilação de dados qsimportfocus do Portrait Miner.

Consulte também

Sobre os assistentes do Portrait Miner

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados


Sobre combinar focus

O Portrait Miner fornece duas formas de combinar os campos de vários focus para criar um novo focus, sendo a primeira ("junção de focus") uma variante da junção esquerda. É possível usar a junção de focus no Portrait Miner [consulte Para juntar campos de um focus a outro focus por meio do Portrait Miner] ou por meio do comando de compilação de dados qsjoin do Portrait Miner.

O segundo método usa o Decision Studio para importar campos de um focus em uma variante da junção esquerda de duas tabelas.

Também é possível mesclar os registros de vários focus no Portrait Miner [consulte Mesclar registros de dois focus] ou por meio do comando de compilação de dados qsmerge do Portrait Miner.

Consulte também

dblookup

Mesclar registros de dois focus

Tópico pai: Trabalhar com arquivos simples, tabelas de bancos de dados e focus


Para juntar campos de um focus a outro focus por meio do Portrait Miner

Dados dois focus que compartilham campos-chave do mesmo tipo e com o mesmo nome, é possível juntar os campos selecionados a partir de um focus para outro, para criar um novo focus, contanto que ambos os focus sejam classificados [consulte Para classificar um focus] por campos-chave (de acordo com a ordem de agrupamento padrão do Portrait Miner).
Para juntar campos de um focus a outro:
  • No Portrait Miner, clique com o botão direito do mouse no focus inicial e escolha Combinar>Juntar Campos.

Na caixa de diálogo Juntar Campos, é possível escolher o focus secundário, a partir do qual os campos serão adicionados, e até três campos-chave usados para juntar os campos selecionados ao focus primário. Também é possível alterar a localização do novo focus ou, em vez de criar um novo focus, escolher substituir um focus de saída criado anteriormente.

Nota:
  • A operação de junção é essencialmente uma junção esquerda (com seu focus inicial sendo a tabela à esquerda). No entanto, se existir um cliente com mais de um registro no focus inicial, o Portrait Miner coincide os registros desse cliente com registros sucessivos para o mesmo cliente em outro focus. O número de registros no novo focus é sempre o mesmo número de registros do focus inicial.
  • Os campos-chave nos dois focus devem ser campos de string, campos de data ou campos numéricos.
  • É possível escolher quais campos adicionar, selecionando os nomes do campo ou escolhendo uma ou mais etiquetas [consulte Trabalhar com grupos de campo].
  • Essa interface do usuário é uma forma de acessar muitas das funcionalidades fornecidas pelo comando de compilação de dados qsjoin do Portrait Miner.

Consulte também

Sobre os assistentes do Portrait Miner

Sobre combinar focus

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Tópico pai: Trabalhar com arquivos simples, tabelas de bancos de dados e focus


Juntar campos de um focus a outro focus usando o Decision Studio

Se dois focus compartilharem campos-chave do mesmo nome e tipo, é possível juntar os campos selecionados de um focus ao outro para criar um novo focus. Para isso, é necessário garantir que os dois focus sejam classificados por campos-chave, de acordo com a ordem de agrupamento padrão do Portrait Miner.
  1. Abra o primeiro focus no Decision Studio e escolha Focus>Importar Campos.
  2. Navegue [consulte Navegar para abrir ou salvar um arquivo, sessão ou tabela de banco de dados] até o segundo focus e clique em Importar.

    É exibida a caixa de diálogo Importar Campos:

  3. No painel Selecione juntar campo-chave, escolha os campos-chave correspondentes ao primeiro focus e ao segundo focus.
  4. Clique em Selecionar Campos no painel Selecionar Campos para selecionar os campos que pretende incluir do segundo focus. No mínimo, é necessário excluir o campo-chave externo para a junção.

    É exibida a caixa de diálogo Selecionar Campos, com todos os campos do segundo focus inicialmente no painel Incluir:

    Use os botões de seta entre os painéis Excluir e Incluir para escolher os campos que pretende juntar.

    Os botões [image] e [image] movem campos realçados, enquanto os botões [image] e [image] movem todos os campos de um painel para outro.

    Use os botões [image] e [image] à direita da janela para organizar campos realçados no painel Incluir.

  5. De volta à caixa de diálogo Importar Campos clique em OK.
Nota:
  • A operação de junção é essencialmente uma junção esquerda (com o primeiro focus sendo a tabela à esquerda). No entanto, se existir um cliente com mais de um registro no segundo focus, o Decision Studio considera somente o primeiro registro desse cliente. Por isso, ao juntar campos a um focus usando o Decision Studio, o número de registros no focus sempre permanece o mesmo.
  • O Decision Studio exclui automaticamente qualquer campo no segundo focus que apresente o mesmo nome de um campo no primeiro focus.
  • Os campos-chave nos dois focus devem ser campos de string, campos de data ou campos numéricos.

Consulte também

Sobre combinar focus

Para juntar campos de um focus a outro focus por meio do Portrait Miner

Tópico pai: Trabalhar com arquivos simples, tabelas de bancos de dados e focus


Mesclar registros de dois focus

Dados dois focus com campos do mesmo tipo, com o mesmo nome e registros classificados [consulte Para classificar um focus] por campos-chave (de acordo com a ordem de agrupamento padrão do Portrait Miner), é possível mesclar os registros nos focus para criar um novo focus que contém os registros de ambos os focus. O novo focus é classificado da mesma forma que os focus originais.

No Portrait Miner, clique com o botão direito do mouse no focus primário e escolha Combinar>Mesclar Registros.

Na caixa de diálogo Mesclar Registros, escolha o focus secundário e especifique os campos-chave. Também é possível escolher a localização do focus de saída.

Nota:
  • Por padrão, um registro do focus secundário que apresente as mesmas chaves que um registro no focus primário é descartado. É possível alterar esse comportamento selecionando a caixa apropriada na caixa de diálogo.
  • Para mesclar dois focus, é necessário que os campos contenham tipos de dados compatíveis.
  • Essa interface do usuário é uma forma de acessar muitas das funcionalidades fornecidas pelo comando de compilação de dados qsmerge do Portrait Miner.

Consulte também

Sobre os assistentes do Portrait Miner

Sobre combinar focus

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Tópico pai: Trabalhar com arquivos simples, tabelas de bancos de dados e focus


Configurar uma vinculação de banco de dados

Para poder se conectar a um banco de dados, antes é necessário configurar uma vinculação de banco de dados.
  1. No Portrait Miner, na guia Bancos de dados, clique em Nova Conexão.

    É exibida a caixa de diálogo Editar Conexão ao Banco de Dados.

  2. Digite o DSN (nome da fonte de dados) para o banco de dados.

    Peça a seu administrador de sistema se não souber o que é isso.

  3. Digite o nome de usuário e senha que usou para se conectar ao banco de dados.
  4. Clique em OK.

    É exibida uma nova vinculação de banco de dados na lista dos bancos de dados disponíveis no Portrait Miner.

Nota:
  • O Portrait Miner armazena suas conexões de bancos de dados em um disco em formato encriptado. Uma vez configurada uma vinculação de banco de dados, não é necessário voltar a digitar seu nome de usuário e senha para o banco de dados a não ser que mudem. Se for necessário corrigir seus detalhes de vinculação, selecione a vinculação no painel Conexões de Banco de Dados Disponíveis, da guia Bancos de dados e clique em Editar a Tabela de Referência Cruzada.
  • Seu administrador de sistema pode ter configurado um banco de dados "parcial" para você, somente com o DSN. Antes de ser possível se conectar ao banco de dados, é necessário completar a vinculação ao banco de dados: selecione a vinculação parcial ao banco de dados e clique em Editar a Tabela de Referência Cruzada para digitar seu nome de usuário e senha.
  • Essa interface do usuário é uma forma de acessar a maior parte das funcionalidades fornecidas pelo comando de compilação de dados do Portrait Miner, qsdbaccess.

Consulte também

Como o Portrait Miner importa tipos de banco de dados

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Tópico pai: Trabalhar com arquivos simples, tabelas de bancos de dados e focus


Como o Portrait Miner importa tipos de banco de dados

Tópico pai: Trabalhar com arquivos simples, tabelas de bancos de dados e focus

Importar para o Portrait Miner a partir de um banco de dados

O Portrait Miner mapeia os seguintes tipos de bancos de dados em seus tipos de dados, baseados no tamanho do tipo de banco de dados e nas configurações de preferências dos Bancos de dados.
Tipo de banco de dados | Escala | Precisão | representar integers grandes como strings | preservar tipos numéricos durante a importação | tipo de campo do Portrait Miner
char, char2, varchar, varchar2, nchar, nchar2, nvarchar, nvarchar2 |  |  |  |  | string
date, time, timestamp, datetime, smalldatetime |  |  |  |  | date
int, integer, tinyint, smallint, byteint, bit |  |  |  |  | inteiro
bigint |  |  | false false true | true false | real string string
decimal, dec, numeric, number | < 0 | 15 > 15 > 15 |  | true false | real real string
decimal, dec, numeric, number | 0 | 0 10 > 10 [image] 15 > 15 > 15 > 10 | false false false true | true false | real inteiro real real string string
float, double, real |  |  |  |  | real
decimal, dec, numeric, number | > 0 | 15 > 15 > 15 |  | true false | real real string
money |  |  |  | true false | real string
smallmoney |  |  |  |  | real
Nota:
  • Nas linhas marcadas com [image], pode haver uma perda de precisão.
  • Nas linhas marcadas com [image], os valores demasiado grandes para armazenar como inteiros serão convertidos em Nulos.

Consulte também

representar integers grandes como strings

preservar tipos numéricos durante a importação

Exportar do Portrait Miner para um banco de dados

Os tipos de bancos de dados que o Portrait Miner exporta dependem do banco de dados de destino e do driver ODBC. O Portrait Miner sugere um tipo apropriado para o banco de dados que você especificar, enquanto o driver ODBC interpreta essa sugestão em um dos tipos nesse banco de dados.

Consulte também

Configurar uma vinculação de banco de dados


Usar o Data Build Manager para importar, processar e exportar dados

O Data Build Manager é um aplicativo do Portrait Miner que suporta a preparação de dados e implementação de modelo.

Para compilar um focus ou implementar um modelo, normalmente é usada uma sequência de comandos de compilação de dados [consulte Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados] e outras operações. Fazer isso manualmente demora algum tempo e é fácil cometer erros. Também é possível preferir executar uma compilação de dados normal ou um processo de implementação sem supervisão, talvez durante a noite. Se algo sair errado (como ficar sem espaço no disco), provavelmente você vai pretender reparar o problema e continuar de onde estava, em vez de começar tudo de novo. Da mesma forma, se as operações necessárias para compilações sucessivas se sobrepuserem em certa medida, é possível economizar tempo de processamento fazendo essas operações apenas uma vez. Mas é difícil seguir as dependências entre operações e fácil esquecer que operações já foram realizadas.

O Data Build Manager usa um arquivo especial chamado "plano de compilação" que descreve como construir um conjunto de dados de análise ou implementar um modelo. O plano de compilação contém vários "destinos" com dependências entre eles e as sequências de operações necessárias para compilar esses destinos.

Abrir um plano de compilação (um arquivo .qsb):
  • No Portrait Miner, clique duas vezes no arquivo ou clique com o botão direito do mouse no arquivo e escolha Abrir.

É possível examinar os detalhes do plano de compilação ao clicar no painel Compilar plano e visualizar as descrições no painel à direita.

A hierarquia (ou "árvore") de elementos no painel Compilar plano lembra a visualização do sistema de arquivos no Portrait Miner ou Windows Explorer e é possível expandir ou recolher partes da visualização de forma semelhante. Use Opções>Expandir árvore (resp. Opções>Recolher árvore) para mostrar a hierarquia totalmente expandida (resp. recolhida).

No topo da hierarquia está um elemento representando o próprio plano de compilação. Outros elementos de particular interesse são os alvos (marcados com [image] ou similar) e os parâmetros (marcados com [image]).

Para atribuir um valor a um parâmetro, selecione o parâmetro no painel Compilar plano e edite o valor no painel Parâmetro à direita.

Após configurar os parâmetros apropriadamente, execute seu plano de compilação clicando em Compilar. É exibida uma janela de progresso. Enquanto o trabalho é executado, é possível clicar em Parar para interromper a execução do plano de compilação. Assim que o trabalho for concluído, clique em Pronto para fechar a janela de progresso.

Nota:
  • O plano de compilação usa um formato de arquivo baseado em XML. Para mais informação sobre o Data Build Manager e o formato dos planos de compilação, consulte Usar o Data Build Manager.
  • O Data Build Manager é uma forma de acessar a funcionalidade fornecida pelo comando de compilação de dados do Portrait Miner, qsbuild.

Consulte também

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

XML no Portrait Miner

Tópico pai: Trabalhar com arquivos simples, tabelas de bancos de dados e focus


Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Além de aplicativos como o Portrait Miner e Decision Studio, o Portrait Miner inclui um pacote abrangente de utilitários de linha de comando chamados comandos de compilação de dados do Portrait Miner. É possível usar os comandos de compilação de dados para diversas tarefas:
  • Importação/exportação de dados entre focus, arquivos simples e tabelas de bancos de dados
  • Processar dados no focus (classificar, derivar, medir, etc.)
  • Juntar focus
  • Gerenciar arquivos de focus (copiar, mover, renomear e excluir)
  • Produzir relatórios

Os comandos de compilação de dados são particularmente úteis para automatizar processos de compilação de dados complexos, pois é possível combiná-los em scripts do shell UNIX ou arquivos em lotes do Windows.

Consulte Referência de comando de compilação de dados do Portrait Miner e do TML para informação detalhada sobre cada comando.

Nota: Para usar os comandos de compilação de dados, é necessário ter acesso à linha de comando para o Portrait Miner. Peça a seu administrador para configurar seu caminho de comando para incluir o diretório que contém os comandos.

Consulte também

Usar o Data Build Manager para importar, processar e exportar dados
Tópico pai: Trabalhar com arquivos simples, tabelas de bancos de dados e focus


Trabalhar com o Decision Studio

  • Trabalhar com as Ferramentas do Decision Studio
  • Trabalhar com listas e dados tabulares no Decision Studio
  • Trabalhar com o Decision Studio


Trabalhar com as Ferramentas do Decision Studio

  • Ferramentas do Decision Studio
  • Relacionamentos das ferramentas
  • Conectar e desconectar ferramentas
  • Para maximizar o espaço de tela para uma ferramenta do Decision Studio
Tópico pai: Trabalhar com o Decision Studio


Ferramentas do Decision Studio

Essas ferramentas do Decision Studio estão disponíveis para visualizar, segmentar e modelar conjuntos de dados de clientes:
Ferramenta | Objetivo
Table Viewer
  • Visualizar seu focus, ao nível de registros individuais de cliente
  • Derivar campos usando FDL
Binning Editor | Agrupar registros de clientes em gamas de valores ou categorias em um campo
Crosstab Viewer | Visualizar dados do resumo em formato tabular
Crossdistribution Viewer | Visualizar dados do resumo como um gráfico de crossdistribution com uma variável de um para três
Profile Viewer | Visualizar dados do resumo em um conjunto de segmentos de uma variável
Map Viewer | Visualizar dados do resumo em um mapa geográfico ou predefinido
Decision Tree Builder | Compilar as segmentações da árvore de decisão de seu conjunto de dados de clientes
Construtor de Scorecard | Compilar modelos scorecard de seu conjunto de dados de cliente
Construtor de Cluster | Compilar modelos de agregação de seu conjunto de dados de seu cliente

Para iniciar uma ferramenta do Decision Studio, escolha seu nome no menu Ferramentas ou clique no botão correspondente na barra de tarefas.

Tópico pai: Trabalhar com as Ferramentas do Decision Studio


Relacionamentos das ferramentas

Cada ferramenta do Decision Studio [consulte Ferramentas do Decision Studio] necessita uma fonte de dados, sejam dados a exibir ou dados para basear um modelo. Normalmente, a fonte de dados para uma ferramenta é o focus atualmente aberto, tendo em conta quaisquer seleções de registros [consulte Selecionar registros de clientes] que estejam no local.

Também é possível fazer com que uma ou mais ferramentas sigam outra [consulte Conectar e desconectar ferramentas], assim, sempre que selecionar um segmento [consulte Selecionar segmentos em uma exibição gráfica] na ferramenta líder, as ferramentas seguidoras tratam esse segmento como sua fonte de dados.

É possível a uma ferramenta seguidora liderar outra ferramenta. É possível ver como as ferramentas estão relacionadas umas com as outras no painel de hierarquia de ferramentas na janela do Decision Studio, que está na guia 'Focus' no lado esquerdo da janela principal. Note que essa não é a guia padrão e normalmente está oculta:

Nesse exemplo, o Visualizador de Dados 5 e o Visualizador de Perfil 6 usam o focus "DBUSA" como suas fontes de dados. O Visualizador de Distribuição Cruzada 4 está seguindo o Visualizador de Perfil 6.

Nota:
  • Quando nenhum segmento está graficamente selecionado em uma ferramenta (sempre é o caso se a ferramenta for uma instância do Visualizador de Dados, Construtor de Scorecard ou Construtor de Cluster), a fonte de dados da própria ferramenta é usada como fonte de dados de todas as suas ferramentas seguidoras.
  • Assim como é possível a um focus, a saída de uma ferramenta também pode ter binnings associados. É possível modificar os binnings associados a saída de uma ferramenta ligando um Binning Editor a essa saída [consulte Conectar e desconectar ferramentas]. Mas se forem selecionados segmentos diferentes na ferramenta (para que a saída se altere), o Decision Studio descarta quaisquer binnings que tenham sido criados.

Consulte também

Mostrar mais detalhes em um segmento ou gráfico selecionado
Tópico pai: Trabalhar com as Ferramentas do Decision Studio

Visualizar a hierarquia de ferramentas seletivamente

  • Clique em um símbolo [image] (recolhido) ou [image] (expandido) para expandir ou recolher parte da visualização da hierarquia de ferramentas.

Trazer uma janela de ferramenta para primeiro plano

Clique duas vezes no nome da ferramenta no painel de hierarquia de ferramentas ou clique com o botão direito do mouse no nome da ferramenta e escolha Trazer para Frente.


Conectar e desconectar ferramentas

Tópico pai: Trabalhar com as Ferramentas do Decision Studio

Conectar uma ferramenta aberta à saída de outra ferramenta

No topo direito de cada barra de ferramentas existe um menu suspenso chamado Guia, onde outra ferramenta pode ser selecionada como fonte de dados. Se preferir, no painel de hierarquia de ferramentas [consulte Relacionamentos das ferramentas] da janela do Decision Studio, arraste o ícone representando a ferramenta seguidora desejada e solte-o sobre o ícone que representa a ferramenta líder desejada.

Abrir uma nova ferramenta seguindo outra ferramenta

No painel de hierarquia de ferramentas [consulte Relacionamentos das ferramentas] da janela do Decision Studio, clique para selecionar o nome da ferramenta líder desejada.

Quaisquer ferramentas iniciadas estão subsequentemente vinculadas à ferramenta selecionada.

Para reverter ao comportamento padrão para novas ferramentas, selecione o focus no topo do painel de hierarquia de ferramentas.

Nota: Também é possível iniciar uma ferramenta vinculada ao clicar com o botão direito do mouse em um possível líder no painel de hierarquia de ferramentas e escolher o possível seguidor no menu Busca detalhada em.

Consulte também

Mostrar mais detalhes em um segmento ou gráfico selecionado

Quebrar uma vinculação entre ferramentas

Faça uma das seguintes ações:
  • No menu suspenso Guia na barra de ferramentas selecione Nenhum.
  • No painel de hierarquia de ferramentas [consulte Relacionamentos das ferramentas] da janela do Decision Studio, arraste o ícone representando a ferramenta seguidora e solte sobre o ícone que representa o focus.
  • Vincule a ferramenta seguidora a uma outra ferramenta líder.
  • Feche a ferramenta líder.

    A ferramenta que estava seguindo fica então vinculada ao focus ou ferramenta que fornecia a fonte de dados à ferramenta líder original.

Nota: Se for arrastado um ícone de ferramenta para um local diferente na hierarquia de ferramentas, quaisquer ferramentas vinculadas a essa ferramentas continuarão a segui-la.


Para maximizar o espaço de tela para uma ferramenta do Decision Studio

Escolha Exibir ou pressione F11

Isso maximiza a janela e oculta a barra de ferramentas e outros elementos da interface do usuário, para aumentar o espaço disponível para visualizar a área principal da janela.

Repetir a ação para voltar à visualização original.

Tópico pai: Trabalhar com as Ferramentas do Decision Studio


Trabalhar com listas e dados tabulares no Decision Studio

  • Classificar em listas e tabelas
  • Exportar dados tabulares do Decision Studio
  • Configurar o formato de exibição para valores numéricos e de datas
Tópico pai: Trabalhar com o Decision Studio


Classificar em listas e tabelas

Na maior parte das tabelas no Decision Studio (sendo exceções especiais as visualizações no Visualizador de Dados ou no Visualizador de Crosstab), é possível reordenar as linhas de várias formas, clicando com o botão direito do mouse em um cabeçalho de coluna e escolhendo uma opção de classificação.

Da mesma forma, na maior parte das listas no Decision Studio, é possível reordenar itens de lista, clicando com o botão direito do mouse no painel de lista.

Na maioria dos casos, estão disponíveis três opções de classificação padrão: não classificado (ou seja, a ordem padrão), crescente e decrescente; mas podem existir muitas funções adicionais que dependem do tipo de dado na coluna da lista.

Nota:
  • Na maior parte dos locais, se clicar repetidamente (com o botão esquerdo do mouse) no cabeçalho de uma coluna da tabela que tem opções de classificação, o Decision Studio irá alternar entre as opções disponíveis. Se existirem várias opções, normalmente é mais fácil clicar com o botão direito do mouse e escolher no menu; mas para colunas com somente três opções de classificação padrão, a classificação de linhas pretendida está, no máximo, a dois cliques.
  • Na janela do Decision Studio, a coluna Interpretações apresenta opções para classificar em cada tipo possível de interpretação. Ao escolher Classificar por Categórico, por exemplo, o Decision Studio exibe campos com binnings categóricos antes de outros campos.
  • A coluna Etiquetas de Usuário na janela principal não pode ser classificada.
  • Classificar linhas em uma tabela ou itens em uma lista afeta, normalmente, a forma como a informação é exibida no contexto atual. Uma exceção consiste em reordenar categorias [consulte Reordenar categorias] em um binning categórico: qualquer ferramenta do Decision Studio que usa o binning mostra os bins na ordem especificada no Binning Editor.

Consulte também

Para classificar um focus
Tópico pai: Trabalhar com listas e dados tabulares no Decision Studio


Exportar dados tabulares do Decision Studio

É possível usar Editar>Copiar para copiar dados tabulares das ferramentas do Decision Studio para a área de transferência, como faria em outros aplicativos do Windows. Existem também quatro variantes da operação padrão de cópia para a área de transferência:
Opção | Objetivo
Copiar Todas as Tabelas | Copiar células de todos os painéis com guias, em vez de apenas do painel atual.
Copiar sem Cabeçalhos | Omite cabeçalhos de linha e de coluna.
Copiar com Rótulos Repetidos | Repetir cabeçalhos para cada linha e coluna (essa opção pode ser útil para criar tabelas dinâmicas no Excel).
Copiar Segmentos Expandidos | Copiar os dados no formato de lista de duas colunas, em vez de em um formato tabular.

Também é possível selecionar células em uma visualização tabular e arrastar os dados diretamente para aplicativos do Windows (como o Microsoft Excel) que podem ler dados em um formato tabular.

Também é possível copiar visualizações tabulares e dados de tabela de referência cruzada [consulte Tabelas de referência cruzada como base para segmentação e visualização de dados] do Decision Studio diretamente para o Microsoft Excel e se tiver dados tabulares no Decision Studio que pretenda compartilhar com colegas é possível enviá-los por e-mail.

Tópico pai: Trabalhar com listas e dados tabulares no Decision Studio

Selecionar regiões de uma tabela

É possível selecionar uma ou mais regiões retangulares em uma visualização tabular como faria em outros aplicativos do Windows. Na maior parte das visualizações tabulares, é possível também clicar em cabeçalhos para selecionar linhas ou colunas inteiras da tabela.

Exportar dados tabulares para o Microsoft Excel

É possível copiar visualizações tabulares ou dados da tabela de referência cruzada subjacentes para o Excel:
  • Para copiar uma visualização tabular para o Excel, faça uma das seguintes opções:
    • No Visualizador de Dados, escolha Arquivo>Vista para Excel.
    • No Construtor de Árvore de Decisão, Construtor de Scorecard ou no Construtor de Cluster, escolha Arquivo>Exportar>Vista para Excel.
    • Clique em [image] na barra de ferramentas.
  • Para copiar dados da tabela de referência cruzada do Visualizador de Crosstab ou do Visualizador de Perfil para o Excel, escolha Arquivo>Exportar>Tabela de Referência Cruzada para Excel ou clique em [image] na barra de ferramentas.
Nota:
  • É criada uma nova pasta de trabalho ao exportar dados para o Excel.
  • Se forem selecionadas células em uma visualização tabular [consulte Selecionar regiões de uma tabela], o Decision Studio exportará somente essas células para o Excel. Caso contrário, toda a tabela ou tabela de referência cruzada é exportada.
  • Ao escolher Vista como Excel Link em vez de Vista para Excel ou Tabela de Referência Cruzada como Excel Link em vez de Tabela de Referência Cruzada para Excel, é criado um link dinâmico, para que quaisquer mudanças na visualização tabular ou na tabela de referência cruzada sejam automaticamente propagadas para o Excel.


Configurar o formato de exibição para valores numéricos e de datas

  1. Na janela do Decision Studio, escolha Editar>Visualizar Preferências.

    É exibida a caixa de diálogo Formato. Um de seus cinco painéis com guias controla os formatos de exibição para valores numéricos e de data:

    Painel | Descrição
    Exibição de Dados | O número de casas decimais para números exibidos; o alinhamento de números; se os zeros à direita são retirados quando exibem frações decimais; se é usado o separador de milhares (específico de localidade) ao exibir números; se as datas são exibidas no formato american (MM/DD/AAAA), european (DD/MM/AAAA) ou YMD (AAAA/MM/DD); se as horas são exibidas de acordo com o relógio de 12 ou de 24 horas
  2. Clique em OK, para confirmar as alterações e fechar a caixa de diálogo.
Nota: Suas configurações são aplicadas em sua sessão atual e nas futuras sessões do Decision Studio, Portrait Miner. No entanto, elas não se aplicam à importação e exportação de arquivos simples ou à avaliação de expressões FDL.

Consulte também

Configurar opções globais para exibições gráficas
Tópico pai: Trabalhar com listas e dados tabulares no Decision Studio


Trabalhar com o Decision Studio

  • Orientar uma exibição gráfica usando o mouse
  • Selecionar segmentos em uma exibição gráfica
  • Exportar visualizações gráficas do Decision Studio
Tópico pai: Trabalhar com o Decision Studio


Orientar uma exibição gráfica usando o mouse

Arraste a visualização gráfica ou a árvore de decisão usando um dos três botões do mouse:
  • Girar o gráfico, arrastar com o botão esquerdo do mouse.
  • Mover o gráfico de um lado para o outro ou verticalmente, arrastar com o botão direito do mouse.
  • Mover o gráfico na sua direção ou afastá-lo, arrastar para cima/baixo com o botão do meio do mouse.
Nota:
  • Se seu mouse tem somente dois botões, é possível emular o botão do meio do mouse mantendo a tecla Alt pressionada enquanto pressiona o botão esquerdo do mouse.
  • Ao mover uma árvore de decisão com o botão direito do mouse, arraste sobre o fundo, para evitar o menu pop-up exibido ao clicar com o botão direito em um segmento.
Tópico pai: Trabalhar com o Decision Studio

Restaurar a visualização original

Escolha Exibir>Página Inicial ou clique em [image] na barra de ferramentas.

Nota:

No Visualizador de Mapas, se a opção de menu Exibir>Auto estiver marcada, a visualização original poderá ter sido de cima, em vez da visualização que corresponde à opção Exibir>Página Inicial.

Visualizar um gráfico de mapa de cima

Escolha Exibir>Cima ou clique em [image] na barra de ferramentas.

Ampliar segmentos selecionados em uma árvore de decisão

  1. Selecione os segmentos [consulte Selecionar segmentos em uma exibição gráfica] em que está interessado.
  2. Escolha Exibir>Fazer Zoom sobre a Seleção ou clique em [image] na barra de ferramentas. Se preferir, é possível clicar com o botão direito do mouse em um dos segmentos selecionados e escolher Fazer Zoom sobre a Seleção.

    O Construtor de Árvore de Decisão amplia (ou reduz) para que os segmentos selecionados e seus subsegmentos fiquem visíveis.

Nota:

Se nenhum segmento for realçado, Exibir>Fazer Zoom sobre a Seleção (ou [image]) tem o mesmo efeito que Exibir>Página Inicial (ou [image]).


Selecionar segmentos em uma exibição gráfica

É possível selecionar segmentos em exibições gráficas no Binning Editor, Visualizador de Perfil, Visualizador de Distribuição Cruzada, Visualizador de Mapas e Construtor de Árvore de Decisão. É possível usar os segmentos selecionados como fonte de dados para ferramentas vinculadas [consulte Relacionamentos das ferramentas] e é possível serem usados para derivar campos [consulte Derivar um campo de uma segmentação gráfica], descrevendo-os.
Tópico pai: Trabalhar com o Decision Studio

Selecionar apenas um segmento

Clique no segmento para selecioná-lo.
Nota:
  • Se o segmento já estiver selecionado como parte de um grupo de segmentos, clique primeiro no fundo para limpar as seleções existentes.
  • No Visualizador de Mapas, para selecionar um segmento representado por uma vinculação de linha (ao contrário de um bloco), clique na seta no meio da vinculação de linha.

Limpar seleções ou estendê-las para mais de um segmento

Faça uma das seguintes ações:
  • Mantenha pressionada a tecla CTRL no teclado e clique em um segmento.

    O segmento fica selecionado caso já não estivesse antes e vice-versa.

  • Mantenha pressionada a tecla CTRL no teclado e arraste com o botão direito do mouse para criar um retângulo "elástico".

    Ao soltar o botão do mouse, os segmentos inteiros ou parciais que ficam dentro dos retângulos são selecionados, caso já não estivessem antes e vice-versa.

Nota: No Visualizador de Mapas, é possível selecionar blocos ou conexões de linha, mas não é possível selecionar ambos. Se for arrastado um retângulo "elástico" sobre uma região contendo blocos e conexões de linha, apenas os blocos serão selecionados.


Exportar visualizações gráficas do Decision Studio

Se tiver uma visualização gráfica no Visualizador de Perfil, Visualizador de Distribuição Cruzada, Visualizador de Mapas, Construtor de Árvore de Decisão ou no Construtor de Scorecard e gostaria de incluí-la em um relatório ou compartilhar a visualização com colegas, é possível salvar a visualização como um arquivo.
Tópico pai: Trabalhar com o Decision Studio

Salvar uma visualização gráfica para um arquivo

No Visualizador de Perfil, Visualizador de Distribuição Cruzada, Visualizador de Mapas, Construtor de Árvore de Decisão ou no Construtor de Scorecard, escolha Arquivo>Exportar>Exibir como Imagem e procure [consulte Navegar para abrir ou salvar um arquivo, sessão ou tabela de banco de dados] uma localização na qual salvar sua visualização gráfica.

O Decision Studio exporta sua imagem como um arquivo JPEG.

Nota:
  • O Decision Studio salva uma visualização gráfica com o mesmo tamanho que aparece no visualizador ou na ferramenta de modelagem.
  • Para usar uma visualização gráfica salva em um relatório, importe ou coloque o arquivo em seu documento de destino.
  • No Visualizador de Perfil, também é possível usar Arquivo>Exportar>Exibir como HTML, para criar uma página na web com a visualização atual.


Trabalhar com o PSS Connector

  • Introdução
  • Extensões do Portrait Miner
  • Extensões do Decision Studio
  • Autenticação
  • Extensões da linha de comando
  • Exportar regras a partir da Interface do Usuário do Portrait Miner
  • Exportar Regras em Lote


Introdução

O conector Portrait Shared Services (PSS) suporta a integração entre o Portrait Miner e outro Conjunto de produtos Portrait , incluindo: Portrait Dialogue, Portrait Interaction Optimizer e Portrait Explorer.

Para obter informações sobre como instalar o PSSConnector, consulte Instalar o PSSConnector na Guia de Administração do Miner.

Tópico pai: Trabalhar com o PSS Connector


Extensões do Portrait Miner

As seguintes extensões estão disponíveis no Portrait Miner.

  • Na barra de ferramentas do Portrait Miner, o botão Gerenciar conexão para o Portrait Shared Services permite que o usuário faça logon ou logoff do Portrait Shared Services. Com um servidor do Portrait Customer Analytics baseado no Windows, sua conexão aos Portrait Shared Services é estabelecida usando a Autenticação do Windows, se possível. Para se conectar usando uma conta diferente, é necessário fazer logoff e, em seguida, voltar a fazer o logon usando as credenciais de conta apropriadas.
  • Na barra de ferramentas, o botão Gerenciar regras no Portrait Shared Repository permite ao usuário visualizar a lista de regras analíticas que foram publicadas para o repositório. É necessário selecionar um domínio lógico de PSS e, a seguir, é possível visualizar as regras publicadas para esse domínio. É possível exportar uma regra novamente para o sistema de arquivo do servidor como um arquivo QMML, usando a opção do botão direito do mouse Salvar como em uma regra.
  • Ao selecionar um arquivo .qmml no Miner, a opção do botão direito do mouse em Publicar regra para o Portrait Shared Repository publicará o modelo QMML como uma regra para o Portrait Shared Repository. É solicitado um nome, tipo e descrição para a regra e o nome do domínio lógico de PSS onde será publicada.

Os aplicativos da barra de ferramentas encontram-se igualmente disponíveis por meio do menu Lançar do Portrait Miner.

Tópico pai: Trabalhar com o PSS Connector


Extensões do Decision Studio

As extensões do Portrait Shared Services para o Decision Studio permitem ao usuário publicar um campo derivado como uma regra para o Portrait Shared Repository, a partir de onde é possível ser usado por outros aplicativos.

As regras podem ser publicadas somente a partir do Visualizador de Dados.

O Visualizador de Dados do Decision Studio também fornece o aplicativo Gerenciar conexão ao Portrait Shared Services, para permitir que o usuário faça o logon e o logoff usando um nome de usuário e uma senha explícitos ou usando a Autenticação do Windows, sempre que possível. O aplicativo fornece a mesma funcionalidade que o Portrait Miner.

O Visualizador de Crosstab do Decision Studio permite publicar a tabela de referência cruzada atual para o PSS. Estas especificações da tabela de referência cruzada podem, então, ser usadas ao gerar relatórios a partir do aplicativo Portrait Explorer application em Marketing HQ.

Tópico pai: Trabalhar com o PSS Connector


Autenticação

É necessário ser autenticada com os Portrait Shared Services de forma a gerenciar, publicar ou recuperar regras armazenadas no Portrait Shared Repository.

Se sua conta de logon do Windows estiver configurada como conta de Autenticação do Windows no aplicativo de Administrador do Portrait Dialogue, os aplicativos Miner o irão autenticar automaticamente e não é necessário fazer nada em específico para fazer logon. Essas contas também não necessitam de nenhuma opção -username ou -password para os utilitários de linha de comando.

Se está usando uma conta de logon que não foi configurada para usar a Autenticação do Windows, deve fazer logon explicitamente no Portrait Miner. Os aplicativos Portrait Miner e Decision Studio irão pedir automaticamente suas credenciais de logon se já não estiver conectado. Os utilitários de linha de comando requerem as opções -username e -password explicitamente.

Assim que se conectar a uma aplicação Portrait Miner, ficará conectado a essa aplicação até sair ou fazer logoff. Deve se autenticar separadamente em cada aplicação que executar.

Tópico pai: Trabalhar com o PSS Connector


Extensões da linha de comando

Extensões do comando de compilação de dados

Os seguintes DBC são fornecidos pela extensão. Todos os comandos exigem argumentos -username e -password explícitos, exceto se a Autenticação do Windows estiver ativada no Portrait Campaign Manager para sua conta de usuário.

  • DBC para mapeamentos (arquivos .xml)
  • DBC para Regras (arquivos .qmml)
  • DBC para Otimizações de decisões (arquivos .qsor)
  • DBC para Conjuntos de Dados do Explorer
Tópico pai: Trabalhar com o PSS Connector


DBC para mapeamentos (arquivos .xml)

  • pssmappingpublish
  • pssmappingretrieve
Tópico pai: Extensões da linha de comando


pssmappingpublish

O comando é usado para publicar um conjunto de mapeamentos de entrada de regra para um domínio de cliente no Portrait Shared Repository. Os parâmetros para o comando são os seguintes:
Publicar um arquivo de mapeamentos de entrada de regra no Portrait Shared Repository

     Necessário:
       -domain <nome do domínio>
          O domínio de cliente do Portrait Campaign Manager para publicar os mapeamentos
          para
       -input <arquivo de mapeamentos XML>
          O arquivo contém a definição de mapeamento da entrada de regra

     Opcional:
       -username <nome do usuário>
          A conta de usuário do Portrait Shared Services a usar. Opcional se for possível conectar
          usando a Autenticação do Windows.
       -password <senha>
       A senha para a conta de usuário do Portrait Shared Services.
Tópico pai: DBC para mapeamentos (arquivos .xml)


pssmappingretrieve

O comando recupera um conjunto de mapeamentos de entrada de regra para um domínio de cliente e o salva como arquivo XML. Os parâmetros para o comando são os seguintes:
Obter mapeamentos de entrada de regra a partir do Portrait Shared Repository e os salvar em um arquivo.

     Necessário:
       -domain <nome do domínio>
          O domínio de cliente do Portrait Campaign Manager para obter os mapeamentos
          .
       -output <arquivo de mapeamentos XML>
          O nome do arquivo para a definição de mapeamento no qual será salvo.

     Opcional:
       -username <nome do usuário>
          A conta de usuário do Portrait Shared Services a usar. Opcional se for possível conectar
          usando a Autenticação do Windows.
       -password <senha>
       A senha para a conta de usuário do Portrait Shared Services.
Tópico pai: DBC para mapeamentos (arquivos .xml)


DBC para Regras (arquivos .qmml)

  • pssrulepublish
  • pssrulelist
  • pssruleretrieve
  • pssruledescribe
Tópico pai: Extensões da linha de comando


pssrulepublish

O comando é usado para publicar os conteúdos de um arquivo QMML como regra para o Portrait Shared Repository. Os parâmetros para o comando são os seguintes:
Publicar uma regra QMML para o Portrait Shared Repository.

     Necessário:
       -domain <nome do domínio>
          O domínio de cliente do Portrait Campaign Manager no qual a regra
          será publicada.
       -name <nome da regra>
          O nome a ser usado para publicar esta regra no repositório.
       -description <texto|@nome do arquivo>
          Descrição para a regra. Se usar o formato @nome do arquivo, use a
          descrição de um arquivo. Opcional com -replace.
       -type <Valor|Propensão|Elevação>
          O tipo de regra sendo publicada - Valor, Propensão ou Elevação.
          Opcional com -replace.
       -input <arquivo QMML>
          O nome do arquivo QMML que contém a regra. O arquivo deve conter
          somente um conjunto de regras único que deve ter uma única saída.

     Opcional:
       -username <nome do usuário>
          A conta de usuário do Portrait Shared Services a usar. Opcional se for possível conectar
          usando a Autenticação do Windows.
       -password <senha>
          A senha para a conta de usuário do Portrait Shared Services.
       -replace
          Substitui o QMML por uma regra existente em vez de publicar uma nova.
          Ao substituir, os parâmetros -type e -description são opcionais.
Tópico pai: DBC para Regras (arquivos .qmml)


pssrulelist

O comando é usado para listar os detalhes de todas as regras associadas a um domínio específico. A lista de regras é retornada em formato de texto simples, mas também pode ser apresentada como um documento XML. Os parâmetros para o comando são os seguintes:
Listar todas as regras em um domínio de cliente no Portrait Shared Repository.

     Necessário:
       -domain <nome do domínio>
          O domínio de cliente para obter as regras.

     Opcional:
       -username <nome do usuário>
          A conta de usuário do Portrait Shared Services a usar. Opcional se for possível conectar
          usando a Autenticação do Windows.
       -password <senha>
          A senha para a conta de usuário do Portrait Shared Services.
       -xml
          Mostra saída no formato XML.
Tópico pai: DBC para Regras (arquivos .qmml)


pssruleretrieve

O comando recupera o QMML compilado para uma regra no Portrait Shared Repository. Os parâmetros para o comando são os seguintes:
Obter uma regra QMML a partir do Portrait Shared Repository e salvá-la em um arquivo.

     Necessário:
       -domain <nome do domínio>
          O domínio de cliente para obter a regra.
       -name <nome da regra>
          O nome da regra publicada no Portrait Shared Repository.
       -output <arquivo QMML>
          O nome do arquivo em que a regra será salva.

     Opcional:
       -username <nome do usuário>
          A conta de usuário do Portrait Shared Services a usar. Opcional se for possível conectar
          usando a Autenticação do Windows.
       -password <senha>
          A senha para a conta de usuário do Portrait Shared Services.
Tópico pai: DBC para Regras (arquivos .qmml)


pssruledescribe

O comando lista os nomes e tipos de entradas e saídas, uma regra no Portrait Shared Repository. Mostra também como os mapeamentos de entrada de regra serão aplicados, descrevendo o mapeamento para um campo ou função, se for definido um. Os parâmetros para o comando são os seguintes:
Descrever uma regra QMML no Portrait Shared Repository.

     Necessário:
       -domain <nome do domínio>
          O domínio de cliente do Portrait Campaign Manager
       -name <nome da regra>
          O nome da regra no domínio de cliente

     Opcional:
       -username <nome do usuário>
          A conta de usuário do Portrait Shared Services a usar. Opcional se for possível conectar
          usando a Autenticação do Windows.
       -password <senha>
       A senha para a conta de usuário do Portrait Shared Services.
Tópico pai: DBC para Regras (arquivos .qmml)


DBC para Otimizações de decisões (arquivos .qsor)

  • pssoptpublish
  • pssoptlist
  • pssoptretrieve
  • pssoptreport
  • pssoptdescribe
Tópico pai: Extensões da linha de comando


pssoptpublish

O comando é usado para publicar os conteúdos de um arquivo de resultados de otimização de decisão QSOR para o Portrait Shared Repository. Os parâmetros para o comando são os seguintes:
 Publicar uma otimização de decisão no Portrait Shared Repository.

     Necessário:
       -domain <nome do domínio>
          O domínio de cliente do Portrait Campaign Manager no qual a otimização
          será publicada.
       -name <nome da otimização>
          O nome a ser usado para publicar esta otimização no repositório.
       -description <texto|@nome do arquivo>
          Descrição para a otimização. Se usar o formato @nome do arquivo, use a
          descrição de um arquivo. Opcional com -replace.
       -input <arquivo QSOR>
          O nome do arquivo de resultado da otimização de decisão.

    Opcional:
       -username <nome do usuário>
          A conta de usuário do Portrait Shared Services a usar.
       -password <senha>
          A senha para a conta de usuário do Portrait Shared Services.
       -replace
           Substitui os detalhes de uma otimização existente em vez de publicar uma
           nova. Ao substituir, o parâmetro -description é opcional.
Tópico pai: DBC para Otimizações de decisões (arquivos .qsor)


pssoptlist

O comando é usado para listar os detalhes de todas as otimizações de decisões associadas a um domínio específico. A lista de otimizações é retornada em formato de texto simples, mas também pode ser apresentada como um documento XML. Os parâmetros para o comando são os seguintes:
Lista todas as otimizações de decisões em um domínio de cliente específico no
Portrait Shared Repository.

     Necessário:
       -domain <nome do domínio>
          O domínio de cliente para obter as otimizações.

     Opcional:
       -username <nome do usuário>
          A conta de usuário do Portrait Shared Services a usar.
       -password <senha>
          A senha para a conta de usuário do Portrait Shared Services.
       -xml
          Mostra saída no formato XML.
Tópico pai: DBC para Otimizações de decisões (arquivos .qsor)


pssoptretrieve

O comando recupera uma otimização de decisão a partir do Portrait Shared Repository. Os parâmetros para o comando são os seguintes:
Recuperar uma otimização de decisão a partir do Portrait Shared Repository e salvá-la em um arquivo.

     Necessário:
       -domain <nome do domínio>
          O domínio de cliente para obter a otimização.
       -name <nome da otimização>
          O nome a otimização de decisão publicada no  Portrait
          Shared Repository.
       -output <arquivo QSOR>
          O nome do arquivo onde a otimização será salva.

     Opcional:
       -username <nome de usuário>
          A conta do Potrait Shared Services a usar.
       -password <senha>
          A senha para a conta de usuário do Portrait Shared Services.
Tópico pai: DBC para Otimizações de decisões (arquivos .qsor)


pssoptreport

O comando recupera o relatório associado com a otimização de decisão do Portrait Shared Repository e o salva para um arquivo. Os parâmetros para o comando são os seguintes:
Obter um relatório associado com uma otimização de decisão a partir do Portrait
Shared Repository e salvá-lo em um arquivo.

     Necessário:
       -domain <nome do domínio>
          O domínio de cliente para obter a otimização.
       -name <nome da otimização>
          O nome a otimização de decisão publicada no  Portrait
          Shared Repository.
       -output <arquivo HTML>
          O nome do arquivo onde o relatório será salvo.

     Opcional:
       -username <nome do usuário>
          A conta de usuário do Portrait Shared Services a usar. Opcional se for possível conectar
          usando a Autenticação do Windows.
       -password <senha>
          A senha para a conta de usuário do Portrait Shared Services.
Tópico pai: DBC para Otimizações de decisões (arquivos .qsor)


pssoptdescribe

O comando lista os nomes dos resultados e os nomes e tipos de entradas e de saídas, uma regra da otimização de decisão no Portrait Shared Repository. Mostra também como os mapeamentos de entrada de regra serão aplicados, descrevendo o mapeamento para um campo ou função, se for definido um. Os parâmetros para o comando são os seguintes:
Descrever a otimização de decisão no Portrait Shared Repository.

     Necessário:
       -domain <nome de domínio>
          o domínio de cliente do Portrait Campaign Manager
       -name <nome de otimização>
          O nome da otimização no domínio de cliente

     Opcional:
       -username <nome do usuário>
          A conta de usuário do Portrait Shared Services a usar. Opcional se for possível conectar
          usando a Autenticação do Windows.
       -password <senha>
          A senha para a conta de usuário do Portrait Shared Services.
Tópico pai: DBC para Otimizações de decisões (arquivos .qsor)


DBC para Conjuntos de Dados do Explorer

  • pssdatasetupdate
Tópico pai: Extensões da linha de comando


pssdatasetupdate

O comando é usado para atualizar um conjunto de dados do Portrait Explorer existente com um novo arquivo de Focus. Os parâmetros para o comando são os seguintes:
Publicar uma nova versão do conjunto de dados para um conjunto de dados nomeado especificamente no Portrait Shared Repository

     Necessário:
       -name <nome do conjunto de dados>
          O nome do conjunto de dados no Portrait Shared Repository ao qual a versão do conjunto de dados pertence.
       -input <caminho do arquivo de focus>
          O caminho do arquivo no computador do servidor do Portrait Analytics Web Services a ser atualizado com a
          versão do conjunto de dados.
     Opcional:
       -username <nome do usuário>
          A conta de usuário do Portrait Shared Services a usar. Opcional se for possível conectar
          usando a Autenticação do Windows.
       -password <senha>
          A senha para a conta de usuário do Portrait Shared Services.
       -timeout <valor de tempo limite (em minutos)>
          O valor máximo do tempo de espera após o início da compilação da versão do conjunto de dados, para que
          o estado da compilação seja concluído (com ou sem sucesso). Se este argumento é omitido
          ou especificado com um valor de 0, então, é aplicado o tempo limite padrão de 10 minutos.
          Observação: Quando o tempo limite tiver sido atingido e o processo para este comando sair, a compilação da versão do conjunto de dados
          continuará no servidor. Poderá contatar um usuário Administrador do Explorer para verificar
          se a compilação da versão do conjunto de dados foi concluída com ou sem sucesso.
Tópico pai: DBC para Conjuntos de Dados do Explorer


Exportar regras a partir da Interface do Usuário do Portrait Miner

  • Exportar Regras a partir do Decision Studio
  • Exportar Regras a partir do Portrait Miner
  • Criar regras de otimização de contatos
Tópico pai: Trabalhar com o PSS Connector


Exportar Regras a partir do Decision Studio

O componente de plug-in do PSSConnector adiciona novos botões da barra de ferramentas à interface de usuário de módulo do Portrait Miner Decision Studio, especificamente; um botão Publicar regra para o Portrait Shared Repository é adicionado à ferramenta Visualizador de Dados.

Esse botão permite exportar uma definição de regra de campo derivado para o Domínio de cliente selecionado no Portrait Dialogue. Se for fornecido um Nome de uma regra que já exista, a definição da regra será atualizada.

O Visualizador de dados do Decision Studio também fornece um botão para iniciar o aplicativo Gerenciar conexão ao Portrait Shared Services, para permitir que faça o logon e o logoff usando um nome de usuário e senha explícitos ou usando a Autenticação do Windows, sempre que possível.

Essa interface do usuário é uma forma de acessar a maior parte das funcionalidades fornecidas pelo comando de compilação de dados pssrulepublish.

Tópico pai: Exportar regras a partir da Interface do Usuário do Portrait Miner


Exportar Regras a partir do Portrait Miner

O Portrait Miner foi estendido para fornecer uma interface alternativa para integrar os resultados analíticos com o Portrait Dialogue.
  • Autenticação: na barra de ferramentas do Portrait Miner, o aplicativo Gerenciar conexão ao Portrait Shared Services permite o logon ou logoff de Portrait Shared Services.

    Com um servidor do Portrait Miner baseado no Windows, sua conexão aos Portrait Shared Services é estabelecida usando a Autenticação do Windows, se possível.

    Para se conectar usando uma conta diferente, é necessário fazer logoff e, em seguida, voltar a fazer o logon usando as credenciais de conta apropriadas.
  • Visualização de regras exportadas: na barra de ferramentas do Portrait Miner, o aplicativo Gerenciar regras no Portrait Shared Repository permite visualizar a lista de regras analíticas publicadas. É necessário selecionar um Domínio de Clientes e, a seguir, é possível visualizar as regras publicadas para esse domínio. Essa interface do usuário é uma forma de acessar a maior parte das funcionalidades fornecidas pelos comandos de compilação de dados cmsrulelist e pssruledescribe.

    É possível exportar uma regra novamente para o sistema de arquivo do servidor como um arquivo QMML usando a opção do botão direito do mouse Salvar como em uma regra. Essa interface do usuário é uma forma de acessar a maior parte das funcionalidades fornecidas pelo comando de compilação de dados pssruleretrieve.

  • Exportar regras: ao selecionar um arquivo .qmml no Portrait Miner, a ação do botão direito do mouse em Publicar regra para o Repositório Portrait Shared permite publicar a descrição (QMML) de modelo como uma regra para uso no Portrait Dialogue. É solicitado um nome, tipo e descrição para a regra e o nome do domínio de cliente onde será publicada. Essa interface do usuário é uma forma de acessar a maior parte das funcionalidades fornecidas pelo comando de compilação de dados pssrulepublish.

Os aplicativos da barra de ferramentas encontram-se igualmente disponíveis por meio do menu Lançar do Portrait Miner.

Tópico pai: Exportar regras a partir da Interface do Usuário do Portrait Miner


Criar regras de otimização de contatos

O Portrait Optimizer é uma extensão do Portrait Miner que permite criar e implementar regras de otimização de contatos no Portrait Dialogue. É possível obter mais informações no Guia do usuário do Portrait Optimizer.

Tópico pai: Exportar regras a partir da Interface do Usuário do Portrait Miner


Exportar Regras em Lote

Os seguintes Comandos de compilação de dados (DBCs) são fornecidos para permitir exportar regras analíticas para o Portrait Dialogue como parte de um lote ou processo programado. Todos os comandos requerem argumentos -username e -password explícitos, a menos que a Autenticação do Windows esteja ativada para sua conta de usuário.

  • Mapeamento de dados
  • Integração de Regra
  • Contatar integração de otimização
Tópico pai: Trabalhar com o PSS Connector


Mapeamento de dados

Se seus conjuntos de dados analíticos são compilados usando nomes de campo diferentes dos nomes de campo subjacentes no Portrait Dialogue ou Interaction Optimizer, ou que precisem ser resolvidos pelas expressões Portrait Dialogue em vez de referências de campo (por exemplo, se estão sendo realizadas análises em uma medição de transação), então você deve publicar uma definição de mapeamentos de entrada de regra. Isso controla a forma como o Portrait Dialogue ou Interaction Optimizer buscam os dados por valores de entrada necessários para a regra analítica do sistema alvo, quando uma regra analítica ou uma otimização de decisão é executada em uma atividade de diálogo do Portrait Dialogue ou em uma interação do Interaction Optimizer.

Nota:
  • Deverá haver um mapeamento um-para-um para cada campo no arquivo de mapeamento – não são permitidos vários mapeamentos por fonte ou campo de destino.
  • pssmappingpublish
  • pssmappingretrieve
  • Formato de mapeamento de entrada de regra
Tópico pai: Exportar Regras em Lote


pssmappingpublish

Publicar um conjunto de mapeamentos de entrada de regra em um domínio lógico de PSS.

Sinopse
pssmappingpublish -domain <domain name>-input <XML mappings file>
    [-password <password>][-replace][-username <username>]

Argumentos opcionais

Opção | Efeito
-password | A senha para os Portrait Shared Services.
-username | O nome do usuário para os Portrait Shared Services.
Tópico pai: Mapeamento de dados


pssmappingretrieve

Recuperar um conjunto de mapeamentos de entrada de regra para um domínio lógico de PSS e salvá-lo como arquivo XML.

Sinopse
pssmappingretrieve -domain <domain name>
    -output <XML mappings file> -target <the name of the target system the mapping is for>
    [-password <password>][-replace][-username <username>]

Argumentos opcionais

Opção | Efeito
-password | A senha para os Portrait Shared Services.
-username | O nome do usuário para os Portrait Shared Services.
Tópico pai: Mapeamento de dados


Formato de mapeamento de entrada de regra

Um arquivo de mapeamentos de entrada de regra é baseado em XML e fornece os nomes de source (como o campo é obtido no sistema de destino) e inputName (o nome da entrada de regra). Não é necessário fornecer mapeamentos para campos com o mesmo nome, tanto no sistema de destino como na regra. A etiqueta <mapping system=""> é usada para especificar o sistema de destino no qual o mapeamento será usado. Para apontar para o Portrait Dialogue, o sistema de mapeamento deve ser configurado como PD, para o Interaction Optimizer, deve ser definido como IO. Poderá haver somente um único mapeamento para qualquer sistema dentro de um domínio lógico.

Por exemplo, implementar regras para o Portrait Dialogue usaria o seguinte formato:
<?xml version="1.0" encoding="UTF-8"?>
<mapping system="PD">
    <inputMap inputName="Analytics-RuleInputName" inputType="string" source="TargetSystem-DataSource" sourceType="FIELD or FUNCTION"/>
    ...
</mapping>

O arquivo de mapeamento é implementado com o DBC pssmappingpublish.

Sempre que os mapeamentos de entrada de regra precisem ser alterados (por exemplo, se for criada uma regra que faz uso de campos adicionais que não foram anteriormente mapeados), é possível importar um novo conjunto de mapeamentos para esse domínio e os novos mapeamentos terão efeito imediatamente – qualquer execução subsequente de operações de Regra analítica ou de Otimização de decisão nos diálogos do Portrait Dialogue nesse domínio obterá imediatamente a nova definição de mapeamento.

Um elemento inputMap em um arquivo de mapeamento possui os atributos seguintes:
  • inputName: este é o nome da entrada de regra; geralmente, será o nome do campo em um conjunto de dados do Portrait Miner no qual a regra foi compilada.
  • inputType: este atributo descreve o tipo de campo no ambiente do Analytics. O atributo assume valores integer, real, string ou date. Serve somente para descrição – não tem qualquer efeito no significado do mapeamento de campo.
  • source: isto, em conjunto com o atributo sourceType, determina como o valor de entrada para o valor é obtido no sistema de destino. No Portrait Dialogue, se o valor sourceType fosse FIELD, então esse atributo especificaria o nome do campo de domínio do cliente correspondente a usar como origem da entrada. Se sourceType for FUNCTION, esse atributo conterá a função do Portrait Dialogue a usar para obter o valor de entrada.
  • sourceType: é possível configurar esse atributo como sourcetype="FIELD" para o Portrait Dialogue ou Interaction Optimizer ou sourcetype="FUNCTION" e especificar se o Portrait Dialogue deve buscar a entrada de regra a um campo de Domínio do cliente ou a uma expressão Portrait Dialogue.

Se o sourcetype for definido como FUNCTION, então o valor do atributo de origem deverá ser uma expressão do Portrait Dialogue válida que retorna um valor único de um dos seguintes tipos de dados: string, integer, float, datetime/date ou boolean (onde o Booleano é mapeado para os valores integer 0 para falso e 1 para verdadeiro).

Exemplo

Aqui está um exemplo de um arquivo de mapeamento que usa funções:

<?xml version="1.0" ?>
<mapping system="PD">
   <!-- Maps to the answer of an integer question in a
     questionnaire. Returns NULL if the customer has not answered
     that questionnaire -->
   <inputMap inputName="TI_Q1" inputType="integer" sourceType="FUNCTION"
     sourceName="AnswerInt(1014,'Q1', '')" />

   <!-- Maps to the answer of single choice question (radio buttons)
     in a questionnaire. Returns the alternative key (e.g. "A1"),
     and NULL if the customer has not answered that questionnaire
   -->
   <inputMap inputName="TI_Q2" inputType="string" sourceType="FUNCTION"
              source="AnswerSingleChoice(1014, 'Q2')" />

   <!-- Maps to the answer of a boolean alternative of a question
     (checkboxes) in a questionnaire. Returns true/false, and NULL
     if the customer has not answered that questionnaire -->
   <inputMap inputName="TI_Q2_BOOL" inputType="integer" sourceType="FUNCTION"
              source="IsAnswered(1014, 'Q2', 'A1')" />

   <!-- Checks if a message of a specific template has been created
     for the customer. Returns true/false -->
   <inputMap inputName="TI_MSG_TEMPLATE_1170" inputType="integer" sourceType="FUNCTION"
              source="hasMessages[templateid = 1170]" />

   <!-- Checks if a customer has a specific value in a category with
     values. Returns true/false -->
   <inputMap inputName="TI_CATEGORY_1011_I5" inputType="integer" sourceType="FUNCTION"
              source="hasCategories[Name = 'CATEGORY_1011' and
              Value = 'I5']" />

   <!-- Checks if a customer has been treated by a dialog operation
     (requires participant logging in the dialog). Returns
     true/false -->
   <inputMap inputName="TI_OFFER_1" inputType="integer" sourceType="FUNCTION" ~
              source="HasOperationHistory(4519)" />

   <!-- Checks if a customer has been treated by a dialog branch
     (requires participant logging in the dialog). Returns
     true/false -->
   <inputMap inputName="TI_OFFER_2" inputType="integer" sourceType="FUNCTION"
              source="HasBranchHistory(1231)" />

   <!-- Counts the number of Orders a customer has -->
   <inputMap inputName="count_orders" inputType="integer" sourceType="FUNCTION"
              source="NumberOf(Orders) " />
              </mapping>
Tópico pai: Mapeamento de dados


Integração de Regra

  • pssrulepublish
  • pssrulelist
  • pssruleretrieve
  • pssruledescribe
Tópico pai: Exportar Regras em Lote


pssrulepublish

Publicar os conteúdos de um arquivo QMML como uma regra nomeada em um domínio lógico de PSS, incluindo uma descrição e seu tipo de regra.

Sinopse
          pssrulepublish -domain <domain name> -name <rule name>
          -description <text | @filename>
          -type <value | propensity | uplift>
          -input <QMML rule file>
          [-password <password>][-replace][-username <username>]

Argumentos opcionais

Opção | Efeito
-password | A senha para os Portrait Shared Services.
-replace | Substitui o QMML por uma regra existente em vez de publicar uma nova. Ao substituir, os parâmetros -type e -description são opcionais.
-username | O nome do usuário para os Portrait Shared Services.
Tópico pai: Integração de Regra


pssrulelist

Lista os detalhes de todas as regras associadas a um domínio lógico de PSS especificado

Sinopse
          pssrulelist -domain <domain name>
          [-password <password>][-username <username>][-xml]

Argumentos opcionais

Opção | Efeito
-password | A senha para os Portrait Shared Services.
-username | O nome do usuário para os Portrait Shared Services.
-xml | Mostra saída no formato XML.
Tópico pai: Integração de Regra


pssruleretrieve

Recupera o QMML compilado para uma regra nomeada em um domínio lógico de PSS para um arquivo.

Sinopse
          pssruleretrieve -domain <domain name>-name<rule name>
          -output <QMML file>
          [-password <password>][-username <username>]

Argumentos opcionais

Opção | Efeito
-password | A senha para os Portrait Shared Services.
-username | O nome do usuário para os Portrait Shared Services.
Tópico pai: Integração de Regra


pssruledescribe

Lista os nomes e tipos de entradas e saídas, uma regra nomeada em um domínio lógico de PSS. Mostra também como os mapeamentos de entrada de regra serão aplicados, descrevendo o mapeamento para um campo ou função, se for definido um. Os parâmetros para o comando são os seguintes:

Sinopse
          pssruledescribe -domain <domain name>-name <rule name>
          [-password <password>][-replace][-username <username>]

Argumentos opcionais

Opção | Efeito
-password | A senha para os Portrait Shared Services.
-username | O nome do usuário para os Portrait Shared Services.
Tópico pai: Integração de Regra


Contatar integração de otimização

É fornecido um conjunto de DBC com o Portrait Optimizer para permitir contatar modelos de otimização a implementar no PSS.

  • pssoptpublish
  • pssoptlist
  • pssoptretrieve
  • pssoptreport
  • pssoptdescribe
Tópico pai: Exportar Regras em Lote


pssoptpublish

Implementa um resultado de otimização de contatos para um domínio lógico de PSS com um nome e uma descrição específicos.

Sinopse
          pssoptpublish -domain <domain name> -name <optimization name>
          -description <text | @filename> -input <QSOR file>
          [-password <password>][-replace][-username <username>]

Argumentos opcionais

Opção | Efeito
-password <senha> | A senha para os Portrait Shared Services.
-replace | Substitui os detalhes de uma otimização existente em vez de publicar uma nova. Ao substituir, o parâmetro -description é opcional.
-username <senha> | O nome do usuário para os Portrait Shared Services.
Tópico pai: Contatar integração de otimização


pssoptlist

Lista as otimizações de contato em um domínio lógico de PSS.

Sinopse
          pssoptlist -domain <domain name>
          [-password <password>] [-username <username>][-xml]

Argumentos opcionais

Opção | Efeito
-password <senha> | A senha para os Portrait Shared Services.
-xml | Mostra saída no formato XML.
-username <nome de usuário> | O nome do usuário para os Portrait Shared Services.
Tópico pai: Contatar integração de otimização


pssoptretrieve

Obtém uma única otimização de contato de um domínio lógico de PSS e a salva em um arquivo de resultado de otimização de contato.

Sinopse
          pssoptretrieve -domain <domain name> -name <optimization name>
          -output <QSOR file>
          [-password <password>] [-username <username>]

Argumentos opcionais

Opção | Efeito
-password <senha> | A senha para os Portrait Shared Services.
-username <nome de usuário> | O nome do usuário para os Portrait Shared Services.
Tópico pai: Contatar integração de otimização


pssoptreport

Obtém um único relatório de otimização de contato de um domínio lógico de PSS e o salva em um arquivo.

Sinopse
          pssoptreport -domain <domain name> -name <optimization name>
          -output <HTML file>
          [-password <password>] [-username <username>]

Argumentos opcionais

Opção | Efeito
-password <senha> | A senha para os Portrait Shared Services.
-username <nome de usuário> | O nome do usuário para os Portrait Shared Services.
Tópico pai: Contatar integração de otimização


pssoptdescribe

Obtém os parâmetros de um único relatório de otimização de contato de um domínio lógico de PSS. Mostra também como os mapeamentos de entrada de regra serão aplicados, descrevendo o mapeamento para um campo ou função, se for definido um para o sistema de destino específico.

Sinopse
          pssoptdescribe -domain <domain name> -name <optimization name>
          [-target <system name>] [-password <password>] [-username <username>]

Argumentos opcionais

Opção | Efeito
-target <nome do sistema> | O nome do sistema de destino para os mapeamentos de campos, por exemplo, PD para Portrait Dialogue ou IO para Interaction Optimizer.
-password <senha> | A senha para os Portrait Shared Services.
-username <nome de usuário> | O nome do usuário para os Portrait Shared Services.
Tópico pai: Contatar integração de otimização


Visualizar registros de clientes em um focus

  • Ver registros de clientes


Ver registros de clientes

No Decision Studio, é possível usar o Visualizador de Dados para visualizar os dados não processados em registros individuais de clientes. Para abrir o Visualizador de Dados a partir da janela do Decision Studio, escolha Ferramentas>Visualizador de Dados ou clique em [image] na barra de ferramentas.

Inicialmente, o Visualizador de Dados exibe dados para os primeiros 100 clientes em seu focus (o primeiro bloco de registro), considerando quaisquer seleções de registro [consulte Selecionar registros de clientes] que estejam no local.

É possível controlar esses campos [consulte Escolher os campos para visualização] e registros [consulte Exibir um bloco de registro diferente] que o Visualizador de Dados exibe e visualizar estatísticas básicas [consulte Exibir estatísticas de campo] para cada campo apresentado.

Nota: Se um valor em um campo de string é uma URL (por exemplo http://www.portraitsoftware.com/), o Visualizador de Dados mostra o valor em azul e sublinhado. É possível clicar duas vezes no valor para visualizar o recurso associado em seu navegador da Web.

Consulte também

Derivar um campo por meio do Visualizador de Dados
Tópico pai: Visualizar registros de clientes em um focus

Escolher os campos para visualização

  1. Escolha Exibir>Mostrar / Ocultar.

    É exibida a caixa de diálogo Ocultar/Mostrar/Reordenar Campos:

    • Use os botões [image] e [image] entre os painéis Ocultar e Mostrar para mover campos realçados de um painel para outro.

      Os botões [image] e [image] movem todos os campos, independentemente dos realçados.

    • Use os botões [image] e [image] à direita do painel Mostrar para reordenar campos.
  2. Clique em OK.
Nota:
  • Também é possível ocultar campos da visualização, selecionando os mesmos no Visualizador de Dados e escolhendo Campo>Ocultar ou clicando com o botão direito do mouse e escolhendo Ocultar.

    Para mostrar um campo que foi ocultado é necessário usar a caixa de diálogo Ocultar/Mostrar/Reordenar Campos, como acima.

  • Ocultar e reordenar campos afeta somente a visualização no Visualizador de Dados. O focus subjacente fica inalterado.

Exibir um bloco de registro diferente

Faça uma das seguintes ações:
  • Escolha Exibir>Bloco de Registro Seguinte ou clique em [image] na parte inferior da barra de rolagem para ver o próximo bloco de 100 registros.
  • Escolha Exibir>Bloco de Registro Anterior ou clique em [image] na parte superior da barra de rolagem para ver o anterior bloco de 100 registros.
  • Escolha Exibir>Ir para Registro e introduza um número de registro para ir a um bloco de registro específico.
Nota: O Visualizador de Dados considera quaisquer seleções de registro [consulte Selecionar registros de clientes] que estejam no local.

Exibir estatísticas de campo

Escolha Exibir>Estatística.

O Visualizador de Dados mostra o valor mínimo não nulo [consulte O valor nulo], o valor máximo não nulo e o número de ocorrências de nulo em cada campo:

Nota: Por razões de eficiência, o Visualizador de Dados não mantém sempre as estatísticas atualizadas. Quando as estatísticas de campo estão desatualizadas, o Visualizador de Dados as exibe em cinza.
  • Para atualizar as estatísticas de um campo ou de um conjunto de campos, selecione os campos e escolha Campo>Atualizar Estatísticas ou clique com o botão direito do mouse em um campo e escolha Atualizar Estatísticas.


Selecionar registros de clientes em um focus

  • Selecionar registros de clientes
  • Seleção de valor ou filtragem usando um campo categórico
  • Seleção ou filtragem de valores usando um campo ou estatística não categórica


Selecionar registros de clientes

É possível selecionar registros em um focus de acordo com os valores em um campo, especificando um conjunto de valores necessários [consulte Selecionar registros em um focus por valor] ou especificando o número de registros [consulte Selecionar um número de registros específico] que se quer. Os visualizadores gráficos e as ferramentas de modelagem que usam o focus operam somente em registros selecionados.
Nota:
  • É possível aplicar seleções de registros baseados em mais de um campo de cada vez, nesse caso, o efeito das seleções de registros é cumulativo; os registros selecionados satisfazem todas as condições selecionadas.
  • Se existir uma seleção de registros associada a um campo, é exibido um "S" na coluna Seleção na janela do Decision Studio. Para um campo não categórico, os intervalos selecionados também aparecem nessa coluna em uma notação matemática padrão, %TODO: Expandir a partir dessa. juntamente com um "+N" ou "-N" dependendo se o valor nulo [consulte O valor nulo] está incluído.
  • As seleções podem ser limpas ou modificadas mesmo depois de um focus ser salvo e aberto novamente.
  • É possível reduzir o tempo que uma seleção demora para aplicar fechando outra janela que não seja mais necessária.
  • A presença de uma seleção de registros não aumenta a velocidade de operações em um focus.

Consulte também

Metadados de focus
Tópico pai: Selecionar registros de clientes em um focus

Selecionar registros em um focus por valor

  1. Na janela do Decision Studio, selecione o campo que pretende usar para a seleção de registros.
  2. Escolha Campo>Selecionar Valores ou clique com o botão direito do mouse e escolha Selecionar Valores ou clique em [image] na barra de ferramentas.

    É exibida a caixa de diálogo Selecionar Valores.

  3. Faça uma seleção de registros baseada nos valores no campo.

    Existem diferentes opções para seleção categórica [consulte Seleção de valor ou filtragem usando um campo categórico] e seleção não categórica [consulte Seleção ou filtragem de valores usando um campo ou estatística não categórica].

  4. Clique em OK, para confirmar sua seleção e feche a janela Selecionar Valores.
Nota:
  • É possível também abrir a janela Selecionar Valores da maior parte das listas de campo por meio do menu de contexto (botão direito do mouse) em um campo.
  • No Visualizador de Crosstab, Visualizador de Mapas, Visualizador de Perfil e Visualizador de Distribuição Cruzada, é possível acessar a janela Selecionar Valores clicando com o botão direito do mouse em um campo na área de configuração de gráfico.

Selecionar um número de registros específico

  1. Na janela do Decision Studio, selecione o campo numérico que pretende usar para a seleção de registros.
  2. Se já existir uma seleção de registros no campo, é necessário remover a seleção [consulte Remover uma seleção de registros de um campo].
  3. Escolha Campo>Selecionar Quantidade ou clique com o botão direito do mouse e escolha Selecionar Quantidade.

    É exibida a caixa de diálogo Selecionar Quantidade:

  4. Escolha selecionar os registros com os valores maiores (topo) ou os valores menores (fundo).
  5. Informe uma porcentagem dos registros disponíveis ou um número exato de registros e escolha "%" ou "#", conforme adequado, a partir do menu suspenso.
  6. Escolha ajustar a quantidade para cima ou para baixo se os valores forem equivalentes.

    Pode acontecer que quando todos os registros forem classificados de acordo com seus valores no campo selecionado, os registros com o mesmo valor no campo superem o limite da quantidade selecionado. Em vez de incluir arbitrariamente alguns desses registros de clientes, o Decision Studio oferece a opção de incluir todos (ajustando a quantidade para cima) ou excluir todos (ajustando a quantidade para baixo).

  7. Clique em OK, para confirmar sua seleção e feche a janela Selecionar Valores.
Nota: Assim que fizer uma seleção de registro por quantidade, ela é indistinguível de uma seleção de registros feita por seleção de valores. Na verdade, é possível selecionar por valor [consulte Selecionar registros em um focus por valor] para ajustar sua seleção de registros, se necessário. No entanto, não é possível selecionar novamente por quantidade sem primeiro remover a seleção.

Remover uma seleção de registros de um campo

  1. Na janela do Decision Studio, selecione o campo com a seleção associada de registros.
  2. Escolha Campo>Limpar Seleção, clique com o botão direito do mouse e selecione Limpar Seleção ou clique em [image] na barra de ferramentas.

Remover todas as seleções de registros de um focus

Escolha Focus>Limpar Todas as Seleções.


Seleção de valor ou filtragem usando um campo categórico

Ao usar valores em um campo categórico [consulte Interpretações de campos] para selecionar registros por valor [consulte Selecionar registros em um focus por valor] em um focus ou aplicar um filtro a um campo categórico que está associado [consulte Associar um campo ou estatística a um aspecto da tabela de referência cruzada/gráfico] com alguns aspectos de uma tabela de referência cruzada ou gráfico, a janela Selecionar Valores ou Filtro fica assim:

Os painéis mostram categorias selecionadas e não selecionadas, que são valores reais no campo (as categorias base) ou as categorias no binning ativo [consulte Modificar um binning categórico], se existir um.

É possível mover categorias de um painel para outro usando um dos botões de seta simples ou marcar/desmarcar todas as categorias usando um dos botões de seta dupla. Para trocar as categorias selecionadas e não selecionadas, clique em [image].

Consulte também

Selecionar um número de registros específico

Seleção ou filtragem de valores usando um campo ou estatística não categórica

Tópico pai: Selecionar registros de clientes em um focus


Seleção ou filtragem de valores usando um campo ou estatística não categórica

Ao usar valores em campos de data ou numéricos não categóricos para selecionar registros por valor [consulte Selecionar registros em um focus por valor] em um focus ou aplicar um filtro a um campo ou estatística não categórica associada [consulte Associar um campo ou estatística a um aspecto da tabela de referência cruzada/gráfico] com algum aspecto de uma tabela de referência cruzada ou gráfico, a janela Selecionar Valores ou Filtro fica assim:

A barra horizontal representa o intervalo dos valores no campo ou estatística, com partes preenchidas representando valores selecionados. O triângulo a apontar para baixo em cada uma das extremidades do intervalo selecionado está preenchido ( [image]) para indicar que o valor do ponto final está incluído no intervalo, ou limitado ( [image]) para indicar que o valor do ponto final está excluído do intervalo.

Ao clicar em um intervalo selecionado, o painel embaixo da barra mostra os valores dos dois pontos finais, juntamente com detalhes, se estão incluídos ou não. É possível avançar de um intervalo selecionado para outro usando os botões de seta em ambos os lados desse painel.

Nota:
  • Se um campo ou uma estatística não estiverem associados a nenhuma seleção/filtro de registro, a barra horizontal na janela Selecionar Valores ou Filtro mostra apenas um intervalo selecionado, com ambos os pontos finais incluídos.
  • O valor nulo [consulte O valor nulo] é incluído ou excluído de acordo com a configuração do menu Manipulação Nula.

    Se for selecionado explicitamente um determinado intervalo de registros, é possível escolher se sua seleção inclui registros contendo o valor nulo (Incluir Sempre) ou os exclui (Excluir Sempre ou Excluído da Seleção Explícita).

    Para selecionar registros que incluam o valor nulo, escolha Selecionar Exclusivamente.

    Para selecionar todos os registros contendo um valor não nulo, não selecione um intervalo explícito (alterando valores ou arrastando pontos finais), escolha somente Excluir Sempre.

Consulte também

Selecionar um número de registros específico

Seleção de valor ou filtragem usando um campo categórico

Tópico pai: Selecionar registros de clientes em um focus

Adicionar um intervalo à seleção

Clique em [image].

Se existirem valores não selecionados à direita do atual intervalo selecionado, o novo intervalo preenche a primeira lacuna disponível à direita. Caso contrário, se existirem valores não selecionados à esquerda do atual intervalo selecionado, o novo intervalo preenche a primeira lacuna disponível à esquerda. Se não existirem valores não selecionados, o Decision Studio divide o maior intervalo selecionado existente para criar um par de novos intervalos.

Remover um intervalo da seleção

  1. Clique no intervalo para selecioná-lo.
  2. Clique em [image].
Nota: Para remover todos os intervalos selecionados, clique em [image].

Incluir ou excluir um ponto final em um intervalo

Clique duas vezes no triângulo correspondente para alterar seu estado ou selecione o intervalo clicando nele e escolha Incluído ou Excluído da lista suspensa apropriada.
Nota:
  • É possível desativar o ponto final esquerdo do intervalo selecionado mais à esquerda (ou o ponto final direito do intervalo selecionado mais à direita) selecionando Desabilitado do menu suspenso do ponto final (em vez de Incluído ou Excluído). O triângulo que marca o ponto final desaparece para indicar que o intervalo selecionado está aberto.
  • Para uma seleção baseada em datas, os intervalos incluem sempre seus pontos finais.

Ajustar um ponto final de um intervalo

Arraste o triângulo esquerdo ou direito correspondente ou arraste todo o intervalo para alterar ambos os pontos simultaneamente, preservando o comprimento do intervalo.

Se preferir, selecione o intervalo e insira um valor na caixa de texto apropriada.

Nota: É possível você usar o botão [image] ou [image] ao lado de uma caixa de texto de ponto final para forçar o ponto final a saltar para o valor mais baixo ou mais alto seguinte que ocorre nos dados.

Inverter uma seleção de intervalo

Clique em [image].

As lacunas entre os intervalos selecionados se tornam os novos intervalos selecionados.


Agrupar registros de clientes binando um campo em um focus

  • Modificar um binning categórico
  • Modificar um binning não categórico
  • Modificar um binning não categórico definido pelo usuário
  • Opções para exibir um binning
  • Anexar um binning extra a um campo não categórico
  • Aplicar um binning a mais de um campo
  • Otimizar um binning para um campo


Modificar um binning categórico

  1. Na janela do Decision Studio, selecione o campo categórico [consulte Interpretações de campos] cujo binning você pretende modificar. Escolha Ferramentas>Binning Editor, ou pressione CTRL+B, ou clique em [image] na barra de ferramentas.
  2. Se preferir, a partir das listas de campos nas ferramentas de modelagem, selecione o campo, clique com o botão direito do mouse e escolha Binning Editor.
  3. Se preferir, nos visualizadores gráficos, clique com o botão direito do mouse em um campo na área de configuração do gráfico e escolha Binning Editor.

    O Binning Editor é aberto, mostrando um gráfico do binning atual para o campo selecionado. No parte inferior esquerda da janela está o painel Hierarquia, que mostra possíveis hierarquias de binnings categóricos com granularidade crescente para o campo atual. O binning selecionado é o binning atual.

    Se não existirem binnings anexados ao campo, o Binning Editor cria um binning chamado "nó sem nome", usando os parâmetros padrão [consulte Para excluir um binning categórico de um campo].

  4. Opcionalmente, selecione um binning diferente no painel Hierarquia; ou crie um novo selecionando um binning existente na hierarquia e clicando em Novo.

    Ao criar um novo binning dessa forma, o binning original selecionado passa a ser o primário do novo binning.

  5. Mescle ou divida categorias [consulte Mesclar ou dividir categorias] para criar um binning mais amplo ou mais estreito, renomeando [consulte Renomear uma categoria] a nova categoria apropriadamente.
  6. Reordene as categorias [consulte Reordenar categorias] no binning, se desejar.
  7. Clique em Aplicar ou OK para confirmar suas alterações à hierarquia de binning categórica.

    Se preferir, clique em Reiniciar para descartar todas as alterações que fez à hierarquia de binning categórica desde a última vez que aplicou alterações.

Nota:
  • Ao aplicar alterações, uma hierarquia de binning categórica atua como apenas um binning. Na maioria dos outros aspectos, os níveis individuais da hierarquia atuam como binnings separados, com o binning atual sendo semelhante ao binning primário [consulte Configurar o binning primário para um campo não categórico] para um campo não categórico.
  • É possível modificar binnings em outros campos sem sair do Binning Editor clicando na guia Campos e selecionando o campo desejado.

Consulte também

Modificar um binning não categórico
Tópico pai: Agrupar registros de clientes binando um campo em um focus

Mesclar ou dividir categorias

  1. No painel Categorias, selecione as categorias que pretende mesclar ou a categoria simples mesclada anteriormente que pretende dividir.

    O painel Categorias Primárias mostra as categorias correspondentes no binning primário (ou categorias base).

  2. Faça uma das seguintes ações:
    • Clique em Mesclar ou clique com o botão direito do mouse no painel Categorias e escolha Mesclar.

      O Binning Editor mescla as categorias selecionadas em uma categoria, tendo como nome uma combinação dos nomes das categoria originais, separados pelo E comercial.

    • Clique em Dividir ou clique com o botão direito do mouse no painel Categorias e escolha Dividir. O Binning Editor divide a categoria selecionada em suas categorias primárias.

Renomear uma categoria

  1. No painel Categorias, clique duas vezes na categoria ou selecione a categoria clicando nela e depois em Renomear.
  2. Digite um novo nome para a categoria e pressione Return.

Reordenar categorias

  1. Clique em Reordenar ou clique com o botão direito do mouse no painel Categorias.
  2. Escolha como reordenar as categorias:
    • Por contagem, descendente (+) ou ascendente (-)
    • Alfabeticamente, por nome de categoria
    • Por número de categoria, ascendente
Nota: Ao ordenar um binning por números de categoria, as categorias mescladas seguem as categorias não mescladas e são classificadas pela categoria de valor mais elevado em cada primário; por exemplo, uma mescla dos bins 2 e 4 precede uma mescla dos bins 1 e 5.

Renomear um binning categórico

É possível atribuir nomes significativos aos binnings na hierarquia de binning categórica para um campo.
  1. No painel Hierarquia do Binning Editor, selecione o binning que pretende renomear.
  2. Clique em Renomear ou simplesmente clique no nome do binning.
  3. Digite seu nome escolhido para o binning e pressione Return.

Para excluir um binning categórico de um campo

  1. No painel Hierarquia do Binning Editor, selecione o binning que pretende excluir.
  2. Clique em Excluir.
Nota: Para excluir todos os binnings categóricos de um ou mais campos, simplesmente apague a interpretação categórica [consulte Para configurar ou limpar uma interpretação de candidato de análise, categórica, geográfica, de exportação ou de chave] nos campos.

Configurar os parâmetros padrão para novos binnings categóricos

  1. Escolha Binning>Parâmetros Padrão ou clique em [image] na barra de ferramentas.
  2. Na guia Categórico, configure o número máximo de categorias separadas e o número mínimo de registros em apenas uma categoria.
  3. Clique em OK para confirmar suas escolhas.
Nota:
  • Se o número de registros contendo um dado valor estiver abaixo do número mínimo de registros para apenas uma categoria - normalmente devido ao campo conter muitos valores distintos - os registros contendo esses valores não são classificados. Os registros não classificados não são mostrados, por padrão, no Binning Editor; para os exibir, escolha Exibir>Dados Não Classificados.
  • Para aplicar os novos parâmetros padrão a um campo que já tem uma interpretação categórica, é necessário limpar a interpretação categórica existente [consulte Para configurar ou limpar uma interpretação de candidato de análise, categórica, geográfica, de exportação ou de chave].


Modificar um binning não categórico

  1. Na janela do Decision Studio, selecione o campo numérico ou de data não categórico [consulte Interpretações de campos] cujo binning pretende modificar. Escolha Ferramentas>Binning Editor, ou pressione CTRL+B, ou clique em [image] na barra de ferramentas.
  2. Se preferir, a partir das listas de campos nas ferramentas de modelagem, selecione o campo, clique com o botão direito do mouse e escolha Binning Editor.
  3. Se preferir, nos visualizadores gráficos, clique com o botão direito do mouse em um campo na área de configuração do gráfico e escolha Binning Editor.

    O Binning Editor é aberto mostrando um gráfico do binning primário [consulte Configurar o binning primário para um campo não categórico] para o campo selecionado.

    Se não existirem binnings anexados ao campo, o Binning Editor cria um binning usando os parâmetros padrão [consulte Configurar os parâmetros padrão para novos inícios não categóricos].

  4. No painel Estilo, selecione o tipo de binning necessário.
    • Para um binning de intervalo igual, é possível configurar o número alvo dos bins de intervalo (bins entre os últimos bins [consulte Últimos bins]) ou a largura do bin de destino.
    • Para um binning de população igual, é possível configurar o número alvo dos bins internos.
    • Para um binning de valor de data, intervalo igual ou de população igual, é possível também especificar as unidades onde as larguras dos bins são medidas (dias, semanas, etc.).
    • Para um binning definido pelo usuário, clique em Editar para especificar limites de bin individual [consulte Modificar um binning não categórico definido pelo usuário] na caixa de diálogo Definido pelo Usuário.
  5. Clique em Aplicar ou OK, para confirmar suas alterações ao binning.

    Se preferir, clique em Reiniciar para descartar todas as alterações feitas ao binning desde a última vez que foram aplicadas alterações.

Nota:
  • Para campos de tipo real, para forçar o Binning Editor a localizar limites do bin em valores integers, marque Binning>Limites de Números Inteiros.
  • O número final dos bins internos pode ser diferente do número alvo para um campo de tipo integer, ou se Binning>Limites de Números Inteiros estiver marcado. Isso acontece por uma dessas razões:
    • O intervalo do campo não inclui limites de números integers suficientes.
    • Binning>Ajustar Automaticamente Número de Bins está selecionado e pelo menos um dos limites do bin final vai ser escolhido automaticamente; nesse caso, o Binning Editor poderá ajustar o número de bins para localizar limites de bins em valores arredondados. Para forçar o número final de bins a ficar com o mesmo valor do número alvo, desmarque Binning>Ajustar Automaticamente Número de Bins e clique em Aplicar ou OK.
  • Para um binning definido pelo usuário, as alterações têm efeito ao clicar em OK na caixa de diálogo Definido pelo Usuário. Não existe, portanto, necessidade de clicar em Aplicar no Binning Editor (e não é possível voltar ao binning original usando Reiniciar).
  • É possível modificar binnings em outros campos sem sair do Binning Editor clicando na guia Campos e selecionando o campo desejado.

Consulte também

Anexar um binning extra a um campo não categórico

Modificar um binning categórico

Tópico pai: Agrupar registros de clientes binando um campo em um focus

Últimos bins

Binnings de intervalo igual ou de população igual no Decision Studio dividem um intervalo numérico ou de data em vários bins. A maior parte desses bins são "internos", mas poderá haver um "último bin" especial em cada uma das extremidades do intervalo.

Quando o Decision Studio cria um início numérico com últimos bins, ele usa um algoritmo inteligente para classificar alguns valores como exceções. Os registros contendo esse valores externos recaem nos últimos bins, enquanto a maioria dos registros recaem nos bins internos.

No Binning Editor do Decision Studio, é possível controlar o uso dos últimos bins em binnings de intervalo igual ou de população igual usando os menus suspensos nos painéis Bin Mínimo e Bin Máximo:
  • Se for escolhido Auto para um binning de intervalo igual numérico, o Binning Editor escolhe o limite do último bin automaticamente.
  • Se for escolhido Auto para um binning de data ou binning de população igual, o Binning Editor omite o último bin.
  • Escolha Fixado em para especificar um limite fixo de último bin.
  • Escolha Nenhum para omitir o último bin em todos os casos.

Também é possível controlar os últimos bins em um binning definido pelo usuário [consulte Modificar um binning não categórico definido pelo usuário].

Excluir um binning não categórico de um campo

  1. No Binning Editor, se já não estiver no campo não categórico cujo binning pretende excluir, clique na guia Campos e selecione o campo.
  2. Escolha Binning>Excluir Binnings ou clique com o botão direito do mouse no painel Campos e escolha Excluir Binnings ou clique em [image] na barra de ferramentas.
Nota:
  • É possível excluir binnings de vários campos não categóricos ao mesmo tempo escolhendo Excluir Binnings em Vários Campos. É exibida uma caixa de diálogo Selecionar Campos na qual é possível escolher os campos cujos binnings pretende excluir.
  • Como seus nomes sugerem, as opções Excluir Binnings e Excluir Binnings em Vários Campos excluem todos os binnings associados a um campo não categórico. Se foi usado o recurso de vários binnings do Decision Studio para anexar mais de um binning a um campo [consulte Anexar um binning extra a um campo não categórico], é possível excluir um binning individual escolhendo Binning>Gerenciar Vários Binnings: selecione o binning necessário na caixa de diálogo Gerenciar Vários Binnings e clique em Excluir.

Configurar os parâmetros padrão para novos inícios não categóricos

  1. No Binning Editor, escolha Binning>Parâmetros Padrão ou clique em [image] na barra de ferramentas.
  2. Na guia Não-Categórico, escolha o número alvo de bins (excluindo nulo [consulte O valor nulo] e bins não classificados e últimos bins [consulte Últimos bins]), o tipo de binning [consulte Modificar um binning não categórico] e se devem ser exibidos bins com larguras de bin proporcionais [consulte Opções do histograma e do gráfico de barras].
  3. Clique em OK para confirmar suas escolhas.
Nota:

Para aplicar os novos parâmetros padrão a um campo já binado, é necessário excluir [consulte Excluir um binning não categórico de um campo] o binning existente.


Modificar um binning não categórico definido pelo usuário

Ao clicar em Editar no Binning Editor para um binning definido pelo usuário, é exibida uma caixa de diálogo Definido pelo Usuário:

Trabalhe a partir do binning existente (talvez um binning antigo de valor real ou população igual) ou clique em Arranque Rápido para começar com um binning predefinido [consulte Usar binnings predefinidos do início rápido]. Depois ajuste o binning para atender a suas necessidades:
  • Altere os limites do bin editando-os diretamente na tabela ou manipulando a visualização gráfica (que funciona como uma visualização gráfica para seleção/filtragem de registros [consulte Seleção ou filtragem de valores usando um campo ou estatística não categórica]).
  • Aumente o número de bins selecionando um bin (na tabela ou na visualização gráfica) e clicando em Dividir Intervalo.

    O bin é dividido em dois bins de igual tamanho.

  • Diminua o número de bins selecionando um bin e clicando em Excluir Intervalo.

    O bin se une ao bin vizinho a sua direita (ou ao da esquerda, no caso de ser o bin mais à direita).

  • Controle o uso dos últimos bins [consulte Últimos bins] escolhendo Ambas, Nenhum, Inferior ou Superior no menu suspenso.
Nota: Ao alterar o valor de um limite do bin, ou marcar ou desmarcar uma caixa de verificação Incluir de, é possível deixar um ou mais bins configurados de forma que não seja possível conterem quaisquer valores. Esse bins inválidos estão destacados como linhas vermelhas na tabela, e rotuladas como "não válidos."

Para remover todos os bins não válidos de seu binning, clique em Excluir Não-Válido.

Consulte também

Modificar um binning não categórico
Tópico pai: Agrupar registros de clientes binando um campo em um focus

Usar binnings predefinidos do início rápido

Ao clicar em Arranque Rápido na caixa de diálogo Definido pelo Usuário, é exibida a caixa de diálogo Predefinições definidas pelo usuário:

Escolhendo o tipo de predefinição apropriada do menu suspenso, é possível criar rapidamente um binning onde os bins entre os valores Bin De e Bin Para têm propriedades úteis:
  • Em um binning de Passo, todos os bins (exceto possivelmente o mais à direita) têm uma largura fornecida.
  • Em um binning Log, existem vários bins com uma largura que aumenta e diminui logaritmicamente.
  • Em um binning Largura Igual, existem vários bins de largura igual.
  • Em um binning Normal, as larguras dos bins correspondem às que seriam obtidas de um binning de população igual se os dados subjacentes fossem distribuídos normalmente entre os valores Bin De e Bin para: quanto mais perto está um bin do valor médio de um campo, mais estreito ele é.
Nota:
  • Se existem valores à esquerda de Bin De ou à direita do valor Bin para, os registros que os contêm recaem nos bins extras (que podem ou não ser classificados como últimos bins [consulte Últimos bins]).
  • Se for selecionado Binar zero separadamente e existir um bin contendo o valor 0, esse bin se divide em até três bins: um para valores inferiores a 0, um para o próprio 0 e um para valores superiores a 0.

    Isso é útil quando zero é um valor especial; por exemplo, clientes com um valor de gasto zero podem formar um segmento distinto.


Opções para exibir um binning

O Binning Editor mostra uma visualização gráfica do binning selecionado, aplicado aos dados para o campo selecionado.

É possível modificar aspectos dessa visualização configurando opções de visualização globais do Decision Studio [consulte Configurar opções globais para exibições gráficas] ou mostrando ou ocultando [consulte Para mostrar ou ocultar segmentos para valores nulos ou não classificados em um gráfico] bins para valores nulos e não classificados.

Também é possível afetar a exibição de um binning não categórico, no Binning Editor e em outro local, escolhendo entre as opções do histograma e do gráfico de barras [consulte Opções do histograma e do gráfico de barras] para o binning.

O Binning Editor também mostra informações numéricas detalhadas sobre um binning e o número de registros em cada bin.

Consulte também

Modificar um binning categórico

Modificar um binning não categórico

Tópico pai: Agrupar registros de clientes binando um campo em um focus

Opções do histograma e do gráfico de barras

Além do tipo de binning e os limites do bin que definem um binning, cada binning está associado a um modo de exibição: seja um histograma ou gráfico de barras (o último sendo o padrão para um início não categórico e a única opção para um binning categórico).
  • Em um histograma, cada bin (que não seja um último bin [consulte Últimos bins], um bin com largura zero ou nulo [consulte O valor nulo], ou bin não classificado) tem uma largura visual proporcional à largura do intervalo subjacente. O Binning Editor traça a densidade de probabilidade com altura da barra:

    Para um dado bin (que não seja um bin de largura zero ou o bin nulo ou não classificado), é possível calcular a contagem de registros multiplicando o número total de registros, a densidade de probabilidade e a largura do intervalo. % Não a largura visual que, para os últimos bins, é diferente. (Para um binning de data, a largura do bin é medida em dias.)

    A exibição do histograma aproxima melhor um gráfico de uma distribuição de valores em um campo.

    Para visualizar um binning não categórico como um histograma no Binning Editor, marque Exibir>Histograma ou selecione [image] na barra de ferramentas.

  • Em um gráfico de barras, todos os bins têm a mesma largura visual (apesar das larguras dos intervalos subjacentes poderem variar em um binning não categórico). O Binning Editor traça a contagem dos registros para cada bin como a altura da barra.

    Quando as larguras de intervalo em um binning variam bastante, o gráfico de barras exibe de forma mais clara os limites do bin e contagens de registros.

    Para visualizar um binning não categórico como um gráfico de barras no Binning Editor, desmarque Exibir>Histograma ou retire a seleção de [image] na barra de ferramentas.

Como o modo de exibição é uma propriedade de um binning e não somente uma opção de visualização no Binning Editor, é necessário efetuar sua alteração permanente (clicando em Aplicar) ou descartar suas alterações ao trocar para outro binning ou fechar o Binning Editor.
Nota:
  • O modo de exibição para um binning afeta as visualizações gráficas no Visualizador de Perfil e Visualizador de Distribuição Cruzada: as divisões em eixos são de largura igual ou proporcionais de acordo com o modo. A exceção está onde a extensão de um bloco em uma dada direção transmite informação: nesse caso, a configuração de exibição do Binning Editor não surte efeito, de forma a não confundir.
  • No Binning Editor, nas visualizações do histograma e do gráfico de barras, a área visual de um bin (que não seja um último bin, um bin de largura zero ou o bin nulo ou não classificado) é proporcional ao número de registros no bin.


Anexar um binning extra a um campo não categórico

É possível anexar um ou mais binnings a um campo não categórico em um focus, apesar de que, em um dado momento, somente um deles — o binning primário — está acessível às ferramentas do Decision Studio além do Binning Editor.
  1. No Binning Editor, se já não estiver no campo que pretende binar, clique na guia Campos e selecione o campo.
  2. Escolha Binning>Gerenciar Vários Binningss ou clique com o botão direito do mouse no painel Campos e escolha Gerenciar Vários Binnings.
  3. Na caixa de diálogo Gerenciar Vários Binnings, faça uma das seguintes ações:
    • Clique em Adicionar.

      O Binning Editor cria um novo binning, com os parâmetros padrão [consulte Configurar os parâmetros padrão para novos inícios não categóricos] para um início não categórico

    • Selecione um binning existente e clique em Duplicar.

      O Binning Editor cria uma cópia do binning selecionado.

Nota:
  • Para usar o novo binning, é necessário torná-lo o binning primário [consulte Configurar o binning primário para um campo não categórico] para o campo.
  • Para ajudá-lo a lembrar qual o binning, é possível atribuir nomes significativos aos binnings: clique duas vezes na caixa de diálogo Gerenciar Vários Binnings.
Tópico pai: Agrupar registros de clientes binando um campo em um focus

Configurar o binning primário para um campo não categórico

  1. No Binning Editor, se já não estiver no campo que pretende binar, clique na guia Campos e selecione o campo.
  2. Escolha Binning>Gerenciar Vários Binningss ou clique com o botão direito do mouse no painel Campos e escolha Gerenciar Vários Binnings.
  3. Na caixa de diálogo Gerenciar Vários Binnings, clique em Tornar Primário.


Aplicar um binning a mais de um campo

É possível reutilizar um binning criando-o em um campo e o aplicando a outro campo similar. É possível copiar e colar [consulte Copiar um binning para outro campo não categórico] um binning não categórico entre campos ou salvar em um arquivo binning [consulte Salvar um binning não categórico] e aplicar o binning [consulte Aplicar um binning não categórico salvo para um novo campo] a outro campo. É possível salvar uma hierarquia de binning categórica [consulte Salvar uma hierarquia de binning categórica] e aplicar a hierarquia [consulte Aplicar uma hierarquia de binning categórica salva a um novo campo] a outro campo.
Nota: Normalmente, seria aplicado um binning ou hierarquia de binning categórica salva a um campo em um focus diferente: para campos não categóricos no mesmo focus, copiar e colar é mais simples.
Tópico pai: Agrupar registros de clientes binando um campo em um focus

Copiar um binning para outro campo não categórico

  1. No Binning Editor, se já não estiver no campo não categórico cujo binning pretende copiar, clique na guia Campos e selecione o campo.
  2. Escolha Binning>Copiar Binning ou clique com o botão direito do mouse no painel Campos e escolha Copiar Binning, ou clique em [image] na barra de ferramentas.
  3. Selecione o campo para o qual pretende aplicar um binning.
  4. Escolha Binning>Colar Binning ou clique com o botão direito do mouse no painel Campos e escolha Colar Binning, ou clique em [image] na barra de ferramentas.

    O Binning Editor cria uma cópia do binning, que recebe o nome do campo original.

Nota:
  • Em vez de colar um binning a apenas um campo, é possível aplicá-lo simultaneamente a vários campos, escolhendo Colar Binning em Vários Campos em vez de Colar Binning. Nesse caso, é exibida uma caixa de diálogo Selecionar Campos Para Colar, onde é possível escolher um grupo de campos. O Binning Editor aplica uma cópia do binning a cada um dos campos escolhidos.
  • Se foi usado o recurso de vários binnings do Decision Studio para anexar mais de um binning a um campo, note que as opções Copiar Binning e Colar Binning se aplicam a binnings primários [consulte Configurar o binning primário para um campo não categórico] associados ao campo.

Salvar um binning não categórico

  1. No Binning Editor, se já não estiver no campo não categórico cujo binning pretende salvar, clique na guia Campos e selecione o campo.
  2. Escolha Arquivo>Salvar como ou clique em [image] na barra de ferramentas e escolha uma localização e um nome para seu arquivo binning.

Aplicar um binning não categórico salvo para um novo campo

  1. No Binning Editor, se já não estiver no campo não categórico a ser colocado no bin usando o binning salvo, clique na guia Campos e selecione o campo.
  2. Escolha Arquivo>Abrir ou clique em [image] na barra de ferramentas.

    Os arquivos binning têm a extensão de nome de arquivo .bng (ou .qsbng).

Salvar uma hierarquia de binning categórica

  1. No Binning Editor, se já não estiver no campo cuja hierarquia de binning categórica pretende salvar, clique na guia Campos e selecione o campo.
  2. Escolha Arquivo>Exportar [Hierarquia Categórica]\ e escolha uma localização e nome para seu arquivo de hierarquia de binning categórica.

    Os arquivos de hierarquia de binning categórica têm a extensão de nome de arquivo .hrc.

Aplicar uma hierarquia de binning categórica salva a um novo campo

  1. No Binning Editor, se já não estiver no campo a ser colocado no bin usando a hierarquia de binning categórica, clique na guia Campos e selecione o campo.
  2. Escolha Arquivo>Importar Hierarquia Categórica ou clique em [image] na barra de ferramentas.
Nota:
  • Ao aplicar uma hierarquia de binning categórica salva a um campo, essa substitui qualquer hierarquia de binning categórica — ou binnings não categóricos — associados ao campo.
  • Se for aplicada uma hierarquia de binning categórica sem uma interpretação categórica, o Decision Studio aplica automaticamente uma interpretação de categoria ao campo.


Otimizar um binning para um campo

É possível usar o Binning Editor para encontrar o binning mais amplo que mais se aproxima de um binning estreito em termos de predição de um objetivo específico. Dessa forma, é possível melhorar um scorecard ou uma árvore de decisão ao mesmo tempo em que se minimiza o risco de sobreajustar o modelo a seus dados.
  1. Verifique se o campo cujo binning que pretende otimizar é interpretado como um candidato de análise [consulte Interpretações de campos] (ou se não existem candidatos de análise no focus).
  2. Certifique-se de que está configurado o objetivo de modelagem apropriado.
  3. Compilar um scorecard . Não feche a janela do Construtor de Scorecard.

    Ao compilar um scorecard, garante-se que as estatísticas necessárias para a otimização estão no local.

  4. No Binning Editor, se já não estiver no campo cujo binning pretende otimizar, clique na guia Campos e selecione o campo.
  5. Escolha Binning>Otimizar ou clique em [image] na barra de ferramentas.

    É exibida a caixa de diálogo Otimizar Binning:

  6. Escolha o binning de origem, especificando se deve ser usado o binning atual, um binning de intervalo igual ou de população igual com um número de bins específico.

    O binning de origem deve ser mais estreito que o resultado pretendido; como um valor aproximado, escolha cerca de dez vezes o número de bins com o qual pretende terminar.

  7. Clique em Criar Binning de Fonte.

    O gráfico no Binning Editor mostra o binning de origem escolhido, codificado por cores com a taxa de coincidência objetivo para cada bin.

  8. Escolha o número de bins internos e o tamanho mínimo de bins para seu binning alvo.
  9. Clique em Otimizar.

    O gráfico no Binning Editor exibe agora o binning alvo gerado usando esses parâmetros, novamente codificado por cores, com a taxa de coincidência objetivo para cada bin.

  10. Clique em Aceitar se desejar binar o campo usando esse binning. (Depois, pode fechar a janela do Construtor de Scorecard.)
Nota:
  • A otimização de binnings somente funciona com bins internos.Os últimos bins não são afetados.
  • Por padrão, o Binning Editor usa o ganho de informação como uma medida de qualidade para o grau de aproximação entre um binning amplo e um binning inicial. Usando o menu suspenso no painel Otimização, é possível escolher usar o índice Gini para essa situação.
  • A otimização de binning é um processo iterativo: Se não estiver satisfeito com o binning de origem, é possível alterar os parâmetros no painel Binning de Fonte a qualquer momento e clicar novamente em Criar Binning de Fonte; se não estiver satisfeito com o binning alvo, é possível alterar os parâmetros nos painéis Binning Alvo e Otimização e clicar novamente em Otimizar.
  • Para um campo não categórico, ao clicar em Aceitar, o novo binning passa a ser o binning primário [consulte Configurar o binning primário para um campo não categórico] para o campo. A não ser que Fazer Backup do Binning Atual seja selecionado antes de aceitar o binning, ele substituirá o binning primário existente.
Tópico pai: Agrupar registros de clientes binando um campo em um focus


Derivar novos campos em um focus

  • Derivar um campo por meio do Visualizador de Dados
  • Derivar um campo do modelo ou tabela de referência cruzada do Decision Studio
  • Os campos associados a árvores de decisão, scorecards, modelos de agregação e tabelas de referência cruzada abstratas
  • Derivar um campo de uma segmentação gráfica
  • Derivar campos em um focus usando o Portrait Miner


Derivar um campo por meio do Visualizador de Dados

  1. Escolha Derivar>Novo ou clique em [image] na barra de ferramentas.

    O Visualizador de Dados cria inicialmente uma coluna Visualização} vazia à direita da tabela.

  2. Na caixa de texto recém selecionada à esquerda do sinal "=", digite um nome para o novo campo.

    Escolha um nome de campo descritivo — mas não muito longo. O nome deve começar com uma letra e não conter caracteres que não sejam letras, dígitos e sublinhados. Não deve entrar em conflito com o nome de outro campo no focus.

  3. Na caixa de texto à direita do sinal "=", digite uma expressão FDL ou lista de expressões [consulte Expressões], para definir o campo em termos de campos existentes.
  4. Escolha Derivar>Calcular, clique em [image] na barra de ferramentas ou simplesmente pressione Return.

    O Visualizador de Dados deriva o novo campo, que aparece no lugar da coluna Visualização}.

Nota:
  • Se a expressão ou lista de expressões for ,muito longa para caber confortavelmente em apenas uma linha, é possível usar o Multi-Line Expression Editor: Escolha Derivar>Editar ou clique em [image] na barra de ferramentas.
  • Para substituir o tipo de dado padrão [consulte Tipos de Dados] para um campo, abra o Multi-Line Expression Editor para revelar opções adicionais de derivação.

    Aqui também é possível configurar uma semente [consulte Sobre funções de números aleatórios em FDL] para computações de números aleatórios. Se não for especificada uma semente, o sistema escolhe uma (baseado no relógio do sistema) e a sequência de resultados será diferente em momentos diferentes.

  • Se for pressionada a tecla Tab (repetidamente) ao introduzir uma expressão de derivação, o Visualizador de Dados alternará por possíveis resultados para a palavra atual, considerando os nomes das funções FDL e campos no focus. Os preenchimentos de nomes de funções FDL incluem os parênteses e vírgulas necessárias, quando aplicável, para indicar o número necessário de argumentos. Se não foi digitada somente parte da palavra, o Visualizador de Dados considera todas as funções e nomes de campos como possíveis preenchimentos.
  • Se preferir, é possível incluir quaisquer nomes de campos do focus em uma expressão de derivação, selecionando-o de uma lista: escolha Derivar>Navegador de Campo.
  • Se não estiver seguro da sintaxe precisa para uma função FDL — ou simplesmente para economizar na digitação — escolha Derivar>Navegador de Função para uma entrada de função assistida [consulte Entrada de função assistida no Visualizador de Dados].
  • Para derivar um campo baseado em valores em outra tabela, use a função FDL dblookup.
  • O Decision Studio gera valores para todos os registros, independentemente se foi ou não aplicada uma seleção.

Consulte também

Derivar campos em um focus usando o Portrait Miner
Tópico pai: Derivar novos campos em um focus

Entrada de função assistida no Visualizador de Dados

Quando escolhe Derivar>Navegador de Função ou clica em [image] no decorrer da introdução de uma expressão de derivação no Visualizador de Dados, é exibida a caixa de diálogo Funções de Derivação. Se for selecionada uma classe de funções (ou Todos) no painel Família de Função, é exibida uma lista de funções FDL nessa classe (ou todas as funções FDL disponíveis) no painel Funções.

Ao selecionar uma função no painel Funções, é exibida uma breve descrição da função. (Para funções que não estão instaladas na FDL, clique em Detalhes para consultar uma descrição mais completa.)

É possível inserir os argumentos necessários para a função no painel Parâmetros.

Abaixo desse painel de parâmetros, é possível ver a expressão FDL correspondente a suas escolhas de função e parâmetros. Ao clicar em OK, o Visualizador de Dados cola essa expressão em sua expressão de derivação no cursor.

Nota:
  • Ao usar a caixa de diálogo Funções de Derivação para inserir uma função na família de função Agregação de Campo, existem dois parâmetros especiais ("where" e "by"), que não correspondem aos argumentos de funções reais. Em vez disso, produzem uma sintaxe FDL especial para funções de agregação.

    O parâmetro "where" é uma expressão FDL de valor booleano [consulte Dados booleanos] usado para selecionar os registros para agregar. Se for omitido o parâmetro, o Decision Studio agregará todos os registros selecionados no focus.

    O parâmetro "by" é um campo de divisão — ou uma lista de campos de divisão separados por vírgulas. Para calcular o valor da função de agregação para um registro, o Decision Studio vai agregar os registros que compartilham o bin dos registros para cada campo de divisão.

  • Ao usar a caixa de diálogo Funções de Derivação para inserir a função FDL isselected, existe um parâmetro especial ("expand"), que não corresponde a um argumento de função real. Ao selecionar a caixa para esse parâmetro, em vez de gerar a expressão isselected(), o Visualizador de Dados insere uma expressão que avalia como verdadeiros somente os registros selecionados na altura.

    Ambas produzem o mesmo resultado — até que sejam selecionados registros diferentes no focus. Então, o resultado da expressão isselected() mudará, mas o resultado da expressão expandida permanecerá o mesmo.

Editar uma expressão de derivação por meio do Visualizador de Dados

  1. Clique no campo no qual pretende editar a expressão de derivação.
  2. Edite a expressão derivada, se necessário, por meio do Multi-Line Expression Editor.
  3. Escolha Derivar>Calcular, clique em [image] na barra de ferramentas ou simplesmente pressione Return.


Derivar um campo do modelo ou tabela de referência cruzada do Decision Studio

  1. Se desejar que um campo reflita os segmentos selecionados de uma árvore de decisão, selecione os segmentos de interesse [consulte Selecionar segmentos em uma exibição gráfica] no Construtor de Árvore de Decisão.
  2. Faça uma das seguintes ações:
    • No Construtor de Árvore de Decisão, escolha Árvore>Gerar Campos.
    • No Construtor de Scorecard, escolha Scorecard>Gerar Campos.
    • No Construtor de Cluster, escolha Clustering>Gerar Campos.
    • No Visualizador de Crosstab, Visualizador de Perfil, Visualizador de Distribuição Cruzada ou Visualizador de Mapas, escolha Segmentos>Gerar Campos.
    • Em qualquer ferramenta de modelagem ou visualizador gráfico, clique em [image] na barra de ferramentas.
    A a caixa de diálogo Gerar Campos de Resultados.
  3. Marque os campos de resultados [consulte Os campos associados a árvores de decisão, scorecards, modelos de agregação e tabelas de referência cruzada abstratas] que pretende gerar, alterando os nomes dos campos conforme necessário.
  4. Clique em OK.

    O Decision Studio gera os campos de resultados no focus.

Nota:
  • Cada campo de resultado é marcado como um campo derivado e tem uma definição FDL associada, sendo possível visualizar ou editar [consulte Derivar um campo por meio do Visualizador de Dados] usando o Visualizador de Dados. Existem comentários com instruções no texto de derivação para ajudar a realizar análises "what if?" simples.
  • O Decision Studio gera valores para todos os registros, independentemente se foi ou não aplicada uma seleção.

Consulte também

Compilar um modelo de agregação

Compilar uma árvore de decisão

Criar uma visualização textual da tabela de referência cruzada

Derivar um campo de uma segmentação gráfica

Salvar o modelo do Decision Studio ou segmentação para implementação como QMML (XML)

Tópico pai: Derivar novos campos em um focus


Os campos associados a árvores de decisão, scorecards, modelos de agregação e tabelas de referência cruzada abstratas

Os seguintes campos de resultados capturam diferentes aspectos das árvores de decisão, tabelas de referências cruzadas abstratas, scorecards e modelos de agregação:
Campo | Aplicável a | Descrição
Índice de Segmento | Qualquer árvore de decisão ou tabela de referência cruzada abstrata | O número identificativo do segmento onde um registro recai - considerando somente segmentos "ramificados" (nível mais baixo, sem filhos) em uma árvore de decisão
Segmento selecionados | Qualquer árvore de decisão ou visualizador gráfico | 1 para registros em segmentos selecionados; 0 para outros registros
Taxa de coincidência | Árvore binária | A taxa de coincidência original para o segmento "ramificado" onde recai um registro, ou seja, a proporção de registros (entre 0 e 1) no segmento que coincide com o objetivo (ignorando registros como nulo [consulte O valor nulo] no campo de objetivo)
Resultado esperado | Árvore binária ou scorecard contínuo | Para uma árvore de decisão: o índice do bin do valor mais comum original no objetivo para o segmento "ramificado" onde recai um registro: normalmente 1 para o valor 0, 2 para o valor 1, e 3 para nulo [consulte O valor nulo] Para um scorecard: a pontuação computada aplicando o scorecard, equivalente ao valor esperado do objetivo
Decisão | Árvore binária ou scorecard binário | Para uma árvore de decisão: 1 se a taxa de coincidência original para o segmento onde recai um registro for acima do valor limite [consulte Configurar o limite de decisão para uma árvore de decisão] para a árvore; 0 caso contrário Para um scorecard: 1 para registros com pontuações acima da pontuação de corte [consulte Configurar a pontuação de corte para um scorecard] para o scorecard; 0 para outros registros
Categoria mais popular | Árvore categórica | O índice do bin da categoria mais comum original no objetivo para o segmento "ramificado" onde recai um registro
Média agregada | Árvore contínua | O valor médio original do objetivo para o segmento "ramificado" onde recai um segmento
Elevar como diferença | Elevação binária + árvore | A elevação original, ou seja, a taxa de coincidência original para a população tratada menos a elevação para a população de controle, para o segmento onde recai um registro
Elevar como quociente | Uplift binário x árvore | A taxa de elevação original, isto é, a taxa de coincidência original para a população tratada dividida por ela para a população de controle, para o segmento onde recai um registro (Se a taxa de coincidência para a população de controle é zero, é atribuído ao registro um número positivo muito grande.)
Elevação da média | Árvore uplift contínua | A elevação original, ou seja, o valor médio original do objetivo para a população tratada menos a elevação original para a população de controle, para o segmento onde recai um registro
Pontuação | Scorecard binário | A pontuação computada aplicando o scorecard
Chances | Scorecard binário | As chances de retornar, responder, negociar, ficar satisfeito ou insatisfeito, dadas por [image] , onde s é a pontuação e a e b são o ponto regulador de diferença e fator de duplicação [consulte Configurar um relacionamento de pontuação/chances para um scorecard] respectivamente.
Probabilidade | Scorecard binário | A probabilidade de retornar, responder, negociar, ficar satisfeito ou insatisfeito, dadas por
Índice de Cluster | Modelo de agregação | O número identificativo do cluster [consulte Compilar um modelo de agregação] onde recai um registro (ou nulo [consulte O valor nulo] para um registro no cluster nulo [consulte O valor nulo na agregação]) (Um binning categórico é aplicado e é atribuído o valor -1 a uma categoria chamada "Exceções.")
Distância de Cluster | Modelo de agregação | A distância normalizada [consulte Medição do tamanho e separação de clusters] entre um registro e o centro do cluster onde recai
Separação de Cluster | Modelo de agregação | A medida de separação para um registro, dado por [image] , onde [image] é a distância do centro de cluster mais próximo e [image] é a distância para o segundo centro de cluster mais próximo.
Nota:
  • A palavra "original" na tabela acima indica que, para as árvores de decisão, os valores em certos campos gerados são da população na qual a árvore de decisão foi compilada, em vez de qualquer população à qual é aplicada mais tarde.
  • O campo de índice de segmento para uma tabela de referência cruzada abstrata considera todos os campos de divisão na tabela de referência cruzada, incluindo aqueles que o visualizador apresenta atualmente na barra [image] (Apenas informação).
  • O campo de segmentos selecionados para tabelas de referências cruzadas abstratas está disponível somente ao salvar um modelo para implantação nos visualizadores gráficos.

Consulte também

Derivar um campo do modelo ou tabela de referência cruzada do Decision Studio

Salvar o modelo do Decision Studio ou segmentação para implementação como QMML (XML)

Tópico pai: Derivar novos campos em um focus

Configurar o limite de decisão para uma árvore de decisão

No Construtor de Árvore de Decisão, altere o limite de decisão da taxa de coincidência, taxa de aceitação ou taxa de rejeição usando o painel abaixo da barra de ferramentas:

Os valores legítimos para esses três parâmetros são os que aparecem na visualização de ganhos [consulte Opções para exibir a árvore de decisão] da árvore de decisão.

Ao digitar um valor para o limite da árvore de decisão ou taxa de rejeição, o valor real (mostrado na caixa não editável à direita) é o valor legítimo mais próximo acima do valor digitado. Para a taxa de aceitação, o valor real é o valor legítimo mais próximo abaixo do valor digitado. O Construtor de Árvore de Decisão ajusta os outros valores em conformidade.

Configurar a pontuação de corte para um scorecard

No Construtor de Scorecard, altere a pontuação de corte, taxa de aceitação (taxa alvo) ou taxa ruim (taxa de acerto) usando o painel abaixo da barra de ferramentas.

O Construtor de Scorecard ajusta os outros valores em conformidade.

Nota:
  • Não é possível configurar uma pontuação de corte para uma compilação de scorecard usando um objetivo contínuo: Em um modelo de valor, você não está tomando uma decisão do tipo sim ou não.
  • A configuração padrão é determinada pelas preferências do Construtor de Scorecard, corte, taxa ruim e taxa de aceitação.

Configurar um relacionamento de pontuação/chances para um scorecard

  1. No Construtor de Scorecard, escolha Scorecard>Formulário.
  2. No painel Escalada da caixa de diálogo Formulário de Scorecard, altere o ponto regulador de diferença e fator de duplicação conforme necessário:
    • O ponto regulador de diferença é a pontuação correspondente às chances de 1.
    • Ao adicionar o fator de duplicação a uma pontuação, as chances correspondentes duplicam (para uma resposta ou modelo de rotatividade — para um modelo de risco, as chances são reduzidas à metade).
  3. Clique em OK.
Nota:
  • Essas opção não estão disponíveis ao usar um objetivo contínuo, pois não existe um conceito de chances associadas a scorecards contínuos.
  • Ao alterar o ponto regulador de diferença ou fator de duplicação, o novo valor não é aplicado até que o novo scorecard seja compilado.


Derivar um campo de uma segmentação gráfica

É possível derivar um campo 0/1 de uma segmentação gráfica para indicar inclusão ou exclusão dos segmentos selecionados.
  1. No Visualizador de Perfil, Visualizador de Distribuição Cruzada, Visualizador de Mapas ou Construtor de Árvore de Decisão, selecione os segmentos de interesse [consulte Selecionar segmentos em uma exibição gráfica].
  2. Escolha Segmentos>Sinalizador Selecionado ou clique em [image] na barra de ferramentas.

    É exibida a caixa de diálogo Nome do Novo Campo.

  3. Digite um nome para o campo derivado e clique em OK.

    O Decision Studio cria um novo campo, com 1 para os registros que recaem em segmentos selecionados e 0 para os outros registros.

Nota:
  • O novo campo é marcado como um campo derivado e tem uma definição FDL associada, sendo possível visualizar ou editar usando o Visualizador de Dados [consulte Derivar um campo por meio do Visualizador de Dados].
  • O novo campo é interpretado como categórico [consulte Interpretações de campos], com nomes de categorias "Não Selecionado" e "Selecionado" para os valores 0 e 1, respectivamente.

Consulte também

Criar um gráfico em um mapa

Criar um gráfico de crossdistribution de várias variáveis

Criar um conjunto de gráficos de perfil de apenas uma variável

Derivar um campo do modelo ou tabela de referência cruzada do Decision Studio

Salvar o modelo do Decision Studio ou segmentação para implementação como QMML (XML)

Tópico pai: Derivar novos campos em um focus


Derivar campos em um focus usando o Portrait Miner

É possível derivar campos usando um conjunto de definições de campo em um arquivo de derivações.
Para derivar campos em um focus, use uma das seguintes opções:
  • No Portrait Miner, clique com o botão direito do mouse no focus no qual você quer derivar os campos e escolha Transformar>Campos Derivados.
  • No Portrait Miner, clique com o botão direito do mouse em um arquivo de derivação e escolha Campos Derivados.

Na caixa de diálogo Campos Derivados, escolha o campo de derivações que contém as definições de campo. Se preferir, selecione um campo de derivações e escolha um focus. Também é possível alterar a localização do novo focus ou escolher substituir um focus de saída criado anteriormente.

Nota: Essa interface do usuário é uma forma de acessar a maior parte das funcionalidades fornecidas pelo comando de compilação de dados qsderive do Portrait Miner.

Consulte também

Sobre os assistentes do Portrait Miner

Derivar um campo por meio do Visualizador de Dados

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Visualizar e editar arquivos de texto no Portrait Miner

Tópico pai: Derivar novos campos em um focus


Renomear e excluir campos em um focus

  • Renomear um campo usando o Visualizador de Dados
  • Renomear campos adicionando um prefixo ou sufixo
  • Para excluir um campo


Renomear um campo usando o Visualizador de Dados

  1. Clique no campo cujo nome pretende alterar.
  2. Na caixa de texto à esquerda do sinal "=", digite um novo nome de campo e pressione Enter.

    O nome deve começar com uma letra e não conter caracteres que não sejam letras, dígitos e sublinhados. Não deve entrar em conflito com o nome de outro campo no focus.

Ao renomear um campo, quaisquer campos derivados (incluindo campos gerados de modelos), cujas expressões de derivação envolvem o nome original do campo, são invalidados.
Nota:
  • Não é possível renomear um campo enquanto este estiver sendo usado por uma ferramenta do Decision Studio.

Consulte também

Renomear campos adicionando um prefixo ou sufixo

Tópico pai: Renomear e excluir campos em um focus


Renomear campos adicionando um prefixo ou sufixo

É possível renomear um ou mais campos em um focus, adicionando um prefixo ou sufixo comum aos nomes do campo.
  1. No Portrait Miner, clique com o botão direito do mouse no focus cujos campos pretende renomear e escolha Transformar>Renomear Campos. É exibida a caixa de diálogo Renomear Campos.
  2. Se preferir, altere a localização do focus de saída.
  3. Faça uma ou mais das seguintes ações:
    • Escolha a string para adicionar como um prefixo.
    • Escolha a string para adicionar como um sufixo.
  4. Escolha um ou mais campos para renomear.
  5. Clique em OK.
Nota:
  • É necessário que cada nome de campo resultante não entre em conflito com o nome de outro campo no focus.
  • A caixa de diálogo Renomear Campos é uma forma de acessar muitas das funcionalidades fornecidas pelo comando de compilação de dados qsrenamefields do Portrait Miner.

Consulte também

Sobre os assistentes do Portrait Miner

Renomear um campo usando o Visualizador de Dados

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Tópico pai: Renomear e excluir campos em um focus


Para excluir um campo

  1. Clique no campo que pretende excluir.
  2. Na janela do Decision Studio, escolha Campo>Excluir ou clique com o botão direito do mouse no campo e escolha Excluir.
  3. No Visualizador de Dados, escolha Campo>Excluir ou clique em [image] na barra de ferramentas. É possível você excluir um campo clicando com o botão direito do mouse em um cabeçalho de campo e escolhendo Excluir.
Nota:
  • Não é possível excluir um campo enquanto este estiver sendo usado por uma ferramenta do Decision Studio.
  • Também é possível excluir um campo na janela do Decision Studio por meio de Campo>Excluir ou escolhendo Excluir ao clicar com o botão direito do mouse em um campo.

Consulte também

Escolher os campos para visualização

Renomear um campo usando o Visualizador de Dados

Tópico pai: Renomear e excluir campos em um focus


Trabalhar com metadados de focus

  • Metadados de focus
  • Rótulos de exibição de campo
  • Interpretações de campos
  • Anexar um comentário a um focus ou campo usando o Decision Studio
  • Visualizar metadados de focus e campo
  • Copiar metadados de um focus para outro
  • Editar metadados de focus no Excel


Metadados de focus

Metadados são "dados sobre dados". Além dos dados brutos do cliente importados de um banco de dados ou criados por meio de medidas de transação, um focus contém metadados. Alguns desses metadados se aplicam ao focus como um todo, enquanto outros metadados se aplicam a campos individuais no focus.

Metadados associados ao focus como um todo

  • O número de registros e campos no focus
  • O comando de compilação de dados usados para criar o focus (se forem criados usando comandos de compilação de dados)
  • Um comentário opcional

Metadados associados a um campo em um focus

  • O nome e tipo de dado do campo [consulte Tipos de Dados]
  • Qualquer rótulo de exibição [consulte Rótulos de exibição de campo] associado ao campo
  • Quaisquer etiquetas de usuário [consulte Etiquetas de Usuário] associadas ao campo
  • Quaisquer interpretações [consulte Interpretações de campos] associadas ao campo
  • Quaisquer binnings associados ao campo
  • Qualquer seleção de registro [consulte Selecionar registros de clientes] baseada em valores no campo
  • A expressão FDL [consulte Sobre Linguagem de Campo Derivado] usada para definir o campo (se o campo fosse derivado)
  • Qualquer comentário associado ao campo
  • Um registro se o campo foi importado (unido) para o focus de outra fonte de dados
  • Os valores mínimos e máximos no campo
  • O número de ocorrências do valor nulo [consulte O valor nulo] no campo
Nota: Os relacionamentos entre as ferramentas em uma sessão do Decision Studio não são armazenados em um arquivo de focus.

Consulte também

Anexar um comentário a um focus ou campo usando o Decision Studio

Copiar metadados de um focus para outro

Criar um Perfil e Auditoria de um focus

Visualizar metadados de focus e campo

Tópico pai: Trabalhar com metadados de focus


Rótulos de exibição de campo

Muitas vezes, não é desejável ou possível editar um nome de campo. No entanto, em algumas das exibições no Decision Studio é possível ver um rótulo de exibição em vez de um nome de campo. As ferramentas que dão suporte aos rótulos de exibição são o Visualizador de Distribuição Cruzada, Visualizador de Crosstab, Visualizador de Perfil, Visualizador de Mapas e Construtor de Árvore de Decisão.

A janela do Decision Studio tem uma coluna Rótulo de Exibição que mostra o rótulo de exibição que será usado para cada campo. Observação: A coluna Rótulo de Exibição é opcional e pode ser mostrada se clicar em Editar>Layout da Coluna.

Tópico pai: Trabalhar com metadados de focus

Editar o rótulo de exibição para um campo

  1. Na janela do Decision Studio, selecione o campo.
  2. Clique uma segunda vez no campo Rótulo de Exibição para editar o nome diretamente. Alternativamente, com a entrada do rótulo de exibição selecionada, é possível:
    • Escolher Campo>Propriedades ou
    • Clicar com o botão direito do mouse e escolher Propriedades ou
    • Clicar em [image] na barra de ferramentas.

Consulte também

Funções de agregação para tabelas de referência cruzada
Nota:
  • Ao contrário dos nomes de campo, não existem restrições quanto aos caracteres usados nos rótulos de exibição.
  • Os rótulos de exibição de campo são salvos com o focus e podem ser exportados e importados juntamente com outros itens de metadados.
  • Não é possível usar os rótulos de exibição em expressões FDL.


Interpretações de campos

No Decision Studio, é possível associar uma ou mais das seguintes interpretações a um campo:

Interpretação de campo | Significado
Objetivo | O campo é o objetivo de modelagem/visualização no focus.
Partição | O campo é o campo de partição tratado/controlado para análise de elevação O primeiro bin ou categoria (normalmente o valor 0) denota o segmento de controle e o segundo bin ou categoria (normalmente o valor 1) denota o segmento tratado.
Candidatos de análise | O campo é um candidato para usar em os modelos do Construtor de Árvore de Decisão, Construtor de Scorecard e Construtor de Cluster.
Categórico | Os valores no campo formam um conjunto discreto e não ordenado. Os campos categóricos são tratados de forma diferente dos outros campos no Binning Editor, Construtor de Árvore de Decisão, Construtor de Cluster e caixa de diálogo Selecionar Valores.
Geográfico | O campo é associado a um mapa para que o possa usar no Visualizador de Mapas.
Exportar | O campo deve ser incluído, por padrão, quando exporta segmentos para um arquivo ou tabela de banco de dados. (Normalmente, é o identificador único, por exemplo, um número de cliente.)
Chave | O campo é associado ao Portrait Explorar e identifica o campo-chave. Só é possível ter um campo-chave.
Nota:
  • Um focus contém no máximo um campo com a interpretação objetiva e no máximo um campo com a interpretação de partição.
  • Se não existirem candidatos de análise em um focus, o Construtor de Árvore de Decisão, Construtor de Scorecard e Construtor de Cluster tratam todos os campos apropriados como candidatos de análise.
  • Da mesma forma, se não existirem campos com a interpretação de exportação em um focus, o Decision Studio trata todos os campos como campos de exportação.
  • No Construtor de Scorecard, é possível interpretar um campo como uma "ponderação". Esse tipo de interpretação é local ao Construtor de Scorecard e faz parte dos metadados do focus.
Tópico pai: Trabalhar com metadados de focus

Para configurar ou limpar uma interpretação de candidato de análise, categórica, geográfica, de exportação ou de chave

  1. Na janela do Decision Studio, selecione os campos cuja interpretação pretende alterar.
  2. Selecione Etiqueta>Interpretações no menu principal e, seguida, selecione Candidato de Análise [image], Categórica [image], Geográfica [image], Exportação [image] ou Chave [image]). Se preferir, clique com o botão direito do mouse e selecione a interpretação ( [image], [image], [image], [image] ou [image]) . O ícone apropriado será exibido na coluna Interpretações do campo.
Nota:
  • É possível configurar interpretações de campo no Visualizador de Dados, a partir do menu Marcar>Interpretações ou clicando com o botão direito do mouse em um nome de campo (cabeçalho da coluna).
  • Para remover uma interpretação, selecione-a uma segunda vez usando as etapas descritas acima.

Para configurar ou limpar o campo de objetivo ou de partição em um focus.

  1. Na janela do Decision Studio, selecione o campo que pretende configurar como campo de objetivo ou de partição.
  2. Selecione Etiqueta>Interpretações no menu principal e, em seguida, selecione Objetivo ( [image]) ou Partição ( [image] ). Se preferir, clique com o botão direito do mouse no campo e selecione a interpretação ( [image] ou [image]). O ícone apropriado será exibido na coluna Interpretações do campo.
Nota:
  • Se já foi configurado um campo de objetivo ou de partição e escolhido interpretar um campo diferente dessa forma, o Decision Studio limpa a interpretação original por você.
  • Para remover uma interpretação objetiva ou de partição de um campo sem atribuir a interpretação a outro campo, selecione o campo e escolha a opção apropriada do menu Marcar>Interpretações novamente.


Anexar um comentário a um focus ou campo usando o Decision Studio

É possível adicionar descrições e outros comentários ao focus e a campos individuais em um focus. Estas informações podem ser úteis ao compartilhar conjuntos de dados com outras pessoas — ou mesmo ao voltar a um conjunto de dados de análise com o qual não trabalhava há algum tempo.
Na janela do Decision Studio:
  • Para adicionar um comentário de focus, escolha Focus>Editar Comentários de Focus.
  • Para adicionar um comentário de campo, clique no campo Comentário e adicione o seu comentário. Se preferir, pode:
    • selecionar o campo necessário e escolher Campo>Propriedades
    • clicar com o botão direito do mouse e escolher Propriedades ou clicar em [image] na barra de ferramentas.

Os comentários de campo aparecem na coluna Comentários na janela do Decision Studio. Também aparecem os comentários de campo e focus em outro local [consulte Visualizar metadados de focus e campo].

Nota:
  • Se for marcada a caixa HTML, o Decision Studio trata pares equilibrados de etiquetas, por exemplo <b>...</b>, como marcação HTML e exibe o comentário correspondente.

Consulte também

Metadados de focus
Tópico pai: Trabalhar com metadados de focus


Visualizar metadados de focus e campo

A janela do Decision Studio exibe metadados de focus [consulte Metadados de focus], incluindo as estatísticas do campo principal. É possível escolher exibir informação diferente usando o menu Editar>Layout de Coluna; sua escolha é aplicada na sessão atual e nas futuras sessões do Decision Studio.

A coluna Interpretações mostra letras correspondentes a interpretações de campos [consulte Interpretações de campos] que foram aplicadas ao campo. Também é possível que apareçam as seguintes letras na coluna Interpretações:

Carta | Significado
B | O campo tem um binning associado a ele.
D | O campo é um campo derivado.
J | O campo foi importado (unido) para o focus de outra fonte de dados.

A coluna Comentários mostra todos os comentários [consulte Anexar um comentário a um focus ou campo usando o Decision Studio] associados a campos.

Nota: Por motivos de eficiência, a janela do Decision Studio não apresenta estatísticas atualizadas o tempo todo. Quando as estatísticas de campo estão desatualizadas, a janela do Decision Studio as deixa cinzas.
  • Para atualizar as estatísticas para apenas um campo, selecione o campo e escolha Campo>Atualizar Estatísticas ou clique com o botão direito do mouse no campo e escolha Atualizar Estatísticas.
  • Para atualizar as estatísticas para todos os campos no focus, escolha Focus>Atualizar Todas as Estatísticas.
Tópico pai: Trabalhar com metadados de focus

Visualizar informações do focus no Decision Studio

Na janela do Decision Studio, escolha Focus>Informação de Focus.

É exibida uma janela, mostrando informações básicas sobre o focus e o histórico do focus. Também aparecem todos os comentários [consulte Anexar um comentário a um focus ou campo usando o Decision Studio] associados ao focus.

Visualizar informações de campo no Decision Studio

Na janela do Decision Studio, realce um campo e escolha Campo>Propriedades ou clique com o botão direito do mouse e escolha Propriedades ou clique em [image] na barra de ferramentas.

Visualizar informações de focus e campos no Portrait Miner

No Portrait Miner, clique com o botão direito do mouse em um focus e escolha Metadados>Mostrar.

Na caixa de diálogo Mostrar Informação do focus, é possível escolher a quantidade de informação de campo a incluir.

É exibida uma janela, mostrando informações básicas sobre o focus e o histórico do focus. Também aparecem todos os comentários [consulte Anexar um comentário a um focus ou campo usando o Decision Studio] associados ao focus.

As informações em campos (se pedidas) aparecem embaixo das informações do focus. Se for escolhido exibir informações detalhadas de campo, isso inclui estatísticas de campo, assim como todos os comentários associados aos campos.

Nota: Essa caixa de diálogo, Mostrar Informação do focus, é uma forma de acessar a maior parte das funcionalidades fornecidas pelo comando de compilação de dados do Portrait Miner, qsdescribe.

Consulte também

Sobre os assistentes do Portrait Miner

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Visualizar dependências e tamanhos de arquivo para um focus

Um focus é armazenado em um disco como arquivo .ftr (o "arquivo de focus") juntamente com um conjunto de arquivos de dados e outros arquivos em duas pastas, com os nomes com extensões .rdx ("Raw Data eXtract") e .xtr ("eXTRa"). Normalmente, as pastas não estarão visíveis no Portrait Miner e na guia "Quadstone" dos navegadores de arquivos do Portrait Miner [consulte Navegar para abrir ou salvar um arquivo, sessão ou tabela de banco de dados].

Um novo focus que é criado por meio de cópia de um focus existente ou pela importação de dados de outro tipo de conjunto de dados (ou como resultado de execução de um script TML) é independente de outros focus. Por outro lado, um focus que é salvo no Decision Studio com novo nome ou um que seja criado através de uma cópia vinculada é dependente das pastas de dados de outros focus.

Para um focus específico, é possível descobrir quais os outros focus de que depende e quais os focus que dependem dele, assim como a quantidade de espaço de disco usada para armazenar dados e metadados: No Portrait Miner, clique com o botão direito do mouse no focus e escolha Propriedades.

Na caixa de diálogo Exibir Propriedades de focus, é possível escolher salvar o relatório de propriedades do focus como um arquivo XML ou HTML. As propriedades do focus são exibidas na guia Saída, no formato selecionado para o arquivo de saída.

Nota: Essa interface do usuário é uma forma de acessar a maior parte das funcionalidades fornecidas pelo comando de compilação de dados do Portrait Miner, qsinfo.

Consulte também

Sobre os assistentes do Portrait Miner

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados


Copiar metadados de um focus para outro

É possível copiar metadados de focus [consulte Metadados de focus] de um focus para outro, incluindo definições ou campos derivados, interpretações de campos, binnings, seleções de registros, comentários de campo e focus e histórico do focus.

Uma forma de fazer isso passa por salvar metadados de focus e aplicar os metadados salvos em outro focus. Outra forma passa por usar um focus diretamente como um "modelo" de metadados para outro focus.

Nota: Ao aplicar um modelo de metadados a um focus, os comentários de campo e focus não são incluídos. Também não é possível aplicar um modelo de metadados se o focus de destino tiver interpretações de campo, seleções ou binnings.

Consulte também

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados
Tópico pai: Trabalhar com metadados de focus

Salvar metadados de focus

Na janela do Decision Studio escolha Focus>Exportar Metadados e navegue [consulte Navegar para abrir ou salvar um arquivo, sessão ou tabela de banco de dados] para escolher a localização onde vai salvar o arquivo de metadados de focus.

Exportar metadados de um focus usando o Portrait Miner

No Portrait Miner, clique com o botão direito do mouse no focus e escolha Metadados>Exportar.

É exibida a caixa de diálogo Exportar Metadados. É possível escolher uma localização para os arquivos de metadados salvos (ou simplesmente aceite o padrão).

Nota: Essa interface do usuário é uma forma de acessar a maior parte das funcionalidades fornecidas pelo comando de compilação de dados do Portrait Miner, qsexportmetadata (tem exatamente o mesmo efeito de salvar metadados do Decision Studio).

Aplicar metadados salvos a um novo focus

No Portrait Miner, faça uma das seguintes ações:
  • Clique com o botão direito do mouse no arquivo de metadados de focus (.qsfm) e escolha Importar como Metadados para focus.

    Na caixa de diálogo Importar Metadados para focus escolha o focus de destino.

  • Clique com o botão direito do mouse no focus de destino e escolha Metadados>Importar.

    Na caixa de diálogo Importar Metadados para focus escolha o arquivo de metadados de focus.

É possível escolher exatamente o tipo de metadados a importar e alterar o destino do focus. Assim que os parâmetros estiverem configurados, clique em Próximo para escolher os detalhes de importação.
Nota:
  • A menos que sejam selecionados explicitamente os campos, o Portrait Miner importa metadados relacionados a campos para todos os campos no focus.
  • O comportamento padrão é substituir o focus de destino com um focus contendo os metadados escolhidos. Se a caixa de seleção correspondente for desmarcada, é possível especificar uma localização para um novo focus.
  • Ao importar metadados, as interpretações categóricas são classificadas como binnings, não como interpretações.
  • Essa interface do usuário é uma forma de acessar a maior parte das funcionalidades fornecidas pelo comando de compilação de dados do Portrait Miner, qsimportmetadata.

Consulte também

Sobre os assistentes do Portrait Miner


Editar metadados de focus no Excel

É possível editar metadados de focus [consulte Metadados de focus] no Excel, incluindo rótulos de exibição de campo, interpretações, etiquetas, derivações e comentários.
  1. Exportar um arquivo de metadados [consulte Salvar metadados de focus] a partir de um focus. No caso de um conjunto de dados recém-importado, este será um modelo em branco, e no caso de um conjunto de dados no qual tenha trabalhado, este conterá todos os rótulos, etiquetas, binnings, derivações e outros detalhes já adicionados.
  2. Para criar um arquivo Excel para editar, clique com o botão direito do mouse no arquivo de metadados e escolha Importar para Excel.
  3. Para editar os metadados no Excel, clique com o botão direito do mouse no arquivo Excel e escolha Enviar para o Excel. É possível encontrar mais detalhes sobre como editar os metadados no arquivo Excel.
  4. Para criar um arquivo de metadados de focus, clique com o botão direito do mouse no arquivo Excel e escolha Exportar como metadados focus.
Tópico pai: Trabalhar com metadados de focus


Trabalhar com grupos de campo

  • Grupos de campos etiquetados
  • Etiquetas de Usuário


Grupos de campos etiquetados

É possível gerenciar grupos de campos de acordo com as etiquetas adicionadas a um campo.
Tópico pai: Trabalhar com grupos de campo

Sobre etiquetas

Uma etiqueta pode consistir em uma etiqueta de usuário ou em uma interpretação. Cada etiqueta de usuário é representada por um marcador colorido que contém sua letra inicial. As cores desses marcadores são geradas automaticamente.
A guia Etiquetas no lado esquerdo da janela do Decision Studio mostra as etiquetas atuais. Cada etiqueta é apresentada em uma linha separada com:
  • Um indicador de estado e um menu suspenso para controlar se os campos com essa etiqueta devem ser apresentados:
    • Sem Preferência: Campos que apresentam essa etiqueta podem ou não ser exibidos, dependendo das escolhas efetuadas para outras etiquetas.
    • Mostrar Campos com Essa Marca: Campos que apresentam essa etiqueta serão exibidos, a menos que também tenham uma etiqueta que esteja configurada para ficar oculta. Campos que não apresentam essa etiqueta ficarão ocultos, a menos que uma de suas etiquetas também esteja configurada para ser exibida.
    • Esconder Sempre Campos com Essa Marca: Campos que apresentam essa etiqueta ficarão ocultos, mesmo se o campo tiver outra etiqueta que esteja configurada para ser exibida.
  • No caso de etiquetas do usuário, seu marcador colorido.
  • O nome da etiqueta.
  • Entre parênteses, o número de campos que apresentam essa etiqueta. No caso de interpretação Derivada, esse texto apresentará também o número de campos recém-criados, se esses estiverem ocultos.
Ao acionar qualquer ferramenta, os campos que ela apresenta são baseados na exibição atual da janela do Decision Studio. No entanto, a maior parte das listas de campos no aplicativo também contêm uma caixa de verificação Todos os campos de Focus que permite apresentar todos os campos, independente da exibição na janela do Decision Studio.
  • O Construtor de Scorecard sempre mostra os campos com a interpretação de Análise. Os campos apresentados na janela do Decision Studio não têm qualquer efeito nisso.
  • O Construtor de Árvore de Decisão e o Construtor de Cluster mostram os campos com a interpretação de Análise e também quaisquer campos que foram mostrados na janela do Decision Studio, mas não apresentam a interpretação de Análise ao serem inicializados. Além disso, quaisquer campos que tenham tido interpretação de Análise quando a ferramenta foi acionada, mas das quais tenham sido removidas essas interpretações, continuarão a ser apresentados.
  • Os visualizadores (Visualizador de Crosstab, Visualizador de Mapas, Visualizador de Distribuição Cruzada e Visualizador de Perfil) mostram todos os campos que estejam atualmente visíveis na janela do Decision Studio mais aqueles que tenham sido usados na especificação de referência cruzada durante a vida útil da ferramenta.
Nota: Se um focus com um grande número de campos estiver sendo usado, configure uma exibição dos campos que interessam na janela do Decision Studio antes de acionar ferramentas.

Consulte também

Etiquetas de Usuário

Interpretações de campos

Mostrar ou ocultar campos no Decision Studio

Clique no menu de estado da etiqueta para escolher qual grupo de campos é apresentado ou ocultado. Se preferir, ao clicar diretamente nos ícones de estados, os três estados disponíveis serão alternados.

O número de campos atualmente apresentados e o número total de campos é exibido em uma barra de estado, na parte inferior da tabela.

Nota: Ao iniciar o Decision Studio ou ao carregar um focus, o status de todas as etiquetas é Sem Preferência, assim, todos os campos serão exibidos.

Exibir todos os campos

Para reconfigurar a exibição para o padrão, onde todas as etiquetas estão configuradas para Sem Preferência e todos os campos são apresentados, clique com o botão direito do mouse em qualquer lugar na guia Etiquetas e selecione Mostrar Todos os Campos.


Etiquetas de Usuário

No Decision Studio, é possível que os campos recebam etiquetas e também que sejam apresentados ou ocultados baseados nessas etiquetas. Uma etiqueta é apenas uma palavra associada a um arquivo. É possível a um campo ter qualquer número de etiquetas e a uma etiqueta ser associada a qualquer número de campos.
Tópico pai: Trabalhar com grupos de campo

Para criar uma etiqueta

  1. Na janela do Decision Studio, selecione os campos que pretende etiquetar.
  2. Clique com o botão direito do mouse e selecione Criar etiqueta de usuário > Nova ou, se preferir, selecione Etiqueta > Nova ou Etiqueta > Criar etiqueta de usuário > Nova no menu principal.
  3. Digite um nome para a etiqueta e clique em OK. Observação: Evite usar nomes de etiquetas que comecem pela mesma letra para garantir que cada um obtenha uma letra diferente na coluna Etiquetas de Usuário na janela do Decision Studio.
  4. Escolha, nas opções Marcar esses Campos:
    • Nenhum, para criar uma etiqueta que não esteja associada a nenhum campo.
    • Campos selecionados, para criar uma etiqueta e adicioná-la aos campos atualmente selecionados na janela do Decision Studio.
    • Campos Coincidindo com a Expressão Regular, para criar uma etiqueta e adicioná-la aos campos que coincidem com uma expressão regular. Por exemplo, a expressão regular .*Code coincide com todos os campos que terminam em Code.
  5. Clique em OK.

Consulte também

Expressões regulares

Excluir uma etiqueta

  1. Na janela do Decision Studio, clique com o botão direito do mouse na etiqueta na seção Usuário do painel Etiqueta.
  2. Selecione Excluir no menu.

Renomear uma etiqueta

  1. Na janela do Decision Studio, clique com o botão direito do mouse na etiqueta na seção Usuário do painel Etiqueta.
  2. Selecione Renomear no menu.

Adicionar um campo a um grupo etiquetado

  1. Na janela do Decision Studio, selecione os campos que pretende etiquetar.
  2. Escolha Criar etiqueta de usuário clicando com o botão direito do mouse nos campos selecionados ou no menu Etiqueta.
  3. Clique no nome da etiqueta desejada. Observação: Quando o campo ou campos já têm a etiqueta, o nome fica esmaecido.

Para remover um campo do grupo etiquetado

  1. Na janela do Decision Studio, selecione os campos dos quais pretende excluir uma etiqueta.
  2. Escolha Limpar Marca clicando com o botão direito do mouse nos campos destacados ou do menu Marcar.
  3. Clique no nome da etiqueta. Quando nenhum dos campos tem a etiqueta, o nome fica esmaecido.
Nota: Uma etiqueta que não é associada a nenhum campo não é salva com o focus.

Exibir etiquetas de campo

  1. Na janela do Decision Studio, selecione um campo.
  2. Escolha Campo>Propriedades ou clique com o botão direito do mouse e escolha Propriedades ou clique em [image] na barra de ferramentas.

Para editar etiquetas de expressão regular

Se criou uma etiqueta de expressão regular, é possível atualizar a expressão regular e voltar a aplicá-la em todos os campos.

  1. Na janela do Decision Studio, clique com o botão direito do mouse na etiqueta de expressão regular no painel Usuário (menu à esquerda).
  2. Selecione Editar e atualize o nome ou expressão regular.
  3. Clique em OK. O sistema aplica novamente a expressão regular a todos os campos.
Nota: A opção de editar somente está disponível na sessão atual. Quando recarrega um focus salvo, a etiqueta de expressão regular está disponível, mas já não é possível editar os valores.


Resumir, segmentar e visualizar dados de focus por meio de tabelas de referência cruzada

  • Tabelas de referência cruzada como base para segmentação e visualização de dados
  • Funções de agregação para tabelas de referência cruzada
  • Criar uma visualização textual da tabela de referência cruzada
  • Organização de campos e estatísticas em uma tabela de referência cruzada ou gráfico
  • Mostrar mais detalhes em um segmento ou gráfico selecionado
  • Para aplicar uma tabela de referência cruzada a um focus


Tabelas de referência cruzada como base para segmentação e visualização de dados

O Decision Studio usa tabelas de referência cruzada como base não só para visualizações da tabela de referência cruzada, mas também para perfil, crossdistribution e gráficos de mapa.

Uma tabela de referência cruzada nesse sentido consiste em zero ou mais campos de divisão, juntamente com uma ou mais estatísticas. As estatísticas são avaliadas para cada célula da segmentação potencialmente multidimensional definida pelos binnings nos campos de divisão.

Após ser especificada uma tabela de referência cruzada abstrata e as estatísticas terem sido computadas, é possível organizar os campos e estatísticas [consulte Organização de campos e estatísticas em uma tabela de referência cruzada ou gráfico] como desejar dentro de sua visualização ou gráfico de tabela de referência cruzada tabular.

Consulte também

Funções de agregação para tabelas de referência cruzada
Tópico pai: Resumir, segmentar e visualizar dados de focus por meio de tabelas de referência cruzada

Especificar os campos e estatísticas na tabela de referência cruzada

  1. No Visualizador de Crosstab, Visualizador de Perfil, Visualizador de Distribuição Cruzada ou Visualizador de Mapas, escolha Editar>Editar a Tabela de Referência Cruzada ou clique em [image] na barra de ferramentas.

    É exibida a caixa de diálogo Selecionar Campos e Funções de Agregação.

  2. Realce os campos de divisão necessários no painel Campos disponíveis e clique em [image] para adicionar os campos realçados ao painel Campos selecionados.
  3. Para cada estatística necessária:
    1. Selecione a função de agregação [consulte Funções de agregação para tabelas de referência cruzada] no painel Funções Disponíveis:.
    2. Se a função de agregação usa um argumento, selecione o campo necessário no painel Parâmetros de Função.
    3. Clique em [image] para adicionar a estatística ao painel Funções de Agregação Selecionadas.

    (De fato, é possível você realçar várias funções de agregação e/ou campos ao mesmo tempo, nesse caso, quando você clica em [image], tem todas as combinações válidas de função/campo como estatísticas.)

  4. Clique em OK para criar uma tabela de referência cruzada.
Nota:
  • Se um visualizador segue [consulte Relacionamentos das ferramentas] outro visualizador (exceto para um Visualizador de Perfil seguindo outro tipo de visualizador ou vice-versa), é possível selecionar Usar Especificação Guia para que o visualizador seguinte herde as especificações de referência cruzada abstrata do visualizador principal (juntamente com seus dados de segmento selecionados).

    A opção Usar Especificação Guia está selecionada por padrão (onde aplicável) ao fazer uma busca detalhada [consulte Mostrar mais detalhes em um segmento ou gráfico selecionado] usando o menu Segmentos>Fazer Busca Detalhada.

  • A barra Tamanho Estimado na caixa de diálogo fornece uma indicação aproximada do tamanho que a tabela de referência cruzada terá em termos de dados. Se a barra preencher o espaço disponível, o mais provável é que a tabela de referência cruzada seja grande demais para ser avaliada ou irá demorar muito tempo para ser acessada.

    É possível alterar o limite de tamanho da tabela de referência cruzada configurando uma preferência [consulte Configurar as preferências do Portrait Miner]: na seção Agregação, altere o valor da opção max size. (O Portrait Miner usa esse valor quando computa a tabela de referência cruzada; no entanto, a barra Tamanho Estimado não a usa para sua estimativa.)

  • Para remover um campo ou estatística do painel Campos selecionados ou Funções de Agregação Selecionadas, realce o campo ou estatística e clique em [image] à direita do painel.

Salvar uma tabela de referência cruzada do Decision Studio

Se pretender reutilizar uma tabela de referência cruzada textual, um gráfico de crossdistribution, um conjunto de gráficos de perfil ou um gráfico de mapa ou compartilhar com alguém que não tenha acesso total ao Portrait Miner, é possível salvar a tabela de referência cruzada abstrata subjacente (incluindo estatísticas avaliadas).
  1. Escolha Arquivo>Salvar como ou clique em [image] na barra de ferramentas.
  2. Navegue [consulte Navegar para abrir ou salvar um arquivo, sessão ou tabela de banco de dados] para a localização necessária e escolha um nome para a tabela de referência cruzada.

Cada visualizador do Decision Studio salva seu próprio tipo de tabela de referência cruzada (com uma extensão de nome de arquivo única), que pode ser aberta em um ou mais visualizadores do Decision Studio. (Também é possível usar a extensão de nome de arquivo .qsxt para uma tabela de referência cruzada genérica.)

Visualizador do Decision Studio | Extensão de nome de arquivo | Visualizadores Compatíveis do Decision Studio
Crosstab Viewer | .qstv | Visualizador de Crosstab, Visualizador de Mapas e Visualizador de Distribuição Cruzada
Crossdistribution Viewer | .qsdv | Visualizador de Crosstab, Visualizador de Mapas e Visualizador de Distribuição Cruzada
Profile Viewer | .qspv | Profile Viewer
Map Viewer | .qsmv | Visualizador de Crosstab, Visualizador de Mapas e Visualizador de Distribuição Cruzada
Qualquer um | .qsxt | Dependente do tipo real de tabela de referência cruzada

Consulte também

Exportar dados tabulares do Decision Studio

Para aplicar uma tabela de referência cruzada a um focus

Abrir uma tabela de referência cruzada no Decision Studio

Salvar o modelo do Decision Studio ou segmentação para implementação como QMML (XML)

XML no Portrait Miner

Abrir uma tabela de referência cruzada no Decision Studio

Se pretende abrir uma tabela de referência cruzada textual, um gráfico de crossdistribution, um conjunto de gráficos de perfil ou um gráfico de mapa salvos anteriormente, é possível carregar a especificação de referência cruzada abstrata subjacente, que depois será aplicada ao focus atual.
  1. Escolha Arquivo>Abrir ou clique em [image] na barra de ferramentas.
  2. Navegue [consulte Navegar para abrir ou salvar um arquivo, sessão ou tabela de banco de dados] para o arquivo necessário da tabela de referência cruzada.
Nota:
  • Campos de divisão e estatísticas que não são compatíveis com o focus atual não são carregados.
  • Quando todos os campos de divisão e estatísticas são compatíveis com o focus atual, o layout salvo da tabela de referência cruzada [consulte Organização de campos e estatísticas em uma tabela de referência cruzada ou gráfico] também é carregado.

Consulte também

Salvar uma tabela de referência cruzada do Decision Studio
© 2015 Pitney Bowes Software Inc. Email: software.support@pb.com


Funções de agregação para tabelas de referência cruzada

As seguintes funções de agregação estão disponíveis para uso em tabelas de referência cruzada abstratas [consulte Tabelas de referência cruzada como base para segmentação e visualização de dados] no Decision Studio. Exceto quando indicado, uma função de agregação assume apenas um campo numeric, string ou date como argumento.

Na maioria das exibições as funções são renomeadas com rótulos de exibição. É possível editar os rótulos na guia Etiquetas de Função ao editar as preferências através de Editar, na janela do Decision Studio. As preferências de visualização são salvas para futuras sessões para cada usuário. Rótulos de função não são salvos com o focus.

Consulte também

Rótulos de exibição de campo
Função | Rótulo padrão | Resultado
Any [consulte any] | Valor de amostra de | Um valor não nulo no campo, obtido de um registro não nulo arbitrário no segmento
ConfIntLower [consulte confintlower] | 95% do limite inferior de | O limite inferior de um intervalo de confiança de 95% para a média do campo no segmento
ConfIntUpper [consulte confintupper] | 95% do limite superior de | O limite superior de um intervalo de confiança de 95% para a média do campo no segmento
Count [consulte count] | Quantidade | O número de registros no segmento (Essa função não usa argumento.)
CountNonNull [consulte countnonnull/countnonnulls] | Quantidade que não está faltando | O número de registros no segmento para o qual o campo não tem valores não nulos [consulte O valor nulo]
CountNull [consulte countnull/countnulls] | Quantidade em falta | O número de registros no segmento para o qual o campo contém valores nulos [consulte O valor nulo]
CountUnique [consulte countunique] | Valor distinto de | O número de valores únicos que ocorrem no campo, possivelmente incluindo o valor nulo
CountUniqueNonNull [consulte countuniquenonnull] | Valores distintos que não estão faltando de | O número de valores únicos, excluindo o valor nulo, que ocorrem no campo
ExpectedCount [consulte expectedcount] | Quantidade esperada | O número de registros que seriam esperados no segmento se os campos na tabela de referência cruzada fossem independentes uns dos outros (Essa função não usa argumento.)
ExpectedProportion [consulte expectedproportion] | Proporção esperada | A proporção da população que seria esperada no segmento se os campos na tabela de referência cruzada fossem independentes uns dos outros (Essa função não usa argumento.)
First [consulte first] | Primeiro valor de | O primeiro valor não nulo no campo para o segmento
Last [consulte last] | Último valor de | O último valor não nulo no campo para o segmento
Max [consulte max (um argumento)] | Máximo | O valor máximo não nulo no campo para o segmento
Mean [consulte mean (um argumento)] | Média | A média (média comum) dos valores não nulos no campo para o segmento (Essa função requer um campo numérico como um argumento.)
Median [consulte median] | Mediano | A mediana (valor do meio) dos valores não nulos no campo para o segmento (Essa função requer um campo numérico ou de string como um argumento.)
Min [consulte min (um argumento)] | Mínimo | O valor mínimo não nulo no campo para o segmento
Mode [consulte mode] | Mais comum | O modo (valor mais comum) dos valores não nulos no campo para o segmento
ModeRatio [consulte moderatio] | Pureza de | A proporção dos registros não nulos no segmento que contêm o valor não nulo mais comum no campo
PercentageRate [consulte percentagerate] | Porcentagem de | A porcentagem de registros não nulos no segmento que contêm o valor 1 no campo É necessário que o campo contenha apenas os valores 0 e 1.
Proportion [consulte proportion] | Proporção | O número de registros no segmento, como uma proporção do número total de registros (Essa função não usa argumento.)
SegmentIndex (segindex) [consulte segindex] | Índice de Segmento | Um número positivo identificando com exclusividade o segmento na tabela de referência cruzada (Essa função não usa argumento.)
Significance [consulte significance] | Significância de | A significância estatística de qualquer discrepância entre o valor médio do campo no segmento e o valor médio do campo para toda a população, com um sinal indicando a direção do desvio (Essa função requer um campo numérico como argumento.)
StandardDeviation (stdev) [consulte stdev] | Desvio padrão de | O desvio padrão dos valores não nulos no campo para o segmento (Essa função requer um campo numérico como argumento.)
Sum [consulte sum (um argumento)] | Soma de | A soma dos valores não nulos no campo para o segmento (Essa função requer um campo numérico como argumento.)
Variance [consulte variance] | Variação de | A variação dos valores não nulos no campo para o segmento (Essa função requer um campo numérico com argumento.)
Nota: Certas funções de agregação (tal como a Median e a Mode) podem produzir strings ou resultados de data — quando aplicadas a campos de string ou data. Como não é possível aos visualizadores gráficos exibirem estatísticas de string ou data, não é possível aplicar essas funções aos campos de string ou data exceto no Visualizador de Crosstab (que pode exibir estatísticas de string e data).
Tópico pai: Resumir, segmentar e visualizar dados de focus por meio de tabelas de referência cruzada


Criar uma visualização textual da tabela de referência cruzada

  1. Na janela do Decision Studio, selecione um ou mais campos que pretende usar em sua tabela de referência cruzada.
  2. Escolha Ferramentas>Visualizador de Crosstab ou clique em [image] na barra de ferramentas.

    O Visualizador de Crosstab abre e exibe a tabela — subdividida pelos campos selecionados — de contagens de registros e valores médios para um objetivo numérico, se um estiver configurado.

Nota:
  • Se for iniciado o Visualizador de Crosstab sem selecionar algum campo, é exibida a caixa de diálogo Selecionar Campos e Funções de Agregação [consulte Tabelas de referência cruzada como base para segmentação e visualização de dados]. Depois, se clicar em OK sem escolher nenhum campo, o Visualizador de Crosstab mostra estatísticas de resumo de toda a população.
  • Para alterar a tabela de referência cruzada subjacente [consulte Tabelas de referência cruzada como base para segmentação e visualização de dados] a qualquer momento, escolha Editar>Editar a Tabela de Referência Cruzada ou clique em [image] na barra de ferramentas.
  • Se houver campos de strings na tabela de referência cruzada pedida que não tenham uma interpretação categórica ou geográfica, o Visualizador de Crosstab solicita que sejam interpretados para que possam ser colocados nos bins apropriadamente. É possível escolher a interpretação categórica padrão, usar uma hierarquia categórica salva ou interpretar o campo como geográfico.

Consulte também

Abrir uma tabela de referência cruzada no Decision Studio

Organização de campos e estatísticas em uma tabela de referência cruzada ou gráfico

Tópico pai: Resumir, segmentar e visualizar dados de focus por meio de tabelas de referência cruzada

Visualizações da Tabela de Referência Cruzada

Por defeito, o Visualizador de Crosstab inclui todos os campos como cabeçalhos de linhas [image], com a única exceção de que se realçar exatamente dois campos na janela do Decision Studio antes de abrir o Visualizador de Crosstab, o Visualizador de Crosstab torna um deles cabeçalho de linha e o outro um cabeçalho de coluna.

Quando existem cabeçalhos de colunas e de linhas, só existe espaço para mostrar uma estatística tabulada na hora; se houver mais de uma, o Visualizador de Crosstab tabula cada estatística em seu próprio painel com guias:

Assim como os bins comuns dos campos de divisão, existem três bins extraordinários: o bin nulo [consulte O valor nulo], o bin não classificado e o bin especial de resumo da tabela de referência cruzada, que contém todos os registros do cliente. Por exemplo, os registros que recaem nos bin de Idade 50 — 59 e o bin do resumo de gênero são simplesmente os registros que recaem no bin de Idade 50 — 59. Isso significa que, na prática, ao incluir bins de resumo em uma visualização de tabela de referência cruzada, é possível ler a informação de todas as tabelas de referências cruzadas envolvendo qualquer um dos campos de divisão.

O Visualizador de Crosstab tem as seguintes opções de visualização:

  • Escolha Exibir>Dados Nulos ou clique em [image] na barra de ferramentas, para ligar ou desligar a exibição de bins nulos.
  • Escolha Exibir>Dados Nulos ou clique em [image] na barra de ferramentas, para ligar ou desligar a exibição de bins de resumo.
Nota:

Apesar de todos os binnings conterem um bin para o valor nulo, nem todos os binnings contêm um bin não classificado.

Consulte também

Para maximizar o espaço de tela para uma ferramenta do Decision Studio

Configurar o formato de exibição para valores numéricos e de datas


Organização de campos e estatísticas em uma tabela de referência cruzada ou gráfico

É possível organizar campos e estatísticas usando a área de configuração do gráfico no fundo do Visualizador de Crosstab, Visualizador de Perfil, Visualizador de Distribuição Cruzada ou Visualizador de Mapas:

  • Os campos e as estatísticas presentes na tabela de referência cruzada subjacente [consulte Tabelas de referência cruzada como base para segmentação e visualização de dados] são representados como botões móveis, por exemplo:

  • A barra [image] (Apenas informação) na parte inferior da área de configuração do gráfico mostra campos e estatísticas que fazem parte da tabela de referência cruzada subjacente mas não surgem na tabela ou gráfico exibidos.
  • As partes verdes ( [image]) da área de configuração do gráfico representam aspectos da tabela de referência cruzada ou gráfico com o qual é possível você associar campos:
    Ícone Aspectos da tabela de referência cruzada/gráfico
    eixo x (esquerda — direita), no Visualizador de Distribuição Cruzada ou Visualizador de Perfil
    eixo y (frente — trás), no Visualizador de Distribuição Cruzada
    eixo z (vertical), no Visualizador de Distribuição Cruzada
    Dimensão de comparação de segmento tratado/controlado, no Visualizador de Distribuição Cruzada ou Visualizador de Crosstab; normalmente para usar com um campo de partição
    Campo de divisão de linha, no Visualizador de Crosstab
    Campo de divisão de coluna, no Visualizador de Crosstab
    Localização para blocos plotados e regiões elevadas, no Visualizador de Mapas
    Localização para os inícios das setas, no Visualizador de Mapas
    Localização para os finais das setas, no Visualizador de Mapas
  • As partes lilás ( [image]) da área de configuração do gráfico representam aspectos da tabela de referência cruzada ou gráfico com os quais é possível você associar estatísticas:
    Ícone Aspectos da tabela de referência cruzada/gráfico
    Cor do bloco (cor do bloco, região ou seta no Visualizador de Mapas)
    Altura do bloco (altura do bloco ou região no Visualizador de Mapas)
    Largura do bloco
    Profundidade do bloco
    Volume do bloco
    Estatística tabulada, no Visualizador de Crosstab
    Espessura de uma seta, no Visualizador de Mapas
Tópico pai: Resumir, segmentar e visualizar dados de focus por meio de tabelas de referência cruzada

Associar um campo ou estatística a um aspecto da tabela de referência cruzada/gráfico

Arraste o campo ou estatística (o botão móvel correspondente na área de configuração do gráfico) e solte ao lado do ícone para conseguir o aspecto da tabela de referência cruzada/gráfico desejado.

Enquanto arrasta um campo ou uma estatística, o ponteiro do mouse muda para refletir o que acontecerá ao soltar o botão do mouse:

Ponteiro | Ação
 | Associa o campo ou estatística ao aspecto da tabela de referência cruzada/gráfico.
 | Troca o campo ou estatística arrastada e o campo ou estatística sob o ponteiro do mouse.
 | Não faz nada.
Nota:
  • É possível associar uma estatística a mais de um aspecto de um gráfico criando um botão móvel extra para as estatísticas: Clique com o botão direito do mouse nas estatísticas e escolha Duplicar.

    Para remover uma estatística duplicada indesejada, arraste uma cópia sobre a outra; solte quando o ponteiro do mouse mudar para

    É possível duplicar um campo da mesma forma em Visualizador de Mapas — para uso simultâneo com blocos/regiões plotados e setas.

  • Ao clicar com o botão direito do mouse em um botão móvel representando um campo, é possível lançar um Binning Editor para editar o binning ou uma caixa de diálogo Selecionar Valores para mudar a seleção de registros. Essas operações se aplicam a um conjunto de dados inteiro, não só a visualização atual.
  • Ao clicar com o botão direito do mouse em um botão móvel representando um campo ou estatística, também se tem a opção de filtrar valores do gráfico. Isso é um filtro somente na visualização atual. Se escolher Filtro será exibida uma caixa de diálogo Filtro. Existem diferentes opções para filtros categóricos [consulte Seleção de valor ou filtragem usando um campo categórico] e filtros não categóricos [consulte Seleção ou filtragem de valores usando um campo ou estatística não categórica].

    Não é possível adicionar, editar ou remover um filtro enquanto um segmento no gráfico está selecionado. O Decision Studio remove todos os filtros quando a tabela de referência cruzada ou gráfico atualiza.

  • Quando você usa a dimensão de comparação ( [image]) — frequentemente com um campo de partição — é possível configurar as funções de comparação exibidas. Clique com o botão direito do mouse e escolha Configuração Delta. Na caixa de diálogo Configurar Tipos de Função Delta, é possível escolher se quer incluir todos os registros, registros tratados ou registros de controle - ou uma de várias razões e diferenças. No Visualizador de Distribuição Cruzada, as legendas do eixo e escala de cor são anotadas em conformidade.

Remover um campo ou estatística de uma tabela de referência ou gráfico

Arraste o campo ou estatística (isto é, o botão móvel correspondente) de sua localização atual para a barra [image].


Mostrar mais detalhes em um segmento ou gráfico selecionado

No Visualizador de Perfil, Visualizador de Distribuição Cruzada ou Visualizador de Mapas, faça uma das seguintes ações:
  • Clique duas vezes em um segmento. (Para mostrar mais detalhes para vários segmentos, selecione os segmentos [consulte Selecionar segmentos em uma exibição gráfica] e mantenha pressionada a tecla CTRL ao clicar duas vezes no último segmento.)

    O Decision Studio abre outro visualizador do mesmo tipo, com a mesma especificação de referência cruzada [consulte Tabelas de referência cruzada como base para segmentação e visualização de dados].

  • Selecione um segmento ou segmentos [consulte Selecionar segmentos em uma exibição gráfica] de interesse. No menu Segmentos>Fazer Busca Detalhada, escolha uma ferramenta para criar o perfil dos segmentos selecionados: o Visualizador de Crosstab, Visualizador de Perfil, Visualizador de Distribuição Cruzada ou Visualizador de Mapas.

    Se for escolhido o Visualizador de Perfil de um dos três visualizadores, ou vice-versa, será necessário especificar os campos e estatísticas [consulte Especificar os campos e estatísticas na tabela de referência cruzada] necessários em seu perfil de segmento. Em todos os outros casos, o Decision Studio usa as mesmas especificações de referência cruzada [consulte Tabelas de referência cruzada como base para segmentação e visualização de dados].

Em qualquer um dos campos, o novo visualizador está vinculado ao visualizador original [consulte Relacionamentos das ferramentas] e o gráfico recentemente criado mostra mais detalhes dos segmentos selecionados (se possível).

Nota:
  • Se forem selecionados novos segmentos no primeiro gráfico, o segundo gráfico será atualizado correspondentemente.
  • O mesmo comportamento de busca detalhada se aplica a todos os pares de ferramentas no relacionamento de seguimento de ferramentas [consulte Relacionamentos das ferramentas].
  • No Visualizador de Mapas, o nível de detalhe disponível depende do mapa.
Tópico pai: Resumir, segmentar e visualizar dados de focus por meio de tabelas de referência cruzada


Para aplicar uma tabela de referência cruzada a um focus

É possível aplicar uma especificação de referência cruzada [consulte Tabelas de referência cruzada como base para segmentação e visualização de dados] a um focus para criar uma nova tabela de referência cruzada.
  • No Portrait Miner, clique com o botão direito do mouse na tabela de referência cruzada que pretende aplicar e escolha Aplicar a focus.

Na caixa de diálogo Aplicar Tabela de Referência Cruzada, escolha a tabela de referência cruzada que pretende aplicar, o focus ao qual pretende aplicá-la e o arquivo de tabela de referência cruzada que pretende criar.

Nota:
  • Por padrão, ao aplicar uma tabela de referência cruzada a um focus, os binnings para os campos de divisão provêm do novo focus. Se a caixa apropriada for selecionada, será possível usar os binnings associados à tabela de referência cruzada original.
  • Essa interface do usuário é uma forma de acessar algumas das funcionalidades fornecidas pelo comando de compilação de dados qsxt do Portrait Miner.

Consulte também

Sobre os assistentes do Portrait Miner

Abrir uma tabela de referência cruzada no Decision Studio

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Visualizar e editar arquivos de texto no Portrait Miner

Tópico pai: Resumir, segmentar e visualizar dados de focus por meio de tabelas de referência cruzada


Visualizar e segmentar dados de focus graficamente

  • Criar um conjunto de gráficos de perfil de apenas uma variável
  • Criar um gráfico de crossdistribution de várias variáveis
  • Criar um gráfico em um mapa
  • Criar um mapa de categoria de uma hierarquia de binning categórica
  • Opções que afetam a exibição de gráficos e árvores de decisão
  • Criar um Perfil e Auditoria de um focus


Criar um conjunto de gráficos de perfil de apenas uma variável

  1. Na janela do Decision Studio, selecione um ou mais campos que pretende usar para criar o perfil de seus dados.
  2. Escolha Ferramentas>Visualizador de Perfil ou clique em [image] na barra de ferramentas.

    O Visualizador de Perfil abre e exibe um gráfico de contagens de registros por bin para cada um de seus campos escolhidos.

Nota:
  • Se for configurado um objetivo numérico no focus, o Visualizador de Perfil mostra a média do objetivo como cor do bloco (a menos que seja alterada a preferência da função objetiva).
  • Se for iniciado o Visualizador de Perfil sem selecionar nenhum campo, será exibida a caixa de diálogo Selecionar Campos e Funções de Agregação [consulte Tabelas de referência cruzada como base para segmentação e visualização de dados].
  • Para alterar a tabela de referência cruzada subjacente [consulte Tabelas de referência cruzada como base para segmentação e visualização de dados] a qualquer momento, escolha Editar>Editar a Tabela de Referência Cruzada ou clique em [image] na barra de ferramentas.
  • Se houver campos de strings na tabela de referência cruzada pedida que não tenham uma interpretação categórica ou geográfica, o Visualizador de Perfil solicita que sejam interpretados para serem colocados nos bins apropriadamente. É possível escolher a interpretação categórica padrão, usar uma hierarquia categórica salva ou interpretar o campo como geográfico.
  • É possível associar [consulte Organização de campos e estatísticas em uma tabela de referência cruzada ou gráfico] várias estatísticas à altura do bloco, para comparar estatísticas similares em apenas um conjunto de eixos para cada campo com perfil.

    Desde que não exista nenhuma estatística associada a cor do bloco, o Visualizador de Perfil usa as cores do arco-íris para distinguir os gráficos sobrepostos associados a diferentes estatísticas.

  • Se forem associadas várias estatísticas à altura do bloco, deve-se garantir que os gráficos estejam escalados em conjunto [consulte Escalar um conjunto de gráficos de perfil em conjunto ou independentemente]; caso contrário, não será possível comparar valores para estatísticas diferentes.

Consulte também

Abrir uma tabela de referência cruzada no Decision Studio

Organização de campos e estatísticas em uma tabela de referência cruzada ou gráfico

Opções do histograma e do gráfico de barras

Opções que afetam a exibição de gráficos e árvores de decisão

Orientar uma exibição gráfica usando o mouse

Escalar um conjunto de gráficos de perfil em conjunto ou independentemente

Tópico pai: Visualizar e segmentar dados de focus graficamente


Criar um gráfico de crossdistribution de várias variáveis

  1. Na janela do Decision Studio, selecione um ou mais (normalmente dois ou mais) campos que pretende usar para dividir seus dados.
  2. Escolha Ferramentas>Visualizador de Distribuição Cruzada ou clique em [image] na barra de ferramentas.

    O Visualizador de Distribuição Cruzada abre e exibe uma área de contagens de registros em segmentos definidos pelos seus campos escolhidos.

Nota:
  • O Visualizador de Distribuição Cruzada representa a contagem de registros por altura de bloco, por padrão, se for selecionado um ou dois campos de divisão e usa o volume do bloco se forem selecionados três campos de divisão.
  • Se realçar mais de três campos de divisão, o Visualizador de Distribuição Cruzada usará inicialmente somente três deles, com os demais sendo exibidos na barra [image] (Apenas informação), na parte inferior da janela.
  • Se for configurado um objetivo numérico no focus, o Visualizador de Distribuição Cruzada mostra a média do objetivo como cor do bloco (a menos que seja alterada a preferência de função objetiva).
  • Se foi configurado um campo de partição no focus, o Visualizador de Distribuição Cruzada o inclui na tabela de referência cruzada e o atribui à dimensão de comparação [consulte Organização de campos e estatísticas em uma tabela de referência cruzada ou gráfico] ( [image]). Para uma estatística envolvendo Count, Mean, PercentageRate ou Sum, o Visualizador de Distribuição Cruzada mostra a estatística da população tratada menos a estatística da população de controle. Para todas as outras estatísticas, o Visualizador de Distribuição Cruzada mostra a estatística de toda a população. É possível você alterar a comparação exibida [consulte Associar um campo ou estatística a um aspecto da tabela de referência cruzada/gráfico].
  • Se o Visualizador de Distribuição Cruzada for iniciado sem selecionar nenhum campo, será exibida a caixa de diálogo Campos and Aggregation Functions [consulte Tabelas de referência cruzada como base para segmentação e visualização de dados].
  • Para alterar a tabela de referência cruzada subjacente [consulte Tabelas de referência cruzada como base para segmentação e visualização de dados] a qualquer momento, escolha Editar>Editar a Tabela de Referência Cruzada ou clique em [image] na barra de ferramentas.
  • Se existirem campos de string na tabela de referência cruzada que não apresentem uma interpretação categórica ou geográfica, o Visualizador de Distribuição Cruzada solicitará que sejam interpretados, para serem colocados nos bins apropriadamente. É possível escolher a interpretação categórica padrão, usar uma hierarquia categórica salva ou interpretar o campo como geográfico.

Consulte também

Abrir uma tabela de referência cruzada no Decision Studio

Organização de campos e estatísticas em uma tabela de referência cruzada ou gráfico

Opções do histograma e do gráfico de barras

Opções que afetam a exibição de gráficos e árvores de decisão

Orientar uma exibição gráfica usando o mouse

Tópico pai: Visualizar e segmentar dados de focus graficamente


Criar um gráfico em um mapa

  1. Na janela do Decision Studio, associe um ou mais campos a um mapa, interpretando-os como campos geográficos (se já não tiverem um ícone Geográfico [image] ao seu lado na coluna Interpretações):
    1. Selecione os campos a serem associadas a um mapa.
    2. Escolha Marcar>Interpretações>Geográfico.

      É exibido um navegador de arquivos do Portrait Miner [consulte Navegar para abrir ou salvar um arquivo, sessão ou tabela de banco de dados].

    3. Navegue até o arquivo de mapa necessário.

      O ícone Geográfico [image] na coluna Interpretações na janela do Decision Studio indica a presença de uma interpretação geográfica.

  2. Selecione os campos interpretados geograficamente que pretende usar em seu gráfico de mapa. Os campos devem ser todos associados ao mesmo mapa.
  3. Escolha Ferramentas>Visualizador de Mapas ou clique em [image] na barra de ferramentas.

    O Visualizador de Mapas abre e exibe seu mapa escolhido, com a contagem de registros em cada região representada pela altura do bloco (se foi selecionado somente um campo).

Nota:
  • Também é possível interpretar um campo como geográfico do Binning Editor: clique com o botão direito do mouse no nome do campo no painel Campos e escolha Interpretações>Geográfico.
  • Se você realçar dois ou mais campos geográficos, o Visualizador de Mapas usará inicialmente somente dois deles, com os demais sendo exibidos na barra [image] (Apenas informação), na parte inferior da janela. Em vez de mostrar as contagens de registros, o mapa mostra vinculações de linha entre regiões, a densidade de uma linha representa o número de registros que vinculam a região inicial à região final.

  • Se um objetivo numérico for configurado no focus, o Visualizador de Mapas mostra a média do objetivo como cor do bloco ou cor da conexão de linha, dependendo do tipo de gráfico (a menos que tenha alterado a preferência de função objetiva).
  • Se for iniciado o Visualizador de Mapas sem selecionar quaisquer campos, é exibida a caixa de diálogo Selecionar Campos e Funções de Agregação [consulte Tabelas de referência cruzada como base para segmentação e visualização de dados].
  • Para alterar a tabela de referência cruzada subjacente [consulte Tabelas de referência cruzada como base para segmentação e visualização de dados] a qualquer momento, escolha Editar>Editar a Tabela de Referência Cruzada ou clique em [image] na barra de ferramentas. É necessário os campos de divisão serem todos associados ao mesmo mapa.

Consulte também

Abrir uma tabela de referência cruzada no Decision Studio

Organização de campos e estatísticas em uma tabela de referência cruzada ou gráfico

Opções que afetam a exibição de gráficos e árvores de decisão

Criar um mapa de categoria de uma hierarquia de binning categórica

Orientar uma exibição gráfica usando o mouse

Tópico pai: Visualizar e segmentar dados de focus graficamente


Criar um mapa de categoria de uma hierarquia de binning categórica

  1. No Portrait Miner, clique com o botão direito do mouse no arquivo da hierarquia de binning categórica do qual pretende criar um mapa de categoria e escolha Criar Mapa de Categoria.

    É exibida a caixa de diálogo Criar Mapa de Categoria.

  2. Escolha a localização do novo mapa de categoria.
  3. Opcionalmente, escolha o tipo de mapa de categoria a criar.
  4. Opcionalmente, não escolha substituir um mapa de categoria existente com o mesmo nome.
  5. Clique em OK.
Nota: Essa interface do usuário é uma forma de acessar a maior parte das funcionalidades fornecidas pelo comando de compilação de dados do Portrait Miner, qsmapgen.

Consulte também

Sobre os assistentes do Portrait Miner

Criar um gráfico em um mapa

Salvar uma hierarquia de binning categórica

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Tópico pai: Visualizar e segmentar dados de focus graficamente


Opções que afetam a exibição de gráficos e árvores de decisão

Existem várias opções que controlam a forma como os gráficos aparecem. Algumas são globais e se aplicam a todos os seus gráficos, outras se aplicam somente a gráficos individuais.

Consulte também

Para maximizar o espaço de tela para uma ferramenta do Decision Studio

Rótulos de exibição de campo

Tópico pai: Visualizar e segmentar dados de focus graficamente

Configurar opções globais para exibições gráficas

  1. Na janela do Decision Studio, escolha Editar>Visualizar Preferências.

    É exibida a caixa de diálogo Formato. Três de seus cinco painéis com guias controlam a exibição dos gráficos:

    Painel | Descrição
    Opções de Gráfico | A escolha de elementos a incluir nos gráficos (barras de eixo, rótulos de eixo, grade, marcas de escala e rótulos de escala); escolha de cores para elementos do gráfico; escolha de cores para bins no Binning Editor; escolha e escala de cores [consulte Alterar o intervalo de cores para blocos em um gráfico ou árvore de decisão] para blocos de gráficos; e inverter para preto, branco ou cinza ao imprimir (e salvar a imagem de) um gráfico
    Fonte do Rótulo do Visto | Seleção de fonte para rótulos de escala, ou seja, valores de campo
    Fonte do Rótulo do Eixo | Seleção de fonte para rótulos do eixo, ou seja, nomes de campo
    Etiquetas de Função | Texto de exibição alternativo para nomes de função de agregação
  2. Clique em OK, para confirmar as alterações e fechar a caixa de diálogo.
Nota:
  • As suas configurações são salvas para sessões futuras do Decision Studio, Perfil e Auditorias e Modelos Instantâneos.
  • A configuração Fonte do Rótulo do Eixo também aplica a fonte usada para rotular árvores de decisão.
  • No painel Cores de bin, as configurações Bins e Exceções são as cores que o Binning Editor usa para bins normais e bins de extremidade, respectivamente. (A configuração Bins é também a cor que o Construtor de Árvore de Decisão usa para os gráficos de barra em segmentos nas árvores contínuas.)
  • No painel Cores Elementares, a configuração Mapa são as cores que o Visualizador de Mapas usa para o limite do próprio mapa.

Consulte também

Configurar o formato de exibição para valores numéricos e de datas

Alterar o intervalo de cores para blocos em um gráfico ou árvore de decisão

  1. Na janela do Decision Studio, escolha Editar>Visualizar Preferências. É exibida a caixa de diálogo Formato, com a guia Opções de Gráfico selecionada.
  2. Use o seletor de cores suspenso no painel Bloquear Cores para escolher as cores para representar os valores para "Alta," "Méd" e "Baixa" (por padrão, vermelho, verde e azul, respectivamente). A interpretação exata dessas cores depende da forma da escala de cor escolhida. Para uma árvore de decisão, a interpretação dessas três cores depende das configurações na caixa de diálogo Ver Configuração para Árvore de Decisão [consulte Controlar o uso de cor e profundidade em uma árvore de decisão].

  3. No painel Mapa de Cores do Visualizador, escolha a forma da escala de cor usada:

    Escala | Descrição
    Linear | Uma distribuição equilibrada de cores entre os valores mínimo e máximo, com o mínimo representado pela cor Méd e o máximo representado pela cor Alta
    Linear com Zero (padrão)

    Se não existirem valores negativos: uma distribuição equilibrada de cores entre zero e o valor máximo, com zero representado pela cor Méd e o máximo representado pela cor Alta

    Se existirem valores positivos: uma distribuição equilibrada de cores entre o valor mínimo e zero, com o mínimo representado pela cor Baixa e zero representado pela cor Média

    Se existirem valores negativos e positivos: uma distribuição equilibrada de cores sobre um intervalo de valores centrados em zero, com o mínimo (ou negativo do máximo) representado pela cor Baixa, zero representado pela cor Méd e o máximo (ou negativo do mínimo) representado pela cor Alta
    Discriminação Máxima | Uma distribuição não linear de cores entre os valores mínimo e máximo, de forma que cada gradação de cor percebida corresponda aproximadamente ao mesmo número de registros (assim maximizando a discriminação entre os valores), com o valor mínimo representado pela cor Baixa, o valor médio representado pela cor Méd e o valor máximo representado pela cor Alta
  4. Use a configuração Número de Cores para controlar o número de cores distintas usadas.
  5. Clique em OK.

Para ocultar ou mostrar uma legenda de cor para um gráfico

No Visualizador de Perfil, Visualizador de Distribuição Cruzada ou Visualizador de Mapas, escolha Exibir>Legenda ou clique em [image] na barra de ferramentas.

Nota:

Uma legenda de cor não está disponível no Construtor de Árvore de Decisão.

Para mostrar ou ocultar segmentos para valores nulos ou não classificados em um gráfico

No Binning Editor, Visualizador de Perfil, Visualizador de Distribuição Cruzada ou Visualizador de Mapas:
  • Escolha Exibir>Dados Nulos ou clique em [image] na barra de ferramentas, para ligar ou desligar a exibição de bins nulos.
  • Escolha Exibir>Dados Não Classificados para ligar ou desligar a exibição de bins não classificados.

Mostrar ou ocultar categorias vazias em um gráfico

No Visualizador de Perfil ou Visualizador de Distribuição Cruzada, escolha Exibir>Categorias Vazias para ligar ou desligar a exibição das categorias vazias.

Escalar um conjunto de gráficos de perfil em conjunto ou independentemente

No Visualizador de Perfil, por padrão, todos os gráficos de perfil compartilham uma escala comum no eixo vertical. Para escalar os gráficos independentemente, escolha Exibir>Escalar Globalmente para remover a marca de seleção com essa opção.

Nota:

É possível associar várias estatísticas com altura de bloco, para que dois ou mais gráficos compartilhem um conjunto de eixos. Se escolher escalar independentemente nesse caso, o eixo vertical não é rotulado e não é possível comparar valores de estatísticas diferentes.

Mostrar ou ocultar o eixo vertical em um gráfico de mapa

No Visualizador de Mapas, marque ou desmarque a opção de menu Exibir>Mostrar Eixo de Altura.

Controlar o uso de cor e profundidade em uma árvore de decisão

  1. No Construtor de Árvore de Decisão, escolha Exibir>Configuração.

    É exibida a caixa de diálogo Ver Configuração para Árvore de Decisão.

  2. Usando os menus suspensos, escolha o que representar, se houver, como profundidade e cor de cada segmento.
  3. Configure o Centrar Escala de Cor de Segmento em para

    Raiz da Árvore para usar a cor do meio do intervalo de cor [consulte Alterar o intervalo de cores para blocos em um gráfico ou árvore de decisão] (verde por padrão) para o segmento raiz;

    Gama Média para usar a cor do meio (verde por padrão) para representar o valor entre os extremos que ocorre na árvore de decisão.

    50% da População que Coincide com o Objetivo etc. (a opção depende do tipo de árvore) para usar a cor do meio (verde por padrão) para representar um valor específico da taxa de coincidência, média agregada, uplift, etc.

  4. Clique em OK.


Criar um Perfil e Auditoria de um focus

O Perfil e Auditoria de um focus é um relatório em formato HTML contendo informações detalhadas do focus, incluindo perfis de alguns ou todos os campos no focus, opcionalmente em relação a um ou mais campos de destino.

Para criar um Perfil e Auditoria no Portrait Miner, clique com o botão direito do mouse no focus que pretende auditar e escolha Criar Perfil e Auditoria.

Na caixa de diálogo Criar Perfil e Auditoria é possível escolher os campos ou grupos de campo etiquetados para criar perfil, se pretender ignorar um campo de partição e os campos de destino a usar. (Se existir um objetivo no focus, é o campo de destino padrão.) Também é possível selecionar um subconjunto de registros no focus usando uma expressão FDL [consulte Expressões].

Após a conclusão, o relatório de auditoria, é exibido na guia Auditoria da caixa de diálogo Criar Perfil e Auditoria.

Nota:
  • É possível escolher os campos a reportar selecionando os nomes de campos ou escolhendo uma ou mais etiquetas [consulte Trabalhar com grupos de campo].
  • É possível escolher uma das quatro opções de formato de imagens usadas na saída HTML:

    svg somente SVG (gráficos vetoriais escaláveis). O SVG oferece a melhor qualidade de imagem e os menores tamanhos de arquivos, mas é necessário que os leitores de seu relatório tenham um navegador Web com um plugin SVG para visualizar ou imprimir essas imagens.

    smallpng SVG mais bitmaps PNG (gráficos de rede portáteis) otimizados para tela. Mesmo sem um plugin SVG, os leitores poderão ver as imagens de seu relatório (mas a qualidade de impressão será relativamente baixa).

    largepng SVG mais bitmaps PNG otimizados para impressora e tela. Os leitores poderão visualizar ou imprimir seu relatório sem a necessidade de um plugin SVG (mas será necessário mais espaço de disco e o relatório pode ficar mais lento na visualização).

    Nenhum Sem imagens.

  • É possível controlar mais aspectos da aparência do Modelo Instantâneo e relatórios de Perfil e Auditoria ao configurar as preferências [consulte Configurar as preferências do Portrait Miner] na seção Auditorias e Instantâneos da janela Preferências.
  • Para o Portrait Miner ser capaz de notificar por e-mail quando o relatório está pronto, é necessário configurar as preferências email e servidor de email apropriadamente.
  • Por padrão, o Portrait Miner salva um Perfil e Auditoria como um arquivo .qshtml único, com imagens incorporadas. Apesar de ser possível abrir esse arquivo no Portrait Miner (clicando duas vezes nele), não é possível usá-lo diretamente fora do Portrait Miner.

    Para criar uma página na web adequada para colocar em um servidor web, clique com o botão direito do mouse no arquivo .qshtml e escolha Desempacotar para arquivo. Escolha uma localização para a pasta e clique em OK. Essa interface do usuário é uma forma de acessar a maior parte das funcionalidades fornecidas pelo comando de compilação de dados do Portrait Miner, qshtmlunpack.

  • É possível criar um Perfil e Auditoria de um conjunto de dados de terceiros clicando com o botão direito do mouse no arquivo no Portrait Miner e escolhendo Auditoria. Na caixa de diálogo exibida, é possível escolher a localização do focus temporário que o Portrait Miner cria no decorrer da preparação do relatório, o nome desse documento aparece em vez de o nome do conjunto de dados originais.
  • A caixa de diálogo Criar Perfil e Auditoria é uma forma de acesso a muitas das funcionalidades fornecidas pelo comando de compilação de dados do Portrait Miner, qsaudit.

Consulte também

Sobre os assistentes do Portrait Miner

Criar um Modelo Instantâneo

Configurar opções globais para exibições gráficas

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Tópico pai: Visualizar e segmentar dados de focus graficamente

Usar um relatório de referência para comparar focus

Um relatório de comparação é como um relatório normal de Perfil e Auditoria, exceto que inclui os perfis dos campos lado a lado nos dois focus, juntamente com detalhes das diferenças entre várias estatísticas, permitindo observar alterações ao longo do tempo, por exemplo.

Para criar um relatório de comparação, crie um relatório de Perfil e Auditoria de seu primeiro focus da forma normal; esse é seu "relatório de referência." Depois crie um relatório de Perfil e Auditoria para seu segundo focus, mas na caixa de diálogo Criar Perfil e Auditoria, especifique o relatório de referência que criou anteriormente.

Nota:
  • É necessário que os campos categóricos tenham os mesmos binnings em ambos os focus.
  • Por padrão, o relatório de comparação inclui os mesmos campos que o relatório de referência. Ao escolher explicitamente os campos a incluir no relatório de comparação, eles são adicionados aos campos cujo perfil foi criado anteriormente.
  • O relatório de comparação usa os mesmos campos de destino que o relatório de referência. Quaisquer campos de destino especificados explicitamente são ignorados.


Metodologia teste/treinamento

  • Metodologia de teste/treinamento para modelagem robusta
  • Para dividir um focus em subpopulações de amostra
  • Aplicar um modelo ou segmentação do Decision Studio para uma população diferente


Metodologia de teste/treinamento para modelagem robusta

Ao compilar um modelo, são necessários alguns meios para determinar sua qualidade. Não é necessário apenas saber o quanto ele descreve bem os dados históricos, mas também o grau de robustez como uma previsão de comportamento futuro.

O problema do sobreajuste Para um scorecard ou árvore de decisão, % ou modelo de agregação, é possível usar uma medida de qualidade, como o índice de Gini, para dar uma indicação de como o modelo descreve um conjunto de dados com precisão: no geral, quanto mais elevado o número, melhor. Mas é necessário ter cuidado para evitar o sobreajuste, que pode ocorrer se seu modelo for muito específico para o conjunto de dados usado para o compilar.

Em princípio, é possível compilar uma árvore de decisão ou um scorecard perfeitamente adequado ao conjunto de dados fornecido. Por exemplo, se existirem recursos suficientes é possível colocar seu campo de identificador de cliente em um bin para que exista um cliente em cada bin, interpretar esse campo como o único candidato de análise e compilar uma árvore de decisão com os níveis necessários para fazer com que todos os segmentos ramificados sejam homogêneos com relação ao objetivo.

Obviamente, um modelo extremamente sobrejustado é de uso limitado. Ele é tão complicado como o conjunto de dados históricos original e não obtém qualquer vantagem dos padrões nos dados. Não fornece quaisquer informações sobre o comportamento do cliente. Mas um modelo muito simples também não consegue tirar vantagem dos padrões nos dados.

De uma certa forma, é possível aplicar conhecimento de negócios para decidir quais campos incluir em um modelo e até como colocar esses campos em bins. Mas existe sempre a tentação de extrair um pouco mais de um modelo e, assim, arriscar um sobreajuste. Por essa razão, são necessários alguns meios para testar seu modelo.

A solução - conjuntos de dados de treinamento e teste Uma forma de evitar o sobreajuste é fazer uma partição de seu focus [consulte Para dividir um focus em subpopulações de amostra] nos conjuntos de dados de treinamento e teste, talvez com cerca de 67% dos dados no conjunto de treinamento e 33% dos dados reservados para o conjunto de teste. É possível compilar um modelo usando dados no conjunto de treinamento e, depois, quando estiver satisfeito com seu poder descritivo, aplicá-lo ao conjunto de teste [consulte Aplicar um modelo ou segmentação do Decision Studio para uma população diferente] para testar seu poder preditivo. Se sua medida de qualidade escolhida cai acentuadamente ao aplicar o modelo (por exemplo, se o Gini cair mais do que cerca de 2%), deve-se esperar um sobreajuste.

Se seu modelo não for suficientemente robusto, é possível voltar ao conjunto de treinamento e tentar melhorar o modelo (mudando os campos, binnings, medições de qualidade incluídos, etc.).

Contudo, se repetir esse processo muitas vezes, há o risco de sobreajustar tudo novamente porque agora está sendo usado todo o focus para influenciar o formato do modelo. A solução é usar três subpopulações de amostra, com talvez 60% dos dados usados para treinamento, 30% para testes e os restantes 10% para validação. Agora é possível usar o feedback do teste para refinar o modelo. Após algumas iterações, é possível aplicar o modelo ao conjunto de validação [consulte Aplicar um modelo ou segmentação do Decision Studio para uma população diferente] para verificar sua robustez.

Tópico pai: Metodologia teste/treinamento

Remoção automática no Construtor de Árvore de Decisão

No Construtor de Árvore de Decisão, é possível usar a remoção automática [consulte Para remover parte de uma árvore de decisão automaticamente] com os conjuntos de dados de teste e de treinamento para criar árvores de decisão que sejam mais robustas. Usando uma remoção de complexidade de custos, o Construtor de Árvore de Decisão identifica automaticamente a árvore removida que tem o melhor desempenho no conjunto de teste.


Para dividir um focus em subpopulações de amostra

  1. Decida acerca do número de subpopulações n e seus tamanhos relativos [image] (onde [image]).
  2. No Visualizador de Dados, derive um campo [consulte Derivar um campo por meio do Visualizador de Dados] usando uma dessas opções:
    • Se desejar duas subpopulações (n = 2), use a função numericTestTrainSplit.
    • Se desejar três subpopulações (n = 3), use a função numericTestTrainValidateSplit.
    • Se pretende subpopulações de igual tamanho ( [image]), use a função sampleEqualSize.
    • Caso contrário, use a seguinte definição:

      Por exemplo, para criar quatro subpopulações, contendo (aproximadamente) 40%, 30%, 20% e 10% da população total respectivamente, é possível usar a seguinte definição de campo:

      a := rndUniform();

      case a < 0.4 : 1; // 0.4 = 40%

      a < 0.7 : 2; // 0.7 = 40% + 30%

      a < 0.9 : 3; // 0.9 = 40% + 30% + 20%

      default : 4

    O focus se encontra agora dividido de acordo com os valores no campo que você derivou. Dependendo da expressão que escolheu, os valores são 1, 2, ..., n, ou 0, 1, ..., n-1.

  3. Interprete o campo como categórico [consulte Para configurar ou limpar uma interpretação de candidato de análise, categórica, geográfica, de exportação ou de chave].
  4. Se preferir, renomeie as novas categorias apropriadamente [consulte Renomear uma categoria].

Para usar uma subpopulação específica, selecione registros [consulte Selecionar registros de clientes] com o valor necessário no campo.

Nota:
  • É possível usar a função testTrainSplit como alternativa para a função numericTestTrainSplit.
  • É possível usar a função testTrainValidateSplit como alternativa para a função numericTestTrainValidateSplit.
  • Como alternativa à caixa de diálogo Selecionar Valores para alternar entre subpopulações, é possível usar o Binning Editor. Vincule [consulte Conectar e desconectar ferramentas] suas ferramentas de análise e visualização à saída do Binning Editor; alterne entre subpopulações selecionando o bin necessário para o campo que derivou.

Consulte também

sampleExactNumber

sampleExactPercentage

sampleStratified

Tópico pai: Metodologia teste/treinamento


Aplicar um modelo ou segmentação do Decision Studio para uma população diferente

  • A forma mais simples de aplicar um modelo a uma população diferente é alterar a seleção de registros atual [consulte Selecionar registros de clientes].
  • Se você pretende aplicar uma árvore de decisão, scorecard ou modelo de agregação a uma população em um arquivo de focus separado, salve seu modelo [consulte Salvar uma árvore de decisão, scorecard ou modelo de agregação], abra o outro arquivo de focus e aplique o modelo salvo [consulte Aplicar uma árvore de decisão, scorecard ou modelo de agregação salvo].
  • Se a nova população é um grupo de segmentos selecionados [consulte Selecionar segmentos em uma exibição gráfica] em outra ferramenta do Decision Studio, simplesmente conecte a ferramenta [consulte Conectar e desconectar ferramentas] na qual foi criado seu modelo ou segmentação à fonte de dados apropriada.

A ferramenta atualiza sua tela para mostrar seu modelo ou segmentação aplicada à nova população.

No caso do Construtor de Árvore de Decisão, é possível ver as estatísticas da população original. No modo de visualização de árvore, o Construtor de Árvore de Decisão mostra estatísticas originais entre colchetes sobre as estatísticas aplicadas:

Nas visualizações textuais [consulte Opções para exibir a árvore de decisão], o Construtor de Árvore de Decisão mostra tabelas de números para populações originais e aplicadas.

Nota:
  • É possível controlar quais os conjuntos de números o Construtor de Árvore de Decisão exibirá escolhendo Exibir>Dados>Original ou Exibir>Dados>Aplicado.
  • Se ainda não foi configurado um objetivo na nova população, uma árvore de decisão aplicada mostra somente o número de registros em cada segmento. Uma tabela de ganhos [consulte Opções para exibir a árvore de decisão] para a nova população está disponível para árvores binárias e de uplift.
  • Se você compilar uma árvore de decisão e mudar o tipo de árvore, o Construtor de Árvore de Decisão mostra a mesma árvore sobreposta por estatísticas e talvez gráficos para o novo tipo de árvore. O Construtor de Árvore de Decisão mostra as estatísticas originais entre colchetes, como se o modelo fosse aplicado a uma outra população.

Consulte também

Metodologia de teste/treinamento para modelagem robusta Salvar o modelo do Decision Studio ou segmentação para implementação como QMML (XML)
Tópico pai: Metodologia teste/treinamento

Salvar uma árvore de decisão, scorecard ou modelo de agregação

  1. Após compilar um modelo no Construtor de Árvore de Decisão, Construtor de Scorecard ou Construtor de Cluster, escolha Arquivo>Salvar como ou clique em [image] na barra de ferramentas.
  2. Escolha o nome e localização de seus arquivos salvos da árvore de decisão, scorecard ou modelo de agregação no navegador de arquivos do Portrait Miner [consulte Navegar para abrir ou salvar um arquivo, sessão ou tabela de banco de dados].

Consulte também

Compilar um modelo de agregação

Compilar uma árvore de decisão

Aplicar uma árvore de decisão, scorecard ou modelo de agregação salvo

  1. No Construtor de Árvore de Decisão, Construtor de Scorecard ou Construtor de Cluster, como apropriado, escolha Arquivo>Abrir ou clique em [image] na barra de ferramentas.

    É exibido um navegador de arquivos do Portrait Miner [consulte Navegar para abrir ou salvar um arquivo, sessão ou tabela de banco de dados].

  2. Navegue até o arquivo de árvore de decisão, scorecard ou modelo de agregação necessário.
Nota: O focus atual deve conter campos com os mesmos nomes e tipos usados pelo modelo.


Compilar árvores de decisão para segmentação e modelagem preditiva

  • Compilar uma árvore de decisão
  • Opções para exibir a árvore de decisão
  • Controlar a compilação de uma árvore de decisão
  • Para remover segmentos indesejados da árvore de decisão


Compilar uma árvore de decisão

  1. Opcionalmente, interprete alguns campos como candidatos de análise [consulte Para configurar ou limpar uma interpretação de candidato de análise, categórica, geográfica, de exportação ou de chave].

    Se existem campos com uma interpretação do candidato de análise, o Construtor de Árvore de Decisão apenas considera esses campos ao compilar ramificações da árvore de decisão.

  2. Interpretar um campo como o objetivo de modelagem .
  3. Somente para árvores uplift, interprete um campo como o campo de partição. (É possível compilar uma árvore uplift se o campo de partição contiver 0 e 1 e nenhum outro valor, incluindo o valor nulo.)
  4. Escolha Ferramentas>Construtor de Árvore de Decisão ou clique em [image] na barra de ferramentas.
  5. Se for necessário, mude o tipo de árvore (para árvore binária, árvore categórica ou árvore contínua), usando o menu suspenso da barra de ferramentas.
    Se não estiver usando um campo de partição:
    • Use uma árvore categórica para um objetivo com valores categóricos (ou uma árvore binária para um objetivo de dois valores).
    • Use uma árvore contínua para um objetivo não categórico.
    Se quiser usar um campo de partição para executar modelagem de elevação:
    • Para um objetivo de dois valores, use uma elevação binária + árvore para modelagem aditiva ou use uma elevaçãobinária x árvore para modelagem multiplicativa.
    • Use uma árvore contínua para um objetivo não categórico.
    • Não é possível usar um objetivo categórico com mais de dois valores.
  6. Se necessário, altere as opções padrão de compilação [consulte Controlar a compilação de uma árvore de decisão].
  7. Escolha Clustering>Compilar até ao Fim ou clique em [image] na barra de ferramentas, para compilar uma árvore de decisão.

Nota:
  • Para adicionar outro nível à árvore atual (não aplicada), escolha Árvore>Compilar Próximo Nível ou clique em [image].
  • Em cada visualização de árvore de decisão [consulte Opções para exibir a árvore de decisão], dois painéis à esquerda mostram campos incluídos (candidatos de análise) e campos excluídos (outros campos no focus).

    É possível interpretar um campo com um candidato de análise movendo-o do painel inferior para o painel superior (e vice-versa), usando os botões de seta entre os painéis. Se estiver compilando um nível de uma árvore de cada vez, é possível usar um conjunto diferente de candidatos de análise para cada nível da árvore.

    Os campos que são usados na árvore de decisão atual aparecem em negrito (independentemente de serem atualmente candidatos de análise).

  • Ao começar a compilar uma árvore de decisão, o Construtor de Árvore de Decisão solicita que sejam interpretados quaisquer campos de cadeia que não têm uma interpretação categórica, para que possam ser colocados em bins apropriadamente. É possível escolher a interpretação categórica padrão ou usar uma hierarquia categórica salva. Se clicar em Cancelar ao ser solicitado para escolher uma interpretação para o campo de string, o Construtor de Árvore de Decisão ignora o candidato de análise e também os campos de string restantes sem uma interpretação categórica.

Consulte também

Controlar a compilação de uma árvore de decisão

Aplicar um modelo ou segmentação do Decision Studio para uma população diferente

Tópico pai: Compilar árvores de decisão para segmentação e modelagem preditiva

Limpar uma árvore de decisão

Para limpar uma árvore de decisão na Construtor de Árvore de Decisão, escolha Árvore>Limpar ou clique em [image] na barra de ferramentas.
Nota: Se o Construtor de Árvore de Decisão estiver exibindo a Visualização de Ganhos ou a Visualização Gráfica, ele muda para mostrar a Visualização de Árvore.


Opções para exibir a árvore de decisão

As seguintes visualizações da Construtor de Árvore de Decisão estão disponíveis:
Exibir | Descrição
Visualização em árvore | Uma representação gráfica de uma árvore de decisão, com toda a população representada no topo e cada nível completo abaixo que representa uma segmentação mais fina
Visualização tabular | Uma representação tabular da árvore de decisão, que mostra estatísticas para cada segmento numerado e uma expressão no estilo FDL que descreve cada segmento. Para uma árvore uplift, o tamanho total da soma dos tamanhos da população de controle e tratada, excluindo quaisquer outros registros.
Visualização de Lista | Uma apresentação alternativa de alguma das informações acima, em um formulário de lista
Visualização de Ganho | Uma tabela de ganhos cumulativa, para os segmentos "filhos" (nível mais baixo, sem filhos) da árvore de decisão, classificado por ordem descendente da taxa de coincidência
Visualização gráfica | Um gráfico Qini, disponível somente para árvores uplift

Para alterar para uma visualização diferente, escolha a visualização a partir do menu Exibir ou clique no botão correspondente na barra de ferramentas.

Consulte também

Opções que afetam a exibição de gráficos e árvores de decisão

Orientar uma exibição gráfica usando o mouse

Tópico pai: Compilar árvores de decisão para segmentação e modelagem preditiva

Para expandir ou recolher parte de uma árvore de decisão

Para se concentrar nas partes interessantes de uma árvore, é possível recolher ou dobrar a subárvore.
  1. Selecione os segmentos [consulte Selecionar segmentos em uma exibição gráfica] que quer dobrar ou desdobrar.
  2. Escolha Segmentos>Dobrar ou Segmentos>Bloquear.

    Ao dobrar segmentos, o Construtor de Árvore de Decisão oculta os descendentes dos segmentos selecionados e marca os segmentos selecionados com um sinal de "+" para indicar que alguns descendentes estão ocultos.

Se preferir, é possível clicar com o botão direito do mouse em um segmento e escolher Dobrar ou Bloquear no menu de contexto.

Nota:
  • A dobragem não é a mesma coisa que a remoção [consulte Remover parte de uma árvore de decisão manualmente]. Ao dobrar parte de uma árvore de decisão, muda somente a visualização da árvore, enquanto os efeitos da remoção afetam o modelo subjacente.
  • Se continuar a compilar a árvore, o Construtor de Árvore de Decisão pode dividir segmentos ocultos (mas os segmentos filhos também ficarão ocultos).


Controlar a compilação de uma árvore de decisão

É possível definir várias restrições [consulte Exibir ou alterar restrições de compilação de árvores] que governem a forma como o Construtor de Árvore de Decisão compila uma árvore de decisão. Também é possível exercer um grau de controle manual bloqueando os [consulte Bloquear e desbloquear segmentos em uma árvore de decisão] segmentos em uma árvore ou removendo [consulte Para remover segmentos indesejados da árvore de decisão] uma árvore.

Consulte também

Compilar uma árvore de decisão

Para remover segmentos indesejados da árvore de decisão

Tópico pai: Compilar árvores de decisão para segmentação e modelagem preditiva

Exibir ou alterar restrições de compilação de árvores

Escolha Árvore>Restrições.

As seguintes configurações estão disponíveis na caixa de diálogo Árvore Constraints:

Configurações | Aplicável a | Descrição
Maximum number of levels in tree | Todos os tipos de árvores | O maior número de gerações em um ramo da árvore (incluindo o segmento "raiz"). Aplica-se apenas ao "compilar até o fim". O Construtor de Árvore de Decisão deixa de compilar a árvore assim que esse número de níveis é criado. Se você escolher Árvore>Compilar Próximo Nível ou clicar em [image] , o Construtor de Árvore de Decisão ignora essa configuração.
I-gain Mínimo para Divisão | Árvores binárias e categóricas | O menor valor aceitável do ganho de informação para uma divisão (um valor entre 0 e 1)
Ganho de R Quadrado Mínimo para Divisão | Árvores contínuas | O menor valor aceitável da medida [image] para uma divisão (um valor entre 0 e 1)
Significância de Elevação Mínima para Divisão | Árvores uplift | O menor valor aceitável da medição de significância da elevação para uma divisão (um valor entre 0 e 1)
Limite para Divisões de Vários Valores | Árvores categóricas e árvores uplift | O número de categorias em um candidato de análise categórica — excluindo nulos e não classificados [consulte O valor nulo] — além do qual o Construtor de Árvore de Decisão já não considera todas as permutações de divisão possíveis Para um candidato de análise com mais categorias que isso, o Construtor de Árvore de Decisão apenas considera divisões que envolvam uma categoria única em um lado e o restante no outro lado.
Tamanho Mínimo de Segmento | Todas as árvores, exceto as árvores uplift | O menor número de registros em um segmento "filho" (nível mais baixo, sem filhos). O Construtor de Árvore de Decisão ignora divisões que iriam resultar em um ou mais segmentos com menos registros. Se for selecionada a caixa Tratar Tamanho de Segmento Mínimo como Percentagem, esse número é tratado como a porcentagem do número de registros na população que é usado para compilar a árvore.
Tamanho de Segmento Mínimo na População Tratada, Tamanho de Segmento Mínimo na População de Controle | Árvores uplift | O menor número de registros, nas populações tratadas e controladas, respectivamente, em um segmento "filho" (nível mais baixo, sem filhos) O Construtor de Árvore de Decisão ignora divisões que poderiam resultar em um ou mais segmentos com registros menores que a população apropriada. A caixa Tratar Tamanho de Segmento Mínimo como Percentagem interpreta os valores como porcentagens da população total, não como porcentagens das populações de controle e tratadas individuais.

Para árvores categóricas, existem duas caixas de seleção adicionais, para forçar o Construtor de Árvore de Decisão a tratar bins não classificados e nulos no objetivo como categorias comuns.

Bloquear e desbloquear segmentos em uma árvore de decisão

Antes de continuar compilando uma árvore de decisão parcialmente compilada, é possível excluir segmentos selecionados em consideração, bloqueando-os.
  1. Selecione os segmentos [consulte Selecionar segmentos em uma exibição gráfica] que quer bloquear ou desbloquear.
  2. Escolha Segmentos>Bloquear ou Segmentos>Desdobrar.

    Quando você bloqueia segmentos, o Construtor de Árvore de Decisão marca segmentos filho abaixo dos segmentos selecionados com um símbolo de cadeado [image].

Se preferir, é possível clicar com o botão direito do mouse em um segmento e escolher Bloquear ou Desdobrar no menu de contexto.


Para remover segmentos indesejados da árvore de decisão

É possível remover segmentos indesejados em uma árvore através da remoção.
Nota: A remoção não é a mesma coisa que a dobragem [consulte Para expandir ou recolher parte de uma árvore de decisão]. Ao remove parte da árvore de decisão, a árvore de decisão subjacente muda, enquanto a dobragem apenas afeta a exibição da árvore.

Consulte também

Bloquear e desbloquear segmentos em uma árvore de decisão

Limpar uma árvore de decisão

Tópico pai: Compilar árvores de decisão para segmentação e modelagem preditiva

Remover parte de uma árvore de decisão manualmente

É possível remover seletivamente segmentos desinteressantes da árvore de decisão.
  1. Selecione segmentos [consulte Selecionar segmentos em uma exibição gráfica] cujos descendentes você deseja remover.
  2. Escolha Segmentos>Remover.

    O Construtor de Árvore de Decisão remove os descendentes de segmentos selecionados e marca os segmentos selecionados com um símbolo de um cadeado para indicar que estão bloqueados.

Se preferir, é possível clicar com o botão direito do mouse em um segmento e escolher Remover no menu de contexto.

Para remover parte de uma árvore de decisão automaticamente

É possível remover automaticamente os segmentos sobreajustados de uma árvore de decisão após a compilação, empregando uma metodologia de teste/treinamento [consulte Metodologia de teste/treinamento para modelagem robusta] e usando a opção Autoremoção [consulte Remoção automática no Construtor de Árvore de Decisão].
  1. Compile sua árvore de decisão [consulte Compilar uma árvore de decisão] em sua população de treinamento.
  2. Aplique a árvore de decisão [consulte Aplicar um modelo ou segmentação do Decision Studio para uma população diferente] à população teste.
  3. Escolha Árvore>Autoremoção ou clique em [image].

O Construtor de Árvore de Decisão remove automaticamente os segmentos que não aumentam o desempenho da árvore de decisão na população teste.


Compilar scorecards para segmentação e modelagem preditiva

  • Sobre o Assistente do Scorecard
  • Compilar um scorecard por meio do Assistente do Scorecard
  • Compilar um scorecard por meio do Construtor de Scorecard
  • Refinar um scorecard ao adicionar ou remover campos
  • Opções para exibir um scorecard
  • Controlar a compilação de um scorecard


Sobre o Assistente do Scorecard

O Assistente do Scorecard automatiza a modelagem do scorecard, usando boas práticas metodológicas: realizando binning otimizado, em seguida, redução variável e, por fim, compilando uma sequência de modelos sobre dados de teste e treinamento para estabelecer o melhor "tamanho de modelo". A metodologia de modelagem inclui as seguintes fases.

Metodologia de teste/treinamento Parte dos dados de origem é usada para o treinamento e outra parte para teste: essa divisão pode ser gerada aleatoriamente ou usando um campo indicador binário designado.

Binning otimizado Os dados de treinamento são usados para selecionar um binning para cada candidato de análise que maximiza sua capacidade preditiva univariável contra o objetivo.

Para campos não categóricos, o assistente do binning otimizado [consulte Otimizar um binning para um campo] é usado repetidamente para selecionar o melhor binning. O número de bins é aumentado até o número de "pontos de mudança" na área do valor médio objetivo do bin exceder um limite configurável (sendo um "ponto de mudança" uma alteração de sinal na inclinação do gráfico). Intuitivamente, isso garante que o perfil do valor médio objetivo, como uma função de cada candidato de análise, é relativamente regular, com poucos altos e baixos.

Para campos categóricos, as categorias onde o valor médio objetivo não é significativamente diferente da média geral são mescladas. É usada uma diferença padrão do teste de médias [consulte significance], com uma Correção de Bonferroni aplicada com base no número total de categorias que aparecem para o campo. Assim, todas as categorias em que o nível de confiança [image] são mescladas (com [image] um limite de significância configurável).

Durante essa fase, os campos com correlação anormalmente elevada para o objetivo são excluídos da análise (com uma mensagem de aviso). É também emitido um aviso para campos em que cada bin individual contém um pequeno número de registros. Ambos os limites são configuráveis.

Redução variável A fase da redução variável reduz o número de candidatos de análise (preditores independentes) daqueles inicialmente marcados para um conjunto de n menor, para diminuir o tempo de execução da fase final de "dimensionamento correto".

O processo divide os candidatos de análise em grupos de até 2n campos e compila um scorecard (usando os dados de treinamento) em cada grupo, descartando os piores campos por meio de uma exclusão por etapas [consulte Refinar um scorecard ao adicionar ou remover campos] até que restem somente os melhores n campos do grupo. Repetindo esse procedimento, acaba-se por identificar os melhores n campos gerais.

Dimensionamento correto A fase de dimensionamento correto seleciona o scorecard que melhor equilibra complexidade (número de preditores) e a capacidade generalizante (como medido pelo conjunto de teste de desempenho). Os dados de treinamento são usados para compilar uma sequência de scorecards com os primeiros que contêm todos os candidatos de análise e cada modelo subsequente, excluindo o pior preditor. O desempenho de cada modelo é avaliado com base nos dados de teste, com o melhor tamanho de modelo selecionado usando um critério configurável. Como fase final, as ponderações no modelo selecionado são reajustadas com base em todos os dados (ou seja, de teste e de treinamento) para aumentar a precisão. Todos os modelos provisórios podem ser salvos em conjunto com os modelos finais, se desejado.

Resultados São gerados vários resultados (opcionalmente), incluindo:

  • Um relatório HTML resumindo a forma como a metodologia foi aplicada, incluindo os parâmetros de entrada e os links para o log de execução detalhado. Isso inclui uma tabela de dados de desempenho que pode ser facilmente apresentada no Excel.
  • O modelo final recomendado (nos formatos .qssc [consulte Salvar uma árvore de decisão, scorecard ou modelo de agregação] e QMML [consulte Salvar o modelo do Decision Studio ou segmentação para implementação como QMML (XML)]).
  • Um relatório do Modelo Instantâneo [consulte Criar um Modelo Instantâneo] para o modelo recomendado.
  • O conjunto de dados final, incluindo os candidatos de análise selecionados, binnings otimizados e predições de modelo. Os conjuntos de dados intermediários também podem ser salvos, se desejado, contendo os metadados gerados pela metodologia até aquele ponto. Eles são normalmente úteis para fazer busca detalhada e explorar as decisões tomadas durante o processo.

Consulte também

Compilar um scorecard por meio do Assistente do Scorecard

Tópico pai: Compilar scorecards para segmentação e modelagem preditiva


Compilar um scorecard por meio do Assistente do Scorecard

Salve seu focus de modelagem, com o campo de objetivo, os candidatos de análise e as variáveis categóricas selecionadas. Essa preparação pode ser automatizada se forem importados metadados de focus [consulte Copiar metadados de um focus para outro] para o focus de modelagem.

No Portrait Miner, clique com o botão direito do mouse no focus e escolha Prever>Assistente do Scorecard.

Na caixa de diálogo Assistente do Scorecard, é possível escolher entre otimizar binnings, selecionar um conjunto reduzido de variáveis para a fase final da construção de modelo ou compilar um modelo de scorecard de tamanho correto. Também é possível configurar detalhes avançados que influenciam o algoritmo de construção de modelo.

Nota:
  • Essa interface do usuário é uma forma de acessar muitas das funcionalidades fornecidas pelo comando de compilação de dados qsscorecardwizard do Portrait Miner.

Consulte também

Sobre o Assistente do Scorecard

Sobre os assistentes do Portrait Miner

Compilar um scorecard por meio do Construtor de Scorecard

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Tópico pai: Compilar scorecards para segmentação e modelagem preditiva


Compilar um scorecard por meio do Construtor de Scorecard

  1. Opcionalmente, interprete alguns campos como candidatos de análise [consulte Para configurar ou limpar uma interpretação de candidato de análise, categórica, geográfica, de exportação ou de chave].

    O Construtor de Scorecard computa estatísticas de pontuação somente em campos que são candidatos de análise (a menos que não existam e, nesse caso, computa estatísticas de todos os campos).

  2. Interpretar um campo como o objetivo de modelagem .
  3. Escolha Ferramentas>Construtor de Scorecard ou clique em [image] na barra de ferramentas.

    O Construtor de Scorecard é aberto.

  4. Se estiver usando um objetivo binário (0/1), escolha o tipo de modelo apropriado no menu Scorecard>Tipo de Modelo: Risco, Resposta, Desistência, Satisfação ou Insatisfação.

    Para um objetivo contínuo, somente o tipo de modelo de valor se encontra disponível.

  5. Novamente, se estiver usando um objetivo binário, é possível escolher Scorecard>Inverter Valor Objetivo para alterar o sentido do campo de objetivo 0/1.

    Por padrão, 1 no objetivo indica defaulter, responder, churner, satisfied customer ou dissatisfied customer, de acordo com o tipo de modelo escolhido.

  6. Se necessário, altere as opções padrão de compilação [consulte Controlar a compilação de um scorecard].
  7. Escolha Scorecard>Compilar ou clique em [image] na barra de ferramentas, para compilar um scorecard.
Nota:
  • Quando o Construtor de Scorecard é inicializado, ele solicita a interpretação de quaisquer campos de string que não apresentem uma interpretação categórica para que possam ser colocados em bins de forma apropriada. É possível escolher a interpretação categórica padrão ou usar uma hierarquia categórica salva. Se clicar em Cancelar quando for informado para escolher uma interpretação para um campo de string, o Construtor de Scorecard ignora esse candidato de análise, juntamente com quaisquer campos de string restantes sem uma interpretação categórica.
  • Sua escolha de tipo de modelo afeta a rotulagem de valores, gráficos etc. (mas somente após ter recompilado seu scorecard). Existe também uma distinção mais fundamental entre os modelos de risco e os outros tipos de modelo de objetivo binário: ao aplicar um modelo de risco, normalmente são aceitos clientes em segmentos com uma taxa padrão prevista baixa; mas ao aplicar um modelo de resposta, de rotatividade, de satisfação ou de insatisfação, normalmente são atingidos clientes em segmentos com uma taxa de resposta/rotatividade/satisfação/insatisfação elevada.
  • Se seu focus contém um campo que representa uma ponderação de registro, selecione esse campo no Construtor de Scorecard e escolha Campos>Definir Ponderação antes de compilar um scorecard. Para ponderações de valores inteiros positivos [image], [image], ..., o scorecard é o mesmo que obteria a partir de um conjunto de dados maior com [image] ocorrências do primeiro registro, [image] do segundo e daí em diante. A interpretação da ponderação é local à instância do Construtor de Scorecard.

Consulte também

Compilar um scorecard por meio do Assistente do Scorecard

Controlar a compilação de um scorecard

Aplicar um modelo ou segmentação do Decision Studio para uma população diferente

Tópico pai: Compilar scorecards para segmentação e modelagem preditiva


Refinar um scorecard ao adicionar ou remover campos

Na Visualização de Campo [consulte Opções para exibir um scorecard] do Construtor de Scorecard, o painel superior mostra campos que estão (devem ser) incluídos no scorecard, enquanto o painel inferior mostra os demais candidatos de análise. Um scorecard que envolva menos campos é potencialmente mais fácil e rápido para implementar e talvez mais robusto [consulte Metodologia de teste/treinamento para modelagem robusta], apesar de poder ser um modelo menos preciso.

Por meio das setas entre os painéis, é possível incluir ou excluir campos manualmente — talvez com base em Gini, V de Cramer ou ganho de informação. É possível automatizar esse processo de seleção de campos, considerando potencialmente as interações entre campos.

  1. Use Campos>Auto Incluir (ou Campos>Auto Excluir) ou clique em [image] (ou [image]) na barra de ferramentas, para incluir (ou excluir) campos.

    É exibida a caixa de diálogo Opção de Auto Inclusão (ou Opções de Auto Exclusão).

  2. Escolha a partir dos seguintes critérios de seleção:
    • Ajuste linear por etapas
    • Medida de qualidade por etapas

    O algoritmo considera a qualidade dos scorecards temporários obtidos ao incluir (ou excluir) um campo por vez. Uma vez incluído (ou excluído) o único campo que resulta no melhor scorecard temporário, o algoritmo repete, até incluir (ou excluir) o número de campos necessários.

    A qualidade do scorecard temporário é determinada pela medida de qualidade atualmente selecionada [consulte Alterar a medida de qualidade usada para compilar o scorecard] — ou pela regressão linear, se for escolhida a opção "Ajuste Linear por Etapas". O scorecard temporário, contudo, é sempre compilado por meio de uma medida de qualidade de regressão linear.

  3. Especifique o número de campos a incluir ou excluir por vez.
  4. Clique em OK para configurar as opções de autoinclusão e autoexclusão.
Nota: É possível compilar um bom primeiro scorecard se forem excluídos todos os campos inicialmente e, em seguida, autoincluir o número necessário de campos por meio do ajuste linear por etapas.
Tópico pai: Compilar scorecards para segmentação e modelagem preditiva


Opções para exibir um scorecard

Estão disponíveis as seguintes visualizações do Construtor de Scorecard:

Exibir | Descrição
Visualização de campo | Uma visualização de dois painéis de candidatos de análise e estatísticas relacionadas, com campos que são incluídos no scorecard no painel superior e com aqueles que são excluídos no painel inferior
Visualização com guias | Uma visualização de um painel com guias do scorecard, apresentando ponderações (pontuações de bin) e estatísticas para um campo por vez
Visualização de scorecard | Uma visualização mais simples do scorecard, mostrando as ponderações (pontuações de bin) para todos os campos em apenas uma visualização
Visualização gráfica | Um dos cinco gráficos [consulte Gráficos do Construtor de Scorecard], em conjunto com painéis que mostram listas de campos incluídos e excluídos
Matriz de correlação | Uma matriz de correlação para os candidatos de análise

Inicialmente, o Construtor de Scorecard mostra a visualização de campo (e as outras visualizações não estarão disponíveis até que um scorecard seja compilado ou aberto). Para alterar para uma visualização diferente, escolha a visualização a partir do menu Exibir ou clique no botão correspondente na barra de ferramentas.

Tópico pai: Compilar scorecards para segmentação e modelagem preditiva

Gráficos do Construtor de Scorecard

Os seguintes gráficos estão disponíveis no Construtor de Scorecard:

Gráfico | Descrição
Gini | A curva Gini para o modelo de scorecard
Histograma | Áreas de clientes sobrepostas que coincidem com o objetivo e clientes que não coincidem com o objetivo contra a pontuação assinalada
Histograma cumulativo | Uma versão cumulativa da referida acima
Curva de estratégia | Uma curva de estratégia, para ajudar a escolher uma pontuação de corte adequada.
Ponderações | Uma representação gráfica do scorecard, com um gráfico de ponderações (pontuações de bin) para cada campo no scorecard

É possível escolher o gráfico para exibição a partir do menu suspenso na parte superior direita do gráfico.

Consulte também

Opções que afetam a exibição de gráficos e árvores de decisão

Orientar uma exibição gráfica usando o mouse


Controlar a compilação de um scorecard

É possível controlar a forma como um scorecard é compilado usando uma medida de qualidade [consulte Alterar a medida de qualidade usada para compilar o scorecard], um solver [consulte Alterar o solver usado para compilar o scorecard] ou um formato [consulte Alterar a forma de um scorecard] diferentes.
Tópico pai: Compilar scorecards para segmentação e modelagem preditiva

Alterar a medida de qualidade usada para compilar o scorecard

A qualidade de um scorecard é uma estimativa de sua precisão. Ao compilar um scorecard, o Construtor de Scorecard tenta maximizar a qualidade do scorecard conforme determinado por uma das três medidas de qualidade.
No menu Scorecard>Medida de Qualidade, escolha uma das seguintes opções:
  • Regressão linear
  • Regressão logística
  • Regressão probit
Nota: Para um objetivo contínuo (não binário), a única medida de qualidade disponível é a regressão linear.

Alterar o solver usado para compilar o scorecard

Com uma determinada medida de qualidade, o Construtor de Scorecard usa um dos cinco solvers para tentar maximizar a qualidade do scorecard. É possível escolher qual solver o Construtor de Scorecard usa e controlar alguns aspectos do comportamento do solver.

  1. Escolha Scorecard>Solver.

    É exibida a caixa de diálogo do Scorecard Solver.

  2. No menu Método, escolha uma das seguintes opções:
    • Simplex
    • Powell
    • Quasi-Newton
    • Conjugar Gradiente
    • Levenberg — Marquardt
Nota: Em geral, não é necessário alterar a medida de qualidade ou quaisquer outras configurações na caixa de diálogo Scorecard Solver. Ao escolher a medida de qualidade [consulte Alterar a medida de qualidade usada para compilar o scorecard], o Construtor de Scorecard escolhe o solver mais poderoso disponível para essa medida.

Alterar a forma de um scorecard

Ao compilar um scorecard, o Construtor de Scorecard trata cada bin de cada campo incluído como uma variável independente ou assinala ponderações em cada campo e, em seguida, transforma essas ponderações de acordo com a importância relativa dos campos no modelo.
  1. Escolha Scorecard>Formulário.

    É exibida a caixa de diálogo do Formulário de Scorecard.

  2. No painel Formulário, escolha "uma ponderação por bin" ou "uma ponderação por campo."
  3. Se for escolhida a mais simples "uma ponderação por campo," especifique como o Construtor de Scorecard transforma as ponderações em cada campo.


Compilar regras de associação e de sequenciação

  • Sobre o Assistente de Regra de Associação
  • Compilar regras de associação e de sequenciação por meio do Assistente de Regra de Associação


Sobre o Assistente de Regra de Associação

O Assistente de Regra de Associação automatiza a descoberta de regras de associação e sequenciação. Isso normalmente é usado para explorar transações detalhadas do cliente, cesta ou dados do evento, para aplicações como:

A análise da cesta de compras identifica combinações de produtos que aparecerem (ou não aparecem) juntos com maior frequência em uma transação de compra (cesta de itens).

O melhor produto seguinte determina a sequência mais comum em que os produtos ou serviços são comprados; por exemplo, é mais provável que os clientes do banco abram contas de investimento/comerciais após abrirem uma conta poupança com taxa de juro elevada.

A análise de impacto do marketing identifica padrões de comunicações de marketing mais prováveis de ocorrerem antes de uma compra

A preparação de dados O Assistente de Regra de Associação executa diretamente com transações ou dados do evento armazenados em um conjunto de dados de um focus, se beneficiando do acesso aos dados de alto desempenho do Portrait Miner.
  • Para a análise da Cesta de Compras, é necessário usar um conjunto de dados de nível do item que contenha um registro por item. O conjunto de dados deve incluir um campo identificador de cesta que agrupe itens na mesma cesta e também um campo identificador de produto (binado e categórico) que indica o nome ou código do produto para cada item. O conjunto de dados deve ser classificado pelo campo-chave identificador da cesta.
  • Para a análise do Produto Seguinte, é necessário escolher um conjunto de dados com um registro por produto ou serviço. O conjunto de dados deve conter um identificar de cesta — muitas vezes o identificador do cliente — que agrupe os produtos, juntamente com o identificador do produto (em bin e categórico) e um carimbo de data/hora de um produto (integer ou date) que indique a ordem pela qual os produtos foram adquiridos. O conjunto de dados deve ser classificado pelo campo-chave identificador da cesta.

Parâmetros do algoritmo O Assistente de Regra de Associação apriori é baseado no algoritmo padrão do setor e inclui uma ampla gama de funcionalidades para controlar a descoberta da regra. Para obter mais informações sobre o algoritmo Apriori, consulte a documentação da mídia de lançamento do Portrait Miner (DVD/zip). A documentação está localizada em \server\Components\ext\qsruleminer\docs\apriori_docs.

É possível restringir a descoberta de regra a certos produtos de interesse e controlar vários parâmetros que definem o que é uma regra de interesse (suporte, confiança, complexidade da regra, medidas ampliadas de seleção de regra). Note que essas configurações podem ter impacto no tempo de execução: em particular, reduzir o valor mínimo de suporte aumentará o tempo de execução, a menos que seja especificada também uma complexidade de regra máxima (número de antecessores).

Terminologia O Assistente de Regra de Associação usa diversos termos que podem ser desconhecidos, incluindo:

Regra Em geral, uma regra declara se um conjunto de condições é satisfeito (o lado esquerdo ou o antecessor da regra), depois ocorrerá uma outra condição (o lado direito ou o consequente da regra). Nas regras de associação e sequenciamento, as condições na regra correspondem à presença de certos itens na cesta. Por exemplo, uma regra simples pode ser: se uma cesta contém pão, então também conterá geleia.

Antecessor O lado esquerdo de uma regra, ou seja, o conjunto de itens que devem aparecer em uma cesta para que a regra seja relevante.

Consequente O lado direito de uma regra, ou seja, o conjunto de itens que a regra prevê estarem presentes quando o lado esquerdo (antecessor) é satisfeito.

Suporte O suporte (absoluto) de um conjunto de itens corresponde ao número de cestas que contêm todos os itens no conjunto. Suporte relativo é o mesmo número expresso como porcentagem do número total de cestas.

Suporte da Regra O suporte de uma regra é o suporte do antecessor da regra, ou seja, a proporção de cestas às quais se aplica a regra do lado esquerdo. Isso mede a frequência de relevância da regra.

Confiança de Regra A confiança de uma regra é o suporte do conjunto de todos os itens que aparecem na regra (à esquerda ou direita), dividido pelo suporte do antecessor da regra. Mede a probabilidade do consequente da regra (lado direito) ser verdadeiro, considerando que o antecessor da regra seja satisfeito, ou seja, a probabilidade de a regra estar correta.

Diferença da Confiança Absoluta relativamente ao Anterior A diferença entre as medidas de confiança posteriores e anteriores (com e sem os itens antecessores). Isso mede a maior (ou menor) probabilidade do consequente da regra quando o lado esquerdo da regra é verdadeiro. Por exemplo, a regra "se há pão, então há geleia" não é muito interessante se sua confiança for similar à regra "se (qualquer coisa), então há geleia".

Valor de Elevação A razão das medidas de confiança posteriores e anteriores (com e sem os itens antecessores).

Resultados São gerados vários resultados (opcionalmente), incluindo:
  • Um relatório modelo em HTML interativo resume as regras criadas, as suas métricas e a opção de filtro de regras que interessam.
  • Um conjunto de dados novo criando um conjunto de dados agregado (um registro por identificador de cesta) que indica se a regra selecionada é satisfeita nesse grupo de registros.
  • As regras como código implementável no formato Transaction Measurement Language.
  • As regras como exportação opcional no formato PMML (Predictive Model Markup Language), usando a guia "Implantar", conforme mostrado abaixo.
Tópico pai: Compilar regras de associação e de sequenciação


Compilar regras de associação e de sequenciação por meio do Assistente de Regra de Associação

Salve seu focus de modelagem com o campo de identificador de produto colocado em um bin e categórico. Essa preparação pode ser automatizada se forem importados metadados de focus [consulte Copiar metadados de um focus para outro] para o focus de modelagem.

No Portrait Miner, clique com o botão direito do mouse em um focus e escolha Prever>Assistente de Regra de Associação.

Na caixa de diálogo Assistente de Regra de Associação, é possível escolher o tipo de regras de associação para compilar, selecionar os parâmetros para identificar regras de interesse e qual o identificador de cesta (por padrão, o primeiro campo), identificador de produto (por padrão, o campo de objetivo) e qual campo de carimbo de data/hora de um produto (por padrão, o campo de partição) analisar. É possível restringir as regras criadas para que sempre incluam um conjunto específico de produtos.

Nota:
  • Essa interface do usuário é uma forma de acessar muitas das funcionalidades fornecidas pelo comando de compilação de dados qsruleminer do Portrait Miner.

Consulte também

Sobre o Assistente de Regra de Associação

Sobre os assistentes do Portrait Miner

Tópico pai: Compilar regras de associação e de sequenciação


Compilar modelos de Naive Bayes para segmentação e modelagem preditiva

  • Sobre o Assistente de Naive Bayes
  • Compilar um modelo de propensão por meio do assistente de Naive Bayes


Sobre o Assistente de Naive Bayes

O assistente de Naive Bayes compila um modelo de propensão por meio do teorema de Bayes, combinado com uma presunção ("naive") de independência condicional, para prever o valor de uma categoria de campo de objetivo a partir da evidência fornecida por um ou mais candidatos de análise. Um modelo de Naive Bayes define essencialmente um conjunto de tabelas de referência cruzada: para cada candidato de análise, existe uma tabela de referência cruzada que contém as contagens de frequência de bins de análise relativamente às categorias objetivo.

Uma contagem zero exige especial atenção e o modelo de Naive Bayes incorpora um parâmetro de limite que especifica uma probabilidade padrão (normalmente muito reduzida) para ser usada quando a contagem é zero.

O assistente de Naive Bayes exige que cada campo (quer seja objetivo ou candidato de análise) seja colocado em bins, de forma que para cada campo apenas um número finito e pequeno de valores seja considerado pelo modelo. O campo de objetivo é tratado como categórico; enquanto os candidatos de análise vão buscar seu binning no conjunto de dados de modelagem. Os valores são tratados como categorias separadas.

Resultados São gerados vários resultados (opcionalmente), incluindo:

  • Um relatório de auditoria HTML que resume como a propensão do modelo de Naive Bayes foi aplicada, incluindo os parâmetros de entrada e a comparação com as respostas históricas.
  • O último modelo recomendado nos formatos de Linguagem de Campo Derivado [consulte Sobre Linguagem de Campo Derivado], QMML [consulte Salvar o modelo do Decision Studio ou segmentação para implementação como QMML (XML)] e de Predictive Model Markup Language (PMML).
  • O último conjunto de dados incluindo a predição do modelo.

Consulte também

Compilar um modelo de propensão por meio do assistente de Naive Bayes
Tópico pai: Compilar modelos de Naive Bayes para segmentação e modelagem preditiva


Compilar um modelo de propensão por meio do assistente de Naive Bayes

Salve seu focus de modelagem, com o campo de objetivo, os candidatos de análise e as variáveis categóricas selecionadas. Essa preparação pode ser automatizada se forem importados metadados de focus [consulte Copiar metadados de um focus para outro] para o focus de modelagem.

No Portrait Miner, clique com o botão direito do mouse em um focus e escolha Prever>Assistente Naive Bayes.

Na caixa de diálogo Assistente Naive Bayes, é possível escolher quais os campos de objetivo e categorias e quais os candidatos de análise devem ser analisados, qual limite de Naive Bayes usar e os detalhes dos resultados de modelagem criados.

Consulte também

Sobre o Assistente de Naive Bayes

Sobre os assistentes do Portrait Miner

Tópico pai: Compilar modelos de Naive Bayes para segmentação e modelagem preditiva


Compilar modelos de agregação para segmentação e modelagem preditiva

  • Sobre modelos de agregação no Portrait Miner
  • Compilar um modelo de agregação
  • Opções para exibir um modelo de agregação
  • Controlar a compilação de um modelo de agregação


Sobre modelos de agregação no Portrait Miner

A agregação é uma técnica de modelagem indireta (sem objetivos), usada para segmentar uma população em clusters de registros similares, com base nos valores observados de um ou mais campos de análise.
  • Cada cluster em um modelo de agregação tem um centro, sendo possível pensar nele como um registro contendo um valor para cada candidato de análise (exceto que um campo categórico [consulte Interpretações de campos] é tratado como se fosse um conjunto de campos indicadores [consulte Campos categóricos na agregação]).
  • Cada registro no focus pertence ao cluster cujo centro está mais perto do registro, de acordo com uma distância métrica da soma de quadrados normalizada [consulte Medição do tamanho e separação de clusters].

Consulte também

Controlar a compilação de um modelo de agregação

Compilar um modelo de agregação

Tópico pai: Compilar modelos de agregação para segmentação e modelagem preditiva

Medição do tamanho e separação de clusters

A ideia da agregação assenta em algumas medidas de distância ou proximidade entre registros.

Considere dois registros [image] e [image] (onde [image] é o valor do campo j no registro i). Primeiro normalize os valores para que cada campo tenha média 0 e desvio padrão 1 (para o conjunto de dados no qual o modelo será compilado):

onde [image] e [image] são respectivamente a média e desvio padrão do campo j. Agora defina a distância entre os registros [image] e [image] como a distância da soma de quadrados Euclidianos entre os registros normalizados [image] e [image]:

(Note que não existe raiz quadrada.)

Graças a essa distância métrica, é possível quantificar o tamanho de um cluster (usando uma de duas medidas, radius e ESS) e o grau de separação de um cluster para os outros clusters. Por extensão, também é possível quantificar a qualidade de um modelo de agregação.
  • O radius de um cluster é a distância máxima entre um registro no cluster e o centro do cluster. Um cluster ideal tem um radius de zero.
  • O ESS de um cluster é a soma das distâncias de todos os registros no cluster, partindo do centro do cluster. Um cluster ideal tem ESS zero.

    Para um modelo de agregação, o ESS total é a soma dos valores de ESS para cada um dos clusters. Um modelo ideal tem um ESS total de zero.

  • A separação para um registro é [image], onde [image] é a distância entre o registro e o centro de cluster mais próximo e [image] é a distância entre o registro e o segundo centro mais próximo. Os valores estão entre 0 e 1; um valor mais alto indica que o registro tem uma ligação mais forte a seu cluster atribuído.

    A separação para um cluster é a separação mínima para o registro no cluster. Um cluster bem separado tem um valor próximo de 1.

    A separação para um modelo de agregação é a separação mínima para o registro no cluster. Um bom modelo tem um valor próximo de 1.

Nota:
  • Para fins de computação da distância métrica, um campo categórico deve ser considerado como um conjunto de campos indicadores [consulte Campos categóricos na agregação].
  • Ao aplicar um modelo de agregação a um novo conjunto de dados, os valores são normalizados relativamente aos parâmetros de escala do conjunto de dados original.

Como o Decision Studio compila um modelo de agregação

O Construtor de Cluster no Decision Studio implementa um algoritmo de agregação por k médias sem hierarquia, também conhecido como "Método de Lloyd".

O algoritmo ignora qualquer binning em um campo não categórico. Exclui candidatos de análise não categórica com desvio padrão zero e também candidatos de análise categórica com registros em apenas uma categoria. Cria uma campo falso para cada categoria não vazia de um candidato de análise categórica incluído.

Estabelecendo clusters iniciais (escolhidos ao acaso), o algoritmo move repetidamente registros entre clusters para minimizar o ESS total:
  1. Cada registro é alocado ao cluster cujo centro está mais perto (segundo a distância métrica). Se um registro for equidistante para dois ou mais clusters, o registro é alocado ao primeiro cluster com a distância mínima.
  2. As exceções [consulte Parâmetros para um modelo de agregação] são excluídas.
  3. As médias de clusters são (re)calculadas e para a próxima iteração os centros dos clusters são definidos para serem estas médias de cluster.
  4. As iterações continuam até que um dos critérios de conclusão [consulte Critérios de conclusão para um modelo de agregação] seja satisfeito.

Campos categóricos na agregação

O algoritmo de agregação trata o candidato de análise categórica como se fosse um conjunto de campos indicadores numéricos, um por categoria (incluindo o nulo [consulte O valor nulo] e categorias não classificadas). Cada categoria no campo original é representada pelo valor 1 no campo indicador correspondente e o valor 0 em cada um dos outros campos indicadores.

Por exemplo, um campo categórico, como Gênero, com três categorias, Masculino, Feminino e nulo, é representado por três campos indicadores, que aparecem no Construtor de Cluster como Gênero (Masculino), Gênero (Feminino), e Gênero (Nulo). Um registro para uma cliente feminina tem valores de 0,1 e 0 respectivamente para esses campos indicadores. Um centro de cluster típico pode ter valores de 0,3, 0,2 e 0,5 nesses campos. (Os valores para os campos indicadores correspondentes a um campo categórico somam sempre 1.)

Quando o Construtor de Cluster mostra o número de dimensões usadas para compilar uma agregação, cada campo indicador conta como uma dimensão.

O valor nulo na agregação

Ao computar a distância, o valor nulo [consulte O valor nulo] em um campo não categórico é considerado igualmente próximo a todos os centros do cluster – isto é, sua contribuição para a distância é zero e a distância de um centro de cluster é determinada pelo resto dos campos. % Duplica texto no tópico "Campos categóricos em agregação". A categoria nula em um candidato de análise categórica é tratada da mesma forma que qualquer outra categoria. Se os candidatos de análise são não categóricos, os registros que contêm o valor nulo para todos eles são ignorados (e produzem um resultado de índice de cluster nulo).
Nota: Ao aplicar um modelo de agregação, o Construtor de Cluster trata os valores categóricos que eram vazios ou que não estavam presentes no momento da compilação atribuindo registros que os contenham no cluster nulo.


Compilar um modelo de agregação

  1. Opcionalmente, interprete alguns campos como candidatos de análise [consulte Para configurar ou limpar uma interpretação de candidato de análise, categórica, geográfica, de exportação ou de chave].

    Se existirem campos com interpretações de candidatos de análise, o Construtor de Cluster considera somente esses campos ao criar modelos de agregação.

  2. Escolha Ferramentas>Cluster ou clique em [image] na barra de ferramentas.
  3. Se necessário, altere as opções padrão de compilação [consulte Controlar a compilação de um modelo de agregação].
  4. Escolha Clustering>Compilar até ao Fim ou clique em [image] na barra de ferramentas, para compilar um modelo de agregação.

    O Construtor de Cluster continua até satisfazer um ou mais critérios de conclusão [consulte Critérios de conclusão para um modelo de agregação] para um modelo de agregação.

  5. Opcionalmente, para criar uma maior iteração do modelo de agregação, escolha Clustering>Fazer Iteração Seguinte ou clique em [image] na barra de ferramentas.

    (Se o modelo de agregação convergiu ou os parâmetros de compilação foram alterados, essa opção não está disponível.)

Nota:
  • O Construtor de Cluster é uma ferramenta de compilação de modelos indireta. Assim, não considera qualquer objetivo configurado.
  • Os painéis à esquerda da janela do Construtor de Cluster mostram campos incluídos (candidatos de análise) e campos excluídos (outros campos no focus), com campos que aparecem no modelo de agregação atual mostrados em negrito.

    É possível interpretar um campo com um candidato de análise movendo-o do painel inferior para o painel superior (e vice-versa), usando os botões de seta entre os painéis.

  • Ao iniciar a compilação de um modelo de agregação, o Construtor de Cluster solicita a interpretação de quaisquer campos de strings que não tenham uma interpretação categórica, para que possam ser colocados nos bins corretamente. É possível escolher a interpretação categórica padrão ou usar uma hierarquia categórica salva. Se clicar em Cancelar quando for solicitada a escolha de uma interpretação para um campo de string, o Construtor de Cluster ignora esse candidato de análise, juntamente com quaisquer campos de string restantes sem uma interpretação categórica.
  • As estatísticas para modelos de agregação aparecem no painel Resultados de Clustering. Isso inclui as medições de qualidade do modelo (ESS total e separação) assim como parâmetros de compilação de modelos.

    As estatísticas para os clusters no último modelo a ser compilado no painel Detalhes de Cluster (exceto para a exceção e os clusters nulos). Isso inclui medições de qualidade do cluster (ESS, separação e alcance) e também o número de registros de cada cluster e os valores de campo que descrevem cada centro de cluster.

  • Para limpar o histórico dos modelos de agregação produzidos juntamente com os detalhes do modelo atual, escolha Clustering>Limpar ou clique em [image] na barra de ferramentas.
  • Os clusters em um modelo de agregação são numerados: cada registro tem um índice de cluster associado entre 1 e o número de clusters — a não ser que seja considerado uma exceção [consulte Parâmetros para um modelo de agregação], nesse caso, tem um índice de cluster -1.

    É possível derivar um campo [consulte Derivar um campo do modelo ou tabela de referência cruzada do Decision Studio] contendo o índice de cluster.

Consulte também

Sobre modelos de agregação no Portrait Miner

Controlar a compilação de um modelo de agregação

Aplicar um modelo ou segmentação do Decision Studio para uma população diferente

Tópico pai: Compilar modelos de agregação para segmentação e modelagem preditiva

Escolher o número indicado de clusters

O algoritmo [consulte Como o Decision Studio compila um modelo de agregação] que o Construtor de Cluster usa para compilar um modelo de agregação requer que seja especificado o número alvo de clusters [consulte Parâmetros para um modelo de agregação] antecipadamente.
Se for escolhido um número de clusters inapropriado, o Construtor de Cluster pode não ser capaz de encontrar um bom modelo de agregação:
  • Se forem especificados muito poucos clusters, o Construtor de Cluster mescla clusters distintos. Na pior das hipóteses, é possível quebrar o cluster "natural" e espalhar seu conteúdo nos clusters vizinhos, resultando em um modelo que não captura os clusters verdadeiros.
  • Se você especificar clusters demais, o Construtor de Cluster dividirá alguns cluster em partes pequenas.
Seu conhecimento de negócios pode sugerir um número adequado de clusters para controlar ou será necessário experimentar com diferentes valores e ver qual leva ao melhor modelo. Um método que funciona razoavelmente bem é explorar o fato de que, apesar de ser difícil detectar se você tem poucos clusters, se tiver clusters em excesso, a medida de separação tende a ser baixa.
  1. Comece escolhendo um número bem grande de clusters e compile vários modelos, tentando maximizar a medida de separação.
  2. Se não for possível obter uma estatística de medida de separação perto dos 100%, reduza o número de clusters em um e tente novamente.
  3. Continue até ser possível, para seu número escolhido de clusters, pelo menos obter ocasionalmente um modelo de agregação com uma medida de separação elevada.
Nota:
  • Pode acontecer de nem sempre conseguir o número de clusters que especificou pois o Construtor de Cluster exclui quaisquer clusters vazios do modelo de agregação.
  • Atenção para o fato de que um modelo pode simplesmente ter uma medida de separação elevada porque classifica uma grande porção de registros como exceções.

Otimizar um modelo de agregação

A medida de separação fornece uma indicação razoavelmente boa quando existem clusters demais. Mas, assim que tiver o número correto de clusters, não é tão útil distinguir entre bons e maus modelos.

Uma forma de otimizar seus modelos é manter o número de clusters fixo e compilar um grande conjunto de modelos de agregação, tentando minimizar o ESS total.

Nota: Atenção para o fato de que um modelo pode simplesmente ter uma medida de separação elevada porque classifica uma grande porção de registros como exceções.

Evitar sobreajuste quando compilar um modelo de agregação

Como em qualquer técnica de compilação de modelos, é necessário avaliar e evitar sobreajuste. Aplique uma metodologia de teste/treinamento [consulte Metodologia de teste/treinamento para modelagem robusta] e seja cuidadoso ao usar o seguinte:
  • Campos de análise com um grande número de categorias
  • Um grande número de candidatos de análise (caso em que outro possível problema é de a maioria dos registros acabar como exceções)
  • Um grande número alvo de clusters


Opções para exibir um modelo de agregação

Estão disponíveis as seguintes visualizações do Construtor de Cluster:

Exibir | Descrição
Visualização tabular | Uma visualização tabular, que mostra as estatísticas para modelos de agregação sucessivos na tabela superior e estatísticas para os clusters do mais recente modelo na tabela inferior, em conjunto com painéis que mostram listas de campos incluídos e excluídos
Visualização gráfica | Um gráfico bidimensional ou tridimensional [consulte Gráficos do Construtor de Cluster], em conjunto com um painel que lista campos em um focus (com campos envolvidos no modelo apresentado em negrito)

Inicialmente, o Construtor de Cluster apresenta a visualização tabular (e a visualização gráfica não está disponível até que seja compilado ou aberto um modelo de agregação). Para alternar entre as visualizações tabular e gráfica, escolha a visualização no menu Exibir ou clique no botão correspondente na barra de ferramentas.

Tópico pai: Compilar modelos de agregação para segmentação e modelagem preditiva

Gráficos do Construtor de Cluster

Na visualização gráfica do Construtor de Cluster:
  • Selecione qualquer número de campo no painel esquerdo e clique em Gráfico 2D para obter um conjunto de gráficos de perfil [consulte Criar um conjunto de gráficos de perfil de apenas uma variável] para esses campos.
  • Selecione até três campos no painel esquerdo e clique em Gráfico 3D para obter um gráfico crossdistribution [consulte Criar um gráfico de crossdistribution de várias variáveis] subdividido pelos seus campos escolhidos.

Em qualquer um dos casos, o Construtor de Cluster associa as seguintes estatísticas a aspectos do gráfico:

Estatística para o segmento | Aspecto do gráfico
count | Altura do bloco (ou volume para um gráfico crossdistribution de três campos)
mode do índice do cluster | Cor do bloco
mode ratio [consulte moderatio] do índice do cluster | Brilho do bloco

Quanto mais puro for um segmento - em relação ao ideal de todos os registros caindo dentro de um cluster único - mais brilhante será a cor do bloco para esse segmento. (Uma razão de modo de 1 para o segmento indica que todos os registros nesse segmento estão no mesmo cluster.)

Cada visualização gráfica mostra uma legenda, com blocos com brilho de 50%, 75% e 100%, para dar uma indicação útil de como cada cor varia com o brilho.


Controlar a compilação de um modelo de agregação

É possível controlar a forma como o Construtor de Cluster compila um modelo de agregação escolhendo Clustering>Parâmetros e alterando as configurações na caixa de diálogo Parâmetros de Clustering:

Consulte também

Sobre modelos de agregação no Portrait Miner

Compilar um modelo de agregação

Tópico pai: Compilar modelos de agregação para segmentação e modelagem preditiva

Parâmetros para um modelo de agregação

Na parte superior da caixa de diálogo Parâmetros de Clustering, existem configurações para parâmetros gerais do modelo de agregação:

Configurações | Descrição
Número de clusters | O número alvo de clusters separados no modelo de agregação
Limite de valor atípico | Um multiplicador m que determina os registros a serem tratados como exceções. O Construtor de Cluster trata um registro como exceção se, para um candidato de análise não categórico, a diferença entre o valor para o registro e o valor para o centro de cluster mais próximo excede m desvios padrão do campo. Se não for configurado o limite de exceção, nenhum registro será considerado como exceção.
Semente definida pelo usuário | Uma semente para inicializar os centros de cluster no algoritmo de agregação. Se não for configurada a semente definida pelo usuário, o Construtor de Cluster escolhe uma semente (baseada no relógio do sistema) para cada compilação. Configurar a semente permite a geração de vários modelos de agregação.
Para reproduzir um modelo de agregação anteriormente compilado, configure a semente aleatória para a apresentada no painel Resultados de Clustering.

Critérios de conclusão para um modelo de agregação

Na parte inferior da caixa de diálogo Parâmetros de Clustering, existem configurações que decidem quando o Construtor de Cluster deixará de procurar por modelos de agregação melhorados:

Configurações | Descrição
Iterações Máximas | O número máximo de iterações do algoritmo de agregação que o Construtor de Cluster irá realizar
Movimento Mínimo | O número de registros n de forma que, se o Construtor de Cluster reclassificar menos de n registros entre os clusters durante uma iteração, não irá realizar mais iterações. É possível especificar o número de registros em termos absolutos ou como uma porcentagem da população total.
Nota: O algoritmo do Construtor de Cluster termina quando algum dos critérios de conclusão é satisfeito. Assim, termina quase sempre sem que o outro critério seja satisfeito.


Aplicar modelos e segmentações a novos dados de clientes e de transações

  • Salvar o modelo do Decision Studio ou segmentação para implementação como QMML (XML)
  • Para converter um modelo ou segmentação do Decision Studio para entrega em SAS
  • Para converter um modelo ou segmentação do Decision Studio para implementação em SQL
  • Metadados de modelo
  • Criar um Modelo Instantâneo


Salvar o modelo do Decision Studio ou segmentação para implementação como QMML (XML)

É possível salvar o modelo ou segmentação como um documento QMML (XML) para implementá-lo por meio do assistente do Campos Derivados [consulte Derivar campos em um focus usando o Portrait Miner], o comando do Portrait Miner de compilação de dados qsderive, para o Portrait Dialogue ou o Portrait Interaction Optimizer (via QMML).
  1. Se seu modelo ou segmentação já não estiver expresso em termos de campos derivados em um focus, faça uma das seguintes ações:
    • Para uma árvore de decisão, scorecard ou modelo de agregação, derive campos gerados [consulte Derivar um campo do modelo ou tabela de referência cruzada do Decision Studio] para encapsular as funcionalidades mais importantes de seu modelo.
    • Para uma segmentação gráfica, derive um campo de marcação [consulte Derivar um campo de uma segmentação gráfica] para segmentos-chave da população identificada de seu gráfico.
    • Para uma tabela de referência cruzada (textual ou gráfica), derive um campo de índice [consulte Derivar um campo do modelo ou tabela de referência cruzada do Decision Studio] representando totalmente a segmentação.
    • Para um modelo ou segmentação com base em regras de negócio, derive campos usando o Visualizador de Dados [consulte Derivar um campo por meio do Visualizador de Dados].
  2. No Visualizador de Dados, escolha Arquivo>Exportar como QMML ou clique em [image] na barra de ferramentas.

    É exibido o navegador de arquivos do Portrait Miner.

  3. Procure [consulte Navegar para abrir ou salvar um arquivo, sessão ou tabela de banco de dados] uma localização onde é possível salvar seu documento QMML e escolha um nome.

    O Decision Studio salva um documento QMML contendo definições de campos derivados no focus.

Nota:
  • Ao escolher Arquivo>Exportar como QMML, o Portrait Miner analisa automaticamente o QMML. Isso remove a necessidade de usar o comando de compilação de dados -parse. Se existir um erro, o Portrait Miner o notifica das derivações que não poderão ser analisadas. Nesse caso, é criado um arquivo QMML, mas sem a representação estruturada das derivações do problema.
  • Ao escolher Arquivo>Exportar como QMML, o documento QMML contém um conjunto de regras que lista todos os campos derivados selecionados no Visualizador de Dados, ou todos os campos derivados se não existirem campos selecionados. Independentemente de quais campos aparecem no conjunto de regras, o documento QMML contém definições para todos os campos derivados.
  • Se quiser incluir funções FDL definidas pelo usuário quando estiver analisando um QMML no Decision Studio, é possível definir funções globalmente acessíveis armazenando-as em um arquivo (ou arquivos) em uma pasta listada nas preferências de bibliotecas de derivação [consulte bibliotecas de derivação].

Consulte também

Sobre Transaction Measurement Language

Aplicar um modelo ou segmentação do Decision Studio para uma população diferente

Para converter um modelo ou segmentação do Decision Studio para entrega em SAS

Para converter um modelo ou segmentação do Decision Studio para implementação em SQL

Salvar uma tabela de referência cruzada do Decision Studio

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

XML no Portrait Miner

Tópico pai: Aplicar modelos e segmentações a novos dados de clientes e de transações


Para converter um modelo ou segmentação do Decision Studio para entrega em SAS

É possível converter para o formato SAS por meio do Portrait Miner. É criada uma instrução SAS separada para cada derivação de campo.

No Portrait Miner, clique com o botão direito do mouse no arquivo QMML que pretende converter e escolha Converter para SAS.

Na caixa de diálogo Converter para SAS format, escolha os campos de saída necessários e uma localização para salvar o modelo SAS.

Nota:
  • A funcionalidade para converter em SAS é experimental.
  • Essa interface do usuário é uma forma de acessar muitas das funcionalidades fornecidas pelo comando de compilação de dados qsqmml2sas do Portrait Miner.

Consulte também

Sobre os assistentes do Portrait Miner

Salvar o modelo do Decision Studio ou segmentação para implementação como QMML (XML)

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Tópico pai: Aplicar modelos e segmentações a novos dados de clientes e de transações


Para converter um modelo ou segmentação do Decision Studio para implementação em SQL

É possível converter para o formato SQL por meio do Portrait Miner. É criada uma instrução SQL SELECT para cada derivação de campo. O Portrait Miner suporta os seguintes tipos de bancos de dados:
  • Oracle
  • Teradata
  • Microsoft SQL Server

No Portrait Miner, clique com o botão direito do mouse no arquivo QMML que pretende converter e escolha Converter para SQL.

Na caixa de diálogo Converter QMML para SQL, escolha a tabela de origem e o tipo de banco de dados de destino.

Nota:
  • A funcionalidade para converter em SQL é experimental.
  • Em SQL, a avaliação de tipos inteiros para booleano não é permitida.
  • Essa interface do usuário é uma forma de acessar muitas das funcionalidades fornecidas pelo comando de compilação de dados qsqmml2sql do Portrait Miner.

Consulte também

Sobre os assistentes do Portrait Miner

Salvar o modelo do Decision Studio ou segmentação para implementação como QMML (XML)

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Tópico pai: Aplicar modelos e segmentações a novos dados de clientes e de transações


Metadados de modelo

Metadados são "dados sobre dados". Cada modelo que compile, seja uma árvore de decisão, um scorecard ou um modelo de agregação, tem metadados associados a ele:
  • A data e a hora em que o modelo foi compilado
  • Quem compilou o modelo
  • O focus no qual o modelo foi baseado
  • A versão do Decision Studio usada para compilar o modelo
  • Comentários do modelo (que pode ser editada no Decision Studio)
  • Configurações de parâmetros de compilação de modelos em vigor no momento em que o modelo foi compilado

Ao salvar um modelo [consulte Salvar uma árvore de decisão, scorecard ou modelo de agregação], o arquivo do modelo contém esses metadados em conjunto com a descrição do próprio modelo.

Para visualizar outros metadados associados a uma árvore de decisão ou scorecard, escolha Árvore (no Construtor de Árvore de Decisão) ou Scorecard (no Construtor de Scorecard).

Consulte também

Criar um Modelo Instantâneo
Tópico pai: Aplicar modelos e segmentações a novos dados de clientes e de transações

Anexar comentários a um modelo

É possível adicionar comentários a uma árvore de decisão ou scorecard, que podem ser úteis ao compartilhar seus modelos com outras pessoas — ou mesmo ao voltar a eles depois de não trabalhar com esses modelos durante algum tempo.
  • No Construtor de Árvore de Decisão, para anexar comentários a uma árvore de decisão, escolha Árvore>Editar Comentários de Modelo.
  • No Construtor de Scorecard, para anexar comentários a um scorecard, escolha Scorecard>Editar Comentários de Modelo.

Em ambos os casos, é exibida uma caixa de diálogo com três áreas de comentários editáveis, nas quais é possível registrar a janela de observação aplicável ao modelo, detalhes sobre como foi validado o modelo e quaisquer outras anotações que se queira fazer.

Nota:
  • Os comentários do modelo aparecem como parte de um registro de modelo instantâneo [consulte Criar um Modelo Instantâneo], em conjunto com quaisquer comentários adicionados ao criar o registro.
  • Se for marcada a caixa HTML, o Decision Studio trata pares equilibrados de etiquetas, por exemplo <b>...</b>, como marcação HTML e exibe o comentário correspondente.


Criar um Modelo Instantâneo

Um Modelo Instantâneo é um relatório em formato HTML contendo uma descrição detalhada de uma árvore de decisão ou scorecard, incluindo várias estatísticas de modelos e perfis de todos os campos envolvidos no modelo.

Para criar um Modelo Instantâneo no Portrait Miner, clique com o botão direito do mouse no modelo salvo [consulte Salvar uma árvore de decisão, scorecard ou modelo de agregação] que pretende estudar e escolha Criar Modelo Instantâneo.

Nas caixas de diálogo Instantâneo da Árvore de Decisão ou Instantâneo do Scorecard, é possível escolher visualizar um relatório para o focus ou um focus diferente, e, se preferir, é possível reportar em todos os campos ou em nenhum, ao contrário dos campos envolvidos no modelo.

Nota:
  • Se for especificada uma descrição para o Modelo Instantâneo, ela é exibida, juntamente com os comentários do modelo [consulte Anexar comentários a um modelo], na seção "Metadados Fornecidos pelo Usuário" do relatório.

  • É possível escolher uma das quatro opções de formato de imagens usadas na saída HTML:

    svg somente SVG (gráficos vetoriais escaláveis). O SVG oferece a melhor qualidade de imagem e os menores tamanhos de arquivos, mas é necessário que os leitores de seu relatório tenham um navegador Web com um plugin SVG para visualizar ou imprimir essas imagens.

    smallpng SVG mais bitmaps PNG (gráficos de rede portáteis) otimizados para tela. Mesmo sem um plugin SVG, os leitores poderão ver as imagens de seu relatório (mas a qualidade de impressão será relativamente baixa).

    largepng SVG mais bitmaps PNG otimizados para impressora e tela. Os leitores poderão visualizar ou imprimir seu relatório sem a necessidade de um plugin SVG (mas será necessário mais espaço de disco e o relatório pode ficar mais lento na visualização).

    Nenhum Sem imagens.

  • É possível controlar mais aspectos da aparência do Modelo Instantâneo e relatórios de Perfil e Auditoria ao configurar as preferências [consulte Configurar as preferências do Portrait Miner] na seção Auditorias e Instantâneos da janela Preferências.
  • Para o Portrait Miner ser capaz de notificar por e-mail quando o relatório está pronto, é necessário configurar as preferências email e servidor de email apropriadamente.
  • Por padrão, o Portrait Miner salva um Modelo Instantâneo como um arquivo .qshtml único, com imagens incorporadas. Apesar de ser possível abrir esse arquivo no Portrait Miner (clicando duas vezes nele), não é possível usá-lo diretamente fora do Portrait Miner.

    Para criar uma página na web adequada para colocar em um servidor web, clique com o botão direito do mouse no arquivo .qshtml e escolha Desempacotar para arquivo. Escolha uma localização, selecione ou crie uma pasta e clique em OK.

  • A caixa de diálogo Criar Perfil e Auditoria é uma forma de acesso a muitas das funcionalidades fornecidas pelo comando de compilação de dados do Portrait Miner, qsdtsnapshot ou qsscsnapshot.

Consulte também

Sobre os assistentes do Portrait Miner

Criar um Perfil e Auditoria de um focus

Configurar opções globais para exibições gráficas

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Tópico pai: Aplicar modelos e segmentações a novos dados de clientes e de transações


Preferências do Portrait Miner

  • Usar preferências
  • Binnings e funções do Decision Studio
  • Ferramentas de visualização do Decision Studio
  • Decision Tree Builder
  • Construtor de Scorecard
  • Formatação de data
  • Navegação de arquivos
  • Arquivos simples
  • Bancos de dados
  • Auditorias e Instantâneos
  • Notificação de e-mail
  • Ajuste e administração do sistema
  • Integração de sistemas e RealTime


Usar preferências

  • Configurar as preferências do Portrait Miner
Tópico pai: Preferências do Portrait Miner


Configurar as preferências do Portrait Miner

É possível personalizar vários aspectos do Portrait Miner para atenderem a suas exigências individuais.
  1. No Portrait Miner, escolha Editar>Preferências.
  2. Escolha a seção em questão no painel à esquerda da janela Preferências.

    As opções disponíveis na seção selecionada aparecem no painel direito.

  3. Faça as seguintes alterações:
    • Marque ou desmarque uma caixa de verificação para alterar uma opção ligar/desligar.
    • Clique na célula Valor para editar um número ou texto. (Para abandonar suas alterações ao editar um número ou texto, clique com o botão direito do mouse na célula e escolha Cancelar.)

      Se aparecerem as setas para cima/baixo na célula, é possível usá-las para alterar o valor numérico.

      Se a célula contém um menu suspenso, é possível escolher uma opção do menu.

      Se for exibido [image], é possível você clicar em isso para localizar [consulte Navegar para abrir ou salvar um arquivo, sessão ou tabela de banco de dados] um arquivo ou pasta.

  4. Clique em Salvar para confirmar suas alterações.
  5. Clique em Sair para fechar a janela Preferências.
Nota:
  • As configurações de preferências só começam a fazer efeito ao iniciar um aplicativo.
  • Ao substituir o valor padrão por uma opção, o nome da opção é exibido em negrito na janela Preferências.
  • Para desfazer uma configuração de preferências, restaurando a preferência para seu valor antes de ter aberto a janela Preferências, clique com o botão direito do mouse no nome da preferência e escolha Desfazer.
  • Para restaurar o padrão do sistema de uma preferência, clique com o botão direito do mouse no nome da preferência e escolha Restaurar Padrão.

    Para restaurar os padrões do sistema para todas as preferências na seção atual, escolha Editar>Restaurar Padrões de Seção. Para restaurar os padrões do sistema para todas as preferências, escolha Editar>Restaurar Todos os Padrões.

  • Se for configurado o valor de qualquer uma das preferências gravação de data, escrita completa, ler ou gravação de data para European, American ou YMD na janela Preferências, as outras três preferências são configuradas para o mesmo valor.
  • Os padrões do sistema para as preferências não são necessariamente os mesmos dos padrões de fábrica: Seu administrador de sistema pode ter substituído algumas configurações. Nas descrições das preferências individuais, os padrões de fábrica são indicados.
  • Quaisquer opções configuradas na janela Preferências são aplicadas de forma igual a todas as partes do Portrait Miner.
  • Se for exibido um aviso sobre uma preferência não reconhecida, a explicação mais provável é que uma de suas configurações diz respeito a uma preferência obsoleta. É possível remover a configuração clicando com o botão direito do mouse no nome da preferência e selecionando Restaurar Padrão. (A entrada para a preferência continua a aparecer na janela Preferências até que a grave e saia.)
  • Se não for possível alterar a configuração de uma preferência, isso pode ser devido a seu administrador de sistema ter bloqueado essa preferência para impedir que os usuários façam alterações.
  • Algumas preferências são indicadas somente para usuários experientes, assim, estão ocultas por padrão. Normalmente, só devem ser alteradas pelo administrador do Portrait Miner. Para visualizar todas as preferências, escolha Exibir>Mostrar Todas as Preferências.

Consulte também

Configurar opções globais para exibições gráficas

Configurar o formato de exibição para valores numéricos e de datas

Tópico pai: Usar preferências


Binnings e funções do Decision Studio

  • bins auto-finalizantes
  • bins auto-finalizantes para populações iguais
  • tipo de binning padrão
  • tamanho mínimo de bin padrão (Binning Categórico)
  • número de bins padrão (Binning Categórico)
  • número de bins padrão (Binning numérico)
  • exibir larguras semelhantes
  • número máximo de bins de data
Tópico pai: Preferências do Portrait Miner


bins auto-finalizantes

Seção Binning numérico

Objetivo Controlar se o Decision Studio cria últimos bins [consulte Últimos bins] ao colocar um campo numérico em um bin.

Valores válidos

Valor | Descrição
true (padrão) | Cria últimos bins "inteligentes" para binnings numéricos (mas consulte bins autofinalizantes para populações iguais).
false | Não cria últimos bins para binnings numéricos.
Tópico pai: Binnings e funções do Decision Studio


bins auto-finalizantes para populações iguais

Seção Binning numérico

Objetivo Controlar se o Decision Studio cria últimos bins [consulte Últimos bins] ao colocar um campo numérico em um bin com um binning de população igual.

Valores válidos

Valor | Descrição
true | Trata binnings de população igual da mesma forma que binnings de intervalo igual: usa a configuração de bins autofinalizantes.
false (padrão) | Não cria últimos bins para binnings de população igual.
Tópico pai: Binnings e funções do Decision Studio


tipo de binning padrão

Seção Binning numérico

Objetivo Configurar o tipo de binning padrão que o Decision Studio aplica a campos numéricos e de data.

Valores válidos

Valor | Descrição
intervalo Real (padrão) | Cria binnings de intervalo igual por padrão.
População Igual | Cria binnings de população igual por padrão.
Nota:

É possível substituir essa configuração em uma base por focus: no Binning Editor, escolha Binning>Parâmetros Padrão ou clique em [image] na barra de ferramentas; na guia Não-Categórico, escolha a partir do menu Tipo de Bin.

Tópico pai: Binnings e funções do Decision Studio


tamanho mínimo de bin padrão (Binning Categórico)

Seção Binning Categórico

Objetivo Configurar o tamanho mínimo de bin para um campo categórico no Decision Studio.

Valores válidos Um inteiro não negativo, por padrão 0

Quando o Decision Studio cria um binning categórico em um campo, cria somente bins para valores que ocorrem, no mínimo, no número especificado de registros. Outros valores não são classificados.

Nota: É possível substituir essa configuração em uma base por focus: no Binning Editor, escolha Binning>Parâmetros Padrão ou clique em [image] na barra de ferramentas; na guia Categórico, configure Tamanho Mínimo de Categoria.

Consulte também

número de bins padrão (Binning Categórico)
Tópico pai: Binnings e funções do Decision Studio


número de bins padrão (Binning Categórico)

Seção Binning Categórico

Objetivo Configurar o número máximo de bins para um campo categórico no Decision Studio.

Valores válidos Um inteiro não negativo, por padrão 250

Quando o Decision Studio cria um binning categórico em um campo, somente cria bins até o número de valores máximo especificado (escolhendo os valores mais comuns em primeiro lugar). Outros valores não são classificados.

Nota: É possível substituir essa configuração em uma base por focus: no Binning Editor, escolha Binning>Parâmetros Padrão ou clique em [image] na barra de ferramentas; na guia Categórico, configure Número Máximo de Categorias.

Consulte também

tamanho mínimo de bin padrão (Binning Categórico)
Tópico pai: Binnings e funções do Decision Studio


número de bins padrão (Binning numérico)

Seção Binning numérico

Objetivo Configurar o número de bins alvo padrão para um binning numérico ou de data no Decision Studio.

Valores válidos Um valor inteiro não negativo, por padrão 10

Nota:
  • O número de bins alvo exclui últimos bins [consulte Últimos bins], bins para valores nulos [consulte O valor nulo] e não classificados.
  • É possível substituir essa configuração em uma base por focus: no Binning Editor, escolha Binning>Parâmetros Padrão ou clique em [image] na barra de ferramentas; na guia Não-Categórico, configure Número de Bins desejados.
Tópico pai: Binnings e funções do Decision Studio


exibir larguras semelhantes

Seção Binning numérico

Objetivo Configurar o modo de exibição padrão que o Decision Studio usa para binnings numéricos e de data: histograma ou gráfico de barras [consulte Opções do histograma e do gráfico de barras].

Valores válidos

Valor | Descrição
true (padrão) | Usa o modo de exibição em gráfico de barras.
false | Usa o modo de exibição em histograma.
Nota:
  • O modo de exibição para um binning também afeta as visualizações gráficas no Visualizador de Perfil e no Visualizador de Distribuição Cruzada.
  • É possível substituir essa configuração em uma base por focus: no Binning Editor, escolha Binning>Parâmetros Padrão ou clique em [image] na barra de ferramentas; na guia Não-Categórico, escolha a partir do menu Gráfico.
Tópico pai: Binnings e funções do Decision Studio


número máximo de bins de data

Seção Binning de data

Objetivo Configurar o número máximo de bins para um campo de data (a largura do bin é ajustada em conformidade). Isso evita, por exemplo, colocar em bins inadvertidamente um intervalo de séculos para segundos.

Valores válidos Um valor inteiro entre 1 e 1000, %Isso não está no arquivo ini por padrão 100

Tópico pai: Binnings e funções do Decision Studio


Ferramentas de visualização do Decision Studio

  • tamanho máximo
  • função objetiva
Tópico pai: Preferências do Portrait Miner


tamanho máximo

Seção Agregação

Objetivo Configurar o tamanho da maior tabela de referência cruzada [consulte Tabelas de referência cruzada como base para segmentação e visualização de dados] que o Decision Studio pode criar.

Valores válidos Um inteiro não negativo, por padrão, 100.000

Nota: Para calcular o tamanho de uma tabela de referência cruzada nesse sentido, compute

para uma tabela de referência cruzada que envolva N campos de divisão, com bins [image], [image], ..., [image] respectivamente (incluindo últimos bins [consulte Últimos bins] onde aplicável e nulo [consulte O valor nulo] e bins não classificados). Por exemplo, uma tabela de referência cruzada com os campos de divisão Income e Age, binados em os bins internos 10 e 8 respectivamente, apresenta o tamanho [image].
Tópico pai: Ferramentas de visualização do Decision Studio


função objetiva

Seção Agregação

Objetivo Configurar a função de agregação [consulte Funções de agregação para tabelas de referência cruzada] que o Decision Studio aplica a um objetivo por padrão ao criar uma visualização da tabela de referência cruzada [consulte Criar uma visualização textual da tabela de referência cruzada], gráfico de perfil [consulte Criar um conjunto de gráficos de perfil de apenas uma variável], gráfico de crossdistribution [consulte Criar um gráfico de crossdistribution de várias variáveis] ou gráfico de mapa [consulte Criar um gráfico em um mapa]. (Para os gráficos, o Decision Studio associa os resultado à cor do bloco.)

Valores válidos

Valor | Descrição
any | Mostra um valor arbitrário [consulte any] do objetivo.
countnonnull | Mostra a contagem de registros não nulos [consulte countnonnull/countnonnulls] para o objetivo.
countnull | Mostra a contagem de registros nulos [consulte countnull/countnulls] para o objetivo.
countunique | Mostra o número de valores únicos [consulte countunique] para o objetivo, potencialmente incluindo o valor nulo.
countuniquenonnull | Mostra o número de valores únicos [consulte countuniquenonnull] para o objetivo, não incluindo o valor nulo.
first | Mostra o valor do objetivo para o primeiro registro [consulte first].
last | Mostra o valor do objetivo para o último registro [consulte last].
max | Mostra o valor máximo [consulte max (um argumento)] do objetivo.
mean (padrão) | Mostra o valor médio [consulte mean (um argumento)] do objetivo.
median | Mostra a mediana (valor do meio) [consulte median] do objetivo.
min | Mostra o valor mínimo [consulte min (um argumento)] do objetivo.
modo | Mostra o modo (valor mais comum) [consulte mode] do objetivo.
moderatio | Mostra a proporção de registros que contêm o valor mais comum [consulte moderatio] do objetivo.
percentagerate | Mostra a porcentagem de registros que contêm o valor 1 [consulte percentagerate] para o objetivo (binário).
significance | Mostra a significância da diferença entre a média do objetivo para o segmento e essa para a população geral.
stdev | Mostra o desvio padrão dos valores [consulte stdev] no objetivo.
sum | Mostra a soma dos valores [consulte sum (um argumento)] no objetivo.
variação | Mostra a variação dos valores [consulte variance] no objetivo.
Tópico pai: Ferramentas de visualização do Decision Studio


Decision Tree Builder

  • valor de reposição de sustentação infinito
Tópico pai: Preferências do Portrait Miner


valor de reposição de sustentação infinito

Seção Construtor de Árvore de Decisão

Objetivo O valor de sustentação para um segmento em uma árvore uplift binária x pode ser infinito. Esse valor é usado para representar a sustentação infinita onde ela for reportada (visualizações de texto, campos de resultados etc.).

Valores válidos Um número real não negativo, por padrão

Tópico pai: Decision Tree Builder


Construtor de Scorecard

  • taxa de aceitação
  • transformação de atributo
  • taxa ruim
  • corte
  • duplicando chances
  • regular diferença
  • cartão inicial
  • inverter objetivo
  • iterações
  • modelo
  • número de casas decimais de exatidão
  • uma ponderação por característica
  • medida de qualidade
  • repetições
  • solver
  • tolerância
Tópico pai: Preferências do Portrait Miner


taxa de aceitação

Seção Construtor de Scorecard

Objetivo Configurar o limite da taxa de aceitação inicial [consulte Os campos associados a árvores de decisão, scorecards, modelos de agregação e tabelas de referência cruzada abstratas] (ou taxa de destino) que o Construtor de Scorecard usa.

Valores válidos Um número real entre 0 e 1, por padrão 0,5

Nota: Normalmente, deve-se configurar apenas um entre corte, taxa ruim e taxa de aceitação uma vez que o primeiro destes que é configurado (na ordem aqui listada) sempre toma precedência sobre os outros.
Tópico pai: Construtor de Scorecard


transformação de atributo

Seção Construtor de Scorecard

Objetivo Controlar a forma como o Construtor de Scorecard transforma valores para bins individuais em um modelo com uma ponderação por campo [consulte uma ponderação por característica].

Valores válidos

Valor | Descrição
Gravar Probabilidades (padrão) | Usa o log de chances (a "ponderação da evidência").
Média | Usa a média.
Probabilidades | Usa as chances.
Gravar média | Usa o log da média.
Nota:

É possível substituir a configuração dessa preferência, alterando a forma [consulte Alterar a forma de um scorecard] na caixa de diálogo Formulário de Scorecard.

Tópico pai: Construtor de Scorecard


taxa ruim

Seção Construtor de Scorecard

Objetivo Configurar o limite da taxa ruim inicial [consulte Os campos associados a árvores de decisão, scorecards, modelos de agregação e tabelas de referência cruzada abstratas] (ou taxa de acerto) que o Construtor de Scorecard usa.

Valores válidos Um número real entre 0 e 1, por padrão 0,5

Nota: Normalmente, deve-se configurar apenas um entre corte, taxa ruim e taxa de aceitação, uma vez que o primeiro destes que é configurado (na ordem aqui listada) sempre toma precedência sobre os outros.
Tópico pai: Construtor de Scorecard


corte

Seção Construtor de Scorecard

Objetivo Configurar a pontuação de corte inicial [consulte Os campos associados a árvores de decisão, scorecards, modelos de agregação e tabelas de referência cruzada abstratas] que o Construtor de Scorecard usa.

Valores válidos Um número real, por padrão 500

Nota: Normalmente, deve-se configurar apenas um entre corte, taxa ruim e taxa de aceitação, uma vez que o primeiro destes que é configurado (na ordem aqui listada) sempre toma precedência sobre os outros.
Tópico pai: Construtor de Scorecard


duplicando chances

Seção Construtor de Scorecard

Objetivo Configurar o fator de duplicação inicial [consulte Os campos associados a árvores de decisão, scorecards, modelos de agregação e tabelas de referência cruzada abstratas] que o Construtor de Scorecard usa para a relação entre pontuação e chances.

Valores válidos Um número real positivo, por padrão 20

Consulte também

regular diferença
Tópico pai: Construtor de Scorecard


regular diferença

Seção Construtor de Scorecard

Objetivo Configurar o ponto de regular diferença inicial [consulte Os campos associados a árvores de decisão, scorecards, modelos de agregação e tabelas de referência cruzada abstratas] que o Construtor de Scorecard usa para a relação entre pontuação e chances.

Valores válidos Um número real positivo, por padrão 500

Consulte também

duplicando chances
Tópico pai: Construtor de Scorecard


cartão inicial

Seção Construtor de Scorecard

Objetivo Configurar o scorecard inicial que o Construtor de Scorecard usa ao aplicar um solver iterativo.

Valores válidos

Valor | Descrição
linear (padrão) | Usa a regressão linear (análise discriminante) para gerar um scorecard inicial.
Fixa | Usa um scorecard inicial com ponderações iguais para todas as variáveis.
em dia | Usa o scorecard atual como um scorecard inicial.
Aleatória | Usa um scorecard inicial gerado de forma pseudoaleatória [consulte Sobre funções de números aleatórios em FDL].
Nota:

É possível substituir a configuração dessa preferência, alterando o cartão inicial [consulte Alterar o solver usado para compilar o scorecard] na caixa de diálogo Scorecard Solver.

Tópico pai: Construtor de Scorecard


inverter objetivo

Seção Construtor de Scorecard

Objetivo Alterar a interpretação 1/0 do objetivo.

Valores válidos

Valor | Descrição
true | Interpreta registros com um 0 no objetivo representando defaulters/churners/responders.
false (padrão) | Interpreta registros com um 1 no objetivo representando defaulters/churners/responders.
Nota:

É possível substituir a configuração dessa preferência, usando a opção de menu Scorecard>Inverter Valor Objetivo.

Tópico pai: Construtor de Scorecard


iterações

Seção Construtor de Scorecard

Objetivo Configurar o número máximo de iterações que um scorecard solver iterativo usa.

Valores válidos Um valor inteiro positivo, por padrão 1000

Nota: É possível substituir a configuração dessa preferência, alterando o número máximo de iterações [consulte Alterar o solver usado para compilar o scorecard] na caixa de diálogo Scorecard Solver.

Consulte também

tolerância
Tópico pai: Construtor de Scorecard


modelo

Seção Construtor de Scorecard

Objetivo Controlar o tipo de modelo padrão .

Valores válidos

Valor | Descrição
Risco (padrão) | Compila um modelo de risco.
resposta | Compila um modelo de resposta.
Desistência | Compila um modelo de rotatividade.
Satisfação | Compila um modelo de satisfação.
Insatisfação | Compila um modelo de insatisfação.
Tópico pai: Construtor de Scorecard


número de casas decimais de exatidão

Seção Construtor de Scorecard

Objetivo Controlar o número de casas decimais de precisão para o qual o Construtor de Scorecard realiza cálculos aproximados, como o valor Gini para um scorecard.

Valores válidos Um valor inteiro entre 1 e 8, por padrão 3

Nota: É possível substituir a configuração dessa preferência, escolhendo Scorecard>Solver no Construtor de Scorecard e alterando o número de casas decimais de precisão.
Tópico pai: Construtor de Scorecard


uma ponderação por característica

Seção Construtor de Scorecard

Objetivo Controlar se o Construtor de Scorecard usa uma ponderação por campo ou uma ponderação por bin.

Valores válidos

Valor | Descrição
true (padrão) | Usa uma ponderação por campo.
false | Usa uma ponderação por bin.
Nota:

É possível substituir a configuração dessa preferência, alterando a forma [consulte Alterar a forma de um scorecard] na caixa de diálogo Formulário de Scorecard.

Consulte também

transformação de atributo
Tópico pai: Construtor de Scorecard


medida de qualidade

Seção Construtor de Scorecard

Objetivo Configurar a medida de qualidade que o Construtor de Scorecard usa.

Valores válidos

Valor | Descrição
linear (padrão) | Usa a regressão linear (análise discriminante).
Logística | Usa a regressão logística.
probit | Usa a regressão probit.
Nota:

É possível alterar a configuração dessa preferência, escolhendo uma medida de qualidade [consulte Alterar a medida de qualidade usada para compilar o scorecard] no menu Scorecard>Medida de Qualidade.

Tópico pai: Construtor de Scorecard


repetições

Seção Construtor de Scorecard

Objetivo Configurar o número de vezes que o Construtor de Scorecard aplica um método ao otimizar um scorecard.

O Construtor de Scorecard usa o valor médio de todas as repetições.

Valores válidos Um valor inteiro positivo, por padrão 1

Nota: É possível substituir a configuração dessa preferência, alterando o número máximo de repetições [consulte Alterar o solver usado para compilar o scorecard] na caixa de diálogo Scorecard Solver.
Tópico pai: Construtor de Scorecard


solver

Seção Construtor de Scorecard

Objetivo Configurar o método do solver usado pelo Construtor de Scorecard.

Valores válidos

Valor | Descrição
direct (padrão) | Usa inversão de matriz direta para realizar uma regressão linear.
conjugate gradient | Usa o método conjugate gradient.
levenberg-marquardt | Usa o método Levenberg — Marquardt.
powell | Usa o método Powell.
quasi newton | Usa o método quasi-Newton.
simplex | Usa o método simplex.
Nota:

É possível substituir a configuração dessa preferência (para medidas de qualidade, exceto regressão linear) alterando o método [consulte Alterar o solver usado para compilar o scorecard] na caixa de diálogo Scorecard Solver.

Tópico pai: Construtor de Scorecard


tolerância

Seção Construtor de Scorecard

Objetivo Configurar uma condição de parada para um scorecard solver iterativo, em termos de tolerância fracionária.

Valores válidos Um número real, por padrão 0,0001

Se o valor dessa preferência é [image], o Construtor de Scorecard para um solver iterativo quando os valores sucessivos [image] e [image] da medida de qualidade satisfazem o seguinte:

Nota: É possível substituir a configuração dessa preferência, alterando a tolerância fracionária [consulte Alterar o solver usado para compilar o scorecard] na caixa de diálogo Scorecard Solver.

Consulte também

iterações
Tópico pai: Construtor de Scorecard


Formatação de data

  • Formatos de data
  • gravação de data
  • índice de dia padrão para datas incompletas
  • índice de mês padrão para datas incompletas
  • escrita completa
  • futuro máximo para anos em formato de dois-dígitos
  • ler
  • escrever hora
  • ano dinâmico fixo em formato dois-dígitos
  • escreva em formato específico de localidade
  • ordem de x
Tópico pai: Preferências do Portrait Miner


Formatos de data

Ao trabalhar com arquivos simples e expressões FDL, é possível especificar como o Portrait Miner deve interpretar ou exportar datas e horas, usando o formato de data padrão [consulte Formatos de data padrão] ou um formato de data personalizado [consulte Formatos de data personalizados].

Consulte também

Configurar o formato de exibição para valores numéricos e de datas
Tópico pai: Formatação de data

Formatos de data padrão

Nome | Formato de data
American | MM/DD/AAAA:hh:mm:ss, por exemplo, 12/31/2000:13:36:59
European | DD/MM/AAAA:hh:mm:ss, por exemplo, 31/12/2000:13:36:59
YMD | AAAA/MM/DD:hh:mm:ss, por exemplo, 2000/12/31:13:36:59
Nota:
  • Os três formatos de data padrão também se aplicam a datas sem o componente de horas e somente horas ("datas" somente com o componente de horas). Em datas com somente data ou somente horas, as horas e datas são omitidas, respectivamente.
  • Os formatos American, European e YMD também englobam dados nas formas MMDDAAAA, DDMMAAAA e AAAAMMDD, respectivamente (somente para entradas).

Formatos de data personalizados

É possível especificar um formato de data personalizado usando códigos de caracteres especiais, cada um começando com um sinal de porcentagem %:
Código | Componente da data formatada
%% | O próprio sinal de porcentagem: "%"
%? | Coincide com qualquer caractere
%* | Coincide com qualquer caractere; por exemplo, para ignorar caracteres à direita, use %Y/%m/%d%*
%a | O nome do dia, de forma abreviada ("seg," "ter," ..., "dom")
%A | O nome do dia, completo ("segunda-feira," "terça-feira," ..., "domingo")
%b | O nome do mês, de forma abreviada ("jan," "fev," ..., "dez")
%B | O nome do mês, completo ("janeiro," "fevereiro," ..., "dezembro")
%c | (Entrada) Equivalente a "%a %b %e %T %Y" (Saída) A data e hora na representação padrão para a localização atual
%C | Equivalente a "%a %b %e %T %Z %Y"
%d | O dia do mês, usando dois dígitos ("01," "02," ..., "31")
%D | Equivalente a "%m/%d/%y"
%e | O dia do mês, com apenas um dígito precedido por um espaço (" 1," " 2," ..., "31")
%h | Equivalente a "%b"
%H | A hora do dia, usando o relógio de 24 horas ("00," "02," ..., "23")
%I | A hora do dia, usando o relógio de 12 horas ("01," "02," ..., "12")
%j | O dia do ano, usando três dígitos (datas Julianas) ("001," "002," ..., "366")
%m | O número do mês, usando dois dígitos ("01," "02," ..., "12")
%M | O minuto da hora, usando dois dígitos ("00," "01," ..., "59")
%p | "AM" ou "PM," de acordo com a hora do dia
%r | Equivalente a "%I:%M:%S %p"
%R | Equivalente a "%H:%M"
%S | O segundo do minuto, usando dois dígitos ("00," "01," ..., "61")
%T | Equivalente a "%H:%M:%S"
%x | A data formatada de acordo com a preferência ordem de x
%X | Equivalente a "%x"
%y | O ano do século, usando dois dígitos ("00," "01," ..., "99")
%Y | O ano, usando quadro dígitos
%Z | O nome do fuso horário da localização atual
Nota:
  • Para usar "%D" ou "%y," também é necessário especificar o ano dinâmico ou um ano futuro máximo (mas não ambos).

    Se for configurado um ano dinâmico igual a um ano válido Y, o Portrait Miner interpretará os anos de dois dígitos como anos entre Y - 99 e Y. Por exemplo, se for configurada a preferência para 2077, o Portrait Miner interpreta os anos de dois dígitos 76, 77 e 78 como 2076, 2077 e 1978, respectivamente.

    Se for configurado um ano futuro máximo igual a um valor n positivo e o ano atual for Y, o Portrait Miner interpretará todos os anos de dois dígitos como anos entre Y + n - 99 e Y + n. Por exemplo, se forem configuradas as preferências para 50 e o ano atual for 2002, o Portrait Miner interpretará os anos de dois dígitos 51, 52 e 53 como 2051, 2052 e 1953, respectivamente.

  • Se for configurada a preferência escreva em formato específico de localidade, os códigos "%a," "%A," "%b," "%B," "%C," "%p," "%x," "%X," e "%Z" podem produzir resultados diferentes ao exibir datas (mas não ao interpretá-las).
  • Assim como /, qualquer caractere (exceto para o separador de campo ou marcador nulo) pode ser usado como separador com a data.
  • Para um formato de data sem um componente dia ou mês explícito, é possível especificar um padrão usando o qualificador "dia" ou "mês".
  • Os códigos de caracteres especiais são os da função strftime da biblioteca C padrão.

Exemplo R–1: Strings de Formatação de Data

Exemplo de data | String de formato de data
02/04/2003 27/10/1940 | European
04/02/2003 10/27/1940 | American
2003/04/02 1940/10/27 | YMD
02-abr-2003 27-out-1940 | %d-%b-%Y
02 abr 2003 27 out 1940 | ((%d %b %Y))
2003-04-02 13:25 1940-10-27 08:23 | ((%Y-%m-%d %H:%M))
2003-04-02:13:25 1940-10-27:08:23 | %Y-%m-%d:%H:%M
2 abr 2003 27 out 1940 | ((%e %b %Y))
2 de abril de 2003 | ((%B %e, %Y))
02/04/2003 13:25 27/10/1940 08:23 | ((%d/%m/%Y %H:%M))
2003-04-02 13:25:15000000 | ((%Y-%m-%d %H:%M:%S%*))
2 de abril de 2003 | ((%B %d, %Y))
2-abr-2003 27-out-1940 | %e-%b-%Y
02/04/03 27/10/40 | (European pivot=2010)
04/02/03 10/27/40 | (American pivot=2010)
03/04/02 40/10/27 | (YMD pivot=2010)
02-abr-03 27-out-40 | (%d-%b-%y pivot=2010)
abril 02, 03 | ((%B %d, %y) pivot=2010)
2-abr-03 27-out-03 | (%e-%b-%y pivot=2010)
abril 2, 03 | ((%B %e, %y) pivot=2010)
01:25 PM 08:23 AM | ((%I:%M %p))
13:25 08:23 | %H:%M

Consulte também

índice de dia padrão para datas incompletas

índice de mês padrão para datas incompletas

futuro máximo para anos em formato de dois-dígitos

ano dinâmico fixo em formato dois-dígitos


gravação de data

Seção Formato de Data

Objetivo Configurar o formato a ser usado em arquivos simples e expressões FDL para gravação de datas que não apresentam o componente de tempo.

Valores válidos

Valor | Descrição
American | Escreve datas como MM/DD/AAAA.
European (padrão) | Escreve datas como DD/MM/AAAA.
YMD | Escreve datas como AAAA/MM/DD.
Uma string de formato de data consulte Formatos de data personalizados] | Escreve datas em um formato personalizado.
Nota:

Normalmente, deve-se configurar as preferências gravação de data, write date e write time com o mesmo valor.

Consulte também

ler
Tópico pai: Formatação de data


índice de dia padrão para datas incompletas

Seção Formato de Data

Objetivo Configurar o dia do mês para datas, em arquivos simples e expressões FDL, sem um componente de dia explícito.

Valores válidos Um integer entre 1 e 31 inclusive, 1 por padrão

Nota:
  • Essa configuração se aplica quando o Portrait Miner converte texto para uma data de acordo com um formato de data [consulte Formatos de data personalizados] tal como "%A%M."
  • Para um arquivo ou campo individual simples, é possível substituir a configuração usando a palavra-chave day.

Consulte também

índice de mês padrão para datas incompletas
Tópico pai: Formatação de data


índice de mês padrão para datas incompletas

Seção Formato de Data

Objetivo Configurar o mês do ano para datas, em arquivos simples e expressões FDL, sem um componente de mês explícito.

Valores válidos Um integer entre 1 e 12 inclusive, 1 por padrão

Nota:
  • Essa configuração se aplica quando o Portrait Miner converte texto para data de acordo com um formato de data [consulte Formatos de data personalizados], como "%Y."
  • Para um arquivo ou campo individual simples, é possível substituir a configuração usando a palavra-chave month.

Consulte também

índice de dia padrão para datas incompletas
Tópico pai: Formatação de data


escrita completa

Seção Formato de Data

Objetivo Configurar o formato a ser usado em arquivos simples e expressões FDL para formatar datas que incluem um componente de tempo.

Valores válidos

Valor | Descrição
American | Formata datas como MM/DD/AAAA:hh:mm:ss.
European (padrão) | Formata datas como DD/MM/AAAA:hh:mm:ss.
YMD | Formata datas como AAAA/MM/DD:hh:mm:ss.
Uma string de formato de data consulte Formatos de data personalizados] | Formata datas em um formato personalizado.
Nota:

Normalmente, as preferências escrita completa, gravação de data e escrever hora devem ser configuradas com o mesmo valor.

Consulte também

ler
Tópico pai: Formatação de data


futuro máximo para anos em formato de dois-dígitos

Seção Formato de Data

Objetivo Controlar a interpretação de anos de dois dígitos em arquivos simples e expressões FDL, usando um ano dinâmico relativo ao ano atual.

Valores válidos Um integer entre 0 e 99 inclusive, ou (por padrão) -1

Nota:
  • Essa configuração se aplica aos códigos de formato de data "%D" e "%y" [consulte Formatos de data personalizados].
  • Para um arquivo ou campo individual simples, é possível substituir a configuração usando a palavra-chave future.

Consulte também

ano dinâmico fixo em formato dois-dígitos
Tópico pai: Formatação de data


ler

Seção Formato de Data

Objetivo Configurar o formato padrão usado para interpretar datas em arquivos simples e expressões FDL

Valores válidos

Valor | Descrição
American | Interpreta datas como MM/DD/AAAA:hh:mm:ss.
European (padrão) | Interpreta datas como DD/MM/AAAA:hh:mm:ss.
YMD | Interpreta datas como AAAA/MM/DD:hh:mm:ss.
Uma string de formato de data consulte Formatos de data personalizados] | Interpreta datas em um formato personalizado.
Nota:

Quando o Portrait Miner lê uma data de um arquivo simples, usa o formato fornecido por essa configuração de preferência, a não ser que seja incluída uma especificação de formato explícita no arquivo de descrição de dado simples.

Consulte também

gravação de data

escrita completa

escrever hora

Tópico pai: Formatação de data


escrever hora

Seção Formato de Data

Objetivo Configurar a formatação a ser usada em arquivos simples e expressões FDL para escrever horas (datas somente com os componentes de horas, minutos e segundos).

Valores válidos

Valor | Descrição
American | Escrever horas como hh:mm:ss.
European (padrão) | Escrever horas como hh:mm:ss.
YMD | Escrever horas como hh:mm:ss.
Uma string de formato de data [consulte Formatos de data personalizados] | Escrever horas em um formato personalizado.
Nota:

Normalmente, as preferências escrever hora, gravação de data e escrita completa devem ser configuradas com o mesmo valor.

Consulte também

ler
Tópico pai: Formatação de data


ano dinâmico fixo em formato dois-dígitos

Seção Formato de Data

objetivo Controlar a interpretação de anos de dois dígitos em arquivos simples e expressões FDL, usando um ano dinâmico fixo.

Valores válidos Um integer positivo (por ano) ou (por padrão) -1

Nota:
  • Essa configuração se aplica aos códigos de formato de data "%D" e "%y" [consulte Formatos de data personalizados].
  • Para um arquivo ou campo individuais simples, é possível substituir a configuração usando a palavra-chave pivot.

Consulte também

futuro máximo para anos em formato de dois-dígitos
Tópico pai: Formatação de data


escreva em formato específico de localidade

Seção Formato de Data

Objetivo Controlar o uso de formatação de data específica de localidade, ao usar os códigos de formatação de data [consulte Formatos de data personalizados] "%a," "%A," "%b," "%B," "%C," "%h," "%p," "%x," "%X," e "%Z."

Valores válidos

Valor | Descrição
true | Usa formatação específica de localidade, incluindo nomes de dias e meses localizados.
false (padrão) | Usa um formato de data padrão, com nomes de dias e meses em inglês.
Nota:

O padrão é falso pois atualmente não é possível ao Portrait Miner interpretar datas que envolvem nomes de dias e meses em outro idioma diferente do inglês.

Tópico pai: Formatação de data


ordem de x

Seção Formato de Data

Objetivo Configurar o formato a ser usado para interpretar ou exibir datas ao usar o código de formato de data "%x" ou "%X" [consulte Formatos de data personalizados].

Valores válidos

Valor | Descrição
American | Trata "%x" como mês/dia/ano.
European (padrão) | Trata "%x" como dia/mês/ano.
YMD | Trata "%x" como ano/mês/dia.
Tópico pai: Formatação de data


Navegação de arquivos

  • Início
  • carregador de mapa
  • início do qsexplorer
Tópico pai: Preferências do Portrait Miner


Início

Seção Ambiente

Objetivo Configurar uma localização de "início" que, por sua vez, configura o valor padrão para várias preferências de navegação de arquivos.

Valores válidos A localização de um diretório/pasta (no servidor do Portrait Miner), não definida por padrão (nesse caso, assume o valor da variável de ambiente do sistema operacional com o mesmo nome, se definida)

Tópico pai: Navegação de arquivos


carregador de mapa

Seção Diretórios

Objetivo Configurar a localização inicial que o Portrait Miner mostra quando se navega para abrir o mapa (com a extensão de arquivo .mif).

Valores válidos A localização de um diretório/pasta (no servidor do Portrait Server), por padrão ext/maps no UNIX) ou ext\maps (no Windows) no diretório de instalação do Portrait Miner

Tópico pai: Navegação de arquivos


início do qsexplorer

Seção Diretórios

Objetivo Configurar a localização inicial que o Portrait Miner mostra, e para a qual o botão [image] no Portrait Miner e todos os navegadores de arquivos do Portrait Miner conduzem.

Valores válidos A localização do diretório/arquivo (no servidor do Portrait Miner), por padrão a configuração da preferência Início

Tópico pai: Navegação de arquivos


Arquivos simples

  • percentagem de corte grande
  • tamanho de amostra de formato de dado
  • tamanho de amostra de dados
  • linhas vazias
  • extração de máximos erros
  • extração de máximos avisos
  • ignore avisos de extração
  • tamanho máximo de dado salvo em megabytes
  • permitir erros de formato de dado
Tópico pai: Preferências do Portrait Miner


percentagem de corte grande

Seção Banco de Dados de Arquivo Simples

Objetivo Definir a proporção mínima de registros de amostra necessários para atribuir ao tipo de dado não genérico [consulte Tipos de Dados] para um campo em um arquivo simples.

Valores válidos Um número real entre 1 e 100, por padrão 99

Se os tipos de dados nos campos em um arquivo simples não forem especificados, o Portrait Miner lê os registros de amostra para os atribuir. Para cada campo, se não houver um tipo numérico ou de data que se aplique a pelo menos à porcentagem dada de registros de amostra, é atribuído o tipo de dado string; para cada campo que contenha dados numéricos, se um tipo integer não se aplicar a pelo menos a porcentagem dada dos registros de amostra, é atribuído um tipo de dado real.

Nota:

Para assegurar a atribuição de tipos de dados que se aplicam a cada registro em um arquivo simples, defina essa preferência e o tamanho de amostra de dados para seus valores máximos.

Tópico pai: Arquivos simples


tamanho de amostra de formato de dado

Seção Banco de Dados de Arquivo Simples

Objetivo Definir o número de registros de amostra que o Portrait Miner lê do arquivo simples para determina o separador de campo, string e marcadores de data e nomes de campo, durante a fase inicial da análise de um arquivo simples.
Nota: A preferência "tamanho de amostra de formato de dado" é usada somente na ausência de um arquivo de descrição do arquivo simples (FDD).

Valores válidos Um inteiro entre 1 e 100.000 inclusive, por padrão 100

Se o formato de dados de um arquivo simples não for especificado, o Portrait Miner lê os registros de amostra para o determinar.

Tópico pai: Arquivos simples


tamanho de amostra de dados

Seção Banco de Dados de Arquivo Simples

Objetivo Definir o número de registros de amostra que o Portrait Miner lê de um arquivo simples para determinar os tipos de dados finais [consulte Tipos de Dados] dos campos.
Nota: A preferência "tamanho de amostra de dados" é usada somente na ausência de um arquivo de descrição do arquivo simples (FDD).

Valores válidos Um inteiro positivo, por padrão 1.000

Nota:

Se estiver importando dados diretamente da saída do programa (isto é, através de um "pipe"), os registros de amostra são aqueles que estão no início do fluxo de dados; caso contrário, o Portrait Miner retira registros de amostras que estão distribuídos por todo o arquivo simples.

Consulte também

tamanho de amostra de formato de dado
Tópico pai: Arquivos simples


linhas vazias

Seção Banco de Dados de Arquivo Simples

Objetivo Controlar como o Portrait Miner trata uma linha vazia ao ler um arquivo simples.

Valores válidos

Valor | Descrição
ignore with warning (padrão) | Ignora a linha, mas cria um aviso.
ignore silently | Ignora a linha, sem gerar um aviso.
null | Cria um registro para a linha contendo o valor nulo [consulte O valor nulo] em cada campo.
Tópico pai: Arquivos simples


extração de máximos erros

Seção Banco de Dados de Arquivo Simples

Objetivo Definir o número máximo de erros de formato de dados que o Portrait Miner permite ao ler o arquivo simples.

Valores válidos Um valor inteiro positivo, por padrão 1.000.000

Se o número de erros excede esse valor, o Portrait Miner rejeita o arquivo simples como impossível de ler e aborta a importação.

Nota:

Se o comando de compilação de dados do Portrait Miner qsimportflat estiver sendo usado, é possível substituir essa definição com a opção -maxerrors.

Consulte também

extração de máximos avisos

permitir erros de formato de dado

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Tópico pai: Arquivos simples


extração de máximos avisos

Seção Banco de Dados de Arquivo Simples

Objetivo Configurar o número máximo de avisos em formato de dados que o Portrait Miner permite ao ler um arquivo simples.

Valores válidos Um valor inteiro positivo, por padrão 1.000.000

Se o número de avisos exceder esse valor, o Portrait Miner rejeita o arquivo simples considerando que o arquivo é impossível de ler e aborta a importação.

Nota:

Se o comando de compilação de dados qsimportflat do Portrait Miner estiver sendo usado, é possível substituir essa configuração com a opção - maxwarnings.

Consulte também

extração de máximos erros

ignore avisos de extração

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Tópico pai: Arquivos simples


ignore avisos de extração

Seção Banco de Dados de Arquivo Simples

Objetivo Verificar se o Portrait Miner reporta mensagens de aviso em formato de dados (e compara o número total de avisos com a preferência extração de máximos avisos) ao ler um arquivo simples.

Valores válidos

Valor | Descrição
true | Não reporta mensagens de aviso.
false (padrão) | Reporta mensagens de aviso.
Nota:
  • O Portrait Miner sempre reporta mensagens de erro e o número total de mensagens de aviso.
  • Se o comando de compilação de dados qsimportflat do Portrait Miner estiver sendo usado, é possível substituir essa configuração com a opção - nowarnings.

Consulte também

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Tópico pai: Arquivos simples


tamanho máximo de dado salvo em megabytes

Seção Banco de Dados de Arquivo Simples

Objetivo Configurar a quantidade máxima de dados (em megabytes) que o Portrait Miner escreve em apenas um arquivo ao exportar como texto, usando um arquivo de descrição de dados simples (FDD).

Valores válidos Um valor inteiro superior a 1, por padrão 2048.

Quando a quantidade de dados escritos em um arquivo de dados atinge seu limite, o Portrait Miner cria um novo arquivo de dados e adiciona uma referência de arquivo extra ao arquivo FDD.

Nota:
  • O Portrait Miner ignora a configuração dessa preferência ao exportar como texto sem usar um arquivo FDD.
  • Para assegurar que o Portrait Miner escreve somente dados em apenas um arquivo, mesmo ao usar um arquivo FDD, altere o valor para $MAXLARGEFILESIZEMB.
Tópico pai: Arquivos simples


permitir erros de formato de dado

Seção Banco de Dados de Arquivo Simples

Objetivo Verificar o comportamento do Portrait Miner ao encontrar erros de formato de dado em arquivos simples.

Valores válidos

Valor | Descrição
true (padrão) | Trata os erros de formato de dado como mensagens.
false | Trata os erros de formato de dado como erros.

Consulte também

extração de máximos erros

extração de máximos avisos

Tópico pai: Arquivos simples


Bancos de dados

  • preservar tipos numéricos durante a importação
  • representar integers grandes como strings
Tópico pai: Preferências do Portrait Miner


preservar tipos numéricos durante a importação

Seção Banco de Dados

Objetivo Determinar o tipo de dado [consulte Tipos de Dados] que o Portrait Miner usa para um campo ao importar valores numéricos com precisão superior a 15 dígitos de um banco de dados.

Valores válidos

Valor | Descrição
true (padrão) | Usa o tipo de dado real, preservando os 15 dígitos mais significativos e descartando os restantes.
false | Usa uma representação de string para preservar a precisão total do original (pelo menos até ao segundo dígito menos significativo).
Tópico pai: Bancos de dados


representar integers grandes como strings

Seção Banco de Dados

Objetivo Determinar o tipo de dado [consulte Tipos de Dados] que o Portrait Miner usa para representar um campo inteiro que contém números grandes demais para serem representados como inteiros de 32-bits (inteiros menores que -2 147483647 ou maiores que 2 147483646) quando são importados de um banco de dados ou arquivo simples.

Valores válidos

Valor | Descrição
true (padrão) | Usa o tipo de dado string.
false | Usa o tipo de dado real.
Tópico pai: Bancos de dados


Auditorias e Instantâneos

  • cor de fundo
  • textura de fundo
  • cor da barra
  • estilo da barra
  • barras de erros
  • escala da barra global
  • escala de ponto global
  • graph3deffect
  • sombra do gráfico
  • altura da imagem
  • escala de ponto de zoom
Tópico pai: Preferências do Portrait Miner


cor de fundo

Seção Auditorias e Instantâneos

Objetivo Controlar a cor de fundo para imagens no Perfil e Auditorias e em Modelos Instantâneos.

Valores válidos Uma string de texto, por padrão "white"

É possível especificar um nome de cor compatível com SVG http://www.w3.org (como "firebrick") ou um valor RGB hex (por exemplo, "#2244FF").

Consulte também

textura de fundo

cor da barra

estilo da barra

barras de erros

escala da barra global

escala de ponto global

graph3deffect

sombra do gráfico

altura da imagem

escala de ponto de zoom

Tópico pai: Auditorias e Instantâneos


textura de fundo

Seção Auditorias e Instantâneos

Objetivo Controlar o uso de textura de fundo para imagens no Perfil e Auditorias e em Modelos Instantâneos (somente formato SVG).

Valores válidos

Valor | Descrição
true | Usa uma textura de fundo.
false (padrão) | Não usa uma textura de fundo.

Consulte também

cor de fundo

cor da barra

estilo da barra

barras de erros

escala da barra global

escala de ponto global

graph3deffect

sombra do gráfico

altura da imagem

escala de ponto de zoom

Tópico pai: Auditorias e Instantâneos


cor da barra

Seção Auditorias e Instantâneos

Objetivo Controlar a cor das barras em gráficos de barras no Perfil e Auditorias e em Modelos Instantâneos.

Valores válidos Uma string de texto, por padrão "#9999FF" (lilás)

É possível especificar um nome de cor compatível com SVG http://www.w3.org (como "firebrick") ou um valor RGB hex (por exemplo, "#2244FF").

Consulte também

cor de fundo

textura de fundo

estilo da barra

barras de erros

escala da barra global

escala de ponto global

graph3deffect

sombra do gráfico

altura da imagem

escala de ponto de zoom

Tópico pai: Auditorias e Instantâneos


estilo da barra

Seção Auditorias e Instantâneos

Objetivo Controlar o estilo de barras em gráficos de barras e segmentos em árvores de decisão para o Perfil e Auditorias e Modelos Instantâneos.

Valores válidos

Valor | Descrição
plain (padrão) | Proporciona um aspecto simples e angular a barras e segmentos.
curved | Proporciona um aspecto curvado a barras e segmentos.
embossed | Proporciona um aspecto elevado e de alto relevo a barras e segmentos.

Consulte também

cor de fundo

textura de fundo

cor da barra

barras de erros

escala da barra global

escala de ponto global

graph3deffect

sombra do gráfico

altura da imagem

escala de ponto de zoom

Tópico pai: Auditorias e Instantâneos


barras de erros

Seção Auditorias e Instantâneos

Objetivo Controlar o uso de barras de erro em gráficos de barras em Perfil e Auditorias e em Modelos Instantâneos.

Valores válidos

Valor | Descrição
true (padrão) | Coloca barras de erro em pontos de dados.
false | Não coloca barras de erro em pontos de dados.

Consulte também

cor de fundo

textura de fundo

cor da barra

estilo da barra

escala da barra global

escala de ponto global

graph3deffect

sombra do gráfico

altura da imagem

escala de ponto de zoom

Tópico pai: Auditorias e Instantâneos


escala da barra global

Seção Auditorias e Instantâneos

Objetivo Controlar a escala relativa de eixos horizontais em gráficos de barras em Perfil e Auditorias e em Modelos Instantâneos.

Valores válidos

Valor | Descrição
true | Faz com que a escala de eixos horizontais seja a mesma para todos os gráficos em cada Perfil e Auditoria e Modelo Instantâneo.
false (padrão) | Não faz com que a escala de eixos horizontais seja a mesma para todos os gráficos em cada Perfil e Auditoria e Modelo Instantâneo.

Consulte também

cor de fundo

textura de fundo

cor da barra

estilo da barra

barras de erros

escala de ponto global

graph3deffect

sombra do gráfico

altura da imagem

escala de ponto de zoom

Tópico pai: Auditorias e Instantâneos


escala de ponto global

Seção Auditorias e Instantâneos

Objetivo Controlar a escala relativa de eixos verticais em gráficos de barras no Perfil e Auditorias e em Modelos Instantâneos.

Valores válidos

Valor | Descrição
true (padrão) | Faz com que a escala de eixos verticais seja a mesma para todos os gráficos em cada Perfil e Auditoria e Modelo Instantâneo.
false | Não faz com que a escala de eixos verticais seja a mesma para todos os gráficos em cada Perfil e Auditoria e Modelo Instantâneo.

Consulte também

cor de fundo

textura de fundo

cor da barra

estilo da barra

barras de erros

escala da barra global

graph3deffect

sombra do gráfico

altura da imagem

escala de ponto de zoom

Tópico pai: Auditorias e Instantâneos


graph3deffect

Seção Auditorias e Instantâneos

Objetivo Controlar o estilo das barras em gráficos de barras para o Perfil e Auditorias e Modelos Instantâneos.

Valores válidos

Valor | Descrição
true | Usa barras tridimensionais.
false (padrão) | Usa barras bidimensionais.

Consulte também

cor de fundo

textura de fundo

cor da barra

estilo da barra

barras de erros

escala da barra global

escala de ponto global

sombra do gráfico

altura da imagem

escala de ponto de zoom

Tópico pai: Auditorias e Instantâneos


sombra do gráfico

Seção Auditorias e Instantâneos

Objetivo Controlar o estilo de barras em gráficos de barras e segmentos em árvores de decisão no Perfil e Auditorias e em Modelos Instantâneos.

Valores válidos

Valor | Descrição
true | Cria um efeito de sombra.
false (padrão) | Não cria um efeito de sombra.

Consulte também

cor de fundo

textura de fundo

cor da barra

estilo da barra

barras de erros

escala da barra global

escala de ponto global

graph3deffect

altura da imagem

escala de ponto de zoom

Tópico pai: Auditorias e Instantâneos


altura da imagem

Seção Auditorias e Instantâneos

Objetivo Controlar a altura (em pixels) de imagens criadas para o Perfil e Auditorias e Modelos Instantâneos. A taxa de proporção das imagens é fixa.

Valores válidos Um valor inteiro positivo, por padrão 300

Consulte também

cor de fundo

textura de fundo

cor da barra

estilo da barra

barras de erros

escala da barra global

escala de ponto global

graph3deffect

sombra do gráfico

escala de ponto de zoom

Tópico pai: Auditorias e Instantâneos


escala de ponto de zoom

Seção Auditorias e Instantâneos

Objetivo Controlar o intervalo do eixo vertical para gráficos de barras no Perfil e Auditorias e em Modelos Instantâneos.

Valores válidos

Valor | Descrição
true | Configura o intervalo do eixo para o intervalo dos pontos de dados.
false (padrão) | Configura o intervalo do eixo para o intervalo dos pontos de dados aumentados com zero.

Consulte também

cor de fundo

textura de fundo

cor da barra

estilo da barra

barras de erros

escala da barra global

escala de ponto global

graph3deffect

sombra do gráfico

altura da imagem

Tópico pai: Auditorias e Instantâneos


Notificação de e-mail

  • email
  • servidor de email
Tópico pai: Preferências do Portrait Miner


email

Seção E-mail

Objetivo Configurar o endereço de e-mail por meio do qual as mensagens de notificação serão enviadas.

Valores válidos Uma string de texto não definida por padrão (por isso, não são enviados e-mails).

Deve ser um endereço de e-mail válido ou uma lista de endereços de e-mail válidos, separados por vírgula; por exemplo, me@mycompany.com.

Nota:

Para inserir uma vírgula literal em um endereço de e-mail, use o texto ${COMMA}.

Consulte também

servidor de email

Tópico pai: Notificação de e-mail


servidor de email

Seção E-mail

Objetivo Configurar o servidor de e-mail por meio do qual as mensagens de notificação serão enviadas.

Valores válidos Uma string de texto não definida por padrão (por isso, não são enviados e-mails).

Deve ser o endereço de um servidor SMTP, por exemplo smtp.mycompany.com.

Consulte também

email

Tópico pai: Notificação de e-mail


Ajuste e administração do sistema

  • bibliotecas de derivação
  • limite leve de memória de focus
  • paralelismo máximo
  • paralelismo
Tópico pai: Preferências do Portrait Miner


bibliotecas de derivação

Seção Funções

Objetivo Especificar localizações de bibliotecas de função FDL definidas pelo usuário ou de terceiros (com extensão de arquivo .fdl).

Valores válidos Uma lista separada por vírgulas do arquivo/diretório/localizações de arquivo (no servidor do Portrait Miner), não definida por padrão.

Quando o Decision Studio é inicializado, as bibliotecas de funções que estão explicitamente listadas assim como aquelas contidas em diretórios/pastas listados (e todos as subpastas) são abertas, fazendo com que as funções definidas nelas fiquem disponíveis para serem usadas no Visualizador de Dados.

Nota:

Para inserir uma vírgula literal em um nome de arquivo/diretório/pasta use o texto ${COMMA}.

Tópico pai: Ajuste e administração do sistema


limite leve de memória de focus

Não se recomenda modificar essa configuração

Esse limite é configurado dinamicamente pelo Portrait Miner; só deve ser alterado após consultar o Suporte do Portrait Miner.

Seção Sintonização do Sistema

Objetivo Configurar um limite "leve" para o uso da memória (em megabytes).

Valores válidos Um valor inteiro maior ou igual a 16; por padrão, um valor determinado no tempo de execução a partir da memória física total disponível e os limites da memória do sistema operacional do Portrait Miner. Se estiver executando a versão de 64 bits do Portrait Miner a quantidade máxima de memória disponível está limitada somente pela memória física da máquina. Se estiver executando a versão de 32 bits do Portrait Miner a quantidade máxima de memória disponível está restrita a 2 GB.

Nota:

O limite se aplica ao Decision Studio e a alguns comandos de compilação de dados (em conjunto com suas interfaces gráficas do usuário associadas). É um limite "leve" porque pode ser excedido, apesar do desempenho do sistema poder sofrer nesse caso.

Se o limite for excedido em 20% ou mais no Decision Studio, uma janela de pop-up avisa ao usuário que isso aconteceu.

Se o limite for excedido em 20% ou mais durante a execução de um comando de compilação de dados, é registrado um erro para stderr (e também para um arquivo de log, se estiver sendo usado um).

Se estiver usando o Portrait Miner Desktop, o limite é dinamicamente gerenciado e nunca deve ser necessário configurar.

Consulte também

paralelismo

Tópico pai: Ajuste e administração do sistema


paralelismo máximo

Seção Sintonização do Sistema

Objetivo Especificar o número máximo de processadores usados (em um servidor do Portrait Miner) em uma sessão de usuário do Decision Studio ou um comando de compilação de dados (e qualquer função do Portrait Miner que seja implementada por meio de um comando de compilação de dados).

Valores válidos Um valor inteiro positivo, por padrão, o número de processadores disponíveis

Consulte também

paralelismo

Tópico pai: Ajuste e administração do sistema


paralelismo

Seção Sintonização do Sistema

Objetivo Especificar o número padrão de processadores usados (no servidor do Portrait Miner) em uma sessão de usuário do Decision Studio ou por um comando de compilação de dados (e qualquer função do Portrait Miner que seja implementada por meio de um comando de compilação de dados). Em algumas circunstâncias, os usuários podem escolher aumentar (ou diminuir) esse número no tempo de execução.

Valores válidos Um valor inteiro positivo, por padrão 1. O valor não pode exceder a configuração da preferência paralelismo máximo.

Tópico pai: Ajuste e administração do sistema


Integração de sistemas e RealTime

  • arquivo de log de administrador
  • período de atualização do cache
  • permitir registro de administrador
  • permitir log de avaliação
  • antes...leia, depois...escreva
  • limite de aviso de regra expirado
  • exportar item de menu XML
  • localidade de gancho de execução externa
  • período de libertação do buffer de registro
  • uso da memória máxima do buffer de registro
  • tamanho do buffer de registro
  • salvar armazenar regra
  • localização do estado do servidor
Tópico pai: Preferências do Portrait Miner


arquivo de log de administrador

Essa configuração é somente para usuários experientes e, normalmente, só deve ser alterada pelo administrador do Portrait Miner.

Seção Actionhouse RT

Objetivo O nome do caminho para o arquivo de log de administração do RealTime, que é usado para registrar todos os eventos de administração do servidor. Somente é usado se permitir registro de administrador estiver ativado.

Valores válidos A localização de um diretório/pasta (no servidor do Portrait Miner), não definida por padrão

Tópico pai: Integração de sistemas e RealTime


período de atualização do cache

Essa configuração é somente para usuários experientes e, normalmente, só deve ser alterada pelo administrador do Portrait Miner.

Seção Actionhouse RT

Objetivo O tempo, em segundos, entre eventos de atualização de regra automática dos clientes do RealTime. Um cliente consulta o servidor periodicamente com esse tempo de atualização para permitir que as redefinições e exclusões de regras sejam repassadas.

Valores válidos Um valor inteiro, por padrão 3600

Tópico pai: Integração de sistemas e RealTime


permitir registro de administrador

Seção Actionhouse RT

Objetivo Ativar ou desativar o registro de administrador do RealTime.

Valores válidos

Valor | Descrição
true | Permite o registro de administrador
false (padrão) | Desativa o registro de administrador

Consulte também

arquivo de log de administrador
Tópico pai: Integração de sistemas e RealTime


permitir log de avaliação

Essa configuração é somente para usuários experientes e, normalmente, só deve ser alterada pelo administrador do Portrait Miner.

Seção Actionhouse RT

Objetivo Ativar ou desativar o log de avaliação de regra do RealTime.

Valores válidos

Valor | Descrição
true (padrão) | Ativa o log de avaliação
false | Desativa o log de avaliação

Consulte também

Tópico pai: Integração de sistemas e RealTime


antes...leia, depois...escreva

Seção Ganchos de Execução Externos

Objetivo Especificar um comando que o Portrait Miner sempre execute antes de ler ou de escrever em arquivos de um determinado tipo.

Valores válidos Uma string de texto, não definida por padrão

O Portrait Miner executa o comando especificado antes de ler ou depois de escrever em um arquivo de um determinado tipo. O nome completo do caminho do arquivo está anexado ao comando como um argumento.

Nota:
Um comando em um gancho de execução é executado em um ambiente herdado do Portrait Miner, exceto:
  • O caminho é expandido para incluir utilitários de linha de comando do Portrait Miner.
  • É possível substituir o diretório/pasta de trabalho herdada por meio do uso da preferência localidade de gancho de execução externa.

É sempre mais seguro especificar o caminho completo para o executável ou configurar a localidade de gancho de execução externa. Em particular, o Windows pesquisa o diretório atual em busca de executáveis antes de pesquisar o caminho, o que pode produzir resultados inesperados.

Tipos de arquivo com ganchos de execução

Nome em preferência | Tipo de arquivo | Ler | Gravar
binning | Arquivo Decision Studio binning (.bng) |  |
hierarquia categórica | Arquivo .hrc |  |
cluster | arquivo modelo de cluster |  |
configuração | Arquivo de preferência (qs.ini) |  |
crosstab | Não usar. |  |
dados | Não usar. |  |
banco de dados | Uma tabela de banco de dados (especificada como um parâmetro DRL para o comando; consulte Gerar script para qstml para informações sobre DRLs) |  |
Árvore de Decisão | Arquivo .qsdt ou .dt |  |
erivação | Arquivo da biblioteca de funções FDL(.fdl) |  |
descrição de Dados Simples | Arquivo .fdd |  |
dados simples | Arquivo de dados simples |  |
Arquivo Simple | Arquivo simples (especificado como um parâmetro de nome de arquivo de descrição de dados simples (FDD) para o comando, se estiver lendo um arquivo simples e solicitado a criação de um arquivo FDD; caso contrário, o parâmetro contém o nome do arquivo de dados simples). Uma operação de arquivo simples pode envolver vários arquivos individuais (um arquivo de descrição de dado simples e um ou mais arquivos de dados simples). A diferença entre esse gancho e os dois anteriores é que o comando é executado somente uma vez por operação (antes que o primeiro arquivo seja lido ou depois de o último arquivo ser escrito); os ganchos de nível inferior são executados uma vez por arquivo individual. |  |
focus | Arquivo .ftr (note que quando um focus é movido ou removido no Portrait Miner ou por meio do qsremove ou qsmove, o comando é executado para o focus antigo que já não existe e também para o novo focus depois de ser criado) |  |
HTML | Arquivo de tabela de referência cruzada em formato HTML |  |
log | Arquivo .log |  |
mapeamento | Arquivo de mapa do Decision Studio (.mid ou .mif) |  |
modelo | Arquivo modelo TML (.tml) criado pelo Decision Studio |  |
qmml | Arquivo modelo QMML (.qmml) criado pelo Decision Studio |  |
scorecard | Arquivo .qssc ou .sc |  |
texto | Não usar. |  |
Tópico pai: Integração de sistemas e RealTime


limite de aviso de regra expirado

Essa configuração é somente para usuários experientes e, normalmente, só deve ser alterada pelo administrador do Portrait Miner.

Seção Actionhouse RT

Objetivo Definir o número máximo de regras no servidor RealTime que podem ser marcadas como "expiradas", mas que não podem ainda ser liberadas pelos clientes. Se esse número for excedido, um aviso de recursos é gravado no log de eventos do sistema (e, se ativado, no arquivo de log de administração do RealTime). Isso normalmente é uma indicação de cliente configurado incorretamente ou travado.

Valores válidos Um valor inteiro, por padrão 10

Consulte também

arquivo de log de administrador
Tópico pai: Integração de sistemas e RealTime


exportar item de menu XML

Seção Actionhouse RT

Objetivo Configurar o texto exibido na opção de menu do Visualizador de Dados para salvar modelos QMML.

Valores válidos Uma string de texto, por padrão "Exportar como QMML..."

Tópico pai: Integração de sistemas e RealTime


localidade de gancho de execução externa

Essa configuração é somente para usuários experientes e, normalmente, só deve ser alterada pelo administrador do Portrait Miner.

Seção Diretórios

Objetivo Especificar o diretório/pasta de trabalho para comandos que o Portrait Miner execute por meio de ganchos de execução [consulte antes...leia, depois...escreva].

Valores válidos A localização de um diretório/pasta (no servidor do Portrait Miner), não definida por padrão

Se a localização não estiver definida, os comandos do gancho de execução herdam seu diretório/pasta de trabalho do Decision Studio.

Tópico pai: Integração de sistemas e RealTime


período de libertação do buffer de registro

Essa configuração é somente para usuários experientes e, normalmente, só deve ser alterada pelo administrador do Portrait Miner.

Seção Actionhouse RT

Objetivo Consulte Integração e administração do RealTime.

Valores válidos Um valor inteiro, por padrão 5

Tópico pai: Integração de sistemas e RealTime


uso da memória máxima do buffer de registro

Essa configuração é somente para usuários experientes e, normalmente, só deve ser alterada pelo administrador do Portrait Miner.

Seção Actionhouse RT

Objetivo Consulte Integração e administração do RealTime.

Valores válidos Um valor inteiro, por padrão 1024

Tópico pai: Integração de sistemas e RealTime


tamanho do buffer de registro

Essa configuração é somente para usuários experientes e, normalmente, só deve ser alterada pelo administrador do Portrait Miner.

Seção Actionhouse RT

Objetivo Consulte Integração e administração do RealTime.

Valores válidos Um valor inteiro, por padrão 10

Tópico pai: Integração de sistemas e RealTime


salvar armazenar regra

Essa configuração é somente para usuários experientes e, normalmente, só deve ser alterada pelo administrador do Portrait Miner.

Seção Diretórios

Objetivo Configurar a localização padrão para salvar modelos QMML (e ativar esse recurso no Decision Studio).

Valores válidos A localização de um diretório/pasta (no servidor do Portrait Miner), não definida por padrão (para que a opção de menu definida pela preferência exportar item de menu XML não apareça no Decision Studio)

Tópico pai: Integração de sistemas e RealTime


localização do estado do servidor

Essa configuração é somente para usuários experientes e, normalmente, só deve ser alterada pelo administrador do Portrait Miner.

Seção Actionhouse RT

Objetivo O diretório onde o servidor do RealTime armazena seu estado ativo. Quando o servidor inicia, carrega o estado a partir desse diretório. À medida que o servidor executa ele mantém aqui uma cópia no disco de seu estado atual.

Valores válidos A localização de um diretório/pasta (no servidor do Portrait Server), por padrão shared/actionhouseRT (no UNIX) ou shared\actionhouseR (no Windows) no diretório de instalação do Portrait Miner

Tópico pai: Integração de sistemas e RealTime


Funções de agregação

  • any
  • confintlower
  • confintupper
  • count
  • countnonnull/countnonnulls
  • countnull/countnulls
  • countunique
  • countuniquenonnull
  • expectedcount
  • expectedproportion
  • first
  • last
  • max (um argumento)
  • mean (um argumento)
  • median
  • min (um argumento)
  • mode
  • moderatio
  • percentage
  • percentagerate
  • proportion
  • segindex
  • significance
  • stdev
  • sum (um argumento)
  • variance


any

Objetivo Escolher um valor não nulo e arbitrário de um campo (possivelmente por grupo ou segmento).

Sintaxe any(x)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | x | O campo de onde escolher um valor

Resultado

Tipo | Descrição
como entrada | Um valor não nulo e arbitrário do campo x (possivelmente por grupo ou segmento)
Nota:

Não é possível usar essa função em uma derivação do Decision Studio, no arquivo de derivações para o qsderive ou na janela Campos Derivados equivalente, no arquivo de rastreios para o qstrack ou em um arquivo de seleções para o qsselect.

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

first

last

Tópico pai: Funções de agregação


confintlower

Objetivo Calcular o limite mínimo de um intervalo de confiança de 95% para a média de um campo.

Sintaxe confintlower(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | O campo a ser considerado

Resultado

Tipo | Descrição
real | O limite inferior de um intervalo dentro do qual, para a média de população do segmento para o campo x, espera-se uma queda com 95% de confiança
Nota:

Não é possível usar essa função em uma derivação do Decision Studio, no arquivo de derivações para o qsderive ou na janela Campos Derivados equivalente, no arquivo de rastreios para o qstrack ou em um arquivo de seleções para o qsselect.

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

confintupper

significance

Tópico pai: Funções de agregação


confintupper

Objetivo Calcular o limite máximo de um intervalo de confiança de 95% para a média de um campo.

Sintaxe confintupper(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | O campo a ser considerado

Resultado

Tipo | Descrição
real | O limite superior de um intervalo dentro do qual, para a média de população do segmento para o campo x, espera-se uma queda com 95% de confiança
Nota:

Não é possível usar essa função em uma derivação do Decision Studio, no arquivo de derivações para o qsderive ou na janela Campos Derivados equivalente, no arquivo de rastreios para o qstrack ou em um arquivo de seleções para o qsselect.

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

confintlower

significance

Tópico pai: Funções de agregação


count

Objetivo Contar o número de registros (possivelmente por grupo ou segmento).

Sintaxe count()

Argumentos Nenhum

Resultado

Tipo | Descrição
inteiro | O número de registros (possivelmente por grupo ou segmento).

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

countnonnull/countnonnulls

countnull/countnulls

countunique

countuniquenonnull

Tópico pai: Funções de agregação


countnonnull/countnonnulls

Objetivo Contar o número de registros no qual um campo tem valores não nulos (possivelmente por grupo ou segmento).

Sintaxe countnonnull(x)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | x | O campo a ser considerado

Resultado

Tipo | Descrição
inteiro | O número de registros no qual o campo x tem valores não nulos (possivelmente por grupo ou segmento)
Nota:

Na tabela de referência cruzada do Decision Studio [consulte Funções de agregação para tabelas de referência cruzada] e em uma medida de contexto [consulte Funções de agregação para medições e derivações] essa função é countnonnull, em um contexto de derivação é countnonnulls.

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

count

countnull/countnulls

countunique

countuniquenonnull

Tópico pai: Funções de agregação


countnull/countnulls

Objetivo Contar o número de registros no qual um campo contém o valor nulo (possivelmente por grupo ou segmento).

Sintaxe countnull(x)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | x | O campo a ser considerado

Resultado

Tipo | Descrição
inteiro | O número de registros no qual o campo x é nulo (possivelmente por grupo ou segmento)
Nota:

Na tabela de referência cruzada do Decision Studio [consulte Funções de agregação para tabelas de referência cruzada] e em uma medida de contexto [consulte Funções de agregação para medições e derivações] essa função é countnull, enquanto que em um contexto de derivação é countnulls.

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

count

countnonnull/countnonnulls

countunique

countuniquenonnull

Tópico pai: Funções de agregação


countunique

Objetivo Contar o número de valores únicos que ocorrem em um campo incluindo, potencialmente, o valor nulo (possivelmente por grupo ou segmento).

Sintaxe countunique(x)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | x | O campo a ser considerado

Resultado

Tipo | Descrição
inteiro | O número de valores únicos, incluindo nulo, que ocorre em x (possivelmente por grupo ou segmento)
Nota:

Não é possível usar essa função em uma derivação do Decision Studio, no arquivo de derivações para o qsderive ou na janela Campos Derivados equivalente, no arquivo de rastreios para o qstrack ou em um arquivo de seleções para o qsselect.

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

count

countnonnull/countnonnulls

countnull/countnulls

countuniquenonnull

Tópico pai: Funções de agregação


countuniquenonnull

Objetivo Contar o número de valores únicos não nulos ocorrendo em um campo (possivelmente por grupo ou segmento).

Sintaxe countuniquenonnull(x)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | x | O campo a ser considerado

Resultado

Tipo | Descrição
inteiro | O número de valores únicos, excluindo o nulo, que ocorre em x (possivelmente por grupo ou segmento)
Nota:

Não é possível usar essa função em uma derivação do Decision Studio, no arquivo de derivações para o qsderive ou na janela Campos Derivados equivalente, no arquivo de rastreios para o qstrack ou em um arquivo de seleções para o qsselect.

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

count

countnonnull/countnonnulls

countnull/countnulls

countunique

Tópico pai: Funções de agregação


expectedcount

Objetivo Calcular a população "esperada" de um segmento de uma tabela de referência cruzada.

Sintaxe expectedcount()

Argumentos Nenhum

Resultado

Tipo | Descrição
real | A contagem de registros que seria esperada para um segmento se os campos da tabela de referência cruzada fossem independentes uns dos outros
Nota:

Só é possível usar essa função em tabelas de referência cruzada do Decision Studio [consulte Funções de agregação para tabelas de referência cruzada] para visualizar dados.

Consulte também

Funções de agregação para tabelas de referência cruzada

expectedproportion

Tópico pai: Funções de agregação


expectedproportion

Objetivo Calcular a população "esperada" de um segmento da tabela de referência cruzada, como uma proporção da população total.

Sintaxe expectedproportion()

Argumentos Nenhum

Resultado

Tipo | Descrição
real | A proporção da população que seria esperada em um segmento se os campos da tabela de referência cruzada fossem independentes uns dos outros
Nota:

Só é possível usar essa função em tabelas de referência cruzada do Decision Studio [consulte Funções de agregação para tabelas de referência cruzada] para visualizar dados.

Consulte também

Funções de agregação para tabelas de referência cruzada

expectedcount

Tópico pai: Funções de agregação


first

Objetivo Escolher o primeiro valor não nulo de um campo (possivelmente por grupo ou segmento).

Sintaxe first(x)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | x | O campo de onde escolher um valor

Resultado

Tipo | Descrição
como entrada | O primeiro valor não nulo encontrado no campo x (possivelmente por grupo ou segmento)
Nota:

Não é possível usar essa função em uma derivação do Decision Studio, no arquivo de derivações para o qsderive ou na janela Campos Derivados equivalente, no arquivo de rastreios para o qstrack ou em um arquivo de seleções para o qsselect.

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

any

last

Tópico pai: Funções de agregação


last

Objetivo Escolher o último valor não nulo de um campo (possivelmente por grupo ou segmento).

Sintaxe last(x)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | x | O campo de onde escolher um valor

Resultado

Tipo | Descrição
como entrada | O último valor não nulo encontrado no campo x (possivelmente por grupo ou segmento)
Nota:

Não é possível usar essa função em uma derivação do Decision Studio, no arquivo de derivações para o qsderive ou na janela Campos Derivados equivalente, no arquivo de rastreios para o qstrack ou em um arquivo de seleções para o qsselect.

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

any

first

Tópico pai: Funções de agregação


max (um argumento)

Objetivo Calcular o valor não nulo máximo em um campo (possivelmente por grupo ou segmento).

Sintaxe max(x)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | x | O campo cujos valores serão comparados

Resultado

Tipo | Descrição
como entrada | O valor não nulo máximo no campo x (possivelmente por grupo ou segmento)
Nota:
  • Atenção para não confundir essa função aggregation com a função multi-argument [consulte max (dois ou mais argumentos), maxnonnull] de mesmo nome.
  • em um contexto de derivação, essa função não aceita um campo de string ou de valor de data como argumento.

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

min (um argumento)

Tópico pai: Funções de agregação


mean (um argumento)

Objetivo Calcular a média (média geral) de valores não nulos em um campo (possivelmente por grupo ou segmento).

Sintaxe mean(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | O campo cuja média vai ser calculada

Resultado

Tipo | Descrição
real | A média dos valores não nulos no campo x (possivelmente por grupo ou segmento)
Nota:

Atenção para não confundir essa função aggregation com a função multi-argument [consulte mean (dois ou mais argumentos), meannonnull] de mesmo nome.

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

median

mode

Tópico pai: Funções de agregação


median

Objetivo Calcular a mediana (valor médio) dos valores não nulos em um campo (possivelmente por grupo ou segmento).

Sintaxe median(x)

Argumentos

Tipo | Nome | Descrição
inteiro, real ou string | x | O campo cuja mediana será calculada

Resultado

Tipo | Descrição
como entrada | O valor da mediana dos valores não nulos no campo x (possivelmente por grupo ou segmento)
Nota:

Não é possível usar essa função em uma derivação do Decision Studio, no arquivo de derivações para o qsderive ou na janela Campos Derivados equivalente, no arquivo de rastreios para o qstrack ou em um arquivo de seleções para o qsselect.

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

mean (um argumento)

mode

Tópico pai: Funções de agregação


min (um argumento)

Objetivo Calcular o valor mínimo não nulo em um campo (possivelmente por grupo ou segmento).

Sintaxe min(x)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | x | O campo cujos valores serão comparados

Resultado

Tipo | Descrição
como entrada | O valor não nulo mínimo no campo x (possivelmente por grupo ou segmento)
Nota:
  • Atenção para não confundir essa função aggregation com a função multi-argument [consulte min (dois ou mais argumentos), minnonnull] de mesmo nome.
  • em um contexto de derivação, essa função não aceita um campo de string ou de valor de data como argumento.

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

max (um argumento)

Tópico pai: Funções de agregação


mode

Objetivo Calcular o modo (valor mais comum) dos valores não nulos em um campo (possivelmente por grupo ou segmento).

Sintaxe mode(x)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | x | O campo cujo modo será calculado

Resultado

Tipo | Descrição
como entrada | O modo dos valores não nulos no campo x (possivelmente por grupo ou segmento)
Nota:
  • No caso de um empate pelo valor mais comum, a função retorna o número menos repetido, a data de empate mais antiga ou a string mais recente alfabeticamente.
  • Não é possível usar essa função em uma derivação do Decision Studio, no arquivo de derivações para o qsderive ou na janela Campos Derivados equivalente, no arquivo de rastreios para o qstrack ou em um arquivo de seleções para o qsselect.

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

mean (um argumento)

median

moderatio

Tópico pai: Funções de agregação


moderatio

Objetivo Calcular a proporção de registros não nulos contendo o valor não nulo mais comum em um campo (possivelmente por grupo ou segmento).

Sintaxe moderatio(x)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | x | O campo cuja razão do modo será calculada

Resultado

Tipo | Descrição
real | A razão do modo do campo x (possivelmente por grupo ou segmento)
Nota:

Não é possível usar essa função em uma derivação do Decision Studio, no arquivo de derivações para o qsderive ou na janela Campos Derivados equivalente, no arquivo de rastreios para o qstrack ou em um arquivo de seleções para o qsselect.

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

mode

Tópico pai: Funções de agregação


percentage

Sintaxe percentage()

Objetivo Calcular o número de registros em um segmento da tabela de referência cruzada, como porcentagem do total.

Argumentos Nenhum

Resultado

Tipo | Descrição
real | A porcentagem de registros (possivelmente por grupo ou segmento).
Nota:

Só é possível usar essa função em uma derivação do Decision Studio, no arquivo de derivações para qsderive ou na janela Campos Derivados equivalente, no arquivo de rastreamento para o qstrack ou em um arquivo de seleções para o qsselect.

Consulte também

Funções de agregação para medições e derivações

Tópico pai: Funções de agregação


percentagerate

Objetivo Calcular, para um campo binário (1/0), a proporção de registros não nulos contendo o valor 1, como uma porcentagem.

Sintaxe percentagerate(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | O campo binário a ser considerado

Resultado

Tipo | Descrição
real | A porcentagem de registros em um campo binário com o valor 1 (possivelmente por grupo ou segmento)
Nota:

Não é possível usar essa função em um arquivo de agregações [consulte Usando funções de agregação e as cláusulas where e default] ou arquivo de estatísticas [consulte Avaliação das estatísticas do focus: a instrução calculate] para o qsmeasure ou na janela Dados Agregados equivalente ou em um arquivo estatístico para o qstrack.

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

Tópico pai: Funções de agregação


proportion

Objetivo Calcular o número de registros por cliente ou segmento, como uma proporção do número total de registros.

Sintaxe proportion()

Argumentos Nenhum

Resultado

Tipo | Descrição
real | O número de registros por cliente ou em um segmento da tabela de referência cruzada, relativamente ao número total de registros
Nota:

Só é possível usar essa função em tabelas de referência cruzada do Decision Studio [consulte Funções de agregação para tabelas de referência cruzada] para visualizar dados.

Consulte também

Funções de agregação para tabelas de referência cruzada
Tópico pai: Funções de agregação


segindex

Objetivo Gerar um número de índice representando um segmento.

Sintaxe segindex()

Argumentos Nenhum

Resultado

Tipo | Descrição
inteiro | Um número positivo identificando, de forma única, um segmento dentro da tabela de referência cruzada
Nota:
  • Havendo segmentos nulos, não classificados ou ocultos em uma visualização da tabela de referência cruzada, eles ainda recebem um índice de segmento, por isso, pode parecer haver intervalos na sequência dos índices visíveis.
  • Não é possível usar essa função em um arquivo de agregações [consulte Usando funções de agregação e as cláusulas where e default] ou arquivo de estatísticas [consulte Avaliação das estatísticas do focus: a instrução calculate] para o qsmeasure ou na janela Dados Agregados equivalente ou em um arquivo estatístico para o qstrack.

Exemplo R–2: Marcação de decis aproximados

É possível guardar um campo "myfield" em 10 bins iguais de população e depois derivar um campo "decil":

segindex() by myfield

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

compartimento

Tópico pai: Funções de agregação


significance

Objetivo Calcular a significância estatística de qualquer discrepância entre o valor médio de um campo para um segmento na tabela de referência cruzada e o valor médio do mesmo campo para toda a população.

Sintaxe significance(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | O campo a ser considerado

Resultado

Tipo | Descrição
real | Um valor entre -1 e 1, cujo sinal indica a direção na qual o segmento médio de x se desvia da média da população de x e cujo valor absoluto indica a significância desse desvio, tendo em conta o tamanho do segmento
Nota:

Não é possível usar essa função em um arquivo de agregações [consulte Usando funções de agregação e as cláusulas where e default] ou arquivo de estatísticas [consulte Avaliação das estatísticas do focus: a instrução calculate] para o qsmeasure ou na janela Dados Agregados equivalente ou em um arquivo estatístico para o qstrack.

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

confintlower

confintupper

Tópico pai: Funções de agregação


stdev

Objetivo Calcular o desvio padrão dos valores não nulos em um campo (possivelmente por grupo ou segmento).

Sintaxe stdev(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | O campo cujo desvio padrão será computado

Resultado

Tipo | Descrição
real | O desvio padrão dos valores não nulos no campo x (possivelmente por grupo ou segmento)

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

Tópico pai: Funções de agregação


sum (um argumento)

Objetivo Calcular a soma dos valores não nulos em um campo (possivelmente por grupo ou segmento).

Sintaxe sum(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | O campo cujos valores serão somados

Resultado

Tipo | Descrição
como entrada | A soma dos valores não nulos no campo x (possivelmente por grupo ou segmento)
Nota:
  • Atenção para não confundir essa função aggregation com a função multi-argument [consulte sum (dois ou mais argumentos), sumnonnull] de mesmo nome.
  • Note que quando a função de agregação sum é aplicada a um conjunto de registros vazios (por exemplo, como resultado do filtro de registro), o resultado é nulo. Normalmente, esse comportamento é evitado configurando o valor padrão para 0.

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

Tópico pai: Funções de agregação


variance

Objetivo Calcular a variação estatística dos valores não nulos em um campo (possivelmente por grupo ou segmento).

Sintaxe variance(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | O campo cuja variação será computada

Resultado

Tipo | Descrição
real | A variação dos valores não nulos no campo x (possivelmente por grupo ou segmento)

Consulte também

Funções de agregação para tabelas de referência cruzada

Funções de agregação para medições e derivações

Tópico pai: Funções de agregação


Referência de Linguagem de Medição de Transação (TML)

  • Sobre Transaction Measurement Language
  • Sintaxe TML
  • Definição de campo: a instrução create
  • Usando funções de agregação e as cláusulas where e default
  • Dividir agregações: a cláusula by
  • Avaliação das estatísticas do focus: a instrução calculate
  • Funções de agregação para medições e derivações
  • Palavras reservadas em TML


Sobre Transaction Measurement Language

A Transaction Measurement Language (TML) é um conjunto de invólucros sintáticos leves em torno das expressões FDL, usados para especificar derivações e agregações de campo em conjunto com os assistentes Campos Derivados [consulte Derivar campos em um focus usando o Portrait Miner] e Dados Agregados [consulte Para converter um focus orientado para a transação em um focus orientado para cliente] e com os comandos de compilação de dados qsderive, qsmeasure, qstrack e qsselect do Portrait Miner.

Consulte também

Sobre Linguagem de Campo Derivado

Sintaxe TML

Usar os comandos de compilação de dados do Portrait Miner para importar, processar e exportar dados

Tópico pai: Referência de Linguagem de Medição de Transação (TML)


Sintaxe TML

Um arquivo de derivações, rastreios, seleções ou agregações contém uma ou mais instruções TML create, enquanto um arquivo de estatísticas contém uma ou mais instruções TML calculate.
  • A TML é uma linguagem sensível a maiúsculas e minúsculas:
    • Palavras-chave da TML (create, by, string etc.) são escritas em minúsculas, exceto em STATISTIC.
    • Os nomes de todas as funções de agregação [consulte Funções de agregação para medições e derivações] estão escritos em letra minúscula.
    • Os nomes Média, média e MÉDIA referem-se todos a campos ou estatísticas diferentes.
  • Nomes para campos e estatísticas devem começar com uma letra ("A" — "Z" ou "a" — "z"), conter apenas letras, dígitos e sublinhado ("_") e não podem ter mais que 128 caracteres; opcionalmente, pode ficar entre aspas simples, por exemplo, 'Customer ID'. É necessário colocar o nome de um campo ou estatística entre aspas simples se ele coincidir com uma palavra reservada à TML ou FDL, ou diferir somente quanto ao uso de maiúsculas ou minúsculas.
  • A sintaxe TML é descrita através de diagramas de ferrovia como esse:

    Desde que siga as setas e não volte para trás, qualquer caminho no diagrama de ferrovia leva a uma TML sintaticamente válida (mesmo que não faça sentido):
    • Palavras em caixas ovais/circulares (tal como create) são palavras-chave TML; devem ser escritas exatamente como aparecem.
    • A pontuação nas caixas ovais também deve ser escrita (como ":" e ":=") exatamente como aparecem (não pode haver espaço entre ":" e "=" em ":=").
    • Não esqueça o ponto e vírgula que termina cada instrução TML.
    • Termos em caixas retangulares (como expressões) referem-se a outros diagramas de ferrovia ou formas descritas em outros locais em palavras; não devem ser escritas literalmente.
  • A TML é uma linguagem formatada livremente: é possível quebrar linhas ou inserir espaço extra entre elementos sintáticos (em caixas ovais/circulares nos diagramas de ferrovia) sem afetar a interpretação de um arquivo de derivações, rastreios, seleções, agregações ou estatísticas.
  • Além de introduzir espaços entre elementos sintáticos, é possível incluir comentários, começando com barras duplas ("//") e continuando até o final da linha.
  • Sempre que a sintaxe TML exigir uma expressão, é possível usar qualquer expressão FDL [consulte Expressões], exceto expressões que usem uma palavra reservada TML, ponto e vírgula ou chaves {...}, que devem ficar entre parênteses (...).

Consulte também

Sobre Transaction Measurement Language

Avaliação das estatísticas do focus: a instrução calculate

Definição de campo: a instrução create

Palavras reservadas em FDL

Palavras reservadas em TML

Tópico pai: Referência de Linguagem de Medição de Transação (TML)


Definição de campo: a instrução create

A instrução create define um campo por derivação ou agregação, dependendo do contexto em que aparece.

Derivações O arquivo de derivações para qsderive ou a janela Campos Derivados equivalente, o arquivo de rastreios para qstrack e o arquivo de seleções para qsselect devem conter instruções create, da seguinte forma:

É possível que opcionalmente o arquivo de agregações para qsmeasure ou a janela Dados Agregados equivalente contenham instruções create, da seguinte forma:

Em ambos os casos, a instrução create define um campo chamado nome, em termos de uma expressão FDL [consulte Expressões]. O tipo de dado do campo é o tipo de dado da expressão, a não ser que seja substituído especificando um tipo compatível [consulte Tipos de Dados].
  • Para cada instrução create sucessiva, o qsderive ou a janela Campos Derivados equivalente derivam um campo no focus de saída usando a expressão fornecida, sendo possível se referir a campos no focus de origem e a campos derivados anteriormente no arquivo de derivações.
  • Para cada instrução create sucessiva no arquivo de rastreios, o qstrack deriva um campo usando a expressão fornecida, sendo possível se referir a campos no focus de origem e a campos derivados anteriormente no arquivo de rastreios, assim como também a estatísticas de focus definidas em quaisquer arquivos de estatísticas. A expressão envolve, normalmente, variáveis de estado [consulte Variáveis].
  • Dado um arquivo de seleções, o qsselect deriva um campo correspondente, por padrão, à primeira instrução create e ignora quaisquer outras instruções no arquivo. É necessário que a expressão de definição seja de tipo booleano (ou compatível).
  • Para cada instrução create sucessiva dessa forma no arquivo de agregações, o qsmeasure ou a janela Dados Agregados deriva um campo no focus de saída usando a expressão fornecida, sendo possível se referir a campos derivados anteriormente no arquivo de agregações e a estatísticas de focus definidas em quaisquer arquivos de estatística.
  • Uma instrução temporary tem o mesmo efeito de uma instrução create, exceto que o campo não aparece no focus de saída. No entanto, ainda é possível consultar o campo temporário nas expressões subsequentes no arquivo de agregações.

Agregações É possível que o arquivo de agregações para o qsmeasure ou a janela Dados Agregados equivalente contenham instruções create da seguinte forma:

Para cada instrução create desse formulário no arquivo de agregações, o qsmeasure ou a janela Dados Agregados deriva eficazmente um campo virtual correspondente à expressão seguindo a função de agregação. É possível a essa expressão se referir a campos no focus de origem.

Após derivar o campo virtual, o qsmeasure ou a janela Dados Agregados aplica a função de agregação [consulte Usando funções de agregação e as cláusulas where e default].

O tipo de dado padrão do(s) campo(s) resultante(s) depende da função de agregação e dos valores, operadores e funções envolvidas na expressão a que se aplicam, mas é possível ser substituído especificando um tipo compatível.

Uma instrução temporary tem o mesmo efeito de uma instrução create, exceto que o campo não aparece no focus de saída. No entanto, ainda é possível consultar o campo temporário nas expressões subsequentes no arquivo de agregações.

Nota:
  • No qsderive ou nos arquivos de derivações Campos Derivados, nos arquivos de seleção qsselect e arquivos de rastreios qstrack, é possível que a expressão envolva estatísticas de campo, variáveis globais e funções definidas nesses termos. Esses recursos FDL não estão disponíveis em um qsmeasure ou arquivo de agregações Dados Agregados.
  • É necessário colocar parênteses extras contendo a expressão, se ela contiver ponto e vírgula, chaves ou uma palavra reservada da TML [consulte Palavras reservadas em TML].
  • É necessário que cada instrução create comece em uma nova linha.

Exemplos Dado o arquivo de derivações, derivations-customer.tml, contendo o seguinte:

// Length of standing of customer in months
create CustMonths := countwholemonths(StartDate, today());
// A key field of extended length
create CustomerID_24 : string(24) := CustomerID;
Aplicar essas derivações ao focus RetailCustApril.ftr para criar um novo focus RetailCustAprilDeriv.ftr: qsderive -derivations derivations-customer.tml\cmdlinecont -input RetailCustApril.ftr -output RetailCustAprilDeriv.ftr Dado o arquivo de seleções, selections-customer.tml, contendo o seguinte:
// Select male customers aged between 18 and 65 inclusive.
create Selection := Gender = 1 and Age >= 18 and Age <= 65;
Aplicar essa seleção ao focus RetailCustApril.ftr para criar um novo focus RetailCustAprilSelection.ftr:
qsselect -selections selections-customer.tml
         -input RetailCustApril.ftr%
         -output RetailCustAprilSelection.ftr
Dado o arquivo de agregações, aggregations-mostRecent.tml, contendo o seguinte:
temporary LastPurchase := max(PurchaseDate);
create AvgTransVal := mean(Amount - 0.01 * PointsRedeemed);
create NumTrans := count();
create MonthsSinceLastPurchase :=
       countwholemonths(LastPurchase, today());

Aplicar essas agregações ao focus RetailTransApril.ftr para criar um focus orientado para cliente RetailAggRecentApril:

qsmeasure -aggregations aggregations-mostRecent.tml
          -input RetailTransAprilSorted.ftr -output RetailAggRecentApril%
          -keys CustomerID

Consulte também

Funções de agregação para medições e derivações

Dividir agregações: a cláusula by

Para converter um focus orientado para a transação em um focus orientado para cliente

Tópico pai: Referência de Linguagem de Medição de Transação (TML)


Usando funções de agregação e as cláusulas where e default

É possível agregar dados usando o qsmeasure ou a janela Dados Agregados equivalente.

Ao usar uma instrução create em um arquivo de agregações [consulte Definição de campo: a instrução create], o qsmeasure ou a janela Dados Agregados deriva eficazmente um campo virtual correspondente à expressão entre parênteses seguidas da função agregação.

Conceitualmente, o qsmeasure ou a janela Agregar Registros dividem os registros no focus de origem — aumentados pelo campo virtual — em grupos de registros com o mesmo valor do campo-chave. Para cada grupo de registros (correspondendo a apenas um valor do campo-chave), o qsmeasure ou a janela Dados Agregados aplicam a função de agregações aos valores do campo virtual dentro desses registros, para produzir apenas um valor de resultado.

Os valores do resultado para todos os grupos juntos constituem um novo campo, com o mesmo nome fornecido na instrução create — a não ser que a instrução create contenha uma cláusula by [consulte Dividir agregações: a cláusula by].

Dentro de cada grupo de registros com um valor de campo-chave comum, certas funções de agregação ignoram os registros para o qual o campo virtual contém um nulo [consulte O valor nulo].

Se a instrução create tiver uma cláusula where, a função de agregação ignora os registros para os quais a expressão associada avalia para 0 ("falso"). É possível a essa expressão se referir a campos no focus de origem.

Como é possível que as funções de agregação ignorem alguns dos registros em um grupo com um valor de campo-chave comum, é possível saltar todos os registros no grupo. Muitas funções de agregação devolvem o valor nulo. Ao incluir uma cláusula default, é possível especificar uma expressão constante a ser avaliada em vez de a agregação no caso de ser devolvido um nulo.

Nota:

Ao usar a função de agregação sum [consulte sum (um argumento)], deve ser especificada uma soma padrão de 0. Se não for usada uma cláusula default, a soma de uma seleção de registro vazio é nula, o que, certamente, não é desejado.

Exemplos Dado o arquivo de agregações, aggregations-purchaseSummary.tml, contendo o seguinte:

create firstPurchaseDate := first(PurchaseDate);
create commonPaymentMethod := mode(PaymentMethod);
create Spend := sum(Amount) default 0;
create SpendInStore800 := sum(Amount)
       where Store = "0800" default 0;
create proportionSpendInStore800 := SpendInStore800 / Spend;
create NumTransCRRedeemed := count()
       where PaymentMethod = "CR" and not isnull(PointsRedeemed);

Aplicar essas agregações ao focus RetailTransApril.ftr para criar um focus orientado para cliente RetailAggSummaryApril:

qsmeasure -aggregations aggregations-purchaseSummary.tml
          -input RetailTransAprilSorted.ftr -output RetailAggSummaryApril
          -keys CustomerID

Consulte também

Funções de agregação para medições e derivações

Expressões

Tópico pai: Referência de Linguagem de Medição de Transação (TML)


Dividir agregações: a cláusula by

O arquivo de agregações para qsmeasure ou a janela Agregar Registros equivalente contêm uma sequência de instruções create [consulte Definição de campo: a instrução create]. Como parte dessa instrução create, é possível incluir opcionalmente uma cláusula by, para dividir sua agregação de acordo com a aplicação de uma função split ou a função bin a uma expressão derivada de outros campos.
Por cada i integer possivelmente retornado pela função split ou a função bin, o qsmeasure ou a janela Dados Agregados criam um campo separado, contendo somente valores agregados dos registros para o qual a aplicação de função avalia para i. O nome de cada um desses campos relacionados é formado a partir do nome na instrução create juntamente com um sufixo que depende da função usada para dividir a agregação.
  • As seguintes funções internas de divisão estão disponíveis (com sufixos de nome de campo fornecidos correspondendo a valores de função sucessivos):
    Função | Sufixos de nome de campo
    day | "_1," "_2," "_3," ..., "_31"
    dayofweek | "Sun," "Mon," "Tue," ..., "Sat"
    hour | "0000," "0100," "0200" ..., "2300"
    isnull | "NonNull," "Null"
    match | "MisMatch," "Match"
    membro | "NotMember," "Member"
    minute | "0," "1," "2," ..., "59"
    month | "Jan," "Feb," "Mar," ..., "Dec"
    second | "0," "1," "2," ..., "59"
    sgn | "Negative," "Zero," "Positive"
    strmember | "NotMember," "Member"
    weekofyear | "_1," "_2," "_3," ..., "_53"
  • É possível usar a função bin para aplicar um binning FDL a uma expressão. Usada como uma função de divisão, a função bin dá origem a sufixos de nome de campo "_1," "_2," ..., "_n," "_null," e "_other" (onde n depende do número de bins no binning).
  • Também é possível configurar sua função de divisão [consulte Funções definidas pelo usuário]. O atributo element_names define os sufixos dos nomes de campo correspondentes aos valores de retorno das funções.

Exemplos Fornecido o arquivo de agregações, aggregations-builtinSplit.tml, contendo o seguinte:

create numberPurchases := count();
create numberPurchasesOn_ := count() by dayofweek(PurchaseDate);
create proportionPurchases_Mon :=
       numberPurchasesOn_Mon / numberPurchases;
create purchaseAmountIn_ :=
       sum(Amount) by month(PurchaseDate) default 0;

Aplicar essas agregações ao focus RetailTransApril.ftr para criar um focus orientado para cliente RetailDateSplitsApril.ftr contendo os campos CustomerID, numberPurchases, numberPurchasesOn_Sun, numberPurchasesOn_Mon, ..., numberPurchasesOn_Sat, proportionPurchases_Mon e purchaseAmountIn_Jan, purchaseAmountIn_Feb, ..., purchaseAmountIn_Dec:

qsmeasure -aggregations aggregations-builtinSplit.tml -keys CustomerID -input RetailTransApril.ftr -output RetailDateSplitsApril.ftr

Fornecido o arquivo de agregações, aggregations-binSplit.tml, contendo o seguinte:

create numberPurchasesAmountBand :=
       count() by bin(EqualRange(20,100,4),Amount);
create numberPurchasesDateBand := count() by
       bin(PrePost(todate(19990401), todate(19990501),
       todate(19990601)), PurchaseDate);
create ratioPrePost :=
       numberPurchasesDateBand_3 / numberPurchasesDateBand_2;

Aplicar essas agregações ao focus RetailTransApril.ftr para criar um focus orientado para cliente, RetailRangeSplitsApril.ftr, contendo os campos CustomerID, numberPurchasesAmountBand_1, numberPurchasesAmountBand_2, ..., numberPurchasesAmountBand_6, numberPurchasesAmountBand_null, numberPurchasesAmountBand_other (correspondendo a dois últimos bins, quatro bins internos e o bin nulo e não classificado), numberPurchasesDateBand_1, numberPurchasesDateBand_2, ..., numberPurchasesDateBand_4, numberPurchasesDateBand_null, numberPurchasesDateBand_other, e ratioPrePost:

qsmeasure -aggregations aggregations-binSplit.tml -keys CustomerID -input RetailTransApril.ftr -output RetailRangeSplitsApril.ftr

Fornecido o arquivo de funções FDL, fdl-functions-storeGroups.fdl, contendo o seguinte:

function StoreGroupFunction( Store )
[
   element_names = "North, South, East, West"
]
{
case
    Store = "0000" or Store = "0800" : 1;
    Store = "0300" or Store = "0600" or Store = "0700" : 2;
    Store = "0100" or Store = "0400" : 3;
    default : 4;
}

Fornecido o arquivo de agregações, aggregations-userDefinedSplit.tml, contendo o seguinte:

create totalPurchases := sum(Amount);
create totalPurchasesByStore_ :=
       sum(Amount) by StoreGroupFunction( Store );
create proportionPurchases_North :=
       totalPurchasesByStore_North / totalPurchases;

Aplicar essas agregações ao focus RetailTransApril.ftr para criar um focus orientado para cliente, RetailGroupSplitsApril.ftr, contendo os campos CustomerID, totalPurchases, totalPurchasesByStore_North, totalPurchasesByStore_South, totalPurchasesByStore_East, totalPurchasesByStore_West, e proportionPurchases_North:

qsmeasure -aggregations aggregations-userDefinedSplit.tml
    -library fdl-functions-storeGroups.fdl
    -keys CustomerID
    -input RetailTransApril.ftr -output RetailGroupSplitsApril.ftr

Consulte também

Funções de agregação para medições e derivações

Expressões

Usando funções de agregação e as cláusulas where e default

Tópico pai: Referência de Linguagem de Medição de Transação (TML)


Avaliação das estatísticas do focus: a instrução calculate

O arquivo de estatísticas para o qsmeasure, a janela Dados Agregados equivalente ou o qstrack contêm instruções calculate da seguinte forma:

A instrução calculate define uma estatística de focus chamada nome em termos de uma função de agregação aplicada a uma expressão FDL [consulte Expressões], que pode se referir a campos no focus de origem.

No caso de uma medição [consulte Usando funções de agregação e as cláusulas where e default], o qsmeasure, o qstrack ou a janela Dados Agregados deriva efetivamente um campo virtual correspondendo à expressão entre parênteses após a função de agregação.

A instrução calculate dá origem a apenas um valor de resultado, obtido por meio da aplicação da função de agregação a todos os valores no campo virtual. (Em contraste, uma instrução create em um arquivo de agregações dá origem a um campo no qual cada valor é obtido pela aplicação da função de agregação aos valores no campo virtual para um grupo de registros.)

O tipo de dado padrão de uma estatística de focus depende da função de agregação e dos valores, operadores e funções envolvidas na expressão a que se aplicam, mas é possível substituí-lo especificando-se um tipo compatível [consulte Tipos de Dados].

Se a instrução calculate tiver uma cláusula where, a função de agregação ignora os registros para os quais a expressão associada avalia para 0 ("falso"). É possível a essa expressão se referir a campos no focus de origem.

Assim que for definida uma estatística de focus no arquivo de estatísticas, é possível se referir a ele em expressões no arquivo de agregações ou rastreios usando a forma especial de nome STATISTIC . É possível usar essa forma em qualquer lugar que seja possível indicar um campo no focus de origem ou arquivo de rastreios.

Exemplos Dado o arquivo de estatísticas, statistics-amount.tml, contendo o seguinte:

calculate averageAmount := mean(Amount);

Dado o arquivo de agregações, aggregations-statistic.tml, contendo o seguinte:

create averageSpend := mean(Amount);

create bigSpender := averageSpend > STATISTIC.averageAmount;

Aplicar essas agregações ao focus RetailTransApril.ftr para criar um focus RetailAprilBigSpenders.ftr orientado para cliente contendo os campos CustomerID, averageSpend e bigSpender:

qsmeasure -statistics statistics-amount.tml

-aggregations aggregations-statistic.tml

-keys CustomerID

-input RetailTransApril.ftr -output RetailAprilBigSpenders.ftr

Consulte também

Funções de agregação para medições e derivações

Tópico pai: Referência de Linguagem de Medição de Transação (TML)


Funções de agregação para medições e derivações

Existem várias funções de agregação disponíveis para uso em medições e derivações.

Usar uma função em uma medida de contexto significa usá-la em \funccontextmeasure.

Usar uma função em um contexto de derivação significa usá-la em \funccontextderive.

Exceto quando indicado, uma função de agregação assume apenas um campo numeric, string ou date como argumento.

Funções de agregação para medições e para derivações É possível usar as seguintes funções de agregação, tanto nos contextos de medição como de derivação:

Função | Resultado
count | O número de registros no grupo/segmento (Essa função não usa argumento.)
max [consulte max (um argumento)] | O valor não nulo máximo no campo para o grupo/segmento (Em um contexto de derivação, essa função não aceita uma expressão de valor string como argumento.)
mean [consulte mean (um argumento)] | A média (média comum) dos valores não nulos no campo para o grupo/segmento (Essa função requer uma expressão numérica como argumento.)
min [consulte min (um argumento)] | O valor não nulo mínimo no campo para o grupo/segmento (Em um contexto de derivação, essa função não aceita uma expressão de valor string como argumento.)
stdev | O desvio padrão dos valores não nulos no campo para o grupo/segmento (Essa função requer uma expressão numérica como argumento.)
sum [consulte sum (um argumento)] | A soma dos valores não nulos no campo para o grupo/segmento (Essa função requer uma expressão numérica como argumento.)
variação | A variância dos valores não nulos no campo para o grupo/segmento (Essa função requer uma expressão numérica como argumento.)

Funções de agregação somente para medições Só é possível usar as seguintes funções de agregação em uma medida de contexto:

Função | Resultado
any | Um valor não nulo no campo, obtido de um registro não nulo arbitrário no grupo/segmento
confintlower | O limite inferior de um intervalo de confiança de 95% para a média do campo no grupo
confintupper | O limite superior de um intervalo de confiança de 95% para a média do campo no grupo
countnonnull [consulte countnonnull/countnonnulls] | O número de registros no grupo para o qual o campo não tem valores não nulos [consulte O valor nulo] Em derivações, use o countnonnulls.
countnull [consulte countnull/countnulls] | O número de registros do grupo para o qual o campo contém nulo [consulte O valor nulo] Em derivações, prefira o countnulls.
countunique | O número de valores únicos que ocorrem no campo, possivelmente incluindo o valor nulo
countuniquenonnull | O número de valores únicos, excluindo o valor nulo, que ocorrem no campo
first | O primeiro valor não nulo no campo para o grupo
last | O último valor não nulo no campo para o grupo
median | A mediana (valor do meio) dos valores não nulos no campo para o grupo (Essa função requer uma expressão numérica ou de valor string como argumento.)
modo | O modo (valor mais comum) dos valores não nulos no campo para o grupo
moderatio | A proporção dos registros não nulos no grupo que contêm o valor não nulo mais comum no campo

Funções de agregação somente para derivações Só é possível usar as seguintes funções de agregação em um contexto de derivação:

Função | Resultado
countnonnulls [consulte countnonnull/countnonnulls] | O número de registros no segmento para o qual o campo não tem valores não nulos [consulte O valor nulo] Em medições, use o countnonnull.
countnulls [consulte countnull/countnulls] | O número de registros no segmento para o qual o campo contém valores nulos [consulte O valor nulo] Em medições, use o countnull.
percentage | O número de registros em um segmento, como porcentagem do número total de registros (Essa função não usa argumento.)
percentagerate | A porcentagem de registros não nulos no segmento que contém o valor 1 no campo É necessário que o campo contenha somente os valores 0 e 1.
segindex | Um número positivo identificando exclusivamente o segmento dentro da tabela de referência cruzada formada pelos campos de divisão (Essa função não usa argumento.)
significance | A significância estatística de qualquer discrepância entre o valor médio do campo no segmento e o valor médio do campo para a população geral, com um sinal para indicar a direção do desvio (Essa função requer uma expressão numérica como argumento.)
Tópico pai: Referência de Linguagem de Medição de Transação (TML)


Palavras reservadas em TML

Os seguintes tokens são palavras reservadas em TML:

aggregation, all, and, as, auto, automatic, bin, binning, bool, boolean, by, calculate, constant, create, crosstab, date, default, description, dimension, double, drl, enum, except, fields, file, float, format, from, full, function, group, include, inplace, input, int, integer, join, left, long, merge, meta, modifiable, normal, on, open, outer, outfile, output, parameter, pragma, real, ref, reference, rename, right, separate_functions, short, show, show_empty_segments, show_summaries, sort, state, statistic, strbytes, string, suppress, table, temp, temporary, track, tracker, view, where

Para usar uma palavra reservada ou uma palavra que difere somente no uso de maiúsculas e minúsculas, como nome de campo ou estatística em TML ou como um identificador [consulte Expressões] em FDL, é necessário colocá-lo entre aspas simples — por exemplo, 'Date'.

Consulte também

Sobre Transaction Measurement Language

Palavras reservadas em FDL

Tópico pai: Referência de Linguagem de Medição de Transação (TML)


Referência de Linguagem de Campo Derivado (FDL)

  • Sobre Linguagem de Campo Derivado
  • Tipos de Dados
  • Expressões
  • Expressões Condicionais
  • Variáveis
  • Funções definidas pelo usuário
  • Funções internas
  • Palavras reservadas em FDL
  • Operadores FDL
  • Funções FDL
  • Binnings
  • Expressões regulares FDL


Sobre Linguagem de Campo Derivado

A Linguagem de Campo Derivado (FDL) é uma linguagem simples, para especificar a criação de novos campos nos focus do Portrait Miner. É possível usar a FDL no Visualizador de Dados [consulte Derivar um campo por meio do Visualizador de Dados] no Decision Studio, os assistentes Campos Derivados [consulte Derivar campos em um focus usando o Portrait Miner] e Dados Agregados [consulte Para converter um focus orientado para a transação em um focus orientado para cliente] e os comandos de compilação de dados Portrait Miner %. Não mencionaremos aqui seu uso com -records. qsderive, qsmeasure, qstrack e qsselect.
É possível usar a FDL para:
  • Transformar, combinar e realizar diversas outras computações em campos existentes em um focus
  • Dividir um focus em um conjunto de amostras aleatórias.
  • Definir segmentos e modelos preditivos
  • Selecionar registros de acordo com um critério de sua escolha

Usa-se normalmente em expressões simples, "de uma linha", como as descritas em Expressões básicas, mas também é possível usar para construir scripts com caminhos de execução complexos e dependentes de dados.

A sintaxe FDL inclui:
  • Operadores para aritmética [consulte Operadores aritméticos].
  • Operadores para comparação [consulte Operadores relacionais] e para combinar expressões lógicas [consulte Operadores lógicos].
  • Duas construções alternativas para uma avaliação condicional de instruções: if...then...else e case [consulte Expressões Condicionais].
  • Um conjunto abrangente de funções internas [consulte Funções internas].
  • A capacidade de encapsular transformações comuns como funções definidas pelos usuários [consulte Funções definidas pelo usuário], para reutilização e compartilhamento.
  • Variáveis, para manter valores para a reutilização em um script FDL, incluindo (em alguns contextos) variáveis "acumuladoras" globais [consulte Variáveis globais no Decision Studio].
  • Uma recurso para incorporar tabelas de referência cruzada em derivações .

Consulte também

Sobre Transaction Measurement Language

Expressões

Tópico pai: Referência de Linguagem de Campo Derivado (FDL)


Tipos de Dados

O FDL é compatível com os seguintes tipos de dados básicos [consulte Sobre Linguagem de Campo Derivado]:

Tipo | Descrição | Exemplos (como literais de FDL)
inteiro | Um número sem parte fracional (entre -2 147 483 647 e 2 147 483 646) | 78004, -100
real | Um número com parte fracionária, representado internamente como número de "ponto flutuante", com precisão de 15 dígitos (entre [image] e [image] ou 0) | 42,3, -0,56
data | Uma data/hora entre 1507 d.C e 3015 d.C, com uma precisão de um segundo | #2009/01/01, #2009/01/01:16:01:39
string | Uma string de caractere, representando dados textuais | "hello"
número pequeno | Um número pequeno sem parte fracional (entre qsminsmallint e qsmaxsmallint) | 42, -1
Nota:
  • Se for usado um valor inteiro literal (tal como 12345678910) que é grande demais para um tipo de dado integer, haverá uma sobrecarga. Muitas vezes é possível resolver esse ponto se for usado um valor real: (nesse caso, 12345678910,0).
  • O tipo smallinteger tem uma aplicabilidade limitada dentro do Portrait Miner e só deve ser usado se absolutamente necessário. Em geral, prefira um tipo integer.
Tópico pai: Referência de Linguagem de Campo Derivado (FDL)

O valor nulo

Além dos valores comuns para cada um dos tipos de dados básicos, é possível um campo ou expressão do tipo inteiro, real, data ou string assumir o valor especial null. O valor nulo representa sempre um valor desconhecido (devido à falta de dados, a uma sobrecarga em um cálculo — como uma divisão por zero — ou por outro motivo). É distinto tanto do zero como da string vazia "".

As funções FDL e os operadores preservam a incerteza introduzida por um argumento ou operando nulo, muitas vezes dando o valor nulo como resultado. Existem, no entanto, funções — em especial isnull e algumas funções de agregação — que lidam especialmente com o valor nulo.

Exemplos

?

1 + null é igual a null.

1 != null é igual a null.

1 < null é igual a null.

null = null é igual a null.

null != null é igual a null.

false ou null é igual a null.

true e null é igual a null.

true ou null é igual a true.

false e null é igual a false.

Consulte também

ifnull, nvl

Dados booleanos

Não existe um tipo de dado booleano (true/false) formal em FDL. No entanto, é possível tratar um campo inteiro (ou variável) contendo somente os valores 0 e 1 ou uma expressão lógica, como Income< 10000, como se fosse do tipo booleano.

As expressões lógicas são avaliadas como 1 quando são verdadeiras e 0 quando são falsas. Expressões condicionais usam esses valores para determinar qual de duas ou mais expressões vão avaliar. Operadores lógicos também trabalham com esses valores. Um valor 0 em um campo inteiro ou variável é interpretado como "false" e qualquer outro valor (não nulo) é interpretado como "true".

Além disso, é possível usar as palavras-chave true e false como literais booleanos (que significam 1 e 0, respectivamente).

Compatibilidade de tipo

Os tipos de dados integers e reais são indicados como compatíveis por tipo, é possível usar um valor integer sempre que for necessário um valor real (mas não vice-versa), por exemplo, como um argumento para uma função. Os tipos de dados date e string só são compatíveis por tipo entre eles.

Os operandos de um operador aritmético binário [consulte Operadores aritméticos] ou operador relacional [consulte Operadores relacionais] têm de ser compatíveis por tipo. Na verdade, no caso de um operador aritmético binário, é necessário que ambos os operandos sejam numéricos; o resulto é real a não ser que ambos os operadores seja integers.

Da mesma forma, as expressões de resultados em uma expressão if ou case [consulte Expressões Condicionais] têm de ser compatíveis por tipo para ser possível determinar o tipo do resultado antes da avaliação. Se as expressões de valores integers e real estão misturadas, o resultado é de valor real.

Conversão de tipo

Além de usarem uma conversão implícita de tipo de dado (que ocorre quando é forçado por um tipo de dado de uma expressão), é possível converter explicitamente os tipos de dados com as funções FDL tointeger, toreal, todate e tostring.

Nota: Ao converter de uma string para um numeric, quaisquer caracteres não numéricos à direita são ignorados.


Expressões

Uma expressão FDL pode ser uma das seguintes:
  • Uma expressão básica [consulte Expressões básicas]
  • Uma expressão condicional [consulte Expressões Condicionais]
  • Uma inicialização ou atribuição de variáveis [consulte Variáveis]
  • Uma lista de expressões separadas por ponto e vírgula (uma lista de expressões), fechadas entre parênteses

Cada expressão tem um tipo de dado associado [consulte Tipos de Dados] e podem ser avaliadas.

Para avaliar uma lista de expressões em um determinado contexto, avalie cada expressão constituinte por vez, da primeira à última; o valor da lista de expressões como um todo é o último valor computado.

Nota:
  • O tipo de dado é deduzido automaticamente. Não é possível especificar sem ser com uma variável local do tipo necessário ou usando uma expressão que force o tipo. Por exemplo, a seguinte expressão força o tipo a ser real:

    if false then 0,0 else...

  • Por padrão, você usará listas de expressões em combinação com atribuições de variáveis.
Tópico pai: Referência de Linguagem de Campo Derivado (FDL)

Expressões básicas

Uma expressão básica pode ser uma das seguintes:
  • Um identificador, opcionalmente contido entre aspas simples, por exemplo, 'Customer ID'. É necessário fechar um identificador entre aspas simples se não começar por uma letra ("A" — "Z" ou "a" — "z"), contiver caracteres que não sejam letras, dígitos e sublinhados ou coincidir com uma palavra reservada TML ou FDL (ou diferir apenas por ser maiúscula ou minúscula). Um identificador não deve ter mais de 128 caracteres.
  • Um literal numérico, por exemplo, 30, -3.28 ou 3.1e8 (o último representando [image])
  • Um literal de string, contido entre aspas duplas, por exemplo, "Uma string"
  • Um literal de data, com prefixo "#," por exemplo, #2004/03/16 ou #2004/03/16:09:12:13
  • A palavra-chave "null" (consulte O valor nulo)
  • Uma aplicação de função, formada por um nome de função (um identificador) seguido por uma lista de argumentos separados por vírgulas (expressões) em parênteses; por exemplo, mean(IncomeA + IncomeB, TotalEstIncome)
  • Uma expressão aritmética, formada por uma expressão de valor numérico conectados por operadores aritméticos [consulte Operadores aritméticos], por exemplo, 365 / 52
  • Uma relação, formada por expressões de valor numérico ou string conectados por operadores relacionais [consulte Operadores relacionais], por exemplo, Age > 30 ou 'State' = "Nova Iorque"
  • Uma expressão lógica, formada por expressões relacionais ou outras de valor booleano vinculadas por operadores lógicos [consulte Operadores lógicos], por exemplo, (Income > 250000) e (MaritalStatus = "Solteiro")
  • Um identificador estatístico, formado por uma palavra-chave da TML STATISTIC seguido por um ponto seguido por um identificador, por exemplo, STATISTIC.AverageIncome (somente em um arquivo de agregações TML)
  • Uma estatística de campo — somente em uma derivação do Decision Studio, um arquivo qsderive de derivação ou um arquivo qsselect de seleções
Nota:
  • Os identificadores FDL são sensíveis a maiúsculas e minúsculas. Por exemplo, as expressões Customer ID e CUSTOMERID se referem a campos diferentes, enquanto as expressões isnull(Age) e IsNull(Age) envolvem funções diferentes.
  • Um literal numérico é avaliado com um integer se não contiver pontos decimais e não usar notação científica. Caso contrário, é avaliado com um número real.
  • É possível a um literal de string conter qualquer caractere que não aspas duplas (") e caracteres newline.
  • Uma literal de data é avaliada inicialmente no formato YMD [consulte Formatos de data]; se falhar, é avaliada de acordo com a configuração de suas preferências para ler [consulte ler].
  • Além de inserir espaços entre os elementos sintáticos, é possível incluir comentários, começando com uma barra dupla ("//") e continua até o final da linha. Por exemplo,
    // This is a comment.
2 + 2 // This is a comment.

Consulte também

Palavras reservadas em FDL

Palavras reservadas em TML


Expressões Condicionais

Em FDL, existem duas formas principais de avaliar condicionalmente uma expressão: a expressão if e a expressão case.

Consulte também

Sobre Linguagem de Campo Derivado

Expressões

Tópico pai: Referência de Linguagem de Campo Derivado (FDL)

A expressão if

Se a condição (uma expressão FDL retornando um valor booleano [consulte Dados booleanos]) for verdadeira, a expressão após then é avaliada; caso contrário, a expressão após else é avaliada. O valor da expressão if é o valor da expressão avaliada.

Nota:
  • É necessário que as expressões após then e else sejam compatíveis por tipo [consulte Tipos de Dados].
  • Se for omitida a parte "else" de uma expressão e a condição for falsa, o valor da expressão if é nulo [consulte O valor nulo].
  • Uma condição nula [consulte O valor nulo] é tratada pela expressão if como se fosse falsa. Essa é uma exceção à regra geral, pois a incerteza introduzida pelo valor nulo é preservada pelas expressões FDL. É possível que isso leve a resultados inesperados: por exemplo, quando Age é nula, as seguintes expressões (a princípio equivalentes) geram o valor nulo, 0 E 1, respectivamente:

    Age > 40

    if Age > 40 then 1 else 0

    if Age <= 40 then 0 else 1

  • É possível testar várias condições usando expressões if aninhadas — expressões if onde a expressão após then ou else é também uma expressão if. Se a expressão após then é uma expressão if, ela deve ser contida entre parênteses para evitar ambiguidade. Se preferir, é possível usar a expressão case [consulte A expressão case].
  • Se for possível expressar sua condição como x = 0 (ou [image]) para algum número x, também é possível usar a função FDL interna cond em vez de uma expressão if.

Exemplos

if Age < 40 then "Jovem"

if Age < 40 then "Jovem" else "Sênior"

if Age > 40 then "Jovem" else if Age < 60 then "Meia-Idade" else "Sênior"

if (Age >= 13 and Age < 20) then "Adolescente"

if isnull(Age) then mean(Age) else Age

if Responder then RespondDate else StartDate

if match(Postcode, "^EH") then "Y" else "N"

if StartDate < #1998/09/08 then "Loyal" else "Recente"

A expressão case

Se a primeira condição (uma expressão FDL retornando um valor booleano [consulte Dados booleanos]) for verdadeira, a expressão correspondente (à direita dos dois pontos) é avaliada e retornada como o valor da expressão case. Caso contrário, a condição seguinte é testada; sendo verdadeira, a expressão correspondente é avaliada e retornada como o valor de uma expressão case. Caso contrário, a condição seguinte é testada, e assim por diante.

A palavra-chave especial default é interpretada com uma expressão sempre verdadeira: normalmente seria usada como a última condição em uma expressão case (quaisquer condições subsequentes seriam ignoradas).

Nota:
  • É necessário que todas as expressões que ocorrem à direita dos dois pontos sejam compatíveis por tipo [consulte Tipos de Dados].
  • Se nenhuma das condições for verdadeira (e não existir uma palavra-chave default), o valor da expressão case é nulo [consulte O valor nulo].
  • Uma condição nula [consulte O valor nulo] é tratada pela expressão case como se fosse falsa. Essa é uma exceção à regra geral, pois a incerteza introduzida pelo valor nulo é preservada pelas expressões FDL. Por exemplo, quando Age é nulo, a expressão seguinte gera o valor 3:

    ocorrência

    Age > 40 : 1;

    Age <= 40 : 2;

    default : 3;

  • Se for usada uma expressão case em uma lista de expressões ou aninhar uma expressão case como uma condição (dentro de uma expressão if ou outra expressão case), ela deve ser contida entre parênteses para evitar ambiguidade.

Exemplos

ocorrência

Age < 40: "Jovem";

default: "NãoJovem";

ocorrência

Response = "Exc": 7;

Response = "M. Sat": 6

Response = "Sat": 5;

Response = "F. Sat": 4;

Response = "Fraco": 3;

Response = "Mau": 2;

default: 1;


Variáveis

Uma variável em FDL é uma localização temporária de armazenamento para valores real, integer, string ou date. É possível usar uma variável local para avaliar uma subexpressão% complicada — particularmente útil se a mesma subexpressão ocorrer mais de uma vez% — ou para avaliar uma expressão envolvendo uma função de número aleatório, para evitar a alteração de valor de uma avaliação para outra. Também é possível usar variáveis globais no Decision Studio [consulte Variáveis globais no Decision Studio] e variáveis de estado em arquivos de rastreio TML [consulte Variáveis de estado em Transaction Measurement Language (TML)] para levar informação de um registro para outro.

Para atribuir um valor a uma variável, use a seguinte sintaxe:

A primeira atribuição é uma inicialização e determina a classe da variável% — local (sem palavra-chave), global ou de estado. As palavras-chave global ou state são usadas somente em conjunto com a primeira atribuição para uma variável global ou de estado (a inicialização).

O identificador [consulte Expressões básicas] é o nome da variável (não deve coincidir com um nome de campo no focus).

Para qualquer classe de variável, seu tipo de dado [consulte Tipos de Dados] corresponde ao primeiro valor que lhe for atribuído.

O valor de uma expressão de atribuição é simplesmente o valor da expressão à direita do sinal ":=".

Por exemplo, a seguinte lista de expressões atribui aleatoriamente o valor 1 (para 20% dos registros), 2 (para outros 20% dos registros) ou 0 (para os demais registros):

x := rndUniform();

ocorrência

x < 0,2 : 1;

x < 0,4 : 2;

default : 0;

Podia ser escrita de forma equivalente nessa forma mais compacta:

ocorrência

( x := rndUniform() ) < 0,2 : 1;

x < 0,4 : 2;

default : 0;

No entanto, a seguinte lista de expressões gera um resultado diferente (e provavelmente indesejado):

ocorrência

rndUniform() < 0,2 : 1;

rndUniform() < 0,4 : 2;

default : 0;

Tópico pai: Referência de Linguagem de Campo Derivado (FDL)

Variáveis globais no Decision Studio

As variáveis são locais por padrão. Uma variável local é destruída assim que a última expressão (a mais externa) na lista de expressões [consulte Expressões] é avaliada — A próxima vez que a mesma variável for usada, será reinicializada. Uma variável local não pode levar informações de um registro para outro. Por exemplo, a seguinte lista de expressões de derivação do campo produz um campo com 1 em todos os registros:

i := 0;

i := i + 1

Uma variável global difere de uma variável local pois não é destruída até que o Decision Studio ou o comando de compilação de dados calcule os valores do campo de todos os registros. A inicialização só acontece uma vez, para o primeiro registro no focus. Por exemplo, a seguinte lista de expressões de derivação de campo produz um campo de índice, com 1 no primeiro registro, 2 no segundo e assim por diante:

global i := 0;

i := i + 1

É possível usar uma variável global na lista de expressões de derivação de campo em uma derivação do Decision Studio, no arquivo de derivações para qsderive ou a janela Campos Derivados equivalente, em um arquivo de rastreios para o qstrack,ou em um arquivo de seleções para o qsselect.

Variáveis de estado em Transaction Measurement Language (TML)

É possível usar uma variável de estado em uma definição de campo TML no arquivo de rastreios qstrack.

Uma variável de estado difere de uma variável local ou uma variável global pois não é destruída até que o qstrack tenha calculado todos os valores de campo para o grupo atual (como definido pelo campo-chave). A inicialização ocorre uma vez por cada grupo.

Por exemplo, a seguinte definição de campo define um campo de balanço atualizado, assumindo que o campo "Deposit" contém uma quantia depositada em uma transação (ou um valor negativo para um levantamento) e o campo"InitialBalance" contém o balanço inicial para o cliente (talvez de uma tabela de cliente adicionada anteriormente):

create Balance := (

state bal := InitialBalance;

bal := bal + Deposit

)


Funções definidas pelo usuário

Para definir uma função FDL que possa ser usada da mesma forma que uma função interna [consulte Funções internas], use a seguinte sintaxe:

O identificador [consulte Expressões básicas] após a palavra-chave "function" é o nome da função. A lista de argumentos (formais) vem a seguir:

Cada argumento formal (que não é precedido por uma palavra-chave de "field" atua como uma variável local [consulte Variáveis] inicializada com o valor do argumento correspondente quando a função é aplicada. O tipo [consulte Tipos de Dados] de um argumento formal é o tipo especificado na definição de função, se presente; caso contrário, é a do argumento usado quando a função é aplicada. Note que são necessários os parênteses mesmo sem argumentos formais.

Seguindo a lista de argumentos vem uma lista opcional de atributos de função [consulte Function attributes] e depois o corpo de definição da função. A lista de expressão [consulte Expressões] é efetivamente prefixada com atribuições variáveis locais, correspondendo a argumentos formais (que não os precedidos por uma palavra-chave "field") antes de serem avaliados para dar o valor de retorno para a função. O tipo de valor de retorno corresponde ao da última expressão.

Exemplos Definir uma função para substituir os zeros no resultado de uma expressão (de qualquer tipo) com o resultado de outra expressão:

function replaceZeros(expr1, expr2)

{

if expr1 = 0 then expr2 else expr1

}

Uma função que pega um argumento de string e o devolve com a primeira letra maiúscula:

function titleCase(string text)

{

concat(toupper(left(text, 1)), right(text, strlen(text) - 1));

}

Nota:
  • Ao especificar o tipo de um argumento de função, use "real", "integer", "string" ou "date."
  • É possível incluir estatísticas de campo em uma definição de função, mas cada argumento de função usado em uma estatística de campo deve ser precedido por uma palavra-chave "field". Por exemplo, para comparar um valor com um resumo sobre todo o focus:

    function MyBand(real field x)

    {

    averageX := mean(x);

    stdevX := stdev(x);

    ocorrência

    x < averageX - stdevX : "Lower";

    x > averageX + stdevX : "Upper";

    default: "Mid";

    }

  • É possível incluir definições de função no início da lista de expressões que definem um campo derivado. Funções definidas dessa forma são locais para a derivação de campo.

    Também é possível definir funções acessíveis globalmente, armazenando-as em um arquivo (ou arquivos) em uma pasta listada na preferência de bibliotecas de derivação [consulte bibliotecas de derivação]. No Decision Studio, no painel Família de Função da caixa de diálogo Funções de Derivação no Visualizador de Dados, as funções em um arquivo chamado classe.fdl aparece na classe chamada classe. Por exemplo, funções em um arquivo com o nome Conditional.fdl aparecem na classe Conditional. É possível reutilizar um nome de classe existente para expandir uma classe com suas próprias funções definidas pelo usuário ou criar sua classe usando um novo nome.

    Ao usar o comando de compilação de dados do Portrait Miner, o qsmeasure, a janela Dados Agregados equivalente ou o comando de compilação de dados qstrack, é possível especificar um arquivo que contenha definições de funções globais adicionais.

  • Não é possível definir funções de agregação em uma medida de contexto, isto é, \funccontextmeasure.
  • Se a lista de expressão terminar com um caractere alfabético, ele deve ser separado da chave por ponto e vírgula ou espaços em branco.
Tópico pai: Referência de Linguagem de Campo Derivado (FDL)

Function attributes

Especifica atributos da função da seguinte forma:

Atributos úteis são:

synopse e description. Esses atributos fornecem uma forma padrão de tornar a função "autodocumentável." Se uma função é instalada em uma pasta listada nas preferências de bibliotecas de derivação [consulte bibliotecas de derivação], a sinopse é exibida quando a função for selecionada no painel Funções da caixa de diálogo Funções de Derivação do Visualizador de Dados. Ao clicar no botão Detalhes, a descrição é exibida. O texto da sinopse deve ser curto, mas o texto de descrição pode ser maior.

Por exemplo:

function nvl(testNull, replaceValue)

[

synopsis = "Substituir valores nulos"

description = "A função nvl() substitui valores nulos...strings."

]

(Note que o atributo de descrição deve estar todo na mesma linha.)

element_names. Em um arquivo de agregações, é possível usar uma função com o atributo element_names para dividir uma agregação para criar vários campos [consulte Dividir agregações: a cláusula by].

O valor desse atributo é uma string que contém uma lista de nomes separados por vírgulas que, por sua vez, estão associados aos valores de retorno 1, 2, ..., da função, na ordem pela qual estão listados.

Por exemplo, o atributo element_names da função abaixo associa os nomes "Baixo", "Médio" e "Elevado" aos valores de retorno 1, 2 e 3, respectivamente:

function band(x)

[ element_names = "Baixo,Médio,Alto" ]

{

clamp(floor(x / 1000), 0, 2) + 1

}

O atributo element_names da função abaixo associa os nomes "Norte", "Sul", "Leste" e "Oeste" aos valores de retorno 1, 2, 3 e 4, respectivamente:

function StoreGroupFunction( Store )

[

element_names = "Norte, Sul, Leste, Oeste"

]

{

ocorrência

Store = "0000" or Store = "0800" : 1;

Store = "0300" or Store = "0600" or Store = "0700" : 2;

Store = "0100" or Store = "0400" : 3;

default : 4;

}


Funções internas

O FDL inclui um conjunto abrangente de funções internas.

Funções condicionais

Função | Descrição
clamp | Restringir um número a um intervalo específico.
cond | Produzir um de dois resultados dependendo se uma expressão é zero ou diferente de zero.
iff | Produzir um de dois resultados dependendo se uma expressão é zero ou diferente de zero.
ifnull, nvl | Substituir o valor nulo.
isnull | Testar se um valor é nulo.
isselected | Marcar os registros selecionados atualmente.
replace | Substituir um número se não estiver dentro do intervalo fornecido.

Funções de conversão de tipos de dados

Função | Objetivo
todate | Converte um valor para uma data.
tointeger | Converte um valor para um número integer.
toreal | Converte um valor para um número real.
tostring | Converte um valor para uma string.

Funções para trabalhar com datas

Função | Objetivo
addcenturies, addcenturiescountbackwards | Calcular uma data a partir de outra data, usando um deslocamento em séculos.
adddays | Calcular uma data a partir de outra data, usando um deslocamento em dias.
addhours | Calcular uma data a partir de outra data, usando um deslocamento em horas.
addminutes | Calcular uma data a partir de outra data, usando um deslocamento em minutos.
addmonths, addmonthscountbackwards | Calcular uma data a partir de outra data, usando um deslocamento em meses.
addseconds | Calcular uma data a partir de outra data, usando um deslocamento em segundos.
addweeks | Calcular uma data a partir de outra data, usando um deslocamento em semanas.
addyears, addyearscountbackwards | Calcular uma data a partir de outra data, usando um deslocamento em anos.
countcenturies | Calcular o período entre duas datas em séculos.
countdays | Calcular o período entre duas datas em dias.
counthours | Calcular o período entre duas datas em horas.
countminutes | Calcular o período entre duas datas em minutos.
countseconds | Contar o número de segundos entre duas datas.
countweeks | Calcular o período entre duas datas em semanas.
countwholecenturies, countwholecenturiesbackwards | Contar o número de séculos entre duas datas.
countwholedays | Contar o número de dias completos entre duas datas.
countwholehours | Contar o número de horas completas entre duas datas.
countwholeminutes | Contar o número de minutos completos entre duas datas.
countwholemonths, countwholemonthsbackwards | Contar o número de meses completos entre duas datas.
countwholeseconds | Contar o número de segundos entre duas datas.
countwholeweeks | Contar o número de semanas completas entre duas datas.
countwholeyears, countwholeyearsbackwards | Contar o número de anos completos entre duas datas.
countyears | Calcular o período entre duas datas em anos.
day | Obter o dia do mês de uma data.
dayofweek | Obter um número representante do dia da semana de uma data.
gmt2edt | Converter uma data na Hora de Greenwhich (GMT) para um Horário de Verão do Leste dos EUA (EDT).
hour | Obter as horas de uma data.
minute | Obter os minutos de uma data.
month | Obter o mês de uma data.
now | Obter a data e a hora atuais.
second | Obter os segundos de uma data.
today | Obter a data atual.
weekofyear | Calcular a semana do ano de uma data, relativamente a uma data inicial específica.
year | Obter o ano de uma data.

Funções para trabalhar com strings

Função | Objetivo
concat | Concatenar duas ou mais strings.
endswith | Testar se uma string termina com outra.
find | Testar se uma string está contida em outra.
left | Retornar uma substring de comprimento especificado a partir do início de uma string.
mid | Retornar uma substring de comprimento especificado a partir do meio de uma string.
right | Retornar uma substring de comprimento especificado a partir do final de uma string.
soundex | Reduzir cada palavra a uma string de quatro caracteres para fins de indexação.
startswith | Testar se uma string inicia com outra.
strlen | Obter o comprimento de uma string.
strmember | Determinar o conjunto de associação.
substitute | Substituir uma string por outra.
substr | Obter uma substring a partir de uma string.
tolower | Converter uma string para texto em letra minúscula.
toupper | Converter uma string para texto em letra maiúscula.
trim | Remover todos os espaços de uma string, exceto os espaços vazios entre as palavras.

Expressões regulares e funções associadas

Função | Objetivo
match | Testar uma string para uma coincidência de expressão regular [consulte Expressões regulares].
replaceall | Substituir todas as substrings que coincidem com uma expressão regular [consulte Expressões regulares].
replacefirst | Substituir a primeira substring que coincidir com uma expressão regular [consulte Expressões regulares].

Funções matemáticas e estatísticas

Tipo | Descrição
abs | Calcular o valor absoluto de um número.
ceil | Arredondar um número para cima, para o número inteiro mais próximo.
cos | Calcular o cosseno de um ângulo.
exp | Calcular o exponencial de um número.
floor | Arredondar um número para baixo, para o número inteiro mais próximo.
log | Calcular o logaritmo natural (base "e") de um número.
log10 | Calcular o logaritmo de base 10 de um número.
logbase | Calcular o logaritmo de um número, para uma base especificada.
max (dois ou mais argumentos), maxnonnull | Calcular o máximo de dois ou mais números, ou a mais recente de duas ou mais datas ou a mais recente de duas ou mais strings alfabeticamente.
mean (dois ou mais argumentos), meannonnull | Calcular a média (média comum) de dois ou mais números.
min (dois ou mais argumentos), minnonnull | Calcular o mínimo entre dois ou mais números, ou a mais recente de duas ou mais datas ou a última de duas ou mais strings alfabeticamente.
normalizar | Normalizar valores de campo para ficarem no intervalo [0,1].
pow | Calcular o resultado de elevar um número à potência de outro.
product, productnonnull | Calcular o produto de dois ou mais números.
round | Arredondar um número para o número inteiro mais próximo.
sgn | Calcular o signo (sinal) de um número.
sin | Calcular o seno de um ângulo.
sqrt | Calcular a raiz quadrada de um número.
sum (dois ou mais argumentos), sumnonnull | Calcular a soma de dois ou mais números.
tan | Calcular a tangente de um ângulo.

Funções de amostragem de dados

Função | Objetivo
numericTestTrainSplit | Criar uma segmentação de teste/treinamento para uso na validação de modelo.
numericTestTrainValidateSplit | Criar uma segmentação de teste/treinamento/validação para uso na validação de modelo.
sampleEqualSize | Criar, aleatoriamente, um índice de segmentação para grupos de mesmo tamanho.
sampleExactNumber | Marcar, aleatoriamente, um número exato de clientes de uma população selecionada.
sampleExactPercentage | Marcar, aleatoriamente, uma porcentagem exata de clientes de uma população selecionada.
sampleStratified | Marcar, aleatoriamente, um número específico de clientes de um segmento e o resto da população.
testTrainSplit | Criar uma segmentação de teste/treinamento para uso na validação de modelo.
testTrainValidateSplit | Criar uma segmentação de teste/treinamento/validação para uso na validação de modelo.

Funções de número aleatório

Função | Objetivo
rndBinomial | Gerar um número inteiro aleatório baseado em uma distribuição binomial.
rndBool | Gerar 0 ou 1 aleatoriamente (com probabilidades iguais).
rndExp | Gerar um número positivo aleatório baseado em uma distribuição exponencial.
rndGamma | Gerar um número positivo aleatório baseado em uma distribuição gama.
rndNormal | Gerar um número aleatório baseado em uma distribuição normal.
rndPoisson | Gerar um inteiro não negativo aleatório, baseado em uma distribuição poissoniana discreta.
rndUniform | Gerar um número aleatório entre 0 e 1, baseado em uma distribuição uniforme.

Funções de retorno de investimento

Função | Objetivo
ActionROI | Estimar a contribuição para o retorno de investimento (dinheiro) por cliente por efetuar ações projetadas para gerar uma resposta definitiva.
ActionROIAnnualized | Estimar o múltiplo para o retorno de investimento anual por cliente por efetuar ações projetadas para gerar uma resposta definitiva de um cliente.
OfferROI | Estimar a contribuição para o retorno de investimento por cliente por efetuar uma oferta projetada para gerar uma resposta definitiva.
OfferROIAnnualized | Estimar o múltiplo para o retorno de investimento anual por efetuar uma oferta projetada para gerar uma resposta definitiva de um cliente.
RetentionActionROI | Estimar a contribuição para o retorno de investimento (dinheiro) por cliente por efetuar ações projetadas para evitar desgastes.
RetentionActionROIAnnualized | Estimar a contribuição para o retorno de investimento anual por cliente por efetuar ações projetadas para evitar desgastes.
RetentionOfferROI | Estimar o retorno de investimento por cliente por fazer uma oferta projetada para evitar desgastes.
RetentionOfferROIAnnualized | Estimar o retorno de investimento anual por cliente por fazer uma oferta projetada para evitar desgastes.

Funções diversas

Função | Objetivo
dblookup | Pesquisar valores em uma tabela de referência (armazenada como um focus).
membro | Determinar o conjunto de associação.
rankOrder, rankOrderApprox | Identificar a classificação de um valor em uma lista de valores.
rankOrderMean, rankOrderApproxMean | Identificar a classificação de um valor em uma lista de valores.
rownum | Gerar o número de cada linha na tabela.

Binnings

Função | Objetivo
compartimento | Obtém um índice do bin correspondente a um valor.

Consulte também

Funções definidas pelo usuário
Tópico pai: Referência de Linguagem de Campo Derivado (FDL)


Palavras reservadas em FDL

Os seguintes tokens são palavras reservadas em \fdl: accum, agg, aggregate, aggregation, and, by, case, date, default, div, double, else, eq, false, field, float, function, global, if, int, integer, long, mod, not, null, number, numeric, or, real, short, state, string, then, true, where e while

Para usar uma palavra reservada ou uma palavra que difere somente no uso de maiúsculas e minúsculas, como um identificador [consulte Expressões] em FDL ou como nome de campo ou estatística em TML, é necessário colocá-lo entre aspas simples — por exemplo, 'State'.

Nota: Apesar dos identificadores em FDL serem sensíveis a maiúsculas e minúsculas (fred e Fred são distintos), as palavras reservadas não são sensíveis a maiúsculas e minúsculas, por isso, estão reservadas em qualquer combinação: por exemplo, if, If, iF, and IF são representações do mesmo token; todas essas combinações são reservadas e não podem ser usadas como identificadores.

Consulte também

Sobre Linguagem de Campo Derivado

Palavras reservadas em TML

Tópico pai: Referência de Linguagem de Campo Derivado (FDL)


Operadores FDL

  • Operadores aritméticos
  • Operadores relacionais
  • Operadores lógicos
  • Precedência de operador
Tópico pai: Referência de Linguagem de Campo Derivado (FDL)


Operadores aritméticos

Exceto o operador menos unário, que prefixa seu único operando, todos os operadores aritméticos FDL são operadores binários infixos, ou seja, são escritos entre seus dois operandos.

Operador | Operandos | Resultado
+ (adição) | numérico | A soma dos operandos
- (subtração) | numérico | O resultado de subtrair o segundo operando ao primeiro
- (menos unário) | numérico | O negativo do operando
* (multiplicação) | numérico | O produto dos operandos
/ (divisão) | numérico | O resultado (real) da divisão do primeiro operando pelo segundo
div (divisão de número inteiro) | inteiro | O resultado (inteiro) da divisão do primeiro operando pelo segundo, ignorando o resto
mod (módulo) | inteiro | O resto na divisão do primeiro operando inteiro pelo segundo (o módulo), com o mesmo sinal do primeiro operando — por exemplo, 9 % 7 é igual a 2 mas -9 % 7 é igual a -2

Exemplos 2 + 5 é igual a 7.

2 - 5 é igual a -3.

- (2 + 5) é igual a -7.

2 * 5 é igual a 10.

2 / 5 é igual a 0,4.

2 div 5 é igual a 0.

2 mod 5 é igual a 2.

5 % 2 é igual a 1.

Nota:
  • Os operadores de adição, subtração, menos unário e de multiplicação preservam o tipo de seus operandos (que são de tipo compatível) [consulte Compatibilidade de tipo]). Se um operando for integer e o outro for um número real, o resultado é real.
  • Se o segundo operando do operador de divisão, de divisão de número inteiro ou de módulo, for zero, o resultado é nulo [consulte O valor nulo], uma vez que a divisão por zero é indefinida.
  • mod exige operandos integer.
  • É possível usar também % em vez de mod.

Consulte também

Operadores lógicos

Precedência de operador

Operadores relacionais

Tópico pai: Operadores FDL


Operadores relacionais

Todos os operadores relacionais FDL são operadores binários infixos, ou seja, são escritos entre seus dois operandos.

Operador | Operandos | Resultado
< (menor que) | inteiro, real, data ou string | "True" se o primeiro operando for menor que o segundo; "false" se o primeiro operando for maior ou igual ao segundo
<= (menor ou igual a) | inteiro, real, data ou string | "True" se o primeiro operando for menor ou igual ao segundo; "false" se o primeiro operando for maior que o segundo
> (maior que) | inteiro, real, data ou string | "True" se o primeiro operando for maior que o segundo; "false" se o primeiro operando for menor ou igual ao segundo
>= (maior ou igual a) | inteiro, real, data ou string | "True" se o primeiro operando for maior ou igual ao segundo; "false" se o primeiro operando for menor que o segundo
= (igualdade) | inteiro, real, data ou string | "True" se ambos os operandos tiverem o mesmo valor; "false" se os operandos apresentarem valores distintos. Para tipos string, a comparação ignora o caractere de espaço à direita em ambos os operandos.
!= (desigualdade) | inteiro, real, data ou string | "True" se os operandos apresentarem valores distintos; "false" se ambos os operandos tiverem o mesmo valor. Para tipos string, a comparação ignora o caractere de espaço à direita em ambos os operandos.

Exemplos 2 < 5 é igual a 1 ("TRUE").

5 < 5 é igual a 0 ("FALSE").

"A" < "B" é igual a 1 ("TRUE").

5 <= 5 é igual a 1 ("TRUE").

5 > 5 é igual a 0 ("FALSE").

7 > 5 é igual a 1 ("TRUE").

#2003/12/31 > #2003/11/30 é igual a 1 ("TRUE").

5 >= 5 é igual a 1 ("TRUE").

"A" = "A" é igual a 1 ("TRUE").

"A" = "a" é igual a 0 ("FALSE").

"A" != "A" é igual a 0 ("FALSE").

"A" != "a" é igua a 1 ("TRUE").

Nota:
  • Os operandos de um operador relacional binário devem ser de tipos compatíveis [consulte Compatibilidade de tipo].
  • Ao comparar datas, "menor que" significa anterior. Ao comparar strings, "menor que" significa anterior alfabeticamente (ou, mais especificamente, anterior na representação de caracteres). Acontece o mesmo com "maior que", etc.
  • Também é possível usar == ou eq em vez de = e <> em vez de !=.

Consulte também

Operadores aritméticos

Dados booleanos

Operadores lógicos

Tópico pai: Operadores FDL


Operadores lógicos

O operador de negação lógica prefixa seu único operando, enquanto os operadores de disjunção e conjugação lógica são operadores binários infixos, ou seja, são escritos entre seus dois operandos.
Operador | Operandos | Resultado
and (conjugação lógica) | boolean | "True" se ambos os operandos forem verdadeiros; "false" se um dos operandos for falso
or (disjunção lógica) | boolean | "True" se um dos operandos for verdadeiro; "false" se ambos os operandos forem falsos
not (negação lógica) | boolean | "True" se o operando for falso; "false" se o operando for verdadeiro

Exemplos ("A" = "A") and (5 = 5) é igual a 1 ("TRUE").

("A" = "B") and (5 = 5) é igual a 0 ("FALSE").

("A" = "B") and (5 = 2) é igual a 0 ("FALSE").

("A" = "A") or (5 = 5) é igual a 1 ("TRUE").

("A" = "B") || (5 = 5) é igual a 1 ("TRUE").

("A" = "B") or (5 = 2) é igual a 0 ("FALSE").

not ("A" = "A") é igual a 0 ("FALSE").

!(("A" = "B") or (5 = 2)) é igual a 1 ("TRUE").

Nota:
  • Atualmente, não existe um tipo de dado booleano [consulte Dados booleanos] em FDL, de forma que os operandos para operadores lógicos são, na verdade, integers. Não se deve, porém, aplicar esses operadores para quaisquer números inteiros.
  • Também é possível usar and em vez de and, || em vez de or e ! em vez de not.

Consulte também

Operadores aritméticos

Precedência de operador

Operadores relacionais

Tópico pai: Operadores FDL


Precedência de operador

Na ausência de parênteses, as operações FDL em uma expressão são realizadas por ordem de precedência de operador, da mais alta à mais baixa:
Classe | Operadores
Menos unário | -
Operadores de multiplicação | * / div mod
Operadores de adição | + -
Operadores relacionais | < <= > >= != =
Negação lógica | not
Operadores binários lógicos | and or

Se há uma ligação de precedência, as operações são realizadas da esquerda para a direita.

As subexpressões entre parênteses são sempre avaliadas em primeiro lugar.

Exemplos -5 + 12 / 4 * 2 + 20 * 3 é igual a 61.

ou seja, a expressão é avaliada como: -5 + ((12 / 4) * 2) + (20 * 3)

Movendo os parênteses:

-(5 + 12 / (4 * 2) + 20) * 3 é igual a -79.5.

Consulte também

Operadores aritméticos

Operadores lógicos

Operadores relacionais

Tópico pai: Operadores FDL


Funções FDL

  • Funções de agregação (multiargumento)
  • Funções condicionais
  • Funções de conversão de tipos de dados
  • Funções para trabalhar com datas
  • Funções matemáticas e estatísticas
  • Outras funções
  • Funções de retorno de investimento
  • Funções de número aleatório
  • Funções de classificação
  • Funções de amostragem de dados
  • Funções para trabalhar com strings
Tópico pai: Referência de Linguagem de Campo Derivado (FDL)


Funções de agregação (multiargumento)

  • max (dois ou mais argumentos), maxnonnull
  • mean (dois ou mais argumentos), meannonnull
  • min (dois ou mais argumentos), minnonnull
  • product, productnonnull
  • sum (dois ou mais argumentos), sumnonnull
Tópico pai: Funções FDL


max (dois ou mais argumentos), maxnonnull

Objetivo Calcular o máximo de dois ou mais números, ou a mais recente de duas ou mais datas ou a mais recente de duas ou mais strings alfabeticamente. A variante max devolve o valor nulo se algum de seus argumentos for nulo; a variante maxnonnull ignora argumentos nulos (mas devolve o valor nulo se todos os argumentos forem nulos).

Sintaxe

max( [image], [image], ...)

maxnonnull( [image], [image], ...)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string (todos do mesmo tipo) | , [image] , ... | Os valores a serem comparados

Resultado

Tipo | Descrição
como entrada | O máximo de [image] , [image] , ...
Nota:
  • Atenção para não confundir essa função max multiargumento com a função de agregação [consulte max (um argumento)] de mesmo nome.
  • Para as strings, "mais recente alfabeticamente" significa "último na representação de caracteres subjacentes."

Exemplos max(5,5, -3, 7, -8,5) é igual a 7.

max(5,5, -3, null, -8,5) é igual a null.

maxnonnull(5,5, -3, 7, -8,5) é igual a 7.

maxnonnull(5,5, -3, null, -8,5) é igual a 5,5.

Para determinar a próxima melhor ação para um cliente, de acordo com diferentes medições de ROI:

maxvalue := max (ROI1, ROI2, ROI3);

ocorrência

maxvalue = ROI1: "Produto1";

maxvalue = ROI2: "Produto2";

maxvalue = ROI3: "Produto3";

Tópico pai: Funções de agregação (multiargumento)


mean (dois ou mais argumentos), meannonnull

Objetivo Calcular a média (média comum) de dois ou mais números. A variante mean devolve o valor nulo se algum de seus argumentos for nulo; a variante meannonnull ignora os argumentos nulos (mas devolve o valor nulo se todos os argumentos forem nulos).

Sintaxe

mean( [image], [image], ...)

meannonnull( [image], [image], ...)

Argumentos

Tipo | Nome | Descrição
numérico | , [image] , ... | Os números para calcular a média

Resultado

Tipo | Descrição
real | A média de [image] , [image] , ...
Nota:

Atenção para não confundir essa função mean multiargumento com a função de agregação [consulte mean (um argumento)] de mesmo nome.

Exemplos mean(5,5, -3, 7, -8,5) é igual a 0,25.

mean(5,5, -3, null, -8,5) é igual a null.

meannonnull(5,5, -3, 7, -8,5) é igual a 0,25.

meannonnull(5,5, -3, null, -8,5) é igual a 2.

Para calcular o gasto médio anual de quatro campos de gastos separados do trimestre:

mean(SpendQtr1, SpendQtr2, SpendQtr3, SpendQtr4)

Tópico pai: Funções de agregação (multiargumento)


min (dois ou mais argumentos), minnonnull

Objetivo Calcular o mínimo de dois ou mais números, ou a mais recente de duas ou mais datas ou a mais recente de duas ou mais strings alfabeticamente. A variante min devolve o valor nulo se algum de seus argumentos for nulo; a variante minnonnull ignora os argumentos nulos (mas devolve o valor nulo se todos os argumentos forem nulos).

Sintaxe

min( [image], [image], ...)

minnonnull( [image], [image], ...)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string (todos do mesmo tipo) | , [image] , ... | Os valores a serem comparados

Resultado

Tipo | Descrição
como entrada | O mínimo de [image] , [image] , ...
Nota:
  • Atenção para não confundir essa função min multiargumento com a função de agregação [consulte min (um argumento)] de mesmo nome.
  • Para as strings, "mais recente alfabeticamente" significa "as mais recentes na representação de caracteres subjacentes."

Exemplos min(5,5, -3, 7, -8,5) é igual a -8,5.

min(5,5, -3, null, -8,5) é igual a null.

minnonnull(5,5, -3, 7, -8,5) é igual a -8,5.

minnonnull(5,5, -3, null, -8,5) é igual a -8,5.

Tópico pai: Funções de agregação (multiargumento)


product, productnonnull

Objetivo Calcular o produto de dois ou mais números. A variante do product retorna o valor nulo se algum de seus argumentos é nulo; a variante productnonnull ignora os argumentos nulos (mas ainda assim retorna o valor nulo se todos os seus argumentos são nulos).

Sintaxe

product( [image], [image], ...)

productnonnull( [image], [image], ...)

Argumentos

Tipo | Nome | Descrição
numérico | , [image] , ... | Os números a serem multiplicados

Resultado

Tipo | Descrição
como entrada | O produto de [image] , [image] , ...

Exemplos product(5,5, -3, 7, -8,5) é igual a 981,75.

product(5,5, -3, null, -8,5) é igual a nulo.

productnonnull(5,5, -3, 7, -8,5) é igual a 981,75.

productnonnull(5,5, -3, null, -8,5) é igual a 140,25.

Tópico pai: Funções de agregação (multiargumento)


sum (dois ou mais argumentos), sumnonnull

Objetivo Calcular a soma de dois ou mais números. A variante de sum devolve o valor nulo se algum de seus argumentos for nulo; a variante de sumnonnull ignora os argumentos nulos (mas devolve o valor nulo se todos os argumentos forem nulos).

Sintaxe

sum( [image], [image], ...)

sumnonnull( [image], [image], ...)

Argumentos

Tipo | Nome | Descrição
numérico | , [image] , ... | Os números a serem somados

Resultado

Tipo | Descrição
como entrada | A soma de [image] , [image] , ...
Nota:

Atenção para não confundir essa função sum multiargumento com a função de agregação [consulte sum (um argumento)] de mesmo nome.

Exemplos sum(5,5, -3, 7, -8,5) é igual a 1.

sum(5,5, -3, null, -8,5) é igual a null.

sumnonnull(5,5, -3, 7, -8,5) é igual a 1.

sumnonnull(5,5, -3, null, -8,5) é igual a -6.

Para derivar o gasto total de seis campos de gastos semanais:

sum(SpendWk1, SpendWk2, SpendWk3, SpendWk4, SpendWk5, SpendWk6)

Tópico pai: Funções de agregação (multiargumento)


Funções condicionais

  • clamp
  • cond
  • iff
  • ifnull, nvl
  • isnull
  • isselected
  • replace
Tópico pai: Funções FDL


clamp

Objetivo Restringir um número entre um intervalo específico.

Sintaxe clamp(x, min, max)

Argumentos

Tipo | Nome | Descrição
numérico | x | O número a ser fixado
como x | min | O limite inferior do intervalo
como x | max | O limite superior do intervalo

Resultado

Tipo | Descrição
como entrada | x se [image] ; min se x < min; max se x > max

Exemplos Fixar valores em um intervalo entre 18 e 65 inclusive, substituindo valores fora do intervalo com os limites de intervalo apropriados:

CustomerAge | clamp(CustomerAge,18,65)
9 | 18
18 | 18
66 | 65
43 | 43

Consulte também

replace
Tópico pai: Funções condicionais


cond

Objetivo Produzir um de dois resultados dependendo se uma expressão é ou não zero.

Sintaxe cond(cond, trueExpr, falseExpr)

Argumentos

Tipo | Nome | Descrição
inteiro | cond | A expressão a testar
inteiro, real, data ou string | trueExpr | Ramificação "true" (diferente de zero)
como trueExpr | falseExpr | Ramificação "false" (zero)

Resultado

Tipo | Descrição
como trueExpr, falseExpr | trueExpr se cond [image] 0; falseExpr se cond = 0
Nota:

Ao contrário de uma expressão if [consulte A expressão if] ou expressão case [consulte A expressão case], ambas as ramificações são avaliadas pela função cond.

Mais significativamente, cond preserva a incerteza de um valor nulo [consulte O valor nulo] na condição.

Se não precisar desse comportamento, use uma expressão if ou case para ser mais rápido.

Exemplos Apontar para clientes com um gasto zero no 2.º Trimestre para uma campanha de correspondência:

SpendQtr2 | cond(SpendQtr2, "Não Enviar", "Enviar")
100.39 | Não Enviar
0 | direta
-5.72 | direta
null | null

Consulte também

clamp

iff

ifnull, nvl

replace

Tópico pai: Funções condicionais


iff

Objetivo Produzir um de dois resultados dependendo se uma expressão é ou não zero.

Sintaxe iff(logical_text, value_if_true, value_if_false)

Argumentos

Tipo | Nome | Descrição
real | logical_text | A expressão a testar
inteiro, real, data ou string | value_if_true | Ramificação "true" (diferente de zero)
como value_if_true | value_if_false | Ramificação "false" (zero ou nulo)

Resultado

Tipo | Descrição
como value_if_true, value_if_false | value_if_true se logical_text [image] 0; value_if_false se logical_text = 0 ou logical_text é nulo

Exemplos iff(Score > 650, "Enviar", "Não Enviar")

Consulte também

cond
Tópico pai: Funções condicionais


ifnull, nvl

Objetivo Substituir o valor nulo. É possível usar nvl como alias para ifnull.

Sintaxe ifnull(testNull, replaceValue)

nvl(testNull, replaceValue)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | testNull | O valor a ser testado
como testNull | replaceValue | A substituição pelo valor nulo

Resultado

Tipo | Descrição
como entrada | Uma cópia do valor testNull com replaceValue substituindo o valor nulo

Exemplos Para substituir valor em falta com um valor derivado de outro campo:

SpendQtr1 | GastoAnual | ifnull(SpendQtr1, AnnualSpend/4)
45.21 | 178.97 | 45.21
null | 150.56 | 37.64
null | 784.27 | 196.07
59.05 | 274.18 | 59.05

Consulte também

cond

isnull

Tópico pai: Funções condicionais


isnull

Objetivo Testar se um valor é nulo.

Sintaxe isnull(x)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | x | O valor a ser testado

Resultado

Tipo | Descrição
inteiro | 1 se x é nulo; caso contrário, 0

Exemplos Substituir entradas de valores nulos em um campo com o valor médio desse campo:

Idade | if isnull(Age) then mean(Age) else Age
32 | 32
null | 44
59 | 59
27 | 27

Consulte também

Dividir agregações: a cláusula by
Tópico pai: Funções condicionais


isselected

Objetivo Marcar os registros atualmente selecionados.

Sintaxe isselected()

Argumentos Nenhum

Resultado

Tipo | Descrição
inteiro | 1, se o registro estiver selecionado atualmente, caso contrário, 0
Nota:

O Visualizador de Dados tem um suporte especial para expansão imediata [consulte Entrada de função assistida no Visualizador de Dados] dessa função.

Exemplos if isselected() then "LowRisk" else "HighRisk"

Tópico pai: Funções condicionais


replace

Objetivo Substituir um número se não estiver dentro do intervalo fornecido.

Sintaxe replace(x, min, max, y)

Argumentos

Tipo | Nome | Descrição
numérico | x | O número a ser testado
como x | min | O limite inferior do intervalo
como x | max | O limite superior do intervalo
como x | y | O valor de substituição

Resultado

Tipo | Descrição
como entrada | x se [image] ; y caso contrário

Exemplos Fixar valores em um intervalo entre 18 e 65 inclusive, substituindo valores fora do intervalo com o valor médio:

CustomerAge | replace (CustomerAge, 18, 65, mean(CustomerAge))
9 | 38
18 | 18
66 | 38
43 | 43

Consulte também

clamp
Tópico pai: Funções condicionais


Funções de conversão de tipos de dados

  • todate
  • tointeger
  • toreal
  • tostring
Tópico pai: Funções FDL


todate

Objetivo Converter um valor para uma data.

Sintaxe todate(x [, format] )

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | x | Um valor a converter
string | formato | Um formato de data [consulte Formatos de data] para uso na conversão (opcional e somente permitido se x for do tipo string)

Resultado

Tipo | Descrição
data | x, como uma data
Nota:
  • Se o argumento é do tipo integer, assume-se que ele represente a data como AAAAMMDD.
  • Se o argumento é do tipo real, assume-se que ele represente a data como AAAAMMDD. HHMMSS.
  • Se o argumento é do tipo string e não é fornecido um argumento de formato de data, a string é convertida de acordo com a configuração em sua preferência ler [consulte ler].

Exemplos (Valores de data mostrados no formato de data european.)

todate(20040109) é igual a 09/01/2004:00:00:00.

todate(20040109.122853) é igual a 09/01/2004:12:08:52.

todate("09/01/2004") é igual a 09/01/2004:00:00:00.

todate("09-Jan-2004","%d-%b-%Y") é igual a 09/01/2004:00:00:00.

todate(#09/01/2004:12:28:53) é igual a 09/01/2004:12:28:53.

Consulte também

tointeger

toreal

tostring

Conversão de tipo

Tópico pai: Funções de conversão de tipos de dados


tointeger

Objetivo Converter um valor para um número integer.

Sintaxe tointeger(x)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | x | Um valor a converter

Resultado

Tipo | Descrição
inteiro | x, como um valor inteiro
Nota:
  • Se o argumento é do tipo real, os dígitos após o ponto decimal são ignorados.
  • Se o argumento é do tipo date, o resultado é no formato AAAAMMDD (o componente de hora é ignorado).
  • Se o argumento é do tipo string, quaisquer caracteres não numéricos à direita são ignorados.

Exemplos tointeger(100) é igual a 100.

tointeger(100,65) é igual a 100.

tointeger("100,65") é igual a 100.

tointeger(#09/01/2004:12:28:53) é igual a 20040109.

Consulte também

todate

toreal

tostring

Conversão de tipo

Tópico pai: Funções de conversão de tipos de dados


toreal

Objetivo Converter um valor para um número real.

Sintaxe toreal(x)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | x | Um valor a converter

Resultado

Tipo | Descrição
real | x, como um número real
Nota:
  • Se o argumento é do tipo date, o resultado é no formato AAAAMMDD.HHMMSS.
  • Se o argumento é do tipo string, quaisquer caracteres não numéricos à direita são ignorados.

Exemplos toreal(100) é igual a 100,0.

toreal(100,65) é igual a 100,65.

toreal("100.65") é igual a 100.65.

toreal(#09/01/2004:12:28:53) é igual a 20040109.122853.

Consulte também

todate

tointeger

tostring

Conversão de tipo

Tópico pai: Funções de conversão de tipos de dados


tostring

Objetivo Converter um valor para uma string.

Sintaxe tostring(x)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | x | Um valor a converter

Resultado

Tipo | Descrição
string | x, como uma string
Nota:
  • Se o argumento é do tipo real, o resultado é um formato decimal comum (não cientifico).
  • Se o argumento é do tipo date, o resultado é formatado de acordo com a configuração de sua preferência gravação de data [consulte gravação de data].

Exemplos tostring(100) é igual a "100".

tostring(1.0065e2) é igual a "100.650000".

tostring("100.65") é igual a "100.65".

tostring(#09/01/2004:12:28:53) é igual a "09/01/2004:12:28:53".

Consulte também

todate

tointeger

toreal

Conversão de tipo

Tópico pai: Funções de conversão de tipos de dados


Funções para trabalhar com datas

  • addcenturies, addcenturiescountbackwards
  • adddays
  • addhours
  • addminutes
  • addmonths, addmonthscountbackwards
  • addseconds
  • addweeks
  • addyears, addyearscountbackwards
  • countcenturies
  • countdays
  • counthours
  • countminutes
  • countseconds
  • countweeks
  • countwholecenturies, countwholecenturiesbackwards
  • countwholedays
  • countwholehours
  • countwholeminutes
  • countwholemonths, countwholemonthsbackwards
  • countwholeseconds
  • countwholeweeks
  • countwholeyears, countwholeyearsbackwards
  • countyears
  • day
  • dayofweek
  • gmt2edt
  • hour
  • minute
  • month
  • now
  • second
  • today
  • weekofyear
  • year
Tópico pai: Funções FDL


addcenturies, addcenturiescountbackwards

Objetivo Calcular a data a partir de outra data usando um deslocamento em séculos.

Sintaxe addcenturies(date, n)

addcenturiescountbackwards(date, n)

Argumentos

Tipo | Nome | Descrição
data | date | A data inicial
inteiro | n | O número de séculos a adicionar (que pode ser negativo)

Resultado

Tipo | Descrição
data | A data n séculos de calendário após a data date (interpretada como |n| séculos antes de date se n < 0). A hora do resultado é igual à parte da hora de date. Consulte addmonths, addmonthscountbackwards para uma explicação das duas variantes.
Nota:

O resultado de adicionar n séculos usando a função addcenturies (respectivamente, addcenturiescountbackwards) é definido como o resultado de adicionar 1200n meses com a função addmonths (respectivamente, addmonthscountbackwards).

Exemplos Para calcular uma data um século depois de d, mostrando a diferença entre as variantes addcenturies e addcenturiescountbackwards (formato de data YMD):

d | addcenturies(d,1) | addcenturiescountbackwards(d,1)
1900/02/14 | 2000/02/14 | 2000/02/15
Consulte também

countcenturies

countwholecenturies, countwholecenturiesbackwards

Formatos de data

Tópico pai: Funções para trabalhar com datas


adddays

Objetivo Calcular uma data a partir de outra data, usando um deslocamento em dias.

Sintaxe adddays(date, n)

Argumentos

Tipo | Nome | Descrição
data | date | A data inicial
inteiro | n | O número de dias a adicionar (que pode ser negativo).

Resultado

Tipo | Descrição
data | A data n dias após a data date (interpretada como |n| dias antes da data date se n < 0). A hora do resultado é igual à parte da hora de date.

Exemplos Formato de data european: adddays(#09/01/2004, 25) é igual a 03/02/2004.

Formato de data european: adddays(#09/01/2004:11:43:46, 25) é igual a 03/02/2004:11:43:46.

Formato de data american: adddays(#01/09/2004, 25) é igual a 02/03/2004.

Formato de data american: adddays(#01/09/2004:11:43:46, 25) é igual a 02/03/2004:11:43:46.

Formato de data YMD: adddays(#2004/01/09, 25) é igual a 2004/02/03.

Formato de data YMD: adddays(#2004/01/09:11:43:46, 25) é igual a 2004/02/03:11:43:46.

Consulte também

countdays

countwholedays

Formatos de data

Tópico pai: Funções para trabalhar com datas


addhours

Objetivo Calcular uma data a partir de outra data usando um deslocamento em horas.

Sintaxe addhours(date, n)

Argumentos

Tipo | Nome | Descrição
data | date | A data inicial
inteiro | n | O número de horas a adicionar (que pode ser negativo)

Resultado

Tipo | Descrição
data | A data n horas após a data date (interpretada como |n| horas antes da date, se n < 0)
Nota:

Todas as datas em FDL incluem um componente de hora.

Exemplos Formato de data european: addhours(#09/01/2004:12:28:53, 25) é igual a 10/01/2004:13:28:53.

Formato de data american: addhours(#01/09/2004:12:28:53, 25) é igual a 01/10/2004:13:28:53.

Formato de data YMD: addhours(#2004/01/09:12:28:53, 25) é igual a 2004/01/10:13:28:53.

Consulte também

counthours

countwholehours

Formatos de data

Tópico pai: Funções para trabalhar com datas


addminutes

Objetivo Calcular uma data a partir de outra data, usando um deslocamento em minutos.

Sintaxe addminutes(date, n)

Argumentos

Tipo | Nome | Descrição
data | date | A data inicial
inteiro | n | O número de minutos a adicionar (que pode ser negativo)

Resultado

Tipo | Descrição
data | A data n minutos após a data date (interpretada como |n| minutos antes da date, se n < 0)
Nota:

Todas as datas em FDL incluem um componente de hora.

Exemplos Formato de data european: addminutes(#09/01/2004:12:28:53, 25) é igual a 09/01/2004:12:53:53.

Formato de data american: addminutes(#01/09/2004:12:28:53, 25) é igual a 01/09/2004:12:53:53.

Formato de data YMD: addminutes(#2004/01/09:12:28:53, 25) é igual a 2004/01/09:12:53:53.

Consulte também

countminutes

countwholeminutes

Formatos de data

Tópico pai: Funções para trabalhar com datas


addmonths, addmonthscountbackwards

Objetivo Calcular uma data a partir de outra data usando um deslocamento em meses.

Sintaxe addmonths(date, n)

addmonthscountbackwards(date, n)

Argumentos

Tipo | Nome | Descrição
data | date | A data inicial
inteiro | n | O número de meses para adicionar (que pode ser negativo)
Resultado
Tipo Descrição
data A data n meses de calendário após a data date (interpretada como |n| meses antes de date se n < 0).

O mês e o ano do resultado são determinados pelo deslocamento n.

Em seguida, o dia do mês do resultado é configurado para ser igual ao indicado na data date (para addmonths) ou o mesmo número de dias do final do mês indicado na data date (para addmonthscountbackwards).

Se o dia do mês acabasse por ser antes do início ou depois do final do mês (porque o mês do resultado é um mês menor que o mês que contém a date), o dia ficaria fixo no primeiro ou último dia do mês, conforme apropriado.

A hora do resultado é igual à parte da hora de date.

Nota:
  • Se forem adicionados n meses por meio do addmonths (ou addmonthscountbackwards), o resultado não será o mesmo que seria obtido ao adicionar um mês n vezes, uma vez que o dia do mês pode ser restringido por um mês intermédio mais curto no último caso.
  • Os resultados da adição de uma data com addmonths e addmonthscountbackwards podem ser diferentes se o mês da data e o mês do resultado tiverem diferentes números de dias.

Exemplos Calcular a data um mês depois de d, mostrando a propagação da hora (formato de data YMD):

d | addmonths(d,1)
2007/08/14:00:00:00 | 2007/09/14:00:00:00
2007/08/14:12:34:56 | 2007/09/14:12:34:56

Calcular uma data um mês depois de d, mostrando a diferença entre as variantes addmonths e addmonthscountbackwards (formato de data YMD):

d | addmonths(d,1) | addmonthscountbackwards(d,1)
2007/08/14 | 2007/09/14 | 2007/09/13

Calcular uma data um mês depois de d, mostrando o comportamento de fixação de addmonths no final de um mês (formato de data YMD):

d | addmonths(d,1)
2007/08/31 | 2007/09/30

Calcular uma data um mês depois de d, mostrando o comportamento de fixação de addmonthscountbackwards no início do mês (formato de data YMD):

d | addmonthscountbackwards(d,1)
2007/08/02 | 2007/09/01
2007/08/01 | 2007/09/01

Calcular o aniversário de seis meses de cada aquisição do cliente, usando o campo de data StartDate da aquisição do cliente:

addmonths(StartDate, 6)

Consulte também

countwholemonths, countwholemonthsbackwards

Formatos de data

Tópico pai: Funções para trabalhar com datas


addseconds

Objetivo Calcular uma data a partir de outra data, usando um deslocamento em segundos.

Sintaxe addseconds(date, n)

Argumentos

Tipo | Nome | Descrição
data | date | A data inicial
inteiro | n | O número de segundos a adicionar (que pode ser negativo)

Resultado

Tipo | Descrição
data | A data n segundos após a data date (interpretada como |n| segundos antes da date, se n < 0)
Nota:

Todas as datas em FDL incluem um componente de hora.

Exemplos Formato de data european: addseconds(#09/01/2004:12:28:53, 25)é igual a 09/01/2004:12:54:18.

Formato de data american: addseconds(#01/09/2004:12:28:53, 25) é igual a 01/09/2004:12:54:18.

Formato de data YMD: addseconds(#2004/01/09:12:28:53, 25) é igual a 2004/01/09:12:54:18.

Consulte também

countseconds

countwholeseconds

Formatos de data

Tópico pai: Funções para trabalhar com datas


addweeks

Objetivo Calcular uma data a partir de outra data, usando um deslocamento em semanas.

Sintaxe addweeks(date, n)

Argumentos

Tipo | Nome | Descrição
data | date | A data inicial
inteiro | n | O número de semanas a adicionar (que pode ser negativo)

Resultado

Tipo | Descrição
date | A data n semanas após a data date (interpretada como |n| semanas antes da date, se n < 0). A hora do resultado é igual à parte da hora de date.

Exemplos Formato de data european: addweeks(#09/01/2004, 8) é igual a 05/03/2004.

Formato de data american: addweeks(#01/09/2004, 8) é igual a 03/05/2004.

Formato de data YMD: addweeks(#2004/01/09, 8) é igual a 2004/03/05.

Consulte também

countweeks

countwholeweeks

Formatos de data

Tópico pai: Funções para trabalhar com datas


addyears, addyearscountbackwards

Objetivo Calcular uma data a partir de outra data, usando um deslocamento em anos.

Sintaxe addyears(date, n)

addyearscountbackwards(date, n)

Argumentos

Tipo | Nome | Descrição
data | date | A data inicial
inteiro | n | O número de anos a adicionar (que pode ser negativo)

Resultado

Tipo | Descrição
data | A data n anos de calendário após a data date (interpretada como |n| anos antes da date se n < 0). A hora do resultado é igual à parte da hora de date. Consulte addmonths, addmonthscountbackwards para uma explicação das duas variantes.
Nota:

O resultado de adicionar n anos usando a função addyears (respectivamente, addyearscountbackwards) é definido como o resultado de adicionar 12n meses com a função addmonths (respectivamente, addmonthscountbackwards).

Exemplos Calcular uma data um ano depois de d, mostrando a diferença entre as variantes addyears e addyearscountbackwards (formato de data YMD):

d | addyears(d,1) | addyearscountbackwards(d,1)
2007/02/14 | 2008/02/14 | 2008/02/15

Para calcular o aniversário de um ano de cada aquisição do cliente, usando o campo de data StartDate da aquisição do cliente:

addyears(StartDate, 1)

Consulte também

countwholeyears, countwholeyearsbackwards

countyears

Formatos de data

Tópico pai: Funções para trabalhar com datas


countcenturies

Objetivo Calcular o período entre duas datas em séculos.

Sintaxe countcenturies(date1, date2)

Argumentos

Tipo | Nome | Descrição
data | date1 | a primeira data
data | date2 | a segunda data

Resultado

Tipo | Descrição
real | O período entre date1 e date2 em séculos (um número negativo se date1 for posterior a date2)
Nota:
  • Se o número não é um múltiplo exato de 100 anos (considerando as partes de hora das datas), o resultado inclui uma parte fracional.
  • O resultado da função countcenturies é definido como a função countyears, dividido por 100.

Exemplos Formato de data european: countcenturies(#09/01/2004, #09/01/2054) é igual a 0,5.

Formato de data american: countcenturies(#01/09/2004, #01/09/2054) é igual a 0,5.

Formato de data YMD: countcenturies(#2004/01/09, #2054/01/09) é igual a 0,5.

Consulte também

countwholecenturies, countwholecenturiesbackwards

Formatos de data

Tópico pai: Funções para trabalhar com datas


countdays

Objetivo Calcular o período entre duas datas em dias.

Sintaxe countdays(date1, date2)

Argumentos

Tipo | Nome | Descrição
data | date1 | a primeira data
data | date2 | a segunda data

Resultado

Tipo | Descrição
real | O período entre date1 e date2 em dias (um número negativo se date1 for posterior a date2)
Nota:

Se as partes da hora das duas datas são diferentes, o resultado inclui uma parte fracional.

Exemplos Formato de data european: countdays(#09/01/2004, #03/02/2004) é igual a 25.

countdays(#09/01/2004:10:00:00, #03/02/2004:11:00:00) é igual a 25,04.

countdays(#09/01/2004:11:00:00, #03/02/2004:10:00:00) é igual a 24,96.

Formato de data american: countdays(#01/09/2004, #02/03/2004) é igual a 25.

countdays(#01/09/2004:10:00:00, #02/03/2004:11:00:00) é igual a 25,04.

countdays(#01/09/2004:11:00:00, #02/03/2004:10:00:00) é igual a 24,96.

Formato de data YMD: countdays(#2004/01/09, #2004/02/03) é igual a 25.

countdays(#2004/01/09:10:00:00, #2004/02/03:11:00:00) é igual a 25,04.

countdays(#2004/01/09:11:00:00, #2004/02/03:10:00:00) é igual a 24,96.

Consulte também

adddays

countwholedays

Formatos de data

Tópico pai: Funções para trabalhar com datas


counthours

Objetivo Calcular o período entre duas datas em horas.

Sintaxe counthours(time1, time2)

Argumentos

Tipo | Nome | Descrição
data | time1 | a primeira data/hora
data | time2 | a segunda data/hora

Resultado

Tipo | Descrição
real | O período entre time1 e time2 em horas (um número negativo se time1 for posterior a time2)
Nota:

Se as partes dos minutos ou dos segundos das duas datas são diferentes, o resultado inclui uma parte fracional.

Exemplos Formato de data european: counthours(#09/01/2004:12:28:53, #10/01/2004:13:28:53) é igual a 25.

Formato de data american: counthours(#01/09/2004:12:28:53, #01/10/2004:13:28:53) é igual a 25.

Formato de data YMD: counthours(#2004/01/09:12:28:53, #2004/01/10:13:28:53) é igual a 25.

Consulte também

countwholehours

Formatos de data

Tópico pai: Funções para trabalhar com datas


countminutes

Objetivo Calcular o período entre duas datas em minutos.

Sintaxe countminutes(time1, time2)

Argumentos

Tipo | Nome | Descrição
data | time1 | a primeira data/hora
data | time2 | a segunda data/hora

Resultado

Tipo | Descrição
real | O período entre time1 e time2 em minutos (um número negativo se time1 for posterior a time2)
Nota:

Se as partes dos segundos das duas datas são diferentes, o resultado inclui uma parte fracional.

Exemplos Formato de data european: countminutes(#09/01/2004:12:28:53, #09/01/2004:12:53:53) é igual a 25.

Formato de data american: countminutes(#01/09/2004:12:28:53, #01/09/2004:12:53:53) é igual a 25.

Formato de data YMD: countminutes(#2004/01/09:12:28:53, #2004/01/09:12:53:53) é igual a 25.

Consulte também

countwholeminutes

Formatos de data

Tópico pai: Funções para trabalhar com datas


countseconds

Objetivo Contar o número de segundos entre duas datas.

Sintaxe countseconds(time1, time2)

Argumentos

Tipo | Nome | Descrição
data | time1 | a primeira data/hora
data | time2 | a segunda data/hora

Resultado

Tipo | Descrição
real | O número de segundos decorridos entre time1 e time2 (um número negativo se time1 for posterior a time2)
Nota:

A única diferença entre essa função e a countwholeseconds é que o resultado da última é do tipo integer.

Exemplos Formato de data european: countseconds(#09/01/2004:12:28:53, #09/01/2004:12:29:18) é igual a 25.

Formato de data american: countseconds(#01/09/2004:12:28:53, #01/09/2004:12:29:18) é igual a 25.

Formato de data YMD: countseconds(#2004/01/09:12:28:53, #2004/01/09:12:29:18) é igual a 25.

Consulte também

Formatos de data
Tópico pai: Funções para trabalhar com datas


countweeks

Objetivo Calcular o período entre duas datas em semanas.

Sintaxe countweeks(date1, date2)

Argumentos

Tipo | Nome | Descrição
data | date1 | a primeira data
data | date2 | a segunda data

Resultado

Tipo | Descrição
real | O período entre date1 e date2 em semanas (um número negativo se date1 é posterior a date2)
Nota:

Se o número não é um múltiplo exato de sete dias (considerando as partes da hora das datas), o resultado inclui uma parte fracional.

Exemplos Formato de data european: countweeks(#09/01/2004, #05/03/2004) é igual a 8.

Formato de data american: countweeks(#01/09/2004, #03/05/2004) é igual a 8.

Formato de data YMD: countweeks(#2004/01/09, #2004/03/05) é igual a 8.

Consulte também

countwholeweeks

Formatos de data

Tópico pai: Funções para trabalhar com datas


countwholecenturies, countwholecenturiesbackwards

Objetivo Contar o número de séculos completos entre duas datas.

Sintaxe countwholecenturies(date1, date2) countwholecenturiesbackwards(date1, date2)

Argumentos

Tipo | Nome | Descrição
data | date1 | a primeira data
data | date2 | a segunda data

Resultado

Tipo | Descrição
inteiro | O número de séculos completos decorridos entre date1 e date2 (um número negativo se date1 for posterior a date2). Consulte countwholemonths, countwholemonthsbackwards para uma explicação das duas variantes.
Nota:
  • O resultado da função countwholecenturies (respectivamente, countwholecenturiesbackwards)) é definido como o resultado da função countwholemonths (respectivamente, countwholemonthsbackwards)) dividido por 1200, ignorando qualquer resto da divisão.
  • Os resultados de comparar duas datas com countwholecenturies e countwholecenturiesbackwards podem ser diferentes, mas somente se ambas as datas ocorrerem em fevereiro, uma data ocorrer em um ano divisível por 400 e a outra ocorrer em um ano divisível por 100 mas não divisível por 400.

Exemplos Para contar o número de séculos completos entre d1 e d2, mostrando a diferença entre as variantes countwholecenturies e countwholecenturiesbackwards (formato de data YMD):

d1 | d2 | countwholecenturies(d1,d2) | countwholecenturiesbackwards(d1,d2)
1900/02/14 | 2000/02/13 | 0 | 0
1900/02/14 | 2000/02/14 | 1 | 0
1900/02/14 | 2000/02/15 | 1 | 1

Consulte também

addcenturies, addcenturiescountbackwards

countcenturies

Formatos de data

Tópico pai: Funções para trabalhar com datas


countwholedays

Objetivo Contar o número de dias completos entre duas datas.

Sintaxe countwholedays(date1, date2)

Argumentos

Tipo | Nome | Descrição
data | date1 | a primeira data
data | date2 | a segunda data

Resultado

Tipo | Descrição
inteiro | O número de períodos de 24 horas completos decorridos entre date1 e date2 (um número negativo se date1 for posterior a date2)

Exemplos Formato de data european: countdays(#09/01/2004, #03/02/2004) é igual a 25.

countdays(#09/01/2004:10:00:00, #03/02/2004:11:00:00) é igual a 25.

countdays(#09/01/2004:11:00:00, #03/02/2004:10:00:00) é igual a 24.

Formato de data american: countdays(#01/09/2004, #02/03/2004) é igual a 25.

countdays(#01/09/2004:10:00:00, #02/03/2004:11:00:00) é igual a 25.

countdays(#01/09/2004:11:00:00, #02/03/2004:10:00:00) é igual a 24.

Formato de data YMD: countdays(#2004/01/09, #2004/02/03) é igual a 25.

countdays(#2004/01/09:10:00:00, #2004/02/03:11:00:00) é igual a 25.

countdays(#2004/01/09:11:00:00, #2004/02/03:10:00:00) é igual a 24.

Consulte também

adddays

countdays

Formatos de data

Tópico pai: Funções para trabalhar com datas


countwholehours

Objetivo Contar o número de horas completas entre duas datas.

Sintaxe countwholehours(time1, time2)

Argumentos

Tipo | Nome | Descrição
data | time1 | a primeira data/hora
data | time2 | a segunda data/hora

Resultado

Tipo | Descrição
inteiro | O número de horas completas decorridas entre time1 e time2 (um número negativo se time1 for posterior a time2)

Exemplos Formato de data european: countwholehours(#09/01/2004:12:28:53, #10/01/2004:13:28:53) é igual a 24.

Formato de data american: countwholehours(#01/09/2004:12:28:53, #01/10/2004:13:28:53) é igual a 24.

Formato de data YMD: countwholehours(#2004/01/09:12:28:53, #2004/01/10:13:28:53) é igual a 24.

Consulte também

counthours

Formatos de data

Tópico pai: Funções para trabalhar com datas


countwholeminutes

Objetivo Contar o número de minutos completos entre duas datas.

Sintaxe countwholeminutes(time1, time2)

Argumentos

Tipo | Nome | Descrição
data | time1 | a primeira data/hora
data | time2 | a segunda data/hora

Resultado

Tipo | Descrição
inteiro | O número de minutos completos decorridos entre time1 e time2 (um número negativo se time1 for posterior a time2)

Exemplos Formato de data european: countwholeminutes(#09/01/2004:12:28:53, #09/01/2004:12:53:53) é igual a 24.

Formato de data american: countwholeminutes(#01/09/2004:12:28:53, #01/09/2004:12:53:53) é igual a 24.

Formato de data YMD: countwholeminutes(#2004/01/09:12:28:53, #2004/01/09:12:53:53) é igual a 24.

Consulte também

countminutes

Formatos de data

Tópico pai: Funções para trabalhar com datas


countwholemonths, countwholemonthsbackwards

Objetivo Contar o número de meses completos entre duas datas.

Sintaxe countwholemonths(date1, date2) countwholemonthsbackwards(date1, date2)

Argumentos

Tipo | Nome | Descrição
data | date1 | a primeira data
data | date2 | a segunda data

Resultado

Tipo | Descrição
inteiro | O número de meses completos decorridos entre date1 e date2 (um número negativo se date1 for posterior a date2)
Nota:
  • As partes da hora de date1 e de date2 são ignoradas.
  • O número de meses completos entre duas datas é o maior número de meses que pode ser adicionado à primeira data (truncando partes de hora e usando addmonths em caso de countwholemonths e addmonthscountbackwards em caso de countwholemonthsbackwards). Assim, se a segunda data for posterior à primeira data, o resultado não é posterior à segunda data, e se a segunda data for anterior à primeira data, o resultado não é anterior à segunda data.
  • Os resultados de comparar duas data com countwholemonths e countwholemonthsbackwards podem ser diferentes quando as datas ocorrem em meses com duração diferente.
  • Devido ao comportamento de fixação de addmonths (e addmonthscountbackwards), o valor absoluto dos resultados de comparar duas datas com countwholemonths (ou countwholemonthsbackwards) pode depender da ordem dos argumentos quando as datas ocorrem em meses com duração diferente.

Exemplos Contar o número de meses completos entre d1 e d2, mostrando o truncamento de partes de hora (formato de data YMD):

d1 | d2 | countwholemonths(d1,d2)
2007/08/14:00:00:00 | 2007/09/14:00:00:00 | 1
2007/08/14:12:34:56 | 2007/09/14:00:00:00 | 1

Contar o número de meses completos entre d1 r d2, mostrando a diferença entre as variantes countwholemonths e countwholemonthsbackwards (formato de data YMD):

d1 | d2 | countwholemonths(d1,d2) | countwholemonthsbackwards(d1,d2)
2007/08/14 | 2007/09/12 | 0 | 0
2007/08/14 | 2007/09/13 | 0 | 1
2007/08/14 | 2007/09/14 | 1 | 1

Contar o número de meses completos entre d1 e d2, mostrando o comportamento de fixação de countwholemonths no final do mês (formato de data YMD):

d1 | d2 | countwholemonths(d1,d2) | countwholemonths(d2,d1)
2007/08/31 | 2007/09/30 | 1 | 0

Contar o número de meses completos entre d1 e d2, mostrando o comportamento de fixação de countwholemonths no início do mês (formato de data YMD):

d1 | d2 | countwholemonthsbackwards(d1,d2) | countwholemonthsbackwards(d2,d1)
2007/07/01 | 2007/06/01 | -1 | 0

Contar o número de comunicações mensais por e-mail que cada cliente recebeu, onde as comunicações são enviadas no dia cinco de cada mês (a última comunicação tendo sido enviada no dia 5 de março de 2006) e usando o campo de data StartDate da aquisição do cliente:

-countwholemonths(#2006/03/05, StartDate)

Para contar o número de anúncios mensais que cada cliente recebeu, onde os anúncios são enviados sete dias antes do final de cada mês (o último anúncio tendo sido enviado no dia 24 de março de 2006) e usando o campo de data StartDate da aquisição do cliente:

-countwholemonthsbackwards(#2006/03/24, StartDate)

Consulte também

addmonths, addmonthscountbackwards

Formatos de data

Tópico pai: Funções para trabalhar com datas


countwholeseconds

Objetivo Contar o número de segundos entre duas datas.

Sintaxe countwholeseconds(time1, time2)

Argumentos

Tipo | Nome | Descrição
data | time1 | a primeira data/hora
data | time2 | a segunda data/hora

Resultado

Tipo | Descrição
inteiro | O número de segundos decorridos entre time1 e time2 (um número negativo se time1 for posterior a time2)
Nota:

A única diferença entre essa função e a countseconds é que o resultado da última é do tipo real.

Exemplos Formato de data european: countwholeseconds(#09/01/2004:12:28:53, #09/01/2004:12:29:18) é igual a 25.

Formato de data american: countwholeseconds(#01/09/2004:12:28:53, #01/09/2004:12:29:18) é igual a 25.

Formato de data YMD: countwholeseconds(#2004/01/09:12:28:53, #2004/01/09:12:29:18) é igual a 25.

Consulte também

Formatos de data
Tópico pai: Funções para trabalhar com datas


countwholeweeks

Objetivo Contar o número de semanas completas entre duas datas.

Sintaxe countwholeweeks(date1, date2)

Argumentos

Tipo | Nome | Descrição
data | date1 | a primeira data
data | date2 | a segunda data

Resultado

Tipo | Descrição
inteiro | O número de semanas completas decorridas entre date1 e date2 (um número negativo se date1 for posterior a date2)

Exemplos Formato de data european: countwholeweeks(#09/01/2004, #09/03/2004) é igual a 8.

Formato de data american: countwholeweeks(#01/09/2004, #03/09/2004) é igual a 8.

Formato de data YMD: countwholeweeks(#2004/01/09, #2004/03/09) é igual a 8.

Consulte também

countweeks

Formatos de data

Tópico pai: Funções para trabalhar com datas


countwholeyears, countwholeyearsbackwards

Objetivo Contar o número de anos completos entre duas datas.

Sintaxe countwholeyears(date1, date2)

countwholeyearsbackwards(date1, date2)

Argumentos

Tipo | Nome | Descrição
data | date1 | a primeira data
data | date2 | a segunda data

Resultado

Tipo | Descrição
inteiro | O número de anos completos decorridos entre date1 e date2 (um número negativo se date1 for posterior a date2). Consulte countwholemonths, countwholemonthsbackwards para uma explicação das duas variantes.
Nota:
  • O resultado da função countwholeyears (respectivamente, countwholeyearsbackwards) é definido como o resultado da função countwholemonths (respectivamente, countwholemonthsbackwards) dividido por 12, ignorando qualquer resto da divisão.
  • Os resultados da comparação de duas datas com countwholeyears e countwholeyearsbackwards podem ser diferentes, mas somente quando ambas as datas ocorrem em fevereiro e uma data ocorre em um ano bissexto e a outra não.

Exemplos Para contar o número de anos completos entre d1 e d2, mostrando a diferença entre as variantes countwholeyears e countwholeyearsbackwards (formato de data YMD):

d1 | d2 | countwholeyears(d1,d2) | countwholeyearsbackwards(d1,d2)
2007/02/14 | 2008/02/13 | 0 | 0
2007/02/14 | 2008/02/14 | 1 | 0
2007/02/14 | 2008/02/15 | 1 | 1
Para computar a idade de cada cliente no dia 1º de março de 2007 a partir de um campo de data de nascimento DOB (formato de data YMD):

countwholeyears(DOB, #2007/03/01)

Consulte também

addyears, addyearscountbackwards

countyears

Formatos de data

Tópico pai: Funções para trabalhar com datas


countyears

Objetivo Calcular o período entre duas datas em anos.

Sintaxe countyears(date1, date2)

Argumentos

Tipo | Nome | Descrição
data | date1 | a primeira data
data | date2 | a segunda data

Resultado

Tipo | Descrição
real | O período entre date1 e date2 em anos (um número negativo se date1 for posterior a date2)
Nota:
  • Se o mês, dia ou a hora de duas datas forem diferentes, o resultado inclui uma parte fracional, contando o ano incompleto como uma fração do número de dias (365 ou 366) no ano da última das duas datas.

Exemplos Formato de data european: countyears(#09/01/2004, #09/01/1994) é igual a -10.

Formato de data american: countyears(#01/09/2004, #01/09/1994) é igual a -10.

Formato de data YMD: countyears(#2004/01/09, #1994/01/09) é igual a -10.

Consulte também

countwholeyears, countwholeyearsbackwards

Formatos de data

Tópico pai: Funções para trabalhar com datas


day

Objetivo Obter o dia do mês de uma data.

Sintaxe day(date)

Argumentos

Tipo | Nome | Descrição
data | date | Uma data

Resultado

Tipo | Descrição
inteiro | A parte do dia do mês de date

Exemplos Formato de data european: day(#09/01/2004) é igual a 9.

Formato de data american: day(#01/09/2004) é igual a 9.

Formato de data YMD: day(#2004/01/09) é igual a 9.

Consulte também

Formatos de data

Dividir agregações: a cláusula by

Tópico pai: Funções para trabalhar com datas


dayofweek

Objetivo Obter um número representante do dia da semana de uma data.

Sintaxe dayofweek(date)

Argumentos

Tipo | Nome | Descrição
data | date | Uma data

Resultado

Tipo | Descrição
inteiro | O dia da semana de date (um número entre 0 e 6, com 0 representando o domingo)

Exemplos Formato de data european: dayofweek(#09/01/2004) é igual a 5 (ou seja, sexta-feira).

Formato de data american: dayofweek(#01/09/2004) é igual a 5 (ou seja, sexta-feira).

Formato de data YMD: dayofweek(#2004/01/09) é igual a 5 (ou seja, sexta-feira).

Consulte também

Formatos de data

Dividir agregações: a cláusula by

Tópico pai: Funções para trabalhar com datas


gmt2edt

Objetivo Converter uma data na Hora de Greenwhich (GMT) para o Horário de Verão do Leste dos EUA (EDT).

Sintaxe gmt2edt(datetimeGMT)

Argumentos

Tipo | Nome | Descrição
data | datetimeGMT | A data GMT para converter

Resultado

Tipo | Descrição
data | A data EDT, calculada para o horário de verão

Exemplos Inverno: GMT2EDT(#09/01/2004:12:28:53) é igual a 09/01/2004:07:28:53.

Verão: GMT2EDT(#09/07/2004:12:28:53) é igual a 09/07/2004:08:28:53.

Tópico pai: Funções para trabalhar com datas


hour

Objetivo Obter as horas de uma data.

Sintaxe hour(time)

Argumentos

Tipo | Nome | Descrição
data | time | Uma data/hora

Resultado

Tipo | Descrição
inteiro | A parte das horas de time

Exemplos Formato de data european: hour(#09/01/2004:12:28:53) é igual a 12.

Formato de data american: hour(#01/09/2004:12:28:53) é igual a 12.

Formato de data YMD: hour(#2004/01/09:12:28:53) é igual a 12.

Consulte também

Formatos de data

Dividir agregações: a cláusula by

Tópico pai: Funções para trabalhar com datas


minute

Objetivo Obter os minutos de uma data.

Sintaxe minute(time)

Argumentos

Tipo | Nome | Descrição
data | time | Uma data/hora
Resultado
Tipo | Descrição
inteiro | Os minutos de time

Exemplos Formato de data european: hour(#09/01/2004:12:28:53) é igual a 28.

Formato de data american: hour(#01/09/2004:12:28:53) é igual a 28.

Formato de data YMD: hour(#2004/01/09:12:28:53) é igual a 28.

Consulte também

Formatos de data

Dividir agregações: a cláusula by

Tópico pai: Funções para trabalhar com datas


month

Objetivo Obter o mês de uma data.

Sintaxe month(date)

Argumentos

Tipo | Nome | Descrição
data | date | Uma data
Resultado
Tipo | Descrição
inteiro | A parte do mês de date

Exemplos Formato de data european: month(#09/01/2004) é igual a 1.

Formato de data american: month(#01/09/2004) é igual a 1.

Formato de data YMD: month(#2004/01/09) é igual a 1.

Consulte também

Formatos de data

Dividir agregações: a cláusula by

Tópico pai: Funções para trabalhar com datas


now

Objetivo Obter a data e hora atual.

Sintaxe now()

Argumentos Nenhum

Resultado

Tipo | Descrição
data | A data atual (incluindo hora), obtida a partir do relógio do sistema
Exemplos Formato de data european: now() é igual a 09/01/2004:12:28:53.

Formato de data american: now() é igual a 01/09/2004:12:28:53.

Formato de data YMD: now() é igual a 2004/01/09:12:28:53.

Consulte também

Formatos de data

today

Tópico pai: Funções para trabalhar com datas


second

Objetivo Obter os segundos de uma data.

Sintaxe second(time)

Argumentos

Tipo | Nome | Descrição
data | time | Uma data/hora
Resultado
Tipo | Descrição
inteiro | A parte dos segundos de time

Exemplos Formato de data european: second(#09/01/2004:12:28:53) é igual a 53.

Formato de data american: second(#01/09/2004:12:28:53) é igual a 53.

Formato de data YMD: second(#2004/01/09:12:28:53) é igual a 53.

Consulte também

Formatos de data

Dividir agregações: a cláusula by

Tópico pai: Funções para trabalhar com datas


today

Objetivo Obter a data atual.

Sintaxe today()

Argumentos Nenhum

Resultado

Tipo | Descrição
data | A data atual obtida a partir do relógio do sistema, com a parte da hora configurada para 00:00:00
Exemplos Formato de data european: today() é igual a 09/01/2004:00:00:00.

Formato de data american: today() é igual a 01/09/2004:00:00:00.

Formato de data YMD: today() é igual a 2004/01/09:00:00:00.

Consulte também

Formatos de data

now

Tópico pai: Funções para trabalhar com datas


weekofyear

Objetivo Calcular a semana do ano de uma data, relativamente a uma data inicial especificada.

Sintaxe weekofyear(date, yearStart)

Argumentos

Tipo | Nome | Descrição
data | date | A data cuja semana do ano deve ser obtida
data | yearStart | A data inicial (por exemplo, de um ano fiscal)
Resultado
Tipo | Descrição
inteiro | A semana do ano de date, relativamente a yearStart
Nota:

Somente são usadas as partes do mês e do dia da data inicial.

Exemplos Formato de data european: weekofyear(#09/07/2004, #01/04/2004) é igual a 14.

Formato de data american: weekofyear(#07/09/2004, #04/01/2004) é igual a 14.

Formato de data YMD: weekofyear(#2004/07/09, #2004/04/01) é igual a 14.

Consulte também

Formatos de data

Dividir agregações: a cláusula by

Tópico pai: Funções para trabalhar com datas


year

Objetivo Obter a parte do ano de uma data.

Sintaxe year(date)

Argumentos

Tipo | Nome | Descrição
data | data | Uma data

Resultado

Tipo | Descrição
inteiro | A parte do ano de date

Exemplos Formato de data european: year(#09/01/2004) é igual a 2004.

Formato de data american: year(#01/09/2004) é igual a 2004.

Formato de data YMD: year(#2004/01/09) é igual a 2004.

Consulte também

Formatos de data
Tópico pai: Funções para trabalhar com datas


Funções matemáticas e estatísticas

  • abs
  • ceil
  • cos
  • exp
  • floor
  • log
  • log10
  • logbase
  • normalizar
  • pow
  • round
  • sgn
  • sin
  • sqrt
  • tan
Tópico pai: Funções FDL


abs

Objetivo Calcular o valor absoluto de um número.

Sintaxe abs(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | Um número com sinal

Resultado

Tipo | Descrição
como entrada | , o valor absoluto, ou magnitude, de x

Exemplos abs(10000) é igual a 10000.

abs(-25000) é igual a 25000.

Para calcular o erro absoluto entre um valor previsto e um valor histórico: abs(Value - PredictedValue)

Consulte também

sgn
Tópico pai: Funções matemáticas e estatísticas


ceil

Objetivo Arredondar um número para cima, para o número inteiro mais próximo.

Sintaxe ceil(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | O número a ser arredondado
Resultado
Tipo | Descrição
inteiro | , o valor inteiro para que

Exemplos ceil(1,25) é igual a 2.

ceil(-1,25) é igual a -1.

Para gerar um número inteiro aleatório entre 1 e 10, inclusive: ceil(rndUniform()*10)

Consulte também

floor

round

Tópico pai: Funções matemáticas e estatísticas


cos

Objetivo Calcular o cosseno de um ângulo.

Sintaxe cos(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | Um ângulo em radianos
Resultado
Tipo | Descrição
real | cos x, o cosseno de x

Exemplos cos(0) é igual a 1.

Tópico pai: Funções matemáticas e estatísticas


exp

Objetivo Calcular o exponencial de um número.

Sintaxe exp(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | O número cujo exponencial deve ser computado
Resultado
Tipo | Descrição
real | , o exponencial de x

Exemplos exp(0) é igual a 1.

Tópico pai: Funções matemáticas e estatísticas


floor

Objetivo Arredondar um número para baixo, para o número inteiro mais próximo.

Sintaxe floor(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | O número a ser arredondado
Resultado
Tipo | Descrição
inteiro | , o valor inteiro para que

Exemplos floor(1,25) é igual a 1.

floor(-1,25) é igual a -2.

Para gerar um número inteiro aleatório entre 0 e 9, inclusive: floor(rndUniform()*10)

Consulte também

ceil

round

Tópico pai: Funções matemáticas e estatísticas


log

Objetivo Calcular o logaritmo natural (base "e") de um número.

Sintaxe log(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | Um número positivo
Resultado
Tipo | Descrição
real | , o logaritmo natural de x

Exemplos log(1) é igual a 0.

Tópico pai: Funções matemáticas e estatísticas


log10

Objetivo Calcular o logaritmo de base 10 de um número.

Sintaxe log10(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | Um número positivo
Resultado
Tipo | Descrição
real | , o logaritmo de base 10 de x

Exemplos log10(100) é igual a 2.

Tópico pai: Funções matemáticas e estatísticas


logbase

Objetivo Calcular o logaritmo de um número, para uma base especificada.

Sintaxe logbase(x, base)

Argumentos

Tipo | Nome | Descrição
numérico | x | O número positivo cujo logaritmo deve ser computado
numérico | base | A base a ser usada
Resultado
Tipo | Descrição
real | , o logaritmo de base base de x

Exemplos logbase(100,10) é igual a 2.

Tópico pai: Funções matemáticas e estatísticas


normalizar

Objetivo Normalizar valores de campo para ficar no intervalo [0,1].

Sintaxe normalize(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | O número a ser normalizado
Resultado
Tipo | Descrição
real | Valor entre 0 e 1 dado por
Nota:

Só é possível usar essa função em uma derivação do Decision Studio, no arquivo de derivações para qsderive ou na janela Campos Derivados equivalente, no arquivo de rastreamento para o qstrack ou em um arquivo de seleções para o qsselect.

Tópico pai: Funções matemáticas e estatísticas


pow

Objetivo Calcular o resultado de elevar um número à potência de outro.

Sintaxe pow(x, exponent)

Argumentos

Tipo | Nome | Descrição
numérico | x | O número a ser elevado a uma potência
numérico | exponent | O exponente
Resultado
Tipo | Descrição
real | , x elevado à potência exponent

Exemplos pow(10, 2) é igual a 100.

Tópico pai: Funções matemáticas e estatísticas


round

Objetivo Arredondar um número para o número inteiro mais próximo.

Sintaxe round(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | O número a ser arredondado
Resultado
Tipo | Descrição
inteiro | o inteiro mais próximo de x, ou, no caso de o valor se encontrar exatamente no meio, o maior de dois inteiros mais próximos (em valor absoluto)

Exemplos round(1,25) é igual a 1.

round(-1,25) é igual a -1.

round(1,5) é igual a 2.

round(-1,5) é igual a -2.

Consulte também

ceil

floor

Tópico pai: Funções matemáticas e estatísticas


sgn

Objetivo Calcular o signo (sinal) de um número.

Sintaxe sgn(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | Um número com sinal
Resultado
Tipo | Descrição
como entrada | Um número representando o sinal de x:

Exemplos sgn(25) é igual a 1.

sgn(-25) é igual a -1.

Consulte também

abs

Dividir agregações: a cláusula by

Tópico pai: Funções matemáticas e estatísticas


sin

Objetivo Calcular o seno de um ângulo.

Sintaxe sin(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | Um ângulo em radianos
Resultado
Tipo | Descrição
real | sin x, o seno de x

Exemplos sin(3,14159/2) é igual a 1.

Tópico pai: Funções matemáticas e estatísticas


sqrt

Objetivo Calcular a raiz quadrada de um número.

Sintaxe sqrt(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | Um número não negativo
Resultado
Tipo | Descrição
real | , a raiz quadrada de x

Exemplos sqrt(25) é igual a 5.

sqrt(-25) é igual a nulo.

Tópico pai: Funções matemáticas e estatísticas


tan

Objetivo Calcular a tangente de um ângulo.

Sintaxe tan(x)

Argumentos

Tipo | Nome | Descrição
numérico | x | Um ângulo em radianos
Resultado
Tipo | Descrição
real | tan x, a tangente de x
Nota:

Se x for da forma [image] para algum inteiro n, tan x é indefinido. Nesse caso, a função FDL retorna nulo.

Exemplos tan(3,14159/4) é igual a 1.

Tópico pai: Funções matemáticas e estatísticas


Outras funções

  • compartimento
  • dblookup
  • membro
  • rownum
Tópico pai: Funções FDL


compartimento

Objetivo Obtém um índice do bin correspondente a um valor.

Sintaxe bin(binning, x)

Argumentos

Tipo | Nome | Descrição
binning | binning | Um binning nomeado, com valores de parâmetros (é necessário que sejam valores literais) entre parênteses, se necessário
inteiro, real, data ou string | x | Um valor compatível com o binning
Resultado
Tipo | Descrição
inteiro | O índice do bin no qual x está situado
Nota:
  • Os índices de bin são inteiros positivos. Para um binning numérico com n bins nominais (numerados como 2 para n + 1), os últimos bins inferior e superior [consulte Últimos bins] são numerados como 1 e n + 2, respectivamente, enquanto os bins nulos e não classificados são enumerados como n + 3 e n + 4.
  • Essa função não está disponível no Decision Studio. Porém, se x for um campo e b o binning primário associado a x, é possível atingir o mesmo resultado usando segindex:

    segindex() by x

Exemplos Dividir agregações usando o binning de intervalo igual EqualRange no campo Amount, resultando em uma agregação segmentada de oito partes (quatro bins internos com valores entre 20 e 100 mais dois últimos bins, um bin nulo e um bin não classificado):

create totalPointsByAmountBands :=

sum(PointsRedeemed) by bin(EqualRange(20, 100, 4), Amount);

Dividir agregações em oito segmentos de acordo com o binning de campanha PrePost, a começar em [image] maio de 1999 e com agregados do mês anterior e posterior à campanha:

create totalSpendPrePostMayCampaign_ := sum(Amount) by

bin(PrePost(todate(19990401), todate(19990501),

todate(19990601)), PurchaseDate);

Consulte também

Boolean

DayFrom, WeekFrom, MonthFrom, YearFrom

DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom

DayMultipleNumBins, WeekMultipleNumBins, MonthMultipleNumBins, YearMultipleNumBins

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo

DayMultipleWidth, WeekMultipleWidth, MonthMultipleWidth, YearMultipleWidth

DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

DayRange, WeekRange, MonthRange, YearRange

DayTo, WeekTo, MonthTo, YearTo

EqualRange

EqualRangeWidth

NegativeNonNegative

PreDuringPost

PrePost

Sign

Dividir agregações: a cláusula by

Tópico pai: Outras funções


dblookup

Objetivo Pesquisar valores em uma tabela de referência (armazenada como um focus).

Sintaxe dblookup(d, k, f, x)

Argumentos

Tipo | Nome | Descrição
string | d | O nome do caminho da tabela de pesquisa
string | k | O nome do campo-chave na tabela de pesquisa
string | f | O nome de um outro campo na tabela de pesquisa
como campo k | x | O valor de pesquisa

Resultado

Tipo | Descrição
como campo f | O valor y no campo f da tabela d, para o registro indexado pelo valor x que ocorre no campo-chave k

Nota:
  • Essa função deve ser usada somente para tabelas de pesquisa pequenas. Se a tabela de pesquisa for comparável em tamanho a uma tabela de cliente ou de transação, deve ser considerado efetuar uma junção.
  • Se o valor de pesquisa não ocorrer no campo-chave, é retornado o valor nulo.
  • Se o valor de pesquisa ocorrer mais de uma vez no campo-chave, é usado o primeiro valor.
  • O espaço em branco à direita é excluído do valor de pesquisa, mas não dos valores do campo-chave na tabela de pesquisa. Isso pode provocar um comportamento inesperado se o campo-chave na tabela de pesquisa apresentar valores com espaço em branco à direita.
  • Para compatibilidade com versões anteriores, é possível prefixar o nome do caminho da tabela de pesquisa com o string focus:.

Exemplo Em um focus, a loja na qual um cliente compra com mais frequência é registrada no campoPopularShop. Um outro focus stores.ftr contém uma tabela que descreve as instalações em cada loja: Nesse focus, StoreCode é o campo-chave, e o campo HasFuel indica se cada loja tem um posto de gasolina. A loja 105 tem um posto de gasolina, as lojas 299 e 204 não, e assim por diante; a loja 189 não está na tabela de pesquisa. Para derivar um campo que indique se a loja favorita de um cliente tem um posto de gasolina:

PopularShop | dblookup("focus:stores.ftr", "StoreCode", "HasFuel", PopularShop)
105 | 1
299 | 0
204 | 0
189 | null

Consulte também

Sobre combinar focus
Tópico pai: Outras funções


membro

Objetivo Determinar o conjunto de associação.

Sintaxe

member(x, [image], [image], ...)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | x | O valor a ser testado
como x | , [image] , ... | Os elementos do conjunto

Resultado

Tipo | Descrição
inteiro | 1 ("true") se x estiver no conjunto [image] ; 0 ("false") caso contrário
Nota:
  • Só é possível usar valores literais (números, strings ou datas) na lista de elementos do conjunto.
  • Normalmente, é mais eficiente usar a função member que uma disjunção de testes de igualdade. Por exemplo, a expressão strmember(F, "a", "b", "c") é mais rápida para avaliar que F = "a" or F = "b" or F = "c".
  • Para compatibilidade com versões anteriores, é possível usar a função strmember em vez da member quando os argumentos são strings.
  • Os espaços em branco à direita em valores de string não são ignorados.

Exemplos Usar os dois primeiros caracteres de um campo StateCode para identificar os clientes da Costa Oeste:

StateCode | member (substr (StateCode, 0, 1), "CA", "OR", WA")
OR009 | 1
CA043 | 1
UT005 | 0
WA027 | 1

Para marcar clientes cujo número de telefone de 10 dígitos apresente códigos de área de Edimburgo (131) ou Glasgow (141) (determinando os primeiros três dígitos por meio do operador div [consulte Operadores aritméticos]):

TelNo | if member (TelNo div 10000000, 131, 141) then "Edin/Glas" else null
1312204491 | Edin/Glas
1753833999 | null
1611234567 | null
1417654321 | Edin/Glas

Consulte também

Dividir agregações: a cláusula by
Tópico pai: Outras funções


rownum

Objetivo Gerar o número de cada linha na tabela.

Sintaxe rownum()

Argumentos Nenhum

Resultado

Tipo | Descrição
inteiro | Um número de índice de 1 até o número de registros na tabela
Nota:

É possível usar essa função somente em uma derivação do Decision Studio, no arquivo de derivações para o qsderive ou na janela Campos Derivados equivalente, no arquivo de rastreamento para o qstrack ou em um arquivo de seleções para o qsselect.

Exemplos Adicionar uma coluna de índice a um conjunto de dados de N-registros, com valores [image]:

ID | rownum()
AZ195 | 1
DI539 | 2
JD974 | 3
BY643 | 4
Tópico pai: Outras funções


Funções de retorno de investimento

  • ActionROI
  • ActionROIAnnualized
  • OfferROI
  • OfferROIAnnualized
  • RetentionActionROI
  • RetentionActionROIAnnualized
  • RetentionOfferROI
  • RetentionOfferROIAnnualized
Tópico pai: Funções FDL


ActionROI

Objetivo Estimar a contribuição ao retorno de investimento (dinheiro) por cliente por efetuar ações projetadas para gerar uma resposta definitiva. A ação ocorre, independente de o cliente responder ou não. Por isso, existe somente o custo da ação, não o de execução.

Sintaxe ActionROI(ResponseProbability, ValueOfResponse, CostOfAction)

Argumentos

Tipo | Nome | Descrição
numérico | ResponseProbability | A probabilidade estimada de que o cliente responderá à ação, exibindo algum comportamento de resposta.
numérico | ValueOfResponse | O valor estimado da resposta do cliente à ação de marketing (se ocorrer)
numérico | CostOfAction | O custo estimado da ação (independente de o cliente responder)
Resultado
Tipo | Descrição
numérico | A contribuição ao retorno de investimento (dinheiro) estimada por cliente por efetuar as ações
Nota:
  • A probabilidade de resposta deve ser uma "elevação", ou seja, a probabilidade de os clientes terem aquele comportamento quando eles, pelo contrário, não o teriam. Se houver qualquer possibilidade de o cliente ter o comportamento desejado sem que a ação seja efetuada, isso deve ser modelado usando um modelo de elevação ou, se isso não funcionar, subtraindo a probabilidade de resposta devido à probabilidade do comportamento sem a ação.
  • O valor de resposta deve ser a receita líquida ignorando o custo da ação de marketing.

Consulte também

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Tópico pai: Funções de retorno de investimento


ActionROIAnnualized

Objetivo Estimar o múltiplo do retorno de investimento anual por cliente por efetuar ações projetadas para gerar uma resposta definitiva de um cliente. A ação ocorre, independente de o cliente responder ou não. Por isso, existe somente o custo da ação, não o de execução.

Sintaxe ActionROIAnnualized(ResponseProbability, ValueOfResponse, CostOfAction, DaysToROI)

Argumentos

Tipo | Nome | Descrição
numérico | ResponseProbability | A probabilidade estimada de que o cliente responderá à ação, exibindo algum comportamento de resposta.
numérico | ValueOfResponse | O valor estimado da resposta do cliente à ação de marketing (se ocorrer)
numérico | CostOfAction | O custo estimado da ação (independente de o cliente responder)
numérico | DaysToROI | O número de dias que se espera ser necessário para alcançar o retorno de investimento fornecido
Resultado
Tipo | Descrição
numérico | O múltiplo do retorno de investimento anual estimado por cliente por efetuar as ações
Nota:
  • A probabilidade de resposta deve ser uma "elevação", ou seja, a probabilidade de os clientes terem aquele comportamento quando eles, pelo contrário, não o teriam. Se houver qualquer possibilidade de o cliente ter o comportamento desejado sem que a ação seja efetuada, isso deve ser modelado usando um modelo de elevação ou, se isso não funcionar, subtraindo a probabilidade de resposta devido à probabilidade do comportamento sem a ação.
  • O valor de resposta deve ser a receita líquida ignorando o custo da ação de marketing.

Consulte também

ActionROI

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Tópico pai: Funções de retorno de investimento


OfferROI

Objetivo Estimar a contribuição ao retorno de investimento por cliente por fazer uma oferta projetada para gerar uma resposta definitiva.

Sintaxe OfferROI(ResponseProbability, ValueOfResponse, CostOfOffer, CostOfFulfilment)

Argumentos

Tipo | Nome | Descrição
numérico | ResponseProbability | A probabilidade estimada de que o cliente responderá à ação, exibindo algum comportamento de resposta.
numérico | ValueOfResponse | O valor estimado da resposta do cliente à ação de marketing (se ocorrer)
numérico | CostOfOffer | O custo estimado da ação (independente de o cliente responder)
numérico | CostOfFulfilment | O custo estimado de uma concretização de uma resposta positiva (zero, se não existirem custos (adicionais) de execução)
Resultado
Tipo | Descrição
numérico | O retorno de investimento estimado por cliente por fazer uma proposta
Nota:
  • A probabilidade de resposta deve ser uma "elevação", ou seja, a probabilidade de os clientes terem aquele comportamento quando eles, pelo contrário, não o teriam. Se houver qualquer possibilidade de o cliente ter o comportamento desejado sem que a ação seja efetuada, isso deve ser modelado usando um modelo de elevação ou, se isso não funcionar, subtraindo a probabilidade de resposta devido à probabilidade do comportamento sem a ação.
  • O valor de resposta deve ser uma receita líquida, ignorando o custo da ação de marketing e o custo de execução da resposta do cliente.

Consulte também

ActionROI

ActionROIAnnualized

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Tópico pai: Funções de retorno de investimento


OfferROIAnnualized

Objetivo Estimar o múltiplo do retorno de investimento anual por cliente por efetuar uma oferta projetada para gerar uma resposta definitiva de um cliente.

Sintaxe OfferROIAnnualized(ResponseProbability, ValueOfResponse, CostOfOffer, CostOfFulfilment, DaysToROI)

Argumentos

Tipo | Nome | Descrição
numérico | ResponseProbability | A probabilidade estimada de que o cliente responderá à ação, exibindo algum comportamento de resposta.
numérico | ValueOfResponse | O valor estimado da resposta do cliente à ação de marketing (se ocorrer)
numérico | CostOfOffer | O custo estimado da ação (independente de o cliente responder)
numérico | CostOfFulfilment | O custo estimado de uma concretização de uma resposta positiva (zero, se não existirem custos (adicionais) de execução)
numérico | DaysToROI | O número de dias que se espera ser necessário para alcançar o retorno de investimento fornecido
Resultado
Tipo | Descrição
numérico | O múltiplo do retorno de investimento anual estimado por cliente por fazer uma oferta
Nota:
  • A probabilidade de resposta deve ser uma "elevação", ou seja, a probabilidade de os clientes terem aquele comportamento quando eles, pelo contrário, não o teriam. Se houver qualquer possibilidade de o cliente ter o comportamento desejado sem que a ação seja efetuada, isso deve ser modelado usando um modelo de elevação ou, se isso não funcionar, subtraindo a probabilidade de resposta devido à probabilidade do comportamento sem a ação.
  • O valor de resposta deve ser uma receita líquida, ignorando o custo da ação de marketing e o custo de execução da resposta do cliente.

Consulte também

ActionROI

ActionROIAnnualized

OfferROI

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Tópico pai: Funções de retorno de investimento


RetentionActionROI

Objetivo Estimar a contribuição ao retorno de investimento (dinheiro) por cliente por efetuar ações projetadas para evitar desgastes. Presume-se que a ação apresente um custo fixo, independentemente de o cliente ser salvo ou não, e de o cliente "aceitar" ou não a oferta.

Sintaxe RetentionActionROI(SaveProbability, NetRevenueAtRisk, CostOfAction)

Argumentos

Tipo | Nome | Descrição
numérico | SaveProbability | A probabilidade estimada de que o cliente será "salvo" (durante o período em análise) como resultado da ação efetuada
numérico | NetRevenueAtRisk | A receita líquida estimada que será perdida se o cliente for submetido a desgaste durante o período em análise
numérico | CostOfAction | O custo estimado da ação (independente de o cliente responder)
Resultado
Tipo | Descrição
numérico | A contribuição ao retorno de investimento (dinheiro) anual estimada por cliente por efetuar ações projetadas para evitar desgastes
Nota:
  • Dizer que um cliente está "salvo" significa que "foi influenciado a não sair quando o cliente, pelo contrário, o teria feito". Esse valor é o negativo da elevação na taxa de desgaste produzido por um modelo de elevação. Se preferir, pode ser calculado como P (desgaste|nenhuma ação) - P (desgaste|ação).
  • A receita líquida em risco deve ser uma receita líquida que ignore o custo da ação projetada para evitar desgastes.

Consulte também

ActionROI

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Tópico pai: Funções de retorno de investimento


RetentionActionROIAnnualized

Objetivo Estimar a contribuição do retorno de investimento anual por cliente por efetuar ações projetadas para evitar desgastes. Presume-se que a ação apresente um custo fixo, independentemente de o cliente ser salvo ou não, e de o cliente "aceitar" ou não a oferta.

Sintaxe RetentionActionROIAnnualized(SaveProbability, NetRevenueAtRisk, CostOfAction, DaysToROI)

Argumentos

Tipo | Nome | Descrição
numérico | SaveProbability | A probabilidade estimada de que o cliente será "salvo" (durante o período em análise) como resultado da ação efetuada
numérico | NetRevenueAtRisk | A receita líquida estimada que será perdida se o cliente for submetido a desgaste durante o período em análise
numérico | CostOfAction | O custo estimado da ação (independente de o cliente responder)
numérico | DaysToROI | O número de dias que se espera ser necessário para alcançar o retorno de investimento fornecido
Resultado
Tipo | Descrição
numérico | A contribuição ao retorno de investimento anual estimada por cliente por efetuar ações projetadas para evitar desgastes
Nota:
  • Dizer que um cliente está "salvo" significa que "foi influenciado a não sair quando o cliente, pelo contrário, o teria feito". Esse valor é o negativo da elevação na taxa de desgaste produzido por um modelo de elevação. Se preferir, pode ser calculado como P (desgaste|nenhuma ação) - P (desgaste|ação).
  • A receita líquida em risco deve ser uma receita líquida que ignore o custo da ação projetada para evitar desgastes.

Consulte também

ActionROI

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionOfferROI

RetentionOfferROIAnnualized

Tópico pai: Funções de retorno de investimento


RetentionOfferROI

Objetivo Estimar o retorno de investimento por cliente por fazer uma oferta projetada para evitar desgastes. Uma oferta, diferente de uma ação, apresenta um custo diferente dependendo da aceitação ou não por parte do cliente.

Sintaxe RetentionOfferROI(SaveProbability, ResponseProbability, NetRevenueAtRisk, CostOfOffer, CostOfFulfilment)

Argumentos

Tipo | Nome | Descrição
numérico | SaveProbability | A probabilidade estimada de que o cliente será "salvo" (durante o período em análise) como resultado da ação efetuada
numérico | ResponseProbability | A probabilidade estimada de o cliente responder à oferta
numérico | NetRevenueAtRisk | A receita líquida estimada que será perdida se o cliente for submetido a desgaste durante o período em análise
numérico | CostOfOffer | O custo estimado da oferta (independente de o cliente responder)
numérico | CostOfFulfilment | O custo estimado de concretização de uma resposta positiva à oferta

Resultado

Tipo | Descrição
numérico | O retorno de investimento estimado por cliente de uma oferta projetada para evitar desgastes
Nota:
  • Dizer que um cliente está "salvo" significa que "foi influenciado a não sair quando o cliente, pelo contrário, o teria feito". Esse valor é deduzido da elevação na taxa de desgaste produzida por um modelo de elevação. Se preferir, pode ser calculado como P (desgaste|nenhuma ação) - P (desgaste|ação).
  • A receita líquida em risco deve ser uma receita líquida ignorando o custo da ação projetada para evitar desgastes.

Consulte também

ActionROI

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROIAnnualized

Tópico pai: Funções de retorno de investimento


RetentionOfferROIAnnualized

Objetivo Estimar o retorno de investimento anual por cliente por fazer uma oferta projetada para evitar desgastes. Uma oferta, diferente de uma ação, apresenta um custo diferente dependendo da aceitação ou não por parte do cliente.

Sintaxe RetentionOfferROIAnnualized(SaveProbability, ResponseProbability, NetRevenueAtRisk, CostOfOffer, CostOfFulfilment, DaysToROI)

Argumentos

Tipo | Nome | Descrição
numérico | SaveProbability | A probabilidade estimada de que o cliente será "salvo" (durante o período em análise) como resultado da ação efetuada
numérico | ResponseProbability | A probabilidade estimada de o cliente responder à oferta
numérico | NetRevenueAtRisk | A receita líquida estimada que será perdida se o cliente for submetido a desgaste durante o período em análise
numérico | CostOfOffer | O custo estimado da oferta (independente de o cliente responder)
numérico | CostOfFulfilment | O custo estimado de concretização de uma resposta positiva à oferta
numérico | DaysToROI | O número de dias que se espera ser necessário para alcançar o retorno de investimento fornecido
Resultado
Tipo | Descrição
numérico | O retorno de investimento anual estimado por cliente de uma oferta projetada para evitar desgastes
Nota:
  • Dizer que um cliente está "salvo" significa que "foi influenciado a não sair quando o cliente, pelo contrário, o teria feito". Esse valor é deduzido da elevação na taxa de desgaste produzida por um modelo de elevação. Se preferir, pode ser calculado como P (desgaste|nenhuma ação) - P (desgaste|ação).
  • A receita líquida em risco deve ser uma receita líquida ignorando o custo da ação projetada para evitar desgastes.

Consulte também

ActionROI

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

Tópico pai: Funções de retorno de investimento


Funções de número aleatório

  • Sobre funções de números aleatórios em FDL
  • rndBinomial
  • rndBool
  • rndExp
  • rndGamma
  • rndNormal
  • rndPoisson
  • rndUniform
Tópico pai: Funções FDL


Sobre funções de números aleatórios em FDL

Ao avaliar uma expressão FDL que envolva uma função de número aleatório (numericTestTrainSplit, numericTestTrainValidateSplit, rndBinomial, rndBool, rndExp, rndGamma, rndNormal, rndPoisson, ou rndUniform sampleEqualSize, sampleExactNumber, sampleExactPercentage, sampleStratified, testTrainSplit, e testTrainValidateSplit), o Portrait Miner exige uma "semente" integer para inicializar sua sequência de números aleatórios. Com a mesma semente, a mesma expressão sempre produzirá a mesma sequência de resultados.
Nota:
  • A semente é armazenada como parte do campo informação.
  • A geração de números (pseudo) aleatórios é baseada na geração de Marsaglia, Zaman e Tsang (1990).
Tópico pai: Funções de número aleatório


rndBinomial

Objetivo Gerar um inteiro aleatório com base em uma distribuição binomial.

Sintaxe rndBinomial(N, p)

Argumentos

Tipo | Nome | Descrição
inteiro | N | O número (positivo) de avaliações
numérico | p | A probabilidade de sucesso para cada avaliação (entre 0 e 1)

Resultado

Tipo | Descrição
inteiro | Um inteiro não negativo aleatório, amostrado da distribuição binomial, com probabilidade dada por
Nota:

A expectativa e a variação da distribuição binomial são [image] e [image] respectivamente.

Exemplos rndBinomial (50; 0,05)

Consulte também

Sobre funções de números aleatórios em FDL
Tópico pai: Funções de número aleatório


rndBool

Objetivo Gerar 0 ou 1 aleatoriamente (com igual probabilidade).

Sintaxe rndBool()

Argumentos Nenhum

Resultado

Tipo | Descrição
inteiro | 0 ou 1, com probabilidades

Exemplos Derivar um campo que aloca o valor 0 para aproximadamente 50% dos registros (selecionados aleatoriamente) e o valor 1 para os demais: rndBool()

Consulte também

Sobre funções de números aleatórios em FDL
Tópico pai: Funções de número aleatório


rndExp

Objetivo Gerar um número positivo aleatório baseado em uma distribuição exponencial.

Sintaxe rndExp(b)

Argumentos

Tipo | Nome | Descrição
numérico | b | O parâmetro de escala (positivo)

Resultado

Tipo | Descrição
real | Um número aleatório positivo, amostrado da distribuição exponencial, com função de densidade de probabilidade dada por [image] (x > 0)
Nota:

A expectativa e a variação da distribuição exponencial são [image] e [image] respetivamente.

Exemplos rndExp(10)

Consulte também

Sobre funções de números aleatórios em FDL
Tópico pai: Funções de número aleatório


rndGamma

Objetivo Gerar um número positivo aleatório baseado em uma distribuição gama.

Sintaxe rndGamma(a, b)

Argumentos

Tipo | Nome | Descrição
inteiro | a | O número (positivo) de eventos independentes
numérico | b | A taxa (positiva) de eventos

Resultado

Tipo | Descrição
real | Um número aleatório positivo, amostrado da distribuição gama [image] , com função de densidade de probabilidade dada por
Nota:

A expectativa e a variação da distribuição gama são [image] e [image] respetivamente.

Exemplos rndGamma (50; 0,05)

Consulte também

Sobre funções de números aleatórios em FDL
Tópico pai: Funções de número aleatório


rndNormal

Objetivo Gerar um número aleatório baseado em uma distribuição normal.

Sintaxe

rndNormal( [image], ef="../../../images/img344.gif"/>h>

Argumentos

Tipo | Nome | Descrição
numérico |  | A média da distribuição
numérico |  | O desvio padrão da distribuição

Resultado

Tipo | Descrição
real | Um número aleatório positivo, amostrado da distribuição normal [image] , com função de densidade de probabilidade dada por
Nota:

A expectativa e a variação da distribuição normal são [image] e [image] respetivamente.

Exemplos Derivar uma distribuição gaussiana, com média zero e desvio padrão da unidade: rndNormal(0,1)

Consulte também

Sobre funções de números aleatórios em FDL
Tópico pai: Funções de número aleatório


rndPoisson

Objetivo Gerar um inteiro não negativo aleatório, baseado em uma distribuição poissoniana discreta.

Sintaxe rndPoisson(mean)

Argumentos

Tipo | Nome | Descrição
numérico |  | A média (positiva) da distribuição

Resultado

Tipo | Descrição
inteiro | Um inteiro não negativo aleatório, amostrado da distribuição poissoniana discreta, com probabilidade dada por [image] ( [image] )
Nota:

A expectativa e a variação da distribuição poissoniana discreta são iguais à média, [image].

Exemplos rndPoisson(10)

Consulte também

Sobre funções de números aleatórios em FDL
Tópico pai: Funções de número aleatório


rndUniform

Objetivo Gerar um número aleatório entre 0 e 1 baseado em uma distribuição uniforme.

Sintaxe rndUniform()

Argumentos Nenhum

Resultado

Tipo | Descrição
real | Um número aleatório, amostrado a partir de uma distribuição uniforme superior a [0, 1)

Exemplos Para gerar um número real aleatório no intervalo [0,10): rndUniform() * 10

Consulte também

Sobre funções de números aleatórios em FDL
Tópico pai: Funções de número aleatório


Funções de classificação

  • rankOrder, rankOrderApprox
  • rankOrderMean, rankOrderApproxMean
Tópico pai: Funções FDL


rankOrder, rankOrderApprox

Objetivo Identificar a classificação de um valor em uma lista de valores.

Sintaxe

rankOrder(x, [image], [image], ...)

rankOrderApprox(x, [image], [image], ...)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | x | O valor a ser classificado
como x | , [image] , ... | A lista de valores para comparação

Resultado

Tipo | Descrição
inteiro | A posição da primeira ocorrência de x dentro da lista de valores obtidos na classificação [image] , [image] , ... em ordem descendente (do último para o primeiro no caso de datas; ordem alfabética inversa no caso de strings). Se x não aparecer na lista, rankOrder devolve um nulo, enquanto rankOrderApprox devolve a posição de x na lista de valores obtida na classificação de x, [image] , [image] , ... em ordem descendente.
Nota:
  • Quando o valor a ser classificado surge apenas uma vez na lista de valores, rankOrder, rankOrderApprox, rankOrderMean e rankOrderApproxMean produzem o mesmo resultado.
  • Quando o valor a ser classificado aparecer mais de uma vez na lista de valores, rankOrderApprox produzirá o mesmo resultado que rankOrder.
  • Quando o valor a ser classificado não aparecer na lista de valores, rankOrderApprox produzirá o mesmo resultado que rankOrderApproxMean.
  • Para as strings, "ordem alfabética" significa a ordem natural de representação dos caracteres.

Exemplos rankOrder(6,74, 6,74, 1,99, 0,00, 9,27) é igual a 2.

rankOrderApprox(6,74, 1,99, 0,00, 9,27) é igual a 2.

Verificar a classificação do número de chamadas telefônicas do cliente no 4º trimestre do ano:

rankOrder(CallsQ4, CallsQ1, CallsQ2, CallsQ3, CallsQ4)

Verificar a classificação do número de chamadas telefônicas do cliente no mês 5 com os 4 anteriores:

RankOrderApprox(CallsM5, CallsM1, CallsM2, CallsM3, CallsM4)

Consulte também

rankOrderMean, rankOrderApproxMean
Tópico pai: Funções de classificação


rankOrderMean, rankOrderApproxMean

Objetivo Identificar a classificação de um valor em uma lista de valores, ou sua classificação média, se aparecer várias vezes.

Sintaxe

rankOrderMean(x, [image], [image], ...)

rankOrderApproxMean(x, [image], [image], ...)

Argumentos

Tipo | Nome | Descrição
inteiro, real, data ou string | x | O valor a ser classificado
como x | , [image] , ... | A lista de valores para comparação

Resultado

Tipo | Descrição
real | A classificação média de x na lista de valores obtidos na classificação [image] , [image] , ... em ordem descendente (do último para o primeiro no caso de datas; em ordem alfabética inversa no caso de strings). Se x não aparecer na lista, rankOrder devolve um nulo, enquanto rankOrderApprox devolve a posição de x na lista de valores obtida na classificação de x, [image] , [image] , ... em ordem descendente.
Nota:
  • Quando o valor a ser classificado surge apenas uma vez na lista de valores, rankOrder, rankOrderApprox, rankOrderMean e rankOrderApproxMean produzem o mesmo resultado.
  • Quando o valor a ser classificado aparecer mais de uma vez na lista de valores, rankOrderApproxMean produzirá o mesmo resultado que rankOrderMean.
  • Quando o valor a ser classificado não aparecer na lista de valores, rankOrderApproxMean produzirá o mesmo resultado que rankOrderApprox.
  • Para as strings, "ordem alfabética" significa a ordem natural de representação dos caracteres.

Exemplos rankOrderMean(6,74, 6,74, 1,99, 6,74, 9,27) é igual a 2,5.

rankOrderApproxMean(6,74, 1,99, 6,74, 9,27, 6,74) é igual a 2,5.

Consulte também

rankOrder, rankOrderApprox
Tópico pai: Funções de classificação


Funções de amostragem de dados

  • numericTestTrainSplit
  • numericTestTrainValidateSplit
  • sampleEqualSize
  • sampleExactNumber
  • sampleExactPercentage
  • sampleStratified
  • testTrainSplit
  • testTrainValidateSplit
Tópico pai: Funções FDL


numericTestTrainSplit

Objetivo Criar uma segmentação de teste/treinamento para uso na validação de modelo.

Sintaxe numericTestTrainSplit(testFraction)

Argumentos

Tipo | Nome | Descrição
real | testFraction | A fração de dados que serão usados como conjunto de teste.
Resultado
Tipo | Descrição
inteiro | Valores 0 para o conjunto de treinamento ou 1 para o conjunto de teste

Exemplos Para derivar um campo que aloca o valor 0 para aproximadamente 70% dos registros (selecionados aleatoriamente) e o valor 1 para os demais: numericTestTrainSplit(0,3)

Consulte também

numericTestTrainValidateSplit

sampleEqualSize

testTrainSplit

testTrainValidateSplit

Para dividir um focus em subpopulações de amostra

Tópico pai: Funções de amostragem de dados


numericTestTrainValidateSplit

Objetivo Criar uma segmentação de teste/treinamento/validação para uso na validação de modelo.

Sintaxe numericTestTrainValidateSplit(testFraction, validateFraction)

Argumentos

Tipo | Nome | Descrição
real | testFraction | A fração de dados que serão usados como conjunto de teste.
real | validateFraction | A fração de dados que será usada como conjunto retido.
Resultado
Tipo | Descrição
inteiro | Valores 0 para o conjunto de treinamento, 1 para o conjunto de teste ou 2 para o conjunto de validação

Exemplos Para derivar um campo que aloca o valor 0 para aproximadamente 50% dos registros (selecionados aleatoriamente), o valor 1 para aproximadamente 30% dos registros (novamente selecionados aleatoriamente) e o valor 2 para os demais: numericTestTrainValidateSplit(0,3; 0,2)

Consulte também

numericTestTrainSplit

sampleEqualSize

testTrainSplit

testTrainValidateSplit

Para dividir um focus em subpopulações de amostra

Tópico pai: Funções de amostragem de dados


sampleEqualSize

Objetivo Criar um índice de segmentação que atribui aleatoriamente os registros para segmentos aproximadamente de mesmo tamanho.

Sintaxe sampleEqualSize(NumberOfSegments)

Argumentos

Tipo | Nome | Descrição
inteiro | NumberOfSegments | O número de segmentos que serão criados
Resultado
Tipo | Descrição
inteiro | Um número entre 1 e NumberOfSegments (inclusive)

Exemplos Para derivar um campo enumerando cinco populações (aproximadamente) de mesmo tamanho: sampleEqualSize(5)

Consulte também

numericTestTrainSplit

numericTestTrainValidateSplit

testTrainSplit

testTrainValidateSplit

Para dividir um focus em subpopulações de amostra

Tópico pai: Funções de amostragem de dados


sampleExactNumber

Objetivo Criar uma amostra aleatória de um tamanho exato, especificado como um número de registros.

Sintaxe sampleExactNumber(NumberToSelect)

Argumentos

Tipo | Nome | Descrição
inteiro | NumberToSelect | O tamanho da amostra a ser criada, como um número de registros

Resultado

Tipo | Descrição
inteiro | 1 se um registro for selecionado para a amostra; 0 caso contrário
Nota:
  • Os registros que atualmente não estão selecionados no focus são assinalados como valor nulo.
  • É possível usar essa função somente em uma derivação do Decision Studio, no arquivo de derivações para o qsderive ou na janela Derivar Campos equivalente, no arquivo de rastreamento para o qstrack, ou em um arquivo de seleções para o qsselect.

Exemplos Para selecionar 1.250 registros para uma amostra: sampleExactNumber(1250)

Consulte também

sampleExactPercentage

sampleStratified

Para dividir um focus em subpopulações de amostra

Tópico pai: Funções de amostragem de dados


sampleExactPercentage

Objetivo Criar uma amostra aleatória de tamanho exato, especificado como uma porcentagem do tamanho da população atualmente selecionada.

Sintaxe sampleExactPercentage(PercentageToSelect)

Argumentos

Tipo | Nome | Descrição
inteiro | PercentageToSelect | O tamanho da amostra a ser criada, como uma porcentagem do tamanho da população atual

Resultado

Tipo | Descrição
inteiro | 1 se um registro for selecionado para a amostra; 0 caso contrário
Nota:
  • Os registros que atualmente não estão selecionados no focus são assinalados como valor nulo.
  • Se a PercentageToSelect multiplicada pelo tamanho da população não for um número inteiro, o número selecionado será o número inteiro mais próximo para cima ou para baixo da PercentageToSelect, multiplicado pelo tamanho da população, e fornecerá, em média, a porcentagem especificada.
  • É possível usar essa função somente em uma derivação do Decision Studio, no arquivo de derivações para o qsderive ou na janela Derivar Campos equivalente, no arquivo de rastreamento para o qstrack, ou em um arquivo de seleções para o qsselect.

Exemplos Para selecionar 25% da população para uma amostra: sampleExactPercentage(25)

Consulte também

sampleExactNumber

sampleStratified

Para dividir um focus em subpopulações de amostra

Tópico pai: Funções de amostragem de dados


sampleStratified

Objetivo Criar uma amostra aleatória que contenha um número exato de registros de um segmento especificado, juntamente com um número exato de registros da população atualmente selecionada restante.

Sintaxe sampleStratified(NumberFromSegmentToSelect, SegmentTotalSize, NumberOutsideSegmentToSelect, OutsideSegmentTotalSize, InSegmentExpression)

Argumentos

Tipo | Nome | Descrição
inteiro | NumberFromSegmentToSelect | O número de registros na amostra a ser selecionada do segmento especificado
inteiro | SegmentTotalSize | O número total de registros no segmento especificado
inteiro | NumberOutsideSegmentToSelect | O número de registros na amostra a selecionar da restante população
inteiro | OutsideSegmentTotalSize | O número total de registros no restante da população
inteiro | InSegmentExpression | A expressão (booleana) que determina se um registro se encontra ou não no segmento especificado

Resultado

Tipo | Descrição
inteiro | 1 se um registro for selecionado para a amostra; 0 caso contrário
Nota:
  • Os registros que atualmente não estão selecionados no focus são assinalados como valor nulo.
  • É possível usar essa função somente em uma derivação do Decision Studio, no arquivo de derivações para o qsderive ou na janela Derivar Campos equivalente, no arquivo de rastreamento para o qstrack, ou em um arquivo de seleções para o qsselect.

Exemplos Para criar uma amostra contendo 2.500 registros de um total de 25.000 do sexo feminino e 5.000 registros de um total de 75.000 que não são do sexo feminino: sampleStratified(2500, 25000, 5000, 75000, Gender = "F")

Consulte também

sampleExactNumber

sampleExactPercentage

Para dividir um focus em subpopulações de amostra

Tópico pai: Funções de amostragem de dados


testTrainSplit

Objetivo Criar uma segmentação de teste/treinamento para uso na validação de modelo.

Sintaxe testTrainSplit(testFraction)

Argumentos

Tipo | Nome | Descrição
real | testFraction | A fração de dados que serão usados como conjunto de teste.
Resultado
Tipo | Descrição
string | Valores da string TestSet ou TrainingSet

Exemplos Para derivar um campo que aloca o valor "TrainingSet" para aproximadamente 70% dos registros (selecionados aleatoriamente) e o valor "TestSet" para os demais:

testTrainSplit(0,3)

Consulte também

numericTestTrainSplit

numericTestTrainValidateSplit

sampleEqualSize

testTrainValidateSplit

Para dividir um focus em subpopulações de amostra

Tópico pai: Funções de amostragem de dados


testTrainValidateSplit

Objetivo Criar uma segmentação de teste/treinamento/validação para uso na validação de modelo.

Sintaxe testTrainValidateSplit(testFraction, validateFraction)

Argumentos

Tipo | Nome | Descrição
real | testFraction | A fração de dados que serão usados como conjunto de teste.
real | validateFraction | A fração de dados que será usada como conjunto retido.

Resultado

Tipo | Descrição
string | Valores da string TestSet, TrainingSet ou ValidationSet

Exemplos Para derivar um campo que aloca o valor "TrainingSet" para aproximadamente 50% dos registros (selecionados aleatoriamente), o valor "TestSet" para aproximadamente 30% (novamente, selecionados aleatoriamente) e o valor "ValidationSet" para os demais:

testTrainValidateSplit(0,3; 0,2)

Consulte também

numericTestTrainSplit

numericTestTrainValidateSplit

sampleEqualSize

testTrainSplit

Para dividir um focus em subpopulações de amostra

Tópico pai: Funções de amostragem de dados


Funções para trabalhar com strings

  • concat
  • endswith
  • find
  • left
  • match
  • mid
  • replaceall
  • replacefirst
  • right
  • soundex
  • startswith
  • strlen
  • strmember
  • substitute
  • substr
  • tolower
  • toupper
  • trim
Tópico pai: Funções FDL


concat

Objetivo Concatenar duas ou mais strings.

Sintaxe

concat( [image], [image], ...)

Argumentos

Tipo | Nome | Descrição
string | , [image] , ... | Strings para concatenar
Resultado
Tipo | Descrição
string | O string obtido ao escrever os caracteres de [image] , seguido pelos caracteres de [image] , etc.

Exemplos Derivar o nome completo de um cliente a partir de dois campos FirstName e Surname:

FirstName | Surname | concat(FirstName," ",Surname)
John | Brown | John Brown
David | Smith | David Smith

Derivar o nome completo de um cliente, usando somente sua inicial:

FirstName | Surname | concat(substr(FirstName,0,0),". ",Surname)
John | Brown | J. Brown
David | Smith | D. Smith
Tópico pai: Funções para trabalhar com strings


endswith

Objetivo Testar se uma string termina com outra.

Sintaxe endswith(find_text, within_text)

Argumentos

Tipo | Nome | Descrição
string | find_text | A string a ser encontrada no final
string | within_text | A string a ser testada
Resultado
Tipo | Descrição
inteiro | 1 ("true") se find_text for encontrada no final de within_text; 0 ("false") caso contrário
Nota:

A função endswith é baseada na função match. Ela anexa o caractere $ ao find_text antes de tratar o resultado como uma expressão regular [consulte Expressões regulares].

Exemplos Derivar um campo que marca endereços de e-mail de domínios .net:

EmailAddress | endswith(".net", EmailAddress)
J.Brown@glob.net | 1
D.Smith@portraitsoftware.com | 0

Consulte também

find

startswith

Tópico pai: Funções para trabalhar com strings


find

Objetivo Testar se uma string está contida em outra string.

Sintaxe find(find_text, within_text)

Argumentos

Tipo | Nome | Descrição
string | find_text | A string a ser encontrada
string | within_text | A string a ser testada

Resultado

Tipo | Descrição
inteiro | 1 ("true") se find_text for encontrado em within_text; 0 ("false"), caso contrário
Nota:

A função find é baseada na função match e trata find_text como uma expressão regular [consulte Expressões regulares].

Exemplos Marcar endereços de e-mail que incluam o texto "portraitsoftware" em letras maiúsculas, minúsculas ou maiúsculas e minúsculas combinadas:

EmailAddress | find("portraitsoftware", tolower(EmailAddress))
J.BROWN@PORTRAITSOFTWARE.COM | 1
J.Brown@glob.net | 0
D.Smith@portraitsoftware.com | 1

Consulte também

endswith

startswith

Tópico pai: Funções para trabalhar com strings


left

Objetivo Retornar uma substring de comprimento especificado a partir do início de uma string.

Sintaxe left(text, num_chars)

Argumentos

Tipo | Nome | Descrição
string | texto | A string da qual extrair
inteiro | num_chars | O número de caracteres
Resultado
Tipo | Descrição
string | A substring formada por num_chars caracteres no início de text
Nota:

A função left é baseada na função substr.

Exemplos Usar os dois primeiros caracteres de um campo StateCode para identificar os clientes da Costa Oeste:

StateCode | membro (left (StateCode, 2), "CA", "OR", WA")
OR009 | 1
CA043 | 1
UT005 | 0
WA027 | 1

Consulte também

mid

right

trim

Tópico pai: Funções para trabalhar com strings


match

Objetivo Testar uma string para uma coincidência de expressão regular [consulte Expressões regulares].

Sintaxe match(regexp, string)

Argumentos

Tipo | Nome | Descrição
string | regexp | A expressão regular
string | string | A string a ser testada
Resultado
Tipo | Descrição
inteiro | 1 ("true") se regexp coincidir com a string; 0 ("false") caso contrário

Exemplos Para marcar clientes cujo código de endereçamento postal do domicílio e o código de endereçamento da agência bancária coincidem nos primeiros dois caracteres (usando a função substr):

HomePostcode | BranchPostCode | match(substr(HomePostcode, 0, 1), substr(BranchPostcode,0,1))
NE25 0AY | NE30 1QX | 1
SW3 | NG18 1HT | 0
CF36 | CF31 1HY | 1
EH9 0NJ | E10 8AJ | 0

Para buscar em um campo de nome da empresa pelos três primeiros caracteres de um campo de um primeiro nome, seguido de qualquer texto e, em seguida, dos conteúdos do campo de um Surname (ignorando maiúsculas):

FirstName | Surname | CompanyName | rx := concat( substr(toupper(FirstName),0,2), "[[:print:]]*", toupper(Surname); match(rx,toupper(CompanyName))
Patrick | Smith | 1234 Pat Smith Ltd | 1
Patrick | Smith | 1234 Pat J Smith Ltd | 1

Para fazer o mesmo, mas somente com algumas letras ou dígitos e apenas um espaço entre o primeiro nome e o Surname:

FirstName | Surname | CompanyName | rx := concat( substr(toupper(FirstName),0,2), "[[:alnum:]]* ", toupper(Surname); match(rx,toupper(CompanyName))
Patrick | Smith | 1234 Pat Smith Ltd | 1
Patrick | Smith | 1234 Pat J Smith Ltd | 0

Consulte também

replaceall

replacefirst

Dividir agregações: a cláusula by

Tópico pai: Funções para trabalhar com strings


mid

Objetivo Retornar uma substring de comprimento especificado do meio de uma string.

Sintaxe mid(text, start_num, num_chars)

Argumentos

Tipo | Nome | Descrição
string | texto | A string da qual extrair
string | start_num | O primeiro índice
string | num_chars | O número de caracteres
Resultado
Tipo | Descrição
string | A substring formada por num_chars caracteres a partir da posição de caractere start_num (inclusive) do text, na qual as posições dos caracteres são numeradas a partir de 1
Nota:

A função mid é baseada na função substr.

Exemplos Derivar uma localização de cinco a sete caracteres a partir de um código de armazenamento:

StoreCode | mid(StoreCode, 5, 3)
0114EDI256 | EDI
1863LON836 | LON
9326EDI039 | EDI
0387BOS041 | BOS

Consulte também

left

right

trim

Tópico pai: Funções para trabalhar com strings


replaceall

Objetivo Substituir todas as substrings que coincidem com uma expressão regular [consulte Expressões regulares].

Sintaxe replaceall(regexp, replacement, string)

Argumentos

Tipo | Nome | Descrição
string | regexp | A expressão regular
string | replacement | A string de substituição
string | string | A string a ser pesquisada
Resultado
Tipo | Descrição
string | Uma cópia da string string com replacement substituindo cada porção sem sobreposição que coincida com regexp
Nota:

A primeira porção de coincidência da string que vai ser pesquisada é a porção maior e que ocorre mais à esquerda que coincide com a expressão regular. A pesquisa seguinte aplica-se ao restante da string que vai ser pesquisada e assim por diante. Por exemplo,

replaceall("i..", "X", "initiation")

produz a string "XtXX" (em vez de, por exemplo, "inXatX"). E

replaceall("i.*i", "X", "initiation")

resulta em "Xon" (em vez de, por exemplo, "XtXon").

Exemplos Para detectar e remover espaços em branco de um campo PostalCode usando uma coincidência de expressão regular:

PostalCode | placeall("[[:blank:]]","",PostalCode))
ND 069 | ND069
IN 099 | IN099
UT 0 0 5 | UT005
O R 009 | OR009

Consulte também

match

replacefirst

Tópico pai: Funções para trabalhar com strings


replacefirst

Objetivo Substituir a primeira substring que coincidir com uma expressão regular [consulte Expressões regulares].

Sintaxe replacefirst(regexp, replacement, string)

Argumentos

Tipo | Nome | Descrição
string | regexp | A expressão regular
string | replacement | A string de substituição
string | string | A string a ser pesquisada
Resultado
Tipo | Descrição
string | Uma cópia da string string com replacement substituindo a primeira porção que coincidir com regexp (se existir alguma)

Exemplos Para extrair o nome de um cliente de um campo de endereço de e-mail no formato "FirstName.Surname@company.com", removendo tudo de "@" em diante e substituindo o "." por um espaço:

E-mail | replacefirst("@.*", "", (replacefirst ("\.", " ", E-mail)))
John.Brown@myco.com | John Brown
Angela.Smith@yourco.com | Angela Smith

Consulte também

match

replaceall

Tópico pai: Funções para trabalhar com strings


right

Objetivo Retornar uma substring de comprimento especificado a partir do final de uma string.

Sintaxe right(text, num_chars)

Argumentos

Tipo | Nome | Descrição
string | texto | A string da qual extrair
inteiro | num_chars | O número de caracteres
Resultado
Tipo | Descrição
string | A substring formada por num_chars caracteres no final de text
Nota:

A função right é baseada na função substr.

Exemplos Para retornar o componente de casa/rua de um campo de código de endereçamento postal do Reino Unido, ou seja, os últimos três caracteres:

Postcode | right(Postcode, 3)
NE25 0AY | 0AY
EH3 7RA | 7RA
SL4 1QX | 1QX
EH9 0NJ | 0NJ

Consulte também

left

mid

trim

Tópico pai: Funções para trabalhar com strings


soundex

Objetivo Reduzir cada palavra a uma string de quatro caracteres para fins de indexação.

Sintaxe soundex(text)

Argumentos

Tipo | Nome | Descrição
string | texto | O texto a reduzir
Resultado
Tipo | Descrição
string | Uma codificação de indexação reduzida a quatro caracteres
Exemplos Para derivar o código soundex para um sobrenome:
Surname | soundex(Surname)
Brown | B650
Smythe | S530
Smith | S530
Bruno | B650
Nota: A função Soundex não está definida para caracteres não ascii.
Tópico pai: Funções para trabalhar com strings


startswith

Objetivo Testar se uma string inicia com outra.

Sintaxe startswith(find_text, within_text)

Argumentos

Tipo | Nome | Descrição
string | find_text | A string a ser buscada
string | within_text | A string a ser testada
Resultado
Tipo | Descrição
inteiro | 1 se find_text for encontrado no início de within_text; 0 caso contrário
Nota:

A função startswith é baseada na função match. Ela inclui um caractere ^ ao find_text antes de tratar o resultado como uma expressão regular [consulte Expressões regulares].

Exemplos Derivar o tipo de cartão de crédito usado em uma transação, como "Discover", "AmEx", "Visa" ou a MasterCard", com base em números de prefixos do cartão:

ocorrência

startswith ("6011", CC_Number): "Discover";

startswith ("4", CC_Number): "Visa";

startswith ("5", CC_Number): "MasterCard";

startswith ("34", CC_Number) or startswith ("37", CC_Number): "AmEx";

default: null;

CC_Number | CC_Type
4111-1111-1111-1111 | Visa
5431-1111-1111-1111 | MasterCard
341-1111-1111-1111 | AmEx
6011-6011-6011-6611 | Discover
Consulte também

endswith

find

Tópico pai: Funções para trabalhar com strings


strlen

ObjetivoObter o comprimento de uma string.

Sintaxe strlen(string)

Argumentos

Tipo | Nome | Descrição
string | string | A string cujo comprimento deve ser determinado
Resultado
Tipo | Descrição
inteiro | O número de caracteres na string

Exemplos Para derivar um campo de string com exatamente quatro caracteres, preenchendo uma string menor com zeros à esquerda:

ocorrência

strlen(AccountID = 1: concat("000", AccountID;

strlen(AccountID = 2: concat("00", AccountID;

strlen(AccountID = 3: concat("0", AccountID;

default: AccountID;

AccountID | Conta
1 | 0001
22 | 0022
333 | 0333
4444 | 4444
Tópico pai: Funções para trabalhar com strings


strmember

Objetivo Determinar o conjunto de associação.

Sintaxe

strmember(x, [image], [image], ...)

Argumentos

Tipo | Nome | Descrição
string | x | O valor a ser testado
como x | , [image] , ... | Os elementos do conjunto

Resultado

Tipo | Descrição
inteiro | 1 ("true") se x estiver no conjunto [image] ; 0 ("false") caso contrário
Nota:
  • Só é possível usar os valores literais da string para a lista de elementos do conjunto.
  • Os espaços em branco à direita não são ignorados.
  • Essa função é preterida em favor da função geral member.

Consulte também

Dividir agregações: a cláusula by
Tópico pai: Funções para trabalhar com strings


substitute

Objetivo Substituir uma string por outra.

Sintaxe substitute(text, old_text, new_text)

Argumentos

Tipo | Nome | Descrição
string | texto | A string a ser pesquisada
string | old_text | A string a ser substituída
string | new_text | A string de substituição

Resultado

Tipo | Descrição
string | Uma cópia da string text com new_text substituindo cada instância sem sobreposição de old_text
Nota:

A função substitute é baseada na função replaceall e trata old_text como uma expressão regular [consulte Expressões regulares].

Exemplos Para remover espaços em branco de um campo chamado PostalCode:

PostalCode | substitute(PostalCode, "[[:blank:]]", "")
ND 069 | ND069
IN 099 | IN099
UT 0 0 5 | UT005
O R 009 | OR009

Consulte também

replacefirst
Tópico pai: Funções para trabalhar com strings


substr

Objetivo Obter uma substring a partir de uma string.

Sintaxe substr(string, start, end)

Argumentos

Tipo | Nome | Descrição
string | string | A string inicial
inteiro | iniciar | O primeiro índice
inteiro | end | O segundo índice

Resultado

Tipo | Descrição
string | A substring formada por caracteres start até end (inclusive) da string, na qual os caracteres são numerados a partir de 0. Os valores de índice positivos contam a partir do início da string, e os valores de índice negativos contam a partir do final da string.

Exemplos Para selecionar os primeiros dois e os últimos três caracteres de um campo PostalCode para oferecer o código do estado:

PostalCode | substr(PostalCode, 0, 1) | substr(PostalCode, -3, -1)
MA015 | MA | 015
WA055 | WA | 055
UT005 | UT | 005
MN119 | MN | 119

Para derivar o tipo de cartão de crédito usado em uma transação, como "Discover", "AmEx", "Visa" ou MasterCard", com base nos números de prefixo do cartão:

ocorrência

substr(CC_Number, 0, 3) = "6011": "Discover";

substr(CC_Number, 0, 0) = "4": "Visa";

substr(CC_Number, 0, 0) = "5": "MasterCard";

substr(CC_Number, 0, 1) = "34" or substr(CC_Number, 0, 1) = "37": "AmEx";

default: null;

CC_Number | CC_Type
4111-1111-1111-1111 | Visa
5431-1111-1111-1111 | MasterCard
341-1111-1111-1111 | AmEx
6011-6011-6011-6611 | Discover
Tópico pai: Funções para trabalhar com strings


tolower

Objetivo Converter uma string para texto em letra minúscula.

Sintaxe tolower(string)

Argumentos

Tipo | Nome | Descrição
string | string | Uma string a ser convertida

Resultado

Tipo | Descrição
string | A string obtida a partir de string substituindo todas as letras maiúsculas na string pela letra minúscula correspondente

Exemplos tolower("ZYXWV") é igual a "zyxwv"

Consulte também

toupper
Tópico pai: Funções para trabalhar com strings


toupper

Objetivo Converter uma string para texto em letra maiúscula.

Sintaxe toupper(string)

Argumentos

Tipo | Nome | Descrição
string | string | Uma string a ser convertida

Resultado

Tipo | Descrição
string | A string obtida a partir da string substituindo todas as letras minúsculas na string pela letra maiúscula correspondente

Exemplos toupper("abcde") é igual a "ABCDE"

Consulte também

tolower
Tópico pai: Funções para trabalhar com strings


trim

Objetivo Remover todos os espaços de uma string, exceto os espaços simples entre as palavras.

Sintaxe trim(text)

Argumentos

Tipo | Nome | Descrição
string | text | A string a ser cortada

Resultado

Tipo | Descrição
string | A string formada a partir de text removendo todos os espaços, exceto os espaços vazios entre palavras
Nota:

A função trim é baseada na função replaceall.

Exemplos Derivar um campo que substitui vários caracteres de espaços em branco por apenas um espaço:

CommentField | trim(CommentField)
Artigos defeituosos devolvidos | Artigos defeituosos devolvidos
Compromisso perdido | Compromisso perdido
Visita de engenheiro: Segunda-feira | Visita de engenheiro: Segunda-feira
Resolvido | Resolvido
Tópico pai: Funções para trabalhar com strings


Binnings

  • Boolean
  • DayFrom, WeekFrom, MonthFrom, YearFrom
  • DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom
  • DayMultipleNumBins, WeekMultipleNumBins, MonthMultipleNumBins, YearMultipleNumBins
  • DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost
  • DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo
  • DayMultipleWidth, WeekMultipleWidth, MonthMultipleWidth, YearMultipleWidth
  • DayPrePost, WeekPrePost, MonthPrePost, YearPrePost
  • DayRange, WeekRange, MonthRange, YearRange
  • DayTo, WeekTo, MonthTo, YearTo
  • EqualRange
  • EqualRangeWidth
  • NegativeNonNegative
  • PreDuringPost
  • PrePost
  • Sign
Tópico pai: Referência de Linguagem de Campo Derivado (FDL)


Boolean

Objetivo Colocar valores booleanos em bins [consulte Dados booleanos].

Parâmetros Nenhum

Resultado

Índice do Bin | Valores
1 | false
2 | true
3 | null [consulte O valor nulo]
4 | não classificado
Tópico pai: Binnings


DayFrom, WeekFrom, MonthFrom, YearFrom

Objetivo Binar valores de data em um número específico de períodos (dias, semanas, meses ou anos) após uma data.

Parâmetros

Tipo | Nome | Descrição
data | a ("start_date") | O início da porção periódica do binning
inteiro | n ("num_bins") | O número de períodos (dias, semanas, meses ou anos) na porção periódica do binning
Resultado
Índice do Bin | Valores
1 | datas anteriores a a; o último bin inferior [consulte Últimos bins]
2, ..., n + 1 | os n períodos consecutivos após a
n + 2 | datas n períodos após a e posteriores; o último bin superior [consulte Últimos bins]
n + 3 | null [consulte O valor nulo]
n + 4 | não classificado

Consulte também

DayRange, WeekRange, MonthRange, YearRange

DayTo, WeekTo, MonthTo, YearTo

Tópico pai: Binnings


DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom

Objetivo Colocar em bins valores de datas em um número específico de períodos após uma data, onde um período é um número específico de dias, semanas, meses ou anos.

Parâmetros

Tipo | Nome | Descrição
data | a ("start_date") | O início da porção periódica do binning
inteiro | m ("width") | O número de unidades (dias, semanas, meses ou anos) em um período
inteiro | n ("num_bins") | O número de bins na porção periódica do binning
Resultado
Índice do Bin | Valores
1 | datas anteriores a a; o último bin inferior [consulte Últimos bins]
2, ..., n + 1 | os n períodos consecutivos (cada um com m unidades) após a
n + 2 | datas n x m unidades após a e posteriores; o último bin superior [consulte Últimos bins]
n + 3 | null [consulte O valor nulo]
n + 4 | não classificado

Consulte também

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo

Tópico pai: Binnings


DayMultipleNumBins, WeekMultipleNumBins, MonthMultipleNumBins, YearMultipleNumBins

Objetivo Colocar valores de data em bins em aproximadamente o número específico de períodos entre duas datas fornecidas, onde o período é um múltiplo fixo da unidade (dia, semana, mês ou ano).

Parâmetros

Tipo | Nome | Descrição
data | a ("start_date") | O início da porção periódica do binning
data | b ("end_date") | O final da porção periódica do binning
inteiro | n ("num_bins") | O número alvo dos períodos (múltiplos de um dia, semana, mês ou anos) na porção periódica do binning

Resultado

Índice do Bin | Valores
1 | datas anteriores a a; o último bin inferior [consulte Últimos bins]
2, ..., N - 3 | períodos entre a e b
N - 2 | datas b e posterior; o último bin superior [consulte Últimos bins]
N - 1 | null [consulte O valor nulo]
N | não classificado
Nota:
  • Esses binnings são como os binnings DayRange, WeekRange, MonthRange e YearRange [consulte DayRange, WeekRange, MonthRange, YearRange], exceto que o período pode ser de duas ou mais unidades (dias, semanas, meses ou anos), para produzir aproximadamente o número alvo de bins.
  • Quando o período é de duas ou mais unidades, é possível ao bin N - 3 ser mais curto que os bins 2 para N - 4.

Consulte também

DayMultipleWidth, WeekMultipleWidth, MonthMultipleWidth, YearMultipleWidth
Tópico pai: Binnings


DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

Objetivo Colocar em bins valores de data em números específicos de bins, antes e depois de uma data de referência fornecida, onde cada bin é um múltiplo da unidade (dia, semana, mês ou ano).

Parâmetros

Tipo | Nome | Descrição
data | a ("ref_date") | A data de referência para o binning
inteiro | m ("width") | O número de bins antes e depois da data de referência
inteiro | n ("num_bins") | O número de unidades (dias, semanas, meses ou anos) em cada bin

Resultado

Índice do Bin | Valores
1 | datas anteriores a n x m unidades antes de a; o último bin inferior [consulte Últimos bins]
2, ..., n + 1 | os n períodos consecutivos (cada um com m unidades) precedendo a
n + 2, ..., 2n + 1 | os n períodos consecutivos (cada um com m unidades) após a
2n + 2 | datas n x m unidades após a e posteriores; o último bin superior [consulte Últimos bins]
2n + 3 | null [consulte O valor nulo]
2n + 4 | não classificado

Consulte também

DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom

DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo

DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

PreDuringPost

PrePost

Tópico pai: Binnings


DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo

Objetivo Colocar em bins valores de datas em um número específico de períodos precedendo uma data, onde um período é um número específico de dias, semanas, meses ou anos.

Parâmetros

Tipo | Nome | Descrição
data | b ("end_date") | O final da porção periódica do binning
inteiro | m ("width") | O número de unidades (dias, semanas, meses ou anos) em um período
inteiro | n ("num_bins") | O número de bins na porção periódica do binning
Resultado
Índice do Bin | Valores
1 | datas anteriores a n x m unidades antes de a; o último bin inferior [consulte Últimos bins]
2, ..., n + 1 | os n períodos consecutivos (cada um com m unidades) precedendo a
n + 2 | datas a e posteriores; o último bin superior [consulte Últimos bins]
n + 3 | null [consulte O valor nulo]
n + 4 | não classificado

Consulte também

DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

Tópico pai: Binnings


DayMultipleWidth, WeekMultipleWidth, MonthMultipleWidth, YearMultipleWidth

Objetivo Colocar valores de data em bins em períodos entre duas datas fornecidas, onde o período é um múltiplo especificado da unidade (dia, semana, mês ou ano).

Parâmetros

Tipo | Nome | Descrição
data | a ("start_date") | O início da porção periódica do binning
data | b ("end_date") | O final da porção periódica do binning
inteiro | m ("width") | O número de unidades (dias, semanas, meses ou anos) em um período

Resultado

Índice do Bin | Valores
1 | datas anteriores a a; o último bin inferior [consulte Últimos bins]
2, ..., N - 3 | períodos entre a e b
N - 2 | datas b e posterior; o último bin superior [consulte Últimos bins]
N - 1 | null [consulte O valor nulo]
N | não classificado
Nota:
  • Esses binnings são como os binnings DayRange, WeekRange, MonthRange e YearRange [consulte DayRange, WeekRange, MonthRange, YearRange], exceto que o período pode ser de duas ou mais unidades (dias, semanas, meses ou anos).
  • Quando o período é de duas ou mais unidades, é possível ao bin N - 3 ser mais curto que os bins 2 para N - 4.

Consulte também

DayMultipleNumBins, WeekMultipleNumBins, MonthMultipleNumBins, YearMultipleNumBins
Tópico pai: Binnings


DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

Objetivo Binar valores de datas em números específicos de períodos (dias, semanas, meses ou anos) precedendo e seguindo uma data de referência fornecida.

Parâmetros

Tipo | Nome | Descrição
data | a ("ref_date") | A data de referência para o binning
inteiro | m ("before") | O número de períodos (dias, semanas, meses ou anos) a binar antes da data de referência
inteiro | n ("after") | O número de períodos a binar antes da data de referência

Resultado

Índice do Bin | Valores
1 | datas anteriores a m períodos antes de a; o último bin inferior [consulte Últimos bins]
2, ..., m + 1 | os m períodos consecutivos precedendo a
m + 2, ..., m + n + 1 | os n períodos consecutivos após a
m + n + 2 | datas n períodos após a e posteriores; o último bin superior [consulte Últimos bins]
m + n + 3 | null [consulte O valor nulo]
m + n + 4 | não classificado

Consulte também

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

PreDuringPost

PrePost

Tópico pai: Binnings


DayRange, WeekRange, MonthRange, YearRange

Objetivo Binar valores de data em períodos (dias, semanas, meses ou anos) entre duas datas fornecidas.

Parâmetros

Tipo | Nome | Descrição
data | a ("start_date") | O início da porção periódica do binning
data | b ("end_date") | O final da porção periódica do binning
Resultado
Índice do Bin | Valores
1 | datas anteriores a a; o último bin inferior [consulte Últimos bins]
2, ..., N - 3 | períodos (dias, semanas, meses ou anos) entre a e b
N - 2 | datas b e posterior; o último bin superior [consulte Últimos bins]
N - 1 | null [consulte O valor nulo]
N | não classificado
Nota:
  • Se houver menos de um período completo entre a e b, o bin 2 contém datas entre a (inclusive) e b (exclusive).
  • Se não houver um número exato de períodos entre a e b (mas houver pelo menos um período completo), o bin, imediatamente anterior a b, é ampliado para acomodar o excesso.

Consulte também

DayFrom, WeekFrom, MonthFrom, YearFrom

DayTo, WeekTo, MonthTo, YearTo

Tópico pai: Binnings


DayTo, WeekTo, MonthTo, YearTo

Objetivo Colocar valores de data em bins em um número específico de períodos (dias, semanas, meses ou anos) após uma data.

Parâmetros

Tipo | Nome | Descrição
data | b ("end_date") | O final da porção periódica do binning
inteiro | n ("num_bins") | O número de períodos (dias, semanas, meses ou anos) na porção periódica do binning
Resultado
Índice do Bin | Valores
1 | datas anteriores a n períodos antes de b; o último bin inferior [consulte Últimos bins]
2, ..., n + 1 | Os n períodos consecutivos precedendo b
n + 2 | datas b e posterior; o último bin superior [consulte Últimos bins]
n + 3 | null [consulte O valor nulo]
n + 4 | não classificado

Consulte também

DayFrom, WeekFrom, MonthFrom, YearFrom

DayRange, WeekRange, MonthRange, YearRange

Tópico pai: Binnings


EqualRange

Objetivo Binar valores numéricos em um número específico de intervalos com largura igual.

Parâmetros

Tipo | Nome | Descrição
real | a ("from") | O limite inferior da porção de intervalo igual do binning
real | b ("to") | O limite superior da porção de intervalo igual do binning
inteiro | n ("num_bins") | O número de bins na porção de intervalo igual do binning

Resultado

Índice do Bin | Valores
1 | ; o último bin inferior [consulte Últimos bins]
2, ..., n + 1 | [a, a + (b - a)/n), ..., [b - (b - a)/n, b)
n + 2 | ; o último bin superior [consulte Últimos bins]
n + 3 | null [consulte O valor nulo]
n + 4 | não classificado

Consulte também

EqualRangeWidth
Tópico pai: Binnings


EqualRangeWidth

Objetivo Colocar em bins valores numéricos em intervalos de uma largura específica.

Parâmetros

Tipo | Nome | Descrição
real | a ("from") | O limite inferior da porção de intervalo igual do binning
real | b ("to") | O limite superior da porção de intervalo igual do binning
real | r ("width") | A largura dos bins na porção de intervalo igual do binning

Resultado

Índice do Bin | Valores
1 | ; o último bin inferior [consulte Últimos bins]
2, ..., N - 3 | bins de largura igual, de largura aproximada r
N - 2 | o último bin superior [consulte Últimos bins]
N - 1 | null [consulte O valor nulo]
N | não classificado
Nota:

Se a - b não for um múltiplo exato de r, é usada uma aproximação de r para que os bins entre a e b sejam de largura igual.

Consulte também

EqualRange
Tópico pai: Binnings


NegativeNonNegative

Objetivo Colocar valores numéricos em bins de acordo com o sinal, agrupamento 0 com valores positivos.

Parâmetros Nenhum

Resultado

Índice do Bin | Valores
1 | ; ou seja, valores negativos
2 | ; ou seja, valores não negativos
3 | null [consulte O valor nulo]
4 | não classificado

Consulte também

Sign
Tópico pai: Binnings


PreDuringPost

Objetivo Binar valores de data em períodos de pré-campanha, durante a campanha e pós-campanha.

Parâmetros

Tipo | Nome | Descrição
data | a ("pre_date") | O início do período de pré-campanha
data | b ("campaign_start_date") | O início da campanha
data | c ("campaign_end_date") | O final da campanha
data | d ("post_date") | O final do período pós-campanha
Resultado
Índice do Bin | Valores
1 | datas anteriores a a; o último bin inferior [consulte Últimos bins]
2 | datas entre a (inclusive) e b (exclusive)
3 | datas entre b (inclusive) e c (exclusive)
4 | datas entre c (inclusive) e d (exclusive)
5 | datas d e posteriores; o último bin superior [consulte Últimos bins]
6 | null [consulte O valor nulo]
7 | não classificado

Consulte também

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

PrePost

Tópico pai: Binnings


PrePost

Objetivo Binar valores da data em períodos de pré-campanha e pós-campanha.

Parâmetros

Tipo | Nome | Descrição
data | a ("pre_date") | O início do período de pré-campanha
data | b ("campaign_date") | A data da campanha
data | c ("post_date") | O final do período pós-campanha

Resultado

Índice do Bin | Valores
1 | datas anteriores a a; o último bin inferior [consulte Últimos bins]
2 | datas entre a (inclusive) e b (exclusive)
3 | datas entre b (inclusive) e c (exclusive)
4 | datas c e posteriores; o último bin superior [consulte Últimos bins]
5 | null [consulte O valor nulo]
6 | não classificado

Consulte também

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

PreDuringPost

Tópico pai: Binnings


Sign

Objetivo Colocar valores numéricos em bins de acordo com o sinal.

Parâmetros Nenhum

Resultado

Índice do Bin | Valores
1 | ; ou seja, valores negativos
2 | 0
3 | ; ou seja, valores positivos
4 | null [consulte O valor nulo]
5 | não classificado

Consulte também

NegativeNonNegative
Tópico pai: Binnings


Expressões regulares FDL

  • Expressões regulares
  • Componentes básicos de uma expressão regular
  • Operadores de expressões regulares
Tópico pai: Referência de Linguagem de Campo Derivado (FDL)


Expressões regulares

Expressões regulares servem para coincidir padrões em strings [consulte Tipos de Dados]. Uma expressão regular é uma string especialmente formatada que representa um padrão de caracteres. Por exemplo, a expressão regular "ar{1,2}y\?$" representa "a letra 'a', seguida de um ou dois 'r', possivelmente seguidos de "y", seguido de o final de uma string." (Esse padrão ocorre em strings como "marry" e "jar" - mas não ocorre em "may" ou "jars.")

Uma expressão regular é composta por componentes básicos [consulte Componentes básicos de uma expressão regular] combinados por meio de operadores [consulte Operadores de expressões regulares].

Se uma expressão regular (que não seja uma subexpressão) coincidir com mais de uma porção de uma string, essa coincide sempre com a porção candidata mais longa e mais à esquerda. Por exemplo, a expressão regular "a[^ad]\+" (representando "a letra 'a', seguida de uma ou mais letras que não sejam 'a' ou 'd'") coincide com "adaptationally." A porção que coincide não é "ation", uma vez que existem porções candidatas mais à esquerda. Nem é "ap" porque, apesar de não existirem candidatos mais à esquerda, existe uma porção candidata mais longa que começa com o mesmo caractere.
  • Para testar uma string quanto a coincidência com expressão regular, use a função match.
  • Para substituir porções de uma string que coincidem com as de outra string, use a função replacefirst ou replaceall.
Nota:
  • As expressões regulares são tipicamente (mas não necessariamente) literais e, nesse caso, devem ser fechadas em aspas duplas, por exemplo, "ar{1,2}y\?$".

  • Miner/FDL usa uma Expressão regular fornecida pela biblioteca ICU. É possível vincular a http://userguide.icu-project.org/strings/regexp).

  • As expressões regulares ICU estão em conformidade com a Norma Técnica Unicode nº 18, as Expressões Regulares Unicode, nível 1, e também incluem Limites de Palavra Padrão e Propriedades de Nome do nível 2.

Tópico pai: Expressões regulares FDL


Componentes básicos de uma expressão regular

Os componentes básicos de uma expressão regular [consulte Expressões regulares] são átomos, âncoras e referências inversas.

Átomos

Um átomo coincide exatamente com um conjunto especificado de caracteres:
Átomo | Caractere coincidente
. (match-any) | Qualquer caractere
[...] (match-list) | Qualquer um dos caracteres especificados
[^...] (non-match-list) | Qualquer caractere que não seja um dos caracteres especificados
Um caractere que não seja ., ^, $, \, [, ] ou *, ocorrendo fora da lista de coincidências ou da lista de não coincidências | O próprio caractere
., ^, $, \, [, ], or *, ocorrendo fora da lista de coincidências ou da lista de não coincidências | O próprio caractere

É possível que uma lista de coincidências ou uma lista de não coincidências inclua caracteres simples, intervalos de caracteres e classes de caracteres. Não é possível usar intervalos de caracteres ou classes de caracteres, exceto em uma lista de coincidências ou lista de não coincidências.

Um intervalo de caracteres é um par de caracteres separado por um hífen e equivale a uma lista de todos os caracteres nesse intervalo (no conjunto de caracteres). Por exemplo, "a-e" equivale a "abcde" em uma lista de coincidências.

Uma classe de caracteres é um dos seguintes tokens predefinidos (em que os colchetes são adicionais em relação aos colchetes circunscrevendo a lista de coincidências ou a lista de não coincidências):

Token | Coincidências
[:alnum:] | Um caractere alfanumérico, ou seja, um caractere alfabético ou um dígito decimal
[:alpha:] | Um caractere alfabético, ou seja, "A" — "Z" e "a" — "z"
[:blank:] | Uma tabulação ou um caractere de espaço
[:cntrl:] | Um caractere de controle
[:digit:] | Um dígito decimal, ou seja, "0" — "9"
[:graph:] | Um caractere imprimível, que não seja o espaço
[:lower:] | Uma letra minúscula
[:print:] | Um caractere imprimível ou espaço
[:punct:] | Um caractere de pontuação
[:space:] | Um caractere de espaço em branco
[:upper:] | Uma letra maiúscula
[:xdigit:] | Um dígito hexadecimal, ou seja, "0" — "9," "A" — "F," e "a" — "f"
Nota:
  • É possível incluir uma combinação de caracteres simples, intervalos de caracteres e classes de caracteres em apenas uma lista de coincidências ou de não coincidências. Por exemplo, a lista de coincidências "[a-ex[:digit:]]" coincide com as letras minúsculas "a" — "e" e "x", bem como com os dígitos decimais ("0" — "9").
  • É possível colocar um hífen em uma lista de coincidências ou em uma lista de não coincidências quando ela ocorre (a) no final de um intervalo, (b) no início de uma lista de coincidências ou de uma lista de não coincidências (nesse caso, é possível também servir como o início de um intervalo), ou (c) no final de uma lista de coincidências ou de uma lista de não coincidências.

Âncoras

Os caracteres ^ e $ são âncoras; eles coincidem com o início e o final de uma string, respectivamente.

Por exemplo, para coincidir "The" que ocorre somente no início de uma string, é possível usar a expressão regular "^The."

Tópico pai: Expressões regulares FDL

Referências inversas

Uma referência inversa é uma barra invertida seguida de apenas um dígito n (exceto 0). Coincide exatamente com os mesmos caracteres que a nª subexpressão fechada em \(...\).

Por exemplo, para coincidir "yoyo," "dodo," etc. — mas não coincidir "dojo" — é possível usar a expressão regular "\(.o\)\1."

Nota:
  • A nª subexpressão de referência inversa é sempre a subexpressão começando com a nª barra invertida/parêntesis de abertura (mesmo se as subexpressões estiverem aninhadas).
  • É possível a subexpressão vazia "\(\)" ser útil para expressões regulares que envolvem alternância [consulte O operador de alternância]. Por exemplo,

    \(fish\(\)\|profit\(\)\)-e-\(chips\2\|loss\3\)

    coincide "fish-and-chips" e "profit-and-loss," mas não coincide "fish-and-loss" ou "profit-and-chips."


Operadores de expressões regulares

Um operador atua em uma ou duas expressões regulares [consulte Expressões regulares] para criar uma nova expressão regular. Os operadores, da maior à menor precedência, são os operadores de repetição [consulte Operadores de repetição], o operador de concatenação [consulte O operador de concatenação] e o operador de alternância [consulte O operador de alternância].

Se há uma ligação de precedência, as operações são realizadas da esquerda para a direita.

As subexpressões fechadas em \(...\) são sempre avaliadas em primeiro lugar.

Tópico pai: Expressões regulares FDL

Operadores de repetição

Os operadores de repetição são unários e escritos após seu único operando.

Operador | Descrição
* (zero-ou-mais) | Se uma expressão regular 'a' coincidir com uma ou mais porções adjacentes de uma string, a expressão regular a* coincidirá com a concatenação dessas porções. Coincide também com qualquer substring vazia.
\+ (um-ou-mais) | Se uma expressão regular 'a' coincidir com uma ou mais porções adjacentes de uma string, a expressão regular a\+ coincidirá com a concatenação dessas porções.
\{m,n\} (0 [image] m [image] n) | Se uma expressão regular 'a' coincidir com, pelo menos, m e não mais do que n porções adjacentes de uma string, a expressão regular a{m,n} coincidirá com a concatenação dessas porções. Se m=0, também coincidirá com qualquer substring vazia.
\? (opcional) | Assim como a{0,1}, a expressão regular a\? coincide com qualquer substring vazia ou com qualquer porção de uma string com a qual a expressão regular a coincida.
Nota:

As "porções adjacentes" mencionadas nas definições de *, \+ e {...} não são necessariamente strings idênticas. Se for necessário coincidir repetições exatas, use as referências inversas [consulte Referências inversas].

O operador de concatenação

Na verdade, o operador de concatenação não é escrito, mas está implícito sempre que duas expressões regulares são escritas uma ao lado da outra.

Se as expressões regulares a e b coincidirem com as porções adjacentes x e y de uma string z (com x precedendo y), a concatenação dea e b (escrita como a seguida de b) coincide com a porção de z contendo x e y.

Nota:

Qualquer string com caracteres não especiais, ou seja, caracteres com nenhum significado especial em uma expressão regular, funciona como uma expressão regular que coincide com essa string devido ao operador de concatenação implícito.

Na prática, a maior parte das expressões regulares é composta por strings de caracteres simples, intercalados com alguns caracteres especiais. Por exemplo, a expressão regular "[SsDd]imple" coincide com as strings "Simple", "simple", "Dimple" e "dimple".

O operador de alternância

O operador de alternância "\|" é um operador binário, escrito entre seus operandos.

Se a expressão regular a ou b coincidir com uma porção de uma string, a alternância a\|b também coincide com essa porção.


XML no Portrait Miner

  • XML no Portrait Miner


XML no Portrait Miner

Para permitir um fácil intercâmbio de resultados com outros aplicativos, o XML é usado no Portrait Miner, de acordo com a configuração do esquema XML do Portrait Miner,http://www.portraitsoftware.com

É necessário que todas as entradas XML para os comandos de compilação de dados do Portrait Miner (e qualquer outra função Portrait Miner implementada por meio do comando de compilação de dados) sejam efetuadas no namespace do Portrait Miner, http://support.portraitsoftware.com. A forma mais fácil de garantir isso é incluir o atributo xmlns=" http://support.portraitsoftware.com " no elemento raiz do documento XML.

Os arquivos XML criados pelo Portrait Miner automaticamente incluem um atributo opcional schemaLocation que aponta para os esquemas em http://www.portraitsoftware.com/xml/qs7.1. Se for usado um editor de reconhecimento de esquemas para criar arquivos XML, é possível acessar esses esquemas diretamente de sua instalação do Portrait Miner em:

<pmhome>/server/qs7.1/integration/schemas

(onde <pmhome> é o diretório de instalação do Portrait Miner). Também é possível encontrar exemplos de como processar esses arquivos XML em:

<pmhome>/server/qs7.1/etc/xslt

Tópico pai: XML no Portrait Miner


Solucionar problemas

  • "Por que não é possível abrir um focus?"
  • "Por que os eixos em meu gráfico estão subdivididos de forma desigual?"
  • "Por que "Manter Segmentos Selecionados" está sempre em cinza?"
  • "Por que meu texto tem uma aparência diferente de quando eu o escrevi?"


"Por que não é possível abrir um focus?"

Possível causa | Solução
Já existe um focus aberto. O Decision Studio somente pode trabalhar com um focus por vez. | Antes de poder abrir um focus ou criar um novo focus a partir de um arquivo simples ou de uma tabela de banco de dados, é necessário fechar seu focus atualmente aberto: escolha Arquivo>Fechar na janela do Decision Studio.
Tópico pai: Solucionar problemas


"Por que os eixos em meu gráfico estão subdivididos de forma desigual?"

Possível causa | Solução
Cada eixo em um gráfico crossdistribution ou de perfil é subdividido de acordo com o binning primário no campo que corresponde ao eixo. Se os bins são exibidos com largura semelhante isso é uma propriedade desse binning. (A exceção está onde a extensão de um bloco em uma dada direção transmite informação: nesse caso, a configuração de exibição do Binning Editor não surte efeito, para não confundir.) | No Binning Editor, selecione o campo necessário e desmarque Exibir>Histograma.
Tópico pai: Solucionar problemas


"Por que "Manter Segmentos Selecionados" está sempre em cinza?"

Possível causa | Solução
Você está tentando manter segmentos selecionados no Visualizador de Dados, Visualizador de Crosstab ou no Construtor de Scorecard. Quando uma ferramenta está vinculada [consulte Relacionamentos das ferramentas] para seguir uma dessas ferramentas, as duas ferramentas compartilham a mesma fonte de dados, independentemente de qualquer seleção na ferramenta líder. | Experimente selecionar os mesmos segmentos em uma ferramenta de visualização.
Tópico pai: Solucionar problemas


"Por que meu texto tem uma aparência diferente de quando eu o escrevi?"

Possível causa | Solução
Existem caracteres em seu texto que não podem ser traduzidos para o conjunto de caracteres ISO-8859-1 (Latim-1). | Evite texto que contenha caracteres que não possam ser traduzidos para o conjunto de caracteres ISO-8859-1.
Tópico pai: Solucionar problemas


Avisos de direitos autorais

  • Avisos de direitos autorais


Avisos de direitos autorais

O Portrait Miner pode conter o seguinte software:

ANTLR

http://www.antlr.org

Apache Batik

Esse produto inclui software desenvolvido pela Apache Software Foundation (http://www.apache.org/).

Copyright © 2000 The Apache Software Foundation. Todos os direitos reservados.

A redistribuição e uso nos formatos de fonte e binário, com ou sem modificação, são permitidos, desde que sejam atendidas as seguintes condições:
  1. As redistribuições de código-fonte devem ter o aviso de direitos autorais acima, essa lista de condições e o aviso de isenção de responsabilidade abaixo.
  2. É necessário que as redistribuições no formato binário reproduzam o aviso de direitos autorais, essa lista de condições e o aviso de isenção de responsabilidade abaixo na documentação e/ou em outros materiais fornecidos com a distribuição.
  3. A documentação para o usuário final incluída na redistribuição, se existir, deve incluir o seguinte reconhecimento: "Esse produto inclui software desenvolvido pela Apache Software Foundation (http://www.apache.org/)." Se preferir, esse reconhecimento pode aparecer no próprio software, se e onde quer que esses reconhecimentos de terceiros normalmente apareçam.
  4. Os nomes "Batik" e "Apache Software Foundation" não podem ser usados para endossar ou promover produtos derivados desse software sem prévia permissão expressa, por escrito. Para obter permissão expressa por escrito, contate apache@apache.org.
  5. Os produtos derivados desse software não podem se chamar "Apache", nem seus nomes podem conter "Apache", sem prévia permissão expressa, por escrito, da Apache Software Foundation.

ESSE SOFTWARE É FORNECIDO "NO ESTADO EM QUE SE ENCONTRA" E SEM QUAISQUER GARANTIAS EXPRESSAS OU IMPLÍCITAS, INCLUINDO, ENTRE OUTRAS, AS GARANTIAS IMPLÍCITAS DE COMERCIALIZAÇÃO E DE ADEQUAÇÃO A UMA FINALIDADE ESPECÍFICA. EM NENHUM CASO A APACHE SOFTWARE FOUNDATION OU SEUS COLABORADORES SERÃO RESPONSÁVEIS POR QUAISQUER DANOS DIRETOS, INDIRETOS, INCIDENTAIS, ESPECIAIS, EXEMPLARES OU CONSEQUENCIAIS (INCLUINDO, ENTRE OUTROS, AQUISIÇÃO DE BENS DE SUBSTITUIÇÃO OU SERVIÇOS; PERDA DE USO, DADOS OU LUCROS; OU INTERRUPÇÃO DE NEGÓCIOS) DECORRENTES E POR QUALQUER TEORIA DE RESPONSABILIDADE, POR MEIO DE CONTRATO, RESPONSABILIDADE RESTRITA OU DELITO CIVIL (INCLUINDO NEGLIGÊNCIA OU OUTRO ATO) RESULTANTES DO USO DESSE SOFTWARE, MESMO SE TIVER SIDO AVISADO SOBRE A POSSIBILIDADE DE TAL DANO.

Esse software consiste em contribuições voluntárias efetuadas por vários indivíduos em nome da Apache Software Foundation. Para mais informações sobre a Apache Software Foundation, consulte http://www.apache.org.

Implementação do algoritmo Apriori

Christian Borgelt, http://www.borgelt.net/apriori.html.

Software aberto redistribuído de acordo com os termos da Licença Pública Geral Menor do GNU.

DOM4J

O Projeto DOM4J, http://www.dom4j.org.
A redistribuição e o uso desse software e documentação associada ("Software"), com ou sem modificação, são permitidos, desde que sejam cumpridas as seguintes condições:
  1. As redistribuições de código-fonte devem manter instruções e avisos de direitos autoriais. As redistribuições também devem conter uma cópia desse documento.
  2. É necessário que as redistribuições no formato binário reproduzam o aviso de direitos autorais, essa lista de condições e o aviso de isenção de responsabilidade abaixo na documentação e/ou em outros materiais fornecidos com a distribuição.
  3. O nome "DOM4J" não pode ser usado para endossar ou promover produtos derivados desse Software sem prévia permissão expressa, por escrito, da MetaStuff, Ltd. Para obter permissão expressa por escrito, contate dom4j-info@metastuff.com.
  4. Os produtos derivados desse software não podem se chamar "DOM4J", nem seus nomes podem conter "DOM4J", sem a prévia permissão expressa, por escrito, da MetaStuff, Ltd. DOM4J é uma marca comercial registrada da MetaStuff, Ltd.
  5. Deve ser dado o devido crédito ao Projeto DOM4J — http://www.dom4j.org

ESSE SOFTWARE É FORNECIDO PELA METASTUFF, LTD. E COLABORADORES "NO ESTADO EM QUE SE ENCONTRA" E SEM QUAISQUER GARANTIAS EXPRESSAS OU IMPLÍCITAS, INCLUINDO, ENTRE OUTRAS, AS GARANTIAS IMPLÍCITAS DE COMERCIALIZAÇÃO E DE ADEQUAÇÃO A UMA FINALIDADE ESPECÍFICA. EM NENHUM CASO A METASTUFF, LTD. OU SEUS COLABORADORES SERÃO RESPONSÁVEIS POR QUAISQUER DANOS DIRETOS, INDIRETOS, INCIDENTAIS, ESPECIAIS, EXEMPLARES OU CONSEQUENCIAIS (INCLUINDO, ENTRE OUTROS, AQUISIÇÃO DE BENS DE SUBSTITUIÇÃO OU SERVIÇOS; PERDA DE USO, DADOS OU LUCROS; OU INTERRUPÇÃO DE NEGÓCIOS) DECORRENTES E POR QUALQUER TEORIA DE RESPONSABILIDADE, POR MEIO DE CONTRATO, RESPONSABILIDADE RESTRITA OU DELITO CIVIL (INCLUINDO NEGLIGÊNCIA OU OUTRO ATO) RESULTANTES DO USO DESSE SOFTWARE, MESMO SE TIVER SIDO AVISADO SOBRE A POSSIBILIDADE DE TAL DANO.

Copyright 2001 — 2004 © MetaStuff, Ltd. Todos os direitos reservados.

fmt

e http://www.cs.princeton.edu/software/cii/} Biblioteca de formatação de strings do livro C Interfaces and Implementations, Techniques for Creating Reusable Software, de David R. Hanson.

O autor desse software é David R. Hanson.

Copyright © 1994, 1995, 1996, 1997 de David R. Hanson. Todos os Direitos Reservados.

É permitido usar, copiar, modificar e distribuir esse software para qualquer fim, sujeito às provisões descritas abaixo, de forma gratuita, desde que esse aviso seja incluído na sua totalidade em todas as cópias de qualquer software que seja ou inclua uma cópia ou modificação desse software e em todas as cópias da documentação de suporte desse software.

ESSE SOFTWARE É FORNECIDO "NO ESTADO EM QUE SE ENCONTRA", SEM QUALQUER GARANTIA EXPRESSA OU IMPLÍCITA. EM PARTICULAR, O AUTOR FAZ QUALQUER REPRESENTAÇÃO OU GARANTIA DE QUALQUER TIPO REFERENTE À COMERCIALIZAÇÃO DESSE OU DE SUA ADEQUAÇÃO A UMA FINALIDADE ESPECÍFICA.

David Hanson, drh@microsoft.com, http://www.research.microsoft.com/~drh/.

FreeTDS

http://www.freetds.org/.

Software livre redistribuído de acordo com a subseção 6b da Licença Pública Geral de Biblioteca do GNU.

getopt

Esse produto (Portrait Miner) pode incluir software desenvolvido pela Universidade da Califórnia, Berkeley e seus colaboradores, sujeitos ao seguinte aviso de permissão:
Copyright © 1987, 1993, 1994 Reitoria da Universidade da Califórnia. Todos os direitos reservados. A redistribuição e uso nos formatos de fonte e binário, com ou sem modificação, são permitidos, desde que sejam atendidas as seguintes condições:
  1. As redistribuições de código-fonte devem ter o aviso de direitos autorais acima, essa lista de condições e o aviso de isenção de responsabilidade abaixo.
  2. É necessário que as redistribuições no formato binário reproduzam o aviso de direitos autorais, essa lista de condições e o aviso de isenção de responsabilidade abaixo na documentação e/ou em outros materiais fornecidos com a distribuição.
  3. Todos os materiais promocionais que mencionem funcionalidades ou uso desse software devem exibir o seguinte reconhecimento: Esse produto inclui software desenvolvido pela Universidade da Califórnia, Berkeley e seus colaboradores.
  4. O nome da Universidade, bem como os nomes de seus colaboradores podem ser usados para endossar ou promover produtos derivados desse software sem prévia permissão expressa por escrito.

ESSE SOFTWARE É FORNECIDO PELA REITORIA E COLABORADORES "NO ESTADO EM QUE SE ENCONTRA" E SEM QUAISQUER GARANTIAS EXPRESSAS OU IMPLÍCITAS, INCLUINDO, ENTRE OUTRAS, AS GARANTIAS IMPLÍCITAS DE COMERCIALIZAÇÃO E DE ADEQUAÇÃO A UMA FINALIDADE ESPECÍFICA. EM NENHUM CASO A REITORIA OU OS COLABORADORES SERÃO RESPONSÁVEIS POR QUAISQUER DANOS DIRETOS, INDIRETOS, INCIDENTAIS, ESPECIAIS, EXEMPLARES OU CONSEQUENCIAIS (INCLUINDO, ENTRE OUTROS, A AQUISIÇÃO DE BENS DE SUBSTITUIÇÃO OU SERVIÇOS; PERDA DE USO, DADOS OU LUCROS; OU INTERRUPÇÃO DE NEGÓCIOS) DECORRENTES E POR QUALQUER TEORIA DE RESPONSABILIDADE, POR MEIO DE CONTRATO, RESPONSABILIDADE RESTRITA OU DELITO CIVIL (INCLUINDO NEGLIGÊNCIA OU OUTRO ATO) RESULTANTES DO USO DESSE SOFTWARE, MESMO SE TIVER SIDO AVISADO SOBRE A POSSIBILIDADE DE TAL DANO.

MemoryClassLoader do OpenEJB.org

A redistribuição e o uso desse software e documentação associada ("Software"), com ou sem modificação, são permitidos, desde que sejam cumpridas as seguintes condições:
  1. As redistribuições de código-fonte devem manter instruções e avisos de direitos autoriais. As redistribuições também devem conter uma cópia desse documento.
  2. É necessário que as redistribuições no formato binário reproduzam o aviso de direitos autorais, essa lista de condições e o aviso de isenção de responsabilidade abaixo na documentação e/ou em outros materiais fornecidos com a distribuição.
  3. O nome "OpenEJB" não pode ser usado para endossar ou promover produtos derivados desse Software sem prévia permissão expressa, por escrito, do The OpenEJB Group. Para obter permissão expressa por escrito, contate info@openejb.org.
  4. Produtos derivados desse Software não podem se chamar "OpenEJB", nem seus nomes podem conter "OpenEJB" sem a prévia permissão expressa, por escrito, do The OpenEJB Group. OpenEJB é uma marca comercial registada do The OpenEJB Group.
  5. Deve ser dado o devido crédito ao Projeto OpenEJB Project (http://www.openejb.org/).

ESSE SOFTWARE É FORNECIDO PELO THE OPENEJB GROUP E COLABORADORES "NO ESTADO EM QUE SE ENCONTRA" E SEM QUAISQUER GARANTIAS EXPRESSAS OU IMPLÍCITAS, INCLUINDO, ENTRE OUTRAS, AS GARANTIAS IMPLÍCITAS DE COMERCIALIZAÇÃO E DE ADEQUAÇÃO A UMA FINALIDADE ESPECÍFICA. EM NENHUM CASO O THE OPENEJB GROUP OU SEUS COLABORADORES SERÃO RESPONSÁVEIS POR QUAISQUER DANOS DIRETOS, INDIRETOS, INCIDENTAIS, ESPECIAIS, EXEMPLARES OU CONSEQUENCIAIS (INCLUINDO, ENTRE OUTROS, A AQUISIÇÃO DE BENS DE SUBSTITUIÇÃO OU SERVIÇOS; PERDA DE USO, DADOS OU LUCROS; OU INTERRUPÇÃO DE NEGÓCIOS) DECORRENTES E POR QUALQUER TEORIA DE RESPONSABILIDADE, POR MEIO DE CONTRATO, RESPONSABILIDADE RESTRITA OU DELITO CIVIL (INCLUINDO NEGLIGÊNCIA OU OUTRO ATO) RESULTANTES DO USO DESSE SOFTWARE, MESMO SE TIVER SIDO AVISADO SOBRE A POSSIBILIDADE DE TAL DANO.

Copyright 2001 — 2005 © The OpenEJB Group. Todos os Direitos Reservados.

Numerical Recipes

Esse produto contém procedimentos baseados em rotinas que aparecem no livro Numerical Recipes: The Art of Scientific Computing, publicado pela Cambridge University Press e são usados com permissão.

pthreads-win32

Uma biblioteca POSIX threads library para o Windowslong. Copyright © 2001 Ross P. Johnson. Todos os direitos reservados.

Software aberto redistribuído de acordo com os termos da Licença Pública Geral Menor do GNU.

RPC/XDR

Copyright © 1986, Sun Microsystems, Inc. sujeito ao seguinte aviso de permissão:

Sun RPC é um produto da Sun Microsystems, Inc. e é fornecido para uso irrestrito, desde que essa legenda seja incluída em todas as mídias de fita e como parte do programa do software em todo ou em parte. Os usuários podem copiar ou modificar o Sun RPC sem encargos, mas não estão autorizados a atribuir a licença ou a distribuir o produto a qualquer pessoa, exceto se fizer parte de um produto ou programa desenvolvido pelo usuário.

O SUN RPC É FORNECIDO "NO ESTADO EM QUE SE ENCONTRA" SEM GARANTIAS DE QUALQUER TIPO, INCLUINDO AS GARANTIAS DE DESIGN, COMERCIALIZAÇÃO E DE ADEQUAÇÃO A UMA FINALIDADE ESPECÍFICA OU RESULTANTE DE UM PROCESSO DE NEGOCIAÇÃO, USO OU DE PRÁTICA COMERCIAL.

O Sun RPC é fornecido sem suporte e sem qualquer obrigação por parte da Sun Microsystems, Inc. de dar assistência ao seu uso, correção, modificação ou aprimoramento.

SUN MICROSYSTEMS, INC. NÃO SERÁ RESPONSÁVEL COM RELAÇÃO À VIOLAÇÃO DE DIREITOS AUTORAIS, SEGREDOS COMERCIAIS OU DE QUAISQUER PATENTES PELO SUN RPC OU DE QUALQUER PARTE DELE.

Em nenhum caso a Sun Microsystems, Inc. será responsável por qualquer perda de receitas ou lucros ou por outros danos especiais, indiretos e consequenciais, mesmo se a Sun tiver sido avisada sobre a possibilidade de tais danos.

Sun Microsystems, Inc.

2550 Garcia Avenue

Mountain View, California 94043

Rx

Copyright © 1996 Tom Lord, Berkeley, CA EUA, exceto porções de "POSIX Regex Functions" que são Copyright © 1995 Free Software Foundation, Inc.

É permitido usar, copiar, modificar, distribuir e vender esse software e sua documentação para qualquer fim de forma gratuita, desde que o aviso de direitos autorais acima apareça em todas as cópias e que, tanto o aviso de direitos autorais, como esse aviso de permissão, apareçam na documentação de suporte.

Software livre redistribuído de acordo com a subseção 6b da Licença Pública Geral de Biblioteca do GNU.

Stat/Transfer

Copyright © 2003 Circle Systems, Inc.

Trang

Conversor de esquemas multiformatos com base no \rng. Copyright © 2002, 2003 Thai Open Source Software Center Ltd. Todos os direitos reservados.
A redistribuição e uso nos formatos de fonte e binário, com ou sem modificação, são permitidos, desde que sejam atendidas as seguintes condições:
  • As redistribuições de código-fonte devem ter o aviso de direitos autorais acima, essa lista de condições e o aviso de isenção de responsabilidade abaixo.
  • É necessário que as redistribuições no formato binário reproduzam o aviso de direitos autorais, essa lista de condições e o aviso de isenção de responsabilidade abaixo na documentação e/ou em outros materiais fornecidos com a distribuição.
  • O nome da Thai Open Source Software Center Ltd, bem como os nomes de seus colaboradores podem ser usados para endossar ou promover produtos derivados desse software sem prévia permissão expressa por escrito.

ESSE SOFTWARE É FORNECIDO PELOS DETENTORES DE DIREITOS AUTORAIS E COLABORADORES "NO ESTADO EM QUE SE ENCONTRA" E SEM QUAISQUER GARANTIAS EXPRESSAS OU IMPLÍCITAS, INCLUINDO, ENTRE OUTRAS, AS GARANTIAS IMPLÍCITAS DE COMERCIALIZAÇÃO E DE ADEQUAÇÃO A UMA FINALIDADE ESPECÍFICA. EM NENHUM CASO A REITORIA OU OS COLABORADORES SERÃO RESPONSÁVEIS POR QUAISQUER DANOS DIRETOS, INDIRETOS, INCIDENTAIS, ESPECIAIS, EXEMPLARES OU CONSEQUENCIAIS (INCLUINDO, ENTRE OUTROS, A AQUISIÇÃO DE BENS DE SUBSTITUIÇÃO OU SERVIÇOS; PERDA DE USO, DADOS OU LUCROS; OU INTERRUPÇÃO DE NEGÓCIOS) DECORRENTES E POR QUALQUER TEORIA DE RESPONSABILIDADE, POR MEIO DE CONTRATO, RESPONSABILIDADE RESTRITA OU DELITO CIVIL (INCLUINDO NEGLIGÊNCIA OU OUTRO ATO) RESULTANTES DO USO DESSE SOFTWARE, MESMO SE TIVER SIDO AVISADO SOBRE A POSSIBILIDADE DE TAL DANO.

unixODBC

Subsistema ODBC de código aberto e um ODBC SDK para Linux, Mac OSX e UNIX. unixODBC, http://www.unixodbc.org/.

Software livre redistribuído de acordo com a subseção 6b da Licença Pública Geral de Biblioteca do GNU.

Xerces Java Parser

Esse produto inclui software desenvolvido pela Apache Software Foundation (http://www.apache.org/).

Copyright © 1999 — 2002 The Apache Software Foundation. Todos os direitos reservados.

A redistribuição e uso nos formatos de fonte e binário, com ou sem modificação, são permitidos, desde que sejam atendidas as seguintes condições:
  1. As redistribuições de código-fonte devem ter o aviso de direitos autorais acima, essa lista de condições e o aviso de isenção de responsabilidade abaixo.
  2. É necessário que as redistribuições no formato binário reproduzam o aviso de direitos autorais, essa lista de condições e o aviso de isenção de responsabilidade abaixo na documentação e/ou em outros materiais fornecidos com a distribuição.
  3. A documentação para o usuário final incluída na redistribuição, se existir, deve incluir o seguinte reconhecimento: "Esse produto inclui software desenvolvido pela Apache Software Foundation (http://www.apache.org/)." Se preferir, esse reconhecimento pode aparecer no próprio software, se e onde quer que esses reconhecimentos de terceiros normalmente apareçam.
  4. Os nomes "Xerces" e "Apache Software Foundation" não podem ser usados para endossar ou promover produtos derivados desse software sem prévia permissão expressa, por escrito. Para obter permissão expressa por escrito, contate apache@apache.org.
  5. Os produtos derivados desse software não podem se chamar "Apache", nem seus nomes podem conter "Apache", sem prévia permissão expressa, por escrito, da Apache Software Foundation.

ESSE SOFTWARE É FORNECIDO "NO ESTADO EM QUE SE ENCONTRA" E SEM QUAISQUER GARANTIAS EXPRESSAS OU IMPLÍCITAS, INCLUINDO, ENTRE OUTRAS, AS GARANTIAS IMPLÍCITAS DE COMERCIALIZAÇÃO E DE ADEQUAÇÃO A UMA FINALIDADE ESPECÍFICA. EM NENHUM CASO A APACHE SOFTWARE FOUNDATION OU SEUS COLABORADORES SERÃO RESPONSÁVEIS POR QUAISQUER DANOS DIRETOS, INDIRETOS, INCIDENTAIS, ESPECIAIS, EXEMPLARES OU CONSEQUENCIAIS (INCLUINDO, ENTRE OUTROS, AQUISIÇÃO DE BENS DE SUBSTITUIÇÃO OU SERVIÇOS; PERDA DE USO, DADOS OU LUCROS; OU INTERRUPÇÃO DE NEGÓCIOS) DECORRENTES E POR QUALQUER TEORIA DE RESPONSABILIDADE, POR MEIO DE CONTRATO, RESPONSABILIDADE RESTRITA OU DELITO CIVIL (INCLUINDO NEGLIGÊNCIA OU OUTRO ATO) RESULTANTES DO USO DESSE SOFTWARE, MESMO SE TIVER SIDO AVISADO SOBRE A POSSIBILIDADE DE TAL DANO.

Esse software consiste em contribuições voluntárias efetuadas por vários indivíduos em nome da Apache Software Foundation e se baseava originalmente no software copyright © 1999, International Business Machines, Inc., http://www.ibm.com. Para mais informações sobre a Apache Software Foundation, consulte http://www.apache.org.

Xerces Java Parser

Copyright © 1995 — 1998 Jean-loup Gailly e Mark Adler.
Tópico pai: Avisos de direitos autorais

LICENÇA PÚBLICA GERAL DE BIBLIOTECA DO GNU

Versão 2, junho de 1991

Copyright © 1991 Free Software Foundation, Inc.

59 Temple Place — Suite 330, Boston, MA 02111-1307, EUA

Qualquer pessoa está autorizada a copiar e a distribuir cópias literais desse documento de licença, mas não está autorizada a fazer alterações.

Preâmbulo

As licenças da maior parte dos softwares são criadas para retirar sua liberdade para compartilhar e alterá-los. Por oposição, as Licenças Públicas Gerais do GNU destinam-se a garantir sua liberdade para compartilhar e alterar software livre — para assegurar que o software é livre para todos os seus usuários.

Essa licença, a Licença Pública Geral de Biblioteca, aplica-se a alguns softwares especialmente designados Free Software Foundation e a quaisquer outras bibliotecas, cujos autores decidam utilizá-la. Também é possível usar a licença em suas bibliotecas.

Quando falamos de software livre, estamos nos referimos a liberdade, não a preço. Nossas Licenças Públicas Gerais são criadas para assegurar que você tenha a liberdade para distribuir cópias de software livre (e cobrar por esse serviço, se pretender), que receba um código-fonte ou que pode adquiri-lo se pretender, que possa alterar o software ou usar partes dele em novos programas livres; e que saiba que pode realizar esses atos.

A fim de proteger seus direitos, é necessário fazer restrições que proíbam qualquer pessoa de lhe negar esses direitos ou de pedir que renuncie aos direitos. Essas restrições se traduzem em determinadas responsabilidades que deverá assumir se distribuir cópias da biblioteca ou se a alterar.

Por exemplo, se você distribuir cópias da biblioteca, seja gratuitamente ou mediante um valor, terá de conceder a seus receptores todos os direitos que estamos concedendo a você. Você terá de garantir que eles, também, recebam ou possam obter o código-fonte. Se vincular um programa à biblioteca, é necessário fornecer arquivos de objeto completos aos destinatários, para que eles possam vinculá-los novamente à biblioteca após efetuarem alterações à biblioteca e a recompilarem. E você terá de exibir a eles esses termos, para que eles conheçam seus direitos.

Nosso método de proteção de seus direitos envolve duas etapas: (1) assegurar o copyright da biblioteca e (2) fornecer essa licença que lhe dá permissão legal para copiar, distribuir e/ou modificar a biblioteca.

Além disso, para a proteção de cada distribuidor, queremos assegurar que todas as pessoas compreendem que não existe nenhuma garantia para essa biblioteca livre. Se a biblioteca for modificada por alguém e transmitida para outras pessoas, queremos que seus destinatários saibam que o que possuem não corresponde à versão original, de forma que quaisquer problemas introduzidos por outros não refletirão na reputação dos autores originais.

Finalmente, qualquer programa livre é constantemente ameaçado por patentes de software. Pretendemos evitar o perigo de que empresas que distribuem software livre obtenham individualmente licenças de patente, transformando assim o programa em software proprietário. Para evitar que isso aconteça, deixamos claro que qualquer patente deve estar licenciada para o uso livre de qualquer pessoa ou então não licenciada.

A maior parte dos softwares GNU, incluindo algumas bibliotecas, está coberta pela Licença Pública Geral comum do GNU, que foi criada para programas utilitários. Essa licença, a Licença Pública Geral de Biblioteca do GNU, se aplica a determinadas bibliotecas designadas. Essa licença é bastante diferente da licença comum; certifique-se de a ler na totalidade e não assuma que qualquer coisa nela seja igual à licença comum.

Possuímos uma licença pública separada para algumas bibliotecas porque essas ignoram a distinção que costumamos fazer entre modificar ou adicionar a um programa e simplesmente usar o programa. Vincular um programa a uma biblioteca, sem alterar a biblioteca, se trata, de certa forma, de usar simplesmente a biblioteca e é semelhante a executar um programa utilitário ou programa aplicativo. No entanto, em um sentido textual e jurídico, o executável vinculado é uma obra combinada, um derivativo da biblioteca original e a Licença Pública Geral comum o trata como tal.

Devido a essa distinção não clara, usar a Licença Pública Geral comum para bibliotecas não promoveu efetivamente o compartilhamento de software porque a maior parte dos desenvolvedores não usou as bibliotecas. Concluímos que condições mais fracas podem promover um melhor compartilhamento.

Contudo, a vinculação irrestrita de programas não livres iria privar os usuários desses programas de todos os benefícios do status livre das próprias bibliotecas. Essa Licença Pública Geral de Biblioteca destina-se a permitir que os desenvolvedores de programas não gratuitos usem bibliotecas livres, ao mesmo tempo que preserva sua liberdade como usuário de tais programas de alterar as bibliotecas livres incorporadas nos programas. (Não sabemos como atingir isso relativamente a alterações nos arquivos de cabeçalho, mas já atingimos isso no que se refere a alterações nas funções reais da Biblioteca.) Esperamos que isso conduza a um desenvolvimento mais rápido de bibliotecas livres.

Seguem abaixo os termos e condições exatos para a cópia, distribuição e modificação. Preste muita atenção à diferença entre uma "obra baseada na biblioteca" e uma "obra que usa a biblioteca". A primeira contém código derivado da biblioteca, enquanto a segunda somente trabalha em conjunto com a biblioteca.

Note que é possível que uma biblioteca seja coberta pela Licença Pública Geral comum, em vez de ser abrangida por esta licença específica.

TERMOS E CONDIÇÕES PARA CÓPIA, DISTRIBUIÇÃO E MODIFICAÇÃO

  • 0. Esse Contrato de Licença se aplica a qualquer biblioteca de software que contenha um aviso colocado pelo detentor de direitos autorais ou outra parte autorizada a transmitir que pode ser distribuído de acordo com os termos dessa Licença Pública Geral de Biblioteca (também designada "essa Licença"). Cada licenciado doravante será denominado "você".

    Uma "biblioteca" significa uma coleção de funções de software e/ou dados preparados, de forma a serem convenientemente ligados com programas de aplicação (que usam algumas dessas funções e dados) para formar executáveis.

    O termo "Biblioteca", abaixo, refere-se a qualquer biblioteca de software ou obra que tenha sido distribuída de acordo com esses termos. Uma "obra baseada na Biblioteca" significa tanto a Biblioteca como qualquer obra derivada, nos termos da legislação autoral: isto é, uma obra contendo a Biblioteca ou parte dela, seja sem alterações ou com modificações e/ou traduzida diretamente para outra linguagem. (Doravante, o termo "modificação" inclui, sem reservas, o termo "tradução").

    O código-fonte de uma obra significa o formato preferencial da obra para que sejam feitas modificações na mesma. Para uma biblioteca, o código-fonte completo significa todo o código fonte para todos os módulos contidos na mesma, além de quaisquer arquivos de definição de interface associados, além dos scripts utilizados para controlar a compilação e a instalação da biblioteca.

    Outras atividades que não a cópia, distribuição e modificação não são cobertas por esta Licença; elas estão fora de seu escopo. O ato de executar um programa usando a Biblioteca não tem restrições, e o resultado gerado a partir desse programa encontra-se coberto somente se seu conteúdo constituir uma obra baseada na Biblioteca (independente do uso da Biblioteca em uma ferramenta para escrevê-lo). Na verdade, isto dependerá daquilo que a Biblioteca faz e o que o programa que usa a biblioteca faz.

  • 1. Você pode copiar e distribuir cópias sem alterações do código-fonte completo da Biblioteca ao recebê-lo, em qualquer meio ou mídia, desde que publique, ostensiva e adequadamente, um aviso de direitos autorais (ou copyright) apropriado e uma notificação sobre a exoneração de garantias; mantenha intactas as informações, avisos ou notificações referentes a esta Licença e à ausência de qualquer garantia; e distribua uma cópia desta Licença junto com a Biblioteca.

    Você poderá cobrar um valor pelo ato físico de transferir uma cópia, e você pode oferecer, se quiser, a proteção de uma garantia em troca de um valor.

  • 2. Você pode modificar sua cópia ou cópias da Biblioteca ou qualquer parte dela, formando, assim, uma obra baseada na Biblioteca, bem como copiar e distribuir essas modificações ou obra, em conformidade com a Cláusula 1 acima, desde que atenda, ainda, a todas as seguintes condições:
    • a) A obra modificada tem de ser, por si só, uma biblioteca de software.
    • b) Você tem de fazer com que os arquivos modificados contenham avisos, em destaque, de que você modificou os arquivos e a data de qualquer modificação.
    • c) Você tem de fazer com que a obra como um todo seja licenciada, sem nenhum custo, a todos os terceiros, de acordo com esta Licença.
    • d) Se um dispositivo, na Biblioteca modificada, se referir a uma função ou a uma tabela de dados a ser fornecida por um programa de aplicação que usa esse dispositivo, outro que não um argumento transmitido quando o dispositivo é invocado, nesse caso, você terá de fazer um esforço de boa-fé para assegurar que, no caso de uma aplicação que não forneça essa função ou tabela, o dispositivo ainda assim opere, e irá realizar qualquer parte de sua finalidade que permanecer significativa. (Por exemplo, uma função de uma biblioteca para computar raízes quadradas tem uma finalidade que é completamente bem definida independentemente da aplicação. Por essa razão, a letra d, da Cláusula 2, exige que qualquer função ou tabela fornecida pela aplicação, usada por essa função, tem de ser opcional: se a aplicação não fornecê-la, a função de raízes quadradas deverá ainda assim computar raízes quadradas).

    Esses requisitos se aplicam à obra modificada como um todo. Se partes identificáveis dessa obra não forem derivadas da Biblioteca e puderem ser razoavelmente consideradas trabalhos independentes e separados, então essa Licença, e seus termos, não se aplicam a essas partes quando forem distribuídas como obras separadas. Porém, quando você distribuir essas mesmas partes como partes de um todo, que por si seja uma obra baseada na Biblioteca, a distribuição desse todo deverá ser realizada de acordo com esta Licença, cujas respectivas permissões para outros licenciados estendem-se à integralidade deste todo, dessa forma, a toda e qualquer parte, independentemente de quem a escreveu.

    Dessa forma, a intenção dessa seção não é exigir direitos ou contestar seus direitos sobre uma obra escrita inteiramente por você; em vez disso, essa seção pretende exercer o direito de controlar a distribuição de obras derivadas ou coletivas baseadas na Biblioteca.

    Além disso, a simples agregação de outra obra, que não seja baseada na Biblioteca, à Biblioteca (ou a uma obra baseada na Biblioteca) em um volume de meio mídia de armazenamento ou distribuição não inclui esta outra obra no âmbito dessa Licença.

  • 3. Você poderá optar por aplicar os termos da Licença Pública Geral do GNU ao invés desta Licença, para uma determinada cópia da Biblioteca. Para tanto, você deverá alterar todos os avisos ou notificações que se refiram a esta Licença, para que eles se refiram à Licença Pública Geral comum do GNU, versão 2, ao invés desta Licença. (Se uma versão mais nova do que a versão 2 da Licença Pública Geral comum do GNU tiver sido gerada, então você poderá especificar essa versão, se preferir). Não faça qualquer outra alteração nesses avisos.

    Uma vez que essa alteração tenha sido feita em uma determinada cópia, ela é irreversível para esta cópia, passando a Licença Pública Geral comum do GNU a ser aplicada para todas as cópias e obras derivadas subsequentes, feitas a partir dessa cópia.

    Essa opção é útil quando você desejar copiar parte do código da Biblioteca em um programa que não seja uma biblioteca.

  • 4. Você poderá copiar e distribuir a Biblioteca (ou uma parte ou obra derivada dela, de acordo com a Cláusula 2) em código-objeto ou formato executável, sob as Cláusulas 1 e 2 acima, desde que inclua todo o código-fonte correspondente, passível de leitura pela máquina, que deve ser distribuído sob os termos das Cláusulas 1 e 2 acima, em um meio ou mídia costumeiramente utilizado para o intercâmbio de software.

    Se a distribuição do código-objeto for feita pela oferta de acesso para cópia a partir de um local designado, então a permissão de acesso equivalente para copiar o código-fonte a partir do mesmo local atende a exigência de distribuição do código-fonte, mesmo que terceiros não sejam levados a copiar a fonte junto com o código-objeto.

  • 5. Um programa que não contenha nenhum derivativo de qualquer parte da Biblioteca, mas que seja desenhado para operar com a Biblioteca ao ser compilado ou ligado a ela, é chamado de uma "obra que usa a Biblioteca". Essa obra, isoladamente, não é uma obra derivada da Biblioteca e, portanto, fica de fora do âmbito desta Licença.

    Entretanto, a ligação de uma "obra que usa a Biblioteca" com a Biblioteca constitui um executável que é um derivado da Biblioteca (pois contém partes da Biblioteca), e não uma "obra que usa a Biblioteca". O executável é, assim, coberto por essa Licença. A Cláusula 6 estabelece os termos para a distribuição desses executáveis.

    Quando uma "obra que usa a Biblioteca" usar material de um arquivo de cabeçalho que é parte da Biblioteca, o código-objeto para a obra poderá ser uma obra derivada da Biblioteca, mesmo que o código-fonte não o seja. Para que isto seja verdade, é especialmente importante se a obra pode ser ligada sem a Biblioteca, ou se a obra é, em si mesma, uma biblioteca. O limite para que isso seja verdade não é definido de forma precisa pela lei.

    Se um arquivo-objeto usar somente parâmetros numéricos, layouts e accessors da estrutura de dados, bem como pequenas macros e pequenas funções inline (dez linhas ou menos de extensão), então o uso do arquivo-objeto não é restrito, independente de ser ele legalmente uma obra derivada. (Executáveis contendo este código-objeto mais partes da Biblioteca continuam submetidos aos termos da Cláusula 6).

    Do contrário, se a obra for um derivado da Biblioteca, você poderá distribuir o código objeto da obra sob os termos da Cláusula 6. Quaisquer executáveis contendo esta obra também se submetem à Cláusula 6, estejam ou não diretamente ligados à Biblioteca em si.

  • 6. Como exceção à Cláusula acima, você também pode combinar ou ligar uma "obra que usa a Biblioteca" à Biblioteca para produzir uma obra contendo partes da Biblioteca e distribuí-la de acordo com os termos de sua escolha, desde que estes termos permitam modificações na obra para uso próprio por parte do cliente e engenharia reversa para depuração dessas modificações.
    Em cada cópia da obra, você terá de colocar um aviso, em destaque, de que a Biblioteca foi usada e que ela e seu uso estão cobertos por essa Licença. Você deverá fornecer uma cópia desta Licença. Se, durante a execução, a obra exibir avisos ou notificações de direitos autorais (ou copyright), você terá de incluir, entre eles, o aviso de direitos autorais (ou copyright) referente à Biblioteca, bem como uma referência direcionando o usuário para a cópia desta Licença. Além disso, você dever tomar ao menos uma das seguintes providências:
    • a) Incluir na obra todo o código-fonte da Biblioteca, passível de leitura pela máquina, incluindo quaisquer modificações que foram usadas na obra (as quais devem ser distribuídas conforme as Cláusulas 1 e 2 acima); e, se a obra for um executável ligado à Biblioteca, com toda a "obra que usa a Bilblioteca" passível de leitura pela máquina, como código-objeto e/ou código-fonte, de modo que o usuário possa modificar a biblioteca e, depois, religar para produzir um executável modificado contendo a Biblioteca modificada. (Fica entendido que o usuário que modificar o conteúdo dos arquivos de definições da Biblioteca não necessariamente será capaz de recompilar a aplicação para usar as definições modificadas).
    • b) Incluir na obra uma oferta por escrito, válida por pelo menos três anos, oferecendo ao mesmo usuário os materiais especificados na letra "a" da Cláusula 6 acima, por um custo não superior ao custo de fazer esta distribuição.
    • c) Se a distribuição da obra for feita com a permissão de acesso para copiar, a partir de um local designado, oferecer acesso equivalente para copiar os materiais acima especificados, a partir do mesmo local.
    • d) Certificar se o usuário já recebeu uma cópia desses materiais ou de que você já enviou uma cópia a esse usuário.

    Para um executável, o formato exigido da "obra que usa a Biblioteca" deve incluir quaisquer dados e programas utilitários necessários para reprodução do executável a partir dele. Porém, como uma exceção especial, oo código-fonte a ser distribuído não necessita incluir algo que seja normalmente distribuído (tanto no formato fonte quanto binário) com os componentes mais importantes (compilador, kernel, e assim por diante) do sistema operacional no qual executável é executado, a menos que esse componente, em si, acompanhe o executável.

    Pode ocorrer que essa exigência contradiga as restrições da licença de outras bibliotecas proprietárias que normalmente não acompanham o sistema operacional. Essa contradição significa que você não pode utilizar ambas e a Biblioteca juntas em um executável distribuído por você.

  • 7. Você pode colocar dispositivos da biblioteca que sejam uma obra baseada na Biblioteca lado-a-lado em apenas uma biblioteca junto com outros dispositivos de bibliotecas, desde que uma distribuição separada da obra baseada na Biblioteca e dos outros dispositivos de bibliotecas seja, de outro modo, permitida e desde que você tome uma das seguintes providências:
    • a) Incluir na biblioteca combinada uma cópia dessa obra baseada na Biblioteca sem a combinação com quaisquer outros dispositivos de biblioteca. Essa cópia tem de ser distribuída de acordo com as condições das cláusulas acima.
    • b) Junto com a biblioteca combinada, fornecer um aviso, em destaque, sobre o fato de que parte dela é uma obra baseada na Biblioteca, e explicando onde encontrar o formato não combinado incluso dessa mesma obra.
  • 8. Você não poderá copiar, modificar, sublicenciar, ligar, ou distribuir a Biblioteca, exceto conforme expressamente disposto nesta Licença. Qualquer tentativa de, de outro modo, copiar, modificar, sublicenciar, ligar ou distribuir a Biblioteca é inválida, e automaticamente terminará seus direitos sob esta Licença. Todavia, terceiros que tiverem recebido cópias ou direitos de você, de acordo com esta Licença, não terão seus direitos rescindidos, enquanto estes terceiros mantiverem o seu pleno cumprimento.
  • 9. Você não é obrigado a aceitar esta Licença, uma vez que você não a assinou. Entretanto, nada mais concede a você permissão para modificar ou distribuir a Biblioteca ou suas obras derivadas. Esses atos são proibidos por lei se você não aceitar esta Licença. Portanto, ao modificar ou distribuir a Biblioteca (ou qualquer obra baseada na Biblioteca), você manifesta sua aceitação desta Licença para fazê-lo, bem como de todos os seus termos e condições para cópia, distribuição ou modificação da Biblioteca ou obras nela baseadas.
  • 10. A cada vez que você redistribuir a Biblioteca (ou qualquer obra nela baseada), o receptor automaticamente recebe uma licença do licenciante original para copiar, distribuir, ligar ou modificar a Biblioteca, sujeito a estes respectivos termos e condições. Você não poderá impor quaisquer restrições adicionais ao exercício, pelos receptores, dos direitos concedidos por este instrumento. Você não tem responsabilidade de promover o cumprimento desta licença por parte de terceiros.
  • 11. Se, como resultado de uma sentença judicial ou alegação de violação de patente, ou por qualquer outro motivo (não restrito às questões de patentes), forem impostas a você condições (tanto através de mandado judicial, contrato ou qualquer outra forma) que contradigam as condições desta Licença, você não estará desobrigado quanto às condições desta Licença. Se você não puder atuar como distribuidor de modo a satisfazer simultaneamente suas obrigações sob esta licença e quaisquer outras obrigações pertinentes, então, como consequência, você não poderá distribuir a Biblioteca de nenhuma forma. Por exemplo, se uma licença sob uma patente não permite a redistribuição por parte de todos aqueles que tiverem recebido cópias, direta ou indiretamente de você, sem o pagamento de royalties, então, a única forma de cumprir tanto com esta exigência quanto com esta licença será deixar de distribuir, por completo, a Biblioteca.

    Se qualquer parte desta Cláusula for considerada inválida ou não executável, sob qualquer circunstância específica, o restante da cláusula deverá continuar a ser aplicado e a cláusula, como um todo, deverá ser aplicada em outras circunstâncias.

    Esta cláusula não tem a finalidade de induzir você a infringir quaisquer patentes ou direitos de propriedade, nem de contestar a validade de quaisquer reivindicações deste tipo; a única finalidade desta cláusula é proteger a integridade do sistema de distribuição do software livre, o qual é implementado mediante práticas de licenças públicas. Muitas pessoas têm feito generosas contribuições à ampla gama de software distribuído através desse sistema, confiando na aplicação consistente deste sistema; cabe ao autor/doador decidir se deseja distribuir software através de qualquer outro sistema e um licenciado não pode impor esta escolha.

    Esta cláusula visa deixar absolutamente claro o que se acredita ser uma consequência do restante desta Licença.

  • 12. Se a distribuição e/ou uso da Biblioteca for restrito em determinados países, tanto por patentes ou por interfaces protegidas por direito autoral, o titular original dos direitos autorais que colocar a Biblioteca sob esta Licença poderá acrescentar uma limitação geográfica de distribuição explícita excluindo esses países, de modo que a distribuição seja permitida somente nos países ou entre os países que não foram excluídos dessa forma. Nesse caso, esta Licença passa a incorporar a limitação como se esta tivesse sido escrita no corpo desta Licença.
  • 13. A Free Software Foundation [Fundação Software Livre] poderá de tempos em tempos publicar versões revisadas e/ou novas da Licença Pública Geral Menor. Essas novas versões serão semelhantes em espírito à presente versão, podendo, porém, ter diferenças nos detalhes, para tratar de novos problemas ou preocupações.

    Cada versão recebe um número distinto de versão. Se a Biblioteca especificar um número de versão desta Licença, aplicável à Biblioteca ou a "qualquer versão posterior", você terá a opção de seguir os termos e condições tanto daquela versão como de qualquer versão posterior publicada pela Free Software Foundation. Se a Biblioteca não especificar um número de licença da versão, você poderá escolher qualquer versão já publicada pela Free Software Foundation.

  • 14. Se você desejar incorporar partes da Biblioteca em outros programas livres cujas condições de distribuição sejam incompatíveis com essas, escreva ao autor para solicitar sua permissão. Para software cujos direitos autorais pertencerem à Free Software Foundation, escreva à Fundação; algumas vezes, fazemos exceções nesse sentido. Nossa decisão será guiada pelos dois objetivos de preservar a condição livre de todos os derivados de nosso software livre e de promover o compartilhamento e reutilização de softwares, de modo geral.

    EXCLUSÃO DE GARANTIA

  • 15. COMO A BIBLIOTECA É LICENCIADA SEM CUSTO, NÃO HÁ NENHUMA GARANTIA PARA A BIBLIOTECA, NO LIMITE PERMITIDO PELA LEI APLICÁVEL. EXCETO QUANDO DE OUTRA FORMA ESTABELECIDO POR ESCRITO, OS TITULARES DOS DIREITOS AUTORAIS E/OU OUTRAS PARTES FORNECEM A BIBLIOTECA "NO ESTADO EM QUE SE ENCONTRA", SEM NENHUMA GARANTIA DE QUALQUER TIPO, TANTO EXPRESSA COMO IMPLÍCITA, INCLUINDO, DENTRE OUTRAS, AS GARANTIAS IMPLÍCITAS DE COMERCIABILIDADE E ADEQUAÇÃO PARA UMA FINALIDADE ESPECÍFICA. O RISCO INTEGRAL QUANTO À QUALIDADE E DESEMPENHO DA BIBLIOTECA É ASSUMIDO POR VOCÊ. CASO A BIBLIOTECA CONTENHA DEFEITOS, VOCÊ ARCARÁ COM OS CUSTOS DE TODOS OS SERVIÇOS, REPAROS OU CORREÇÕES NECESSÁRIAS.
  • 16. EM NENHUMA CIRCUNSTÂNCIA, A MENOS QUE EXIGIDO PELA LEI APLICÁVEL OU ACORDADO POR ESCRITO, QUALQUER TITULAR DE DIREITOS AUTORAIS OU QUALQUER OUTRA PARTE QUE POSSA MODIFICAR E/OU REDISTRIBUIR A BIBLIOTECA, CONFORME PERMITIDO ACIMA, SERÁ RESPONSÁVEL PARA COM VOCÊ POR DANOS, INCLUINDO ENTRE OUTROS QUAISQUER DANOS GERAIS, ESPECIAIS, FORTUITOS OU EMERGENTES, ADVINDOS DO USO OU IMPOSSIBILIDADE DE USO DA BIBLIOTECA (INCLUINDO, ENTRE OUTROS, PERDA DE DADOS, DADOS SENDO GERADOS DE FORMA IMPRECISA, PERDAS SOFRIDAS POR VOCÊ OU TERCEIROS OU A IMPOSSIBILIDADE DA BIBLIOTECA DE OPERAR COM QUALQUER OUTRO SOFTWARE), MESMO QUE ESSE TITULAR, OU OUTRA PARTE, TENHA SIDO AVISADO SOBRE A POSSIBILIDADE DESSES DANOS.
FIM DOS TERMOS E CONDIÇÕES

Como Aplicar Estes Termos para Suas Novas Bibliotecas

Se você desenvolver uma nova biblioteca e quiser que ela seja da maior utilidade possível para o público, nós recomendamos fazer dela um software livre que todos possam redistribuir e modificar. Você pode fazer isto permitindo a redistribuição sob estes termos (ou, alternativamente, sob os termos da Licença Pública Geral comum).

Para fazer isto, anexe as notificações seguintes à biblioteca. É mais seguro anexá-las ao começo de cada arquivo-fonte, de modo a transmitir do modo mais eficiente a exclusão de garantia; e cada arquivo deve ter ao menos a linha de "direitos autorais reservados" e uma indicação de onde a notificação completa se encontra.

    one line to give the library's name and an idea of what it does.
    Copyright (C) year name of author

    This library is free software; you can redistribute it and/or
    modify it under the terms of the GNU Library General Public
    License as published by the Free Software Foundation; either
    version 2 of the License, or (at your option) any later version.

    This library is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
    Library General Public License for more details.

    You should have received a copy of the GNU Library General Public
    License along with this library; if not, write to the
    Free Software Foundation, Inc., 59 Temple Place - Suite 330,
    Boston, MA  02111-1307, USA.

Inclua também informações sobre como contatar você por correio eletrônico e por meio postal.

Você também pode solicitar a seu empregador (se você for um programador) ou a sua instituição acadêmica, se for o caso, para assinar uma "renúncia de direitos autorais" sobre a biblioteca, se necessário. Segue um exemplo; altere os nomes:
    Yoyodyne, Inc., hereby disclaims all copyright interest in
    the library 'Frob' (a library for tweaking knobs) written
    by James Random Hacker.

    signature of Ty Coon, 1 April 1990
    Ty Coon, President of Vice
Isso é tudo!

LICENÇA PÚBLICA GERAL MENOR DO GNU

Versão 2.1, fevereiro de 1999

Copyright © 1991, 1999 Free Software Foundation, Inc.

59 Temple Place, Suite 330, Boston, MA 02111-1307 EUA

Qualquer pessoa está autorizada a copiar e a distribuir cópias literais desse documento de licença, mas não está autorizada a fazer alterações.

Preâmbulo

As licenças da maior parte dos softwares são criadas para retirar sua liberdade para compartilhar e alterá-los. Por oposição, as Licenças Públicas Gerais do GNU destinam-se a garantir sua liberdade para compartilhar e alterar software livre — para assegurar que o software é livre para todos os seus usuários.

A presente Licença Pública Geral Menor se aplica a alguns pacotes de software especialmente designados – normalmente bibliotecas – da Free Software Foundation e de outros autores que decidam utilizá-la. Você pode utilizá-la também, mas recomendamos que antes, você analise cuidadosamente se esta licença, ou a Licença Pública Geral comum, é a melhor estratégia a ser adotada em cada caso específico, tendo como base as explicações abaixo.

Quando falamos de software livre, estamos nos referindo a liberdade de uso e não de gratuidade de preço. Nossas Licenças Públicas Gerais são elaboradas para garantir que você tenha liberdade para distribuir cópias de software livre (cobrando por esse serviço se você assim o desejar); que você receba código-fonte ou o obtenha, se quiser; que você modifique o software e utilize partes dele em novos programas livres; e que você tenha ciência de que pode praticar estes atos.

A fim de proteger seus direitos, é necessário fazer restrições que proíbam os distribuidores de lhe negar esses direitos ou de pedir que renuncie a esses direitos. Essas restrições se traduzem em determinadas responsabilidades que deverá assumir se distribuir cópias da biblioteca ou se a alterar.

Por exemplo, se você distribuir cópias da biblioteca, seja gratuitamente ou mediante um valor, terá de conceder a seus receptores todos os direitos que estamos concedendo a você. Você terá de garantir que eles, também, recebam ou possam obter o código-fonte. Se você ligar outro código com a biblioteca, você deve fornecer os arquivos-objeto completos para os receptores, de modo que eles possam ligá-los novamente com a biblioteca após terem feito mudanças na biblioteca e recompilado a mesma. E você terá de exibir a eles esses termos, para que eles conheçam seus direitos.

Protegemos seus direitos através de um método que envolve dois passos: 1) estabelecemos direitos autorais sobre a biblioteca e (2) oferecemos a você esta licença, que dá a você permissão para copiar, distribuir e/ou modificar a biblioteca.

Para proteger cada distribuidor, queremos deixar bem claro que não há nenhuma garantia para a biblioteca livre. Além disso, se a biblioteca for modificada por alguém e passada adiante, os receptores devem saber que o que eles têm não é a versão original, de modo que a reputação do autor original não será afetada por problemas que possam ser introduzidos por outros.

Por fim, as patentes de software representam uma ameaça constante para a existência de qualquer programa livre. Queremos assegurar que uma empresa não possa efetivamente restringir os usuários de um programa livre por ter obtido uma licença restritiva de um titular de direitos de patente. Por isso, insistimos que qualquer licença de patente obtida para alguma versão da biblioteca seja consistente com a plena liberdade de uso, especificada nesta licença.

A maior parte dos softwares do GNU, incluindo algumas bibliotecas, está coberta pela Licença Pública Geral comum do GNU. A presente Licença Pública Geral Menor do GNU se aplica a determinadas bibliotecas designadas, sendo bastante diferente da Licença Pública Geral comum. Usamos esta licença para determinadas bibliotecas, a fim de permitir a ligação dessas bibliotecas a programas não livres.

Quando um programa é ligado a uma biblioteca, seja estaticamente ou usando uma biblioteca compartilhada, essa combinação das duas é em termos legais uma obra combinada, uma derivação da biblioteca original. Por essa razão, a Licença Pública Geral comum somente permite essa ligação se a combinação como um todo atender a seus critérios de liberdade. A Licença Pública Geral Menor permite critérios mais flexíveis para a ligação de outros códigos à biblioteca.

Chamamos esta licença de Licença Pública Geral "Menor" porque ela faz Menos para proteger a liberdade do usuário do que a Licença Pública Geral comum. Ela também oferece a outros desenvolvedores de software livre uma Menor vantagem na competição com programas não livres. Essas desvantagens são o motivo pelo qual usamos a Licença Pública Geral comum para muitas bibliotecas. Por outro lado, em determinadas circunstâncias especiais, a licença Menor oferece vantagens.

Por exemplo, em raras ocasiões, pode existir uma necessidade especial de se incentivar a mais ampla utilização possível de uma determinada biblioteca, para que ela se torne um padrão de fato. Para conseguir isso, deve-se permitir que programas não-livres utilizem a biblioteca. Um caso mais frequente ocorre quando uma biblioteca livre desempenha a mesma função de bibliotecas não livres amplamente usadas. Nesse caso, existem poucas vantagens em restringir a biblioteca livre somente para software livre, então utilizamos a Licença Pública Geral Menor.

Em outros casos, a permissão para usar uma determinada biblioteca em programas não-livres possibilita que um maior número de pessoas use um amplo leque de softwares livres. Por exemplo, a permissão para usar a Biblioteca C do GNU permite que muito mais pessoas usem todo o sistema operacional do GNU, bem como sua variante, o sistema operacional do GNU/Linux.

Mesmo protegendo a liberdade dos usuários em menor grau, a Licença Pública Geral Menor garante ao usuário de um programa que esteja ligado à Biblioteca a liberdade e os meios para executar o programa, usando uma versão modificada da Biblioteca.

Seguem abaixo os termos e condições exatos para a cópia, distribuição e modificação. Preste muita atenção à diferença entre uma "obra baseada na biblioteca" e uma "obra que usa a biblioteca". O primeiro contém código que é derivado da biblioteca, enquanto o segundo tem de ser combinado à biblioteca para que possa ser executado.

TERMOS E CONDIÇÕES PARA CÓPIA, DISTRIBUIÇÃO E MODIFICAÇÃO

  • 0. O presente Contrato de Licença se aplica a qualquer biblioteca de software ou a outro programa que contenha um aviso colocado pelo titular dos direitos autorais ou outra parte autorizada, informando que ela pode ser distribuída nos termos desta Licença Pública Geral Menor (também denominada "esta Licença"). Cada licenciado doravante será denominado "você".

    Uma "biblioteca" significa uma coleção de funções de software e/ou dados preparados, de forma a serem convenientemente ligados com programas de aplicação (que usam algumas dessas funções e dados) para formar executáveis.

    O termo "Biblioteca", abaixo, refere-se a qualquer biblioteca de software ou obra que tenha sido distribuída de acordo com esses termos. Uma "obra baseada na Biblioteca" significa tanto a Biblioteca como qualquer obra derivada, nos termos da legislação autoral: isto é, uma obra contendo a Biblioteca ou parte dela, seja sem alterações ou com modificações e/ou traduzida diretamente para outra linguagem. (Doravante, o termo "modificação" inclui, sem reservas, o termo "tradução").

    O código-fonte de uma obra significa o formato preferencial da obra para que sejam feitas modificações na mesma. Para uma biblioteca, o código-fonte completo significa todo o código fonte para todos os módulos contidos na mesma, além de quaisquer arquivos de definição de interface associados, além dos scripts utilizados para controlar a compilação e a instalação da biblioteca.

    Outras atividades que não a cópia, distribuição e modificação não são cobertas por esta Licença; elas estão fora de seu escopo. O ato de executar um programa usando a Biblioteca não tem restrições, e o resultado gerado a partir desse programa encontra-se coberto somente se seu conteúdo constituir uma obra baseada na Biblioteca (independente do uso da Biblioteca em uma ferramenta para escrevê-lo). Na verdade, isto dependerá daquilo que a Biblioteca faz e o que o programa que usa a biblioteca faz.

  • 1. Você pode copiar e distribuir cópias sem alterações do código-fonte completo da Biblioteca ao recebê-lo, em qualquer meio ou mídia, desde que publique, ostensiva e adequadamente, um aviso de direitos autorais (ou copyright) apropriado e uma notificação sobre a exoneração de garantias; mantenha intactas as informações, avisos ou notificações referentes a esta Licença e à ausência de qualquer garantia; e distribua uma cópia desta Licença junto com a Biblioteca.

    Você poderá cobrar um valor pelo ato físico de transferir uma cópia, e você pode oferecer, se quiser, a proteção de uma garantia em troca de um valor.

  • 2. Você pode modificar sua cópia ou cópias da Biblioteca ou qualquer parte dela, formando, assim, uma obra baseada na Biblioteca, bem como copiar e distribuir essas modificações ou obra, em conformidade com a Cláusula 1 acima, desde que atenda, ainda, a todas as seguintes condições:
    • a) A obra modificada tem de ser, por si só, uma biblioteca de software.
    • b) Você tem de fazer com que os arquivos modificados contenham avisos, em destaque, de que você modificou os arquivos e a data de qualquer modificação.
    • c) Você tem de fazer com que a obra como um todo seja licenciada, sem nenhum custo, a todos os terceiros, de acordo com esta Licença.
    • d) Se um dispositivo, na Biblioteca modificada, se referir a uma função ou a uma tabela de dados a ser fornecida por um programa de aplicação que usa esse dispositivo, outro que não um argumento transmitido quando o dispositivo é invocado, nesse caso, você terá de fazer um esforço de boa-fé para assegurar que, no caso de uma aplicação que não forneça essa função ou tabela, o dispositivo ainda assim opere, e irá realizar qualquer parte de sua finalidade que permanecer significativa. (Por exemplo, uma função de uma biblioteca para computar raízes quadradas tem uma finalidade que é completamente bem definida independentemente da aplicação. Por essa razão, a letra d, da Cláusula 2, exige que qualquer função ou tabela fornecida pela aplicação, usada por essa função, tem de ser opcional: se a aplicação não fornecê-la, a função de raízes quadradas deverá ainda assim computar raízes quadradas).

    Esses requisitos se aplicam à obra modificada como um todo. Se partes identificáveis dessa obra não forem derivadas da Biblioteca e puderem ser razoavelmente consideradas trabalhos independentes e separados, então essa Licença, e seus termos, não se aplicam a essas partes quando forem distribuídas como obras separadas. Porém, quando você distribuir essas mesmas partes como partes de um todo, que por si seja uma obra baseada na Biblioteca, a distribuição desse todo deverá ser realizada de acordo com esta Licença, cujas respectivas permissões para outros licenciados estendem-se à integralidade deste todo, dessa forma, a toda e qualquer parte, independentemente de quem a escreveu.

    Dessa forma, a intenção dessa seção não é exigir direitos ou contestar seus direitos sobre uma obra escrita inteiramente por você; em vez disso, essa seção pretende exercer o direito de controlar a distribuição de obras derivadas ou coletivas baseadas na Biblioteca.

    Além disso, a simples agregação de outra obra, que não seja baseada na Biblioteca, à Biblioteca (ou a uma obra baseada na Biblioteca) em um volume de meio mídia de armazenamento ou distribuição não inclui esta outra obra no âmbito dessa Licença.

  • 3. Você poderá optar por aplicar os termos da Licença Pública Geral do GNU ao invés desta Licença, para uma determinada cópia da Biblioteca. Para tanto, você deverá alterar todos os avisos ou notificações que se refiram a esta Licença, para que eles se refiram à Licença Pública Geral comum do GNU, versão 2, ao invés desta Licença. (Se uma versão mais nova do que a versão 2 da Licença Pública Geral comum do GNU tiver sido gerada, então você poderá especificar essa versão, se preferir). Não faça qualquer outra alteração nesses avisos.

    Uma vez que essa alteração tenha sido feita em uma determinada cópia, ela é irreversível para esta cópia, passando a Licença Pública Geral comum do GNU a ser aplicada para todas as cópias e obras derivadas subsequentes, feitas a partir dessa cópia.

    Essa opção é útil quando você desejar copiar parte do código da Biblioteca em um programa que não seja uma biblioteca.

  • 4. Você poderá copiar e distribuir a Biblioteca (ou uma parte ou obra derivada dela, de acordo com a Cláusula 2) em código-objeto ou formato executável, sob as Cláusulas 1 e 2 acima, desde que inclua todo o código-fonte correspondente, passível de leitura pela máquina, que deve ser distribuído sob os termos das Cláusulas 1 e 2 acima, em um meio ou mídia costumeiramente utilizado para o intercâmbio de software.

    Se a distribuição do código-objeto for feita pela oferta de acesso para cópia a partir de um local designado, então a permissão de acesso equivalente para copiar o código-fonte a partir do mesmo local atende a exigência de distribuição do código-fonte, mesmo que terceiros não sejam levados a copiar a fonte junto com o código-objeto.

  • 5. Um programa que não contenha nenhum derivativo de qualquer parte da Biblioteca, mas que seja desenhado para operar com a Biblioteca ao ser compilado ou ligado a ela, é chamado de uma "obra que usa a Biblioteca". Essa obra, isoladamente, não é uma obra derivada da Biblioteca e, portanto, fica de fora do âmbito desta Licença.

    Entretanto, a ligação de uma "obra que usa a Biblioteca" com a Biblioteca constitui um executável que é um derivado da Biblioteca (pois contém partes da Biblioteca), e não uma "obra que usa a Biblioteca". O executável é, assim, coberto por essa Licença. A Cláusula 6 estabelece os termos para a distribuição desses executáveis.

    Quando uma "obra que usa a Biblioteca" usar material de um arquivo de cabeçalho que é parte da Biblioteca, o código-objeto para a obra poderá ser uma obra derivada da Biblioteca, mesmo que o código-fonte não o seja. Para que isto seja verdade, é especialmente importante se a obra pode ser ligada sem a Biblioteca, ou se a obra é, em si mesma, uma biblioteca. O limite para que isso seja verdade não é definido de forma precisa pela lei.

    Se um arquivo-objeto usar somente parâmetros numéricos, layouts e accessors da estrutura de dados, bem como pequenas macros e pequenas funções inline (dez linhas ou menos de extensão), então o uso do arquivo-objeto não é restrito, independente de ser ele legalmente uma obra derivada. (Executáveis contendo este código-objeto mais partes da Biblioteca continuam submetidos aos termos da Cláusula 6).

    Do contrário, se a obra for um derivado da Biblioteca, você poderá distribuir o código objeto da obra sob os termos da Cláusula 6. Quaisquer executáveis contendo esta obra também se submetem à Cláusula 6, estejam ou não diretamente ligados à Biblioteca em si.

  • 6. Como exceção à Cláusula acima, você também pode combinar ou ligar uma "obra que usa a Biblioteca" à Biblioteca para produzir uma obra contendo partes da Biblioteca e distribuí-la de acordo com os termos de sua escolha, desde que estes termos permitam modificações na obra para uso próprio por parte do cliente e engenharia reversa para depuração dessas modificações.
    Em cada cópia da obra, você terá de colocar um aviso, em destaque, de que a Biblioteca foi usada e que ela e seu uso estão cobertos por essa Licença. Você deverá fornecer uma cópia desta Licença. Se, durante a execução, a obra exibir avisos ou notificações de direitos autorais (ou copyright), você terá de incluir, entre eles, o aviso de direitos autorais (ou copyright) referente à Biblioteca, bem como uma referência direcionando o usuário para a cópia desta Licença. Além disso, você dever tomar ao menos uma das seguintes providências:
    • a) Incluir na obra todo o código-fonte da Biblioteca, passível de leitura pela máquina, incluindo quaisquer modificações que foram usadas na obra (as quais devem ser distribuídas conforme as Cláusulas 1 e 2 acima); e, se a obra for um executável ligado à Biblioteca, com toda a "obra que usa a Bilblioteca" passível de leitura pela máquina, como código-objeto e/ou código-fonte, de modo que o usuário possa modificar a biblioteca e, depois, religar para produzir um executável modificado contendo a Biblioteca modificada. (Fica entendido que o usuário que modificar o conteúdo dos arquivos de definições da Biblioteca não necessariamente será capaz de recompilar a aplicação para usar as definições modificadas).
    • b) Usar um mecanismo adequado de biblioteca compartilhada para ligar com a Biblioteca. Um mecanismo adequado é aquele que (1) usa, ao tempo da execução, uma cópia da biblioteca já presente no sistema do computador do usuário, e (2) irá operar adequadamente com uma versão modificada da biblioteca, se o usuário instalar uma, desde que a versão modificada seja compatível com a interface da versão com a qual a obra foi feita.
    • c) Incluir na obra uma oferta por escrito, válida por pelo menos três anos, oferecendo ao mesmo usuário os materiais especificados na letra "a" da Cláusula 6 acima, por um custo não superior ao custo de fazer esta distribuição.
    • d) Se a distribuição da obra for feita com a permissão de acesso para copiar, a partir de um local designado, oferecer acesso equivalente para copiar os materiais acima especificados, a partir do mesmo local.
    • e) Certificar se o usuário já recebeu uma cópia desses materiais ou de que você já enviou uma cópia a esse usuário.

    Para um executável, o formato exigido da "obra que usa a Biblioteca" deve incluir quaisquer dados e programas utilitários necessários para reprodução do executável a partir dele. Porém, como uma exceção especial, os materiais a serem distribuídos não necessitam incluir algo que seja normalmente distribuído (tanto no formato fonte quanto binário) com os componentes mais importantes (compilador, kernel, e assim por diante) do sistema operacional no qual executável é executado, a menos que esse componente, em si, acompanhe o executável.

    Pode ocorrer que essa exigência contradiga as restrições da licença de outras bibliotecas proprietárias que normalmente não acompanham o sistema operacional. Essa contradição significa que você não pode utilizar ambas e a Biblioteca juntas em um executável distribuído por você.

  • 7. Você pode colocar dispositivos da biblioteca que sejam uma obra baseada na Biblioteca lado-a-lado em apenas uma biblioteca junto com outros dispositivos de bibliotecas, desde que uma distribuição separada da obra baseada na Biblioteca e dos outros dispositivos de bibliotecas seja, de outro modo, permitida e desde que você tome uma das seguintes providências:
    • a) Incluir na biblioteca combinada uma cópia dessa obra baseada na Biblioteca sem a combinação com quaisquer outros dispositivos de biblioteca. Essa cópia tem de ser distribuída de acordo com as condições das cláusulas acima.
    • b) Junto com a biblioteca combinada, fornecer um aviso, em destaque, sobre o fato de que parte dela é uma obra baseada na Biblioteca, e explicando onde encontrar o formato não combinado incluso dessa mesma obra.
  • 8. Você não poderá copiar, modificar, sublicenciar, ligar, ou distribuir a Biblioteca, exceto conforme expressamente disposto nesta Licença. Qualquer tentativa de, de outro modo, copiar, modificar, sublicenciar, ligar ou distribuir a Biblioteca é inválida, e automaticamente terminará seus direitos sob esta Licença. Todavia, terceiros que tiverem recebido cópias ou direitos de você, de acordo com esta Licença, não terão seus direitos rescindidos, enquanto estes terceiros mantiverem o seu pleno cumprimento.
  • 9. Você não é obrigado a aceitar esta Licença, uma vez que você não a assinou. Entretanto, nada mais concede a você permissão para modificar ou distribuir a Biblioteca ou suas obras derivadas. Esses atos são proibidos por lei se você não aceitar esta Licença. Portanto, ao modificar ou distribuir a Biblioteca (ou qualquer obra baseada na Biblioteca), você manifesta sua aceitação desta Licença para fazê-lo, bem como de todos os seus termos e condições para cópia, distribuição ou modificação da Biblioteca ou obras nela baseadas.
  • 10. A cada vez que você redistribuir a Biblioteca (ou qualquer obra nela baseada), o receptor automaticamente recebe uma licença do licenciante original para copiar, distribuir, ligar ou modificar a Biblioteca, sujeito a estes respectivos termos e condições. Você não poderá impor quaisquer restrições adicionais ao exercício, pelos receptores, dos direitos concedidos por este instrumento. Você não tem responsabilidade de promover o cumprimento desta licença por parte de terceiros.
  • 11. Se, como resultado de uma sentença judicial ou alegação de violação de patente, ou por qualquer outro motivo (não restrito às questões de patentes), forem impostas a você condições (tanto através de mandado judicial, contrato ou qualquer outra forma) que contradigam as condições desta Licença, você não estará desobrigado quanto às condições desta Licença. Se você não puder atuar como distribuidor de modo a satisfazer simultaneamente suas obrigações sob esta licença e quaisquer outras obrigações pertinentes, então, como consequência, você não poderá distribuir a Biblioteca de nenhuma forma. Por exemplo, se uma licença sob uma patente não permite a redistribuição por parte de todos aqueles que tiverem recebido cópias, direta ou indiretamente de você, sem o pagamento de royalties, então, a única forma de cumprir tanto com esta exigência quanto com esta licença será deixar de distribuir, por completo, a Biblioteca.

    Se qualquer parte desta Cláusula for considerada inválida ou não executável, sob qualquer circunstância específica, o restante da cláusula deverá continuar a ser aplicado e a cláusula, como um todo, deverá ser aplicada em outras circunstâncias.

    Esta cláusula não tem a finalidade de induzir você a infringir quaisquer patentes ou direitos de propriedade, nem de contestar a validade de quaisquer reivindicações deste tipo; a única finalidade desta cláusula é proteger a integridade do sistema de distribuição do software livre, o qual é implementado mediante práticas de licenças públicas. Muitas pessoas têm feito generosas contribuições à ampla gama de software distribuído através desse sistema, confiando na aplicação consistente deste sistema; cabe ao autor/doador decidir se deseja distribuir software através de qualquer outro sistema e um licenciado não pode impor esta escolha.

    Esta cláusula visa deixar absolutamente claro o que se acredita ser uma consequência do restante desta Licença.

  • 12. Se a distribuição e/ou uso da Biblioteca for restrito em determinados países, tanto por patentes ou por interfaces protegidas por direito autoral, o titular original dos direitos autorais que colocar a Biblioteca sob esta Licença poderá acrescentar uma limitação geográfica de distribuição explícita excluindo esses países, de modo que a distribuição seja permitida somente nos países ou entre os países que não foram excluídos dessa forma. Nesse caso, esta Licença passa a incorporar a limitação como se esta tivesse sido escrita no corpo desta Licença.
  • 13. A Free Software Foundation [Fundação Software Livre] poderá de tempos em tempos publicar versões revisadas e/ou novas da Licença Pública Geral Menor. Essas novas versões serão semelhantes em espírito à presente versão, podendo, porém, ter diferenças nos detalhes, para tratar de novos problemas ou preocupações.

    Cada versão recebe um número distinto de versão. Se a Biblioteca especificar um número de versão desta Licença, aplicável à Biblioteca ou a "qualquer versão posterior", você terá a opção de seguir os termos e condições tanto daquela versão como de qualquer versão posterior publicada pela Free Software Foundation. Se a Biblioteca não especificar um número de licença da versão, você poderá escolher qualquer versão já publicada pela Free Software Foundation.

  • 14. Se você desejar incorporar partes da Biblioteca em outros programas livres cujas condições de distribuição sejam incompatíveis com essas, escreva ao autor para solicitar sua permissão. Para software cujos direitos autorais pertencerem à Free Software Foundation, escreva à Fundação; algumas vezes, fazemos exceções nesse sentido. Nossa decisão será guiada pelos dois objetivos de preservar a condição livre de todos os derivados de nosso software livre e de promover o compartilhamento e reutilização de softwares, de modo geral.

    EXCLUSÃO DE GARANTIA

  • 15. COMO A BIBLIOTECA É LICENCIADA SEM CUSTO, NÃO HÁ NENHUMA GARANTIA PARA A BIBLIOTECA, NO LIMITE PERMITIDO PELA LEI APLICÁVEL. EXCETO QUANDO DE OUTRA FORMA ESTABELECIDO POR ESCRITO, OS TITULARES DOS DIREITOS AUTORAIS E/OU OUTRAS PARTES FORNECEM A BIBLIOTECA "NO ESTADO EM QUE SE ENCONTRA", SEM NENHUMA GARANTIA DE QUALQUER TIPO, TANTO EXPRESSA COMO IMPLÍCITA, INCLUINDO, DENTRE OUTRAS, AS GARANTIAS IMPLÍCITAS DE COMERCIABILIDADE E ADEQUAÇÃO PARA UMA FINALIDADE ESPECÍFICA. O RISCO INTEGRAL QUANTO À QUALIDADE E DESEMPENHO DA BIBLIOTECA É ASSUMIDO POR VOCÊ. CASO A BIBLIOTECA CONTENHA DEFEITOS, VOCÊ ARCARÁ COM OS CUSTOS DE TODOS OS SERVIÇOS, REPAROS OU CORREÇÕES NECESSÁRIAS.
  • 16. EM NENHUMA CIRCUNSTÂNCIA, A MENOS QUE EXIGIDO PELA LEI APLICÁVEL OU ACORDADO POR ESCRITO, QUALQUER TITULAR DE DIREITOS AUTORAIS OU QUALQUER OUTRA PARTE QUE POSSA MODIFICAR E/OU REDISTRIBUIR A BIBLIOTECA, CONFORME PERMITIDO ACIMA, SERÁ RESPONSÁVEL PARA COM VOCÊ POR DANOS, INCLUINDO ENTRE OUTROS QUAISQUER DANOS GERAIS, ESPECIAIS, FORTUITOS OU EMERGENTES, ADVINDOS DO USO OU IMPOSSIBILIDADE DE USO DA BIBLIOTECA (INCLUINDO, ENTRE OUTROS, PERDA DE DADOS, DADOS SENDO GERADOS DE FORMA IMPRECISA, PERDAS SOFRIDAS POR VOCÊ OU TERCEIROS OU A IMPOSSIBILIDADE DA BIBLIOTECA DE OPERAR COM QUALQUER OUTRO SOFTWARE), MESMO QUE ESSE TITULAR, OU OUTRA PARTE, TENHA SIDO AVISADO SOBRE A POSSIBILIDADE DESSES DANOS.
FIM DOS TERMOS E CONDIÇÕES

Como Aplicar Estes Termos para Suas Novas Bibliotecas

Se você desenvolver uma nova biblioteca e quiser que ela seja da maior utilidade possível para o público, nós recomendamos fazer dela um software livre que todos possam redistribuir e modificar. Você pode fazer isto permitindo a redistribuição sob estes termos (ou, alternativamente, sob os termos da Licença Pública Geral comum).

Para fazer isto, anexe as notificações seguintes à biblioteca. É mais seguro anexá-las ao começo de cada arquivo-fonte, de modo a transmitir do modo mais eficiente a exclusão de garantia; e cada arquivo deve ter ao menos a linha de "direitos autorais reservados" e uma indicação de onde a notificação completa se encontra.

    one line to give the library's name and an idea of what it does.
    Copyright (C) year name of author

    This library is free software; you can redistribute it and/or
    modify it under the terms of the GNU Lesser General Public
    License as published by the Free Software Foundation; either
    version 2.1 of the License, or (at your option) any later version.

    This library is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
    Lesser General Public License for more details.

    You should have received a copy of the GNU Lesser General Public
    License along with this library; if not, write to the Free Software
    Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA

Inclua também informações sobre como contatar você por correio eletrônico e por meio postal.

Você também pode solicitar a seu empregador (se você for um programador) ou a sua instituição acadêmica, se for o caso, para assinar uma "renúncia de direitos autorais" sobre a biblioteca, se necessário. Segue um exemplo; altere os nomes:
    Yoyodyne, Inc., hereby disclaims all copyright interest in
    the library 'Frob' (a library for tweaking knobs) written
    by James Random Hacker.

    signature of Ty Coon, 1 April 1990
    Ty Coon, President of Vice
Isso é tudo!


Direitos autorais

© 2016 Pitney Bowes Software Inc. Todos os direitos reservados.

Esse documento pode conter informações confidenciais ou protegidas por direitos autorais pertencentes à Pitney Bowes Inc. e/ou a seus subsidiários e suas empresas associadas.

Portrait Software, o logotipo Portrait Software, Portrait e a marca Portrait Software’s Portrait são marcas comerciais da Portrait Software International Limited e não podem ser usadas nem exploradas de forma alguma sem prévia autorização expressa por escrito da Portrait Software International Limited.

Reconhecimento de marcas comerciais

Outros nomes do produto, nomes, marcas, logotipos e símbolos da empresa referenciados aqui podem ser marcas comerciais ou marcas comerciais registradas de seus proprietários registrados.

Suporte Portrait Software

Se precisar de ajuda com algo que não se encontre nesses documentos, visite a Base de Conhecimentos em nosso site da Web. http://support.portraitsoftware.com e siga os links para seu produto.

Também é possível baixar outros documentos da Portrait Software a partir desse site. Se não tiver um nome de usuário e senha - ou se os esqueceu - contate-nos através de um dos canais abaixo.

Se tiver algum problema com o uso, a instalação ou os documentos desse produto, contate-nos usando um dos seguintes métodos:

E-mail: support@portraitsoftware.com

Telefone

  • EUA/Canadá 1-800-335-3860 (número gratuito)
  • Resto do mundo +44 800 840 0001

Quando estiver reportando um problema, ajuda se nos disser:

  • O nome do aplicativo de software
  • As circunstâncias em que o problema apareceu
  • Que mensagens de erro você viu (se tiver visto alguma)
  • A versão do software que você estava usando

Pitney Bowes Software Inc.

February 23, 2016


Online Help