Introduction

  • Présentation de Portrait Miner
© 2015 Pitney Bowes Software Inc. Email: software.support@pb.com


Présentation de Portrait Miner

Portrait Miner est une solution d'analyse prévisionnelle efficace permettant aux spécialistes de la connaissance client ainsi qu'aux professionnels d'obtenir une vision précise de leur clientèle pour mieux la comprendre, d'identifier les points à améliorer, de parvenir à une segmentation optimale et de prévoir les comportements futurs.

Comblant le fossé entre les outils d'exploitation de données standard, qui offrent un champ limité d'exploration des données, et les solutions de calculs en masse, qui exigent des statisticiens pour créer des requêtes et générer des modèles, Portrait Customer Analytics est une solution nouvelle génération conçue pour offrir une facilité d'utilisation inégalée, et un rapide aperçu des actions à entreprendre.

Cette solution utilise un puissant mode de visualisation des données en 3D et un module d'automatisation de modélisation rapide permettant de mettre en évidence d'importantes relations entre les données et de générer des scores de propension en un seul clic, stimulant ainsi la précision des modèles prédictifs et augmentant la vitesse des résultats analytiques.

Portrait Miner permet de prévoir les comportements et propensions ayant un impact sur les revenus d'une entreprise, comme les pertes de clients, les opportunités de vente incitative (montée en gamme) et de vente croisée, la planification et la segmentation d'une campagne, la satisfaction et la fidélité de la clientèle et la valeur du capital client sur le long terme.

Sujet parent : Introduction


Démarrer

  • Lancement de Portrait Miner
  • Ajout ou suppression des informations des serveurs Portrait Miner
  • Ouverture ou enregistrement d'un fichier, d'une session ou d'une table de base de données
  • Utilisation des fichiers sur les disques locaux
  • Manipulation des fichiers focus dans Portrait Miner
  • Affichage et modification de fichiers texte dans Portrait Miner
  • À propos du codage de texte
  • Utilisation des fichiers de session


Lancement de Portrait Miner

  1. Vous avez le choix entre les méthodes suivantes :
    • Double-cliquez sur le raccourci bureau de Portrait Miner. Portrait Miner démarre.
    • Allez dans le menu Démarrer de Windows et, sous Programmes>Portrait Miner, choisissez Portrait Miner.
  2. Si la fenêtre de connexion s'affiche, saisissez votre nom d'utilisateur et votre mot de passe pour le serveur Portrait Miner et cliquez sur OK.

    Votre administrateur système doit être en mesure de vous indiquer quel le serveur utiliser (si plusieurs) ainsi que votre nom d'utilisateur et mot de passe pour ce serveur. Si le système d'exploitation de votre serveur est Windows, votre nom d'utilisateur et votre mot de passe doivent être appropriés pour le domaine Windows que vous avez configuré dans les détails du serveur.

    Si vous n'avez jamais utilisé Portrait Miner et que le menu Serveur est vide, reportez-vous à la section Ajout ou suppression des informations des serveurs Portrait Miner.

    Une fois que vous êtes connecté à un serveur Portrait Miner, vous pouvez exécuter d'autres applications de Portrait Miner, elles se connecteront au même serveur sans vous inviter à vous connecter de nouveau. Vous resterez connecté au serveur Portrait Miner jusqu'à ce que vous vous déconnectiez explicitement (en choisissant Fichier>Déconnexion dans toutes les applications Portrait Miner) ou que vous quittiez votre dernière application Portrait Miner ouverte (en choisissant Fichier>Quitter ou en cliquant sur [image] dans la fenêtre principale de l'application).

Sujet parent : Démarrer


Ajout ou suppression des informations des serveurs Portrait Miner

Lors de la première utilisation de Portrait Miner, le menu Serveur de la fenêtre de connexion est vide (à moins que votre administrateur système l'ait configuré pour vous).

Si vous voulez ajouter une entrée au menu Serveur, vous devez connaître le nom du réseau du serveur Portrait Miner ainsi que son numéro de port. Votre administrateur système doit être en mesure de vous fournir cette information.

Sujet parent : Démarrer

Ajout d'un serveur au menu Serveur

  1. Dans la fenêtre de connexion, cliquez sur Serveurs pour afficher la boîte de dialogue Serveurs :

  2. Cliquez sur Ajouter pour afficher la boîte de dialogue Ajouter un serveur :

  3. Dans la zone Nom, saisissez la description du serveur utilisé dans la liste Serveur de la fenêtre de connexion.
  4. Dans la zone Serveur, saisissez le nom du réseau du serveur Portrait Miner (par exemple : nomserveur.nomsociete.com).
  5. Sélectionnez Unix ou Windows en fonction du système d'exploitation du serveur Portrait Miner. Si vous choisissez Windows, spécifiez le domaine Windows auquel vous vous connecterez, ou bien utilisez le paramètre par défaut (« Local ») pour spécifier un compte local sur le serveur.
  6. Dans la zone Port, saisissez le numéro de port pour lequel le serveur a été configuré.
  7. Cliquez sur OK pour ajouter les informations sur le nouveau serveur.
  8. Dans la boîte de dialogue Serveurs, cliquez sur Fermer pour revenir à la fenêtre de connexion.

Modification des informations d'un serveur

  1. Cliquez sur le bouton Serveurs.
  2. Surlignez un serveur disponible et cliquez sur Modifier.

    La boîte de dialogue Modifier la configuration du serveur apparaît. Elle est pratiquement identique à la boîte de dialogue Ajouter un serveur [voir Ajout d'un serveur au menu Serveur].

  3. Modifiez le nom, le serveur ou le port au besoin et cliquez sur OK.
  4. Cliquez sur Fermer, pour fermer la boîte de dialogue Serveurs .

Suppression d'un serveur dans le menu Serveurs

  1. Cliquez sur le bouton Serveurs.
  2. Surlignez le serveur que vous voulez supprimer et cliquez sur Supprimer.
  3. Cliquez sur Fermer.


Ouverture ou enregistrement d'un fichier, d'une session ou d'une table de base de données

Dans Portrait Miner, un explorateur de fichiers s'affiche à chaque fois que vous ouvrez ou enregistrez un fichier, une session ou une table de base de données. Il est similaire aux explorateurs de fichiers des autres applications de Windows, mais il a des variantes qui vous permettent de naviguer parmi les fichiers de votre PC, de votre serveur Portrait Miner (dans la version client-serveur du logiciel) et parmi les tables de vos bases de données.

Lorsque vous ouvrez ou enregistrez un jeu de données, l'explorateur de fichiers contient jusqu'à trois onglets intitulés « Quadstone », « Tous les fichiers », et « SGBDR », comme dans l'exemple suivant :

Sujet parent : Démarrer

Navigation dans Portrait Miner

Les onglets « Quadstone » et « Tous les fichiers » affichent tous les deux des fichiers et des dossiers dans Portrait Miner, mais le premier est légèrement plus restrictif :
 | Onglet « Quadstone » | Onglet « Tous les fichiers »
Dossiers affichés | Tous les dossiers sauf : les dossiers avec les extensions de noms de fichiers .rdx et .xtr, qui contiennent des fichiers de données pour focus ; les dossiers qui ont des noms commençant par un point (.) | Tous les dossiers
Fichiers affichés lorsque Fichiers de type est défini dans Tous les fichiers | Tous les fichiers sauf : les fichiers avec les extensions de noms de fichiers tels que.fcs, .mid, .mdh, .spa et .x86 ; les fichiers dont les noms se terminent par un tilde (~) ; les fichiers dont les noms commencent par un point (.) | Tous les fichiers
Fichiers affichés lorsque Fichiers de type est défini pour un type de fichier particulier | Seulement les fichiers avec la ou les extensions de nom de fichier données) | Comme « Quadstone »

Si vous enregistrez un jeu de données en tant que fichier texte ou focus, assurez-vous d'avoir choisi le type requis dans le sélecteur Fichiers de type.

Remarque :
  • Portrait Miner affiche normalement les mêmes fichiers et dossiers qu'un explorateur de fichiers affiche sous l'onglet Quadstone. Vous pouvez afficher les fichiers et dossiers qu'un explorateur de fichiers affiche sous l'onglet Tous les fichiers en choisissant Afficher>Afficher les fichiers masqués.
  • Portrait Miner génère des fichiers journaux à des fins administratives. Pour atteindre le dossier qui contient ces fichiers journaux, cliquez sur [image] dans la barre d'outils.
  • Pour atteindre le dossier précédent, suivant ou parent, cliquez sur [image], sur [image] ou sur [image] dans la barre d'outils.
  • Pour accéder directement au dossier par défaut, (le paramètre de préférence accueil qsexplorer), cliquez sur
  • Vous pouvez directement accéder à un dossier arbitraire en choisissant Afficher >Atteindre... et en saisissant le nom du dossier.

Navigation dans les bases de données, les espaces de noms et les tables

Vous pouvez parcourir les bases de données en utilisant l'onglet « SGBDR », lorsqu'il est présent. (« SGBDR » signifie « Système de Gestion de Base de Données Relationnelle »). Cet onglet affiche d'abord une liste des bases de données disponibles. Vous pouvez naviguer dans une hiérarchie de base de données, jusqu'au niveau des tables individuelles, exactement de la même manière que vous naviguez dans le système de fichiers.

Voir également

Configuration d'une connexion à une base de données

Utilisation des sessions sur votre PC

Vous pouvez parcourir les sessions précédemment enregistrées (fichiers .pms) en cliquant sur le menu Fichier > Ouvrir une session . Dans ce cas, l'explorateur de fichiers affiche un seul onglet intitulé « Poste de travail » avec les fichiers .pms présélectionnés.

Dans ces cas, l'explorateur de fichiers affiche un seul onglet, intitulé « Poste de travail » :

Vous pouvez rechercher et enregistrer des fichiers sur votre PC comme vous le feriez dans n'importe quelle autre application Windows.

Utilisation des fichiers sur votre PC

Vous pouvez enregistrer certains types de fichiers sur votre PC (ou sur un lecteur réseau accessible depuis votre PC). Ces fichiers comprennent des graphiques exportés et des tableaux croisés enregistrés.

Dans ces cas, l'explorateur de fichiers affiche un seul onglet, intitulé « Poste de travail » :

Vous pouvez rechercher et enregistrer des fichiers sur votre PC comme vous le feriez dans n'importe quelle autre application Windows.


Utilisation des fichiers sur les disques locaux

Même si vous n'avez pas d'accès direct à votre machine de serveur Portrait Miner, vous pouvez enregistrer et ouvrir certains fichiers (tels que les scripts, les images et les tableaux croisés) sur votre PC. Pour utiliser un fichier de données qui est sur votre PC (ou un lecteur réseau accessible), vous pouvez faire glisser un fichier de données de l'Explorateur Windows vers un dossier dans Portrait Miner.

Une copie du fichier apparaît dans le dossier sur le serveur de Portrait Miner, que vous pouvez ensuite utiliser directement.

Remarque : Tout comme le déplacement des fichiers de l'Explorateur Windows vers Portrait Miner, vous pouvez faire glisser les fichiers dans la direction opposée pour les copier depuis le serveur de Portrait Miner vers un disque local.

Voir également

Affichage et modification de fichiers texte dans Portrait Miner
Sujet parent : Démarrer


Manipulation des fichiers focus dans Portrait Miner

Un focus est stocké sur disque sous forme de fichier .ftr (le « fichier focus ») avec un ensemble de fichiers de données et d'autres fichiers dans deux dossiers, avec des extensions .rdx (« Raw Data eXtract ») et .xtr (« eXTRa »). Les dossiers sont normalement masqués dans Portrait Miner et dans l'onglet « Quadstone » d'un explorateur de fichiers Portrait Miner [voir Ouverture ou enregistrement d'un fichier, d'une session ou d'une table de base de données].

Un focus créé par copie d'un focus existant ou par importation de données depuis un autre type de base de données (ou à la suite de l'exécution d'un script TML) est indépendant des autres focus. En revanche, un focus qui est enregistré depuis Decision Studio avec un nouveau nom, ou un autre qui est créé en faisant une copie liée est dépendant des dossiers de données appartenant à d'autres focus.

En raison de l'interdépendance potentielle des focus, vous ne devez pas copier, déplacer, renommer ni supprimer des fichiers focus ni des dossiers utilisant des utilitaires de système d'exploitation, par exemple, Windows Explorer ou les outils de ligne de commande UNIX. Vous devez toujours utiliser Portrait Miner (ou les commandes data build de Portrait Miner) à la place.
Sujet parent : Démarrer

Copie ou déplacement d'un fichier focus vers un autre dossier

  1. Dans Portrait Miner, cliquez sur le fichier focus que vous voulez copier ou déplacer.
  2. Vous avez le choix entre les méthodes suivantes :
    Copie d'un fichier | Déplacement d'un fichier
    Choisissez Modifier>Copier. | Choisissez Modifier>Couper.
    Cliquez avec le bouton droit et choisissez Copier. | Cliquez avec le bouton droit et choisissez Couper.
    Cliquez sur [image] dans la barre d'outils. | Cliquez sur [image] dans la barre d'outils.
    Appuyez sur CTRL+C. | Appuyez sur CTRL+X.
  3. Accédez au dossier de destination.
  4. Choisissez Modifier>Coller, cliquez droit et choisissez Coller, cliquez sur [image] dans la barre d'outils ou appuyez sur CTRL+V.
Remarque :
  • Vous pouvez copier un fichier focus sous forme de un focus indépendant (comme ci-dessus), auquel cas les données elles-mêmes sont dupliquées. Vous pouvez également créer une copie liée, qui partage des données avec le focus original. Vous pouvez le faire avec Coller le lien au lieu de Coller. Il n'existe pas de raccourci dans la barre d'outils. Vous ne pouvez pas créer une copie liée lorsque vous déplacez un fichier focus.
  • Vous pouvez également choisir un nouveau nom pour un focus que vous déplacez ou copiez en choisissant Coller comme ou (lorsque vous le copiez) Coller le lien comme.
  • Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par les commandes data build qscopy, qslink et qsmove de Portrait Miner.
  • Vous pouvez également copier ou déplacer des fichiers non focus (mais pas créer des copies liées) de la même façon.

Voir également

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Renommage d'un fichier focus

  1. Dans Portrait Miner, cliquez sur le fichier que vous voulez renommer.
  2. Choisissez Modifier>Renommer, cliquez avec le bouton droit et choisissez Renommer, ou cliquez tout simplement une seconde fois sur le nom du fichier.

    Le nom du fichier devient modifiable.

Remarque :
  • Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsmove de Portrait Miner.
  • Vous pouvez également renommer les fichiers non focus et les dossiers de la même façon.

Voir également

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Suppression d'un fichier focus

Vous pouvez utiliser Portrait Miner pour supprimer de manière récursive une chaîne entière de focus : sélectionnez le focus à supprimer, et tous les focus qui en dépendent sont également supprimés. La confirmation du focus qui sera supprimé est affichée et vous avez le choix de continuer ou d'arrêter complètement l'opération de suppression.

  1. Dans Portrait Miner, cliquez sur le fichier que vous voulez supprimer.
  2. Choisissez Modifier>Supprimer, cliquez droit et choisissez Supprimer, cliquez sur [image] dans la barre d'outils ou appuyez sur Supprimer.
Remarque :
  • Cette interface utilisateur accède à la plupart des fonctionnalités fournies par la commande data build qsremove de Portrait Miner.
  • Vous pouvez également supprimer les fichiers non focus et les dossiers de la même façon. Avant de supprimer un dossier, vous devez d'abord supprimer tous les fichiers focus contenus dans ce dossier.

Voir également

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Création d'un fichier archive

Vous pouvez créer un fichier archive à partir d'un focus ou d'un dossier qui contient un ensemble de focus connexes ou de sous-dossiers.

Dans Portrait Miner, cliquez avec le bouton droit sur le fichier ou le dossier que vous voulez archiver et choisissez Archiver pour un dossier, ou Exporter>pour archiver pour un focus.

Dans la boîte de dialogue Archiver dans le fichier ZIP, spécifiez un nom de fichier de sortie.

Remarque :
  • Si vous créez un fichier d'archive dans un dossier qui contient des focus qui renvoient vers des données en dehors du dossier, les données externes sont copiées dans l'archive. Vous avez ainsi la garantie de toujours obtenir un ensemble cohérent de focus associés lorsque vous extrayez le fichier d'archive.
  • Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsarchive de Portrait Miner.

Voir également

À propos des assistants Portrait Miner

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Extraction d'un fichier archive

Dans Portrait Miner, cliquez avec le bouton droit sur le fichier d'archive que vous souhaitez extraire et choisissez Extraire.

Dans la boîte de dialogue Extraire de l'archive ZIP, Indiquez un dossier de sortie et si vous souhaitez écraser les fichiers existants.

Remarque : Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsunzip de Portrait Miner.

Voir également

À propos des assistants Portrait Miner

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données


Affichage et modification de fichiers texte dans Portrait Miner

La modification ou l'affichage d'un fichier Portrait Miner dépend du type de fichier. Il est possible de :
  • cliquer avec le bouton droit sur le fichier et choisir Modifier, pour modifier (ou afficher) le fichier dans le Bloc-notes,
  • cliquer avec le bouton droit sur le fichier et choisir Afficher, pour afficher le fichier dans une application appropriée,
  • faire un double-clic sur le fichier comme alternative aux choix énoncés ci-dessus.
Type de fichier | Modification | Affichage | Double-cliquer
Fichier de données texte (.txt, .dat, .csv, .tab, .fdf), fichier de description de données texte (.fdd) |  |  | — (Ouvrir [voir Création d'un focus à partir de données dans un fichier texte])
Fichier SQL (.sql) |  |  | — (Ouvrir)
Bloc-notes. Fichier script TML (.tml), fichier de calcul FDL (.fdl), fichier de hiérarchie de segmentation qualitative (.hrc) |  |  | Modification
Fichier journal (.log) |  |  | Affichage
Fichier XML(.xml, .qmml, etc.) |  |  | Affichage
Remarque :
  • Même si vous n'avez pas d'accès direct à votre machine serveur Portrait Miner, vous pouvez encore afficher et, le cas échéant, modifier des fichiers texte sur le serveur. Il existe deux versions de Portrait Miner : une version client-serveur, et Portrait Miner Desktop. Si vous utilisez la version client-serveur, lorsque vous utilisez Portrait Miner pour afficher ou modifier un fichier texte dans le Bloc-notes, vous travaillez en fait avec une copie locale du fichier. Si vous enregistrez le fichier, mais que le bloc-notes reste ouvert, la version sur le serveur reste inchangée. Portrait Miner copie uniquement la version mise à jour sur votre PC sur le serveur lorsque vous quittez le bloc-notes.
  • Vous devez utiliser un encodage ISO-8859-1 (Latin-1) lors de l'enregistrement des fichiers texte.

Voir également

Manipulation des fichiers focus dans Portrait Miner

Utilisation des fichiers sur les disques locaux

XML dans Portrait Miner

Sujet parent : Démarrer


À propos du codage de texte

Les fichiers texte de Portrait Miner sont codés au format Unicode, tel que défini par la BOM (Byte Order Mark) du fichier. Sous Windows, un fichier sans BOM est considéré par le système comme ANSI selon les préférences régionales de la machine, par exemple, Windows 1215 en Europe et aux États-Unis, et CP932 au Japon Sur une machine Solaris, un fichier sans BOM est considéré comme codé au format latin-1.

Sujet parent : Démarrer


Utilisation des fichiers de session

Si vous travaillez sur l'un des outils d'affichage de Portrait Miner (Aperçu du tableau croisé, Aperçu 3D, Aperçu du profil ou Aperçu de la carte) et que vous souhaitez sauvegarder votre affichage en cours, vous pouvez utiliser l'option Fichier > Enregistrer la session dans la fenêtre Decision Studio. Les fichiers sont enregistrés avec l'extension (.pms) et sont précédés par défaut du nom de fichier focus.
Les sessions enregistrées peuvent être chargées à partir de Decision Studio, ou en double-cliquant sur le fichier .pms dans la fenêtre de l'explorateur de Portrait Miner.
Remarque :
Session files are directly linked to the associated focus file and must reside in the same directory.

Télécharger ou ouvrir une session enregistrée

Vous pouvez charger des sessions enregistrées pour les outils Portrait Miner suivants :

  • Aperçu du tableau croisé
  • Aperçu 3D
  • Aperçu du profil
  • Aperçu de la carte
    Remarque : Tous les fichiers de sessions enregistrés sont directement liés au fichier focus à partir duquel ils ont été créés.
Télécharger une session enregistrée à partir de Portrait Miner
  1. Ouvrez Portrait Miner et accédez à votre répertoire de sessions enregistrées.
  2. Double-cliquez sur le fichier de session enregistré (.pms). La session télécharge les données focus et la session enregistrée associées.
Ouvrir une session enregistrée à partir de Decision Studio
  1. Ouvrez Decision Studio.
  2. Sélectionnez Fichier > Ouvrir une session et recherchez le fichier de session correspondant (.pms). La session télécharge les données focus et la session enregistrée associées.

Enregistrer une session

Vous pouvez enregistrer les détails d'une session individuelle pour les outils Portrait Miner suivants :

  • Aperçu du tableau croisé
  • Aperçu 3D
  • Aperçu du profil
  • Aperçu de la carte
Enregistrer une session
  1. En conservant la session ouverte, passez à la fenêtre Decision Studio et sélectionnez Fichier>Enregistrer la session.
  2. Ajoutez votre nom de fichier au préfixe par défaut dans la boîte de dialogue Enregistrer la session. Remarque : Le préfixe sert à identifier le fichier focus associé à la session.
Sujet parent : Démarrer


Fichiers texte, tables de bases de données et focus

  • À propos des assistants Portrait Miner
  • Ouverture d'un focus pour la visualisation, la segmentation et la modélisation
  • Tri d'un focus
  • Conversion d'un focus base transaction en focus base client
  • Création d'un focus à partir de données dans un fichier texte
  • Création d'un focus à partir de données dans une base de données
  • Création d'un focus à partir d'un jeu de données SAS ou tiers
  • Exportation d'enregistrements de fichiers de données, d'une table de base de données ou d'un focus
  • À propos de l'assemblage de focus
  • Jonction de champs d'un focus à un autre focus avec Portrait Miner
  • Jonction de champs d'un focus à un autre à l'aide de Decision Studio
  • Fusion des entrées de deux focus
  • Configuration d'une connexion à une base de données
  • Importation des types de base de données par Portrait Miner
  • Utilisation de Data Build Manager pour l'importation, le traitement et l'exportation de données
  • Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données


À propos des assistants Portrait Miner

Les assistants Portrait Miner s'ouvrent depuis Portrait Miner, après que vous avez sélectionné un focus ou un autre fichier, et fournissent un accès à l'interface utilisateur aux commandes data build de Portrait Miner.

Chaque assistant affiche les paramètres de commande sous un onglet Paramètres. Les valeurs de l'onglet Paramètres peuvent être modifiées soit en effectuant directement une saisie dans le champ, soit en cliquant sur Parcourir [image] pour afficher une autre boîte de dialogue à partir de laquelle une valeur peut être sélectionnée.

Lorsque tous les paramètres obligatoires (indiqués par un astérisque rouge dans le champ du paramètre) ont été sélectionnés, cliquez sur Lancer pour exécuter la commande data build associée. Si nécessaire, vous pouvez stopper la commande en cliquant sur le bouton Stop ; par exemple, si vous vous êtes trompé de paramètre.

Lorsque l'opération est terminée, les résultats sont affichés sous l'onglet Sortie. Si des erreurs se produisent durant le traitement de la commande, un message d'erreur est affiché sous l'onglet Erreur.

Voir également

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données
Sujet parent : Fichiers texte, tables de bases de données et focus


Ouverture d'un focus pour la visualisation, la segmentation et la modélisation

Après avoir obtenu les données client dans un formulaire de focus, vous pouvez l'ouvrir dans Decision Studio pour analyse à l'aide d'une gamme d'outils [voir Outils Decision Studio] pour la visualisation, la segmentation et la modélisation.

Un focus peut être ouvert à l'aide d'une des options suivantes :

  • Dans Portrait Miner, double-cliquez sur le focus que vous désirez ouvrir ou cliquez avec le bouton droit sur le focus et choisissez Ouvrir.
  • Dans une fenêtre Decision Studio avec le focus ouvert, choisissez Fichier>Fermer, pour fermer le focus ouvert. Ensuite, choisissez Fichier>Ouvrir ou cliquez sur [image] dans la barre d'outils et accédez au focus que vous souhaitez ouvrir.

    Si vous avez modifié un focus depuis sa création ou depuis qu'il est ouvert, Decision Studio vous permet d'enregistrer ces modifications avant de le fermer.

Remarque :
  • Si le focus est en lecture seule, utilisez Fichier>Enregistrer sous ou cliquez sur [image] dans la barre d'outils et choisissez un nouveau nom ou un nouvel emplacement pour votre focus ou copiez le focus dans un nouvel emplacement. Certaines fonctionnalités et options ne marchent pas avec un focus en lecture seule.
  • Dans une session Decision Studio, vous ne pouvez ouvrir qu'un seul focus à la fois.

    Cependant, vous pouvez avoir plusieurs sessions Decision Studio à la fois.

  • Deux utilisateurs ou plus peuvent ouvrir le même focus et l'utiliser dans Decision Studio. Bien entendu, vous devez vous assurer que lorsque vous enregistrez le focus, vous n'enregistrez pas le travail d'un autre utilisateur.

Voir également

Création d'un focus à partir de données dans une base de données

Création d'un focus à partir de données dans un fichier texte

Lancement de Portrait Miner

Sujet parent : Fichiers texte, tables de bases de données et focus


Tri d'un focus

Vous pouvez trier les enregistrements dans un focus en fonction des valeurs dans un maximum de trois champs.
Pour trier un focus, procédez comme suit :
  • Dans Portrait Miner, cliquez avec le bouton droit sur le focus que vous voulez trier et choisissez Transformer>Trier.

Dans la boîte de dialogue Trier le focus, choisissez jusqu'à trois champs clés pour déterminer l'ordre du focus trié. Vous pouvez aussi modifier l'emplacement du nouveau focus ou choisir de remplacer un focus de sortie créé précédemment.

Remarque :
  • Si vous choisissez plus d'un champ, la clé de tri primaire est le champ sélectionné qui apparaît en premier dans le focus et la clé de tri secondaire est le champ sélectionné qui apparaît en second Si vous choisissez trois champs, l'autre champ correspond à la clé de tri tertiaire.
  • Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qssort de Portrait Miner.

Voir également

À propos des assistants Portrait Miner

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Sujet parent : Fichiers texte, tables de bases de données et focus

Vérification de l'ordre de tri d'un focus

Dans Portrait Miner, cliquez avec le bouton droit sur le focus que vous voulez vérifier, et choisissez Transformer>Vérifier l'ordre de tri.

Dans la boîte de dialogue Vérifier l'ordre de tri, choisissez des champs clés. Portrait Miner vérifiera si le focus est trié en fonction de ces champs.


Conversion d'un focus base transaction en focus base client

Pour l'analyse des données client, vous avez besoin de données base client. Si vous avez un focus base transaction, c'est-à-dire, un focus dans lequel chaque enregistrement représente une transaction client, vous pouvez calculer des statistiques agrégées par client pour créer des champs dans une nouveau focus base client. Vous pouvez utiliser le nouveau focus pour l'analyser immédiatement ou le joindre d'abord [voir À propos de l'assemblage de focus] à d'autres focus base client.
Pour convertir un focus, procédez comme suit :
  • Dans Portrait Miner, cliquez avec le bouton droit sur le focus base transaction et choisissez Transformer>Agréger des entrées.

Dans la boîte de dialogue Agréger des entrées, choisissez le fichier qui contient des définitions de champ et les champs clés qui identifient de manière unique un client. Vous pouvez aussi modifier l'emplacement du nouveau focus ou choisir de remplacer un focus de sortie créé précédemment.

Remarque :
  • Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsmeasure de Portrait Miner.
  • Pour suivre les modifications d'état dans un flux de transactions, vous devez utiliser la commande data build qstrack associée de Portrait Miner.

Voir également

À propos des assistants Portrait Miner

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Affichage et modification de fichiers texte dans Portrait Miner

Sujet parent : Fichiers texte, tables de bases de données et focus


Création d'un focus à partir de données dans un fichier texte

Pour utiliser Portrait Miner afin d'analyser un jeu de données sous la forme d'un fichier texte, vous devez d'abord créer un focus à partir du fichier de données.
Pour créer un focus :
  • Dans Portrait Miner, double-cliquez sur le fichier, ou cliquez avec le bouton droit sur le fichier et choisissez Ouvrir.
Deux fenêtres apparaissent :
  • La fenêtre Informations de format du fichier texte affiche la tentative initiale de Decision Studio de classer les données, en surlignant les problèmes rencontrés.

    Vous pouvez fermer cette fenêtre à tout moment.

  • L'autre fenêtre est celle de l'Assistant Nouveau Focus, qui affiche d'abord l'étape 1 d'un processus d'importation en cinq étapes :

    Vous pouvez vous déplacer entre les étapes avec les boutons Suivant et Précédent. À tout moment, vous pouvez cliquer sur Terminer pour accepter les choix effectués jusqu'à présent et créer un nouveau focus à partir de votre jeu de données.

    Avant de cliquer sur Terminer, vous pouvez choisir l'emplacement dans lequel vous souhaitez enregistrer votre focus, en cliquant sur le bouton Parcourir dans le volet Enregistrer le Focus sous et en naviguant [voir Ouverture ou enregistrement d'un fichier, d'une session ou d'une table de base de données] jusqu'à l'emplacement de votre choix.

    À chaque étape, l'assistant Nouveau Focus affiche l'interprétation en cours de Decision Studio des noms et des types de champs dans le fichier texte, avec un petit échantillon de données affichées avec cette interprétation.

Étape 1 : Choisissez un format de largeur fixe ou délimitée dans le volet Choisir le format. Choisissez Délimité si les valeurs des champs sont séparées par des virgules, des barres verticales ou certains autres délimiteurs ; choisissez Largeur fixe si les valeurs des champs commencent et se terminent aux mêmes positions de caractère fixe sur chaque ligne du fichier.

Étape 2 : Définissez les détails du format Le volet Options de format affiche un résumé des détails de format qui sont en cours de configuration.

Si Decision Studio a interprété le format de fichier texte de manière incorrecte (par exemple, s'il a choisi le mauvais séparateur de champ), cliquez sur Définir le format dans le volet Options de format pour ouvrir la fenêtre Définir le format de fichier texte (ainsi que la fenêtre d'aperçu Données brutes) :

La version affichée sur la gauche concerne les données de champ délimité ; la version sur la droite concerne les champs de largeur fixe

(Lorsque vous choisissez les champs de largeur fixe et passez de l'étape 1 à l'étape 2, les fenêtres Définir le format de fichier texte et Données brutes apparaissent automatiquement.)

Si la première ligne de votre fichier est constituée de noms de champ plutôt que de données, cochez la case En-têtes des colonnes.

Les paramètres Séparateur de champs, Lire les valeurs non renseignées sous, Lire les dates sous, Lire l'indicateur de date sous et Lire les chaînes sous vous permettent de spécifier en détail les aspects du format de fichier texte , avec les options communes disponibles dans les menus déroulants. Définissez Séparateur de champs sur « rien » pour un fichier texte avec champs de largeur fixe.

Pour les champs de largeur fixe, utilisez la table pour spécifier les noms de domaine et leurs positions de début et de fin. Vous pouvez utiliser la fenêtre Données brutes pour vous en inspirer : la « règle » au-dessus affiche les positions de caractère, et si vous déplacez le pointeur de la souris sur les données de l'échantillon, le texte de pointage donne la position du caractère actuellement sous le pointeur.

Étape 3 : Définissez les détails de format des champs La table des détails de champ s'élargit pour inclure trois lignes modifiables (avec des arrière-plans blancs) :

Les deux premières lignes contiennent le nom et le type en cours de chaque champ. Pour un champ de chaîne, la troisième ligne contient sa longueur (maximale) en caractères. Pour un champ de date, la troisième ligne contient le format de date.

Vous pouvez saisir un nouveau nom de champ, une longueur de chaîne ou un format de date personnalisé [voir Formats de date personnalisés] directement.

Si vous cliquez sur un type de champ, un menu apparaît, affichant les quatre types de données disponibles [voir Types de données]. Pour les champs de date, un menu des trois formats de date standard [voir Formats de date standard] est disponible.

Étape 4 : Enregistrez les détails du format Si vous devez réutiliser vos paramètres de format plus tard, vous pouvez créer un fichier de description de données texte (FDD) en cliquant sur Exporter le format et en choisissant un emplacement.

Étape 5 : Sélectionnez les champs à importer Par défaut, Decision Studio importe tous les champs dans un fichier texte. Si vous n'avez pas besoin de tous les champs, cliquez sur Sélectionner les champs dans le volet Sélectionner les champs. La boîte de dialogue Sélectionner les champs apparaît, avec tous les champs de la source des données externes dans le volet Inclure :

Utilisez les boutons présentant des flèches entre les volets Exclure et Inclure pour choisir les champs du fichier texte que vous souhaitez inclure dans votre focus.

Les boutons [image] et [image] déplacent les champs surlignés, alors que les boutons [image] et [image] déplacent tous les champs d'un volet à l'autre.

Utilisez les boutons [image] et [image] à droite de la fenêtre pour réarranger les champs surlignés dans le volet Inclure.

Remarque :
  • Vous pouvez cliquer sur Afficher les données dans l'assistant Nouveau Focus pour afficher les données telles qu'elles apparaissent dans le fichier. Vous trouverez peut-être utile de le faire si Decision Studio ne peut pas mettre au point le fichier.
  • Pour vous permettre de définir les détails du format de fichier pour un fichier texte avec des champs de largeur fixe, vous pouvez copier-coller ou faire glisser une description externe des données dans la table de la boîte de dialogue Définir le format de fichier texte.

    La description peut être sous la forme d'une feuille de calcul Excel ou en texte brut avec deux ou trois colonnes de valeurs séparées par des tabulations. La première colonne de données, facultative, contient les noms de champ ; les deux colonnes suivantes (ou les deux restantes) contiennent des positions de début et de fin pour les champs.

  • Decision Studio base son interprétation initiale d'un fichier texte sur un sous-ensemble d'enregistrements. Pour modifier le nombre d'enregistrements que Decision Studio utilise, modifiez les paramètres de préférence format de la date pour échantillon ; pour modifier la sensibilité de Decision Studio aux données incorrectement formatées, modifiez les paramètres de préférence d'approximation du seuil (%).

    Si Decision Studio a besoin de plus d'informations pour interpréter le fichier texte correctement, il lit un plus grand sous-ensemble d'enregistrements Pour modifier le nombre d'enregistrements que Decision Studio utilise dans ce cas, modifiez les paramètres de préférence de taille de l'échantillon.

  • Lorsque Decision Studio a terminé l'importation du fichier texte, il crée un fichier journal approprié. Vous devez examiner ce fichier si Decision Studio signale des erreurs ou des avertissements durant le processus d'importation.

    Dans Portrait Miner, vous pouvez cliquer sur [image] pour atteindre le répertoire contenant les fichiers journaux (le sous-répertoire shared/logs (UNIX) ou shared\logs (Windows) du répertoire d'installation Portrait Miner).

    Le fichier journal requis est le fichier journal le plus récent dont le nom commence par le nom du fichier texte d'origine. Vous pouvez trier les fichiers journaux par ordre de date/heure en cliquant sur l'en-tête de colonne Modifié.

  • Decision Studio transforme tous les noms de champ non valides en noms de champ valides.
  • Si un fichier texte possède un fichier de description de données texte (FDD), vous pouvez l'utiliser pour définir le format de fichier initial : cliquez sur Importer le format dans l'étape 1 du processus d'importation. (Vous pouvez ensuite apporter des modifications au format de la manière habituelle.)

    Sinon, vous pouvez démarrer l'assistant Nouveau Focus en double-cliquant sur le fichier FDD dans Portrait Miner.

  • Une valeur d'entier est qualifiée de « réel court » dans l'assistant Nouveau Focus, si elle est spécifiée comme petit entier [voir Types de données] dans un fichier FDD. Un champ smallinterger occupe moins d'espace disque qu'un champ d'entier normal, mais il ne peut contenir qu'un nombre limité de valeurs.
  • Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par les commandes data build qsgenfdd et qsimportflat de Portrait Miner.

Voir également

Création d'un focus à partir de données dans une base de données

lignes vides

nombre maximal d'erreurs d'extraction

nombre maximal d'avertissements d'extraction

ignorer les avertissements d'extraction

autoriser les erreurs de format de données

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Sujet parent : Fichiers texte, tables de bases de données et focus


Création d'un focus à partir de données dans une base de données

Pour utiliser Portrait Miner afin d'analyser un jeu de données sous la forme d'une table de base de données (ou d'une combinaison de tables et de vues), vous devez d'abord créer un focus à partir des données de la base de données.
Sujet parent : Fichiers texte, tables de bases de données et focus

Importation de données depuis une base de données

Pour importer des données :
  • Dans Portrait Miner, accédez à l'onglet Base de données et ouvrez une connexion à la base de données. Pour plus d'informations, reportez-vous à Configuration d'une connexion à une base de données.
  • Double-cliquez sur la table de base de données ou cliquez avec le bouton droit et choisissez Ouvrir.

La boîte de dialogue Nouveau focus s'affiche :

Cette boîte de dialogue Nouveau Focus présente un aperçu des données, comprenant des noms de champ et des types de champ.
  • Dans le volet Enregistrer le Focus sous, cliquez sur Parcourir, et ouvrez [voir Ouverture ou enregistrement d'un fichier, d'une session ou d'une table de base de données] l'emplacement de votre choix pour le focus.
  • Cliquez sur OK pour créer le nouveau focus.

Si vous ne souhaitez pas importer tous les champs de la table, cliquez sur Sélectionner les champs. La boîte de dialogue Sélectionner les champs s'affiche :

Tous les champs de la source des données externes qui peuvent être importés sont initialement affichés dans le volet Inclure.
  • Utilisez les boutons présentant des flèches pour choisir les champs de la table que vous voulez inclure dans votre focus.

    Les boutons [image] et [image] déplacent les champs surlignés, alors que les boutons [image] et [image] déplacent tous les champs d'un volet à l'autre.

    Utilisez les boutons [image] et [image] à droite de la fenêtre pour réarranger les champs surlignés dans le volet Inclure.

  • Lorsque vous avez sélectionné les champs requis, cliquez sur OK pour revenir à la boîte de dialogue Nouveau Focus.
Remarque :
  • Vous ne pouvez pas importer une colonne de cette façon, si son nom n'est pas un identificateur valide [voir Expressions de base] dans FDL.
  • Les champs à nombre réel avec une précision de plus de 15 chiffres dans une base de données sont traités par défaut comme des champs de chaîne dans Portrait Miner. En modifiant la préférence conserver les types numériques lors de l'importation vous pouvez les forcer à être traités comme des champs réels (avec une précision tronquée).

Voir également

Création d'un focus à partir de données dans un fichier texte

Configuration d'une connexion à une base de données

Importation de données par requête d'une base de données

Vous pouvez créer un focus depuis une combinaison de tables et de vues dans une base de données, en spécifiant une requête SQL qui sélectionne les données dont vous avez besoin.
  • Dans Portrait Miner, double-cliquez sur un fichier SQL comportant la requête que vous voulez utiliser, ou cliquez avec le bouton droit et choisissez Ouvrir.

Dans la boîte de dialogue Importer de la requête, choisissez un emplacement pour le focus que vous voulez créer ; saisissez ou modifiez la requête SQL si nécessaire ; et choisissez une connexion de base de données [voir Configuration d'une connexion à une base de données].

Remarque :
  • Si vous ouvrez la boîte de dialogue Importer de la requête à l'aide d'un fichier SQL, Portrait Miner calcule un nom de focus du nom de fichier, et utilise le contenu du fichier comme la requête SQL initiale. Cependant, une fois la boîte de dialogue ouverte, le fichier lui-même n'est plus approprié : il s'agit de la requête dans la boîte de dialogue qui est réellement exécutée, pas la requête dans le fichier.
  • La requête SQL est passée en l'état à la base de données, comme une seule instruction ; un point-virgule de fermeture n'est pas nécessaire (il peut être une syntaxe non valide pour certains systèmes de base de données).
  • Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsimportdb de Portrait Miner.

Voir également

À propos des assistants Portrait Miner

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données


Création d'un focus à partir d'un jeu de données SAS ou tiers

Pour utiliser Portrait Miner afin d'analyser un jeu de données tiers, vous devez créer un focus à partir du jeu de données. Portrait Miner peut importer des données depuis divers jeux de données tiers, y compris ceux créés sous SAS, SPSS et Excel. La liste complète des formats pris en charge est disponible à l'adresse http://support.quadstone.com/info/requirements/
Sujet parent : Fichiers texte, tables de bases de données et focus

Création d'un focus à partir d'un jeu de données SAS

  • Dans Portrait Miner, faites un double clic sur le fichier de jeu de données que vous désirez importer, ou faites un clic droit et choisissez Ouvrir.

Dans la boîte de dialogue Importer le focus, vous pouvez choisir les champs que vous désirez importer (par défaut, tous les champs sont importés) et choisir s'il faut importer un champ et des métadonnées de libellé de valeur dans le focus créé. De plus, vous pouvez modifier l'emplacement du nouveau focus ou choisir d'écraser le focus de sortie.

Remarque :
  • Les métadonnées SAS se lisent dans un fichier catalogue SAS format.sas7bcat devant être présent dans le même dossier que le jeu de données SAS source.
  • Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsimportstat de Portrait Miner.
  • Vous pouvez faire l'audit [voir Création d'un profil et d'un audit de focus] d'un jeu de données tiers sans avoir d'abord créé de focus : cliquez simplement sur le jeu de données dans Portrait Miner et choisissez Audit.

Création d'un focus à partir d'un jeu de données Excel ou tiers

  • Dans Portrait Miner, faites un double clic sur le fichier de jeu de données que vous désirez importer, ou faites un clic droit et choisissez Ouvrir.

Dans la boîte de dialogue Importer le focus, vous pouvez choisir les champs que vous désirez importer (par défaut, tous les champs sont importés). De plus, vous pouvez modifier l'emplacement du nouveau focus ou choisir d'écraser le focus de sortie.

Remarque :
  • Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsimportstat de Portrait Miner.
  • Vous pouvez faire l'audit [voir Création d'un profil et d'un audit de focus] d'un jeu de données tiers sans avoir d'abord créé de focus : cliquez simplement sur le jeu de données dans Portrait Miner et choisissez Audit.
  • Vous pouvez ouvrir un fichier Excel dans Excel en faisant un clic droit dessus dans Portrait Miner et en choisissant Envoyer dans Excel.

Voir également

À propos des assistants Portrait Miner

Création d'un focus à partir de données dans une base de données

Création d'un focus à partir de données dans un fichier texte

Exportation de données vers un fichier SAS ou un jeu de données tiers


Exportation d'enregistrements de fichiers de données, d'une table de base de données ou d'un focus

Vous pouvez exporter les enregistrements d'un focus dans un fichier texte, une table de base de données ou un autre focus de Decision Studio, ou dans un fichier texte [voir Exportation d'enregistrements d'un fichier texte à l'aide de Portrait Miner], un autre focus [voir Exportation d'enregistrements vers un focus à l'aide de Portrait Miner] ou un autre jeu de données SAS ou tiers [voir Exportation de données vers un fichier SAS ou un jeu de données tiers] à l'aide de Portrait Miner.
Sujet parent : Fichiers texte, tables de bases de données et focus

Exportation d'enregistrements de Decision Studio vers un fichier texte, une table de base de données ou un focus

Vous pouvez exporter les enregistrements d'un focus ou de segments surlignés d'un Aperçu graphique dans un fichier texte, une table de base de données ou un autre focus.
  1. Vous avez le choix entre les méthodes suivantes :
    • Dans la fenêtre Decision Studio, choisissez Focus>Exporter les données.
    • Dans l'Aperçu du profil, l'Aperçu de la distribution croisée, l'Aperçu de la carte ou l'Arbre de décision, surlignez les segments [voir Sélection des segments dans une vue graphique] que vous désirez exporter, puis choisissez Segments ou cliquez sur [image] dans la barre d'outils.

    La boîte de dialogue Exporter les enregistrements s'affiche :

  2. Cliquez sur le bouton Parcourir.
  3. Accédez [voir Ouverture ou enregistrement d'un fichier, d'une session ou d'une table de base de données] à l'emplacement requis et choisissez un nom et un type pour le jeu de données que vous exportez.
  4. Si vous désirez choisir un sous-ensemble de champs dans le focus, cliquez sur le bouton Sélectionner.

    Une boîte de dialogue de sélection de champs s'affiche, avec tous les champs initialement dans le volet Sélectionné (à moins que vous ayez interprété certains champs du focus comme étant des champs d'exportation [voir Définition ou effacement d'une variable candidate, une interprétation clé, qualitative, géographique ou d'exportation], auquel cas ces champs sont sélectionnés) :

    Utilisez les boutons fléchés entre les volets Non sélectionné et Sélectionné pour choisir les champs que vous désirez voir affichés dans le jeu de données exporté.

    Les boutons [image] et [image] déplacent les champs surlignés, alors que les boutons [image] et [image] déplacent tous les champs d'un volet à l'autre.

    Utilisez les boutons [image] et [image] à droite de la fenêtre pour réarranger les champs surlignés dans le volet Sélectionné.

  5. Si vous êtes en train de créer un fichier texte, vous pouvez cliquer sur Format, pour contrôler le format d'exportation [voir Contrôle du format d'exportation d'un fichier texte].
  6. Cliquez sur OK, pour exporter les données.

Exportation d'enregistrements d'un fichier texte à l'aide de Portrait Miner

Pour exporter des enregistrements :
  • Dans Portrait Miner, faites un clic droit sur le focus que vous désirez exporter et choisissez Exporter>au format texte.

Dans la boite de dialogue Exporter du texte, vous pouvez choisir les champs du focus à exporter, et modifier le nom du fichier de sortie et l'emplacement. Cliquez sur Suivant pour afficher l'onglet Format et choisissez les options d'exportation, identiques à celles dans la boîte de dialogue Options d'exportation [voir Contrôle du format d'exportation d'un fichier texte], du fichier de sortie.

Remarque :
  • Vous pouvez choisir les champs à exporter, soit en sélectionnant les noms de champ, soit en choisissant une ou plusieurs balises [voir Utilisation de groupes de champs].
  • Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsexportflat de Portrait Miner.

Voir également

À propos des assistants Portrait Miner

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Contrôle du format d'exportation d'un fichier texte

Dans Decision Studio, si vous cliquez sur Format dans la boîte de dialogue Exporter les enregistrements lors de l'exportation de données vers un fichier texte, la boîte de dialogue Options d'exportation s'affiche :

Vous pouvez y spécifier un séparateur de champs, une chaîne à utiliser à la place de la valeur null [voir La valeur null], le format à utiliser pour les valeurs de dates, et s'il faut utiliser des guillemets simples ou doubles (ou aucun) autour des valeurs de chaîne. Si vous choisissez d'utiliser des guillemets autour des valeurs de chaîne, vous pouvez les utiliser pour toutes les valeurs de chaîne (au lieu de ne les utiliser que lorsque le contenu de la valeur les rend nécessaires).

Si vous choisissez un fichier texte comme fichier d'exportation, vous pouvez générer une description de données texte (FDD) qui l'accompagne. Si vous choisissez un fichier FDD comme fichier d'exportation (auquel cas Portrait Miner en crée automatiquement un ou plusieurs associés aux fichiers de données), l'option pour générer un fichier FDD est déjà cochée.

Vous pouvez inclure des noms de champ en haut de votre fichier de données en cochant l'option En-têtes de colonnes.

Vous pouvez exporter les données à un format de largeur fixe en cochant l'option Largeur de colonne fixe. Les largeurs de colonnes dans ce format sont fonction du type et de la taille de chaque champ.

Exportation de données vers un fichier SAS ou un jeu de données tiers

Portrait Miner peut importer des données sous divers formats statistiques tiers, y compris ceux créés sous SAS, SPSS et Excel.

Dans Portrait Miner, faites un clic droit sur le focus que vous désirez exporter et choisissez Exporter>pour un autre programme.

Dans la boîte de dialogue Exporter pour un autre programme, vous pouvez choisir les champs à exporter et le programme vers lequel effectuer l'exportation et modifier l'emplacement du fichier de sortie.

Remarque :
  • Vous pouvez choisir les champs à exporter, soit en sélectionnant les noms de champ, soit en choisissant une ou plusieurs balises [voir Utilisation de groupes de champs].
  • Si vous ne spécifiez pas les champs à exporter, Portrait Miner exporte tous les champs du focus.
  • Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsexportstat de Portrait Miner.

Voir également

À propos des assistants Portrait Miner

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Exportation d'enregistrements vers un focus à l'aide de Portrait Miner

Vous pouvez exporter un sous ensemble de champs ou d'enregistrements d'un focus existant dans un nouveau focus.

Dans Portrait Miner, faites un clic droit sur le focus que vous désirez exporter et choisissez Exporter>au format focus. Dans la boîte de dialogue Exporter au format focus, vous pouvez choisir les champs à exporter et où enregistrer les focus exportés. Vous pouvez aussi sélectionner un sous ensemble d'enregistrements à l'aide d'une expression FDL [voir Expressions].

Remarque :
  • Vous pouvez choisir les champs à exporter, soit en sélectionnant les noms de champ, soit en choisissant une ou plusieurs balises [voir Utilisation de groupes de champs].
  • Si vous ne spécifiez pas les champs à exporter, Portrait Miner exporte tous les champs du focus.
  • Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsimportfocus de Portrait Miner.

Voir également

À propos des assistants Portrait Miner

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données


À propos de l'assemblage de focus

Portrait Miner propose deux manières d'assembler les champs de plusieurs focus pour créer un nouveau focus, le premier (« focus join ») étant une variante d'une jointure à gauche. Vous pouvez utiliser focus join dans Portrait Miner [voir Jonction de champs d'un focus à un autre focus avec Portrait Miner] ou via qsjoin de Portrait Miner.

La seconde méthode utilise Decision Studio pour importer des champs d'un focus dans une variante de jointure à gauche à deux tables.

Vous pouvez aussi fusionner les enregistrements de plusieurs focus, dans Portrait Miner [voir Fusion des entrées de deux focus] ou via qsmerge de Portrait Miner.

Voir également

dblookup

Fusion des entrées de deux focus

Sujet parent : Fichiers texte, tables de bases de données et focus


Jonction de champs d'un focus à un autre focus avec Portrait Miner

Étant donné deux focus qui partagent des champs clés du même nom et du même type, vous pouvez joindre des champs sélectionnés d'un focus à l'autre pour créer un nouveau focus, à condition que les deux focus soient triés [voir Tri d'un focus] en fonction des champs clés (selon l'ordre de classement Portrait Miner standard).
Pour joindre les champs d'un focus à un autre, procédez comme suit :
  • Dans Portrait Miner, cliquez avec le bouton droit sur le focus initial et choisissez Associer>Réunir des champs.

Dans la boîte de dialogue Réunir des champs, vous pouvez choisir le focus secondaire à partir duquel les champs seront ajoutés et jusqu'à trois champs clés utilisés pour joindre les champs sélectionnés au focus primaire. Vous pouvez également modifier l'emplacement du nouveau focus ou, plutôt que de créer un nouveau focus, choisir de remplacer un focus de sortie créé précédemment.

Remarque :
  • L'opération de jointure est essentiellement une jointure à gauche (votre focus initial étant la table sur la gauche). Toutefois, s'il existe un client avec plus d'un enregistrement dans le focus initial, Portrait Miner met en correspondance les enregistrements pour ce client avec des enregistrements successifs pour le même client dans l'autre focus. Le nombre d'enregistrements du nouveau focus est toujours identique au nombre d'enregistrements du focus initial.
  • Les champs clés des deux focus doivent tous deux être des champs de chaîne, des champs de date ou des champs numériques.
  • Vous pouvez choisir les champs à ajouter en sélectionnant les noms de champ ou en choisissant une ou plusieurs balises [voir Utilisation de groupes de champs].
  • Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsjoin de Portrait Miner.

Voir également

À propos des assistants Portrait Miner

À propos de l'assemblage de focus

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Sujet parent : Fichiers texte, tables de bases de données et focus


Jonction de champs d'un focus à un autre à l'aide de Decision Studio

Si deux focus partagent des champs de clé du même nom et du même type, vous pouvez joindre à un autre focus des champs sélectionnés dans un focus pour créer un nouveau focus. Pour cela, vous devez vous assurer que les deux focus sont classés en fonction de leurs champs, conformément à l'ordre de classement Portrait Miner standard.
  1. Ouvrez le premier focus dans Decision Studio et choisissez Focus>Importer des champs.
  2. Accédez [voir Ouverture ou enregistrement d'un fichier, d'une session ou d'une table de base de données] au second focus et cliquer sur Importer.

    La boîte de dialogue Importer des champ s'affiche :

  3. Dans le volet Sélectionner le champ identifiant de jointure, choisissez les champs clés correspondants du premier focus et du second focus.
  4. Cliquez sur Sélectionner des champs dans le volet Sélectionner des champs, pour sélectionner les champs du second focus que vous désirez inclure. Au minimum, vous devez exclure de la jointure le champ clé externe.

    La boîte de dialogue Sélectionner des champs s'affiche, avec tous les champs du second focus qui étaient initialement dans le volet Inclure :

    Utilisez les boutons fléchés entre les volets Exclure et Inclure pour choisir les champs dont vous désirez faire la jointure.

    Les boutons [image] et [image] déplacent les champs surlignés, alors que les boutons [image] et [image] déplacent tous les champs d'un volet à l'autre.

    Utilisez les boutons [image] et [image] à droite de la fenêtre pour réarranger les champs surlignés dans le volet Inclure.

  5. De retour dans la boîte de dialogue Importer des champs, cliquez sur OK.
Remarque :
  • L'opération de jointure est essentiellement une jointure gauche (avec le premier focus étant la table sur la gauche). Cependant, s'il existe un client comportant plusieurs enregistrements dans le second focus, Decision Studio ne considère que le premier enregistrement de ce client. Par conséquent, lorsque vous faites une jointure de champs à l'aide de Decision Studio, le nombre d'enregistrements dans le focus reste toujours le même.
  • Decision Studio exclut automatiquement tous les champs du second focus ayant le même nom qu'un champ du premier focus.
  • Les champs clés des deux focus doivent tous deux être des champs de chaîne, des champs de date ou des champs numériques.

Voir également

À propos de l'assemblage de focus

Jonction de champs d'un focus à un autre focus avec Portrait Miner

Sujet parent : Fichiers texte, tables de bases de données et focus


Fusion des entrées de deux focus

Étant donné deux focus avec des champs du mêmes nom et du même type et des enregistrements triées [voir Tri d'un focus] en fonction des champs clés (selon l'ordre de classement Portrait Miner standard), vous pouvez fusionner les enregistrements des focus pour créer un nouveau focus qui contient les enregistrements de ces deux focus. Le nouveau focus est trié de la même manière que les focus originaux.

Dans Portrait Miner, cliquez avec le bouton droit sur le focus primaire et choisissez Associer>Fusionner des entrées.

Dans la boîte de dialogue Fusionner des entrées, choisissez le focus secondaire, et spécifier les champs clés. Vous pouvez également choisir un emplacement pour le focus de sortie.

Remarque :
  • Par défaut, une entrée de focus secondaire qui a les mêmes clés qu'une entrée dans le focus primaire est écartée. Vous pouvez modifier ce comportement en cochant la case appropriée dans la boîte de dialogue.
  • Pour que deux focus puissent être fusionnés, les champs à fusionner doivent contenir des types de données compatibles.
  • Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsmerge de Portrait Miner.

Voir également

À propos des assistants Portrait Miner

À propos de l'assemblage de focus

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Sujet parent : Fichiers texte, tables de bases de données et focus


Configuration d'une connexion à une base de données

Pour pouvoir vous connecter à une base de données, vous devez d'abord configurer une connexion à la base de données.
  1. Dans Portrait Miner, sous l'onglet Bases de données, cliquez sur Nouvelle connexion.

    La boîte de dialogue Modifier la connexion de base de données apparaît.

  2. Saisissez le DSN (nom de source de données) de la base de données.

    Si vous ne le connaissez pas, demandez-le à votre administrateur système.

  3. Saisissez le nom d'utilisateur et le mot de passe que vous utilisez pour vous connecter à la base de données.
  4. Cliquez sur OK.

    Une nouvelle connexion à la base de données apparaît dans la liste des bases de données disponibles dans Portrait Miner.

Remarque :
  • Portrait Miner stocke vos connexions à la base de données sur le disque sous un format crypté. Une fois que vous avez configuré une connexion à la base de données, et tant que vous ne l'avez pas modifié, il ne vous est plus nécessaire de saisir de nouveau votre nom d'utilisateur ou mot de passe pour la base de données. Si vous devez modifier vos informations de connexion, surlignez la connexion dans le volet Bases de données disponibles de l'onglet Bases de données et cliquez sur Modifier la connexion.
  • Votre administrateur système peut avoir configuré une connexion « partielle » à la base de données pour vous, composée seulement d'un DSN. Avant de vous connecter à la base de données, vous devez terminer la connexion à la base de données : surlignez la connexion partielle à la base de données partielle et cliquez sur Modifier la connexion pour saisir votre nom d'utilisateur et votre mot de passe.
  • Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par les commandes data build qsdbaccess de Portrait Miner.

Voir également

Importation des types de base de données par Portrait Miner

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Sujet parent : Fichiers texte, tables de bases de données et focus


Importation des types de base de données par Portrait Miner

Sujet parent : Fichiers texte, tables de bases de données et focus

Importation vers Portrait Miner depuis une base de données

Portrait Miner mappe les types de base de données suivants avec leurs types de données, sur la base de la taille du type de base de données et des paramètres de préférences de Bases de données .
Type de base de données | Echelle | Précision | Représenter des entiers importants sous forme de chaîne de caractères | conserver les types numériques lors de l'importation | Type de champ Portrait Miner
char, char2, varchar, varchar2, nchar, nchar2, nvarchar, nvarchar2 |  |  |  |  | chaîne
date, time, timestamp, datetime, smalldatetime |  |  |  |  | date
int, integer, tinyint, smallint, byteint, bit |  |  |  |  | entier
bigint |  |  | false false true | true false | réel chaîne chaîne
decimal, dec, numeric, number | < 0 | 15 > 15 > 15 |  | true false | réel réel chaîne
decimal, dec, numeric, number | 0 | 0 10 > 10 [image] 15 > 15 > 15 > 10 | false false false true | true false | réel entier réel réel chaîne chaîne
float, double, real |  |  |  |  | réel
decimal, dec, numeric, number | > 0 | 15 > 15 > 15 |  | true false | réel réel chaîne
money |  |  |  | true false | réel chaîne
smallmoney |  |  |  |  | réel
Remarque :
  • Dans les lignes marquées par [image], il peut y avoir quelques pertes de précision.
  • Dans les lignes marquées par [image], les valeurs trop grandes pour être stockées sous forme d'entiers seront converties à la valeur Null.

Voir également

Représenter des entiers importants sous forme de chaîne de caractères

conserver les types numériques lors de l'importation

Exportation d'une base de données avec Portrait Miner

Portrait Miner exporte des types de bases de données qui dépendent à la fois de la base de données cible et du pilote ODBC. Portrait Miner suggère un type approprié pour la base de données que vous indiquez, tandis que le pilote ODBC interprète cette suggestion dans l'un des types de cette base de données.

Voir également

Configuration d'une connexion à une base de données


Utilisation de Data Build Manager pour l'importation, le traitement et l'exportation de données

Data Build Manager est une application Portrait Miner prenant en charge la préparation de données et le déploiement de la modélisation.

Pour construire un focus ou déployer un modèle, vous devez normalement utiliser une séquence data build [voir Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données] et d'autres opérations. Le faire manuellement prend du temps, et il est facile de faire des erreurs en cours de route. Vous pouvez aussi choisir d'exécuter une commande data build classique ou un déploiement de processus sans surveillance, probablement pendant la nuit. En cas d'incident, comme un manque d'espace disque, vous voudrez probablement corriger le problème et reprendre là où vous en étiez plutôt que de tout recommencer. De même, si les opérations nécessaires à des manipulations successives se chevauchent dans une certaine mesure, vous désirerez peut-être économiser du temps de traitement en effectuant de telles opérations en une seule fois. Mais il est difficile de garder la trace des dépendances entre les opérations, et facile d'oublier quelles opérations ont déjà été effectuées.

Data Build Manager utilise un fichier spécial nommé « plan de construction » décrivant comment construire un jeu de données d'analyse ou déployer un modèle. Le plan de construction contient plusieurs « cibles » interdépendantes et les séquences d'opérations nécessaires pour construire les cibles.

Pour ouvrir un plan de construction (un fichier .qsb) :
  • Dans Portrait Miner, double-cliquez sur le fichier, ou cliquez avec le bouton droit sur le fichier et choisissez Ouvrir.

Vous pouvez examiner les détails du plan de construction en cliquant sur les éléments dans le volet Plan de construction, et en visualisant leur description dans le volet de droite.

La hiérarchie (ou « arbre ») des éléments dans le volet Plan de construction rappelle l'affichage du fichier système dans Portrait Miner ou Windows Explorer, et vous pouvez développer ou réduire certaines parties de l'affichage de la même manière. Utilisez Options>Développer l'arbre (Options>Réduire l'arbre) pour afficher la hiérarchie entièrement développée (rép. réduit).

Au sommet de la hiérarchie se trouve un élément représentant le plan de construction lui-même. D'autres éléments d'un intérêt particulier sont les cibles (marquées par [image] ou similaire) et les paramètres (marqués par [image]).

Pour assigner une valeur à un paramètre, surlignez le paramètre dans le volet Plan de construction et modifiez la valeur dans le volet Paramètres sur la droite.

Après avoir correctement défini les paramètres, exécutez votre plan de construction en cliquant sur Construire. Une fenêtre de progression s'affiche. Pendant que le travail s'effectue, vous pouvez cliquer sur Stop pour interrompre l'exécution du plan de construction. Lorsque le travail est terminé, cliquez sur Effectué pour fermer la fenêtre de progression.

Remarque :
  • Le plan de construction utilise un format de fichier basé sur le format XML. Pour plus d'informations sur Data Build Manager et sur le format des plans de construction, voir Utilisation de Data Build Manager.
  • Data Build Manager est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsbuild de Portrait Miner.

Voir également

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

XML dans Portrait Miner

Sujet parent : Fichiers texte, tables de bases de données et focus


Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

De même que les applications comme Portrait Miner et Decision Studio, Portrait Miner comporte une suite complète d'utilitaires de ligne de commande nommés commandes data build de Portrait Miner. Vous pouvez utiliser les commandes data build pour toute sorte de tâches :
  • Importation/exportation de données entre focus, fichiers texte et tables de bases de données
  • Traitement des données dans les focus (classement, calcul, mesure, etc.)
  • Association de focus
  • Gestion des fichiers focus (copie, déplacement, modification de nom et suppression)
  • Production de rapports

Les commandes data build sont particulièrement utiles pour l'automatisation de processus data build, puisque vous pouvez les combiner dans les scripts shell UNIX ou les fichiers de commandes Windows.

Voir Commande data build de Portrait Miner et Guide de référence TML pour avoir des informations détaillées sur chacune des commandes.

Remarque : Pour utiliser les commandes data build, vous devez avoir un accès à Portrait Miner en ligne de commande. Demandez à votre administrateur système de configurer votre chemin de commande pour y inclure le répertoire contenant les commandes.

Voir également

Utilisation de Data Build Manager pour l'importation, le traitement et l'exportation de données
Sujet parent : Fichiers texte, tables de bases de données et focus


Utilisation de Decision Studio

  • Utilisation des outils Decision Studio
  • Utilisation des listes et des données tabulaires dans Decision Studio
  • Utilisation de Decision Studio


Utilisation des outils Decision Studio

  • Outils Decision Studio
  • Relations entre outils
  • Création et suppression de liens aux outils
  • Optimisation de l'espace d'affichage pour un outil Decision Studio
Sujet parent : Utilisation de Decision Studio


Outils Decision Studio

Ces outils Decision Studio sont disponibles pour la visualisation, la segmentation et la modélisation des jeux de données client :
Outil | Objectif
Aperçu du tableau
  • Affichage de votre focus, au niveau des enregistrements de clients individuels
  • Calcul de champs à l'aide de FDL
Éditeur de découpage | Groupement d'enregistrements de clients dans des bandes de valeurs ou des catégories dans un champ
Aperçu du tableau croisé | Affichage de données résumées sous la forme d'un tableau
Aperçu de la distribution croisée | Affichage de données résumées sous forme d'un graphique de distribution croisée de une à trois variables
Aperçu du profil | Affichage de données résumées dans un ensemble de segmentation d'une à trois variables
Aperçu de la carte | Affichage de données résumées dans une carte géographique ou prédéfinie
Arbre de Décision | Segmentations de construction d'arbre de décision de votre jeu de données client
Scoring | Construction des modèles de scoring de votre jeu de données client
Classification | Construction des modèles de classification de votre jeu de données client

Pour lancer un outil Decision Studio, choisissez son nom dans le menu Outils ou faites un clic droit sur le bouton correspondant dans la barre d'outils.

Sujet parent : Utilisation des outils Decision Studio


Relations entre outils

Chaque outil Decision Studio [voir Outils Decision Studio] a besoin d'une source de données, qu'il s'agisse des données à afficher ou des données sur lesquelles baser un modèle. Normalement, la source de données d'un outil est le focus actuellement ouvert, prenant en compte toute sélection d'enregistrements [voir Sélection d'enregistrements client] déjà en place.

Vous pouvez également faire en sorte qu'un outil ou plusieurs en suivent un autre [voir Création et suppression de liens aux outils], pour qu'à chaque fois que vous sélectionnez un segment [voir Sélection des segments dans une vue graphique] dans l'outil organisateur, les outils suiveurs considèrent ce segment comme leur source de données.

Un outil suiveur peut aussi mener à un autre outil. Vous pouvez aussi voir comment les outils sont en relation entre eux dans la fenêtre du volet de hiérarchie d'outil de Decision Studio, qui se trouve sous l'onglet Focus sur le côté gauche de la fenêtre principale. Remarquez que comme il ne s'agit pas de l'onglet par défaut, il est normalement masqué :

Dans cet exemple, l'Aperçu du tableau 5 et l'Aperçu du profil 6 utilisent tous deux le focus « DBUSA » comme source de leurs données. L'Aperçu de la distribution croisée 4 suit l'Aperçu du profil 6.

Remarque :
  • Lorsqu'aucun segment n'est sélectionné graphiquement dans un outil (c'est toujours le cas si l'outil est une instance de l'Aperçu du tableau, du Scoring, ou de la Classification), la propre source de l'outil est utilisée comme source de données pour tous les outils suivants.
  • De même qu'un focus peut avoir des découpages qui lui sont associés, c'est la même chose pour la sortie d'un outil. Vous pouvez modifier les découpages qui sont associés à la sortie d'un outil en liant l'Éditeur de découpage à cette sortie [voir Création et suppression de liens aux outils]. Mais si vous sélectionnez des segments différents dans l'outil (pour que la sortie soit modifiée), Decision Studio rejette tous les découpages que vous avez créés.

Voir également

Affichage détaillé d'un segment sélectionné dans un graphique
Sujet parent : Utilisation des outils Decision Studio

Afficher la hiérarchie d'outils de façon sélective

  • Cliquez sur [image] pour élargir ou [image] réduire une partie de l'aperçu de la hiérarchie d'outils.

Pour faire passer la fenêtre de l'outil au premier plan

Faites un double clic sur le nom d'outil dans le volet de hiérarchie d'outils, ou faites un clic droit sur le nom de l'outil et choisissez Placer au premier plan.


Création et suppression de liens aux outils

Sujet parent : Utilisation des outils Decision Studio

Pour lier un outil ouvert à la sortie d'un autre outil

En haut à droite de chaque barre d'outils d'outil se trouve un menu déroulant intitulé Organisateur, dans lequel un autre outil peut être sélectionné comme source de données. Sinon, dans le volet de hiérarchie d'outils [voir Relations entre outils] de la fenêtre de Decision Studio, faites glisser l'icône représentant l'outil suiveur désiré, et déposez-la sur l'icône représentant l'outil organisateur désiré.

Pour ouvrir un nouvel outil suiveur d'un autre outil

Dans le volet de hiérarchie d'outils [voir Relations entre outils] de la fenêtre de Decision Studio, cliquez pour sélectionner le nom de l'outil organisateur désiré.

N'importe quel outil que vous lancez ensuite est lié à l'outil sélectionné.

Pour revenir au comportement par défaut des nouveaux outils, sélectionnez à la place le focus situé tout en haut du volet de hiérarchie d'outils.

Remarque : Vous pouvez également lancer un outil lié en faisant un clic droit sur l'organisateur potentiel dans le volet de hiérarchie d'outils et en choisissant le suiveur potentiel dans le menu Faire un zoom avant.

Voir également

Affichage détaillé d'un segment sélectionné dans un graphique

Pour rompre un lien entre des outils

Vous avez le choix entre les méthodes suivantes :
  • Dans le menu déroulant Organisateur de la barre d'outils, sélectionnez Aucun.
  • Dans le volet de hiérarchie d'outils [voir Relations entre outils] de la fenêtre de Decision Studio, faites glisser l'icône représentant l'outil suiveur et déposez-la sur l'icône représentant le focus.
  • Liez l'outil suiveur à un outil organisateur différent.
  • Fermez l'outil organisateur.

    L'outil qui était suiveur est alors lié au focus ou à l'outil qui a fourni la source de données pour l'outil organisateur d'origine.

Remarque : Si vous faites glisser une icône d'outil vers une place différente dans la hiérarchie d'outils, tous les outils liés à cet outil continuent à le suivre.


Optimisation de l'espace d'affichage pour un outil Decision Studio

Choisissez Afficher ou appuyez sur F11.

Cela agrandit la fenêtre au maximum et masque la barre d'outils et les autres éléments d'interface utilisateur pour augmenter l'espace disponible à l'affichage dans la zone principale de la fenêtre.

Répétez cette action pour revenir à l'affichage d'origine.

Sujet parent : Utilisation des outils Decision Studio


Utilisation des listes et des données tabulaires dans Decision Studio

  • Classement de listes et de tables
  • Exportation de données tabulaires à partir de Decision Studio
  • Définition du format d'affichage des valeurs numériques et de date
Sujet parent : Utilisation de Decision Studio


Classement de listes et de tables

Dans la plupart des tables de Decision Studio (les exceptions à noter étant les affichages dans l'Aperçu du tableau et l'Aperçu du tableau croisé), vous pouvez réorganiser les lignes de diverses façons en faisant un clic droit sur un en-tête de colonne et en choisissant une option de tri.

De même, dans la plupart des listes de Decision Studio, vous pouvez réorganiser les éléments de la liste en faisant un clic droit sur n'importe quel élément du volet de liste.

Dans la plupart des cas, trois options standard de classement sont disponibles : non trié (c'est à dire l'ordre par défaut), croissant et décroissant ; il peut cependant exister des options supplémentaires selon le genre de données dans la liste ou la colonne.

Remarque :
  • Dans la plupart des emplacements, si vous cliquez de façon répétée (avec le bouton gauche de la souris) sur l'en-tête de la colonne d'une table offrant des options de classement, Decision Studio parcourt les options disponibles. S'il existe beaucoup d'options, il est habituellement plus facile de faire un clic droit et de choisir dans le menu, mais, pour les colonnes n'ayant que les trois options standard, le classement par ligne désiré nécessite tout au plus deux clics.
  • Dans la fenêtre Decision Studio, la colonne Interprétations comporte une option permettant de faire un classement par chacun des types d'interprétation possibles. Lorsque vous choisissez classer qualitativement, par exemple, Decision Studio affiche les champs ayant des découpages par catégories avant les autres champs.
  • La colonne Balises utilisateur de la fenêtre principale ne peut pas être classée.
  • Le classement des lignes d'une table ou des éléments d'une liste n'affecte habituellement que la façon dont les informations s'affichent dans le contexte en cours. La réorganisation du classement des catégories [voir Réorganisation de catégories] est une exception dans un découpage par catégories : un outil Decision Studio qui utilise le découpage affiche les modalités dans l'ordre que vous avez spécifié dans l'Éditeur de découpage.

Voir également

Tri d'un focus
Sujet parent : Utilisation des listes et des données tabulaires dans Decision Studio


Exportation de données tabulaires à partir de Decision Studio

Vous pouvez utiliser Modifier>Copier afin de copier des données tabulaires à partir des outils de Decision Studio vers le presse-papiers, comme vous le feriez avec les autres applications de Windows. Il existe également quatre variantes de l'opération de copie vers le presse-papiers standard :
Option | Objectif
Copier tous les tableaux | Copier les cellules de tous les volets à onglets, au lieu de copier juste la cellule en cours.
Copier sans en-têtes | Omettre les en-têtes de ligne et de colonne.
Copier avec la répétition des étiquettes | Répéter les en-têtes pour chaque ligne et colonne (vous trouverez cela utile pour créer des tableaux croisés dynamiques dans Excel).
Copier les segments élargis | Copier les données dans un format de liste à deux colonnes, au lieu d'un format tabulaire.

Vous pouvez également surligner les cellules dans une vue tabulaire, et glisser les données directement dans les applications Windows (comme dans Microsoft Excel) qui peuvent lire des données dans un format tabulaire.

Vous pouvez également copier les vues tabulaires et les tableaux croisés [voir Tableaux croisés comme base de segmentation et de visualisation des données] de Decision Studio directement vers Microsoft Excel, et, si vous avez des données tabulaires dans Decision Studio que vous aimeriez partager avec vos collègues, vous pouvez les leur envoyer par courrier électronique.

Sujet parent : Utilisation des listes et des données tabulaires dans Decision Studio

Mise en surbrillance des régions d'une table

Vous pouvez surligner une ou plusieurs régions rectangulaires dans une vue tabulaire comme vous le feriez dans d'autres applications de Windows. Dans la plupart des vues tabulaires, vous pouvez également cliquer sur les en-têtes pour surligner les lignes complètes ou les colonnes de la table.

Exportation de données tabulaires vers Microsoft Excel

Vous pouvez copier des vues tabulaires ou des données de tableaux croisés sous-jacents vers Excel :
  • Pour copier une vue tabulaire vers Excel, effectuez l'une des opérations suivantes :
    • Dans l'Aperçu du tableau, choisissez Fichier>Afficher dans Excel.
    • Dans l'Arbre de décision, le Scoring ou la Classification, choisissez Fichier>Exporter>Afficher dans Excel.
    • Cliquez sur [image] dans la barre d'outils.
  • Pour copier des données de tableau croisé à partir de l'Aperçu du tableau croisé ou de l'Aperçu du profil vers Excel, choisissez Fichier>Exporter>Tableau croisé dans Excel ou cliquez sur [image] dans la barre d'outils.
Remarque :
  • Un nouveau classeur est créé lors de l'exportation de données vers Excel.
  • Si vous surlignez les cellules dans une vue tabulaire [voir Mise en surbrillance des régions d'une table], Decision Studio exporte seulement ces cellules vers Excel. Sinon, la table entière ou le tableau croisé est exporté.
  • En choisissant Aperçu au format Lien Excel au lieu de Afficher dans Excel, ou Tableau croisé au format Lien Excel au lieu deTableau croisé dans Excel, vous créez un lien dynamique, afin que toute modification de votre vue tabulaire ou tableau croisé soit automatiquement propagée vers Excel.


Définition du format d'affichage des valeurs numériques et de date

  1. Dans la fenêtre Decision Studio, sélectionnez Edition>Préférences d'affichage.

    La boîte de dialogue Format s'affiche. Un des cinq tableaux avec onglets contrôle l'affichage des formats des valeurs numériques et de date :

    Volet | Description
    Affichage des données | Le nombre d'emplacements décimaux affichés pour les chiffres, l'alignement des chiffres, s'il faut ou non enlever les zéros à droite lors de l'affichage des fractions décimales, ou s'il faut ou non utiliser un séparateur des milliers lors de l'affichage des chiffres ; s'il faut ou non afficher les dates au format américain (MM/JJ/AAAA), européen (JJ/MM/AAAA) ou AMJ (AAAA/MM/JJ) ; s'il faut ou non afficher les heures par 12 ou 24 heures
  2. Cliquez sur OK pour confirmer toutes les modifications et fermez la boîte de dialogue.
Remarque : Votre paramétrage s'applique dans toute la section en cours, ainsi que dans toutes les futures sessions Decision Studio et Portrait Miner. Toutefois, il ne s'applique pas à l'importation ni à l'exportation de fichiers texte, ni non plus à l'évaluation d'expressions FDL.

Voir également

Définition des options globales des affichages graphiques
Sujet parent : Utilisation des listes et des données tabulaires dans Decision Studio


Utilisation de Decision Studio

  • Orientation d'un affichage graphique à l'aide de la souris
  • Sélection des segments dans une vue graphique
  • Exportation des vues graphiques depuis Decision Studio
Sujet parent : Utilisation de Decision Studio


Orientation d'un affichage graphique à l'aide de la souris

Faites glisser la vue du graphique ou l'arbre de décision à l'aide d'un des trois boutons de la souris :
  • Pour pivoter un graphique, faites-le glisser avec le bouton gauche de la souris.
  • Pour déplacer un graphique d'un côté à l'autre ou verticalement, faites-le glisser avec le bouton droit de la souris.
  • Pour rapprocher ou éloigner un graphique de vous, faites-le glisser vers le haut/vers le bas à l'aide du bouton central de la souris.
Remarque :
  • Si votre souris ne dispose que de deux boutons, vous pouvez émuler le bouton central de la souris en maintenant la touche Alt enfoncée tout en appuyant sur le bouton gauche de la souris.
  • Lorsque vous déplacez un arbre de décision avec le bouton droit de la souris, faites-le sur l'arrière-plan pour éviter le menu contextuel qui apparait avec le bouton droit de la souris lors d'un clic droit sur un segment.
Sujet parent : Utilisation de Decision Studio

Pour revenir à l'affichage d'origine

Choisissez Afficher>Accueil ou cliquez sur [image] dans la barre d'outils.

Remarque :

Dans l'Aperçu de la carte, si l'option du menu Afficher>Auto est cochée, l'affichage d'origine peut provenir de plus haut, au lieu de l'affichage correspondant à l'option Afficher>Accueil.

Vue aérienne d'un graphique de carte

Choisissez Afficher>Haut ou cliquez sur [image] dans la barre d'outils.

Pour faire un zoom avant sur les segments sélectionnés d'un arbre de décision

  1. sélectionnez les segments [voir Sélection des segments dans une vue graphique] qui vous intéressent.
  2. Choisissez Afficher>Zoom sur la sélection ou cliquez sur [image] dans la barre d'outils. Sinon, vous pouvez faire un clic droit sur l'un des segments sélectionnés et choisir Faire un zoom sur la sélection.

    L'Arbre de décision fait un zoom avant (ou arrière) de façon à ce que les segments sélectionnés et leurs sous-segments soient visibles.

Remarque :

Si aucun segment n'est surligné, Afficher>Zoom sur la sélection (ou [image]) a le même effet que Afficher>Accueil (ou [image]).


Sélection des segments dans une vue graphique

Vous pouvez sélectionner des segments dans l'Éditeur de découpage, l'Aperçu du profil, l'Aperçu de la distribution croisée, l'Aperçu de la carte et l'Arbre de décision. Des segments sélectionnés peuvent être utilisés comme source de données pour les outils liés [voir Relations entre outils], et peuvent être utilisés pour calculer des champs [voir Calcul d'un champ à partir d'une segmentation graphique] en les décrivant.
Sujet parent : Utilisation de Decision Studio

Pour sélectionner un seul segment

Cliquez sur le segment pour le sélectionner.
Remarque :
  • Si le segment est déjà sélectionné parce qu'il fait partie d'un groupe de segments, cliquez d'abord sur l'arrière-plan pour effacer la sélection existante.
  • Dans l'Aperçu de la carte, pour sélectionner un segment représenté par un lien de ligne (par opposition à un bloc), cliquez sur la flèche au milieu du lien de ligne.

Pour effacer les sélections ou les étendre sur plusieurs segments

Vous avez le choix entre les méthodes suivantes :
  • Maintenez enfoncée la touche CTRL du clavier et cliquez sur un segment.

    Le segment est sélectionné s'il ne l'était pas avant et vice versa.

  • Maintenez enfoncée la touche CTRL du clavier et balayez avec le bouton gauche de la souris pour créer un rectangle « élastique ».

    Lorsque vous relâchez le bouton de la souris, les segments qui étaient complètement ou partiellement dans le rectangle sont sélectionnés s'ils ne l'étaient pas avant et vice versa.

Remarque : Dans l'Aperçu de la carte, vous pouvez sélectionner des blocs ou des liens de ligne, mais pas les deux en même temps. Si vous faites glisser un rectangle « élastique » par-dessus une région contenant à la fois des blocs et des liens de ligne, seuls les blocs sont sélectionnés.


Exportation des vues graphiques depuis Decision Studio

Si vous disposez d'une vue graphique dans l'Aperçu du profil, l'Aperçu de la distribution croisée, l'Aperçu de la carte, l'Arbre de décision ou le Scoring, et que vous désirez l'inclure à un rapport ou la partager avec des collègues, vous pouvez l'enregistrer sous forme de fichier.
Sujet parent : Utilisation de Decision Studio

Pour enregistrer une vue graphique dans un fichier

Dans l'Aperçu du profil, l'Aperçu de la distribution croisée, l'Aperçu de la carte, l'Arbre de décision ou le Scoring, choisissez Fichier>Exporter>Afficher en tant qu'image, et accédez [voir Ouverture ou enregistrement d'un fichier, d'une session ou d'une table de base de données] à un emplacement dans lequel enregistrer votre vue graphique.

Decision Studio exporte votre image sous forme de fichier JPEG.

Remarque :
  • Decision Studio enregistre une vue graphique à la même taille que celle où elle apparaît dans l'Aperçu ou l'outil de modélisation.
  • Pour utiliser une vue graphique enregistrée dans un rapport , importez ou placez le fichier dans votre document cible.
  • Dans l'Aperçu du profil, vous pouvez aussi utiliser Fichier>Exporter>Afficher au format HTML pour créer une page Web contenant la vue en cours.


Utilisation de PSSConnector

  • Introduction
  • Extensions Portrait Miner
  • Extensions Decision Studio
  • Authentification
  • Extensions de ligne de commande
  • Exportation de règles depuis l'interface utilisateur de Portrait Miner
  • Exportation de règles par lots


Introduction

Le connecteur Portrait Shared Services (PSS) prend en charge l'intégration entre Portrait Miner et d'autres produits de Portrait Suite : Portrait Dialogue, Portrait Interaction Optimizer et Portrait Explorer.

Pour plus d'informations sur l'installation de PSSConnector, reportez-vous à la section Installation de PSSConnector du Guide d'administration de Miner.

Sujet parent : Utilisation de PSSConnector


Extensions Portrait Miner

Les extensions suivantes sont disponibles dans Portrait Miner.

  • Dans la barre d'outils, le bouton Gestion des connexions à Portrait Shared Services permet à l'utilisateur d'ouvrir ou de fermer une session depuis Portrait Shared Services. Avec un serveur Portrait Customer Analytics sous Windows, votre connexion à Portrait Shared Services est établie automatiquement via une Authentification Windows, si c'est possible. Pour se connecter un utilisant un compte différent, vous devez fermer la session puis la rouvrir en utilisant les autorisations appropriées au compte.
  • Dans la barre d'outils, le bouton Gestion des règles dans le référentiel Portrait Shared Repository permet à l'utilisateur d'afficher la liste des règles analytiques qui ont été publiées dans le référentiel. Vous devez sélectionner un domaine PSS logique, vous pouvez alors afficher les règles qui sont publiées pour ce domaine. Vous pouvez réexporter une règle vers le système de fichiers du serveur sous forme de fichier QMML en cliquant avec le bouton droit de la souris sur une règle et en sélectionnant Enregistrer sous.
  • Si vous sélectionnez un fichier .qmml dans Miner, l'action par clic droit sur la souris Publication d'une règle sur le référentiel Portrait Shared Repository publie le QMML modèle sous forme de règle dans Portrait Shared Repository. Vous êtes invité à saisir le nom, le type et la description à affecter à la règle et le nom du domaine PSS logique dans lequel la publier.

Les applications de la barre d'outils sont également disponibles depuis le menu Lancer de Portrait Miner.

Sujet parent : Utilisation de PSSConnector


Extensions Decision Studio

Les extensions Portrait Shared Services pour Decision Studio permettent à l'utilisateur de publier un champ calculé sous forme de règle dans Portrait Shared Repository, où il peut être utilisé par d'autres applications.

Il n'est possible de publier des règles que depuis l'Aperçu du tableau.

L'Aperçu du tableau de Decision Studio fournit également l'application Gestion des connexions à Portrait Shared Services, pour permettre à l'utilisateur d'ouvrir ou de fermer une session en utilisant un nom d'utilisateur et un mot de passe explicites ou une authentification Windows, lorsque c'est possible. L'application offre les mêmes fonctionnalités que celles de Portrait Miner.

L'Aperçu du tableau croisé de Decision Studio permet de publier le tableau croisé en cours dans PSS. Ces spécifications de tableau croisé peuvent ensuite être utilisées lors de la génération de rapports depuis l'application Portrait Explorer dans Marketing HQ.

Sujet parent : Utilisation de PSSConnector


Authentification

Vous devez être authentifié dans le Portrait Shared Services afin de pouvoir gérer, publier ou récupérer des règles stockées dans le référentiel Portrait Shared Repository.

Si votre compte de connexion Windows est configuré en tant que compte d'authentification Windows dans l'application Portrait Dialogue Admin, les applications Miner vous authentifient alors automatiquement, et vous n'avez pas d'action à entreprendre pour ouvrir une session. De tels comptes ne nécessitent aucune option -username ou -password pour les utilitaires de ligne de commande.

Si vous utilisez un compte de connexion qui n'est pas configuré pour l'Authentification Windows, vous devez explicitement ouvrir une session Portrait Miner. Les applications Portrait Miner et Decision Studio vous invitent automatiquement à fournir vos informations de connexion si vous n'êtes pas déjà connecté. Les utilitaires de ligne de commande requièrent des options -username et -password explicites.

Après avoir ouvert une session dans une des applications Portrait Miner, vous conservez cette session jusqu'à ce que vous la quittiez délibérément. Vous devez faire une authentification distincte pour chaque application que vous lancez.

Sujet parent : Utilisation de PSSConnector


Extensions de ligne de commande

Extensions de ligne de commande data build

Les commandes data build (DBC) suivantes sont fournies par l'extension. Les commandes requièrent toutes des arguments -username et -password explicites, à moins que l'authentification Windows ne soit activée dans Portrait Campaign Manager pour votre compte d'utilisateur.

  • Commandes de mappages (fichiers .xml)
  • Commandes pour les règles (fichiers .qmml)
  • Commandes d'optimisation des décisions (fichiers .qsor)
  • Commandes pour les jeux de données Explorer
Sujet parent : Utilisation de PSSConnector


Commandes de mappages (fichiers .xml)

  • pssmappingpublish
  • pssmappingretrieve
Sujet parent : Extensions de ligne de commande


pssmappingpublish

Cette commande permet de publier un ensemble de mappages d'entrée de règle dans un domaine client dans Portrait Shared Repository. Les paramètres pour la commande sont comme suit :
Publier un fichier de mappage d'entrée de règle dans Portrait Shared Repository

     Requis :
       -domain <nom de domaine>
          Domaine client Portrait Campaign Manager dans lequel publier les mappages

       -input <fichier de mappage XML>
          Fichier contenant la définition des mappages d'entrée de règle

     Facultatif :
       -username <nom d'utilisateur>
          Compte d'utilisateur Portrait Shared Services à utiliser. Facultatif si vous pouvez
          vous connecter via l'Authentification Windows.
       -password <mot de passe>
       Mot de passe du compte d'utilisateur Portrait Shared Services.
Sujet parent : Commandes de mappages (fichiers .xml)


pssmappingretrieve

Cette commande récupère un ensemble de mappages d'entrée de règle pour un domaine client et les enregistre sous forme de fichier XML. Les paramètres pour la commande sont comme suit :
Extraire des mappages d'entrée de règle à partir du référentiel Portrait Shared Repository et les enregistrer dans un fichier.

     Requis :
       -domain <nom de domaine>
          Domaine client Portrait Campaign Manager dans lequel récupérer les mappages
.
       -output <fichier de mappage XML>
          Nom du fichier dans lequel écrire la définition des mappages.

     Facultatif :
       -username <nom d'utilisateur>
          Compte d'utilisateur Portrait Shared Services à utiliser. Facultatif si vous pouvez
          vous connecter via l'Authentification Windows.
       -password <mot de passe>
       Mot de passe du compte d'utilisateur Portrait Shared Services.
Sujet parent : Commandes de mappages (fichiers .xml)


Commandes pour les règles (fichiers .qmml)

  • pssrulepublish
  • pssrulelist
  • pssruleretrieve
  • pssruledescribe
Sujet parent : Extensions de ligne de commande


pssrulepublish

Cette commande permet de publier le contenu d'un fichier QMML sous forme de règle dans Portrait Shared Repository. Les paramètres pour la commande sont comme suit :
Publier une règle QMML dans le référentiel Portrait Shared Repository.

     Requis :
       -domain <nom de domaine>
          Domaine client Portrait Campaign Manager dans lequel la règle doit
          être publiée.
       -name <nom de règle>
          Nom à utiliser pour publier cette règle dans le référentiel.
       -description <texte | @nom de fichier>
          Description de la règle. Si la forme @nom de fichier est utilisée, prenez la
          description d'un fichier. Vous pouvez utiliser l'option -replace.
       -type <Valeur | Propension | Uplift>
          Type de règle en cours de publication : valeur, propension ou uplift.
          Vous pouvez utiliser l'option -replace.
       -input <fichier QMML>
          Nom du fichier QMML contenant la règle. Le fichier ne doit contenir
          qu'un seul ensemble de règles et ce dernier ne doit avoir qu'une seule sortie.

     Facultatif :
       -username <nom d'utilisateur>
          Compte d'utilisateur Portrait Shared Services à utiliser. Facultatif si vous pouvez
          vous connecter via l'Authentification Windows.
       -password <mot de passe>
          Mot de passe du compte d'utilisateur Portrait Shared Services.
       -replace
          Remplace le QMML d'une règle existante au lieu d'en publier un nouveau.
          Lors du remplacement, les paramètres -type et -description sont en option.
Sujet parent : Commandes pour les règles (fichiers .qmml)


pssrulelist

Cette commande permet de répertorier les détails de l'ensemble des règles associées à un domaine spécifié. La liste des règles est renvoyée sous forme de texte brut, mais elle peut aussi l'être sous forme de document XML. Les paramètres pour la commande sont comme suit :
Énumérer toutes les règles d'un domaine client dans le référentiel Portrait Shared Repository.

     Requis :
       -domain <nom de domaine>
          Domaine client dans lequel récupérer les règles.

     Facultatif :
       -username <nom d'utilisateur>
          Compte d'utilisateur Portrait Shared Services à utiliser. Facultatif si vous pouvez
          vous connecter via l'Authentification Windows.
       -password <mot de passe>
          Mot de passe du compte d'utilisateur Portrait Shared Services.
       -xml
          Indique la sortie au format XML.
Sujet parent : Commandes pour les règles (fichiers .qmml)


pssruleretrieve

Cette commande récupère le QMML compilé d'une règle dans Portrait Shared Repository. Les paramètres pour la commande sont comme suit :
Extraire une règle QMML à partir du référentiel Portrait Shared Repository et l'enregistrer dans un fichier.

     Requis :
       -domain <nom de domaine>
          Domaine client dans lequel récupérer la règle.
       -name <nom de règle>
          Nom de la règle publiée dans Portrait Shared Repository.
       -output <fichier QMML>
          Nom du fichier dans lequel la règle doit être enregistrée.

     Facultatif :
       -username <nom d'utilisateur>
          Compte d'utilisateur Portrait Shared Services à utiliser. Facultatif si vous pouvez
          vous connecter via l'Authentification Windows.
       -password <mot de passe>
          Mot de passe du compte d'utilisateur Portrait Shared Services.
Sujet parent : Commandes pour les règles (fichiers .qmml)


pssruledescribe

La commande répertorie les noms et les types des entrées, des sorties d'une règle dans Portrait Shared Repository. Ceci indique également comment la règle de mappage des entrées s'applique, en décrivant le mappage d'un champ ou d'une fonction, si un mappage est défini. Les paramètres pour la commande sont comme suit :
Décrire une règle QMML dans le référentiel Portrait Shared Repository.

     Requis :
       -domain <nom de domaine>
          Domaine client Portrait Campaign Manager
       -name <nom de règle>
          Nom de la règle dans le domaine client

     Facultatif :
       -username <nom d'utilisateur>
          Compte d'utilisateur Portrait Shared Services à utiliser. Facultatif si vous pouvez
          vous connecter via l'Authentification Windows.
       -password <mot de passe>
       Mot de passe du compte d'utilisateur Portrait Shared Services.
Sujet parent : Commandes pour les règles (fichiers .qmml)


Commandes d'optimisation des décisions (fichiers .qsor)

  • pssoptpublish
  • pssoptlist
  • pssoptretrieve
  • pssoptreport
  • pssoptdescribe
Sujet parent : Extensions de ligne de commande


pssoptpublish

Cette commande permet de publier le contenu d'un fichier de résultats d'optimisation des décisions QSOR dans Portrait Shared Repository. Les paramètres pour la commande sont comme suit :
 Publier une optimisation des décisions dans le référentiel Portrait Shared Repository.

     Requis :
       -domain <nom de domaine>
          Domaine client Portrait Campaign Manager dans lequel l'optimisation
          doit être publiée.
       -name <nom d'optimisation>
          Nom à utiliser pour publier cette optimisation dans le référentiel.
       -description <texte | @nom de fichier>
          Description de l'optimisation. Si la forme @nom de fichier est utilisée, prenez la
          description d'un fichier. Vous pouvez utiliser l'option -replace.
       -input <fichier QSOR>
          Nom du fichier de résultats d'optimisation des décisions.

    Facultatif :
       -username <nom d'utilisateur>
          Compte d'utilisateur Portrait Shared Services à utiliser.
       -password <mot de passe>
          Mot de passe du compte d'utilisateur Portrait Shared Services.
       -replace
           Remplace par les détails d'une optimisation existante plutôt que d'en créer une
           nouvelle. Lors du remplacement, le paramètre -description est facultatif.
Sujet parent : Commandes d'optimisation des décisions (fichiers .qsor)


pssoptlist

Cette commande permet de répertorier les détails de l'ensemble des optimisations des décisions associées à un domaine spécifié. La liste des optimisations est renvoyée sous forme de texte brut, mais elle peut aussi l'être sous forme de document XML. Les paramètres pour la commande sont comme suit :
Répertorier l'ensemble des optimisations des décisions d'un domaine client donné dans
Portrait Shared Repository.

     Requis :
       -domain <nom de domaine>
          Domaine client dans lequel récupérer les optimisations.

     Facultatif :
       -username <nom d'utilisateur>
          Compte d'utilisateur Portrait Shared Services à utiliser.
       -password <mot de passe>
          Mot de passe du compte d'utilisateur Portrait Shared Services.
       -xml
          Indique la sortie au format XML.
Sujet parent : Commandes d'optimisation des décisions (fichiers .qsor)


pssoptretrieve

Cette commande récupère l'optimisation des décisions auprès de Portrait Shared Repository. Les paramètres pour la commande sont comme suit :
Extraire une optimisation des décisions de Portrait Shared Repository et l'enregistrer dans un fichier.

     Requis :
       -domain <nom de domaine>
          Domaine client dans lequel récupérer l'optimisation.
       -name <nom d'optimisation>
          Nom de l'optimisation des décisions publiée dans
           Portrait Shared Repository.
       -output <fichier QSOR>
          Nom du fichier dans lequel l'optimisation doit être enregistrée.

     Facultatif :
       -username <nom d'utilisateur>
          Compte d'utilisateur Portrait Shared Services à utiliser.
       -password <mot de passe>
          Mot de passe du compte d'utilisateur Portrait Shared Services.
Sujet parent : Commandes d'optimisation des décisions (fichiers .qsor)


pssoptreport

Cette commande récupère le rapport associé à une optimisation des décisions auprès de Portrait Shared Repository et l'enregistre dans un fichier. Les paramètres pour la commande sont comme suit :
Extraire un rapport associé à une optimisation des décisions de Portrait
Shared Repository et l'enregistrer dans un fichier.

     Requis :
       -domain <nom de domaine>
          Domaine client dans lequel récupérer l'optimisation.
       -name <nom d'optimisation>
          Nom de l'optimisation des décisions publiée dans
           Portrait Shared Repository.
       -output <fichier HTML>
          Nom du fichier dans lequel le rapport doit être enregistré.

     Facultatif :
       -username <nom d'utilisateur>
          Compte d'utilisateur Portrait Shared Services à utiliser. Facultatif si vous pouvez
          vous connecter via l'Authentification Windows.
       -password <mot de passe>
          Mot de passe du compte d'utilisateur Portrait Shared Services.
Sujet parent : Commandes d'optimisation des décisions (fichiers .qsor)


pssoptdescribe

La commande répertorie les noms des résultats et les noms et types des entrées et des sorties d'une règle d'optimisation des décisions dans Portrait Shared Repository. Ceci indique également comment la règle de mappage des entrées s'applique, en décrivant le mappage d'un champ ou d'une fonction, si un mappage est défini. Les paramètres pour la commande sont comme suit :
Décrire une optimisation des décisions dans le référentiel Portrait Shared Repository.

     Requis :
       -domain <nom de domaine>
          Domaine client Portrait Campaign Manager
       -name <nom d'optimisation>
          Nom de l'optimisation dans le domaine client

     Facultatif :
       -username <nom d'utilisateur>
          Compte d'utilisateur Portrait Shared Services à utiliser. Facultatif si vous pouvez
          vous connecter via l'Authentification Windows.
       -password <mot de passe>
          Mot de passe du compte d'utilisateur Portrait Shared Services.
Sujet parent : Commandes d'optimisation des décisions (fichiers .qsor)


Commandes pour les jeux de données Explorer

  • pssdatasetupdate
Sujet parent : Extensions de ligne de commande


pssdatasetupdate

Cette commande permet de mettre à jour un jeu de données Portrait Explorer existant en fonction d'un nouveau fichier focus. Les paramètres pour la commande sont comme suit :
Publier une nouvelle version de jeu de données pour un jeu de données spécifiquement nommé dans Portrait Shared Repository

     Requis :
       -name <nom de jeu de données>
          Nom du jeu de données de Portrait Shared Repository auquel est destinée la version de jeu de données.
       -input <chemin d'accès au fichier focus>
          Nom d'accès au fichier sur le serveur Portrait Analytics Web Services à charger comme
          version de jeu de données.
     Facultatif :
       -username <nom d'utilisateur>
          Compte d'utilisateur Portrait Shared Services à utiliser. Facultatif si vous pouvez
          vous connecter via l'Authentification Windows.
       -password <mot de passe>
          Mot de passe du compte d'utilisateur Portrait Shared Services.
       -timeout <valeur de temporisation (en minutes)>
          Durée maximale à attendre, une fois que la construction de la version de jeu de données a été lancée, pour
          obtenir le statut de construction final (réussite ou échec). Si cet argument est omis
          ou si sa valeur est définie sur 0, une limite de temporisation par défaut de 10 minutes s'applique.
          Remarque : À l'expiration de la temporisation et lorsque le processus de cette commande se ferme, la construction
          de la version de jeu de données se poursuit sur le serveur. Vous pouvez contacter un administrateur Explorer pour savoir
          si la construction de la version de jeu de données s'est correctement terminée ou a échoué.
Sujet parent : Commandes pour les jeux de données Explorer


Exportation de règles depuis l'interface utilisateur de Portrait Miner

  • Exportation de règles depuis Decision Studio
  • Exportation de règles depuis Portrait Miner
  • Création de règles d'optimisation des contacts
Sujet parent : Utilisation de PSSConnector


Exportation de règles depuis Decision Studio

Le composant module complémentaire PSSConnector ajoute de nouveaux boutons de barre d'outils spécifiques à l'interface utilisateur du module Decision Studio de Portrait Miner ; un bouton Publication d'une règle sur le référentiel Portrait Shared Repository est ajouté à l'outil Aperçu du tableau.

Ce bouton vous permet d'exporter une définition de règle de champ calculé vers le domaine client sélectionné dans Portrait Dialogue. Si vous fournissez un nom de règle qui existe déjà, la définition de la règle sera mise à jour.

L'Aperçu du tableau de Decision Studio fournit également un bouton pour démarrer l'application Gestion des connexions à Portrait Shared Services, pour vous permettre d'ouvrir ou de fermer une session en utilisant un nom d'utilisateur et un mot de passe explicites ou une Authentification Windows, lorsque c'est possible.

Cette interface utilisateur permet d'accéder à la plupart des fonctionnalités fournies par la commande data build pssrulepublish.

Sujet parent : Exportation de règles depuis l'interface utilisateur de Portrait Miner


Exportation de règles depuis Portrait Miner

Portrait Miner a été étendu et présente désormais une interface alternative vous permettant d'intégrer des résultats analytiques à Portrait Dialogue.
  • Authentification : Dans la barre d'outils Portrait Miner, l'application Gestion des connexions à Portrait Shared Services vous permet d'ouvrir ou de fermer une session depuis Portrait Shared Services.

    Avec un serveur Portrait Miner Windows, votre connexion à Portrait Shared Services est établie automatiquement avec l'Authentification Windows, si possible.

    Pour se connecter un utilisant un compte différent, vous devez fermer la session puis la rouvrir en utilisant les autorisations appropriées au compte.
  • Afficher des règles exportées : Dans la barre d'outils de Portrait Miner, l'application Gestion des règles dans le référentiel Portrait Shared Repository vous permet d'afficher la liste des règles analytiques qui ont été publiées. Vous devez sélectionner un Domaine client, vous pouvez alors afficher les règles qui sont publiées pour ce domaine. Cette interface utilisateur permet d'accéder à la plupart des fonctionnalités fournies par les commandes data build pssrulelist et pssruledescribe.

    Vous pouvez réexporter une règle vers le système de fichiers du serveur sous forme de fichier QMML avec la fonction Enregistrer sous par clic droit de la souris sur une règle. Cette interface utilisateur permet d'accéder à la plupart des fonctionnalités fournies par la commande data build pssruleretrieve.

  • Exportation de règles: Lors de la sélection d'un fichier .qmml dans Portrait Miner, l'action par clic droit Publication d'une règle sur le référentiel Portrait Shared Repository vous permet de publier la description du modèle (QMML) sous forme de règle à utiliser dans Portrait Dialogue. Vous êtes invité à saisir le nom, le type et la description à affecter à la règle et le nom du domaine client dans lequel la publier. Cette interface utilisateur permet d'accéder à la plupart des fonctionnalités fournies par la commande data build pssrulepublish.

Les applications de la barre d'outils sont également disponibles depuis le menu Lancer de Portrait Miner.

Sujet parent : Exportation de règles depuis l'interface utilisateur de Portrait Miner


Création de règles d'optimisation des contacts

Portrait Optimizer est une extension de Portrait Miner vous permettant de créer et de déployer des règles d'optimisation des contacts dans Portrait Dialogue. Vous pouvez trouver plus de détails dans le Guide de l'utilisateur Portrait Optimizer.

Sujet parent : Exportation de règles depuis l'interface utilisateur de Portrait Miner


Exportation de règles par lots

Les commandes data build (DBC) suivantes sont fournies pour vous permettre d'exporter des règles analytiques vers Portrait Dialogue en tant que partie d'un lot ou d'un processus programmé. Les commandes requièrent toutes des arguments explicites -username et -password, à moins que l'authentification de votre compte utilisateur Windows ne soit activée sur votre compte d'utilisateur.

  • Mappage de données
  • Intégration de règle
  • Intégration d'optimisations des contacts
Sujet parent : Utilisation de PSSConnector


Mappage de données

Si votre jeu de données analytiques est construit à l'aide de noms de champ différents des noms de champ sous-jacents de Portrait Dialogue ou Interaction Optimizer, ou s'il doit être résolu par des expressions Portrait Dialogue plutôt que par des références de champ (par exemple, si l'analyse est réalisée sur une mesure de transaction), vous devez publier une définition de mappages d'entrée de règle. Ce système permet de contrôler la manière dont Portrait Dialogue ou Interaction Optimizer recherche les données des valeurs d'entrée requises par la règle analytique auprès d'un système cible, en cas d'exécution d'une règle analytique ou d'une optimisation des décisions dans le cadre d'une activité de dialogue Portrait Dialogue ou d'une interaction Interaction Optimizer.

Remarque :
  • Il doit y avoir un mappage par champ dans le fichier de mappage : les mappages multiples par source ou par destination ne sont pas autorisés.
  • pssmappingpublish
  • pssmappingretrieve
  • Format de mappage d'entrée de règle
Sujet parent : Exportation de règles par lots


pssmappingpublish

Cette règle publie un ensemble de mappages d'entrée de règle pour un domaine PSS logique.

Résumé
pssmappingpublish -domain <domain name>-input <XML mappings file>
    [-password <password>][-replace][-username <username>]

Arguments facultatifs

Option | Effet
-password | Le mot de passe pour Portrait Shared Services.
-username | Le nom d'utilisateur pour Portrait Shared Services.
Sujet parent : Mappage de données


pssmappingretrieve

Cette règle récupère un ensemble de mappages d'entrée de règle pour un domaine PSS logique et les enregistre sous forme de fichier XML.

Résumé
pssmappingretrieve -domain <domain name>
    -output <XML mappings file> -target <the name of the target system the mapping is for>
    [-password <password>][-replace][-username <username>]

Arguments facultatifs

Option | Effet
-password | Le mot de passe pour Portrait Shared Services.
-username | Le nom d'utilisateur pour Portrait Shared Services.
Sujet parent : Mappage de données


Format de mappage d'entrée de règle

Un fichier de mappages d'entrée de règle se présente au format XML et fournit les noms de source (la manière dont le champ est sourcé dans le système cible) et d'inputName (nom de la règle d'entrée). Vous n'avez pas à fournir de mappages pour les champs portant le même nom dans le système cible et dans la règle. La balise <système de mappage=""> est utilisée pour spécifier le système cible pour lequel le mappage doit être utilisé. Pour cibler Portrait Dialogue, le système de mappage doit être défini sur Portrait Dialogue, et, pour cibler Interaction Optimizer, il doit être défini sur IO. Il ne peut exister qu'un seul mappage pour chaque système d'un domaine logique.

Par exemple, le déploiement de règles pour Portrait Dialogue utilise le format suivant :
<?xml version="1.0" encoding="UTF-8"?>
<mapping system="PD">
    <inputMap inputName="Analytics-RuleInputName" inputType="string" source="TargetSystem-DataSource" sourceType="FIELD or FUNCTION"/>
    ...
</mapping>

Le fichier de mappage est déployé avec la commande pssmappingpublish.

Lorsque les mappages d'entrée de règle doivent être modifiés (par exemple, si vous créez une règle qui utilise des champs supplémentaires n'ayant pas encore été mappés), vous pouvez importer un nouvel ensemble de mappages pour ce domaine et les nouveaux mappages prennent effet immédiatement. Toute exécution ultérieure d'opérations de règle analytique ou d'optimisation des décisions dans des dialogues Portrait Dialogue de ce domaine hérite immédiatement de la nouvelle définition de mappage.

Un élément inputMap dans un fichier de mappage présente les attributs suivants :
  • inputName : Il s'agit du nom de l'entrée de règle, généralement le nom du champ d'un jeu de données Portrait Miner sur lequel la règle a été construite.
  • inputType : Cet attribut décrit le type de champ de l'environnement Analytics. L'attribut prend la valeur integer, real, string ou date. C'est uniquement à titre descriptif - cela n'a aucun effet sur la signification du mappage du champ.
  • source : En conjonction avec l'attribut sourceType, il détermine la manière dont la valeur d'entrée de la valeur est obtenue dans le système cible. Dans Portrait Dialogue, si la valeur sourceType est FIELD, l'attribut spécifie le nom du champ de domaine client correspondant à utiliser comme source pour l'entrée. Si sourceType est défini sur FUNCTION, cet attribut contient la fonction Portrait Dialogue à utiliser pour obtenir la valeur d'entrée.
  • sourceType : Vous pouvez définir cet attribut soit par sourcetype="FIELD" aussi bien pour Portrait Dialogue que pour Interaction Optimizer, soit par sourcetype="FUNCTION", et spécifier si Portrait Dialogue doit sourcer l'entrée de règle depuis un champ du Domaine client ou une expression Portrait Dialogue.

Si sourcetype est défini sur FUNCTION, la valeur de l'attribut source doit être une expression Portrait Dialogue valide renvoyant une seule valeur de l'un des types de données suivants : string, integer, float, datetime/date ou boolean (où Boolean est mappé aux valeurs entières 0 pour false et 1 pour true).

Exemple

Voici un exemple de fichier de mappage utilisant ces fonctions :

<?xml version="1.0" ?>
<mapping system="PD">
   <!-- Maps to the answer of an integer question in a
     questionnaire. Returns NULL if the customer has not answered
     that questionnaire -->
   <inputMap inputName="TI_Q1" inputType="integer" sourceType="FUNCTION"
     sourceName="AnswerInt(1014,'Q1', '')" />

   <!-- Maps to the answer of single choice question (radio buttons)
     in a questionnaire. Returns the alternative key (e.g. "A1"),
     and NULL if the customer has not answered that questionnaire
   -->
   <inputMap inputName="TI_Q2" inputType="string" sourceType="FUNCTION"
              source="AnswerSingleChoice(1014, 'Q2')" />

   <!-- Maps to the answer of a boolean alternative of a question
     (checkboxes) in a questionnaire. Returns true/false, and NULL
     if the customer has not answered that questionnaire -->
   <inputMap inputName="TI_Q2_BOOL" inputType="integer" sourceType="FUNCTION"
              source="IsAnswered(1014, 'Q2', 'A1')" />

   <!-- Checks if a message of a specific template has been created
     for the customer. Returns true/false -->
   <inputMap inputName="TI_MSG_TEMPLATE_1170" inputType="integer" sourceType="FUNCTION"
              source="hasMessages[templateid = 1170]" />

   <!-- Checks if a customer has a specific value in a category with
     values. Returns true/false -->
   <inputMap inputName="TI_CATEGORY_1011_I5" inputType="integer" sourceType="FUNCTION"
              source="hasCategories[Name = 'CATEGORY_1011' and
              Value = 'I5']" />

   <!-- Checks if a customer has been treated by a dialog operation
     (requires participant logging in the dialog). Returns
     true/false -->
   <inputMap inputName="TI_OFFER_1" inputType="integer" sourceType="FUNCTION" ~
              source="HasOperationHistory(4519)" />

   <!-- Checks if a customer has been treated by a dialog branch
     (requires participant logging in the dialog). Returns
     true/false -->
   <inputMap inputName="TI_OFFER_2" inputType="integer" sourceType="FUNCTION"
              source="HasBranchHistory(1231)" />

   <!-- Counts the number of Orders a customer has -->
   <inputMap inputName="count_orders" inputType="integer" sourceType="FUNCTION"
              source="NumberOf(Orders) " />
              </mapping>
Sujet parent : Mappage de données


Intégration de règle

  • pssrulepublish
  • pssrulelist
  • pssruleretrieve
  • pssruledescribe
Sujet parent : Exportation de règles par lots


pssrulepublish

Cette règle publie le contenu d'un fichier QMML sous forme de règle nommée dans un domaine PSS logique incluant une description et son type de règle.

Résumé
          pssrulepublish -domain <domain name> -name <rule name>
          -description <text | @filename>
          -type <value | propensity | uplift>
          -input <QMML rule file>
          [-password <password>][-replace][-username <username>]

Arguments facultatifs

Option | Effet
-password | Le mot de passe pour Portrait Shared Services.
-replace | Remplace le QMML d'une règle existant au lieu d'en publier un nouveau. Lors du remplacement, les paramètres -type et -description sont en option.
-username | Le nom d'utilisateur pour Portrait Shared Services.
Sujet parent : Intégration de règle


pssrulelist

Cette règle répertorie les détails de toutes les règles associées à un domaine PSS logique spécifié.

Résumé
          pssrulelist -domain <domain name>
          [-password <password>][-username <username>][-xml]

Arguments facultatifs

Option | Effet
-password | Le mot de passe pour Portrait Shared Services.
-username | Le nom d'utilisateur pour Portrait Shared Services.
-xml | Indique la sortie au format XML.
Sujet parent : Intégration de règle


pssruleretrieve

Cette règle récupère le QMML compilé d'une règle nommée d'un domaine PSS logique dans un fichier.

Résumé
          pssruleretrieve -domain <domain name>-name<rule name>
          -output <QMML file>
          [-password <password>][-username <username>]

Arguments facultatifs

Option | Effet
-password | Le mot de passe pour Portrait Shared Services.
-username | Le nom d'utilisateur pour Portrait Shared Services.
Sujet parent : Intégration de règle


pssruledescribe

Cette règle répertorie les noms et les types des entrées et des sorties d'une règle nommée dans un domaine PSS logique. Ceci indique également comment la règle de mappage des entrées s'applique, en décrivant le mappage d'un champ ou d'une fonction, si un mappage est défini. Les paramètres pour la commande sont comme suit :

Résumé
          pssruledescribe -domain <domain name>-name <rule name>
          [-password <password>][-replace][-username <username>]

Arguments facultatifs

Option | Effet
-password | Le mot de passe pour Portrait Shared Services.
-username | Le nom d'utilisateur pour Portrait Shared Services.
Sujet parent : Intégration de règle


Intégration d'optimisations des contacts

Portrait Optimizer comporte un ensemble de commandes data build permettant le déploiement de modèles d'optimisation des contacts dans PSS.

  • pssoptpublish
  • pssoptlist
  • pssoptretrieve
  • pssoptreport
  • pssoptdescribe
Sujet parent : Exportation de règles par lots


pssoptpublish

Cette règle déploie un résultat d'optimisation des contacts dans un domaine PSS logique avec un nom et une description.

Résumé
          pssoptpublish -domain <domain name> -name <optimization name>
          -description <text | @filename> -input <QSOR file>
          [-password <password>][-replace][-username <username>]

Arguments facultatifs

Option | Effet
-password <mot de passe> | Le mot de passe pour Portrait Shared Services.
-replace | Remplace par les informations d'une optimisation existante au lieu d'en publier une nouvelle. Lors du remplacement, le paramètre -description est facultatif.
-username <mot de passe> | Le nom d'utilisateur pour Portrait Shared Services.
Sujet parent : Intégration d'optimisations des contacts


pssoptlist

Cette règle répertorie les optimisations des contacts d'un domaine PSS logique.

Résumé
          pssoptlist -domain <domain name>
          [-password <password>] [-username <username>][-xml]

Arguments facultatifs

Option | Effet
-password <mot de passe> | Le mot de passe pour Portrait Shared Services.
-xml | Indique la sortie au format XML.
-username <nom d'utilisateur> | Le nom d'utilisateur pour Portrait Shared Services.
Sujet parent : Intégration d'optimisations des contacts


pssoptretrieve

Cette règle récupère une seule optimisation des contacts auprès d'un domaine PSS logique et l'enregistre dans une archive de résultats d'optimisation des contacts.

Résumé
          pssoptretrieve -domain <domain name> -name <optimization name>
          -output <QSOR file>
          [-password <password>] [-username <username>]

Arguments facultatifs

Option | Effet
-password <mot de passe> | Le mot de passe pour Portrait Shared Services.
-username <nom d'utilisateur> | Le nom d'utilisateur pour Portrait Shared Services.
Sujet parent : Intégration d'optimisations des contacts


pssoptreport

Cette règle récupère un seul rapport d'optimisation des contacts auprès d'un domaine PSS logique et l'enregistre dans un fichier.

Résumé
          pssoptreport -domain <domain name> -name <optimization name>
          -output <HTML file>
          [-password <password>] [-username <username>]

Arguments facultatifs

Option | Effet
-password <mot de passe> | Le mot de passe pour Portrait Shared Services.
-username <nom d'utilisateur> | Le nom d'utilisateur pour Portrait Shared Services.
Sujet parent : Intégration d'optimisations des contacts


pssoptdescribe

Cette règle récupère les paramètres d'un seul rapport d'optimisation des contacts auprès d'un domaine PSS logique. Cette règle indique également le mode d'application des mappages d'entrée de règle, en décrivant le mappage d'un champ ou d'une fonction, si un mappage est défini pour le système cible indiqué.

Résumé
          pssoptdescribe -domain <domain name> -name <optimization name>
          [-target <system name>] [-password <password>] [-username <username>]

Arguments facultatifs

Option | Effet
-target <nom de système> | Nom du système cible pour les mappages de champs, par exemple Dialogue pour Portrait Dialogue ou IO pour Interaction Optimizer.
-password <mot de passe> | Le mot de passe pour Portrait Shared Services.
-username <nom d'utilisateur> | Le nom d'utilisateur pour Portrait Shared Services.
Sujet parent : Intégration d'optimisations des contacts


Visualisation des enregistrements clients dans un focus

  • Visualisation des enregistrements client


Visualisation des enregistrements client

Dans Decision Studio, vous pouvez utiliser l'Aperçu du tableau pour visualiser les données brutes dans des enregistrements client individuels. Pour ouvrir l'Aperçu du tableau depuis la fenêtre Decision Studio, choisissez Outils>Aperçu du tableau ou cliquez sur [image] dans la barre d'outils.

L'Aperçu du tableau indique initialement les données des 100 premiers clients de votre focus (le premier bloc d'enregistrement), en tenant compte de toute sélection d'enregistrement [voir Sélection d'enregistrements client] déjà en place.

Vous pouvez contrôler les champs [voir Choix des champs à visualiser] et les enregistrements [voir Affichage d'un bloc d'enregistrement différent] que l'Aperçu du tableau indique et vous pouvez visualiser les statistiques de base [voir Affichage des statistiques d'un champ] de chaque champ affiché.

Remarque : Si une valeur dans un champ de chaîne est une URL (par exemple http://www.portraitsoftware.com/), l'Aperçu du tableau indique la valeur en bleu et la souligne. Vous pouvez faire un double-clic sur la valeur à afficher pour visualiser la ressource associée dans votre navigateur Web.

Voir également

Calcul d'un champ avec l'Aperçu du tableau
Sujet parent : Visualisation des enregistrements clients dans un focus

Choix des champs à visualiser

  1. Choisissez Visualisation>Masquer/Afficher.

    La boîte de dialogue Masquer/Afficher/Réorganiser les champs s'affiche :

    • Utilisez les boutons [image] et [image] entre les volets Masquer et Afficher pour déplacer les champs surlignés d'un volet à l'autre.

      Les boutons [image] et [image] déplacent tous les champs, sans tenir compte du surlignage.

    • Utilisez les boutons [image] et [image] à droite du volet Afficher pour réorganiser les champs.
  2. Cliquez sur OK.
Remarque :
  • Vous pouvez aussi masquer les champs dans la visualisation en les surlignant dans l'Aperçu du tableau et en choisissant Champ>Masquer, ou en faisant un clic droit et en choisissant Masquer.

    Pour afficher un champ que vous avez masqué de cette façon, vous devez utiliser la boîte de dialogue Masquer/Afficher/Réorganiser les champs comme indiqué plus haut.

  • Masquer et réorganiser des champs n'affecte la visualisation que dans l'Aperçu du tableau. Le focus sous-jacent demeure inchangé.

Affichage d'un bloc d'enregistrement différent

Effectuer l'une des étapes suivantes :
  • Choisissez Afficher>Prochain bloc d'enregistrements ou cliquez sur [image] en bas de la barre de défilement pour voir le prochain bloc des 100 enregistrements.
  • Choisissez Afficher>Précédent bloc d'enregistrements ou cliquez sur [image] en haut de la barre de défilement pour voir le précédent bloc de 100 enregistrements.
  • Choisissez Affichage>Aller à l'enregistrement et saisissez le nom d'un enregistrement pour passer à un bloc d'enregistrement donné.
Remarque : L'Aperçu du tableau prend en compte n'importe quelle sélection d'enregistrement [voir Sélection d'enregistrements client] déjà en place.

Affichage des statistiques d'un champ

Choisissez Affichage>Statistiques.

L'Aperçu du tableau indique la valeur du minimum non null [voir La valeur null], la valeur du maximum non null et le nombre d'occurrences de null dans chaque champ :

Remarque : Pour des raisons d'efficacité, l'Aperçu du tableau ne met pas les statistiques à jour à chaque fois. Lorsque les statistiques de champ ne sont pas à jour, l'Aperçu du tableau les affiche grisées.
  • Pour mettre à jour les statistiques d'un champ ou d'un ensemble de champs, surlignez les champs et choisissez Champ>Mettre à jour les statistiques, ou faites un clic droit sur un champ et choisissez Mettre à jour les statistiques.


Sélection des enregistrements client dans un focus

  • Sélection d'enregistrements client
  • Sélection de valeur ou de filtrage à l'aide d'un champ qualitatif
  • Sélection ou filtrage de valeurs à l'aide d'un champ non qualitatif ou d'une statistique


Sélection d'enregistrements client

Vous pouvez sélectionner des enregistrements dans un focus d'après les valeurs d'un champ, soit en spécifiant un ensemble de valeurs requises [voir Sélection d'enregistrements d'un focus par valeur], soit en spécifiant le nombre d'enregistrements [voir Sélection d'un nombre donné d'enregistrements] que vous désirez. Les visionneuses graphiques et les outils de modélisation utilisent le focus pour agir uniquement sur les enregistrements sélectionnés.
Remarque :
  • Vous pouvez appliquer les sélections d'enregistrements en vous basant sur un ou plusieurs champs à la fois, auquel cas l'effet des sélections d'enregistrements sont cumulatives, c'est à dire que les enregistrements sélectionnés remplissent toutes les conditions choisies.
  • Si une sélection d'enregistrement est associée à un champ, un « S » apparaît dans la colonne Sélection de la fenêtre Decision Studio. Pour un champ non qualitatif, les intervalles sélectionnés apparaissent également dans cette colonne dans la notation mathématique standard, %TODO : Développez selon ceci, en même temps qu'un « +N » ou « -N » selon que la valeur null [voir La valeur null] est incluse ou non.
  • Les sélections peuvent être effacées ou modifiées même après qu'un focus a été sauvegardé et rouvert.
  • Vous pouvez réduire le temps que dure une sélection en fermant les autres fenêtres dont vous n'avez plus besoin.
  • La présence d'une sélection d'enregistrement n'améliore pas la vitesse des opérations dans le focus.

Voir également

Métadonnées des fichier focus
Sujet parent : Sélection des enregistrements client dans un focus

Sélection d'enregistrements d'un focus par valeur

  1. Dans la fenêtre Decision Studio, surlignez le champ que vous désirez utiliser pour la sélection d'enregistrement.
  2. Choisissez Champ>Sélectionner des valeurs ou faites un clic droit et choisissez Sélectionner des valeurs ou cliquez sur [image] dans la barre d'outils.

    La boîte de dialogue Sélectionner des valeurs s'affiche.

  3. Faites une sélection d'enregistrement basée sur les valeurs du champ.

    Il existe différentes options pour la sélection qualitative [voir Sélection de valeur ou de filtrage à l'aide d'un champ qualitatif] et la sélection non qualitative [voir Sélection ou filtrage de valeurs à l'aide d'un champ non qualitatif ou d'une statistique].

  4. Cliquez sur OK, pour confirmer votre sélection et fermez la fenêtre Sélectionner des valeurs.
Remarque :
  • Vous pouvez aussi ouvrir la fenêtre Sélectionner les valeurs depuis la plupart des listes de champs via le menu de clic droit sur un champ.
  • Dans l'Aperçu du tableau croisé, l'Aperçu de la carte, l'Aperçu du profil et l'Aperçu de la distribution croisée, vous pouvez accéder à la fenêtre Sélectionner les valeurs en faisant un clic droit sur un champ dans la zone de configuration graphique.

Sélection d'un nombre donné d'enregistrements

  1. Dans la fenêtre Decision Studio, surlignez le champ numérique que vous désirez utiliser pour la sélection d'enregistrement.
  2. S'il existe déjà une sélection d'enregistrement sur un champ, vous devez supprimer la sélection [voir Suppression d'une sélection d'enregistrements dans un champ].
  3. Choisissez Champ>Sélectionner la quantité ou faites un clic droit et choisissez Sélectionner la quantité.

    La boîte de dialogue Sélectionner la quantité s'affiche :

  4. Sélectionnez s'il faut choisir les enregistrements ayant les plus hautes (haut) ou les plus basses (bas) valeurs.
  5. Saisissez soit un pourcentage des enregistrements disponibles, soit un nombre exact d'enregistrements, et choisissez « % » ou « # » en conséquence dans le menu déroulant.
  6. Choisissez s'il faut ajuster la quantité vers le haut ou vers le bas en cas d'équivalences.

    Il peut arriver, lorsque tous les enregistrements sont classés selon leur valeur dans le champ choisi, que des enregistrements ayant la même valeur dans le champ chevauchent le seuil de quantité choisi. Plutôt que d'inclure arbitrairement certains de ces enregistrements client, Decision Studio vous laisse la possibilité de tous les inclure (en ajustant la quantité vers le haut) ou de tous les exclure (en ajustant la quantité vers le bas).

  7. Cliquez sur OK, pour confirmer votre sélection et fermez la fenêtre Sélectionner des valeurs.
Remarque : Après avoir fait une sélection d'enregistrement par quantité, il n'est plus possible de la distinguer d'une sélection d'enregistrement faite en sélectionnant des valeurs. Cependant, vous pouvez effectuer une sélection par valeur [voir Sélection d'enregistrements d'un focus par valeur] pour affiner votre sélection d'enregistrements si nécessaire. Toutefois, vous ne pouvez pas sélectionner de nouveau en fonction de la quantité sans supprimer d'abord la sélection.

Suppression d'une sélection d'enregistrements dans un champ

  1. Dans la fenêtre Decision Studio, surlignez le champ comportant l'enregistrement de sélection associé.
  2. Choisissez Champ>Effacer la sélection ou faites un clic droit et choisissez Effacer la sélection, ou encore cliquez sur [image] dans la barre d'outils.

Suppression de toutes les sélections d'enregistrement d'un focus

Choisissez Focus>Effacer toutes les sélections.


Sélection de valeur ou de filtrage à l'aide d'un champ qualitatif

Lorsque vous utilisez des valeurs dans un champ qualitatif [voir Interprétations des champs] pour sélectionner des enregistrements par valeur [voir Sélection d'enregistrements d'un focus par valeur] dans un focus, ou appliquer un filtre à un champ qualitatif qui est associé [voir Association d'un champ ou d'une statistique sous forme de tableau croisé/graphique] à certains aspects d'un tableau croisé ou d'un graphique, la fenêtre Sélectionner des valeurs ou Filtrer ressemble à ceci :

Les volets affichent des catégories sélectionnées et non sélectionnées, qui sont soit les valeurs réelles du champ (les catégories de base), soit les catégories du découpage en cours [voir Modification d'un découpage par catégorie], le cas échéant.

Vous pouvez déplacer les catégories surlignées d'un volet à l'autre à l'aide d'un des boutons à simple flèche ou sélectionner/désélectionner toutes les catégories à l'aide d'un des boutons à double flèche. Pour basculer entre les catégories sélectionnées et désélectionnées, cliquez sur [image].

Voir également

Sélection d'un nombre donné d'enregistrements

Sélection ou filtrage de valeurs à l'aide d'un champ non qualitatif ou d'une statistique

Sujet parent : Sélection des enregistrements client dans un focus


Sélection ou filtrage de valeurs à l'aide d'un champ non qualitatif ou d'une statistique

Lorsque vous utilisez des valeurs dans un champ numérique non qualitatif ou de date pour sélectionner des enregistrements par valeur [voir Sélection d'enregistrements d'un focus par valeur] dans un focus, ou appliquer un filtre à un champ non qualitatif ou à une statistique qui est associé [voir Association d'un champ ou d'une statistique sous forme de tableau croisé/graphique] avec certains aspects d'un tableau croisé ou d'un graphique, la fenêtre Sélectionner des valeurs ou Filtrer ressemble à cela :

La barre horizontale représente la plage de valeurs dans le champ ou la statistique, avec des portions remplies représentant les valeurs sélectionnées. Le coin pointant vers le bas de chaque extrémité d'une modalité sélectionnée est soit plein ( [image]) pour indiquer que la valeur limite est incluse dans la modalité, soit souligné ( [image]) pour indiquer que la valeur limite est exclue de la modalité.

Lorsque vous surlignez une plage sélectionnée en cliquant dessus, le volet sous la barre indique les valeurs des deux extrémités, ainsi que leurs détails s'ils ont été inclus. Vous pouvez passer d'une plage sélectionnée à l'autre avec les boutons fléchés de chaque côté de ce volet.

Remarque :
  • Si un champ ou une statistique n'a pas de sélection/d'enregistrement qui lui est associé, la barre horizontale dans la fenêtre Sélectionner des valeurs ou Filtrer ne présente qu'une seule plage sélectionnée, avec les deux extrémités incluses.
  • La valeur null [voir La valeur null] est incluse ou exclue selon le paramétrage du menu Traitement des données non renseignées.

    Si vous sélectionnez explicitement une plage d'enregistrements donnée, vous pouvez choisir si votre sélection inclut les enregistrements contenant la valeur null (Toujours inclure) ou vous pouvez les exclure (Toujours exclure ou Exclure de la sélection explicite).

    Pour sélectionner uniquement les enregistrements contenant la valeur null, choisissez Sélectionner l'exclusivité.

    Pour sélectionner tous les enregistrements contenant une valeur non null, ne sélectionnez pas de plage explicite (en modifiant les valeurs ou en faisant glisser les extrémités), mais choisissez simplement Toujours exclure.

Voir également

Sélection d'un nombre donné d'enregistrements

Sélection de valeur ou de filtrage à l'aide d'un champ qualitatif

Sujet parent : Sélection des enregistrements client dans un focus

Ajout d'une plage à la sélection

Cliquez sur [image].

S'il existe des valeurs non sélectionnées à droite de la plage actuellement surlignée, la nouvelle plage remplit le premier interstice disponible sur la droite. Sinon, s'il existe des valeurs non sélectionnées à gauche de la plage actuellement surlignée, la nouvelle plage remplit le premier interstice disponible sur la gauche. Si aucune valeur n'est sélectionnée, Decision Studio divise la plage existante la plus large pour créer une paire de nouvelles plages.

Suppression d'une plage de la sélection

  1. Cliquez sur la plage pour la surligner.
  2. Cliquez sur [image].
Remarque : Pour supprimer toutes les plages sélectionnées, cliquez sur [image].

Inclusion ou exclusion d'un point d'extrémité d'une plage

Faites un double clic sur le coin correspondant pour modifier son état, ou surlignez la page en cliquant dessus et choisissez Inclus ou Exclus dans la liste déroulante appropriée.
Remarque :
  • Vous pouvez désactiver le point d'extrémité gauche de la plage sélectionnée à l'extrême gauche (ou le point d'extrémité droit de la plage à l'extrême droite) en choisissant Désactivé dans le menu déroulant des points d'extrémité (au lieu de Inclus ou Exclus). Le coin marquant le point d'extrémité disparaît alors pour indiquer que la plage sélectionnée est illimitée.
  • Pour une sélection à partir de dates, les plages incluent toujours leurs points d'extrémité.

Ajustement d'un point d'extrémité dans une plage

Faites glisser le coin correspondant vers la droite ou la gauche, ou faites glisser la plage entière pour modifier les points d'extrémité simultanément, en préservant ainsi la longueur de la plage.

Sinon, surlignez la plage et saisissez une valeur dans la zone de texte appropriée.

Remarque : Vous pouvez utiliser le bouton [image] ou [image] à côté d'une zone de texte limite pour forcer le point final à passer à la valeur suivante la plus basse ou la plus haute se produisant effectivement dans les données.

Inversion d'une sélection de plages

Cliquez sur [image].

Les interstices entre les plages sélectionnées deviennent les nouvelles plages sélectionnées.


Groupement d'enregistrements client par découpage d'un champ de focus

  • Modification d'un découpage par catégorie
  • Modification d'un découpage non qualitatif
  • Modification d'un découpage non qualitatif défini par l'utilisateur
  • Options d'affichage des découpages
  • Jonction d'un découpage supplémentaire à un champ non qualitatif
  • Application d'un découpage à plusieurs champs.
  • Optimisation du découpage d'un champ


Modification d'un découpage par catégorie

  1. Dans la fenêtre Decision Studio, sélectionnez le champ qualitatif [voir Interprétations des champs] dont vous désirez modifier le découpage. Choisissez Outils>Éditeur de découpage ou appuyez sur CTRL+B, ou cliquez sur [image] dans la barre d'outils.
  2. Ou bien, à partir des listes de champs dans les outils de modélisation, sélectionnez le champ, faites un clic droit et choisissez Éditeur de découpage.
  3. Ou encore, dans les visionneuses graphiques, faites un clic droit sur un champ dans la zone de configuration graphique et choisissez Éditeur de découpage.

    L'Éditeur de découpage s'ouvre, montrant un graphique du découpage en cours du champ que vous avez sélectionné. Dans l'angle inférieur gauche de la fenêtre se trouve le volet Hiérarchie, qui indique potentiellement la hiérarchie de découpages par catégories progressivement plus approximatifs dans le champ en cours. Le découpage sélectionné est le découpage en cours.

    S'il n'y a pas de découpage joint au champ, l'Éditeur de découpage crée un découpage nommé « unnamed node » (nœud sans nom) utilisant les paramètres par défaut [voir Suppression d'un découpage par catégorie d'un champ].

  4. Vous pouvez sélectionner un découpage différent dans le volet Hiérarchie ; ou d'en créer un nouveau en sélectionnant un découpage existant dans la hiérarchie et en cliquant sur Nouveau.

    Lorsque vous créez un nouveau découpage de cette façon, le découpage d'origine que vous avez sélectionné est le parent du nouveau découpage.

  5. Fusionnez ou séparez des catégories [voir Fusion ou division de catégories] pour créer un découpage plus approximatif ou plus fin [voir Renommage d'une catégorie], en renommant les nouvelles catégories de façon appropriée.
  6. Réordonnez les catégories [voir Réorganisation de catégories] dans le découpage si désiré.
  7. Cliquez sur Appliquer ou sur OK, pour confirmer vos modifications de la hiérarchie de découpage par catégorie.

    Sinon, cliquez sur Réinitialiser pour rejeter toutes les modifications que vous avez apportées à la hiérarchie de découpage par catégorie depuis la dernière fois où vous avez appliqué des modifications.

Remarque :
  • Lorsque vous appliquez les modifications, une hiérarchie de découpage par catégorie agit comme un découpage unique. Dans la plupart des autres cas, les niveaux individuels de la hiérarchie agissent comme des découpages séparés, avec le découpage en cours semblable au découpage primaire [voir Définition d'un découpage primaire d'un champ non qualitatif] d'un champ non qualitatif.
  • Vous pouvez modifier les découpages dans d'autres champs sans quitter l'Éditeur de découpage en cliquant sur l'onglet Champs et en sélectionnant le champ désiré.

Voir également

Modification d'un découpage non qualitatif
Sujet parent : Groupement d'enregistrements client par découpage d'un champ de focus

Fusion ou division de catégories

  1. Dans le volet Catégories, sélectionnez les catégories que vous désirez fusionner ou la catégorie unique précédemment fusionnée que vous désirez séparer.

    Le volet Catégories d'origine indique les catégories correspondantes dans le découpage parent (ou les catégories de base).

  2. Vous avez le choix entre les méthodes suivantes :
    • Cliquez sur Fusionner ou faites un clic droit dans le volet Catégories et choisissez Fusionner.

      L'Éditeur de découpage fusionne les catégories sélectionnées en une seule catégorie, nommée comme combinaison des noms de la catégorie d'origine séparés par des esperluettes.

    • Cliquez sur Séparer ou faites un clic droit dans le volet Catégories et choisissez Séparer. L'Éditeur de découpage sépare la catégorie sélectionnée en ses catégories parentes.

Renommage d'une catégorie

  1. Dans le volet Catégorie, faites un double clic sur la catégorie ou sélectionnez la catégorie en cliquant dessus, puis sur Renommer.
  2. Saisissez un nouveau nom pour la catégorie et appuyez sur Entrée.

Réorganisation de catégories

  1. Cliquez sur Réorganiser ou faites un clic droit dans le volet Catégories.
  2. Choisissez comment réorganiser les catégories :
    • Par ordre descendant (+) ou ascendant (-)
    • Par ordre alphabétique du nom de catégorie
    • Par numéro de catégorie, ascendant
Remarque : Lors du classement d'un découpage par numéro de catégorie, les catégories fusionnées suivent les catégories non fusionnées et sont classées selon la catégorie ayant le numéro le plus élevé dans chaque parent ; par exemple, une fusion des modalités 2 et 4 précède une fusion des modalités 1 et 5.

Pour renommer un découpage par catégorie

Vous pouvez attribuer des noms significatifs aux découpages dans la hiérarchie de découpage par catégorie d'un champ.
  1. Dans le volet Hiérarchie de l'Éditeur de découpage, sélectionnez le découpage que vous désirez renommer.
  2. Cliquez sur Renommer ou cliquez simplement de nouveau sur le nom du découpage.
  3. Saisissez le nom que vous avez choisi pour le découpage et appuyez sur Entrée.

Suppression d'un découpage par catégorie d'un champ

  1. Dans le volet Hiérarchie de l'Éditeur de découpage, sélectionnez le découpage que vous désirez supprimer.
  2. Cliquez sur Supprimer.
Remarque : Pour supprimer tous les découpages par catégories d'un ou plusieurs champs, effacez simplement l'interprétation qualitative sur les champs [voir Définition ou effacement d'une variable candidate, une interprétation clé, qualitative, géographique ou d'exportation].

Pour définir les paramètres par défaut de nouveaux découpages par catégories

  1. Choisissez Découpage>Paramètres par défaut ou cliquez sur [image] dans la barre d'outils.
  2. Sous l'onglet Qualitatif, définissez le nombre maximal de catégories séparées et le nombre d'enregistrements minimal dans une seule catégorie.
  3. Cliquez sur OK, pour confirmer vos choix.
Remarque :
  • Si le nombre d'enregistrements contenant une valeur donnée tombe en dessous du nombre d'enregistrements pour une seule catégorie (généralement car le champ contient de trop nombreuses valeurs distinctes), les enregistrements contenant cette valeur sont non classés. Les enregistrements non classés n'apparaissent pas par défaut dans l'Éditeur de découpage ; pour les afficher, choisissez Afficher>Données non classées.
  • Pour appliquer les nouveaux paramètres par défaut d'un champ qui a déjà une interprétation qualitative, vous devez effacer l'interprétation qualitative existant déjà [voir Définition ou effacement d'une variable candidate, une interprétation clé, qualitative, géographique ou d'exportation].


Modification d'un découpage non qualitatif

  1. Dans la fenêtre Decision Studio, sélectionnez le champ non qualitatif [voir Interprétations des champs] numérique ou de date dont vous désirez modifier le découpage. Choisissez Outils>Éditeur de découpage ou appuyez sur CTRL+B, ou cliquez sur [image] dans la barre d'outils.
  2. Ou bien, à partir des listes de champs dans les outils de modélisation, sélectionnez le champ, faites un clic droit et choisissez Éditeur de découpage.
  3. Ou encore, dans les visionneuses graphiques, faites un clic droit sur un champ dans la zone de configuration graphique et choisissez Éditeur de découpage.

    L'Éditeur de découpage s'ouvre, montrant un graphique du découpage primaire [voir Définition d'un découpage primaire d'un champ non qualitatif] pour le champ que vous avez sélectionné.

    S'il n'existe pas de découpage joint au champ, l'Éditeur de découpage crée un découpage utilisant les paramètres par défaut [voir Définition des paramètres par défaut de nouveaux découpages non qualitatifs].

  4. Dans le volet Style, sélectionnez le type de découpage requis.
    • Pour un découpage par plage égale, vous pouvez définir soit le nombre cible des modalités internes (modalités entre les modalités de fin) [voir Modalités de fin]), soit la largeur de modalité cible.
    • Pour un découpage par population égale, vous pouvez définir le nombre cible de modalités internes.
    • Pour un découpage par plage égale ou population égale évalué par date, vous pouvez aussi spécifier les unités dans lesquelles sont mesurées les largeurs d'intervalles (jours, semaines, etc.).
    • Pour un découpage défini par l'utilisateur, cliquez sur Éditer pour spécifier les limites de découpage individuel [voir Modification d'un découpage non qualitatif défini par l'utilisateur] dans la boîte de dialogue Défini par l'utilisateur.
  5. Cliquez sur Appliquer ou sur OK pour confirmer vos modifications de découpage.

    Sinon, cliquez sur Réinitialiser pour rejeter toutes les modifications que vous avez apportées au découpage depuis la dernière fois où vous avez appliqué des modifications.

Remarque :
  • Pour des champs de type réel, afin d'obliger l'Éditeur de découpage à situer les limites de découpage sur des valeurs entières, cochez Découpage>Limites à valeur entière.
  • Le nombre final de modalités internes peut différer du nombre cible d'un champ de type entier ou si Découpage>Limites à valeur entière est coché. Ceci se produit pour diverses raisons :
    • La plage du champ n'inclut pas suffisamment de limites à valeur entière.
    • Découpage>Ajuster automatiquement le nombre de modalités est coché, et au moins l'une des limites de fin de modalité doit être choisie automatiquement ; dans ce cas, l'Éditeur de découpage peut ajuster le nombre de modalités pour localiser les limites de modalité sur des valeurs entières. Pour forcer le nombre de modalités final à être identique à celui du nombre cible, décochez Découpage>Ajuster automatiquement le nombre de modalités et cliquez sur Appliquer ou sur OK.
  • Pour un découpage défini par l'utilisateur, les modifications prennent effet lorsque vous cliquez sur OK dans la boîte de dialogue Défini par l'utilisateur. Par conséquent il n'est pas nécessaire de cliquer sur Appliquer dans l'Éditeur de découpage (et vous ne pouvez pas revenir au découpage d'origine à l'aide de Réinitialiser).
  • Vous pouvez modifier les découpages dans d'autres champs sans quitter l'Éditeur de découpage en cliquant sur l'onglet Champs et en sélectionnant le champ désiré.

Voir également

Jonction d'un découpage supplémentaire à un champ non qualitatif

Modification d'un découpage par catégorie

Sujet parent : Groupement d'enregistrements client par découpage d'un champ de focus

Modalités de fin

Les modalités de population égale et de plage égale dans Decision Studio divisent une plage numérique ou de date en une série de modalités. La plupart de ces modalités sont « internes », mais il peut y avoir une modalité de fin spéciale à chaque extrémité de la plage.

Lorsque Decision Studio crée un découpage numérique avec des modalités de fin, il utilise un algorithme intelligent pour classer certaines valeurs en tant que valeurs incohérentes. Les enregistrements contenant ces valeurs incohérentes tombent dans les modalités de fin, alors que la majorité des enregistrements tombe dans les modalités internes.

Dans l'Éditeur de découpage de Decision Studio, vous pouvez contrôler l'utilisation des modalités de fin, dans des découpages de plage égale ou de population égale, en utilisant les menus déroulants des volets Modalité de fin minimale et Modalité de fin maximale :
  • Si vous choisissez Auto pour un découpage numérique de plage égale, l'Éditeur de découpage choisit automatiquement la limite de modalité de fin.
  • Si vous choisissez Auto pour un découpage de date ou de population égale, l'Éditeur de découpage omet la modalité de fin.
  • Choisissez Fixé à pour spécifier une limite fixe de modalité de fin.
  • Choisissez Aucune pour omettre la modalité de fin dans chaque cas.

Vous pouvez aussi contrôler les modalités de fin dans un découpage défini par l'utilisateur [voir Modification d'un découpage non qualitatif défini par l'utilisateur].

Suppression d'un découpage non qualitatif d'un champ

  1. Dans l'Éditeur de découpage, si vous n'avez pas déjà sous les yeux le champ non qualitatif dont vous désirez supprimer le découpage, cliquez sur l'onglet Champs et sélectionnez le champ.
  2. Choisissez Découpage>Supprimer les découpages ou faites un clic droit dans le volet Champs et choisissez Supprimer des découpages ou cliquez sur [image] dans la barre d'outils.
Remarque :
  • Vous pouvez supprimer simultanément les découpages de plusieurs champs non qualitatifs en choisissant Supprimer les découpages sur les champs multiples. La boîte de dialogue Sélectionner des champs s'affiche, dans laquelle vous pouvez choisir les champs dont vous voulez supprimer les découpages.
  • Comme leur nom le suggère, les options Supprimer des découpages et Supprimer les découpages sur les champs multiples suppriment tous les découpages associés à un champ non qualitatif. Si vous avez utilisé la fonctionnalité découpages multiples de Decision Studio pour joindre plusieurs découpages à un champ [voir Jonction d'un découpage supplémentaire à un champ non qualitatif], vous pouvez supprimer un découpage séparément en choisissant Découpage>Gérer des découpages multiples : sélectionnez le découpage requis dans la boîte de dialogue Gérer des découpages multiples et cliquez sur Supprimer.

Définition des paramètres par défaut de nouveaux découpages non qualitatifs

  1. Dans l'Éditeur de découpage, choisissez Découpage>Paramètres par défaut ou cliquez sur [image] dans la barre d'outils.
  2. Sous l'onglet Non qualitatif, choisissez le nombre de modalités ciblé (en excluant les modalités null, non classées [voir La valeur null] et de fin [voir Modalités de fin]), le type de découpage [voir Modification d'un découpage non qualitatif], et en précisant s'il faut afficher les modalités avec des largeurs proportionnelles [voir Options histogramme et graphique à barres].
  3. Cliquez sur OK, pour confirmer vos choix.
Remarque :

Pour appliquer les nouveaux paramètres par défaut à un champ qui a déjà un découpage, vous devez supprimer [voir Suppression d'un découpage non qualitatif d'un champ] le découpage existant.


Modification d'un découpage non qualitatif défini par l'utilisateur

Lorsque vous cliquez sur Éditer dans l'Éditeur de découpage pour un découpage défini par l'utilisateur, la boîte de dialogue Défini par l'utilisateur s'affiche :

Travaillez à partir du découpage existant (peut-être un découpage par plage égale ou par population égale), ou cliquez sur Démarrage rapide pour commencer par un découpage prédéfini [voir Utilisation de découpages prédéfinis prêts à l'emploi]. Ajustez ensuite le découpage selon vos besoins :
  • Modifiez les limites des modalités directement dans le tableau ou en les manipulant dans l'affichage graphique (qui fonctionne comme l'affichage graphique pour la sélection/le filtrage de résultats [voir Sélection ou filtrage de valeurs à l'aide d'un champ non qualitatif ou d'une statistique]).
  • Augmentez le nombre de modalités en sélectionnant une modalité (dans le tableau ou la vue graphique) et en cliquant sur Découper la plage.

    La modalité se sépare en deux modalités de taille égale.

  • Diminuez le nombre de modalités en sélectionnant une modalité et en cliquant sur Supprimer la plage.

    La modalité fusionne avec sa voisine de droite (ou de gauche dans le cas de la modalité la plus à droite).

  • Contrôlez l'utilisation des modalités de fin [voir Modalités de fin] en choisissant Les deux, Aucun, Inférieur ou Supérieur dans le menu déroulant.
Remarque : En modifiant la valeur d'une limite de modalité, ou en cochant ou désélectionnant Inclure depuis, vous pouvez laisser une ou plusieurs modalités définies de façon à ce qu'elles ne puissent pas contenir de valeur. Ce type de modalité non valide est surligné par des lignes rouges dans le tableau et libellée « non valide ».

Pour retirer tous les modalités non valides de votre découpage, cliquez sur Supprimer la valeur non valide.

Voir également

Modification d'un découpage non qualitatif
Sujet parent : Groupement d'enregistrements client par découpage d'un champ de focus

Utilisation de découpages prédéfinis prêts à l'emploi

lorsque vous cliquez sur Démarrage rapide dans la boîte de dialogue Défini par l'utilisateur, la boîte de dialogue Présélections personnalisées s'affiche :

En choisissant le type de prédéfinition approprié dans le menu déroulant, vous pouvez rapidement créer un découpage dans lequel les modalités entre les valeurs Découper depuis et Découper jusqu'à ont des propriétés utiles :
  • Dans un découpage par Séquence, toutes les modalités (sauf peut-être celles les plus à droite) ont une largeur donnée.
  • Dans un découpage par Log, il existe un nombre donné de modalités avec une largeur augmentant ou diminuant de façon logarithmique.
  • Dans un découpage par Largeur égale, il existe un nombre donné de modalités de largeur égale.
  • Dans un découpage Normal, les largeurs de modalité sont celles que vous obtiendriez pour un découpage par population égale si les données sélectionnées étaient normalement distribuées entre les valeurs Découper depuis et Découper jusqu'à : plus une modalité est proche de la valeur moyenne du champ, plus elle est étroite.
Remarque :
  • S'il existe des valeurs à gauche de la valeur Découper depuis ou à droite de la valeur Découper jusqu'à, les enregistrements qui les contiennent tombent dans les modalités supplémentaires (qui sont ou non classées en tant que modalités de fin [voir Modalités de fin]).
  • Si vous cochez Séparer la valeur 0 et qu'une modalité contient la valeur 0, cette modalité se divise jusqu'en trois modalités : une pour les valeurs inférieures à 0, une pour 0 lui-même et une pour les valeurs supérieures à 0.

    Ceci est utile lorsque zéro est une valeur spéciale, par exemple les clients présentant zéro dépense peuvent former un segment distinct.


Options d'affichage des découpages

L'Éditeur de découpage présente une vue graphique du découpage sélectionné, appliquée aux données du champ sélectionné.

Vous pouvez modifier les aspects de cette vue en paramétrant les options d'affichage globales de Decision Studio [voir Définition des options globales des affichages graphiques] ou en affichant ou masquant les modalités [voir Affichage ou masquage de segments ayant une valeur null et non classée dans un graphique] des valeurs null et non classées.

Vous pouvez aussi affecter l'affichage d'un découpage non qualitatif à la fois dans l'Éditeur de découpage et ailleurs, en choisissant parmi les options histogramme et graphique à barres [voir Options histogramme et graphique à barres] pour le découpage.

L'Éditeur de découpage présente aussi les informations numériques détaillées d'un découpage et le nombre d'enregistrements dans chaque modalité.

Voir également

Modification d'un découpage par catégorie

Modification d'un découpage non qualitatif

Sujet parent : Groupement d'enregistrements client par découpage d'un champ de focus

Options histogramme et graphique à barres

À part le type de découpage et les limites de découpage définissant un découpage, chaque découpage a un mode d'affichage qui lui est associé : soit un histogramme, soit un graphique à barres (ce dernier étant celui par défaut pour un découpage non qualitatif et l'unique option pour un découpage par catégories).
  • Dans un histogramme, chaque découpage (autre qu'une modalité de fin [voir Modalités de fin], une modalité de largeur zéro, ou les modalités null ou non classées [voir La valeur null]) a une largeur proportionnelle à la largeur de modalité sous-jacente. L'Éditeur de découpage représente la densité de probabilité par la hauteur d'une barre :

    Pour une modalité donnée (autre qu'une modalité de largeur zéro ou une modalité null ou non classée), vous pouvez calculer le nombre d'enregistrements en multipliant ensemble le nombre total d'enregistrements, la densité de probabilité et la largeur de modalité. Il ne s'agit pas de la largeur visuelle, qui est différente pour les modalités de fin. Pour un découpage par date, la largeur de modalité est mesurée en jours.

    L'affichage de l'histogramme fait la meilleure approximation graphique de la distribution des valeurs dans un champ.

    Pour afficher un découpage non qualitatif sous forme d'un histogramme dans l'Éditeur de découpage, cochez Afficher>Histogramme ou sélectionnez [image] sur la barre d'outils.

  • Dans un graphique à barres, toutes les modalités ont visuellement la même largeur (bien que la largeur de la modalité sous-jacente varie pour un découpage non qualitatif). L'Éditeur de découpage représente le nombre d'enregistrements de chaque modalité par une hauteur de barre.

    Lorsque les largeurs des modalités dans un découpage varient fortement, le graphique à barres indique plus clairement les limites de modalités et le nombre d'enregistrements.

    Pour afficher un découpage non qualitatif sous forme d'un graphique à barres dans l'Éditeur de découpage, décochez Afficher>Histogramme ou désélectionnez [image] sur la barre d'outils.

Étant donné que le mode d'affichage est l'une des propriétés d'un découpage plutôt qu'une sorte d'option d'affichage dans l'Éditeur de découpage, vous devez soit rendre votre modification permanente (en cliquant sur Appliquer), soit rejeter vos modifications lorsque vous passez à un autre découpage, soit encore fermer l'Éditeur de découpage.
Remarque :
  • Le mode d'affichage d'un découpage affecte les vues graphiques Dans l'Aperçu du profil et Aperçu de la distribution croisée : les divisions sur les axes sont d'égale largeur ou proportionnelles selon le mode choisi. Il existe une exception lorsque l'extension d'un bloc dans une direction donnée transmet des informations : dans ce cas, le paramètre d'affichage de l'Éditeur de découpage n'a aucun effet, de façon à ne pas induire d'erreur.
  • Dans l'Éditeur de découpage, dans les vues d'histogramme et de graphique à barres, la partie visualisée d'un intervalle (autre qu'une modalité de fin, une modalité de largeur zéro ou une modalité null ou non classée) est proportionnelle au nombre d'enregistrements dans la modalité.


Jonction d'un découpage supplémentaire à un champ non qualitatif

Vous pouvez joindre un ou plusieurs découpages à un champ non qualitatif dans un focus, bien qu'à un moment donné, un seul de ceux-ci (le découpage primaire) soit accessible aux outils de Decision Studio autres que l'Éditeur de découpage.
  1. Dans l'Éditeur de découpage, si vous n'avez pas déjà sous les yeux le champ que vous souhaitez découper, cliquez sur l'onglet Champs et sélectionnez le champ.
  2. Choisissez Découpage>Gérer des découpages multiples ou faites un clic droit dans le volet Champs et choisissez Gérer plusieurs champs.
  3. Dans la boîte de dialogue Gérer des découpages multiples, effectuez l'une des opérations suivantes :
    • Cliquez sur Ajouter.

      L'Éditeur de découpage crée un nouveau découpage avec les paramètres par défaut [voir Définition des paramètres par défaut de nouveaux découpages non qualitatifs] pour un découpage non qualitatif.

    • Sélectionnez un découpage existant et cliquez sur Dupliquer.

      L'Éditeur de découpage crée une copie du découpage sélectionné.

Remarque :
  • Pour utiliser le nouveau découpage, vous devez le faire dans le découpage primaire [voir Définition d'un découpage primaire d'un champ non qualitatif] du champ.
  • Pour vous aider à vous souvenir à quoi correspondent les découpages, vous pouvez leur donner des noms significatifs : faites un double clic sur le découpage dans la boîte de dialogue Gérer des découpages multiples.
Sujet parent : Groupement d'enregistrements client par découpage d'un champ de focus

Définition d'un découpage primaire d'un champ non qualitatif

  1. Dans l'Éditeur de découpage, si vous n'avez pas déjà sous les yeux le champ que vous souhaitez découper, cliquez sur l'onglet Champs et sélectionnez le champ.
  2. Choisissez Découpage>Gérer des découpages multiples ou faites un clic droit dans le volet Champs et choisissez Gérer plusieurs champs.
  3. Dans la boîte de dialogue Gérer des découpages multiples, cliquez sur Définir comme primaire.


Application d'un découpage à plusieurs champs.

Vous pouvez réutiliser un découpage en le créant sur ??un champ et en l'appliquant à d'autres champs similaires. Vous pouvez copier et coller [voir Copie d'un découpage vers un autre champ non qualitatif] un découpage non qualitatif d'un champ à l'autre ou l'enregistrer dans un fichier de découpage [voir Enregistrement d'un découpage non qualitatif] et ensuite appliquer le découpage [voir Application d'un découpage non qualitatif enregistré à un nouveau champ] à un autre champ. Vous pouvez également enregistrer une hiérarchie de découpage par catégories [voir Enregistrement d'une hiérarchie de découpage par catégories], puis appliquer la hiérarchie [voir Application d'une hiérarchie de découpage par catégories enregistré à un nouveau champ] à un autre champ.
Remarque : En général, vous appliquez un découpage enregistré ou une hiérarchie de découpage par catégories à un champ dans un fichier focus différent : pour les champs non qualitatifs du même fichier focus, copiez et collez-le simplement.
Sujet parent : Groupement d'enregistrements client par découpage d'un champ de focus

Copie d'un découpage vers un autre champ non qualitatif

  1. Dans l'Éditeur de découpage, si vous n'avez pas encore trouvé le champ non qualitatif dont vous souhaitez copier le découpage, cliquez sur l'onglet Champs et sélectionnez le champ.
  2. Choisissez Découpage>Copier le découpage ou faites un clic droit dans le volet Champs et choisissez Copier le découpage ou cliquez sur [image] dans la barre d'outils.
  3. Sélectionnez le champ auquel vous souhaitez appliquer le découpage.
  4. Choisissez Découpage>Coller un découpage ou faites un clic droit dans le volet Champs et choisissez Coller un découpage ou cliquez sur [image] dans la barre d'outils.

    L'Éditeur de découpage crée une copie du découpage, nommée suivant le champ d'origine.

Remarque :
  • Au lieu de coller un découpage dans un seul champ, vous pouvez l'appliquer simultanément à plusieurs champs en choisissant Coller le découpage sur les champs multiples au lieu de Coller un découpage. Au cas où une boîte de dialogue Sélectionner les champs à coller s'affiche, dans lequel vous pouvez choisir un groupe de champs. L'Éditeur de découpage applique une copie du découpage à chacun des champs que vous choisissez.
  • Si vous avez utilisé la fonction de découpages multiples de Decision Studio pour associer plusieurs découpage à un champ, notez que les options Copier le découpage et Coller un découpage s'appliquent aux découpages primaires [voir Définition d'un découpage primaire d'un champ non qualitatif] associés au champ.

Enregistrement d'un découpage non qualitatif

  1. Dans l'Éditeur de découpage, si vous n'avez pas encore trouvé le champ non qualitatif dont vous souhaitez enregistrer le découpage, cliquez sur l'onglet Champs et sélectionnez le champ.
  2. Choisissez Fichier>Enregistrer sous ou cliquez sur [image] dans la barre d'outils et choisissez un emplacement et un nom pour votre fichier de découpage.

Application d'un découpage non qualitatif enregistré à un nouveau champ

  1. Dans l'Éditeur de découpage, si vous n'avez pas encore le champ non qualitatif dont vous souhaitez enregistrer le découpage, cliquez sur l'onglet Champs et sélectionnez le champ.
  2. Choisissez Fichier>Ouvrir ou cliquez sur [image] dans la barre d'outils.

    Les fichiers de découpage ont l'extension .bng (ou.qsbng).

Enregistrement d'une hiérarchie de découpage par catégories

  1. Dans l'Éditeur de découpage, si vous n'avez pas encore trouvé le champ non qualitatif dont vous souhaitez enregistrer la hiérarchie de découpage, cliquez sur l'onglet Champs et sélectionnez le champ.
  2. Sélectionnez Fichier>Exporter[Hiérarchie qualitative]\ et sélectionnez un emplacement et un nom pour votre ficher de hiérarchie de découpage par catégories.

    Les fichiers de hiérarchie de découpage par catégories ont l'extension .hrc.

Application d'une hiérarchie de découpage par catégories enregistré à un nouveau champ

  1. Dans l'Éditeur de découpage, si vous n'avez pas encore le champ à découper avec le hiérarchie de découpage par catégories enregistré, cliquez sur l'onglet Champs et sélectionnez le champ.
  2. Choisissez Fichier>Importer une hiérarchie qualitative ou cliquez sur [image] dans la barre d'outils.
Remarque :
  • Lorsque vous appliquez une hiérarchie de découpage par catégories enregistré à un champ, elle écrase toute hiérarchie de découpage par catégories précédente (ou de découpages non qualitatifs) associée au champ.
  • si vous appliquez une hiérarchie de découpage par catégories enregistrée sans interprétation qualitative, Decision Studio applique automatiquement une interprétation qualitative au champ.


Optimisation du découpage d'un champ

Vous pouvez utiliser Éditeur de découpage pour obtenir une ébauche de découpage s'approchant le plus d'un découpage fin, en termes de prédiction d'un objectif donné. De cette façon, vous pouvez améliorer un scoring ou un arbre de décision tout en minimisant le risque de surdimensionner le modèle pour vos données.
  1. Assurez-vous que le champ dont vous voulez optimiser le découpage est interprété en tant que variable candidate [voir Interprétations des champs] (ou qu'il n'existe pas de variable candidate dans le focus).
  2. Assurez-vous que l'objectif de modélisation approprié est défini.
  3. Construisez un scoring . Ne fermez pas la fenêtre Scoring.

    En construisant un scoring, vous garantissez que les statistiques requises pour l'optimisation sont en place.

  4. Dans l'Éditeur de découpage, si vous n'avez pas déjà sous les yeux le champ dont vous désirez supprimer le découpage, cliquez sur l'onglet Champs et surlignez le champ.
  5. Choisissez Découpage>Optimiser ou cliquez sur [image] dans la barre d'outils.

    La boîte de dialogue Optimiser le découpage s'affiche :

  6. Choisissez le découpage source en spécifiant s'il faut ou non utiliser le découpage en cours ou bien un découpage par population égale ou par plage égale pour un nombre de modalités données.

    Le découpage source doit être beaucoup plus précis que le résultat désiré ; comme guide approximatif, choisissez environ dix fois le nombre de modalités que vous projetez d'obtenir à la fin.

  7. Cliquez sur Créer un découpage source.

    Le graphique dans l'Éditeur de découpage présente le découpage que vous avez choisi, avec le taux de correspondance objectif de chaque modalité codé par couleur.

  8. Choisissez le nombre de modalités internes et la taille minimale pour votre découpage cible.
  9. Cliquez sur Optimiser.

    Le graphique dans l'Éditeur de découpage présente maintenant le découpage cible généré à l'aide de ces paramètres, de nouveau codés par couleur pour le taux de correspondance objectif de chaque modalité.

  10. Cliquez sur Accepter si vous désirez découper le champ avec ce découpage. (Vous pouvez maintenant fermer la fenêtre Scoring).
Remarque :
  • L'optimisation de découpage ne marche que pour des modalités internes.Les modalités de fin ne sont pas affectées.
  • Par défaut, Éditeur de découpage utilise le gain d'information comme critère de qualité pour l'approximation de découpage du découpage initial. Avec le menu déroulant du volet Optimisation, vous pouvez choisir à la place d'utiliser le critère de mesure de Gini.
  • L'optimisation de découpage est un processus itératif : Si vous n'êtes pas satisfait du découpage source, vous pouvez modifier les paramètres dans le volet Découpage source à tout moment en cliquant de nouveau sur Créer un découpage source ; si vous n'êtes pas satisfait du découpage cible, vous pouvez modifier les paramètres dans les volets Découpage cible et Optimisation et cliquer de nouveau sur Optimiser.
  • Pour un champ non qualitatif, lorsque vous cliquez sur Accepter, le nouveau découpage devient le découpage primaire [voir Définition d'un découpage primaire d'un champ non qualitatif] du champ. Si vous n'avez pas coché Faire une sauvegarde du découpage en cours avant d'accepter le découpage, cela écrase le découpage primaire existant.
Sujet parent : Groupement d'enregistrements client par découpage d'un champ de focus


Calcul des nouveaux champs d'un focus

  • Calcul d'un champ avec l'Aperçu du tableau
  • Calcul d'un champ depuis un modèle ou un tableau croisé Decision Studio
  • Champs associés aux modèles d'arbre de décision, de scoring et de classification et aux tableaux croisés résumés
  • Calcul d'un champ à partir d'une segmentation graphique
  • Calcul de champs dans un focus avec Portrait Miner


Calcul d'un champ avec l'Aperçu du tableau

  1. Choisissez Calculer>Nouveau ou cliquez sur [image] dans la barre d'outils.

    L'Aperçu du tableau crée initialement une colonne Aperçu vide à droite du tableau.

  2. Dans la zone de texte nouvellement surlignée à gauche du signe « = », saisissez un nom pour le nouveau champ.

    Choisissez un nom de champ descriptif, mais pas trop long. Le nom du champ doit commencer par une lettre et ne doit contenir que des lettres, chiffres et des caractères de soulignement. Il ne doit pas entrer en conflit avec le nom d'un autre champ du focus.

  3. Dans la zone de texte à droite du signe « = », saisissez une expression FDL ou une liste d'expressions [voir Expressions], afin de définir le champ en termes de champs existants.
  4. Choisissez Calculer>Calculs, cliquez sur [image] dans la barre d'outils ou appuyez simplement sur Entrée.

    L'Aperçu du tableau calcule le nouveau champ, qui apparaît à la place de la colonne Aperçu.

Remarque :
  • Si l'expression ou la liste d'expressions est trop longue pour tenir aisément sur une seule ligne, vous pouvez utiliser l'Éditeur de variables : choisissez Calculer>Modifier ou cliquez sur [image] dans la barre d'outils.
  • Pour modifier le type de données par défaut [voir Types de données] pour un champ, ouvrez l'Éditeur de variables pour faire apparaître les options de calcul supplémentaires.

    Vous avez également la possibilité ici de définir une seed [voir À propos des fonctions FDL à nombre aléatoire] pour des calculs de nombre aléatoire. Si vous n'indiquez pas de seed, le système en sélectionne une pour vous (basée sur l'horloge système), et la séquence des résultats sera différente en fonction du moment.

  • Si vous appuyez sur la touche Tab (??plusieurs fois) en saisissant une expression de calcul, l'Aperçu du tableau passe en revue toutes les saisies semi-automatiques possibles pour le mot en cours, en considérant les noms des fonctions FDL et des champs dans le focus. Les saisies semi-automatiques des noms de fonctions FDL comprennent les parenthèses et les virgules requises, le cas échéant, pour indiquer le nombre d'arguments requis. Si vous n'avez pas saisi juste une partie d'un mot, l'Aperçu du tableau considère tous les noms des fonctions et de champs comme des saisies semi-automatiques possibles.
  • Vous pouvez également inclure tout nom de champ du focus dans une expression de calcul en le choisissant dans une liste : choisissez Calculer >Explorer les champs.
  • Si vous n'êtes pas sûr de la syntaxe exacte d'une fonction FDL, ou tout simplement pour éviter d'effectuer une saisie, choisissez Calculer >Aide contextuelle sur la fonction pour l'entrée de la fonction assistée [voir Saisie de fonction assistée dans l'Aperçu du tableau].
  • Pour calculer un champ basé sur des valeurs dans une autre table, utilisez la fonction FDL dblookup.
  • Decision Studio génère des valeurs pour tous les enregistrements, qu'une sélection soit appliquée ou non.

Voir également

Calcul de champs dans un focus avec Portrait Miner
Sujet parent : Calcul des nouveaux champs d'un focus

Saisie de fonction assistée dans l'Aperçu du tableau

Lorsque vous choisissez Calculer>Aide contextuelle sur la fonction ou que vous cliquez sur [image] en cours de saisie d'une expression de calcul dans l'Aperçu du tableau, la boîte de dialogue Fonctions de calcul s'affiche. Si vous surlignez une classe de fonctions (ou Toutes) dans le volet Famille de fonction, une liste des fonctions FDL dans cette classe (ou toutes les fonctions FDL disponibles) apparaît dans le volet Fonctions.

Lorsque vous surlignez une fonction dans le volet Fonctions, une brève description de la fonction apparaît. (Pour les fonctions qui ne sont pas intégrées dans FDL, cliquez sur Détails pour voir une description plus complète.)

Vous pouvez saisir les arguments requis pour la fonction dans le volet Paramètres.

Sous le volet Paramètres, vous pouvez voir l'expression FDL en cours correspondant à votre choix de fonction et de paramètres. Lorsque vous cliquez sur OK, l'Aperçu du tableau colle cette expression dans votre expression de calcul sous le curseur.

Remarque :
  • Lorsque vous utilisez la boîte de dialogue Fonctions de calcul pour saisir une fonction dans la famille de fonctions Agrégation du champ, il existe deux paramètres spéciaux (« where » et « by »), qui ne correspondent pas aux arguments de la fonction en cours. Au lieu de cela, ils produisent une syntaxe FDL spéciale pour les fonctions d'agrégation.

    Le paramètre « where » est une expression FDL de valeur booléenne [voir Données booléennes] utilisée pour sélectionner les enregistrements à agréger. Si vous omettez ce paramètre, Decision Studio agrège tous les enregistrements sélectionnés dans le focus.

    Le paramètre « by » est un champ de ventilation ou une liste de champs de ventilation séparés par des virgules. Pour calculer la valeur de la fonction d'agrégation pour un enregistrement, Decision Studio réalise une agrégation sur les enregistrements qui partagent la modalité d'enregistrement pour chaque champ de ventilation.

  • Lorsque vous utilisez la boîte de dialogue Fonctions de calcul pour saisir dans la fonction FDL isselected, il existe un paramètre spécial (« expand »), qui ne correspond pas à un argument de fonction réel. Lorsque vous cochez la case de ce paramètre, au lieu de générer l'expression isselected(), l'Aperçu du tableau insère une expression qui renvoie true seulement pour les enregistrements qui sont sélectionnés à ce stade.

    Les deux expressions produisent le même résultat, jusqu'à ce que vous sélectionniez des enregistrements différents dans le focus. Ensuite le résultat de l'expression isselected() change, mais le résultat de l'expression étendue reste le même.

Modification d'une expression de calcul avec l'Aperçu du tableau

  1. Cliquez sur le champ dont vous souhaitez modifier l'expression de calcul.
  2. Si nécessaire, modifiez l'expression de calcul avec l'Éditeur de variables.
  3. Choisissez Calculer>Calculs, cliquez sur [image] dans la barre d'outils ou appuyez simplement sur Entrée.


Calcul d'un champ depuis un modèle ou un tableau croisé Decision Studio

  1. Si vous souhaitez qu'un champ reflète les segments sélectionnés d'un arbre de décision, sélectionnez les segments importants [voir Sélection des segments dans une vue graphique] dans l'Arbre de décision.
  2. Vous avez le choix entre les méthodes suivantes :
    • Dans l'Arbre de décision, sélectionnez Arbre>Création de champs.
    • Dans le Scoring, sélectionnez Scoring>Création de champs.
    • Dans la Classification, sélectionnez Classification>Création de champs.
    • Dans un Aperçu du Tableau Croisé, Aperçu du Profil, Aperçu de la distribution croisée ou Aperçu de la carte, sélectionnez Segments>Création de champs.
    • Dans tout outil de modélisation ou tout aperçu graphique, cliquez sur [image] dans la barre d'outils.
    A La boîte de dialogue Création de champs de résultats s'affiche.
  3. Vérifier les champs de résultats [voir Champs associés aux modèles d'arbre de décision, de scoring et de classification et aux tableaux croisés résumés] que vous souhaitez générer, en changeant les noms de champs si nécessaire.
  4. Cliquez sur OK.

    Decision Studio génère les champs de résultats dans le fichier focus.

Remarque :
  • Chaque champ de résultats est repéré comme un champ calculé et dispose d'une définition FDL associée que vous pouvez afficher ou modifier [voir Calcul d'un champ avec l'Aperçu du tableau] grâce à l'Aperçu du tableau. Le texte de calcul contient des commentaires d'instructions pour vous aider à procéder à des analyses simples de type « que faire si ? ».
  • Decision Studio génère des valeurs pour tous les enregistrements, qu'une sélection soit appliquée ou non.

Voir également

Création d'un modèle de classification

Construction d'un arbre de décision

Création d'un tableau croisé textuel

Calcul d'un champ à partir d'une segmentation graphique

Enregistrement d'un modèle ou d'une segmentation Decision Studio au format QMML (XML)

Sujet parent : Calcul des nouveaux champs d'un focus


Champs associés aux modèles d'arbre de décision, de scoring et de classification et aux tableaux croisés résumés

Les champs de résultats suivants saisissent les différents aspects des arbres de décision, des tableaux croisé abstraits, des modèles de classification :
Champ | Applicable à | Description
Index de segment | Tout arbre de décision ou tableau croisé abstrait | Le numéro identifiant du segment dans lequel un enregistrement se trouve, prenant en compte uniquement les segments « feuille » (niveau le plus bas, sans parent) dans un arbre de décision
Segments sélectionnés | Tout arbre de décision ou aperçu graphique | 1 pour les enregistrements dans les segments sélectionnés ; 0 pour les autres enregistrements
Taux de correspondance | Arbre binaire | Le taux de correspondance original du segment « feuille » dans lequel l'enregistrement se trouve, c'est à dire, la proportion (entre 0 et 1) des enregistrements du segment qui correspondent à l'objectif (ignorer les enregistrements avec null [voir La valeur null] dans le champ objectif)
Résultat prévu | Arbre binaire ou scoring continu | Pour un arbre de décision : l'indice de modalité de la valeur originale la plus commune de l'objectif pour un segment « feuille » dans lequel l'enregistrement se trouve : normalement 1 pour la valeur 0, 2 pour la valeur 1 et 3 pour null [voir La valeur null] Pour un scoring : le score calculé en appliquant le scoring , équivalent à la valeur prévue de l'objectif
Décision | Arbre binaire ou scoring binaire | Pour un arbre de décision : 1 si le taux de correspondance du segment dans lequel se trouve l'enregistrement est au-dessus de la valeur seuil [voir Définition du seuil de décision d’un arbre de décision] pour l'arbre ; autre que 0 Pour un scoring : 1 pour les enregistrements avec des scores au-dessus du score de seuil [voir Définition du seuil de score d’un scoring] pour le scoring ; 0 pour les autres enregistrements
Catégorie la plus populaire | Arbre qualitatif | L'indice de classification de la catégorie originale la plus commune de l'objectif pour un segment dans lequel un enregistrement se trouve
Moyenne d'objectif | Arbre continu | La valeur moyenne initiale de l'objectif du segment « feuille » dans lequel se trouve une valeur moyenne
Uplift comme différence | Uplift binaire + arbre | L’uplift d'origine, c’est à dire, le taux de correspondance original de la population traitée moins celui de la population témoin, pour le segment dans lequel un enregistrement se trouve
Uplift comme quotient | Uplift binaire x arbre | Ratio uplift original, c’est à dire, le taux de correspondance original de la population traitée divisé par celui de la population témoin, pour le segment dans lequel se trouve un enregistrement. (Si le taux de correspondance de la population témoin est égal à zéro, un très grand nombre positif est attribué à l’enregistrement.)
Uplift de moyenne | Arbre uplift continu | L’uplift original, c'est-à-dire la valeur originale de l'objectif de la population traitée moins celle de la population témoin, pour le segment dans lequel un enregistrement de trouve
Score | Scoring binaire | Le score calculé en appliquant le scoring
Risques | Scoring binaire | Les probabilités d'obtenir une valeur par défaut, de réponse, de défection ou de satisfaction/d'insatisfaction fournies par [image] , où s est le score et a et b sont respectivement le seuil de probabilités et le facteur de doublement [voir Définition du lien score/probabilités pour un scoring]
Probabilité | Scoring binaire | La probabilité d’utilisation par défaut, de réponse, d’attrition ou d'être satisfait ou insatisfait, selon
Index de classe | Modèle de classification | Le numéro d’identification du groupe [voir Création d'un modèle de classification]dans lequel se trouve un enregistrement (ou la valeur null [voir La valeur null] pour un enregistrement du groupe null [voir La valeur null dans la classification]) (Un découpage par catégories s’applique et la valeur -1 est classée dans une catégorie nommée « Valeurs aberrantes ».)
Distance entre les groupes | Modèle de classification | La distance normalisée [voir Mesure de la taille et de la séparation des groupes] entre un enregistrement et le centre du groupe dans lequel il se trouve
Séparation de groupe | Modèle de classification | La mesure de séparation pour un enregistrement, donnée par [image] , où [image] est la distance au centre de la classe la plus près et [image] est la distance au centre de la classe la deuxième plus près
Remarque :
  • Le mot « original » dans le tableau ci-dessus indique que, pour les arbres de décision, les valeurs de certains champs sont générées à partir de la population sur laquelle l'arbre de décision a été construit, plutôt que la population à laquelle il s’applique ensuite.
  • Le champ indice-segment du tableau croisé abstrait prend en compte tous les champs de ventilation du tableau croisé, y compris ceux que l’aperçu indique dans la barre [image] (Informations seulement).
  • Le champ segments-sélectionnés des tableaux croisés abstrait est uniquement disponible lors de l'enregistrement d'un modèle pour le déploiement dans les aperçus graphiques.

Voir également

Calcul d'un champ depuis un modèle ou un tableau croisé Decision Studio

Enregistrement d'un modèle ou d'une segmentation Decision Studio au format QMML (XML)

Sujet parent : Calcul des nouveaux champs d'un focus

Définition du seuil de décision d’un arbre de décision

Dans l'Arbre de décision, modifiez le seuil de décision du taux de correspondance, le taux d’acceptation ou le taux de rejet dans le volet qui se trouve sous la barre d'outils :

Les valeurs légitimes pour ces trois paramètres sont celles qui apparaissent dans l’aperçu des gains [voir Options d'affichage d'un arbre de décision] de l'arbre de décision.

Lorsque vous saisissez une valeur pour le seuil de décision ou le taux de rejet, la valeur réelle (affichée dans la zone non modifiable à droite) est la valeur légitime la plus proche au-dessus de la valeur que vous saisissez. Pour le taux d’acceptation, la valeur réelle est la valeur légitime la plus proche sous la valeur que vous saisissez. l'Arbre de décision ajuste les autres valeurs en conséquence.

Définition du seuil de score d’un scoring

Dans le Scoring, modifiez le seuil de score, le taux d’acceptation (taux cible) ou le mauvais taux (taux de réussite), dans le volet au-dessous de la barre d'outils.

Le Scoring ajuste les autres valeurs en conséquence.

Remarque :
  • Vous ne pouvez pas définir un seuil de score pour un scoring construit à l’aide d’un objectif continu : dans un modèle de valeur, vous ne saisissez pas de décision oui/non.
  • Le réglage par défaut est déterminé par les préférences du Scoring le taux seuil, le mauvais taux et le taux d’acceptation.

Définition du lien score/probabilités pour un scoring

  1. Dans le Scoring, choisissez Format>scoring.
  2. Dans la fenêtre Echelle de la boîte de dialogue Formulaire de scoring, modifiez le seuil de probabilités et le facteur de doublement, si besoin :
    • Le point de probabilités égales correspond au score correspondant à une probabilité de 1.
    • Lorsque vous ajoutez le facteur de doublement à un score, les probabilités correspondantes doublent (pour une réponse ou un modèle d’attrition). Pour un modèle de risque, les probabilités sont divisées par deux.
  3. Cliquez sur OK.
Remarque :
  • Ces options ne sont pas disponibles lorsque vous utilisez un objectif continu car il n'y a aucune notion de probabilités associée à des scoring continus.
  • Lorsque vous changez le seuil de probabilité égale ou le facteur de doublement, la nouvelle valeur ne s'applique pas tant que vous n’avez pas créé le scoring suivant.


Calcul d'un champ à partir d'une segmentation graphique

Vous pouvez calculer un champ 0/1 à partir d'une segmentation graphique pour indiquer une inclusion ou une exclusion à partir de segments sélectionnés.
  1. Dans l'Aperçu du profil, l'Aperçu de la distribution croisée, l'Aperçu de la carte, ou l'Arbre de décision, sélectionnez les éléments qui vous intéressent [voir Sélection des segments dans une vue graphique].
  2. Choisissez Segments>Indicateur sélectionné ou cliquez sur [image] dans la barre d'outils.

    Une nouvelle boîte de dialogue Nouveau nom du champ s'affiche.

  3. Saisissez un nom pour le champ calculé et cliquez sur OK.

    Decision Studio crée un nouveau champ, avec 1 pour les enregistrements qui tombent sur les segments sélectionnés et 0 pour les autres enregistrements.

Remarque :
  • Le nouveau champ est marqué comme champ calculé et a une définition FDL associée, que vous pouvez afficher ou modifier [voir Calcul d'un champ avec l'Aperçu du tableau] à l'aide de Aperçu du tableau.
  • Le nouveau champ est interprété comme étant qualitatif [voir Interprétations des champs], avec les noms de catégories « Not Selected » et « Selected » pour les valeurs 0 et 1, respectivement.

Voir également

Création d'un graphique sur une carte

Création d'un graphique de distribution croisée multi-variable

Création d'un ensemble de graphiques de profil à variable unique

Calcul d'un champ depuis un modèle ou un tableau croisé Decision Studio

Enregistrement d'un modèle ou d'une segmentation Decision Studio au format QMML (XML)

Sujet parent : Calcul des nouveaux champs d'un focus


Calcul de champs dans un focus avec Portrait Miner

Vous pouvez calculer des champs à l'aide d'un ensemble de définitions des champs dans un fichier de calculs.
Pour calculer des champs dans un focus, utilisez l'une des options suivantes :
  • Dans Portrait Miner, cliquez avec le bouton droit sur le focus dans lequel vous souhaitez calculer des champs et choisissez Transformer>Calculer des champs.
  • Dans Portrait Miner, cliquez avec le bouton droit sur un fichier de calculs et choisissez Calculer des champs.

Dans la boîte de dialogue Calculer des champs, choisissez un fichier de calculs comprenant les définitions de champ. Sinon, si vous sélectionnez un fichier de calculs, choisissez un focus. Vous pouvez aussi modifier l'emplacement du nouveau focus ou choisir de remplacer un focus de sortie créé précédemment.

Remarque : Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsderive de Portrait Miner.

Voir également

À propos des assistants Portrait Miner

Calcul d'un champ avec l'Aperçu du tableau

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Affichage et modification de fichiers texte dans Portrait Miner

Sujet parent : Calcul des nouveaux champs d'un focus


Renommage et suppression des champs d'un focus

  • Renommage d'un champ avec l'Aperçu du tableau
  • Renommage de champs par l'ajout d'un préfixe ou d'un suffixe
  • Suppression d'un champ


Renommage d'un champ avec l'Aperçu du tableau

  1. Cliquez sur le champ dont vous désirez modifier le nom.
  2. Dans la zone de texte à gauche du signe « = », saisissez un nouveau nom de champ et appuyez sur Entrée.

    Le nom du champ doit commencer par une lettre et ne doit contenir que des lettres, chiffres et des caractères de soulignement. Il ne doit pas entrer en conflit avec le nom d'un autre champ du focus.

Lorsque vous renommez un champ, vous invalidez tous les champs calculés (y compris les champs générés par un modèle) dont les expressions de calcul impliquent le nom d'origine.
Remarque :
  • Vous ne pouvez pas renommer un champ lorsqu'il est en cours d'utilisation par un outil Decision Studio.

Voir également

Renommage de champs par l'ajout d'un préfixe ou d'un suffixe

Sujet parent : Renommage et suppression des champs d'un focus


Renommage de champs par l'ajout d'un préfixe ou d'un suffixe

Vous pouvez renommer un ou plusieurs champs dans un focus en ajoutant un préfixe ou un suffixe commun aux noms de champs.
  1. Dans Portrait Miner, faites un clic droit sur le focus dont vous désirez renommer les champs et choisissez Transformer>Renommer les champs. La boîte de dialogue Renommer des champ s'affiche.
  2. Éventuellement, modifiez l'emplacement du focus de sortie.
  3. Effectuez l'une des actions suivantes ou les deux :
    • Choisissez la chaîne à ajouter comme préfixe.
    • Choisissez la chaîne à ajouter comme suffixe.
  4. Choisissez un ou plusieurs champs à renommer.
  5. Cliquez sur OK.
Remarque :
  • Chaque nom de champ résultant ne doit pas entrer en conflit avec le nom d'un autre champ du focus.
  • La boîte de dialogue Renommer des champs est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsrenamefields de Portrait Miner.

Voir également

À propos des assistants Portrait Miner

Renommage d'un champ avec l'Aperçu du tableau

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Sujet parent : Renommage et suppression des champs d'un focus


Suppression d'un champ

  1. Cliquez sur le champ que vous désirez supprimer.
  2. Dans la fenêtre Decision Studio, choisissez Champ>Supprimer, ou cliquez sur le champ et choisissez Supprimer.
  3. Dans l'Aperçu du tableau, choisissez Champ>Supprimer ou cliquez sur [image] dans la barre d'outils. Vous pouvez également supprimer un champ en cliquant droit sur l'en-tête de champ et en choisissant Supprimer.
Remarque :
  • Vous ne pouvez pas supprimer un champ lorsqu'il est en cours d'utilisation par un outil Decision Studio.
  • Vous pouvez aussi supprimer un champ dans la fenêtre Decision Studio en cliquant sur Champ>Supprimer ou en choisissant Supprimer en faisant un clic droit sur un champ.

Voir également

Choix des champs à visualiser

Renommage d'un champ avec l'Aperçu du tableau

Sujet parent : Renommage et suppression des champs d'un focus


Utilisation des métadonnées d'un focus

  • Métadonnées des fichier focus
  • Libellés d'affichage d'un champ
  • Interprétations des champs
  • Ajout d'un commentaire à un focus ou à un champ à l'aide de Decision Studio
  • Visualisation des métadonnées de focus et de champ
  • Copie de métadonnées de focus d'un focus à l'autre
  • Édition des métadonnées d'un focus dans Excel


Métadonnées des fichier focus

Les métadonnées sont des « données sur les données ». Outre les données client brutes que vous importez depuis une base de données ou créez en prenant des mesures de transaction, un focus contient des métadonnées. Certaines de ces métadonnées s'appliquent à l'ensemble du focus, alors que d'autres métadonnées s'appliquent individuellement à des champs du focus.

Métadonnées associées à l'ensemble du focus

  • Les numéros d'enregistrements et de champs dans le focus
  • Les commandes data build utilisées pour créer le focus (s'il a été créé à l'aide de commandes data build)
  • Un commentaire facultatif

Métadonnées associées à un champ dans le focus

  • Le nom du champ et le type de données [voir Types de données]
  • Tout libellé d'affichage [voir Libellés d'affichage d'un champ] associé au champ
  • Toute balise utilisateur [voir Balises utilisateur] associée au champ
  • Toutes les interprétations [voir Interprétations des champs] associées au champ
  • Tout découpage associé au champ
  • Toute sélection d'enregistrement [voir Sélection d'enregistrements client] basée sur des valeurs du champ
  • L'expression FDL [voir À propos du langage FDL] utilisée pour définir le champ (si le champ a été calculé)
  • Tout commentaire associé au champ
  • Un enregistrement indiquant si le champ a été importé dans le focus ou joint à celui-ci depuis une autre source de données
  • Les valeurs minimale et maximale du champ
  • Le nombre d'occurrences de la valeur null [voir La valeur null] dans le champ
Remarque : Les relations entre outils dans une session Decision Studio ne sont pas stockées dans un fichier focus.

Voir également

Ajout d'un commentaire à un focus ou à un champ à l'aide de Decision Studio

Copie de métadonnées de focus d'un focus à l'autre

Création d'un profil et d'un audit de focus

Visualisation des métadonnées de focus et de champ

Sujet parent : Utilisation des métadonnées d'un focus


Libellés d'affichage d'un champ

Il est souvent déconseillé ou impossible de modifier le nom d'un champ. Cependant, certains affichages dans Decision Studio peuvent indiquer un libellé d'affichage à la place du nom de champ. Les outils prenant en charge les libellés d'affichage sont l'Aperçu de la distribution croisée, l'Aperçu du tableau croisé, l'Aperçu du profil, l'Aperçu de la carte et l'Arbre de décision.

La fenêtre Decision Studio comporte une colonne Libellé d'affichage qui indique le libellé d'affichage qui sera utilisé pour chaque champ. Remarque : La colonne Libellé d'affichage est facultative et s'affiche en cliquant sur Modifier>Disposition des colonnes.

Sujet parent : Utilisation des métadonnées d'un focus

Édition du libellé d'affichage d'un champ

  1. Surlignez le champ dans la fenêtre Decision Studio.
  2. Cliquez une seconde fois sur le champ Libellé d'affichage pour modifier le nom directement. Sinon, une fois l'entrée du libellé d'affichage mise en surbrillance, vous pouvez :
    • choisir Propriétés>du champ, ou
    • faire un clic droit et choisir Propriétés, ou encore
    • cliquer sur [image] dans la barre d'outils.

Voir également

Fonctions d'agrégation pour les tableaux croisés
Remarque :
  • Contrairement aux noms de champ, il n'existe pas de restrictions sur les caractères utilisés dans les libellés d'affichage.
  • Les libellés d'affichage de champ sont sauvegardés avec le focus et peuvent être exportés et importés en même temps que les autres éléments de métadonnées.
  • Les libellés d'affichage ne peuvent pas être utilisés dans les expressions FDL.


Interprétations des champs

Dans Decision Studio, vous pouvez associer une ou plusieurs des interprétations suivantes à un champ :

Interprétation de champ | Signification
Objectif | Le champ est l'objectif de modélisation/visualisation dans le focus.
Partition | Le champ est le champ de partition d'analyse Uplift du champ traité/contrôlé. La première modalité ou catégorie (généralement la valeur 0) indique le segment témoin et la seconde modalité ou catégorie (généralement la valeur 1) indique le segment traité.
Variable candidate | Le champ est un candidat à utiliser dans des modèles d'Arbre de décision, de Scoring et de Classification.
Qualitatif | Les valeurs du champ forment un ensemble distinct, inorganisé. Les champs qualitatifs sont traités différemment des autres champs dans l'Éditeur de découpage, l'Arbre de décision, la Classification et la boîte de dialogue Sélectionner des valeurs.
Géographique | Le champ est associé à une carte, de manière à pouvoir être utilisé dans l'Aperçu de la carte.
Exporter | Le champ doit être inclus par défaut lorsque vous exportez des segments vers un fichier ou une table de base de données. (Normalement, c'est l'identifiant unique, par exemple, un numéro de client).
Clé | Le champ est associé à Portrait Explorer et sert à identifier le champ clé. Vous ne pouvez avoir qu'un seul champ clé.
Remarque :
  • Un focus contient au plus un champ avec une interprétation d'objectif et au plus un champ avec une interprétation de partition.
  • En l'absence de variable candidate dans un focus, l'Arbre de décision, le Scoring et la Classification traitent tous les champs appropriés comme des variables candidates.
  • De même, s'il n'existe aucun champ ayant une interprétation d'exportation dans un focus, Decision Studio traite tous les champs comme étant des champs d'exportation.
  • Dans le Scoring, vous pouvez interpréter un champ comme étant un « poids ». Ce type d'interprétation est local au Scoring et ne fait pas partie des métadonnées du focus.
Sujet parent : Utilisation des métadonnées d'un focus

Définition ou effacement d'une variable candidate, une interprétation clé, qualitative, géographique ou d'exportation

  1. Dans la fenêtre Decision Studio, surlignez les champs dont vous désirez modifier l'interprétation.
  2. Sélectionnez Balise>Interprétations dans le menu, puis sélectionnez variable candidate [image], qualitative [image], géographique [image], d'exportation [image] ou clé [image]). Vous pouvez également faire un clic droit sur le champ et sélectionner l'interprétation ( [image], [image], [image], [image] ou [image]). L'icône approprié apparaît dans la colonne Interprétations du champ.
Remarque :
  • Vous pouvez définir les interprétations de champ dans l'Aperçu du tableau, depuis le menu Balise>Interprétations, ou en faisant un clic droit sur le nom d'un champ (en-tête de colonne).
  • Pour supprimer une interprétation, sélectionnez-la une seconde fois en suivant les étapes décrites précédemment.

Définition ou effacement du champ d'objectif ou de partition d'un focus

  1. Dans la fenêtre Decision Studio, surlignez le champ que vous désirez définir comme champ d'objectif ou de partition.
  2. Sélectionnez Balise>Interprétations dans le menu principal, puis sélectionnez Objectif ( [image]) ou Partition ( [image] ). Vous pouvez également faire un clic droit sur le champ et sélectionner l'interprétation ( [image] ou [image]). L'icône approprié apparaît dans la colonne Interprétations du champ.
Remarque :
  • Si vous avez déjà défini un champ d'objectif ou de partition, et ensuite choisi d'interpréter un champ différent de la même façon, Decision Studio efface pour vous l'interprétation d'origine.
  • Pour supprimer l'interprétation d'objectif ou de partition d'un champ sans assigner l'interprétation à un autre champ, surlignez le champ, et choisissez de nouveau l'option appropriée dans le menu Balise>Interprétations.


Ajout d'un commentaire à un focus ou à un champ à l'aide de Decision Studio

Vous pouvez ajouter individuellement des descriptions et d'autres commentaires à des champs dans un focus. Ces informations peuvent être utiles lorsque vous partagez des jeux de données avec d'autres personnes, ou même lorsque vous revenez sur l'analyse d'un jeu de données avec lequel vous n'avez pas travaillé depuis un certain temps.
Dans la fenêtre Decision Studio :
  • Pour ajouter un commentaire de focus, choisissez Focus>Modifier les commentaires du Focus.
  • Pour ajouter un commentaire de champ, cliquez sur le champ Commentaire et ajoutez votre commentaire. Vous pouvez également :
    • surligner le champ requis et choisir Champ>Propriétés
    • faire un clic droit et choisir Propriétés, ou encore cliquer sur [image] dans la barre d'outils.

Les commentaires du champ s'affichent dans la colonne Commentaires de la fenêtre Decision Studio. Les commentaires de champ et de focus apparaissent également à d'autres endroits [voir Visualisation des métadonnées de focus et de champ].

Remarque :
  • Si vous cochez la case HTML, Decision Studio traite les paires de balises équilibrées, par exemple <b>...</b>, comme balisage HTML, et affiche le commentaire en conséquence.

Voir également

Métadonnées des fichier focus
Sujet parent : Utilisation des métadonnées d'un focus


Visualisation des métadonnées de focus et de champ

La fenêtre Decision Studio affiche les métadonnées de focus [voir Métadonnées des fichier focus], y compris les statistiques du champ principal. Vous pouvez choisir d'afficher différentes informations en cliquant sur le menu Éditer>Disposition des colonnes ; votre choix s'applique à la session en cours et aux futures sessions dans Decision Studio.

La colonne des Interprétations indique les lettres correspondant aux interprétations de champ [voir Interprétations des champs] qui ont été appliquées au champ. Les lettres suivantes peuvent également apparaître dans la colonne Interprétations :

Lettre | Signification
B | Le champ comporte un découpage associé.
D | Le champ est un champ calculé
J | Le champ a été importé dans le focus ou joint à celui-ci depuis une autre source de données.

La colonne Commentaires indique tout type de commentaire [voir Ajout d'un commentaire à un focus ou à un champ à l'aide de Decision Studio] associé à des champs.

Remarque : Pour des raisons d'efficacité, la fenêtre Decision Studio ne met pas les statistiques à jour à chaque fois. Lorsque les statistiques de champ ne sont pas à jour, elles sont grisées dans la fenêtre Decision Studio.
  • Pour mettre à jour les statistiques d'un champ, surlignez le champ et choisissez Champ>Mettre à jour les statistiques, ou faites un clic droit sur un champ et choisissez Mettre à jour les statistiques.
  • Pour mettre à jour les statistiques de chaque champ du focus, choisissez Focus>Mettre à jour toutes les statistiques.
Sujet parent : Utilisation des métadonnées d'un focus

Affichage des informations de focus dans Decision Studio

Dans la fenêtre Decision Studio, choisissez Focus>Informations du focus.

Une fenêtre s'affiche, indiquant les informations de base sur le focus et l'historique du focus. Tout commentaire [voir Ajout d'un commentaire à un focus ou à un champ à l'aide de Decision Studio] associé au focus s'affiche également.

Affichage des informations de champ dans Decision Studio

Dans la fenêtre Decision Studio, surlignez un champ et choisissez Champ>Propriétés, ou faites un clic droit et choisissez Propriétés ou cliquez sur [image] dans la barre d'outils.

Affichage des informations de focus et de champ dans Portrait Miner

Dans Portrait Miner, faites un clic droit sur un focus, et choisissez Métadonnées>Afficher.

Dans la boîte de dialogue Afficher les informations du focus, vous pouvez choisir la quantité d'informations de champ à inclure.

Une fenêtre s'affiche, indiquant les informations de base sur le focus et l'historique du focus. Tout commentaire [voir Ajout d'un commentaire à un focus ou à un champ à l'aide de Decision Studio] associé au focus s'affiche également.

Les informations des champs (si demandées) apparaissent en dessous des informations de focus. Si vous choisissez d'afficher des informations de champ détaillées, celles-ci incluent les statistiques de champ ainsi que tout commentaire associé aux champs.

Remarque : La boîte de dialogue Afficher les informations du focus est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsdescribe de Portrait Miner.

Voir également

À propos des assistants Portrait Miner

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Affichage des interdépendances et les tailles de fichier d'un focus

Un focus est stocké sur le disque en tant que fichier .ftr (le « fichier focus ») associé à un ensemble de fichiers de données et d'autres fichiers dans deux dossiers, et portent les extensions .rdx (« Données brutes eXtract ») et .xtr (« eXTRa »). Les dossiers sont normalement masqués dans Portrait Miner et dans l'onglet « Quadstone » d'un explorateur de fichiers Portrait Miner [voir Ouverture ou enregistrement d'un fichier, d'une session ou d'une table de base de données].

Un focus créé par copie d'un focus existant ou par importation de données depuis un autre type de base de données (ou à la suite de l'exécution d'un script TML) est indépendant des autres focus. En revanche, un focus qui est enregistré depuis Decision Studio avec un nouveau nom, ou un autre qui est créé en faisant une copie liée est dépendant des dossiers de données appartenant à d'autres focus.

Pour un focus donné, vous pouvez découvrir les autres focus dont il dépend et ceux qui dépendent de lui, ainsi que la quantité d'espace disque utilisée pour le stockage des données et des métadonnées : dans Portrait Miner, faites un clic droit sur le focus et choisissez Propriétés.

Dans la boîte de dialogue Afficher les propriétés du focus, vous pouvez choisir d'enregistrer le rapport sur les propriétés du focus en tant que fichier XML ou HTML. Les propriétés du focus sont aussi affichées sous l'onglet Sortie, au format sélectionné pour le fichier de sortie.

Remarque : Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsinfo de Portrait Miner.

Voir également

À propos des assistants Portrait Miner

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données


Copie de métadonnées de focus d'un focus à l'autre

Vous pouvez copier des métadonnées de focus [voir Métadonnées des fichier focus] d'un focus à l'autre, incluant les définitions de champs calculés, d'interprétations de champs, de découpages, de sélections d'enregistrements, de commentaires de champ et de focus, et l'historique du focus.

Une des méthodes consiste à enregistrer les métadonnées de focus dans un fichier, puis à appliquer les métadonnées à un autre focus. Une autre façon est d'utiliser un focus directement en tant que « modèle » de métadonnées pour un autre focus.

Remarque : Lorsque vous appliquez un modèle de métadonnées à un focus, les commentaires de champ et de focus ne sont pas inclus. De même, vous ne pouvez pas appliquer un modèle de métadonnées à un focus cible si le focus cible possède déjà des interprétations de champ, des sélections ou des découpages.

Voir également

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données
Sujet parent : Utilisation des métadonnées d'un focus

Enregistrement des métadonnées d'un focus

Dans la fenêtre Decision Studio, choisissez Focus>Exporter les métadonnées et ouvrez [voir Ouverture ou enregistrement d'un fichier, d'une session ou d'une table de base de données] l'emplacement dans lequel vous souhaitez enregistrer le fichier de métadonnées de focus.

Exportation de métadonnées depuis un focus à l'aide de Portrait Miner

Dans Portrait Miner, faites un clic droit sur le focus et choisissez Métadonnées>Exportation.

La boîte de dialogue Exporter les métadonnées s'affiche. Vous pouvez choisir un emplacement pour le fichier de métadonnées sauvegardées (ou simplement accepter l'emplacement par défaut).

Remarque : L'interface utilisateur est une façon d'accéder aux fonctionnalités apportées par la commande data build qsexportmetadata de Portrait Miner (et a exactement le même résultat qu'une sauvegarde de métadonnées dans Decision Studio).

Application de métadonnées sauvegardées à un nouveau focus

Dans Portrait Miner, effectuez l'une des opérations suivantes :
  • Faites un clic droit sur le fichier de métadonnées de focus (.qsfm), et choisissez Importer comme métadonnées dans le focus.

    Dans la boîte de dialogue Importer des métadonnées dans le focus, choisissez le focus cible.

  • Faites un clic droit sur le focus cible et choisissez Métadonnées>Importer.

    Dans la boîte de dialogue Importer les métadonnées dans le focus, choisissez le fichier de métadonnées de focus.

Vous pouvez choisir exactement quelle sorte de métadonnées importer et changer la cible du focus. Une fois les paramètres définis, cliquez sur Suivant pour choisir les renseignements d'importation.
Remarque :
  • À moins que vous ayez sélectionné explicitement les champs, Portrait Miner importe les métadonnées relatives à tous les champs du focus.
  • Le comportement par défaut est d'écraser le focus cible par un focus contenant les métadonnées choisies. Si vous décochez la case à cocher concernée, vous pouvez à la place spécifier un emplacement pour un nouveau focus.
  • Lors de l'importation de métadonnées, les interprétations qualitatives sont classées comme des découpages et non comme des interprétations.
  • Cette interface est une façon d'accéder à la plupart des fonctionnalités de la commande data build qsimportmetadata.

Voir également

À propos des assistants Portrait Miner


Édition des métadonnées d'un focus dans Excel

Vous pouvez modifier les métadonnées d'un focus [voir Métadonnées des fichier focus] dans Excel, y compris le libellé d'affichage des champs, les interprétations, les balises, les calculs et les commentaires.
  1. Exporter un fichier de métadonnées [voir Enregistrement des métadonnées d'un focus] d'un focus. Pour un jeu de données nouvellement importé, il s'agit d'un modèle vierge, et pour un jeu de données sur lequel vous avez travaillé, il contient tous les libellés, balises, découpages, calculs et autres détails que vous avez ajoutés.
  2. Pour créer un fichier Excel à éditer, faites un clic droit sur le fichier de métadonnées et choisissez Importer dans Excel.
  3. Pour éditer les métadonnées dans Excel, faites un clic droit sur le fichier Excel et choisissez Envoyer dans Excel. Le fichier Excel vous donnera plus de détails sur la façon d'éditer les métadonnées qu'il contient.
  4. Pour créer un fichier de métadonnées de focus, faites un clic droit sur le fichier Excel et choisissez Exporter en tant que métadonnées de focus Quadstone.
Sujet parent : Utilisation des métadonnées d'un focus


Utilisation de groupes de champs

  • Groupes de champs balisés
  • Balises utilisateur


Groupes de champs balisés

Vous pouvez gérer des groupes de champs d'après les balises ajoutées à un champ.
Sujet parent : Utilisation de groupes de champs

À propos des balises

Une balise peut être une balise client ou une interprétation. Chaque balise client est représentée par un marqueur contenant son initiale. La couleur de ces marqueurs est générée automatiquement.
L'onglet Balises du côté gauche de la fenêtre Decision Studio indique les balises en cours. Chaque balise est indiquée sur une ligne séparée avec :
  • Un indicateur de statut, un menu déroulant pour contrôler si les champs ayant cette balise doivent être visibles :
    • Pas de préférences : Les champs présentant cette balise peuvent ou non être visibles, selon les choix faits pour les autres balises.
    • Indiquer les champs comportant cette balise : Les champs présentant cette balise sont visibles, à moins qu'ils ne comportent aussi une balise également définie pour être masquée. Les champs ne comportant pas cette balise sont masqués, à moins qu'une de leurs balises ne soit définie pour être visible.
    • Toujours masquer les champs comprenant cette balise : Les champs portant cette balise seront masqués, même si le champ comporte une autre balise définie pour être visible.
  • Pour les balises utilisateur, il s'agit d'un marqueur de couleur.
  • Le nom de la balise.
  • Entre parenthèses, le nombre de champs comportant cette balise. Dans le cas d'interprétations Calculées, ce texte indique également le nombre de champs nouvellement créés s'ils sont masqués pour l'affichage.
Lorsqu'un outil est lancé, les champs qui sont visibles dans celui-ci sont basés sur l'affichage en cours de la fenêtre de Decision Studio. Cependant, la plupart des listes de champ de l'application ont également une case à cocher Tous les champs du focus permettant que tous les champs soient visualisés sans tenir compte de la vue dans la fenêtre Decision Studio.
  • Le Scoring ne présente pas toujours les champs dans l'interprétation Analyse. Les champs visibles dans la fenêtre Decision Studio n'ont pas d'incidence sur cela.
  • L'Arbre de décision et la Classification présentent les champs avec l'interprétation Analyse de même que pour tous les champs qui étaient visibles dans la fenêtre Decision Studio mais n'ayant pas l'interprétation Analyse lorsqu'ils ont été lancés. De surcroit, tous les champs qui avaient l'interprétation Analyse lorsque l'outil a été lancé, mais pour lesquels cette interprétation avait été supprimée, resteront visibles.
  • Les Aperçus (Aperçu du tableau croisé, Aperçu de la carte, Aperçu de la distribution croisée et Aperçu du profil) indiquent tous les champs actuellement visibles dans la fenêtre Decision Studio, plus tous ceux qui ont été utilisés dans la spécification de tableau croisé durant la dernière utilisation de l'outil.
Remarque : SI vous utilisez un focus avec un grand nombre de champs, définissez une visualisation pour les champs qui présentent un intérêt pour vous dans la fenêtre Decision Studio avant de lancer les outils.

Voir également

Balises utilisateur

Interprétations des champs

Afficher ou masquer des champs dans Decision Studio

Cliquez sur le menu d'état de balise pour choisir quel groupe afficher ou masquer. Sinon, cliquez directement sur l'icône d'état lors du parcours dans l'arborescence des états disponibles.

Le nombre de champs actuellement affichés et le nombre total de champs sont indiqués dans une barre d'état au bas de la fenêtre.

Remarque : Lorsque Decision Studio est lancé ou que le focus est chargé, toutes les balises ont l'état Pas de préférence, par conséquent, tous les champs seront visibles.

Pour afficher tous les champs

Pour réinitialiser l'affichage par défaut pour lequel les balises sont définies Pas de préférence et tous les champs sont visibles, faites un clic droit n'importe où sous l'onglet Balises et sélectionnez Afficher tous les champs.


Balises utilisateur

Dans Decision Studio, les champs peuvent recevoir des balises servant à les masquer ou les rendre visibles. Une balise est simplement un mot associé à un champ. Un champ peut comporter n'importe quel nombre de balises et une balise peut être associée à n'importe quel nombre de champs.
Sujet parent : Utilisation de groupes de champs

Création de balises

  1. Dans la fenêtre Decision Studio, surlignez les champs que vous souhaitez marquer.
  2. Faites un clic droit et sélectionnez Ajouter une balise utilisateur > Nouveau. Vous pouvez également sélectionner Balise > Nouveau ou Balise > Ajouter une balise utilisateur > Nouveau dans le menu principal.
  3. Saisissez un nom pour la balise et cliquez sur OK. Remarque : Il est conseillé d'éviter d'utiliser des noms de balises commençant par la même lettre pour être sûr que chacune aura une lettre différente dans la colonne Balises utilisateur de la fenêtre Decision Studio.
  4. Choisissez, à partir des options Étiqueter ces champs :
    • Aucun, pour créer une balise n'étant associée à aucun champ.
    • Champs sélectionnés, pour créer une balise et l'ajouter aux champs actuellement surlignés dans la fenêtre Decision Studio.
    • Champs correspondant à l'expression régulière, pour créer une balise et l'ajouter aux champs correspondant à une expression régulière. Par exemple, l'expression régulière .*Code correspond à tous les champs finissant par Code.
  5. Cliquez sur OK.

Voir également

Expressions régulières

Suppression de balises

  1. Dans la fenêtre Decision Studio, faites un clic droit sur la balise dans la section Utilisateur du volet Balise.
  2. Dans le menu, sélectionnez Supprimer.

Renommage de balises

  1. Dans la fenêtre Decision Studio, faites un clic droit sur la balise dans la section Utilisateur du volet Balise.
  2. Dans le menu, sélectionnez Renommer.

Ajout d'un champ à un groupe balisé

  1. Dans la fenêtre Decision Studio, surlignez les champs que vous souhaitez marquer.
  2. Choisissez Ajouter une balise utilisateur soit en faisant un clic droit sur les champs surlignés, soit depuis le menu Balise.
  3. Cliquez sur le nom de balise désiré. Remarque : Lorsque le ou les champs ont déjà la balise, le nom est grisé.

Suppression d'un champ d'un groupe balisé

  1. Dans la fenêtre Decision Studio, surlignez les champs dont vous souhaitez supprimer une balise.
  2. Choisissez Effacer une balise soit en faisant un clic droit sur les champs surlignés, soit depuis le menu Balise.
  3. Cliquez sur le nom de balise. Lorsqu'aucun des champs n'a déjà la balise, le nom est grisé.
Remarque : Une balise qui n'est associée à aucun champ ne sera pas enregistrée avec le focus.

Visualisation des balises d'un champ

  1. Surlignez le champ dans la fenêtre Decision Studio.
  2. Choisissez Champ>Propriétés ou faites un clic droit et choisissez Propriétés, ou encore, cliquez sur [image] dans la barre d'outils.

Modification des balises d'expressions régulières

Si vous avez créé une balise d'expression régulière, vous pouvez mettre à jour l'expression régulière et la réappliquer à tous les champs.

  1. Dans la fenêtre Decision Studio, faites un clic droit sur la balise d'expression régulière dans le volet Utilisateur (menu gauche).
  2. Sélectionnez Modifier et mettez à jour le nom ou l'expression régulière.
  3. Cliquez sur OK. Le système réapplique l'expression régulière à tous les champs.
Remarque : L'option de modification n'est valable que dans la session en cours. Lorsque vous téléchargez de nouveau un focus enregistré, la balise d'expression régulière est disponible, mais vous ne pouvez plus en modifier les valeurs.


Récapitulation, segmentation et visualisation d'un focus à l'aide des tableaux croisés

  • Tableaux croisés comme base de segmentation et de visualisation des données
  • Fonctions d'agrégation pour les tableaux croisés
  • Création d'un tableau croisé textuel
  • Organisation des champs et des statistiques dans un tableau croisé ou un graphique
  • Affichage détaillé d'un segment sélectionné dans un graphique
  • Application d'un tableau croisé à un focus


Tableaux croisés comme base de segmentation et de visualisation des données

Decision Studio utilise des tableaux croisés abstraits non seulement comme base pour les aperçus du tableau croisé, mais aussi pour le profil, la distribution croisée et les graphiques de carte.

Un tableau croisé dans ce sens se compose de zéro ou de plusieurs champs de ventilation, avec une ou plusieurs statistiques. Les statistiques sont évaluées pour chaque cellule de la segmentation potentiellement multidimensionnelle qui est définie par les découpages sur les champs de ventilation.

Une fois que vous avez spécifié un tableau croisé abstrait et que les statistiques ont été calculées, vous pouvez organiser les champs et les statistiques [voir Organisation des champs et des statistiques dans un tableau croisé ou un graphique] à votre convenance dans votre aperçu du tableau croisé tabulaire ou graphique.

Voir également

Fonctions d'agrégation pour les tableaux croisés
Sujet parent : Récapitulation, segmentation et visualisation d'un focus à l'aide des tableaux croisés

Définition des champs et des statistiques dans les tableaux croisés

  1. Dans l'Aperçu du tableau croisé, l'Aperçu du profil, l'Aperçu de la distribution croisée ou l'Aperçu de la carte, choisissez Modifier>Modifier le tableau croisé ou cliquez sur [image] dans la barre d'outils.

    La boîte de dialogue Sélectionner les champs et les fonctions d'agrégation apparaît.

  2. Surlignez les champs de ventilation nécessaires dans le volet Champs disponibles et cliquez sur [image] pour ajouter les champs surlignés au volet Champs sélectionnés.
  3. Pour chaque statistique requise :
    1. Surlignez la fonction d'agrégation [voir Fonctions d'agrégation pour les tableaux croisés] dans le volet Fonctions disponibles.
    2. Si la fonction d'agrégation prend un argument, surlignez le champ requis dans le volet Paramètres de la fonction.
    3. Cliquez sur [image] pour ajouter la statistique au volet Fonctions d'agrégation sélectionnées.

    Vous pouvez surligner plusieurs fonctions et/ou champs d'agrégation en même temps, auquel cas, lorsque vous cliquez sur [image], vous obtenez toutes les combinaisons fonction/champ valides sous forme de statistiques.

  4. Cliquez sur OK pour créer le tableau croisé.
Remarque :
  • Si un aperçu suit [voir Relations entre outils] un autre aperçu (sauf pour un Aperçu du profil suivant un autre type d'aperçu ou vice versa), vous pouvez cocher la case Utiliser la description de l'organisateur pour que l'aperçu suivant hérite des spécifications du tableau croisé abstrait de l'aperçu de début (ainsi que de ses données de segment surlignées).

    La case Utiliser la description de l'organisateur est cochée par défaut (le cas échéant) lorsque vous faites un zoom avant [voir Affichage détaillé d'un segment sélectionné dans un graphique] en cliquant sur le menu Segments >Déploiement.

  • La barre Taille estimée de la boîte de dialogue donne une indication approximative de la taille du tableau croisé en termes de données. Si la barre remplit l'espace disponible, il est probable que le tableau croisé est trop grand pour être évalué ou que cela prend trop de temps pour y accéder.

    Vous pouvez modifier la limite de la taille du tableau croisé en paramétrant une préférence [voir Définition des préférences de Portrait Miner] : Dans la section Agrégation, modifiez la valeur de l'option taille maximale. Portrait Miner utilise cette valeur lorsqu'il calcule le tableau croisé. Cependant, la barre Taille estimée ne l'utilise pas pour son estimation.

  • Pour supprimer un champ ou une statistique dans le volet Champs sélectionnés ou Fonctions d'agrégation sélectionnées, surlignez le champ ou la statistique et cliquez sur [image] à droite du volet.

Enregistrement d'un tableau croisé à partir de Decision Studio

Si vous souhaitez réutiliser un tableau croisé textuel, un graphique de distribution croisée, un ensemble de graphiques de profil ou un graphique de carte, ou les partager avec quelqu'un qui n'a pas entièrement accès à Portrait Miner, vous pouvez enregistrer le tableau croisé abstrait sous-jacent (y compris les statistiques évaluées).
  1. Choisissez Fichier>Enregistrer sous ou cliquez sur [image] dans la barre d'outils.
  2. Ouvrez [voir Ouverture ou enregistrement d'un fichier, d'une session ou d'une table de base de données] l'emplacement requis et choisissez un nom pour le tableau croisé.

Chaque aperçu de Decision Studio enregistre son propre type de tableau croisé (avec une extension de nom de fichier unique), que vous pouvez ouvrir dans un ou plusieurs aperçus de Decision Studio. Vous pouvez également utiliser une extension de nom de fichier .qsxt pour un tableau croisé générique.

Aperçu de Decision Studio | Extension de nom de fichier | Aperçus de Decision Studio compatibles
Aperçu du tableau croisé | .qstv | Aperçu du tableau croisé, Aperçu de la carte et Aperçu de la distribution croisée
Aperçu de la distribution croisée | .qsdv | Aperçu du tableau croisé, Aperçu de la carte et Aperçu de la distribution croisée
Aperçu du profil | .qspv | Aperçu du profil
Aperçu de la carte | .qsmv | Aperçu du tableau croisé, Aperçu de la carte et Aperçu de la distribution croisée
Tout | .qsxt | Suivant le type de tableau croisé en cours

Voir également

Exportation de données tabulaires à partir de Decision Studio

Application d'un tableau croisé à un focus

Ouverture d'un tableau croisé dans Decision Studio

Enregistrement d'un modèle ou d'une segmentation Decision Studio au format QMML (XML)

XML dans Portrait Miner

Ouverture d'un tableau croisé dans Decision Studio

Si vous souhaitez ouvrir un tableau croisé textuel enregistré précédemment, un graphique de distribution croisée, un ensemble de graphiques de profil ou un graphique de carte, vous pouvez charger la spécification de tableau croisé abstrait sous-jacente, qui sera ensuite appliquée au focus en cours.
  1. Choisissez Fichier>Ouvrir ou cliquez sur [image] dans la barre d'outils.
  2. Ouvrez [voir Ouverture ou enregistrement d'un fichier, d'une session ou d'une table de base de données] le fichier de tableau croisé requis.
Remarque :
  • Les champs de ventilation et les statistiques qui ne sont pas compatibles avec le focus en cours ne sont pas chargés.
  • Lorsque tous les champs de ventilation et les statistiques sont compatibles avec le focus en cours, la mise en page du tableau croisé enregistré [voir Organisation des champs et des statistiques dans un tableau croisé ou un graphique] est également chargée.

Voir également

Enregistrement d'un tableau croisé à partir de Decision Studio
© 2015 Pitney Bowes Software Inc. Email: software.support@pb.com


Fonctions d'agrégation pour les tableaux croisés

Les fonctions d'agrégation suivantes sont disponibles et utilisables dans les tableaux croisés abstraits [voir Tableaux croisés comme base de segmentation et de visualisation des données] dans Decision Studio. Sauf avertissement contraire ; une fonction d'agrégation prend un seul champ numérique, de chaîne ou de date comme argument.

Sur la plupart des écrans, les fonctions sont ré-étiquetées avec des étiquettes d'affichage. Les étiquettes peuvent être modifiées dans l'onglet Étiquettes des fonctions lors de la modification des préférences d'affichage via Edition dans la fenêtre de Decision Studio. Les préférences d'affichage restent identiques pour les sessions suivantes de chaque utilisateur. Les étiquettes des fonctions ne sont pas enregistrées avec le focus.

Voir également

Libellés d'affichage d'un champ
Fonction | Étiquette par défaut | Résultat
Any [voir any] | Valeur échantillon de | Une valeur non null dans le champ, élaborée à partir d'un enregistrement arbitraire non null dans le segment
ConfIntLower [voir confintlower] | Limite inférieure de la borne à 95 % | La limite inférieure d'un intervalle de confiance de 95 % pour la moyenne du champ dans le segment
ConfIntUpper [voir confintupper] | Limite supérieure de la borne à 95 % | La limite supérieure d'un intervalle de confiance de 95 % pour la moyenne du champ dans le segment
Count [voir count] | Quantité | Le nombre d'enregistrements dans le segment. Cette fonction n'accepte pas d'argument.
CountNonNull [voir countnonnull/countnonnulls] | Quantité non manquante | Le nombre d'enregistrements dans le segment dont le champ a des valeurs non null [voir La valeur null]
CountNull [voir countnull/countnulls] | Quantité manquante | le nombre d'enregistrements dans le segment dont le champ contient la valeur null [voir La valeur null]
CountUnique [voir countunique] | Valeur distincte de | Le nombre de valeurs uniques se produisant dans le champ, incluant potentiellement la valeur null.
CountUniqueNonNull [voir countuniquenonnull] | Valeurs distinctes non manquantes de | Le nombre de valeurs uniques, à l'exception de la valeur null, se produisant dans le champ
ExpectedCount [voir expectedcount] | Quantité attendue | Le nombre d'enregistrements qui serait attendu dans le segment si les champs du tableau croisé étaient indépendants les uns des autres. Cette fonction n'accepte pas d'argument.
ExpectedProportion [voir expectedproportion] | Proportion attendue | La proportion de population qui serait attendue dans le segment si les champs du tableau croisé étaient indépendants les uns des autres. Cette fonction n'accepte pas d'argument.
First [voir first] | Première valeur de | La première valeur non null dans le champ pour le segment
Last [voir last] | Dernière valeur de | La dernière valeur non null dans le champ pour le segment
Max [voir max (un seul argument)] | Maximum | La valeur non null maximale dans le champ pour le segment
Mean [voir mean (un argument)] | Moyenne | La moyenne (moyenne commune) des valeurs non null dans le champ pour le segment. Cette fonction nécessite un champ numérique comme argument.
Median [voir median] | Médiane | La médiane (valeur du milieu) des valeurs non null dans le champ pour le segment. Cette fonction nécessite un champ numérique comme argument.
Min [voir min (un argument)] | Minimum | La valeur non null minimale dans le champ pour le segment
Mode [voir mode] | Plus commun | Le mode (valeur la plus commune) des valeurs non null dans le champ pour le segment
ModeRatio [voir moderatio] | Pureté de | La proportion d'enregistrements non null dans le segment qui contiennent la valeur non null la plus commune dans le champ.
PercentageRate [voir percentagerate] | Pourcentage de | Le pourcentage d'enregistrements non null dans le segment qui contiennent la valeur 1 dans le champ. Le champ doit uniquement contenir les valeurs 0 et 1.
Proportion [voir proportion] | Proportion | Le nombre d'enregistrements dans le segment en tant que proportion du nombre total d'enregistrements. Cette fonction n'accepte pas d'argument.
SegmentIndex (segindex) [voir segindex] | Index de segment | Un nombre positif identifiant de manière unique le segment dans le tableau croisé. Cette fonction n'accepte pas d'argument.
Significance [voir significance] | Significativité de | La significativité statistique de toute incohérence entre la valeur moyenne du champ dans le segment et la valeur moyenne du champ pour l'ensemble de la population, avec un signe indiquant la direction de l'écart-type (cette fonction nécessite un champ numérique comme argument).
StandardDeviation (stdev) [voir stdev] | Dev. std. de | L'écart-type des valeurs non null dans le champ pour le segment Cette fonction nécessite un champ numérique comme argument.
Sum [voir sum (un argument)] | Somme de | La somme des valeurs non null dans le champ pour le segment Cette fonction nécessite un champ numérique comme argument.
Variance [voir variance] | Variance de | La variance des valeurs non null dans le champ pour le segment. Cette fonction nécessite un champ numérique comme argument.
Remarque : Certaines fonctions d'agrégation (comme Median et Mode) peuvent générer des résultats de chaîne ou de date lorsque vous les appliquez à des champs de date ou de chaîne. Étant donné que les aperçus graphiques ne peuvent pas afficher les statistiques de chaîne ou de date, vous ne pouvez pas appliquer ces fonctions aux champs de chaîne ou de date, sauf dans l'Aperçu du tableau croisé (qui peut afficher des statistiques de chaîne et de date).
Sujet parent : Récapitulation, segmentation et visualisation d'un focus à l'aide des tableaux croisés


Création d'un tableau croisé textuel

  1. Dans la fenêtre de Decision Studio, sélectionnez un ou plusieurs champs que vous désirez utiliser dans votre tableau croisé.
  2. Choisissez Outils>Aperçu du tableau croisé ou cliquez sur [image] dans la barre d'outils.

    L'Aperçu du tableau croisé s'ouvre et affiche un tableau (ventilé dans les champs sélectionnés) du nombre d'enregistrements et des valeurs moyennes d'un objectif numérique , le cas échéant.

Remarque :
  • Si vous lancez l'Aperçu du tableau croisé sans qu'aucun champ ne soit sélectionné, la boîte de dialogue Tableaux croisés comme base de segmentation et de visualisation des donnéesSélectionner les champs et les fonctions d'agrégation [voir ] s'affiche. Si vous cliquez sur OK sans choisir aucun champ, l'Aperçu du tableau croisé indique les statistiques résumées de la population entière.
  • Pour modifier le tableau croisé sous-jacent [voir Tableaux croisés comme base de segmentation et de visualisation des données], vous pouvez à tout moment choisir Modifier>Modifier le tableau croisé ou cliquer sur [image] dans la barre d'outils.
  • S'il existe des champs de chaîne dans le tableau croisé requis n'ayant ni interprétation géographique ni interprétation qualitative, l'Aperçu du tableau croisé vous invite à les interpréter, pour qu'ils puissent être découpés de façon appropriée. Vous pouvez choisir l'interprétation qualitative par défaut, utiliser une hiérarchie qualitative enregistrée, ou interpréter le champ comme étant géographique.

Voir également

Ouverture d'un tableau croisé dans Decision Studio

Organisation des champs et des statistiques dans un tableau croisé ou un graphique

Sujet parent : Récapitulation, segmentation et visualisation d'un focus à l'aide des tableaux croisés

Affichages du tableau croisé

Par défaut, l'Aperçu du tableau croisé comprend tous les champs en en-tête de ligne [image], l'exception étant que si vous surlignez exactement deux champs dans la fenêtre Decision Studio avant d'ouvrir l'Aperçu du tableau croisé, l'Aperçu du tableau croisé fait de l'un un en-tête de ligne et de l'autre un en-tête de colonne.

Lorsqu'il existe à la fois des en-têtes de ligne et de colonne, il n'est possible d'indiquer qu'une statistique à la fois ; si vous en avez plusieurs, l'Aperçu du tableau croisé tabule chaque statistique dans son propre volet d'onglets :

Comme pour les modalités ordinaires des champs de ventilation, il existe trois modalités extraordinaires : l'intervalle null [voir La valeur null], la modalité non classée et la modalité de tableau croisé spécial résumé, qui contient tous les enregistrements des clients. Ainsi, par exemple, les enregistrements qui tombent à la fois dans la modalité d'âge 50 — 59 et dans le résumé de modalité de sexe représentent simplement les enregistrements tombant dans la modalité d'âge 50 — 59. D'un point de vue pratique, cela signifie que lorsque vous incluez des modalités de résumé dans un affichage de tableau croisé, vous pouvez ne pas faire apparaître les informations de chaque tableau croisé impliquant n'importe lequel des champs de ventilation.

L'Aperçu du tableau croisé a les options d'affichage suivantes :

  • Choisissez Afficher>Données non renseignées ou cliquez sur [image] dans la barre d'outils pour activer ou désactiver l'affichage des modalités non renseignées.
  • Choisissez Afficher>Données récapitulatives ou cliquez sur [image] dans la barre d'outils pour activer ou désactiver les modalités récapitulatives.
Remarque :

Bien que chaque découpage contienne une modalité pour la valeur null, tous les découpages ne contiennent pas d'intervalle non classé.

Voir également

Optimisation de l'espace d'affichage pour un outil Decision Studio

Définition du format d'affichage des valeurs numériques et de date


Organisation des champs et des statistiques dans un tableau croisé ou un graphique

Vous pouvez organiser les champs et les statistiques avec la zone de configuration graphique en bas de l'Aperçu du tableau croisé, de l'Aperçu du profil, de l'Aperçu de la distribution croisée ou de l'Aperçu de la carte :

  • Les champs et les statistiques qui sont présents dans le tableau croisé sous-jacent [voir Tableaux croisés comme base de segmentation et de visualisation des données] sont représentés par des boutons déplaçables, par exemple :

  • La barre [image] (Informations seulement) au bas de la zone de configuration graphique affiche des champs et des statistiques qui font partie du tableau croisé sous-jacent, mais qui ne figurent pas dans le tableau ou le graphique affiché.
  • Les parties vertes ( [image]) de la zone de configuration graphique représentent les aspects du tableau croisé ou du graphique auxquels vous pouvez associer les champs :
    Icône Format du tableau croisé/graphique
    Axes x (gauche - droite), dans l'Aperçu de la distribution croisée ou l'Aperçu du profil
    Axes y (avant - arrière) dans l'Aperçu de la distribution croisée
    Axes z (vertical), dans l'Aperçu de la distribution croisée
    Dimension de comparaison du segment traité/contrôlé, dans l'Aperçu du tableau croisé ou l'Aperçu du tableau croisé ; utilisée généralement avec un champ de partition
    Champ de ventilation de la ligne, dans l'Aperçu du tableau croisé
    Champ de ventilation de la colonne, dans l'Aperçu du tableau croisé
    Emplacement pour les régions tracées en blocs et relief, dans l'Aperçu de la carte
    Emplacement pour les départs des flèches, dans l'Aperçu de la carte
    Emplacement pour les extrémités des flèches, dans l'Aperçu de la carte
  • Les parties ( [image]) de la zone de configuration graphique représentent les aspects du tableau croisé ou du graphique auxquels vous pouvez associer les statistiques :
    Icône Format du tableau croisé/graphique
    Couleur du bloc (couleur de bloc, région ou flèche dans l'Aperçu de la carte)
    Hauteur du bloc (hauteur de bloc ou région dans l'Aperçu de la carte)
    Largeur du bloc
    Profondeur du bloc
    Volume du bloc
    Statistique tabulée, dans l'Aperçu du tableau croisé
    Épaisseur d'une flèche dans l'Aperçu de la carte
Sujet parent : Récapitulation, segmentation et visualisation d'un focus à l'aide des tableaux croisés

Association d'un champ ou d'une statistique sous forme de tableau croisé/graphique

Faites glisser le champ ou la statistique (c'est à dire, le bouton mobile correspondant dans la zone de configuration graphique) et déposez-le à côté de l'icône de l'aspect de tableau croisé/graphique désiré.

Pendant que vous faites glisser un champ ou une statistique, le pointeur de la souris se modifie pour refléter ce qui se passera lorsque vous relâcherez le bouton de la souris :

Pointeur | Action
 | Associe un champ ou une statistique ayant l'aspect d'un tableau croisé/graphique
 | Remplace le champ ou la statistique par le champ ou la statistique se trouvant sous le pointeur de la souris.
 | Ne fait rien.
Remarque :
  • Vous pouvez associer une statistique à plusieurs aspects ou graphiques en créant un bouton amovible supplémentaire pour la statistique : faites un clic droit et choisissez Dupliquer.

    Pour supprimer une statistique dupliquée superflue, faites glisser une copie par-dessus l'autre et déposez-la lorsque le pointeur de la souris devient

    Vous pouvez dupliquer un champ de la même façon dans l'Aperçu de la carte, pour une utilisation simultanée avec des représentations de blocs/régions et de flèches.

  • Lorsque vous faites un clic droit sur un bouton mobile représentant un champ, vous pouvez lancer un Éditeur de découpage pour modifier le découpage, ou une boîte de dialogue Sélectionner les valeurs pour modifier la sélection d'enregistrement. Ces opérations s'appliquent à la totalité des jeux de données et pas seulement à la vue en cours.
  • Lorsque vous faites un clic droit sur un bouton mobile représentant un champ ou une statistique, vous pouvez également éliminer par filtrage des valeurs du graphique. Il s'agit d'un filtre valable uniquement pour la visualisation en cours. Si vous choisissez Filtrer, une boîte de dialogue Filtrer s'affiche. Il existe trois options différentes pour le filtrage qualitatif [voir Sélection de valeur ou de filtrage à l'aide d'un champ qualitatif] et le filtrage non qualitatif [voir Sélection ou filtrage de valeurs à l'aide d'un champ non qualitatif ou d'une statistique].

    Vous ne pouvez pas ajouter, modifier ni supprimer un filtre pendant qu'un segment est surligné dans le graphique. Decision Studio supprime tous les filtres lors des mises à jour des tableaux croisés ou des graphiques.

  • Lorsque vous utilisez la dimension de comparaison ( [image]) (généralement avec un champ de partition ), vous pouvez configurer les fonctions de comparaison affichées. Faites un clic droit et choisissez Configuration des comparaisons. Dans la boîte de dialogue Configuration des types de comparaison de la de fonction, vous pouvez choisir d'enregistrer tous les enregistrements, les enregistrements traités ou les enregistrements témoins, ou un seul parmi plusieurs ratios et différences. Dans l'Aperçu de la distribution croisée, les légendes des axes et des échelles de couleur sont annotées en conséquence.

Suppression d'un champ ou d'une statistique d'un tableau croisé ou un graphique

Faites glisser le champ ou la statistique (c'est à dire le bouton mobile correspondant) de son emplacement en cours jusqu'à la barre [image].


Affichage détaillé d'un segment sélectionné dans un graphique

Dans l'Aperçu du profil, l'Aperçu de la distribution croisée ou l'Aperçu de la carte, effectuez l'une des actions suivantes :
  • Faites un double clic sur un segment. Pour afficher plus de détails sur plusieurs segments, sélectionnez les segments [voir Sélection des segments dans une vue graphique] et continuez à maintenir la touche CTRL enfoncée tout en cliquant deux fois sur le dernier segment.

    Decision Studio ouvre un autre aperçu du même type, avec la même spécification de tableau croisé [voir Tableaux croisés comme base de segmentation et de visualisation des données].

  • Sélectionnez un ou des segments [voir Sélection des segments dans une vue graphique] qui vous intéressent. Dans le menu Segments>Approfondir, choisissez un outil dans lequel profiler les segments sélectionnés : Aperçu du tableau croisé, Aperçu du profil, Aperçu de la distribution croisée ou Aperçu de la carte.

    Si vous choisissez Aperçu du profil à partir de l'un des autres aperçus d'arbre, ou vice versa, vous devez spécifier les champs et les statistiques [voir Définition des champs et des statistiques dans les tableaux croisés] requises pour votre profil de segment. Dans tous les autres cas, Decision Studio utilise la même spécification de tableau croisé [voir Tableaux croisés comme base de segmentation et de visualisation des données].

Dans tous les cas, le nouvel aperçu est lié [voir Relations entre outils] à l'aperçu d'origine et le graphique nouvellement créé présente plus de détails sur les segments sélectionnés (le cas échéant).

Remarque :
  • Si vous sélectionnez de nouveaux segments dans le premier graphique, le second graphique se met à jour en conséquence.
  • Le même comportement d'approfondissement s'applique à toutes les paires d'outils dans un relation de suite d'outils [voir Relations entre outils].
  • Dans l'Aperçu de la carte, le niveau de détails disponible dépend de la carte.
Sujet parent : Récapitulation, segmentation et visualisation d'un focus à l'aide des tableaux croisés


Application d'un tableau croisé à un focus

Vous pouvez appliquer une description de tableau croisé [voir Tableaux croisés comme base de segmentation et de visualisation des données] à un focus pour créer un nouveau tableau croisé.
  • Dans Portrait Miner, cliquez avec le bouton droit sur le tableau croisé que vous voulez appliquer, et choisissez Appliquer au Focus.

Dans la boîte de dialogue Appliquer le tableau croisé, choisissez le tableau croisé à appliquer, le focus auquel vous souhaitez l'appliquer et le fichier du tableau croisé que vous souhaitez créer.

Remarque :
  • Par défaut, lorsque vous appliquez un tableau croisé à un focus, les échantillons de champs de ventilation proviennent du nouveau focus. En cochant la case appropriée, vous pouvez utiliser les échantillons associés au tableau croisé d'origine.
  • Cette interface utilisateur est un moyen d'accéder à certaines fonctionnalités fournies par la commande data build qsxt Portrait Miner.

Voir également

À propos des assistants Portrait Miner

Ouverture d'un tableau croisé dans Decision Studio

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Affichage et modification de fichiers texte dans Portrait Miner

Sujet parent : Récapitulation, segmentation et visualisation d'un focus à l'aide des tableaux croisés


Visualisation et segmentation graphique des données de focus

  • Création d'un ensemble de graphiques de profil à variable unique
  • Création d'un graphique de distribution croisée multi-variable
  • Création d'un graphique sur une carte
  • Création d'une carte de catégorie à partir d'une hiérarchie de découpage par catégories
  • Options affectant l'affichage de graphiques et d'arbres de décision
  • Création d'un profil et d'un audit de focus


Création d'un ensemble de graphiques de profil à variable unique

  1. Dans la fenêtre de Decision Studio, sélectionnez un ou plusieurs champs que vous désirez utiliser dans vos données.
  2. Choisissez Outils>Aperçu du profil ou cliquez sur [image] dans la barre d'outils.

    L'Aperçu du profil s'ouvre et affiche un graphique du nombre d'enregistrements par modalité pour chacun des champs choisis.

Remarque :
  • Si un objectif numérique est défini dans le focus, l'Aperçu du profil indique la moyenne de l'objectif sous la forme d'une couleur de bloc (à moins que vous ayez modifié la préférence fonction d'objectif).
  • Si vous lancez l'Aperçu du profil sans qu'aucun champ ne soit sélectionné, la boîte de dialogue Sélectionner les champs et les fonctions d'agrégation [voir Tableaux croisés comme base de segmentation et de visualisation des données] s'affiche.
  • Pour modifier le tableau croisé sous-jacent [voir Tableaux croisés comme base de segmentation et de visualisation des données], vous pouvez à tout moment choisir Modifier>Modifier le tableau croisé ou cliquer sur [image] dans la barre d'outils.
  • S'il existe des champs de chaîne dans le tableau croisé requis n'ayant ni interprétation géographique ni interprétation qualitative, l'Aperçu du profil vous invite à les interpréter, pour qu'ils puissent être découpés de façon appropriée. Vous pouvez choisir l'interprétation qualitative par défaut, utiliser une hiérarchie qualitative enregistrée, ou interpréter le champ comme étant géographique.
  • Vous pouvez associer [voir Organisation des champs et des statistiques dans un tableau croisé ou un graphique] plusieurs statistiques à des hauteurs de blocs pour comparer des statistiques similaires sur un seul ensemble d'axes pour chaque champ de profil.

    Tant qu'aucune statistique n'est associée à la couleur de bloc, l'Aperçu du profil utilise une coloration arc en ciel pour distinguer les graphiques associés superposés ayant des statistiques différentes.

  • Si vous associez plusieurs statistiques à la hauteur de bloc, vous devez vous assurer que les graphiques ont une mise à l'échelle conjointe [voir Mise à l'échelle des graphiques de profil ensemble ou séparément.] ; sinon, vous ne pourrez pas comparer les valeurs des différentes statistiques.

Voir également

Ouverture d'un tableau croisé dans Decision Studio

Organisation des champs et des statistiques dans un tableau croisé ou un graphique

Options histogramme et graphique à barres

Options affectant l'affichage de graphiques et d'arbres de décision

Orientation d'un affichage graphique à l'aide de la souris

Mise à l'échelle des graphiques de profil ensemble ou séparément.

Sujet parent : Visualisation et segmentation graphique des données de focus


Création d'un graphique de distribution croisée multi-variable

  1. Dans la fenêtre de Decision Studio, sélectionnez un ou plusieurs champs (généralement, deux ou plus) que vous désirez utiliser pour ventiler vos données.
  2. Choisissez Outils>Aperçu de la distribution croisée ou cliquez sur [image] dans la barre d'outils.

    L'Aperçu de la distribution croisée s'ouvre et affiche un graphique du nombre d'enregistrements par segments défini par les champs que vous avez choisi.

Remarque :
  • L'Aperçu de la distribution croisée représente par défaut le nombre d'enregistrements par la hauteur de bloc si vous sélectionnez un ou deux champs de ventilation, alors qu'il utilise le volume des blocs si vous sélectionnez trois champs de ventilation.
  • Si vous surlignez deux ou plusieurs champs de ventilation, l'Aperçu de la distribution croisée n'utilise que trois d'entre eux pour commencer, le reste apparaissant dans la barre [image] (Informations seulement), au bas de la fenêtre.
  • Si un objectif numérique est défini dans le focus, l'Aperçu de la distribution croisée indique la moyenne de l'objectif sous la forme d'une couleur de bloc (à moins que vous ayez modifié la préférence fonction d'objectif).
  • Si vous avez défini un champ de partition dans le focus, l'Aperçu de la distribution croisée l'inclut dans le tableau croisé et l'affecte à la dimension de comparaison [voir Organisation des champs et des statistiques dans un tableau croisé ou un graphique] ( [image]). Pour une statistique impliquant Nombre, Moyenne, Taux de pourcentage ou Total, l'Aperçu de la distribution croisée affiche la statistique de l'échantillon traité moins la statistique de la population témoin. Pour toutes les autres statistiques, l'Aperçu de la distribution croisée affiche la statistique de la population globale. Vous pouvez modifier la comparaison affichée [voir Association d'un champ ou d'une statistique sous forme de tableau croisé/graphique].
  • Si vous lancez l'Aperçu de la distribution croisée sans qu'aucun champ ne soit sélectionné, la boîte de dialogue Sélectionner les champs et les fonctions d'agrégation [voir Tableaux croisés comme base de segmentation et de visualisation des données] s'affiche.
  • Pour modifier le tableau croisé sous-jacent [voir Tableaux croisés comme base de segmentation et de visualisation des données], vous pouvez à tout moment choisir Modifier>Modifier le tableau croisé ou cliquer sur [image] dans la barre d'outils.
  • S'il existe des champs de chaîne dans le tableau croisé requis n'ayant ni interprétation géographique ni interprétation qualitative, l'Aperçu de la distribution croisée vous invite à les interpréter, pour qu'ils puissent être découpés de façon appropriée. Vous pouvez choisir l'interprétation qualitative par défaut, utiliser une hiérarchie qualitative enregistrée, ou interpréter le champ comme étant géographique.

Voir également

Ouverture d'un tableau croisé dans Decision Studio

Organisation des champs et des statistiques dans un tableau croisé ou un graphique

Options histogramme et graphique à barres

Options affectant l'affichage de graphiques et d'arbres de décision

Orientation d'un affichage graphique à l'aide de la souris

Sujet parent : Visualisation et segmentation graphique des données de focus


Création d'un graphique sur une carte

  1. Dans la fenêtre de Decision Studio, associez un ou plusieurs champs à une carte en les interprétant en tant que champs géographiques (s'ils n'ont pas déjà un icône géographique [image] à côté d'eux dans la colonne Interprétations) :
    1. Sélectionnez les champs devant être associés à une carte.
    2. Choisissez balise>Interprétation>Géographique.

      Un navigateur de fichier Portrait Miner [voir Ouverture ou enregistrement d'un fichier, d'une session ou d'une table de base de données] s'affiche.

    3. Ouvrez le fichier carte requis.

      Un icône Géographique [image] dans la colonne Interprétations de la fenêtre de Decision Studio indique la présence d'une interprétation géographique.

  2. sélectionnez les champs géographiquement interprétés que vous désirez utiliser dans votre graphique de carte. Les champs doivent tous être associés à la même carte.
  3. Choisissez Outils>Aperçu de la carte ou cliquez sur [image] dans la barre d'outils.

    L'Aperçu de la carte s'ouvre et affiche la carte choisie, avec le nombre d'enregistrements pour chaque région représenté par une hauteur de bloc (si vous ne sélectionnez qu'un seul champ).

Remarque :
  • Vous pouvez aussi interpréter un champ depuis l'Éditeur de découpage : faites un clic droit sur le nom dans le volet Champs et choisissez Interprétations>Géographique.
  • Si vous surlignez deux ou plusieurs champs géographiques, l'Aperçu de la carte n'utilise que deux d'entre eux d'abord, le reste apparaissant dans la barre [image] (Informations seulement), en bas de la fenêtre. Au lieu d'indiquer le nombre d'enregistrements, la carte indique les liens de ligne entre les régions, dans lesquelles l'épaisseur d'un lien de ligne représente le nombre d'enregistrements qui relient la région de départ à la région de fin.

  • Si un objectif numérique est défini dans le focus, l'Aperçu de la carte indique la moyenne de l'objectif sous la forme d'une couleur de bloc ou d'une ligne de lien de couleur, selon le type de graphique (à moins que vous ayez modifié la préférence fonction d'objectif).
  • Si vous lancez l'Aperçu de la carte sans qu'aucun champ ne soit sélectionné, la boîte de dialogue Sélectionner les champs et les fonctions d'agrégation [voir Tableaux croisés comme base de segmentation et de visualisation des données] s'affiche.
  • Pour modifier le tableau croisé sous-jacent [voir Tableaux croisés comme base de segmentation et de visualisation des données], vous pouvez à tout moment choisir Modifier>Modifier le tableau croisé ou cliquer sur [image] dans la barre d'outils. Les champs de ventilation doivent tous être associés à la même carte.

Voir également

Ouverture d'un tableau croisé dans Decision Studio

Organisation des champs et des statistiques dans un tableau croisé ou un graphique

Options affectant l'affichage de graphiques et d'arbres de décision

Création d'une carte de catégorie à partir d'une hiérarchie de découpage par catégories

Orientation d'un affichage graphique à l'aide de la souris

Sujet parent : Visualisation et segmentation graphique des données de focus


Création d'une carte de catégorie à partir d'une hiérarchie de découpage par catégories

  1. Dans Portrait Miner, faites un clic droit sur le fichier de hiérarchie de découpage par catégories à partir duquel vous souhaitez créer une carte de catégorie et sélectionnez Créer une carte de catégorie.

    La boîte de dialogue Créer une carte de catégorie s'affiche.

  2. Sélectionnez l'emplacement de la nouvelle carte de catégorie.
  3. Choisissez éventuellement le type de carte de catégorie à créer.
  4. Choisissez éventuellement de ne pas écraser les carte de catégorie du même nom.
  5. Cliquez sur OK.
Remarque : Cette interface utilisateur permet d'accéder à la plupart des fonctionnalités fournies par la commande data build qsmapgen de Portrait Miner.

Voir également

À propos des assistants Portrait Miner

Création d'un graphique sur une carte

Enregistrement d'une hiérarchie de découpage par catégories

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Sujet parent : Visualisation et segmentation graphique des données de focus


Options affectant l'affichage de graphiques et d'arbres de décision

Il existe de nombreuses options contrôlant l'apparence des graphiques. Certaines sont globales et s'appliquent à tous vos graphiques, alors que d'autres ne s'appliquent qu'à un graphique en particulier.

Voir également

Optimisation de l'espace d'affichage pour un outil Decision Studio

Libellés d'affichage d'un champ

Sujet parent : Visualisation et segmentation graphique des données de focus

Définition des options globales des affichages graphiques

  1. Dans la fenêtre Decision Studio, sélectionnez Edition>Préférences d'affichage.

    La boîte de dialogue Format s'affiche. Trois de ses cinq volets à onglets contrôlent l'affichage graphique :

    Volet | Description
    Options de graphique | Le choix des éléments à inclure dans les graphiques (barres des axes, libellés des axes, grille, coches et étiquettes à cocher) le choix des couleurs pour les éléments graphiques, le choix des couleurs des modalités dans l'Éditeur de découpage ; le choix et les couleurs des graduations [voir Modification la plage de couleurs des blocs dans un graphique ou un arbre de décision] pour les blocs de graphiques, et s'il faut ou non inverser le noir, le blanc et le gris lors de l'impression (et sauvegarder l'image) d'un graphique
    Cocher la police de l'étiquette | Sélecteur de police pour les étiquettes à cocher, c'est à dire, les valeurs de champ
    Police de l'étiquette de l’axe | Sélecteur de police de caractères pour les libellés des axes, c'est à dire, les valeurs de champ
    Étiquettes des fonctions | Texte d'affichage alternatif pour les noms de fonctions d'agrégation
  2. Cliquez sur OK pour confirmer toutes les modifications et fermez la boîte de dialogue.
Remarque :
  • Vos paramètres sont enregistrés pour de futures sessions Decision Studio, Profile et Audits et Synthèse de modèle.
  • Le paramétrage Police de caractère du libellé des axes gouverne aussi les polices de caractères servant aux libellés de l'arbre de décision.
  • Dans le volet Couleurs de modalité, les paramètres Modalités et Valeurs aberrantes sont les couleurs utilisées par l'Éditeur de découpage pour les modalités normales et les Dernières modalités, respectivement. Le paramétrage des Modalités est aussi la couleur que le Constructeur d'arbre de décision utilise pour les graphiques à barres des segments des arbres en continu.
  • Dans le volet Couleurs d'élément, le paramétrage de Carte est la couleur que l'Aperçu de la carte utilise pour le contour de la carte elle-même.

Voir également

Définition du format d'affichage des valeurs numériques et de date

Modification la plage de couleurs des blocs dans un graphique ou un arbre de décision

  1. Dans la fenêtre Decision Studio, sélectionnez Edition>Préférences d'affichage. La boîte de dialogue Format s'affiche, avec l'onglet Options de graphique sélectionné.
  2. Utilisez les sélecteurs de couleurs sous forme de liste déroulante dans le volet Couleur du bloc pour choisir les couleurs devant représenter les valeurs « High », « Mid », et « Low » (par défaut, rouge, vert et bleu, respectivement). L'interprétation exacte de ces couleurs dépend de la forme d'échelle de couleur choisi. Pour un arbre de décision, l'interprétation de ces couleurs dépend des paramètres de la boîte de dialogue Afficher la configuration pour l'arbre de décision [voir Contrôler de l'utilisation de la couleur et de la profondeur dans un arbre de décision].

  3. Dans le volet Carte de couleur du Viewer, choisissez la forme d'échelle de couleurs utilisée :

    Mise à l'échelle | Description
    Linéaire | Une répartition régulière des couleurs entre les valeurs maximale et minimale, avec le minimum représenté par la couleur Mid et le maximum représenté par la couleur High
    Linéaire avec zéro (par défaut)

    S'il n'y a pas de valeur négative : une répartition régulière des couleurs entre les valeurs zéro et maximale, avec le zéro représenté par la couleur Mid et le maximum représenté par la couleur High

    S'il n'y a pas de valeur positive : une répartition régulière des couleurs entre les valeurs minimum et zéro, avec le minimum représenté par la couleur Low et le maximum représenté par la couleur Mid

    S'il existe à la fois des valeurs positives et négatives : Une répartition régulière des couleurs sur une plage de valeurs centrées sur zéro, avec le minimum (ou le négatif du maximum) représenté par la couleur Low, zéro représenté par la couleur Mid et le maximum (ou négatif du minimum) représenté par la couleur High
    Discrimination maximale | Une répartition non linéaire des couleurs entre les valeurs maximale et minimale, de telle façon que chaque nuance de couleur corresponde en gros à un même nombre d'enregistrements (accentuant ainsi la discrimination entre les valeurs), avec la valeur minimale représentée par la couleur Low, la valeur moyenne représentée par la couleur Mid et la valeur maximale représentée par la couleur High
  4. Utilisez le paramètre Nombre de couleurs pour contrôler le nombre de couleurs distinctes utilisées.
  5. Cliquez sur OK.

Affichage ou masquage de la légende de couleur d'un graphique

Dans l'Aperçu du profil, l'Aperçu de la distribution croisée ou l'Aperçu de la carte, choisissez Afficher>Légende ou cliquez sur [image] dans la barre d'outils.

Remarque :

Il n'existe pas de légende de couleurs disponible dans l'Arbre de décision.

Affichage ou masquage de segments ayant une valeur null et non classée dans un graphique

Dans l'Éditeur de découpage, l'Aperçu du profil, l'Aperçu de la distribution croisée ou l'Aperçu de la carte :
  • Choisissez Afficher>Données non renseignées ou cliquez sur [image] dans la barre d'outils pour activer ou désactiver l'affichage des modalités non renseignées.
  • Choisissez Afficher>Données non classées pour afficher ou masquer l'affichage des modalités non classées.

Affichage ou masquage de catégories vides dans un graphique

Dans l'Aperçu du profil ou l'Aperçu de la distribution croisée, choisissez Afficher>Catégories vides pour afficher ou masquer l'affichage des catégories vides.

Mise à l'échelle des graphiques de profil ensemble ou séparément.

Dans l'Aperçu du profil, par défaut, tous les graphiques de profil sont à une même échelle sur l'axe vertical. Pour avoir une échelle de graphiques indépendante, choisissez Afficher>Échelonner globalement pour décocher la case à côté de cette option.

Remarque :

Vous pouvez associer plusieurs statistiques à la hauteur d'un bloc, de sorte que deux graphiques ou plus partagent des axes communs. Si vous choisissez dans ce cas une mise à l'échelle indépendante, l'axe vertical n'a pas de libellé et vous ne pouvez pas comparer les valeurs des différentes statistiques.

Affichage ou masquage de l'axe vertical dans un graphique de carte

Dans l'Aperçu de la carte, cochez ou décochez l'option de menu Afficher>Afficher l'axe hauteur.

Contrôler de l'utilisation de la couleur et de la profondeur dans un arbre de décision

  1. Dans l'Arbre de décision, choisissez Afficher>Configuration.

    La boîte de dialogue Afficher la configuration pour l'arbre de décision s'affiche.

  2. À l'aide des menus déroulants, choisissez, le cas échéant, ce qui doit représenter la profondeur et la couleur de chaque segment.
  3. Définissez Échelle de couleur du segment central à sur

    Racine de l'arbre pour utiliser les couleurs moyennes dans la plage de couleurs [voir Modification la plage de couleurs des blocs dans un graphique ou un arbre de décision] (vert par défaut) pour le segment racine ;

    Plage moyenne pour utiliser les couleurs moyennes (vert par défaut) pour représenter la valeur à mi-chemin entre les extrêmes apparaissant dans l'arbre de décision.

    50 % de la population correspondant à l'objectif etc. (l'option dépend du type de l'arbre) pour utiliser la couleur du milieu (vert par défaut) pour représenter une valeur particulière de taux de correspondance, une moyenne d'objectif, un uplift, etc.

  4. Cliquez sur OK.


Création d'un profil et d'un audit de focus

Profil et Audit d'un focus est un rapport au format HTML contenant des informations sur le focus, incluant le profil de certains ou de tous les champs du focus, éventuellement en relation avec un ou plusieurs champs cibles.

Pour créer un profil et un audit dans Portrait Miner, faites un clic droit sur le focus que vous désirez auditer et choisissez Créer un profil et contrôler.

Dans la boîte de dialogue Créer un profil et contrôler, vous pouvez choisir quels champs ou groupes de champs balisés profiler, s'il faut ignorer un champ de partition et quels champs cibles utiliser. (Si le focus comporte un objectif, il s'agit du champ cible par défaut). Vous pouvez aussi sélectionner un sous ensemble d'enregistrements à l'aide d'une expression FDL [voir Expressions].

Une fois terminé, le rapport d'audit est affiché sous l'onglet Audit du dialogue Créer un profil et contrôler.

Remarque :
  • Vous pouvez choisir les champs sur lesquels vous désirez faire un rapport, soit en sélectionnant les noms de champ, soit en choisissant une ou plusieurs balises [voir Utilisation de groupes de champs].
  • Vous pouvez choisir une des quatre options pour les formats des images utilisées dans la sortie HTML :

    svg SVG (graphique vectoriel adaptable ) uniquement. Le format SVG offre la meilleure qualité d'image et les plus petites tailles de fichier, mais les lecteurs de votre rapport doivent avoir un navigateur Web comportant un plugin SVG pour afficher ou imprimer ces images.

    smallpng SVG plus bitmap PNG optimisés pour l'écran (graphiques réseau mobiles). Même sans plugin SVG, les lecteurs sont à même de lire les images de votre rapport (mais la qualité d'impression est relativement basse).

    largepng SVG plus bitmap PNG optimisés pour l'écran et l'imprimante. Les lecteurs sont à même d'afficher ou d'imprimer votre rapport sans avoir besoin d'un plugin SVG (mais il est nécessaire d'avoir plus d'espace disque et le rapport met plus longtemps à s'afficher).

    aucun Pas d'image.

  • Vous pouvez contrôler davantage les aspects de l'apparence de la synthèse de modèle et des rapports de Profil et d'Audit en définissant les préférences [voir Définition des préférences de Portrait Miner] dans la section Audits et Synthèses de la fenêtre des Préférences.
  • Pour que Portrait Miner puisse vous avertir par e-mail lorsqu'un rapport est prêt, vous devez définir les préférences emailaddress et emailserver en conséquence.
  • Par défaut, Portrait Miner enregistre un profil et un audit comme un simple fichier .qshtml, avec des images intégrées. Bien que vous puissiez ouvrir ce fichier dans Portrait Miner (en effectuant un double clic sur le fichier), vous ne pouvez pas l'utiliser directement à l'extérieur de Portrait Miner.

    Pour créer une page Web adaptée qui peut être placée sur un serveur Web, faites un clic droit sur un fichier .qshtml, et choisissez Décompacter dans le dossier. Choisissez un emplacement pour le dossier et cliquez sur OK. C'est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qshtmlunpack de Portrait Miner.

  • Vous pouvez créer un profil et un audit sur un jeu de données tiers en faisant un clic droit sur le fichier dans Portrait Miner et en choisissant Audit. Dans la boîte de dialogue qui s'affiche, vous pouvez choisir un emplacement pour le focus temporaire que Portrait Miner a créé pendant le déroulement de la préparation du rapport ; le nom de ce focus apparaît à la place du nom du jeu de données d'origine.
  • Le dialogue Créer un profil et contrôler est une façon d'accéder à la plupart des fonctionnalités fournies par la commande data build qsaudit de Portrait Miner.

Voir également

À propos des assistants Portrait Miner

Création d'une synthèse de modèle

Définition des options globales des affichages graphiques

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Sujet parent : Visualisation et segmentation graphique des données de focus

Utilisation d'un rapport de référence pour comparer des focus

Un rapport de comparaison est comparable à un rapport de profil et d'audit, excepté qu'il inclut côte-à-côte les profils dans deux focus, ainsi que les détails des différences entre les diverses statistiques, vous permettant par exemple d'observer les modifications dans le temps.

Pour créer un rapport de comparaison, créez un rapport de profil et d'audit pour votre premier focus de la façon habituelle, c'est votre « rapport de référence ». Créez alors un rapport de profil et d'audit pour votre deuxième audit, mais dans le dialogue Créer un profil et contrôler, spécifiez le rapport de référence que vous avez créé précédemment.

Remarque :
  • Les champs qualitatifs ont le même découpage dans les deux focus.
  • Par défaut, le rapport de comparaison inclut les mêmes champs que le rapport de référence. Si vous choisissez explicitement des champs à inclure dans le rapport de comparaison, ils sont ajoutés aux champs précédemment profilés.
  • Le rapport de comparaison utilise les mêmes champs cibles que dans le rapport de référence. Tous les champs cibles explicitement spécifiés sont ignorés.


Méthodologie de test/apprentissage

  • Méthodologie de test/apprentissage pour une modélisation solide
  • Diviser d'un fichier focus en sous-populations types
  • Appliquer d'un modèle ou d'une segmentation Decision Studio à une population différente


Méthodologie de test/apprentissage pour une modélisation solide

Lorsque vous créez un modèle, vous avez besoin de moyens pour déterminer sa qualité. Vous avez non seulement besoin de savoir la manière dont il indique les données historiques, mais vous avez aussi besoin de connaître sa solidité en tant un indicateur de comportement futur.

Le problème de débordement Pour un arbre de scoring ou de décision, % ou modèle de classification, vous pouvez utiliser une mesure de qualité telle que la mesure de Gini pour donner une indication sur la précision de la description d'un jeu de données du modèle : En général, plus le nombre est élevé, mieux c’est. Mais vous devez être prudent et éviter tout débordement, ce qui peut se produire si votre modèle est trop spécifique au jeu de données qui a servi à le créer.

En principe, vous pouvez créer un arbre de décision ou de scoring qui s'adapte parfaitement à un jeu de données spécifique. Par exemple, avec des ressources suffisantes, vous pouvez découper votre champ identifiant-client afin qu'il n'existe qu'un seul client dans chaque modalité, interpréter ce champ en tant que seule variable candidate et construire un arbre de décision avec autant de niveaux que nécessaire pour rendre tous les segments de feuilles homogènes selon l'objectif.

Un tel modèle si adapté a clairement un usage limité. Il est tout aussi compliqué qu'un jeu de données historiques originales et ne profite pas des tendances des données. Il ne fournit certainement aucune observation du comportement des clients. Mais un modèle trop simple ne peut pas profiter des tendances des données non plus.

Dans une certaine mesure, vous pouvez appliquer des connaissances commerciales pour décider quels sont les champs à inclure dans un modèle et même comment découper ces champs. Mais la tentation d'obtenir un peu plus à partir d'un modèle est toujours présente et donc il existe un risque de débordement. Pour cette raison, vous avez besoin d'un moyen de tester votre modèle.

Une solution : jeux de données d'apprentissage et de test Une façon d'éviter tout débordement consiste à partager votre focus [voir Diviser d'un fichier focus en sous-populations types] entre jeux de données d'apprentissage et de test, avec peut-être 67 % des données réservées à l'apprentissage et 33 % des données réservées au test. Vous pouvez construire un modèle à l'aide des données du jeu de données d'apprentissage et ensuite, lorsque vous êtes satisfait de sa puissance de description, appliquez-le au jeu de données de test [voir Appliquer d'un modèle ou d'une segmentation Decision Studio à une population différente] pour tester sa puissance de prédiction. Si votre mesure de la qualité baisse nettement lorsque vous appliquez le modèle (par exemple, si le coefficient de Gini diminue de plus de 2% environ), vous devriez soupçonner un débordement.

Si votre modèle n'est pas suffisamment solide, vous pouvez revenir à l'apprentissage et essayer d'améliorer le modèle (en changeant notamment les champs, les découpages, les mesures de qualité, etc.)

Toutefois, si vous répétez ce processus un trop grand nombre de fois, vous risquez un débordement à nouveau car vous utilisez actuellement le fichier focus pour influencer le format du modèle. La solution consiste à utiliser trois sous-populations types, avec peut-être 60% ??des données utilisées pour l'apprentissage, 30% pour le test et les 10% restants pour la validation. Vous pouvez maintenant vous permettre d'utiliser les commentaires des tests pour affiner le modèle. Après quelques itérations, vous pouvez appliquer le modèle à l'ensemble de validation [voir Appliquer d'un modèle ou d'une segmentation Decision Studio à une population différente] pour vérifier sa solidité.

Sujet parent : Méthodologie de test/apprentissage

Élagage automatique dans l'Arbre de décision

Dans l'Arbre de décision, vous pouvez utiliser l'élagage automatique [voir Élagage automatique d'une partie de l'arbre de décision] en conjonction avec les jeux de données de test et d'apprentissage pour créer des arbres de décision plus solides. Grâce à l'élagage complexité-coût, l'Arbre de décision identifie automatiquement l'arbre élagué qui donne les meilleurs résultats sur l'ensemble de test.


Diviser d'un fichier focus en sous-populations types

  1. Décidez du nombre de sous-populations n et leurs tailles relatives [image] (où [image]).
  2. Dans l'Aperçu du tableau, calculez un champ [voir Calcul d'un champ avec l'Aperçu du tableau] grâce à l'une des fonctions suivantes :
    • Si vous voulez deux sous-populations (n = 2), utilisez la fonction numericTestTrainSplit.
    • Si vous voulez trois sous-populations (n = 3), utilisez la fonction numericTestTrainValidateSplit.
    • Si vous souhaitez des sous-populations de tailles égales ( [image]), utilisez la fonction sampleEqualSize.
    • Sinon, utilisez la définition suivante :

      Par exemple, pour créer quatre sous-populations, contenant respectivement (environ) 40%, 30%, 20% et 10% de la population totale, vous pouvez utiliser la définition de champ suivante :

      a := rndUniform();

      cas a < 0,4 : 1; // 0,4 = 40%

      a < 0,7 : 2; // 0,7 = 40% + 30%

      a < 0,9 : 3; // 0,9 = 40% + 30% + 20%

      default : 4

    Le fichier focus est maintenant divisé selon les valeurs du champ que vous avez calculé. Selon l'expression que vous avez choisie, les valeurs sont 1, 2, ..., n, ou 0, 1, ..., n-1.

  3. Interprétez le champ comme qualitatif [voir Définition ou effacement d'une variable candidate, une interprétation clé, qualitative, géographique ou d'exportation].
  4. Renommez éventuellement [voir Renommage d'une catégorie] les nouvelles catégories de manière appropriée.

Pour utiliser une sous-population particulière, sélectionnez des enregistrements [voir Sélection d'enregistrements client] avec la valeur requise dans le champ.

Remarque :
  • Vous pouvez utiliser la fonction testTrainSplit comme alternative à la fonction numericTestTrainSplit.
  • Vous pouvez utiliser la fonction testTrainValidateSplit comme alternative à la fonction numericTestTrainValidateSplit.
  • Comme alternative à l'utilisation de la boîte de dialogue Sélectionner les valeurs pour passer d'une sous-population à une autre, vous pouvez utiliser l'Éditeur de découpage. Liez [voir Création et suppression de liens aux outils] vos outils d'analyse et de visualisation à la sortie de l'Éditeur de découpage ; passez d'une sous-population à l'autre en surlignant la modalité requise du champ que vous avez calculé.

Voir également

sampleExactNumber

sampleExactPercentage

sampleStratified

Sujet parent : Méthodologie de test/apprentissage


Appliquer d'un modèle ou d'une segmentation Decision Studio à une population différente

  • La façon la plus simple d'appliquer un modèle à une population différente est de modifier la sélection d'enregistrements en cours [voir Sélection d'enregistrements client].
  • Si vous désirez appliquer un arbre de décision, un scoring ou un modèle de mise en cluster à une population dans un fichier focus différent, enregistrez votre modèle [voir Enregistrement d'un arbre de décision, un scoring ou un modèle de mise en cluster], puis ouvrez l'autre fichier focus et appliquez le modèle enregistré [voir Application d'un modèle d'arbre de décision, de scoring ou de classification].
  • Si la nouvelle population est un groupe de segments sélectionnés [voir Sélection des segments dans une vue graphique] dans un autre outil Decision Studio, liez simplement [voir Création et suppression de liens aux outils] l'outil dans lequel vous élaborez votre modèle ou votre segment à la source de données appropriée.

L'outil met à jour son affichage pour vous présenter le modèle ou le segment appliqué à la nouvelle population.

Dans le cas de l'Arbre de décision, les statistiques de la population d'origine restent visibles. Dans l'affichage de l'arbre, l'Arbre de décision présente les statistiques d'origine entre crochets au-dessus des statistiques appliquées :

Dans les affichages textuels [voir Options d'affichage d'un arbre de décision], l'Arbre de décision indique les tableaux et les figures à la fois de la population d'origine et de la population appliquée.

Remarque :
  • Vous pouvez contrôler quels ensembles de chiffres l'Arbre de décision affiche en choisissant Afficher>Données>Original ou Afficher>Données>Appliqué.
  • Si vous n'avez pas défini d'objectif dans la nouvelle population, un arbre de décision appliqué présente seulement le nombre d'enregistrements pour chaque segment. Un tableau des augmentations [voir Options d'affichage d'un arbre de décision] de la nouvelle population est disponible pour les arbres binaires et uplift.
  • Si vous construisez un arbre de décision, puis changez ensuite le type de l'arbre, l'Arbre de décision affiche le même arbre auquel les statistiques sont superposées et éventuellement les graphiques du nouveau type d'arbre. L'Arbre de décision affiche les statistiques d'origine entre crochets, bien que le modèle soit appliqué à une population différente.

Voir également

Méthodologie de test/apprentissage pour une modélisation solide Enregistrement d'un modèle ou d'une segmentation Decision Studio au format QMML (XML)
Sujet parent : Méthodologie de test/apprentissage

Enregistrement d'un arbre de décision, un scoring ou un modèle de mise en cluster

  1. Après avoir construit un modèle dans l'Arbre de décision, le Scoring, ou la Classification, choisissez Fichier>Enregistrer sous ou cliquez sur [image] dans la barre d'outils.
  2. Choisissez un nom et un emplacement pour l'arbre de décision, le scoring ou le fichier de modèle de classification que vous avez créé dans le navigateur de fichier Portrait Miner [voir Ouverture ou enregistrement d'un fichier, d'une session ou d'une table de base de données].

Voir également

Création d'un modèle de classification

Construction d'un arbre de décision

Application d'un modèle d'arbre de décision, de scoring ou de classification

  1. Dans l'Arbre de décision, le Scoring ou la Classification, selon les cas, choisissez Fichier>Ouvrir ou cliquez sur [image] dans la barre d'outils.

    Un navigateur de fichier Portrait Miner [voir Ouverture ou enregistrement d'un fichier, d'une session ou d'une table de base de données] s'affiche.

  2. Ouvrez le fichier de modèle d'arbre de décision, de scoring ou de classification requis.
Remarque : Le focus en cours doit contenir des champs ayant les mêmes noms et types que ceux utilisés par le modèle.


Construction d'arbres de décision pour la segmentation et la modélisation prédictive

  • Construction d'un arbre de décision
  • Options d'affichage d'un arbre de décision
  • Contrôle de la construction d'un arbre de décision
  • Suppression des segments non désirés d'un arbre de décision


Construction d'un arbre de décision

  1. Interprétez éventuellement certains champs comme des variables candidates [voir Définition ou effacement d'une variable candidate, une interprétation clé, qualitative, géographique ou d'exportation].

    S'il existe des champs avec une interprétation de variable candidate, l'Arbre de décision ne considère ces champs que lorsqu'il crée des branches d'arbre de décision.

  2. Interprétez un champ comme l'objectif de modélisation .
  3. Pour les arbres uplift uniquement, interprétez un champ comme la partition de champ. (Vous pouvez uniquement construire un arbre uplift si le champ de partition contient 0 et 1 et aucune autre valeur, valeur null comprise)
  4. Choisissez Outils>Arbre de décision ou cliquez sur [image] dans la barre d'outils.
  5. Si nécessaire, changez le type d'arbre de décision (variable binaire, nominale, ou continue) avec le menu déroulant dans la barre d'outils.
    Si vous n'utilisez pas un champ de partition :
    • utilisez un arbre à variable nominale pour un objectif avec des valeurs qualitatives (ou un arbre à variable binaire pour un objectif binaire),
    • utilisez un arbre à variable continue pour un objectif par valeur.
    Si vous voulez utiliser un champ de partition pour effectuer une modélisation uplift, procédez comme suit :
    • Pour un objectif binaire, utilisez un arbre uplift binaire + pour modélisation additive ou utilisez un arbre uplift binaire x pour modélisation multiplicative.
    • utilisez un arbre à variable continue pour un objectif par valeur.
    • Vous ne pouvez pas utiliser un objectif qualitatif avec plus de deux valeurs.
  6. Si besoin, changez la valeur par défaut des options de création [voir Contrôle de la construction d'un arbre de décision].
  7. Choisissez Arbre>Construire jusqu'à la fin ou cliquez sur [image] dans la barre d'outils pour construire un arbre de décision :

Remarque :
  • pour ajouter un autre niveau à l'arbre en cours (non appliqué), choisissez Arbre>Construire le prochain niveau ou cliquez sur [image].
  • Dans chaque vue de l'arbre de décision [voir Options d'affichage d'un arbre de décision], deux volets à gauche affichent les champs inclus (variables candidates) et les champs exclus (autre champs dans le focus).

    Vous pouvez interpréter un champ comme une variable candidate en le déplaçant du volet inférieur vers le volet supérieur (et vice versa), avec les boutons présentant des flèches entre les volets. Si vous construisez un niveau de l'arbre à la fois, vous pouvez même utiliser un ensemble différent de variables candidates pour chaque niveau de l'arbre.

    Les champs utilisés dans l'arbre de décision apparaissent en caractères gras (sans savoir s'ils sont actuellement des variables candidates).

  • Lorsque vous commencez à construire un arbre de décision, l'Arbre de décision vous invite à interpréter tous les champs de chaîne qui n'ont pas d'interprétation nominale, pour qu'ils puissent être segmentés de manière adéquate. Vous pouvez soit choisir l'interprétation qualitative par défaut, soit utiliser une hiérarchie qualitative enregistrée. Si vous cliquez sur Annuler lorsque vous êtes invité à choisir une interprétation pour un champ de chaîne, l'Arbre de décision ignore cette variable candidate, ainsi que les champs de chaîne restants sans interprétation nominale.

Voir également

Contrôle de la construction d'un arbre de décision

Appliquer d'un modèle ou d'une segmentation Decision Studio à une population différente

Sujet parent : Construction d'arbres de décision pour la segmentation et la modélisation prédictive

Suppression d'un arbre de décision

Pour effacer un arbre de décision dans l'Arbre de décision, choisissez Arbre>Effacer ou cliquez sur [image] dans la barre d'outils.
Remarque : Si l'Arbre de décision affiche les modes Afficher les gains ou Afficher le graphique, il modifie le mode en Afficher l'arbre.


Options d'affichage d'un arbre de décision

Les vues suivantes de Arbre de décision sont disponibles :
Affichage | Description
Afficher l'arbre | Une représentation graphique d'un arbre de décision, avec l'ensemble de l'échantillon représenté au sommet et chaque niveau complet inférieur représentant une segmentation plus fine
Afficher le tableau | Une représentation tabulaire de l'arbre de décision, affichant des statistiques pour chaque segment numéroté et une expression de style FDL décrivant chaque segment Pour un arbre uplift, la taille totale est la somme des tailles des échantillons activés et des échantillons témoins, à l'exclusion de tout autre enregistrement.
Afficher la liste | Une présentation alternative de certaines des informations ci-dessus, sous forme de liste
Afficher les gains | Une table de gains cumulatifs pour les segments « terminaux » (niveau le plus bas, sans descendance) de l'arbre de décision, triés par ordre décroissant des taux de correspondance
Afficher le graphique | Un graphique Qini, disponible pour les arbres uplift uniquement

Pour passer à une visualisation différente, choisissez l'affichage soit depuis le menu Affichage, soit en cliquant sur le bouton correspondant dans la barre d'outils.

Voir également

Options affectant l'affichage de graphiques et d'arbres de décision

Orientation d'un affichage graphique à l'aide de la souris

Sujet parent : Construction d'arbres de décision pour la segmentation et la modélisation prédictive

Développement ou réduction d'une partie de l'arbre de décision

Pour se concentrer sur les parties intéressantes d'un arbre, vous pouvez réduire ou plier un sous-arbre.
  1. Surlignez les segments [voir Sélection des segments dans une vue graphique] que vous voulez plier ou déplier.
  2. Choisissez Segments>Plier ou Segments>Déplier.

    Lorsque vous pliez des segments, l'Arbre de décision masque les descendants des segments surlignés et les marquent avec un signe « + » pour indiquer que certains descendants sont masqués.

Sinon, vous pouvez cliquer avec le bouton droit de la souris sur un segment et choisir Plier ou Déplier dans le menu qui apparaît.

Remarque :
  • Le pliage n'est pas la même chose que l'élagage [voir Élagage manuel d'une partie de l'arbre de décision]. Lorsque vous pliez une partie d'un arbre de décision, seul l'affichage de l'arbre est modifié, alors que l'élagage affecte le modèle sous-jacent.
  • Si vous poursuivez la construction de l'arbre, l'Arbre de décision peut découper des segments masqués (mais les segments enfants seront également masqués).


Contrôle de la construction d'un arbre de décision

Vous pouvez définir différentes contraintes [voir Affichage ou modification des contraintes de la construction de l'arbre] qui déterminent la façon dont l'Arbre de décision construit un arbre de décision. Vous pouvez également exercer un contrôle manuel en verrouillant des segments [voir Verrouillage ou déverrouillage des segments dans un arbre de décision] dans un arbre ou en élaguant [voir Suppression des segments non désirés d'un arbre de décision] un arbre.

Voir également

Construction d'un arbre de décision

Suppression des segments non désirés d'un arbre de décision

Sujet parent : Construction d'arbres de décision pour la segmentation et la modélisation prédictive

Affichage ou modification des contraintes de la construction de l'arbre

Choisissez Arbre>Contraintes.

Les paramètres suivants sont disponibles dans la boîte de dialogueArbre de contraintes :

Paramètre | Applicable à | Description
Nombre maximal de niveaux dans l'arbre | Tous les types d'arbre | Le plus grand nombre de générations dans toute branche de l'arbre (y compris le segment « racine ») Cela s'applique uniquement pendant la phase « construire jusqu'à la fin. » Arbre de décision cesse de construire l'arbre une fois que ce nombre de niveaux est généré. Si vous choisissez Arbre>Construire le prochain niveau ou cliquez sur [image] , l'Arbre de décision ignore ce paramètre.
I-gain minimal pour la segmentation | Arbres à variables binaire et nominale | La plus petite valeur acceptable de l'information Gain pour une segmentation (une valeur entre 0 et 1)
R2 minimal pour la segmentation | Arbres à variable continue | La plus petite valeur acceptable de la mesure [image] pour une segmentation (une valeur entre 0 et 1)
Significativité uplift minimale pour la segmentation | Arbres Uplift | La plus petite valeur acceptable de la mesure de la significativité uplift pour une segmentation (une valeur entre 0 et 1)
Seuil pour segmentation à valeurs multiples | Arbres à variable nominale et arbres uplift | Le nombre de catégories d'une variable candidate qualitative, hormis celles qui sont null [voir La valeur null] et non classées, au-delà duquel l'Arbre de décision ne considère plus toutes les permutations possibles de segmentation Pour une variable candidate avec plus de catégories, l'Arbre de décision ne considère que les segmentations impliquant une seule catégorie d'un côté et le reste de l'autre.
Taille du segment minimal | Tous les types d'arbres sauf les arbres uplift | Le plus petit nombre d'enregistrements dans un segment « terminal » (niveau le plus bas, sans descendance) l'Arbre de décision ne tient pas compte des segmentations qui se traduiraient par un ou plusieurs segments avec moins d'enregistrements. Si vous cochez la case Fixer le seuil minimal en pourcentage, ce nombre est traité comme un pourcentage du nombre d'enregistrements dans l'échantillon que vous utilisez pour créer l'arbre.
Taille du segment minimal dans l'échantillon traité, taille du segment minimal dans l'échantillon témoin | Arbres Uplift | Le plus petit nombre d'enregistrements, dans les échantillons témoins et les échantillons activés, dans un segment « terminal » (niveau le plus bas, sans descendance) L'Arbre de décision ignore les segmentations qui se traduiraient par un ou plusieurs segments avec moins d'enregistrements dans l'échantillon approprié. L'option Fixer le seuil minimal en pourcentage interprète les valeurs comme des pourcentages de la population totale, et non pas comme des pourcentages individuels d'échantillons témoins et d'échantillons activés.

En ce qui concerne les arbres qualitatifs, il existe deux cases à cocher supplémentaires, pour forcer l'Arbre de décision à traiter les modalités null et non classées dans l'objectif comme des catégories ordinaires.

Verrouillage ou déverrouillage des segments dans un arbre de décision

Avant de continuer à construire un arbre de décision partiellement construit, vous pouvez exclure certains segments, en les verrouillant.
  1. Surlignez les segments [voir Sélection des segments dans une vue graphique] que vous voulez verrouiller ou déverrouillez.
  2. Choisissez Segments>Verrouiller ou Segments>Déverrouiller.

    Lorsque vous verrouillez des segments, l'Arbre de décision marque les segments terminaux sous les segments surlignés avec un symbole de cadenas [image].

Sinon, vous pouvez cliquer avec le bouton droit de la souris sur un segment et choisir Verrouiller ou Déverrouiller dans le menu qui apparaît.


Suppression des segments non désirés d'un arbre de décision

Vous pouvez supprimer les segments non désirés dans un arbre grâce à l'élagage.
Remarque : L'élagage n'est pas la même chose que le pliage [voir Développement ou réduction d'une partie de l'arbre de décision]. Lorsque vous élaguez une partie de l'arbre de décision, l'arbre de décision sous-jacent est modifié, alors que le pliage affecte seulement l'affichage de l'arbre.

Voir également

Verrouillage ou déverrouillage des segments dans un arbre de décision

Suppression d'un arbre de décision

Sujet parent : Construction d'arbres de décision pour la segmentation et la modélisation prédictive

Élagage manuel d'une partie de l'arbre de décision

Vous pouvez supprimer de manière sélective les segments sans intérêt d'un arbre de décision.
  1. Surlignez les segments [voir Sélection des segments dans une vue graphique] dont vous voulez supprimer les descendants.
  2. Choisissez Segments>Élaguer.

    L'Arbre de décision supprime les descendants des segments surlignés et marque les segments surlignés avec un symbole de cadenas pour indiquer qu'ils sont verrouillés.

Sinon, vous pouvez cliquer avec le bouton droit de la souris et choisir Élaguer dans le menu qui apparaît.

Élagage automatique d'une partie de l'arbre de décision

Vous pouvez supprimer automatiquement les segments de sur-apprentissage d'un arbre de décision après leur création, avec une méthodologie de test/apprentissage [voir Méthodologie de test/apprentissage pour une modélisation solide] et avec l'option Auto-élagage [voir Élagage automatique dans l'Arbre de décision].
  1. Concevoir votre arbre de décision [voir Construction d'un arbre de décision] sur l'échantillon d'apprentissage.
  2. Appliquer cet arbre de décision [voir Appliquer d'un modèle ou d'une segmentation Decision Studio à une population différente] à l'échantillon de test.
  3. Choisissez Arbre>Auto-élagage ou cliquez sur [image].

L'Arbre de décision supprime automatiquement les segments qui n'augmentent pas les performances de l'arbre de décision sur l'échantillon de test.


Construction de scorings pour la segmentation et la modélisation prédictive

  • À propos de l'Assistant Scoring
  • Construction d'un scoring à l'aide de l'Assistant Scoring
  • Construction d'un scoring à l'aide du Scoring
  • Affinage d'un scoring par ajout ou suppression de champs
  • Options d'affichage d'un scoring
  • Contrôle de la construction d'un scoring


À propos de l'Assistant Scoring

L'Assistant Scoring automatise la modélisation de scoring par la méthodologie des bonnes pratiques : réalisation de découpages optimisés, puis réduction de variables, et finalement construction d'une séquence de modèles sur les données de test et d'apprentissage pour établir la meilleure « taille de modèle ». La méthodologie de modélisation se compose des étapes suivantes.

Méthodologie de test/apprentissage Les données source sont en partie utilisées pour l'apprentissage, et en partie pour le test : cette séparation peut être générée de façon aléatoire avec un champ d'indicateur binaire désigné.

Découpage optimisé Les données d'apprentissage servent à sélectionner un découpage pour chaque variable candidate qui maximise ses prédictions invariables par rapport à l'objectif.

Pour les champs non qualitatifs, l'assistant de découpage optimisé [voir Optimisation du découpage d'un champ] sert de façon itérative à choisir le meilleur découpage. Le nombre de modalités est augmenté jusqu'à ce que le nombre de « turning points » (points de retournement) dans la représentation de la valeur d'objectif moyenne par modalité dépasse un seuil configurable (un « turning point » étant un changement d'orientation dans la pente du graphique). Intuitivement, ceci garantit que le profil de la valeur d'objectif moyenne comme fonction de chaque variable candidate est relativement « lisse », sans de trop nombreuses montées et descentes.

Pour les champs qualitatifs, les catégories dans lesquelles la valeur d'objectif moyenne n'est pas significativement différente de la moyenne générale sont fusionnées ensemble. Une différence de moyenne standard d'un test de moyenne [voir significance] est utilisée, avec une correction de Bonferroni appliquée en se basant sur le nombre total de catégories, apparaissant dans le champ. En conséquence, toutes les catégories avec le niveau de confiance [image] sont fusionnées (avec [image] un seuil de significativité configurable).

Durant cette phase, les champs ayant une corrélation étrangement élevée par rapport à l'objectif sont exclus d'une analyse plus approfondie (avec un message d'avertissement). Un avertissement est également émis pour les champs dans lesquels toute modalité individuelle contient un petit nombre d'enregistrements. Les deux seuils sont configurables.

Réduction de variables La phase de réduction de variables réduit la réserve de variables candidates (prédicteurs indépendants) par rapport à celles qui étaient marquées initialement à un ensemble plus petit de n, de façon à diminuer le temps de traitement alloué de la phase finale de « right-sizing » (redimensionnement).

Le processus partitionne des variables candidates en groupes jusqu'à des champs 2n et élabore un scoring (à l'aide des données d'apprentissage) sur chaque groupe, rejetant les champs les moins significatifs par exclusion séquentielle [voir Affinage d'un scoring par ajout ou suppression de champs] jusqu'à ce qu'il ne reste plus que les meilleurs n champs du groupe. En répétant cette procédure, les n meilleurs de tous les champs peuvent être identifiés.

Redimensionnement La phase de redimensionnement choisit le scoring qui équilibre le mieux la complexité (nombre de prédicteurs) par rapport à la perspective de généralisation (telle que mesurée dans les résultats de l'ensemble des tests). Les données d'apprentissage servent à construire une séquence de n scorings dont le premier contient toutes les n variables candidates, et chaque modèle suivant exclut le plus mauvais prédicteur. Le résultat de chaque modèle est alors imposé dans les données de test, avec la meilleure taille de modèle choisie à l'aide d'un critère configurable. Pour l'étape finale, les poids des modèles sélectionnés sont redéfinis en se basant sur toutes les données (par ex. à la fois le test et l'apprentissage) pour en améliorer la précision. Si désiré, tous les modèles intermédiaires peuvent être enregistrés avec le modèle final.

Résultats Diverses sorties sont (facultativement) générées, y compris:

  • Un rapport au format HTML récapitulant la façon dont la méthodologie a été appliquée, comprenant les paramètres d'entrée et les liens au journal d'exécution détaillé. Il inclut une table des données de performances pouvant facilement être établie dans Excel.
  • Le modèle final recommandé (aux formats .qssc [voir Enregistrement d'un arbre de décision, un scoring ou un modèle de mise en cluster] et QMML [voir Enregistrement d'un modèle ou d'une segmentation Decision Studio au format QMML (XML)]).
  • Une synthèse de modèle [voir Création d'une synthèse de modèle] du modèle recommandé.
  • Le jeu de données final comprenant les variables candidates sélectionnées, les découpages optimisés et les prédictions de modèle. Les jeux de données intermédiaires peuvent aussi être enregistrés, le cas échéant, avec les métadonnées, générées par la méthodologie jusqu'à ce point, qu'ils contiennent. Celles-ci sont souvent utiles pour forer et explorer les décision prises durant le processus.

Voir également

Construction d'un scoring à l'aide de l'Assistant Scoring

Sujet parent : Construction de scorings pour la segmentation et la modélisation prédictive


Construction d'un scoring à l'aide de l'Assistant Scoring

Enregistrez votre fichier focus de modélisation, avec le champ de l'objectif, les variables candidates et les variables qualitatives marquées. Cette préparation peut être automatisée en important des métadonnées de focus [voir Copie de métadonnées de focus d'un focus à l'autre] dans le fichier focus de modélisation.

Dans Portrait Miner, faites un clic droit sur un fichier focus et sélectionnez Prévoir>Assistant Scoring.

Dans la boîte de dialogue Assistant Scoring, vous pouvez choisir soit d'optimiser les découpages, soit de sélectionner un ensemble réduit de variables pour la phase de construction du modèle final, soit encore de construire un modèle de scoring de taille adaptée. Vous pouvez également configurer les détails avancés qui influencent l'algorithme de construction du modèle.

Remarque :
  • Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsscorecardwizard de Portrait Miner.

Voir également

À propos de l'Assistant Scoring

À propos des assistants Portrait Miner

Construction d'un scoring à l'aide du Scoring

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Sujet parent : Construction de scorings pour la segmentation et la modélisation prédictive


Construction d'un scoring à l'aide du Scoring

  1. Interprétez éventuellement certains champs comme des variables candidates [voir Définition ou effacement d'une variable candidate, une interprétation clé, qualitative, géographique ou d'exportation].

    Le Scoring ne calcule que les statistiques de scoring des champs de variables candidates (à moins qu'il n'y en ait aucun, auquel cas, il calcule les statistiques pour tous les champs).

  2. Interprétez un champ comme l'objectif de modélisation .
  3. Choisissez Outils>Scoring ou cliquez sur [image] dans la barre d'outils.

    Le Scoring s'ouvre.

  4. Si vous utilisez un objectif binaire (0/1), choisissez le type de modèle approprié dans le menu Scoring>Type de modèle : risque, réponse, attrition, satisfaction ou insatisfaction.

    Pour un objectif continu, seul le type de modèle de valeur est disponible.

  5. Encore une fois si vous utilisez un objectif binaire, vous pouvez choisir Scoring>Inverser la valeur objectif, pour changer le sens du champ d'objectif 0 / 1.

    Par défaut, 1 dans l'objectif indique une défaillance, un répondeur, une attrition, un client satisfait ou un client insatisfait, selon le type de modèle choisi.

  6. Si besoin, changez la valeur par défaut des options de création [voir Contrôle de la construction d'un scoring].
  7. Choisissez Scoring>Créer ou cliquez sur [image] dans la barre d'outils pour créer un scoring.
Remarque :
  • Lorsque vous ouvrez Scoring, il vous invite à interpréter tous les champs de chaîne qui n'ont pas d’interprétation qualitative, de sorte qu'ils puissent être découpés correctement. Vous pouvez soit choisir l'interprétation qualitative par défaut, soit utiliser une hiérarchie qualitative enregistrée. Si vous cliquez sur Annuler lorsque vous êtes invité à choisir l’interprétation d'un champ de chaîne, le Scoring ignore cette variable candidat, ainsi que les champs de chaîne sans interprétation qualitative.
  • Votre choix du type de modèle affecte l'étiquetage des valeurs, graphiques, etc. (mais seulement après que vous avez reconstruit votre scoring). Il existe aussi une distinction plus fondamentale entre les modèles de risque et les autres types de modèle d'objectif binaire : lors de l'application d'un modèle de risque, généralement, vous acceptez des clients dans les segments avec un taux de défaut prévu faible, mais, lors de l'application d'un modèle de réponse, d'attrition, de satisfaction ou d'insatisfaction, vous ciblez généralement les clients dans des segments avec un taux de réponse d'attrition/de satisfaction/d'insatisfaction prévu élevé.
  • Si votre fichier focus contient un champ qui représente un poids enregistré, sélectionnez ce champ dans le Scoring et choisissez Champs>Définir le poids, avant de construire un scoring. Pour les pondérations d'entier positif [image], [image], ..., le scoring est le même que celui que vous obtiendriez à partir d'un jeu de données plus grand avec les [image] occurrences du premier enregistrement, les [image] du deuxième, etc. L'interprétation de pondération est locale à l'instance du Scoring.

Voir également

Construction d'un scoring à l'aide de l'Assistant Scoring

Contrôle de la construction d'un scoring

Appliquer d'un modèle ou d'une segmentation Decision Studio à une population différente

Sujet parent : Construction de scorings pour la segmentation et la modélisation prédictive


Affinage d'un scoring par ajout ou suppression de champs

Dans Afficher le champ [voir Options d'affichage d'un scoring] du Scoring, le volet supérieur présente les champs qui sont (qui vont) être inclus dans le scoring, alors que le volet inférieur présente les variables candidates restantes. Un scoring impliquant peu de champs est potentiellement plus facile/rapide à déployer et peut-être plus solide [voir Méthodologie de test/apprentissage pour une modélisation solide], bien que ce puisse être un modèle plus précis.

Avec les flèches situées entre les volets, vous pouvez inclure ou exclure des champs manuellement (peut-être sur une base de Gini, Cramer's V ou gain d'information). Vous pouvez aussi automatiser ce processus de sélection de champs, en prenant potentiellement en compte les interactions entre champs.

  1. Utilisez Champs>Inclure automatiquement (ou Champs>Exclure automatiquement) ou cliquez sur [image] (ou [image]) dans la barre d'outils pour inclure (ou exclure) des champs.

    La boîte de dialogue Options d'inclusion automatique (ou Options d'exclusion automatique) s'affiche.

  2. Choisissez parmi les critères de sélection suivants :
    • Adaptation linéaire par étape
    • Mesure de la qualité par étape

    L'algorithme tient compte de la qualité des scorings temporaires obtenus en incluant (ou excluant) chaque champ tout à tour. Ayant inclus (ou exclus) le seul champ qui donne des résultats dans le meilleur scoring temporaire, l'algorithme recommence, jusqu'à ce qu'il ait inclus (ou exclu) le nombre de champs requis.

    La qualité du scoring temporaire est déterminée par la mesure de qualité actuellement sélectionnée [voir Modification de la mesure de la qualité utilisée pour construire un scoring], ou la régression linéaire si vous choisissez l'option Adaptation linéaire. Le scoring temporaire, toutefois, est toujours construit à l'aide d'une mesure de qualité de régression linéaire.

  3. Spécifiez le nombre de champs à inclure ou exclure à la fois.
  4. Cliquez sur OK, pour définir les options auto-inclure ou -exclure.
Remarque : Vous pouvez construire un bon premier scoring en excluant d'abord tous les champs et ensuite, en auto-incluant le nombre requis de champs à l'aide d'une adaptation linéaire par étape.
Sujet parent : Construction de scorings pour la segmentation et la modélisation prédictive


Options d'affichage d'un scoring

Les visualisations Scoring suivantes sont disponibles :

Affichage | Description
Afficher le champ | Une visualisation en deux volets des variables candidates et des statistiques associées, avec les champs inclus dans le scoring dans le volet supérieur et ceux qui sont exclus dans le volet inférieur
Affichage par onglets | Un volet à onglets de visualisation de scoring, montrant les poids (scores de modalité) et les statistiques champ par champ
affichage Tableau de bord | Une vue plus simple du scoring, montrant les poids (scores de modalités) de tous les champs en une seule vue
Afficher le graphique | Un des cinq graphiques [voir Graphiques de Scoring], le long des volets montrant les listes des champs inclus ou exclus
Matrice de corrélation | Une matrice de corrélation des variables candidates

Au départ, Scoring affiche une vue du champ (et d'autres vues sont disponibles jusqu'à ce que vous ayez construit ou ouvert un scoring). Pour passer à une visualisation différente, choisissez l'affichage soit depuis le menu Affichage, soit en cliquant sur le bouton correspondant dans la barre d'outils.

Sujet parent : Construction de scorings pour la segmentation et la modélisation prédictive

Graphiques de Scoring

Les graphiques suivants sont disponibles dans Scoring :

Graphique | Description
Gini | La courbe de Gini pour le modèle de scoring
Histogramme | Représentations superposées de clients correspondant à l'objectif et de clients ne correspondant pas à l'objectif par rapport au score assigné
Histogramme cumulatif | Une version cumulative de ce qui précède
Courbe de stratégie | Une courbe de stratégie, pour vous aider à saisir un score de seuil adéquat
Poids | Une représentation graphique du scoring, avec un graphique des poids (scores de découpage) pour chaque champ du scoring

Vous pouvez choisir le graphique à afficher dans le menu déroulant en haut à droite du graphique.

Voir également

Options affectant l'affichage de graphiques et d'arbres de décision

Orientation d'un affichage graphique à l'aide de la souris


Contrôle de la construction d'un scoring

Vous pouvez contrôler la façon dont un scoring est construit en utilisant une mesure de qualité différente [voir Modification de la mesure de la qualité utilisée pour construire un scoring], solveur [voir Modification du solveur utilisé pour construire un scoring] ou format [voir Modification du format d'un scoring].
Sujet parent : Construction de scorings pour la segmentation et la modélisation prédictive

Modification de la mesure de la qualité utilisée pour construire un scoring

La qualité d'un scoring est évaluée d'après sa précision. Lors de la construction d'un scoring, le Scoring tente de maximiser la qualité du scoring en fonction de l'une des trois mesures de la qualité.
Dans le menu Scoring>Mesure de la qualité, choisissez soit :
  • Régression linéaire
  • Régression logistique
  • Régression probit
Remarque : Pour un objectif continu (non binaire), la mesure de la qualité disponible est la régression linéaire.

Modification du solveur utilisé pour construire un scoring

Compte tenu d'une mesure de la qualité, le Scoring utilise l'un des cinq solveurs pour tenter de maximiser la qualité du scoring. Vous pouvez choisir quel solveur est utilisé par le Scoring et contrôler certains aspects du comportement du solveur.

  1. Sélectionnez Scoring>Solveur.

    La boîte de dialogue Solveur de scoring s'affiche.

  2. Dans le menu Méthode, choisissez soit :
    • Simplex
    • Powell
    • Quasi-Newton
    • Conjugate Gradient
    • Levenberg Marquardt
Remarque : En général, il n'est pas nécessaire de changer la mesure de la qualité ou l'un des paramètres dans la boîte de dialogue Solveur de scoring. Lorsque vous choisissez la mesure de la qualité [voir Modification de la mesure de la qualité utilisée pour construire un scoring], le Scoring choisit le plus puissant solveur disponible pour cette mesure.

Modification du format d'un scoring

Lors de la construction d'un scoring, le Scoring traite chaque modalité de chaque champ inclus comme une variable indépendante ou il attribue des poids dans chaque champ, puis transforme ces poids en fonction de l'importance relative des champs du modèle.
  1. Sélectionnez Scoring>Format.

    La boîte de dialogue Formulaire de scoring s'affiche.

  2. Dans la fenêtre Format, choisissez « un poids par modalité » ou « un poids par champ ».
  3. Si vous avez choisi le plus simple, « un poids par champ », précisez la façon dont le Scoring transforme les poids dans chaque champ.


Construction de règles d'association et de séquençage

  • A propos de l'Assistant de Règle d'Association
  • Construction des règles d'association et de séquençage à l'aide de l'assistant de règle d'association


A propos de l'Assistant de Règle d'Association

L'Assistant de règle d'association automatise la découverte des règles d'association et de séquençage. Il est généralement utilisé pour explorer les données client détaillées, un panier ou des données d'événement pour les applications :

Analyse du panier client identifie les combinaisons de produits qui apparaissent fréquemment (ou n'apparaissent pas) dans une transaction d'achat unique (panier d'articles).

Meilleur produit suivant détermine la séquence la plus commune dans laquelle les produits ou services sont achetés, par exemple, les clients bancaires sont plus enclins à ouvrir un compte de placement/ boursier après l'ouverture d'un compte épargne à intérêts élevés.

Analyse de l'impact commercial identifie les modes de communication commerciale les plus probables avant un prochain achat

Préparation des données L'Assistant de règle d'association s'exécute directement sur des données de transaction ou d'événement stockées dans un jeu de données de fichier focus, profitant de l'accès aux données très performant de Portrait Miner.
  • Pour l'analyse du panier client, vous devez utiliser un jeu de données sur les articles contenant un enregistrement par article. L'ensemble des données doit contenir un champ identifiant du panier regroupant les articles dans un même panier, ainsi qu'un champ identifiant produit (compartimenté et qualitatif) indiquant le nom du produit ou le code de chaque article. L'ensemble des données doit être trié par le champ clé d'identifiant de panier.
  • Pour l'analyse du produit suivant, vous devez choisir un jeu de données avec un seul enregistrement par produit ou service. Le jeu des données doit contenir un identifiant de panier, souvent l'identifiant client, regroupant les produits, ainsi que l'identifiant du produit (découpé et qualitatif) et un horodatage produit (entier ou date) indiquant l'ordre dans lequel les produits ont été acquis. L'ensemble des données doit être trié par le champ clé d'identifiant de panier.

Paramètres de l'algorithme L'Assistant de règle d'association est basé sur l'algorithme standard industriel Apriori et comprend un large éventail de fonctionnalités pour contrôler la découverte de la règle. Pour plus d'informations sur l'algorithme APriori, reportez-vous à la documentation correspondante sur le support de publication (DVD/zip) de Portrait miner. Cette documentation se trouve à l'emplacement suivant :\server\Components\ext\qsruleminer\docs\apriori_docs.

Vous pouvez restreindre la règle de découverte pour les produits d'intérêt particulier et contrôler plusieurs paramètres définissant ce qu'est une règle intéressante (prise en charge, confiance, complexité de la règle, mesures de sélection de règle étendue). Notez que ces paramètres peuvent avoir un impact sur le temps d'exécution : en particulier, en réduisant la valeur minimale de la prise en charge augmentera le temps d'exécution sauf si une complexité maximale de règle (nombre d'antécédents) est également spécifiée.

Terminologie L'Assistant de règle d'association utilise une série de termes probablement inconnus, à savoir :

Règle En général, une règle affirme que si un ensemble de conditions sont remplies (le côté gauche ou l'antécédent de la règle), alors une autre condition se produit (le côté droit ou le résultat de la règle). Dans les règles d'association et de séquençage, les conditions de la règle correspondent à la présence d'articles particuliers dans le panier. Exemple de règle simple : si un panier contient du pain, alors il contiendra aussi de la confiture.

Antécédent Le côté gauche d'une règle, c'est à dire l'ensemble des articles qui doivent apparaître dans le panier pour que la règle soit pertinente.

Résultat Le côté droit d'une règle, c'est à dire l'ensemble des articles que la règle prévoit seront présents lorsque le côté gauche (antécédents) est satisfait.

Prise en charge La prise en charge (absolue) d'un ensemble d'articles est le nombre de paniers contenant tous les articles de l'ensemble. La prise en charge relative est la même nombre exprimé en pourcentage que le nombre total de paniers.

Prise en charge d'une règle La prise en charge d'une règle est la prise en charge de l'antécédent de la règle, c'est à dire la proportion des paniers pour lesquels le côté gauche de la règle s'applique. Cela mesure le nombre de fois où la règle est pertinente.

Confiance de la règle La confiance d'une règle est la prise en charge de l'ensemble des éléments qui apparaissent dans la règle (à gauche ou à droite), divisée par la prise en charge de l'antécédent de la règle. Elle mesure la probabilité de réalisation du résultat de la règle (à droite), étant donné que l'antécédent de la règle est satisfait, c'est à dire la probabilité de correction de la règle.

Différence absolue de la confiance par rapport à la précédente La différence entre les mesures de confiance antérieures et postérieures (avec et sans les éléments précédents). Elle mesure la probabilité (plus ou moins) de résultat de la règle lorsque le côté gauche de la règle est vrai. Par exemple, la règle « si pain, alors confiture » n'est pas très intéressante si sa confiance est semblable à la règle « si (article), alors confiture ».

Valeur Lift Le rapport entre les mesures de confiance antérieures et postérieures (avec et sans les éléments précédents).

Résultats Diverses sorties sont (facultativement) générées, y compris:
  • Un rapport de modèle interactif HTML résumant les règles créées, leurs indicateurs et la possibilité de filtrer selon des règles intéressantes.
  • Un nouveau jeu de données créant un jeu de données agrégées (un seul enregistrement par identifiant de panier) indiquant si chaque règle sélectionnée est satisfaite pour ce groupe d'enregistrements.
  • Les règles comme le code déployable au format TML.
  • Règles d'une exportation facultative au format PMML (Predictive Model Markup Language) à l'aide de l'onglet Déployer, tel qu'il est indiqué ci-dessous.
Sujet parent : Construction de règles d'association et de séquençage


Construction des règles d'association et de séquençage à l'aide de l'assistant de règle d'association

Enregistrez votre fichier focus de modélisation, avec le champ identifiant du produit compartimenté et qualitatif. Cette préparation peut être automatisée en important des métadonnées de focus [voir Copie de métadonnées de focus d'un focus à l'autre] dans le fichier focus de modélisation.

Dans Portrait Miner, faites un clic droit sur un fichier focus et sélectionnez Prévoir>Assistant de règle d'association.

Dans la boîte de dialogue Assistant de règle d'association, vous pouvez choisir le type de règles d'association à construire, sélectionner les paramètres pour identifier les règles intéressantes et l'identifiant de panier (par défaut, le premier champ), l'identifiant de produit (par défaut, le champ de l'objectif) et le champ d'horodatage du produit (par défaut, le champ de partition) à analyser. Vous pouvez restreindre les règles créées et toujours inclure un ensemble spécifique de produits.

Remarque :
  • Cette interface utilisateur permet d'accéder à la plupart des fonctionnalités fournies par la commande intégrée qsruleminer de Portrait Miner.

Voir également

A propos de l'Assistant de Règle d'Association

À propos des assistants Portrait Miner

Sujet parent : Construction de règles d'association et de séquençage


Construction de modèles Naive Bayes pour segmentation et modélisation prédictive

  • A propos de l'assistant Naive Bayes
  • Construction d'un modèle de propension à l'aide de l'assistant Naive Bayes


A propos de l'assistant Naive Bayes

L'assistant Naive Bayes construit un modèle de propension à l'aide théorème de Bayes, combiné à une présomption (« naïve ») d'indépendance conditionnelle, pour prévoir la valeur d'une catégorie de champ de l'objectif, à partir de preuves fournies par une ou plusieurs variables candidates. Un modèle Naive Bayes définit essentiellement un ensemble de tableaux croisés : pour chaque variable candidate, il existe un tableau croisé qui contient la fréquence des modalités d'analyse selon les catégories d'objectif.

Un intervalle de zéro nécessite une attention particulière et le modèle Naive Bayes intègre un paramètre qui spécifie une probabilité par défaut (habituellement très faible) à utiliser lorsque l'intervalle est de zéro.

L'assistant Naive Bayes nécessite que chaque champ (que ce soit la variable candidat ou l'objectif) soit découpé de sorte que, pour chaque champ, seul un petit nombre limité de valeurs sont prises en compte par le modèle. Le champ de l'objectif est traité comme qualitatif, tandis que les variables candidates tirent leur découpage de l'ensemble des données de modélisation. Les valeurs sont traitées comme des catégories distinctes.

Résultats Diverses sorties sont (facultativement) générées, y compris:

  • Un rapport de vérification HTML résumant la manière dont la propension du modèle Naive Bayes a été appliquée, y compris les paramètres d'entrée et la comparaison avec les réponses historiques.
  • Le modèle final recommandé dans les formats FDL [voir À propos du langage FDL], QMML [voir Enregistrement d'un modèle ou d'une segmentation Decision Studio au format QMML (XML)] et PMML.
  • L'ensemble final incluant la prévision du modèle.

Voir également

Construction d'un modèle de propension à l'aide de l'assistant Naive Bayes
Sujet parent : Construction de modèles Naive Bayes pour segmentation et modélisation prédictive


Construction d'un modèle de propension à l'aide de l'assistant Naive Bayes

Enregistrez votre fichier focus de modélisation, avec le champ de l'objectif, les variables candidates et les variables qualitatives marquées. Cette préparation peut être automatisée en important des métadonnées de focus [voir Copie de métadonnées de focus d'un focus à l'autre] dans le fichier focus de modélisation.

Dans Portrait Miner, faites un clic droit sur un fichier focus et sélectionnez Prévoir>Assistant Naive Bayes.

Dans la boîte de dialogue Assistant Naive Bayes, vous pouvez choisir quels champ d'objectif, variables candidates et catégorie analyser, le seuil Naive Bayes à utiliser et les détails des résultats de modélisation créés.

Voir également

A propos de l'assistant Naive Bayes

À propos des assistants Portrait Miner

Sujet parent : Construction de modèles Naive Bayes pour segmentation et modélisation prédictive


Construction de modèles de classification pour segmentation et modélisation prédictive

  • À propos des modèles de classification dans Portrait Miner
  • Création d'un modèle de classification
  • Options d'affichage d'un modèle de classification
  • Contrôle de la création d'un modèle de classification


À propos des modèles de classification dans Portrait Miner

La classification est une technique de modélisation indirecte (sans objectif), utilisée pour segmenter une population en groupes d’enregistrements similaires selon les valeurs observées d'un ou de plusieurs champs d'analyse.
  • Chaque groupe dans un modèle de classification a un centre que vous pouvez considérer comme un enregistrement contenant une valeur pour chaque variable candidat (sauf qu'un champ [voir Interprétations des champs] qualitatif est traité comme s'il s'agissait d'un ensemble de champs indicateurs [voir Champs qualitatifs de classification]).
  • Chaque enregistrement dans le fichier focus appartient au groupe dont le centre est le plus proche de l’enregistrement, selon une distance métrique normalisée de la somme des carrés [voir Mesure de la taille et de la séparation des groupes].

Voir également

Contrôle de la création d'un modèle de classification

Création d'un modèle de classification

Sujet parent : Construction de modèles de classification pour segmentation et modélisation prédictive

Mesure de la taille et de la séparation des groupes

L'idée de classification repose sur une certaine mesure de la distance ou la proximité entre les enregistrements.

Prenez deux enregistrements [image] et [image] (où [image] est la valeur de champ j dans l'enregistrement i). Normalisez d’abord les valeurs de telle sorte que chaque champ ait une moyenne 0 et un écart-type 1 (pour le jeu de données sur lequel le modèle doit être créé) :

où [image] et [image] sont respectivement la moyenne et l'écart-type de champ j. Définissez maintenant la distance entre les enregistrements [image] et [image] en tant que distance euclidienne ordinaire de la somme des carrés entre les enregistrements normalisés [image] et [image] :

Notez qu'il n'y a pas de racine carrée.

Selon cette mesure de distance, il est possible de quantifier la taille d'un groupe (à l’aide d’une des deux mesures, le rayon et l’ESS) et si un groupe est bien distinct des autres groupes. Par extension, vous pouvez aussi quantifier la qualité d'un modèle de classification.
  • Le rayon d'un groupe est la distance maximale entre un enregistrement dans le groupe et le centre du groupe. Un groupe idéal n'a pas de rayon.
  • L'ESS d’un groupe est la somme des distances de tous les enregistrements dans le groupe à partir du centre du groupe. Un groupe idéal n'a pas d'ESS.

    Pour un modèle de classification, la somme totale des carrés est la somme des valeurs des carrés pour chacun des groupes. Un modèle idéal a une somme totale des carrés égale à zéro.

  • La séparation pour un enregistrement est [image], où [image] est la distance entre l'enregistrement et le centre de classe le plus près et [image] est la distance entre l'enregistrement et le centre le deuxième plus près. Les valeurs classées entre 0 et 1 ; une valeur plus élevée indique que l'enregistrement a un attachement plus fort à sa classe assignée.

    La séparation d’un groupe est la séparation minimale d’un enregistrement du groupe. Un groupe bien séparé a une valeur proche de 1.

    La séparation d’un modèle de classification est la séparation minimale pour un enregistrement dans l’ensemble des données. Le bon modèle a une valeur proche de 1.

Remarque :
  • Pour calculer la mesure de la distance, un champ qualitatif doit être considéré comme un ensemble de champs indicateur [voir Champs qualitatifs de classification].
  • Lorsque vous appliquez un modèle de classification à un nouveau jeu de données, les valeurs sont normalisées selon les paramètres d'échelle du jeu de données d'origine.

Comment Studio décision crée un modèle de classification

la Classification dans Decision Studio met en œuvre un algorithme non hiérarchique des moyennes k, aussi connu comme la « méthode Lloyd ».

L’algorithme ignore tout découpage d’un champ non qualitatif. Il exclut les variables candidates non qualitatives avec un écart-type de zéro ainsi que des variables candidates qualitatives avec des enregistrements dans une seule catégorie. Il crée un champ fictif pour chaque catégorie non vide d’une variable candidat qualitative incluse.

Selon un ensemble de groupes initiaux (choisis au hasard), l'algorithme déplace itérativement les enregistrements entre les groupes afin de minimiser la somme totale des carrés :
  1. Chaque enregistrement est attribué au groupe dont le centre est le plus proche (selon la distance métrique). Dans le cas d'un enregistrement à égale distance de deux ou plusieurs groupes, l’enregistrement est attribué au premier groupe à une distance minimale
  2. Les valeurs aberrantes [voir Paramètres d’un modèle de classification] exclues.
  3. Les moyennes du groupe sont (re)calculées et, pour l’itération suivante, les centres des groupes sont destinés à être ces moyennes de groupe.
  4. Les itérations se poursuivent jusqu'à ce que l'un des critères d’arrêt [voir Critères d’arrêt d’un modèle de classification] soit satisfait.

Champs qualitatifs de classification

L'algorithme de classification traite une variable candidate qualitative comme s’il s'agissait d'un ensemble de champs indicateurs numériques, un par catégorie (y compris les null [voir La valeur null] et les catégories non classées). Chaque catégorie du champ initial est représentée par la valeur 1 dans le champ indicateur correspondant et la valeur 0 dans chacun des autres champs indicateurs.

Par exemple, un champ qualitatif comme le Sexe, avec trois catégories, masculin, féminin, et vide, est représenté par trois champs indicateurs qui apparaissent dans la Classification en tant Sexe (masculin), Sexe (féminin) et Sexe (vide). Un enregistrement d’un client femme indique dans ces champs indicateurs la valeur respective 0, 1 et 0. Un centre de groupe normal peut indiquer dans ces champs des valeurs 0,3, 0,2 et 0,5. (Les valeurs pour les champs indicateurs correspondant à un champ qualitatif toujours ajouter jusqu'à 1.)

Lorsque Classification indique le nombre de dimensions utilisées pour créer un groupe, chaque champ indicateur est considéré comme une dimension.

La valeur null dans la classification

Lors du calcul de la distance, la valeur null [voir La valeur null] d'un champ non qualitatif est considérée proche de manière égale de tous les centres de groupes – c’est à dire que sa contribution à la distance est nulle et que la distance à partir d'un centre de groupe est déterminée par le reste des champs. % Duplique le texte de la section « champs qualitatifs de classification ». La catégorie vide dans une variable candidat qualitative est traitée de la même manière que toute autre catégorie. Si toutes les variables candidates ne sont pas qualitatives, les enregistrements qui contiennent la valeur null pour tous sont ignorés (et produisent un résultat d'indice-groupe null).
Remarque : Lors de l’application d’un modèle de classification, la Classification traite les valeurs qualitatives qui étaient vides ou absentes au moment de la création en attribuant les enregistrements qui les incluent au groupe vide.


Création d'un modèle de classification

  1. Interprétez éventuellement certains champs comme des variables candidates [voir Définition ou effacement d'une variable candidate, une interprétation clé, qualitative, géographique ou d'exportation].

    S’il existe des champs avec une interprétation de variables candidates, la Classification ne considère ces champs que lors de la création des modèles de classification.

  2. Choisissez Outils>Classification ou cliquez sur [image] dans la barre d'outils.
  3. Si besoin, changez la valeur par défaut des options de création [voir Contrôle de la création d'un modèle de classification].
  4. Choisissez Classification>Construire jusqu'à la fin ou cliquez sur [image] dans la barre d'outils pour construire un modèle de classification.

    la Classification continue jusqu'à ce qu'il satisfasse à un ou plusieurs des critères d’arrêt [voir Critères d’arrêt d’un modèle de classification] pour un modèle de classification.

  5. Éventuellement, pour créer une nouvelle itération du modèle de classification, choisissez Classification>Effectuer la prochaine itération ou cliquez sur [image] dans la barre d'outils.

    Si le modèle de classification a convergé ou si les paramètres de création ont changé, cette option n'est pas disponible.

Remarque :
  • la Classification pas un outil de création de modèle. Il ne tient donc compte d’aucun objectif que vous avez défini.
  • Les fenêtres sur la gauche de la fenêtre Classification affichent les champs inclus (variables candidates) et les champs exclus (autres champs du fichier focus), ainsi que des champs qui apparaissent dans le modèle de classification en cours en gras.

    Vous pouvez interpréter un champ comme une variable candidate en le déplaçant du volet inférieur vers le volet supérieur (et vice versa), avec les boutons présentant des flèches entre les volets.

  • Lorsque vous commencez à créer un modèle de classification, la Classification vous invite à interpréter tous les champs de chaîne qui n'ont pas d’interprétation qualitative, de sorte qu'ils puissent être découpés correctement. Vous pouvez soit choisir l'interprétation qualitative par défaut, soit utiliser une hiérarchie qualitative enregistrée. Si vous cliquez sur Annuler lorsque vous êtes invité à choisir l’interprétation d'un champ de chaîne, la Classification ignore cette variable candidat, ainsi que les champs de chaîne sans interprétation qualitative.
  • Les statistiques des modèles de classification apparaissent dans la fenêtre Résultats de classification. Elles comprennent des mesures de la qualité du modèle (somme totale des carrés et séparation) ainsi que des paramètres de création de modèle.

    Les statistiques des classifications du dernier modèle à créer s’affichent dans la fenêtre Détails du groupe (sauf pour les groupes aberrants et vides). Elles comprennent des mesures de la qualité de groupe (ESS, séparation et rayon), ainsi que le nombre d'enregistrements dans chaque groupe et les valeurs des champs qui décrivent le chaque centre de groupe.

  • Pour effacer l'historique des modèles de classification créé ainsi que les détails du modèle en cours, choisissez Classification>Effacer ou cliquez sur [image] dans la barre d'outils.
  • Les groupes d’un modèle de classification sont numérotés : chaque enregistrement est associé à un index de classe compris entre 1 et le nombre de groupes, à moins qu'il ne soit considéré comme une valeur aberrante [voir Paramètres d’un modèle de classification], auquel cas il obtient l'index de classe -1.

    Vous pouvez calculer un champ [voir Calcul d'un champ depuis un modèle ou un tableau croisé Decision Studio] contenant l’index de classe.

Voir également

À propos des modèles de classification dans Portrait Miner

Contrôle de la création d'un modèle de classification

Appliquer d'un modèle ou d'une segmentation Decision Studio à une population différente

Sujet parent : Construction de modèles de classification pour segmentation et modélisation prédictive

Choix du bon nombre de groupes

L'algorithme [voir Comment Studio décision crée un modèle de classification] que la Classification utilise pour créer un modèle de classification vous oblige à spécifier le nombre cible de groupes [voir Paramètres d’un modèle de classification] à l'avance.
Si vous choisissez un nombre approprié de groupes, la Classification peut ne pas trouver un bon modèle de classification :
  • Si vous spécifiez trop peu de groupes, la Classification fusionne des groupes distincts. Dans le pire des cas, il peut casser un groupe « naturel » et répartir son contenu dans les groupes voisins, et donc le modèle ne tiendra pas du tout compte des groupes réels.
  • Si vous spécifiez trop de groupes, la Classification va diviser certains groupes en petites parties.
Votre connaissance de l'entreprise peut vous aider à trouver un nombre de groupes approprié ou vous pourriez être face à différentes valeurs et voir laquelle conduit au meilleur modèle. La méthode qui fonctionne assez correctement est d'exploiter le fait que, bien qu'il soit difficile de savoir si vous avez trop peu de groupes, si vous avez en avez trop, la mesure de séparation aura tendance à être faible.
  1. Commencez par choisir un assez grand nombre de groupes et par créer plusieurs modèles, en essayant de maximiser la mesure de séparation.
  2. Si vous ne pouvez pas obtenir une statistique de mesure de séparation proche de 100%, réduisez le nombre de groupes à un et essayez à nouveau.
  3. Continuez jusqu'à ce que, pour votre nombre de groupes, vous pouvez au moins obtenu quelques modèles de classification avec une mesure de séparation élevée.
Remarque :
  • Vous ne pouvez pas toujours obtenir le nombre de groupes que vous spécifiez, comme la Classification exclut tout groupe vide à partir d'un modèle de classification.
  • Soyez conscient qu'un modèle peut avoir une mesure de séparation élevée simplement parce qu'il classe une grande proportion des enregistrements comme des valeurs aberrantes.

Optimisation d’un modèle de classification

La mesure de séparation donne une indication assez correcte lorsqu’il existe trop de groupes. Mais, une fois que vous avez le bon nombre de groupes, il n'est pas tellement utile pour distinguer les bons et les mauvais modèles.

Une manière d’optimiser votre modèle est de maintenir le nombre fixe de groupes et de créer un grand ensemble de modèles de classification en essayant de minimiser la somme totale des carrés.

Remarque : Soyez conscient qu'un modèle peut avoir une mesure de séparation élevée simplement parce qu'il classe une grande proportion des enregistrements comme des valeurs aberrantes.

Évitement des débordements lors de la création d’un modèle de classification

Comme avec toute technique de création de modèle, vous devez évaluer et éviter tout débordement. Utilisez une méthodologie de test/d’apprentissage [voir Méthodologie de test/apprentissage pour une modélisation solide] et soyez prudents lors de l’utilisation des éléments suivants :
  • Champs d’analyse avec un grand nombre de catégories
  • Un grand nombre de variables candidates (auquel cas un autre problème éventuel est que la majorité des enregistrements finissent comme des valeurs aberrantes)
  • Un grand nombre cible de groupes


Options d'affichage d'un modèle de classification

Les options d'affichage de Classification suivantes sont disponibles :

Affichage | Description
Afficher le tableau | Un affichage à double tableau, présentant les statistiques des modèles de classification successifs dans le tableau supérieur et les statistiques des classification du modèle le plus récent dans le tableau inférieur, à côtés de fenêtres indiquant la listes des champs inclus et exclus
Afficher le graphique | Un graphique en deux ou en trois dimensions [voir Graphiques de la Classification], à côté d'une fenêtre indiquant les champs du fichier focus (avec les champs impliqués dans le modèle indiqué en caractères gras)

Initialement, la Classification affiche le tableau (et le graphique est indisponible jusqu'à vous construisiez ou ouvriez un modèle de classification). Pour passer du tableau au graphique, choisissez l'affichage soit dans le menu Affichage, soit en cliquant sur le bouton correspondant dans la barre d'outils.

Sujet parent : Construction de modèles de classification pour segmentation et modélisation prédictive

Graphiques de la Classification

Sur le graphique du Classification :
  • Sélectionnez n'importe quel nombre de champs dans la fenêtre de gauche et cliquez sur Graphique 2D pour obtenir un ensemble de graphiques de profil [voir Création d'un ensemble de graphiques de profil à variable unique] pour ces champs.
  • Sélectionnez jusqu'à trois champs dans la fenêtre de gauche et cliquez sur Graphique 3D pour obtenir un graphique de distribution croisée [voir Création d'un graphique de distribution croisée multi-variable] ventilé par les champs que vous avez choisis.

Dans les deux cas, la Classification associe les statistiques suivantes aux aspects du graphique :

Statistique de segment | Aspect de graphique
count | Hauteur de bloc (ou volume pour un graphique de distribution croisée à trois champs)
mode d'index de classe | Couleur du bloc
ratio du mode [voir moderatio] d'index de classe | Luminosité du bloc

Plus un segment est pur, selon l'idéal de tous les enregistrements relevant d'un groupe unique, plus la couleur du bloc de ce segment est lumineuse. Un ratio de mode de 1 pour un segment indique que tous les enregistrements dans ce segment sont dans le même groupe.

Chaque affichage de graphique indique une légende, avec des blocs dont la luminosité est de 50 %, 75 % et 100 %, pour donner une indication utile sur la façon dont chaque couleur varie selon la luminosité.


Contrôle de la création d'un modèle de classification

Vous pouvez contrôler la façon dont la Classification crée un modèle de classification en sélectionnant Classification>Paramètres et en changeant les paramètres dans la boîte de dialogue Paramètres de classification :

Voir également

À propos des modèles de classification dans Portrait Miner

Création d'un modèle de classification

Sujet parent : Construction de modèles de classification pour segmentation et modélisation prédictive

Paramètres d’un modèle de classification

La moitié supérieure de la boîte de dialogue Paramètres de classification comporte des réglages pour les paramètres de modèle de classification généraux :

Paramètre | Description
Nombre de groupes : | Le nombre cible de groupes séparés dans le modèle de classification
Limite aberrante | Un multiplicateur m qui détermine les enregistrements à traiter comme des valeurs aberrantes la Classification traite un enregistrement comme un cas particulier si, pour une variable candidat non qualitative, la différence entre la valeur de l'enregistrement et la valeur du centre de groupe le plus proche dépasse m écarts standards du champ. Si la limite aberrante n'est pas définie, aucun enregistrement n’est considéré comme aberrant.
Initialisation personnalisée : | Initialisation pour initialiser les centres de groupe dans l'algorithme de classification Si l’initialisation de l'utilisateur n'est pas définie, la Classification choisit une initialisation (selon l'horloge système) pour chaque création. La définition de l’initialisation permet de généré les modèles de classification reproductibles.
Pour reproduire un modèle de classification précédemment créé, réglez la valeur de départ aléatoire sur celle indiquée pour le modèle dans la fenêtre Résultats de classification.

Critères d’arrêt d’un modèle de classification

Dans la moitié inférieure de la boîte de dialogue Paramètres de classification, il existe des paramètres de contrôle lorsque la Classification arrête la recherche de modèles de classification améliorés :

Paramètre | Description
Nombre maximal d'itérations | Le nombre maximal d'itérations de l'algorithme de classification que la Classification effectuera
Mouvement minimal | Le nombre d’enregistrements n tel que, si la Classification reclasse moins de n enregistrements dans les groupes au cours d'une itération, elle n’effectue aucune autre itération. Vous pouvez spécifier le nombre d'enregistrements soit en termes absolus, soit en pourcentage de la population totale.
Remarque : L’algorithme Classification prend fin lorsqu’un critère d’arrêt est satisfait. Cependant il s’arrête généralement sans avoir satisfait à l'autre critère.


Application des modèles et des segmentations aux nouveaux clients et aux données de transaction

  • Enregistrement d'un modèle ou d'une segmentation Decision Studio au format QMML (XML)
  • Conversion d'un modèle Decision Studio ou d'une segmentation pour déploiement SAS
  • Conversion d'un modèle Decision Studio ou d'une segmentation pour déploiement SQL
  • Modèle de métadonnées
  • Création d'une synthèse de modèle


Enregistrement d'un modèle ou d'une segmentation Decision Studio au format QMML (XML)

Vous pouvez enregistrer un modèle ou une segmentation en tant que document QMML (XML) pour le déployer via l'assistant Calculer des champs [voir Calcul de champs dans un focus avec Portrait Miner], la commande data build qsderive de Portrait Miner ou pour Portrait Dialogue ou Portrait Interaction Optimizer (via QMML).
  1. Si votre modèle ou segmentation n'est pas déjà exprimé en termes de champs calculés dans un focus, effectuez l'une des opérations suivantes :
    • Pour un arbre de décision, un scoring, ou un modèle de classification, calculez les champs générés [voir Calcul d'un champ depuis un modèle ou un tableau croisé Decision Studio] pour encapsuler les fonctionnalités importantes de votre modèle.
    • Pour une segmentation graphique, calculez un champ flag [voir Calcul d'un champ à partir d'une segmentation graphique] pour les segments clés de la population identifiée dans votre graphique.
    • Pour un tableau croisé (textuel ou graphique), calculez un champ index [voir Calcul d'un champ depuis un modèle ou un tableau croisé Decision Studio] représentant complètement la segmentation.
    • Pour un modèle ou une segmentation basé sur des règles métier, calculez des champs avec l'Aperçu du tableau [voir Calcul d'un champ avec l'Aperçu du tableau].
  2. Dans l'Aperçu du tableau, choisissez Fichier>Exporter au format QMML ou cliquez sur [image] dans la barre d'outils.

    Un explorateur de fichiers Portrait Miner apparaît.

  3. Placez-vous [voir Ouverture ou enregistrement d'un fichier, d'une session ou d'une table de base de données] à l'endroit où vous souhaitez enregistrer votre document QMML, et choisissez lui un nom.

    Decision Studio enregistre un document QMML qui comprend des définitions de champs calculés dans le focus.

Remarque :
  • Lorsque vous choisissez Fichier>Exporter au format QMML, Portrait Miner analyse automatiquement le QMML. Cette option supprime la nécessité d'utiliser la commande data build qsqmmledit -parse. En cas d'erreur, Portrait Miner vous indique les calculs qui n'ont pas pu être analysés. Dans ce cas, un fichier QMML file est créé, mais sans la représentation structurée des calculs du problème.
  • Lorsque vous choisissez Fichier>Exporter au format QMML, le document QMML comprend un ensemble de règles qui contiennent tous les champs calculés surlignés dans l'Aperçu du tableau ou tous les champs calculés, si aucun champ n'est surligné. Indépendamment des champs apparaissant dans l'ensemble de règles, le document QMML contient des définitions pour tous les champs calculés.
  • Si vous souhaitez inclure des fonctions FDL définies par l'utilisateur pendant l'analyse QMML dans Decision Studio, vous pouvez définir des fonctions accessibles globalement en les stockant dans un fichier (ou des fichiers) dans un dossier répertorié dans la préférence bibliothèques de calcul [voir bibliothèques de calcul].

Voir également

À propos du langage TML

Appliquer d'un modèle ou d'une segmentation Decision Studio à une population différente

Conversion d'un modèle Decision Studio ou d'une segmentation pour déploiement SAS

Conversion d'un modèle Decision Studio ou d'une segmentation pour déploiement SQL

Enregistrement d'un tableau croisé à partir de Decision Studio

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

XML dans Portrait Miner

Sujet parent : Application des modèles et des segmentations aux nouveaux clients et aux données de transaction


Conversion d'un modèle Decision Studio ou d'une segmentation pour déploiement SAS

Vous pouvez effectuer une conversion au format SAS avec Portrait Miner. Une instruction SAS séparée est créée pour chaque calcul de champ.

Dans Portrait Miner, cliquez avec le bouton droit sur le fichier QMML que vous voulez convertir et choisissez Conversion au format SAS.

Dans la boîte de dialogue Conversion au format SAS, choisissez les champs de sortie requis et un emplacement pour enregistrer le modèle SAS.

Remarque :
  • La fonctionnalité de conversion au format SAS est expérimentale.
  • Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsqmml2sas de Portrait Miner.

Voir également

À propos des assistants Portrait Miner

Enregistrement d'un modèle ou d'une segmentation Decision Studio au format QMML (XML)

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Sujet parent : Application des modèles et des segmentations aux nouveaux clients et aux données de transaction


Conversion d'un modèle Decision Studio ou d'une segmentation pour déploiement SQL

Vous pouvez effectuer une conversion au format SQL avec Portrait Miner. Une instruction SQL SELECT est créée pour chaque calcul de champ. Portrait Miner prend en charge les types de bases de données suivantes :
  • Oracle
  • Teradata
  • Microsoft SQL Server

Dans Portrait Miner, cliquez avec le bouton droit sur le fichier QMML que vous voulez convertir et choisissez Convertir au format SQL.

Dans la boîte de dialogue Conversion d'un QMML au format SQL, choisissez la table source et le type de la base de données cible.

Remarque :
  • La fonctionnalité Convertir au format SQL est expérimentale.
  • Dans SQL, l'évaluation des types entiers en booléen n'est pas autorisée.
  • Cette interface utilisateur est un moyen d'accéder à la plupart des fonctionnalités fournies par la commande data build qsqmml2sql de Portrait Miner.

Voir également

À propos des assistants Portrait Miner

Enregistrement d'un modèle ou d'une segmentation Decision Studio au format QMML (XML)

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Sujet parent : Application des modèles et des segmentations aux nouveaux clients et aux données de transaction


Modèle de métadonnées

Les métadonnées sont des « données sur les données ». Chaque modèle que vous construisez, qu'il s'agisse d'un arbre de décision, un scoring, ou un modèle de classification a des métadonnées associées :
  • La date et l'heure de la construction du modèle
  • Qui a construit le modèle
  • Le focus sur lequel le modèle est basé
  • La version de Decision Studio qui a été utilisée pour construire le modèle
  • Les commentaires du modèle (que vous pouvez modifier dans Decision Studio)
  • Les paramètres de construction de modèle qui étaient disponibles au moment où le modèle a été construit.

Lorsque vous enregistrez [voir Enregistrement d'un arbre de décision, un scoring ou un modèle de mise en cluster] un modèle, le fichier de modèle contient ces métadonnées ainsi que la description du modèle lui-même.

Pour voir les autres métadonnées associées à un arbre de décision ou un scoring, choisissez Arbre (dans l'Arbre de décision) ou Scoring (dans le Scoring).

Voir également

Création d'une synthèse de modèle
Sujet parent : Application des modèles et des segmentations aux nouveaux clients et aux données de transaction

Ajout de commentaires à un modèle

Vous pouvez ajouter des commentaires à un arbre de décision ou au scoring, ce qui peut être utile lorsque vous partagez vos modèles avec d'autres personnes ou même lorsque vous y revenez après ne pas les avoir utilisés depuis un certain temps.
  • Dans l'Arbre de décision, pour attacher des commentaires à un arbre de décision, choisissez Arbre>Modifier les commentaires du modèle.
  • Dans le Scoring, pour attacher des commentaires à un scoring, choisissez Scoring>Modifier les commentaires du modèle.

Dans les deux cas, une boîte de dialogue s'affiche avec trois zones de commentaires modifiables, dans lesquelles vous pouvez enregistrer la fenêtre d'observation applicable au modèle, qui contient des informations sur la façon dont vous avez validé le modèle et toutes les notes que vous souhaitez faire.

Remarque :
  • Les modèles de commentaires sont intégrés au rapport de Synthèse de modèle [voir Création d'une synthèse de modèle], ainsi que les commentaires que vous ajoutez lorsque vous créez le rapport.
  • Si vous cochez la case HTML, Decision Studio traite les paires de balises équilibrées, par exemple <b>...</b>, comme balisage HTML, et affiche le commentaire en conséquence.


Création d'une synthèse de modèle

Une synthèse de modèle est un rapport au format HTML contenant une description détaillée d'un arbre de décision ou d'un scoring, incluant divers modèles de statistiques et de profils, de tous les champs impliqués dans le modèle.

Pour créer une synthèse de modèle dans Portrait Miner, faites un clic droit sur le modèle enregistré [voir Enregistrement d'un arbre de décision, un scoring ou un modèle de mise en cluster] que vous désirez étudier et choisissez Créer une synthèse du modèle.

Dans la boîte de dialogue Synthèse de l'arbre de décision ou Synthèse du scoring, vous pouvez choisir d'afficher un rapport du focus ou d'un focus différent, et vous pouvez également établir un rapport sur tous les champs ou aucun champ, par opposition aux champs impliqués dans le modèle.

Remarque :
  • Si vous spécifiez une description pour la synthèse de modèle, celle-ci apparaît avec tous les commentaires de modèle [voir Ajout de commentaires à un modèle], dans la section « Métadonnées fournies par l'utilisateur » du rapport.

  • Vous pouvez choisir une des quatre options pour les formats des images utilisées dans la sortie HTML :

    svg SVG (graphique vectoriel adaptable ) uniquement. Le format SVG offre la meilleure qualité d'image et les plus petites tailles de fichier, mais les lecteurs de votre rapport doivent avoir un navigateur Web comportant un plugin SVG pour afficher ou imprimer ces images.

    smallpng SVG plus bitmap PNG optimisés pour l'écran (graphiques réseau mobiles). Même sans plugin SVG, les lecteurs sont à même de lire les images de votre rapport (mais la qualité d'impression est relativement basse).

    largepng SVG plus bitmap PNG optimisés pour l'écran et l'imprimante. Les lecteurs sont à même d'afficher ou d'imprimer votre rapport sans avoir besoin d'un plugin SVG (mais il est nécessaire d'avoir plus d'espace disque et le rapport met plus longtemps à s'afficher).

    aucun Pas d'image.

  • Vous pouvez contrôler davantage les aspects de l'apparence de la synthèse de modèle et des rapports de Profil et d'Audit en définissant les préférences [voir Définition des préférences de Portrait Miner] dans la section Audits et Synthèses de la fenêtre des Préférences.
  • Pour que Portrait Miner puisse vous avertir par e-mail lorsqu'un rapport est prêt, vous devez définir les préférences emailaddress et emailserver en conséquence.
  • Par défaut, Portrait Miner enregistre une synthèse de modèle sous la forme d'un fichier unique .qshtml, avec des images intégrées. Bien que vous puissiez ouvrir ce fichier dans Portrait Miner (en effectuant un double clic sur le fichier), vous ne pouvez pas l'utiliser directement à l'extérieur de Portrait Miner.

    Pour créer une page Web adaptée qui peut être placée sur un serveur Web, faites un clic droit sur un fichier .qshtml, et choisissez Décompacter dans le dossier. Choisissez un emplacement, sélectionnez ou créez un dossier et cliquez sur OK.

  • La boîte de dialogue Créer un profil et contrôler est une façon d'accéder à la plupart des fonctionnalités fournies par la commande data build qsdtsnapshot ou qsscsnapshot de Portrait Miner.

Voir également

À propos des assistants Portrait Miner

Création d'un profil et d'un audit de focus

Définition des options globales des affichages graphiques

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Sujet parent : Application des modèles et des segmentations aux nouveaux clients et aux données de transaction


Préférences de Portrait Miner

  • Utilisation des préférences
  • Fonctions et découpages de Decision Studio
  • Outils de visualisation de Decision Studio
  • Arbre de Décision
  • Scoring
  • Formatage de la date
  • Recherche de fichier
  • Fichiers texte
  • Bases de données
  • Audits et synthèses
  • Notification e-mail
  • Paramétrage du système et administration
  • Temps réel et intégration des systèmes


Utilisation des préférences

  • Définition des préférences de Portrait Miner
Sujet parent : Préférences de Portrait Miner


Définition des préférences de Portrait Miner

Vous pouvez personnaliser plusieurs aspects de Portrait Miner pour correspondre à vos spécifications personnelles.
  1. Dans Portrait Miner, choisissez Éditer>Préférences.
  2. Choisissez la section correspondante dans le volet de gauche de la fenêtre Préférences.

    Les options disponibles dans la section sélectionnée s'affichent dans le volet de droite.

  3. Faites les modifications comme suit :
    • Cochez ou décochez une case à cocher pour modifier la sélection d'une option.
    • Cliquez dans la cellule Valeur pour éditer un chiffre ou un texte. Pour abandonner vos modifications pendant l'édition d'un chiffre ou d'un texte, faites un clic droit dans la cellule et choisissez Annuler.

      Si des flèches vers le haut/bas apparaissent dans la cellule, vous pouvez utiliser ces modifications pour modifier la valeur numérique.

      Si la cellule contient un menu déroulant, vous pouvez choisir une option dans le menu déroulant.

      Si [image] s'affiche, vous pouvez cliquer dessus pour ouvrir [voir Ouverture ou enregistrement d'un fichier, d'une session ou d'une table de base de données] un fichier ou un dossier.

  4. Cliquez sur Enregistrer, pour confirmer vos choix.
  5. Cliquez sur Quitter pour fermer la fenêtre des Préférences.
Remarque :
  • Les paramètres de préférence ne prennent effet que lorsque vous démarrez une application.
  • Lorsque vous avez dépassé la valeur par défaut d'une option, son nom apparaît en caractères gras dans la fenêtre Préférences.
  • Pour annuler un paramètre de préférence, en revenant à la valeur de préférence que vous aviez avant d'ouvrir la fenêtre Préférences, faites un clic droit sur le nom de la préférence et choisissez Annuler.
  • Pour restaurer le système par défaut d'une préférence, faites un clic droit sur le nom de la préférence et choisissez Restaurer les valeurs par défaut.

    Pour restaurer les paramètres par défaut de toutes les préférences de la section en cours, choisissez Éditer>Restaurer les valeurs par défaut de la section nom. Pour restaurer les paramètres système par défaut de toutes les préférences, choisissez Éditer>Restaurer toutes les valeurs par défaut.

  • Si vous définissez la valeur de n'importe quelle préférence format de la date, format intégral, lecture ou format de l'heure aux normes européennes, américaines, ou AMJ dans la fenêtre Préférences, les trois autres préférences sont définies selon la même valeur.
  • Les paramètres système par défaut des préférences ne sont pas nécessairement les mêmes que les paramètres par défaut : votre administrateur système peut avoir écrasé certains paramètres. Dans les descriptions des préférences individuelles, les paramètres par défaut sont indiqués.
  • Toute les options que vous définissez dans la fenêtre Préférences s'appliquent également à toutes les parties de Portrait Miner.
  • Si vous voyez un message d'avertissement à propos d'une préférence non reconnue, l'explication la plus vraisemblable est qu'un de vos paramètres concerne une préférence obsolète. Vous pouvez supprimer le paramétrage en entier en faisant un clic droit sur le nom d'une préférence et en choisissant Restaurer les valeurs par défaut. La saisie des préférences est toujours visible dans la fenêtre des Préférences jusqu'à ce que vous enregistriez et quittiez l'application.
  • Si vous découvrez que vous ne pouvez pas modifier le paramétrage d'une préférence, votre administrateur système l'a peut-être verrouillé pour empêcher que les utilisateurs effectuent des modifications.
  • Certaines préférences sont destinées uniquement aux utilisateurs confirmés, et, en tant que tels, sont masquées par défaut. Elles ne devraient normalement être modifiées que par l'administrateur de Portrait Miner. Pour visualiser toutes les préférences, choisissez Visualiser>Afficher toutes les préférences.

Voir également

Définition des options globales des affichages graphiques

Définition du format d'affichage des valeurs numériques et de date

Sujet parent : Utilisation des préférences


Fonctions et découpages de Decision Studio

  • modalités extrêmes automatiques
  • modalités extrêmes automatiques pour classes de même effectif
  • type de découpage par défaut
  • taille de modalité minimale par défaut (découpage par catégories)
  • nombre de modalités par défaut (découpage par catégories)
  • nombre de modalités par défaut (découpage numérique)
  • affichage largueur identique
  • nombre maximal de modalités de date
Sujet parent : Préférences de Portrait Miner


modalités extrêmes automatiques

Section Découpage numérique

Objectif Contrôler si Decision Studio crée des modalités extrêmes [voir Modalités de fin] lors du découpage d'un champ numérique.

Valeurs valides

Valeur | Description
true (par défaut) | Créer des modalités extrêmes « intelligentes » pour avoir des découpages numériques (mais voir modalités extrêmes automatiques pour classes de même effectif).
false | Ne pas créer de modalités extrêmes pour avoir des découpages numériques.
Sujet parent : Fonctions et découpages de Decision Studio


modalités extrêmes automatiques pour classes de même effectif

Section Découpage numérique

Objectif Contrôler si Decision Studio crée des modalités extrêmes [voir Modalités de fin] lors du découpage d'un champ numérique avec découpage de population égale.

Valeurs valides

Valeur | Description
true | Traitez les découpages de population égale de la même manière que les découpages de plage égale : utilisez le paramètre modalités extrêmes automatiques.
false (par défaut) | Ne pas créer de modalités extrêmes pour avoir des découpages de population égale.
Sujet parent : Fonctions et découpages de Decision Studio


type de découpage par défaut

Section Découpage numérique

Objectif Définir le type de découpage par défaut que Decision Studio applique aux champs numériques et de date.

Valeurs valides

Valeur | Description
intervalles égaux (par défaut) | Créez des découpages de plage égale par défaut.
effectifs égaux | Créez des découpages de population égale par défaut.
Remarque :

Vous pouvez supprimer ce paramètre sur une base de focus : dans l'Éditeur de découpage, choisissez Découpage>Paramètres par défaut ou cliquez sur [image] dans la barre d'outils ; sous l'onglet Non qualitatif, choisissez dans le menu Type de modalité.

Sujet parent : Fonctions et découpages de Decision Studio


taille de modalité minimale par défaut (découpage par catégories)

Section Découpage par catégories

Objectif Définir la taille de modalité minimale pour obtenir un champ qualitatif dans Decision Studio.

Valeurs valides Un nombre entier non négatif, par défaut 0

Lorsque Decision Studio crée un découpage par catégories dans un champ, il ne crée que des modalités pour des valeurs présentes au minimum dans le nombre d'enregistrements spécifié. Autres valeurs non classées.

Remarque : Vous pouvez supprimer ce paramètre sur une base de focus : dans l'Éditeur de découpage, choisissez Découpage>Paramètres par défaut ou cliquez sur [image] dans la barre d'outils ; sous l'onglet Qualitatif, définissez Taille min de la catégorie.

Voir également

nombre de modalités par défaut (découpage par catégories)
Sujet parent : Fonctions et découpages de Decision Studio


nombre de modalités par défaut (découpage par catégories)

Section Découpage par catégories

Objectif Définir le nombre de modalités maximal pour obtenir un champ qualitatif dans Decision Studio.

Valeurs valides Un nombre entier non négatif, par défaut 250

Lorsque Decision Studio crée un découpage par catégories dans un champ, il crée des modalités pour le nombre spécifié de valeurs au maximum (en choisissant d'abord les valeurs les plus communes). Autres valeurs non classées.

Remarque : Vous pouvez supprimer ce paramètre sur une base de focus : dans l'Éditeur de découpage, choisissez Découpage>Paramètres par défaut ou cliquez sur [image] dans la barre d'outils ; sous l'onglet Qualitatif, définissez Nombre max de catégories.

Voir également

taille de modalité minimale par défaut (découpage par catégories)
Sujet parent : Fonctions et découpages de Decision Studio


nombre de modalités par défaut (découpage numérique)

Section Découpage numérique

Objectif Définir le nombre cible par défaut de modalités pour un découpage numérique ou de date dans Decision Studio.

Valeurs valides Un nombre entier non négatif, par défaut 10

Remarque :
  • Le nombre cible par défaut de modalités exclut les modalités extrêmes [voir Modalités de fin] et les classes avec la valeur zéro [voir La valeur null] et non classées.
  • Vous pouvez supprimer ce paramètre sur une base de focus : dans l'Éditeur de découpage, choisissez Découpage>Paramètres par défaut ou cliquez sur [image] dans la barre d'outils ; sous l'onglet Non qualitatif, définissez Modalités internes cible.
Sujet parent : Fonctions et découpages de Decision Studio


affichage largueur identique

Section Découpage numérique

Objectif Définir le mode d'affichage par défaut que Decision Studio utilise pour les découpages numériques ou de date : histogramme ou graphique à barres [voir Options histogramme et graphique à barres].

Valeurs valides

Valeur | Description
true (par défaut) | Utilisez le mode d'affichage graphique à barres.
false | Utilisez le mode d'affichage histogramme.
Remarque :
  • Le mode d'affichage d'un découpage affecte également les affichages graphiques dans l'Aperçu du profil et l'Aperçu de la distribution croisée.
  • Vous pouvez supprimer ce paramètre sur une base de focus : dans l'Éditeur de découpage, choisissez Découpage>Paramètres par défaut ou cliquez sur [image] dans la barre d'outils ; sous l'onglet Non qualitatif, choisissez dans le menu Graphique.
Sujet parent : Fonctions et découpages de Decision Studio


nombre maximal de modalités de date

Section Découpage de date

Objectif Définir le nombre maximal de modalités pour obtenir un champ de date (l'étendue des modalités est ajustée en conséquence). Cela évite, par exemple, le découpage par inadvertance d'une plage de siècles par seconde.

Valeurs valides Un nombre entier entre 1 et 1 000, non présent dans le fichier ini, par défaut 100

Sujet parent : Fonctions et découpages de Decision Studio


Outils de visualisation de Decision Studio

  • taille maximale
  • fonction objectif
Sujet parent : Préférences de Portrait Miner


taille maximale

Section Agrégation

Objectif Définir la taille du plus grand tableau croisé [voir Tableaux croisés comme base de segmentation et de visualisation des données] que Decision Studio peut créer.

Valeurs valides Un entier non négatif, par défaut 100 000

Remarque : Pour calculer la taille d'un tableau croisé dans ce sens, calculez

pour un tableau croisé présentant des N champs de ventilation avec des modalités [image], [image], ..., [image] respectivement (y compris les modalité limites [voir Modalités de fin] le cas échéant, et les modalités non null [voir La valeur null] et non classées). Par exemple, un tableau croisé avec des champs de ventilation Revenu et Âge, découpés en modalités internes de 10 et 8 respectivement, a la taille [image].
Sujet parent : Outils de visualisation de Decision Studio


fonction objectif

Section Agrégation

Objectif Définir la fonction d'agrégation [voir Fonctions d'agrégation pour les tableaux croisés] que Decision Studio applique par défaut à un objectif lorsque vous créez l'affichage d'un tableau croisé [voir Création d'un tableau croisé textuel], d'un graphique de profil [voir Création d'un ensemble de graphiques de profil à variable unique], d'un graphique de distribution croisée [voir Création d'un graphique de distribution croisée multi-variable] ou d'un graphique de carte [voir Création d'un graphique sur une carte]. (Pour les graphiques, Decision Studio associe le résultat à une couleur de bloc.)

Valeurs valides

Valeur | Description
any | Indique une valeur arbitraire [voir any] de l'objectif.
countnonnull | Indique le nombre d'enregistrements non null [voir countnonnull/countnonnulls] de l'objectif.
countnull | Indique le nombre d'enregistrements null [voir countnull/countnulls] de l'objectif.
countunique | Indique le nombre de valeurs uniques [voir countunique] de l'objectif incluant potentiellement la valeur null.
countuniquenonnull | Indique le nombre de valeurs uniques [voir countuniquenonnull] de l'objectif n'incluant pas la valeur null.
first | Indique la valeur de l'objectif pour le premier enregistrement [voir first].
last | Indique la valeur de l'objectif pour le dernier enregistrement [voir last].
max | Indique la valeur maximale [voir max (un seul argument)] de l'objectif.
mean (par défaut) | Indique la valeur moyenne [voir mean (un argument)] de l'objectif
median | Indique la valeur médiane (valeur du milieu) [voir median] de l'objectif.
min | Indique la valeur minimale [voir min (un argument)] de l'objectif.
mode | Indique le mode (valeur la plus commune) [voir mode] de l'objectif.
moderatio | Indique la proportion d'enregistrements contenant la valeur la plus commune [voir moderatio] de l'objectif.
percentagerate | Indique le pourcentage d'enregistrements contenant la valeur 1 [voir percentagerate] de l'objectif (binaire).
significance | Indique la significativité de la différence entre la moyenne de l'objectif du segment et celle de la population globale.
stdev | Indique l'écart-type des valeurs [voir stdev] de l'objectif.
sum | Indique la somme des valeurs [voir sum (un argument)] de l'objectif.
écart | Indique l'écart entre les valeurs [voir variance] de l'objectif.
Sujet parent : Outils de visualisation de Decision Studio


Arbre de Décision

  • borne supérieure de l'uplift
Sujet parent : Préférences de Portrait Miner


borne supérieure de l'uplift

Section Arbre de Décision

Objectif La valeur de l'uplift d'un segment dans un uplift binaire x arbre peut être infinie. Cette valeur sert à représenter l'uplift infini partout où il est signalé (affichages de texte, champs de résultats, etc.)

Valeurs valides Un nombre entier non négatif, par défaut

Sujet parent : Arbre de Décision


Scoring

  • taux d'acceptation
  • transformation d'attribut
  • mauvais taux
  • seuil
  • doubling odds
  • even odds
  • carte initiale
  • objectif inverse
  • itérations
  • modèle
  • nombre de décimales pour la précision
  • un poids par caractéristique
  • mesure de la qualité
  • parcours
  • solveur
  • tolérance
Sujet parent : Préférences de Portrait Miner


taux d'acceptation

Section Scoring

Objectif Définir le seuil de taux d'acceptation initial [voir Champs associés aux modèles d'arbre de décision, de scoring et de classification et aux tableaux croisés résumés] (ou taux cible) que le Scoring utilise.

Valeurs valides Un nombre réel compris entre 0 et 1, par défaut 0,5

Remarque : Vous devez normalement ne pas définir plus d'un seul seuil, mauvais taux et taux d'acceptation, comme le premier de ceux qui est défini (dans l'ordre indiqué ici) qui prévaut toujours sur les autres.
Sujet parent : Scoring


transformation d'attribut

Section Scoring

Objectif Contrôler la manière dont le Scoring transforme les valeurs des modalités individuelles dans un modèle one-weight-per-field [voir un poids par caractéristique].

Valeurs valides

Valeur | Description
enregistrer les risques (par défaut) | Utilisez l'enregistrement des risques (le « poids de la preuve »).
moyenne | Utilisez la moyenne.
risques | Utilisez les risques.
enregistrer la moyenne | Utilisez l'enregistrement de la moyenne
Remarque :

Vous pouvez supprimer le paramètre de cette préférence en modifiant le format [voir Modification du format d'un scoring] dans la boîte de dialogue Formulaire de scoring.

Sujet parent : Scoring


mauvais taux

Section Scoring

Objectif Définir le seuil de mauvais taux initial [voir Champs associés aux modèles d'arbre de décision, de scoring et de classification et aux tableaux croisés résumés] (ou taux de réussite) que le Scoring utilise.

Valeurs valides Un nombre réel compris entre 0 et 1, par défaut 0,5

Remarque : Vous devez normalement ne pas définir plus d'un seul seuil, mauvais taux et taux d'acceptation, car le premier de ceux-ci qui est défini(dans l'ordre indiqué ici) a toujours la priorité sur les autres.
Sujet parent : Scoring


seuil

Section Scoring

Objectif Définir le seuil de score initial [voir Champs associés aux modèles d'arbre de décision, de scoring et de classification et aux tableaux croisés résumés] que le Scoring utilise.

Valeurs valides Un nombre réel, par défaut 500

Remarque : Vous devez normalement ne pas définir plus d'un seul seuil, mauvais taux et taux d'acceptation, car le premier de ceux-ci qui est défini (dans l'ordre indiqué ici) a toujours la priorité sur les autres.
Sujet parent : Scoring


doubling odds

Section Scoring

Objectif Définir le facteur de doublement initial [voir Champs associés aux modèles d'arbre de décision, de scoring et de classification et aux tableaux croisés résumés] que le Scoring utilise pour la relation entre le score et les risques.

Valeurs valides Un nombre réel positif, par défaut 20

Voir également

even odds
Sujet parent : Scoring


even odds

Section Scoring

Objectif Définir le seuil de risques initial [voir Champs associés aux modèles d'arbre de décision, de scoring et de classification et aux tableaux croisés résumés] que le Scoring utilise pour la relation entre le score et les risques.

Valeurs valides Un nombre réel positif, par défaut 500

Voir également

doubling odds
Sujet parent : Scoring


carte initiale

Section Scoring

Objectif Définir le scoring initial que le Scoring utilise lors de l'application d'un solveur itératif.

Valeurs valides

Valeur | Description
linéaire (par défaut) | Utilisez une régression linéaire (analyse discriminante) pour générer un scoring initial.
fixé | Utilisez un scoring initial avec des poids égaux pour toutes les variables.
à jour | Utilisez le scoring en cours comme scoring initial.
aléatoire | Utilisez un pseudo-scoring initial généré de manière aléatoire [voir À propos des fonctions FDL à nombre aléatoire].
Remarque :

Vous pouvez supprimer le paramètre de cette préférence en modifiant la carte de départ [voir Modification du solveur utilisé pour construire un scoring] dans la boîte de dialogue Solveur de scoring.

Sujet parent : Scoring


objectif inverse

Section Scoring

Objectif Changer l'interprétation 1/0 de l'objectif.

Valeurs valides

Valeur | Description
true | Interprétez les enregistrements avec un 0 dans l'objectif comme défaillances/clients ayant changé de fournisseur/répondeurs.
false (par défaut) | Interprétez les enregistrements avec un 1 dans l'objectif comme défaillances/clients ayant changé de fournisseur/répondeurs.
Remarque :

Vous pouvez remplacer le paramètre de cette préférence avec l'option du menu Scoring>Inverser la valeur de l'objectif.

Sujet parent : Scoring


itérations

Section Scoring

Objectif Définir le nombre maximal d'itérations qu'un solveur de scoring itératif utilise.

Valeurs valides Un nombre entier positif, par défaut 1000

Remarque : Vous pouvez supprimer le paramètre de cette préférence en modifiant le nombre maximal d'itérations [voir Modification du solveur utilisé pour construire un scoring] dans la boîte de dialogue Solveur de scoring.

Voir également

tolérance
Sujet parent : Scoring


modèle

Section Scoring

Objectif Contrôler le type de modèle par défaut .

Valeurs valides

Valeur | Description
risque (par défaut) | Créez un modèle de risque.
réponse | Créez un modèle de réponse.
attrition | Créez un modèle d'attrition.
satisfaction | Créez un modèle de satisfaction.
insatisfaction | Créez un modèle d'insatisfaction.
Sujet parent : Scoring


nombre de décimales pour la précision

Section Scoring

Objectif Contrôler le nombre de décimales pour la précision pour lequel le Scoring effectue des calculs approximatifs, comme la valeur Gini pour un scoring.

Valeurs valides Un nombre entier entre 1 et 8, par défaut 3

Remarque : Vous pouvez remplacer le paramètre de cette préférence en choisissant Scoring>Solveur dans le Scoring et en changeant le nombre de décimales pour la précision.
Sujet parent : Scoring


un poids par caractéristique

Section Scoring

Objectif Contrôler si le Scoring utilise un poids par champ ou un poids par découpage.

Valeurs valides

Valeur | Description
true (par défaut) | Utilisez un poids par champ.
false | Utilisez un poids par modalité.
Remarque :

Vous pouvez supprimer le paramètre de cette préférence en modifiant le format [voir Modification du format d'un scoring] dans la boîte de dialogue Formulaire de scoring.

Voir également

transformation d'attribut
Sujet parent : Scoring


mesure de la qualité

Section Scoring

Objectif Définir la mesure de qualité utilisée par le Scoring.

Valeurs valides

Valeur | Description
linéaire (par défaut) | Utilisez une régression linéaire (analyse discriminante).
logistique | Utilisez la régression logistique.
probit | Utilisez la régression probit.
Remarque :

Vous pouvez supprimer le paramètre de cette préférence en choisissant une mesure de la qualité [voir Modification de la mesure de la qualité utilisée pour construire un scoring] dans le menu Scoring>Mesure de la qualité.

Sujet parent : Scoring


parcours

Section Scoring

Objectif Définir le nombre de fois que le Scoring applique une méthode pour optimiser un scoring.

Le Scoring utilise la valeur moyenne de tous les parcours.

Valeurs valides Un nombre entier positif, par défaut 1

Remarque : Vous pouvez supprimer le paramètre de cette préférence en modifiant le nombre de parcours [voir Modification du solveur utilisé pour construire un scoring] dans la boîte de dialogue Solveur de scoring.
Sujet parent : Scoring


solveur

Section Scoring

Objectif Définir la méthode de solveur que le Scoring utilise.

Valeurs valides

Valeur | Description
direct (par défaut) | Utilisez l'inversion directe de matrice pour effectuer une régression linéaire.
conjugate gradient | Utilisez la méthode conjugate gradient.
levenberg-marquardt | Utilisez la méthode Levenberg — Marquardt.
powell | Utilisez la méthode Powell.
quasi newton | Utilisez la méthode quasi-Newton.
simplex | Utilisez la méthode simplex.
Remarque :

Vous pouvez supprimer le paramètre de cette préférence (pour les mesures de qualité autres que la régression linéaire) en modifiant la méthode [voir Modification du solveur utilisé pour construire un scoring] dans la boîte de dialogue Solveur de scoring.

Sujet parent : Scoring


tolérance

Section Scoring

Objectif Définir une condition d'arrêt pour un solveur de scoring itératif, en termes de tolérance fractionnelle.

Valeurs valides Un nombre réel, par défaut 0,0001

Si la valeur de cette préférence est [image], le Scoring arrête un solveur itératif lorsque les valeurs successives [image] et [image] de la mesure de qualité satisfont ce qui suit :

Remarque : Vous pouvez supprimer le paramètre de cette préférence en modifiant la tolérance fractionnelle [voir Modification du solveur utilisé pour construire un scoring] dans la boîte de dialogue Solveur de scoring.

Voir également

itérations
Sujet parent : Scoring


Formatage de la date

  • Formats de date
  • format de la date
  • index de jour par défaut pour dates incomplètes
  • index de mois par défaut pour dates incomplètes
  • format intégral
  • futur maximal pour années à deux chiffres
  • lire
  • format de l'heure
  • année pivot à deux chiffres
  • écrire au format propre aux paramètres régionaux
  • tri
Sujet parent : Préférences de Portrait Miner


Formats de date

En travaillant avec des fichiers texte et des expressions FDL, vous pouvez spécifier comment Portrait Miner doit interpréter ou exporter les dates et les heures en utilisant soit un format de date standard [voir Formats de date standard], soit un format de date personnalisé [voir Formats de date personnalisés].

Voir également

Définition du format d'affichage des valeurs numériques et de date
Sujet parent : Formatage de la date

Formats de date standard

Nom | Format de date
Américain | MM/JJ/AAAA:hh:mm:ss, par exemple, 12/31/2000:13:36:59
Européen | JJ/MM/AAAA:hh:mm:ss, par exemple, 31/12/2000:13:36:59
AMJ | AAAA/MM/JJ:hh:mm:ss, par exemple, 2000/12/31:13:36:59
Remarque :
  • Les trois formats standard de date s'appliquent également aux dates sans composant horaire et aux heures pures (« dates » ayant seulement un composant horaire). Pour les formats date uniquement et heure uniquement, les parties date et heure sont respectivement omises.
  • Les formats Américain, Européen et AMJ englobent également les données sous la forme MMJJAAAA, JJMMAAAA et AAAAMMJJ, respectivement (pour l'entrée uniquement).

Formats de date personnalisés

Vous pouvez spécifier un format de date en utilisant des codes de caractères spéciaux commençant chacun par le signe pourcentage % :
Code | Composant d'une date formatée
%% | Le signe pourcent lui-même : "%"
%? | Correspond à tout caractère unique
%* | Correspond à tout nombre de caractères, par exemple, pour ignorer les caractères suivants, utiliser %Y/%m/%d%*
%a | Le nom du jour sous sa forme abrégée (« Lun », « Mar », ..., « Dim »)
%A | Le nom du jour en entier (« Lundi », « mardi », ..., « Dimanche »)
%b | Le nom du mois sous sa forme abrégée (« Jan », « Fév », ..., « Déc »)
%B | Le nom du mois en entier (« Janvier », « Février », ..., « Décembre »)
%c | (Entrée) Équivalent à « %a %b %e %T %Y » (Sortie) La date et l'heure dans la représentation standard de localisation en cours
%C | Équivalent à « %a %b %e %T %Z %Y »
%d | Le jour du mois, avec deux chiffres (« 01 », « 02 », ..., « 31 »)
%D | Équivalent à « %m/%d/%y »
%e | Le jour du mois, avec uniquement des chiffres précédés par un espace (« 1 », « 2 », ..., « 31 »)
%h | Équivalent à « %b »
%H | L'heure de la journée avec des jours de 24 heures (« 00 », « 02 », ..., « 23 »)
%I | L'heure de la journée avec des jours de 12 heures (« 01 », « 02 », ..., « 12 »)
%j | Le jour de l'année avec trois chiffres (calendrier Julien) (« 001 », « 002 », ..., « 366 »)
%m | Le numéro du mois, avec deux chiffres (« 01 », « 02 », ..., « 12 »)
%M | La minute de l'heure, avec deux chiffres (« 00 », « 01 », ..., « 59 »)
%p | « AM » or « PM », en fonction de l'heure de la journée
%r | Équivalent à « %I:%M:%S %p »
%R | Équivalent à « %H:%M »
%S | La seconde des minutes, avec deux chiffres (« 00 », « 01 », ..., « 61 »)
%T | Équivalent à « %H:%M:%S »
%x | La date formatée selon la préférence classement x
%X | Équivalent à « %x »
%y | L'année dans le siècle, avec deux chiffres (« 00 », « 01 », ..., « 99 »)
%Y | L'année, format à quatre chiffres
%Z | Le nom du fuseau horaire des paramètres régionaux actifs
Remarque :
  • Pour utiliser « %D » ou « %y », vous devez également spécifier soit une année pivot, soit une année maximale future (mais pas les deux).

    Si vous définissez un pivot égal à une année valide Y, Portrait Miner interprète les années à deux chiffres comme étant des années comprises entre Y - 99 et Y. Par exemple, si vous définissez la préférence à 2077, Portrait Miner interprète les années à deux chiffres 76, 77 et 78 comme étant 2076, 2077 et 1978, respectivement.

    Si vous définissez une année future maximale égale à une valeur positive n et que l'année en cours est Y, Portrait Miner interprète toutes les années à deux chiffres comme étant des années entre Y + n - 99 et Y + n. Par exemple, si vous définissez la préférence à 50 et que l'année en cours est 2002, Portrait Miner interprète les années à deux chiffres 51, 52 et 53 comme étant 2051, 2052 et 1953, respectivement.

  • Si vous définissez utiliser le format local spécifique, les codes « %a », « %A », « %b », « %B », « %C », « %p », « %x », « %X » et « %Z » peuvent produire des résultats différents lors de l'affichage des dates (mais pas lors de leur interprétation).
  • De même que /, tout autre caractère (excepté pour le séparateur de champ ou le marqueur null) peut être utilisé en tant que séparateur dans la date.
  • Pour un format de date manquant de composant explicite de jour et de mois, vous pouvez spécifier une valeur par défaut avec le qualificatif « day » ou « month ».
  • Les codes de caractères spéciaux sont ceux de la fonction de bibliothèque standard C strftime.

Exemple R–1 : Chaînes de formatage de date

Exemple de date | Chaîne de format de date
02/04/2003 27/10/1940 | Européen
04/02/2003 10/27/1940 | Américain
2003/04/02 1940/10/27 | AMJ
02-Avr-2003 27-Oct-1940 | %d-%b-%Y
02 Avr 2003 27 Oct 1940 | ((%d %b %Y))
2003-04-02 13:25 1940-10-27 08:23 | ((%Y-%m-%d %H:%M))
2003-04-02:13:25 1940-10-27:08:23 | %Y-%m-%d:%H:%M
2 Avr 2003 27 Oct 1940 | ((%e %b %Y))
Avril 2, 2003 | ((%B %e, %Y))
02/04/2003 13:25 27/10/1940 08:23 | ((%d/%m/%Y %H:%M))
2003-04-02 13:25:15000000 | ((%Y-%m-%d %H:%M:%S%*))
Avril 02, 2003 | ((%B %d, %Y))
2-Avr-2003 27-Oct-1940 | %e-%b-%Y
02/04/03 27/10/40 | (pivot européen=2010)
04/02/03 10/27/40 | (pivot américain=2010)
03/04/02 40/10/27 | (pivot AMJ=2010)
02-Avr-03 27-Oct.-40 | (%d-%b-%y pivot=2010)
Avril 02, 03 | ((%B %d, %y) pivot=2010)
2-Avr-03 27-Oct.-03 | (%e-%b-%y pivot=2010)
Avril 2, 03 | ((%B %e, %y) pivot=2010)
01:25 PM 08:23 | ((%I:%M %p))
13:25 08:23 | %H:%M

Voir également

index de jour par défaut pour dates incomplètes

index de mois par défaut pour dates incomplètes

futur maximal pour années à deux chiffres

année pivot à deux chiffres


format de la date

Section Format de date

Objectif Définir le format à utiliser dans des fichiers texte et des expressions SDL pour l'écriture de dates incluant un composant d'heure.

Valeurs valides

Valeur | Description
Américain | Écrire les dates au format MM/JJ/AAAA.
Européen (par défaut) | Écrire les dates au format JJ/MM/AAAA.
AMJ | Écrire les dates au format AAAA/MM/JJ.
Une chaîne de format de date [voir Formats de date personnalisés] | Écrire les dates à un format personnalisé.
Remarque :

Vous devez normalement définir les préférences format de la date, format intégral et format de l'heure à la même valeur.

Voir également

lire
Sujet parent : Formatage de la date


index de jour par défaut pour dates incomplètes

Section Format de date

Objectif Définir le jour du mois pour les dates, en fichiers texte et expressions FDL, auxquelles il manque un composant de jour explicite.

Valeurs valides Un entier entre 1 et 31 inclus, par défaut 1

Remarque :
  • Ce paramètre s'applique lorsque Portrait Miner convertit du texte en date d'après un format de date [voir Formats de date personnalisés] tel que « %Y%M ».
  • Pour un fichier texte ou un champ, vous pouvez écraser le paramètre avec le mot clé day.

Voir également

index de mois par défaut pour dates incomplètes
Sujet parent : Formatage de la date


index de mois par défaut pour dates incomplètes

Section Format de date

Objectif Définir le mois de l'année pour les dates, en fichiers texte et expressions FDL, auxquelles il manque un composant de mois explicite.

Valeurs valides Un entier entre 1 et 12 inclus, par défaut 1

Remarque :
  • Ce paramètre s'applique lorsque Portrait Miner convertit un texte en date d'après un format de date [voir Formats de date personnalisés] comme « %Y ».
  • Pour un fichier texte ou un champ individuel, vous pouvez écraser le paramètre avec le mot clé month.

Voir également

index de jour par défaut pour dates incomplètes
Sujet parent : Formatage de la date


format intégral

Section Format de date

Objectif Définir le format à utiliser dans des fichiers texte et des expressions SDL pour le formatage de dates incluant un composant d'heure.

Valeurs valides

Valeur | Description
Américain | Formate les dates en MM/JJ/AAAA:hh:mm:ss.
Européen (par défaut) | Formate les dates en JJ/MM/AAAA:hh:mm:ss.
AMJ | Formate les dates en AAAA/MM/JJ:hh:mm:ss.
Une chaîne de format de date [voir Formats de date personnalisés] | Formate les dates à un format personnalisé.
Remarque :

Vous devez normalement définir les préférences format intégral, format de la date et format de l'heure à la même valeur.

Voir également

lire
Sujet parent : Formatage de la date


futur maximal pour années à deux chiffres

Section Format de date

Objectif Contrôler l'interprétation d'années à deux chiffres dans des fichiers texte et dans des expressions FDL, à l'aide d'une année pivot glissante correspondant à l'année en cours.

Valeurs valides Un entier entre 0 et 99 inclus, ou (par défaut ) -1

Remarque :
  • Ce paramètre s'applique aux codes de format de date « %D » et « %y » [voir Formats de date personnalisés].
  • Pour un fichier texte ou un champ individuel, vous pouvez écraser le paramètre avec le mot clé future.

Voir également

année pivot à deux chiffres
Sujet parent : Formatage de la date


lire

Section Format de date

Objectif Définir le format par défaut utilisé pour l'interprétation des dates en fichiers textes et expressions FDL.

Valeurs valides

Valeur | Description
Américain | Interprète les dates en MM/JJ/AAAA:hh:mm:ss.
Européen (par défaut) | Interprète les dates en JJ/MM/AAAA:hh:mm:ss.
AMJ | interprète les dates en AAAA/MM/JJ:hh:mm:ss.
Une chaîne de format de date [voir Formats de date personnalisés] | interprète les dates à un format personnalisé.
Remarque :

Lorsque Portrait Miner interprète une date dans un fichier texte, il utilise le format donné par ce paramètre de préférence, à moins d'inclure une spécification de format implicite dans le fichier texte de description de données.

Voir également

format de la date

format intégral

format de l'heure

Sujet parent : Formatage de la date


format de l'heure

Section Format de date

Objectif Définir le format à utiliser dans des fichiers texte et des expressions FDL pour écrire les heures (c'est à dire, dates ayant seulement les composants heure, minute et seconde).

Valeurs valides

Valeur | Description
Américain | Écrit l'heure au format hh:mm:ss.
Européen (par défaut) | Écrit l'heure au format hh:mm:ss.
AMJ | Écrit l'heure au format hh:mm:ss.
Une chaîne de format de date [voir Formats de date personnalisés] | Écrit les heures à un format personnalisé.
Remarque :

Vous devez normalement définir les préférences format de l'heure, format de la date et format intégral à la même valeur.

Voir également

lire
Sujet parent : Formatage de la date


année pivot à deux chiffres

Section Format de date

Objectif Contrôler l'interprétation d'années à deux chiffres dans des fichiers texte et dans des expressions FDL, à l'aide d'une année pivot fixe.

Valeurs valides Un entier positif (une année) ou (par défaut) -1

Remarque :
  • Ce paramètre s'applique aux codes de format de date « %D » et « %y » [voir Formats de date personnalisés].
  • Pour un fichier texte ou un champ individuel, vous pouvez écraser le paramètre avec le mot clé pivot.

Voir également

futur maximal pour années à deux chiffres
Sujet parent : Formatage de la date


écrire au format propre aux paramètres régionaux

Section Format de date

Objectif Contrôler l'utilisation de formatage de date en fonction de paramètres régionaux, lors de l'utilisation de codes de formatage de date [voir Formats de date personnalisés] « %a », « %A », « %b », « %B », « %C », « %h », « %p », « %x », « %X » et « %Z. »

Valeurs valides

Valeur | Description
true | Utilise le formatage propre aux paramètres régionaux, y compris des noms de jours et de mois localisés.
false (par défaut) | Utilise un format de date standard, avec des noms de jours et de mois en anglais.
Remarque :

La valeur par défaut est false, car Portrait Miner ne peut actuellement pas interpréter des dates impliquant des noms de jours et de mois non anglais.

Sujet parent : Formatage de la date


tri

Section Format de date

Objectif Définir le format à utiliser pour l'interprétation ou l'affichage de dates lors de l'utilisation du code de format de date « %x » ou « %X » [voir Formats de date personnalisés].

Valeurs valides

Valeur | Description
Américain | Traite « %x » en tant que mois/jour/année.
Européen (par défaut) | Traite « %x » en tant que jour/mois/année.
AMJ | Traite « %x » en tant que année/mois/jour.
Sujet parent : Formatage de la date


Recherche de fichier

  • ACCUEIL
  • chargement de la carte
  • accueil qsexplorer
Sujet parent : Préférences de Portrait Miner


ACCUEIL

Section Environnement

Objectif Définir un emplacement d'« accueil » qui, à son tour, définit la valeur par défaut des différentes préférences de recherche de fichiers.

Valeurs valides L'emplacement d'un dossier/répertoire (sur le serveur Portrait Miner), par défaut non défini (donc il prend la valeur de la variable d'environnement du système d'exploitation du même nom, si elle est définie)

Sujet parent : Recherche de fichier


chargement de la carte

Section Répertoires

Objectif Définir l'emplacement initial affiché par Portrait Miner lorsque vous ouvrez une carte (avec l'extension de nom de fichier .mif).

Valeurs valides L'emplacement d'un répertoire/dossier (sur le serveur Portrait Miner), par défaut ext/maps (sous UNIX) ou ext\maps (sous Windows) dans le répertoire d'installation de Portrait Miner

Sujet parent : Recherche de fichier


accueil qsexplorer

Section Répertoires

Objectif Définir l'emplacement initial que Portrait Miner affiche et auquel le bouton [image] dans Portrait Miner et chaque explorateur de fichier Portrait Miner mène.

Valeurs valides L'emplacement d'un répertoire/dossier (sur le serveur Portrait Miner), par défaut l'emplacement de la préférence HOME

Sujet parent : Recherche de fichier


Fichiers texte

  • approximation du seuil (%)
  • format de la date pour échantillon
  • taille de l'échantillon
  • lignes vides
  • nombre maximal d'erreurs d'extraction
  • nombre maximal d'avertissements d'extraction
  • ignorer les avertissements d'extraction
  • taille maximale d'enregistrement (en mégaoctets)
  • autoriser les erreurs de format de données
Sujet parent : Préférences de Portrait Miner


approximation du seuil (%)

Section Base de données du fichier texte

Objectif Définir la proportion minimale d'enregistrements d'échantillon nécessaires pour affecter un type de données non génériques [voir Types de données] à un champ dans un fichier texte.

Valeurs valides Un nombre réel compris entre 1 et 100, par défaut 99

Si les types de données des champs dans un fichier texte ne sont pas spécifiés, Portrait Miner lit les enregistrements de l'échantillon pour les affecter. Pour chaque champ, s'il n'y a aucun type numérique ou date s'appliquant au moins au pourcentage donné des enregistrements de l'échantillon, un type de données chaîne est assigné à la place. Pour chaque champ contenant des données numériques, si le type entier ne s'applique pas au moins au pourcentage donné des enregistrements de l'échantillon, un type de données réel est assigné à la place.

Remarque :

Afin de garantir l'attribution des types de données qui s'appliquent à chaque enregistrement dans un fichier texte, configurez cette préférence et la taille de l'échantillon à leurs valeurs maximales.

Sujet parent : Fichiers texte


format de la date pour échantillon

Section Base de données du fichier texte

Objectif Définir le nombre d'enregistrements d'échantillon lus par Portrait Miner à partir d'un fichier texte pour déterminer le séparateur de champs, les marqueurs de chaîne et de date et les noms de champ, au cours de la phase initiale de l'analyse d'un fichier texte.
Remarque : La préférence « format de la date pour échantillon » n'est utilisée qu'en l'absence de fichier FDD (description du fichier texte).

Valeurs valides Un entier compris entre 1 et 100 000 inclus, par défaut 100

Si le format de données d'un fichier texte n'est pas indiqué, Portrait Miner lit les enregistrements de l'échantillon pour le déterminer.

Sujet parent : Fichiers texte


taille de l'échantillon

Section Base de données du fichier texte

Objectif Définir le nombre d'enregistrements d'échantillon que Portrait Miner lit à partir d'un fichier texte afin de déterminer les types de données finales [voir Types de données] des champs.
Remarque : La préférence « taille de l'échantillon » n'est utilisée qu'en l'absence de fichier FDD (description du fichier texte).

Valeurs valides Un entier positif, par défaut 1 000

Remarque :

Si vous importez des données directement à partir de la sortie du programme (c'est-à-dire, via un « canal »), les enregistrements de l'échantillon sont ceux du début du flux de données ; sinon Portrait Miner prend des enregistrements d'échantillon qui sont répartis à travers l'ensemble du fichier texte.

Voir également

format de la date pour échantillon
Sujet parent : Fichiers texte


lignes vides

Section Base de données du fichier texte

Objectif Contrôler le traitement d'une ligne vide lors de la lecture d'un fichier texte dans Portrait Miner.

Valeurs valides

Valeur | Description
ignorer avec avertissement (par défaut) | Ignorer la ligne, mais produire un avertissement.
ignorer en silence | Ignorer la ligne, sans produire d'avertissement.
Null | Créer un enregistrement pour la ligne, comprenant la valeur null [voir La valeur null] dans tous les champs.
Sujet parent : Fichiers texte


nombre maximal d'erreurs d'extraction

Section Base de données du fichier texte

Objectif Définir le nombre maximal d'erreurs de format de données autorisé par Portrait Miner lors de la lecture d'un fichier texte.

Valeurs valides Un entier positif, par défaut 1 000 000

Si le nombre d'erreurs dépasse cette valeur, Portrait Miner rejette le fichier texte comme illisible et abandonne l'importation.

Remarque :

Si vous utilisez la commande data build qsimportflat de Portrait Miner, vous pouvez écraser ce paramètre avec l'option - maxerrors.

Voir également

nombre maximal d'avertissements d'extraction

autoriser les erreurs de format de données

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Sujet parent : Fichiers texte


nombre maximal d'avertissements d'extraction

Section Base de données du fichier texte

Objectif Définir le nombre maximal d'avertissements de format de données autorisé par Portrait Miner lors de la lecture d'un fichier texte.

Valeurs valides Un entier positif, par défaut 1 000 000

Si le nombre d'avertissements dépasse cette valeur, Portrait Miner rejette le fichier texte comme illisible et abandonne l'importation.

Remarque :

Si vous utilisez la commande data build qsimportflat de Portrait Miner, vous pouvez remplacer ce paramètre avec l'option - maxwarnings.

Voir également

nombre maximal d'erreurs d'extraction

ignorer les avertissements d'extraction

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Sujet parent : Fichiers texte


ignorer les avertissements d'extraction

Section Base de données du fichier texte

Objectif Contrôler si Portrait Miner signale les messages d'avertissement de format de données (et compare le nombre total d'avertissements à la préférence nombre maximal d'avertissements d'extraction) lors de la lecture d'un fichier texte.

Valeurs valides

Valeur | Description
true | Ne pas signaler de messages d'avertissement.
false (par défaut) | Signaler des messages d'avertissement.
Remarque :
  • Portrait Miner signale toujours les messages d'erreur, et le nombre total de messages d'avertissement.
  • Si vous utilisez la commande data build qsimportflat de Portrait Miner, vous pouvez remplacer ce paramètre avec l'option - nowarnings.

Voir également

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Sujet parent : Fichiers texte


taille maximale d'enregistrement (en mégaoctets)

Section Base de données du fichier texte

Objectif Définir la quantité maximale de données (en mégaoctets) que Portrait Miner écrit dans un seul fichier lors de l'exportation sous format texte en utilisant un fichier texte de description des données (FDD).

Valeurs valides Un nombre entier supérieur à 1, par défaut 2 048

Lorsque la quantité de données écrites dans un fichier de données atteint cette limite, Portrait Miner crée un nouveau fichier de données et ajoute une référence de fichier supplémentaire dans le fichier FDD.

Remarque :
  • Portrait Miner ignore le paramètre de cette préférence lors de l'exportation sous format texte sans utiliser de fichier FDD.
  • Afin de s'assurer que Portrait Miner n'écrit les données que dans un fichier unique, même lors de l'utilisation d'un fichier FDD, modifiez la valeur $MAXLARGEFILESIZEMB.
Sujet parent : Fichiers texte


autoriser les erreurs de format de données

Section Base de données du fichier texte

Objectif Contrôler le comportement de Portrait Miner lorsqu'il rencontre des erreurs de format de données dans des fichiers texte.

Valeurs valides

Valeur | Description
true (par défaut) | Traiter les erreurs de format de données comme des avertissements.
false | Traiter les erreurs de format de données comme des erreurs.

Voir également

nombre maximal d'erreurs d'extraction

nombre maximal d'avertissements d'extraction

Sujet parent : Fichiers texte


Bases de données

  • conserver les types numériques lors de l'importation
  • Représenter des entiers importants sous forme de chaîne de caractères
Sujet parent : Préférences de Portrait Miner


conserver les types numériques lors de l'importation

Section Base de données

Objectif Déterminer le type de données [voir Types de données] que Portrait Miner utilise pour un champ lors de l'importation de valeurs numériques à une précision de plus de 15 chiffres depuis une base de données.

Valeurs valides

Valeur | Description
true (par défaut) | Utiliser le type de données réelles, en conservant les 15 chiffres les plus significatifs et en rejetant le reste.
false | Utiliser une représentation de chaîne pour conserver la précision de l'original (au moins jusqu'au deuxième chiffre significatif).
Sujet parent : Bases de données


Représenter des entiers importants sous forme de chaîne de caractères

Section Base de données

Objectif Déterminer le type de données [voir Types de données] que Portrait Miner utilise pour représenter un champ entier qui contient des nombres trop grands pour être représentés par des entiers de 32 bits (entiers inférieurs à -2 147 483 647 ou supérieurs à 2 147 483 646) lors de l'importation à partir d'une base de données ou d'un fichier texte.

Valeurs valides

Valeur | Description
true (par défaut) | Utilisez le type de données chaîne.
false | Utilisez le type de données réel.
Sujet parent : Bases de données


Audits et synthèses

  • backgroundcolor
  • backgroundtexture
  • barcolor
  • barstyle
  • errorbars
  • globalbarscale
  • globalpointscale
  • graph3deffect
  • graphshadow
  • imageheight
  • zoompointscale
Sujet parent : Préférences de Portrait Miner


backgroundcolor

Section Audits et synthèses

Objectif Contrôler la couleur de l'arrière-plan des images dans Profil et audits et Synthèses de modèle.

Valeurs valides Une chaîne de texte, par défaut « blanc »

Vous pouvez spécifier un nom de couleur compatible SVG http://www.w3.org (comme « rouge brique ») ou une valeur hexadécimale RVB (comme « #2244FF »).

Voir également

backgroundtexture

barcolor

barstyle

errorbars

globalbarscale

globalpointscale

graph3deffect

graphshadow

imageheight

zoompointscale

Sujet parent : Audits et synthèses


backgroundtexture

Section Audits et synthèses

Objectif Contrôler l'utilisation de la texture de l'arrière-plan des images dans Profil et audits et Synthèses de modèle (format SVG uniquement).

Valeurs valides

Valeur | Description
true | Utiliser une texture d'arrière-plan.
false (par défaut) | Ne pas utiliser de texture d'arrière-plan.

Voir également

backgroundcolor

barcolor

barstyle

errorbars

globalbarscale

globalpointscale

graph3deffect

graphshadow

imageheight

zoompointscale

Sujet parent : Audits et synthèses


barcolor

Section Audits et synthèses

Objectif Contrôler la couleur des barres des graphiques à barres dans Profil et audits et Synthèses de modèle.

Valeurs valides Une chaîne de texte, par défaut « #9999FF » (lilas)

Vous pouvez spécifier un nom de couleur compatible SVG http://www.w3.org (comme « rouge brique ») ou une valeur hexadécimale RVB (comme « #2244FF »).

Voir également

backgroundcolor

backgroundtexture

barstyle

errorbars

globalbarscale

globalpointscale

graph3deffect

graphshadow

imageheight

zoompointscale

Sujet parent : Audits et synthèses


barstyle

Section Audits et synthèses

Objectif Contrôler le style des barres des graphiques à barres et des segments des arbres de décision dans Profil et audits et Synthèses de modèle.

Valeurs valides

Valeur | Description
brut (par défaut) | Donnez aux barres ou aux segments une apparence brute, angulaire.
arrondi | Donnez aux barres ou aux segments une apparence arrondie.
gaufré | Donnez aux barres ou aux segments une apparence en relief, gaufrée.

Voir également

backgroundcolor

backgroundtexture

barcolor

errorbars

globalbarscale

globalpointscale

graph3deffect

graphshadow

imageheight

zoompointscale

Sujet parent : Audits et synthèses


errorbars

Section Audits et synthèses

Objectif Contrôler l'utilisation des barres d'erreur dans les graphiques à barres dans Profil et audits et Synthèses de modèle.

Valeurs valides

Valeur | Description
true (par défaut) | Placer les barres d'erreur sur des points de données.
false | Ne pas placer de barres d'erreur sur des points de données.

Voir également

backgroundcolor

backgroundtexture

barcolor

barstyle

globalbarscale

globalpointscale

graph3deffect

graphshadow

imageheight

zoompointscale

Sujet parent : Audits et synthèses


globalbarscale

Section Audits et synthèses

Objectif Contrôler l'échelle relative des axes horizontaux des graphiques à barres dans Profil et audits et Synthèses de modèle.

Valeurs valides

Valeur | Description
true | Utiliser la même échelle d'axe horizontal pour tous les graphiques dans chaque Profil et audits et Synthèse de modèle.
false (par défaut) | Ne pas faire la même échelle d'axe horizontal pour tous les graphiques dans chaque Profil et audits et Synthèse de modèle.

Voir également

backgroundcolor

backgroundtexture

barcolor

barstyle

errorbars

globalpointscale

graph3deffect

graphshadow

imageheight

zoompointscale

Sujet parent : Audits et synthèses


globalpointscale

Section Audits et synthèses

Objectif Contrôler l'échelle relative des axes verticaux des graphiques à barres dans Profil et audits et Synthèses de modèle.

Valeurs valides

Valeur | Description
true (par défaut) | Utiliser la même échelle d'axe vertical pour tous les graphiques dans chaque Profil et audits et Synthèse de modèle.
false | Ne pas faire la même échelle d'axe vertical pour tous les graphiques dans chaque Profil et audits et Synthèse de modèle.

Voir également

backgroundcolor

backgroundtexture

barcolor

barstyle

errorbars

globalbarscale

graph3deffect

graphshadow

imageheight

zoompointscale

Sujet parent : Audits et synthèses


graph3deffect

Section Audits et synthèses

Objectif Contrôler le style des barres des graphiques à barres dans Profil et audits et Synthèses de modèle.

Valeurs valides

Valeur | Description
true | Utiliser des barres en trois dimensions.
false (par défaut) | Utiliser des barres en deux dimensions.

Voir également

backgroundcolor

backgroundtexture

barcolor

barstyle

errorbars

globalbarscale

globalpointscale

graphshadow

imageheight

zoompointscale

Sujet parent : Audits et synthèses


graphshadow

Section Audits et synthèses

Objectif Contrôler le style des barres des graphiques à barres et des segments des arbres de décision dans Profil et audits et Synthèses de modèle.

Valeurs valides

Valeur | Description
true | Créer un effet d'ombre.
false (par défaut) | Ne pas créer d'effet d'ombre.

Voir également

backgroundcolor

backgroundtexture

barcolor

barstyle

errorbars

globalbarscale

globalpointscale

graph3deffect

imageheight

zoompointscale

Sujet parent : Audits et synthèses


imageheight

Section Audits et synthèses

Objectif Contrôler la hauteur (en pixels) des images créées pour Profil et audits et Synthèses de modèle. Le ratio d'aspect de l'image est fixe.

Valeurs valides Un nombre entier positif, par défaut 300

Voir également

backgroundcolor

backgroundtexture

barcolor

barstyle

errorbars

globalbarscale

globalpointscale

graph3deffect

graphshadow

zoompointscale

Sujet parent : Audits et synthèses


zoompointscale

Section Audits et synthèses

Objectif Contrôler la plage de l'axe vertical des graphiques à barres dans Profil et audits et Synthèses de modèle.

Valeurs valides

Valeur | Description
true | Définir la plage de l'axe selon celle des points de données.
false (par défaut) | Définir la plage de l'axe selon celle des points de données augmentée de zéro.

Voir également

backgroundcolor

backgroundtexture

barcolor

barstyle

errorbars

globalbarscale

globalpointscale

graph3deffect

graphshadow

imageheight

Sujet parent : Audits et synthèses


Notification e-mail

  • emailaddress
  • emailserver
Sujet parent : Préférences de Portrait Miner


emailaddress

Section E-mail

Objectif Définir l'adresse électronique à laquelle les messages de notification sont envoyés.

Valeurs valides Une chaîne de caractères, par défaut non définie (aucun e-mail n'est alors envoyé).

Il s'agit d'une adresse électronique valide ou d'une liste d'adresses électroniques valides séparées par des virgules ; par exemple, moi@masociete.com.

Remarque :

Pour insérer une virgule littérale dans une adresse électronique, utilisez le texte ${COMMA}.

Voir également

emailserver

Sujet parent : Notification e-mail


emailserver

Section E-mail

Objectif Définir le serveur de messagerie via lequel les courriers électroniques de notification sont envoyés.

Valeurs valides Une chaîne de caractères, par défaut non définie (aucun e-mail n'est alors envoyé).

Il s'agit de l'adresse d'un serveur SMTP, par exemple, smtp.masociete.com.

Voir également

emailaddress

Sujet parent : Notification e-mail


Paramétrage du système et administration

  • bibliothèques de calcul
  • limite mémoire du fichier
  • nombre maximal de processeurs en parallèle
  • parallélisme
Sujet parent : Préférences de Portrait Miner


bibliothèques de calcul

Section Fonctions

Objectif Spécifier les emplacements des bibliothèques de fonctions FDL tierces ou définies par l'utilisateur (avec l'extension de nom de fichier .fdl).

Valeurs valides Une liste d'emplacements de fichiers/répertoires/dossiers (sur le serveur Portrait Miner) séparés par des virgules, par défaut non définis.

Lorsque Decision Studio démarre, il ouvre les bibliothèques de fonctions explicitement énumérées ainsi que celles contenues dans les répertoires/dossiers (et tous les sous-dossiers) répertoriés, rendant les fonctions qui y sont définies disponibles et utilisables dans l'Aperçu du tableau.

Remarque :

Pour insérer une virgule littérale dans un nom de fichier/répertoire/dossier, utilisez le texte ${COMMA}.

Sujet parent : Paramétrage du système et administration


limite mémoire du fichier

Il n'est pas recommandé de modifier ce paramètre

Cette limite est définie de façon dynamique par Portrait Miner, vous ne devez pas apporter de modifications à cette limite avant d'avoir consulté le support technique de Portrait Miner.

Section Mise au point du système

Objectif Définir une limite conditionnelle (« soft ») d'usage de la mémoire (en mégaoctets).

Valeurs valides Un entier supérieur ou égal à 16. Par défaut, une valeur déterminée pendant l'exécution à partir de la quantité totale de mémoire physique disponible et des limites de la mémoire du système d'exploitation de Portrait Miner. Si vous exécutez la version 64-bit de Portrait Miner, la quantité maximale de mémoire disponible a pour seule limite la mémoire physique de la machine. Si vous exécutez la version 32-bit de Portrait Miner, la quantité maximale de mémoire disponible est limitée à 2 Go.

Remarque :

Cette limite s'applique à Decision Studio ainsi qu'à certaines commandes de construction de données (ainsi que leurs interfaces utilisateur graphiques associées). Il s'agit d'une limite conditionnelle de mémoire (soft) car cette limite peut être dépassée, même si les performances du système peuvent en souffrir.

Si la limite est dépassée de 20 % ou plus dans Decision Studio, une fenêtre pop-up en avertira l'utilisateur.

Si la limite est dépassée de 20 % ou plus au cours de l'exécution d'une commande de manipulation des données, un avertissement sera consigné dans stderr (et aussi dans un fichier journal, si un tel fichier est utilisé).

Si vous utilisez Portrait Miner Desktop, cette limite est gérée de façon dynamique et ne devrait jamais exiger de réglage.

Voir également

parallélisme

Sujet parent : Paramétrage du système et administration


nombre maximal de processeurs en parallèle

Section Mise au point du système

Objectif Indiquer le nombre maximal de processeurs utilisés (sur le serveur Portrait Miner) par une session utilisateur Decision Studio ou par une commande data build (ainsi que par toute fonction de Portrait Miner exécutée via une commande data build).

Valeurs valides Un entier positif. Par défaut, le nombre de processeurs disponibles.

Voir également

parallélisme

Sujet parent : Paramétrage du système et administration


parallélisme

Section Mise au point du système

Objectif Indiquer le nombre de processeurs utilisés par défaut (sur le serveur Portrait Miner) par une session utilisateur Decision Studio ou par une commande data build (ainsi que par toute fonction de Portrait Miner exécutée via une commande data build). Dans certaines circonstances, les utilisateurs peuvent choisir d'augmenter (ou de diminuer) ce nombre lors de l'exécution.

Valeurs valides Un entier positif. Par défaut, 1. Cette valeur ne peut pas être supérieure au paramètre de la préférence de nombre maximal de processeurs en parallèle.

Sujet parent : Paramétrage du système et administration


Temps réel et intégration des systèmes

  • fichier journal admin
  • période d'actualisation du cache
  • activer l'enregistrement d'administration
  • activer l'enregistrement d'évaluation
  • avant ... lecture, après... écriture
  • seuil d'avertissement des règles expiré
  • exporter un élément de menu XML
  • emplacement d'exécution externe du hook
  • période flush du tampon d'enregistrement
  • utilisation de mémoire maximale du tampon d'enregistrement
  • taille du tampon d'enregistrement
  • règle stocker enregistrer
  • emplacement de l'état du serveur
Sujet parent : Préférences de Portrait Miner


fichier journal admin

Ce paramètre est destiné à une utilisation experte et ne doit normalement pas être modifié par l'administrateur Portrait Miner.

Section Actionhouse RT

Objectif Le chemin vers le fichier journal d'administration en temps réel utilisé pour consigner tous les événements d'administration du serveur. Il n'est utilisé que si activer l'enregistrement d'administration est activé.

Valeurs valides L'emplacement d'un dossier/répertoire (sur le serveur Portrait Miner), par défaut non défini

Sujet parent : Temps réel et intégration des systèmes


période d'actualisation du cache

Ce paramètre est destiné à une utilisation experte et ne doit normalement pas être modifié par l'administrateur Portrait Miner.

Section Actionhouse RT

Objectif Le temps en secondes entre les événements de rafraîchissement automatique de la règle à partir des clients en temps réel. Un client interroge le serveur périodiquement avec cette période de rafraîchissement, pour permettre la duplication des redéfinitions ou suppressions de règle.

Valeurs valides Un nombre entier, par défaut 3600

Sujet parent : Temps réel et intégration des systèmes


activer l'enregistrement d'administration

Section Actionhouse RT

Objectif Activer ou désactiver l'enregistrement d'administration en temps réel.

Valeurs valides

Valeur | Description
true | Activer l'enregistrement d'administration
false (par défaut) | Désactiver l'enregistrement d'administration

Voir également

fichier journal admin
Sujet parent : Temps réel et intégration des systèmes


activer l'enregistrement d'évaluation

Ce paramètre est destiné à une utilisation experte et ne doit normalement pas être modifié par l'administrateur Portrait Miner.

Section Actionhouse RT

Objectif Activer ou désactiver l'enregistrement d'évaluation en temps réel.

Valeurs valides

Valeur | Description
true (par défaut) | Activer l'enregistrement d'évaluation
false | Désactiver l'enregistrement d'évaluation

Voir également

Sujet parent : Temps réel et intégration des systèmes


avant ... lecture, après... écriture

Section Hooks d'exécution externe

Objectif Spécifiez une commande que Portrait Miner exécute avant de lire ou d'écrire dans les fichiers du type donné.

Valeurs valides Une chaîne de texte, par défaut non définie

Portrait Miner exécute la commande spécifiée avant de lire à partir de ou après l'écriture d'un fichier du type donné. Le chemin complet du fichier est ajouté à la commande en tant qu'argument.

Remarque :
Une commande dans un hook d'exécution s'exécute dans un environnement dont il hérite de Portrait Miner, sauf :
  • Le chemin est augmenté afin d'inclure les utilitaires de ligne de commande.
  • Vous pouvez supprimer le répertoire/dossier de travail hérité à l'aide de la préférence emplacement d'exécution externe du hook.

Il est toujours plus prudent de spécifier le chemin complet vers l'exécutable ou de définir l'emplacement externe du hook d'exécution. En particulier, Windows recherche le répertoire courant pour les exécutables avant de chercher le chemin, ce qui peut générer des résultats inattendus.

Types de fichiers avec des hooks d'exécution

Nom de préférence | Type de fichier | Lire | Ecrire
découpage | Fichier de découpage Decision Studio (.bng) |  |
hiérarchie de catégorie | fichier .hrc |  |
cluster | fichier de modèle de classification |  |
configuration | Fichier de préférence (qs.ini) |  |
tableau croisé | Ne pas utiliser. |  |
données | Ne pas utiliser. |  |
base de données | Un tableau de base de données (spécifié comme un paramètre à la commande DRL, voir Script pour qstml pour plus d'informations sur les DRL) |  |
arbre de décision | fichier .qsdt ou .dt |  |
calcul | fichier bibliothèque de fonction FDL (.fdl) |  |
description de données texte | fichier .fdd |  |
données texte | fichier de données texte |  |
fichier texte | fichier texte (spécifié comme un paramètre de fichier (FDD) de description de données texte à la commande, si vous écrivez un fichier texte et avez demandé qu'un fichier FDD soit créé, sinon le paramètre contient à la place le nom du fichier de données texte). L'utilisation d'un fichier texte peut impliquer plusieurs fichiers individuels (un fichier de description de données texte et un ou plusieurs fichiers de données texte). La différence entre ce hook et les deux précédents est que la commande est exécutée une seule fois par opération (avant la lecture du premier fichier ou après l'écriture du dernier fichier), les hooks de niveau inférieur sont exécutés une fois par fichier individuel. |  |
focus | fichier .ftr (notez que lorsqu'un fichier focus est déplacé ou supprimé dans Portrait Miner ou avec qsremove ou qsmove, la commande est exécutée pour l'ancien fichier focus qui n'existe plus et pour le nouveau fichier focus une fois créé) |  |
HTML | fichier du tableau croisé HTML formaté |  |
enregistrement | fichier .log |  |
mappage | fichier de carte Decision Studio (.mid or .mif) |  |
modèle | fichier de modèle TML model (.tml) créé par Decision Studio |  |
qmml | fichier de modèle QMML model (.qmml) créé par Decision Studio |  |
tableau de bord | fichier .qssc ou .sc |  |
texte | Ne pas utiliser. |  |
Sujet parent : Temps réel et intégration des systèmes


seuil d'avertissement des règles expiré

Ce paramètre est destiné à une utilisation experte et ne doit normalement pas être modifié par l'administrateur Portrait Miner.

Section Actionhouse RT

Objectif Le nombre maximal de règles sur le serveur en temps réel qui peuvent être marquées comme « expirées », mais pas encore libérées par les clients. Si ce nombre est dépassé, un avertissement de ressources est écrit dans le journal des événements système (et, s'il est activé, le fichier journal d'administration en temps réel). Il s'agit habituellement une indication d'un client mal configuré ou écrasé.

Valeurs valides Un nombre entier, par défaut 10

Voir également

fichier journal admin
Sujet parent : Temps réel et intégration des systèmes


exporter un élément de menu XML

Section Actionhouse RT

Objectif Définir le texte qui apparaît dans l'option du menu Aperçu du tableau pour enregistrer les modèles QMML.

Valeurs valides Une chaîne de texte, par défaut « Exporter au format QMML... »

Sujet parent : Temps réel et intégration des systèmes


emplacement d'exécution externe du hook

Ce paramètre est destiné à une utilisation experte et ne doit normalement pas être modifié par l'administrateur Portrait Miner.

Section Répertoires

Objectif Spécifier le répertoire/dossier de travail pour les commandes sue Portrait Miner exécute via les hooks d'exécution [voir avant ... lecture, après... écriture].

Valeurs valides L'emplacement d'un dossier/répertoire (sur le serveur Portrait Miner), par défaut non défini

Si l'emplacement n'est pas défini, les commandes du hook d'exécution héritent leur répertoire/dossier de travail de Decision Studio.

Sujet parent : Temps réel et intégration des systèmes


période flush du tampon d'enregistrement

Ce paramètre est destiné à une utilisation experte et ne doit normalement pas être modifié par l'administrateur Portrait Miner.

Section Actionhouse RT

Objectif Voir Intégration et administration en temps réel.

Valeurs valides Un nombre entier, par défaut 5

Sujet parent : Temps réel et intégration des systèmes


utilisation de mémoire maximale du tampon d'enregistrement

Ce paramètre est destiné à une utilisation experte et ne doit normalement pas être modifié par l'administrateur Portrait Miner.

Section Actionhouse RT

Objectif Voir Intégration et administration en temps réel.

Valeurs valides Un nombre entier, par défaut 1024

Sujet parent : Temps réel et intégration des systèmes


taille du tampon d'enregistrement

Ce paramètre est destiné à une utilisation experte et ne doit normalement pas être modifié par l'administrateur Portrait Miner.

Section Actionhouse RT

Objectif Voir Intégration et administration en temps réel.

Valeurs valides Un nombre entier, par défaut 10

Sujet parent : Temps réel et intégration des systèmes


règle stocker enregistrer

Ce paramètre est destiné à une utilisation experte et ne doit normalement pas être modifié par l'administrateur Portrait Miner.

Section Répertoires

Objectif Définir l'emplacement par défaut pour enregistrer les modèles QMML (et activer cette fonction dans Decision Studio).

Valeurs valides L'emplacement d'un dossier/répertoire (sur le serveur Portrait Miner), par défaut non défini (afin que l'option de menu défini par la préférence exporter l'élément de menu XML n'apparaît pas dans Decision Studio)

Sujet parent : Temps réel et intégration des systèmes


emplacement de l'état du serveur

Ce paramètre est destiné à une utilisation experte et ne doit normalement pas être modifié par l'administrateur Portrait Miner.

Section Actionhouse RT

Objectif Le répertoire où le serveur stocke son état actif en temps réel. Lorsque le serveur démarre, il charge l'état de ce répertoire. Le serveur conserve une copie de son état en cours ici sur le disque pendant son exécution.

Valeurs valides L'emplacement d'un répertoire/dossier (sur le serveur Portrait Miner), par défaut shared/actionhouseRT (sous UNIX) ou shared\actionhouseRT (sous Windows) dans le répertoire d'installation de Portrait Miner

Sujet parent : Temps réel et intégration des systèmes


Fonctions d'agrégation

  • any
  • confintlower
  • confintupper
  • count
  • countnonnull/countnonnulls
  • countnull/countnulls
  • countunique
  • countuniquenonnull
  • expectedcount
  • expectedproportion
  • first
  • last
  • max (un seul argument)
  • mean (un argument)
  • median
  • min (un argument)
  • mode
  • moderatio
  • percentage
  • percentagerate
  • proportion
  • segindex
  • significance
  • stdev
  • sum (un argument)
  • variance


any

Objectif Prélever arbitrairement un valeur non null d'un champ (éventuellement par groupe ou par segment).

Syntaxe any(x)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | x | Le champ dans lequel choisir une valeur

Résultat

Type | Description
comme en entrée | Une valeur arbitraire non null dans le champ x (éventuellement par groupe ou par segment)
Remarque :

Vous ne pouvez pas utiliser cette fonction dans un calcul Decision Studio, dans le fichier des calculs pour qsderive ou la fenêtre Calculer des champs équivalente, dans le fichier de traceurs pour qstrack ou dans un fichier de sélections pour qsselect.

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

first

last

Sujet parent : Fonctions d'agrégation


confintlower

Objectif Calculer la limite inférieure d'un intervalle de confiance de 95% pour la moyenne d'un champ.

Syntaxe confintlower(x)

Arguments

Type | Nom | Description
numérique | x | Le champ à considérer

Résultat

Type | Description
réel | La limite inférieure d'un intervalle dans laquelle la population moyenne du segment d'un champ x risque de passer sous les 95% de confiance
Remarque :

Vous ne pouvez pas utiliser cette fonction dans un calcul Decision Studio, dans le fichier des calculs pour qsderive ou la fenêtre Calculer des champs équivalente, dans le fichier de traceurs pour qstrack ou dans un fichier de sélections pour qsselect.

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

confintupper

significance

Sujet parent : Fonctions d'agrégation


confintupper

Objectif Calculer la limite supérieure d'un intervalle de confiance de 95% pour la moyenne d'un champ.

Syntaxe confintupper(x)

Arguments

Type | Nom | Description
numérique | x | Le champ à considérer

Résultat

Type | Description
réel | La limite supérieure d'un intervalle dans laquelle la population moyenne du segment d'un champ x risque de passer sous les 95% de confiance
Remarque :

Vous ne pouvez pas utiliser cette fonction dans un calcul Decision Studio, dans le fichier des calculs pour qsderive ou la fenêtre Calculer des champs équivalente, dans le fichier de traceurs pour qstrack ou dans un fichier de sélections pour qsselect.

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

confintlower

significance

Sujet parent : Fonctions d'agrégation


count

Objectif Compter le nombre d'enregistrements (éventuellement par groupe ou segment).

Syntaxe count()

Arguments Aucun

Résultat

Type | Description
entier | Le nombre d'enregistrements (éventuellement par groupe ou segment).

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

countnonnull/countnonnulls

countnull/countnulls

countunique

countuniquenonnull

Sujet parent : Fonctions d'agrégation


countnonnull/countnonnulls

Objectif Compter le nombre d'enregistrements pour lesquels un champ a une valeur non null (éventuellement par groupe ou segment).

Syntaxe countnonnull(x)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | x | Le champ à considérer

Résultat

Type | Description
entier | Le nombre d'enregistrements pour lesquels le champ x a des valeurs définies (éventuellement par groupe ou segment)
Remarque :

Dans les tableaux croisés Decision Studio [voir Fonctions d'agrégation pour les tableaux croisés] et dans un contexte de mesure [voir Fonctions d'agrégation pour les mesures et les calculs], cette fonction est countnonnull, alors que dans un contexte de calcul, il s'agit de countnonnulls.

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

count

countnull/countnulls

countunique

countuniquenonnull

Sujet parent : Fonctions d'agrégation


countnull/countnulls

Objectif Compter le nombre d'enregistrements pour lesquels un champ contient la valeur null (éventuellement par groupe ou segment)

Syntaxe countnull(x)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | x | Le champ à considérer

Résultat

Type | Description
entier | Le nombre d'enregistrements pour lesquels le champ x est vide (éventuellement par groupe ou segment)
Remarque :

Dans les tableaux croisés Decision Studio [voir Fonctions d'agrégation pour les tableaux croisés] et dans un contexte de mesure [voir Fonctions d'agrégation pour les mesures et les calculs], cette fonction est countnull, alors que dans un contexte de calcul, il s'agit de countnulls.

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

count

countnonnull/countnonnulls

countunique

countuniquenonnull

Sujet parent : Fonctions d'agrégation


countunique

Objectif Compter le nombre d'occurrences de valeurs uniques dans un champ, incluant éventuellement la valeur null (éventuellement par groupe ou segment)

Syntaxe countunique(x)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | x | Le champ à considérer

Résultat

Type | Description
entier | Le nombre de valeurs uniques, y compris null, que l'on trouve dans x (éventuellement par groupe ou segment)
Remarque :

Vous ne pouvez pas utiliser cette fonction dans un calcul Decision Studio, dans le fichier des calculs pour qsderive ou la fenêtre Calculer des champs équivalente, dans le fichier de traceurs pour qstrack ou dans un fichier de sélections pour qsselect.

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

count

countnonnull/countnonnulls

countnull/countnulls

countuniquenonnull

Sujet parent : Fonctions d'agrégation


countuniquenonnull

Objectif Compter le nombre d'occurrences de valeurs uniques définies dans un champ (éventuellement par groupe ou segment).

Syntaxe countuniquenonnull(x)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | x | Le champ à considérer

Résultat

Type | Description
entier | Le nombre de valeurs uniques, sauf null, que l'on trouve dans x (éventuellement par groupe ou segment)
Remarque :

Vous ne pouvez pas utiliser cette fonction dans un calcul Decision Studio, dans le fichier des calculs pour qsderive ou la fenêtre Calculer des champs équivalente, dans le fichier de traceurs pour qstrack ou dans un fichier de sélections pour qsselect.

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

count

countnonnull/countnonnulls

countnull/countnulls

countunique

Sujet parent : Fonctions d'agrégation


expectedcount

Objectif Calculer la population « attendue » d'un segment de tableau croisé.

Syntaxe expectedcount()

Arguments Aucun

Résultat

Type | Description
réel | Le nombre d'enregistrement attendu pour un segment si les champs du tableau croisé sont indépendants les uns des autres
Remarque :

Vous ne pouvez utiliser cette fonction que dans les tableaux croisés Decision Studio [voir Fonctions d'agrégation pour les tableaux croisés] pour la visualisation des données.

Voir également

Fonctions d'agrégation pour les tableaux croisés

expectedproportion

Sujet parent : Fonctions d'agrégation


expectedproportion

Objectif Calculer la population « attendue » d'un segment de tableau croisé sous forme de proportion de la population totale.

Syntaxe expectedproportion()

Arguments Aucun

Résultat

Type | Description
réel | La proportion de la population attendue dans un segment si les champs du tableau croisé sont indépendants les uns des autres
Remarque :

Vous ne pouvez utiliser cette fonction que dans les tableaux croisés Decision Studio [voir Fonctions d'agrégation pour les tableaux croisés] pour la visualisation des données.

Voir également

Fonctions d'agrégation pour les tableaux croisés

expectedcount

Sujet parent : Fonctions d'agrégation


first

Objectif Prendre la première valeur définie dans un champ (éventuellement par groupe ou segment).

Syntaxe first(x)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | x | Le champ dans lequel choisir une valeur

Résultat

Type | Description
comme en entrée | La première valeur définie rencontrée dans un champ x (éventuellement par groupe ou segment)
Remarque :

Vous ne pouvez pas utiliser cette fonction dans un calcul Decision Studio, dans le fichier des calculs pour qsderive ou la fenêtre Calculer des champs équivalente, dans le fichier de traceurs pour qstrack ou dans un fichier de sélections pour qsselect.

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

any

last

Sujet parent : Fonctions d'agrégation


last

Objectif Prendre la dernière valeur définie dans un champ (éventuellement par groupe ou segment).

Syntaxe last(x)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | x | Le champ dans lequel choisir une valeur

Résultat

Type | Description
comme en entrée | La dernière valeur définie rencontrée dans un champ x (éventuellement par groupe ou segment)
Remarque :

Vous ne pouvez pas utiliser cette fonction dans un calcul Decision Studio, dans le fichier des calculs pour qsderive ou la fenêtre Calculer des champs équivalente, dans le fichier de traceurs pour qstrack ou dans un fichier de sélections pour qsselect.

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

any

first

Sujet parent : Fonctions d'agrégation


max (un seul argument)

Objectif Calculer la valeur définie maximale dans un champ (éventuellement par groupe ou segment).

Syntaxe max(x)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | x | Le champ dont les valeurs doivent être comparées

Résultat

Type | Description
comme en entrée | La valeur définie maximale dans un champ x (éventuellement par groupe ou segment)
Remarque :
  • Ne pas confondre cette fonction agrégation avec la fonction à argument multiple [voir max (deux arguments ou plus), maxnonnull] du même nom.
  • Dans un contexte de calcul, cette fonction n'accepte aucun champ contenant un argument de date ou de chaîne.

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

min (un argument)

Sujet parent : Fonctions d'agrégation


mean (un argument)

Objectif Calculer la moyenne (moyenne normale) des valeurs définies dans un champ (éventuellement par groupe ou segment).

Syntaxe mean(x)

Arguments

Type | Nom | Description
numérique | x | Le champ dont la moyenne doit être calculée

Résultat

Type | Description
réel | La moyenne des valeurs définies dans un champ x (éventuellement par groupe ou segment)
Remarque :

Ne pas confondre cette fonction agrégation avec la fonction à argument multiple [voir mean (deux arguments ou plus), meannonnull] du même nom.

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

median

mode

Sujet parent : Fonctions d'agrégation


median

Objectif Calculer la médiane (valeur moyenne) des valeurs définies dans un champ (éventuellement par groupe ou segment).

Syntaxe median(x)

Arguments

Type | Nom | Description
entier, réel ou chaîne | x | Le champ dont la médiane doit être calculée

Résultat

Type | Description
comme en entrée | La valeur médiane des valeurs définies dans un champ x (éventuellement par groupe ou segment)
Remarque :

Vous ne pouvez pas utiliser cette fonction dans un calcul Decision Studio, dans le fichier des calculs pour qsderive ou la fenêtre Calculer des champs équivalente, dans le fichier de traceurs pour qstrack ou dans un fichier de sélections pour qsselect.

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

mean (un argument)

mode

Sujet parent : Fonctions d'agrégation


min (un argument)

Objectif Calculer la valeur définie minimale dans un champ (éventuellement par groupe ou segment).

Syntaxe min(x)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | x | Le champ dont les valeurs doivent être comparées

Résultat

Type | Description
comme en entrée | La valeur définie minimale dans un champ x (éventuellement par groupe ou segment)
Remarque :
  • Ne pas confondre cette fonction agrégation avec la fonction à argument multiple [voir min (deux arguments ou plus), minnonnull] du même nom.
  • Dans un contexte de calcul, cette fonction n'accepte aucun champ contenant un argument de date ou de chaîne.

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

max (un seul argument)

Sujet parent : Fonctions d'agrégation


mode

Objectif Calculer le mode (valeur la plus commune) des valeurs définies dans un champ (éventuellement par groupe ou segment).

Syntaxe mode(x)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | x | Le champ dont le mode doit être calculé

Résultat

Type | Description
comme en entrée | Le mode des valeurs définies dans un champ x (éventuellement par groupe ou segment)
Remarque :
  • En cas d'égalité de la valeur la plus commune, la fonction revient au plus petit nombre d'égalisation, la première date d'égalisation ou la première chaîne d'égalisation par ordre alphabétique.
  • Vous ne pouvez pas utiliser cette fonction dans un calcul Decision Studio, dans le fichier des calculs pour qsderive ou la fenêtre Calculer des champs équivalente, dans le fichier de traceurs pour qstrack ou dans un fichier de sélections pour qsselect.

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

mean (un argument)

median

moderatio

Sujet parent : Fonctions d'agrégation


moderatio

Objectif Calculer la proportion d'enregistrements définis contenant la valeur la plus commune dans un champ (éventuellement par groupe ou segment).

Syntaxe moderatio(x)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | x | Le champ dont le ratio de mode doit être calculé

Résultat

Type | Description
réel | Le ration de mode du champ x (éventuellement par groupe ou segment)
Remarque :

Vous ne pouvez pas utiliser cette fonction dans un calcul Decision Studio, dans le fichier des calculs pour qsderive ou la fenêtre Calculer des champs équivalente, dans le fichier de traceurs pour qstrack ou dans un fichier de sélections pour qsselect.

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

mode

Sujet parent : Fonctions d'agrégation


percentage

Syntaxe percentage()

Objectif Calculer le nombre d'enregistrements dans un segment à double entrée, en pourcentage du total.

Arguments Aucun

Résultat

Type | Description
réel | Le pourcentage d'enregistrements (éventuellement par groupe ou segment)
Remarque :

Vous ne pouvez utiliser cette fonction que dans un calcul Decision Studio, dans le fichier de calculs de qsderive ou la fenêtre équivalente Calculer des champs, dans le fichier de traceurs de qstrack, ou dans un fichier de sélections de qsselect.

Voir également

Fonctions d'agrégation pour les mesures et les calculs

Sujet parent : Fonctions d'agrégation


percentagerate

Objectif Pour un champ binaire (1/0), calculer la proportion d'enregistrements définis contenant la valeur 1, en pourcentage.

Syntaxe percentagerate(x)

Arguments

Type | Nom | Description
numérique | x | Le champ binaire à considérer

Résultat

Type | Description
réel | Le pourcentage d'enregistrements dans un champ binaire ayant la valeur 1 (éventuellement par groupe ou segment)
Remarque :

Vous ne pouvez pas utiliser cette fonction dans un fichier d'agrégations [voir Utilisation des fonctions d'agrégation et des clauses where et default] ou fichier de statistiques [voir Evaluation des statistiques focus : l'instruction calculate] pour qsmeasure ou la fenêtre équivalente Agréger des entrées ou le fichier statistique pour qstrack.

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

Sujet parent : Fonctions d'agrégation


proportion

Objectif Calculer le nombre d'enregistrements par client ou par segment, sous forme de proportion du nombre total d'enregistrements.

Syntaxe proportion()

Arguments Aucun

Résultat

Type | Description
réel | Le nombre d'enregistrements pour un client ou dans un segment de tableau croisé, par rapport au nombre total d'enregistrements
Remarque :

Vous ne pouvez utiliser cette fonction que dans les tableaux croisés Decision Studio [voir Fonctions d'agrégation pour les tableaux croisés] pour la visualisation des données.

Voir également

Fonctions d'agrégation pour les tableaux croisés
Sujet parent : Fonctions d'agrégation


segindex

Objectif Générer un numéro indice représentant un segment.

Syntaxe segindex()

Arguments Aucun

Résultat

Type | Description
entier | Un nombre positif unique qui indique un segment dans un tableau croisé
Remarque :
  • Si les segments nuls, non classés ou vides sont cachés lors de l'affichage d'un tableau croisé, ils reçoivent quand même un indice de segment, donc il peut y avoir des espaces dans la séquence d'indices visibles.
  • Vous ne pouvez pas utiliser cette fonction dans un fichier d'agrégations [voir Utilisation des fonctions d'agrégation et des clauses where et default] ou fichier de statistiques [voir Evaluation des statistiques focus : l'instruction calculate] pour qsmeasure ou la fenêtre équivalente Agréger des entrées ou le fichier statistique pour qstrack.

Exemple R–2 : Marquage des déciles approximatifs

Vous pouvez découper un champ « myfield » en dix modalités de population identique, puis calculer un champ « décile » :

segindex() byyfield

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

corbeille

Sujet parent : Fonctions d'agrégation


significance

Objectif Calculer la significativité statistique de toute différence entre la valeur moyenne d'un champ pour un segment à double entrée et la valeur moyenne du champ identique pour la population.

Syntaxe significance(x)

Arguments

Type | Nom | Description
numérique | x | Le champ à considérer

Résultat

Type | Description
réel | Une valeur entre -1 et 1 dont le signe indique la direction dans laquelle le segment moyen x est différent de la population moyenne de x et dont la valeur absolue indique la significativité statistique de cet écart, en prenant en compte la taille du segment
Remarque :

Vous ne pouvez pas utiliser cette fonction dans un fichier d'agrégations [voir Utilisation des fonctions d'agrégation et des clauses where et default] ou fichier de statistiques [voir Evaluation des statistiques focus : l'instruction calculate] pour qsmeasure ou la fenêtre équivalente Agréger des entrées ou le fichier statistique pour qstrack.

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

confintlower

confintupper

Sujet parent : Fonctions d'agrégation


stdev

Objectif Calculer l'écart-type des valeurs non null dans un champ (éventuellement par groupe ou segment).

Syntaxe stdev(x)

Arguments

Type | Nom | Description
numérique | x | Le champ dont l'écart-type doit être calculé

Résultat

Type | Description
réel | L'écart-type des valeurs non null dans un champ x (éventuellement par groupe ou segment)

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

Sujet parent : Fonctions d'agrégation


sum (un argument)

Objectif Calculer la somme des valeurs non nulles dans un champ (éventuellement par groupe ou segment).

Syntaxe sum(x)

Arguments

Type | Nom | Description
numérique | x | Le champ dont les valeurs sont additionnées

Résultat

Type | Description
comme en entrée | Somme des valeurs non nulles dans le champ x (éventuellement par groupe ou segment).
Remarque :
  • Ne pas confondre cette fonction agrégation avec la fonction à argument multiple [voir sum (deux arguments ou plus), sumnonnull] du même nom.
  • Notez que lors de l'application de la fonction d'agrégation sum à un ensemble d'enregistrements vides (par exemple, comme résultat du filtrage d'enregistrements), le résultat est null. Vous devez normalement remplacer ce comportement, en définissant la valeur par défaut sur 0.

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

Sujet parent : Fonctions d'agrégation


variance

Objectif Calculer la variance statistique des valeurs non null dans un champ (éventuellement par groupe ou segment).

Syntaxe variance(x)

Arguments

Type | Nom | Description
numérique | x | Le champ dont la variance doit être calculée

Résultat

Type | Description
réel | L'écart des valeurs définies dans un champ x (éventuellement par groupe ou segment)

Voir également

Fonctions d'agrégation pour les tableaux croisés

Fonctions d'agrégation pour les mesures et les calculs

Sujet parent : Fonctions d'agrégation


Références TML

  • À propos du langage TML
  • Syntaxe TML
  • Définition des champs : l'instruction create
  • Utilisation des fonctions d'agrégation et des clauses where et default
  • Découpage des agrégations : la clause by
  • Evaluation des statistiques focus : l'instruction calculate
  • Fonctions d'agrégation pour les mesures et les calculs
  • Mots réservés dans TML


À propos du langage TML

Transaction Measurement Language (TML) est un ensemble de wrappers syntaxiques légers autour des expressions FDL, utilisé pour spécifier les calculs de champ et les agrégations conjointement avec les assistants Calculer des champs [voir Calcul de champs dans un focus avec Portrait Miner] et Agréger des entrées [voir Conversion d'un focus base transaction en focus base client], et les commandes data build qsderive, qsmeasure, qstrack et qsselect de Portrait Miner.

Voir également

À propos du langage FDL

Syntaxe TML

Utilisation des commandes data build pour l'importation, le traitement et l'exportation de données

Sujet parent : Références TML


Syntaxe TML

Un fichier de calculs, de traceurs, de sélections ou d'agrégations comprend une ou plusieurs instructions create TML, alors qu'un fichier de statistiques comprend un ou plusieurs segments calculate TML.
  • TML est un langage sensible à la casse :
    • Les mots-clés TML (create, by, string etc.) sont écrits en caractères minuscules, sauf STATISTIC.
    • Les noms des fonctions d'agrégation [voir Fonctions d'agrégation pour les mesures et les calculs] sont écrits en caractères minuscules.
    • Les noms Moyenne, moyenne et MOYENNE font tous référence à champs ou statistiques différents.
  • Les noms des champs et des statistiques doivent commencer par une lettre (« A » - « Z » ou « a » - « z »), contenir uniquement des lettres, des chiffres et le caractère de soulignement (« _ »), et ils ne doivent pas contenir plus de 128 caractères ; éventuellement entre guillemets simples, par exemple, 'CustomerID'. Vous devez placer le nom d'un champ ou d'une statistique entre des guillemets simples s'il coïncide avec un TML ou un mot réservé FDL ou s'il diffère de seulement un des cas.
  • La syntaxe TML est décrite à l'aide de diagrammes chemin de fer de la façon suivante :

    Tant que vous suivez les flèches et que vous ne revenez pas en arrière, tout chemin au travers d'un diagramme chemin de fer mène à un TML syntaxiquement valide (mais pas nécessairement significatif) :
    • Les mots dans les zones ovales/circulaires (comme create) sont des mots clés TML ; vous devez les saisir exactement tels qu'ils apparaissent.
    • Vous devez également saisir la ponctuation dans les zones ovales (comme « : » et « := ») exactement telle qu'elle apparaît (il ne doit pas y avoir d'espace entre « : » et « = » dans « := »).
    • N'oubliez pas le point-virgule qui termine chaque instruction TML.
    • Les termes dans les zones rectangulaires (comme expression) font référence à d'autres diagrammes de chemin de fer ou à des formes décrites ailleurs dans les mots ; vous ne devez pas les saisir littéralement.
  • TML est un langage formaté libre : vous pouvez passer à la ligne suivante ou insérer des espaces supplémentaires entre les éléments syntaxiques (dans les zones ovales/circulaires des diagrammes de chemin de fer) sans affecter l'interprétation d'un fichier de calculs, de traceurs, de sélections, d'agrégations ou de statistiques.
  • Tout comme l'introduction d'espaces entre les éléments syntaxiques, vous pouvez inclure des commentaires, qui commencent par une double barre oblique (« // ») et qui continuent jusqu'à la fin de la même ligne.
  • Chaque fois que la syntaxe TML exige une expression, vous pouvez utiliser n'importe quelle expression FDL [voir Expressions], sauf pour une expression impliquant un mot réservé TML, un point-virgule ou des accolades {...}, qui doit être placée entre parenthèses (...).

Voir également

À propos du langage TML

Evaluation des statistiques focus : l'instruction calculate

Définition des champs : l'instruction create

Mots réservés dans FDL

Mots réservés dans TML

Sujet parent : Références TML


Définition des champs : l'instruction create

L'instruction create définit un champ par calcul ou agrégation, selon le contexte dans lequel il apparaît.

Calculs Le fichier de calculs pour qsderive ou la fenêtre Calculer des champs équivalente, le fichier de traceurs pour qstrack et les fichiers de sélections pour qsselect doivent inclure les instructions create de la forme suivante :

Le fichiers d'agrégations pour qsmeasure ou la fenêtre Agréger des entrées équivalente peut éventuellement inclure des instructions create de la forme suivante :

Dans les deux cas, l'instruction create définit un champ appelé nom en termes d'expression FDL [voir Expressions]. Le type de données du champ est le type de données de l'expression, à moins de le substituer en spécifiant un type compatible [voir Types de données].
  • Pour chaque instruction create successive dans le fichier de calculs, qsderive ou la fenêtre Calculer des champs calcule un champ dans le focus de sortie à l'aide de l'expression fournie, ce qui peut correspondre aux champs dans le focus source et aux champs calculés précédemment dans le fichier de calculs.
  • Pour chaque instruction create successive dans le fichier de traceurs, qstrack calcule un champ avec l'expression fournie, ce qui peut correspondre aux champs dans le focus source et aux champs calculés précédemment dans le fichier de traceurs ainsi qu'aux statistiques du focus définies dans le fichier de statistiques. Généralement, l'expression implique des variables d'état [voir Variables].
  • Compte tenu du fichier de sélections, qsselect calcule un champ correspondant par défaut à la première instruction create et ignore toutes les autres instructions dans le fichier. L'expression de définition doit être de type booléen (ou compatible).
  • Pour chaque instruction create successive de ce type dans le fichier d'agrégations, qsmeasure ou la fenêtre Agréger des entrées calcule un champ dans le focus de sortie avec l'expression fournie, laquelle peut correspondre aux champs calculés précédemment dans le fichier d'agrégations et aux statistiques de focus définies dans tout fichier de statistiques.
  • Une instruction temporary a le même effet qu'une instruction create, à la différence que le champ n'apparaît pas dans le focus de sortie. Cependant vous pouvez toujours désigner le champ temporaire dans les expressions suivantes dans le fichier d'agrégations.

Agrégations Le fichier d'agrégations pour qsmeasure ou la fenêtre Agréger des entrées équivalente peut éventuellement inclure des instructions create de la forme suivante :

Pour chaque instruction create de ce type dans le fichier d'agrégations, qsmeasure ou la fenêtre Agréger des entrées calcule efficacement un champ virtuel correspondant à l'expression selon la fonction d'agrégation. Cette expression peut se rapporter aux champs dans le focus source.

Après avoir calculé le champ virtuel, qsmeasure ou la fenêtre Agréger des entrées applique la fonction d'agrégation [voir Utilisation des fonctions d'agrégation et des clauses where et default].

Le type de données par défaut du ou des champs dépend de la fonction d'agrégation et des valeurs, des opérateurs et des fonctions impliqués dans l'expression à laquelle il s'applique, mais vous pouvez le remplacer en spécifiant un type compatible.

Une instruction temporary a le même effet qu'une instruction create, à la différence que le champ n'apparaît pas dans le focus de sortie. Cependant vous pouvez toujours désigner le champ temporaire dans les expressions suivantes dans le fichier d'agrégations.

Remarque :
  • Dans qsderive ou dans les fichiers de calculs Calculer des champs, les fichiers de sélections qsselect et les fichiers de traceurs qstrack, l'expression peut impliquer des statistiques de champ, des variables globales et des fonctions définies par rapport à celles-ci. Ces fonctionnalités FDL ne sont pas disponibles dans un fichier qsmeasure ou un fichier d'agrégations Agréger des entrées.
  • Vous devez mettre des parenthèses supplémentaires autour de l'expression si elle contient un point-virgule, des accolades ou un mot réservé TML [voir Mots réservés dans TML].
  • Chaque instruction create doit commencer sur une nouvelle ligne.

Exemples Compte tenu du fichier de calculs, derivations-customer.tml, qui contient les éléments suivants :

// Length of standing of customer in months
create CustMonths := countwholemonths(StartDate, today());
// A key field of extended length
create CustomerID_24 : string(24) := CustomerID;
Appliquer ces calculs au focus RetailCustApril.ftr pour créer un nouveau focus RetailCustAprilDeriv.ftr : qsderive -derivations derivations-customer.tml\cmdlinecont -input RetailCustApril.ftr -output RetailCustAprilDeriv.ftr Compte tenu du fichier de sélections, selections-customer.tml, qui contient les éléments suivants :
// Select male customers aged between 18 and 65 inclusive.
create Selection := Gender = 1 and Age >= 18 and Age <= 65;
Appliquer cette sélection au focus RetailCustApril.ftr pour créer un nouveau focus RetailCustAprilSelection.ftr :
qsselect -selections selections-customer.tml
         -input RetailCustApril.ftr%
         -output RetailCustAprilSelection.ftr
Compte tenu du fichier d'agrégations, aggregations-mostRecent.tml, qui contient les éléments suivants :
temporary LastPurchase := max(PurchaseDate);
create AvgTransVal := mean(Amount - 0.01 * PointsRedeemed);
create NumTrans := count();
create MonthsSinceLastPurchase :=
       countwholemonths(LastPurchase, today());

Appliquer ces agrégations au focus RetailTransApril.ftr pour créer un focus orienté vers le client RetailAggRecentApril :

qsmeasure -aggregations aggregations-mostRecent.tml
          -input RetailTransAprilSorted.ftr -output RetailAggRecentApril%
          -keys CustomerID

Voir également

Fonctions d'agrégation pour les mesures et les calculs

Découpage des agrégations : la clause by

Conversion d'un focus base transaction en focus base client

Sujet parent : Références TML


Utilisation des fonctions d'agrégation et des clauses where et default

Vous pouvez agréger des enregistrements avec qsmeasure ou la fenêtre Agréger des entrées équivalente.

Lorsque vous utilisez une instruction create dans un fichier d'agrégations [voir Définition des champs : l'instruction create], qsmeasure ou la fenêtre Agréger des entrées calcule efficacement un champ virtuel correspondant à l'expression entre parenthèses suivant la Fonction d'agrégation.

Conceptuellement, qsmeasure ou la fenêtre Agréger des entrées divise les enregistrements dans le focus source, renforcé par le champ virtuel, en groupes d'enregistrements ayant la même valeur de champ clé. Pour chaque groupe d'enregistrements (correspondant à une seule valeur de champ clé), qsmeasure ou la fenêtre Agréger des entrées applique la fonction d'agrégation aux valeurs du champ virtuel dans ces enregistrements, pour générer une seule valeur de résultat.

Les valeurs du résultat pour tous les groupes pris ensemble constituent un nouveau champ, portant le nom fourni dans l'instruction create, à moins que l'instruction create ne contienne une clause by [voir Découpage des agrégations : la clause by].

Dans chaque groupe d'enregistrements avec une valeur de champ clé commune, certaines fonctions d'agrégation ignorent les enregistrements dont le champ virtuel contient la valeur null [voir La valeur null].

Si l'instruction create contient une clause where, la fonction d'agrégation ignore les enregistrements dont l'expression associée renvoie une valeur 0 (« false »). Cette expression peut se rapporter aux champs dans le focus source.

Étant donné les fonctions d'agrégation peuvent ignorer certains de ces enregistrements dans un groupe avec une valeur de champ clé commune, il est possible que tous les enregistrements du groupe soient ignorés. Dans ce cas, la plupart des fonctions d'agrégation renvoient la valeur null. L'insertion d'une clausedefault vous permet de spécifier une expression constante à évaluer au lieu de l'agrégation dans l'éventualité où elle renvoie null.

Remarque :

Lorsque vous utilisez la fonction d'agrégation sum [voir sum (un argument)], vous devez généralement indiquer la somme 0 par défaut. Si vous n'utilisez pas de clause default, la somme d'une sélection d'entrées vides est null, ce qui n'est probablement pas ce que vous voulez.

Exemples Compte tenu du fichier d'agrégations, aggregations-purchaseSummary.tml, qui contient les éléments suivants :

create firstPurchaseDate := first(PurchaseDate);
create commonPaymentMethod := mode(PaymentMethod);
create Spend := sum(Amount) default 0;
create SpendInStore800 := sum(Amount)
       where Store = "0800" default 0;
create proportionSpendInStore800 := SpendInStore800 / Spend;
create NumTransCRRedeemed := count()
       where PaymentMethod = "CR" and not isnull(PointsRedeemed);

Appliquer ces agrégations au focus RetailTransApril.ftr pour créer un focus orienté vers le client RetailAggSummaryApril :

qsmeasure -aggregations aggregations-purchaseSummary.tml
          -input RetailTransAprilSorted.ftr -output RetailAggSummaryApril
          -keys CustomerID

Voir également

Fonctions d'agrégation pour les mesures et les calculs

Expressions

Sujet parent : Références TML


Découpage des agrégations : la clause by

Le fichier d'agrégations pour qsmeasure ou la fenêtre Agréger des entrées équivalente contient une séquence d'instructions Définition des champs : l'instruction createcreate [voir ]. Dans le cadre d'une instruction create, vous pouvez éventuellement inclure une clause by, pour diviser votre agrégation en fonction de l'application d'une fonction de division ou de la fonction modalité en une expression dérivée des autres champs.
Pour chaque entier i possible, renvoyé par la fonction de division ou de découpage, qsmeasure ou la fenêtre Agréger des entrées crée un champ distinct, contenant des valeurs agrégées à partir de ces entrées pour lesquelles l'application de la fonction évalue à i. Le nom de chacun de ces champs connexes est formé du nom dans l'instruction create avec un suffixe qui dépend de la fonction utilisée pour diviser l'agrégation.
  • Les fonctions de division intégrée suivantes sont disponibles (avec les suffixes de nom de champ fournis correspondant aux valeurs de fonction successives) :
    Fonction | Suffixes de nom de champ
    day | "_1," "_2," "_3," ..., "_31"
    dayofweek | "Dim," "Lun," "Mar," ..., "Sam"
    hour | "0000," "0100," "0200" ..., "2300"
    isnull | "NonNull," "Null"
    match | "MisMatch," "Match"
    membre | "NotMember," "Member"
    minute | "0," "1," "2" ..., "59"
    month | "Jan," "Fév," "Mar," ..., "Déc"
    second | "0," "1," "2" ..., "59"
    sgn | "Négatif," "Zéro," "Positif"
    strmember | "NotMember," "Member"
    weekofyear | "_1," "_2," "_3," ..., "_53"
  • Vous pouvez utiliser la fonction découpage pour appliquer un découpage FDL à une expression. Utilisée comme fonction de division, la fonction de découpage crée des suffixes de nom de champ "_1," "_2," ..., "_n," "_null," et "_other" (où n dépend du nombre de modalités dans le découpage).
  • Vous pouvez également définir votre propre fonction de division [voir Fonctions définies par l'utilisateur]. L'attribut element_names définit les suffixes de nom de champ correspondant à des valeurs de retour des fonctions.

Exemples Compte tenu du fichier d'agrégations, aggregations-builtinSplit.tml, qui contient les éléments suivants :

create numberPurchases := count();
create numberPurchasesOn_ := count() by dayofweek(PurchaseDate);
create proportionPurchases_Mon :=
       numberPurchasesOn_Mon / numberPurchases;
create purchaseAmountIn_ :=
       sum(Amount) by month(PurchaseDate) default 0;

Appliquer ces agrégations au focus RetailTransApril.ftr pour créer un focus orienté vers le client RetailDateSplitsApril.ftr comprenant les champs CustomerID, numberPurchases, numberPurchasesOn_Sun, numberPurchasesOn_Mon, ..., numberPurchasesOn_Sat, proportionPurchases_Mon et purchaseAmountIn_Jan, purchaseAmountIn_Feb, ..., purchaseAmountIn_Dec :

qsmeasure -aggregations aggregations-builtinSplit.tml -keys CustomerID -input RetailTransApril.ftr -output RetailDateSplitsApril.ftr

Compte tenu du fichier d'agrégations, aggregations-binSplit.tml, qui contient les éléments suivants :

create numberPurchasesAmountBand :=
       count() by bin(EqualRange(20,100,4),Amount);
create numberPurchasesDateBand := count() by
       bin(PrePost(todate(19990401), todate(19990501),
       todate(19990601)), PurchaseDate);
create ratioPrePost :=
       numberPurchasesDateBand_3 / numberPurchasesDateBand_2;

Appliquer ces agrégations au focus RetailTransApril.ftr pour créer un focus orienté vers le client, RetailRangeSplitsApril.ftr, comprenant les champs CustomerID, numberPurchasesAmountBand_1, numberPurchasesAmountBand_2, ..., numberPurchasesAmountBand_6, numberPurchasesAmountBand_null, numberPurchasesAmountBand_other (correspondant à deux modalités de fin, à quatre modalités internes et à la modalité null et non classée), numberPurchasesDateBand_1, numberPurchasesDateBand_2, ..., numberPurchasesDateBand_4, numberPurchasesDateBand_null, numberPurchasesDateBand_other et ratioPrePost :

qsmeasure -aggregations aggregations-binSplit.tml -keys CustomerID -input RetailTransApril.ftr -output RetailRangeSplitsApril.ftr

Compte tenu du fichier de fonctions FDL, fdl-functions-storeGroups.fdl, qui contient les éléments suivants :

function StoreGroupFunction( Store )
[
   element_names = "North, South, East, West"
]
{
case
    Store = "0000" or Store = "0800" : 1;
    Store = "0300" or Store = "0600" or Store = "0700" : 2;
    Store = "0100" or Store = "0400" : 3;
    default : 4;
}

Compte tenu du fichier d'agrégations, aggregations-userDefinedSplit.tml, qui contient les éléments suivants :

create totalPurchases := sum(Amount);
create totalPurchasesByStore_ :=
       sum(Amount) by StoreGroupFunction( Store );
create proportionPurchases_North :=
       totalPurchasesByStore_North / totalPurchases;

Appliquer ces agrégations au focus RetailTransApril.ftr pour créer un focus orienté vers le client, RetailGroupSplitsApril.ftr, comprenant les champs CustomerID, totalPurchases, totalPurchasesByStore_North, totalPurchasesByStore_South, totalPurchasesByStore_East, totalPurchasesByStore_West et proportionPurchases_North :

qsmeasure -aggregations aggregations-userDefinedSplit.tml
    -library fdl-functions-storeGroups.fdl
    -keys CustomerID
    -input RetailTransApril.ftr -output RetailGroupSplitsApril.ftr

Voir également

Fonctions d'agrégation pour les mesures et les calculs

Expressions

Utilisation des fonctions d'agrégation et des clauses where et default

Sujet parent : Références TML


Evaluation des statistiques focus : l'instruction calculate

Le fichier de statistiques pour qsmeasure, la fenêtre équivalente Agréger des entrées ou qstrack contient des instructions calculate sous la forme suivante :

L'instruction calculate indique la statistique focus appelée nom selon les termes d'une fonction d'agrégation appliquée à une expression FDL [voir Expressions], qui peut se rapporter à des champs dans le fichier focus.

Comme dans le cas d'une mesure [voir Utilisation des fonctions d'agrégation et des clauses where et default], qsmeasure, qstrack ou la fenêtre Agréger des entrées calcule effectivement un champ virtuel correspondant à l'expression entre parenthèses suivant la fonction d'agrégation.

L'instruction calculate donne lieu à une valeur de résultat unique, obtenue en appliquant la fonction d'agrégation à toutes les valeurs du champ virtuel. En revanche, une instruction create dans un fichier d'agrégations donne lieu à un champ, dans lequel chaque valeur est obtenue en appliquant la fonction d'agrégation aux valeurs du champ virtuel pour un groupe d'enregistrements.

Le type de données par défaut d'une statistique focus dépend de la fonction d'agrégation et des valeurs, des opérateurs et des fonctions impliquées dans l'expression à laquelle il s'applique, mais vous pouvez le remplacer en spécifiant un type compatible [voir Types de données].

Si l'instruction calculate contient une clause where, la fonction d'agrégation ignore les enregistrements pour lesquels l'expression associée est évaluée à 0 (« false »). Cette expression peut se rapporter aux champs dans le focus source.

Une fois que vous avez défini une statistique focus dans le fichier de statistiques, vous pouvez la consulter dans les expressions du fichier d'agrégations ou de traceurs à l'aide du format spécial STATISTIQUE.nom. Vous pouvez utiliser ce format partout où vous pouvez vous référer à un champ dans le fichier focus source ou le fichier de traceurs.

Exemples Selon le fichier de statistiques, statistics-amount.tml, qui contient :

calculate averageAmount := mean(Amount);

Selon le fichier d'agrégations, aggregations-statistic.tml, qui contient :

create averageSpend := mean(Amount);

create bigSpender := averageSpend > STATISTIC.averageAmount;

Appliquer ces agrégations au fichier focus RetailTransApril.ftr pour créer un fichier focus client RetailAprilBigSpenders.ftr contenant les champs CustomerID, averageSpend et bigSpender :

qsmeasure -statistics statistics-amount.tml

-aggregations aggregations-statistic.tml

-keys CustomerID

-input RetailTransApril.ftr -output RetailAprilBigSpenders.ftr

Voir également

Fonctions d'agrégation pour les mesures et les calculs

Sujet parent : Références TML


Fonctions d'agrégation pour les mesures et les calculs

Il existe de nombreuses fonctions d'agrégation disponibles pour les mesures et les calculs.

Utiliser une fonction dans un contexte de mesure signifie l'utiliser \funccontextmeasure.

Utiliser une fonction dans un contexte de calcul signifie l'utiliser \funccontextderive.

Sauf avertissement contraire ; une fonction d'agrégation prend un seul champ numérique, de chaîne ou de date comme argument.

Fonctions d'agrégation pour les mesures comme pour les calculs Vous pouvez utiliser les fonctions d'agrégation suivantes dans des contextes de mesures comme de calculs :

Fonction | Résultat
count | Le nombre d'enregistrements dans le groupe/segment Cette fonction ne prend pas d'argument.
max [voir max (un seul argument)] | La valeur maximale non null dans le champ du groupe/segment Dans un contexte de calcul, cette fonction n'accepte pas d'expression à valeur de chaîne comme argument.
mean [voir mean (un argument)] | La valeur mean (moyenne commune) des valeurs non null dans le champ du groupe/segment Cette fonction requiert une expression numérique comme argument.
min [voir min (un argument)] | La valeur minimale non null dans le champ du groupe/segment Dans un contexte de calcul, cette fonction n'accepte pas d'expression à valeur de chaîne comme argument.
stdev | La déviation standard des valeurs non null dans le champ du groupe/segment Cette fonction requiert une expression numérique comme argument.
sum [voir sum (un argument)] | La somme des valeurs non null dans le champ du groupe/segment Cette fonction requiert une expression numérique comme argument.
écart | La variance des valeurs non null dans le champ du groupe/segment Cette fonction requiert une expression numérique comme argument.

Fonctions d'agrégation pour les mesures uniquement Vous pouvez utiliser les fonctions d'agrégation suivantes dans des contextes de mesure uniquement :

Fonction | Résultat
any | Une valeur non null dans le champ, élaborée à partir d'un enregistrement arbitraire non null dans le groupe/segment
confintlower | La limite inférieure d'un intervalle à 95% de confiance pour la moyenne du champ dans le groupe
confintupper | La limite supérieure d'un intervalle à 95% de confiance pour la moyenne du champ dans le groupe
countnonnull [voir countnonnull/countnonnulls] | Le nombre d'enregistrements dans le groupe dont le champ a des valeurs non null [voir La valeur null] Dans des calculs, utilisez à la place countnonnulls.
countnull [voir countnull/countnulls] | Le nombre d'enregistrements dans le groupe dont le champ contient null [voir La valeur null] Dans les calculs, utilisez à la place countnulls.
countunique | Le nombre de valeurs uniques se produisant dans le champ, incluant potentiellement la valeur null.
countuniquenonnull | Le nombre de valeurs uniques, à l'exception de la valeur null, se produisant dans le champ
first | La première valeur non null dans le champ du groupe
last | La dernière valeur non null dans le champ du groupe
median | La moyenne (valeur moyenne) des valeurs non null dans le champ du groupe Cette fonction requiert une expression numérique ou à valeur de chaîne comme argument.
mode | Le mode (valeur la plus commune) des valeurs non null dans le champ du groupe
moderatio | La proportion d'enregistrements non null dans le groupe qui contient la valeur non null la plus commune dans le champ

Fonctions d'agrégation pour les calculs uniquement Vous pouvez utiliser les fonctions d'agrégation suivantes dans des contextes de calcul uniquement :

Fonction | Résultat
countnonnulls [voir countnonnull/countnonnulls] | Le nombre d'enregistrements dans le segment dont le champ a des valeurs non null [voir La valeur null] Dans les mesures, utilisez à la place countnonnulls.
countnulls [voir countnull/countnulls] | le nombre d'enregistrements dans le segment dont le champ contient la valeur null [voir La valeur null] Dans les mesures, utilisez à la place countnull.
percentage | Le nombre d'enregistrements dans le segment, sous forme de pourcentage du nombre total d'enregistrements Cette fonction ne prend pas d'argument.
percentagerate | Le pourcentage d'enregistrements non null dans le segment qui contiennent la valeur 1 dans le champ Le champ doit contenir uniquement les valeurs 0 et 1.
segindex | Un nombre positif identifiant uniquement le segment à l'intérieur du tableau croisé formé par les champs de ventilation Cette fonction ne prend pas d'argument.
significance | La significativité statistique de toute divergence entre la valeur moyenne du champ du segment et la valeur moyenne du champ de la population entière, avec un signe indiquant la direction de la déviation Cette fonction requiert une expression numérique comme argument.
Sujet parent : Références TML


Mots réservés dans TML

Les unités lexicales suivantes sont des mots réservés dans TML :

aggregation, all, and, as, auto, automatic, bin, binning, bool, boolean, by, calculate, constant, create, crosstab, date, default, description, dimension, double, drl, enum, except, fields, file, float, format, from, full, function, group, include, inplace, input, int, integer, join, left, long, merge, meta, modifiable, normal, on, open, outer, outfile, output, parameter, pragma, real, ref, reference, rename, right, separate_functions, short, show, show_empty_segments, show_summaries, sort, state, statistic, strbytes, string, suppress, table, temp, temporary, track, tracker, view, where

Pour utiliser un mot réservé ou un mot qui diffère d'un mot réservé uniquement au niveau de la casse comme nom de champ ou de statistique dans TML, ou comme identifiant [voir Expressions] dans FDL, vous devez l'entourer de guillemets simples, comme par exemple, 'Date'.

Voir également

À propos du langage TML

Mots réservés dans FDL

Sujet parent : Références TML


Références FDL

  • À propos du langage FDL
  • Types de données
  • Expressions
  • Expressions conditionnelles
  • Variables
  • Fonctions définies par l'utilisateur
  • Fonctions pré-définies
  • Mots réservés dans FDL
  • opérateurs FDL
  • fonctions FDL
  • Découpages
  • Expressions FDL régulières


À propos du langage FDL

Le langage FDL (Field Derivation Language, langage de calcul de champ) est un langage simple permettant de définir la création de nouveaux champs dans les focus Portrait Miner. Vous pouvez utiliser FDL dans l'Aperçu du tableau [voir Calcul d'un champ avec l'Aperçu du tableau] dans Decision Studio, les assistants des options Calculer des champs [voir Calcul de champs dans un focus avec Portrait Miner] et Agréger des entrées [voir Conversion d'un focus base transaction en focus base client], et les commandes data build de Portrait Miner. Nous ne mentionnerons pas ici son utilisation avec les enregistrements qsderive, qsmeasure, qstrack et qsselect.
Vous pouvez utiliser FDL pour réaliser les opérations suivantes :
  • Transformer, combiner et effectuer un large éventail d'autres calculs sur les champs existants dans un focus
  • Partitionner un focus en un ensemble d'échantillons aléatoires.
  • Définir des segmentations et des modèles prédictifs
  • Sélectionner des enregistrements selon un critère de votre choix

Vous l'utilisez généralement dans des lignes d'expressions simples, d'une ligne, comme celles décrites dans Expressions de base, mais vous pouvez également l'utiliser pour construire des scripts avec des chemins d'exécution complexes, dépendant des données.

La syntaxe FDL comprend les éléments suivants :
  • Des opérateurs arithmétiques [voir Opérateurs arithmétiques].
  • Des opérateurs de comparaison [voir Opérateurs relationnels] et permettant de combiner les expressions logiques [voir Opérateurs logiques].
  • Deux constructions alternatives pour l'évaluation conditionnelle des instructions : if...then...else et case [voir Expressions conditionnelles].
  • Un ensemble complet de fonctions intégrées [voir Fonctions pré-définies].
  • La capacité d'encapsuler des transformations communes comme fonctions définies par l'utilisateur [voir Fonctions définies par l'utilisateur], en vue de leur réutilisation et de leur partage.
  • Des variables, pour stocker des valeurs à réutiliser dans un script FDL, y compris (dans certains contextes) des variables « accumulatrices » globales [voir Variables globales dans Decision Studio].
  • Une fonction permettant d'intégrer des tableaux croisés dans les calculs .

Voir également

À propos du langage TML

Expressions

Sujet parent : Références FDL


Types de données

Les types de données de base suivants sont pris en charge dans FDL [voir À propos du langage FDL] :

Type | Description | Exemples (comme littéraux FDL)
entier | Un nombre sans partie fractionnelle (entre -2 147 483 647 et 2 147 483 646) | 78004, -100
réel | Un nombre avec une partie fractionnelle, représenté en interne par un nombre comportant une « virgule flottante » à une précision de 15 chiffres (entre [image] et [image] , ou 0) | 42,3 ; -0,56
date | Une date/heure comprise entre 1507 et 3015 apr. J.-C., à la seconde près | #2009/01/01, #2009/01/01:16:01:39
chaîne | Une chaîne de caractères, représentant des données texte | « bonjour »
petit entier | Un petit nombre sans partie fractionnelle (entre qsminsmallint et qsmaxsmallint) | 42, -1
Remarque :
  • Si vous utilisez une valeur d'entier littéral (comme 12345678910) qui est trop grande pour un type de données entier, vous obtiendrez un dépassement de capacité. Vous pouvez contourner le problème en utilisant une valeur réelle à la place : (dans ce cas, 12345678910,0).
  • Le type petit entier a une portée limitée dans Portrait Miner et ne devrait être utilisé que lorsque cela s'avère absolument nécessaire. En général, nous conseillons d'utiliser le type entier à la place.
Sujet parent : Références FDL

La valeur null

En plus des valeurs ordinaires pour chacun des types de données de base, un champ ou une expression d'entier, de réel, de date ou de type chaîne peut prendre la valeur spéciale null. La valeur null représente toujours une valeur inconnue (en raison de données manquantes ou d'un dépassement de capacité dans un calcul, comme la division par zéro, ou pour d'autres raisons). Elle se distingue à la fois de zéro et d'une chaîne vide "".

Les fonctions FDL et les opérateurs conservent l'incertitude introduite par un argument ou un opérande null, donnant souvent la valeur null par la suite. Cependant, il existe des fonctions, notamment isnull et certaines fonctions d'agrégation, qui gèrent spécifiquement la valeur null.

Exemples

?

1 + null est égal à null.

1 != null est égal à null.

1 < null est égal à null.

null = null est égal à null.

null != null est égal à null.

false or null est égal à null.

true and null est égal à null.

true or null est égal à true.

false and null est égal à false.

Voir également

ifnull, nvl

Données booléennes

Il n'y a aucun type de données booléennes formelles (true/false) dans FDL. Cependant, vous pouvez traiter un champ entier (ou une variable) contenant uniquement les valeurs 0 et 1, ou une expression logique comme Income < 10000, comme s'il s'agissait d'un type booléen.

Les expressions logiques génèrent 1 lorsqu'elles sont true (vraies) et 0 lorsqu'elles sont false (fausses). Les expressions conditionnelles utilisent ces valeurs pour déterminer les expressions (parmi les deux ou plus) à évaluer. Les opérateurs logiques fonctionnent aussi avec ces valeurs. La valeur 0 dans un champ entier ou une variable est interprétée comme « false » et toute autre valeur (non null) est interprétée comme « true ».

En outre, vous pouvez utiliser les mots clés true et false comme des littéraux booléens (qui représentent respectivement 1 et 0).

Compatibilité de type

Les types de données entier et réel sont dits de type compatible, car vous pouvez utiliser une valeur entière chaque fois qu'une valeur réelle est nécessaire (mais pas l'inverse), par exemple, comme argument d'une fonction. Les types de données date et chaîne sont seulement de type compatible avec eux-mêmes.

Les opérandes d'un opérateur arithmétique binaire [voir Opérateurs arithmétiques] ou d'un opérateur relationnel [voir Opérateurs relationnels] doivent être de type compatible. En effet, dans le cas d'un opérateur arithmétique binaire, les deux opérandes doivent être numériques ; le résultat est réel, sauf si les deux opérandes sont des entiers.

De même, les expressions de résultat dans une expression if ou case [voir Expressions conditionnelles] doivent être de type compatible, de sorte que le type du résultat puisse être spécifié avant évaluation. Si les expressions entières et réelles sont mélangées, le résultat est de type réel.

Conversion de type

En plus d'utiliser la conversion implicite de type de données (qui se produit lorsque le type de données d'une expression est forcé), vous pouvez convertir explicitement les types de données entre les fonctions FDL tointeger, toreal, todate et tostring.

Remarque : Lors de la conversion d'une chaîne en une valeur numérique, tous les caractères de fin non numériques sont ignorés.


Expressions

Une expression FDL est l'un des éléments suivants :
  • Une expression de base [voir Expressions de base]
  • Une expression conditionnelle [voir Expressions conditionnelles]
  • Une initialisation ou une attribution de variable[voir Variables]
  • Une liste d'expressions séparées par des points-virgules (une liste d'expressions), entre parenthèses

Chaque expression a un type de données associé [voir Types de données] et peut être évaluée.

Afin d'évaluer une liste d'expressions dans un contexte donné, évaluez chaque expression la composant, de la première à la dernière. La valeur de la liste d'expressions dans son ensemble est la dernière valeur calculée.

Remarque :
  • Le type de données est déduit automatiquement. Vous ne pouvez pas le spécifier autrement qu'en utilisant une variable locale du type requis, ou avec une expression qui force le type. Par exemple, l'expression suivante force le type à être réel :

    if false then 0.0 else...

  • Vous utilisez généralement des listes d'expressions conjointement avec l'affectation de la variable.
Sujet parent : Références FDL

Expressions de base

Uneexpression de base est l'une des expressions suivantes :
  • Un identificateur, éventuellement entre guillemets simples, par exemple'CustomerID'. Vous devez placer un identificateur encadré par des guillemets simples, s'il ne commence pas par une lettre (« A » - « Z » ou « a » - « z »), s'il contient des caractères autres que des lettres, des chiffres et des caractères de soulignement ou s'il coïncide avec un mot réservé TML ou FDL (ou s'il diffère d'un de ces mots uniquement par la casse ). Un identificateur ne doit pas contenir plus de 128 caractères.
  • Un littéral numérique, par exemple 30, -3.28, ou 3.1e8 (le dernier de ceux-ci représentant [image])
  • Un littéral de chaîne, entre guillemets, par exemple, "A string"
  • Un littéral de date, précédé de « # », par exemple, #2004/03/16 ou #2004/03/16:09:12:13
  • Le mot clé « null » (voir La valeur null)
  • Une application de fonction, composée d'un nom de fonction (un identificateur) suivi d'une liste d'arguments (expressions) séparés par des virgules entre parenthèses ; par exemple, mean(IncomeA + IncomeB, TotalEstIncome)
  • Une expression arithmétique, composée d'expressions de valeur numérique reliées par des opérateurs arithmétiques [voir Opérateurs arithmétiques], par exemple 365 / 52
  • Une relation, composée d'expressions de valeur numérique ou de chaîne reliées par des opérateurs relationnels [voir Opérateurs relationnels], par exemple, Age > 30 ou 'State' = "New York"
  • Une expression logique, composée de relations ou d'autres expressions de valeur booléenne reliées par des opérateurs logiques [voir Opérateurs logiques], par exemple, (Income > 250000) et (MaritalStatus = "Single")
  • Un identificateur statistique, composé du mot clé TML STATISTIC suivi par un point, puis suivi par un identificateur, par exemple, STATISTIC.AverageIncome (uniquement dans un fichier d'agrégations TML)
  • Une statistique de champ , uniquement dans un calcul de Decision Studio, un qsderive ou un qsselect qsselect
Remarque :
  • Les identificateurs FDL sont sensibles à la casse. Par exemple, les expressions CustomerID et CUSTOMERID se réfèrent à différents champs, alors que les expressions isnull(Age) et IsNull(Age) impliquent des fonctions différentes.
  • Un littéral numérique est évalué comme un entier, s'il ne contient aucun point décimal et n'utilise pas de notation scientifique. Sinon, il est évalué comme un nombre réel.
  • Un littéral de chaîne peut contenir des caractères autres que des guillemets doubles (") et des caractères de saut de ligne.
  • Un littéral de date est évalué initialement au format AMJ [voir Formats de date] ; si cette évaluation échoue, il est évalué selon le paramètre de votre préférence de lecture [voir lire].
  • Tout comme l'introduction d'espaces entre les éléments syntaxiques, vous pouvez inclure des commentaires, qui commencent par une double barre oblique (« // ») et qui continuent jusqu'à la fin de la ligne. Par exemple,
    // This is a comment.
2 + 2 // This is a comment.

Voir également

Mots réservés dans FDL

Mots réservés dans TML


Expressions conditionnelles

Dans FDL, il existe deux principales façons d'évaluer une expression conditionnelle : l'expression if et l'expression case.

Voir également

À propos du langage FDL

Expressions

Sujet parent : Références FDL

L'expression if

Si la condition (une expression FDL retournant une valeur booléenne [voir Données booléennes]) est définie sur true, l'expression qui suit then est évaluée ; sinon, l'expression qui suit else est évaluée. La valeur de l'expression if est la valeur de l'expression évaluée.

Remarque :
  • Les expressions suivantes then et else doivent être de type compatible [voir Types de données].
  • Si vous omettez la partie « else » d'une expression if et que la condition est false, la valeur de l'expression if est null [voir La valeur null].
  • Une condition null [voir La valeur null] est traitée par l'expression if comme si elle était false. Il s'agit d'une exception à la règle générale selon laquelle l'incertitude introduite par la valeur null est préservée par des expressions FDL. Cela peut entraîner des résultats inattendus : par exemple, lorsque Age est null, les expressions suivantes (à première vue équivalentes) génèrent la valeur null, 0 et 1 respectivement :

    Age > 40

    if Age > 40 then 1 else 0

    if Age <= 40 then 0 else 1

  • Vous pouvez tester plusieurs conditions utilisant les expressions if imbriquées : des expressions if dans lesquelles l'expression suivant then ou else est elle-même une expression if. Si l'expression suivante then est une expression if, vous devez la placer entre parenthèses pour éviter toute ambiguïté. Vous pouvez utiliser également l'expression case [voir L'expression case].
  • Si votre condition peut être exprimée sous la forme x = 0 (ou [image]) pour certains nombres x, vous pouvez également utiliser la fonction FDL intégrée cond au lieu d'une expression if.

Exemples

if Age < 40 then "Young"

if Age < 40 then "Young" else "Senior"

if Age > 40 then "Young" else if Age < 60 then "MiddleAged" else "Senior"

if (Age >= 13 and Age < 20) then "Teenager"

if isnull(Age) then mean(Age) else Age

if Responder then RespondDate else StartDate

if match(Postcode, "^EH") then "Y" else "N"

if StartDate < #1998/09/08 then "Loyal" else "Recent"

L'expression case

Si la première condition (une expression FDL renvoyant une valeur booléenne [voir Données booléennes]) est définie sur true, l'expression correspondante (à droite des deux-points) est évaluée et renvoyée comme valeur de l'expression case. Sinon, la condition suivante est testée ; si elle est true, l'expression correspondante est évaluée et retournée comme valeur de l'expression case. Sinon, la condition suivante est testée, et ainsi de suite.

Le mot clé spécial default est interprété comme une expression toujours true : utilisez-la comme la dernière condition d'une expression case (car toutes les conditions suivantes sont ignorées).

Remarque :
  • Toutes les expressions qui se produisent à droite des deux-points doivent être de type compatible [voir Types de données].
  • Si aucune des conditions n'est true (et qu'il n'existe pas de mot clé default), la valeur de l'expression case est null [voir La valeur null].
  • Une condition null [voir La valeur null] est traitée par l'expression case comme si elle était false. Il s'agit d'une exception à la règle générale selon laquelle l'incertitude introduite par la valeur null est préservée par des expressions FDL. Par exemple, lorsque Age est null, l'expression suivante génère la valeur 3 :

    boîte

    Age> 40 : 1;

    Age <= 40 : 2;

    default : 3;

  • Si vous utilisez une expression case dans une liste d'expressions ou si vous imbriquez une expression case comme une condition (à l'intérieur d'une expression if ou d'une autre expression case), vous devez la mettre entre parenthèses pour éviter toute ambiguïté.

Exemples

boîte

Age <40: "Young";

default: "NotYoung";

boîte

Response = "Exc": 7;

Response = "V. Sat": 6

Response = "Sat": 5

Response = "F. Sat": 4;

Response = "Poor": 3;

Response = "Bad": 2;

default: 1;


Variables

Une variable dans FDL est un emplacement de stockage temporaire pour une valeur d'entier, de réel, de date ou de type chaîne. Vous pouvez utiliser une variable locale pour évaluer une sous expression compliquée, (particulièrement utile si la sous expression se produit plus d'une fois), ou afin d'évaluer une expression impliquant une fonction de nombre aléatoire, afin d'éviter que sa valeur ne change d'une évaluation à l'autre. Vous pouvez également utiliser des variables globales dans Decision Studio [voir Variables globales dans Decision Studio] et des variables d'état dans les fichiers de traceurs TML [voir Variables d'état dans Transaction Measurement Language] pour transmettre des informations d'un enregistrement à l'autre.

Pour attribuer une valeur à une variable, utilisez la syntaxe suivante .

La première attribution est une initialisation et détermine la classe de la variable : locale (aucun mot clé), globale ou d'état. Le mot clé global ou état n'est utilisé que conjointement avec la première assignation à une variable globale ou d'état (l'initialisation).

L'identificateur [voir Expressions de base] est le nom de la variable (qui ne doit pas coïncider avec un nom de champ dans le focus).

Pour chaque classe de variable, son type de données [voir Types de données] est celui de la première valeur qui lui est attribuée.

La valeur d'une expression d'attribution est simplement la valeur de l'expression à droite du signe « := ».

Par exemple, la liste d'expressions suivante attribue de manière aléatoire la valeur 1 (à 20 % des enregistrements), 2 (à 20 % des enregistrements), ou 0 (au reste des enregistrements) :

x := rndUniform();

boîte

x < 0.2 : 1;

x < 0.4 : 2;

default : 0;

Elle peut être écrite de façon équivalente sous cette forme plus compacte :

boîte

( x := rndUniform() ) < 0.2 : 1;

x < 0.4 : 2;

default : 0;

Cependant, la liste d'expressions suivante génère un résultat différent (et probablement non désiré) :

boîte

rndUniform() < 0.2 : 1;

rndUniform() < 0.4 : 2;

default : 0;

Sujet parent : Références FDL

Variables globales dans Decision Studio

Les variables sont locales par défaut. Une variable locale est supprimée dès que la dernière expression dans la liste d'expressions (extérieur englobant) [voir Expressions] est évaluée. Lors de l'utilisation suivante de la même variable, elle est réinitialisée. Une variable locale ne peut pas transmettre des informations d'un enregistrement à l'autre. Par exemple, la liste d'expressions de calcul de champ suivante génère un champ avec 1 dans chaque enregistrement :

i := 0;

i := i + 1

Une variable globale diffère d'une variable locale en ce sens qu'elle n'est pas supprimée tant que Decision Studio ou la commande data build n'a pas calculé les valeurs de champ pour tous les enregistrements. L'initialisation ne se produit qu'une seule fois, lors du premier enregistrement dans le focus. Par exemple, la liste d'expressions de calcul de champ génère un champ d'index, avec 1 dans le premier enregistrement, 2 dans le second, et ainsi de suite :

global i := 0;

i := i + 1

Vous pouvez utiliser une variable globale dans une liste d'expressions de calcul de champ dans un calcul de Decision Studio, dans le fichier de calculs pour qsderive ou la fenêtre Calculer des champs équivalente, dans un fichier de traceurs pour qstrack, ou dans un fichier de sélections pour qsselect.

Variables d'état dans Transaction Measurement Language

Vous pouvez utiliser une variable d'état dans une définition de champ TML dans le fichier de traceurs qstrack.

Une variable d'état diffère d'une variable locale ou globale en ce sens qu'elle n'est pas supprimée tant que qstrack n'a pas calculé toutes les valeurs de champ pour le groupe en cours (comme défini dans le champ clé). L'initialisation se produit une fois pour chaque groupe.

Par exemple, la définition de champ suivante définit un champ de cumul, en supposant que le champ « Deposit » contient un montant déposé dans une transaction (ou une valeur négative pour un retrait) et le champ « initialbalance » contient le solde initial pour le client (peut-être à partir d'une table des clients jointe antérieurement) :

create Balance := (

state bal := InitialBalance;

bal := bal + Deposit

)


Fonctions définies par l'utilisateur

Pour définir une fonction FDL que vous pouvez utiliser de la même façon qu'une fonction pré-définie [voir Fonctions pré-définies], utilisez la syntaxe suivante :

L'identificateur [voir Expressions de base] suivant le mot-clé « function » est le nom de la fonction. La liste des arguments (formels) vient ensuite :

Chaque argument formel (autre que celui précédé par un mot-clé « field ») agit comme une variable locale [voir Variables] qui est initialisée avec la valeur de l'argument réel correspondant lorsque la fonction est appliquée. Le type [voir Types de données] d'un argument formel est le type spécifié dans la définition de la fonction, s'il est présent ; sinon, c'est celui de l'argument en cours utilisé lorsque la fonction est appliquée. Notez que les parenthèses fermantes sont nécessaires même s'il n'y a pas d'arguments formels.

Après la liste des arguments vient une liste optionnelle d'attributs de fonction [voir Attributs de fonction] et ensuite le corps de définition de la fonction. La liste d'expressions [voir Expressions] est effectivement préfixée avec des attributions de variables locales correspondant aux arguments formels (autres que ceux précédés par un mot-clé « field »), avant d'être évaluée pour donner la valeur de retour de la fonction. Le type de la valeur de retour est celui de la dernière expression.

Exemples Définir une fonction pour remplacer les zéros dans le résultat d'une expression (de n'importe quel type) par le résultat d'une autre expression :

fonction replaceZeros(expr1, expr2)

{

si expr1 = 0 alors expr2 sinon expr1

}

Une fonction qui prend un argument de chaîne et le retourne avec la première lettre capitalisée :

fonction titleCase(texte de chaîne)

{

concat(toupper(left(text, 1)), right(text, strlen(text) - 1));

}

Remarque :
  • Lors de la précision du type d'un argument de fonction, utilisez « réel », « entier », « chaîne » ou « date ».
  • Vous pouvez inclure des statistiques de champ dans une définition de fonction, mais chaque argument de fonction utilisé dans une statistique de champ doit être précédé par un mot-clé « field ». Par exemple, pour comparer une valeur à un récapitulatif sur l'ensemble du focus :

    function MyBand(champ réel x)

    {

    averageX := mean(x);

    stdevX := stdev(x);

    boîte

    x < averageX - stdevX : « Inférieur » ;

    x > averageX + stdevX : « Supérieur » ;

    default: "Milieu";

    }

  • Vous pouvez inclure des définitions de fonction au début de la liste d'expression qui définit un champ calculé. Les fonctions ainsi définies sont locales sur le calcul du champ.

    Vous pouvez également définir de façon globale les fonctions accessibles en les enregistrant dans un fichier (ou plusieurs fichiers) dans un dossier répertorié dans la préférence bibliothèques de calcul [voir bibliothèques de calcul]. Dans Decision Studio, dans le volet Famille de fonction de la boîte de dialogue Fonctions de calcul dans l'Aperçu du tableau, les fonctions dans un fichier nommé classe .fdl apparaissent dans une classe nommée classe. Par exemple, les fonctions d'un fichier nommé Conditional.fdl apparaissent dans la classe Conditional. Vous pouvez réutiliser un nom de classe existant pour augmenter une classe avec vos propres fonctions définies par l'utilisateur ou créer votre propre classe en utilisant un nouveau nom.

    Lors de l'utilisation de la commande data build qsmeasure de Portrait Miner, la fenêtre équivalente Agréger des entrées ou la commande data build qstrack, vous pouvez indiquer un fichier contenant les définitions de fonction globales supplémentaires.

  • Vous ne pouvez pas définir des fonctions d'agrégation dans un contexte de mesures, c'est-à-dire, \funccontextmeasure.
  • Si la liste d'expression se termine par un caractère alphabétique, il doit être séparé de l'accolade fermante par un point-virgule ou un espace forcé.
Sujet parent : Références FDL

Attributs de fonction

Spécifiez les attributs de fonction comme suit :

Les attributs utiles sont :

synopsis et description. Ces attributs fournissent un moyen standard de rendre la fonction « autodocumentée ». Si une fonction est installée dans un dossier répertorié dans la préférence bibliothèques de calcul [voir bibliothèques de calcul], le synopsis est affiché lorsque vous surlignez la fonction dans le volet Fonctions de la boîte de dialogue Fonctions de calcul de l'Aperçu du tableau. Lorsque vous cliquez sur le bouton Détails, la description s'affiche. Le texte du synopsis doit être court mais le texte de description peut être plus long.

Par exemple :

fonction nvl(testNull, replaceValue)

[

synopsis = "Remplacer les valeurs non renseignées"

description = "La fonction nvl() remplace les chaînes de valeurs non renseignées."

]

Notez que les attributs de description doivent tous être sur la même ligne.

element_names. Dans un fichier d'agrégations, vous pouvez utiliser une fonction avec l'attribut element_names pour partager une agrégation afin de créer des champs multiples [voir Découpage des agrégations : la clause by].

La valeur de cet attribut est une chaîne contenant une liste de noms séparés par virgule, associés aux valeurs de retour de la fonction 1, 2, ..., pour qu'ils soient répertoriés.

Par exemple, l'attribut element_names de la fonction suivante associe les noms « Low », « Medium » et « High » à des valeurs de retour 1, 2, et 3, respectivement :

function band(x)

[ element_names = "Low,Medium,High" ]

{

clamp(floor(x / 1000), 0, 2) + 1

}

L'attribut element_names de la fonction suivante associe les noms « North », « South », « East » et « West » à des valeurs de retour 1, 2, 3 et 4 respectivement :

function StoreGroupFunction( Store )

[

element_names = "North, South, East, West"

]

{

boîte

Store = "0000" or Store = "0800" : 1;

Store = "0300" or Store = "0600" or Store = "0700" : 2;

Store = "0100" or Store = "0400" : 3;

default : 4;

}


Fonctions pré-définies

FDL comprend un ensemble complet de fonctions pré-définies.

Fonctions conditionnelles

Fonction | Description
clamp | Limiter un nombre pour qu'il se trouve dans un intervalle donné.
cond | Produire un des deux résultats en fonction du zéro ou non zéro dans l'expression.
iff | Produire un des deux résultats en fonction du zéro ou non zéro dans l'expression.
ifnull, nvl | Remplacer les valeurs non renseignées.
isnull | Tester si une valeur est non renseignée.
isselected | Indiquer les entrées actuellement sélectionnées.
replace | Remplacer un nombre s'il ne se trouve pas dans un intervalle donné.

Fonctions de conversion du type de données

Fonction | Objectif
todate | Convertir une valeur en date.
tointeger | Convertir une valeur en entier.
toreal | Convertir une valeur en nombre réel.
tostring | Convertir une valeur en chaîne.

Fonctions spécifiques aux dates

Fonction | Objectif
addcenturies, addcenturiescountbackwards | Calculer une date à partir d'une autre date à l'aide d'une compensation en siècles.
adddays | Calculer une date à partir d'une autre date à l'aide d'une compensation en jours.
addhours | Calculer une date à partir d'une autre date à l'aide d'une compensation en heures.
addminutes | Calculer une date à partir d'une autre date à l'aide d'une compensation en minutes.
addmonths, addmonthscountbackwards | Calculer une date à partir d'une autre date à l'aide d'une compensation en mois.
addseconds | Calculer une date à partir d'une autre date à l'aide d'une compensation en secondes.
addweeks | Calculer une date à partir d'une autre date à l'aide d'une compensation en semaines.
addyears, addyearscountbackwards | Calculer une date à partir d'une autre date à l'aide d'une compensation en années.
countcenturies | Calculer la période entre deux dates en siècles.
countdays | Calculer la période entre deux dates en jours.
counthours | Calculer la période entre deux dates en heures.
countminutes | Calculer la période entre deux dates en minutes.
countseconds | Compter le nombre de secondes entre deux dates.
countweeks | Calculer la période entre deux dates en semaines.
countwholecenturies, countwholecenturiesbackwards | Compter le nombre de siècles complets entre deux dates.
countwholedays | Compter le nombre de jours complets entre deux dates.
countwholehours | Compter le nombre d'heures complètes entre deux dates.
countwholeminutes | Compter le nombre de minutes complètes entre deux dates.
countwholemonths, countwholemonthsbackwards | Compter le nombre de mois complets entre deux dates.
countwholeseconds | Compter le nombre de secondes entre deux dates.
countwholeweeks | Compter le nombre de semaines complètes entre deux dates.
countwholeyears, countwholeyearsbackwards | Compter le nombre d'années complètes entre deux dates.
countyears | Calculer la période entre deux dates en années.
day | Obtenir le jour du mois d'une date.
dayofweek | Obtenir un chiffre représentant le jour du mois d'une date.
gmt2edt | Convertir une date en Temps Moyen de Greenwich (GMT) en Heure d'Été de l'Est (EDT).
hour | Obtenir les heures d'une date.
minute | Obtenir les minutes d'une date.
month | Obtenir le mois de la date.
now | Obtenir la date et l'heure en cours.
second | Obtenir les secondes de la date.
today | Obtenir la date en cours.
weekofyear | Calculer la semaine de l'année d'une date, relative à une date de départ indiquée.
year | Obtenir l'année de la date.

Fonctions spécifiques aux chaînes

Fonction | Objectif
concat | Concaténer deux ou plusieurs chaînes.
endswith | Tester si une chaîne se termine avec une autre.
find | Tester si une chaîne est contenue dans une autre.
left | Renvoyer une sous-chaîne de longueur spécifique à partir du début d'une chaîne.
mid | Renvoyer une sous-chaîne de longueur spécifique à partir du milieu d'une chaîne.
right | Renvoyer une sous-chaîne de longueur spécifique à partir de la fin d'une chaîne.
soundex | Réduire chaque mot à une chaîne de quatre caractères à des fins d'indexation.
startswith | Tester si une chaîne commence avec une autre.
strlen | Obtenir la longueur d'une chaîne.
strmember | Déterminer l'appartenance de l'ensemble.
substitute | Remplacer une chaîne par une autre.
substr | Obtenir une sous-chaîne à partir d'une chaîne.
tolower | Convertir une chaîne en texte minuscule.
toupper | Convertir une chaîne en texte majuscule.
découper | Supprimer tous les espaces d'une chaîne de texte à l'exception des espaces simples entre les mots.

Expressions régulières et fonctions associées

Fonction | Objectif
match | Tester une chaîne pour une correspondance d'expression régulière [voir Expressions régulières].
replaceall | Remplacer toutes les sous-chaînes qui correspondent à une expression régulière [voir Expressions régulières].
replacefirst | Remplacer la première sous-chaîne qui correspond à une expression régulière [voir Expressions régulières].

Fonctions mathématiques et statistiques

Type | Description
abs | Calculer la valeur absolue d'un nombre.
ceil | Arrondir un nombre à l'entier supérieur le plus proche.
cos | Calculer le cosinus d'un angle.
exp | Calculer la fonction exponentielle d'un nombre.
floor | Arrondir par défaut un nombre à l'entier le plus proche.
enregistrement | Calculer le logarithme naturel (base-e) d'un nombre.
log10 | Calculer le logarithme de base 10 d'un nombre.
logbase | Calculer le logarithme d'un nombre sur une base spécifique.
max (deux arguments ou plus), maxnonnull | Calculer le maximum de deux ou plusieurs nombres, ou les dernières de deux ou plusieurs dates ou les dernières par ordre alphabétique de deux ou plusieurs chaînes.
mean (deux arguments ou plus), meannonnull | Calculer la moyenne (moyenne standard) de deux ou plusieurs nombres.
min (deux arguments ou plus), minnonnull | Calculer le minimum de deux ou plusieurs nombres ou les premières de deux ou plusieurs dates ou les premières de deux ou plusieurs chaînes par ordre alphabétique.
normaliser | Normaliser les valeurs du champ pour qu'elles se trouvent dans l'intervalle [0,1].
pow | Calculer le résultat de l'augmentation d'un nombre à la puissance d'un autre nombre.
product, productnonnull | Calculer le produit de deux ou plusieurs nombres.
round | Arrondir un nombre à l'entier le plus proche.
sgn | Calculer le signum (signe) d'un nombre.
sin | Calculer le sinus d'un angle.
sqrt | Calculer la racine carrée d'un nombre.
sum (deux arguments ou plus), sumnonnull | Calculer la somme de deux ou plusieurs nombres.
tan | Calculer la tangente d'un angle.

Fonctions d'échantillonnage des données

Fonction | Objectif
numericTestTrainSplit | Créer une segmentation test/apprentissage pour l'utiliser dans une validation de modèle.
numericTestTrainValidateSplit | Créer une segmentation test/apprentissage/validation pour l'utiliser dans une validation de modèle.
sampleEqualSize | Créer, au hasard, un index de segmentation pour les groupes de tailles égales.
sampleExactNumber | Indiquer, au hasard, un nombre exact de clients à partir d'une population sélectionnée.
sampleExactPercentage | Indiquer, au hasard, un pourcentage exact de clients à partir d'une population sélectionnée.
sampleStratified | Indiquer, au hasard, un nombre spécifique de clients à partir d'un segment et le reste de la population.
testTrainSplit | Créer une segmentation test/apprentissage pour l'utiliser dans une validation de modèle.
testTrainValidateSplit | Créer une segmentation test/apprentissage/validation pour l'utiliser dans une validation de modèle.

Fonctions de nombre aléatoire

Fonction | Objectif
rndBinomial | Générer un entier aléatoire basé sur une distribution binomiale.
rndBool | Générer soit 0, soit 1 de façon aléatoire (avec une probabilité égale).
rndExp | Générer un nombre positif aléatoire basé sur une distribution exponentielle.
rndGamma | Générer un nombre positif aléatoire basé sur une distribution Gamma.
rndNormal | Générer un nombre positif aléatoire basé sur une distribution normale.
rndPoisson | Générer un entier non négatif aléatoire basé sur une distribution discrète de la loi Poisson.
rndUniform | Générer un nombre aléatoire entre 0 et 1 basé sur une distribution uniforme.

Fonctions de retour sur investissement

Fonction | Objectif
ActionROI | Estimer la contribution du retour sur investissement par client d'une action visant à générer une réponse précise.
ActionROIAnnualized | Estimer le levier annuel du retour sur investissement par client d'une action visant à générer la réponse précise d'un client.
OfferROI | Estimer la contribution du retour sur investissement par client d'une offre visant à générer une réponse précise.
OfferROIAnnualized | Estimer le levier annuel du retour sur investissement par client d'une offre visant à générer la réponse précise d'un client.
RetentionActionROI | Estimer la contribution du retour sur investissement par client d'une action visant à empêcher l'attrition.
RetentionActionROIAnnualized | Estimer la contribution annuelle du retour sur investissement par client d'une action visant à empêcher l'attrition.
RetentionOfferROI | Estimer le retour sur investissement par client d'une offre visant à empêcher l'attrition.
RetentionOfferROIAnnualized | Estimer le retour sur investissement annuel par client d'une offre visant à empêcher l'attrition.

Fonctions diverses

Fonction | Objectif
dblookup | Consulter les valeurs dans un tableau de références (stocké en tant que focus).
membre | Déterminer l'appartenance de l'ensemble.
rankOrder, rankOrderApprox | Identifier le rang d'une valeur dans une liste de valeurs.
rankOrderMean, rankOrderApproxMean | Identifier le rang d'une valeur dans une liste de valeurs.
rownum | Générer le nombre de chaque ligne dans le tableau.

Découpages

Fonction | Objectif
corbeille | Obtenir un index de modalité correspondant à une valeur.

Voir également

Fonctions définies par l'utilisateur
Sujet parent : Références FDL


Mots réservés dans FDL

Les unités lexicales suivantes sont des mots réservés dans FDL : accum, agg, aggregate, aggregation, and, by, case, date, default, div, double, else, eq, false, field, float, function, global, if, int, integer, long, mod, not, null, number, numeric, or, real, short, state, string, then, true, where, et while

Pour utiliser un mot réservé ou un mot qui diffère d'un mot réservé uniquement au niveau de la casse comme identifiant [voir Expressions] dans FDL ou comme nom de champ ou de statistique dans TML, vous devez l'entourer de guillemets simples, comme par exemple, 'State'.

Remarque : Bien que les identificateurs dans FDL soient sensibles à la casse (fred et Fred sont distincts), les mots réservés ne sont pas sensibles à la casse et sont donc réservés quelle que soit leur combinaison majuscules/minuscules : par exemple, if, If, iF, et IF sont tous des représentations de la même unité lexicale ; toutes ces combinaisons sont réservées et ne doivent pas être utilisées comme des identificateurs.

Voir également

À propos du langage FDL

Mots réservés dans TML

Sujet parent : Références FDL


opérateurs FDL

  • Opérateurs arithmétiques
  • Opérateurs relationnels
  • Opérateurs logiques
  • Priorité de l'opérateur
Sujet parent : Références FDL


Opérateurs arithmétiques

Sauf pour le moins unaire, qui préfixe son adresse unique, tous les opérateurs arithmétiques FDL sont des opérateurs binaires infixes, c'est-à-dire, qu'ils sont écrits entre leurs deux opérandes.

Opérateur | Opérandes | Résultat
+ (addition) | numérique | La somme des opérandes
- (soustraction) | numérique | Le résultat de la soustraction du second opérande et du premier
- (moins unaire) | numérique | L'opérande négatif
* (multiplication) | numérique | Le produit des opérandes
/ (division) | numérique | Le résultat (réel) de la division du premier opérande par le deuxième
div (division d'entiers) | entier | Le résultat (entier) de la division du premier opérande par le deuxième, ignorant tout reste
mod (modulo) | entier | Le reste de la division d'entier du premier opérande par le deuxième (le module), avec le même signe que le premier opérande — par exemple, 9 % 7 fait 2 mais -9 % 7 fait -2

Exemples 2 + 5 est égal à 7.

2 - 5 est égal à -3.

- (2 + 5) est égal à -7.

2 * 5 est égal à 10.

2 / 5 est égal à 0.4.

2 div 5 est égal à 0.

2 mod 5 est égal à 2.

5 % 2 est égal à 1.

Remarque :
  • Les opérateurs d'addition, de soustraction, de moins unaire et de multiplication conservent le type de leurs opérandes (qui sont compatibles en type [voir Compatibilité de type]). Si un opérande est un entier et l'autre est un chiffre réel, le résultat est réel.
  • Si le deuxième opérande de la division, la division d'un entier ou l'opérateur modulo est zéro, le résultat est null [voir La valeur null], comme une division par zéro est non définie.
  • mod nécessite des opérandes entiers.
  • Vous pouvez également utiliser % au lieu de mod.

Voir également

Opérateurs logiques

Priorité de l'opérateur

Opérateurs relationnels

Sujet parent : opérateurs FDL


Opérateurs relationnels

Tous les opérateurs relationnels FDL sont des opérateurs binaires infixes, c'est-à-dire qu'ils sont écrits entre leurs deux opérandes.

Opérateur | Opérandes | Résultat
< (inférieur à) | entier, réel, date ou chaîne | True si le premier opérande est inférieur au deuxième ; false si le premier opérande est supérieur ou égale au deuxième
<= (inférieur ou égale à) | entier, réel, date ou chaîne | True si le premier opérande est inférieur ou égale au deuxième ; false si le premier opérande est supérieur au deuxième
> (supérieur à) | entier, réel, date ou chaîne | True si le premier opérande est supérieur au deuxième ; false si le premier opérande est inférieur ou égale au deuxième
>= (supérieur ou égale à) | entier, réel, date ou chaîne | True si le premier opérande est supérieur ou égale au deuxième ; false si le premier opérande est inférieur au deuxième
= (égalité) | entier, réel, date ou chaîne | True si les deux opérandes ont la même valeur ; false si les opérandes ont des valeurs distinctes. Pour les types de chaîne, la comparaison ignore les caractères de séparation des deux opérandes.
!= (inégalité) | entier, réel, date ou chaîne | True si les opérandes ont des valeurs distinctes ; false si les deux opérandes ont la même valeur. Pour les types de chaîne, la comparaison ignore les caractères de séparation des deux opérandes.

Exemples 2 < 5 est égal à 1 (TRUE).

5 < 5 est égal à 0 (FALSE).

"A" < "B" est égal à 1 (TRUE).

5 <= 5 est égal à 1 (TRUE).

5 > 5 est égal à 0 (FALSE).

7 > 5 est égal à 1 (TRUE).

#2003/12/31 > #2003/11/30 est égal à 1 (TRUE).

5 >= 5 est égal à 1 (TRUE).

"A" = "A" est égal à 1 (TRUE).

"A" = "a" est égal à 0 (FALSE).

"A" != "A" est égal à 0 (FALSE).

"A" != "a" est égal à 1 (TRUE).

Remarque :
  • Les opérandes d'un opérateur relationnel binaire doivent être compatibles en type [voir Compatibilité de type].
  • Lors de la comparaison des dates, « inférieur à » signifie antérieur. Lors de la comparaison des chaînes, « inférieur à » signifie antérieur dans l'alphabet (ou plus spécifiquement, antérieurement dans la représentation de caractère sous-jacente). Idem pour « supérieur à », etc.
  • Vous pouvez également utiliser == ou eq au lieu de = et <> au lieu de !=.

Voir également

Opérateurs arithmétiques

Données booléennes

Opérateurs logiques

Sujet parent : opérateurs FDL


Opérateurs logiques

L'opérateur de négation logique préfixe son opérande unique, alors que les opérateurs de conjonction et de disjonction logiques sont des opérateurs binaires infixes, c'est-à-dire, qu'ils sont écrits entre leurs deux opérandes.
Opérateur | Opérandes | Résultat
and (conjonction logique) | booléen | True si les deux opérandes sont true ; false si un des opérandes est false
or (disjonction logique) | booléen | True si un des opérandes est true ; false si les deux opérandes sont false
not (négation logique) | booléen | True si l'opérande est false ; false si l'opérande est true

Exemples ("A" = "A") et (5 = 5) est égal à 1 (TRUE).

("A" = "B") and (5 = 5) est égal à 0 (FALSE).

("A" = "B") and (5 = 2) est égal à 0 (FALSE).

("A" = "A") or (5 = 5) est égal à 1 (TRUE).

("A" = "B") || (5 = 5) est égal à 1 (TRUE).

("A" = "B") or (5 = 2) est égal à 0 (FALSE).

not ("A" = "A") est égal à 0 (FALSE).

!(("A" = "B") or (5 = 2)) est égal à 1 (TRUE).

Remarque :
  • Actuellement, il n'existe aucun type de données booléen [voir Données booléennes] dans FDL, c'est pourquoi les opérandes des opérateurs logiques sont en fait des entiers. Vous ne devriez cependant pas appliquer ces opérateurs à des entiers arbitraires.
  • Vous pouvez également utiliser and au lieu de and, || au lieu de or et ! au lieu de not.

Voir également

Opérateurs arithmétiques

Priorité de l'opérateur

Opérateurs relationnels

Sujet parent : opérateurs FDL


Priorité de l'opérateur

En l'absence de parenthèses, les opérations FDL dans une expression sont effectuées dans l'ordre de priorité des opérateurs du plus haut au plus bas :
Class | Opérateurs
Moins unaire | -
Opérateurs de multiplication | * / div mod
Opérateurs d'addition | + -
Opérateurs relationnels | < <= > >= != =
Négation logique | not
Opérateurs logiques binaires | and or

S'il existe une équivalence de priorité, les opérations sont effectuées de gauche à droite.

Les sous-expressions entre parenthèses sont toujours évaluées en premier.

Exemples -5 + 12 / 4 * 2 + 20 * 3 est égal à 61.

c'est-à-dire que l'expression est évaluée comme suit : -5 + ((12 / 4) * 2) + (20 * 3)

En déplaçant les parenthèses :

-(5 + 12 / (4 * 2) + 20) * 3 est égal à -79,5.

Voir également

Opérateurs arithmétiques

Opérateurs logiques

Opérateurs relationnels

Sujet parent : opérateurs FDL


fonctions FDL

  • Fonctions d'agrégation (argument multiple)
  • Fonctions conditionnelles
  • Fonctions de conversion du type de données
  • Fonctions spécifiques aux dates
  • Fonctions mathématiques et statistiques
  • Autres fonctions
  • Fonctions de retour sur investissement
  • Fonctions de nombre aléatoire
  • Fonctions de classement
  • Fonctions d'échantillonnage des données
  • Fonctions spécifiques aux chaînes
Sujet parent : Références FDL


Fonctions d'agrégation (argument multiple)

  • max (deux arguments ou plus), maxnonnull
  • mean (deux arguments ou plus), meannonnull
  • min (deux arguments ou plus), minnonnull
  • product, productnonnull
  • sum (deux arguments ou plus), sumnonnull
Sujet parent : fonctions FDL


max (deux arguments ou plus), maxnonnull

Objectif Calculer le chiffre maximal parmi deux chiffres ou plus, ou la dernière date parmi deux dates ou plus, ou la dernière chaîne selon l'ordre alphabétique parmi deux chaines ou plus. L'écart max revient à la valeur null si un de ses arguments est null, l'écart maxnonnull ignore les arguments nuls (mais revient toujours à la valeur null si tous ses arguments sont nuls).

Syntaxe

max( [image], [image], ...)

maxnonnull( [image], [image], ...)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne (tous du même type) | , [image] , ... | Les valeurs à comparer

Résultat

Type | Description
comme en entrée | Le maximum de [image] , [image] , ...
Remarque :
  • Ne pas confondre cette fonction max à argument multiple avec la fonction agrégation [voir max (un seul argument)] du même nom.
  • Pour les chaînes, « le dernier dans l'ordre alphabétique » signifie « le dernier des caractères sous-jacents ».

Exemples max(5.5, -3, 7, -8.5) est égal à 7.

max(5.5, -3, null, -8.5) est égal à null.

maxnonnull(5.5, -3, 7, -8.5) est égal à 7.

maxnonnull(5.5, -3, null, -8.5) est égal à 5.5.

Pour déterminer la meilleure action à effectuer pour un client selon différentes mesures ROI :

maxvalue := max (ROI1, ROI2, ROI3);

boîte

maxvalue = ROI1: "Product1";

maxvalue = ROI2: "Product2";

maxvalue = ROI3: "Product3";

Sujet parent : Fonctions d'agrégation (argument multiple)


mean (deux arguments ou plus), meannonnull

Objectif Calculer la moyenne (moyenne normale) de deux chiffres ou plus. La variante mean renvoie la valeur null si l'un de ses arguments est null, la variante meannonnull ignore les arguments null (mais renvoie toujours la valeur null si tous ses arguments sont null).

Syntaxe

mean( [image], [image], ...)

meannonnull( [image], [image], ...)

Arguments

Type | Nom | Description
numérique | , [image] , ... | Les nombres dont il faut faire la moyenne

Résultat

Type | Description
réel | La moyenne de [image] , [image] , ...
Remarque :

Ne pas confondre cette fonction moyenne à argument multiple avec la fonction agrégation [voir mean (un argument)] du même nom.

Exemples mean(5.5, -3, 7, -8.5) est égal à 0.25.

mean(5.5, -3, null, -8.5) est égal à null.

meannonnull(5.5, -3, 7, -8.5) est égal à 0.25.

meannonnull(5.5, -3, null, -8.5) est égal à -2.

Pour calculer les dépenses moyennes annuelles à partir de quatre champs de dépenses trimestrielles :

mean(SpendQtr1, SpendQtr2, SpendQtr3, SpendQtr4)

Sujet parent : Fonctions d'agrégation (argument multiple)


min (deux arguments ou plus), minnonnull

Objectif Calculer le chiffre minimal parmi deux chiffres ou plus, ou la première date parmi deux dates ou plus, ou la première chaîne selon l'ordre alphabétique parmi deux chaînes ou plus. La variante min renvoie la valeur null si l'un de ses arguments est null, la variante minnonnull ignore les arguments null (mais renvoie toujours la valeur null si tous ses arguments sont null).

Syntaxe

min( [image], [image], ...)

minnonnull( [image], [image], ...)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne (tous du même type) | , [image] , ... | Les valeurs à comparer

Résultat

Type | Description
comme en entrée | Le minimum de [image] , [image] , ...
Remarque :
  • Ne pas confondre cette fonction min à argument multiple avec la fonction agrégation [voir min (un argument)] du même nom.
  • Pour les chaînes, « le premier dans l'ordre alphabétique » signifie « le premier des caractères sous-jacents ».

Exemples min(5.5, -3, 7, -8.5) est égal à -8.5.

min(5.5, -3, null, -8.5) est égal à null.

minnonnull(5.5, -3, 7, -8.5) est égal à -8.5.

minnonnull(5.5, -3, null, -8.5) est égal à -8.5.

Sujet parent : Fonctions d'agrégation (argument multiple)


product, productnonnull

Objectif Calculer le produit de deux nombres ou plus. La variante product renvoie la valeur null si l'un de ses arguments est null ; la variante productnonnull ignore les arguments null (mais renvoie toujours la valeur null si tous ses arguments sont null).

Syntaxe

product( [image], [image], ...)

productnonnull( [image], [image], ...)

Arguments

Type | Nom | Description
numérique | , [image] , ... | Les nombres à multiplier

Résultat

Type | Description
comme en entrée | Le produit de [image] , [image] , ...

Exemples product(5.5, -3, 7, -8.5) est égal à 981.75.

product(5,5, -3, null, -8.5) est égal à null.

productnonnull(5.5, -3, 7, -8.5) égale 981.75.

productnonnull(5.5, -3, null, -8.5) égale 140.25.

Sujet parent : Fonctions d'agrégation (argument multiple)


sum (deux arguments ou plus), sumnonnull

Objectif Calculer la somme de deux nombres ou plus. La variante sum renvoie la valeur null si l'un de ses arguments est null, la variante sumnonnull ignore les arguments null (mais renvoie toujours la valeur null si tous ses arguments sont null).

Syntaxe

sum( [image], [image], ...)

sumnonnull( [image], [image], ...)

Arguments

Type | Nom | Description
numérique | , [image] , ... | Les nombres qui doivent être ajoutés

Résultat

Type | Description
comme en entrée | La somme de [image] , [image] , ...
Remarque :

Veillez à ne pas confondre cette fonction sum à argument multiple avec la fonction agrégation [voir sum (un argument)] du même nom.

Exemples sum(5.5, -3, 7, -8.5) est égal à 1.

sum(5.5, -3, null, -8.5) est égal à null.

sumnonnull(5.5, -3, 7, -8.5) est égal à 1.

sumnonnull(5.5, -3, null, -8.5) est égal à 6.

Pour calculer la dépense totale des champs de dépense sur six semaines :

sum(SpendWk1, SpendWk2, SpendWk3, SpendWk4, SpendWk5, SpendWk6)

Sujet parent : Fonctions d'agrégation (argument multiple)


Fonctions conditionnelles

  • clamp
  • cond
  • iff
  • ifnull, nvl
  • isnull
  • isselected
  • replace
Sujet parent : fonctions FDL


clamp

Objectif Contraindre un nombre à se situer dans un intervalle donné.

Syntaxe clamp(x, min, max)

Arguments

Type | Nom | Description
numérique | x | Le nombre à fixer
comme x | min | La limite inférieure de l'intervalle
comme x | max | La limite supérieure de l'intervalle

Résultat

Type | Description
comme en entrée | x if [image] ; min if x < min; max if x > max

Exemples Pour fixer les valeurs entre 18 et 65 inclus, en remplaçant les valeurs en dehors de la plage par les limites de plage appropriées :

CustomerAge | clamp(CustomerAge,18,65)
9 | 18
18 | 18
66 | 65
43 | 43

Voir également

replace
Sujet parent : Fonctions conditionnelles


cond

Objectif Générer l'un des deux résultats selon qu'une expression est null ou non null.

Syntaxe cond(cond, trueExpr, falseExpr)

Arguments

Type | Nom | Description
entier | cond | L'expression à tester
entier, réel, date ou chaîne | trueExpr | branche « True » (non zéro)
comme trueExpr | falseExpr | branche « False » (zéro)

Résultat

Type | Description
comme trueExpr, falseExpr | trueExpr if cond [image] 0; falseExpr if cond = 0
Remarque :

Contrairement à une expression if [voir L'expression if] ou une expression case [voir L'expression case], les deux branches sont évaluées par la fonction cond.

Plus important encore, cond préserve l'incertitude d'une valeur null [voir La valeur null] dans la condition.

Si vous n'avez pas besoin de ce comportement, utilisez une expression if ou case pour la vitesse.

Exemples Pour cibler des clients avec une dépense de zéro au deuxième trimestre pour une campagne de publipostage :

SpendQtr2 | cond(SpendQtr2, "Don't Mail", "Mail")
100.39 | Don't mail
0 | Mail
-5.72 | Mail
Null | Null

Voir également

clamp

iff

ifnull, nvl

replace

Sujet parent : Fonctions conditionnelles


iff

Objectif Générer l'un des deux résultats selon qu'une expression est null ou non null.

Syntaxe iff(logical_text, value_if_true, value_if_false)

Arguments

Type | Nom | Description
réel | logical_text | L'expression à tester
entier, réel, date ou chaîne | value_if_true | branche « True » (non zéro)
comme value_if_true | value_if_false | Branche « False » (zéro ou null)

Résultat

Type | Description
comme value_if_true, value_if_false | value_if_true if logical_text [image] 0; value_if_false if logical_text = 0 or logical_text is null

Exemples iff(Score > 650, "Mail", "No Mail")

Voir également

cond
Sujet parent : Fonctions conditionnelles


ifnull, nvl

Objectif Remplacer la valeur null. Vous pouvez utiliser nvl comme alias pour ifnull.

Syntaxe ifnull(testNull, replaceValue)

nvl(testNull, replaceValue)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | testNull | La valeur à tester
comme testNull | replaceValue | Le remplacement de la valeur null

Résultat

Type | Description
comme en entrée | Une copie de la valeur testNull avec replaceValue remplaçant la valeur null

Exemples Remplacer les valeurs manquantes par une valeur dérivée d'un autre champ :

SpendQtr1 | AnnualSpend | ifnull(SpendQtr1, AnnualSpend/4)
45.21 | 178.97 | 45.21
Null | 150.56 | 37.64
Null | 784.27 | 196.07
59.05 | 274.18 | 59.05

Voir également

cond

isnull

Sujet parent : Fonctions conditionnelles


isnull

Objectif Tester si une valeur est null.

Syntaxe isnull(x)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | x | La valeur à tester

Résultat

Type | Description
entier | 1 si x est null ; sinon 0

Exemples Pour remplacer les entrées de valeur null d'un champ par la valeur moyenne de ce champ :

Âge | if isnull(Age) then mean(Age) else Age
32 | 32
Null | 44
59 | 59
27 | 27

Voir également

Découpage des agrégations : la clause by
Sujet parent : Fonctions conditionnelles


isselected

Objectif Indiquer les enregistrements sélectionnés.

Syntaxe isselected()

Arguments Aucun

Résultat

Type | Description
entier | 1 si l'enregistrement est actuellement sélectionné, sinon 0
Remarque :

L'Aperçu du tableau bénéficie d'une prise en charge spéciale pour une expansion immédiate [voir Saisie de fonction assistée dans l'Aperçu du tableau] de cette fonction.

Exemples if isselected() then "LowRisk" else "HighRisk"

Sujet parent : Fonctions conditionnelles


replace

Objectif Remplacer un nombre s'il ne se trouve pas dans un intervalle donné.

Syntaxe replace(x, min, max, y)

Arguments

Type | Nom | Description
numérique | x | Le nombre à tester
comme x | min | La limite inférieure de l'intervalle
comme x | max | La limite supérieure de l'intervalle
comme x | y | La valeur de remplacement

Résultat

Type | Description
comme en entrée | x si [image] ; y sinon

Exemples Pour fixer les valeurs entre 18 et 65 inclus, en remplaçant les valeurs en dehors de la plage par la valeur moyenne :

CustomerAge | replace (CustomerAge, 18, 65, mean(CustomerAge))
9 | 38
18 | 18
66 | 38
43 | 43

Voir également

clamp
Sujet parent : Fonctions conditionnelles


Fonctions de conversion du type de données

  • todate
  • tointeger
  • toreal
  • tostring
Sujet parent : fonctions FDL


todate

Objectif Convertir une valeur en date.

Syntaxe todate(x [, format] )

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | x | Une valeur à convertir
chaîne | mise en forme | Un format de date [voir Formats de date] à utiliser pour la conversion (optionnel et seulement autorisé si x est d'un type de chaîne)

Résultat

Type | Description
date | x, en tant que date
Remarque :
  • Si l'argument est de type d'entier, il faut représenter la date comme suit AAAAMMJJ.
  • Si l'argument est de type réel, il faut représenter la date comme suit AAAAMMJJ.HHMMSS.
  • Si l'argument est de type chaîne et qu'aucun format de date n'est fourni, la chaîne est convertie en fonction de la configuration de votre préférence lecture [voir lire].

Exemples (Valeurs de date indiquées avec un format de date européen.)

todate(20040109) est égal à 09/01/2004:00:00:00.

todate(20040109,122853) est égal à 09/01/2004:12:08:52.

todate("09/01/2004") est égal à 09/01/2004:00:00:00.

todate("09-Jan-2004","%d-%b-%Y") est égal à 09/01/2004:00:00:00.

todate(#09/01/2004:12:28:53) est égal à 09/01/2004:12:28:53.

Voir également

tointeger

toreal

tostring

Conversion de type

Sujet parent : Fonctions de conversion du type de données


tointeger

Objectif Convertir une valeur en entier.

Syntaxe tointeger(x)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | x | Une valeur à convertir

Résultat

Type | Description
entier | x, en tant qu'entier
Remarque :
  • Si l'argument est de type réel, les chiffres après la décimale sont ignorés.
  • Si l'argument est de type date, le résultat est sous la forme AAAAMMJJ (le composant temps est ignoré).
  • Si l'argument est de type chaîne, tout caractère de séparation non numérique est ignoré.

Exemples tointeger(100) est égal à 100.

tointeger(100.65) est égal à 100.

tointeger("100.65") est égal à 100.

tointeger(#09/01/2004:12:28:53) est égal à 20040109.

Voir également

todate

toreal

tostring

Conversion de type

Sujet parent : Fonctions de conversion du type de données


toreal

Objectif Convertir une valeur en nombre réel.

Syntaxe toreal(x)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | x | Une valeur à convertir

Résultat

Type | Description
réel | x, en tant que nombre réel
Remarque :
  • Si l'argument est de type date, le résultat est sous la forme AAAAMMJJ.HHMMSS.
  • Si l'argument est de type chaîne, tout caractère de séparation non numérique est ignoré.

Exemples toreal(100) est égal à 100.0.

toreal(100.65) est égal à 100.65.

toreal("100.65") est égal à 100.65.

toreal(#09/01/2004:12:28:53) est égal à 20040109.122853.

Voir également

todate

tointeger

tostring

Conversion de type

Sujet parent : Fonctions de conversion du type de données


tostring

Objectif Convertir une valeur en chaîne.

Syntaxe tostring(x)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | x | Une valeur à convertir

Résultat

Type | Description
chaîne | x, en tant que chaîne
Remarque :
  • Si l'argument est de type réel, le résultat est au format décimal ordinaire (non scientifique).
  • Si l'argument est de type date, le résultat est formaté en fonction de la configuration de votre préférence format de la date [voir format de la date].

Exemples tostring(100) est égal à "100".

tostring(1.0065e2) est égal à "100.650000".

tostring("100.65") est égal à "100.65".

tostring(#09/01/2004:12:28:53) est égal à "09/01/2004:12:28:53".

Voir également

todate

tointeger

toreal

Conversion de type

Sujet parent : Fonctions de conversion du type de données


Fonctions spécifiques aux dates

  • addcenturies, addcenturiescountbackwards
  • adddays
  • addhours
  • addminutes
  • addmonths, addmonthscountbackwards
  • addseconds
  • addweeks
  • addyears, addyearscountbackwards
  • countcenturies
  • countdays
  • counthours
  • countminutes
  • countseconds
  • countweeks
  • countwholecenturies, countwholecenturiesbackwards
  • countwholedays
  • countwholehours
  • countwholeminutes
  • countwholemonths, countwholemonthsbackwards
  • countwholeseconds
  • countwholeweeks
  • countwholeyears, countwholeyearsbackwards
  • countyears
  • day
  • dayofweek
  • gmt2edt
  • hour
  • minute
  • month
  • now
  • second
  • today
  • weekofyear
  • year
Sujet parent : fonctions FDL


addcenturies, addcenturiescountbackwards

Objectif Calculer une date à partir d'une autre date à l'aide d'une compensation en siècles.

Syntaxe addcenturies(date, n)

addcenturiescountbackwards(date, n)

Arguments

Type | Nom | Description
date | date | La date de début
entier | n | Le nombre de siècles à ajouter (qui peut être négatif)

Résultat

Type | Description
date | La date n siècles civils après la date date (interprétée comme |n| siècles avant la date si n < 0). La partie temps du résultat est la même que la partie temps de date. Voir addmonths, addmonthscountbackwards pour une explication des deux variantes.
Remarque :

Le résultat de l'ajout de n siècles à l'aide de la fonction addcenturies (respectivement addcenturiescountbackwards) est défini pour être le résultat de l'ajout de 1200n mois avec la fonction addmonths (respectivement addmonthscountbackwards).

Exemples Pour calculer une date un siècle plus tard que d, affichant la différence entre les variantes addcenturies et addcenturiescountbackwards (format de date AMJ) :

d | addcenturies(d,1) | addcenturiescountbackwards(d,1)
1900/02/14 | 2000/02/14 | 2000/02/15
Voir également

countcenturies

countwholecenturies, countwholecenturiesbackwards

Formats de date

Sujet parent : Fonctions spécifiques aux dates


adddays

Objectif Calculer une date à partir d'une autre date à l'aide d'une compensation en jours.

Syntaxe adddays(date, n)

Arguments

Type | Nom | Description
date | date | La date de début
entier | n | Le nombre de jours à ajouter (qui peut être négatif)

Résultat

Type | Description
date | La date n jours après la date date (interprétée comme |n| jours avant date si n < 0). La partie temps du résultat est la même que la partie temps de date.

Exemples Format de date européen : adddays(#09/01/2004, 25) est égal à 03/02/2004.

Format de date européen : adddays(#09/01/2004:11:43:46, 25) est égal à 03/02/2004:11:43:46.

Format de date américain : adddays(#01/09/2004, 25) est égal à 02/03/2004.

Format de date américain : adddays(#01/09/2004:11:43:46, 25) est égal à 02/03/2004:11:43:46.

Format de date AMJ : adddays(#2004/01/09, 25) est égal à 2004/02/03.

Format de date AMJ : adddays(#2004/01/09:11:43:46, 25) est égal à 2004/02/03:11:43:46.

Voir également

countdays

countwholedays

Formats de date

Sujet parent : Fonctions spécifiques aux dates


addhours

Objectif Calculer une date à partir d'une autre date à l'aide d'une compensation en heures.

Syntaxe addhours(date, n)

Arguments

Type | Nom | Description
date | date | La date de début
entier | n | Le nombre d'heures à ajouter (qui peut être négatif)

Résultat

Type | Description
date | La date n heures après la date date (interprétée comme |n| heures avant date si n < 0)
Remarque :

Toutes les dates dans FDL comprennent un composant temps.

Exemples Format de date européen : addhours(#09/01/2004:12:28:53, 25) est égal à 10/01/2004:13:28:53.

Format de date américain : addhours(#01/09/2004:12:28:53, 25) est égal à 01/10/2004:13:28:53.

Format de date AMJ : addhours(#2004/01/09:12:28:53, 25) est égal à 2004/01/10:13:28:53.

Voir également

counthours

countwholehours

Formats de date

Sujet parent : Fonctions spécifiques aux dates


addminutes

Objectif Calculer une date à partir d'une autre date à l'aide d'une compensation en minutes.

Syntaxe addminutes(date, n)

Arguments

Type | Nom | Description
date | date | La date de début
entier | n | Le nombre de minutes à ajouter (qui peut être négatif)

Résultat

Type | Description
date | La date n minutes après la date date (interprétée comme |n| minutes avant date si n < 0)
Remarque :

Toutes les dates dans FDL comprennent un composant temps.

Exemples Format de date européen : addminutes(#09/01/2004:12:28:53, 25) est égal à 09/01/2004:12:53:53.

Format de date américain : addminutes(#01/09/2004:12:28:53, 25) est égal à 01/09/2004:12:53:53.

Format de date AMJ : addminutes(#2004/01/09:12:28:53, 25) est égal à 2004/01/09:12:53:53.

Voir également

countminutes

countwholeminutes

Formats de date

Sujet parent : Fonctions spécifiques aux dates


addmonths, addmonthscountbackwards

Objectif Calculer une date à partir d'une autre date à l'aide d'une compensation en mois.

Syntaxe addmonths(date, n)

addmonthscountbackwards(date, n)

Arguments

Type | Nom | Description
date | date | La date de début
entier | n | Le nombre de mois à ajouter (qui peut être négatif)
Résultat
Type Description
date La date n mois civils après la date date (interprétée comme |n| mois avant la date si n < 0).

Le mois et l'année du résultat sont déterminés par la compensation n.

Le jour du mois du résultat est alors défini pour être le même que celui de la date date (pour addmonths) ou le même nombre de jours de la fin du mois comme il est dans la date date (pour addmonthscountbackwards).

Si le jour du mois se termine avant le début ou après la fin du mois (car le mois résultat est un mois plus court que le mois contenant la date), il est fixé au premier ou au dernier jour du mois selon les cas.

La partie temps du résultat est la même que la partie temps de date.

Remarque :
  • Si vous ajoutez n mois avec addmonths (ou addmonthscountbackwards), vous n'obtenez pas nécessairement le même résultat que celui que vous obtenez en ajoutant un mois n fois, car le jour du mois peut être contraint par un mois court intermédiaire dans ce dernier cas.
  • Les résultats d'addition à une date avec addmonths et addmonthscountbackwards peuvent différer si le mois de la date et le mois du résultat comprennent un nombre de jours différents.

Exemples Pour calculer une date un mois plus tard que d, en affichant la propagation des parties du temps (format de date AMJ) :

d | addmonths(d,1)
2007/08/14:00:00:00 | 2007/09/14:00:00:00
2007/08/14:12:34:56 | 2007/09/14:12:34:56

Pour calculer une date un mois plus tard que d, affichant la différence entre les variantes addmonths et addmonthscountbackwards (format de date AMJ) :

d | addmonths(d,1) | addmonthscountbackwards(d,1)
2007/08/14 | 2007/09/14 | 2007/09/13

Pour calculer une date un mois plus tard que d, affichant le comportement de fixation de addmonths à la fin d'un mois (format de date AMJ) :

d | addmonths(d,1)
2007/08/31 | 2007/09/30

Pour calculer une date un mois plus tard que d, affichant le comportement de fixation de addmonthscountbackwards au début du mois (format de date AMJ) :

d | addmonthscountbackwards(d,1)
2007/08/02 | 2007/09/01
2007/08/01 | 2007/09/01

Pour calculer l'anniversaire des six mois de l'acquisition de chaque client à l'aide du champ de date d'acquisition du client StartDate:

addmonths(StartDate, 6)

Voir également

countwholemonths, countwholemonthsbackwards

Formats de date

Sujet parent : Fonctions spécifiques aux dates


addseconds

Objectif Calculer une date à partir d'une autre date à l'aide d'une compensation en secondes.

Syntaxe addseconds(date, n)

Arguments

Type | Nom | Description
date | date | La date de début
entier | n | Le nombre de secondes à ajouter (qui peut être négatif)

Résultat

Type | Description
date | Les secondes de la date n après la date date (interprétée comme |n| secondes avant date si n < 0)
Remarque :

Toutes les dates dans FDL comprennent un composant temps.

Exemples Format de date européen : addseconds(#09/01/2004:12:28:53, 25) est égal à 09/01/2004:12:54:18.

Format de date américain : addseconds(#01/09/2004:12:28:53, 25) est égal à 01/09/2004:12:54:18.

Format de date AMJ : addseconds(#2004/01/09:12:28:53, 25) est égal à 2004/01/09:12:54:18.

Voir également

countseconds

countwholeseconds

Formats de date

Sujet parent : Fonctions spécifiques aux dates


addweeks

Objectif Calculer une date à partir d'une autre date à l'aide d'une compensation en semaines.

Syntaxe addweeks(date, n)

Arguments

Type | Nom | Description
date | date | La date de début
entier | n | Le nombre de semaines à ajouter (qui peut être négatif)

Résultat

Type | Description
date | La date n semaines après la date date (interprétée comme |n| semaines avant date si n < 0). La partie temps du résultat est la même que la partie temps de date.

Exemples Format de date européen : addweeks(#09/01/2004, 8) est égal à 05/03/2004.

Format de date américain : addweeks(#01/09/2004, 8) est égal à 03/05/2004.

Format de date AMJ : addweeks(#2004/01/09, 8) est égal à 2004/03/05.

Voir également

countweeks

countwholeweeks

Formats de date

Sujet parent : Fonctions spécifiques aux dates


addyears, addyearscountbackwards

Objectif Calculer une date à partir d'une autre date à l'aide d'une compensation en années.

Syntaxe addyears(date, n)

addyearscountbackwards(date, n)

Arguments

Type | Nom | Description
date | date | La date de début
entier | n | Le nombre d'années à ajouter (qui peut être négatif)

Résultat

Type | Description
date | La date n années civiles après la date date (interprétée comme |n| années avant la date si n < 0). La partie temps du résultat est la même que la partie temps de date. Voir addmonths, addmonthscountbackwards pour une explication des deux variantes.
Remarque :

Le résultat de l'ajout de n années à l'aide de la fonction addyears (respectivement addyearscountbackwards) est défini pour être le résultat de l'ajout de 12n mois avec la fonction addmonths (respectivement addmonthscountbackwards).

Exemples Pour calculer une date une année plus tard que d, affichant la différence entre les variantes addyears et addyearscountbackwards (format de date AMJ) :

d | addyears(d,1) | addyearscountbackwards(d,1)
2007/02/14 | 2008/02/14 | 2008/02/15

Pour calculer la date anniversaire de l'acquisition de chaque client à l'aide du champ de date d'acquisition du client StartDate :

addyears(StartDate, 1)

Voir également

countwholeyears, countwholeyearsbackwards

countyears

Formats de date

Sujet parent : Fonctions spécifiques aux dates


countcenturies

Objectif Calculer la période entre deux dates en siècles.

Syntaxe countcenturies(date1, date2)

Arguments

Type | Nom | Description
date | date1 | la première date
date | date2 | la deuxième date

Résultat

Type | Description
réel | La période entre date1 et date2 en siècles (un nombre négatif si date1 est postérieure à date2)
Remarque :
  • Si le numéro n'est pas un multiple exact de 100 ans (prenant les heures des dates en compte), le résultat comprend une partie fractionnelle.
  • Le résultat de la fonction countcenturies est défini pour être le résultat de la fonction countyears divisé par 100.

Exemples Format de date européen : countcenturies(#09/01/2004, #09/01/2054) est égal à 0.5.

Format de date américain : countcenturies(#01/09/2004, #01/09/2054) est égal à 0.5.

Format de date AMJ : countcenturies(#2004/01/09, #2054/01/09) est égal à 0,5.

Voir également

countwholecenturies, countwholecenturiesbackwards

Formats de date

Sujet parent : Fonctions spécifiques aux dates


countdays

Objectif Calculer la période entre deux dates en jours.

Syntaxe countdays(date1, date2)

Arguments

Type | Nom | Description
date | date1 | la première date
date | date2 | la deuxième date

Résultat

Type | Description
réel | La période entre date1 et date2 en jours (négatif si date1 est postérieure à date2)
Remarque :

Si les parties heure des deux dates diffèrent, le résultat comprend une partie fractionnelle.

Exemples Format de date européen : countdays(#09/01/2004, #03/02/2004) est égal à 25.

countdays(#09/01/2004:10:00:00, #03/02/2004:11:00:00) est égal à 25.04.

countdays(#09/01/2004:11:00:00, #03/02/2004:10:00:00) est égal à 24.96.

Format de date américain : countdays(#01/09/2004, #02/03/2004) est égal à 25.

countdays(#01/09/2004:10:00:00, #02/03/2004:11:00:00) est égal à 25.04.

countdays(#01/09/2004:11:00:00, #02/03/2004:10:00:00) est égal à 24.96.

Format de date AMJ : countdays(#2004/01/09, #2004/02/03) est égal à 25.

countdays(#2004/01/09:10:00:00, #2004/02/03:11:00:00) est égal à 25.04.

countdays(#2004/01/09:11:00:00, #2004/02/03:10:00:00) est égal à 24.96.

Voir également

adddays

countwholedays

Formats de date

Sujet parent : Fonctions spécifiques aux dates


counthours

Objectif Calculer la période entre deux dates en heures.

Syntaxe counthours(time1, time2)

Arguments

Type | Nom | Description
date | time1 | la première date/heure
date | time2 | la deuxième date/heure

Résultat

Type | Description
réel | La période entre time1 et time2 en heures (un nombre négatif si time1 est postérieure à time2)
Remarque :

Si les minutes ou secondes des deux dates diffèrent, le résultat comprend une partie fractionnelle.

Exemples Format de date européen : counthours(#09/01/2004:12:28:53, #10/01/2004:13:28:53) est égal à 25.

Format de date américain : counthours(#01/09/2004:12:28:53, #01/10/2004:13:28:53) est égal à 25.

Format de date AMJ : counthours(#2004/01/09:12:28:53, #2004/01/10:13:28:53) est égal à 25.

Voir également

countwholehours

Formats de date

Sujet parent : Fonctions spécifiques aux dates


countminutes

Objectif Calculer la période entre deux dates en minutes.

Syntaxe countminutes(time1, time2)

Arguments

Type | Nom | Description
date | time1 | la première date/heure
date | time2 | la deuxième date/heure

Résultat

Type | Description
réel | La période entre time1 et time2 en minutes (si time1 est postérieure à time2)
Remarque :

Si les secondes des deux dates diffèrent, le résultat comprend une partie fractionnelle.

Exemples Format de date européen : countminutes(#09/01/2004:12:28:53, #09/01/2004:12:53:53) est égal à 25.

Format de date américain : countminutes(#01/09/2004:12:28:53, #01/09/2004:12:53:53) est égal à 25.

Format de date AMJ : countminutes(#2004/01/09:12:28:53, #2004/01/09:12:53:53) est égal à 25.

Voir également

countwholeminutes

Formats de date

Sujet parent : Fonctions spécifiques aux dates


countseconds

Objectif Compter le nombre de secondes entre deux dates.

Syntaxe countseconds(time1, time2)

Arguments

Type | Nom | Description
date | time1 | la première date/heure
date | time2 | la deuxième date/heure

Résultat

Type | Description
réel | Le nombre de secondes entre time1 et time2 (négatif si time1 est postérieure à time2)
Remarque :

La seule différence entre cette fonction et countwholeseconds est que le résultat du dernier est de type entier.

Exemples Format de date européen : countseconds(#09/01/2004:12:28:53, #09/01/2004:12:29:18) est égal à 25.

Format de date américain : countseconds(#01/09/2004:12:28:53, #01/09/2004:12:29:18) est égal à 25.

Format de date AMJ : countseconds(#2004/01/09:12:28:53, #2004/01/09:12:29:18) est égal à 25.

Voir également

Formats de date
Sujet parent : Fonctions spécifiques aux dates


countweeks

Objectif Calculer la période entre deux dates en semaines.

Syntaxe countweeks(date1, date2)

Arguments

Type | Nom | Description
date | date1 | la première date
date | date2 | la deuxième date

Résultat

Type | Description
réel | La période entre date1 et date2 en semaines (négatif si date1 est postérieure à date2)
Remarque :

Si la période n'est pas un multiple exact de sept jours (prenant l'heure des dates en compte), le résultat comprend une partie fractionnelle.

Exemples Format de date européen : countweeks(#09/01/2004, #05/03/2004) est égal à 8.

Format de date américain : countweeks(#01/09/2004, #03/05/2004) est égal à 8.

Format de date AMJ : countweeks(#2004/01/09, #2004/03/05) est égal à 8.

Voir également

countwholeweeks

Formats de date

Sujet parent : Fonctions spécifiques aux dates


countwholecenturies, countwholecenturiesbackwards

Objectif Compter le nombre de siècles complets entre deux dates.

Syntaxe countwholecenturies(date1, date2) countwholecenturiesbackwards(date1, date2)

Arguments

Type | Nom | Description
date | date1 | la première date
date | date2 | la deuxième date

Résultat

Type | Description
entier | Le nombre de siècles complets écoulés entre date1 et date2 (un nombre négatif si date1 est postérieure à date2). Voir countwholemonths, countwholemonthsbackwards pour une explication des deux variantes.
Remarque :
  • Le résultat de la fonction countwholecenturies (respectivement countwholecenturiesbackwards) est défini comme le résultat de la fonction countwholemonths (respectivement countwholemonthsbackwards) divisé par 1 200, ignorant tout reste.
  • Les résultats de la comparaison des deux dates avec countwholecenturies et countwholecenturiesbackwards peuvent différer, mais seulement lorsque les deux dates se trouvent en février, une date se trouve dans une année divisible par 400 et l'autre se trouve dans une année divisible par 100 mais non divisible par 400.

Exemples Pour compter le nombre de siècles complets entre d1 et d2, affichant la différence entre les variantes countwholecenturies et countwholecenturiesbackwards (format de date AMJ) :

d1 | d2 | countwholecenturies(d1,d2) | countwholecenturiesbackwards(d1,d2)
1900/02/14 | 2000/02/13 | 0 | 0
1900/02/14 | 2000/02/14 | 1 | 0
1900/02/14 | 2000/02/15 | 1 | 1

Voir également

addcenturies, addcenturiescountbackwards

countcenturies

Formats de date

Sujet parent : Fonctions spécifiques aux dates


countwholedays

Objectif Compter le nombre de jours complets entre deux dates.

Syntaxe countwholedays(date1, date2)

Arguments

Type | Nom | Description
date | date1 | la première date
date | date2 | la deuxième date

Résultat

Type | Description
entier | Le nombre de périodes de 24 heures complètes écoulées entre date1 et date2 (un nombre négatif si date1 est postérieure à date2)

Exemples Format de date européen : countdays(#09/01/2004, #03/02/2004) est égal à 25.

countdays(#09/01/2004:10:00:00, #03/02/2004:11:00:00) est égal à 25.

countdays(#09/01/2004:11:00:00, #03/02/2004:10:00:00) est égal à 24.

Format de date américain : countdays(#01/09/2004, #02/03/2004) est égal à 25.

countdays(#01/09/2004:10:00:00, #02/03/2004:11:00:00) est égal à 25.

countdays(#01/09/2004:11:00:00, #02/03/2004:10:00:00) est égal à 24.

Format de date AMJ : countdays(#2004/01/09, #2004/02/03) est égal à 25.

countdays(#2004/01/09:10:00:00, #2004/02/03:11:00:00) est égal à 25.

countdays(#2004/01/09:11:00:00, #2004/02/03:10:00:00) est égal à 24.

Voir également

adddays

countdays

Formats de date

Sujet parent : Fonctions spécifiques aux dates


countwholehours

Objectif Compter le nombre d'heures complètes entre deux dates.

Syntaxe countwholehours(time1, time2)

Arguments

Type | Nom | Description
date | time1 | la première date/heure
date | time2 | la deuxième date/heure

Résultat

Type | Description
entier | Le nombre d'heures complètes écoulées entre time1 et time2 (un nombre négatif si time1 est postérieure à time2)

Exemples Format de date européen : countwholehours(#09/01/2004:12:28:53, #10/01/2004:13:28:53) est égal à 24.

Format de date américain : countwholehours(#01/09/2004:12:28:53, #01/10/2004:13:28:53) est égal à 24.

Format de date AMJ : countwholehours(#2004/01/09:12:28:53, #2004/01/10:13:28:53) est égal à 24.

Voir également

counthours

Formats de date

Sujet parent : Fonctions spécifiques aux dates


countwholeminutes

Objectif Compter le nombre de minutes complètes entre deux dates.

Syntaxe countwholeminutes(time1, time2)

Arguments

Type | Nom | Description
date | time1 | la première date/heure
date | time2 | la deuxième date/heure

Résultat

Type | Description
entier | Le nombre de minutes complètes écoulées entre time1 et time2 (négatif si time1 est postérieure à time2)

Exemples Format de date européen : countwholeminutes(#09/01/2004:12:28:53, #09/01/2004:12:53:53) est égal à 24.

Format de date américain : countwholeminutes(#01/09/2004:12:28:53, #01/09/2004:12:53:53) est égal à 24.

Format de date AMJ : countwholeminutes(#2004/01/09:12:28:53, #2004/01/09:12:53:53) est égal à 24.

Voir également

countminutes

Formats de date

Sujet parent : Fonctions spécifiques aux dates


countwholemonths, countwholemonthsbackwards

Objectif Compter le nombre de mois complets entre deux dates.

Syntaxe countwholemonths(date1, date2) countwholemonthsbackwards(date1, date2)

Arguments

Type | Nom | Description
date | date1 | la première date
date | date2 | la deuxième date

Résultat

Type | Description
entier | Le nombre de mois complets écoulés entre date1 et date2 (un nombre négatif si date1 est postérieure à date2)
Remarque :
  • Les parties heure de date1 et date2 sont ignorées.
  • Le nombre de mois complets entre deux dates est le nombre le plus grand de mois qui peut être ajouté à la première date (troncation des parties de l'heure et utilisation de addmonths dans le cas de countwholemonths et addmonthscountbackwards dans le cas de countwholemonthsbackwards) de telle sorte que, si la deuxième date est postérieure à la première date, le résultat ne soit pas ultérieur à la deuxième date, et si la deuxième date est antérieure à la première date, le résultat ne soit pas antérieur à la deuxième date.
  • Les résultats de la comparaison des deux dates avec countwholemonths et countwholemonthsbackwards peuvent différer lorsque les dates se trouvent dans des mois de longueurs différentes.
  • En raison du comportement de fixation de addmonths (et addmonthscountbackwards), la valeur absolue des résultats de comparaison de deux dates avec countwholemonths (ou countwholemonthsbackwards) peut dépendre de l'ordre des arguments lorsque les dates se trouvent dans des mois de longueurs différentes.

Exemples Pour compter le nombre de mois complets entre d1 et d2, affichant la troncation des parties de l'heure (format de date AMJ) :

d1 | d2 | countwholemonths(d1,d2)
2007/08/14:00:00:00 | 2007/09/14:00:00:00 | 1
2007/08/14:12:34:56 | 2007/09/14:00:00:00 | 1

Pour compter le nombre de mois complets entre d1 et d2, affichant la différence entre les variantes countwholemonths et countwholemonthsbackwards (format de date AMJ) :

d1 | d2 | countwholemonths(d1,d2) | countwholemonthsbackwards(d1,d2)
2007/08/14 | 2007/09/12 | 0 | 0
2007/08/14 | 2007/09/13 | 0 | 1
2007/08/14 | 2007/09/14 | 1 | 1

Pour compter le nombre de mois complets entre d1 et d2, en affichant le comportement de fixation de countwholemonths à la fin du mois (format de date AMJ) :

d1 | d2 | countwholemonths(d1,d2) | countwholemonths(d2,d1)
2007/08/31 | 2007/09/30 | 1 | 0

Pour compter le nombre de mois complets entre d1 et d2, affichant le comportement de fixation de countwholemonths au début du mois (format de date AMJ) :

d1 | d2 | countwholemonthsbackwards(d1,d2) | countwholemonthsbackwards(d2,d1)
2007/07/01 | 2007/06/01 | -1 | 0

Pour compter le nombre de communications électroniques mensuelles que chaque client a reçues, où les communications sont envoyées le cinquième jour de chaque mois (la dernière communication ayant été envoyée le 5 mars 2006) et à l'aide du champ de date d'acquisition du client StartDate :

-countwholemonths(#2006/03/05, StartDate)

Pour compter le nombre d'instructions mensuelles que chaque client a reçues, où les instructions sont envoyées sept jours avant la fin de chaque mois (la dernière instruction ayant été envoyée le 24 mars 2006) et avec le champ de date d'acquisition du client StartDate :

-countwholemonthsbackwards(#2006/03/24, StartDate)

Voir également

addmonths, addmonthscountbackwards

Formats de date

Sujet parent : Fonctions spécifiques aux dates


countwholeseconds

Objectif Compter le nombre de secondes entre deux dates.

Syntaxe countwholeseconds(time1, time2)

Arguments

Type | Nom | Description
date | time1 | la première date/heure
date | time2 | la deuxième date/heure

Résultat

Type | Description
entier | Le nombre de secondes entre time1 et time2 (négatif si time1 est postérieure à time2)
Remarque :

La seule différence entre cette fonction et countseconds est que le résultat du dernier est de type réel.

Exemples Format de date européen : countwholeseconds(#09/01/2004:12:28:53, #09/01/2004:12:29:18) est égal à 25.

Format de date américain : countwholeseconds(#01/09/2004:12:28:53, #01/09/2004:12:29:18) est égal à 25.

Format de date AMJ : countwholeseconds(#2004/01/09:12:28:53, #2004/01/09:12:29:18) est égal à 25.

Voir également

Formats de date
Sujet parent : Fonctions spécifiques aux dates


countwholeweeks

Objectif Compter le nombre de semaines complètes entre deux dates.

Syntaxe countwholeweeks(date1, date2)

Arguments

Type | Nom | Description
date | date1 | la première date
date | date2 | la deuxième date

Résultat

Type | Description
entier | Le nombre de semaines complètes écoulées entre date1 et date2 négatif si date1 est postérieure à date2)

Exemples Format de date européen : countwholeweeks(#09/01/2004, #09/03/2004) est égal à 8.

Format de date américain : countwholeweeks(#01/09/2004, #03/09/2004) est égal à 8.

Format de date AMJ : countwholeweeks(#2004/01/09, #2004/03/09) est égal à 8.

Voir également

countweeks

Formats de date

Sujet parent : Fonctions spécifiques aux dates


countwholeyears, countwholeyearsbackwards

Objectif Compter le nombre d'années complètes entre deux dates.

Syntaxe countwholeyears(date1, date2)

countwholeyearsbackwards(date1, date2)

Arguments

Type | Nom | Description
date | date1 | la première date
date | date2 | la deuxième date

Résultat

Type | Description
entier | Le nombre d'années complètes écoulées entre date1 et date2 (un nombre négatif si date1 est postérieure à date2). Voir countwholemonths, countwholemonthsbackwards pour une explication des deux variantes.
Remarque :
  • Le résultat de la fonction countwholeyears (respectivement countwholeyearsbackwards) est défini comme le résultat de la fonction countwholemonths (respectivement countwholemonthsbackwards) divisé par 12, ignorant tout reste.
  • Les résultats de la comparaison de deux dates avec countwholeyears et countwholeyearsbackwards peuvent différer, mais seulement lorsque les deux dates se trouvent en février, une date se trouve dans une année bissextile et l'autre non.

Exemples Pour compter le nombre d'années complètes entre d1 and d2, affichant la différence entre les variantes countwholeyears et countwholeyearsbackwards (format de date AMJ) :

d1 | d2 | countwholeyears(d1,d2) | countwholeyearsbackwards(d1,d2)
2007/02/14 | 2008/02/13 | 0 | 0
2007/02/14 | 2008/02/14 | 1 | 0
2007/02/14 | 2008/02/15 | 1 | 1
Pour calculer l'âge de chaque client au 1er mars 2007 à partir du champ date de naissance DDN (format de date AMJ) :

countwholeyears(DDN, #2007/03/01)

Voir également

addyears, addyearscountbackwards

countyears

Formats de date

Sujet parent : Fonctions spécifiques aux dates


countyears

Objectif Calculer la période entre deux dates en années.

Syntaxe countyears(date1, date2)

Arguments

Type | Nom | Description
date | date1 | la première date
date | date2 | la deuxième date

Résultat

Type | Description
réel | La période entre date1 et date2 en années (un nombre négatif si date1 est postérieure à date2)
Remarque :
  • Si le mois, le jour ou l'heure des deux dates diffèrent, le résultat comprend une partie fractionnelle, comptant l'année incomplète comme une fraction du nombre de jours (365 ou 366) dans l'année de la date dont l'échéance est la plus lointaine.

Exemples Format de date européen : countyears(#09/01/2004, #09/01/1994) est égal à -10.

Format de date américain : countyears(#01/09/2004, #01/09/1994) est égal à -10.

Format de date AMJ : countyears(#2004/01/09, #1994/01/09) est égal à -10.

Voir également

countwholeyears, countwholeyearsbackwards

Formats de date

Sujet parent : Fonctions spécifiques aux dates


day

Objectif Obtenir le jour du mois d'une date.

Syntaxe day(date)

Arguments

Type | Nom | Description
date | date | Une date

Résultat

Type | Description
entier | Le jour du mois de date

Exemples Format de date européen : day(#09/01/2004) est égal à 9.

Format de date américain : day(#01/09/2004) est égal à 9.

Format de date AMJ : day(#2004/01/09) est égal à 9.

Voir également

Formats de date

Découpage des agrégations : la clause by

Sujet parent : Fonctions spécifiques aux dates


dayofweek

Objectif Obtenir un nombre représentant le jour de la semaine d'une date.

Syntaxe dayofweek(date)

Arguments

Type | Nom | Description
date | date | Une date

Résultat

Type | Description
entier | Le jour de la semaine de date (un nombre entre 0 et 6, 0 représentant dimanche)

Exemples Format de date européen : dayofweek(#09/01/2004) est égal à 5 (c'est-à-dire, vendredi).

Format de date américain : dayofweek(#01/09/2004) est égal à 5 (c'est-à-dire, vendredi).

Format de date AMJ : dayofweek(#2004/01/09) est égal à 5 (c'est-à-dire, vendredi).

Voir également

Formats de date

Découpage des agrégations : la clause by

Sujet parent : Fonctions spécifiques aux dates


gmt2edt

Objectif Convertir une date en Temps Moyen de Greenwich (GMT) en Heure d'Été de l'Est (EDT).

Syntaxe gmt2edt(datetimeGMT)

Arguments

Type | Nom | Description
date | datetimeGMT | La date GMT à convertir

Résultat

Type | Description
date | La date EDT, pour l'heure d'été

Exemples Hiver : GMT2EDT(#09/01/2004:12:28:53) est égal à 09/01/2004:07:28:53.

Été : GMT2EDT(#09/07/2004:12:28:53) est égal à 09/07/2004:08:28:53.

Sujet parent : Fonctions spécifiques aux dates


hour

Objectif Obtenir les heures d'une date.

Syntaxe hour(time)

Arguments

Type | Nom | Description
date | heure | Une date/heure

Résultat

Type | Description
entier | La partie horaire de time

Exemples Format de date européen : hour(#09/01/2004:12:28:53) est égal à 12.

Format de date américain : hour(#01/09/2004:12:28:53) est égal à 12.

Format de date AMJ : hour(#2004/01/09:12:28:53) est égal à 12.

Voir également

Formats de date

Découpage des agrégations : la clause by

Sujet parent : Fonctions spécifiques aux dates


minute

Objectif Obtenir les minutes d'une date.

Syntaxe minute(time)

Arguments

Type | Nom | Description
date | heure | Une date/heure
Résultat
Type | Description
entier | Les minutes de time

Exemples Format de date européen : minute(#09/01/2004:12:28:53) est égal à 28.

Format de date américain : minute(#01/09/2004:12:28:53) est égal à 28.

Format de date AMJ : minute(#2004/01/09:12:28:53 est égal à 28.

Voir également

Formats de date

Découpage des agrégations : la clause by

Sujet parent : Fonctions spécifiques aux dates


month

Objectif Obtenir le mois d'une date.

Syntaxe month(date)

Arguments

Type | Nom | Description
date | date | Une date
Résultat
Type | Description
entier | Le mois de la date

Exemples Format de date européen : month(#09/01/2004) est égal à 1.

Format de date américain : month(#01/09/2004) est égal à 1.

Format de date AMJ : month(#2004/01/09) est égal à 1.

Voir également

Formats de date

Découpage des agrégations : la clause by

Sujet parent : Fonctions spécifiques aux dates


now

Objectif Obtenir la date et l'heure en cours.

Syntaxe now()

Arguments Aucun

Résultat

Type | Description
date | La date en cours (y compris l'heure), obtenue à partir de l'horloge système
Exemples Format de date européen : now() est égal à 09/01/2004:12:28:53.

Format de date américain : now() est égal à 01/09/2004:12:28:53.

Format de date AMJ : now() est égal à 2004/01/09:12:28:53.

Voir également

Formats de date

today

Sujet parent : Fonctions spécifiques aux dates


second

Objectif Obtenir les secondes d'une date.

Syntaxe second(time)

Arguments

Type | Nom | Description
date | heure | Une date/heure
Résultat
Type | Description
entier | Les secondes de time

Exemples Format de date européen : second(#09/01/2004:12:28:53) est égal à 53.

Format de date américain : second(#01/09/2004:12:28:53) est égal à 53.

Format de date AMJ : second(#2004/01/09:12:28:53) est égal à 53.

Voir également

Formats de date

Découpage des agrégations : la clause by

Sujet parent : Fonctions spécifiques aux dates


today

Objectif Obtenir la date en cours.

Syntaxe today()

Arguments Aucun

Résultat

Type | Description
date | La date en cours, obtenue à partir de l'horloge système, avec l'heure réglée sur 00:00:00
Exemples Format de date européen : today() est égal à 09/01/2004:00:00:00.

Format de date américain : today() est égal à 01/09/2004:00:00:00.

Format de date AMJ : today() est égal à 2004/01/09:00:00:00.

Voir également

Formats de date

now

Sujet parent : Fonctions spécifiques aux dates


weekofyear

Objectif Calculer la semaine de l'année d'une date, par rapport à une date de départ indiquée.

Syntaxe weekofyear(date, yearStart)

Arguments

Type | Nom | Description
date | date | La date de la semaine de l'année à obtenir
date | yearStart | La date de départ (par exemple, d'une année fiscale)
Résultat
Type | Description
entier | La semaine de l'année de date, par rapport à yearStart
Remarque :

Seuls le mois et le jour de la date de départ sont utilisés.

Exemples Format de date européen : weekofyear(#09/07/2004, #01/04/2004) est égal à 14.

Format de date américain : weekofyear(#07/09/2004, #04/01/2004) est égal à 14.

Format de date AMJ : weekofyear(#2004/07/09, #2004/04/01) est égal à 14.

Voir également

Formats de date

Découpage des agrégations : la clause by

Sujet parent : Fonctions spécifiques aux dates


year

Objectif Obtenir l'année d'une date.

Syntaxe year(date)

Arguments

Type | Nom | Description
date | date | Une date

Résultat

Type | Description
entier | L'année de date

Exemples Format de date européen : year(#09/01/2004) est égal à 2004.

Format de date américain : year(#01/09/2004) est égal à 2004.

Format de date AMJ : year(#2004/01/09) est égal à 2004.

Voir également

Formats de date
Sujet parent : Fonctions spécifiques aux dates


Fonctions mathématiques et statistiques

  • abs
  • ceil
  • cos
  • exp
  • floor
  • enregistrement
  • log10
  • logbase
  • normaliser
  • pow
  • round
  • sgn
  • sin
  • sqrt
  • tan
Sujet parent : fonctions FDL


abs

Objectif Calculer la valeur absolue d'un nombre.

Syntaxe abs(x)

Arguments

Type | Nom | Description
numérique | x | Un numéro signé

Résultat

Type | Description
comme en entrée | , la valeur absolue, ou la magnitude, de x

Exemples abs(10000) est égal à 10000.

abs(-25000) est égal à 25000.

Pour calculer l'erreur absolue entre une valeur prévue et une valeur historique : abs(Value - PredictedValue)

Voir également

sgn
Sujet parent : Fonctions mathématiques et statistiques


ceil

Objectif Arrondir un nombre à l'entier supérieur le plus proche.

Syntaxe ceil(x)

Arguments

Type | Nom | Description
numérique | x | Le nombre à arrondir
Résultat
Type | Description
entier | , l'entier comme

Exemples ceil(1.25) est égal à 2.

ceil(-1.25) est égal à -1.

Pour générer un entier aléatoire entre 1 et 10 inclus : ceil(rndUniform()*10)

Voir également

floor

round

Sujet parent : Fonctions mathématiques et statistiques


cos

Objectif Calculer le cosinus d'un angle.

Syntaxe cos(x)

Arguments

Type | Nom | Description
numérique | x | Un angle en radians
Résultat
Type | Description
réel | cos x, le cosinus de x

Exemples cos(0) est égal à 1.

Sujet parent : Fonctions mathématiques et statistiques


exp

Objectif Calculer l'exponentiel d'un nombre.

Syntaxe exp(x)

Arguments

Type | Nom | Description
numérique | x | Le nombre dont l'exponentiel doit être calculé
Résultat
Type | Description
réel | , l'exponentiel de x

Exemples exp(0) est égal à 1.

Sujet parent : Fonctions mathématiques et statistiques


floor

Objectif Arrondir un nombre à l'entier inférieur le plus proche.

Syntaxe floor(x)

Arguments

Type | Nom | Description
numérique | x | Le nombre à arrondir
Résultat
Type | Description
entier | , l'entier comme

Exemples floor(1.25) est égal à 1.

floor(-1.25) est égal à -2.

Pour générer un entier aléatoire entre 0 et 9 inclus : floor(rndUniform()*10)

Voir également

ceil

round

Sujet parent : Fonctions mathématiques et statistiques


enregistrement

Objectif Calculer le logarithme naturel (base-e) d'un nombre.

Syntaxe log(x)

Arguments

Type | Nom | Description
numérique | x | Un nombre positif
Résultat
Type | Description
réel | , le logarithme naturel de x

Exemples log(1) est égal à 0.

Sujet parent : Fonctions mathématiques et statistiques


log10

Objectif Calculer le logarithme en base-10 d'un nombre.

Syntaxe log10(x)

Arguments

Type | Nom | Description
numérique | x | Un nombre positif
Résultat
Type | Description
réel | , le logarithme en base-10 de x

Exemples log10(100) est égal à 2.

Sujet parent : Fonctions mathématiques et statistiques


logbase

Objectif calculer le logarithme d'un nombre en une base spécifiée.

Syntaxe logbase(x, base)

Arguments

Type | Nom | Description
numérique | x | Le nombre positif dont le logarithme doit être calculé
numérique | base | La base à utiliser
Résultat
Type | Description
réel | , le logarithme base- base de x

Exemples logbase(100,10) est égal à 2.

Sujet parent : Fonctions mathématiques et statistiques


normaliser

Objectif normaliser les valeurs de champ pour qu'elles tiennent dans l'intervalle [0,1].

Syntaxe normalize(x)

Arguments

Type | Nom | Description
numérique | x | Le nombre à normaliser
Résultat
Type | Description
réel | Valeur entre 0 et 1 donnée par
Remarque :

Vous ne pouvez utiliser cette fonction que dans un calcul Decision Studio, dans le fichier de calculs de qsderive ou la fenêtre équivalente Calculer des champs, dans le fichier de traceurs de qstrack, ou dans un fichier de sélections de qsselect.

Sujet parent : Fonctions mathématiques et statistiques


pow

Objectif Calculer le résultat de l'élévation d'un nombre à la puissance d'un autre nombre.

Syntaxe pow(x, exponent)

Arguments

Type | Nom | Description
numérique | x | Le nombre à élever à une puissance
numérique | exponent | L'exposant
Résultat
Type | Description
réel | , x élevé à la puissance exponent

Exemples pow(10, 2) est égal à 100.

Sujet parent : Fonctions mathématiques et statistiques


round

Objectif Arrondir un nombre à l'entier le plus proche.

Syntaxe round(x)

Arguments

Type | Nom | Description
numérique | x | Le nombre à arrondir
Résultat
Type | Description
entier | l'entier le plus proche de x, ou, en cas d'équivalence, le plus grand des deux entiers les plus proches (en valeur absolue)

Exemples round(1.25) est égal à 1.

round(-1.25) est égal à -1.

round(1.5) est égal à 2.

round(-1.5) est égal à -2.

Voir également

ceil

floor

Sujet parent : Fonctions mathématiques et statistiques


sgn

Objectif Calculer le signum (signe) d'un nombre.

Syntaxe sgn(x)

Arguments

Type | Nom | Description
numérique | x | Un numéro signé
Résultat
Type | Description
comme en entrée | Un nombre représentant le signe de x :

Exemples sgn(25) est égal à 1.

sgn(-25) est égal à -1.

Voir également

abs

Découpage des agrégations : la clause by

Sujet parent : Fonctions mathématiques et statistiques


sin

Objectif Calculer le sinus d'un angle.

Syntaxe sin(x)

Arguments

Type | Nom | Description
numérique | x | Un angle en radians
Résultat
Type | Description
réel | sin x, le sinus de x

Exemples sin(3.14159/2) est égal à 1.

Sujet parent : Fonctions mathématiques et statistiques


sqrt

Objectif Calculer la racine carrée d'un nombre.

Syntaxe sqrt(x)

Arguments

Type | Nom | Description
numérique | x | Un nombre non négatif
Résultat
Type | Description
réel | , la racine carré de x

Exemples sqrt(25) est égal à 5.

sqrt(-25) est égal à null.

Sujet parent : Fonctions mathématiques et statistiques


tan

Objectif Calculer la tangente d'un angle.

Syntaxe tan(x)

Arguments

Type | Nom | Description
numérique | x | Un angle en radians
Résultat
Type | Description
réel | tan x, la tangente de x
Remarque :

Si x est de la forme [image] pour un entier n, tan x est indéfini. Dans ce cas, la fonction FDL renvoie null.

Exemples tan(3.14159/4) est égal à 1.

Sujet parent : Fonctions mathématiques et statistiques


Autres fonctions

  • corbeille
  • dblookup
  • membre
  • rownum
Sujet parent : fonctions FDL


corbeille

Objectif Obtenir un indice de modalité correspondant à une valeur.

Syntaxe bin(binning, x)

Arguments

Type | Nom | Description
découpage | découpage | Un découpage nommé, avec des valeurs de paramètres (qui doivent être des valeurs littérales) entre parenthèses si nécessaire
entier, réel, date ou chaîne | x | Une valeur compatible avec le découpage
Résultat
Type | Description
entier | L'indice de modalité dans lequel x se trouve
Remarque :
  • Les indices de modalité sont des nombres entiers positifs. Pour un découpage numérique avec n modalités nominales (numérotées de 2 à n + 1), les modalités finales inférieure et supérieure [voir Modalités de fin] sont numérotées 1 et n + 2, respectivement, tandis que les modalités null et non classées sont numérotées n + 3 et n + 4.
  • Cette fonction n'est pas disponible dans Decision Studio. Cependant, si x est un champ et b est le découpage primaire associé à x, vous pouvez obtenir le même résultat grâce à segindex :

    segindex() selon x

Exemples Diviser les agrégations à l'aide du découpage par modalité identique EqualRange sur le champ Amount, pour obtenir une agrégation segmentée de huit manières (quatre modalités internes entre des valeurs de quantité 20 et 100, et deux modalités finales, une modalité null et une modalité non classée) :

create totalPointsByAmountBands :=

sum(PointsRedeemed) by bin(EqualRange(20, 100, 4), Amount);

Partager les agrégations en huit segments basés sur le découpage de la campagne PrePost, démarrant le [image] mai 1999, et avec des agrégats du mois précédent et suivant la campagne :

create totalSpendPrePostMayCampaign_ := sum(Amount) by

bin(PrePost(todate(19990401), todate(19990501),

todate(19990601)), PurchaseDate);

Voir également

Boolean

DayFrom, WeekFrom, MonthFrom, YearFrom

DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom

DayMultipleNumBins, WeekMultipleNumBins, MonthMultipleNumBins, YearMultipleNumBins

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo

DayMultipleWidth, WeekMultipleWidth, MonthMultipleWidth, YearMultipleWidth

DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

DayRange, WeekRange, MonthRange, YearRange

DayTo, WeekTo, MonthTo, YearTo

EqualRange

EqualRangeWidth

NegativeNonNegative

PreDuringPost

PrePost

Sign

Découpage des agrégations : la clause by

Sujet parent : Autres fonctions


dblookup

Objectif Rechercher des valeurs dans une table de référence (stockée comme un focus).

Syntaxe dblookup(d, k, f, x)

Arguments

Type | Nom | Description
chaîne | d | Le chemin d'accès de la table de recherche
chaîne | k | Le nom de la champ clé dans la table de recherche
chaîne | f | Le nom d'un autre champ dans la table de recherche
comme le champ k | x | La valeur de recherche

Résultat

Type | Description
comme le champ f | La valeur y dans le champ f de la table d, pour l'entrée indexée par la valeur x existant dans le champ clé k

Remarque :
  • Vous devez seulement utiliser cette fonction pour de petites tables de recherche. Si la table de recherche est de taille comparable à une table de client ou de transaction, vous devriez envisager une jointure à la place.
  • Si la valeur de recherche n'est pas présente dans le champ clé, la valeur null est renvoyée.
  • Si la valeur de recherche est présente plusieurs fois dans le champ clé, la première valeur est utilisée.
  • Les espaces parasites sont enlevés depuis la valeur de recherche, mais pas depuis les valeurs du champ clé dans la table de recherche. Cela peut produire un comportement inattendu si le champ clé de la table de recherche contient des valeurs avec des espaces parasites.
  • Pour la rétrocompatibilité, vous pouvez préfixer le chemin d'accès de la table de correspondance avec la chaîne focus :.

Exemple Dans un focus, le magasin dans lequel un client fait ses achats le plus fréquemment est enregistré dans le champ PopularShop. Un autre focus stores.ftr comprend une table de recherche qui décrit les installations de chaque magasin : Dans ce focus, StoreCode est le champ clé et le champ HasFuel indique si chaque magasin possède une station d'essence. Le magasin 105 possède une station d'essence, les magasins 299 et 204 n'en possèdent pas, et ainsi de suite ; le magasin 189 n'est pas dans la table de recherche. Pour calculer un champ qui signale si le magasin préféré de chaque client possède une station essence, procédez comme suit :

PopularShop | dblookup("focus:stores.ftr", "StoreCode", "HasFuel", PopularShop)
105 | 1
299 | 0
204 | 0
189 | Null

Voir également

À propos de l'assemblage de focus
Sujet parent : Autres fonctions


membre

Objectif Déterminer l'appartenance à un ensemble.

Syntaxe

member(x, [image], [image], ...)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | x | La valeur à tester
comme x | , [image] , ... | Les éléments de l'ensemble

Résultat

Type | Description
entier | 1 (true) if x est dans l'ensemble sinon [image] ; 0 (false)
Remarque :
  • Vous ne pouvez utiliser que des valeurs littérales (chiffres, chaînes ou dates) pour la liste des éléments d'ensemble.
  • En général, il est plus efficace d'utiliser la fonction de membre qu'une disjonction des tests d'égalité. Par exemple, l'expression strmember(F, "a", "b", "c") est plus rapide à évaluer que F = "a" ou F = "b" ou F = "c".
  • Pour la compatibilité inverse, vous pouvez utiliser strmember au lieu de member lorsque les arguments sont des chaînes.
  • L'espace forcé de séparation des valeurs de chaîne n'est pas ignoré.

Exemples Pour utiliser les deux premiers caractères d'un champ StateCode pour identifier les clients de la côte Ouest :

StateCode | member (substr (StateCode, 0, 1), "CA", "OR", WA")
OR009 | 1
CA043 | 1
UT005 | 0
WA027 | 1

Pour indiquer les clients dont le numéro de téléphone à 10 chiffres comportent les indicateurs régionaux d'Edinburgh (131) ou de Glasgow (141) (en déterminant les trois premiers chiffres à l'aide de l'opérateur div [voir Opérateurs arithmétiques]) :

TelNo | if member (TelNo div 10000000, 131, 141) then "Edin/Glas" else null
1312204491 | Edin/Glas
1753833999 | Null
1611234567 | Null
1417654321 | Edin/Glas

Voir également

Découpage des agrégations : la clause by
Sujet parent : Autres fonctions


rownum

Objectif Générer le numéro de chaque ligne dans la table.

Syntaxe rownum()

Arguments Aucun

Résultat

Type | Description
entier | Un numéro d'index de 1 jusqu'au nombre d'enregistrements dans la table
Remarque :

Vous ne pouvez utiliser cette fonction que dans un calcul Decision Studio, dans le fichier de calculs de qsderive ou la fenêtre équivalente Calculer des champs, dans le fichier de traceurs de qstrack ou dans un fichier de sélections de qsselect.

Exemples Pour ajouter une colonne d'index à un jeu de données N-record, avec des valeurs [image] :

ID | rownum()
AZ195 | 1
DI539 | 2
JD974 | 3
BY643 | 4
Sujet parent : Autres fonctions


Fonctions de retour sur investissement

  • ActionROI
  • ActionROIAnnualized
  • OfferROI
  • OfferROIAnnualized
  • RetentionActionROI
  • RetentionActionROIAnnualized
  • RetentionOfferROI
  • RetentionOfferROIAnnualized
Sujet parent : fonctions FDL


ActionROI

Objectif Estimer le retour par client (argent) sur la contribution à l'investissement en entreprenant une action conçue pour générer une réponse définie. L'action se produit, que le client réponde ou non. Il n'y a donc qu'un coût d'action, pas de conditions requises.

Syntaxe ActionROI(ResponseProbability, ValueOfResponse, CostOfAction)

Arguments

Type | Nom | Description
numérique | ResponseProbability | La probabilité estimée qu'un client répondra à cette action en manifestant un comportement réponse
numérique | ValueOfResponse | La valeur estimée de la réponse d'un client à l'action de marketing (si le cas se produit)
numérique | CostOfAction | Le coût estimé de l'action (que le client réponde ou non)
Résultat
Type | Description
numérique | Le retour par client estimé sur la contribution à l'investissement (argent) pour entreprendre cette action
Remarque :
  • La probabilité de réponse doit être une « uplift », c'est à dire, la probabilité que le client manifestera ce comportement alors que sans cette action, il ne l'aurait pas fait. S'il existe une possibilité que le client manifeste le comportement désiré sans que l'action soit entreprise, vous devez la modéliser à l'aide d'un modèle uplift ou, si cela échoue, en soustrayant la probabilité de réponse par rapport à la probabilité sans cette action.
  • La valeur de la réponse doit être un revenu net ignorant le coût de l'action de marketing.

Voir également

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Sujet parent : Fonctions de retour sur investissement


ActionROIAnnualized

Objectif Estimer le retour multiple sur investissement annualisé par client pour entreprendre une action conçue pour générer une réponse définie d'un client. L'action se produit, que le client réponde ou non. Il n'y a donc qu'un coût d'action, pas de conditions requises.

Syntaxe ActionROI(ResponseProbability, ValueOfResponse, CostOfAction)

Arguments

Type | Nom | Description
numérique | ResponseProbability | La probabilité estimée qu'un client répondra à cette action en manifestant un comportement réponse
numérique | ValueOfResponse | La valeur estimée de la réponse d'un client à l'action de marketing (si le cas se produit)
numérique | CostOfAction | Le coût estimé de l'action (que le client réponde ou non)
numérique | DaysToROI | Le nombre de jours nécessaires supposés pour atteindre un retour sur investissement donné
Résultat
Type | Description
numérique | Le retour sur investissement multiple annualisé par client estimé pour entreprendre cette action
Remarque :
  • La probabilité de réponse doit être une « uplift », c'est à dire, la probabilité que le client manifestera ce comportement alors que sans cette action, il ne l'aurait pas fait. S'il existe une possibilité que le client manifeste le comportement désiré sans que l'action soit entreprise, vous devez la modéliser à l'aide d'un modèle uplift ou, si cela échoue, en soustrayant la probabilité de réponse par rapport à la probabilité sans cette action.
  • La valeur de la réponse doit être un revenu net ignorant le coût de l'action de marketing.

Voir également

ActionROI

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Sujet parent : Fonctions de retour sur investissement


OfferROI

Objectif Estimer le retour par client sur la contribution à l'investissement en faisant une offre conçue pour générer une réponse définie.

Syntaxe OfferROI(ResponseProbability, ValueOfResponse, CostOfOffer, CostOfFulfilment)

Arguments

Type | Nom | Description
numérique | ResponseProbability | La probabilité estimée qu'un client répondra à cette action en manifestant un comportement réponse
numérique | ValueOfResponse | La valeur estimée de la réponse d'un client à l'action de marketing (si le cas se produit)
numérique | CostOfOffer | Le coût estimé de l'action (que le client réponde ou non)
numérique | CostOfFulfilment | Le coût estimé des conditions à une réponse positive (zéro s'il n'y a pas de conditions de coûts (supplémentaires) à remplir)
Résultat
Type | Description
numérique | Le retour estimé sur investissement par client pour avoir fait une offre
Remarque :
  • La probabilité de réponse doit être une « uplift », c'est à dire, la probabilité que le client manifestera ce comportement alors que sans cette action, il ne l'aurait pas fait. S'il existe une possibilité que le client manifeste le comportement désiré sans que l'action soit entreprise, vous devez la modéliser à l'aide d'un modèle uplift ou, si cela échoue, en soustrayant la probabilité de réponse par rapport à la probabilité sans cette action.
  • La valeur de la réponse doit être un revenu net ignorant le coût de l'action de marketing et le coût pour remplir les conditions afin que le client ait cette réponse.

Voir également

ActionROI

ActionROIAnnualized

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Sujet parent : Fonctions de retour sur investissement


OfferROIAnnualized

Objectif Estimer le retour sur investissement annualisé par client pour entreprendre une offre conçue pour générer une réponse définie d'un client.

Syntaxe OfferROIAnnualized(ResponseProbability, ValueOfResponse, CostOfOffer, CostOfFulfilment, DaysToROI)

Arguments

Type | Nom | Description
numérique | ResponseProbability | La probabilité estimée qu'un client répondra à cette action en manifestant un comportement réponse
numérique | ValueOfResponse | La valeur estimée de la réponse d'un client à l'action de marketing (si le cas se produit)
numérique | CostOfOffer | Le coût estimé de l'action (que le client réponde ou non)
numérique | CostOfFulfilment | Le coût estimé des conditions à une réponse positive (zéro s'il n'y a pas de conditions de coûts (supplémentaires) à remplir)
numérique | DaysToROI | Le nombre de jours nécessaires supposés pour atteindre un retour sur investissement donné
Résultat
Type | Description
numérique | Les retour sur investissement par client annualisés pour avoir fait une offre
Remarque :
  • La probabilité de réponse doit être une « uplift », c'est à dire, la probabilité que le client manifestera ce comportement alors que sans cette action, il ne l'aurait pas fait. S'il existe une possibilité que le client manifeste le comportement désiré sans que l'action soit entreprise, vous devez la modéliser à l'aide d'un modèle uplift ou, si cela échoue, en soustrayant la probabilité de réponse par rapport à la probabilité sans cette action.
  • La valeur de la réponse doit être un revenu net ignorant le coût de l'action de marketing et le coût pour remplir les conditions afin que le client ait cette réponse.

Voir également

ActionROI

ActionROIAnnualized

OfferROI

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Sujet parent : Fonctions de retour sur investissement


RetentionActionROI

Objectif Estimer le retour par client (argent) sur la contribution à l'investissement en entreprenant une action conçue pour empêcher une attrition. L'action est supposée avoir un coût fixe, sans tenir compte du fait que le client soit sauvé ou non, ni qu'il « accepte » l'offre ou non.

Syntaxe RetentionActionROI(SaveProbability, NetRevenueAtRisk, CostOfAction)

Arguments

Type | Nom | Description
numérique | SaveProbability | La probabilité estimée que le client sera « sauvé » (pour la période prise en considération) grâce à l'action entreprise
numérique | NetRevenueAtRisk | Le revenu net estimé qui sera perdu si le client subit une attrition dans la période considérée
numérique | CostOfAction | Le coût estimé de l'action (que le client réponde ou non)
Résultat
Type | Description
numérique | Le retour estimé par client (argent) sur la contribution à l'investissement en entreprenant une action destinée à empêcher une attrition
Remarque :
  • Dire qu'un client est « sauvé » signifie que « cela n'a pas provoqué la désertion alors que le client sans cela l'aurait fait » Cette valeur est le négatif d'un uplift dans un taux d'attrition produit par un modèle d'uplift. Sinon, il peut être calculé comme P(attrition|pas d'action) - P(attrition|action).
  • Le revenu net à risque doit être le revenu qui ignore le coût de l'action conçue pour empêcher l'attrition.

Voir également

ActionROI

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Sujet parent : Fonctions de retour sur investissement


RetentionActionROIAnnualized

Objectif Estimer le retour annualisé par client sur la contribution à l'investissement en entreprenant une action conçue pour empêcher une attrition. L'action est supposée avoir un coût fixe, sans tenir compte du fait que le client soit sauvé ou non, ni qu'il « accepte » l'offre ou non.

Syntaxe RetentionActionROIAnnualized(SaveProbability, NetRevenueAtRisk, CostOfAction, DaysToROI)

Arguments

Type | Nom | Description
numérique | SaveProbability | La probabilité estimée que le client sera « sauvé » (pour la période prise en considération) grâce à l'action entreprise
numérique | NetRevenueAtRisk | Le revenu net estimé qui sera perdu si le client subit une attrition dans la période considérée
numérique | CostOfAction | Le coût estimé de l'action (que le client réponde ou non)
numérique | DaysToROI | Le nombre de jours nécessaires supposés pour atteindre un retour sur investissement donné
Résultat
Type | Description
numérique | Le retour annualisé estimé par client sur la contribution à l'investissement pour une action conçue pour empêcher l'attrition
Remarque :
  • Dire qu'un client est « sauvé » signifie que « cela n'a pas provoqué la désertion alors que le client sans cela l'aurait fait » Cette valeur est le négatif d'un uplift dans un taux d'attrition produit par un modèle d'uplift. Sinon, il peut être calculé comme P(attrition|pas d'action) - P(attrition|action).
  • Le revenu net à risque doit être le revenu qui ignore le coût de l'action conçue pour empêcher l'attrition.

Voir également

ActionROI

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionOfferROI

RetentionOfferROIAnnualized

Sujet parent : Fonctions de retour sur investissement


RetentionOfferROI

Objectif Estimer le retour par client sur la contribution à l'investissement en faisant une offre conçue pour empêcher l'attrition. Une offre, contrairement à une action, a différents coûts, selon qu'elle est acceptée ou non par le client.

Syntaxe RetentionOfferROI(SaveProbability, ResponseProbability, NetRevenueAtRisk, CostOfOffer, CostOfFulfilment)

Arguments

Type | Nom | Description
numérique | SaveProbability | La probabilité estimée que le client sera « sauvé » (pour la période prise en considération) grâce à l'action entreprise
numérique | ResponseProbability | La probabilité estimée que le client répondra à l'offre
numérique | NetRevenueAtRisk | Le revenu net estimé qui sera perdu si le client subit une attrition dans la période considérée
numérique | CostOfOffer | Le coût estimé de l'offre (que le client réponde ou non)
numérique | CostOfFulfilment | Le coût estimé pour remplir les conditions d'une réponse positive à l'offre

Résultat

Type | Description
numérique | Le retour estimé par client sur l'investissement à partir une offre conçue pour empêcher l'attrition.
Remarque :
  • Dire qu'un client est « sauvé » signifie que « cela n'a pas provoqué sa désertion alors que le client sans cela l'aurait fait ». Cette valeur est le négatif d'un uplift dans un taux d'attrition produit par un modèle d'uplift. Sinon, il peut être calculé comme P(attrition|pas d'action) - P(attrition|action).
  • Le revenu net à risque doit être un revenu net qui ignore le coût de l'action conçue pour empêcher l'attrition.

Voir également

ActionROI

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROIAnnualized

Sujet parent : Fonctions de retour sur investissement


RetentionOfferROIAnnualized

Objectif Estimer le retour annualisé par client sur la contribution à l'investissement en faisant une offre conçue pour empêcher l'attrition. Une offre, contrairement à une action, a différents coûts, selon qu'elle est acceptée ou non par le client.

Syntaxe RetentionOfferROIAnnualized(SaveProbability, ResponseProbability, NetRevenueAtRisk, CostOfOffer, CostOfFulfilment, DaysToROI)

Arguments

Type | Nom | Description
numérique | SaveProbability | La probabilité estimée que le client sera « sauvé » (pour la période prise en considération) grâce à l'action entreprise
numérique | ResponseProbability | La probabilité estimée que le client répondra à l'offre
numérique | NetRevenueAtRisk | Le revenu net estimé qui sera perdu si le client subit une attrition dans la période considérée
numérique | CostOfOffer | Le coût estimé de l'offre (que le client réponde ou non)
numérique | CostOfFulfilment | Le coût estimé pour remplir les conditions d'une réponse positive à l'offre
numérique | DaysToROI | Le nombre de jours nécessaires supposés pour atteindre un retour sur investissement donné
Résultat
Type | Description
numérique | Le retour estimé par client sur l'investissement à partir une offre conçue pour empêcher l'attrition.
Remarque :
  • Dire qu'un client est « sauvé » signifie que « cela n'a pas provoqué sa désertion alors que le client sans cela l'aurait fait ». Cette valeur est le négatif d'un uplift dans un taux d'attrition produit par un modèle d'uplift. Sinon, il peut être calculé comme P(attrition|pas d'action) - P(attrition|action).
  • Le revenu net à risque doit être un revenu net qui ignore le coût de l'action conçue pour empêcher l'attrition.

Voir également

ActionROI

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

Sujet parent : Fonctions de retour sur investissement


Fonctions de nombre aléatoire

  • À propos des fonctions FDL à nombre aléatoire
  • rndBinomial
  • rndBool
  • rndExp
  • rndGamma
  • rndNormal
  • rndPoisson
  • rndUniform
Sujet parent : fonctions FDL


À propos des fonctions FDL à nombre aléatoire

Lors de l'évaluation d'une expression impliquant une fonction à nombre aléatoire (numericTestTrainSplit, numericTestTrainValidateSplit, rndBinomial, rndBool, rndExp, rndGamma, rndNormal, rndPoisson, ou rndUniform sampleEqualSize, sampleExactNumber, sampleExactPercentage, sampleStratified, testTrainSplit, et testTrainValidateSplit), Portrait Miner a besoin d'un entier « seed » (graine) pour initialiser sa séquence de nombres aléatoires. Avec la même graine (seed), la même expression produira toujours la même séquence de résultats.
Remarque :
  • Seed est stocké séparément des informations du champ.
  • La (pseudo) génération de nombre entier est basée sur celles de Marsaglia, Zaman, et Tsang (1990).
Sujet parent : Fonctions de nombre aléatoire


rndBinomial

Objectif Générer un entier aléatoire basé sur une distribution binomiale.

Syntaxe rndBinomial(N, p)

Arguments

Type | Nom | Description
entier | N | Le nombre (positif) d'essais
numérique | p | La probabilité de réussite de chaque essai (entre 0 et 1)

Résultat

Type | Description
entier | Un entier aléatoire non négatif échantillonné dans la distribution binomiale, avec une probabilité donnée par
Remarque :

La prévision et la variance de la distribution binomiale sont [image] et [image], respectivement.

Exemples rndBinomial (50, 0,05)

Voir également

À propos des fonctions FDL à nombre aléatoire
Sujet parent : Fonctions de nombre aléatoire


rndBool

Objectif Générer de façon aléatoire soit 0, soit 1 (avec une probabilité égale).

Syntaxe rndBool()

Arguments Aucun

Résultat

Type | Description
entier | Soit 0, soit 1, avec les probabilités

Exemples Pour calculer un champ qui alloue la valeur 0 à approximativement 50% des enregistrements (choisis de façon aléatoire) et la valeur 1 à ce qui reste : rndBool()

Voir également

À propos des fonctions FDL à nombre aléatoire
Sujet parent : Fonctions de nombre aléatoire


rndExp

Objectif Générer un nombre positif aléatoire basé sur une distribution exponentielle.

Syntaxe rndExp(b)

Arguments

Type | Nom | Description
numérique | b | Le paramètre d'échelle (positif)

Résultat

Type | Description
réel | Un nombre aléatoire positif, échantillon de la distribution exponentielle, avec la fonction de la densité de probabilité indiquée par [image] (x > 0)
Remarque :

La prévision et la variance de la distribution exponentielle sont [image] et [image] respectivement.

Exemples rndExp(10)

Voir également

À propos des fonctions FDL à nombre aléatoire
Sujet parent : Fonctions de nombre aléatoire


rndGamma

Objectif Générer un nombre positif aléatoire basé sur une distribution gamma.

Syntaxe rndGamma(a, b)

Arguments

Type | Nom | Description
entier | a | Le nombre (positif) d'événements indépendants
numérique | b | Le taux d'événements (positif)

Résultat

Type | Description
réel | Un nombre aléatoire positif, échantillon de la distribution gamma [image] , avec la fonction de la densité de probabilité indiquée par
Remarque :

La prévision et la variance de la distribution gamma sont [image] et [image] respectivement.

Exemples rndGamma (50, 0,05)

Voir également

À propos des fonctions FDL à nombre aléatoire
Sujet parent : Fonctions de nombre aléatoire


rndNormal

Objectif Générer un nombre aléatoire basé sur une distribution normale.

Syntaxe

rndNormal( [image], ef="../../../../images/img344.gif"/>h>

Arguments

Type | Nom | Description
numérique |  | La moyenne de la distribution
numérique |  | L'écart-type de la distribution

Résultat

Type | Description
réel | Un nombre aléatoire positif, échantillon de la distribution normale [image] , avec la fonction de la densité de probabilité indiquée par
Remarque :

La prévision et la variance de la distribution normale sont [image] et [image] respectivement.

Exemples Pour calculer une distribution gaussienne avec une moyenne nulle et une déviation d'unité standard : rndNormal(0,1)

Voir également

À propos des fonctions FDL à nombre aléatoire
Sujet parent : Fonctions de nombre aléatoire


rndPoisson

Objectif Générer un entier aléatoire non négatif basé sur une distribution discrète de Poisson.

Syntaxe rndPoisson(moyenne)

Arguments

Type | Nom | Description
numérique |  | La moyenne (positive) de la distribution

Résultat

Type | Description
entier | Un entier aléatoire non négatif échantillonné à partir de la distribution Poisson discrète, avec une probabilité donnée de [image] ( [image] )
Remarque :

La prévision et la variance de la distribution Poisson discrète sont toutes les deux égales à la moyenne, [image].

Exemples rndPoisson(10)

Voir également

À propos des fonctions FDL à nombre aléatoire
Sujet parent : Fonctions de nombre aléatoire


rndUniform

Objectif Générer un nombre aléatoire entre 0 et 1 basé sur une distribution uniforme.

Syntaxe rndUniform()

Arguments Aucun

Résultat

Type | Description
réel | Un nombre aléatoire échantillonné à partir d'une distribution uniforme sur tout l'intervalle [0, 1)

Exemples pour générer un nombre aléatoire réel dans la plage [0,10) : rndUniform() * 10

Voir également

À propos des fonctions FDL à nombre aléatoire
Sujet parent : Fonctions de nombre aléatoire


Fonctions de classement

  • rankOrder, rankOrderApprox
  • rankOrderMean, rankOrderApproxMean
Sujet parent : fonctions FDL


rankOrder, rankOrderApprox

Objectif Identifier le rang d'une valeur dans une liste de valeurs.

Syntaxe

rankOrder(x, [image], [image], ...)

rankOrderApprox(x, [image], [image], ...)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | x | La valeur à classer par rang
comme x | , [image] , ... | La liste de valeurs par comparaison

Résultat

Type | Description
entier | La position de la première occurrence de x dans la liste des valeurs obtenues en triant [image] , [image] , ... en ordre décroissant (de la plus ancienne à la plus récente pour les dates ; ordre alphabétique inversé pour les chaînes) Si x ne se produit pas dans la liste, rankOrder renvoie la valeur null, alors que rankOrderApprox renvoie la position de x à l'intérieur de la liste des valeurs obtenues en triant x, [image] , [image] , ... en ordre décroissant.
Remarque :
  • Lorsque la valeur à classer n'a qu'une seule occurrence dans la liste de valeurs, rankOrder, rankOrderApprox, rankOrderMean, et rankOrderApproxMean donnent tous le même résultat.
  • Lorsque la valeur à classer a plusieurs occurrences dans la liste de valeurs, rankOrderApprox donne le même résultat que rankOrder.
  • Lorsque la valeur à classer n'a aucune occurrence dans la liste de valeurs, rankOrderApprox donne le même résultat que rankOrderApproxMean.
  • Dans les chaînes, « alphabetical order » (ordre alphabétique) signifie l'ordre naturel de la représentation sous-jacente des caractères.

Exemples rankOrder(6.74, 6.74, 1.99, 0.00, 9.27) est égal à 2.

rankOrderApprox(6.74, 1.99, 0.00, 9.27) est égal à 2.

Pour vérifier à quel endroit le nombre d'appels téléphoniques d'un client durant le trimestre 4 se classe dans une année :

rankOrder(CallsQ4, CallsQ1, CallsQ2, CallsQ3, CallsQ4)

Pour vérifier à quel endroit le nombre d'appels téléphoniques d'un client durant le mois 5 se classe par rapport aux quatre mois précédents :

RankOrderApprox(CallsM5, CallsM1, CallsM2, CallsM3, CallsM4)

Voir également

rankOrderMean, rankOrderApproxMean
Sujet parent : Fonctions de classement


rankOrderMean, rankOrderApproxMean

Objectif Identifier le rang d'une valeur dans une liste de valeurs, ou son rang moyen si elle se présente plusieurs fois.

Syntaxe

rankOrderMean(x, [image], [image], ...)

rankOrderApproxMean(x, [image], [image], ...)

Arguments

Type | Nom | Description
entier, réel, date ou chaîne | x | La valeur à classer par rang
comme x | , [image] , ... | La liste de valeurs par comparaison

Résultat

Type | Description
réel | Le rang moyen de x dans la liste des valeurs obtenues en triant [image] , [image] , ... en ordre décroissant (de la plus ancienne à la plus récente pour les dates ; ordre alphabétique inversé pour les chaînes) Si x ne se produit pas dans la liste, rankOrderMean renvoie la valeur null, alors que rankOrderApproxMean renvoie la position de x à l'intérieur de la liste des valeurs obtenues en triant x, [image] , [image] , ... en ordre décroissant.
Remarque :
  • Lorsque la valeur à classer n'a qu'une seule occurrence dans la liste de valeurs, rankOrder, rankOrderApprox, rankOrderMean, et rankOrderApproxMean donnent tous le même résultat.
  • Lorsque la valeur à classer a plusieurs occurrences dans la liste de valeurs, rankOrderApproxMean donne le même résultat que rankOrderMean.
  • Lorsque la valeur à classer n'a aucune occurrence dans la liste de valeurs, rankOrderApproxMean donne le même résultat que rankOrderApprox.
  • Dans les chaînes, « alphabetical order » (ordre alphabétique) signifie l'ordre naturel de la représentation sous-jacente des caractères.

Exemples rankOrderMean(6.74, 6.74, 1.99, 6.74, 9.27) est égal à 2.5.

rankOrderApproxMean(6.74, 1.99, 6.74, 9.27, 6.74) est égal à 2.5.

Voir également

rankOrder, rankOrderApprox
Sujet parent : Fonctions de classement


Fonctions d'échantillonnage des données

  • numericTestTrainSplit
  • numericTestTrainValidateSplit
  • sampleEqualSize
  • sampleExactNumber
  • sampleExactPercentage
  • sampleStratified
  • testTrainSplit
  • testTrainValidateSplit
Sujet parent : fonctions FDL


numericTestTrainSplit

Objectif Créer une segmentation de test/d'apprentissage utilisable dans une validation de modèle.

Syntaxe numericTestTrainSplit(testFraction)

Arguments

Type | Nom | Description
réel | testFraction | La fraction des données devant être utilisée en tant que l'ensemble de test
Résultat
Type | Description
entier | Valeurs 0 pour l'apprentissage ou 1 pour le test

Exemples Pour calculer un champ qui donne une valeur 0 à environ 70% des enregistrements (choisis de manière aléatoire) et la valeur 1 aux autres : numericTestTrainSplit(0.3)

Voir également

numericTestTrainValidateSplit

sampleEqualSize

testTrainSplit

testTrainValidateSplit

Diviser d'un fichier focus en sous-populations types

Sujet parent : Fonctions d'échantillonnage des données


numericTestTrainValidateSplit

Objectif Créer une segmentation de test/d'apprentissage/de validation utilisable dans une validation de modèle.

Syntaxe numericTestTrainValidateSplit(testFraction, validateFraction)

Arguments

Type | Nom | Description
réel | testFraction | La fraction des données devant être utilisée en tant que l'ensemble de test
réel | validateFraction | La fraction des données à utiliser comme ensemble de données d'exclusion
Résultat
Type | Description
entier | Valeurs 0 pour l'ensemble d'apprentissage, 1 pour l'ensemble de test ou 2 pour l'ensemble de validation

Exemples Calculer un champ qui affecte la valeur 0 à environ 50 % des enregistrements (choisis de manière aléatoire), la valeur 1 à environ 30 % des enregistrements (encore une fois choisis de manière aléatoire) et la valeur 2 au reste : numericTestTrainValidateSplit(0.3, 0.2)

Voir également

numericTestTrainSplit

sampleEqualSize

testTrainSplit

testTrainValidateSplit

Diviser d'un fichier focus en sous-populations types

Sujet parent : Fonctions d'échantillonnage des données


sampleEqualSize

Objectif Créer un index de segmentation qui attribue des enregistrements au hasard aux segments de taille approximativement égale.

Syntaxe sampleEqualSize(NumberOfSegments)

Arguments

Type | Nom | Description
entier | NumberOfSegments | Le nombre de segments à créer
Résultat
Type | Description
entier | Un nombre entre 1 et NumberOfSegments (inclus)

Exemples Pour calculer un champ énumérant cinq populations de même taille (environ) : sampleEqualSize(5)

Voir également

numericTestTrainSplit

numericTestTrainValidateSplit

testTrainSplit

testTrainValidateSplit

Diviser d'un fichier focus en sous-populations types

Sujet parent : Fonctions d'échantillonnage des données


sampleExactNumber

Objectif Créer un échantillon aléatoire d'une taille exacte, spécifiée sous forme de nombre d'enregistrements.

Syntaxe sampleExactNumber(NumberToSelect)

Arguments

Type | Nom | Description
entier | NumberToSelect | La taille de l'échantillon à créer, en tant que nombre d'enregistrements

Résultat

Type | Description
entier | 1 si un enregistrement est choisi pour l'échantillon, sinon 0.
Remarque :
  • La valeur null est attribuée aux enregistrements qui ne sont pas sélectionnés actuellement dans le focus.
  • Vous ne pouvez utiliser cette fonction que dans un calcul Decision Studio, dans le fichier de calculs pour qsderive ou la fenêtre équivalente Calculer des champs, dans le fichier de traceurs pour qstrack, ou dans le fichier de sélections pour qsselect.

Exemples Choisir 1 250 enregistrements pour un échantillon : sampleExactNumber(1250)

Voir également

sampleExactPercentage

sampleStratified

Diviser d'un fichier focus en sous-populations types

Sujet parent : Fonctions d'échantillonnage des données


sampleExactPercentage

Objectif Créer un échantillon aléatoire d'une taille exacte, spécifié sous forme de pourcentage de la taille de la population sélectionnée.

Syntaxe sampleExactPercentage(PercentageToSelect)

Arguments

Type | Nom | Description
entier | PercentageToSelect | La taille de l'échantillon à créer, sous forme de pourcentage de la taille de la population en cours

Résultat

Type | Description
entier | 1 si un enregistrement est choisi pour l'échantillon, sinon 0.
Remarque :
  • La valeur null est attribuée aux enregistrements qui ne sont pas sélectionnés actuellement dans le focus.
  • SiPercentageToSelect multiplié par la taille de l'échantillon n'est pas un nombre entier, le nombre choisi sera le nombre entier le plus proche au-dessus ou au-dessous de PercentageToSelect multiplié par la taille de l'échantillon et donnera en moyenne le pourcentage spécifié.
  • Vous ne pouvez utiliser cette fonction que dans un calcul Decision Studio, dans le fichier de calculs pour qsderive ou la fenêtre équivalente Calculer des champs, dans le fichier de traceurs pour qstrack, ou dans le fichier de sélections pour qsselect.

Exemples Choisir 25 % de la population pour un échantillon : sampleExactPercentage(25)

Voir également

sampleExactNumber

sampleStratified

Diviser d'un fichier focus en sous-populations types

Sujet parent : Fonctions d'échantillonnage des données


sampleStratified

Objectif Créer un échantillon aléatoire contenant un nombre exact d'enregistrements d'un segment spécifié, avec un nombre exact d'enregistrements parmi le reste de l'échantillon sélectionné.

Syntaxe sampleStratified(NumberFromSegmentToSelect, SegmentTotalSize, NumberOutsideSegmentToSelect, OutsideSegmentTotalSize, InSegmentExpression)

Arguments

Type | Nom | Description
entier | NumberFromSegmentToSelect | Le nombre d'enregistrements choisis à partir du segment spécifié dans l'échantillon
entier | SegmentTotalSize | Le nombre total d'enregistrements dans le segment spécifié
entier | NumberOutsideSegmentToSelect | Le nombre d'enregistrements choisis parmi le reste de la population dans l'échantillon
entier | OutsideSegmentTotalSize | Le nombre total d'enregistrements parmi le reste de la population
entier | InSegmentExpression | L'expression (booléenne) qui détermine si un enregistrement est dans le segment spécifié ou non

Résultat

Type | Description
entier | 1 si un enregistrement est choisi pour l'échantillon, sinon 0.
Remarque :
  • La valeur null est attribuée aux enregistrements qui ne sont pas sélectionnés actuellement dans le focus.
  • Vous ne pouvez utiliser cette fonction que dans un calcul Decision Studio, dans le fichier de calculs pour qsderive ou la fenêtre équivalente Calculer des champs, dans le fichier de traceurs pour qstrack, ou dans le fichier de sélections pour qsselect.

Exemples Pour créer un échantillon comprenant 2 500 enregistrements sur un total de 25 000 femmes, et 5 000 enregistrements sur un total de 75 000 non femmes : sampleStratified(2500, 25000, 5000, 75000, Gender = "F")

Voir également

sampleExactNumber

sampleExactPercentage

Diviser d'un fichier focus en sous-populations types

Sujet parent : Fonctions d'échantillonnage des données


testTrainSplit

Objectif Créer une segmentation de test/d'apprentissage utilisable dans une validation de modèle.

Syntaxe testTrainSplit(testFraction)

Arguments

Type | Nom | Description
réel | testFraction | La fraction des données devant être utilisée en tant que l'ensemble de test
Résultat
Type | Description
chaîne | Valeurs de chaîne TestSet ou TrainingSet

Exemples Pour calculer un champ qui affecte la valeur « TrainingSet » à environ 70 % des enregistrements (choisis de manière aléatoire) et la valeur « TestSet » au reste :

testTrainSplit(0.3)

Voir également

numericTestTrainSplit

numericTestTrainValidateSplit

sampleEqualSize

testTrainValidateSplit

Diviser d'un fichier focus en sous-populations types

Sujet parent : Fonctions d'échantillonnage des données


testTrainValidateSplit

Objectif Créer une segmentation de test/d'apprentissage/de validation utilisable dans une validation de modèle.

Syntaxe testTrainValidateSplit(testFraction, validateFraction)

Arguments

Type | Nom | Description
réel | testFraction | La fraction des données devant être utilisée en tant que l'ensemble de test
réel | validateFraction | La fraction des données à utiliser comme ensemble de données d'exclusion

Résultat

Type | Description
chaîne | Valeurs de chaîne TestSet, TrainingSet ou ValidationSet

Exemples Calculer un champ qui affecte la valeur « TrainingSet » à environ 50 % des enregistrements (choisis de manière aléatoire), la valeur « TestSet » à environ 30 % des enregistrements (encore une fois choisis de manière aléatoire) et la valeur « ValidationSet » au reste :

testTrainValidateSplit(0.3, 0.2)

Voir également

numericTestTrainSplit

numericTestTrainValidateSplit

sampleEqualSize

testTrainSplit

Diviser d'un fichier focus en sous-populations types

Sujet parent : Fonctions d'échantillonnage des données


Fonctions spécifiques aux chaînes

  • concat
  • endswith
  • find
  • left
  • match
  • mid
  • replaceall
  • replacefirst
  • right
  • soundex
  • startswith
  • strlen
  • strmember
  • substitute
  • substr
  • tolower
  • toupper
  • découper
Sujet parent : fonctions FDL


concat

Objectif Concaténer deux ou plusieurs chaînes.

Syntaxe

concat( [image], [image], ...)

Arguments

Type | Nom | Description
chaîne | , [image] , ... | Chaînes à concaténer
Résultat
Type | Description
chaîne | La chaîne obtenue en écrivant les caractères de [image] , suivie par les caractères de [image] , etc.

Exemples Calculer le nom complet d'un client à partir de deux champs FirstName et Surname :

FirstName | Surname | concat(FirstName," ",Surname)
John | Brown | John Brown
David | Smith | David Smith

Calculer le nom complet d'un client, mais en n'utilisant que ses initiales :

FirstName | Surname | concat(substr(FirstName,0,0),". ",Surname)
John | Brown | J. Brown
David | Smith | D. Smith
Sujet parent : Fonctions spécifiques aux chaînes


endswith

Objectif Tester si une chaîne se termine par une autre.

Syntaxe endswith(find_text, within_text)

Arguments

Type | Nom | Description
chaîne | find_text | La chaîne à trouver à la fin
chaîne | within_text | La chaîne à tester
Résultat
Type | Description
entier | 1 (true) si find_text se trouve à la fin de within_text ; 0 (false) sinon
Remarque :

La fonction endswith est basée sur la fonction match. Elle ajoute un caractère $ à find_text avant de traiter le résultat comme une expression régulière [voir Expressions régulières].

Exemples Pour calculer un champ qui indique les adresses électroniques à partir des domaines .net :

EmailAddress | endswith(".net", EmailAddress)
J.Brown@glob.net | 1
D.Smith@portraitsoftware.com | 0

Voir également

find

startswith

Sujet parent : Fonctions spécifiques aux chaînes


find

Objectif Tester si une chaîne est contenue dans une autre.

Syntaxe find(find_text, within_text)

Arguments

Type | Nom | Description
chaîne | find_text | La chaîne à trouver
chaîne | within_text | La chaîne à tester

Résultat

Type | Description
entier | 1 (true) si find_text se trouve dans within_text; 0 (false) sinon
Remarque :

La fonction find est basée sur la fonction match et elle traite find_text comme une expression régulière [voir Expressions régulières].

Exemples Pour indiquer les adresses électroniques contenant le texte « portraitsoftware » en lettres majuscules, minuscules ou mixtes :

EmailAddress | find("portraitsoftware", tolower(EmailAddress))
J.BROWN@PORTRAITSOFTWARE.COM | 1
J.Brown@glob.net | 0
D.Smith@portraitsoftware.com | 1

Voir également

endswith

startswith

Sujet parent : Fonctions spécifiques aux chaînes


left

Objectif Renvoyer une sous-chaîne de longueur spécifique à partir du début d'une chaîne.

Syntaxe left(text, num_chars)

Arguments

Type | Nom | Description
chaîne | texte | La chaîne à partir de laquelle extraire
entier | num_chars | Le nombre de caractères
Résultat
Type | Description
chaîne | La sous-chaîne formée par les caractères num_chars au début de text
Remarque :

La fonction left est basée sur la fonction substr.

Exemples Pour utiliser les deux premiers caractères d'un champ StateCode pour identifier les clients de la côte Ouest :

StateCode | member (left (StateCode, 2), "CA", "OR", WA")
OR009 | 1
CA043 | 1
UT005 | 0
WA027 | 1

Voir également

mid

right

découper

Sujet parent : Fonctions spécifiques aux chaînes


match

Objectif Tester une chaîne pour une correspondance d'expression régulière [voir Expressions régulières].

Syntaxe match(regexp, string)

Arguments

Type | Nom | Description
chaîne | regexp | L'expression régulière
chaîne | string | La chaîne à tester
Résultat
Type | Description
entier | 1 (true) si regexp correspond à string ; sinon 0 (false)

Exemples Pour indiquer les clients dont le code postal du domicile et le code postal de l'agence bancaire correspondent au niveau des deux premiers caractères (avec la fonction substr) :

HomePostcode | BranchPostCode | match(substr(HomePostcode, 0, 1), substr(BranchPostcode,0,1))
NE25 0AY | NE30 1QX | 1
SW3 | NG18 1HT | 0
CF36 | CF31 1HY | 1
EH9 0NJ | E10 8AJ | 0

Pour rechercher dans le champ de nom d'une société les trois premiers caractères d'un prénom, suivis par n'importe quel texte, puis le contenu d'un champ de nom de famille (en ignorant la casse) :

FirstName | FamilyName | CompanyName | rx := concat( substr(toupper(FirstName),0,2), "[[:print:]]*", toupper(FamilyName); match(rx,toupper(CompanyName))
Patrick | Smith | 1234 Pat Smith Ltd | 1
Patrick | Smith | 1234 Pat J Smith Ltd | 1

Pour faire la même chose, mais avec seulement quelques lettres ou chiffres et un espace simple entre le prénom et le nom de famille :

FirstName | FamilyName | CompanyName | rx := concat( substr(toupper(FirstName),0,2), "[[:alnum:]]* ", toupper(FamilyName); match(rx,toupper(CompanyName))
Patrick | Smith | 1234 Pat Smith Ltd | 1
Patrick | Smith | 1234 Pat J Smith Ltd | 0

Voir également

replaceall

replacefirst

Découpage des agrégations : la clause by

Sujet parent : Fonctions spécifiques aux chaînes


mid

Objectif Renvoyer une sous-chaîne de longueur spécifique à partir du milieu d'une chaîne.

Syntaxe mid(text, start_num, num_chars)

Arguments

Type | Nom | Description
chaîne | texte | La chaîne à partir de laquelle extraire
chaîne | start_num | Le premier index
chaîne | num_chars | Le nombre de caractères
Résultat
Type | Description
chaîne | La sous-chaîne formée par le caractère num_chars depuis la position du caractère start_num (inclusif) de text, où la position des caractères est numérotée à partir de 1
Remarque :

La fonction mid est basée sur la fonction substr.

Exemples Pour calculer une position du cinquième au septième caractère d'un code store :

StoreCode | mid(StoreCode, 5, 3)
0114EDI256 | EDI
1863LON836 | LON
9326EDI039 | EDI
0387BOS041 | BOS

Voir également

left

right

découper

Sujet parent : Fonctions spécifiques aux chaînes


replaceall

Objectif Remplacer toutes les sous-chaînes correspondant à une expression régulière [voir Expressions régulières].

Syntaxe replaceall(regexp, replacement, string)

Arguments

Type | Nom | Description
chaîne | regexp | L'expression régulière
chaîne | replacement | La chaîne de remplacement
chaîne | string | La chaîne à trouver
Résultat
Type | Description
chaîne | Une copie de la chaîne text avec replacement remplaçant chaque instance ne recouvrant pas regexp
Remarque :

La première portion correspondante de la chaîne faisant l'objet de la recherche est la plus à gauche, la portion la plus longue à laquelle correspond l'expression. La recherche suivante s'applique au reste de la chaîne faisant l'objet d'une recherche, et ainsi de suite. Par exemple,

replaceall("i..", "X", "initiation")

donne la priorité à la chaîne « XtXX » (plutôt que, mettons, « inXatX »). Et

replaceall("i.*i", "X", "initiation")

donne le résultat « Xon » (plutôt que, mettons, « XtXon »).

Exemples Détecter et supprimer un espace du champ d'un PostalCode à l'aide d'une expression régulière correspondante :

PostalCode | replaceall("[[:blank:]]","",PostalCode))
ND 069 | ND069
IN 099 | IN099
UT 0 0 5 | UT005
O R 009 | OR009

Voir également

match

replacefirst

Sujet parent : Fonctions spécifiques aux chaînes


replacefirst

Objectif Remplace la première sous-chaîne correspondant à une expression régulière [voir Expressions régulières].

Syntaxe replacefirst(regexp, replacement, string)

Arguments

Type | Nom | Description
chaîne | regexp | L'expression régulière
chaîne | replacement | La chaîne de remplacement
chaîne | string | La chaîne à trouver
Résultat
Type | Description
chaîne | Une copie de la chaîne string avec replacement remplaçant la première portion correspondant à regexp (le cas échéant)

Exemples Pour extraire le nom d'un client d'un champ d'adresse e-mail au format « Prénom.Nom@entreprise.com », en supprimant tout à partir de « @ » et en remplaçant « . » par un espace :

E-mail | replacefirst("@.*", "", (replacefirst ("\.", " ", Email)))
John.Brown@myco.com | John Brown
Angela.Smith@yourco.com | Angela Smith

Voir également

match

replaceall

Sujet parent : Fonctions spécifiques aux chaînes


right

Objectif Renvoyer une sous-chaîne d'une longueur spécifiée à partir de la fin d'une chaîne.

Syntaxe right(text, num_chars)

Arguments

Type | Nom | Description
chaîne | text | La chaîne à partir de laquelle extraire
entier | num_chars | Le nombre de caractères
Résultat
Type | Description
chaîne | La sous-chaîne formée par les caractères num_chars à la fin de text
Remarque :

La fonction right est basée sur la fonction substr.

Exemples Pour renvoyer le composant maison/rue d'un champ de code postal du Royaume Uni, c'est à dire les trois derniers caractères :

Postcode | right(Postcode, 3)
NE25 0AY | 0AY
EH3 7RA | 7RA
SL4 1QX | 1QX
EH9 0NJ | 0NJ

Voir également

left

mid

découper

Sujet parent : Fonctions spécifiques aux chaînes


soundex

Objectif Réduire chaque mot en une chaîne de quatre caractères à des fins d'indexation.

Syntaxe soundex(text)

Arguments

Type | Nom | Description
chaîne | texte | Le texte à réduire
Résultat
Type | Description
chaîne | Un codage d'index réduit à quatre caractères
Exemples Pour calculer le code soundex d'un nom de famille :
Surname | soundex(Nom de famille)
Brown | B650
Smythe | S530
Smith | S530
Bruno | B650
Remarque : La fonction Soundex n'est pas définie pour les caractères non ASCII.
Sujet parent : Fonctions spécifiques aux chaînes


startswith

Objectif Tester si une chaîne débute par une autre.

Syntaxe startswith(find_text, within_text)

Arguments

Type | Nom | Description
chaîne | find_text | La chaîne à chercher au début
chaîne | within_text | La chaîne à tester
Résultat
Type | Description
entier | 1 si find_text se trouve au début de within_text; 0 sinon
Remarque :

La fonction startswith est basée sur la fonction match. Elle ajoute un caractère ^ à find_text avant de traiter le résultat comme une expression régulière [voir Expressions régulières].

Exemples Pour calculer le type de carte de crédit utilisée dans une transaction, comme « Discover », « AmEx », « Visa » ou « MasterCard », basées sur les numéros préfixes de la carte :

boîte

startswith ("6011", CC_Number) : "Discover";

startswith ("4", CC_Number) : "Visa";

startswith ("5", CC_Number) : "MasterCard";

startswith ("34",CC_Number) ou startswith ("37", CC_Number) : "AmEx";

default: null;

CC_Number | CC_Type
4111-1111-1111-1111 | Visa
5431-1111-1111-1111 | MasterCard
341-1111-1111-1111 | AmEx
6011-6011-6011-6611 | Discover
Voir également

endswith

find

Sujet parent : Fonctions spécifiques aux chaînes


strlen

Objectif Obtenir la longueur d'une chaîne.

Syntaxe strlen(string)

Arguments

Type | Nom | Description
chaîne | string | La chaîne dont la longueur doit être déterminée
Résultat
Type | Description
entier | Le nombre de caractères de string

Exemples Pour calculer un champ de chaîne ayant exactement quatre caractères, en complémentant un champ de chaîne plus court avec des zéros en début de chaîne :

boîte

strlen(AccountID) = 1: concat("000", AccountID);

strlen(AccountID) = 2: concat("00", AccountID);

strlen(AccountID) = 3: concat("0", AccountID);

default: AccountID;

AccountID | Compte
1 | 0001
22 | 0022
333 | 0333
4444 | 4444
Sujet parent : Fonctions spécifiques aux chaînes


strmember

Objectif Déterminer l'appartenance à un ensemble.

Syntaxe

strmember(x, [image], [image], ...)

Arguments

Type | Nom | Description
chaîne | x | La valeur à tester
comme x | , [image] , ... | Les éléments de l'ensemble

Résultat

Type | Description
entier | 1 (true) if x est dans l'ensemble sinon [image] ; 0 (false)
Remarque :
  • Vous ne pouvez utiliser que les valeurs littérales de chaîne pour la liste des éléments d'ensemble.
  • L'espace forcé de séparation des valeurs n'est pas ignoré.
  • Cette fonction est dépréciée en faveur de la fonction member la plus générale.

Voir également

Découpage des agrégations : la clause by
Sujet parent : Fonctions spécifiques aux chaînes


substitute

Objectif Remplacer une chaîne par une autre.

Syntax substitute(text, old_text, new_text)

Arguments

Type | Nom | Description
chaîne | texte | La chaîne à trouver
chaîne | old_text | La chaîne à remplacer
chaîne | new_text | La chaîne de remplacement

Résultat

Type | Description
chaîne | Une copie de la chaîne text avec new_text remplaçant chaque instance ne recouvrant pas old_text
Remarque :

La fonction substitute est basée sur la fonction replaceall, et elle considère old_text comme une expression normale [voir Expressions régulières].

Exemples Pour retirer chaque caractère espace d'un champ nommé PostalCode:

PostalCode | substitute(PostalCode, "[[:blank:]]", "")
ND 069 | ND069
IN 099 | IN099
UT 0 0 5 | UT005
O R 009 | OR009

Voir également

replacefirst
Sujet parent : Fonctions spécifiques aux chaînes


substr

Objectif Extraire une sous-chaîne d'une chaîne.

Syntaxe substr(string, start, end)

Arguments

Type | Nom | Description
chaîne | string | La chaîne d'origine
entier | start | Le premier index
entier | end | Le second index

Résultat

Type | Description
chaîne | La sous -chaîne formée par les caractères start jusqu'à end (inclusif) de string, où les caractères sont numérotés à partir de 0. Décompte des valeurs d'index positives à partir du début de la chaîne, et des valeurs d'index négatives à partir de la fin de la chaîne.

Exemples Pour sélectionner les deux premiers et les trois derniers caractères d'un champ PostalCode pour obtenir le code de l'État :

PostalCode | substr(PostalCode, 0, 1) | substr(PostalCode, -3, -1)
MA015 | MA | 015
WA055 | WA | 055
UT005 | UT | 005
MN119 | MN | 119

Pour calculer le type de carte de crédit utilisé dans une transaction, telle que « Discover », « AmEx », « Visa » ou « MasterCard », en se basant sur les numéros de préfixe de carte :

boîte

substr(CC_Number, 0, 3) = "6011": "Discover";

substr(CC_Number, 0, 0) = "4": "Visa";

substr(CC_Number, 0, 0) = "5": "MasterCard";

substr(CC_Number, 0, 1) = "34" or substr(CC_Number, 0, 1) = "37": "AmEx";

default: null;

CC_Number | CC_Type
4111-1111-1111-1111 | Visa
5431-1111-1111-1111 | MasterCard
341-1111-1111-1111 | AmEx
6011-6011-6011-6611 | Discover
Sujet parent : Fonctions spécifiques aux chaînes


tolower

Objectif Convertir une chaîne en texte en lettres minuscules.

Syntaxe tolower(string)

Arguments

Type | Nom | Description
chaîne | string | La chaîne à convertir

Résultat

Type | Description
chaîne | La chaîne obtenue à partir de string en remplaçant chaque lettre majuscule dans string par la minuscule correspondante

Exemples tolower("ZYXWV") est égal à "zyxwv"

Voir également

toupper
Sujet parent : Fonctions spécifiques aux chaînes


toupper

Objectif Convertir une chaîne en texte en lettres majuscules.

Syntaxe toupper(string)

Arguments

Type | Nom | Description
chaîne | string | La chaîne à convertir

Résultat

Type | Description
chaîne | La chaîne obtenue à partir de string en remplaçant chaque lettre minuscule dans string par la majuscule correspondante

Exemples toupper("abcde") est égal à "ABCDE"

Voir également

tolower
Sujet parent : Fonctions spécifiques aux chaînes


découper

Objectif Supprime tous les espaces d'une chaîne à l'exception des espaces simples entre les mots.

Syntaxe trim(text)

Arguments

Type | Nom | Description
chaîne | text | La chaîne à rectifier

Résultat

Type | Description
chaîne | La chaîne formée à partir de text en retirant tous les espaces excepté les espaces simples entre les mots
Remarque :

La fonction trim est basée sur la fonction replaceall.

Exemples Pour calculer un champ qui remplace plusieurs caractères espace par un unique espace :

CommentField | trim(CommentField)
Articles défectueux retournés | Articles défectueux retournés
Rendez-vous manqué | Rendez-vous manqué
Ingénieur à rencontrer : Lundi | Ingénieur à rencontrer : Lundi
Résolu | Résolu
Sujet parent : Fonctions spécifiques aux chaînes


Découpages

  • Boolean
  • DayFrom, WeekFrom, MonthFrom, YearFrom
  • DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom
  • DayMultipleNumBins, WeekMultipleNumBins, MonthMultipleNumBins, YearMultipleNumBins
  • DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost
  • DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo
  • DayMultipleWidth, WeekMultipleWidth, MonthMultipleWidth, YearMultipleWidth
  • DayPrePost, WeekPrePost, MonthPrePost, YearPrePost
  • DayRange, WeekRange, MonthRange, YearRange
  • DayTo, WeekTo, MonthTo, YearTo
  • EqualRange
  • EqualRangeWidth
  • NegativeNonNegative
  • PreDuringPost
  • PrePost
  • Sign
Sujet parent : Références FDL


Boolean

Objectif Découpage de valeurs booléennes [voir Données booléennes].

Paramètres Aucun

Résultat

Indice de modalité | Valeurs
1 | false
2 | true
3 | vide [voir La valeur null]
4 | non classé
Sujet parent : Découpages


DayFrom, WeekFrom, MonthFrom, YearFrom

Objectif Découper les valeurs de date en un nombre spécifique de périodes (jours, semaines, mois ou années) après une date donnée.

Paramètres

Type | Nom | Description
date | a ("start_date") | Le début de la partie périodique du découpage
entier | n ("num_bins") | Le nombre de périodes (jours, semaines, mois ou années) dans la partie périodique du découpage
Résultat
Indice de modalité | Valeurs
1 | dates antérieures à a ; la modalité finale inférieure [voir Modalités de fin]
2, ..., n + 1 | les périodes consécutives n après a
n + 2 | dates n périodes après a et ultérieures ; la modalité finale supérieure [voir Modalités de fin]
n + 3 | vide [voir La valeur null]
n + 4 | non classé

Voir également

DayRange, WeekRange, MonthRange, YearRange

DayTo, WeekTo, MonthTo, YearTo

Sujet parent : Découpages


DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom

Objectif Découper les valeurs de date en plusieurs périodes suivant une date donnée, lorsque chaque période est un nombre spécifié de jours, semaines, mois ou années.

Paramètres

Type | Nom | Description
date | a ("start_date") | Le début de la partie périodique du découpage
entier | m ("width") | Le nombre d'unités (jours, semaines, mois ou années) dans une période
entier | n ("num_bins") | Le nombre de modalités dans la partie périodique du découpage
Résultat
Indice de modalité | Valeurs
1 | dates antérieures à a ; la modalité finale inférieure [voir Modalités de fin]
2, ..., n + 1 | les périodes consécutives n (chacune des unités m) suivant a
n + 2 | dates n x unités m après a et ultérieures ; la modalité finale supérieure [voir Modalités de fin]
n + 3 | vide [voir La valeur null]
n + 4 | non classé

Voir également

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo

Sujet parent : Découpages


DayMultipleNumBins, WeekMultipleNumBins, MonthMultipleNumBins, YearMultipleNumBins

Objectif Découper les valeurs de date approximativement selon le nombre spécifié de périodes entre deux dates données, lorsque la période est un multiple fixe de l'unité (jour, semaine, mois ou année).

Paramètres

Type | Nom | Description
date | a ("start_date") | Le début de la partie périodique du découpage
date | b ("end_date") | La fin de la partie périodique du découpage
entier | n ("num_bins") | Le nombre cible de périodes (multiples d'un jour, semaine, mois ou année) dans la partie périodique du découpage

Résultat

Indice de modalité | Valeurs
1 | dates antérieures à a ; la modalité finale inférieure [voir Modalités de fin]
2, ..., N - 3 | périodes entre a et b
N - 2 | dates b et ultérieures ; la modalité finale supérieure [voir Modalités de fin]
N - 1 | vide [voir La valeur null]
N | non classé
Remarque :
  • Ces découpages sont identiques aux découpages DayRange, WeekRange, MonthRange et YearRange [voir DayRange, WeekRange, MonthRange, YearRange], sauf lorsque la période peut être de deux unités ou plus (jours, semaines, mois ou années), pour donner environ le nombre cible de modalités.
  • Lorsque la période est de deux unités ou plus, la modalité N - 3 peut être plus courte que les modalités 2 à N - 4.

Voir également

DayMultipleWidth, WeekMultipleWidth, MonthMultipleWidth, YearMultipleWidth
Sujet parent : Découpages


DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

Objectif Découper les valeurs de date en plusieurs modalités spécifiques avant et après une date de référence donnée, lorsque chaque modalité est un multiple donné de l'unité (jour, semaine, mois ou année).

Paramètres

Type | Nom | Description
date | a ("ref_date") | La date de référence du découpage
entier | m ("width") | Le nombre de modalités avant et après la date de référence
entier | n ("num_bins") | Le nombre d'unités (jours, semaines, mois ou années) dans chaque modalité

Résultat

Indice de modalité | Valeurs
1 | dates antérieures à n x unités m avant a ; la modalité finale inférieure [voir Modalités de fin]
2, ..., n + 1 | les périodes consécutives n (chacune des unités m) précédant a
n + 2, ..., 2n + 1 | les périodes consécutives n (chacune des unités m) suivant a
2n + 2 | dates n x unités m après a et ultérieures ; la modalité finale supérieure [voir Modalités de fin]
2n + 3 | vide [voir La valeur null]
2n + 4 | non classé

Voir également

DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom

DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo

DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

PreDuringPost

PrePost

Sujet parent : Découpages


DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo

Objectif Découper les valeurs de date en plusieurs périodes avant une date donnée, lorsque chaque période est un nombre spécifié de jours, semaines, mois ou années.

Paramètres

Type | Nom | Description
date | b ("end_date") | La fin de la partie périodique du découpage
entier | m ("width") | Le nombre d'unités (jours, semaines, mois ou années) dans une période
entier | n ("num_bins") | Le nombre de modalités dans la partie périodique du découpage
Résultat
Indice de modalité | Valeurs
1 | dates antérieures à n x unités m avant a ; la modalité finale inférieure [voir Modalités de fin]
2, ..., n + 1 | les périodes consécutives n (chacune des unités m) précédant a
n + 2 | dates a et ultérieures ; la modalité finale supérieure [voir Modalités de fin]
n + 3 | vide [voir La valeur null]
n + 4 | non classé

Voir également

DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

Sujet parent : Découpages


DayMultipleWidth, WeekMultipleWidth, MonthMultipleWidth, YearMultipleWidth

Objectif Découper les valeurs de date en périodes entre deux dates données, lorsque la période est un multiple spécifié de l'unité (jour, semaine, mois ou année).

Paramètres

Type | Nom | Description
date | a ("start_date") | Le début de la partie périodique du découpage
date | b ("end_date") | La fin de la partie périodique du découpage
entier | m ("width") | Le nombre d'unités (jours, semaines, mois ou années) dans une période

Résultat

Indice de modalité | Valeurs
1 | dates antérieures à a ; la modalité finale inférieure [voir Modalités de fin]
2, ..., N - 3 | périodes entre a et b
N - 2 | dates b et ultérieures ; la modalité finale supérieure [voir Modalités de fin]
N - 1 | vide [voir La valeur null]
N | non classé
Remarque :
  • Ces découpages sont identiques aux découpages DayRange, WeekRange, MonthRange et YearRange [voir DayRange, WeekRange, MonthRange, YearRange], sauf lorsque la période peut être de deux unités ou plus (jours, semaines, mois ou années).
  • Lorsque la période est de deux unités ou plus, la modalité N - 3 peut être plus courte que les modalités 2 à N - 4.

Voir également

DayMultipleNumBins, WeekMultipleNumBins, MonthMultipleNumBins, YearMultipleNumBins
Sujet parent : Découpages


DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

Objectif Découper les valeurs de date en plusieurs périodes (jour, semaine, mois ou année) avant et après une date de référence donnée.

Paramètres

Type | Nom | Description
date | a ("ref_date") | La date de référence du découpage
entier | m ("before") | Le nombre de périodes (jours, semaines, mois ou années) à découper avant la date de référence
entier | n ("after") | Le nombre de périodes à découper après la date de référence

Résultat

Indice de modalité | Valeurs
1 | dates antérieures aux périodes m avant a ; la modalité finale inférieure [voir Modalités de fin]
2, ..., m + 1 | les périodes consécutives m avant a
m + 2, ..., m + n + 1 | les périodes consécutives n après a
m + n + 2 | dates n périodes après a et ultérieures ; la modalité finale supérieure [voir Modalités de fin]
m + n + 3 | vide [voir La valeur null]
m + n + 4 | non classé

Voir également

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

PreDuringPost

PrePost

Sujet parent : Découpages


DayRange, WeekRange, MonthRange, YearRange

Objectif Découper les valeurs de date en périodes (jours, semaines, mois ou années) entre deux dates données.

Paramètres

Type | Nom | Description
date | a ("start_date") | Le début de la partie périodique du découpage
date | b ("end_date") | La fin de la partie périodique du découpage
Résultat
Indice de modalité | Valeurs
1 | dates antérieures à a ; la modalité finale inférieure [voir Modalités de fin]
2, ..., N - 3 | périodes (jours, semaines, mois ou années) entre a et b
N - 2 | dates b et ultérieures ; la modalité finale supérieure [voir Modalités de fin]
N - 1 | vide [voir La valeur null]
N | non classé
Remarque :
  • S'il n'y a pas de période complète entre a et b, la modalité 2 comprend des dates entre a (inclus) et b (exclus).
  • S'il n'existe pas de nombre exact de périodes entre a et b (mais s'il existe au moins une période complète), la modalité précédente immédiatement b est allongée pour remédier à l'excédent.

Voir également

DayFrom, WeekFrom, MonthFrom, YearFrom

DayTo, WeekTo, MonthTo, YearTo

Sujet parent : Découpages


DayTo, WeekTo, MonthTo, YearTo

Objectif Découper les valeurs de date en un nombre spécifique de périodes (jours, semaines, mois ou années) avant une date donnée.

Paramètres

Type | Nom | Description
date | b ("end_date") | La fin de la partie périodique du découpage
entier | n ("num_bins") | Le nombre de périodes (jours, semaines, mois ou années) dans la partie périodique du découpage
Résultat
Indice de modalité | Valeurs
1 | dates antérieures à les périodes n avant b ; la modalité finale inférieure [voir Modalités de fin]
2, ..., n + 1 | les périodes consécutives n avant b
n + 2 | dates b et ultérieures ; la modalité finale supérieure [voir Modalités de fin]
n + 3 | vide [voir La valeur null]
n + 4 | non classé

Voir également

DayFrom, WeekFrom, MonthFrom, YearFrom

DayRange, WeekRange, MonthRange, YearRange

Sujet parent : Découpages


EqualRange

Objectif Découper les valeurs numériques en un nombre précis de modalités égales.

Paramètres

Type | Nom | Description
réel | a ("from") | L'extrémité inférieure de la portion à intervalle égal du découpage
réel | b ("to") | L'extrémité supérieure de la portion à intervalle égal du découpage
entier | n ("num_bins") | Le nombre de modalités dans la portion à intervalle égal du découpage

Résultat

Indice de modalité | Valeurs
1 | ; la modalité finale inférieure [voir Modalités de fin]
2, ..., n + 1 | [a, a + (b - a)/n), ..., [b - (b - a)/n, b)
n + 2 | ; la modalité finale supérieure [voir Modalités de fin]
n + 3 | vide [voir La valeur null]
n + 4 | non classé

Voir également

EqualRangeWidth
Sujet parent : Découpages


EqualRangeWidth

Objectif Découper les valeurs numériques en intervalles spécifiques.

Paramètres

Type | Nom | Description
réel | a ("from") | L'extrémité inférieure de la portion à intervalle égal du découpage
réel | b ("to") | L'extrémité supérieure de la portion à intervalle égal du découpage
réel | r ("width") | La largeur des modalités dans la portion à intervalle égal du découpage

Résultat

Indice de modalité | Valeurs
1 | ; la modalité finale inférieure [voir Modalités de fin]
2, ..., N - 3 | modalités de largeur égale approximative r
N - 2 | la modalité finale supérieure [voir Modalités de fin]
N - 1 | vide [voir La valeur null]
N | non classé
Remarque :

Si a - b n'est pas un multiple exact de r, on utilise une approximation de r, pour que les modalités entre a et b soient de largeur égale.

Voir également

EqualRange
Sujet parent : Découpages


NegativeNonNegative

Objectif Découper les valeurs numériques selon le signe, en groupant les 0 avec les valeurs positives.

Paramètres Aucun

Résultat

Indice de modalité | Valeurs
1 | ; c'est à dire, des valeurs négatives
2 | ; c'est à dire, des valeurs non négatives
3 | vide [voir La valeur null]
4 | non classé

Voir également

Sign
Sujet parent : Découpages


PreDuringPost

Objectif Découper les valeurs de date en périodes de pré-campagne, en cours de campagne et post-campagne.

Paramètres

Type | Nom | Description
date | a ("pre_date") | Le début de la période de pré-campagne
date | b ("campaign_start_date") | Le début de la campagne
date | c ("campaign_end_date") | La fin de la campagne
date | d ("post_date") | La fin de la période de post-campagne
Résultat
Indice de modalité | Valeurs
1 | dates antérieures à a ; la modalité finale inférieure [voir Modalités de fin]
2 | dates entre a (inclus) et b (exclus)
3 | dates entre b (inclus) et c (exclus)
4 | dates entre c (inclus) et d (exclus)
5 | dates d et ultérieures ; la modalité finale supérieure [voir Modalités de fin]
6 | vide [voir La valeur null]
7 | non classé

Voir également

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

PrePost

Sujet parent : Découpages


PrePost

Objectif Découper les valeurs de date en périodes de pré-campagne et post-campagne.

Paramètres

Type | Nom | Description
date | a ("pre_date") | Le début de la période de pré-campagne
date | b ("campaign_date") | La date de campagne
date | c ("post_date") | La fin de la période de post-campagne

Résultat

Indice de modalité | Valeurs
1 | dates antérieures à a ; la modalité finale inférieure [voir Modalités de fin]
2 | dates entre a (inclus) et b (exclus)
3 | dates entre b (inclus) et c (exclus)
4 | dates c et ultérieures ; la modalité finale supérieure [voir Modalités de fin]
5 | vide [voir La valeur null]
6 | non classé

Voir également

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

PreDuringPost

Sujet parent : Découpages


Sign

Objectif Découper les valeurs numériques selon le signe

Paramètres Aucun

Résultat

Indice de modalité | Valeurs
1 | ; c'est à dire, des valeurs négatives
2 | 0
3 | ; c'est à dire, des valeurs positives
4 | vide [voir La valeur null]
5 | non classé

Voir également

NegativeNonNegative
Sujet parent : Découpages


Expressions FDL régulières

  • Expressions régulières
  • Composants de base d'une expression régulière
  • Opérateurs d'expressions régulières
Sujet parent : Références FDL


Expressions régulières

Les expressions régulières servent à la correspondance des modèles dans les chaînes [voir Types de données]. Une expression régulière est une chaîne spécialement formatée représentant un modèle de caractères. Par exemple, l'expression « ar{1,2}y\?$ » représente « la lettre 'a', suivie par un ou deux 'r', éventuellement suivis par 'y,' suivi par la fin de la chaîne ». Ce modèle se produit dans des chaînes comme « marry » et « jar », mais pas dans « may » ou « jars ».

Une expression régulière est constituée de composants de base [voir Composants de base d'une expression régulière] combinés à l'aide d'opérateurs [voir Opérateurs d'expressions régulières].

Si une expression régulière (autre qu'une sous-expression) peut correspondre à plusieurs portions d'une chaîne, elle correspond toujours à la plus à gauche, la plus longue des portions candidates. Par exemple, l'expression régulière "a[^ad]\+" (représentant "la lettre 'a', suivie par une lettre ou plus à l'exception de 'a' 'd'") fait correspondre "adaptationally." La portion correspondante n'est pas « ation », puisqu'il n'existe pas de portion candidate plus loin vers la gauche. Il ne s'agit pas non plus de « ap », car, bien qu'il n'existe pas de portion candidate plus loin vers la gauche, il existe une portion candidate plus longue commençant au même caractère.
  • Pour tester une chaîne pour une correspondance d'expression régulière, utilisez la fonction match.
  • Pour remplacer les portions correspondantes d'une chaîne par une autre chaîne, utilisez la fonction replacefirst ou replaceall.
Remarque :
  • Les expressions régulières sont généralement (mais pas nécessairement) littérales, auquel cas elles doivent être placées entre guillemets, par exemple, "ar{1,2}y\?$".

  • Miner/FDL utilise les expressions régulières fournies par la bibliothèque ICU. Voici un lien vers cette bibliothèque : http://userguide.icu-project.org/strings/regexp).

  • Les expression régulières ICU sont conformes à la Unicode Technical Standard #18 (Norme technique Unicode #18), Unicode Regular Expressions (Expressions régulières Unicode), Niveau 1, et incluent également Default Word Boundaries and Name Properties depuis le niveau 2.

Sujet parent : Expressions FDL régulières


Composants de base d'une expression régulière

Les composants de base d'une expression régulière [voir Expressions régulières] sont des atomes, des ancres et des rétro-références.

Atomes

Un atome correspond exactement à l'un des ensembles de caractères spécifiés :
Atome | Caractère correspondant
. (correspond à n'importe lequel) | Tout caractère
[...] (correspond à la liste) | N'importe lequel des caractères spécifiés
[^...] (ne correspond pas à la liste) | Tout caractère autre que l'un des caractères spécifiés
Un caractère autre que ., ^, $, \, [, ] ou *, survenant à l'extérieur d'une liste de correspondance ou d'une liste de non correspondance | Le caractère lui-même
., ^, $, \, [, ] ou *, survenant à l'extérieur d'une liste de correspondance ou d'une liste de non correspondance | Le caractère lui-même

Une liste de correspondance ou de non correspondance peut inclure des caractères simples, des plages de caractères et des classes de caractères. Vous ne pouvez pas utiliser de plages de caractères ni classes de caractères excepté dans une liste de correspondance ou de non correspondance.

Une plage de caractères est une paire de caractères séparés par un tiret, et est équivalente à la liste de tous les caractères dans cette plage (dans le jeu de caractères). Par exemple, « a-e » est équivalent à « abcde » dans une liste de correspondance.

Une classe de caractères est l'un des jetons prédéfinis suivants (où les crochets qui l'enserrent sont ajoutés à ceux qui enserrent la liste de correspondance ou de non correspondance ) :

Jeton | Correspondances
[:alnum:] | Un caractère alphanumérique, c'est à dire un caractère alphabétique ou un chiffre décimal
[:alpha:] | Un caractère alphabétique, c'est à dire, « A » — « Z » et « a » — « z »
[:blank:] | Un caractère tabulation ou espace
[:cntrl:] | Un caractère de contrôle
[:digit:] | Un chiffre décimal, c'est à dire, « 0 » — « 9 »
[:graph:] | Un caractère imprimable autre qu'un espace
[:lower:] | Une lettre minuscule
[:print:] | Un caractère imprimable ou un espace
[:punct:] | Un caractère de ponctuation
[:space:] | Un caractère espace
[:upper:] | Une lettre majuscule
[:xdigit:] | Un chiffre hexadécimal, c'est à dire, « 0 » — « 9 », « A » — « F », et « a » — « f »
Remarque :
  • Vous pouvez inclure un mélange de caractères simples, de plages de caractères et de classes de caractères dans une même liste de correspondance ou de non correspondance. Par exemple, la liste de correspondance « [a-ex[:digit:]] » correspond aux lettres minuscules « a » — « e » et « x » ainsi qu'aux chiffres décimaux (« 0 » — « 9 »).
  • Un tiret, dans une liste de correspondance ou de non correspondance, représente lui-même lorsqu'il se trouve (a) à la fin d'une plage, (b) au démarrage de la liste de correspondance et de non correspondance (auquel cas il peut aussi servir de démarrage d'une plage) ou (c) à la fin de la liste de correspondance ou de non correspondance.

Ancres

les caractères ^ et $ sont des ancres ; elles correspondent respectivement au début et à la fin d'une chaîne.

Par exemple, pour correspondre à « The » se produisant au démarrage d'une chaîne et nulle part ailleurs, vous devez utiliser l'expression régulière « ^The ».

Sujet parent : Expressions FDL régulières

Rétro-références

Une rétro-référence est une barre oblique inverse suivie par un seul chiffre n (autre que 0). Elle correspond exactement aux mêmes caractères que la nième sous-expression enserrée dans \(...\).

Par exemple, pour correspondre à « yoyo », « dodo », etc. (mais pas à « dojo »), vous devez utiliser l'expression régulière « \(.o\)\1 ».

Remarque :
  • La nième sous-expression rétro-référencée est toujours la sous-expression commençant par la nième barre oblique inverse/parenthèse ouverte (même si les sous-expressions sont imbriquées).
  • La sous-expression vide « \(\) » peut être utile dans les expressions régulières impliquant une alternance [voir L'opérateur d'alternance]. Par exemple,

    \(fish\(\)\|profit\(\)\)-and-\(chips\2\|loss\3\)

    correspond à la fois à « fish-and-chips » et à « profit-and-loss », mais pas à « fish-and-loss » ou « profit-and-chips ».


Opérateurs d'expressions régulières

Un opérateur agit sur une ou deux expressions régulières [voir Expressions régulières] pour créer une nouvelle expression. Les opérateurs, de la priorité la plus haute à celle la plus basse, sont les opérateurs de répétition [voir Opérateurs de répétition], l'opérateur de concaténation [voir L'opérateur de concaténation] et l'opérateur d'alternance [voir L'opérateur d'alternance].

S'il existe une équivalence de priorité, les opérations sont effectuées de gauche à droite.

Les sous-expressions enserrées dans (...) sont toujours évaluées en premier.

Sujet parent : Expressions FDL régulières

Opérateurs de répétition

Les opérateurs de répétition sont unaires et sont écrits à la suite de leur unique opérande.

Opérateur | Description
* (zéro ou plus) | Si une expression régulière a correspond à une ou plusieurs portions adjacentes d'une chaîne, l'expression régulière a* correspond à la concaténation de ces portions. Il correspond également à toute sous-chaîne vide.
\+ (un ou plus) | Si une expression régulière a correspond à une ou plusieurs portions adjacentes d'une chaîne, l'expression régulière a\+ correspond à la concaténation de ces portions.
\{m,n\} (0 [image] m [image] n) | Si une expression régulière correspond au moins à m et pas à plus de n portions adjacentes d'une chaîne, l'expression régulière a\{m,n\} correspond à la concaténation de ces portions. Si m=0, il correspond aussi à une sous-chaîne vide.
\? (facultatif) | Équivalente à a\{0,1\}, l'expression régulière a\? correspond à toute sous-chaîne vide, ou toute portion d'une chaîne à laquelle l'expression régulière a correspond.
Remarque :

Les « portions adjacentes » mentionnées dans les définitions de *, \+ et {...} ne sont pas nécessairement des chaînes identiques. Si vous devez faire correspondre des répétitions exactes, utilisez des rétro-références [voir Rétro-références].

L'opérateur de concaténation

L'opérateur de concaténation n'est pas écrit, en fait, mais est plutôt impliqué chaque fois que vous écrivez deux expressions régulières côte à côte.

Si les expressions régulières a et b correspondent aux portions adjacentes x et y d'une chaîne z (avec x précédant y), la concaténation de a et de b (écrite a suivi par b) correspond à la portion de z contenant x et y.

Remarque :

Toute chaîne de caractères non spéciaux, c'est-à-dire des caractères sans signification spéciale dans une expression régulière, sert d'expression régulière correspondant à cette chaîne, en raison de l'opérateur de concaténation implicite.

En pratique, la plupart des expressions régulières consistent en des chaînes de caractères simples, entrecoupés de quelques caractères spéciaux. Par exemple, l'expression régulière « [SsDd]imple » correspond aux chaînes « Simple », « simple », « Dimple » et « dimple ».

L'opérateur d'alternance

L'opérateur d'alternance « | » est un opérateur binaire, écrit entre ses opérandes.

Si l'une ou l'autre des expressions régulières a et b correspond à une portion d'une chaîne, l'alternance a|b correspond également à cette portion.


XML dans Portrait Miner

  • XML dans Portrait Miner


XML dans Portrait Miner

Pour permettre un échange de résultats facile avec d'autres applications, le XML est utilisé dans l'ensemble de Portrait Miner, selon la définition du schéma XML de Portrait Miner, http://www.portraitsoftware.com

Toutes les entrées XML vers les commandes data build de Portrait Miner (et toute fonction de Portrait Miner qui est implémentée via une commande data build de Portrait Miner) doivent se trouver dans l'espace de noms Portrait Miner, http://support.portraitsoftware.com. Pour s'en assurer de la façon la plus simple, incluez l'attribut xmlns=" http://support.portraitsoftware.com " dans l'élément racine du document XML.

Les fichiers XML créés par Portrait Miner incluent automatiquement un attribut facultatif schemaLocation qui dirige vers les schémas à l'adresse http://www.portraitsoftware.com/xml/qs7.1. Si vous utilisez un éditeur prenant en charge les schémas pour créer des fichiers XML, vous pouvez directement accéder à ces schémas depuis votre installation Portrait Miner à l'adresse suivante :

<rep.inst.>/server/qs7.1/integration/schemas

(où <rep.inst.> est le répertoire d'installation de Portrait Miner). Vous trouverez aussi des exemples montrant comment traiter ces fichiers XML à l'emplacement :

<rep.inst.>/server/qs7.1/etc/xslt

Sujet parent : XML dans Portrait Miner


Dépannage

  • « Pourquoi ne puis-je pas ouvrir un fichier focus ? »
  • « Pourquoi les axes de mon graphique sont-ils divisés de manière inégale ? »
  • « Pourquoi 'Maintenir les segments en surbrillance' est-il toujours grisé ? »
  • « Pourquoi mon texte ne ressemble-t-il pas à ce que j'ai saisi ? »


« Pourquoi ne puis-je pas ouvrir un fichier focus ? »

Cause possible | Solution
Un fichier focus est déjà ouvert. Decision Studio ne peut travailler qu'avec un seul fichier focus à la fois. | Avant de pouvoir ouvrir une discussion ou créer un nouveau fichier focus à partir d'un fichier texte ou d'un tableau de données, vous devez fermer votre fichier focus actuellement ouvert : sélectionnez Fichier>Fermer dans la fenêtre Decision Studio.
Sujet parent : Dépannage


« Pourquoi les axes de mon graphique sont-ils divisés de manière inégale ? »

Cause possible | Solution
Chaque axe d'un graphique de profil ou de distribution croisée subdivisé selon le découpage principal du champ correspondant à l'axe. Si les modalités sont présentées avec une largeur égale, il s'agit une propriété de ce découpage. L'exception est l'endroit où la longueur d'un bloc dans une direction donnée transmet de l'information : dans ce cas, le paramètre d'affichage de l'Éditeur de découpage n'a aucun effet, afin de ne pas induire en erreur. | Dans l'Éditeur de découpage, sélectionnez le champ requis et décochez Affichage>Histogramme.
Sujet parent : Dépannage


« Pourquoi 'Maintenir les segments en surbrillance' est-il toujours grisé ? »

Cause possible | Solution
Vous tentez de garder les segments en surbrillance dans l'Aperçu du tableau, l'Aperçu du tableau croisé ou le Scoring. Lorsqu'un outil est lié [voir Relations entre outils] pour suivre l'un de ces outils, les deux outils partagent la même source de données, quels que soient les éléments en surbrillance dans le premier outil. | Essayez plutôt de mettre en surbrillance les mêmes segments dans un outil de visualisation graphique.
Sujet parent : Dépannage


« Pourquoi mon texte ne ressemble-t-il pas à ce que j'ai saisi ? »

Cause possible | Solution
Certains caractères de votre texte ne peuvent pas être traduits au format de jeu de caractères (Latin-1) ISO-8859-1. | Évitez tout texte contenant des caractères qui ne peuvent pas être traduits vers le jeu de caractères (Latin-1) ISO-8859-1.
Sujet parent : Dépannage


Avis relatifs aux copyrights

  • Avis relatifs aux copyrights


Avis relatifs aux copyrights

Portrait Miner peut inclure les logiciels suivants :

ANTLR

http://www.antlr.org

Apache Batik

Ce produit comprend des logiciels développés par l'Apache Software Foundation (http://www.apache.org/).

Copyright © 2000 The Apache Software Foundation. Tous droits réservés.

La redistribution et l'utilisation sous des formes source et binaire, avec ou sans modification, sont autorisées si les conditions suivantes sont respectées :
  1. Les redistributions de code source doivent rappeler l'avis de droit d'auteur ci-dessus, cette liste de conditions et l'avertissement suivant.
  2. Les redistributions sous forme binaire doivent rappeler l'avis de droit d'auteur ci-dessus, cette liste de conditions et l'avertissement suivant dans la documentation et/ou tout autre document fourni à la distribution.
  3. La documentation de l'utilisateur final incluse avec la redistribution, le cas échéant, doit inclure la mention suivante : « Ce produit inclut des logiciels développés par l'Apache Software Foundation (http://www.apache.org/). Cette mention peut également apparaître dans le logiciel lui-même, si et au cas où ces les remerciements tiers apparaissent normalement.
  4. Les noms « Batik » et « Apache Software Foundation » ne doivent pas être utilisés pour avaliser ni promouvoir des produits dérivés de ce logiciel sans autorisation préalable écrite. Pour tout autorisation écrite, veuillez contacter apache@apache.org.
  5. Les produits dérivés de ce logiciel ne peuvent s'appeler « Apache » et « Apache » ne doit pas non plus apparaître dans leur nom, sans l'autorisation préalable écrite de l'Apache Software Foundation.

CE LOGICIEL EST FOURNI « EN L'ÉTAT » ET LES GARANTIES EXPLICITES OU IMPLICITES, Y COMPRIS, MAIS SANS S'Y LIMITER, LES GARANTIES IMPLICITES DE QUALITÉ MARCHANDE ET D'ADÉQUATION À UN USAGE PARTICULIER SONT EXCLUES. EN AUCUN CAS APACHE SOFTWARE FOUNDATION OU SES COLLABORATEURS NE SERONT TENUS RESPONSABLES DES DOMMAGES DIRECTS, INDIRECTS, ACCESSOIRES, SPÉCIFIQUES, ACCIDENTELS OU IMMATÉRIELS (Y COMPRIS, MAIS SANS S'Y LIMITER, L'ACQUISITION DE BIENS OU DE SERVICES, LA PERTE DE JOUISSANCE, DE DONNÉES OU DE BÉNÉFICES OU L'INTERRUPTION D'EXPLOITATION), QUELLE QU'EN SOIT LA CAUSE ET SELON TOUTE DÉFINITION DE LA RESPONSABILITÉ, QUE CE SOIT UN MANQUEMENT, UNE RESPONSABILITÉ ABSOLUE OU UN DÉLIT (Y COMPRIS UNE NÉGLIGENCE OU TOUTE AUTRE VIOLATION) RÉSULTANT D'UNE QUELCONQUE UTILISATION DE CE LOGICIEL, MÊME AVERTIS DE L'ÉVENTUALITÉ DE TELS DOMMAGES.

Ce logiciel provient de contributions volontaires versées par de nombreuses personnes, au nom de l'Apache Software Foundation. Pour plus d'informations sur l'Apache Software Foundation, veuillez consulter http://www.apache.org.

implémentation de l'algorithme APriori

Christian Borgelt, http://www.borgelt.net/apriori.html.

Logiciel public redistribué selon les conditions de la Licence publique générale simplifiée GNU.

DOM4J

Le projet DOM4J, http://www.dom4j.org.
La redistribution et l'utilisation de ce logiciel et de la documentation jointe, avec ou sans modification, sont autorisées si les conditions suivantes sont respectées :
  1. Les redistributions de code source doivent rappeler les déclarations et les avis de droit d'auteur. Les redistributions doivent également inclure une copie de ce document.
  2. Les redistributions sous forme binaire doivent rappeler l'avis de droit d'auteur ci-dessus, cette liste de conditions et l'avertissement suivant dans la documentation et/ou tout autre document fourni à la distribution.
  3. Le nom « DOM4J » ne doit pas être utilisé pour avaliser ni promouvoir des produits dérivés de ce logiciel sans autorisation préalable écrite de MetaStuff, Ltd. Pour toute autorisation écrite, veuillez contacter dom4j-info@metastuff.com.
  4. Les produits dérivés de ce logiciel ne peuvent s'appeler « DOM4J » et « DOM4J » ne peut apparaître dans leur nom sans l'autorisation préalable écrite de MetaStuff, Ltd. DOM4J est une marque déposée de MetaStuff, Ltd.
  5. Tout crédit dû doit être accordé au projet DOM4J — http://www.dom4j.org

CE LOGICIEL EST FOURNI PAR METASTUFF, LTD. ET SES COLLABORATEURS « EN L'ÉTAT » ET LES GARANTIES EXPLICITES OU IMPLICITES, Y COMPRIS, MAIS SANS S'Y LIMITER, LES GARANTIES IMPLICITES DE QUALITÉ MARCHANDE ET D'ADÉQUATION À UN USAGE PARTICULIER, SONT EXCLUES. EN AUCUN CAS METASTUFF, LTD. OU SES COLLABORATEURS NE SERONT TENUS RESPONSABLES DES DOMMAGES DIRECTS, INDIRECTS, ACCESSOIRES, SPÉCIFIQUES, ACCIDENTELS OU IMMATÉRIELS (Y COMPRIS, MAIS SANS S'Y LIMITER, L'ACQUISITION DE BIENS OU DE SERVICES, LA PERTE DE JOUISSANCE, DE DONNÉES OU DE BÉNÉFICES OU L'INTERRUPTION D'EXPLOITATION), QUELLE QU'EN SOIT LA CAUSE ET SELON TOUTE DÉFINITION DE LA RESPONSABILITÉ, QUE CE SOIT UN MANQUEMENT, UNE RESPONSABILITÉ ABSOLUE OU UN DÉLIT (Y COMPRIS UNE NÉGLIGENCE OU TOUTE AUTRE VIOLATION ) RÉSULTANT D'UNE QUELCONQUE UTILISATION DE CE LOGICIEL, MÊME AVERTIS DE L'ÉVENTUALITÉ DE TELS DOMMAGES.

Copyright 2001 — 2004 © MetaStuff, Ltd. Tous droits réservés.

fmt

et http://www.cs.princeton.edu/software/cii/} Bibliothèque de formatage de chaînes tirée du livre C Interfaces et implémentations : Techniques de création de logiciels réutilisables de David R. Hanson.

L'auteur de ce logiciel est David R. Hanson.

Copyright © 1994, 1995, 1996, 1997 de David R. Hanson. Tous droits réservés.

L'autorisation d'utiliser, copier, modifier et distribuer ce logiciel à quelque fin que ce soit, sous réserve des dispositions décrites ci-dessous, sans frais, est accordée, à condition que cet avis soit entièrement inclus dans toutes les copies d'un logiciel qui est ou comprend une copie ou modification de ce logiciel et dans toutes les copies des documents de support d'un tel logiciel.

CE LOGICIEL EST FOURNI « EN L'ÉTAT », SANS AUCUNE GARANTIE IMPLICITE OU EXPLICITE. L'AUTEUR, EN PARTICULIER, NE FAIT AUCUNE DÉCLARATION NI GARANTIE D'AUCUNE SORTE CONCERNANT LA QUALITÉ MARCHANDE DE CE LOGICIEL OU SON ADÉQUATION À UN USAGE PARTICULIER.

David Hanson, drh@microsoft.com, http://www.research.microsoft.com/~drh/.

FreeTDS

http://www.freetds.org/.

Logiciel gratuit redistribué en vertu du paragraphe 6b de la Licence publique générale pour bibliothèque GNU.

getopt

Ce produit (Portrait Miner) peut inclure un logiciel développé par l'Université de Californie, Berkeley et ses collaborateurs, sous réserve de l'avis d'autorisation suivant :
Copyright © 1987, 1993, 1994 Les Régents de l'Université de Californie. Tous droits réservés. La redistribution et l'utilisation sous des formes source et binaire, avec ou sans modification, sont autorisées si les conditions suivantes sont respectées :
  1. Les redistributions de code source doivent rappeler l'avis de droit d'auteur ci-dessus, cette liste de conditions et l'avertissement suivant.
  2. Les redistributions sous forme binaire doivent rappeler l'avis de droit d'auteur ci-dessus, cette liste de conditions et l'avertissement suivant dans la documentation et/ou tout autre document fourni à la distribution.
  3. Tous les supports publicitaires mentionnant les fonctions ou l'utilisation de ce logiciel doivent comporter la mention suivante : Ce produit inclut un logiciel développé par l'Université de Californie, Berkeley et ses collaborateurs.
  4. Ni le nom de l'université, ni les noms de ses collaborateurs ne peuvent être utilisés pour avaliser ou promouvoir des produits dérivés de ce logiciel sans autorisation préalable écrite spécifique.

CE LOGICIEL EST FOURNI PAR LES RÉGENTS ET LES COLLABORATEURS « EN L'ÉTAT » ET LES GARANTIES EXPLICITES OU IMPLICITES, Y COMPRIS, MAIS SANS S'Y LIMITER, LES GARANTIES IMPLICITES DE QUALITÉ MARCHANDE ET D'ADÉQUATION À UN USAGE PARTICULIER SONT EXCLUES. EN AUCUN CAS LES RÉGENTS OU COLLABORATEURS NE SERONT TENUS RESPONSABLES DES DOMMAGES DIRECTS, INDIRECTS, ACCESSOIRES, SPÉCIFIQUES, ACCIDENTELS OU IMMATÉRIELS (Y COMPRIS, MAIS SANS S'Y LIMITER, L'ACQUISITION DE BIENS OU DE SERVICES, LA PERTE DE JOUISSANCE, DE DONNÉES OU DE BÉNÉFICES OU L'INTERRUPTION D'EXPLOITATION), QUELLE QU'EN SOIT LA CAUSE ET SELON TOUTE DÉFINITION LA RESPONSABILITÉ, QUE CE SOIT UN MANQUEMENT, UNE RESPONSABILITÉ ABSOLUE OU UN DÉLIT (Y COMPRIS UNE NÉGLIGENCE OU TOUTE AUTRE VIOLATION ) RÉSULTANT D'UNE QUELCONQUE UTILISATION DE CE LOGICIEL, MÊME AVERTIS DE L'ÉVENTUALITÉ DE TELS DOMMAGES.

MemoryClassLoader de OpenEJB.org

La redistribution et l'utilisation de ce logiciel et de la documentation jointe, avec ou sans modification, sont autorisées si les conditions suivantes sont respectées :
  1. Les redistributions de code source doivent rappeler les déclarations et les avis de droit d'auteur. Les redistributions doivent également inclure une copie de ce document.
  2. Les redistributions sous forme binaire doivent rappeler l'avis de droit d'auteur ci-dessus, cette liste de conditions et l'avertissement suivant dans la documentation et/ou tout autre document fourni à la distribution.
  3. Le nom « OpenEJB » ne doit pas être utilisé pour avaliser ni promouvoir des produits dérivés de ce logiciel sans autorisation préalable écrite de The OpenEJB Group. Pour tout autorisation écrite, veuillez contacter info@openejb.org.
  4. Les produits dérivés de ce logiciel ne peuvent s'appeler « OpenEJB » et « OpenEJB » ne doit pas non plus apparaître dans leur nom, sans l'autorisation préalable écrite de The OpenEJB Group. OpenEJB est une marque déposée de The OpenEJB Group.
  5. Tout crédit dû doit être accordé au projet OpenEJB — http://www.openejb.org

CE LOGICIEL EST FOURNI PAR THE OPENEJB GROUP ET SES COLLABORATEURS « EN L'ÉTAT » ET LES GARANTIES EXPLICITES OU IMPLICITES, Y COMPRIS, MAIS SANS S'Y LIMITER, LES GARANTIES IMPLICITES DE QUALITÉ MARCHANDE ET D'ADÉQUATION À UN USAGE PARTICULIER SONT EXCLUES. EN AUCUN CAS THE OPENEJB GROUP OU SES COLLABORATEURS NE SERONT TENUS RESPONSABLES DES DOMMAGES DIRECTS, INDIRECTS, ACCESSOIRES, SPÉCIFIQUES, ACCIDENTELS OU IMMATÉRIELS (Y COMPRIS, MAIS SANS S'Y LIMITER, L'ACQUISITION DE BIENS OU DE SERVICES, LA PERTE DE JOUISSANCE, DE DONNÉES OU DE BÉNÉFICES OU L'INTERRUPTION D'EXPLOITATION), QUELLE QU'EN SOIT LA CAUSE ET SELON TOUTE DÉFINITION LA RESPONSABILITÉ, QUE CE SOIT UN MANQUEMENT, UNE RESPONSABILITÉ ABSOLUE OU UN DÉLIT (Y COMPRIS UNE NÉGLIGENCE OU TOUTE AUTRE VIOLATION ) RÉSULTANT D'UNE QUELCONQUE UTILISATION DE CE LOGICIEL, MÊME AVERTIS DE L'ÉVENTUALITÉ DE TELS DOMMAGES.

Copyright 2001 — 2005 © The OpenEJB Group. Tous droits réservés.

Réponses numériques

Ce produit inclut des procédures basées sur des programmes de réponses numériques : L'art du calcul scientifique, publié par Cambridge University Press, et sont utilisés selon autorisation.

pthreads-win32

Bibliothèque de discussions A POSIX pour Windowslong. Copyright © 2001 Ross P. Johnson. Tous droits réservés.

Logiciel public redistribué selon les conditions de la Licence publique générale simplifiée GNU.

RPC/XDR

Copyright © 1986, Sun Microsystems, Inc. soumis à l'avis d'autorisation suivant :

Sun RPC est un produit de Sun Microsystems, Inc et est destiné à une utilisation illimitée à condition que cette légende soit incluse en totalité ou en partie sur tous les supports de bande et en tant que partie du programme logiciel. Les utilisateurs peuvent copier ou modifier Sun RPC gratuitement, mais ne sont pas autorisés à en octroyer une licence ni à le distribuer à quiconque, sauf dans le cadre d'un produit ou d'un programme développé par l'utilisateur.

SUN RPC EST FOURNI EN L'ÉTAT SANS GARANTIE D'AUCUNE SORTE, Y COMPRIS LES GARANTIES DE CONCEPTION, DE QUALITÉ MARCHANDE ET D'ADÉQUATION À UN USAGE PARTICULIER OU DÉCOULANT DE L'EXÉCUTION D'UN CONTRAT, D'UN USAGE OU D'UNE PRATIQUE COMMERCIALE.

Sun RPC est fourni sans support et sans aucune obligation de la part de Sun Microsystems, Inc. pour aider à son utilisation, sa correction, sa modification ou son amélioration.

SUN MICROSYSTEMS, INC. NE SERA EN AUCUN CAS TENU RESPONSABLE QUANT À LA VIOLATION DE TOUT OU PARTIE DES DROITS D'AUTEUR, SECRETS COMMERCIAUX OU DE TOUT BREVET DE SUN RPC.

En aucun cas, Sun Microsystems, Inc. ne peut être tenu responsable de toute perte de revenus ou bénéfices ou d'autres dommages spécifiques, indirects et immatériels, même si Sun a été informé de la possibilité de tels dommages.

Sun Microsystems, Inc.

2550 Garcia Avenue

Mountain View, California 94043

Rx

Copyright © 1996 Tom Lord, Berkeley, CA USA, excepté des portions de « POSIX Regex Functions » qui sont des Copyright © 1995 Free Software Foundation, Inc.

L'autorisation d'utiliser, copier, modifier, distribuer et vendre ce logiciel et sa documentation dans n'importe quel but est ici autorisée gratuitement, à condition que l'avis de copyright ci-dessus apparaisse dans toutes les copies et que cet avis de copyright et cette autorisation apparaissent dans la documentation support.

Logiciel gratuit redistribué en vertu du paragraphe 6b de la Licence publique générale pour bibliothèque GNU.

Stat/Transfer

Copyright © 2003 Circle Systems, Inc.

Trang

Convertisseur de schémas multi-format basé sur \rng. Copyright © 2002, 2003 Thai Open Source Software Center Ltd. Tous droits réservés.
La redistribution et l'utilisation sous des formes source et binaire, avec ou sans modification, sont autorisées si les conditions suivantes sont respectées :
  • Les redistributions de code source doivent rappeler l'avis de droit d'auteur ci-dessus, cette liste de conditions et l'avertissement suivant.
  • Les redistributions sous forme binaire doivent rappeler l'avis de droit d'auteur ci-dessus, cette liste de conditions et l'avertissement suivant dans la documentation et/ou tout autre document fourni à la distribution.
  • Ni le nom de Thai Open Source Software Center Ltd, ni les noms de ses collaborateurs ne peuvent être utilisés pour avaliser ni promouvoir des produits dérivés de ce logiciel sans autorisation préalable écrite spécifique.

CE LOGICIEL EST FOURNI PAR LES TITULAIRES DE COPYRIGHT ET LES COLLABORATEURS « EN L'ÉTAT » ET LES GARANTIES EXPLICITES OU IMPLICITES, Y COMPRIS, MAIS SANS S'Y LIMITER, LES GARANTIES IMPLICITES DE QUALITÉ MARCHANDE ET D'ADÉQUATION À UN USAGE PARTICULIER SONT EXCLUES. EN AUCUN CAS LES RÉGENTS OU COLLABORATEURS NE SERONT TENUS RESPONSABLES DES DOMMAGES DIRECTS, INDIRECTS, ACCESSOIRES, SPÉCIFIQUES, ACCIDENTELS OU IMMATÉRIELS (Y COMPRIS, MAIS SANS S'Y LIMITER, L'ACQUISITION DE BIENS OU DE SERVICES, LA PERTE DE JOUISSANCE, DE DONNÉES OU DE BÉNÉFICES OU L'INTERRUPTION D'EXPLOITATION), QUELLE QU'EN SOIT LA CAUSE ET SELON TOUTE DÉFINITION LA RESPONSABILITÉ, QUE CE SOIT UN MANQUEMENT, UNE RESPONSABILITÉ ABSOLUE OU UN DÉLIT (Y COMPRIS UNE NÉGLIGENCE OU TOUTE AUTRE VIOLATION ) RÉSULTANT D'UNE QUELCONQUE UTILISATION DE CE LOGICIEL, MÊME AVERTIS DE L'ÉVENTUALITÉ DE TELS DOMMAGES.

unixODBC

Sous-système Open Source ODBC et un SDK ODBC pour Linux, Mac OSX et UNIX. unixODBC, http://www.unixodbc.org/.

Logiciel gratuit redistribué en vertu du paragraphe 6b de la Licence publique générale pour bibliothèque GNU.

Xerces Java Parser

Ce produit comprend des logiciels développés par l'Apache Software Foundation (http://www.apache.org/).

Copyright © 1999 — 2002 The Apache Software Foundation. Tous droits réservés.

La redistribution et l'utilisation sous des formes source et binaire, avec ou sans modification, sont autorisées si les conditions suivantes sont respectées :
  1. Les redistributions de code source doivent rappeler l'avis de droit d'auteur ci-dessus, cette liste de conditions et l'avertissement suivant.
  2. Les redistributions sous forme binaire doivent rappeler l'avis de droit d'auteur ci-dessus, cette liste de conditions et l'avertissement suivant dans la documentation et/ou tout autre document fourni à la distribution.
  3. La documentation de l'utilisateur final incluse avec la redistribution, le cas échéant, doit inclure la mention suivante : « Ce produit inclut des logiciels développés par l'Apache Software Foundation (http://www.apache.org/). Cette mention peut également apparaître dans le logiciel lui-même, si et au cas où ces les remerciements tiers apparaissent normalement.
  4. Les noms « Xerces » et « Apache Software Foundation » ne doivent pas être utilisés pour avaliser ni promouvoir des produits dérivés de ce logiciel sans autorisation préalable écrite. Pour tout autorisation écrite, veuillez contacter apache@apache.org.
  5. Les produits dérivés de ce logiciel ne peuvent s'appeler « Apache » et « Apache » ne doit pas non plus apparaître dans leur nom, sans l'autorisation préalable écrite de l'Apache Software Foundation.

CE LOGICIEL EST FOURNI « EN L'ÉTAT » ET LES GARANTIES EXPLICITES OU IMPLICITES, Y COMPRIS, MAIS SANS S'Y LIMITER, LES GARANTIES IMPLICITES DE QUALITÉ MARCHANDE ET D'ADÉQUATION À UN USAGE PARTICULIER SONT EXCLUES. EN AUCUN CAS APACHE SOFTWARE FOUNDATION OU SES COLLABORATEURS NE SERONT TENUS RESPONSABLES DES DOMMAGES DIRECTS, INDIRECTS, ACCESSOIRES, SPÉCIFIQUES, ACCIDENTELS OU IMMATÉRIELS (Y COMPRIS, MAIS SANS S'Y LIMITER, L'ACQUISITION DE BIENS OU DE SERVICES, LA PERTE DE JOUISSANCE, DE DONNÉES OU DE BÉNÉFICES OU L'INTERRUPTION D'EXPLOITATION), QUELLE QU'EN SOIT LA CAUSE ET SELON TOUTE DÉFINITION DE LA RESPONSABILITÉ, QUE CE SOIT UN MANQUEMENT, UNE RESPONSABILITÉ ABSOLUE OU UN DÉLIT (Y COMPRIS UNE NÉGLIGENCE OU TOUTE AUTRE VIOLATION) RÉSULTANT D'UNE QUELCONQUE UTILISATION DE CE LOGICIEL, MÊME AVERTIS DE L'ÉVENTUALITÉ DE TELS DOMMAGES.

Ce logiciel provient de contributions volontaires versées par de nombreuses personnes au nom de l'Apache Software Foundation et était à l'origine basé sur le copyright logiciel © 1999, International Business Machines, Inc, http://www.ibm.com. Pour plus d'informations sur l'Apache Software Foundation, veuillez consulter http://www.apache.org.

Xerces Java Parser

Copyright © 1995 — 1998 Jean-loup Gailly et Mark Adler.
Sujet parent : Avis relatifs aux copyrights

LICENCE PUBLIQUE GÉNÉRALE POUR BIBLIOTHÈQUE GNU

Version 2, juin 1991

Copyright © 1991 Free Software Foundation, Inc.

59 Temple Place — Suite 330, Boston, MA 02111-1307, USA

Chacun est autorisé à copier et distribuer des copies textuelles de ce document de licence, mais aucune modification n'est autorisée.

Préambule

Les licences de la plupart des logiciels sont conçues pour vous enlever votre liberté de partage et modification. En revanche, les Licences publiques générales GNU sont destinées à vous garantir une liberté de partage et de modification des logiciels gratuits, pour garantir un logiciel gratuit à tous ses utilisateurs.

Cette licence, la licence publique générale pour bibliothèque, s'applique à certains logiciels spécialement conçus par Free Software Foundation et à toute autre bibliothèque dont les auteurs décident de l'utiliser. Vous pouvez aussi l'utiliser pour vos bibliothèques.

En ce qui concerne les logiciels libres, nous nous référons à la liberté, et non au prix. Nos licences publiques générales sont conçues pour vous garantir une liberté de distribution des copies de logiciels gratuits (et de facturation de ce service si vous le souhaitez), un code source ou la possibilité de l'obtenir si vous le souhaitez, la possibilité de modifier le logiciel ou d'en utiliser des parties dans de nouveaux programmes gratuits, et le fait que vous savez que vous pouvez entreprendre ces actions.

Pour protéger vos droits, nous devons apporter des restrictions qui interdisent à quiconque de vous refuser ces droits ou de vous demander d'y renoncer. Ces restrictions se traduisent par certaines responsabilités vous incombant si vous distribuez des copies de la bibliothèque ou si vous la modifiez.

Par exemple, si vous distribuez des copies de la bibliothèque, que ce soit gratuitement ou moyennant des frais, vous devez accorder aux destinataires tous les droits que nous vous avons donnés. Vous devez vous assurer que, eux aussi, reçoivent ou peuvent recevoir le code source. Si vous associez un programme à la bibliothèque, vous devez fournir des fichiers objets complets aux destinataires afin qu'ils puissent les associer à la bibliothèque, après avoir apporté des modifications à la bibliothèque et l'avoir recompilée. Et vous devez leur indiquer les présentes conditions afin qu'ils connaissent leurs droits.

Notre méthode afin de protéger vos droits comporte deux étapes : (1) protéger les droit d'auteur de la bibliothèque et (2) vous proposer cette licence qui vous donne l'autorisation légale de copier, distribuer et/ou modifier la bibliothèque.

Également, pour protéger chaque distributeur, nous voulons nous assurer que chacun comprenne qu'il n'y a aucune garantie pour cette bibliothèque gratuite. Si la bibliothèque est modifiée par quelqu'un d'autre et redistribué ensuite, nous voulons que les destinataires sachent que ce qu'ils ont n'est pas la version originale, de sorte que tout problème introduit par d'autres ne se retourne pas contre la réputation de l'auteur original.

Enfin, tout programme gratuit est constamment menacé par les brevets de logiciels. Nous souhaitons éviter que les entreprises de distribution de logiciels gratuits puissent obtenir des licences de brevets, ce qui aurait pour effet de transformer le programme en logiciel propriétaire. Pour éviter cela, nous avons clairement indiqué que tout brevet doit être autorisé pour une utilisation gratuite par tous ou ne doit pas autorisé du tout.

La plupart des logiciels GNU, y compris certaines bibliothèques, sont couverts par la Licence Publique Générale GNU, qui a été conçue pour les programmes utilitaires. Cette licence, la licence publique générale GNU, s'applique à certaines bibliothèques précises. Cette licence est assez différente de la licence ordinaire, soyez sûr de la lire en entier et ne présumez pas que tout est identique à la licence ordinaire.

La raison pour laquelle nous avons une licence publique différente pour certaines bibliothèques est que ces dernières brouillent la distinction que nous avons l'habitude de faire entre la modification ou l'ajout à un programme et la simple utilisation. Associer un programme à une bibliothèque, sans modifier la bibliothèque, signifie en quelque sorte tout simplement utiliser la bibliothèque et est analogue à l'exécution d'un programme utilitaire ou d'un programme d'application. Cependant, dans un sens textuel et juridique, l'exécutable associé est un travail combiné, un dérivé de la bibliothèque originale, et la Licence publique générale le traite comme tel.

En raison de cette distinction floue, l'utilisation de la Licence publique générale pour les bibliothèques n'a favorisé de manière efficace aucun logiciel de partage, car la plupart des développeurs n'ont pas utilisé les bibliothèques. Nous en avons conclu que les conditions les plus faibles pourraient favoriser un meilleur partage.

Toutefois, une association non restreinte de programmes payants priverait les utilisateurs de ces programmes de la gratuité des bibliothèques elles-mêmes. Cette licence publique générale pour bibliothèques est destinée à permettre aux développeurs de programmes payants d'utiliser les bibliothèques gratuites, tout en préservant votre liberté en tant qu'utilisateur de ces programmes de modifier les bibliothèques gratuites qui y sont incorporées. (Nous n'avons pas vu comment y parvenir en ce qui concerne les modifications dans les fichiers d'en-tête, mais nous y sommes parvenus en ce qui concerne les modifications dans les fonctions réelles de la bibliothèque.) L'espoir est que cela mènera à un développement plus rapide des bibliothèques libres.

Les conditions générales précises pour la copie, la distribution et la modification suivent. Prêtez attention à la différence entre une « œuvre basée sur la bibliothèque » et une « œuvre qui utilise la bibliothèque ». La première contient du code dérivé de la bibliothèque, alors que la seconde fonctionne seulement avec la bibliothèque.

Notez qu'il est possible qu'une bibliothèque soit couverte par la Licence Publique Générale (GPL) ordinaire plutôt que par cette licence spéciale.

CONDITIONS GÉNÉRALES POUR LA COPIE, LA DISTRIBUTION ET LA MODIFICATION

  • 0. Ce contrat de licence s'applique à toute bibliothèque de logiciels qui contient un avis inséré par le titulaire du copyright ou toute autre partie autorisée indiquant qu'elle peut être distribuée conformément aux conditions de la Licence Publique Générale pour Bibliothèques, (également appelée « cette licence »). Chaque titulaire de licence est désigné par « vous ».

    Une « bibliothèque » signifie un ensemble de fonctions logicielles et/ou données préparées de manière à être convenablement liées avec des programmes d'application (qui utilisent certaines de ces fonctions et données) pour former des exécutables.

    La « Bibliothèque », ci-dessous, se réfère à toute bibliothèque logicielle ou œuvre qui a été distribuée conformément à ces conditions. Une « œuvre basée sur la Bibliothèque » signifie soit la Bibliothèque, soit toute œuvre dérivée protégée par la loi sur les droits d'auteur : c'est-à-dire, une œuvre contenant la Bibliothèque ou une partie de celle-ci, soit de manière identique, soit avec des modifications et/ou traduite dans une autre langue. Ci-après, la traduction est incluse sans limitation dans le terme « modification ».

    « Code source » pour une œuvre représente la forme privilégiée de l'œuvre pour y effectuer des modifications. Pour une bibliothèque, le code source complet signifie tout le code source pour tous les modules qu'il contient, ainsi que tous les fichiers de définition d'interface associés, et les scripts utilisés pour contrôler la compilation et l'installation de la bibliothèque.

    Les activités autres que la copie, la distribution et la modification ne sont pas couvertes par cette Licence ; elles sont hors de sa portée. Le fait d'exécuter un programme à l'aide de la Bibliothèque n'est pas limité, et la production d'un tel programme n'est couverte que si son contenu constitue une œuvre basée sur la Bibliothèque (indépendamment de l'utilisation de la bibliothèque dans un outil pour l'écrire). Si tel est bien le cas, cela dépend de ce que la Bibliothèque effectue et en quoi consiste le programme qui utilise la bibliothèque.

  • 1. Vous pouvez copier et distribuer des copies textuelles de code source complet de la Bibliothèque que vous recevez, dans tout support, tant que vous publiez correctement et visiblement sur chaque copie un avis de copyright approprié et la décharge de garantie ; que vous gardez intacts tous les avis qui font référence à cette licence et à l'absence de toute garantie ; et que vous distribuez une copie de cette licence avec la Bibliothèque.

    Vous pouvez facturer des frais pour l'acte physique de transmission d'une copie, et vous pouvez à votre choix offrir une protection de garantie en échange d'une redevance.

  • 2. Vous pouvez modifier votre copie ou vos copies de la bibliothèque ou toute partie de celle-ci, en formant ainsi une œuvre basée sur la Bibliothèque ainsi que copier et distribuer ces modifications ou œuvre conformément aux conditions de l'article 1 mentionné ci-dessus, pourvu que vous puissiez aussi remplir toutes les conditions suivantes :
    • a) L'œuvre modifiée doit aussi être une bibliothèque logicielle.
    • b) Vous devez munir les fichiers modifiés d'avis bien visibles stipulant que vous avez modifié les fichiers et la date de chaque modification.
    • c) Vous devez prendre les dispositions voulues pour que l'ensemble des œuvres devant faire l'objet d'une licence le soient sans frais pour tous les tiers conformément aux conditions de cette Licence.
    • d) Si une fonctionnalité dans la Bibliothèque modifiée fait référence à une fonction ou à une table de données qui doit être fournie par un programme d'application qui utilise cette fonctionnalité, hormis en tant qu'argument transmis lorsque la fonctionnalité est invoquée, alors vous devez vous efforcer de bonne foi à garantir que, dans le cas où une application ne fournit pas cette fonction ou table, la fonctionnalité fonctionne encore et qu'elle effectue ses tâches de manière significative. (Par exemple, une fonction dans une bibliothèque pour calculer des racines carrées a une finalité totalement définie et indépendante de l'application. Par conséquent, l'article 2d exige que toute fonction fournie par une application ou table utilisée par cette fonction soit optionnelle : Si l'application ne la fournit pas, la fonction racine carrée doit encore calculer des racines carrées.)

    Ces exigences s'appliquent à l'ensemble de l'œuvre modifiée. Si des sections identifiables de cette œuvre ne sont pas issues de la Bibliothèque, et qu'elles peuvent être raisonnablement considérées comme des œuvres indépendantes et distinctes, alors la présente Licence et ses conditions ne s'appliquent pas à ces sections lorsque vous les distribuez en tant qu'œuvres distinctes. Mais lorsque vous distribuez les mêmes sections en tant que parties d'un ensemble qui est une œuvre basée sur la Bibliothèque, la distribution de l'ensemble doit figurer dans les conditions de cette Licence, dont les permissions pour les autres licences s'étendent à l'ensemble, et donc à chaque et toute partie indifféremment de qui l'a écrit.

    Ainsi, le but de cette section n'est pas de revendiquer des droits ou de contester vos droits sur une œuvre écrite entièrement par vous, mais l'intention est d'exercer le droit de contrôler la distribution d'œuvres dérivées ou collectives basées sur la Bibliothèque

    En outre, la simple agrégation d'une autre œuvre qui n'est pas basée sur la Bibliothèque avec la Bibliothèque (ou avec une œuvre basée sur la Bibliothèque) sur un volume d'un support de stockage ou de distribution ne place pas cette autre œuvre sous le champ de cette licence.

  • 3. Vous pouvez choisir d'appliquer les termes de la Licence Publique Générale de GNU, au lieu de cette Licence à une copie de la Bibliothèque. Pour ce faire, vous devez modifier tous les avis qui se réfèrent à cette Licence, afin qu'ils se réfèrent à la Licence Publique Générale ordinaire de GNU, version 2, au lieu de la présente Licence. (Si une version plus récente que la version 2 de la Licence Publique Générale de GNU est apparue, alors vous pouvez spécifier cette version si vous le souhaitez.) Ne faites pas d'autres modifications dans ces avis.

    Une fois que cette modification est apportée dans une copie donnée, elle est irréversible pour cette copie, de sorte que la Licence Publique Générale de GNU s'applique à toutes les copies subséquentes et les œuvres dérivées issues de cette copie.

    Cette option est utile lorsque vous souhaitez copier une partie du code de la Bibliothèque dans un programme qui n'est pas une bibliothèque.

  • 4. Vous pouvez copier et distribuer la Bibliothèque (ou une partie ou un dérivé de celle-ci, en vertu de l'article 2) en code objet ou sous forme d'exécutable aux termes des articles 1 et 2 ci-dessus, à condition qu'elle soit accompagnée de l'intégralité du code source correspondant assimilable par machine, lequel doit être distribué selon les termes des articles 1 et 2 ci-dessus sur un support habituellement utilisé pour l'échange de logiciels.

    Si la distribution du code objet consiste à offrir un accès pour copier à partir d'un lieu désigné, alors l'offre d'un accès équivalent pour copier le code source à partir du même endroit satisfait à l'obligation de distribuer le code source, même si les tiers ne sont pas contraints de copier la source avec le code objet.

  • 5. Un programme qui ne contient aucun dérivé d'une partie de la Bibliothèque, mais qui est conçu pour fonctionner avec la Bibliothèque en étant compilé ou lié à elle, est appelé une « œuvre qui utilise la Bibliothèque ». Une telle œuvre, isolément, n'est pas une œuvre dérivée de la Bibliothèque et donc n'entre pas dans le champ d'application de la présente licence.

    Cependant, lier une « œuvre qui utilise la Bibliothèque » avec la Bibliothèque crée un exécutable qui est un dérivé de la Bibliothèque (parce qu'il contient certaines parties de la Bibliothèque), plutôt qu'une « œuvre qui utilise la Bibliothèque ». L'exécutable est donc couvert par cette licence. L'article 6 stipule les conditions pour la distribution de ces fichiers exécutables.

    Lorsqu'un « travail qui utilise la Bibliothèque » utilise le matériel d'un fichier d'en-tête faisant partie de la Bibliothèque, le code objet pour l'œuvre peut être un travail dérivé de la Bibliothèque même si le code source ne l'est pas. Que cela soit vrai est particulièrement important si l'œuvre peut être liée sans la Bibliothèque, ou si l'œuvre est en soi une bibliothèque. Le seuil pour que cela soit vrai n'est pas précisément défini par la loi.

    Si un tel fichier objet utilise uniquement des paramètres numériques, des présentations de structure de données et des accesseurs ainsi que de petites fonctions de code incorporé (moins de dix lignes de longueur), alors l'utilisation du fichier objet est libre, indépendamment de savoir s'il est juridiquement une œuvre dérivée. ( Les exécutables contenant ce code objet et des parties de la Bibliothèque relèveront toujours de l'article 6.)

    Par ailleurs, si l'œuvre est un dérivé de la Bibliothèque, vous pouvez distribuer le code objet pour l'œuvre selon les termes de l'article 6. Tous les exécutables contenant cette œuvre relèvent également de l'article 6, qu'ils soient ou non directement liés avec la Bibliothèque elle-même.

  • 6. Comme exception aux articles ci-dessus, vous pouvez aussi compiler ou lier une « œuvre qui utilise la Bibliothèque » à la Bibliothèque afin de produire une œuvre qui contient des parties de la Bibliothèque, et distribuer cette œuvre selon les termes de votre choix, à condition que les termes permettent la modification de l'œuvre pour l'usage propre du client et sa rétro conception pour le débogage de telles modifications.
    Vous devez fournir un avis bien visible avec chaque copie de l'œuvre indiquant qu'elle utilise la Bibliothèque et que la Bibliothèque et son utilisation sont couverts par la présente Licence. Vous devez fournir une copie de cette Licence. Si pendant l'exécution, l'œuvre affiche les notices de copyright, vous devez inclure la notice de copyright pour la Bibliothèque parmi elles, ainsi qu'une référence de l'utilisateur de la copie de cette Licence. Vous devez également effectuer les actions suivantes :
    • a) Accompagner l'œuvre du code source complet correspondant assimilable par machine pour la Bibliothèque, y compris toutes les modifications qui ont été utilisées dans l'œuvre (qui doivent être distribuées en vertu des articles 1 et 2 ci-dessus), et, si l'œuvre est un exécutable lié à la Bibliothèque, avec l'« œuvre qui utilise la Bibliothèque » complète et assimilable par machine, sous forme de code objet et/ou code source, afin que l'utilisateur puisse modifier la Bibliothèque et ensuite la relier pour produire un exécutable modifié contenant la Bibliothèque modifiée. Il est entendu que l'utilisateur qui modifie le contenu des fichiers de définitions de la Bibliothèque ne sera pas nécessairement capable de recompiler l'application pour utiliser les définitions modifiées.
    • b) Accompagner l'œuvre d'une offre écrite, valable pendant au moins trois ans, pour fournir au même utilisateur les éléments spécifiés dans l'article 6a, ci-dessus, à un tarif n'excédant pas le coût d'exécution de cette distribution.
    • c) Si la distribution de l'œuvre se fait en offrant l'accès à une copie à endroit désigné, offrir un accès équivalent pour copier le matériel spécifié ci-dessus à partir du même endroit.
    • d) Vérifier que l'utilisateur a déjà reçu une copie de ce matériel ou que vous lui avez déjà envoyé une copie.

    Pour un exécutable, la forme requise de l' « œuvre qui utilise la Bibliothèque » doit inclure toutes les données et les programmes utilitaires nécessaires pour la reproduction de l'exécutable à partir de celle-ci. Toutefois, à titre d'exception ponctuelle, le code source distribué peut ne pas inclure tout ce qui est normalement distribué (source ou binaire) avec les composants principaux (compilateur, noyau, etc.) du système d'exploitation sur lequel l'exécutable s'exécute, à moins que ce composant lui-même n'accompagne l'exécutable.

    Il peut arriver que cette exigence soit en contradiction avec les restrictions de licence d'autres bibliothèques propriétaires qui, normalement, n'accompagnent pas le système d'exploitation. Une telle contradiction signifie que vous ne pouvez pas les utiliser ensemble et avec la Bibliothèque dans un exécutable que vous distribuez.

  • 7. Vous pouvez placer des fonctionnalités de bibliothèque qui représentent une œuvre basée sur la Bibliothèque côte à côte avec des fonctionnalités d'autres bibliothèques qui ne sont pas couvertes par la présente Licence, et distribuer une telle bibliothèque combinée, à condition que la distribution séparée de l'œuvre basée sur la Bibliothèque et les fonctionnalités des autres bibliothèques soient autorisées par ailleurs, et à condition d'effectuer les actions suivantes :
    • a) Accompagner la bibliothèque combinée avec une copie de la même œuvre basée sur la bibliothèque, non combinée avec aucune autre fonctionnalité de la bibliothèque. La distribution doit être effectuée selon les termes des articles ci-dessus.
    • b) Fournir une notice bien visible de la bibliothèque combinée du fait qu'une partie de celle-ci est une œuvre basée sur la Bibliothèque et qui explique où trouver la forme non combinée de la même œuvre.
  • 8. Vous ne pouvez pas copier, modifier, concéder sous licence, lier ou distribuer la Bibliothèque sauf dans les cas expressément prévus par la présente Licence. Toute tentative de copier, modifier, concéder sous licence, lier ou distribuer la Bibliothèque autrement est nulle et vos droits prendront fin automatiquement en vertu de la présente Licence. Toutefois, les parties qui ont reçu des copies ou des droits, au titre de cette Licence ne verront pas leurs licences résiliées tant que ces parties continueront à les respecter pleinement.
  • 9. Vous n'êtes pas tenu d'accepter cette Licence, tant que vous ne l'avez pas signée. Cependant, vous n'êtes pas autorisé à modifier ou distribuer la Bibliothèque ou ses œuvres dérivées. Ces actions sont interdites par la loi si vous n'acceptez pas cette Licence. Par conséquent, en modifiant ou en distribuant la Bibliothèque (ou toute œuvre basée sur la Bibliothèque), vous signifiez votre acceptation de la présente Licence pour ce faire, et toutes ses modalités et conditions pour la copie, la distribution ou la modification de la Bibliothèque ou des œuvres basées sur elle.
  • 10. Chaque fois que vous redistribuez la Bibliothèque (ou toute œuvre basée sur la Bibliothèque), le destinataire reçoit automatiquement une licence du concédant de la licence originale pour copier, distribuer, lier ou modifier la Bibliothèque sous réserve de ces termes et conditions. Vous ne pouvez pas imposer de restrictions supplémentaires sur l'exercice des destinataires des droits accordés par les présentes. Vous n'êtes pas responsable du respect de la conformité par des tierces parties de la présente Licence.
  • 11. Si, en conséquence d'un jugement de tribunal ou d'une allégation de violation de brevet ou pour toute autre raison (non limitée aux questions de brevet), des obligations vous sont imposées (que ce soit par ordonnance, accord amiable ou autre) qui contredisent les conditions de cette Licence, cela ne vous dispense pas des conditions de cette Licence. Si vous ne pouvez pas distribuer afin de satisfaire simultanément vos obligations en vertu de cette licence et toutes les autres obligations pertinentes, alors en conséquence vous ne pouvez absolument pas distribuer la Bibliothèque. Par exemple, si une licence de brevet ne permettait pas une redistribution gratuite de la Bibliothèque par tous ceux qui reçoivent des copies directement ou indirectement par votre intermédiaire, alors le seul moyen de satisfaire les deux parties et cette Licence serait de vous abstenir totalement de toute distribution de la Bibliothèque.

    Si une partie quelconque de cet article est non valide ou inexécutable dans des circonstances données, le reste de l'article est censé s'appliquer, et l'article dans son ensemble est censé s'appliquer dans d'autres circonstances.

    Le but de cet article n'est pas de vous induire à transgresser un quelconque brevet ou d'autres revendications à un droit de propriété ou à contester la validité de telles revendications ; cet article a pour seul but de protéger l'intégrité du système de distribution du logiciel libre qui est mis en œuvre par les pratiques de licence publique. De nombreuses personnes ont apporté une contribution généreuse à la vaste gamme de logiciels distribués par le biais de ce système en s'appuyant sur une application cohérente de ce système ; Il appartient à l'auteur/donateur de décider si il ou elle est disposé(e) à distribuer un logiciel par le biais de tout autre système et un titulaire d'une licence ne peut pas imposer ce choix.

    Cet article est destiné à rendre parfaitement clair ce que l'on croit être une conséquence du reste de la présente licence.

  • 12. Si la distribution et/ou l'utilisation de la Bibliothèque est restreinte dans certains pays par des brevets ou par des interfaces protégées, le détenteur du copyright original qui place la Bibliothèque sous cette Licence peut ajouter une restriction de distribution explicite de répartition géographique, excluant ces pays, afin que la distribution soit autorisée uniquement dans ou entre les pays qui ne sont pas exclus. Dans un tel cas, la présente Licence incorpore la limitation comme si elle était écrite dans le corps de la présente Licence.
  • 13. La Free Software Foundation peut publier des versions révisées et/ou de nouvelles versions de la Licence Publique Générale pour bibliothèques ponctuellement. Ces nouvelles versions seront semblables dans l'esprit à la présente version, mais elles peuvent différer en détail pour résoudre de nouveaux problèmes ou préoccupations.

    Chaque version reçoit un numéro de version distinctif. Si la Bibliothèque spécifie un numéro de version de cette Licence qui s'applique à elle et à « toute version ultérieure », vous avez la possibilité de suivre les termes et conditions de cette version ou de toute version ultérieure publiée par la Free Software Foundation. Si la Bibliothèque ne spécifie pas un numéro de version de licence, vous pouvez choisir n'importe quelle version publiée par la Free Software Foundation.

  • 14. Si vous souhaitez incorporer des parties de la Bibliothèque dans d'autres programmes libres dont les conditions de distribution sont incompatibles avec celles-ci, écrivez à l'auteur pour demander la permission. Pour tout logiciel protégé par la Free Software Foundation, écrivez à la Free Software Foundation ; nous faisons parfois des exceptions. Notre décision sera guidée par le double objectif de préserver le statut libre de tous les dérivés de nos logiciels libres et de promouvoir le partage et la réutilisation du logiciel en général.

    AUCUNE GARANTIE

  • 15. ÉTANT DONNÉ QUE LA BIBLIOTHÈQUE EST UNE LICENCE GRATUITE, IL N'Y AUCUNE GARANTIE POUR LA BIBLIOTHÈQUE, DANS LA MESURE PERMISE PAR LES LOIS APPLICABLES. SAUF MENTION CONTRAIRE ÉCRITE, LES TITULAIRES DU DROIT D'AUTEUR ET/OU LES AUTRES PARTIES FOURNISSENT LA BIBLIOTHÈQUE « TELLE QUELLE » SANS GARANTIE D'AUCUNE SORTE, SOIT EXPRESSE, SOIT IMPLICITE, Y COMPRIS, MAIS SANS LIMITATION, LES GARANTIES IMPLICITES DE QUALITÉ MARCHANDE ET D'ADÉQUATION À UN USAGE PARTICULIER. LA TOTALITÉ DU RISQUE EN MATIÈRE DE QUALITÉ ET PERFORMANCES DE LA BIBLIOTHÈQUE VOUS REVIENT. SI LA BIBLIOTHÈQUE S'AVÉRAIT DÉFECTUEUSE, VOUS ASSUMEREZ LE COÛT DE TOUT ENTRETIEN, RÉPARATION OU CORRECTION.
  • 16. SAUF EN CAS D'OBLIGATION LÉGALE OU D'ACCORD ÉCRIT, LE DÉTENTEUR DU COPYRIGHT OU TOUTE AUTRE PARTIE SUSCEPTIBLE DE MODIFIER OU DE REDISTRIBUER LA BIBLIOTHÈQUE, COMME AUTORISÉ PLUS HAUT, NE PEUT EN AUCUN CAS ÊTRE RESPONSABLE DE DOMMAGES ENVERS VOUS, Y COMPRIS TOUT DOMMAGE GÉNÉRAL, SPÉCIAL, ACCESSOIRE OU INDIRECT SURVENANT DE L'UTILISATION OU DE L'IMPOSSIBILITÉ D'UTILISER LA BIBLIOTHÈQUE (Y COMPRIS, SANS S'Y LIMITER, LA PERTE OU L'ALTÉRATION DE DONNÉES OU LES PERTES SUBIES PAR VOUS OU DES TIERS OU LE NON-FONCTIONNEMENT DE LA BIBLIOTHÈQUE AVEC UN AUTRE LOGICIEL), MÊME SI LE DÉTENTEUR, OU UNE AUTRE PARTIE, A ÉTÉ INFORMÉ DE LA POSSIBILITÉ QUE DE TELS DOMMAGES SURVIENNENT.
FIN DES CONDITIONS GÉNÉRALES

Comment appliquer ces conditions à vos nouvelles bibliothèques

Si vous développez une nouvelle bibliothèque, et que vous voulez qu'elle soit de la plus grande utilité possible au public, nous vous recommandons de créer un logiciel libre que chacun puisse redistribuer et modifier. Vous pouvez le faire en autorisant la redistribution selon ces conditions (ou, alternativement, selon les conditions de la Licence Publique Générale ordinaire).

Pour appliquer ces conditions, joignez les avis suivants à la bibliothèque. Il est plus sûr de les joindre au début de chaque fichier source pour transmettre plus efficacement l'exclusion de garantie. En outre, il est conseillé que chaque fichier comporte au moins la ligne « copyright » et un pointeur indiquant où se trouve l'avis complet.

    one line to give the library's name and an idea of what it does.
    Copyright (C) year name of author

    This library is free software; you can redistribute it and/or
    modify it under the terms of the GNU Library General Public
    License as published by the Free Software Foundation; either
    version 2 of the License, or (at your option) any later version.

    This library is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
    Library General Public License for more details.

    You should have received a copy of the GNU Library General Public
    License along with this library; if not, write to the
    Free Software Foundation, Inc., 59 Temple Place - Suite 330,
    Boston, MA  02111-1307, USA.

Ajoutez également des informations sur la façon de communiquer avec vous par courrier électronique et courrier papier.

Vous devriez également demander à votre employeur (si vous travaillez en tant que programmeur) ou à votre école, le cas échéant, de signer un « avis de non-responsabilité du droit d'auteur » pour la bibliothèque, si nécessaire. Voici un échantillon, modifiez les noms :
    Yoyodyne, Inc., hereby disclaims all copyright interest in
    the library 'Frob' (a library for tweaking knobs) written
    by James Random Hacker.

    signature of Ty Coon, 1 April 1990
    Ty Coon, President of Vice
C'est tout !

LICENCE PUBLIQUE GÉNÉRALE LIMITÉE (LGPL)

Version 2.1, février 1999

Copyright © 1991, 1999 Free Software Foundation, Inc.

59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

Chacun est autorisé à copier et distribuer des copies textuelles de ce document de licence, mais aucune modification n'est autorisée.

Préambule

Les licences de la plupart des logiciels sont conçues pour vous enlever votre liberté de partage et modification. En revanche, les Licences publiques générales GNU sont destinées à vous garantir une liberté de partage et de modification des logiciels gratuits, pour garantir un logiciel gratuit à tous ses utilisateurs.

Cette licence, la Licence publique générale limitée, s'applique à certains logiciels spécialement désignés, généralement des bibliothèques, de la Free Software Foundation et des autres auteurs qui décident de l'utiliser. Vous pouvez l'utiliser également, mais nous vous suggérons de bien réfléchir sur la question de savoir si cette licence ou la Licence Publique Générale ordinaire est la meilleure stratégie à utiliser dans un cas particulier, sur la base des explications ci-dessous.

En ce qui concerne les logiciels libres, nous parlons de liberté d'utilisation, pas de prix. Nos Licences Publiques Générales sont conçues pour vous assurer d'avoir la liberté de distribuer des copies de logiciels libres (et de facturer ce service si vous le souhaitez) ; de recevoir le code source ou de l'obtenir si vous le voulez , de pouvoir modifier le logiciel et utiliser des morceaux dans de nouveaux programmes libres, et vous informer que vous êtes en mesure d'effectuer toutes ces opérations.

Afin de protéger vos droits, nous devons faire des restrictions qui interdisent aux distributeurs de vous refuser ces droits ou de vous demander de renoncer à ces droits. Ces restrictions se traduisent par certaines responsabilités pour vous si vous distribuez des copies de la bibliothèque ou si vous les modifiez.

Par exemple, si vous distribuez des copies de la bibliothèque, que ce soit gratuitement ou moyennant des frais, vous devez accorder aux destinataires tous les droits que nous vous avons donnés. Vous devez vous assurer que, eux aussi, reçoivent ou peuvent recevoir le code source. Si vous liez un autre code à la bibliothèque, vous devez fournir des fichiers objets complets aux destinataires, de sorte qu'ils puissent les lier avec la bibliothèque après avoir modifié la bibliothèque et après l'avoir recompilée. Et vous devez leur indiquer les présentes conditions afin qu'ils connaissent leurs droits.

Nous protégeons vos droits avec une méthode en deux étapes : 1) nous protégeons le droit d'auteur de la bibliothèque, et (2) nous vous offrons cette licence, qui vous donne la permission légale de copier, distribuer et/ou modifier la bibliothèque.

Afin de protéger chaque distributeur, nous voulons indiquer clairement qu'il n'y a aucune garantie pour la bibliothèque libre. Aussi, si la bibliothèque est modifiée par quelqu'un d'autre et redistribuée ensuite, les destinataires doivent savoir qu'il ne s'agit pas de la version originale, de sorte que la réputation de l'auteur original ne sera pas affectée par des problèmes qui pourraient être introduits par d'autres.

Enfin, les brevets logiciels constituent une menace constante pour l'existence de tout programme libre. Nous souhaitons faire en sorte qu'une société ne puisse pas restreindre effectivement les utilisateurs d'un programme libre en obtenant une licence restrictive d'un titulaire de brevet. Par conséquent, nous insistons pour que toute licence de brevet obtenue pour une version de la bibliothèque soit cohérente avec la pleine liberté d'utilisation spécifiée dans cette licence.

La plupart des logiciels GNU, y compris certaines bibliothèques, sont couverts par la Licence Publique Générale de GNU. Cette licence, la Licence Publique Générale Limitée, s'applique à certaines bibliothèques désignées et est bien différente de la Licence Publique Générale ordinaire. Nous utilisons cette licence pour certaines bibliothèques afin de permettre de lier ces bibliothèques à des programmes non libres.

Lorsqu'un programme est lié à une bibliothèque, soit de manière statique, soit en utilisant une bibliothèque partagée, la combinaison des deux est juridiquement parlant une œuvre combinée, un dérivé de la bibliothèque originale. La Licence Publique Générale ordinaire autorise une telle liaison seulement si l'ensemble satisfait ses critères de liberté. La Licence Publique Générale limitée permet des critères plus laxistes pour relier un autre code à la bibliothèque.

Nous appelons cette licence la License Publique Générale « Limitée », car elle fait moins pour protéger la liberté de l'utilisateur que la GPL ordinaire. Elle fournit également aux autres développeurs de logiciels libres moins d'avantages sur les concurrents des programmes non libres. Ces inconvénients sont la raison pour laquelle nous utilisons la Licence Publique Générale pour de nombreuses bibliothèques. Cependant, la licence LGPL offre des avantages dans certaines circonstances particulières.

Par exemple, à de rares occasions, il peut y avoir un besoin particulier d'encourager l'utilisation la plus large possible d'une certaine bibliothèque, afin qu'elle devienne un standard de facto. Pour atteindre cet objectif, les programmes non libres doivent être autorisés à utiliser la bibliothèque. Un cas plus fréquent est celui d'une bibliothèque gratuite faisant le même travail que les bibliothèques non libres largement utilisées. Dans ce cas, il n'y a rien à gagner à limiter la bibliothèque libre au logiciel libre uniquement, par conséquent, nous utilisons la Licence Publique Générale Limitée.

Dans d'autres cas, l'autorisation d'utiliser une bibliothèque particulière dans des programmes non libres permet à un plus grand nombre de personnes d'utiliser un vaste ensemble de logiciels libres. Par exemple, la permission d'utiliser la bibliothèque GNU C dans des programmes non libres permet à beaucoup plus de gens d'utiliser le système d'exploitation GNU, ainsi que sa variante, le système d'exploitation GNU/Linux.

Bien que la Licence Publique Générale Limitée soit moins protectrice de la liberté des utilisateurs, elle garantit que l'utilisateur d'un programme qui est lié à la Bibliothèque a la liberté et la possibilité d'exécuter ce programme en utilisant une version modifiée de la bibliothèque.

Les conditions générales précises pour la copie, la distribution et la modification suivent. Prêtez attention à la différence entre une « œuvre basée sur la bibliothèque » et une « œuvre qui utilise la bibliothèque ». La première contient du code dérivé de la bibliothèque, alors que la seconde doit être combinée avec la bibliothèque afin de s'exécuter.

CONDITIONS GÉNÉRALES POUR LA COPIE, LA DISTRIBUTION ET LA MODIFICATION

  • 0. Ce contrat de licence s'applique à toute bibliothèque de logiciels qui contient un avis inséré par le titulaire du droit d'auteur ou toute autre partie autorisée indiquant qu'elle peut être distribuée conformément aux conditions de la Licence Publique Générale Limitée (également appelée « cette licence »). Chaque titulaire de licence est désigné par « vous ».

    Une « bibliothèque » signifie un ensemble de fonctions logicielles et/ou données préparées de manière à être convenablement liées avec des programmes d'application (qui utilisent certaines de ces fonctions et données) pour former des exécutables.

    La « Bibliothèque », ci-dessous, se réfère à toute bibliothèque logicielle ou œuvre qui a été distribuée conformément à ces conditions. Une « œuvre basée sur la Bibliothèque » signifie soit la Bibliothèque, soit toute œuvre dérivée protégée par la loi sur les droits d'auteur : c'est-à-dire, une œuvre contenant la Bibliothèque ou une partie de celle-ci, soit de manière identique, soit avec des modifications et/ou traduite dans une autre langue. Ci-après, la traduction est incluse sans limitation dans le terme « modification ».

    « Code source » pour une œuvre représente la forme privilégiée de l'œuvre pour y effectuer des modifications. Pour une bibliothèque, le code source complet signifie tout le code source pour tous les modules qu'il contient, ainsi que tous les fichiers de définition d'interface associés, et les scripts utilisés pour contrôler la compilation et l'installation de la bibliothèque.

    Les activités autres que la copie, la distribution et la modification ne sont pas couvertes par cette Licence ; elles sont hors de sa portée. Le fait d'exécuter un programme à l'aide de la Bibliothèque n'est pas limité, et la production d'un tel programme n'est couverte que si son contenu constitue une œuvre basée sur la Bibliothèque (indépendamment de l'utilisation de la bibliothèque dans un outil pour l'écrire). Si tel est bien le cas, cela dépend de ce que la Bibliothèque effectue et en quoi consiste le programme qui utilise la bibliothèque.

  • 1. Vous pouvez copier et distribuer des copies textuelles de code source complet de la Bibliothèque que vous recevez, dans tout support, tant que vous publiez correctement et visiblement sur chaque copie un avis de copyright approprié et la décharge de garantie ; que vous gardez intacts tous les avis qui font référence à cette licence et à l'absence de toute garantie ; et que vous distribuez une copie de cette licence avec la Bibliothèque.

    Vous pouvez facturer des frais pour l'acte physique de transmission d'une copie, et vous pouvez à votre choix offrir une protection de garantie en échange d'une redevance.

  • 2. Vous pouvez modifier votre copie ou vos copies de la bibliothèque ou toute partie de celle-ci, en formant ainsi une œuvre basée sur la Bibliothèque ainsi que copier et distribuer ces modifications ou œuvre conformément aux conditions de l'article 1 mentionné ci-dessus, pourvu que vous puissiez aussi remplir toutes les conditions suivantes :
    • a) L'œuvre modifiée doit aussi être une bibliothèque logicielle.
    • b) Vous devez munir les fichiers modifiés d'avis bien visibles stipulant que vous avez modifié les fichiers et la date de chaque modification.
    • c) Vous devez prendre les dispositions voulues pour que l'ensemble des œuvres devant faire l'objet d'une licence le soient sans frais pour tous les tiers conformément aux conditions de cette Licence.
    • d) Si une fonctionnalité dans la Bibliothèque modifiée fait référence à une fonction ou à une table de données qui doit être fournie par un programme d'application qui utilise cette fonctionnalité, hormis en tant qu'argument transmis lorsque la fonctionnalité est invoquée, alors vous devez vous efforcer de bonne foi à garantir que, dans le cas où une application ne fournit pas cette fonction ou table, la fonctionnalité fonctionne encore et qu'elle effectue ses tâches de manière significative. (Par exemple, une fonction dans une bibliothèque pour calculer des racines carrées a une finalité totalement définie et indépendante de l'application. Par conséquent, l'article 2d exige que toute fonction fournie par une application ou table utilisée par cette fonction soit optionnelle : Si l'application ne la fournit pas, la fonction racine carrée doit encore calculer des racines carrées.)

    Ces exigences s'appliquent à l'ensemble de l'œuvre modifiée. Si des sections identifiables de cette œuvre ne sont pas issues de la Bibliothèque, et qu'elles peuvent être raisonnablement considérées comme des œuvres indépendantes et distinctes, alors la présente Licence et ses conditions ne s'appliquent pas à ces sections lorsque vous les distribuez en tant qu'œuvres distinctes. Mais lorsque vous distribuez les mêmes sections en tant que parties d'un ensemble qui est une œuvre basée sur la Bibliothèque, la distribution de l'ensemble doit figurer dans les conditions de cette Licence, dont les permissions pour les autres licences s'étendent à l'ensemble, et donc à chaque et toute partie indifféremment de qui l'a écrit.

    Ainsi, le but de cette section n'est pas de revendiquer des droits ou de contester vos droits sur une œuvre écrite entièrement par vous, mais l'intention est d'exercer le droit de contrôler la distribution d'œuvres dérivées ou collectives basées sur la Bibliothèque

    En outre, la simple agrégation d'une autre œuvre qui n'est pas basée sur la Bibliothèque avec la Bibliothèque (ou avec une œuvre basée sur la Bibliothèque) sur un volume d'un support de stockage ou de distribution ne place pas cette autre œuvre sous le champ de cette licence.

  • 3. Vous pouvez choisir d'appliquer les termes de la Licence Publique Générale de GNU, au lieu de cette Licence à une copie de la Bibliothèque. Pour ce faire, vous devez modifier tous les avis qui se réfèrent à cette Licence, afin qu'ils se réfèrent à la Licence Publique Générale ordinaire de GNU, version 2, au lieu de la présente Licence. (Si une version plus récente que la version 2 de la Licence Publique Générale de GNU est apparue, alors vous pouvez spécifier cette version si vous le souhaitez.) Ne faites pas d'autres modifications dans ces avis.

    Une fois que cette modification est apportée dans une copie donnée, elle est irréversible pour cette copie, de sorte que la Licence Publique Générale de GNU s'applique à toutes les copies subséquentes et les œuvres dérivées issues de cette copie.

    Cette option est utile lorsque vous souhaitez copier une partie du code de la Bibliothèque dans un programme qui n'est pas une bibliothèque.

  • 4. Vous pouvez copier et distribuer la Bibliothèque (ou une partie ou un dérivé de celle-ci, en vertu de l'article 2) en code objet ou sous forme d'exécutable aux termes des articles 1 et 2 ci-dessus, à condition qu'elle soit accompagnée de l'intégralité du code source correspondant assimilable par machine, lequel doit être distribué selon les termes des articles 1 et 2 ci-dessus sur un support habituellement utilisé pour l'échange de logiciels.

    Si la distribution du code objet consiste à offrir un accès pour copier à partir d'un lieu désigné, alors l'offre d'un accès équivalent pour copier le code source à partir du même endroit satisfait à l'obligation de distribuer le code source, même si les tiers ne sont pas contraints de copier la source avec le code objet.

  • 5. Un programme qui ne contient aucun dérivé d'une partie de la Bibliothèque, mais qui est conçu pour fonctionner avec la Bibliothèque en étant compilé ou lié à elle, est appelé une « œuvre qui utilise la Bibliothèque ». Une telle œuvre, isolément, n'est pas une œuvre dérivée de la Bibliothèque et donc n'entre pas dans le champ d'application de la présente licence.

    Cependant, lier une « œuvre qui utilise la Bibliothèque » avec la Bibliothèque crée un exécutable qui est un dérivé de la Bibliothèque (parce qu'il contient certaines parties de la Bibliothèque), plutôt qu'une « œuvre qui utilise la Bibliothèque ». L'exécutable est donc couvert par cette licence. L'article 6 stipule les conditions pour la distribution de ces fichiers exécutables.

    Lorsqu'un « travail qui utilise la Bibliothèque » utilise le matériel d'un fichier d'en-tête faisant partie de la Bibliothèque, le code objet pour l'œuvre peut être un travail dérivé de la Bibliothèque même si le code source ne l'est pas. Que cela soit vrai est particulièrement important si l'œuvre peut être liée sans la Bibliothèque, ou si l'œuvre est en soi une bibliothèque. Le seuil pour que cela soit vrai n'est pas précisément défini par la loi.

    Si un tel fichier objet utilise uniquement des paramètres numériques, des présentations de structure de données et des accesseurs ainsi que de petites fonctions de code incorporé (moins de dix lignes de longueur), alors l'utilisation du fichier objet est libre, indépendamment de savoir s'il est juridiquement une œuvre dérivée. ( Les exécutables contenant ce code objet et des parties de la Bibliothèque relèveront toujours de l'article 6.)

    Par ailleurs, si l'œuvre est un dérivé de la Bibliothèque, vous pouvez distribuer le code objet pour l'œuvre selon les termes de l'article 6. Tous les exécutables contenant cette œuvre relèvent également de l'article 6, qu'ils soient ou non directement liés avec la Bibliothèque elle-même.

  • 6. Comme exception aux articles ci-dessus, vous pouvez aussi compiler ou lier une « œuvre qui utilise la Bibliothèque » à la Bibliothèque afin de produire une œuvre qui contient des parties de la Bibliothèque, et distribuer cette œuvre selon les termes de votre choix, à condition que les termes permettent la modification de l'œuvre pour l'usage propre du client et sa rétro conception pour le débogage de telles modifications.
    Vous devez fournir un avis bien visible avec chaque copie de l'œuvre indiquant qu'elle utilise la Bibliothèque et que la Bibliothèque et son utilisation sont couverts par la présente Licence. Vous devez fournir une copie de cette Licence. Si pendant l'exécution, l'œuvre affiche les notices de copyright, vous devez inclure la notice de copyright pour la Bibliothèque parmi elles, ainsi qu'une référence de l'utilisateur de la copie de cette Licence. Vous devez également effectuer les actions suivantes :
    • a) Accompagner l'œuvre du code source complet correspondant assimilable par machine pour la Bibliothèque, y compris toutes les modifications qui ont été utilisées dans l'œuvre (qui doivent être distribuées en vertu des articles 1 et 2 ci-dessus), et, si l'œuvre est un exécutable lié à la Bibliothèque, avec l'« œuvre qui utilise la Bibliothèque » complète et assimilable par machine, sous forme de code objet et/ou code source, afin que l'utilisateur puisse modifier la Bibliothèque et ensuite la relier pour produire un exécutable modifié contenant la Bibliothèque modifiée. Il est entendu que l'utilisateur qui modifie le contenu des fichiers de définitions de la Bibliothèque ne sera pas nécessairement capable de recompiler l'application pour utiliser les définitions modifiées.
    • b) Utiliser un mécanisme approprié de bibliothèque partagée pour lier avec la bibliothèque. Un mécanisme approprié est celui qui (1) utilise, au moment de l'exécution, une copie de la bibliothèque déjà présente sur le système informatique de l'utilisateur, plutôt que de copier les fonctions de la bibliothèque vers l'exécutable, et (2) qui fonctionnera correctement avec une version modifiée de la bibliothèque, si l'utilisateur en installe une, tant que la version modifiée est une interface compatible avec la version de l'œuvre.
    • c) Accompagner l'œuvre avec une offre écrite, valable pendant au moins trois ans, pour fournir au même utilisateur les éléments spécifiés dans l'article 6a, ci-dessus, pour un tarif n'excédant pas le coût d'exécution de cette distribution.
    • d) Si la distribution de l'œuvre se fait en offrant l'accès à une copie à endroit désigné, offrir un accès équivalent pour copier le matériel spécifié ci-dessus à partir du même endroit.
    • e) Vérifiez que l'utilisateur a déjà reçu une copie de ce matériel ou que vous lui avez déjà envoyé une copie.

    Pour un exécutable, la forme requise de l' « œuvre qui utilise la Bibliothèque » doit inclure toutes les données et les programmes utilitaires nécessaires pour la reproduction de l'exécutable à partir de celle-ci. Toutefois, à titre d'exception ponctuelle, le matériel distribué peut ne pas comprendre tout ce qui est normalement distribué (source ou binaire) avec les composants principaux (compilateur, noyau, etc.) du système d'exploitation sur lequel l'exécutable s'exécute, à moins que ce composant lui-même n'accompagne l'exécutable

    Il peut arriver que cette exigence soit en contradiction avec les restrictions de licence d'autres bibliothèques propriétaires qui, normalement, n'accompagnent pas le système d'exploitation. Une telle contradiction signifie que vous ne pouvez pas les utiliser ensemble et avec la Bibliothèque dans un exécutable que vous distribuez.

  • 7. Vous pouvez placer des fonctionnalités de bibliothèque qui représentent une œuvre basée sur la Bibliothèque côte à côte avec des fonctionnalités d'autres bibliothèques qui ne sont pas couvertes par la présente Licence, et distribuer une telle bibliothèque combinée, à condition que la distribution séparée de l'œuvre basée sur la Bibliothèque et les fonctionnalités des autres bibliothèques soient autorisées par ailleurs, et à condition d'effectuer les actions suivantes :
    • a) Accompagner la bibliothèque combinée avec une copie de la même œuvre basée sur la bibliothèque, non combinée avec aucune autre fonctionnalité de la bibliothèque. La distribution doit être effectuée selon les termes des articles ci-dessus.
    • b) Fournir une notice bien visible de la bibliothèque combinée du fait qu'une partie de celle-ci est une œuvre basée sur la Bibliothèque et qui explique où trouver la forme non combinée de la même œuvre.
  • 8. Vous ne pouvez pas copier, modifier, concéder sous licence, lier ou distribuer la Bibliothèque sauf dans les cas expressément prévus par la présente Licence. Toute tentative de copier, modifier, concéder sous licence, lier ou distribuer la Bibliothèque autrement est nulle et vos droits prendront fin automatiquement en vertu de la présente Licence. Toutefois, les parties qui ont reçu des copies ou des droits, au titre de cette Licence ne verront pas leurs licences résiliées tant que ces parties continueront à les respecter pleinement.
  • 9. Vous n'êtes pas tenu d'accepter cette Licence, tant que vous ne l'avez pas signée. Cependant, vous n'êtes pas autorisé à modifier ou distribuer la Bibliothèque ou ses œuvres dérivées. Ces actions sont interdites par la loi si vous n'acceptez pas cette Licence. Par conséquent, en modifiant ou en distribuant la Bibliothèque (ou toute œuvre basée sur la Bibliothèque), vous signifiez votre acceptation de la présente Licence pour ce faire, et toutes ses modalités et conditions pour la copie, la distribution ou la modification de la Bibliothèque ou des œuvres basées sur elle.
  • 10. Chaque fois que vous redistribuez la Bibliothèque (ou toute œuvre basée sur la Bibliothèque), le destinataire reçoit automatiquement une licence du concédant de la licence originale pour copier, distribuer, lier ou modifier la Bibliothèque sous réserve de ces termes et conditions. Vous ne pouvez pas imposer de restrictions supplémentaires sur l'exercice des destinataires des droits accordés par les présentes. Vous n'êtes pas responsable du respect de la conformité par des tierces parties de la présente licence.
  • 11. Si, en conséquence d'un jugement de tribunal ou d'une allégation de violation de brevet ou pour toute autre raison (non limitée aux questions de brevet), des obligations vous sont imposées (que ce soit par ordonnance, accord amiable ou autre) qui contredisent les conditions de cette Licence, cela ne vous dispense pas des conditions de cette Licence. Si vous ne pouvez pas distribuer afin de satisfaire simultanément vos obligations en vertu de cette licence et toutes les autres obligations pertinentes, alors en conséquence vous ne pouvez absolument pas distribuer la Bibliothèque. Par exemple, si une licence de brevet ne permettait pas une redistribution gratuite de la Bibliothèque par tous ceux qui reçoivent des copies directement ou indirectement par votre intermédiaire, alors le seul moyen de satisfaire les deux parties et cette Licence serait de vous abstenir totalement de toute distribution de la Bibliothèque.

    Si une partie quelconque de cet article est non valide ou inexécutable dans des circonstances données, le reste de l'article est censé s'appliquer, et l'article dans son ensemble est censé s'appliquer dans d'autres circonstances.

    Le but de cet article n'est pas de vous induire à transgresser un quelconque brevet ou d'autres revendications à un droit de propriété ou à contester la validité de telles revendications ; cet article a pour seul but de protéger l'intégrité du système de distribution du logiciel libre qui est mis en œuvre par les pratiques de licence publique. De nombreuses personnes ont apporté une contribution généreuse à la vaste gamme de logiciels distribués par le biais de ce système en s'appuyant sur une application cohérente de ce système ; Il appartient à l'auteur/donateur de décider si il ou elle est disposé(e) à distribuer un logiciel par le biais de tout autre système et un titulaire d'une licence ne peut pas imposer ce choix.

    Cet article est destiné à rendre parfaitement clair ce que l'on croit être une conséquence du reste de la présente licence.

  • 12. Si la distribution et/ou l'utilisation de la Bibliothèque est restreinte dans certains pays par des brevets ou par des interfaces protégées, le détenteur du copyright original qui place la Bibliothèque sous cette Licence peut ajouter une restriction de distribution explicite de répartition géographique, excluant ces pays, afin que la distribution soit autorisée uniquement dans ou entre les pays qui ne sont pas exclus. Dans un tel cas, la présente Licence incorpore la limitation comme si elle était écrite dans le corps de la présente Licence.
  • 13. La Free Software Foundation peut publier des versions révisées et/ou de nouvelles versions de la Licence Publique Générale Limitée ponctuellement. Ces nouvelles versions seront semblables dans l'esprit à la présente version, mais elles peuvent différer en détail pour résoudre de nouveaux problèmes ou préoccupations.

    Chaque version reçoit un numéro de version distinctif. Si la Bibliothèque spécifie un numéro de version de cette Licence qui s'applique à elle et à « toute version ultérieure », vous avez la possibilité de suivre les termes et conditions de cette version ou de toute version ultérieure publiée par la Free Software Foundation. Si la Bibliothèque ne spécifie pas un numéro de version de licence, vous pouvez choisir n'importe quelle version publiée par la Free Software Foundation.

  • 14. Si vous souhaitez incorporer des parties de la Bibliothèque dans d'autres programmes libres dont les conditions de distribution sont incompatibles avec celles-ci, écrivez à l'auteur pour demander la permission. Pour tout logiciel protégé par la Free Software Foundation, écrivez à la Free Software Foundation ; nous faisons parfois des exceptions. Notre décision sera guidée par le double objectif de préserver le statut libre de tous les dérivés de nos logiciels libres et de promouvoir le partage et la réutilisation du logiciel en général.

    AUCUNE GARANTIE

  • 15. ÉTANT DONNÉ QUE LA BIBLIOTHÈQUE EST UNE LICENCE GRATUITE, IL N'Y AUCUNE GARANTIE POUR LA BIBLIOTHÈQUE, DANS LA MESURE PERMISE PAR LES LOIS APPLICABLES. SAUF MENTION CONTRAIRE ÉCRITE, LES TITULAIRES DU DROIT D'AUTEUR ET/OU LES AUTRES PARTIES FOURNISSENT LA BIBLIOTHÈQUE « TELLE QUELLE » SANS GARANTIE D'AUCUNE SORTE, SOIT EXPRESSE, SOIT IMPLICITE, Y COMPRIS, MAIS SANS LIMITATION, LES GARANTIES IMPLICITES DE QUALITÉ MARCHANDE ET D'ADÉQUATION À UN USAGE PARTICULIER. LA TOTALITÉ DU RISQUE EN MATIÈRE DE QUALITÉ ET PERFORMANCES DE LA BIBLIOTHÈQUE VOUS REVIENT. SI LA BIBLIOTHÈQUE S'AVÉRAIT DÉFECTUEUSE, VOUS ASSUMEREZ LE COÛT DE TOUT ENTRETIEN, RÉPARATION OU CORRECTION.
  • 16. SAUF EN CAS D'OBLIGATION LÉGALE OU D'ACCORD ÉCRIT, LE DÉTENTEUR DU COPYRIGHT OU TOUTE AUTRE PARTIE SUSCEPTIBLE DE MODIFIER OU DE REDISTRIBUER LA BIBLIOTHÈQUE, COMME AUTORISÉ PLUS HAUT, NE PEUT EN AUCUN CAS ÊTRE RESPONSABLE DE DOMMAGES ENVERS VOUS, Y COMPRIS TOUT DOMMAGE GÉNÉRAL, SPÉCIAL, ACCESSOIRE OU INDIRECT SURVENANT DE L'UTILISATION OU DE L'IMPOSSIBILITÉ D'UTILISER LA BIBLIOTHÈQUE (Y COMPRIS, SANS S'Y LIMITER, LA PERTE OU L'ALTÉRATION DE DONNÉES OU LES PERTES SUBIES PAR VOUS OU DES TIERS OU LE NON-FONCTIONNEMENT DE LA BIBLIOTHÈQUE AVEC UN AUTRE LOGICIEL), MÊME SI LE DÉTENTEUR, OU UNE AUTRE PARTIE, A ÉTÉ INFORMÉ DE LA POSSIBILITÉ QUE DE TELS DOMMAGES SURVIENNENT.
FIN DES CONDITIONS GÉNÉRALES

Comment appliquer ces conditions à vos nouvelles bibliothèques

Si vous développez une nouvelle bibliothèque, et que vous voulez qu'elle soit de la plus grande utilité possible au public, nous vous recommandons de créer un logiciel libre que chacun puisse redistribuer et modifier. Vous pouvez le faire en autorisant la redistribution selon ces conditions (ou, alternativement, selon les conditions de la Licence Publique Générale ordinaire).

Pour appliquer ces conditions, joignez les avis suivants à la bibliothèque. Il est plus sûr de les joindre au début de chaque fichier source pour transmettre plus efficacement l'exclusion de garantie. En outre, il est conseillé que chaque fichier comporte au moins la ligne « copyright » et un pointeur indiquant où se trouve l'avis complet.

    one line to give the library's name and an idea of what it does.
    Copyright (C) year name of author

    This library is free software; you can redistribute it and/or
    modify it under the terms of the GNU Lesser General Public
    License as published by the Free Software Foundation; either
    version 2.1 of the License, or (at your option) any later version.

    This library is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
    Lesser General Public License for more details.

    You should have received a copy of the GNU Lesser General Public
    License along with this library; if not, write to the Free Software
    Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA

Ajoutez également des informations sur la façon de communiquer avec vous par courrier électronique et courrier papier.

Vous devriez également demander à votre employeur (si vous travaillez en tant que programmeur) ou à votre école, le cas échéant, de signer un « avis de non-responsabilité du droit d'auteur » pour la bibliothèque, si nécessaire. Voici un échantillon, modifiez les noms :
    Yoyodyne, Inc., hereby disclaims all copyright interest in
    the library 'Frob' (a library for tweaking knobs) written
    by James Random Hacker.

    signature of Ty Coon, 1 April 1990
    Ty Coon, President of Vice
C'est tout !


Copyright

© 2016 Pitney Bowes Software Inc. Tous droits réservés.

Ce document peut contenir des informations confidentielles et exclusives appartenant à Pitney Bowes Inc et/ou ses filiales et sociétés associées.

Portrait Software, le logo Portrait Software, Portrait, et la marque Portrait de Portrait Software sont des marques déposées de Portrait Software International Limited et ne peuvent être utilisées ou exploitées de quelque manière que ce soit sans l'accord exprès, préalable et écrit de Portrait Software International Limited.

Marques déposées

Tous les autres noms de produits, noms de société, marques, logos et symboles mentionnés ci-après peuvent être des marques ou des marques déposées de leurs propriétaires respectifs.

Assistance Portrait Software

Si vous avez besoin d'aide concernant un sujet qui n'est pas couvert par cette documentation, essayez notre Base de Connaissance sur notre site Internet http://support.portraitsoftware.com et suivez le lien vers votre produit.

Vous pouvez également télécharger d'autres documents d'informations Portrait Software à partir de notre site. Si vous ne possédez pas de nom d'utilisateur ou de mot de passe, ou si vous les avez oubliés, nous vous prions de nous contacter par l'un des moyens énoncés ci-dessous.

Si vous rencontrez un problème lors de l'utilisation, de l'installation ou avec la documentation de ce produit, veuillez nous contacter en utilisant l'une des méthodes suivantes :

Courriel : support@portraitsoftware.com

Téléphone

  • USA/Canada 1-800-335-3860 (numéro gratuit)
  • Reste du monde +44 800 840 0001

Lorsque vous nous signalez un problème, il nous est utile de connaître :

  • Le nom du logiciel
  • Les circonstances dans lesquelles le problème est survenu
  • Les messages d'erreur que vous avez vus (s'il y en a eu)
  • La version du logiciel que vous étiez en train d'utiliser

Pitney Bowes Software Inc.

February 23, 2016


Online Help