Introducción

  • Descripción general de Portrait Miner
© 2015 Pitney Bowes Software Inc. Email: software.support@pb.com


Descripción general de Portrait Miner

Portrait Miner es una poderosa solución de análisis predictivo que permite que tanto los profesionales dedicados a la percepción del cliente como los usuarios comerciales puedan formar una imagen clara de sus clientes para comprenderlos mejor, descubrir áreas de oportunidades, alcanzar una mayor segmentación y predecir comportamientos futuros.

Portrait Customer Analytics es una solución incomparable de próxima generación, diseñada para facilitar el uso y obtener rápidas visiones ejecutables. Esta solución reduce la brecha entre las herramientas estándar de inteligencia empresarial que poseen un alcance limitado para explorar información y las soluciones de procesamiento de datos numéricos para las cuales los programadores estadísticos deben crear consultas y modelos.

Esta solución utiliza una poderosa visualización de la información en 3D y una rápida automatización de modelos para revelar importantes conexiones entre los datos y calcular tendencias con solo pulsar un botón, lo cual incrementa la precisión del modelo predictivo y aumenta la velocidad de los resultados analíticos.

Portrait Miner se puede utilizar para prever comportamientos y tendencias que puedan afectar las ganancias, como la fuga de clientes, las oportunidades de ventas cruzadas y ventas mejoradas, el planeamiento y la segmentación de campañas, la satisfacción y lealtad del cliente y el valor del ciclo de vida del cliente.

Tema principal: Introducción


Introducción

  • Inicio de Portrait Miner
  • Para agregar o quitar detalles de servidores de Portrait Miner
  • Exploración para abrir o guardar un archivo o tabla de base de datos
  • Cómo trabajar con archivos en discos locales
  • Manipulación de archivos de enfoque en Portrait Miner
  • Visualización y edición de archivos de texto en Portrait Miner
  • Acerca de la codificación de texto
  • Cómo trabajar con archivos de sesiones


Inicio de Portrait Miner

  1. Realice uno de los procedimientos siguientes:
    • Haga doble clic en el icono de acceso directo de Portrait Miner en el escritorio. Se inicia Portrait Miner.
    • Vaya al menú Inicio de Windows y, en Programas>Portrait Miner, seleccione Portrait Miner.
  2. Si aparece una ventana de inicio de sesión, ingrese su nombre de usuario y contraseña para el servidor de Portrait Miner y haga clic en Aceptar.

    El administrador del sistema debe poder indicarle el servidor que debe usar (si hay opciones) y su nombre de usuario y contraseña para ese servidor. (Si el sistema operativo de su servidor es Windows, su nombre de usuario y contraseña deben ser adecuados para el dominio de Windows que configuró en los detalles del servidor).

    Si no ha usado Portrait Miner anteriormente y el menú Servidor está vacío, consulte la sección Para agregar o quitar detalles de servidores de Portrait Miner.

    Una vez que haya iniciado sesión en un servidor de Portrait Miner, puede ejecutar otras aplicaciones de Portrait Miner, que se conectarán con el mismo servidor sin solicitarle que inicie sesión otra vez. Permanecerá conectado al servidor de Portrait Miner hasta que explícitamente cierre sesión (seleccionando Archivo>Cerrar sesión en cualquier aplicación de Portrait Miner) o abandone la última aplicación abierta de Portrait Miner (seleccionando Archivo>Salir o haciendo clic en [image] en la ventana principal de la aplicación).

Tema principal: Introducción


Para agregar o quitar detalles de servidores de Portrait Miner

La primera vez que utilice Portrait Miner, el menú Servidor en la ventana de inicio de sesión está vacío (a menos que el administrador del sistema lo haya configurado para usted).

Si desea agregar una entrada al menú Servidor, es necesario que conozca el nombre de la red del servidor de Portrait Miner así como también su número de puerto. El administrador del sistema debe poder proporcionarle esta información.

Tema principal: Introducción

Para agregar un servidor al menú Servidor

  1. En la ventana de inicio de sesión, haga clic en Servidores para mostrar el cuadro de diálogo Servidores:

  2. Haga clic en Agregar para mostrar el cuadro de diálogo Agregar configuración de servidor:

  3. En el cuadro Nombre, ingrese la descripción del servidor utilizada en la lista Servidor de la ventana de inicio de sesión.
  4. En el cuadro Servidor, ingrese el nombre de la red del servidor de Portrait Miner (por ejemplo, yourserver.yourco.com).
  5. Seleccione Unix o Windows de acuerdo con el sistema operativo del servidor de Portrait Miner. Si selecciona Windows, especifique el dominio de Windows en el que iniciará sesión o utilice la configuración por defecto ("Local") para especificar una cuenta local en el servidor.
  6. En el cuadro Puerto, ingrese el número del puerto para el que se ha configurado el servidor.
  7. Haga clic en Aceptar para agregar los nuevos detalles del servidor.
  8. En el cuadro de diálogo Servidores, haga clic en Cerrar para regresar a la ventana de inicio de sesión.

Para editar los detalles de un servidor

  1. Haga clic en el botón Servidores.
  2. Resalte un servidor disponible y haga clic en Editar.

    Aparece el cuadro de diálogo Editar configuración del servidor, que es esencialmente igual al cuadro de diálogo Agregar configuración del servidor [consulte la sección Para agregar un servidor al menú Servidor].

  3. Corrija el nombre, el servidor o el puerto según sea necesario y haga clic en Aceptar.
  4. Haga clic en Cerrar para cerrar el cuadro de diálogo Servidores.

Para quitar un servidor del menú Servidores

  1. Haga clic en el botón Servidores.
  2. Resalte el servidor que desea quitar y haga clic en Quitar.
  3. Haga clic en Cerrar.


Exploración para abrir o guardar un archivo o tabla de base de datos

En Portrait Miner, siempre que abra o guarde un archivo, una sesión o una tabla de base de datos, aparecerá un explorador de archivos de Portrait Miner. Este explorador se asemeja a los exploradores de archivos en otras aplicaciones de Windows, pero tiene variantes que le permiten explorar archivos en su equipo, archivos en su servidor de Portrait Miner (en la versión cliente-servidor del software) y tablas en sus bases de datos.

Cuando abre o guarda un conjunto de datos, el explorador de archivos incluye hasta tres fichas, con los nombres "Quadstone", "Todos los archivos" y "RDBMS," tal como se ve en el siguiente ejemplo:

Tema principal: Introducción

Exploración de archivos en Portrait Miner

Las fichas "Quadstone" y "Todos los archivos" muestran archivos y carpetas en Portrait Miner, pero el anterior es algo más restrictivo:
 | Ficha "Quadstone" | Ficha "Todos los archivos"
Carpetas mostradas | Todas las carpetas, excepto: carpetas con las extensiones del nombre de archivo .rdx y .xtr, que incluyen archivos de datos para enfoques; carpetas cuyos nombres comienzan con un punto (.) | Todas las carpetas
Archivos que se muestran cuando Archivos de tipo se configura en Todos los archivos | Todos los archivos excepto: archivos con las extensiones de nombre de archivo .fcs, .mid, .mdh, .spa y .x86; archivos cuyos nombres finalizan con un tilde (~); archivos cuyos nombres comienzan con un punto (.) | Todos los archivos
Archivos que se muestran cuando Archivos de tipo se configura en un tipo de archivo en particular | Solo los archivos con las extensiones de nombre de archivo dadas | Como "Quadstone"

Si guarda un conjunto de datos como un archivo plano o enfoque, asegúrese de seleccionar el tipo necesario en el selector Archivos de tipo.

Nota:
  • Portrait Miner normalmente muestra los mismos archivos y carpetas que un explorador de archivos muestra bajo la ficha Quadstone. Puede mostrar los archivos y las carpetas que un explorador de archivos muestra bajo la ficha Todos los archivos seleccionando Ver>Mostrar archivos ocultos.
  • Portrait Miner genera archivos de registro con fines administrativos. Para ir a la carpeta que contiene estos archivos de registro, haga clic en [image] en la barra de herramientas.
  • Para ir a la carpeta anterior, siguiente o padre, haga clic en [image], [image] o [image] en la barra de herramientas.
  • Para ir directamente a la carpeta por defecto (la configuración de la preferencia inicio de qsexplorer), haga clic en
  • Puede ir directamente a una carpeta arbitraria seleccionando Ver>Ir a... y escribiendo el nombre de la carpeta.

Exploración de bases de datos, espacios de nombres y tablas

Puede explorar las bases de datos utilizando la ficha "RDBMS" cuando esté presente. ("RDBMS" hace referencia a "sistema de administración de bases de datos relacionales" [Relational Database Management System]). La ficha muestra inicialmente una lista de bases de datos disponibles. Puede explorar dentro de una jerarquía de bases de datos, bajar al nivel de tablas individuales simplemente de la misma forma en que explora en el sistema de archivos.

También consulte

Para configurar una conexión de base de datos

Exploración de sesiones en su equipo

Puede explorar las sesiones guardadas anteriormente (archivos .pms) utilizando el menú Archivo > Abrir sesión. En este caso, el explorador de archivos muestra una única ficha, con el nombre "Mi PC", donde la extensión del archivo .pms está seleccionada con anterioridad.

En estos casos, el explorador de archivos muestra una única ficha, con el nombre "Mi PC":

Puede explorar y guardar los archivos en el equipo de la misma forma que lo haría en cualquier otra aplicación de Windows.

Exploración de archivos en su equipo

Puede guardar algunos tipos de archivos en su equipo (o en una unidad de red a la que pueda acceder desde el equipo). Estos archivos incluyen gráficos exportados y tabulaciones cruzadas guardadas.

En estos casos, el explorador de archivos muestra una única ficha, con el nombre "Mi PC":

Puede explorar y guardar los archivos en el equipo de la misma forma que lo haría en cualquier otra aplicación de Windows.


Cómo trabajar con archivos en discos locales

Incluso si no tiene acceso directo a su equipo del servidor de Portrait Miner, puede guardar y abrir algunos archivos (tal como secuencias de comandos, imágenes y tabulaciones cruzadas) en el equipo. Para usar un archivo de datos que está en su equipo (o una unidad de red accesible), puede arrastrar un archivo de datos desde Windows Explorer hasta una carpeta de Portrait Miner.

Aparecerá una copia del archivo en la carpeta del servidor de Portrait Miner, que puede luego utilizar directamente.

Nota: Además de arrastrar archivos desde Windows Explorar hasta Portrait Miner, puede arrastrar archivos en la dirección opuesta para copiarlos desde el servidor de Portrait Miner a un disco local.

También consulte

Visualización y edición de archivos de texto en Portrait Miner
Tema principal: Introducción


Manipulación de archivos de enfoque en Portrait Miner

Un enfoque se almacena en el disco como un archivo .ftr (el "archivo de enfoque") junto con una colección de archivos de datos y otros en dos carpetas; sus nombres finalizan con .rdx ("Raw Data eXtract") y .xtr ("eXTRa"). Las carpetas suelen estar ocultas en Portrait Miner y en la ficha "Quadstone" del explorador de archivos de Portrait Miner [consulte Exploración para abrir o guardar un archivo o tabla de base de datos].

Un nuevo enfoque que se crea al copiar un enfoque existente o importar datos de otra clase de conjunto de datos (o como resultado de la ejecución de una secuencia de comandos TML) es independiente de otros enfoques. Por otro lado, un enfoque que se guarda de Decision Studio con un nombre nuevo, o uno que se crea al crear una copia enlazada depende de carpetas de datos que pertenecen a otros enfoques.

Dada la posible interdependencia de enfoques, no debe copiar, mover, cambiar el nombre o eliminar archivos de enfoque utilizando utilidades del sistema operativo, por ejemplo, Windows Explorer o herramientas de línea de comandos UNIX. En cambio, siempre debe utilizar Portrait Miner (o comandos de creación de datos de Portrait Miner).
Tema principal: Introducción

Copia o traslado de un archivo de enfoque a otra carpeta

  1. En Portrait Miner, haga clic en un archivo de enfoque que desea copiar o mover.
  2. Realice uno de los procedimientos siguientes:
    Si copia el archivo | Si mueve el archivo
    Seleccione Editar>Copiar. | Seleccione Editar>Cortar.
    Haga clic con el botón secundario del mouse y seleccione Copiar. | Haga clic con el botón secundario y seleccione Cortar.
    Haga clic en [image] en la barra de herramientas. | Haga clic en [image] en la barra de herramientas.
    Presione CTRL+C. | Presione CTRL+X.
  3. Desplácese hasta la carpeta de destino.
  4. Seleccione Editar>Pegar, haga clic con el botón secundario del mouse y seleccione Pegar, haga clic en [image] en la barra de herramientas o presione CTRL+V.
Nota:
  • Puede copiar un archivo de enfoque como un enfoque independiente (según se mencionó anteriormente), en cuyo caso los datos en sí se duplican; o bien, puede crear una copia enlazada, que comparte datos con el enfoque original. Para hacerlo, utilice Pegar enlace en lugar de Pegar. (No hay acceso directo en la barra de herramientas para hacer esto). No puede crear una copia vinculada al mover un archivo de enfoque.
  • También puede seleccionar un nombre nuevo para un enfoque que mueva o copia si selecciona Pegar como o (al copiar) Pegar el enlace como.
  • Esta interfaz de usuario es una forma de acceder a muchas de las funciones proporcionadas por los comandos de creación de datos qscopy, qslink y qsmove de Portrait Miner.
  • También puede copiar o mover archivos diferentes a los que enfoque (pero no crear copias vinculadas) de la misma forma.

También consulte

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Cambio del nombre de un archivo de enfoque

  1. En Portrait Miner, haga clic en el archivo cuyo nombre desee cambiar.
  2. Seleccione Editar>Cambiar nombre, haga clic con el botón secundario del mouse y seleccione Cambiar nombre, o simplemente haga clic por segunda vez en el nombre del archivo.

    Ahora podrá editar el nombre del archivo.

Nota:
  • Esta interfaz de usuario es una forma de acceder a muchas de las funciones proporcionadas por el comando de creación de datos qsmove de Portrait Miner.
  • También puede cambiar el nombre de archivos diferentes a los de enfoque y carpetas de la misma forma.

También consulte

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Eliminación de un archivo de enfoque

Puede utilizar Portrait Miner para eliminar recurrentemente una cadena completa de enfoque: seleccione el enfoque para eliminar y todos los enfoques que dependen de él también se eliminarán. Se muestra la confirmación de la eliminación de los enfoques, y tiene la opción de continuar o detener la operación de eliminación por completo.

  1. En Portrait Miner, haga clic en el archivo de enfoque que desea eliminar.
  2. Seleccione Editar>Eliminar, haga clic con el botón secundario del mouse y seleccione Eliminar, haga clic en [image] en la barra de herramientas o presione Delete.
Nota:
  • Esta interfaz de usuario accede a la mayoría de las funciones proporcionadas por el comando de creación de datos qsremove de Portrait Miner.
  • También puede eliminar archivos diferentes a los de enfoque y carpetas de la misma forma. Antes de eliminar una carpeta, primero debe eliminar los archivos de enfoque incluidos dentro de ella.

También consulte

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Creación de un archivo de archivos

Puede crear un archivo de archivos a partir de un enfoque o carpeta que contenga un conjunto de enfoques relacionados o subcarpetas.

En Portrait Miner, haga clic con el botón secundario en el archivo o la carpeta que desea archivar y seleccionar Archivar para una carpeta o Exportar>Para archivar para un enfoque.

En el cuadro de diálogo Archivar en archivo ZIP, especifique un nombre de archivo de salida.

Nota:
  • Si crea un archivo de archivos a partir de una carpeta que contiene enfoques enlazados a datos fuera de la carpeta, los datos externos se copiarán en el archivo. De esta forma se asegura de tener siempre un conjunto coherente de enfoques relacionados al extraer del archivo de archivos.
  • Esta interfaz de usuario es una forma de acceder a muchas de las funciones proporcionadas por el comando de creación de datos qsarchive de Portrait Miner.

También consulte

Acerca de los asistentes de Portrait Miner

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Extracción de un archivo de archivos

En Portrait Miner, haga clic con el botón secundario en el archivo de archivos del que desee extraer y seleccione Extraer.

En el cuadro de diálogo Extraer de archivo ZIP, seleccione una carpeta de salida y si desea sobrescribir los archivos existentes.

Nota: Esta interfaz de usuario es una forma de acceder a muchas de las funciones proporcionadas por el comando de creación de datos qsunzip de Portrait Miner.

También consulte

Acerca de los asistentes de Portrait Miner

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos


Visualización y edición de archivos de texto en Portrait Miner

La forma para editar o ver un archivo de Portrait Miner depende de su tipo de archivo. Puede:
  • hacer clic con el botón secundario en el archivo y seleccionar Editar para editar (o ver) el archivo en el Bloc de notas;
  • hacer clic con el botón secundario en el archivo y seleccionar Ver para ver el archivo en una aplicación adecuada;
  • hacer doble clic en el archivo como una alternativa a una de las opciones anteriores.
Tipo de archivo | Edit (Editar) | Vista | Haga doble clic en
Archivo de datos de texto (.txt, .dat, .csv, .tab, .fdf), archivo de descripción de datos planos (.fdd) |  |  | — (Abrir [consulte Creación de un enfoque de datos en un archivo de texto])
archivo SQL (.sql) |  |  | — (Abrir)
Bloc de notas. Archivo de secuencias de comandos TML (.tml), archivo de derivaciones FDL (.fdl), archivo de jerarquía de creación de rangos categóricos (.hrc) |  |  | Edit (Editar)
Archivo de registro (.log) |  |  | Vista
Archivo XML (.xml, .qmml, etc.) |  |  | Vista
Nota:
  • Incluso si no tiene acceso directo al equipo del servidor de Portrait Miner, aún puede ver y, si corresponde, editar archivos de texto en el servidor. Hay dos versiones de Portrait Miner: una versión cliente-servidor y Portrait Miner Desktop. Si utiliza la versión cliente-servidor, cuando utilice Portrait Miner para ver o editar un archivo de texto en el Bloc de notas, realmente estará trabajando con una copia local del archivo. Si guarda el archivo pero el Bloc de notas permanece abierto, la versión en el servidor no se modifica; Portrait Miner sólo copia la versión actualizada en el equipo nuevamente en el servidor cuando sale del Bloc de notas.
  • Debe utilizar una codificación ISO-8859-1 (Latin-1) al guardar archivos de texto.

También consulte

Manipulación de archivos de enfoque en Portrait Miner

Cómo trabajar con archivos en discos locales

XML en Portrait Miner

Tema principal: Introducción


Acerca de la codificación de texto

Los archivos de texto en Portrait Miner pueden estar codificados en Unicode, según la definición de la marca BOM (Byte Order Mark) del archivo. Si un archivo en Windows no tiene marca BOM, se asume que se trata de lo que Windows describe como 'ANSI' en relación con la configuración regional de la máquina, por ejemplo, Windows 1215 en Europa y EE. UU, CP932 en Japan. En Solaris, un archivo sin marca BOM se asume como un archivo con codificación latin-1.

Tema principal: Introducción


Cómo trabajar con archivos de sesiones

Si está trabajando dentro de una de las herramientas de visores individuales de Portrait Miner (Crosstab, 3D, Profile o Visor de Mapa) y desea guardar la vista actual, puede hacerlo utilizando la opción Archivo > Guardar sesión en la ventana Decision Studio. Los archivos se guardan con la extensión del archivo (.pms) y tienen como prefijo por defecto el nombre de archivo del enfoque.
Las sesiones guardadas pueden cargarse dentro de Decision Studio o, como opción, puede hacer doble clic en el archivo .pms en la ventana del explorador de Portrait Miner.
Nota:
Session files are directly linked to the associated focus file and must reside in the same directory.

Carga o apertura de una sesión guardada

Puede cargar sesiones guardadas para las siguientes herramientas de Portrait Miner:

  • Visor de Tabulación Cruzada
  • 3D viewer
  • Visor de Perfil
  • Visor de Mapa
    Nota: Todos los archivos de sesiones guardados están directamente relacionados con el archivo de enfoque a partir del cual se crearon.
Para cargar una sesión guardada de Portrait Miner
  1. Abra Portrait Miner y navegue hacia su directorio de sesiones guardadas.
  2. Haga doble clic en el archivo de sesiones guardadas (.pms). La sesión cargará los datos del enfoque asociados y la sesión guardada.
Para abrir una sesión guardada de Decision Studio
  1. Abra Decision Studio.
  2. Seleccione Archivo > Abrir sesión y explore el archivo de sesiones relevantes (.pms). La sesión cargará los datos del enfoque asociados y la sesión guardada.

Cómo guardar una sesión

Puede guardar información de sesiones individuales para las siguientes herramientas de Portrait Miner:

  • Visor de Tabulación Cruzada
  • 3D viewer
  • Visor de Perfil
  • Visor de Mapa
Para guardar una sesión
  1. Con su sesión abierta, cambie a la ventana Decision Studio y seleccione Archivo>Guardar sesión.
  2. En el cuadro de diálogo Guardar sesión, agregue el nombre de archivo al prefijo predeterminado. Nota: El prefijo identifica el archivo del enfoque relacionado con la sesión.
Tema principal: Introducción


Cómo trabajar con archivos planos, tablas de bases de datos y enfoques

  • Acerca de los asistentes de Portrait Miner
  • Cómo abrir un enfoque para visualizar, segmentar y modelar
  • Para ordenar un enfoque
  • Para convertir un enfoque orientado en la transacción a un enfoque orientado en el cliente
  • Creación de un enfoque de datos en un archivo de texto
  • Creación de un enfoque a partir de datos de una base de datos
  • Creación de un enfoque desde un SAS o desde un conjunto de datos de terceros
  • Exportación de registros a un archivo de datos, tabla de base de datos o enfoque
  • Acerca de la combinación de enfoques
  • Para unir campos de un enfoque a otro enfoque mediante el uso de Portrait Miner
  • Para unir campos de un enfoque a otro enfoque con Decision Studio
  • Combinación de registros de dos enfoques
  • Para configurar una conexión de base de datos
  • Cómo Portrait Miner importa los tipos de base de datos
  • Uso de Data Build Manager para importar, procesar y exportar datos
  • Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos


Acerca de los asistentes de Portrait Miner

Los asistentes de Portrait Miner se abren desde Portrait Miner, después de seleccionar un enfoque u otro archivo, y brindan el acceso a la interfaz de usuario de los comandos de creación de datos de Portrait Miner.

Cada asistente muestra los parámetros de los comandos en la ficha Parámetros. Los valores en la ficha Parámetros pueden modificarse si escribe directamente en el campo o si hace clic en Explorar [image] para mostrar un cuadro de diálogo adicional desde donde se puede seleccionar un valor.

Una vez que todos los parámetros obligatorios (indicados con un asterisco rojo en el campo del parámetro) han sido seleccionados, haga clic en Ir para ejecutar los comandos de creación de datos asociados. De ser necesario, puede detener el comando haciendo clic en el botón Detener; por ejemplo, si ha seleccionado los parámetros incorrectos.

Después de que el comando haya finalizado, podrá visualizar los resultados en la ficha Salida. Si ocurren errores al procesar el comando, aparecerá un mensaje de error en la ficha Error.

También consulte

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos
Tema principal: Cómo trabajar con archivos planos, tablas de bases de datos y enfoques


Cómo abrir un enfoque para visualizar, segmentar y modelar

Una vez que se tienen los datos del cliente en forma de enfoque, se pueden abrir en Decision Studio para analizarlos con las distintas herramientas [consulte Herramientas de Decision Studio] para visualizar, segmentar y modelar.

Se puede abrir un enfoque con una de las siguientes opciones:

  • En Portrait Miner, haga doble clic en el enfoque que desea abrir o clic con el botón derecho en el enfoque y seleccione Abrir.
  • En una ventana de Decision Studio con un enfoque ya abierto, seleccione Archivo>Close para cerrar ese enfoque. A continuación, seleccione Archivo>Abrir o haga clic en [image] en la barra de herramientas y explore para encontrar el enfoque que desee abrir.

    (Si ha modificado un enfoque después de crearlo o abrirlo, Decision Studio le da la posibilidad de guardar los cambios antes de cerrarlo).

Nota:
  • Si se le advierte que el enfoque es de sólo lectura, use Archivo>Guardar como, o haga clic en [image] en la barra de herramientas y seleccione un nuevo nombre o ubicación para su enfoque. O bien, copie el enfoque a una nueva ubicación. Algunas de las características y opciones del producto no funcionan con un enfoque de solo lectura.
  • Sólo se puede tener un enfoque abierto por vez en una sesión determinada de Decision Studio.

    (Sin embargo, se puede tener más de una sesión abierta a la vez de Decision Studio).

  • Dos o más usuarios pueden abrir el mismo enfoque en Decision Studio y trabajar simultáneamente con él. (Por supuesto, se debe asegurar de que cuando se guarda el enfoque, no se guarde sobre el trabajo de otro usuario).

También consulte

Creación de un enfoque a partir de datos de una base de datos

Creación de un enfoque de datos en un archivo de texto

Inicio de Portrait Miner

Tema principal: Cómo trabajar con archivos planos, tablas de bases de datos y enfoques


Para ordenar un enfoque

Puede ordenar los registros de un enfoque de acuerdo a los valores en hasta tres campos.
Para ordenar un enfoque:
  • En Portrait Miner, haga clic con el botón secundario del mouse en el enfoque que desea ordenar y seleccione Transformar>Ordenar.

En el cuadro de diálogo Ordenar enfoque, seleccione hasta tres campos clave para determinar el orden el enfoque ordenado. Además, puede cambiar la ubicación del nuevo enfoque o seleccionar sobrescribir un enfoque de salida creado anteriormente.

Nota:
  • Si elige más de un campo, la clave de orden primaria es el campo seleccionado que aparece primero en el enfoque y la clave de orden secundaria es el campo seleccionado que aparece segundo. (Si elige tres campos, el otro campo es la clave de orden terciaria).
  • Esta interfaz de usuario es una forma de acceder a muchas de las funciones proporcionadas por el comando de creación de datos qssort de Portrait Miner.

También consulte

Acerca de los asistentes de Portrait Miner

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Tema principal: Cómo trabajar con archivos planos, tablas de bases de datos y enfoques

Para comprobar el orden de clasificación de un enfoque

En Portrait Miner, haga clic con el botón secundario del mouse en el enfoque cuyo orden desea comprobar y seleccione Transformar>Comprobar orden de clasificación.

En el cuadro de diálogo Comprobar orden de clasificación, seleccione los campos clave; Portrait Miner comprobará si el enfoque está ordenado conforme a estos campos.


Para convertir un enfoque orientado en la transacción a un enfoque orientado en el cliente

Para el análisis de datos del cliente, es necesario datos orientados al cliente. Si tiene un enfoque orientado a la transacción, es decir, un enfoque en el que cada registro representa una transacción del cliente, puede calcular las estadísticas agregadas por cliente para crear campos en un nuevo enfoque orientado al cliente. Puede utilizar el nuevo enfoque para el análisis directo o primero únalo [consulte Acerca de la combinación de enfoques] a otro enfoque orientado al cliente.
Para convertir un enfoque:
  • En Portrait Miner, haga clic con el botón secundario del mouse en el enfoque orientado a la transacción y seleccione Transformar>Agregar registros.

En el cuadro de diálogo Agregar registros, seleccione el archivo que incluye las definiciones de campos y los campos clave que identificar en forma única a un cliente. También puede cambiar la ubicación del nuevo enfoque o seleccionar que se sobrescriba un enfoque de salida creado anteriormente.

Nota:
  • Esta interfaz de usuario es una forma de acceder a muchas de las funciones proporcionadas por el comando de creación de datos qsmeasure de Portrait Miner.
  • Para llevar un seguimiento de los cambios de estado en un flujo de transacciones, debe utilizar el comando de creación de datos qstrack relacionado de Portrait Miner.

También consulte

Acerca de los asistentes de Portrait Miner

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Visualización y edición de archivos de texto en Portrait Miner

Tema principal: Cómo trabajar con archivos planos, tablas de bases de datos y enfoques


Creación de un enfoque de datos en un archivo de texto

Para utilizar Portrait Miner para analizar un conjunto de datos en la forma de un archivo de texto, primero es necesario crear un enfoque desde el archivo de datos.
Para crear un enfoque:
  • En Portrait Miner, haga doble clic en el archivo, o haga clic con el botón secundario del mouse en el archivo y seleccione Abrir.
Aparecerán dos ventanas:
  • La ventana Información de formato de archivo plano muestra el intento inicial de Decision Studio hacer coherentes los datos, y destaca los problemas encontrados.

    Puede cerrar esta ventana en cualquier momento.

  • La otra ventana es el asistente Nuevo enfoque, que muestra inicialmente el paso 1 de un proceso de importación de cinco pasos:

    Puede moverse entre los pasos utilizando los botones Siguiente y Atrás. En cualquier etapa, puede hacer clic en Finish para aceptar las opciones realizadas hasta el momento y crear un nuevo enfoque a partir de su conjunto de datos.

    Antes de hacer clic en Finalizar, puede elegir dónde guardar su enfoque. Para ello, haga clic en el botón Explorar en el panel Guardar enfoque como y desplácese a [consulte Exploración para abrir o guardar un archivo o tabla de base de datos] para seleccionar una ubicación.

    En cada paso, el asistente Nuevo enfoque muestra la interpretación actual de Decision Studio de los nombres y tipos de campos en el archivo plano, junto con una muestra pequeña de los datos visualizados con esta interpretación.

Paso 1: Seleccione el formato delimitado o de ancho fijo En el panel Elegir formato, seleccione delimitado si los valores del campo están separados por comas, barras verticales o algún otro delimitador; seleccione Ancho fijo si los valores de campo comienzan y finalizan en las mismas posiciones de caracteres fijos en cada línea del archivo.

Paso 2: Establecer detalles de formato de archivo plano El panel Opciones de formato muestra un resumen de los detalles de formato actualmente establecidos.

Si Decision Studio ha interpretado el formato de archivo plano incorrectamente (por ejemplo, si ha seleccionado el separador de campo equivocado), haga clic en Configurar formato en el panel Opciones de formato para abrir la ventana Configurar formato de archivo plano (junto con una ventana de vista previa Datos sin procesar):

La versión que se muestra a la izquierda es para datos de campos delimitados; la versión a la derecha es para campos de ancho fijo.

Cuando selecciona campos de ancho fijo y continúa del paso 1 al paso 2, aparecerán automáticamente las ventanas Configurar formato de archivo plano y Datos sin procesar).

Si la primera fila de su archivo incluye nombres de campos en lugar de datos, marque la opción Encabezados de columna.

Los parámetros Separador de campo, Leer nulo como, Leer fechas como, Leer marcador de fecha como y Leer cadenas como le permiten especificar aspectos detallados del formato de archivo plano, con opciones comunes disponibles en los menús desplegables. Configure Separador de campo en "nada" para un archivo plano con campos de ancho fijo.

Para campos de ancho fijo, utilice la tabla para especificar los nombres de campos y sus posiciones inicial y de finalización. Puede utilizar la ventana Datos sin procesar como guía para esto: la "regla" en la parte superior muestra las posiciones de caracteres, y a medida que mueve el puntero del mouse por los datos de la muestra, pase por encima del texto para conocer la posición del carácter actualmente debajo del puntero.

Paso 3: Configurar los detalles de formato del campo La tabla de detalles de campos se expande para incluir tres filas editables (con fondos blancos):

Las primeras dos filas incluyen el nombre y tipo actuales de cada campo. Para un campo de cadena, la tercera fila incluye su longitud (máxima) de caracteres. Para un campo de fecha, la tercera fila incluye el formato de fecha.

Puede escribir un nuevo nombre de campo, longitud de cadena o formato de fecha personalizado [consulte Formatos de fechas personalizados] directamente.

Si hace clic en el tipo de un campo, aparecerá un menú que le muestra los cuatro tipos de datos disponibles [consulte Tipos de datos]. Para campos de fechas, está disponible un menú de los tres formatos de fecha estándar [consulte Formatos de fecha estándar].

Paso 4: Guardar detalles de formato Si necesitará volver a usar sus parámetros de formato más adelante, puede crear un archivo de descripción de datos planos (FDD) haciendo clic en Exportar formato y seleccionando una ubicación.

Paso 5: Seleccionar campos para importar Por defecto, Decision Studio importa todos los campos en un archivo plano. Si no son necesarios todos los campos, haga clic en Seleccionar campos en el panel Seleccionar campos. El cuadro de diálogo Seleccionar campos aparece, y muestra todos los campos de una fuente de datos externa inicialmente en el panel Incluir:

Utilice los botones de flechas entre los paneles Excluir e Incluir para seleccionar los campos de ese archivo plano que desea incluir en su enfoque.

Los botones [image] y [image] mueven campos resaltados, mientras que los botones [image] y [image] mueven todos los campos de un panel al otro.

Use los botones [image] y [image] a la derecha de la ventana para reorganizar campos resaltados en el panel Incluir.

Nota:
  • Puede hacer clic en Mostrar datos del asistente Nuevo enfoque para ver los datos como que aparecen en el archivo. Probablemente le resulte útil hacer esto si Decision Studio no puede determinar el formato del archivo.
  • Como ayuda durante la configuración de los detalles del formato del archivo para un archivo plano con campos de ancho fijo, puede copiar y pegar o arrastrar una descripción externa de los datos a la tabla en el cuadro de diálogo Configurar formato de archivo plano.

    La descripción puede estar en la forma de una hoja de cálculo de Excel o texto plano con dos o tres columnas de valores separados por tabulaciones. La primera columna de datos, que es opcional, incluye los nombres de campos; las dos siguientes (o sólo dos) columnas incluyen posiciones inicial y de finalización para los campos.

  • Decision Studio basa su interpretación inicial de un archivo plano en un subconjunto de los registros. Para cambiar el número de registros que Decision Studio utiliza para esto, cambie los ajustes de la preferencia de tamaño de muestra de formato de datos; para cambiar la sensibilidad de Decision Studio ante datos con formato erróneo, cambie la configuración de la preferencia de porcentaje de corte en bruto.

    Si Decision Studio necesita más información para interpretar el archivo plano correctamente, lee un subconjunto más amplio de registros. Para cambiar el número de registros que Decision Studio utiliza en este caso, cambie los ajustes de la preferencia de tamaño de muestra de los datos.

  • Cuando Decision Studio haya finalizado la importación del archivo plano, creará un archivo de registro correspondiente. Debe analizar este archivo si Decision Studio informa errores o advertencias durante el proceso de importación.

    En Portrait Miner, puede hacer clic en [image] para ir al directorio que contiene los archivos de registro%, el subdirectorio shared/logs (UNIX) o shared\logs (Windows) del directorio de instalación de Portrait Miner.

    El archivo de registro requerido es el archivo de registro más reciente cuyo nombre comienza con el nombre del archivo plano original (Puede ordenar los archivos de registro en orden fecha/hora si hace clic en el encabezado de columna Modificado).

  • Decision Studio cambia cualquier nombre de campo no válido por nombres de campo válidos.
  • Si un archivo plano tiene un archivo de descripción de datos planos (FDD) asociado, puede utilizarlo para configurar el formato de archivo inicial: haga clic en Importar formato en el paso 1 del proceso de importación. (Luego puede realizar cambios en el formato de la forma habitual).

    Como opción, puede iniciar el asistente Nuevo enfoque si hace doble clic en el archivo FDD de Portrait Miner.

  • Un valor entero es calificado como "pequeño" en el asistente Nuevo enfoque si se especifica como smallinteger [consulte Tipos de datos] en un archivo FDD. Un campo smallinteger ocupa menos espacio en disco que un campo entero normal, pero sólo puede abarcar un rango limitado de valores.
  • Esta interfaz de usuario es una forma de acceder a muchas de las funciones proporcionados por los comandos de creación de datos qsgenfdd y qsimportflat de Portrait Miner.

También consulte

Creación de un enfoque a partir de datos de una base de datos

líneas vacías

errores máximos de extracción

advertencias máximas de extracción

ignorar advertencias de extracción

permitir errores de formato de datos

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Tema principal: Cómo trabajar con archivos planos, tablas de bases de datos y enfoques


Creación de un enfoque a partir de datos de una base de datos

Para utilizar Portrait Miner para analizar un conjunto de datos con la forma de una tabla de base de datos (o alguna combinación de tablas y vistas), primero es necesario crear un enfoque a partir de los datos de la base de datos.
Tema principal: Cómo trabajar con archivos planos, tablas de bases de datos y enfoques

Importación de datos de una tabla de la base de datos

Para importar datos:
  • En Portrait Miner, desplácese hasta la ficha Base de datos y abra una conexión de la base de datos. Para obtener más información, consulte Para configurar una conexión de base de datos.
  • Haga doble clic en la tabla de base de datos o haga clic con el botón secundario y seleccione Abrir.

Aparecerá el cuadro de diálogo Nuevo enfoque:

Este cuadro de diálogo Nuevo enfoque muestra una vista previa de los datos, incluidos los nombres y tipos de campos.
  • En el panel Guardar enfoque como, haga clic en Explorar y explore [consulte Exploración para abrir o guardar un archivo o tabla de base de datos] para seleccionar una ubicación para el enfoque.
  • Haga clic en OK para crear el nuevo enfoque.

Si no desea importar todos los campos de la tabla, haga clic en Seleccionar campos. Aparecerá el cuadro de diálogo Seleccionar campos:

Todos los campos de fuentes de datos externas que puedan importarse se muestran inicialmente en el panel Incluir.
  • Utilice los botones de flechas para seleccionar los campos de la tabla que desea incluir en su enfoque.

    Los botones [image] y [image] mueven campos resaltados, mientras que los botones [image] y [image] mueven todos los campos de un panel al otro.

    Use los botones [image] y [image] a la derecha de la ventana para reorganizar campos resaltados en el panel Incluir.

  • Cuando haya seleccionado los campos necesario, haga clic en OK para regresar al cuadro de diálogo Nuevo enfoque.
Nota:
  • No puede importar una columna de esta forma si su nombre no es un identificador válido [consulte Expresiones básicas] en FDL.
  • Los campos de números reales con una precisión mayor a 15 dígitos en una base de datos se tratan por defecto como campos de cadena en Portrait Miner. Si cambia la preferencia de preservar los tipos numéricos al importar, puede forzarlos a que se traten como campos reales (con precisión truncada).

También consulte

Creación de un enfoque de datos en un archivo de texto

Para configurar una conexión de base de datos

Importación de datos mediante consulta de una base de datos

Puede crear un enfoque a partir de una combinación de tablas y vistas en una base de datos si especifica una consulta SQL que seleccione los datos necesarios.
  • En Portrait Miner, haga doble clic en un archivo SQL que incluya la consulta que desea utilizar o haga clic con el botón secundario del mouse en el archivo y seleccione Abrir.

En el cuadro de diálogo Importar desde la consulta, seleccione una ubicación para el enfoque que desea crear; ingrese o modifique la consulta SQL de ser necesario; y seleccione una conexión de base de datos [consulte Para configurar una conexión de base de datos].

Nota:
  • Si abre el cuadro de diálogo Importar desde la consulta mediante el uso de un archivo SQL, Portrait Miner deriva un nombre de enfoque del nombre de archivo y utiliza el contenido del archivo como la consulta SQL inicial. No obstante, una vez abierto el cuadro de diálogo, el archivo en sí ya no es relevante: es la consulta en el cuadro de diálogo, no la consulta en el archivo, la que se ejecuta realmente.
  • SQL se pasa como está a la base de datos como una única instrucción; no es necesario un punto y coma de terminación (y puede ser sintaxis no válida para algunos sistemas de base de datos).
  • Esta interfaz de usuario es una forma de acceder a muchas de las funciones proporcionadas por el comando de creación de datos qsimportdb de Portrait Miner.

También consulte

Acerca de los asistentes de Portrait Miner

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos


Creación de un enfoque desde un SAS o desde un conjunto de datos de terceros

Cuando se usa Portrait Miner para analizar un conjunto de datos de terceros se debe crear un enfoque a partir del conjunto de datos. Portrait Miner puede importar datos desde varios conjuntos de datos de terceros, incluyendo aquellos creados por SAS, SPSS y Excel. (Consulte http://support.quadstone.com/info/requirements/ para obtener una lista completa de los formatos compatibles).
Tema principal: Cómo trabajar con archivos planos, tablas de bases de datos y enfoques

Creación de un enfoque a partir de un conjunto de datos SAS

  • En Portrait Miner, haga doble clic en el archivo del conjunto de datos que desea importar o clic con el botón derecho y seleccione Abrir.

En el cuadro de diálogo Importar enfoque se pueden elegir los campos que se desean importar (por defecto, se importan todos los campos) y elegir si se desea importar metadatos de etiqueta de campo y valor en el enfoque creado. También se puede cambiar la ubicación del nuevo enfoque o elegir sobrescribir el enfoque de salida.

Nota:
  • Los metadatos de SAS se leen desde un archivo de catálogo SAS format.sas7bcat que debe estar presente en la misma carpeta que el conjunto de datos SAS de origen.
  • Esta interfaz de usuario es el modo de acceder a la mayor parte de la funcionalidad provista por el comando de creación de datos qsimportstat de Portrait Miner .
  • Se puede auditar [consulte Creación de un perfil y auditoría de un enfoque] un conjunto de datos de terceros sin crear primero un enfoque: simplemente haga clic con el botón derecho en el conjunto de datos en Portrait Miner y seleccione Auditar.

Creación de un enfoque desde Excel o desde otro conjunto de datos de terceros

  • En Portrait Miner, haga doble clic en el archivo del conjunto de datos que desea importar o clic con el botón derecho y seleccione Abrir.

En el cuadro de diálogo Importar enfoque se pueden elegir los campos que se desean importar (por defecto, se importan todos los campos). También se puede cambiar la ubicación del nuevo enfoque o elegir sobrescribir el enfoque de salida.

Nota:
  • Esta interfaz de usuario es el modo de acceder a la mayor parte de la funcionalidad provista por el comando de creación de datos qsimportstat de Portrait Miner .
  • Se puede auditar [consulte Creación de un perfil y auditoría de un enfoque] un conjunto de datos de terceros sin crear primero un enfoque: simplemente haga clic con el botón derecho en el conjunto de datos en Portrait Miner y seleccione Auditar.
  • Se puede abrir un libro de Excel en Excel haciendo clic con el botón derecho en él en Portrait Miner y seleccionando Enviar a Excel.

También consulte

Acerca de los asistentes de Portrait Miner

Creación de un enfoque a partir de datos de una base de datos

Creación de un enfoque de datos en un archivo de texto

Exportación de registros a un archivo SAS o a otro conjunto de datos de terceros.


Exportación de registros a un archivo de datos, tabla de base de datos o enfoque

Con Portrait Miner, se pueden exportar registros desde un enfoque a un archivo plano, una tabla de base de datos u otro enfoque de Decision Studio, o a un archivo plano [consulte Para exportar registros a un archivo plano con Portrait Miner], otro enfoque [consulte Exportación de registros a un enfoque con Portrait Miner], un conjunto de datos SAS u otro conjunto de datos de terceros [consulte Exportación de registros a un archivo SAS o a otro conjunto de datos de terceros.].
Tema principal: Cómo trabajar con archivos planos, tablas de bases de datos y enfoques

Exportación de registros desde Decision Studio a un archivo plano, una tabla de base de datos o un enfoque

Se pueden exportar registros desde un enfoque o desde segmentos resaltados en un visor gráfico hacia un archivo plano, tabla de base de datos u otro enfoque.
  1. Realice uno de los procedimientos siguientes:
    • En la ventana de Decision Studio elija Enfoque>Exportar datos.
    • En Visor de Perfil, Visor de Distribución Cruzada, Visor de Mapa o el Creador de árboles de decisión, resalte los segmentos [consulte Resaltado de segmentos en una presentación gráfica] que desee exportar y luego seleccione Segmentos o haga clic en [image] en la barra de herramientas.

    Aparece el cuadro de diálogo de Exportar registros :

  2. Haga clic en el botón Explorar .
  3. Desplácese [consulte Exploración para abrir o guardar un archivo o tabla de base de datos] hasta la ubicación requerida y elija un nombre y un tipo para su conjunto de datos exportado.
  4. Si desea elegir un subconjunto de los campos en el enfoque, haga clic en el botón Seleccionar .

    Aparece un cuadro de diálogo de selección de campos, con todos los campos inicialmente en el panel Selectados (a menos que se haya interpretado que algunos de los campos del enfoque son campos de exportación [consulte Para establecer o borrar una interpretación categórica, geográfica, de candidato para análisis, de exportación o de clave], en cuyo caso, esos campos están seleccionados):

    Use las flechas entre los paneles No seleccionados y Seleccionados para elegir los campos que deben aparecer en el conjunto de datos exportado.

    Los botones [image] y [image] mueven campos resaltados, mientras que los botones [image] y [image] mueven todos los campos de un panel al otro.

    Use los botones [image] y [image] a la derecha de la ventana para reorganizar los campos resaltados en el panel Seleccionado.

  5. Si se está creando un archivo plano, también se puede hacer clic en Formato para controlar el formato de la exportación [consulte Cómo controlar el formato de exportación de un archivo plano].
  6. Haga clic en OK para exportar los datos.

Para exportar registros a un archivo plano con Portrait Miner

Para exportar registros:
  • En Portrait Miner, haga clic con el botón derecho en el enfoque que desea exportar y seleccione Exportar>como texto.

En el cuadro de diálogo de Exportar texto se pueden elegir los campos que se desea exportar del enfoque y modificar el nombre y la ubicación del archivo de salida. Haga clic en Siguiente para que aparezca la tabulación Formato y elija las opciones de exportación, similares a las que se encuentran en el cuadro de diálogo Exportar opciones [consulte Cómo controlar el formato de exportación de un archivo plano], para el archivo de salida.

Nota:
  • Se puede elegir qué campos exportar seleccionando los nombres de los campos o eligiendo una o más etiquetas [consulte Cómo trabajar con grupos de campos].
  • Esta interfaz de usuario es el modo de acceder a la mayor parte de la funcionalidad provista por el comando de creación de datos qsexportflat de Portrait Miner.

También consulte

Acerca de los asistentes de Portrait Miner

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Cómo controlar el formato de exportación de un archivo plano

En Decision Studio, si se hace clic en Formato en el cuadro de diálogo Exportar registros, cuando se exportan datos a un archivo plano, aparece el cuadro de diálogo Opciones de exportación :

Aquí se pueden especificar un separador de campos, una cadena que se puede usar en lugar del valor nulo [consulte El valor null] , el formato que se debe usar para los valores de datos y si usar comillas simples o dobles, o no usar comillas, con valores de cadenas. Si se elige usar comillas con los valores de cadenas, se tiene la opción de usarlas para todos los valores (en lugar de sólo usarlas cuando el contenido del valor lo hace necesario).

Si se elige un archivo de texto como archivo de exportación, se tiene la opción de generar un archivo de descripción de datos planos (FDD) para que lo acompañe. Si se elige un archivo FDD como archivo de exportación (en cuyo caso Portrait Miner crea automáticamente uno o más archivos de datos asociados), la opción de generar un archivo FDD ya esta marcada.

Se pueden incluir nombres de campos arriba de los archivos de datos marcando la opción Encabezados de columna.

Se pueden exportar datos en un formato de ancho fijo marcando la opción Ancho fijo de columna. Los anchos de las columnas en este formato dependen del tipo y tamaño de cada campo.

Exportación de registros a un archivo SAS o a otro conjunto de datos de terceros.

Portrait Miner puede exportar datos en distintos formatos estadísticos de terceros, incluyendo los de SAS, SPSS y Excel.

En Portrait Miner, haga clic con el botón derecho en el enfoque que desea exportar y seleccione Exportar>para otro programa.

En el diálogo Exportar para otro programa se puede elegir qué campos exportar, a qué programa exportar y cambiar la ubicación del archivo de salida.

Nota:
  • Se puede elegir qué campos exportar seleccionando los nombres de los campos o eligiendo una o más etiquetas [consulte Cómo trabajar con grupos de campos].
  • Si no se especifica qué campos exportar, Portrait Miner exporta todos los campos en el enfoque.
  • Esta interfaz de usuario es el modo de acceder a la mayor parte de la funcionalidad provista por el comando de creación de datos qsexportstat de Portrait Miner .

También consulte

Acerca de los asistentes de Portrait Miner

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Exportación de registros a un enfoque con Portrait Miner

Se puede exportar un subconjunto de los campos o registros desde un enfoque existente a un nuevo enfoque.

En Portrait Miner, haga clic con el botón derecho en el enfoque que desea exportar y seleccione Exportar>como enfoque. En el cuadro de diálogo Exportar como enfoque se puede elegir qué campos exportar y dónde guardar el enfoque exportado. También puede seleccionar un subconjunto de registros en el enfoque mediante una expresión FDL [consulte Expressions (Expresiones)].

Nota:
  • Se puede elegir qué campos exportar seleccionando los nombres de los campos o eligiendo una o más etiquetas [consulte Cómo trabajar con grupos de campos].
  • Si no se especifica qué campos exportar, Portrait Miner exporta todos los campos en el enfoque.
  • Esta interfaz de usuario es el modo de acceder a la mayor parte de la funcionalidad provista por el comando de creación de datos qsimportfocus de Portrait Miner .

También consulte

Acerca de los asistentes de Portrait Miner

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos


Acerca de la combinación de enfoques

Portrait Miner ofrece dos formas de combinar los campos de múltiples enfoques para crear uno nuevo, el primero ("focus join") es una variante de un left join. También puede utilizar focus join en Portrait Miner [consulte Para unir campos de un enfoque a otro enfoque mediante el uso de Portrait Miner] o a través del comando de creación de datos qsjoin de Portrait Miner.

El segundo método utiliza Decision Studio para importar campos desde un enfoque en una variante de un left join de dos tablas.

También puede fusionar los registros de múltiples enfoques, en Portrait Miner [consulte Combinación de registros de dos enfoques] o a través del comando de creación de datos qsmerge de Portrait Miner.

También consulte

dblookup

Combinación de registros de dos enfoques

Tema principal: Cómo trabajar con archivos planos, tablas de bases de datos y enfoques


Para unir campos de un enfoque a otro enfoque mediante el uso de Portrait Miner

Dados dos enfoques que comparten campos clave del mismo nombre y tipo, puede unir los campos seleccionados de un enfoque con el otro para crear uno nuevo, siempre y cuando ambos enfoques estén ordenados [consulte Para ordenar un enfoque] por los campos clave (de acuerdo al orden de comparación estándar de Portrait Miner).
Para unir campos de un enfoque con otro:
  • En Portrait Miner, haga clic con el botón secundario del mouse en el enfoque inicial y seleccione Combinar>Unir campos.

En el cuadro de diálogo Unir campos, puede seleccionar el enfoque secundario desde el cual se agregarán los campos y hasta tres campos clave utilizados para unir los campos seleccionados con el enfoque primario. También puede cambiar la ubicación del nuevo enfoque, o bien, en lugar de crear uno nuevo, seleccionar sobrescribir un enfoque de salida creado anteriormente.

Nota:
  • La operación de unión es fundamentalmente un left join (donde su enfoque inicial es la tabla a la izquierda). No obstante, si hay un cliente con más de un registro en el enfoque inicial, Portrait Miner relaciona los registros de ese cliente con registros sucesivos para el mismo cliente en el otro enfoque. El número de registros en el enfoque nuevo siempre es el mismo que el número de registros en el enfoque inicial.
  • Los campos clave en los dos enfoques deben ser campos de cadena, campos de fecha o campos numéricos.
  • Para elegir los campos que desee agregar, seleccione los nombres de campos o una o más etiquetas [consulte Cómo trabajar con grupos de campos].
  • Esta interfaz de usuario es una forma de acceder a muchas de las funciones proporcionadas por el comando de creación de datos qsjoin de Portrait Miner.

También consulte

Acerca de los asistentes de Portrait Miner

Acerca de la combinación de enfoques

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Tema principal: Cómo trabajar con archivos planos, tablas de bases de datos y enfoques


Para unir campos de un enfoque a otro enfoque con Decision Studio

Si dos enfoques comparten campos clave del mismo nombre y tipo se pueden unir los enfoques seleccionados de un enfoque a los de otro para crear un nuevo enfoque. Para hacer esto es necesario asegurarse de que ambos enfoques estén ordenados según los campos clave, de acuerdo con el orden de comparación estándar de Portrait Miner.
  1. Abra el primer enfoque en Decision Studio y seleccione Enfoque>Importar campos.
  2. Desplácese [consulte Exploración para abrir o guardar un archivo o tabla de base de datos] hasta el segundo enfoque y haga clic en Importar.

    Aparece el cuadro de diálogo Importar campos :

  3. En el panel Seleccionar unir campo clave elija los campos clave correspondientes para el primer y el segundo enfoque.
  4. Haga clic en Seleccionar campos en el panel Seleccionar campos para seleccionar los campos que desea incluir del segundo enfoque. Al menos, excluya el campo clave externo para la unión.

    Aparece el cuadro de diálogo Seleccionar campos con todos los campos del segundo enfoque inicialmente en el panel Incluir:

    Use las flechas entre los paneles Excluir e Incluir para elegir los campos que desea unir.

    Los botones [image] y [image] mueven campos resaltados, mientras que los botones [image] y [image] mueven todos los campos de un panel al otro.

    Use los botones [image] y [image] a la derecha de la ventana para reorganizar campos resaltados en el panel Incluir.

  5. De regreso en el cuadro de diálogo Importar campos haga clic en OK.
Nota:
  • La operación de unión es esencialmente una unión de izquierda (donde el primer enfoque es la tabla de la izquierda). Sin embargo, si hay un cliente con más de un registro en el segundo enfoque, Decision Studio sólo considera el primer registro para ese cliente. Por lo tanto, cuando se unen campos a un enfoque con Decision Studio, el número de registros en el enfoque siempre permanece igual.
  • Decision Studio excluye automáticamente cualquier campo en el segundo enfoque que tenga el mismo nombre que un campo en el primer enfoque.
  • Los campos clave en los dos enfoques deben ser campos de cadena, campos de fecha o campos numéricos.

También consulte

Acerca de la combinación de enfoques

Para unir campos de un enfoque a otro enfoque mediante el uso de Portrait Miner

Tema principal: Cómo trabajar con archivos planos, tablas de bases de datos y enfoques


Combinación de registros de dos enfoques

Dados dos enfoques con campos de nombres y tipos similares y registros ordenados [consulte Para ordenar un enfoque] por los mismos campos clave (de acuerdo al orden de comparación estándar de Portrait Miner), puede combinar los registros en el enfoque para crear uno nuevo que incluya los registros de ambos enfoques. El nuevo enfoque se ordenará de la misma forma que el enfoque original.

En Portrait Miner, haga clic con el botón secundario del mouse en el enfoque primario y seleccione Combinar>Unir campos.

En el cuadro de diálogo Combinar registros, seleccione el enfoque secundario y especifique los campos clave. También puede seleccionar una ubicación para el enfoque de salida.

Nota:
  • Por defecto, un registro del enfoque secundario que tiene las mismas claves que un registro el en enfoque primario se descarta. Puede cambiar este comportamiento si marca el cuadro correspondiente en el cuadro de diálogo.
  • Para combinar dos enfoques, los campos que se combinarán deben incluir tipos de datos compatibles.
  • Esta interfaz de usuario es una forma de acceder a muchas de las funciones proporcionadas por el comando de creación de datos qsmerge de Portrait Miner.

También consulte

Acerca de los asistentes de Portrait Miner

Acerca de la combinación de enfoques

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Tema principal: Cómo trabajar con archivos planos, tablas de bases de datos y enfoques


Para configurar una conexión de base de datos

Para poder conectarse con una base de datos, primero necesita configurar una conexión de base de datos.
  1. En Portrait Miner, debajo de la ficha Bases de datos, haga clic en Nueva conexión.

    Aparece el cuadro de diálogo Editar conexión de base de datos.

  2. Ingrese el DSN (nombre de fuente de datos [data source name]) para la base de datos.

    Pregunte a su administrador de sistema si conoce de qué se trata esto.

  3. Ingrese el nombre de usuario y la contraseña que utiliza para conectarse con la base de datos.
  4. Haga clic en Aceptar.

    Aparece una nueva conexión de base de datos en la lista de bases de datos disponibles en Portrait Miner.

Nota:
  • Portrait Miner almacena sus conexiones de bases de datos en el disco en forma cifrada. Una vez que haya configurado una conexión de base de datos, no es necesario que vuelva a ingresar su nombre de usuario o contraseña para la base de datos, excepto que los modifique. Si necesita corregir los detalles de su conexión, resalte la conexión en el panel Bases de datos disponibles de la ficha Bases de datos y haga clic en Editar conexión.
  • El administrador del sistema posiblemente haya configurado una conexión de base de datos "parcial" para usted, que comprende solo un DSN. Antes de que pueda conectarse con la base de datos, es necesario que complete la conexión de base de datos: resalte la conexión de base de datos parcial y haga clic en Editar conexión para ingresar su nombre de usuario y contraseña.
  • Esta interfaz de usuario es una manera de acceder a muchas de las funciones que ofrece el comando de creación de datos qsdbaccess de Portrait Miner.

También consulte

Cómo Portrait Miner importa los tipos de base de datos

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Tema principal: Cómo trabajar con archivos planos, tablas de bases de datos y enfoques


Cómo Portrait Miner importa los tipos de base de datos

Tema principal: Cómo trabajar con archivos planos, tablas de bases de datos y enfoques

Importación a Portrait Miner desde una base de datos

Portrait Miner asigna los siguientes tipos de base de datos a sus tipos de datos según el tamaño del tipo de base de datos y a la configuración de preferencias de las Bases de datos.
Tipo de base de datos | Scale (Escala) | Precision (Precisión) | representar enteros largos como cadenas | preservar los tipos numéricos al importar | Tipo de campo de Portrait Miner
char, char2, varchar, varchar2, nchar, nchar2, nvarchar, nvarchar2 |  |  |  |  | cadena
date, time, timestamp, datetime, smalldatetime |  |  |  |  | fecha
int, integer, tinyint, smallint, byteint, bit |  |  |  |  | entero
bigint |  |  | false false true | true false | real cadena cadena
decimal, dec, numeric, number | < 0 | 15 > 15 > 15 |  | true false | real real cadena
decimal, dec, numeric, number | 0 | 0 10 > 10 [image] 15 > 15 > 15 > 10 | false false false true | true false | real entero real real cadena cadena
float, double, real |  |  |  |  | real
decimal, dec, numeric, number | > 0 | 15 > 15 > 15 |  | true false | real real cadena
money |  |  |  | true false | real cadena
smallmoney |  |  |  |  | real
Nota:
  • En las filas marcadas con [image], puede haber pérdida de precisión.
  • En las filas marcadas con [image], los valores que sean demasiado largos para almacenar como enteros se convertirán a Null.

También consulte

representar enteros largos como cadenas

preservar los tipos numéricos al importar

Exportación de Portrait Miner a una base de datos

Los tipos de base de datos que Portrait Miner exporta dependen de la base de datos de destino y el controlador ODBC. Portrait Miner sugiere un tipo adecuado para la base de datos que especifique, si bien el controlador ODBC interpreta esa sugerencia en uno de los tipos de esa base de datos.

También consulte

Para configurar una conexión de base de datos


Uso de Data Build Manager para importar, procesar y exportar datos

Data Build Manager es una aplicación de Portrait Miner que permite la preparación de datos y la implementación de modelos.

Para crear un enfoque o implementar un modelo, generalmente se usa una secuencia de comandos de creación de datos [consulte la sección Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos] y otras operaciones. Realizar esto de forma manual lleva tiempo y es muy fácil cometer errores en el proceso. Puede ser preferible ejecutar un proceso regular de creación de datos o de implementación sin supervisión, quizás durante la noche. Si ocurre un error (como quedarse sin espacio en el disco), es conveniente solucionar el problema y seguir con el proceso en donde quedó, en lugar de comenzar de nuevo desde el principio. De la misma manera, si las operaciones necesarias para las creaciones exitosas se superponen, podrá ahorrar tiempo de procesamiento realizando las operaciones solo una vez. Pero es difícil realizar un seguimiento de las dependencias entre las operaciones, y es fácil olvidarse cuáles operaciones ya han sido realizadas.

Data Build Manager usa un archivo especial llamado "plan de preparación de datos" que describe como crear un conjunto de datos de un análisis o cómo implementar un modelo. El plan de preparación de datos contiene una cantidad de "objetivos" con dependencias entre ellos y las secuencias de operaciones que se necesitan para crear los objetivos.

Para abrir un plan de preparación de datos (a .qsb archivo):
  • En Portrait Miner, haga doble clic en el archivo, o haga clic con el botón secundario del mouse en el archivo y seleccione Abrir.

Puede examinar los detalles del plan de preparación de datos haciendo clic en los elementos en el panel Plan de preparación de datos y mirando sus descripciones a la derecha del panel.

La jerarquía (o "árbol") de elementos en el panel Plan de preparación de datos es igual a la organización de archivos en Portrait Miner o Windows Explorer, y puede expandir o contraer las partes de la misma manera. Use Opciones>Expandir árbol (u Opciones>Contraer árbol) para mostrar la jerarquía más expandida (o contraída, respectivamente).

En la parte superior de la jerarquía hay un elemento que representa el mismo plan de preparación de datos. Otros elementos de particular interés son los objetivos (marcados con [image] o de forma similar) y los parámetros (marcados con [image]).

Para asignar un valor a un parámetro, resalte el parámetro en el panel Plan de preparación de datos y edite el valor en el panel Parámetro a la derecha.

Una vez configurados los parámetros, ejecute el plan de preparación de datos haciendo clic en Crear. Aparecerá una ventana de progreso. Mientras se ejecuta el proceso, puede hacer clic en Detener para detener la ejecución del plan de preparación de datos. Una vez finalizado el proceso, haga clic en Terminado para cerrar la ventana de progreso.

Nota:
  • El plan de preparación de datos utiliza un formato de archivo basado en XML. Para obtener más información sobre Data Build Manager y los formatos de los planes de preparación de datos, consulte Uso de Data Build Manager.
  • Data Build Manager es una forma de acceder a la funcionalidad que ofrece el comando de creación de datos qsbuild de Portrait Miner.

También consulte

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

XML en Portrait Miner

Tema principal: Cómo trabajar con archivos planos, tablas de bases de datos y enfoques


Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Además de aplicaciones como Portrait Miner y Decision Studio, Portrait Miner incluye un conjunto integral de utilidades de línea de comandos llamados comandos de creación de datos de Portrait Miner. Puede utilizar los comandos de creación de datos para diversas tareas:
  • Importación/Exportación de datos entre enfoques, archivos planos y tablas de bases de datos
  • Procesamiento de datos en enfoques (ordenación, derivación, medidas, etc.)
  • Unión de enfoques
  • Administración de archivos de enfoque (copiar, mover, cambiar nombre y eliminar)
  • Producción de informes

Los comandos de construcción de datos son particularmente útiles para la automatización de procesos complejos de creación de datos debido a que puede combinarlos en comandos de shell de UNIX o archivos por lotes de Windows.

Consulte comandos de creación de datos de Portrait Miner y referencias TML para obtener información detallada sobre los comandos individuales.

Nota: Para utilizar los comandos de creación de datos, debe tener acceso de línea de comandos a Portrait Miner. Pídale al administrador de su sistema que configure su ruta de comandos para que incluya el directorio que contiene los comandos.

También consulte

Uso de Data Build Manager para importar, procesar y exportar datos
Tema principal: Cómo trabajar con archivos planos, tablas de bases de datos y enfoques


Cómo trabajar con Decision Studio

  • Cómo trabajar con las herramientas de Decision Studio
  • Cómo trabajar con listas y datos tabulares en Decision Studio
  • Cómo trabajar con Decision Studio


Cómo trabajar con las herramientas de Decision Studio

  • Herramientas de Decision Studio
  • Relaciones entre herramientas
  • Para vincular y desvincular herramientas
  • Para maximizar el espacio de la pantalla para una herramienta de Decision Studio
Tema principal: Cómo trabajar con Decision Studio


Herramientas de Decision Studio

Estas herramientas de Decision Studio están disponibles para visualizar, segmentar y modelar conjuntos de datos del cliente:
Tool | Objetivo
Table Viewer
  • Ver sus enfoques a nivel de registros individuales del cliente
  • Derivar campos con FDL
Binning Editor | Agrupar registros del cliente en bandas de valores o categorías en un campo
Crosstab Viewer | Ver datos de resumen en forma de tabla
Crossdistribution Viewer | Ver datos de resumen como gráfico de distribución cruzada de una a tres variables
Profile Viewer | Ver datos de resumen en un conjunto de segmentaciones de una variable
Map Viewer | Ver datos de resumen en un mapa geográfico u otro definido previamente
Creador de árbol de decisión | Crear segmentaciones en el árbol de decisión del conjunto de datos de su cliente
Creador de scorecards | Crear modelos de scorecard del conjunto de datos de su cliente
Creador de clusters | Crear modelos de clustering del conjunto de datos de su cliente

Para iniciar una herramienta de Decision Studio, seleccione su nombre en el menú Herramientas o bien haga clic en el botón correspondiente ubicado en la barra de herramientas.

Tema principal: Cómo trabajar con las herramientas de Decision Studio


Relaciones entre herramientas

Toda herramienta de Decision Studio [consulte la sección Herramientas de Decision Studio] necesita un origen de datos, ya sea de datos que se mostrarán o de datos sobre los cuales se basará un modelo. Normalmente, el origen de datos de una herramienta es el enfoque que se encuentra abierto actualmente, considerando toda selección de registros [consulte la sección Selección de registros de clientes] que se encuentran en su lugar.

También puede hacer que una o más herramientas sigan a otra [consulte la sección Para vincular y desvincular herramientas], de manera que cuando resalta un segmento [consulte la sección Resaltado de segmentos en una presentación gráfica] en la herramienta líder, las herramientas de seguimiento toman a ese segmento como el origen de sus datos.

Una herramienta de seguimiento también puede liderar a otra herramienta. Para ver cómo se relacionan entre sí las herramientas, puede ingresar al panel de jerarquía de herramientas en la ventana de Decision Studio, que se encuentra en la ficha 'Enfoque' en el lado izquierdo de la ventana principal. Tenga en cuenta que no es la ficha por defecto, por lo cual generalmente está oculta:

En este ejemplo, Visor de Tablas 5 y Visor de Perfil 6 utilizan el enfoque "DBUSA" como origen de datos. Visor de Distribución Cruzada 4 le sigue a Visor de Perfil 6.

Nota:
  • Cuando no hay segmentos resaltados gráficamente en una herramienta (siempre es así si la herramienta es una instancia de Visor de Tablas, Creador de scorecardso Creador de clusters), el propio origen de datos de la herramienta se utiliza como origen de datos de cualquier herramienta de seguimiento.
  • Del mismo modo en que un enfoque puede tener rangos asociados a él, lo mismo puede hacer la salida de una herramienta. Puede modificar los rangos asociados con la salida de una herramienta vinculando un Binning Editor con dicha salida [consulte la sección Para vincular y desvincular herramientas]. Pero si selecciona distintos segmentos en la herramienta (de manera que cambie la salida), Decision Studio descarta cualquier rango que haya creado.

También consulte

Para mostrar más detalles de un segmento seleccionado de un gráfico
Tema principal: Cómo trabajar con las herramientas de Decision Studio

Vista de la jerarquía de herramientas selectivamente

  • Haga clic en el símbolo [image] (contraído) o [image] (expandido) para expandir o contraer parte de la vista de jerarquía de herramientas.

Para traer al frente una ventana de herramientas

Haga doble clic en el nombre de la herramienta dentro del panel de jerarquía de herramientas, o bien haga clic con secundario del mouse en el nombre de la herramienta y seleccione Traer al frente.


Para vincular y desvincular herramientas

Tema principal: Cómo trabajar con las herramientas de Decision Studio

Para vincular una herramienta abierta con la salida de otra herramienta

En la parte superior derecha de cada herramienta de la barra de herramientas hay un menú desplegable con el nombre Líder, donde se puede seleccionar otra herramienta como origen de los datos. Alternativamente, en el panel de jerarquía de la herramienta [consulte la sección Relaciones entre herramientas] de la ventana de Decision Studio, arrastre el icono que representa la herramienta de seguimiento deseada y suéltelo en el icono que representa la herramienta líder deseada.

Para abrir una nueva herramienta que sigue a otra herramienta

En el panel de jerarquía de la herramienta [consulte la sección Relaciones entre herramientas] de la ventana de Decision Studio, haga clic para resaltar el nombre de la herramienta líder deseada.

Toda herramienta que inicie posteriormente estará vinculada a la herramienta resaltada.

Para revertir el comportamiento por defecto en el caso de las nuevas herramientas, resalte el enfoque que se encuentra en la parte superior del panel de jerarquía de la herramienta.

Nota: También puede iniciar una herramienta vinculada haciendo clic con el botón secundario del mouse en un posible líder, en el panel de jerarquía de la herramienta, y seleccionando el posible seguidor en el menú Informe detallado en.

También consulte

Para mostrar más detalles de un segmento seleccionado de un gráfico

Para romper un vínculo entre herramientas

Realice uno de los procedimientos siguientes:
  • En el menú desplegable Líder ubicado en la barra de herramientas, seleccione Ninguno.
  • En el panel de jerarquía de la herramienta [consulte la sección Relaciones entre herramientas] de la ventana de Decision Studio, arrastre el icono que representa la herramienta de seguimiento y suéltelo en el icono que representa al enfoque.
  • Vincule la herramienta de seguimiento con otra herramienta líder.
  • Cierre la herramienta líder.

    Luego, la herramienta que seguía queda vinculada con el enfoque o la herramienta que suministró el origen de los datos a la herramienta líder original.

Nota: Si arrastra el icono de una herramienta a otro lugar de la jerarquía de herramientas, toda herramienta vinculada con ella continuará siguiéndola.


Para maximizar el espacio de la pantalla para una herramienta de Decision Studio

Seleccione Ver o presione F11

Así se maximiza la ventana y se oculta la barra de herramientas junto con los demás elementos de la interfaz de usuario para aumentar el espacio disponible para visualizar el área principal de la ventana.

Repita la acción para volver a la vista original.

Tema principal: Cómo trabajar con las herramientas de Decision Studio


Cómo trabajar con listas y datos tabulares en Decision Studio

  • Ordenamiento en listas y tablas
  • Exportación de datos tabulares de Decision Studio
  • Para configurar el formato de visualización para valores numéricos y de fecha
Tema principal: Cómo trabajar con Decision Studio


Ordenamiento en listas y tablas

En la mayoría de las tablas de Decision Studio (las excepciones más notables son las vistas en Visor de Tablas y Visor de Tabulación Cruzada) se pueden reordenar la filas de distintas formas, haciendo clic con el botón derecho en el encabezado de una columna y eligiendo una opción de ordenamiento.

En forma similar, en la mayoría de las listas de Decision Studio se pueden reordenar los elementos de la lista haciendo clic con el botón derecho en cualquier lugar del panel de la lista.

En la mayoría de los casos se dispone de tres opciones para ordenar: sin ordenar (es decir, el orden por defecto), ascendente y descendente; pero pueden haber opciones adicionales de acuerdo con el tipo de datos en la lista o columna.

Nota:
  • en la mayoría de los casos, si se hace clic repetidamente (con el botón izquierdo del mouse) en el encabezado de la columna de una tabla que tiene opciones para ordenar, Decision Studio hace un ciclo por todas las opciones disponibles. Si existen muchas opciones, por lo general es más fácil hacer clic con el botón derecho y elegir del menú, pero en el caso de columnas que sólo tienen las tres opciones estándar, el orden deseado de las filas se puede hacer con dos clics.
  • En la ventana de Decision Studio la columna Interpretaciones tiene opciones para ordenar según cada uno de los tipos de interpretación posibles. Cuando se elige Ordenar por categoría, por ejemplo, Decision Studio muestra los campos de rangos categóricos antes que los otros campos.
  • La columna Etiquetas de usuario de la ventana principal no puede ordenarse.
  • El ordenar las filas de una tabla o los elementos en una lista generalmente afecta sólo la forma en que aparece la información en el contexto actual. Una excepción es cuando se reordenan categorías [consulte Para reordenar categorías] en rangos categóricos: todas las herramientas de Decision Studio que usan rangos muestran los rangos en el orden que se especifica en el Binning Editor.

También consulte

Para ordenar un enfoque
Tema principal: Cómo trabajar con listas y datos tabulares en Decision Studio


Exportación de datos tabulares de Decision Studio

Puede utilizar Editar>copiar para copiar datos tabulares de las herramientas de Decision Studio al portapapeles, como lo haría con cualquier otra aplicación de Windows. También hay cuatro variantes de la operación de copia estándar en el portapapeles:
Opción | Objetivo
Copiar todas las tablas | Copiar celdas de todos los paneles de tablas, en lugar de sólo del panel actual.
Copiar sin los encabezados | Omitir encabezados de filas y columnas.
Copiar con las etiquetas repetidas | Repetir encabezados para cada fila y columna (puede resultarle útil para crear tablas giratorias en Excel).
Copiar los segmentos expandidos | Copiar los datos en un formato de lista de dos columnas, en lugar de un formato tabular.

También es posible resaltar celdas en una vista tabular y arrastrar los datos directamente a las aplicaciones de Windows (tal como Microsoft Excel) que pueda leer datos en un formato tabular.

También puede copiar datos de vistas tabulares y tabulaciones cruzadas [consulte Tabulaciones cruzadas como la base para la segmentación y visualización de datos] de Decision Studio directamente en Microsoft Excel, y si tiene datos tabulares en Decision Studio que desea compartir con colegas, puede enviarlos por correo electrónico.

Tema principal: Cómo trabajar con listas y datos tabulares en Decision Studio

Resaltar regiones de una tabla

Puede resaltar una o más regiones rectangulares en una vista tabular de la misma forma que lo haría en otras aplicaciones de Windows. En la mayoría de las vistas tabulares, también puede hacer clic en los encabezados para resaltar filas o columnas completas de la tabla.

Exportación de datos tabulares a Microsoft Excel

Puede copiar vistas tabulares o datos de tabulaciones cruzadas subyacentes a Excel:
  • Para copiar una vista tabular a Excel, realice una de las siguientes:
    • En Visor de Tablas, seleccione Archivo>View to Excel.
    • En el Creador de árboles de decisión, Creador de scorecardso Creador de clusters, seleccione Archivo>Exportar>View to Excel.
    • Haga clic en [image] en la barra de herramientas.
  • Para copiar datos de tabulaciones cruzadas de Visor de Tabulación Cruzada o Visor de Perfil en Excel, seleccione Archivo>Exportar>Crosstab to Excel, o haga clic en [image] en la barra de herramientas.
Nota:
  • Se crea un nuevo libro de trabajo al exportar datos a Excel.
  • Si resalta celdas en la vista tabular [consulte Resaltar regiones de una tabla], Decision Studio exporta únicamente estas celdas a Excel. De lo contrario, se exporta toda la tabla o tabulación cruzada.
  • Si selecciona View as Excel Link en lugar de View to Excel, o Crosstab as Excel Link en lugar de Crosstab to Excel, creará un vínculo dinámico, de modo que los cambios en la vista tabular o tabulación cruzada se propagarán automáticamente a Excel.


Para configurar el formato de visualización para valores numéricos y de fecha

  1. En la ventana Decision Studio, elija Editar>Ver preferencias.

    Aparecerá el cuadro de diálogo Formato. Uno de los cinco paneles tabulados controla el formato de visualización de valores numéricos y de fecha:

    Panel | Descripción
    Visualización de datos | La cantidad de lugares decimales visualizados para números; la alineación de los números; si se eliminarán los ceros finales en fracciones decimales; si se utilizará un separador de millares (específico de la ubicación); si las fechas se visualizarán en formato americano (MM/DD/AAAA), europeo (DD/MM/AAAA), o AMD (AAAA/MM/DD); si se visualizarán los tiempos según el reloj de 12 horas o 24 horas
  2. Haga clic en Aceptar para confirmar los cambios y cierre el cuadro de diálogo.
Nota: Las configuraciones se activarán para la sesión actual y sesiones futuras de Decision Studio, y Portrait Miner. Sin embargo, no se aplicarán a las importaciones o exportaciones de archivos planos, o a la evaluación de expresiones FDL.

También consulte

Para configurar opciones globales para la visualización gráfica
Tema principal: Cómo trabajar con listas y datos tabulares en Decision Studio


Cómo trabajar con Decision Studio

  • Para orientar la presentación gráfica con el mouse
  • Resaltado de segmentos en una presentación gráfica
  • Exportación de vistas gráficas desde Decision Studio
Tema principal: Cómo trabajar con Decision Studio


Para orientar la presentación gráfica con el mouse

Arrastre el gráfico o la vista del árbol de decisión con uno de los tres botones del mouse:
  • Para girar el gráfico, arrastre con el botón primario del mouse.
  • Para mover el gráfico de un lado a otro o verticalmente, arrastre con el botón secundario del mouse.
  • Para acercar o alejar el gráfico, arrastre hacia arriba o hacia abajo con el botón medio del mouse.
Nota:
  • Si el mouse tiene solamente dos botones, puede simular las funciones del botón medio del mouse manteniendo presionada la tecla Alt y mientras presiona el botón primario del mouse.
  • Cuando mueve un árbol de decisión con el botón secundario del mouse, arrastre en el fondo para evitar que aparezca el menú emergente cuando hace clic en un segmento con el botón secundario del mouse.
Tema principal: Cómo trabajar con Decision Studio

Para restablecer la vista original

Seleccione Ver>Inicio o haga clic en [image] en la barra de herramientas.

Nota:

En Visor de Mapa, si la opción de menú Ver>Automático está marcada, es posible que la vista original haya sido desde la parte superior en lugar de la vista que corresponde a la opción Ver>Inicio.

Para ver un gráfico de mapa desde la parte superior

Seleccione Ver>Parte superior o haga clic en [image] en la barra de herramientas.

Para acercar los segmentos seleccionados en un árbol de decisión

  1. Resalte los segmentos [consulte la sección Resaltado de segmentos en una presentación gráfica] de su interés.
  2. Seleccione Ver>Acercar la selección o haga clic en [image] en la barra de herramientas. Alternativamente, puede hacer clic con el botón secundario del mouse en uno de los segmentos resaltados y seleccione Acercar la selección.

    El Creador de árboles de decisiónse acerca (o se aleja) de manera que los segmentos resaltados y los subsegmentos sean visibles.

Nota:

Si no se resaltan segmentos, Ver>Acercar la selección (o [image]) tendrá el mismo efecto que Ver>Inicio (o [image]).


Resaltado de segmentos en una presentación gráfica

Puede resaltar segmentos en las presentaciones gráficas de Binning Editor, Visor de Perfil, Visor de Distribución Cruzada, Visor de Mapa y Creador de árboles de decisión. Los segmentos resaltados pueden utilizarse como un origen de datos para herramientas vinculadas [consulte la sección Relaciones entre herramientas], y se puede utilizar para derivar campos [consulte la sección Para derivar un campo de una segmentación gráfica] que los describan.
Tema principal: Cómo trabajar con Decision Studio

Para resaltar un único segmento

Haga clic en un segmento para resaltarlo.
Nota:
  • Si el segmento ya está resaltado como parte de un grupo de segmentos, primero haga clic en el fondo para eliminar el resaltado ya existente.
  • En el Visor de Mapa, para resaltar un segmento representado por un vínculo de línea (a diferencia de un bloque), haga clic en la flecha que se encuentra en el centro del vínculo de línea.

Para eliminar el resaltado o ampliarlo a más de un segmento

Realice uno de los procedimientos siguientes:
  • En el teclado, mantenga presionada la tecla CTRL y haga clic en un segmento.

    El segmento se resalta si no estaba resaltado antes y viceversa.

  • Mantenga presionada la tecla CTRL en el teclado y arrastre con el botón primario del mouse para crear un rectángulo de "banda de goma".

    Cuando suelta el botón del mouse, los segmentos que quedan total o parcialmente dentro del rectángulo se resaltan si no lo estaban y viceversa.

Nota: En Visor de Mapa puede seleccionar vínculos de bloques o líneas, pero no ambos a la vez. Si arrastra un rectángulo de "banda de goma" sobre una región que contiene vínculos de bloques y líneas, solamente se seleccionan los bloques.


Exportación de vistas gráficas desde Decision Studio

Si se cuenta con una vista gráfica en el Visor de Perfil, Visor de Distribución Cruzada, Visor de Mapa, Creador de árboles de decisióno Creador de scorecardsy desea incluirla en un informe o compartirla con colegas, se puede guardar la vista como un archivo.
Tema principal: Cómo trabajar con Decision Studio

Para guardar una vista gráfica en un archivo

en el Visor de Perfil, Visor de Distribución Cruzada, Visor de Mapa, Creador de árboles de decisióno Creador de scorecards, seleccione Archivo>Exportar>Ver como imagen, y desplácese [consulte Exploración para abrir o guardar un archivo o tabla de base de datos] hasta el lugar donde quiera guardar su vista gráfica.

Decision Studio exporta la imagen como archivo JPEG.

Nota:
  • Decision Studio guarda una vista gráfica del mismo tamaño que aparece en el visor o en la herramienta de modelado.
  • Para usar una vista gráfica guardada en un informe, importe o coloque el archivo en el documento de destino.
  • En Visor de Perfil, también se puede usar Archivo>Exportar>Ver como HTML para crear una página web que contenga la vista actual.


Cómo trabajar con el conector de PSS

  • Introducción
  • Extensiones de Portrait Miner
  • Extensiones de Decision Studio
  • Autenticación
  • Extensiones de línea de comandos
  • Exportación de reglas desde la interfaz de usuario de Portrait Miner
  • Exportación de reglas en lote


Introducción

El conector de Portrait Shared Services (PSS) admite la integración entre Portrait Miner y otros productos de Portrait Suite, entre los que se incluyen: Portrait Dialogue, Portrait Interaction Optimizer y Portrait Explorer.

Para obtener más información acerca de la instalación de PSSConnector, consulte la sección Instalación de PSSConnector en la Guía de administración de Miner.

Tema principal: Cómo trabajar con el conector de PSS


Extensiones de Portrait Miner

En Portrait Miner, están disponibles las siguientes extensiones.

  • En la barra de herramientas, el botón Administrar conexión a Portrait Shared Services permite iniciar o cerrar sesión desde Portrait Shared Services. Con un servidor de Portrait Customer Analytics basado en Windows, su conexión a Portrait Shared Services se establece en forma automática mediante el uso de la autenticación de Windows, de ser posible. Para establecer la conexión con una cuenta diferente, debe cerrar sesión y luego volver a iniciar sesión mediante el uso de las credenciales adecuadas de la cuenta.
  • En la barra de herramientas, el botón Administrar reglas en el Portrait Shared Repository permite ver la lista de reglas analíticas que se han publicado en el repositorio. Debe seleccionar un dominio lógico de PSS y, a continuación, puede ver las reglas publicadas en ese conjunto. Puede exportar nuevamente una regla al sistema de archivos del servidor como un archivo QMML mediante el uso de la opción Guardar como cuando hace clic con el botón secundario en una regla.
  • Al seleccionar un archivo .qmml en Miner, la acción disponible a través de un clic con el botón secundario Publicar regla en el Portrait Shared Repository publicará el modelo QMML como una regla en Portrait Shared Repository. Se le solicita que ingrese el nombre, el tipo y la descripción de la regla, y el nombre del dominio lógico de PSS en el cual se publicará.

Las aplicaciones de la barra de herramientas también están disponibles a través del menú Inicio de Portrait Miner.

Tema principal: Cómo trabajar con el conector de PSS


Extensiones de Decision Studio

Las extensiones de Portrait Shared Services para Decision Studio ofrecen la capacidad de publicar un campo derivado como una regla en Portrait Shared Repository, desde donde otras aplicaciones pueden utilizarlo.

Las reglas solo se pueden publicar desde el Visor de Tablas.

El Visor de Tablas de Decision Studio también proporciona la aplicación Administrar conexión a Portrait Shared Services, que permite iniciar o cerrar sesión con un nombre de usuario y una contraseña explícitos, o mediante el uso de la autenticación de Windows, cuando sea necesario. La aplicación proporciona las mismas funciones que en Portrait Miner.

El Visor de Tablas de Decision Studio ofrece la capacidad de publicar la tabulación cruzada actual en PSS. Estas especificaciones de tabulación cruzada se pueden usar al generar informes desde la aplicación de Portrait Explorer en Marketing HQ.

Tema principal: Cómo trabajar con el conector de PSS


Autenticación

Es necesario que se autentique en Portrait Shared Services para poder administrar, publicar o recuperar reglas almacenadas en el Portrait Shared Repository.

Si su cuenta de inicio de sesión de Windows está configurada como una cuenta de Autenticación de Windows en la aplicación Portrait Dialogue Admin, las aplicaciones de Miner lo autenticarán en forma automática, y no será necesario que realice ninguna otra acción explícita para iniciar sesión. Este tipo de cuentas no requiere opciones -username o -password para las utilidades de línea de comandos.

Si utiliza una cuenta de inicio de sesión que no está configurada para usar la Autenticación de Windows, entonces deberá iniciar sesión desde Portrait Miner en forma explícita. Las aplicaciones Portrait Miner y Decision Studio le solicitarán en forma automática las credenciales de inicio de sesión, si aún no ha iniciado sesión. Las utilidades de línea de comandos requieren opciones -username y -password explícitamente.

Una vez que haya iniciado sesión desde una de las aplicaciones de Portrait Miner, debe permanecer conectado a esa aplicación hasta salir o cerrar sesión explícitamente. Se debe autenticar por separado para cada aplicación que ejecute.

Tema principal: Cómo trabajar con el conector de PSS


Extensiones de línea de comandos

Extensiones de comandos de creación de datos

La extensión proporciona los siguientes DBC. Todos los comandos requieren argumentos -username y -password explícitos, a menos que esté habilitada la autenticación de Windows en Portrait Campaign Manager para su cuenta de usuario.

  • DBC para mapeos (archivos .xml)
  • DBC para reglas (archivos .qmml)
  • DBC para optimizaciones de decisiones (archivos .qsor)
  • DBC para conjuntos de datos de Explorer
Tema principal: Cómo trabajar con el conector de PSS


DBC para mapeos (archivos .xml)

  • pssmappingpublish
  • pssmappingretrieve
Tema principal: Extensiones de línea de comandos


pssmappingpublish

El comando se usa para publicar un conjunto de mapeos de entrada de regla para un dominio de cliente en Portrait Shared Repository. Los parámetros para el comando son los siguientes:
Publique un archivo de mapeos de entrada de reglas en Portrait Shared Repository

     Requerido:
       -domain <nombre de dominio>
          El dominio de cliente de Portrait Campaign Manager para publicar los mapeos
          en
       -input <archivo de mapeos XML>
          El archivo que contiene la definición de mapeos de entrada de reglas

     Opcional:
       -username <nombre de usuario>
          La cuenta de usuario de Portrait Shared Services que se utilizará. Opcional si puede
          conectarse mediante la autenticación de Windows.
       -password <contraseña>
       La contraseña de la cuenta de usuario de Portrait Shared Services.
Tema principal: DBC para mapeos (archivos .xml)


pssmappingretrieve

El comando recupera un conjunto de mapeos de entrada de regla para un dominio de cliente y lo guarda como un archivo XML. Los parámetros para el comando son los siguientes:
Busque la regla input-mappings de Portrait Shared Repository y guárdela en un archivo.

     Necesario:
       -domain <nombre de dominio>
          El conjunto de clientes de Portrait Campaign Manager en el que buscar los mapeos
.
       -output <archivo de mapeos XML>
          El nombre del archivo en el que se escribirá la definición de los mapeos.

     Opcional:
       -username <nombre de usuario>
          La cuenta de usuario de Portrait Shared Services que se utilizará. Opcional si puede
          conectarse mediante la autenticación de Windows.
       -password <contraseña>
       La contraseña de la cuenta de usuario de Portrait Shared Services.
Tema principal: DBC para mapeos (archivos .xml)


DBC para reglas (archivos .qmml)

  • pssrulepublish
  • pssrulelist
  • pssruleretrieve
  • pssruledescribe
Tema principal: Extensiones de línea de comandos


pssrulepublish

El comando se utiliza para publicar el contenido de un archivo QMML como una regla en Portrait Shared Repository. Los parámetros para el comando son los siguientes:
Publicar una regla QMML en Portrait Shared Repository.

     Necesario:
       -domain <nombre de dominio>
          El dominio de clientes de Portrait Campaign Manager en el que se publica
          la regla.
       -name <nombre de regla>
          El nombre que se utilizará para publicar esta regla en el repositorio.
       -description <texto | @nombrearchivo>
          Descripción de la regla. Si se utiliza el formato @nombrearchivo, extraiga la
          descripción de un archivo. Opcional con -replace.
       -type <Valor | Propensión | Alza>
          El tipo de la regla que se está publicando: Valor, Propensión o Alza.
          Opcional con -replace.
       -input <archivo QMML>
          El nombre del archivo QMML que contiene la regla. El archivo debe contener
          solamente un único conjunto de reglas y este conjunto debe tener una única salida.

     Opcional:
       -username <nombre de usuario>
          La cuenta de usuario de Portrait Shared Services que se utilizará. Opcional si puede
          conectarse mediante la autenticación de Windows.
       -password <contraseña>
          La contraseña de la cuenta de usuario de Portrait Shared Services.
       -replace
          Reemplaza QMML por una regla existente en lugar de publicar una nueva.
          Al reemplazar, los parámetros -type y -description son opcionales.
Tema principal: DBC para reglas (archivos .qmml)


pssrulelist

El comando se utiliza para mostrar los detalles de todas las reglas asociadas con un dominio especificado. La lista de reglas se devuelve en texto sin formato, pero también puede informarse como un documento XML. Los parámetros para el comando son los siguientes:
Lista de todas las reglas en un conjunto de clientes de Portrait Shared Repository.

     Necesario:
       -domain <nombre de dominio>
          El dominio de cliente en el que se buscarán las reglas.

     Opcional:
       -username <nombre de usuario>
          La cuenta de usuario de Portrait Shared Services que se utilizará. Opcional si puede
          conectarse mediante la autenticación de Windows.
       -password <contraseña>
          La contraseña de la cuenta de usuario de Portrait Shared Services.
       -xml
          Muestra la salida en un formato XML.
Tema principal: DBC para reglas (archivos .qmml)


pssruleretrieve

El comando recupera el QMML compilado de una regla en Portrait Shared Repository. Los parámetros para el comando son los siguientes:
Busque una regla QMML de Portrait Shared Repository y guárdela en un archivo.

     Necesario:
       -domain <nombre de dominio>
          El dominio de cliente en el que se buscará la regla.
       -name <nombre de regla>
          El nombre de la regla publicada en Portrait Shared Repository.
       -output <archivo QMML>
          El nombre del archivo en el que se guardará la regla.

     Opcional:
       -username <nombre de usuario>
          La cuenta de usuario de Portrait Shared Services que se utilizará. Opcional si puede
          conectarse mediante la autenticación de Windows.
       -password <contraseña>
          La contraseña de la cuenta de usuario de Portrait Shared Services.
Tema principal: DBC para reglas (archivos .qmml)


pssruledescribe

El comando muestra los nombres y tipos de las entradas y las salidas de una regla en Portrait Shared Repository. También muestra cómo se aplicarán los mapeos de entrada de reglas. Para ello se describe el mapeo a un campo o función, si se ha definido uno. Los parámetros para el comando son los siguientes:
Describa una regla QMML en Portrait Shared Repository.

     Necesario:
       -domain <nombre de dominio>
          El dominio de cliente de Portrait Campaign Manager.
       -name <nombre de regla>
          El nombre de la regla en el dominio de cliente.

     Opcional:
       -username <nombre de usuario>
          La cuenta de usuario de Portrait Shared Services que se utilizará. Opcional si puede
          conectarse mediante la autenticación de Windows.
       -password <contraseña>
       La contraseña de la cuenta de usuario de Portrait Shared Services.
Tema principal: DBC para reglas (archivos .qmml)


DBC para optimizaciones de decisiones (archivos .qsor)

  • pssoptpublish
  • pssoptlist
  • pssoptretrieve
  • pssoptreport
  • pssoptdescribe
Tema principal: Extensiones de línea de comandos


pssoptpublish

El comando se utiliza para publicar el contenido de un archivo de resultados de optimizaciones de decisiones QSOR en Portrait Shared Repository. Los parámetros para el comando son los siguientes:
 Publique una optimización de decisiones en Portrait Shared Repository.

     Necesario:
       -domain <nombre de dominio>
          El dominio de clientes de Portrait Campaign Manager en el que se publica
          la optimización.
       -name <nombre de optimización>
          El nombre que se utilizará para publicar esta optimización en el repositorio.
       -description <texto | @nombrearchivo>
          Descripción de la optimización. Si se utiliza el formato @nombrearchivo, extraiga la
          descripción de un archivo. Opcional con -replace.
       -input <archivo QSOR>
          El nombre del archivo de resultados de optimizaciones de decisiones.

    Opcional:
       -username <nombre de usuario>
          La cuenta de usuario de Portrait Shared Services que se utilizará.
       -password <contraseña>
          La contraseña de la cuenta de usuario de Portrait Shared Services.
       -replace
           Reemplaza los detalles de una optimización existente en lugar de publicar
           una nueva. Al reemplazar, el parámetro -description es opcional.
Tema principal: DBC para optimizaciones de decisiones (archivos .qsor)


pssoptlist

El comando se utiliza para mostrar los detalles de todas las optimiazciones de decisiones asociadas con un dominio especificado. La lista de optimizaciones se devuelve en texto sin formato, pero también puede informarse como un documento XML. Los parámetros para el comando son los siguientes:
Incluya todas las optimizaciones de decisiones en un dominio de cliente en particular en
Portrait Shared Repository.

     Necesario:
       -domain <nombre de dominio>
          El dominio de cliente en el que se buscarán las optimizaciones.

     Opcional:
       -username <nombre de usuario>
          La cuenta de usuario de Portrait Shared Services que se utilizará.
       -password <contraseña>
          La contraseña de la cuenta de usuario de Portrait Shared Services.
       -xml
          Muestra la salida en un formato XML.
Tema principal: DBC para optimizaciones de decisiones (archivos .qsor)


pssoptretrieve

El comando recupera una optimización de decisiones de Portrait Shared Repository. Los parámetros para el comando son los siguientes:
Recupere una optimización de decisiones de Portrait Shared Repository y guárdela en un archivo.

     Necesario:
       -domain <nombre de dominio>
          El dominio de cliente en el que se buscará la optimización.
       -name <nombre de optimización>
          El nombre de la optimización de decisiones publicada en Portrait
          Shared Repository.
       -output <archivo QSOR>
          El nombre del archivo en el que se guardará la optimización.

     Opcional:
       -username <nombre de usuario>
          La cuenta de usuario de Portrait Shared Services que se utilizará.
       -password <contraseña>
          La contraseña de la cuenta de usuario de Portrait Shared Services.
Tema principal: DBC para optimizaciones de decisiones (archivos .qsor)


pssoptreport

El comando recupera el informe asociado con una optimización de decisiones de Portrait Shared Repository y lo guarda en un archivo. Los parámetros para el comando son los siguientes:
Busque una optimización de decisiones de Portrait
Shared Repository y guárdela en un archivo.

     Necesario:
       -domain <nombre de dominio>
          El dominio de cliente en el que se buscará la optimización.
       -name <nombre de optimización>
          El nombre de la optimización de decisiones publicada en Portrait
          Shared Repository.
       -output <archivo HTML>
          El nombre del archivo en el que se guardará el informe.

     Opcional:
       -username <nombre de usuario>
          La cuenta de usuario de Portrait Shared Services que se utilizará. Opcional si puede
          conectarse mediante la autenticación de Windows.
       -password <contraseña>
          La contraseña de la cuenta de usuario de Portrait Shared Services.
Tema principal: DBC para optimizaciones de decisiones (archivos .qsor)


pssoptdescribe

El comando muestra los nombres de los resultados y los nombres y tipos de las entradas y salidas de una regla de optimización de decisiones en Portrait Shared Repository. También muestra cómo se aplicarán los mapeos de entrada de reglas. Para ello se describe el mapeo a un campo o función, si se ha definido uno. Los parámetros para el comando son los siguientes:
Describa una optimización de decisiones en Portrait Shared Repository.

     Necesario:
       -domain <nombre de dominio>
          El dominio de cliente de Portrait Campaign Manager.
       -name <nombre de optimización>
          El nombre de la optimización en el dominio de cliente.

     Opcional:
       -username <nombre de usuario>
          La cuenta de usuario de Portrait Shared Services que se utilizará. Opcional si puede
          conectarse mediante la autenticación de Windows.
       -password <contraseña>
          La contraseña de la cuenta de usuario de Portrait Shared Services.
Tema principal: DBC para optimizaciones de decisiones (archivos .qsor)


DBC para conjuntos de datos de Explorer

  • pssdatasetupdate
Tema principal: Extensiones de línea de comandos


pssdatasetupdate

El comando se utiliza para actualizar un conjunto de datos de Portrait Explorer existente con un archivo de enfoque nuevo. Los parámetros para el comando son los siguientes:
Publique una nueva versión del conjunto de datos para un conjunto de datos con nombre específico en Portrait Shared Repository

     Requerido:
       -name <nombre del conjunto de datos>
          El nombre del conjunto de datos en Portrait Shared Repository para el cual es la versión del conjunto de datos.
       -input <ruta del archivo de enfoque>
          La ruta del archivo en el equipo del servidor de Portrait Analytics Web Services que se actualizará como la
          versión del conjunto de datos.
     Opcional:
       -username <nombre de usuario>
          La cuenta de usuario de Portrait Shared Services que se utilizará. Opcional si puede
          conectarse mediante la autenticación de Windows.
       -password <contraseña>
          La contraseña de la cuenta de usuario de Portrait Shared Services.
       -timeout <valor de tiempo de espera (en minutos)>
          La cantidad máxima de tiempo para esperar, después de que se ha iniciado la generación de la versión del conjunto de datos, para que
          se complete el estado de generación (con éxito o no). Si este argumento se omite
          o se especifica con un valor de 0, se aplica el límite de tiempo de espera por defecto de 10 minutos.
          Nota: Cuando se ha alcanzado el tiempo de espera y se cierra el proceso de este comando, la generación
          de la versión del conjunto de datos continúa en el servidor. Puede comunicarse con un administrador de Explorer
          para verificar si la generación de la versión del conjunto de datos se completó con éxito posteriormente o no.
Tema principal: DBC para conjuntos de datos de Explorer


Exportación de reglas desde la interfaz de usuario de Portrait Miner

  • Exportación de reglas desde Decision Studio
  • Exportar reglas de Portrait Miner
  • Creación de reglas de optimización de contacto
Tema principal: Cómo trabajar con el conector de PSS


Exportación de reglas desde Decision Studio

El componente del complemento PSSConnector agrega nuevos botones a la barra de herramientas de la interfaz de usuario del módulo de Portrait Miner Decision Studio específicamente; se agrega un botón Publicar regla para Portrait Shared Repository a la herramienta Visor de Tablas.

Este botón le permite exportar una definición de regla de campo derivada al dominio seleccionado en Portrait Dialogue. Si proporciona un nombre de una regla que ya existe, se actualizará la definición de la regla.

Decision Studio Table Viewer también proporciona un botón que permite iniciar la aplicación Administrar conexión a Portrait Shared Services, lo que le permite iniciar o cerrar sesión usando un nombre de usuario o contraseña explícitos, o mediante el uso de Autenticación de Windows, cuando sea necesario.

Esta interfaz de usuario es una forma de acceder a muchas de las funciones proporcionadas por el comando de creación de datos pssrulepublish.

Tema principal: Exportación de reglas desde la interfaz de usuario de Portrait Miner


Exportar reglas de Portrait Miner

Portrait Miner se ha extendido para proporcionar una interfaz alternativa que le permita integrar resultados analíticos con Portrait Dialogue.
  • Autenticación: En la barra de herramientas de Portrait Miner, la aplicación Administrar conexión a Portrait Shared Services permite iniciar o cerrar sesión desde Portrait Shared Services.

    Con un servidor de Portrait Miner basado en Windows, su conexión a Portrait Shared Services se establece en forma automática mediante el uso de la Autenticación de Windows, de ser posible.

    Para establecer la conexión con una cuenta diferente, debe cerrar sesión y luego volver a iniciar sesión mediante el uso de las credenciales adecuadas de la cuenta.
  • Visualización de reglas exportadas: En la barra de herramientas de Portrait Miner, la aplicación Administrar reglas en el Portrait Shared Repository permite ver la lista de reglas analíticas que se han publicado. Debe seleccionar un Conjunto de clientes y, a continuación, puede ver las reglas publicadas en ese conjunto. Esta interfaz de usuario es una forma de acceder a muchas de las funciones proporcionadas por los comandos de creación de datos pssrulelist y pssruledescribe.

    Puede exportar una regla nuevamente al sistema de archivos del servidor como un archivo QMML mediante el uso de la opción Guardar cuando hace clic con el botón secundario en una regla. Esta interfaz de usuario es una forma de acceder a muchas de las funciones proporcionadas por el comando de creación de datos pssruleretrieve.

  • Exportación de reglas: Al seleccionar un archivo .qmml en Portrait Miner, la acción disponible a través de un clic con el botón secundario del mouse Publicar regla en el Portrait Shared Repository permite publicar la descripción del modelo (QMML) como una regla para usar en Portrait Dialogue. Se le solicita ingresar el nombre, tipo y la descripción de la regla, y el nombre del dominio en la cual se publicará. Esta interfaz de usuario es una forma de acceder a muchas de las funciones proporcionadas por el comando de creación de datos pssrulepublish.

Las aplicaciones de la barra de herramientas también están disponibles a través del menú Inicio de Portrait Miner.

Tema principal: Exportación de reglas desde la interfaz de usuario de Portrait Miner


Creación de reglas de optimización de contacto

Portrait Optimizer es una extensión a Portrait Miner que le permite crear e implementar reglas de optimización de contacto a Portrait Dialogue. Puede obtener más información detallada en la Guía de usuario de Portrait Optimizer.

Tema principal: Exportación de reglas desde la interfaz de usuario de Portrait Miner


Exportación de reglas en lote

Se proporcionan los siguientes comandos de creación de datos (DBC) con el fin de permitirle exportar reglas analíticas a Portrait Dialogue como parte de un proceso de lote o programado. Todos los comandos requieren argumentos -username y -password explícitos, a menos que esté habilitada la Autenticación de Windows para su cuenta de usuario.

  • Mapeo de datos
  • Integración de reglas
  • Integración de optimización de contacto
Tema principal: Cómo trabajar con el conector de PSS


Mapeo de datos

Si sus conjuntos de datos analíticos se crean mediante el uso de nombres de campos diferentes de los nombres de campos subyacentes en Portrait Dialogue o Interaction Optimizer, o si necesitan resolverse mediante expresiones de Portrait Dialogue en lugar de referencias de campo (por ejemplo, si el análisis se realiza sobre una medición de transacciones), entonces debe publicar una definición de mapeos de entrada de reglas. Esto controla cómo Portrait Dialogue o Interaction Optimizer originan los datos para los valores de entrada requeridos por la regla analítica del sistema de destino, cuando se ejecuta una regla analítica o una optimización de decisiones dentro de una actividad del cuadro de diálogo de Portrait Dialogue o una interacción de Interaction Optimizer.

Nota:
  • Debe hacer una asignación uno a uno para cada campo en el archivo de asignación, no se permiten las asignaciones múltiples por campo de origen o de destino.
  • pssmappingpublish
  • pssmappingretrieve
  • Formato de mapeo de entrada de reglas
Tema principal: Exportación de reglas en lote


pssmappingpublish

Publique un conjunto de mapeos de entrada de regla en un dominio lógico de PSS.

Sinopsis
pssmappingpublish -domain <domain name>-input <XML mappings file>
    [-password <password>][-replace][-username <username>]

Argumentos opcionales

Opción | Efecto
-password | La contraseña de Portrait Shared Services.
-username | El nombre de usuario de Portrait Shared Services.
Tema principal: Mapeo de datos


pssmappingretrieve

Recupera un conjunto de mapeos de entrada de regla para un dominio lógico de PSS y lo guarda como un archivo XML.

Sinopsis
pssmappingretrieve -domain <domain name>
    -output <XML mappings file> -target <the name of the target system the mapping is for>
    [-password <password>][-replace][-username <username>]

Argumentos opcionales

Opción | Efecto
-password | La contraseña de Portrait Shared Services.
-username | El nombre de usuario de Portrait Shared Services.
Tema principal: Mapeo de datos


Formato de mapeo de entrada de reglas

Un archivo de mapeo con entrada de reglas se basa en XML y proporciona el source (la manera en que el archivo se origina en el sistema de destino) y nombres inputName (cómo se llama la entrada de regla). No es necesario que proporcione mapeos para campos que tienen el mismo nombre en el sistema de destino y en la regla. La etiqueta <mapping system=""> se utiliza para especificar para qué sistema de destino se debe utilizar el mapeo. Para especificar Portrait Dialogue como destino, el sistema de mapeo se debe establecer en PD y para especificar Interaction Optimizer, se debe establecer en IO. Solo puede haber un único mapeo para cada sistema dentro de un dominio lógico.

Por ejemplo, implementar reglas en Portrait Dialogue utilizaría el siguiente formato:
<?xml version="1.0" encoding="UTF-8"?>
<mapping system="PD">
    <inputMap inputName="Analytics-RuleInputName" inputType="string" source="TargetSystem-DataSource" sourceType="FIELD or FUNCTION"/>
    ...
</mapping>

El archivo de mapeos se implementa con el DBC pssmappingpublish.

Siempre que deban cambiarse los mapeos de entrada de reglas (por ejemplo, si crea una regla que utiliza campos adicionales no mapeados anteriormente), puede importar un nuevo conjunto de mapeos para ese conjunto y los nuevos mapeos entrarán en vigencia de forma inmediata; cualquier ejecución posterior de las operaciones de Analytics Rule o Decision Optimization en los cuadros de diálogo de Portrait Dialogue de ese conjunto adquirirán de inmediato la nueva definición de mapeo.

Un elemento inputMap en un archivo de mapeo tiene los siguientes atributos:
  • inputName: Este es el nombre de la entrada de reglas. Generalmente, será el nombre del campo en un conjunto de datos de Portrait Miner en el cual se creó la regla.
  • inputType: Este atributo describe el tipo de campo en el entorno de Analytics. El atributo asume los valores integer, real, string o date. Es solo con fines descriptivos, no tiene ningún efecto sobre el significado del mapeo de campos.
  • source: Esto, junto con el atributo sourceType determina la manera en que se obtiene el valor de entrada para el valor en el sistema de destino. En Portrait Dialogue, si el valor sourceType es FIELD , entonces este atributo especificaría el nombre del conjunto de clientes correspondiente para utilizar como origen para la entrada. Si sourceType es FUNCTION, este atributo contiene la función Portrait Dialogue que se utilizará para obtener el valor de entrada.
  • sourcetype: Puede establecer este atributo como sourcetype="FIELD" para Portrait Dialogue o Interaction Optimizer, o como sourcetype="FUNCTION", y especifica si Portrait Dialogue debe originar la entrada de regla desde un campo del Dominio o una expresión de Portrait Dialogue.

Si se define sourcetype como FUNCTION, entonces el valor del atributo de origen debe ser una expresión de Portrait Dialogue válida, que devuelva un único valor de uno de los siguientes tipos de datos: string, integer, float, datetime/date o boolean (donde se mapea un booleano a los valores enteros 0 para false y 1 para true).

Ejemplo

A continuación se incluye un ejemplo de un archivo de mapeos que usa funciones:

<?xml version="1.0" ?>
<mapping system="PD">
   <!-- Maps to the answer of an integer question in a
     questionnaire. Returns NULL if the customer has not answered
     that questionnaire -->
   <inputMap inputName="TI_Q1" inputType="integer" sourceType="FUNCTION"
     sourceName="AnswerInt(1014,'Q1', '')" />

   <!-- Maps to the answer of single choice question (radio buttons)
     in a questionnaire. Returns the alternative key (e.g. "A1"),
     and NULL if the customer has not answered that questionnaire
   -->
   <inputMap inputName="TI_Q2" inputType="string" sourceType="FUNCTION"
              source="AnswerSingleChoice(1014, 'Q2')" />

   <!-- Maps to the answer of a boolean alternative of a question
     (checkboxes) in a questionnaire. Returns true/false, and NULL
     if the customer has not answered that questionnaire -->
   <inputMap inputName="TI_Q2_BOOL" inputType="integer" sourceType="FUNCTION"
              source="IsAnswered(1014, 'Q2', 'A1')" />

   <!-- Checks if a message of a specific template has been created
     for the customer. Returns true/false -->
   <inputMap inputName="TI_MSG_TEMPLATE_1170" inputType="integer" sourceType="FUNCTION"
              source="hasMessages[templateid = 1170]" />

   <!-- Checks if a customer has a specific value in a category with
     values. Returns true/false -->
   <inputMap inputName="TI_CATEGORY_1011_I5" inputType="integer" sourceType="FUNCTION"
              source="hasCategories[Name = 'CATEGORY_1011' and
              Value = 'I5']" />

   <!-- Checks if a customer has been treated by a dialog operation
     (requires participant logging in the dialog). Returns
     true/false -->
   <inputMap inputName="TI_OFFER_1" inputType="integer" sourceType="FUNCTION" ~
              source="HasOperationHistory(4519)" />

   <!-- Checks if a customer has been treated by a dialog branch
     (requires participant logging in the dialog). Returns
     true/false -->
   <inputMap inputName="TI_OFFER_2" inputType="integer" sourceType="FUNCTION"
              source="HasBranchHistory(1231)" />

   <!-- Counts the number of Orders a customer has -->
   <inputMap inputName="count_orders" inputType="integer" sourceType="FUNCTION"
              source="NumberOf(Orders) " />
              </mapping>
Tema principal: Mapeo de datos


Integración de reglas

  • pssrulepublish
  • pssrulelist
  • pssruleretrieve
  • pssruledescribe
Tema principal: Exportación de reglas en lote


pssrulepublish

Publique el contenido de un archivo QMML como una regla con nombre en un dominio lógico de PSS, incluida una descripción y su tipo de regla.

Sinopsis
          pssrulepublish -domain <domain name> -name <rule name>
          -description <text | @filename>
          -type <value | propensity | uplift>
          -input <QMML rule file>
          [-password <password>][-replace][-username <username>]

Argumentos opcionales

Opción | Efecto
-password | La contraseña de Portrait Shared Services.
-replace | Reemplaza QMML por una regla existente en lugar de publicar una nueva. Al reemplazar, los parámetros -type y -description son opcionales.
-username | El nombre de usuario de Portrait Shared Services.
Tema principal: Integración de reglas


pssrulelist

Incluya los detalles de todas las reglas asociadas a un dominio lógico de PSS.

Sinopsis
          pssrulelist -domain <domain name>
          [-password <password>][-username <username>][-xml]

Argumentos opcionales

Opción | Efecto
-password | La contraseña de Portrait Shared Services.
-username | El nombre de usuario de Portrait Shared Services.
-xml | Muestra la salida en un formato XML.
Tema principal: Integración de reglas


pssruleretrieve

Recupere el QMML compilado para una regla con nombre en un dominio lógico de PSS a un archivo.

Sinopsis
          pssruleretrieve -domain <domain name>-name<rule name>
          -output <QMML file>
          [-password <password>][-username <username>]

Argumentos opcionales

Opción | Efecto
-password | La contraseña de Portrait Shared Services.
-username | El nombre de usuario de Portrait Shared Services.
Tema principal: Integración de reglas


pssruledescribe

Incluya los nombres y los tipos de entradas y salidas de una regla con nombre en un dominio lógico de PSS. También muestra cómo se aplicarán los mapeos de entrada de reglas. Para ello se describe el mapeo a un campo o función, si se ha definido uno. Los parámetros para el comando son los siguientes:

Sinopsis
          pssruledescribe -domain <domain name>-name <rule name>
          [-password <password>][-replace][-username <username>]

Argumentos opcionales

Opción | Efecto
-password | La contraseña de Portrait Shared Services.
-username | El nombre de usuario de Portrait Shared Services.
Tema principal: Integración de reglas


Integración de optimización de contacto

Se proporciona un conjunto de DBC con Portrait Optimizer para permitir la implementación de modelos de optimización de contacto en PSS.

  • pssoptpublish
  • pssoptlist
  • pssoptretrieve
  • pssoptreport
  • pssoptdescribe
Tema principal: Exportación de reglas en lote


pssoptpublish

Implemente un resultado de optimización de contacto en un dominio lógico de PSS con un nombre y una descripción determinados.

Sinopsis
          pssoptpublish -domain <domain name> -name <optimization name>
          -description <text | @filename> -input <QSOR file>
          [-password <password>][-replace][-username <username>]

Argumentos opcionales

Opción | Efecto
-password <contraseña> | La contraseña de Portrait Shared Services.
-replace | Reemplaza los detalles de una optimización existente en lugar de publicar una nueva. Al reemplazar, el parámetro -description es opcional.
-username <contraseña> | El nombre de usuario de Portrait Shared Services.
Tema principal: Integración de optimización de contacto


pssoptlist

Incluya las optimizaciones de contacto en un dominio lógico de PSS.

Sinopsis
          pssoptlist -domain <domain name>
          [-password <password>] [-username <username>][-xml]

Argumentos opcionales

Opción | Efecto
-password <contraseña> | La contraseña de Portrait Shared Services.
-xml | Muestra la salida en un formato XML.
-username <contraseña> | El nombre de usuario de Portrait Shared Services.
Tema principal: Integración de optimización de contacto


pssoptretrieve

Obtenga una única optimización de contacto de un dominio lógico de PSS y guárdela en un archivo de resultados de optimización de contacto.

Sinopsis
          pssoptretrieve -domain <domain name> -name <optimization name>
          -output <QSOR file>
          [-password <password>] [-username <username>]

Argumentos opcionales

Opción | Efecto
-password <contraseña> | La contraseña de Portrait Shared Services.
-username <contraseña> | El nombre de usuario de Portrait Shared Services.
Tema principal: Integración de optimización de contacto


pssoptreport

Obtenga un único informe de optimización de contacto de un dominio lógico de PSS y guárdelo en un archivo.

Sinopsis
          pssoptreport -domain <domain name> -name <optimization name>
          -output <HTML file>
          [-password <password>] [-username <username>]

Argumentos opcionales

Opción | Efecto
-password <contraseña> | La contraseña de Portrait Shared Services.
-username <contraseña> | El nombre de usuario de Portrait Shared Services.
Tema principal: Integración de optimización de contacto


pssoptdescribe

Obtenga los parámetros de un único informe de optimización de contacto de un dominio lógico de PSS. También se muestra cómo se aplicarán los mapeos de entrada de reglas. Para ello se describe el mapeo en un campo o función, si se ha definido uno para el sistema de destino especificado.

Sinopsis
          pssoptdescribe -domain <domain name> -name <optimization name>
          [-target <system name>] [-password <password>] [-username <username>]

Argumentos opcionales

Opción | Efecto
-target <nombre del sistema> | El nombre del sistema de destino para los mapeos de campo; por ej., PD para Portrait Dialogue o IO para Interaction Optimizer.
-password <contraseña> | La contraseña de Portrait Shared Services.
-username <contraseña> | El nombre de usuario de Portrait Shared Services.
Tema principal: Integración de optimización de contacto


Visualización de los registros de los clientes en un enfoque

  • Visualización de los registros de los clientes


Visualización de los registros de los clientes

En Decision Studio, se puede usar Visor de Tablas para visualizar los datos sin procesar en los registros de clientes individuales. Para abrir Visor de Tablas desde la ventana de Decision Studio, seleccione Herramientas>Visor de Tablas o haga clic en [image] en la barra de herramientas.

Visor de Tablas muestra inicialmente los datos de los primeros 100 clientes en su enfoque (el primer bloque de registros), teniendo en cuenta las selecciones de registros realizadas [consulte Selección de registros de clientes] .

Se pueden controlar los campos [consulte Para elegir los campos que desea ver] y los registros [consulte Para mostrar un bloque de registros diferente] que muestra Visor de Tablas y se pueden visualizar las estadísticas básicas [consulte Para mostrar las estadísticas de campo] de cada campo mostrado.

Nota: Si el valor en un campo cadena es una dirección URL (por ejemplo http://www.portraitsoftware.com/), Visor de Tablas muestra el valor en azul y lo subraya. Se puede hacer doble clic en el valor para ver el recurso asociado en su navegador de la web.

También consulte

Para derivar un campo utilizando Visor de Tablas
Tema principal: Visualización de los registros de los clientes en un enfoque

Para elegir los campos que desea ver

  1. Seleccione Ver>Ocultar/Mostrar.

    Aparece el cuadro de diálogo Ocultar/Mostrar/Reordenar los campos:

    • Use los botones [image] y [image] entre los paneles Ocultar y Mostrar para mover los campos resaltados de un panel al otro.

      Los botones [image] y [image] mueven todos los campos, independientemente de si están resaltados.

    • Use los botones [image] y [image] a la derecha del panel Mostrar para reordenar los campos.
  2. Haga clic en Aceptar.
Nota:
  • También se pueden ocultar campos de la vista resaltándolos con Visor de Tablas y seleccionando Campo>Ocultar o haciendo clic con el botón derecho para elegir Ocultar.

    Para mostrar un campo que se ha ocultado de este modo, se debe usar el cuadro de diálogo Ocultar/Mostrar/Reordenar los campos como se indica arriba.

  • Ocultar y reordenar los campos sólo afecta la vista en Visor de Tablas. El enfoque subyacente no se modifica.

Para mostrar un bloque de registros diferente

Siga uno de los siguientes procedimientos:
  • Seleccione Ver>Bloque de registros siguiente o haga clic en [image] en la parte inferior de la barra de desplazamiento para ver el siguiente bloque de 100 registros.
  • Seleccione Ver>Bloque de registros anterior o haga clic en [image] en la parte superior de la barra de desplazamiento para ver el bloque anterior de 100 registros.
  • Seleccione Ver>Ir a registro e ingrese un número de registro para saltar a un bloque de registros en particular.
Nota: Visor de Tablas tiene en cuenta todas las selecciones de registros que se hayan realizado [consulte Selección de registros de clientes] .

Para mostrar las estadísticas de campo

Seleccione Ver>Estadísticas.

Visor de Tablas muestra el valor mínimo no nulo [consulte El valor null], el máximo valor no nulo y el número de instancias de nulo en cada campo:

Nota: Debido a cuestiones de eficiencia, Visor de Tablas no mantiene las estadísticas actualizadas todo el tiempo. Cuando las estadísticas de campo están desactualizadas, Visor de Tablas las muestra sombreadas.
  • Para actualizar las estadísticas para un campo o conjunto de campos, resalte los campos y seleccione Campo>Actualizar estadísticas o haga clic con el botón derecho sobre un campo y seleccione Actualizar estadísticas.


Seleccionar los registros de los clientes en un enfoque

  • Selección de registros de clientes
  • Selección de valor o filtrado usando un campo categórico
  • Selección o filtrado de valores utilizando un campo o estadística no categórico


Selección de registros de clientes

Puede seleccionar los registros en un enfoque de acuerdo con los valores de un campo, especificando el conjunto de valores requeridos [consulte la sección Para seleccionar registros en un enfoque por valor] o especificando la cantidad de registros [consulte la sección Para seleccionar una cantidad determinada de registros] que desee. Los visores gráficos y las herramientas de modelaje que usan el enfoque operan solo en registros específicos.
Nota:
  • Puede utilizar la selección de registros en más de un campo a la vez, en cuyo caso la selección de registros es acumulativa; es decir, los registros seleccionados cumplirán con todas las condiciones elegidas.
  • Si hay una selección de registros asociada con un campo, una "S" aparecerá en la columna Selección de la ventana de Decision Studio. Para un campo no categórico, los intervalos seleccionados también aparecerán en la columna en notación matemática estándar, %TODO: Expanda sobre esta base. junto con "+N" o "-N" depende si el valor null [consulte la sección El valor null] está incluido o no.
  • Las selecciones pueden eliminarse o modificarse incluso después de guardar y volver a abrir el enfoque.
  • Puede reducir el tiempo de aplicación de la selección si cierra otras ventanas que no necesita.
  • La presencia de una selección de registros no mejora la velocidad de las operaciones en el enfoque.

También consulte

Metadata del enfoque
Tema principal: Seleccionar los registros de los clientes en un enfoque

Para seleccionar registros en un enfoque por valor

  1. En la ventana de Decision Studio, resalte el registro que quiera utilizar para la selección de registros.
  2. Seleccione Campo>Seleccionar valores, haga clic con el botón secundario del mouse y seleccione Seleccionar valores o haga clic en [image] en la barra de herramientas.

    Aparecerá el cuadro de diálogo Seleccionar valores.

  3. Haga una selección de registro de acuerdo con los valores en un campo.

    Hay diferentes opciones para la selección categórica [consulte la sección Selección de valor o filtrado usando un campo categórico] y la selección no categórica [consulte la sección Selección o filtrado de valores utilizando un campo o estadística no categórico].

  4. Haga clic en Aceptar para confirmar la selección y cierre la ventana Seleccionar valores.
Nota:
  • También puede abrir la ventana Seleccionar valores desde la mayoría de las listas de campo al hacer clic con el botón secundario en el menú de un campo.
  • En el Visor de Tabulación Cruzada, el Visor de Mapa, el Visor de Perfil y el Visor de Distribución Cruzada puede acceder a la ventana Seleccionar valores al hacer clic con el botón secundario en un campo del área de configuración de gráficos.

Para seleccionar una cantidad determinada de registros

  1. En la ventana de Decision Studio, resalte el registro numérico que quiera utilizar para la selección de registros.
  2. Si hay una selección de registros existente en el campo, deberá eliminar esa selección [consulte la sección Para quitar la selección de registros de un campo].
  3. Seleccione Campo>Seleccionar cantidad o haga clic con el botón secundario del mouse y elija Seleccionar cantidad.

    Aparecerá el cuadro de diálogo Seleccionar cantidad.

  4. Seleccione si desea seleccionar los registros con los valores más altos (superior) o los más bajos (inferior).
  5. Ingrese un porcentaje de los registros disponibles o un número exacto de registros y seleccione "%" o "#" respectivamente del menú desplegable.
  6. Seleccione si desea ajustar la cantidad para arriba o para abajo en caso de que sean nexos.

    Puede suceder que, una vez que todos los registros estén clasificados de acuerdo con sus valores en el campo elegido, los registros con el mismo valor en un campo extiendan el umbral de cantidad seleccionado. Para evitar incluir arbitrariamente algunos de esos registros, Decision Studio le ofrece la opción de incluirlos a todos (ajustando la cantidad para arriba) o excluirlos a todos (ajustando la cantidad para abajo).

  7. Haga clic en Aceptar para confirmar la selección y cierre la ventana Seleccionar valores.
Nota: Una vez realizada la selección de registros por cantidad, es indistinguible de una selección de registros hecha seleccionando valores. Puede seleccionar por valor [consulte la sección Para seleccionar registros en un enfoque por valor] para ajustar su selección de registros de ser necesario. Sin embargo, no puede volver a seleccionar por cantidad sin eliminar primero la selección.

Para quitar la selección de registros de un campo

  1. En la ventana de Decision Studio, resalte el campo con la selección de registro asociada.
  2. Seleccione Campo>Borrar selección, haga clic con el botón secundario y seleccione Borrar selección o haga clic en [image] en la barra de herramientas.

Para quitar todas las selecciones de registro de un enfoque

Seleccione Enfoque>Borrar todas las selecciones.


Selección de valor o filtrado usando un campo categórico

Cuando usa valores en un campo categórico [consulte Interpretación de los campos] para seleccionar registros por valor [consulte la sección Para seleccionar registros en un enfoque por valor] en un enfoque, o aplica un filtro a un campo categórico asociado [consulte la sección Para asociar un campo o estadística con un aspecto de un gráfico o una tabulación cruzada] con algunos aspectos de una tabulación cruzada o un gráfico, la ventana Seleccionar valores o Filtro aparece de la siguiente manera:

Los paneles muestran las categorías seleccionadas y no seleccionadas, que pueden ser los valores actuales del campo (las categorías base) o las categorías en el rango activo [consulte la sección Para modificar una creación de rangos categóricos], si existe uno.

Puede mover categorías resaltadas de un panel a otro utilizando uno de los botones de flecha única o seleccionar/rechazar la selección de todas las categorías utilizando uno de los botones de flechas dobles. Para intercambiar categorías seleccionadas y no seleccionadas, haga clic en [image].

También consulte

Para seleccionar una cantidad determinada de registros

Selección o filtrado de valores utilizando un campo o estadística no categórico

Tema principal: Seleccionar los registros de los clientes en un enfoque


Selección o filtrado de valores utilizando un campo o estadística no categórico

Si utiliza valores en un campo de fecha o numérico no categórico para seleccionar registros por valor [consulte la sección Para seleccionar registros en un enfoque por valor] en un enfoque, o aplica un filtro a una estadística o un campo no categórico que está asociado [consulte la sección Para asociar un campo o estadística con un aspecto de un gráfico o una tabulación cruzada] con algunos aspectos de una tabulación cruzada o un gráfico, la venta de Seleccionar valores o Filtro aparece de la siguiente manera:

La barra horizontal representa el rango de valores en un campo o estadística, con porciones completas que representan los valores seleccionados. La cuña que apunta hacia abajo en cada extremo del rango seleccionado está completa ( [image]) para indicar que el valor de punto final está incluido en el rango o delineada ( [image]) para indicar que el valor de punto final está excluido del rango.

Si resalta un rango seleccionado haciendo clic en él, el panel debajo de la barra mostrará los valores para los dos extremos, y aclarará si están incluidos o no. Puede moverse de un rango seleccionado a otro utilizando los botones de flechas a cada lado del panel.

Nota:
  • Si un campo o una estadística no está asociado con un filtrado o selección de registro, la barra horizontal en la ventana Seleccionar valores o Filtro mostrará un solo rango seleccionado, con ambos extremos incluidos.
  • El valor null [consulte la sección El valor null] estará incluido o excluido de acuerdo con la configuración del menú Manejo de nulos.

    Si selecciona un determinado rango de registros explícitamente, puede seleccionar si la selección incluirá los registros que contienen el valor nulo (Incluir siempre) o si los excluirá (Excluir siempre o Excluir de la selección explícita).

    Para elegir solo los registros que contienen el valor nulo, elija Seleccionar en forma exclusiva.

    Para elegir todos los registros que contengan un valor no nulo, no seleccione un rango explícito (cambiando valores o arrastrando los extremos), simplemente seleccione Excluir siempre.

También consulte

Para seleccionar una cantidad determinada de registros

Selección de valor o filtrado usando un campo categórico

Tema principal: Seleccionar los registros de los clientes en un enfoque

Para agregar un rango a una selección

Haga clic en [image].

Si hay valores sin seleccionar a la derecha del rango resaltado actualmente, el nuevo rango completará el primer intervalo disponible hacia la derecha. De lo contrario, si hay valores sin seleccionar a la izquierda del rango resaltado actualmente, el nuevo rango completará el primer espacio disponible hacia la izquierda. Si no hay valores sin seleccionar, Decision Studio divide el rango seleccionado existente más grande para crear un nuevo par de rangos.

Para quitar un rango de la selección

  1. Haga clic en el rango para resaltarlo.
  2. Haga clic en [image].
Nota: Para quitar todos los rangos seleccionados, haga clic en [image].

Para incluir o excluir un extremo en un rango

Haga doble clic en la cuña correspondiente para cambiar su estado, o resalte el rango haciendo clic en esta y seleccione Incluidos o Excluidos de la lista desplegable correspondiente.
Nota:
  • Puede deshabilitar el extremo izquierdo del rango más a la izquierda seleccionado (o el extremo derecho del rango más a la derecha seleccionado) si elige Deshabilitado del menú desplegable del extremo (en lugar de Incluidos o Excluidos). La cuña que marca el extremo luego desaparece para indicar que el rango seleccionado está abierto.
  • Para una selección basada en fechas, los rangos siempre incluyen extremos.

Para ajustar un extremo de un rango

Arrastre la cuña correspondiente a la derecha o a la izquierda, o arrastre el rango completo para cambiar ambos extremos al mismo tiempo, manteniendo la longitud del rango.

Alternativamente, resalte el rango e ingrese un valor en el cuadro de texto correspondiente.

Nota: Puede usar el botón [image] o [image] junto a un cuadro de texto de punto final para forzar al punto final a que avance hasta el siguiente valor más bajo o más alto que aparezca realmente en los datos.

Para invertir la selección de un rango

Haga clic en [image].

Los intervalos entre los rangos seleccionados serán los nuevos rangos seleccionados.


Agrupación de los registros de los clientes creando rangos en el campo de un enfoque

  • Para modificar una creación de rangos categóricos
  • Para modificar una creación de rangos no categóricos
  • Modificación de rangos no categóricos personalizados
  • Opciones para mostrar un rango
  • Para adjuntar un rango adicional a un campo no categórico
  • Aplicación de una creación de rangos a más de un campo
  • Para optimizar la creación de rangos de un campo


Para modificar una creación de rangos categóricos

  1. En la ventana de Decision Studio, resalte el campo categórico [consulte la sección Interpretación de los campos] cuyo rango desea modificar. Seleccione Herramientas>Binning Editor, presione CTRL+B o haga clic en [image] en la barra de herramientas.
  2. Alternativamente, desde la lista de campos de las herramientas de modelado, resalte el campo, haga clic con el botón secundario del mouse y seleccione Binning Editor.
  3. Alternativamente, en los visores gráficos, haga clic con el botón secundario del mouse en un campo en el área de configuración de gráficos y seleccione Binning Editor.

    Se abrirá el Binning Editor y mostrará un gráfico de los rangos actuales del campo que haya seleccionado. En la parte inferior izquierda de la ventana se encuentra el panel Jerarquía, que muestra potencialmente una jerarquía de rangos categóricos más gruesos del campo actual. El rango resaltado es el rango actual.

    Si no hay un rango adjunto al campo, el Binning Editor crea un rango llamado "nodo sin nombre" con los parámetros por defecto [consulte la sección Para eliminar rangos categóricos de un campo].

  4. Opcionalmente podrá resaltar un rango distinto en el panel Jerarquía; o podrá crear uno nuevo resaltando un rango ya existente en la jerarquía y haciendo clic en Nuevo.

    Cuando crea un nuevo rango de esta manera, el rango original que resaltó es el padre del nuevo rango.

  5. Combine o divida las categorías [consulte la sección Para combinar o dividir categorías] para crear rangos más gruesos o más finos y cambie el nombre [consulte la sección Para cambiar el nombre de una categoría] de las nuevas categorías según corresponda.
  6. Si lo desea, reordene las categorías [consulte la sección Para reordenar categorías] en el rango.
  7. Haga clic en Aplicar o en Aceptar para confirmar los cambios en la jerarquía de rangos categóricos.

    Alternativamente, haga clic en Restablecer para descartar todos los cambios que ha realizado sobre la jerarquía de rangos categóricos desde la última vez que aplicó los cambios.

Nota:
  • Cuando aplica los cambios, una jerarquía de rangos categóricos funciona como un único rango. En la mayoría de los demás aspectos, los niveles individuales de la jerarquía funcionan como rangos individuales, en los que el rango actual es semejante al rango primario [consulte la sección Para establecer el rango primario de un campo no categórico] de un campo no categórico.
  • Puede modificar la creación de rangos en otros campos sin salir de Binning Editor al hacer clic en la ficha Campos y al resaltar el campo deseado.

También consulte

Para modificar una creación de rangos no categóricos
Tema principal: Agrupación de los registros de los clientes creando rangos en el campo de un enfoque

Para combinar o dividir categorías

  1. En el panel Categorías, resalte las categorías que desea combinar o la categoría ya combinada que desea dividir.

    El panel de Categorías padre muestra las categorías correspondientes en el rango padre (o categorías base).

  2. Realice uno de los procedimientos siguientes:
    • Haga clic en Combinar o haga clic con el botón secundario del mouse en el panel Categorías y seleccione Combinar.

      Binning Editor combina las categorías resaltadas en una sola categoría, que recibe su nombre a partir de la combinación de los nombres originales de las categorías, separado por la "Y" comercial.

    • Haga clic en Dividir o haga clic con el botón secundario del mouse en el panel Categorías y seleccione Dividir. Binning Editor divide la categoría resaltada en sus categorías padre.

Para cambiar el nombre de una categoría

  1. En el panel Categorías haga doble clic en una categoría, o bien resalte la categoría haciendo clic en ella y luego haga clic en Cambiar nombre.
  2. Ingrese un nuevo nombre para la categoría y presione Volver.

Para reordenar categorías

  1. Haga clic en Reordenar o haga clic con el botón secundario del mouse en el panel Categorías.
  2. Seleccione de qué modo reordenar las categorías:
    • Por recuento, descendente (+) o ascendente (-)
    • Alfabéticamente por nombre de categoría
    • Por número de categoría, ascendente
Nota: Cuando se ordena un rango por números de categoría, las categorías combinadas se presentan luego de las categorías sin combinar y se ordenan por la categoría de mayor número en cada padre; por ejemplo, una combinación de los rangos 2 y 4 antecede a una combinación de los rangos 1 y 5.

Para cambiar el nombre de rangos categóricos

Puede asignar nombres significativos a los rangos de la jerarquía de rangos categóricos de un campo.
  1. En el panel Jerarquía de Binning Editor, resalte el rango cuyo nombre desea cambiar.
  2. Haga clic en Cambiar nombre o simplemente haga clic una vez más en el nombre del rango.
  3. Ingrese el nombre de rango que haya elegido y presione Volver.

Para eliminar rangos categóricos de un campo

  1. En el panel Jerarquía de Binning Editor, resalte el rango que desea eliminar.
  2. Haga clic en Eliminar.
Nota: Para eliminar todos los rangos categóricos de uno o más campos, simplemente borre la interpretación categórica [consulte la sección Para establecer o borrar una interpretación categórica, geográfica, de candidato para análisis, de exportación o de clave] de los campos.

Para establecer los parámetros por defecto para rangos categóricos nuevos

  1. Seleccione Rangos>Parámetros por defecto o haga clic en [image] en la barra de herramientas.
  2. En la ficha Categórico, establezca la cantidad máxima de categorías y la cantidad mínima de registros de una sola categoría.
  3. Haga clic en Aceptar para confirmar su selección.
Nota:
  • Si la cantidad de registros que contienen un valor dado se encuentra entre la cantidad mínima de registros de una categoría, normalmente debido a que el campo contiene demasiados valores distintos, los registros que contienen dicho valor quedan sin clasificar. Los registros sin clasificar no se muestran por defecto en Binning Editor; para mostrarlos, seleccione Ver>Datos sin clasificar.
  • Para aplicar los nuevos parámetros por defecto a un campo que ya tiene una interpretación categórica, debe borrar la interpretación categórica ya existente [consulte la sección Para establecer o borrar una interpretación categórica, geográfica, de candidato para análisis, de exportación o de clave].


Para modificar una creación de rangos no categóricos

  1. En la ventana de Decision Studio, resalte el campo no categórico [consulte la sección Interpretación de los campos] numérico o de fecha cuyo rango desea modificar. Seleccione Herramientas>Binning Editor, presione CTRL+B o haga clic en [image] en la barra de herramientas.
  2. Alternativamente, desde la lista de campos de las herramientas de modelado, resalte el campo, haga clic con el botón secundario del mouse y seleccione Binning Editor.
  3. Alternativamente, en los visores gráficos, haga clic con el botón secundario del mouse en un campo en el área de configuración de gráficos y seleccione Binning Editor.

    Se abrirá el Binning Editor y mostrará un gráfico de los rangos primarios [consulte la sección Para establecer el rango primario de un campo no categórico] del campo que haya seleccionado.

    Si no hay un rango adjunto al campo, el Binning Editor crea un rango con los parámetros por defecto [consulte la sección Para establecer los parámetros por defecto para rangos no categóricos nuevos].

  4. Desde el panel Estilo, seleccione el tipo de rango requerido.
    • Para una creación de rangos equivalentes, puede establecer ya sea la cantidad objetivo de rangos internos (rangos entre los rangos finales [consulte la sección Rangos finales]) o bien el ancho del rango objetivo.
    • Para una creación de rangos de población equivalente, puede establecer el número objetivo de rangos internos.
    • Para una creación de rangos equivalentes o de población equivalente con valor de fecha, también puede especificar las unidades en las que se mide el ancho de rango (días, semanas, etc.).
    • Para una creación de rangos personalizada, haga clic en Editar para especificar los límites del rango en particular [consulte la sección Modificación de rangos no categóricos personalizados] en el cuadro de diálogo Personalizado.
  5. Haga clic en Aplicar o en Aceptar para confirmar los cambios en la creación de rangos.

    Alternativamente, haga clic en Restablecer para descartar todos los cambios que ha realizado en la creación de rangos desde la última vez que aplicó los cambios.

Nota:
  • En el caso de campos de tipo real, para forzar al Binning Editor a que localice los límites de rangos en valores enteros, compruebe Creando rangos>Límites de números enteros.
  • La cantidad final de rangos internos puede ser distinta de la cantidad objetivo de un campo o tipo entero, o si está marcada la opción Creando rangos>Límites de números enteros. Esto sucede por alguno de estos dos motivos:
    • El rango del campo no incluye suficientes límites de número entero.
    • Creando rangos>Ajustar automáticamente la cantidad de rangos está marcado, y se seleccionará automáticamente al menos uno de los límites de rangos finales; en este caso el Binning Editor puede ajustar la cantidad de rangos para localizar los límites de rangos en valores de números redondeados. Para forzar la cantidad final de rangos para que sea igual a la cantidad de números objetivo, desmarque Rangos>Ajustar automáticamente la cantidad de rangos y haga clic en Aplicar o Aceptar.
  • Para lograr una creación de rangos personalizada, los cambios se hacen efectivos cuando hace clic en Aceptar dentro del cuadro de diálogo Personalizado. Por lo tanto, no es necesario hacer clic en Aplicar en Binning Editor (y no podrá regresar a la creación de rangos original utilizando Restablecer).
  • Puede modificar la creación de rangos en otros campos sin salir de Binning Editor al hacer clic en la ficha Campos y al resaltar el campo deseado.

También consulte

Para adjuntar un rango adicional a un campo no categórico

Para modificar una creación de rangos categóricos

Tema principal: Agrupación de los registros de los clientes creando rangos en el campo de un enfoque

Rangos finales

En Decision Studio, la creación de rangos de población equivalente o de rangos equivalentes divide un rango numérico o de fecha en una serie de rangos. La mayoría de estos rangos son "internos" pero es posible que haya un "rango final" especial al final de cada uno de los rangos.

Cuando Decision Studio crea un rango numérico con rangos finales, utiliza un algoritmo inteligente para clasificar algunos valores como valor atípico. Los registros que contengan dichos valores atípicos quedarán en los rangos finales, mientras que la mayoría de los registros quedarán en los rangos internos.

En el Binning Editor de Decision Studio puede controlar el uso de rangos finales en rangos equivalentes y de población equivalente mediante el uso de los menús desplegables que se encuentran en los paneles de Rango final mínimo y Rango final máximo:
  • Si selecciona Automático para una creación de rangos numéricos equivalentes, Binning Editor seleccionará automáticamente el límite del rango final.
  • Si selecciona Automático para un rango de fecha o un rango de población equivalente, el Binning Editor omite el rango final.
  • Seleccione Fijado en para especificar un límite fijo de rango final.
  • Seleccione Ninguno para omitir el rango final en todos los casos.

Además, puede controlar los rangos finales en una creación de rangos personalizada [consulte la sección Modificación de rangos no categóricos personalizados].

Para eliminar rangos no categóricos de un campo

  1. En Binning Editor, si aún no está viendo el campo no categórico cuyos rangos desea eliminar, haga clic en la ficha Campos y resalte el campo.
  2. Seleccione Rangos>Eliminar rangos, haga clic con el botón secundario del mouse en el panel Campos y seleccione Eliminar rangos o haga clic en [image] en la barra de herramientas.
Nota:
  • Puede eliminar simultáneamente los rangos de varios campos no categóricos. Para ello debe seleccionar Eliminar rangos en múltiples campos. Aparecerá un cuadro de diálogo Seleccionar campos, en el cual podrá seleccionar los campos cuyos rangos desea eliminar.
  • Tal como sugieren sus nombres, las opciones Eliminar rangos y Eliminar rangos en múltiples campos eliminan todos los rangos asociados con un campo no categórico. Si ha utilizado la función de múltiples rangos en Decision Studio para adjuntar más de un rango a un campo [consulte la sección Para adjuntar un rango adicional a un campo no categórico], podrá eliminar un rango individual seleccionando Creando rangos>Administrar múltiples rangos: resalte el rango requerido en el cuadro de diálogo Administrar múltiples rangos y haga clic en Eliminar.

Para establecer los parámetros por defecto para rangos no categóricos nuevos

  1. En Binning Editor, seleccione Rangos>Parámetros por defecto o haga clic en [image] en la barra de herramientas.
  2. En la ficha No categórico, seleccione la cantidad objetivo de rangos (sin incluir nulo [consulte la sección El valor null], los rangos sin clasificar y los rangos finales [consulte la sección Rangos finales]), el tipo de rango [consulte la sección Para modificar una creación de rangos no categóricos] y si desea mostrar los rangos que tengan anchos de rango proporcional [consulte la sección Opciones de histograma y gráfico de barras].
  3. Haga clic en Aceptar para confirmar su selección.
Nota:

Para aplicar los nuevos parámetros por defecto a un campo que ya tiene los rangos creados, debe eliminar [consulte la sección Para eliminar rangos no categóricos de un campo] los rangos existentes.


Modificación de rangos no categóricos personalizados

Cuando hace clic en Editar en Binning Editor para un rango personalizado, aparece el cuadro de diálogo Personalizado:

Trabaje a partir del rango existente (quizá anteriormente haya sido un rango equivalente o de población equivalente), o haga clic en Inicio rápido para comenzar con un rango preconfigurado [consulte la sección Cómo utilizar los rangos preconfigurados de inicio rápido]. Luego ajuste el rango de manera que se adapte a sus necesidades:
  • Cambie los límites del rango editándolo directamente en la tabla o manipulando la vista gráfica (que funciona de la misma manera que la vista gráfica para seleccionar o filtrar registros [consulte la sección Selección o filtrado de valores utilizando un campo o estadística no categórico]).
  • Aumente la cantidad de rangos resaltando uno (en la tabla o en la vista gráfica) y haciendo clic en Dividir rango.

    El rango se divide en dos rangos del mismo tamaño.

  • Disminuya la cantidad de rangos resaltando uno y haciendo clic en Eliminar rango.

    El rango se combina con el rango que se encuentra a su derecha (o a su izquierda si se trata del rango más a la derecha).

  • Controle el uso de los rangos finales [consulte la sección Rangos finales] seleccionando Ambos, Ninguno, Inferioro Superior en el menú desplegable.
Nota: Cambiando el valor de un límite de rango o activando o desactivando una casilla de verificación de Incluir desde, puede dejar uno o más rangos definidos de manera que no puedan contener ningún valor. Esos rangos inválidos se resaltan como filas rojas en la tabla y se los etiqueta como "No válido."

Para eliminar todos los rangos inválidos de sus rangos, haga clic en Eliminar los no válidos.

También consulte

Para modificar una creación de rangos no categóricos
Tema principal: Agrupación de los registros de los clientes creando rangos en el campo de un enfoque

Cómo utilizar los rangos preconfigurados de inicio rápido

Cuando hace clic en Inicio rápido dentro del cuadro de diálogo Personalizado, aparece el cuadro de diálogo Preconfiguración personalizada:

Si selecciona el tipo preconfigurado adecuado del menú desplegable, podrá crear rápidamente un rango donde los valores de los rangos Rango de y Rango para tengan propiedades útiles:
  • En un rango Progreso, todos los rangos (excepto quizás el rango más a la derecha) tienen un ancho dado.
  • En un rango de Registro hay cierta cantidad de rangos con un ancho en aumento o disminución logarítmica.
  • En un rango de Ancho equivalente hay una cierta cantidad de rangos de ancho equivalente.
  • En un rango Normal, el ancho de los rangos son los que se obtendrían para un rango de población equivalente si los datos subyacentes estuvieran distribuidos normalmente entre los valores de Rango de y Rango para: cuanto más cerca esté un rango del valor promedio del campo, más angosto será.
Nota:
  • Si hay valores a la izquierda del valor Rango de o a la derecha del valor Rango para, los registros que los contengan quedarán en rangos adicionales (que podrán estar clasificados como rangos finales o no [consulte la sección Rangos finales]).
  • Si marca la opción Rango cero por separado y hay un rango que contiene el valor 0, dicho rango se divide hasta en tres rangos: uno para los valores menores a 0, otro para el valor 0 y uno para los valores mayores que 0.

    Esta división es útil cuando el cero es un valor especial; por ejemplo, en el caso de clientes que tienen una cifra de gastos cero y pueden conformar un segmento distinto.


Opciones para mostrar un rango

Binning Editor muestra una vista gráfica del rango resaltado, aplicada a los datos del campo resaltado.

Puede modificar aspectos de esta vista estableciendo las opciones globales de presentación de Decision Studio [consulte la sección Para configurar opciones globales para la visualización gráfica] o mostrando u ocultando [consulte la sección Para mostrar u ocultar segmentos de valores nulos y sin clasificar en un gráfico] rangos de valores nulos o sin clasificar.

También puede afectar la presentación de un rango no categórico, tanto en Binning Editor como en cualquier otra parte, seleccionando entre las opciones de histograma y gráfico de barras [consulte la sección Opciones de histograma y gráfico de barras] del rango.

Además, Binning Editor muestra información numérica detallada acerca de un rango y la cantidad de registros presentes en cada rango.

También consulte

Para modificar una creación de rangos categóricos

Para modificar una creación de rangos no categóricos

Tema principal: Agrupación de los registros de los clientes creando rangos en el campo de un enfoque

Opciones de histograma y gráfico de barras

Además del tipo de rango y de los límites del rango que lo definen, cada rango tiene asociado un modo de presentación: ya sea histograma o gráfico de barras (este último es por defecto para rangos no categóricos y es la única opción para rangos categóricos).
  • En un histograma, cada rango (que no sea un rango final [consulte la sección Rangos finales], un rango de ancho cero, o un rango nulo [consulte la sección El valor null] o sin clasificar) tiene un ancho visual proporcional al ancho del intervalo subyacente. Binning Editor traza la densidad de probabilidad como la altura de una barra:

    Para un rango dado (que no sea un rango de ancho cero o un rango nulo o sin clasificar), puede calcular el recuento de registros multiplicando la cantidad total de registros, la densidad de probabilidad y el ancho del intervalo. % Pero no el ancho visual, que es distinto en los rangos finales. (Para rangos de fecha, el ancho de rango se mide en días).

    La presentación de histogramas es la que más se aproxima a un gráfico de la distribución de valores en un campo.

    Para ver un rango no categórico como histograma en Binning Editor, marque Ver>Histograma o seleccione [image] en la barra de herramientas.

  • En un gráfico de barras, todos los rangos tienen el mismo ancho visual (aunque el ancho de los intervalos subyacentes puede variar en un rango no categórico). Binning Editor traza el recuento de registros de cada rango como la altura de una barra.

    Cuando el ancho de los intervalos de un rango presenta una gran variación, la presentación de gráficos de barras muestra con mayor claridad los límites del rango y el recuento de registros.

    Para ver un rango no categórico como gráfico de barras en Binning Editor, quite la marca de Ver>Histograma o deseleccione [image] en la barra de herramientas.

Dado que el modo de presentación es una propiedad del rango en lugar de ser apenas una opción de visualización de Binning Editor, debe hacer su cambio permanente (haciendo clic en Aplicar) o descartar el cambio cuando pase a otro rango o cierre Binning Editor.
Nota:
  • El modo de presentación de un rango afecta las vistas gráficas en el Visor de Perfil y Visor de Distribución Cruzada: las divisiones en los ejes son del mismo ancho o proporcionales según el modo. La excepción ocurre cuando la extensión de un bloque en una dirección dada transmite información: en este caso, la configuración de presentación de Binning Editor no tiene efecto para no dar una idea equivocada.
  • En Binning Editor, en las vistas de histogramas y gráficos de barras, el área visual de un rango (que no sea un rango final, de ancho cero o un rango nulo o sin clasificar) es proporcional a la cantidad de registros del rango.


Para adjuntar un rango adicional a un campo no categórico

Puede adjuntar uno o más rangos a un campo no categórico en un enfoque, aunque en un momento dado, se puede acceder solamente a uno de ellos, el rango primario, para las herramientas de Decision Studio que no sean Binning Editor.
  1. En Binning Editor, si aún no está viendo el campo cuyos rangos desea crear, haga clic en la ficha Campos y resalte el campo.
  2. Seleccione Rangos>Administrar múltiples rangos o haga clic con el botón secundario del mouse en el panel Campos y seleccione Administrar múltiples rangos.
  3. En el cuadro de diálogo Administrar múltiples rangos, realice uno de los procedimientos siguientes:
    • Haga clic en Agregar.

      Binning Editor crea un nuevo rango, con los parámetros por defecto [consulte la sección Para establecer los parámetros por defecto para rangos no categóricos nuevos] para rangos no categóricos

    • Resalte un rango ya existente y haga clic en Duplicar.

      Binning Editor crea una copia del rango resaltado.

Nota:
  • Para utilizar el nuevo rango, debe convertirlo en el rango primario [consulte la sección Para establecer el rango primario de un campo no categórico] para el campo.
  • Para ayudarlo a recordar cuál es cual entre los rangos, puede asignarles nombres significativos: haga doble clic en el rango, dentro del cuadro de diálogo Administrar múltiples rangos.
Tema principal: Agrupación de los registros de los clientes creando rangos en el campo de un enfoque

Para establecer el rango primario de un campo no categórico

  1. En Binning Editor, si aún no está viendo el campo cuyos rangos desea crear, haga clic en la ficha Campos y resalte el campo.
  2. Seleccione Rangos>Administrar múltiples rangos o haga clic con el botón secundario del mouse en el panel Campos y seleccione Administrar múltiples rangos.
  3. En el cuadro de diálogo Administrar múltiples rangos, haga clic en Convertir en primario.


Aplicación de una creación de rangos a más de un campo

Se puede volver a usar una creación de rangos creándola en un campo y aplicándola a otros similares. Se puede hacer copiar y pegar [consulte Para copiar una creación de rangos a otro campo no categórico] en una creación de rangos no categóricos entre campos o guardarla en un archivo de creación de rangos [consulte Para guardar una creación de rangos no categóricos] y luego aplicar la creación de rangos [consulte Para aplicar una creación de rangos no categóricos a un nuevo campo] a otro campo. También se puede guardar una jerarquía de creación de rangos categóricos [consulte Para guardar una jerarquía de creación de rangos no categóricos] y luego aplicar la jerarquía [consulte Para aplicar una jerarquía de creación de rangos categóricos guardada a un nuevo campo] a otro campo.
Nota: Por lo general se aplica una creación de rangos o una jerarquía de creación de rangos categóricos guardadas a un campo en un enfoque distinto: para campos no categóricos en el mismo enfoque, copiar y pegar resulta más simple.
Tema principal: Agrupación de los registros de los clientes creando rangos en el campo de un enfoque

Para copiar una creación de rangos a otro campo no categórico

  1. En el Editor de creación de rangos, si ya no se encuentra observando el campo no categórico cuya creación de rangos desea copiar, haga clic en la pestaña Campos y resalte el campo.
  2. Seleccione Binning>Copiar rango, haga clic con el botón secundario del mouse en el panel Campos y seleccione Campos, o haga clic en [image] en la barra de herramientas.
  3. Resalte el campo al cual desea aplicar la creación de rangos.
  4. Seleccione Binning>Pegar rango, haga clic con el botón secundario del mouse en el panel Campos y seleccione Pegar rango, o haga clic en [image] en la barra de herramientas.

    El Editor de creación de rangos crea una copia de la creación de rangos, con el nombre el campo original.

Nota:
  • En lugar de pegar una creación de rangos a un único campo, se puede aplicarla simultáneamente a varios campos al seleccionar Pegar rango en múltiples campos en lugar de Pegar rango. En este caso, aparece el cuadro de diálogo Seleccionar campos para pegar, en el que se puede elegir un grupo de campos. El Editor de creación de rangos aplica una copia de los rangos a cada uno de los campos que usted elige.
  • Si ha usado la característica de creación de rangos múltiples de Decision Studio para adjuntar más de un rango a un campo, debe tener en cuenta que las opciones de Copiar rango y Pegar rango se aplican a los rangos primarios [consulte Para establecer el rango primario de un campo no categórico] asociados con ese campo.

Para guardar una creación de rangos no categóricos

  1. En el Editor de creación de rangos, si ya no se encuentra observando el campo no categórico cuyos rangos desea copiar, haga clic en la pestaña Campos y resalte el campo.
  2. Seleccione Archivo>Guardar como o haga clic en [image] en la barra de herramientas y seleccione una ubicación y un nombre para el archivo de rangos.

Para aplicar una creación de rangos no categóricos a un nuevo campo

  1. En el Editor de creación de rangos, si ya no se encuentra observando el campo no categórico donde se deben crear los rangos utilizando los rangos guardados, haga clic en la pestaña Campos y resalte el campo.
  2. Seleccione Archivo>Abrir o haga clic en [image] en la barra de herramientas.

    Los archivos de creación de rangos tienen extensiones .bng (o .qsbng).

Para guardar una jerarquía de creación de rangos no categóricos

  1. En el Editor de creación de rangos, si no se encuentra observando el campo cuya jerarquía de creación de rangos categóricos desea guardar, haga clic en la pestaña Campos y resalte el campo.
  2. Seleccione Archivo>Exportar [jerarquía categórica]\ y seleccione una ubicación y un nombre para el archivo de jerarquía de creación de rangos categóricos.

    Los archivos de jerarquía de creación de rangos categóricos tienen la extensión .hrc.

Para aplicar una jerarquía de creación de rangos categóricos guardada a un nuevo campo

  1. En el Editor de creación de rangos, si no se encuentra observando el campo donde se deben crear los rangos utilizando la jerarquía de creación de rangos categóricos guardada, haga clic en la ficha Campos y resalte el campo.
  2. Seleccione Archivo>Importar jerarquía categórica o haga clic en [image] en la barra de herramientas.
Nota:
  • Cuando se aplica a un campo una jerarquía de creación de rangos categóricos guardada, se sobrescriben todas las jerarquías de creación de rangos categóricos o no categóricos previas asociadas con el campo.
  • Si se aplica a un campo una jerarquía de creación de rangos categóricos guardada sin una interpretación categórica, Decision Studio aplica automáticamente una interpretación categórica al campo.


Para optimizar la creación de rangos de un campo

Se puede usar Binning Editor para encontrar una creación de rangos en bruto que se aproxime mejor a una creación de rangos precisa en términos de predecir un objetivo determinado. De este modo, se puede mejorar una scorecard o un árbol de decisión al mismo tiempo que se minimiza el riesgo de sobreadaptar el modelo a los datos.
  1. Verifique que el campo cuya creación de rangos desea optimizar se interprete como un candidato a análisis [consulte Interpretación de los campos] (o que no hayan candidatos a análisis en el enfoque).
  2. Verifique que el objetivo de modelado apropiado se configure
  3. Cree una scorecard . No cierre la ventana de Creador de scorecards.

    Al crear una scorecard, se asegura de que las estadísticas que se requieren para la optimización estén en su lugar.

  4. En Binning Editor, si todavía no ve el campo cuyos rangos desea optimizar, haga clic en la pestaña Campos y resalte el campo.
  5. Seleccione Rangos>Optimizar o haga clic en [image] en la barra de herramientas.

    Aparece el cuadro de diálogo Optimizar rango:

  6. Elija los rangos de origen, especificando si se deben usar los rangos actuales o los rangos de población igual o los rangos de rangos iguales con un número determinado de rangos.

    La creación de rangos de origen debe ser mucho más precisa que el resultado deseado, como guía, elija el número de rangos con los que quiere acabar multiplicado por diez.

  7. Haga clic en Crear rango de origen....

    El gráfico de  Binning Editor muestra la creación de rangos de origen que se eligió, codificada en colores con la tasa de coincidencia objetivo para cada rango.

  8. Elija el número de rangos internos y el tamaño mínimo de rango para los rangos objetivo.
  9. Haga clic en Optimizar.

    El gráfico en Binning Editor ahora muestra los rangos objetivo generados utilizando estos parámetros, nuevamente codificados por color con la tasa de coincidencia objetivo para cada rango.

  10. Haga clic en Aceptar si desea crear los rangos de este campo con estos rangos. (Luego se puede cerrar la ventana de Creador de scorecards).
Nota:
  • La optimización de rangos sólo funciona con rangos internos. Los rangos finales no se ven afectados.
  • Por defecto, Binning Editor usa la información como medida de calidad de cuánto se aproxima una creación de rangos en bruto a la creación inicial. Otra opción consiste en usar el menú desplegable del panel Optimization y elegir la medida Gini.
  • La optimización de la creación de rangos es un proceso iterativo: si no está satisfecho con los rangos de origen, en cualquier momento se pueden cambiar los parámetros en el panel Rango de origen y hacer clic nuevamente en Crear rango de origen; si no está satisfecho con los rangos objetivo, se pueden cambiar los parámetros en los paneles Rango objetivo y Optimization y luego hacer clic nuevamente en Optimizar.
  • Para un campo no categórico, cuando se hace clic en Accept, los nuevos rangos se convierten en los rangos primarios [consulte Para establecer el rango primario de un campo no categórico] para el campo. A menos que se marque Crear una copia del rango actual antes de aceptar los rangos, se sobrescriben los rangos primarios existentes.
Tema principal: Agrupación de los registros de los clientes creando rangos en el campo de un enfoque


Derivar nuevos campos en un enfoque

  • Para derivar un campo utilizando Visor de Tablas
  • Para derivar un campo desde un modelo o tabulación cruzada de Decision Studio
  • Campos asociados con árboles de decisión, scorecards, modelos de clústeres y tabulaciones cruzadas abstractas.
  • Para derivar un campo de una segmentación gráfica
  • Para derivar campos en un enfoque mediante el uso de Portrait Miner


Para derivar un campo utilizando Visor de Tablas

  1. Seleccione Derivar>Nuevo o haga clic en [image] en la barra de herramientas.

    Visor de Tablas crea inicialmente una columna Vista previa vacía a la derecha de la tabla.

  2. En el cuadro de texto recientemente resaltado a la izquierda del signo "=", ingrese un nombre para el nuevo campo.

    Seleccione un nombre de campo descriptivo, pero no demasiado largo. El nombre debe comenzar con una letra y no debe incluir ningún otro carácter que no sean letras, dígitos y guiones bajos. No debe coincidir con el nombre de otro campo en el enfoque.

  3. En el cuadro de texto a la derecha del signo "=", ingrese una expresión FDL o lista de expresiones [consulte Expressions (Expresiones)] para definir el campo en relación con los campos existentes.
  4. Seleccione Derivar>Calcular, haga clic en [image] en la barra de herramientas, o simplemente presione Volver.

    Visor de Tablas deriva el nuevo campo, que aparece en lugar de la columna Vista previa.

Nota:
  • Si la expresión o lista de expresiones es demasiado larga para adecuarse cómodamente a una única línea, puede utilizar el Editor de expresiones multilíneas: seleccione Derivar>Editar o haga clic en [image] en la barra de herramientas.
  • Para sobrescribir el tipo de datos por defecto [consulte la sección Tipos de datos] para un campo, abra el Editor de expresiones multilíneas para mostrar opciones de derivación adicionales.

    Aquí también puede definir una semilla [consulte la sección Sobre las funciones de números aleatorios en FDL] para cálculos de números aleatorios. Si no especifica una semilla, el sistema elige una por usted (en función del reloj del sistema) y la secuencia de resultados será diferente a distintas horas.

  • Si presiona la tecla Tab (varias veces) al ingresar una expresión de derivación, Visor de Tablas circula por posibles rellenos para la palabra actual, y considera nombres de funciones FDL y campos en el enfoque. Los rellenos de los nombres de funciones FDL incluyen los paréntesis y comas necesarios, cuando corresponda, para indicar el número necesario de argumentos. Si no ha escrito solo parte de una palabra, Tabla Viewer considera todos los nombres de funciones y campos como rellenos posibles.
  • Alternativamente, puede incluir cualquier nombre de campo desde el enfoque en una expresión de derivación si lo selecciona desde una lista: seleccione Derivar>Explorador de campos.
  • Si tiene dudas sobre la sintaxis exacta de una función FDL, o simplemente para guardar lo que escribió, seleccione Derivar>Explorador de funciones para obtener ayuda con la entrada de funciones [consulte la sección Ayuda en la entrada de funciones en Visor de Tablas].
  • Para derivar un campo según valores de otra tabla, utilice la función FDL dblookup.
  • Decision Studio genera valores para todos los registros independientemente de si una selección se aplica actualmente.

También consulte

Para derivar campos en un enfoque mediante el uso de Portrait Miner
Tema principal: Derivar nuevos campos en un enfoque

Ayuda en la entrada de funciones en Visor de Tablas

Cuando seleccione Derivar>Explorador de función o haga clic en [image] en el curso de introducir una expresión de derivación en Visor de Tablas, aparecerá el cuadro de diálogo Funciones de derivación. Si resalta una clase de funciones (o Todas) en el panel Familia de funciones, aparecerá una lista de las funciones FDL de esa clase (o todas las funciones FDL disponibles) en el panel Funciones.

Cuando resalta una función en el panel Funciones, aparecerá una breve descripción de la función. Para las funciones que no están incorporadas en FDL, haga clic en Detalles para ver una descripción más completa).

Puede ingresar los argumentos necesarios para la función en el panel Parámetros.

Debajo del panel de parámetros, puede ver la expresión FDL real que corresponde a su elección de función y parámetros. Cuando hace clic en Aceptar, Visor de Tablas pega esa expresión en su expresión de derivación en el cursor.

Nota:
  • Cuando utiliza el cuadro de diálogo Funciones de derivación para ingresar una función en la familia de funciones Agregación de campos, hay dos parámetros especiales ("where" y "by"), que no corresponden a los argumentos de la función real. En cambio, producen una sintaxis FDL especial para las funciones de agregación.

    El parámetro "where" es una expresión FDL de valor booleano [consulte la sección Datos booleanos] utilizado para seleccionar los registros para agregar. Si omite el parámetro, Decision Studio agrega todos los registros actualmente seleccionados en el enfoque.

    El parámetro "by" es un campo de desglose, o una lista separada por comas de campos de desglose. Para calcular el valor de la función de agregación para un registro, Decision Studio agrega registros que comparten el rango de registros para cada campo de desglose.

  • Cuando utiliza el cuadro de diálogo Funciones de derivación para ingresar la función FDL isselected, hay un parámetro especial ("expand"), que no corresponden con un argumento de la función actual. Cuando marca el cuadro para este parámetro, en lugar de generar la expresión isselected(), Visor de Tablas inserta una expresión que se evalúa en true solo para aquellos registros que están seleccionados en este momento.

    Ambas expresiones producen el mismo resultado, hasta que seleccione registros diferentes en el enfoque. A continuación, el resultado de la expresión isselected() cambiará, pero el resultado de la expresión expandida no presentará cambios.

Para editar una expresión de derivación utilizando Visor de Tablas

  1. Haga clic en el campo cuya expresión de derivación desee editar.
  2. Edite la expresión de derivación, de ser necesario a través del Editor de expresiones multilíneas.
  3. Seleccione Derivar>Calcular, haga clic en [image] en la barra de herramientas, o simplemente presione Volver.


Para derivar un campo desde un modelo o tabulación cruzada de Decision Studio

  1. Si se desea que un campo refleje segmentos seleccionados de un árbol de decisión, resalte los segmentos de interés [consulte Resaltado de segmentos en una presentación gráfica] en el Constructor de árboles de decisión.
  2. Realice uno de los procedimientos siguientes:
    • En el Constructor de árboles de decisión, seleccione Árbol>Generar campos.
    • En el Creador de scorecards, seleccione Scorecard>Generar campos.
    • En el Creador de clústeres, seleccione Clustering>Generar campos.
    • En el Visor de tabulación cruzada, Visor de perfil, Visor de distribución cruzada o Visor de mapa, seleccione Segmentos>Generar campos.
    • En cualquier herramienta de modelado o visor de gráficos, haga clic en [image] en la barra de herramientas.
    A Aparece el cuadro de diálogo Generar resultados.
  3. Verifique qué campos de resultados [consulte Campos asociados con árboles de decisión, scorecards, modelos de clústeres y tabulaciones cruzadas abstractas.] desea generar y cambie los nombres de los campos si es necesario.
  4. Haga clic en Aceptar.

    Decision Studio genera los campos de resultados en el enfoque.

Nota:
  • Cada campo de resultados se marca como campo derivado y tiene asociada una definición FDL que puede verse o editarse [consulte Para derivar un campo utilizando Visor de Tablas] con el Visor de tabla. Hay instrucciones en el texto de derivación que lo ayudarán a realizar análisis simples del tipo "qué pasaría si...".
  • Decision Studio genera valores para todos los registros independientemente de si una selección se aplica actualmente.

También consulte

Para construir un modelo de clústeres

Para crear un árbol de decisiones

Para crear una vista de tabulación cruzada textual

Para derivar un campo de una segmentación gráfica

Para guardar un modelo o una segmentación de Decision Studio para la implementación como QMML (XML)

Tema principal: Derivar nuevos campos en un enfoque


Campos asociados con árboles de decisión, scorecards, modelos de clústeres y tabulaciones cruzadas abstractas.

Los siguientes campos de resultados capturan distintos aspectos de los árboles de decisión, tabulaciones cruzadas abstractas, scorecards y modelos de creación de clústeres:
Campo | Se aplica a | Descripción
Índice de segmento | Cualquier árbol de decisión o tabulación cruzada abstracta | El número identificador del segmento en el que entra un registro, considerando solo los resúmenes de segmentos (nivel inferior, sin secundarios) en el árbol de decisión
Segmentos seleccionados | Cualquier árbol de decisión o visor gráfico | 1 para registros en los segmentos resaltados, 0 para los demás registros
Relación de coincidencia | Árbol binario | La relación de coincidencia original para el resumen de segmentos en el que entra un registro, es decir la proporción de registros (entre 0 y 1) en el segmento que coincide con el objetivo (ignorando los registros con nulo [consulte El valor null] en el campo objetivo)
Resultado predicho | Árbol binario o scorecard continua | Para un árbol de decisión: el índice de rango en el valor original más común en el objetivo para el resumen de segmentos en el que entra un registro: por lo general 1 para el valor 0, 2 para el valor 1, y 3 para nulo [consulte El valor null] Para una scorecard: el resultado que se computa aplicando la scorecard , equivalente al valor predicho del objetivo
Decisión | Árbol binario o scorecard binario | Para un árbol de decisión: 1 si la relación de coincidencia original para el segmento en el que entra un registro está por encima del nivel umbral [consulte Para definir el umbral de decisión para un árbol de decisión] para el árbol; de lo contrario 0. Para una scorecard: 1 para registros con resultado por encima del resultado de corte [consulte Para establecer el resultado de corte para una scorecard] para la scorecard; 0 para otros registros
Categoría más popular | Árbol categórico | El índice de rango de la categoría original más común en el objetivo para el segmento en el que entra un registro
Media objetivo | Árbol continuo | El valor medio original del objetivo para el resumen de segmentos en donde entra un registro
Alza como diferencia | Alza binaria + árbol | El alza original, es decir, la relación de coincidencia original para la población tratada menos la de la población de control, para el segmento en el que entra un registro
Alza como cociente | Alza binaria x árbol | La relación de alza original (es decir, la relación de coincidencia original para la población tratada dividida por la de la población de control) para el segmento en el que entra un registro (si la relación de coincidencia para la población de control es igual a cero, el registro se asigna a un número positivo muy grande).
Alza de la media | Árbol de alza continua | El alza original, es decir, la media original del objetivo para la población tratada menos la de la población de control, para el segmento en el que entra un registro
Resultado | Scorecard binaria | El resultado que se computa aplicando la scorecard
Probabilidades | Scorecard binaria | Las probabilidades de valores predeterminados, respuestas, cancelaciones o estar satisfecho o insatisfecho, dadas por [image] , donde s es la clasificación y a y b son el punto de probabilidades y el factor de duplicación [consulte Para establecer la relación resultado/probabilidades para una scorecard] respectivamente
Probabilidad | Scorecard binaria | Las probabilidades de cálculo por defecto, respuesta, cancelación de clientes, satisfacción o insatisfacción dadas por
Índice de clúster | Modelo de clúster | El número de identificación de un clúster [consulte Para construir un modelo de clústeres] en el que entra un registro (o nulo [consulte El valor null] para un registro en el clúster nulo [consulte El valor nulo en la creación de clústeres]) (Se aplica una creación de rangos categórica y al valor -1 se le asigna una categoría llamada "valor atípico").
Distancia de clúster | Modelo de clúster | La distancia normalizada [consulte Cómo mediar el tamaño y la separación de los clústeres] entre un registro y el centro del clúster en el que entra
Separación de clúster | Modelo de clúster | La medida de separación para un registro, dada por [image] , donde [image] es la distancia al centro de cluster más cercano y [image] es la distancia al segundo centro de cluster más cercano
Nota:
  • En la tabla precedente el término "original" indica que para los árboles de decisión, los valores en ciertos campos generados corresponden a la población en la que se basó el árbol de decisión, en lugar de corresponder a cualquier población a la que se los aplica después.
  • El campo de índice de segmentos para una tabulación cruzada abstracta tiene en cuenta todos los campos de desglose en la tabulación cruzada, incluido cualquiera que el visor enumere actualmente en la barra [image] (Información únicamente).
  • El campo de segmentos seleccionados para tabulaciones cruzadas abstractas sólo está disponible cuando se guarda un modelo para su implementación en los visores gráficos.

También consulte

Para derivar un campo desde un modelo o tabulación cruzada de Decision Studio

Para guardar un modelo o una segmentación de Decision Studio para la implementación como QMML (XML)

Tema principal: Derivar nuevos campos en un enfoque

Para definir el umbral de decisión para un árbol de decisión

En el Constructor de árbol de decisión, modifique el umbral de decisión de relación de coincidencia, la tasa de aceptados o la tasa de rechazados en el panel por debajo de la barra de herramientas:

Los valores legítimos para estos tres parámetros son los que aparecen en la vista de ganancias [consulte Opciones para la visualización de un árbol de decisiones] del árbol de decisión.

Cuando se ingresa un valor para el umbral de decisión o la tasa de rechazados, el valor real (que se muestra en el cuadro no editable a la derecha) es el valor legítimo más cercano por encima del valor que se ingresa. Para la tasa de aceptados, el valor real es el valor legítimo más cercano por debajo del valor que se ingresa. El Constructor de árboles de decisión ajusta los demás valores como corresponde.

Para establecer el resultado de corte para una scorecard

En el Creador de scorecards, modifique el resultado de corte, la tasa de aceptados (tasa objetivo) o tasa de defectuosos (tasa de llamada) utilizando el panel por debajo de la barra de herramientas.

El Creador de scorecardsajusta los demás valores como corresponde.

Nota:
  • No se puede definir un resultado de corte para una scorecard construida con un objetivo continuo: en un modelo de valor, no se está tomando una decisión por sí/no.
  • El valor por defecto es determinado por las preferencias del Creador de scorecards en corte, tasa de defectuosos y tasa de aceptación.

Para establecer la relación resultado/probabilidades para una scorecard

  1. En el Creador de scorecards, elija Scorecard>Formulario.
  2. En el panel Cambiando de tamaño del cuadro de diálogo de la Formulario de Scorecard modifique el punto de probabilidades y el factor de duplicación según se requiera:
    • El punto de probabilidades es el resultado que corresponde a las probabilidades de 1.
    • Cuando se suma el factor de duplicación a un resultado, la probabilidad correspondiente se duplica (para un modelo de respuesta o de cancelación, en el caso de un modelo de riesgo, las probabilidades se dividen por la mitad).
  3. Haga clic en Aceptar.
Nota:
  • Estas opciones no están disponibles cuando se usa un objetivo continuo dado que no existe un concepto de probabilidades asociado a las scorecards continuas.
  • Cuando se cambia el punto de probabilidades o el factor de duplicación, el nuevo valor no se aplica hasta la siguiente creación de una scorecard.


Para derivar un campo de una segmentación gráfica

Puede derivar un campo 0/1 a partir de una segmentación gráfica para indicar la inclusión o la exclusión de los segmentos seleccionados.
  1. En Visor de Perfil, Visor de Distribución Cruzada, Visor de Mapa o Creador de árboles de decisión, resalte segmentos que sean de su interés [consulte la sección Resaltado de segmentos en una presentación gráfica].
  2. Seleccione Segmentos>Marca seleccionada o haga clic en [image] en la barra de herramientas.

    Aparecerá un cuadro de diálogo Nuevo nombre de campo.

  3. Ingrese un nombre para el archivo derivado y haga clic en Aceptar.

    Decision Studio crea un nuevo campo, con 1 en registros que quedan en los segmentos resaltados y 0 que quedan en otros registros.

Nota:
  • El nuevo campo se marca como campo derivado y tiene una definición FDL asociada que puede ver o editar [consulte la sección Para derivar un campo utilizando Visor de Tablas] utilizando el Visor de Tablas.
  • El nuevo campo se interpreta como categórico [consulte la sección Interpretación de los campos], con los nombres de categoría "No seleccionado" y "Seleccionado" para los valores 0 y 1 respectivamente.

También consulte

Crear un gráfico en un mapa

Para crear un gráfico de distribución cruzada con variables múltiples

Para crear un conjunto de gráficos de perfil de una sola variable

Para derivar un campo desde un modelo o tabulación cruzada de Decision Studio

Para guardar un modelo o una segmentación de Decision Studio para la implementación como QMML (XML)

Tema principal: Derivar nuevos campos en un enfoque


Para derivar campos en un enfoque mediante el uso de Portrait Miner

Puede derivar campos mediante el uso de un conjunto de definiciones de campo en un archivo de derivaciones.
Para derivar campos en un enfoque, utilice una de las siguientes opciones:
  • En Portrait Miner, haga clic con el botón secundario del mouse en el enfoque del que desea derivar campos y seleccione Transformar>Derivar campos.
  • En Portrait Miner, haga clic con el botón secundario del mouse en un archivo de derivaciones y seleccione Derivar campos.

En el cuadro de diálogo Derivar campos, seleccione un archivo de derivaciones que incluya las definiciones de campos. Como opción, si seleccionó un archivo de derivaciones, seleccione un enfoque. También puede cambiar la ubicación del nuevo enfoque o seleccionar que se sobrescriba un enfoque de salida creado anteriormente.

Nota: Esta interfaz de usuario es una forma de acceder a muchas de las funciones proporcionadas por el comando de creación de datos qsderive de Portrait Miner.

También consulte

Acerca de los asistentes de Portrait Miner

Para derivar un campo utilizando Visor de Tablas

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Visualización y edición de archivos de texto en Portrait Miner

Tema principal: Derivar nuevos campos en un enfoque


Cambiar el nombre y borrar campos en un enfoque

  • Par cambiar el nombre de un campo con el Visor de tablas
  • Cómo cambiar el nombre de un campo agregando un prefijo o sufijo
  • Para eliminar un campo


Par cambiar el nombre de un campo con el Visor de tablas

  1. Haga clic en el campo cuyo nombre desea cambiar.
  2. En el cuadro de diálogo a la izquierda del signo "=" ingrese un nuevo nombre de campo y presione Intro.

    El nombre debe comenzar con una letra y no debe incluir ningún otro carácter que no sean letras, dígitos y guiones bajos. No debe coincidir con el nombre de otro campo en el enfoque.

Cuando se cambia el nombre de un campo, se invalidan todos los campos derivados (incluyendo a los campos generados por modelos) cuyas expresiones de derivación involucran al nombre original del campo.
Nota:
  • No se puede cambiar el nombre de un campo si está siendo usado por una herramienta de Decision Studio.

También consulte

Cómo cambiar el nombre de un campo agregando un prefijo o sufijo

Tema principal: Cambiar el nombre y borrar campos en un enfoque


Cómo cambiar el nombre de un campo agregando un prefijo o sufijo

Se puede cambiar el nombre de uno o más campos en un enfoque agregando un prefijo o sufijo común a los nombres de los campos.
  1. En Portrait Miner, haga clic con el botón derecho en el enfoque a cuyos campos desea cambiar el nombre y seleccione Transformar>Cambiar nombres de campos. Aparece el cuadro de diálogo Cambiar nombres de campos.
  2. Opcionalmente, se puede cambiar la ubicación de enfoque de salida.
  3. Siga uno de los siguientes procedimientos o los dos:
    • Elija la cadena que desea agregar como prefijo.
    • Elija la cadena que desea agregar como sufijo.
  4. Elija uno o más campos a los que desea cambiar el nombre.
  5. Haga clic en Aceptar.
Nota:
  • El nombre resultante no debe entrar en conflicto con el nombre de otro campo en el enfoque.
  • El cuadro de diálogo Cambiar nombres de campos es un modo de acceder a la mayor parte de la funcionalidad provista por el comando de creación de datos qsrenamefields de Portrait Miner .

También consulte

Acerca de los asistentes de Portrait Miner

Par cambiar el nombre de un campo con el Visor de tablas

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Tema principal: Cambiar el nombre y borrar campos en un enfoque


Para eliminar un campo

  1. Haga clic en el campo que desea eliminar.
  2. En la ventana de Decision Studio, elija Campo>Eliminar o haga clic con el botón derecho en el campo y elija Eliminar.
  3. En Visor de Tablas, seleccione Campo>Eliminar o haga clic en [image] en la barra de herramientas. También puede eliminar un campo si hace clic con el botón secundario del mouse en el encabezado del campo y selecciona Eliminar.
Nota:
  • No se puede eliminar un campo si está siendo usado por una herramienta de Decision Studio.
  • También se puede eliminar un campo en la ventana de Decision Studio mediante Campo>Eliminar o al seleccionar Eliminar al hacer clic con el botón secundario en un campo.

También consulte

Para elegir los campos que desea ver

Par cambiar el nombre de un campo con el Visor de tablas

Tema principal: Cambiar el nombre y borrar campos en un enfoque


Cómo trabajar con metadatos de enfoque

  • Metadata del enfoque
  • Etiquetas de visualización de campo
  • Interpretación de los campos
  • Adjuntar un comentario a un enfoque o un campo utilizando Decision Studio
  • Visualización de metadata del enfoque y el campo
  • Copiar metadata de un enfoque a otro
  • Edición de metadatos de enfoque en Excel


Metadata del enfoque

Metadata es "datos acerca de datos". Además de los datos sin procesar de un cliente que se importan de una base de datos o se crean tomando medidas de transacción, un enfoque contiene metadata. Parte de esta metadata corresponde a la totalidad del enfoque, mientras que otra parte corresponde a campos individuales del enfoque.

Metadata asociada con la totalidad del enfoque

  • La cantidad de registros y campos en un enfoque
  • Los comandos de creación de datos utilizados para crear el enfoque (si se creó utilizando comandos de creación de datos)
  • Un comentario opcional

Metadata asociada con un campo en el enfoque

  • El nombre y tipo de datos del campo [consulte la sección Tipos de datos]
  • Cualquier etiqueta de visualización [consulte la sección Etiquetas de visualización de campo] asociada con el campo
  • Cualquier etiqueta de usuario [consulte la sección Etiquetas de usuario] asociada con el campo
  • Cualquier interpretación [consulte la sección Interpretación de los campos] asociada con el campo
  • Cualquier rango asociado con el campo
  • Cualquier selección de registro [consulte la sección Selección de registros de clientes] basada en valores del campo
  • La expresión [consulte la sección Acerca del lenguaje de derivación de campos (FDL)] utilizada para definir el campo (si el campo está derivado)
  • Cualquier comentario asociado con el campo
  • Un registro de importación del campo al (unido al) enfoque desde otra fuente de datos (si corresponde)
  • Los valores máximos y mínimos del campo
  • La cantidad de veces que aparece el valor null [consulte la sección El valor null] en el campo
Nota: Las relaciones entre las herramientas en una sesión de Decision Studio no están almacenadas en un archivo de enfoque.

También consulte

Adjuntar un comentario a un enfoque o un campo utilizando Decision Studio

Copiar metadata de un enfoque a otro

Creación de un perfil y auditoría de un enfoque

Visualización de metadata del enfoque y el campo

Tema principal: Cómo trabajar con metadatos de enfoque


Etiquetas de visualización de campo

A veces no es conveniente o posible editar el nombre de un campo. Sin embargo, algunas de las pantallas de Decision Studio pueden mostrar etiquetas de visualización en lugar del nombre del campo. Las herramientas que trabajan con las etiquetas de visualización son Visor de Distribución Cruzada, Visor de Tabulación Cruzada, Visor de Perfil, Visor de Mapa y Creador de árboles de decisión.

La ventana de Decision Studio tiene una columna Etiqueta de visualización que muestra la etiqueta de visualización que se utilizará para cada campo. Nota: La columna Etiqueta de visualización es opcional y puede mostrarse si hace clic en Editar>Diseño de columna.

Tema principal: Cómo trabajar con metadatos de enfoque

Para editar la etiqueta de visualización de un campo

  1. En la ventana de Decision Studio, resalte el campo.
  2. Haga clic por segunda vez en el campo Etiqueta de visualización para editar el nombre directamente. Como opción, si está resaltada la entrada de la etiqueta de visualización, puede:
    • Seleccionar Campo>Propiedades, o
    • Hacer clic con el botón secundario y seleccionar Propiedades, o
    • Hacer clic en [image] en la barra de herramientas.

También consulte

Funciones de agregación para tabulaciones cruzadas
Nota:
  • A diferencia de los nombres de campos, no hay restricciones de caracteres en las etiquetas de visualización.
  • Las etiquetas de visualización se guardan en el enfoque y se pueden importar y exportar juntos con los otros elementos de metadata.
  • Las etiquetas de visualización no se pueden utilizar en expresiones en FDL.


Interpretación de los campos

En Decision Studio, puede asociar una o más de las siguientes interpretaciones a un campo:

Interpretación de un campo | Significado
Objetivo | El campo es el objetivo de modelo y de visualización en el enfoque.
Partición | El campo es el campo de partición tratado o de control para un análisis de uplift. El primer rango o categoría (generalmente el valor 0) indica el segmento de control y el segundo rango o categoría (generalmente el valor 1) indica el segmento tratado.
Candidato para análisis | El campo es candidato para ser utilizado en modelos de Creador de árboles de decisión, Creador de scorecards y Creador de Clusters.
Categórico | Los valores en un campo conforman un conjunto discreto y desordenado. En los cuadros de diálogo de Binning Editor, Creador de árboles de decisión, Creador de Clusters y Seleccionar valores los campos categóricos reciben un tratamiento distinto al resto de los campos.
Geográfica | El campo está asociado a un mapa, de modo que puede usarlo en Visor de Mapa.
Exportar | El campo debe incluirse por defecto al exportar segmentos a un archivo o tabla de base de datos. (Generalmente, es un identificador único, por ejemplo, un número de cliente.)
Clave | El campo está asociado a Portrait Explorer e identifica el campo clave. Solo puede tener un campo clave.
Nota:
  • Un enfoque contiene un campo con interpretación de objetivo o un campo con interpretación de partición.
  • Si no hay candidatos de análisis en un enfoque, Creador de árboles de decisión, Creador de scorecardsy Creador de Clusters considerarán a todos los campos apropiados candidatos para el análisis.
  • De la misma manera, si no hay campos con interpretación de exportación en un enfoque, Decision Studio considera a todos los campos de exportación.
  • En Creador de scorecards, puede interpretar un campo como una "ponderación". Este tipo de interpretación es específica de Creador de scorecardsy no forma parte de metadata del enfoque.
Tema principal: Cómo trabajar con metadatos de enfoque

Para establecer o borrar una interpretación categórica, geográfica, de candidato para análisis, de exportación o de clave

  1. En la ventana de Decision Studio, resalte los campos con las interpretaciones que desea cambiar.
  2. Seleccione Etiqueta>Interpretaciones en el menú principal y, a continuación, seleccione Candidato para análisis [image], Categórica [image], Geográfica [image], Exportación [image] o Clave [image]). Como opción, haga clic con el botón secundario en el campo y seleccione la interpretación ( [image], [image], [image], [image] o [image]). Se mostrará el icono correspondiente en la columna Interpretaciones del campo.
Nota:
  • Puede configurar interpretaciones de campo en el Visor de Tablas, desde el menú Etiqueta>Interpretaciones, o haciendo clic con el botón secundario del mouse en el nombre del campo (título de la columna).
  • Para quitar una interpretación, selecciónela por segunda vez utilizando los pasos mencionados.

Para configurar o borrar el campo de objetivo o de partición en un enfoque

  1. En la ventana de Decision Studio, resalte el campo que desea configurar como campo de objetivo o de partición.
  2. Seleccione Etiqueta>Interpretaciones en el menú principal y, a continuación, seleccione Objetivo ( [image]) o Partición ( [image] ). Como opción, haga clic con el botón secundario en el campo y seleccione la interpretación ( [image] o [image]). Se mostrará el icono correspondiente en la columna Interpretaciones del campo.
Nota:
  • Si ya ha configurado un campo de objetivo o de partición, y luego quiere interpretar otro campo de esa manera, Decision Studio elimina la interpretación original.
  • Para quitar la interpretación de objetivo o de partición de un campo sin asignarla a otro campo, resalte el campo y seleccione nuevamente la opción adecuada del menú Etiqueta>Interpretaciones.


Adjuntar un comentario a un enfoque o un campo utilizando Decision Studio

Puede agregar descripciones y otros comentarios a un enfoque y a campos individuales dentro de un enfoque. Esta información puede ser útil cuando se comparten conjuntos de datos con otras personas, o incluso cuando se vuelve a trabajar con el conjunto de datos de un análisis después de un tiempo.
En la ventana de Decision Studio:
  • Para agregar un comentario al enfoque, seleccione Enfoque>Editar comentarios del enfoque.
  • Para agregar un comentario al campo, haga clic en el campo Comentario y escriba su comentario. Como opción, puede:
    • resaltar el campo requerido y elegir Campo>Propiedades
    • hacer clic con el botón secundario y elegir Propiedades o hacer clic en [image] en la barra de herramientas.

Los comentarios de los campos aparecen en la columna Comentarios en la ventana de Decision Studio. Los comentarios de campo y de enfoque también aparecen en otros lugares [consulte la sección Visualización de metadata del enfoque y el campo].

Nota:
  • Si marca el cuadro HTML, Decision Studio considera a los pares equilibrados de etiquetas, por ejemplo <b>...</b>, como marcado HTML, y muestra los comentarios correspondientes.

También consulte

Metadata del enfoque
Tema principal: Cómo trabajar con metadatos de enfoque


Visualización de metadata del enfoque y el campo

La ventana de Decision Studio muestra metadata del enfoque [consulte la sección Metadata del enfoque], incluida la estadística de campo principal. Puede seleccionar la presentación de otra información utilizando el menú Editar>Diseño de columna; sus selecciones se visualizarán en la sesión actual y en las sesiones futuras de Decision Studio.

La columna Interpretaciones muestra letras que corresponden a las interpretaciones de campos [consulte la sección Interpretación de los campos] que han sido aplicadas al campo. Las siguientes letras también pueden aparecer en la columna Interpretaciones:

Cartas | Significado
B | El campo tiene un rango asociado a él.
D | El campo tiene un campo derivado.
J | El campo fue importado al (unido al) enfoque desde otra fuente de datos.

La columna Comentarios muestra cualquier comentario [consulte la sección Adjuntar un comentario a un enfoque o un campo utilizando Decision Studio] asociado con campos.

Nota: Para mejorar la eficiencia, la ventana de Decision Studio no actualiza las estadísticas constantemente. Cuando las estadísticas de campo están desactualizadas, se verán de color gris en la ventana de Decision Studio.
  • Para actualizar las estadísticas de un solo campo, resalte ese campo y seleccione Campo>Actualizar estadísticas, o haga clic con el botón secundario del mouse en el campo y seleccione Actualizar estadísticas.
  • Para actualizar las estadísticas de todos los campos en el enfoque, seleccione Enfoque>Actualizar todas las estadísticas.
Tema principal: Cómo trabajar con metadatos de enfoque

Para visualizar información de un enfoque en Decision Studio

En la ventana de Decision Studio, seleccione Enfoque>Información de enfoque.

Aparecerá una ventana mostrando la información básica del enfoque y su historial. Cualquier comentario [consulte la sección Adjuntar un comentario a un enfoque o un campo utilizando Decision Studio] asociado con el enfoque también aparecerá.

Para visualizar información de un campo en Decision Studio

En la ventana de Decision Studio, resalte un campo y seleccione Campo>Propiedades, o haga clic con el botón secundario del mouse y seleccione Propiedades, o haga clic en [image] en la barra de herramientas.

Para visualizar información de un campo o un enfoque en Portrait Miner

En Portrait Miner, haga clic con el botón secundario del mouse en un enfoque y seleccione Metadata>Mostrar.

En el cuadro de diálogo Mostrar información de enfoque, puede seleccionar la cantidad de información de campo que desea incluir.

Aparecerá luego una ventana mostrando la información básica del enfoque y su historial. Cualquier comentario [consulte la sección Adjuntar un comentario a un enfoque o un campo utilizando Decision Studio] asociado con el enfoque también aparecerá.

La información de los campos (si se solicita) aparecerá debajo de la información del enfoque. Si decide visualizar información de campo detallada, esto incluirá estadísticas de campo, así como también cualquier comentario relacionado con los campos.

Nota: Este cuadro de diálogo Mostrar información de enfoque es una manera de acceder a muchas de las funciones que ofrece el comando de creación de datos qsdescribe de Portrait Miner.

También consulte

Acerca de los asistentes de Portrait Miner

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Para ver dependencias y tamaños de archivo para un enfoque

Un enfoque se guarda en el disco como un archivo .ftr (el "archivo de enfoque") junto con un conjunto de archivos de datos y otros archivos en dos carpetas, con nombres que terminan en .rdx ("Raw Data eXtract") y .xtr ("eXTRa"). Las carpetas suelen estar ocultas en Portrait Miner y en la ficha "Quadstone" del explorador de archivos de Portrait Miner [consulte Exploración para abrir o guardar un archivo o tabla de base de datos].

Un nuevo enfoque que se crea al copiar un enfoque existente o importar datos de otra clase de conjunto de datos (o como resultado de la ejecución de una secuencia de comandos TML) es independiente de otros enfoques. Por otro lado, un enfoque que se guarda de Decision Studio con un nombre nuevo, o uno que se crea al crear una copia enlazada depende de carpetas de datos que pertenecen a otros enfoques.

Para un enfoque determinado, puede averiguar de cuáles otros enfoques depende, cuáles enfoques dependen de él y la cantidad de espacio que ocupa en el disco para guardar los datos y metadata: en Portrait Miner, haga clic con el botón secundario del mouse en el enfoque y seleccione Propiedades.

En el diálogo Mostrar propiedades de enfoque, puede elegir guardar el informe de las propiedades del enfoque como un archivo XML o HTML. Las propiedades del enfoque también se muestra en la ficha Salida, en el formato seleccionado para el archivo de salida.

Nota: Esta interfaz de usuario es una manera de acceder a muchas de las funciones que ofrece el comando de creación de datos qsinfo de Portrait Miner.

También consulte

Acerca de los asistentes de Portrait Miner

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos


Copiar metadata de un enfoque a otro

Puede copiar metadata [consulte la sección Metadata del enfoque] de un enfoque a otro, incluidas las definiciones de campos derivados, interpretaciones de campos, rangos, selecciones de registros, comentarios de campo y enfoque e historial de un enfoque.

Una manera de hacerlo es guardando los metadata de enfoque en un archivo y aplicando ese archivo a otro enfoque. Otra manera es utilizar un enfoque como "plantilla" de metadata para otro enfoque.

Nota: Cuando aplica una plantilla de metadata a un enfoque, los comentarios de campo y enfoque no se incluyen. Tampoco se puede aplicar una plantilla de metadata a un enfoque objetivo si este ya tiene interpretaciones, selecciones o rangos de campo.

También consulte

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos
Tema principal: Cómo trabajar con metadatos de enfoque

Para guardar metadata de un enfoque

en la ventana de Decision Studio, seleccione Enfoque>Exportar metadata y explore [consulte la sección Exploración para abrir o guardar un archivo o tabla de base de datos] para seleccionar una ubicación en la cual guardar el archivo de metadata de enfoque.

Para exportar metadata de un enfoque usando Portrait Miner

En Portrait Miner, haga clic con el botón secundario del mouse en el enfoque y seleccione Metadata>Exportar.

Aparecerá el cuadro de diálogo Exportar metadata. Puede seleccionar una ubicación para el archivo de metadata guardado (o puede simplemente aceptar la opción por defecto).

Nota: Esta interfaz de usuario es una manera de acceder a las funciones que ofrece el comando de creación de datos qsexportmetadata de Portrait Miner (y tiene exactamente el mismo efecto que al guardar metadata de Decision Studio).

Para aplicar metadata guardada en un nuevo enfoque

En Portrait Miner, realice uno de los procedimientos siguientes:
  • Haga clic con el botón secundario del mouse en el archivo de metadata de enfoque (.qsfm) y seleccione Importar como metadata a enfoque.

    En el cuadro de diálogo Importar metadata para enfoque, seleccione el enfoque objetivo.

  • Haga clic con el botón secundario del mouse en el enfoque objetivo y seleccione Metadata>Importar.

    En el cuadro de diálogo Importar metadata para enfoque, seleccione el archivo de metadata de enfoque.

Puede elegir exactamente el tipo de metadata que desea importar y cambiar el objetivo para el enfoque. Una vez definidos los parámetros, haga clic en Siguiente para importar los detalles.
Nota:
  • A menos que seleccione explícitamente campos específicos, Portrait Miner importa metadata relacionada con campos para todos los campos del enfoque.
  • El comportamiento por defecto es sobrescribir el enfoque objetivo con un enfoque que contiene metadata seleccionada. Si desactiva la casilla de verificación correspondiente, podrá especificar la ubicación para un nuevo enfoque.
  • Al importar metadata, las interpretaciones categóricas se clasifican como rangos, no como interpretaciones.
  • Esta interfaz de usuario es una manera de acceder a muchas de las funciones que ofrece el comando de creación de datos qsimportmetadata de Portrait Miner.

También consulte

Acerca de los asistentes de Portrait Miner


Edición de metadatos de enfoque en Excel

Se pueden editar metadatos de enfoque [consulte Metadata del enfoque] en Excel, incluso etiquetas de campo, interpretaciones, etiquetas, derivaciones y comentarios.
  1. Exportar un archivo de metadatos [consulte Para guardar metadata de un enfoque] desde un enfoque. Para un conjunto de datos recién importados, esta será una plantilla en blanco y para un conjunto de datos con los que se ha trabajado contendrá todas las etiquetas, rangos, derivaciones y otros detalles que se hayan agregado.
  2. Para crear un archivo Excel para editar, haga clic con el botón derecho en el archivo de metadatos y seleccione Importar a Excel.
  3. Para editar los metadatos en Excel, haga clic con el botón derecho en el archivo Excel y seleccione Enviar a Excel. Dentro del archivo Excel hay más detalles sobre cómo editar los metadatos.
  4. Para crear un archivo de metadatos de enfoque, haga clic con el botón derecho en el archivo Excel y seleccione Exportar como Quadstone Focus Metadata.
Tema principal: Cómo trabajar con metadatos de enfoque


Cómo trabajar con grupos de campos

  • Grupos de campos etiquetados
  • Etiquetas de usuario


Grupos de campos etiquetados

Se pueden administrar grupos de campos de acuerdo con las etiquetas agregadas a un campo.
Tema principal: Cómo trabajar con grupos de campos

Etiquetas

Una etiqueta puede ser una etiqueta de usuario o una interpretación. Cada etiqueta de usuario está representada por un marcador de color que contiene su letra inicial. Los colores de los marcadores se generan automáticamente.
La tabulación Etiquetas a la izquierda de la ventana de Decision Studio muestra las etiquetas actuales. Cada etiqueta se muestra en una fila separada con:
  • Un indicador de estado y un menú desplegable que permite controlar si se deben mostrar o no los campos con esta etiqueta:
    • Sin preferencia: Los campos que tienen esta etiqueta pueden mostrarse o no, en función de las selecciones realizadas para otras etiquetas.
    • Mostrar los campos con esta etiqueta: Los campos que tengan esta etiqueta se mostrarán a menos que también tengan una etiqueta configurada para que estén ocultos. Los campos que no tengan esta etiqueta permanecerán ocultos a menos que una de sus etiquetas también esté configurada para que se muestren.
    • Ocultar siempre los campos con esta etiqueta: Los campos que tienen esta etiqueta estarán ocultos aunque el campo tenga otra etiqueta que esté configurada para que se muestre.
  • Para las etiquetas de usuario, su marcador de color.
  • El nombre de la etiqueta.
  • Entre paréntesis, el número de campos que tienen esta etiqueta. En el caso de la interpretación Derivado, este texto también muestra el número de campos recién creados si estos están ocultos.
Cuando se inicia una herramienta, los campos que se muestran dentro de ella están basados en lo que muestra la ventana de Decision Studio en ese momento. Sin embargo, la mayoría de las listas de campos en la aplicación también tienen una casilla de verificación Todos los campos de enfoque que permite ver todos los campos sin importar la vista en la ventana de Decision Studio.
  • Creador de scorecardssiempre muestra los campos con la interpretación Análisis. Los campos que se muestran en la ventana de Decision Studio no tienen efecto sobre esto.
  • Creador de árboles de decisión y Creador de clusters muestran los campos con la interpretación Análisis así como también todos los campos que aparecen en la ventana de Decision Studio pero no tienen interpretación Análisis cuando se inician. Además, todos los campos que tuvieron una interpretación Análisis cuando se inició la herramienta, pero a los que se les quitó la interpretación, seguirán mostrándose.
  • Los visores (Visor de Tabulación Cruzada, Visor de Mapa, Visor de Distribución Cruzada y Visor de Perfil) muestran todos los campos que están actualmente visibles en la ventana de Decision Studio, además de todos los que se han usado en la especificación de tabulación cruzada durante la vida útil de la herramienta.
Nota: Si se está usando un enfoque con un gran número de campos, configure una vista que sea de su interés en la ventana de Decision Studio antes de iniciar las herramientas.

También consulte

Etiquetas de usuario

Interpretación de los campos

Cómo mostrar u ocultar campos en Decision Studio

Haga clic en el menú de estado de las etiquetas para elegir qué grupo de campos se muestra o se oculta. De modo alternativo se puede hacer clic directamente en los íconos de estado para circular por los tres estados disponibles.

El número de campos que se muestran actualmente y el número total de los campos se muestran en una barra de estado en la parte inferior de la ventana.

Nota: Cuando se inicia Decision Studio o cuando se carga un enfoque, todas las etiquetas tienen un estado Sin preferencia, por lo que se muestran todos los campos.

Para mostrar todos los campos

Para restablecer a vista por defecto, donde todas las etiquetas se configuran para Sin preferencia y se muestran todos los campos, haga clic en cualquier lugar de la ficha Etiquetas y seleccione Mostrar todos los campos.


Etiquetas de usuario

En Decision Studio se pueden asignar etiquetas a los campos, y según estas etiquetas se pueden mostrar u ocultar esos campos. Una etiqueta es simplemente una palabra que se asocia con un campo. Un campo puede tener varias etiquetas y una etiqueta puede estar asociada con varios campos.
Tema principal: Cómo trabajar con grupos de campos

Para crear un etiqueta

  1. En la ventana de Decision Studio, resalte los campos que desea etiquetar.
  2. Haga clic con el botón secundario y seleccione Agregar etiqueta de usuario > Nueva o, como opción, seleccione Etiqueta > Nueva o Etiqueta > Agregar etiqueta de usuario > Nueva en el menú principal.
  3. Ingrese el nombre para la etiqueta y haga clic en Aceptar. Nota: Es conveniente evitar nombres de etiquetas que comiencen con la misma letra para asegurar que cada etiqueta obtenga una letra distinta en la columna Etiquetas de usuario dentro de la ventana de Decision Studio.
  4. Seleccione de las opciones de Etiquetar estos campos:
    • Ninguno para crear una etiqueta que no está asociada con ningún campo.
    • Campos seleccionados para crear una etiqueta y agregarla a los campos resaltados actualmente en la ventana de Decision Studio.
    • Campos que coinciden con la expresión regular para crear una etiqueta y agregarla a los campos que coinciden con una expresión regular. Por ejemplo, la expresión regular .*Código coincide con todos los campos que terminan en código.
  5. Haga clic en Aceptar.

También consulte

Expresiones regulares

Para eliminar una etiqueta

  1. En la ventana de Decision Studio, haga clic con el botón secundario en la etiqueta de la sección Usuario del panel Etiqueta.
  2. Seleccione Eliminar en el menú.

Para cambiar el nombre de una etiqueta

  1. En la ventana de Decision Studio, haga clic con el botón secundario en la etiqueta de la sección Usuario del panel Etiqueta.
  2. Seleccione Cambiar nombre en el menú.

Para agregar un campo a un grupo con etiqueta

  1. En la ventana de Decision Studio, resalte los campos que desea etiquetar.
  2. Seleccione Agregar etiqueta de usuario haciendo clic con el botón secundario en los campos resaltados o desde el menú Etiqueta.
  3. Haga clic en la etiqueta deseada. Nota: Cuando el campo o los campos ya tienen etiqueta, el nombre aparece en color gris.

Para quitar un campo de un grupo con etiqueta

  1. En la ventana de Decision Studio, resalte los campos cuya etiqueta desee borrar.
  2. Seleccione Borrar etiqueta haciendo clic con el botón secundario del mouse en los campos resaltados o desde el menú Etiqueta.
  3. Haga clic en el nombre de la etiqueta. Cuando ninguno de los campos tiene la etiqueta, el nombre aparece en gris.
Nota: Una etiqueta que no está asociada a ningún campo no se guarda en el enfoque.

Para ver etiquetas de campo

  1. En la ventana de Decision Studio, resalte un campo.
  2. Seleccione Campo>Propiedades, haga clic con el botón secundario y seleccione Propiedades o haga clic en [image] en la barra de herramientas.

Para editar etiquetas de expresiones regulares

Si ha creado una etiqueta de expresión regular, puede actualizar la expresión regular y volver a aplicarla en relación con todos los campos.

  1. En la ventana de Decision Studio, haga clic con el botón secundario en la etiqueta de expresión regular en el panel Usuario (menú izquierdo).
  2. Seleccione Editar y actualice el nombre o la expresión regular.
  3. Haga clic en Aceptar. El sistema vuelve a aplicar la expresión regular a todos los campos.
Nota: La opción de edición solo está disponible en la sesión actual. Al volver a cargar un enfoque guardado, la etiqueta de expresión regular está disponible, pero ya no puede editar los valores.


Resumir, segmentar y visualizar datos de enfoque usando tabulación cruzada.

  • Tabulaciones cruzadas como la base para la segmentación y visualización de datos
  • Funciones de agregación para tabulaciones cruzadas
  • Para crear una vista de tabulación cruzada textual
  • Organización de campos y estadísticas en una tabulación cruzada o gráfico
  • Para mostrar más detalles de un segmento seleccionado de un gráfico
  • Para aplicar una tabulación cruzada a un enfoque


Tabulaciones cruzadas como la base para la segmentación y visualización de datos

Decision Studio utiliza tabulaciones cruzadas de resumen como la base, no solo para las vistas de tabulaciones cruzadas, sino también para los gráficos de perfil, distribución cruzada y mapas.

Una tabulación cruzada en este sentido comprende cero o más campos de desglose, junto con una o más estadísticas. Las estadísticas se evalúan para cada celda de posible segmentación multidimensional definida por los rangos en los campos de desglose.

Una vez que haya especificado una tabulación cruzada de resumen y se hayan calculado las estadísticas, puede organizar los campos y las estadísticas [consulte la sección Organización de campos y estadísticas en una tabulación cruzada o gráfico] según lo desee dentro de la vista o gráfico de tabulación cruzada tabular.

También consulte

Funciones de agregación para tabulaciones cruzadas
Tema principal: Resumir, segmentar y visualizar datos de enfoque usando tabulación cruzada.

Para especificar los campos y las estadísticas en una tabulación cruzada

  1. En Visor de Tabulación Cruzada, Visor de Perfil, Visor de Distribución Cruzada o Visor de Mapa, seleccione Editar>Editar la tabulación cruzada o haga clic en [image] en la barra de herramientas.

    Aparece el cuadro de diálogo Seleccionar campos y funciones de agregación.

  2. Resalte los campos de desglose necesarios en el panel Campos disponibles y haga clic en [image] para agregar los campos resaltados al panel Campos seleccionados.
  3. Para cada estadística requerida:
    1. Resalte la función de agregación [consulte la sección Funciones de agregación para tabulaciones cruzadas] en el panel Funciones disponibles.
    2. Si la función de agregación incorpora un argumento, resalte el campo requerido en el panel Parámetros de la función.
    3. Haga clic en [image] para agregar la estadística al panel Funciones de agregación seleccionadas.

    (En realidad, puede resaltar varias funciones de agregación o campos al mismo tiempo. En ese caso, cuando haga clic en [image], obtendrá todas las combinaciones válidas de funciones/campos como estadísticas).

  4. Haga clic en Aceptar para crear la tabulación cruzada.
Nota:
  • Si el visor sigue [consulte la sección Relaciones entre herramientas] otro visor (excepto en el caso de Visor de Perfil que sigue otra clase de visor o viceversa), puede marcar Usar especificación líder para que el siguiente visor herede la especificación de tabulaciones cruzadas de resumen del visor líder (junto con los datos resaltados del segmento).

    La opción Usar especificación líder está seleccionada por defecto (cuando corresponda) si desglosa [consulte la sección Para mostrar más detalles de un segmento seleccionado de un gráfico] mediante el uso del menú Segmentos>Informe detallado.

  • La barra Tamaño estimado en el cuadro de diálogo le ofrece una indicación aproximada del tamaño que tendrá la tabulación cruzada en relación con los datos. Si la barra rellena el espacio disponible, probablemente la tabulación cruzada será muy grande para evaluarse o el acceso a ella demorará mucho tiempo.

    Puede cambiar el límite del tamaño de la tabulación cruzada si configura una preferencia [consulte la sección Para configurar las preferencias de Portrait Miner]: en la sección Agregación, cambie el valor para la opción tamaño máx. (Portrait Miner utiliza este valor cuando calcula la tabulación cruzada. No obstante, la barra Tamaño estimado no lo utiliza para su estimación).

  • Para quitar un campo o estadística del panel Campos seleccionados o Funciones de agregación seleccionadas, resalte el campo o la estadística y haga clic en [image] a la derecha del panel.

Para guardar una tabulación cruzada de Decision Studio

Si desea volver a utilizar una tabulación cruzada textual, un gráfico de distribución cruzada o un gráfico de mapas, o compartirlo con alguien que no tenga acceso completo a Portrait Miner, puede guardar la tabulación cruzada de resumen subyacente (incluidas las estadísticas evaluadas).
  1. Seleccione Archivo>Guardar como o haga clic en [image] en la barra de herramientas.
  2. Explore [consulte la sección Exploración para abrir o guardar un archivo o tabla de base de datos] hasta la ubicación requerida y seleccione un nombre para la tabulación cruzada.

Cada visor de Decision Studio guarda su propia clase de tabulación cruzada (con una extensión de nombre de archivo única), que puede abrir en uno o más visores de Decision Studio o Visores de resultados. (También puede utilizar la extensión del nombre de archivo .qsxt para una tabulación cruzada genérica).

Visor de Decision Studio | Extensión del nombre de archivo | Visores compatibles con Decision Studio
Crosstab Viewer | .qstv | Visor de Tabulación Cruzada, Visor de Mapa y Visor de Distribución Cruzada
Crossdistribution Viewer | .qsdv | Visor de Tabulación Cruzada, Visor de Mapa y Visor de Distribución Cruzada
Profile Viewer | .qspv | Profile Viewer
Map Viewer | .qsmv | Visor de Tabulación Cruzada, Visor de Mapa y Visor de Distribución Cruzada
Any | .qsxt | Depende del tipo de tabulación cruzada real

También consulte

Exportación de datos tabulares de Decision Studio

Para aplicar una tabulación cruzada a un enfoque

Para abrir una tabulación cruzada en Decision Studio

Para guardar un modelo o una segmentación de Decision Studio para la implementación como QMML (XML)

XML en Portrait Miner

Para abrir una tabulación cruzada en Decision Studio

Si desea abrir una tabulación cruzada textual guardada anteriormente, un gráfico de distribución cruzada, un conjunto de gráficos de perfil o un gráfico de mapas, puede cargar la especificación de tabulación cruzada de resumen subyacente, que se aplicará luego al enfoque actual.
  1. Seleccione Archivo>Abrir o haga clic en [image] en la barra de herramientas.
  2. Explore [consulte la sección Exploración para abrir o guardar un archivo o tabla de base de datos] hasta el archivo de la tabulación cruzada requerida.
Nota:
  • Los campos de desglose y las estadísticas que no son compatibles con el enfoque actual no se cargan.
  • Cuando todos los campos de desglose y las estadísticas son compatibles con el enfoque actual, el diseño de la tabulación cruzada guardado [consulte la sección Organización de campos y estadísticas en una tabulación cruzada o gráfico] también se carga.

También consulte

Para guardar una tabulación cruzada de Decision Studio
© 2015 Pitney Bowes Software Inc. Email: software.support@pb.com


Funciones de agregación para tabulaciones cruzadas

Las siguientes funciones de agregación están disponibles para su uso en tabulaciones cruzadas de resumen [consulte la sección Tabulaciones cruzadas como la base para la segmentación y visualización de datos] en Decision Studio. Excepto en el caso de que se indique lo contrario, una función de agregación toma un campo único numérico, de cadena o de fecha como un argumento.

En la mayoría de las pantallas, las funciones se vuelven a etiquetar con etiquetas de pantalla. Las etiquetas pueden editarse en la ficha Etiquetas de función al editar las preferencias de visualización a través de Editar en la ventana de Decision Studio. Las preferencias de visualización se recuerdan para las futuras sesiones de cada usuario. Las etiquetas de funciones no se guardan con el enfoque.

También consulte

Etiquetas de visualización de campo
Función | Etiqueta por defecto | Resultado
Any [consulte la sección any] | Valor de muestra de | Valor no nulo en el campo, derivado de un registro no nulo arbitrario en el segmento
ConfIntLower [consulte la sección confintlower] | Límite 95% más bajo que | Límite más bajo de un intervalo de confianza del 95% para la media del campo en el segmento
ConfIntUpper [consulte la sección confintupper] | Límite 95% más alto que | Límite más alto de un intervalo de confianza del 95% para la media del campo en el segmento
Count [consulte count] | Cantidad | Cantidad de registros en el segmento (Esta función no incorpora un argumento).
CountNonNull [consulte la sección countnonnull/countnonnulls] | No falta la cantidad | Cantidad de registros en el segmento para el cual el campo tiene valores no nulos [consulte la sección El valor null]
CountNull [consulte la sección countnull/countnulls] | Falta la cantidad | Cantidad de registros en el segmento para el cual el campo incluye valores nulos [consulte la sección El valor null]
CountUnique [consulte la sección countunique] | Valor distinto de | Cantidad de valores únicos que se dan en el campo, posiblemente incluido el valor nulo
CountUniqueNonNull [consulte la sección countuniquenonnull] | Valores definidos no faltantes de | Cantidad de valores únicos, sin incluir el valor nulo, que se dan en el campo
ExpectedCount [consulte la sección expectedcount] | Cantidad esperada | Cantidad de registros que se esperan en el segmento si los campos de la tabulación cruzada eran independientes entre sí (Esta función no incorpora un argumento).
ExpectedProportion [consulte la sección expectedproportion] | Proporción esperada | Proporción de la población que se espera en el segmento si los campos de la tabulación cruzada eran independientes entre sí (Esta función no incorpora un argumento).
First [consulte la sección first] | Primer valor de | Primer valor no nulo en el campo para el segmento
Last [consulte la sección last] | Último valor de | Último valor no nulo en el campo para el segmento
Max [consulte la sección max (un argumento)] | Maximum (máximo) | Valor no nulo máximo en el campo para el segmento
Mean [consulte la sección mean (un argumento)] | Average (promedio) | Media (promedio común) de los valores no nulos en el campo para el segmento (Esta función requiere un campo numérico como argumento).
Median [consulte median] | Mediana | Media (valor del medio) de los valores no nulos en el campo para el segmento (Esta función requiere u campo numérico o de cadena como argumento).
Min [consulte la sección min (un argumento)] | Minimum (mínimo) | Valor no nulo mínimo en el campo para el segmento
Mode [consulte la sección mode] | Más común | Modo (valor más común) de los valores no nulos en el campo para el segmento
ModeRatio [consulte la sección moderatio] | Pureza de | Proporción de registros no nulos en el segmento que incluyen el valor no nulo más común en el campo
PercentageRate [consulte la sección percentagerate] | Porcentaje de | Porcentaje de registros no nulos en el segmento que incluyen el valor 1 en el campo. El campo incluye solo los valores 0 y 1.
Proporción [consulte la sección proportion] | Proporción | Número de registros en el segmento, como proporción del número total de registros (Esta función no incorpora un argumento).
SegmentIndex (segindex) [consulte segindex] | Índice de segmento | Número positivo que identifica en forma única el segmento dentro de la tabulación cruzada (Esta función no incorpora un argumento).
Significance [consulte la sección significance] | Importancia de | Importancia estadística de cualquier discrepancia entre el valor medio del campo en el segmento y el valor medio del campo para toda la población, con un signo que indica la dirección de la desviación (Esta función requiere un campo numérico como argumento.
StandardDeviation (stdev) [consulte la sección stdev] | Desviación estándar de | Desviación estándar de los valores no nulos en el campo para el segmento (Esta función requiere un campo numérico como argumento).
Sum [consulte la sección sum (un argumento)] | Suma de | Suma de los valores no nulos en el campo para el segmento (Esta función requiere un campo numérico como argumento).
Variance [consulte la sección variance] | Varianza de | Varianza de los valores no nulos en el campo para el segmento (Esta función requiere u campo numérico como argumento).
Nota: Determinadas funciones de agregación (por ejemplo, Media y Modo) pueden producir resultados de cadena o de fecha, cuando las aplica a campos de cadena o de fecha. Dado que los visores gráficos no pueden mostrar estadísticas de cadena o de fecha, no puede aplicar estas funciones a campos de cadena o de fecha en el Visor de Tabulación Cruzada (que puede mostrar estadísticas de cadena y de fecha).
Tema principal: Resumir, segmentar y visualizar datos de enfoque usando tabulación cruzada.


Para crear una vista de tabulación cruzada textual

  1. En la ventana de Decision Studio, resalte uno o más campos que desee utilizar en su tabulación cruzada.
  2. Seleccione Herramientas>Visor de Tabulación Cruzada o haga clic en [image] en la barra de herramientas.

    Se abrirá el Visor de Tabulación Cruzada y se mostrará una tabla, desglosada por los campos resaltados, de recuentos de registros y valores promedio de un objetivo numérico , si hay uno establecido.

Nota:
  • Si inicia Visor de Tabulación Cruzada sin resaltar ningún campo, aparecerá el cuadro de diálogo Seleccionar campos y funciones de agregación [consulte la sección Tabulaciones cruzadas como la base para la segmentación y visualización de datos]. Si luego hace clic en Aceptar sin seleccionar ningún campo, Visor de Tabulación Cruzada le muestra un resumen de estadísticas de toda la población.
  • Para cambiar la tabulación cruzada subyacente [consulte la sección Tabulaciones cruzadas como la base para la segmentación y visualización de datos] en cualquier momento, seleccione Editar>Editar tabulación cruzada o haga clic en [image] en la barra de herramientas.
  • Si hay campos en cualquier cadena en la tabulación cruzada solicitada y no tienen interpretación categórica o no categórica ni geográfica, Visor de Tabulación Cruzada le solicita que los interprete, de manera que puedan ser distribuidos en rangos adecuadamente. Puede seleccionar la interpretación categórica por defecto, utilizar una jerarquía categórica guardada o interpretar el campo como geográfico.

También consulte

Para abrir una tabulación cruzada en Decision Studio

Organización de campos y estadísticas en una tabulación cruzada o gráfico

Tema principal: Resumir, segmentar y visualizar datos de enfoque usando tabulación cruzada.

Vistas de tabulación cruzada

Por defecto, Visor de Tabulación Cruzada incluye todos los campos como encabezados de fila [image], la única excepción es que si usted resalta exactamente dos campos en la ventana de Decision Studio antes de abrir Visor de Tabulación Cruzada, a partir de los dos, Visor de Tabulación Cruzada crea un encabezado de fila y un encabezado de columna.

Cuando hay encabezados de filas y de columnas, solo hay espacio para mostrar una estadística tabulada a la vez; si hay más de uno, el Visor de Tabulación Cruzada tabula cada estadística en su propio panel tabulado:

Del mismo modo que los rangos normales de los campos de desglose, existen tres rangos extraordinarios: el rango nulo [consulte la sección El valor null], el rango sin clasificar y el rango especial con tabulación cruzada resumen, que contiene todos los registros del cliente. Así, por ejemplo, los registros que se encuentran en el rango de edad entre 50 y 59 años y el resumen del rango Sexo son simplemente los registros que se encuentran en el rango de edad entre 50 y 59 años. En la práctica, esto significa que cuando se incluyen rangos de resúmenes en la vista de tabulación cruzada, se puede leer la información de toda tabulación cruzada posible que incluya cualquiera de los tres campos de desglose.

Visor de Tabulación Cruzada cuenta con las siguientes opciones de vista:

  • Seleccione Ver>Datos de nulos o haga clic en [image] en la barra de herramientas, para activar o desactivar la visualización de rangos nulos.
  • Seleccione Ver>Datos de resumen o haga clic en [image] en la barra de herramientas, para activar o desactivar la visualización de rangos de resúmenes.
Nota:

Si bien todo rango contiene uno para el valor nulo, no todos los rangos contienen un rango sin clasificar.

También consulte

Para maximizar el espacio de la pantalla para una herramienta de Decision Studio

Para configurar el formato de visualización para valores numéricos y de fecha


Organización de campos y estadísticas en una tabulación cruzada o gráfico

Puede organizar campos y estadísticas mediante el uso del área de configuración de gráficos en la parte inferior de Visor de Tabulación Cruzada, Visor de Perfil, Visor de Distribución Cruzada o Visor de Mapa:

  • Los campos y las estadísticas presentes en la tabulación cruzada subyacente [consulte la sección Tabulaciones cruzadas como la base para la segmentación y visualización de datos] están representados como botones móviles, por ejemplo:

  • La barra [image] (Información únicamente) en la parte inferior del área de configuración de gráficos muestra campos y estadísticas que forman parte de la tabulación cruzada subyacente, pero que no se muestran en la tabla o el gráfico que se visualizan.
  • Las partes verdes ( [image]) del área de configuración de gráficos representan aspectos de la tabulación cruzada o del gráfico con los que puede asociar los campos:
    Icono Aspecto de gráfico o tabulación cruzada
    eje x (izquierda — derecha), en Visor de Distribución Cruzada o Visor de Perfil
    eje y (adelante — atrás) , en Visor de Distribución Cruzada
    eje z (vertical), en Visor de Distribución Cruzada
    Dimensión de comparación de segmentos tratados/de control, en Visor de Distribución Cruzada o Visor de Tabulación Cruzada; comúnmente para su uso con un campo de partición
    Campo de desglose de filas, en Visor de Tabulación Cruzada
    Campo de desglose de columnas, en Visor de Tabulación Cruzada
    Ubicación para bloques graficados y regiones elevadas, en Visor de Mapa
    Ubicación para los inicios de flechas, en Visor de Mapa
    Ubicación para los finales de flechas, en Visor de Mapa
  • Las partes lilas ( [image]) del área de configuración de gráficos representan aspectos de la tabulación cruzada o del gráfico con los que puede asociar las estadísticas:
    Icono Aspecto de gráfico o tabulación cruzada
    Color del bloque (color del bloque, región o flecha en Visor de Mapa)
    Altura del bloque (altura del bloque o región en Visor de Mapa)
    Bloquear ancho
    Bloquear profundidad
    Bloquear volumen
    Estadísticas tabuladas, en Visor de Tabulación Cruzada
    Grosor de una flecha, en Visor de Mapa
Tema principal: Resumir, segmentar y visualizar datos de enfoque usando tabulación cruzada.

Para asociar un campo o estadística con un aspecto de un gráfico o una tabulación cruzada

Arrastre el campo o la estadística (es decir, el botón móvil correspondiente en el área de configuración del gráfico) y colóquelo al lado del icono del aspecto del gráfico o tabulación cruzada deseado.

Al arrastrar un campo o estadística, el puntero del mouse cambia para mostrar lo que sucederá cuando se suelte el botón del mouse:

Puntero | Acción
 | Asocie el campo o la estadística con el aspecto de un gráfico o una tabulación cruzada.
 | Intercambie el campo o la estadística arrastrada y el campo o estadística debajo del puntero del mouse.
 | No haga nada.
Nota:
  • Puede asociar una estadística con más de un aspecto de un gráfico creando un botón móvil extra para la estadística: haga clic con el botón secundario del mouse en la estadística y seleccione Duplicar.

    Para quitar una estadística duplicada, arrastre una copia sobre la otra; suelte cuando el puntero del mouse cambia a

    Puede duplicar un campo de la misma manera en el Visor de Mapa, para usar simultáneamente con flechas y bloques o regiones trazados.

  • Si hace clic con el botón secundario del mouse en un botón móvil que represente un campo, puede iniciar el Binning Editor para editar los rangos, o un cuadro de diálogo Seleccionar valores para cambiar el registro de selección. Estas operaciones se pueden realizar en todo el conjunto de datos, no solo en la vista actual.
  • Si hace clic con el botón secundario del mouse en un botón móvil que represente un campo o una estadística, también aparece la opción de filtrar valores del gráfico. Este es un filtro que aparece solo en la vista actual. Si selecciona Filtro, aparecerá un cuadro de diálogo Filtro. Hay diferentes opciones para los filtros categóricos [consulte la sección Selección de valor o filtrado usando un campo categórico] y los filtros no categóricos [consulte la sección Selección o filtrado de valores utilizando un campo o estadística no categórico].

    No puede agregar, editar ni quitar un filtro si hay un segmento del gráfico resaltado. Decision Studio quita todos los filtros cuando se actualiza el gráfico o la tabulación cruzada.

  • Cuando utiliza la dimensión de comparación ( [image]), a menudo con un campo de partición, puede configurar las funciones de comparación que se visualizan. Haga clic con el botón secundario del mouse en una estadística y seleccione Configuración delta. En el cuadro de diálogo Configurar los tipos de función delta, puede seleccionar incluir todos los registros, los registros tratados, los registros de control, o una de las tantas proporciones y diferencias. En Visor de Distribución Cruzada, las leyendas de los ejes y las escalas de color están anotadas en consecuencia.

Para quitar un campo o una estadística de una tabulación cruzada o un gráfico

Arrastre el campo o la estadística (es decir, el botón móvil correspondiente) de su ubicación actual hasta la barra de [image].


Para mostrar más detalles de un segmento seleccionado de un gráfico

En Visor de Perfil, Visor de Distribución Cruzada o Visor de Mapa realice uno de los procedimientos siguientes:
  • Haga doble clic en un segmento. (Para ver más detalles de varios segmentos, resáltelos [consulte la sección Resaltado de segmentos en una presentación gráfica] y mantenga presionada la tecla CTRL mientras hace doble clic en el último segmento).

    Decision Studio abre otro visor del mismo tipo, con la misma especificación de tabulación cruzada [consulte la sección Tabulaciones cruzadas como la base para la segmentación y visualización de datos].

  • Resalte uno o más segmentos [consulte la sección Resaltado de segmentos en una presentación gráfica] que sean de su interés. Desde el menú Segmentos>Informe detallado, seleccione una herramienta en la que desee realizar el perfil de los segmentos seleccionados: el Visor de Tabulación Cruzada, Visor de Perfil, Visor de Distribución Cruzada o Visor de Mapa.

    Si selecciona el Visor de Perfil de entre los otros tres visores, o viceversa, debe especificar los campos y las estadísticas [consulte la sección Para especificar los campos y las estadísticas en una tabulación cruzada] que requiere en el perfil del segmento. En todos los demás casos, Decision Studio utiliza la misma especificación de tabulación cruzada [consulte la sección Tabulaciones cruzadas como la base para la segmentación y visualización de datos].

En cualquier caso, el nuevo visor está vinculado [consulte la sección Relaciones entre herramientas] con el visor original y el gráfico recién creado muestra más detalles de los segmentos resaltados (siempre que sea posible).

Nota:
  • Si resalta nuevos segmentos en el primer gráfico, el segundo gráfico se actualiza en consecuencia.
  • El mismo comportamiento de informe detallado se aplica a todos los pares de herramientas presentes en una relación de seguimiento de herramientas [consulte la sección Relaciones entre herramientas].
  • En el Visor de Mapa, el nivel de detalles disponible depende del mapa.
Tema principal: Resumir, segmentar y visualizar datos de enfoque usando tabulación cruzada.


Para aplicar una tabulación cruzada a un enfoque

Puede aplicar una especificación de tabulación cruzada [consulte Tabulaciones cruzadas como la base para la segmentación y visualización de datos] a un enfoque para crear una nueva tabulación cruzada.
  • En Portrait Miner, haga clic con el botón secundario del mouse en la tabulación cruzada que desee aplicar y seleccionar Aplicar al enfoque.

En el diálogo Aplicar tabulación cruzada, elija la tabla cruzada que desea aplicar, el enfoque donde desea aplicarla y el archivo de tabla cruzada que desea crear.

Nota:
  • Por defecto, al aplicar una tabla cruzada a un enfoque, los rangos de los campos de desglose se obtienen del nuevo enfoque. Si selecciona la casilla que corresponde, puede utilizar los rangos de la tabla cruzada original.
  • Esta interfaz de usuario es una manera de acceder a muchas de las funciones que ofrece el comando de creación de datos qsxt de Portrait Miner.

También consulte

Acerca de los asistentes de Portrait Miner

Para abrir una tabulación cruzada en Decision Studio

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Visualización y edición de archivos de texto en Portrait Miner

Tema principal: Resumir, segmentar y visualizar datos de enfoque usando tabulación cruzada.


Visualizar y segmentar datos de enfoque en forma gráfica

  • Para crear un conjunto de gráficos de perfil de una sola variable
  • Para crear un gráfico de distribución cruzada con variables múltiples
  • Crear un gráfico en un mapa
  • Para crear un mapa de categorías a partir de una jerarquía de creación de rangos categóricos.
  • Opciones que afectan la visualización de gráficos y árboles de decisiones
  • Creación de un perfil y auditoría de un enfoque


Para crear un conjunto de gráficos de perfil de una sola variable

  1. En la ventana de Decision Studio, resalte uno o más campos que desee utilizar para realizar el perfil de sus datos.
  2. Seleccione Herramientas>Visor de Perfil o haga clic en [image] en la barra de herramientas.

    Se abre Visor de Perfil y muestra un gráfico de recuentos de registro por rango de cada uno de los campos seleccionados.

Nota:
  • Si se establece un objetivo numérico en el enfoque, Visor de Perfil le muestra la media del objetivo como un color de bloque (a menos que haya cambiado la preferencia de función de objetivo).
  • Si inicia Visor de Perfil sin resaltar ningún campo, aparecerá el cuadro de diálogo Seleccionar campos y funciones de agregación [consulte la sección Tabulaciones cruzadas como la base para la segmentación y visualización de datos].
  • Para cambiar la tabulación cruzada subyacente [consulte la sección Tabulaciones cruzadas como la base para la segmentación y visualización de datos] en cualquier momento, seleccione Editar>Editar tabulación cruzada o haga clic en [image] en la barra de herramientas.
  • Si hay campos en cadena en la tabulación cruzada requerida y no tienen interpretación categórica ni geográfica, Visor de Perfil le solicita que los interprete, de manera que puedan ser distribuidos en rangos adecuadamente. Puede seleccionar la interpretación categórica por defecto, utilizar una jerarquía categórica guardada o interpretar el campo como geográfico.
  • Puede asociar [consulte la sección Organización de campos y estadísticas en una tabulación cruzada o gráfico] múltiples estadísticas con la altura de bloque para comparar estadísticas similares en un conjunto de ejes de cada campo con perfil generado.

    Mientras no haya una estadística asociada con el color de bloque, Visor de Perfil utiliza distintos colores para distinguir los gráficos superpuestos asociados con las diferentes estadísticas.

  • Si asocia varias estadísticas con la altura del bloque, debe asegurarse de que los gráficos estén en escala conjuntamente [consulte la sección Para poner a escala un conjunto de gráficos de perfil de manera conjunta o independiente]; de lo contrario, no podrá comparar valores para las distintas estadísticas.

También consulte

Para abrir una tabulación cruzada en Decision Studio

Organización de campos y estadísticas en una tabulación cruzada o gráfico

Opciones de histograma y gráfico de barras

Opciones que afectan la visualización de gráficos y árboles de decisiones

Para orientar la presentación gráfica con el mouse

Para poner a escala un conjunto de gráficos de perfil de manera conjunta o independiente

Tema principal: Visualizar y segmentar datos de enfoque en forma gráfica


Para crear un gráfico de distribución cruzada con variables múltiples

  1. En la ventana de Decision Studio, resalte uno o más (generalmente dos o más) campos que desee utilizar para desglosar los datos.
  2. Seleccione Herramientas>Visor de Distribución Cruzada o haga clic en [image] en la barra de herramientas.

    Se abre Visor de Distribución Cruzada y muestra un trazado de los recuentos de registros en los segmentos definidos por los campos que usted seleccionó.

Nota:
  • Visor de Distribución Cruzada representa el recuento de registros mediante la altura del bloque por defecto si resalta uno o dos campos de desglose, mientras que utiliza el volumen del bloque si resalta tres campos de desglose.
  • Si resalta más de tres campos de desglose, el Visor de Distribución Cruzada solamente usa tres de ellos inicialmente, y el resto aparece en la barra [image] (Información únicamente), en la parte inferior de la ventana.
  • Si se establece un objetivo numérico en el enfoque, Visor de Distribución Cruzada le muestra la media del objetivo como un color de bloque (a menos que haya cambiado la preferencia de función de objetivo).
  • Si ha establecido un campo de partición en el enfoque, Visor de Distribución Cruzada lo incluye en la tabulación cruzada y lo asigna a la dimensión de comparación [consulte la sección Organización de campos y estadísticas en una tabulación cruzada o gráfico] ( [image]). Para conocer una estadística que incluya Recuento, Media, PercentageRate o Suma, Visor de Distribución Cruzada muestra la estadística para la población tratada menos la estadística para la población de control. Para todas las demás estadísticas, Visor de Distribución Cruzada muestra la estadística para toda la población. Puede cambiar la comparación que se muestra [consulte la sección Para asociar un campo o estadística con un aspecto de un gráfico o una tabulación cruzada].
  • Si inicia Visor de Distribución Cruzada sin resaltar ningún campo, aparecerá el cuadro de diálogo Seleccionar campos y funciones de agregación [consulte la sección Tabulaciones cruzadas como la base para la segmentación y visualización de datos].
  • Para cambiar la tabulación cruzada subyacente [consulte la sección Tabulaciones cruzadas como la base para la segmentación y visualización de datos] en cualquier momento, seleccione Editar>Editar tabulación cruzada o haga clic en [image] en la barra de herramientas.
  • Si hay algún campo de cadena en la tabulación cruzada solicitada y no tiene una interpretación categórica ni geográfica, Visor de Distribución Cruzada le solicita que los interprete, de manera que puedan ser distribuidos en rangos adecuadamente. Puede seleccionar la interpretación categórica por defecto, utilizar una jerarquía categórica guardada o interpretar el campo como geográfico.

También consulte

Para abrir una tabulación cruzada en Decision Studio

Organización de campos y estadísticas en una tabulación cruzada o gráfico

Opciones de histograma y gráfico de barras

Opciones que afectan la visualización de gráficos y árboles de decisiones

Para orientar la presentación gráfica con el mouse

Tema principal: Visualizar y segmentar datos de enfoque en forma gráfica


Crear un gráfico en un mapa

  1. En la ventana de Decision Studio, asocie uno o más campos con un mapa interpretándolos como campos geográficos (si aún no tienen un icono Geográfico [image] junto a ellos, en la columna Interpretaciones):
    1. Resalte los campos que se asociarán con un mapa.
    2. Seleccione Etiqueta>Interpretación>Geográfica.

      Aparecerá un explorador de archivos de Portrait Miner [consulte la sección Exploración para abrir o guardar un archivo o tabla de base de datos].

    3. Desplácese hasta el archivo de mapa requerido.

      El icono Geográfico [image] de la columna Interpretaciones en la ventana de Decision Studio indica la presencia de una interpretación geográfica.

  2. Resalte los campos interpretados geográficamente que desea utilizar en su gráfico de mapa. Todos los campos deben estar asociados con el mismo mapa.
  3. Seleccione Herramientas>Visor de Mapa o haga clic en [image] en la barra de herramientas.

    Se abre Visor de Mapa y muestra el mapa seleccionado, donde el recuento de registros de cada región está representado por la altura de bloque (si solamente resaltó un campo).

Nota:
  • También puede interpretar un campo como geográfico desde el Binning Editor: haga clic con el botón secundario del mouse en el nombre del archivo en el panel Campos y seleccione Interpretaciones>Geográficas.
  • Si resalta dos o más campos geográficos, Visor de Mapa solamente usa dos de ellos inicialmente, el resto aparecerá en la barra [image] (Información únicamente), en la parte inferior de la ventana. En lugar de mostrar los recuentos de registros, el mapa muestra vínculos de línea entre regiones. El espesor de vínculos de línea representa la cantidad de registros que conectan la región de inicio con la región de fin.

  • Si se configura un objetivo numérico en el enfoque, Visor de Mapa muestra el promedio del objetivo como un color de bloque o enlace de línea, según el tipo de gráfico (a menos que haya cambiado la preferencia de función de objetivo).
  • Si inicia Visor de Mapa sin resaltar ningún campo, aparecerá el cuadro de diálogo Seleccionar campos y funciones de agregación [consulte la sección Tabulaciones cruzadas como la base para la segmentación y visualización de datos].
  • Para cambiar la tabulación cruzada subyacente [consulte la sección Tabulaciones cruzadas como la base para la segmentación y visualización de datos] en cualquier momento, seleccione Editar>Editar tabulación cruzada o haga clic en [image] en la barra de herramientas. Todos los campos de desglose deben estar asociados con el mismo mapa.

También consulte

Para abrir una tabulación cruzada en Decision Studio

Organización de campos y estadísticas en una tabulación cruzada o gráfico

Opciones que afectan la visualización de gráficos y árboles de decisiones

Para crear un mapa de categorías a partir de una jerarquía de creación de rangos categóricos.

Para orientar la presentación gráfica con el mouse

Tema principal: Visualizar y segmentar datos de enfoque en forma gráfica


Para crear un mapa de categorías a partir de una jerarquía de creación de rangos categóricos.

  1. En Portrait Miner, haga clic en el botón derecho en el archivo de jerarquía de creación de rangos categóricos a partir del cual desea crear un mapa de categorías y elija Crear mapa de categorías.

    Aparece el cuadro de diálogo Crear mapa de categorías.

  2. Elija la ubicación para el nuevo mapa de categoría.
  3. En forma opcional, elija el tipo de mapa de categoría que se desea crear.
  4. En forma opcional, elija no sobrescribir ningún mapa de categorías existente con el mismo nombre.
  5. Haga clic en Aceptar.
Nota: Esta interfaz de usuario es una forma de acceder a la mayor parte de las funcionalidades provistas por el comando de construcción de datos qsmapgen de Portrait Miner.

También consulte

Acerca de los asistentes de Portrait Miner

Crear un gráfico en un mapa

Para guardar una jerarquía de creación de rangos no categóricos

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Tema principal: Visualizar y segmentar datos de enfoque en forma gráfica


Opciones que afectan la visualización de gráficos y árboles de decisiones

Hay muchas opciones que controlan cómo aparecen los gráficos. Algunas son globales y se pueden aplicar a todos los gráficos, mientras que otras solo se pueden utilizar en gráficos individuales.

También consulte

Para maximizar el espacio de la pantalla para una herramienta de Decision Studio

Etiquetas de visualización de campo

Tema principal: Visualizar y segmentar datos de enfoque en forma gráfica

Para configurar opciones globales para la visualización gráfica

  1. En la ventana Decision Studio, elija Editar>Ver preferencias.

    Aparecerá el cuadro de diálogo Formato. Tres de los cinco paneles tabulados controlan la visualización de gráficos:

    Panel | Descripción
    Opciones de gráfico | Conjunto de elementos que se pueden incluir en gráficos (barras de eje, etiquetas de eje, cuadrículas, marcas de graduación y etiquetas de marcas); selección de colores para los elementos del gráfico; selección de colores para los rangos en el Binning Editor; selección de colores y escala de colores [consulte la sección Para cambiar el rango de colores de los bloques de un gráfico o un árbol de decisión] para bloques de gráficos; y la opción de invertir negro, blanco y gris al imprimir (y guardar la imagen de) un gráfico
    Fuente de etiqueta de marca | Seleccionador de fuente para etiquetas de marca, es decir, valores de campo
    Fuente de etiqueta de eje | Seleccionador de fuente para etiquetas de eje, es decir, nombres de campo
    Etiquetas de función | Texto de la pantalla alternativo para agregar nombres de funciones
  2. Haga clic en Aceptar para confirmar los cambios y cierre el cuadro de diálogo.
Nota:
  • Su configuración se guardará para futuras sesiones de Decision Studio, Fotos de Modelos y Perfil y Auditorías.
  • La configuración Fuente de etiqueta de eje también indica la fuente que se utilizará para los árboles de decisiones de etiquetas.
  • En el panel Colores del rango, las configuraciones Rangos y Valores atípicos son los colores que usa Binning Editor para los rangos normales y los rangos finales, respectivamente. (La configuración Rangos también es el color que el Creador de árboles de decisiónutiliza para los gráficos de barras en los segmentos de árboles continuos).
  • En el panel Colores del elemento, la configuración Mapa es el color que el Map Viewer utiliza para los límites de los mapas.

También consulte

Para configurar el formato de visualización para valores numéricos y de fecha

Para cambiar el rango de colores de los bloques de un gráfico o un árbol de decisión

  1. En la ventana Decision Studio, elija Editar>Ver preferencias. Aparecerá el cuadro de diálogo Formato y estará seleccionada la ficha Opciones de gráfico.
  2. Utilice los selectores desplegables de color que se encuentran en el panel Colores del bloque para seleccionar los colores que representarán los valores "Alto," "Medio" y "Bajo" (por defecto se utilizan rojo, verde y azul, respectivamente). La interpretación exacta de estos colores depende de la forma de la escala de colores seleccionada. En un árbol de decisión, la interpretación de los colores depende de las configuraciones seleccionadas en el cuadro de diálogo Ver configuración para el árbol de decisión [consulte la sección Para controlar el uso de color y profundidad en un árbol de decisión].

  3. En el panel Mapa de colores del visor, seleccione la forma de la escala de colores utilizada:

    Cambiando de tamaño | Descripción
    Lineal | Distribución equitativa de los colores entre los valores máximos y los mínimos, donde el valor mínimo está representado con el color Mediano y el máximo está representado con el color Alto
    Lineal con cero (por defecto)

    Si no hay valores negativos: distribución equitativa de colores entre cero y el valor máximo, donde cero está representado con el color Mediano y el valor máximo está representado con el color Alto

    Si no hay valores positivos: distribución equitativa de colores entre el valor mínimo y cero, donde el valor mínimo está representado con el color Bajo y el cero está representado con el color Mediano

    Si hay valores negativos y positivos: distribución equitativa de colores en un rango de valores centrados en cero, donde el mínimo (o el negativo del máximo) está representado con el color Bajo, el cero está representado con el color Mediano y el máximo (o negativo del mínimo) está representado con el color Alto
    Discriminación máxima | distribución no lineal de colores entre los valores máximo y mínimo, de manera tal que cada graduación de color se corresponda aproximadamente con la misma cantidad de registros (y así maximizar la discriminación entre valores), donde el valor mínimo esté representado con el color Bajo, el valor medio esté representado con el color Mediano y el valor máximo esté representado con el color Alto
  4. Utilice la configuración Cantidad de colores para controlar la cantidad de colores distintos que se utilizarán.
  5. Haga clic en Aceptar.

Para mostrar u ocultar la leyenda de color de un gráfico

En Visor de Perfil, Visor de Distribución Cruzada o Visor de Mapa, seleccione Ver>Leyenda o haga clic en [image] en la barra de herramientas.

Nota:

La leyenda de color no está disponible en el Creador de árboles de decisión.

Para mostrar u ocultar segmentos de valores nulos y sin clasificar en un gráfico

en Binning Editor, Visor de Perfil, Visor de Distribución Cruzada o Visor de Mapa:
  • Seleccione Ver>Datos de nulos o haga clic en [image] en la barra de herramientas, para activar o desactivar la visualización de rangos nulos.
  • Seleccione Ver>Datos sin clasificar para activar o desactivar la presentación de rangos sin clasificar.

Para mostrar u ocultar categorías vacías en un gráfico

En Visor de Perfil o Visor de Distribución Cruzada, seleccione Ver>Categorías vacías para activar o desactivar la presentación de categorías vacías.

Para poner a escala un conjunto de gráficos de perfil de manera conjunta o independiente

Por defecto, en Visor de Perfil todos los gráficos de perfil comparten una escala común en el eje vertical. Para cambiar tamaño de los gráficos de manera independiente, seleccione Ver>Cambiar tamaño en forma global y elimine la marca de verificación que se encuentra en esta opción.

Nota:

Puede asociar varias estadísticas con la altura del bloque, de manera que dos o más gráficos puedan compartir un conjunto de ejes. Si selecciona el cambio de tamaño independiente en este caso, el eje vertical queda sin etiquetar y no podrá comparar valores de las distintas estadísticas.

Para mostrar u ocultar el eje vertical en un gráfico de mapa

En el Visor de Mapa, marque o desmarque la opción de menú Ver>Mostrar el eje de altura.

Para controlar el uso de color y profundidad en un árbol de decisión

  1. En el Creador de árboles de decisión, seleccione Ver>Configuración.

    Aparecerá el cuadro de diálogo Ver configuración para el árbol de decisión.

  2. Con los menús desplegables, seleccione qué representar mediante la profundidad y el color de cada segmento.
  3. Establezca Centrar la escala de color de segmento en en

    Raíz del árbol para utilizar el color medio del rango de colores [consulte la sección Para cambiar el rango de colores de los bloques de un gráfico o un árbol de decisión] (por defecto: verde) en el segmento de raíz;

    Rango medio para utilizar el color medio (por defecto: verde) para representar el punto medio de valores entre los extremos que se presentan en el árbol de decisión.

    50% de la población que coincide con el objetivo etc. (la opción depende del tipo de árbol) para utilizar el color medio (por defecto: verde) para representar un valor particular de relación de coincidencia, media objetivo, uplift etc.

  4. Haga clic en Aceptar.


Creación de un perfil y auditoría de un enfoque

Un perfil y auditoría de un enfoque es un informe en formato HTML que contiene información detallada de un enfoque e incluye los perfiles de algunos o todos los campos del enfoque, opcionalmente en relación con uno o más campos objetivos.

Para crear un perfil y auditoría en Portrait Miner, haga clic con el botón secundario del mouse en el enfoque que desea auditar y seleccione Crear perfil y auditar.

En el cuadro de diálogo Crear perfil y auditar, puede seleccionar los campos o grupos de campos con etiqueta para los cuales desee crear un perfil, puede decidir si quiere ignorar un campo de partición y qué campos objetivo utilizar. (Si hay un objetivo en el enfoque, será el campo objetivo por defecto). También puede seleccionar un subconjunto de registros en el enfoque mediante una expresión FDL [consulte Expressions (Expresiones)].

Una vez terminado, el informe de auditoría se visualizará en la ficha Auditar en el cuadro de diálogo Crear perfil y auditar.

Nota:
  • Puede seleccionar los campos que desea informar al seleccionar los nombres de campo o una o más etiquetas [consulte Cómo trabajar con grupos de campos].
  • Puede seleccionar una de las cuatro opciones de formatos de imágenes para la salida HTML:

    svg SVG (Gráficos Vectoriales Escalables [scalable vector graphics]) solamente. SVG proporciona la mejor calidad de imagen y el tamaño más pequeño de archivos, pero quienes lean su informe deberán contar con un explorador web con un complemento SVG para poder visualizar o imprimir estas imágenes.

    smallpng SVG más los mapas de bits de PNG (gráficos de red portátiles [portable network graphics]) con visualización en pantalla optimizada. Aunque sin complemento SVG, los lectores podrán ver las imágenes del informe (pero la calidad de impresión será deficiente).

    largepng SVG más los mapas de bits de PNG con visualización en pantalla e impresión optimizadas. Los lectores podrán ver o imprimir el informe sin necesidad de un complemento SVG (pero ocupa más espacio de disco y es posible que sea más lento visualizar el informe).

    ninguno sin imágenes.

  • Puede controlar otros aspectos de la apariencia de los informes de foto de modelo y de perfil y auditoría configurando las preferencias [consulte la sección Para configurar las preferencias de Portrait Miner] en la sección Auditorías y fotos de la ventana de Preferencias.
  • Para que Portrait Miner le notifique por correo electrónico cuando está finalizado el informe, deberá configurar las preferencias emailaddress y emailserver de manera adecuada.
  • Por defecto, Portrait Miner guarda Perfil y auditoría como archivo único .qshtml con las imágenes insertadas. Si bien puede abrir este archivo en Portrait Miner (haciendo doble clic en él), no puede utilizarlo directamente fuera de Portrait Miner.

    Para crear una página web que se pueda ubicar en un servidor web, haga clic con el botón secundario del mouse en un archivo .qshtml y seleccione Descomprimir en carpeta. Seleccione una ubicación para la carpeta y haga clic en Aceptar. Esta es una manera de acceder a muchas de las funciones que ofrece el comando de creación de datos qshtmlunpack de Portrait Miner.

  • Puede crear un perfil y auditoría de un conjunto de datos de terceros haciendo clic con el botón secundario del mouse en el archivo en Portrait Miner y eligiendo la opción Auditar. En el diálogo que aparece, puede seleccionar la ubicación para el enfoque temporal que Portrait Miner crea mientras se prepara el informe; en el informe aparecerá el nombre de este enfoque en lugar del nombre del conjunto de datos original.
  • El cuadro diálogo Crear perfil y auditar es una manera de acceder a muchas de las funciones que ofrece el comando de creación de datos qsaudit de Portrait Miner.

También consulte

Acerca de los asistentes de Portrait Miner

Creación de una foto de modelo

Para configurar opciones globales para la visualización gráfica

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Tema principal: Visualizar y segmentar datos de enfoque en forma gráfica

Uso de un informe de referencias para comparar enfoques

Un informe de comparación es como cualquier informe de perfil y auditoría, pero incluye informes paralelos de los campos de dos enfoques, junto con detalles de las diferencias entre varias estadísticas, que permiten observar, por ejemplo, los cambios en el tiempo.

Para crear un informe de comparación, cree un informe de perfil y auditoría para el primer enfoque de manera usual; este será el "informe de referencia". Después cree un informe de perfil y auditoría para el segundo enfoque, pero en el cuadro de diálogo Crear perfil y auditar, especifique el informe de referencia que creó previamente.

Nota:
  • Los campos categóricos deben tener los mismos rangos en los dos enfoques.
  • Por defecto, el informe de comparación incluye los mismos campos que el informe de referencia. Si selecciona explícitamente campos para incluir en el informe de comparación, se agregarán a los campos con perfiles generados previamente.
  • El informe de comparación utiliza los mismos campos objetivos que el informe de referencia. Los campos objetivos especificados explícitamente son ignorados.


Metodología de prueba/capacitación

  • Metodología de prueba/capacitación para un modelo robusto
  • Para particionar un enfoque en subpoblaciones de muestra
  • Para aplicar un modelo o segmentación de Decision Studio a una población distinta


Metodología de prueba/capacitación para un modelo robusto

Cuando se crea un modelo, se necesita algún medio de determinar su calidad. Es necesario saber no sólo cuál es su eficiencia para describir datos históricos, sino también cuán robusto es como predictor de una conducta futura.

El problema del sobreajuste Para una scorecard o árbol de decisiones, % o modelo de creación de clústeres, se puede usar una medida de calidad como la Gini para tener una indicación de la exactitud del modelo para describir un conjunto de datos: en general, cuanto mayor es el número, mejor. Pero se debe tener cuidado para evitar el sobreajuste, que puede ocurrir si el modelo es demasiado específico para el conjunto de datos que se utilizó para crearlo.

En principio, se puede crear un árbol de decisiones o un scorecard que se ajuste perfectamente a un conjunto de datos determinado. Por ejemplo, si se cuenta con los recursos suficientes, se podría hacer una creación de rangos para el campo de identificación de clientes de modo que haya un cliente en cada rango, luego interpretar ese campo como el único candidato de análisis y luego crear un árbol de decisión con tantos niveles como sea necesario para hacer que cada resumen de segmentos sea homogéneo con respecto al objetivo.

Resulta claro que un modelo tan sobreajustado tiene una utilidad limitada. Es tan complicado como el conjunto de datos históricos originales y no aprovecha los patrones en los datos. Ciertamente, no permite comprender nada sobre la conducta de los clientes. No obstante, si el modelo es demasiado simple, tampoco aprovecha los patrones en los datos.

Hasta cierto punto, se puede aplicar el conocimiento del negocio para decidir qué campos incluir en un modelo e incluso cómo crear los rangos para esos campos. Pero siempre existe la tentación de tratar de incluir demasiado en un modelo, lo que corre el peligro de resultar en el sobreajuste del mismo. Es por eso que se debe contar con un medio para poner a prueba el modelo.

Una solución: conjuntos de datos de capacitación y de prueba Un modo de evitar el sobreajuste es hacer particiones en el enfoque [consulte Para particionar un enfoque en subpoblaciones de muestra] en conjuntos de datos decapacitación y prueba, con quizás el 67% de los datos en el conjunto de capacitación y el 33% de los datos reservados para el conjunto de prueba. Puede construir un modelo con los datos del conjunto de capacitación y luego, una vez que esté satisfecho con su potencia descriptiva, aplicarlo al conjunto de prueba [consulte Para aplicar un modelo o segmentación de Decision Studio a una población distinta] a fin de poner a prueba su potencia predictiva. Si la medida de calidad se reduce mucho cuando se aplica el modelo (por ejemplo, si el Gini disminuye más del 2%), debemos considerar que existe sobreajuste.

Si el modelo no es lo suficientemente robusto, se puede volver al conjunto de capacitación y tratar de mejorar el modelo (cambiando los campos incluidos, la creación de rangos, las medidas de calidad, etc..).

Sin embargo, si se repite este proceso demasiadas veces, se corre el riesgo de tener nuevamente sobreajuste porque ahora se está usando todo el enfoque para influir en la forma del modelo. La solución es usar tres subpoblaciones modelo, con quizás 60% de los datos que se usan para capacitación, 30% para pruebas, y el 10% restante para validación. Ahora es posible usar la información de la prueba para refinar el modelo. Después de algunas iteraciones, se puede aplicar el modelo al conjunto de validación [consulte Para aplicar un modelo o segmentación de Decision Studio a una población distinta] para verificar su robustez.

Tema principal: Metodología de prueba/capacitación

Poda automática en el Creador de árbol de decisiones

Se puede utilizar poda automática en el Creador de árboles de decisiones [consulte Para podar parte de un árbol de decisiones automáticamente] junto con conjuntos de datos de prueba y capacitación a fin de crear árboles de decisión más robustos. Con la poda basada en complejidad de costos, el Creador de árboles de decisión identifica automáticamente el árbol podado que tiene un mejor desempeño en el conjunto de prueba.


Para particionar un enfoque en subpoblaciones de muestra

  1. Decida el número de subpoblaciones n y sus tamaños relativos [image] (donde [image]).
  2. En el Visor de tablas, derive un campo [consulte Para derivar un campo utilizando Visor de Tablas] utilizando uno de los procedimientos a continuación:
    • Si desea dos subpoblaciones (n = 2), utilice la función numericTestTrainSplit.
    • Si desea tres subpoblaciones (n = 3), utilice la función numericTestTrainValidateSplit.
    • Si desea subpoblaciones del mismo tamaño ( [image]), use la función sampleEqualSize.
    • De lo contrario, use la siguiente definición:

      Por ejemplo. para crear cuatro subpoblaciones que contengan (aproximadamente) 40%, 30%, 20% y 10% de la población total respectivamente, se podría usar la siguiente definición de campo:

      a := rndUniform();

      caso a < 0.4 : 1; // 0.4 = 40%

      a < 0.7 : 2; // 0.7 = 40% + 30%

      a < 0.9 : 3; // 0.9 = 40% + 30% + 20%

      por defecto : 4

    El enfoque ahora está particionado de acuerdo con los valores en el campo que se ha derivado. De acuerdo con la expresión que se elija, los valores son 1, 2, ..., n o 0, 1, ..., n-1.

  3. Interprete el campo como si fuera categórico [consulte Para establecer o borrar una interpretación categórica, geográfica, de candidato para análisis, de exportación o de clave].
  4. Opcionalmente, cambie el nombre [consulte Para cambiar el nombre de una categoría] de las nuevas categorías en la forma apropiada.

Para usar una subpoblación en particular, seleccione los registros [consulte Selección de registros de clientes] con el valor requerido en el campo.

Nota:
  • Se puede usar la función testTrainSplit como alternativa a la función numericTestTrainSplit.
  • Se puede usar la función testTrainValidateSplit como alternativa a la función numericTestTrainValidateSplit.
  • Como alternativa al cuadro de diálogo Seleccionar valores para alternar entre subpoblaciones, también se puede usar el Editor de rangos. Relacione [consulte Para vincular y desvincular herramientas] las herramientas de análisis y visualización con la salida del Editor de rangos, alterne entre las subpoblaciones resaltando el rango requerido del campo que se ha derivado.

También consulte

sampleExactNumber

sampleExactPercentage

sampleStratified

Tema principal: Metodología de prueba/capacitación


Para aplicar un modelo o segmentación de Decision Studio a una población distinta

  • La manera más simple de aplicar un modelo a una población distinta es cambiar la selección actual de registros [consulte la sección Selección de registros de clientes].
  • Si desea aplicar un árbol de decisión, scorecard o modelo de clustering a una población en un archivo de enfoque separado, guarde el modelo, [consulte la sección Para guardar un árbol de decisión, scorecard o modelo de clustering] luego abra el archivo del otro enfoque y aplique el modelo guardado [consulte la sección Para aplicar un árbol de decisión, scorecard o modelo de clustering].
  • Si la nueva población es un grupo de segmentos resaltados [consulte la sección Resaltado de segmentos en una presentación gráfica] en otra herramienta de Decision Studio, simplemente establezca un enlace [consulte la sección Para vincular y desvincular herramientas] entre la herramienta en la que creó el modelo o la segmentación y el origen de datos correspondiente.

La herramienta actualiza su presentación para mostrar el modelo o la segmentación aplicados a la nueva población.

En el caso del Creador de árboles de decisión, puede continuar viendo las estadísticas de la población original. En la vista de árbol, el Creador de árboles de decisiónmuestra estadísticas originales entre paréntesis, encima de las estadísticas aplicadas:

En las vistas de texto [consulte la sección Opciones para la visualización de un árbol de decisiones], el Creador de árboles de decisiónmuestra tablas de cifras tanto de la población original como de la población aplicada.

Nota:
  • Puede controlar qué conjuntos de cifras mostrará el Creador de árboles de decisión al seleccionar Ver>Datos>Original o Ver>Datos>Aplicado.
  • Si no ha establecido un objetivo en la nueva población, un árbol de decisión aplicado apenas muestra la cantidad de registros de cada segmento. La tabla de aumentos [consulte la sección Opciones para la visualización de un árbol de decisiones] de la nueva población está disponible para árboles binarios y uplift.
  • Si crea un árbol de decisiones y luego cambia el tipo de árbol, el Creador de árboles de decisiónmuestra el mismo árbol superpuesto con estadísticas y quizás gráficos del nuevo tipo de árbol. El Creador de árboles de decisiónmuestra las estadísticas originales entre paréntesis, como si el modelo se aplicara a una población distinta.

También consulte

Metodología de prueba/capacitación para un modelo robusto Para guardar un modelo o una segmentación de Decision Studio para la implementación como QMML (XML)
Tema principal: Metodología de prueba/capacitación

Para guardar un árbol de decisión, scorecard o modelo de clustering

  1. Una vez que haya creado un modelo en el Creador de árboles de decisión, Creador de scorecardso Creador de Clusters, seleccione Archivo>Guardar como o haga clic en [image] en la barra de herramientas.
  2. Seleccione un nombre y una ubicación para el archivo de árbol de decisión, scorecard o modelo de clustering en el explorador de archivos de Portrait Miner [consulte la sección Exploración para abrir o guardar un archivo o tabla de base de datos].

También consulte

Para construir un modelo de clústeres

Para crear un árbol de decisiones

Para aplicar un árbol de decisión, scorecard o modelo de clustering

  1. En el Creador de árboles de decisión, Creador de scorecardso Creador de Clusters, según corresponda, seleccione Archivo>Abrir o haga clic en [image] en la barra de herramientas.

    Aparecerá un explorador de archivos de Portrait Miner [consulte la sección Exploración para abrir o guardar un archivo o tabla de base de datos].

  2. Desplácese hasta el archivo de árbol de decisión, scorecard o modelo de clustering deseado.
Nota: El enfoque actual debe contener campos con los mismos nombres y clases que los utilizados en el modelo.


Creación de árboles de decisión para el modelado predictivo y por segmentación

  • Para crear un árbol de decisiones
  • Opciones para la visualización de un árbol de decisiones
  • Control de la creación de un árbol de decisiones
  • Para eliminar segmentos no deseados de un árbol de decisiones


Para crear un árbol de decisiones

  1. Como opción, interprete algunos campos como candidatos para análisis [consulte Para establecer o borrar una interpretación categórica, geográfica, de candidato para análisis, de exportación o de clave].

    Si hay campos con una interpretación de candidatos para análisis, el Creador de árboles de decisión sólo considera estos campos al crear ramas del árbol de decisiones.

  2. Interprete un campo como el objetivo de modelado .
  3. Para árboles de alza solamente, interprete un campo como el campo de partición. (Sólo puede crear un árbol de alza si el campo de partición incluye 0 y 1 y ningún otro valor, incluido el valor nulo).
  4. Seleccione Herramientas>Creador de árboles de decisión o haga clic en [image] en la barra de herramientas.
  5. De ser necesario, cambie el tipo de árbol (a árbol binario, árbol de categorías o árbol continuo) mediante el uso del menú desplegable en la barra de herramientas.
    Si no utiliza un campo de partición:
    • Utilice un árbol de categorías para un objetivo con valores categóricos (o un árbol binario para un objetivo con dos valores).
    • Utilice un árbol continuo para un objetivo no categórico.
    Si desea utilizar un campo de partición para realizar el modelo de alza:
    • Para un objetivo de dos valores, utilice un alza binaria + árbol para el modelo aditivo o utilice un alza binaria + árbol para un modelo multiplicativo.
    • Utilice un árbol continuo para un objetivo no categórico.
    • No puede utilizar un objetivo categórico con más de dos valores.
  6. De ser necesario, cambie las opciones de creación predeterminadas [consulte Control de la creación de un árbol de decisiones].
  7. Seleccione Árbol>Crear hasta el final o haga clic en [image] en la barra de herramientas para crear un árbol de decisión:

Nota:
  • Para agregar otro nivel al árbol actual (no aplicado), seleccione Árbol>Crear el nivel siguiente o haga clic en [image].
  • En cada vista del árbol de decisiones [consulte Opciones para la visualización de un árbol de decisiones], dos paneles a la izquierda muestran campos incluidos (candidatos para análisis) y campos excluidos (otros campos en el enfoque).

    Puede interpretar un campo como un candidato para análisis si lo mueve del panel inferior al panel superior (y viceversa) mediante el uso de los botones de flecha entre los paneles. Si crea un nivel del árbol por vez, incluso puede utilizar un conjunto diferente de candidatos para análisis para cada nivel del árbol.

    Los campos que se utilizan en el árbol de decisiones actual aparecen en negrita (independiente de si son candidatos para análisis en este momento).

  • Cuando comienza a crear un árbol de decisiones, el Creador de árboles de decisión le indica que interprete los campos de cadena que no tienen una interpretación categórica, de modo que se puedan ordenar por rangos correspondientemente. Puede elegir la interpretación categórica predeterminada o usar una jerarquía categórica guardada. Si hace clic en Cancelar cuando se le solicita que seleccione una interpretación para un campo de cadena, el Creador de árboles de decisión ignora ese candidato para análisis, junto con cualquier campo de cadena restante sin una interpretación categórica.

También consulte

Control de la creación de un árbol de decisiones

Para aplicar un modelo o segmentación de Decision Studio a una población distinta

Tema principal: Creación de árboles de decisión para el modelado predictivo y por segmentación

Para crear un árbol de decisiones

Para borrar un árbol de decisión en el Creador de árboles de decisión, seleccione Árbol>Borrar o haga clic en [image] en la barra de herramientas.
Nota: Si el Creador de árboles de decisión muestra la Vista de ganancias o la Vista de gráfico, cambia a la Vista de árbol.


Opciones para la visualización de un árbol de decisiones

Las siguientes vistas están disponibles en el Creador de árboles de decisión:
Vista | Descripción
Vista de árbol | Una representación gráfica de un árbol de decisiones, donde la población entera está representada en la parte superior y cada nivel completo por debajo representa una segmentación más fina
Vista tabla | Una representación tabular del árbol de decisiones, que muestra estadísticas para cada segmento numerado y una expresión de estilo FDL que describe cada segmento. Para un árbol uplift, el tamaño total es la suma de los tamaños de población tratada y control, sin incluir los otros registros.
Vista listado | Una presentación alternativa de parte de la información mencionada, en forma de lista
Vista de ganancias | Una tabla de ganancias acumuladas, para los segmentos de "hoja" (nivel más bajo, sin secundarios) del árbol de decisiones, ordenada en orden descendiente de relación de coincidencia
Vista de gráfico | Un gráfico Qini, disponible para árboles de alza solamente

Para cambiar a una vista distinta, elija una vista del menú Ver o haga clic en el botón correspondiente de la barra de herramientas.

También consulte

Opciones que afectan la visualización de gráficos y árboles de decisiones

Para orientar la presentación gráfica con el mouse

Tema principal: Creación de árboles de decisión para el modelado predictivo y por segmentación

Para expandir o contraer parte de un árbol de decisiones

Para concentrarse en partes interesantes de un árbol, puede contraer o plegar un subárbol.
  1. Seleccione los segmentos [consulte Resaltado de segmentos en una presentación gráfica] que desea plegar o desplegar.
  2. Seleccione Segmentos>Plegar o Segmentos>Desplegar.

    Cuando pliega segmentos, el Creador de árboles de decisión oculta los descendientes de segmentos seleccionados y marca estos segmentos con un signo "+" para indicar que algunos descendientes están ocultos.

Como opción, puede hacer clic con el botón secundario del mouse en un segmento y seleccione Plegar o Desplegar en el menú que aparece.

Nota:
  • El pliegue no es lo mismo que la poda [consulte Para podar parte de un árbol de decisiones manualmente]. Cuando pliega parte de un árbol de decisiones, solamente cambiará la vista del árbol, mientras que la poda afectará al modelo subyacente.
  • Si continúa creando el árbol, el Creador de árboles de decisión puede dividir segmentos ocultos (pero los segmentos secundarios también se ocultarán).


Control de la creación de un árbol de decisiones

Puede definir varias restricciones [consulte Para ver o modificar restricciones en la creación de árboles] que rigen cómo se crea un árbol de decisiones en el Creador de árboles de decisión. También puede ejercer un grado de control manual si bloquea [consulte Para bloquear o desbloquear segmentos en un árbol de decisiones] segmentos en un árbol o poda [consulte Para eliminar segmentos no deseados de un árbol de decisiones] un árbol.

También consulte

Para crear un árbol de decisiones

Para eliminar segmentos no deseados de un árbol de decisiones

Tema principal: Creación de árboles de decisión para el modelado predictivo y por segmentación

Para ver o modificar restricciones en la creación de árboles

Seleccione Árbol>Restricciones.

Están disponibles los siguientes ajustes en el cuadro de diálogo Restricciones del árbol:

Configuración | Se aplica a | Descripción
Cantidad máxima de niveles en el árbol | Todos los tipos de árbol | El número más grande de generaciones en cualquier rama del árbol (incluido el segmento de "raíz") Esto sólo se aplica cuando elige la opción "crear hasta el final". El Creador de árboles de decisión detiene la creación del árbol una vez que se genera esta cantidad de niveles. Si selecciona Árbol>Crear el nivel siguiente o hace clic en [image] , el Creador de árboles de decisión ignora la configuración.
Ganancia de información mínima para la división | Árboles binarios y categóricos | El valor mínimo aceptable de ganancia de información para una división (un valor entre 0 y 1)
Ganancia de coeficiente de determinación mínima para la división | Árboles continuos | El valor mínimo aceptable de la medida [image] para una división (un valor de entre 0 y 1)
Importancia de alza mínima para la división | Árboles de alza | El valor mínimo aceptable de relevancia de alza medido para una división (un valor entre 0 y 1)
Umbral para divisiones multivaluadas | Árboles de categorías y árboles de alza | El número de categorías en un candidato de análisis categórico, sin incluir las nulas [consulte El valor null] y sin clasificar, más allá del que el Creador de árboles de decisión ya no considera todas las permutaciones de división posibles Para un candidato para análisis con más categorías que esto, el Creador de árboles de decisión sólo considera divisiones que impliquen una única categoría en un lado y el resto en el otro.
Tamaño mínimo de segmento | Todos los tipos de árbol, excepto de alza | El número mínimo de registros en un segmento de "hoja" (nivel más bajo, sin secundarios). El Creador de árboles de decisión ignora divisiones con un resultado de uno o más segmentos con menos registros. Si marca el cuadro Tratar el tamaño mínimo de segmento como porcentaje, este número se trata como un porcentaje del número de registros en la población que utiliza para crear el árbol.
Tamaño mínimo de segmento en población tratada, tamaño mínimo de segmento en la población control | Árboles de alza | El número mínimo de registros, en las poblaciones tratada y de control respectivamente, en un segmento de "hoja" (nivel más bajo, sin secundarios) El Creador de árboles de decisión ignora divisiones con un resultado de uno o más segmentos con menos registros en la población correspondiente. El cuadro Tratar el tamaño mínimo de segmento como porcentaje interpreta valores como porcentajes de la población total, no como porcentajes de las poblaciones tratada o control individuales.

Para los árboles de categorías, hay dos casillas de verificación adicionales, que permiten forzar al Creador de árboles de decisión a tratar rangos nulos y sin clasificar en el objetivo como categorías ordinarias.

Para bloquear o desbloquear segmentos en un árbol de decisiones

Antes de continuar con la creación de un árbol de decisiones parcialmente creado, puede excluir segmentos seleccionados de la consideración mediante su bloqueo.
  1. Seleccione los segmentos [consulte Resaltado de segmentos en una presentación gráfica] que desea bloquear o desbloquear.
  2. Seleccione Segmentos>Bloquear o Segmentos>Desbloquear.

    Cuando bloquea segmentos, el Creador de árboles de decisión marca el resumen de segmentos debajo de cualquier segmento resaltado con un símbolo de candado [image].

Como opción, puede hacer clic con el botón secundario del mouse en un segmento y seleccionar Bloquear o Desbloquear en el menú que aparece.


Para eliminar segmentos no deseados de un árbol de decisiones

Para eliminar segmentos no deseados de un árbol, utilice la poda.
Nota: La poda no es lo mismo que el pliegue [consulte Para expandir o contraer parte de un árbol de decisiones]. Cuando poda parte de un árbol de decisiones, el árbol de decisiones subyacente cambia, mientras que el pliegue sólo afecta la visualización del árbol.

También consulte

Para bloquear o desbloquear segmentos en un árbol de decisiones

Para crear un árbol de decisiones

Tema principal: Creación de árboles de decisión para el modelado predictivo y por segmentación

Para podar parte de un árbol de decisiones manualmente

Sólo puede eliminar selectivamente segmentos no interesantes de un árbol de decisiones.
  1. Seleccione segmentos [consulte Resaltado de segmentos en una presentación gráfica] cuyos descendientes desee eliminar.
  2. Seleccione Segmentos>Podar.

    El Creador de árboles de decisión elimina los descendientes de segmentos seleccionados y marca los segmentos seleccionados con un símbolo de candado para indicar que están bloqueados.

Como opción, puede hacer clic con el botón secundario del mouse en un segmento y seleccionar Podar en el menú que aparece.

Para podar parte de un árbol de decisiones automáticamente

Puede eliminar automáticamente segmentos sobreajustados de un árbol de decisiones después de crearlo. Para ello, emplee una metodología de prueba/capacitación [consulte Metodología de prueba/capacitación para un modelo robusto] y utilice la opción Podar automáticamente [consulte Poda automática en el Creador de árbol de decisiones].
  1. Cree su árbol de decisiones [consulte Para crear un árbol de decisiones] en la población de capacitación.
  2. Aplique este árbol de decisiones [consulte Para aplicar un modelo o segmentación de Decision Studio a una población distinta] a la población de prueba.
  3. Seleccione Árbol>Podar automáticamente o haga clic en [image].

El Creador de árboles de decisión eliminar automáticamente los segmentos que no aumentan el rendimiento del árbol de decisiones en la población de prueba.


Creación de scorecards para el modelado predictivo y por segmentación

  • Acerca del Asistente de scorecard
  • Crear un scorecard con el Asistente de Scorecard
  • Crear un scorecard con el Creador de scorecards
  • Cómo refinar una scorecard agregando o eliminando campos
  • Opciones para mostrar una scorecard
  • Control de la creación de un scorecard


Acerca del Asistente de scorecard

El Asistente de scorecard automatiza el modelado de scorecards utilizando metodología de mejores prácticas: crea rangos optimizados, luego reducción variable y finalmente crea una secuencia de modelos en datos de prueba y capacitación para establecer el mejor "tamaño de modelo". La metodología de modelado consta de las siguientes etapas.

Metodología de prueba/capacitación Una parte de los datos de origen se usa para capacitación y otra parte para pruebas: esta división puede generarse aleatoriamente o utilizando un campo indicador binario designado.

Creación de rangos optimizados Los datos de capacitación se usan para seleccionar rangos para cada candidato de análisis que maximiza su poder predictivo univariante comparado con el objetivo.

Para campos no categóricos, el ayudante de creación de rango optimizados [consulte Para optimizar la creación de rangos de un campo] se usa en forma iterativa para elegir los mejores rangos. El número de rangos se aumenta hasta que el número de "puntos de ajuste" en el gráfico del valor objetivo promedio por rango excede a un umbral configurable (un "punto de ajuste" es un cambio de signo en la curva de un gráfico). Intuitivamente, esto asegura que el perfil del valor objetivo promedio como función de cada candidato de análisis sea relativamente "parejo", sin demasiados altos y bajos.

Para campos categóricos, se combinan las categorías donde el valor objetivo promedio no es significativamente diferente de la media general. Se usa una prueba de diferencia de medias estándar [consulte significance] con una corrección de Bonferroni aplicada, basada en el número total de categorías que aparecen para el campo. Así, todas las categorías que tienen el nivel de confianza [image] están combinadas (con [image] un importante umbral configurable).

Durante esta fase, los campos con una correlación sospechosamente alta al objetivo se excluyen de futuros análisis (con un mensaje de advertencia). También se emite una advertencia para los campos en los que cualquiera de los rangos individuales contiene un número pequeño de registros. Ambos umbrales son configurables.

Reducción variable La fase de reducción variable reduce el grupo de candidatos a análisis (predictores independientes) de aquellos inicialmente marcados como un grupo más pequeño de n, a fin de disminuir el tiempo de ejecución de la última fase de "encontrar el tamaño correcto".

El proceso realiza una partición de los candidatos de análisis en grupos de campos 2n y crea una scorecard (con los datos de capacitación) en cada grupo, descartando los peores campos por exclusión gradual [consulte Cómo refinar una scorecard agregando o eliminando campos] hasta que quedan sólo los n mejores campos del grupo. Repitiendo este procedimiento eventualmente se identifican los n mejores campos en general.

Tamaño La fase de encontrar el tamaño correcto elige la scorecard que equilibra mejor la complejidad (número de predictores) con la generalización (medida por el rendimiento del conjunto de prueba). Los datos de capacitación se usan para crear una secuencia de n scorecards. El primero contiene los n candidatos de análisis y cada modelo subsiguiente excluye al peor predictor. Luego se evalúa el rendimiento de cada modelo con los datos de prueba y se elige el mejor modelo con un criterio configurable. En el paso final, se reajustan los coeficientes de ponderación del modelo seleccionado, basándose en todos los datos (es decir, tanto los datos de prueba como los de capacitación) a fin de mejorar la precisión. Si se desea pueden guardarse todos los modelos interinos junto con el modelo final.

Resultados Se generan (en forma opcional) diversos resultados, entre otros:

  • Un informe HTML que resume cómo se aplicó la metodología, incluidos los parámetros de entrada y los enlaces al registro de ejecución detallado. Esto incluye una tabla de datos de rendimiento que puede graficarse fácilmente en Excel.
  • El modelo recomendado final (en formatos .qssc [consulte Para guardar un árbol de decisión, scorecard o modelo de clustering] y QMML [consulte Para guardar un modelo o una segmentación de Decision Studio para la implementación como QMML (XML)]).
  • Un informe foto de modelo [consulte Creación de una foto de modelo] para el modelo recomendado.
  • El conjunto de datos final, incluidos los candidatos de análisis seleccionados, los rangos optimizados y las predicciones de modelos. También pueden guardarse si se desea los conjuntos de datos intermedios que contienen la metadata generada por la metodología hasta ese momento. Estos a menudo resultan útiles para tener un informe detallado y explorar las decisiones que se tomaron durante el proceso.

También consulte

Crear un scorecard con el Asistente de Scorecard

Tema principal: Creación de scorecards para el modelado predictivo y por segmentación


Crear un scorecard con el Asistente de Scorecard

Guarde su enfoque de modelado, con el campo objetivo, los candidatos para análisis y las variables categóricas marcadas. Esta preparación se puede automatizar importando el enfoque de metadatos [consulte la sección Copiar metadata de un enfoque a otro] en el enfoque de modelado.

En Portrait Miner, haga clic con el botón secundario del mouse en un enfoque y elija Predecir>Asistente de Scorecard.

En el cuadro de diálogo Asistente de Scorecard, puede elegir optimizar rangos, seleccionar un conjunto reducido de variables para la fase de creación del modelo final o crear un modelo de scorecard optimizado. También puede configurar detalles avanzados que influencien el algoritmo de creación del modelo.

Nota:
  • Esta interfaz de usuario es una forma de tener acceso a gran parte de la funcionalidad proporcionada por el comando de creación de datos qsscorecardwizard de Portrait Miner.

También consulte

Acerca del Asistente de scorecard

Acerca de los asistentes de Portrait Miner

Crear un scorecard con el Creador de scorecards

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Tema principal: Creación de scorecards para el modelado predictivo y por segmentación


Crear un scorecard con el Creador de scorecards

  1. Como opción, interprete algunos campos como candidatos para análisis [consulte Para establecer o borrar una interpretación categórica, geográfica, de candidato para análisis, de exportación o de clave].

    El Creador de scorecardscomputa únicamente las estadísticas de resultados para campos que son candidatos para análisis (a menos que no haya ninguno, en cuyo caso, computa estadísticas para todos los campos).

  2. Interprete un campo como el objetivo de modelado .
  3. Seleccione Herramientas>Creador de scorecards o haga clic en [image] en la barra de herramientas.

    El Creador de scorecardsse abrirá.

  4. Si está usando un objetivo binario (0/1), elija el tipo de modelo apropiado del menú Scorecard>Tipo de modelo: riesgo, respuesta, cancelación, satisfacción o insatisfacción.

    Para un objetivo continuo, únicamente está disponible el tipo de modelo de valor.

  5. Una vez más, si está usando un objetivo binario, puede elegir Scorecard>Invertir el valor objetivo para cambiar el sentido del campo objetivo 0/1.

    De manera predeterminada, 1 en el objetivo indica mora, respuesta, cancelación, cliente satisfecho o insatisfecho, según el tipo de modelo elegido.

  6. De ser necesario, cambie las opciones de creación predeterminadas [consulte Control de la creación de un scorecard].
  7. Seleccione Scorecard>Crear o haga clic en [image] en la barra de herramientas, para crear un scorecard.
Nota:
  • Cuando abre el Creador de scorecards, éste le solicitará que interprete cualquier campo de cadena que no tenga una interpretación categórica, de manera tal que se puedan ordenar por rango en forma apropiada. Puede elegir la interpretación categórica predeterminada o usar una jerarquía categórica guardada. Si hace clic en Cancelar cuando se le solicite que elija una interpretación para un campo de cadena, el Creador de scorecardsignorará ese candidato para análisis junto con cualquier campo de cadena restante sin interpretación categórica.
  • Su elección de tipo de modelo afecta el rótulo de valores, gráficos, etc. (pero sólo después de crear nuevamente su scorecard). También existe una distinción más fundamental entre modelos de riesgo y otros tipos de modelos binarios objetivos: al aplicar un modelo de riesgo, habitualmente, acepta clientes en segmentos con una tasa predeterminada de incumplimiento reducida; pero al aplicar un modelo de respuesta, cancelación, satisfacción o insatisfacción, habitualmente, se dirige a clientes en segmentos con una tasa de respuesta/cancelación/satisfacción/insatisfacción predicha elevada.
  • Si su enfoque contiene un campo que representa un coeficiente de ponderación de registro, destaque ese campo en el Creador de scorecardsy elija Campos>Establecer como coeficiente de ponderación antes de crear un scorecard. Para ponderaciones enteras positivas [image], [image], ..., el scorecard es el mismo que obtendría de un conjunto de datos más grande con [image] ocurrencias del primer registro, [image] del segundo y así sucesivamente. La interpretación de ponderaciones es local para la instancia de Creador de scorecards.

También consulte

Crear un scorecard con el Asistente de Scorecard

Control de la creación de un scorecard

Para aplicar un modelo o segmentación de Decision Studio a una población distinta

Tema principal: Creación de scorecards para el modelado predictivo y por segmentación


Cómo refinar una scorecard agregando o eliminando campos

En Vista de campo [consulte Opciones para mostrar una scorecard] de Creador de scorecards, el panel superior muestra campos que deben incluirse en la scorecard, mientras que el panel superior muestra los restantes candidatos de análisis. Una scorecard con menos campos es potencialmente más fácil y rápida de implementar y quizás más robusta [consulte Metodología de prueba/capacitación para un modelo robusto], aunque quizás sea un modelo menos exacto.

Se pueden incluir o excluir campos manualmente con las flechas entre los paneles, con Gini, V de Cramer o ganancia de información como base. También se puede automatizar este proceso de selección de campos, teniendo en cuenta, potencialmente, las interacciones entre campos.

  1. Use Campos>Incluir automáticamente (o Campos>Excluir automáticamente) o haga clic en [image] (o en [image]) en la barra de herramientas, para incluir (o excluir) campos.

    Aparece el cuadro de diálogo de Opciones de exclusión automática (o Opciones de inclusión automática) .

  2. Elija algunos de los siguientes criterios de selección:
    • Regresión lineal gradual
    • Medida de calidad gradual

    El algoritmo considera la calidad de las scorecards temporarias obtenidos incluyendo (o excluyendo) cada campo por vez. Una vez que se ha incluido (o excluido) el campo que permite lograr la mejor scorecard temporaria, el algoritmo se repite, hasta incluir (o excluir) el número requerido de campos.

    La calidad de la scorecard temporaria es determinada por la medida de calidad seleccionada en ese momento [consulte Para cambiar la medida de calidad utilizada para crear un scorecard] , o regresión lineal si se elije esa opción. Sin embargo, esta scorecard temporaria siempre se crea usando la medida de calidad de regresión lineal.

  3. Especifique el número de campos que se deben incluir o excluir por vez.
  4. Haga clic en OK para configurar las opciones de autoincluir o autoexcluir.
Nota: Se puede crear una buena scorecard excluyendo todos los campos al principio y luego autoincluyendo el número requerido de campos usando una regresión lineal gradual.
Tema principal: Creación de scorecards para el modelado predictivo y por segmentación


Opciones para mostrar una scorecard

Están disponibles las siguientes vistas de Creador de scorecards:

Vista | Descripción
Vista de campo | Una vista de dos paneles de candidatos de análisis y estadísticas asociadas, con los campos que están incluidos en la scorecard en el panel superior y aquellos que están excluidos en el panel inferior.
Vista tabulada | Una vista de panel con etiquetas de la scorecard, mostrando coeficientes de ponderación (puntaje de rangos) y estadísticas un campo por vez.
Vista de Scorecard | Una vista más simple de la scorecard, mostrando los coeficientes de ponderación (puntaje de rangos) para todos los campos en una sola vista.
Vista de gráfico | Uno de los cinco gráficos [consulte Gráficos de Creador de scorecards], al lado de paneles que muestran listas de campos incluidos y excluidos.
Matriz de correlación | Una matriz de correlación para los candidatos de análisis.

Inicialmente, Creador de scorecards muestra la vista de campo (y otras vistas no están disponibles hasta que se crea o abre una scorecard). Para cambiar a una vista distinta, elija una vista del menú Ver o haga clic en el botón correspondiente de la barra de herramientas.

Tema principal: Creación de scorecards para el modelado predictivo y por segmentación

Gráficos de Creador de scorecards

En Creador de scorecards están disponibles los siguientes gráficos:

Gráfico | Descripción
Gini | La curva de Gini para el modelo de scorecard
Histograma | Gráficos superpuestos de clientes que coinciden con el objetivo y clientes que no coinciden con el objetivo comparados con un resultado asignado.
Histograma acumulativo | Una versión acumulativa de lo anterior
Curva de estrategia | Una curva de estrategia, para ayudar a elegir un resultado de recorte adecuado.
Coeficientes de ponderación | Una representación gráfica del scorecard, con un gráfico de coeficientes de ponderación (resultados de rango) para cada campo del scorecard

En el menú desplegable de la esquina superior derecha del gráfico, puede elegir el gráfico que desea que se muestre.

También consulte

Opciones que afectan la visualización de gráficos y árboles de decisiones

Para orientar la presentación gráfica con el mouse


Control de la creación de un scorecard

Puede controlar la forma en que se crea un scorecard utilizando una medida de calidad [consulte la sección Para cambiar la medida de calidad utilizada para crear un scorecard], un solucionador [consulte la sección Para cambiar el solucionador utilizado para crear un scorecard] o un formulario [consulte la sección Para cambiar el formulario de un scorecard] diferente.
Tema principal: Creación de scorecards para el modelado predictivo y por segmentación

Para cambiar la medida de calidad utilizada para crear un scorecard

La calidad de un scorecard es un cálculo aproximado de su precisión. Al crear un scorecard, el Creador de scorecardsintenta maximizar su calidad según una de tres medidas de calidad.
En el menú Scorecard>Medida de calidad, elija una de las siguientes opciones:
  • Regresión lineal
  • Regresión logística
  • Línea de regresión de probits
Nota: Para un objetivo continuo (no binario), la única medida de calidad disponible es la regresión lineal.

Para cambiar el solucionador utilizado para crear un scorecard

Dada una medida de calidad, el Creador de scorecardsutiliza uno de cinco solucionadores para intentar maximizar la calidad del scorecard. Puede elegir el solucionador que desea que el Creador de scorecardsutilice y controlar algunos aspectos de la conducta del solucionador.

  1. Elija Scorecard>Solucionador.

    Aparecerá el cuadro de diálogo Solucionador de Scorecard.

  2. En el menú Método, elija una de las siguientes opciones:
    • Simplex
    • Powell
    • Quasi-Newton
    • Gradiente conjugado
    • Levenberg — Marquardt
Nota: En general, no es necesario cambiar la medida de calidad o cualesquiera de las configuraciones del cuadro de diálogo Solucionador de Scorecard. Al elegir la medida de calidad [consulte la sección Para cambiar la medida de calidad utilizada para crear un scorecard], el Creador de scorecardselige al solucionador más potente disponible para esa medida.

Para cambiar el formulario de un scorecard

Al crear un scorecard, el Creador de scorecardstrata cada rango de cada campo incluido como una variable independiente o asigna coeficientes de ponderación dentro de cada campo y, luego, transforma dichos coeficientes de acuerdo con la importancia relativa de los campos en el modelo.
  1. Elija Scorecard>Formulario.

    Aparecerá el cuadro de diálogo Formulario de Scorecard.

  2. En el panel Formulario, elija "un coeficiente de ponderación por rango" o "un coeficiente de ponderación por campo".
  3. Si elige la opción más simple, "un coeficiente de ponderación por campo", especifique la forma en que el Creador de scorecardstransformará los coeficientes de ponderación dentro de cada campo.


Reglas de secuencia y asociación para la creación

  • Acerca del Asistente para reglas de asociación
  • Reglas de secuencia y asociación para utilizar el Asistente para reglas de asociación


Acerca del Asistente para reglas de asociación

El Asistente para reglas de asociación automatiza el descubrimiento de reglas de secuencia y asociación. Por lo general, esto se utiliza para explorar datos de eventos, cestas o transacciones de clientes detalladas para aplicaciones como las siguientes:

Análisis de cesta de mercado identifica combinaciones de productos que, comúnmente, aparecen (o no aparecen) juntas dentro de una única transacción de compra (cesta de productos).

Mejor producto siguiente determina la secuencia más común en la que se compran productos o servicios; por ejemplo, es más probable que los clientes de bancos abran una cuenta de inversión/de crédito después de abrir una caja de ahorro de intereses elevados.

Análisis de impacto de promoción comercial identifica patrones de comunicaciones de promoción comercial con mayores probabilidades de que se produzcan antes de una compra

Preparación de datos el Asistente para reglas de asociación se ejecuta directamente contra transacciones o datos de eventos almacenados en un conjunto de datos de enfoque, que se beneficia del acceso a datos de alto rendimiento de Portrait Miner.
  • Para el análisis de Cesta de mercado, debe usar un conjunto de datos del nivel de elementos que contenga un registro por elemento. El conjunto de datos debe contener un identificador de cesta que agrupe a los elementos en la misma cesta, así como un campo identificador de producto (ordenado por rangos y categórico) que indique el nombre de producto o el código de cada elemento. El conjunto de datos se debe ordenar según el campo clave identificador de cesta.
  • Para el análisis de Producto siguiente, debe elegir un conjunto de datos con un registro por producto o servicio. El conjunto de datos debe contener un identificador de cesta, con frecuencia, el identificador de cliente, que agrupe los productos, el identificador de producto (ordenado por rangos y categórico) y la marca de hora del producto (entero o fecha) que indique el orden en que se adquirieron los productos. El conjunto de datos se debe ordenar según el campo clave identificador de cesta.

Parámetros de algoritmos el Asistente para reglas de asociación está basado sobre el algoritmo a priori que es estándar en la industria y que incluye una amplia gama de funcionalidades para controlar el descubrimiento de reglas. Para obtener más información sobre el algoritmo Apriori, consulte la documentación sobre Apriori en la versión de medios de Portrait Miner (DVD/zip). La documentación se encuentra en \server\Components\ext\qsruleminer\docs\apriori_docs.

El descubrimiento de reglas se puede restringir a productos de interés particulares, y se pueden controlar diversos parámetros que definen lo que es una regla interesante (soporte, nivel de confianza, complejidad de la regla, medidas de selección de reglas ampliadas). Observe que estas configuraciones pueden tener un impacto sobre el tiempo de ejecución: en especial, si se reduce el valor mínimo de admisión, el tiempo de ejecución aumentará, a menos que también se especifique una complejidad de regla máxima (cantidad de antecedentes).

Terminología el Asistente para reglas de asociación usa una variedad de términos que, tal vez, no le resulten familiares, entre otros:

Regla en general, una regla afirma que si se cumple con un conjunto de condiciones (el lado izquierdo o el antecedente de la regla), entonces, se producirá otra condición (el lado derecho o el consecuente de la regla). En las reglas de asociación o secuencia, las condiciones de la regla corresponden a la presencia de elementos específicos en la cesta. Por ejemplo, una regla simple podría ser la siguiente: si una cesta contiene pan, entonces, también contendrá mermelada.

Antecedente el lado izquierdo de una regla, es decir, el conjunto de elementos que deben aparecer en la cesta para que la regla sea relevante.

Consecuente el lado derecho de una regla, es decir, el conjunto de elementos que la regla predice que estarán presentes cuando se cumpla con el lado izquierdo (antecedente).

Soporte el soporte (absoluto) de un conjunto de elementos es la cantidad de cestas que contienen todos los elementos del conjunto. El soporte relativo es la misma cantidad expresada como un porcentaje de la cantidad total de cestas.

Soporte de regla el soporte de una regla es el del antecedente de la regla, es decir, la proporción de cestas a la que se aplica el lado izquierdo de la regla. Esto mide la frecuencia con la que la regla es relevante.

Nivel de confianza el nivel de confianza de una regla es el soporte del conjunto de todos los elementos que aparecen en la regla (a la izquierda o a la derecha), dividido por el soporte del antecedente de la regla. Mide la probabilidad de que el consecuente de la regla (lado derecho) sea verdadero si se cumple con el antecedente de la regla; es decir, la probabilidad de que la regla sea correcta.

Diferencia de nivel de confianza absoluta con anterior la diferencia con las medidas del nivel de confianza posteriores y anteriores (con y sin los elementos del antecedente). Mide cuán mayor (o menor) es la probabilidad del consecuente de una regla cuando el lado izquierdo de la regla es verdadero. Por ejemplo, la regla "si pan, entonces mermelada" no es muy interesante si su nivel de confianza es similar a la regla "si (cualquier elemento), entonces mermelada".

Valor de elevación la proporción de las medidas del nivel de confianza posteriores y anteriores (con y sin los elementos del antecedente).

Resultados Se generan (en forma opcional) diversos resultados, entre otros:
  • Un informe de modelo HTML interactivo que resume las reglas creadas, su métrica y la opción de filtrar reglas interesantes.
  • Un nuevo conjunto de datos clasificado que crea un conjunto de datos total (un registro por identificador de cesta) y que indica si cada regla seleccionada se cumple para ese grupo de registros.
  • Las reglas como código instalable en formato Transaction Measurement Language.
  • Las reglas como exportación opcional en el formato de lenguaje de marcado de modelo predictivo (PMML), con un uso de la ficha “Implementar”, como se muestra a continuación.
Tema principal: Reglas de secuencia y asociación para la creación


Reglas de secuencia y asociación para utilizar el Asistente para reglas de asociación

Guarde su enfoque de modelado con el campo identificador de producto ordenado por rangos y categórico. Esta preparación se puede automatizar importando el enfoque de metadatos [consulte la sección Copiar metadata de un enfoque a otro] en el enfoque de modelado.

En Portrait Miner, haga clic con el botón secundario del mouse en un enfoque y elija Predecir>Asistente para reglas de asociación.

En el cuadro de diálogo Asistente para reglas de asociación, puede elegir el tipo de reglas de asociación que desea crear, seleccionar los parámetros para identificar reglas interesantes y qué campo identificador de cesta (elige el primer campo en forma predeterminada), identificador de producto (elige el campo objetivo en forma predeterminada) y de marca de hora de producto (elige el campo de partición en forma predeterminada) desea analizar. Puede limitar las reglas creadas para que siempre incluyan un conjunto específico de productos.

Nota:
  • Esta interfaz de usuario es una forma de tener acceso a gran parte de la funcionalidad proporcionada por el comando de creación de datos qsruleminer de Portrait Miner.

También consulte

Acerca del Asistente para reglas de asociación

Acerca de los asistentes de Portrait Miner

Tema principal: Reglas de secuencia y asociación para la creación


Creación de modelos Naive Bayes para segmentación y creación de modelos predictivos

  • Acerca del Asistente de Naive Bayes
  • Creación de un modelo de propensión con el Asistente de Naive Bayes


Acerca del Asistente de Naive Bayes

El Asistente de Naive Bayes crea un modelo de propensión con el teorema de Bayes combinado con una suposición (ingenua, "naive") de independencia condicional para predecir el valor de una categoría de campo objetivo, a partir de evidencia dada por un o más de un candidato para análisis. Esencialmente, un modelo Naive Bayes define un conjunto de tabulaciones cruzadas: hay una tabulación cruzada por cada candidato para análisis, que contiene los recuentos de frecuencia de rangos de análisis respecto de categorías objetivo.

Un recuento de cero requiere atención especial y el modelo Naive Bayes incorpora un parámetro umbral que especifica una probabilidad predeterminada (por lo general, muy pequeña) para usar cuando el recuento sea cero.

El Asistente de Naive Bayes requiere que cada campo (ya sea objetivo o candidato para análisis) sea ordenado por rangos de manera que, para cada campo, el modelo considere únicamente una cantidad pequeña y finita de valores. El campo objetivo se trata como categórico; mientras que los candidatos para análisis toman sus rangos del conjunto de datos de modelación. Los valores se tratan como categorías separadas.

Resultados Se generan (en forma opcional) diversos resultados, entre otros:

  • Un informe de auditoría HTML que resume la forma en que la propensión del modelo Naive Bayes se aplicó, incluso los parámetros de entrada y la comparación con las respuestas históricas.
  • El modelo final recomendado en formatos Field Derivation Language [consulte la sección Acerca del lenguaje de derivación de campos (FDL)], QMML [consulte la sección Para guardar un modelo o una segmentación de Decision Studio para la implementación como QMML (XML)] y Predictive Model Markup Language (PMML).
  • El conjunto de datos final, incluso la predicción de modelo.

También consulte

Creación de un modelo de propensión con el Asistente de Naive Bayes
Tema principal: Creación de modelos Naive Bayes para segmentación y creación de modelos predictivos


Creación de un modelo de propensión con el Asistente de Naive Bayes

Guarde su enfoque de modelado, con el campo objetivo, los candidatos para análisis y las variables categóricas marcadas. Esta preparación se puede automatizar importando el enfoque de metadatos [consulte la sección Copiar metadata de un enfoque a otro] en el enfoque de modelado.

En Portrait Miner, haga clic con el botón secundario del mouse en un enfoque y elija Predecir>Asistente de Naive Bayes.

En el cuadro de diálogo Asistente de Naive Bayes, puede elegir qué campo objetivo, categoría y candidatos para análisis desea analizar, el umbral de Naive Bayes que desea usar y los detalles de los resultados de modelado creados.

También consulte

Acerca del Asistente de Naive Bayes

Acerca de los asistentes de Portrait Miner

Tema principal: Creación de modelos Naive Bayes para segmentación y creación de modelos predictivos


Creación de modelos de clustering para segmentación y creación de modelos predictivos

  • Sobre modelos de creación de clústeres en Portrait Miner
  • Para construir un modelo de clústeres
  • Opciones para visualizar un modelo de clustering
  • Cómo controlar la creación de un modelo de creación de clústeres


Sobre modelos de creación de clústeres en Portrait Miner

La creación de clústeres es un técnica de modelado no dirigida (libre de objetivos) que se utiliza para segmentar a una población en clústeres de registros similares basándose en los valores observados de uno o más campos de análisis.
  • Cada clúster en un modelo de creación de clústeres tiene un centro, que puede considerarse como un registro que contiene un valor para cada candidato de análisis (excepto por el hecho de que un campo [consulte Interpretación de los campos] categórico se trata como si fuera un conjunto de campos indicadores [consulte Los campos categóricos en la creación de clústeres]).
  • Cada registro en el foco pertenece al clúster cuyo centro está más cercano al registro de acuerdo con una métrica de distancia normalizada de suma de cuadrados [consulte Cómo mediar el tamaño y la separación de los clústeres].

También consulte

Cómo controlar la creación de un modelo de creación de clústeres

Para construir un modelo de clústeres

Tema principal: Creación de modelos de clustering para segmentación y creación de modelos predictivos

Cómo mediar el tamaño y la separación de los clústeres

La idea de creación de clústeres se basa en una medida de la distancia o cercanía entre registros.

Considere dos registros, [image] y [image] (donde [image] es el valor del campo j en el registro i). Primero normalice los valores de modo que cada campo tenga una media de 0 y una desviación estándar de 1 (para el conjunto de datos en base al cual está creado el modelo) :

donde [image] y [image] son respectivamente la media y la desviación estándar del campo j. Ahora, defina la distancia entre los registros [image] y [image] como la distancia euclidiana común de la suma de los cuadrados entre los registros normalizados [image] y [image]:

(Nótese que no existe raíz cuadrada).

Dada esta métrica de distancia, resulta posible cuantificar el tamaño de clúster (utilizando una de dos medidas, el radio o el ESS) y cuán bien separado está un clúster de los demás clústeres. Por extensión se puede cuantificar la calidad de un modelo de creación de clústeres.
  • El radio de un clúster es la distancia máxima entre el registro en el clúster y el centro del clúster. Un clúster ideal tiene radio cero.
  • El ESS de un clúster es la suma de las distancias de todos los registros en un clúster desde el centro del clúster. Un clúster ideal tiene ESS cero.

    En un modelo de creación de clústeres, el ESS total es la suma de los valores ESS para cada uno de los clústeres. Un modelo ideal tiene un ESS total igual a cero.

  • La separación para un registro es [image], donde [image] es la distancia entre el registro y el centro de clústeres más cercano, y [image] es la distancia entre el registro y el segundo centro más cercano. Los valores varían entre 0 y 1; un valor más alto indica que el registro tiene una conexión más sólida a su clúster asignado.

    La separación para un clústeres es la separación mínima para un registro en el clúster. Un clúster bien separado tiene un valor cercano a 1.

    La separación para un modelo de clústeres es la separación mínima para un registro en el conjunto de datos. Un buen modelo tiene un valor cercano a 1.

Nota:
  • Con el propósito de computar la métrica de distancia se debe considerar un campo categórico como un conjunto de campos indicadores [consulte Los campos categóricos en la creación de clústeres].
  • Cuando se aplica un modelo de creación de clústeres a un nuevo conjunto de datos los valores de normalizan con respecto a los parámetros de escala del conjunto de datos original.

Cómo crea Decision Studio un modelo de creación de clústeres

El Creador de clústeres en Decision Studio implementa un algoritmo no jerárquico del método de las K medias, también llamado "método de Lloyd".

El algoritmo ignora cualquier tipo de creación de rangos en un campo no categórico. Excluye a los candidatos de análisis no categórico con desviación estándar cero así como también los candidatos de análisis categórico con registros en sólo una categoría. Crea un campo ficticio para cada categoría no vacía de un candidato de análisis categórico incluido.

Dado un conjunto de clústeres iniciales (elegidos aleatoriamente), el algoritmo mueve registros iterativamente entre los clústeres para minimizar el ESS total:
  1. Cada registro se asigna al clúster de cuyo centro está más cerca (de acuerdo con la métrica de distancia). En el caso de que un registro esté equidistante de dos o más clústeres, el registro se asigna al primer clúster con la distancia mínima.
  2. Se excluyen los [consulte Parámetros para un modelo de creación de clústeres] valores atípicos.
  3. Las medias del clúster se (re)calculan y para la siguiente iteración los centros del clúster se configuran para ser las medias de ese clúster.
  4. Las iteraciones continúan hasta que se satisface uno de los criterios de [consulte Criterios de terminación para un modelo de creación de clústeres] terminación.

Los campos categóricos en la creación de clústeres

El algoritmo de creación de clústeres trata a un candidato de análisis categórico como si fuera un conjunto de campos indicadores numéricos, uno por categoría (incluyendo nulo [consulte El valor null] y categorías no clasificadas). Cada categoría en el campo original está representada por el valor 1 en el campo indicador correspondiente y el valor 0 en cada uno de los demás campos indicadores.

Por ejemplo, un campo categórico como el de Género, con tres categorías, Masculino, Femenino y Nulo, es representado por tres campos indicadores que aparecen en el Creador de clústeres como Gender (Masculino), Gender (Femenino) y Gender (Nulo). Un registro para un cliente mujer tiene valores 0, 1, y 0 respectivamente para esos campos indicadores. Un centro de clúster típico podría tener los valores 0.3, 0.2, y 0.5 en estos campos. (Los valores para los campos indicadores que corresponden a un campo categórico siempre suman 1.)

Cuando el Creador de clústeres muestra el número de dimensiones utilizadas para construir un clúster, cada campo indicador cuanta como una dimensión.

El valor nulo en la creación de clústeres

Cuando se computan distancias, el valor null [consulte El valor null] en un campo no categórico se considera que está igual de cerca a todos los centros de los clústeres, es decir, que su contribución a la distancia es cero y que la distancia desde el centro de un clúster se determina por el resto de los campos. % Duplica texto en el tema "Campos categóricos en la creación de clústeres". La categoría nulo en un candidato de análisis categórico se trata como cualquier otra categoría. Si los candidatos de análisis son no categóricos, los registros que contienen el valor nulo para todos ellos son ignorados ( y producen un resultado de índice de clúster nulo).
Nota: Cuando se aplica un modelo de clústeres, el Creador de clústeres trata a los valores categóricos que estaban vacíos o no estaban presentes en el momento de la creación asignando registros que los contienen al clúster nulo.


Para construir un modelo de clústeres

  1. Como opción, interprete algunos campos como candidatos para análisis [consulte Para establecer o borrar una interpretación categórica, geográfica, de candidato para análisis, de exportación o de clave].

    Si existen campos con una interpretación de candidato de análisis, el Creador de clústeres sólo considera esos campos cuando crea modelos de clústeres.

  2. Seleccione Herramientas>Creador de clústeres o haga clic en [image] en la barra de herramientas.
  3. De ser necesario, cambie las opciones de creación predeterminadas [consulte Cómo controlar la creación de un modelo de creación de clústeres].
  4. Seleccione Clustering>Crear hasta el final o haga clic en [image] en la barra de herramientas para crear un modelo de clústeres.

    El Creador de clústeres continua hasta que satisface una o más de los criterios de terminación [consulte Criterios de terminación para un modelo de creación de clústeres] para un modelo de creación de clústeres.

  5. Como opción, para crear una iteración adicional del modelo de clústeres, seleccione Clustering>Realizar la próxima iteración o haga clic en [image] en la barra de herramientas.

    (Si el modelo de creación de clústeres ha convergido o los parámetros de creación han cambiado, esta opción no está disponible).

Nota:
  • El Creador de clústeres es una herramienta de creación de modelos no dirigida. Por lo tanto no tiene en cuenta ningún objetivo que se haya establecido.
  • Los paneles a la izquierda de la ventana del Creador de clústeres muestran campos incluidos (candidatos de análisis) y campos excluidos (otros campos en el enfoque) con campos que aparecen en el modelo de creación de clústeres actual que se muestra en negrita.

    Puede interpretar un campo como un candidato para análisis si lo mueve del panel inferior al panel superior (y viceversa) mediante el uso de los botones de flecha entre los paneles.

  • Cuando se empieza a crear un modelo de clúster, el Creador de clústeres avisa que se deben interpretar todos los campos de cadena que no tengan una interpretación categórica, de modo que se puedan ubicar en rangos en forma apropiada. Puede elegir la interpretación categórica predeterminada o usar una jerarquía categórica guardada. Si hace clic en Cancelar cuando el Creador de clústeres le indica que elija una interpretación para un campo de cadena, el Creador de clústeres ignora ese candidato de análisis, junto con todos los demás campos de cadena sin interpretación categórica.
  • Las estadísticas para los modelos de creación de clústeres aparecen en el panel de Resultados de clustering . Entre estos se incluyen las medidas de calidad de modelos (ESS total y separación) así como también parámetros de creación de modelos.

    Las estadísticas para los clústeres en el último modelo que debe crearse aparece en el panel Detalles de cluster (excepto para los valores atípicos y nulos). Estos incluyen medidas de calidad de los clústeres (ESS, separación y radio) así como también el número de registros en cada clúster y los valores de campo que describen el centro de cada clúster.

  • Para borrar el historial de modelos de clústeres generado junto con los detalles del modelo actual, seleccione Clustering>Borrar o haga clic en [image] en la barra de herramientas.
  • Los clústeres en un modelo de creación de clústeres están numerados: cada registro tiene un índice de clúster asociado entre 1 y el número de clústeres, a menos que se considere un valor atípico [Consulte Parámetros para un modelo de creación de clústeres], en cuyo caso tiene el índice de clúster -1.

    Se puede derivar un campo [consulte Para derivar un campo desde un modelo o tabulación cruzada de Decision Studio] que contiene el índice de clúster.

También consulte

Sobre modelos de creación de clústeres en Portrait Miner

Cómo controlar la creación de un modelo de creación de clústeres

Para aplicar un modelo o segmentación de Decision Studio a una población distinta

Tema principal: Creación de modelos de clustering para segmentación y creación de modelos predictivos

Cómo elegir el número correcto de clústeres

El algoritmo [consulte Cómo crea Decision Studio un modelo de creación de clústeres] que usa el Creador de clústeres para crear un modelo de creación de clústeres exige que se especifique el numero objetivo de clústeres [consulte Parámetros para un modelo de creación de clústeres] por adelantado.
Si se elige un número inapropiado de clústeres, el Creador de clústeres no podrá encontrar un buen modelo de clústeres:
  • Si se especifican pocos clústeres, el Creador de clústeres fusiona clústeres distintos. En el peor de los casos, puede romper un clúster "natural" y distribuir sus contenidos en los clústeres vecinos, lo que resulta en un modelo que no captura en absoluto clústeres reales.
  • Si se especifican demasiados clústeres, el Creador de clústeres dividirá algunos clústeres en pequeñas partes.
Su conocimiento del negocio le indicará el número adecuado de clústeres, de lo contrario, experimente con distintos valores y decida cuál permite lograr el mejor modelo. Un método que funciona bien consiste en aprovechar el hecho de que, aunque es difícil detectar cuando hay pocos clústeres, cuando hay demasiados, la medida de separación tiende a ser baja.
  1. Comience por elegir un número bastante grande de clústeres y cree varios modelos, tratando de maximizar la medida de separación.
  2. Si no puede lograr una estadística de medida de separación cercana al 100%, reduzca el número de clústeres de a uno e intente nuevamente.
  3. Continúe hasta que, para el número elegido de clústeres, se puede obtener, aunque sea ocasionalmente, un modelo de creación de clústeres con una medida de separación alta.
Nota:
  • Es posible que no siempre obtenga el número de clústeres que usted especificó, dado que el Creador de clústeres excluye los clústeres vacíos del modelo de clústeres.
  • Tenga en cuenta que un modelo puede presentar una medida de separación alta simplemente porque clasifica a una gran cantidad de registros como valores atípicos.

Optimización de un modelo de creación de clústeres

La medida de separación proporciona una indicación razonablemente buena de cuando hay demasiados clústeres. Sin embargo, una vez que se tiene el número correcto de clústeres, no resulta tan útil para distinguir entre buenos y malos modelos.

Una forma de optimizar el modelo es mantener fijo el número de clústeres y crear un gran conjunto de modelos de clústeres, tratando de minimizar el ESS total.

Nota: Tenga en cuenta que un modelo puede presentar una medida de separación alta simplemente porque clasifica a una gran cantidad de registros como valores atípicos.

Como evitar el sobreajuste cuando se crea un modelo de creación de clústeres.

Al igual que con cualquier otra técnica de creación de modelos, se necesita hacer una evaluación y evitar el sobreajuste. Utilice una metodología de prueba/capacitación [consulte Metodología de prueba/capacitación para un modelo robusto] y tenga cuidado cuando usa los siguientes elementos:
  • Campos de análisis con un gran número de categorías
  • Un gran número de candidatos de análisis (en cuyo caso otro problema posible es que la mayoría de los registros terminan considerándose valores atípicos)
  • Un gran número objetivo de clústeres


Opciones para visualizar un modelo de clustering

Están disponibles las siguientes vistas del Creador de clusters:

Vista | Descripción
Vista tabla | Una vista de dos tablas, que muestra las estadísticas de modelos de clustering sucesivos en la tabla superior y estadísticas de los clusters del modelo más reciente en la tabla inferior, junto con paneles que muestran listas de campos incluidos y excluidos
Vista de gráfico | Un gráfico bidimensional o tridimensional [consulte la sección Gráficos del Creador de clusters], junto con un panel que enumera los campos en el enfoque (los campos incluidos en el modelo se muestran en negrita)

Inicialmente, el Creador de clusters muestra la viste de tabla (y la vista de gráfico no está disponible hasta que crea o abre un modelo de clustering). Para cambiar entre las vistas de tabla y de gráfico, elija la vista del menú Vista o haga clic en el botón correspondiente de la barra de herramientas.

Tema principal: Creación de modelos de clustering para segmentación y creación de modelos predictivos

Gráficos del Creador de clusters

En la vista de gráfico del Creador de clusters:
  • Seleccione la cantidad de campos del panel izquierdo que desee y haga clic en Gráfico 2D para obtener un conjunto de gráficos de perfil [consulte la sección Para crear un conjunto de gráficos de perfil de una sola variable] para esos campos.
  • Seleccione hasta tres campos del panel izquierdo y haga clic en Gráfico 3D para obtener un gráfico de distribución cruzada [consulte la sección Para crear un gráfico de distribución cruzada con variables múltiples] desglosado según sus campos elegidos.

En cualquier caso, el Creador de clusters asocia las siguientes estadísticas con aspectos del gráfico:

Estadística para segmento | Aspecto del gráfico
count | Altura del bloque (o volumen para un gráfico de distribución de tres campos)
mode de índice cluster | Color del bloque
proporción de modo [consulte la sección moderatio] de índice cluster | Brillo del bloque

Cuanto más puro un segmento, respecto del ideal de todos los registros incluidos en un cluster único, más brillante es el color del bloque de ese segmento (una proporción de modo de 1 para un segmento indica que todos los registros de ese segmento están en el mismo cluster).

Cada vista de gráfico muestra una leyenda, con bloques para brillo de 50 %, 75 % y 100 %, para dar una indicación útil respecto de la forma en que cada color varía con el brillo.


Cómo controlar la creación de un modelo de creación de clústeres

Para controlar el modo en que el Creador de clústeres crea un modelo de clúster, seleccione Clustering>Parámetros y cambie la configuración en el cuadro de diálogo Parámetros de clustering :

También consulte

Sobre modelos de creación de clústeres en Portrait Miner

Para construir un modelo de clústeres

Tema principal: Creación de modelos de clustering para segmentación y creación de modelos predictivos

Parámetros para un modelo de creación de clústeres

En la mitad superior del cuadro de diálogo Parámetros de clustering existen configuraciones para los parámetros generales de modelado de clústeres:

Configuración | Descripción
Cantidad de clústeres: | El número objetivo de clústeres separados en un modelo de creación de clústeres
Límite de valor atípico | Un múltiplo m que determina qué registros se tratarán como valores atípicos. El Creador de clústeres trata a un registro como un valor atípico si, para un candidato a análisis no categórico, la diferencia entre el valor para el registro y el valor para el centro del clúster más cercano excede las desviaciones estándar m del campo. Si no se establece el límite de valores atípicos, ningún registro se considera como valor atípico.
Semilla personalizada | Una semilla para inicializar los centros de los clústeres en el algoritmo de creación de clústeres. Si no se establece la semilla personalizada, el Creador de clústeres elige una semilla (basada en el reloj del sistema) para cada creación. El personalizar la semilla permite que se generen modelos de creación de clústeres repetibles.
Para reproducir un modelo de creación de clústeres creado previamente, coloque la semilla aleatoria a la que se muestra para el modelo en el panel de Resultados de clustering .

Criterios de terminación para un modelo de creación de clústeres

En la mitad inferior del cuadro de diálogo Parámetros de clustering , existen configuraciones que determinan el momento en que el Creador de clústeres deja de buscar modelos de clústeres mejorados:

Configuración | Descripción
Iteraciones máximas: | El número máximo de iteraciones del algoritmo de creación de clústeres que realizará el Creador de clústeres
Movimiento mínimo: | El número de n registros de modo que, si el Creador de clústeres reclasifica menos de n registros entre clústeres durante una iteración, no realizará más iteraciones. Se puede especificar el número de registros en términos absolutos o como un porcentaje de la población total.
Nota: El algoritmo del Creador de clústeres termina cuando queda satisfecho uno de los dos criterios de terminación. Por lo tanto, por lo general termina sin haber satisfecho uno de los dos criterios.


Aplicación de modelos y segmentaciones a nuevos datos de transacciones y clientes

  • Para guardar un modelo o una segmentación de Decision Studio para la implementación como QMML (XML)
  • Para convertir un modelo o segmentación de Decision Studio para implementación en SAS
  • Para convertir un modelo o segmentación de Decision Studio para implementar en SQL
  • Metadatos de modelos
  • Creación de una foto de modelo


Para guardar un modelo o una segmentación de Decision Studio para la implementación como QMML (XML)

Puede guardar un modelo o una segmentación como un documento QMML (XML) para implementarlo a través del asistente Derivar campos [consulte Para derivar campos en un enfoque mediante el uso de Portrait Miner], el comando de creación de datos de Portrait Miner qsderive o para Portrait Dialogue o Portrait Interaction Optimizer (a través de QMML).
  1. Si el modelo o la segmentación ya no se expresó en términos de campos derivados en un enfoque, realice una de las siguientes acciones:
    • Para un árbol de decisiones, una scorecard o un modelo de clústeres, derive campos generados [consulte Para derivar un campo desde un modelo o tabulación cruzada de Decision Studio] para encapsular las funciones importantes de su modelo.
    • Para una segmentación de gráficos, derive un campo marcado [consulte Para derivar un campo de una segmentación gráfica] para segmentos clave de la población identificada de su gráfico.
    • Para una tabulación cruzada (textual o gráfica), derive un campo de índice [consulte Para derivar un campo desde un modelo o tabulación cruzada de Decision Studio] que represente completamente la segmentación.
    • Para un modelo o una segmentación basada en reglas comerciales, derive campos que utilicen Visor de Tablas [consulte Para derivar un campo utilizando Visor de Tablas].
  2. En Visor de Tablas, seleccione Archivo>Exportar como QMML o haga clic en [image] en la barra de herramientas.

    Aparece un navegador de archivos de Portrait Miner.

  3. Desplácese [consulte Exploración para abrir o guardar un archivo o tabla de base de datos] hasta una ubicación en la que guarda su documento QMML y seleccione un nombre para él.

    Decision Studio guarda un documento QMML que incluye definiciones de campos derivados en el enfoque.

Nota:
  • Cuando seleccione Archivo>Exportar como QMML, Portrait Miner analiza automáticamente QMML. Esto elimina la necesidad de utilizar el comando de creación de datos qsqmmledit -parse. Si hay un error, Portrait Miner le notifica acerca de las derivaciones que no pudieron analizarse. En este caso, se crea un archivo QMML, pero sin la representación estructurada de las derivaciones de problemas.
  • Cuando seleccione Archivo>Exportar como QMML, el documento QMML incluye un conjunto de reglas que enumera todos los campos derivados que están seleccionados en Visor de Tablas, o todos los campos derivados si no hay campos seleccionados. Independientemente del campo que aparezca en el conjunto de reglas, el documento QMML incluye definiciones para todos los campos derivados.
  • Si desea incluir funciones FDL definidas por el usuario al analizar QMML en Decision Studio, puede definir funciones de acceso global mediante su almacenamiento en un archivo (o archivos) de una carpeta incluida en la preferencia bibliotecas de derivación [consulte bibliotecas de derivación].

También consulte

Acerca de Transaction Measurement Language

Para aplicar un modelo o segmentación de Decision Studio a una población distinta

Para convertir un modelo o segmentación de Decision Studio para implementación en SAS

Para convertir un modelo o segmentación de Decision Studio para implementar en SQL

Para guardar una tabulación cruzada de Decision Studio

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

XML en Portrait Miner

Tema principal: Aplicación de modelos y segmentaciones a nuevos datos de transacciones y clientes


Para convertir un modelo o segmentación de Decision Studio para implementación en SAS

Puede convertir a formato SAS mediante Portrait Miner. Se crea una instrucción SAS separada para cada derivación de campo.

En Portrait Miner, haga clic con el botón secundario del mouse en el archivo QMML que desee convertir y seleccionar Convert to SAS.

En el cuadro de diálogo Convert to SAS format, seleccione los campos de salida necesarios y una ubicación para guardar el modelo SAS.

Nota:
  • La conversión a la función SAS es experimental.
  • Esta interfaz de usuario es una forma de acceder a muchas de las funciones proporcionadas por el comando de creación de datos qsqmml2sas de Portrait Miner.

También consulte

Acerca de los asistentes de Portrait Miner

Para guardar un modelo o una segmentación de Decision Studio para la implementación como QMML (XML)

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Tema principal: Aplicación de modelos y segmentaciones a nuevos datos de transacciones y clientes


Para convertir un modelo o segmentación de Decision Studio para implementar en SQL

Puede convertir a formato SQL mediante Portrait Miner. Se crea una instrucción SELECT de SQL separada para cada derivación de campo. Portrait Miner admite los siguientes tipos de base de datos:
  • Oracle
  • Teradata
  • Microsoft SQL Server

En Portrait Miner, haga clic con el botón secundario del mouse en el archivo QMML que desee convertir y seleccione Convertir a SQL.

En el cuadro de diálogo Convertir QMML a SQL, seleccione la tabla de origen y el tipo de base de datos de destino.

Nota:
  • La conversión a la función SQL es experimental.
  • En SQL, la evaluación de tipos entero a booleano no está permitida.
  • Esta interfaz de usuario es una forma de acceder a muchas de las funciones proporcionadas por el comando de creación de datos qsqmml2sql de Portrait Miner.

También consulte

Acerca de los asistentes de Portrait Miner

Para guardar un modelo o una segmentación de Decision Studio para la implementación como QMML (XML)

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Tema principal: Aplicación de modelos y segmentaciones a nuevos datos de transacciones y clientes


Metadatos de modelos

Metadata es "datos acerca de datos". Cada modelo que cree, ya sea un árbol de decisiones, scorecard o modelo de clústeres, tiene metadatos asociados a él.
  • La fecha y la hora en que se creó el modelo
  • Quién creó el modelo
  • El enfoque en el que está basado el modelo
  • La versión de Decision Studio que se utilizó para crear el modelo
  • Comentarios del modelo (que puede editar en Decision Studio)
  • Configuración de parámetros de creación de modelos vigente en el momento en que se creó el modelo

Cuando guarda [consulte Para guardar un árbol de decisión, scorecard o modelo de clustering] un modelo, el archivo de modelos incluye estos metadatos junto con la descripción del modelo en sí.

Para ver otros metadatos asociados a este árbol de decisiones o scorecard, seleccione Árbol (en el Creador de árboles de decisión) o Scorecard (en Creador de scorecards).

También consulte

Creación de una foto de modelo
Tema principal: Aplicación de modelos y segmentaciones a nuevos datos de transacciones y clientes

Adjuntar comentarios a un modelo

Puede agregar comentarios a un árbol de decisiones o scorecard, que pueden ser útiles al compartir sus modelos con otras personas, o incluso al volver a verlos después de no haber trabajado con ellos durante un tiempo.
  • En el Creador de árboles de decisión, para adjuntar comentarios a un árbol de decisiones, seleccione Árbol>Editar comentarios de modelo.
  • En Creador de scorecards, para adjuntar comentarios a un scorecard, seleccione Scorecard>Editar comentarios de modelo.

En cualquiera de los casos, aparecerá un cuadro de diálogo con tres áreas de comentario que puede editar, en las que puede registrar la ventana de observación aplicable al modelo, detalles de cómo validó el modelo y cualquier otra nota que desee realizar.

Nota:
  • Los comentarios de modelos aparecen como parte de un informe Foto de modelo [consulte Creación de una foto de modelo], junto con los comentarios que agrega al crear el informe.
  • Si marca el cuadro HTML, Decision Studio considera a los pares equilibrados de etiquetas, por ejemplo <b>...</b>, como marcado HTML, y muestra los comentarios correspondientes.


Creación de una foto de modelo

Una foto de modelo es un informe en formato HTML que contiene una descripción detallada de un árbol de decisión o scorecard, incluidas varias estadísticas del modelo y perfiles de todos los campos involucrados en el modelo.

Para crear una foto de modelo en Portrait Miner, haga clic con el botón secundario del mouse en el modelo guardado [consulte la sección Para guardar un árbol de decisión, scorecard o modelo de clustering] que desea estudiar y luego seleccione Crear foto de modelo.

En el cuadro de diálogo Foto de árbol de decisión o Foto de Scorecard, puede seleccionar para ver un informe del enfoque o de otro enfoque y además, opcionalmente puede informar todos los campos o no campos, a diferencia de los campos involucrados en el modelo.

Nota:
  • Si especifica una descripción para la foto de modelo, aparece junto con cualquier comentario sobre el modelo [consulte la sección Adjuntar comentarios a un modelo], en la sección "Metadata provista por el usuario" del informe.

  • Puede seleccionar una de las cuatro opciones de formatos de imágenes para la salida HTML:

    svg SVG (Gráficos Vectoriales Escalables [scalable vector graphics]) solamente. SVG proporciona la mejor calidad de imagen y el tamaño más pequeño de archivos, pero quienes lean su informe deberán contar con un explorador web con un complemento SVG para poder visualizar o imprimir estas imágenes.

    smallpng SVG más los mapas de bits de PNG (gráficos de red portátiles [portable network graphics]) con visualización en pantalla optimizada. Aunque sin complemento SVG, los lectores podrán ver las imágenes del informe (pero la calidad de impresión será deficiente).

    largepng SVG más los mapas de bits de PNG con visualización en pantalla e impresión optimizadas. Los lectores podrán ver o imprimir el informe sin necesidad de un complemento SVG (pero ocupa más espacio de disco y es posible que sea más lento visualizar el informe).

    ninguno sin imágenes.

  • Puede controlar otros aspectos de la apariencia de los informes de foto de modelo y de perfil y auditoría configurando las preferencias [consulte la sección Para configurar las preferencias de Portrait Miner] en la sección Auditorías y fotos de la ventana de Preferencias.
  • Para que Portrait Miner le notifique por correo electrónico cuando está finalizado el informe, deberá configurar las preferencias emailaddress y emailserver de manera adecuada.
  • Por defecto, Portrait Miner guarda una foto de modelo como un único archivo .qshtml, con imágenes insertadas. Si bien puede abrir este archivo en Portrait Miner (haciendo doble clic en él), no puede utilizarlo directamente fuera de Portrait Miner.

    Para crear una página web que se pueda ubicar en un servidor web, haga clic con el botón secundario del mouse en un archivo .qshtml y seleccione Descomprimir en carpeta. Elija una ubicación, seleccione o cree una carpeta y haga clic en Aceptar.

  • El cuadro de diálogo Crear perfil y auditar es una manera de acceder a muchas de las funciones que ofrece el comando de creación de datos qsdtsnapshot o qsscsnapshot de Portrait Miner.

También consulte

Acerca de los asistentes de Portrait Miner

Creación de un perfil y auditoría de un enfoque

Para configurar opciones globales para la visualización gráfica

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Tema principal: Aplicación de modelos y segmentaciones a nuevos datos de transacciones y clientes


Preferencias de Portrait Miner

  • Uso de preferencias
  • Rangos y funciones de Decision Studio
  • Herramientas de visualización de Decision Studio
  • Creador de árbol de decisión
  • Creador de scorecards
  • Formato de fecha
  • Navegación por archivos
  • Archivos planos
  • Bases de datos
  • Auditorías y fotos
  • Notificación por correo electrónico
  • Administración y calibración del sistema
  • Integración de sistemas y tiempo real


Uso de preferencias

  • Para configurar las preferencias de Portrait Miner
Tema principal: Preferencias de Portrait Miner


Para configurar las preferencias de Portrait Miner

Puede personalizar diferentes aspectos de Portrait Miner para adaptarlo a sus requisitos individuales.
  1. En Portrait Miner, seleccione Editar>Preferencias.
  2. Seleccione la sección relevante del panel izquierdo en la ventana de Preferencias.

    Las opciones disponibles de la sección seleccionada aparecerán en el panel derecho.

  3. Haga los cambios de la siguiente manera:
    • Active o desactive una casilla de verificación para activar o desactivar una opción.
    • Haga clic en la celda Valor para editar un número o texto. (Para salir de los cambios mientras edita un número o un texto, haga clic con el botón secundario del mouse en la celda y seleccione la opción Cancelar).

      Si las flechas hacia arriba y hacia abajo aparecen en la celda, puede utilizarlas para cambiar el valor numérico.

      Si la celda tiene un menú desplegable, puede seleccionar una opción del menú.

      Si aparece [image], puede hacer clic en él para explorar [consulte la sección Exploración para abrir o guardar un archivo o tabla de base de datos] y buscar un archivo o una carpeta.

  4. Haga clic en Guardar para confirmar los cambios.
  5. Haga clic en Salir para cerrar la ventana de Preferencias.
Nota:
  • Las configuraciones de preferencias entran en vigencia solo cuando se inicia la aplicación.
  • Cuando haya anulado el valor por defecto por una opción, su nombre aparecerá en negrita en la ventana de Preferencias.
  • Para deshacer una configuración de preferencias, y restaurar la preferencia al valor que tenía antes de abrir la ventana de Preferencias, haga clic con el botón secundario del mouse en el nombre de la preferencia y seleccione Deshacer.
  • Para restaurar la configuración por defecto de sistemas para una preferencia, haga clic con el botón secundario del mouse en el nombre de la preferencia y seleccione Restaurar la configuración por defecto.

    Para restaurar las configuraciones por defecto de sistemas para todas las preferencias en la sección actual, seleccione Editar>Restaurar las configuraciones por defecto de nombres de la sección. Para restaurar las configuraciones por defecto de sistemas para todas las preferencias, seleccione Editar>Restaurar todas las configuraciones por defecto.

  • Si configura el valor de alguna de las preferencias de escritura de fecha, escritura total, leer o escritura de hora a europeo, americano, o AMD en la ventana de Preferencias, las otras preferencias se configurarán automáticamente a ese valor.
  • Las configuraciones por defecto de sistemas para las preferencias no son necesariamente lo mismo que configuraciones por defecto de fábrica: el administrador del sistema puede haber anulado algunas configuraciones. En la descripción de preferencias individuales, las opciones predeterminadas de fábrica están indicadas.
  • Cualquier opción que configure en la ventana de Preferencias se aplicará a todas las partes de Portrait Miner.
  • Si visualiza una advertencia sobre una preferencia no reconocida, la explicación probable es que una de las configuraciones corresponde a una preferencia que está obsoleta. Puede quitar la configuración total haciendo clic con el botón secundario del mouse en el nombre de la preferencia y eligiendo Restaurar la configuración por defecto. (La entrada de la preferencia todavía aparecerá en la ventana de Preferencias hasta que guarde y salga del sistema).
  • Si no puede cambiar la configuración de una preferencia, se debe a que el administrador de su sistema la ha bloqueado para evitar que los usuarios realicen cambios.
  • Determinadas preferencias solo pueden ser modificadas por expertos y, por ende, están ocultas por defecto. Pueden ser cambiadas solo por el administrador de Portrait Miner. Para ver todas las preferencias, seleccione Ver>Mostrar todas las preferencias.

También consulte

Para configurar opciones globales para la visualización gráfica

Para configurar el formato de visualización para valores numéricos y de fecha

Tema principal: Uso de preferencias


Rangos y funciones de Decision Studio

  • rangos de final automático
  • rangos de final automático para mismos registros
  • tipo de rangos por defecto
  • tamaño mínimo por defecto de rangos (Rango categórico)
  • número de rangos por defecto (Rango categórico)
  • número de rangos por defecto (Rango numérico)
  • mostrar el mismo ancho
  • número máximo de rangos por fecha
Tema principal: Preferencias de Portrait Miner


rangos de final automático

Sección Rango numérico

Objetivo Controlar si Decision Studio crea rangos finales [consulte la sección Rangos finales] al ordenar por rango un campo numérico.

Valores válidos

Valor | Descripción
true (predeterminado) | Crea rangos finales "inteligentes" para rangos numéricos (pero consulte rangos de final automático con mismos registros).
false | No crea rangos finales para rangos numéricos.
Tema principal: Rangos y funciones de Decision Studio


rangos de final automático para mismos registros

Sección Rango numérico

Objetivo Controlar si Decision Studio crea rangos finales [consulte la sección Rangos finales] al ordenar por rango un campo numérico con rangos con mismos registros.

Valores válidos

Valor | Descripción
true | Trata a rangos con mismos registros de la misma forma que a los rangos iguales: usa la configuración de rangos de final automático.
false (predeterminado) | No crea rangos finales para rangos con mismos registros.
Tema principal: Rangos y funciones de Decision Studio


tipo de rangos por defecto

Sección Rango numérico

Objetivo Configurar el tipo de rango por defecto que Decision Studio aplica a campos numéricos y de fecha.

Valores válidos

Valor | Descripción
rangos iguales (predeterminado) | Crea rangos iguales en forma predeterminada.
población equivalente | Crea rangos con mismos registros en forma predeterminada.
Nota:

Puede anular esta configuración según cada enfoque: En Binning Editor, seleccione Rangos>Parámetros por defecto o haga clic en [image] en la barra de herramientas; debajo de la ficha No categórico, seleccione en el menú Tipo de rango.

Tema principal: Rangos y funciones de Decision Studio


tamaño mínimo por defecto de rangos (Rango categórico)

Sección Rango categórico

Objetivo Configurar el tamaño mínimo de rangos para un campo categórico en Decision Studio.

Valores válidos Un número entero no negativo; por defecto, 0

Cuando Decision Studio crea un rango categórico en un campo, únicamente crea rangos para valores que se producen, al menos, en una cantidad especificada de registros. Otros valores no están clasificados.

Nota: Puede anular esta configuración según cada enfoque: En Binning Editor, seleccione Rangos>Parámetros por defecto o haga clic en [image] en la barra de herramientas; en la ficha Categórico, establezca Tamaño mínimo de categoría.

También consulte

número de rangos por defecto (Rango categórico)
Tema principal: Rangos y funciones de Decision Studio


número de rangos por defecto (Rango categórico)

Sección Rango categórico

Objetivo Configurar el número máximo de rangos para un campo categórico en Decision Studio.

Valores válidos Un número entero no negativo; por defecto, 250

Cuando Decision Studio crea un rango categórico en un campo, únicamente crea rangos para, al menos, la cantidad especificada de valores (primero se eligen los valores más comunes). Otros valores no están clasificados.

Nota: Puede anular esta configuración según cada enfoque: En Binning Editor, seleccione Rangos> Parámetros por defecto o haga clic en [image] en la barra de herramientas; debajo de la ficha Categórico, establezca Cantidad máxima de categorías.

También consulte

tamaño mínimo por defecto de rangos (Rango categórico)
Tema principal: Rangos y funciones de Decision Studio


número de rangos por defecto (Rango numérico)

Sección Rango numérico

Objetivo Configurar el número de rangos por defecto objetivo para un rango numérico o de fecha en Decision Studio.

Valores válidos Un número entero no negativo; por defecto, 10

Nota:
  • El número de rangos objetivo no incluye los rangos finales [consulte la sección Rangos finales] y los rangos para valores nulos [consulte la sección El valor null] y sin clasificar.
  • Puede anular esta configuración según cada enfoque: En Binning Editor, seleccione Rangos> Parámetros por defecto o haga clic en [image] en la barra de herramientas; debajo de la ficha No categórico, establezca Rangos internos objetivo.
Tema principal: Rangos y funciones de Decision Studio


mostrar el mismo ancho

Sección Rango numérico

Objetivo Configurar el modo de visualización predeterminado que Decision Studio utiliza para rangos numéricos y de fecha: histograma o gráfico de barras [consulte la sección Opciones de histograma y gráfico de barras].

Valores válidos

Valor | Descripción
true (predeterminado) | Usa el modo de visualización gráfico de barras.
false | Usa el modo de visualización histograma.
Nota:
  • El modo de visualización de un rango también afecta las vistas gráficas en el Visor de perfil y el Visor de Distribución Cruzada.
  • Puede anular esta configuración según cada enfoque: En Binning Editor, seleccione Rangos>Parámetros por defecto o haga clic en [image] en la barra de herramientas; debajo de la ficha No categórico, seleccione en el menú Gráfico.
Tema principal: Rangos y funciones de Decision Studio


número máximo de rangos por fecha

Sección Rango de fecha

Objetivo Configurar el número máximo de rangos para un campo de fecha (el ancho de rango se ajusta en consecuencia). Esto evita, por ejemplo, ordenar sin darse cuenta un rango de siglos por segundos.

Valores válidos Un número entero entre 1 y 1000; %No está en el archivo ini por defecto, 100

Tema principal: Rangos y funciones de Decision Studio


Herramientas de visualización de Decision Studio

  • tamaño máximo
  • función de objetivo
Tema principal: Preferencias de Portrait Miner


tamaño máximo

Sección Agregación

Objetivo Establecer el tamaño de la tabulación cruzada más grande [consulte Tabulaciones cruzadas como la base para la segmentación y visualización de datos] que Decision Studio puede crear.

Valores válidos Un número entero no negativo, por defecto 100.000.

Nota: Para calcular el tamaño de una tabulación cruzada en este sentido, calcule

para una tabulación cruzada que implica N campos de desglose, con [image], [image], ..., [image] rangos respectivamente (incluidos rangos finales [consulte Rangos finales] cuando corresponda, y rangos nulos [consulte El valor null] y rangos no clasificados). Por ejemplo, una tabulación cruzada con campos de desglose Income y Age, en rangos de 10 y 8 rangos internos respectivamente, tiene un tamaño de [image].
Tema principal: Herramientas de visualización de Decision Studio


función de objetivo

Sección Agregación

Objetivo Establecer la función de agregación [consulte la sección Funciones de agregación para tabulaciones cruzadas] que aplica Decision Studio a un objetivo por defecto, cuando crea una vista de tabulación cruzada [consulte la sección Para crear una vista de tabulación cruzada textual], gráfico de perfil [consulte la sección Para crear un conjunto de gráficos de perfil de una sola variable], gráfico de distribución cruzada [consulte la sección Para crear un gráfico de distribución cruzada con variables múltiples] o gráfico de mapa [consulte la sección Crear un gráfico en un mapa]. (Para los gráficos, Decision Studio asocia el resultado con un color de bloque).

Valores válidos

Valor | Descripción
any | Muestra un valor arbitrario [consulte la sección any] del objetivo.
countnonnull | Muestra el recuento de registros que no son nulos [consulte la sección countnonnull/countnonnulls] en el objetivo.
countnull | Muestra el recuento de registros que son nulos [consulte la sección countnull/countnulls] en el objetivo.
countunique | Muestra la cantidad de valores únicos [consulte la sección countunique] del objetivo, que posiblemente incluya el valor nulo.
countuniquenonnull | Muestra la cantidad de valores únicos [consulte la sección countuniquenonnull] del objetivo, que no incluye el valor nulo.
first | Muestra el valor del objetivo para el primer registro [consulte la sección first].
last | Muestra el valor del objetivo para el último registro [consulte la sección last].
max | Muestra el valor máximo [consulte la sección max (un argumento)] del objetivo.
mean (por defecto) | Muestra el valor medio [consulte la sección mean (un argumento)] del objetivo.
median | Muestra el valor mediano [consulte la sección median] del objetivo.
min | Muestra el valor mínimo [consulte la sección min (un argumento)] del objetivo.
mode | Muestra el modo (valor más común) [consulte la sección mode] del objetivo.
moderatio | Muestra la proporción de registros que contienen el valor más común [consulte la sección moderatio] del objetivo.
percentagerate | Muestra el porcentaje de los registros que contienen el valor 1 [consulte la sección percentagerate] para el objetivo (binario).
significance | Muestra la significancia de la diferencia entre la media del objetivo del segmento y aquella de la población en general.
stdev | Muestra la desviación estándar de los valores [consulte la sección stdev] en el objetivo.
sum | Muestra la suma de los valores [consulte la sección sum (un argumento)] en el objetivo.
variance | Muestra la varianza de los valores [consulte la sección variance] en el objetivo.
Tema principal: Herramientas de visualización de Decision Studio


Creador de árbol de decisión

  • valor de reemplazo de uplift infinito
Tema principal: Preferencias de Portrait Miner


valor de reemplazo de uplift infinito

Sección Constructor de Árboles de Decisión

Objetivo El valor de uplift de un segmento en un uplift binario x árbol puede ser infinito. Este valor se utiliza para representar el uplift infinito donde se informa (vistas de texto, campos de resultados, etc.).

Valores válidos Un número real no negativo, por defecto

Tema principal: Creador de árbol de decisión


Creador de scorecards

  • tasa de aceptación
  • transformación de atributo
  • tasa de desaciertos
  • corte
  • doble de probabilidades
  • probabilidades
  • tarjeta inicial
  • invertir objetivo
  • iteraciones
  • modelo
  • número de lugares decimales de precisión
  • un coeficiente de ponderación por característica
  • medida de calidad
  • ejecuciones
  • solucionador
  • tolerancia
Tema principal: Preferencias de Portrait Miner


tasa de aceptación

Sección Creador de scorecards

Objetivo Establecer el umbral de la tasa de aceptación inicial [consulte Campos asociados con árboles de decisión, scorecards, modelos de clústeres y tabulaciones cruzadas abstractas.] (o tasa de destino) que utiliza Creador de scorecards.

Valores válidos Un número real entre 0 y 1, por defecto 0.5

Nota: Normalmente no debe establecer más de un corte, tasa de desaciertos y tasa de aceptación, dado que el primero de estos que se establece (en el orden mencionado aquí) siempre precede a cualquiera de los otros.
Tema principal: Creador de scorecards


transformación de atributo

Sección Creador de scorecards

Objetivo Controlar la forma en que el Creador de scorecardstransforma valores de rangos individuales en un modelo de un coeficiente de ponderación por campo [consulte la sección un coeficiente de ponderación por característica].

Valores válidos

Valor | Descripción
Registrar probabilidades (predeterminado) | Use el registro de probabilidades (el "coeficiente de ponderación de evidencia").
Media | Usar la media.
Probabilidades | Usar las probabilidades.
Registrar media | Usar el registro de la media.
Nota:

Puede anular la configuración de esta preferencia si cambia el formulario [consulte la sección Para cambiar el formulario de un scorecard] en el cuadro de diálogo Formulario de Scorecard.

Tema principal: Creador de scorecards


tasa de desaciertos

Sección Creador de scorecards

Objetivo Establecer el umbral de la tasa de desaciertos inicial [consulte Campos asociados con árboles de decisión, scorecards, modelos de clústeres y tabulaciones cruzadas abstractas.] (o la tasa de aceptación) que utiliza Creador de scorecards.

Valores válidos Un número real entre 0 y 1, por defecto 0.5

Nota: Normalmente no debe establecer más de un corte, tasa de desaciertos y tasa de aceptación. dado que el primero de estos que se establece (en el orden mencionado aquí) siempre precede a cualquiera de los otros.
Tema principal: Creador de scorecards


corte

Sección Creador de scorecards

Objetivo Establecer la puntuación de corte inicial [consulte Campos asociados con árboles de decisión, scorecards, modelos de clústeres y tabulaciones cruzadas abstractas.] que utiliza Creador de scorecards.

Valores válidos Un número real, por defecto 500

Nota: Normalmente no debe establecer más de un corte, tasa de desacierto y tasa de aceptación, dado que el primero de estos que se establece (en el orden mencionado aquí) siempre precede a cualquiera de los otros.
Tema principal: Creador de scorecards


doble de probabilidades

Sección Creador de scorecards

Objetivo Configurar el factor doble inicial [consulte la sección Campos asociados con árboles de decisión, scorecards, modelos de clústeres y tabulaciones cruzadas abstractas.] que el Creador de scorecardsutiliza para la relación entre resultado y probabilidades.

Valores válidos Un número real positivo; por defecto, 20

También consulte

probabilidades
Tema principal: Creador de scorecards


probabilidades

Sección Creador de scorecards

Objetivo Configurar el factor inicial de probabilidades [consulte la sección Campos asociados con árboles de decisión, scorecards, modelos de clústeres y tabulaciones cruzadas abstractas.] que el Creador de scorecardsutiliza para la relación entre resultado y probabilidades.

Valores válidos Un número real positivo; por defecto, 500

También consulte

doble de probabilidades
Tema principal: Creador de scorecards


tarjeta inicial

Sección Creador de scorecards

Objetivo Configurar el scorecard inicial que el Creador de scorecardsutiliza al aplicar un solucionador iterativo.

Valores válidos

Valor | Descripción
lineal (predeterminado) | Usa la regresión lineal (análisis discriminatorio) para generar un scorecard inicial.
fijado | Usa un scorecard inicial con iguales coeficientes de ponderaciones para todas las variables.
actual | Usa el scorecard actual como scorecard inicial.
aleatorio | Usa un scorecard inicial generado en forma seudoaleatoria [consulte la sección Sobre las funciones de números aleatorios en FDL].
Nota:

Puede anular la configuración de esta preferencia si cambia la tarjeta de inicio [consulte la sección Para cambiar el solucionador utilizado para crear un scorecard] en el cuadro de diálogo Solucionador de Scorecard.

Tema principal: Creador de scorecards


invertir objetivo

Sección Creador de scorecards

Objetivo Cambiar la interpretación 1/0 del objetivo.

Valores válidos

Valor | Descripción
true | Interpreta registros con 0 en el objetivo como en mora/cancelación/respuesta.
false (predeterminado) | Interpreta registros con 1 en el objetivo como en mora/cancelación/respuesta.
Nota:

Puede anular la configuración de esta preferencia si utiliza la opción del menú Scorecard>Invertir el valor objetivo.

Tema principal: Creador de scorecards


iteraciones

Sección Creador de scorecards

Objetivo Configurar la cantidad máxima de iteraciones que utiliza un solucionador de scorecard iterativo.

Valores válidos Un número entero positivo; por defecto, 1000

Nota: Puede anular la configuración de esta preferencia si cambia la cantidad máxima de iteraciones [consulte la sección Para cambiar el solucionador utilizado para crear un scorecard] en el cuadro de diálogo Solucionador de Scorecard.

También consulte

tolerancia
Tema principal: Creador de scorecards


modelo

Sección Creador de scorecards

Objetivo Controlar el tipo de modelo predeterminado .

Valores válidos

Valor | Descripción
riesgo (predeterminado) | Crea un modelo de riesgo.
respuesta | Crea un modelo de respuesta.
cancelación | Crea un modelo de cancelación.
satisfacción | Crea un modelo de satisfacción.
insatisfacción | Crea un modelo de insatisfacción.
Tema principal: Creador de scorecards


número de lugares decimales de precisión

Sección Creador de scorecards

Objetivo Controlar el número de lugares decimales de precisión respecto de los cuales el Creador de scorecardsrealiza cálculos aproximados, como el valor Gini de un scorecard.

Valores válidos Un número entero entre 1 y 8; por defecto, 3

Nota: Puede anular la configuración de esta preferencia si elige Scorecard>Solucionador en el Creador de scorecardsy cambia el número de lugares decimales de precisión.
Tema principal: Creador de scorecards


un coeficiente de ponderación por característica

Sección Creador de scorecards

Objetivo Controlar si el Creador de scorecardsutiliza un coeficiente de ponderación por campo o un coeficiente de ponderación por rango.

Valores válidos

Valor | Descripción
true (predeterminado) | Usa un coeficiente de ponderación por campo.
false | Usa un coeficiente de ponderación por rango.
Nota:

Puede anular la configuración de esta preferencia si cambia el formulario [consulte la sección Para cambiar el formulario de un scorecard] en el cuadro de diálogo Formulario de Scorecard.

También consulte

transformación de atributo
Tema principal: Creador de scorecards


medida de calidad

Sección Creador de scorecards

Objetivo Configurar la medida de calidad que utiliza el Creador de scorecards.

Valores válidos

Valor | Descripción
lineal (predeterminado) | Usa la regresión lineal (análisis discriminatorio).
logística | Usa la regresión logística.
probits | Usa la línea de regresión de probits.
Nota:

Puede anular la configuración de esta preferencia si elige una medida de calidad [consulte la sección Para cambiar la medida de calidad utilizada para crear un scorecard] en el menú Scorecard>Medida de calidad.

Tema principal: Creador de scorecards


ejecuciones

Sección Creador de scorecards

Objetivo Configurar la cantidad de veces que el Creador de scorecardsaplica un método al optimizar un scorecard.

El Creador de scorecardsutiliza un valor promedio de todas las ejecuciones.

Valores válidos Un número entero positivo; por defecto, 1

Nota: Puede anular la configuración de esta preferencia si cambia la cantidad de ejecuciones [consulte la sección Para cambiar el solucionador utilizado para crear un scorecard] en el cuadro de diálogo Solucionador de Scorecard.
Tema principal: Creador de scorecards


solucionador

Sección Creador de scorecards

Objetivo Configurar el método solucionador que utiliza el Creador de scorecards.

Valores válidos

Valor | Descripción
directo (predeterminado) | Usa la inversión de matriz directa para realizar la regresión lineal.
gradiente conjugado | Usa el método de gradiente conjugado.
levenberg-marquardt | Usa el método Levenberg — Marquardt.
powell | Usa el método Powell.
quasi newton | Usa el método quasi-Newton.
simplex | Usa el método simplex.
Nota:

Puede anular la configuración de esta preferencia (para medidas de calidad que no sean regresión lineal) si cambia el método [consulte la sección Para cambiar el solucionador utilizado para crear un scorecard] en el cuadro de diálogo Solucionador de Scorecard.

Tema principal: Creador de scorecards


tolerancia

Sección Creador de scorecards

Objetivo Configurar una condición de detención para un solucionador de scorecard iterativo, en cuanto a tolerancia fraccionaria.

Valores válidos Un número real; por defecto, 0,0001

Si el valor de esta preferencia es [image], Creador de scorecardsdetiene un solucionador iterativo cuando los valores sucesivos [image] y [image] de la medida de calidad satisfacen lo siguiente:

Nota: Puede anular la configuración de esta preferencia si cambia la tolerancia fraccionaria [consulte la sección Para cambiar el solucionador utilizado para crear un scorecard] en el cuadro de diálogo Solucionador de Scorecard.

También consulte

iteraciones
Tema principal: Creador de scorecards


Formato de fecha

  • Formatos de fecha
  • escritura de fecha
  • índice de día por defecto para fechas incompletas
  • índice de mes por defecto para fechas incompletas
  • escritura total
  • futuro máximo para años de dos dígitos
  • leer
  • escritura de hora
  • año de quiebre con dos dígitos fijos
  • escritura en la preferencia de formato local
  • preferencia de
Tema principal: Preferencias de Portrait Miner


Formatos de fecha

Cuando trabaja con archivos planos y expresiones FDL, puede especificar la forma en la que Portrait Miner debe interpretar o exportar las fechas y las horas, usando un formato de fecha estándar [consulte la sección Formatos de fecha estándar] o un formato de fecha personalizado [consulte la sección Formatos de fechas personalizados].

También consulte

Para configurar el formato de visualización para valores numéricos y de fecha
Tema principal: Formato de fecha

Formatos de fecha estándar

Nombre | Formato de fecha
Americano | MM/DD/AAAA:hh:mm:ss, por ejemplo, 12/31/2000:13:36:59
Europeo | DD/MM/AAAA:hh:mm:ss, por ejemplo, 31/12/2000:13:36:59
AMD | AAAA/MM/DD:hh:mm:ss, por ejemplo, 2000/12/31:13:36:59
Nota:
  • Los tres formatos de fecha estándar también se pueden utilizar para fechas sin componente de hora y para horas puras ("fechas" con solo un componente de hora). Para fechas con solo horas o solo fechas, las partes de hora y fecha, respectivamente, son omitidas.
  • Los formatos Americano, Europeo, y AMD también incluyen datos en las formas MMDDAAAA, DDMMAAAA y AAAAMMDD respectivamente (solo para entradas).

Formatos de fechas personalizados

Puede especificar un formato de fecha personalizado con los códigos de caracteres especiales, todos comienzan con el signo de porcentaje %:
Código | Componente de fecha con formato
%% | El mismo signo de porcentaje: "%"
%? | Coincide con cualquier carácter
%* | Coincide con cualquier cantidad de caracteres; por ejemplo, para ignorar los caracteres finales, use %A/%m/%d%*
%a | El nombre del día en forma abreviada ("lu.", "ma.", ..., "do.")
%A | El nombre del día completo ("lunes", "martes", ..., "domingo")
%b | El nombre del mes en forma abreviada ("en.", "febr.", ..., "dic.")
%B | El nombre del mes completo ("enero", "febrero", ..., "diciembre")
%c | (Entrada) Equivalente a "%a %b %e %T %Y" (Salida) La fecha y hora en la representación estándar para la ubicación actual
%C | Equivalente a "%a %b %e %T %Z %Y"
%d | El día del mes, usando dos dígitos ("01", "02", ..., "31")
%D | Equivalente a "%m/%d/%y"
%e | El día del mes, en un solo dígito precedido por un espacio (" 1", " 2", ..., "31")
%h | Equivalente a "%b"
%H | La hora del día, usando el reloj de 24 horas ("00", "02", ..., "23")
%I | La hora del día, usando el reloj de 12 horas ("01", "02", ..., "12")
%j | El día del año, usando tres dígitos (fechas julianas) ("001", "002", ..., "366")
%m | El número del mes, usando dos dígitos ("01", "02", ..., "12")
%M | Los minutos de una hora, usando dos dígitos ("00", "01", ..., "59")
%p | "a.m." o "p.m." según corresponda
%r | Equivalente a "%I:%M:%S %p"
%R | Equivalente a "%H:%M"
%S | El segundo del minuto, usando dos dígitos ("00", "01", ..., "61")
%T | Equivalente a "%H:%M:%S"
%x | El formato de fecha de acuerdo con la preferencia ordenación x
%X | Equivalente a "%x"
%y | Los años de un siglo, usando dos dígitos ("00", "01", ..., "99")
%Y | El año, usando cuatro dígitos
%Z | El nombre de la zona horaria de la ubicación actual
Nota:
  • Para usar "%D" o "%y", debe especificar el año de quiebre o un año futuro máximo (pero no ambos).

    Si configura un quiebre igual a un año válido A, Portrait Miner interpretará los años de dos dígitos como años entre A - 99 y A. Por ejemplo, si configura las preferencias en 2077, Portrait Miner interpreta los años de dos dígitos 76, 77 y 78 como 2076, 2077 y 1978 respectivamente.

    Si configura un año máximo futuro igual a un valor positivo n y el año actual es A, Portrait Miner interpreta todos los años de dos dígitos como años entre A + n - 99 y A + n. Por ejemplo, si configura las preferencias en 50 y el año actual es 2002, Portrait Miner interpreta los años de dos dígitos 51, 52 y 53 como 2051, 2052 y 1953 respectivamente.

  • Si configura la preferencia escribir en el formato local específico, los códigos "%a", "%A", "%b", "%B", "%C", "%p", "%x", "%X", y "%Z" pueden generar resultados diferentes al mostrar las fechas (pero no al interpretarlas).
  • Así como /, cualquier otro carácter (salvo el separador de campo o el marcador nulo) puede utilizarse como separador en la fecha.
  • En los formatos de fecha que no tienen un componente de día o mes explícito, puede especificar uno por defecto utilizando el calificador de "día" o "mes".
  • Los códigos de caracteres especiales son los de la función de biblioteca C estándar strftime.

Ejemplo R–1: Cadenas de formato de fecha

Ejemplo de fecha | Cadena de formato de fecha
02/04/2003 27/10/1940 | Europeo
04/02/2003 10/27/1940 | Americano
2003/04/02 1940/10/27 | AMD
02-Apr-2003 27-Oct-1940 | %d-%b-%Y
02 Apr 2003 27 Oct 1940 | ((%d %b %Y))
2003-04-02 13:25 1940-10-27 08:23 | ((%Y-%m-%d %H:%M))
2003-04-02:13:25 1940-10-27:08:23 | %Y-%m-%d:%H:%M
2 Apr 2003 27 Oct 1940 | ((%e %b %Y))
April 2, 2003 | ((%B %e, %Y))
02/04/2003 13:25 27/10/1940 08:23 | ((%d/%m/%Y %H:%M))
2003-04-02 13:25:15000000 | ((%Y-%m-%d %H:%M:%S%*))
April 02, 2003 | ((%B %d, %Y))
2-Apr-2003 27-Oct-1940 | %e-%b-%Y
02/04/03 27/10/40 | (quiebre europeo=2010)
04/02/03 10/27/40 | (quiebre americano=2010)
03/04/02 40/10/27 | (quiebre AMD=2010)
02-Apr-03 27-Oct-40 | (%d-%b-%y pivot=2010)
April 02, 03 | ((%B %d, %y) pivot=2010)
2-Apr-03 27-Oct-03 | (%e-%b-%y pivot=2010)
April 2, 03 | ((%B %e, %y) pivot=2010)
01:25 PM 08:23 AM | ((%I:%M %p))
13:25 08:23 | %H:%M

También consulte

índice de día por defecto para fechas incompletas

índice de mes por defecto para fechas incompletas

futuro máximo para años de dos dígitos

año de quiebre con dos dígitos fijos


escritura de fecha

Sección Formato de fecha

Objetivo Configurar el formato que se va a utilizar para escrituras de fechas sin componente de hora en archivos planos o expresiones FDL.

Valores válidos

Valor | Descripción
Americano | Escrituras de fecha como MM/DD/AAAA.
Europeo (por defecto) | Escritura de fecha DD/MM/AAAA.
AMD | Escrituras de fecha AAAA/MM/DD.
Cadena de formato de fecha [consulte la sección Formatos de fechas personalizados] | Escritura de fecha en formato personalizado.
Nota:

Se recomienda configurar las preferencias escritura de fecha, escritura total y escritura de hora al mismo valor.

También consulte

leer
Tema principal: Formato de fecha


índice de día por defecto para fechas incompletas

Sección Formato de fecha

Objetivo Establecer el día del mes para las fechas, en archivos planos y expresiones FDL, que no tienen un componente explícito para el día.

Valores válidos Un entero entre 1 y 31 inclusive, por defecto 1

Nota:
  • Esta configuración se aplica cuando Portrait Miner convierte texto a fecha de acuerdo con un formato de fecha [consulte la sección Formatos de fechas personalizados] como "%Y%M."
  • Para un archivo plano o campo individual, puede anular la configuración utilizando la palabra clave día.

También consulte

índice de mes por defecto para fechas incompletas
Tema principal: Formato de fecha


índice de mes por defecto para fechas incompletas

Sección Formato de fecha

Objetivo Establecer el mes del año para las fechas, en archivos planos y expresiones FDL, que no tienen un componente explícito para el mes.

Valores válidos Un entero entre 1 y 12 inclusive, por defecto 1

Nota:
  • Esta configuración se aplica cuando Portrait Miner convierte texto a fecha de acuerdo con un formato de fecha [consulte la sección Formatos de fechas personalizados] como "%Y."
  • Para un archivo plano o campo individual, puede anular la configuración utilizando la palabra clave mes.

También consulte

índice de día por defecto para fechas incompletas
Tema principal: Formato de fecha


escritura total

Sección Formato de fecha

Objetivo Establecer el formato que se utilizará en archivos planos y expresiones FDL para dar formato a las fechas que incluyen un componente de tiempo.

Valores válidos

Valor | Descripción
Americano | Formato de fechas MM/DD/AAAA:hh:mm:ss.
Europeo (por defecto) | Formato de fechas DD/MM/AAAA:hh:mm:ss.
AMD | Formato de fechas AAAA/MM/DD:hh:mm:ss.
Cadena de formato de fecha [consulte la sección Formatos de fechas personalizados] | Dar formato personalizado a las fechas.
Nota:

Normalmente deberá establecer las preferencias escritura total, escritura de fecha y escritura de hora en el mismo valor.

También consulte

leer
Tema principal: Formato de fecha


futuro máximo para años de dos dígitos

Sección Formato de fecha

Objetivo Controlar la interpretación de los años de dos dígitos en archivos planos y expresiones FDL, utilizando un año de quiebre en relación con el año actual.

Valores válidos Un entero entre 0 y 99 inclusive, o (por defecto) -1

Nota:
  • Esta configuración se aplica a los códigos "%D" e "%y" de formato de fecha [consulte la sección Formatos de fechas personalizados].
  • Para un archivo plano o campo individual, puede anular la configuración utilizando la palabra clave futuro.

También consulte

año de quiebre con dos dígitos fijos
Tema principal: Formato de fecha


leer

Sección Formato de fecha

Objetivo Establecer el formato por defecto utilizado para interpretar fechas en archivos planos y expresiones FDL

Valores válidos

Valor | Descripción
Americano | Interpretar fechas como MM/DD/AAAA:hh:mm:ss.
Europeo (por defecto) | Interpretar fechas como DD/MM/AAAA:hh:mm:ss.
AMD | Interpretar fechas como AAAA/MM/DD:hh:mm:ss.
Cadena de formato de fecha [consulte la sección Formatos de fechas personalizados] | Interpretar las fechas en formato personalizado.
Nota:

Cuando Portrait Miner lee una fecha de un archivo plano, utiliza el formato dado por esta configuración de preferencias, a menos que usted incluya una especificación explícita de formato en el archivo descriptor de texto plano.

También consulte

escritura de fecha

escritura total

escritura de hora

Tema principal: Formato de fecha


escritura de hora

Sección Formato de fecha

Objetivo Establecer el formato que se utilizará en archivos planos y expresiones FDL para escribir la hora (es decir, fechas con tan solo componentes de horas, minutos y segundos).

Valores válidos

Valor | Descripción
Americano | Escribir las horas como hh:mm:ss.
Europeo (por defecto) | Escribir las horas como hh:mm:ss.
AMD | Escribir las horas como hh:mm:ss.
Cadena de formato de fecha [consulte la sección Formatos de fechas personalizados] | Escriba la hora en formato personalizado.
Nota:

Normalmente deberá establecer las preferencias escritura de hora, escritura de fecha y escritura total en el mismo valor.

También consulte

leer
Tema principal: Formato de fecha


año de quiebre con dos dígitos fijos

Sección Formato de fecha

Objetivo Controlar la interpretación de años de dos dígitos en archivos planos y expresiones FDL, con un año de quiebre fijo.

Valores válidos Un entero positivo (un año) o (por defecto) -1

Nota:
  • Esta configuración se aplica a los códigos "%D" e "%y" de formato de fecha [consulte la sección Formatos de fechas personalizados].
  • Para un archivo plano o campo individual, puede anular la configuración utilizando la palabra clave quiebre.

También consulte

futuro máximo para años de dos dígitos
Tema principal: Formato de fecha


escritura en la preferencia de formato local

Sección Formato de fecha

Objetivo Controlar el uso de formato de fecha local específico cuando se utilizan los códigos de formato de fecha [consulte la sección Formatos de fechas personalizados] "%a," "%A," "%b," "%B," "%C," "%h," "%p," "%x," "%X," y "%Z."

Valores válidos

Valor | Descripción
true | Utilizar formato local específico, incluidos nombres localizados de días y meses.
false (predeterminado) | Utilizar un formato de fecha estándar, con nombres de días y meses en inglés.
Nota:

Por defecto es falso porque Portrait Miner actualmente no puede interpretar fechas que involucren nombres de días y meses que no estén en inglés.

Tema principal: Formato de fecha


preferencia de

Sección Formato de fecha

Objetivo Establecer el formato que se utilizará para interpretar o mostrar las fechas cuando se utiliza el código de formato de fecha "%x" o "%X" [consulte la sección Formatos de fechas personalizados].

Valores válidos

Valor | Descripción
Americano | Tratar "%x" como mes/día/año.
Europeo (por defecto) | Tratar "%x" como día/mes/año.
AMD | Tratar "%x" como año/mes/día.
Tema principal: Formato de fecha


Navegación por archivos

  • HOME
  • mapear carga
  • inicio de qsexplorer
Tema principal: Preferencias de Portrait Miner


HOME

Sección Entorno

Objetivo Configurar una ubicación "home" que, a su vez, configure el valor predeterminado para diversas preferencias de navegación por archivos.

Valores válidos La ubicación de un directorio/una carpeta (en el servidor de Portrait Miner), que no se configure en forma predeterminada (de manera que toma el valor de la variable del entorno del sistema operativo del mismo nombre, si está configurado)

Tema principal: Navegación por archivos


mapear carga

Sección Directorios

Objetivo Configurar la ubicación inicial que muestra Portrait Miner cuando navega para abrir un mapa (con la extensión del nombre de archivo .mif).

Valores válidos La ubicación de un directorio/carpeta (en el servidor de Portrait Miner), por defecto ext/maps (en UNIX) o ext\maps (en Windows) en el directorio de instalación de Portrait Miner.

Tema principal: Navegación por archivos


inicio de qsexplorer

Sección Directorios

Objetivo Establecer la ubicación inicial que muestra Portrait Miner, y a la que el botón [image] de Portrait Miner y cada navegador de archivos de Portrait Miner lo dirigen.

Valores válidos La ubicación de un directorio/carpeta (en el servidor de Portrait Miner), por defecto la configuración de la preferencia HOME.

Tema principal: Navegación por archivos


Archivos planos

  • porcentaje de corte en bruto
  • tamaño de muestra del formato de datos
  • tamaño de muestra de los datos
  • líneas vacías
  • errores máximos de extracción
  • advertencias máximas de extracción
  • ignorar advertencias de extracción
  • tamaño máximo del archivo de datos guardado en megabytes
  • permitir errores de formato de datos
Tema principal: Preferencias de Portrait Miner


porcentaje de corte en bruto

Sección Base de datos del archivo plano

Objetivo Establecer la proporción mínima de registros de muestra necesaria para asignar un tipo de datos no genérico [consulte Tipos de datos] a un campo en un archivo plano.

Valores válidos Un número real entre 1 y 100, por defecto 99

Si los tipos de datos de campos en un archivo plano no están especificados, Portrait Miner lee registros de muestra para asignarlos. Para cada campo, si no hay un tipo numérico o fecha que se aplique a al menos el porcentaje determinado de registros de muestra, se asigna en su lugar un tipo de datos de cadena; para cada campo que incluye datos numéricos, si no se aplica un tipo entero a al menos el porcentaje determinado de registros de muestra, se asigna en su lugar un tipo de datos real.

Nota:

Para asegurarse de que la asignación de tipos de datos que se aplica a cada registro de un archivo plano, configure esta preferencia y el tamaño de muestra de datos a sus valores máximos.

Tema principal: Archivos planos


tamaño de muestra del formato de datos

Sección Base de datos del archivo plano

Objetivo Establecer el número de registros de muestra que Portrait Miner lee de un archivo plano para determinar el separador de campo, los marcadores de cadena y fecha y los nombres de campo durante la fase inicial del análisis de un archivo plano.
Nota: La preferencia de tamaño de muestra de formato de datos se utiliza únicamente en ausencia de un archivo de descripción del archivo plano (FDD).

Valores válidos Un entero entre 1 y 100.000 inclusive, por defecto 100

Si no se especifica el formato de datos de un archivo plano, Portrait Miner lee registros de muestra para determinarlo.

Tema principal: Archivos planos


tamaño de muestra de los datos

Sección Base de datos del archivo plano

Objetivo Establecer el número de registros de muestra que Portrait Miner lee de un archivo plano para determinar los tipos de datos finales [consulte Tipos de datos] de campos.
Nota: La preferencia de tamaño de muestra de datos se utiliza únicamente en ausencia de un archivo de descripción del archivo plano (FDD).

Valores válidos Un entero positivo, por defecto 1000

Nota:

Si importa datos directamente de una salida de programa (es decir, a través de una "canalización"), los registros de muestra son aquellos ubicados al comienzo del flujo de datos; de lo contrario, Portrait Miner toma registros de muestra distribuidos a través de todo el archivo plano.

También consulte

tamaño de muestra del formato de datos
Tema principal: Archivos planos


líneas vacías

Sección Base de datos del archivo plano

Objetivo Controlar cómo Portrait Miner trata una línea en blanco al leer un archivo plano.

Valores válidos

Valor | Descripción
ignorar con advertencia (por defecto) | Ignora la línea pero genera una advertencia.
ignorar silenciosamente | Ignora la línea sin generar una advertencia.
null | Crea un registro para la línea, que incluye el valor nulo [consulte El valor null] en cada campo.
Tema principal: Archivos planos


errores máximos de extracción

Sección Base de datos del archivo plano

Objetivo Establecer el número máximo de errores de formato de datos que Portrait Miner permite al leer un archivo plano.

Valores válidos Un entero positivo, por defecto 1.000.000

Si el número de errores excede este valor, Portrait Miner rechaza el archivo plano como ilegible y anula la importación.

Nota:

Si está utilizando el comando de creación de datos qsimportflat de Portrait Miner, puede sobrescribir esta configuración con la opción - maxerrors.

También consulte

advertencias máximas de extracción

permitir errores de formato de datos

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Tema principal: Archivos planos


advertencias máximas de extracción

Sección Base de datos del archivo plano

Objetivo Establecer el número máximo de advertencias de formato de datos que Portrait Miner permite al leer un archivo plano.

Valores válidos Un entero positivo, por defecto 1.000.000

Si el número de advertencias excede este valor, Portrait Miner rechaza el archivo plano como ilegible y anula la importación.

Nota:

Si está utilizando el comando de creación de datos qsimportflat de Portrait Miner, puede sobrescribir esta configuración con la opción - maxwarnings.

También consulte

errores máximos de extracción

ignorar advertencias de extracción

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Tema principal: Archivos planos


ignorar advertencias de extracción

Sección Base de datos del archivo plano

Objetivo Controlar si Portrait Miner informa mensajes de advertencia de formato de datos (y compara el número total de advertencias con la preferencia advertencias máximas de extracción) al leer un archivo plano.

Valores válidos

Valor | Descripción
true | No informa mensajes de advertencia.
false (predeterminado) | Informa mensajes de advertencia.
Nota:
  • Portrait Miner siempre informa mensajes de error, y el número total de mensajes de advertencia.
  • Si está utilizando el comando de creación de datos qsimportflat de Portrait Miner, puede sobrescribir esta configuración con la opción - nowarnings.

También consulte

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Tema principal: Archivos planos


tamaño máximo del archivo de datos guardado en megabytes

Sección Base de datos del archivo plano

Objetivo Configurar la cantidad máxima de datos (en megabytes) que Portrait Miner escribe en un solo archivo durante la exportación como texto con un archivo descriptor de texto plano (FDD).

Valores válidos Un número entero mayor que 1; por defecto, 2048.

Cuando la cantidad de datos escritos en un archivo de datos alcanza este límite, Portrait Miner crea un nuevo archivo de datos y agrega una referencia de archivo adicional en el archivo FDD.

Nota:
  • Portrait Miner ignora la configuración de esta preferencia al exportar como texto sin usar un archivo FDD.
  • Para asegurar que Portrait Miner únicamente escriba datos a un solo archivo, al usar un archivo FDD, cambie el valor a $MAXLARGEFILESIZEMB.
Tema principal: Archivos planos


permitir errores de formato de datos

Sección Base de datos del archivo plano

Objetivo Controlar el comportamiento de Portrait Miner cuando encuentra errores de formato de datos en archivos planos.

Valores válidos

Valor | Descripción
true (predeterminado) | Trata los errores de formato de datos como advertencias.
false | Trata los errores de formato de datos como errores.

También consulte

errores máximos de extracción

advertencias máximas de extracción

Tema principal: Archivos planos


Bases de datos

  • preservar los tipos numéricos al importar
  • representar enteros largos como cadenas
Tema principal: Preferencias de Portrait Miner


preservar los tipos numéricos al importar

Sección Base de datos

Objetivo Determinar el tipo de datos [consulte Tipos de datos] que Portrait Miner utiliza para un campo al importar valores numéricos con una precisión de más de 15 dígitos desde una base de datos.

Valores válidos

Valor | Descripción
true (predeterminado) | Utilice el tipo de datos real, de modo de preservar los 15 dígitos más importantes y descartar el resto.
false | Utilice una representación de cadena para preservar la precisión completa del original (al menos hasta el segundo dígito menos importante).
Tema principal: Bases de datos


representar enteros largos como cadenas

Sección Base de datos

Objetivo determinar el tipo de datos [consulte Tipos de datos] que Portrait Miner utiliza para representar un campo entero que incluye números demasiado largos para representarse como enteros de 32 bits (enteros menores que -2 147483647 o mayores que 2 147483646) al importar desde una base de datos o archivo plano.

Valores válidos

Valor | Descripción
true (predeterminado) | Usar el tipo de datos de cadena.
false | Usar el tipo de datos real.
Tema principal: Bases de datos


Auditorías y fotos

  • backgroundcolor
  • backgroundtexture
  • barcolor
  • barstyle
  • errorbars
  • globalbarscale
  • globalpointscale
  • graph3deffect
  • graphshadow
  • imageheight
  • zoompointscale
Tema principal: Preferencias de Portrait Miner


backgroundcolor

Sección Auditorías y fotos

Objetivo Controlar el color del fondo para imágenes en Fotos de Modelos y Perfil y Auditorías.

Valores válidos Una cadena de texto; por defecto, "blanco"

Puede especificar un nombre de color de acuerdo con SVG http://www.w3.org (como "firebrick") o un valor RGB hexadecimal (como "#2244FF").

También consulte

backgroundtexture

barcolor

barstyle

errorbars

globalbarscale

globalpointscale

graph3deffect

graphshadow

imageheight

zoompointscale

Tema principal: Auditorías y fotos


backgroundtexture

Sección Auditorías y fotos

Objetivo Controlar el uso de la textura de fondo para imágenes en Fotos de Modelos y Perfil y Auditorías (únicamente en formato SVG).

Valores válidos

Valor | Descripción
true | Usa una textura de fondo.
false (predeterminado) | No usa una textura de fondo.

También consulte

backgroundcolor

barcolor

barstyle

errorbars

globalbarscale

globalpointscale

graph3deffect

graphshadow

imageheight

zoompointscale

Tema principal: Auditorías y fotos


barcolor

Sección Auditorías y fotos

Objetivo Controlar el color de las barras en los gráficos de barras en Fotos de Modelos y Perfil y Auditorías.

Valores válidos Una cadena de texto; por defecto, "#9999FF" (lila)

Puede especificar un nombre de color de acuerdo con SVG http://www.w3.org (como "firebrick") o un valor RGB hexadecimal (como "#2244FF").

También consulte

backgroundcolor

backgroundtexture

barstyle

errorbars

globalbarscale

globalpointscale

graph3deffect

graphshadow

imageheight

zoompointscale

Tema principal: Auditorías y fotos


barstyle

Sección Auditorías y fotos

Objetivo Controlar el estilo de las barras en los gráficos de barras y los segmentos de árboles de decisión para Fotos de Modelo y Perfil y Auditorías.

Valores válidos

Valor | Descripción
sin formato (predeterminado) | Da un aspecto plano y angular a las barras o los segmentos.
curvado | Da un aspecto curvado a las barras o los segmentos.
en relieve | Da un aspecto en relieve a las barras o los segmentos.

También consulte

backgroundcolor

backgroundtexture

barcolor

errorbars

globalbarscale

globalpointscale

graph3deffect

graphshadow

imageheight

zoompointscale

Tema principal: Auditorías y fotos


errorbars

Sección Auditorías y fotos

Objetivo Controlar el uso de barras de error en los gráficos de barras en Fotos de Modelos y Perfil y Auditorías.

Valores válidos

Valor | Descripción
true (predeterminado) | Coloca barras de error en puntos de datos.
false | No coloca barras de error en puntos de datos.

También consulte

backgroundcolor

backgroundtexture

barcolor

barstyle

globalbarscale

globalpointscale

graph3deffect

graphshadow

imageheight

zoompointscale

Tema principal: Auditorías y fotos


globalbarscale

Sección Auditorías y fotos

Objetivo Controlar el ajuste relativo de los ejes horizontales en gráficos de barra en Fotos de Modelos y Perfil y Auditorías.

Valores válidos

Valor | Descripción
true | Hace que la escala de los ejes horizontales sea igual para todos los gráficos en cada Foto de Modelo y Perfil y Auditoría.
false (predeterminado) | No hace que la escala de los ejes horizontales sea igual para todos los gráficos en cada Foto de Modelo y Perfil y Auditoría.

También consulte

backgroundcolor

backgroundtexture

barcolor

barstyle

errorbars

globalpointscale

graph3deffect

graphshadow

imageheight

zoompointscale

Tema principal: Auditorías y fotos


globalpointscale

Sección Auditorías y fotos

Objetivo Controlar el ajuste relativo de los ejes verticales en gráficos de barra en Fotos de Modelos y Perfil y Auditorías.

Valores válidos

Valor | Descripción
true (predeterminado) | Hace que la escala de los ejes verticales sea igual para todos los gráficos en cada Foto de Modelo y Perfil y Auditoría.
false | No hace que la escala de los ejes verticales sea igual para todos los gráficos en cada Foto de Modelo y Perfil y Auditoría.

También consulte

backgroundcolor

backgroundtexture

barcolor

barstyle

errorbars

globalbarscale

graph3deffect

graphshadow

imageheight

zoompointscale

Tema principal: Auditorías y fotos


graph3deffect

Sección Auditorías y fotos

Objetivo Controlar el estilo de las barras en los gráficos de barras para Fotos de Modelos y Perfil y Auditorías.

Valores válidos

Valor | Descripción
true | Usa barras tridimensionales.
false (predeterminado) | Usa barras bidimensionales.

También consulte

backgroundcolor

backgroundtexture

barcolor

barstyle

errorbars

globalbarscale

globalpointscale

graphshadow

imageheight

zoompointscale

Tema principal: Auditorías y fotos


graphshadow

Sección Auditorías y fotos

Objetivo Controlar el estilo de las barras en los gráficos de barras y los segmentos de árboles de decisión en Fotos de Modelo y Perfil y Auditorías.

Valores válidos

Valor | Descripción
true | Crea un efecto de sombra.
false (predeterminado) | No crea un efecto de sombra.

También consulte

backgroundcolor

backgroundtexture

barcolor

barstyle

errorbars

globalbarscale

globalpointscale

graph3deffect

imageheight

zoompointscale

Tema principal: Auditorías y fotos


imageheight

Sección Auditorías y fotos

Objetivo Controlar la altura (en píxeles) de las imágenes creadas para Fotos de Modelos y Perfil y Auditorías. La relación de aspecto de las imágenes está fija.

Valores válidos Un número entero positivo; por defecto, 300

También consulte

backgroundcolor

backgroundtexture

barcolor

barstyle

errorbars

globalbarscale

globalpointscale

graph3deffect

graphshadow

zoompointscale

Tema principal: Auditorías y fotos


zoompointscale

Sección Auditorías y fotos

Objetivo Controlar el rango del eje vertical para gráficos de barras en Fotos de Modelos y Perfil y Auditorías.

Valores válidos

Valor | Descripción
true | Establece el rango del eje como el de los puntos de datos.
false (predeterminado) | Establece el rango del eje como el de los puntos de datos aumentado con cero.

También consulte

backgroundcolor

backgroundtexture

barcolor

barstyle

errorbars

globalbarscale

globalpointscale

graph3deffect

graphshadow

imageheight

Tema principal: Auditorías y fotos


Notificación por correo electrónico

  • emailaddress
  • emailserver
Tema principal: Preferencias de Portrait Miner


emailaddress

Sección Correo electrónico

Objetivo Configurar la dirección de correo electrónico a la que se enviarán mensajes de notificación.

Valores válidos Una cadena de texto que no está configurada por defecto (de modo que no se envía correo electrónico).

Se debe tratar de una dirección de correo electrónico válida o una lista de direcciones de correo electrónico válidas separadas por coma; por ejemplo, yo@miempresa.com.

Nota:

Para insertar una coma literal en una dirección de correo electrónico, utilice el texto ${COMMA}.

También consulte

emailserver

Tema principal: Notificación por correo electrónico


emailserver

Sección Correo electrónico

Objetivo Configurar el servidor de correo electrónico a través del cual se enviarán mensajes de notificación.

Valores válidos Una cadena de texto que no está configurada por defecto (de modo que no se envía correo electrónico).

Se debe tratar de la dirección de un servidor SMTP, por ejemplo, smtp.miempresa.com.

También consulte

emailaddress

Tema principal: Notificación por correo electrónico


Administración y calibración del sistema

  • bibliotecas de derivación
  • límite blando de la memoria del enfoque
  • paralelismo máximo
  • Paralelismo
Tema principal: Preferencias de Portrait Miner


bibliotecas de derivación

Sección Funciones

Objetivo Especificar las ubicaciones de bibliotecas de funciones FDL de terceros o definidas por el usuario (con la extensión del nombre de archivo .fdl).

Valores válidos Una lista de ubicaciones de archivos/directorios/carpetas separada por comas (en el servidor de Portrait Miner) no configuradas por defecto.

Cuando se inicia Decision Studio, abre bibliotecas de funciones que se enumeran explícitamente y también las incluidas en directorios/carpetas (y todas las subcarpetas) enumeradas, de modo que habilita las funciones definidas dentro de ellas para utilizarlas en el Visor de tabla.

Nota:

Para insertar una coma literal en un nombre de archivo/directorio/carpeta, utilice el texto ${COMMA}.

Tema principal: Administración y calibración del sistema


límite blando de la memoria del enfoque

No se recomienda cambiar esta configuración

Portrait Miner establece este límite de forma dinámica. Cualquier cambio en el límite deberá hacerse únicamente después de consultar al Servicio de Soporte de Portrait Miner.

Sección Calibrar el sistema

Objetivo Configurar un límite "blando" para el uso de la memoria (en megabytes).

Valores válidos Un número entero mayor o igual a 16, por defecto, un valor determinado al ejecutar a partir del total de la memoria física disponible y los límites de la memoria del sistema operativo de Portrait Miner. Si ejecuta la versión de 64 bits de Portrait Miner, la cantidad máxima de memoria disponible está limitada sólo por la memoria física del equipo. Si ejecuta la versión de 32 bits de Portrait Miner, la cantidad máxima de memoria disponible se limita a 2 GB.

Nota:

El límite también se aplica a Decision Studio y a determinados comandos de creación de datos (junto con las interfaces de usuario gráficas correspondientes). El límite se denomina "blando" porque se puede exceder, aunque esto puede alterar el rendimiento del sistema.

Si el límite se excede un 20% o más en Decision Studio, una ventana emergente alertará al usuario.

Si el límite se excede un 20% o más al ejecutar un comando de creación de datos, se escribirá una advertencia en el stderr (y también en el archivo de registro, si se está utilizando uno).

En Portrait Miner Desktop, el límite se administra dinámicamente y no debería requerir configuración.

También consulte

Paralelismo

Tema principal: Administración y calibración del sistema


paralelismo máximo

Sección Calibrar el sistema

Objetivo Especificar el número máximo de procesadores utilizados (en el servidor de Portrait Miner) en una sesión de usuario de Decision Studio o en un comando de creación de datos (y cualquier función de Portrait Miner que se implemente a través de dicho comandos).

Valores válidos Un número entero positivo; por defecto, el número de procesadores disponibles.

También consulte

Paralelismo

Tema principal: Administración y calibración del sistema


Paralelismo

Sección Calibrar el sistema

Objetivo Especificar el número de procesadores utilizados por defecto (en el servidor de Portrait Miner) en una sesión de usuario de Decision Studio o en un comando de creación de datos (y cualquier función de Portrait Miner que se implemente a través de dichos comandos). En algunas circunstancias, los usuarios pueden elegir aumentar (o disminuir) este número al ejecutar.

Valores válidos Un número entero positivo; por defecto, 1. El valor no puede exceder la configuración de la preferencia de paralelismo máximo.

Tema principal: Administración y calibración del sistema


Integración de sistemas y tiempo real

  • archivo de registro del administrador
  • período de actualización de caché
  • permitir el acceso del administrador
  • permitir el acceso a la evaluación
  • antes de lectura de ..., después de escritura de ...
  • umbral de advertencia de regla vencido
  • exportar el elemento del menú XML
  • ubicación de enlace para ejecución externa
  • accediendo al período de vaciado de búfer
  • accediendo a la utilización máxima de memoria de búfer
  • accediendo al tamaño de búfer
  • regla de almacenar y guardar
  • ubicación de estado del servidor
Tema principal: Preferencias de Portrait Miner


archivo de registro del administrador

Esta configuración es para expertos y, habitualmente, sólo debe ser cambiada por el administrador de Portrait Miner.

Sección Actionhouse RT

Objetivo El nombre de ruta de acceso al archivo de registro en tiempo real, que se utiliza para registrar todos los eventos de administración del servidor. Sólo se usa si permitir el acceso del administrador está activado.

Valores válidos La ubicación de un directorio/una carpeta (en el servidor de Portrait Miner) que no está configurada por defecto

Tema principal: Integración de sistemas y tiempo real


período de actualización de caché

Esta configuración es para expertos y, habitualmente, sólo debe ser cambiada por el administrador de Portrait Miner.

Sección Actionhouse RT

Objetivo El tiempo en segundos entre eventos de actualización de reglas automáticos de clientes en tiempo real. Un cliente pregunta al servidor periódicamente este período de actualización para permitir que se copien las redefiniciones o eliminaciones de reglas.

Valores válidos Un número entero; por defecto, 3600

Tema principal: Integración de sistemas y tiempo real


permitir el acceso del administrador

Sección Actionhouse RT

Objetivo Permitir o no el acceso del administrador en tiempo real.

Valores válidos

Valor | Descripción
true | Permite el acceso del administrador
false (predeterminado) | No permite el acceso del administrador

También consulte

archivo de registro del administrador
Tema principal: Integración de sistemas y tiempo real


permitir el acceso a la evaluación

Esta configuración es para expertos y, habitualmente, sólo debe ser cambiada por el administrador de Portrait Miner.

Sección Actionhouse RT

Objetivo Permitir o no el acceso a la evaluación de reglas en tiempo real.

Valores válidos

Valor | Descripción
true (predeterminado) | Permite el acceso a la evaluación
false | No permite el acceso a la evaluación

También consulte

Tema principal: Integración de sistemas y tiempo real


antes de lectura de ..., después de escritura de ...

Sección Enlaces de ejecución externa

Objetivo Especificar un comando que Portrait Miner siempre ejecute antes de leer o escribir archivos del tipo especificado.

Valores válidos Una cadena de texto que no está configurada por defecto

Portrait Miner ejecuta el comando especificado antes de leer o escribir un archivo del tipo indicado. El nombre de ruta completo del archivo se anexa al comando como argumento.

Nota:
Un comando en un enlace de ejecución se ejecuta en un entorno que hereda de Portrait Miner, excepto que:
  • Se aumente la ruta para que incluya utilidades de línea de comandos de Portrait Miner.
  • Puede anular el directorio/la carpeta de trabajo heredada con la preferencia ubicación de enlace para ejecución externa.

Siempre es más seguro especificar el nombre de ruta completo en el ejecutable o configurar la ubicación del enlace de ejecución externa. En particular, Windows busca ejecutables en el directorio actual antes de buscar la ruta, lo cual puede producir resultados inesperados.

Tipos de archivos con enlaces de ejecución

Nombre en la preferencia | Tipo de archivo | Lectura | Escritura
binning | Archivo de creación de rangos en Decision Studio (.bng) |  |
jerarquía de categorías | archivo .hrc |  |
cluster | archivo de modelo de cluster |  |
configuración | Archivo de preferencia (qs.ini) |  |
crosstab | No usar. |  |
datos | No usar. |  |
base de datos | Una tabla de base de datos (especificada como un parámetro de DRL para el comando; consulte la sección Secuencias para qstml para obtener información acerca de DRL) |  |
árbol de decisión | archivo .qsdt o .dt |  |
derivación | archivo de biblioteca de función FDL (.fdl) |  |
descriptor de texto plano | archivo .fdd |  |
datos planos | archivo de texto plano |  |
archivo plano | archivo plano (especificado como parámetro de nombre de archivo descriptor de texto plano (FDD) al comando, si está escribiendo un archivo plano y pidió que se cree un archivo FDD; de lo contrario, el parámetro contiene el nombre de archivo de datos planos en su lugar). Una operación de archivo plano puede involucrar diversos archivos individuales (un archivo descriptor de texto plano y un archivo de datos planos o más de uno). La diferencia entre este enlace y los dos anteriores es que el comando se ejecuta sólo una vez por operación (antes de leer el primer archivo o después de escribir el último); los enlaces de menor nivel se ejecutan una vez por archivo individual. |  |
focus | archivo .ftr (observe que cuando un enfoque se mueve o elimina en Portrait Miner o con qsremove o qsmove, el comando se ejecuta tanto para el enfoque antiguo, que ya no existe, como para el nuevo enfoque después de su creación) |  |
HTML | archivo de tabulación cruzada con formato HTML |  |
log | archivo .log |  |
map | archivo de mapa de Decision Studio (.mid o .mif) |  |
modelo | archivo de modelo TML (.tml) creado por Decision Studio |  |
qmml | archivo de modelo QMML (.qmml) creado por Decision Studio |  |
scorecard | archivo .qssc o .sc |  |
text | No usar. |  |
Tema principal: Integración de sistemas y tiempo real


umbral de advertencia de regla vencido

Esta configuración es para expertos y, habitualmente, sólo debe ser cambiada por el administrador de Portrait Miner.

Sección Actionhouse RT

Objetivo La cantidad máxima de reglas en el servidor de tiempo real que se pueden marcar como "vencidas", pero que los clientes todavía no anularon. Si se supera esta cantidad, se escribe una advertencia de recursos en el registro de eventos del sistema (y, si se permite, en el archivo de registro del administrador de tiempo real). Por lo general, esto indica un cliente mal configurado o cuyo sistema se cayó.

Valores válidos Un número entero; por defecto, 10

También consulte

archivo de registro del administrador
Tema principal: Integración de sistemas y tiempo real


exportar el elemento del menú XML

Sección Actionhouse RT

Objetivo Configurar el texto que aparece en la opción de menú Visor de Tabla para guardar modelos QMML.

Valores válidos Una cadena de texto; por defecto, "Exportar como QMML..."

Tema principal: Integración de sistemas y tiempo real


ubicación de enlace para ejecución externa

Esta configuración es para expertos y, habitualmente, sólo debe ser cambiada por el administrador de Portrait Miner.

Sección Directorios

Objetivo Especificar el directorio/la carpeta de trabajo para comandos que Portrait Miner ejecuta a través de enlaces de ejecución [consulte la sección antes de lectura de ..., después de escritura de ...].

Valores válidos La ubicación de un directorio/una carpeta (en el servidor de Portrait Miner) que no está configurada por defecto

Si la ubicación no se ha configurado, los comandos de enlace de ejecución heredan su directorio/carpeta de trabajo de Decision Studio.

Tema principal: Integración de sistemas y tiempo real


accediendo al período de vaciado de búfer

Esta configuración es para expertos y, habitualmente, sólo debe ser cambiada por el administrador de Portrait Miner.

Sección Actionhouse RT

Objetivo Consulte la sección Administración e integración en tiempo real.

Valores válidos Un número entero; por defecto, 5

Tema principal: Integración de sistemas y tiempo real


accediendo a la utilización máxima de memoria de búfer

Esta configuración es para expertos y, habitualmente, sólo debe ser cambiada por el administrador de Portrait Miner.

Sección Actionhouse RT

Objetivo Consulte la sección Administración e integración en tiempo real.

Valores válidos Un número entero; por defecto, 1024

Tema principal: Integración de sistemas y tiempo real


accediendo al tamaño de búfer

Esta configuración es para expertos y, habitualmente, sólo debe ser cambiada por el administrador de Portrait Miner.

Sección Actionhouse RT

Objetivo Consulte la sección Administración e integración en tiempo real.

Valores válidos Un número entero; por defecto, 10

Tema principal: Integración de sistemas y tiempo real


regla de almacenar y guardar

Esta configuración es para expertos y, habitualmente, sólo debe ser cambiada por el administrador de Portrait Miner.

Sección Directorios

Objetivo Configurar la ubicación predeterminada para guardar modelos QMML (y permitir esta función en Decision Studio).

Valores válidos La ubicación de un directorio/una carpeta (en el servidor de Portrait Miner) que no está configurada por defecto (de manera que la opción de menú definida por la preferencia exportar elemento del menú XML no aparezca en Decision Studio)

Tema principal: Integración de sistemas y tiempo real


ubicación de estado del servidor

Esta configuración es para expertos y, habitualmente, sólo debe ser cambiada por el administrador de Portrait Miner.

Sección Actionhouse RT

Objetivo El directorio en el que el servidor en tiempo real almacena su estado activo. Cuando el servidor se enciende, carga el estado de este directorio. El servidor mantiene una copia en el disco de su estado actual aquí a medida que se ejecuta.

Valores válidos La ubicación de un directorio/carpeta (en el servidor de Portrait Miner); de manera predeterminada shared/actionhouseRT (en UNIX) o shared\actionhouseRT (en Windows) en el directorio de instalación de Portrait Miner.

Tema principal: Integración de sistemas y tiempo real


Funciones de agregación

  • any
  • confintlower
  • confintupper
  • count
  • countnonnull/countnonnulls
  • countnull/countnulls
  • countunique
  • countuniquenonnull
  • expectedcount
  • expectedproportion
  • first
  • last
  • max (un argumento)
  • mean (un argumento)
  • median
  • min (un argumento)
  • mode
  • moderatio
  • percentage
  • percentagerate
  • proportion
  • segindex
  • significance
  • stdev
  • sum (un argumento)
  • variance


any

Objetivo Tomar arbitrariamente un valor no nulo de un campo (posiblemente por grupo o por segmento).

Sintaxis any(x)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | x | El campo del que se elige un valor

Resultado

Tipo | Descripción
como entrada | Un valor arbitrario no nulo del campo x (posiblemente por grupo o por segmento)
Nota:

No puede utilizar esta función en una derivación de Decision Studio, ni en el archivo de derivaciones de qsderive ni en la ventana Derivar campos equivalente, ni en el archivo de rastreo de qstrack, ni en un archivo de selecciones de qsselect.

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

first

last

Tema principal: Funciones de agregación


confintlower

Objetivo Calcular el límite inferior un intervalo de confianza de 95% para la media de un campo.

Sintaxis confintlower(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | El campo que debe considerarse

Resultado

Tipo | Descripción
real | El límite inferior de un intervalo dentro del cual se espera que la media de la población del segmento para el campo x entre dentro de un 95% de confianza
Nota:

No puede utilizar esta función en una derivación de Decision Studio, ni en el archivo de derivaciones de qsderive ni en la ventana Derivar campos equivalente, ni en el archivo de rastreo de qstrack, ni en un archivo de selecciones de qsselect.

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

confintupper

significance

Tema principal: Funciones de agregación


confintupper

Objetivo Calcular el límite superior un intervalo de confianza de 95% para la media de un campo.

Sintaxis confintupper(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | El campo que debe considerarse

Resultado

Tipo | Descripción
real | El límite superior de un intervalo dentro del cual se espera que la media de la población del segmento para el campo x entre dentro de un 95% de confianza
Nota:

No puede utilizar esta función en una derivación de Decision Studio, ni en el archivo de derivaciones de qsderive ni en la ventana Derivar campos equivalente, ni en el archivo de rastreo de qstrack, ni en un archivo de selecciones de qsselect.

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

confintlower

significance

Tema principal: Funciones de agregación


count

Objetivo Recuento del número de registros (posiblemente por grupo o segmento).

Sintaxis count()

Argumentos Ninguno

Resultado

Tipo | Descripción
entero | El número de registros (posiblemente por grupo o segmento).

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

countnonnull/countnonnulls

countnull/countnulls

countunique

countuniquenonnull

Tema principal: Funciones de agregación


countnonnull/countnonnulls

Objetivo Recuento del número de registros para los cuales un campo tiene valores no-nulos (posiblemente por grupo o segmento).

Sintaxis countnonnull(x)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | x | El campo que debe considerarse

Resultado

Tipo | Descripción
entero | El número de registros para los cuales el campo x tiene valores no nulos (posiblemente por grupo o segmento).
Nota:

En las tabulaciones cruzadas de Decision Studio [consulte Funciones de agregación para tabulaciones cruzadas] y en un contexto de medición [consulte Funciones de agregación para mediciones y derivaciones], esta función es countnonnull, mientras que en un contexto de derivación es countnonnulls.

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

count

countnull/countnulls

countunique

countuniquenonnull

Tema principal: Funciones de agregación


countnull/countnulls

Objetivo Recuento del número de registros para los cuales un campo contiene el valor nulo (posiblemente por grupo o segmento).

Sintaxis countnull(x)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | x | El campo que debe considerarse

Resultado

Tipo | Descripción
entero | El número de registros para los cuales el campo x es nulo (posiblemente por grupo o segmento).
Nota:

En las tabulaciones cruzadas de Decision Studio [consulte Funciones de agregación para tabulaciones cruzadas] y en un contexto de medición [consulte Funciones de agregación para mediciones y derivaciones], esta función es countnull, mientras que en un contexto de derivación es countnulls.

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

count

countnonnull/countnonnulls

countunique

countuniquenonnull

Tema principal: Funciones de agregación


countunique

Objetivo Recuento del número de valores únicos que ocurren en un campo y que incluyen potencialmente el valor nulo (posiblemente por grupo o segmento).

Sintaxis countunique(x)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | x | El campo que debe considerarse

Resultado

Tipo | Descripción
entero | El número de valores únicos, incluyendo nulo, que ocurren en x (posiblemente por grupo o segmento).
Nota:

No puede utilizar esta función en una derivación de Decision Studio, ni en el archivo de derivaciones de qsderive ni en la ventana Derivar campos equivalente, ni en el archivo de rastreo de qstrack, ni en un archivo de selecciones de qsselect.

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

count

countnonnull/countnonnulls

countnull/countnulls

countuniquenonnull

Tema principal: Funciones de agregación


countuniquenonnull

Objetivo Recuento del número de valores únicos no nulos que ocurren en un campo (posiblemente por grupo o segmento).

Sintaxis countuniquenonnull(x)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | x | El campo que debe considerarse

Resultado

Tipo | Descripción
entero | El número de valores únicos, excluyendo nulo, que ocurren en x (posiblemente por grupo o segmento).
Nota:

No puede utilizar esta función en una derivación de Decision Studio, ni en el archivo de derivaciones de qsderive ni en la ventana Derivar campos equivalente, ni en el archivo de rastreo de qstrack, ni en un archivo de selecciones de qsselect.

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

count

countnonnull/countnonnulls

countnull/countnulls

countunique

Tema principal: Funciones de agregación


expectedcount

Objetivo Calcular la población "esperada" de un segmento de tabla cruzada.

Sintaxis expectedcount()

Argumentos Ninguno

Resultado

Tipo | Descripción
real | El conteo de registros esperado en un segmento si los campos de la tabla cruzada fueran independientes el uno del otro.
Nota:

Puede utilizar esta función en las tablas cruzadas de Decision Studio [consulte Funciones de agregación para tabulaciones cruzadas] solo para visualizar datos.

También consulte

Funciones de agregación para tabulaciones cruzadas

expectedproportion

Tema principal: Funciones de agregación


expectedproportion

Objetivo Calcular la población "esperada" de un segmento de tabla cruzada, como proporción de la población total.

Sintaxis expectedproportion()

Argumentos Ninguno

Resultado

Tipo | Descripción
real | La proporción de la población esperada en un segmento si los campos de la tabla cruzada fueran independientes el uno del otro.
Nota:

Puede utilizar esta función en las tablas cruzadas de Decision Studio [consulte Funciones de agregación para tabulaciones cruzadas] solo para visualizar datos.

También consulte

Funciones de agregación para tabulaciones cruzadas

expectedcount

Tema principal: Funciones de agregación


first

Objetivo Elegir el primer valor no nulo en un campo (posiblemente por grupo o segmento).

Sintaxis first(x)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | x | El campo del que se elige un valor

Resultado

Tipo | Descripción
como entrada | El primer valor mínimo no nulo encontrado en el campo x (posiblemente por grupo o segmento)
Nota:

No puede utilizar esta función en una derivación de Decision Studio, ni en el archivo de derivaciones de qsderive ni en la ventana Derivar campos equivalente, ni en el archivo de rastreo de qstrack, ni en un archivo de selecciones de qsselect.

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

any

last

Tema principal: Funciones de agregación


last

Objetivo Elegir el último valor no nulo en un campo (posiblemente por grupo o segmento).

Sintaxis last(x)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | x | El campo del que se elige un valor

Resultado

Tipo | Descripción
como entrada | El último valor no nulo encontrado en el campo x (posiblemente por grupo o segmento)
Nota:

No puede utilizar esta función en una derivación de Decision Studio, ni en el archivo de derivaciones de qsderive ni en la ventana Derivar campos equivalente, ni en el archivo de rastreo de qstrack, ni en un archivo de selecciones de qsselect.

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

any

first

Tema principal: Funciones de agregación


max (un argumento)

Objetivo Calcular el valor máximo no nulo en un campo (posiblemente por grupo o segmento).

Sintaxis max(x)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | x | El campo cuyos valores deben compararse

Resultado

Tipo | Descripción
como entrada | El valor máximo no nulo en el campo x (posiblemente por grupo o segmento)
Nota:
  • No se debe confundir esta función aggregation con la función multi-argument [consulte max (dos o más argumentos), maxnonnull] del mismo nombre.
  • En un contexto de derivación, esta función no acepta como argumento un campo con valor de cadena o de fecha.

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

min (un argumento)

Tema principal: Funciones de agregación


mean (un argumento)

Objetivo Calcular el promedio (media común) de los valores no nulos de un campo (posiblemente por grupo o segmento).

Sintaxis mean(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | El campo cuya media debe calcularse

Resultado

Tipo | Descripción
real | La media de los valores no nulos en un campo x (posiblemente por grupo o segmento)
Nota:

No se debe confundir esta función aggregation con la función multi-argument [consulte mean (dos o más argumentos), meannonnull] del mismo nombre.

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

median

mode

Tema principal: Funciones de agregación


median

Objetivo Calcular la mediana (valor mediano) de los valores no nulos de un campo (posiblemente por grupo o segmento).

Sintaxis median(x)

Argumentos

Tipo | Nombre | Descripción
entero, real o cadena | x | El campo cuya mediana debe calcularse

Resultado

Tipo | Descripción
como entrada | La mediana de los valores no nulos en un campo x (posiblemente por grupo o segmento)
Nota:

No puede utilizar esta función en una derivación de Decision Studio, ni en el archivo de derivaciones de qsderive ni en la ventana Derivar campos equivalente, ni en el archivo de rastreo de qstrack, ni en un archivo de selecciones de qsselect.

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

mean (un argumento)

mode

Tema principal: Funciones de agregación


min (un argumento)

Objetivo Calcular el valor mínimo no nulo en un campo (posiblemente por grupo o segmento).

Sintaxis min(x)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | x | El campo cuyos valores deben compararse

Resultado

Tipo | Descripción
como entrada | El valor mínimo no nulo en el campo x (posiblemente por grupo o segmento)
Nota:
  • No se debe confundir esta función aggregation con la función multi-argument [consulte min (dos o más argumentos), minnonnull] del mismo nombre.
  • En un contexto de derivación, esta función no acepta como argumento un campo con valor de cadena o de fecha.

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

max (un argumento)

Tema principal: Funciones de agregación


mode

Objetivo Calcular la moda (el valor más común) de los valores no nulos de un campo (posiblemente por grupo o segmento).

Sintaxis mode(x)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | x | El campo cuya moda debe calcularse

Resultado

Tipo | Descripción
como entrada | El modo de los valores no nulos en un campo x (posiblemente por grupo o segmento)
Nota:
  • En el caso de un empate en el valor más común, la función indica el valor que empata menos, la fecha más temprana que empata o la primera cadena en orden alfabético que empata .
  • No puede utilizar esta función en una derivación de Decision Studio, ni en el archivo de derivaciones de qsderive ni en la ventana Derivar campos equivalente, ni en el archivo de rastreo de qstrack, ni en un archivo de selecciones de qsselect.

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

mean (un argumento)

median

moderatio

Tema principal: Funciones de agregación


moderatio

Objetivo Calcular la proporción de registros no nulos que contienen el valor no nulo más común de un campo (posiblemente por grupo o segmento).

Sintaxis moderatio(x)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | x | El campo cuyo coeficiente de moda debe calcularse

Resultado

Tipo | Descripción
real | El coeficiente de moda del campo x (posiblemente por grupo o segmento)
Nota:

No puede utilizar esta función en una derivación de Decision Studio, ni en el archivo de derivaciones de qsderive ni en la ventana Derivar campos equivalente, ni en el archivo de rastreo de qstrack, ni en un archivo de selecciones de qsselect.

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

mode

Tema principal: Funciones de agregación


percentage

Sintaxis percentage()

Objetivo Calcular el número de registros en un segmento de tabulación cruzada, como porcentaje del total.

Argumentos Ninguno

Resultado

Tipo | Descripción
real | El porcentaje de registros (posiblemente por grupo o segmento).
Nota:

Sólo puede utilizar esta función en una derivación de Decision Studio, en el archivo de derivaciones de qsderive o en la ventana Derivar campos equivalente en el archivo de rastreo qstrack o en un archivo de selecciones de qsselect.

También consulte

Funciones de agregación para mediciones y derivaciones

Tema principal: Funciones de agregación


percentagerate

Objetivo Para un campo binario (1/0), calcular la proporción de registros no nulos que contienen el valor 1, como porcentaje.

Sintaxis percentagerate(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | El campo binario que debe considerarse

Resultado

Tipo | Descripción
real | El porcentaje de registros en un campo binario que tienen el valor 1 (posiblemente por grupo o segmento)
Nota:

Esta función no puede usarse en archivo de agregación [consulte Uso de funciones de agregación y las cláusulas where y default] ni en un archivo de estadísticas [consulte Evaluación del enfoque de estadísticas: la instrucción de calcular] para qsmeasure ni en la ventana equivalente de Agregar registros ni en un archivo de estadísticas para qstrack.

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

Tema principal: Funciones de agregación


proportion

Objetivo Calcular la cantidad de registros por cliente o por segmento, como proporción del número total de los registros.

Sintaxis proportion()

Argumentos Ninguno

Resultado

Tipo | Descripción
real | La cantidad de registros de un cliente o en un segmento de tabla cruzada, relativo al número total de registros
Nota:

Puede utilizar esta función en las tablas cruzadas de Decision Studio [consulte Funciones de agregación para tabulaciones cruzadas] solo para visualizar datos.

También consulte

Funciones de agregación para tabulaciones cruzadas
Tema principal: Funciones de agregación


segindex

Objetivo Generar un número de índice que represente un segmento.

Sintaxis segindex()

Argumentos Ninguno

Resultado

Tipo | Descripción
entero | Un número positivo que identifica únicamente a un segmento dentro de una tabulación cruzada.
Nota:
  • Si se ocultan segmentos nulos, sin clasificar o vacíos en una vista de tabulación cruzada, aún así reciben un índice de segmento, por lo que podrían aparecer huecos en la secuencia de índices visibles.
  • Esta función no puede usarse en archivo de agregación [consulte Uso de funciones de agregación y las cláusulas where y default] ni en un archivo de estadísticas [consulte Evaluación del enfoque de estadísticas: la instrucción de calcular] para qsmeasure ni en la ventana equivalente de Agregar registros ni en un archivo de estadísticas para qstrack.

Ejemplo R–2: Marcación de deciles aproximados

Se pueden crear rangos en un campo "myfield" en diez rangos de igual población y luego derivar un campo "decile":

segindex() by myfield

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

bin

Tema principal: Funciones de agregación


significance

Objetivo Calcular la significancia estadística de cualquier discrepancia entre el valor medio de un campo para un segmento de una tabulación cruzada y el valor medio del mismo campo para toda la población.

Sintaxis significance(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | El campo que debe considerarse

Resultado

Tipo | Descripción
real | Un valor entre -1 and 1, cuyo signo indica la dirección en la cual la media del segmento de x se desvía de la media de la población de x y cuyo valor absoluto indica la significación estadística de tal desviación, teniendo en cuenta el tamaño del segmento.
Nota:

Esta función no puede usarse en archivo de agregación [consulte Uso de funciones de agregación y las cláusulas where y default] ni en un archivo de estadísticas [consulte Evaluación del enfoque de estadísticas: la instrucción de calcular] para qsmeasure ni en la ventana equivalente de Agregar registros ni en un archivo de estadísticas para qstrack.

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

confintlower

confintupper

Tema principal: Funciones de agregación


stdev

Objetivo Calcular la desviación estándar de los valores no nulos de un campo (posiblemente por grupo o segmento).

Sintaxis stdev(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | El campo cuya desviación estándar debe computarse

Resultado

Tipo | Descripción
real | La desviación estándar de los valores no nulos en un campo x (posiblemente por grupo o segmento)

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

Tema principal: Funciones de agregación


sum (un argumento)

Objetivo Calcular la suma de los valores no nulos en un campo (posiblemente por grupo o segmento).

Sintaxis sum(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | El campo cuyos valores se sumarán

Resultado

Tipo | Descripción
como entrada | La suma de los valores no nulos en el campo x (posiblemente por grupo o segmento)
Nota:
  • No se debe confundir esta función aggregation con la función multi-argument [consulte sum (dos o más argumentos), sumnonnull] del mismo nombre.
  • Tenga en cuenta que cuando la función sum de agregación se aplica a un conjunto vacío de registros (por ejemplo, como consecuencia del filtrado de registros), el resultado es null. Normalmente debería sobrescribir este comportamiento mediante la configuración del valor predeterminado en 0.

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

Tema principal: Funciones de agregación


variance

Objetivo Calcular la varianza estadística de los valores no nulos de un campo (posiblemente por grupo o segmento).

Sintaxis variance(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | El campo cuya varianza debe computarse

Resultado

Tipo | Descripción
real | La varianza de los valores no nulos en el campo x (posiblemente por grupo o segmento)

También consulte

Funciones de agregación para tabulaciones cruzadas

Funciones de agregación para mediciones y derivaciones

Tema principal: Funciones de agregación


Referencia de Transaction Measurement Language (TML)

  • Acerca de Transaction Measurement Language
  • Sintaxis de TML
  • Definición de campos: la instrucción create
  • Uso de funciones de agregación y las cláusulas where y default
  • División de agregaciones: la cláusula by
  • Evaluación del enfoque de estadísticas: la instrucción de calcular
  • Funciones de agregación para mediciones y derivaciones
  • Palabras reservadas en TML


Acerca de Transaction Measurement Language

Transaction Measurement Language (TML) es una colección de recubridores sintácticos livianos alrededor de expresiones FDL, utilizados para especificar derivaciones de campos y agregaciones en conjunto con los asistentes Derivar campos [consulte Para derivar campos en un enfoque mediante el uso de Portrait Miner] y Agregar registros [consulte Para convertir un enfoque orientado en la transacción a un enfoque orientado en el cliente] y los comandos de creación de datos qsderive, qsmeasure, qstrack y qsselect de Portrait Miner.

También consulte

Acerca del lenguaje de derivación de campos (FDL)

Sintaxis de TML

Uso de los comandos de creación de datos de Portrait Miner para importación, procesamiento y exportación de datos

Tema principal: Referencia de Transaction Measurement Language (TML)


Sintaxis de TML

Un archivo de derivaciones, rastreos, selecciones o agregaciones incluye una o más instrucciones create de TML, mientras que un archivo de estadísticas incluye una o más instrucciones calculate de TML.
  • TML es un lenguaje que distingue mayúsculas de minúsculas:
    • Las palabras clave de TML (create, by, string etc.) se escriben en minúsculas, a excepción de STATISTIC.
    • Los nombres de todas las funciones de agregación [consulte Funciones de agregación para mediciones y derivaciones] se escriben en minúsculas.
    • Los nombres Average, average, y AVERAGE hacen referencia a distintos campos o estadísticas.
  • Los nombres de campos y estadísticas deben comenzar con una letra ("A" — "Z" o "a" — "z"), incluir solamente letras, dígitos y guión bajo ("_") y no tener más de 128 caracteres; como opción pueden estar entre comillas simples, por ejemplo, 'CustomerID'. Debe encerrar el nombre de un campo o estadística en comillas simples si coincide con una palabra reservada de TML o FDL, o si es diferente de una sólo en fuente.
  • La sintaxis de TML se describe utilizando diagramas de ferrocarriles similares al siguiente:

    Siempre y cuando siga las flechas y no marche hacia atrás, cualquier ruta a través del diagrama del ferrocarril lleva a TML de sintaxis válida (aunque no necesariamente significativo):
    • Las palabras en cuadros con forma de óvalo/circulares (como create) son palabras clave de TML; debe escribirlas exactamente como aparecen.
    • También debe escribir la puntuación en los cuadros con forma de óvalo (como ":" y ":=") exactamente como aparece (no puede agregar espacios entre ":" y "=" en ":=").
    • No olvide el punto y coma que finaliza cada instrucción de TML.
    • Los términos en cuadros rectangulares (como expression) hacen referencia a otros diagramas de ferrocarriles o a formas descritas en otro lugar en palabras; no debe escribirlos literalmente.
  • TML es un lenguaje de formato libre: puede separar líneas o insertar espacios adicionales entre elementos sintácticos (en cuadros con forma de óvalo/circulares en diagramas de ferrocarriles) sin afectar la interpretación de un archivo de derivaciones, rastreos, selecciones, agregaciones o estadísticas.
  • Además de introducir espacios entre elementos sintácticos, puede incluir comentarios, que comienzan con una barra doble ("//") y continúan hasta el final de la misma línea.
  • Siempre que la sintaxis de TML requiera una expresión, puede utilizar cualquier expresión FDL [consulte Expressions (Expresiones)], excepto que una expresión que implique una palabra reservada de TML, un punto y coma o llaves {...} debe encerrarse entre paréntesis (...).

También consulte

Acerca de Transaction Measurement Language

Evaluación del enfoque de estadísticas: la instrucción de calcular

Definición de campos: la instrucción create

Palabras reservadas en FDL

Palabras reservadas en TML

Tema principal: Referencia de Transaction Measurement Language (TML)


Definición de campos: la instrucción create

La instrucción create define un campo por derivación o agregación, según el contexto en el que aparece.

Derivaciones El archivo de derivaciones para qsderive o la ventana Derivar campos equivalente, el archivo de rastreos para qstrack y el archivo de selecciones para qsselect deben incluir instrucciones create de la siguiente forma:

El archivo de agregaciones para qsmeasure o la ventana Agregar registros equivalente puede como opción incluir instrucciones create de la siguiente forma:

En ambos casos, la instrucción create define un campo llamado nombre en relación con una expresión FDL [consulte la sección Expressions (Expresiones)]. El tipo de datos del campo es el tipo de datos de la expresión, a menos que los sobrescriba especificando un tipo compatible [consulte la sección Tipos de datos].
  • Para cada instrucción create sucesiva en el archivo de derivaciones, qsderive o la ventana Derivar campos deriva un campo en el enfoque de salida utilizando la expresión dada, que puede hacer referencia a campos en el enfoque de origen y a campos derivados más temprano en el archivo de derivaciones.
  • Para cada instrucción create sucesiva en el archivo de rastreos, qstrack deriva un campo utilizando la expresión dada, que puede hacer referencia a campos en el enfoque de origen y a campos derivados más temprano en el archivo de rastreos, así como también a estadísticas de enfoque definidas en cualquier archivo de estadísticas. La expresión comúnmente implica variables de estado [consulte la sección Variables].
  • Dado un archivo de selecciones, qsselect deriva un campo correspondiente de forma predeterminada con la primera instrucción create e ignora cualquier otra instrucción en el archivo. La expresión de definición debe ser de tipo booleano (o compatible).
  • Para cada instrucción create sucesiva de esta forma en el archivo de agregaciones, qsmeasure o la ventana Agregar registros deriva un campo en el enfoque de salida utilizando la expresión dada, que puede hacer referencia a campos derivados anteriormente en el archivo de agregaciones y a estadísticas de enfoque definidas en cualquier archivo de estadísticas.
  • Una instrucción temporary tiene el mismo efecto que la instrucción create, excepto que el campo no aparece en el enfoque de salida. No obstante, aún puede hacer referencia al campo temporary en las expresiones siguientes del archivo de agregaciones.

Agregaciones El archivo de agregaciones para qsmeasure o la ventana Agregar registros equivalente puede incluir instrucciones create de la siguiente forma:

Para cada instrucción create de esta forma en el archivo de agregaciones, qsmeasure o la ventana Agregar registros deriva eficazmente un campo virtual correspondiente a la expresión siguiendo la función de agregación. Esta expresión puede hacer referencia a campos en el enfoque de origen.

Después de derivar el campo virtual, qsmeasure o la ventana Agregar registros aplica la función de agregación [consulte la sección Uso de funciones de agregación y las cláusulas where y default].

El tipo de datos por defecto de los campos resultantes depende de la función de agregación y los valores, operadores y funciones implicados en la expresión a la que se aplica, pero puede sobrescribirlo especificando un tipo compatible.

Una instrucción temporary tiene el mismo efecto que la instrucción create, excepto que el campo no aparece en el enfoque de salida. No obstante, aún puede hacer referencia al campo temporary en las expresiones siguientes del archivo de agregaciones.

Nota:
  • En qsderive o archivos de derivaciones Derivar campos, archivos de selecciones qsselect y archivos de rastreos qsrack, la expresión puede implicar estadísticas de campos, variables globales y funciones definidas en función de estos. Estas funciones FDL no están disponibles en un archivo de agregaciones qsmeasure o Agregar registros.
  • Debe colocar paréntesis adicionales en la expresión si incluye un punto y coma, corchetes o una palabra reservada TML [consulte la sección Palabras reservadas en TML].
  • Cada instrucción create debe comenzar en una nueva línea.

Ejemplos Dado el archivo de derivaciones, derivations-customer.tml, que incluye lo siguiente:

// Length of standing of customer in months
create CustMonths := countwholemonths(StartDate, today());
// A key field of extended length
create CustomerID_24 : string(24) := CustomerID;
Aplique estas derivaciones al enfoque RetailCustApril.ftr para crear un nuevo enfoque RetailCustAprilDeriv.ftr: qsderive -derivations derivations-customer.tml\cmdlinecont -input RetailCustApril.ftr -output RetailCustAprilDeriv.ftr Dado el archivo de selecciones, selections-customer.tml, que incluye lo siguiente:
// Select male customers aged between 18 and 65 inclusive.
create Selection := Gender = 1 and Age >= 18 and Age <= 65;
Aplique esta selección al enfoque RetailCustApril.ftr para crear un nuevo enfoque RetailCustAprilSelection.ftr:
qsselect -selections selections-customer.tml
         -input RetailCustApril.ftr%
         -output RetailCustAprilSelection.ftr
Dado el archivo de agregaciones, aggregations-mostRecent.tml, que incluye lo siguiente:
temporary LastPurchase := max(PurchaseDate);
create AvgTransVal := mean(Amount - 0.01 * PointsRedeemed);
create NumTrans := count();
create MonthsSinceLastPurchase :=
       countwholemonths(LastPurchase, today());

Aplique estas agregaciones al enfoque RetailTransApril.ftr para crear un enfoque orientado al cliente RetailAggRecentApril:

qsmeasure -aggregations aggregations-mostRecent.tml
          -input RetailTransAprilSorted.ftr -output RetailAggRecentApril%
          -keys CustomerID

También consulte

Funciones de agregación para mediciones y derivaciones

División de agregaciones: la cláusula by

Para convertir un enfoque orientado en la transacción a un enfoque orientado en el cliente

Tema principal: Referencia de Transaction Measurement Language (TML)


Uso de funciones de agregación y las cláusulas where y default

Puede agregar registros utilizando qsmeasure o la ventana Agregar registros equivalente.

Cuando utiliza una instrucción create en un archivo de agregaciones [consulte la sección Definición de campos: la instrucción create], qsmeasure o la ventana Agregar registros equivalente deriva eficazmente un campo virtual que corresponde a la expresión entre paréntesis que sigue a la función de agregación.

Conceptualmente, qsmeasure o la ventana Agregar registros divide los registros en el enfoque de origen (aumentado por el campo virtual) en grupos de registros con el mismo valor de campo clave. Para cada grupo de registros (que corresponden a un único valor de campo clave), qsmeasure o la ventana Agregar registros aplica la función de agregación a los valores del campo virtual dentro de estos registros para producir un único valor de resultado.

Los valores de resultado de todos los grupos en conjunto constituyen un nuevo campo, con el nombre determinado en la instrucción create, a menos que la instrucción create incluya una cláusula by [consulte la sección División de agregaciones: la cláusula by].

Dentro de cada grupo de registros con un valor de campo clave común, determinadas funciones de agregación ignoran los registros para los que el campo virtual incluye null [consulte la sección El valor null].

Si la instrucción create incluye una cláusula where, la función de agregación ignora registros para los que la expresión asociada se evalúa en 0 ("false"). Esta expresión puede hacer referencia a campos en el enfoque de origen.

Dado que las funciones de agregación pueden ignorar algunos de los registros en un grupo con un valor de campo clave, es posible que se omitan todos los registros en el grupo. Muchas funciones de agregación regresan el valor null en este caso. Al incluir una cláusula default, puede especificar una expresión constante que se evaluará en lugar de la agregación en el caso de que devuelva el valor null.

Nota:

Cuando utiliza la función sum de agregación [consulte la sección sum (un argumento)], comúnmente debe especificar una suma predeterminada de 0. Si no utiliza una cláusula default, la suma de una selección vacía de registros es null, lo probablemente no será lo que desea.

Ejemplos Dado el archivo de agregaciones, aggregations-purchaseSummary.tml, que incluye lo siguiente:

create firstPurchaseDate := first(PurchaseDate);
create commonPaymentMethod := mode(PaymentMethod);
create Spend := sum(Amount) default 0;
create SpendInStore800 := sum(Amount)
       where Store = "0800" default 0;
create proportionSpendInStore800 := SpendInStore800 / Spend;
create NumTransCRRedeemed := count()
       where PaymentMethod = "CR" and not isnull(PointsRedeemed);

Aplique estas agregaciones al enfoque RetailTransApril.ftr para crear un enfoque orientado al cliente RetailAggSummaryApril:

qsmeasure -aggregations aggregations-purchaseSummary.tml
          -input RetailTransAprilSorted.ftr -output RetailAggSummaryApril
          -keys CustomerID

También consulte

Funciones de agregación para mediciones y derivaciones

Expressions (Expresiones)

Tema principal: Referencia de Transaction Measurement Language (TML)


División de agregaciones: la cláusula by

El archivo de agregaciones para qsmeasure o la ventana Agregar registros equivalente incluye una secuencia de instrucciones create [consulte Definición de campos: la instrucción create]. Como parte de una instrucción create, también puede incluir una cláusula by para desglosar su agregación de acuerdo con la aplicación de una función de división o la función bin a una expresión derivada de otros campos.
Para cada posible entero i devuelto por la función de división o función bin, qsmeasure o la ventana Agregar registros crea un campo separado, que incluye valores agregados de solo estos registros para los que se evalúa la aplicación de la función en i. El nombre de cada uno de estos campos está formado por el nombre en la instrucción create junto con un sufijo que depende de la función utilizada para la división de la agregación.
  • Están disponibles las siguientes funciones de división incorporadas (con sufijos de nombres de campo determinados que corresponden a sucesivos valores de la función):
    Función | Sufijos de nombres de campos
    day | "_1," "_2," "_3," ..., "_31"
    dayofweek | "Sun," "Mon," "Tue," ..., "Sat"
    hour | "0000," "0100," "0200" ..., "2300"
    isnull | "NonNull," "Null"
    match | "MisMatch," "Match"
    member | "NotMember," "Member"
    minute | "0," "1," "2," ..., "59"
    month | "Jan," "Feb," "Mar," ..., "Dec"
    second | "0," "1," "2," ..., "59"
    sgn | "Negative," "Zero," "Positive"
    strmember | "NotMember," "Member"
    weekofyear | "_1," "_2," "_3," ..., "_53"
  • Puede utilizar la función bin para aplicar un rango FDL a una expresión. Si se utiliza como una función de división, la función bin da lugar a sufijos de nombres ce campos "_1," "_2," ..., "_n," "_null," y "_other" (donde n depende del número de rangos en la creación de rangos).
  • También puede definir su propia función de división [consulte la sección Funciones definidas por el usuario]. El atributo element_names define los sufijos de nombres de campos correspondientes a los valores de devolución de la función.

Ejemplos Dado el archivo de agregaciones, aggregations-builtinSplit.tml, que incluye lo siguiente:

create numberPurchases := count();
create numberPurchasesOn_ := count() by dayofweek(PurchaseDate);
create proportionPurchases_Mon :=
       numberPurchasesOn_Mon / numberPurchases;
create purchaseAmountIn_ :=
       sum(Amount) by month(PurchaseDate) default 0;

Aplique estas agregaciones al enfoque RetailTransApril.ftr para crear un enfoque orientado al cliente RetailDateSplitsApril.ftr que incluya campos CustomerID, numberPurchases, numberPurchasesOn_Sun, numberPurchasesOn_Mon, ..., numberPurchasesOn_Sat, proportionPurchases_Mon, y purchaseAmountIn_Jan, purchaseAmountIn_Feb, ..., purchaseAmountIn_Dec:

qsmeasure -aggregations aggregations-builtinSplit.tml -keys CustomerID -input RetailTransApril.ftr -output RetailDateSplitsApril.ftr

Dado el archivo de agregaciones, aggregations-binSplit.tml, que incluye lo siguiente:

create numberPurchasesAmountBand :=
       count() by bin(EqualRange(20,100,4),Amount);
create numberPurchasesDateBand := count() by
       bin(PrePost(todate(19990401), todate(19990501),
       todate(19990601)), PurchaseDate);
create ratioPrePost :=
       numberPurchasesDateBand_3 / numberPurchasesDateBand_2;

Aplique estas agregaciones al enfoque RetailTransApril.ftr para crear un enfoque orientado al cliente, RetailRangeSplitsApril.ftr, que incluye campos CustomerID, numberPurchasesAmountBand_1, numberPurchasesAmountBand_2, ..., numberPurchasesAmountBand_6, numberPurchasesAmountBand_null, numberPurchasesAmountBand_other (correspondiente a dos rangos finales, cuatro rangos internos y el rango no clasificado y null), numberPurchasesDateBand_1, numberPurchasesDateBand_2, ..., numberPurchasesDateBand_4, numberPurchasesDateBand_null, numberPurchasesDateBand_other y ratioPrePost:

qsmeasure -aggregations aggregations-binSplit.tml -keys CustomerID -input RetailTransApril.ftr -output RetailRangeSplitsApril.ftr

Dado el archivo de funciones FDL, fdl-functions-storeGroups.fdl, que incluye lo siguiente:

function StoreGroupFunction( Store )
[
   element_names = "North, South, East, West"
]
{
case
    Store = "0000" or Store = "0800" : 1;
    Store = "0300" or Store = "0600" or Store = "0700" : 2;
    Store = "0100" or Store = "0400" : 3;
    default : 4;
}

Dado el archivo de agregaciones, aggregations-userDefinedSplit.tml, que incluye lo siguiente:

create totalPurchases := sum(Amount);
create totalPurchasesByStore_ :=
       sum(Amount) by StoreGroupFunction( Store );
create proportionPurchases_North :=
       totalPurchasesByStore_North / totalPurchases;

Aplique estas agregaciones al enfoque RetailTransApril.ftr para crear un enfoque orientado al cliente, RetailGroupSplitsApril.ftr, que incluye los campos CustomerID, totalPurchases, totalPurchasesByStore_North, totalPurchasesByStore_South, totalPurchasesByStore_East, totalPurchasesByStore_West y proportionPurchases_North:

qsmeasure -aggregations aggregations-userDefinedSplit.tml
    -library fdl-functions-storeGroups.fdl
    -keys CustomerID
    -input RetailTransApril.ftr -output RetailGroupSplitsApril.ftr

También consulte

Funciones de agregación para mediciones y derivaciones

Expressions (Expresiones)

Uso de funciones de agregación y las cláusulas where y default

Tema principal: Referencia de Transaction Measurement Language (TML)


Evaluación del enfoque de estadísticas: la instrucción de calcular

El archivo de estadística para qsmeasure, la ventana Agregar registros equivalente o qstrack contienen instrucciones calculate del siguiente tipo:

La instrucción calculate define una estadística de enfoque llamada nombre en términos de una función de agregación aplicada a una expresión FDL [consulte Expressions (Expresiones)], que puede referirse a los campos en el enfoque de origen.

Al igual que sucede con una medición [consulte Uso de funciones de agregación y las cláusulas where y default], qsmeasure, qstrack o la ventana Agregar registros deriva efectivamente un campo virtual que corresponde a la expresión entre paréntesis que sigue a la función de agregación.

La instrucción calculate genera un único valor de resultado, que se obtiene aplicando la función de agregación a todos los valores en el campo virtual. (Por el contrario, la instrucción create en un archivo de agregaciones genera un campo en el que cada valor se obtiene aplicando la función de agregación a los valores en el campo virtual para un grupo de registros.)

El tipo de dato por defecto de una estadística de enfoque depende de la función de agregación y de los valores, los operadores y las funciones involucradas en la expresión a la que este se aplica, pero se lo puede anular si se especifica un tipo compatible [consulte Tipos de datos].

Si la instrucción calculate contiene una cláusula where, la función de agregación ignora los registros para los que la expresión asociada evalúa a 0 ("falso"). Esta expresión puede hacer referencia a campos en el enfoque de origen.

Una vez que se ha definido una estadística de enfoque en el archivo de estadística, se puede remitir a ella en las expresiones del archivo de agregaciones o del archivo seguidor mediante la forma especial STATISTIC.nombre. Se puede usar esta forma siempre que se desee remitirse a un campo en el archivo seguidor o de enfoque de origen.

Ejemplos Dado el archivo de estadísticas, statistics-amount.tml, que contiene lo siguiente:

calculate averageAmount := mean(Amount);

Dado el archivo de agregaciones, aggregations-statistic.tml, que contiene:

crear averageSpend := mean(Amount);

crear bigSpender := averageSpend > STATISTIC.averageAmount;

Aplicar estas agregaciones al enfoque RetailTransApril.ftr para crear un enfoque orientado al cliente RetailAprilBigSpenders.ftr que contenga los campos CustomerID, averageSpend y bigSpender:

qsmeasure -statistics statistics-amount.tml

-aggregations aggregations-statistic.tml

-keys CustomerID

-input RetailTransApril.ftr -output RetailAprilBigSpenders.ftr

También consulte

Funciones de agregación para mediciones y derivaciones

Tema principal: Referencia de Transaction Measurement Language (TML)


Funciones de agregación para mediciones y derivaciones

Existen varias funciones de agregación disponibles para su uso en mediciones y derivaciones.

Utilizar una función en un contexto de medición significa utilizarla \funccontextmeasure.

Utilizar una función en un contexto de derivación significa utilizarla \funccontextderive.

Excepto en el caso de que se indique lo contrario, una función de agregación toma un campo único numérico, de cadena o de fecha como un argumento.

Funciones de agregación para mediciones y derivaciones Puede utilizar las siguientes funciones de agregación tanto en contextos de medición como en aquellos de derivación:

Función | Resultado
count | Cantidad de registros en el grupo/segmento (Esta función no toma un argumento)
max [consulte la sección max (un argumento)] | El valor no nulo máximo del campo para el grupo/segmento (En un contexto de derivación, esta función no acepta como argumento una expresión con valores en cadena).
mean [consulte la sección mean (un argumento)] | La media (promedio común) de los valores no nulos del campo para el grupo/segmento (Esta función requiere como argumento una expresión numérica).
min [consulte la sección min (un argumento)] | El valor no nulo mínimo del campo para el grupo/segmento (En un contexto de derivación, esta función no acepta como argumento una expresión con valores en cadena).
stdev | La desviación estándar de los valores no nulos del campo para el grupo/segmento (Esta función requiere como argumento una expresión numérica).
sum [consulte la sección sum (un argumento)] | La suma de los valores no nulos del campo para el grupo/segmento (Esta función requiere como argumento una expresión numérica).
variance | La varianza de los valores no nulos del campo para el grupo/segmento (Esta función requiere como argumento una expresión numérica).

Funciones de agregación solo para mediciones Puede utilizar las siguientes funciones de agregación solamente en un contexto de medición:

Función | Resultado
any | Un valor no nulo en el campo, extraído de un registro no nulo arbitrario en el grupo/segmento
confintlower | Límite inferior de un intervalo de confianza del 95% para la media de un campo del grupo
confintupper | Límite superior de un intervalo de confianza del 95% para la media de un campo del grupo
countnonnull [consulte la sección countnonnull/countnonnulls] | Cantidad de registros en el grupo para los cuales el campo tiene valores no nulos [consulte la sección El valor null] En las derivaciones, en cambio, utilice countnonnulls.
countnull [consulte la sección countnull/countnulls] | Cantidad de registros en el grupo para los cuales el campo contiene valore nulos [consulte la sección El valor null] En las derivaciones, en cambio, utilice countnulls.
countunique | Cantidad de valores únicos que se dan en el campo, posiblemente incluido el valor nulo
countuniquenonnull | Cantidad de valores únicos, sin incluir el valor nulo, que se dan en el campo
first | El primer valor no nulo mínimo del campo para el grupo
last | Último valor no nulo mínimo del campo para el grupo
median | Mediana (valor medio) de los valores no nulos del campo para el grupo (Esta función requiere como argumento una expresión numérica o con valores de cadena).
mode | Modo (valor más común) de los valores no nulos del campo para el grupo
moderatio | Proporción de registros no nulos en el grupo que contienen los valores no nulos más comunes del campo

Funciones de agregación solo para derivaciones Puede utilizar las siguientes funciones de agregación solamente en un contexto de derivación:

Función | Resultado
countnonnulls [consulte la sección countnonnull/countnonnulls] | Cantidad de registros en el segmento para el cual el campo tiene valores no nulos [consulte la sección El valor null] En las mediciones, en cambio, utilice countnonnull.
countnulls [consulte la sección countnull/countnulls] | Cantidad de registros en el segmento para el cual el campo incluye valores nulos [consulte la sección El valor null] En las mediciones, en cambio, utilice countnull.
percentage | Cantidad de registros en el segmento, como porcentaje de la cantidad total de registros (Esta función no toma un argumento)
percentagerate | Porcentaje de registros no nulos en el segmento que contienen el valor 1 en el campo El campo solo debe contener los valores 0 y 1.
segindex | Número positivo que identifica de manera única el segmento que se encuentra dentro de la tabulación cruzada formada por los campos de desglose (Esta función no toma un argumento)
significance | Significancia estadística de cualquier discrepancia entre el valor medio del campo en el segmento y el valor medio del campo para toda la población, con un signo que indica la dirección de la desviación (Esta función requiere como argumento una expresión numérica).
Tema principal: Referencia de Transaction Measurement Language (TML)


Palabras reservadas en TML

Los siguientes símbolos son palabras reservadas en TML:

aggregation, all, and, as, auto, automatic, bin, binning, bool, boolean, by, calculate, constant, create, crosstab, date, default, description, dimension, double, drl, enum, except, fields, file, float, format, from, full, function, group, include, inplace, input, int, integer, join, left, long, merge, meta, modifiable, normal, on, open, outer, outfile, output, parameter, pragma, real, ref, reference, rename, right, separate_functions, short, show, show_empty_segments, show_summaries, sort, state, statistic, strbytes, string, suppress, table, temp, temporary, track, tracker, view, where

Para utilizar una palabra reservada o una palabra diferente únicamente en fuente de una palabra reservada, como un nombre de campo o estadística en TML o como un identificador [consulte Expressions (Expresiones)] en FDL, debe encerrarla con comillas simples, por ejemplo, 'Date'.

También consulte

Acerca de Transaction Measurement Language

Palabras reservadas en FDL

Tema principal: Referencia de Transaction Measurement Language (TML)


Referencia de Field Derivation Language (FDL)

  • Acerca del lenguaje de derivación de campos (FDL)
  • Tipos de datos
  • Expressions (Expresiones)
  • Expresiones condicionales
  • Variables
  • Funciones definidas por el usuario
  • Funciones incorporadas
  • Palabras reservadas en FDL
  • Operadores de FDL
  • Funciones de FDL
  • Rangos
  • Expresiones regulares de FDL


Acerca del lenguaje de derivación de campos (FDL)

Field Derivation Language (FDL) es un lenguaje simple que permite especificar la creación de campos nuevos en enfoques de Portrait Miner. Puede utilizar FDL en el Visor de Tablas [consulte la sección Para derivar un campo utilizando Visor de Tablas] de Decision Studio, los asistentes Derivar campos [consulte la sección Para derivar campos en un enfoque mediante el uso de Portrait Miner] y Agregar registros [consulte la sección Para convertir un enfoque orientado en la transacción a un enfoque orientado en el cliente], y los comandos % de creación de datos de Portrait Miner. Aquí no se menciona su uso con los registros qsderive, qsmeasure, qstrack y qsselect.
Puede emplear FDL para lo siguiente:
  • Transformar, combinar y realizar una variedad de otros cálculos en campos existentes en un enfoque
  • Dividir un enfoque en un conjunto de muestras aleatorias
  • Definir segmentaciones y modelos predictivos
  • Seleccionar registros de acuerdo con un criterio que elija

Comúnmente lo utiliza en expresiones de "una línea" simples, tal como aquellas descritas en Expresiones básicas, pero también puede utilizarlo para construir scripts con rutas de ejecución complejas dependientes de datos.

La sintaxis de FDL incluye:
  • Operadores para aritmética [consulte la sección Operadores aritméticos].
  • Operadores para comparación [consulte Operadores relacionales] y para la combinación de expresiones lógicas [consulte la sección Operadores lógicos].
  • Dos construcciones alternativas para la evaluación condicional de instrucciones: if...then...else y case [consulte la sección Expresiones condicionales].
  • Un conjunto integral de funciones incorporadas [consulte la sección Funciones incorporadas].
  • La posibilidad de encapsular transformaciones comunes como funciones definidas por el usuario [consulte la sección Funciones definidas por el usuario] para volver a utilizar y compartir.
  • Variables, para retener valores para volver a utilizar dentro de un script FDL, incluido (en algunos contextos) variables del "acumulador" global [consulte la sección Variables globales en Decision Studio].
  • Una facilidad que permite incorporar tabulaciones cruzadas a derivaciones .

También consulte

Acerca de Transaction Measurement Language

Expressions (Expresiones)

Tema principal: Referencia de Field Derivation Language (FDL)


Tipos de datos

Los siguientes tipos de datos básicos son compatibles en FDL [consulte la sección Acerca del lenguaje de derivación de campos (FDL)]:

Tipo | Descripción | Ejemplos (como literales de FDL)
entero | Un número sin una parte fraccional (entre -2 147 483 647 y 2 147 483 646) | 78004, -100
real | Un número con una parte fraccionaria, representado de modo interno como un número de "punto flotante" con precisión de 15 dígitos (entre [image] y [image] , o 0) | 42,3, -0,56
fecha | Una fecha/hora entre AD 1507 y AD 3015, con precisión de un segundo | #2009/01/01, #2009/01/01:16:01:39
cadena | Una cadena de caracteres, que representa datos textuales | "hello"
número pequeño | Un número pequeño sin una parte fraccional (entre qsminsmallint y qsmaxsmallint) | 42, -1
Nota:
  • Si utiliza un valor entero literal (tal como 12345678910) que es demasiado largo para un tipo de datos entero, obtendrá un flujo excesivo. Con frecuencia puede trabajar con esto utilizando en cambio un valor real: (en este caso, 12345678910.0).
  • El tipo smallinteger tiene aplicabilidad limitada dentro de Portrait Miner, y solo debe utilizarse cuando sea absolutamente necesario. En general, debe utilizar el tipo integer en su lugar.
Tema principal: Referencia de Field Derivation Language (FDL)

El valor null

Además de los valores ordinarios para cada uno de los tipos de datos básicos, un campo o expresión de tipo integer, real, fecha o cadena puede adquirir el valor especial null. El valor nulo siempre representa un valor desconocido (a causa de datos faltantes, dado un flujo excesivo en un cálculo, tal como división por cero, o por algún otro motivo). Se diferencia de cero y la cadena vacía "".

Las funciones y operaciones FDL preservan la incertidumbre introducida por un argumento u operando nulo, con frecuencia proporcionando el valor nulo como resultado. No obstante, hay funciones, a saber isnull y algunas funciones de agregación, que tratan especialmente el valor nulo.

Ejemplos

?

1 + null es igual a null.

1 != null es igual a null.

1 < null es igual a null.

null = null es igual a null.

null != null es igual a null.

false or null es igual a null.

true and null es igual a null.

true or null es igual a true.

false and null es igual a false.

También consulte

ifnull, nvl

Datos booleanos

No hay tipo de datos booleano formal (verdadero/falso) en FDL. Sin embargo, puede tratar un campo integer (o variable) que incluye solo los valores 0 y 1, o una expresión lógica tal como Ingresos < 10000, como si fueran del tipo buleano.

Las expresiones lógicas evalúan a 1 cuando son del tipo true y a 0 cuando son del tipo false. Expresiones condicionales utilizan estos valores para determinar cuáles de dos o más expresiones evaluar. Operadores lógicos también funcionan con estos valores. Un valor de 0 en un campo o variable integer se interpreta como "falso" y cualquier otro valor (no nulo) se interpreta como "true".

Además, puede utilizar las palabras clave true y false como literales buleanos (que representan 1 y 0, respectivamente).

Compatibilidad de tipos

Los tipos de datos integer y real son compatibles con tipos, dado que puede utilizar un valor integer siempre que se requiera un valor real (pero no viceversa), por ejemplo, como un argumento para una función. Los tipos de datos date y string son únicamente compatibles con tipos entre sí mismos.

Los operandos de un operador aritmético binario [consulte la sección Operadores aritméticos] u operador relacional [consulte la sección Operadores relacionales] deben ser compatibles con tipos. De hecho, en el caso de un operador aritmético binario, ambos operandos deben ser numéricos; el resultado es real a menos que los operandos sean enteros.

De igual forma, las expresiones de resultado en una expresión if o case [consulte la sección Expresiones condicionales] deben ser compatibles con tipos, de modo que el tipo del resultado pueda determinarse antes de la evaluación. Si se combinan expresiones de valor integer y real, el resultado es un valor real.

Conversión de tipos

Además de utilizar la conversión de tipos de datos implícita (que se da cuando el tipo de datos de una expresión se fuerza), puede convertir explícitamente entre tipos de datos con las funciones FDL tointeger, toreal, todate y tostring.

Nota: Al convertir desde una cadena a un numérico, cualquier carácter no numérico posterior se ignorará.


Expressions (Expresiones)

Una expresión FDL es una de las siguientes:
  • Una expresión básica [consulte la sección Expresiones básicas]
  • Una expresión condicional [consulte la sección Expresiones condicionales]
  • Una inicialización o asignación de variables [consulte la sección Variables]
  • Una lista de expresiones separadas por puntos y coma (una lista de expresiones), encerrada entre paréntesis

Cada expresión tiene un tipo de datos asociado [consulte Tipos de datos] y puede evaluarse.

Para evaluar una lista de expresiones en un contexto determinado, evalúe cada expresión constituyente por vez, de la primera a la última; el valor de la lista de expresiones en su totalidad es el último valor calculado.

Nota:
  • El tipo de datos se infiere automáticamente. No puede especificar uno diferente mediante el uso de una variable local del tipo requerido, o mediante el uso de una expresión que fuerce el tipo. Por ejemplo, la siguiente expresión fuerza el tipo para que sea real:

    if false then 0.0 else ...

  • Por lo general utiliza listas de expresiones en combinación con asignación de variables.
Tema principal: Referencia de Field Derivation Language (FDL)

Expresiones básicas

Una expresión básica es una de las siguientes:
  • Un identificador, opcionalmente citado entre comillas simples, por ejemplo, 'CustomerID'. Debe encerrar un identificador entre comillas simples si no comienza con una letra ("A" — "Z" o "a" — "z"), incluye caracteres diferentes a letras, dígitos y guiones bajos, o coincide con una palabra reservada TML o FDL (o es diferente de uno únicamente en fuente). Un identificador no debe tener más de 128 caracteres.
  • Un literal numérico, por ejemplo, 30, -3.28, o 3.1e8 (este último representa [image])
  • Un literal de cadena, encerrado en comillas dobles, por ejemplo, "Una cadena"
  • Un literal de fecha, con el prefijo "#", por ejemplo, #2004/03/16 o #2004/03/16:09:12:13
  • La palabra clave "null" (consulte la sección El valor null)
  • Una aplicación de función, que comprende el nombre de una función (un identificador) seguido de una lista de argumentos separados por coma (expresiones) en paréntesis; por ejemplo, mean(IncomeA + IncomeB, TotalEstIncome)
  • Una expresión aritmética, que comprende expresiones de valor numérico conectados por operadores aritméticos [consulte la sección Operadores aritméticos], por ejemplo, 365/52
  • Una relación, que comprende expresiones de valor numérico o de cadena conectadas por operadores relacionales [consulte la sección Operadores relacionales], por ejemplo, Age > 30 o 'State' = "New York"
  • Una expresión lógica, que comprende relaciones u otras expresiones de valor buleano conectadas por operadores lógicos [consulte la secciónOperadores lógicos ], por ejemplo, (Income > 250000) y (MaritalStatus = "Single")
  • Un identificador estadístico, que comprende la palabra clave TML STATISTIC seguida de un identificador, por ejemplo, STATISTIC.AverageIncome (solo en un archivo de agregaciones TML)
  • Una estadística de campos — solo en una derivación de Decision Studio, un archivo de derivaciones qsderive o un archivo de selecciones qsselect selections file>
Nota:
  • Los identificadores FDL distinguen entre mayúsculas y minúsculas. Por ejemplo, las expresiones CustomerID y CUSTOMERID hacen referencia a campos diferentes, mientras que las expresiones isnull(Age) y IsNull(Age) implican funciones diferentes.
  • Un literal numérico se evalúa como un entero si no incluye punto decimal y no utiliza notación científica. De lo contrario, se evalúa como número real.
  • Un literal de cadena puede incluir caracteres diferentes a comillas dobles (") y caracteres de línea nueva.
  • Un literal de fecha se evalúa inicialmente en el formato AMD [consulte la sección Formatos de fecha]; si esto falla, se evalúa de acuerdo a la configuración de su preferencia read [consulte la sección leer].
  • Además de incorporar espacios entre elementos sintácticos, puede incluir comentarios que comiencen con una barra vertical doble ("//") y continúen hasta el final de la línea. For example,
    // This is a comment.
2 + 2 // This is a comment.

También consulte

Palabras reservadas en FDL

Palabras reservadas en TML


Expresiones condicionales

En FDL, hay dos formas principales en las que puede evaluar condicionalmente una expresión: la expresión if y la expresión case.

También consulte

Acerca del lenguaje de derivación de campos (FDL)

Expressions (Expresiones)

Tema principal: Referencia de Field Derivation Language (FDL)

La expresión if

Si la condición (una expresión FDL que regresa un valor booleano [consulte la sección Datos booleanos]) es verdadero, la expresión que sigue a then se evalúa; de lo contrario, la expresión que sigue a else se evalúa. El valor de la expresión es el valor de la expresión evaluada.

Nota:
  • Las expresiones que siguen a then y else deben ser compatibles con tipos [consulte la sección Tipos de datos].
  • Si omite la parte "else" de una expresión if y la condición es false, el valor de la expresión if es null [consulte la sección El valor null].
  • Una condición null [consulte la sección El valor null] se trata por la expresión if como si fuera falsa. Esta es una excepción a la regla general que indica que la incertidumbre introducida por el valor null se preserva por las expresiones FDL. Esto puede dar lugar a resultados imprevistos: por ejemplo, cuando Age es null, las siguientes expresiones (a primera vista equivalentes) generan el valor null, 0 y 1 respectivamente:

    Age > 40

    if Age > 40 then 1 else 0

    if Age <= 40 then 0 else 1

  • Puede probar diferentes condiciones utilizando expresiones if agrupadas; si las expresiones en la que la expresión que sigue a then o else es en sí misma una expresión if. Si la expresión que sigue a then es una expresión if, debe encerrarla entre paréntesis para evitar ambigüedad. Alternativamente, puede utilizar la expresión case [consulte la sección La expresión case].
  • Si su condición se puede expresar como x = 0 (o [image]) para algún número X, también puede utilizar la función FDL incorporada cond en lugar de una expresión if.

Ejemplos

if Age < 40 then "Young"

if Age < 40 then "Young" else "Senior"

if Age > 40 then "Young" else if Age < 60 then "MiddleAged" else "Senior"

if (Age >= 13 and Age < 20) then "Teenager"

if isnull(Age) then mean(Age) else Age

if Responder then RespondDate else StartDate

if match(Postcode, "^EH") then "Y" else "N"

if StartDate < #1998/09/08 then "Loyal" else "Recent"

La expresión case

Si la primera condición (una expresión FDL que regresa un valor booleano [consulte la sección Datos booleanos]) es true, la expresión correspondiente (a la derecha de los dos puntos) se evalúa y regresa como el valor de la expresión case. De lo contrario, se prueba la siguiente condición; de ser true, la expresión correspondiente se evalúa y regresa como el valor de la expresión case. De lo contrario, se prueba la siguiente condición y así sucesivamente.

La palabra clave default especial se interpreta como una expresión siempre true: normalmente la utilizaría como la última condición en una expresión case (dado que las condiciones subsiguientes se ignorarían).

Nota:
  • Todas las expresiones que sucedan a la derecha de los dos puntos deben ser compatibles con tipos [consulte la sección Tipos de datos].
  • Si ninguna de las condiciones es verdadera (y no hay palabra clave default), el valor de la expresión case es null [consulte la sección El valor null].
  • Una condición null [consulte la sección El valor null] se trata por la expresión case como si fuera falsa. Esta es una excepción a la regla general que indica que la incertidumbre introducida por el valor null se preserva por las expresiones FDL. Por ejemplo, cuando Age es null, la siguiente expresión genera el valor 3:

    case

    Age > 40 : 1;

    Age <= 40 : 2;

    default : 3;

  • Si utiliza una expresión case en una lista de expresiones o agrupa una expresión case como condición (dentro de una expresión if u otra expresión case), debe encerrarla entre paréntesis para evitar ambigüedad.

Ejemplos

case

Age < 40: "Young";

default: "NotYoung";

case

Response = "Exc": 7;

Response = "V. Sat": 6

Response = "Sat": 5;

Response = "F. Sat": 4;

Response = "Poor": 3;

Response = "Bad": 2;

default: 1;


Variables

Una variable en FDL es una ubicación de almacenamiento temporal para un valor real, entero, string o date. Puede utilizar una variable local para evaluar una subexpresión% complicada, particularmente útil si se da la misma subexpresión más de una vez%, o para evaluar una expresión que incluye una función de números aleatorios, y así evitar que su valor cambie de una evaluación a la siguiente. También puede utilizar variables global en Decision Studio [consulte la sección Variables globales en Decision Studio] y variables state en archivos de rastreo TML [consulte la sección Variables state en Transaction Measurement Language] para llevar información de un registro al siguiente.

Para asignar un valor a una variable, utilice la siguiente sintaxis:

La primera de tal asignación es una inicialización y determina la clase de la variable% — local (sin palabra clave), global o state. La palabra clave global o state solo se utiliza en conjunto con la primera asignación a una variable global o state (la inicialización).

El identificador [consulte la sección Expresiones básicas] es el nombre de la variable (que no debe coincidir con un nombre de campo en el enfoque).

Para cualquier clase de variable, su tipo de datos [consulte la sección Tipos de datos] es aquel del primer valor que se le asignó.

El valor de una expresión de asignación es simplemente el valor de la expresión a la derecha del signo ":=".

Por ejemplo, la siguiente lista de expresiones asigna aleatoriamente el valor 1 (al 20% de los registros), 2 (a otro 20% de los registros) o 0 (al resto de los registros):

x := rndUniform();

case

x < 0.2 : 1;

x < 0.4 : 2;

default : 0;

Puede escribirse equivalentemente en su forma más compacta:

case

( x := rndUniform() ) < 0.2 : 1;

x < 0.4 : 2;

default : 0;

No obstante, la siguiente lista de expresiones genera un resultado diferente (y probablemente no deseado):

case

rndUniform() < 0.2 : 1;

rndUniform() < 0.4 : 2;

default : 0;

Tema principal: Referencia de Field Derivation Language (FDL)

Variables globales en Decision Studio

Las variables son locales por defecto. Una variable local se destruye tan pronto como se evalúe la última expresión en la lista de expresiones (la más cercana al paréntesis de cierre) [consulte la sección Expressions (Expresiones)] — La próxima vez que se utilice la misma variable, se volverá a inicializar. Una variable local no puede llevar información de un registro al siguiente. Por ejemplo, la siguiente lista de expresiones de derivación de campos produce un campo con 1 en cada registro:

i := 0;

i := i + 1

Una variable global es diferente de una variable local en que no se destruye hasta que Decision Studio o el comando de creación de datos haya calculado los valores de campos para todos los registros. La inicialización solo sucede una vez, para el primer registro en el enfoque. Por ejemplo, la siguiente lista de expresiones de derivación de campos produce un campo índice, con 1 en el primer registro, 2 en el segundo, y así sucesivamente:

global i := 0;

i := i + 1

Puede utilizar una variable global en una lista de expresiones de derivación de campos en una derivación de Decision Studio, en el archivo de derivaciones para qsderive o la ventana Derivar campos equivalente, en un archivo de rastreo para qstracko en un archivo de selecciones para qsselect.

Variables state en Transaction Measurement Language

Puede utilizar una variable state en una definición del campo TML en el archivo de rastreo qstrack.

Una variable state es diferente de una variable local o global en que no se destruye hasta que qstrack haya calculado todos los valores de campos para el grupo actual (según se define por el campo clave). La inicialización sucede una sola vez para cada grupo.

Por ejemplo, la siguiente definición de campo define un campo de equilibrio de ejecución, suponiendo que el campo "Deposit" incluye una cantidad depositada en una transacción (o un valor negativo para una extracción) y el campo "InitialBalance" incluye el saldo inicial para el cliente (quizás de una tabla del cliente unida anteriormente):

create Balance := (

state bal := InitialBalance;

bal := bal + Deposit

)


Funciones definidas por el usuario

Para definir una función FDL que pueda utilizar como una función incorporada [consulte Funciones incorporadas], utilice la siguiente sintaxis:

El identificador [consulte Expresiones básicas] seguido de la palabra clave de la "función" es el nombre de la función. La lista de argumentos (formales) viene a continuación:

Cada argumento formal (excepto uno precedido por una palabra clave "field") actúa como una variable local [consulte Variables] que se inicia con el valor del argumento actual correspondiente cuando se aplica la función. El tipo [consulte Tipos de datos] de cada argumento formal es el tipo especificado en la definición de la función, si la hay; si no, es el tipo del argumento utilizado al aplicar la función. Los paréntesis de cierre son necesario incluso si no existen argumentos formales.

A la lista de argumentos le sigue una lista opcional de atributos de funciones [consulte Atributos de funciones], y después el cuerpo de definición de la función. La lista de expresiones [consulte Expressions (Expresiones)] está encabezada por asignaciones de variables locales que corresponden a los argumentos formales (excepto uno precedido por una palabra clave "field"), antes de ser evaluados para determinar el valor de retorno de la función. El tipo del valor de retorno es similar al de la última expresión.

Ejemplos Defina un función para reemplazar ceros en el resultado de una expresión (de cualquier tipo) con los resultados de otra expresión:

function replaceZeros(expr1, expr2)

{

si expr1 = 0 entonces expr2 si no expr1

}

Una función que toma un argumento en cadena y transforma la primer letra a mayúscula:

function titleCase(texto de la cadena)

{

concat(toupper(left(text, 1)), right(text, strlen(text) - 1));

}

Nota:
  • Al especificar el tipo de argumento de función, utilice "real", "integer", "string" o "date."
  • Puede incluir estadísticas de campo en la definición de un campo, pero cada argumento de función que se utilice en una estadística de campo debe estar precedido por una palabra clave "field". Por ejemplo, para comparar un valor con un resumen de todo el enfoque:

    function MyBand(campo real x)

    {

    averageX := mean(x);

    stdevX := stdev(x);

    case

    x < averageX - stdevX : "Lower";

    x > averageX + stdevX : "Upper";

    default: "Mid";

    }

  • Puede incluir definiciones de campo al principio de la lista de expresiones que define un campo derivado. Estas funciones definidas son locales a la derivación de campo.

    También puede definir las funciones accesibles globales al guardarlas en un archivo (o varios) en la carpeta de la lista de preferencias de bibliotecas de derivación [consulte bibliotecas de derivación] . En Decision Studio, en el panel Familia de funciones en el cuadro de diálogo Funciones de derivación del Visor de Tablas, las funciones en los archivos "clase.fdl" aparecen en la clase con el mismo nombre. Por ejemplo, las funciones en un archivo llamado Conditional.fdl aparecen en la clase Conditional. Puede volver a utilizar el nombre de una clase existente, para agregarle las funciones definidas por el usuario que desee, o puede crear una clase propia utilizando un nuevo nombre.

    Al utilizar el comando de creación de datos qsmeasure de Portrait Miner, la ventana Agregar registros equivalente, o el comando de creación de datos qstrack, puede especificar un archivo que contenga definiciones de funciones globales adicionales.

  • No puede definir funciones de agregación en un contexto de mediciones, es decir, \funccontextmeasure.
  • Si la lista de expresiones finaliza con un carácter alfabético, debe estar separado del paréntesis de cierre por un punto y coma o un espacio en blanco.
Tema principal: Referencia de Field Derivation Language (FDL)

Atributos de funciones

Para especificar los atributos de las funciones:

Atributos útiles:

sinopsis y descripción. Con estos atributos se puede hacer, de manera estándar, la función "con documentación automática". Si una función está instalada en una carpeta incluida en las preferencias de las bibliotecas de derivación [consulte bibliotecas de derivación], la sinopsis se muestra al resaltar la función en el panel Funciones del cuadro de diálogo Funciones de derivación del Visor de Tablas. Si hace clic en el botón Details, se podrá visualizar la descripción. El texto de sinopsis debería ser corto, pero el texto de descripción puede ser más largo.

Por ejemplo:

function nvl(testNull, replaceValue)

[

sinopsis = "Reemplazar valores nulos"

descripción = "la función nvl() reemplaza los valores...las cadenas nulos".

]

(Observe que los atributos de descripción deben estar todos en la misma línea).

element_names. En un archivo de agregación, puede utilizar una función con el atributo element_names para dividir una agregación y crear campos múltiples [consulte División de agregaciones: la cláusula by].

El valor de este atributo es una cadena con una lista de nombres separados por comas, asociados con valores de retorno de la función 1, 2,..., en el orden que están listados.

Por ejemplo, el atributo element_names de la siguiente función asocia los nombres "Low", "Medium" y "High" con los valores de retorno 1, 2 y 3 respectivamente:

function band(x)

[ element_names = "Low,Medium,High" ]

{

clamp(floor(x / 1000), 0, 2) + 1

}

El atributo element_names de la siguiente función asocia los nombres "North", "South", "East" y "West" con los valores de retorno 1, 2, 3 y 4 respectivamente:

function StoreGroupFunction( Store )

[

element_names = "North, South, East, West"

]

{

case

Store = "0000" o Store = "0800" : 1;

Store = "0300" o Store = "0600" o Store = "0700" : 2;

Store = "0100" o Store = "0400" : 3;

por defecto : 4;

}


Funciones incorporadas

FDL incluye una larga lista de funciones incorporadas.

Funciones condicionales

Función | Descripción
clamp | Limitar un número para que se mantenga dentro del intervalo dado.
cond | Producir uno o dos resultados, depende si la expresión es cero o no cero.
iff | Producir uno o dos resultados, depende si la expresión es cero o no cero.
ifnull, nvl | Reemplazar el valor nulo.
isnull | Comprobar si un valor es nulo o no.
isselected | Marcar los registros que están seleccionados.
replace | Reemplazar un número si no está dentro de un intervalo dado.

Funciones de conversión de tipo de datos

Función | Objetivo
todate | Convertir un valor en una fecha.
tointeger | Convertir un valor en un entero.
toreal | Convertir un valor en un número real.
tostring | Convertir un valor en una cadena.

Funciones para trabajar con fechas

Función | Objetivo
addcenturies, addcenturiescountbackwards | Calcular una fecha a partir de otra fecha utilizando un sistema de compensación en siglos.
adddays | Calcular una fecha a partir de otra fecha utilizando un sistema de compensación en días.
addhours | Calcular una fecha a partir de otra fecha utilizando un sistema de compensación en horas.
addminutes | Calcular una fecha a partir de otra fecha utilizando un sistema de compensación en minutos.
addmonths, addmonthscountbackwards | Calcular una fecha a partir de otra fecha utilizando un sistema de compensación en meses.
addseconds | Calcular una fecha a partir de otra fecha utilizando un sistema de compensación en segundos.
addweeks | Calcular una fecha a partir de otra fecha utilizando un sistema de compensación en semanas.
addyears, addyearscountbackwards | Calcular una fecha a partir de otra fecha utilizando un sistema de compensación en años.
countcenturies | Calcular la cantidad de siglos entre dos fechas.
countdays | Calcular la cantidad de días entre dos fechas.
counthours | Calcular la cantidad de horas entre dos fechas.
countminutes | Calcular la cantidad de minutos entre dos fechas.
countseconds | Calcular la cantidad de segundos entre dos fechas.
countweeks | Calcular la cantidad de semanas entre dos fechas.
countwholecenturies, countwholecenturiesbackwards | Calcular la cantidad de siglos enteros entre dos fechas.
countwholedays | Calcular la cantidad de días enteros entre dos fechas.
countwholehours | Calcular la cantidad de horas enteras entre dos fechas.
countwholeminutes | Calcular la cantidad de minutos enteros entre dos fechas.
countwholemonths, countwholemonthsbackwards | Calcular la cantidad de meses enteros entre dos fechas.
countwholeseconds | Calcular la cantidad de segundos entre dos fechas.
countwholeweeks | Calcular la cantidad de semanas enteras entre dos fechas.
countwholeyears, countwholeyearsbackwards | Calcular la cantidad de años enteros entre dos fechas.
countyears | Calcular la cantidad de años entre dos fechas.
day | Obtener el día del mes de una fecha.
dayofweek | Obtener un número que represente el día de la semana de una fecha.
gmt2edt | Convertir una fecha en Hora Media de Greenwich (GMT) al Horario del Este (EDT).
hour | Obtener las horas de una fecha.
minute | Obtener los minutos de una fecha.
month | Obtener los meses de una fecha.
now | Obtener la fecha y la hora actuales.
second | Obtener los segundos de una fecha.
today | Obtener la fecha actual.
weekofyear | Calcular la semana del año de una fecha, tomando una fecha de inicio específica.
year | Obtener el año de una fecha.

Funciones para trabajar con cadenas

Función | Objetivo
concat | Concatenar dos o más cadenas.
endswith | Probar si una cadena termina con otra.
find | Probar si una cadena está dentro de otra.
left | Devolver una subcadena de longitud específica del inicio de una cadena.
mid | Devolver una subcadena de longitud específica del medio de una cadena.
right | Devolver una subcadena de longitud específica del final de una cadena.
soundex | Reducir las palabras a cadenas de cuatro caracteres para un índice.
startswith | Probar si una cadena comienza con otra.
strlen | Obtener la longitud de una cadena.
strmember | Determinar la pertenencia a un conjunto.
substitute | Reemplazar una cadena por otra.
substr | Obtener una subcadena de una cadena.
tolower | Convertir una cadena a minúscula.
toupper | Convertir una cadena a mayúscula.
trim | Eliminar todos los espacios de una cadena de texto, excepto los espacios individuales entre las palabras.

Expresiones regulares y sus funciones asociadas

Función | Objetivo
match | Probar una cadena para encontrar una coincidencia de expresión regular [consulte Expresiones regulares].
replaceall | Reemplazar todas las subcadenas que coinciden con una expresión regular [consulte Expresiones regulares].
replacefirst | Reemplazar la primer subcadena que coincide con una expresión regular [consulte Expresiones regulares].

Funciones matemáticas y estadísticas

Tipo | Descripción
abs | Calcular el valor absoluto de un número.
ceil | Redondear un número para arriba al entero más cercano.
cos | Calcular el coseno de un ángulo.
exp | Calcular el exponencial de un número.
floor | Redondear un número para abajo al entero más cercano.
log | Calcular el logaritmo natural (base e) de un número.
log10 | Calcular el logaritmo base 10 de un número.
logbase | Calcular el logaritmo de un número, en una base específica.
max (dos o más argumentos), maxnonnull | Calcular el más alto de dos o más números, o la más reciente de dos o más fechas, o la última en el alfabeto de dos o más cadenas.
mean (dos o más argumentos), meannonnull | Calcular la media (el promedio) de dos o más números.
min (dos o más argumentos), minnonnull | Calcular el más bajo de dos o más números, o la más lejana de dos o más fechas, o la primera en el alfabeto de dos o más cadenas.
normalize | Normalizar los campos de valores para ubicarlos en el intervalo [0,1].
pow | Calcular el resultado de elevar un número a la potencia de otro número.
product, productnonnull | Calcular el producto de dos o más números.
round | Redondear un número al entero más cercano.
sgn | Calcular el signum (signo) de un número.
sin | Calcular el seno de un ángulo.
sqrt | Calcular la raíz cuadrada de un número.
sum (dos o más argumentos), sumnonnull | Calcular la suma de dos o más números.
tan | Calcular la tangente de un ángulo.

Funciones de muestreo de datos

Función | Objetivo
numericTestTrainSplit | Crear una segmentación de prueba y capacitación para usar en una validación de modelo.
numericTestTrainValidateSplit | Crear una segmentación de prueba, capacitación y validación para usar en una validación de modelo.
sampleEqualSize | Crear, al azar, un índice de segmentación para los grupos de igual tamaño.
sampleExactNumber | Marcar, aleatoriamente, una cantidad exacta de clientes de una población especificada.
sampleExactPercentage | Marcar, aleatoriamente, un porcentaje exacto de clientes de una población especificada.
sampleStratified | Marcar, aleatoriamente, una cantidad exacta de clientes de un segmento y del resto de la población.
testTrainSplit | Crear una segmentación de prueba y capacitación para usar en una validación de modelo.
testTrainValidateSplit | Crear una segmentación de prueba, capacitación y validación para usar en una validación de modelo.

Funciones de números aleatorios

Función | Objetivo
rndBinomial | Generar un entero aleatorio basado en una distribución binomial.
rndBool | Generar un 0 ó 1 de manera aleatoria (con probabilidades iguales).
rndExp | Generar un número positivo aleatorio basado en una distribución exponencial.
rndGamma | Generar un número positivo aleatorio basado en una distribución gamma.
rndNormal | Generar un número positivo aleatorio basado en una distribución normal.
rndPoisson | Generar un número no negativo entero aleatorio basado en un distribución de Poisson discreta.
rndUniform | Generar un número aleatorio entre 0 y 1 basado en una distribución uniforme.

Funciones de rentabilidad de la inversión

Función | Objetivo
ActionROI | Estimar (en dinero) la contribución de rentabilidad de la inversión por cliente al tomar medidas diseñadas para generar una respuesta definitiva.
ActionROIAnnualized | Estimar el múltiplo anual de rentabilidad de la inversión por cliente al tomar medidas diseñadas para generar una respuesta definitiva de un cliente.
OfferROI | Estimar la contribución de rentabilidad de la inversión por cliente al hacer una oferta diseñada para generar una respuesta definitiva.
OfferROIAnnualized | Estimar el múltiplo anual de rentabilidad de la inversión por cliente al hacer una oferta diseñada para generar una respuesta definitiva de un cliente.
RetentionActionROI | Estimar (en dinero) la contribución de rentabilidad de la inversión por cliente al tomar medidas diseñadas para prevenir desgastes.
RetentionActionROIAnnualized | Estimar la contribución anual de rentabilidad de la inversión por cliente al tomar medidas diseñadas para prevenir desgastes.
RetentionOfferROI | Estimar la rentabilidad de la inversión por cliente al hacer una oferta diseñada para prevenir desgastes.
RetentionOfferROIAnnualized | Estimar la rentabilidad anual de la inversión por cliente al hacer una oferta diseñada para prevenir desgastes.

Funciones diversas

Función | Objetivo
dblookup | Buscar valores en una tabla de referencias (guardada como enfoque).
member | Determinar la pertenencia a un conjunto.
rankOrder, rankOrderApprox | Identificar el orden de un valor dentro de una lista de valores.
rankOrderMean, rankOrderApproxMean | Identificar el orden de un valor dentro de una lista de valores.
rownum | Mostrar el número de cada fila en una tabla.

Rangos

Función | Objetivo
bin | Obtener un índice de rangos correspondientes a un valor.

También consulte

Funciones definidas por el usuario
Tema principal: Referencia de Field Derivation Language (FDL)


Palabras reservadas en FDL

Los siguientes símbolos son palabras reservadas en \fdl: accum, agg, aggregate, aggregation, y, by, case, date, default, div, double, else, eq, false, field, float, function, global, if, int, integer, long, mod, not, null, number, numeric, o, real, short, state, string, then, true, where, y while

Para utilizar una palabra reservada o una palabra diferente únicamente en fuente de una palabra reservada, como un identificador [consulte Expressions (Expresiones)] en FDL o como un nombre de campo o estadística en TML, debe encerrarla con comillas simples, por ejemplo, 'State'.

Nota: Si bien los identificadores en FDL distinguen mayúsculas de minúsculas (fred y Fred son distintos), las palabras reservadas no y, por lo tanto, se reservan en cualquier combinación de fuente: por ejemplo, if, If, iF e IF son todas representaciones del mismo símbolo; este tipo de combinaciones están reservadas y no puede utilizarse como identificadores.

También consulte

Acerca del lenguaje de derivación de campos (FDL)

Palabras reservadas en TML

Tema principal: Referencia de Field Derivation Language (FDL)


Operadores de FDL

  • Operadores aritméticos
  • Operadores relacionales
  • Operadores lógicos
  • Prioridad de operadores
Tema principal: Referencia de Field Derivation Language (FDL)


Operadores aritméticos

Excepto por el menos unario, que precede a su único operando, todos los operadores aritméticos FDL son operadores binarios infijos, es decir, están escritos entre sus dos operandos.

Operator (Operador) | Operandos | Resultado
+ (adición) | numérico | La suma de los operandos
- (sustracción) | numérico | El resultado de restar el segundo operando al primero
- (menos unario) | numérico | El negativo del operando
* (multiplicación) | numérico | El producto de los operandos
/ (división) | numérico | El resultado (real) al dividir el primer operando por el segundo
div (división de enteros) | entero | El resultado (entero) al dividir el primer operando por el segundo, ignorando cualquier resto
mod (módulo) | entero | El resto al dividir el primer operando por el segundo (el módulo), con el mismo signo que el primer operando, por ejemplo, 9 % 7 es igual a 2, pero -9 % 7 es igual a -2

Ejemplos 2 + 5 es igual a 7.

2 - 5 es igual a -3.

- (2 + 5) es igual a -7.

2 * 5 es igual a 10.

2 / 5 es igual a 0.4.

2 div 5 es igual a 0.

2 mod 5 es igual a 2.

5 % 2 es igual a 1.

Nota:
  • Los operadores de adición, sustracción, menos unario, y multiplicación conservan el tipo de sus operandos (que son compatibles según el tipo [consulte Compatibilidad de tipos]). Si un operando es un entero y el otro un número real, el resultado será real.
  • Si el segundo operando de una división, división de enteros u operador módulo es cero, es resultado será nulo [consulte El valor null], ya que la división por cero no está especificada.
  • mod requiere operandos enteros.
  • También puede utilizar % en lugar de mod.

También consulte

Operadores lógicos

Prioridad de operadores

Operadores relacionales

Tema principal: Operadores de FDL


Operadores relacionales

Todos los operadores relacionales son operadores binarios no fijos, es decir, están escritos entre sus dos operandos.

Operator (Operador) | Operandos | Resultado
< (menor que) | entero, real, fecha, o cadena | Verdadero si el primer operando es menor que el segundo; falso si el primero es mayor o igual que el segundo
<= (menor que o igual que) | entero, real, fecha, o cadena | Verdadero si el primer operando es menor o igual que el segundo; falso si el primero es mayor que el segundo
> (mayor que o igual que) | entero, real, fecha, o cadena | Verdadero si el primer operando es mayor que el segundo; falso si el primero es menor o igual que segundo
>= (mayor que o igual que) | entero, real, fecha, o cadena | Verdadero si el primer operando es mayor o igual que el segundo; falso si el primero es menor que el segundo
= (igualdad) | entero, real, fecha, o cadena | Verdadero si los dos operandos tienen el mismo valor; falso si los operandos tienen distintos valores. Para tipos de cadenas, la comparación ignora los caracteres de espacio finales en los dos operandos.
!= (desigualdad) | entero, real, fecha, o cadena | Verdadero si los operandos tiene valores diferentes; falso si los dos operandos tiene el mismo valor. Para tipos de cadenas, la comparación ignora los caracteres de espacio finales en los dos operandos.

Ejemplos 2 < 5 igual a 1 (TRUE).

5 < 5 igual a 0 (FALSE).

"A" < "B" igual a 1 (TRUE).

5 <= 5 igual a 1 (TRUE).

5 > 5 igual a 0 (FALSE).

7 > 5 igual a 1 (TRUE).

#2003/12/31 > #2003/11/30 igual a 1 (TRUE).

5 >= 5 igual a 1 (TRUE).

"A" = "A" igual a 1 (TRUE).

"A" = "a" igual a 0 (FALSE).

"A" != "A" igual a 0 (FALSE).

"A" != "a" igual a 1 (TRUE).

Nota:
  • Los operandos de los operadores relacionales binarios deben ser compatibles [consulte Compatibilidad de tipos].
  • Al comparar fechas, "menor que" significa antes que. Al comparar cadenas, "menor que" significa antes en el alfabeto ( o más específicamente, antes en la representación de caracteres subyacentes). Lo mismo pasa con "mayor que" etc.
  • También puede usar == o eq en vez de = y <> en vez de !=.

También consulte

Operadores aritméticos

Datos booleanos

Operadores lógicos

Tema principal: Operadores de FDL


Operadores lógicos

El operador lógico de negación precede a su único operando, mientras que los operadores lógicos de conjunción y disyunción son operadores binarios no fijos, es decir, están escritos entre sus dos operandos.
Operator (Operador) | Operandos | Resultado
and (conjunción lógica) | boolean | Verdadero si ambos operandos son verdaderos; falso si uno de los operandos es falso
or (disyunción lógica) | boolean | Verdadero si un operando es verdadero; falso si los dos operandos son falsos
not (negación lógica) | boolean | Verdadero si el operando es falso; falso si el operando es verdadero

Ejemplos ("A" = "A") y (5 = 5) igual a 1 (TRUE).

("A" = "B") and (5 = 5) igual a 0 (FALSE).

("A" = "B") and (5 = 2) igual a 0 (FALSE).

("A" = "A") or (5 = 5) igual a 1 (TRUE).

("A" = "B") || (5 = 5) igual a 1 (TRUE).

("A" = "B") or (5 = 2) igual a 0 (FALSE).

not ("A" = "A") igual a 0 (FALSE).

!(("A" = "B") or (5 = 2)) igual a 1 (TRUE).

Nota:
  • No hay ningún tipo de datos booleanos [consulte Datos booleanos] en FDL, por eso los operandos para los operadores lógicos con enteros. No debe aplicar estos operadores a números enteros arbitrarios.
  • Puede usar and en vez de and, || en vez de or, y ! en vez de not.

También consulte

Operadores aritméticos

Prioridad de operadores

Operadores relacionales

Tema principal: Operadores de FDL


Prioridad de operadores

Frente a la ausencia de paréntesis, las operaciones FDL en una expresión se llevan a cabo de acuerdo a la prioridad de operadores, del mayor al menor:
Clase | Operadores
Menos unario | -
Operadores de multiplicaciones | * / div mod
Operadores de adición | + -
Operadores relacionales | < <= > >= != =
Negación lógica | not
Operadores lógicos binarios | and or

Si hay igualdad de prioridad, las operaciones se realizan de izquierda a derecha.

Las subexpresiones entre paréntesis se evalúan siempre primero.

Ejemplos -5 + 12 / 4 * 2 + 20 * 3 es igual a 61.

es decir, la expresión se evalúa de la siguiente manera: -5 + ((12 / 4) * 2) + (20 * 3)

Al mover los paréntesis:

-(5 + 12 / (4 * 2) + 20) * 3 es igual a -79.5.

También consulte

Operadores aritméticos

Operadores lógicos

Operadores relacionales

Tema principal: Operadores de FDL


Funciones de FDL

  • Funciones de agregación (argumentos múltiples)
  • Funciones condicionales
  • Funciones de conversión de tipo de datos
  • Funciones para trabajar con fechas
  • Funciones matemáticas y estadísticas
  • Otras funciones
  • Funciones de rentabilidad de la inversión
  • Funciones de números aleatorios
  • Funciones de graduación
  • Funciones de muestreo de datos
  • Funciones para trabajar con cadenas
Tema principal: Referencia de Field Derivation Language (FDL)


Funciones de agregación (argumentos múltiples)

  • max (dos o más argumentos), maxnonnull
  • mean (dos o más argumentos), meannonnull
  • min (dos o más argumentos), minnonnull
  • product, productnonnull
  • sum (dos o más argumentos), sumnonnull
Tema principal: Funciones de FDL


max (dos o más argumentos), maxnonnull

Objetivo Calcular el máximo de dos o más números, o la última de dos o más fechas o la última en orden alfabético de dos o más cadenas. La variante max devuelve el valor nulo si alguno de sus argumentos es nulo, la variante maxnonnull ignora los argumentos nulos (pero aún así devuelve el valor nulo si todos sus argumentos son nulos).

Sintaxis

max( [image], [image], ...)

maxnonnull( [image], [image], ...)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena (todos del mismo tipo) | , [image] , ... | Los valores que deben compararse

Resultado

Tipo | Descripción
como entrada | El máximo de [image] , [image] , ...
Nota:
  • No se debe confundir esta función max multi-argument con la función aggregation [consulte max (un argumento)] del mismo nombre.
  • En el caso de las cadenas, "último en orden alfabético" significa "último en la representación del carácter subyacente".

Ejemplos max(5.5, -3, 7, -8.5) es igual a 7.

max(5.5, -3, nulo, -8.5) es igual a nulo.

maxnonnull (5.5, -3, 7, -8.5) es igual a 7.

maxnonnull (5.5, -3, nulo, -8.5) es igual a 5.5.

Para determinar la mejor acción siguiente para un cliente de acuerdo con distintas medidas de ROI:

maxvalue := max (ROI1, ROI2, ROI3);

case

maxvalue = ROI1: "Producto1";

maxvalue = ROI2: "Producto2";

maxvalue = ROI3: "Producto3";

Tema principal: Funciones de agregación (argumentos múltiples)


mean (dos o más argumentos), meannonnull

Objetivo Calcular el promedio (media común) de dos o más números. La variante media devuelve el valor nulo si alguno de sus argumentos es nulo, la variante meannonnull ignora los argumentos nulos (pero aún así devuelve el valor nulo si todos sus argumentos son nulos).

Sintaxis

mean( [image], [image], ...)

meannonnull( [image], [image], ...)

Argumentos

Tipo | Nombre | Descripción
numérico | , [image] , ... | Los números que se deben promediar

Resultado

Tipo | Descripción
real | La media de [image] , [image] , ...
Nota:

No se debe confundir esta función mean multi-argument con la función deaggregation [consulte mean (un argumento)] del mismo nombre.

Ejemplos mean(5.5, -3, 7, -8.5) es igual a 0.25.

mean (5.5, -3, nulo, -8.5) es igual a nulo.

meannonnull (5.5, -3, 7, -8.5) es igual a 0.25.

meannonnull (5.5, -3, nulo, -8.5) es igual a -2.

Para calcular el gasto promedio anual de cuatro campos de gasto de trimestres separados:

mean(SpendQtr1, SpendQtr2, SpendQtr3, SpendQtr4)

Tema principal: Funciones de agregación (argumentos múltiples)


min (dos o más argumentos), minnonnull

Objetivo Calcular el mínimo de dos o más números, o la más temprana de dos o más fechas o la primera en orden alfabético de dos o más cadenas. La variante min devuelve el valor nulo si alguno de sus argumentos es nulo, la variante minnonnull ignora los argumentos nulos (pero aún así devuelve el valor nulo si todos sus argumentos son nulos).

Sintaxis

min( [image], [image], ...)

minnonnull( [image], [image], ...)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena (todos del mismo tipo) | , [image] , ... | Los valores que deben compararse

Resultado

Tipo | Descripción
como entrada | El mínimo de [image] , [image] , ...
Nota:
  • No se debe confundir esta función min multi-argument con la función aggregation [consulte min (un argumento)] del mismo nombre.
  • En el caso de las cadenas, "primera en orden alfabético" significa "primera en la representación del carácter subyacente".

Ejemplos min(5.5, -3, 7, -8.5) es igual a -8.5.

min (5.5, -3, nulo, -8.5) es igual a nulo.

minnonnull (5.5, -3, 7, -8.5) es igual a -8.5.

minnonnull (5.5, -3, nulo, -8.5) es igual a -8.5.

Tema principal: Funciones de agregación (argumentos múltiples)


product, productnonnull

Objetivo Calcular el producto de dos o más números. La variante product devuelve el valor nulo si alguno de sus argumentos es nulo, la variante productnonnull ignora los argumentos nulos (pero aún así devuelve el valor nulo si todos sus argumentos son nulos).

Sintaxis

product( [image], [image], ...)

productnonnull( [image], [image], ...)

Argumentos

Tipo | Nombre | Descripción
numérico | , [image] , ... | Los números que deben multiplicarse

Resultado

Tipo | Descripción
como entrada | El producto de [image] , [image] , ...

Ejemplos product(5.5, -3, 7, -8.5) es igual a 981.75.

product (5.5, -3, nulo, -8.5) es igual a nulo.

productnonnull (5.5, -3, 7, -8.5) es igual a 981.75.

productnonnull (5.5, -3, nulo, -8.5) es igual a 140.25.

Tema principal: Funciones de agregación (argumentos múltiples)


sum (dos o más argumentos), sumnonnull

Objetivo Calcular la suma de dos o más números. La variante sum regresa el valor nulo si cualquiera de sus argumentos es nulo; la variante sumnonnull ignora los argumentos nulos (pero aún regresa el valor nulo si todos sus argumentos son nulos).

Sintaxis

sum( [image], [image], ...)

sumnonnull( [image], [image], ...)

Argumentos

Tipo | Nombre | Descripción
numérico | , [image] , ... | Los números que se agregarán

Resultado

Tipo | Descripción
como entrada | La suma de [image] , [image] , ...
Nota:

Tenga cuidado de no confundir esta función de suma multi-argument con la función de aggregation [consulte la sección sum (un argumento)] del mismo nombre.

Ejemplos sum(5.5, -3, 7, -8.5) es igual a 1.

sum (5.5, -3, null, -8.5) es igual a null.

sumnonnull(5.5, -3, 7, -8.5) es igual a 1.

sumnonnull(5.5, -3, null, -8.5) es igual a -6.

Para derivar el gasto total de seis campos de datos semanales:

sum(SpendWk1, SpendWk2, SpendWk3, SpendWk4, SpendWk5, SpendWk6)

Tema principal: Funciones de agregación (argumentos múltiples)


Funciones condicionales

  • clamp
  • cond
  • iff
  • ifnull, nvl
  • isnull
  • isselected
  • replace
Tema principal: Funciones de FDL


clamp

Objetivo Restringir un número para que esté dentro de un intervalo determinado.

Sintaxis clamp(x, min, max)

Argumentos

Tipo | Nombre | Descripción
numérico | x | El número al que se aplicará la función clamp
como x | min | El límite más bajo del intervalo
como x | max | El límite más alto del intervalo

Resultado

Tipo | Descripción
como entrada | x if [image] ; min if x < min; max if x > max

Ejemplos Para fijar valores dentro de un rango de 18 a 65 inclusive, reemplace los valores fuera del rango con los límites adecuados del rango:

CustomerAge | clamp(CustomerAge,18,65)
9 | 18
18 | 18
66 | 65
43 | 43

También consulte

replace
Tema principal: Funciones condicionales


cond

Objetivo Producir uno de los dos resultados en función de si una expresión es cero o no cero.

Sintaxis cond(cond, trueExpr, falseExpr)

Argumentos

Tipo | Nombre | Descripción
entero | cond | La expresión para probar
entero, real, fecha, o cadena | trueExpr | Rama "True" (no cero)
como trueExpr | falseExpr | Rama "False" (cero)

Resultado

Tipo | Descripción
como trueExpr, falseExpr | trueExpr Si cond [image] 0; falseExpr Si cond = 0
Nota:

A diferencia de la expresión if [consulte la sección La expresión if] o la expresión case [consulte la sección La expresión case], ambas ramas se evalúan por la función cond.

Más significativamente, cond preserva la incertidumbre de un valor null [consulte El valor null] en la condición.

Si este comportamiento no es necesario, utilice una expresión if o case para agilizar la acción.

Ejemplos Para orientarse a clientes con un gasto cero en el Trimestre 2 para una campaña de correo:

SpendQtr2 | cond(SpendQtr2, "Don't Mail", "Mail")
100.39 | Don't Mail
0 | Mail
-5.72 | Mail
null | null

También consulte

clamp

iff

ifnull, nvl

replace

Tema principal: Funciones condicionales


iff

Objetivo Producir uno de los dos resultados en función de si una expresión es cero o no cero.

Sintaxis iff(logical_text, value_if_true, value_if_false)

Argumentos

Tipo | Nombre | Descripción
real | logical_text | La expresión para probar
entero, real, fecha, o cadena | value_if_true | Rama "True" (no cero)
como value_if_true | value_if_false | Rama "False" (cero o null)

Resultado

Tipo | Descripción
como value_if_true, value_if_false | value_if_true si logical_text [image] 0; value_if_false si logical_text = 0 o logical_text es nulo

Ejemplos iff(Score > 650, "Mail", "No Mail")

También consulte

cond
Tema principal: Funciones condicionales


ifnull, nvl

Objetivo Reemplazar el valor null. Puede utilizar nvl como alias para ifnull.

Sintaxis ifnull(testNull, replaceValue)

nvl(testNull, replaceValue)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | testNull | El valor que será comprobado
como testNull | replaceValue | El reemplazo para el valor null

Resultado

Tipo | Descripción
como entrada | Una copia del valor testNull con replaceValue que reemplaza el valor null

Ejemplos Para reemplazar valores faltantes con un valor derivado de otro campo:

SpendQtr1 | AnnualSpend | ifnull(SpendQtr1, AnnualSpend/4)
45.21 | 178.97 | 45.21
null | 150.56 | 37.64
null | 784.27 | 196.07
59.05 | 274.18 | 59.05

También consulte

cond

isnull

Tema principal: Funciones condicionales


isnull

Objetivo Probar si un valor es null.

Sintaxis isnull(x)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | x | El valor que será comprobado

Resultado

Tipo | Descripción
entero | 1 if x es null; 0 de lo contrario

Ejemplos Para reemplazar entradas de valor null en un campo con el valor medio de ese campo:

Age | if isnull(Age) then mean(Age) else Age
32 | 32
null | 44
59 | 59
27 | 27

También consulte

División de agregaciones: la cláusula by
Tema principal: Funciones condicionales


isselected

Objetivo Marcar los registros que están seleccionados.

Sintaxis isselected()

Argumentos Ninguno

Resultado

Tipo | Descripción
entero | 1 si el registro está seleccionado, de lo contrario 0
Nota:

El Visor de Tablas es compatible con la expansión inmediata [consulte Ayuda en la entrada de funciones en Visor de Tablas] de esta función.

Ejemplos if isselected() then "LowRisk" else "HighRisk"

Tema principal: Funciones condicionales


replace

Objetivo Reemplazar un número si no se encuentra dentro de un intervalo determinado.

Sintaxis replace(x, min, max, y)

Argumentos

Tipo | Nombre | Descripción
numérico | x | El número que se probará
como x | min | El límite más bajo del intervalo
como x | max | El límite más alto del intervalo
como x | y | El valor de reemplazo

Resultado

Tipo | Descripción
como entrada | x si [image] ; de lo contrario y

Ejemplos Para fijar valores dentro de un intervalo de 18 a 65 inclusive, reemplace los valores fuera del rango con el valor medio:

CustomerAge | replace (CustomerAge, 18, 65, mean(CustomerAge))
9 | 38
18 | 18
66 | 38
43 | 43

También consulte

clamp
Tema principal: Funciones condicionales


Funciones de conversión de tipo de datos

  • todate
  • tointeger
  • toreal
  • tostring
Tema principal: Funciones de FDL


todate

Objetivo Convertir un valor en una fecha.

Sintaxis todate(x [, format] )

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | x | El valor a convertir
cadena | format | El formato de fecha [consulte Formatos de fecha] a utilizar para la conversión (opcional, y solo se puede elegir si x es un tipo de cadena)

Resultado

Tipo | Descripción
fecha | x, como una fecha
Nota:
  • Si el argumento es un número entero, se asume que representará la fecha en el formato AAAAMMDD.
  • Si el argumento es un número real, se asume que representará la fecha en el formato AAAAMMDD.HHMMSS.
  • Si el argumento es una cadena, y no se define argumento de formato de fecha, la cadena se convierte siguiendo la configuración de las preferencias de lectura [consulte leer].

Ejemplos (Valores de fechas en formato europeo.)

todate(20040109) igual a 09/01/2004:00:00:00.

todate(20040109.122853) igual a 09/01/2004:12:08:52.

todate("09/01/2004") igual a 09/01/2004:00:00:00.

todate("09-Jan-2004","%d-%b-%Y") igual a 09/01/2004:00:00:00.

todate(#09/01/2004:12:28:53) igual a 09/01/2004:12:28:53.

También consulte

tointeger

toreal

tostring

Conversión de tipos

Tema principal: Funciones de conversión de tipo de datos


tointeger

Objetivo Convertir un valor en un entero.

Sintaxis tointeger(x)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | x | El valor a convertir

Resultado

Tipo | Descripción
entero | x, como un entero
Nota:
  • SI el argumento es un número real, se ignorarán los dígitos después de la coma decimal.
  • Si el argumento es una fecha, el resultado tendrá el formato AAAAMMDD (se ignorará el componente de hora).
  • Si el argumento es una cadena, se ignorarán los caracteres numéricos finales.

Ejemplos tointeger(100) igual a 100.

tointeger (100.65) igual a 100.

tointeger ("100.65") igual a 100.

tointeger (#09/01/2004:12:28:53) igual a 20040109.

También consulte

todate

toreal

tostring

Conversión de tipos

Tema principal: Funciones de conversión de tipo de datos


toreal

Objetivo Convertir un valor en un número real.

Sintaxis toreal(x)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | x | El valor a convertir

Resultado

Tipo | Descripción
real | x, como un número real
Nota:
  • Si el argumento es una fecha, el resultado tendrá el formato AAAAMMDD.HHMMSS.
  • Si el argumento es una cadena, se ignorarán los caracteres numéricos finales.

Ejemplos toreal(100) igual a 100.0.

toreal (100.65) igual a 100.65.

toreal ("100.65") igual a 100.65.

toreal (#09/01/2004:12:28:53) igual a 20040109.122853.

También consulte

todate

tointeger

tostring

Conversión de tipos

Tema principal: Funciones de conversión de tipo de datos


tostring

Objetivo Convertir un valor en una cadena.

Sintaxis tostring(x)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | x | El valor a convertir

Resultado

Tipo | Descripción
cadena | x, como una cadena
Nota:
  • Si el argumento es real, el resultado será en formato decimal normal (no científico).
  • Si el resultado es un dato, el resultado tendrá el formato indicado en la configuración de las preferencias de escritura de fecha [consulte escritura de fecha].

Ejemplos tostring(100) igual a "100".

tostring (1.0065e2) igual a "100.650000".

tostring ("100.65") igual a "100.65".

tostring (#09/01/2004:12:28:53 igual a "09/01/2004:12:28:53".

También consulte

todate

tointeger

toreal

Conversión de tipos

Tema principal: Funciones de conversión de tipo de datos


Funciones para trabajar con fechas

  • addcenturies, addcenturiescountbackwards
  • adddays
  • addhours
  • addminutes
  • addmonths, addmonthscountbackwards
  • addseconds
  • addweeks
  • addyears, addyearscountbackwards
  • countcenturies
  • countdays
  • counthours
  • countminutes
  • countseconds
  • countweeks
  • countwholecenturies, countwholecenturiesbackwards
  • countwholedays
  • countwholehours
  • countwholeminutes
  • countwholemonths, countwholemonthsbackwards
  • countwholeseconds
  • countwholeweeks
  • countwholeyears, countwholeyearsbackwards
  • countyears
  • day
  • dayofweek
  • gmt2edt
  • hour
  • minute
  • month
  • now
  • second
  • today
  • weekofyear
  • year
Tema principal: Funciones de FDL


addcenturies, addcenturiescountbackwards

Objetivo Calcular una fecha a partir de otra fecha utilizando un sistema de compensación en siglos.

Sintaxis addcenturies(date, n)

addcenturiescountbackwards(date, n)

Argumentos

Tipo | Nombre | Descripción
fecha | fecha | Fecha de comienzo
entero | n | La cantidad de siglos a agregar (puede ser un número negativo)

Resultado

Tipo | Descripción
fecha | La fecha n agrega siglos a la fecha date (que se entiende como |n| siglos antes de date si n < 0). La hora del resultado es la misma que la de date. Consulte addmonths, addmonthscountbackwards para leer una explicación de las dos variantes.
Nota:

El resultado de agregar n años con la función addcenturies (o addcenturiescountbackwards) es el resultado de agregar 1200n meses con la función addmonths (o addmonthscountbackwards).

Ejemplos Para calcular una fecha un siglo más tarde que d, mostrando la diferencia entre las variantes addcenturies y addcenturiescountbackwards (formato de fecha AMD):

d | addcenturies(d,1) | addcenturiescountbackwards(d,1)
1900/02/14 | 2000/02/14 | 2000/02/15
También consulte

countcenturies

countwholecenturies, countwholecenturiesbackwards

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


adddays

Objetivo Calcular una fecha a partir de otra fecha utilizando un sistema de compensación en días.

Sintaxis adddays(date, n)

Argumentos

Tipo | Nombre | Descripción
fecha | fecha | Fecha de comienzo
entero | n | Cantidad de días a agregar (puede ser un número negativo)

Resultado

Tipo | Descripción
fecha | La fecha n agrega años a la fecha date (que se entiende como |n| días antes de date si n < 0). La hora del resultado es la misma que la de date.

Ejemplos Formato de fecha europeo: adddays (#09/01/2004, 25) igual a 03/02/2004.

Formato de fecha europeo: adddays (09/01/2004:11:43:46, 25) igual a 03/02/2004:11:43:46.

Formato de fecha estadounidense: adddays (#01/09/2004, 25) igual a 02/03/2004.

Formato de fecha estadounidense: adddays (#01/09/2004:11:43:46, 25) igual a 02/03/2004:11:43:46.

Formato de fecha AMD: adddays (#2004/01/09, 25) igual a 2004/02/03.

Formato de fecha AMD: adddays (#2004/01/09:11:43:46, 25) igual a 2004/02/03:11:43:46.

También consulte

countdays

countwholedays

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


addhours

Objetivo Calcular una fecha a partir de otra fecha utilizando un sistema de compensación en horas.

Sintaxis addhours(date, n)

Argumentos

Tipo | Nombre | Descripción
fecha | fecha | Fecha de comienzo
entero | n | Cantidad de horas a agregar (puede ser un número negativo)

Resultado

Tipo | Descripción
fecha | La fecha n agrega horas a la fecha date (que se entiende como |n| |horas antes de date si n < 0)
Nota:

Todas las fechas en FDL incluyen un componente de hora.

Ejemplos Formato de fecha europeo: addhours (#09/01/2004:12:28:53, 25) igual a 10/01/2004:13:28:53.

Formato de fecha estadounidense: addhours (#01/09/2004:12:28:53, 25) igual a 01/10/2004:13:28:53.

Formato de fecha AMD: addhours (#2004/01/09:12:28:53, 25) igual a 2004/01/10:13:28:53.

También consulte

counthours

countwholehours

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


addminutes

Objetivo Calcular una fecha a partir de otra fecha utilizando un sistema de compensación en minutos.

Sintaxis addminutes(date, n)

Argumentos

Tipo | Nombre | Descripción
fecha | fecha | Fecha de comienzo
entero | n | Cantidad de minutos a agregar (puede ser un número negativo)

Resultado

Tipo | Descripción
fecha | La fecha n agrega minutos a la fecha date (que se entiende como |n| minutos antes de date si n < 0)
Nota:

Todas las fechas en FDL incluyen un componente de hora.

Ejemplos Formato de fecha europeo: addminutes (#09/01/2004:12:28:53, 25) igual a 09/01/2004:12:53:53.

Formato de fecha estadounidense: addminutes (#01/09/2004:12:28:53, 25) igual a 01/09/2004:12:53:53.

Formato de fecha AMD: addminutes (#2004/01/09:12:28:53, 25) igual a 2004/01/09:12:53:53.

También consulte

countminutes

countwholeminutes

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


addmonths, addmonthscountbackwards

Objetivo Calcular una fecha a partir de otra fecha utilizando un sistema de compensación en meses.

Sintaxis addmonths(date, n)

addmonthscountbackwards(fecha, n)

Argumentos

Tipo | Nombre | Descripción
fecha | fecha | Fecha de comienzo
entero | n | La cantidad de meses a agregar (puede ser un número negativo)
Resultado
Tipo Descripción
fecha La fecha n agrega meses a la fecha date (que se entiende como |n| meses antes de date si n < 0).

Las partes de mes y año del resultado están determinadas por el desplazamiento n.

El día del mes del resultado es el mismo de la fecha date (para addmonths) o la misma cantidad de días desde el último día del mes como en la fecha date (para addmonthscountbackwards).

Si el día del mes resulta ser anterior al comienzo del mes o posterior a su finalización (porque el mes de resultado es un mes más corto que el mes de date), se fijará en el primer o último día del mes, según corresponda.

La hora del resultado es la misma que la de date.

Nota:
  • Si agrega n meses utilizando la función (o addmonthscountbackwards), no obtendrá el mismo resultado que al agregar un mes n veces, ya que el día del mes estará limitado por un mes corto intermedio en el último caso.
  • Los resultados al agregar meses con addmonths y addmonthscountbackwards puede ser diferentes si el mes de la fecha y el mes del resultado tienen una cantidad diferente de días.

Ejemplos Para calcular una fecha un mes más tarde que d, mostrando la propagación de las partes de hora (formato de fecha AMD):

d | addmonths(d,1)
2007/08/14:00:00:00 | 2007/09/14:00:00:00
2007/08/14:12:34:56 | 2007/09/14:12:34:56

Para calcular una fecha un mes más tarde que d, mostrando la diferencia entre las variantes addcenturies y addcenturiescountbackwards (formato de fecha AMD):

d | addmonths(d,1) | addmonthscountbackwards(d,1)
2007/08/14 | 2007/09/14 | 2007/09/13

Para calcular una fecha un mes más tarde que d, mostrando el comportamiento de fijación de addmonths al final de un mes (formato de fecha AMD):

d | addmonths(d,1)
2007/08/31 | 2007/09/30

Para calcular una fecha un mes más tarde que d, mostrando el comportamiento de fijación de addmonthscountbackwards al final de un mes (formato de fecha AMD):

d | addmonthscountbackwards(d,1)
2007/08/02 | 2007/09/01
2007/08/01 | 2007/09/01

Para calcular los seis meses desde el día de adquisición de cada cliente utilizando el campo de fecha de adquisición del cliente StartDate:

addmonths(StartDate, 6)

También consulte

countwholemonths, countwholemonthsbackwards

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


addseconds

Objetivo Calcular una fecha a partir de otra fecha utilizando un sistema de compensación en segundos.

Sintaxis addseconds(date, n)

Argumentos

Tipo | Nombre | Descripción
fecha | fecha | Fecha de comienzo
entero | n | Cantidad de segundos a agregar (puede ser un número negativo)

Resultado

Tipo | Descripción
fecha | La fecha n agrega segundos a la fecha date (que se entiende como |n| segundos antes de date si n < 0)
Nota:

Todas las fechas en FDL incluyen un componente de hora.

Ejemplos Formato de fecha europeo: addseconds (#09/01/2004:12:28:53, 25) igual a 09/01/2004:12:54:18.

Formato de fecha estadounidense: addseconds (#01/09/2004:12:28:53, 25) igual a 01/09/2004:12:54:18.

Formato de fecha AMD: addseconds (#2004/01/09:12:28:53, 25) igual a 2004/01/09:12:54:18.

También consulte

countseconds

countwholeseconds

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


addweeks

Objetivo Calcular una fecha a partir de otra fecha utilizando un sistema de compensación en semanas.

Sintaxis addweeks(date, n)

Argumentos

Tipo | Nombre | Descripción
fecha | fecha | Fecha de comienzo
entero | n | Cantidad de semanas a agregar (puede ser un número negativo)

Resultado

Tipo | Descripción
fecha | La fecha n agrega semanas a la fecha date (que se entiende como |n| semanas antes de date si n < 0) La hora del resultado es la misma que la de date.

Ejemplos Formato de fecha europeo: addweeks (#09/01/2004, 8) igual a 05/03/2004.

Formato de fecha estadounidense: addweeks (#01/09/2004, 8) igual a 03/05/2004.

Formato de fecha AMD: addweeks (#2004/01/09, 8) igual a 2004/03/05.

También consulte

countweeks

countwholeweeks

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


addyears, addyearscountbackwards

Objetivo Calcular una fecha a partir de otra fecha utilizando un sistema de compensación en años.

Sintaxis addyears(date, n)

addyearscountbackwards(fecha, n)

Argumentos

Tipo | Nombre | Descripción
fecha | fecha | Fecha de comienzo
entero | n | Cantidad de años a agregar (puede ser un número negativo)

Resultado

Tipo | Descripción
fecha | La fecha n agrega años a la fecha date (que se entiende como |n| años antes de date si n < 0). La hora del resultado es la misma que la de date. Consulte addmonths, addmonthscountbackwards para leer una explicación de las dos variantes.
Nota:

El resultado de agregar n años con la función addyears (o addyearscountbackwards) es el resultado de agregar 12n meses con la función addmonths (o addmonthscountbackwards).

Ejemplos Para calcular una fecha un año más tarde que d, mostrar la diferencia entre las variantes addyears y addyearscountbackwards (formato de fecha AMD):

d | addyears(d,1) | addyearscountbackwards(d,1)
2007/02/14 | 2008/02/14 | 2008/02/15

Para calcular el primer aniversario de la adquisición de cada cliente, utilizando el campo de fecha de adquisición del cliente StartDate:

addyears(StartDate, 1)

También consulte

countwholeyears, countwholeyearsbackwards

countyears

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


countcenturies

Objetivo Calcular el período entre dos fechas en siglos.

Sintaxis countcenturies(date1, date2)

Argumentos

Tipo | Nombre | Descripción
fecha | date1 | la primera fecha
fecha | date2 | la segunda fecha

Resultado

Tipo | Descripción
real | El período entre date1 y date2 en siglos (un número negativo si date1 es posterior a date2)
Nota:
  • Si el período no es un múltiplo exacto de 100 años (teniendo en cuenta las partes de hora en las fechas) el resultado incluye una parte fraccionaria.
  • El resultado de la función countcenturies es igual al resultado de la función countyears dividido por 100.

Ejemplos Formato de fecha europeo: countcenturies (#09/01/2004, #09/01/2054) igual a 0.5.

Formato de fecha estadounidense: countcenturies (#01/09/2004, #01/09/2054) igual a 0.5.

Formato de fecha AMD: countcenturies (#2004/01/09, #2054/01/09) igual a 0.5.

También consulte

countwholecenturies, countwholecenturiesbackwards

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


countdays

Objetivo Calcular el período entre dos fechas en días.

Sintaxis countdays(date1, date2)

Argumentos

Tipo | Nombre | Descripción
fecha | date1 | la primera fecha
fecha | date2 | la segunda fecha

Resultado

Tipo | Descripción
real | El período entre date1 y date2 en días (un número negativo si date1 es posterior a date2)
Nota:

Si la hora entre las dos fechas difiere, el resultado incluye una parte fraccionaria.

Ejemplos Formato de fecha europeo: countdays (#09/01/2004, #03/02/2004) igual a 25.

countdays ((#09/01/2004:10:00:00, #03/02/2004:11:00:00) igual a 25.04.

countdays (#09/01/2004:11:00:00, #03/02/2004:10:00:00) igual a 24.96.

Formato de fecha estadounidense: countdays (#01/09/2004, #02/03/2004) igual a 25.

countdays (#01/09/2004:10:00:00, #02/03/2004:11:00:00) igual a 25.04.

countdays (#01/09/2004:11:00:00, #02/03/2004:10:00:00) igual a 24.96.

Formato de fecha AMD: countdays (#2004/01/09, #2004/02/03) igual a 25.

countdays(#2004/01/09:10:00:00, #2004/02/03:11:00:00) igual a 25.04.

countdays (#2004/01/09:11:00:00, #2004/02/03:10:00:00) igual a 24.96.

También consulte

adddays

countwholedays

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


counthours

Objetivo Calcular el período entre dos fechas en horas.

Sintaxis counthours(time1, time2)

Argumentos

Tipo | Nombre | Descripción
fecha | time1 | la primera fecha/hora
fecha | time2 | la segunda fecha/hora

Resultado

Tipo | Descripción
real | El período entre time1 y time2 en horas (un número negativo si time1 es posterior a time2)
Nota:

Si los minutos o segundos entre las dos fechas difieren, el resultado incluye una parte fraccionaria.

Ejemplos Formato de fecha europeo: counthours (#09/01/2004:12:28:53, #10/01/2004:13:28:53) igual a 25.

Formato de fecha estadounidense: counthours (#01/09/2004:12:28:53, #01/10/2004:13:28:53) igual a 25.

Formato de fecha AMD: counthours (#2004/01/09:12:28:53, #2004/01/10:13:28:53) igual a 25.

También consulte

countwholehours

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


countminutes

Objetivo Calcular el período entre dos fechas en minutos.

Sintaxis countminutes(time1, time2)

Argumentos

Tipo | Nombre | Descripción
fecha | time1 | la primera fecha/hora
fecha | time2 | la segunda fecha/hora

Resultado

Tipo | Descripción
real | El período entre time1 y time2 en minutos (un número negativo si time1 es posterior a time2)
Nota:

Si los segundos entre las dos fechas difieren, el resultado incluye una parte fraccionaria.

Ejemplos Formato de fecha europeo: countminutes (#09/01/2004:12:28:53, #09/01/2004:12:53:53) igual a 25.

Formato de fecha estadounidense: countminutes (#01/09/2004:12:28:53, #01/09/2004:12:53:53) igual a 25.

Formato de fecha AMD: countminutes (#2004/01/09:12:28:53, #2004/01/09:12:53:53) igual a 25.

También consulte

countwholeminutes

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


countseconds

Objetivo Contar la cantidad de segundos entre dos fechas.

Sintaxis countseconds(time1, time2)

Argumentos

Tipo | Nombre | Descripción
fecha | time1 | la primera fecha/hora
fecha | time2 | la segunda fecha/hora

Resultado

Tipo | Descripción
real | La cantidad de segundos transcurridos entre time1 y time2 (un número negativo si time1 es posterior a time2)
Nota:

La única diferencia entre esta función y countwholeseconds es que el resultado de la última es un número entero.

Ejemplos Formato de fecha europeo: countseconds (#09/01/2004:12:28:53, #09/01/2004:12:29:18) igual a 25.

Formato de fecha estadounidense: countseconds (#01/09/2004:12:28:53, #01/09/2004:12:29:18) igual a 25.

Formato de fecha AMD: countseconds (#2004/01/09:12:28:53, #2004/01/09:12:29:18) igual a 25.

También consulte

Formatos de fecha
Tema principal: Funciones para trabajar con fechas


countweeks

Objetivo Calcular el período entre dos fechas en semanas.

Sintaxis countweeks(date1, date2)

Argumentos

Tipo | Nombre | Descripción
fecha | date1 | la primera fecha
fecha | date2 | la segunda fecha

Resultado

Tipo | Descripción
real | El período entre date1 y date2 en semanas (un número negativo si date1 es posterior a date2)
Nota:

Si el período no es un múltiplo de 7 días (teniendo en cuenta la hora) el resultado incluye una parte fraccionaria.

Ejemplos Formato de fecha europeo: countweeks (#09/01/2004, #05/03/2004) igual a 8.

Formato de fecha estadounidense: countweeks (#01/09/2004, #03/05/2004) igual a 8.

Formato de fecha AMD: countweeks (#2004/01/09, #2004/03/05) igual a 8.

También consulte

countwholeweeks

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


countwholecenturies, countwholecenturiesbackwards

Objetivo Contar la cantidad de siglos enteros entre dos fechas.

Sintaxis countwholecenturies(date1, date2) countwholecenturiesbackwards(date1, date2)

Argumentos

Tipo | Nombre | Descripción
fecha | date1 | la primera fecha
fecha | date2 | la segunda fecha

Resultado

Tipo | Descripción
entero | La cantidad de siglos enteros transcurridos entre date1 y date2 (un número negativo si date1 es posterior a date2). Consulte countwholemonths, countwholemonthsbackwards para leer una explicación de las dos variantes.
Nota:
  • El resultado de la función countwholecenturies (o countwholecenturiesbackwards) es el resultado de la función countwholemonths (o countwholemonthsbackwards) dividido por 1200, ignorando cualquier resto.
  • El resultado de una comparación de dos fechas con countwholecenturies y countwholecenturiesbackwards puede variar, pero solo si las dos fechas son en febrero, una de las dos en un año divisible por 400, y la otra en un año divisible por 100 pero no por 400.

Ejemplos Para contar la cantidad de siglos enteros entre d1 y d2, mostrando la diferencia entre las variantes countwholecenturies y countwholecenturiesbackwards (formato de fecha AMD):

d1 | d2 | countwholecenturies(d1,d2) | countwholecenturiesbackwards(d1,d2)
1900/02/14 | 2000/02/13 | 0 | 0
1900/02/14 | 2000/02/14 | 1 | 0
1900/02/14 | 2000/02/15 | 1 | 1

También consulte

addcenturies, addcenturiescountbackwards

countcenturies

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


countwholedays

Objetivo Contar la cantidad de días enteros entre dos fechas.

Sintaxis countwholedays(date1, date2)

Argumentos

Tipo | Nombre | Descripción
fecha | date1 | la primera fecha
fecha | date2 | la segunda fecha

Resultado

Tipo | Descripción
entero | La cantidad de períodos de 24 horas enteros transcurridos entre date1 y date2 (un número negativo si date1 es posterior a date2).

Ejemplos Formato de fecha europeo: countdays (#09/01/2004, #03/02/2004) igual a 25.

countdays (#09/01/2004:10:00:00, #03/02/2004:11:00:00) igual a 25.

countdays (#09/01/2004:11:00:00, #03/02/2004:10:00:00) igual a 24.

Formato de fecha estadounidense: countdays (#01/09/2004, #02/03/2004) igual a 25.

countdays (#01/09/2004:10:00:00, #02/03/2004:11:00:00) igual a 25.

countdays (#01/09/2004:11:00:00, #02/03/2004:10:00:00) igual a 24.

Formato de fecha AMD: countdays (#2004/01/09, #2004/02/03) igual a 25.

countdays (#2004/01/09:10:00:00, #2004/02/03:11:00:00) igual a 25.

countdays (#2004/01/09:11:00:00, #2004/02/03:10:00:00) igual a 24.

También consulte

adddays

countdays

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


countwholehours

Objetivo Contar la cantidad de horas enteras entre dos fechas.

Sintaxis countwholehours(time1, time2)

Argumentos

Tipo | Nombre | Descripción
fecha | time1 | la primera fecha/hora
fecha | time2 | la segunda fecha/hora

Resultado

Tipo | Descripción
entero | La cantidad de horas enteras transcurridas entre time1 y time2 (un número negativo si time1 es posterior a time2)

Ejemplos Formato de fecha europeo: countwholehours (#09/01/2004:12:28:53, #10/01/2004:13:28:53) igual a 24.

Formato de fecha estadounidense: countwholehours (#01/09/2004:12:28:53, #01/10/2004:13:28:53) igual a 24.

Formato de fecha AMD: countwholehours (#2004/01/09:12:28:53, #2004/01/10:13:28:53) igual a 24.

También consulte

counthours

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


countwholeminutes

Objetivo Contar la cantidad de minutos enteros entre dos fechas.

Sintaxis countwholeminutes(time1, time2)

Argumentos

Tipo | Nombre | Descripción
fecha | time1 | la primera fecha/hora
fecha | time2 | la segunda fecha/hora

Resultado

Tipo | Descripción
entero | La cantidad de minutos enteros transcurridas entre time1 y time2 (un número negativo si time1 es posterior a time2)

Ejemplos Formato de fecha europeo: countwholeminutes (#09/01/2004:12:28:53, #09/01/2004:12:53:53) igual a 24.

Formato de fecha estadounidense: countwholeminutes (#01/09/2004:12:28:53, #01/09/2004:12:53:53) igual a 24.

Formato de fecha AMD: countwholeminutes (#2004/01/09:12:28:53, #2004/01/09:12:53:53) igual a 24.

También consulte

countminutes

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


countwholemonths, countwholemonthsbackwards

Objetivo Calcular la cantidad de meses enteros entre dos fechas.

Sintaxis countwholemonths(date1, date2) countwholemonthsbackwards(date1, date2)

Argumentos

Tipo | Nombre | Descripción
fecha | date1 | la primera fecha
fecha | date2 | la segunda fecha

Resultado

Tipo | Descripción
entero | La cantidad de meses enteros transcurridos entre date1 y date2 (un número negativo si date1 es posterior a date2)
Nota:
  • Las partes de hora de date1 y date2 son ignoradas.
  • La cantidad de meses enteros entre dos fechas es la mayor cantidad de meses que se pueden agregar a la primera fecha (truncando la parte de hora y utilizando addmonths para countwholemonths, y addmonthscountbackwards en caso de countwholemonthsbackwards) de modo que si la segunda fecha es posterior a la primera, el resultado no será posterior a la segunda fecha, y si la segunda fecha es anterior a la primera, el resultado no podrá ser anterior a la segunda.
  • Los resultados al comparar dos fechas con countwholemonths y countwholemonthsbackwards pueden ser diferentes si las fechas tienen meses de diferente duración.
  • Debido al comportamiento de fijación de addmonths (y addmonthscountbackwards), el valor absoluto de los resultados al comparar dos fechas con countwholemonths (o countwholemonthsbackwards) dependerá del orden de los argumentos si las fechas tienen meses de diferente duración.

Ejemplos Para contar la cantidad de meses completos entre d1 y d2, truncando las partes de hora (formato de fecha AMD):

d1 | d2 | countwholemonths(d1,d2)
2007/08/14:00:00:00 | 2007/09/14:00:00:00 | 1
2007/08/14:12:34:56 | 2007/09/14:00:00:00 | 1

Para contar la cantidad de meses enteros entre d1 y d2, mostrando la diferencia entre las variantes countwholemonths y countwholemonthsbackwards (formato de fecha AMD):

d1 | d2 | countwholemonths(d1,d2) | countwholemonthsbackwards(d1,d2)
2007/08/14 | 2007/09/12 | 0 | 0
2007/08/14 | 2007/09/13 | 0 | 1
2007/08/14 | 2007/09/14 | 1 | 1

Para contar la cantidad de meses enteros entre d1 y d2, mostrando el comportamiento de fijación de countwholemonths al final de un mes (formato de fecha AMD):

d1 | d2 | countwholemonths(d1,d2) | countwholemonths(d2,d1)
2007/08/31 | 2007/09/30 | 1 | 0

Para contar la cantidad de meses enteros entre d1 y d2, mostrando el comportamiento de fijación de countwholemonths al principio de un mes (formato de fecha AMD):

d1 | d2 | countwholemonthsbackwards(d1,d2) | countwholemonthsbackwards(d2,d1)
2007/07/01 | 2007/06/01 | -1 | 0

Para contar la cantidad de comunicaciones por correo electrónico que recibió cada cliente, cuando las comunicaciones se envían el día 5 de cada mes (y la última comunicación fue enviada el 5 de marzo de 2006), utilizando el campo de fecha de adquisición de cliente StartDate:

-countwholemonths(#2006/03/05, StartDate)

Para contar la cantidad de estados mensuales que recibió cada cliente, cuando los estados se envían siete días antes del cierre de cada mes (y el último fue enviado el 24 de marzo de 2006), utilizando el campo de fecha de adquisición de cliente StartDate:

-countwholemonthsbackwards(#2006/03/24, StartDate)

También consulte

addmonths, addmonthscountbackwards

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


countwholeseconds

Objetivo Contar la cantidad de segundos entre dos fechas.

Sintaxis countwholeseconds(time1, time2)

Argumentos

Tipo | Nombre | Descripción
fecha | time1 | la primera fecha/hora
fecha | time2 | la segunda fecha/hora

Resultado

Tipo | Descripción
entero | La cantidad de segundos transcurridos entre time1 y time2 (un número negativo si time1 es posterior a time2)
Nota:

La única diferencia entre esta función y countseconds es que el resultado de la última es un número real.

Ejemplos Formato de fecha europeo: countwholeseconds (#09/01/2004:12:28:53, #09/01/2004:12:29:18) igual a 25.

Formato de fecha estadounidense: countwholeseconds (#01/09/2004:12:28:53, #01/09/2004:12:29:18) igual a 25.

Formato de fecha AMD: countwholeseconds (#2004/01/09:12:28:53, #2004/01/09:12:29:18) igual a 25.

También consulte

Formatos de fecha
Tema principal: Funciones para trabajar con fechas


countwholeweeks

Objetivo Contar la cantidad de semanas enteras entre dos fechas.

Sintaxis countwholeweeks(date1, date2)

Argumentos

Tipo | Nombre | Descripción
fecha | date1 | la primera fecha
fecha | date2 | la segunda fecha

Resultado

Tipo | Descripción
entero | La cantidad de semanas enteras transcurridos entre date1 y date2 (un número negativo si date1 es posterior a date2).

Ejemplos Formato de fecha europeo: countwholeweeks (#09/01/2004, #09/03/2004) igual a 8.

Formato de fecha estadounidense: countwholeweeks (#01/09/2004, #03/09/2004) igual a 8.

Formato de fecha AMD: countwholeweeks (#2004/01/09, #2004/03/09) igual a 8.

También consulte

countweeks

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


countwholeyears, countwholeyearsbackwards

Objetivo Contar la cantidad de años enteros entre dos fechas.

Sintaxis countwholeyears(date1, date2)

countwholeyearsbackwards(date1, date2)

Argumentos

Tipo | Nombre | Descripción
fecha | date1 | la primera fecha
fecha | date2 | la segunda fecha

Resultado

Tipo | Descripción
entero | La cantidad de años enteros transcurridos entre date1 y date2 (un número negativo si date1 es posterior a date2). Consulte countwholemonths, countwholemonthsbackwards para leer una explicación de las dos variantes.
Nota:
  • El resultado de la función countwholeyears(o countwholeyearsbackwards) es el resultado de la función countwholemonths (o countwholemonthsbackwards) dividido por 12, ignorando cualquier resto.
  • El resultado de una comparación de dos fechas con countwholeyears y countwholeyearsbackwards puede variar, pero solo si las dos fechas son en febrero, una en año bisiesto y la otra no.

Ejemplos Para contar la cantidad de años enteros entre d1 y d2, mostrando la diferencia entre las variantes countwholeyears y countwholeyearsbackwards (formato de fecha AMD):

d1 | d2 | countwholeyears(d1,d2) | countwholeyearsbackwards(d1,d2)
2007/02/14 | 2008/02/13 | 0 | 0
2007/02/14 | 2008/02/14 | 1 | 0
2007/02/14 | 2008/02/15 | 1 | 1
Para calcular la edad de cada cliente al 1 de marzo de 2007 desde un campo de fecha de nacimiento DOB (formato de fecha AMD):

countwholeyears(DOB, #2007/03/01)

También consulte

addyears, addyearscountbackwards

countyears

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


countyears

Objetivo Calcular el período entre dos fechas en años.

Sintaxis countyears(date1, date2)

Argumentos

Tipo | Nombre | Descripción
fecha | date1 | la primera fecha
fecha | date2 | la segunda fecha

Resultado

Tipo | Descripción
real | El período entre date1 y date2 en años (un número negativo si date1 es posterior a date2)
Nota:
  • Si las partes de meses, días y hora de las dos fechas difieren, el resultado incluye una parte fraccionaria, y se cuenta el año incompleto como una fracción del número de días (365 ó 366) en el año de la fecha más tardía.

Ejemplos Formato de fecha europeo: countyears (#09/01/2004, #09/01/1994) igual a -10.

Formato de fecha estadounidense: countyears (#01/09/2004, #01/09/1994) igual a -10.

Formato de fecha AMD: countyears (#2004/01/09, #1994/01/09) igual a 10.

También consulte

countwholeyears, countwholeyearsbackwards

Formatos de fecha

Tema principal: Funciones para trabajar con fechas


day

Objetivo Obtener el día del mes de una fecha.

Sintaxis day(date)

Argumentos

Tipo | Nombre | Descripción
fecha | fecha | Una fecha

Resultado

Tipo | Descripción
entero | El día del mes de date

Ejemplos Formato de fecha europeo: day(#09/01/2004) igual a 9.

Formato de fecha estadounidense: day(#01/09/2004) igual a 9.

Formato de fecha AMD: day(#2004/01/09) igual a 9.

También consulte

Formatos de fecha

División de agregaciones: la cláusula by

Tema principal: Funciones para trabajar con fechas


dayofweek

Objetivo Obtener un número que represente el día de la semana de una fecha.

Sintaxis dayofweek(date)

Argumentos

Tipo | Nombre | Descripción
fecha | fecha | Una fecha

Resultado

Tipo | Descripción
entero | El día de la semana de date (un número entre 0 y 6, dónde el 0 representa el domingo)

Ejemplos Formato de fecha europeo: dayofweek (#09/01/2004) igual a 5 (es decir, viernes).

Formato de fecha estadounidense: dayofweek (#01/09/2004) igual a 5 (es decir, viernes).

Formato de fecha AMD: dayofweek (#2004/01/09) igual a 5 (es decir, viernes).

También consulte

Formatos de fecha

División de agregaciones: la cláusula by

Tema principal: Funciones para trabajar con fechas


gmt2edt

Objetivo Convertir una fecha en Hora Media de Greenwich (GMT) al Horario del Este (EDT).

Sintaxis gmt2edt(datetimeGMT)

Argumentos

Tipo | Nombre | Descripción
fecha | datetimeGMT | La fecha en GMT a convertir

Resultado

Tipo | Descripción
fecha | La fecha en EDT, teniendo en cuenta el horario de verano

Ejemplos Invierno: GMT2EDT(#09/01/2004:12:28:53) igual a 09/01/2004:07:28:53.

Verano: GMT2EDT(#09/07/2004:12:28:53) igual a 09/07/2004:08:28:53.

Tema principal: Funciones para trabajar con fechas


hour

Objetivo Obtener las horas de una fecha.

Sintaxis hour(time)

Argumentos

Tipo | Nombre | Descripción
fecha | time | Una fecha/hora

Resultado

Tipo | Descripción
entero | Las horas de time

Ejemplos Formato de fecha europeo: hour (#09/01/2004:12:28:53) igual a 12.

Formato de fecha estadounidense: hour (#01/09/2004:12:28:53) igual a 12.

Formato de fecha AMD: hour (#2004/01/09:12:28:53) igual a 12.

También consulte

Formatos de fecha

División de agregaciones: la cláusula by

Tema principal: Funciones para trabajar con fechas


minute

Objetivo Obtener los minutos de una fecha.

Sintaxis minute(time)

Argumentos

Tipo | Nombre | Descripción
fecha | time | Una fecha/hora
Resultado
Tipo | Descripción
entero | Los minutos de time

Ejemplos Formato de fecha europeo: minute (#09/01/2004:12:28:53) igual a 28.

Formato de fecha estadounidense: minute (#01/09/2004:12:28:53) igual a 28.

Formato de fecha AMD: minute (#2004/01/09:12:28:53) igual a 28.

También consulte

Formatos de fecha

División de agregaciones: la cláusula by

Tema principal: Funciones para trabajar con fechas


month

Objetivo Obtener los meses de una fecha.

Sintaxis month(date)

Argumentos

Tipo | Nombre | Descripción
fecha | fecha | Una fecha
Resultado
Tipo | Descripción
entero | El mes de date

Ejemplos Formato de fecha europeo: month (#09/01/2004) igual a 1.

Formato de fecha estadounidense: month (#01/09/2004) igual a 1.

Formato de fecha AMD: month (#2004/01/09) igual a 1.

También consulte

Formatos de fecha

División de agregaciones: la cláusula by

Tema principal: Funciones para trabajar con fechas


now

Objetivo Obtener la fecha y hora actual.

Sintaxis now()

Argumentos Ninguno

Resultado

Tipo | Descripción
fecha | La fecha actual (incluyendo la hora), que se obtiene del reloj del sistema
Ejemplos Formato de fecha europeo: now () igual a 09/01/2004:12:28:53.

Formato de fecha estadounidense: now () igual a 01/09/2004:12:28:53.

Formato de fecha AMD: now () igual a 2004/01/09:12:28:53.

También consulte

Formatos de fecha

today

Tema principal: Funciones para trabajar con fechas


second

Objetivo Obtener los segundos de una fecha.

Sintaxis second(time)

Argumentos

Tipo | Nombre | Descripción
fecha | time | Una fecha/hora
Resultado
Tipo | Descripción
entero | Los segundos de time

Ejemplos Formato de fecha europeo: second (#09/01/2004:12:28:53) igual a 53.

Formato de fecha estadounidense: second (#01/09/2004:12:28:53) igual a 53.

Formato de fecha AMD: second (#2004/01/09:12:28:53) igual a 53.

También consulte

Formatos de fecha

División de agregaciones: la cláusula by

Tema principal: Funciones para trabajar con fechas


today

Objetivo Obtener la fecha actual.

Sintaxis today()

Argumentos Ninguno

Resultado

Tipo | Descripción
fecha | La fecha actual que se obtiene del reloj del sistema, con la hora configurada en 00:00:00
Ejemplos Formato de fecha europeo: today () igual a 09/01/2004:00:00:00.

Formato de fecha estadounidense: today () igual a 01/09/2004:00:00:00.

Formato de fecha AMD: today () igual a 2004/01/09:00:00:00.

También consulte

Formatos de fecha

now

Tema principal: Funciones para trabajar con fechas


weekofyear

Objetivo Calcular la semana del año de una fecha, tomando una fecha de inicio específica.

Sintaxis weekofyear(date, yearStart)

Argumentos

Tipo | Nombre | Descripción
fecha | fecha | La fecha de la que se quiere calcular la semana del año
fecha | yearStart | La fecha de inicio (por ejemplo, de una año financiero)
Resultado
Tipo | Descripción
entero | La semana del año de date, tomando como referencia a yearStart
Nota:

Solo se utilizan los meses y días de la fecha de inicio.

Ejemplos Formato de fecha europeo: weekofyear (#09/07/2004, #01/04/2004) igual a 14.

Formato de fecha estadounidense: weekofyear (#07/09/2004, #04/01/2004) igual a 14.

Formato de fecha AMD: weekofyear (#2004/07/09, #2004/04/01) igual a 14.

También consulte

Formatos de fecha

División de agregaciones: la cláusula by

Tema principal: Funciones para trabajar con fechas


year

Objetivo Obtener el año de una fecha.

Sintaxis year(date)

Argumentos

Tipo | Nombre | Descripción
fecha | fecha | Una fecha

Resultado

Tipo | Descripción
entero | El año de date

Ejemplos Formato de fecha europeo: year (#09/01/2004) igual a 2004.

Formato de fecha estadounidense: year (#01/09/2004) igual a 2004.

Formato de fecha AMD: year (#2004/01/09) igual a 2004.

También consulte

Formatos de fecha
Tema principal: Funciones para trabajar con fechas


Funciones matemáticas y estadísticas

  • abs
  • ceil
  • cos
  • exp
  • floor
  • log
  • log10
  • logbase
  • normalize
  • pow
  • round
  • sgn
  • sin
  • sqrt
  • tan
Tema principal: Funciones de FDL


abs

Objetivo Calcular el valor absoluto de un número.

Sintaxis abs(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | Un número con signo

Resultado

Tipo | Descripción
como entrada | , el valor absoluto, o la magnitud, de x

Ejemplos abs(10000) igual a 10000.

abs (-25000) igual a 25000.

Para calcular el error absoluto entre un valor previsto y un valor histórico: abs(Value - PredictedValue)

También consulte

sgn
Tema principal: Funciones matemáticas y estadísticas


ceil

Objetivo Redondear un número hacia arriba hasta el entero más cercano.

Sintaxis ceil(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | El número que debe redondearse
Resultado
Tipo | Descripción
entero | , el entero, de forma tal que

Ejemplos ceil(1.25) es igual a 2.

ceil(-1.25) es igual a -1.

Generar un entero aleatorio entre 1 y 10 incluido: ceil(rndUniform()*10)

También consulte

floor

round

Tema principal: Funciones matemáticas y estadísticas


cos

Objetivo Calcular el coseno de un ángulo.

Sintaxis cos(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | Un ángulo en radianes
Resultado
Tipo | Descripción
real | cos x, el coseno de x

Ejemplos cos(0) es igual a 1.

Tema principal: Funciones matemáticas y estadísticas


exp

Objetivo Calcular la exponencial de un número.

Sintaxis exp(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | El número cuyo exponencial debe computarse
Resultado
Tipo | Descripción
real | , el exponencial de x

Ejemplos exp (0) es igual a 1.

Tema principal: Funciones matemáticas y estadísticas


floor

Objetivo Redondear un número hacia abajo hasta el entero más cercano.

Sintaxis floor(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | El número que debe redondearse
Resultado
Tipo | Descripción
entero | , el entero, de forma tal que

Ejemplos floor(1.25) es igual a 1.

floor(-1.25) es igual a -2.

Generar un entero aleatorio entre 0 y 9 incluido: floor(rndUniform()*10)

También consulte

ceil

round

Tema principal: Funciones matemáticas y estadísticas


log

Objetivo Calcular el logaritmo natural de un número en (base e).

Sintaxis log(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | Un número positivo
Resultado
Tipo | Descripción
real | , el logaritmo natural de x

Ejemplos log(1) es igual a 0.

Tema principal: Funciones matemáticas y estadísticas


log10

Objetivo Calcular el logaritmo de un número en base 10.

Sintaxis log10(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | Un número positivo
Resultado
Tipo | Descripción
real | , el logaritmo base-10 de x

Ejemplos log10(100) es igual a 2.

Tema principal: Funciones matemáticas y estadísticas


logbase

Objetivo Calcular el logaritmo de un número en una base especificada.

Sintaxis logbase(x, base)

Argumentos

Tipo | Nombre | Descripción
numérico | x | El número positivo cuyo logaritmo debe computarse
numérico | base | La base que debe usarse
Resultado
Tipo | Descripción
real | , el logaritmo base-basede x

Ejemplos logbase100,10 es igual a 2.

Tema principal: Funciones matemáticas y estadísticas


normalize

Objetivo Normalizar valores de campo que se encuentran en el intervalo [0,1].

Sintaxis normalize(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | El número que debe normalizarse
Resultado
Tipo | Descripción
real | Valor entre 0 y 1 dado por
Nota:

Sólo puede utilizar esta función en una derivación de Decision Studio, en el archivo de derivaciones de qsderive o en la ventana Derivar campos equivalente en el archivo de rastreo qstrack o en un archivo de selecciones de qsselect.

Tema principal: Funciones matemáticas y estadísticas


pow

Objetivo Calcular el resultado de elevar un número a la potencia de otro número.

Sintaxis pow(x, exponent)

Argumentos

Tipo | Nombre | Descripción
numérico | x | El número que debe elevarse a una potencia
numérico | exponent | El exponente
Resultado
Tipo | Descripción
real | , x elevado a la potencia exponent

Ejemplos pow(10, 2) es igual a 100.

Tema principal: Funciones matemáticas y estadísticas


round

Objetivo Redondear un número hasta el entero más cercano.

Sintaxis round(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | El número que debe redondearse
Resultado
Tipo | Descripción
entero | el entero más cercano a x, o, en el caso de un empate, el mayor de los dos enteros más cercanos (en valores absolutos)

Ejemplos round(1.25) es igual a 1.

round (-1.25) es igual a -1.

round (1.5) es igual a 2.

round (-1.5) es igual a -2.

También consulte

ceil

floor

Tema principal: Funciones matemáticas y estadísticas


sgn

Objetivo Calcular el signum (signo) de un número.

Sintaxis sgn(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | Un número con signo
Resultado
Tipo | Descripción
como entrada | Un número representando el signo de x:

Ejemplos sgn(25) igual a 1.

sgn(-25) igual a -1.

También consulte

abs

División de agregaciones: la cláusula by

Tema principal: Funciones matemáticas y estadísticas


sin

Objetivo Calcular el seno de un ángulo.

Sintaxis sin(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | Un ángulo en radianes
Resultado
Tipo | Descripción
real | sin x, el seno de x

Ejemplos sin(3.14159/2) es igual a 1.

Tema principal: Funciones matemáticas y estadísticas


sqrt

Objetivo Calcular la raíz cuadrada de un número.

Sintaxis sqrt(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | Un número no negativo
Resultado
Tipo | Descripción
real | , calcula la raíz cuadrada de x

Ejemplos sqrt(25) es igual a 5.

sqrt(-25) es igual a nulo.

Tema principal: Funciones matemáticas y estadísticas


tan

Objetivo Calcular la tangente de un ángulo.

Sintaxis tan(x)

Argumentos

Tipo | Nombre | Descripción
numérico | x | Un ángulo en radianes
Resultado
Tipo | Descripción
real | tan x, la tangente de x
Nota:

Six se expresa como [image] for some entero n, tan x es indefinida. En ese caso, la función FDL devuelve nulo.

Ejemplos tan(3.14159/4) es igual a 1.

Tema principal: Funciones matemáticas y estadísticas


Otras funciones

  • bin
  • dblookup
  • member
  • rownum
Tema principal: Funciones de FDL


bin

Objetivo Obtener un índice de rangos correspondiente a un valor.

Sintaxis bin(binning, x)

Argumentos

Tipo | Nombre | Descripción
binning | binning | Una creación de rangos con nombre, con valores de parámetro (que deben ser valores literales) en paréntesis si se requiere
entero, real, fecha, o cadena | x | Un valor compatible con la creación de rangos
Resultado
Tipo | Descripción
entero | El índice de rango del rango en el que está x
Nota:
  • Los índices de rango son enteros positivos. Para un rango numérico con una cantidad n de rangos nominales (numerados de 2 a n + 1), los rangos de los extremos superior e inferior [consulte Rangos finales] están numerados 1 y n + 2 respectivamente, mientras que los rangos nulos y sin clasificar están numerados n + 3 y n + 4.
  • Esta función no está disponible en Decision Studio. No obstante, si x es un campo y b es el rango primario asociado con x, se puede obtener el mismo resultado utilizando segindex:

    segindex() by x

Ejemplos Las agregaciones divididas que usan la creación de rangos iguales EqualRange en el campo Amount , lo que resulta en una agregación segmentada en ocho (cuatro rangos internos entre las cantidades 20 y 100 más dos rangos en los extremos, un rango nulo y un rango sin clasificar):

create totalPointsByAmountBands :=

sum(PointsRedeemed) by bin(EqualRange(20, 100, 4), Amount);

Agregaciones divididas en ocho segmentos basadas en la creación de rangos de campaña PrePost, que comienza en [image] mayo de 1999, y con agregados del mes anterior y posterior a la campaña:

create totalSpendPrePostMayCampaign_ := sum(Amount) by

bin(PrePost(todate(19990401), todate(19990501),

todate(19990601)), PurchaseDate);

También consulte

boolean

DayFrom, WeekFrom, MonthFrom, YearFrom

DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom

DayMultipleNumBins, WeekMultipleNumBins, MonthMultipleNumBins, YearMultipleNumBins

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo

DayMultipleWidth, WeekMultipleWidth, MonthMultipleWidth, YearMultipleWidth

DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

DayRange, WeekRange, MonthRange, YearRange

DayTo, WeekTo, MonthTo, YearTo

EqualRange

EqualRangeWidth

NegativeNonNegative

PreDuringPost

PrePost

Sign

División de agregaciones: la cláusula by

Tema principal: Otras funciones


dblookup

Objetivo Búsqueda de valores en una tabla de referencia (almacenado como un enfoque).

Sintaxis dblookup(d, k, f, x)

Argumentos

Tipo | Nombre | Descripción
cadena | d | El nombre de ruta de la tabla de búsqueda
cadena | k | El nombre del campo clave en la tabla de búsqueda
cadena | f | El nombre de otro campo en la tabla de búsqueda
como campo k | x | El valor de búsqueda

Resultado

Tipo | Descripción
como campo f | El valor y en el campo f de la tabla d, para el registro indexado por el valor x presente en el campo clave k

Nota:
  • Sólo debe utilizar esta función para tablas de búsqueda pequeñas. Si la tabla de búsqueda es de un tamaño comparable a una tabla de clientes o de transacciones, debe considerar realizar una unión.
  • Si el valor de búsqueda no está presente en el campo clave, se devuelve el valor nulo.
  • Si el valor de búsqueda se presenta más de una vez en el campo clave, se utiliza el primer valor.
  • El espacio en blanco posterior se corta del valor de búsqueda, pero no de los valores del campo clave en la tabla de búsqueda. Esto puede generar un comportamiento inesperado si el campo clave en la tabla de búsqueda incluye valores con espacios en blanco posteriores.
  • Para la compatibilidad con versiones anteriores, puede colocar un prefijo en el nombre de ruta de la tabla de búsqueda con la cadena focus:.

Ejemplo En un enfoque, la tienda en la que un cliente realiza sus compras frecuentes está registrada en el campo PopularShop. Otro enfoque stores.ftr incluye una tabla de búsqueda que describe las instalaciones en cada tienda: En este enfoque, StoreCode es el campo clave, y el campo HasFuel indica si cada tienda tiene una estación de gasolina. La tienda 105 tiene una estación de gasolina, las tiendas 299 y 204 no, y así sucesivamente; la tienda 189 no está en la tabla de búsqueda. Para derivar un campo que marca si la tienda favorita de cada cliente tiene una estación de gasolina:

PopularShop | dblookup("focus:stores.ftr", "StoreCode", "HasFuel", PopularShop)
105 | 1
299 | 0
204 | 0
189 | null

También consulte

Acerca de la combinación de enfoques
Tema principal: Otras funciones


member

Objetivo Determinar la pertenencia a un conjunto.

Sintaxis

member(x, [image], [image], ...)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | x | El valor que será comprobado
como x | , [image] , ... | Los elementos del conjunto

Resultado

Tipo | Descripción
entero | 1 (true) if x está en el conjunto [image] ; de lo contrario 0 (false)
Nota:
  • Solo se pueden utilizar valores literales (números, cadenas o fechas) para la lista de elementos del conjunto.
  • En general, es más eficiente utilizar la función miembro que una disyunción de pruebas de igualdad. Por ejemplo, la expresión strmember(F, "a", "b", "c") es más rápida de evaluar que F = "a" or F = "b" or F = "c".
  • Para buscar compatibilidad hacia atrás, puede utilizar strmember en vez de member cuando los argumentos sean cadenas.
  • Los espacios en blanco al final de las cadenas no son ignorados.

Ejemplos Para utilizar los dos primeros caracteres de un campo StateCode para identificar clientes de la costa Este u Oeste:

StateCode | miembro (substr (StateCode, 0, 1), "CA", "OR", WA")
OR009 | 1
CA043 | 1
UT005 | 0
WA027 | 1

Para marcar clientes con números telefónicos de 10 dígitos que tengan los códigos de área de Edimburgo (131) o Glasgow (141) (determinando los tres primeros dígitos utilizando el operador div [consulte Operadores aritméticos]):

TelNo | si es miembro (TelNo div 10000000, 131, 141) entonces "Edim/Glas" si no nulo
1312204491 | Edim/Glas
1753833999 | null
1611234567 | null
1417654321 | Edim/Glas

También consulte

División de agregaciones: la cláusula by
Tema principal: Otras funciones


rownum

Objetivo Generar el número de cada fila en la tabla.

Sintaxis rownum()

Argumentos Ninguno

Resultado

Tipo | Descripción
entero | Un número de índice de 1 al número de registros en la tabla
Nota:

Sólo se puede usar esta función en una derivación de Decision Studio, en el archivo de derivación para qsderive o la ventana Derivar campos equivalente en el archivo seguidor para qstrack o en un archivo de selecciones para qsselect.

Ejemplos Para agregar una columna de índice a un conjunto de datos de registro N, con los valores [image]:

Identificación | rownum()
AZ195 | 1
DI539 | 2
JD974 | 3
BY643 | 4
Tema principal: Otras funciones


Funciones de rentabilidad de la inversión

  • ActionROI
  • ActionROIAnnualized
  • OfferROI
  • OfferROIAnnualized
  • RetentionActionROI
  • RetentionActionROIAnnualized
  • RetentionOfferROI
  • RetentionOfferROIAnnualized
Tema principal: Funciones de FDL


ActionROI

Objetivo Calcular la contribución al ROI (dinero) por cliente de emprender una acción diseñada para generar una respuesta definitiva. La acción sucede ya sea que el cliente responda o no, de modo que sólo está el costo de la acción, no del cumplimiento.

Sintaxis ActionROI(ResponseProbability, ValueOfResponse, CostOfAction)

Argumentos

Tipo | Nombre | Descripción
numérico | ResponseProbability | La probabilidad estimada de que un cliente responda a la acción mostrando algún tipo de conducta de respuesta.
numérico | ValueOfResponse | El valor estimado de la respuesta de un cliente a una acción de marketing (si ocurre)
numérico | CostOfAction | El costo estimado de una acción (ya sea que el cliente responda o no)
Resultado
Tipo | Descripción
numérico | La contribución al ROI (dinero) de emprender una acción, calculada por cliente
Nota:
  • La probabilidad de respuesta debe ser un "alza", es decir, la probabilidad de que el cliente muestre esa conducta cuando de otro modo no lo hubiera hecho. Si existe alguna posibilidad de que el cliente muestre la conducta deseada sin emprender la acción, esto debe modelarse utilizando el modelo de "alza" o, si eso falla, se debe restar la posibilidad de la respuesta con acción de la posibilidad sin la acción.
  • El valor de la respuesta debe ser un ingreso neto que ignora el costo de la acción de marketing.

También consulte

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Tema principal: Funciones de rentabilidad de la inversión


ActionROIAnnualized

Objetivo Calcular el ROI múltiple anualizado por cliente de emprender una acción diseñada para generar una respuesta definitiva de un cliente. La acción sucede ya sea que el cliente responda o no, de modo que sólo está el costo de la acción, no del cumplimiento.

Sintaxis ActionROIAnnualized(ResponseProbability, ValueOfResponse, CostOfAction, DaysToROI)

Argumentos

Tipo | Nombre | Descripción
numérico | ResponseProbability | La probabilidad estimada de que un cliente responda a la acción mostrando algún tipo de conducta de respuesta.
numérico | ValueOfResponse | El valor estimado de la respuesta de un cliente a una acción de marketing (si ocurre)
numérico | CostOfAction | El costo estimado de una acción (ya sea que el cliente responda o no)
numérico | DaysToROI | El número de días que se requerirá para lograr un ROI determinado.
Resultado
Tipo | Descripción
numérico | El ROI múltiple anualizado y calculado por cliente de emprender una acción.
Nota:
  • La probabilidad de respuesta debe ser un "alza", es decir, la probabilidad de que el cliente muestre esa conducta cuando de otro modo no lo hubiera hecho. Si existe alguna posibilidad de que el cliente muestre la conducta deseada sin emprender la acción, esto debe modelarse utilizando el modelo de "alza" o, si eso falla, se debe restar la posibilidad de la respuesta con acción de la posibilidad sin la acción.
  • El valor de la respuesta debe ser un ingreso neto que ignora el costo de la acción de marketing.

También consulte

ActionROI

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Tema principal: Funciones de rentabilidad de la inversión


OfferROI

Objetivo Calcular la contribución al ROI por cliente de una oferta diseñada para generar una respuesta definitiva.

Sintaxis OfferROI(ResponseProbability, ValueOfResponse, CostOfOffer, CostOfFulfilment)

Argumentos

Tipo | Nombre | Descripción
numérico | ResponseProbability | La probabilidad estimada de que un cliente responda a la acción mostrando algún tipo de conducta de respuesta.
numérico | ValueOfResponse | El valor estimado de la respuesta de un cliente a una acción de marketing (si ocurre)
numérico | CostOfOffer | El costo estimado de una acción (ya sea que el cliente responda o no)
numérico | CostOfFulfilment | El costo estimado del cumplimiento de una respuesta positiva (cero si no hay costo de cumplimiento (adicional))
Resultado
Tipo | Descripción
numérico | El ROI estimado por cliente de realizar una oferta
Nota:
  • La probabilidad de respuesta debe ser un "alza", es decir, la probabilidad de que el cliente muestre esa conducta cuando de otro modo no lo hubiera hecho. Si existe alguna posibilidad de que el cliente muestre la conducta deseada sin emprender la acción, esto debe modelarse utilizando el modelo de "alza" o, si eso falla, se debe restar la posibilidad de la respuesta con acción de la posibilidad sin la acción.
  • El valor de la respuesta debe ser un ingreso neto que ignora el costo de la acción de marketing y el costo del cumplimiento de la respuesta del cliente.

También consulte

ActionROI

ActionROIAnnualized

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Tema principal: Funciones de rentabilidad de la inversión


OfferROIAnnualized

Objetivo Calcular ROI múltiple anualizado por cliente de hacer una oferta diseñado para generar una respuesta definitiva de un cliente.

Sintaxis OfferROIAnnualized(ResponseProbability, ValueOfResponse, CostOfOffer, CostOfFulfilment, DaysToROI)

Argumentos

Tipo | Nombre | Descripción
numérico | ResponseProbability | La probabilidad estimada de que un cliente responda a la acción mostrando algún tipo de conducta de respuesta.
numérico | ValueOfResponse | El valor estimado de la respuesta de un cliente a una acción de marketing (si ocurre)
numérico | CostOfOffer | El costo estimado de una acción (ya sea que el cliente responda o no)
numérico | CostOfFulfilment | El costo estimado del cumplimiento de una respuesta positiva (cero si no hay costo de cumplimiento (adicional))
numérico | DaysToROI | El número de días que se requerirá para lograr un ROI determinado.
Resultado
Tipo | Descripción
numérico | El ROI múltiple anualizado estimado por cliente de realizar una oferta
Nota:
  • La probabilidad de respuesta debe ser un "alza", es decir, la probabilidad de que el cliente muestre esa conducta cuando de otro modo no lo hubiera hecho. Si existe alguna posibilidad de que el cliente muestre la conducta deseada sin emprender la acción, esto debe modelarse utilizando el modelo de "alza" o, si eso falla, se debe restar la posibilidad de la respuesta con acción de la posibilidad sin la acción.
  • El valor de la respuesta debe ser un ingreso neto que ignora el costo de la acción de marketing y el costo del cumplimiento de la respuesta del cliente.

También consulte

ActionROI

ActionROIAnnualized

OfferROI

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Tema principal: Funciones de rentabilidad de la inversión


RetentionActionROI

Objetivo Calcular la contribución al ROI (dinero) por cliente de una acción diseñada para evitar el desgaste. Se asume que la acción tiene un costo fijo, sin importar si se conserva al cliente o no, y si el cliente "acepta" o no la oferta.

Sintaxis RetentionActionROI(SaveProbability, NetRevenueAtRisk, CostOfAction)

Argumentos

Tipo | Nombre | Descripción
numérico | SaveProbability | La probabilidad estimada de que el cliente se "conservará" (para el período en consideración) como resultado de la acción emprendida
numérico | NetRevenueAtRisk | El ingreso neto estimado que se perderá si el cliente no se conserva durante el período en consideración
numérico | CostOfAction | El costo estimado de una acción (ya sea que el cliente responda o no)
Resultado
Tipo | Descripción
numérico | Calcular la contribución al ROI (dinero) por cliente de una acción diseñada para evitar el desgaste.
Nota:
  • Decir que se ha "conservado" un cliente significa que "se evitó la pérdida de un cliente cuando de lo contrario se hubiera perdido". Este valor es el negativo del alza en la tasa de desgaste producida por el modelo de alza. Alternativamente, puede calcularse como P(desgaste|sin acción) - P(desgaste|con acción).
  • El ingreso neto en riesgo debe ser un ingreso neto que ignora el costo de la acción diseñada para evitar el desgaste.

También consulte

ActionROI

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Tema principal: Funciones de rentabilidad de la inversión


RetentionActionROIAnnualized

Objetivo Calcular la contribución anual al ROI por cliente de una acción diseñada para evitar el desgaste. Se asume que la acción tiene un costo fijo, sin importar si se conserva al cliente o no, y si el cliente "acepta" o no la oferta.

Sintaxis RetentionActionROIAnnualized(SaveProbability, NetRevenueAtRisk, CostOfAction, DaysToROI)

Argumentos

Tipo | Nombre | Descripción
numérico | SaveProbability | La probabilidad estimada de que el cliente se "conservará" (para el período en consideración) como resultado de la acción emprendida
numérico | NetRevenueAtRisk | El ingreso neto estimado que se perderá si el cliente no se conserva durante el período en consideración
numérico | CostOfAction | El costo estimado de una acción (ya sea que el cliente responda o no)
numérico | DaysToROI | El número de días que se requerirá para lograr un ROI determinado.
Resultado
Tipo | Descripción
numérico | La contribución estimada al ROI anualizado por cliente de una acción diseñada para evitar el desgaste.
Nota:
  • Decir que se ha "conservado" un cliente significa que "se evitó la pérdida de un cliente cuando de lo contrario se hubiera perdido". Este valor es el negativo del alza en la tasa de desgaste producida por el modelo de alza. Alternativamente, puede calcularse como P(desgaste|sin acción) - P(desgaste|con acción).
  • El ingreso neto en riesgo debe ser un ingreso neto que ignora el costo de la acción diseñada para evitar el desgaste.

También consulte

ActionROI

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionOfferROI

RetentionOfferROIAnnualized

Tema principal: Funciones de rentabilidad de la inversión


RetentionOfferROI

Objetivo Calcular el ROI por cliente de hacer una oferta diseñada para evitar el desgaste. Una oferta, a diferencia de una acción, tiene un costo diferente si es aceptada por el cliente que si no es aceptada.

Sintaxis RetentionOfferROI(SaveProbability, ResponseProbability, NetRevenueAtRisk, CostOfOffer, CostOfFulfilment)

Argumentos

Tipo | Nombre | Descripción
numérico | SaveProbability | La probabilidad estimada de que el cliente se "conservará" (para el período en consideración) como resultado de la acción emprendida
numérico | ResponseProbability | La probabilidad estimada de que el cliente responda a la oferta
numérico | NetRevenueAtRisk | El ingreso neto estimado que se perderá si el cliente no se conserva durante el período en consideración
numérico | CostOfOffer | El costo estimado de una oferta (ya sea que el cliente responda o no)
numérico | CostOfFulfilment | El costo estimado de obtener una respuesta positiva a la oferta.

Resultado

Tipo | Descripción
numérico | El ROI estimado por cliente de una oferta diseñada para evitar el desgaste
Nota:
  • Decir que se ha "conservado" un cliente significa que "se evitó la pérdida de un cliente cuando de lo contrario se hubiera perdido". Este valor es menos el alza en la tasa de desgaste producido por el modelo de alza. Alternativamente, puede calcularse como P(desgaste|sin acción) - P(desgaste|con acción).
  • El ingreso neto en riesgo debe ser un ingreso neto que ignora el costo de la acción diseñada para evitar el desgaste.

También consulte

ActionROI

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROIAnnualized

Tema principal: Funciones de rentabilidad de la inversión


RetentionOfferROIAnnualized

Objetivo Calcular el ROI anualizado por cliente de hacer una oferta diseñada para evitar el desgaste. Una oferta, a diferencia de una acción, tiene un costo diferente si es aceptada por el cliente que si no es aceptada.

Sintaxis RetentionOfferROIAnnualized(SaveProbability, ResponseProbability, NetRevenueAtRisk, CostOfOffer, CostOfFulfilment, DaysToROI)

Argumentos

Tipo | Nombre | Descripción
numérico | SaveProbability | La probabilidad estimada de que el cliente se "conservará" (para el período en consideración) como resultado de la acción emprendida
numérico | ResponseProbability | La probabilidad estimada de que el cliente responda a la oferta
numérico | NetRevenueAtRisk | El ingreso neto estimado que se perderá si el cliente no se conserva durante el período en consideración
numérico | CostOfOffer | El costo estimado de una oferta (ya sea que el cliente responda o no)
numérico | CostOfFulfilment | El costo estimado de obtener una respuesta positiva a la oferta.
numérico | DaysToROI | El número de días que se requerirá para lograr un ROI determinado.
Resultado
Tipo | Descripción
numérico | El ROI anualizado por cliente estimado de una oferta diseñada para evitar el desgaste.
Nota:
  • Decir que se ha "conservado" un cliente significa que "se evitó la pérdida de un cliente cuando de lo contrario se hubiera perdido". Este valor es menos el alza en la tasa de desgaste producido por el modelo de alza. Alternativamente, puede calcularse como P(desgaste|sin acción) - P(desgaste|con acción).
  • El ingreso neto en riesgo debe ser un ingreso neto que ignora el costo de la acción diseñada para evitar el desgaste.

También consulte

ActionROI

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

Tema principal: Funciones de rentabilidad de la inversión


Funciones de números aleatorios

  • Sobre las funciones de números aleatorios en FDL
  • rndBinomial
  • rndBool
  • rndExp
  • rndGamma
  • rndNormal
  • rndPoisson
  • rndUniform
Tema principal: Funciones de FDL


Sobre las funciones de números aleatorios en FDL

Cuando se evalúa una expresión FDL que involucra a una función de número aleatorio numericTestTrainSplit, numericTestTrainValidateSplit, rndBinomial, rndBool, rndExp, rndGamma, rndNormal, rndPoisson o rndUniform sampleEqualSize, sampleExactNumber, sampleExactPercentage, sampleStratified, testTrainSplit y testTrainValidateSplit), Portrait Miner necesita una "semilla" de un entero para inicializar su secuencia de números aleatorios. Con la misma semilla, la misma expresión siempre producirá la misma secuencia de resultados.
Nota:
  • La semilla se almacena como parte de la información del campo.
  • La generación de números en forma (pseudo)aleatoria está basada en la de Marsaglia, Zaman, y Tsang (1990).
Tema principal: Funciones de números aleatorios


rndBinomial

Objetivo Generar un entero aleatorio basado en una distribución binomial.

Sintaxis rndBinomial(N, p)

Argumentos

Tipo | Nombre | Descripción
entero | n | Los números (positivos) de las pruebas
numérico | p | La probabilidad de éxito de cada prueba (entre 0 y 1)

Resultado

Tipo | Descripción
entero | Un entero aleatorio no negativo tomado de la distribución binomial, con la probabilidad dada por
Nota:

La expectativa y la varianza de la distribución binomial son [image] y [image], respectivamente.

Ejemplos rndBinomial (50, 0.05)

También consulte

Sobre las funciones de números aleatorios en FDL
Tema principal: Funciones de números aleatorios


rndBool

Objetivo Generar 0 ó 1 aleatoriamente (con iguales probabilidades).

Sintaxis rndBool()

Argumentos Ninguno

Resultado

Tipo | Descripción
entero | 0 ó 1, con probabilidades

Ejemplos Derivar un campo que asigna el valor 0 a aproximadamente 50% de los registros (elegidos al azar) y el valor 1 al resto de los registros: rndBool()

También consulte

Sobre las funciones de números aleatorios en FDL
Tema principal: Funciones de números aleatorios


rndExp

Objetivo Generar un número positivo aleatorio basado en una distribución exponencial.

Sintaxis rndExp(b)

Argumentos

Tipo | Nombre | Descripción
numérico | b | El parámetro de la escala (positivo)

Resultado

Tipo | Descripción
real | Un número positivo aleatorio tomado de una distribución exponencial, con la función de densidad de probabilidad dada por [image] (x > 0)
Nota:

La expectativa y la varianza de la distribución exponencial son [image] y [image] respectivamente.

Ejemplos rndExp (10)

También consulte

Sobre las funciones de números aleatorios en FDL
Tema principal: Funciones de números aleatorios


rndGamma

Objetivo Generar un número positivo aleatorio basado en una distribución gamma.

Sintaxis rndGamma(a, b)

Argumentos

Tipo | Nombre | Descripción
entero | a | El número (positivo) de eventos independientes
numérico | b | La relación de eventos (positiva)

Resultado

Tipo | Descripción
real | Un número positivo aleatorio tomado de una distribución gamma [image] , con la función de densidad de probabilidad dada por
Nota:

La expectativa y la varianza de la distribución gamma son [image] y [image] respectivamente.

Ejemplos rndGamma (50, 0.05)

También consulte

Sobre las funciones de números aleatorios en FDL
Tema principal: Funciones de números aleatorios


rndNormal

Objetivo Generar un número aleatorio basado en una distribución normal.

Sintaxis

rndNormal( [image], ef="../../../images/img344.gif"/>h>

Argumentos

Tipo | Nombre | Descripción
numérico |  | La media de la distribución
numérico |  | La desviación estándar de la distribución

Resultado

Tipo | Descripción
real | Un número positivo aleatorio tomado de la distribución normal [image] , con la función de densidad de probabilidad dada por
Nota:

La expectativa y la varianza de la distribución normal son [image] y [image] respectivamente.

Ejemplos Derivar una distribución de Gauss con una media de cero y desviación estándar de unidad: rndNormal(0,1)

También consulte

Sobre las funciones de números aleatorios en FDL
Tema principal: Funciones de números aleatorios


rndPoisson

Objetivo Generar un entero no negativo aleatorio basado en una distribución de Poisson discreta.

Sintaxis rndPoisson(mean)

Argumentos

Tipo | Nombre | Descripción
numérico |  | La media (positiva) de la distribución

Resultado

Tipo | Descripción
entero | Un entero no negativo aleatorio tomado de una distribución discreta de Poisson, con la probabilidad calculada a partir de [image] ( [image] )
Nota:

Tanto la expectativa como la varianza de la distribución de Poisson discreta son iguales a la media, [image].

Ejemplos rndPoisson (10)

También consulte

Sobre las funciones de números aleatorios en FDL
Tema principal: Funciones de números aleatorios


rndUniform

Objetivo Generar un número aleatorio entre 0 y 1 basado en una distribución uniforme.

Sintaxis rndUniform()

Argumentos Ninguno

Resultado

Tipo | Descripción
real | Un número aleatorio tomado de una distribución uniforme por encima de [0, 1)

Ejemplos Para generar un número real aleatorio en el rango de [0,10): rndUniform() * 10

También consulte

Sobre las funciones de números aleatorios en FDL
Tema principal: Funciones de números aleatorios


Funciones de graduación

  • rankOrder, rankOrderApprox
  • rankOrderMean, rankOrderApproxMean
Tema principal: Funciones de FDL


rankOrder, rankOrderApprox

Objetivo Identificar la graduación de un valor dentro de una lista de valores.

Sintaxis

rankOrder(x, [image], [image], ...)

rankOrderApprox(x, [image], [image], ...)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | x | El valor que debe graduarse
como x | , [image] , ... | La lista de valores para comparar

Resultado

Tipo | Descripción
entero | La posición de la primera ocurrencia de x dentro de la lista de valores obtenidos mediante la clasificación de [image] , [image] , ... en orden descendente (de la última a la primera para las fechas; en orden alfabético inverso para las cadenas) Si x no aparece en la lista, rankOrder devuelve nulo, mientras que rankOrderApprox devuelve la posición de x dentro de la lista de valores obtenidos mediante la clasificación de x, [image] , [image] , ... en orden descendente.
Nota:
  • Cuando el valor a jerarquizar aparece exactamente una vez en la lista de valores, rankOrder, rankOrderApprox, rankOrderMean y rankOrderApproxMean todas dan el mismo resultado.
  • Cuando el valor que debe graduarse aparece más de una vez en la lista de valores, rankOrderApprox da el mismo resultado que rankOrder.
  • Cuando el valor que debe graduarse no aparece en la lista de valores, rankOrderApprox da el mismo resultado que rankOrderApproxMean.
  • Para las cadenas, "orden alfabético" significa el orden natural de la representación de los caracteres subyacentes.

Ejemplos rankOrder(6.74, 6.74, 1.99, 0.00, 9.27) es igual a 2.

rankOrderApprox(6.74, 1.99, 0.00, 9.27) es igual a 2.

Para verificar la graduación en un año del número de llamadas de un cliente en el 4º trimestre:

rankOrder(CallsQ4, CallsQ1, CallsQ2, CallsQ3, CallsQ4)

Para verificar la graduación en el mes 5 del número de llamadas de un cliente con respecto a los cuatro meses anteriores:

RankOrderApprox(CallsM5, CallsM1, CallsM2, CallsM3, CallsM4)

También consulte

rankOrderMean, rankOrderApproxMean
Tema principal: Funciones de graduación


rankOrderMean, rankOrderApproxMean

Objetivo Identificar la graduación de un valor dentro de una lista de valores, o su graduación promedio si aparece más de una vez.

Sintaxis

rankOrderMean(x, [image], [image], ...)

rankOrderApproxMean(x, [image], [image], ...)

Argumentos

Tipo | Nombre | Descripción
entero, real, fecha, o cadena | x | El valor que debe graduarse
como x | , [image] , ... | La lista de valores para comparar

Resultado

Tipo | Descripción
real | La clasificación media de x dentro de la lista de valores obtenidos mediante la clasificación de [image] , [image] , ... en orden descendente (de la última a la primera para las fechas; en orden alfabético inverso para las cadenas) Si x no aparece en la lista, rankOrderMean devuelve nulo, mientras que rankOrderApproxMean devuelve la posición de x dentro de la lista de valores obtenidos mediante la clasificación de x, [image] , [image] , ... en orden descendente.
Nota:
  • Cuando el valor a jerarquizar aparece exactamente una vez en la lista de valores, rankOrder, rankOrderApprox, rankOrderMean y rankOrderApproxMean todas dan el mismo resultado.
  • Cuando el valor que debe graduarse aparece más de una vez en la lista de valores, rankOrderApproxMean da el mismo resultado que rankOrderMean.
  • Cuando el valor que debe graduarse no aparece en la lista de valores, rankOrderApproxMean da el mismo resultado que rankOrderApprox.
  • Para las cadenas, "orden alfabético" significa el orden natural de la representación de los caracteres subyacentes.

Ejemplos rankOrderMean(6.74, 6.74, 1.99, 6.74, 9.27) es igual a 2.5.

rankOrderApproxMean(6.74, 1.99, 6.74, 9.27, 6.74) es igual a 2.5.

También consulte

rankOrder, rankOrderApprox
Tema principal: Funciones de graduación


Funciones de muestreo de datos

  • numericTestTrainSplit
  • numericTestTrainValidateSplit
  • sampleEqualSize
  • sampleExactNumber
  • sampleExactPercentage
  • sampleStratified
  • testTrainSplit
  • testTrainValidateSplit
Tema principal: Funciones de FDL


numericTestTrainSplit

Objetivo Crear una segmentación de prueba/capacitación para usar en la validación de modelos.

Sintaxis numericTestTrainSplit(testFraction)

Argumentos

Tipo | Nombre | Descripción
real | testFraction | La fracción de los datos que se utilizará como el conjunto de prueba
Resultado
Tipo | Descripción
entero | Valores 0 para el conjunto de capacitación o 1 para el conjunto de prueba

Ejemplos Para derivar un campo que asigna el valor 0 a aproximadamente 70% de los registros (elegidos en forma aleatoria) y el valor 1 a los restantes: numericTestTrainSplit(0.3)

También consulte

numericTestTrainValidateSplit

sampleEqualSize

testTrainSplit

testTrainValidateSplit

Para particionar un enfoque en subpoblaciones de muestra

Tema principal: Funciones de muestreo de datos


numericTestTrainValidateSplit

Objetivo Crear una segmentación de prueba/capacitación/validación para su uso en la validación de modelos.

Sintaxis numericTestTrainValidateSplit(testFraction, validateFraction)

Argumentos

Tipo | Nombre | Descripción
real | testFraction | La fracción de los datos que se utilizará como el conjunto de prueba
real | validateFraction | La fracción de los datos que se utilizará como el conjunto representativo
Resultado
Tipo | Descripción
entero | Los valores 0 para el conjunto de capacitación, 1 para el conjunto de prueba o 2 para el conjunto de validación

Ejemplos Para derivar un campo que asigna el valor 0 a aproximadamente el 50% de los registros (seleccionados aleatoriamente), el valor 1 a aproximadamente el 30% de los registros (nuevamente seleccionados aleatoriamente) y el valor 2 al resto: numericTestTrainValidateSplit(0.3, 0.2)

También consulte

numericTestTrainSplit

sampleEqualSize

testTrainSplit

testTrainValidateSplit

Para particionar un enfoque en subpoblaciones de muestra

Tema principal: Funciones de muestreo de datos


sampleEqualSize

Objetivo Crear un índice de segmentación que asigne aleatoriamente registros a segmentos de tamaño aproximadamente igual.

Sintaxis sampleEqualSize(NumberOfSegments)

Argumentos

Tipo | Nombre | Descripción
entero | NumberOfSegments | El número de segmentos para crear
Resultado
Tipo | Descripción
entero | Un número entre 1 y NumberOfSegments (inclusive)

Ejemplos Para derivar un campo que enumera cinco poblaciones de igual tamaño (aproximadamente): sampleEqualSize(5)

También consulte

numericTestTrainSplit

numericTestTrainValidateSplit

testTrainSplit

testTrainValidateSplit

Para particionar un enfoque en subpoblaciones de muestra

Tema principal: Funciones de muestreo de datos


sampleExactNumber

Objetivo Crear una muestra aleatoria de un tamaño exacto, especificada como un número de registros.

Sintaxis sampleExactNumber(NumberToSelect)

Argumentos

Tipo | Nombre | Descripción
entero | NumberToSelect | El tamaño de la muestra para crear, como un número de registros

Resultado

Tipo | Descripción
entero | 1 si se selecciona un registro para la muestra; de lo contrario 0
Nota:
  • Los registros que no están actualmente seleccionados en el enfoque reciben el valor nulo.
  • Sólo puede utilizar esta función en una derivación de Decision Studio, en el archivo de derivaciones para qsderive o la ventana Derivar campos equivalente, en el archivo de rastreos para qstrack o en un archivo de selecciones para qsselect.

Ejemplos Para seleccionar 1250 registros para una muestra. sampleExactNumber(1250)

También consulte

sampleExactPercentage

sampleStratified

Para particionar un enfoque en subpoblaciones de muestra

Tema principal: Funciones de muestreo de datos


sampleExactPercentage

Objetivo Crear una muestra aleatoria de un tamaño exacto, especificada como un porcentaje del tamaño de la población seleccionada actualmente.

Sintaxis sampleExactPercentage(PercentageToSelect)

Argumentos

Tipo | Nombre | Descripción
entero | PercentageToSelect | El tamaño de la muestra para crear, como un porcentaje del tamaño de la población actual

Resultado

Tipo | Descripción
entero | 1 si se selecciona un registro para la muestra; de lo contrario 0
Nota:
  • Los registros que no están actualmente seleccionados en el enfoque reciben el valor nulo.
  • Si PercentageToSelect multiplicado por el tamaño de la población no es un número entero, el número seleccionado será el número entero más cercano arriba o abajo de PercentageToSelect multiplicado por el tamaño de la población y proporcionará en promedio el porcentaje especificado.
  • Sólo puede utilizar esta función en una derivación de Decision Studio, en el archivo de derivaciones para qsderive o la ventana Derivar campos equivalente, en el archivo de rastreos para qstrack o en un archivo de selecciones para qsselect.

Ejemplos Para seleccionar el 25% de la población para la muestra: sampleExactPercentage(25)

También consulte

sampleExactNumber

sampleStratified

Para particionar un enfoque en subpoblaciones de muestra

Tema principal: Funciones de muestreo de datos


sampleStratified

Objetivo Crear una muestra aleatoria que incluye un número exacto de registros de un segmento específico, junto con un número exacto de registros del resto de la población seleccionada actualmente.

Sintaxis sampleStratified(NumberFromSegmentToSelect, SegmentTotalSize, NumberOutsideSegmentToSelect, OutsideSegmentTotalSize, InSegmentExpression)

Argumentos

Tipo | Nombre | Descripción
entero | NumberFromSegmentToSelect | El número de registros en la muestra que se seleccionará del segmento especificado
entero | SegmentTotalSize | El número total de registros en el segmento especificado
entero | NumberOutsideSegmentToSelect | El número de registros en la muestra que se seleccionará del resto de la población
entero | OutsideSegmentTotalSize | El número total de registros en el resto de la población
entero | InSegmentExpression | La expresión (booleana) que determina si un registro está o no en el segmento especificado

Resultado

Tipo | Descripción
entero | 1 si se selecciona un registro para la muestra; de lo contrario 0
Nota:
  • Los registros que no están actualmente seleccionados en el enfoque reciben el valor nulo.
  • Sólo puede utilizar esta función en una derivación de Decision Studio, en el archivo de derivaciones para qsderive o la ventana Derivar campos equivalente, en el archivo de rastreos para qstrack o en un archivo de selecciones para qsselect.

Ejemplos Para crear una muestra que comprenda 2500 registros de un total de 25.000 mujeres y 5000 registros de un total de 75.000 no mujeres: sampleStratified(2500, 25000, 5000, 75000, Gender = "F")

También consulte

sampleExactNumber

sampleExactPercentage

Para particionar un enfoque en subpoblaciones de muestra

Tema principal: Funciones de muestreo de datos


testTrainSplit

Objetivo Crear una segmentación de prueba/capacitación para usar en la validación de modelos.

Sintaxis testTrainSplit(testFraction)

Argumentos

Tipo | Nombre | Descripción
real | testFraction | La fracción de los datos que se utilizará como el conjunto de prueba
Resultado
Tipo | Descripción
cadena | Valores de cadena TestSet o TrainingSet

Ejemplos Para derivar un campo que asigna el valor "TrainingSet" a aproximadamente el 70% de los registros (seleccionados aleatoriamente) y el valor "TestSet" al resto:

testTrainSplit(0.3)

También consulte

numericTestTrainSplit

numericTestTrainValidateSplit

sampleEqualSize

testTrainValidateSplit

Para particionar un enfoque en subpoblaciones de muestra

Tema principal: Funciones de muestreo de datos


testTrainValidateSplit

Objetivo Crear una segmentación de prueba/capacitación/validación para su uso en la validación de modelos.

Sintaxis testTrainValidateSplit(testFraction, validateFraction)

Argumentos

Tipo | Nombre | Descripción
real | testFraction | La fracción de los datos que se utilizará como el conjunto de prueba
real | validateFraction | La fracción de los datos que se utilizará como el conjunto representativo

Resultado

Tipo | Descripción
cadena | Valores de cadena TestSet, TrainingSet o ValidationSet

Ejemplos Para derivar un campo que asigna el valor "TrainingSet" a aproximadamente el 50% de los registros (seleccionados aleatoriamente), el valor "TestSet" a aproximadamente el 30% de los registros (nuevamente seleccionados aleatoriamente) y el valor "ValidationSet" al resto:

testTrainValidateSplit(0.3, 0.2)

También consulte

numericTestTrainSplit

numericTestTrainValidateSplit

sampleEqualSize

testTrainSplit

Para particionar un enfoque en subpoblaciones de muestra

Tema principal: Funciones de muestreo de datos


Funciones para trabajar con cadenas

  • concat
  • endswith
  • find
  • left
  • match
  • mid
  • replaceall
  • replacefirst
  • right
  • soundex
  • startswith
  • strlen
  • strmember
  • substitute
  • substr
  • tolower
  • toupper
  • trim
Tema principal: Funciones de FDL


concat

Objetivo Concatenar dos o más cadenas.

Sintaxis

concat( [image], [image], ...)

Argumentos

Tipo | Nombre | Descripción
cadena | , [image] , ... | Cadenas para ser concatenadas
Resultado
Tipo | Descripción
cadena | Cadena obtenida mediante la escritura de los caracteres [image] , seguida de los caracteres [image] , etc.

Ejemplo Obtiene el nombre completo de un cliente de dos campos FirstName y Surname:

FirstName | Surname | concat(FirstName," ",Surname)
John | Brown | John Brown
David | Smith | David Smith

Obtener el nombre completo de un cliente, pero utilizando solo su inicial:

FirstName | Surname | concat(substr(FirstName,0,0),". ",Surname)
John | Brown | J. Brown
David | Smith | D. Smith
Tema principal: Funciones para trabajar con cadenas


endswith

Objetivo Probar si una cadena termina con otra.

Sintaxis endswith(find_text, within_text)

Argumentos

Tipo | Nombre | Descripción
cadena | find_text | La cadena al final
cadena | within_text | La cadena que será comprobada
Resultado
Tipo | Descripción
entero | 1 (true) si find_text se encuentra al final de within_text; 0 (false) si no
Nota:

La función endswith se basa en la función match. Añade un carácter $ a find_text antes de tratar el resultado como una expresión regular [consulte Expresiones regulares].

Ejemplos Para derivar un campo que marca direcciones de correo electrónico desde dominios .net:

EmailAddress | endswith(".net", EmailAddress)
J.Brown@glob.net | 1
D.Smith@portraitsoftware.com | 0

También consulte

find

startswith

Tema principal: Funciones para trabajar con cadenas


find

Objetivo Probar si una cadena está dentro de otra.

Sintaxis find(find_text, within_text)

Argumentos

Tipo | Nombre | Descripción
cadena | find_text | La cadena que se debe encontrar
cadena | within_text | La cadena que será comprobada

Resultado

Tipo | Descripción
entero | 1 (true) si find_text está dentro de within_text; 0 (false) si no
Nota:

La función encontrar se basa en la función match, y trata a find_text como una expresión regular [consulte Expresiones regulares].

Ejemplo Marcar direcciones de correo electrónico que contienen el texto "portraitsoftware" en mayúscula, minúscula o una combinación:

EmailAddress | find("portraitsoftware", tolower(EmailAddress))
J.BROWN@PORTRAITSOFTWARE.COM | 1
J.Brown@glob.net | 0
D.Smith@portraitsoftware.com | 1

También consulte

endswith

startswith

Tema principal: Funciones para trabajar con cadenas


left

Objetivo Devolver una subcadena de longitud específica del inicio de una cadena.

Sintaxis left(text, num_chars)

Argumentos

Tipo | Nombre | Descripción
cadena | text | La cadena de la que se extrae
entero | num_chars | El número de caracteres
Resultado
Tipo | Descripción
cadena | La subcadena formada por caracteres num_chars al principio de text
Nota:

La función izquierda se basa en la función substr.

Ejemplos Para utilizar los dos primeros caracteres de un campo StateCode para identificar clientes de la costa Este u Oeste:

StateCode | member (left(StateCode, 2), "CA", "OR", WA")
OR009 | 1
CA043 | 1
UT005 | 0
WA027 | 1

También consulte

mid

right

trim

Tema principal: Funciones para trabajar con cadenas


match

Objetivo Probar una cadena para encontrar una coincidencia de expresión regular [consulte la sección Expresiones regulares].

Sintaxis match(regexp, string)

Argumentos

Tipo | Nombre | Descripción
cadena | regexp | La expresión regular
cadena | string | La cadena que será comprobada
Resultado
Tipo | Descripción
entero | 1 (true) si regexp coincide con string; 0 (false) si es al revés

Ejemplos Para marcar los clientes con los dos primeros caracteres del código postal de su casa y la sucursal de su banco iguales (función substr):

Código postal de la casa | Código postal de la sucursal | match(substr(HomePostcode, 0, 1), substr(BranchPostcode,0,1))
NE25 0AY | NE30 1QX | 1
SW3 | NG18 1HT | 0
CF36 | CF31 1HY | 1
EH9 0NJ | E10 8AJ | 0

Para buscar en el campo Nombre de la compañía los primeros tres caracteres del campo Nombre, seguidos por cualquier texto y después el contenido del campo Apellido (ignorando las mayúsculas):

FirstName | FamilyName | CompanyName | rx := concat( substr(toupper(FirstName),0,2), "[[:print:]]*", toupper(FamilyName); match(rx,toupper(CompanyName))
Patrick | Smith | 1234 Pat Smith Ltd | 1
Patrick | Smith | 1234 Pat J Smith Ltd | 1

Para hacer lo mismo, pero con solo algunas letras o dígitos y un solo espacio entre el nombre y el apellido:

FirstName | FamilyName | CompanyName | rx := concat( substr(toupper(FirstName),0,2), "[[:alnum:]]* ", toupper(FamilyName); match(rx,toupper(CompanyName))
Patrick | Smith | 1234 Pat Smith Ltd | 1
Patrick | Smith | 1234 Pat J Smith Ltd | 0

También consulte

replaceall

replacefirst

División de agregaciones: la cláusula by

Tema principal: Funciones para trabajar con cadenas


mid

Objetivo Devolver una subcadena de longitud específica del medio de una cadena.

Sintaxis mid(text, start_num, num_chars)

Argumentos

Tipo | Nombre | Descripción
cadena | text | La cadena de la que se extrae
cadena | start_num | El primer índice
cadena | num_chars | El número de caracteres
Resultado
Tipo | Descripción
cadena | La subcadena formada por los caracteres num_chars de la posición de caracteres start_num (incluido) de texto, donde las posiciones de los caracteres están numeradas a partir del 1
Nota:

La función mid está basada en la función substr.

Ejemplos Para derivar una ubicación desde el quinto hasta el séptimo carácter de un código de almacenamiento:

StoreCode | mid(StoreCode, 5, 3)
0114EDI256 | EDI
1863LON836 | LON
9326EDI039 | EDI
0387BOS041 | BOS

También consulte

left

right

trim

Tema principal: Funciones para trabajar con cadenas


replaceall

Objetivo Reemplazar todas las subcadenas que coinciden con una expresión regular [consulte la sección Expresiones regulares].

Sintaxis replaceall(regexp, replacement, string)

Argumentos

Tipo | Nombre | Descripción
cadena | regexp | La expresión regular
cadena | replacement | La cadena de reemplazo
cadena | string | La cadena que se debe buscar
Resultado
Tipo | Descripción
string | Una copia de la cadena string con replacement reemplazando cada parte no superpuesta que coincida con regexp
Nota:

La primera parte con coincidencia de la cadena que se debe buscar es la parte más larga y más a la izquierda que coincide con la expresión regular. La próxima búsqueda será en el resto de la cadena que se debe buscar, y así sucesivamente. For example,

replaceall("i..", "X", "initiation")

produce la cadena "XtXX" (en vez de, por ejemplo, "inXatX"). And

replaceall("i.*i", "X", "initiation")

resulta en "Xon" (en vez de, por ejemplo, "XtXon").

Ejemplos Para detectar y quitar los espacios en blanco del campo PostalCode utilizando una coincidencia de expresión regular:

PostalCode | replaceall("[[:blank:]]","",PostalCode))
ND 069 | ND069
IN 099 | IN099
UT 0 0 5 | UT005
O R 009 | OR009

También consulte

match

replacefirst

Tema principal: Funciones para trabajar con cadenas


replacefirst

Objetivo Reemplazar la primera subcadena que coincide con una expresión regular [consulte la sección Expresiones regulares].

Sintaxis replacefirst(regexp, replacement, string)

Argumentos

Tipo | Nombre | Descripción
cadena | regexp | La expresión regular
cadena | replacement | La cadena de reemplazo
cadena | string | La cadena que se debe buscar
Resultado
Tipo | Descripción
cadena | Una copia de la cadena string con replacement reemplazando la primera parte que coincide con regexp (si hubiera)

Ejemplos Para extraer el nombre de un cliente de un campo de dirección de correo electrónico en el formato "Firstname.Surname@company.com", quitando toda la información desde el "@" en adelante y reemplazando "." por un espacio:

Correo electrónico | replacefirst("@.*", "", (replacefirst ("\.", " ", Email)))
John.Brown@myco.com | John Brown
Angela.Smith@yourco.com | Angela Smith

También consulte

match

replaceall

Tema principal: Funciones para trabajar con cadenas


right

Objetivo Devolver una subcadena de un largo especificado desde el extremo de una cadena.

Sintaxis right(text, num_chars)

Argumentos

Tipo | Nombre | Descripción
cadena | text | La cadena de la que se extrae
entero | num_chars | El número de caracteres
Resultado
Tipo | Descripción
cadena | La subcadena formada por caracteres num_chars en el extremo de text
Nota:

La función "right" está basada en la función substr.

Ejemplos Para devolver el componente casa/calle de un campo de código postal del Reino Unido, es decir, los últimos tres caracteres:

Postcodeold_text | right(Postcode, 3)
NE25 0AY | 0AY
EH3 7RA | 7RA
SL4 1QX | 1QX
EH9 0NJ | 0NJ

También consulte

left

mid

trim

Tema principal: Funciones para trabajar con cadenas


soundex

Objetivo Reducir cada palabra a una cadena de cuatro caracteres para propósitos de indexación.

Sintaxis soundex(text)

Argumentos

Tipo | Nombre | Descripción
cadena | text | El texto que se debe reducir
Resultado
Tipo | Descripción
cadena | Una codificación de índice reducida a cuatro caracteres
Ejemplos Derivar un código soundex para un apellido:
Surname | soundex(Surname)
Brown | B650
Smythe | S530
Smith | S530
Bruno | B650
Nota: La función Soundex no está definida para caracteres que no sean ascii.
Tema principal: Funciones para trabajar con cadenas


startswith

Objetivo Probar si una cadena comienza con otra.

Sintaxis startswith(find_text, within_text)

Argumentos

Tipo | Nombre | Descripción
cadena | find_text | La cadena a buscar en el inicio
cadena | within_text | La cadena que será comprobada
Resultado
Tipo | Descripción
entero | 1 si find_text se encuentra al inicio de within_text; 0 si no
Nota:

La función startswith se basa en la función match. Añade un carácter ^ adelante de find_text antes de tratar el resultado como una expresión regular [consulte Expresiones regulares].

Ejemplos Para obtener el tipo de tarjeta de crédito utilizada en una transacción, como "Discover", "AmEx", "Visa" o "MasterCard", basándose en los números prefijos de las tarjetas:

case

startswith ("6011", CC_Number): "Discover";

startswith ("4", CC_Number): "Visa";

startswith ("5", CC_Number): "MasterCard";

startswith ("34",CC_Number) o startswith ("37", CC_Number): "AmEx";

default: null;

CC_Number | CC_Type
4111-1111-1111-1111 | Visa
5431-1111-1111-1111 | MasterCard
341-1111-1111-1111 | AmEx
6011-6011-6011-6611 | Discover
También consulte

endswith

find

Tema principal: Funciones para trabajar con cadenas


strlen

Objetivo Obtener el largo de una cadena.

Sintaxis strlen(string)

Argumentos

Tipo | Nombre | Descripción
cadena | string | La cadena cuyo largo debe determinarse
Resultado
Tipo | Descripción
entero | El número de caracteres en string

Ejemplos Derivar un campo de cadena de exactamente cuatro caracteres, rellenando un campo de cadena más corto con ceros adelante:

case

strlen(AccountID) = 1: concat("000", AccountID);

strlen(AccountID) = 2: concat("00", AccountID);

strlen(AccountID) = 3: concat("0", AccountID);

default: AccountID;

AccountID | Account
1 | 0001
22 | 0022
333 | 0333
4444 | 4444
Tema principal: Funciones para trabajar con cadenas


strmember

Objetivo Determinar la pertenencia a un conjunto.

Sintaxis

strmember(x, [image], [image], ...)

Argumentos

Tipo | Nombre | Descripción
cadena | x | El valor que será comprobado
como x | , [image] , ... | Los elementos del conjunto

Resultado

Tipo | Descripción
entero | 1 (true) if x está en el conjunto [image] ; de lo contrario 0 (false)
Nota:
  • Solo puede usar los valores literales de una cadena para la lista de los elementos del conjunto.
  • Los espacios en blanco al final de los valores no son ignorados.
  • Se prefiere la función más general miembro a esta función.

También consulte

División de agregaciones: la cláusula by
Tema principal: Funciones para trabajar con cadenas


substitute

Objetivo Reemplazar una cadena por otra.

Sintaxis substitute(text, old_text, new_text)

Argumentos

Tipo | Nombre | Descripción
cadena | text | La cadena que se debe buscar
cadena | old_text | La cadena que será reemplazada
cadena | new_text | La cadena de reemplazo

Resultado

Tipo | Descripción
cadena | Una copia de la cadena text con new_text que reemplaza cada instancia no superpuesta de old_text
Nota:

La función "substitute" está basada en la función replaceall y trata al old_text como a una expresión regular [consulte Expresiones regulares].

Ejemplos Eliminar espacio en blanco de campo llamado PostalCode:

PostalCode | substitute(PostalCode, "[[:blank:]]", "")
ND 069 | ND069
IN 099 | IN099
UT 0 0 5 | UT005
O R 009 | OR009

También consulte

replacefirst
Tema principal: Funciones para trabajar con cadenas


substr

Objetivo Obtener una subcadena de una cadena.

Sintaxis substr(string, start, end)

Argumentos

Tipo | Nombre | Descripción
cadena | string | La cadena de inicio
entero | start | El primer índice
entero | end | El segundo índice

Resultado

Tipo | Descripción
cadena | La subcadena formada por caracteres desde start hasta end (inclusive) de string, donde los caracteres están numerados comenzando con 0. Los valores de índice positivos van desde el inicio de una cadena y los valores de índice negativos van desde el final de la cadena.

Ejemplos Para seleccionar los primeros dos y los últimos tres caracteres de un campo de PostalCode para obtener el código del estado:

PostalCode | substr(PostalCode, 0, 1) | substr(PostalCode, -3, -1)
MA015 | MA | 015
WA055 | WA | 055
UT005 | UT | 005
MN119 | MN | 119

Para obtener el tipo de tarjeta de crédito utilizada en una transacción, como "Discover", "AmEx", "Visa" o "MasterCard", basándose en los números prefijos de las tarjetas:

case

substr(CC_Number, 0, 3) = "6011": "Discover";

substr(CC_Number, 0, 0) = "4": "Visa";

substr(CC_Number, 0, 0) = "5": "MasterCard";

substr(CC_Number, 0, 1) = "34" o substr(CC_Number, 0, 1) = "37": "AmEx";

default: null;

CC_Number | CC_Type
4111-1111-1111-1111 | Visa
5431-1111-1111-1111 | MasterCard
341-1111-1111-1111 | AmEx
6011-6011-6011-6611 | Discover
Tema principal: Funciones para trabajar con cadenas


tolower

Objetivo Convertir una cadena a texto en minúscula.

Sintaxis tolower(string)

Argumentos

Tipo | Nombre | Descripción
cadena | cadena | Una cadena que debe convertirse

Resultado

Tipo | Descripción
cadena | La cadena obtenida de string reemplazando todas las letras mayúsculas en string por las letras minúsculas correspondientes

Ejemplos tolower("ZYXWV") es igual a "zyxwv"

También consulte

toupper
Tema principal: Funciones para trabajar con cadenas


toupper

Objetivo Convertir una cadena a texto a letra mayúscula.

Sintaxis toupper(string)

Argumentos

Tipo | Nombre | Descripción
cadena | string | Una cadena que debe convertirse

Resultado

Tipo | Descripción
cadena | La cadena obtenida de string reemplazando todas las letras minúsculas en string por las letras mayúsculas correspondientes

Ejemplos toupper ("abcde") es igual a "ABCDE"

También consulte

tolower
Tema principal: Funciones para trabajar con cadenas


trim

Objetivo Eliminar todos los espacios en una cadena excepto los espacios únicos entre palabras.

Sintaxis trim(text)

Argumentos

Tipo | Nombre | Descripción
cadena | text | La cadena que será comparada

Resultado

Tipo | Descripción
cadena | La cadena formada por text eliminar todos los espacios excepto los espacios únicos entre palabras
Nota:

La función "trim" está basada en la función replaceall.

Ejemplos Para derivar un campo que reemplaza múltiples caracteres de espacio en blanco por un único espacio:

CommentField | trim(CommentField)
Artículos defectuosos devueltos | Artículos defectuosos devueltos
Ausencia a una cita | Ausencia a una cita
Ingeniero que visita: Lunes | Ingeniero que visita: Lunes
Resuelto | Resuelto
Tema principal: Funciones para trabajar con cadenas


Rangos

  • boolean
  • DayFrom, WeekFrom, MonthFrom, YearFrom
  • DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom
  • DayMultipleNumBins, WeekMultipleNumBins, MonthMultipleNumBins, YearMultipleNumBins
  • DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost
  • DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo
  • DayMultipleWidth, WeekMultipleWidth, MonthMultipleWidth, YearMultipleWidth
  • DayPrePost, WeekPrePost, MonthPrePost, YearPrePost
  • DayRange, WeekRange, MonthRange, YearRange
  • DayTo, WeekTo, MonthTo, YearTo
  • EqualRange
  • EqualRangeWidth
  • NegativeNonNegative
  • PreDuringPost
  • PrePost
  • Sign
Tema principal: Referencia de Field Derivation Language (FDL)


boolean

Objetivo Valores booleanos de rangos [consulte Datos booleanos].

Parámetros Ninguno

Resultado

Índice de rangos | Valores
1 | false
2 | true
3 | nulo [Consulte El valor null]
4 | sin clasificar
Tema principal: Rangos


DayFrom, WeekFrom, MonthFrom, YearFrom

Objetivo Valores de fecha de rangos en un número específico de períodos (días, meses o años) posteriores a una fecha dada.

Parámetros

Tipo | Nombre | Descripción
fecha | a ("start_date") | El comienzo de la porción periódica de la creación de rangos
entero | n ("num_bins") | El número de períodos (días, semanas, meses o años) en la porción periódica de la creación de rangos.
Resultado
Índice de rangos | Valores
1 | fechas anteriores a "a"; el rango del extremo inferior [consulte Rangos finales]
2, ..., n + 1 | los períodos consecutivos n posteriores a "a"
n + 2 | fechas n períodos anteriores a "a" y posteriores, el rango del extremo superior [consulte Rangos finales]
n + 3 | nulo [Consulte El valor null]
n + 4 | sin clasificar

También consulte

DayRange, WeekRange, MonthRange, YearRange

DayTo, WeekTo, MonthTo, YearTo

Tema principal: Rangos


DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom

Objetivo Valores de fecha de rango en un número específico de períodos después de una fecha dada, donde cada período es un número específico de días, semanas, meses o años.

Parámetros

Tipo | Nombre | Descripción
fecha | a ("start_date") | El comienzo de la porción periódica de la creación de rangos
entero | m ("width") | El número de unidades (días, semanas, meses, o años) en un período
entero | n ("num_bins") | El número de rangos en la porción periódica de la creación de rangos
Resultado
Índice de rangos | Valores
1 | fechas anteriores a "a"; el rango del extremo inferior [consulte Rangos finales]
2, ..., n + 1 | los períodos consecutivos n (cada uno de m unidades) posteriores a "a"
n + 2 | fechas n x m unidades posteriores a "a" y posteriores; el rango del extremo superior [Consulte Rangos finales]
n + 3 | nulo [Consulte El valor null]
n + 4 | sin clasificar

También consulte

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo

Tema principal: Rangos


DayMultipleNumBins, WeekMultipleNumBins, MonthMultipleNumBins, YearMultipleNumBins

Objetivo Valores de fecha de rangos en aproximadamente el número de períodos especificados entre dos fechas dadas, donde el período es un múltiplo fijo de la unidad (día, semana, mes o año).

Parámetros

Tipo | Nombre | Descripción
fecha | a ("start_date") | El comienzo de la porción periódica de la creación de rangos
fecha | b ("end_date") | El final de la porción periódica de la creación de rangos
entero | n ("num_bins") | El número objetivo de períodos (múltiplos de un día, una semana, un mes o un año) en la porción periódica de la creación de rangos.

Resultado

Índice de rangos | Valores
1 | fechas anteriores a "a"; el rango del extremo inferior [consulte Rangos finales]
2, ..., N - 3 | períodos entre a y b
N - 2 | fechas b y posteriores; el rango del extremo superior [consulte Rangos finales]
N - 1 | nulo [Consulte El valor null]
n | sin clasificar
Nota:
  • Estas creaciones de rangos son como la creación de rangos DayRange, WeekRange, MonthRange, and YearRange [consulte DayRange, WeekRange, MonthRange, YearRange] , excepto por el hecho de que un período puede incluir una o más unidades (días, semanas, meses o años) para arrojar aproximadamente el número objetivo de rangos.
  • Cuando un período es de dos o más unidades, el rango N - 3 puede ser más corto que los rangos 2 a N - 4.

También consulte

DayMultipleWidth, WeekMultipleWidth, MonthMultipleWidth, YearMultipleWidth
Tema principal: Rangos


DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

Objetivo Valores de fecha de rango en números específicos de rangos y después de una fecha de referencia dada, donde cada rango es un múltiplo dado de la unidad (día, semana, mes o año).

Parámetros

Tipo | Nombre | Descripción
fecha | a ("ref_date") | La fecha de referencia para la creación de rangos
entero | m ("width") | El número de rangos antes de la fecha de referencia y después de ella
entero | n ("num_bins") | El número de unidades (días, semanas, meses, o años) en cada rango

Resultado

Índice de rangos | Valores
1 | fechas anteriores a n x m unidades antes de "a"; el rango del extremo inferior [consulte Rangos finales]
2, ..., n + 1 | los períodos consecutivos n (cada uno de m unidades) anteriores a "a"
n + 2, ..., 2n + 1 | los períodos consecutivos n (cada uno de m unidades) posteriores a "a"
2n + 2 | fechas n x m unidades posteriores a "a" y posteriores; el rango del extremo superior [Consulte Rangos finales]
2n + 3 | nulo [Consulte El valor null]
2n + 4 | sin clasificar

También consulte

DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom

DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo

DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

PreDuringPost

PrePost

Tema principal: Rangos


DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo

Objetivo Valores de fecha de rango en un número específico de períodos anteriores a una fecha dada, donde cada período es un número específico de días, semanas, meses o años.

Parámetros

Tipo | Nombre | Descripción
fecha | b ("end_date") | El final de la porción periódica de la creación de rangos
entero | m ("width") | El número de unidades (días, semanas, meses, o años) en un período
entero | n ("num_bins") | El número de rangos en la porción periódica de la creación de rangos
Resultado
Índice de rangos | Valores
1 | fechas anteriores a n x m unidades antes de "a"; el rango del extremo inferior [consulte Rangos finales]
2, ..., n + 1 | los períodos consecutivos n (cada uno de m unidades) anteriores a "a"
n + 2 | fechas "a" y posteriores; el rango del extremo superior [consulte Rangos finales]
n + 3 | nulo [Consulte El valor null]
n + 4 | sin clasificar

También consulte

DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

Tema principal: Rangos


DayMultipleWidth, WeekMultipleWidth, MonthMultipleWidth, YearMultipleWidth

Objetivo Valores de fecha de rangos en períodos entre dos fechas dadas, donde el período es un múltiplo específico de la unidad (día, semana, mes o año).

Parámetros

Tipo | Nombre | Descripción
fecha | a ("start_date") | El comienzo de la porción periódica de la creación de rangos
fecha | b ("end_date") | El final de la porción periódica de la creación de rangos
entero | m ("width") | El número de unidades (días, semanas, meses, o años) en un período

Resultado

Índice de rangos | Valores
1 | fechas anteriores a "a"; el rango del extremo inferior [consulte Rangos finales]
2, ..., N - 3 | períodos entre a y b
N - 2 | fechas b y posteriores; el rango del extremo superior [consulte Rangos finales]
N - 1 | nulo [Consulte El valor null]
n | sin clasificar
Nota:
  • Estas creaciones de rangos son como la creación de rangos DayRange, WeekRange, MonthRange, and YearRange [consulte DayRange, WeekRange, MonthRange, YearRange] , excepto por el hecho de que un período puede ser de una o más unidades (días, semanas, meses o años).
  • Cuando un período es de dos o más unidades, el rango N - 3 puede ser más corto que los rangos 2 a N - 4.

También consulte

DayMultipleNumBins, WeekMultipleNumBins, MonthMultipleNumBins, YearMultipleNumBins
Tema principal: Rangos


DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

Objetivo Valores de fecha de rango en números de períodos específicos (días, semanas, meses o años) anteriores a una fecha de referencia dada y posteriores a ella.

Parámetros

Tipo | Nombre | Descripción
fecha | a ("ref_date") | La fecha de referencia para la creación de rangos
entero | m ("before") | El número de períodos (días, semanas, meses o años) para los que deben crearse rangos antes de la fecha de referencia.
entero | n ("after") | El número de períodos para los que deben crearse rangos después de la fecha de referencia.

Resultado

Índice de rangos | Valores
1 | fechas anteriores a períodos m anteriores a "a", el rango del extremo inferior [consulte Rangos finales]
2, ..., m + 1 | los períodos consecutivos m anteriores a "a"
m + 2, ..., m + n + 1 | los períodos consecutivos n posteriores a "a"
m + n + 2 | fechas n períodos anteriores a "a" y posteriores, el rango del extremo superior [consulte Rangos finales]
m + n + 3 | nulo [Consulte El valor null]
m + n + 4 | sin clasificar

También consulte

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

PreDuringPost

PrePost

Tema principal: Rangos


DayRange, WeekRange, MonthRange, YearRange

Objetivo Valores de fechas de rango en períodos (días, semanas, meses o años) entre dos fechas dadas.

Parámetros

Tipo | Nombre | Descripción
fecha | a ("start_date") | El comienzo de la porción periódica de la creación de rangos
fecha | b ("end_date") | El final de la porción periódica de la creación de rangos
Resultado
Índice de rangos | Valores
1 | fechas anteriores a "a"; el rango del extremo inferior [consulte Rangos finales]
2, ..., N - 3 | períodos (días, semanas, meses o años) entre a y b
N - 2 | fechas b y posteriores; el rango del extremo superior [consulte Rangos finales]
N - 1 | nulo [Consulte El valor null]
n | sin clasificar
Nota:
  • Si hay menos de un período completo entre a y b, el rango 2 contiene fechas entre a (incluido) y b (excluido).
  • Si no hay un número exacto de períodos entre a y b (pero hay como mínimo un período completo), el rango que precede inmediatamente a b se alarga para darle lugar al exceso.

También consulte

DayFrom, WeekFrom, MonthFrom, YearFrom

DayTo, WeekTo, MonthTo, YearTo

Tema principal: Rangos


DayTo, WeekTo, MonthTo, YearTo

Objetivo Valores de fecha de rangos en un número específico de períodos (días, meses o años) anteriores a una fecha dada.

Parámetros

Tipo | Nombre | Descripción
fecha | b ("end_date") | El final de la porción periódica de la creación de rangos
entero | n ("num_bins") | El número de períodos (días, semanas, meses o años) en la porción periódica de la creación de rangos.
Resultado
Índice de rangos | Valores
1 | fechas anteriores a n períodos anteriores a b, el rango del extremo inferior [consulte Rangos finales]
2, ..., n + 1 | los períodos consecutivos n anteriores a "b"
n + 2 | fechas b y posteriores; el rango del extremo superior [consulte Rangos finales]
n + 3 | nulo [Consulte El valor null]
n + 4 | sin clasificar

También consulte

DayFrom, WeekFrom, MonthFrom, YearFrom

DayRange, WeekRange, MonthRange, YearRange

Tema principal: Rangos


EqualRange

Objetivo Los valores numéricos de rangos en un número especificado de intervalos de igual ancho.

Parámetros

Tipo | Nombre | Descripción
real | a ("from") | El extremo inferior de la porción de igual rango de la creación de rangos
real | b ("to") | El extremo superior de la porción de igual rango de la creación de rangos
entero | n ("num_bins") | El número de rangos en la porción de igual rango de la creación de rangos

Resultado

Índice de rangos | Valores
1 | ; el rango del extremo inferior [consulte Rangos finales]
2, ..., n + 1 | [a, a + (b - a)/n), ..., [b - (b - a)/n, b)
n + 2 | ; el rango del extremo superior [consulte Rangos finales]
n + 3 | nulo [Consulte El valor null]
n + 4 | sin clasificar

También consulte

EqualRangeWidth
Tema principal: Rangos


EqualRangeWidth

Objetivo Valores numéricos de rangos en intervalos de un ancho específico.

Parámetros

Tipo | Nombre | Descripción
real | a ("from") | El extremo inferior de la porción de igual rango de la creación de rangos
real | b ("to") | El extremo superior de la porción de igual rango de la creación de rangos
real | r ("width") | El ancho de rangos en la porción de igual rango de la creación de rangos

Resultado

Índice de rangos | Valores
1 | ; el rango del extremo inferior [consulte Rangos finales]
2, ..., N - 3 | rangos de igual ancho y ancho aproximado r
N - 2 | el rango del extremo superior [consulte Rangos finales]
N - 1 | nulo [Consulte El valor null]
n | sin clasificar
Nota:

Si a - b no es múltiplo exacto de r, se usa una aproximación de r, de modo que los rangos entre a y b sean del mismo ancho.

También consulte

EqualRange
Tema principal: Rangos


NegativeNonNegative

Objetivo Valores numéricos de rango de acuerdo con el signo, agrupando 0 con los valores positivos.

Parámetros Ninguno

Resultado

Índice de rangos | Valores
1 | ; es decir, valores negativos
2 | ; es decir, valores no negativos
3 | nulo [Consulte El valor null]
4 | sin clasificar

También consulte

Sign
Tema principal: Rangos


PreDuringPost

Objetivo Valores de fecha de rangos en períodos pre-campaña, durante la campaña y post-campaña.

Parámetros

Tipo | Nombre | Descripción
fecha | a ("pre_date") | El comienzo del período de pre-campaña
fecha | b ("campaign_start_date") | El comienzo de la campaña
fecha | c ("campaign_end_date") | El final de la campaña
fecha | d ("post_date") | El final del período post-campaña
Resultado
Índice de rangos | Valores
1 | fechas anteriores a "a"; el rango del extremo inferior [consulte Rangos finales]
2 | Fechas entre a (incluido) y b (excluido)
3 | fechas entre b (incluido) and c (excluido)
4 | fechas entre c (incluido) and d (excluido)
5 | fechas d y posteriores; el rango del extremo superior [consulte Rangos finales]
6 | nulo [Consulte El valor null]
7 | sin clasificar

También consulte

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

PrePost

Tema principal: Rangos


PrePost

Objetivo Valores de fecha de rangos en períodos pre-campaña and post-campaña.

Parámetros

Tipo | Nombre | Descripción
fecha | a ("pre_date") | El comienzo del período de pre-campaña
fecha | b ("campaign_date") | La fecha de la campaña
fecha | c ("post_date") | El final del período post-campaña

Resultado

Índice de rangos | Valores
1 | fechas anteriores a "a"; el rango del extremo inferior [consulte Rangos finales]
2 | Fechas entre a (incluido) y b (excluido)
3 | fechas entre b (incluido) and c (excluido)
4 | fechas c y posteriores; el rango del extremo superior [consulte Rangos finales]
5 | nulo [Consulte El valor null]
6 | sin clasificar

También consulte

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

PreDuringPost

Tema principal: Rangos


Sign

Objetivo Valores numéricos de rango de acuerdo con el signo.

Parámetros Ninguno

Resultado

Índice de rangos | Valores
1 | ; es decir, valores negativos
2 | 0
3 | ; es decir, valores positivos
4 | nulo [Consulte El valor null]
5 | sin clasificar

También consulte

NegativeNonNegative
Tema principal: Rangos


Expresiones regulares de FDL

  • Expresiones regulares
  • Componentes básicos de una expresión regular
  • Operadores de las expresiones regulares
Tema principal: Referencia de Field Derivation Language (FDL)


Expresiones regulares

Las expresiones regulares se utilizan para hacer coincidir patrones en las cadenas [consulte la sección Tipos de datos]. Una expresión regular es una cadena con formato especial que representa un patrón de caracteres. Por ejemplo, la expresión regular "ar{1,2}y\?$" representa "la letra 'a,' seguida por una o dos 'r', posiblemente seguidas por 'y,' seguidas por el final de la secuencia." (Ese patrón ocurre en una cadena como "Harry" y "amar", pero no en "hay" o "amaras").

Una expresión regular consiste en componentes básicos [consulte la sección Componentes básicos de una expresión regular] combinados usando operadores [consulte la sección Operadores de las expresiones regulares].

Si una expresión regular (distinta de una subexpresión) coincide con más de una parte de una cadena, siempre coincidirá con la parte más larga y más a la izquierda. Por ejemplo, la expresión regular "a[^ad]\+" (que representa "la letra 'a', seguida por una o más letras salvo la 'a' o la 'd'") coincide con "adaptationally." La parte que coincide no es "acion," ya que hay otras partes más a la izquierda. Tampoco lo es "ap" porque, aunque no haya más partes a la izquierda, hay una parte más larga que comienza en el mismo carácter.
  • Para buscar una coincidencia de una expresión regular en una cadena, use la función match.
  • Para reemplazar una coincidencia en una cadena con otra cadena, use las funciones replacefirst o replaceall.
Nota:
  • Las expresiones regulares son típicamente (pero no necesariamente) literales, en ese caso, deben figurar entre comillas, por ejemplo, "ar{1,2}y\?$".

  • Miner/FDL usa una expresión regular proporcionada por la biblioteca ICU. Podemos vincularnos con http://userguide.icu-project.org/strings/regexp.

  • Las Expresiones regulares de ICU rigen conforme a la Norma técnica Unicode n.° 18, las Expresiones regulares Unicode, nivel 1 y además incluye límites de Palabras predeterminadas y Propiedades de nombre del nivel 2.

Tema principal: Expresiones regulares de FDL


Componentes básicos de una expresión regular

Los componentes básicos de una expresión regular [consulte la sección Expresiones regulares] son átomos, delimitadores y referencias inversas.

Átomos

Un átomo coincide con uno de un conjunto de caracteres especificados:
Átomo | Carácter con el que coincide
. (cualquier coincidencia) | Cualquier carácter
[...] (lista de coincidencias) | Cualquiera de los caracteres especificados
[^...] (lista sin coincidencias) | Cualquier de los caracteres no especificados
Un carácter diferente de ., ^, $, \, [, ] o * que ocurre fuera de una lista de coincidencias o de una lista sin coincidencias | El carácter
Un carácter diferente de ., ^, $, \, [, ] o * que ocurre fuera de una lista de coincidencias o de una lista sin coincidencias | El carácter

Una lista de coincidencias o una lista sin coincidencias pueden incluir caracteres simples, rango de caracteres y clases de caracteres. No puedes utilizar los rangos o las clases de caracteres fuera de una lista de coincidencias o una lista sin coincidencias.

Un rango de caracteres es un par de caracteres separados por un guión, equivalente a una lista de todos los caracteres en ese rango (dentro del conjunto de caracteres). Por ejemplo, "a-e" es equivalente a "abcde" en una lista de coincidencias.

Una clase de caracteres es uno de los siguientes tokens definidos previamente (donde los corchetes de cierre son adicionales a los que cierran la lista de coincidencias y la lista sin coincidencias):

Token | Coincidencias
[:alnum:] | Un carácter alfanumérico, que puede ser un carácter alfabético o un dígito decimal
[:alpha:] | Un carácter alfabético, es decir, "A" — "Z" y "a" — "z"
[:blank:] | Una ficha o un carácter de espacio
[:cntrl:] | Un carácter de control
[:digit:] | Un dígito decimal, es decir, "0" — "9"
[:graph:] | Un carácter imprimible a parte del espacio
[:lower:] | Una letra en minúscula
[:print:] | Un carácter o espacio imprimible
[:punct:] | Un carácter de puntuación
[:space:] | Un carácter de espacio en blanco
[:upper:] | Un carácter en mayúscula
[:xdigit:] | Un dígito hexadecimal, es decir, "0" — "9," "A" — "F" y "a" — "f"
Nota:
  • Puede incluir una mezcla de caracteres simples, rangos y clases de caracteres en una lista de coincidencias única o en una lista sin coincidencias. Por ejemplo, la lista de coincidencias "[a-ex[:digit:]]" coincide con las letras en minúscula "a" — "e" y "x" y con los dígitos decimales ("0" — "9").
  • Un guión en una lista de coincidencias o una lista sin coincidencias tiene significado propio cuando está (a) al final de un rango, (b) al principio de una lista de coincidencias o una lista sin coincidencias (en este caso también puede estar al principio de un rango), o (c) al final de una lista de coincidencias o una lista sin coincidencias.

Delimitadores

Los caracteres ^ y $ son delimitadores; coinciden con el principio y el final de una cadena respectivamente.

Por ejemplo, para hacer coincidir "The" al principio de una cadena y en ningún otro lugar, se puede usar la expresión regular "^The."

Tema principal: Expresiones regulares de FDL

Referencias inversas

Una referencia inversa es una barra invertida seguida por un solo dígito n (aparte de 0). Coincide con los mismos caracteres que la subexpresión nth encerrada en \(...\).

Por ejemplo, para hacer coincidir "yoyo," "dodo," etc. — pero no "dojo" — se puede utilizar la expresión regular "\(.o\)\1."

Nota:
  • La subexpresión con referencia inversa nth es siempre la subexpresión que comienza con una barra invertida/paréntesis de apertura (aun cuando las subexpresiones están anidadas).
  • La subexpresión vacía "\(\)" se puede utilizar en expresiones regulares que implican alternancia [consulte la sección El operador de alternancia]. For example,

    \(pan\(\)\|pérdida\(\)\)-y-\(agua\2\|ganancia\3\)

    coincide con "pan-y-agua" y "pérdida-y-ganancia," pero no con "pan-y-ganancia" o "pérdida-y-agua."


Operadores de las expresiones regulares

Un operador trabaja en una o dos expresiones regulares [consulte la sección Expresiones regulares] para crear una nueva expresión regular. Los operadores, de mayor a menor prioridad, son los operadores de repetición [consulte la sección Operadores de repetición], el operador de concatenación [consulte la sección El operador de concatenación], y el operador de alternancia [consulte la sección El operador de alternancia].

Si hay igualdad de prioridad, las operaciones se realizan de izquierda a derecha.

Las subexpresiones encerradas en \(...\) siempre se evalúan primero.

Tema principal: Expresiones regulares de FDL

Operadores de repetición

Los operadores de repetición son unarios y están escritos siguiendo un solo operando.

Operator (Operador) | Descripción
* (cero o más) | Si una expresión regular a coincide con una o más partes adyacentes de una cadena, la expresión regular a* coincide con la concatenación de esas partes. También coincide con una subcadena vacía.
\+ (uno o más) | Si una expresión regular a coincide con una o más partes adyacentes de una cadena, la expresión regular a\+ coincide con la concatenación de esas partes.
\{m,n\} (0 [image] m [image] n) | Si una expresión regular coincide al menos con m y con no más de n partes adyacentes de una cadena, la expresión regular a\{m,n\} coincide con la concatenación de esas partes. Si m=0, también coincide con una subcadena vacía.
\? (opcional) | Equivalente a a\{0,1\}, la expresión regular a\? coincide con cualquier subcadena vacía, o cualquier parte de una cadena que coincide con la expresión regular a.
Nota:

Las "partes adyacentes" mencionadas en las definiciones de *, \+, y {...} no son secuencias idénticas necesariamente. Si necesita hacer coincidir repeticiones exactas, use las referencias inversas [consulte la sección Referencias inversas].

El operador de concatenación

El operador de concatenación no está realmente escrito, pero está implícito cuando escribe dos expresiones regulares una al lado de la otra.

Si las expresiones regulares a y b coinciden con las partes adyacentes x e y de una cadena z (con x antes de y), la concatenación de a y b (a seguida por b) coincide con la parte z que contiene x e y.

Nota:

Cualquier secuencia de caracteres no especiales, es decir, caracteres sin significado especial en una expresión regular, funciona como una expresión regular que coincide con esa secuencia, debido al operador de concatenación implícito.

En la práctica, la mayoría de las expresiones regulares están formadas por cadenas de caracteres simples, intercaladas por algunos caracteres especiales. Por ejemplo, la expresión regular "[SsTt]imple" coincide con las cadenas "Simple," "simple," "Timple," y "timple."

El operador de alternancia

El operador de alternancia "\|" es un operador binario, escrito entre sus operandos.

Si cualquiera de las expresiones regulares a y b coinciden con una parte de una cadena, la alternancia a\|b también coincidirá con esa porción.


XML en Portrait Miner

  • XML en Portrait Miner


XML en Portrait Miner

XML se usa en todo Portrait Miner para permitir un fácil intercambio de resultados con otras aplicaciones, de acuerdo con la definición del esquema XML de Portrait Miner,http://www.portraitsoftware.com

Todas las entradas en XML a los comandos de creación de datos de Portrait Miner (y a cualquier función de Portrait Miner que se implemente a través de los comandos de creación de datos de Portrait Miner) se deben ingresar en el espacio de nombre de Portrait Miner, http://support.portraitsoftware.com. La manera más sencilla de garantizarlo es incluir el atributo xmlns=" http://support.portraitsoftware.com " en el elemento de raíz del documento XML.

Los archivos XML creados automáticamente por Portrait Miner incluyen un atributo opcional schemaLocation que indica los esquemas en http://www.portraitsoftware.com/xml/qs7.1. Si utiliza un editor que reconoce los esquemas para crear los archivos XML, podrá acceder a estos esquemas directamente desde Portrait Miner en:

<pmhome>/server/qs7.1/integration/schemas

(<pmhome> es el directorio de instalación de Portrait Miner). También encontrará ejemplos de cómo procesar estos archivos XML en:

<pmhome>/server/qs7.1/etc/xslt

Tema principal: XML en Portrait Miner


Resolución de problemas

  • "¿Por qué no puedo abrir un enfoque?"
  • "¿Por que los ejes de mi gráfico están subdivididos en forma desigual?"
  • "¿Por qué 'Mantener segmentos resaltados' siempre está en gris?"
  • "¿Por qué mi texto se ve diferente a cuando lo escribí?"


"¿Por qué no puedo abrir un enfoque?"

Causa posible | Solución
Ya tiene un enfoque abierto. Decision Studio sólo puede trabajar con un enfoque a la vez. | Antes de poder abrir un enfoque o crear un enfoque nuevo con una tabla de base de datos o archivo plano, debe cerrar el enfoque que tiene abierto actualmente: elija archivo>Cerrar en la ventana de Decision Studio.
Tema principal: Resolución de problemas


"¿Por que los ejes de mi gráfico están subdivididos en forma desigual?"

Causa posible | Solución
Cada eje de un gráfico de distribución cruzada o de perfil está subdividido de acuerdo con el rango primario del campo que corresponde al eje. Si los rangos se muestran con igual ancho, es una propiedad de ese rango. (La excepción es cuando el alcance de un bloque en un directorio dado brinda información: en este caso, la configuración de visualización de Binning Editor no tiene ningún efecto, de manera que no se creen confusiones). | En Binning Editor, seleccione el campo requerido y desactive Ver>Histograma.
Tema principal: Resolución de problemas


"¿Por qué 'Mantener segmentos resaltados' siempre está en gris?"

Causa posible | Solución
Intenta mantener segmentos resaltados en el Visor de Tabla, Visor de Tabulación Cruzada o Creador de scorecards. Cuando una herramienta está unida [consulte la sección Relaciones entre herramientas] a una de estas herramientas, las dos herramientas comparten la misma fuente de datos, independientemente de si alguna parte está resaltada en la herramienta líder. | En lugar de eso, intente resaltar los mismos segmentos en una herramienta de visualización gráfica.
Tema principal: Resolución de problemas


"¿Por qué mi texto se ve diferente a cuando lo escribí?"

Causa posible | Solución
Hay caracteres en su texto que no se pueden traducir al conjunto de caracteres ISO-8859-1 (Latin-1). | Evite el texto que contenga caracteres que no se pueden traducir al conjunto de caracteres ISO-8859-1.
Tema principal: Resolución de problemas


Aviso de derechos de autor

  • Aviso de derechos de autor


Aviso de derechos de autor

Portrait Miner puede contener el siguiente software:

ANTLR

http://www.antlr.org

Apache Batik

Este producto incluye software desarrollado por Apache Software Foundation (http://www.apache.org/).

© 2000 The Apache Software Foundation. Todos los derechos reservados.

La redistribución y el uso tanto del código fuente como de los binarios, con o sin modificación, se permiten siempre que se cumpla con las siguientes condiciones:
  1. Las redistribuciones de código fuente deben conservar el aviso de derechos de autor detallado anteriormente, esta lista de condiciones y la siguiente exención de responsabilidad.
  2. Las redistribuciones de binarios deben reproducir el aviso de derechos de autor anterior, esta lista de condiciones y la siguiente exención de responsabilidad en la documentación u otros materiales que se proporcionen con la distribución.
  3. La documentación para el usuario final incluida con la redistribución, si existiere, debe incluir el siguiente reconocimiento: "Este producto incluye software desarrollado por Apache Software Foundation (http://www.apache.org/)". En forma alternativa, el presente reconocimiento puede aparecer en el software en sí, en el caso de que aparezcan normalmente reconocimientos de terceros de ese tipo y en el lugar donde aparezcan.
  4. Los nombres "Batik" y "Apache Software Foundation" no se deben usar para patrocinar ni promocionar productos derivados del presente software sin previo permiso por escrito. Para obtener permiso escrito, comuníquese con apache@apache.org.
  5. Los productos derivados del presente software no se pueden denominar "Apache", y "Apache" no puede aparecer en su nombre sin previo permiso escrito de Apache Software Foundation.

EL PRESENTE SOFTWARE SE PROPORCIONA "EN EL ESTADO EN QUE SE ENCUENTRA" Y SE RENUNCIA A LA RESPONSABILIDAD POR CUALQUIER GARANTÍA EXPRESA O IMPLÍCITA, ENTRE OTRAS, LAS GARANTÍAS IMPLÍCITAS DE COMERCIABILIDAD O APTITUD PARA UN PROPÓSITO ESPECÍFICO. APACHE SOFTWARE FOUNDATION O SUS CONTRIBUIDORES NO SERÁN RESPONSABLES, EN NINGÚN CASO, POR LOS DAÑOS DIRECTOS, INDIRECTOS, ACCESORIOS, ESPECIALES, PUNITIVOS O EMERGENTES (ENTRE OTROS, LA ADQUISICIÓN DE BIENES O SERVICIOS SUSTITUTOS; PÉRDIDA DE USO, DE DATOS O LUCRO CESANTE; O INTERRUPCIÓN COMERCIAL), INDEPENDIENTEMENTE DE CÓMO SE PRODUJERON Y EN FUNCIÓN DE CUALQUIER PRINCIPIO DE RESPONSABILIDAD, YA SEA CONTRACTUAL, EXTRACONTRACTUAL U OBJETIVA (INCLUSO NEGLIGENCIA O DE OTRO TIPO) QUE SURJA DE CUALQUIER FORMA DEL USO DEL PRESENTE SOFTWARE, INCLUSO SI SE ADVIERTE ACERCA DE LA POSIBILIDAD DE DICHO DAÑO.

El presente software está compuesto por contribuciones voluntarias realizadas por muchos individuos en nombre de Apache Software Foundation. Para obtener más información acerca de Apache Software Foundation, visite http://www.apache.org.

Apriori algorithm implementation (Implementación del algoritmo apriori)

Christian Borgelt, http://www.borgelt.net/apriori.html.

Software abierto redistribuido en virtud de los términos de la GNU Lesser General Public License (Licencia Pública General Menor de GNU).

DOM4J

El proyecto DOM4J, http://www.dom4j.org.
La redistribución y el uso del presente software y la documentación asociada (en adelante, el "Software"), con o sin modificación, se permiten siempre que se cumpla con las siguientes condiciones:
  1. Las redistribuciones de código fuente deben conservar las declaraciones y avisos de derechos de autor. Las redistribuciones también deben contener una copia del presente documento.
  2. Las redistribuciones de binarios deben reproducir el aviso de derechos de autor anterior, esta lista de condiciones y la siguiente exención de responsabilidad en la documentación u otros materiales que se proporcionen con la distribución.
  3. El nombre "DOM4J" no se debe usar para patrocinar ni promocionar productos derivados del presente Software sin previo permiso por escrito de MetaStuff, Ltd. Para obtener permiso escrito, comuníquese con dom4j-info@metastuff.com.
  4. Los productos derivados del presente Software no se pueden denominar "DOM4J", y "DOM4J" no puede aparecer en sus nombres sin previo permiso escrito de MetaStuff, Ltd. DOM4J es una marca comercial registrada de MetaStuff, Ltd.
  5. Se debe otorgar el crédito debido al proyecto DOM4J: http://www.dom4j.org

EL PRESENTE SOFTWARE ES PROPORCIONADO POR METASTUFF, LTD. Y SUS CONTRIBUIDORES "EN EL ESTADO EN QUE SE ENCUENTRA" Y SE RENUNCIA A LA RESPONSABILIDAD POR CUALQUIER GARANTÍA EXPRESA O IMPLÍCITA, ENTRE OTRAS, LAS GARANTÍAS IMPLÍCITAS DE COMERCIABILIDAD O APTITUD PARA UN PROPÓSITO ESPECÍFICO. METASTUFF, LTD. O SUS CONTRIBUIDORES NO SERÁN RESPONSABLES, EN NINGÚN CASO, POR LOS DAÑOS DIRECTOS, INDIRECTOS, ACCESORIOS, ESPECIALES, PUNITIVOS O EMERGENTES (ENTRE OTROS, LA ADQUISICIÓN DE BIENES O SERVICIOS SUSTITUTOS; PÉRDIDA DE USO, DE DATOS O LUCRO CESANTE; O INTERRUPCIÓN COMERCIAL), INDEPENDIENTEMENTE DE CÓMO SE PRODUJERON Y EN FUNCIÓN DE CUALQUIER PRINCIPIO DE RESPONSABILIDAD, YA SEA CONTRACTUAL, EXTRACONTRACTUAL U OBJETIVA (INCLUSO NEGLIGENCIA O DE OTRO TIPO) QUE SURJA DE CUALQUIER FORMA DEL USO DEL PRESENTE SOFTWARE, INCLUSO SI SE ADVIERTE ACERCA DE LA POSIBILIDAD DE DICHO DAÑO.

© 2001 — 2004 MetaStuff, Ltd. Todos los derechos reservados.

fmt

y http://www.cs.princeton.edu/software/cii/} Biblioteca de formateo de cadenas del libro C Interfaces and Implementations, Techniques for Creating Reusable Software (C Interfaces e implementaciones. Técnicas para crear software reusable), de David R. Hanson.

El autor del presente software es David R. Hanson.

© 1994, 1995, 1996, 1997 de David R. Hanson. Todos los derechos reservados.

Por medio del presente documento, se otorga permiso para usar, copiar, modificar y distribuir el presente software con cualquier fin, con sujeción a las disposiciones que se describen a continuación y sin arancel, siempre que el presente aviso completo se incluya en todas las copias de cualquier software que sea o incluya una copia o modificación del presente software y en todas las copias de la documentación respaldatoria para dicho software.

EL PRESENTE SOFTWARE SE PROPORCIONA "EN EL ESTADO EN QUE SE ENCUENTRA", SIN NINGUNA GARANTÍA EXPRESA O IMPLÍCITA. EN PARTICULAR, EL AUTOR NO REALIZA NINGUNA MANIFESTACIÓN NI OTORGA GARANTÍA DE NINGÚN TIPO RESPECTO DE LA COMERCIABILIDAD DEL PRESENTE SOFTWARE O SU APTITUD PARA UN PROPÓSITO ESPECÍFICO.

David Hanson, drh@microsoft.com, http://www.research.microsoft.com/~drh/.

FreeTDS

http://www.freetds.org/.

Software libre redistribuido en virtud del inciso 6b de la GNU Library General Public License (Licencia Pública General de Bibliotecas de GNU).

getopt

El presente producto (Portrait Miner) puede incluir software desarrollado por la Universidad de California, Berkeley y sus contribuidores, con sujeción al siguiente aviso de permiso:
© 1987, 1993, 1994 The Regents of the University of California. Todos los derechos reservados. La redistribución y el uso tanto del código fuente como de los binarios, con o sin modificación, se permiten siempre que se cumpla con las siguientes condiciones:
  1. Las redistribuciones de código fuente deben conservar el aviso de derechos de autor detallado anteriormente, esta lista de condiciones y la siguiente exención de responsabilidad.
  2. Las redistribuciones de binarios deben reproducir el aviso de derechos de autor anterior, esta lista de condiciones y la siguiente exención de responsabilidad en la documentación u otros materiales que se proporcionen con la distribución.
  3. Todos los materiales publicitarios que mencionen características o el uso del presente software deben mostrar el siguiente reconocimiento: El presente producto incluye software desarrollado por la Universidad de California, Berkeley y sus contribuidores.
  4. El nombre de la Universidad y los nombres de sus contribuidores no se pueden usar para patrocinar o promocionar productos derivados el presente software sin permiso específico por escrito.

LOS REGENTES Y CONTRIBUIDORES PROPORCIONAN EL PRESENTE SOFTWARE "EN EL ESTADO EN QUE SE ENCUENTRA" Y SE RENUNCIA A LA RESPONSABILIDAD POR CUALQUIER GARANTÍA EXPRESA O IMPLÍCITA, ENTRE OTRAS, LAS GARANTÍAS IMPLÍCITAS DE COMERCIABILIDAD O APTITUD PARA UN PROPÓSITO ESPECÍFICO. LOS REGENTES Y CONTRIBUIDORES NO SERÁN RESPONSABLES, EN NINGÚN CASO, POR LOS DAÑOS DIRECTOS, INDIRECTOS, ACCESORIOS, ESPECIALES, PUNITIVOS O EMERGENTES (ENTRE OTROS, LA ADQUISICIÓN DE BIENES O SERVICIOS SUSTITUTOS; PÉRDIDA DE USO, DE DATOS O LUCRO CESANTE; O INTERRUPCIÓN COMERCIAL), INDEPENDIENTEMENTE DE CÓMO SE PRODUJERON Y EN FUNCIÓN DE CUALQUIER PRINCIPIO DE RESPONSABILIDAD, YA SEA CONTRACTUAL, EXTRACONTRACTUAL U OBJETIVA (INCLUSO NEGLIGENCIA O DE OTRO TIPO) QUE SURJA DE CUALQUIER FORMA DEL USO DEL PRESENTE SOFTWARE, INCLUSO SI SE ADVIERTE ACERCA DE LA POSIBILIDAD DE DICHO DAÑO.

MemoryClassLoader de OpenEJB.org

La redistribución y el uso del presente software y la documentación asociada (en adelante, el "Software"), con o sin modificación, se permiten siempre que se cumpla con las siguientes condiciones:
  1. Las redistribuciones de código fuente deben conservar las declaraciones y avisos de derechos de autor. Las redistribuciones también deben contener una copia del presente documento.
  2. Las redistribuciones de binarios deben reproducir el aviso de derechos de autor anterior, esta lista de condiciones y la siguiente exención de responsabilidad en la documentación u otros materiales que se proporcionen con la distribución.
  3. El nombre "OpenEJB" no se debe usar para patrocinar ni promocionar productos derivados del presente Software sin previo permiso escrito del Grupo OpenEJB. Para obtener permiso escrito, comuníquese con info@openejb.org.
  4. Los productos derivados del presente Software no se pueden denominar "OpenEJB", y "OpenEJB" no puede aparecer en sus nombres sin previo permiso escrito del Grupo OpenEJB. OpenEJB es una marca comercial registrada del Grupo OpenEJB.
  5. Se debe otorgar el crédito debido al proyecto OpenEJB (http://www.openejb.org/).

EL GRUPO DE OPENEJB Y CONTRIBUIDORES PROPORCIONAN EL PRESENTE SOFTWARE "EN EL ESTADO EN QUE SE ENCUENTRA", Y SE RENUNCIA A LA RESPONSABILIDAD POR CUALQUIER GARANTÍA EXPRESA O IMPLÍCITA, ENTRE OTRAS, LAS GARANTÍAS IMPLÍCITAS DE COMERCIABILIDAD O APTITUD PARA UN PROPÓSITO ESPECÍFICO. EL GRUPO OPENEJB O SUS CONTRIBUIDORES NO SERÁN, EN NINGÚN CASO, RESPONSABLES POR LOS DAÑOS DIRECTOS, INDIRECTOS, ACCESORIOS, ESPECIALES, PUNITIVOS O EMERGENTES (ENTRE OTROS, LA ADQUISICIÓN DE BIENES O SERVICIOS SUSTITUTOS; PÉRDIDA DE USO, DE DATOS O LUCRO CESANTE; O INTERRUPCIÓN COMERCIAL), INDEPENDIENTEMENTE DE CÓMO SE PRODUJERON Y EN FUNCIÓN DE CUALQUIER PRINCIPIO DE RESPONSABILIDAD, YA SEA CONTRACTUAL, EXTRACONTRACTUAL U OBJETIVA (INCLUSO NEGLIGENCIA O DE OTRO TIPO) QUE SURJA DE CUALQUIER FORMA DEL USO DEL PRESENTE SOFTWARE, INCLUSO SI SE ADVIERTE ACERCA DE LA POSIBILIDAD DE DICHO DAÑO.

© 2001 — 2005 The OpenEJB Group. Todos los derechos reservados.

Numerical Recipes

Este producto contiene procedimientos realizados en función de rutinas de Numerical Recipes: The Art of Scientific Computing (Recetas numéricas: el arte de la computación científica), publicado por Cambridge University Press, y se usan con permiso.

pthreads-win32

Una biblioteca de subprocesos POSIX para Windowslong. © 2001 Ross P. Johnson. Todos los derechos reservados.

Software abierto redistribuido en virtud de los términos de la GNU Lesser General Public License (Licencia Pública General Menor de GNU).

RPC/XDR

© 1986, Sun Microsystems, Inc., con sujeción al siguiente aviso de permiso:

Sun RPC es un producto de Sun Microsystems, Inc. y se proporciona para el uso no restringido siempre que la presente leyenda se incluya en todos los medios grabados y como parte del programa de software, en todo o en parte. Los usuarios pueden copiar o modificar Sun RPC sin cargo, pero no están autorizados a otorgarlo bajo licencia ni a distribuirlo a ninguna otra persona, excepto como parte de un producto o programa desarrollado por el usuario.

SUN RPC SE PROPORCIONA "EN EL ESTADO EN QUE SE ENCUENTRA", SIN GARANTÍAS DE NINGÚN TIPO, INCLUSO LAS GARANTÍAS DE DISEÑO, COMERCIABILIDAD Y APTITUD PARA UN PROPÓSITO ESPECÍFICO, O QUE SURJAN DEL TRANSCURSO DE UNA NEGOCIACIÓN, EL USO O LA PRÁCTICA COMERCIAL.

Sun RPC se proporciona sin asistencia técnica y sin ninguna obligación de parte de Sun Microsystems, Inc. de ayudar en su uso, corrección, modificación o mejora.

SUN MICROSYSTEMS, INC. NO TENDRÁ RESPONSABILIDAD ALGUNA RESPECTO DE LA VIOLACIÓN DE DERECHOS DE AUTOR, SECRETOS COMERCIALES O CUALQUIER PATENTE POR PARTE DE SUN RPC O CUALQUIER PARTE DE ESTA EMPRESA.

Sun Microsystems, Inc. no será responsable, en ninguna circunstancia, por cualquier lucro cesante u otros daños especiales, indirectos y emergentes, incluso si se advirtió a Sun que existía la posibilidad de que se produjeran dichos daños.

Sun Microsystems, Inc.

2550 Garcia Avenue

Mountain View, California 94043

Rx

© 1996 Tom Lord, Berkeley, CA USA, excepto porciones de "POSIX Regex Functions" que tienen © 1995 Free Software Foundation, Inc.

Por medio del presente documento, se otorga permiso para usar, copiar, modificar, distribuir y vender el presente software y sus documentos para cualquier fin y sin arancel, siempre que se incluya el aviso de derechos de autor anterior en todas las copias y se incluya tanto el aviso de derechos de autor como el presente aviso de permiso en la documentación de respaldo

Software libre redistribuido en virtud del inciso 6b de la GNU Library General Public License (Licencia Pública General de Bibliotecas de GNU).

Stat/Transfer

© 2003 Circle Systems, Inc.

Trang

Conversor de esquemas de formatos múltiples basado en \rng. © 2002, 2003 Thai Open Source Software Center Ltd. Todos los derechos reservados.
La redistribución y el uso tanto del código fuente como de los binarios, con o sin modificación, se permiten siempre que se cumpla con las siguientes condiciones:
  • Las redistribuciones de código fuente deben conservar el aviso de derechos de autor detallado anteriormente, esta lista de condiciones y la siguiente exención de responsabilidad.
  • Las redistribuciones de binarios deben reproducir el aviso de derechos de autor anterior, esta lista de condiciones y la siguiente exención de responsabilidad en la documentación u otros materiales que se proporcionen con la distribución.
  • El nombre de Thai Open Source Software Center Ltd y los nombres de sus contribuidores no se pueden usar para patrocinar o promocionar productos derivados del presente software sin permiso específico por escrito.

LOS TITULARES DE LOS DERECHOS DE AUTOR Y CONTRIBUIDORES PROPORCIONAN EL PRESENTE SOFTWARE "EN EL ESTADO EN QUE SE ENCUENTRA" Y SE RENUNCIA A LA RESPONSABILIDAD POR CUALQUIER GARANTÍA EXPRESA O IMPLÍCITA, ENTRE OTRAS, LAS GARANTÍAS IMPLÍCITAS DE COMERCIABILIDAD O APTITUD PARA UN PROPÓSITO ESPECÍFICO. LOS REGENTES Y CONTRIBUIDORES NO SERÁN RESPONSABLES, EN NINGÚN CASO, POR LOS DAÑOS DIRECTOS, INDIRECTOS, ACCESORIOS, ESPECIALES, PUNITIVOS O EMERGENTES (ENTRE OTROS, LA ADQUISICIÓN DE BIENES O SERVICIOS SUSTITUTOS; PÉRDIDA DE USO, DE DATOS O LUCRO CESANTE; O INTERRUPCIÓN COMERCIAL), INDEPENDIENTEMENTE DE CÓMO SE PRODUJERON Y EN FUNCIÓN DE CUALQUIER PRINCIPIO DE RESPONSABILIDAD, YA SEA CONTRACTUAL, EXTRACONTRACTUAL U OBJETIVA (INCLUSO NEGLIGENCIA O DE OTRO TIPO) QUE SURJA DE CUALQUIER FORMA DEL USO DEL PRESENTE SOFTWARE, INCLUSO SI SE ADVIERTE ACERCA DE LA POSIBILIDAD DE DICHO DAÑO.

unixODBC

Subsistema ODBC de código abierto y ODBC SDK para Linux, Mac OSX y UNIX. unixODBC, http://www.unixodbc.org/.

Software libre redistribuido en virtud del inciso 6b de la GNU Library General Public License (Licencia Pública General de Bibliotecas de GNU).

Xerces Java Parser

Este producto incluye software desarrollado por Apache Software Foundation (http://www.apache.org/).

© 1999 — 2002 The Apache Software Foundation. Todos los derechos reservados.

La redistribución y el uso tanto del código fuente como de los binarios, con o sin modificación, se permiten siempre que se cumpla con las siguientes condiciones:
  1. Las redistribuciones de código fuente deben conservar el aviso de derechos de autor detallado anteriormente, esta lista de condiciones y la siguiente exención de responsabilidad.
  2. Las redistribuciones de binarios deben reproducir el aviso de derechos de autor anterior, esta lista de condiciones y la siguiente exención de responsabilidad en la documentación u otros materiales que se proporcionen con la distribución.
  3. La documentación para el usuario final incluida con la redistribución, si existiere, debe incluir el siguiente reconocimiento: "Este producto incluye software desarrollado por Apache Software Foundation (http://www.apache.org/)". En forma alternativa, el presente reconocimiento puede aparecer en el software en sí, en el caso de que aparezcan normalmente reconocimientos de terceros de ese tipo y en el lugar donde aparezcan.
  4. Los nombres "Xerces" y "Apache Software Foundation" no se deben usar para patrocinar ni promocionar productos derivados del presente software sin previo permiso por escrito. Para obtener permiso escrito, comuníquese con apache@apache.org.
  5. Los productos derivados del presente software no se pueden denominar "Apache", y "Apache" no puede aparecer en su nombre sin previo permiso escrito de Apache Software Foundation.

EL PRESENTE SOFTWARE SE PROPORCIONA "EN EL ESTADO EN QUE SE ENCUENTRA" Y SE RENUNCIA A LA RESPONSABILIDAD POR CUALQUIER GARANTÍA EXPRESA O IMPLÍCITA, ENTRE OTRAS, LAS GARANTÍAS IMPLÍCITAS DE COMERCIABILIDAD O APTITUD PARA UN PROPÓSITO ESPECÍFICO. APACHE SOFTWARE FOUNDATION O SUS CONTRIBUIDORES NO SERÁN RESPONSABLES, EN NINGÚN CASO, POR LOS DAÑOS DIRECTOS, INDIRECTOS, ACCESORIOS, ESPECIALES, PUNITIVOS O EMERGENTES (ENTRE OTROS, LA ADQUISICIÓN DE BIENES O SERVICIOS SUSTITUTOS; PÉRDIDA DE USO, DE DATOS O LUCRO CESANTE; O INTERRUPCIÓN COMERCIAL), INDEPENDIENTEMENTE DE CÓMO SE PRODUJERON Y EN FUNCIÓN DE CUALQUIER PRINCIPIO DE RESPONSABILIDAD, YA SEA CONTRACTUAL, EXTRACONTRACTUAL U OBJETIVA (INCLUSO NEGLIGENCIA O DE OTRO TIPO) QUE SURJA DE CUALQUIER FORMA DEL USO DEL PRESENTE SOFTWARE, INCLUSO SI SE ADVIERTE ACERCA DE LA POSIBILIDAD DE DICHO DAÑO.

El presente software está compuesto por contribuciones voluntarias realizadas por muchos individuos en nombre de Apache Software Foundation y, originalmente, estaba basado sobre el software © 1999, International Business Machines, Inc., http://www.ibm.com. Para obtener más información acerca de Apache Software Foundation, visite http://www.apache.org.

Xerces Java Parser

© 1995 — 1998 Jean-loup Gailly and Mark Adler.
Tema principal: Aviso de derechos de autor

GNU LIBRARY GENERAL PUBLIC LICENSE (Licencia Pública General de Bibliotecas de GNU)

Versión 2, junio de 1991

© 1991 Free Software Foundation, Inc.

59 Temple Place — Suite 330, Boston, MA 02111-1307, USA

Se permite la copia y distribución de copias literales de este documento, pero no se permite su modificación.

Preámbulo

Las licencias para la mayoría del software están diseñadas para impedirle que lo comparta o modifique. Por el contrario, la Licencia Pública General de GNU tiene la intención de garantizarle la libertad de compartir y modificar software libre, para asegurar que el software sea libre para todos sus usuarios.

La presente Licencia Pública General de Bibliotecas se aplica a parte del software especialmente designado de la Free Software Foundation y a cualquier otra biblioteca si sus autores deciden utilizarla. Usted también puede usarlo para sus bibliotecas.

Cuando hablamos de software libre, estamos refiriéndonos a libertad, no a precio. Nuestras Licencias Públicas Generales están diseñadas para asegurarnos de que tenga la libertad de distribuir copias de software libre (y cobrar por ese servicio si lo desea), de que reciba el código fuente o que pueda conseguirlo si lo desea, de que pueda modificar el software o usar fragmentos de él en nuevos programas libres y de que sepa que puede hacer todas estas cosas.

Para proteger sus derechos, debemos establecer algunas restricciones que prohíban a terceros a negarle estos derechos o pedirle que renuncie a ellos. Estas restricciones se traducen en determinadas obligaciones que lo afectan si distribuye copias de la biblioteca o si la modifica.

Por ejemplo, si distribuye copias de la biblioteca, gratuitamente o por un arancel, debe proporcionar a los destinatarios todos los derechos que le fueron concedidos a usted. Debe asegurarse de que ellos también reciban, o puedan obtener, el código fuente. Si vincula un programa con la biblioteca, debe proporcionar archivos objeto completos a los receptores para que puedan vincularlos nuevamente a la biblioteca, después de modificar la biblioteca y recompilarla. Además, debe mostrarles estos términos para que puedan conocer sus derechos.

Nuestro método para proteger sus derechos tiene dos medidas: 1) ponemos el software bajo derechos de autor y 2) le ofrecemos esta licencia, que le da permiso legal para copiar, distribuir o modificar la biblioteca.

También, para la protección de cada distribuidor, queremos asegurarnos de que todos comprendan que no se proporciona garantía alguna para esta biblioteca libre. Si otra persona modifica la biblioteca y la transmite, queremos que sus receptores sepan que lo que tienen no es la versión original, de forma que cualquier problema introducido por terceros no afecte la reputación de los autores originales.

Por último, cualquier programa libre está constantemente amenazado por patentes sobre el software. Queremos evitar el peligro de que las empresas que redistribuyen software libre obtengan patentes por su cuenta y, así, conviertan el programa en software de propiedad exclusiva. Para evitarlo, hemos dejado en claro que cualquier patente debe ser otorgada bajo licencia para el uso libre de cualquier persona, o no debe ser otorgada.

La mayoría del software de GNU, incluso algunas bibliotecas, están cubiertas por la Licencia Pública General de GNU común, que fue diseñada para programas de utilidad. En cambio, la Licencia Pública General de Bibliotecas de GNU se aplica a determinadas bibliotecas designadas. La presente licencia es bastante diferente a la común; asegúrese de leerla por completo y no suponga que alguna de las partes que contiene es igual a una de la licencia común.

La razón por la cual tenemos una licencia pública separada para algunas bibliotecas es que empañan la distinción que, generalmente, hacemos entre modificar o agregar un programa y simplemente usarlo. Vincular un programa con una biblioteca, sin modificar la biblioteca, en algún sentido, es simplemente usar la biblioteca y se puede comparar con ejecutar un programa de utilidad o de aplicación. No obstante, en un sentido textual y legal, el ejecutable vinculado es un trabajo combinado, un producto derivado de la biblioteca original, y la Licencia Pública General común lo trata como tal.

Dado lo poco claro de esta distinción, el uso de la Licencia Pública General común para bibliotecas no fomentaba en forma eficaz que se compartiera el software, dado que la mayoría de los desarrolladores no usaban las bibliotecas. Llegamos a la conclusión de que condiciones menos rígidas podían fomentar que se compartiera mejor.

Sin embargo, crear vínculos sin restricciones para los programas que no son libres privaría a los usuarios de dichos programas de todos los beneficios obtenidos de la condición de libre de las bibliotecas en sí. La presente Licencia Pública General de Bibliotecas tiene la intención de permitir que los desarrolladores de programas que no son libres usen bibliotecas libres, mientras que se mantiene su libertad como usuario de dichos programas de modificar las bibliotecas gratuitas que se incorporan en ellos. (No hemos determinado cómo lograrlo en cuanto a modificaciones en archivos de cabecera, pero lo hemos logrado en cuanto a modificaciones en las funciones reales de la Biblioteca). Lo que esperamos es que esto dé lugar a un desarrollo más rápido de bibliotecas gratuitas.

A continuación se incluyen los términos y las condiciones exactos para la copia, distribución y modificación. Preste especial atención a la diferencia entre un "trabajo basado en la biblioteca" y "un trabajo que utiliza la biblioteca". Este último incluye código derivado de la biblioteca, mientras que el primero sólo funciona junto con la biblioteca.

Tenga en cuenta que resulta posible que una biblioteca esté cubierta por la Licencia Pública General común en lugar de por esta licencia especial.

TÉRMINOS Y CONDICIONES PARA LA COPIA, DISTRIBUCIÓN Y MODIFICACIÓN

  • 0. Este Acuerdo de licencia se aplica a cualquier biblioteca de software que incluya un aviso colocado por el propietario de los derechos de autor u otra parte autorizada en el que se indique que está permitida su distribución bajo los términos de esta Licencia Pública General para bibliotecas (también llamada, "esta Licencia"). Se hace referencia a cada licenciatario como "usted".

    Una "biblioteca" es un grupo de funciones o datos del software preparado de manera tal que está vinculado convenientemente a programas de aplicaciones (que usan algunas de estas funciones y datos) para crear archivos ejecutables.

    La "Biblioteca", a continuación, hace referencia a cualquier biblioteca de software o trabajo que se haya distribuido conforme a estos términos. Un "trabajo basado en la Biblioteca" es la Biblioteca o cualquier trabajo derivado en conformidad con las leyes de derechos de autor: es decir, un trabajo que incluya la Biblioteca o una parte de ella, ya sea en forma exacta o con modificaciones o traducido directamente a otro idioma. (De ahora en adelante, la traducción se incluye sin limitación en el término "modificación").

    "Código fuente" para un trabajo hace referencia a la forma preferida del trabajo para realizar modificaciones en él. Para una biblioteca, el código fuente completo hace referencia a todo el código fuente de todos los módulos que contiene, además de cualquier archivo de definición de interfaz asociado, más las secuencias de comandos que se utilizan para controlar la compilación e instalación de la biblioteca.

    Las actividades diferentes a copiar, distribuir y modificar no están mencionadas en esta Licencia y están fuera de su alcance. El acto de ejecutar un programa mediante el uso de la Biblioteca no está restringido, y el resultado de este tipo de programas se cubre únicamente si su contenido constituye un trabajo basado en la biblioteca (independiente del uso de la Biblioteca en una herramienta para escribirla). Esto depende de lo que hace la Biblioteca y de lo que hace el programa que usa la Biblioteca.

  • 1. Puede copiar y distribuir copias exactas del código fuente completo de la Biblioteca a medida que las reciba, en cualquier medio, siempre y cuando publique en forma notoria y adecuada en cada copia un aviso de derechos de autor apropiado y renuncia de responsabilidad de garantía; mantenga intactos todos los avisos que hacen referencia a esta Licencia y a la ausencia de garantías; y distribuya una copia de esta Licencia junto con la Biblioteca.

    Puede aplicar un cargo por el acto físico de transferir una copia, y puede, como opción, ofrecer protección de garantía a cambio de un arancel.

  • 2. Puede modificar su copia o copias de la Biblioteca o parte de ella y, por lo tanto, crear una trabajo basado en la Biblioteca, y copiar y distribuir estas modificaciones o el trabajo conforme a los términos de la Sección 1 anterior, siempre y cuando cumpla todas las condiciones siguientes:
    • a) El trabajo modificado debe ser una biblioteca de software en sí mismo.
    • b) Debe hacer que los archivos modificados lleven avisos prominentes que indiquen que los ha modificado y la fecha de tales modificaciones.
    • c) Debe hacer que el trabajo entero cuente con una licencia gratuita para todos los terceros de conformidad con los términos de esta Licencia.
    • d) Si una utilidad en la Biblioteca modificada hace referencia a una función o una tabla de datos que se proporcionará por un programa de aplicaciones que usa esa utilidad (diferente a un argumento pasado al invocar la utilidad), entonces debe esforzarse para garantizar que, en el caso de que una aplicación no proporcione esta función o tabla, la utilidad continuará funcionando y realizará cualquier parte de su objetivo que siga siendo útil. (Por ejemplo, una función de una biblioteca que se utilice para calcular raíces cuadradas tiene un objetivo bien definido independiente de la aplicación. Por lo tanto, la Subsección 2d requiere que cualquier función o tabla proporcionada por una aplicación utilizada por esta función sea opcional: Si la aplicación no la proporciona, la función de raíz cuadrada todavía debe calcular las raíces cuadradas).

    Estos requisitos se aplican al trabajo modificado en su totalidad. Si secciones identificables de ese trabajo no se derivan de la Biblioteca, y se pueden considerar razonablemente como trabajos independientes y separados en sí mismos, esta Licencia y sus términos no se aplican a estas secciones una vez que las distribuya como trabajos separados. No obstante, cuando distribuya las mismas secciones como parte de un todo, como un trabajo basado en la Biblioteca, la distribución del todo debe cumplir con los términos de esta Licencia, cuyos permisos para otros licenciatarios se extiende al todo y, de esta manera, a cada una de las partes independientemente de quién la creó.

    Por lo tanto, esta sección no pretende reclamar derechos ni impugnar sus derechos a un trabajo creado en su totalidad por usted; en cambio, el objetivo es poner en ejercicio el derecho a controlar la distribución de trabajos derivados o colectivos basados en la Biblioteca.

    Además, la simple adición de otro trabajo no basado en la Biblioteca con la Biblioteca (o con un trabajo basado en la Biblioteca) en un volumen de un medio de almacenamiento o distribución no incluye al otro trabajo dentro del alcance de esta Licencia.

  • 3. Tiene la opción de aplicar los términos de la Licencia Pública General común de GNU en lugar de esta Licencia a una copia determinada de la Biblioteca. Para hacerlo, debe modificar todos los avisos que hacen referencia a esta Licencia, de modo que hagan referencia a la Licencia Pública General de GNU común, versión 2, en lugar de a este documento. (Si se ha creado una versión más reciente de la versión 2 de la Licencia Pública General de GNU común, entonces puede especificar esa versión si así lo desea). No realice ninguna otra modificación en estos avisos.

    Una vez realizada esta modificación en una copia determinada, ya no puede revertirse en esa copia y, por lo tanto, la Licencia Pública General de GNU común se aplicará a todas las copias posteriores y trabajos derivados creados a partir de esa copia.

    Esta opción resulta útil cuando quiere copiar parte del código de la Biblioteca en un programa que no es una biblioteca.

  • 4. Puede copiar y distribuir la Biblioteca (o una parte de ella o un derivado de ella, conforme a la Sección 2) en código de objeto o forma ejecutable según los términos de las Secciones 1 y 2 anteriores, siempre que lo acompañe con el código fuente completo legible por máquina correspondiente, que debe distribuirse conforme a los términos de las Secciones 1 y 2 anteriores en un medio utilizado en forma personalizada para el intercambio de software.

    Si la distribución de código de objeto se realiza mediante el ofrecimiento de acceso para copiar desde un lugar designado, el requisito de distribuir el código fuente se satisface mediante el ofrecimiento de acceso equivalente para copiar el código fuente desde el mismo lugar, incluso, a pesar de que los terceros no tienen la obligación de copiarlo.

  • 5. Un programa que no incluye derivados de ninguna parte de la Biblioteca, pero que está designado para que funcione con la Biblioteca mediante su compilación o vinculación a ella, se denomina un "trabajo que usa la Biblioteca". Este tipo de trabajo, por sí mismo, no es un trabajo derivado de la Biblioteca y, por lo tanto, no se incluye dentro del alcance de esta Licencia.

    No obstante, la vinculación de un "trabajo que usa la Biblioteca" con la Biblioteca crea un archivo ejecutable que constituye un derivado de la Biblioteca (dado que incluye partes de ella) en lugar de un "trabajo que usa la biblioteca". El archivo ejecutable está, por tanto, cubierto por esta Licencia. La Sección 6 menciona los términos para la distribución de estos archivos ejecutables.

    Cuando un "trabajo que usa la Biblioteca" usa material de un archivo de encabezado que forma parte de la Biblioteca, el código de objeto para el trabajo puede ser un trabajo derivado de la Biblioteca, incluso, a pesar de que su código fuente no lo sea. Esto resulta especialmente significativo si el trabajo puede vincularse sin la Biblioteca, o si el trabajo por sí mismo es una biblioteca. El umbral para esto no está precisamente definido por las leyes.

    Si este tipo de archivo de objeto utiliza únicamente parámetros numéricos, diseños y permisos de estructura de datos y macros pequeñas y funciones en línea pequeñas (diez líneas o menos de longitud), el uso del archivo de objeto no está restringido, independientemente de si es un trabajo derivado lícito. (Los archivos ejecutables que incluyen este código de objeto más partes de la Biblioteca, aún estarán incluidos en la Sección 6).

    De lo contrario, si el trabajo es un derivado de la Biblioteca, puede distribuir el código de objeto para el trabajo conforme a los términos de la Sección 6. Cualquier archivo ejecutable que incluya ese trabajo también estará incluido en la Sección 6, ya sea que esté vinculado o no directamente con la Biblioteca en sí.

  • 6. Como excepción a las Secciones mencionadas, también puede compilar o vincular un "trabajo que usa la Biblioteca" con la Biblioteca para crear un trabajo que incluya partes de la Biblioteca, y distribuir ese trabajo conforme a los términos que elija, siempre que los términos permitan la modificación del trabajo para el uso propio y tareas de ingeniería inversa del cliente con el fin de depurar estas modificaciones.
    Debe colocar un aviso prominente con cada copia del trabajo que indique que la Biblioteca se utiliza en ella y que la Biblioteca y su uso están cubiertos por esta Licencia. Debe proporcionar una copia de esta Licencia. Si el trabajo durante la ejecución muestra avisos de derechos de autor, debe incluir el aviso de derechos de autor para la Biblioteca entre ellos, así como también referencia que direccione al usuario a la copia de esta Licencia. Además, también debe realizar lo siguiente:
    • a) Acompañar el trabajo con el código fuente completo legible por máquina correspondiente para la Biblioteca, incluidos los cambios utilizados en el trabajo (que debe distribuirse conforme a las Secciones 1 y 2 anteriores); y, si el trabajo es un archivo ejecutable vinculado con la Biblioteca, con el "trabajo que usa la Biblioteca" completo legible por máquina, como código de objeto o código fuente, de modo que el usuario pueda modificar la Biblioteca y crear un nuevo vínculo para generar un archivo ejecutable modificado que incluya la Biblioteca modificada. (Se entiende que el usuario que modifica el contenido de archivos de definiciones en la Biblioteca no necesariamente podrá recompilar la aplicación para utilizar las definiciones modificadas).
    • b) Acompañar el trabajo con una oferta escrita, válida durante un mínimo de tres años, que proporcione al mismo usuario los materiales especificados en la Subsección 6a, arriba, por un cargo que no exceda el costo de esta distribución.
    • c) Si la distribución del trabajo se realiza mediante el ofrecimiento de acceso para copiar desde un lugar designado, ofrecer acceso equivalente para copiar los materiales especificados anteriormente desde el mismo lugar.
    • d) Verificar que el usuario ya haya recibido una copia de estos materiales o que se haya enviado a este usuario una copia.

    Para un archivo ejecutable, la forma requerida del "trabajo que usa la Biblioteca" debe incluir datos y programas de utilidades necesarios para la reproducción del ejecutable a partir de él. No obstante, como excepción especial, el código fuente distribuido no necesita incluir cualquier cosa que normalmente se distribuya (en forma de fuente o binaria) con los principales componentes (compilador, kernel, etc.) del sistema operativo en el que se ejecuta el archivo ejecutable, a menos que el componente en sí acompañe al archivo.

    Puede suceder que este requisito contradiga las restricciones de la licencia de otras bibliotecas de propiedad que, normalmente, no acompañan al sistema operativo. Esta contradicción significa que no puede usar ambas y la Biblioteca en un archivo ejecutable que distribuya.

  • 7. Puede colocar utilidades de bibliotecas que constituyan un trabajo basado en la Biblioteca juntas en una única biblioteca con otras utilidades de bibliotecas no cubiertas por esta Licencia, y distribuir esta biblioteca combinada, siempre que la distribución separada del trabajo basado en la Biblioteca y la de las utilidades de otra biblioteca esté permitida y que lleve a cabo las siguientes dos acciones:
    • a) Acompañar la biblioteca combinada con una copia del mismo trabajo basado en la Biblioteca, sin combinar con utilidades de otra biblioteca. Se debe distribuir conforme a los términos de las Secciones anteriores.
    • b) Proporcionar un aviso prominente con la biblioteca combinada que indique que parte de ella es un trabajo basado en la Biblioteca, y en donde se explique dónde buscar la forma sin combinar acompañante del mismo trabajo.
  • 8. No puede copiar, modificar, sublicenciar, vincular con o distribuir la Biblioteca, excepto en los casos que se expresan en esta Licencia. Cualquier intento de copiar, modificar, sublicenciar, vincular con o distribuir la Biblioteca de otra forma es nulo, y terminará en forma automática los derechos otorgados mediante esta Licencia. Sin embargo, las licencias de las partes que recibieron copias o derechos de usted conforme a esta Licencia no serán revocadas, siempre y cuando continúen demostrando un cumplimiento estricto.
  • 9. No es necesario que acepte esta Licencia, dado que no la ha firmado. No obstante, ningún otro elemento le otorga permiso para modificar o distribuir la Biblioteca o sus trabajos derivados. En el caso de que no acepte esta Licencia, estas acciones están prohibidas por ley. Por lo tanto, al modificar o distribuir la Biblioteca (o cualquier trabajo basado en la Biblioteca), está indicando su aceptación de la Licencia para hacerlo, y todos sus términos y condiciones para copiar, distribuir o modificar la Biblioteca o trabajos basados en ella.
  • 10. Siempre que redistribuya la Biblioteca (o cualquier trabajo basado en la Biblioteca), el destinatario recibe automáticamente una licencia del licenciante original para copiar, distribuir, vincular con o modificar la Biblioteca, sujeto a estos términos y condiciones. No puede imponer restricciones adicionales sobre el ejercicio de los derechos otorgados en el presente documento a los destinatarios. Usted no es responsable de exigir el cumplimiento de esta Licencia a terceros.
  • 11. Si, como consecuencia de un orden judicial o acusación de violación de patentes, o por cualquier otro motivo (sin limitación a problemas de patentes), se le imponen condiciones (mediante orden judicial, acuerdo o de otra forma) que contradicen las condiciones de esta Licencia, no lo exoneran de las condiciones incluidas en esta Licencia. Si no puede realizar la distribución de forma tal que cumpla en forma simultánea sus obligaciones conforme a esta Licencia y cualquier otra obligación pertinente, no podrá, en consecuencia, distribuir la Biblioteca en absoluto. Por ejemplo, si la licencia de una patente no permite la redistribución libre de regalías de la Biblioteca por todos aquellos que reciben copias directamente o indirectamente a través de usted, entonces la única forma en que puede cumplir con esto y con esta Licencia sería evitando en su totalidad la distribución de la Biblioteca.

    Si cualquier parte de esta sección se considera no válida o sin efecto de acuerdo con una circunstancia en particular, se aplicará el resto de la sección, y la sección completa se aplicará en otras circunstancias.

    El objetivo de esta sección no es inducirlo al incumplimiento de patentes o cualquier otro reclamo de derechos de propiedad ni impugnar la validez de estos reclamos; está sección se proporciona con el único fin de proteger la integridad del sistema de distribución de software gratuito que se implementa mediante las prácticas de licencias públicas. Muchas personas han contribuido en gran medida a la amplia variedad de software distribuido a través de ese sistema en función de su aplicación constante; es decisión del autor/donante si está dispuesto a distribuir software a través de cualquier otro sistema, y el licenciatario no puede imponer esa decisión.

    Esta sección pretende dejar en claro lo que se considera como una consecuencia del resto de esta Licencia.

  • 12. Si la distribución y/o el uso de la Biblioteca está limitado en determinados países por patentes o interfaces con derechos de autor, el propietario del derecho de autor original que coloca la Biblioteca conforme a esta Licencia puede agregar una limitación de distribución geográfica explícita que excluya a estos países, de modo que se permita esa distribución únicamente en o entre países no excluidos. En este caso, esta Licencia incorpora la limitación como si se escribiera en el cuerpo de esta Licencia.
  • 13. La Free Software Foundation puede publicar versiones revisadas o nuevas de la Licencia Pública General para bibliotecas ocasionalmente. Estas versiones nuevas serán de intención similar a la versión actual, pero pueden diferir en detalles con el fin de abordar nuevos problemas o inquietudes.

    Cada versión recibe un número de versión diferente. Si la Biblioteca especifica un número de versión de esta Licencia que se aplica a ella y a "cualquier versión posterior", tiene la opción de cumplir los términos y condiciones de esa versión o de cualquier versión posterior publicada por la Free Software Foundation. Si la Biblioteca no especifica un número de versión de licencia, puede elegir una versión cualquiera publicada por la Free Software Foundation.

  • 14. Si desea incorporar partes de la Biblioteca a otros programas gratuitos cuyas condiciones de distribución no son compatibles con estas, comuníquese con el autor para solicitar su permiso. Para el software protegido por derechos de autor de la Free Software Foundation, comuníquese con la Free Software Foundation; algunas veces hacemos excepciones. Nuestra decisión estará basada en dos objetivos: preservar el estado gratuito de todos los derivados de nuestro software gratuito y promover el uso compartido y reutilización del software en general.

    SIN GARANTÍAS

  • 15. DADO QUE LA LICENCIA PARA LA BIBLIOTECA SE OTORGA DE FORMA GRATUITA, NO SE PROPORCIONAN GARANTÍAS PARA LA BIBLIOTECA EN LA MEDIDA PERMITIDA POR LAS LEYES APLICABLES. EXCEPTO QUE SE MANIFIESTE LO CONTRARIO POR ESCRITO, LOS PROPIETARIOS DE DERECHOS DE AUTOR U OTRAS PARTES PROPORCIONAN LA BIBLIOTECA "EN EL ESTADO EN EL QUE SE ENCUENTRA", SIN GARANTÍAS DE NINGÚN TIPO, EXPLÍCITA O IMPLÍCITA, INCLUIDAS, ENTRE OTRAS, GARANTÍAS DE COMERCIABILIDAD E IDONEIDAD PARA UN FIN EN PARTICULAR. USTED ASUME TODOS LOS RIESGOS RELACIONADOS CON LA CALIDAD Y EL RENDIMIENTO DE LA BIBLIOTECA. EN EL CASO DE PROBAR QUE UNA BIBLIOTECA CONTIENE DEFECTOS, USTED ES RESPONSABLE DEL COSTO DE TODAS LAS TAREAS DE SERVICIO, REPARACIÓN O CORRECCIÓN NECESARIAS.
  • 16. EN NINGÚN CASO, A MENOS QUE LO REQUIERAN LAS LEYES APLICABLES O SE ACUERDE POR ESCRITO, UN PROPIETARIO DE DERECHOS DE AUTOR, O CUALQUIER OTRA PARTE QUE PUEDA MODIFICAR O REDISTRIBUIR LA BIBLIOTECA SEGÚN LO PERMITIDO ANTERIORMENTE, SERÁ RESPONSABLE ANTE USTED POR DAÑOS, INCLUIDOS DAÑOS GENERALES, ESPECIALES, INCIDENTALES O CONSECUENTES QUE SURJAN A PARTIR DEL USO O LA INCAPACIDAD PARA USAR LA BIBLIOTECA (INCLUIDA, ENTRE OTROS, LA PÉRDIDA DE DATOS O DATOS IMPRECISOS, O LAS PÉRDIDAS SOSTENIDAS POR USTED U OTROS, ASÍ COMO TAMBIÉN LA IMPOSIBILIDAD DE LA BIBLIOTECA DE FUNCIONAR CON OTRO SOFTWARE), INCLUSO, SI ESTE PROPIETARIO O TERCERO HA SIDO ADVERTIDO DE LA POSIBILIDAD DE ESTOS DAÑOS.
FIN DE TÉRMINOS Y CONDICIONES

Cómo aplicar estos términos a sus nuevas bibliotecas

Si crea una nueva biblioteca y desea que pueda utilizarse en la mayor medida posible por el público, le recomendamos que la cree como software gratuito que todos puedan redistribuir y cambiar. También puede hacerlo al permitir la redistribución conforme a estos términos (o bien, como opción, conforme a los términos de la Licencia Pública General común).

Para aplicar estos términos, anexe los siguientes avisos a la biblioteca. Es recomendable anexarlos al comienzo de cada archivo de origen para transmitir en forma más eficaz la exclusión de garantías; y cada archivo debe tener como mínimo la línea "derecho de autor" y un puntero al lugar en el que se encuentra el aviso completo.

    one line to give the library's name and an idea of what it does.
    Copyright (C) year name of author

    This library is free software; you can redistribute it and/or
    modify it under the terms of the GNU Library General Public
    License as published by the Free Software Foundation; either
    version 2 of the License, or (at your option) any later version.

    This library is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
    Library General Public License for more details.

    You should have received a copy of the GNU Library General Public
    License along with this library; if not, write to the
    Free Software Foundation, Inc., 59 Temple Place - Suite 330,
    Boston, MA  02111-1307, USA.

Además, agregue información sobre cómo comunicarse con usted mediante correo electrónico o correo postal.

También debe solicitar a su empleador (si trabaja como programador) o a su escuela, si corresponde, que firme una "renuncia de derechos de autor" para la biblioteca, de ser necesario. A continuación se incluye un ejemplo; modifique los nombres:
    Yoyodyne, Inc., hereby disclaims all copyright interest in
    the library 'Frob' (a library for tweaking knobs) written
    by James Random Hacker.

    signature of Ty Coon, 1 April 1990
    Ty Coon, President of Vice
¡Eso es todo!

LICENCIA PÚBLICA GENERAL DE GNU MENOR

Versión 2.1, Febrero de 1999

Copyright © 1991, 1999 Free Software Foundation, Inc.

59 Temple Place, Suite 330, Boston, MA 02111-1307 Estados Unidos

Se permite la copia y distribución de copias literales de este documento, pero no se permite su modificación.

Preámbulo

Las licencias para la mayoría del software están diseñadas para impedirle que lo comparta o modifique. Por el contrario, la Licencia Pública General de GNU tiene la intención de garantizarle la libertad de compartir y modificar software libre, para asegurar que el software sea libre para todos sus usuarios.

Esta licencia, la Licencia Pública General Menor, se aplica a algunos paquetes de software especialmente designados (comúnmente bibliotecas) de Free Software Foundation y otros autores que decidan utilizarlos. También usted puede utilizarlo, pero le sugerimos que primero considere detenidamente si esta licencia o la Licencia Pública general común es la mejor estrategia para implementar en un caso en particular, en función de las explicaciones que encontrará a continuación.

Cuando hacemos referencia a software gratuito, queremos decir libertad de uso, no precio. Nuestras Licencias Públicas Generales están diseñadas para garantizar que tenga la libertad para distribuir copias del software gratuito (y aplicar un cargo por este servicio si lo desea); que reciba el código fuente o pueda obtenerlo si lo desea; que pueda cambiar el software y usar parte de él en nuevos programas gratuitos; y que reciba información sobre la posibilidad que existe para hacer esto.

Para proteger sus derechos, necesitamos imponer restricciones que prohíban a los distribuidores denegarle estos derechos o solicitarle que renuncie a estos derechos. Estas restricciones se traducen en determinadas responsabilidades que usted debe asumir si distribuye copias de la biblioteca o si la modifica.

Por ejemplo, si distribuye copias de la biblioteca, gratuitamente o por un arancel, debe proporcionar a los destinatarios todos los derechos que le fueron concedidos a usted. Debe asegurarse de que ellos también reciban, o puedan obtener, el código fuente. Si vincula otro código con la biblioteca, debe proporcionar los archivos de objeto completos a los destinatarios, de modo que ellos puedan crear un nuevo vínculo con la biblioteca tras realizar modificaciones en ella y recompilarla. Además, debe mostrarles estos términos para que puedan conocer sus derechos.

Protegemos sus derechos mediante un método de dos pasos: (1) aplicamos derechos de autor sobre la biblioteca y (2) le ofrecemos esta licencia, que le otorga permiso legal para copiar, distribuir o modificar la biblioteca.

Para proteger a cada distribuidor, queremos dejar en claro que no hay garantías sobre la biblioteca gratuita. Además, si la biblioteca otra persona modifica la biblioteca y la comparte, los destinatarios deben saber que lo que recibieron no es la versión original. De esta forma, la reputación del autor original no se verá afectada por problemas que puedan haber sido introducidos por otras personas.

Finalmente, las patentes de software constituyen una amenaza constante para la existencia de cualquier programa gratuito. Queremos garantizar que una compañía no pueda restringir en forma eficaz a los usuarios de un programa gratuito mediante la obtención de una licencia restrictiva del propietario de una patente. En consecuencia, insistimos en que la licencia de cualquier patente obtenida para una versión de la biblioteca debe ser coherente con la libertad completa de uso especificada en esta licencia.

La mayoría del software de GNU, incluidas algunas bibliotecas, está cubierto por la Licencia Pública General común de GNU. Esta licencia, la Licencia Pública General Menor de GNU, se aplica a bibliotecas designadas y es algo diferente de la Licencia Pública General común. Utilizamos esta licencia para determinadas bibliotecas con el fin de permitir su vinculación con programas no gratuitos.

Cuando se vincula un programa con una biblioteca, en forma estática o a través del uso de una biblioteca compartida, la combinación de los dos es, en términos legales, un trabajo combinado, derivado de la biblioteca original. La Licencia Pública General común permite por tanto esta vinculación solamente si la combinación en su totalidad cumple con sus criterios de libertad. La Licencia Pública General Menor permite criterios menos estrictos para la vinculación de otro código con la biblioteca.

Llamamos a esta licencia la Licencia Pública General "Menor", dado que proporciona "menos" protecciones a la libertad del usuario que la Licencia Pública General común. También proporciona a otros desarrolladores de software gratuito "menos" ventajas sobre los programas no gratuitos de la competencia. Estas desventajas son el motivo por el que utilizamos la Licencia Pública General común para muchas bibliotecas. No obstante, la licencia Menor ofrece ventajas en determinadas circunstancias.

Por ejemplo, en raras ocasiones, probablemente haya una necesidad especial de alentar el mayor uso posible de una determinada biblioteca, de modo que se convierta en un estándar de hecho. Para lograr esto, se debe permitir que los programas no gratuitos usen la biblioteca. Un caso más frecuente es aquél en el que una biblioteca gratuita funciona de la misma forma que las bibliotecas no gratuitas de uso frecuente. En este caso, no hay demasiadas ventajas en limitar la biblioteca gratuita al software gratuito únicamente, de modo que usamos la Licencia Pública General Menor.

En otros casos, el permiso para usar una biblioteca particular en programas no gratuitos permite que una mayor cantidad de personas usen una amplia variedad de software gratuito. Por ejemplo, el permiso para usar la Biblioteca C de GNU en programas no gratuitos permite que muchas más personas usen el sistema operativo completo de GNU, así como también su variante, el sistema operativo Linux/GNU.

Si bien la Licencia Pública General Menor incluye menos protecciones para la libertad del usuario, garantiza que el usuario de un programa vinculado con la Biblioteca tenga la libertad y los recursos para ejecutar ese programa mediante el uso de una versión modificada de la Biblioteca.

A continuación se incluyen los términos y las condiciones exactos para la copia, distribución y modificación. Preste especial atención a la diferencia entre un "trabajo basado en la biblioteca" y "un trabajo que utiliza la biblioteca". El primero incluye código derivado de la biblioteca, mientras que el último debe combinarse con la biblioteca para ejecutarse.

TÉRMINOS Y CONDICIONES PARA LA COPIA, DISTRIBUCIÓN Y MODIFICACIÓN

  • 0. Este Acuerdo de licencia se aplica a cualquier biblioteca de software u otro programa que incluya un aviso colocado por el propietario de los derechos de autor u otra parte autorizada, en el que se indique que está permitida su distribución bajo los términos de esta Licencia Pública General Menor (también llamada, "esta Licencia"). Se hace referencia a cada licenciatario como "usted".

    Una "biblioteca" es un grupo de funciones o datos del software preparado de manera tal que está vinculado convenientemente a programas de aplicaciones (que usan algunas de estas funciones y datos) para crear archivos ejecutables.

    La "Biblioteca", a continuación, hace referencia a cualquier biblioteca de software o trabajo que se haya distribuido conforme a estos términos. Un "trabajo basado en la Biblioteca" es la Biblioteca o cualquier trabajo derivado en conformidad con las leyes de derechos de autor: es decir, un trabajo que incluya la Biblioteca o una parte de ella, ya sea en forma exacta o con modificaciones o traducido directamente a otro idioma. (De ahora en adelante, la traducción se incluye sin limitación en el término "modificación").

    "Código fuente" para un trabajo hace referencia a la forma preferida del trabajo para realizar modificaciones en él. Para una biblioteca, el código fuente completo hace referencia a todo el código fuente de todos los módulos que contiene, además de cualquier archivo de definición de interfaz asociado, más las secuencias de comandos que se utilizan para controlar la compilación e instalación de la biblioteca.

    Las actividades diferentes a copiar, distribuir y modificar no están mencionadas en esta Licencia y están fuera de su alcance. El acto de ejecutar un programa mediante el uso de la Biblioteca no está restringido, y el resultado de este tipo de programas se cubre únicamente si su contenido constituye un trabajo basado en la biblioteca (independiente del uso de la Biblioteca en una herramienta para escribirla). Esto depende de lo que hace la Biblioteca y de lo que hace el programa que usa la Biblioteca.

  • 1. Puede copiar y distribuir copias exactas del código fuente completo de la Biblioteca a medida que las reciba, en cualquier medio, siempre y cuando publique en forma notoria y adecuada en cada copia un aviso de derechos de autor apropiado y renuncia de responsabilidad de garantía; mantenga intactos todos los avisos que hacen referencia a esta Licencia y a la ausencia de garantías; y distribuya una copia de esta Licencia junto con la Biblioteca.

    Puede aplicar un cargo por el acto físico de transferir una copia, y puede, como opción, ofrecer protección de garantía a cambio de un arancel.

  • 2. Puede modificar su copia o copias de la Biblioteca o parte de ella y, por lo tanto, crear una trabajo basado en la Biblioteca, y copiar y distribuir estas modificaciones o el trabajo conforme a los términos de la Sección 1 anterior, siempre y cuando cumpla todas las condiciones siguientes:
    • a) El trabajo modificado debe ser una biblioteca de software en sí mismo.
    • b) Debe hacer que los archivos modificados lleven avisos prominentes que indiquen que los ha modificado y la fecha de tales modificaciones.
    • c) Debe hacer que el trabajo entero cuente con una licencia gratuita para todos los terceros de conformidad con los términos de esta Licencia.
    • d) Si una utilidad en la Biblioteca modificada hace referencia a una función o una tabla de datos que se proporcionará por un programa de aplicaciones que usa esa utilidad (diferente a un argumento pasado al invocar la utilidad), entonces debe esforzarse para garantizar que, en el caso de que una aplicación no proporcione esta función o tabla, la utilidad continuará funcionando y realizará cualquier parte de su objetivo que siga siendo útil. (Por ejemplo, una función de una biblioteca que se utilice para calcular raíces cuadradas tiene un objetivo bien definido independiente de la aplicación. Por lo tanto, la Subsección 2d requiere que cualquier función o tabla proporcionada por una aplicación utilizada por esta función sea opcional: Si la aplicación no la proporciona, la función de raíz cuadrada todavía debe calcular las raíces cuadradas).

    Estos requisitos se aplican al trabajo modificado en su totalidad. Si secciones identificables de ese trabajo no se derivan de la Biblioteca, y se pueden considerar razonablemente como trabajos independientes y separados en sí mismos, esta Licencia y sus términos no se aplican a estas secciones una vez que las distribuya como trabajos separados. No obstante, cuando distribuya las mismas secciones como parte de un todo, como un trabajo basado en la Biblioteca, la distribución del todo debe cumplir con los términos de esta Licencia, cuyos permisos para otros licenciatarios se extiende al todo y, de esta manera, a cada una de las partes independientemente de quién la creó.

    Por lo tanto, esta sección no pretende reclamar derechos ni impugnar sus derechos a un trabajo creado en su totalidad por usted; en cambio, el objetivo es poner en ejercicio el derecho a controlar la distribución de trabajos derivados o colectivos basados en la Biblioteca.

    Además, la simple adición de otro trabajo no basado en la Biblioteca con la Biblioteca (o con un trabajo basado en la Biblioteca) en un volumen de un medio de almacenamiento o distribución no incluye al otro trabajo dentro del alcance de esta Licencia.

  • 3. Tiene la opción de aplicar los términos de la Licencia Pública General común de GNU en lugar de esta Licencia a una copia determinada de la Biblioteca. Para hacerlo, debe modificar todos los avisos que hacen referencia a esta Licencia, de modo que hagan referencia a la Licencia Pública General de GNU común, versión 2, en lugar de a este documento. (Si se ha creado una versión más reciente de la versión 2 de la Licencia Pública General de GNU común, entonces puede especificar esa versión si así lo desea). No realice ninguna otra modificación en estos avisos.

    Una vez realizada esta modificación en una copia determinada, ya no puede revertirse en esa copia y, por lo tanto, la Licencia Pública General de GNU común se aplicará a todas las copias posteriores y trabajos derivados creados a partir de esa copia.

    Esta opción resulta útil cuando quiere copiar parte del código de la Biblioteca en un programa que no es una biblioteca.

  • 4. Puede copiar y distribuir la Biblioteca (o una parte de ella o un derivado de ella, conforme a la Sección 2) en código de objeto o forma ejecutable según los términos de las Secciones 1 y 2 anteriores, siempre que lo acompañe con el código fuente completo legible por máquina correspondiente, que debe distribuirse conforme a los términos de las Secciones 1 y 2 anteriores en un medio utilizado en forma personalizada para el intercambio de software.

    Si la distribución de código de objeto se realiza mediante el ofrecimiento de acceso para copiar desde un lugar designado, el requisito de distribuir el código fuente se satisface mediante el ofrecimiento de acceso equivalente para copiar el código fuente desde el mismo lugar, incluso, a pesar de que los terceros no tienen la obligación de copiarlo.

  • 5. Un programa que no incluye derivados de ninguna parte de la Biblioteca, pero que está designado para que funcione con la Biblioteca mediante su compilación o vinculación a ella, se denomina un "trabajo que usa la Biblioteca". Este tipo de trabajo, por sí mismo, no es un trabajo derivado de la Biblioteca y, por lo tanto, no se incluye dentro del alcance de esta Licencia.

    No obstante, la vinculación de un "trabajo que usa la Biblioteca" con la Biblioteca crea un archivo ejecutable que constituye un derivado de la Biblioteca (dado que incluye partes de ella) en lugar de un "trabajo que usa la biblioteca". El archivo ejecutable está, por tanto, cubierto por esta Licencia. La Sección 6 menciona los términos para la distribución de estos archivos ejecutables.

    Cuando un "trabajo que usa la Biblioteca" usa material de un archivo de encabezado que forma parte de la Biblioteca, el código de objeto para el trabajo puede ser un trabajo derivado de la Biblioteca, incluso, a pesar de que su código fuente no lo sea. Esto resulta especialmente significativo si el trabajo puede vincularse sin la Biblioteca, o si el trabajo por sí mismo es una biblioteca. El umbral para esto no está precisamente definido por las leyes.

    Si este tipo de archivo de objeto utiliza únicamente parámetros numéricos, diseños y permisos de estructura de datos y macros pequeñas y funciones en línea pequeñas (diez líneas o menos de longitud), el uso del archivo de objeto no está restringido, independientemente de si es un trabajo derivado lícito. (Los archivos ejecutables que incluyen este código de objeto más partes de la Biblioteca, aún estarán incluidos en la Sección 6).

    De lo contrario, si el trabajo es un derivado de la Biblioteca, puede distribuir el código de objeto para el trabajo conforme a los términos de la Sección 6. Cualquier archivo ejecutable que incluya ese trabajo también estará incluido en la Sección 6, ya sea que esté vinculado o no directamente con la Biblioteca en sí.

  • 6. Como excepción a las Secciones mencionadas, también puede compilar o vincular un "trabajo que usa la Biblioteca" con la Biblioteca para crear un trabajo que incluya partes de la Biblioteca, y distribuir ese trabajo conforme a los términos que elija, siempre que los términos permitan la modificación del trabajo para uso propio y tareas de ingeniería inversa del cliente con el fin de depurar estas modificaciones.
    Debe colocar un aviso prominente con cada copia del trabajo que indique que la Biblioteca se utiliza en ella y que la Biblioteca y su uso están cubiertos por esta Licencia. Debe proporcionar una copia de esta Licencia. Si el trabajo durante la ejecución muestra avisos de derechos de autor, debe incluir el aviso de derechos de autor para la Biblioteca entre ellos, así como también referencia que direccione al usuario a la copia de esta Licencia. Además, también debe realizar lo siguiente:
    • a) Acompañar el trabajo con el código fuente completo legible por máquina correspondiente para la Biblioteca, incluidos los cambios utilizados en el trabajo (que debe distribuirse conforme a las Secciones 1 y 2 anteriores); y, si el trabajo es un archivo ejecutable vinculado con la Biblioteca, con el "trabajo que usa la Biblioteca" completo legible por máquina, como código de objeto o código fuente, de modo que el usuario pueda modificar la Biblioteca y crear un nuevo vínculo para generar un archivo ejecutable modificado que incluya la Biblioteca modificada. (Se entiende que el usuario que modifica el contenido de archivos de definiciones en la Biblioteca no necesariamente podrá recompilar la aplicación para utilizar las definiciones modificadas).
    • b) Utilizar un mecanismo de biblioteca compartida adecuado para vincularlo con la Biblioteca. Un mecanismo adecuado es uno que (1) usa en el momento de la ejecución una copia de la biblioteca ya presente en el sistema informático del usuario en lugar de copiar funciones de la biblioteca en el archivo ejecutable, y que (2) funcionará correctamente con una versión modificada de la biblioteca, si el usuario instala una, siempre y cuando la versión modificada tenga una interfaz compatible con la versión con la que se creó el trabajo.
    • c) Acompañar el trabajo con una oferta escrita, válida durante un mínimo de tres años, que proporcione al mismo usuario los materiales especificados en la Subsección 6a, arriba, por un cargo que no exceda el costo de esta distribución.
    • d) Si la distribución del trabajo se realiza mediante el ofrecimiento de acceso para copiar desde un lugar designado, ofrecer acceso equivalente para copiar los materiales especificados anteriormente desde el mismo lugar.
    • e) Verificar que el usuario ya haya recibido una copia de estos materiales o que haya enviado a este usuario una copia.

    Para un archivo ejecutable, la forma requerida del "trabajo que usa la Biblioteca" debe incluir datos y programas de utilidades necesarios para la reproducción del ejecutable a partir de él. No obstante, como excepción especial, los materiales que se distribuirán no necesitan incluir cualquier cosa que normalmente se distribuya (en forma de fuente o binaria) con los principales componentes (compilador, kernel, etc.) del sistema operativo en el que se ejecuta el archivo ejecutable, a menos que el componente en sí acompañe al archivo.

    Puede suceder que este requisito contradiga las restricciones de la licencia de otras bibliotecas de propiedad que, normalmente, no acompañan al sistema operativo. Esta contradicción significa que no puede usar ambas y la Biblioteca en un archivo ejecutable que distribuya.

  • 7. Puede colocar utilidades de bibliotecas que constituyan un trabajo basado en la Biblioteca juntas en una única biblioteca con otras utilidades de bibliotecas no cubiertas por esta Licencia, y distribuir esta biblioteca combinada, siempre que la distribución separada del trabajo basado en la Biblioteca y la de las utilidades de otra biblioteca esté permitida y que lleve a cabo las siguientes dos acciones:
    • a) Acompañar la biblioteca combinada con una copia del mismo trabajo basado en la Biblioteca, sin combinar con utilidades de otra biblioteca. Se debe distribuir conforme a los términos de las Secciones anteriores.
    • b) Proporcionar un aviso prominente con la biblioteca combinada que indique que parte de ella es un trabajo basado en la Biblioteca, y en donde se explique dónde buscar la forma sin combinar acompañante del mismo trabajo.
  • 8. No puede copiar, modificar, sublicenciar, vincular con o distribuir la Biblioteca, excepto en los casos que se expresan en esta Licencia. Cualquier intento de copiar, modificar, sublicenciar, vincular con o distribuir la Biblioteca de otra forma es nulo, y terminará en forma automática los derechos otorgados mediante esta Licencia. Sin embargo, las licencias de las partes que recibieron copias o derechos de usted conforme a esta Licencia no serán revocadas, siempre y cuando continúen demostrando un cumplimiento estricto.
  • 9. No es necesario que acepte esta Licencia, dado que no la ha firmado. No obstante, ningún otro elemento le otorga permiso para modificar o distribuir la Biblioteca o sus trabajos derivados. En el caso de que no acepte esta Licencia, estas acciones están prohibidas por ley. Por lo tanto, al modificar o distribuir la Biblioteca (o cualquier trabajo basado en la Biblioteca), está indicando su aceptación de la Licencia para hacerlo, y todos sus términos y condiciones para copiar, distribuir o modificar la Biblioteca o trabajos basados en ella.
  • 10. Siempre que redistribuya la Biblioteca (o cualquier trabajo basado en la Biblioteca), el destinatario recibe automáticamente una licencia del licenciante original para copiar, distribuir, vincular con o modificar la Biblioteca, sujeto a estos términos y condiciones. No puede imponer restricciones adicionales sobre el ejercicio de los derechos otorgados en el presente documento a los destinatarios. Usted no es responsable de exigir el cumplimiento por parte de terceros de esta Licencia.
  • 11. Si, como consecuencia de un orden judicial o acusación de violación de patentes, o por cualquier otro motivo (sin limitación a problemas de patentes), se le imponen condiciones (mediante orden judicial, acuerdo o de otra forma) que contradicen las condiciones de esta Licencia, no lo exoneran de las condiciones incluidas en esta Licencia. Si no puede realizar la distribución de forma tal que cumpla en forma simultánea sus obligaciones conforme a esta Licencia y cualquier otra obligación pertinente, no podrá, en consecuencia, distribuir la Biblioteca en absoluto. Por ejemplo, si la licencia de una patente no permite la redistribución libre de regalías de la Biblioteca por todos aquellos que reciben copias directamente o indirectamente a través de usted, entonces la única forma en que puede cumplir con esto y con esta Licencia sería evitando en su totalidad la distribución de la Biblioteca.

    Si cualquier parte de esta sección se considera no válida o sin efecto de acuerdo con una circunstancia en particular, se aplicará el resto de la sección, y la sección completa se aplicará en otras circunstancias.

    El objetivo de esta sección no es inducirlo al incumplimiento de patentes o cualquier otro reclamo de derechos de propiedad ni impugnar la validez de estos reclamos; está sección se proporciona con el único fin de proteger la integridad del sistema de distribución de software gratuito que se implementa mediante las prácticas de licencias públicas. Muchas personas han contribuido en gran medida a la amplia variedad de software distribuido a través de ese sistema en función de su aplicación constante; es decisión del autor/donante si está dispuesto a distribuir software a través de cualquier otro sistema, y el licenciatario no puede imponer esa decisión.

    Esta sección pretende dejar en claro lo que se considera como una consecuencia del resto de esta Licencia.

  • 12. Si la distribución y/o el uso de la Biblioteca está limitado en determinados países por patentes o interfaces con derechos de autor, el propietario del derecho de autor original que coloca la Biblioteca conforme a esta Licencia puede agregar una limitación de distribución geográfica explícita que excluya a estos países, de modo que se permita esa distribución únicamente en o entre países no excluidos. En este caso, esta Licencia incorpora la limitación como si se escribiera en el cuerpo de esta Licencia.
  • 13. La Free Software Foundation puede publicar versiones revisadas o nuevas de la Licencia Pública General Menor ocasionalmente. Estas versiones nuevas serán de intención similar a la versión actual, pero pueden diferir en detalles con el fin de abordar nuevos problemas o inquietudes.

    Cada versión recibe un número de versión diferente. Si la Biblioteca especifica un número de versión de esta Licencia que se aplica a ella y a "cualquier versión posterior", tiene la opción de cumplir los términos y condiciones de esa versión o de cualquier versión posterior publicada por la Free Software Foundation. Si la Biblioteca no especifica un número de versión de licencia, puede elegir una versión cualquiera publicada por la Free Software Foundation.

  • 14. Si desea incorporar partes de la Biblioteca a otros programas gratuitos cuyas condiciones de distribución no son compatibles con estas, comuníquese con el autor para solicitar su permiso. Para el software protegido por derechos de autor de la Free Software Foundation, comuníquese con la Free Software Foundation; algunas veces hacemos excepciones. Nuestra decisión estará basada en dos objetivos: preservar el estado gratuito de todos los derivados de nuestro software gratuito y promover el uso compartido y reutilización del software en general.

    SIN GARANTÍAS

  • 15. DADO QUE LA LICENCIA PARA LA BIBLIOTECA SE OTORGA DE FORMA GRATUITA, NO SE PROPORCIONAN GARANTÍAS PARA LA BIBLIOTECA EN LA MEDIDA PERMITIDA POR LAS LEYES APLICABLES. EXCEPTO QUE SE MANIFIESTE LO CONTRARIO POR ESCRITO, LOS PROPIETARIOS DE DERECHOS DE AUTOR U OTRAS PARTES PROPORCIONAN LA BIBLIOTECA "EN EL ESTADO EN EL QUE SE ENCUENTRA", SIN GARANTÍAS DE NINGÚN TIPO, EXPLÍCITA O IMPLÍCITA, INCLUIDAS, ENTRE OTRAS, GARANTÍAS DE COMERCIABILIDAD E IDONEIDAD PARA UN FIN EN PARTICULAR. USTED ASUME TODOS LOS RIESGOS RELACIONADOS CON LA CALIDAD Y EL RENDIMIENTO DE LA BIBLIOTECA. EN EL CASO DE PROBAR QUE UNA BIBLIOTECA CONTIENE DEFECTOS, USTED ES RESPONSABLE DEL COSTO DE TODAS LAS TAREAS DE SERVICIO, REPARACIÓN O CORRECCIÓN NECESARIAS.
  • 16. EN NINGÚN CASO, A MENOS QUE LO REQUIERAN LAS LEYES APLICABLES O SE ACUERDE POR ESCRITO, UN PROPIETARIO DE DERECHOS DE AUTOR, O CUALQUIER OTRA PARTE QUE PUEDA MODIFICAR O REDISTRIBUIR LA BIBLIOTECA SEGÚN LO PERMITIDO ANTERIORMENTE, SERÁ RESPONSABLE ANTE USTED POR DAÑOS, INCLUIDOS DAÑOS GENERALES, ESPECIALES, INCIDENTALES O CONSECUENTES QUE SURJAN A PARTIR DEL USO O LA INCAPACIDAD PARA USAR LA BIBLIOTECA (INCLUIDA, ENTRE OTROS, LA PÉRDIDA DE DATOS O DATOS IMPRECISOS, O LAS PÉRDIDAS SOSTENIDAS POR USTED U OTROS, ASÍ COMO TAMBIÉN LA IMPOSIBILIDAD DE LA BIBLIOTECA DE FUNCIONAR CON OTRO SOFTWARE), INCLUSO, SI ESTE PROPIETARIO O TERCERO HA SIDO ADVERTIDO DE LA POSIBILIDAD DE ESTOS DAÑOS.
FIN DE TÉRMINOS Y CONDICIONES

Cómo aplicar estos términos a sus nuevas bibliotecas

Si crea una nueva biblioteca y desea que pueda utilizarse en la mayor medida posible por el público, le recomendamos que la cree como software gratuito que todos puedan redistribuir y cambiar. También puede hacerlo al permitir la redistribución conforme a estos términos (o bien, como opción, conforme a los términos de la Licencia Pública General común).

Para aplicar estos términos, anexe los siguientes avisos a la biblioteca. Es recomendable anexarlos al comienzo de cada archivo de origen para transmitir en forma más eficaz la exclusión de garantías; y cada archivo debe tener como mínimo la línea "derecho de autor" y un puntero al lugar en el que se encuentra el aviso completo.

    one line to give the library's name and an idea of what it does.
    Copyright (C) year name of author

    This library is free software; you can redistribute it and/or
    modify it under the terms of the GNU Lesser General Public
    License as published by the Free Software Foundation; either
    version 2.1 of the License, or (at your option) any later version.

    This library is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
    Lesser General Public License for more details.

    You should have received a copy of the GNU Lesser General Public
    License along with this library; if not, write to the Free Software
    Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA

Además, agregue información sobre cómo comunicarse con usted mediante correo electrónico o correo postal.

También debe solicitar a su empleador (si trabaja como programador) o a su escuela, si corresponde, que firme una "renuncia de derechos de autor" para la biblioteca, de ser necesario. A continuación se incluye un ejemplo; modifique los nombres:
    Yoyodyne, Inc., hereby disclaims all copyright interest in
    the library 'Frob' (a library for tweaking knobs) written
    by James Random Hacker.

    signature of Ty Coon, 1 April 1990
    Ty Coon, President of Vice
¡Eso es todo!


Copyright

© 2016 Pitney Bowes Software Inc. Todos los derechos reservados.

Este documento puede incluir información confidencial y exclusiva de propiedad de Pitney Bowes Inc. y/o sus subsidiarias y compañías asociadas.

Portrait Software, el logotipo de Portrait Software, Portrait y la marca Portrait de Portrait Software son las marcas comerciales de Portrait Software International Limited y se prohíbe su uso o explotación de cualquier forma sin previa autorización escrita expresa de Portrait Software International Limited.

Reconocimiento de marcas comerciales

Otros nombres de productos, nombres de compañías, marcas, logotipos y símbolos a los que se hace referencia en la presente pueden ser marcas comerciales o marcas comerciales registradas de sus propietarios registrados.

Soporte técnico de Portrait Software

Si necesita ayuda con algún tema no abordado en esta documentación, consulte la Base de conocimientos de nuestro sitio web http://support.portraitsoftware.com y siga los enlaces que llevan al producto.

También puede descargar otra documentación de Portrait Software desde el sitio. Si no tiene nombre de usuario ni contraseña, o no los recuerda, comuníquese con nosotros a través de uno de los canales mencionados a continuación.

Si encuentra un problema en el uso, la instalación o la documentación de este producto, comuníquese con nosotros a través de cualquiera de los siguientes métodos:

Correo electrónico:support@portraitsoftware.com

Teléfono

  • EE. UU./Canadá 1-800-335-3860 (línea gratuita)
  • Resto del mundo +44 800 840 0001

Cuando notifique un problema, nos resultará útil la siguiente información:

  • El nombre de la aplicación de software.
  • Las circunstancias en las que surgió el problema.
  • Los mensajes de error que recibió (si hubiera).
  • La versión del software que utiliza.

Pitney Bowes Software Inc.

February 23, 2016


Online Help