Einleitung

  • Portrait Miner Überblick
© 2015 Pitney Bowes Software Inc. Email: software.support@pb.com


Portrait Miner Überblick

Portrait Miner ist eine starke Vorhersagelösung, die es Kundeneinblick-Profis und Geschäftsnutzern gleichermaßen erlaubt, ein klares Bild ihrer Kunden zum Zwecke eines besseren Kundenverständnisses zu bekommen, neue Möglichkeiten zu entdecken, optimale Segmentierung zu erreichen und zukünftiges Verhalten vorherzusagen.

Portrait Customer Analytics ist eine Lösung der nächsten Generation, die für unvergleichliche Benutzerfreundlichkeit und schnelle Einsicht entworfen wurde, und den Spagat zwischen Standard-Business-Intelligence-Tools mit begrenztem Fokus auf Datenauswertungs- und Zahlenauswertungs-Lösungen, die statistische Programmierer zum Aufbau von Abfragen und Erstellen von Modellen erfordern, locker schafft.

Die Lösung verwendet leistungsstarke 3D-Datenvisualisierung und schnelle Modellierungsautomatisierung zum Aufzeigen wichtiger Datenbeziehungen und Tendenzangaben auf Knopfdruck, fördert die Genauigkeit von Vorhersagemodellen und erhöht die Geschwindigkeit der Analyseergebnisse.

Portrait Miner kann zur Vorhersage von Profiteinflussverhalten und -eigenschaften verwendet werden, darunter Kundenabwanderung, Querverkauf und Verkaufsmöglichkeiten, Kampagnenplanung und -segmentierung, Kundenzufriedenheit und -bindung sowie Langzeitwert der Kundenbeziehungen.

Übergeordnetes Thema: Einleitung


Erste Schritte

  • Portrait Miner starten
  • Angaben zu Portrait Miner-Servern hinzufügen oder löschen
  • Navigieren zum Öffnen oder Speichern einer Datei, Sitzung oder einer Datenbanktabelle
  • Mit Dateien und lokalen Festplatten arbeiten
  • Fokusdateien in Portrait Miner manipulieren
  • Textdateien in Portrait Miner ansehen und bearbeiten
  • Informationen zur Textverschlüsselung
  • Arbeiten mit Sitzungsdateien


Portrait Miner starten

  1. Führen Sie einen der folgenden Schritte aus:
    • Doppelklicken Sie auf das Portrait Miner-Verknüpfungssymbol auf Ihrem Arbeitsplatz. Portrait Miner startet.
    • Öffnen Sie das Windows „Start“-Menü und wählen Sie unter „Programme>Portrait Miner“ Portrait Miner aus.
  2. Wenn ein Anmeldefenster erscheint, geben Sie Ihren Benutzernamen und das Kennwort für den Portrait Miner Server ein und klicken Sie auf „OK“.

    Ihr Systemadministrator sollte Ihnen mitteilen, welchen Server Sie benutzen sollten (wenn eine Auswahl vorhanden ist) und welchen Benutzernamen bzw. Kennwort Sie für diesen Server verwenden müssen. (Wenn das Betriebssystem Ihrer Server Windows ist, müssen Ihr Benutzername und Ihr Kennwort für die von Ihnen in den Servereinstellungen konfigurierte Windows-Domäne geeignet sein.)

    Wenn Sie Portrait Miner vorher noch nicht benutzt haben und das „Server“-Menü leer ist, siehe Angaben zu Portrait Miner-Servern hinzufügen oder löschen.

    Sobald Sie sich auf einem Portrait Miner-Server angemeldet haben, können Sie weitere Portrait Miner-Anwendungen, die sich mit demselben Server verbinden, ausführen. Sie werden nicht aufgefordert, sich noch einmal anzumelden. Sie bleiben auf dem Portrait Miner-Server angemeldet, bis Sie sich explizit abmelden (wählen Sie dazu „Datei>Logout“ in einer beliebigen Portrait Miner-Anwendung) oder Ihre zuletzt geöffnete Portrait Miner-Anwendung beenden (wählen Sie dazu „Datei>Beenden“ oder klicken Sie im Hauptfenster der Anwendung auf [image]).

Übergeordnetes Thema: Erste Schritte


Angaben zu Portrait Miner-Servern hinzufügen oder löschen

Wenn Sie Portrait Miner zum ersten Mal benutzen, ist das „Server“-Menü im Anmeldefenster leer (wenn Ihr Systemadministrator es nicht für Sie eingerichtet hat).

Wenn Sie eine Eingabe im „Server“-Menü machen möchten, müssen Sie den Netzwerknamen von Portrait Miner und seine Portnummer kennen. Ihr Systemadministrator kann Ihnen diese Informationen geben.

Übergeordnetes Thema: Erste Schritte

Um einen Server zum Servermenü hinzuzufügen

  1. Klicken Sie im Anmeldefenster auf Server, um das Dialogfenster Server anzuzeigen:

  2. Klicken Sie auf Hinzufügen, um das Dialogfenster Serverkonfiguration hinzufügen anzuzeigen:

  3. Geben Sie in dem Fenster Name die Serverbeschreibung ein, die in der Server-Liste des Anmeldefensters verwendet wird.
  4. Geben Sie im „Server-Fenster den Netzwerknamen des Portrait Miner-Servers (zum Beispiel „IhrServer.IhreFirma.com“) ein.
  5. Wählen Sie entweder Unix oder Windows, je nach dem Betriebssystem des Portrait Miner Servers. Wenn Sie Windows wählen, legen Sie die Windows-Domäne an, bei der Sie sich anmelden werden, oder verwenden Sie die Standardeinstellung ("Local"), um ein lokales Konto auf dem Server einzurichten.
  6. Geben Sie im Fenster Port die Nummer des Ports ein, für den der Server konfiguriert wurde.
  7. Klicken Sie auf OK, um die neuen Serverdetails hinzuzufügen.
  8. Klicken Sie im Dialogfenster Server auf Schließen, um zum Anmeldefenster zurückzukehren.

To bearbeiten Sie eine Eingabe für den Server

  1. Klicken Sie auf die Schaltfläche „Server“.
  2. Markieren Sie einen verfügbaren Server und klicken Sie auf „Bearbeiten“.

    Das Dialogfeld Serverkonfiguration bearbeiten wird angezeigt, das im Wesentlichen dasselbe ist wie das Dialogfeld Serverkonfiguration hinzufügen [siehe Um einen Server zum Servermenü hinzuzufügen].

  3. Ergänzen Sie ggf. den Namen, Server oder Port und klicken Sie auf „OK“.
  4. Klicken Sie auf „Schließen“, um das Dialogfeld „Server“ zu schließen.

Einen Server aus dem Servermenü entfernen

  1. Klicken Sie auf die Schaltfläche „Server“.
  2. Markieren Sie den Server, den Sie entfernen möchten und klicken Sie auf „Entfernen„.
  3. Klicken Sie auf „Schließen“.


Navigieren zum Öffnen oder Speichern einer Datei, Sitzung oder einer Datenbanktabelle

Wenn Sie eine Datei, Sitzung oder Datenbanktabelle in Portrait Miner öffnen oder speichern, erscheint ein Portrait Miner-Dateibrowser. Er ähnelt den Browsern in anderen Windows-Anwendungen, verfügt aber über Varianten, mit deren Hilfe Sie durch Dateien auf ihrem PC, Dateien auf Ihrem Portrait Miner-Server (in der Client-Server-Version der Software) und Tabellen Ihrer Datenbanken navigieren können.

Wenn Sie einen Datensatz öffnen oder speichern, enthält der Browser bis zu drei Registerkarten, die mit „Quadstone,“ „Alle Dateien,“ und „RDBMS,“ wie im folgenden Beispiel, bezeichnet sind:

Übergeordnetes Thema: Erste Schritte

Navigation durch Dateien in Portrait Miner

Die Registerkarten „Quadstone“ und „Alle Dateien“ zeigen Dateien und Ordner in Portrait Miner an, der erste ist jedoch etwas restriktiver:
 | Die Registerkarte „Quadstone“ | Die Registerkarte „Alle Dateien“
Angezeigte Ordner | Alle Ordner außer: Ordner mit den Dateierweiterungen .rdx und .xtr, die Datendateien für Fokusse, Ordner, deren Bezeichnung mit einem Punkt (.) beginnt | Alle Ordner
Dateien, die angezeigt werden, wenn „Dateityp“ auf „Alle Dateien“ gesetzt wird. | Alle Dateien außer: Dateien mit den Dateierweiterungen .fcs, .mid, .mdh, .spa, und .x86; Dateien, deren Namen mit einer Tilde (~) enden; Dateien, deren Name mit einem Punkt (.) beginnt. | Alle Dateien
Dateien, die angezeigt werden, wenn „Dateityp“ in einen bestimmten Dateityp geändert wird. | Nur Dateien mit der/den vorgegebenen Dateierweiterung(en) | Wie „Quadstone“

Wenn Sie einen Datensatz als Datei oder Fokus speichern, achten Sie darauf, den notwenigen Typ in der Auswahl „Dateityp“ auszuwählen.

Anmerkung:
  • Portrait Miner zeigt normalerweise dieselben Dateien und Ordner wie ein Browser in der Registerkarte „Quadstone“ an. Sie können die Dateien und Ordner, die ein Dateibrowser auf der Registerkarte „Alle Dateien“ anzeigt durch Auswahl von „Ansicht>Versteckte Dateien anzeigen“ anzeigen.
  • Portrait Miner generiert Protokolle zu Administrationszwecken. Um zu dem Ordner zu navigieren, der diese Protokolldateien enthält, klicken Sie in der Symbolleiste auf [image].
  • Um zum vorherigen, nächsten oder übergeordneten Ordner zu navigieren, klicken Sie in der Symbolleiste auf [image], [image] oder [image].
  • Um direkt zum Standardordner zu navigieren (der Einstellung der Option qsexplorer home), klicken Sie auf [image].
  • Sie können direkt zu einem beliebigen Ordner navigieren, indem Sie Ansicht>Gehe Zu... auswählen und den Ordnernamen eingeben.

Navigieren in Datenbanken, Namensbereichen und Tabellen

Sie können in Datenbanken navigieren, verwenden Sie die Registerkarte „RDBMS“, wenn sie angezeigt wird. („RDBMS“ steht für „Relational Database Management System.“) Zunächst enthält diese Registerkarte eine Liste aller verfügbaren Datenbanken. Sie können innerhalb einer Datenbankhierarchie bis hin zur Ebene einzelner Tabellen in derselben Weise navigieren, wie Sie es in einem Dateisystem tun.

Siehe auch

Eine Datenbankverbindung herstellen

Navigieren durch die Sitzungen auf Ihrem PC

Sie können nach bereits gespeicherten Sitzungen (.pms-Dateien) im Menü Datei > Sitzung öffnen suchen. In diesem Fall wird im Browser eine einzige Registerkarte angezeigt, die mit Arbeitsplatz bezeichnet ist und die Vorauswahl .pms als Dateityp hat.

In diesem Fall enthält der Browser eine einzige Registerkarte, die mit „Arbeitsplatz“ bezeichnet ist:

Sie können durch die Dateien navigieren und Dateien auf Ihrem PC in derselben Weise wie unter einer Windows-Anwendung speichern.

Navigieren durch die Dateien auf Ihrem PC

Sie können verschiedene Dateitypen auf Ihrem PC speichern (oder auf einem Netzwerklaufwerk, auf das Sie von Ihrem PC aus zugreifen können). Darin eingeschlossen sind exportierte Diagramme und gespeicherte Kreuztabellen.

In diesem Fall enthält der Browser eine einzige Registerkarte, die mit „Arbeitsplatz“ bezeichnet ist:

Sie können durch die Dateien navigieren und Dateien auf Ihrem PC in derselben Weise wie unter einer Windows-Anwendung speichern.


Mit Dateien und lokalen Festplatten arbeiten

Auch wenn Sie keinen direkten Zugriff auf Ihren Portrait Miner-Server haben, können Sie einige Dateien (beispielsweise Skripts, Bilder und Kreuztabellen) auf Ihrem PC speichern und öffnen. Um eine Datendatei, die sich auf Ihrem PC (oder einem zugänglichen Netzwerklaufwerk) befindet zu verwenden, können Sie die Datendatei aus Windows Explorer in einen Portrait Miner Ordner ziehen.

In diesem Ordner auf dem Portrait Miner-Server erscheint eine Kopie der Datei, die Sie dann sofort benutzen können.

Anmerkung: So wie Sie Dateien aus dem Windows Explorer in Portrait Miner ziehen können, können Sie auch Dateien in umgekehrter Richtung ziehen, um sie vom Portrait Miner-Server auf eine lokale Festplatte zu kopieren.

Siehe auch

Textdateien in Portrait Miner ansehen und bearbeiten
Übergeordnetes Thema: Erste Schritte


Fokusdateien in Portrait Miner manipulieren

Ein Fokus wird als .ftr-.Datei (die „Fokusdatei“), zusammen mit einer Auswahl Datendateien und anderen Dateien in zwei Ordnern, deren Namen auf .rdx („Raw Data eXtract“) und .xtr („eXTRa“) enden, auf der Festplatte gespeichert. Diese Ordner werden in Portrait Miner und in der Registerkarte „Quadstone“ des Portrait Miner-Dateibrowser im Allgemeinen nicht angezeigt [siehe Navigieren zum Öffnen oder Speichern einer Datei, Sitzung oder einer Datenbanktabelle].

Ein neuer Fokus, erstellt durch kopieren eines vorhandenen Fokusses oder durch das Importieren von Daten von einer anderen Art von Datensatz (oder als Ergebnis der Ausführung eines TML-Skripts) ist von anderen Fokussen „unabhängig“. Auf der anderen Seite ist ein Fokus, der mit Decision Studio mit einem neuen Namen gespeichert, oder einer, der durch die Erstellung einer verlinkten Kopie erstellt wurde, abhängig von Datenordnern, die zu einem anderen Fokus gehören.

Aufgrund der möglichen Interdependenz der Fokusse dürfen Sie keine Fokusdateien und Ordner mit den Hilfsprogrammen des Betriebssystems, beispielsweise Windows Explorer oder UNIX Befehlszeilentools, kopieren, verschieben, umbennenen oder löschen. Stattdessen müssen Sie immer Portrait Miner (oder die Portrait Miner Dateierstellungsbefehle) verwenden.
Übergeordnetes Thema: Erste Schritte

Kopieren oder verschieben einer Fokusdatei in einen anderen Ordner

  1. Klicken Sie in Portrait Miner auf die Fokusdatei, die Sie kopieren oder verschieben möchten.
  2. Führen Sie einen der folgenden Schritte aus:
    Beim Kopieren der Datei | Beim Verschieben der Datei
    Wählen Sie Bearbeiten>Kopieren. | Wählen Sie Bearbeiten>Ausschneiden.
    Klicken Sie mit der rechten Maustaste und wählen Sie Kopieren. | Klicken Sie mit der rechten Maustaste und wählen Sie Ausschneiden.
    Klicken Sie in der Symbolleiste auf [image]. | Klicken Sie in der Symbolleiste auf [image].
    Betätigen Sie „STRG+C“. | Betätigen Sie „STRG+X“.
  3. Navigieren Sie zum Zielordner.
  4. Wählen Sie „Bearbeiten>Einfügen“, klicken Sie mit der rechten Maustaste und wählen Sie „Einfügen“, klicken Sie in der Symbolleiste auf [image], oder drücken Sie Strg+V.
Anmerkung:
  • Sie können eine Fokusdatei als unabhängigen Fokus (siehe oben) kopieren, in diesem Fall werden die Daten dupliziert, oder Sie können eine verknüpfte Kopie erstellen, die die Daten des Originalfokus nutzt. Verwenden Sie hierzu „Verknüpfung einfügen“ anstatt „Einfügen“. (Die Symbolleiste enthält keine Verknüpfung hierfür.) Sie können keine verknüpfte Kopie erstellen, wenn Sie die Fokusdatei verschieben.
  • Sie können auch einen Namen für den Fokus, den Sie kopieren oder verschieben, auswählen, verwenden Sie hierzu „Einfügen als“ oder (beim Kopieren) „Verknüpfung einfügen als“.
  • Diese Benutzerschnittstelle ist eine Möglichkeit, um auf einen großen Teil der durch den Portrait Miner Datenaufbaubefehle qscopy, qslink und qsmove bereitgestellte Funktionalität zu nutzen.
  • Sie können Nicht-Fokusdateien (aber keine verknüpften Kopien) auf dieselbe Weise kopieren oder verschieben.

Siehe auch

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Eine Fokusdatei umbenennen

  1. Klicken Sie in Portrait Miner auf die Datei, die Sie umbenennen möchten.
  2. Wählen Sie „Bearbeiten>Umbennenen“, klicken Sie mit der rechten Maustaste und wählen Sie „Umbenennen“ oder klicken Sie einfach noch ein zweites Mal auf den Dateinamen.

    Der Dateiname kann bearbeitet werden.

Anmerkung:
  • Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl qsmove in Portrait Miner bereitgestellt werden, zuzugreifen.
  • Sie können eine Nicht-Fokusdatei auf dieselbe Weise umbenennen.

Siehe auch

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Eine Fokusdatei löschen

Sie können Portrait Miner zum rekursiven Löschen einer ganzen Fokuskette verwenden: Wählen Sie den zu löschenden Fokus und alle Fokusse, die von ihm abhängig sind, werden ebenfalls gelöscht. Eine Bestätigung, welcher Fokus gelöscht wird, wird angezeigt und Sie haben Sie Wahl, ob Sie fortfahren oder den Löschvorgang beenden möchten.

  1. Klicken Sie in Portrait Miner auf die Datei, die Sie löschen möchten.
  2. Wählen Sie „Bearbeiten>Löschen“, klicken Sie mit der rechten Maustaste und wählen Sie „Löschen“, klicken Sie in der Symbolleiste auf [image], oder drücken Sie die Löschtaste.
Anmerkung:
  • Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl qsremove in Portrait Miner bereitgestellt werden, zuzugreifen.
  • Sie können eine Nicht-Fokusdatei und Ordner auf dieselbe Weise löschen. Bevor Sie einen Ordner löschen, müssen Sie die darin enthaltenen Fokusdateien löschen.

Siehe auch

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Eine Archivdatei erstellen

Sie können eine Archivdatei aus einem Fokus oder einem Ordner, der eine Reihe zugehöriger Fokusse oder Unterordner enthält, erstellen.

Führen Sie in Portrait Miner einen Rechtsklick auf der Datei oder dem Ordner aus, den Sie archivieren möchten und wählen Sie „Archiv“ für einen Ordner oder „Export>in Archiv“ für einen Fokus.

Geben Sie im Dialogfeld „In ZIP-Datei archivieren“ den Namen der Ausgabedatei an.

Anmerkung:
  • Falls Sie eine Archivdatei aus einem Ordner mit Fokussen erstellen, die mit Daten außerhalb des Ordners verbunden sind, werden die externen Daten in die Archivdatei kopiert. Damit wird sichergestellt, dass Sie immer einen konsistenten Satz zugehöriger Fokusse erhalten, wenn Sie aus der Archivdatei extrahieren.
  • Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl „qsarchive“ in Portrait Miner bereitgestellt werden, zuzugreifen.

Siehe auch

Informationen über Portrait Miner-Assistenten

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Aus einer Archivdatei extrahieren

Führen Sie in Portrait Miner einen Rechtsklick auf der Archivdatei aus, die extrahieren möchten und wählen Sie „Extrahieren“.

Wählen Sie im Dialogfeld „Aus ZIP-Archiv extrahieren“ einen Ausgabeordner und entscheiden, ob Sie vorhandene Dateien überschreiben möchten.

Anmerkung: Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl „qsunzip“ in Portrait Miner bereitgestellt werden, zuzugreifen.

Siehe auch

Informationen über Portrait Miner-Assistenten

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten


Textdateien in Portrait Miner ansehen und bearbeiten

Wie Sie eine Datei aus Portrait Miner bearbeiten oder ansehen, hängt vom Dateityp ab. Sie können:
  • einen Rechtsklick auf der Datei ausführen und „Bearbeiten“ wählen, um die Datei mit Notepad zu bearbeiten oder anzusehen,
  • einen Rechtsklick auf der Datei ausführen und „Ansicht“ wählen, um die Datei in einer geeigneten Anwendung anzusehen,
  • alternativ für eine der obigen Funktionen Doppelklick auf der Datei ausführen.
Dateityp | Bearbeiten | Ansicht | Doppelklicken
Textdatendatei (.txt, .dat, .csv, .tab, .fdf), Dateibeschreibung (.fdd) |  |  | — (Öffnen [siehe Einen Fokus aus Daten in einer Textdatei erstellen])
SQL-Datei (.sql) |  |  | — (Öffnen)
Notepad. TML-Skriptdatei (.tml), FDL-Ableitungsdatei (.fdl), Hierarchiedatei für kategorische Klasseneinteilung (.hrc) |  |  | Bearbeiten
Protokolldatei (.log) |  |  | Ansicht
XML -Datei (.xml, .qmml, usw.) |  |  | Ansicht
Anmerkung:
  • Wenn Sie keinen direkten Zugriff auf Ihren Portrait Miner-Server haben, können Sie die Dateien ansehen und gegebenenfalls Textdateien auf dem Server bearbeiten. Es gibt zwei Portrait Miner-Versionen: Eine Client-Server-Version und Portrait Miner Desktop. Wenn Sie die Client-Server-Version benutzen, verwenden Sie Portrait Miner zur Ansicht oder zum Bearbeiten einer Textdatei mit Notepad, Sie arbeiten mit einer Kopie der Datei. Wenn Sie die Datei speichern, Notepad aber geöffnet bleibt, bleibt die Version auf dem Server unverändert, Portrait Miner kopiert die aktualisierte Version von Ihrem PC auf den Server, sobald Sie Notepad geschlossen haben.
  • Zum Speichern der Textdateien müssen Sie eine ISO-8859-1 (Latin-1) Kodierung verwenden.

Siehe auch

Fokusdateien in Portrait Miner manipulieren

Mit Dateien und lokalen Festplatten arbeiten

XML in Portrait Miner

Übergeordnetes Thema: Erste Schritte


Informationen zur Textverschlüsselung

Textdateien in Portrait Miner können mit Unicode verschlüsselt sein, wie es in der Bytereihenfolge-Marke (BOM) der Datei definiert ist. Wenn eine Datei unter Windows keine Bytereihenfolge-Marke besitzt, wird von Windows angenommen, dass die Verschlüsselung „ANSI“ gemäß der regionalen Einstellungen des Computers verwendet wird, z. B. Windows 1215 in Europa und den USA oder CP932 in Japan. In Solaris wird für eine Datei ohne Bytereihenfolge-Marke angenommen, dass sie mit Latin-1 verschlüsselt ist.

Übergeordnetes Thema: Erste Schritte


Arbeiten mit Sitzungsdateien

Wenn Sie in einem der Anzeigewerkzeuge von Portrait Miner (Kreuztabellen-, 3D-, Profil- oder Zuordnungsansicht) arbeiten und die aktuelle Ansicht speichern möchten, verwenden Sie die Option Datei > Sitzung speichern im Fenster Decision Studio. Die Dateien werden mit der Endung (.pms) gespeichert und haben standardmäßig den Namen der Fokus-Datei.
Gespeicherte Sitzungen können in Decision Studio oder alternativ durch Doppelklick auf die .pms-Datei im Explorer-Fenster von Portrait Miner geladen werden.
Anmerkung:
Session files are directly linked to the associated focus file and must reside in the same directory.

Laden oder Öffnen einer gespeicherten Sitzung

Sie können gespeicherte Sitzungen für die folgenden Portrait Miner-Werkzeuge laden:

  • Kreuztabellenansicht
  • 3D-Ansicht
  • Profilansicht
  • Zuordnungsansicht
    Anmerkung: Alle gespeicherten Sitzungsdateien sind direkt mit der Fokusdatei verknüpft, aus der heraus sie erstellt wurden.
So laden Sie eine gespeicherte Sitzung in Portrait Miner
  1. Öffnen Sie Portrait Miner, und navigieren Sie zum Verzeichnis mit Ihrer gespeicherten Sitzung.
  2. Doppelklicken Sie auf die gespeicherte Sitzungsdatei (.pms). Die Sitzung lädt die zugehörigen Fokusdaten und die gespeicherte Sitzung.
So öffnen Sie eine gespeicherte Sitzung in Decision Studio
  1. Öffnen Sie Decision Studio.
  2. Wählen Sie Datei > Sitzung öffnen, und navigieren Sie zur entsprechenden Sitzungsdatei (.pms). Die Sitzung lädt die zugehörigen Fokusdaten und die gespeicherte Sitzung.

Speichern einer Sitzung

Sie können Sitzungsinformationen für die folgenden Portrait Miner-Werkzeuge speichern:

  • Kreuztabellenansicht
  • 3D-Ansicht
  • Profilansicht
  • Zuordnungsansicht
So speichern Sie eine Sitzung
  1. Wechseln Sie bei geöffneter Sitzung zum Decision Studio-Fenster, und wählen Sie Datei > Sitzung speichern aus.
  2. Fügen Sie im Dialogfeld Sitzung speichern Ihren gewünschten Dateinamen zum Standardpräfix hinzu. Hinweis: Das Präfix weist die zur Sitzung gehörende Fokusdatei aus.
Übergeordnetes Thema: Erste Schritte


Arbeiten mit Dateien, Datenbank-Tabellen und Fokussen

  • Informationen über Portrait Miner-Assistenten
  • Einen Fokus für die Visualisierung, Segmentierung und Modellierung öffnen
  • Einen Fokus sortieren
  • Konvertierung eines transaktionsorientierten Fokusses in einen kundenorientierten Fokus
  • Einen Fokus aus Daten in einer Textdatei erstellen
  • Einen Fokus aus Daten in einer Datenbank erstellen
  • Erstellen eines Fokus aus SAS oder einem Datensatz einer dritten Partei
  • Exportieren von Datensätzen in eine Datendatei, Datenbanktabelle oder Fokus
  • Informatinoen zur Kombination von Fokussen
  • So vereinen Sie Felder aus einem Fokus mit einem anderen Fokus mit Portrait Miner
  • So vereinen Sie Felder aus einem Fokus mit einem anderen Fokus mit Decision Studio
  • Die Datensätze zweier Fokusse vereinen
  • Eine Datenbankverbindung herstellen
  • Wie Portrait Miner-Datenbanktypen importiert
  • Verwenden des Data Build Manager für das Importieren, Verarbeiten und Exportieren von Daten
  • Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten


Informationen über Portrait Miner-Assistenten

Die Portrait Miner-Assistenten werden in Portrait Miner geöffnet, nachdem ein Fokus oder eine andere Datei ausgewählt wurde, und gewähren Zugriff auf die Benutzeroberfläche der Portrait Miner-Dateierstellungsbefehle.

In jedem Assistenten werden die Befehlsparameter auf der Registerkarte „Parameter“ angezeigt. Werte auf der Registerkarte „Parameter“ können verändert werden, indem Sie sie entweder direkt in das Feld eingeben oder auf „Durchsuchen“ [image] klicken, um ein weiteres Dialogfeld anzuzeigen, in dem Sie einen Wert auswählen können.

Nachdem alle verbindlichen Parameter – dargestellt durch einen roten Stern im Parameterfeld - ausgewählt wurden, klicken Sie auf „Los“, um den dazugehörigen Dateierstellungsbefehl auszuführen. Falls erforderlich, können Sie den Befehl beenden, indem Sie auf die Schaltfläche „Stopp“ klicken. Ein Grund dafür wäre beispielsweise die Auswahl der falschen Parameter.

Nachdem der Befehl ausgeführt wurde, werden die Ergebnisse auf der Registerkarte „Ausgabe“ angezeigt. Sollten bei der Verarbeitung des Befehls Fehler aufgetreten sein, wird auf der Registerkarte „Fehler“ eine Fehlermeldung angezeigt.

Siehe auch

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten
Übergeordnetes Thema: Arbeiten mit Dateien, Datenbank-Tabellen und Fokussen


Einen Fokus für die Visualisierung, Segmentierung und Modellierung öffnen

Sobald Sie Kundendaten in der Form eines Fokus haben, können Sie sie für die Analyse in Decision Studio öffnen und dabei eine Reihe von Tools [siehe Decision Studio Tools] für die Visualisierung, Segmentierung und Modellierung verwenden.

Ein Fokus kann mit einer der folgenden Optionen geöffnet werden:

  • Im Portrait Miner doppelklicken Sie auf den zu öffnenden Fokus oder klicken mit der rechten Maustaste auf den Fokus und wählen „Öffnen “.
  • Wählen Sie im Decision Studio-Fenster mit einem geöffneten Fokus die Optinen „Datei>Schließen“, um den vorhandenen Fokus zu schließen. Wählen Sie dann „Datei>Öffnen“ oder klicken in der Symbolleiste auf [image], und suchen Sie den Fokus, den Sie öffnen möchten.

    (Wenn Sie den Fokus seit einer Änderung oder dem Erstellen modifiziert haben, gibt Ihnen Decision Studio die Möglichkeit, Ihre Änderungen zu speichern, bevor Sie es schließen.)

Anmerkung:
  • Wenn Sie gewarnt werden, dass der Fokus schreibgeschützt ist, verwenden Sie „Datei>Speichern unter“ oder klicken Sie in der Symbolleiste auf [image], und wählen Sie einen neuen Namen oder Speicherort für Ihren Fokus, oder kopieren Sie den Fokus für einen neuen Speicherort. Einige Funktionen und Optionen funktionieren mit einem schreibgeschützten Fokus nicht.
  • In einer gegebenen Decision Studio-Sitzung kann immer nur ein Fokus gleichzeitig geöffnet sein.

    (Sie können jedoch mehr als eine Decision Studio-Sitzung zu einem Zeitpunkt haben.)

  • Zwei oder mehr Benutzer können gleichzeitig einen Fokus in Decision Studio öffnen und simultan daran arbeiten. (Natürlich sollten Sie sicherstellen, dass Sie beim Speichern des Fokus vermeiden, einen Fokus eines anderen Benutzers zu überschreiben).

Siehe auch

Einen Fokus aus Daten in einer Datenbank erstellen

Einen Fokus aus Daten in einer Textdatei erstellen

Portrait Miner starten

Übergeordnetes Thema: Arbeiten mit Dateien, Datenbank-Tabellen und Fokussen


Einen Fokus sortieren

Sie können die Datensätze in einem Fokus entsprechend der Werte in bis zu drei Feldern sortieren.
Einen Fokus sortieren:
  • Führen Sie in Portrait Miner einen Rechtsklick auf den Fokus, den Sie sortieren möchten aus oder wählen Sie „Transformieren>Sortieren“.

Wählen Sie im Dialogfeld „Fokus sortieren“ bis zu drei Schlüsselfelder zur Bestimmung der Reihenfolge des zu sortierenden Fokusses aus. Zusätzlich können Sie den Speicherort des neuen Fokusses ändern oder einen früher erstellten Ausgabefokus überschreiben.

Anmerkung:
  • Wenn Sie mehr als ein Feld auswählen, ist der Primärsortierschlüssel das ausgewählte Feld, das als erstes im Fokus erscheint und der Sekundärsortierschlüssel ist das ausgewählte Feld, das als zweites erscheint. (Wenn Sie drei Felder auswählen, ist das dritte Feld der Tertiärsortierschlüssel.)
  • Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl „qssort“ in Portrait Miner bereitgestellt werden, zuzugreifen.

Siehe auch

Informationen über Portrait Miner-Assistenten

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Übergeordnetes Thema: Arbeiten mit Dateien, Datenbank-Tabellen und Fokussen

Sortierreihenfolge eines Fokusses prüfen

In Portrait Miner setzen Sie einen Rechtsklick auf den zu prüfenden Fokus und wählen „Transformieren>Sortierreihenfolge überprüfen“.

Wählen Sie im Dialogfeld „Sortierreihenfolge überprüfen“ die Schlüsselfelder aus. Portrait Miner prüft, ob der Fokus anhand dieser Felder sortiert wurde.


Konvertierung eines transaktionsorientierten Fokusses in einen kundenorientierten Fokus

Für eine Datenanalyse auf Kundenebene benötigen Sie kundenorientierte Daten. Wenn Sie einen transaktionsorientierten Fokus haben, das heißt, einen Fokus, in dem jeder Datensatz eine Kundentransaktion darstellt, können Sie pro Kunde aggregierte Statistiken berechnen, um Felder in einem neuen, kundenorientierten Fokus zu erstellen. Sie können den neuen Fokus sofort für die Analyse verwenden oder ihn zunächst mit anderen kundenorientierten Fokussen verknüpfen [siehe Informatinoen zur Kombination von Fokussen]
Einen Fokus konvertieren:
  • Klicken Sie in Portrait Miner mit der rechten Maustaste auf den transaktionsorientierten Fokus und wählen Sie „Transformieren>Datensätze aggregieren“.

Wählen Sie im Dialogfeld „Datensätzen aggregieren“ die Datei, die die Felddefinitionen und die Schlüsselfelder, die den Kunden eindeutig identifizieren, aus. Sie können den Speicherort des neuen Fokusses ändern oder einen früher erstellten Ausgabefokus überschreiben.

Anmerkung:
  • Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl „qsmeasure“ in Portrait Miner bereitgestellt werden, zuzugreifen.
  • Verwenden Sie den Portrait Miner Datenaufbaubefehl „qstrack“ zur Nachverfolgung der Änderungen in einem Transaktionsstrom.

Siehe auch

Informationen über Portrait Miner-Assistenten

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Textdateien in Portrait Miner ansehen und bearbeiten

Übergeordnetes Thema: Arbeiten mit Dateien, Datenbank-Tabellen und Fokussen


Einen Fokus aus Daten in einer Textdatei erstellen

Um Portrait Miner zur Analyse einer Datenreihe in Form einer Textdatei zu verwenden, müssen Sie zunächst einen Fokus aus der Datendatei erstellen.
Einen Fokus erstellen:
  • Doppelklicken Sie in Portrait Miner auf die Datei oder klicken Sie mit der rechten Maustaste auf die Datei und wählen Sie „Öffnen“.
Zwei Fenster werden geöffnet:
  • Das Fenster „Dateiformatinformationen“ zeigt den ersten Versuch von Decision Studio, die Daten sinnvoll auszulesen, an. Stellen, an denen es Probleme gab, werden markiert.

    Sie können dieses Fenster jederzeit schließen.

  • Das zweite Fenster ist der Assistenten „Neuer Fokus“, der zunächst Schritt 1 eines aus 5 Schritten bestehenden Importprozesses anzeigt:

    Sie können mit den Schaltflächen „Weiter“ und „Zurück“ zwischen den Schritten navigieren. Sie können jederzeit „Beenden“ anklicken, um die bisher getroffene Auswahl zu akzeptieren und einen neuen Fokus aus Ihrer Datenreihe zu erstellen.

    Bevor Sie auf „Beenden“ klicken, können Sie den Speicherort für Ihren Fokus auswählen, klicken Sie hierzu auf die Schaltfläche „Durchsuchen“ im Fensterbereich „Fokus speichern als“ und navigieren [siehe Navigieren zum Öffnen oder Speichern einer Datei, Sitzung oder einer Datenbanktabelle] Sie bis zum gewünschten Speicherort..

    Der Assistent „Neuer Fokus“ zeigt bei jedem Schritt die aktuelle Interpretation der Feldnamen und Typen der Datei durch Decision Studio, sowie eine kleines Beispiel der mit dieser Interpretation zu sehenden Daten an.

Schritt 1: Wählen Sie das abgegrenzte Format oder das Format mit fester Breite, wählen Sie im Fensterbereich „Format wählen“ „Getrennt“, wenn die Feldwerte durch Kommas, senkrechte Striche oder ein anderes Trennzeichen getrennt sind, wählen Sie „Feste Breite“ wenn die Feldwerte mit demselben Zeichen fester Breite in jeder Zeile der Datei beginnen und enden.

Schritt 2: Einstellen der Formatdetails für Dateien Der Fensterbereich „Formatoptionen“ zeigt eine Zusammenfassung der aktuell eingestellten Formatdetails.

Wenn das Format der Datei von Decision Studio falsch interpretiert wurde (zum Beispiel, wenn das falsche Feldtrennzeichen ausgewählt wurde), klicken Sie auf „Format einstellen“ im Fensterbereich Formatoptionen, um das Fenster „Dateiformat einstellen“ (sowie ein Vorschaufenster für „Rohdaten“) zu öffnen:

Die links angezeigte Version ist für abgegrenzte Daten, die Version rechts für Felder mit fester Breite.

(Wenn Sie Felder mit fester Breite auswählen und von Schritt 1 zu Schritt 2 gehen, erscheinen die Fenster „Dateiformat einstellen“ und „Rohdaten“ automatisch.)

Wenn die erste Zeile Ihrer Datei aus Feldnamen anstelle von Daten besteht, markieren Sie die Option „Spaltenüberschriften“.

Die Einstellungen „Feldtrennzeichen“, „Nullen lesen als“, „Daten lesen als“, „Datumsmarkierung lesen als“ und „Strings lesen als“ ermöglichen Ihnen, detaillierte Aspekte des Formats der Datei zu bestimmen, wobei die allgemeinen Optionen in den Dropdown-Menüs zu finden sind. Einstellen des „Feldtrennzeichen“ auf „keines“ für eine Datei mit Feldern fester Breite.

Verwenden Sie die Tabelle zur Bestimmung der Feldnamen sowie die Beginn- und Endeposition der Felder mit fester Breite. Sie können das Fenster „Rohdaten“ zur Hilfe nehmen: Das „Lineal“ oben zeigt die Position der Zeichen an und wenn Sie den Mauszeiger über die Beispieldaten bewegen, wird in einer Textfeld die Position des Zeichens, auf dem sich der Cursor gerade befindet, angegeben..

Schritt 3: Feldformatdetails einstellen Die Tabelle für die Felddetails wird um drei editierbare Zeilen (mit weißem Hintergrund) erweitert:

Die ersten beiden Zeilen enthalten den Namen und Typ von jedem Feld. Bei einem Stringfeld enthält die dritte Zeile seine (maximale) Länge in Zeichen. Bei einem Datumsfeld enthält die dritte Zeile das Datumsformat.

Sie können einen neuen Feldnamen, eine Stringlänge oder ein angepasste Datumsformat [siehe Benutzerdefinierte Datumsformate] direkt eingeben.

Wenn Sie auf den Feldtyp klicken erscheint ein Menü, in dem die vier verfügbaren Datentypen [siehe Datentypen] angezeigt werden. Bei Datumsfeldern erscheint ein Menü mit den drei verfügbaren Standard-Datumsformaten [siehe Standardmäßige Datumsformate].

Schritt 4: Speichern der Formatdetails Wenn Sie Ihre Formateinstellungen später noch einmal verwenden möchten, können eine Dateibeschreibung (FDD) durch Klicken auf „Format exportieren“ und Auswahl eines Speicherorts erstellen.

Schritt 5: Felder auswählen, die Import werden sollen Standardmäßig importiert Decision Studio alle Felder in eine Datei. Wenn Sie nicht alle Felder benötigen, klicken Sie auf „Felder auswählen“ im Fensterbereich „Felder auswählen“. Das Dialogfeld „Felder auswählen“ erscheint mit allen Feldern der externen Datenquelle die im Fensterbereich „Einfügen“ angezeigt werden:

Benutzen Sie die Pfeiltasten, um zwischen den Fensterbereichen „Ausschließen“ und „Einschließen“ die die Felder aus der Datei, die Sie in Ihren Fokus übernehmen möchten, auszuwählen.

Die Schaltflächen [image] und [image] verschieben markierte Felder, wohingegen die Schaltflächen [image] und [image] alle Felder aus einem Fensterbereich in einen anderen verschieben.

Verwenden Sie die Schaltflächen [image] und [image] auf der rechten Seite des Fensters, um markierte Felder im Fensterbereich „Einschließlich“ neu anzuordnen.

Anmerkung:
  • Klicken Sie auf „Daten anzeigen“ im Assistenten „Neuer Fokus“, um die Daten so anzuzeigen, wie sie in der Datei erscheinen. Dies kann hilfreich sein, wenn Decision Studio das Format der Datei nicht erkennt.
  • Um die Einstellung der Formatdetails für eine Datei mit Feldern fester Breite zu erleichtern, können Sie eine externe Beschreibung der Daten mit kopieren und einfügen in die Tabelle im Dialogfeld „Dateiformat einstellen“ einfügen.

    Die Beschreibung kann in Form eines Excel-Tabellenkalkulation oder nur Text mit zwei oder drei Spalten, die durch Tabulator getrennte Werte enthalten, vorhanden sein. Die erste Datenspalte, die optional ist, enthält die Feldnamen, die beiden nächsten (oder nur zwei) Spalten enthalten die Beginn- und Endeposition der Felder.

  • Decision Studio basiert die erste Interpretation einer Datei auf einer Teilmenge der Datensätze. Um die Anzahl der von Decision Studio dafür verwendeten Datensätze zu ändern, ändern Sie die Einstellungen der Option „Datenformat Vorschaugröße“. Um die Empfindlichkeit von Decision Studio gegenüber schlecht formatierten Daten zu ändern, ändern Sie die Einstellungen der Option „Grobabschaltungs-Prozentsatz“.

    Wenn Decision Studio weitere Informationen zur korrekten Interpretation der Datei benötigt, wird eine größere Teilmenge Datensätze gelesen. Um die Anzahl der Datensätze, die Decision Studio in diesem Fall verwendet, zu ändern, ändern Sie die Einstellungen der Option „Datenvorschaugröße“.

  • Wenn die Datei vollständig in Decision Studio eingelesen wurde, wird die entsprechende Protokolldatei erstellt. Sie sollten diese Datei von Decision Studio während des Importprozesses auf ausgegebene Fehler oder Warnungen prüfen.

    In Portrait Miner können Sie auf [image] klicken, um zu dem Verzeichnis zu wechseln, das die Protokolldateien enthält – das Unterverzeichnis shared/logs (UNIX) oder shared\logs (Windows) des Portrait Miner-Installationsverzeichnisses.

    Die erforderliche Protokolldatei ist die neueste Protokolldatei, deren Namen mit dem Namen der Ursprungsdatei beginnt (Sie können die Protokolldateien in nach Datum/Uhrzeit sortieren indem Sie auf die Spaltenüberschrift der Spalte „Modifiziert“ klicken.)

  • Decision Studio ändert alle ungültigen Feldnamen in gültige.
  • Wenn eine Datei eine zugeordnete Dateibeschreibung (FDD) besitzt, können Sie diese zur Einstellung des anfänglichen Dateiformats verwenden. Klicken Sie in Schritt 1 des Prozesses auf „Importformat“. (Sie können das Format wie gewohnt verändern)

    Alternativ können Sie den Assistenten „Neuer Fokus“ mit einem Doppelklick auf die FDD-Datei in Portrait Miner starten.

  • Ein Integerwert wird im Assistenten „Neuer Fokus“ als „klein“ eingestuft, wenn er als short Integer [siehe Datentypen] in einer FDD-Datei spezifiziert wurde. Ein short Integerfeld benötigt weniger Speicherplatz als ein normales Integerfeld, kann jedoch nur einen begrenzten Umfang von Werten aufnehmen.
  • Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen zuzugreifen, die über die Datenerstellungsbefehle qsgenfdd und qsimportflat von Portrait Miner bereitgestellt werden.

Siehe auch

Einen Fokus aus Daten in einer Datenbank erstellen

leer Zeilen

Extraktion max. Fehler

Extraktion max. Warnungen

Extraktionswarnungen ignorieren

Datenformatfehler zulassen

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Übergeordnetes Thema: Arbeiten mit Dateien, Datenbank-Tabellen und Fokussen


Einen Fokus aus Daten in einer Datenbank erstellen

Um einen Datensatz in Form einer Datenbanktabelle (oder einer Kombination aus Tabellen und Ansichten) mit Portrait Miner zu analysieren, müssen Sie zunächst einen Fokus aus den Daten in der Datenbank erstellen.
Übergeordnetes Thema: Arbeiten mit Dateien, Datenbank-Tabellen und Fokussen

Importieren von Daten aus einer Datenbanktabelle

Um Daten zu importieren:
  • Navigieren Sie in Portrait Miner zur Registerkarte Datenbank, und öffnen Sie eine Datenbankverbindung. Weitere Informationen finden Sie unter Eine Datenbankverbindung herstellen.
  • Doppelklicken Sie auf die Datenbanktabelle oder klicken Sie mit der rechten Maustaste darauf und wählen Sie Öffnen.

Das Dialogfeld „Neuer Fokus“ wird angezeigt:

Dieser Dialog „Neuer Fokus“ enthält eine Vorschau auf die Daten, einschließlich der Feldnamen und -typen.
  • Klicken Sie im Fensterbereich „Fokus speicher als“ Sie auf „Durchsuchen“ und navigieren [siehe Navigieren zum Öffnen oder Speichern einer Datei, Sitzung oder einer Datenbanktabelle] Sie, um einen Speicherort für den Fokus auszuwählen.
  • Klicken Sie auf „OK“, um den neuen Fokus zu erstellen.

Wenn Sie nicht alle Felder aus der Tabelle importieren möchten, klicken Sie auf „Felder auswählen“. Das Dialogfeld „Felder auswählen“ wird geöffnet:

Alle Felder aus der externen Datenquelle, die importiert werden können, werden zunächst im Fensterbereich „Einschließen“ angezeigt.
  • Benutzen Sie die Pfeilschaltflächen, um die Felder der Tabelle, die Sie in Ihrem Fokus verwenden möchten, auszuwählen.

    Die Schaltflächen [image] und [image] verschieben markierte Felder, wohingegen die Schaltflächen [image] und [image] alle Felder aus einem Fensterbereich in einen anderen verschieben.

    Verwenden Sie die Schaltflächen [image] und [image] auf der rechten Seite des Fensters, um markierte Felder im Fensterbereich „Einschließlich“ neu anzuordnen.

  • Nachdem Sie die gewünschten Felder ausgewählt haben, klicken Sie auf „OK“, um zum Dialogfeld „Neuer Fokus“ zurückzukehren.
Anmerkung:
  • Sie können auf diese Weise keine Spalten importieren, wenn deren Namen keine gültigen FDL-Identifizierer [siehe Basisausdrücke] sind.
  • Felder mit reellen Zahlen, die mit mehr als 15 Nachkommastellen in einer Datenbank vorhanden sind, werden von Portrait Miner standardmäßig als Stringfelder behandelt. Durch Änderung der Option „Bei Import numerische Typen beibehalten“ können Sie erzwingen, dass sie als reelle Felder (mit abgeschnittenen Nachkommastellen) behandelt werden.

Siehe auch

Einen Fokus aus Daten in einer Textdatei erstellen

Eine Datenbankverbindung herstellen

Datenimport durch Datenbankabfrage

Sie können einen Fokus aus einer Kombination aus Tabellen und Ansichten in einer Datenbank erstellen, indem Sie eine SQL-Abfrage, die die von Ihnen benötigten Daten auswählt, aufbauen.
  • In Portrait Miner doppelklicken Sie auf eine SQL-Datei, die die von Ihnen gewünschte Abfrage enthält oder führen Sie einen Rechtsklick auf der Datei aus und wählen Sie „Öffnen“.

Im Dialogfeld „Aus Abfrage importieren“ wählen Sie einen Speicherort für den zu erstellenden Fokus aus; geben Sie ggf. die SQL-Abfrage ein oder modifizieren Sie sie und wählen Sie eine Datenbankverbindung [siehe Eine Datenbankverbindung herstellen].

Anmerkung:
  • Wenn Sie das Dialogfeld „Aus Abfrage importieren“ mit einer SQL-Datei öffnen, leitet Portrait Miner einen Fokusnamen aus dem Dateinamen ab und verwendet den Inhalt der Datei als erste SQL-Abfrage. Sobald das Dialogfeld geöffnet ist, ist die Datei selber nicht mehr relevant: Die Abfrage im Dialogfeld, nicht die Abfrage in der Datei, wird ausgeführt.
  • Die SQL-Abfrage wird an die Datenbank als einzelnes Statement unverändert weitergegeben, ein abschließendes Semikolon ist nicht erforderlich (und kann bei einigen Datenbanken eine ungültige Syntax darstellen).
  • Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl „qsimportdb“ in Portrait Miner bereitgestellt werden, zuzugreifen.

Siehe auch

Informationen über Portrait Miner-Assistenten

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten


Erstellen eines Fokus aus SAS oder einem Datensatz einer dritten Partei

Um Portrait Miner für die Analyse eines Drittanbieter-Datensatzes verwenden zu können, müssen Sie aus dem Datensatz einen Fokus erstellen. Porträt Miner kann Daten aus verschiedenen Drittanbieter-Datensätzen importieren, einschließlich der von SAS, SPSS und Excel. (Siehe http://support.quadstone.com/info/requirements/ für eine vollständige Liste der unterstützten Formate.)
Übergeordnetes Thema: Arbeiten mit Dateien, Datenbank-Tabellen und Fokussen

Einen Fokus aus einem SAS-Dataset erstellen

  • Doppelklicken Sie in Porträt Miner auf die Datenssatzdatei, die Sie importieren möchten, oder klicken Sie mit der rechten Maustaste und wählen Sie „Öffnen“.

Im Dialogfeld „Fokus importieren“ können Sie die Felder auswählen, die Sie importieren möchten (standardmäßig werden alle Felder importiert) und entscheiden, ob Sie Feld- und Wert-Label-Metadaten in den erstellten Fokus importieren möchten. Zusätzlich können Sie den Standort des neuen Fokus ändern oder sich entscheiden, den Ausgabefokus zu überschreiben.

Anmerkung:
  • SAS-Metadaten werden aus einer „format.sas7bcat“-SAS Katalogdatei gelesen, die im selben Ordner wie der SAS Quellen-Datensatz vorhanden sein muss.
  • Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl „qsimportstat“ in Portrait Miner bereitgestellt werden, zuzugreifen.
  • Sie können eine Revision eines Drittanbieter-Datensatzes durchführen [siehe Für einen Fokus ein Profil erstellen und prüfen] ohne vorher einen Fokus zu erstellen: Klicken Sie einfach mit der rechten Maustaste auf den Datensatz in Portrait Miner und wählen Sie „Überprüfen“.

Erstellen eines Fokus von einem Excel- oder einem anderen Drittanbieter-Datensatz

  • Doppelklicken Sie in Porträt Miner auf die Datensatzdatei, die Sie importieren möchten, oder klicken Sie mit der rechten Maustaste und wählen Sie „Öffnen“.

Im Dialogfeld „Fokus importieren“ können Sie die Felder auswählen, die Sie importieren möchten (standardmäßig werden alle Felder importiert). Zusätzlich können Sie den Standort des neuen Fokus ändern oder sich entscheiden, den Ausgabefokus zu überschreiben.

Anmerkung:
  • Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl „qsimportstat“ in Portrait Miner bereitgestellt werden, zuzugreifen.
  • Sie können eine Revision eines Drittanbieter-Datensatzes durchführen [siehe Für einen Fokus ein Profil erstellen und prüfen] ohne vorher einen Fokus zu erstellen: Klicken Sie einfach mit der rechten Maustaste auf den Datensatz in Portrait Miner und wählen Sie „Überprüfen“.
  • Sie können eine Excel-Arbeitsmappe in Excel öffnen, indem Sie mit Porträt Miner mit der rechten Maustaste darauf klicken und „Nach Excel übertragen“ wählen.

Siehe auch

Informationen über Portrait Miner-Assistenten

Einen Fokus aus Daten in einer Datenbank erstellen

Einen Fokus aus Daten in einer Textdatei erstellen

Exportieren von Datensätzen in eine SAS-Datei oder einen anderen Drittanbieter-Datensatz


Exportieren von Datensätzen in eine Datendatei, Datenbanktabelle oder Fokus

Sie können Datensätze aus einem Fokus in eine Flatfile, Datenbanktabelle oder in einen anderen Fokus von Decision Studio exportieren. Sie können sie aber auch mithilfe von Portrait Miner in eine Flatfile [siehe Datensätze mit Portrait Miner in eine Datei exportieren], in einen anderen Fokus [siehe Exportieren von Datensätzen zu einem Fokus mit Portrait Miner], einen SAS-Datensatz oder den Datensatz eines anderen Drittanbieters [siehe Exportieren von Datensätzen in eine SAS-Datei oder einen anderen Drittanbieter-Datensatz] exportieren.
Übergeordnetes Thema: Arbeiten mit Dateien, Datenbank-Tabellen und Fokussen

Export von Datensätzen aus Decision Studio eine Datei, Datenbanktabelle oder Fokus

Sie können Datensätze aus dem Fokus oder markierten Segmenten in einer grafischen Darstellung in eine Datei, eine Datenbanktabelle oder einen anderen Fokus exportieren.
  1. Führen Sie einen der folgenden Schritte aus:
    • Wählen Sie im Decision Studio-Fenster die Optionen „Fokus> Daten exportieren“.
    • Markieren Sie im Profilansicht, Kreuzverteilungsansicht, Zuordnungsansicht oder Entscheidungsbaum-Werkzeug die Segmente [siehe Segmente in einer Diagrammanzeige markieren], die Sie exportieren möchten und wählen Sie dann „Segmente“ oder klicken Sie in der Symbolleiste auf [image].

    Das Dialogfeld „Datensätze exportieren“ wird angezeigt:

  2. Klicken Sie auf die Schaltfläche „Durchsuchen“.
  3. Navigieren Sie [siehe Navigieren zum Öffnen oder Speichern einer Datei, Sitzung oder einer Datenbanktabelle] an die gewünschte Stelle und wählen Sie einen Namen und einen Typ für die exportierte Datenmenge aus.
  4. Wenn Sie eine Teilmenge der Felder im Fokus wählen möchten, klicken Sie auf die Schaltfläche „Auswählen“.

    Ein Dialogfeld „Feldauswahl“ wird angezeigt, mit allen Feldern zunächst im Bereich „Auswählen“ (es sei denn, Sie haben einige Felder im Fokus als Export-Felder [siehe Für das Festlegen oder Leeren eines Analysekandidaten, einer kategorischen, geografischen, Export-oder Zielinterpretation] interpretiert, in welchem Fall diese Felder ausgewählt werden):

    Mit den Pfeiltasten wechseln Sie zwischen den Bereichen „Nicht auswählen“ und „Auswählen“, um die Felder auszuwählen, die Sie im exportierten Datensatz anzeigen möchten.

    Die Schaltflächen [image] und [image] verschieben markierte Felder, wohingegen die Schaltflächen [image] und [image] alle Felder aus einem Fensterbereich in einen anderen verschieben.

    Verwenden Sie die Schaltflächen [image] und [image] auf der rechten Seite des Fensters, um markierte Felder im Fensterbereich „Ausgewählt“ neu anzuordnen.

  5. Wenn Sie eine Datei erstellen, klicken Sie gegebenenfalls auf „Format“, um das Exportformat zu steuern [siehe Export-Format der Datei steuern].
  6. Klicken Sie auf „OK“, um die Daten zu exportieren.

Datensätze mit Portrait Miner in eine Datei exportieren

Um Datensätze zu exportieren:
  • Klicken Sie in Portrait Miner auf den zu exportierenden Fokus und wählen Sie „Export>als Text“.

Im Dialogfeld „Export Text“ können im zu exportierenden Fokus die Felder auswählen und den Namen der Ausgabedatei und den Speicherort ändern. Klicken Sie auf „Weiter“, um die die Registerkarte „Format“ anzuzeigen und wählen Sie die Exportoptionen, ähnlich wie bei dem Dialogfeld „Exportoptionen“ [siehe Export-Format der Datei steuern] für die Ausgabedatei.

Anmerkung:
  • Sie können wählen, welche Felder exportiert werden sollen, indem Sie Feldnamen oder einen oder mehrere Tags [siehe Arbeiten mit Feldgruppen] auswählen.
  • Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl „qsexportflat“ in Portrait Miner bereitgestellt werden, zuzugreifen.

Siehe auch

Informationen über Portrait Miner-Assistenten

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Export-Format der Datei steuern

Wenn Sie in Decision Studio im Dialogfeld Datensätze exportieren auf Format klicken, wenn Sie Daten in eine Datei exportieren, wird das Dialogfeld Exportoptionen angezeigt:

Hier können Sie einen Feld-Separator spezifizieren, ein String, der an der Stelle der Null verwendet wird [siehe Der Nullwert] Wert, das Format für Datumswerte und ob Einzel- oder Doppelanführungszeichen (oder keine) rund um den String verwendet werden sollen. Wenn Sie sich dafür entscheiden, dass Anführungszeichen um Stringwerte verwendet werden sollen, haben Sie die Möglichkeit, sie für alle Werte zu benutzen (statt nur, wenn der Inhalt des Wertes es notwendig macht).

Wenn Sie eine Textdatei als Exportdatei wählen, haben Sie die Möglichkeit, zusätzlich eine Dateibeschreibung (FDD) zu erzeugen. Wenn Sie eine FDD-Datei als ihre Exportdatei wählen (in diesem Fall erstellt Portrait Miner automatisch eine oder mehrere verbundene Dateien), ist die Möglichkeit, eine FDD-Datei zu erzeugen, bereits markiert.

Sie können Feldnamen am Anfang Ihrer Dateien einfügen, indem Sie die Option „Spaltenüberschriften“ markieren.

Sie können Daten in einem Format mit fester Breite exportieren, indem Sie die Option „Feste Spaltenbreite“ markieren. Die Spaltenbreiten in diesem Format hängen von der Art und Größe der einzelnen Felder ab.

Exportieren von Datensätzen in eine SAS-Datei oder einen anderen Drittanbieter-Datensatz

Portrait Miner kann Daten in verschiedene statistische Formate von Drittanbietern exportieren, einschließlich für SAS, SPSS und Excel.

Klicken Sie in Portrait Miner auf den zu exportierenden Fokus und wählen Sie „Export>für ein anderes Programm“.

Im Dialogfeld „Export für ein anderes Programm“ können Sie die zu exportierenden Felder wählen und das Zielprogramm für den Export sowie den Speicherort der Ausgabedatei ändern.

Anmerkung:
  • Sie können wählen, welche Felder exportiert werden sollen, indem Sie Feldnamen oder einen oder mehrere Tags [siehe Arbeiten mit Feldgruppen] auswählen.
  • Wenn Sie nicht angeben, welche Felder exportiert werden sollen, exportiert Portrait Miner alle Felder in dem Fokus.
  • Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl „qsexportstat“ in Portrait Miner bereitgestellt werden, zuzugreifen.

Siehe auch

Informationen über Portrait Miner-Assistenten

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Exportieren von Datensätzen zu einem Fokus mit Portrait Miner

Sie können einen Teil der Felder oder Datensätze aus einem bestehenden Fokus zu einem neuen Fokus exportieren.

Klicken Sie in Portrait Miner auf den zu exportierenden Fokus und wählen Sie „Export>als Fokus“. Im Dialogfeld „Export als Fokus“ können Sie die zu exportierenden Felder und den Speicherort des exportierten Fokus auswählen. Sie können außerdem mithilfe eines FDL-Ausdrucks einen Teil der Datensätze im Fokus auswählen [siehe Formeln].

Anmerkung:
  • Sie können wählen, welche Felder exportiert werden sollen, indem Sie Feldnamen oder einen oder mehrere Tags [siehe Arbeiten mit Feldgruppen] auswählen.
  • Wenn Sie nicht angeben, welche Felder exportiert werden sollen, exportiert Portrait Miner alle Felder in dem Fokus.
  • Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl „qsimportfocus“ in Portrait Miner bereitgestellt werden, zuzugreifen.

Siehe auch

Informationen über Portrait Miner-Assistenten

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten


Informatinoen zur Kombination von Fokussen

Portrait Miner bietet zwei Wege für die Kombination der „Felder“ von mehreren Fokussen, um einen neuen Fokus zu erstellen. Der 1. („Fokus verknüpfen“) ist eine Variante von einer Linksverknüpfung. Sie können „Fokus verknüpfen“ in Portrait Miner [siehe So vereinen Sie Felder aus einem Fokus mit einem anderen Fokus mit Portrait Miner] verwenden oder über den qsjoin Portrait Miner-Dateierstellungsbefehl verknüpfen.

Die 2. Methode benutzt Decision Studio für den Import von Feldern aus einem Fokus in eine Variante von Linksverknüpfung mit zwei Tabellen.

Auch können Sie die Datensätze mehrerer Fokusse in Portrait Miner [siehe Die Datensätze zweier Fokusse vereinen] oder über den qsmerge Portrait Miner-Dateierstellungsbefehl verknüpfen.

Siehe auch

dblookup

Die Datensätze zweier Fokusse vereinen

Übergeordnetes Thema: Arbeiten mit Dateien, Datenbank-Tabellen und Fokussen


So vereinen Sie Felder aus einem Fokus mit einem anderen Fokus mit Portrait Miner

Wenn zwei Fokusse grundlegende Felder mit gleichem Namen und Typ gemeinsam nutzen, können Sie die ausgewählten Felder mit einem anderen Fokus zu einem neuen Fokus verbinden, vorausgesetzt, dass beide Fokusse anhand der Schlüsselfelder (gemäß der Standard-Sortierreihenfolge in Portrait Miner) sortiert [siehe Einen Fokus sortieren] sind.
Felder von einem zum anderen Fokus vereinen:
  • Klicken Sie in Portrait Miner mit der rechten Maustaste auf einen Fokus und wählen Sie „Kombinieren>Felder vereinen“.

Im Dialogfeld Felder vereinen können Sie den Sekundärfokus, aus dem die Felder hinzugefügt werden sollen, auswählen und bis zu drei Schlüsselfelder verwenden, um die ausgewählten Felder im Primärfokus zu vereinen. Sie können den Speicherort des neuen Fokusses ändern oder, anstatt einen neuen Fokus zu erstellen, einen früher erstellten Ausgabefokus überschreiben.

Anmerkung:
  • Der Verknüpfungsprozess ist im Wesentlichen eine „Linksverknüpfung“ (Ihr erster Fokus ist die Tabelle auf der linken Seite). Wenn jedoch ein Kunde mit mehr als einem Datensatz im ersten Fokus vorhanden ist, stimmt Portrait Miner die Datensätze für diesen Kunden mit den nachfolgenden Datensätzen für denselben Kunden im anderen Fokus ab. Die Anzahl der Datensätze im neuen Fokus im immer dieselbe wie die Anzahl der Datensätze im ersten Fokus.
  • Die Schlüsselfelder in den beiden Fokussen müssen beide Stringfelder, beide Datumsfelder oder beide numerische Felder sein.
  • Sie können wählen, welche Felder hinzugefügt werden sollen, indem Sie Feldnamen oder einen oder mehrere Tags [siehe Arbeiten mit Feldgruppen] auswählen.
  • Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl „qsjoin“ in Portrait Miner bereitgestellt werden, zuzugreifen.

Siehe auch

Informationen über Portrait Miner-Assistenten

Informatinoen zur Kombination von Fokussen

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Übergeordnetes Thema: Arbeiten mit Dateien, Datenbank-Tabellen und Fokussen


So vereinen Sie Felder aus einem Fokus mit einem anderen Fokus mit Decision Studio

Wenn zwei Fokusse grundlegende Felder mit gleichem Namen und Typ gemeinsam nutzen, können Sie die ausgewählten Felder mit einem anderen Fokus zu einem neuen Fokus verbinden. Um dies zu tun, müssen Sie sicherstellen, dass beide Fokusse nach den Schlüsselfeldern, in Übereinstimmung mit der Standard-Sortierreihenfolge von Portrait Miner, sortiert sind.
  1. Öffnen Sie den ersten Fokus im Decision Studio und wählen Sie „Fokus> Felder importieren“.
  2. Navigieren Sie [siehe Navigieren zum Öffnen oder Speichern einer Datei, Sitzung oder einer Datenbanktabelle] zum zweiten Fokus und klicken Sie auf „Importieren“.

    Das Dialogfeld „Felder importieren“ wird angezeigt:

  3. Im Bereich „Join-Schlüsselfeld auswählen“ wählen Sie die entsprechenden Schlüsselfelder für den ersten Fokus und den zweiten Fokus.
  4. Klicken Sie auf „Felder auswählen“ im Bereich „Felder auswählen“, um die Felder auszuwählen, die Sie aus dem zweiten Fokus auszuwählen möchten. Zumindest müssen Sie das externe Schlüsselfeld für die Verknüpfung auszuschließen.

    Das Dialogfeld „Felder auswählen„ wird mit allen Feldern aus dem zweiten Fokus angezeigt, die zunächst im Bereich „Einschließlich“ waren:

    Benutzen Sie die Pfeiltasten, um zwischen den Bereichen „Ausschließlich“ und „Einschließlich“ zu navigieren und die Felder auszuwählen, die Sie verknüpfen möchten.

    Die Schaltflächen [image] und [image] verschieben markierte Felder, wohingegen die Schaltflächen [image] und [image] alle Felder aus einem Fensterbereich in einen anderen verschieben.

    Verwenden Sie die Schaltflächen [image] und [image] auf der rechten Seite des Fensters, um markierte Felder im Fensterbereich „Einschließlich“ neu anzuordnen.

  5. Klicken Sie zurück im Dialogfeld „Felder importieren“ auf „OK“.
Anmerkung:
  • Die Verknüpfungs-Operation ist im Wesentlichen ein „left join“ (mit dem ersten Fokus als Tabelle auf der linken Seite). Wenn es allerdings einen Kunden mit mehr als einem Datensatz im zweiten Fokus gibt, berücksichtigt Decision Studio nur den ersten Datensatz des Kunden. Deshalb, wenn Sie Felder mit Decision Studio verbinden, bliebt die Anzahl der Datensätze im Fokus immer gleich.
  • Decision Studio schließt automatisch ein beliebiges Feld in dem zweiten Fokus aus, das den gleichen Namen wie ein Feld im ersten Fokus hat.
  • Die Schlüsselfelder in den beiden Fokussen müssen beide Stringfelder, beide Datumsfelder oder beide numerische Felder sein.

Siehe auch

Informatinoen zur Kombination von Fokussen

So vereinen Sie Felder aus einem Fokus mit einem anderen Fokus mit Portrait Miner

Übergeordnetes Thema: Arbeiten mit Dateien, Datenbank-Tabellen und Fokussen


Die Datensätze zweier Fokusse vereinen

Angenommen, Sie haben zwei Fokusse mit Feldern gleichen Namens, Typs und Datensätzen nach den Schlüsselfeldern sortiert [siehe Einen Fokus sortieren] (entsprechend der Portrait Miner-Standardsortierfolge), dann können Sie die Datensätze in den Fokussen vereinen, um einen neuen Fokus zu erstellen, der die Datensätze aus beiden Fokussen enthält. Der neue Fokus wird auf die dieselbe Weise sortiert wie die Originalfokusse.

Klicken Sie in Portrait Miner mit der rechten Maustaste auf dem Primärfokus und wählen Sie „Kombinieren>Felder vereinen“.

Wählen Sie im Dialogfeld „Datensätze vereinen“ den Sekundärfokus aus und spezifizieren die Schlüsselfelder. Sie können auch einen Speicherort für den Ausgabefokus auswählen.

Anmerkung:
  • Standardmäßig wird ein Datensatz des Sekundärfokusses, der dieselben Schlüssel wie der Primärfokus aufweist, verworfen. Sie können dieses Verhalten durch markieren des entsprechenden Kontrollkästchens im Dialogfeld ändern.
  • Um zwei Fokusse zu vereinen müssen die zu vereinigenden Felder kompatible Datentypen enthalten.
  • Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl „qsmerge“ in Portrait Miner bereitgestellt werden, zuzugreifen.

Siehe auch

Informationen über Portrait Miner-Assistenten

Informatinoen zur Kombination von Fokussen

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Übergeordnetes Thema: Arbeiten mit Dateien, Datenbank-Tabellen und Fokussen


Eine Datenbankverbindung herstellen

Um sich mit einer Datenbank verbinden zu können, müssen Sie zunächst eine Datenbankverbindung aufbauen.
  1. Auf der Registerkarte „Datenbanken“ in Portrait Miner klicken Sie auf „Neue Verbindung“.

    Das Dialogfeld „Datenbankverbindung bearbeiten“ erscheint.

  2. Geben Sie den DSN (Data Source Name - Name der Datenquelle) für die Datenbank ein.

    Bitten Sie Ihren Systemadministrator um Hilfe, wenn Sie sich nicht sicher sind.

  3. Geben Sie den Benutzernamen und das Kennwort ein, mit dem Sie sich bei der Datenbank anmelden.
  4. Klicken Sie auf „OK“.

    In der Liste der in Portrait Miner verfügbaren Datenbanken erscheint eine neue Datenbankverbindung.

Anmerkung:
  • Portrait Miner speichert Ihre Datenbankverbindungen in verschlüsselter Form auf der Festplatte. Nachdem Sie eine Datenbankverbindung hergestellt haben, müssen Sie Ihren Benutzernamen oder Ihr Kennwort für die Datenbank nicht erneut eingeben, solange diese nicht gewechselt wird. Wenn Sie Ihre Verbindungsdaten ergänzen müssen, markieren Sie die Verbindung im Abschnitt „Verfügbare Datenbanken“ auf der Registerkarte „Datenbanken“ und klicken auf „Verbindung bearbeiten“.
  • Es ist möglich, dass Ihr Systemadministrator eine „unvollständige“ Datenbankverbindung für Sie eingerichtet hat, die nur aus einem DSN besteht. Bevor Sie eine Verbindung zur Datenbank herstellen können, müssen Sie diese Datenbankverbindung vervollständigen: Markieren Sie die unvollständige Datenbankverbindung und klicken Sie auf „Verbindung bearbeiten“, um Ihren Benutzernamen und Ihr Kennwort einzugeben.
  • Diese Benutzerschnittstelle ist ein Weg, um die durch den Portrait Miner Datenaufbaubefehl „qsdbaccess“ bereitgestellte Funktionalität zu nutzen.

Siehe auch

Wie Portrait Miner-Datenbanktypen importiert

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Übergeordnetes Thema: Arbeiten mit Dateien, Datenbank-Tabellen und Fokussen


Wie Portrait Miner-Datenbanktypen importiert

Übergeordnetes Thema: Arbeiten mit Dateien, Datenbank-Tabellen und Fokussen

In Portrait Miner aus einer Datenbank importieren

Portrait Miner ordnet die folgenden Datenbanktypen seinen Datentypen anhand der Größe des Datenbanktyps und den Optionseinstellungen für die „Datenbanken“ zu.
Datenbanktyp | Nachkommastellen | Präzision | große Ganzzahlen als Zeichenfolgen repräsentieren | Bei Import numerische Typen beibehalten | Portrait Miner-Feldtyp
char, char2, varchar, varchar2, nchar, nchar2, nvarchar, nvarchar2 |  |  |  |  | Zeichenfolge
date, time, timestamp, datetime, smalldatetime |  |  |  |  | date
int, integer, tinyint, smallint, byteint, bit |  |  |  |  | ganze Zahl
bigint |  |  | false false true | true false | Reelle Zahl Zeichenfolge string
decimal, dec, numeric, number | < 0 | 15 > 15 > 15 |  | true false | Reelle Zahl Reelle Zahl Zeichenfolge
decimal, dec, numeric, number | 0 | 0 10 > 10 [image] 15 > 15 > 15 > 10 | false false false true | true false | Reelle Zahl ganze Zahl Reelle Zahl Reelle Zahl Zeichenfolge string
float, double, real |  |  |  |  | Reelle Zahl
decimal, dec, numeric, number | > 0 | 15 > 15 > 15 |  | true false | Reelle Zahl Reelle Zahl Zeichenfolge
money |  |  |  | true false | Reelle Zahl Zeichenfolge
smallmoney |  |  |  |  | Reelle Zahl
Anmerkung:
  • In mit [image] markierten Zeilen kann ein gerinfügiger Genauigkeitsverlust auftreten.
  • In mit [image] markierten Zeilen werden Werte, die zu lang sind, um sie als Integer zu speichern, in Null konvertiert.

Siehe auch

große Ganzzahlen als Zeichenfolgen repräsentieren

Bei Import numerische Typen beibehalten

Von Portrait Miner in eine Datenbank exportieren

Die Datenbanktypen, die Portrait Miner exportiert, hängen sowohl von der Zieldatenbank als auch dem ODBC-Treiber ab. Portrait Miner empfiehlt einen geeigneten Typ für die Datenbank, die sie angeben, während der ODBC-Treiber diese Empfehlung in einen der Typen in der Datenbank interpretiert.

Siehe auch

Eine Datenbankverbindung herstellen


Verwenden des Data Build Manager für das Importieren, Verarbeiten und Exportieren von Daten

Der Data Build Manager ist eine Anwendung in Portrait Miner, die Datenvorbereitung und Modelleinsatz unterstützt.

Für die Erstellung eines Fokus oder für den Einsatz eines Modells verwenden Sie typischerweise eine Reihe von Dateierstellungsbefehlen [siehe Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten] und andere Vorgänge. Das von Hand zu tun benötigt Zeit und es können sich schnell Fehler einschleichen. Es könnte auch der Fall sein, dass Sie eine unbeaufsichtigte reguläre Dateierstellung oder einen Anwendungsvorgang durchführen möchten, vielleicht über Nacht. Sollte etwas schiefgehen (wie z. B. Speicherplatz geht aus), möchten Sie wahrscheinlich das Problem beheben und ab dem unterbrochenen Punkt fortsetzen, anstatt wieder von vorne beginnen zu müssen. Auch wenn die Operationen für die sukzessive Erstellung in einigen Umfängen zu Überlappungen führt, können Sie Zeit sparen, indem Sie diese Operationen einmal ausführen. Aber es ist schwierig, die Abhängigkeiten zwischen den Operationen im Auge zu behalten und es wird leicht vergessen, welche Operationen bereits ausgeführt wurden.

Der Data Build Manager verwendet eine spezielle Datei, auch Strukturplan genannt, die beschreibt, wie ein Analysedatensatz erstellt oder ein Modell eingesetzt wird. Der Strukturplan enthält eine Reihe von „Zielen“ mit den Abhängigkeiten dazwischen und die für die Erstellung der Ziele erforderlichen Operationssequenzen.

Öffnen eines Strukturplans (eine .qsb-Datei):
  • Doppelklicken Sie in Portrait Miner auf die Datei oder klicken Sie mit der rechten Maustaste auf die Datei und wählen Sie „Öffnen“.

Sie können die Details des Strukturplans begutachten, indem Sie im Fenster „Strukturplan“ auf die Elemente klicken und die Beschreibung im rechten Fenster ablesen.

Die Hierarchie (oder „Baumansicht“) der Elemente im Fenster „Strukturplan“ erinnert an die Dateisystemansicht in Portrait Miner oder Windows Explorer und Sie können die Bestandteile der Ansicht auf ähnliche Weise erweitern und zusammenklappen. Verwenden Sie „Optionen>Baum erweitern“ (oder „Optionen>Baum zusammenfalten“), um die voll erweiterte (oder zusammengefaltete) Hierarchie anzuzeigen.

Oben in der Hierarchie befindet sich ein Element, das den Strukturplan selber repräsentiert. Zu anderen Elementen, die von besonderem Interesse sind, gehören die Ziele (mit [image] oder ähnlich gekennzeichnet) und die Parameter (mit [image] gekennzeichnet).

Um einem Parameter einen Wert zuzuordnen, markieren Sie den Parameter im Fenster „Strukturplan“ und bearbeiten den Wert im Fenster „Parameter“ rechts.

Nachdem Sie die Parameter entsprechend festgelegt haben, führen Sie Ihren Strukturplan aus, indem Sie auf „Erstellen“ klicken. Ein Fortschrittsfenster erscheint. Klicken Sie auf „Stopp“, während der Job ausgeführt wird, um die Ausführung des Strukturplans anzuhalten. Nachdem der Job abgeschlossen ist, klicken Sie auf „Fertig“, um das Fortschrittsfenster zu schließen.

Anmerkung:
  • Der Strukturplan verwendet ein Dateiformat auf XML-Basis. Weitere Informationen über den Data Build Manager und über das Format von Strukturplänen finden Sie unter „Verwenden des Data Build Manager“.
  • Der Data Build Manager stellt eine Möglichkeit für den Zugriff auf die Funktionen dar, die über den Dateierstellungsbefehl qsbuild in Portrait Miner bereitgestellt werden.

Siehe auch

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

XML in Portrait Miner

Übergeordnetes Thema: Arbeiten mit Dateien, Datenbank-Tabellen und Fokussen


Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Wie auch bei der Anwendung Decision Studio, enthält Portrait Miner eine umfangreiche Suite mit Befehlszeilen-Dienstprogrammen, die sogenannten Portrait Miner-Dateierstellungsbefehle. Sie können die Dateierstellungsbefehle für eine Vielzahl von Aufgaben einsetzen:
  • Import/Export von Daten zwischen Fokussen, Dateien und Datenbanktabellen
  • Verarbeitung der Daten im Fokussen (sortieren, ableiten, messen usw.)
  • Fokusse zusammenführen
  • Verwaltung von Fokusdateien (kopieren, verschieben, umbenennen und löschen)
  • Erzeugen von Berichten

Die Dateierstellungsbefehle sind insbesondere dann nützlich, wenn komplexe Dateierstellungsvorgänge automatisiert werden, da Sie diese mit UNIX Shell-Skripten oder Windows-Stapeldateien kombinieren können.

Siehe „Portrait Miner Dateierstellungsbefehl und TML-Referenz“ für detaillierte Informationen über die einzelnen Befehle.

Anmerkung: Um diese Dateierstellungsbefehle zu verwenden, müssen Sie über Zugriffsrechte für die Befehlszeile von Portrait Miner verfügen. Bitten Sie Ihren Systemadministrator bei der Konfiguration Ihres Befehlspfades darum, dass er das Verzeichnis mit den Befehlen berücksichtigt.

Siehe auch

Verwenden des Data Build Manager für das Importieren, Verarbeiten und Exportieren von Daten
Übergeordnetes Thema: Arbeiten mit Dateien, Datenbank-Tabellen und Fokussen


Mit Decision Studio arbeiten

  • Mit Decision Studio Tools arbeiten
  • Mit Listen und tabellarischen Daten in Decision Studio arbeiten
  • Mit Decision Studio arbeiten


Mit Decision Studio Tools arbeiten

  • Decision Studio Tools
  • Tool-Zuordnungen
  • Tools miteinander verknüpfen und Verknüpfungen aufheben
  • Zur Maximierung eines Bildschirms in einem Decision Studio-Tool
Übergeordnetes Thema: Mit Decision Studio arbeiten


Decision Studio Tools

Diese Decision Studio Tools stehen zur Visualisierung, Segmentierung und Modellierung von benutzerdefinierten Datensätzen zur Verfügung:
Tool | Zweck
Tabellenansicht
  • Anzeigen Ihres Fokus auf dem Stand der individuellen Kundendatensätze
  • Felder mithilfe von FDL ableiten
Klasseneditor | Kundendatensätze in einem Feld nach Werten oder Kategorien gruppieren
Kreuztabellenansicht | Zusammenfassungen in Tabellenform anzeigen
Kreuzverteilungsansicht | Zusammenfassungen als Kreuzverteilungsdiagramm mit einer bis drei Variablen anzeigen
Profilansicht | Zusammenfassungen in einer Gruppe von Segmentierungen mit einer Variable anzeigen
Zuordnungsansicht | Zusammenfassungen auf einer geografischen oder anderweitig voreingestellten Karte anzeigen
Entscheidungsbaum-Werkzeug | Entscheidungsbaum-Segmentierungen Ihrer Kundendatensätze erstellen
Scorecard Builder | Scorecard-Modelle Ihrer Kundendatensätze erstellen
Clustermodell-Werkzeug | Clustermodelle Ihrer Kundendatensätze erstellen

Um ein Decision Studio Tool zu starten, wählen Sie entweder den Namen aus dem Menü „Tools“ oder klicken Sie auf die entsprechende Schaltfläche in der Symbolleiste.

Übergeordnetes Thema: Mit Decision Studio Tools arbeiten


Tool-Zuordnungen

Jedes Decision Studio Tool [siehe Decision Studio Tools] benötigt eine Datenquelle, ob es sich dabei nun um anzuzeigende Daten handelt oder um Daten, auf denen ein Modell basieren soll. Normalerweise ist die Datenquelle für ein Tool der Fokus, der bereits geöffnet ist, unter Berücksichtigung aller vorhandener Datensatzauswahlen [siehe Auswahl von Kundendatensätzen].

Sie können auch mit einem oder mehreren Tools einem anderen „folgen“ [siehe Tools miteinander verknüpfen und Verknüpfungen aufheben], sodass, wann immer Sie ein Segment [siehe Segmente in einer Diagrammanzeige markieren] mit dem „vorangehenden“ Tool markieren, die „nachfolgenden“ Tools das Segment als Datenquelle behandeln.

Ein nachfolgendes Tool kann wiederum einem weiteren Tool vorangehen. Sie können die Zuordnung zwischen den Tools im Bereich „Tool-Hierarchie“ des Decision Studio-Fensters ansehen, welcher sich auf der linken Seite des Hauptfensters der Registerkarte „Fokus“ befindet. Beachten Sie, dass dies nicht die Standard-Registerkarte ist und normalerweise ausgeblendet ist:

In diesem Beispiel benutzen Tabellenansicht 5 und Profilansicht 6 den Fokus „DBUSA“ als Datenquelle. Kreuzverteilungsansicht 4 folgt Profilansicht 6 nach.

Anmerkung:
  • Wenn keine Segmente grafisch in einem Tool markiert sind (ist immer der Fall, wenn das Tool Tabellenansicht, Scorecard-Werkzeug oder Clustermodell-Werkzeug ist), wird die eigene Datenquelle des Tools als Datenquelle für nachfolgende Tools verwendet.
  • So wie ein Fokus verbundene Klasseneinteilungen haben kann, ist dieses auch bei der Ausgabe eines Tools möglich. Sie können die mit der Ausgabe eines Tools verbundenen Klasseneinteilungen bearbeiten, indem Sie einen Klasseneditor mit dieser Ausgabe verknüpfen [siehe Tools miteinander verknüpfen und Verknüpfungen aufheben]. Wenn Sie aber verschiedene Segmente im Tool auswählen (sodass sich die Ausgabe ändert), verwirft Decision Studio sämtliche von Ihnen erstellte Klasseneinteilungen.

Siehe auch

Weitere Details in einem ausgewählten Segment eines Diagramms anzeigen
Übergeordnetes Thema: Mit Decision Studio Tools arbeiten

Selektive Anzeige der Tool-Hierarchie

  • Klicken Sie auf ein Symbol [image] (ausgeblendet) oder [image] (eingeblendet), um einen Teil der Hierarchieansicht ein- bzw. auszublenden.

Ein Tool-Fenster in den Vordergrund bringen

Entweder Doppelklick auf dem Tool-Namen im Fensterbereich der Tool-Hierarchie oder Sie klicken mit der rechten Maustaste auf den Tool-Namen und wählen „In den Vordergrund“.


Tools miteinander verknüpfen und Verknüpfungen aufheben

Übergeordnetes Thema: Mit Decision Studio Tools arbeiten

Verknüpfen eines geöffneten Tools mit der Ausgabe eines anderen Tools

In jeder Symbolleiste eines Tools befindet sich oben rechts ein Dropdownmenü mit der Bezeichnung Vorgänger, in dem ein anderes Tool als Datenquelle ausgewählt werden kann. Alternativ können Sie im Tool-Hierarchie-Fensterbereich [siehe Tool-Zuordnungen] im Decision Studio-Fenster das Symbol, das den gewünschten Nachfolger repräsentiert, auf das Symbol, das den gewünschten Vorgänger repräsentiert, ziehen.

Öffnen eines neuen Tools als Nachfolger eines anderen Tools

Klicken Sie im Tool-Hierarchie-Fensterbereich [siehe Tool-Zuordnungen] im Decision Studio-Fenster auf den zu markierenden Namen des gewünschten Vorgängers.

Alle Tools, die Sie anschließend starten, werden mit dem markierten Tool verlinkt.

Um das Standardverhalten für neue Tools umzukehren, markieren Sie stattdessen den Fokus oben im Fensterbereich „Tool-Hierarchie“.

Anmerkung: Sie können ein verlinktes Tool auch starten, indem Sie mit der rechten Maustaste auf einen künftigen Vorgänger im Fensterbereich „Tool-Hierarchie“ klicken und den künftigen Nachfolger aus dem Menü „Drill-down in“ wählen.

Siehe auch

Weitere Details in einem ausgewählten Segment eines Diagramms anzeigen

Eine Verknüpfung zwischen Tools aufheben

Führen Sie einen der folgenden Schritte aus:
  • Wählen Sie im Dropdown-Menü „Vorgänger“ auf der Symbolleiste „Keinen“.
  • Ziehen Sie im Fensterbereich „Tool-Hierarchie“ [siehe Tool-Zuordnungen] des Decision Studio-Fensters das Symbol, das den Nachfolger repräsentiert, auf das Symbol, das den Fokus repräsentiert.
  • Verknüpfen Sie das nachfolgende Tool mit einem anderen Vorgänger.
  • Schließen Sie das Vorgänger-Tool.

    Das Nachfolger-Tool wird dann mit dem Fokus oder dem Tool verlinkt, das die Datenquelle für den ursprünglichen Vorgänger gestellt hat.

Anmerkung: Wenn Sie ein Tool-Symbol in der Tool-Hierarchie an einen anderen Ort ziehen, folgen alle Tools, die damit verlinkt sind, dem Vorgänger auch weiterhin nach.


Zur Maximierung eines Bildschirms in einem Decision Studio-Tool

Wählen Sie „Ansicht“ oder betätigen Sie F11

Das Fenster wird maximiert und die Symbolleiste und andere Elemente der Benutzeroberfläche werden ausgeblendet, um den verfügbaren Platz zum Anzeigen des Hauptbereichs des Fensters zu vergrößern.

Wiederholen Sie diesen Vorgang, um zur ursprünglichen Ansicht zurückzukehren.

Übergeordnetes Thema: Mit Decision Studio Tools arbeiten


Mit Listen und tabellarischen Daten in Decision Studio arbeiten

  • Sortierung in Listen und Tabellen
  • Exportieren von tabellarischen Daten aus Decision Studio
  • Festlegen des Anzeigeformats für numerische und Datumswerte
Übergeordnetes Thema: Mit Decision Studio arbeiten


Sortierung in Listen und Tabellen

In den meisten Tabellen in Decision Studio (nennenswerte Ausnahmen sind Ansichten im Tabellenansicht und Kreuztabellenansicht) können Sie die Zeilen auf verschiedene Weise neu anordnen, indem Sie mit der rechten Maustaste auf eine Spaltenüberschrift klicken und eine Sortieroption auswählen.

Auch in den meisten Listen in Decision Studio können Sie die Reihenfolge der Listenelemente neu anordnen, indem Sie mit der rechten Maustaste irgendwo in die Liste klicken.

In den meisten Fällen stehen drei Standardoptionen für die Sortierung zur Verfügung: unsortiert (das ist die vorgegebene Reihenfolge), auf- und absteigend; aber es können auch zusätzliche Optionen vorhanden sein, je nach der Art der Daten in der Liste oder Spalte.

Anmerkung:
  • An den meisten Stellen ist es so, dass wenn Sie wiederholt (mit der linken Maustaste) auf die Überschrift einer Spalte der Tabelle klicken, Decision Studio durch die verfügbaren Optionen für die Sortierung rollt. Falls es viele Optionen gibt, ist es meist einfacher mit der rechten Maustaste zu klicken und aus dem Menü zu wählen; bei den Spalten, mit nur drei Standard-Optionen für die Sortierung, ist die gewünschte Zeilenanordnung nur zwei Mausklicks entfernt.
  • Im Decision Studio-Fenster hat die Spalte „Interpretationen“ Optionen für das Sortieren nach jedem der möglichen Interpretationstypen. Wenn Sie beispielsweise „Sortieren nach Kategorie“ wählen, zeigt Decision Studio Felder mit kategorischen Klasseneinteilungen vor anderen Feldern.
  • Die Spalte Benutzer-Kennzeichnungen im Hauptfenster kann nicht sortiert werden.
  • Sortieren von Zeilen in einer Tabelle oder von Punkten in einer Liste betrifft in der Regel nur auf die Art und Weise, wie die Informationen im aktuellen Kontext erscheinen. Eine Ausnahme bildet das Neuordnen von Kategorien [siehe Kategorien neu ordnen] in einer kategorischen Klasseneinteilung: jedes Decision Studio Tool, das Klasseneinteilung verwendet, zeigt die Klassen in der Reihenfolge, die Sie im Klasseneditor angeben.

Siehe auch

Einen Fokus sortieren
Übergeordnetes Thema: Mit Listen und tabellarischen Daten in Decision Studio arbeiten


Exportieren von tabellarischen Daten aus Decision Studio

Sie können „Bearbeiten>Kopieren“ verwenden, um tabellarische Daten aus Decision Studio Werkzeugen in die Zwischenablage zu kopieren, genauso wie in anderen Windows-Anwendungen. Es gibt vier Varianten für den Standardkopiervorgang in die Zwischenablage:
Option | Zweck
Alle Tabellen kopieren | Kopieren der Zellen aus allen Tabellenbereichen, anstatt nur aus dem aktuellen.
Ohne Kopfzeilen kopieren | Zeilen- und Spaltenüberschriften auslassen.
Mit wiederholten Beschriftungen kopieren | Die Beschriftungen jeder Zeile und jeder Spalte wiederholen (dies kann bei der Erstellung von Pivottabellen in Excel hilfreich sein).
Erweiterte Segmente kopieren | Kopieren Sie die Daten in ein zweispaltiges Listenformat anstatt in ein Tabellenformat.

Es ist auch möglich, Zellen in der tabellarischen Ansicht zu markieren und die Daten direkt in eine Windows-Anwendung (wie Microsoft Excel), die die Daten in einem tabellarischen Format lesen kann, zu ziehen.

Sie können auch Daten aus tabellarischen Ansichten und Kreuztabellen [siehe Kreuztabellen als Basis für die Segmentierung und Visualisierung von Daten] aus Decision Studio direkt in Microsoft Excel kopieren und wenn Sie tabellarische Daten in Decision Studio haben, die Sie mit Kollegen gemeinsam nutzen möchten, können Sie diese per Email versenden.

Übergeordnetes Thema: Mit Listen und tabellarischen Daten in Decision Studio arbeiten

Bereiche einer Tabelle markieren

Sie können einen oder mehrere rechteckige Bereiche in einer tabellarischen Ansicht wie in anderen Windows-Anwendungen markieren. In den meisten Ansichten können Sie auf die Beschriftungen klicken, um ganze Zeilen oder Spalten in der Tabelle zu markieren.

Tabellarischen Daten in Microsoft Excel exportieren

Sie können tabellarische Ansichten oder darunter liegende Kreuztabellen in eine Excel-Datei kopieren:
  • Um eine tabellarische Ansicht in eine Excel-Datei zu kopieren, gehen Sie folgendermaßen vor:
    • Wählen Sie im Tabellenansicht „Datei>Ansicht nach Excel“.
    • Wählen Sie im Entscheidungsbaum-Werkzeug, Scorecard-Werkzeug oder Clustermodell-Werkzeug „Datei>Exportieren>Ansicht nach Excel“.
    • Klicken Sie in der Symbolleiste auf [image].
  • Um Kreuztabellendaten aus dem Kreuztabellenansicht oder Profilansicht in eine Excel-Datei zu kopieren, wählen Sie „Datei>Exportieren>Kreuztabelle nach Excel“ oder klicken Sie in der Symbolleiste auf [image].
Anmerkung:
  • Beim Export der Daten nach Excel wird eine neue Arbeitsmappe erstellt.
  • Wenn Sie Zellen in einer tabellarischen Ansicht [siehe Bereiche einer Tabelle markieren] markieren, exportiert Decision Studio nur diese Zellen nach Excel. Andernfalls wird die gesamte Tabelle oder Kreuztabelle nach Excel exportiert.
  • Wenn Sie „Ansicht als Excel-Link“ anstatt „Ansicht nach Excel“ oder „Kreuztabelle als Excel-Link“ anstatt „Kreuztabelle nach Excel“ auswählen, erstellen Sie eine dynamische Verknüpfung, so dass alle Änderungen in Ihrer tabellarischen Ansicht oder Kreuztabelle automatisch nach Excel übertragen werden.


Festlegen des Anzeigeformats für numerische und Datumswerte

  1. Wählen Sie im Decision Studio-Fenster die Optionen Bearbeiten > Einstellungen anzeigen.

    Das Dialogfeld „Format“ erscheint. Eines der fünf Registerfenster steuert die Anzeigeformate für numerische und Datumswerte:

    Bereich | Beschreibung
    Datenanzeige | Die Anzahl der angezeigten Dezimalstellen für Zahlen; die Ausrichtung der Zahlen; ob führende Nullen bei der Anzeige von Dezimalbrüchen entfernt werden sollen; ob ein Tausendertrennzeichen (Gebietsschema-spezifisch) bei der Anzeige von Zahlen verwendet werden soll; ob das Datum im amerikanischen (MM/DD/YYYY), europäischen (DD/MM/YYYY) oder im JMT-Format (YYYY/MM/DD) angezeigt werden soll; ob die Zeitanzeige im 12-Stunden- oder 24-Stunden-Format angezeigt werden soll
  2. Klicken Sie auf „OK“, um vorgenommene Änderungen zu speichern und das Dialogfeld zu schließen.
Anmerkung: Ihre Einstellungen gelten für die aktuelle Sitzung und für zukünftige Sitzungen mit Decision Studio und Portrait Miner. Sie gelten jedoch nicht für das Importieren und Exportieren von Dateien oder für die Bewertung von FDL-Ausdrücken.

Siehe auch

Festlegen globaler Optionen für grafische Anzeigen
Übergeordnetes Thema: Mit Listen und tabellarischen Daten in Decision Studio arbeiten


Mit Decision Studio arbeiten

  • Ausrichten einer Diagrammanzeige mit Hilfe der Maus
  • Segmente in einer Diagrammanzeige markieren
  • Exportieren grafischer Ansichten von Decision Studio
Übergeordnetes Thema: Mit Decision Studio arbeiten


Ausrichten einer Diagrammanzeige mit Hilfe der Maus

Ziehen Sie die Diagramm- oder die Entscheidungsbaumanzeige mit Hilfe einer der drei Maustasten:
  • Um das Diagramm zu drehen, ziehen Sie mit der linken Maustaste.
  • Um das Diagramm von einer Seite zur anderen oder vertikal zu verschieben, ziehen Sie mit der rechten Maustaste.
  • Um das Diagramm zu sich hin oder von sich weg zu bewegen, ziehen Sie mit der mittleren Maustaste hoch/runter.
Anmerkung:
  • Wenn Ihre Maus nur zwei Tasten hat, können Sie die mittlere Maustaste emulieren, indem Sie die Alt-Taste gedrückt halten, während Sie die linke Maustaste betätigen.
  • Wenn Sie einen Entscheidungsbaum mit der rechten Maustaste bewegen, ziehen Sie auf den Hintergrund, um das bei einem rechten Mausklick auf einem Segment erscheinende Popup-Menü zu vermeiden.
Übergeordnetes Thema: Mit Decision Studio arbeiten

Wiederherstellen der ursprünglichen Anzeige

Wählen Sie „Ansicht>Start“ oder klicken Sie in der Symbolleiste auf [image].

Anmerkung:

Wenn im Zuordnungsansicht die Menüoption „Ansichten>Auto“ markiert ist, war die ursprüngliche Ansicht möglicherweise eine Draufsicht und entsprach nicht der Ansicht der Option „Ansichten>Home“.

Draufsicht eines Kartendiagramms

Wählen Sie „Ansicht>Oben“ oder klicken Sie in der Symbolleiste auf [image].

Vergrößern ausgewählter Segmente in einem Entscheidungsbaum

  1. Markieren Sie die Segmente [siehe Segmente in einer Diagrammanzeige markieren], die Sie interessieren.
  2. Wählen Sie „Ansicht>Auswahl vergrößern“, oder drücken Sie Strg+B, oder klicken Sie in der Symbolleiste auf [image]. Alternativ können Sie mit der rechten Maustaste auf eines der markierten Segmente klicken, und wählen dann „Auswahl Vergrößern“.

    Der Entscheidungsbaum-Werkzeug vergrößert (oder verkleinert), sodass die markierten Segmente und Ihre Sub-Segmente sichtbar sind.

Anmerkung:

Wenn keine Segmente markiert sind, hat „Ansicht>Auswahl vergrößern“ (oder [image]) den gleichen Effekt wie „Ansicht>Start“ (oder [image]).


Segmente in einer Diagrammanzeige markieren

Sie können Segmente in Diagrammanzeigen im Klasseneditor, Profilansicht, Kreuzverteilungsansicht, Zuordnungsansicht und Entscheidungsbaum-Werkzeug markieren. Markierte Segmente können als Datenquelle für verlinkte Tools verwendet werden [siehe Tool-Zuordnungen], und um Felder abzuleiten, indem sie beschrieben werden [siehe Ableiten eines Feldes von einer grafischen Segmentierung].
Übergeordnetes Thema: Mit Decision Studio arbeiten

Markieren eines einzelnen Segments

Klicken Sie auf das Segment, um es zu markieren.
Anmerkung:
  • Wenn das Segment bereits als Teil einer Gruppe von Segmenten markiert ist, klicken Sie zuerst auf den Hintergrund, um die bestehende Markierung aufzuheben.
  • Um im Zuordnungsansicht ein Segment zu markieren, das durch eine Linienverknüpfung dargestellt wird (im Gegensatz zu einem Block), klicken Sie auf den Pfeil in der Mitte der Linienverknüpfung.

Markierungen löschen oder auf mehr als ein Segment erweitern

Führen Sie einen der folgenden Schritte aus:
  • Halten Sie auf der Tastatur die Strg-Taste gedrückt und klicken Sie auf ein Segment.

    Das Segment wird markiert, falls es das nicht schon vorher war, und umgekehrt.

  • Halten Sie die Strg-Taste gedrückt und ziehen Sie mit der linken Maustaste, um ein „Gummiband“-Rechteck zu erstellen.

    Wenn Sie die Maustaste loslassen, werden Segmente, die vollständig oder teilweise in dem Rechteck liegen, markiert, falls sie das nicht schon waren, und umgekehrt.

Anmerkung: Im Zuordnungsansicht können Sie Blöcke oder Linienverknüpfungen auswählen, allerdings nicht gleichzeitig. Wenn Sie ein „Gummiband“-Rechteck über einen Bereich ziehen, der sowohl Blöcke als auch Linienverknüpfungen enthält, werden nur die Blöcke ausgewählt.


Exportieren grafischer Ansichten von Decision Studio

Wenn Sie im Profilansicht, Kreuzverteilungsansicht, Zuordnungsansicht, Entscheidungsbaum-Werkzeug oder Scorecard-Assistent eine grafische Darstellung haben und Sie diese in einen Bericht bringen oder mit Kollegen gemeinsam nutzen möchten, können Sie die Ansicht als Datei speichern.
Übergeordnetes Thema: Mit Decision Studio arbeiten

So speichern Sie ein Diagramm in einer Datei

Im Profilansicht, Kreuzverteilungsansicht, Zuordnungsansicht, Entscheidungsbaum-Werkzeug oder Scorecard-Assistent wählen Sie Datei>Export>Als Bild anzeigen und navigieren zu [siehe Navigieren zum Öffnen oder Speichern einer Datei, Sitzung oder einer Datenbanktabelle] einem Speicherort, wo Sie das Diagramm speichern möchten.

Decision Studio exportiert das Bild als JPEG-Datei.

Anmerkung:
  • Decision Studio speichert ein Diagramm in der gleichen Größe, wie es im Viewer oder Modellierungswerkzeug wird angezeigt.
  • Um ein gespeichertes Diagramm in einem Bericht zu benutzen, importieren oder platzieren Sie die Datei in Ihrem Zieldokument.
  • Im Profilansicht können Sie auch „Datei>Export>Als HTML anzeigen“ benutzen, um eine Webseite mit der aktuellen Ansicht zu erstellen.


Arbeiten mit dem PSS Connector

  • Einleitung
  • Portrait Miner-Erweiterungen
  • Decision Studio-Erweiterungen
  • Authentifizierung
  • Befehlszeilenerweiterungen
  • Exportieren von Regeln über die Portrait Miner-Benutzeroberfläche
  • Exportieren von Regeln im Batch


Einleitung

Der Portrait Shared Services (PSS) Connector unterstützt die Integration zwischen Portrait Miner und anderen Produkten der Portrait Suite, unter anderem: Portrait Dialogue, Portrait Interaction Optimizer und Portrait Explorer.

Informationen zur Installation des PSSConnector finden Sie unter Installieren des PSSConnector im Portrait Miner-Administratorhandbuch.

Übergeordnetes Thema: Arbeiten mit dem PSS Connector


Portrait Miner-Erweiterungen

Die folgenden Erweiterungen sind in Portrait Miner verfügbar.

  • In der Symbolleiste kann sich der Benutzer über die Schaltfläche Verbindung zu Portrait Shared Services verwalten bei Portrait Shared Services anmelden oder abmelden. Mit einem Windows-basierten Portrait Customer Analytics-Server wird Ihre Verbindung zu Portrait Shared Services automatisch über die Windows-Authentifizierung hergestellt, sofern dies möglich ist. Um eine Verbindung über ein anderes Konto herzustellen, müssen Sie sich abmelden und dann mit den entsprechenden Anmeldeinformationen erneut anmelden.
  • In der Symbolleiste kann der Benutzer über die Schaltfläche Regeln im Portrait Shared Repository verwalten die Liste der Analyseregeln anzeigen, die im Repository veröffentlicht wurden. Sie müssen eine logische PSS-Domäne auswählen und können dann die Regeln anzeigen, die in dieser Domäne veröffentlicht wurden. Sie können eine Regel als QMML-Datei wieder zurück in das Serverdateisystem exportieren. Klicken Sie dazu mit der rechten Maustaste auf eine Regel, und wählen Sie Speichern unter.
  • Wenn Sie bei der Auswahl einer .qmml-Datei in Miner im Kontextmenü auf Regel im Portrait Shared Repository veröffentlichen klicken, wird die Modell-QMML als Regel im Portrait Shared Repository veröffentlicht. Sie werden aufgefordert, den Namen, den Typ und die Beschreibung für die Regel sowie den Namen der logischen PSS-Domäne anzugeben, in der diese veröffentlicht werden soll.

Die Symbolleistenanwendungen stehen auch über das Start-Menü von Portrait Miner zur Verfügung.

Übergeordnetes Thema: Arbeiten mit dem PSS Connector


Decision Studio-Erweiterungen

Mithilfe der Portrait Shared Services-Erweiterungen für Decision Studio kann der Benutzer eine abgeleitetes Feld als Regel im Portrait Shared Repository veröffentlichen, von wo aus sie von anderen Anwendungen verwendet werden kann.

Regeln können nur von der Tabellenansicht aus veröffentlicht werden.

Die Tabellenansicht von Decision Studio verfügt auch über die Anwendung Verbindung zu Portrait Shared Services verwalten, über die sich der Benutzer mit einem expliziten Benutzernamen und Kennwort oder, wenn möglich, über die Windows-Authentifizierung anmelden oder abmelden kann. Die Anwendung bietet dieselben Funktionen wie in Portrait Miner.

Mithilfe der Kreuztabellenansicht von Decision Studio können Sie die aktuelle Kreuztabelle in PSS veröffentlichen. Diese Kreuztabellenspezifikationen können dann beim Erstellen von Berichten in der Portrait Explorer-Anwendung in Marketing HQ verwendet werden.

Übergeordnetes Thema: Arbeiten mit dem PSS Connector


Authentifizierung

Sie müssen bei Portrait Shared Services authentifiziert sein, um im Portrait Shared Repository gespeicherte Regeln verwalten, veröffentlichen oder abrufen zu können.

Wenn Ihr Windows-Anmeldekonto in der Admin-Anwendung von Portrait Dialogue als Windows-Authentifizierungskonto konfiguriert ist, werden Sie von Miner-Anwendungen automatisch authentifiziert und müssen keine besonderen Maßnahmen zur Anmeldung ergreifen. Derartige Konten brauchen auch in den Befehlszeilendienstprogrammen keinen -username oder -password-Optionen.

Wenn Sie ein Anmeldekonto verwenden, das nicht für die Windows-Authentifizierung konfiguriert ist, müssen Sie sich von Portrait Miner aus explizit anmelden. Die Anwendungen Portrait Miner und Decision Studio fordern Sie automatisch zur Eingabe Ihrer Anmeldeinformationen auf, wenn Sie noch nicht angemeldet sind. Die Befehlszeilendienstprogramme benötigen die Optionen -username und -password.

Sobald Sie sich von einer der Portrait Miner-Anwendungen aus angemeldet haben, bleiben Sie solange angemeldet, bis Sie die Anwendung beenden oder sich explizit abmelden. Sie müssen sich bei jeder Anwendung, die Sie ausführen, getrennt anmelden.

Übergeordnetes Thema: Arbeiten mit dem PSS Connector


Befehlszeilenerweiterungen

Erweiterungen für den Datenerstellungsbefehl (DBC)

Die folgenden DBCs werden von der Erweiterung bereitgestellt. Alle diese Befehle benötigen die expliziten Argumente -username und -password, wenn für Ihr Benutzerkonto keine Windows-Authentifizierung in Portrait Campaign Manager aktiviert wurde.

  • Datenerstellungsbefehle für Zuordnungen (.xml-Dateien)
  • Datenerstellungsbefehle für Regeln (.qmml-Dateien)
  • Datenerstellungsbefehle für Entscheidungsoptimierungen (.qsor-Dateien)
  • Datenerstellungsbefehle für Explorer-Datensätze
Übergeordnetes Thema: Arbeiten mit dem PSS Connector


Datenerstellungsbefehle für Zuordnungen (.xml-Dateien)

  • pssmappingpublish
  • pssmappingretrieve
Übergeordnetes Thema: Befehlszeilenerweiterungen


pssmappingpublish

Dieser Befehl wird verwendet, um einen Satz von Regeleingabezuordnungen zu einer Kundendomäne im Portrait Shared Repository zu veröffentlichen. Die Parameter für den Befehl sind:
Regeleingabe-Zuordnungsdatei im Portrait Shared Repository veröffentlichen

     Erforderlich:
       -domain <Domänenname>
          Die Portrait Campaign Manager-Kundendomäne, in der die Zuordnungen veröffentlicht
          werden
       -input <XML-Zuordnungsdatei>
          Die Datei, welche die  Regeleingabe-Zuordnungsdefinition enthält

     Optional:
       -username <Benutzername>
          Das zu verwendende Portrait Shared Services-Benutzerkonto. Optional, wenn Sie
          eine Verbindung über die Windows-Authentifizierung herstellen können.
       -password <Kennwort>
       Das Kennwort für das Portrait Shared Services-Benutzerkonto.
Übergeordnetes Thema: Datenerstellungsbefehle für Zuordnungen (.xml-Dateien)


pssmappingretrieve

Dieser Befehl ruft einen Satz von Regeleingabezuordnungen für eine Kundendomäne ab und speichert sie in einer XML-Datei. Die Parameter für den Befehl sind:
Regeleingabezuordnungen vom Portrait Shared Repository abrufen und in einer Datei speichern.

     Erforderlich:
       -domain <Domänenname>
          Die Portrait Campaign Manager-Kundendomäne, von der die Zuordnungen
          abgerufen werden.
       -output <XML-Zuordnungsdatei>
          Der Name der Datei, in die die Zuordnungsdefinition geschrieben werden soll.

     Optional:
       -username <Benutzername>
          Das zu verwendende Portrait Shared Services-Benutzerkonto. Optional, wenn Sie
          eine Verbindung über die Windows-Authentifizierung herstellen können.
       -password <Kennwort>
       Das Kennwort für das Portrait Shared Services-Benutzerkonto.
Übergeordnetes Thema: Datenerstellungsbefehle für Zuordnungen (.xml-Dateien)


Datenerstellungsbefehle für Regeln (.qmml-Dateien)

  • pssrulepublish
  • pssrulelist
  • pssruleretrieve
  • pssruledescribe
Übergeordnetes Thema: Befehlszeilenerweiterungen


pssrulepublish

Dieser Befehl wird verwendet, um den Inhalt einer QMML-Datei als Regel im Portrait Shared Repository zu veröffentlichen. Die Parameter für den Befehl sind:
QMML-Regel im Portrait Shared Repository veröffentlichen.

     Erforderlich:
       -domain <Domänenname>
          Die Portrait Campaign Manager-Kundendomäne, in der die Regel
          veröffentlicht werden soll.
       -name <Regelname>
          Der zur Veröffentlichung dieser Regel im Repository zu verwendende Name.
       -description <Text | @Dateiname>
          Beschreibung für die Regel. Wenn die Form @Dateiname verwendet wird, nehmen Sie die
          Beschreibung aus einer Datei. Optional mit -replace.
       -type <Wert | Tendenz | Uplift>
          Der Typ der zu veröffentlichen Regel – Wert, Tendenz oder Uplift.
          Optional mit -replace.
       -input <QMML-Datei>
          Der Name der QMML-Datei, die die Regel enthält. Die Datei darf
          nur einen einzigen Regelsatz enthalten, und der Regelsatz darf nur eine einzige Ausgabe haben.

     Optional:
       -username <Benutzername>
          Das zu verwendende Portrait Shared Services-Benutzerkonto. Optional, wenn Sie
          eine Verbindung über die Windows-Authentifizierung herstellen können.
       -password <Kennwort>
          Das Kennwort für das Portrait Shared Services-Benutzerkonto.
       -replace
          Ersetzt die QMML einer vorhandenen Regel, anstatt eine neue zu veröffentlichen.
          Beim Ersetzen sind die Parameter -type und -description optional.
Übergeordnetes Thema: Datenerstellungsbefehle für Regeln (.qmml-Dateien)


pssrulelist

Dieser Befehl wird verwendet, um die Details aller Regeln aufzuführen, die einer bestimmten Domäne zugeordnet sind. Die Liste der Regeln wird in reiner Textform zurückgegeben. Sie kann aber auch als XML-Dokument angezeigt werden. Die Parameter für den Befehl sind:
Alle Regeln in einer Kundendomäne im Portrait Shared Repository aufführen.

     Erforderlich:
       -domain <Domänenname>
          Die Kundendomäne, von der die Regeln abgerufen werden.

     Optional:
       -username <Benutzername>
          Das zu verwendende Portrait Shared Services-Benutzerkonto. Optional, wenn Sie
          eine Verbindung über die Windows-Authentifizierung herstellen können.
       -password <Kennwort>
          Das Kennwort für das Portrait Shared Services-Benutzerkonto.
       -xml
          Zeigt die Ausgabe im XML-Format an.
Übergeordnetes Thema: Datenerstellungsbefehle für Regeln (.qmml-Dateien)


pssruleretrieve

Dieser Befehl ruft die kompilierte QMML für eine Regel im Portrait Shared Repository ab. Die Parameter für den Befehl sind:
Eine QMML-Regel vom Portrait Shared Repository abrufen und in einer Datei speichern.

     Erforderlich:
       -domain <Domänenname>
          Die Kundendomäne, von der die Regel abgerufen wird.
       -name <Regelname>
          Der Name der veröffentlichten Regel im Portrait Shared Repository.
       -output <QMML-Datei>
          Der Name der Datei, in der die Regel gespeichert werden soll.

     Optional:
       -username <Benutzername>
          Das zu verwendende Portrait Shared Services-Benutzerkonto. Optional, wenn Sie
          eine Verbindung über die Windows-Authentifizierung herstellen können.
       -password <Kennwort>
          Das Kennwort für das Portrait Shared Services-Benutzerkonto.
Übergeordnetes Thema: Datenerstellungsbefehle für Regeln (.qmml-Dateien)


pssruledescribe

Dieser Befehl führt die Namen und Typen der Eingaben in und Ausgaben aus einer Regel im Portrait Shared Repository auf. Zeigt auch, wie die Regeleingabezuordnungen angewendet werden, indem die Zuordnung zu einem Feld oder einer Funktion beschrieben wird, falls die Zuordnung definiert ist. Die Parameter für den Befehl sind:
Eine QMML-Regel im Portrait Shared Repository beschreiben.

     Erforderlich:
       -domain <Domänenname>
          Die Portrait Campaign Manager-Kundendomäne
       -name <Regelname>
          Der Name der Regel in der Kundendomäne

     Optional:
       -username <Benutzername>
          Das zu verwendende Portrait Shared Services-Benutzerkonto. Optional, wenn Sie
          eine Verbindung über die Windows-Authentifizierung herstellen können.
       -password <Kennwort>
       Das Kennwort für das Portrait Shared Services-Benutzerkonto.
Übergeordnetes Thema: Datenerstellungsbefehle für Regeln (.qmml-Dateien)


Datenerstellungsbefehle für Entscheidungsoptimierungen (.qsor-Dateien)

  • pssoptpublish
  • pssoptlist
  • pssoptretrieve
  • pssoptreport
  • pssoptdescribe
Übergeordnetes Thema: Befehlszeilenerweiterungen


pssoptpublish

Dieser Befehl wird verwendet, um den Inhalt einer QSOR-Ergebnisdatei für Entscheidungsoptimierungen im Portrait Shared Repository zu veröffentlichen. Die Parameter für den Befehl sind:
 Eine Entscheidungsoptimierung im Portrait Shared Repository veröffentlichen.

     Erforderlich:
       -domain <Domänenname>
          Die Portrait Campaign Manager-Kundendomäne, in der die Optimierung
          veröffentlicht werden soll.
       -name <Regelname>
          Der zur Veröffentlichung dieser Optimierung im Repository zu verwendende Name.
       -description <Text | @Dateiname>
          Beschreibung für die Optimierung. Wenn die Form @Dateiname verwendet wird, nehmen Sie die
          Beschreibung aus einer Datei. Optional mit -replace.
       -input <QSOR-Datei>
          Der Name der Ergebnisdatei der Entscheidungsoptimierung.

    Optional:
       -username <Benutzername>
          Das zu verwendende Portrait Shared Services-Benutzerkonto.
       -password <Kennwort>
          Das Kennwort für das Portrait Shared Services-Benutzerkonto.
       -replace
           Ersetzt die Details einer vorhandenen Optimierung, anstatt eine
           neue zu veröffentlichen. Beim Ersetzen ist der Parameter -description optional.
Übergeordnetes Thema: Datenerstellungsbefehle für Entscheidungsoptimierungen (.qsor-Dateien)


pssoptlist

Dieser Befehl wird verwendet, um die Details aller Entscheidungsoptimierungen aufzuführen, die einer bestimmten Domäne zugeordnet sind. Die Liste der Optimierungen wird in reiner Textform zurückgegeben. Sie kann aber auch als XML-Dokument angezeigt werden. Die Parameter für den Befehl sind:
Alle Entscheidungsoptimierungen in einer bestimmten Kundendomäne im
Portrait Shared Repository aufführen.

     Erforderlich:
       -domain <Domänenname>
          Die Kundendomäne, von der die Optimierungen abgerufen werden.

     Optional:
       -username <Benutzername>
          Das zu verwendende Portrait Shared Services-Benutzerkonto.
       -password <Kennwort>
          Das Kennwort für das Portrait Shared Services-Benutzerkonto.
       -xml
          Zeigt die Ausgabe im XML-Format an.
Übergeordnetes Thema: Datenerstellungsbefehle für Entscheidungsoptimierungen (.qsor-Dateien)


pssoptretrieve

Dieser Befehl ruft eine Entscheidungsoptimierung vom Portrait Shared Repository ab. Die Parameter für den Befehl sind:
Eine Entscheidungsoptimierung vom Portrait Shared Repository abrufen und in einer Datei speichern.

     Erforderlich:
       -domain <Domänenname>
          Die Kundendomäne, von der die Optimierung abgerufen wird.
       -name <Optimierungsname>
          Der Name der veröffentlichten Entscheidungsoptimierung im Portrait
          Shared Repository.
       -output <QSOR-Datei>
          Der Name der Datei, in der die Optimierung gespeichert werden soll.

     Optional:
       -username <Benutzername>
          Das zu verwendende Portrait Shared Services-Benutzerkonto.
       -password <Kennwort>
          Das Kennwort für das Portrait Shared Services-Benutzerkonto.
Übergeordnetes Thema: Datenerstellungsbefehle für Entscheidungsoptimierungen (.qsor-Dateien)


pssoptreport

Dieser Befehl ruft den zu einer Entscheidungsoptimierung gehörenden Bericht vom Portrait Shared Repository ab und speichert ihn in einer Datei. Die Parameter für den Befehl sind:
Einen zu einer Entscheidungsoptimierung gehörenden Bericht vom Portrait
Shared Repository abrufen und in einer Datei speichern.

     Erforderlich:
       -domain <Domänenname>
          Die Kundendomäne, von der die Optimierung abgerufen wird.
       -name <Optimierungsname>
          Der Name der veröffentlichten Entscheidungsoptimierung im Portrait
          Shared Repository.
       -output <HTML-Datei>
          Der Name der Datei, in der der Bericht gespeichert werden soll.

     Optional:
       -username <Benutzername>
          Das zu verwendende Portrait Shared Services-Benutzerkonto. Optional, wenn Sie
          eine Verbindung über die Windows-Authentifizierung herstellen können.
       -password <Kennwort>
          Das Kennwort für das Portrait Shared Services-Benutzerkonto.
Übergeordnetes Thema: Datenerstellungsbefehle für Entscheidungsoptimierungen (.qsor-Dateien)


pssoptdescribe

Dieser Befehl führt die Namen der Ergebnisse sowie die Namen und Typen der Eingaben in und Ausgaben aus einer Entscheidungsoptimierungsregel im Portrait Shared Repository auf. Zeigt auch, wie die Regeleingabezuordnungen angewendet werden, indem die Zuordnung zu einem Feld oder einer Funktion beschrieben wird, falls die Zuordnung definiert ist. Die Parameter für den Befehl sind:
Eine Entscheidungsoptimierung im Portrait Shared Repository beschreiben.

     Erforderlich:
       -domain <Domänenname>
          Die Portrait Campaign Manager-Kundendomäne
       -name <Optimierungsname>
          Der Name der Optimierung in der Kundendomäne

     Optional:
       -username <Benutzername>
          Das zu verwendende Portrait Shared Services-Benutzerkonto. Optional, wenn Sie
          eine Verbindung über die Windows-Authentifizierung herstellen können.
       -password <Kennwort>
          Das Kennwort für das Portrait Shared Services-Benutzerkonto.
Übergeordnetes Thema: Datenerstellungsbefehle für Entscheidungsoptimierungen (.qsor-Dateien)


Datenerstellungsbefehle für Explorer-Datensätze

  • pssdatasetupdate
Übergeordnetes Thema: Befehlszeilenerweiterungen


pssdatasetupdate

Dieser Befehl wird verwendet, um einen vorhandenen Portrait Explorer-Datensatz mit einer neuen Fokusdatei zu aktualisieren. Die Parameter für den Befehl sind:
Eine neue Datensatzversion für einen spezifisch benannten Datensatz im Portrait Shared Repository veröffentlichen

     Erforderlich:
       -name <Datensatzname>
          Der Name des Datensatzes im Portrait Shared Repository, für den die Datensatzversion sein soll.
       -input <Fokusdateipfad>
          Der Dateipfad auf dem Portrait Analytics Web Services-Servercomputer, der als
          Datensatzversion hochgeladen werden soll.
     Optional:
       -username <Benutzername>
          Das zu verwendende Portrait Shared Services-Benutzerkonto. Optional, wenn Sie
          eine Verbindung über die Windows-Authentifizierung herstellen können.
       -password <Kennwort>
          Das Kennwort für das Portrait Shared Services-Benutzerkonto.
       -timeout <Zeitlimitwert (in Minuten)>
          Die maximale Wartezeit nach der Initialisierung der Erstellung der Datensatzversion bis
          zum Abschluss der Erstellung (erfolgreich oder nicht erfolgreich). Wird dieses Argument nicht
          oder mit einem Wert 0 angegeben, wird der standardmäßige Zeitlimitwert von 10 Minuten verwendet.
          Hinweis: Wenn das Zeitlimit erreicht und der Prozess für diesen Befehl beendet wird, wird die
          Versionserstellung auf dem Server fortgeführt. Sie können sich an einen Explorer-Administrator wenden, um zu prüfen,
          ob die Erstellung der Datensatzversion letztlich erfolgreich oder nicht erfolgreich abgeschlossen wurde.
Übergeordnetes Thema: Datenerstellungsbefehle für Explorer-Datensätze


Exportieren von Regeln über die Portrait Miner-Benutzeroberfläche

  • Exportieren von Regeln aus Decision Studio
  • Exportieren von Regeln aus Portrait Miner
  • Erstellen von Kontaktoptimierungsregeln
Übergeordnetes Thema: Arbeiten mit dem PSS Connector


Exportieren von Regeln aus Decision Studio

Durch die PSSConnector-Plugin-Komponente verfügt die Benutzeroberfläche des Portrait Miner Decision Studio-Moduls über neue Schaltflächen in der Symbolleiste. Im Tabellenansichts-Tool wurde die neue Schaltfläche Regel im Portrait Shared Repository veröffentlichen hinzugefügt.

Über diese Schaltfläche können Sie die Regeldefinition eines abgeleiteten Feldes in die ausgewählte Kundendomäne in Portrait Dialogue exportieren. Wenn Sie den Namen einer bereits vorhandenen Regel angeben, wird die Definition der Regel aktualisiert.

Die Tabellenansicht von Decision Studio verfügt auch über eine Schaltfläche zum Starten der Anwendung Verbindung zu Portrait Shared Services verwalten, über die Sie sich mit einem expliziten Benutzernamen und Kennwort oder, wenn möglich, über die Windows-Authentifizierung anmelden oder abmelden können.

Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen zuzugreifen, die über den Datenerstellungsbefehl pssrulepublish bereitgestellt werden.

Übergeordnetes Thema: Exportieren von Regeln über die Portrait Miner-Benutzeroberfläche


Exportieren von Regeln aus Portrait Miner

Portrait Miner wurde erweitert und bietet jetzt eine alternative Schnittstelle, mit der Sie Analyseergebnisse in Portrait Dialogue integrieren können.
  • Authentifizierung In der Portrait Miner-Symbolleiste können Sie sich mithilfe der Anwendung Verbindung zu Portrait Shared Services verwalten bei Portrait Shared Services anmelden oder abmelden.

    Mit einem Windows-basierten Portrait Miner-Server wird Ihre Verbindung zu Portrait Shared Services automatisch über die Windows-Authentifizierung hergestellt, sofern dies möglich ist.

    Um eine Verbindung über ein anderes Konto herzustellen, müssen Sie sich abmelden und dann mit den entsprechenden Anmeldeinformationen erneut anmelden.
  • Anzeigen der exportierten Regeln: In der Portrait Miner-Symbolleiste ist es möglich, dass Sie sich mithilfe der Anwendung Regeln im Portrait Shared Repository verwalten die Liste der veröffentlichten Analyseregeln ansehen können. Sie müssen eine Kundendomäne auswählen und können dann die Regeln anzeigen, die in dieser Domäne veröffentlicht wurden. Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen zuzugreifen, die über die Datenerstellungsbefehle pssrulelist und pssruledescribe bereitgestellt werden.

    Sie können eine Regel als QMML-Datei wieder zurück in das Serverdateisystem exportieren. Klicken Sie dazu mit der rechten Maustaste auf eine Regel, und wählen Sie „Speichern unter“. Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen zuzugreifen, die über den Datenerstellungsbefehl pssruleretrieve bereitgestellt werden.

  • Regeln exportieren: Wenn Sie bei der Auswahl einer .qmml-Datei in Portrait Miner im Kontextmenü auf Regel im Portrait Shared Repository veröffentlichen klicken, können Sie die Modellbeschreibung (QMML) als Regel zur Verwendung in Portrait Dialogue veröffentlichen. Sie werden aufgefordert, den Namen, den Typ und die Beschreibung für die Regel sowie den Namen der Kundendomäne anzugeben, in der diese veröffentlicht werden soll. Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen zuzugreifen, die über den Datenerstellungsbefehl pssrulepublish bereitgestellt werden.

Die Symbolleistenanwendungen stehen auch über das Start-Menü von Portrait Miner zur Verfügung.

Übergeordnetes Thema: Exportieren von Regeln über die Portrait Miner-Benutzeroberfläche


Erstellen von Kontaktoptimierungsregeln

Portrait Optimizer ist eine Erweiterung zu Portrait Miner, mit deren Hilfe Sie Kontaktoptimierungsregeln erstellen und in Portrait Dialogue anwenden können. Weitere Details hierzu finden Sie im Portrait Optimizer-Benutzerhandbuch.

Übergeordnetes Thema: Exportieren von Regeln über die Portrait Miner-Benutzeroberfläche


Exportieren von Regeln im Batch

Die folgenden Datenerstellungsbefehle (DBCs) stehen Ihnen zur Verfügung, um im Rahmen eines Batch oder geplanten Prozesses Analyseregeln nach Portrait Dialogue exportieren zu können. Alle diese Befehle benötigen explizit die Argumente -username und -password, wenn für Ihr Benutzerkonto keine Windows-Authentifizierung aktiviert wurde.

  • Datenzuordnung
  • Regelintegration
  • Kontaktoptimierungsintegration
Übergeordnetes Thema: Arbeiten mit dem PSS Connector


Datenzuordnung

Wenn Ihre Analysedatensätze mithilfe von Feldnamen erstellt wurden, die sich von den zugrunde liegenden Feldnamen in Portrait Dialogue oder Interaction Optimizer unterscheiden oder durch Portrait Dialogue-Ausdrücke anstelle von Feldreferenzen aufgelöst werden müssen (z. B. wenn die Analyse für eine Transaktionsmessgröße durchgeführt wird), müssen Sie eine Definition der Regeleingabezuordnungen veröffentlichen. Diese steuert, wie Portrait Dialogue oder Interaction Optimizer die Daten für Eingabewerte, die von der Analyseregel benötigt werden, vom Zielsystem abruft, wenn eine Analyseregel oder Entscheidungsoptimierung in einer Dialogaktivität von Portrait Dialogue oder in einer Interaktion von Interaction Optimizer ausgeführt wird.

Anmerkung:
  • Für jedes Feld in der Zuordnungsdatei muss eine 1:1 Zuordnung bestehen. Mehrere Zuordnungen pro Quell- oder Zielfeld sind nicht zulässig.
  • pssmappingpublish
  • pssmappingretrieve
  • Format der Regeleingabezuordnung
Übergeordnetes Thema: Exportieren von Regeln im Batch


pssmappingpublish

Einen Satz von Regeleingabezuordnungen in einer logischen PSS-Domäne veröffentlichen.

Synopsis
pssmappingpublish -domain <domain name>-input <XML mappings file>
    [-password <password>][-replace][-username <username>]

Optionale Argumente

Option | Effekt
-password | Das Kennwort für Portrait Shared Services.
-username | Der Benutzername für Portrait Shared Services.
Übergeordnetes Thema: Datenzuordnung


pssmappingretrieve

Einen Satz von Regeleingabezuordnungen für eine logische PSS-Domäne abrufen und in einer XML-Datei speichern.

Synopsis
pssmappingretrieve -domain <domain name>
    -output <XML mappings file> -target <the name of the target system the mapping is for>
    [-password <password>][-replace][-username <username>]

Optionale Argumente

Option | Effekt
-password | Das Kennwort für Portrait Shared Services.
-username | Der Benutzername für Portrait Shared Services.
Übergeordnetes Thema: Datenzuordnung


Format der Regeleingabezuordnung

Eine Regeleingabezuordnungsdatei basiert auf XML und liefert die Namen für source (Bezugsquelle für das Feld im Zielsystem) und inputName (Bezeichnung für die Regeleingabe). Sie müssen keine Zuordnungen für Felder angeben, die im Zielsystem und in der Regel denselben Namen haben. Mit dem Tag <mapping system=""> wird das Zielsystem angegeben, für das die Zuordnung gelten soll. Um Portrait Dialogue als Zielsystem anzugeben, sollte für das Zuordnungssystem PD und für Interaction Optimizer IO festgelegt werden. Es darf nur eine einzige Zuordnung für jedes System in einer logischen Domäne geben.

Bei der Anwendung von Regeln auf Portrait Dialogue würde beispielsweise folgendes Format verwendet werden:
<?xml version="1.0" encoding="UTF-8"?>
<mapping system="PD">
    <inputMap inputName="Analytics-RuleInputName" inputType="string" source="TargetSystem-DataSource" sourceType="FIELD or FUNCTION"/>
    ...
</mapping>

Die Zuordnungsdatei wird mit dem Datenerstellungsbefehl cmsmappingpublish angewandt.

Wenn die Regeleingabezuordnungen geändert werden müssen (beispielsweise, wenn Sie eine Regel erstellen, bei der zusätzliche Felder genutzt werden, die zuvor nicht zugeordnet wurden), können Sie einen neuen Satz Zuordnungen für die Domäne importieren. Die neuen Zuordnungen werden sofort wirksam. Jede nachfolgende Ausführung von Analyseregel- oder Entscheidungsoptimierungsoperationen in Portrait Dialogue-Dialogen in dieser Domäne greifen sofort die neue Zuordnungsdefinition auf.

Ein inputMap-Element in einer Zuordnungsdatei verfügt über folgende Attribute:
  • inputName: Dies ist der Name der Regeleingabe. Es handelt sich im Allgemeinen um den Namen des Feldes in einem Portrait Miner-Datensatz, auf das sich die Regel bezieht.
  • inputType: Dieses Attribut beschreibt den Feldtyp in der Analyseumgebung. Das Attribut kann die Werte integer, real, string oder date annehmen. Es dient lediglich der Beschreibung und hat keine Auswirkung auf die Bedeutung der Feldzuordnung.
  • source: Dieses Attribut bestimmt zusammen mit sourceType die Herkunft des Eingabewerts im Zielsystem. Wenn in Portrait Dialogue sourceType den Wert FIELD hätte, würde durch dieses Attribut der Name des entsprechenden Kundendomänefelds angegeben, das als Eingabequelle verwendet werden soll. Wenn sourceTypeden Wert FUNCTION aufweist, enthält dieses Attribut die Portrait Dialogue-Funktion, über die der Eingabewert ermittelt werden soll.
  • sourceType: Sie können dieses Attribut entweder als sourcetype="FIELD" für Portrait Dialogue oder Interaction Optimizer oder als sourcetype="FUNCTION" festlegen. Dadurch wird festgelegt, ob Portrait Dialogue die Regeleingabe aus einem Kundendomänenfeld oder einem Portrait Dialogue-Ausdruck abrufen soll.

Wenn sourcetype als FUNCTION definiert ist, muss der Wert des Quellattributs ein gültiger Portrait Dialogue-Ausdruck sein, der einen einzelnen Wert von einem der folgenden Datentypen zurückgibt: string, integer, float, datetime/date oder boolean (wobei „boolean“ den ganzzahligen Werten 0 für false und 1 für true zugeordnet wird).

Beispiel

Hier ein Bespiel für eine Zuordnungsdatei mit Funktionen:

<?xml version="1.0" ?>
<mapping system="PD">
   <!-- Maps to the answer of an integer question in a
     questionnaire. Returns NULL if the customer has not answered
     that questionnaire -->
   <inputMap inputName="TI_Q1" inputType="integer" sourceType="FUNCTION"
     sourceName="AnswerInt(1014,'Q1', '')" />

   <!-- Maps to the answer of single choice question (radio buttons)
     in a questionnaire. Returns the alternative key (e.g. "A1"),
     and NULL if the customer has not answered that questionnaire
   -->
   <inputMap inputName="TI_Q2" inputType="string" sourceType="FUNCTION"
              source="AnswerSingleChoice(1014, 'Q2')" />

   <!-- Maps to the answer of a boolean alternative of a question
     (checkboxes) in a questionnaire. Returns true/false, and NULL
     if the customer has not answered that questionnaire -->
   <inputMap inputName="TI_Q2_BOOL" inputType="integer" sourceType="FUNCTION"
              source="IsAnswered(1014, 'Q2', 'A1')" />

   <!-- Checks if a message of a specific template has been created
     for the customer. Returns true/false -->
   <inputMap inputName="TI_MSG_TEMPLATE_1170" inputType="integer" sourceType="FUNCTION"
              source="hasMessages[templateid = 1170]" />

   <!-- Checks if a customer has a specific value in a category with
     values. Returns true/false -->
   <inputMap inputName="TI_CATEGORY_1011_I5" inputType="integer" sourceType="FUNCTION"
              source="hasCategories[Name = 'CATEGORY_1011' and
              Value = 'I5']" />

   <!-- Checks if a customer has been treated by a dialog operation
     (requires participant logging in the dialog). Returns
     true/false -->
   <inputMap inputName="TI_OFFER_1" inputType="integer" sourceType="FUNCTION" ~
              source="HasOperationHistory(4519)" />

   <!-- Checks if a customer has been treated by a dialog branch
     (requires participant logging in the dialog). Returns
     true/false -->
   <inputMap inputName="TI_OFFER_2" inputType="integer" sourceType="FUNCTION"
              source="HasBranchHistory(1231)" />

   <!-- Counts the number of Orders a customer has -->
   <inputMap inputName="count_orders" inputType="integer" sourceType="FUNCTION"
              source="NumberOf(Orders) " />
              </mapping>
Übergeordnetes Thema: Datenzuordnung


Regelintegration

  • pssrulepublish
  • pssrulelist
  • pssruleretrieve
  • pssruledescribe
Übergeordnetes Thema: Exportieren von Regeln im Batch


pssrulepublish

Veröffentlicht den Inhalt einer QMML-Datei als benannte Regel in einer logischen PSS-Domäne mit einer Beschreibung und ihrem Regeltyp.

Synopsis
          pssrulepublish -domain <domain name> -name <rule name>
          -description <text | @filename>
          -type <value | propensity | uplift>
          -input <QMML rule file>
          [-password <password>][-replace][-username <username>]

Optionale Argumente

Option | Effekt
-password | Das Kennwort für Portrait Shared Services.
-replace | Ersetzt die QMML einer vorhandenen Regel, statt eine neue zu veröffentlichen. Beim Ersetzen sind die Parameter -type und -description optional.
-username | Der Benutzername für Portrait Shared Services.
Übergeordnetes Thema: Regelintegration


pssrulelist

Führt die Details aller Regeln auf, die einer bestimmten logischen PSS-Domäne zugeordnet sind.

Synopsis
          pssrulelist -domain <domain name>
          [-password <password>][-username <username>][-xml]

Optionale Argumente

Option | Effekt
-password | Das Kennwort für Portrait Shared Services.
-username | Der Benutzername für Portrait Shared Services.
-xml | Zeigt die Ausgabe im XML-Format an.
Übergeordnetes Thema: Regelintegration


pssruleretrieve

Ruft die kompilierte QMML für eine benannte Regel in einer logischen PSS-Domäne in eine Datei ab.

Synopsis
          pssruleretrieve -domain <domain name>-name<rule name>
          -output <QMML file>
          [-password <password>][-username <username>]

Optionale Argumente

Option | Effekt
-password | Das Kennwort für Portrait Shared Services.
-username | Der Benutzername für Portrait Shared Services.
Übergeordnetes Thema: Regelintegration


pssruledescribe

Führt die Namen und Typen der Eingaben in und Ausgaben aus einer benannten Regel in einer logischen PSS-Domäne auf. Zeigt auch, wie die Regeleingabezuordnungen angewendet werden, indem die Zuordnung zu einem Feld oder einer Funktion beschrieben wird, falls die Zuordnung definiert ist. Die Parameter für den Befehl sind:

Synopsis
          pssruledescribe -domain <domain name>-name <rule name>
          [-password <password>][-replace][-username <username>]

Optionale Argumente

Option | Effekt
-password | Das Kennwort für Portrait Shared Services.
-username | Der Benutzername für Portrait Shared Services.
Übergeordnetes Thema: Regelintegration


Kontaktoptimierungsintegration

In Portrait Optimizer wird ein Satz von DBCs bereitgestellt, um Kontaktoptimierungsmodelle in PSS anwenden zu können.

  • pssoptpublish
  • pssoptlist
  • pssoptretrieve
  • pssoptreport
  • pssoptdescribe
Übergeordnetes Thema: Exportieren von Regeln im Batch


pssoptpublish

Wendet ein Kontaktoptimierungsergebnis auf eine logische PSS-Domäne mit einem bestimmten Namen und einer Beschreibung an.

Synopsis
          pssoptpublish -domain <domain name> -name <optimization name>
          -description <text | @filename> -input <QSOR file>
          [-password <password>][-replace][-username <username>]

Optionale Argumente

Option | Effekt
-password <Kennwort> | Das Kennwort für Portrait Shared Services.
-replace | Ersetzt die Details einer vorhandenen Optimierung, anstatt eine neue zu veröffentlichen. Beim Ersetzen ist der Parameter -description optional.
-username <Kennwort> | Der Benutzername für Portrait Shared Services.
Übergeordnetes Thema: Kontaktoptimierungsintegration


pssoptlist

Führt die Kontaktoptimierungen in einer logischen PSS-Domäne auf.

Synopsis
          pssoptlist -domain <domain name>
          [-password <password>] [-username <username>][-xml]

Optionale Argumente

Option | Effekt
-password <Kennwort> | Das Kennwort für Portrait Shared Services.
-xml | Zeigt die Ausgabe im XML-Format an.
-username <Benutzername> | Der Benutzername für Portrait Shared Services.
Übergeordnetes Thema: Kontaktoptimierungsintegration


pssoptretrieve

Ruft eine einzelne Kontaktoptimierung von einer logischen PSS-Domäne ab und speichert sie in einem Kontaktoptimierungs-Ergebnisarchiv.

Synopsis
          pssoptretrieve -domain <domain name> -name <optimization name>
          -output <QSOR file>
          [-password <password>] [-username <username>]

Optionale Argumente

Option | Effekt
-password <Kennwort> | Das Kennwort für Portrait Shared Services.
-username <Benutzername> | Der Benutzername für Portrait Shared Services.
Übergeordnetes Thema: Kontaktoptimierungsintegration


pssoptreport

Ruft einen einzelnen Kontaktoptimierungsbericht von einer logischen PSS-Domäne ab und speichert ihn in einer Datei.

Synopsis
          pssoptreport -domain <domain name> -name <optimization name>
          -output <HTML file>
          [-password <password>] [-username <username>]

Optionale Argumente

Option | Effekt
-password <Kennwort> | Das Kennwort für Portrait Shared Services.
-username <Benutzername> | Der Benutzername für Portrait Shared Services.
Übergeordnetes Thema: Kontaktoptimierungsintegration


pssoptdescribe

Ruft die Parameter eines einzelnen Kontaktoptimierungsberichts von einer logischen PSS-Domäne ab. Der Befehl zeigt auch durch die Beschreibung der Zuordnung zu einem Feld oder einer Funktion, wie die Regeleingabezuordnungen angewendet werden, sofern eine Zuordnung für das angegebene Zielsystem definiert ist.

Synopsis
          pssoptdescribe -domain <domain name> -name <optimization name>
          [-target <system name>] [-password <password>] [-username <username>]

Optionale Argumente

Option | Effekt
-target <Systemname> | Der Name des Zielsystems für die Feldzuordnungen, z. B. PD für Portrait Dialogue oder IO für Interaction Optimizer.
-password <Kennwort> | Das Kennwort für Portrait Shared Services.
-username <Benutzername> | Der Benutzername für Portrait Shared Services.
Übergeordnetes Thema: Kontaktoptimierungsintegration


Kundendatensätze in einem Fokus anzeigen

  • Kundendatensätze anzeigen


Kundendatensätze anzeigen

In Decision Studio können Sie den Tabellenansicht benutzen, um auf die Rohdaten in einzelnen Kundendatensätzen anzuzeigen. Um im Decision Studio-Fenster den Tabellenansicht zu öffnen, wählen Sie „Tools>Tabellenansicht“ oder klicken in der Symbolleiste auf [image].

Der Tabellenansicht zeigt zunächst Daten für die ersten 100 Kunden in Ihrem Fokus (den ersten „Datensatzblock“) und beachtet dabei alle Datensatzauswahlen [siehe Auswahl von Kundendatensätzen], die in Funktion sind.

Sie können die vom Tabellenansicht angezeigten Felder [siehe Die Felder auswählen, die Sie anzeigen möchten] und Datensätze [siehe Einen anderen Datensatzblock anzeigen] steuern und für jedes angezeigte Feld grundlegende Statistiken ansehen [siehe Feldstatistiken anzeigen].

Anmerkung: Wenn es sich bei einem Wert in einem Stringfeld um eine URL handelt (zum Beispiel http://www.portraitsoftware.com /) zeigt der Tabellenansicht den Wert in Blau und unterstrichen an. Sie können auf den Wert „doppelklicken“, um die damit verbundenen Ressourcen in Ihrem Web-Browser anzuzeigen.

Siehe auch

Ein Feld mithilfe des Tabellenansichts ableiten
Übergeordnetes Thema: Kundendatensätze in einem Fokus anzeigen

Die Felder auswählen, die Sie anzeigen möchten

  1. Wählen Sie „Ansicht>Ausblenden/Anzeigen“.

    Das Dialogfeld „Felder ausblenden/anzeigen/reorganisieren“ wird angezeigt:

    • Verwenden Sie die Schaltflächen [image] und [image] zum Umschalten zwischen „Ausblenden“ und „Anzeigen“ von Fensterbereichen, um markierte Felder von einem Fensterbereich in einen anderen zu verschieben.

      Die Schaltflächen [image] und [image] verschieben alle Felder, unabhängig davon, ob sie markiert sind oder nicht.

    • Verwenden Sie die Schaltflächen [image] und [image] auf der rechten Seite des Fensterbereichs „Anzeigen“, um die Felder neu zu ordnen.
  2. Klicken Sie auf „OK“.
Anmerkung:
  • Außerdem können Sie Felder ausblenden, indem Sie sie im Tabellenansicht markieren und die Optionen „Feld> Ausblenden“ wählen oder mit der rechten Maustaste klicken und auf „Ausblenden“ wählen.

    Um ein Feld zu zeigen, dass Sie auf diese Weise ausgeblendet haben, müssen Sie das Dialogfeld „Felder Ausblenden/Anzeigen/Reorganisieren Felder“ wie oben benutzen.

  • Ausblenden und Neuordnen der Felder wirkt sich nur auf die Ansicht im Tabellenansicht aus. Der zugrunde liegenden Fokus bleibt unverändert.

Einen anderen Datensatzblock anzeigen

Tun Sie Folgendes:
  • Wählen Sie „Ansicht>Nächster Datensatzblock“ oder klicken Sie unten an der Bildlaufleiste auf [image], um den nächsten Block von 100 Datensätzen anzuzeigen.
  • Wählen Sie „Ansicht>Vorheriger Datensatzblock“ oder klicken Sie Oben an der Bildlaufleiste auf [image], um den vorherigen Block von 100 Datensätzen anzuzeigen.
  • Wählen Sie „Ansicht>Gehe zu Datensatz“ und geben Sie eine Datensatznummer an, um zu einem bestimmten Datensatzblock zu springen.
Anmerkung: Der Tabellenansicht berücksichtigt jede Datensatzauswahl [siehe Auswahl von Kundendatensätzen], die vorhanden ist.

Feldstatistiken anzeigen

Wählen Sie Ansicht>Statistik.

Der Tabellenansicht zeigt den minimalen ungleich Null [siehe Der Nullwert] Wert, den maximalen ungleich Null Wert und die Anzahl der Vorkommen von Null in den einzelnen Feldern:

Anmerkung: Aus Gründen der Effizienz behält der Tabellenansicht die Statistiken nicht zu allen Zeiten aktuell. Wenn die Feldstatistiken veraltet sind, zeigt der Tabellenansicht sie ausgegraut.
  • Wenn Sie die Statistiken für ein Feld oder eine Gruppe von Feldern aktualisieren möchten, markieren Sie die Felder und wählen Sie „Feld>Statistiken aktualisieren“, oder klicken Sie mit der rechten Maustaste auf ein Feld und wählen Sie „Statistiken aktualisieren“.


Kundendatensätze in einem Fokus auswählen

  • Auswahl von Kundendatensätzen
  • Wertauswahl oder Filterung unter Verwendung eines kategorischen Feldes
  • Wertauswahl oder Filterung unter Verwendung eines/einer nicht-kategorischen Feldes oder Statistik


Auswahl von Kundendatensätzen

Sie können die Datensätze in einem Fokus entsprechend der Werte in einem Feld auswählen, indem Sie entweder die erforderliche Gruppe an Werten [siehe Auswahl von Datensätzen in einem Fokus nach Wert] oder indem Sie die Anzahl der Datensätze [siehe Auswahl einer vorgegebenen Anzahl Datensätze], die Sie möchten, angeben. Grafische Anzeigen und Modellierungstools, die den Fokus verwenden, arbeiten nur mit ausgewählten Datensätzen.
Anmerkung:
  • Sie können Datensatzauswahlen, die auf mehr als einem Feld basieren, gleichzeitig anwenden, wobei in diesem Fall die Auswirkung der Datensatzauswahl kumulativ erfolgt; das bedeutet, die ausgewählten Datensätze entsprechen allen ausgewählten Bedingungen.
  • Ist einem Feld keine Datensatzauswahl zugeordnet, erscheint in de Spalte „Auswahl“ im Fenster von Decision Studio ein „S“. Bei einem nicht-kategorischen Feld erscheinen die ausgewählten Intervalle außerdem in dieser Spalte in mathematischer Standardschreibweise. Danach erweitern, zusammen mit einem „+N“ oder „-N“, je nachdem, ob der Nullwert [siehe Der Nullwert] eingeschlossen ist oder nicht.
  • Auswahlen können gelöscht oder bearbeitet werden, auch wenn ein Fokus gespeichert oder neu geöffnet wurde.
  • Sie können die Zeit reduzieren, die eine Auswahl in Anspruch nimmt, bis sie übernommen wird, indem Sie andere Fenster schließen, die nicht mehr benötigt werden.
  • Das Vorhandensein einer Datensatzauswahl verbessert nicht die Geschwindigkeit der Vorgänge im Fokus.

Siehe auch

Fokus-Metadaten
Übergeordnetes Thema: Kundendatensätze in einem Fokus auswählen

Auswahl von Datensätzen in einem Fokus nach Wert

  1. Markieren Sie im Fenster von Decision Studio das Feld, das Sie für die Datensatzauswahl verwenden möchten.
  2. Wählen Sie „Feld>Werte auswählen“ oder klicken Sie mit der rechten Maustaste und wählen Sie „´Werte auswählen“ oder klicken Sie in der Symbolleiste auf [image].

    Das Dialogfeld „Werte auswählen“ erscheint.

  3. Treffen Sie eine Datensatzauswahl auf Basis der Werte in dem Feld.

    Es bestehen verschiedene Auswahlmöglichkeiten für die kategorische Auswahl [siehe Wertauswahl oder Filterung unter Verwendung eines kategorischen Feldes] und nichtkategorische Auswahl [siehe Wertauswahl oder Filterung unter Verwendung eines/einer nicht-kategorischen Feldes oder Statistik].

  4. Klicken Sie auf „OK“, um Ihre Auswahl zu bestätigen und schließen Sie das Fenster „Werte auswählen“.
Anmerkung:
  • Sie können auch von den meisten Feldlisten über das Kontextmenü eines Feldes das Fenster Werte auswählen öffnen.
  • In der Kreuztabellenansicht, Zuordnungsansicht, Profilansicht und Kreuzverteilungsansicht können Sie auf das Fenster Werte auswählen zugreifen, indem Sie mit der rechten Maustaste auf ein Feld im Diagramm-Konfigurationsbereich klicken.

Auswahl einer vorgegebenen Anzahl Datensätze

  1. Markieren Sie im Fenster von Decision Studio das numerische Feld, das Sie für die Datensatzauswahl verwenden möchten.
  2. Ist in dem Feld eine bestehende Datensatzauswahl vorhanden, müssen Sie diese Auswahl entfernen [siehe Entfernen einer Datensatzauswahl von einem Feld].
  3. Wählen Sie „Feld>Menge auswählen“ oder klicken Sie mit der rechten Maustaste und wählen Sie „Menge auswählen“.

    Das Dialogfeld „Menge auswählen“ erscheint.

  4. Wählen Sie aus, ob die Datensätze mit den höchsten („oben“) oder den niedrigsten („unten“) Werten ausgewählt werden sollen.
  5. Geben Sie entweder den Prozentwert der verfügbaren Datensätze oder eine exakte Anzahl an Datensätzen ein und wählen Sie entsprechend „%“ oder „#“ aus dem Dropdown-Menü.
  6. Wählen Sie aus, ob im Falle von Verbindungen die Menge erhöht oder gesenkt werden soll.

    Es könnte unter Umständen der Fall sein, dass wenn alle Datensätze entsprechend ihrer Werte im ausgewählten Feld sortiert wurden, Datensätze mit dem gleichen Wert in dem Feld den Schwellwert für die ausgewählte Menge überschreiten. Anstatt auf beliebige Weise einige dieser Kundendatensätze zu berücksichtigen, bietet Decision Studio Ihnen die Auswahl, sie alle zu berücksichtigen (Anpassen der Menge nach oben) oder sie alle auszuschließen (Anpassen der Menge nach unten).

  7. Klicken Sie auf „OK“, um Ihre Auswahl zu bestätigen und schließen Sie das Fenster „Werte auswählen“.
Anmerkung: Nachdem Sie eine Datensatzauswahl nach Menge erstellt haben, kann sie von einer Datensatzauswahl durch die Auswahl von Werten nicht mehr unterschieden werden. Stattdessen können Sie nach Wert auswählen [siehe Auswahl von Datensätzen in einem Fokus nach Wert], um Ihre Datensatzauswahl abzustimmen, falls erforderlich. Sie können jedoch nicht erneut nach Menge auswählen, ohne zuerst die Auswahl zu entfernen.

Entfernen einer Datensatzauswahl von einem Feld

  1. Markieren Sie im Fenster von Decision Studio das Feld mit der zugeordneten Datensatzauswahl.
  2. Wählen Sie Feld>Auswahl aufheben, oder klicken Sie mit der rechten Maustaste und wählen Sie Auswahl aufheben, oder klicken Sie in der Symbolleiste auf [image].

Entfernen aller Datensatzauswahlen aus einem Fokus

Wählen Sie „Fokus>Alle Auswahlen aufheben“.


Wertauswahl oder Filterung unter Verwendung eines kategorischen Feldes

Wenn Sie Werte in einem kategorischen [siehe Feldinterpretationen] Feld für die Auswahl von Datensätzen nach Wert [siehe Auswahl von Datensätzen in einem Fokus nach Wert] in einem Fokus verwenden oder einen Filter für ein kategorisches Feld [siehe Für das Verbinden eines Feldes oder einer Statistik mit einer Kreuztabellen-/Diagrammansicht] mit Bezug zu einer Kreuztabelle oder einem Diagramm anwenden, sehen die Fenster „Werte auswählen“ oder „Filter“ folgendermaßen aus:

In den Fenstern werden ausgewählte und nicht ausgewählte Kategorien angezeigt, die entweder die tatsächlichen Werte in dem Feld (die Basiskategorien) oder die Kategorien in der aktiven Klasseneinteilung (falls vorhanden) sind [siehe Bearbeiten einer kategorischen Klasseneinteilung].

Sie können die verschiedenen markierten Kategorien von einem Fenster zum anderen verschieben, indem Sie eine der Einzelpfeil-Schaltflächen verwenden oder alle Kategorien mithilfe der Doppelpfeil-Schaltflächen auswählen/abwählen. Um ausgewählte und nicht ausgewählte Kategorien zu tauschen, klicken Sie auf [image].

Siehe auch

Auswahl einer vorgegebenen Anzahl Datensätze

Wertauswahl oder Filterung unter Verwendung eines/einer nicht-kategorischen Feldes oder Statistik

Übergeordnetes Thema: Kundendatensätze in einem Fokus auswählen


Wertauswahl oder Filterung unter Verwendung eines/einer nicht-kategorischen Feldes oder Statistik

Wenn Sie Werte in einem nicht-kategorischen numerischen oder Datumsfeld für die Auswahl der Datensätze nach Wert [siehe Auswahl von Datensätzen in einem Fokus nach Wert] in einem Fokus verwend oder Sie einen Filter für ein nicht-kategorisches Feld oder eine Statistik an mit [siehe Für das Verbinden eines Feldes oder einer Statistik mit einer Kreuztabellen-/Diagrammansicht] Verbindung zu einer Kreuztabelle oder zu einem Diagramm anwenden, sieht das Fenster von „Werte auswählen“ oder „Filter“ in etwa so aus:

Die horizontale Leiste repräsentiert den Wertbereich in dem Feld oder Statistik mit ausgefüllten Teilen, die ausgewählte Werte repräsentieren. Der abwärts zeigende Keil am Ende eines jeden ausgewählten Bereichs ist entweder gefüllt ( [image]), was darauf hinweist, dass der Endpunktwert in den Bereich eingeschlossen ist, oder umrissen ( [image]), was darauf hinweist, dass der Endpunktwert nicht im Bereich enthalten ist.

Wenn Sie einen markierten Bereich durch Anklicken markieren, werden im Fenster unter der Leiste die Werte für die zwei Endpunkte sowie die Details darüber, ob sie eingeschlossen werden, angezeigt. Sie können sich mit den Pfeilschaltflächen an den Seiten dieses Fensters von einem ausgewählten Bereich zu einem anderen bewegen.

Anmerkung:
  • Wenn einem Feld oder einer Statistik kein(e) Datensatzauswahl/-filter zugeordnet wurden, wird in der horizontalen Leiste im Fenster „Werte auswählen“ oder „Filter“ ein einzelner ausgewählter Bereich ausgewählt, wobei beide Endpunkte eingeschlossen sind.
  • Der Nullwert [siehe Der Nullwert] wird, entsprechend der Einstellung im Menü „Null-Behandlung“, einschlossen oder nicht.

    Wenn Sie explizit einen vorgegebenen Bereich von Datensätzen auswählen, können Sie wählen, ob Ihre Auswahl Datensätze mit Nullwert enthält („Immer einschließen“) oder ausschließt („Immer ausschließen“ oder „Von expliziter Auswahl ausschließen“).

    Um nur Datensätze auszuwählen, die den Nullwert enthalten, wählen Sie „Exklusiv auswählen“.

    Um alle Datensätze auszuwählen, die keinen Nullwert enthalten, sollte kein expliziter Bereich ausgewählt werden (durch Änderung der Werte oder durch Ziehen der Endpunkte), sondern wählen Sie einfach („Immer ausschließen“

Siehe auch

Auswahl einer vorgegebenen Anzahl Datensätze

Wertauswahl oder Filterung unter Verwendung eines kategorischen Feldes

Übergeordnetes Thema: Kundendatensätze in einem Fokus auswählen

Hinzufügen eines Bereichs zu einer Auswahl

Klicken Sie auf [image].

Wenn rechts neben dem derzeit markierten Bereich nicht ausgewählte Werte vorhanden sind, wird der neue Bereich in die erste verfügbar Spalte rechts eingetragen. Andernfalls, wenn links neben dem derzeit markierten Bereich nicht ausgewählte Werte vorhanden sind, wird der neue Bereich in die erste verfügbar Spalte links eingetragen. Sind keine nicht ausgewählten Werte vorhanden, unterteilt Decision Studio den größten vorhandenen ausgewählten Bereich, um so ein Paar neuer Bereiche zu erstellen.

Entfernen eines Bereich aus einer Auswahl

  1. Klicken Sie auf den Bereich, um ihn zu markieren.
  2. Klicken Sie auf [image].
Anmerkung: Um alle ausgewählten Bereiche zu entfernen, klicken Sie auf [image].

Einen Endpunkt in einem Bereich ein- oder ausschließen

Doppelklicken Sie auf den entsprechenden Keil, um seinen Status zu ändern, oder markieren Sie den Bereich durch Anklicken und wählen Sie „Einschließen“ oder „Ausschließen“ aus der entsprechenden Dropdownliste.
Anmerkung:
  • Sie können den linken Endpunkt des linken ausgewählten Bereichs deaktivieren (oder den rechten Endpunkt des rechten ausgewählten Bereichs) indem Sie im Dropdownmenü des Endpunkts „Deaktiviert“ auswählen (anstatt „Einschließen“ oder „Ausschließen“). Der den Endpunkt markierende Keil verschwindet und weist so darauf hin, dass der ausgewählte Bereich erweiterbar ist.
  • Für eine Auswahl auf Datumsbasis schließen die Bereiche immer ihre Endpunkte ein.

Anpassung eines Endpunktes eines Bereichs

Ziehen Sie den entsprechenden Keil nach links oder rechts oder ziehen Sie den gesamten Bereich, um beide Endpunkte gleichzeitig und unter Beibehaltung der Länge des Bereichs zu ändern.

Alternativ können Sie den Bereich markieren und geben in dem entsprechenden Textfeld einen Wert ein.

Anmerkung: Sie können die Schaltflächen [image] oder [image] neben dem Textfeld eines Endpunkts verwenden, um zum nächsten niedrigsten oder höchsten Wert zu springen, der tatsächlich in den Daten vorhanden ist.

Invertieren einer Bereichsauswahl

Klicken Sie auf [image].

Die Lücken zwischen den ausgewählten Bereichen werden zu den neu ausgewählten Bereichen.


Gruppieren von Kundendaten durch Klasseneinteilung eines Felds in einem Fokus

  • Bearbeiten einer kategorischen Klasseneinteilung
  • Bearbeiten einer nicht-kategorischen Klasseneinteilung
  • Ändern einer benutzerdefinierten nicht-kategorischen Klasseneinteilung
  • Optionen für die Anzeige einer Klasseneinteilung
  • Anfügen einer zusätzlichen Klasseneinteilung an ein nicht-kategorisches Feld
  • Übernehmen einer Klasseneinteilung für mehr als ein Feld
  • Um eine Klasseneinteilung für ein Feld zu optimieren


Bearbeiten einer kategorischen Klasseneinteilung

  1. Markieren Sie im Fenster des Decision Studio die kategorischen Felder [siehe Feldinterpretationen], deren Klasseneinteilung Sie verändern möchten. Wählen Sie „Tools>Klasseneditor“, oder drücken Sie Strg+B, oder klicken Sie in der Symbolleiste auf [image].
  2. Alternativ markieren Sie das Feld aus der Feldliste der Modellierungstools, klicken auf die rechte Maustaste und wählen „Klasseneditor“.
  3. Alternativ klicken Sie mit der rechten Maustaste in den grafischen Darstellungen auf ein Feld im „Konfigurationsbereichs für Graphen“ und wählen „Klasseneditor“.

    Der Klasseneditor wird geöffnet und zeigt ein Diagramm der aktuellen Klasseneinteilung für das ausgewählte Feld an. Unten links im Fenster befindet sich das „Hierarchie“-Fenster, das potentiell eine Hierarchie der zunehmend grobkörnigen, kategorischen Klasseneinteilungen für das aktuelle Feld anzeigt. Die markierte Klasseneinteilung ist die aktuelle Klasseneinteilung.

    Wenn keine Klasseneinteilung an das Feld angefügt ist, erstellt der Klasseneditor basierend auf den Standardparametern [siehe Löschen einer kategorischen Klasseneinteilung aus einem Feld] eine Klassenteilung mit dem Namen „unbenannter Knotenpunkt“.

  4. Optional markieren Sie eine andere Klasseneinteilung im Fensterbereich „Hierarchie“, oder erstellen Sie eine neue, indem Sie eine bestehende Klasseneinteilung in der Hierarchie markieren und auf „Neu“ klicken.

    Wenn Sie auf diese Weise eine neue Klasseneinteilung erstellen, ist die ursprüngliche Klasseneinteilung der Vorgänger der neuen.

  5. Verbinden oder teilen Sie Kategorien [siehe Kategorien zusammenfügen oder splitten], um eine grob- oder feinkörnigere Klasseneinteilung zu erstellen, und benennen Sie die neuen Kategorien entsprechend [siehe Umbenennen einer Kategorie].
  6. Falls gewünscht, ordnen Sie die Kategorien in der Klasseneinteilung neu [siehe Kategorien neu ordnen].
  7. Klicken Sie auf „Anwenden“ oder „OK“, um Ihre Änderungen der kategorischen Klasseneinteilungs-Hierarchie zu bestätigen.

    Alternativ klicken Sie auf „Zurücksetzen“, um alle Änderungen, die Sie an der kategorischen Klassenteilungs-Hierarchie seit der letzten Übernahme von Änderungen durchgeführt haben, zu verwerfen.

Anmerkung:
  • Wenn Sie Änderungen anwenden, verhält sich eine kategorische Klasseneinteilungs-Hierarchie wie eine einzelne Klasseneinteilung. Ansonsten verhalten sich die meisten individuellen Stufen der Hierarchie wie separate Klasseneinteilungen, wobei die aktuelle Klasseneinteilung der primären Klasseneinteilung für ein nicht-kategorisches Feld ähnelt [siehe Festlegen der primären Klasseneinteilung für ein nicht-kategorisches Feld].
  • Sie können Klasseneinteilungen bei anderen Feldern ändern, ohne den Klasseneditor zu verlassen, indem Sie auf die Registerkarte Felder klicken und das gewünschte Feld markieren.

Siehe auch

Bearbeiten einer nicht-kategorischen Klasseneinteilung
Übergeordnetes Thema: Gruppieren von Kundendaten durch Klasseneinteilung eines Felds in einem Fokus

Kategorien zusammenfügen oder splitten

  1. Markieren Sie im Fensterbereich „Kategorien“ die Kategorien, die sie zusammenfügen möchten, oder die zuvor hinzugefügte einzelne Kategorie, die Sie splitten möchten.

    Der Fensterbereich „Übergeordnete Kategorien“ zeigt die entsprechenden Kategorien in der übergeordneten Klasseneinteilung (oder Basiskategorien) an.

  2. Führen Sie einen der folgenden Schritte aus:
    • Klicken Sie auf „Zusammenfügen“ oder klicken Sie mit der rechten Maustaste im Fensterbereich „Kategorien“ und wählen „Zusammenfügen“.

      Der Klasseneditor fügt die markierten die Kategorien zusammen, wobei der Name der neuen Kategorie aus einer Kombination der ursprünglichen Kategorienamen, getrennt durch ein kaufmännisches Und „&“, besteht.

    • Klicken Sie auf „Splitten“ oder klicken Sie mit der rechten Maustaste im Fensterbereich „Kategorien“ und wählen „Splitten“. Der Klasseneditor splittet die markierte Kategorie in seine Vorgänger-Kategorien auf.

Umbenennen einer Kategorie

  1. Doppelklicken Sie im Fensterbereich „Kategorien“ entweder auf die Kategorie, oder markieren Sie die Kategorie, indem Sie zuerst darauf klicken und klicken anschließend auf „Umbenennen“.
  2. Geben Sie einen neuen Namen für die Kategorie ein und betätigen Sie die Eingabetaste.

Kategorien neu ordnen

  1. Klicken Sie auf „Neu anordnen“ oder klicken Sie mit der rechten Maustaste im Fensterbereich „Kategorien“.
  2. Wählen Sie, wie Sie die Kategorien neu ordnen möchten:
    • Nach Anzahl, absteigend (+) oder aufsteigend (-)
    • Alphabetisch nach Kategoriename
    • Nach Kategorienummer, aufsteigend
Anmerkung: Wenn Sie eine Klasseneinteilung nach Anzahl der Kategorien sortieren, kommen zusammengeführte Kategorien nach den einzelnen Kategorien und sind nach der Kategorie mit der höchsten Zahl in jeder Stammkategorie sortiert; zum Beispiel kommt die Zusammenführung der Klassen 2 und 4 vor der Zusammenführung der Klassen 1 und 5.

Umbenennen einer kategorischen Klasseneinteilung

Sie können den Klasseneinteilungen in der kategorischen Klasseneinteilungs-Hierarchie für ein Feld beschreibende Namen geben.
  1. Markieren Sie im Fensterbereich „Hierarchie“ des Klasseneditors die Klasseneinteilung, die Sie umbenennen möchten.
  2. Klicken Sie auf „Umbenennen“ oder klicken Sie einfach erneut auf den Namen der Klasseneinteilung.
  3. Geben Sie den gewünschten Namen für die Klasseneinteilung ein und betätigen Sie die Eingabetaste.

Löschen einer kategorischen Klasseneinteilung aus einem Feld

  1. Markieren Sie im Fensterbereich „Hierarchie“ des Klasseneditors die Klasseneinteilung, die Sie löschen möchten.
  2. Klicken Sie auf „Löschen“.
Anmerkung: Um alle kategorischen Klasseneinteilungen aus einem oder mehreren Feldern zu löschen, leeren Sie einfach die kategorische Interpretation [siehe Für das Festlegen oder Leeren eines Analysekandidaten, einer kategorischen, geografischen, Export-oder Zielinterpretation] der Felder.

Festlegen der Standard-Parameter für neue kategorische Klasseneinteilungen

  1. Wählen Sie „Klasseneinteilung>Standard-Parameter“ oder klicken Sie in der Symbolleiste auf [image].
  2. Legen Sie unter der Registerkarte „Kategorisch“ die maximale Anzahl separater Kategorien und die minimale Anzahl von Datensätzen in einer einzelnen Kategorie fest.
  3. Klicken Sie auf „OK“, um Ihre Auswahl zu bestätigen.
Anmerkung:
  • Wenn die Anzahl der Datensätze, die einen bestimmten Wert beinhalten, unter die Mindestanzahl von Datensätzen für eine einzelne Kategorie fällt - in der Regel, weil das Feld zu viele unterschiedliche Werte enthält - werden Datensätze, die diesen Wert enthalten, nicht klassifiziert. Unklassifizierte Datensätze werden standardmäßig nicht im Klasseneditor angezeigt; um sie anzuzeigen, wählen Sie „Ansichten>Unklassifizierte Daten“.
  • Um die neuen Standardparameter auf ein Feld anzuwenden, das bereits eine kategorische Interpretation aufweist, müssen Sie die vorhandene kategorische Interpretation löschen [siehe Für das Festlegen oder Leeren eines Analysekandidaten, einer kategorischen, geografischen, Export-oder Zielinterpretation].


Bearbeiten einer nicht-kategorischen Klasseneinteilung

  1. Markieren Sie im Fenster des Decision Studio die nicht-kategorischen [siehe Feldinterpretationen], numerischen oder Datumsfelder, deren Klasseneinteilung Sie verändern möchten. Wählen Sie „Tools>Klasseneditor“, oder drücken Sie Strg+B, oder klicken Sie in der Symbolleiste auf [image].
  2. Alternativ markieren Sie das Feld aus der Feldliste der Modellierungstools, klicken auf die rechte Maustaste und wählen „Klasseneditor“.
  3. Alternativ klicken Sie mit der rechten Maustaste in den grafischen Darstellungen auf ein Feld im „Konfigurationsbereichs für Graphen“ und wählen „Klasseneditor“.

    Der Klasseneditor wird geöffnet und zeigt ein Diagramm der primären Klasseneinteilung [siehe Festlegen der primären Klasseneinteilung für ein nicht-kategorisches Feld] für das ausgewählte Feld an.

    Wenn keine Klasseneinteilung an das Feld angefügt ist, erstellt der Klasseneditor eine Klasseneinteilung basierend auf den Standardparametern [siehe Festlegen der Standard-Parameter für neue nicht-kategorische Klasseneinteilungen].

  4. Wählen Sie aus dem Fensterbereich „Stil“ den erforderlichen Typ der Klasseneinteilung.
    • Für eine konstante Klassenbreite können Sie entweder die gewünschte Anzahl interner Klassen (Klassen zwischen den Randklassen [siehe Randklassen]) oder die gewünschte Klassenbreite festlegen.
    • Für eine konstante Klassengröße können Sie die gewünschte Anzahl interner Klassen festlegen.
    • Für eine nach Datum gewertete, konstante Klassenbreite und -größe können Sie auch die Einheiten festlegen, in denen Klassenbreiten gemessen werden (Tage, Wochen, usw.).
    • Für eine benutzerdefinierte Klasseneinteilung klicken Sie auf „Bearbeiten“, um die individuellen Klassengrenzen [sieheÄndern einer benutzerdefinierten nicht-kategorischen Klasseneinteilung] im Dialogfeld „Benutzerdefiniert“ festzulegen.
  5. Klicken Sie auf „Anwenden“ oder „OK“, um Ihre Änderungen der Klasseneinteilung zu bestätigen.

    Alternativ klicken Sie auf „Zurücksetzen“, um alle Änderungen, die Sie an der Klassenteilung seit der letzten Übernahme von Änderungen durchgeführt haben, zu verwerfen.

Anmerkung:
  • Um den Klasseneditor zu zwingen, für Felder reeller Zahlen Klassengrenzen bei integeren Werten zu ermitteln, markieren Sie „Klasseneinteilung>Integer-Begrenzungen“.
  • Die endgültige Anzahl interner Klassen kann der Zielanzahl für ein Integerfeld abweichen, oder wenn „Klasseneinteilung>Integer-Begrenzungen ausgewählt ist. Das geschieht aus einem von zwei Gründen:
    • Der Bereich des Felds beinhaltet nicht genügend Integer-Begrenzungen.
    • „Klasseneinteilung>Anzahl Klassen automatisch anpassen“ ist ausgewählt, und mindestens eine der Randklassengrenzen wird automatisch ausgewählt; in diesem Falls kann der Klasseneditor die Anzahl der Klassen anpassen, um Klassengrenzen bei gerundeten Zahlenwerten zu ermitteln. Um zu erzwingen, dass die endgültige Anzahl an Klassen der Zielanzahl entspricht, heben Sie die Markierung „Klasseneinteilung>Anzahl Klassen automatisch anpassen“ auf und klicken Sie auf „Anwenden“ oder „OK“.
  • Für eine benutzerdefinierte Klasseneinteilung werden Änderungen übernommen, wenn Sie auf „OK“ im Dialogfeld „Benutzerdefiniert“ klicken. Daher besteht kein Grund, im Klasseneditor auf „Anwenden“ zu klicken (außerdem können Sie nicht zur ursprünglichen Klasseneinteilung zurückkehren, indem Sie „Zurücksetzen“ wählen).
  • Sie können Klasseneinteilungen bei anderen Feldern ändern, ohne den Klasseneditor zu verlassen, indem Sie auf die Registerkarte Felder klicken und das gewünschte Feld markieren.

Siehe auch

Anfügen einer zusätzlichen Klasseneinteilung an ein nicht-kategorisches Feld

Bearbeiten einer kategorischen Klasseneinteilung

Übergeordnetes Thema: Gruppieren von Kundendaten durch Klasseneinteilung eines Felds in einem Fokus

Randklassen

, gleiche Gesamtmenge und konstante Klassengröße im Decision Studio teilen numerische oder Datumsbereiche in eine Reihe von Klassen ein. Die meisten dieser Klassen sind „intern“, aber es könnte eine besondere „Randklasse“ an jedem Ende des Bereichs geben.

Wenn Decision Studio eine numerische Klasseneinteilung mit Randklassen erstellt, verwendet es einen intelligenten Algorithmus, um einige Werte als abweichendes Ergebnis zu werten. Datensätze mit diesen abweichenden Werten fallen in die Randklassen, während der Großteil der Datensätze in die internen Klassen fallen.

Im Decision Studio Klasseneditor können Sie die Verwendung von Klassen mit gleicher Breite und konstanter Klassengrößen steuern, indem Sie die Dropdown-Menüs in den Fensterbereichen „Min. Randklasse“ und „Max. Randklasse“ verwenden:
  • Wenn Sie „Auto“ für eine numerische, konstante Klassenbreite auswählen, wählt der Klasseneditor die Randklassengrenze automatisch.
  • Wenn Sie „Auto“ für eine Datumsklasseneinteilung oder eine konstante Klassengröße wählen, lässt der Klasseneditor die Randklasse weg.
  • Wählen Sie „Fest bei“, um eine festgelegte Randklassengrenze zu bestimmen.
  • Wählen Sie „Keine“, um die Randklasse in jedem Fall wegzulassen.

Sie können Randklassen auch in einer benutzerdefinierten Klasseneinteilung steuern [siehe Ändern einer benutzerdefinierten nicht-kategorischen Klasseneinteilung].

Löschen einer nicht-kategorischen Klasseneinteilung aus einem Feld

  1. Wenn Sie nicht schon jetzt auf das nicht-kategorische Feld im Klasseneditor blicken, dessen Klasseneinteilung Sie löschen möchten, klicken Sie auf die Registerkarte „Felder“ und markieren Sie das Feld.
  2. Wählen Sie „Klasseneinteilung>Klasseneinteilungen löschen“ oder klicken Sie mit der rechten Maustaste im Fensterbereich „Felder“ und wählen Sie „Klasseneinteilungen löschen“ oder klicken Sie in der Symbolleiste auf [image].
Anmerkung:
  • Sie können Klasseneinteilungen verschiedener nicht-kategorischer Felder gleichzeitig löschen, indem Sie „Klasseneinteilungen in mehreren Feldern löschen“ auswählen. Ein Dialogfeld „Felder auswählen“, in dem Sie die Felder auswählen können, deren Klasseneinteilungen Sie löschen möchten, erscheint.
  • Wie ihr Name unterstellt, löschen die Optionen „Klasseneinteilungen löschen“ und „Klasseneinteilungen in mehreren Feldern löschen“ „alle“ auf ein nicht-kategorisches Feld bezogene Klasseneinteilungen. Falls Sie die Funktion für mehrere Klasseneinteilungen von Decision Studio gewählt haben, um mehr als eine Klasseneinteilung an ein Feld anzufügen [siehe Anfügen einer zusätzlichen Klasseneinteilung an ein nicht-kategorisches Feld], können Sie eine einzelne Klasseneinteilung löschen, indem Sie „Klasseneinteilung>Mehrere Klassenteilungen verwalten“ wählen: Markieren Sie die entsprechende Klasseneinteilung im Dialogfeld „Mehrere Klassenteilungen verwalten“ und klicken Sie auf „Löschen“.

Festlegen der Standard-Parameter für neue nicht-kategorische Klasseneinteilungen

  1. Wählen Sie im Klasseneditor die Optionen Klasseneinteilung>Standardparameter, oder klicken Sie in der Symbolleiste auf [image].
  2. Wählen Sie in der Registerkarte „Nicht-kategorisch“ die Zielanzahl der Klassen (ausgeschlossen Klassen für Null [siehe Der Nullwert] und unklassifizierte Klassen und Randklassen [siehe Randklassen]), den Klassentyp [siehe Bearbeiten einer nicht-kategorischen Klasseneinteilung], und ob Klassen mit proportionalen Klassenbreiten angezeigt werden sollen [siehe Histogramm- und Balkendiagramm-Optionen].
  3. Klicken Sie auf „OK“, um Ihre Auswahl zu bestätigen.
Anmerkung:

Um die neuen Standardparameter auf ein Feld anzuwenden, das bereits in Klassen eingeteilt wurde, müssen Sie die bestehenden Klasseneinteilungen löschen [siehe Löschen einer nicht-kategorischen Klasseneinteilung aus einem Feld].


Ändern einer benutzerdefinierten nicht-kategorischen Klasseneinteilung

Wenn Sie im Klasseneditor für eine benutzerdefinierte Klasseneinteilung auf „Bearbeiten“ klicken, erscheint das Dialogfeld „Benutzerdefiniert“:

Arbeiten Sie ausgehend von der bestehenden Klasseneinteilung (möglicherweise zuvor eine Gleich-Gesamtmenge oder Gleicher-Bereich-Klasseneinteilung), oder klicken Sie auf „Schnellstart“, um mit einer voreingestellten Klasseneinteilung [siehe Verwendung von voreingestellten Schnellstart-Klasseneinteilungen] zu beginnen. Dann passen Sie die Klasseneinteilung ihren Ansprüchen an:
  • Ändern Sie die Klassengrenzen, indem Sie sie direkt in der Tabelle bearbeiten oder indem Sie die grafische Ansicht beeinflussen (funktioniert wie die grafische Ansicht für das Auswählen/Filtern von Datensätzen [siehe Wertauswahl oder Filterung unter Verwendung eines/einer nicht-kategorischen Feldes oder Statistik]).
  • Erhöhen Sie die Anzahl der Klassen, indem Sie eine Klasse markieren (in der Tabelle oder grafischen Ansicht) und auf „Bereich splitten klicken.

    Die Klasse teilt sich in zwei gleichgroße Klassen.

  • Reduzieren Sie die Anzahl der Klassen, indem Sie eine Klasse markieren und auf „Bereich löschen“ klicken.

    Die Klasse wird mit der benachbarten Klasse zu ihrer Rechten (oder zu ihrer Linken, falls es sich um die Klasse ganz rechts handelt) zusammen gefügt.

  • Steuern Sie die Verwendung von Randklassen [siehe Randklassen], indem Sie „Beide“, „Keine“, „Untere“ oder „Obere“ aus dem Dropdown-Menü wählen.
Anmerkung: Durch Ändern des Wertes einer Klassengrenze oder durch Aktivieren oder Deaktivieren des Kontrollkästchens „Einschließlich von“ können Sie eine oder mehrere Klassen derart definieren, dass sie keinesfalls irgendwelche Werte enthalten können. Solche ungültigen Klassen werden als rote Zeilen in der Tabelle hervorgehoben und als „ungültig“ markiert.

Um alle ungültigen Klassen aus Ihrer Klasseneinteilung zu entfernen, klicken Sie auf „Ungültige löschen“.

Siehe auch

Bearbeiten einer nicht-kategorischen Klasseneinteilung
Übergeordnetes Thema: Gruppieren von Kundendaten durch Klasseneinteilung eines Felds in einem Fokus

Verwendung von voreingestellten Schnellstart-Klasseneinteilungen

Wenn Sie auf „Schnellstart“ im Dialogfeld „Benutzerdefiniert“ klicken, erscheint das Dialogfeld „Benutzerdefinierte Vorgaben“.

Indem Sie eine angemessene Vorgabe aus dem Dropdown-Menü wählen, können Sie schnell eine Klasseneinteilung erstellen, bei der die Klassen zwischen Werten der „Klasse von“ und der „Klasse bis“ nützliche Eigenschaften aufweisen:
  • In einer „Fortschritt“-Klasseneinteilung, haben alle Klassen (außer möglicherweise der Klasse ganz rechts) eine vorgegebene Breite.
  • In einer „Protokoll“-Klasseneinteilung gibt es eine vorgegebene Anzahl an Klassen mit logarithmisch zunehmender oder abnehmender Breite.
  • In einer „Gleiche Breite“-Klasseneinteilung gibt es eine vorgegebene Anzahl an Klassen mit gleicher Breite.
  • In einer „Normalen“ Klasseneinteilung sind die Klassenbreiten die, die Sie für eine konstante Klassengröße erhalten würden, wenn die zugrunde liegenden Daten normal zwischen den Werten der „Klasse von“ und der „Klasse bis“ verteilt wären: Je näher eine Klasse dem Mittelwert des Feldes ist, desto schmaler ist sie.
Anmerkung:
  • Wenn es Werte links von dem Wert der „Klasse von“ oder rechts von dem Wert der „Klasse bis“ gibt, fallen die enthaltenden Datensätze in Extra-Klassen (die unter Umständen als Randklassen eingestuft werden könnten, oder auch nicht [siehe Randklassen]).
  • Wenn Sie „Klasse Null separat“ wählen und es eine Klasse gibt, die den Wert 0 enthält, wird diese Klasse in drei Klassen aufgeteilt: Eine für Werte unter 0, eine für 0 selber, und eine für Werte über 0.

    Dies ist dann nützlich, wenn Null ein besonderer Wert ist, zum Beispiel Kunden mit einem Ausgabenwert von Null, die ein eigenständiges Segment bilden.


Optionen für die Anzeige einer Klasseneinteilung

Der Klasseneditor zeigt eine grafische Ansicht der markierten Klasseneinteilung an, die auf die Daten des markierten Feldes angewendet wurde.

Sie können das Erscheinungsbild dieser Ansicht verändern, indem Sie die Allgemeinen Decision Studio Anzeigeoptionen festlegen [siehe Festlegen globaler Optionen für grafische Anzeigen] oder indem Sie Klassen für Nullwerte und unklassifizierte Werte ein- oder ausblenden [siehe Anzeigen oder Verbergen von Segmenten für Null- und unklassifizierte Werte in einem Diagramm].

Sie können auch die Anzeige einer nicht-kategorischen Klasseneinteilung beeinflussen, sowohl im Klasseneditor als auch woanders, indem Sie zwischen Histogramm- und Balkendiagramm-Optionen für die Klasseneinteilung wählen [siehe Histogramm- und Balkendiagramm-Optionen].

Der Klasseneditor zeigt außerdem detaillierte numerische Informationen über eine Klasseneinteilung und die Anzahl der Datensätze in jeder Klasse an.

Siehe auch

Bearbeiten einer kategorischen Klasseneinteilung

Bearbeiten einer nicht-kategorischen Klasseneinteilung

Übergeordnetes Thema: Gruppieren von Kundendaten durch Klasseneinteilung eines Felds in einem Fokus

Histogramm- und Balkendiagramm-Optionen

Abgesehen vom Typ der Klasseneinteilung und den Klassengrenzen, die eine Klasseneinteilung definieren, gibt es für jede Klasseneinteilung einen Anzeigemodus, der für sie festgelegt ist: Entweder „Histogramm“ oder „Balkendiagramm“ (Letzteres ist Standard für eine nicht-kategorische Klasseneinteilung und die einzige Option für eine kategorische Klasseneinteilung).
  • In einem Histogramm hat jede Klasse (anders als eine Randklasse [siehe Randklassen], eine Klassenbreite Null oder die Klasse für Nullwerte [siehe Der Nullwert] oder unklassifizierte Klasse) eine visuelle Breite proportional zur zugrunde liegenden Intervallbreite. Der Klasseneditor stellt die „Wahrscheinlichkeitsdichte“ als Balkenhöhe dar:

    Für eine bestimmte Klasse (außer der Klassenbreite Null, der Klasse für Nullwerte oder unklassifizierten Klasse), können Sie die Anzahl der Datensätze berechnen, indem Sie die Gesamtanzahl der Datensätze, die Wahrscheinlichkeitsdichte und die Intervallbreite miteinander multiplizieren. % Nicht die visuelle Breite, die für Randklassen unterschiedlich ist. (Für eine Datumsklasseneinteilung wird die Klassenbreite in Tagen gemessen.)

    Die Histogramm-Anzeige kommt einem Diagramm mit der Werteverteilung in einem Feld am nächsten.

    Um eine nicht-kategorische Klasseneinteilung im Klasseneditor als Histogramm anzuzeigen, markieren Sie „Ansichten>Histogramm“ oder wählen Sie [image] in der Symbolleiste.

  • In einem Balkendiagramm haben alle Klassen die gleiche visuelle Breite (obwohl die zugrunde liegenden Intervallbreiten in einer nicht-kategorischen Klasseneinteilung variieren können). Der Klasseneditor stellt die Anzahl der Datensätze für jede Klasse als Balkenhöhe dar.

    Wenn die Intervallbreiten in einer Klasseneinteilung stark variieren, zeigt die Balkendiagrammanzeige am deutlichsten die Klassengrenzen und die Anzahl der Datensätze an.

    Um eine nicht-kategorische Klasseneinteilung im Klasseneditor als Balkendiagramm anzuzeigen, heben Sie die Markierung „Ansichten>Histogramm“ auf, oder deaktivieren Sie [image] in der Symbolleiste.

Da der Anzeigemodus eine Eigenschaft einer Klasseneinteilung und nicht nur eine Anzeigeoption im Klasseneditor ist, müssen Sie Ihre Änderung entweder permanent machen (indem Sie auf „Anwenden“ klicken), oder verwerfen, wenn Sie zu einer anderen Klasseneinteilung wechseln oder den Klasseneditor schließen.
Anmerkung:
  • Der Anzeigemodus für eine Klasseneinteilung beeinflusst Diagrammansichten im Profilansicht und Kreuzverteilungsansicht: Verteilungen auf den Achsen sind gleich breit oder proportional, entsprechend dem Modus. Die Ausnahme ist, wenn die Ausdehnung eines Blocks in eine bestimmte Richtung Informationen übermittelt: In diesem Fall, hat die Anzeigeeinstellung des Klasseneditors keinen Einfluss, sodass Missverständnisse vermieden werden.
  • Im Klasseneditor, sowohl in der Histogramm- als auch in der Balkendiagrammansicht, ist der visuelle Bereich einer Klasse (außer Randklassen, einer Klassenbreite-Null oder der Klasse für Nullwerte oder unklassifizierten Klasse) proportional zur Anzahl der Datensätze in der Klasse.


Anfügen einer zusätzlichen Klasseneinteilung an ein nicht-kategorisches Feld

Sie können eine oder mehrere Klasseneinteilungen an ein nicht-kategorisches Feld in einem Fokus anfügen, wenn auch zu einem bestimmten Zeitpunkt nur eine davon – die primäre Klasseneinteilung – für Decision Studio-Tools außer dem Klasseneditor zugänglich ist.
  1. Wenn Sie nicht schon jetzt auf das Feld im Klasseneditor blicken, das Sie klassifizieren möchten, klicken Sie auf die Registerkarte „Felder“ und markieren Sie das Feld.
  2. Wählen Sie „Klasseneinteilung>Mehrere Klasseneinteilungen Verwalten“ oder klicken Sie mit der rechten Maustaste im Fensterbereich „Felder“ und wählen „Mehrere Klasseneinteilungen Verwalten“.
  3. Führen Sie im Dialogfeld „Mehrere Klasseneinteilungen Verwalten“ einen der folgenden Schritte durch:
    • Klicken Sie auf „Hinzufügen“.

      Der Klasseneditor erstellt eine neue Klasseneinteilung mit den neuen Standard-Parametern [siehe Festlegen der Standard-Parameter für neue nicht-kategorische Klasseneinteilungen] für eine nicht-kategorische Klasseneinteilung.

    • Markieren Sie eine bestehende Klasseneinteilung und klicken Sie auf „Duplizieren“.

      Der Klasseneditor erstellt eine Kopie der markierten Klasseneinteilung.

Anmerkung:
  • Um die neue Klasseneinteilung zu verwenden, müssen Sie sie als primäre Klasseneinteilung [siehe Festlegen der primären Klasseneinteilung für ein nicht-kategorisches Feld] für das Feld festlegen.
  • Als Hilfestellung zum Unterscheiden der verschiedenen Klasseneinteilungen können Sie ihnen beschreibende Namen geben: Doppelklicken Sie auf die Klasseneinteilung im Dialogfeld „Mehrere Klasseneinteilungen Verwalten“.
Übergeordnetes Thema: Gruppieren von Kundendaten durch Klasseneinteilung eines Felds in einem Fokus

Festlegen der primären Klasseneinteilung für ein nicht-kategorisches Feld

  1. Wenn Sie nicht schon jetzt auf das Feld im Klasseneditor blicken, das Sie klassifizieren möchten, klicken Sie auf die Registerkarte „Felder“ und markieren Sie das Feld.
  2. Wählen Sie „Klasseneinteilung>Mehrere Klasseneinteilungen Verwalten“ oder klicken Sie mit der rechten Maustaste im Fensterbereich „Felder“ und wählen „Mehrere Klasseneinteilungen Verwalten“.
  3. Klicken Sie im Dialogfeld „Mehrere Klasseneinteilungen Verwalten“ auf „Primär machen“.


Übernehmen einer Klasseneinteilung für mehr als ein Feld

Sie können eine Klasseneinteilung wiederverwenden, indem Sie sie für ein Feld erstellen und für ein anderes, ähnliches Feld übernehmen. Sie können eine nicht-kategorische Klasseneinteilung zwischen Feldern kopieren und einfügen [siehe So kopieren Sie eine Klasseneinteilung in ein anderes, nicht-kategorisches Feld] oder sie in eine Klasseneinteilungsdatei speichern [siehe So speichern Sie eine nicht-kategorische Klasseneinteilung] und dann die Klasseneinteilung für ein anderes Feld übernehmen [siehe So übernehmen Sie eine gespeicherte nicht-kategorische Klasseneinteilung für ein neues Feld]. Sie können auch eine kategorische Klassenhierarchie speichern [siehe So speichern Sie eine kategorische Klassenhierarchie] und die Hierarchie dann für ein anderes Feld übernehmen [siehe So übernehmen Sie eine gespeicherte kategorische Klassenhierarchie für ein neues Feld].
Anmerkung: Normalerweise würden Sie eine gespeicherte Klasseneinteilung oder kategorische Klassenhierarchie auf ein Feld in einem anderen Fokus übertragen: Bei nicht-kategorischen Feldern im selben Fokus ist „Kopieren“ und „Einfügen“ einfacher.
Übergeordnetes Thema: Gruppieren von Kundendaten durch Klasseneinteilung eines Felds in einem Fokus

So kopieren Sie eine Klasseneinteilung in ein anderes, nicht-kategorisches Feld

  1. Wenn Sie nicht schon jetzt auf das nicht-kategorische Feld im Klasseneditor blicken, dessen Klasseneinteilung Sie kopieren möchten, klicken Sie auf die Registerkarte „Felder“ und markieren Sie das Feld.
  2. Wählen Sie „Klasseneinteilung>Klasseneinteilung kopieren“, oder klicken Sie mit der rechten Maustaste in den Fensterbereich „Felder“ und wählen Sie „Klasseneinteilung kopieren“ oder klicken Sie in der Symbolleiste auf [image].
  3. Markieren Sie das Feld, für das Sie die Klasseneinteilung übernehmen möchten.
  4. Wählen Sie „Klasseneinteilung>Klasseneinteilung einfügen“, oder klicken Sie mit der rechten Maustaste in den Fensterbereich „Felder“ und wählen Sie „Klasseneinteilung einfügen“ oder klicken Sie in der Symbolleiste auf [image].

    Der Klasseneditor erstellt eine Kopie der Klasseneinteilung und benennt sie entsprechend dem ursprünglichen Feld.

Anmerkung:
  • Statt eine Klasseneinteilung in ein einzelnes Feld zu kopieren, können Sie sie gleichzeitig für mehrere Felder übernehmen, indem Sie „Klasseneinteilung in mehrere Felder einfügen“ statt „Klasseneinteilung einfügen“ wählen. In diesem Fall wird das Dialogfeld „Felder für Einfügen auswählen“ angezeigt, in dem Sie eine Gruppe von Feldern auswählen können. Der Klasseneditor erstellt eine Kopie der Klasseneinteilung und benennt sie entsprechend jedem der von Ihnen gewählten Felder.
  • Wenn Sie die Funktion der mehrfachen Klasseneinteilung in Decision Studio verwendet haben, um einem Feld mehr als eine Klasseneinteilung beizufügen, beachten Sie, dass die Optionen „Klasseneinteilung kopieren“ und „Klasseneinteilung einfügen“ für die primären Klasseneinteilungen [siehe Festlegen der primären Klasseneinteilung für ein nicht-kategorisches Feld] gelten, die mit dem Feld verknüpft sind.

So speichern Sie eine nicht-kategorische Klasseneinteilung

  1. Wenn Sie nicht schon jetzt auf das nicht-kategorische Feld im Klasseneditor blicken, dessen Klasseneinteilung Sie speichern möchten, klicken Sie auf die Registerkarte „Felder“ und markieren Sie das Feld.
  2. Wählen Sie Datei>Speichern unter oder klicken Sie in der Symbolleiste auf [image], und wählen Sie dann einen Speicherort und Namen für Ihre Klasseneinteilungsdatei aus.

So übernehmen Sie eine gespeicherte nicht-kategorische Klasseneinteilung für ein neues Feld

  1. Wenn Sie nicht schon jetzt auf das nicht-kategorische Feld im Klasseneditor blicken, das Sie mit der gespeicherten Klasseneinteilung klassifizieren möchten, klicken Sie auf die Registerkarte „Felder“ und markieren Sie das Feld.
  2. Wählen Sie „Datei>Öffnen“ oder klicken Sie in der Symbolleiste auf [image].

    Klasseneinteilungsdateien haben die Dateierweiterung .bng (oder .qsbng).

So speichern Sie eine kategorische Klassenhierarchie

  1. Wenn Sie nicht schon jetzt auf das Feld im Klasseneditor blicken, dessen kategorische Klassenhierarchie Sie speichern möchten, klicken Sie auf die Registerkarte „Felder“ und markieren Sie das Feld.
  2. Wählen Sie „Datei>Export[Kategorische Hierarchie]\“ und wählen Sie dann einen Speicherort und Namen für ihre kategorische Klassenhierarchiedatei.

    Kategorische Klassenhierarchiedateien haben die Dateierweiterung .hrc.

So übernehmen Sie eine gespeicherte kategorische Klassenhierarchie für ein neues Feld

K
  1. Wenn Sie nicht schon jetzt auf das Feld im Klasseneditor blicken, das Sie mit der gespeicherten kategorischen Klassenhierarchie klassifizieren möchten, klicken Sie auf die Registerkarte „Felder“ und markieren Sie das Feld.
  2. Wählen Sie „Datei>Kategorische Hierarchie importieren“ oder klicken Sie in der Symbolleiste auf [image].
Anmerkung:
  • Wenn Sie eine gespeicherte kategorische Klasseneinteilungshierarchie auf ein Feld anwenden, wird jede vorherige kategorische Klasseneinteilungshierarchie (oder nicht-kategorische Klasseneinteilungen) überschrieben, die dem Feld zugeordnet ist.
  • Wenn Sie eine gespeicherte kategorische Klassenhierarchie für ein Feld ohne kategorische Interpretation übernehmen, wendet Decision Studio die kategorische Interpretation automatisch auf das Feld an.


Um eine Klasseneinteilung für ein Feld zu optimieren

Sie können den Klasseneditor benutzen, um eine grobe Klasseneinteilung zu finden, die sich am besten einer feinen Klasseneinteilung nähert, in Bezug auf die Vorhersage eines bestimmten Ziels. Auf diese Weise verbessern Sie eine Scorecard oder einen Decision Tree bei gleichzeitiger Minimierung des Risikos von Überanpassung des Modells an Ihre Daten.
  1. Stellen Sie sicher, dass das Feld, dessen Klasseneinteilung Sie optimieren möchten, wie ein Analysekandidat interpretiert wird [siehe Feldinterpretationen] (oder, dass es keine Analysekandidaten im Fokus gibt).
  2. Stellen Sie sicher, dass das entsprechende Modellierungs-Ziel gesetzt ist.
  3. Eine Scorecard erstellen . Schließen Sie das Fenster Scorecard-Assistent nicht.

    Durch den Aufbau einer Scorecard stellen Sie sicher, dass die Statistiken, die für die Optimierung benötigt werden, vorhanden sind.

  4. Wenn Sie nicht schon jetzt auf das Feld im Klasseneditor blicken, dessen Klasseneinteilung Sie optimieren möchten, klicken Sie auf die Registerkarte „Felder“ und markieren Sie das Feld.
  5. Wählen Sie „Klasseneinteilung>Optimieren“ oder klicken Sie in der Symbolleiste auf [image].

    Das Dialogfeld „Klasseneinteilung optimieren“ wird angezeigt:

  6. Wählen Sie die Quellenklasseneinteilung, indem Sie angeben, ob Sie die aktuelle Klasseneinteilung oder eine Gleich-Gesamtmenge oder Gleicher-Bereich-Klasseneinteilung mit einer bestimmten Anzahl von Klassen verwenden möchten.

    Die Quellenklasseneinteilung sollte viel feiner sein als das gewünschte Ergebnis; als eine grobe Orientierung: etwa zehnmal die Anzahl der Klassen, die Sie am Ende haben möchten.

  7. Klicken Sie auf „Quellenklasseneinteilung erstellen“.

    Das Diagramm im Klasseneditor zeigt die von Ihnen gewählte Quellenklasseneinteilung, farbcodiert mit der Ziel-Trefferrate für jedes Ziel.

  8. Wählen Sie die Anzahl der internen Klassen und die minimale Klassengröße für Ihr Klasseneinteilungsziel.
  9. Klicken Sie auf „Optimieren“.

    Das Diagramm im Klasseneditor zeigt nun das Klasseneinteilungsziel unter Verwendung dieser Parameter, wieder farbcodiert mit der Ziel-Trefferrate für jede Klasse.

  10. Klicken Sie auf „Annehmen“, wenn Sie das Feld mit dieser Klasseneinteilung in Klassen einteilen möchten. (Sie können dann das Fenster Scorecard-Assistent schließen.)
Anmerkung:
  • Klasseneinteilungs-Optimierung funktioniert nur mit internen Klassen. Randklassen sind nicht betroffen.
  • Standardmäßig verwendet der Klasseneditor Informationsgewinne als ein Qualitätsmaß dafür, wie gut eine gröbere Klasseneinteilung sich der anfänglichen Klasseneinteilung nähert. Mit dem Dropdown-Menü im Bereich „Optimierung“ können Sie sich dazu entschließen, das Gini-Maß dafür zu verwenden.
  • Klasseneinteilungs-Optimierung ist ein iterativer Prozess: Wenn Sie mit der Quellenklasseneinteilung nicht zufrieden sind, können Sie die Parameter im Bereich „Quellenklasseneinteilung“ jederzeit ändern und klicken erneut auf „Quellenklasseneinteilung erstellen“; wenn Sie mit dem Klasseneinteilungsziel nicht zufrieden sind, können Sie die Parameter in den Bereichen „Klasseneinteilungsziel“ und „Optimierung“ ändern und erneut auf „Optimieren“ klicken.
  • Für ein nicht-kategorisches Feld wird, wenn Sie auf „Akzeptieren“ klicken, die neue Klasseneinteilung zur primären Klasseneinteilung [siehe Festlegen der primären Klasseneinteilung für ein nicht-kategorisches Feld] für das Feld. Sofern Sie „Aktuelle Klasseneinteilung sichern“ vor der Annahme der Klasseneinteilung überprüft haben, wird die vorhandene Primär-Klasseneinteilung überschrieben.
Übergeordnetes Thema: Gruppieren von Kundendaten durch Klasseneinteilung eines Felds in einem Fokus


Ableiten neuer Felder in einen Fokus

  • Ein Feld mithilfe des Tabellenansichts ableiten
  • So leiten Sie ein Feld aus einem Decision Studio-Modell oder einer Kreuztabelle ab
  • Mit Entscheidungsbäumen, Scorecards, Clustermodellen und abstrakten Kreuztabellen verknüpfte Felder
  • Ableiten eines Feldes von einer grafischen Segmentierung
  • Felder in einem Fokus mit Portrait Miner ableiten


Ein Feld mithilfe des Tabellenansichts ableiten

  1. Wählen Sie „Ableiten>Neu“ oder klicken Sie in der Symbolleiste auf [image].

    Der Tabellenansicht erstellt zunächst eine leere „Vorschau“}-Spalte auf der rechten Seite der Tabelle.

  2. Im neu markierten Textfenster links des „=“ Zeichens geben Sie den Namen für das neue Feld ein.

    Wählen Sie einen beschreibenden Feldnamen - jedoch nicht zu lang. Der Name muss mit einem Buchstaben beginnen und darf keine anderen Zeichen als Buchstaben, Ziffern und Unterstriche enthalten. Er darf nicht mit dem Namen eines anderen Feldes im Fokus kollidieren.

  3. Im Textfenster rechts vom „=“ Zeichen geben Sie einen FDL-Ausdruck oder eine Ausdrucksliste ein [siehe Formeln], um die Felder im Hinblick auf vorhandene Felder zu definieren.
  4. Wählen Sie „Ableiten>Neu“, klicken Sie in der Symbolleiste auf [image] oder drücken Sie einfach die Eingabetaste.

    Der Tabellenansicht leitet das neue Feld ab, es erscheint an Stelle der „Vorschau“}-Spalte.

Anmerkung:
  • Wenn der Ausdruck oder die Ausdrucksliste zu lang für eine Zeile ist, können Sie den „Multi-line Ausdruckseditor“ verwenden: Wählen Sie „Ableiten>Bearbeiten“ oder klicken Sie in der Symbolleiste auf [image].
  • Um den Standarddatentyp [siehe Datentypen] für ein Feld zu überschreiben, öffnen Sie den Multi-line Ausdruckseditor, um weitere Ableitungsoptionen anzuzeigen.

    Sie können hier einen Startparameter [siehe Informationen zu Zufallszahlenfunktionen in FDL] für die Zufallszahlenberechnungen einstellen: Wenn Sie keinen Startparameter angeben, wählt das System einen (basierend auf der Systemuhr) aus, die Ergebnissequenz wird, abhängig von der Uhrzeit, unterschiedlich sein.

  • Wenn Sie (wiederholt) die Tabulatortaste betätigen, während Sie einen Ableitungsausdruck eingeben, sucht der Tabellenansicht nach einer möglichen Ergänzung für das aktuelle Wort und berücksichtigt dabei die Namen der FDL-Funktionen und Felder im Fokus. Die Vervollständigung der Namen der FDL-Funktionen schließt gegebenenfalls die notwendigen runden Klammern und Kommas, sofern anwendbar, ein, um die erforderliche Anzahl Argumente anzuzeigen. Wenn Sie keinen Teil eines Wortes eingegeben haben, berücksichtigt der Tabellenansicht alle Namen der Funktionen und Felder als mögliche Ergänzungen.
  • Alternativ können Sie jeden Feldnamen aus dem Fokus durch Auswahl aus einer Liste in einen Ableitungsausdruck übernehmen: Wählen Sie „Ableiten>Feldbrowser“.
  • Wenn Sie sich bezüglich der genauen Syntax einer FDL-Funktion nicht sicher sind – oder nicht tippen möchten – wählen Sie „Ableiten>Funktionsbrowser“ für die unterstützende Funktionseingabe [siehe Unterstützte Funktionseingabe im Tabellenansicht].
  • Um ein Feld auf der Basis von Werten aus einer anderen Tabelle abzuleiten, wenden Sie die FDL-Funktion dblookup an.
  • Decision Studio erzeugt Werte für alle Datensätze, unabhängig davon, ob derzeit eine Auswahl festgelegt wurde.

Siehe auch

Felder in einem Fokus mit Portrait Miner ableiten
Übergeordnetes Thema: Ableiten neuer Felder in einen Fokus

Unterstützte Funktionseingabe im Tabellenansicht

Wenn Sie Ableiten>Funktionsbrowser auswählen oder während der Eingabe einer Ableitungsfunktion im Tabellenansicht auf [image] klicken, wird das Dialogfeld „Variablenableitungsfunktionen“ angezeigt. Wenn Sie eine Funktionsklasse markieren (oder „Alle“) im Fenster „Funktionsfamilie“, wird eine Liste der FDL-Funktionen in dieser Klasse (oder alle verfügbaren FDL-Funktionen) im „Funktions“-Fenster angezeigt.

Wenn Sie eine Funktion im „Funktions“-Fenster markieren, wird eine kurze Beschreibung der Funktion angezeigt. (Für Funktionen, die nicht in FDL aufgebaut sind, klicken Sie auf „Details“, um eine genauere Beschreibung zu sehen.)

Sie können die erforderlichen Argumente im Fenster „Parameter“ eingeben.

Unterhalb des Parameterfensters sehen Sie den aktuellen FDL-Ausdruck, der Ihrer Funktions- und Parameterwahl entspricht. Wenn Sie auf „OK“ klicken, fügt der Tabellenansicht diesen Ausdruck an der Stelle, an der sich der Cursor befindet, in Ihren Ableitungsausdruck ein.

Anmerkung:
  • Wenn Sie das Dialogfeld „Ableitungsfunktionen“ zur Eingabe einer Funktion in die Funktionsfamilie „Feldaggregation“ verwenden, gibt es zwei besondere Parameter („wo“ und „durch“), die nicht zu den eigentlichen Funktionsargumenten gehören. Sie werden für spezielle FDL-Syntax für Aggregationsfunktionen verwendet.

    Der Parameter „wo“ ist ein boolesch [siehe Boolesche Daten]-bewerteter FDL-Ausdruck, der zur Auswahl der Datensätze, über die aggregiert werden soll, verwendet wird. Wenn Sie den Parameter weglassen, aggregiert Decision Studio über alle aktuell ausgewählten Datensätze im Fokus.

    Der Parameter „durch“ ist ein Aufschlüsselungsfeld - oder eine durch Kommas getrennte Auflistung von Aufschlüsselungsfeldern. Um den Wert einer Aggregationsfunktion für einen Datensatz zu berechnen, aggregiert Decision Studio über Datensätze, die die Klasse des Datensatzes für jedes Aufschlüsselungsfeld gemeinsam haben.

  • Wenn Sie das Dialogfeld „Ableitungsfunktionen“ zur Eingabe der FDL-Funktion „isselected“ verwenden, gibt es einen besonderen Parameter („ausdehnen“), der nicht zu einem eigentlichen Funktionsargument gehört. Wenn Sie diesen Parameter markieren, anstatt den Ausdruck „isselected()“ zu generieren, fügt der Tabellenansicht einen Ausdruck, der nur die Datensätze mit true bewertet, die „in diesem Moment“ ausgewählt sind.

    Beide Ausdrücke führen zum selben Ergebnis, bis Sie andere Datensätze im Fokus auswählen. Dann ändert sich das Ergebnis des Ausdrucks „isselected()“, das Ergebnis des erweiterten Ausdrucks bleibt jedoch unverändert.

Eine Ableitungsfunktion mit dem Tabellenansicht ändern

  1. Klicken Sie auf das Feld, dessen Ableitungsausdruck Sie bearbeiten möchten.
  2. Bearbeiten Sie den Ableitungsausdruck, wenn nötig, verwenden Sie den „Mullti-Line Expression Editor“.
  3. Wählen Sie „Ableiten>Neu“, klicken Sie in der Symbolleiste auf [image] oder drücken Sie einfach die Eingabetaste.


So leiten Sie ein Feld aus einem Decision Studio-Modell oder einer Kreuztabelle ab

  1. Wenn ein Feld ausgewählte Segmente eines Entscheidungsbaums widerspiegeln soll, markieren Sie die gewünschten Segmente [siehe Segmente in einer Diagrammanzeige markieren] im Entscheidungsbaum-Werkzeug.
  2. Führen Sie einen der folgenden Schritte aus:
    • Wählen Sie im Entscheidungsbaum-Werkzeug „Baum>Felder erzeugen“.
    • Wählen Sie im Scorecard-Werkzeug „Scorecard>Felder erzeugen“.
    • Wählen Sie im Clustermodell-Werkzeug „Clustering>Felder erzeugen“.
    • Wählen Sie im Kreuztabellenansicht, Profilansicht, Kreuzverteilungsansicht oder Zuordnungsansicht „Segmente>Felder erzeugen“.
    • In jedem anderen Modellierungstool klicken Sie in der Symbolleiste auf [image].
    A Das Dialogfeld „Ergebnisfelder erzeugen“ wird angezeigt.
  3. Markieren Sie die Ergebnisfelder [siehe Mit Entscheidungsbäumen, Scorecards, Clustermodellen und abstrakten Kreuztabellen verknüpfte Felder], die Sie generieren möchten, und ändern Sie die Feldnamen nach Bedarf.
  4. Klicken Sie auf „OK“.

    Decision Studio erzeugt die Ergebnisfelder im Fokus.

Anmerkung:
  • Jedes Ergebnisfeld ist als ein abgeleitetes Feld gekennzeichnet und verfügt über eine zugehörige FDL-Definition, die Sie mit dem Tabellenansicht anzeigen oder bearbeiten [siehe Ein Feld mithilfe des Tabellenansichts ableiten] können. Der Ableitungstext enthält Anleitungskommentare darüber, wie sie eine einfache „What-if“-Analyse ausführen können.
  • Decision Studio erzeugt Werte für alle Datensätze, unabhängig davon, ob derzeit eine Auswahl festgelegt wurde.

Siehe auch

So bauen Sie ein Clustermodell auf

Aufbau eines Entscheidungsbaums

Erstellen einer textuellen Kreuztabellenansicht

Ableiten eines Feldes von einer grafischen Segmentierung

Speichern eines Decision Studio Modells oder einer Segmentierung zur Verwendung als QMML (XML)

Übergeordnetes Thema: Ableiten neuer Felder in einen Fokus


Mit Entscheidungsbäumen, Scorecards, Clustermodellen und abstrakten Kreuztabellen verknüpfte Felder

Die folgenden Ergebnisfelder erfassen unterschiedliche Aspekte der Entscheidungsbäume, abstrakten Kreuztabellen, Scorecards und Clustermodellen:
Feld | Anwendbar für | Beschreibung
Segmentindex | Jeder Entscheidungsbaum bzw. jede abstrakte Kreuztabelle | Die kennzeichnenden Nummer des Segments, in das ein Datensatz fällt, wobei nur „Blatt“-Segmente (unterste Ebene, kein untergeordnetes Element) in einem Entscheidungsbaum berücksichtigt werden
Ausgewählte Segmente | Jeder Entscheidungsbaum bzw. jede Diagrammansicht | 1 für Datensätze in markierten Segmenten; 0 für anderen Datensätze
Trefferrate | Binärer Baum | Die ursprünglich Trefferrate für das „Blatt“-Segment, in das ein Datensatz fällt. Das heißt, der Anteil (zwischen 0 und 1) der Datensätze im Segment, der dem Ziel entspricht (ignoriert Datensätze mit Null [siehe Der Nullwert] im Zielfeld)
Vorhergesagtes Ergebnis | Binärer Baum oder kontinuierliche Scorecard | Bei einem Entscheidungsbaum: Der Klassenindex des häufigsten Originalwerts im Ziel für das „Blatt“-Segment, in das ein Datensatz fällt: normalerweise 1 für den Wert 0, 2 für den Wert 1 und 3 für Null [siehe Der Nullwert]. Bei einer Scorecard: Der durch Anwendung der Scorecard berechnete Score , entspricht dem vorhergesagten Wert des Ziels
Entscheidung | Binärer Baum oder binäre Scorecard | Bei einem Entscheidungsbaum: 1, wenn die ursprüngliche Trefferrate für das , in den ein Datensatz fällt, oberhalb des Schwellenwerts [siehe So legen Sie den Entscheidungsschwellenwert für einen Entscheidungsbaum fest] für den Baum liegt; ansonsten 0. Bei einer Scorecard: 1 für Datensätze mit Scores über dem Cut-off-Score [siehe So stellen Sie den Cut-off-Score für eine Scorecard ein] für die Scorecard; 0 für andere Datensätze
Populärste Kategorie | Kategorischer Baum | Der Klassenindex der häufigsten Originalkategorie im Ziel für das Segment, in das ein Datensatz fällt
Mittelwert Ziel | Kontinuierlicher Baum | Der ursprüngliche Mittelwert des Ziels für das „Blatt“-Segment, in das ein Datensatz fällt
Uplift als Differenz | Binärer Uplift + Baum | Der ursprüngliche Uplift, d.h. die ursprüngliche Trefferrate für die bearbeitete Gesamtmenge minus der für die Kontroll-Gesamtmenge, für das Segment, in das ein Datensatz fällt
Uplift als Quotient | Binärer Uplift x Baum | Das ursprüngliche Uplift-Verhältnis, d. h. die ursprüngliche Trefferrate für die bearbeitete Gesamtmenge dividiert durch die Kontroll-Gesamtmenge, für das Segment, in das ein Datensatz fällt. (Wenn die Trefferrate für die Kontroll-Gesamtmenge Null ist, wird dem Datensatz eine sehr große positive Zahl zugewiesen.)
Uplift von Mittelwert | Kontinuierlicher Uplift-Baum | Der ursprüngliche Mittelwert, d.h. der ursprüngliche Mittelwert für die bearbeitete Gesamtmenge minus dem für die Kontroll-Gesamtmenge, für das Segment, in das ein Datensatz fällt
Bewertung | Binäre Scorecard | Der durch Anwendung der Scorecard berechnete Score
Odds | Binäre Scorecard | Die Odds von Nichteinhaltung, Reaktion, Abwanderung oder Erfüllung bzw. Nichterfüllung, die durch [image] gegeben sind, wobei s die Bewertung und a und b der Even-Odds-Punkt bzw. Verdopplungsfaktor [siehe So legen Sie Score/Odds-Beziehung für eine Scorecard fest] ist.
Wahrscheinlichkeit | Binäre Scorecard | Die Wahrscheinlichkeit von Nichteinhaltung, Reaktion, Churning oder Erfüllung bzw. Nichterfüllung, gegeben durch
Cluster-Index | Clustermodell | Die kennzeichnenden Nummer des Cluster [siehe So bauen Sie ein Clustermodell auf], in das ein Datensatz fällt (oder Null [siehe Der Nullwert] für einen Datensatz im Null-Cluster [siehe Der Nullwert beim Clustering]). (Eine kategorische Klasseneinteilung wird angewandt, und der Wert -1 wird einer Kategorie namens „Sonderfälle“ zugewiesen.)
Cluster-Abstand | Clustermodell | Der normalisierte Abstand [siehe Messen der Größe und Trennung von Clustern] zwischen einem Datensatz und dem Zentrum des Clusters, in das er fällt
Cluster-Separation | Clustermodell | Das Trennungsmaß für einen Datensatz, das durch [image] gegeben ist, wobei [image] die Distanz bis zum nächsten Cluster-Zentrum und [image] die Distanz zum zweitnächsten Cluster-Zentrum ist.
Anmerkung:
  • Das Wort „original“ in der obigen Tabelle bedeutet, dass bei Entscheidungsbäumen die Werte in bestimmten erzeugten Feldern aus der Gesamtmenge sind, auf welcher der Entscheidungsbaum aufgebaut wurde, anstatt einer Gesamtmenge, auf die sie später angewendet wird.
  • Das Feld „Segmentindex“ für eine abstrakte Kreuztabelle berücksichtigt alle Aufschlüsselungsfelder in der Kreuztabelle, einschließlich aller, die der Viewer gegenwärtig in der Leiste [image] (Nur zur Information) aufführt.
  • Das Feld „Ausgewählte Segmente“ für abstrakte Kreuztabellen ist nur beim Speichern eines Modells für den Einsatz in Diagramm anzeigen verfügbar.

Siehe auch

So leiten Sie ein Feld aus einem Decision Studio-Modell oder einer Kreuztabelle ab

Speichern eines Decision Studio Modells oder einer Segmentierung zur Verwendung als QMML (XML)

Übergeordnetes Thema: Ableiten neuer Felder in einen Fokus

So legen Sie den Entscheidungsschwellenwert für einen Entscheidungsbaum fest

Im Entscheidungsbaum-Werkzeug ändern Sie den Akzeptanzraten-Entscheidungsschwellenwert, die Akzeptanzrate oder Zurückweisungsrate über die Bereiche unterhalb der Symbolleiste:

Gültige Werte für diese drei Parameter sind diejenigen, die in der Gewinnansicht [siehe Optionen zur Anzeige eines Entscheidungsbaums] des Entscheidungsbaums angezeigt werden.

Wenn Sie einen Wert für den Entscheidungsschwellenwert oder die Zurückweisungsrate eingeben, ist der tatsächliche Wert (im nicht editierbaren Feld rechts) der nächste legitime Wert über dem Wert, den Sie eingeben. Für die Akzeptanzrate ist der tatsächliche Wert der nächste gültige Wert unter dem Wert, den Sie eingeben. Der Entscheidungsbaum-Werkzeug passt die anderen Werte entsprechend an.

So stellen Sie den Cut-off-Score für eine Scorecard ein

Im Scorecard-Werkzeug ändern Sie Cut-off-Score, Akzeptanzrate (Zielrate) oder Misserfolgsrate (Erfolgsrate) über den Bereich unterhalb der Symbolleiste.

Scorecard-Werkzeug passt die anderen Werte entsprechend an.

Anmerkung:
  • Sie können keinen Cut-off-Score für eine Scorecard festlegen, die mit einem kontinuierlichen Ziel erstellt wurde: in einem Wertemodell treffen Sie keine Ja/Nein-Entscheidungen.
  • Die Standardeinstellung wird durch die Scorecard-Werkzeug-Einstellungen Cut-off, Misserfolgsrate und Akzeptanzrate bestimmt.

So legen Sie Score/Odds-Beziehung für eine Scorecard fest

  1. Im Scorecard-Werkzeug wählen Sie „Scorecard>Formular“.
  2. Im Bereich „Skalierung“ des Dialogfelds „Scorecard-Formular“ ändern Sie den Even-Odds-Punkt und Verdopplungsfaktor wie erforderlich:
    • Der „Even-Odds-Punkt“ ist das Ergebnis, das Odds von 1 entspricht.
    • Wenn Sie den „Verdopplungsfaktor“ zu einem Score hinzufügen, verdoppeln sich die entsprechenden Odds (für ein Antwort- oder Churn-Modell - bei einem Risikomodell werden die Odds halbiert).
  3. Klicken Sie auf „OK“.
Anmerkung:
  • Diese Optionen sind nicht verfügbar, wenn Sie ein kontinuierliches Ziel benutzen, da es kein Konzept gibt, bei dem Odds mit kontinuierlichen Scorecards verbunden sind.
  • Wenn Sie den Even-Odds-Punkt oder Verdopplungsfaktor ändern, gelten die neuen Werte erst dann, wenn Sie die nächste Scorecard erstellen.


Ableiten eines Feldes von einer grafischen Segmentierung

Sie können ein 0/1-Feld von einer grafischen Segmentierung ableiten, um den Einschluss oder Ausschluss von ausgewählten Segmenten anzuzeigen.
  1. Markieren Sie im Profilansicht, Kreuzverteilungsansicht, Zuordnungsansicht oder Entscheidungsbaum-Werkzeug die Segmente von Interesse [siehe Segmente in einer Diagrammanzeige markieren].
  2. Wählen Sie „Segmente>Gewähltes Kennzeichen“ oder klicken Sie in der Symbolleiste auf [image].

    Ein Dialogfeld „Neuer Feldname“ erscheint.

  3. Geben Sie einen Namen für das abgeleitete Feld ein und klicken Sie auf „OK“.

    Decision Studio erstellt ein neues Feld mit 1 in Datensätzen, die in markierte Segmente fallen, und 0 in anderen Datensätzen.

Anmerkung:
  • Das neue Feld ist als abgeleitetes Feld gekennzeichnet und hat eine zugehörige FDL-Definition, die Sie mit Hilfe des Tabellenansichts ansehen oder bearbeiten können [siehe Ein Feld mithilfe des Tabellenansichts ableiten].
  • Das neue Feld wird als kategorisch interpretiert [siehe Feldinterpretationen], mit kategorischen Namen „Nicht Ausgewählt“ und „Ausgewählt“ für die Werte 0 und 1.

Siehe auch

Um ein Diagramm auf einer Karte zu erstellen

Erstellen eines Kreuzverteilungsdiagramms mit mehreren Variablen

Erstellen einer Gruppe von Profildiagrammen mit einer Variablen

So leiten Sie ein Feld aus einem Decision Studio-Modell oder einer Kreuztabelle ab

Speichern eines Decision Studio Modells oder einer Segmentierung zur Verwendung als QMML (XML)

Übergeordnetes Thema: Ableiten neuer Felder in einen Fokus


Felder in einem Fokus mit Portrait Miner ableiten

Sie können Felder mit einer Reihe Feldableitungen in einer Ableitungsdatei ableiten.
Verwenden Sie eine der folgenden Optionen, um ein Feld in einem Fokus abzuleiten:
  • Klicken Sie in Portrait Miner mit der rechten Maustaste auf den Fokus, in dem Sie Felder ableiten möchten, und wählen „Transformieren>Felder ableiten“.
  • Führen Sie in Portrait Miner einen Rechtsklick auf einer Ableitungsdatei aus und wählen Sie „Felder ableiten“.

Wählen Sie im Dialogfeld „Felder ableiten“ eine Ableitungsdatei, die die Felddefinitionen enthält. Alternativ können Sie , wenn Sie eine Ableitungsdatei ausgewählt haben, einen Fokus auswählen. Sie können den Speicherort des neuen Fokusses ändern oder einen früher erstellten Ausgabefokus überschreiben.

Anmerkung: Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl „qsderive“ in Portrait Miner bereitgestellt werden, zuzugreifen.

Siehe auch

Informationen über Portrait Miner-Assistenten

Ein Feld mithilfe des Tabellenansichts ableiten

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Textdateien in Portrait Miner ansehen und bearbeiten

Übergeordnetes Thema: Ableiten neuer Felder in einen Fokus


Umbenennen und Löschen von Feldern in einem Fokus

  • Ein Feld mit dem Tabellenansicht umbenennen
  • Felder durch ein Präfix oder Suffix umbenennen
  • Ein Feld löschen


Ein Feld mit dem Tabellenansicht umbenennen

  1. Klicken Sie auf das Feld, dessen Namen Sie ändern möchten.
  2. Im Textfeld auf der linken Seite des „=“-Zeichens, geben Sie einen neuen Feldnamen ein und betätigen Sie die Eingabetaste.

    Der Name muss mit einem Buchstaben beginnen und darf keine anderen Zeichen als Buchstaben, Ziffern und Unterstriche enthalten. Er darf nicht mit dem Namen eines anderen Feldes im Fokus kollidieren.

Wenn Sie ein Feld umbenennen, machen Sie abgeleitete Felder ungültig (einschließlich Modell-erzeugter Felder), deren Ableitungsausdrücke den ursprünglichen Feldnamen beinhalten.
Anmerkung:
  • Sie können ein Feld solange nicht umbenennen, wie es durch ein Decision Studio-Tool in Benutzung ist.

Siehe auch

Felder durch ein Präfix oder Suffix umbenennen

Übergeordnetes Thema: Umbenennen und Löschen von Feldern in einem Fokus


Felder durch ein Präfix oder Suffix umbenennen

Sie können ein oder mehrere Felder in einem Fokus umbenennen, indem ein gemeinsames Präfix oder Suffix zu den Feldnamen hinzufügen.
  1. Klicken Sie in Portrait Miner mit der rechten Maustaste auf den Fokus, dessen Felder die Sie umbenennen möchten, und wählen Sie „Transformieren>Felder umbenennen“. Das Dialogfeld „Felder umbenennen“ wird angezeigt.
  2. Optional können Sie den Speicherort des Ausgabefokus ändern.
  3. Führen Sie eine oder beide der folgenden Möglichkeiten aus:
    • Wählen Sie den String, den Sie als Präfix hinzuzufügen möchten.
    • Wählen Sie den String, den als Suffix hinzuzufügen möchten.
  4. Wählen Sie ein oder mehrere Felder aus, die Sie umbenennen möchten.
  5. Klicken Sie auf „OK“.
Anmerkung:
  • Jeder resultierende Feld Name darf nicht mit dem Namen eines anderen Feldes in dem Fokus kollidieren.
  • Das Dialogfeld „Felder umbenennen“ ist ein Weg für den Zugriff auf einen Großteil der Funktionalität des von Portrait Miner zur Verfügung gestellten Dateierstellungsbefehls „qsrenamefields“ zu erhalten.

Siehe auch

Informationen über Portrait Miner-Assistenten

Ein Feld mit dem Tabellenansicht umbenennen

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Übergeordnetes Thema: Umbenennen und Löschen von Feldern in einem Fokus


Ein Feld löschen

  1. Klicken Sie auf das Feld, das Sie löschen möchten.
  2. Im Decision Studio-Fenster wählen Sie „Feld> Löschen“ oder klicken Sie mit der rechten Maustaste auf das Feld und wählen Sie „Löschen“.
  3. Wählen Sie im Tabellenansicht „Feld>Löschen“ oder klicken Sie in der Symbolleiste auf [image]. Sie können ein Feld auch löschen, indem Sie mit der rechten Maustaste auf die Feldüberschrift klicken und „Löschen“ wählen.
Anmerkung:
  • Sie können ein Feld solange nicht löschen, wie es durch ein Decision Studio-Tool in Benutzung ist.
  • Sie können auch ein Feld im Decision Studio-Fenster löschen, indem Sie Feld>Löschen verwenden oder Löschen wählen, wenn Sie mit der rechten Maustaste auf ein Feld klicken.

Siehe auch

Die Felder auswählen, die Sie anzeigen möchten

Ein Feld mit dem Tabellenansicht umbenennen

Übergeordnetes Thema: Umbenennen und Löschen von Feldern in einem Fokus


Mit Fokus-Metadaten arbeiten

  • Fokus-Metadaten
  • Feldbeschreibungen
  • Feldinterpretationen
  • Kommentar mithilfe von Decision Studio an einem Fokus oder Feld anhängen
  • Anzeige von Fokus- und Feldmetadaten
  • Kopieren der Fokus-Metadaten von einem Fokus zum anderen
  • Fokus-Metadaten in Excel bearbeiten


Fokus-Metadaten

Metadaten sind „Daten über Daten.“ Neben den Rohkundendaten, die Sie aus einer Datenbank importieren oder durch die Hinzunahme von Transaktionskennzahlen erstellen, enthält ein Fokus Metadaten. Einige dieser Metadaten gelten für den Fokus als Ganzes, während andere Metadaten für einzelne Felder im Fokus gelten.

Dem Fokus als Ganzes zugeordnete Metadaten

  • Die Anzahl der Datensätze und Felder im Fokus
  • Die für die Erstellung des Fokus verwendeten Befehle des Dateierstellungsbefehls (falls erstellt mithilfe von Dateierstellungsbefehlen)
  • Ein optionaler Kommentar

Einem Feld in einem Fokus zugeordnete Metadaten

  • Der Name und Datentyp des Feldes [siehe Datentypen]
  • Alle, dem Feld zugeordneten Anzeigebeschriftungen [siehe Feldbeschreibungen]
  • Alle, dem Feld zugeordneten Benutzerkennzeichnungen [siehe Benutzerkennzeichnungen]
  • Alle, dem Feld zugeordneten Interpretationen [siehe Feldinterpretationen]
  • Alle, dem Feld zugeordneten Klasseneinteilungen
  • Jede Datensatzauswahl [siehe Auswahl von Kundendatensätzen], die auf den Werten im Feld basiert
  • Der für die Definierung des Feldes (falls das Feld abgeleitet wurde) verwendete FDL-Ausdruck [siehe Informatinoen zur Field Derivation Language]
  • Alle, dem Feld zugeordneten Kommentare
  • Ein Datensatz darüber, ob das Feld in den Fokus von einer anderen Datenquelle importiert (vereint) wurde
  • Die Mindest- und Maximalwerte in dem Feld
  • Die Anzahl des Auftretens des Wertes Null [siehe Der Nullwert] in dem Feld
Anmerkung: Die Beziehung zwischen Tools in einer Sitzung in Decision Studio werden nicht in einer Fokusdatei gespeichert.

Siehe auch

Kommentar mithilfe von Decision Studio an einem Fokus oder Feld anhängen

Kopieren der Fokus-Metadaten von einem Fokus zum anderen

Für einen Fokus ein Profil erstellen und prüfen

Anzeige von Fokus- und Feldmetadaten

Übergeordnetes Thema: Mit Fokus-Metadaten arbeiten


Feldbeschreibungen

Die Bearbeitung eines Feldnamens ist oft nicht erwünscht oder möglich. Einige der Ansichten in Decision Studio können statt des Feldnamens eine Beschriftung anzeigen. Tools, die Beschriftungen unterstützen, sind Kreuzverteilungsansicht, Kreuztabellenansicht, Profilansicht, Zuordnungsansicht und Entscheidungsbaum-Werkzeug.

Das Fenster von Decision Studio enthält die Spalte Beschriftung, in der die Beschriftung angezeigt wird, die für die einzelnen Felder verwendet wird. Hinweis: Die Spalte Beschriftung ist optional und kann durch Klick auf Bearbeiten>Spaltenlayout angezeigt werden.

Übergeordnetes Thema: Mit Fokus-Metadaten arbeiten

Bearbeitung der Beschriftung eines Feldes

  1. Im Fenster von Decision Studio das Feld markieren.
  2. Noch einmal auf das Feld Beschriftung klicken, um den Namen direkt zu bearbeiten. Alternativ können Sie bei markierter Beschriftung:
    • Feld>Eigenschaften wählen oder
    • rechtsklicken und Eigenschäften wählen oder
    • Klicken Sie in der Symbolleiste auf [image].

Siehe auch

Aggregationsfunktionen für Kreuztabellen
Anmerkung:
  • Anders als bei den Feldnamen bestehen keine Einschränkungen für die in den Beschriftungen verwendeten Zeichen.
  • Feldbeschriftungen werden mit dem Fokus gespeichert und können zusammen mit anderen Metadatenelementen exportiert und importiert werden.
  • Beschriftungen können in FDL-Ausdrücken nicht verwendet werden.


Feldinterpretationen

In Decision Studio können Sie einem Feld die folgenden Interpretationen zuordnen:

Feldinterpretation | Bedeutung
Ziel | Das Feld ist das Modellierung-/Visualisierungsziel im Fokus.
Partition | Das Feld ist das behandelte/Kontrollpartitionsfeld für Uplift-Analysen. Die erste Klassifizierung oder Kategorie (im Allgemeinen der Wert 0) kennzeichnet das Kontrollsegment und die zweite Klassifizierung oder Kategorie (im Allgemeinen der Wert 1) kennzeichnet das behandelte Segment.
Analysekandidat | Das Feld ist ein Kandidat für die Verwendung in den Entscheidungsbaum-Werkzeug, Scorecard-Werkzeug und Clustermodell-Werkzeug-Modellen.
Kategorisch | Werte in dem Feld bilden einen diskreten, ungeordneten Satz. Kategorische Felder werden gegenüber anderen Feldern im Dialogfeld vom Klasseneditor, Entscheidungsbaum-Werkzeug, Clustermodell-Werkzeug und „Werte auswählen“ unterschiedlich behandelt.
Geografisch | Das Feld ist einer Zuordnung zugeordnet, damit Sie es im Zuordnungsansicht verwenden können.
Export | Das Feld wird standardmäßig berücksichtigt, wenn Sie Segmente in eine Datei oder Datenbanktabelle exportieren. (Typischerweise handelt es sich um den eindeutigen Identifizierer, wie beispielsweise eine Kundennummer.)
Schlüssel | Das Feld ist mit Portrait Explorer verknüpft und weist das Schlüsselfeld aus. Es kann nur ein Schlüsselfeld geben
Anmerkung:
  • Ein Fokus enthält mindestens ein Feld mit den Zielinterpretationen und höchstens ein Feld mit den Partitionsinterpretationen.
  • Befindet sich keine Analysekandidaten in einem Fokus, behandeln Entscheidungsbaum-Werkzeug, Scorecard-Werkzeug und Clustermodell-Werkzeug alle geeigneten Felder als Analysekandidaten.
  • Gleichermaßen gilt, befinden sich keine Felder mit Exportinterpretation in einem Fokus, behandelt Decision Studio alle Felder so, als ob es sich um Exportfelder handelt.
  • Im Scorecard-Werkzeug können Sie ein Feld als eine „Gewichtung“ interpretieren. Diese Art von Interpretation gehört zum Scorecard-Werkzeug und bildet keinen Teil der Fokus-Metadaten.
Übergeordnetes Thema: Mit Fokus-Metadaten arbeiten

Für das Festlegen oder Leeren eines Analysekandidaten, einer kategorischen, geografischen, Export-oder Zielinterpretation

  1. Im Fenster von Decision Studio markieren Sie die Felder, deren Interpretation Sie ändern möchten.
  2. Wählen Sie im Hauptmenü die Optionen „Kennzeichnung>Interpretationen“ und dann „Analysekandidat“ [image], „Kategorisch“ [image], „Geografisch“ [image], „Export“ [image] oder „Schlüssel“ [image]). Klicken Sie alternativ mit der rechten Maustaste auf das Feld und wählen Sie die Interpretation ( [image], [image], [image], [image], oder [image]) aus. Das entsprechende Symbol wird in der Spalte Interpretationen des Feldes angezeigt.
Anmerkung:
  • Sie können über das Menü „Kennzeichnung>Interpretationen“ die Feldinterpretationen im Tabellenansicht festlegen oder klicken Sie mit der rechten Maustaste auf einen Feldnamen (Spaltenüberschrift).
  • Wählen Sie zum Entfernen einer Interpretation diese erneut aus und folgen Sie den entsprechenden oben beschriebenen Schritten.

So legt man ein Ziel- oder Partitionsfeld in einem Fokus fest oder leert es

  1. Markieren Sie im Decision Studio-Fenster das Feld, das Sie als das Ziel- oder Partitionsfeld festlegen möchten.
  2. Wählen Sie im Hauptmenü die Optionen „Kennzeichnung>Interpretationen“ und dann „Ziel“ ( [image]) oder „Partition“ ( [image] ). Klicken Sie alternativ mit der rechten Maustaste auf das Feld und wählen Sie die Interpretation ( [image] oder [image]) aus. Das entsprechende Symbol wird in der Spalte Interpretationen des Feldes angezeigt.
Anmerkung:
  • Haben Sie bereits ein Ziel- oder Partitionsfeld festgelegt und wählen dann die Interpretation eines anderen Feldes auf diese Art und Weise, löscht Decision Studio die ursprüngliche Interpretation für Sie.
  • Um die Ziel- oder Partitionsinterpretation aus einem Feld zu entfernen, ohne die Interpretation einem anderen Feld zuzuweisen, markieren Sie das Feld und wählen aus dem Menü „Kennzeichnung>Interpretationen“ erneut die entsprechende Option.


Kommentar mithilfe von Decision Studio an einem Fokus oder Feld anhängen

Sie können einem Fokus und einzelnen Feldern Beschreibungen und andere Kommentare hinzufügen. Diese Informationen können bei der Freigabe von Datensätzen für andere Personen nützlich sein - oder auch dann, wenn Sie zu einem Analysedatensatz zurückkehren, an dem Sie eine Zeit lang nicht gearbeitet haben.
Im Fenster von Decision Studio:
  • Um einen Fokuskommentar hinzuzufügen, wählen Sie „Fokus>Fokus-Bemerkungen bearbeiten“.
  • Klicken Sie zum Hinzufügen eines Feldkommentars auf das Feld Kommentar und fügen Ihren Kommentar hinzu. Alternativ können Sie:
    • das jeweilige Feld markieren und Feld>Eigenschaften wählen,
    • Klicken Sie mit der rechten Maustaste und wählen Sie „Eigenschaften“, oder klicken Sie in der Symbolleiste auf [image].

Feldkommentare erscheinen im Fenster von Decision Studio in der Spalte „Kommentare“. Feld- und Fokuskommentare erscheinen auch an anderer Stelle [siehe Anzeige von Fokus- und Feldmetadaten].

Anmerkung:
  • Wenn Sie das Feld „HTML“ markieren, behandelt Decision Studio die balancierten Kennzeichnungspaare, wie z. B. <b>...</b>, als HTML-Markierung und zeigt die Kommentare entsprechend an.

Siehe auch

Fokus-Metadaten
Übergeordnetes Thema: Mit Fokus-Metadaten arbeiten


Anzeige von Fokus- und Feldmetadaten

Im Fenster von Decision Studio werden die Fokus-Metadaten [siehe Fokus-Metadaten] einschließlich der Hauptfeldstatistiken angezeigt. Sie können über das Menü „Bearbeiten>Spaltenlayout“ die Anzeige verschiedener Informationen auswählen wobei Ihre Auswahl für die aktuelle und zukünftige Decision Studio-Sitzung übernommen wird.

In der Spalte „Interpretationen“ werden die Buchstaben entsprechend der für das Feld verwendeten Feldinterpretationen angezeigt [siehe Feldinterpretationen]. Darüber hinaus können die folgenden Buchstaben in der Spalte „Interpretationen“ erscheinen:

Buchstabe | Bedeutung
B | Dem Feld wurde eine Klasseneinteilung zugeordnet.
D | Das Feld ist ein abgeleitetes Feld.
J | Das Feld wurde in den Fokus von einer anderen Datenquelle importiert (vereint).

In der Spalte „Kommentare“ werden alle Kommentare angezeigt [siehe Kommentar mithilfe von Decision Studio an einem Fokus oder Feld anhängen], die Feldern zugeordnet sind.

Anmerkung: Aus Gründen der Effizienz werden im Fenster von Decision Studio nicht immer aktuelle Statistiken angezeigt. Nicht mehr aktuelle Feldstatistiken werden im Decision Studio grau hinterlegt.
  • Um die Statistiken für ein Einzelfeld zu aktualisieren, markieren Sie das Feld und wählen „Feld>Statistiken aktualisieren“ oder klicken mit der rechten Maustaste auf das Feld und wählen „Statistiken aktualisieren“.
  • Um die Statistiken für jedes Feld im Fokus zu aktualisieren, wählen Sie „Fokus>Alle Statistiken aktualisieren“.
Übergeordnetes Thema: Mit Fokus-Metadaten arbeiten

Anzeige der Fokusinformationen in Decision Studio

wählen Sie im Fenster von Decision Studio „Fokus>Fokus-Informationen“.

Ein Fenster erscheint und zeigt die grundlegenden Informationen über den Fokus und den Fokusverlauf an. Darüber hinaus werden alle dem Fokus zugeordneten Kommentare [siehe Kommentar mithilfe von Decision Studio an einem Fokus oder Feld anhängen] angezeigt.

Anzeige der Feldinformationen in Decision Studio

Markieren Sie im Fenster von Decision Studio ein Feld und wählen Sie „Feld>Eigenschaften“ oder klicken Sie mit der rechten Maustaste und wählen Sie „Eigenschaften“ oder klicken Sie in der Symbolleiste auf [image].

Anzeige von Fokus- und Feldinformationen in Portrait Miner

Klicken Sie in Portrait Miner mit der rechten Maustaste auf einen Fokus und wählen Sie „Metadaten>Ansichten“.

Im Dialogfeld „Fokus-Information anzeigen“ können Sie den Umfang der Feldinformationen auswählen, die eingeschlossen werden sollen.

Dann erscheint ein Fenster und zeigt die grundlegenden Informationen über den Fokus und den Fokusverlauf an. Darüber hinaus werden alle dem Fokus zugeordneten Kommentare [siehe Kommentar mithilfe von Decision Studio an einem Fokus oder Feld anhängen] angezeigt.

Die Feldinformationen (falls angefordert) erscheinen unter den Fokusinformationen. Wenn Sie detaillierte Feldinformationen anzeigen auswählen, beinhaltet dies die Feldstatistiken sowie alle diesem Feld zugeordneten Kommentare.

Anmerkung: Über dieses Dialogfeld „Fokus-Information anzeigen“ kann auf viele Funktionen zugegriffen werden, die über den Dateierstellungsbefehl „qsdescribe“ in Portrait Miner bereitgestellt werden.

Siehe auch

Informationen über Portrait Miner-Assistenten

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Anzeige von Abhängigkeiten und Dateigrößen für einen Fokus

Ein Fokus wird auf einer Festplatte als .ftr-Datei (die „Fokusdatei“), zusammen mit einer Sammlung von Datendateien und anderen Dateien in zwei Ordnern gespeichert, wobei die Namen mit .rdx („Raw Data eXtract“) und .xtr („eXTRa“) enden. Diese Ordner werden in Portrait Miner und in der Registerkarte „Quadstone“ des Portrait Miner-Dateibrowser im Allgemeinen nicht angezeigt [siehe Navigieren zum Öffnen oder Speichern einer Datei, Sitzung oder einer Datenbanktabelle].

Ein neuer Fokus, erstellt durch kopieren eines vorhandenen Fokusses oder durch das Importieren von Daten von einer anderen Art von Datensatz (oder als Ergebnis der Ausführung eines TML-Skripts) ist von anderen Fokussen „unabhängig“. Auf der anderen Seite ist ein Fokus, der mit Decision Studio mit einem neuen Namen gespeichert, oder einer, der durch die Erstellung einer verlinkten Kopie erstellt wurde, abhängig von Datenordnern, die zu einem anderen Fokus gehören.

Für einen bestimmten Fokus können Sie herausfinden, von welchen Fokussen er abhängig ist, und welche Fokusse davon abhängig sind, sowie die Größe des für die Speicherung von Daten und Metadaten verwendete Festplattenspeicherplatz ansehen. Klicken Sie in Portrait Miner mit der rechten Maustaste auf dem Fokus und wählen Sie „Eigenschaften“.

Im Dialog „Fokus-Eigenschaften anzeigen“ können Sie auswählen, ob der Bericht der Fokuseigenschaften als XML- oder HTML-Datei gespeichert werden soll. Die Eigenschaften des Fokus werden auch in der Registerkarte „Ausgabe“ im für die Ausgabedatei ausgewählten Format angezeigt.

Anmerkung: Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl qsinfo in Portrait Miner bereitgestellt werden, zuzugreifen.

Siehe auch

Informationen über Portrait Miner-Assistenten

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten


Kopieren der Fokus-Metadaten von einem Fokus zum anderen

Sie können die Fokus-Metadaten [siehe Fokus-Metadaten] von einem Fokus zum anderen, einschließlich der Definitionen abgeleiteter Felder, Feldinterpretationen, Klasseneinteilungen, Datensatzauswahlen, Feld- und Fokuskommentare und Fokusverlauf, kopieren.

Eine Möglichkeit dafür ist die Speicherung der Fokus-Metadaten in einer Datei, und dann die Übernahme der gespeicherten Metadaten in einen anderen Fokus. Eine andere Möglichkeit ist die Verwendung eines Fokus direkt als Metadaten-„Vorlage“ für einen anderen Fokus.

Anmerkung: Wenn Sie eine Metadatenvorlage für einen Fokus übernehmen, werden Feld- und Fokuskommentare nicht eingeschlossen. Außerdem gilt, Sie können eine Metadatenvorlage für einen Zielfokus nicht übernehmen, wenn der Zielfokus bereits Feldinterpretationen, Auswahlen oder Klasseneinteilungen enthält.

Siehe auch

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten
Übergeordnetes Thema: Mit Fokus-Metadaten arbeiten

Speichern der Fokus-Metadaten

Wählen Sie im Fenster von Decision Studio Fokus>Metadaten exportieren [siehe Navigieren zum Öffnen oder Speichern einer Datei, Sitzung oder einer Datenbanktabelle], um einen Speicherort auszuwählen, unter dem die Fokus-Metadatendatei gespeichert werden soll.

Exportieren von Fokus-Metadaten mithilfe von Portrait Miner

Klicken Sie in Portrait Miner mit der rechten Maustaste auf den Fokus und wählen Sie Metadaten>Exportieren.

Der Dialog „Metadaten exportieren“ erscheint. Sie können einen Speicherort für die gespeicherte Metadatendatei auswählen (oder einfach das Standardverzeichnis übernehmen).

Anmerkung: Diese Benutzeroberfläche ist eine Möglichkeit für den Zugriff auf die Funktionen, die über den Dateierstellungsbefehl „qsexportmetadata“ von Portrait Miner bereitgestellt werden (und hat exakt die gleiche Wirkung, wie die Speicherung der Metadaten von Decision Studio aus).

Übernahme gespeicherter Metadaten für einen neuen Fokus

Tun Sie in Portrait Miner Folgendes:
  • Klicken Sie mit der rechten Maustaste auf die Fokus-Metadatendatei (.qsfm) und wählen Sie „Als Metadaten in Fokus importieren“.

    Wählen Sie im Dialogfeld „Metadaten in Fokus importieren“ den Zielfokus.

  • Klicken Sie mit der rechten Maustaste auf den Zielfokus und wählen Sie „Metadaten>Importieren“.

    Wählen Sie im Dialogfeld „Metadaten in Fokus importieren“ die Fokus-Metadatendatei aus.

Sie können exakt auswählen, welche Art von Metadaten importiert werden sollen und ändern das Ziel für den Fokus. Nachdem die Parameter definiert wurden, klicken Sie auf „Weiter“, um die Details für den Importvorgang auszuwählen.
Anmerkung:
  • Außer wenn Sie explizit Felder auswählen, importiert Portrait Miner feldbezogene Metadaten für alle Felder in den Fokus.
  • Das Standardverhalten überschreibt den Zielfokus, wobei ein Fokus die ausgewählten Metadaten enthält. Wenn das relevante Kontrollkästchen von Ihnen deaktiviert wird, können Sie stattdessen einen Speicherort für einen neuen Fokus angeben.
  • Beim Importieren von Metadaten werden die kategorischen Interpretationen in Klasseneinteilungen und nicht in Interpretationen eingeteilt.
  • Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl qsimportmetadata in Portrait Miner bereitgestellt werden, zuzugreifen.

Siehe auch

Informationen über Portrait Miner-Assistenten


Fokus-Metadaten in Excel bearbeiten

Sie können Fokus-Metadaten [siehe Fokus-Metadaten] in Excel bearbeiten, einschließlich der Feldanzeigebeschriftungen, Interpretationen, Tags, Ableitungen und Kommentare.
  1. Exportieren einer Datei mit Metadaten [siehe Speichern der Fokus-Metadaten] aus einem Fokus. Für einen neu importierten Datensatz ist dies eine leere Vorlage. Und für einen Datensatz, an dem Sie gearbeitet haben, sind alle Beschreibungen, Kennzeichnungen, Klasseneinteilungen, Ableitungen und andere Details enthalten, die Sie hinzugefügt haben.
  2. Um eine Excel-Datei zum Bearbeiten zu erstellen, klicken Sie mit der rechten Maustaste auf die Metadatendatei und wählen Sie „In Excel importieren“.
  3. Um die Metadaten in Excel zu bearbeiten, klicken Sie mit der rechten Maustaste auf die Excel-Datei und wählen Sie „Nach Excel übertragen“. Weitere Einzelheiten darüber, wie die Metadaten zu bearbeiten sind, finden Sie in der Excel-Datei.
  4. Um eine Fokus-Metadatendatei zu erstellen, klicken Sie mit der rechten Maustaste auf die Excel-Datei und wählen Sie „Als Fokus-Metadaten exportieren“.
Übergeordnetes Thema: Mit Fokus-Metadaten arbeiten


Arbeiten mit Feldgruppen

  • Gekennzeichnete Feldgruppen
  • Benutzerkennzeichnungen


Gekennzeichnete Feldgruppen

Sie können Feldgruppen entsprechend den hinzugefügten Kennzeichnungen verwalten.
Übergeordnetes Thema: Arbeiten mit Feldgruppen

Informationen zu Kennzeichnungen

Eine Kennzeichnung kann eine Benutzer-Kennzeichnung oder eine Interpretation sein. Jede Benutzer-Kennzeichnung wird durch eine farbige Markierung mit seinen Anfangsbuchstaben vertreten. Die Farben dieser Marker werden automatisch generiert.
Die Registerkarte „Kennzeichnungen“ auf der linken Seite des Fensters Decision Studio zeigt die aktuellen Kennzeichnungen. Jede Kennzeichnung wird in einer separaten Zeile angezeigt mit:
  • Einer Statusanzeige und einem Dropdown-Menü, um zu steuern, ob Felder mit dieser Kennzeichnung angezeigt werden sollen oder nicht:
    • Keine Option: Felder mit diesem Tag werden je nach den getroffenen Auswahlen bei anderen Tags angezeigt oder nicht angezeigt.
    • Felder mit dieser Kennzeichnung anzeigen: Felder mit diesem Tag werden angezeigt, es sei denn, sie besitzen ein anderes Tag, das auf Ausblenden gesetzt ist. Felder ohne diese Kennzeichnungen werden ausgeblendet, außer, wenn eine ihrer Kennzeichnungen auch auf Anzeigen gesetzt ist.
    • Felder mit dieser Kennzeichnung immer ausblenden: Felder mit dieser Kennzeichnung werden auch dann ausgeblendet, wenn das Feld eine weitere Kennzeichnung hat, die auf Anzeigen gesetzt ist.
  • Für Benutzer-Kennzeichnungen ist es eine farbige Markierung.
  • Der Name der Kennzeichnung.
  • In Klammern die Anzahl der Felder mit dieser Kennzeichnung. Im Fall der abgeleiteten Interpretation zeigt dieser Text auch die Anzahl der neu erstellten Felder an, wenn sie in der Ansicht ausgeblendet sind.
Beim Start eines Tools basieren die darin angezeigten Felder auf der aktuellen Anzeige im Decision Studio-Fenster. Allerdings haben die meisten Feldlisten in der Anwendung auch ein Kontrollkästchen „Alle Fokusfelder“, das ein Anzeigen aller Felder unabhängig von der Ansicht im Decision Studio-Fenster ermöglicht.
  • Die Scorecard-Assistent zeigt immer die Felder mit der „Analyse“-Interpretation. Die Felder im Decision Studio-Fenster haben keinen Einfluss auf diese.
  • Der Entscheidungsbaum-Werkzeug und der Clustermodell-Werkzeug zeigen die Felder mit der „Analyse“-Interpretation sowie alle Felder, die im Decision Studio-Fenster angezeigt wurden, aber nicht über die „Analyse“-Interpretation verfügten, als sie gestartet wurden. Darüber werden alle Felder weiter angezeigt, die beim Start des Tools „Analyse“-Interpretation hatten, von denen aber die Interpretation entfernt wurde.
  • Die Viewer (Kreuztabellenansicht, Zuordnungsansicht, Kreuzverteilungsansicht und Profilansicht) zeigen alle Felder an, die aktuell im Decision Studio-Fenster sichtbar sind sowie alle, die in der Kreuztabellen-Spezifikation während der Laufzeit des Tools verwendet wurden.
Anmerkung: Wenn Sie einen Fokus mit einer Vielzahl von Feldern benutzen, richten Sie vor dem Start der Tools eine Ansicht auf die Felder ein, die für Sie im Decision Studio-Fenster von Interesse sind.

Siehe auch

Benutzerkennzeichnungen

Feldinterpretationen

Anzeigen oder Ausblenden von Feldern im Decision Studio

Klicken Sie auf das Menü „Kennzeichnungsstatus“, um auszuwählen, welche Feldgruppe angezeigt oder ausgeblendet wird. Wenn Sie alternativ direkt auf die Statussymbole klicken, wird durch die drei verfügbaren Zustände gerollt.

Die Anzahl der zur Zeit angezeigten Felder und die Gesamtzahl der Felder werden in einer Statusleiste am unteren Rand des Fensters angezeigt.

Anmerkung: Wenn Decision Studio gestartet wird oder ein Fokus geladen ist, haben alle Kennzeichnungen den Status „Keine Option“, daher werden alle Felder angezeigt.

Alle Felder anzeigen

Um die Ansicht auf den Standard zurückzusetzen, auf den alle Kennzeichnungen auf „Keine Option“ gesetzt sind und alle Felder angezeigt werden, klicken Sie mit der rechten Maustaste irgendwo in die Registerkarte „Kennzeichnungen“ und wählen Sie „Alle Felder anzeigen“.


Benutzerkennzeichnungen

In Decision Studio können Felder mit Kennzeichnungen versehen und Felder können auf Basis dieser Kennzeichnungen angezeigt und ausgeblendet werden. Eine Kennzeichnung ist einfach ein Wort, das einem Feld zugeordnet wurde. Einem Feld kann eine beliebige Anzahl von Kennzeichnungen zugeordnet werden und eine Kennzeichnung kann einer beliebigen Anzahl von Feldern zugeordnet werden.
Übergeordnetes Thema: Arbeiten mit Feldgruppen

Erstellung einer Kennzeichnung

  1. Markieren Sie im Decision Studio-Fenster die Felder, die Sie kennzeichnen möchten.
  2. Klicken Sie mit der rechten Maustaste und wählen Sie die Optionen „Benutzerkennzeichnung hinzufügen > Neu“ oder alternativ „Kennzeichnung > Neu“ oder „Kennzeichnung > Benutzerkennzeichnung hinzufügen> Neu“ aus dem Hauptmenü aus.
  3. Geben Sie einen Namen für die Kennzeichnung ein und klicken Sie auf OK. Hinweis: Sie sollten die Verwendung von Namen von Kennzeichnungen vermeiden, die mit dem gleichen Buchstaben beginnen, um so sicherzustellen, dass jede Kennzeichnung in der Spalte „Benutzerkennzeichnungen“ im Decision Studio-Fenster einen anderen Buchstaben erhalten.
  4. Wählen Sie aus den Optionen „Diese Felder markieren“ aus:
    • Keine, um eine Kennzeichnung zu erstellen, die keinem Feld zugeordnet ist.
    • Ausgewählte Felder, um eine Kennzeichnung zu erstellen und zu den Feldern, die derzeit im Fenster von Decision Studio markiert sind, hinzuzufügen.
    • Felder, die mit regulärem Ausdruck übereinstimmen, um eine Kennzeichnung zu erstellen und zu den Feldern hinzuzufügen, die mit einem regulären Ausdruck übereinstimmen. Beispiel: Der reguläre Ausdruck .*Code entspricht allen Feldern, die mit Code enden.
  5. Klicken Sie auf OK.

Siehe auch

Regular Expression

Löschen einer Kennzeichnung

  1. Klicken Sie im Decision Studio-Fenster im Bereich Benutzer mit der rechten Maustaste auf der Kennzeichnung.
  2. Wählen Sie im Menü Löschen

Umbenennen einer Kennzeichnung

  1. Klicken Sie im Decision Studio-Fenster im Bereich Benutzer mit der rechten Maustaste auf der Kennzeichnung.
  2. Wählen Sie im Menü Umbenennen.

Hinzufügen eines Feldes zu einer gekennzeichneten Gruppe

  1. Markieren Sie im Decision Studio-Fenster die Felder, die Sie kennzeichnen möchten.
  2. Wählen Sie Benutzerkennzeichnung hinzufügen, indem Sie entweder mit der rechten Maustaste auf die markierten Felder klicken oder wählen Sie die Funktion aus dem Menü Kennzeichnung.
  3. Klicken Sie auf den Namen der gewünschten Kennzeichnung. Hinweis: Wo Feld/Felder bereits eine Kennzeichnung enthalten, ist der Name grau hinterlegt.

Entfernen eines Feldes aus einer gekennzeichneten Gruppe

  1. Markieren Sie im Decision Studio-Fenster die Felder, aus denen Sie eine Kennzeichnung entfernen möchten.
  2. Wählen Sie „Kennzeichnung löschen“, indem Sie entweder mit der rechten Maustaste auf die markierten Felder klicken oder wählen Sie die Funktion aus dem Menü „Kennzeichnung“.
  3. Klicken Sie auf den Namen der Kennzeichnung. Wo keine Felder eine Kennzeichnung enthalten, ist der Name grau hinterlegt.
Anmerkung: Eine Kennzeichnung, die keinem Feld zugeordnet wurde, wird nicht mit dem Fokus gespeichert.

Feldkennzeichnungen anzeigen

  1. Im Fenster von Decision Studio ein Feld markieren.
  2. Wählen Sie Feld>Eigenschaften oder klicken Sie mit der rechten Maustaste und wählen Sie Eigenschaften oder klicken Sie in der Symbolleiste auf [image].

Kennzeichnungen regulärer Ausdrücke bearbeiten

Wenn Sie eine Kennzeichnung eines regulären Ausdrucks erstellt haben, können Sie den regulären Ausdruck aktualisieren und ihn auf alle Felder anwenden.

  1. Klicken Sie im Decision Studio-Fenster im Bereich Benutzer (linkes Menü) mit der rechten Maustaste auf die Kennzeichnung des regulären Ausdrucks.
  2. Wählen Sie Bearbeiten und aktualisieren Sie den Namen oder regulären Ausdruck.
  3. Klicken Sie auf OK. Das System wendet den regulären Ausdruck auf alle Felder an.
Anmerkung: Die Bearbeitungsoption ist nur in der aktuellen Sitzung verfügbar. Beim erneuten Laden eines gespeicherten Fokus ist die Kennzeichnung des regulären Ausdrucks verfügbar, jedoch können Sie die Werte nicht mehr bearbeiten.


Zusammenfassen Segmentieren und Visualisieren von Fokusdaten mittels Kreuztabellen

  • Kreuztabellen als Basis für die Segmentierung und Visualisierung von Daten
  • Aggregationsfunktionen für Kreuztabellen
  • Erstellen einer textuellen Kreuztabellenansicht
  • Anordnen von Feldern und Statistiken in einer Kreuztabelle oder einem Graphen
  • Weitere Details in einem ausgewählten Segment eines Diagramms anzeigen
  • Eine Kreuztabelle auf einen Fokus anwenden


Kreuztabellen als Basis für die Segmentierung und Visualisierung von Daten

Decision Studio verwendet abstrakte Kreuztabellen nicht nur als Basis für die Kreuztabellenansicht, sondern auch für Profil-, Kreuzdistributions- und Kartendiagrammen.

Eine „Kreuztabelle“ in diesem Sinn besteht aus 0 oder mehr Aufschlüsselungsfeldern sowie einer oder mehrerer Statistiken. Die Statistiken werden für jeden Zelle der potentiell mehrdimensionalen Segmentierung, die durch die Klasseneinteilung der Aufschlüsselungsfelder definiert ist, ausgewertet.

Sobald Sie eine abstrakte Kreuztabelle spezifiziert haben und die Statistiken berechnet wurden, können Sie die Felder und Statistiken [siehe Anordnen von Feldern und Statistiken in einer Kreuztabelle oder einem Graphen] innerhalb Ihrer Kreuztabellenansicht oder Diagramm nach Belieben anordnen.

Siehe auch

Aggregationsfunktionen für Kreuztabellen
Übergeordnetes Thema: Zusammenfassen Segmentieren und Visualisieren von Fokusdaten mittels Kreuztabellen

Felder und Statistiken in einer Kreuztabelle spezifizieren

  1. Im Kreuztabellenansicht, Profilansicht, Kreuzverteilungsansicht oder im Zuordnungsansicht wählen Sie „Bearbeiten>Kreuztabelle bearbeiten“ oder klicken in der Symbolleiste auf [image].

    Das Dialogfeld „Felder und Aggregationsfunktionen auswählen“ erscheint.

  2. Markieren Sie die gewünschten Aufschlüsselungsfelder im Bereich „Verfügbare Felder“ und klicken Sie auf [image], um die markierten Felder dem Bereich „Ausgewählte Felder“ hinzuzufügen.
  3. Für jede benötigte Statistik:
    1. Markieren Sie die Aggregationsfunktion [siehe Aggregationsfunktionen für Kreuztabellen] im Fenster „Verfügbare Funktionen“.
    2. Wenn die Aggregationsfunktion ein Argument benötigt, markieren Sie das benötigte Feld in Fenster „Funktionsparameter“.
    3. Klicken Sie auf [image], um die Statistik dem Bereich „Ausgewählte Aggregationsfunktionen“ hinzuzufügen.

    (Sie können mehrere Aggregationsfunktionen und/oder Felder gleichzeitig markieren. Wenn Sie dann auf [image] klicken, erhalten Sie alle gültigen Funktion/Feld-Kombinationen als Statistik.)

  4. klicken Sie auf „OK“, um die Kreuztabelle zu erstellen.
Anmerkung:
  • Wenn ein Viewer auf einen anderen Viewer folgt [siehe Tool-Zuordnungen] (ausgenommen ein Profilansicht folgt auf einen anderen Viewer oder umgekehrt), können Sie „Führende Spezifikation verwenden“ prüfen, um den nachfolgenden Viewer zu zwingen, die Spezifikation der abstrakten Kreuztabelle des führenden Viewers (zusammen mit ihren markierten Segmentdaten) zu übernehmen.

    Die Option „Führende Spezifikation verwenden“ ist standardmäßig ausgewählt (wenn möglich), wenn Sie einen Drilldown [siehe Weitere Details in einem ausgewählten Segment eines Diagramms anzeigen] über das Menü „Segmente>Drill Down“ angestoßen haben.

  • Die Leiste „Geschätzte Größe“ im Dialogfeld gibt eine ungefähre Übersicht über die Größe der Kreuztabelle in Bezug auf die Daten. Wenn die Leiste den verfügbaren Platz ausfüllt, ist es wahrscheinlich, dass die Kreuztabelle zu groß wird, um ausgewertet zu werden oder dass ein Zugriff darauf zu lange dauert.

    Sie können das Limit für die Größe der Kreuztabelle durch Einstellen einer Präferenz [siehe Festlegen der Portrait Miner-Einstellungen] ändern: Im Abschnitt „Aggregation“ wählen Sie den Wert für die Option „max Größe“ aus. (Portrait Miner verwendet diesen Wert bei der Berechnung der Kreuztabelle; die Leiste „Geschätzte Größe“ wird nicht für die Größenschätzung verwendet.)

  • Um ein Feld oder eine Statistik aus dem Bereich „Ausgewählte Felder“ oder „Ausgewählte Aggregationsfunktionen“ zu entfernen, markieren Sie das Feld oder die Statistik und klicken auf der rechten Seite des Bereichs auf [image].

Speichern einer Kreuztabelle aus Decision Studio

Wenn Sie eine textliche Kreuztabelle, ein Kreuzdistributionsgraph, eine Reihe Profilgraphen oder ein Kartengraph erneut verwenden oder für jemanden freigeben möchten, der keinen Vollzugriff auf Portrait Miner hat, können Sie die zugrunde liegende abstrakte Kreuztabelle (einschließlich der geprüften Statistik) speichern.
  1. Wählen Sie „Datei>Speichern unter“ oder klicken Sie in der Symbolleiste auf [image].
  2. Navigieren Sie [siehe Navigieren zum Öffnen oder Speichern einer Datei, Sitzung oder einer Datenbanktabelle] zum gewünschten Speicherort und wählen Sie einen Namen für die Kreuztabelle.

Jeder Decision Studio Viewer speichert seine eigene Form der Kreuztabelle (mit einer eindeutigen Dateierweiterung), die Sie in einem oder mehreren Decision Studio Viewern anzeigen können. (Sie können auch die Dateierweiterung .qsxt für eine allgemeine Kreuztabelle verwenden.)

Decision Studio Viewer | Dateinamenerweiterung | Kompatible Decision Studio Viewer
Kreuztabellenansicht | .qstv | Kreuztabellenansicht, Zuordnungsansicht und Kreuzverteilungsansicht
Kreuzverteilungsansicht | .qsdv | Kreuztabellenansicht, Zuordnungsansicht und Kreuzverteilungsansicht
Profilansicht | .qspv | Profilansicht
Zuordnungsansicht | .qsmv | Kreuztabellenansicht, Zuordnungsansicht und Kreuzverteilungsansicht
Alle | .qsxt | Abhängig vom aktuellen Kreuztabellenansicht

Siehe auch

Exportieren von tabellarischen Daten aus Decision Studio

Eine Kreuztabelle auf einen Fokus anwenden

Eine Kreuztabelle in Decision Studio öffnen

Speichern eines Decision Studio Modells oder einer Segmentierung zur Verwendung als QMML (XML)

XML in Portrait Miner

Eine Kreuztabelle in Decision Studio öffnen

Wenn Sie eine vorher gespeicherte textliche Kreuztabelle, einen Kreuzdistributionsgraphen, eine Reihe Profilgraphen öffnen möchten, können Sie die darunter liegende abstrakte Kreuztabellenspezifikation laden, die dann auf den aktuellen Fokus angewendet wird.
  1. Wählen Sie „Datei>Öffnen“ oder klicken Sie in der Symbolleiste auf [image].
  2. Navigieren Sie [siehe Navigieren zum Öffnen oder Speichern einer Datei, Sitzung oder einer Datenbanktabelle] zur gewünschten Kreuztabellendatei.
Anmerkung:
  • Aufschlüsselungsfelder und Statistiken, die auf den aktuellen Fokus nicht anwendbar sind, werden nicht geladen.
  • Wenn alle Aufschlüsselungsfelder und Statistiken mit dem aktuellen Fokus kompatibel sind, wird das gespeicherte Layout [siehe Anordnen von Feldern und Statistiken in einer Kreuztabelle oder einem Graphen] der Kreuztabelle ebenfalls geladen.

Siehe auch

Speichern einer Kreuztabelle aus Decision Studio
© 2015 Pitney Bowes Software Inc. Email: software.support@pb.com


Aggregationsfunktionen für Kreuztabellen

Folgende Aggregationsfunktionen stehen zur Verwendung in abstrakten Kreuztabellen [siehe Kreuztabellen als Basis für die Segmentierung und Visualisierung von Daten] in Decision Studio. Wenn nicht anderweitig angegeben, übernimmt eine Aggregationsfunktion einen numerischen Wert, einen String oder ein Datumsfeld als Argument.

Auf den meisten Ansichten werden die Funktionen mit Anzeigeetiketten versehen. Diese Etiketten können auf der Registerkarte „Funktionsetiketten“ während der Bearbeitung der Ansichtsoptionen über „Bearbeiten“ im Decision Studio Fenster bearbeitet werden. Ansichtsoptionen werden für weitere Sitzungen eines jeden Benutzers gespeichert. Funktionsetiketten werden nicht mit dem Fokus gespeichert.

Siehe auch

Feldbeschreibungen
Funktion | Standardetikett | Ergebnis
Any [siehe any] | Vorschauwert von | Der Wert ungleich Null im Feld, gezogen aus einem beliebigen Datensatz mit Wert ungleich Null im Segment
ConfIntLower [siehe confintlower] | 95 % untere Grenze von | Die Untergrenze eines 95% Konfidenzintervalls für den Mittelwert des Feldes in dem Segment.
ConfIntUpper [siehe confintupper] | 95 % obere Grenze von | Die Oberegrenze eines 95 % Konfidenzintervalls für den Mittelwert des Feldes in dem Segment.
Count [siehe count] | Anzahl | Die Anzahl der Datensätze im Segment (Diese Funktion übernimmt kein Argument.)
CountNonNull [siehe countnonnull/countnonnulls] | Anzahl nicht fehlend | Die Anzahl der Datensätze in dem Segment bei denen das Feld Werte ungleich Null enthält [siehe Der Nullwert]
CountNull [siehe countnull/countnulls] | Anzahl fehlend | Die Anzahl der Datensätze in dem Segment bei denen das Feld Null enthält [siehe Der Nullwert]
CountUnique [siehe countunique] | Eindeutiger Wert von | Die Anzahl der eindeutigen Werte, einschließlich Null, die im Feld auftreten.
CountUniqueNonNull [siehe countuniquenonnull] | Eindeutige, nicht fehlende Werte von | Die Anzahl der eindeutigen Werte, einschließlich dem Wert Null, die im Feld auftreten
ExpectedCount [siehe expectedcount] | Erwartete Menge | Die Anzahl der Datensätze, die in dem Segment erwartet werden, wenn die Felder der Kreuztabelle unabhängig voneinander sind (Diese Funktion übernimmt kein Argument)
ExpectedProportion [siehe expectedproportion] | Erwartete Proportion | Der Anteil der Gesamtmenge, der in dem Segment erwartet wird, wenn die Felder der Kreuztabelle unabhängig voneinander sind (Diese Funktion übernimmt kein Argument.)
First [siehe first] | Erster Wert von | Der erste Wert ungleich Null im Feld für das Segment
Last [siehe last] | Letzter Wert von | Der letzte Wert ungleich Null im Feld für das Segment
Max [siehe max (ein Argument)] | Maximum | Der maximale Wert ungleich Null im Feld für das Segment
mean [siehe mean (ein Argument)] | Durchschnitt | Der Mittelwert (allgemeiner Durchschnitt) der ungleich Null ungleich Null in dem Feld einer Gruppe/Segment (Diese Funktion erfordert ein numerische Feld als Argument.)
median [siehe median] | Mittellinie | Der Mittellinie (Mittelwert) der ungleich Null ungleich Null in dem Feld einer Gruppe/Segment (Diese Funktion erfordert ein numerische Feld als Argument.)
Min [siehe min (ein Argument)] | Minimum | Der minimale Wert ungleich Null im Feld für das Segment
Mode [siehe Modus] | Am gebräuchlichsten | Der dichteste Wert (gebräuchlichster Wert) der Werte ungleich Null in dem Feld für das Segment
ModeRatio [siehe moderatio] | Purity von | Die Proportion der nicht-Null-Datensätze in dem Segment, das den gebräuchlichsten Wert ungleich Null im Feld enthält
PercentageRate [siehe percentagerate] | Prozentsatz von | Der Prozentsatz der Nicht-Null-Datensätze im Segment, das den Wert 1 in dem Feld enthält. Das Feld darf nur die Werte 0 und 1 enthalten.
Proportion [siehe Proportion] | Proportion | Die Anzahl der Datensätze im Segment als Proportion der Gesamtanzahl Datensätze (Die Funktion benötigt kein Argument).
SegmentIndex (segindex) [siehe segindex] | Segmentindex | Eine positive Zahl, die das Segment innerhalb der Kreuztabelle eindeutig identifiziert (Diese Funktion benötigt kein Argument)
Significance [siehe significance] | Signifikanz von | Die statistische Signifikanz einer Diskrepanz zwischen dem Mittelwert des Feldes im Segment und dem Mittelwert des Feldes der Gesamtmenge mit einem Zeichen, welches die Richtung der Abweichung anzeigt (Diese Funktion benötigt ein numerisches Feld als Argument).
StandardDeviation (stdev) [siehe stdev] | Std. dev. von | Die Standardabweichung der Werte ungleich Null in dem Feld für das Segment (Diese Funktion benötigt ein numerisches Feld als Argument.)
sum [siehe sum (ein Argument)] | Summe von | Die Summe der Werte ungleich Null in dem Feld für das Segment (Diese Funktion benötigt ein numerisches Feld als Argument).
Variance [siehe Abweichung] | Abweichung von | Die Abweichung der Werte ungleich Null in dem Feld für das Segment (Diese Funktion benötigt ein numerisches Feld als Argument).
Anmerkung: Bestimmte Aggregationsfunktionen (wie Median und dichtester Mode) können String- oder Datumsergebnisse produzieren - wenn Sie sie auf String- oder Datumsfelder anwenden. Da grafische Viewer keine String- oder Datumsstatistiken wiedergeben können, können Sie solche Funktionen nicht auf String- oder Datumsfelder anwenden, ausgenommen ist der Kreuztabellenansicht (der String - und Datumsstatistiken anzeigen kann).
Übergeordnetes Thema: Zusammenfassen Segmentieren und Visualisieren von Fokusdaten mittels Kreuztabellen


Erstellen einer textuellen Kreuztabellenansicht

  1. Markieren Sie im Decision Studio-Fenster ein oder mehrere Felder, die Sie in Ihrer Kreuztabelle verwenden möchten.
  2. Wählen Sie „Tools>Kreuztabellenansicht“ oder klicken Sie in der Symbolleiste auf [image].

    Die Kreuztabellenansicht wird geöffnet und zeigt eine Tabelle an (aufgeschlüsselt nach den von Ihnen markierten Feldern) mit der Anzahl der Datensätze und Durchschnittswerte für eine numerische Zielvariable , falls eine festgelegt wurde.

Anmerkung:
  • Wenn Sie den Kreuztabellenansicht starten, ohne Felder zu markieren, erscheint das Dialogfeld „Felder und Aggregationsfunktionen auswählen“ [siehe Kreuztabellen als Basis für die Segmentierung und Visualisierung von Daten]. Wenn Sie anschließend auf „OK“ klicken, ohne Felder auszuwählen, zeigt der Kreuztabellenansicht Zusammenfassungsstatistiken für den gesamten Datensatz an.
  • Um die untergeordnete Kreuztabelle jederzeit zu ändern [siehe Kreuztabellen als Basis für die Segmentierung und Visualisierung von Daten], wählen Sie „Bearbeiten>Kreuztabelle Bearbeiten“ oder klicken Sie in der Symbolleiste auf [image].
  • Wenn es in der angeforderten Kreuztabelle Stringfelder gibt, die weder eine kategorische noch eine geografische Interpretation aufweisen, fordert der Kreuztabellenansicht Sie auf, diese zu interpretieren, sodass sie angemessen in Klassen eingeteilt werden können. Sie können die standardmäßige kategorische Interpretation wählen, eine gespeicherte kategorische Hierarchie verwenden, oder das Feld als geografisch interpretieren.

Siehe auch

Eine Kreuztabelle in Decision Studio öffnen

Anordnen von Feldern und Statistiken in einer Kreuztabelle oder einem Graphen

Übergeordnetes Thema: Zusammenfassen Segmentieren und Visualisieren von Fokusdaten mittels Kreuztabellen

Kreuztabellenansichten

Standardmäßig enthält der Kreuztabellenansicht alle Felder als Zeilenüberschriften [image]. Die einzige Ausnahme ist, wenn Sie genau zwei Felder im Fenster von Decision Studio markieren, bevor Sie den Kreuztabellenansicht öffnen, macht der Kreuztabellenansicht eins zu einer Zeilenüberschrift und das andere zu einer Spaltenüberschrift.

Wenn sowohl Zeilen- als auch Spaltenüberschriften vorhanden sind, gibt es nur einen Bereich, in dem eine tabellarische Statistik gleichzeitig angezeigt werden kann; falls Sie über mehr als eine verfügen, stellt der Kreuztabellenansicht jede Statistik tabellarisch in ihrem eigenen Registerkartenfenster dar:

Abgesehen von den gewöhnlichen Klassen der Merkmale gibt es drei außergewöhnliche Klassen: die Klasse für Nullwerte [siehe Der Nullwert], die unklassifizierte Klasse und die spezielle Klasse für Kreuztabellen-Zusammenfassungen, die alle Kundendatensätze enthält. Die Datensätze, die sowohl in die Altersklasse 50–59 und in die Klasse für die Geschlechtsübersicht fallen, sind beispielsweise einfach die Datensätze, die in die Altersklasse 50–59 fallen. In der Praxis bedeutet das, dass, wenn Sie Übersichtsklassen in eine Kreuztabellenansicht einfügen, Sie die Informationen für alle möglichen Kreuztabellen einschließlich aller Merkmale ablesen können.

Der Kreuztabellenansicht bietet folgende Anzeigeoptionen:

  • Wählen Sie Ansicht>Nulldaten oder klicken Sie in der Symbolleiste auf [image], um die Anzeige der Klassen für Nullwerte ein- bzw. auszuschalten.
  • Wählen Sie „Ansicht>Zusammenfassungsdaten“ oder klicken Sie in der Symbolleiste auf [image], um die Anzeige der Klassen für Zusammenfassungen ein- bzw. auszuschalten.
Anmerkung:

Obwohl jede Klasseneinteilung eine Klasse für den Nullwert enthält, so enthält nicht jede Klasseneinteilung eine unklassifizierte Klasse.

Siehe auch

Zur Maximierung eines Bildschirms in einem Decision Studio-Tool

Festlegen des Anzeigeformats für numerische und Datumswerte


Anordnen von Feldern und Statistiken in einer Kreuztabelle oder einem Graphen

Sie können im „Konfigurationsbereich für Graphen“ am unteren Rand des Kreuztabellenansichts, Profilansicht, Kreuzverteilungsansichts oder Zuordnungsansichts Felder und Statistiken anordnen:

  • Die Felder und Statistiken in der untergeordneten Kreuztabelle [siehe Kreuztabellen als Basis für die Segmentierung und Visualisierung von Daten] werden durch bewegliche Schaltflächen dargestellt, zum Beispiel:

  • Die Leiste [image] (Nur zur Information) am unteren Rand des Konfigurationsbereichs für Graphen zeigt die Felder und Statistiken, die Teil der darunter liegenden Kreuztabelle sind, aber nicht in der angezeigten Tabelle oder Graphen erscheinen.
  • Die grünen ( [image]) Teile des Konfigurationsbereichs für Diagramme zeigen die Aspekte der Kreuztabelle oder der grafischen Darstellung, mit denen Sie Felder verknüpfen können:
    Symbol Kreuztabelle/Graph-Aspect
    x (links — rechts) Achse im Kreuzverteilungsansicht oder Profilansicht
    y (vorne — hinten) Achse im Kreuzverteilungsansicht
    z (vertikal) Achse im Kreuzverteilungsansicht
    Behandelte/Kontrollsegment-Vergleichsgröße im Kreuzverteilungsansicht oder Kreuztabellenansicht, wird normalerweise mit einem Partitionsfeld verwendet
    Zeilenaufschlüsselungsfeld im Kreuztabellenansicht
    Spaltenaufschlüsselungsfeld im Kreuztabellenansicht
    Ort für geplottete Blöcke und herangezogene Bereiche im Zuordnungsansicht
    Ort für den Beginn von Pfeilen im Zuordnungsansicht
    Ort für das Ende von Pfeilen im Zuordnungsansicht
  • Die lila ( [image]) Teile des Konfigurationsbereichs für grafische Darstellungen zeigen die Aspekte der Kreuztabelle oder der grafischen Darstellung, mit denen Sie Statistiken verknüpfen können:
    Symbol Kreuztabelle/Graph-Aspect
    Blockfarbe (Block, Region oder Pfeilfarbe im Zuordnungsansicht)
    Blockhöhe (Block- oder Bereichshöhe im Zuordnungsansicht)
    Blockbreite
    Blocktiefe
    Blockvolumen
    Tabellierte Statistik im Kreuztabellenansicht
    Pfeildicke in Zuordnungsansicht
Übergeordnetes Thema: Zusammenfassen Segmentieren und Visualisieren von Fokusdaten mittels Kreuztabellen

Für das Verbinden eines Feldes oder einer Statistik mit einer Kreuztabellen-/Diagrammansicht

Ziehen Sie das Feld oder die Statistik (d.h. die entsprechende bewegliche Schaltfläche im Diagramm-Konfigurationsbereich) und legen Sie es neben der Schaltfläche für die/das gewünschte Kreuztabelle/Diagramm ab.

Wenn Sie ein Feld oder eine Statistik ziehen, ändert sich der Mauszeiger und zeigt an, was passiert, wenn Sie die Maustaste loslassen:

Zeiger | Aktion
 | Verbinden Sie das Feld oder die Statistik mit einer Kreuztabellen-/Diagrammansicht.
 | Tauschen Sie das/die gezogene Feld oder Statistik und das Feld oder die Statistik unter dem Mauszeiger.
 | Tun Sie nichts.
Anmerkung:
  • Sie können einer Statistik mehr als eine Ansicht eines Diagramms zuordnen, indem Sie eine zusätzliche bewegliche Schaltfläche für die Statistik erstellen: Klicken Sie mit der rechten Maustaste auf die Statistik und wählen Sie „Duplizieren“.

    Um eine unerwünschte, doppelt vorhandene Statistik zu entfernen, ziehen Sie eine Kopie auf eine andere und lassen den Mauszeiger los, sobald er sich ändert auf

    Sie duplizieren ein Feld im Zuordnungsansicht auf dieselbe Weise - für gleichzeitige Verwendung mit gezeichneten Blöcken/Bereiche und Pfeilen.

  • Wenn Sie auf eine ein Feld repräsentierende Schaltfläche klicken, können Sie den Klasseneditor zur Bearbeitung der Klasseneinteilung oder ein Dialogfeld „Werte auswählen“ starten bzw. öffnen, um die Datensatzauswahl zu ändern. Dieser Vorgang gilt nur für den gesamten Datensatz, nicht nur für die aktuelle Ansicht.
  • Wenn Sie auf eine ein Feld repräsentierende Schaltfläche oder Statistik klicken besteht außerdem die Option der Filterung der Werte aus dem Diagramm. Dabei handelt es sich um einen Filter, der ausschließlich für die aktuelle Ansicht gilt. Wenn Sie „Filter“ auswählen erscheint das Dialogfeld „Filter“. Es bestehen verschiedene Auswahlmöglichkeiten für die kategorische Filterung [siehe Wertauswahl oder Filterung unter Verwendung eines kategorischen Feldes] und nicht-kategorische Filterung [siehe Wertauswahl oder Filterung unter Verwendung eines/einer nicht-kategorischen Feldes oder Statistik].

    Sie können einen Filter weder hinzufügen, bearbeiten oder entfernen, solange ein Segment im Diagramm markiert ist. Decision Studio entfernt alle Filter, sobald die Kreuztabelle oder das Diagramm aktualisiert werden.

  • Wenn Sie die Vergleichsdimension ( [image]) verwenden - häufig mit einem Partitionsfeld — können Sie die angezeigten Vergleichsfunktionen konfigurieren. Klicken Sie mit der rechten Maustaste auf eine Statistik und wählen Sie „Deltakonfiguration“. Im Dialogfeld „Funktions-Delta-Typen konfigurieren“ können Sie auswählen, ob alle Datensätze, behandelten Datensätze oder Kontrolldatensätze berücksichtigt werden sollen - oder eine der verschiedenen Kennzahlen und Unterschiede. Im Kreuzverteilungsansicht werden Achse und Farbskalalegenden entsprechend mit Kommentaren versehen.

Um ein Feld oder eine Statistik aus einer Kreuztabelle oder aus einem Diagramm zu entfernen

Ziehen Sie das Feld oder die Statistik (d.h. die entsprechende bewegliche Schaltfläche) vom aktuellen Standort auf die Leiste [image].


Weitere Details in einem ausgewählten Segment eines Diagramms anzeigen

Führen Sie im Profilansicht, Kreuzverteilungsansicht oder Zuordnungsansicht einen der folgenden Schritte durch:
  • Doppelklicken Sie auf ein Segment. (Um weitere Details für mehrere Segmente anzuzeigen, markieren Sie die Segmente [siehe Segmente in einer Diagrammanzeige markieren] und halten die STRG-Taste weiter gedrückt, während Sie Doppelklick auf dem letzten Segment ausführen.)

    Decision Studio öffnet eine andere Ansicht des gleichen Typs mit derselben Kreuztabellenspezifikation [siehe Kreuztabellen als Basis für die Segmentierung und Visualisierung von Daten] .

  • Markieren Sie ein oder mehrere relevante Segmente [siehe Segmente in einer Diagrammanzeige markieren]. Wählen Sie aus dem Menü „Segmente>Drill-Down“ ein Tool, in welchem die ausgewählten Segmente dargestellt werden sollen: den Kreuztabellenansicht, Profilansicht, Kreuzverteilungsansicht oder Zuordnungsansicht.

    Wenn Sie den Profilansicht von einem der drei anderen Viewer auswählen, oder umgekehrt, müssen Sie die Felder und Statistiken [siehe Felder und Statistiken in einer Kreuztabelle spezifizieren], die Sie in Ihrem Segmentprofil benötigen, genau bestimmen. In allen anderen Fällen verwendet Decision Studio die gleiche Kreuztabellenbeschreibung [siehe Kreuztabellen als Basis für die Segmentierung und Visualisierung von Daten].

In jedem Fall ist der neue Viewer mit dem ursprünglichen Viewer verknüpft [siehe Tool-Zuordnungen], und das neu erstellte Diagramm zeigt weitere Details der markierten Segmente an (sofern möglich).

Anmerkung:
  • Wenn Sie neue Segmente im ersten Diagramm markieren, wird das zweite Diagramm entsprechend aktualisiert.
  • Das gleiche „Drill-down“-Verhalten wird auf alle Tool-Paare angewendet, die sich in einer Nachfolgerzuordnung befinden [siehe Tool-Zuordnungen].
  • Im Zuordnungsansicht hängt das Maß der Details von der Karte ab.
Übergeordnetes Thema: Zusammenfassen Segmentieren und Visualisieren von Fokusdaten mittels Kreuztabellen


Eine Kreuztabelle auf einen Fokus anwenden

Sie können eine Kreuztabellenspezifikation [siehe Kreuztabellen als Basis für die Segmentierung und Visualisierung von Daten] auf einen Fokus anwenden, um eine neue Kreuztabelle zu erstellen.
  • Führen Sie in Portrait Miner einen Rechtsklick auf der anzulegenden Kreuztabelle aus und wählen Sie „Für Fokus anwenden“.

Wählen Sie im Dialog Kreuztabelle anwenden die Kreuztabelle, die Sie anwenden möchten, den Fokus, für den Sie angewendet werden soll, und die Kreuztabellendatei, die Sie erstellen möchten, aus.

Anmerkung:
  • Wenn Sie eine Kreuztabelle für einen Fokus anwenden, stammen die Klasseneinteilungen für die Aufschlüsselungsfelder standardmäßig von dem neuen Fokus. Durch Markierung des entsprechenden Feldes können Sie stattdessen die der originalen Kreuztabelle zugeordneten Klasseneinteilungen verwenden.
  • Diese Benutzeroberfläche ist eine Möglichkeit für den Zugriff auf die meisten Funktionen, die über den Datenerstellungsbefehl qstxt in Portrait Miner bereitgestellt werden.

Siehe auch

Informationen über Portrait Miner-Assistenten

Eine Kreuztabelle in Decision Studio öffnen

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Textdateien in Portrait Miner ansehen und bearbeiten

Übergeordnetes Thema: Zusammenfassen Segmentieren und Visualisieren von Fokusdaten mittels Kreuztabellen


Fokusdaten grafisch visualisieren und segmentieren

  • Erstellen einer Gruppe von Profildiagrammen mit einer Variablen
  • Erstellen eines Kreuzverteilungsdiagramms mit mehreren Variablen
  • Um ein Diagramm auf einer Karte zu erstellen
  • So erstellen Sie eine Kategoriezuordnung aus einer kategorischen Hierarchiedatei
  • Optionen, die sich auf die Anzeige von Diagrammen und Entscheidungsbäumen auswirken
  • Für einen Fokus ein Profil erstellen und prüfen


Erstellen einer Gruppe von Profildiagrammen mit einer Variablen

  1. Markieren Sie im Decision Studio-Fenster ein oder mehrere Felder, die Sie verwenden möchten, um Ihre Daten darzustellen.
  2. Wählen Sie „Tools>Profilansicht“ oder klicken Sie in der Symbolleiste auf [image].

    Der Profilansicht wird geöffnet und zeigt ein Diagramm mit der Anzahl an Datensätzen pro Klasse für jedes der von Ihnen gewählten Felder an.

Anmerkung:
  • Wenn eine numerische Zielvariable im Fokus festgelegt wurde, zeigt der Profilansicht den Mittelwert der Zielvariable als Blockfarbe an (es sei denn, Sie haben die Einstellung „Funktion Zielvariable“ geändert).
  • Wenn Sie den Profilansicht starten, ohne Felder zu markieren, erscheint das Dialogfeld „Felder und Aggregationsfunktionen auswählen“ [siehe Kreuztabellen als Basis für die Segmentierung und Visualisierung von Daten].
  • Um die untergeordnete Kreuztabelle jederzeit zu ändern [siehe Kreuztabellen als Basis für die Segmentierung und Visualisierung von Daten], wählen Sie „Bearbeiten>Kreuztabelle Bearbeiten“ oder klicken Sie in der Symbolleiste auf [image].
  • Wenn es in der angeforderten Kreuztabelle Stringfelder gibt, die weder eine kategorische noch eine geografische Interpretation aufweisen, fordert der Profilansicht Sie auf, diese zu interpretieren, sodass sie angemessen in Klassen eingeteilt werden können. Sie können die standardmäßige kategorische Interpretation wählen, eine gespeicherte kategorische Hierarchie verwenden, oder das Feld als geografisch interpretieren.
  • Sie können mehrere Statistiken mit Blockhöhe zuordnen [siehe Anordnen von Feldern und Statistiken in einer Kreuztabelle oder einem Graphen], um ähnliche Statistiken auf einer einzelnen Achsengruppe für jedes dargestellte Feld miteinander zu vergleichen.

    Solange der Blockfarbe keine Statistik zugeordnet wurde, verwendet der Profilansicht eine Regenbogenfärbung, um die sich überlappenden Diagrammen, denen verschiedenen Statistiken zugeordnet sind, zu unterscheiden.

  • Wenn Sie mehreren Statistiken Blockfarben zuordnen, sollten Sie sicherstellen, dass die Diagramme verbunden skaliert werden [siehe Gemeinsames oder unabhängiges Skalieren eines Satzes Profildiagrammen]; andernfalls können Sie die Werte für die verschiedenen Statistiken nicht vergleichen.

Siehe auch

Eine Kreuztabelle in Decision Studio öffnen

Anordnen von Feldern und Statistiken in einer Kreuztabelle oder einem Graphen

Histogramm- und Balkendiagramm-Optionen

Optionen, die sich auf die Anzeige von Diagrammen und Entscheidungsbäumen auswirken

Ausrichten einer Diagrammanzeige mit Hilfe der Maus

Gemeinsames oder unabhängiges Skalieren eines Satzes Profildiagrammen

Übergeordnetes Thema: Fokusdaten grafisch visualisieren und segmentieren


Erstellen eines Kreuzverteilungsdiagramms mit mehreren Variablen

  1. Markieren Sie im Decision Studio-Fenster ein oder mehrere Felder (normalerweise zwei oder mehr), die Sie verwenden möchten, um Ihre Daten darzustellen.
  2. Wählen Sie „Tools>Kreuzverteilungsansicht“ oder klicken Sie in der Symbolleiste auf [image].

    Der Kreuzverteilungsansicht wird geöffnet und zeigt eine Diagramm mit der Anzahl der Datensätze an, die durch ihre ausgewählten Felder definiert wurde.

Anmerkung:
  • Der Kreuzverteilungsansicht stellt die Anzahl der Datensätze standardmäßig nach Blockhöhe dar, wenn Sie ein oder zwei Merkmalfelder markieren, und er verwendet Blockvolumen, wenn Sie drei Merkmalfelder markieren.
  • Wenn Sie mehr als drei Aufschlüsselungsfelder markieren, werden in der Kreuzverteilungsansicht zunächst nur drei von ihnen verwendet. Die übrigen erscheinen in der Leiste [image] (Nur zur Information) am unteren Fensterrand.
  • Wenn eine numerische Zielvariable im Fokus festgelegt wurde, zeigt der Kreuzverteilungsansicht den Mittelwert der Zielvariable als Blockfarbe an (es sei denn, Sie haben die Einstellung „Funktion Zielvariable“ geändert).
  • Wenn Sie ein Partitions -Feld im Fokus festgelegt haben, nimmt der Kreuzverteilungsansicht es in die Kreuztabelle auf und weist es der Vergleichsdimension [siehe Anordnen von Feldern und Statistiken in einer Kreuztabelle oder einem Graphen] ( [image]) zu. Bei einer Statistik, bei der Count, Mean, PercentageRate oder Sum verwendet werden, zeigt der Kreuzverteilungsansicht die Statistik für die behandelte Gesamtmenge minus der Statistik für die Kontroll-Gesamtmenge. Bei allen anderen Statistiken zeigt der Kreuzverteilungsansicht die Statistik für die ganze Gesamtmenge. Sie können den angezeigten Vergleich [siehe Für das Verbinden eines Feldes oder einer Statistik mit einer Kreuztabellen-/Diagrammansicht] ändern.
  • Wenn Sie den Kreuzverteilungsansicht starten, ohne Felder zu markieren, erscheint das Dialogfeld „Felder und Aggregationsfunktionen auswählen“ [siehe Kreuztabellen als Basis für die Segmentierung und Visualisierung von Daten].
  • Um die untergeordnete Kreuztabelle jederzeit zu ändern [siehe Kreuztabellen als Basis für die Segmentierung und Visualisierung von Daten], wählen Sie „Bearbeiten>Kreuztabelle Bearbeiten“ oder klicken Sie in der Symbolleiste auf [image].
  • Wenn es in der angeforderten Kreuztabelle Stringfelder gibt, die weder eine kategorische noch eine geografische Interpretation aufweisen, fordert der Kreuzverteilungsansicht Sie auf, diese zu interpretieren, sodass sie angemessen in Klassen eingeteilt werden können. Sie können die standardmäßige kategorische Interpretation wählen, eine gespeicherte kategorische Hierarchie verwenden, oder das Feld als geografisch interpretieren.

Siehe auch

Eine Kreuztabelle in Decision Studio öffnen

Anordnen von Feldern und Statistiken in einer Kreuztabelle oder einem Graphen

Histogramm- und Balkendiagramm-Optionen

Optionen, die sich auf die Anzeige von Diagrammen und Entscheidungsbäumen auswirken

Ausrichten einer Diagrammanzeige mit Hilfe der Maus

Übergeordnetes Thema: Fokusdaten grafisch visualisieren und segmentieren


Um ein Diagramm auf einer Karte zu erstellen

  1. Ordnen Sie im Decision Studio-Fenster ein oder mehrere Felder einer Karte zu, indem Sie sie als geografische Felder interpretieren (falls nicht bereits ein Geografisches Symbol [image] neben ihnen in der Spalte Interpretationen steht):
    1. Markieren Sie die Felder, die einer Karte zugeordnet werden sollen.
    2. Wählen Sie „Kennzeichnung>Interpretation>Geografisch“.

      Ein Portrait Miner Dateibrowser [siehe Navigieren zum Öffnen oder Speichern einer Datei, Sitzung oder einer Datenbanktabelle] erscheint.

    3. Navigieren Sie zur erforderlichen Kartendatei.

      Das Geografische Symbol [image] in der Spalte Interpretationen im Decision Studio-Fenster zeigt an, dass eine geografische Interpretation vorhanden ist.

  2. Markieren Sie die geografisch interpretierten Felder, die Sie in Ihrer Kartendiagramm verwenden möchten. Die Felder müssen alle der gleichen Karte zugeordnet sein.
  3. Wählen Sie „Tools>Zuordnungsansicht“ oder klicken Sie in der Symbolleiste auf [image].

    Der Zuordnungsansicht wird geöffnet und zeigt die von Ihnen ausgewählte Karte an, wobei die Anzahl der Datensätze in jedem Bereich durch Blockhöhen dargestellt wird (falls Sie nur ein Feld markiert haben).

Anmerkung:
  • Sie können ein Feld als geografisch auch vom Klasseneditor aus interpretieren: Klicken Sie mit der rechten Maustaste im Fensterbereich „Felder“ auf den Feldnamen und wählen Sie „Interpretationen>Geografisch“.
  • Wenn Sie zwei oder mehr geografische Felder markieren, werden im Zuordnungsansicht zunächst nur zwei von ihnen genutzt. Die übrigen erscheinen in der Leiste [image] (Nur zur Informationen) unten im Fenster. Anstatt die Anzahl der Datensätze anzuzeigen, zeigt die Karte Linienverknüpfungen zwischen Bereichen an, wobei die Dicke einer Linienverknüpfung die Anzahl an Datensätzen repräsentiert, die der Anfangsbereich mit dem Endbereich verbindet.

  • Falls im Fokus ein numerisches Ziel festgelegt wurde, zeigt der Zuordnungsansicht den Durchschnitt der Zielvariable als Blockfarbe oder Linienverknüpfungsfarbe, abhängig vom Diagrammtyp (es sei denn, Sie haben die Einstellung Funktion Zielvariable geändert), an.
  • Wenn Sie den Zuordnungsansicht starten, ohne Felder zu markieren, erscheint das Dialogfeld „Felder und Aggregationsfunktionen auswählen“ [siehe Kreuztabellen als Basis für die Segmentierung und Visualisierung von Daten].
  • Um die untergeordnete Kreuztabelle jederzeit zu ändern [siehe Kreuztabellen als Basis für die Segmentierung und Visualisierung von Daten], wählen Sie „Bearbeiten>Kreuztabelle Bearbeiten“ oder klicken Sie in der Symbolleiste auf [image]. Die Aufschlüsselungsfelder müssen alle der gleichen Karte zugeordnet sein.

Siehe auch

Eine Kreuztabelle in Decision Studio öffnen

Anordnen von Feldern und Statistiken in einer Kreuztabelle oder einem Graphen

Optionen, die sich auf die Anzeige von Diagrammen und Entscheidungsbäumen auswirken

So erstellen Sie eine Kategoriezuordnung aus einer kategorischen Hierarchiedatei

Ausrichten einer Diagrammanzeige mit Hilfe der Maus

Übergeordnetes Thema: Fokusdaten grafisch visualisieren und segmentieren


So erstellen Sie eine Kategoriezuordnung aus einer kategorischen Hierarchiedatei

  1. Klicken Sie in Portrait Miner mit der rechten Maustaste auf die kategorische Klassenhierarchiedatei, aus der Sie eine Kategoriezuordnung erstellen möchten, und wählen Sie „Kategoriezuordnung erstellen“.

    Das Dialogfeld „Kategoriezuordnung erstellen“ wird angezeigt.

  2. Wählen Sie den Speicherort für die neue Kategoriezuordnung.
  3. Optional wählen Sie den Typ der zu erstellenden Kategoriezuordnung.
  4. Optional wählen Sie, keine vorhandenen Zuordnungsdateien mit dem gleichen Namen zu überschreiben.
  5. Klicken Sie auf „OK“.
Anmerkung: Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl qsmapgen in Portrait Miner bereitgestellt werden, zuzugreifen.

Siehe auch

Informationen über Portrait Miner-Assistenten

Um ein Diagramm auf einer Karte zu erstellen

So speichern Sie eine kategorische Klassenhierarchie

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Übergeordnetes Thema: Fokusdaten grafisch visualisieren und segmentieren


Optionen, die sich auf die Anzeige von Diagrammen und Entscheidungsbäumen auswirken

Es steht eine Reihe von Optionen zur Verfügung, die steuern, wie die Diagramme erscheinen. Einige wirken global und werden für alle Ihre Diagramme übernommen, während andere nur für einzelne Diagramme angewendet werden.

Siehe auch

Zur Maximierung eines Bildschirms in einem Decision Studio-Tool

Feldbeschreibungen

Übergeordnetes Thema: Fokusdaten grafisch visualisieren und segmentieren

Festlegen globaler Optionen für grafische Anzeigen

  1. Wählen Sie im Decision Studio-Fenster die Optionen Bearbeiten > Einstellungen anzeigen.

    Das Dialogfeld „Format“ erscheint. Drei der fünf Registerkartenfenster steuern die Anzeige der Diagramme:

    Bereich | Beschreibung
    Grafikoptionen | Auswahl der in den Diagrammen enthaltenen Elemente (Achsenleisten, Achsenbeschriftungen, Gitter, Zeichenmarkierungen und Zeichenbeschriftung); Auswahl der Farben für grafische Elemente; Auswahl der Farben für Klassen im Klasseneditor; Auswahl der Farben und Farbskalierung [siehe Ändern der Farbskala für Blöcke in einem Diagramm oder in einem Entscheidungsbaum] für Diagrammblöcke und ob beim Drucken eines Diagramms zu Schwarz, Weiß und Grau invertiert werden soll (und speichern des Bildes von).
    Schriftart Zeichenbeschriftung | Schriftartenwähler für Zeichenbeschriftungen, d. h. Feldwerte
    Schriftart Achsenbeschriftung | Schriftartenwähler für Achsenbeschriftungen, d. h. Feldnamen
    Funktionsbeschriftungen | Alternativer Anzeigetest für Aggregations-Funktionsnamen
  2. Klicken Sie auf „OK“, um vorgenommene Änderungen zu speichern und das Dialogfeld zu schließen.
Anmerkung:
  • Ihre Einstellungen werden für zukünftige Sitzungen in Decision Studio, Profile und Audits sowie Modell-Momentaufnahmen gespeichert.
  • Die Einstellung „Schriftart Achsenbeschriftung“ steuert außerdem die für die Beschriftung der Entscheidungsbäume verwendete Schriftart.
  • Im Fenster Klassenfarben sind die Einstellungen Klassen und Sonderfälle die Farben, die der Klasseneditor jeweils für normale Klassen bzw. Randklassen verwendet. (Die Einstellung „Klassen“ ist außerdem die Farbe, die der Entscheidungsbaum-Werkzeug für die Balkendiagramme in Segmenten von kontinuierlichen Bäumen verwendet.)
  • Im Fenster Elementfarben ist die Einstellung Karte die Farbe, die die Zuordnungsansicht für die Kontur der Karte selbst verwendet.

Siehe auch

Festlegen des Anzeigeformats für numerische und Datumswerte

Ändern der Farbskala für Blöcke in einem Diagramm oder in einem Entscheidungsbaum

  1. Wählen Sie im Decision Studio-Fenster die Optionen Bearbeiten > Einstellungen anzeigen. Das Dialogfeld „Format“ erscheint mit der gewählten Registerkarte „Diagramm-Optionen“.
  2. Benutzen Sie die Einblendliste der Farbauswahl im Fenster Block-Farben, um die Farben auszuwählen, die für die Werte „Hoch,“ „Mittel“, und „Niedrig“ stehen (standardmäßig entsprechend rot, grün, und blau). Die genaue Interpretation dieser Farben hängt von der Art der ausgewählten Farbskala ab. Bei einem Entscheidungsbaum hängt die Interpretation dieser drei Farben von den Einstellungen im Dialogfeld „Konfiguration für Entscheidungsbaum anzeigen“ ab [siehe Steuerung der Verwendung von Farbe und Tiefe in einem Entscheidungsbaum].

  3. Wählen Sie im Fensterbereich „Farbzuordnungsanzeige“ die verwendete Art der Farbskala:

    Skalierung | Beschreibung
    Linear | Eine gleichmäßige Verteilung der Farben zwischen den Minimal- und Maximalwerten, wobei der Minimalwert durch die Farbe „Mittel“ und der Maximalwert durch die Farbe „Hoch“ repräsentiert wird.
    Linear mit Null (Standard)

    Gibt es keine negativen Werte: Eine gleichmäßige Verteilung der Farben zwischen Null und dem Maximalwert, wobei Null durch die Farbe „Mittel“ und der Maximalwert durch die Farbe „Hoch“ dargestellt wird.

    Gibt es keine positiven Werte: Eine gleichmäßige Verteilung der Farben zwischen dem Minimalwert und Null, wobei der Minimalwert durch die Farbe Niedrig und Null durch die Farbe Mittel dargestellt wird.

    Gibt es negative und positive Werte: Eine gleichmäßige Verteilung der Farben über einem Wertebereich basierend auf Null, wobei der Minimalwert (oder der negative Wert des Maximalwerts) durch die Farbe „Niedrig“, Null durch die Farbe „Mittel“, und der Maximalwert (oder der negative Wert des Minimalwerts) durch die Farbe „Hoch“ dargestellt wird.
    Maximale Diskriminanz | Eine nichtlineare Verteilung der Farben zwischen den Minimal- und Maximalwerten, sodass jede wahrgenommene Farbabstufung ungefähr der gleichen Anzahl an Datensätzen entspricht (dementsprechend maximiert sich die Diskriminanz zwischen den Werten), wobei der Minimalwert durch die Farbe „Niedrig“, der Medianwert durch die Farbe „Mittel“, und der Maximalwert durch die Farbe „Hoch“ dargestellt wird.
  4. Verwenden Sie die Einstellung „Anzahl der Farben“, um die verwendete Anzahl der verschiedenen Farben zu steuern.
  5. Klicken Sie auf „OK“.

Verbergen oder Anzeigen einer Farblegende für ein Diagramm

Im Profilansicht, Kreuzverteilungsansicht oder Zuordnungsansicht wählen Sie „Ansichten>Legende“ oder klicken Sie in der Symbolleiste auf [image].

Anmerkung:

Im Entscheidungsbaum-Werkzeug ist keine Farblegende verfügbar.

Anzeigen oder Verbergen von Segmenten für Null- und unklassifizierte Werte in einem Diagramm

Im Klasseneditor, Profilansicht, Kreuzverteilungsansicht oder Zuordnungsansicht:
  • Wählen Sie Ansicht>Nulldaten oder klicken Sie in der Symbolleiste auf [image], um die Anzeige der Klassen für Nullwerte ein- bzw. auszuschalten.
  • Wählen Sie „Ansichten>Unklassifizierte Daten“, um die Anzeige von unklassifizierten Klassen ein- oder auszuschalten.

Anzeigen oder Verbergen leerer Kategorien in einen Diagramm

Wählen Sie im Profilansicht oder Kreuzverteilungsansicht „Ansichten>Leere Kategorien“, um die Anzeige leerer Kategorien ein- oder auszuschalten.

Gemeinsames oder unabhängiges Skalieren eines Satzes Profildiagrammen

Im Profilansicht haben alle Profildiagramme standardmäßig eine gemeinsame Skala auf der vertikalen Achse. Um die Diagramm unabhängig voneinander zu skalieren, wählen Sie „Ansichten>Global Skalieren“, um die Markierung, die diese Option unterdrückt, aufzuheben.

Anmerkung:

Sie können mehrere Statistiken mit Blockhöhe verbinden, sodass zwei oder mehr Diagramme einen gemeinsamen Achsensatz teilen. Wenn Sie in diesem Fall eine voneinander unabhängige Skalierung wählen, ist die vertikale Achse nicht beschriftet und Sie können keine Werte für die verschiedenen Statistiken miteinander vergleichen.

Anzeigen oder Verbergen der vertikalen Achse in einem Kartendiagramm

Markieren oder entfernen Sie im Zuordnungsansicht die Markierung der Menüoption „Ansichten>Höhenachse Anzeigen“.

Steuerung der Verwendung von Farbe und Tiefe in einem Entscheidungsbaum

  1. Wählen Sie im Entscheidungsbaum-Werkzeug „Ansichten>Konfiguration“.

    Das Dialogfeld „Konfiguration für Entscheidungsbaum Anzeigen“ erscheint.

  2. Wählen Sie mit Hilfe der Dropdown-Menüs, was (falls überhaupt) als Tiefe und Farbe jedes Segments angezeigt werden soll.
  3. Legen Sie „Segmentfarbskala zentrieren bei“ fest auf

    Wurzel des Baums, um die mittlere Farbe der Farbskala (standardmäßig grün) für das Wurzelsegment zu verwenden [siehe Ändern der Farbskala für Blöcke in einem Diagramm oder in einem Entscheidungsbaum];

    Mittel-Bereich, um die mittlere Farbe (standardmäßig grün) für den Wert zwischen den im Entscheidungsbaum auftretenden Extremen zu verwenden.

    50% der Gesamtmengen mit übereinstimmendem Ziel usw. (die Option ist abhängig von der Art des Baums), um die mittlere Farbe (standardmäßig grün) für einen bestimmten Wert von Trefferrate, Durchschnitt, Uplift usw. zu verwenden.

  4. Klicken Sie auf „OK“.


Für einen Fokus ein Profil erstellen und prüfen

Für einen Fokus ein „Profil erstellen und prüfen“ ist ein Bericht im HTML-Format, der detaillierte Informationen über den Fokus enthält, einschließlich der Profile oder einiger/aller Felder im Fokus, optional in Bezug auf eines oder mehrere Zielfelder.

Um ein „Profil erstellen und prüfen“ in Portrait Miner zu erstellen, klicken Sie mit der rechten Maustaste auf den zu prüfenden Fokus und wählen Profil und Überprüfung erstellen.

Im Dialogfeld Profil und Überprüfung erstellen können Sie auswählen, welche Felder oder markierten Feldgruppen profiliert werden sollen, ob ein Partitionsfeld ignoriert und welche Zielfelder verwendet werden sollen. (Befindet sich ein Ziel im Fokus, handelt es sich um das Standardzielfeld.) Sie können außerdem mithilfe eines FDL-Ausdrucks einen Teil der Datensätze im Fokus auswählen [siehe Formeln].

Nach dem Abschluss wird der Überprüfungsbericht auf der Registerkarte Überprüfung im Dialog Profil und Überprüfung erstellen angezeigt.

Anmerkung:
  • Sie können wählen, für welche Felder ein Bericht erstellt werden soll, indem Sie entweder die Feldnamen oder einen oder mehrere Tags auswählen [siehe Arbeiten mit Feldgruppen].
  • Sie können eine von vier Optionen für die in der HTML-Ausgabe verwendeten Bildformate auswählen:

    svg nur SVG (Scalable Vector Graphics). SVG bietet die beste Bildqualität und die kleinste Dateigröße, aber die Leser Ihres Berichts müssen über einen Webbrowser mit SVG-Plugin verfügen, um diese Bilder anzeigen und drucken zu können.

    smallpng SVG sowie für den Bildschirm optimierte PNG-Bitmaps (Portable Network Graphics). Aber auch ohne SVG-Plugin sind die Bilder in Ihrem Bericht für die Leser zu sehen (aber die Druckqualität wird relativ schlecht sein).

    largepng SVG sowie für Drucker und Bildschirm optimierte PNG-Bitmaps. Die Leser können Ihren Bericht ansehen oder ausdrucken, ohne das ein SVG-Plugin erforderlich ist (es wird aber mehr Festplattenspeicher benötigt und der Bericht kann langsamer angezeigt werden).

    none Keine Bilder.

  • Sie können weitere Aspekte des Erscheinungsbild von Modell-Schnappschüssen und Profil und Überprüfungen steuern [siehe Festlegen der Portrait Miner-Einstellungen] und zwar im Bereich „Prüfungen und Zusammenfassungen“ im Fenster „Einstellungen“.
  • Damit Portrait Miner Sie per E-Mail benachrichtigen kann, sobald ein Bericht bereitsteht, müssen Sie die Einstellungen „emailaddress“ und „emailserver“ entsprechend festlegen.
  • Standardmäßig speichert Portrait Miner ein Profil und Überprüfung als einzelne .qshtml-Datei mit eingelagerten Bildern. Auch wenn diese Datei in Portrait Miner geöffnet werden kann (per Doppelklick), kann sie nicht direkt außerhalb von Portrait Miner verwendet werden.

    Um eine Webseite zu erstellen, die auf einem Webserver platziert werden kann, klicken Sie mit der rechten Maustaste auf eine .qshtml-Datei und wählen „In Verzeichnis entpacken“. Wählen Sie einen Speicherort für den Ordner und klicken Sie auf OK. Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl qshtmlunpackin Portrait Miner bereitgestellt werden, zuzugreifen.

  • Sie können ein Profil und Überprüfung eines Datensatztyps eines Dritten erstellen, indem Sie mit der rechten Maustaste in Portrait Miner auf die Datei klicken und „Überprüfung“ auswählen. In dem jetzt erscheinenden Dialog können Sie einen Speicherort für den von Portrait Miner im Zuge der Vorbereitung des Berichts erstellten temporären Fokus auswählen. In dem Bericht erscheint der Name dieses Fokus anstelle des Namens des originalen Datensatzes.
  • Über das Dialogfeld Profil und Überprüfung erstellen kann auf viele Funktionen zugegriffen werden, die über den Dateierstellungsbefehl „qsaudit“ in Portrait Miner bereitgestellt werden.

Siehe auch

Informationen über Portrait Miner-Assistenten

Einen Modellzusammenfassung erstellen

Festlegen globaler Optionen für grafische Anzeigen

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Übergeordnetes Thema: Fokusdaten grafisch visualisieren und segmentieren

Verwenden eines Referenzberichts für den Vergleich der Fokusse

Ein Vergleichsbericht ähnelt einem normalen Profil- und Überprüfungsbericht, nur das er nebeneinander angeordnete Profile von Feldern in zwei Fokussen zusammen mit den Details der Unterschiede zwischen verschiedenen Statistiken einschließt, was Ihnen beispielsweise die Beobachtung von Änderungen im Zeitverlauf ermöglicht.

Um einen Vergleichsbericht zu erstellen, erstellen Sie für Ihren ersten Fokus auf normaler Art und Weise einen Profil- und Überprüfungsbericht, Ihren „Referenzbericht.“ Danach erstellen Sie einen Profil- und Überprüfungsbericht für Ihren zweiten Fokus, geben aber im Dialog Profil und Überprüfung erstellen den Referenzbericht an, den Sie zuvor erstellt haben.

Anmerkung:
  • Kategorische Felder müssen in beiden Fokussen die gleichen Klasseneinteilungen aufweisen.
  • Standardmäßig enthält der Vergleichsbericht die gleichen Felder wie der Referenzbericht. Wenn Sie explizit Felder auswählen, die im Vergleichsbericht enthalten sein sollen, werden diese den zuvor profilierten Feldern hinzugefügt.
  • Der Vergleichsbericht verwendet die gleichen Zielfelder wie der Referenzbericht. Alle explizit angegebenen Zielfelder werden ignoriert.


Test/Trainingsmethodik

  • Test/Trainingsmethodik für robuste Modellierung
  • So partitionieren Sie einen Fokus in Muster-Teilgesamtmengen
  • Übernehmen eines Modells oder einer Segmentierung von Decision Studio für einen anderen Datensatz


Test/Trainingsmethodik für robuste Modellierung

Wenn Sie ein Modell aufbauen, benötigen Sie einige Mittelwerte zur Bestimmung der Qualität. Sie müssen nicht nur wissen, wie gut es historische Daten beschreibt, Sie müssen auch wissen, wie robust es als Prädiktor für zukünftiges Verhalten ist.

Das Problem der Überanpassung Für eine Scorecard oder einen Entscheidungsbaum, % oder Clustering-Model, können Sie einen Qualitätsmaßstab wie das Gini-Maß benutzen, um einen Hinweis darüber zu erhalten, wie genau das Modell einen Datensatz beschreibt: ganz allgemein, je höher die Zahl, desto besser. Aber Sie müssen vorsichtig sein, um Überanpassung zu vermeiden, die auftreten kann, wenn Ihr Modell zu spezifisch für den Datensatz ist, das bei der Erstellung verwendet wurde.

Im Prinzip können Sie einen Entscheidungsbaum oder eine Scorecard erstellen, die zu einem gegebenen Datensatz perfekt passt. Mit ausreichenden Ressourcen könnten Sie beispielsweise Ihr Kunden-ID-Feld klassifizieren, sodass es einen Kunden in jeder Klasse gibt, dieses Feld als einzigen Analysekandidaten interpretieren und einen Entscheidungsbaum mit so vielen Ebenen wie nötig aufbauen, um jedes Blattsegment homogen in Bezug auf das Ziel zu machen.

Natürlich ist solch ein extremes Überanpassungs-Modell von begrenztem Nutzen. Es ist genauso kompliziert wie der ursprüngliche historische Datensatz und nutzt keine Vorteile der Muster in den Daten. Es bietet sicherlich keine Einblicke in das Kundenverhalten. Aber ein zu einfaches Modell nutzt die Muster in den Daten nicht.

Bis zu einem gewissen Grad können Sie betriebswirtschaftliche Kenntnisse anwenden, um zu entscheiden, welche Felder in einem Modell zu integrieren sind und sogar, wie man diese Felder klassifizieren kann. Aber es gibt immer die Versuchung, ein wenig mehr aus einem Modell heraus zu pressen und damit Überanpassung zu riskieren. Aus diesem Grund brauchen Sie Mittelwerte zum Testen Ihres Modells.

Eine Lösung - Training und Test-Datasets Ein Weg, um Überanpassung zu vermeiden, ist die Partitionierung Ihres Fokus [siehe So partitionieren Sie einen Fokus in Muster-Teilgesamtmengen] in Training und Test-Datensätze mit vielleicht 67 % der Daten im Trainingssatz und 33 % der Daten für den Testsatz. Sie können ein Modell mit den Daten aus dem Trainingssatz erstellen und es dann, wenn Sie mit der beschreibenden Leistung zufrieden sind, auf den Testsatz [siehe Übernehmen eines Modells oder einer Segmentierung von Decision Studio für einen anderen Datensatz] anwenden, um seine Vorhersagekraft zu testen. Wenn Ihre gewählte Qualitätsgröße deutlich sinkt, wenn Sie das Modell anwenden (z. B., wenn der Gini um mehr als etwa 2 % sinkt) sollten Sie Überanpassung vermuten.

Wenn Ihr Modell nicht robust genug ist, können Sie zum Trainingssatz zurückgehen und versuchen, das Modell zu verbessern (durch Änderung der enthaltenen Felder, Klasseneinteilungen, Qualitätsmaßnahmen usw.).

Wenn Sie allerdings diesen Vorgang zu oft wiederholen, riskieren Sie erneut eine Überanpassung, weil Sie jetzt den ganzen Fokus verwenden, um die Form des Modells zu beeinflussen. Die Lösung ist die Verwendung von drei Muster-Teilgesamtmengen, mit vielleicht 60 % der Daten für das Training, 30 % für das Testen und die restlichen 10 % für die Validierung. Sie können es sich jetzt leisten, die Rückmeldungen von Tests zu benutzen, um das Modell zu verfeinern. Nach ein paar Wiederholungen können Sie das Modell zur Validierung geben [siehe Übernehmen eines Modells oder einer Segmentierung von Decision Studio für einen anderen Datensatz], um die Robustheit zu überprüfen.

Übergeordnetes Thema: Test/Trainingsmethodik

Automatisches Pruning im Entscheidungsbaum-Werkzeug

Im Entscheidungsbaum-Werkzeug können Sie das automatische Pruning [siehe Einen Teil eines Entscheidungsbaums automatisch prunen] in Verbindung mit Test- und Trainings-Datasets benutzen, um robustere Entscheidungsbäume zu erstellen. Mit dem Kosten-Komplexitäts-Pruning erkennt das Entscheidungsbaum-Werkzeug automatisch den bereinigten Baum, der beim Testsatz die beste Leistung erzielt.


So partitionieren Sie einen Fokus in Muster-Teilgesamtmengen

  1. Bestimmen Sie die Anzahl der Teilgesamtmengen n und ihre relative Größe [image] (wobei [image])
  2. Leiten Sie im Tabellenansicht ein Feld ab [siehe Ein Feld mithilfe des Tabellenansichts ableiten] indem Sie eine der folgenden Möglichkeiten verwenden:
    • Wenn Sie zwei Teilgesamtmengen (n = 2) wünschen, verwenden Sie die Funktion „numericTestTrainSplit“.
    • Wenn Sie drei Teilgesamtmengen (n = 3) wünschen, verwenden Sie die Funktion „numericTestTrainValidateSplit“.
    • Wenn Sie Teilgesamtmengen gleicher Größe ( [image]) wünschen, verwenden Sie die Funktion sampleEqualSize.
    • Ansonsten verwenden Sie die folgende Definition:

      Um beispielsweise vier Teilgesamtmengen zu erstellen, die (ungefähr) 40 %, 30 %, 20 % und 10 % der Gesamtmenge enthalten, könnten Sie die folgende Felddefinition verwenden:

      a := rndUniform();

      case a < 0.4 : 1; // 0.4 = 40%

      a < 0.7 : 2; // 0.7 = 40% + 30%

      a < 0.9 : 3; // 0.9 = 40% + 30% + 20%

      default : 4

    Der Fokus ist jetzt gemäß den Werten in dem von Ihnen abgeleiteten Feld partitioniert. Abhängig von dem gewählten Ausdruck sind die Werte 1, 2, ..., n, oder 0, 1, ..., n-1.

  3. Feld als kategorisch interpretieren [siehe Für das Festlegen oder Leeren eines Analysekandidaten, einer kategorischen, geografischen, Export-oder Zielinterpretation].
  4. Optional können Sie die neuen Kategorien entsprechend umbenennen [siehe Umbenennen einer Kategorie].

Um eine bestimmte Teilgesamtmenge zu nutzen, wählen Sie Datensätze aus [siehe Auswahl von Kundendatensätzen], die den gewünschten Wert im Feld haben.

Anmerkung:
  • Sie können die Funktion „testTrainSplit“ als Alternative zur Funktion „numericTestTrainSplit“ verwenden.
  • Sie können die Funktion „testTrainValidateSplit“ als Alternative zur Funktion „numericTestTrainValidateSplit“ verwenden.
  • Als Alternative zur Verwendung des Dialogfelds „Werte wählen“ können Sie zum Wechseln zwischen Teilgesamtmengen auch den Klasseneditor verwenden. Verknüpfen [siehe Tools miteinander verknüpfen und Verknüpfungen aufheben] Sie Ihre Analyse- und Visualisierungstools mit der Ausgabe des Klasseneditors. Wechseln Sie zwischen Teilgesamtmengen, indem Sie die gewünschte Klasse des von Ihnen abgeleiteten Felds markieren.

Siehe auch

sampleExactNumber

sampleExactPercentage

sampleStratified

Übergeordnetes Thema: Test/Trainingsmethodik


Übernehmen eines Modells oder einer Segmentierung von Decision Studio für einen anderen Datensatz

  • Der einfachste Weg, ein Modell auf einen anderen Datensatz anzuwenden, ist, die derzeitige Datensatzauswahl zu ändern [siehe Auswahl von Kundendatensätzen].
  • Wenn Sie einen Entscheidungsbaum, eine Scorecard oder ein Clustermodell in einen Datensatz aus einer separaten Fokusdatei übernehmen möchten, speichern Sie Ihr Modell [siehe Einen Entscheidungsbaum, eine Scorecard oder ein Clustermodell speichern], öffnen Sie dann die andere Fokusdatei und übernehmen Sie das gespeicherte Modell [siehe Anwenden eines Entscheidungsbaums, einer Scorecard oder eines Clustermodells].
  • Wenn es sich bei dem neuen Datensatz um eine Gruppe markierter Segmente [siehe Segmente in einer Diagrammanzeige markieren] in einem anderen Decision Studio Tool handelt, verknüpfen Sie einfach [siehe Tools miteinander verknüpfen und Verknüpfungen aufheben] das Tool, in dem Sie Ihr Modell oder Ihre Segmentierung erstellt haben, mit der entsprechenden Datenquelle.

Das Tool aktualisiert seine Anzeige, um Ihr Modell oder Ihre Segmentierung, die für den neuen Datensatz übernommen wurde, anzuzeigen.

Im Entscheidungsbaum-Werkzeug können Sie immer noch die Statistiken für den ursprünglichen Datensatz sehen. In der Entscheidungsbaumansicht zeigt der Entscheidungsbaum-Werkzeug ursprüngliche Statistiken über den übernommenen Statistiken in Klammern an:

In Textansichten [siehe Optionen zur Anzeige eines Entscheidungsbaums] zeigt der Entscheidungsbaum-Werkzeug mit Zahlen sowohl für die ursprünglichen als auch für die übernommenen Datensätze an.

Anmerkung:
  • Sie können steuern, welche Zahlen das Entscheidungsbaum-Werkzeug anzeigt, indem Sie Ansicht>Daten>Original oder Ansicht>Daten>Angewandt wählen.
  • Wenn Sie kein Ziel in der neuen Gesamtmenge festgelegt haben, zeigt ein angewendeter Entscheidungsbaum nur die Anzahl der Datensätze in jedem Segment an. Eine Gains-Tabelle [siehe Optionen zur Anzeige eines Entscheidungsbaums] für die neue Gesamtmenge ist für binäre und Uplift-Bäume verfügbar.
  • Wenn Sie einen Entscheidungsbaum erstellen und dann den Baumtyp ändern, zeigt der Entscheidungsbaum-Werkzeug den selben Baum, überlagert mit Statistiken und möglicherweise Diagrammen für den neuen Baumtyp, an. Der Entscheidungsbaum-Werkzeug zeigt die ursprünglichen Statistiken in Klammern an, so als wäre das Modell für eine andere Gesamtmenge übernommen worden.

Siehe auch

Test/Trainingsmethodik für robuste Modellierung Speichern eines Decision Studio Modells oder einer Segmentierung zur Verwendung als QMML (XML)
Übergeordnetes Thema: Test/Trainingsmethodik

Einen Entscheidungsbaum, eine Scorecard oder ein Clustermodell speichern

  1. Wenn Sie ein Modell im Entscheidungsbaum-Werkzeug, Scorecard-Werkzeug oder Clustermodell-Werkzeug erstellt haben, wählen Sie „Datei>Speichern unter“ oder klicken Sie in der Symbolleiste auf [image].
  2. Wählen Sie im Dateibrowser von Portrait Miner [siehe Navigieren zum Öffnen oder Speichern einer Datei, Sitzung oder einer Datenbanktabelle] einen Namen und einen Speicherort für Ihren zu speichernden Entscheidungsbaum, Scorecard oder Clustermodell aus.

Siehe auch

So bauen Sie ein Clustermodell auf

Aufbau eines Entscheidungsbaums

Anwenden eines Entscheidungsbaums, einer Scorecard oder eines Clustermodells

  1. Wählen Sie jeweils im Entscheidungsbaum-Werkzeug, Scorecard-Werkzeug oder Clustermodell-Werkzeug „Datei>Öffnen“ oder klicken Sie in der Symbolleiste auf [image].

    Ein Portrait Miner Dateibrowser [siehe Navigieren zum Öffnen oder Speichern einer Datei, Sitzung oder einer Datenbanktabelle] erscheint.

  2. Navigieren Sie zur gewünschten Entscheidungsbaum-, Scorecard-, oder Clustermodell-Datei.
Anmerkung: Der aktuelle Fokus muss Felder mit den gleichen Namen und Typen enthalten, wie die vom Modell verwendeten.


Entscheidungsbäume erstellen für die Segmentierung und Predictive Modeling

  • Aufbau eines Entscheidungsbaums
  • Optionen zur Anzeige eines Entscheidungsbaums
  • Steuern des Aufbaus eines Entscheidungsbaums
  • Unerwünschte Segmente aus einem Entscheidungsbaum entfernen


Aufbau eines Entscheidungsbaums

  1. Optional einige Felder als Analysekandidaten interpretieren [siehe Für das Festlegen oder Leeren eines Analysekandidaten, einer kategorischen, geografischen, Export-oder Zielinterpretation].

    Wenn Felder mit einer Interpretation als Analysekandidaten vorhanden sind, berücksichtigt der Entscheidungsbaum-Werkzeug nur solche Felder beim Aufbau der Zweige des Entscheidungsbaums.

  2. Feld als Modellierungsziel interpretieren .
  3. Nur für Uplift-Bäume, Interpretation eines Feldes als das Partitions feld. (Einen Uplift-Entscheidungsbaum können Sie nur erstellen, wenn das Partitionsfeld 0 und 1 und keine anderen Werte, einschließlich des Nullwertes, enthält.)
  4. Wählen Sie „Tools>Entscheidungsbaum-Werkzeug“ oder klicken Sie in der Symbolleiste auf [image].
  5. Falls erforderlich, ändern Sie den Entscheidungsbaumtyp (auf binären Entscheidungsbaum, kategorischen Entscheidungsbaum oder fortlaufenden Entscheidungsbaum), verwenden Sie das Dropdown-Menü in der Symbolleiste.
    Wenn Sie kein Partitionsfeld verwenden:
    • Verwenden Sie einen kategorischen Entscheidungsbaum für eine Zielvariable mit kategorischen Werten (oder einen binären Entscheidungsbaum für eine zweiwertige Zielvariable).
    • Verwenden Sie einen stetigen Entscheidungsbaum für eine nicht-kategorische Zielvariable.
    Wenn Sie ein Partitionsfeld verwenden möchten, erstellen Sie eine Uplift-Modellierung.
    • Für eine zweiwertige Zielwertvariable verwenden Sie einen binären Uplift + Entscheidungsbaum für eine additive Modellierung oder verwenden Sie einen binären Uplift x Entscheidungsbaum für eine multiplikative Modellierung.
    • Verwenden Sie einen stetigen Entscheidungsbaum für eine nicht-kategorische Zielvariable.
    • Sie können keine kategorische Zielvariable mit mehr als zwei Werten verwenden.
  6. Wenn nötig, ändern Sie die Standard-Erstellungsoptionen [siehe Steuern des Aufbaus eines Entscheidungsbaums].
  7. Wählen Sie „Entscheidungsbaum>Aufbauen bis Ende“ oder klicken Sie in der Symbolleiste auf [image], um einen Entscheidungsbaum aufzubauen:

Anmerkung:
  • Um einem aktuellen (nicht angewandten) Entscheidungsbaum eine weitere Ebene hinzuzufügen, wählen Sie „Entscheidungsbaum>Nächste Ebene aufbauen“ oder klicken Sie auf [image].
  • In jeder Entscheidungsbaumansicht [siehe Optionen zur Anzeige eines Entscheidungsbaums] zeigen zwei links angeordnete Fensterbereiche die enthaltenen Felder (Analysekandidaten) und die ausgeschlossenen Felder (sonstige Felder im Fokus) an.

    Sie können ein Feld wie einen Analysekandidaten interpretieren, indem Sie es aus dem unteren Bereich in den oberen Bereich verschieben (und umgekehrt) und dazu die Pfeiltasten benutzen. Wenn Sie die Ebenen nacheinander aufbauen, können Sie unterschiedliche Analysekandidaten für jede Ebene des Entscheidungsbaums verwenden.

    Felder, die im aktiven Entscheidungsbaum verwendet wurden, erscheinen in Fettschrift (unabhängig davon, ob sie aktuelle Analysekandidaten sind).

  • Wenn Sie mit dem Aufbau eines Entscheidungsbaum beginnen, werden Sie vom Entscheidungsbaum-Werkzeug aufgefordert alle Stringfelder, die keine kategorische Interpretation aufweisen, zu interpretieren, so dass sie entsprechend klassifiziert werden können. Sie können entweder die standardmäßige kategorische Interpretation wählen oder eine gespeicherte kategorische Hierarchie verwenden. Wenn Sie nach der Aufforderung, eine Interpretation für ein Stringfeld auszuwählen, auf „Abbrechen“ klicken, ignoriert der Entscheidungsbaum-Werkzeug diesen Analysekandidaten sowie alle restlichen Stringfelder ohne kategorische Interpretation.

Siehe auch

Steuern des Aufbaus eines Entscheidungsbaums

Übernehmen eines Modells oder einer Segmentierung von Decision Studio für einen anderen Datensatz

Übergeordnetes Thema: Entscheidungsbäume erstellen für die Segmentierung und Predictive Modeling

Löschen eines Entscheidungsbaums

Um einen Entscheidungsbaum im Entscheidungsbaum-Werkzeug zu löschen, wählen Sie „Entscheidungsbaum>Löschen“ oder klicken Sie in der Symbolleiste auf [image].
Anmerkung: Wenn sich der Entscheidungsbaum-Werkzeug in der Gains-Ansicht oder der Diagrammansicht befindet, schaltet er auf die Entscheidungsbaumansicht um.


Optionen zur Anzeige eines Entscheidungsbaums

Folgende Entscheidungsbaum-Werkzeug Ansichten stehen zur Verfügung
Ansicht | Beschreibung
Baumansicht | Eine grafische Darstellung eines Entscheidungsbaums, die gesamte Menge wird an der Spitze dargestellt und jede vollständige, darunter liegende Ebene stellte eine feinere Segmentierung dar.
Tabellenansicht | Eine Darstellung des Entscheidungsbaumes in Tabellenform, die die Statistiken für jedes nummerierte Segment und einen FDL-ähnlichen Ausdruck, der jedes Segment beschreibt, enthält. Im Fall eines Uplift-Entscheidungsbaums ist die Gesamtgröße die Summe aller behandelten und kontrollierten Gesamtmengengrößen, andere Datensätze sind ausgeschlossen.
Listenansicht | Einige dieser Informationen können auch als Liste dargestellt werden.
Gewinnansicht | Eine kumulative Gain-Tabelle für die „Blatt“ (niedrigste Ebene, sich nicht weiter verzweigend) Segmente des Entscheidungsbaums, in absteigender Reihenfolge nach Trefferquote sortiert
Grafikansicht | Ein Qini-Diagramm, nur für Uplift-Bäume verfügbar

Um zu einer anderen Ansicht zu wechseln, wählen Sie entweder die Ansicht aus dem Menü „Ansicht“ oder Sie klicken auf die entsprechende Schaltfläche der Symbolleiste.

Siehe auch

Optionen, die sich auf die Anzeige von Diagrammen und Entscheidungsbäumen auswirken

Ausrichten einer Diagrammanzeige mit Hilfe der Maus

Übergeordnetes Thema: Entscheidungsbäume erstellen für die Segmentierung und Predictive Modeling

Einen Teil eines Entscheidungsbaumes erweitern oder zuklappen

Um sich auf die interessanten Teile des Entscheidungsbaums zu konzentrieren, können Sie einen Teilbaum zuklappen.
  1. Markieren Sie die Segmente [siehe Segmente in einer Diagrammanzeige markieren], die Sie zu- oder aufklappen möchten.
  2. Wählen Sie „Segmente>Zuklappen“ oder „Segmente>Aufklappen“.

    Wenn Sie Segmente zuklappen, versteckt Entscheidungsbaum-Werkzeug die Nachfolger der markierten Segmente und kennzeichnet die markierten Segmente mit einem „+“, das auf versteckte Nachfolger hinweist.

Alternativ können Sie einen Rechtsklick auf ein Segment setzen und Zuklappen oder Aufklappen aus dem sich öffnenden Menü auswählen.

Anmerkung:
  • Zuklappen ist nicht dasselbe wie Pruning [siehe Einen Teil eines Entscheidungsbaums manuell prunen]. Wenn Sie einen Teil eines Entscheidungsbaums zuklappen, ändert sich nur die Ansicht des Entscheidungsbaums. Das Pruning beeinflusst hingegen das zugrundeliegende Modell.
  • Wenn Sie den Entscheidungsbaum weiter aufbauen, kann der Entscheidungsbaum-Werkzeug versteckte Segmente splitten (nachgeordnete Segmente werden ebenfalls versteckt).


Steuern des Aufbaus eines Entscheidungsbaums

Sie können verschiedene Beschränkungen [siehe Entscheidungsbaum bildende Beschränkungen ansehen oder ändern], die den Aufbau eines Entscheidungsbaums mit Entscheidungsbaum-Werkzeug steuern, einstellen. Sie können durch Sperren [siehe Segmente in einem Entscheidungsbaum sperren oder entsperren] von Segmenten eines Entscheidungsbaums oder Pruning [siehe Unerwünschte Segmente aus einem Entscheidungsbaum entfernen] eines Entscheidungsbaums eine gewisse manuelle Steuerung ausüben.

Siehe auch

Aufbau eines Entscheidungsbaums

Unerwünschte Segmente aus einem Entscheidungsbaum entfernen

Übergeordnetes Thema: Entscheidungsbäume erstellen für die Segmentierung und Predictive Modeling

Entscheidungsbaum bildende Beschränkungen ansehen oder ändern

Wählen Sie „Entscheidungsbaum>Beschränkungen“.

Folgende Einstellungen sind in der Dialogfeld Entscheidungsbaumbeschränkungen verfügbar:

Einstellung | Anwendbar für | Beschreibung
Maximale Anzahl Ebenen im Entscheidungsbaum | Alle Entscheidungsbaumtypen | Die höchste Anzahl Generationen in einem Zweig des Entscheidungsbaums (einschließlich des „Wurzelsegments“). Dies gilt nur für Aufbauen bis Ende". Der Entscheidungsbaum-Werkzeug beendet den Aufbau des Entscheidungsbaums, sobald diese Anzahl Ebenen generiert ist. Wenn Sie „Entscheidungsbaum>Nächste Ebene aufbauen“ wählen oder auf [image] klicken, ignoriert der Entscheidungsbaum-Werkzeug diese Einstellung.
Minimum I-Gain für Split: | Binäre und kategorische Bäume | Der kleinste zulässige Wert des Information Gain für einen Split (ein Wert zwischen 0 und 1)
Minimum R-Quadrat-Gewinn für Split | Kontinuierliche Bäume | Der kleinste zulässige Wert der Kennzahl [image] für einen Split (ein Wert zwischen 0 und 1)
Minimum Uplift-Signifikanz für Split | Uplift-Bäume | Der kleinste zulässige Wert der Uplift-Signifikanz-Bemessung für einen Split (ein Wert zwischen 0 und 1)
Schwellenwert für Multi-Valued-Splits | Kategorische Bäume und Uplift-Bäume | Die Anzahl Kategorien in einem kategorischen Analysekandidaten - außer Null [siehe Der Nullwert] und unklassifiziert - außerhalb derer der Entscheidungsbaum-Werkzeug mögliche Splitpermutationen nicht berücksichtigt. Für einen Analysekandidaten mit mehr Kategorien als diesen, berücksichtigt der Entscheidungsbaum-Werkzeug nur Splits mit nur einer Kategorie auf der einen Seite und den Rest auf der anderen Seite.
Minimale Segmentgröße | Alle Entscheidungsbaumtypen außer Uplift-Bäumen | Die kleinste Anzahl Datensätze in einem „Blatt“ (unterste Ebene, nicht weiter verzweigt) Segment. Der Entscheidungsbaum-Werkzeug ignoriert Splits, die ein oder mehrere Segmente mit weniger Datensätzen ergeben. Wenn Sie „Behandle Minimumsegmentgröße als Prozentsatz“ markieren, wird diese Zahl als Prozentsatz einer Anzahl Datensätze in der Gesamtmenge, die Sie zum Aufbau des Entscheidungsbaums verwenden, behandelt.
Mindestsegmentgröße in einer behandelten Gesamtmenge, Mindestsegmentgröße in der Kontroll-Gesamtmenge | Uplift-Bäume | Die kleinste Anzahl Datensätze in der behandelten bzw. in der Kontroll-Gesamtmenge in einem „Blatt“ (unterste Ebene, nicht weiter verzweigt) Segment. Der Entscheidungsbaum-Werkzeug ignoriert Splits, die in einem oder mehreren Segmenten mit weniger Datensätzen in der entsprechenden Gesamtmenge resultieren Das Kontrollkästchen Behandle Minimumsegmentgröße als Prozentsatz interpretiert Werte als Prozentsätze der Gesamtmenge, nicht als Prozentsätze der einzelnen, behandelten oder der Kontroll-Gesamtmenge.

Bei kategorischen Bäumen sind zwei zusätzliche Kontrollkästchen vorhanden, um den Entscheidungsbaum-Werkzeug zu zwingen, Null und unklassifizierte Einteilungen in der Zielvorgabe als einfache Kategorien zu behandeln.

Segmente in einem Entscheidungsbaum sperren oder entsperren

Bevor Sie mit dem Aufbau eines teilweise aufgebauten Entscheidungsbaums fortfahren, können Sie ausgewählte Segmente ausschließen, indem Sie sie „sperren“.
  1. Markieren Sie die Segmente [siehe Segmente in einer Diagrammanzeige markieren], die Sie sperren oder entsperren möchten.
  2. Wählen Sie „Segmente>Sperren“ oder „Segmente>Entsperren“.

    Wenn Sie Segmente sperren, markiert der Entscheidungsbaum-Werkzeug Blattsegmente unterhalb der markierten Segmente mit einem Schloss [image].

Alternativ können Sie einen Rechtsklick auf ein Segment ausführen und „Sperren“ oder „Entsperren“ aus dem sich öffnenden Menü auswählen.


Unerwünschte Segmente aus einem Entscheidungsbaum entfernen

Sie können unerwünschte Segmente in einem Entscheidungsbaum durch Pruning entfernen.
Anmerkung: Pruning ist nicht dasselbe wie Zuklappen [siehe Einen Teil eines Entscheidungsbaumes erweitern oder zuklappen]. Wenn Sie einen Teil eines Entscheidungsbaums prunen, ändert sich der darunter liegende Entscheidungsbaum, das Zuklappen betrifft dagegen nur die Anzeige des Entscheidungsbaums.

Siehe auch

Segmente in einem Entscheidungsbaum sperren oder entsperren

Löschen eines Entscheidungsbaums

Übergeordnetes Thema: Entscheidungsbäume erstellen für die Segmentierung und Predictive Modeling

Einen Teil eines Entscheidungsbaums manuell prunen

Sie können uninteressante Segmente selektiv aus einem Entscheidungsbaum entfernen.
  1. Markieren Sie die Segmente [siehe Segmente in einer Diagrammanzeige markieren] deren Nachfolger Sie entfernen möchten.
  2. Wählen Sie „Segmente>Prune“.

    Der Entscheidungsbaum-Werkzeug entfernt die Nachfolger der markierten Segmente und markiert die gekennzeichneten Segmente mit einem Schloss, das anzeigt, dass sie gesperrt sind.

Alternativ können Sie einen Rechtsklick auf ein Segment setzen und Prune aus dem sich öffnenden Menü auswählen.

Einen Teil eines Entscheidungsbaums automatisch prunen

Sie können mit einer Test-/Trainingsmethodik [siehe Test/Trainingsmethodik für robuste Modellierung] und der Autoprune [siehe Automatisches Pruning im Entscheidungsbaum-Werkzeug] Option überangepasste Segmente eines Entscheidungsbaums nach seinem Aufbau automatisch entfernen.
  1. Bauen Sie Ihren Entscheidungsbaum [siehe Aufbau eines Entscheidungsbaums] anhand der Trainingsgesamtmenge auf.
  2. Wenden Sie diesen Entscheidungsbaum [siehe Übernehmen eines Modells oder einer Segmentierung von Decision Studio für einen anderen Datensatz] auf die Testgesamtmenge an.
  3. Wählen Sie „Entscheidungsbaum>Autoprune“ oder klicken Sie auf [image].

Der Entscheidungsbaum-Werkzeug entfernt automatisch die Segmente, die die Effizienz des Entscheidungsbaums auf die Testgesamtmenge nicht erhöhen.


Scorecards erstellen für Segmentierung und Predictive Modeling

  • Informationen zum Scorecard-Assistenten
  • Erstellen einer Scorecard mit dem Scorecard-Assistenten
  • Erstellen einer Scorecard mit dem Scorecard-Assistent
  • Verfeinern einer Scorecard durch Hinzufügen oder Entfernen von Feldern
  • Optionen für die Anzeige einer Scorecard
  • Steuern des Erstellens einer Scorecard


Informationen zum Scorecard-Assistenten

Der Scorecard-Assistent automatisiert die Scorecard-Modellierung mit der Best-Practice-Methodik: Dabei wird eine optimierte Klasseneinteilung und danach eine Variablenreduzierung durchgeführt und abschließend eine Sequenz von Modellen anhand von Test- und Trainingsdaten erstellt, um die beste „Modellgröße“ zu bestimmen. Die Modellierungs-Methodik umfasst folgende Stufen.

Test/Trainings-Methodik Ein Teil der Quelldaten wird für das Training und ein Teil zum Testen verwendet: Diese Spaltung kann stichprobenweise oder mit einem bestimmten binären Indikatorfeld erzeugt werden.

Optimierte Klasseneinteilung Die Trainingsdaten werden verwendet, um eine Klasseneinteilung für jeden Analysekandidaten auszuwählen, welcher die univariate Vorhersagekraft gegenüber dem Ziel maximiert.

Für nicht-kategorische Felder wird der Assistent für optimierte Klasseneinteilung [siehe Um eine Klasseneinteilung für ein Feld zu optimieren] iterativ benutzt, um die beste Klasseneinteilung zu wählen. Die Anzahl der Klassen wird erhöht, bis die Anzahl der „Wendepunkte“ im Plot des durchschnittlichen Zielwerts nach Klassen einen konfigurierbaren Schwellenwert überschreitet (ein „Wendepunkt“ ist ein Vorzeichenwechsel bei der Steigung der Kurve). Dadurch wird intuitiv sichergestellt, dass das Profil des durchschnittlichen Zielwerts als Funktion jedes Analysekandidaten relativ „glatt“ und ohne zu viele Höhen und Tiefen ist.

Bei kategorischen Feldern werden Kategorien, in denen sich der durchschnittliche Zielwert nicht wesentlich vom Gesamtmittel unterscheidet, zusammengeführt. Ein Standard-Mittelwertdifferenz-Test [siehe significance] wird mit einer angewandten Bonferroni-Korrektur, basierend auf der Gesamtzahl der Kategorien, die für das Feld angezeigt werden, verwendet. Daher werden alle Kategorien, in denen die Sicherheitswahrscheinlichkeit [image] beträgt, zusammengeführt (mit [image], einem konfigurierbaren Signifikanz-Schwellenwert).

Während dieser Phase werden Felder mit einer auffällig hohen Korrelation zum Ziel von weiteren Analysen ausgeschlossen (mit Warnmeldung). Eine Warnung wird auch für Felder ausgegeben, bei denen eine individuelle Klasse eine geringe Anzahl von Datensätzen enthält. Beide Schwellenwert sind konfigurierbar.

Variablenreduzierung Die Variablenreduzierungsphase reduziert den Pool der Analysekandidaten (unabhängige Prädiktoren) von denen ursprünglich für eine kleinere Gruppe von n markierten, um die Laufzeit der endgültigen „Größenanpassung“ zu verringern.

Der Prozess partitioniert die Analysekandidaten in Gruppen von bis zu 2n-Felder und erstellt eine Scorecard (mit Hilfe der Trainingsdaten) für jede Gruppe, verwirft die Schlimmsten Felder durch schrittweise Ausgrenzung [siehe Verfeinern einer Scorecard durch Hinzufügen oder Entfernen von Feldern], bis nur noch die besten n Felder der Gruppe übrig bleiben. Durch Wiederholung dieses Verfahrens werden schließlich die n besten Gesamtfelder identifiziert.

Größenanpassung Die Größenanpassung wählt die Scorecard, die am besten Komplexität (Anzahl der Prädiktoren) gegen Generalisierbarkeit (wie von Test-Set-Leistung gemessen) ausbalanciert. Die Trainingsdaten werden verwendet, um eine Sequenz von n Scorecards zu erstellen, wobei die ersten alle n Analysekandidaten enthalten und jedes weitere Modell die schlimmste Vorhersage ausschließt. Die Leistung von jedem Modell wird danach mit den Testdaten mithilfe der besten ausgewählten Modellgröße unter Anwendung eines konfigurierbaren Kriteriums überprüft. Zum Abschluss werden die Gewichtungen des ausgewählten Modells, basierend auf allen Daten (d. h. Test- und Trainingsdaten) angepasst, um die Genauigkeit zu verbessern. Sämtliche Interimsmodelle können zusammen mit dem endgültigen Modell gespeichert werden, sofern gewünscht.

Ergebnisse (Optional) werden verschiedene Ausgaben erzeugt, darunter:

  • Ein HTML-Bericht, der zusammenfasst, wie die Methodologie angewandt wurde, einschließlich der Eingabeparameter und Verknüpfungen zum detaillieren Ausführungsprotokoll. Er beinhaltet eine Tabelle mit Leistungsdaten, die in Excel einfach als Diagramme dargestellt werden können.
  • Das endgültig empfohlene Modell (in .qssc-Format [siehe Einen Entscheidungsbaum, eine Scorecard oder ein Clustermodell speichern] und QMML-Format [siehe Speichern eines Decision Studio Modells oder einer Segmentierung zur Verwendung als QMML (XML)]).
  • Ein Model-Zusammenfassungsbericht [siehe Einen Modellzusammenfassung erstellen] für das empfohlene Modell.
  • Der endgültige Datensatz, einschließlich der ausgewählten Analysekandidaten, optimierten Klasseneinteilungen und Modellvorhersagen. Zwischendatensätze können mit den von der Methodologie zu diesem Zeitpunkt erzeugten Metadaten ebenfalls gespeichert werden, sofern gewünscht. Diese sind häufig nützlich, um die während des Prozesses getroffenen Entscheidungen genauer anzusehen und zu analysieren.

Siehe auch

Erstellen einer Scorecard mit dem Scorecard-Assistenten

Übergeordnetes Thema: Scorecards erstellen für Segmentierung und Predictive Modeling


Erstellen einer Scorecard mit dem Scorecard-Assistenten

Speichern Sie Ihren Modellierungsfokus mit dem markierten Zielfeld, Analysekandidaten und kategorische Variablen. Diese Vorbereitung kann durch Importieren von Fokus-Metadaten [siehe Kopieren der Fokus-Metadaten von einem Fokus zum anderen] in den Modellierungsfokus automatisiert werden.

Klicken Sie in Portrait Miner mit der rechten Maustaste auf einen Fokus und wählen Sie „Vorhersage>Scorecard-Assistent“.

Im Dialogfeld „Scorecard-Assistent“ können Sie wählen, ob Sie Klasseneinteilung optimieren, einen reduzierten Satz von Variablen für die Endphase der Modellerstellung auswählen oder ein Scorecard-Modell mit richtiger Größe erstellen möchten. Sie können auch weitergehende Details konfigurieren, die den Modellerstellungsalgorithmus beeinflussen.

Anmerkung:
  • Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl qsscorecardwizard in Portrait Miner bereitgestellt werden, zuzugreifen.

Siehe auch

Informationen zum Scorecard-Assistenten

Informationen über Portrait Miner-Assistenten

Erstellen einer Scorecard mit dem Scorecard-Assistent

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Übergeordnetes Thema: Scorecards erstellen für Segmentierung und Predictive Modeling


Erstellen einer Scorecard mit dem Scorecard-Assistent

  1. Optional einige Felder als Analysekandidaten interpretieren [siehe Für das Festlegen oder Leeren eines Analysekandidaten, einer kategorischen, geografischen, Export-oder Zielinterpretation].

    Der Scorecard-Assistent berechnet nur Wertungsstatistiken für Felder, die Analysekandidaten sind (es sei denn, es gibt keine, in Fall berechnet er die Statistik für alle Felder).

  2. Feld als Modellierungsziel interpretieren .
  3. Wählen Sie „Tools>Scorecard-Assistent“ oder klicken Sie in der Symbolleiste auf [image].

    Der Scorecard-Assistent wird angezeigt.

  4. Wenn Sie ein binäres (0/1) Ziel verwenden, wählen Sie den entsprechenden Modelltyp aus dem Menü „Scorecard>Modelltyp“: Risiko, Antwort, Abwanderung, Zufriedenheit oder Unzufriedenheit.

    Für ein stetiges Ziel ist nur der Wert Modelltyp verfügbar.

  5. Wiederum, wenn Sie ein binäres Ziel verwenden, können Sie „Scorecard>Umgekehrter Zielwert“ wählen, um die Bedeutung des 0/1 Zielfelds zu ändern.

    Gemäß Standard gibt 1 im Ziel je nach gewähltem Modelltyp einen standardmäßigen, antwortenden, abwandernden, zufriedenen Kunde oder einen unzufriedenen Kunde an.

  6. Wenn nötig, ändern Sie die Standard-Erstellungsoptionen [siehe Steuern des Erstellens einer Scorecard].
  7. Wählen Sie „Scorecard>Erstellen“ oder klicken Sie in der Symbolleiste auf [image], um eine Scorecard zu erstellen.
Anmerkung:
  • Wenn Sie den Scorecard-Assistent öffnen, fordert er Sie auf, Stringfelder zu interpretieren, die keine kategorische Interpretation haben, sodass sie entsprechend klassifiziert werden können. Sie können entweder die standardmäßige kategorische Interpretation wählen oder eine gespeicherte kategorische Hierarchie verwenden. Wenn Sie bei der Aufforderung eine Interpretation für ein Stringfeld auswählen auf „Abbrechen“ klicken, ignoriert der Scorecard-Assistent den Analysekandidaten, zusammen mit allen übrigen Stringfeldern ohne kategorische Interpretation.
  • Die von Ihnen getroffenen Auswahl des Modelltyps beeinflusst die Beschriftung von Werten, Diagrammen usw. (aber erst nach dem Neuerstellen der Scorecard). Es gibt auch noch eine grundlegender Unterscheidung zwischen Risikomodellen und den anderen Binär-Ziel-Modelltypen: Bei einem Risikomodell übernehmen Sie normalerweise Kunden in Segmenten mit einer niedrigen vorhergesagten Standardrate. Wenn Sie jedoch eine Antwort-, Abwanderungs-, Zufriedenheits- oder Unzufriedenheitsmodell anwenden, zielen Sie normalerweise auf Kunden in Segmenten ab, die eine hohe vorhergesagte Antwort-/Abwanderungs-/Zufriedenheits-/Unzufriedenheitsrate haben.
  • Wenn Ihr Fokus ein Feld enthält, das eine Datensatzgewichtung repräsentiert, markieren Sie das Feld im Scorecard-Assistent und wählen „Felder>Gewichtung einstellen“, bevor Sie eine Scorecard erstellen. Bei positiven Integer-Gewichtungen [image], [image], ..., ist die Scorecard dieselbe, wie sie sie aus einem größeren Datensatz mit [image] -Vorkommnisse des ersten Datensatzes, [image] des zweiten usw. erhalten würden. Die Gewichtungsinterpretation erfolgt lokal für die Scorecard-Assistent-Instanz.

Siehe auch

Erstellen einer Scorecard mit dem Scorecard-Assistenten

Steuern des Erstellens einer Scorecard

Übernehmen eines Modells oder einer Segmentierung von Decision Studio für einen anderen Datensatz

Übergeordnetes Thema: Scorecards erstellen für Segmentierung und Predictive Modeling


Verfeinern einer Scorecard durch Hinzufügen oder Entfernen von Feldern

Im Field View [siehe Optionen für die Anzeige einer Scorecard] des Scorecard-Assistent zeigt der obere Bereich Felder, die in der Scorecard enthalten sind (sein sollen), während der untere Bereich die verbleibenden Analysekandidaten anzeigt. Eine Scorecard mit weniger Feldern ist möglicherweise einfacher/schneller zu implementieren und vielleicht noch robuster [siehe Test/Trainingsmethodik für robuste Modellierung], auch wenn es dann vielleicht ein weniger genaues Modell ist.

Mithilfe der Pfeile können Sie zwischen den Bereichen manuell Felder ein- oder ausschließen – eventuell auf der Basis von Gini, Cramers V oder Informationsgewinn. Sie können diesen Prozess der Feldauswahl auch automatisieren, möglicherweise unter Berücksichtigung von Wechselwirkungen zwischen den Feldern.

  1. Benutzen Sie „Felder>Autom. Einschließen“ (oder „Felder>Autom. Ausschließen“) oder klicken Sie in der Symbolleiste auf [image] (oder [image]), um Felder einzuschließen (oder auszuschließen).

    Das Dialogfeld „Autom. Einschluss-Optionen“ (oder „Autom. Ausschluss-Optionen“) wird angezeigt.

  2. Wählen Sie aus den folgenden Auswahlkriterien:
    • Schrittweise lineare Anpassung
    • Schrittweise Qualitätsgröße

    Der Algorithmus prüft die Qualität der temporären Scorecards durch die Einbeziehung (oder ohne) jedes Feldes der Reihe nach. Nach der Einbeziehung (oder Ausschluss) des Einzelfelds, das die beste temporäre Scorecard ergibt, wiederholt der Algorithmus solange, bis er die erforderliche Anzahl von Feldern einbezogen (oder ausgeschlossen) hat.

    Die Qualität der temporären Scorecard wird durch die aktuell ausgewählte Qualitätsmessung bestimmt [siehe So ändern Sie die Qualitätsgröße, die beim Aufbau einer Scorecard verwendet wird] - oder durch die lineare Regression, wenn Sie die Option „lineare Anpassung“ wählen. Die temporäre Scorecard wird aber immer mit Hilfe der linearen Regressions-Qualitätsmessung gebildet.

  3. Geben Sie die Anzahl der Felder an, die zu einem Zeitpunkt eingeschlossen oder ausgeschlossen werden sollen.
  4. Klicken Sie auf „OK“, um die autom. Ausschluss- und autom. Einschluss-Optionen auszuwählen.
Anmerkung: Sie können eine gute erste Scorecard zunächst durch den Ausschluss aller Felder erstellen und dann die erforderliche Anzahl von Feldern mit schrittweiser linearer Anpassung automatisch einschließen.
Übergeordnetes Thema: Scorecards erstellen für Segmentierung und Predictive Modeling


Optionen für die Anzeige einer Scorecard

Die folgenden Scorecard-Assistent-Ansichten stehen zur Verfügung:

Ansicht | Beschreibung
Feldansicht | Eine Zwei-Bereiche-Ansicht der Analysekandidaten und die damit verbundenen Statistiken, mit Feldern, die in der Scorecard im oberen Bereich enthalten sind und denjenigen, die im unteren Bereich ausgeschlossen sind
Registeransicht | Eine Bereichsansicht der Scorecard mit Registerkarten, die Gewichtungen (Klassenbewertungen) und Statistiken für jeweils ein Feld zurzeit
Bewertungslistenansicht | Eine einfachere Ansicht der Scorecard, welche die Gewichtungen (Klassenwertungen) für alle Felder in einer Ansicht zeigt
Grafikansicht | Eine der fünf grafischen Darstellungen [siehe Scorecard-Assistent-Diagramme], nebenstehende Bereiche zeigen Listen der ein- und ausgeschlossenen Felder
Korrelationsmatrix | Eine Korrelationsmatrix der Analysekandidaten

Zunächst zeigt der Scorecard-Assistent die Feldansicht (und andere Ansichten sind nicht verfügbar, bis Sie eine Scorecard erstellen oder öffnen). Um zu einer anderen Ansicht zu wechseln, wählen Sie entweder die Ansicht aus dem Menü „Ansicht“ oder Sie klicken auf die entsprechende Schaltfläche der Symbolleiste.

Übergeordnetes Thema: Scorecards erstellen für Segmentierung und Predictive Modeling

Scorecard-Assistent-Diagramme

Die folgenden grafischen Darstellungen sind im Scorecard-Assistent verfügbar:

Diagramm | Beschreibung
Gini | Die Gini-Kurve für das Scorecard-Modell
Histogramm | Überlagerte Plots von Kunden, die dem Ziel entsprechen und Kunden, die mit dem Ziel gegen die zugeordnete Bewertung nicht übereinstimmen
Kumulatives Histogramm | Eine kumulative Version des obigen
Strategiekurve | Eine Strategiekurve, um Ihnen bei der Auswahl einer geeigneten Abschaltung-Bewertung zu helfen
Gewichtungen | Eine grafische Darstellung der Scorecard, mit einem Diagramm der Gewichtungen (Klassen-Scores) für jedes Feld in der Scorecard

Sie können das anzuzeigende Diagramm aus dem Dropdown-Menü oben rechts im Diagramm auswählen.

Siehe auch

Optionen, die sich auf die Anzeige von Diagrammen und Entscheidungsbäumen auswirken

Ausrichten einer Diagrammanzeige mit Hilfe der Maus


Steuern des Erstellens einer Scorecard

Sie können steuern, wie eine Scorecard aufgebaut wird, indem Sie eine unterschiedliche Qualitätsgröße [siehe So ändern Sie die Qualitätsgröße, die beim Aufbau einer Scorecard verwendet wird], Auflöser [siehe So ändern Sie den Auflöser, der beim Aufbau einer Scorecard verwendet wird] oder Formular [siehe So ändern Sie das Formular einer Scorecard] verwenden.
Übergeordnetes Thema: Scorecards erstellen für Segmentierung und Predictive Modeling

So ändern Sie die Qualitätsgröße, die beim Aufbau einer Scorecard verwendet wird

Die Qualität einer Scorecard ist eine Schätzung ihrer Genauigkeit. Beim Erstellen einer Scorecard versucht der Scorecard-Assistent, die Scorecard-Qualität gemäß einer der drei Qualitätsgrößen zu maximieren.
Wählen Sie im Menü „Scorecard>Qualitätsgröße“ eine der folgenden Möglichkeiten:
  • Lineare Regression
  • Logistische Regression
  • Probit Regression
Anmerkung: Für ein stetiges (nicht binäres) Ziel ist die einzige verfügbare Qualitätsgröße die lineare Regression.

So ändern Sie den Auflöser, der beim Aufbau einer Scorecard verwendet wird

Bei einer Qualitätsgröße nutzt der Scorecard-Assistent einen von fünf Auflösern bei dem Versuch, die Scorecard-Qualität zu maximieren. Sie können wählen, welchen Auflöser der Scorecard-Assistent nutzt, und einige Aspekte im Verhalten des Auflösers steuern.

  1. Wählen Sie „Scorecard>Auflöser“

    Das Dialogfeld „Scorecard-Auflöser“ wird angezeigt.

  2. Wählen Sie im Menü „Methode“ eine der folgenden Möglichkeiten:
    • Simplex
    • Powell
    • Quasi-Newton
    • Konjugierter Gradient
    • Levenberg-Marquardt
Anmerkung: Im Allgemeinen sollte es nicht notwendig sein, die Qualitätsgröße oder eine der Einstellungen im Dialogfeld Scorecard-Auflöser zu ändern. Wenn Sie die Qualitätsgröße [siehe So ändern Sie die Qualitätsgröße, die beim Aufbau einer Scorecard verwendet wird] wählen, wählt der Scorecard-Assistent den leistungsstärksten Auflöser für diese Größe.

So ändern Sie das Formular einer Scorecard

Beim Aufbau einer Scorecard behandelt der Scorecard-Assistent entweder jede Klasse eines jeden enthaltenen Felds als eine unabhängige Variable oder weist ihm Gewichtungen innerhalb jedes Felds zu und formt diese Gewichtungen dann entsprechend der relativen Bedeutung der Felder im Modell um.
  1. Wählen Sie „Scorecard>Formular“.

    Das Dialogfeld Scorecard-Formular wird angezeigt.

  2. Wählen Sie im Bereich Formular „eine Gewichtung pro Klasse“ oder „eine Gewichtung pro Feld.“
  3. Wenn Sie die einfachere Option „eine Gewichtung pro Feld“ wählen, geben Sie an, wie der Scorecard-Assistent die Gewichtungen innerhalb jedes Felds transformieren soll.


Erstellen von Assoziations- und Sequenzregeln

  • Informationen zum Assoziationsanalyse-Assistenten
  • Erstellen von Assoziations- und Sequenzregeln mit dem Assoziationsanalyse-Assistenten


Informationen zum Assoziationsanalyse-Assistenten

Der Assoziationsanalyse-Assistent automatisiert die Erkennung von Assoziations- und Sequenzregeln. Diese werden normalerweise benutzt, um detaillierte Kundentransaktionen, Korb- oder Ereignisdaten für Anwendungen zu detaillieren, wie:

Marktkorbanalysen identifiziert Produktkombinationen, die für gewöhnlich (oder nicht erscheinen) zusammen in einer einzigen Kauftransaktion (Korb mit Artikeln) erscheinen.

Bestes nächste Produkt bestimmt die häufigste Sequenz in der Produkte oder Dienstleistungen gekauft werden. Bankkunden eröffnen beispielsweise eher ein Investment-/Handelskonto, nachdem sie ein hochverzinsliches Sparkonto eröffnet haben.

Marktauswirkungsanalyse identifiziert Marketing-Kommunikationsmuster, die wahrscheinlicher vor einem Kauf auftreten

Datenaufbereitung Der Assoziationsanalyse-Assistent führt direkt einen Abgleich mit Transaktions- oder Ereignisdaten in einem gespeicherten Fokusdatensatz durch, wobei er vom Hochleistungsdatenzugriff von Portrait Miner begünstigt wird.
  • Für Marktkorbanalysen sollten Sie einen Datensatz auf Artikelbasis mit einem Datensatz pro Artikel verwenden. Der Datensatz muss einen Korbidentifizierer-Feld enthalten, das die Artikeln im selben Korb gruppiert, und ein Produktidentifizierer-Feld (klassifiziert und kategorisch), das den Produktnamen oder Code für jeden Artikel angibt. Der Datensatz muss nach dem Korbidentifizier-Schlüsselfeld sortiert sein.
  • Bei Nächstes-Produkt-Analysen sollten Sie einen Datensatz mit einem Datensatz pro Produkt oder Dienst wählen. Der Datensatz muss einen Korbidentifizierer enthalten – häufig der Kundenidentifizierer – der Produkte zusammen mit dem Produktidentifizierer (klassifiziert und kategorisch) und einer Produktzeitmarke (Integer oder Datum), die die Reihenfolge, in der die Produkte erworben wurden, anzeigt, gruppiert. Der Datensatz muss nach dem Korbidentifizier-Schlüsselfeld sortiert sein.

Algorithmusparameter Der Assoziationsanalyse Assistent basiert auf dem genormten Apriori-Algorithmus und enthält eine umfangreiche Funktionalität für die Steuerung zum Auffinden der Regeln. Weitere Informationen zum Apriori-Algorithmus finden Sie in der Apriori-Dokumentation auf Ihrem Portait Miner-Datenträger (DVD/zip). Die Dokumentation befindet sich unter \server\Components\ext\qsruleminer\docs\apriori_docs.

Sie können die Regelerkennung auf bestimmte interessante Produkte einschränken und eine Vielzahl von Parametern steuern, die definieren, was eine interessante Regel ist (Unterstützung, Konfidenz, Regelkomplexität, erweiterte Regelauswahlgrößen). Beachten Sie, dass diese Einstellungen die Ausführungszeit beeinflussen können: Insbesondere das Reduzieren des Minimum-Supportwerts verlängert die Ausführungszeit, es sei denn die maximale Regelkomplexität (Anzahl Vorgänger) wird ebenfalls angegeben.

Terminologie Der Assoziationsanalyse Assistent nutzt eine Vielzahl von Begriffen, die möglicherweise nicht vertraut sein können, einschließlich:

Regel Im Allgemeinen behauptet eine Regel, dass wenn ein Set von Bedingungen erfüllt ist (die linke Seite oder Vorgänger der Regel), wird eine andere Bedingung eintreten (die rechte Seite oder Nachfolger der Regel). Bei Assoziations- und Sequenzregeln entsprechen die Bedingungen in der Regel dem Vorhandensein bestimmter Artikel im Korb. Eine einfach Regel könne beispielsweise Folgende sein: Wenn ein Korb Brot enthält, dann wird er auch Marmelade enthalten.

Vorgänger Die linke Seite einer Regel, z. B. das Set mit den Artikeln, die im Korb erscheinen müssen, damit die Regel relevant ist.

Nachfolger Die rechte Seite einer Regel, z. B. ein Set von Artikeln, dass die Regel vorhersagt und die gegenwärtig sein werden, wenn die linke Seite (Vorgänger) erfüllt ist.

Support Die (absolute) Unterstützung eines Sets mit Elementen ist die Anzahl Körbe, die alle Artikel im Set enthalten. Relative Unterstützung ist die gleiche Zahl als Prozentsatz der Gesamtanzahl der Körbe ausgedrückt.

Regel-Support Der Support einer Regel ist die Unterstützung der Vorgeschichte der Regel, z. B. Verhältnis der Körbe für die linke Seite der Regel angewendet wurde. Hiermit wird gemessen, wie häufig die Regel relevant ist.

Regelkonfidenz Die Konfidenz einer Regel ist die Unterstützung des Sets aller Artikel, die in der Regel (links oder rechts) erscheinen, dividiert durch die Unterstützung der Vorgeschichte der Regel. Hiermit wird die Likelihood, dass die Konklusion der Regel (rechte Seite) true ist, gemessen, wobei der Vorgänger der Regel erfüllt ist, z. B. die Likelihood, dass die Regel richtig ist.

Absoluter Konfidenzunterschied zu Vorheriger Die Differenz in den nachfolgenden und vorherigen Konfidenzkennzahlen (mit und ohne Vorgängerelementen). Dadurch wird gemessen, wie viel mehr (oder weniger) wahrscheinlich der Nachfolger der Regel ist, wenn die linke Seite der Regel true ist. Beispielsweise ist die Regel „wenn Brot, dann Marmelade“ ist nicht sehr interessant, wenn ihre Konfidenz ähnlich der Regel „wenn (irgendetwas), dann Marmelade“ ist.

Lift-Wert Das Verhältnis von nachheriger und vorheriger Konfidenzgröße (mit und ohne Vorgängerelemente).

Ergebnisse (Optional) werden verschiedene Ausgaben erzeugt, darunter:
  • Ein interaktiver HTML-Modellbericht fasst die erstellten Regeln, ihre Metrik und die Option zusammen, um interessante Regeln herauszufiltern.
  • Ein bewerteter neuer Datensatz erstellt einen aggregierten Datensatz (ein Datensatz pro Korbidentifizierer), welcher angibt, ob eine ausgewählte Regel für die Datensatzgruppe erfüllt wurde.
  • Die Regeln als ausführbarer Code im Transaction Measurement Language-Format.
  • „Verwenden sie das Register „Deploy“, wie unten aufgezeigt, um die Regeln in die Predictive Model Markup Language (PMML) optional zu exportieren.
Übergeordnetes Thema: Erstellen von Assoziations- und Sequenzregeln


Erstellen von Assoziations- und Sequenzregeln mit dem Assoziationsanalyse-Assistenten

Speichern Sie Ihren Modellierungsfokus mit dem Produktidentifizierer-Feld klassifiziert und kategorisch. Diese Vorbereitung kann durch Importieren von Fokus-Metadaten [siehe Kopieren der Fokus-Metadaten von einem Fokus zum anderen] in den Modellierungsfokus automatisiert werden.

Klicken Sie in Portrait Miner mit der rechten Maustaste auf einen Fokus und wählen Sie „Vorhersage>Assoziationsanalyse-Assistent“.

Im Dialogfeld Assoziationsanalyse-Assistent können Sie die Art der zu erstellenden Assoziationsregeln wählen, die Parameter zu Kennzeichnung interessanter Regeln auswählen und auswählen, welcher Korbidentifizierer (gemäß Voreinstellung das erste Feld), Produktidentifizierer (gemäß Voreinstellung das Zielfeld) und Produkt-Zeitstempel (gemäß Voreinstellung das Partitionsfeld) analysiert werden sollen. Sie können die erstellten Regeln dahin gehend einschränken, dass immer ein bestimmter Satz von Produkten eingeschlossen wird.

Anmerkung:
  • Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl qsruleminer in Portrait Miner bereitgestellt werden, zuzugreifen.

Siehe auch

Informationen zum Assoziationsanalyse-Assistenten

Informationen über Portrait Miner-Assistenten

Übergeordnetes Thema: Erstellen von Assoziations- und Sequenzregeln


Erstellen von Naive Bayes-Modellen für die Segmentierung und Predictive Modeling

  • Informationen zum Naive-Bayes-Assistenten
  • Erstellen eines Tendenzmodells mit dem Naive Bayes-Assistenten


Informationen zum Naive-Bayes-Assistenten

Der Naive Bayes-Assistent erstellt mithilfe des Bayes'schen Lehrsatzes ein Tendenzmodell, kombiniert mit einer („naiven“) Annahme bedingter Unabhängigkeit, um den Wert einer Zielfeldkategorie aus dem Nachweis vorherzusagen, der durch einen oder mehrere Analysekandidaten gegeben ist. Ein Naive-Bayes-Modell definiert im Wesentlichen ein Set von Kreuztabellen: Für jeden Analysekandidaten existiert eine Kreuztabelle, die die Häufigkeitszählungen der Analysekassen hinsichtlich ihrer Zielkategorien enthält.

Bei einer Zählung von Null ist besondere Beachtung erforderlich, und das Naive-Bayes-Modell beinhaltete einen Schwellenwertparameter, der eine Standardwahrscheinlichkeit (normalerweise sehr gering) spezifiziert, die zu verwenden ist, wenn die Zählung Null ist.

Der Naive Bayes-Assistent erfordert, dass jedes Feld (ob Ziel oder Analysekandidat) so klassifiziert ist, dass für jedes Feld nur eine kleine, endliche Anzahl von Werten vom Modell berücksichtigt wird. Das Zielfeld wird als kategorisch behandelt, während die Analysekandidaten ihre Klasseneinteilung aus dem Modellierungsdatensatz übernehmen. Werte werden als separate Kategorien behandelt.

Ergebnisse (Optional) werden verschiedene Ausgaben erzeugt, darunter:

  • Ein HTML-Bericht, der zusammenfasst, wie die Naive Bayes-Modelltendenz, einschließlich der Eingabeparameter und Vergleich mit den historischen Antworten, angewandt wurde.
  • Das endgültig empfohlene Modell in den Formaten Field Derivation Language [siehe Informatinoen zur Field Derivation Language], QMML [siehe Speichern eines Decision Studio Modells oder einer Segmentierung zur Verwendung als QMML (XML)] und Predictive Modell Markup Language (PMML).
  • Der endgültige Datensatz einschließlich der Modellvorhersage.

Siehe auch

Erstellen eines Tendenzmodells mit dem Naive Bayes-Assistenten
Übergeordnetes Thema: Erstellen von Naive Bayes-Modellen für die Segmentierung und Predictive Modeling


Erstellen eines Tendenzmodells mit dem Naive Bayes-Assistenten

Speichern Sie Ihren Modellierungsfokus mit dem markierten Zielfeld, Analysekandidaten und kategorische Variablen. Diese Vorbereitung kann durch Importieren von Fokus-Metadaten [siehe Kopieren der Fokus-Metadaten von einem Fokus zum anderen] in den Modellierungsfokus automatisiert werden.

Klicken Sie in Portrait Miner mit der rechten Maustaste auf einen Fokus und wählen Sie „Vorhersage>Naive Bayes-Assistent“.

Im Dialogfeld „Naive Bayes-Assistent“ können Sie das zu analysierende Zielfeld, sowie Kategorie und Analysekandidaten, den zu verwendenden Naive-Bayes-Schwellenwert und die Details der erzeugten Modellierungsergebnisse auswählen.

Siehe auch

Informationen zum Naive-Bayes-Assistenten

Informationen über Portrait Miner-Assistenten

Übergeordnetes Thema: Erstellen von Naive Bayes-Modellen für die Segmentierung und Predictive Modeling


Clustermodelle erstellen für die Segmentierung und Predictive Modeling

  • Informationen zu Clustermodellen in Portrait Miner
  • So bauen Sie ein Clustermodell auf
  • Optionen für die Anzeige eines Clustermodells
  • Steuern des Aufbaus eines Clustermodells


Informationen zu Clustermodellen in Portrait Miner

Clustering ist eine ungerichtete (zielfreie) Modellierungstechnik zur Segmentierung einer Gesamtmenge in „Cluster“ von ähnlichen Datensätzen auf den beobachteten Werten eines oder mehrerer Analysefelder.
  • Jedes Cluster in einem Clustermodell verfügt über ein „Zentrum“, das Sie sich als einen Datensatz vorstellen können, der einen Wert für jeden Analysekandidaten enthält (außer, dass ein kategorisches [siehe Feldinterpretationen] Feld so behandelt wird, als ob es ein Satz von Indikatorfeldern wäre [siehe Kategorische Felder beim Clustering]).
  • Jeder Datensatz im Fokus gehört zu dem Cluster, dessen Zentrum dem Datensatz am nächsten ist, entsprechend einer normalisierten Quadratsummen-Distanzmetrik [siehe Messen der Größe und Trennung von Clustern].

Siehe auch

Steuern des Aufbaus eines Clustermodells

So bauen Sie ein Clustermodell auf

Übergeordnetes Thema: Clustermodelle erstellen für die Segmentierung und Predictive Modeling

Messen der Größe und Trennung von Clustern

Die Idee des Clustering beruht auf einem gewissen Maß an Distanz oder Nähe zwischen Datensätzen.

Betrachten wir zwei Datensätze [image] und [image] (wobei [image] der Wert von Feld j im Datensatz i ist). Zuerst werden die Werte so „normalisiert“, dass jedes Feld einen Mittelwert von 0 und eine Standardabweichung von 1 hat (für den Datensatz, auf dem das Modell aufbaut):

wobei [image] bzw. der Mittelwert bzw. die Standardabweichung von Feld j sind. Definieren Sie jetzt die Distanz zwischen den Datensätzen [image] und [image] als normale Euklidische Quadratsummen-Distanz zwischen den normalisierten Datensätzen [image] und [image]:

(Beachten Sie, dass es keine Quadratwurzel gibt.)

Angesichts dieser Abstandsmetrik ist es möglich, die Größe eines Clusters (mit einer der beiden Messgrößen, Radius und ESS) zu bestimmen und zu erkennen, wie gut ein Cluster von anderen Clustern separiert ist. In der Erweiterung können Sie auch eine Quantifizierung der Qualität eines Clustermodells erreichen.
  • Der Radius eines Clusters ist die maximale Entfernung zwischen einem Datensatz im Cluster und dem Cluster-Zentrum. Ein ideales Cluster hat einen Radius von Null.
  • Die ESS eines Clusters ist die Summe der Abstände aller Datensätze im Cluster vom Zentrum des Clusters. Ein ideales Cluster hat Null ESS.

    Für ein Clustermodell ist die Gesamt-ESS die Summe der ESS-Werte für jedes Cluster. Ein ideales Modell hat Null Gesamt-ESS.

  • Die Trennung für einen Datensatz ist [image], wobei [image] die Distanz vom Datensatz zum nächsten Cluster-Zentrum und [image] die Distanz vom Datensatz zum zweitnächsten Cluster-Zentrum ist. Werte liegen zwischen 0 und 1; ein höherer Wert weist darauf hin, dass der Datensatz eine stärke Verknüpfung mit dem ihm zugeordneten Cluster hat.

    Die Separation für ein Cluster ist der Mindestabstand für einen Datensatz in dem Cluster. Ein gut getrenntes Cluster hat einen Wert nahe 1.

    Die Separation für ein Clustermodell ist der Mindestabstand für einen Datensatz in dem Dataset. Ein gutes Modell hat einen Wert nahe 1.

Anmerkung:
  • Für die Zwecke der Berechnung der Distanzmetrik sollte ein kategorisches Feld als eine Reihe von Indikator-Feldern betrachtet werden [siehe Kategorische Felder beim Clustering].
  • Wenn Sie ein Cluster-Modell auf ein neues Dataset anwenden, werden die Werte in Bezug auf die Skalierungsparameter des ursprünglichen Datasets normalisiert.

Wie das Decision Studio ein Clustermodell erstellt

Der Clustermodell-Werkzeug im Decision Studio implementiert einen nicht-hierarchischen k-means-Clustering-Algorithmus, auch als „Lloyd-Methode“ bekannt.

Der Algorithmus ignoriert Klasseneinteilung auf einem nicht-kategorischen Feld. Er schließt nicht-kategorische Analysekandidaten mit Null Standardabweichung sowie kategorische Analysekandidaten mit Datensätzen in nur einer Kategorie aus. Er erstellt ein Dummy-Feld für jede nicht-leere Kategorie eines enthaltenen kategorischen Analysekandidaten.

Im Rahmen von vorgegebenen Clustern (ausgewählt nach dem Zufallsprinzip), bewegt der Algorithmus iterativ Datensätze zwischen Clustern, um die Gesamt-ESS zu minimieren:
  1. Jeder Datensatz wird dem Cluster zugeordnet, dessen Zentrum er am nächsten ist (entsprechend der Entfernungsmetrik). Falls ein Datensatz von zwei oder mehreren Clustern den gleichen Abstand hat, wird der Datensatz dem ersten Cluster mit dem minimalsten Abstand zugeordnet.
  2. Sonderfälle [siehe Parameter für ein Clustermodell] werden ausgeschlossen.
  3. Die Cluster-Mittelwerte werden (neu) berechnet und für die nächste Iteration werden die Cluster-Zentren so eingerichtet, dass sie diese Cluster-Mittelwerte sind.
  4. Iterationen werden so lange fortgesetzt, bis eines der Abbruchkriterien [siehe Abbruchkriterien für ein Clustermodell] befriedigt ist.

Kategorische Felder beim Clustering

Der Cluster-Algorithmus behandelt einen kategorischen Analysekandidaten, als wäre es eine Reihe von numerischen Indikator-Feldern, eins pro Kategorie (einschließlich Null [siehe Der Nullwert] und nicht klassifizierten Kategorien). Jede Kategorie im ursprünglichen Feld wird durch den Wert 1 im entsprechenden Indikator-Feld und den Wert 0 in jedem der anderen Indikator-Felder repräsentiert.

Beispielsweise wird ein kategorisches Feld wie Geschlecht mit drei Kategorien, männlich, weiblich und Null, durch drei Indikator-Felder repräsentiert, die im Clustermodell-Werkzeug als Geschlecht (männlich), Geschlecht (weiblich) und Geschlecht (Null) erscheinen. Ein Datensatz für eine Kundin hat die Werte 0, 1 und 0 für diese Indikator-Felder. Ein typisches Cluster-Zentrum hat vielleicht die Werte 0,3, 0,2, und 0,5 in diesen Feldern. (Die Werte für Indikator-Felder, die mit einem kategorischen Feld korrespondieren, addieren sich immer zu 1.)

Wenn der Clustermodell-Werkzeug die Anzahl der Dimensionen zeigt, die zum Erstellen eines Clusterings verwendet werden, zählt jedes Indikator-Feld als eine Dimension.

Der Nullwert beim Clustering

Beim Berechnen der Distanz wird der Nullwert [siehe Der Nullwert] in einem nicht-kategorischen Feld als gleich nah zu allen Cluster-Zentren betrachtet, d. h., sein Beitrag zur Distanz ist Null und die Distanz von einem Cluster-Zentrum wird durch die restlichen Felder bestimmt. % dupliziert Text im Thema „Kategorische Felder beim Clustering“. Die Null-Kategorie in einem kategorischen Analysekandidaten wird genauso behandelt wie jede andere Kategorie. Wenn alle Analysekandidaten nicht-kategorisch sind, werden Datensätze, die den Null-Wert für alle enthalten, ignoriert (und produzieren ein Null-Cluster-Index-Ergebnis).
Anmerkung: Bei der Anwendung eines Clustermodells behandelt der Clustermodell-Werkzeug kategorische Werte, die leer oder beim Erstellen gar nicht vorhanden waren, mit der Zuordnung der in ihnen enthaltenden Datensätze zu einem Null-Cluster.


So bauen Sie ein Clustermodell auf

  1. Optional einige Felder als Analysekandidaten interpretieren [siehe Für das Festlegen oder Leeren eines Analysekandidaten, einer kategorischen, geografischen, Export-oder Zielinterpretation].

    Wenn es Felder mit Analysekandidaten-Interpretation gibt, berücksichtigt der Clustermodell-Werkzeug nur diese Felder beim Erstellen von Clustermodellen.

  2. Wählen Sie „Tools>Clustermodell-Werkzeug“ oder klicken Sie in der Symbolleiste auf [image].
  3. Wenn nötig, ändern Sie die Standard-Erstellungsoptionen [siehe Steuern des Aufbaus eines Clustermodells].
  4. Wählen Sie „Clustering>Aufbauen bis Ende“ oder klicken Sie in der Symbolleiste auf [image], um ein Clustermodell aufzubauen.

    Der Clustermodell-Werkzeug fährt solange fort, bis er eine oder mehrere der Abbruchkriterien [siehe Abbruchkriterien für ein Clustermodell] für ein Clustermodell erfüllt.

  5. Um optional eine weitere Iteration des Clustermodells zu erstellen, wählen Sie „Clustering>Nächste Iteration ausführen“ oder klicken Sie in der Symbolleiste auf [image].

    (Wenn das Clustermodell konvergiert hat oder sich die Erstellungsparameter geändert haben, steht diese Option nicht zur Verfügung.)

Anmerkung:
  • Der Clustermodell-Werkzeug ist ein ungerichtetes Modellbau-Werkzeug. Er berücksichtigt daher keine Zielsetzung, die Sie gesetzt haben.
  • Die Bereiche auf der linken Seite des Fensters Clustermodell-Werkzeug zeigen eingeschlossene (Analysekandidaten) und ausgeschlossene Felder (andere Felder im Fokus) mit Feldern, die im aktuellen Clustermodell in Fettdruck angezeigt erscheinen.

    Sie können ein Feld wie einen Analysekandidaten interpretieren, indem Sie es aus dem unteren Bereich in den oberen Bereich verschieben (und umgekehrt) und dazu die Pfeiltasten benutzen.

  • Wenn Sie ein Clustermodell zu erstellen beginnen, fordert der Clustermodell-Werkzeug Sie auf, Felder mit beliebigem String zu interpretieren, die keine kategorische Interpretation haben, sodass sie entsprechend klassifiziert werden können. Sie können entweder die standardmäßige kategorische Interpretation wählen oder eine gespeicherte kategorische Hierarchie verwenden. Wenn Sie bei der Aufforderung eine Interpretation für ein Stringfeld zu wählen auf „Abbrechen“ klicken, ignoriert der Clustermodell-Werkzeug den Analysekandidaten, zusammen mit allen übrigen Stringfeldern ohne eine kategorische Interpretation.
  • Statistiken für Clustermodelle werden im Bereich „Clustering-Ergebnisse“ angezeigt. Dazu gehören Messungen der Modell-Qualität (insgesamt ESS und Trennung) sowie Modellbau-Parameter.

    Statistiken für die Cluster im letzten Modell erscheinen im Bereich „Cluster-Details“ (mit Ausnahme der Sonderfälle und Null-Cluster). Dazu gehören Messgrößen der Cluster-Qualität (ESS, Trennung und Radius) sowie die Anzahl der Datensätze in jedem Cluster und die Feldwerte, die das Zentrum jedes Clusters beschreiben.

  • Um den Verlauf von Clustermodellen zusammen mit den aktuellen Modelldetails zu löschen, wählen Sie „Clustering>Löschen“ oder klicken Sie in der Symbolleiste auf [image].
  • Cluster in einem Clustermodell sind nummeriert: Jeder Datensatz besitzt einen entsprechenden Cluster-Index zwischen 1 und der Anzahl der Cluster, es sei denn, er wird als Sonderfall [siehe Parameter für ein Clustermodell] betrachtet. In diesem Fall besitzt er den Cluster-Index -1.

    Sie können ein Feld mit dem Cluster-Index ableiten [siehe So leiten Sie ein Feld aus einem Decision Studio-Modell oder einer Kreuztabelle ab].

Siehe auch

Informationen zu Clustermodellen in Portrait Miner

Steuern des Aufbaus eines Clustermodells

Übernehmen eines Modells oder einer Segmentierung von Decision Studio für einen anderen Datensatz

Übergeordnetes Thema: Clustermodelle erstellen für die Segmentierung und Predictive Modeling

Wählen der richtigen Anzahl von Clustern

Der Algorithmus [siehe Wie das Decision Studio ein Clustermodell erstellt], den der Clustermodell-Werkzeug zur Erstellung eines Clustermodells benutzt, verlangt von Ihnen, die Zielanzahl der Cluster [siehe Parameter für ein Clustermodell] vorher festzulegen.
Wenn Sie eine unangemessene Anzahl von Clustern wählen, kann der Clustermodell-Werkzeug kein gutes Clustermodell finden:
  • Wenn Sie zu wenige Cluster angeben, mischt der Clustermodell-Werkzeug eindeutige Cluster. Im schlimmsten Fall kann er einen „natürlichen“ Cluster aufbrechen und seinen Inhalt über benachbarte Cluster verteilen, was zu einem Modell führt, das die realen Cluster überhaupt nicht erfasst.
  • Wenn Sie zu viele Cluster angeben, wird der Clustermodell-Werkzeug einige Cluster in kleine Teile zerlegen.
Ihre betriebswirtschaftlichen Kenntnisse können Ihnen eine geeignete Anzahl von Clustern vorgeben oder Sie müssen möglicherweise mit verschiedenen Werten experimentieren und sehen, was zum besten Modell führt. Eine Methode, die recht gut funktioniert, ist die Tatsache auszunutzen, dass, obwohl es schwer zu erkennen ist, Sie zu wenige Cluster haben; wenn Sie zu viele haben, wird das Trennungsmaß tendenziell niedrig sein.
  1. Beginnen Sie mit einer ziemlich großen Anzahl von Clustern und bauen Sie mehrere Modelle und versuchen Sie, das Trennungsmaß zu maximieren.
  2. Wenn Sie keine Trennungsmaßstatistik nahe 100 % erhalten, reduzieren Sie die Anzahl der Cluster um eins und versuchen Sie es erneut.
  3. Fahren Sie solange weiter fort, bis Sie für die gewählte Anzahl von Clustern zumindest gelegentlich ein Clustermodell mit einem hohen Trennungsmaß erhalten.
Anmerkung:
  • Sie erhalten möglicherweise nicht immer die Anzahl der Cluster, die Sie angeben, da der Clustermodell-Werkzeug alle leeren Cluster aus einem Clustermodell ausschließt.
  • Beachten Sie, dass ein Modell ein hohes Trennungsmaß haben kann, nur weil es einen großen Teil der Datensätze als Sonderfälle klassifiziert.

Optimieren eines Clustermodells

Das Trennungsmaß gibt einen recht guten Hinweis darauf, wann zu viele Cluster vorhanden sind. Aber wenn man einmal die richtige Anzahl von Clustern gefunden hat, ist es nicht so hilfreich bei der Unterscheidung zwischen guten und schlechten Modellen.

Ein Weg, um Ihr Modell zu optimieren, ist, die Anzahl der Cluster fixiert zu halten und einen großen Satz von Clustermodellen zu erstellen und zu versuchen, die gesamte ESS zu minimieren.

Anmerkung: Beachten Sie, dass ein Modell ein hohes Trennungsmaß haben kann, nur weil es einen großen Teil der Datensätze als Sonderfälle klassifiziert.

Vermeiden der Überanpassung beim Erstellen eines Clustermodells

Wie bei jeder Modellbautechnik, müssen Sie Überanpassung beurteilen und vermeiden. Benutzen Sie eine Test/Trainingsmethodik [siehe Test/Trainingsmethodik für robuste Modellierung] und seien Sie vorsichtig, wenn Sie die Folgende benutzen:
  • Analysefelder mit einer großen Anzahl von Kategorien
  • Eine große Anzahl von Analysekandidaten (in welchem Fall ein anderes mögliches Problem ist, dass die Mehrheit der Datensätze als Sonderfälle enden)
  • Eine große Zielanzahl von Clustern


Optionen für die Anzeige eines Clustermodells

Die folgenden Clustermodell-Werkzeug-Ansichten stehen zur Verfügung:

Ansicht | Beschreibung
Tabellenansicht | Eine Zwei-Tabellen-Ansicht, die Statistiken für aufeinander folgende Clustermodelle in der oberen Tabelle und Statistiken für die Cluster des aktuellsten Modells in der unteren Tabelle anzeigt. In den seitlichen Fensterbereichen stehen Listen der eingeschlossenen und ausgeschlossenen Felder.
Grafikansicht | Eine zwei- oder dreidimensionale grafische Darstellung [siehe Clustermodell-Werkzeug-Diagramme]. Im den seitlichen Fensterbereich sind die Felder im Fokus aufgeführt (wobei die im Modell enthaltenen Felder fett dargestellt sind).

Zunächst zeigt der Clustermodell-Werkzeug die Tabellenansicht (und die Diagrammansicht ist nicht verfügbar, bis Sie ein Clustermodell erstellen oder öffnen). Um zwischen Tabellen- und Diagrammansichten zu wechseln, wählen Sie entweder die Ansicht aus dem Menü „Ansicht“ oder Sie klicken auf die entsprechende Schaltfläche der Symbolleiste.

Übergeordnetes Thema: Clustermodelle erstellen für die Segmentierung und Predictive Modeling

Clustermodell-Werkzeug-Diagramme

In der Diagrammansicht des Clustermodell-Werkzeug:
  • Markieren Sie eine beliebige Anzahl von Feldern im linken Fensterbereich und klicken Sie auf „2D-Diagramm“, um einen Satz von Profildiagrammen [siehe Erstellen einer Gruppe von Profildiagrammen mit einer Variablen] für diese Felder zu erhalten.
  • Markieren Sie bis zu drei Felder im linken Fensterbereich und klicken Sie auf „3D-Diagramm“, um ein Kreuzverteilungsdiagramm [siehe Erstellen eines Kreuzverteilungsdiagramms mit mehreren Variablen], aufgeschlüsselt nach den von Ihnen gewählten Feldern, zu erhalten.

In beiden Fällen verknüpft der Clustermodell-Werkzeug die folgenden Statistiken mit dem Aussehen des Diagramms:

Statistik für Segment | Diagrammaussehen
count | Blockhöhe (oder Volumen, bei einem Drei-Felder-Kreuzverteilungsdiagramm)
mode des Cluster-Index | Blockfarbe
mode ratio [siehe moderatio] des Cluster-Index | Bockhelligkeit

Je reiner ein Segment - hinsichtlich des Ideals aller Datensätze, die in ein einzelnes Cluster fallen - ist, desto heller ist die Blockfarbe für das Segment. (Ein Modusanteil von 1 für ein Segment gibt an, dass alle Datensätze in dem Segment in demselben Cluster liegen.)

Jede Diagrammansicht enthält auch eine Legende mit Blöcken für 50 %, 75 % und 100 % Helligkeit, um einen nützlichen Hinweis zu geben, wie sich jede Farbe je nach Helligkeit verändert.


Steuern des Aufbaus eines Clustermodells

Sie können steuern, wie der Clustermodell-Werkzeug ein Clustermodell erstellt, indem Sie „Clustering>Parameter“ wählen und die Einstellungen im Dialogfeld „Clustering-Parameter“ ändern:

Siehe auch

Informationen zu Clustermodellen in Portrait Miner

So bauen Sie ein Clustermodell auf

Übergeordnetes Thema: Clustermodelle erstellen für die Segmentierung und Predictive Modeling

Parameter für ein Clustermodell

In der oberen Hälfte des Dialogfelds „Clustering-Parameter“ stehen Einstellungen für allgemeine Clustermodell-Parameter:

Einstellung | Beschreibung
Anzahl Cluster | Die angestrebte Anzahl von getrennten Clustern im Clustermodell
Sonderfallbegrenzung | Ein Multiplikator m, der bestimmt, dass die Datensätze als Sonderfälle behandelt werden sollen. Der Clustermodell-Werkzeug behandelt einen Datensatz als Sonderfall, wenn für einige nicht-kategorische Analysekandidaten die Differenz zwischen dem Wert für den Datensatz und dem Wert für das nächste Clusterzentrum m Standardabweichungen des Feldes übersteigt. Wenn die Sonderfallbegrenzung nicht gesetzt ist, werden keine Datensätze als Sonderfälle erkannt.
Benutzerdefinierte Startparameter | Ein Startparameter für die Initialisierung der Clusterzentren im Cluster-Algorithmus. Wenn der benutzerdefinierte Startparameter nicht gesetzt ist, wählt der Clustermodell-Werkzeug einen Startparameter (basierend auf der Systemuhr) für jede Erstellung aus. Das Einstellen des Startparameters ermöglicht es wiederholbare Clustermodelle zu erzeugen.
Stellen Sie zur Reproduktion eines zuvor erstellten Clustermodells den zufälligen Startparameter auf den Startparameter, der für das Modell im Bereich „Clustering-Ergebnisse“ angezeigt wird.

Abbruchkriterien für ein Clustermodell

In der unteren Hälfte des Dialogfelds „Clustering-Parameter“ stehen Einstellungen für den Fall, dass der Clustermodell-Werkzeug nicht weiter nach verbesserten Clustermodellen sucht:

Einstellung | Beschreibung
Maximale Iterationen | Die maximale Anzahl der Iterationen im Clustering-Algorithmus, die der Clustermodell-Werkzeug ausführt
Minimale Bewegung | Die Anzahl der Datensätze n, sodass der Clustermodell-Werkzeug keine weiteren Iterationen ausführt, wenn er weniger als n Datensätze während einer Iteration zwischen den Clustern neu klassifiziert. Sie können die Anzahl der Datensätze in absoluten Zahlen oder als Prozentsatz der Gesamtmenge spezifizieren.
Anmerkung: Der Algorithmus des Clustermodell-Werkzeug endet, wenn ein Abbruchkriterium erfüllt ist. Deshalb endet er in der Regel, ohne das andere Kriterium zu befriedigen.


Anwenden neuer Modelle und Segmentierungen auf neue Kunden- und Transaktionsdaten

  • Speichern eines Decision Studio Modells oder einer Segmentierung zur Verwendung als QMML (XML)
  • Ein Decision Studio Modell oder Segmentierung für die Verwendung in SAS konvertieren
  • Ein Decision Studio Modell oder Segmentierung für die Verwendung in SQL konvertieren
  • Modellmetadaten
  • Einen Modellzusammenfassung erstellen


Speichern eines Decision Studio Modells oder einer Segmentierung zur Verwendung als QMML (XML)

Sie können ein Modell oder eine Segmentierung als QMML (XML) Dokument speichern, um es mit dem Assistenten „Felder ableiten“ [siehe Felder in einem Fokus mit Portrait Miner ableiten], dem Portrait Miner Dateierstellungsbefehl qsderive oder mit Potrait Dialogue oder Portrait Interaction (über QMML) zu verwenden.
  1. Wenn Ihr Modell oder Ihre Segmentierung nicht bereits in Bedingungen der abgeleiteten Felder in einem Fokus ausgedrückt ist, gehen Sie folgendermaßen vor:
    • Für einen Entscheidungsbaum, eine Scorecard oder ein Clustering Modell, leiten Sie erzeugte Felder [siehe So leiten Sie ein Feld aus einem Decision Studio-Modell oder einer Kreuztabelle ab] ab, um die wichtigen Eigenschaften Ihres Modells einzukapseln.
    • Für eine grafische Segmentierung leiten Sie ein Kennzeichenfeld [siehe Ableiten eines Feldes von einer grafischen Segmentierung] für die Schlüsselsegmente der von Ihrem Diagramm bestimmten Gesamtmenge ab.
    • Für eine Kreuztabelle (textlich oder grafisch) leiten Sie ein Index-Feld [siehe So leiten Sie ein Feld aus einem Decision Studio-Modell oder einer Kreuztabelle ab], das die Segmentierung vollständig darstellt, ab.
    • Für ein Modell oder eine Segmentierung, die auf Geschäftsregeln beruht, leiten Sie Felder mit dem Tabellenansicht [siehe Ein Feld mithilfe des Tabellenansichts ableiten] ab.
  2. Wählen Sie im Tabellenansicht „Datei>Als QMML exportieren“ oder klicken Sie in der Symbolleiste auf [image].

    Ein Portrait Miner Dateibrowser erscheint.

  3. Navigieren [siehe Navigieren zum Öffnen oder Speichern einer Datei, Sitzung oder einer Datenbanktabelle] Sie zu einem Speicherort, an dem Sie Ihr QMML-Dokument speichern möchten und wählen Sie einen Namen für das Dokument aus.

    Decision Studio speichert ein QMML-Dokument, das die Definitionen der abgeleiteten Felder im Fokus enthält.

Anmerkung:
  • Wenn Sie „Datei>Als QMML exportieren“ wählen, parst Portrait Miner die QMML-Datei automatisch. Damit brauchen Sie den Dateierstellungsbefehl qsqmmledit -parse nicht anzuwenden. Falls ein Fehlers auftritt meldet Portrait Miner die Ableitungen, die nicht geparst werden konnten. In diesem Fall wird eine QMML-Datei erstellt, jedoch ohne die strukturierte Darstellung der problematischen Ableitungen.
  • Wenn Sie „Datei>Als QMML exportieren“ auswählen, enthält das QMML-Dokument einen Regelsatz, der alle abgeleiteten Felder, die im Tabellenansicht markiert wurden oder alle abgeleiteten Felder, wenn keine Felder markiert wurden, auflistet. Unabhängig davon, welche Felder im Regelsatz erscheinen, enthält das QMML-Dokument Definitionen für alle abgeleiteten Felder.
  • Wenn Sie benutzerdefinierte FDL-Funktionen beim Parsen von QMML in Decision Studio einfügen möchten, können Sie allgemein zugängliche Funktionen in einer Datei (oder Dateien) in einem Order, die/der sich in den Optionen der „Ableitungsbibliotheken“ [siehe Ableitungsbibliotheken] befindet, speichern.

Siehe auch

Informationen zur Transaction Measurement Language

Übernehmen eines Modells oder einer Segmentierung von Decision Studio für einen anderen Datensatz

Ein Decision Studio Modell oder Segmentierung für die Verwendung in SAS konvertieren

Ein Decision Studio Modell oder Segmentierung für die Verwendung in SQL konvertieren

Speichern einer Kreuztabelle aus Decision Studio

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

XML in Portrait Miner

Übergeordnetes Thema: Anwenden neuer Modelle und Segmentierungen auf neue Kunden- und Transaktionsdaten


Ein Decision Studio Modell oder Segmentierung für die Verwendung in SAS konvertieren

Sie können Portrait Miner verwenden, um in SAS-Format zu konvertieren. Es wird ein separates SAS-Statement für jede Feldableitung erstellt.

Führen Sie in Portrait Miner einen Rechtsklick auf der QMML-Datei aus, die Sie konvertieren möchten und wählen Sie „In SAS konvertieren“.

Wählen Sie im Dialogfeld „In SAS-Format konvertieren“ die gewünschten Ausgabefelder und einen Speicherort für das SAS-Modell aus.

Anmerkung:
  • Die Konvertierungsfunktion in SAS ist experimentell.
  • Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl „qsqmml2sas“ in Portrait Miner bereitgestellt werden, zuzugreifen.

Siehe auch

Informationen über Portrait Miner-Assistenten

Speichern eines Decision Studio Modells oder einer Segmentierung zur Verwendung als QMML (XML)

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Übergeordnetes Thema: Anwenden neuer Modelle und Segmentierungen auf neue Kunden- und Transaktionsdaten


Ein Decision Studio Modell oder Segmentierung für die Verwendung in SQL konvertieren

Sie können Portrait Miner verwenden, um in SQL-Format zu konvertieren. Es wird eine separate SQL SELECT-Statement für jede Feldableitung erstellt. Portrait Miner unterstützt folgende Datenbanktypen:
  • Oracle
  • Teradata
  • Microsoft SQL Server

Führen Sie in Portrait Miner einen Rechtsklick auf der QMML-Datei aus, die Sie konvertieren möchten und wählen Sie „In SQL konvertieren“.

Wählen Sie im Dialogfeld „QMML in SQL konvertieren“ die Quelltabelle und den Zieldatenbanktyp aus.

Anmerkung:
  • Die Konvertierungsfunktion in SQL ist experimentell.
  • In SQL ist die Auswertung von Integertypen in boolesche nicht erlaubt.
  • Diese Benutzeroberfläche ist eine Möglichkeit, um auf die meisten Funktionen, die über den Dateierstellungsbefehl „qsqmml2sql“ in Portrait Miner bereitgestellt werden, zuzugreifen.

Siehe auch

Informationen über Portrait Miner-Assistenten

Speichern eines Decision Studio Modells oder einer Segmentierung zur Verwendung als QMML (XML)

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Übergeordnetes Thema: Anwenden neuer Modelle und Segmentierungen auf neue Kunden- und Transaktionsdaten


Modellmetadaten

Metadaten sind „Daten über Daten.“ Jedes Modell, das Sie erstellen, sei es in einem Entscheidungsbaum, einer Scorecard oder Clustermodell, hat zugehörige Metadaten.
  • Datum und Uhrzeit der Erstellung des Modells
  • Wer das Modell erstellt hat
  • Der Fokus, auf dem das Modell basiert
  • Die Decision Studio Version, die zur Erstellung des Modells benutzt wurde
  • Kommentare zum Modell (die Sie in Decision Studio editieren können)
  • Parametereinstellungen zum Modellaufbau, die wirksam waren, als das Modell aufgebaut wurde

Wenn Sie ein Modell speichern [siehe Einen Entscheidungsbaum, eine Scorecard oder ein Clustermodell speichern] enthält die Modelldatei diese Metadaten sowie eine Beschreibung des Modells.

Um die übrigen, mit einem Entscheidungsbaum oder einer Scorecard verbundenen Metadaten zu sehen, wählen Sie „Entscheidungsbaum“ (im Entscheidungsbaum-Werkzeug) oder Scorecard (im Scorecard-Werkzeug).

Siehe auch

Einen Modellzusammenfassung erstellen
Übergeordnetes Thema: Anwenden neuer Modelle und Segmentierungen auf neue Kunden- und Transaktionsdaten

Anfügen von Kommentaren zu einem Modell

Sie können Kommentare zu einem Entscheidungsbaum oder einer Scorecard hinzufügen, die hilfreich sein können, wenn Sie Ihre Modelle gemeinsam mit anderen Personen verwenden oder sogar, wenn Sie auf sie zurückgreifen, nachdem Sie eine Weile nicht damit gearbeitet haben.
  • Wählen Sie zum Einfügen von Kommentaren zu einem Entscheidungsbaum im Entscheidungsbaum-Werkzeug „Entscheidungsbaum>Modellkommentare bearbeiten“ aus.
  • Wählen Sie im Scorecard-Werkzeug zum Einfügen von Kommentaren zu einer Scorecard „Scorecard>Modellkommentare bearbeiten“ aus.

In beiden Fällen wird ein Dialogfeld geöffnet, in dem sich drei editierbare Kommentarbereiche befinden, in denen Sie das für das Modell geeignete Beobachtungsfenster mit Angaben, wie Sie das Modell validieren und allen anderen Hinweisen, die Sie geben möchten, aufzeichnen können.

Anmerkung:
  • Modellkommentare erscheinen als Teil des Modellzusammenfassungsbereich [siehe Einen Modellzusammenfassung erstellen] zusammen mit allen Kommentaren, die Sie hinzufügen, wenn Sie den Bericht erstellen.
  • Wenn Sie das Feld „HTML“ markieren, behandelt Decision Studio die balancierten Kennzeichnungspaare, wie z. B. <b>...</b>, als HTML-Markierung und zeigt die Kommentare entsprechend an.


Einen Modellzusammenfassung erstellen

Eine Modellzusammenfassung ist ein Bericht im HTML-Format, der eine detaillierte Beschreibung eines Entscheidungsbaums oder einer Scorecard einschließlich verschiedener Modell-Statistiken und -Profile aller im Modell enthaltenen Felder enthält.

Um eine Modellzusammenfassung in Portrait Miner zu erstellen, klicken Sie mit der rechten Maustaste auf das gespeicherte Modell [siehe Einen Entscheidungsbaum, eine Scorecard oder ein Clustermodell speichern], das Sie untersuchen möchten, und wählen „Modellzusammenfassung erstellen“.

Im Dialogfeld „Entscheidungsbaum-Zusammenfassung“ oder „Scorecard-Zusammenfassung“ können Sie sich einen Bericht für diesen oder einen anderen Fokus anzeigen lassen, und Sie können optional Berichte über alle oder keine Felder erstellen, im Gegensatz zu den im Modell involvierten Feldern.

Anmerkung:
  • Wenn Sie eine Beschreibung für die Modellzusammenfassung vorgeben, erscheint diese zusammen mit allen Modellkommentaren [siehe Anfügen von Kommentaren zu einem Modell], im Bereich „Benutzergelieferte Metadaten“ des Berichts.

  • Sie können eine von vier Optionen für die in der HTML-Ausgabe verwendeten Bildformate auswählen:

    svg nur SVG (Scalable Vector Graphics). SVG bietet die beste Bildqualität und die kleinste Dateigröße, aber die Leser Ihres Berichts müssen über einen Webbrowser mit SVG-Plugin verfügen, um diese Bilder anzeigen und drucken zu können.

    smallpng SVG sowie für den Bildschirm optimierte PNG-Bitmaps (Portable Network Graphics). Aber auch ohne SVG-Plugin sind die Bilder in Ihrem Bericht für die Leser zu sehen (aber die Druckqualität wird relativ schlecht sein).

    largepng SVG sowie für Drucker und Bildschirm optimierte PNG-Bitmaps. Die Leser können Ihren Bericht ansehen oder ausdrucken, ohne das ein SVG-Plugin erforderlich ist (es wird aber mehr Festplattenspeicher benötigt und der Bericht kann langsamer angezeigt werden).

    none Keine Bilder.

  • Sie können weitere Aspekte des Erscheinungsbild von Modell-Schnappschüssen und Profil und Überprüfungen steuern [siehe Festlegen der Portrait Miner-Einstellungen] und zwar im Bereich „Prüfungen und Zusammenfassungen“ im Fenster „Einstellungen“.
  • Damit Portrait Miner Sie per E-Mail benachrichtigen kann, sobald ein Bericht bereitsteht, müssen Sie die Einstellungen „emailaddress“ und „emailserver“ entsprechend festlegen.
  • Standardmäßig speichert Portrait Miner eine Modellzusammenfassung als einzelne .qshtml-Datei mit eingelagerten Bildern. Auch wenn diese Datei in Portrait Miner geöffnet werden kann (per Doppelklick), kann sie nicht direkt außerhalb von Portrait Miner verwendet werden.

    Um eine Webseite zu erstellen, die auf einem Webserver platziert werden kann, klicken Sie mit der rechten Maustaste auf eine .qshtml-Datei und wählen „In Verzeichnis entpacken“. Wählen Sie einen Speicherort, wählen oder erstellen Sie einen Ordner und klicken Sie auf „OK“.

  • Über das Dialogfeld Profil und Überprüfung erstellen kann auf viele Funktionen zugegriffen werden, die über den Dateierstellungsbefehl qsdtsnapshot oder qsscsnapshot in Portrait Miner bereitgestellt werden.

Siehe auch

Informationen über Portrait Miner-Assistenten

Für einen Fokus ein Profil erstellen und prüfen

Festlegen globaler Optionen für grafische Anzeigen

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Übergeordnetes Thema: Anwenden neuer Modelle und Segmentierungen auf neue Kunden- und Transaktionsdaten


Portrait Miner - Optionen

  • Verwenden der Optionen
  • Decision Studio Klasseneinteilungen und Funktionen
  • Decision Studio-Visualisierungstools
  • Entscheidungsbaum-Werkzeug
  • Scorecard Builder
  • Datumsformatierung
  • Dateisuche
  • Dateien
  • Datenbanken
  • Prüfungen und Zusammenfassungen
  • E-Mail-Benachrichtigung
  • Systemtuning und -verwaltung
  • Systemintegration und RealTime


Verwenden der Optionen

  • Festlegen der Portrait Miner-Einstellungen
Übergeordnetes Thema: Portrait Miner - Optionen


Festlegen der Portrait Miner-Einstellungen

Sie können verschiedene Aspekte in Portrait Miner so anpassen, dass Sie Ihren persönlichen Anforderungen entsprechen.
  1. Wählen Sie in Portrait Miner „Bearbeiten>Einstellungen“.
  2. Wählen Sie den relevanten Bereich aus dem linken Bereich des Fensters „Einstellungen“.

    Die in dem ausgewählten Bereich verfügbaren Optionen erscheinen im rechten Bereich.

  3. Machen Sie folgende Änderungen:
    • Markieren oder Demarkieren Sie ein Kontrollkästchen zur Änderung einer Ein-/Aus-Option.
    • Klicken Sie auf die Zelle „Wert“, um eine Zahl oder einen Text zu bearbeiten. (Um Ihre Änderungen zu verwerfen, während Sie eine Zahl oder einen Text bearbeiten, klicken Sie mit der rechten Maustaste in die Zelle und wählen „Abbrechen“.)

      Wenn Auf/Ab-Pfeile in der Zelle erscheinen können Sie diese zur Änderung des numerischen Wertes verwenden.

      Wenn die Zelle ein Dropdown-Menü enthält können Sie eine Option aus dem Menü auswählen.

      Wenn [image] angezeigt wird, können Sie darauf klicken, um nach einer Datei oder einem Ordner zu suchen [siehe Navigieren zum Öffnen oder Speichern einer Datei, Sitzung oder einer Datenbanktabelle].

  4. Klicken Sie auf „Speichern“, um Ihre Änderungen zu speichern.
  5. Klicken Sie auf „Beenden“, um das Fenster „Einstellungen“ zu schließen.
Anmerkung:
  • Die Optionseinstellungen werden nur wirksam, wenn Sie eine Anwendung starten.
  • Wenn Sie den Standardwert für eine Option überschrieben haben, erscheint deren Name im Fenster „Einstellungen“ in Fettschrift.
  • Um eine Einstellungsänderung rückgängig zu machen und die Einstellung auf den Wert zu ändern, der beim Öffnen des Fensters „Einstellungen“ eingetragen war, klicken Sie mit der rechten Maustaste auf die Einstellung und wählen „Rückgängig“.
  • Um den Systemstandard für einen Einstellungswert wiederherzustellen, klicken Sie mit der rechten Maustaste auf die Einstellung und wählen „Standard wiederherstellen“.

    Um die Systemstandardwerte für alle Einstellungen im aktuellen Bereich wiederherzustellen, wählen Sie „Bearbeiten>Abschnitts-Standardnamen wiederherstellen“. Um die Systemstandardwerte für alle Einstellungen wiederherzustellen, wählen Sie „Bearbeiten>Alle Standardeinstellungen wiederherstellen“.

  • Haben Sie einen der Werte der Einstellungen von „Daten schreiben“, „Vollständiger Schreibzugriff“, „Lesen“ oder „Zeit schreiben“ im Fenster „Einstellungen“ auf Europäisch, Amerikanisch oder JMT geändert, werden die anderen drei Einstellungen auf den gleichen Wert geändert.
  • Die Systemstandardwerte für die Einstellungen entsprechen nicht unbedingt der „Fabrikeinstellung“: Ihr Systemadministrator hat eventuell einige Einstellungen überschrieben. In den Beschreibungen einzelner Einstellungswerte werden die Fabrikeinstellungen angegeben.
  • Alle Optionen, die Sie im Fenster „Einstellungen“ festgelegt haben, finden ebenso Anwendung für alle Teile von Portrait Miner.
  • Erscheint eine Warnung über eine nicht erkannte Einstellung, ist die Erklärung dafür höchstwahrscheinlich die, dass eine Ihrer Einstellungen einen Einstellungswert betrifft, der veraltet ist. Sie können die Einstellung als Ganzes entfernen, indem Sie mit der rechten Maustaste auf den Einstellungswert klicken und „Standard wiederherstellen“ auswählen. (Der Eintrag für die Einstellungen erscheint solange weiterhin im Fenster „Einstellungen“, bis Sie speichern und beenden.)
  • Wenn Sie eine Einstellung eines Einstellungswertes nicht ändern können, könnte das daran liegen, dass Ihr Systemadministrator diese „gesperrt“ hat, damit die Benutzer keine Änderungen daran durchführen können.
  • Bestimmte Einstellungen sollen nur von Experten geändert werden und sind daher standardmäßig verborgen. Diese sollten normalerweise nur von einem Administrator von Portrait Miner geändert werden. Wählen Sie zur Ansicht aller Einstellungen die Optionen „Anzeigen>Alle Einstellungen anzeigen“.

Siehe auch

Festlegen globaler Optionen für grafische Anzeigen

Festlegen des Anzeigeformats für numerische und Datumswerte

Übergeordnetes Thema: Verwenden der Optionen


Decision Studio Klasseneinteilungen und Funktionen

  • Auto-End Klassen
  • Auto-End Klassen für gleiche Gesamtmenge
  • Standardklasseneinteilungstyp
  • Standardmäßige Mindestklassengröße (Kategorische Klasseneinteilung)
  • Standardanzahl Klassen (Kategorische Klasseneinteilung)
  • Standardanzahl Klassen (Numerische Klasseneinteilung)
  • Gleiche Breite anzeigen
  • Max. Anzahl Datumsklassen
Übergeordnetes Thema: Portrait Miner - Optionen


Auto-End Klassen

Abschnitt Numerische Klasseneinteilung

Ziel Steuern, ob Decision Studio bei der Klasseneinteilung eines numerischen Felds Randklassen [siehe Randklassen] erzeugt.

Gültige Werte

Wert | Beschreibung
true (Standard) | „Intelligente“ Randklassen für numerische Klasseneinteilung erstellen (aber siehe „Auto-End Klassen für gleiche Gesamtmenge“).
false | Keine Randklassen für numerische Klasseneinteilung erstellen.
Übergeordnetes Thema: Decision Studio Klasseneinteilungen und Funktionen


Auto-End Klassen für gleiche Gesamtmenge

Abschnitt Numerische Klasseneinteilung

Ziel Steuern, ob Decision Studio bei der Klasseneinteilung eines numerischen Felds mit konstanter Klassengröße Randklassen [siehe Randklassen] erzeugt.

Gültige Werte

Wert | Beschreibung
true | Konstante Klassengröße wie konstante Klassenbreite behandeln: Verwenden der Einstellung von Auto-End Klassen.
false (Standard) | Keine Randklassen für konstante Klassengröße erstellen.
Übergeordnetes Thema: Decision Studio Klasseneinteilungen und Funktionen


Standardklasseneinteilungstyp

Abschnitt Numerische Klasseneinteilung

Ziel Festlegen des Standardklasseneinteilungstyps, den Decision Studio für numerisch und Datumsfelder anwendet.

Gültige Werte

Wert | Beschreibung
Gleicher Bereich (Standard) | Gemäß Voreinstellung konstante Klassenbreite erstellen.
Gleiche Gesamtmenge | Gemäß Voreinstellung konstante Klassengröße erstellen.
Anmerkung:

Sie können diese Einstellung pro Fokus überschreiben: Wählen Sie im Klasseneditor „Klasseneinteilung>Standardparameter“ oder klicken Sie in der Symbolleiste auf [image]. Wählen Sie auf der Registerkarte „Nicht-kategorisch“ aus dem Menü „Klassentyp“.

Übergeordnetes Thema: Decision Studio Klasseneinteilungen und Funktionen


Standardmäßige Mindestklassengröße (Kategorische Klasseneinteilung)

Abschnitt Kategorische Klasseneinteilung

Ziel Festlegen der Mindestklassengröße für ein kategorisches Feld im Decision Studio.

Gültige Werte Eine nicht negative, ganze Zahl, Standardwert 0

Wenn Decision Studio eine kategorische Klasseneinteilung für ein Feld erstellt, werden nur Klassen für Werte erstellt, die mindestens in der angegebenen Anzahl von Datensätzen vorkommen. Andere Werte werden nicht klassifiziert.

Anmerkung: Sie können diese Einstellung pro Fokus überschreiben: Wählen Sie im Klasseneditor „Klasseneinteilung>Standardparameter“ oder klicken Sie in der Symbolleiste auf [image]. Legen Sie auf der Registerkarte „Kategorisch“ die „Min. Kategoriengröße“ fest.

Siehe auch

Standardanzahl Klassen (Kategorische Klasseneinteilung)
Übergeordnetes Thema: Decision Studio Klasseneinteilungen und Funktionen


Standardanzahl Klassen (Kategorische Klasseneinteilung)

Abschnitt Kategorische Klasseneinteilung

Ziel Festlegen der Standardanzahl Klassen für ein kategorisches Feld im Decision Studio.

Gültige Werte Eine nicht negative, ganze Zahl, Standardwert 250

Wenn Decision Studio eine kategorische Klasseneinteilung für ein Feld erstellt, werden nur Klassen für maximal die angegebenen Anzahl von Werten erstellt (erst Auswahl der häufigsten Werte). Andere Werte werden nicht klassifiziert.

Anmerkung: Sie können diese Einstellung pro Fokus überschreiben: Wählen Sie im Klasseneditor „Klasseneinteilung>Standardparameter“ oder klicken Sie in der Symbolleiste auf [image]. Legen Sie auf der Registerkarte „Kategorisch“ die „Max. Anzahl Kategorien“ fest.

Siehe auch

Standardmäßige Mindestklassengröße (Kategorische Klasseneinteilung)
Übergeordnetes Thema: Decision Studio Klasseneinteilungen und Funktionen


Standardanzahl Klassen (Numerische Klasseneinteilung)

Abschnitt Numerische Klasseneinteilung

Ziel Festlegen der Standardzielanzahl Klassen für numerische oder Datums-Klasseneinteilung im Decision Studio.

Gültige Werte Eine nicht negative, ganze Zahl, Standardwert 10

Anmerkung:
  • Die Zielanzahl Klassen schließt Randklassen [siehe Randklassen] und Klassen für Null [siehe Der Nullwert] sowie unklassifizierte Werte aus.
  • Sie können diese Einstellung pro Fokus überschreiben: Wählen Sie im Klasseneditor „Klasseneinteilung>Standardparameter“ oder klicken Sie in der Symbolleiste auf [image]. Legen Sie auf der Registerkarte „Nicht-kategorisch“ die „Interne Klassen als Ziel“ fest.
Übergeordnetes Thema: Decision Studio Klasseneinteilungen und Funktionen


Gleiche Breite anzeigen

Abschnitt Numerische Klasseneinteilung

Ziel Festlegen des Standardanzeigemodus, den Decision Studio für numerische und Datumsklassen anwendet: Histogramm oder Balkendiagramm [siehe Histogramm- und Balkendiagramm-Optionen].

Gültige Werte

Wert | Beschreibung
true (Standard) | Anzeigemodus Balkendiagramm verwenden.
false | Anzeigemodus Histogramm verwenden.
Anmerkung:
  • Der Anzeigemodus für eine Klasseneinteilung beeinflusst auch die Diagrammansichten in der Profilansicht und der Kreuzverteilungsansicht.
  • Sie können diese Einstellung pro Fokus überschreiben: Wählen Sie im Klasseneditor „Klasseneinteilung>Standardparameter“ oder klicken Sie in der Symbolleiste auf [image]. Wählen Sie auf der Registerkarte „Nicht-kategorisch“ aus dem Menü „Diagramme“.
Übergeordnetes Thema: Decision Studio Klasseneinteilungen und Funktionen


Max. Anzahl Datumsklassen

Abschnitt Datumsklasseneinteilung

Ziel Festlegen der Maximalanzahl Klassen für ein Datumsfeld im Decision Studio (Klassenbreite ist entsprechend einstellbar). Dadurch wird beispielsweise eine versehentliche Klasseneinteilung eines Bereichs von Jahrhunderten nach Sekunden vermieden.

Gültige Werte Eine ganze Zahl zwischen 1 und 1.000, Dies ist in der INI-Datei nicht standardmäßig 100

Übergeordnetes Thema: Decision Studio Klasseneinteilungen und Funktionen


Decision Studio-Visualisierungstools

  • Maximale Größe
  • Zielfunktion
Übergeordnetes Thema: Portrait Miner - Optionen


Maximale Größe

Abschnitt Aggregation

Ziel Einstellen der Größe der größten Kreuztabelle [siehe Kreuztabellen als Basis für die Segmentierung und Visualisierung von Daten],die Decision Studio erstellen kann.

Gültige Werte Eine nicht negative, ganze Zahl, Standardwert 100.000

Anmerkung: Um die Größe einer Kreuztabelle in diesem Sinne zu bestimmen, berechnen Sie

für eine Kreuztabelle mit N Aufschlüsselungsfelder, mit [image], [image], ..., bzw. Klassen (einschließlich ggf. Randklassen [siehe Randklassen], Klassen für Nullwerte [siehe Der Nullwert] und Klassen für nicht definierte Werte). Eine Kreuztabelle mit Aufschlüsselungsfeldern „Income“ und „Age“, klassifiziert in 10 bzw. 8 interne Klassen, hat beispielsweise die Größe [image].
Übergeordnetes Thema: Decision Studio-Visualisierungstools


Zielfunktion

Abschnitt Aggregation

Ziel Legen Sie die Aggregationsfunktion fest [siehe Aggregationsfunktionen für Kreuztabellen], die Decision Studio standardmäßig auf eine Zielvariable anwendet, wenn Sie eine Kreuztabellenansicht [siehe Erstellen einer textuellen Kreuztabellenansicht], ein Profildiagramm [siehe Erstellen einer Gruppe von Profildiagrammen mit einer Variablen], Kreuztabellendiagramm [siehe Erstellen eines Kreuzverteilungsdiagramms mit mehreren Variablen] oder ein Kartendiagramm [siehe Um ein Diagramm auf einer Karte zu erstellen] erstellen. (Für Diagramme verknüpft Decision Studio das Ergebnis mit der Blockfarbe.)

Gültige Werte

Wert | Beschreibung
any | Anzeigen eines beliebigen Wertes [siehe any] der Zielvariable.
countnonnull | Anzahl der Nicht-Null-Datensätze [siehe countnonnull/countnonnulls] für die Zielvariable anzeigen.
countnull | Anzahl der Null-Datensätze [siehe countnull/countnulls] für die Zielvariable anzeigen.
countunique | Anzahl der Einzelwerte [siehe countunique] für die Zielvariable anzeigen, möglicherweise inklusive des Null-Wertes.
countuniquenonnull | Anzahl der Einzelwerte [siehe countuniquenonnull] für die Zielvariable anzeigen, außer dem Null-Wert.
first | Den Wert der Zielvariable für den ersten Datensatz [siehe first] anzeigen.
last | Den Wert der Zielvariable für den letzten Datensatz [siehe last] anzeigen.
Max | Anzeigen des Maximalwerts [siehe max (ein Argument)] der Zielvariable.
mean (Standard) | Anzeigen des Mittelwerts [siehe mean (ein Argument)] der Zielvariable.
median | Anzeigen des Medians (mittlerer Wert) [siehe median] der Zielvariable.
min | Anzeigen des Minimalwerts [siehe min (ein Argument)] der Zielvariable.
Modus | Anzeigen des Modus (häufigster Wert) [siehe Modus] der Zielvariable.
moderatio | Anzeigen des Verhältnisses der Datensätze, die den häufigsten Wert [siehe moderatio] der Zielvariable enthalten.
percentagerate | Anzeigen des Prozentsatzes der Datensätze, die den Wert 1 [siehe percentagerate] für die (binäre) Zielvariable enthalten.
significance | Anzeigen der „Signifikanz“ des Unterschiedes zwischen dem Mittelwert der Zielvariable für das Segment und jenem für den gesamten Datensatz.
stdev | Anzeigen der Standardabweichung der Werte [siehe stdev] in der Zielvariable.
sum | Anzeigen der Summe der Werte [siehe sum (ein Argument)] in der Zielvariable.
Abweichung | Anzeigen der Abweichung der Werte [siehe Abweichung] in der Zielvariable.
Übergeordnetes Thema: Decision Studio-Visualisierungstools


Entscheidungsbaum-Werkzeug

  • infinite Uplift Ersatzwert
Übergeordnetes Thema: Portrait Miner - Optionen


infinite Uplift Ersatzwert

Abschnitt Entscheidungsbaum-Werkzeug

Ziel Der Uplift-Wert für ein Segment in einem binären Uplift x Baum kann unendlich sein. Dieser Wert wird herangezogen, um den unendlichen Uplift darzustellen, wenn er berichtet wird (Textansichten, Ergebnisfelder usw.).

Gültige Werte Eine nicht-negative, reelle Zahl, Standardwert

Übergeordnetes Thema: Entscheidungsbaum-Werkzeug


Scorecard Builder

  • Akzeptanzrate
  • Attributtransformation
  • Misserfolgsrate
  • Abschaltung
  • verdoppelte Odds
  • gleiche Odds
  • ursprüngliche Karte
  • Ziel umkehren
  • Iterationen
  • Modell
  • Anzahl der Dezimalstellen der Präzision
  • eine Gewichtung pro Charakteristik
  • Qualitätsgröße
  • läuft
  • Auflöser
  • Toleranz
Übergeordnetes Thema: Portrait Miner - Optionen


Akzeptanzrate

Abschnitt Scorecard-Werkzeug

Ziel Festlegen des ersten Schwellenwertes für die Akzeptanzrate [siehe Mit Entscheidungsbäumen, Scorecards, Clustermodellen und abstrakten Kreuztabellen verknüpfte Felder] (oder Zielrate), die der Scorecard-Werkzeug verwendet.

Gültige Werte Eine reelle Zahl zwischen 0 und 1, Standardwert 0,5

Anmerkung: Sie sollten normalerweise nicht mehr als eine Abschaltung setzen, Abschaltung, bad rate und accept rate, da die erste gesetzte (in der hier angegebenen Reihenfolge), immer vorrangig vor allen anderen ist.
Übergeordnetes Thema: Scorecard Builder


Attributtransformation

Abschnitt Scorecard-Werkzeug

Ziel Steuern, wie der Scorecard-Assistent Werte für individuelle Klassen in einem Eine-Gewichtung-pro-Feld-Modell [siehe eine Gewichtung pro Charakteristik] umformt.

Gültige Werte

Wert | Beschreibung
log odds (default) | Log der Odds verwenden (die „Weight of Evidence“).
Mittelwert | Mittelwert verwenden.
odds | Odds verwenden.
Log Mittelwert | Logarithmus des Mittelwerts verwenden.
Anmerkung:

Sie können die Einstellung dieser Option überschreiben, indem Sie das Formular [siehe So ändern Sie das Formular einer Scorecard] im Dialogfeld Auto-End Klassen für gleiche Gesamtmenge„Scorecard-Formular“ ändern.

Übergeordnetes Thema: Scorecard Builder


Misserfolgsrate

Abschnitt Scorecard-Werkzeug

Ziel Festlegen des ersten Schwellenwertes für die Misserfolgsrate [siehe Mit Entscheidungsbäumen, Scorecards, Clustermodellen und abstrakten Kreuztabellen verknüpfte Felder] (oder Trefferquote), die der Scorecard-Werkzeug verwendet.

Gültige Werte Eine reelle Zahl zwischen 0 und 1, Standardwert 0,5

Anmerkung: Sie sollten normalerweise nicht mehr als eine „Abschaltung“ setzen, „bad rate“ und accept rate, da die erste gesetzte (in der hier angegebenen Reihenfolge), immer vorrangig vor allen anderen ist.
Übergeordnetes Thema: Scorecard Builder


Abschaltung

Abschnitt Scorecard-Werkzeug

Ziel Festlegen des ersten Abschaltungsergebnisses [siehe Mit Entscheidungsbäumen, Scorecards, Clustermodellen und abstrakten Kreuztabellen verknüpfte Felder], das der Scorecard-Werkzeug verwendet.

Gültige Werte Eine reelle Zahl, Standardwert 500

Anmerkung: Sie sollten normalerweise nicht mehr als eine Abschaltung setzen, bad rate und accept rate, da die erste gesetzte (in der hier angegebenen Reihenfolge), immer vorrangig vor allen anderen ist.
Übergeordnetes Thema: Scorecard Builder


verdoppelte Odds

Abschnitt Scorecard-Werkzeug

Ziel Festlegen des anfänglichen Verdopplungsfaktors [siehe Mit Entscheidungsbäumen, Scorecards, Clustermodellen und abstrakten Kreuztabellen verknüpfte Felder], den der Scorecard-Assistent für die Beziehung zwischen Score und Odds verwendet.

Gültige Werte Eine positive, reelle Zahl, Standardwert 20

Siehe auch

gleiche Odds
Übergeordnetes Thema: Scorecard Builder


gleiche Odds

Abschnitt Scorecard-Werkzeug

Ziel Festlegen des anfänglichen Even-Odds-Punkts [siehe Mit Entscheidungsbäumen, Scorecards, Clustermodellen und abstrakten Kreuztabellen verknüpfte Felder], den der Scorecard-Assistent für die Beziehung zwischen Score und Odds verwendet.

Gültige Werte Eine positive, reelle Zahl, Standardwert 500

Siehe auch

verdoppelte Odds
Übergeordnetes Thema: Scorecard Builder


ursprüngliche Karte

Abschnitt Scorecard-Werkzeug

Ziel Festlegen der ursprünglichen Scorecard, die der Scorecard-Assistent bei der Anwendung eines iterativen Auflösers nutzt.

Gültige Werte

Wert | Beschreibung
linear (Standard) | Lineare Regression (Diskriminanten Analyse) zur Erzeugung der ursprünglichen Scorecard verwenden.
Fest | Eine ursprüngliche Scorecard mit gleichen Gewichtungen für alle Variablen verwenden.
aktuell | Aktuelle Scorecard als ursprüngliche Scorecard verwenden.
Zufällig | Eine quasi-zufällige [siehe Informationen zu Zufallszahlenfunktionen in FDL] generierte ursprüngliche Scorecard verwenden.
Anmerkung:

Sie können die Einstellung dieser Option überschreiben, indem Sie das Formular [siehe So ändern Sie den Auflöser, der beim Aufbau einer Scorecard verwendet wird] im Dialogfeld „Scorecard-Auflöser“ ändern.

Übergeordnetes Thema: Scorecard Builder


Ziel umkehren

Abschnitt Scorecard-Werkzeug

Ziel Ändern der 1/0-Auslegung des Ziels.

Gültige Werte

Wert | Beschreibung
true | Datensätze mit 0 im Ziel als Standardmäßige, Abwandernde, Antwortende auslegen.
false (Standard) | Datensätze mit 1 im Ziel als Standardmäßige, Abwandernde, Antwortende auslegen.
Anmerkung:

Sie können die Einstellung dieser Option überschreiben, indem Sie die Menüoption „Scorecard>Umgekehrter Zielwert“ verwenden.

Übergeordnetes Thema: Scorecard Builder


Iterationen

Abschnitt Scorecard-Werkzeug

Ziel Festlegen der maximalen Anzahl Iterationen, die ein iterativer Scorecard-Auflöser nutzt.

Gültige Werte Eine positive, ganze Zahl, Standardwert 1000

Anmerkung: Sie können die Einstellung dieser Option überschreiben, indem Sie die Maximalanzahl der Iterationen [siehe So ändern Sie den Auflöser, der beim Aufbau einer Scorecard verwendet wird] im Dialogfeld „Scorecard-Auflöser“ ändern.

Siehe auch

Toleranz
Übergeordnetes Thema: Scorecard Builder


Modell

Abschnitt Scorecard-Werkzeug

Ziel Steuern des Standardmodelltyps .

Gültige Werte

Wert | Beschreibung
Risiko (default) | Risikomodell erstellen.
Antwort | Antwortmodell erstellen.
Abwanderung | Abwanderungsmodell erstellen.
Zufriedenheit | Zufriedenheitsmodell erstellen.
Unzufriedenheit | Unzufriedenheitsmodell erstellen.
Übergeordnetes Thema: Scorecard Builder


Anzahl der Dezimalstellen der Präzision

Abschnitt Scorecard-Werkzeug

Ziel Steuern der Anzahl der Dezimalstellen der Präzision, bis zu der der Scorecard-Assistent Annäherungsberechnungen durchführt, wie beispielsweise der Gini-Wert für eine Scorecard.

Gültige Werte Ein Integer zwischen 1 und 8, Standardwert 3

Anmerkung: Sie können die Einstellung dieser Option überschreiben, indem Sie „Scorecard>Auflöser“ im Scorecard-Assistent wählen und die Anzahl der Dezimalstellen der Präzision ändern.
Übergeordnetes Thema: Scorecard Builder


eine Gewichtung pro Charakteristik

Abschnitt Scorecard-Werkzeug

Ziel Steuern, ob der Scorecard-Assistent eine Gewichtung pro Feld oder eine Gewichtung pro Klasse verwendet.

Gültige Werte

Wert | Beschreibung
true (Standard) | Eine Gewichtung pro Feld verwenden.
false | Eine Gewichtung pro Klasse verwenden.
Anmerkung:

Sie können die Einstellung dieser Option überschreiben, indem Sie das Formular [siehe So ändern Sie das Formular einer Scorecard] im Dialogfeld Auto-End Klassen für gleiche Gesamtmenge„Scorecard-Formular“ ändern.

Siehe auch

Attributtransformation
Übergeordnetes Thema: Scorecard Builder


Qualitätsgröße

Abschnitt Scorecard-Werkzeug

Ziel Festlegen der Qualitätsgröße, die der Scorecard-Assistent verwendet.

Gültige Werte

Wert | Beschreibung
linear (Standard) | Lineare Regression (Diskriminanten Analyse) verwenden.
Logistische | Logistische Regression verwenden.
probit | Probit-Regression verwenden.
Anmerkung:

Sie können die Einstellung dieser Option überschreiben, indem Sie eine Qualitätsgröße [siehe So ändern Sie die Qualitätsgröße, die beim Aufbau einer Scorecard verwendet wird] im Menü „Scorecard>Qualitätsgröße“ wählen.

Übergeordnetes Thema: Scorecard Builder


läuft

Abschnitt Scorecard-Werkzeug

Ziel Festlegen, wie oft der Scorecard-Assistent beim Optimieren einer Scorecard eine Methode anwendet.

Der Scorecard-Assistent nutzt bei allen Läufen den Durchschnittswert.

Gültige Werte Eine positive, ganze Zahl, Standardwert 1

Anmerkung: Sie können die Einstellung dieser Option überschreiben, indem Sie die Anzahl der Läufe [siehe So ändern Sie den Auflöser, der beim Aufbau einer Scorecard verwendet wird] im Dialogfeld „Scorecard-Auflöser“ ändern.
Übergeordnetes Thema: Scorecard Builder


Auflöser

Abschnitt Scorecard-Werkzeug

Ziel Festlegen der Auflösungsmethode, die der Scorecard-Assistent verwendet.

Gültige Werte

Wert | Beschreibung
direct (Default) | Direkte Matrixumkehr zur Durchführung einer linearen Regression verwenden.
conjugate gradient | Methode Konjugierter Gradient verwenden.
Levenberg-Marquardt | Levenberg-Marquardt-Methode verwenden.
powell | Powell-Methode verwenden.
quasi newton | Quasi-Newton-Methode verwenden.
simplex | Simplex-Methode verwenden.
Anmerkung:

Sie können die Einstellung dieser Option überschreiben (für Qualitätsgrößen außer linearer Regression), indem Sie die Methode[siehe So ändern Sie den Auflöser, der beim Aufbau einer Scorecard verwendet wird] im Dialogfeld „Scorecard-Auflöser“ ändern.

Übergeordnetes Thema: Scorecard Builder


Toleranz

Abschnitt Scorecard-Werkzeug

Ziel Festlegen einer Stoppbedingung für einen iterativen Scorecard-Auflöser, im Sinne fraktionaler Toleranz.

Gültige Werte Eine reelle Zahl, Standardwert 0,0001

Wenn der Wert dieser Option [image] ist, stoppt der Scorecard-Assistent einen iterativen Auflöser, wenn aufeinanderfolgende Werte [image] und [image] der Qualitätsgröße Folgendes erfüllen:

Anmerkung: Sie können die Einstellung dieser Option überschreiben, indem Sie die fraktionale Toleranz [siehe So ändern Sie den Auflöser, der beim Aufbau einer Scorecard verwendet wird] im Dialogfeld „Scorecard-Auflöser“ ändern.

Siehe auch

Iterationen
Übergeordnetes Thema: Scorecard Builder


Datumsformatierung

  • Datumsformate
  • Datum schreiben
  • Standardtagindex für unvollständige Daten
  • Standardmonatsindex für unvollständige Daten
  • Vollständiger Schreibzugriff
  • maximum future for two-digit years
  • read
  • Zeit schreiben
  • two-digit fixed pivot year
  • im Gebietsschema-spezifischen Format schreiben
  • x ordering
Übergeordnetes Thema: Portrait Miner - Optionen


Datumsformate

Wenn Sie mit Dateien und FDL-Ausdrücken arbeiten, können sie angeben, wie Portrait Miner das Datum und Uhrzeiten interpretieren und exportieren soll. Entweder als standardmäßiges Datumsformat, [siehe Standardmäßige Datumsformate] oder als kundenspezifisches Datumsformat [siehe Benutzerdefinierte Datumsformate].

Siehe auch

Festlegen des Anzeigeformats für numerische und Datumswerte
Übergeordnetes Thema: Datumsformatierung

Standardmäßige Datumsformate

Name | Datumsformat
Amerikanisch | MM/TT/JJJJ:hh:mm:ss, z. B. 12/31/2000:13:36:59
Europäisch | TT/MM/JJJJ:hh:mm:ss, z. B. 31/12/2000:13:36:59
JMT | JJJJ/MM/TT/:hh:mm:ss, z. B. 2000/12/31:13:36:59
Anmerkung:
  • Alle drei standardmäßigen Datumsformate können auch für ein Datum ohne Uhrzeitkomponente oder nur aus Uhrzeit bestehend angewendet werden („Datum“ nur mit einer Zeitkomponente). Bei Nur-Datum- und Nur-Zeit-Angaben werden die Uhrzeit und das Datum entsprechend unterdrückt.
  • Amerikanische, Europäische und Jahr, Monat, Tag-Formate füllen ein Datum in den Formen MMTTJJJJ, TTMMJJJJ und JJJJMMTT aus (Nur für Eingabe).

Benutzerdefinierte Datumsformate

Sie können ein angepasstes Datumsformat mithilfe besonderer Zeichencodes festlegen, indem diese mit dem Prozentzeichen % beginnen:
Format | Komponente des formatierten Datums
%% | Das Prozentzeichen selber: "%"
%? | kann jedem einzelnen Zeichen zugeordnet werden
%* | kann jeder Anzahl von Zeichen zugeordnet werden, z. B., um nachfolgende Zeichen zu ignorieren, verwenden Sie %Y/%m/%d%*
%a | Der Name des Wochentages in abgekürzter Form („Mon,“ „Die,“ ..., „Son“)
%a | Der Name des Wochentages ausgeschrieben („Montag,“ „Dienstag,“ ..., „Sonntag“)
%b | Der Name des Monats in abgekürzter Form („Jan,“ „Feb,“ ..., „Dez“)
%b | Der Name des Monats ausgeschrieben („Januar,“ „Februar,“ ..., „Dezember“)
%c | (Eingabe) Gleichwertig mit „%a %b %e %T %Y“ (Ausgabe) Datum und Uhrzeit in der standardmäßigen Darstellung für den aktuellen Ort
%c | Gleichwertig mit „%a %b %e %T %Z %Y“
%d | Der Tag des Monats mit zwei Stellen („01,“ „02,“ ..., „31“)
%d | Gleichwertig mit „%m/%d/%y“
%e | Der Tag des Monats mit einem führenden Leerzeichen („ 1,“ „ 2,“ ..., „31“)
%h | Gleichwertig mit „%b“
%h | Die Stunde des Tages im 24-Stundenformat („00,“ „02,“ ..., „23“)
%I | Die Stunde des Tages im 12-Stundenformat („01,“ „02,“ ..., „12“)
%j | Der Tag des Jahres mit drei Stellen (Julianisches Datum) („001,“ „002,“ ..., „366“)
%m | Die Nummer des Monats mit zwei Stellen („01,“ „02,“ ..., „12“)
%m | Der Tag des Monats mit zwei Stellen („00,“ „01,“ ..., „59“)
%p | „AM“ oder „PM,“ entsprechend der Tageszeit
%r | Gleichwertig mit „%I:%M:%S %p“
%r | Gleichwertig mit „%H:%M“
%S | Der Tag des Monats mit zwei Stellen („00,“ „01,“ ..., „61“)
%T | Gleichwertig mit „%H:%M:%S“
%x | Das Datum formatiert entsprechend der Einstellung x ordering
%x | Gleichwertig mit „%x“
%y | Der Tag des Monats mit zwei Stellen („00,“ „01,“ ..., „99“)
%y | Das Jahr mit vier Stellen
%Z | Der Name der aktuellen Zeitzone
Anmerkung:
  • Um „%D“ oder „%y,“ zu verwenden, müssen Sie entweder ein Pivot-Jahr oder ein maximales zukünftiges Jahr (aber nicht beides) angeben.

    Wenn Sie ein Pivot gleich einem gültigen Jahr Y setzen, interpretiert Portrait Miner die zweistelligen Jahre als Jahre zwischen Y - 99 und Y. Wenn Sie beispielsweise die Option auf 2077 setzen, interpretiert Portrait Miner die zweistelligen Jahre 76, 77 und 78 entsprechend als 2076, 2077 und 1978.

    Wenn Sie ein maximales Jahr in der Zukunft gleich einem positiven Wert n setzen und das aktuelle Jahr ist Y, interpretiert Portrait Miner alle zweistelligen Jahre als Jahre zwischen Y + n - 99 und Y + n. Wenn Sie beispielsweise die Option auf 50 setzen und das aktuelle Jahr 2002 ist, interpretiert Portrait Miner die zweistelligen Jahre 51, 52 und 53 entsprechend als 2051, 2052 und 1953.

  • Wenn Sie die Einstellung „im Gebietsschema-spezifischen Format schreiben“ festlegen, könnten die Codes „%a,“ „%A,“ „%b,“ „%B,“ „%C,“ „%p,“ „%x,“ „%X,“ und „%Z“ unterschiedliche Ergebnisse bei der Anzeige von Daten erzeugen (aber nicht bei deren Interpretierung).
  • Neben / können alle anderen Zeichen (mit Ausnahme der Feldtrennzeichen oder Nullmarkierungen) als Trennzeichen innerhalb des Datums verwendet werden.
  • Bei einem Datumsformat, bei dem eine bestimmte Datums- oder Monatskomponente fehlt, können Sie einen Standardwert mithilfe dem „Tag“- oder „Monat“-Qualifizierer festlegen.
  • Diese besonderen Zeichencodes stammen aus der standardmäßigen C-Bibliotheksfunktion strftime.

Beispiel R–1: Datumsformatierungsstrings

Datumsbeispiel | Datumsformatstring
02/04/2003 27/10/1940 | Europäisch
04/02/2003 10/27/1940 | Amerikanisch
2003/04/02 1940/10/27 | JMT
02-Apr-2003 27-Okt-1940 | %d-%b-%Y
02 Apr 2003 27 Okt 1940 | ((%d %b %Y))
2003-04-02 13:25 1940-10-27 08:23 | ((%Y-%m-%d %H:%M))
2003-04-02:13:25 1940-10-27:08:23 | %Y-%m-%d:%H:%M
2 Apr 2003 27 Okt 1940 | ((%e %b %Y))
April 2, 2003 | ((%B %e, %Y))
02/04/2003 13:25 27/10/1940 08:23 | ((%d/%m/%Y %H:%M))
2003-04-02 13:25:15000000 | ((%Y-%m-%d %H:%M:%S%*))
April 02, 2003 | ((%B %d, %Y))
2-Apr-2003 27-Okt-1940 | %e-%b-%Y
02/04/03 27/10/40 | (Europäisches Pivot=2010)
04/02/03 10/27/40 | (Amerikanisches Pivot=2010)
03/04/02 40/10/27 | (JMT-Pivot=2010)
02-Apr-03 27-Okt-40 | (%d-%b-%y pivot=2010)
April 02, 03 | ((%B %d, %y) pivot=2010)
2-Apr-03 27-Oct-03 | (%e-%b-%y pivot=2010)
April 2, 03 | ((%B %e, %y) pivot=2010)
01:25 PM 08:23 AM | ((%I:%M %p))
13:25 08:23 | %H:%M

Siehe auch

Standardtagindex für unvollständige Daten

Standardmonatsindex für unvollständige Daten

maximum future for two-digit years

two-digit fixed pivot year


Datum schreiben

Abschnitt Datumsformat

Ziel Festlegen des in Dateien und FDL-Ausdrücken zu verwendenden Formats für das Schreiben von Daten, die keine Zeitkomponente aufweisen.

Gültige Werte

Wert | Beschreibung
Amerikanisch | Schreibt Datumsangaben als MM/TT/JJJJ.
Europäisch (Standard) | Schreibt Datumsangaben als TT/MM/JJJJ.
JMT | Schreibt Datumsangaben als JJJJ/MM/TT.
Ein Datumsformat-String [siehe Benutzerdefinierte Datumsformate] | Schreibt Datumsangaben im benutzerdefinierten Format.
Anmerkung:

Sie sollten normalerweise die Einstellungen „Daten schreiben“, „Vollständiger Schreibzugriff“ und „Zeit schreiben“ auf den gleichen Wert festlegen.

Siehe auch

read
Übergeordnetes Thema: Datumsformatierung


Standardtagindex für unvollständige Daten

Abschnitt Datumsformat

Ziel Festlegen vom Tag des Monats für Daten in Dateien und FDL-Ausdrücken, die keine bestimmte Tageskomponente aufweisen.

Gültige Werte Ein Integer zwischen 1 und 31 einschließlich, standardmäßig 1

Anmerkung:
  • Diese Einstellung wird angewendet, wenn Portrait Miner Text entsprechend eines Datumsformats in ein Datum konvertiert [siehe Benutzerdefinierte Datumsformate], wie „%Y%M.“
  • Für eine individuelle Datei oder ein individuelles Feld können Sie die Einstellung übergehen, indem Sie das Kennwort „day“ verwenden.

Siehe auch

Standardmonatsindex für unvollständige Daten
Übergeordnetes Thema: Datumsformatierung


Standardmonatsindex für unvollständige Daten

Abschnitt Datumsformat

Ziel Festlegen vom Monat vom Jahr für Daten in Dateien und FDL-Ausdrücken, die keine bestimmte Tageskomponente aufweisen.

Gültige Werte Ein Integer zwischen 1 und 12 einschließlich, standardmäßig 1

Anmerkung:
  • Diese Einstellung wird angewendet, wenn Portrait Miner Text entsprechend eines Datumsformats in ein Datum konvertiert [siehe Benutzerdefinierte Datumsformate], wie „%Y.“
  • Für eine individuelle Datei oder ein individuelles Feld können Sie die Einstellung übergehen, indem Sie das Kennwort „month“ verwenden.

Siehe auch

Standardtagindex für unvollständige Daten
Übergeordnetes Thema: Datumsformatierung


Vollständiger Schreibzugriff

Abschnitt Datumsformat

Ziel Festlegen des in Dateien und FDL-Ausdrücken zu verwendenden Formats für das Schreiben von Daten, die eine Zeitkomponente aufweisen.

Gültige Werte

Wert | Beschreibung
Amerikanisch | Formatiert Datum als MM/TT/JJJJ:hh:mm:ss.
Europäisch (Standard) | Formatiert Datum als TT/MM/JJJJ:hh:mm:ss.
JMT | Formatiert Datum als JJJJ/MM/TT:hh:mm:ss.
Ein Datumsformat-String [siehe Benutzerdefinierte Datumsformate] | Formatiert Datumsangaben im benutzerdefinierten Format.
Anmerkung:

Sie sollten normalerweise die Einstellungen „Vollständiger Schreibzugriff“, „Datum speichern“ und „Uhrzeit schreiben“ auf den gleichen Wert festlegen.

Siehe auch

read
Übergeordnetes Thema: Datumsformatierung


maximum future for two-digit years

Abschnitt Datumsformat

Ziel Steuern der Interpretation von zweistelligen Jahresangaben in Dateien und FDL-Begriffen, indem Sie ein Pivot-Jahr abhängig vom aktuellen Jahr verwenden.

Gültige Werte Ein Integer zwischen 0 und 99 einschließlich, oder (standardmäßig) -1

Anmerkung:
  • Diese Einstellung wird auf die Datumsformat-Codes „%D“ und „%y“ angewendet [siehe Benutzerdefinierte Datumsformate].
  • Für eine individuelle Datei oder ein individuelles Feld können Sie die Einstellung übergehen, indem Sie das Kennwort „future“ verwenden.

Siehe auch

two-digit fixed pivot year
Übergeordnetes Thema: Datumsformatierung


read

Abschnitt Datumsformat

Ziel Festlegen des Standardformats für die Interpretation von Datumsangaben in Dateien und FDL-Ausdrücken

Gültige Werte

Wert | Beschreibung
Amerikanisch | Interpretiert ein Datum als MM/TT/JJJJ:hh:mm:ss.
Europäisch (Standard) | Interpretiert ein Datum als TT/MM/JJJJ:hh:mm:ss.
JMT | Interpretiert ein Datum als JJJJ/MM/TT:hh:mm:ss.
Ein Datumsformat-String [siehe Benutzerdefinierte Datumsformate] | Datumsangaben im benutzerdefinierten Format interpretieren.
Anmerkung:

Wenn Portrait Miner alle Datumsangaben aus einer Datei liest, verwendet es das durch diese Einstellung vorgegebene Format, es sei denn, Sie fügen eine ausdrückliche Formatvorgabe in die Dateibeschreibung ein.

Siehe auch

Datum schreiben

Vollständiger Schreibzugriff

Zeit schreiben

Übergeordnetes Thema: Datumsformatierung


Zeit schreiben

Abschnitt Datumsformat

Ziel Festlegen des in Dateien und FDL-Begriffen zu verwendenden Formats für das Schreiben von Zeitangaben (das heißt, Datum nur mit Stunden-, Minuten- und Sekundenkomponenten).

Gültige Werte

Wert | Beschreibung
Amerikanisch | Schreibt Uhrzeiten als hh:mm:ss.
Europäisch (Standard) | Schreibt Uhrzeiten als hh:mm:ss.
JMT | Schreibt Uhrzeiten als hh:mm:ss.
Ein Datumsformat-String [siehe Benutzerdefinierte Datumsformate] | Schreibt Uhrzeit im benutzerdefinierten Format.
Anmerkung:

Sie sollten normalerweise die Einstellungen „Uhrzeit schreiben“, „Datum schreiben“ und „Vollständiger Schreibzugriff“ auf den gleichen Wert festlegen.

Siehe auch

read
Übergeordnetes Thema: Datumsformatierung


two-digit fixed pivot year

Abschnitt Datumsformat

Ziel Steuern der Interpretation von zweistelligen Jahresangaben in Dateien und FDL-Ausdrücken, indem Sie ein festgelegtes Pivot-Jahr verwenden.

Gültige Werte Ein positives Integer (ein Jahr) oder (standardmäßig) -1

Anmerkung:
  • Diese Einstellung wird auf die Datumsformat-Codes „%D“ und „%y“ angewendet [siehe Benutzerdefinierte Datumsformate].
  • Für eine individuelle Datei oder ein individuelles Feld können Sie die Einstellung übergehen, indem Sie das Kennwort „pivot“ verwenden.

Siehe auch

maximum future for two-digit years
Übergeordnetes Thema: Datumsformatierung


im Gebietsschema-spezifischen Format schreiben

Abschnitt Datumsformat

Ziel Steuern der Verwendung der Gebietsschema-spezifischen Datumsformatierung bei der Verwendung von Datumsformatierungs-Codes [siehe Benutzerdefinierte Datumsformate] „%a,“ „%A,“ „%b,“ „%B,“ „%C,“ „%h,“ „%p,“ „%x,“ „%X,“ und „%Z.“

Gültige Werte

Wert | Beschreibung
true | Verwenden der Gebietschema-spezifischen Formatierung, einschließlich lokalisierter Tages- und Monatsnamen.
false (Standard) | Verwenden es eines Standard-Datumsformat mit englischen Tages- und Monatsnamen.
Anmerkung:

Der Standard ist false, da Portrait Miner derzeit keine Daten interpretieren kann, die nicht die englischen Tages- und Monatsnamen verwenden.

Übergeordnetes Thema: Datumsformatierung


x ordering

Abschnitt Datumsformat

Ziel Festlegen des Formats, damit Daten interpretiert oder anzeigt werden, wenn der Datumsformat-Code „%x“ or „%X“ verwendet wird [siehe Benutzerdefinierte Datumsformate].

Gültige Werte

Wert | Beschreibung
Amerikanisch | „%x“ als Monat/Tag/Jahr behandeln.
Europäisch (Standard) | „%x“ als Tag/Monat/Jahr behandeln.
JMT | „%x“ als Jahr/Monat/Tag behandeln.
Übergeordnetes Thema: Datumsformatierung


Dateisuche

  • START
  • Zuordnungsladung
  • qsexplorer Basisverzeichnis
Übergeordnetes Thema: Portrait Miner - Optionen


START

Abschnitt Umgebung

Ziel Festlegen eines „Start“-Speicherorts, der wiederum den Standardwert für verschiedene Optionen bei der Dateisuche festlegt.

Gültige Werte Der Speicherort eines Verzeichnisses/Ordners (auf dem Portrait Miner-Server); standardmäßig nicht festgelegt (sodass der Wert der entsprechenden Umgebungsvariablen des Betriebssystems übernommen wird, falls festgelegt)

Übergeordnetes Thema: Dateisuche


Zuordnungsladung

Abschnitt Verzeichnisse

Zweck Festlegen des ursprünglichen Speicherorts, den Portrait Miner anzeigt, wenn Sie eine Karte suchen und öffnen (mit der Dateinamenerweiterung .mif)

Gültige Werte Der Speicherort eines Verzeichnisses/Ordners (auf dem Porträt Miner-Server), standardmäßig ext/maps (unter UNIX) oder ext\maps (unter Windows) im Portrait Miner-Installationsverzeichnis

Übergeordnetes Thema: Dateisuche


qsexplorer Basisverzeichnis

Abschnitt Verzeichnisse

Zweck Festlegen des ursprünglichen Speicherorts, den Portrait Miner anzeigt und zu dem die Schaltfläche [image] in Portrait Miner und jeder Dateibrowser in Portrait Miner führt.

Gültige Werte Die Lage eines Verzeichnisses/ Ordners (auf dem Portrait Miner-Server); standardmäßig die Einstellung der Option HOME

Übergeordnetes Thema: Dateisuche


Dateien

  • Grobabschaltungs-Prozentsatz
  • Datenformat Vorschaugröße
  • Datenvorschaugröße
  • leer Zeilen
  • Extraktion max. Fehler
  • Extraktion max. Warnungen
  • Extraktionswarnungen ignorieren
  • Maximal gespeicherte Datendateigröße in Megabytes
  • Datenformatfehler zulassen
Übergeordnetes Thema: Portrait Miner - Optionen


Grobabschaltungs-Prozentsatz

Abschnitt Dateidatenbank

Ziel Einstellung des Mindestanteils von Vorschaudatensätzen, die zur Zuordnung eines nicht generischen Datentyps [siehe Datentypen] zu einem Feld in der Datei benötigt werden.

Gültige Werte Eine reelle Zahl zwischen 1 und 100, Standardwert 99

Wenn die Datentypen der Felder in einer Datei nicht spezifiziert sind, benötigt Portrait Miner Vorschaudatensätze, um sie zu spezifizieren. Für jedes Feld wird, wenn kein numerischer Datentyp auf mindestens den vorgegebenen Prozentsatz der Vorschaudatensätze angewendet werden kann, ein Stringdatentyp angewendet, jedem Feld, das numerische Daten enthält, wird, wenn ein Integertyp nicht auf mindestens dem vorgegebenen Prozentsatz der Vorschaudatensätze angewendet werden kann, ein reeller Datentyp zugeordnet.

Anmerkung:

Setzen Sie diese Option und „Datenvorschaugröße“ auf ihre Maximalwerte, um die Datentypen sicher zuzuordnen, die zu jedem Datensatz in der Datei gehören.

Übergeordnetes Thema: Dateien


Datenformat Vorschaugröße

Abschnitt Dateidatenbank

Ziel Einstellung der Anzahl Vorschaudatensätze, die Portrait Miner aus einer Datei ausliest, um das Feldtrennzeichen, Strings und Datumsmarkierungen und Feldnamen während der ersten Analysephase einer Datei zu bestimmen.
Anmerkung: Die Option „Datenformat-Vorschaugröße“ wird nur bei einer nicht vorhandenen Flatfile-Beschreibungsdatei (FDD) verwendet.

Gültige Werte Ein Integer zwischen 1 und 100.000 einschließlich, standardmäßig 100

Wenn das Datenformat einer Flatfile nicht angegeben wird, liest Portrait Miner Beispieldatensätze, um das Format zu bestimmen.

Übergeordnetes Thema: Dateien


Datenvorschaugröße

Abschnitt Dateidatenbank

Ziel Einstellen der Anzahl Vorschaudatensätze, die Portrait Miner aus einer Datei ausliest, um die endgültigen Datentypen [siehe Datentypen] der Felder zu bestimmen.
Anmerkung: Die Option „Datenvorschaugröße“ wird nur bei einer nicht vorhandenen Flatfile-Beschreibungsdatei (FDD) verwendet.

Gültige Werte Eine positive, ganze Zahl, Standardwert 1.000

Anmerkung:

Wenn Sie Daten direkt aus einer Programmausgabe (d.h., mit einem senkrechten Strich) importieren, sind die Vorschaudatensätze, die zu Beginn des Datenstroms stehen, andernfalls sammelt Portrait Miner Vorschaudatensätze, die über die gesamte Datei verteilt sind.

Siehe auch

Datenformat Vorschaugröße
Übergeordnetes Thema: Dateien


leer Zeilen

Abschnitt Dateidatenbank

Ziel Steuern, wie eine leere Zeile beim Lesen einer Datei von Portrait Miner behandelt wird.

Gültige Werte

Wert | Beschreibung
ignore with warning (Standard) | Zeile ignorieren, aber eine Warnung generieren.
ignore silently | Zeile ignorieren, ohne eine Warnung zu generieren.
Null | Einen Datensatz für diese Zeile mit Null [siehe Der Nullwert] in jedem Feld erstellen.
Übergeordnetes Thema: Dateien


Extraktion max. Fehler

Abschnitt Dateidatenbank

Ziel Einstellen der maximalen Anzahl „Datenformatfehler“, die Portrait Miner beim Lesen einer Datei zulässt.

Gültige Werte Eine positive, ganze Zahl, Standardwert 1.000.000

Wenn die Anzahl der Fehler diesen Wert übersteigt, lehnt Portrait Miner die Datei als unlesbar ab und bricht den Import ab.

Anmerkung:

Wenn Sie den Portrait Miner Dateierstellungsbefehl „qsimportflat“ verwenden, können Sie diese Einstellung mit der Option - maxerrors überschreiben.

Siehe auch

Extraktion max. Warnungen

Datenformatfehler zulassen

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Übergeordnetes Thema: Dateien


Extraktion max. Warnungen

Abschnitt Dateidatenbank

Ziel Einstellen der maximalen Anzahl „Datenformatwarnungen“, die Portrait Miner beim Lesen einer Datei zulässt.

Gültige Werte Eine positive, ganze Zahl, Standardwert 1.000.000

Wenn die Anzahl der Warnungen diesen Wert übersteigt, lehnt Portrait Miner die Datei als unlesbar ab und bricht den Import ab.

Anmerkung:

Wenn Sie den Portrait Miner Dateierstellungsbefehl „qsimportflat“ verwenden, können Sie diese Einstellung mit der Option maxwarnings überschreiben.

Siehe auch

Extraktion max. Fehler

Extraktionswarnungen ignorieren

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Übergeordnetes Thema: Dateien


Extraktionswarnungen ignorieren

Abschnitt Dateidatenbank

Ziel Kontrollieren, ob Portrait Miner Datenformatwarnungen beim Lesen einer Datei zurückmeldet (und die Gesamtanzahl Warnungen mit der Option „Extraktion max. Warnungen“ vergleicht).

Gültige Werte

Wert | Beschreibung
true | Keine Warnungen ausgeben.
false (Standard) | Warnungen ausgeben.
Anmerkung:
  • Portrait Miner gibt immer „Fehlermeldungen“ und die gesamte „Anzahl“ Warnungen aus.
  • Wenn Sie den Portrait Miner Dateierstellungsbefehl „qsimportflat“ verwenden, können Sie diese Einstellung mit der Option „Keine Warnungen“ überschreiben.

Siehe auch

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Übergeordnetes Thema: Dateien


Maximal gespeicherte Datendateigröße in Megabytes

Abschnitt Dateidatenbank

Ziel Festlegen der Maximalmenge der Daten (in Megabyte), die Portrait Miner beim Export als Text mit einer FDD-Datei (Flat-Data Description) in eine einzelne Datei schreibt.

Gültige Werte Eine ganze Zahl größer als 1, Standardwert 2048.

Wenn die in eine Datendatei geschriebene Datenmenge diesen Grenzwert erreicht, erstellt Portrait Miner eine neue Datendatei und fügt einen zusätzlichen Dateiverweis in die FDD-Datei ein.

Anmerkung:
  • Portrait Miner ignoriert die Einstellung dieser Option beim Export als Text ohne FDD-Datei.
  • Um sicherzustellen, dass Portrait Miner immer nur Daten in eine einzelne Datei schreibt, auch wenn eine FDD-Datei verwendet wird, ändern Sie den Wert auf $MAXLARGEFILESIZEMB.
Übergeordnetes Thema: Dateien


Datenformatfehler zulassen

Abschnitt Dateidatenbank

Ziel Das Verhalten von Portrait Miner beim Auffinden von Datenformatfehlern in Dateien steuern.

Gültige Werte

Wert | Beschreibung
true (Standard) | Datenformatfehler als Warnung behandeln.
false | Datenformatfehler als Fehler behandeln.

Siehe auch

Extraktion max. Fehler

Extraktion max. Warnungen

Übergeordnetes Thema: Dateien


Datenbanken

  • Bei Import numerische Typen beibehalten
  • große Ganzzahlen als Zeichenfolgen repräsentieren
Übergeordnetes Thema: Portrait Miner - Optionen


Bei Import numerische Typen beibehalten

Abschnitt Datenbank

Ziel Bestimmung der Datenbank [siehe Datentypen], die Portrait Miner für ein Feld beim Import von numerischen Werten mit mehr als 15 Nachkommastellen aus einer Datenbank verwendet.

Gültige Werte

Wert | Beschreibung
true (Standard) | Verwendung des reellen Datentyps, Beibehaltung der wichtigsten 15 Stellen und verwerfen der übrigen.
false | Verwendung einer Stringdarstellung, um die Nachkommastellen des Originals (mindestens bis zur zweitkleinsten wichtigen Stelle) beizubehalten
Übergeordnetes Thema: Datenbanken


große Ganzzahlen als Zeichenfolgen repräsentieren

Abschnitt Datenbank

Zweck Bestimmung des Datentyps [siehe Datentypen], den Portrait Miner beim Import aus einer Datenbank oder einer Datei zur Darstellung eines Integer-Feldes verwendet, das Zahlen enthält, die für eine Darstellung als 32-bit-Integer zu lang sind (Integer kleiner als -2 147483647 oder größer als 2 147483646).

Gültige Werte

Wert | Beschreibung
true (Standard) | Datentyp „String“ verwenden.
false | Datentyp „Reelle Zahl“ verwenden.
Übergeordnetes Thema: Datenbanken


Prüfungen und Zusammenfassungen

  • backgroundcolor
  • backgroundtexture
  • barcolor
  • barstyle
  • errorbars
  • globalbarscale
  • globalpointscale
  • graph3deffect
  • graphshadow
  • imageheight
  • zoompointscale
Übergeordnetes Thema: Portrait Miner - Optionen


backgroundcolor

Abschnitt Überprüfungen und Speicherauszug

Ziel Steuern der Hintergrundfarbe für Bilder in Profilen, sowie Prüfungen und Zusammenfassungenn.

Gültige Werte Ein Textstring, Standardwert „weiße“

Sie können einen SVG-konformen Farbnamen http://www.w3.org (z. B. „firebrick“) oder einen hexadezimalen RGB-Wert (z. B. „#2244FF“) angeben.

Siehe auch

backgroundtexture

barcolor

barstyle

errorbars

globalbarscale

globalpointscale

graph3deffect

graphshadow

imageheight

zoompointscale

Übergeordnetes Thema: Prüfungen und Zusammenfassungen


backgroundtexture

Abschnitt Überprüfungen und Speicherauszug

Ziel Steuern der Hintergrundtextur für Bilder in Profilen sowie Prüfungen und Zusammenfassungen (nur SVG-Format).

Gültige Werte

Wert | Beschreibung
true | Hintergrundtextur verwenden.
false (Standard) | Keine Hintergrundtextur verwenden.

Siehe auch

backgroundcolor

barcolor

barstyle

errorbars

globalbarscale

globalpointscale

graph3deffect

graphshadow

imageheight

zoompointscale

Übergeordnetes Thema: Prüfungen und Zusammenfassungen


barcolor

Abschnitt Überprüfungen und Speicherauszug

Ziel Steuern der Farbe von Balken in Balkendiagrammen in Profilen sowie Prüfungen und Modellzusammenfassungen.

Gültige Werte Eine Textstring, Standardwert „#9999FF“ (lila)

Sie können einen SVG-konformen Farbnamen http://www.w3.org (z. B. „firebrick“) oder einen hexadezimalen RGB-Wert (z. B. „#2244FF“) angeben.

Siehe auch

backgroundcolor

backgroundtexture

barstyle

errorbars

globalbarscale

globalpointscale

graph3deffect

graphshadow

imageheight

zoompointscale

Übergeordnetes Thema: Prüfungen und Zusammenfassungen


barstyle

Abschnitt Überprüfungen und Speicherauszug

Ziel Steuern des Stils von Balken in Balkendiagrammen und Segmenten in Entscheidungsbäumen für Profile, sowie Überprüfungen und Modellspeicherauszüge.

Gültige Werte

Wert | Beschreibung
plain (Standard) | Balken oder Segmente erhalten ein flaches, winkliges Aussehen.
curved | Balken oder Segmente erhalten ein kurviges Aussehen.
embossed | Balken oder Segmente erhalten ein erhabenes, eingeprägtes Aussehen.

Siehe auch

backgroundcolor

backgroundtexture

barcolor

errorbars

globalbarscale

globalpointscale

graph3deffect

graphshadow

imageheight

zoompointscale

Übergeordnetes Thema: Prüfungen und Zusammenfassungen


errorbars

Abschnitt Überprüfungen und Speicherauszug

Ziel Steuern der Verwendung von Fehlerbalken in Balkendiagrammen in Profilen, sowie Prüfungen und Zusammenfassungen.

Gültige Werte

Wert | Beschreibung
true (Standard) | Fehlerbalken auf Datenpunkte platzieren.
false | Fehlerbalken nicht auf Datenpunkte platzieren.

Siehe auch

backgroundcolor

backgroundtexture

barcolor

barstyle

globalbarscale

globalpointscale

graph3deffect

graphshadow

imageheight

zoompointscale

Übergeordnetes Thema: Prüfungen und Zusammenfassungen


globalbarscale

Abschnitt Überprüfungen und Speicherauszug

Ziel Steuern der relativen Skalierung der horizontalen Achsen in Balkendiagrammen in Profilen, sowie Prüfungen und Zusammenfassungen.

Gültige Werte

Wert | Beschreibung
true | Skala der horizontalen Achsen bei allen Diagrammen gleich setzen, in allen Profilen, sowie Prüfungen und Zusammenfassungen.
false (Standard) | Skala der horizontalen Achsen bei allen Diagrammen nicht gleich setzen, in allen Profilen, sowie Prüfungen und Zusammenfassungen.

Siehe auch

backgroundcolor

backgroundtexture

barcolor

barstyle

errorbars

globalpointscale

graph3deffect

graphshadow

imageheight

zoompointscale

Übergeordnetes Thema: Prüfungen und Zusammenfassungen


globalpointscale

Abschnitt Überprüfungen und Speicherauszug

Ziel Steuern der relativen Skalierung der vertikalen Achsen in Balkendiagrammen in Profilen, sowie Prüfungen und Zusammenfassungen.

Gültige Werte

Wert | Beschreibung
true (Standard) | Skala der vertikalen Achsen bei allen Diagrammen gleich setzen, in allen Profilen, sowie Prüfungen und Zusammenfassungen.
false | Skala der vertikalen Achsen bei allen Diagrammen nicht gleich setzen, in allen Profilen, sowie Prüfungen und Zusammenfassungen.

Siehe auch

backgroundcolor

backgroundtexture

barcolor

barstyle

errorbars

globalbarscale

graph3deffect

graphshadow

imageheight

zoompointscale

Übergeordnetes Thema: Prüfungen und Zusammenfassungen


graph3deffect

Abschnitt Überprüfungen und Speicherauszug

Ziel Steuern des Stils von Balken in Balkendiagrammen für Profile, sowie Überprüfungen und Modellzusammenfassungen.

Gültige Werte

Wert | Beschreibung
true | Dreidimensionale Balken verwenden.
false (Standard) | Zweidimensionale Balken verwenden.

Siehe auch

backgroundcolor

backgroundtexture

barcolor

barstyle

errorbars

globalbarscale

globalpointscale

graphshadow

imageheight

zoompointscale

Übergeordnetes Thema: Prüfungen und Zusammenfassungen


graphshadow

Abschnitt Überprüfungen und Speicherauszug

Ziel Steuern des Stils von Balken in Balkendiagrammen und Segmenten in Entscheidungsbäumen in Profilen sowie Prüfungen und Modellzusammenfassungen.

Gültige Werte

Wert | Beschreibung
true | Schatten-Effekt erzeugen.
false (Standard) | Keinen Schatten-Effekt erzeugen.

Siehe auch

backgroundcolor

backgroundtexture

barcolor

barstyle

errorbars

globalbarscale

globalpointscale

graph3deffect

imageheight

zoompointscale

Übergeordnetes Thema: Prüfungen und Zusammenfassungen


imageheight

Abschnitt Überprüfungen und Speicherauszug

Ziel Steuern der Höhe (in Pixel) von erstellten Bildern für Profile, sowie Überprüfungen und Modellspeicherzügen. Feststehendes Ansichtsverhältnis des Bilds.

Gültige Werte Eine positive, ganze Zahl, Standardwert 300

Siehe auch

backgroundcolor

backgroundtexture

barcolor

barstyle

errorbars

globalbarscale

globalpointscale

graph3deffect

graphshadow

zoompointscale

Übergeordnetes Thema: Prüfungen und Zusammenfassungen


zoompointscale

Abschnitt Überprüfungen und Speicherauszug

Ziel Steuern des Bereichs der vertikalen Achse bei Balkendiagrammen in Profilen, sowie Überprüfungen und Modellspeicherauszügen.

Gültige Werte

Wert | Beschreibung
true | Bereich der Achse auf den der Datenpunkte setzen.
false (Standard) | Bereich der Achse auf den der Datenpunkte, erweitert um Null, setzen.

Siehe auch

backgroundcolor

backgroundtexture

barcolor

barstyle

errorbars

globalbarscale

globalpointscale

graph3deffect

graphshadow

imageheight

Übergeordnetes Thema: Prüfungen und Zusammenfassungen


E-Mail-Benachrichtigung

  • emailaddress
  • emailserver
Übergeordnetes Thema: Portrait Miner - Optionen


emailaddress

Abschnitt E-Mail

Zweck Festlegen der E-Mail-Adresse, an die Benachrichtigungen gesendet werden

Gültige Werte Eine Textzeichenfolge, die standardmäßig nicht angegeben ist (sodass keine E-Mail gesendet wird)

Es sollte eine gültige E-Mail-Adresse oder eine durch Komma getrennte Liste von gültigen E-Mail-Adressen sein, z. B. ich@meinefirma.de.

Anmerkung:

Um ein Komma in eine E-Mail-Adresse einzufügen, verwenden Sie den Text ${COMMA}.

Siehe auch

emailserver

Übergeordnetes Thema: E-Mail-Benachrichtigung


emailserver

Abschnitt E-Mail

Zweck Festlegen des E-Mail-Servers, über den Benachrichtigungen gesendet werden

Gültige Werte Eine Textzeichenfolge, die standardmäßig nicht angegeben ist (sodass keine E-Mail gesendet wird)

Es sollte die Adresse eines SMTP-Servers sein, z. B. smtp.meinefirma.de.

Siehe auch

emailaddress

Übergeordnetes Thema: E-Mail-Benachrichtigung


Systemtuning und -verwaltung

  • Ableitungsbibliotheken
  • Fokusspeicher-Weichbegrenzungs-
  • Maximaler Parallelismus
  • Parallelismus
Übergeordnetes Thema: Portrait Miner - Optionen


Ableitungsbibliotheken

Abschnitt Funktionen

Ziel Legen Sie die Speicherorte von Drittanbieter- oder benutzerdefinierten FDL-Funktionsbibliotheken fest (mit der Dateiendung .fdl).

Gültige Werte Eine durch Komma getrennte Liste von Datei/Verzeichnis/Ordner-Speicherorten (auf dem Portrait Miner-Server); standardmäßig nicht gesetzt.

Wenn Decision Studio startet, öffnet es Funktionsbibliotheken, die explizit gelistet sind sowie jene, die in gelisteten Verzeichnissen/Ordnern (und allen Unterordnern) stehen. Auf diesem Wege werden die in den Bibliotheken definierten Funktionen für den Einsatz in der Tabellenanicht nutzbar.

Anmerkung:

Um ein Komma in einen Datei/Verzeichnis/Ordner-Namen einzufügen, benutzen Sie den Text ${COMMA}.

Übergeordnetes Thema: Systemtuning und -verwaltung


Fokusspeicher-Weichbegrenzungs-

Ändern dieser Einstellung wird nicht empfohlen

Dieses Limit wird dynamisch von Portrait Miner gesetzt; Sie sollten dieses Limit nur nach Rücksprache mit dem Portrait Miner Support ändern.

Abschnitt Systemtuning

Zweck Festlegen einer „weichen“ Grenze für die Speicherauslastung (in MB)

Gültige Werte Eine Ganzzahl größer als oder gleich 16, standardmäßig ein Wert, der bei der Laufzeit aus dem gesamten verfügbaren physischen Speicher und den Speicherbegrenzungen des Betriebssystems von Portrait Miner festgelegt wird. Haben Sie eine 64-Bit-Version von Portrait Miner, ist die Gesamtmenge des verfügbaren Speichers nur durch den physischen Speicher des Computer begrenzt. Haben Sie eine 32-Bit-Version von Portrait Miner, ist die Gesamtmenge des verfügbaren Speichers auf 2 GB begrenzt.

Anmerkung:

Das Limit gilt für Decision Studio und für bestimmte Dateierstellungsbefehle (zusammen mit ihren jeweiligen grafischen Benutzerschnittstellen). Es ist ein „Softlimit“ und kann überschritten werden, obwohl die Systemleistung in diesem Fall leiden kann.

Wird das Limit um 20 % oder mehr in Decision Studio überschritten, warnt ein Pop-up-Fenster den Benutzer davor.

Wird das Limit um 20 % oder mehr während der Ausführung eines Dateierstellungsbefehls überschritten, wird eine Warnung in stderr geschrieben (und auch in eine Protokolldatei, falls eine verwendet wird).

Bei Verwendung von Portrait Miner Desktop wird dieses Limit automatisch verwaltet und sollte keinerlei Einstellung nötig machen.

Siehe auch

Parallelismus

Übergeordnetes Thema: Systemtuning und -verwaltung


Maximaler Parallelismus

Abschnitt Systemtuning

Zweck Festlegen der maximalen Anzahl der (auf dem Portrait Miner-Server) verwendeten Prozessoren bei einer Decision Studio-Benutzersitzung oder einem Datenerstellungsbefehl (und jede Portrait Miner-Funktion, die über einen Datenerstellungsbefehl implementiert wird)

Gültige Werte Eine positive Ganzzahl, standardmäßig die Zahl der verfügbaren Prozessoren

Siehe auch

Parallelismus

Übergeordnetes Thema: Systemtuning und -verwaltung


Parallelismus

Abschnitt Systemtuning

Zweck Festlegen der Standardanzahl der (auf dem Portrait Miner-Server) verwendeten Prozessoren bei einer Decision Studio-Benutzersitzung oder einem Datenerstellungsbefehl (und jede Portrait Miner-Funktion, die über einen Datenerstellungsbefehl implementiert wird). Unter gewissen Umständen können Benutzer diese Zahl bei der Laufzeit erhöhen oder verringern.

Gültige Werte Eine positive Ganzzahl, standardmäßig 1. Der Wert darf nicht die Einstellung des maximalen Parallelismus überschreiten.

Übergeordnetes Thema: Systemtuning und -verwaltung


Systemintegration und RealTime

  • Adminprotokolldatei
  • Cache-Aktualisierungszeitraum
  • Administrations-Protokollierung aktivieren
  • Bewertungsprotokollierung aktivieren
  • before ... read, after ... write
  • Schwellwert für Warnung für abgelaufene Regel
  • XML-Menüelement exportieren
  • externe Ausführung Hook-Standort
  • Protokollierungspuffer-Löschungszeitraum
  • Protokollierungspuffer, max. Speichernutzung
  • Protokollierungspuffergröße
  • rule store save
  • Server-Statusstandort
Übergeordnetes Thema: Portrait Miner - Optionen


Adminprotokolldatei

Diese Einstellung wird nur beim Export verwendet und braucht normalerweise nur vom Portrait Miner-Administrator geändert zu werden.

Abschnitt Actionhouse RT

Ziel Der Pfadname für die RealTime-Adminprotokolldatei, die zur Protokollierung aller Serveradministrationsereignisse verwendet wird. Sie wird nur verwendet, wenn „Administrations-Protokollierung aktivieren“ aktiviert ist.

Gültige Werte Der Speicherort eines Verzeichnisses/Ordners (auf dem Portrait Miner-Server), standardmäßig nicht festgelegt

Übergeordnetes Thema: Systemintegration und RealTime


Cache-Aktualisierungszeitraum

Diese Einstellung wird nur beim Export verwendet und braucht normalerweise nur vom Portrait Miner-Administrator geändert zu werden.

Abschnitt Actionhouse RT

Ziel Die Zeit in Sekunden zwischen automatischen Regelaktualisierungsereignissen von RealTime-Clients. Ein Client fragt den Server regelmäßig mit diesem Aktualisierungszeitraum ab, damit Neudefinitionen oder Löschungen von Regeln herüberkopiert werden.

Gültige Werte Eine ganze Zahl, Standardwert 3600

Übergeordnetes Thema: Systemintegration und RealTime


Administrations-Protokollierung aktivieren

Abschnitt Actionhouse RT

Ziel Aktivieren bzw. deaktivieren der RealTime-Administrations-Protokollierung.

Gültige Werte

Wert | Beschreibung
true | Administrations-Protokollierung aktivieren
false (Standard) | Administrations-Protokollierung deaktivieren

Siehe auch

Adminprotokolldatei
Übergeordnetes Thema: Systemintegration und RealTime


Bewertungsprotokollierung aktivieren

Diese Einstellung wird nur beim Export verwendet und braucht normalerweise nur vom Portrait Miner-Administrator geändert zu werden.

Abschnitt Actionhouse RT

Ziel Aktivieren bzw. deaktivieren der RealTime-Bewertungsprotokollierung.

Gültige Werte

Wert | Beschreibung
true (Standard) | Bewertungsprotokollierung aktivieren
false | Bewertungsprotokollierung deaktivieren

Siehe auch

Übergeordnetes Thema: Systemintegration und RealTime


before ... read, after ... write

Abschnitt Externe Ausführung Hooks

Ziel Spezifizieren eines Befehl, den Portrait Miner immer vor dem Lesen aus oder Schreiben in Dateien des angegebenen Typs ausführt.

Gültige Werte Ein Textstring, Standardwert nicht gesetzt

Portrait Miner führt den angegebenen Befehl vor dem Lesen oder nach dem Schreiben in eine Datei des angegebenen Typs aus. Dem Befehl wird der gesamte Pfadname als Argument angehängt.

Anmerkung:
Ein Befehl in einem Ausführungs-Hook läuft in einer Umgebung, die er von Portrait Miner erbt, außer:
  • Der Pfad wird erweitert, um das Portrait Miner-Befehlszeilen-Utility mit aufzunehmen.
  • Sie können das vererbte Arbeitsverzeichnis/Ordner mit der Option „Externe Ausführung Hook-Standort“ überschreiben.

Es ist immer sicherer, den kompletten Pfad zu der ausführbaren Datei anzugeben oder den Hook-Standort der externen Ausführung anzugeben. Insbesondere Windows durchsucht das aktuelle Verzeichnis nach ausführbaren Dateien, bevor der Pfad durchsucht wird, was zu unerwarteten Ergebnissen führen kann.

Dateitypen mit Ausführungs-Hooks

Name in Option | Dateityp | Lesen | Schreiben
binning | Decision Studio Klasseneinteilungsdatei (.bng) |  |
Kategoriehierarchie | .hrc-Datei |  |
Cluster | Clustermodelldatei |  |
Konfiguration | Optionsdatei (qs.ini) |  |
crosstab | Nicht verwenden. |  |
Daten | Nicht verwenden. |  |
Datenbank | Eine Datenbanktabelle (angegeben als ein DRL-Parameter zum Befehl; weitere Informationen zu DRLS finden Sie unter „Skripts für qstml“) |  |
Entscheidungsbaum | .qsdt- oder .dt-Datei |  |
Ableitung | FDL Funktionsbibliotheksdatei (.fdl) |  |
Dateibeschreibung | .fdd-Datei |  |
Datei | Datei |  |
Datei | Datei (angegeben als Dateibeschreibung-Dateinamensparameter zum Befehl, wenn Sie eine Datei schreiben und angegeben haben, dass eine FDD-Datei erstellt werden soll; ansonsten enthält der Parameter stattdessen den Namen der Datei). Bei einer Dateioperation können mehrere einzelne Dateien beteiligt sein (eine Dateibeschreibung und eine oder mehrere Dateien). Der Unterschied zwischen diesem Hook und die beiden vorangegangenen ist, dass der Befehl pro Operation nur einmal ausgeführt wird (vor dem Lesen der ersten Datei oder nach dem Schreiben der letzten Datei). Die Hooks auf niedrigerer Ebene werden einmal pro Datei ausgeführt. |  |
focus | .ftr-Datei (Beachten Sie, dass beim Verschieben oder Entfernen eines Fokus Portrait Miner oder mit dem Befehl qsremove bzw. qsmove, der Befehl für den alten Fokus ausgeführt wird, der nicht mehr existiert, und für den neuen Fokus, nachdem er erstellt wurde) |  |
HTML | Kreuztabellendatei in HTML-Format |  |
Protokoll | .log-Datei |  |
zuordnen | Decision Studio Zuordnungsdatei (.mid oder .mif) |  |
Modell | TML-Modelldatei (.tml), erstellt von Decision Studio |  |
qmml | QMML-Modell-Datei (.qmml), erstellt von Decision Studio |  |
Bewertungsliste | .qssc- oder .sc Datei |  |
Text | Nicht verwenden. |  |
Übergeordnetes Thema: Systemintegration und RealTime


Schwellwert für Warnung für abgelaufene Regel

Diese Einstellung wird nur beim Export verwendet und braucht normalerweise nur vom Portrait Miner-Administrator geändert zu werden.

Abschnitt Actionhouse RT

Ziel Die Maximalanzahl von Regeln auf dem RealTime-Server, die als „abgelaufen“ gekennzeichnet sein können aber noch nicht von den Clients umgesetzt wurden. Bei Überschreitung dieser Anzahl wird eine Warnung in das Systemereignisprotokoll geschrieben (und, sofern aktiviert, in die RealTime-Administratorprotokolldatei). Normalerweise weist dies auf einen falsch konfigurierten oder abgestürzten Client hin.

Gültige Werte Eine ganze Zahl, Standardwert 10

Siehe auch

Adminprotokolldatei
Übergeordnetes Thema: Systemintegration und RealTime


XML-Menüelement exportieren

Abschnitt Actionhouse RT

Ziel Festlegen des Texts, der in der Menüoption Tabellenansicht zum Speichern von QMML-Modellen erscheint.

Gültige Werte Ein Textstring, Standardwert „Exportieren als QMML...“

Übergeordnetes Thema: Systemintegration und RealTime


externe Ausführung Hook-Standort

Diese Einstellung wird nur beim Export verwendet und braucht normalerweise nur vom Portrait Miner-Administrator geändert zu werden.

Abschnitt Verzeichnisse

Ziel Spezifizieren des Arbeitsverzeichnisses/Ordners für Befehle, die Portrait Miner über Ausführungs-Hooks [siehe before ... read, after ... write] ausführt.

Gültige Werte Der Speicherort eines Verzeichnisses/Ordners (auf dem Portrait Miner-Server), standardmäßig nicht festgelegt

Wenn der Speicherort nicht angegeben ist, erben die Ausführungs-Hook-Befehle ihr Arbeitsverzeichnis/Ordner vom Decision Studio.

Übergeordnetes Thema: Systemintegration und RealTime


Protokollierungspuffer-Löschungszeitraum

Diese Einstellung wird nur beim Export verwendet und braucht normalerweise nur vom Portrait Miner-Administrator geändert zu werden.

Abschnitt Actionhouse RT

Ziel Siehe „RealTime-Integration und -Administration“.

Gültige Werte Eine ganze Zahl, Standardwert 5

Übergeordnetes Thema: Systemintegration und RealTime


Protokollierungspuffer, max. Speichernutzung

Diese Einstellung wird nur beim Export verwendet und braucht normalerweise nur vom Portrait Miner-Administrator geändert zu werden.

Abschnitt Actionhouse RT

Ziel Siehe „RealTime-Integration und -Administration“.

Gültige Werte Eine ganze Zahl, Standardwert 1024

Übergeordnetes Thema: Systemintegration und RealTime


Protokollierungspuffergröße

Diese Einstellung wird nur beim Export verwendet und braucht normalerweise nur vom Portrait Miner-Administrator geändert zu werden.

Abschnitt Actionhouse RT

Ziel Siehe „RealTime-Integration und -Administration“.

Gültige Werte Eine ganze Zahl, Standardwert 10

Übergeordnetes Thema: Systemintegration und RealTime


rule store save

Diese Einstellung wird nur beim Export verwendet und braucht normalerweise nur vom Portrait Miner-Administrator geändert zu werden.

Abschnitt Verzeichnisse

Ziel Festlegen des Standardspeicherorts zum Speichern von QMML-Modellen (und deren Aktivierung in Decision Studio).

Gültige Werte Der Speicherort eines Verzeichnisses/Ordners (auf dem Portrait Miner-Server), standardmäßig nicht festgelegt (sodass der die durch die Menüoption, die durch die Option „XML-Menüelement exportieren“ definiert wird, nicht im Decision Studio erscheint)

Übergeordnetes Thema: Systemintegration und RealTime


Server-Statusstandort

Diese Einstellung wird nur beim Export verwendet und braucht normalerweise nur vom Portrait Miner-Administrator geändert zu werden.

Abschnitt Actionhouse RT

Ziel Das Verzeichnis, in dem der RealTime-Server seinen aktiven Status speichert. Wenn der Server hochfährt, lädt er den Status aus diesem Verzeichnis. Der Server pflegt hier eine Festplattenkopie seines aktuellen Status, während er läuft.

Gültige Werte Der Speicherort eines Verzeichnisses/Ordners (auf dem Porträt Miner-Server), standardmäßig shared/actionhouseRT (unter UNIX) oder shared\actionhouseRT (unter Windows) im Portrait Miner-Installationsverzeichnis

Übergeordnetes Thema: Systemintegration und RealTime


Aggregationsfunktionen

  • any
  • confintlower
  • confintupper
  • count
  • countnonnull/countnonnulls
  • countnull/countnulls
  • countunique
  • countuniquenonnull
  • expectedcount
  • expectedproportion
  • first
  • last
  • max (ein Argument)
  • mean (ein Argument)
  • median
  • min (ein Argument)
  • Modus
  • moderatio
  • percentage
  • percentagerate
  • Proportion
  • segindex
  • significance
  • stdev
  • sum (ein Argument)
  • Abweichung


any

Ziel Auswählen eines beliebigen Wertes ungleich Null aus einem Feld aus (möglicherweise pro Gruppe oder Segment).

Syntax any (x)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Das Feld, aus dem der Wert zu nehmen ist

Ergebnis

Typ | Beschreibung
als Eingabe | Ein beliebiger Wert ungleich Null im Feld x (möglicherweise pro Gruppe oder Segment)
Anmerkung:

Sie können diese Funktion nicht in einer Decision Studio-Ableitung, der Ableitungsdatei für qsderive oder dem äquivalenten Fenster „Felder ableiten“, in der Tracker-Datei für qstrack oder in einer Auswahldatei für qsselect verwenden.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

first

last

Übergeordnetes Thema: Aggregationsfunktionen


confintlower

Ziel Berechnen der unteren Grenze eines 95 % Konfidenzintervalls für den Mittelwert eines Felds.

Syntax confintlower(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Das zu berücksichtigende Feld

Ergebnis

Typ | Beschreibung
Reelle Zahl | Die untere Grenze eines Intervalls in dem der Mittelwert der Gesamtmenge des Segments für das Feld x wahrscheinlich in den Konfidenzbereich von 95 % fällt.
Anmerkung:

Sie können diese Funktion nicht in einer Decision Studio-Ableitung, der Ableitungsdatei für qsderive oder dem äquivalenten Fenster „Felder ableiten“, in der Tracker-Datei für qstrack oder in einer Auswahldatei für qsselect verwenden.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

confintupper

significance

Übergeordnetes Thema: Aggregationsfunktionen


confintupper

Ziel Berechnen der oberen Grenze eines 95 % Konfidenzintervalls für den Mittelwert eines Feldes.

Syntax confintupper(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Das zu berücksichtigende Feld

Ergebnis

Typ | Beschreibung
Reelle Zahl | Die obere Grenze eines Intervalls in dem der Mittelwert der Gesamtmenge des Segments für das Feld x wahrscheinlich in den Konfidenzbereich von 95 % fällt.
Anmerkung:

Sie können diese Funktion nicht in einer Decision Studio-Ableitung, der Ableitungsdatei für qsderive oder dem äquivalenten Fenster „Felder ableiten“, in der Tracker-Datei für qstrack oder in einer Auswahldatei für qsselect verwenden.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

confintlower

significance

Übergeordnetes Thema: Aggregationsfunktionen


count

Ziel Zählt die Anzahl der Datensätze (wenn möglich pro Gruppe oder Segment).

Syntax count()

Argumente Keine

Ergebnis

Typ | Beschreibung
ganze Zahl | Die Anzahl der Datensätze (wenn möglich pro Gruppe oder Segment).

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

countnonnull/countnonnulls

countnull/countnulls

countunique

countuniquenonnull

Übergeordnetes Thema: Aggregationsfunktionen


countnonnull/countnonnulls

Ziel Zählt die Anzahl der Datensätze mit einem Feld, dass Werte ungleich Null enthält (wenn möglich pro Gruppe oder Segment).

Syntax countnonnull(x)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Das zu berücksichtigende Feld

Ergebnis

Typ | Beschreibung
ganze Zahl | Die Anzahl der Datensätze bei denen das Feld x Werte ungleich Null enthält (wenn möglich pro Gruppe oder Segment).
Anmerkung:

In Decision Studio-Kreuztabellen [siehe Aggregationsfunktionen für Kreuztabellen] und in einem Kennzahlenkontext [siehe Aggregationsfunktionen für Kennzahlen und Ableitungen] ist diese Funktion countnonnull, während sie in einem Ableitungskontext countnonnulls ist.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

count

countnull/countnulls

countunique

countuniquenonnull

Übergeordnetes Thema: Aggregationsfunktionen


countnull/countnulls

Ziel Zählt die Anzahl der Datensätze mit einem Feld, das den Wert Null enthält (wenn möglich pro Gruppe oder Segment).

Syntax countnull(x)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Das zu berücksichtigende Feld

Ergebnis

Typ | Beschreibung
ganze Zahl | Die Anzahl der Datensätze bei denen das Feld x Null ist (wenn möglich pro Gruppe oder Segment).
Anmerkung:

In Decision Studio-Kreuztabellen [siehe Aggregationsfunktionen für Kreuztabellen] und in einem Kennzahlenkontext [siehe Aggregationsfunktionen für Kennzahlen und Ableitungen] ist diese Funktion countnull, während sie in einem Ableitungskontext countnulls ist.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

count

countnonnull/countnonnulls

countunique

countuniquenonnull

Übergeordnetes Thema: Aggregationsfunktionen


countunique

Ziel Zählt die Anzahl von eindeutigen Werten, die in einem Feld auftreten, möglicherweise den Wert Null einschließend (wenn möglich pro Gruppe oder Segment).

Syntax countunique(x)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Das zu berücksichtigende Feld

Ergebnis

Typ | Beschreibung
ganze Zahl | Die Anzahl der eindeutigen Werte, einschließlich Null, die in x auftreten (wenn möglich pro Gruppe oder Segment).
Anmerkung:

Sie können diese Funktion nicht in einer Decision Studio-Ableitung, der Ableitungsdatei für qsderive oder dem äquivalenten Fenster „Felder ableiten“, in der Tracker-Datei für qstrack oder in einer Auswahldatei für qsselect verwenden.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

count

countnonnull/countnonnulls

countnull/countnulls

countuniquenonnull

Übergeordnetes Thema: Aggregationsfunktionen


countuniquenonnull

Ziel Zählt die Anzahl von eindeutigen Werten ungleich Null, die in einem Feld auftreten (wenn möglich pro Gruppe oder Segment).

Syntax countuniquenonnull(x)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Das zu berücksichtigende Feld

Ergebnis

Typ | Beschreibung
ganze Zahl | Die Anzahl der eindeutigen Werte, außer Null, die in x auftreten (wenn möglich pro Gruppe oder Segment).
Anmerkung:

Sie können diese Funktion nicht in einer Decision Studio-Ableitung, der Ableitungsdatei für qsderive oder dem äquivalenten Fenster „Felder ableiten“, in der Tracker-Datei für qstrack oder in einer Auswahldatei für qsselect verwenden.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

count

countnonnull/countnonnulls

countnull/countnulls

countunique

Übergeordnetes Thema: Aggregationsfunktionen


expectedcount

Ziel Berechnen der „erwarteten“ Gesamtmenge eines Kreuztabellensegments.

Syntax expectedcount()

Argumente Keine

Ergebnis

Typ | Beschreibung
Reelle Zahl | Die Datensatzanzahl, den man für ein Segment erwarten würde, wenn die Felder der Kreuztabelle unabhängig voneinander wären
Anmerkung:

Sie können diese Funktion ausschließlich mit Kreuztabellen in Decision Studio [siehe Aggregationsfunktionen für Kreuztabellen] für die Visualisierung von Daten verwenden.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

expectedproportion

Übergeordnetes Thema: Aggregationsfunktionen


expectedproportion

Ziel Berechnung die „erwartete“ Gesamtmenge eines Kreuztabellensegments als Proportion einer Gesamtmenge.

Syntax expectedproportion()

Argumente Keine

Ergebnis

Typ | Beschreibung
Reelle Zahl | Die Proportion der Gesamtmenge, die man für ein Segment erwarten würde, wenn die Felder der Kreuztabelle unabhängig voneinander wären
Anmerkung:

Sie können diese Funktion ausschließlich mit Kreuztabellen in Decision Studio [siehe Aggregationsfunktionen für Kreuztabellen] für die Visualisierung von Daten verwenden.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

expectedcount

Übergeordnetes Thema: Aggregationsfunktionen


first

Ziel Aufgreifen des ersten Werts ungleich Null aus einem Feld (möglicherweise pro Gruppe oder Segment).

Syntax first(x)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Das Feld, aus dem der Wert zu nehmen ist

Ergebnis

Typ | Beschreibung
als Eingabe | Der erste Wert ungleich Null, der im Feld x auftritt (möglicherweise pro Gruppe oder Segment)
Anmerkung:

Sie können diese Funktion nicht in einer Decision Studio-Ableitung, der Ableitungsdatei für qsderive oder dem äquivalenten Fenster „Felder ableiten“, in der Tracker-Datei für qstrack oder in einer Auswahldatei für qsselect verwenden.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

any

last

Übergeordnetes Thema: Aggregationsfunktionen


last

Ziel Aufgreifen des letzten Werts ungleich Null aus einem Feld (möglicherweise pro Gruppe oder Segment).

Syntax last(x)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Das Feld, aus dem der Wert zu nehmen ist

Ergebnis

Typ | Beschreibung
als Eingabe | Der letzte Wert ungleich Null, der im Feld x auftritt (möglicherweise pro Gruppe oder Segment)
Anmerkung:

Sie können diese Funktion nicht in einer Decision Studio-Ableitung, der Ableitungsdatei für qsderive oder dem äquivalenten Fenster „Felder ableiten“, in der Tracker-Datei für qstrack oder in einer Auswahldatei für qsselect verwenden.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

any

first

Übergeordnetes Thema: Aggregationsfunktionen


max (ein Argument)

Ziel Berechnen des maximalen Werts ungleich Null in einem Feld (möglicherweise pro Gruppe oder Segment).

Syntax max(x)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Das Feld, dessen Werte zu vergleichen sind

Ergebnis

Typ | Beschreibung
als Eingabe | Der maximale Wert ungleich Null im Feld x (wenn möglich pro Gruppe oder Segment).
Anmerkung:
  • Verwechseln Sie diese aggregations-Funktion nicht mit der multi-argument-Funktion [siehe max (zwei oder mehr Argumente), maxnonnull] gleichen Namens.
  • In einem Ableitungskontext akzeptiert diese Funktion kein String- oder datumbewertetes Feld als Argument.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

min (ein Argument)

Übergeordnetes Thema: Aggregationsfunktionen


mean (ein Argument)

Ziel Berechnen des Mittelwerts (gemeinsamer Durchschnitt) der Werte ungleich Null in einem Feld (möglicherweise pro Gruppe oder Segment).

Syntax mean(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Das Feld, dessen Mittelwert zu berechnen ist

Ergebnis

Typ | Beschreibung
Reelle Zahl | Der Mittelwert der Werte ungleich Null im Feld x (möglicherweise pro Gruppe oder Segment)
Anmerkung:

Verwechseln Sie diese aggregations-Funktion nicht mit der multi-argument-Funktion [siehe mean (zwei oder mehr Argumente), meannonnull] gleichen Namens.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

median

Modus

Übergeordnetes Thema: Aggregationsfunktionen


median

Ziel Berechnen des Medians (oder Zentralwert) der Werte ungleich Null in einem Feld (möglicherweise pro Gruppe oder Segment).

Syntax median(x)

Argumente

Typ | Name | Beschreibung
Integer, reelle Zahl oder String | x | Das Feld, dessen Median zu berechnen ist

Ergebnis

Typ | Beschreibung
als Eingabe | Der Median der Werte ungleich Null im Feld x (möglicherweise pro Gruppe oder Segment)
Anmerkung:

Sie können diese Funktion nicht in einer Decision Studio-Ableitung, der Ableitungsdatei für qsderive oder dem äquivalenten Fenster „Felder ableiten“, in der Tracker-Datei für qstrack oder in einer Auswahldatei für qsselect verwenden.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

mean (ein Argument)

Modus

Übergeordnetes Thema: Aggregationsfunktionen


min (ein Argument)

Ziel Berechnen des minimalen Werts ungleich Null in einem Feld (möglicherweise pro Gruppe oder Segment).

Syntax min(x)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Das Feld, dessen Werte zu vergleichen sind

Ergebnis

Typ | Beschreibung
als Eingabe | Der minimale Wert ungleich Null im Feld x (möglicherweise pro Gruppe oder Segment)
Anmerkung:
  • Verwechseln Sie diese aggregations-Funktion nicht mit der multi-argument-Funktion [siehe min (zwei oder mehr Argumente), minnonnull] gleichen Namens.
  • In einem Ableitungskontext akzeptiert diese Funktion kein String- oder datumbewertetes Feld als Argument.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

max (ein Argument)

Übergeordnetes Thema: Aggregationsfunktionen


Modus

Ziel Berechnen des Modus (häufigster Wert) der Werte ungleich Null in einem Feld (möglicherweise pro Gruppe oder Segment).

Syntax mode(x)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Das Feld, dessen Modus zu berechnen ist

Ergebnis

Typ | Beschreibung
als Eingabe | Der Modus der Werte ungleich Null im Feld x (möglicherweise pro Gruppe oder Segment)
Anmerkung:
  • Im Fall einer Bindung für den häufigsten Wert gibt die Funktion die am wenigste bindende Zahl, das früheste Bindungsdatum oder die alphabetisch früheste bindender String zurück.
  • Sie können diese Funktion nicht in einer Decision Studio-Ableitung, der Ableitungsdatei für qsderive oder dem äquivalenten Fenster „Felder ableiten“, in der Tracker-Datei für qstrack oder in einer Auswahldatei für qsselect verwenden.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

mean (ein Argument)

median

moderatio

Übergeordnetes Thema: Aggregationsfunktionen


moderatio

Ziel Berechnen des Verhältnisses der Datensätze ungleich Null, die den häufigsten Wert ungleich Null in einem Feld beinhalten (möglicherweise pro Gruppe oder Segment).

Syntax moderatio(x)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Das Feld, dessen Modusverhältnis berechnet werden soll

Ergebnis

Typ | Beschreibung
Reelle Zahl | Das Modusverhältnis des Feldes x (möglicherweise pro Gruppe oder Segment)
Anmerkung:

Sie können diese Funktion nicht in einer Decision Studio-Ableitung, der Ableitungsdatei für qsderive oder dem äquivalenten Fenster „Felder ableiten“, in der Tracker-Datei für qstrack oder in einer Auswahldatei für qsselect verwenden.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

Modus

Übergeordnetes Thema: Aggregationsfunktionen


percentage

Syntax percentage()

Ziel Berechnen der Anzahl der Datensätze in einem Kreuztabellensegment als Prozentsatz der Gesamtsumme.

Argumente Keine

Ergebnis

Typ | Beschreibung
Reelle Zahl | Der Prozentsatz der Datensätze (möglicherweise pro Gruppe oder Segment)
Anmerkung:

Sie können diese Funktion nur in einer Decision Studio-Ableitung, der Ableitungsdatei für qsderive oder dem äquivalenten Fenster Felder ableiten, in der Tracker-Datei für qstrack oder in einer Auswahldatei für qsselect verwenden.

Siehe auch

Aggregationsfunktionen für Kennzahlen und Ableitungen

Übergeordnetes Thema: Aggregationsfunktionen


percentagerate

Ziel Für ein binäres (1/0) Feld den Anteil der Datensätze ungleich Null als Prozentsatz berechnen, die den Wert 1 beinhalten.

Syntax percentagerate(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Das zu berücksichtigende binäre Feld

Ergebnis

Typ | Beschreibung
Reelle Zahl | Der Prozentsatz der Datensätze in einem binären Feld mit dem Wert 1 (möglicherweise pro Gruppe oder Segment)
Anmerkung:

Sie können diese Funktion nicht in einer Aggregationsdatei [siehe Verwenden von Aggregationsfunktionen und der „where“ und „default“-Klauseln] oder Statistikdatei [siehe Überprüfen von Fokusstatistiken: die calculate-Anweisung] für qsmeasure oder dem äquivalenten Fenster „Datensätze hinzufügen“ oder in einer Statistikdatei für qstrack verwenden.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

Übergeordnetes Thema: Aggregationsfunktionen


Proportion

Ziel Berechne die Anzahl der Datensätze pro Kunde oder Segment als Proportion der Gesamtzahl von Datensätzen.

Syntax proportion()

Argumente Keine

Ergebnis

Typ | Beschreibung
Reelle Zahl | Die Anzahl der Datensätze für einen Kunden oder in einem Kreuztabellensegment, relativ zur Gesamtzahl der Datensätze
Anmerkung:

Sie können diese Funktion ausschließlich mit Kreuztabellen in Decision Studio [siehe Aggregationsfunktionen für Kreuztabellen] für die Visualisierung von Daten verwenden.

Siehe auch

Aggregationsfunktionen für Kreuztabellen
Übergeordnetes Thema: Aggregationsfunktionen


segindex

Ziel Generieren einer Indexnummer, die ein Segment repräsentiert.

Syntax segindex()

Argumente Keine

Ergebnis

Typ | Beschreibung
ganze Zahl | Eine positive Zahl, die ein Segment in einer Kreuztabelle eindeutig identifiziert
Anmerkung:
  • Wenn das Ergebnis Null oder unklassifiziert ist oder leere Segmente in einer Kreuztabellenansicht ausgeblendet sind, erhalten Sie dennoch einen Segmentindex. Deshalb können Lücken in der Reihenfolge der sichtbaren Indizes auftreten.
  • Sie können diese Funktion nicht in einer Aggregationsdatei [siehe Verwenden von Aggregationsfunktionen und der „where“ und „default“-Klauseln] oder Statistikdatei [siehe Überprüfen von Fokusstatistiken: die calculate-Anweisung] für qsmeasure oder dem äquivalenten Fenster „Datensätze hinzufügen“ oder in einer Statistikdatei für qstrack verwenden.

Beispiel R–2: Markieren eines approximativen Dezils

Sie können ein Feld „myfield“ in zehn Klassen gleicher Gesamtmenge einteilen und ein Feld „Dezile“ ableiten:

segindex() by myfield

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

Lagerfach

Übergeordnetes Thema: Aggregationsfunktionen


significance

Ziel Berechnen der statistischen Signifikanz einer Diskrepanz zwischen dem Mittelwert eines Felds für ein Kreuztabellensegment und dem Mittelwert desselben Felds für die ganze Gesamtmenge.

Syntax significance(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Das zu berücksichtigende Feld

Ergebnis

Typ | Beschreibung
Reelle Zahl | Ein Wert zwischen -1 und 1, dessen Vorzeichen die Richtung angibt, in die der Mittelwert von x des Segments vom Mittelwert von x der Gesamtmenge abweicht, und dessen absoluter Wert die statistische Signifikanz dieser Abweichung unter Berücksichtigung der Segmentgröße angibt
Anmerkung:

Sie können diese Funktion nicht in einer Aggregationsdatei [siehe Verwenden von Aggregationsfunktionen und der „where“ und „default“-Klauseln] oder Statistikdatei [siehe Überprüfen von Fokusstatistiken: die calculate-Anweisung] für qsmeasure oder dem äquivalenten Fenster „Datensätze hinzufügen“ oder in einer Statistikdatei für qstrack verwenden.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

confintlower

confintupper

Übergeordnetes Thema: Aggregationsfunktionen


stdev

Ziel Berechnen der Standardabweichung der Werte ungleich Null in einem Feld (möglicherweise pro Gruppe oder Segment).

Syntax stdev(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Das Feld, dessen Standardabweichung zu berechnen ist

Ergebnis

Typ | Beschreibung
Reelle Zahl | Die Standardabweichung der Werte ungleich Null im Feld x (möglicherweise pro Gruppe oder Segment)

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

Übergeordnetes Thema: Aggregationsfunktionen


sum (ein Argument)

Zweck Berechnen der Summe der Werte ungleich Null in einem Feld (wenn möglich pro Gruppe oder Segment).

Syntax sum(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Das Feld, dessen Werte summiert werden sollen

Ergebnis

Typ | Beschreibung
als Eingabe | Die Summe der Werte ungleich Null in einem Feld x (wenn möglich pro Gruppe oder Segment)
Anmerkung:
  • Verwechseln Sie diese aggregations-Funktion nicht mit der multi-argument-Funktion [siehe sum (zwei oder mehr Argumente), sumnonnull] gleichen Namens.
  • Beachten Sie, dass, wenn die Summe-Aggregationsfunktion auf ein leeres Datensatzset (z. B. als ein Ergebnis von Datensatzfilterung) angewendet wird, das Ergebnis Null ist. Sie sollten dieses Verhalten normalerweise überschreiben, indem Sie den Standardwert auf 0 setzen.

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

Übergeordnetes Thema: Aggregationsfunktionen


Abweichung

Ziel Berechnen der Varianz (statistische Abweichung) der Werte ungleich Null in einem Feld (möglicherweise pro Gruppe oder Segment).

Syntax variance(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Das Feld, dessen Varianz zu berechnen ist

Ergebnis

Typ | Beschreibung
Reelle Zahl | Die Varianz der Werte ungleich Null im Feld x (möglicherweise pro Gruppe oder Segment)

Siehe auch

Aggregationsfunktionen für Kreuztabellen

Aggregationsfunktionen für Kennzahlen und Ableitungen

Übergeordnetes Thema: Aggregationsfunktionen


Transaction Measurement Language (TML) Referenz

  • Informationen zur Transaction Measurement Language
  • TML-Syntax
  • Felddefinition: Das create-Statement
  • Verwenden von Aggregationsfunktionen und der „where“ und „default“-Klauseln
  • Verteilungsaggregationen: Die by-Klausel
  • Überprüfen von Fokusstatistiken: die calculate-Anweisung
  • Aggregationsfunktionen für Kennzahlen und Ableitungen
  • Reservierte Worte in TML


Informationen zur Transaction Measurement Language

Transaction Measurement Language (TML) ist eine Sammlung leichter syntaktischer Hüllen um FDL-Ausdrücke, die zur Spezifizierung von Feldabweichungen und Aggregationen im Zusammenhang mit den Assistenten „Felder ableiten“ [siehe Felder in einem Fokus mit Portrait Miner ableiten] und „Datensätze hinzufügen“ [siehe Konvertierung eines transaktionsorientierten Fokusses in einen kundenorientierten Fokus] und den Portrait Miner-Dateierstellungsbefehlen qsderive, qsmeasure, qstrack und qsselect verwendet werden.

Siehe auch

Informatinoen zur Field Derivation Language

TML-Syntax

Verwenden der Dateierstellungsbefehle in Portrait Miner für das Importieren, Verarbeiten und Exportieren von Daten

Übergeordnetes Thema: Transaction Measurement Language (TML) Referenz


TML-Syntax

Eine Ableitungs-, Tracker-, Auswahl- oder Aggregationsdatei enthält eine oder mehrere TML create-Statements, eine Statistikdatei hingegen enthält eine oder mehrere calculate-Statements.
  • TML ist eine von Groß- und Kleinschreibung abhängige Sprache:
    • TML Schlüsselwörter (create, by, string etc.) werden kleingeschrieben, ausgenommen davon ist STATISTIC.
    • Die Namen der Aggregationsfunktionen [siehe Aggregationsfunktionen für Kennzahlen und Ableitungen] werden kleingeschrieben.
    • Die Namen Average, average und AVERAGE beziehen sich alle auf unterschiedliche Felder oder Statistiken.
  • Namen für Felder und Statistiken müssen mit einem Buchstaben (A–Z oder a–z) beginnen, dürfen nur Buchstaben, Ziffern und den Unterstrich (_) enthalten und nicht länger als 128 Zeichen sein. Sie können optional in einfachen Anführungszeichen stehen, zum Beispiel 'CustomerID'. Sie müssen den Namen eines Feldes oder einer Statistik in einfache Anführungszeichen setzen, wenn er mit einem für TML oder FDL reservierten Wort übereinstimmt oder sich von ihm nur durch Groß-/Kleinschreibung unterscheidet.
  • Die TML-Syntax wird mit „Bahndiagrammen“ wie folgt beschrieben:

    Solange Sie den Pfeilen folgen und nicht zurückkehren, führt jeder Pfad in einem Bahndiagramm zu syntaktisch gültigem (aber nicht notwendigerweise sinnvollem) TML:
    • Worte in ovalen/kreisförmigen Markierungen (wie create) sind TML-„Schlüsselwörter“. Sie müssen sie genau so schreiben, wie sie angegeben werden.
    • Sie müssen auch die Zeichensetzung in ovalen Markierungen (wie „:“ und „:=“) exakt wie angegeben übernehmen (Sie dürfen keine Leerzeichen zwischen „:“ und „=“ in „:=“ einfügen).
    • Vergessen Sie nicht das Semikolon, mit dem jedes TML-Statement beendet wird.
    • Begriffe in rechteckigen Markierungen (wie expression) beziehen sich auf andere Bahndiagramme oder Formen, die andernorts in Worten beschrieben sind, Sie dürfen diese nicht wörtlich wiedergeben.
  • TML ist eine frei formatierte Sprache: Sie können Zeilen umbrechen oder zusätzliche Leerzeichen zwischen syntaktische Elemente (in ovalen/kreisförmigen Feldern in Bahndiagrammen) setzen, ohne die Interpretation einer Ableitungs-, Tracker-, Auswahl-, Aggregations- oder Statistikdatei zu verändern.
  • So wie Sie Leerzeichen zwischen syntaktischen Elemente einfügen können, können Sie auch Kommentare einfügen, die mit zwei Schrägstrichen („//“) beginnen und sich bis zum Zeilenende fortsetzen können.
  • Wenn die TML-Syntax einen Ausdruck verlangt, können Sie jeden FDL-Ausdruck [siehe Formeln], mit Ausnahme der Ausdrücke, die ein für TML reserviertes Wort, ein Semikolon oder geschweifte Klammern {...} beinhalten, verwenden, diese Ausdrücke müssen in runden Klammern (...) geschrieben werden.

Siehe auch

Informationen zur Transaction Measurement Language

Überprüfen von Fokusstatistiken: die calculate-Anweisung

Felddefinition: Das create-Statement

Reservierte Worte in FDL

Reservierte Worte in TML

Übergeordnetes Thema: Transaction Measurement Language (TML) Referenz


Felddefinition: Das create-Statement

Das create-Statement definiert ein Feld durch Ableitung oder Aggregation in Abhängigkeit vom Kontext, in dem es erscheint.

Ableitungen Die Ableitungsdatei für qsderive oder das äquivalente Fenster „Felder ableiten“, die Tracker-Datei für qstrack und die Auswahldatei für qsselect müssen create-Statements in folgender Form enthalten:

Die Aggregationsdatei für qsmeasure oder das äquivalente Fenster „Datensätze aggregieren“ können optional create-Statements in folgender Form enthalten:

In beiden Fällen definiert das create-Statement ein Feld mit der Bezeichnung name im Sinne eines FDL-expression [siehe Formeln]. Der Datentyp der Felder ist der Datentyp des Ausdrucks, außer Sie überschreiben es durch die Spezifizierung eines kompatiblen type [siehe Datentypen].
  • Für jedes nachfolgende create-Statement in der Ableitungsdatei leiten qsderive oder das Fenster „Felder ableiten“ ein Feld im Ausgabefokus mit dem vorgegebenen „Ausdruck“ ab, welches sich sowohl auf die Felder im Quellfokus als auch auf die in der Ableitungsdatei abgeleiteten Felder bezieht.
  • Für jedes nachfolgende create-Statement in der Tracker-Datei leitet qstrack ein Feld mit dem vorgegebenen „Ausdruck“ ab, welches sich sowohl auf die Felder im Quellfokus und auf zuvor in der Tracker-Datei abgeleiteten Felder bezieht, als auch auf Fokusstatistiken, die in Statistikdateien definiert wurden. Der Ausdruck bezieht normalerweise Statusvariablen mit ein [siehe Variablen].
  • Mit einer vorgegebenen Auswahldatei leitet qsselect ein Feld ab, welches standardmäßig dem ersten create-Statement entspricht, wobei alle anderen Statements in der Datei ignoriert werden. Der definierende „Ausdruck“ muss vom Typ boolesch (oder kompatibel) sein.
  • Für jedes nachfolgende create-Statement dieser Form in der Aggregationsdatei, leiten qsmeasure oder das Fenster „Datensätze aggregieren“ ein Feld im Ausgabefokus mit dem vorgegebenen „Ausdruck“ ab, welches sich sowohl auf die in der zuvor abgeleiteten Aggregationsdatei und auf die in einer Statistikdatei definierten Fokusstatistiken bezieht.
  • Eine temporary Aussage hat dieselbe Wirkung wie eine create-Aussage, das Feld erscheint jedoch nicht im Ausgabefokus. Sie können sich jedoch in nachfolgenden Ausdrücken noch immer auf das temporäre Feld in der Aggregationsdatei beziehen.

Aggregationen Die Aggregationsdatei für qsmeasure oder das äquivalente Datensätze aggregieren-Fenster können create-Statements in folgender Form enthalten:

Für jedes create-Statement in dieser Form in der Aggregationsdatei, leiten qsmeasure oder das Fenster „Datensätze aggregieren“ effektiv ein virtuelles Feld ab, das dem „Ausdruck“ in der „Aggregationsfunktion“ folgt. Dieser Ausdruck kann sich auf Felder im Quellfokus beziehen.

Nach dem Ableiten des virtuellen Feldes wendet qsmeasure oder das Fenster „Datensätze aggregieren„ die Aggregationsfunktion an [siehe Verwenden von Aggregationsfunktionen und der „where“ und „default“-Klauseln].

Der standardmäßige Datentyp des sich ergebenden Feldes (Felder) hängt von der Aggregationsfunktion und den in den Ausdruck einbezogenen Werten, Operatoren und Funktionen, auf die er angewendet wird, ab, kann jedoch durch Angabe eines kompatiblen Typs überschrieben werden.

Eine temporary Aussage hat dieselbe Wirkung wie eine create-Aussage, das Feld erscheint jedoch nicht im Ausgabefokus. Sie können sich jedoch in nachfolgenden Ausdrücken noch immer auf das temporäre Feld in der Aggregationsdatei beziehen.

Anmerkung:
  • In qsderive oder „Felder ableiten“ Ableitungsdateien, qsselect Auswahldateien und qstrack Trackerdateien kann der „Ausdruck“ Feldstatistiken, globale Variablen und Funktionen in dieser Form enthalten. Diese FDL-Eigenschaften stehen in einer qsmeasure oder „Datensätze aggregieren“ Aggregationsdatei nicht zur Verfügung.
  • Sie müssen zusätzliche runde Klammern um den „Ausdruck“ setzen, falls dieser ein Semikolon, geschwungene Klammern oder ein für TML reserviertes Wort enthält [siehe Reservierte Worte in TML].
  • Jedes create-Statement muss mit einer neuen Zeile beginnen.

Beispiele Vorgegeben ist die Ableitungsdatei derivations-customer.tml mit folgendem Inhalt:

// Length of standing of customer in months
create CustMonths := countwholemonths(StartDate, today());
// A key field of extended length
create CustomerID_24 : string(24) := CustomerID;
Wenden Sie diese Anleitungen auf den Fokus RetailCustApril.ftr an, um einen neuen Fokus RetailCustAprilDeriv.ftr zu erstellen: qsderive -derivations derivations-customer.tml\cmdlinecont -input RetailCustApril.ftr -output RetailCustAprilDeriv.ftr Angenommen, die Auswahldatei selections-customer.tml enthält folgendes:
// Select male customers aged between 18 and 65 inclusive.
create Selection := Gender = 1 and Age >= 18 and Age <= 65;
Wenden Sie diese Auswahl auf den Fokus RetailCustApril.ftr an, um einen neuen Fokus RetailCustAprilSelection.ftr zu erstellen:
qsselect -selections selections-customer.tml
         -input RetailCustApril.ftr%
         -output RetailCustAprilSelection.ftr
Vorgegeben ist die Aggregationsdatei aggregations-mostRecent.tml mit folgendem Inhalt:
temporary LastPurchase := max(PurchaseDate);
create AvgTransVal := mean(Amount - 0.01 * PointsRedeemed);
create NumTrans := count();
create MonthsSinceLastPurchase :=
       countwholemonths(LastPurchase, today());

Wenden Sie diese Aggregationen auf den Fokus RetailTransApril.ftr an, um einen kundenorientierten Fokus RetailAggRecentApril zu erstellen:

qsmeasure -aggregations aggregations-mostRecent.tml
          -input RetailTransAprilSorted.ftr -output RetailAggRecentApril%
          -keys CustomerID

Siehe auch

Aggregationsfunktionen für Kennzahlen und Ableitungen

Verteilungsaggregationen: Die by-Klausel

Konvertierung eines transaktionsorientierten Fokusses in einen kundenorientierten Fokus

Übergeordnetes Thema: Transaction Measurement Language (TML) Referenz


Verwenden von Aggregationsfunktionen und der „where“ und „default“-Klauseln

Sie können mit qsmeasure oder dem äquivalenten Fenster Datensätze aggregieren Datensätze hinzufügen.

Wenn Sie ein create-Statement in einer Aggregationsdatei [siehe Felddefinition: Das create-Statement] benutzen, leiten qsmeasure oder das Fenster „Datensätze aggregieren“ effektiv ein virtuelles Feld ab, das dem „Ausdruck“ in Klammern nach der „Aggregationsfunktion“ folgt.

Konzeptuell dividiert qsmeasure oder das Fenster Datensätze hinzufügen die Datensätze im Quellfokus (erweitert um das virtuelle Feld) in Datensatzgruppen mit dem gleichen Schlüsselfeldwert. Für jede Datensatzgruppe (entsprechend einem einzigen Schlüsselfeldwert) wenden qsmeasure oder das Fenster „Datensätze aggregieren“ die Aggregationsfunktion auf die Werte des virtuellen Feldes innerhalb dieser Datensätze an, um einen einzigen Ergebniswert auszugeben.

Die Ergebniswerte für alle Gruppen zusammengenommen bilden ein neues Feld mit dem in der create-Anweisung angegebenen Namen, es sei denn, die create-Anweisung enthält eine by-Bedingung [siehe Verteilungsaggregationen: Die by-Klausel].

Innerhalb jeder Datensatzgruppe mit einem gemeinsamen Schlüsselfeldwert, ignorieren bestimmte Aggregationsdatei Datensätze, wenn das virtuelle Feld Null enthält [siehe Der Nullwert].

Falls das create-Statement eine where-Klausel enthält, ignoriert die Aggregationsfunktion Datensätze für die der zugewiesene „Ausdruck“ mit 0 („false“) überprüft wurde. Dieser Ausdruck kann sich auf Felder im Quellfokus beziehen.

Da Aggregationsfunktionen einige der Datensätze in einer Gruppe mit einem gemeinsamen Schlüsselfeldwert ignorieren können, ist es möglich, dass alle Datensätze in der Gruppe übersprungen werden. In diesem Falle geben viele Aggregationsfunktionen den Wert gleich Null zurück. Durch Einschließen einer „Standard“-Klausel können Sie einen konstanten „Ausdruck“ spezifizieren, der überprüft wird, anstatt das die Aggregation in dem eintretenden Ereignis Null zurückgibt.

Anmerkung:

Wenn Sie die Funktion „sum aggregation“ [siehe sum (ein Argument)] verwenden, müssen Sie für gewöhnlich die Standardsumme 0 festlegen. Wenn Sie keine „Standard“-Klausel verwenden, ist die Summe einer leeren Datensatzauswall Null – ein Ergebnis, dass Sie wahrscheinlich nicht wünschen.

Beispiele Bezüglich der Aggregationsdatei aggregations-purchaseSummary.tml mit folgendem Inhalt:

create firstPurchaseDate := first(PurchaseDate);
create commonPaymentMethod := mode(PaymentMethod);
create Spend := sum(Amount) default 0;
create SpendInStore800 := sum(Amount)
       where Store = "0800" default 0;
create proportionSpendInStore800 := SpendInStore800 / Spend;
create NumTransCRRedeemed := count()
       where PaymentMethod = "CR" and not isnull(PointsRedeemed);

Wenden Sie diese Aggregationen auf den Fokus RetailTransApril.ftr an, um einen kundenorientierten Fokus RetailAggSummaryApril zu erstellen:

qsmeasure -aggregations aggregations-purchaseSummary.tml
          -input RetailTransAprilSorted.ftr -output RetailAggSummaryApril
          -keys CustomerID

Siehe auch

Aggregationsfunktionen für Kennzahlen und Ableitungen

Formeln

Übergeordnetes Thema: Transaction Measurement Language (TML) Referenz


Verteilungsaggregationen: Die by-Klausel

Die Aggregationsdatei für qsmeasure oder das entsprechende Fenster Datensätze hinzufügen enthält eine Sequenz von create-Anweisungen [siehe Felddefinition: Das create-Statement]. Als Teil eines solchen create-Statements können Sie optional eine by-Klausel hinzufügen, um Ihre Aggregation für die Anwendung von entweder einer split-Funktion oder der bin-Funktion auf einen von anderen Feldern abgeleiteten Ausdruck aufzuschlüsseln.
Für jedes mögliche Integer i, zurückgegeben von der split-Funktion oder bin-Funktion, wird qsmeasure oder das Fenster „Datensätze aggregieren“ eine separates Feld mit von diesen Datensätzen hinzugefügten Werten, welche die Funktion Anwendung mit i überprüft, erstellen. Der Name von jedem dieser in Beziehung stehenden Felder wird aus dem „Name“ im create-Statement zusammen mit einer Erweiterung, die von der für die Verteilung der Aggregation verwendeten Funktion abhängt, gebildet.
  • Die folgenden integrierten split-Funktionen sind verfügbar (mit gegebenem Feldnamenserweiterungen entsprechend den aufeinanderfolgenden Funktionswerten):
    Funktion | Feldnamenserweiterungen
    day | „_1,“ „_2,“ „_3,“ ..., „_31“
    dayofweek | „Son,“ „Mon,“ „Die,“ ..., „Sam“
    hour | „0000,“ „0100,“ „0200“ ..., „2300“
    isnull | „NonNull,“ „Null“
    match | „KeinTreffer,“ „Treffer“
    Mitglied | "NichtMitglied," "Mitglied"
    minute | "0," "1," "2," ..., "59"
    month | „Jan,“ „Feb,“ „Mär,“ ..., „Dez“
    second | "0," "1," "2," ..., "59"
    sgn | „Negativ,“ „0,“ „Positiv“
    strmember | "NichtMitglied," "Mitglied"
    weekofyear | "_1," "_2," "_3," ..., "_53"
  • Sie können die bin-Funktion verwenden, um eine FDL-Klasseneinteilung für einen Ausdruck anzuwenden. Als split-Funktion verwendet, ergibt die bin-Funktion aufsteigende Feldnamenserweiterungen „_1,“ „_2,“ ..., „_n,“ „_null,“ und „_other“ (wobei n von der Anzahl der Klassen in der Klasseneinteilung abhängt).
  • Sie können auch Ihre eigene Split-Funktion definieren [siehe Benutzerdefinierte Funktionen]. Das Attribut element_names definiert die Feldnamenerweiterungen entsprechend den von der Funktion zurückgegebenen Werten.

Beispiele Bezüglich der Aggregationsdatei aggregations-builtinSplit.tml mit folgendem Inhalt:

create numberPurchases := count();
create numberPurchasesOn_ := count() by dayofweek(PurchaseDate);
create proportionPurchases_Mon :=
       numberPurchasesOn_Mon / numberPurchases;
create purchaseAmountIn_ :=
       sum(Amount) by month(PurchaseDate) default 0;

Wenden Sie diese Aggregationen auf den Fokus RetailTransApril.ftr an, um einen kundenorientierten Fokus RetailDateSplitsApril.ftr mit den Feldern CustomerID, numberPurchases, numberPurchasesOn_Sun, numberPurchasesOn_Mon, ..., numberPurchasesOn_Sat, proportionPurchases_Mon, and purchaseAmountIn_Jan, purchaseAmountIn_Feb, ..., purchaseAmountIn_Dec: zu erstellen

qsmeasure -aggregations aggregations-builtinSplit.tml -keys CustomerID -input RetailTransApril.ftr -output RetailDateSplitsApril.ftr

Bezüglich der Aggregationsdatei aggregations-builtinSplit.tml mit folgendem Inhalt:

create numberPurchasesAmountBand :=
       count() by bin(EqualRange(20,100,4),Amount);
create numberPurchasesDateBand := count() by
       bin(PrePost(todate(19990401), todate(19990501),
       todate(19990601)), PurchaseDate);
create ratioPrePost :=
       numberPurchasesDateBand_3 / numberPurchasesDateBand_2;

Wenden Sie diese Aggregationen auf den Fokus RetailTransApril.ftr an, um einen Kunden-orientierten Fokus RetailRangeSplitsApril.ftr mit den Feldern CustomerID, numberPurchasesAmountBand_1, numberPurchasesAmountBand_2, ..., numberPurchasesAmountBand_6, numberPurchasesAmountBand_null, numberPurchasesAmountBand_other (2 Endklassen entsprechend, 4 internen Klassen und die Null und nicht klassifizierte Klasse), numberPurchasesDateBand_1, numberPurchasesDateBand_2, ..., numberPurchasesDateBand_4, numberPurchasesDateBand_null, numberPurchasesDateBand_other, and ratioPrePost: zu erstellen

qsmeasure -aggregations aggregations-binSplit.tml -keys CustomerID -input RetailTransApril.ftr -output RetailRangeSplitsApril.ftr

Bezüglich der SQL-Abfragedatei fdl-functions-storeGroups.fdl, die folgendes beinhaltet:

function StoreGroupFunction( Store )
[
   element_names = "North, South, East, West"
]
{
case
    Store = "0000" or Store = "0800" : 1;
    Store = "0300" or Store = "0600" or Store = "0700" : 2;
    Store = "0100" or Store = "0400" : 3;
    default : 4;
}

Bezüglich der Aggregationsdatei aggregations-builtinSplit.tml mit folgendem Inhalt:

create totalPurchases := sum(Amount);
create totalPurchasesByStore_ :=
       sum(Amount) by StoreGroupFunction( Store );
create proportionPurchases_North :=
       totalPurchasesByStore_North / totalPurchases;

Wenden Sie die Aggregationen auf den Fokus RetailTransApril.ftr an, um einen Kunden-orientieren Fokus RetailGroupSplitsApril.ftr mit den Feldern CustomerID, totalPurchases, totalPurchasesByStore_North, totalPurchasesByStore_South, totalPurchasesByStore_East, totalPurchasesByStore_West, and proportionPurchases_North: zu erstellen

qsmeasure -aggregations aggregations-userDefinedSplit.tml
    -library fdl-functions-storeGroups.fdl
    -keys CustomerID
    -input RetailTransApril.ftr -output RetailGroupSplitsApril.ftr

Siehe auch

Aggregationsfunktionen für Kennzahlen und Ableitungen

Formeln

Verwenden von Aggregationsfunktionen und der „where“ und „default“-Klauseln

Übergeordnetes Thema: Transaction Measurement Language (TML) Referenz


Überprüfen von Fokusstatistiken: die calculate-Anweisung

Die Statistikdatei für qsmeasure, das äquivalente Fenster „Datensätze hinzufügen“ oder qstrack enthält calculate-Anweisungen in folgender Form:

Die calculate-Anweisung definiert eine Fokusstatistik namens name in dem Sinne, dass eine „Aggregationsfunktion“ auf einen FDL-Ausdruck [siehe Formeln] angewendet wird, der sich auf Felder im Quell-Fokus beziehen kann.

Wie im Fall einer Kennzahl [siehe Verwenden von Aggregationsfunktionen und der „where“ und „default“-Klauseln] leiten qsmeasure, qstrack oder das Fenster „Datensätze hinzufügen“ tatsächlich ein virtuelles Feld entsprechend dem „Ausdruck“ ab, der in Klammern hinter der „Aggregationsfunktion“ steht.

Die calculate-Anweisung produziert einen einzelnen Ergebniswert, der durch Anwendung der Aggregationsfunktion auf alle Werte im virtuellen Feld gewonnen wird. (Im Gegensatz dazu liefert eine create-Anweisung in einer Aggregationsdatei ein „Feld “, in dem jeder Wert durch Anwenden der Aggregationsfunktion auf die Werte im virtuellen Feld für eine Gruppe von Datensätzen gewonnen wird.)

Der Standarddatentyp einer Fokusstatistik hängt von der Aggregationsfunktion und den Werten, Operatoren und Funktionen im Ausdruck ab, für den er gilt. Sie können ihn jedoch überschreiben, indem Sie einen kompatiblen „Typ“ [siehe Datentypen] angeben.

Wenn die create-Anweisung eine where-Klausel enthält, ignoriert die Aggregationsfunktion Datensätze, bei denen der zugehörige „Ausdruck“ 0 („false“) ergibt. Dieser Ausdruck kann sich auf Felder im Quellfokus beziehen.

Nachdem Sie eine Fokusstatistik in der Statistikdatei definiert haben, können Sie diese auf Ausdrücke in der Aggregations- oder Tracker-Datei mithilfe der Sonderform STATISTIC.name in Beziehung setzen. Sie können diese Formel überall dort verwenden, wo Sie auf ein Feld in der Quellfokus- oder Tracker-Datei verweisen können.

Beispiele Bezüglich der Statistikdatei statistics-amount.tml mit folgendem Inhalt:

calculate averageAmount := mean(Amount);

Bezüglich der Aggregationsdatei aggregations-statistic.tml, die folgendes beinhaltet:

create averageSpend := mean(Amount);

create bigSpender := averageSpend > STATISTIC.averageAmount;

Wenden Sie diese Aggregationen auf den Fokus RetailTransApril.ftr an, um einen kundenorientierten Fokus RetailAprilBigSpenders.ftr mit den Feldern CustomerID, averageSpend und bigSpender: zu erstellen

qsmeasure -statistics statistics-amount.tml

-aggregations aggregations-statistic.tml

-keys CustomerID

-input RetailTransApril.ftr -output RetailAprilBigSpenders.ftr

Siehe auch

Aggregationsfunktionen für Kennzahlen und Ableitungen

Übergeordnetes Thema: Transaction Measurement Language (TML) Referenz


Aggregationsfunktionen für Kennzahlen und Ableitungen

Es gibt eine Vielzahl von Aggregationsfunktionen für die Verwendung in Kennzahlen und Abweichungen.

Eine Funktion in einem „Aggregierungskontext“ zu verwenden, heißt, sie \funccontextmeasure zu verwenden.

Eine Funktion in einem „Ableitungskontext“ zu verwenden, heißt, sie \funccontextderive zu verwenden.

Wenn nicht anderweitig angegeben, übernimmt eine Aggregationsfunktion einen numerischen Wert, einen String oder ein Datumsfeld als Argument.

Aggregationsfunktionen für Aggregierungen und Ableitungen Sie können folgende Aggregationsfunktionen sowohl in Aggregierungs- als auch in Ableitungskontexten verwenden:

Funktion | Ergebnis
count | Die Anzahl der Datensätze in der Gruppe/dem Segment (Diese Funktion übernimmt kein Argument.)
max [siehe max (ein Argument)] | Der maximale Wert ungleich Null im Feld für die Gruppe/das Segment (In einem Ableitungskontext akzeptiert diese Funktion keinen String-gewerteten Ausdruck als Argument.)
mean [siehe mean (ein Argument)] | Der Mittelwert (allgemeiner Durchschnitt) der Werte ungleich Null in dem Feld einer Gruppe/Segment (Diese Funktion erfordert einen numerischen Ausdruck als Argument.)
min [siehe min (ein Argument)] | Der minimale Wert ungleich Null im Feld für die Gruppe/Segment (In einem Ableitungskontext akzeptiert diese Funktion keinen String-gewerteten Ausdruck als Argument.)
stdev | Die Standardabweichung der Werte ungleich Null in dem Feld einer Gruppe/Segment (Diese Funktion erfordert einen numerischen Ausdruck als Argument.)
sum [siehe sum (ein Argument)] | Die Summe Werte ungleich Null in dem Feld einer Gruppe/Segment (Diese Funktion erfordert einen numerischen Ausdruck als Argument.)
Abweichung | Die Abweichung der Werte ungleich Null in dem Feld einer Gruppe/Segment (Diese Funktion erfordert einen numerischen Ausdruck als Argument.)

Aggregationsfunktionen nur für Aggregierungen Sie können folgende Aggregationsfunktionen nur in einem Aggregierungskontext verwenden:

Funktion | Ergebnis
any | Ein Wert im Feld, der ungleich Null ist und aus einem beliebigen Datensatz mit Wert ungleich Null in der Gruppe/dem Segment gezogen wurde
confintlower | Die Untergrenze eines 95% Konfidenzintervalls für den Mittelwert des Feldes in der Gruppe
confintupper | Die Obergrenze eines 95% Konfidenzintervalls für den Mittelwert des Feldes in der Gruppe
countnonnull [siehe countnonnull/countnonnulls] | Die Anzahl der Datensätze in der Gruppe, bei denen das Feld Werte ungleich Null enthält [siehe Der Nullwert] Benutzen Sie in Ableitungen stattdessen countnonnulls.
countnull [siehe countnull/countnulls] | Die Anzahl der Datensätze in der Gruppe, bei denen das Feld Null enthält [siehe Der Nullwert]. Benutzen Sie in Ableitungen stattdessen countnulls.
countunique | Die Anzahl der eindeutigen Werte, einschließlich Null, die im Feld auftreten.
countuniquenonnull | Die Anzahl der eindeutigen Werte, einschließlich dem Wert Null, die im Feld auftreten
first | Der erste Wert ungleich Null im Feld für die Gruppe
last | Der letzte Wert ungleich Null im Feld für die Gruppe
median | Der Median (Mittelwert) der Werte ungleich Null in dem Feld für die Gruppe (Diese Funktion erfordert einen numerischen oder String-gewerteten Ausdruck als Argument.)
Modus | Der Modus (häufigster Wert) der Werte ungleich Null in dem Feld für die Gruppe
moderatio | Das Verhältnis der Nicht-Null-Datensätze in der Gruppe, welche die häufigsten Wert ungleich Null in dem Feld enthält

Aggregationsfunktionen nur für Ableitungen Sie können folgende Aggregationsfunktionen nur im Ableitungskontext verwenden:

Funktion | Ergebnis
countnonnulls [siehe countnonnull/countnonnulls] | Die Anzahl der Datensätze in dem Segment bei denen das Feld Werte ungleich Null enthält [siehe Der Nullwert] Benutzen Sie in Kennzahlen stattdessen countnonnull.
countnulls [siehe countnull/countnulls] | Die Anzahl der Datensätze in dem Segment bei denen das Feld Null enthält [siehe Der Nullwert] Benutzen Sie in Kennzahlen stattdessen countnull.
percentage | Die Anzahl der Datensätze in dem Segment, als Prozentsatz der Gesamtanzahl der Datensätze (Diese Funktion übernimmt kein Argument.)
percentagerate | Der Prozentsatz der Nicht-Null-Datensätze im Segment die den Wert 1 im Feld enthalten Das Feld darf nur die Werte 0 und 1 enthalten.
segindex | Eine eindeutige positive Zahl zur Kennzeichnung des Segments innerhalb der Kreuztabelle, erstellt aus den Aufschlüsselungsfeldern (Diese Funktion übernimmt kein Argument.)
significance | Die statistische Signifikanz einer Diskrepanz zwischen dem Mittelwert des Feldes im Segment und dem Mittelwert des Feldes der Gesamtmenge mit einem Zeichen, welches die Richtung der Abweichung angibt. (Diese Funktion erfordert einen numerischen Ausdruck als Argument.)
Übergeordnetes Thema: Transaction Measurement Language (TML) Referenz


Reservierte Worte in TML

Folgende Tokens sind reservierte Worte in TML:

aggregation, all, and, as, auto, automatic, bin, binning, bool, boolean, by, calculate, constant, create, crosstab, date, default, description, dimension, double, drl, enum, except, fields, file, float, format, from, full, function, group, include, inplace, input, int, integer, join, left, long, merge, meta, modifiable, normal, on, open, outer, outfile, output, parameter, pragma, real, ref, reference, rename, right, separate_functions, short, show, show_empty_segments, show_summaries, sort, state, statistic, strbytes, string, suppress, table, temp, temporary, track, tracker, view, where

Um ein reserviertes Wort oder ein Wort, das sich nur durch Groß-/Kleinschreibung von einem reservierten Wort unterscheidet, als Feld- oder Statistiknamen in TML oder als Identifizierer [siehe Formeln] in FDL zu verwenden, müssen Sie es in einfache Anführungszeichen setzen, zum Beispiel 'Date'.

Siehe auch

Informationen zur Transaction Measurement Language

Reservierte Worte in FDL

Übergeordnetes Thema: Transaction Measurement Language (TML) Referenz


Field Derivation Language (FDL) Referenz

  • Informatinoen zur Field Derivation Language
  • Datentypen
  • Formeln
  • Konditionale Ausdrücke
  • Variablen
  • Benutzerdefinierte Funktionen
  • Integrierte Funktionen
  • Reservierte Worte in FDL
  • FDL-Operatoren
  • FDL-Funktionen
  • Klasseneinteilungen
  • Normale FDL-Ausdrücke


Informatinoen zur Field Derivation Language

Die Field Derivation Language (FDL) ist eine einfache Sprache zur Spezifizierung der Erstellung neuer Felder in den Portrait Miner-Fokussen. Sie können FDL in der Tabellenansicht [siehe Ein Feld mithilfe des Tabellenansichts ableiten] in Decision Studio, in den Assistenten Felder ableiten [siehe Felder in einem Fokus mit Portrait Miner ableiten] und Datensätze hinzufügen [siehe Konvertierung eines transaktionsorientierten Fokusses in einen kundenorientierten Fokus] sowie für die Portrait Miner-Datenerstellungsbefehle verwenden % An dieser Stelle lassen wir ihre Verwendung mit -records unberücksichtigt. qsderive, qsmeasure, qstrack und qsselect.
Sie können FDL verwenden, um:
  • Vorhandene Felder in einem Fokus zu transformieren, zu kombinieren und um eine Vielzahl anderer Berechnungen mit ihnen auszuführen
  • Einen Fokus in ein Set von Zufallsmustern aufzuteilen.
  • Segmentierungen und Vorhersagemodelle zu bestimmen
  • Datensätze entsprechend einem Kriterium Ihrer Wahl auszuwählen

Sie normalerweise in einfachen „einzeiligen“ Ausdrücken, wie die in Basisausdrücke beschriebenen, verwenden. Sie können sie aber auch benutzen, um Skripte mit komplexen datenabhängigen Ausführungspfaden zu erstellen.

Der FDL-Syntax beinhaltet:
  • Operatoren für Arithmetik [siehe Arithmetische Operatoren].
  • Operatoren für Vergleiche [siehe Vergleichsoperatoren] und für die Kombination von logischen Ausdrücken [siehe Logische Operatoren].
  • Zwei Alternativen für die konditionale Überprüfung von Statements: if...then...else und case [siehe Konditionale Ausdrücke].
  • Ein umfangreiches Set von integrierten Funktionen [siehe Integrierte Funktionen].
  • Die Fähigkeit allgemeine Transformationen als benutzerdefinierte Funktionen [siehe Benutzerdefinierte Funktionen] für Wiederverwendung und Teilen zu kapseln.
  • Variablen, um Werte für die Wiederverwendung innerhalb eines FDL-Skripts einschließlich (in einigen Kontexten) globaler Speichervariablen [siehe Globale Variable in Decision Studio] zu speichern.
  • Eine Möglichkeit um Kreuztabellen in Ableitungen zu integrieren .

Siehe auch

Informationen zur Transaction Measurement Language

Formeln

Übergeordnetes Thema: Field Derivation Language (FDL) Referenz


Datentypen

In FDL werden folgende Basisdatentypen unterstützt [siehe Informatinoen zur Field Derivation Language]:

Typ | Beschreibung | Beispiele (FDL-getreu)
ganze Zahl | Eine Zahl ohne fraktionalen Teil (zwischen -2 147 483 647 und 2 147 483 646) | 78004, -100
Reelle Zahl | Eine Zahl mit fraktionalem Teil, die intern als „Gleitkomma“-Zahl mit 15-stelliger Genauigkeit dargestellt wird (zwischen [image] und [image] , oder 0) | 42,3, -0,56
datum | Ein Datum/Zeit zwischen 1507 nach Christus und 3015 nach Christus mit einer Genauigkeit von 1 Sekunde | #2009/01/01, #2009/01/01:16:01:39
Zeichenfolge | Ein String, Textdaten darstellend | „Hallo“
Kleine Zahl | Eine kleine Zahl ohne fraktionalen Teil (zwischen qsminsmallint und qsmaxsmallint) | 42, -1
Anmerkung:
  • Falls Sie einen Integer-Literalwert (wie 12345678910) verwenden, der zu lang für einen Integer-Datentyp ist, erhalten Sie einen Überlauf. Sie können dieses häufig umgehen, indem Sie stattdessen einen reellen Wert verwenden: (In diesem Fall 12345678910,0).
  • Der Typ short Integer kann in Portrait Miner eingeschränkt verwendet werden und sollte nur, wenn unbedingt erforderlich, verwendet werden. Im Allgemeinen sollten Sie stattdessen den Typ Integer verwenden.
Übergeordnetes Thema: Field Derivation Language (FDL) Referenz

Der Nullwert

Zusätzlich zu den normalen Werten für die Grunddatentypen kann ein Feld oder Ausdruck vom Typ Integer, reelle Zahl, Datum oder String den Sonderwert Null haben. Der Nullwert stellt immer einen unbekannten Wert dar (wegen fehlenden Daten aus einem Überlauf in einer Berechnung — wie Division durch Null — oder aus einem anderen Grund). Er unterscheidet sich sowohl von 0 als auch des leeren Strings "".

FDL-Funktionen und Operatoren bewahren den Fehler, eingeführt durch ein Null-Argument oder Operator, welche der Null häufig einen Wert als Ergebnis geben. Es gibt allerdings auch Funktionen, insbesondere isnull und einige Aggregationsfunktionen, die den Nullwert besonders behandeln.

Beispiele

?

1 + null entspricht null.

1 != null entspricht null.

1 < null entspricht null.

null = null entspricht null.

null != null entspricht null.

false or null entspricht null.

true and null entspricht null.

true or null entspricht true.

false and null entspricht false.

Siehe auch

ifnull, nvl

Boolesche Daten

In FDL gibt es keinen formalen booleschen Datentyp (true/false). Trotzdem können Sie ein Integer-Feld (oder Variable) derartig behandeln, dass es nur die Werte 0 und 1 oder einen logischen Ausdruck wie „Income < 10000“ enthält, als wäre es ein boolescher Typ.

Logische Ausdrücke sind 1, wenn sie „true“ und 0 wenn sie „false“ sind. Bedingungsausdrücke verwenden diese Werte, um zu bestimmen, ob zwei oder mehr Ausdrücken zu überprüfen sind. Logische Operatoren arbeiten ebenfalls mit diesen Werten. Ein Wert 0 in einem Integer-Feld oder Variable wird als „false“ und jeder andere (ungleich Null) Wert wird als „true“ interpretiert.

Zusätzlich können die Schlüsselbegriffe „true“ und „false“ als boolesche Buchstabensymbole (welche entsprechend für 1 und 0 stehen) verwendet werden.

Typ-Kompatibilität

Die Datentypen Integer und reelle Zahl müssen „Typ-kompatibel“ sein, da sie sonst einen Integer-Wert anstelle eines reellen Wertes verwenden können (jedoch nicht umgekehrt), z. B. als Argument für eine Funktion. Datentypen „Datum“ und „Zeichenfolge“ sind untereinander nicht typkompatibel.

Die Operatoren eines binären Arithmetik-Operators [siehe Arithmetische Operatoren] oder Vergleichsoperators [siehe Vergleichsoperatoren] müssen typkompatibel sein. Iim Fall eines binären Arithmetikoperators müssen allerdings beide Operatoren numerisch sein, wobei das Ergebnis reell ist, auch wenn beide Operatoren integer sind.

Ebenfalls müssen die Ergebnisausdrücke in einem if- oder case-Ausdruck [siehe Konditionale Ausdrücke] typkompatibel sein, damit der Ergebnistyp vor der Überprüfung überprüft werden kann. Wenn integer- und reell-bewertete Ausdrücke gemischt werden, ist das Ergebnis ein reeller Wert.

Typkonvertierung

Neben der impliziten Datentypkonvertierung (was geschieht, wenn der Datentyp eines Ausdrucks dieses erzwingt) können Sie explizit mit den FDL-Funktionen tointeger, toreal, todate und tostring zwischen den Datentypen konvertieren.

Anmerkung: Bei der Konvertierung eines Strings in einen numerischen Wert wird jedes führende nicht-numerische Zeichen ignoriert.


Formeln

Ein „FDL-Ausdruck“ ist einer von folgenden:
  • Ein Basisausdruck [siehe Basisausdrücke]
  • Ein Bedingungsausdruck [siehe Konditionale Ausdrücke]
  • Eine Variableninitialisierung oder Zuordnung [siehe Variablen]
  • Eine durch Semikolon getrennte Liste der Ausdrücke (eine „Ausdrucksliste“), eingeschlossen von runden Klammern

Jeder Ausdruck hat einen zugewiesenen Datentyp [siehe Datentypen] und kann überprüft werden.

Um einen Ausdrucksliste in einem vorgegebenen Kontext zu überprüfen, überprüfen Sie jeden zugehörigen Ausdruck der Reihe nach vom Ersten zum Letzten. Der Wert der Ausdrucksliste als ein Ganzes ist der letzte berechnete Wert.

Anmerkung:
  • Der Datentyp wird automatisch geschlussfolgert. Sie können ihn nur durch die Verwendung einer lokalen Variablen mit dem erforderlichen Typ festlegen oder indem Sie einem Ausdruck verwenden, der den Typ erzwingt. Zum Beispiel erzwingt der folgende Ausdruck den reellen Wertetyp:

    if false then 0,0 else ...

  • Normalerweise verwenden Sie Ausdruckslisten im Kombination mit Variablenzuweisungen.
Übergeordnetes Thema: Field Derivation Language (FDL) Referenz

Basisausdrücke

Ein „Basisausdruck“ ist einer der folgenden:
  • Ein „Identifizierer“ optional mit Apostroph eingeschlossen, z. B. „CustomerID“. Sie müssen einen Identifizierer, der nicht mit einem Buchstaben („A“ — „Z“ oder „a“ — „z“) beginnt, mit Apostroph einschließen, da er andere Zeichen wie Buchstaben, Ziffern oder Unterstriche enthält oder mit einem für TML oder FDL reserviertem Wort (oder von einen nur im Fall abweicht) übereinstimmt. Ein Identifizierer darf nicht länger als 128 Zeichen sein.
  • Ein numeric literal z. B. 30, -3,28, oder 3,1e8 (der letzte repräsentiert [image])
  • Ein „String-Literal“ eingeschlossen in Anführungszeichen, zum Beispiel, „Ein String“
  • Ein „Datumsliteral“ mit Vorzeichen „#,“ z. B. #2004/03/16 oder #2004/03/16:09:12:13
  • Der Schlüsselbegriff „null“ (siehe Der Nullwert)
  • Eine „Funktionsanwendung“, bestehend aus einer Funktionsbezeichnung (ein Identifizierer) gefolgt von einer durch Kommas getrennten Liste mit Argumenten (Ausdrücke) in Anführungszeichen, z. B. „mean(IncomeA + IncomeB, TotalEstIncome)“
  • Ein „Arithmetischer Ausdruck“ bestehend aus einem numerisch-bewerteten Ausdruck verbunden durch arithmetische Operatoren [siehe Arithmetische Operatoren], z. B. 365 / 52
  • Eine „Tabelle“ bestehend aus numerischen oder String-Ausdrücken, verbunden durch Beziehungsoperatoren [siehe Vergleichsoperatoren], z. B. „Age > 30“ oder 'State' = „New York“
  • Ein „Logischer Ausdruck“ bestehend aus Beziehungen oder anderen booleschen bewerteten Ausdrücken verbunden durch logische Operatoren [siehe Logische Operatoren], z. B. (Einkommen > 250000) und (MaritalStatus = „Ledig“)
  • Ein „Statistischer Identifizierer“ bestehend aus dem TML-Schlüsselbegriff STATISTIC gefolgt von einer Periode, gefolgt von einem Identifizierer, z. B. STATISTIC.AverageIncome („nur“ in einer TML-Zusatzdatei)
  • Eine Feldstatistik – nur in einer Decision Studio-Ableitung, eine qsderive Ableitungsdatei oder eine qsselect Auswahldatei
Anmerkung:
  • Bei FDL-Identifizierern muss die Groß-/Kleinschreibung beachtet werden. Beispiel: Die Ausdrücke „CustomerID“ und „CUSTOMERID“ beziehen sich auf verschiedene Felder, während die Ausdrücke „isnull(Age)“ und „IsNull(Age)“ verschiedene Funktionen einbeziehen.
  • Ein numerisches Literal wird als integer bewertet, wenn es keinen Dezimalpunkt enthält und keine wissenschaftliche Notation verwendet. Anderenfalls wird es als reelle Zahl überprüft.
  • Eine String-Literal kann alle Zeichen enthalten, mit Ausnahme von Anführungszeichen (") und Zeilenende-Zeichen.
  • Ein Datums-Literal wird anfänglich im Format Jahr, Monat, Tag überprüft [siehe Datumsformate]; Falls dies fehlschlägt, wird es entsprechend den Einstellungen ihrer read-Optionen behandelt [siehe read].
  • So wie Sie Leerzeichen zwischen syntaktischen Elemente einfügen können, können Sie auch Kommentare einfügen, die mit zwei Schrägstrichen („//“) beginnen und sich bis zum Zeilenende vorsetzen. Zum Beispiel:
    // This is a comment.
2 + 2 // This is a comment.

Siehe auch

Reservierte Worte in FDL

Reservierte Worte in TML


Konditionale Ausdrücke

In FDL gibt es zwei Hauptwege zur konditionalen Überprüfung eines Ausdruckes: Der if-Ausdruck und der case-Ausdruck.

Siehe auch

Informatinoen zur Field Derivation Language

Formeln

Übergeordnetes Thema: Field Derivation Language (FDL) Referenz

Der if-Ausdruck

Falls die Bedingung (ein FDL-Ausdruck einen booleschen Wert [siehe Boolesche Daten] ergibt) „true“ ist, wird der nachfolgende Ausdruck then überprüft; andernfalls wird der nachfolgende Ausdruck else überprüft. Der Wert des if-Ausdrucks ist der Wert des überprüften Ausdrucks.

Anmerkung:
  • Die nachfolgenden Ausdrücke then und else müssen Typ-kompatibel sein [siehe Datentypen].
  • Wenn Sie den „else“-Teil in einem Ausdruck weglassen und die Bedingung „false“ ist, ist der Wert des Ausdrucks Null [siehe Der Nullwert].
  • Eine Null-Bedingung [siehe Der Nullwert] wird vom if-Ausdruck behandelt, als wenn sie „false“ ist. Dies ist eine Ausnahme von der allgemeinen Regel, nach der die durch einen Nullwert eingeführte Unsicherheit von den FDL-Ausdrücken beibehalten wird. Dies kann zu unerwarteten Ergebnissen führen: z. B. wenn „Alter“ Null ist, generieren nachfolgende (aus 1. Sicht gleichwertige) Ausdrücke entsprechend den Nullwert, 0 und 1:

    Age > 40

    if Age > 40 then 1 else 0

    if Age <= 40 then 0 else 1

  • Sie können mehrere Bedingungen mit verschachtelten if-Ausdrücken testen — if-Ausdrücke in welchen der nachfolgende Ausdruck then oder else selber ein if-Ausdruck ist. Wenn der auf then folgende Ausdruck ein if-Ausdruck ist, müssen Sie ihn in runde Klammern setzen, um Mehrdeutigkeiten zu vermeiden. Alternativ können Sie den Ausdruck „case“ verwenden [siehe Der case-Ausdruck].
  • Wenn Ihre Bedingung als x = 0 (oder [image]) für eine beliebige Zahl x ausgedrückt werden kann, können Sie auch die integrierte FDL-Funktion cond anstelle eines if-Ausdrucks verwenden.

Beispiele

if Age < 40 then "Young"

if Age < 40 then "Young" else "Senior"

if Age > 40 then "Young" else if Age < 60 then "MiddleAged" else "Senior"

if (Age >= 13 and Age < 20) then "Teenager"

if isnull(Alter) then mean(Alter) else Alter

if Responder then RespondDate else StartDate

if match(Postcodel, "^EH") then "J" else "N"

if StartDate < #1998/09/08 then "Loyal" else "Recent"

Der case-Ausdruck

Wenn die 1. Bedingung (ein FDL-Ausdruck einen booleschen Wert ergibt [siehe Boolesche Daten]) der „true“ ist, wird der entsprechende Ausdruck (rechts vom Semikolon) überprüft und als der Wert des case-Ausdrucks zurückgegeben. Andernfalls wird die nächste Bedingung getestet. Wenn diese „true“ ist, wird der entsprechende Ausdruck überprüft und als Wert des case-Ausdrucks zurückgegeben. Andernfalls wird die nächste Bedingung getestet, usw., usw.

Der spezielle Schlüsselbegriff „default“ wird als ein „immer-true“ Ausdruck interpretiert: Sie sollten diesen normalerweise als letzte Bedingung in einem case-Ausdruck verwenden (da alle nachfolgenden Bedingungen ignoriert werden).

Anmerkung:
  • Alle die Ausdrücke, die rechts von Semikolons auftreten, müssen Typ-kompatibel sein [siehe Datentypen].
  • Falls keine der Bedingungen „true“ ist (und es gibt keinen Schlüsselbegriff „default“), ist der Wert des case-Ausdrucks Null [siehe Der Nullwert].
  • Eine Null-Bedingung [siehe Der Nullwert] wird vom case-Ausdruck behandelt, als wenn sie „false“ ist. Dies ist eine Ausnahme von der allgemeinen Regel, nach der die durch einen Nullwert eingeführte Unsicherheit von den FDL-Ausdrücken beibehalten wird. Beispiel: Wenn „Age“ Null ist, generieren die folgenden Bedingungen den Wert 3:

    Anfrage

    Age > 40 : 1;

    Age <= 40 : 2;

    default : 3;

  • Wenn Sie einen case-Ausdruck in einer Ausdrucksliste oder einen case-Ausdruck als eine Bedingung einbetten (innerhalb eines if-Ausdrucks oder einem anderen case-Ausdruck), müssen Sie ihn in runde Klammern setzen, um Mehrdeutigkeiten zu vermeiden.

Beispiele

Anfrage

Age < 40: "Jung";

default: "NichtJung";

Anfrage

Response = "Exc": 7;

Response = "V. Sat". 6

Response = "Sat": 5;

Response = "F. Sat". 4;

Response = "Poor": 3;

Response = "Bad": 2;

default: 1;


Variablen

Eine variable in FDL ist ein temporärer Speicherort für eine Reelle Zahl, ganze Zahl, String oder Datumswert. Sie können eine lokale Variable für die Überprüfung eines komplizierten Unterausdruck% verwenden — ins besonders wenn ein Unterausdruck mehr als einmal% auftritt — oder um einen Ausdruck mit einer Zufallszahlenfunktion zu überprüfen, um zu vermeiden, dass sich sein Wert von einer Überprüfung zur Nächsten ändert. Sie können ebenfalls globale Variablen in Decision Studio [siehe Globale Variable in Decision Studio] verwenden und Statusvariablen in TML-Tracker-Dateien [siehe Statusvariablen in TML (Transaction Measurement Language)], um Informationen von einem Datensatz zum nächsten zu übertragen.

Um einer Variable einen Wert zuzuweisen, verwenden Sie folgende Syntax:

Die erste Zuweisung ist eine „Initialisierung“ und bestimmt die Klasse der Variable% - lokal (kein Schlüsselwort), global oder Status. Der Schlüsselbegriff global oder state wird nur in Verbindung mit der ersten Zuweisung zu einer global-Variable oder einer state-Variable verwendet (bei der Initialisierung).

Der Identifizierer [siehe Basisausdrücke] ist der Name der Variable (welcher nicht mit einem Feldnamen im Fokus übereinstimmen muss).

Für jede Variablenklasse ist der Datentyp [siehe Datentypen] der vom ersten zugewiesenen Wert.

Der Wert eines zugewiesenen Ausdruck ist einfach der Wert des Ausdrucks rechts vom „:=“-Zeichen.

Beisipiel: Die folgende Ausdrucksliste weist zufällig den Wert 1 (20% der Datensätze), 2 (20% der anderen Datensätzen) oder 0 (dem Rest der Datensätze) zu:

x := rndUniform();

Anfrage

x < 0,2 : 1;

x < 0,4 : 2;

default : 0;

Diese Funktion kann äquivalent in dieser kompakteren Form geschrieben werden:

Anfrage

( x := rndUniform() ) < 0.2 : 1;

x < 0,4 : 2;

default : 0;

Dennoch generiert die nachfolgende Ausdrucksliste ein anderes (möglicherweise unerwünschtes) Ergebnis:

Anfrage

rndUniform() < 0,2 : 1;

rndUniform() < 0,4 : 2;

default : 0;

Übergeordnetes Thema: Field Derivation Language (FDL) Referenz

Globale Variable in Decision Studio

Variablen sind standardmäßig „lokal“. Eine lokale Variable wird zerstört, wenn der letzte Ausdruck in der (Letzter eingeschlossen) Ausdrucksliste [siehe Formeln] überprüft wurde. Das nächste Mal, wenn diese Variable wieder benutzt wird, wird sie neu angelegt. Eine lokale Variable kann keine Information von einem Datensatz zum nächsten übertragen. Beispiel: Die folgende Feld-Ableitungs-Ausdrucksliste erstellt ein Feld mit 1 in jedem Datensatz:

i := 0;

i := i + 1

Eine globale Variable unterscheidet sich von einer lokalen Variablen darin, dass sie nicht zerstört wird, bis Decision Studio oder der Dateierstellungsbefehl die Feldwerte für alle Datensätze berechnet hat. Das Anlegen geschieht einmal für den ersten Datensatz im Fokus. Beispiel: Die folgende Feldableitungsausdrucksliste erstellt ein Indexfeld mit 1 im 1. Datensatz, mit 2 im 2. Datensatz, usw.:

global i := 0;

i := i + 1

Sie können eine globale Variable in einer Feldableitungsausdrucksliste in einer Decision Studio-Ableitung in der Ableitungsdatei verwenden für qsderive oder dem äquivalenten Fenster „Felder ableiten“, in einer Tracker-Datei für qstrack, oder in einer Auswahldatei für qsselect.

Statusvariablen in TML (Transaction Measurement Language)

Sie können eine Statusvariable in einer TML-Felddefinition in der qstrack Tracker-Datei verwenden.

Eine Statusvariable unterscheidet sich von einer lokalen oder globalen Variablen darin, dass sie nicht zerstört wird, bis qstrack alle Feldwerte für die aktuelle Gruppe (wie durch das Schlüsselfeld definiert) berechnet hat. Das Anlegen geschieht einmal für jede Gruppe.

Beispielsweise definiert die folgende Felddefinition ein Feld „laufende Rechnung“, es wird angenommen, dass das Feld „Deposit“ einen in einer Transaktion hinterlegten Betrag (oder einen negativen Wert für eine Abbuchung) enthält und das Feld „AnfangsSaldo“ den Ausgangssaldo für den Kunden (eventuelle aus einer früher verbundenen Kundentabelle) enthält:

create Balance := (

state bal := InitialBalance;

bal := bal + Deposit

)


Benutzerdefinierte Funktionen

Um eine FDL-Funktion zu definieren, die Sie auf die gleiche Art und Weise wie die integrierte Funktion verwenden können [siehe Integrierte Funktionen], verwenden Sie die folgende Syntax:

Der Identifizierer [siehe Basisausdrücke] gefolgt vom Schlüsselwort „function“ ist der Name der Funktion. Die Liste (formaler) Argumente kommt als Nächstes:

Jedes formale Argument (ohne vorangestelltes Schlüsselwort „field“) agiert als lokale Variable [siehe Variablen], die bei der Anwendung der Funktion mit dem Wert des entsprechend vorhandenen Arguments initialisiert wird. Der Typ [siehe Datentypen] eines formalen Arguments ist der in der Funktionsdefinition angegebene Typ, falls vorhanden; ansonsten wird bei der Anwendung der Funktion der Typ des eigentlichen Arguments verwendet. Beachten Sie, dass die umschließenden Klammern erforderlich sind, auch wenn keine formalen Argumente vorhanden sind.

Folgend der Liste von Argumenten kommt eine optionale Liste der Funktionsattribute [sieheFunktionsattribute] und dann die Definition des Funktionsaufbaus. Die Ausdrucksliste [siehe Formeln] werden gewissermaßen lokale Variablenzuweisungen entsprechend der formalen Argumente vorangestellt (anders als die mir einem Schlüsselwort „field“ vorangestellten), bevor sie bewertet werden, um einen Rückgabewert für die Funktion bereitzustellen. Der Typ von Rückgabe wert ist der des letzten Ausdrucks.

Beispiele Definition einer Funktion für das Ersetzen von Nullen im Ergebnis eines Ausdrucks (alle Typen) mit dem Ergebnis eines anderen Ausdrucks:

function replaceZeros(expr1, expr2)

{

if expr1 = 0 then expr2 else expr1

}

Eine Funktion, die ein Stringargument nimmt und mit dem ersten Buchstaben großgeschrieben zurückgibt:

function titleCase(string text)

{

concat(toupper(left(text, 1)), right(text, strlen(text) - 1));

}

Anmerkung:
  • Verwenden Sie bei der Angabe der Typen eines Funktionsargument „real“, „integer“, „string“ oder „date.“
  • Sie können Feldstatistiken in eine Funktionsdefinition einbeziehen, aber jedes Funktionsargument, das in einer Feldstatistik verwendet wird, muss das Schlüsselwort „field“ vorangestellt werden. Beispiel: So vergleicht man einen Wert mit einer Zusammenfassung über den gesamten Fokus:

    function MyBand(real field x)

    {

    averageX := mean(x);

    stdevX := stdev(x);

    Anfrage

    x < averageX - stdevX : "Lower";

    x > averageX + stdevX : "Upper";

    default: "Mid";

    }

  • Sie können zu Beginn einer Ausdrucksliste Funktionsdefinitionen einfügen, die ein abgeleitetes Feld definieren. So definierte Funktionen gelten lokal für die Feldableitung.

    Sie können zudem global zugängliche Funktionen definieren, indem Sie diese in einer Datei (oder in Dateien) in einem Ordner speichern, der in der Option Ableitungsbibliotheken aufgeführt ist [siehe Ableitungsbibliotheken] . Im Fenster Funktionsfamilie von Decision Studio im Dialogfeld Ableitungsfunktionen das Tabellenansicht erscheinen Funktionen in einer Datei mit der benannten Klasse .fdl in der Klasse mit dem Namen „class“. Beispiel: Funktionen in einer Datei mit dem Namen Conditional.fdl erscheinen in der Klasse Conditional. Sie können einen vorhandenen Klassennamen erneut verwenden, um eine Klasse anhand Ihrer eigenen benutzerdefinierten Funktionen zu erweitern, oder Sie erstellen Ihre eigene Klasse durch die Verwendung eines neuen Namens.

    Durch die Verwendung des Datenerstellungsbefehls qsmeasure in Portrait Miner, des entsprechenden Fensters Datensätze hinzufügen, oder den Datenerstellungsbefehl qstrack, können Sie eine Datei angeben, die zusätzliche globale Funktionsdefinitionen enthält.

  • Sie können in einem Messbezug keine Aggregations-Funktionen definieren, wie z. B. \funccontextmeasure.
  • Endet die Ausdrucksliste mit einem alphabetischen Zeichen, muss dieses durch ein Semikolon oder einen Zwischenraum von der schließenden Klammer getrennt.
Übergeordnetes Thema: Field Derivation Language (FDL) Referenz

Funktionsattribute

Geben Sie die Funktionsattribute wie folgt ein:

Nützliche Attribute sind:

synopsis und description. Diese Attribute bieten eine Standardmöglichkeit für die Erstellung der Funktion „Selbstdokumentierung:“ Wird eine Funktion in einem Ordner installiert, der in der Option Ableitungsbibliotheken aufgeführt ist [siehe Ableitungsbibliotheken], wird die Synopsis angezeigt, wenn Sie die Funktion im Fenster Funktionen des Dialogfeldes Ableitungsfunktionen in der Tabellenansicht markieren. Klicken Sie auf die Schaltfläche Details, wird die Beschreibung angezeigt. Der Synopsistext sollte kurz, aber der Beschreibungstext kann länger sein.

Zum Beispiel:

function nvl(testNull, replaceValue)

[

synopsis = "Replace null values"

description = "The nvl() function replaces null values...strings."

]

(Beachten Sie, dass sich die Beschreibungsattribute alle auf der gleichen Zeile befinden müssen.)

element_names. In einer Aggregationsdatei können Sie eine Funktion mit dem Attribut element_names verwenden, um eine Aggregation aufzuteilen und mehrere Felder zu erstellen [siehe Verteilungsaggregationen: Die by-Klausel].

Der Wert dieses Attributs ist ein String, der eine durch Komma getrennte Namensliste enthält, die mit den Funktionsrückgabewerten 1, 2, ... verknüpft ist, in der Reihenfolge, in der sie aufgelistet sind.

Beispiel: Das Attribut element_names der folgenden Funktion verbindet die Namen „Niedrig“, „Mittel“ und „Hoch“ jeweils mit den Rückgabewerten 1, 2 und 3:

function band(x)

[ element_names = "Low,Medium,High" ]

{

clamp(floor(x / 1000), 0, 2) + 1

}

Das Attribut element_names der folgenden Funktion verknüpft die Namen „Norden“, „Süden“, „Osten“ und „Westen“ jeweils mit den Rückgabewerten 1, 2, 3 und 4:

function StoreGroupFunction( Store )

[

element_names = "North, South, East, West"

]

{

Anfrage

Store = "0000" or Store = "0800" : 1;

Store = "0300" or Store = "0600" or Store = "0700" : 2;

Store = "0100" or Store = "0400" : 3;

default : 4;

}


Integrierte Funktionen

FDL enthält einen umfangreichen Satz integrierter Funktionen.

Bedingungsfunktionen

Funktion | Beschreibung
clamp | Beschränkt eine Zahl darauf, zwischen einem vorgegebenen Intervall zu liegen.
cond | Produziert ein von zwei Ergebnissen in Abhängigkeit davon, ob ein Ausdruck Null oder Nicht-Null ist.
iff | Produziert ein von zwei Ergebnissen in Abhängigkeit davon, ob ein Ausdruck Null oder Nicht-Null ist.
ifnull, nvl | Ersetzt den Nullwert.
isnull | Testet, ob der Wert eine Null ist.
isselected | Markiert die derzeit ausgewählten Datensätze.
replace | Ersetzen einer Zahl, wenn diese nicht innerhalb eines vorgegebenen Intervalls liegt.

Datentyp-Konvertierungsfunktionen

Funktion | Zweck
todate | Konvertierung eines Wertes in ein Datum.
tointeger | Konvertierung eines Wertes in eine Ganzzahl.
toreal | Konvertierung eines Wertes in eine reelle Zahl.
tostring | Konvertierung eines Wertes in einen String.

Funktionen für die Arbeit mit Datumsangaben

Funktion | Zweck
addcenturies, addcenturiescountbackwards | Berechnung eines Datums von einem anderen Datum unter Verwendung eines Versatzes in Jahrhunderten.
adddays | Berechnung eines Datums von einem anderen Datum unter Verwendung eines Versatzes in Tagen.
addhours | Berechnung eines Datums von einem anderen Datum unter Verwendung eines Versatzes in Stunden.
addminutes | Berechnung eines Datums von einem anderen Datum unter Verwendung eines Versatzes in Minuten.
addmonths, addmonthscountbackwards | Berechnung eines Datums von einem anderen Datum unter Verwendung eines Versatzes in Monaten.
addseconds | Berechnung eines Datums von einem anderen Datum unter Verwendung eines Versatzes in Sekunden.
addweeks | Berechnung eines Datum von einem anderen Datum unter Verwendung eines Versatzes in Wochen.
addyears, addyearscountbackwards | Berechnung eines Datum von einem anderen Datum unter Verwendung eines Versatzes in Jahren.
countcenturies | Berechnung des Zeitraums zwischen zwei Daten in Jahrhunderten.
countdays | Berechnung des Zeitraums zwischen zwei Daten in Tagen.
counthours | Berechnung des Zeitraums zwischen zwei Daten in Stunden.
countminutes | Berechnung des Zeitraums zwischen zwei Daten in Minuten.
countseconds | Zählt die Anzahl der Sekunden zwischen zwei Daten
countweeks | Berechnung des Zeitraums zwischen zwei Daten in Wochen.
countwholecenturies, countwholecenturiesbackwards | Zählt die Anzahl kompletter Jahrhunderte zwischen zwei Daten.
countwholedays | Zählt die Anzahl kompletter Tage zwischen zwei Daten.
countwholehours | Zählt die Anzahl kompletter Stunden zwischen zwei Daten.
countwholeminutes | Zählt die Anzahl kompletter Minuten zwischen zwei Daten.
countwholemonths, countwholemonthsbackwards | Zählt die Anzahl kompletter Monate zwischen zwei Daten.
countwholeseconds | Zählt die Anzahl der Sekunden zwischen zwei Daten
countwholeweeks | Zählt die Anzahl kompletter Wochen zwischen zwei Daten.
countwholeyears, countwholeyearsbackwards | Zählt die Anzahl kompletter Jahre zwischen zwei Daten.
countyears | Berechnung des Zeitraums zwischen zwei Daten in Jahren.
day | Abrufen des Tages einer Datumsangabe.
dayofweek | Abrufen einer Zahl, die den Tag eines Datums repräsentiert.
gmt2edt | Konvertierung eines Greenwich Mean Time (GMT)-Datums zu Eastern Daylight Time (EDT).
hour | Abrufen der Stunden als Teil einer Datumsangabe.
minute | Abrufen der Minuten als Teil einer Datumsangabe.
month | Gibt den Monatsteil eines Datums zurück
now | Gibt Systemdatum und -zeit zurück
second | Abrufen der Sekunden als Teil einer Datumsangabe.
today | Abrufen des aktuellen Datums.
weekofyear | Berechnet das Jahr der Woche einer Datumsangabe in Bezug zu einem angegebenen Startdatum.
year | Gibt den Jahresteil eines Datums zurück

Funktionen für die Arbeit mit Strings

Funktion | Zweck
concat | Verketten von zwei oder mehr Strings.
endswith | Testen, ob ein String mit dem anderen endet.
find | Testen, ob ein String innerhalb eines anderen Strings enthalten ist.
left | Rückgabe einer Teilzeichenfolge von bestimmter Länge ab Stringbeginn.
mid | Rückgabe einer Teilzeichenfolge von bestimmter Länge ab der Stringmitte.
right | Rückgabe einer Teilzeichenfolge von bestimmter Länge ab Stringende.
soundex | Reduzierung aller Wörter auf einen vierbuchstabigen String zu Indexierungszwecken.
startswith | Testen, ob ein String mit dem anderen startet.
strlen | Gibt die Länge einer Zeichenfolge zurück
strmember | Bestimmung der Satzmitgliedschaft.
Ersatz | Ersetzen eines Strings durch einen anderen.
substr | Abrufen einer Teilzeichenfolge aus einem String.
tolower | Konvertiert einen String in einen klein geschriebenen Text.
toupper | Konvertiert einen String in einen großgeschriebenen Text.
trim | Entfernt alle Leerzeichen aus einer Textzeichenfolge, außer einzelnen Leerzeichen zwischen Wörtern

Reguläre Ausdrücke und verknüpfte Funktionen

Funktion | Zweck
match | Prüfen eines Strings für eine reguläre Ausdrucksübereinstimmung [siehe Regular Expression].
replaceall | Ersetzen aller Teilzeichenfolgen, die mit einem regulären Ausdruck übereinstimmen [siehe Regular Expression].
replacefirst | Ersetzen der ersten Teilzeichenfolge, die mit einem regulären Ausdruck übereinstimmt [sieheRegular Expression].

Mathematische und statistische Funktionen

Typ | Beschreibung
abs | Berechnung des absoluten Werts einer Zahl.
ceil | Aufrunden einer Zahl auf das nächste Integer.
cos | Berechnung des Kosinus eines Winkels.
exp | Berechnung des Exponentialwerts einer Zahl.
floor | Abrunden einer Zahl auf die nächste Ganzzahl.
Protokoll | Berechnung des natürlichen Basis-e-Logarithmus einer Zahl.
log10 | Berechnung des Basis-10-Logarithmus einer Zahl.
logbase | Berechnung des Logarithmus einer Zahl für eine angegebene Basis.
max (zwei oder mehr Argumente), maxnonnull | Berechnung des Maximums zweier oder mehr Zahlen oder das späteste von zwei oder mehr Daten oder der im Alphabet letzte von zwei oder mehr Strings.
mean (zwei oder mehr Argumente), meannonnull | Berechnung des Durchschnittswertes (allgemeiner Durchschnitt) zweier oder mehrerer Zahlen.
min (zwei oder mehr Argumente), minnonnull | Berechnung des Minimums zweier oder mehr Zahlen oder das früheste von zwei oder mehr Daten oder der im Alphabet erste von zwei oder mehr Strings.
normalisieren | Normalisierung der Feldwerte, damit diese innerhalb des Intervalls [0,1] liegen.
pow | Berechnung des Ergebnisses der Erhöhung einer Zahl einer anderen Hochzahl.
product, productnonnull | Berechnung des Produkts zweier oder mehrerer Zahlen.
round | Runden einer Zahl auf das nächste Integer.
sgn | Berechnung des Signums (Vorzeichens) einer Zahl.
sin | Berechnung des Sinus eines Winkels.
sqrt | Berechnung der Quadratwurzel einer Zahl.
sum (zwei oder mehr Argumente), sumnonnull | Berechnung der Summe zweier oder mehrerer Zahlen.
tan | Berechnung der Tangente eines Winkels.

Datenabtast-Funktionen

Funktion | Zweck
numericTestTrainSplit | Erstellung einer Test/Schulungs-Segmentierung für die Verwendung in der Modellvalidierung.
numericTestTrainValidateSplit | Erstellung einer Test/Schulungs/Validierungs-Segmentierung für die Verwendung in der Modellvalidierung.
sampleEqualSize | Zufällige Erstellung eines Segmentierungsindex für Gruppen gleicher Größe.
sampleExactNumber | Zufällige Markierung einer exakten Kundenanzahl von einer ausgewählten Gesamtmenge.
sampleExactPercentage | Zufällige Markierung einer exakten Prozentzahl an Kunden von einer ausgewählten Gesamtmenge.
sampleStratified | Zufällige Markierung einer angegebenen Anzahl an Kunden von einem Segment und dem Rest der Gesamtmenge.
testTrainSplit | Erstellung einer Test/Schulungs-Segmentierung für die Verwendung in der Modellvalidierung.
testTrainValidateSplit | Erstellung einer Test/Schulungs/Validierungs-Segmentierung für die Verwendung in der Modellvalidierung.

Zufallszahlenfunktionen

Funktion | Zweck
rndBinomial | Erzeugung einer zufälligen Ganzzahl auf Basis einer binomischen Verteilung.
rndBool | Zufällige Erzeugung von 0 oder 1 (mit gleicher Wahrscheinlichkeit).
rndExp | Erzeugung einer zufälligen positiven Zahl auf Basis einer exponentiellen Verteilung.
rndGamma | Erzeugung einer zufälligen positiven Zahl auf Basis einer exponentiellen Gammaverteilung.
rndNormal | Erzeugung einer zufälligen Zahl auf Basis einer normalen Verteilung.
rndPoisson | Erzeugung einer zufälligen nichtnegativen Ganzzahl auf Basis einer diskreten Poissonverteilung.
rndUniform | Erzeugung einer zufälligen Zahl zwischen 0 und 1 auf Basis einer Gleichverteilung.

ROI-Funktionen

Funktion | Zweck
ActionROI | Schätzen Sie den Beitrag der Kapitalrendite (Geld) durch Maßnahmen zur Generierung einer Definite Response.
ActionROIAnnualized | Schätzen Sie den auf das Jahr umgerechneten Beitrag der Kapitalrendite pro Kunde durch Maßnahmen zur Generierung einer Definite Response von einem Kunden.
OfferROI | Schätzen Sie den Beitrag der Kapitalrendite pro Kunde durch die Erstellung eines Angebots zur Generierung einer Definite Response.
OfferROIAnnualized | Schätzen Sie den auf das Jahr umgerechneten Beitrag der Kapitalrendite pro Kunde durch ein Angebot zur Generierung einer Definite Response von einem Kunden.
RetentionActionROI | Schätzen Sie den Beitrag der Kapitalrendite (Geld) durch Maßnahmen zur Vermeidung einer Abnahme.
RetentionActionROIAnnualized | Schätzen Sie den auf das Jahr umgerechneten Beitrag der Kapitalrendite pro Kunde durch Maßnahmen zur Vermeidung einer Abnahme.
RetentionOfferROI | Schätzen Sie den Beitrag der Kapitalrendite pro Kunde durch das Abgeben eines Angebots zur Vermeidung einer Abnahme.
RetentionOfferROIAnnualized | Schätzen Sie den auf das Jahr umgerechneten Beitrag der Kapitalrendite pro Kunde durch das Abgeben eines Angebots zur Vermeidung einer Abnahme.

Verschiedene Funktionen

Funktion | Zweck
dblookup | Suche nach Werten in einer Referenztabelle (gespeichert als Fokus).
Mitglied | Bestimmung der Satzmitgliedschaft.
rankOrder, rankOrderApprox | Identifizierung des Ranges eines Wertes innerhalb einer Werteliste.
rankOrderMean, rankOrderApproxMean | Identifizierung des Ranges eines Wertes innerhalb einer Werteliste.
rownum | Erzeugung der Zahl jeder Reihe in der Tabelle.

Klasseneinteilungen

Funktion | Zweck
Lagerfach | Abrufen eines Klassenindex entsprechend eines Werts.

Siehe auch

Benutzerdefinierte Funktionen
Übergeordnetes Thema: Field Derivation Language (FDL) Referenz


Reservierte Worte in FDL

Folgende Tokens sind reservierte Worte in FDL: accum, agg, aggregate, aggregation, and, by, case, date, default, div, double, else, eq, false, field, float, function, global, if, int, integer, long, mod, not, null, number, numeric, or, real, short, state, string, then, true, where und while

Um ein reserviertes Wort oder ein Wort, das sich nur durch Groß-/Kleinschreibung von einem reservierten Wort unterscheidet, als Identifizierer [siehe Formeln] in FDL oder als Feld- oder Statistiknamen in TML zu verwenden, müssen Sie es in einfache Anführungszeichen setzen, zum Beispiel 'State'.

Anmerkung: Obwohl die Identifizierer in FDL von der Schreibweise abhängig sind (fred und Fred sind verschieden), sind die reservierten Wörter nicht von der Schreibweise abhängig und daher in jeder Kombination aus Groß- und Kleinschreibung reserviert: Zum Beispiel repräsentieren if, If, iF und IF alle dasselbe Token; alle diese Kombinationen sind reserviert und dürfen nicht als Identifizierer verwendet werden.

Siehe auch

Informatinoen zur Field Derivation Language

Reservierte Worte in TML

Übergeordnetes Thema: Field Derivation Language (FDL) Referenz


FDL-Operatoren

  • Arithmetische Operatoren
  • Vergleichsoperatoren
  • Logische Operatoren
  • Operatorpriorität
Übergeordnetes Thema: Field Derivation Language (FDL) Referenz


Arithmetische Operatoren

Mit Ausnahme für monadisches Minus, das seinem Einzeloperanden vorangestellt wird, handelt es sich bei allen arithmetischen FDL-Operatoren um eingefügt Binäroperatoren, das bedeutet, sie werden zwischen deren zwei Operanden geschrieben.

Operator | Operanden | Ergebnis
+ (Addition) | numerisch | Die Summe der Operanden
- (Subtraktion) | numerisch | Das Ergebnis der Subtraktion des zweiten Operanden vom ersten Operand
- (monadisches Minus) | numerisch | Der Negative der Operanden
* (Multiplikation) | numerisch | Das Produkt der Operanden
/ (Division) | numerisch | Das (echte) Ergebnis für das Teilen des ersten Operanden durch den zweiten Operanden
div (Ganzzahldivision) | ganze Zahl | Das (Ganzzahl) Ergebnis für das Teilen des ersten Operanden durch den zweiten Operanden und ignorieren aller Reste
mod (Modulo) | ganze Zahl | Der Rest einer Ganzzahl teilt den ersten Operanden durch den zweiten Operanden (der Modulus) mit dem gleichen Zeichen wie der erste Operand — Beispiel: 9 % 7 ergibt 2, aber -9 % 7 ergibt -2

Beispiele 2 + 5 ergibt 7.

2 - 5 ergibt -3.

- (2 + 5) ergibt -7.

2 * 5 ergibt 10.

2 / 5 ergibt 0,4.

2 div 5 ergibt 0.

2 mod 5 ergibt 2.

5 % 2 ergibt 1.

Anmerkung:
  • The Operatoren für Addition, Subtraktion, monadisches Minus und Multiplikation behalten den Typ ihres Operanden bei (die typenkompatibel sind [siehe Typ-Kompatibilität]). Handelt es sich bei einem Operanden um eine Ganzzahl und der andere ist eine reelle Zahl, ist auch das Ergebnis real.
  • Lautet der Wert des zweiten Operanden der Division, Ganzzahl-Division oder Modulo-Operator Null, ist das Ergebnis Null [siehe Der Nullwert], da die Division durch Null undefiniert ist.
  • mod erfordert Ganzzahloperanden.
  • Sie können auch % anstelle von mod verwenden.

Siehe auch

Logische Operatoren

Operatorpriorität

Vergleichsoperatoren

Übergeordnetes Thema: FDL-Operatoren


Vergleichsoperatoren

Bei allen FDL-Vergleichsoperatoren sind, handelt es sich um eingefügte Binäroperatoren, das bedeutet, sie werden zwischen deren zwei Operanden geschrieben.

Operator | Operanden | Ergebnis
< Kleiner als | ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | True, wenn der erste Operand weniger als eine Sekunde ist; False, wenn der erste Operand größer oder gleich eine Sekunde ist
<= ist weniger oder gleich | ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | True, wenn der erste Operand weniger als eine Sekunde ist; False, wenn der erste Operand größer als eine Sekunde ist
> (größer als) | ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | True, wenn der erste Operand größer als eine Sekunde ist; False, wenn der erste Operand kleiner oder gleich eine Sekunde ist
>= größer als oder gleich | ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | True, wenn der erste Operand mehr als eine Sekunde ist; False, wenn der erste Operand kleiner als eine Sekunde ist
= (Parität) | ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | True, wenn beide Operanden den gleichen Wert besitzen; False, wenn die Operanden unterschiedliche Werte besitzen. Bei Stringtypen ignoriert der Vergleich führende Leerzeichen in beiden Operanden.
!= (Ungleichung) | ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | True, wenn beide Operanden unterschiedliche Werte besitzen; False, wenn die Operanden die gleichen Werte besitzen. Bei Stringtypen ignoriert der Vergleich führende Leerzeichen in beiden Operanden.

Beispiele 2 < 5 ergibt 1 (TRUE).

5 < 5 ergibt 0 (FALSE).

"A" < "B" ergibt 1 (TRUE).

5 <= 5 ergibt 1 (TRUE).

5 > 5 ergibt 0 (FALSE).

7 > 5 ergibt 1 (TRUE).

#2003/12/31 > #2003/11/30 ergibt 1 (TRUE).

5 >= 5 ergibt 1 (TRUE).

"A" = "A" ergibt 1 (TRUE).

"A" = "a" ergibt 0 (FALSE).

"A" != "A" ergibt 0 (FALSE).

"A" != "a" ergibt 1 (TRUE).

Anmerkung:
  • Die Operanden eines binären Vergleichsoperators müssen typenkompatibel sein [siehe Typ-Kompatibilität].
  • Beim Vergleich von Daten bedeutet „weniger als“ früher. Beim Vergleich von Strings bedeutet „weniger als“ vorher im Alphabet (oder um es genauer zu sagen, früher in der zugrunde liegenden Zeichenrepräsentation). Dasselbe gilt für „größer als“ usw.
  • Sie können außerdem == oder eq anstelle von = und <> anstelle von != verwenden.

Siehe auch

Arithmetische Operatoren

Boolesche Daten

Logische Operatoren

Übergeordnetes Thema: FDL-Operatoren


Logische Operatoren

Der logische Verneinungsoperator wird seinem Einzeloperator vorangestellt, während die Verzweigungs- und Trennungsoperatoren eingefügte Binäroperatoren sind, das bedeutet, das bedeutet, sie werden zwischen deren zwei Operanden geschrieben.
Operator | Operanden | Ergebnis
and (logische Verzweigung) | boolean | True, wenn beide Operanden true sind; false, wenn einer der Operanden false ist
or (logische Verzweigung) | boolean | True, wenn ein Operand true ist; false, wenn beide Operanden false sind
not (logische Verneinung) | boolean | True, wenn der Operand false ist; false, wenn der Operand true ist

Beispiele ("A" = "A") und (5 = 5) ergibt 1 (TRUE).

("A" = "B") and (5 = 5) ergibt 0 (FALSE).

("A" = "B") and (5 = 2) ergibt 0 (FALSE).

("A" = "A") orr (5 = 5) ergibt 1 (TRUE).

("A" = "B") || (5 = 5) ergibt 1 (TRUE).

("A" = "B") orr (5 = 2) ergibt 0 (FALSE).

not ("A" = "A") ergibt 0 (FALSE).

!(("A" = "B") orr (5 = 2)) ergibt 1 (TRUE).

Anmerkung:
  • Derzeit befindet sich kein Boolesch-Datentyp [siehe Boolesche Daten] in FDL, daher handelt es sich bei den Operanden für logische Operatoren eigentlich um Ganzzahlen. Sie sollten diese Operatoren jedoch nicht für willkürliche Zahlen anwenden.
  • Sie können auch and anstelle von and verwenden, || anstelle von or und ! anstelle von not.

Siehe auch

Arithmetische Operatoren

Operatorpriorität

Vergleichsoperatoren

Übergeordnetes Thema: FDL-Operatoren


Operatorpriorität

Bei fehlenden Klammern werden die FDL-Vorgänge in einem Ausdruck in der Reihenfolge ihrer Operatorpriorität ausgeführt, von der Höchsten zur Niedrigsten.
Klasse | Operatoren
Monadisches Minus | -
Multiplikationsoperatoren | * / div mod
Additionsoperatoren | + -
Vergleichsoperatoren | < <= > >= != =
Logische Verneinung | nicht
Logische Binäroperatoren | and or

Liegt bezüglich der Priorität ein Unentschieden vor, werden die Operationen von links nach rechts ausgeführt.

Unterausdrücke in Klammern werden zuerst bewertet.

Beispiele -5 + 12 / 4 * 2 + 20 * 3 ergibt 61.

das bedeutet, der Ausdruck wird bewertet als: -5 + ((12 / 4) * 2) + (20 * 3)

Verschieben der Klammern:

-(5 + 12 / (4 * 2) + 20) * 3 ergibt -79,5.

Siehe auch

Arithmetische Operatoren

Logische Operatoren

Vergleichsoperatoren

Übergeordnetes Thema: FDL-Operatoren


FDL-Funktionen

  • Aggregationsfunktionen (Multi-Argument)
  • Bedingungsfunktionen
  • Datentyp-Konvertierungsfunktionen
  • Funktionen für die Arbeit mit Datumsangaben
  • Mathematische und statistische Funktionen
  • Sonstige Funktionen
  • ROI-Funktionen
  • Zufallszahlenfunktionen
  • Rang-Funktionen
  • Datenabtast-Funktionen
  • Funktionen für die Arbeit mit Strings
Übergeordnetes Thema: Field Derivation Language (FDL) Referenz


Aggregationsfunktionen (Multi-Argument)

  • max (zwei oder mehr Argumente), maxnonnull
  • mean (zwei oder mehr Argumente), meannonnull
  • min (zwei oder mehr Argumente), minnonnull
  • product, productnonnull
  • sum (zwei oder mehr Argumente), sumnonnull
Übergeordnetes Thema: FDL-Funktionen


max (zwei oder mehr Argumente), maxnonnull

Ziel Berechnen des Maximums von zwei oder mehr Zahlen, oder die aktuellsten von zwei oder mehreren Datumsangaben, oder die alphabetisch letzte von zwei oder mehr Strings. Die max-Variante gibt den Nullwert zurück, wenn eins ihrer Argumente Null ist. Die maxnonnull-Variante ignoriert Null-Argumente (gibt aber dennoch den Nullwert zurück, wenn alle Argumente Null sind).

Syntax

max( [image], [image], ...)

maxnonnull( [image], [image], ...)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge (alle derselbe Typ) | , [image] , ... | Die zu vergleichenden Werte

Ergebnis

Typ | Beschreibung
als Eingabe | Das Maximum von [image] , [image] , ...
Anmerkung:
  • Verwechseln Sie diese Multi-Argument-Funktion nicht mit der Aggregationsfunktion [siehe max (ein Argument)] gleichen Namens.
  • Bei Strings bedeutet „alphabetisch letzte“ „letzte in der zugrunde liegenden Zeichendarstellung“.

Beispiele max(5.5, -3, 7, -8.5) entspricht 7.

max(5,5, -3, Null, -8,5) entspricht Null.

maxnonnull(5,5, -3, 7, -8,5) entspricht 7.

maxnonnull(5,5, -3, Null, -8,5) entspricht 5,5.

So berechnen Sie die nächstbeste Maßnahme für einen Kunden, basierend auf verschiedenen ROI-Größen:

maxvalue := max (ROI1, ROI2, ROI3);

Anfrage

maxvalue = ROI1: "Produkt1";

maxvalue = ROI2: "Produkt2";

maxvalue = ROI3: "Produkt3";

Übergeordnetes Thema: Aggregationsfunktionen (Multi-Argument)


mean (zwei oder mehr Argumente), meannonnull

Ziel Den Mittelwert des Feldes (gemeinsamer Durchschnitt) von zwei oder mehr Zahlen berechnen. Die mean-Variante gibt den Nullwert zurück, wenn eins ihrer Argumente Null ist. Die meannonnull-Variante ignoriert Null-Argumente (gibt aber dennoch den Nullwert zurück, wenn alle Argumente Null sind).

Syntax

mean( [image], [image], ...)

meannonnull( [image], [image], ...)

Argumente

Typ | Name | Beschreibung
numerisch | , [image] , ... | Die Zahlen, deren Durchschnitt zu ermitteln ist

Ergebnis

Typ | Beschreibung
Reelle Zahl | Der Mittelwert von [image] , [image] , ...
Anmerkung:

Verwechseln Sie diese „Multi-Argument“-Mittelwertfunktion nicht mit der „Aggregations“-Funktion [siehe mean (ein Argument)] gleichen Namens.

Beispiele mean(5,5, -3, 7, -8,5) entspricht 0,25.

mean(5,5, -3, Null, -8,5) entspricht Null.

meannonnull(5,5, -3, 7, -8,5) entspricht 0,25.

meannonnull(5,5, -3, Null, -8,5) entspricht -2.

Zum Berechnen der durchschnittlichen Jahresausgaben aus vier getrennten Quartalsausgabenfeldern:

mean(SpendQtr1, SpendQtr2, SpendQtr3, SpendQtr4)

Übergeordnetes Thema: Aggregationsfunktionen (Multi-Argument)


min (zwei oder mehr Argumente), minnonnull

Ziel Berechnen des Minimums von zwei oder mehr Zahlen, oder die frühesten von zwei oder mehr Datumsangaben, oder die alphabetisch erste von zwei oder mehr Strings. Die min-Variante gibt den Nullwert zurück, wenn eins ihrer Argumente Null ist. Die minnonnull-Variante ignoriert Null-Argumente (gibt aber dennoch den Nullwert zurück, wenn alle Argumente Null sind).

Syntax

min( [image], [image], ...)

minnonnull( [image], [image], ...)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge (alle derselbe Typ) | , [image] , ... | Die zu vergleichenden Werte

Ergebnis

Typ | Beschreibung
als Eingabe | Das Minimum von [image] , [image] , ...
Anmerkung:
  • Verwechseln Sie diese „Multi-Argument“-Minimalwertfunktion nicht mit der „Aggregations“-Funktion [siehe min (ein Argument)] gleichen Namens.
  • Für Strings bedeutet „alphabetisch frühester“ „frühester in der zugrundeliegenden Zeichendarstellung.“

Beispiele min(5,5, -3, 7, -8,5) entspricht -8,5.

Min(5,5, -3, null, -8,5) entspricht Null.

minnonnull(5,5, -3, 7, -8,5) entspricht -8,5.

minnonnull(5,5, -3, null, -8,5) entspricht -8,5.

Übergeordnetes Thema: Aggregationsfunktionen (Multi-Argument)


product, productnonnull

Ziel Berechnet das Produkt von zwei oder mehr Zahlen. Die Produktvariante gibt den Wert Null zurück, wenn eines ihrer Argumente Null ist, die Variante „productnonnull“ ignoriert Null-Argumente (gibt aber auch den Wert Null zurück, wenn alle ihre Argumente Null sind).

Syntax

product( [image], [image], ...)

productnonnull( [image], [image], ...)

Argumente

Typ | Name | Beschreibung
numerisch | , [image] , ... | Die zu multiplizierenden Zahlen

Ergebnis

Typ | Beschreibung
als Eingabe | Das Produkt von [image] , [image] , ...

Beispiele product(5.5, -3, 7, -8.5) ist gleich 981.75.

product(5.5, -3, null, -8.5) ist gleich null.

productnonnull(5.5, -3, 7, -8.5) ist gleich 981.75.

productnonnull(5.5, -3, null, -8.5) ist gleich 140.25.

Übergeordnetes Thema: Aggregationsfunktionen (Multi-Argument)


sum (zwei oder mehr Argumente), sumnonnull

Ziel Berechnen der Summe von zwei oder mehr Zahlen. Die sum-Variante gibt den Wert gleich Null zurück, wenn eines ihrer Argumente Null ist. Die sumnonnull Variante ignoriert Null-Argumente (gibt aber den Wert gleich Null zurück, wenn alle ihre Argumente Null sind).

Syntax

sum( [image], [image], ...)

sumnonnull( [image], [image], ...)

Argumente

Typ | Name | Beschreibung
numerisch | , [image] , ... | Die zu addierenden Zahlen

Ergebnis

Typ | Beschreibung
als Eingabe | Die Summe von [image] , [image] , ...
Anmerkung:

Verwechseln Sie diese multi-argument-Summenfunktion nicht mit der aggregations-Funktion [siehe sum (ein Argument)] gleichen Namens.

Beispiele sum(5,5, -3, 7, -8,5) entspricht 1.

sum(5,5, -3, null, -8,5) entspricht null.

sumnonnull(5,5, -3, 7, -8.5) entspricht 1.

sumnonnull(5,5, -3, null, -8.5) entspricht -6.

Um die Gesamtausgaben von sechs Wochenausgabenfeldern abzuleiten:

sum(SpendWk1, SpendWk2, SpendWk3, SpendWk4, SpendWk5, SpendWk6)

Übergeordnetes Thema: Aggregationsfunktionen (Multi-Argument)


Bedingungsfunktionen

  • clamp
  • cond
  • iff
  • ifnull, nvl
  • isnull
  • isselected
  • replace
Übergeordnetes Thema: FDL-Funktionen


clamp

Zweck Einschränken einer Zahl, damit sie innerhalb eines gegebenen Intervalls liegt.

Syntax clamp(x, min, max)

Argumente

Typ | Name | Beschreibung
numerisch | x | Die zu haltende Zahl
als x | min | Die Untergrenze des Intervalls
als x | Max | Die Obergrenze des Intervalls

Ergebnis

Typ | Beschreibung
als Eingabe | x if [image] ; min if x < min; max if x > max

Beispiele Um Werte in einem Bereich von 18 bis einschließlich 65 zu halten, sind die Werte außerhalb des Bereichs durch entsprechende Bereichsgrenzen zu ersetzen:

CustomerAge | clamp(CustomerAge,18,65)
9 | 18
18 | 18
66 | 65
43 | 43

Siehe auch

replace
Übergeordnetes Thema: Bedingungsfunktionen


cond

Zweck Ausgabe eines von zwei Ergebnissen, abhängig davon, ob ein Ausdruck Null oder nicht Null ist.

Syntax cond(cond, trueExpr, falseExpr)

Argumente

Typ | Name | Beschreibung
ganze Zahl | cond | Der zu testende Ausdruck
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | trueExpr | "True" (nicht 0)-Verzweigung
als trueExpr | falseExpr | "False" (0)-Verzweigung

Ergebnis

Typ | Beschreibung
als trueExpr, falseExpr | trueExpr if cond [image] 0; falseExpr if cond = 0
Anmerkung:

Im Gegensatz zum if-Ausdruck [siehe Der if-Ausdruck] oder case-Ausdruck [siehe Der case-Ausdruck], werden beide Verzweigungen von der cond-Funktion überprüft.

Bezeichnenderweise bewahrt „cond“ den Fehler eines Wertes Null [siehe Der Nullwert] in der Bedingung.

Wenn Sie dieses Verhalten nicht brauchen, verwenden Sie für die Geschwindigkeit einen if- oder case-Ausdruck.

Beispiele Herauszufiltern von Kunden mit 0 Ausgaben für eine Mailing-Kampagne im 2. Quartal:

SpendQtr2 | cond(SpendQtr2, "Nicht anschreiben", "Anschreiben")
100.39 | Nicht anschreiben
0 | Mail
-5.72 | Mail
Null | Null

Siehe auch

clamp

iff

ifnull, nvl

replace

Übergeordnetes Thema: Bedingungsfunktionen


iff

Zweck Ausgabe eines von zwei Ergebnissen, abhängig davon, ob ein Ausdruck Null oder nicht Null ist.

Syntax iff(logical_text, value_if_true, value_if_false)

Argumente

Typ | Name | Beschreibung
Reelle Zahl | logical_text | Der zu testende Ausdruck
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | value_if_true | "True" (nicht 0)-Verzweigung
als value_if_true | value_if_false | "False" (zero oder 0)-Verzweigung

Ergebnis

Typ | Beschreibung
als value_if_true, value_if_false | value_if_true if logical_text [image] 0; value_if_false if logical_text = 0 or logical_text is null

Beispiele iff(Score > 650, "Mail", "kein Mail")

Siehe auch

cond
Übergeordnetes Thema: Bedingungsfunktionen


ifnull, nvl

Zweck Ersetzen des Werts Null. Sie können nvl als Alias für ifnull verwenden.

Syntax ifnull(testNull, replaceValue)

nvl(testNull, replaceValue)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | testNull | Der zu testende Wert
als testNull | replaceValue | Der Ersatz für den Wert Null

Ergebnis

Typ | Beschreibung
als Eingabe | Eine Kopie des Wertes testNull mit replaceValue als Ersatz für den Wert Null

Beispiele Um fehlende Werte mit einem von einem anderen Feld abgeleiteten Wert zu ersetzen:

SpendQtr1 | AnnualSpend | ifnull(SpendQtr1, AnnualSpend/4)
45.21 | 178.97 | 45.21
Null | 150.56 | 37.64
Null | 784.27 | 196.07
59.05 | 274.18 | 59.05

Siehe auch

cond

isnull

Übergeordnetes Thema: Bedingungsfunktionen


isnull

Zweck Testen, ob ein Wert Null ist.

Syntax isnull(x)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Der zu testende Wert

Ergebnis

Typ | Beschreibung
ganze Zahl | 1 wenn x Null ist; 0 andernfalls

Beispiele Um Einträge des Wertes Null in einem Feld mit dem Mittelwert des Feldes zu ersetzen:

Age | if isnull(Alter) then mean(Alter) else Alter
32 | 32
Null | 44
59 | 59
27 | 27

Siehe auch

Verteilungsaggregationen: Die by-Klausel
Übergeordnetes Thema: Bedingungsfunktionen


isselected

Ziel Markierung der derzeit ausgewählten Datensätze.

Syntax isselected()

Argumente Keine

Ergebnis

Typ | Beschreibung
ganze Zahl | 1, wenn der Datensatz derzeit ausgewählt ist, ansonsten 0
Anmerkung:

Der Tabellenansicht bietet eine spezielle Unterstützung für die sofortige Erweiterung [siehe Unterstützte Funktionseingabe im Tabellenansicht] dieser Funktion.

Beispiele if isselected() then "LowRisk" else "HighRisk"

Übergeordnetes Thema: Bedingungsfunktionen


replace

Zweck Ersetzen einer Zahl, wenn sie nicht innerhalb eines angegebenen Intervalls liegt.

Syntax replace(x, min, max, y)

Argumente

Typ | Name | Beschreibung
numerisch | x | Die zu testende Zahl
als x | min | Die Untergrenze des Intervalls
als x | Max | Die Obergrenze des Intervalls
als x | y | Der Ersatzwert

Ergebnis

Typ | Beschreibung
als Eingabe | x if [image] ; y sonst

Beispiele Um Werte in einem Bereich von 18 bis einschließlich 65 zu halten, werden Werte außerhalb des Bereichs durch den Mittelwert ersetzt.

CustomerAge | replace (CustomerAge, 18, 65, mean(CustomerAge))
9 | 38
18 | 18
66 | 38
43 | 43

Siehe auch

clamp
Übergeordnetes Thema: Bedingungsfunktionen


Datentyp-Konvertierungsfunktionen

  • todate
  • tointeger
  • toreal
  • tostring
Übergeordnetes Thema: FDL-Funktionen


todate

Ziel Konvertierung eines Wertes in ein Datum.

Syntax todate(x [, format] )

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Ein Wert zur Konvertierung von
Zeichenfolge | Format | Ein Datumsformat [siehe Datumsformate] für die Konvertierung (optional und nur erlaubt, wenn x ein Stringtyp ist)

Ergebnis

Typ | Beschreibung
datum | x, als ein Datum
Anmerkung:
  • Handelt es sich um ein Argument vom Typ Integer, wird eine Darstellung des Datums als JJJJMMTT angenommen.
  • Handelt es sich um ein Argument vom Typ Reelle Zahl, wird eine Darstellung des Datums als JJJJMMTT.HHMMSS angenommen.
  • Handelt es sich um ein Argument vom Typ String und es wird kein Argument für das Datumsformat angegeben, wird der String entsprechend der Einstellung Ihrer read-Präferenz konvertiert [siehe read].

Beispiele (Datumswerte sind im europäischen Datumsformat angezeigt.)

todate(20040109) ergibt 09/01/2004:00:00:00.

todate(20040109.122853) ergibt 09/01/2004:12:08:52.

todate("09/01/2004") ergibt 09/01/2004:00:00:00.

todate("09-Jan-2004","%d-%b-%Y") ergibt 09/01/2004:00:00:00.

todate(#09/01/2004:12:28:53) ergibt 09/01/2004:12:28:53.

Siehe auch

tointeger

toreal

tostring

Typkonvertierung

Übergeordnetes Thema: Datentyp-Konvertierungsfunktionen


tointeger

Ziel Konvertierung eines Wertes in eine Ganzzahl.

Syntax tointeger(x)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Ein Wert zur Konvertierung von

Ergebnis

Typ | Beschreibung
ganze Zahl | x, als ein Integer
Anmerkung:
  • Handelt es sich um ein Argument vom Typ „Reell“, werden die Ziffern nach dem Dezimalpunkt ignoriert.
  • Handelt es sich um ein Argument vom Typ „Datum“, besitzt das Ergebnis die Form JJJJMMTT (die Zeitkomponente wird ignoriert).
  • Handelt es sich um ein Argument vom Typ „String“, werden alle führenden, nichtnumerischen Zeichen ignoriert.

Beispiele tointeger(100) ergibt 100.

tointeger(100,65) ergibt 100.

tointeger("100,65") ergibt 100.

tointeger(#09/01/2004:12:28:53) ergibt 20040109.

Siehe auch

todate

toreal

tostring

Typkonvertierung

Übergeordnetes Thema: Datentyp-Konvertierungsfunktionen


toreal

Ziel Konvertierung eines Wertes in eine reelle Zahl.

Syntax toreal(x)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Ein Wert zur Konvertierung von

Ergebnis

Typ | Beschreibung
Reelle Zahl | x, als eine reelle Zahl
Anmerkung:
  • Handelt es sich um ein Argument vom Typ „Datum“, besitzt das Ergebnis die Form JJJJMMTT.HHMMSS.
  • Handelt es sich um ein Argument vom Typ „String“, werden alle führenden, nichtnumerischen Zeichen ignoriert.

Beispiele toreal(100) ergibt 100,0.

toreal(100,65) ergibt 100,65.

toreal("100,65") ergibt 100,65.

toreal(#09/01/2004:12:28:53) ergibt 20040109.122853.

Siehe auch

todate

tointeger

tostring

Typkonvertierung

Übergeordnetes Thema: Datentyp-Konvertierungsfunktionen


tostring

Ziel Konvertierung eines Wertes in einen String.

Syntax tostring(x)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Ein Wert zur Konvertierung von

Ergebnis

Typ | Beschreibung
Zeichenfolge | x, als ein String
Anmerkung:
  • Handelt es sich um ein Argument vom Typ Reell, wird das Ergebnis im gewöhnlichen (und nicht im wissenschaftlichen) Dezimalformat ausgegeben.
  • Handelt es sich um ein Argument vom Typ Datum, wird das Ergebnis entsprechend der Einstellung Ihrer Präferenz date write formatiert [siehe Datum schreiben].

Beispiele tostring(100) ergibt "100".

tostring(1.0065e2) ergibt "100.650000".

tostring("100,65") ergibt "100,65".

tostring(#09/01/2004:12:28:53) ergibt "09/01/2004:12:28:53".

Siehe auch

todate

tointeger

toreal

Typkonvertierung

Übergeordnetes Thema: Datentyp-Konvertierungsfunktionen


Funktionen für die Arbeit mit Datumsangaben

  • addcenturies, addcenturiescountbackwards
  • adddays
  • addhours
  • addminutes
  • addmonths, addmonthscountbackwards
  • addseconds
  • addweeks
  • addyears, addyearscountbackwards
  • countcenturies
  • countdays
  • counthours
  • countminutes
  • countseconds
  • countweeks
  • countwholecenturies, countwholecenturiesbackwards
  • countwholedays
  • countwholehours
  • countwholeminutes
  • countwholemonths, countwholemonthsbackwards
  • countwholeseconds
  • countwholeweeks
  • countwholeyears, countwholeyearsbackwards
  • countyears
  • day
  • dayofweek
  • gmt2edt
  • hour
  • minute
  • month
  • now
  • second
  • today
  • weekofyear
  • year
Übergeordnetes Thema: FDL-Funktionen


addcenturies, addcenturiescountbackwards

Ziel Berechnet ein Datum von einem anderen Datum unter Verwendung eines Versatzes in Jahrhunderten.

Syntax addcenturies(date, n)

addcenturiescountbackwards(date, n)

Argumente

Typ | Name | Beschreibung
datum | date | Das Startdatum
ganze Zahl | n | Die Anzahl der hinzuzufügenden Jahrhunderte (kann ein negativer Wert sein)

Ergebnis

Typ | Beschreibung
datum | Das Datum n Jahrhunderte nach dem Datum date (interpretiert als |n| Jahrhunderte vor date, wenn n < 0). Der Zeitteil des Ergebnisses entspricht dem Zeitteil von date. Siehe addmonths, addmonthscountbackwards für eine Erklärung der zwei Varianten.
Anmerkung:

Das Ergebnis des Hinzufügens von n Jahrhunderten mithilfe der Funktion „addcenturies“ (entsprechend „addcenturiescountbackwards“) wird definiert als das Ergebnis des Hinzufügens von 1200n Monaten mit der Funktion „addmonths“ (entsprechend „addmonthscountbackwards“).

Beispiele So berechnen Sie ein Datum ein Jahrhundert später als d, wobei der Unterschied zwischen den Varianten addcenturies und countbackwards (JMT-Datumsformat) angezeigt wird:

d | addcenturies(d,1) | addcenturiescountbackwards(d,1)
1900/02/14 | 2000/02/14 | 2000/02/15
Siehe auch

countcenturies

countwholecenturies, countwholecenturiesbackwards

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


adddays

Ziel Berechnet ein Datum von einem anderen Datum unter Verwendung eines Versatzes in Tagen.

Syntax adddays(date, n)

Argumente

Typ | Name | Beschreibung
datum | date | Das Startdatum
ganze Zahl | n | Die Anzahl der hinzuzufügenden Tage (kann ein negativer Wert sein)

Ergebnis

Typ | Beschreibung
datum | Das Datum n Tage nach dem Datum date (interpretiert als |n| Tage vor date, wenn n < 0). Der Zeitteil des Ergebnisses entspricht dem Zeitteil von date.

Beispiele Europäisches Datumsformat: adddays(#09/01/2004, 25) ergibt 03/02/2004.

Europäisches Datumsformat: adddays(#09/01/2004:11:43:46, 25) ergibt 03/02/2004:11:43:46.

Amerikanisches Datumsformat: adddays(#01/09/2004, 25) ergibt 02/03/2004.

Amerikanisches Datumsformat: adddays(#01/09/2004:11:43:46, 25) ergibt 02/03/2004:11:43:46.

JMT-Datumsformat: adddays(#2004/01/09, 25) ergibt 2004/02/03.

JMT-Datumsformat: adddays(#2004/01/09:11:43:46, 25) ergibt 2004/02/03:11:43:46.

Siehe auch

countdays

countwholedays

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


addhours

Ziel Berechnet ein Datum von einem anderen Datum unter Verwendung eines Versatzes in Stunden.

Syntax addhours(date, n)

Argumente

Typ | Name | Beschreibung
datum | date | Das Startdatum
ganze Zahl | n | Die Anzahl der hinzuzufügenden Stunden (kann ein negativer Wert sein)

Ergebnis

Typ | Beschreibung
datum | Das Datum n Stunden nach dem date (interpretiert als |n| Stunden vor date, wenn n < 0)
Anmerkung:

Alle Daten in FDL beinhalten eine Zeitkomponente.

Beispiele Europäisches Datumsformat: addhours(#09/01/2004:12:28:53, 25) ergibt 10/01/2004:13:28:53.

Amerikanisches Datumsformat: addhours(#01/09/2004:12:28:53, 25) ergibt 01/10/2004:13:28:53.

JMT-Datumsformat: addhours(#2004/01/09:12:28:53, 25) ergibt 2004/01/10:13:28:53.

Siehe auch

counthours

countwholehours

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


addminutes

Ziel Berechnet ein Datum von einem anderen Datum unter Verwendung eines Versatzes in Minuten.

Syntax addminutes(date, n)

Argumente

Typ | Name | Beschreibung
datum | date | Das Startdatum
ganze Zahl | n | Die Anzahl der hinzuzufügenden Minuten (kann ein negativer Wert sein)

Ergebnis

Typ | Beschreibung
datum | Das Datum n Minuten nach dem Datum date (interpretiert als |n| Minuten vor Datum, wenn n < 0)
Anmerkung:

Alle Daten in FDL beinhalten eine Zeitkomponente.

Beispiele Europäisches Datumsformat: addminutes(#09/01/2004:12:28:53, 25) ergibt 09/01/2004:12:53:53.

Amerikanisches Datumsformat: addminutes(#01/09/2004:12:28:53, 25) ergibt 01/09/2004:12:53:53.

JMT-Datumsformat: addminutes(#2004/01/09:12:28:53, 25) ergibt 2004/01/09:12:53:53.

Siehe auch

countminutes

countwholeminutes

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


addmonths, addmonthscountbackwards

Ziel Berechnet ein Datum von einem anderen Datum unter Verwendung eines Versatzes in Monaten.

Syntax addmonths(date, n)

addmonthscountbackwards(date, n)

Argumente

Typ | Name | Beschreibung
datum | date | Das Startdatum
ganze Zahl | n | Die Anzahl der hinzuzufügenden Monate (kann ein negativer Wert sein)
Ergebnis
Typ Beschreibung
datum Das Datum n Kalendermonate nach dem Datum date (interpretiert als |n| Monate vor date, falls n < 0).

Die Teile Monat und Jahr des Ergebnisses werden bestimmt durch den Versatz n.

Dann wird der Tag des Monats des Ergebnisses auf den gleichen Wert festgelegt wie im Datum date (für „addmonths“) oder auf die gleiche Anzahl Tage ab dem Ende des Monats wie im Datum date (für „addmonthscountbackwards“).

Endet der Tag des Monats vor dem Beginn oder nach dem Ende des Monats (weil der Ergebnismonat ein kürzerer Monat ist als der Monat, der date enthält), wird er entsprechend an den ersten oder letzten Tag des Monats geklammert.

Der Zeitteil des Ergebnisses entspricht dem Zeitteil von date.

Anmerkung:
  • Fügen Sie mithilfe von addmonths (oder addmonthscountbackwards) n Monate hinzu, erhalten Sie nicht unbedingt das gleiche Ergebnis, als wenn Sie einen Monat n-mail hinzufügen würden, da der Tag des Monats im letzteren Fall durch einen dazwischen liegenden kurzen Monat eingeschränkt sein könnte.
  • Die Ergebnisse des Hinzufügens eines Datums mit addmonths und addmonthscountbackwards können sich unterscheiden, wenn der Monatsteil eines Datums und der Monatsteil des Ergebnisses unterschiedliche Tageszahlen enthalten.

Beispiele So berechnen Sie ein Datum einen Monat später als d, wobei die Propagation der Zeitteile (JMT-Datumsformat) angezeigt wird:

d | addmonths(d,1)
2007/08/14:00:00:00 | 2007/09/14:00:00:00
2007/08/14:12:34:56 | 2007/09/14:12:34:56

So berechnen Sie ein Datum einen Monat später als d, wobei der Unterschied zwischen den Varianten „addmonths“ und „addmonthscountbackwards“ (JMT-Datumsformat) angezeigt wird:

d | addmonths(d,1) | addmonthscountbackwards(d,1)
2007/08/14 | 2007/09/14 | 2007/09/13

So berechnen Sie ein Datum einen Monat später als d, wobei das Klammerverhalten von „addmonths“ am Ende eines Monats (JMT-Datumsformat) angezeigt wird:

d | addmonths(d,1)
2007/08/31 | 2007/09/30

So berechnen Sie ein Datum einen Monat später als d, wobei das Klammerverhalten von „addmonthscountbackwards“ am Beginn des Monats (JMT-Datumsformat) angezeigt wird:

d | addmonthscountbackwards(d,1)
2007/08/02 | 2007/09/01
2007/08/01 | 2007/09/01

So berechnen Sie das sechsmonatige Jubiläum der einzelnen Kundenakquisen, indem Sie das Datumsfeld StartDate für die Kundenakquise verwenden:

addmonths(StartDate, 6)

Siehe auch

countwholemonths, countwholemonthsbackwards

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


addseconds

Ziel Berechnet ein Datum durch ein anderes Datum unter Verwendung eines Versatzes in Sekunden.

Syntax addseconds(date, n)

Argumente

Typ | Name | Beschreibung
datum | date | Das Startdatum
ganze Zahl | n | Die Anzahl der hinzuzufügenden Sekunden (kann ein negativer Wert sein)

Ergebnis

Typ | Beschreibung
datum | Das Datum n Sekunden nach dem Datum date (interpretiert als |n| Sekunden vor date, wenn n < 0)
Anmerkung:

Alle Daten in FDL beinhalten eine Zeitkomponente.

Beispiele Europäisches Datumsformat: addseconds(#09/01/2004:12:28:53, 25) ergibt 09/01/2004:12:54:18.

Amerikanisches Datumsformat: addseconds(#01/09/2004:12:28:53, 25) ergibt 01/09/2004:12:54:18.

JMT-Datumsformat: addseconds(#2004/01/09:12:28:53, 25) ergibt 2004/01/09:12:54:18.

Siehe auch

countseconds

countwholeseconds

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


addweeks

Ziel Berechnet ein Datum von einem anderen Datum unter Verwendung eines Versatzes in Wochen.

Syntax addweeks(date, n)

Argumente

Typ | Name | Beschreibung
datum | date | Das Startdatum
ganze Zahl | n | Die Anzahl der hinzuzufügenden Wochen (kann ein negativer Wert sein)

Ergebnis

Typ | Beschreibung
datum | Das Datum n Wochen nach dem Datum date (interpretiert als |n| Wochen vor date, wenn n < 0) Der Zeitteil des Ergebnisses entspricht dem Zeitteil von date.

Beispiele Europäisches Datumsformat: addweeks(#09/01/2004, 8) ergibt 05/03/2004.

Amerikanisches Datumsformat: addweeks(#01/09/2004, 8) ergibt 03/05/2004.

JMT-Datumsformat: addweeks(#2004/01/09, 8) ergibt 2004/03/05.

Siehe auch

countweeks

countwholeweeks

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


addyears, addyearscountbackwards

Ziel Berechnet ein Datum von einem anderen Datum unter Verwendung eines Versatzes in Jahren.

Syntax addyears(date, n)

addyearscountbackwards(date, n)

Argumente

Typ | Name | Beschreibung
datum | date | Das Startdatum
ganze Zahl | n | Die Anzahl der hinzuzufügenden Jahre (kann ein negativer Wert sein)

Ergebnis

Typ | Beschreibung
datum | Das Datum n Kalenderjahre nach dem Datum date (interpretiert als |n| Jahre vor date, falls n < 0). Der Zeitteil des Ergebnisses entspricht dem Zeitteil von date. Siehe addmonths, addmonthscountbackwards für eine Erklärung der zwei Varianten.
Anmerkung:

Das Ergebnis des Hinzufügens von n Jahren mithilfe der Funktion addyears (entsprechend addyearscountbackwards) wird definiert als das Ergebnis des Hinzufügens von 12n Monaten mit der Funktion addmonths (entsprechend addmonthscountbackwards).

Beispiele So berechnen Sie ein Datum, ein Jahr später als d, wobei der Unterschied zwischen den Varianten addyears and addyearscountbackwards (JMT-Datumsformat) angezeigt wird:

d | addyears(d,1) | addyearscountbackwards(d,1)
2007/02/14 | 2008/02/14 | 2008/02/15

Verwenden Sie zur Berechnung des einjährigen Jubiläums der einzelnen Kundenakquisen das Datumsfeld für die Kundenakquise StartDate:

addyears(StartDate, 1)

Siehe auch

countwholeyears, countwholeyearsbackwards

countyears

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


countcenturies

Ziel Berechnet den Zeitraum zwischen zwei Daten in Jahrhunderten.

Syntax countcenturies(date1, date2)

Argumente

Typ | Name | Beschreibung
datum | date1 | Das erste Datum
datum | date2 | Das zweite Datum

Ergebnis

Typ | Beschreibung
Reelle Zahl | Der Zeitraum zwischen date1 und date2 in Jahrhunderten (eine negative Zahl, wenn date1 nach date2 liegt)
Anmerkung:
  • Ist die Zahl kein exaktes Mehrfaches von 100 Jahren (unter Berücksichtigung der Zeitteile der Daten), enthält das Ergebnis einen fraktionalen Teil.
  • Das Ergebnis der Funktion countcenturies wird als das Ergebnis der Funktion countyears definiert, geteilt durch 100.

Beispiele Europäisches Datumsformat: countcenturies(#09/01/2004, #09/01/2054) ergibt 0.5.

Amerikanisches Datumsformat: countcenturies(#01/09/2004, #01/09/2054) ergibt 0.5.

JMT-Datumsformat: countcenturies(#2004/01/09, #2054/01/09) ergibt 0,5.

Siehe auch

countwholecenturies, countwholecenturiesbackwards

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


countdays

Ziel Berechnet den Zeitraum zwischen zwei Daten in Tagen.

Syntax countdays(date1, date2)

Argumente

Typ | Name | Beschreibung
datum | date1 | Das erste Datum
datum | date2 | Das zweite Datum

Ergebnis

Typ | Beschreibung
Reelle Zahl | Der Zeitraum zwischen date1 und date2 in Tagen (eine negative Zahl, wenn date1 nach date2 liegt)
Anmerkung:

Unterscheiden sich die Zeitteile der zwei Daten, beinhaltet das Ergebnis einen fraktionalen Teil.

Beispiele Europäisches Datumsformat: countdays(#09/01/2004, #03/02/2004) ergibt 25.

countdays(#09/01/2004:10:00:00, #03/02/2004:11:00:00) ergibt 25.04.

countdays(#09/01/2004:11:00:00, #03/02/2004:10:00:00) ergibt 24.96.

Amerikanisches Datumsformat: countdays(#01/09/2004, #02/03/2004) ergibt 25.

countdays(#01/09/2004:10:00:00, #02/03/2004:11:00:00) ergibt 25.04.

countdays(#01/09/2004:11:00:00, #02/03/2004:10:00:00) ergibt 24.96.

JMT-Datumsformat: countdays(#2004/01/09, #2004/02/03) ergibt 25.

countdays(#2004/01/09:10:00:00, #2004/02/03:11:00:00) ergibt 25.04.

countdays(#2004/01/09:11:00:00, #2004/02/03:10:00:00) ergibt 24.96.

Siehe auch

adddays

countwholedays

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


counthours

Ziel Berechnung des Zeitraums zwischen zwei Daten in Stunden.

Syntax counthours(time1, time2)

Argumente

Typ | Name | Beschreibung
datum | time1 | erste(s) Datum/Uhrzeit
datum | time2 | zweite(s) Datum/Uhrzeit

Ergebnis

Typ | Beschreibung
Reelle Zahl | Der Zeitraum zwischen time1 und time2 in Tagen (eine negative Zahl, wenn time1 nach time2 liegt)
Anmerkung:

Unterscheiden sich die Minuten- oder Sekundenteile der zwei Daten, beinhaltet das Ergebnis einen fraktionalen Teil.

Beispiele Europäisches Datumsformat: counthours(#09/01/2004:12:28:53, #10/01/2004:13:28:53) ergibt 25.

Amerikanisches Datumsformat: counthours(#01/09/2004:12:28:53, #01/10/2004:13:28:53) ergibt 25.

JMT-Datumsformat: counthours(#2004/01/09:12:28:53, #2004/01/10:13:28:53) ergibt 25.

Siehe auch

countwholehours

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


countminutes

Ziel Berechnet den Zeitraum zwischen zwei Daten in Minuten.

Syntax countminutes(time1, time2)

Argumente

Typ | Name | Beschreibung
datum | time1 | erste(s) Datum/Uhrzeit
datum | time2 | zweite(s) Datum/Uhrzeit

Ergebnis

Typ | Beschreibung
Reelle Zahl | Der Zeitraum zwischen time1 und time2 in Minuten (eine negative Zahl, wenn time1 nach time2 liegt)
Anmerkung:

Unterscheiden sich die Sekundenteile der zwei Daten, beinhaltet das Ergebnis einen fraktionalen Teil.

Beispiele Europäisches Datumsformat: countminutes(#09/01/2004:12:28:53, #09/01/2004:12:53:53) ergibt 25.

Amerikanisches Datumsformat: countminutes(#01/09/2004:12:28:53, #01/09/2004:12:53:53) ergibt 25.

JMT-Datumsformat: countminutes(#2004/01/09:12:28:53, #2004/01/09:12:53:53) ergibt 25.

Siehe auch

countwholeminutes

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


countseconds

Zweck Zählt die Anzahl der Sekunden zwischen zwei Daten.

Syntax countseconds(time1, time2)

Argumente

Typ | Name | Beschreibung
datum | time1 | erste(s) Datum/Uhrzeit
datum | time2 | zweite(s) Datum/Uhrzeit

Ergebnis

Typ | Beschreibung
Reelle Zahl | Die Anzahl Sekunden zwischen time1 und time2 (eine negative Zahl, wenn time1 nach time2 liegt)
Anmerkung:

Der einzige Unterschied zwischen dieser Funktion und countwholeseconds ist der, dass das Ergebnis des Letzteren vom Typ Ganzzahl ist.

Beispiele Europäisches Datumsformat: countseconds(#09/01/2004:12:28:53, #09/01/2004:12:29:18) ergibt 25.

Amerikanisches Datumsformat: countseconds(#01/09/2004:12:28:53, #01/09/2004:12:29:18) ergibt 25.

JMT-Datumsformat: countseconds(#2004/01/09:12:28:53, #2004/01/09:12:29:18) ergibt 25.

Siehe auch

Datumsformate
Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


countweeks

Ziel Berechnet den Zeitraum zwischen zwei Daten in Wochen.

Syntax countweeks(date1, date2)

Argumente

Typ | Name | Beschreibung
datum | date1 | Das erste Datum
datum | date2 | Das zweite Datum

Ergebnis

Typ | Beschreibung
Reelle Zahl | Der Zeitraum zwischen date1 und date2 in Wochen (eine negative Zahl, wenn date1 nach date2 liegt)
Anmerkung:

Ist der Zeitraum kein exaktes Mehrfaches von sieben Tagen (unter Berücksichtigung der Zeitteile der Daten), enthält das Ergebnis einen fraktionalen Teil.

Beispiele Europäisches Datumsformat: countweeks(#09/01/2004, #05/03/2004) ergibt 8.

Amerikanisches Datumsformat: countweeks(#01/09/2004, #03/05/2004) ergibt 8.

JMT-Datumsformat: countweeks(#2004/01/09, #2004/03/05) ergibt 8.

Siehe auch

countwholeweeks

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


countwholecenturies, countwholecenturiesbackwards

Ziel Zählt die Anzahl kompletter Jahrhunderte zwischen zwei Daten.

Syntax countwholecenturies(date1, date2) countwholecenturiesbackwards(date1, date2)

Argumente

Typ | Name | Beschreibung
datum | date1 | Das erste Datum
datum | date2 | Das zweite Datum

Ergebnis

Typ | Beschreibung
ganze Zahl | Die Anzahl kompletter Jahrhunderte, vergangen zwischen date1 und date2 (eine negative Zahl, wenn date1 nach date2 liegt). Siehe countwholemonths, countwholemonthsbackwards für eine Erklärung der zwei Varianten.
Anmerkung:
  • Das Ergebnis der Funktion countwholecenturies (entsprechend countwholecenturiesbackwards) wird definiert als das Ergebnis der Funktion countwholemonths (entsprechend countwholemonthsbackwards), geteilt durch 1200, den Rest ignorierend.
  • Die Ergebnisse des Vergleichs zweier Daten mit countwholecenturies und countwholecenturiesbackwards können unterschiedlich sein, aber nur wenn beide Daten im Februar liegen, ein Datum in einem Jahr teilbar durch 400 liegt und das andere in einem Jahr teilbar durch 100, aber nicht durch 400, liegt.

Beispiele Für das Zählen der Anzahl kompletter Jahrhunderte zwischen d1 und d2, Anzeige des Unterschieds zwischen den Varianten countwholecenturies und countwholecenturiesbackwards (JMT-Datumsformat):

d1 | d2 | countwholecenturies(d1,d2) | countwholecenturiesbackwards(d1,d2)
1900/02/14 | 2000/02/13 | 0 | 0
1900/02/14 | 2000/02/14 | 1 | 0
1900/02/14 | 2000/02/15 | 1 | 1

Siehe auch

addcenturies, addcenturiescountbackwards

countcenturies

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


countwholedays

Ziel Zählt die Anzahl kompletter Tage zwischen zwei Daten.

Syntax countwholedays(date1, date2)

Argumente

Typ | Name | Beschreibung
datum | date1 | Das erste Datum
datum | date2 | Das zweite Datum

Ergebnis

Typ | Beschreibung
ganze Zahl | Die Anzahl kompletter 24-Stunden-Zeiträume, vergangen zwischen date1 und date2 (eine negative Zahl, wenn date1 nach date2 liegt).

Beispiele Europäisches Datumsformat: countdays(#09/01/2004, #03/02/2004) ergibt 25.

countdays(#09/01/2004:10:00:00, #03/02/2004:11:00:00) ergibt 25.

countdays(#09/01/2004:11:00:00, #03/02/2004:10:00:00) ergibt 24.

Amerikanisches Datumsformat: countdays(#01/09/2004, #02/03/2004) ergibt 25.

countdays(#01/09/2004:10:00:00, #02/03/2004:11:00:00) ergibt 25.

countdays(#01/09/2004:11:00:00, #02/03/2004:10:00:00) ergibt 24.

JMT-Datumsformat: countdays(#2004/01/09, #2004/02/03) ergibt 25.

countdays(#2004/01/09:10:00:00, #2004/02/03:11:00:00) ergibt 25.

countdays(#2004/01/09:11:00:00, #2004/02/03:10:00:00) ergibt 24.

Siehe auch

adddays

countdays

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


countwholehours

Ziel Zählt die Anzahl kompletter Stunden zwischen zwei Daten.

Syntax countwholehours(time1, time2)

Argumente

Typ | Name | Beschreibung
datum | time1 | erste(s) Datum/Uhrzeit
datum | time2 | zweite(s) Datum/Uhrzeit

Ergebnis

Typ | Beschreibung
ganze Zahl | Die Anzahl Stunden zwischen time1 und time2 (eine negative Zahl, wenn time1 nach time2 liegt)

Beispiele Europäisches Datumsformat: countwholehours(#09/01/2004:12:28:53, #10/01/2004:13:28:53) ergibt 24.

Amerikanisches Datumsformat: countwholehours(#01/09/2004:12:28:53, #01/10/2004:13:28:53) ergibt 24.

JMT-Datumsformat: countwholehours(#2004/01/09:12:28:53, #2004/01/10:13:28:53) ergibt 24.

Siehe auch

counthours

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


countwholeminutes

Ziel Zählt die Anzahl kompletter Minuten zwischen zwei Daten.

Syntax countwholeminutes(time1, time2)

Argumente

Typ | Name | Beschreibung
datum | time1 | erste(s) Datum/Uhrzeit
datum | time2 | zweite(s) Datum/Uhrzeit

Ergebnis

Typ | Beschreibung
ganze Zahl | Die Anzahl Minuten zwischen time1 und time2 (eine negative Zahl, wenn time1 nach time2 liegt)

Beispiele Europäisches Datumsformat: countwholeminutes(#09/01/2004:12:28:53, #09/01/2004:12:53:53) ergibt 24.

Amerikanisches Datumsformat: countwholeminutes(#01/09/2004:12:28:53, #01/09/2004:12:53:53) ergibt 24.

JMT-Datumsformat: countwholeminutes(#2004/01/09:12:28:53, #2004/01/09:12:53:53) ergibt 24.

Siehe auch

countminutes

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


countwholemonths, countwholemonthsbackwards

Ziel Zählt die Anzahl kompletter Monate zwischen zwei Daten.

Syntax countwholemonths(date1, date2) countwholemonthsbackwards(date1, date2)

Argumente

Typ | Name | Beschreibung
datum | date1 | Das erste Datum
datum | date2 | Das zweite Datum

Ergebnis

Typ | Beschreibung
ganze Zahl | Die Anzahl kompletter Monate, vergangen zwischen date1 und date2 (eine negative Zahl, wenn date1 nach date2 liegt)
Anmerkung:
  • Die Zeitteile von date1 und date2 werden ignoriert.
  • Die Anzahl kompletter Monate zwischen den zwei Daten ist die größte Anzahl an Monaten, die dem ersten Datum hinzugefügt werden kann (Kürzung der Zeitteile und Verwendung von addmonths im Fall von countwholemonths und addmonthscountbackwards im Fall von countwholemonthsbackwards), sodass, wenn das zweite Datum nach dem ersten Datum liegt, das Ergebnis nicht nach dem zweiten Datum liegen kann, und wenn das zweite Datum vor dem ersten Datum liegt, das Ergebnis nicht vor dem zweiten Datum liegen kann.
  • Die Ergebnisse aus dem Vergleich der zwei Daten mit countwholemonths und countwholemonthsbackwards können unterschiedlich sein, wenn die Daten innerhalb Monate verschiedener Längen liegen.
  • Aufgrund des Klammerverhaltens von addmonths (und addmonthscountbackwards) kann der absolute Wert des Ergebnisses aus dem Vergleich zweier Daten mit countwholemonths (oder countwholemonthsbackwards) von der Reihenfolge der Argumente abhängig sein, wenn die Daten innerhalb von Monaten verschiedener Länge liegen.

Beispiele Für das Zählen der Anzahl kompletter Monate zwischen d1 und d2, Anzeige der Verkürzung der Zeitteile (JMT-Datumsformat):

d1 | d2 | countwholemonths(d1,d2)
2007/08/14:00:00:00 | 2007/09/14:00:00:00 | 1
2007/08/14:12:34:56 | 2007/09/14:00:00:00 | 1

Für das Zählen der Anzahl kompletter Monate zwischen d1 und d2, Anzeige des Unterschieds zwischen den Varianten countwholemonths and countwholemonthsbackwards (JMT-Datumsformat):

d1 | d2 | countwholemonths(d1,d2) | countwholemonthsbackwards(d1,d2)
2007/08/14 | 2007/09/12 | 0 | 0
2007/08/14 | 2007/09/13 | 0 | 1
2007/08/14 | 2007/09/14 | 1 | 1

Für das Zählen der Anzahl kompletter Monate zwischen d1 und d2, Anzeige des Klammerverhaltens von countwholemonths am Ende des Monats (JMT-Format):

d1 | d2 | countwholemonths(d1,d2) | countwholemonths(d2,d1)
2007/08/31 | 2007/09/30 | 1 | 0

Für das Zählen der Anzahl kompletter Monate zwischen d1 und d2, Anzeige des Klammerverhaltens von countwholemonths zu Beginn des Monats (JMT-Format):

d1 | d2 | countwholemonthsbackwards(d1,d2) | countwholemonthsbackwards(d2,d1)
2007/07/01 | 2007/06/01 | -1 | 0

So bestimmen Sie die Anzahl monatlicher E-Mail-Kommunikationen, die jeder Kunde erhalten hat, wobei die Kommunikationen am fünften Tag des Monats zugesendet werden (der letzte Auszug wurde am 5. März 2006 gesendet) und Verwendung des Datumsfeldes StartDate für die Kundenakquise:

-countwholemonths(#2006/03/05, StartDate)

So bestimmen Sie die Anzahl monatlicher Kontoauszüge, die jeder Kunde erhalten hat, wobei die Auszüge sieben Tage vor dem Monatsende zugesendet werden (der letzte Auszug wurde am 24. März 2006 gesendet) und Verwendung des Datumsfeldes StartDate für die Kundenakquise:

-countwholemonthsbackwards(#2006/03/24, StartDate)

Siehe auch

addmonths, addmonthscountbackwards

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


countwholeseconds

Zweck Zählt die Anzahl der Sekunden zwischen zwei Daten.

Syntax countwholeseconds(time1, time2)

Argumente

Typ | Name | Beschreibung
datum | time1 | erste(s) Datum/Uhrzeit
datum | time2 | zweite(s) Datum/Uhrzeit

Ergebnis

Typ | Beschreibung
ganze Zahl | Die Anzahl Sekunden zwischen time1 und time2 (eine negative Zahl, wenn time1 nach time2 liegt)
Anmerkung:

Der einzige Unterschied zwischen dieser Funktion und countseconds ist der, dass das Ergebnis des Letzteren vom Typ Reell ist.

Beispiele Europäisches Datumsformat: countwholeseconds(#09/01/2004:12:28:53, #09/01/2004:12:29:18) ergibt 25.

Amerikanisches Datumsformat: countwholeseconds(#01/09/2004:12:28:53, #01/09/2004:12:29:18) ergibt 25.

JMT-Datumsformat: countwholeseconds(#2004/01/09:12:28:53, #2004/01/09:12:29:18) ergibt 25.

Siehe auch

Datumsformate
Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


countwholeweeks

Ziel Zählt die Anzahl kompletter Wochen zwischen zwei Daten.

Syntax countwholeweeks(date1, date2)

Argumente

Typ | Name | Beschreibung
datum | date1 | Das erste Datum
datum | date2 | Das zweite Datum

Ergebnis

Typ | Beschreibung
ganze Zahl | Die Anzahl kompletter Wochen, vergangen zwischen date1 und date2 (eine negative Zahl, wenn date1 nach date2 liegt).

Beispiele Europäisches Datumsformat: countwholeweeks(#09/01/2004, #09/03/2004) ergibt 8.

Amerikanisches Datumsformat: countwholeweeks(#01/09/2004, #03/09/2004) ergibt 8.

JMT-Datumsformat: countwholeweeks(#2004/01/09, #2004/03/09) ergibt 8.

Siehe auch

countweeks

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


countwholeyears, countwholeyearsbackwards

Ziel Zählt die Anzahl kompletter Jahre zwischen zwei Daten.

Syntax countwholeyears(date1, date2)

countwholeyearsbackwards(date1, date2)

Argumente

Typ | Name | Beschreibung
datum | date1 | Das erste Datum
datum | date2 | Das zweite Datum

Ergebnis

Typ | Beschreibung
ganze Zahl | Die Anzahl kompletter Monate, vergangen zwischen date1 and date2 (eine negative Zahl, wenn date1 nach date2 liegt). Siehe countwholemonths, countwholemonthsbackwards für eine Erklärung der zwei Varianten.
Anmerkung:
  • Das Ergebnis der Funktion countwholeyears (entsprechend countwholeyearsbackwards) wird definiert als das Ergebnis der Funktion countwholemonths (entsprechend countwholemonthsbackwards), geteilt durch 12, den Rest ignorierend.
  • Die Ergebnisse des Vergleichs zweier Daten mit countwholeyears und countwholeyearsbackwardskönnen unterschiedlich sein, aber nur wenn beide Daten im Februar liegen, ein Datum in einem Schaltjahr liegt und das andere nicht.

Beispiele Für das Zählen der Anzahl kompletter Jahre zwischen d1 und d2, Anzeige des Unterschieds zwischen den Varianten countwholeyears und countwholeyearsbackwards (JMT-Datumsformat):

d1 | d2 | countwholeyears(d1,d2) | countwholeyearsbackwards(d1,d2)
2007/02/14 | 2008/02/13 | 0 | 0
2007/02/14 | 2008/02/14 | 1 | 0
2007/02/14 | 2008/02/15 | 1 | 1
So berechnen Sie das Alter der Kunden am 1. März 2007 aus einem Geburtstagsfeld: GEB (JMT-Datumsformat):

countwholeyears(DOB, #2007/03/01)

Siehe auch

addyears, addyearscountbackwards

countyears

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


countyears

Ziel Berechnung des Zeitraums zwischen zwei Daten in Jahren.

Syntax countyears(date1, date2)

Argumente

Typ | Name | Beschreibung
datum | date1 | Das erste Datum
datum | date2 | Das zweite Datum

Ergebnis

Typ | Beschreibung
Reelle Zahl | Der Zeitraum zwischen date1 und date2 in Jahren (eine negative Zahl, wenn date1 nach date2 liegt)
Anmerkung:
  • Unterscheiden sich Monat, Tag oder Zeitteile dieser zwei Daten, beinhaltet das Ergebnis einen fraktionalen Teil, das unvollständige Jahr als einen Bruch der Anzahl Tage zählend (365 oder 366) in dem Jahr des späteren der zwei Daten.

Beispiele Europäisches Datumsformat: countyears(#09/01/2004, #09/01/1994) ergibt -10.

Amerikanisches Datumsformat: countyears(#01/09/2004, #01/09/1994) ergibt -10.

JMT-Datumsformat: countyears(#2004/01/09, #1994/01/09) ergibt -10.

Siehe auch

countwholeyears, countwholeyearsbackwards

Datumsformate

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


day

Ziel Abrufen des Tages einer Datumsangabe.

Syntax day(date)

Argumente

Typ | Name | Beschreibung
datum | date | Ein Datum

Ergebnis

Typ | Beschreibung
ganze Zahl | Der Tag eines Datum

Beispiele Europäisches Datumsformat: Tag(#09/01/2004) entspricht 9.

Amerikanisches Datumsformat: Tag(#01/09/2004) entspricht 9.

JMT-Datumsformat: Tag(#2004/01/09) entspricht 9.

Siehe auch

Datumsformate

Verteilungsaggregationen: Die by-Klausel

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


dayofweek

Ziel Abrufen einer Zahl, die den Tag eines Datums repräsentiert.

Syntax dayofweek(date)

Argumente

Typ | Name | Beschreibung
datum | date | Ein Datum

Ergebnis

Typ | Beschreibung
ganze Zahl | Der Tag der Woche eines Datums (eine Zahl zwischen 0 und 6, wobei 0 für Sonntag steht)

Beispiele Europäisches Datumsformat: dayofweek(#09/01/2004) entspricht 5 (ein Freitag).

Amerikanisches Datumsformat: dayofweek(#01/09/2004) entspricht 5 (ein Freitag).

JMT-Datumsformat: dayofweek(#2004/01/09) entspricht 5 (ein Freitag).

Siehe auch

Datumsformate

Verteilungsaggregationen: Die by-Klausel

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


gmt2edt

Ziel Konvertierung eines Greenwich Mean Time (GMT)-Datums zu Eastern Daylight Time (EDT).

Syntax gmt2edt(datetimeGMT)

Argumente

Typ | Name | Beschreibung
datum | datetimeGMT | Das zu konvertierende GMT-Datum

Ergebnis

Typ | Beschreibung
datum | Das EDT-Datum, unter Berücksichtigung der Zeitumstellungen

Beispiele Winter: GMT2EDT(#09/01/2004:12:28:53) ergibt 09/01/2004:07:28:53.

Summer: GMT2EDT(#09/07/2004:12:28:53) ergibt 09/07/2004:08:28:53.

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


hour

Ziel Abrufen der Stunden als Teil einer Datumsangabe.

Syntax hour(time)

Argumente

Typ | Name | Beschreibung
datum | time | Datum/Uhrzeit

Ergebnis

Typ | Beschreibung
ganze Zahl | Die Stunden als Teil einer time

Beispiele Europäisches Datumsformat: hour(#09/01/2004:12:28:53) entspricht 12.

Amerikanisches Datumsformat: hour(#01/09/2004:12:28:53) entspricht 12.

JMT-Datumsformat: hour(#2004/01/09:12:28:53) entspricht 12.

Siehe auch

Datumsformate

Verteilungsaggregationen: Die by-Klausel

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


minute

Ziel Abfrage der Minuten einer Datumsangabe.

Syntax minute(time)

Argumente

Typ | Name | Beschreibung
datum | time | Datum/Uhrzeit
Ergebnis
Typ | Beschreibung
ganze Zahl | Die Minuten als Teil einer time

Beispiele Europäisches Datumsformat: minute(#09/01/2004:12:28:53) ergibt 28.

Amerikanisches Datumsformat: minute(#01/09/2004:12:28:53) ergibt 28.

JMT-Datumsformat: minute(#2004/01/09:12:28:53 ergibt 28.

Siehe auch

Datumsformate

Verteilungsaggregationen: Die by-Klausel

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


month

Ziel Abrufen des Monats als Teil einer Datumsangabe.

Syntax month(date)

Argumente

Typ | Name | Beschreibung
datum | date | Ein Datum
Ergebnis
Typ | Beschreibung
ganze Zahl | Der Monat als Teil eines Datums

Beispiele Europäisches Datumsformat: month(#09/01/2004) ergibt 1.

Amerikanisches Datumsformat: month(#01/09/2004) ergibt 1.

JMT-Datumsformat: month(#2004/01/09) ergibt 1.

Siehe auch

Datumsformate

Verteilungsaggregationen: Die by-Klausel

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


now

Ziel Abrufen von Systemdatum und -zeit.

Syntax now()

Argumente Keine

Ergebnis

Typ | Beschreibung
datum | Das aktuelle Datum (einschließlich Uhrzeit), abgerufen von der Systemuhr
Beispiele Europäisches Datumsformat: now() ergibt 09/01/2004:12:28:53.

Amerikanisches Datumsformat: now() ergibt 01/09/2004:12:28:53.

JMT-Datumsformat: now() ergibt 2004/01/09:12:28:53.

Siehe auch

Datumsformate

today

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


second

Ziel Abfrage der Sekunden einer Datumsangabe.

Syntax second(time)

Argumente

Typ | Name | Beschreibung
datum | time | Datum/Uhrzeit
Ergebnis
Typ | Beschreibung
ganze Zahl | Die Sekunden als Teil einer Time

Beispiele Europäisches Datumsformat: second(#09/01/2004:12:28:53) ergibt 53.

Amerikanisches Datumsformat: second(#01/09/2004:12:28:53) ergibt 53.

JMT-Datumsformat: second(#2004/01/09:12:28:53) ergibt 53.

Siehe auch

Datumsformate

Verteilungsaggregationen: Die by-Klausel

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


today

Ziel Abrufen des aktuellen Datums.

Syntax today()

Argumente Keine

Ergebnis

Typ | Beschreibung
datum | Das aktuelle Datum, abgerufen von der Systemuhr, mit dem Zeitteil festgelegt auf 00:00:00
Beispiele Europäisches Datumsformat: today() ergibt 09/01/2004:00:00:00.

Amerikanisches Datumsformat: today() ergibt 01/09/2004:00:00:00.

JMT-Datumsformat: today() ergibt 2004/01/09:00:00:00.

Siehe auch

Datumsformate

now

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


weekofyear

Ziel Berechnet das Jahr der Woche einer Datumsangabe in Bezug zu einem angegebenen Startdatum.

Syntax weekofyear(date, yearStart)

Argumente

Typ | Name | Beschreibung
datum | date | Das Datum, dessen Woche des Jahres abgerufen werden soll
datum | yearStart | Das Startdatum (beispielsweise ein Finanzjahr)
Ergebnis
Typ | Beschreibung
ganze Zahl | Die Woche eines Jahres eines date in Bezug auf yearStart
Anmerkung:

Nur die Teile Monat und Tag des StartDate werden verwendet.

Beispiele Europäisches Datumsformat: weekofyear(#09/07/2004, #01/04/2004) ergibt 14.

Amerikanisches Datumsformat: weekofyear(#07/09/2004, #04/01/2004) ergibt 14.

JMT-Datumsformat: weekofyear(#2004/07/09, #2004/04/01) ergibt 14.

Siehe auch

Datumsformate

Verteilungsaggregationen: Die by-Klausel

Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


year

Ziel Abrufen des Jahres als Teil einer Datumsangabe.

Syntax year(date)

Argumente

Typ | Name | Beschreibung
datum | date | Ein Datum

Ergebnis

Typ | Beschreibung
ganze Zahl | Das Jahr als Teil eines date

Beispiele Europäisches Datumsformat: year(#09/01/2004) ergibt 2004.

Amerikanisches Datumsformat: year(#01/09/2004) ergibt 2004.

JMT-Datumsformat: year(#2004/01/09) ergibt 2004.

Siehe auch

Datumsformate
Übergeordnetes Thema: Funktionen für die Arbeit mit Datumsangaben


Mathematische und statistische Funktionen

  • abs
  • ceil
  • cos
  • exp
  • floor
  • Protokoll
  • log10
  • logbase
  • normalisieren
  • pow
  • round
  • sgn
  • sin
  • sqrt
  • tan
Übergeordnetes Thema: FDL-Funktionen


abs

Ziel Berechnung des absoluten Werts einer Zahl.

Syntax abs(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Eine Zahl mit Vorzeichen

Ergebnis

Typ | Beschreibung
als Eingabe | , der absolute Werte oder Größe von x

Beispiele abs(10000) ergibt 10000.

abs(-25000) ergibt 25000.

Berechnung des absoluten Fehlers zwischen einem vorhergesagten Wert und einem historischen Wert: abs(Value - PredictedValue)

Siehe auch

sgn
Übergeordnetes Thema: Mathematische und statistische Funktionen


ceil

Ziel Aufrunden einer Zahl auf das nächste Integer.

Syntax ceil(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Die zu rundende Zahl
Ergebnis
Typ | Beschreibung
ganze Zahl | , das Integer, das diese

Beispiele ceil(1.25) ist gleich 2.

ceil(-1.25) ist gleich -1.

So erzeugen Sie eine Zufallszahl zwischen 1 und einschließlich 10: ceil(rndUniform()*10)

Siehe auch

floor

round

Übergeordnetes Thema: Mathematische und statistische Funktionen


cos

Ziel Berechnen des Cosinus eines Winkels.

Syntax cos(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Ein Winkel im Bogenmaß
Ergebnis
Typ | Beschreibung
Reelle Zahl | cos x der Cosinus von x

Beispiele cos(0) ist gleich 1.

Übergeordnetes Thema: Mathematische und statistische Funktionen


exp

Ziel Berechnen des Exponentials einer Zahl.

Syntax exp(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Die Zahl, deren Exponent berechnet werden soll
Ergebnis
Typ | Beschreibung
Reelle Zahl | , die Exponentialform von x

Beispiele exp(0) ist gleich 1.

Übergeordnetes Thema: Mathematische und statistische Funktionen


floor

Ziel Abrunden einer Zahl auf das nächste Integer.

Syntax floor(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Die zu rundende Zahl
Ergebnis
Typ | Beschreibung
ganze Zahl | , das Integer, das diese

Beispiele floor(1.25) ist gleich 1.

floor(-1.25) ist gleich -2.

So erzeugen Sie eine Zufallszahl zwischen 0 und einschließlich 9: floor(rndUniform()*10)

Siehe auch

ceil

round

Übergeordnetes Thema: Mathematische und statistische Funktionen


Protokoll

Ziel Berechnung des natürlichen Logarithmus (zur Basis e) einer Zahl.

Syntax log(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Eine positive Zahl
Ergebnis
Typ | Beschreibung
Reelle Zahl | , der natürliche Logarithmus von x

Beispiele log(1) ist gleich 0.

Übergeordnetes Thema: Mathematische und statistische Funktionen


log10

Ziel Berechnung des natürlichen Logarithmus (zur Basis 10) einer Zahl.

Syntax log10(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Eine positive Zahl
Ergebnis
Typ | Beschreibung
Reelle Zahl | , der Logarithmus zur Basis 10 von x

Beispiele log10(100) ist gleich 2.

Übergeordnetes Thema: Mathematische und statistische Funktionen


logbase

Ziel Berechnen des Logarithmus einer Zahl zu einer angegebenen Basis.

Syntax logbase(x, base)

Argumente

Typ | Name | Beschreibung
numerisch | x | Die positive Zahl, deren Logarithmus berechnet werden soll
numerisch | base | Die zu verwendende Basis
Ergebnis
Typ | Beschreibung
Reelle Zahl | , der Logarithmus zur Basis base von x

Beispiele logbase(100,10) ist gleich 2.

Übergeordnetes Thema: Mathematische und statistische Funktionen


normalisieren

Ziel Normalisieren von Feldwerten, die im Interval [0,1] liegen.

Syntax normalize(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Die Zahl, die normalisiert werden soll
Ergebnis
Typ | Beschreibung
Reelle Zahl | Wert zwischen 0 und 1 gegeben durch
Anmerkung:

Sie können diese Funktion nur in einer Decision Studio-Ableitung, der Ableitungsdatei für qsderive oder dem äquivalenten Fenster Felder ableiten, in der Tracker-Datei für qstrack oder in einer Auswahldatei für qsselect verwenden.

Übergeordnetes Thema: Mathematische und statistische Funktionen


pow

Ziel Berechnen des Ergebnisses, wenn eine Zahl als Exponent einer anderen verwendet wird.

Syntax pow(x, exponent)

Argumente

Typ | Name | Beschreibung
numerisch | x | Die Zahl, die einen Exponenten erhält
numerisch | exponent | Der Exponent
Ergebnis
Typ | Beschreibung
Reelle Zahl | , x mit dem Exponenten exponent

Beispiele pow(10, 2) ist gleich 100.

Übergeordnetes Thema: Mathematische und statistische Funktionen


round

Ziel Runden einer Zahl auf das nächste Integer.

Syntax round(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Die zu rundende Zahl
Ergebnis
Typ | Beschreibung
ganze Zahl | Das nächste Integer x oder, im Falle eines Unentschiedens, das größere der beiden nächstliegenden Integer (in absoluten Werten)

Beispiele round(1,25) ist gleich 1.

round(-1,25) ist gleich -1.

round(1,5) ist gleich 2.

round(-1,5) ist gleich -2.

Siehe auch

ceil

floor

Übergeordnetes Thema: Mathematische und statistische Funktionen


sgn

Ziel Berechnung des Signums (Vorzeichens) einer Zahl.

Syntax sgn(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Eine Zahl mit Vorzeichen
Ergebnis
Typ | Beschreibung
als Eingabe | Eine Zahl, die das Vorzeichen von x repräsentiert:

Beispiele sgn(25) ergibt 1.

sgn(-25) ergibt -1.

Siehe auch

abs

Verteilungsaggregationen: Die by-Klausel

Übergeordnetes Thema: Mathematische und statistische Funktionen


sin

Ziel Berechnen des Sinus eines Winkels.

Syntax sin(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Ein Winkel im Bogenmaß
Ergebnis
Typ | Beschreibung
Reelle Zahl | sin x, der Sinus von x

Beispiele sin(3.14159/2) ist gleich 1.

Übergeordnetes Thema: Mathematische und statistische Funktionen


sqrt

Ziel Berechnen der Quadratwurzel einer Zahl.

Syntax sqrt(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Eine nicht-negative Zahl
Ergebnis
Typ | Beschreibung
Reelle Zahl | , die Quadratwurzel aus x

Beispiele sqrt(25) ist gleich 5.

sqrt(-25) ist gleich null.

Übergeordnetes Thema: Mathematische und statistische Funktionen


tan

Ziel Berechnen des Tangens eines Winkels.

Syntax tan(x)

Argumente

Typ | Name | Beschreibung
numerisch | x | Ein Winkel im Bogenmaß
Ergebnis
Typ | Beschreibung
Reelle Zahl | tan x, der Tangens von x
Anmerkung:

Wenn x in der Formel [image] für ein beliebiges Integer n ist, ist tan x nicht definiert. In diesem Fall gibt die FDL-Funktion Null zurück.

Beispiele tan(3.14159/4) ist gleich 1.

Übergeordnetes Thema: Mathematische und statistische Funktionen


Sonstige Funktionen

  • Lagerfach
  • dblookup
  • Mitglied
  • rownum
Übergeordnetes Thema: FDL-Funktionen


Lagerfach

Ziel Erhalten eines Klassenindex entsprechend eines Werts.

Syntax bin(binning, x)

Argumente

Typ | Name | Beschreibung
binning | binning | Eine benannte Klasseneinteilung mit Parameterwerten (die Literalwerte sein müssen) in Klammern, wenn erforderlich
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Ein mit der Klasseneinteilung kompatibler Wert
Ergebnis
Typ | Beschreibung
ganze Zahl | Der Klassenindex der Klasse, in dem sich x befindet
Anmerkung:
  • Klassenindizes sind positive ganze Zahlen. Bei einer numerischen Klasseneinteilung mit n nominalen Klassen (nummeriert von 2 bis n + 1): Die oberen und unteren Randklassen [siehe Randklassen] werden mit 1 bzw. n + 2 nummeriert, während Klassen für Nullwerte und Klassen für nicht definierte Werte mit n + 3 und n + 4 nummeriert werden.
  • Diese Funktion ist in Decision Studio nicht verfügbar. Wenn jedoch x ein Feld und b die primäre, x zugeordnete Klasseneinteilung ist, können Sie das gleiche Ergebnis mit segindex erzielen:

    segindex() by x

Beispiele Splitten der Aggregationen mittels der konstanten Klassenbreite EqualRange für das Feld Amount. Das resultiert in einer achtfach segmentierten Aggregation (vier interne Klassen zwischen den Betragswerten 20 und 100 plus zwei Randklassen, einer Klasse für Nullwerte und einer Klasse für nicht definierte Werte):

create totalPointsByAmountBands :=

sum(PointsRedeemed) by bin(EqualRange(20, 100, 4), Amount);

Splitten der Aggregationen in acht Segmente, basierend auf der Kampagnenklasseneinteilung PrePost, beginnend am [image] Mai 1999, und mit Aggregationen aus dem Monat vor und nach der Kampagne:

create totalSpendPrePostMayCampaign_ := sum(Amount) by

bin(PrePost(todate(19990401), todate(19990501),

todate(19990601)), PurchaseDate);

Siehe auch

Boolesch

DayFrom, WeekFrom, MonthFrom, YearFrom

DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom

DayMultipleNumBins, WeekMultipleNumBins, MonthMultipleNumBins, YearMultipleNumBins

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo

DayMultipleWidth, WeekMultipleWidth, MonthMultipleWidth, YearMultipleWidth

DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

DayRange, WeekRange, MonthRange, YearRange

DayTo, WeekTo, MonthTo, YearTo

EqualRange

EqualRangeWidth

NegativeNonNegative

PreDuringPost

PrePost

Sign

Verteilungsaggregationen: Die by-Klausel

Übergeordnetes Thema: Sonstige Funktionen


dblookup

Ziel Werte in einer Referenztabelle (als Fokus gespeichert) nachschlagen.

Syntax dblookup(d, k, f, x)

Argumente

Typ | Name | Beschreibung
Zeichenfolge | d | Der Pfadname der Nachschlagetabelle
Zeichenfolge | k | Der Name des Schlüsselfelds in der Nachschlagetabelle
Zeichenfolge | f | Der Name eines weiteren Feldes in der Nachschlagetabelle
wie Feld k | x | Der Nachschlagewert

Ergebnis

Typ | Beschreibung
wie Feld f | Der Wert y im Feld f der Tabelle d, für den mit x indexierten Datensatz, auftretend im Feld k

Anmerkung:
  • Sie sollten diese Funktion nur für kleine Nachschlagetabellen verwenden. Wenn die Größe der Nachschlagetabelle mit einer Transaktionstabelle oder einer Kundentabelle vergleichbar ist, sollten Sie sie verknüpfen.
  • Wenn der Nachschlagewert nicht im Schlüsselfeld auftritt, wird der Nullwert ausgegeben.
  • Wenn der Nachschlagewert mehr als einmal im Schlüsselfeld auftritt, wird der erste Wert verwendet.
  • Nachfolgende, nichtdruckbare Zeichen werden vom Nachschlagewert entfernt, jedoch nicht von den Werten im Schlüsselfeld der Nachschlagetabelle. Dies kann zu unerwartetem Verhalten führen, wenn das Schlüsselfeld in der Nachschlagetabelle Werte mit nachfolgenden nichtdruckbaren Zeichen enthält.
  • Sie können den String focus: dem Pfadnamen der Nachschlagetabelle voranstellen, um eine Rückwärtskompatibilität zu erhalten.

Beispiel In einem Fokus ist das Geschäft, in dem ein Kunde am häufigsten einkauft, im Feld PopularShop gespeichert. Ein weiterer Fokus stores.ftr enthält eine Nachschlagetabelle, die die Einrichtungen in allen Geschäften beschreibt: In diesem Fokus ist StoreCode das Schlüsselfeld und das Feld HasFuel zeigt an, ob das Geschäft eine Tankstelle hat. Geschäft 105 ist eine Tankstelle angeschlossen, den Geschäften 299 und 204 nicht usw., Geschäft 189 ist in der Suchtabelle nicht enthalten. Ein Feld ableiten, das kennzeichnet, ob alle bevorzugten Geschäfte eines jeden Kunden eine Tankstelle haben.

PopularShop | dblookup("focus:stores.ftr", "StoreCode", "HasFuel", PopularShop)
105 | 1
299 | 0
204 | 0
189 | Null

Siehe auch

Informatinoen zur Kombination von Fokussen
Übergeordnetes Thema: Sonstige Funktionen


Mitglied

Ziel Bestimmung der Satzmitgliedschaft.

Syntax

member(x, [image], [image], ...)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Der zu testende Wert
als x | , [image] , ... | Die Elemente des Satzes

Ergebnis

Typ | Beschreibung
ganze Zahl | 1 (true) wenn x im Satz enthalten ist [image] ; sonst 0 (false)
Anmerkung:
  • Sie können für die Liste der Satzelemente nur literale Werte verwenden (Zahlen, Zeichenfolgen oder Daten).
  • Im Allgemeinen ist es wesentlich effizienter, die Mitgliedsfunktion anstelle einer Disjunktion von Gleichwertigkeitstests zu verwenden. Beispiel: Der Ausdruck strmember(F, "a", "b", "c") ist schneller evaluiert als F = "a" or F = "b" or F = "c".
  • Aus Gründen der Rückwärtskompatibilität können Sie strmember anstelle von member verwenden, wenn es sich bei den Argumenten um Zeichenfolgen handelt.
  • Führender Zwischenraum in Zeichenfolgewerten werden nicht ignoriert.

Beispiele So verwenden Sie die ersten zwei Zeichen eines Feldes StateCode zur Identifizierung von Westküstenkunden:

StateCode | member (substr (StateCode, 0, 1), "CA", "OR", WA")
OR009 | 1
CA043 | 1
UT005 | 0
WA027 | 1

So markieren Sie Kunden, deren zehnstelligen, numerischen Telefonnummern die Vorwahlen für Edinburgh (131) oder Glasgow (141) enthalten (durch Feststellung der ersten drei Ziffern mithilfe des Elements div [siehe Arithmetische Operatoren] Operator):

TelNo | if member (TelNo div 10000000, 131, 141) then "Edin/Glas" else null
1312204491 | Edin/Glas
1753833999 | Null
1611234567 | Null
1417654321 | Edin/Glas

Siehe auch

Verteilungsaggregationen: Die by-Klausel
Übergeordnetes Thema: Sonstige Funktionen


rownum

Ziel Generieren der Nummer jeder Zeile in der Tabelle.

Syntax rownum()

Argumente Keine

Ergebnis

Typ | Beschreibung
ganze Zahl | Eine Indexnummer von 1 bis zur Anzahl der Datensätze in der Tabelle
Anmerkung:

Sie können diese Funktion nur in einer Decision Studio-Ableitung, der Ableitungsdatei für qsderive oder dem äquivalenten Fenster „Felder ableiten“, in der Tracker-Datei für qstrack oder in einer Auswahldatei für qsselect verwenden.

Beispiele Um eine Indexspalte zu einem N-Datensatz hinzuzufügen, mit Werten [image]:

ID | rownum()
AZ195 | 1
DI539 | 2
JD974 | 3
BY643 | 4
Übergeordnetes Thema: Sonstige Funktionen


ROI-Funktionen

  • ActionROI
  • ActionROIAnnualized
  • OfferROI
  • OfferROIAnnualized
  • RetentionActionROI
  • RetentionActionROIAnnualized
  • RetentionOfferROI
  • RetentionOfferROIAnnualized
Übergeordnetes Thema: FDL-Funktionen


ActionROI

Ziel Schätzen des Return-on-Investment-Beitrags pro Kunde (Geld) aus einer Handlung, die eine definitive Antwort erzeugt. Die Handlung geschieht, unabhängig davon, ob der Kunde reagiert, daher gibt es nur die Kosten der Maßnahme, nicht der Erfüllung.

Syntax ActionROI(ResponseProbability, ValueOfResponse, CostOfAction)

Argumente

Typ | Name | Beschreibung
numerisch | ResponseProbability | Die geschätzte Wahrscheinlichkeit, dass der Kunde auf die Aktion reagieren wird, indem er ein Ansprechverhalten zeigt
numerisch | ValueOfResponse | Der geschätzte Wert der Kundenreaktion auf die Marketingaktion (wenn sie eintritt)
numerisch | CostOfAction | Die geschätzten Kosten der Maßnahme (ob der Kunde reagiert oder nicht)
Ergebnis
Typ | Beschreibung
numerisch | Der geschätzte Return on Investment-Beitrag pro Kunde (Geld) nach vorgenommener Aktion
Anmerkung:
  • Die Antwort-Wahrscheinlichkeit sollte ein „Uplift“ sein, das heißt, die Wahrscheinlichkeit, dass der Kunde dieses Verhalten zeigt, wenn sie sonst nichts getan hätten. Wenn es irgendeine Möglichkeit gibt, dass Kunden ohne die Maßnahme das gewünschte Verhalten zeigen, sollten Sie dies mit Hilfe eines Uplifts modellieren oder, wenn das fehlschlägt, durch Subtraktion der Wahrscheinlichkeit der Reaktion, wenn die Aktion der Wahrscheinlichkeit ohne die Aktion gegeben ist.
  • Der Wert der Antwort sollte ein Nettoumsatz sein, bei dem die Kosten für die Marketingaktion ignoriert werden.

Siehe auch

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Übergeordnetes Thema: ROI-Funktionen


ActionROIAnnualized

Ziel Schätzen des annualisierten Return-on-Investment-Mehrfachen pro Kunde bei einer Aktion, die so gestaltet ist, dass sie eine definitive Antwort von einem Kunden generiert. Die Handlung geschieht, unabhängig davon, ob der Kunde reagiert, daher gibt es nur die Kosten der Maßnahme, nicht der Erfüllung.

Syntax ActionROIAnnualized(ResponseProbability, ValueOfResponse, CostOfAction, DaysToROI)

Argumente

Typ | Name | Beschreibung
numerisch | ResponseProbability | Die geschätzte Wahrscheinlichkeit, dass der Kunde auf die Aktion reagieren wird, indem er ein Ansprechverhalten zeigt
numerisch | ValueOfResponse | Der geschätzte Wert der Kundenreaktion auf die Marketingaktion (wenn sie eintritt)
numerisch | CostOfAction | Die geschätzten Kosten der Maßnahme (ob der Kunde reagiert oder nicht)
numerisch | DaysToROI | Die erwartete Anzahl Tage, die erforderlich sind, um die angegebene Rendite (return on investment, ROI) zu erzielen
Ergebnis
Typ | Beschreibung
numerisch | Das geschätzte annualisierte Return on Investment-Mehrfache pro Kunde von der unternommenen Aktion
Anmerkung:
  • Die Antwort-Wahrscheinlichkeit sollte ein „Uplift“ sein, das heißt, die Wahrscheinlichkeit, dass der Kunde dieses Verhalten zeigt, wenn sie sonst nichts getan hätten. Wenn es irgendeine Möglichkeit gibt, dass Kunden ohne die Maßnahme das gewünschte Verhalten zeigen, sollten Sie dies mit Hilfe eines Uplifts modellieren oder, wenn das fehlschlägt, durch Subtraktion der Wahrscheinlichkeit der Reaktion, wenn die Aktion der Wahrscheinlichkeit ohne die Aktion gegeben ist.
  • Der Wert der Antwort sollte ein Nettoumsatz sein, bei dem die Kosten für die Marketingaktion ignoriert werden.

Siehe auch

ActionROI

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Übergeordnetes Thema: ROI-Funktionen


OfferROI

Ziel Schätzen des Return on Investment-Beitrags pro Kunde aus einem Angebot, das eine definitive Antwort erzeugt.

Syntax OfferROI(ResponseProbability, ValueOfResponse, CostOfOffer, CostOfFulfilment)

Argumente

Typ | Name | Beschreibung
numerisch | ResponseProbability | Die geschätzte Wahrscheinlichkeit, dass der Kunde auf die Aktion reagieren wird, indem er ein Ansprechverhalten zeigt
numerisch | ValueOfResponse | Der geschätzte Wert der Kundenreaktion auf die Marketingaktion (wenn sie eintritt)
numerisch | CostOfOffer | Die geschätzten Kosten der Maßnahme (ob der Kunde reagiert oder nicht)
numerisch | CostOfFulfilment | Die geschätzten Kosten für eine erfüllte positive Antwort (Null, wenn keine (zusätzlichen) Kosten für Erfüllung)
Ergebnis
Typ | Beschreibung
numerisch | Der geschätzte Return on Investment pro Kunde von der Angebotslegung
Anmerkung:
  • Die Antwort-Wahrscheinlichkeit sollte ein „Uplift“ sein, das heißt, die Wahrscheinlichkeit, dass der Kunde dieses Verhalten zeigt, wenn sie sonst nichts getan hätten. Wenn es irgendeine Möglichkeit gibt, dass Kunden ohne die Maßnahme das gewünschte Verhalten zeigen, sollten Sie dies mit Hilfe eines Uplifts modellieren oder, wenn das fehlschlägt, durch Subtraktion der Wahrscheinlichkeit der Reaktion, wenn die Aktion der Wahrscheinlichkeit ohne die Aktion gegeben ist.
  • Der Wert der Antwort sollte ein Nettoumsatz sein, der die Kosten für die Marketingaktion und die Kosten der Erfüllung der Kundenantwort ignoriert.

Siehe auch

ActionROI

ActionROIAnnualized

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Übergeordnetes Thema: ROI-Funktionen


OfferROIAnnualized

Ziel Schätzen des annualisierten Return-on-Investment-Mehrfachen pro Kunde eines Angebots, das so gestaltet ist, dass es eine definitive Antwort von einem Kunden generiert.

Syntax OfferROIAnnualized(ResponseProbability, ValueOfResponse, CostOfOffer, CostOfFulfilment, DaysToROI)

Argumente

Typ | Name | Beschreibung
numerisch | ResponseProbability | Die geschätzte Wahrscheinlichkeit, dass der Kunde auf die Aktion reagieren wird, indem er ein Ansprechverhalten zeigt
numerisch | ValueOfResponse | Der geschätzte Wert der Kundenreaktion auf die Marketingaktion (wenn sie eintritt)
numerisch | CostOfOffer | Die geschätzten Kosten der Maßnahme (ob der Kunde reagiert oder nicht)
numerisch | CostOfFulfilment | Die geschätzten Kosten für eine erfüllte positive Antwort (Null, wenn keine (zusätzlichen) Kosten für Erfüllung)
numerisch | DaysToROI | Die erwartete Anzahl Tage, die erforderlich sind, um die angegebene Rendite (return on investment, ROI) zu erzielen
Ergebnis
Typ | Beschreibung
numerisch | Die geschätzte annualisierte Return on Investment Multiple pro Kunde von der Angebotslegung
Anmerkung:
  • Die Antwort-Wahrscheinlichkeit sollte ein „Uplift“ sein, das heißt, die Wahrscheinlichkeit, dass der Kunde dieses Verhalten zeigt, wenn sie sonst nichts getan hätten. Wenn es irgendeine Möglichkeit gibt, dass Kunden ohne die Maßnahme das gewünschte Verhalten zeigen, sollten Sie dies mit Hilfe eines Uplifts modellieren oder, wenn das fehlschlägt, durch Subtraktion der Wahrscheinlichkeit der Reaktion, wenn die Aktion der Wahrscheinlichkeit ohne die Aktion gegeben ist.
  • Der Wert der Antwort sollte ein Nettoumsatz sein, der die Kosten für die Marketingaktion und die Kosten der Erfüllung der Kundenantwort ignoriert.

Siehe auch

ActionROI

ActionROIAnnualized

OfferROI

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Übergeordnetes Thema: ROI-Funktionen


RetentionActionROI

Ziel Schätzen des Return-on-Investment-Beitrags pro Kunde (Geld) aus einer Handlung, die Abgänge verhindert. Für die Aktion werden feste Kosten angenommen, unabhängig davon, ob der Kunde gesichert ist oder nicht und ob ein Kunde das Angebot „akzeptiert“ oder nicht.

Syntax RetentionActionROI(SaveProbability, NetRevenueAtRisk, CostOfAction)

Argumente

Typ | Name | Beschreibung
numerisch | SaveProbability | Die geschätzte Wahrscheinlichkeit, dass der Kunde als Folge der getroffenen Aktion „gesichert“ wird (für den betrachteten Zeitraum)
numerisch | NetRevenueAtRisk | Der geschätzte Nettoumsatz, der verloren geht, wenn der Kunde im betrachteten Zeitraum abgängig wird
numerisch | CostOfAction | Die geschätzten Kosten der Maßnahme (ob der Kunde reagiert oder nicht)
Ergebnis
Typ | Beschreibung
numerisch | Schätzung des Return on Investment-Beitrags pro Kunde (Geld) aus einer Handlung, die Abgänge verhindert
Anmerkung:
  • Zu sagen, dass ein Kunde „gesichert“ ist, bedeutet „wurde dazu gebracht nicht zu gehen, was er andernfalls getan hätte“. Dieser Wert ist der negative Uplift der Abgangsrate, die durch ein Uplift-Modell produziert wird. Alternativ kann es als P (Abgang|keine Aktion) berechnet werden - P (Abgang|Aktion).
  • Bei dem gefährdeten Nettoumsatz sollte es sich um einen Nettoumsatz handeln, der die Kosten zur Verhinderung der Aktion ignoriert.

Siehe auch

ActionROI

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROIAnnualized

RetentionOfferROI

RetentionOfferROIAnnualized

Übergeordnetes Thema: ROI-Funktionen


RetentionActionROIAnnualized

Ziel Schätzen des annualisierten Return-on-Investment-Beitrags pro Kunde aus einer Handlung, die Abgänge verhindert. Für die Aktion werden feste Kosten angenommen, unabhängig davon, ob der Kunde gesichert ist oder nicht und ob ein Kunde das Angebot „akzeptiert“ oder nicht.

Syntax RetentionActionROIAnnualized(SaveProbability, NetRevenueAtRisk, CostOfAction, DaysToROI)

Argumente

Typ | Name | Beschreibung
numerisch | SaveProbability | Die geschätzte Wahrscheinlichkeit, dass der Kunde als Folge der getroffenen Aktion „gesichert“ wird (für den betrachteten Zeitraum)
numerisch | NetRevenueAtRisk | Der geschätzte Nettoumsatz, der verloren geht, wenn der Kunde im betrachteten Zeitraum abgängig wird
numerisch | CostOfAction | Die geschätzten Kosten der Maßnahme (ob der Kunde reagiert oder nicht)
numerisch | DaysToROI | Die erwartete Anzahl Tage, die erforderlich sind, um die angegebene Rendite (return on investment, ROI) zu erzielen
Ergebnis
Typ | Beschreibung
numerisch | Schätzung des annualisierten Return on Investment-Beitrags pro Kunde aus einer Handlung, die Abgänge verhindert
Anmerkung:
  • Zu sagen, dass ein Kunde „gesichert“ ist, bedeutet „wurde dazu gebracht nicht zu gehen, was er andernfalls getan hätte“. Dieser Wert ist der negative Uplift der Abgangsrate, die durch ein Uplift-Modell produziert wird. Alternativ kann es als P (Abgang|keine Aktion) berechnet werden - P (Abgang|Aktion).
  • Bei dem gefährdeten Nettoumsatz sollte es sich um einen Nettoumsatz handeln, der die Kosten zur Verhinderung der Aktion ignoriert.

Siehe auch

ActionROI

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionOfferROI

RetentionOfferROIAnnualized

Übergeordnetes Thema: ROI-Funktionen


RetentionOfferROI

Ziel Schätzen des Return on Investment pro Kunde auf ein Angebot, das so gestaltet ist, dass es den Abgang verhindert. Ein Angebot, im Gegensatz zu einer Aktion, hat eine andere Kostenstruktur, je nachdem, ob es von dem Kunden akzeptiert wird oder nicht.

Syntax RetentionOfferROI(SaveProbability, ResponseProbability, NetRevenueAtRisk, CostOfOffer, CostOfFulfilment)

Argumente

Typ | Name | Beschreibung
numerisch | SaveProbability | Die geschätzte Wahrscheinlichkeit, dass der Kunde als Folge der getroffenen Aktion „gesichert“ wird (für den betrachteten Zeitraum)
numerisch | ResponseProbability | Die geschätzte Wahrscheinlichkeit, dass der Kunde auf das Angebot reagiert
numerisch | NetRevenueAtRisk | Der geschätzte Nettoumsatz, der verloren geht, wenn der Kunde im betrachteten Zeitraum abgängig wird
numerisch | CostOfOffer | Die geschätzten Kosten des Angebots (ob der Kunde reagiert oder nicht)
numerisch | CostOfFulfilment | Die geschätzten Kosten für die Erfüllung einer positiven Resonanz auf das Angebot

Ergebnis

Typ | Beschreibung
numerisch | Der geschätzte Return on Investment pro Kunde auf ein Angebot, das so gestaltet ist, dass ein Abgang verhindert wird
Anmerkung:
  • Zu sagen, dass ein Kunde „gesichert“ ist, bedeutet „wurde dazu gebracht nicht zu gehen, was er andernfalls getan hätte.“ Dieser Wert ist minus dem Uplift der Abgangsrate, die durch ein Uplift-Modell produziert wird. Alternativ kann es als P (Abgang|keine Aktion) berechnet werden - P (Abgang|Aktion).
  • Bei dem gefährdeten Nettoumsatz sollte es sich um einen Nettoumsatz handeln, der die Kosten zur Verhinderung der Aktion ignoriert.

Siehe auch

ActionROI

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROIAnnualized

Übergeordnetes Thema: ROI-Funktionen


RetentionOfferROIAnnualized

Ziel Schätzen des annualisierten Return on Investment pro Kunde auf ein Angebot, das so gestaltet ist, dass es den Abgang verhindert. Ein Angebot, im Gegensatz zu einer Aktion, hat eine andere Kostenstruktur, je nachdem, ob es von dem Kunden akzeptiert wird oder nicht.

Syntax RetentionOfferROIAnnualized(SaveProbability, ResponseProbability, NetRevenueAtRisk, CostOfOffer, CostOfFulfilment, DaysToROI)

Argumente

Typ | Name | Beschreibung
numerisch | SaveProbability | Die geschätzte Wahrscheinlichkeit, dass der Kunde als Folge der getroffenen Aktion „gesichert“ wird (für den betrachteten Zeitraum)
numerisch | ResponseProbability | Die geschätzte Wahrscheinlichkeit, dass der Kunde auf das Angebot reagiert
numerisch | NetRevenueAtRisk | Der geschätzte Nettoumsatz, der verloren geht, wenn der Kunde im betrachteten Zeitraum abgängig wird
numerisch | CostOfOffer | Die geschätzten Kosten des Angebots (ob der Kunde reagiert oder nicht)
numerisch | CostOfFulfilment | Die geschätzten Kosten für die Erfüllung einer positiven Resonanz auf das Angebot
numerisch | DaysToROI | Die erwartete Anzahl Tage, die erforderlich sind, um die angegebene Rendite (return on investment, ROI) zu erzielen
Ergebnis
Typ | Beschreibung
numerisch | Der geschätzte annualisierte Return on Investment pro Kunde auf ein Angebot, das so gestaltet ist, dass ein Abgang verhindert wird
Anmerkung:
  • Zu sagen, dass ein Kunde „gesichert“ ist, bedeutet „wurde dazu gebracht nicht zu gehen, was er andernfalls getan hätte.“ Dieser Wert ist minus dem Uplift der Abgangsrate, die durch ein Uplift-Modell produziert wird. Alternativ kann es als P (Abgang|keine Aktion) berechnet werden - P (Abgang|Aktion).
  • Bei dem gefährdeten Nettoumsatz sollte es sich um einen Nettoumsatz handeln, der die Kosten zur Verhinderung der Aktion ignoriert.

Siehe auch

ActionROI

ActionROIAnnualized

OfferROI

OfferROIAnnualized

RetentionActionROI

RetentionActionROIAnnualized

RetentionOfferROI

Übergeordnetes Thema: ROI-Funktionen


Zufallszahlenfunktionen

  • Informationen zu Zufallszahlenfunktionen in FDL
  • rndBinomial
  • rndBool
  • rndExp
  • rndGamma
  • rndNormal
  • rndPoisson
  • rndUniform
Übergeordnetes Thema: FDL-Funktionen


Informationen zu Zufallszahlenfunktionen in FDL

Beim Bewerten eines FDL-Ausdrucks mithilfe einer Zufallszahlfunktion (numericTestTrainSplit, numericTestTrainValidateSplit, rndBinomial, rndBool, rndExp, rndGamma, rndNormal, rndPoisson, oder rndUniform sampleEqualSize, sampleExactNumber, sampleExactPercentage, sampleStratified, testTrainSplit und testTrainValidateSplit) benötigt Portrait Miner einen Integer-„Startparameter“, um seine Sequenz von Zufallszahlen zu initialisieren. Mit demselben Startparameter zeigt derselbe Ausdruck immer dieselbe Reihenfolge der Ergebnisse.
Anmerkung:
  • Der Startparameter wird als Teil des Feldes gespeichert.
  • Die Erzeugung von (Pseudo-)Zufallszahlen basiert auf der von Marsaglia, Zaman und Tsang (1990).
Übergeordnetes Thema: Zufallszahlenfunktionen


rndBinomial

Ziel Erzeugen einer Integer-Zufallszahl auf Basis der Binomialverteilung.

Syntax rndBinomial(N, p)

Argumente

Typ | Name | Beschreibung
ganze Zahl | N | Die (positive) Anzahl der Versuche
numerisch | p | Die Wahrscheinlichkeit des Erfolgs für jeden Versuch (zwischen 0 und 1)

Ergebnis

Typ | Beschreibung
ganze Zahl | Ein zufälliges nicht-negative Integer aus der Binomialverteilung, mit Wahrscheinlichkeit gegeben durch
Anmerkung:

Der Erwartungswert und die Abweichung der Binomialverteilung sind entsprechend [image] und [image].

Beispiele rndBinomial (50, 0,05)

Siehe auch

Informationen zu Zufallszahlenfunktionen in FDL
Übergeordnetes Thema: Zufallszahlenfunktionen


rndBool

Ziel Erzeugen von 0 oder 1 nach Zufallsprinzip (mit gleicher Wahrscheinlichkeit).

Syntax rndBool()

Argumente Keine

Ergebnis

Typ | Beschreibung
ganze Zahl | Entweder 0 oder 1, mit Wahrscheinlichkeiten

Beispiele So leiten Sie ein Feld ab, das den Wert 0 an ca. 50 % der Datensätze (zufällig ausgewählt) und den Wert 1 an den Rest zugewiesen hat: rndBool()

Siehe auch

Informationen zu Zufallszahlenfunktionen in FDL
Übergeordnetes Thema: Zufallszahlenfunktionen


rndExp

Ziel Erzeugen einer positiven Zufallszahl auf der Basis der Exponentialverteilung.

Syntax rndExp(b)

Argumente

Typ | Name | Beschreibung
numerisch | b | Der (positive) Skalenparameter

Ergebnis

Typ | Beschreibung
Reelle Zahl | Eine positive Zufallszahl, aus einer Exponentialverteilung abgefragt, mit Wahrscheinlichkeit einer Dichtefunktion gegeben durch [image] (x > 0)
Anmerkung:

Der Erwartungswert und die Abweichung der Exponentialverteilung sind entsprechend [image] und [image].

Beispiele rndExp(10)

Siehe auch

Informationen zu Zufallszahlenfunktionen in FDL
Übergeordnetes Thema: Zufallszahlenfunktionen


rndGamma

Ziel Erzeugen einer positiven Zufallszahl auf der Basis der Gammaverteilung.

Syntax rndGamma(a, b)

Argumente

Typ | Name | Beschreibung
ganze Zahl | a | Die (positive) Zahl von unabhängigen Ereignissen
numerisch | b | Die (positive) Ereignisrate

Ergebnis

Typ | Beschreibung
Reelle Zahl | Eine positive Zufallszahl, aus der Gammaverteilung [image] abgefragt, mit Wahrscheinlichkeit einer Dichtefunktion spezifiziert durch
Anmerkung:

Der Erwartungswert und die Abweichung der Gammaverteilung sind entsprechend [image] und [image].

Beispiele rndGamma (50, 0,05)

Siehe auch

Informationen zu Zufallszahlenfunktionen in FDL
Übergeordnetes Thema: Zufallszahlenfunktionen


rndNormal

Ziel Erzeugen einer positiven Zufallszahl auf der Basis der Normalverteilung.

Syntax

rndNormal( [image], ef="../../../images/img344.gif"/>h>

Argumente

Typ | Name | Beschreibung
numerisch |  | Der Mittelwert der Verteilung
numerisch |  | Die Standardabweichung der Normalverteilung

Ergebnis

Typ | Beschreibung
Reelle Zahl | Eine positive Zufallszahl, aus einer Normalverteilung [image] abgefragt, mit Wahrscheinlichkeit einer Dichtefunktion spezifiziert durch
Anmerkung:

Der Erwartungswert und die Abweichung der Normalverteilung sind entsprechend [image] und [image].

Beispiele So leiten Sie eine Gaußverteilung mit Mittelwert Null und Einheitsstandardabweichung ab: rndNormal(0,1)

Siehe auch

Informationen zu Zufallszahlenfunktionen in FDL
Übergeordnetes Thema: Zufallszahlenfunktionen


rndPoisson

Ziel Erzeugen einer zufälligen nicht-negativen Zahl auf Basis der diskreten Poissonverteilung.

Syntax rndPoisson(mean)

Argumente

Typ | Name | Beschreibung
numerisch |  | Der (positive) Mittelwert der Verteilung

Ergebnis

Typ | Beschreibung
ganze Zahl | Ein zufälliges nicht-negative Integer aus der diskreten Poissonverteilung, mit Wahrscheinlichkeit gegeben durch [image] ( [image] )
Anmerkung:

Der Erwartungswert und die Abweichung einer diskreten Poissonverteilung entsprechen dem Mittelwert, [image].

Beispiele rndPoisson(10)

Siehe auch

Informationen zu Zufallszahlenfunktionen in FDL
Übergeordnetes Thema: Zufallszahlenfunktionen


rndUniform

Ziel Erzeugen einer Zufallszahl zwischen 0 und 1 auf der Basis einer gleichmäßigen Verteilung.

Syntax rndUniform()

Argumente Keine

Ergebnis

Typ | Beschreibung
Reelle Zahl | Eine zufällige Zahl aus einer gleichmäßigen Verteilung über den Bereich [0, 1)

Beispiele Erzeugen einer reellen Zufallszahl im Bereich [0,10): rndUniform() * 10

Siehe auch

Informationen zu Zufallszahlenfunktionen in FDL
Übergeordnetes Thema: Zufallszahlenfunktionen


Rang-Funktionen

  • rankOrder, rankOrderApprox
  • rankOrderMean, rankOrderApproxMean
Übergeordnetes Thema: FDL-Funktionen


rankOrder, rankOrderApprox

Ziel Identifizieren des Rangs eines Werts in einer Werteliste.

Syntax

rankOrder(x, [image], [image], ...)

rankOrderApprox(x, [image], [image], ...)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Der einzustufende Wert
als x | , [image] , ... | Die Liste der Vergleichswerte

Ergebnis

Typ | Beschreibung
ganze Zahl | Die Position des ersten Auftretens von x in der Werteliste, die durch die Sortierung von [image] , [image] , ... in absteigender Reihenfolge erhalten wurde (aktuellstes bis frühestes bei Datumsangaben; umgekehrte alphabetische Reihenfolge bei Strings) Wenn x nicht in der Liste erscheint, ergibt rankOrder null, rankOrderApprox hingegen ergibt die Position von x in der Werteliste als Ergebnis einer Sortierung nach x, [image] , [image] , ... in absteigender Reihenfolge.
Anmerkung:
  • Wenn der einzuordnende Wert genau einmal in der Werteliste vorkommt, führen rankOrder, rankOrderApprox, rankOrderMean und rankOrderApproxMean zu demselben Ergebnis.
  • Wenn der einzustufende Wert mehr als einmal in der Werteliste vorkommt, gibt „rankOrderApprox“ dasselbe Ergebnis wie „rankOrder“.
  • Wenn der einzustufende Wert nicht in der Werteliste vorkommt, gibt „rankOrderApprox“ dasselbe Ergebnis wie „rankOrderApproxMean“.
  • Bei Strings bedeutet „alphabetische Reihenfolge“ die natürliche Ordnung der zugrunde liegenden Zeichendarstellung.

Beispiele rankOrder(6,74, 6,74, 1,99, 0,00, 9,27) ist gleich 2.

rankOrderApprox(6,74, 1,99, 0,00, 9,27) ist gleich 2.

Um zu überprüfen, auf welchem Platz die Anzahl der Anrufe eines Kunden im 4. Quartal während eines Jahres eingestuft sind:

rankOrder(CallsQ4, CallsQ1, CallsQ2, CallsQ3, CallsQ4)

Um zu überprüfen, auf welchem Platz die Anzahl der Anrufe eines Kunden im 5. Monat im Vergleich mit den vier Vormonaten eingestuft sind:

RankOrderApprox(CallsM5, CallsM1, CallsM2, CallsM3, CallsM4)

Siehe auch

rankOrderMean, rankOrderApproxMean
Übergeordnetes Thema: Rang-Funktionen


rankOrderMean, rankOrderApproxMean

Ziel Identifizieren des Rangs eines Werts in einer Werteliste oder der durchschnittliche Rang, wenn er mehr als einmal vorkommt.

Syntax

rankOrderMean(x, [image], [image], ...)

rankOrderApproxMean(x, [image], [image], ...)

Argumente

Typ | Name | Beschreibung
ganze Zahl, reelle Zahl, datum, oder Zeichenfolge | x | Der einzustufende Wert
als x | , [image] , ... | Die Liste der Vergleichswerte

Ergebnis

Typ | Beschreibung
Reelle Zahl | Der mittlere Rang von x in der Werteliste, die durch die Sortierung von [image] , [image] , ... in absteigender Reihenfolge erhalten wurde (aktuellstes bis frühestes bei Datumsangaben; umgekehrte alphabetische Reihenfolge bei Strings) Wenn x nicht in der Liste erscheint, ergibt rankOrderMean null, rankOrderApproxMean hingegen ergibt die Position von x in der Werteliste als Ergebnis einer Sortierung nach x, [image] , [image] , ... in absteigender Reihenfolge.
Anmerkung:
  • Wenn der einzuordnende Wert genau einmal in der Werteliste vorkommt, führen rankOrder, rankOrderApprox, rankOrderMean und rankOrderApproxMean zu demselben Ergebnis.
  • Wenn der einzustufende Wert mehr als einmal in der Werteliste vorkommt, gibt „rankOrderApproxMean“ dasselbe Ergebnis wie „rankOrderMean“.
  • Wenn der einzustufende Wert nicht in der Werteliste vorkommt, gibt „rankOrderApproxMean“ dasselbe Ergebnis wie „rankOrderApprox“.
  • Bei Strings bedeutet „alphabetische Reihenfolge“ die natürliche Ordnung der zugrunde liegenden Zeichendarstellung.

Beispiele rankOrderMean(6,74, 6,74, 1,99, 6,74, 9,27) ist gleich 2,5.

rankOrderApproxMean(6,74, 1,99, 6,74, 9,27, 6,74) ist gleich 2,5.

Siehe auch

rankOrder, rankOrderApprox
Übergeordnetes Thema: Rang-Funktionen


Datenabtast-Funktionen

  • numericTestTrainSplit
  • numericTestTrainValidateSplit
  • sampleEqualSize
  • sampleExactNumber
  • sampleExactPercentage
  • sampleStratified
  • testTrainSplit
  • testTrainValidateSplit
Übergeordnetes Thema: FDL-Funktionen


numericTestTrainSplit

Ziel Erstellen einer Test/Training-Segmentierung zur Verwendung bei der Modellvalidierung.

Syntax numericTestTrainSplit(testFraction)

Argumente

Typ | Name | Beschreibung
Reelle Zahl | testFraction | Der Teil der Daten, der als Testsatz genutzt werden soll
Ergebnis
Typ | Beschreibung
ganze Zahl | Werte 0 für den Trainingssatz oder 1 für den Testsatz

Beispiele So leiten Sie ein Feld ab, das den Wert 0 an ca. 70 % der Datensätze (zufällig ausgewählt) und den Wert 1 an den Rest zugewiesen hat: numericTestTrainSplit(0,3)

Siehe auch

numericTestTrainValidateSplit

sampleEqualSize

testTrainSplit

testTrainValidateSplit

So partitionieren Sie einen Fokus in Muster-Teilgesamtmengen

Übergeordnetes Thema: Datenabtast-Funktionen


numericTestTrainValidateSplit

Ziel Erstellen einer Test-/Schulungs-Validierungssegmentierung zur Verwendung in einer Modellierungsvalidierung.

Syntax numericTestTrainValidateSplit(testFraction, validateFraction)

Argumente

Typ | Name | Beschreibung
Reelle Zahl | testFraction | Der Teil der Daten, der als Testsatz genutzt werden soll
Reelle Zahl | validateFraction | Der Teil der Daten, die als Haltesatz verwendet werden soll
Ergebnis
Typ | Beschreibung
ganze Zahl | Wert 0 für den Trainingssatz, Wert 1 für den Testsatz oder 2 für den Validierungssatz

Beispiele Ableitung eines Feldes, das den Wert 0 etwa 50 % der (zufällig ausgewählten) Datensätze, den Wert 1 etwa 30 % der (ebenfalls zufällig ausgewählten) und den Wert 2 dem Rest zuordnet: numericTestTrainValidateSplit(0,3, 0,2)

Siehe auch

numericTestTrainSplit

sampleEqualSize

testTrainSplit

testTrainValidateSplit

So partitionieren Sie einen Fokus in Muster-Teilgesamtmengen

Übergeordnetes Thema: Datenabtast-Funktionen


sampleEqualSize

Ziel Erstellen eines Segmentierungsindexes, der etwa gleich großen Segmenten Datensätze zuordnet.

Syntax sampleEqualSize(NumberOfSegments)

Argumente

Typ | Name | Beschreibung
ganze Zahl | NumberOfSegments | Die Anzahl der zu erstellenden Segmente
Ergebnis
Typ | Beschreibung
ganze Zahl | Eine Zahl zwischen 1 und NumberOfSegments (einschließlich)

Beispiele So leiten Sie ein Feld ab, das die fünf (etwa) gleiche Gesamtmengen aufzählt. sampleEqualSize(5)

Siehe auch

numericTestTrainSplit

numericTestTrainValidateSplit

testTrainSplit

testTrainValidateSplit

So partitionieren Sie einen Fokus in Muster-Teilgesamtmengen

Übergeordnetes Thema: Datenabtast-Funktionen


sampleExactNumber

Ziel Erstellen einer zufälligen Abfrage einer exakten Größe, die als Anzahl Datensätze festgelegt wurde.

Syntax sampleExactNumber(NumberToSelect)

Argumente

Typ | Name | Beschreibung
ganze Zahl | NumberToSelect | Die Größe der zu erstellenden Abfrage als Anzahl Datensätze

Ergebnis

Typ | Beschreibung
ganze Zahl | 1, wenn ein Datensatz für die Abfrage ausgewählt wurde; andernfalls 0
Anmerkung:
  • Im Fokus nicht aktuell ausgewählten Datensätzen wird der Nullwert zugeordnet.
  • Sie können diese Funktion nur in einer Decision Studio Ableitung, in der Ableitungsdatei für qsderive oder des äquivalenten Fensters derive Fields, in der Tracker-Datei für qstrack oder in einer Auswahldatei für qsselect verwenden.

Beispiele Auswahl von 1.250 für eine Abfrage: sampleExactNumber(1250)

Siehe auch

sampleExactPercentage

sampleStratified

So partitionieren Sie einen Fokus in Muster-Teilgesamtmengen

Übergeordnetes Thema: Datenabtast-Funktionen


sampleExactPercentage

Ziel Erstellen einer zufälligen Abfrage in einer exakten Größe, die als Prozentsatz der Größe der aktuell ausgewählten Gesamtmenge definiert ist.

Syntax sampleExactPercentage(PercentageToSelect)

Argumente

Typ | Name | Beschreibung
ganze Zahl | PercentageToSelect | Die Größe der zu erstellenden Abfrage als Prozentsatz der Größe der aktuellen Gesamtmenge

Ergebnis

Typ | Beschreibung
ganze Zahl | 1, wenn ein Datensatz für die Abfrage ausgewählt wurde; andernfalls 0
Anmerkung:
  • Im Fokus nicht aktuell ausgewählten Datensätzen wird der Nullwert zugeordnet.
  • Wenn PercentageToSelect multipliziert mit der Größe der Gesamtmenge kein Integer ergibt, wird die Zahl (höher oder niedriger) ausgewählt, die PercentageToSelect multipliziert mit der Größe der Gesamtmenge am nächsten liegt und durchschnittlich den spezifizierten Prozentsatz ergibt.
  • Sie können diese Funktion nur in einer Decision Studio Ableitung, in der Ableitungsdatei für qsderive oder des äquivalenten Fensters derive Fields, in der Tracker-Datei für qstrack oder in einer Auswahldatei für qsselect verwenden.

Beispiele 25 % der Gesamtmenge als Beispiel auswählen sampleExactPercentage(25)

Siehe auch

sampleExactNumber

sampleStratified

So partitionieren Sie einen Fokus in Muster-Teilgesamtmengen

Übergeordnetes Thema: Datenabtast-Funktionen


sampleStratified

Ziel Erstellen einer zufälligen Abfrage, die eine exakte Anzahl Datensätze aus einem spezifizierten Segment sowie eine exakte Anzahl Datensätze aus dem Rest der aktuell ausgewählten Gesamtmenge enthält.

Syntax sampleStratified(NumberFromSegmentToSelect, SegmentTotalSize, NumberOutsideSegmentToSelect, OutsideSegmentTotalSize, InSegmentExpression)

Argumente

Typ | Name | Beschreibung
ganze Zahl | NumberFromSegmentToSelect | Die Anzahl der Datensätze in der Abfrage, die aus dem angegebenen Segment ausgewählt werden sollen
ganze Zahl | SegmentTotalSize | Die gesamte Anzahl Datensätze im spezifizierten Segment
ganze Zahl | NumberOutsideSegmentToSelect | Die Anzahl der Datensätze in der Abfrage, die aus der übrigen Gesamtmenge ausgewählt werden sollen
ganze Zahl | OutsideSegmentTotalSize | Die gesamte Anzahl Datensätze in der übrigen Gesamtmenge
ganze Zahl | InSegmentExpression | Der (boolesche) Ausdruck, der bestimmt, ob sich ein Datensatz im spezifizierten Segment befindet oder nicht

Ergebnis

Typ | Beschreibung
ganze Zahl | 1, wenn ein Datensatz für die Abfrage ausgewählt wurde; andernfalls 0
Anmerkung:
  • Im Fokus nicht aktuell ausgewählten Datensätzen wird der Nullwert zugeordnet.
  • Sie können diese Funktion nur in einer Decision Studio Ableitung, in der Ableitungsdatei für qsderive oder des äquivalenten Fensters derive Fields, in der Tracker-Datei für qstrack oder in einer Auswahldatei für qsselect verwenden.

Beispiele Erstellen einer Abfrage, die 2.500 Datensätze aus insgesamt 25.000 weiblichen Personen und 5.000 Datensätze aus insgesamt 75.000 nicht weiblichen Personen umfasst: sampleStratified(2500, 25000, 5000, 75000, Gender = "F")

Siehe auch

sampleExactNumber

sampleExactPercentage

So partitionieren Sie einen Fokus in Muster-Teilgesamtmengen

Übergeordnetes Thema: Datenabtast-Funktionen


testTrainSplit

Ziel Erstellen einer Test/Training-Segmentierung zur Verwendung bei der Modellvalidierung.

Syntax testTrainSplit(testFraction)

Argumente

Typ | Name | Beschreibung
Reelle Zahl | testFraction | Der Teil der Daten, der als Testsatz genutzt werden soll
Ergebnis
Typ | Beschreibung
Zeichenfolge | Stringwerte TestSet oder TrainingSet

Beispiele Um ein Feld mit dem Wert „TrainingSet“ etwa 70 % der Datensätze (zufällig ausgewählt) und den Wert „TestSet“ dem Rest zuordnet, abzuleiten:

testTrainSplit(0,3)

Siehe auch

numericTestTrainSplit

numericTestTrainValidateSplit

sampleEqualSize

testTrainValidateSplit

So partitionieren Sie einen Fokus in Muster-Teilgesamtmengen

Übergeordnetes Thema: Datenabtast-Funktionen


testTrainValidateSplit

Ziel Erstellen einer Test-/Schulungs-Validierungssegmentierung zur Verwendung in einer Modellierungsvalidierung.

Syntax testTrainValidateSplit(testFraction, validateFraction)

Argumente

Typ | Name | Beschreibung
Reelle Zahl | testFraction | Der Teil der Daten, der als Testsatz genutzt werden soll
Reelle Zahl | validateFraction | Der Teil der Daten, die als Haltesatz verwendet werden soll

Ergebnis

Typ | Beschreibung
Zeichenfolge | Stringwerte TestSet, TrainingSet oder ValidationSet

Beispiele Ableitung eines Feldes, das den Wert „TrainingSet“ etwa 50 % der (zufällig ausgewählten) Datensätze, den Wert „TestSet“ etwa 30 % der (ebenfalls zufällig ausgewählten) und den Wert „ValidationSet“ dem Rest zuordnet:

TestTrainValidateSplit(0,3, 0,2)

Siehe auch

numericTestTrainSplit

numericTestTrainValidateSplit

sampleEqualSize

testTrainSplit

So partitionieren Sie einen Fokus in Muster-Teilgesamtmengen

Übergeordnetes Thema: Datenabtast-Funktionen


Funktionen für die Arbeit mit Strings

  • concat
  • endswith
  • find
  • left
  • match
  • mid
  • replaceall
  • replacefirst
  • right
  • soundex
  • startswith
  • strlen
  • strmember
  • Ersatz
  • substr
  • tolower
  • toupper
  • trim
Übergeordnetes Thema: FDL-Funktionen


concat

Ziel Verbinden von zwei oder mehr Strings.

Syntax

concat( [image], [image], ...)

Argumente

Typ | Name | Beschreibung
Zeichenfolge | , [image] , ... | Strings, die verbunden werden sollen
Ergebnis
Typ | Beschreibung
Zeichenfolge | Der String, den man Schreiben der Zeichen von [image] gewonnen wird, gefolgt von der Zeichen von [image] usw.

Beispiele Ableitung des vollständigen Kundennamens aus den zwei Feldern FirstName und Surname:

FirstName | Surname | concat(FirstName," ",Surname)
John | Brown | John Brown
David | Smith | David Smith

Ableitung des vollständigen Kundennamens, aber nur Verwendung derer Initialen:

FirstName | Surname | concat(substr(FirstName,0,0),". ",Surname)
John | Brown | J. Brown
David | Smith | D. Smith
Übergeordnetes Thema: Funktionen für die Arbeit mit Strings


endswith

Ziel Testen, ob ein String mit dem anderen endet.

Syntax endswith(find_text, within_text)

Argumente

Typ | Name | Beschreibung
Zeichenfolge | find_text | Der String, der am Ende gefunden werden soll
Zeichenfolge | within_text | Der zu testende String
Ergebnis
Typ | Beschreibung
ganze Zahl | 1 (true), wenn find_text am Ende von within_text; 0 (false) gefunden wird, ansonsten
Anmerkung:

Die Funktion endswith basiert auf der Funktion match. Es hängt ein $-Zeichen für find_text an, bevor das Ergebnis als regulärer Ausdruck behandelt wird [siehe Regular Expression].

Beispiele So leiten Sie ein Feld ab, das E-Mail-Adressen von .net-Domains markiert:

emailaddress | endswith(".net", EmailAddress)
J.Brown@glob.net | 1
D.Smith@portraitsoftware.com | 0

Siehe auch

find

startswith

Übergeordnetes Thema: Funktionen für die Arbeit mit Strings


find

Ziel Testen, ob ein String innerhalb eines anderen Strings enthalten ist.

Syntax find(find_text, within_text)

Argumente

Typ | Name | Beschreibung
Zeichenfolge | find_text | Der zu findende String
Zeichenfolge | within_text | Der zu testende String

Ergebnis

Typ | Beschreibung
ganze Zahl | 1 (true), wenn find_text gefunden wird in within_text; 0 (false), ansonsten
Anmerkung:

Die Suchfunktion basiert auf der Funktion match und behandelt find_text als einen regulären Ausdruck [siehe Regular Expression].

Beispiele Markierung von E-Mail-Adressen, die den Text „portraitsoftware“ in jeder Kombination aus Groß-/Kleinschreibung enthalten:

emailaddress | find("portraitsoftware", tolower(EmailAddress))
J.BROWN@PORTRAITSOFTWARE.COM | 1
J.Brown@glob.net | 0
D.Smith@portraitsoftware.com | 1

Siehe auch

endswith

startswith

Übergeordnetes Thema: Funktionen für die Arbeit mit Strings


left

Ziel Rückgabe einer Teilzeichenfolge von bestimmter Länge ab Stringende.

Syntax left(text, num_chars)

Argumente

Typ | Name | Beschreibung
Zeichenfolge | Text | Der String, aus dem extrahiert werden soll
ganze Zahl | num_chars | Die Anzahl der Zeichen
Ergebnis
Typ | Beschreibung
Zeichenfolge | Die Teilzeichenfolge, gebildet durch num_chars Zeichen zu Beginn von text
Anmerkung:

Die Funktion left basiert auf der Funktion substr.

Beispiele So verwenden Sie die ersten zwei Zeichen eines Feldes StateCode zur Identifizierung von Westküstenkunden:

StateCode | member (left (StateCode, 2), "CA", "OR", WA")
OR009 | 1
CA043 | 1
UT005 | 0
WA027 | 1

Siehe auch

mid

right

trim

Übergeordnetes Thema: Funktionen für die Arbeit mit Strings


match

Zweck Prüfen einer Zeichenfolge auf Übereinstimmung mit einem regulären Ausdruck [siehe Regular Expression].

Syntax match(regexp, string)

Argumente

Typ | Name | Beschreibung
Zeichenfolge | regexp | Der Reguläre Ausdruck
Zeichenfolge | string | Der zu testende String
Ergebnis
Typ | Beschreibung
ganze Zahl | 1 (true) wenn regexp mit string übereinstimmt; 0 (false) sonst

Beispiele Markierung von Kunden mit einem Kennzeichen, bei denen die Postleitzahl des Wohnorts mit den ersten beiden Zeichen der Postleitzahl der Bankfiliale übereinstimmen (Anwendung der substr Funktion):

HomePostcode | BranchPostCode | match(substr(HomePostcode, 0, 1), substr(BranchPostcode,0,1))
NE25 0AY | NE30 1QX | 1
SW3 | NG18 1HT | 0
CF36 | CF31 1HY | 1
EH9 0NJ | E10 8AJ | 0

Um in einem Firmennamen-Feld nach den ersten drei Zeichen eines Vornamen-Feldes, gefolgt von beliebigem Text, und dann den Inhalt des Zunamen-Feldes zu suchen (Groß-/Kleinschreibung ignorierend):

FirstName | FamilyName | CompanyName | rx := concat( substr(toupper(FirstName),0,2), "[[:print:]]*", toupper(FamilyName); match(rx,toupper(CompanyName))
Patrick | Smith | 1234 Pat Smith Ltd | 1
Patrick | Smith | 1234 Pat J Smith Ltd | 1

Dasselbe Vorgehen, jedoch mit nur einigen Buchstaben oder Stellen und einer einfachen Leerstelle zwischen Vor- und Zuname:

FirstName | FamilyName | CompanyName | rx := concat( substr(toupper(FirstName),0,2), "[[:alnum:]]* ", toupper(FamilyName); match(rx,toupper(CompanyName))
Patrick | Smith | 1234 Pat Smith Ltd | 1
Patrick | Smith | 1234 Pat J Smith Ltd | 0

Siehe auch

replaceall

replacefirst

Verteilungsaggregationen: Die by-Klausel

Übergeordnetes Thema: Funktionen für die Arbeit mit Strings


mid

Ziel Zurückgeben eines Substrings der angegebenen Länge von der Mitte eines Strings.

Syntax mid(text, start_num, num_chars)

Argumente

Typ | Name | Beschreibung
Zeichenfolge | Text | Der String, aus dem extrahiert werden soll
Zeichenfolge | start_num | Der erste Index
Zeichenfolge | num_chars | Die Anzahl der Zeichen
Ergebnis
Typ | Beschreibung
Zeichenfolge | Der Substring, der von den Zeichen num_chars von Zeichenposition start_num (inklusive) Text geformt wird, wobei die Zeichenposition mit 1 beginnend durchnummeriert sind
Anmerkung:

Die Funktion mid basiert auf der Funktion substr.

Beispiele So leiten Sie eine Position aus dem fünften bis siebten Zeichen eines StoreCode ab:

StoreCode | mid(StoreCode, 5, 3)
0114EDI256 | EDI
1863LON836 | LON
9326EDI039 | EDI
0387BOS041 | BOS

Siehe auch

left

right

trim

Übergeordnetes Thema: Funktionen für die Arbeit mit Strings


replaceall

Zweck Ersetzen aller untergeordneten Zeichenfolgen, die mit einem regulären Ausdruck übereinstimmen [sieheRegular Expression].

Syntax replaceall(regexp, replacement, string)

Argumente

Typ | Name | Beschreibung
Zeichenfolge | regexp | Der Reguläre Ausdruck
Zeichenfolge | replacement | Der ersetzende String
Zeichenfolge | string | Der zu suchende String
Ergebnis
Typ | Beschreibung
Zeichenfolge | Eine Kopie des Strings „string“ mit „replacement“ ersetzt die einzelnen, nicht überlappenden Teile, die „regexp“ entsprechen
Anmerkung:

Der erste übereinstimmende Teil des zu suchenden Strings ist der linke, längste Teil, mit dem der reguläre Ausdruck übereinstimmt. Die nächste Suche gilt für den Rest des zu suchenden Strings und so weiter. Zum Beispiel:

replaceall("i..", "X", "initiation")

ergibt den String „XtXX“ (anstatt, sagen wir mal „inXatX“). Und

replaceall("i.*i", "X", "initiation")

führt zum Ergebnis „Xon“ (anstatt, sagen wir „XtXon“).

Beispiele So erkennen und entfernen Sie den Zwischenraum vom Feld „Postcode“ unter Verwendung einer Übereinstimmung mit einem regulären Ausdruck:

PLZ | replaceall("[[:blank:]]","",PostalCode))
ND 069 | ND069
IN 099 | IN099
UT 0 0 5 | UT005
O R 009 | OR009

Siehe auch

match

replacefirst

Übergeordnetes Thema: Funktionen für die Arbeit mit Strings


replacefirst

Ziel Ersetzen des ersten Substrings, der mit einem regulären Ausdruck übereinstimmt [siehe Regular Expression].

Syntax replacefirst(regexp, replacement, string)

Argumente

Typ | Name | Beschreibung
Zeichenfolge | regexp | Der Reguläre Ausdruck
Zeichenfolge | replacement | Der ersetzende String
Zeichenfolge | string | Der zu suchende String
Ergebnis
Typ | Beschreibung
Zeichenfolge | Eine Kopie des Strings „string“ mit „replacement“ ersetzt den ersten Teil, der mit „regexp“ möglicherweise übereinstimmt (Sofern vorhanden)

Beispiele Um den Kundennamen aus dem Feld E-Mail-Adresse in das Format „Vorname.Nachname@Unternehmen.com“ zu extrahieren, indem alles ab „@“ entfernt und das „.“ mit einem Leerzeichen ersetzt wird:

E-Mail | replacefirst("@.*", "", (replacefirst ("\.", " ", Email)))
John.Brown@myco.com | John Brown
Angela.Smith@yourco.com | Angela Smith

Siehe auch

match

replaceall

Übergeordnetes Thema: Funktionen für die Arbeit mit Strings


right

Ziel Zurückgeben eines Substrings der angegebenen Länge vom Ende eines Strings.

Syntax right(text, num_chars)

Argumente

Typ | Name | Beschreibung
Zeichenfolge | Text | Der String, aus dem extrahiert werden soll
ganze Zahl | num_chars | Die Anzahl der Zeichen
Ergebnis
Typ | Beschreibung
Zeichenfolge | Der Substring, geformt von den Zeichen num_chars am Ende von text
Anmerkung:

Die Funktion right basiert auf der Funktion substr.

Beispiele Um den Haus/Straßenbestandteil eines britischen Postleitzahlbereichs wiederzugeben, das heißt, die letzten drei Zeichen:

Postcode | right(Postcode, 3)
NE25 0AY | 0AY
EH3 7RA | 7RA
SL4 1QX | 1QX
EH9 0NJ | 0NJ

Siehe auch

left

mid

trim

Übergeordnetes Thema: Funktionen für die Arbeit mit Strings


soundex

ZielReduzieren jedes Wortes auf einen vierstelligen String für Indexzwecke.

Syntax soundex(text)

Argumente

Typ | Name | Beschreibung
Zeichenfolge | Text | Der zu reduzierende Text
Ergebnis
Typ | Beschreibung
Zeichenfolge | Eine auf vier Zeichen reduzierte Index-Codierung
Beispiele So leiten Sie einen Soundex-Code für einen Familiennamen ab:
Surname | soundex(Surname)
Brown | B650
Smythe | S530
Smith | S530
Bruno | B650
Anmerkung: Die Soundex-Funktion ist nicht für Nicht-ASCII-Zeichen definiert.
Übergeordnetes Thema: Funktionen für die Arbeit mit Strings


startswith

Ziel Testen, ob ein String mit dem anderen beginnt.

Syntax startswith(find_text, within_text)

Argumente

Typ | Name | Beschreibung
Zeichenfolge | find_text | Der String, der am Beginn gefunden werden soll
Zeichenfolge | within_text | Der zu testende String
Ergebnis
Typ | Beschreibung
ganze Zahl | 1, wenn find_text am Beginn von within_text; 0 gefunden werden soll, ansonsten
Anmerkung:

Die Funktion startswith basiert auf der Funktion match. Es stellt ein^ Zeichen find_text voran, bevor das Ergebnis als regulärer Ausdruck behandelt wird [siehe Regular Expression].

Beispiele Um die in der Transaktion verwendete Kreditkarte abzuleiten, wie z. B. „Discover“, „AmEx“, „Visa“ oder„MasterCard“, basierend auf den Kartenvorwahl:

Anfrage

startswith ("6011", CC_Number): "Discover";

startswith ("4", CC_Number): "Visa";

startswith ("5", CC_Number): "MasterCard";

startswith ("34",CC_Number) or startswith ("37", CC_Number): "AmEx";

default: null;

CC_Number | CC_Type
4111-1111-1111-1111 | Visa
5431-1111-1111-1111 | MasterCard
341-1111-1111-1111 | AmEx
6011-6011-6011-6611 | Discover
Siehe auch

endswith

find

Übergeordnetes Thema: Funktionen für die Arbeit mit Strings


strlen

Ziel Ermitteln der Länge eines Strings.

Syntax strlen(string)

Argumente

Typ | Name | Beschreibung
Zeichenfolge | string | Der String, dessen Länge bestimmt werden soll
Ergebnis
Typ | Beschreibung
ganze Zahl | Die Anzahl der Zeichen in string

Beispiele So leiten Sie ein Stringfeld mit genau vier Zeichen durch Auffüllen eines kürzeren Stringfelds mit führenden Nullen ab:

Anfrage

strlen(AccountID) = 1: concat("000", AccountID);

strlen(AccountID) = 2: concat("00", AccountID);

strlen(AccountID) = 3: concat("0", AccountID);

default: AccountID;

AccountID | Konto
1 | 0001
22 | 0022
333 | 0333
4444 | 4444
Übergeordnetes Thema: Funktionen für die Arbeit mit Strings


strmember

Ziel Bestimmung der Satzmitgliedschaft.

Syntax

strmember(x, [image], [image], ...)

Argumente

Typ | Name | Beschreibung
Zeichenfolge | x | Der zu testende Wert
als x | , [image] , ... | Die Elemente des Satzes

Ergebnis

Typ | Beschreibung
ganze Zahl | 1 (true) wenn x im Satz enthalten ist [image] ; sonst 0 (false)
Anmerkung:
  • Sie können für die Liste der Satzelemente nur literale Stringwerte verwenden.
  • Führender Zwischenraum in den Werten werden nicht ignoriert.
  • Diese Funktion wird zu Gunsten der mehr allgemeinen member-Funktion abgelehnt.

Siehe auch

Verteilungsaggregationen: Die by-Klausel
Übergeordnetes Thema: Funktionen für die Arbeit mit Strings


Ersatz

Ziel Ersetzen eines Strings durch einen anderen.

Syntax substitute(text, old_text, new_text)

Argumente

Typ | Name | Beschreibung
Zeichenfolge | Text | Der zu suchende String
Zeichenfolge | old_text | Der zu ersetzende String
Zeichenfolge | new_text | Der ersetzende String

Ergebnis

Typ | Beschreibung
Zeichenfolge | Eine Kopie des Strings text durch new_text, wobei jede nicht überlappende Instanz von old_text ersetzt wird
Anmerkung:

Die Funktion „substitute“ basiert auf der Funktion „replaceall“ und behandelt „old_text“ als einen regulären Ausdruck [siehe Regular Expression].

Beispiele So beseitigen Sie Leerzeichen (whitespace) aus einem Feld mit dem Namen „PostalCode“:

PLZ | substitute(PostalCode, "[[:blank:]]", "")
ND 069 | ND069
IN 099 | IN099
UT 0 0 5 | UT005
O R 009 | OR009

Siehe auch

replacefirst
Übergeordnetes Thema: Funktionen für die Arbeit mit Strings


substr

Zweck Abrufen einer untergeordneten Zeichenfolge aus einer Zeichenfolge

Syntax substr(string, start, end)

Argumente

Typ | Name | Beschreibung
Zeichenfolge | string | Der ursprüngliche String
ganze Zahl | start | Der erste Index
ganze Zahl | end | Der zweite Index

Ergebnis

Typ | Beschreibung
Zeichenfolge | Der aus Zeichen geformte Substring „Start“ bis „Ende“ (inklusive) „String“, wobei die Zeichen beginnend mit 0 durchnummeriert sind. Positive Indexwerte zählen ab Beginn des Strings und negative Indexwerte zählen ab Ende des Strings.

Beispiele Um die ersten zwei und letzten drei Zeichen eines Feldes „PostalCode“ auszuwählen, um den Bundesstaatcode zu erhalten:

PLZ | substr(PostalCode, 0, 1) | substr(PostalCode, -3, -1)
MA015 | MA | 015
WA055 | WA | 055
UT005 | UT | 005
MN119 | MN | 119

Um die in der Transaktion verwendete Kreditkarte abzuleiten, wie z. B. „Discover“, „AmEx“, „Visa“ oder „MasterCard“, basierend auf dem Kartenpräfix:

Anfrage

substr(CC_Number, 0, 3) = "6011": "Discover";

substr(CC_Number, 0, 0) = "4": "Visa";

substr(CC_Number, 0, 0) = "5": "MasterCard";

substr(CC_Number, 0, 1) = "34" oder substr(CC_Number, 0, 1) = "37": "AmEx";

default: null;

CC_Number | CC_Type
4111-1111-1111-1111 | Visa
5431-1111-1111-1111 | MasterCard
341-1111-1111-1111 | AmEx
6011-6011-6011-6611 | Discover
Übergeordnetes Thema: Funktionen für die Arbeit mit Strings


tolower

Ziel Konvertieren eines Strings in Kleinbuchstaben.

Syntax tolower(string)

Argumente

Typ | Name | Beschreibung
Zeichenfolge | string | Ein zu konvertierender String

Ergebnis

Typ | Beschreibung
Zeichenfolge | Der sich ergebende String aus „string“, wenn jeder Großbuchstabe in „string“ durch den entsprechenden Kleinbuchstaben ersetzt wird

Beispiele tolower(„ZYa ("start_date")XWV“) ist gleich „zyxwv“

Siehe auch

toupper
Übergeordnetes Thema: Funktionen für die Arbeit mit Strings


toupper

Ziel Konvertieren eines Strings in Großbuchstaben.

Syntax toupper(string)

Argumente

Typ | Name | Beschreibung
Zeichenfolge | string | Ein zu konvertierender String

Ergebnis

Typ | Beschreibung
Zeichenfolge | Der sich ergebende String aus „string“, wenn jeder Kleinbuchstabe in „string“ durch den entsprechenden Großbuchstaben ersetzt wird

Beispiele toupper(„abcde“) ist gleich „ABCDE“

Siehe auch

tolower
Übergeordnetes Thema: Funktionen für die Arbeit mit Strings


trim

Ziel Entfernt alle Leerzeichen aus einer Textzeichenfolge, außer einzelnen Leerzeichen zwischen Wörtern

Syntax trim(text)

Argumente

Typ | Name | Beschreibung
Zeichenfolge | Text | Zu trimmende String

Ergebnis

Typ | Beschreibung
Zeichenfolge | Der String, gebildet aus text, Beseitigung aller Leerzeichen außer einzelner Leerzeichen zwischen den Wörtern
Anmerkung:

Die Trim-Funktion basiert auf der Funktion replaceall.

Beispiele So leiten Sie ein Feld ab, das mehrere Leerzeichen durch ein einziges Leerzeichen ersetzt:

CommentField | trim(CommentField)
Fehlerhafte Güter zurückgegeben | Fehlerhafte Güter zurückgegeben
Verpasster Termin | Verpasster Termin
Technikerbesuch: Montag | Technikerbesuch: Montag
Gelöst | Gelöst
Übergeordnetes Thema: Funktionen für die Arbeit mit Strings


Klasseneinteilungen

  • Boolesch
  • DayFrom, WeekFrom, MonthFrom, YearFrom
  • DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom
  • DayMultipleNumBins, WeekMultipleNumBins, MonthMultipleNumBins, YearMultipleNumBins
  • DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost
  • DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo
  • DayMultipleWidth, WeekMultipleWidth, MonthMultipleWidth, YearMultipleWidth
  • DayPrePost, WeekPrePost, MonthPrePost, YearPrePost
  • DayRange, WeekRange, MonthRange, YearRange
  • DayTo, WeekTo, MonthTo, YearTo
  • EqualRange
  • EqualRangeWidth
  • NegativeNonNegative
  • PreDuringPost
  • PrePost
  • Sign
Übergeordnetes Thema: Field Derivation Language (FDL) Referenz


Boolesch

Ziel Klassifizieren Boolescher [siehe Boolesche Daten] Werte.

Parameter Keine

Ergebnis

Klassenindex | Werte
1 | false
2 | true
3 | null [siehe Der Nullwert]
4 | unklassifiziert
Übergeordnetes Thema: Klasseneinteilungen


DayFrom, WeekFrom, MonthFrom, YearFrom

Ziel Klassifizieren von Datumswerten in eine angegebene Anzahl von Zeiträumen (Tage, Wochen, Monate oder Jahr) nach einem gegebenen Datum.

Parameter

Typ | Name | Beschreibung
datum | a ("start_date") | Der Beginn des Zeitraumteils der Klasseneinteilung
ganze Zahl | n ("num_bins") | Die Anzahl der Zeiträume (Tage, Wochen, Monate oder Jahre) im Zeitraumteil der Klasseneinteilung
Ergebnis
Klassenindex | Werte
1 | Daten vor a; die untere Randklasse [siehe Randklassen]
2, ..., n + 1 | die n aufeinanderfolgenden Zeiträume nach a
n + 2 | Daten n Zeiträume nach a und später; die obere Randklasse [siehe Randklassen]
n + 3 | null [siehe Der Nullwert]
n + 4 | unklassifiziert

Siehe auch

DayRange, WeekRange, MonthRange, YearRange

DayTo, WeekTo, MonthTo, YearTo

Übergeordnetes Thema: Klasseneinteilungen


DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom

Ziel Klassifizieren von Datumswerten in eine angegebene Anzahl von Zeiträumen nach einem gegebenen Datum, wobei ein Zeitraum eine angegebene Anzahl von Tagen, Wochen, Monaten oder Jahren ist.

Parameter

Typ | Name | Beschreibung
datum | a ("start_date") | Der Beginn des Zeitraumteils der Klasseneinteilung
ganze Zahl | m ("Width") | Die Anzahl der Einheiten (Tage, Wochen, Monate oder Jahre) in einem Zeitraum
ganze Zahl | n ("num_bins") | Die Anzahl der Klassen im Zeitraumteil der Klasseneinteilung
Ergebnis
Klassenindex | Werte
1 | Daten vor a; die untere Randklasse [siehe Randklassen]
2, ..., n + 1 | die n aufeinanderfolgenden Zeiträume (jeweils mit m Einheiten) nach a
n + 2 | Daten n x m Einheiten nach a und später; die obere Randklasse [siehe Randklassen]
n + 3 | null [siehe Der Nullwert]
n + 4 | unklassifiziert

Siehe auch

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo

Übergeordnetes Thema: Klasseneinteilungen


DayMultipleNumBins, WeekMultipleNumBins, MonthMultipleNumBins, YearMultipleNumBins

Ziel Klassifizieren von Datumswerten in ungefähr die angegebene Anzahl von Klassen zwischen zwei gegebenen Daten, wobei der Zeitraum ein feststehendes Mehrfaches der Einheit ist (Tag, Woche, Monat oder Jahr).

Parameter

Typ | Name | Beschreibung
datum | a ("start_date") | Der Beginn des Zeitraumteils der Klasseneinteilung
datum | b ("end_date") | Das Ende des Zeitraumteils der Klasseneinteilung
ganze Zahl | n ("num_bins") | Die Zielanzahl der Zeiträume (Vielfaches von Tag, Woche, Monat oder Jahr) im Zeitraumteil der Klasseneinteilung

Ergebnis

Klassenindex | Werte
1 | Daten vor a; die untere Randklasse [siehe Randklassen]
2, ..., N - 3 | Zeiträume zwischen a und b
N - 2 | Daten b und später; die obere Randklasse [siehe Randklassen]
N - 1 | null [siehe Der Nullwert]
N | unklassifiziert
Anmerkung:
  • Diese Klasseneinteilungen sind wie die Klasseneinteilungen DayRange, WeekRange, MonthRange und YearRange [siehe DayRange, WeekRange, MonthRange, YearRange], nur dass der Zeitraum zwei oder mehr Einheiten (Tage, Wochen, Monate oder Jahre) sein kann, um ungefähr die Zielanzahl an Klassen zu erreichen.
  • Wenn der Zeitraum zwei oder mehr Einheiten beträgt, kann Klasse N - 3 kürzer sein als die Klassen 2 bis N - 4.

Siehe auch

DayMultipleWidth, WeekMultipleWidth, MonthMultipleWidth, YearMultipleWidth
Übergeordnetes Thema: Klasseneinteilungen


DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

Ziel Klassifizieren von Datumswerten in eine angegebene Anzahl von Klassen vor und nach einem gegebenen Bezugsdatum, wobei jede Klasse ein bestimmtes Mehrfaches der Einheit ist (Tag, Woche, Monat oder Jahr).

Parameter

Typ | Name | Beschreibung
datum | a ("ref_date") | Das Bezugsdatum für die Klasseneinteilung
ganze Zahl | m ("Width") | Die Anzahl der Klassen vor und nach dem Referenzdatum
ganze Zahl | n ("num_bins") | Die Anzahl der Einheiten (Tage, Wochen, Monate oder Jahre) in jeder Klasse

Ergebnis

Klassenindex | Werte
1 | Daten vor n x m Einheiten vor a; die untere Randklasse [siehe Randklassen]
2, ..., n + 1 | die n aufeinanderfolgenden Zeiträume (jeweils mit m Einheiten) vor a
n + 2, ..., 2n + 1 | die n aufeinanderfolgenden Zeiträume (jeweils mit m Einheiten) nach a
2n + 2 | Daten n x m Einheiten nach a und später; die obere Randklasse [siehe Randklassen]
2n + 3 | null [siehe Der Nullwert]
2n + 4 | unklassifiziert

Siehe auch

DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom

DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo

DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

PreDuringPost

PrePost

Übergeordnetes Thema: Klasseneinteilungen


DayMultipleTo, WeekMultipleTo, MonthMultipleTo, YearMultipleTo

Ziel Klassifizieren von Datumswerten in eine angegebene Anzahl von Zeiträumen vor einem gegebenen Datum, wobei ein Zeitraum eine angegebene Anzahl von Tagen, Wochen, Monaten oder Jahren ist.

Parameter

Typ | Name | Beschreibung
datum | b ("end_date") | Das Ende des Zeitraumteils der Klasseneinteilung
ganze Zahl | m ("Width") | Die Anzahl der Einheiten (Tage, Wochen, Monate oder Jahre) in einem Zeitraum
ganze Zahl | n ("num_bins") | Die Anzahl der Klassen im Zeitraumteil der Klasseneinteilung
Ergebnis
Klassenindex | Werte
1 | Daten vor n x m Einheiten vor a; die untere Randklasse [siehe Randklassen]
2, ..., n + 1 | die n aufeinanderfolgenden Zeiträume (jeweils mit m Einheiten) vor a
n + 2 | Daten a und später; die obere Randklasse [siehe Randklassen]
n + 3 | null [siehe Der Nullwert]
n + 4 | unklassifiziert

Siehe auch

DayMultipleFrom, WeekMultipleFrom, MonthMultipleFrom, YearMultipleFrom

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

Übergeordnetes Thema: Klasseneinteilungen


DayMultipleWidth, WeekMultipleWidth, MonthMultipleWidth, YearMultipleWidth

Ziel Klassifizieren von Datumswerten in Zeiträume zwischen zwei gegebenen Daten, wobei der Zeitraum ein feststehendes Mehrfaches der Einheit ist (Tag, Woche, Monat oder Jahr).

Parameter

Typ | Name | Beschreibung
datum | a ("start_date") | Der Beginn des Zeitraumteils der Klasseneinteilung
datum | b ("end_date") | Das Ende des Zeitraumteils der Klasseneinteilung
ganze Zahl | m ("Width") | Die Anzahl der Einheiten (Tage, Wochen, Monate oder Jahre) in einem Zeitraum

Ergebnis

Klassenindex | Werte
1 | Daten vor a; die untere Randklasse [siehe Randklassen]
2, ..., N - 3 | Zeiträume zwischen a und b
N - 2 | Daten b und später; die obere Randklasse [siehe Randklassen]
N - 1 | null [siehe Der Nullwert]
N | unklassifiziert
Anmerkung:
  • Diese Klasseneinteilungen sind wie die Klasseneinteilungen DayRange, WeekRange, MonthRange und YearRange [siehe DayRange, WeekRange, MonthRange, YearRange], nur dass der Zeitraum zwei oder mehr Einheiten (Tage, Wochen, Monate oder Jahre) sein kann.
  • Wenn der Zeitraum zwei oder mehr Einheiten beträgt, kann Klasse N - 3 kürzer sein als die Klassen 2 bis N - 4.

Siehe auch

DayMultipleNumBins, WeekMultipleNumBins, MonthMultipleNumBins, YearMultipleNumBins
Übergeordnetes Thema: Klasseneinteilungen


DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

Ziel Klassifizieren von Datumswerten in angegebene Anzahlen von Zeiträumen (Tage, Wochen, Monate oder Jahr) vor und nach einem gegebenen Bezugsdatum.

Parameter

Typ | Name | Beschreibung
datum | a ("ref_date") | Das Bezugsdatum für die Klasseneinteilung
ganze Zahl | m ("before") | Die Anzahl der Zeiträume (Tage, Wochen, Monate oder Jahre) für die Einteilung vor dem Bezugsdatum
ganze Zahl | n ("after") | Die Anzahl der nach dem Bezugsdatum einzuteilenden Zeiträume

Ergebnis

Klassenindex | Werte
1 | Daten früher als m Zeiträume vor a; die untere Randklasse [siehe Randklassen]
2, ..., m + 1 | die m aufeinanderfolgenden Zeiträume vor a
m + 2, ..., m + n + 1 | die n aufeinanderfolgenden Zeiträume nach a
m + n + 2 | Daten n Zeiträume nach a und später; die obere Randklasse [siehe Randklassen]
m + n + 3 | null [siehe Der Nullwert]
m + n + 4 | unklassifiziert

Siehe auch

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

PreDuringPost

PrePost

Übergeordnetes Thema: Klasseneinteilungen


DayRange, WeekRange, MonthRange, YearRange

Ziel Klassifizieren von Datumswerten in eine angegebene Anzahl von Zeiträumen (Tage, Wochen, Monate oder Jahr) zwischen zwei gegebenen Datumsangaben.

Parameter

Typ | Name | Beschreibung
datum | a ("start_date") | Der Beginn des Zeitraumteils der Klasseneinteilung
datum | b ("end_date") | Das Ende des Zeitraumteils der Klasseneinteilung
Ergebnis
Klassenindex | Werte
1 | Daten vor a; die untere Randklasse [siehe Randklassen]
2, ..., N - 3 | Zeiträume (Tage, Wochen, Monate oder Jahre) zwischen a und b
N - 2 | Daten b und später; die obere Randklasse [siehe Randklassen]
N - 1 | null [siehe Der Nullwert]
N | unklassifiziert
Anmerkung:
  • Wenn weniger als ein ganzer Zeitraum zwischen a und b vorhanden ist, enthält Klasse 2 Daten zwischen a (einschließlich) und b (ausschließlich).
  • Wenn keine genaue Anzahl von Zeiträumen zwischen a und b vorhanden ist (aber mindestens ein kompletter Zeitraum), wird die Klasse, die direkt vor b liegt, verlängert, um den Rest aufzunehmen.

Siehe auch

DayFrom, WeekFrom, MonthFrom, YearFrom

DayTo, WeekTo, MonthTo, YearTo

Übergeordnetes Thema: Klasseneinteilungen


DayTo, WeekTo, MonthTo, YearTo

Ziel Klassifizieren von Datumswerten in eine angegebene Anzahl von Zeiträumen (Tage, Wochen, Monate oder Jahr) vor einem gegebenen Datum.

Parameter

Typ | Name | Beschreibung
datum | b ("end_date") | Das Ende des Zeitraumteils der Klasseneinteilung
ganze Zahl | n ("num_bins") | Die Anzahl der Zeiträume (Tage, Wochen, Monate oder Jahre) im Zeitraumteil der Klasseneinteilung
Ergebnis
Klassenindex | Werte
1 | Daten vor n Zeiträumen vor b; die untere Randklasse [siehe Randklassen]
2, ..., n + 1 | die n aufeinanderfolgenden Zeiträume vor b
n + 2 | Daten b und später; die obere Randklasse [siehe Randklassen]
n + 3 | null [siehe Der Nullwert]
n + 4 | unklassifiziert

Siehe auch

DayFrom, WeekFrom, MonthFrom, YearFrom

DayRange, WeekRange, MonthRange, YearRange

Übergeordnetes Thema: Klasseneinteilungen


EqualRange

Ziel Einteilen numerischer Werte in eine angegebene Anzahl gleichgroßer Intervalle.

Parameter

Typ | Name | Beschreibung
Reelle Zahl | a ("from") | Das untere Ende des Equal-Range-Teils der Klasseneinteilung
Reelle Zahl | b ("to") | Das obere Ende des Equal-Range-Teils der Klasseneinteilung
ganze Zahl | n ("num_bins") | Die Anzahl der Klassen im Equal-Range-Teil der Klasseneinteilung

Ergebnis

Klassenindex | Werte
1 | ; die untere Randklasse [siehe Randklassen]
2, ..., n + 1 | [a, a + (b - a)/n), ..., [b - (b - a)/n, b)
n + 2 | ; die obere Randklasse [siehe Randklassen]
n + 3 | null [siehe Der Nullwert]
n + 4 | unklassifiziert

Siehe auch

EqualRangeWidth
Übergeordnetes Thema: Klasseneinteilungen


EqualRangeWidth

Ziel Einteilen numerischer Werte in Intervalle einer angegebenen Breite.

Parameter

Typ | Name | Beschreibung
Reelle Zahl | a ("from") | Das untere Ende des Equal-Range-Teils der Klasseneinteilung
Reelle Zahl | b ("to") | Das obere Ende des Equal-Range-Teils der Klasseneinteilung
Reelle Zahl | r ("width") | Die Breite der Klassen im Equal-Range-Teil der Klasseneinteilung

Ergebnis

Klassenindex | Werte
1 | ; die untere Randklasse [siehe Randklassen]
2, ..., N - 3 | Gleichbreite Klassen mit einer ungefähren Breite r
N - 2 | die obere Randklasse [siehe Randklassen]
N - 1 | null [siehe Der Nullwert]
N | unklassifiziert
Anmerkung:

Wenn a - b kein exaktes Mehrfaches von r ist, wird eine Annäherung zu r durchgeführt, sodass die Klassen zwischen a und b die gleiche Breite haben.

Siehe auch

EqualRange
Übergeordnetes Thema: Klasseneinteilungen


NegativeNonNegative

Ziel Klassifizieren numerischer Werte gemäß Vorzeichen, wobei 0 mit positiven Werten gruppiert wird.

Parameter Keine

Ergebnis

Klassenindex | Werte
1 | ; das ist, negative Werte
2 | ; das ist, natürliche Werte
3 | null [siehe Der Nullwert]
4 | unklassifiziert

Siehe auch

Sign
Übergeordnetes Thema: Klasseneinteilungen


PreDuringPost

Ziel Klassifizieren von Datumswerten in Vor-, Während- und Nach-Kampagnen-Zeiträume.

Parameter

Typ | Name | Beschreibung
datum | a ("pre_date") | Der Start des Vor-Kampagne-Zeitraums
datum | b ("campaign_start_date") | Der Start der Kampagne
datum | c ("campaign_end_date") | Das Ende der Kampagne
datum | d ("post_date") | Das Ende des Nach-Kampagne-Zeitraums
Ergebnis
Klassenindex | Werte
1 | Daten vor a; die untere Randklasse [siehe Randklassen]
2 | Daten zwischen a (einschließlich) und b (ausschließlich)
3 | Daten zwischen b (einschließlich) und c (ausschließlich)
4 | Daten zwischen c (einschließlich) und d (ausschließlich)
5 | Daten d und später; die obere Randklasse [siehe Randklassen]
6 | null [siehe Der Nullwert]
7 | unklassifiziert

Siehe auch

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

PrePost

Übergeordnetes Thema: Klasseneinteilungen


PrePost

Ziel Klassifizieren von Datumswerten in Vor- und Nach-Kampagnen-Zeiträume.

Parameter

Typ | Name | Beschreibung
datum | a ("pre_date") | Der Start des Vor-Kampagne-Zeitraums
datum | b ("campaign_date") | Das Kampagnendatum
datum | c ("post_date") | Das Ende des Nach-Kampagne-Zeitraums

Ergebnis

Klassenindex | Werte
1 | Daten vor a; die untere Randklasse [siehe Randklassen]
2 | Daten zwischen a (einschließlich) und b (ausschließlich)
3 | Daten zwischen b (einschließlich) und c (ausschließlich)
4 | Daten c und später; die obere Randklasse [siehe Randklassen]
5 | null [siehe Der Nullwert]
6 | unklassifiziert

Siehe auch

DayMultiplePrePost, WeekMultiplePrePost, MonthMultiplePrePost, YearMultiplePrePost

DayPrePost, WeekPrePost, MonthPrePost, YearPrePost

PreDuringPost

Übergeordnetes Thema: Klasseneinteilungen


Sign

Ziel Klassifizieren numerischer Werte gemäß Vorzeichen.

Parameter Keine

Ergebnis

Klassenindex | Werte
1 | ; das ist, negative Werte
2 | 0
3 | ; das ist, positive Werte
4 | null [siehe Der Nullwert]
5 | unklassifiziert

Siehe auch

NegativeNonNegative
Übergeordnetes Thema: Klasseneinteilungen


Normale FDL-Ausdrücke

  • Regular Expression
  • Basiskomponenten eines regulären Ausdrucks
  • Regulärer Ausdruck Operatoren
Übergeordnetes Thema: Field Derivation Language (FDL) Referenz


Regular Expression

Reguläre Ausdrücke sind für übereinstimmende Muster in Strings [siehe Datentypen]. Ein „regulärer Ausdruck“ ist ein speziell formatierter String, der ein „Muster“ aus Zeichen repräsentiert. So stellt zum Beispiel der reguläre Ausdruck „ar{1,2}y\?$“ den Buchstaben 'a,' gefolgt von einem oder zwei 'r', möglicherweise gefolgt von 'y,' gefolgt vom Ende der Zeichenfolge dar. (Das Muster tritt auf in Strings, wie z. B. „marry“ und „jar“ - aber nicht in „may“ oder „jars.“)

Ein regulärer Ausdruck besteht aus drei kombinierten Grundkomponenten [siehe Basiskomponenten eines regulären Ausdrucks] mit Operatoren [siehe Regulärer Ausdruck Operatoren].

Wenn ein regulärer Ausdruck (anders als ein Teilausdruck) mehr als einem Teil eines Strings entspricht, wird immer der höchstwertige, längste in Frage kommende Teil des Strings abgeglichen. Der reguläre Ausdruck „a[^ad]\+“ (der den Buchstaben 'a', gefolgt von einem oder mehreren Buchstaben, die kein 'a' oder 'd' sind) entspricht, beispielsweise „adaptationally“. Der übereinstimmende Teil ist nicht „ation,“, da weiter links Kandidatenteile vorhanden sind. Auch „ap,“ ist es nicht, da auch, wenn weiter links keine Kandidaten vorhanden sind, ein mit dem gleichen Zeichen beginnender, längerer Kandidatenteil vorhanden ist.
  • Um einen String auf die Übereinstimmung mit einem regulären Ausdruck zu überprüfen, verwenden Sie die Funktion „match“.
  • Um übereinstimmende Teile eines Strings durch einen anderen String zu ersetzen, verwenden Sie die Funktion „replacefirst oder replaceall“.
Anmerkung:
  • Reguläre Ausdrücke sind im Normalfall (aber nicht notwendigerweise) Literale, in diesem Fall müssen Sie in Anführungszeichen stehen, z. B. „ar{1,2}y\?$“.

  • Miner/FDL verwendet reguläre Ausdrücke aus der ICU-Bibliothek. Wir können einen Link mit http://userguide.icu-project.org/strings/regexp herstellen.

  • Reguläre ICU-Ausdrücke entsprechen dem technischen Unicode-Standard #18 bzw. den regulären Unicode-Ausdrücken der Stufe 1 und beinhalten standardmäßige Wortgrenzen und Nameneigenschaften der Stufe 2.

Übergeordnetes Thema: Normale FDL-Ausdrücke


Basiskomponenten eines regulären Ausdrucks

Die Grundkomponenten eines regulären Ausdrucks [siehe Regular Expression] sind Atome, Anker und Rückverweise.

Atome

Ein Atom entspricht exakt einem angegebenen Zeichensatz:
Atom | Zeichen übereinstimmend
. (Übereinstimmung-beliebig) | Beliebiges Zeichen
[...] (Übereinstimmungsliste) | Jedes der spezifizierten Zeichen
[^...] (Nichtübereinstimmungsliste) | Jedes Zeichen, außer einem der spezifizierten Zeichen
Ein anderes Zeichen als ., ^, $, \, [, ] oder * außerhalb einer Übereinstimmungsliste oder Nichtübereinstimmungsliste | Das Zeichen selbst
als ., ^, $, \, [, ] oder * außerhalb einer Übereinstimmungsliste oder Nichtübereinstimmungsliste | Das Zeichen selbst

Eine Übereinstimmungsliste oder Nichtübereinstimmungsliste kann einfache Zeichen, Zeichenbereiche und Zeichenklassen enthalten. Zeichenbereiche oder Zeichenklassen können nur in einer „Übereinstimmungsliste“ oder „Nicht-Übereinstimmungsliste“ verwendet werden.

Ein „Zeichenbereich“ besteht aus einem durch einen Bindestrich getrenntes Zeichenpaar und entspricht einer Liste aller Zeichen in diesem Bereich (innerhalb des Zeichensatzes). Zum Beispiel: „a-e“ entspricht „abcde“ in einer Übereinstimmungsliste.

Eine „Zeichenklasse“ ist eines der folgenden vordefinierten Tokens (die umschließenden Klammern sind zusätzlich zu den die Übereinstimmungsliste oder Nicht-Übereinstimmungsliste umschließenden, gesetzt):

Token | Treffer
[:alnum:] | Ein alphanumerisches Zeichen, das ein Buchstaben oder eine Ziffer ist.
[:alpha:] | Ein Buchstabe, das heißt, „A“ — „Z“ und „a“ — „z“
[:blank:] | Ein Tabulator- oder Leerzeichen
[:cntrl:] | Ein Steuerzeichen
[:digit:] | Eine Ziffer, das heißt, „0“ — „9“
[:graph:] | Ein druckbares Zeichen, das kein Leerzeichen ist
[:lower:] | Ein Kleinbuchstabe
[:print:] | Ein druckbares Zeichen oder Leerzeichen
[:punct:] | Ein Satzzeichen
[:space:] | Ein nicht druckbares Leerzeichen
[:upper:] | Ein Großbuchstabe
[:xdigit:] | Eine Hexadezimalzahl, wie z. B. „0“ — „9,“ „A“ — „F,“ und „a“ — „f“
Anmerkung:
  • Sie können eine Mischung aus einfachen Zeichen, Zeichenbereichen und Zeichenklassen in einer einzelnen „Übereinstimmungsliste“ oder „Nichtübereinstimmungsliste“ verwenden. Beispiel: Die Übereinstimmungsliste „[a-ex[:digit:]]“ entspricht den kleingeschriebenen Buchstaben „a“ — „e“ und „x,“ sowie den Dezimalzahlen („0“ — „9“).
  • Ein Bindestrich in einer Übereinstimmungsliste oder Nichtübereinstimmungsliste steht für sich allein, wenn er sich (a) am Ende des Bereichs (b) oder am Anfang der Übereinstimmungsliste oder Nichtübereinstimmungsliste (wobei er in diesem Fall auch als Bereichsbeginn dienen kann) oder (c) am Ende der Übereinstimmungsliste oder Nichtübereinstimmungsliste steht.

Anker

Die Zeichen ^ und $ sind „Anker“; sie entsprechen jeweils dem Anfang und Ende eines Strings.

Beispiel: Zur Übereinstimmung von „The“ zu Beginn eines Strings und nirgendwo sonst könnten Sie den regulären Ausdruck „^The“ verwenden.

Übergeordnetes Thema: Normale FDL-Ausdrücke

Rückverweise

Ein „ Ein „Rückverweis“ ist ein Rückwärtsschrägstrich, gefolgt von einer Einzelzahl n (außer 0). Er entspricht exakt den gleichen Zeichen, wie der Unterausdruck n., eingeschlossen in \(...\).

Beispiel: Zur Übereinstimmung mit „yoyo,“ „dodo,“ usw. — aber nicht „dojo“ — könnten Sie den regulären Ausdruck „\(.o\)\1 verwenden.“

Anmerkung:
  • Der rückverwiesene Unterausdruck nth ist immer der Unterausdruck, beginnend mit dem nth öffnenden Rückwärtsschrägstrich/Klammern (auch bei ineinander verschachtelten Unterausdrücken).
  • Der leere Unterausdruck „\(\)“ kann in regulären Ausdrücken mit Wechselfolge nützlich sein [siehe Der Alternationsoperator]. Zum Beispiel:

    \(fish\(\)\|profit\(\)\)-und-\(chips\2\|loss\3\)

    entspricht beiden „fish-and-chips“ und „profit-and-loss,“ aber nicht „fish-and-loss“ oder „profit-and-chips.“


Regulärer Ausdruck Operatoren

Ein „Operator“ wirkt auf einen oder zwei reguläre Ausdrücke [siehe Regular Expression], um einen neuen regulären Ausdruck zu erstellen. Die Operatoren, von der höchsten bis zur niedrigsten Priorität, sind die Wiederholungsoperatoren [siehe Wiederholungsoperatoren], der Konkatenationoperator [siehe Der Konkatenationoperator] und der Alternationsoperator [siehe Der Alternationsoperator].

Liegt bezüglich der Priorität ein Unentschieden vor, werden die Operationen von links nach rechts ausgeführt.

In \(...\) eingeschlossene Unterausdrücke werden zuerst überprüft.

Übergeordnetes Thema: Normale FDL-Ausdrücke

Wiederholungsoperatoren

Die Wiederholungsoperatoren sind unär und sind so geschrieben, dass sie ihrem Einzeloperand folgen.

Operator | Beschreibung
* (Null oder mehr) | Stimmt ein regulärer Ausdruck mit einem oder mehreren benachbarten Teilen eines Strings überein, entspricht der reguläre Ausdruck a* der Konkatenation dieser Teile. Er stimmt auch mit einer leeren Substring überein.
\+ (eine oder mehr) | Stimmt ein regulärer Ausdruck mit einem oder mehreren benachbarten Teilen eines Strings überein, entspricht der reguläre Ausdruck a\+ der Konkatenation dieser Teile.
\{m,n\} (0 [image] m [image] n) | Stimmt ein regulärer Ausdruck mit mindestens m und nicht mehr als n benachbarten Teilen eines Strings überein, entspricht der reguläre Ausdruck a\{m,n\} der Konkatenation dieser Teile. If m=0, er stimmt auch mit jedem leeren Substring überein.
\? (optional) | Entsprechend zu a\{0,1\} stimmt der reguläre Ausdruck a\? mit jedem leeren Substring oder einem Teil eines Strings überein, der dem regulären Ausdruck a entspricht.
Anmerkung:

Die in den Definitionen für *, \+, and {...} genannten „benachbarten Teile“ sind nicht notwendigerweise identische Zeichenfolgen. Falls Sie exakt übereinstimmende Wiederholungen benötigen, verwenden Sie Rückverweise [siehe Rückverweise].

Der Konkatenationoperator

Der Konkatenationoperator wird nicht wirklich geschrieben, aber wird impliziert, wann immer Sie zwei reguläre Ausdrücke nebeneinander schreiben.

Falls reguläre Ausdrücke a und b mit den benachbarten Teilen x und y eines Strings z übereinstimmen (mit x vorangehendem y), entspricht die Konkatenation von a und b (geschrieben als a gefolgt von b) dem Teil von z mit dem Inhalt x und y.

Anmerkung:

Jede Zeichenfolge, die nicht aus Sonderzeichen besteht, das heißt, Zeichen ohne spezielle Bedeutung in einem regulären Ausdruck, dient als regulärer Ausdruck, der diese Zeichenfolge aufgrund des implizierten Konkatenationsoperators matcht.

In der Praxis bestehen die meisten regulären Ausdrücke aus einfachen Zeichenstrings, durchsetzt mit nur wenigen Sonderzeichen. Beispiel: der reguläre Ausdruck „[SsDd]imple“ entspricht den Strings „Simple,“ „simple,“ „Dimple,“ und „dimple.“

Der Alternationsoperator

Der Alternationsoperator „\|“ ist ein Binäroperator, geschrieben zwischen seinen Operanden.

Stimmen die regulären Ausdrücke a und b mit einem Teil des Strings überein, entspricht auch die Alternation a\|b diesem Teil.


XML in Portrait Miner

  • XML in Portrait Miner


XML in Portrait Miner

Um den einfachen Austausch von Ergebnissen mit anderen Anwendungen zu ermöglichen, verwendet Portrait Miner XML entsprechend der Portrait Miner XML-Schemadefinition, siehe http://www.portraitsoftware.com

Alle XML-Eingaben für die Portrait Miner-Dateierstellungsbefehle (und alle Portrait Miner-Funktionen, die über Portrait Miner-Dateierstellungsbefehle implementiert werden) müssen im Portrait Miner-Namensraum vorhanden sein, siehe http://support.portraitsoftware.com. Der einfachste Weg dieses sicherzustellen ist das Attribut xmlns=" http://support.portraitsoftware.com " im Hauptelement des XML-Dokuments einzuschließen.

Mit Portrait Miner automatisch erstellte XML-Dateien enthalten ein optionales schemaLocation-Attribut, welches auf Schemen unter http://www.portraitsoftware.com/xml/qs7.1 verweist. Wenn Sie einen Schema-aware-Editor für die Erstellung von XML-Dateien benutzen, können Sie auf diese Schemata direkt von ihrer Portrait Miner-Installation zugreifen unter:

<pmhome>/server/qs7.1/integration/schemas

(Wobei <pmhome> das Portrait Miner-Installationsverzeichnis ist). Sie können weitere Beispiele über die Verarbeitung dieser XML-Dateien finden unter:

<pmhome>/server/qs7.1/etc/xslt

Übergeordnetes Thema: XML in Portrait Miner


Fehlerbehebung

  • „Warum kann ich einen Fokus nicht öffnen?“
  • „Warum sind die Achsen in meinem Diagramm ungleich unterteilt?“
  • „Warum ist 'Markierte Segmente beibehalten' immer ausgegraut?“
  • „Warum sieht mein Text anders aus, als ich ihn eingegeben habe?“


„Warum kann ich einen Fokus nicht öffnen?“

Möglicher Grund | Lösung
Sie haben bereits einen Fokus geöffnet. Decision Studio kann nur mit einem Fokus gleichzeitig arbeiten. | Bevor Sie einen Fokus öffnen oder einen neuen Fokus aus einer Datei oder Datenbanktabelle erstellen können, müssen Sie den derzeit geöffneten Fokus schließen: Wählen Sie „Datei>Schließen“ im Decision Studio-Fenster.
Übergeordnetes Thema: Fehlerbehebung


„Warum sind die Achsen in meinem Diagramm ungleich unterteilt?“

Möglicher Grund | Lösung
Jede Achse in einem Kreuzverteilungs- oder Profil-Diagramm ist gemäß der primären Klasseneinteilung bei dem Feld, das der Achse entspricht, unterteilt. Ob die Klassen mit gleicher Breite angezeigt werden, ist eine Eigenschaft dieser Klasseneinteilung. (Die Ausnahme ist, wenn die Ausdehnung eines Blocks in eine bestimmte Richtung Informationen übermittelt: In diesem Fall, hat die Anzeigeeinstellung des Klasseneditors keinen Einfluss, sodass Missverständnisse vermieden werden.) | Wählen Sie im Klasseneditor das erforderliche Feld aus und deaktivieren Sie „Ansicht>Histogramm“.
Übergeordnetes Thema: Fehlerbehebung


„Warum ist 'Markierte Segmente beibehalten' immer ausgegraut?“

Möglicher Grund | Lösung
Sie versuchen, markierte Segmente im Tabellenansicht, Kreuztabellenansicht oder Scorecard-Assistent beizubehalten. Wenn ein Tool verknüpft ist [siehe Tool-Zuordnungen] um einem dieser Tools zu folgen, teilen sich die beiden Tools dieselbe Datenquelle, unabhängig davon, ob etwas im führenden Tool markiert ist. | Versuchen Sie statt dessen, dieselben Segmente in einem grafischen Visualisierungstool zu markieren.
Übergeordnetes Thema: Fehlerbehebung


„Warum sieht mein Text anders aus, als ich ihn eingegeben habe?“

Möglicher Grund | Lösung
Es gibt Zeichen in Ihrem Text, die nicht in den Zeichensatz ISO-8859-1 (Latein-1) umgewandelt werden können. | Vermeiden Sie Text mit Zeichen, die nicht in den Zeichensatz ISO-8859-1 umgewandelt werden können.
Übergeordnetes Thema: Fehlerbehebung


Urheberrechtshinweis

  • Urheberrechtshinweis


Urheberrechtshinweis

Portrait Miner kann folgende Software enthalten:

ANTLR

http://www.antlr.org

Apache Batik

Dieses Produkt enthält Software, die von der Apache Software Foundation (http://www.apache.org/) entwickelt wurde.

Copyright © 2000 The Apache Software Foundation. Alle Rechte vorbehalten.

Die Weiterverbreitung und Nutzung in Quell- und Binärform, ob verändert oder unverändert, ist unter folgenden Bedingungen zulässig:
  1. Bei einer Weiterverbreitung des Quellcodes müssen der oben genannte Urheberrechtsvermerk (Copyright), diese Liste mit Bedingungen und der folgende Gewährleistungsausschluss enthalten bleiben.
  2. Bei einer Weiterverbreitung in Binärform müssen der oben genannte Urheberrechtsvermerk (Copyright), diese Liste mit Bedingungen und der folgende Gewährleistungsausschluss in der Dokumentation und/oder anderem mitverbreiteten Material wiedergegeben werden.
  3. Die gegebenenfalls in der Weiterverbreitung enthaltene Endbenutzerdokumentation muss folgenden Hinweis enthalten: „Dieses Produkt enthält Software, die von Apache Software Foundation (http://www.apache.org/) entwickelt wurde.“ Alternativ kann dieser Hinweis in der Software selbst stehen, wenn und wo derartige Fremdanbieter-Hinweise normalerweise erscheinen.
  4. Die Bezeichnungen „Batik“ und „Apache Software Foundation“ dürfen ohne vorherige schriftliche Genehmigung nicht verwendet werden, um aus dieser Software abgeleitete Produkte zu bewerben oder zu vermarkten. Die schriftliche Genehmigung ist einzuholen unter apache@apache.org.
  5. Aus dieser Software abgeleitete Produkte dürfen ohne die vorherige schriftliche Genehmigung von Apache Software Foundation weder als „Apache“ bezeichnet werden, noch darf „Apache“ in ihrem Namen vorkommen.

DIESE SOFTWARE WIRD „WIE BESEHEN“ BEREITGESTELLT UND ALLE AUSDRÜCKLICHEN ODER STILLSCHWEIGENDEN GEWÄHRLEISTUNGEN, EINSCHLIESSLICH, JEDOCH NICHT BESCHRÄNKT AUF STILLSCHWEIGENDE GEWÄHRLEISTUNGEN DER MARKTFÄHIGKEIT UND DER EIGNUNG FÜR EINEN BESTIMMTEN ZWECK, SIND AUSGESCHLOSSEN. IN KEINEM FALL HAFTET DIE APACHE SOFTWARE FOUNDATION ODER MITWIRKENDE FÜR UNMITTELBARE, MITTELBARE, BEILÄUFIG ENTSTANDENE, BESONDERE, EXEMPLARISCHE ODER FOLGESCHÄDEN (EINSCHLIESSLICH, ABER NICHT NUR, BESCHAFFUNG VON ERSATZWAREN ODER -DIENSTLEISTUNGEN, NUTZUNGSAUSFALL, DATEN- ODER GEWINNVERLUST ODER GESCHÄFTSUNTERBRECHUNG), DIE IN IRGENDEINER FORM AUS DER NUTZUNG DIESER SOFTWARE ENTSTEHEN, SELBST WENN AUF DIE MÖGLICHKEIT SOLCHER SCHÄDEN HINGEWIESEN WURDE. DABEI IST IRRELEVANT, WIE UND AUF WELCHER HAFTUNGSGRUNDLAGE SIE ENTSTANDEN SIND UND OB DURCH VERTRAGS-, KAUSAL- ODER VERSCHULDENSHAFTUNG (EINSCHLIESSLICH FAHRLÄSSIGKEIT UND ANDERE).

Diese Software besteht aus freiwilligen Beiträgen, die zahlreiche Einzelpersonen im Namen der Apache Software Foundation geleistet haben. Weitere Informationen zur Apache Software Foundation finden Sie unter http://www.apache.org.

Apriori-Algorithmus-Implementierung

Christian Borgelt, http://www.borgelt.net/apriori.html.

Freie Software, weiterverbreitet gemäß den Bedingungen der GNU Lesser General Public License.

DOM4J

Das DOM4J-Project, http://www.dom4j.org.
Die Weiterverbreitung und Nutzung dieser Software und zugehöriger Dokumentation („Software“), ob verändert oder unverändert, ist unter folgenden Bedingungen zulässig:
  1. Weiterverbreitungen des Quellcodes müssen Copyright-Angaben und -Hinweise enthalten. Weiterverbreitungen müssen auch eine Kopie dieses Dokuments enthalten.
  2. Bei einer Weiterverbreitung in Binärform müssen der oben genannte Urheberrechtsvermerk (Copyright), diese Liste mit Bedingungen und der folgende Gewährleistungsausschluss in der Dokumentation und/oder anderem mitverbreiteten Material wiedergegeben werden.
  3. Ohne vorherige schriftliche Genehmigung von MetaStuff, Ltd. darf die Bezeichnung „DOM4J“ nicht verwendet werden, um aus dieser Software abgeleitete Produkte zu bewerben oder zu vermarkten. Für eine schriftliche Genehmigung kontaktieren Sie bitte dom4j-info@metastuff.com.
  4. Aus dieser Software abgeleitete Produkte dürfen ohne die vorherige schriftliche Genehmigung von MetaStuff, Ltd. weder als „DOM4J“ bezeichnet werden, noch darf „DOM4J“ in ihrem Namen vorkommen. DOM4J ist eine eingetragene Marke der MetaStuff, Ltd.
  5. Dem DOM4J-Projekt gebührt besondere Anerkennung – http://www.dom4j.org

DIESE SOFTWARE WIRD VON METASTUFF, LTD. UND MITWIRKENDEN „WIE BESEHEN” BEREITGESTELLT UND ALLE AUSDRÜCKLICHEN ODER STILLSCHWEIGENDEN GEWÄHRLEISTUNGEN, EINSCHLIESSLICH, ABER NICHT NUR, DER STILLSCHWEIGENDEN GEWÄHRLEISTUNGEN DER MARKTFÄHIGKEIT UND EIGNUNG FÜR EINEN BESTIMMTEN ZWECK, SIND AUSGESCHLOSSEN. IN KEINEM FALL HAFTEN METASTUFF, LTD. ODER MITWIRKENDE FÜR UNMITTELBARE, MITTELBARE, BEILÄUFIG ENTSTANDENE, BESONDERE, EXEMPLARISCHE ODER FOLGESCHÄDEN (EINSCHLIESSLICH, ABER NICHT NUR, BESCHAFFUNG VON ERSATZWAREN ODER -DIENSTLEISTUNGEN, NUTZUNGSAUSFALL, DATEN- ODER GEWINNVERLUST ODER GESCHÄFTSUNTERBRECHUNG), DIE IN IRGENDEINER FORM AUS DER NUTZUNG DIESER SOFTWARE ENTSTEHEN, SELBST WENN AUF DIE MÖGLICHKEIT SOLCHER SCHÄDEN HINGEWIESEN WURDE. DABEI IST IRRELEVANT, WIE UND AUF WELCHER HAFTUNGSGRUNDLAGE SIE ENTSTANDEN SIND UND OB DURCH VERTRAGS-, KAUSAL- ODER VERSCHULDENSHAFTUNG (EINSCHLIESSLICH FAHRLÄSSIGKEIT UND ANDERE).

Copyright 2001 - 2004 © MetaStuff, Ltd. Alle Rechte vorbehalten.

fmt

und http://www.cs.princeton.edu/software/cii/} Stringformatierungs-Library aus dem Buch C Interfaces and Implementations, Techniques for Creating Reusable Software von David R. Hanson.

Verfasser dieser Software ist David R. Hanson.

Copyright © 1994, 1995, 1996, 1997 by David R. Hanson. Alle Rechte vorbehalten.

Hierdurch wird die Genehmigung zur Verwendung, Vervielfältigung, Änderung und Weiterverbreitung dieser Software zu allen Zwecken ohne Vergütung gewährt, vorbehaltlich der unten angegebenen Bedingungen, sofern dieser Vermerk vollständig in allen Kopien einer Software enthalten ist, die entweder eine Kopie oder eine Bearbeitung dieser Software ist oder diese enthält, sowie in allen Kopien der diese Software unterstützenden Dokumentation.

DIESE SOFTWARE WIRD „WIE BESEHEN“ ZUR VERFÜGUNG GESTELLT, OHNE AUSDRÜCKLICHE ODER STILLSCHWEIGENDE GEWÄHRLEISTUNG. INSBESONDERE GIBT DER VERFASSER KEINE ZUSICHERUNG ODER GEWÄHRLEISTUNG ZUR MARKTFÄHIGKEIT DIESER SOFTWARE ODER ZU IHRER EIGNUNG FÜR EINEN BESTIMMTEN ZWECK.

David Hanson, drh@microsoft.com, http://www.research.microsoft.com/~drh/.

FreeTDS

http://www.freetds.org/.

Freie Software, weiterverbreitet gemäß Unterabsatz 6b der GNU Library General Public License.

getopt

Dieses Produkt (Portrait Miner) kann Software enthalten, die von der University of California, Berkeley unter dem Vorbehalt des folgenden Genehmigungshinweises entwickelt wurde:
Copyright © 1987, 1993, 1994 The Regents of the University of California. Alle Rechte vorbehalten. Die Weiterverbreitung und Nutzung in Quell- und Binärform, ob verändert oder unverändert, ist unter folgenden Bedingungen zulässig:
  1. Bei einer Weiterverbreitung des Quellcodes müssen der oben genannte Urheberrechtsvermerk (Copyright), diese Liste mit Bedingungen und der folgende Gewährleistungsausschluss enthalten bleiben.
  2. Bei einer Weiterverbreitung in Binärform müssen der oben genannte Urheberrechtsvermerk (Copyright), diese Liste mit Bedingungen und der folgende Gewährleistungsausschluss in der Dokumentation und/oder anderem mitverbreiteten Material wiedergegeben werden.
  3. Sämtliches Werbematerial, in dem Funktionen oder die Nutzung dieser Software erwähnt werden, muss folgenden Hinweis enthalten: Dieses Produkt enthält Software, die von der University of California, Berkeley und ihren Mitwirkenden entwickelt wurde.
  4. Ohne vorherige schriftliche Genehmigung dürfen weder der Name der Universität noch die Namen von Mitwirkenden verwendet werden, um aus dieser Software abgeleitete Produkte zu bewerben oder zu vermarkten.

DIESE SOFTWARE WIRD VON THE REGENTS UND MITWIRKENDEN „WIE BESEHEN“ BEREITGESTELLT; ALLE AUSDRÜCKLICHEN ODER STILLSCHWEIGENDEN GEWÄHRLEISTUNGEN, EINSCHLIESSLICH, JEDOCH NICHT BESCHRÄNKT AUF STILLSCHWEIGENDE GEWÄHRLEISTUNGEN DER MARKTFÄHIGKEIT UND DER EIGNUNG FÜR EINEN BESTIMMTEN ZWECK, SIND AUSGESCHLOSSEN. IN KEINEM FALL HAFTEN THE REGENTS ODER MITWIRKENDE FÜR UNMITTELBARE, MITTELBARE, BEILÄUFIG ENTSTANDENE, BESONDERE ODER EXEMPLARISCHE SCHÄDEN ODER FOLGESCHÄDEN (EINSCHLIESSLICH, ABER NICHT NUR, BESCHAFFUNG VON ERSATZWAREN ODER -DIENSTLEISTUNGEN, NUTZUNGSAUSFALL, DATEN- ODER GEWINNVERLUST ODER GESCHÄFTSUNTERBRECHUNG), DIE IN IRGENDEINER FORM AUS DER NUTZUNG DIESER SOFTWARE ENTSTEHEN, SELBST WENN AUF DIE MÖGLICHKEIT SOLCHER SCHÄDEN HINGEWIESEN WURDE. DABEI IST IRRELEVANT, WIE UND AUF WELCHER HAFTUNGSGRUNDLAGE SIE ENTSTANDEN SIND UND OB DURCH VERTRAGS-, KAUSAL- ODER VERSCHULDENSHAFTUNG (EINSCHLIESSLICH FAHRLÄSSIGKEIT UND ANDERE).

MemoryClassLoader von OpenEJB.org

Die Weiterverbreitung und Nutzung dieser Software und zugehöriger Dokumentation („Software“), ob verändert oder unverändert, ist unter folgenden Bedingungen zulässig:
  1. Weiterverbreitungen des Quellcodes müssen Copyright-Angaben und -Hinweise enthalten. Weiterverbreitungen müssen auch eine Kopie dieses Dokuments enthalten.
  2. Bei einer Weiterverbreitung in Binärform müssen der oben genannte Urheberrechtsvermerk (Copyright), diese Liste mit Bedingungen und der folgende Gewährleistungsausschluss in der Dokumentation und/oder anderem mitverbreiteten Material wiedergegeben werden.
  3. Ohne vorherige schriftliche Genehmigung darf die Bezeichnung „OpenEJB“ nicht verwendet werden, um aus dieser Software abgeleitete Produkte zu bewerben oder zu vermarkten. Die schriftliche Genehmigung ist einzuholen unter info@openejb.org.
  4. Aus dieser Software abgeleitete Produkte dürfen ohne die vorherige schriftliche Genehmigung von The OpenEJB Group weder als „OpenEJB“ bezeichnet werden, noch darf „OpenEJB“ in ihrem Namen vorkommen. OpenEJB ist eine eingetragene Marke von The OpenEJB Group.
  5. Dem OpenEJB-Projekt ist gebührende Anerkennung zu widmen http://www.openejb.org/).

THE OPENEJB GROUP UND DIE MITWIRKENDEN STELLEN DIE SOFTWARE „WIE BESEHEN“ BEREIT; ALLE AUSDRÜCKLICHEN ODER STILLSCHWEIGENDEN GEWÄHRLEISTUNGEN, EINSCHLIESSLICH, ABER NICHT NUR, DER STILLSCHWEIGENDEN GEWÄHRLEISTUNGEN DER MARKTFÄHIGKEIT UND EIGNUNG FÜR EINEN BESTIMMTEN ZWECK, SIND AUSGESCHLOSSEN. IN KEINEM FALL HAFTEN THE OPENEJB GROUP ODER AN DEM PROJEKT MITWIRKENDE FÜR UNMITTELBARE, MITTELBARE, BEILÄUFIG ENTSTANDENE, BESONDERE; EXEMPLARISCHE ODER FOLGESCHÄDEN (EINSCHLIESSLICH, ABER NICHT BESCHRÄNKT AUF BESCHAFFUNG VON ERSATZWAREN ODER -DIENSTLEISTUNGEN, NUTZUNGSAUSFALL, DATEN- ODER GEWINNVERLUST ODER GESCHÄFTSUNTERBRECHUNG), DIE IN IRGENDEINER FORM AUS DER NUTZUNG DIESER SOFTWARE ENTSTEHEN, SELBST WENN AUF DIE MÖGLICHKEIT SOLCHER SCHÄDEN HINGEWIESEN WURDE; DABEI IST IRRELEVANT, WIE UND AUF WELCHER HAFTUNGSGRUNDLAGE SIE ENTSTANDEN SIND UND OB DURCH VERTRAGS-, KAUSAL- ODER VERSCHULDENSHAFTUNG (EINSCHLIESSLICH FAHRLÄSSIGKEIT UND ANDERE).

Copyright 2001 - 2005 © The OpenEJB Group. Alle Rechte vorbehalten.

Numerical Recipes

Dieses Produkt enthält Prozeduren, die auf Routinen in Numerical Recipes beruhen: The Art of Scientific Computing, veröffentlicht von Cambridge University Press, und mit Genehmigung genutzt.

pthreads-win32

Eine POSIX Threads-Bibliothek für Windowslong. Copyright © 2001 Ross P. Johnson. Alle Rechte vorbehalten.

Freie Software, weiterverbreitet gemäß den Bedingungen der GNU Lesser General Public License.

RPC/XDR

Copyright © 1986, Sun Microsystems, Inc., vorbehaltlich des folgenden Genehmigungshinweises:

Sun RPC ist ein Produkt der Sun Microsystems, Inc. und wird zur uneingeschränkten Nutzung zur Verfügung gestellt, sofern dieser Hinweis auf allen Bandmedien und als Bestandteil des gesamten oder teilweisen Softwareprogramms erscheint. Benutzer können Sun RPC ohne Vergütung kopieren oder verändern. Sie sind aber nicht befugt, Sun RPC an andere Personen zu lizenzieren oder weiterzuverbreiten, es sei denn, als Bestandteil eines vom Benutzer entwickelten Produkts oder Programms.

SUN RPC WIRD „WIE BESEHEN“ BEREITGESTELLT, OHNE EINE GEWÄHRLEISTUNG JEGLICHER ART, EINSCHLIESSLICH DER GEWÄHRLEISTUNGEN FÜR DESIGN, MARKTFÄHIGKEIT ODER EIGNUNG FÜR EINEN BESTIMMTEN ZWECK ODER AUS DER ABWICKLUNG EINES RECHTSGESCHÄFTS, DER BENUTZUNG ODER AUS EINEM HANDELSBRAUCH.

Sun RPC wird ohne Unterstützung und ohne dass Sun Microsystems, Inc. verpflichtet würde, bei seiner Benutzung, Berichtigung, Änderung oder Verbesserung Unterstützung zu leisten, bereitgestellt.

SUN MICROSYSTEMS, INC. HAFTET NICHT FÜR DIE VERLETZUNG VON URHEBERRECHTEN, GESCHÄFTSGEHEIMNISSEN ODER PATENTEN DURCH SUN RPC ODER DESSEN TEILE.

In keinem Fall haftet Sun Microsystems, Inc. für entgangene Erlöse oder Gewinne oder andere besondere, mittelbare und Folgeschäden, auch für den Fall, dass Sun über die Möglichkeit solcher Schäden informiert wurde:

Sun Microsystems, Inc.

2550 Garcia Avenue

Mountain View, Kalifornien 94043

Rx

Copyright © 1996 Tom Lord, Berkeley, CA USA, außer Teilen von „POSIX Regex Functions“ mit Copyright © 1995 Free Software Foundation, Inc.

Hierdurch wird die Genehmigung zur Verwendung, Vervielfältigung, Änderung und Weiterverbreitung dieser Software zu allen Zwecken ohne Vergütung gewährt, unter dem Vorbehalt, dass obiger Urheberrechtsvermerk (Copyright) in allen Kopien enthalten ist und dass dieser Urheberrechtsvermerk (Copyright) und dieser Genehmigungsvermerk in der diese Software unterstützenden Dokumentation erscheint.

Freie Software, weiterverbreitet gemäß Unterabsatz 6b der GNU Library General Public License.

Stat/Transfer

Copyright © 2003 Circle Systems, Inc.

Trang

Multi-Format Schemakonvertierungsprogramm basierend auf \rng. Copyright © 2002, 2003 Thai Open Source Software Center Ltd. Alle Rechte vorbehalten.
Die Weiterverbreitung und Nutzung in Quell- und Binärform, ob verändert oder unverändert, ist unter folgenden Bedingungen zulässig:
  • Bei einer Weiterverbreitung des Quellcodes müssen der oben genannte Urheberrechtsvermerk (Copyright), diese Liste mit Bedingungen und der folgende Gewährleistungsausschluss enthalten bleiben.
  • Bei einer Weiterverbreitung in Binärform müssen der oben genannte Urheberrechtsvermerk (Copyright), diese Liste mit Bedingungen und der folgende Gewährleistungsausschluss in der Dokumentation und/oder anderem mitverbreiteten Material wiedergegeben werden.
  • Ohne vorherige schriftliche Genehmigung dürfen weder der Name der Thai Open Source Software Center Ltd noch die Namen von Mitwirkenden verwendet werden, um aus dieser Software abgeleitete Produkte zu bewerben oder zu vermarkten.

DER INHABER DER URHEBERRECHTE UND DIE MITWIRKENDEN STELLEN DIE SOFTWARE „WIE BESEHEN“ BEREIT; ALLE AUSDRÜCKLICHEN ODER STILLSCHWEIGENDEN GEWÄHRLEISTUNGEN, EINSCHLIESSLICH, ABER NICHT NUR, DER STILLSCHWEIGENDEN GEWÄHRLEISTUNGEN DER MARKTFÄHIGKEIT UND EIGNUNG FÜR EINEN BESTIMMTEN ZWECK, SIND AUSGESCHLOSSEN. IN KEINEM FALL HAFTEN THE REGENTS ODER MITWIRKENDE FÜR UNMITTELBARE, MITTELBARE, BEILÄUFIG ENTSTANDENE, BESONDERE ODER EXEMPLARISCHE SCHÄDEN ODER FOLGESCHÄDEN (EINSCHLIESSLICH, ABER NICHT NUR, BESCHAFFUNG VON ERSATZWAREN ODER -DIENSTLEISTUNGEN, NUTZUNGSAUSFALL, DATEN- ODER GEWINNVERLUST ODER GESCHÄFTSUNTERBRECHUNG), DIE IN IRGENDEINER FORM AUS DER NUTZUNG DIESER SOFTWARE ENTSTEHEN, SELBST WENN AUF DIE MÖGLICHKEIT SOLCHER SCHÄDEN HINGEWIESEN WURDE. DABEI IST IRRELEVANT, WIE UND AUF WELCHER HAFTUNGSGRUNDLAGE SIE ENTSTANDEN SIND UND OB DURCH VERTRAGS-, KAUSAL- ODER VERSCHULDENSHAFTUNG (EINSCHLIESSLICH FAHRLÄSSIGKEIT UND ANDERE).

unixODBC

Open Source ODBC-Teilsystem und ein ODBC SDK für Linux, Mac OSX und UNIX. unixODBC, http://www.unixodbc.org/.

Freie Software, weiterverbreitet gemäß Unterabsatz 6b der GNU Library General Public License.

Xerces Java Parser

Dieses Produkt enthält Software, die von der Apache Software Foundation (http://www.apache.org/) entwickelt wurde.

Copyright © 1999 — 2002 The Apache Software Foundation. Alle Rechte vorbehalten.

Die Weiterverbreitung und Nutzung in Quell- und Binärform, ob verändert oder unverändert, ist unter folgenden Bedingungen zulässig:
  1. Bei einer Weiterverbreitung des Quellcodes müssen der oben genannte Urheberrechtsvermerk (Copyright), diese Liste mit Bedingungen und der folgende Gewährleistungsausschluss enthalten bleiben.
  2. Bei einer Weiterverbreitung in Binärform müssen der oben genannte Urheberrechtsvermerk (Copyright), diese Liste mit Bedingungen und der folgende Gewährleistungsausschluss in der Dokumentation und/oder anderem mitverbreiteten Material wiedergegeben werden.
  3. Die gegebenenfalls in der Weiterverbreitung enthaltene Endbenutzerdokumentation muss folgenden Hinweis enthalten: „Dieses Produkt enthält Software, die von Apache Software Foundation (http://www.apache.org/) entwickelt wurde.“ Alternativ kann dieser Hinweis in der Software selbst stehen, wenn und wo derartige Fremdanbieter-Hinweise normalerweise erscheinen.
  4. Die Bezeichnungen „Xerces“ und „Apache Software Foundation“ dürfen ohne vorherige schriftliche Genehmigung nicht zur Bekräftigung oder Verkaufsförderung von aus dieser Software abgeleiteten Produkten verwendet werden. Die schriftliche Genehmigung ist einzuholen unter apache@apache.org.
  5. Aus dieser Software abgeleitete Produkte dürfen ohne die vorherige schriftliche Genehmigung von Apache Software Foundation weder als „Apache“ bezeichnet werden, noch darf „Apache“ in ihrem Namen vorkommen.

DIESE SOFTWARE WIRD „WIE BESEHEN“ BEREITGESTELLT UND ALLE AUSDRÜCKLICHEN ODER STILLSCHWEIGENDEN GEWÄHRLEISTUNGEN, EINSCHLIESSLICH, JEDOCH NICHT BESCHRÄNKT AUF STILLSCHWEIGENDE GEWÄHRLEISTUNGEN DER MARKTFÄHIGKEIT UND DER EIGNUNG FÜR EINEN BESTIMMTEN ZWECK, SIND AUSGESCHLOSSEN. IN KEINEM FALL HAFTET DIE APACHE SOFTWARE FOUNDATION ODER MITWIRKENDE FÜR UNMITTELBARE, MITTELBARE, BEILÄUFIG ENTSTANDENE, BESONDERE, EXEMPLARISCHE ODER FOLGESCHÄDEN (EINSCHLIESSLICH, ABER NICHT NUR, BESCHAFFUNG VON ERSATZWAREN ODER -DIENSTLEISTUNGEN, NUTZUNGSAUSFALL, DATEN- ODER GEWINNVERLUST ODER GESCHÄFTSUNTERBRECHUNG), DIE IN IRGENDEINER FORM AUS DER NUTZUNG DIESER SOFTWARE ENTSTEHEN, SELBST WENN AUF DIE MÖGLICHKEIT SOLCHER SCHÄDEN HINGEWIESEN WURDE. DABEI IST IRRELEVANT, WIE UND AUF WELCHER HAFTUNGSGRUNDLAGE SIE ENTSTANDEN SIND UND OB DURCH VERTRAGS-, KAUSAL- ODER VERSCHULDENSHAFTUNG (EINSCHLIESSLICH FAHRLÄSSIGKEIT UND ANDERE).

Diese Software besteht aus freiwilligen Beiträgen, die zahlreiche Einzelpersonen im Namen der Apache Software Foundation geleistet haben, und basierte ursprünglich auf Software-Urheberrecht © 1999, International Business Machines, Inc., http://www.ibm.com. Weitere Informationen zur Apache Software Foundation finden Sie unter http://www.apache.org.

Xerces Java Parser

Copyright © 1995 — 1998 Jean-loup Gailly und Mark Adler.
Übergeordnetes Thema: Urheberrechtshinweis

GNU LIBRARY GENERAL PUBLIC LICENSE

Version 2, Juni 1991

Copyright © 1991 Free Software Foundation, Inc.

59 Temple Place — Suite 330, Boston, MA 02111-1307, USA

Jedem ist es gestattet, wortgetreue Kopien dieser Lizenz zu kopieren und weiter zu verbreiten, Änderungen sind nicht gestattet.

Präambel

Die Lizenzen für die meiste Software dienen dazu, Ihnen die Freiheit zum Teilen und zum Ändern der Software zu nehmen. Im Gegensatz dazu garantieren Ihnen die GNU General Public Licenses die Freiheit, freie Software zu teilen und zu verändern, um sicherzustellen, dass die Software für alle Benutzer frei zugänglich ist.

Diese Lizenz, die Library General Public License, gilt für bestimmte, besonders bezeichnete Software der Free Software Foundation sowie für andere Bibliotheken, deren Verfasser sich entschließen, sie zu nutzen. Sie können sie auch auf Ihre Bibliotheken anwenden.

Die Bezeichnung „freier“ Software bezieht sich auf die freie Nutzung, nicht auf den Preis. Unsere General Public Licenses sollen Ihnen die Freiheit gewähren, Kopien der freien Software zu verbreiten (und für diese Dienstleistung eine Vergütung zu erheben, falls gewünscht), Quellcode zu erhalten oder ihn zu beschaffen, die Software zu ändern oder Teile daraus in neuen freien Programmen zu verwenden; außerdem sollen sie Sie darüber informieren, dass Sie diese Freiheit haben.

Um Ihre Rechte zu schützen, müssen wir Beschränkungen festlegen, damit niemand Ihnen diese Rechte vorenthalten oder Sie zum Verzicht auf diese Rechte auffordern kann. Aus diesen Beschränkungen ergeben sich Verantwortlichkeiten für Sie, falls Sie Kopien der Bibliothek verbreiten oder die Software ändern.

Wenn Sie beispielsweise Kopien der Bibliothek unentgeltlich oder gegen Entgelt verbreiten, müssen Sie den Empfängern sämtliche Rechte gewähren, die Sie haben. Sie müssen sicherstellen, dass auch der Empfänger den Quellcode erhält oder darauf zugreifen kann. Wenn Sie ein Programm mit der Bibliothek verknüpfen, müssen Sie den Empfängern vollständige Objektdateien bereitstellen, damit die Empfänger sie wiederum mit der Bibliothek verknüpfen können, nachdem Änderungen an der Bibliothek vorgenommen wurden und sie neu kompiliert wurde. Und Sie müssen ihnen diese Bedingungen mitteilen, damit sie ihre Rechte kennen.

Unsere Methode zum Schutz Ihrer Rechte besteht aus zwei Stufen: (1) Die Bibliothek urheberrechtlich schützen. (2) Ihnen diese Lizenz bieten, die Ihnen die rechtliche Genehmigung zum Kopieren, Weiterverbreiten und/oder Ändern der Bibliothek einräumt.

Außerdem möchten wir zum Schutz der einzelnen Benutzer sicherstellen, dass alle verstehen, dass es für diese freie Bibliothek keine Gewährleistung gibt. Wenn die Bibliothek durch jemanden geändert und weitergegeben wird, möchten wir, dass die Empfänger dieser Weitergabe wissen, dass sie nicht die Originalversion haben, damit sich eventuelle Probleme, die von anderen einprogrammiert wurden, nicht auf den guten Ruf des Originalverfassers auswirken.

Schließlich stellen Software-Patente eine ständige Bedrohung für freie Programme dar. Wir möchten die Gefahr vermeiden, dass Unternehmen, die freie Software weiterverbreiten, Einzelpatentlizenzen erwerben und somit im Endeffekt das Programm in eine proprietäre Software verwandeln. Dazu haben wir klargestellt, dass sämtliche Patente jedem ein freies Nutzungsrecht einräumen müssen oder gar nicht lizenziert werden dürfen.

Der meiste GNU-Software, einschließlich einiger Bibliotheken sind durch die normale GNU General Public License abgedeckt, die für Dienstprogramme entwickelt wurde. Diese Lizenz, die GNU Library General Public Licence, gilt für bestimmte bezeichnete Bibliotheken. Diese Lizenz unterscheidet sich erheblich von der normalen Lizenz. Achten Sie darauf, sie vollständig zu lesen und gehen Sie nicht davon aus, dass alles gleich der normalen Lizenz ist.

Der Grund dafür, dass wir eine separate öffentliche Lizenz für bestimmte Bibliotheken haben, ist, dass sie die Unterscheidung verwischen, die wir üblicherweise zwischen dem Ändern oder Hinzufügen zu einem Programm machen und deren reinen Nutzung. Das Verknüpfen eines Programms mit einer Bibliothek, ohne diese zu verändern, ist in gewisser Weise eine reine Nutzung der Bibliothek und entspricht dem Lauf eines Dienst- oder Anwendungsprogramms. Allerdings ist in einem wörtlichen und rechtlichen Sinne das verlinkte ausführbare Programm ein verbundenes Werk, eine Ableitung der Originalbibliothek, und die normale General Public Licence behandelt es als ein solches.

Wegen dieser verschwommenen Unterscheidung hat der Einsatz der normalen General Public Licence bei Bibliotheken das Teilen von Software nicht erfolgreich gefördert, weil die meisten Entwickler die Bibliotheken nicht nutzten. Daraus haben wir gefolgert, dass weniger strenge Bedingungen das Teilen besser fördern könnten.

Allerdings würde ein uneingeschränktes Verknüpfen von nicht freien Programmen die Nutzer dieser Programme um alle Vorteile des freien Status der Bibliotheken an sich bringen. Diese Library General Public Licence soll es Entwicklern nicht freier Programme ermöglichen, freie Bibliotheken zu verwenden und trotzdem Ihnen als Nutzer dieser Programme die Freiheit erhalten, die darin enthaltenen freien Bibliotheken zu ändern. (Wir sehen noch nicht, wie wir dies hinsichtlich Änderungen in Header-Dateien erreichen, aber wir haben dies hinsichtlich Änderungen in den eigentlichen Funktionen der Bibliothek erreicht). Wir hoffen, dass dies zu einer schnelleren Entwicklung freier Bibliotheken führt.

Die genauen Bedingungen für Kopieren, Weitergabe und Modifikation folgen. Beachten Sie unbedingt den Unterschied zwischen einem „Werk, das auf der Bibliothek basiert“ und einem „Werk, das die Bibliothek verwendet“. Das erste enthält Code, der aus einer Bibliothek abgeleitet wurde, das letztere arbeitet nur mit der Bibliothek zusammen.

Beachten Sie, dass es möglich ist, dass eine Lizenz von der General Public License (GPL) anstatt ihrer eigenen abgedeckt wird.

BEDINGUNGEN FÜR KOPIEREN, VERBREITUNG UND MODIFIKATION

  • 0. Diese Lizenzvereinbarung gilt für alle Softwarebibliotheken, die einen vom Inhaber des Urheberrechts oder einer autorisierten Partei eingefügten Hinweis beinhaltet, der besagt, dass sie entsprechend der Bedingungen ihrer General Public License für Bibliotheken (nachstehend „diese Lizenz“) verbreitet werden darf. Jeder Lizenznehmer wird mit „Sie“ bezeichnet.

    Unter einer „Bibliothek“ wird eine Sammlung von Softwarefunktionen und/oder Daten verstanden, die so vorbereitet sind, dass sie in geeigneter Weise mit anderen Anwendungsprogrammen (die einige dieser Funktionen und Daten nutzen) verknüpft werden können, um ausführbare Programme zu erhalten.

    Der nachstehende Begriff „Bibliothek“ bezieht sich auf eine solche Softwarebibliothek oder Arbeiten, die unter diesen Bedingungen verbreitet worden sind. Ein „Werk, das auf einer Bibliothek basiert“ bezeichnet entweder eine Bibliothek oder jedes abgeleitete Werk, das unter das Urheberrecht fällt: Das heißt, ein Werk, das die Bibliothek oder einen Teil der Bibliothek, entweder wortgetreu oder modifiziert und/oder direkt in eine andere Sprache übersetzt, enthält. (Nachstehend fällt Übersetzung ohne Einschränkung unter den Begriff „Modifikation“.)

    Der „Quellcode“ für ein Werk bezeichnet die bevorzugte Form eines Werks, um es zu modifizieren. Im Fall einer Bibliothek bedeutet „vollständiger Quellcode“ der gesamte Quellcode für alle darin enthaltenen Module, sowie alle zugehörigen Schnittstellendefinitionsdateien und die zur Kontrolle der Kompilierung und Installation der Bibliothek verwendeten Skripte.

    Diese Lizenz deckt nur das Kopieren, die Verbreitung und Modifikation ab, alle anderen Aktivitäten sind nicht darin enthalten. Der Vorgang der Ausführung eines Programms unter Verwendung der Bibliothek wird nicht eingeschränkt und die Ergebnisse eines solchen Programms sind nur dann abgedeckt, wenn seine Inhalte ein Werk, das auf der Bibliothek basiert, bilden (unabhängig davon, ob die Bibliothek in einem Werkzeug zum Schreiben des Programms verwendet wurde). Ob dies zutrifft, hängt davon ab, was die Bibliothek bewirkt und was das Programm, das die Bibliothek verwendet, bewirkt.

  • 1. Sie können wortgetreue Kopien des vollständigen Quellcodes der Bibliothek, so, wie Sie ihn erhalten, mittels jeden Mediums, kopieren und verbreiten, vorausgesetzt, dass Sie auf jeder Kopie einen deutlichen und geeigneten Urheberrechtsvermerk und Haftungsausschluss anbringen, alle Vermerke, die sich auf diese Lizenz und den Haftungsausschluss beziehen, nicht beschädigen und eine Kopie dieser Lizenzvereinbarung zusammen mit der Bibliothek verbreiten.

    Sie können eine Gebühr für den physischen Akt der Verbreitung einer Kopie erheben und Sie können, so Sie dies wünschen, eine Garantie als Gegenleistung für die Gebühr aussprechen.

  • 2. Sie können Ihre Kopie oder Kopien der Bibliothek oder eines jeden Teils der Bibliothek modifizieren. Auf diese Weise entsteht eine Arbeit, die auf der Bibliothek basiert, und diese Modifikationen oder Arbeiten gemäß den in Abschnitt 1 oben genannten Bedingungen unter der Voraussetzung, dass Sie alle folgenden Bedingungen einhalten, verbreiten:
    • a) Das modifizierte Werk muss selbst eine Softwarebibliothek sein.
    • b) Sie müssen veranlassen, dass die modifizierten Dateien mit deutlich sichtbaren Vermerken, die darauf hinweisen, dass Sie die Dateien geändert haben sowie das Datum der Änderungen, versehen sind.
    • c) Sie müssen veranlassen, dass die gesamte Arbeit für alle Dritten gemäß den Bedingungen dieser Lizenz kostenfrei lizenziert wird.
    • d) Wenn eine Routine in der modifizierten Bibliothek sich auf eine Funktion oder eine Tabelle bezieht, die von einer Anwendung, die diese Routine bereitstellt, genutzt wird, außer, es wird ein Argument übergeben, wenn diese Routine aufgerufen wird, in diesem Fall müssen Sie sich in gutem Glauben darum bemühen, sicherzustellen, dass, falls eine Anwendung eine solche Funktion oder Tabelle nicht bereitstellt, diese Routine weiterhin arbeitet und denjenigen Teil ihres Zweckes, der sinnvoll bleibt, weiterhin ausführt. (Zum Beispiel: Eine Funktion in einer Bibliothek zur Berechnung von Quadratwurzeln hat einen Zweck, der wohldefiniert unabhängig von der Anwendung ist. Daher verlangt Unterabschnitt 2d, dass alle von Anwendungen bereitgestellte Funktionen oder Tabellen, die von dieser Funktion genutzt werden, optional sein müssen: Wenn die Anwendung sie nicht bereitstellt, muss die Quadratwurzelfunktion auch weiterhin Quadratwurzeln berechnen.)

    Diese Anforderungen betreffenden die veränderte Arbeit als Ganzes. Wenn identifizierbare Abschnitte des Werkes nicht von der Bibliothek abgeleitet sind und vernünftigerweise selbst als unabhängige und eigenständige Werke betrachtet werden können, dann erstrecken sich diese Lizenz und ihre Bedingungen nicht auf diese Abschnitte, wenn sie als eigenständige Werke verbreitet werden. Wenn Sie jedoch dieselben Abschnitte als Teil eines Ganzen, das ein Werk, das auf der Bibliothek basiert, darstellt, muss die Verbreitung des Ganzen den Bedingungen dieser Lizenz entsprechen, deren Gestattung für andere Lizenznehmer sich auf das Ganze erweitert und sich daher auf jeden einzelnen Teil, unabhängig davon, wer ihn geschrieben hat, bezieht.

    Es ist jedoch nicht Zweck dieses Abschnitts Rechte einzufordern oder Rechte an von Ihnen geschriebenen Werken anzufechten, sein Zweck ist hingegen, das Recht zur Kontrolle der Verbreitung abgeleiteter oder kollektiver Werke, die auf der Bibliothek basieren, auszuüben.

    Weiterhin führt die reine Vereinigung eines Werkes, das nicht auf der Bibliothek basiert (oder eines Werkes, das auf der Bibliothek basiert) auf einem Speicher- oder Verteilermedium nicht dazu, das dieses Werk unter die Lizenz fällt.

  • 3. Sie können hierfür die Bedingungen einer klassischen GNU General Public License anstelle dieser Lizenz auf eine Kopie der Bibliothek anwenden. Um dies tun zu können, müssen Sie alle Vermerke, die sich auf diese Lizenz beziehen, so ändern, dass sich auf die GNU General Public License Version 2 anstatt auf diese Lizenz beziehen. (Wenn eine neuere Version als Version 2 der klassischen GNU General Public License erschienen ist, können Sie, wenn Sie möchten, diese Version angeben.) Nehmen Sie keine weiteren Änderungen an den Vermerken vor.

    Sobald der Vermerk einer Kopie geändert wurde, ist dies für diese Kopie nicht mehr rückgängig zu machen, das heißt, dass die klassische GNU General Public License auf alle folgenden Kopien und Ableitungen auf Arbeiten, die mit dieser Kopie erstellt wurden, angewendet wird.

    Diese Option ist sinnvoll, wenn Sie einen Teil des Codes der Bibliothek in ein Programm, das keine Bibliothek enthält, kopieren möchten.

  • 4. Sie können die Bibliothek (oder einen Teil oder eine Ableitung davon gemäß Abschnitt 2) in Objektcode oder eine ausführbare Form gemäß den Bestimmungen der Abschnitte 1 und 2 oben kopieren und verbreiten, vorausgesetzt, dass diese zusammen mit dem zugehörigen maschinenlesbaren Quellcode, der sich gemäß den Bestimmungen der Abschnitte 1 und 2 oben auf einem normalerweise für den Austausch von Software verwendeten Medium befinden muss, kopiert und verbreitet werden.

    Wenn eine Verteilung des Objektcodes durch das Angebot eines Zugangs zu einer Kopie von einer bestimmten Stelle aus erfolgen kann, erfüllt ein gleichwertiger Zugang zur Kopie des Quellcodes von derselben Stelle aus die Anforderungen zur Verteilung des Quellcodes, auch wenn Dritte nicht dazu gezwungen werden, den Quellcode zusammen mit dem Objektcode zu kopieren.

  • 5. Ein Programm, das keine Ableitung aus irgendwelchen Teilen der Bibliothek enthält, jedoch für die Ausführung zusammen mit der Bibliothek durch Kompilierung oder Verlinkung konzipiert ist, wird als „Werk, das die Bibliothek benutzt“ bezeichnet. Ein solches Werk ist isoliert kein abgeleitetes Werk aus der Bibliothek und fällt daher nicht unter diese Lizenz.

    Trotzdem erzeugt, im Gegenteil zu einem „Werk, das die Bibliothek benutzt“, eine Verlinkung eines „Werks, das die Bibliothek benutzt“ mit der Bibliothek eine ausführbare Datei, die eine Ableitung der Bibliothek darstellt (da es Teile der Bibliothek enthält). Die ausführbare Datei fällt daher unter die Lizenz. In Abschnitt 6 werden die Bedingungen für die Verteilung solcher ausführbarer Dateien erläutert.

    Wenn ein „Werk, das die Bibliothek benutzt“ Material aus einer Header-Datei, die Teil der Bibliothek ist, verwendet, kann der Objektcode des Werks ein von der Bibliothek abgeleitetes Werk sein, auch wenn der Quellcode dies nicht ist. Ob dies zutrifft ist besonders dann von Bedeutung, wenn das Werk ohne die Bibliothek verknüpft werden kann oder das Werk selbst eine Bibliothek ist. Der Schwellenwert für das Zutreffen dieser Bedingung ist im Gesetz nicht eindeutig geregelt.

    Wenn eine solche Objektdatei nur numerische Parameter, Datenstrukturlayouts und Zugriffberechtigungen, kleine Makros, kleine Inline-Funktionen (mit einer Länge von zehn Zeilen oder weniger) benutzt, ist die Verwendung der Objektdatei nicht eingeschränkt, unabhängig davon, ob sie aus juristischer Sicht ein abgeleitetes Werk darstellt. (Ausführbare Dateien, die diesen Objektcode und Teile der Bibliothek enthalten, fallen jedoch unter Abschnitt 6.)

    Wenn das Werk jedoch eine Ableitung der Bibliothek ist, können Sie den Objektcode für das Werk gemäß den Bestimmungen von Abschnitt 6 verteilen. Alle ausführbaren Dateien, die dieses Werk enthalten, fallen ebenfalls unter Abschnitt 6, unabhängig davon, ob sie direkt mit der Bibliothek verknüpft sind oder nicht.

  • 6. Als Ausnahme der obigen Abschnitte können Sie ein „Werk, das die Bibliothek benutzt“ kompilieren oder mit der Bibliothek verknüpfen, um ein Werk zu produzieren, das Teile der Bibliothek beinhaltet und dieses Werk gemäß der Bestimmungen Ihrer Wahl verteilen, vorausgesetzt, dass diese Bedingungen die Modifikation dieses Werks für den Eigengebrauch des Kunden und das Reverse Engineering für das Debugging solcher Modifikationen gestatten.
    Sie müssen einen deutlichen Vermerk auf jeder Kopie des Werkes anbringen, aus dem hervorgeht, dass die Bibliothek darin verwendet wurde und dass die Bibliothek und deren Verwendung unter diese Lizenz fallen. Sie müssen eine Kopie der Lizenz zur Verfügung stellen. Wenn das Werk während der Ausführung Urheberrechtshinweise anzeigt, müssen Sie einen Urheberrechtshinweis für die Bibliothek, sowie eine Referenz, die den Anwender zur Kopie dieser Lizenz leitet, einfügen. Sie müssen ebenfalls einen der folgenden Punkte erfüllen:
    • a) Das Werk muss zusammen mit dem zugehörigen, vollständigen maschinenlesbaren Quellcode für die Bibliothek, einschließlich aller im Werk verwendeten Änderungen (die gemäß Abschnitt 1 und 2 oben verbreitet werden müssen) und, falls das Werk eine mit der Bibliothek verknüpfte ausführbare Datei ist, zusammen mit dem vollständigen maschinenlesbaren „Werk, das die Bibliothek benutzt“ als Objekt- und/oder als Quellcode verbreitet werden, so dass der Anwender die Bibliothek modifizieren und dann neu verknüpfen kann, um eine modifizierte ausführbare Datei, die die modifizierte Bibliothek enthält, zu produzieren. (Es besteht Einverständnis darüber, dass der Benutzer, der die Inhalte der Definitionsdateien in der Bibliothek ändert, nicht notwendigerweise in der Lage ist, die Anwendung zu rekompilieren, um die modifizierten Definitionen zu verwenden.)
    • b) Das Werk muss zusammen mit dem schriftlichen Angebot, dem Benutzer dieselben Materialien wie in Unterabschnitt 6a oben spezifiziert gegen eine Gebühr, die die Kosten dieser Verbreitung nicht übersteigt, zu liefern, verteilt werden, das mindestens drei Jahre gültig bleiben muss.
    • c) Wenn die Verteilung des Werks über das Angebot eines Zugangs zu einer Kopiermöglichkeit von einer bestimmten Stelle aus erfolgt, bieten Sie einen gleichwertigen Zugang für das Kopieren der oben genannten Materialien von derselben Stelle an.
    • d) Prüfen Sie, ob der Benutzer bereits eine Kopie dieser Materialien erhalten hat oder ob Sie diesem Benutzer bereits eine Kopie geschickt haben.

    Im Fall einer ausführbaren Datei muss die erforderliche Form des „Werks, das die Bibliothek benutzt“ alle Daten und Hilfsprogramme, die für die Reproduktion der ausführbaren Datei von ihm benötigt werden, enthalten. Als besondere Ausnahme jedoch braucht der verbreitete Quellcode nichts beinhalten, das normalerweise (entweder als Quellcode oder in binärer Form) mit den wichtigsten Komponenten (Compiler, Kernel usw.) des Betriebssystems verbreitet wird und mit dem die ausführbare Datei ausgeführt werden kann, sofern die Komponente nicht selbst mit der ausführbaren Datei verbreitet wird.

    Es kann vorkommen, dass diese Anforderung den Lizenzbeschränkungen anderer geschützter Bibliotheken, die normalerweise nicht zum Betriebssystem gehören, widerspricht. Ein solcher Widerspruch bedeutet, dass Sie nicht beide und die Bibliothek zusammen in einer von Ihnen verbreiteten ausführbaren Datei benutzen können.

  • 7. Sie können Bibliotheksroutinen, die ein Werk, basierend auf der Bibliothek sind, nebeneinander in einer einzigen Bibliothek, zusammen mit anderen Bibliotheksroutinen, die nicht von der Lizenz abgedeckt sind, platzieren und eine solche kombinierte Bibliothek verbreiten, vorausgesetzt, dass die separate Verbreitung des auf der Bibliothek basierenden Werks und der anderen Bibliotheksroutinen ansonsten erlaubt ist und unter der Voraussetzung, dass Sie folgendes einhalten:
    • a) Fügen Sie zur kombinierten Bibliothek eine Kopie desselben auf der Bibliothek basierenden Werks hinzu, die nicht mit irgendeiner anderen Routine kombiniert ist. Dies muss gemäß der Bestimmungen der obigen Absätze erfolgen.
    • b) Bringen Sie einen deutlich sichtbaren Vermerk an der kombinierten Bibliothek an, aus dem hervorgeht, dass ein Teil davon ein auf einer Bibliothek basiertes Werk ist und erklären Sie, wo die entsprechende nicht kombinierte Form desselben Werkes verfügbar ist.
  • 8. Sie dürfen die Bibliothek nicht kopieren, modifizieren, sublizenzieren, verknüpfen mit oder verbreiten, wenn diese Lizenz dies nicht ausdrücklich gestattet. Jeder Versuch, die Lizenz zu kopieren, modifizieren, sublizenzieren, verknüpfen mit oder zu verbreiten, lässt sie ungültig werden und Ihre Rechte gemäß dieser Lizenz werden automatisch gekündigt. Parteien, die Kopien oder Rechte gemäß dieser Lizenz von Ihnen erhalten haben, werden die Lizenzen nicht gekündigt, sofern diese Parteien der Einhaltung zur Gänze entsprechen.
  • 9. Sie sind nicht verpflichtet, dieses Lizenz zu akzeptieren, da Sie sie nicht unterschrieben haben. Jedoch erhalten Sie keine andere Erlaubnis, die Bibliothek oder ihre abgeleiteten Arbeiten zu modifizieren oder zu verbreiten. Diese Maßnahmen sind gesetzlich untersagt, wenn Sie die Lizenz nicht akzeptieren. Sie geben daher Ihr Einverständnis, indem Sie die Bibliothek (oder alle auf der Bibliothek basierenden Arbeiten) modifizieren oder verbreiten und akzeptieren damit alle Bedingungen zum Kopieren, Verbreiten und Modifizieren der Bibliothek oder der darauf basierenden Werke.
  • 10. Jedes Mal, wenn Sie die Bibliothek (oder auf der Bibliothek basierende Werke) verbreiten, erhält der Empfänger automatisch eine Lizenz des ursprünglichen Lizenzgebers zum Kopieren, Verbreiten, Verknüpfen mit oder Modifizieren der Bibliothek, die diesen Bedingungen unterliegt. Sie dürfen keine dem Empfänger bei der Ausübung seiner hierin erteilten Rechte keine weiteren Beschränkungen auferlegen. Sie sind nicht für die Durchsetzung der Einhaltung durch Dritte gegenüber diesem Lizenznehmer verantwortlich.
  • 11. Wenn Ihnen infolge eines Gerichtsurteils oder Behauptung einer Patentverletzung oder aus irgendeinem anderen Grund (nicht auf Patentstreitigkeiten beschränkt), Bedingungen auferlegt werden (gleich ob per Gerichtsurteil, Vereinbarung oder sonstigem), die den Bestimmungen dieser Lizenz widersprechen, entbinden diese Sie nicht von den Bestimmungen der Lizenz. Wenn Sie die Bibliothek nicht verbreiten können, um gleichzeitig Ihren Verpflichtungen aus dieser Lizenz und anderen einschlägigen Verpflichtungen nachzukommen, dürfen Sie die Bibliothek überhaupt nicht verbreiten. Beispielsweise, wenn eine Patentlizenz die gebührenfreie Weiterverbreitung der Bibliothek durch alle, die direkt oder indirekt Kopien von Ihnen erhalten haben, nicht erlaubt ist, ist der einzige Weg, beiden Verpflichtungen nachzukommen ist, gänzlich von der Verbreitung der Bibliothek Abstand zu nehmen.

    Sollte sich ein Teil dieses Abschnitts als ungültig oder unter bestimmten Umständen nicht durchsetzbar erweisen, so soll dieser Abschnitt seinem Sinne nach angewandt werden; im übrigen soll dieser Abschnitt als Ganzes gelten.

    Es ist nicht Zweck dieses Abschnitts, Sie dazu zu veranlassen, Patente oder andere Eigentumsrechte zu verletzen oder die Gültigkeit solcher Forderungen in Frage zu stellen, dieser Abschnitt dient nur dazu, die Integrität des freien Software-Verbreitungssystems, die durch die Public Licenses implementiert wurde, zu schützen. Viele Menschen haben großzügige Beiträge zu der breitgefächerten Software geleistet, die über dieses System im Vertrauen auf konsistente Anwendung dieses Systems verteilt wird. Der Autor/Spender entscheidet, ob er oder sie die Software über irgendein anderes System verbreiten möchte und ein Lizenznehmer kann diese Wahl nicht auferlegen.

    Dieser Abschnitt dient zur absoluten Klarstellung, was als Konsequenz aus dem Rest der Lizenz betrachtet wird.

  • 12. Wenn die Verbreitung und/oder die Verwendung der Bibliothek in bestimmten Ländern, entweder durch Patente oder durch urheberrechtlich geschützte Schnittstellen eingeschränkt ist, kann der ursprüngliche Inhaber der Urheberrechts, der die Bibliothek unter diese Lizenz stellt, eine explizite Beschränkung der geografischen Verbreitung, die diese Länder ausschließt, hinzufügen, so dass die Verbreitung nur in oder zwischen Ländern, die nicht ausgeschlossen sind, gestattet ist. In diesem Fall wird diese Beschränkung Teil der Lizenz, so als ob sie im Haupttext der Lizenz enthalten wäre.
  • 13. Die Free Software Foundation kann von Zeit zu Zeit überarbeitete und/oder neue Versionen der Library General Public License veröffentlichen. Diese neuen Versionen werden der vorliegenden Version ähnlich sein, können jedoch im Detail davon abweichen, um neue Probleme oder Überlegungen anzusprechen.

    Jede Version erhält eine klar unterscheidbare Versionsnummer. Wenn eine Bibliothek angibt, dass eine bestimmte Versionsnummer dieser Lizenz oder irgendeine spätere Version darauf anwendbar ist, haben Sie die Wahl, entweder die Bestimmungen der genannten Version zu befolgen oder denen jeder beliebigen späteren Version, die von der Free Software Foundation veröffentlicht wurde. Wenn die Bibliothek keine Versionsnummer der Lizenz angibt, können Sie eine aus allen bisher von der Free Software Foundation veröffentlichten wählen.

  • 14. Wenn Sie Teile der Bibliothek in andere freie Programme, deren Verbreitungsbestimmungen nicht mit diesen kompatibel sind, einfügen möchten, schreiben Sie den Autor an und bitten Sie um Erlaubnis. Wenn es sich um Software handelt, die von der Free Software Foundation urheberrechtlich geschützt wurde, schreiben Sie an die Free Software Foundation, wir machen manchmal Ausnahmen hierfür. Unsere Entscheidung wird von den zwei Zielen des Bewahrens des freien Status aller Ableitungen unserer freien Software und der Förderung des gemeinsamen Nutzens und Wiederverwendung von Software im Allgemeinen geleitet sein.

    KEINE GARANTIE

  • 15. DA DIE BIBLIOTHEK KOSTENFREI LIZENZIERT WIRD, ERHALTEN SIE KEINE GARANTIE FÜR DIE BIBLIOTHEK, SOWEIT DIES DURCH DIE ANWENDBAREN GESETZTE GEREGELT IST. WENN NICHT ANDERS SCHRIFTLICH ANGEGEBEN, LIEFERN DER INHABER DES COPYRIGHTS UND/ODER ANDERE PARTEIEN DIE BIBLIOTHEK „AS IS“, OHNE GARANTIEN UND HAFTUNG, ENTWEDER AUSDRÜCKLICH ODER IMPLIZIERT, JEDER ART ZU ÜBERNEHMEN, EINSCHLIESSLICH, JEDOCH NICHT DARAUF BESCHRÄNKT, DIE MARKTFÄHIGKEIT UND DIE EIGNUNG FÜR EINEN BESTIMMTEN ZWECK ZU GARANTIEREN. SIE TRAGEN DAS GESAMTE RISIKO BEZÜGLICH DER QUALITÄT UND LEISTUNGSFÄHIGKEIT DER BIBLIOTHEK. WENN SICH DIE BIBLIOTHEK ALS FEHLERHAFT HERAUSSTELLT, ÜBERNEHMEN SIE ALLE KOSTEN FÜR NOTWENDIGE SERVICEARBEITEN, REPARATUREN ODER KORREKTURMASSNAHMEN.
  • 16. DER COPYRIGHT-EIGENTÜMER ODER EINE ANDERE PARTEI, DIE DIE BIBLIOTHEK WIE OBEN BESCHRIEBEN ÄNDERN UND/ODER VERTEILEN, WERDEN IN KEINEM FALL, AUSSER WENN ES DAS ANWENDBARE RECHT ERFORDERT ODER WENN EINE SCHRIFTLICHE VEREINBARUNG VORLIEGT, IHNEN GEGENÜBER KEINE HAFTUNG FÜR SCHÄDEN ÜBERNEHMEN, EINSCHLIESSLICH ALLER ALLGEMEINEN, SPEZIELLEN, ZUFÄLLIGEN ODER FOLGESCHÄDEN, DIE AUS DER VERWENDUNG ODER DER UNMÖGLICHKEIT DER VERWENDUNG DER BIBLIOTHEK ENTSTANDEN SIND (EINSCHLIESSLICH ABER NICHT BESCHRÄNKT AUF DEN DATENVERLUST ODER DER NICHT KORREKTEN WIEDERGABE VON DATEN ODER VERLUSTEN FÜR SIE ODER DRITTE ODER DER INKOMPATIBILITÄT DER SOFTWARE MIT ANDEREN PROGRAMMEN), AUCH WENN DER EIGENTÜMER ODER EINE ANDERE PARTEI AUF DIE MÖGLICHKEIT SOLCHER SCHÄDEN HINGEWIESEN WURDEN.
ENDE DER ALLGEMEINEN BEDINGUNGEN

Wie Sie diese Bestimmungen auf Ihre Bibliotheken anwenden

Wenn Sie eine neue Bibliothek entwickeln und Sie diese der Öffentlichkeit zur Verfügung stellen möchten, empfehlen wir, sie als freie Software, die jeder weiter verbreiten und ändern kann, bereitzustellen. Sie können die Weiterverbreitung gemäß diesen Bestimmungen (oder alternativ, gemäß den Bestimmungen der klassischen General Public License) erlauben.

Hängen Sie zur Anwendung dieser Bestimmungen folgende Vermerke an der Bibliothek an. Die sicherste Lösung ist, sie zu Beginn einer jeden Quelldatei anzufügen, um äußerst effektiv den Ausschluss der Garantie und Haftung auszudrücken. Jede Datei sollte mindestens die „Copyright-Zeile“ und einen Verweis auf den vollständigen Vermerk enthalten.

    one line to give the library's name and an idea of what it does.
    Copyright (C) year name of author

    This library is free software; you can redistribute it and/or
    modify it under the terms of the GNU Library General Public
    License as published by the Free Software Foundation; either
    version 2 of the License, or (at your option) any later version.

    This library is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
    Library General Public License for more details.

    You should have received a copy of the GNU Library General Public
    License along with this library; if not, write to the
    Free Software Foundation, Inc., 59 Temple Place - Suite 330,
    Boston, MA  02111-1307, USA.

Fügen Sie Ihre Kontaktdaten für elektronische und normale Post hinzu.

Sie sollten Ihren Arbeitgeber (wenn Sie als Programmierer arbeiten) oder Ihre Schule bitten, den „Copyright & Haftungsausschluss“ zu unterzeichnen. Hier ein Muster, ändern Sie bitte die Namen:
    Yoyodyne, Inc., hereby disclaims all copyright interest in
    the library 'Frob' (a library for tweaking knobs) written
    by James Random Hacker.

    signature of Ty Coon, 1 April 1990
    Ty Coon, President of Vice
Das ist alles!

GNU LESSER GENERAL PUBLIC LICENSE

Version 2.1, Februar 1999

Copyright © 1991, 1999 Free Software Foundation, Inc.

59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

Jedem ist es gestattet, wortgetreue Kopien dieser Lizenz zu kopieren und weiter zu verbreiten, Änderungen sind nicht gestattet.

Präambel

Die Lizenzen für die meiste Software dienen dazu, Ihnen die Freiheit zum Teilen und zum Ändern der Software zu nehmen. Im Gegensatz dazu garantieren Ihnen die GNU General Public Licenses die Freiheit, freie Software zu teilen und zu verändern, um sicherzustellen, dass die Software für alle Benutzer frei zugänglich ist.

Diese Lesser General Public License gilt für einige speziell konzipierte Softwarepakete (in der Regel Bibliotheken) der Free Software Foundation und anderer Autoren, die sie verwenden. Sie können Sie ebenfalls verwenden, wir schlagen jedoch vor, dass Sie zunächst genau überlegen, ob diese Lizenz oder die klassische General Public License, basierend auf nachstehenden Erklärungen, im Einzelfall die bessere Strategie darstellt:

Wenn wir von Software sprechen, beziehen wir uns auf die Freiheit, sie zu nutzen, nicht auf den Preis. Unsere General Public Licenses sind dazu gedacht, dass Sie die Freiheit besitzen, Kopien der freien Software (und diesen Service zu berechnen, wenn Sie dies möchten) zu verbreiten, zu der Sie den Quellcode bekommen oder bekommen können, wenn Sie dies möchten, dass Sie diese Software ändern können und Teile daraus in neuen, freien Programmen verwenden können und dass Sie wissen, dass Sie genau dies tun können.

Um Ihre Rechte zu schützen, müssen wir Beschränkungen einführen, die Distributoren, die Ihnen diese Rechte absprechen oder Sie bitten, diese Rechte aufzugeben. Diese Beschränkungen führen zu bestimmten Verantwortlichkeiten für Sie, wenn Sie Kopien der Bibliothek verbreiten oder sie modifizieren.

Wenn Sie beispielsweise Kopien der Bibliothek unentgeltlich oder gegen Entgelt verbreiten, müssen Sie den Empfängern sämtliche Rechte gewähren, die Sie haben. Sie müssen sicherstellen, dass auch der Empfänger den Quellcode erhält oder darauf zugreifen kann. Wenn Sie den Code mit der Bibliothek verknüpfen, müssen Sie den Empfängern vollständige Objektdateien zur Verfügung stellen, so dass sie diese nach Änderungen an der Bibliothek und deren Rekompilierung wieder mit der Bibliothek verknüpfen können. Und Sie müssen ihnen diese Bedingungen mitteilen, damit sie ihre Rechte kennen.

Wir schützen Ihre Rechte mit einer zweistufigen Methode: (1) Wir schützen die Bibliothek und (2) wir bieten Ihnen diese Lizenz an, die Ihnen das Recht gibt, die Software zu kopieren, zu verbreiten und/oder zu verändern.

Um jeden Distributor zu schützen, stellen wir klar, dass es für diese Bibliothek keine Gewährleistungs- und Haftungsansprüche gibt. Auch wenn die Bibliothek von einem Anderen modifiziert und weitergegeben wurde, sollten die Empfänger wissen, dass das, was sie bekommen haben, nicht die Originalversion ist, so dass der Ruf des Autors der Originalversion nicht durch Probleme, die eventuell von Anderen verursacht wurden, Schaden nimmt.

Letztendlich stellen Softwarepatente eine ständige Bedrohung für die Existenz jedes freien Programms dar. Wir möchten sicherstellen, dass kein Unternehmen die Anwender eines freien Programms durch den Erwerb einer restriktiven Lizenz von einem Patentinhaber effektiv einschränken kann. Daher bestehen wir darauf, dass jede Patentlizenz, die für eine Version der Bibliothek erworben wurde, im Einklang mit der vollen Freiheit zur Nutzung, wie in dieser Lizenz beschrieben, stehen muss.

Die meiste GNU-Software, einschließlich Bibliotheken, wird von der klassischen GNU General Public License abgedeckt. Diese Lizenz, die GNU Lesser General Public License, bezieht sich auf bestimmte, designierte Bibliotheken und unterscheidet sich von der klassischen General Public License. Wir verwenden diese Lizenz für bestimmte Bibliotheken, um eine Verknüpfung dieser Bibliotheken mit nicht-freien Programmen zu ermöglichen.

Wenn ein Programm mit einer Bibliothek verknüpft ist, gleich, ob statisch oder über eine gemeinsam genutzte Bibliothek, ist die Kombination der beiden aus juristischer Sicht ein kombiniertes Werk, eine Ableitung der ursprünglichen Bibliothek. Die klassische General Public License erlaubt diese Verknüpfung daher nur, wenn die gesamte Kombination ihren Kriterien für Freiheit entspricht. Die Lesser General Public License erlaubt das Anlegen lockerer Kriterien zur Verknüpfung anderen Codes mit der Bibliothek.

Wir bezeichnen diese Lizenz als „Lesser“ General Public License, da sie weniger zum Schutz der Freiheit des Benutzers beiträgt wie die klassische General Public License. Sie bietet auch anderen freien Softwareentwicklern weniger Vorteile gegenüber konkurrierenden, nicht-freien Programmen. Aufgrund dieser Nachteile verwenden wir die klassische General Public License für viele Bibliotheken. Die Lesser License bietet jedoch unter bestimmten, besonderen Voraussetzungen Vorteile.

Wenn beispielsweise der seltene Fall, dass ein spezieller Bedarf zur Förderung der möglichst umfassenden Nutzung einer Bibliothek besteht, so dass sie zum Defacto-Standard wird. Um dies zu erreichen, müssen nicht-freie Programme die Bibliothek nutzen können. Ein häufiger auftretender Fall ist, dass die freie Bibliothek dieselbe Aufgabe ausführt, wie weit verbreitete nicht-freie Bibliotheken. In diesem Fall wird durch die Beschränkung der freien Bibliothek auf freie Software wenig gewonnen, wir verwenden daher die Lesser General Public License.

In anderen Fällen ermöglicht die Erlaubnis eine bestimmte Bibliothek in nicht-freien Programmen zu verwenden einem größeren Personenkreis einen großen Teil freier Software zu verwenden. So ermöglicht beispielsweise die Erlaubnis, die GNU C-Bibliothek in nicht-freien Programmen zu verwenden, wesentlich mehr Menschen die Nutzung des gesamten GNU-Betriebssystems sowie seiner Variante, das GNU/Linux-Betriebssystem.

Obwohl die Lesser General Public License die Freiheit des Benutzers weniger schützt, stellt sie sicher, dass der Benutzer eines Programms, das mit der Bibliothek verknüpft ist, die Freiheit und die erforderlichen Mittel besitzt, dieses Programm mit einer modifizierten Version der Bibliothek auszuführen.

Die genauen Bedingungen für Kopieren, Weitergabe und Modifikation folgen. Beachten Sie unbedingt den Unterschied zwischen einem „Werk, das auf der Bibliothek basiert“ und einem „Werk, das die Bibliothek verwendet“. Das erste enthält Code, der von der Bibliothek abgeleitet wurde, wohingegen das letztere mit der Bibliothek kombiniert werden muss, um ausgeführt zu werden.

BEDINGUNGEN FÜR KOPIEREN, VERBREITUNG UND MODIFIKATION

  • 0. Diese Lizenzvereinbarung gilt für alle Softwarebibliotheken oder andere Programme, die einen vom Inhaber des Urheberrechts oder einer autorisierten Partei eingefügten Hinweis beinhaltet, der besagt, dass sie entsprechend der Bedingungen dieser Lesser General Public License für Bibliotheken (nachstehend „diese Lizenz“) verbreitet werden darf. Jeder Lizenznehmer wird mit „Sie“ bezeichnet.

    Unter einer „Bibliothek“ wird eine Sammlung von Softwarefunktionen und/oder Daten verstanden, die so vorbereitet sind, dass sie in geeigneter Weise mit anderen Anwendungsprogrammen (die einige dieser Funktionen und Daten nutzen) verknüpft werden können, um ausführbare Programme zu erhalten.

    Der nachstehende Begriff „Bibliothek“ bezieht sich auf eine solche Softwarebibliothek oder Arbeiten, die unter diesen Bedingungen verbreitet worden sind. Ein „Werk, das auf einer Bibliothek basiert“ bezeichnet entweder eine Bibliothek oder jedes abgeleitete Werk, das unter das Urheberrecht fällt: Das heißt, ein Werk, das die Bibliothek oder einen Teil der Bibliothek, entweder wortgetreu oder modifiziert und/oder direkt in eine andere Sprache übersetzt, enthält. (Nachstehend fällt Übersetzung ohne Einschränkung unter den Begriff „Modifikation“.)

    Der „Quellcode“ für ein Werk bezeichnet die bevorzugte Form eines Werks, um es zu modifizieren. Im Fall einer Bibliothek bedeutet „vollständiger Quellcode“ der gesamte Quellcode für alle darin enthaltenen Module, sowie alle zugehörigen Schnittstellendefinitionsdateien und die zur Kontrolle der Kompilierung und Installation der Bibliothek verwendeten Skripte.

    Diese Lizenz deckt nur das Kopieren, die Verbreitung und Modifikation ab, alle anderen Aktivitäten sind nicht darin enthalten. Der Vorgang der Ausführung eines Programms unter Verwendung der Bibliothek wird nicht eingeschränkt und die Ergebnisse eines solchen Programms sind nur dann abgedeckt, wenn seine Inhalte ein Werk, das auf der Bibliothek basiert, bilden (unabhängig davon, ob die Bibliothek in einem Werkzeug zum Schreiben des Programms verwendet wurde). Ob dies zutrifft, hängt davon ab, was die Bibliothek bewirkt und was das Programm, das die Bibliothek verwendet, bewirkt.

  • 1. Sie können wortgetreue Kopien des vollständigen Quellcodes der Bibliothek, so, wie Sie ihn erhalten, mittels jeden Mediums, kopieren und verbreiten, vorausgesetzt, dass Sie auf jeder Kopie einen deutlichen und geeigneten Urheberrechtsvermerk und Haftungsausschluss anbringen, alle Vermerke, die sich auf diese Lizenz und den Haftungsausschluss beziehen, nicht beschädigen und eine Kopie dieser Lizenzvereinbarung zusammen mit der Bibliothek verbreiten.

    Sie können eine Gebühr für den physischen Akt der Verbreitung einer Kopie erheben und Sie können, so Sie dies wünschen, eine Garantie als Gegenleistung für die Gebühr aussprechen.

  • 2. Sie können Ihre Kopie oder Kopien der Bibliothek oder eines jeden Teils der Bibliothek modifizieren. Auf diese Weise entsteht eine Arbeit, die auf der Bibliothek basiert, und diese Modifikationen oder Arbeiten gemäß den in Abschnitt 1 oben genannten Bedingungen unter der Voraussetzung, dass Sie alle folgenden Bedingungen einhalten, verbreiten:
    • a) Das modifizierte Werk muss selbst eine Softwarebibliothek sein.
    • b) Sie müssen veranlassen, dass die modifizierten Dateien mit deutlich sichtbaren Vermerken, die darauf hinweisen, dass Sie die Dateien geändert haben sowie das Datum der Änderungen, versehen sind.
    • c) Sie müssen veranlassen, dass die gesamte Arbeit für alle Dritten gemäß den Bedingungen dieser Lizenz kostenfrei lizenziert wird.
    • d) Wenn eine Routine in der modifizierten Bibliothek sich auf eine Funktion oder eine Tabelle bezieht, die von einer Anwendung, die diese Routine bereitstellt, genutzt wird, außer, es wird ein Argument übergeben, wenn diese Routine aufgerufen wird, in diesem Fall müssen Sie sich in gutem Glauben darum bemühen, sicherzustellen, dass, falls eine Anwendung eine solche Funktion oder Tabelle nicht bereitstellt, diese Routine weiterhin arbeitet und denjenigen Teil ihres Zweckes, der sinnvoll bleibt, weiterhin ausführt. (Zum Beispiel: Eine Funktion in einer Bibliothek zur Berechnung von Quadratwurzeln hat einen Zweck, der wohldefiniert unabhängig von der Anwendung ist. Daher verlangt Unterabschnitt 2d, dass alle von Anwendungen bereitgestellte Funktionen oder Tabellen, die von dieser Funktion genutzt werden, optional sein müssen: Wenn die Anwendung sie nicht bereitstellt, muss die Quadratwurzelfunktion auch weiterhin Quadratwurzeln berechnen.)

    Diese Anforderungen betreffenden die veränderte Arbeit als Ganzes. Wenn identifizierbare Abschnitte des Werkes nicht von der Bibliothek abgeleitet sind und vernünftigerweise selbst als unabhängige und eigenständige Werke betrachtet werden können, dann erstrecken sich diese Lizenz und ihre Bedingungen nicht auf diese Abschnitte, wenn sie als eigenständige Werke verbreitet werden. Wenn Sie jedoch dieselben Abschnitte als Teil eines Ganzen, das ein Werk, das auf der Bibliothek basiert, darstellt, muss die Verbreitung des Ganzen den Bedingungen dieser Lizenz entsprechen, deren Gestattung für andere Lizenznehmer sich auf das Ganze erweitert und sich daher auf jeden einzelnen Teil, unabhängig davon, wer ihn geschrieben hat, bezieht.

    Es ist jedoch nicht Zweck dieses Abschnitts Rechte einzufordern oder Rechte an von Ihnen geschriebenen Werken anzufechten, sein Zweck ist hingegen, das Recht zur Kontrolle der Verbreitung abgeleiteter oder kollektiver Werke, die auf der Bibliothek basieren, auszuüben.

    Weiterhin führt die reine Vereinigung eines Werkes, das nicht auf der Bibliothek basiert (oder eines Werkes, das auf der Bibliothek basiert) auf einem Speicher- oder Verteilermedium nicht dazu, das dieses Werk unter die Lizenz fällt.

  • 3. Sie können hierfür die Bedingungen einer klassischen GNU General Public License anstelle dieser Lizenz auf eine Kopie der Bibliothek anwenden. Um dies tun zu können, müssen Sie alle Vermerke, die sich auf diese Lizenz beziehen, so ändern, dass sich auf die GNU General Public License Version 2 anstatt auf diese Lizenz beziehen. (Wenn eine neuere Version als Version 2 der klassischen GNU General Public License erschienen ist, können Sie, wenn Sie möchten, diese Version angeben.) Nehmen Sie keine weiteren Änderungen an den Vermerken vor.

    Sobald der Vermerk einer Kopie geändert wurde, ist dies für diese Kopie nicht mehr rückgängig zu machen, das heißt, dass die klassische GNU General Public License auf alle folgenden Kopien und Ableitungen auf Arbeiten, die mit dieser Kopie erstellt wurden, angewendet wird.

    Diese Option ist sinnvoll, wenn Sie einen Teil des Codes der Bibliothek in ein Programm, das keine Bibliothek enthält, kopieren möchten.

  • 4. Sie können die Bibliothek (oder einen Teil oder eine Ableitung davon gemäß Abschnitt 2) in Objektcode oder eine ausführbare Form gemäß den Bestimmungen der Abschnitte 1 und 2 oben kopieren und verbreiten, vorausgesetzt, dass diese zusammen mit dem zugehörigen maschinenlesbaren Quellcode, der sich gemäß den Bestimmungen der Abschnitte 1 und 2 oben auf einem normalerweise für den Austausch von Software verwendeten Medium befinden muss, kopiert und verbreitet werden.

    Wenn eine Verteilung des Objektcodes durch das Angebot eines Zugangs zu einer Kopie von einer bestimmten Stelle aus erfolgen kann, erfüllt ein gleichwertiger Zugang zur Kopie des Quellcodes von derselben Stelle aus die Anforderungen zur Verteilung des Quellcodes, auch wenn Dritte nicht dazu gezwungen werden, den Quellcode zusammen mit dem Objektcode zu kopieren.

  • 5. Ein Programm, das keine Ableitung aus irgendwelchen Teilen der Bibliothek enthält, jedoch für die Ausführung zusammen mit der Bibliothek durch Kompilierung oder Verlinkung konzipiert ist, wird als „Werk, das die Bibliothek benutzt“ bezeichnet. Ein solches Werk ist isoliert kein abgeleitetes Werk aus der Bibliothek und fällt daher nicht unter diese Lizenz.

    Trotzdem erzeugt, im Gegenteil zu einem „Werk, das die Bibliothek benutzt“, eine Verlinkung eines „Werks, das die Bibliothek benutzt“ mit der Bibliothek eine ausführbare Datei, die eine Ableitung der Bibliothek darstellt (da es Teile der Bibliothek enthält). Die ausführbare Datei fällt daher unter die Lizenz. In Abschnitt 6 werden die Bedingungen für die Verteilung solcher ausführbarer Dateien erläutert.

    Wenn ein „Werk, das die Bibliothek benutzt“ Material aus einer Header-Datei, die Teil der Bibliothek ist, verwendet, kann der Objektcode des Werks ein von der Bibliothek abgeleitetes Werk sein, auch wenn der Quellcode dies nicht ist. Ob dies zutrifft ist besonders dann von Bedeutung, wenn das Werk ohne die Bibliothek verknüpft werden kann oder das Werk selbst eine Bibliothek ist. Der Schwellenwert für das Zutreffen dieser Bedingung ist im Gesetz nicht eindeutig geregelt.

    Wenn eine solche Objektdatei nur numerische Parameter, Datenstrukturlayouts und Zugriffberechtigungen, kleine Makros, kleine Inline-Funktionen (mit einer Länge von zehn Zeilen oder weniger) benutzt, ist die Verwendung der Objektdatei nicht eingeschränkt, unabhängig davon, ob sie aus juristischer Sicht ein abgeleitetes Werk darstellt. (Ausführbare Dateien, die diesen Objektcode und Teile der Bibliothek enthalten, fallen jedoch unter Abschnitt 6.)

    Wenn das Werk jedoch eine Ableitung der Bibliothek ist, können Sie den Objektcode für das Werk gemäß den Bestimmungen von Abschnitt 6 verteilen. Alle ausführbaren Dateien, die dieses Werk enthalten, fallen ebenfalls unter Abschnitt 6, unabhängig davon, ob sie direkt mit der Bibliothek verknüpft sind oder nicht.

  • 6. Als Ausnahme der obigen Abschnitte können Sie ein „Werk, das die Bibliothek benutzt“ kombinieren oder mit der Bibliothek verknüpfen, um ein Werk zu produzieren, das Teile der Bibliothek beinhaltet und dieses Werk gemäß der Bestimmungen Ihrer Wahl verteilen, vorausgesetzt, dass diese Bedingungen die Modifikation dieses Werks für den Eigengebrauch des Kunden und das Reverse Engineering für das Debugging solcher Modifikationen gestatten.
    Sie müssen einen deutlichen Vermerk auf jeder Kopie des Werkes anbringen, aus dem hervorgeht, dass die Bibliothek darin verwendet wurde und dass die Bibliothek und deren Verwendung unter diese Lizenz fallen. Sie müssen eine Kopie der Lizenz zur Verfügung stellen. Wenn das Werk während der Ausführung Urheberrechtshinweise anzeigt, müssen Sie einen Urheberrechtshinweis für die Bibliothek, sowie eine Referenz, die den Anwender zur Kopie dieser Lizenz leitet, einfügen. Sie müssen ebenfalls einen der folgenden Punkte erfüllen:
    • a) Das Werk muss zusammen mit dem zugehörigen, vollständigen maschinenlesbaren Quellcode für die Bibliothek, einschließlich aller im Werk verwendeten Änderungen (die gemäß Abschnitt 1 und 2 oben verbreitet werden müssen) und, falls das Werk eine mit der Bibliothek verknüpfte ausführbare Datei ist, zusammen mit dem vollständigen maschinenlesbaren „Werk, das die Bibliothek benutzt“ als Objekt- und/oder als Quellcode verbreitet werden, so dass der Anwender die Bibliothek modifizieren und dann neu verknüpfen kann, um eine modifizierte ausführbare Datei, die die modifizierte Bibliothek enthält, zu produzieren. (Es besteht Einverständnis darüber, dass der Benutzer, der die Inhalte der Definitionsdateien in der Bibliothek ändert, nicht notwendigerweise in der Lage ist, die Anwendung zu rekompilieren, um die modifizierten Definitionen zu verwenden.)
    • b) Verwenden Sie einen geeigneten Mechanismus für gemeinsame Bibliotheken zur Verknüpfung mit der Bibliothek. Ein geeigneter Mechanismus ist einer, der (1) zur Laufzeit eine bereits auf dem Computersystem des Benutzers vorhandene Bibliothek benutzt anstatt Bibliotheksfunktionen in die ausführbare Datei zu kopieren und (2) mit einer modifizierten Version der Bibliothek einwandfrei arbeitet, wenn der Benutzer eine installiert, solange die modifizierte Version mit der Version, mit der das Werk erstellt wurde, schnittstellenkompatibel ist.
    • c) Das Werk muss zusammen mit dem schriftlichen Angebot, dem Benutzer dieselben Materialien wie in Unterabschnitt 6a oben spezifiziert gegen eine Gebühr, die die Kosten dieser Verbreitung nicht übersteigt, zu liefern, verteilt werden, das mindestens drei Jahre gültig bleiben muss.
    • d) Wenn die Verteilung des Werks über das Angebot eines Zugangs zu einer Kopiermöglichkeit von einer bestimmten Stelle aus erfolgt, bieten Sie einen gleichwertigen Zugang für das Kopieren der oben genannten Materialien von derselben Stelle an.
    • e) Prüfen Sie, ob der Benutzer bereits eine Kopie dieser Materialien erhalten hat oder ob Sie diesem Benutzer bereits eine Kopie geschickt haben.

    Im Fall einer ausführbaren Datei muss die erforderliche Form des „Werks, das die Bibliothek benutzt“ alle Daten und Hilfsprogramme, die für die Reproduktion der ausführbaren Datei von ihm benötigt werden, enthalten. Als besondere Ausnahme jedoch braucht das zu verbreitende Material nichts zu beinhalten, das normalerweise (entweder als Quellcode oder in binärer Form) mit den wichtigsten Komponenten (Compiler, Kernel usw.) des Betriebssystems verbreitet wird und mit dem die ausführbare Datei ausgeführt werden kann, sofern die Komponente nicht selbst mit der ausführbaren Datei verbreitet wird.

    Es kann vorkommen, dass diese Anforderung den Lizenzbeschränkungen anderer geschützter Bibliotheken, die normalerweise nicht zum Betriebssystem gehören, widerspricht. Ein solcher Widerspruch bedeutet, dass Sie nicht beide und die Bibliothek zusammen in einer von Ihnen verbreiteten ausführbaren Datei benutzen können.

  • 7. Sie können Bibliotheksroutinen, die ein Werk, basierend auf der Bibliothek sind, nebeneinander in einer einzigen Bibliothek, zusammen mit anderen Bibliotheksroutinen, die nicht von der Lizenz abgedeckt sind, platzieren und eine solche kombinierte Bibliothek verbreiten, vorausgesetzt, dass die separate Verbreitung des auf der Bibliothek basierenden Werks und der anderen Bibliotheksroutinen ansonsten erlaubt ist und unter der Voraussetzung, dass Sie folgendes einhalten:
    • a) Fügen Sie zur kombinierten Bibliothek eine Kopie desselben auf der Bibliothek basierenden Werks hinzu, die nicht mit irgendeiner anderen Routine kombiniert ist. Dies muss gemäß der Bestimmungen der obigen Absätze erfolgen.
    • b) Bringen Sie einen deutlich sichtbaren Vermerk an der kombinierten Bibliothek an, aus dem hervorgeht, dass ein Teil davon ein auf einer Bibliothek basiertes Werk ist und erklären Sie, wo die entsprechende nicht kombinierte Form desselben Werkes verfügbar ist.
  • 8. Sie dürfen die Bibliothek nicht kopieren, modifizieren, sublizenzieren, verknüpfen mit oder verbreiten, wenn diese Lizenz dies nicht ausdrücklich gestattet. Jeder Versuch, die Lizenz zu kopieren, modifizieren, sublizenzieren, verknüpfen mit oder zu verbreiten, lässt sie ungültig werden und Ihre Rechte gemäß dieser Lizenz werden automatisch gekündigt. Parteien, die Kopien oder Rechte gemäß dieser Lizenz von Ihnen erhalten haben, werden die Lizenzen nicht gekündigt, sofern diese Parteien der Einhaltung zur Gänze entsprechen.
  • 9. Sie sind nicht verpflichtet, dieses Lizenz zu akzeptieren, da Sie sie nicht unterschrieben haben. Jedoch erhalten Sie keine andere Erlaubnis, die Bibliothek oder ihre abgeleiteten Arbeiten zu modifizieren oder zu verbreiten. Diese Maßnahmen sind gesetzlich untersagt, wenn Sie die Lizenz nicht akzeptieren. Sie geben daher Ihr Einverständnis, indem Sie die Bibliothek (oder alle auf der Bibliothek basierenden Arbeiten) modifizieren oder verbreiten und akzeptieren damit alle Bedingungen zum Kopieren, Verbreiten und Modifizieren der Bibliothek oder der darauf basierenden Werke.
  • 10. Jedes Mal, wenn Sie die Bibliothek (oder auf der Bibliothek basierende Werke) verbreiten, erhält der Empfänger automatisch eine Lizenz des ursprünglichen Lizenzgebers zum Kopieren, Verbreiten, Verknüpfen mit oder Modifizieren der Bibliothek, die diesen Bedingungen unterliegt. Sie dürfen keine dem Empfänger bei der Ausübung seiner hierin erteilten Rechte keine weiteren Beschränkungen auferlegen. Sie sind nicht für die Durchsetzung der Einhaltung durch Dritte mit dieser Lizenz verantwortlich.
  • 11. Wenn Ihnen infolge eines Gerichtsurteils oder Behauptung einer Patentverletzung oder aus irgendeinem anderen Grund (nicht auf Patentstreitigkeiten beschränkt), Bedingungen auferlegt werden (gleich ob per Gerichtsurteil, Vereinbarung oder sonstigem), die den Bestimmungen dieser Lizenz widersprechen, entbinden diese Sie nicht von den Bestimmungen der Lizenz. Wenn Sie die Bibliothek nicht verbreiten können, um gleichzeitig Ihren Verpflichtungen aus dieser Lizenz und anderen einschlägigen Verpflichtungen nachzukommen, dürfen Sie die Bibliothek überhaupt nicht verbreiten. Beispielsweise, wenn eine Patentlizenz die gebührenfreie Weiterverbreitung der Bibliothek durch alle, die direkt oder indirekt Kopien von Ihnen erhalten haben, nicht erlaubt ist, ist der einzige Weg, beiden Verpflichtungen nachzukommen ist, gänzlich von der Verbreitung der Bibliothek Abstand zu nehmen.

    Sollte sich ein Teil dieses Abschnitts als ungültig oder unter bestimmten Umständen nicht durchsetzbar erweisen, so soll dieser Abschnitt seinem Sinne nach angewandt werden; im übrigen soll dieser Abschnitt als Ganzes gelten.

    Es ist nicht Zweck dieses Abschnitts, Sie dazu zu veranlassen, Patente oder andere Eigentumsrechte zu verletzen oder die Gültigkeit solcher Forderungen in Frage zu stellen, dieser Abschnitt dient nur dazu, die Integrität des freien Software-Verbreitungssystems, die durch die Public Licenses implementiert wurde, zu schützen. Viele Menschen haben großzügige Beiträge zu der breitgefächerten Software geleistet, die über dieses System im Vertrauen auf konsistente Anwendung dieses Systems verteilt wird. Der Autor/Spender entscheidet, ob er oder sie die Software über irgendein anderes System verbreiten möchte und ein Lizenznehmer kann diese Wahl nicht auferlegen.

    Dieser Abschnitt dient zur absoluten Klarstellung, was als Konsequenz aus dem Rest der Lizenz betrachtet wird.

  • 12. Wenn die Verbreitung und/oder die Verwendung der Bibliothek in bestimmten Ländern, entweder durch Patente oder durch urheberrechtlich geschützte Schnittstellen eingeschränkt ist, kann der ursprüngliche Inhaber der Urheberrechts, der die Bibliothek unter diese Lizenz stellt, eine explizite Beschränkung der geografischen Verbreitung, die diese Länder ausschließt, hinzufügen, so dass die Verbreitung nur in oder zwischen Ländern, die nicht ausgeschlossen sind, gestattet ist. In diesem Fall wird diese Beschränkung Teil der Lizenz, so als ob sie im Haupttext der Lizenz enthalten wäre.
  • 13. Die Free Software Foundation kann von Zeit zu Zeit überarbeitete und/oder neue Versionen der Lesser General Public License veröffentlichen. Diese neuen Versionen werden der vorliegenden Version ähnlich sein, können jedoch im Detail davon abweichen, um neue Probleme oder Überlegungen anzusprechen.

    Jede Version erhält eine klar unterscheidbare Versionsnummer. Wenn eine Bibliothek angibt, dass eine bestimmte Versionsnummer dieser Lizenz oder irgendeine spätere Version darauf anwendbar ist, haben Sie die Wahl, entweder die Bestimmungen der genannten Version zu befolgen oder denen jeder beliebigen späteren Version, die von der Free Software Foundation veröffentlicht wurde. Wenn die Bibliothek keine Versionsnummer der Lizenz angibt, können Sie eine aus allen bisher von der Free Software Foundation veröffentlichten wählen.

  • 14. Wenn Sie Teile der Bibliothek in andere freie Programme, deren Verbreitungsbestimmungen nicht mit diesen kompatibel sind, einfügen möchten, schreiben Sie den Autor an und bitten Sie um Erlaubnis. Wenn es sich um Software handelt, die von der Free Software Foundation urheberrechtlich geschützt wurde, schreiben Sie an die Free Software Foundation, wir machen manchmal Ausnahmen hierfür. Unsere Entscheidung wird von den zwei Zielen des Bewahrens des freien Status aller Ableitungen unserer freien Software und der Förderung des gemeinsamen Nutzens und Wiederverwendung von Software im Allgemeinen geleitet sein.

    KEINE GARANTIE

  • 15. DA DIE BIBLIOTHEK KOSTENFREI LIZENZIERT WIRD, ERHALTEN SIE KEINE GARANTIE FÜR DIE BIBLIOTHEK, SOWEIT DIES DURCH DIE ANWENDBAREN GESETZTE GEREGELT IST. WENN NICHT ANDERS SCHRIFTLICH ANGEGEBEN, LIEFERN DER INHABER DES COPYRIGHTS UND/ODER ANDERE PARTEIEN DIE BIBLIOTHEK „AS IS“, OHNE GARANTIEN UND HAFTUNG, ENTWEDER AUSDRÜCKLICH ODER IMPLIZIERT, JEDER ART ZU ÜBERNEHMEN, EINSCHLIESSLICH, JEDOCH NICHT DARAUF BESCHRÄNKT, DIE MARKTFÄHIGKEIT UND DIE EIGNUNG FÜR EINEN BESTIMMTEN ZWECK ZU GARANTIEREN. SIE TRAGEN DAS GESAMTE RISIKO BEZÜGLICH DER QUALITÄT UND LEISTUNGSFÄHIGKEIT DER BIBLIOTHEK. WENN SICH DIE BIBLIOTHEK ALS FEHLERHAFT HERAUSSTELLT, ÜBERNEHMEN SIE ALLE KOSTEN FÜR NOTWENDIGE SERVICEARBEITEN, REPARATUREN ODER KORREKTURMASSNAHMEN.
  • 16. DER COPYRIGHT-EIGENTÜMER ODER EINE ANDERE PARTEI, DIE DIE BIBLIOTHEK WIE OBEN BESCHRIEBEN ÄNDERN UND/ODER VERTEILEN, WERDEN IN KEINEM FALL, AUSSER WENN ES DAS ANWENDBARE RECHT ERFORDERT ODER WENN EINE SCHRIFTLICHE VEREINBARUNG VORLIEGT, IHNEN GEGENÜBER KEINE HAFTUNG FÜR SCHÄDEN ÜBERNEHMEN, EINSCHLIESSLICH ALLER ALLGEMEINEN, SPEZIELLEN, ZUFÄLLIGEN ODER FOLGESCHÄDEN, DIE AUS DER VERWENDUNG ODER DER UNMÖGLICHKEIT DER VERWENDUNG DER BIBLIOTHEK ENTSTANDEN SIND (EINSCHLIESSLICH ABER NICHT BESCHRÄNKT AUF DEN DATENVERLUST ODER DER NICHT KORREKTEN WIEDERGABE VON DATEN ODER VERLUSTEN FÜR SIE ODER DRITTE ODER DER INKOMPATIBILITÄT DER SOFTWARE MIT ANDEREN PROGRAMMEN), AUCH WENN DER EIGENTÜMER ODER EINE ANDERE PARTEI AUF DIE MÖGLICHKEIT SOLCHER SCHÄDEN HINGEWIESEN WURDEN.
ENDE DER ALLGEMEINEN BEDINGUNGEN

Wie Sie diese Bestimmungen auf Ihre Bibliotheken anwenden

Wenn Sie eine neue Bibliothek entwickeln und Sie diese der Öffentlichkeit zur Verfügung stellen möchten, empfehlen wir, sie als freie Software, die jeder weiter verbreiten und ändern kann, bereitzustellen. Sie können die Weiterverbreitung gemäß diesen Bestimmungen (oder alternativ, gemäß den Bestimmungen der klassischen General Public License) erlauben.

Hängen Sie zur Anwendung dieser Bestimmungen folgende Vermerke an der Bibliothek an. Die sicherste Lösung ist, sie zu Beginn einer jeden Quelldatei anzufügen, um äußerst effektiv den Ausschluss der Garantie und Haftung auszudrücken. Jede Datei sollte mindestens die „Copyright-Zeile“ und einen Verweis auf den vollständigen Vermerk enthalten.

    one line to give the library's name and an idea of what it does.
    Copyright (C) year name of author

    This library is free software; you can redistribute it and/or
    modify it under the terms of the GNU Lesser General Public
    License as published by the Free Software Foundation; either
    version 2.1 of the License, or (at your option) any later version.

    This library is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
    Lesser General Public License for more details.

    You should have received a copy of the GNU Lesser General Public
    License along with this library; if not, write to the Free Software
    Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA

Fügen Sie Ihre Kontaktdaten für elektronische und normale Post hinzu.

Sie sollten Ihren Arbeitgeber (wenn Sie als Programmierer arbeiten) oder Ihre Schule bitten, den „Copyright & Haftungsausschluss“ zu unterzeichnen. Hier ein Muster, ändern Sie bitte die Namen:
    Yoyodyne, Inc., hereby disclaims all copyright interest in
    the library 'Frob' (a library for tweaking knobs) written
    by James Random Hacker.

    signature of Ty Coon, 1 April 1990
    Ty Coon, President of Vice
Das ist alles!


Copyright

© 2016 Pitney Bowes Software Inc. Alle Rechte vorbehalten.

Dieses Dokument kann vertrauliche und eigentumsrechtlich geschützte Informationen enthalten, die Eigentum von Pitney Bowes Inc. bzw. seinen Tochter- und Beteiligungsgesellschaften sind.

Die Portrait Software, das Portrait Software-Logo und das Portrait-Zeichen der Portrait Software sind Warenzeichen der Portrait Software International Limited und dürfen in keiner Weise ohne die vorherige, ausdrückliche schriftliche Genehmigung von Portrait Software International Limited benutzt oder verwertet werden.

Warenzeichen

Die Namen von Firmen und Produkten, Marken, Logos und Zeichen, die hier genannt werden, sind möglicherweise Warenzeichen oder eingetragene Warenzeichen ihrer jeweiligen Eigentümer.

Portrait Software-Support

Sollten sie über den Inhalt dieser Dokumentation hinausgehende Hilfe benötigen, können sie in der Wissensbasis auf unserer Website http://support.portraitsoftware.com nachsehen und den Links zu ihrem Produkt folgen.

Sie können auch andere Portrait Miner-Dokumentationen herunterladen. Falls Sie keinen Benutzernamen und kein Kennwort haben oder sie diese vergessen haben sollten, kontaktieren Sie uns über einen der nachstehenden Kanäle.

Wenn sie Probleme bei der Nutzung, Installation oder Dokumentation von diesem Produkt feststellen, kontaktieren sie uns bitte auf einem der folgenden Wege:

E-Mail: support@portraitsoftware.com

Telefon

  • USA/Kanada 1-800-335-3860 (gebührenfrei)
  • Übrige Welt +44 800 840 0001

Bei einer Problemmeldung ist es hilfreich, wenn Sie uns Folgendes mitteilen können:

  • Der Name der Software-Anwendung
  • Die Umstände, unter denen das Problem auftrat
  • Welche Fehlermeldungen Sie gegebenenfalls gesehen haben
  • Die Version der von Ihnen benutzten Software

Pitney Bowes Software Inc.

February 23, 2016


Online Help