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1 Introduction
Encom Discover Mobile is a portable companion to Encom Discover for MapInfo 
Professional. It is a powerful Geographic Information System (GIS) and mapping 
application designed specifically to run on mobile Pocket PC (Pocket Personal 
Computer or PPC) devices, and is compatible with embedded Microsoft Windows 
Mobile 5 and 6.5 operating systems. Discover Mobile is built on Pitney Bowes 
Software’s MapX Mobile platform and provides support for native MapInfo 
Professional data. Such data can be transferred to and from the mobile device 
when linked to an external PC through the use of the Microsoft ActiveSync data 
exchange system or through Windows Mobile Device Center.

Encom Discover Mobile provides inbuilt support for GPS devices capable of 
supporting NMEA 0183 (National Marine Electronics Association) standard data 
transfer protocol. This enables you to perform data capture operations, sample 
logging, mapping and in-field navigation with real-time GPS information using 
virtually any connected GPS device.

With Discover Mobile your data goes wherever you do!

Discover Mobile also supports Trimble TSIP (Trimble Standard Interface 
Protocol) protocol, allowing connectivity with Trimble DGPS devices such as the 
Pro XRS and XT, with full support for Trimble Post-Processing capabilities.

For information on installing Discover Mobile, see:

• Hardware and Operating System Requirements

• Installing Discover Mobile

• Licensing Discover Mobile

• Transferring Data Between Devices

• Getting Help

For a quick introduction to starting and using Discover Mobile, see Getting 
Started.

Note Trimble protocol supported up to Trimble Pathfinder SDK to version 2.41.
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Hardware and Operating System Requirements

The Discover Mobile application is designed to run on mobile devices which use 
the Microsoft Windows Mobile 5 and 6 (including updates 6.1 and 6.5) edition 
operating systems.

For information on the recommended minimum hardware/software system 
specification, see:

• Pocket PC Device Requirements

• Desktop or Laptop PC Requirements

• Pocket PC to Desktop PC Communication Requirements

• Desktop Post-Processing Software Requirements

Pocket PC Device Requirements

Pocket PC device running Microsoft® Windows Mobile 5 or Windows Mobile 6. 
Minimum 64 Mb of RAM, with 28MB of free space on Main Memory.

Discover Mobile will not run on handheld devices which run Windows CE.NET, 
Windows CE 3.0-5.0, Windows HPC 2000 or handheld machines running earlier 
operating systems or processors.

Desktop or Laptop PC Requirements

PC with Pentium 4 series or later processor, with a minimum of 512 megabytes 
of RAM is recommended. Supported operating systems are:

• Windows 7 (32- or 64-bit)

• Windows XP Professional (32-bit, Service Pack 3)

Pocket PC to Desktop PC Communication Requirements

• On Windows XP, Microsoft ActiveSync version 4.5 or later

• On Windows 7, Windows Mobile Device Center 6.1 or later. 
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Desktop Post-Processing Software Requirements

Post-processing of field data collected using DGPS requires the following desktop 
software:

• MapInfo Professional 10.0 or later

• Encom Discover 2012 or later

• Trimble GPS Pathfinder Office 4.00 or later

Installing Discover Mobile

Installation of Discover Mobile is a three-step procedure:

1. Connect the mobile device to the desktop or laptop computer via 
ActiveSync or Windows Mobile Device Center. For more information, see 
PC Synchronisation.

2. On the desktop or laptop, run the Discover Mobile install program. For 
more information, see Software Installation. The install program installs 
software, documentation, and sample data on the PC and also installs 
Discover Mobile on the mobile device.

3. Register the software with the mobile device and install a licence file to 
activate the software. This licence file must be obtained from Pitney 
Bowes Software. For more information, see Licensing Discover Mobile.

Software Installation

Before you install the software:

• Make sure that the Pocket PC device (PPC) is connected to the laptop or 
desktop computer, and the PPC is turned on and has established a 
synchronization connection to the PC via Microsoft ActiveSync (Windows 
XP) or Windows Mobile Device Center (Windows 7).  For more 
information, see PC Synchronisation.

• Make sure that there is at least 28MB of free space in the PPC main 
memory. 

To install the Discover Mobile software on your PC and mobile device:

1. Download or copy the Discover Mobile installation file 
DiscoverMobile_3.7_Setup_WindowsMobile.exe onto the PC.
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2. On the PC, run the install program.

To run the program, locate the executable file with Windows Explorer, and 
then either double-click the file name, or right-click on the file name and 
select Open.

3. Follow the prompts, press Next to proceed to the next step, and, when 
complete, press Finish to install the software on the PC.

4. When the installation on the PC is complete, you will be asked to confirm 
installation of the software on the mobile device.

The software is now ready to be licensed (see Licensing Discover Mobile).

See also
...Hardware and Operating System Requirements
... Licensing Discover Mobile
... Transferring Data Between Devices

Reinstalling Discover Mobile on the PPC

When Discover Mobile is installed on the PC, the install file specific to the PPC 
device is copied to the C:\Program Files\Encom\Discover 
Mobile\Application Files\Windows Mobile (32-Bit) or C:\Program 
Files (x86)\Encom\Discover Mobile\Application Files\Windows 
Mobile (64-Bit) folder on the PC.

To reinstall the software on the PPC:

1. With the PPC synchronized to the PC, copy 
DiscoverMobile_Setup.CAB file from the Windows Mobile folder on 
the PC to the \My Documents folder on the PPC.

Note After Discover Mobile has been installed on the PC, it can be installed on a 
synchronised mobile device at any time by running Setup.exe, which is located 
under C:\Program Files\Encom\Discover Mobile\Application 
Files\Windows Mobile (32-Bit) or C:\Program Files 
(x86)\Encom\Discover Mobile\Application Files\Windows Mobile 
(64-Bit). Alternatively, rerun the install program on the PC.

Note If you intend to use the post-processing functionality of the Trimble TSIP 
protocol, you will need Discover 2012 or later installed, as well as Trimble GPS 
Pathfinder Office 4.00 or later.



1 Introduction 5

2. From the mobile device, tap the DiscoverMobile_Setup.CAB file to 
install Discover Mobile.

Licensing Discover Mobile

When you start Discover Mobile for the first time you will be prompted to licence 
the software. You will need to obtain a licence file from Pitney Bowes Software 
(PBS). You only need to license the software once on each installation.

To license the software:

The Discover Mobile licence screen is displayed.

Licence screen showing user and licence information

1. Check that the PPC system clock is correct. You can change the date and 
time by either tapping the date in the PPC desktop display, or by selecting 
Start>Settings>System>Clock.

2. On the PPC, start Discover Mobile by tapping Start and then Discover 
Mobile or select Start>Programs and tap the Discover Mobile icon.
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3. Complete the Name and Company fields, and then tap the Save button. 
The user information is saved to DiscMobileLicInfo.txt file in the \My 
Documents folder on the PPC.

Save the DiscMobileLicInfo.TXT file

4. From Windows Explorer on your PC, navigate to the \My Documents 
folder on the PPC and copy the DiscMobileLicInfo.txt file from the 
PPC to the PC.

5. Attach the DiscMobileLicInfo.txt file to an e-mail and send to 
natural.resources@pb.com.

6. By return email, you will receive a licence file from PBS with the filename 
extension of .LIC.

mailto:natural.resources@pb.com
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7. Copy the licence file to the \My Documents folder on the PPC and, if you 
are using a storage card, copy the same file to the storage card (e.g. 
\Disk\Discover Mobile). Storing a copy of the licence file on the 
storage card is recommended in case the main memory is wiped (e.g. 
because of a flat battery).

8. Start Discover Mobile by tapping Start>Discover Mobile or by tapping the 
Start>Programs>Discover Mobile icon. When Discover Mobile starts 
the licence dialog is displayed. 

9. Tap the Load button and select the licence file (e.g. 
DiscMobileLic.LIC). Tap Validate to activate the software. If the 
licence information is valid, the software will be activated and Discover 
Mobile is now ready for use.

Before you begin to use the software, backup the software and licence files to 
your storage card and PC. Remember to backup your work frequently.
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Reactivating the Licence

If the software is erased from the PPC, you must reinstall the Discover Mobile 
software and then reactivate the software licence. You can reuse your original 
licence file to activate Discover Mobile at any time providing you use the licence 
file on the same PPC device.

Keep a copy of the licence file on your PC or another form of storage media  (e.g. 
CF Flash card or Secure Digital card). 

Transferring Data Between Devices

Transferring data between your mobile device and your desktop computer is as 
simple as dragging and dropping files from one device to the other using Windows 
Explorer. All that is required to activate this functionality is to establish a 
connection between the two devices using Microsoft ActiveSync or Windows 
Mobile Device Center (see PC Synchronisation).

These synchronisation applications can provide communication between the 
mobile device and a desktop or laptop computer via a serial, universal serial bus 
(USB)  or ethernet connection. USB connections are the most common and are 
significantly faster than serial connections for data transfer. It is possible to use 
ethernet or a wireless LAN connection to transfer files between your mobile 
device and a host computer. However, you cannot use an ethernet or wireless 
LAN connection to remotely install software or to perform file synchronisation. 
Please refer to your mobile device documentation for details on how to establish 
a local area network connection.

When a mobile device is connected to your desktop computer, it will be 
automatically listed in the file system tree in Windows Explorer as a Mobile Device 
(Windows XP) or as a named computer (Windows 7). You can copy, paste, drag 
and drop files to and from your local computer to the mobile device, just as you 
would with any folder using Windows Explorer. It is good practice to store data 
files on a removable storage card, such as a Compact Flash (CF) or Secure 
Digital (SD) card, instead of the main RAM memory of the PPC. This will ensure 
that you do not loose any data in the event of a power failure. It also frees up on-
board memory for the PPC operating system.

Warning If your PPC device loses all power due to a flat battery, all information stored in 
the main memory will be lost. This includes all installed programs and data you 
have added to the device since receiving it from the factory.

You should also keep a copy of the installation .CAB file on the storage card so 
that you can reinstall the software in the field (see Reinstalling Discover Mobile 
on the PPC).
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PC Synchronisation

Microsoft ActiveSync (Windows XP) and Windows Mobile Device Center 
(Windows 7) are synchronisation applications supplied by Microsoft for Microsoft 
Windows® powered Pocket PCs, allowing file transfer between PCs and mobile 
devices.

ActiveSync and Windows Mobile Device Center software provide all file services 
to synchronise or backup data and install software on the PPC. Please refer to 
your PPC user guide for information on how to establish a connection between 
your mobile device and desktop computer.

See also
...Pocket PC to Desktop PC Communication Requirements

Microsoft ActiveSync

ActiveSync is used for transferring data between your PC and mobile device if 
your PC is running Windows XP. ActiveSync may be pre-installed on the mobile 
device but you will need to install the application software on your PC computer. 
If you do not have an ActiveSync installation CD-ROM you can download the 
software for free from a Microsoft Download website. Refer to the Microsoft 
ActiveSync User Guide for instructions on installing ActiveSync software.

Microsoft ActiveSync comes pre-installed in ROM on all mobile devices but needs 
to be installed on the host computer using the accompanying software installation 
CD shipped with the mobile device.  If you do not have an installation CD you can 
download or update to the latest version of ActiveSync freely from the Microsoft 
download centre web page. Windows Mobile Device Center should be pre-
installed with the Windows 7 operating system, if not it can be downloaded from 
a Microsoft Download website.

See also
...PC Synchronisation
...Pocket PC to Desktop PC Communication Requirements

Windows Mobile Device Center

Windows Mobile Device Center is used for transferring data between your PC and 
mobile device if your PC is running Windows 7 operating system. Windows 
Mobile Device Center should be pre-installed with Windows 7 operating system, 
if not it can be downloaded from a Microsoft Download website. Refer to the 
Windows Mobile Device Center documentation for instructions on installing the 
software.
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See also
...PC Synchronisation
...Pocket PC to Desktop PC Communication Requirements

Getting Help

The Discover Mobile User Guide is installed on the desktop PC, under 
C:\Program Files\Encom\Discover Mobile\Documentation. (32-bit) or 
C:\Program Files (x86)\Encom\Discover Mobile\Documentation. (64-
bit)

Help for the Discover Mobile mobile tools on both the mobile device (PPC) and 
the desktop can be accessed from the DiscoverMobile>Help menu.

Contacting PBS

You can obtain product support for Encom Discover by e-mail or telephone, or 
from your PBS reseller.

Contact details are:

E-mail pbbi.support@pb.com

Web www.pbencom.com

Telephone +61 2 9437 6255

mailto:pbbi.support@pb.com
http://www.pbencom.com
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2 Best Practice with a Portable PC
In this section:

• Running Programs and Memory

• Power and Battery Use

• Data Storage

Running Programs and Memory

Check the task manager on the Pocket PC (PPC) periodically to make sure that 
a large number of programs are not currently running. For example, if the close 
button (the X at the top-right of the screen) is used to close Discover Mobile the 
program is only removed from the screen but remains in memory. To exit 
properly, the GO>Exit menu should be selected. If there are many programs 
running in the background the Pocket PC battery will be quickly used up.

Power and Battery Use

Choose a topic:

• Bluetooth Manager

• Charging

• External Batteries

• In-Vehicle Recharging

Bluetooth Manager

If you are using a Bluetooth wireless GPS make sure to turn off the Bluetooth 
radio when it is not in use. This can be carried out using the Bluetooth Manager.

Charging

Before venturing into the field, make sure the Pocket PC is fully charged. Make 
sure the device is connected to the Universal Desktop cradle or AC Adaptor when 
not in the field. If the device fails to turn on as a result of extended use, the Pocket 
PC will need to be fully charged and a normal reset performed before the charge 
indicator light will flash again.



12 Encom Discover Mobile User Guide

External Batteries 

Invest in at least one external battery to extend the life of the Pocket PC between 
charging. The external battery or expansion pack is removable and rechargeable 
and can also be used to run PC, CF or SD cards depending on the type of 
expansion pack. Charging takes place when the Pocket PC is in the Desktop 
cradle or on the optional battery charger. For extended periods of field work it is 
worth investing in more than one external battery so one can be charging while 
the other is in use.

Alternatively, a portable 12-volt battery may be purchased relatively inexpensively 
which will provide a continuous power source to the Pocket PC in the field 
although the battery must be carried at all times.

If using external batteries with a PC device, make sure the batteries are 
connected properly and fully charged. If the batteries go completely flat and will 
not turn on, connect them to a power source and leave for 5 minutes. While 
connected to the power source perform a soft reset and hold down power key to 
turn the device back on.

In-Vehicle Recharging

Invest in an auto adapter to use the Pocket PC while travelling or to charge in 
between field usage. Do the same for Bluetooth GPS units.

Data Storage

Choose a topic:

• Keep Data on External Storage Card

• Set Storage Card Directory Paths

• Backup Your Installation of Discover Mobile

Keep Data on External Storage Card

Apart from expanding the storage capacity on the Pocket PC, any data stored on 
a storage card does not depend on power from the device. Therefore any data 
recorded on the storage card will not be lost if the battery becomes completely 
flat. Copying some programs to the storage card can free up memory space on 
the Pocket PC.

The types of data you should keep on the storage card include:
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• All map data (e.g., topographical, geological data, images, etc.)

• Discover Mobile licence file

• GPS point and line logs

• Named styles files

• Pick list files

• Hotlink files

• Track logs

• New tables

• Image files

• A backup copy of the Discover Mobile installation file 
DiscoverMobile_Setup.CAB

Set Storage Card Directory Paths

By default the file paths in Discover Mobile are set to the My Documents directory 
in the Main Memory of the Pocket PC device not the storage card. These paths 
should be altered before going out to the field. To modify a directory path:

1. Select GO>Preferences menu and scroll to Directories.

2. Enter the appropriate root project directory location on the storage card for 
saving each of the project’s tables, GPS track log files, pick list files, 
named styles files, hotlink files, new tables, and image files.

See Directories for further information.

Backup Your Installation of Discover Mobile 

It is also recommended to keep a copy of the Discover Mobile installation file on 
the storage card. 

Note The directory structure on a storage card is limited to one level only and file 
names cannot be longer than 21 characters in length.
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• Copy the DiscoverMobile_Setup.CAB file from the PC Discover Mobile 
installation directory onto the storage card. Use this file to re-install the 
software (see Reinstalling Discover Mobile on the PPC).

• Additionally, keeping the Discover Mobile licence file on the storage card 
will ensure that the application can be activated if re-installation is 
required.
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3 Data Preparation
When preparing your data for field use with Discover Mobile it is important that 
you give careful consideration to optimising the structure and size and coverage 
of the data tables so that you obtain maximum performance on the PPC device. 
Although PPCs are extremely well featured and perform exceptionally well on 
most tasks they do not possess anywhere near the computing power (memory or 
the processor capacity) of the average desktop computer. It is therefore important 
that you keep this in mind when preparing your data for use in Discover Mobile.

When preparing data for the field, review the topics under Supported File Types 
and Table Size Limits and Things You Can Do to Improve Performance.

A selection of Desktop Tools are available to assist with the preparation of data 
on the desktop.

Supported File Types and Table Size Limits

Discover Mobile cannot access non-native MapInfo Professional tables such as 
Excel (.XLS, .XLSX), Text (.TXT) or MS Access (.MDB, .ACCDB). These tables 
should be converted to native MapInfo Professional tables using the File>Save 
Copy As command in MapInfo Professional prior to use. In general, vector tables 
with less than 2000 objects will give acceptable performance.

Raster Images

Discover Mobile can access raster data stored in .BMP, .TIFF, .JPG, .GIF or 
.ECW file format providing the images have an associated .TAB file (i.e. they have 
been opened in MapInfo Professional prior to being displayed in Discover 
Mobile). Discover Mobile cannot open raster images directly apart from those 
saved in GeoTIFF format. Ideally raster images should be kept below a couple of 
MB in size. It is also more efficient to produce a single low-resolution image for 
regional navigation and switch to smaller, high-resolution images for each project 
area.

Note Discover Mobile does not support Time or Date/Time fields.

Note Grid image formats, such as DEM or Topographic data, are not supported and 
must be converted to a raster image.
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ECW Files

Discover Mobile supports raster images in the ER Mapper .ECW format provided 
they have already been associated with a MapInfo Professional .TAB file. The 
MapInfo Professional .TAB file must point directly to the .ECW image file as 
Discover Mobile cannot open .ECW files directly. 

Raster images in .ECW format will give the best performance in Discover Mobile 
due to the lossless compression algorithms used.

ECW images typically have a compression of at least 10% of the file size. It is 
recommend to use only ECW files up to 20MB in file size.

Things You Can Do to Improve Performance

The following suggestions will improve the performance of Discover Mobile and 
assist with management of your data:

• Supported File Types and Table Size Limits

• Subsetting Datasets to the Project Area

• Convert Tables to Same Projection

• Set Table Default View

• Save Data as Geoset File

• Set Zoom Layering for Large Raster Images

• Pack Tables

• Create Data Entry Pick Lists

• Create Named Styles

Note To import an ECW into MapInfo Professional, navigate to Discover>Import and 
Export>ALG\ECW\JP2000 Import.



3 Data Preparation 17

Subsetting Datasets to the Project Area

In theory, Discover Mobile can display as much data as there is available memory 
on the PPC. However this is not realistic in practice. For the best map redraw 
performance you are encouraged to keep your datasets as small as practical for 
your intended Discover Mobile session. It is recommended to use subsets of data 
for each project area. There are three main methods that may be used to subset 
data:

• Use the Discover Clip to Polygon Tool tool to subset selected vector data 
layers to a defined region

• Use the Discover Mobile Save to Registered Raster Tool tool to capture a 
map window view, including gridded surfaces, to display as a backdrop

• Use the Discover Clip Image tool to crop an image registered in MapInfo 
Professional to a defined region.

Clip to Polygon Tool

The Clip to Polygon tool enables any number of vector (points, lines or region) 
layers to be clipped to a defined region. The data layers may be clipped to a 
tenement boundary, a map sheet boundary or simply a freehand region created 
over a project area or area of interest. 

1. Open data tables to clip into map window in MapInfo Professional.

2. Select a map object polygon/region to use as the clipping boundary. This 
object may be part of an existing table or digitised into the cosmetic layer. 

3. Choose Discover>Object Editing>Clip to Polygon.

Note Clip to Polygon does not clip objects contained in the Cosmetic layer. You 
cannot undo a Clip to Polygon operation, and for this reason we recommend that 
you operate on a copy of the original data. The Clip to Polygon tool does not 
work with raster images or thematic map layers.
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Selected region clipping boundary and Clip Layers Dialog 

4. Choose to clip outside or inside the selected polygon boundary.

5. All tables by default are selected for clipping and new tables will be 
created for the clipped layers with a “_CLIP” extension.

6. Select a folder to save the new clipped data tables and click OK.

7. The clipped tables are automatically opened into the current map window.
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Resulting clipped layers opened in new map window

Save to Registered Raster Tool

The Clip to Polygon tool only works with creating data subsets for vector data. 
The Save to Registered Raster tool will create a registered image of the visible 
contents of any map window to the extent of that map windows view. It is therefore 
an excellent way to convert multiple layers/datasets in a map window into a single 
image (eg. topographical data) or convert a vector geology map into an image so 
it can be overlain on a magnetic or gravity image with a set transparency. It can 
also be used to convert and crop gridded data (e.g. a geophysical or geochemical 
grid) into an image to be used in Discover Mobile. 

The tool also supports ECW compression and adjustable detail size, making it an 
excellent tool to clip and compress existing registered raster images opened in 
MapInfo Professional map window.
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It is opened via the DiscoverMobile>Save Registered Raster menu. See Save 
Registered Raster for more information on using this tool.

Clip Image

The Clip Image tool allows multiple, large registered images to be clipped down 
to a region more appropriate for use within Discover Mobile (e.g. clipping a 
regional air photo down to the extent of a prospect). It is recommended that if 
working over a large images area, clip the image to a series of smaller work areas, 
and then open and close these as appropriate within Discover Mobile (therefore 
decreasing memory usage and increasing display redraw speeds.

1. Open the registered source image into a MapInfo Professional map 
window.

2. In the same mapper, create a polygon region to clip the image. This can 
be a polygon drawn into the cosmetic layer and selected.  Alternatively a 
table containing a single table could be used (such as a tenement 
boundary); if the table contains multiple polygons, select the polygon (e.g. 
tenement) of interest.

3. Open the Discover>Images menu, and select Clip Image. Ensure that 
the correct image is selected in the pull-down list at the top of the dialog. 
Enable the Clip Outside Polygon option, and set the Table to clip 
against as either *Selection* or the polygon table name.

4. Press OK. A new cropped image will be created, named after the source 
image file with a ‘_clipped’ suffix. 

Note It is much better using a raster image as a background map instead of displaying 
the original vector layers. This is because there is only one layer to redraw and 
may be up to 1000 times faster than re-drawing large vector datasets. The vector 
data can always be loaded temporarily if attribute data needs to be queried; i.e. 
view assay results for selected samples or drillhole collar information.



3 Data Preparation 21

Convert Tables to Same Projection

Like MapInfo Professional, Discover Mobile can display multiple tables with 
different map projections in a single map window. While this feature can be very 
useful it does come at some performance cost. In order to display map objects 
with different projections in the same map window Discover Mobile must perform 
“on-the-fly” coordinate transformations. This requires significant processor 
performance and can slow down a map redraw by up to 100%. To ensure the best 
map redraw performance make sure that all your map tables share a common 
projection. 

To convert a number of vector tables to the same projection:

1. In MapInfo Professional, select Discover>Table Utilities>Multi-Table 
Reproject.

2. Check the box next to the tables to re-project or choose Select All.

3. Press New Projection and select a projection from the pull-down lists.

4. Choose to Overwrite existing tables or Create new tables.

5. Type a directory location.

6. Choose to annotate new tables with name suffix.

7. Click OK to create the newly projected tables.
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To reproject an image into a new projection:

(Preferably the same projection as the vector data.)

1. Ensure the registered image is open within MapInfo Professional.

2. Open Discover>Images menu, and select Reproject Image.

3. Ensure that the correct source image is selected in the top pull-down list.

4. Use the Browse button to set the New projection.

5. Browse for an output directory location and specify a new image name.

6. Click OK to create the new reprojected image.

Set Table Default View

You can improve the speed at which Discover Mobile opens and displays your 
data by changing the default table view. 

1. Open a table into a map window in MapInfo Professional.

2. Set the required map centre and zoom level for the table in the map 
window.

3. Select Discover>Map Window>Set Default Table View.

4. Choose the table from the pull-down list.

5. Click OK to save the default table view.
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Save Data as Geoset File

A Geoset file is similar to the MapInfo Professional Workspace (.WOR) file. 
Discover Mobile uses a Geoset (.GST) to record information about the current 
map window zoom level, the list of open layers, whether zoom layering or style 
override has been set for a particular layer etc. Discover Mobile cannot open a 
MapInfo Professional Workspace file. 

1. Open required tables into a map window in MapInfo Professional

2. Set the map window zoom level so that it is quite small and turn on zoom 
layering function (via the Layer control dialog) for any layers which contain 
a lot of data or for large raster images. 

3. Select Tools>Tool Manager and load the MapX Geoset utility.

4. Select Tools>MapX Geoset Utility>Save MapX Geoset As and type a 
name and location for the new Geoset.

5. Copy the data tables and geoset file to Discover Mobile.

Save Geoset in Discover Mobile

Saving the current work session within Discover Mobile as a Geoset allows a 
rapid restoration of the session the next time the application is opened. See 
Saving and Restoring Your Workspace for further information.

Set Zoom Layering for Large Raster Images

Turning off the display of complex or detailed map layers when you zoom out and 
move around the map window will significantly improve map redraw speed and 
remove unnecessary detail from the map display at larger zoom levels. This can 
be applied using the zoom layering function within Discover Mobile. See Layer 
and Object Visibility for more information on this topic.

Note A geoset saves information about a single map window only not a multi-window 
environment like a workspace. All the tables referenced in a geoset must be 
located in the same directory as the geoset file in Discover Mobile. Map labels 
are not saved as part of a geoset.
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Pack Tables

Although map objects or records appear as though they have been removed from 
a MapInfo Professional table when they have been deleted, the storage space 
they occupied is not removed until a table is packed. This tool is especially useful 
for tables created from external databases and must be done prior to copying 
tables to the Pocket PC device.

1. Select Discover>Table Utilities>Multi-Pack.

2. Choose the tables to pack from the list available command to pack 
multiple tables at the same time.

3. Pack both graphical and tabular data. 

4. Click OK

Create Data Entry Pick Lists

The use of Pick Lists (e.g. look-up tables of predefined rock or sample codes) 
within Discover Mobile can greatly increase the efficiency and speed of data 
entry, and minimize data entry errors. See Picklist Editor for more information on 
creating and using pick lists.
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Create Named Styles

The ability to apply an existing style to a new object can greatly simplify the 
display window in Discover Mobile, particularly when dealing with large numbers 
of the same object type (eg points) with differing attributes (eg rock-chips, soil and 
lag samples). Creating and applying Named Styles to objects allows graphical 
differentiation, minimizing duplication of sampling. See Name Style Editor for 
more information.

Named Styles can also be configured so that each style is automatically placed 
into pre-linked table, with style (rather than table) specific Quick Pick options.

Desktop Tools

Included with Discover Mobile are a number of desktop tools to be used in 
conjunction with MapInfo Professional. These can auto-load with Discover, 
otherwise they can be accessed by navigating to Tools>Run MapBasic 
Program and browse to the following folder:

C:\Program Files\Encom\Discover Mobile (32-bit) or 
C:\Program Files (x86)\Encom\Discover Mobile (64-bit)

Select the file DiscMobile.MBX and click Open. A new menu item called 
Discover Mobile should then appear on the MapInfo Professional menu bar.

You can add this tool to the Tools>Tool Manager to set it to permanently auto-
load when MapInfo Professional is opened.

The tools available from this menu are:

• DiscoverMobile Manager

• Convert Hotlinks

• Name Style Editor

• Range Style Editor

• Picklist Editor

• Table Merge

• Save Registered Raster

For information on the steps involved in preparing and transferring data from the 
desktop to the mobile device, see Discover Mobile Workflow.
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Discover Mobile Workflow

When transferring data to and from a mobile device and modifying the data over 
a number of sessions, it is important that you follow a good workflow procedure 
to ensure data is efficiently updated and prepared for use in Discover Mobile.

When you are preparing your data on the desktop, you should collect all the 
relevant files and place them in your Project Directory (set in the Discover Mobile 
DiscoverMobile Manager tool), in the \Encom_DM_Tables directory.

Similarly once you have retrieved data from the device via the tool, the modified 
and new Discover Mobile data tables will be in the Encom_DM_Tables_WM 
directory which will need to be manually updated to the \Encom_DM_Tables 
copy.
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DiscoverMobile Manager

The first step in using the desktop tools is to specify a directory to store and copy 
data for Tables, Picklists, Name Styles, Image Files, and Hotlink Files. The 
specified directory will be used by the Style Editor, Picklist Editor, Range Style 
Editor, and Table Merge tools. Navigate to DiscoverMobile>DiscoverMobile 
Manager and browse to a folder on your local disk or network drive where the 
mobile data is located, e.g. C:\ProgramData\Encom\Discover Mobile Data.

You can then do the following (see Discover Mobile Workflow):

• Specify Data to Transfer

• Preparing Tables for Mobile Device

• Transferring Data

• Updating with New Device Data

• Connection Status
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Specify Data to Transfer

Specify the data types which are to be copied to and from the mobile device. 
Uncheck any data types which are not required to be copied.

The options include:

• Tables 

• Picklists

• NameStyles

• Images

• Hotlinks

When a directory has been specified a series of folders are created in the root 
directory where the data resides, these are called:

Encom_DM_Tables_WM

Encom_DM_Picklists

Encom_DM_Namestyles

Encom_DM_Images

Encom_DM_Hotlinks

Preparing Tables for Mobile Device

Make sure any tables or files you have prepared for use on the mobile device are 
placed in the Project Directory root folder.

Before transferring your data to the device, click on the Enable Table Marge 
button. This will perform a check on all tables in that project directory that will be 
copied to the device.

Note To specify the directories on the mobile device where the data is to be copied, 
navigate to GO>Preferences>Directories. By default these will be set to \My 
Documents, it is advisable to re-path this to a removable disk in case of a crash 
or hard reset which will delete these files.
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Any tables which are fund not compatible for use with the Table Merge, to preview 
and merge modifications back to the desktop tables, will be listed and you should 
select any tables which you are going to modify on the device. Click OK and they 
will be updated to be compatible with the Table Merge tool.

Transferring Data

Transferring data to and from the computer and mobile device is a matter of 
selecting the appropriate method of transfer.

Updating with New Device Data

When you transfer from device to the PC all the tables from the Device project 
directory will be placed in Encom_DM_Tables_WM. Other files—picklists, 
namedstyles, images, and hotlinks folders—will all be placed in the same 
directory overwriting the existing copies, updating them with any modification to 
these performed in Discover Mobile.

With the Tables directory, however, you will then need to update your original 
tables in the project root directory, with the data either with the Table Merge tool 
or a manual update with a file copy and over-write.

Connection Status

The status of the connection from the PC to mobile device to displayed at the 
bottom of the dialog. Data can only be transferred when the PC and mobile device 
are correctly connected.

To transfer data from the local or network disk, click the Copy data from PC to 
device button.

To transfer data from the mobile device click the Copy data from device to PC 
button.

Note Make sure to update your original table once you have retrieved the device data. 
Failure to do so may result in data loss as device and desktop data is overwritten 
during the transfer.
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Convert Hotlinks

Discover Mobile and MapInfo Professional both support hotlinks from a Tables 
fields to documents and resources stored on the computer.  When moving a Table 
from Discover Mobile back to the desktop MapInfo Professional the hotlink file 
paths can be edited to convert the folder locations of the linked files.

To convert hotlinks in a table:

1. Copy the .TAB file and linked files to the preferred location on your 
desktop computer.

2. From the DiscoverMobile menu select the Convert Hotlinks item. In the 
Discover Mobile Hotlink Converter dialog select the table which contains 
the hotlinks you wish to remap and then in the fields to check list box 
select the column which contains the link path.

3. Under Options, check the box Change link directory path to: and enter 
the file path or browse to the location of your hotlink files.

4. If you have linked Pocket Word or Excel files then leave the Convert 
extensions options ticked and click OK to complete the re-link function.

Name Style Editor

The Name Style Editor facilities the creation and management of Named Styles 
for Discover Mobile from a desktop interface. Named Styles enable the user to 
create a style library for point, line and region objects. Named styles allow the 
textural capture of data to be attributed to user defined object styles, this enables 
streamlined data capture and validation.

Named Styles can be directly created in Discover Mobile; however, the Desktop 
interface provides a more functional user interface.

The directory of the Named Styles is specified by the DiscoverMobile Manager 
tool. Alternatively, the directory can be manually redirected from the Output 
option.

To activate the new hotlinks in MapInfo Professional go to the MapInfo 
Professional Layer control and select the layer which contains the hotlinks. Click 
the HotLink button. Select the field which contains the file path and check the 
appropriate options from the bottom of the dialog. Click OK to finish the setup 
process. To activate a Hotlink, click on the lightning bolt icon   and then click on 
the object to bring up the linked file
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Mobile Style Editor dialog

Create Named Style

Named Styles can be created from one of two methods, from an existing style 
library or from a blank template.

To create a new Named Style select either Point, Line or Region object type from 
the Mobile Style Editor dialog. Alternately, styles can be created for all map object 
types.

To create a series of Named Styles, type the attribute into the Description text 
box and define the Style, Foreground and Background definitions.

Note Any tables, fields and fonts referenced by the Style library must be opened in 
Mapinfo Professional prior to opening the library.

To create a Named Style from an existing file, click the Open existing style 
library button and select either an existing Named Style (*.TXT). The text file will 
need to conform to a particular structure, based on a previously created Named 
Style.
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To create a new style definition click the New Style button, this will insert a new 
record for style definition.

To delete a style definition, highlight the designated field and click the Delete 
Style button.

 

To reorder the current Named Style, highlight the designated field and use either 
the Move Up or Move Down button.

Note To save a Description to the table when a style is applied, an auto-pick field can 
be set for the Table and Field. See Linking a Style to Tables and Setting Auto-
fields .
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Regions Named Style definition

Linking a Style to Tables and Setting Auto-fields

Optionally, a specific table can be selected for each style to link to. The table you 
wish to link to has to be currently opened in MapInfo Professional to appear in the 
selectable list.

Setting this allows styles to be applied to the specified table when using a Named 
Style for a new object within DiscoverMobile.

In addition, Auto-fields can be set for the table by clicking the adjacent button next 
to the linked table name. This allows GPS derived fields to be set, which are also 
available within a picklist.
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This is a powerful method to apply auto-field picklists to populate a table attribute 
based on the Named Style selected for the object.  For example, you could use 
the Set Constant Value to assign one attribute field with the same name as the 
Named Styles – such that one you select “Granite” named style for the table, the 
Rock_Type field would be automatically populated with “Granite”.  You also could 
do other conditional auto-fields, such as set a field to “Object Area” for Region 
Styles, but not set this for Point Styles.

Saving Named Style

When all the correct Named Styles have been defined browse to the correct 
Output Style Library directory and click OK to save.

Range Style Editor

The Range Style Editor allows the creation and editing of Range Styles for 
Discover mobile from the desktop interface. This functionality is similar to the 
Point Classification tool in Discover's Geochem module. Range Styles allows the 
user to auto-classify the XRF data points in real time, or apply the point style 
permanently to any point data table opened in Discover Mobile. 

For example, you could collect a series of data point measurements, and as an 
alternative to thematically mapping them, you could apply a pre-created Range 
Style for custom From-To ranges of the data. This is applied and saved in the 
table.

Note Not setting the Optional columns (Capture Table and Auto-Field options) 
means that the set styles are non-table specific; they will simply be captured to 
the current insertion layer in Discover Mobile, regardless of object type. The only 
Auto-Field options that will be applied are those that have been set to the table 
itself using the Picklist Editor. 



3 Data Preparation 35

Range Style Editor

Create Range Style

Range Styles can be created from one of two methods: from an existing range 
style library or from a blank template.

To create a series of Range Styles, type the lower bound into the >= column, and 
the upper bound for the range into the < column.

The values can either be absolute numbers. Alternatively tick to Range Values 
are percentile option, and the range value will then be percentiles, and must be 
between 0-100 percentile. Note that percentile differ from percentage, and 
percentile reflect the number of observations that fall within the range. For 
example, if you have 10 range and 10 sample points, there will be one point in 
each percentile range, regardless of the measured data values and data range.

Left click in each of the other columns to define the Font file, Point symbol Style, 
colour and symbol size.
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Picklist Editor

The Pick Editor facilitates the creation and management of Picklists for Discover 
Mobile from a desktop interface. Picklists are fully customisable validation lists 
used when digitising and attributing objects in Discover Mobile. Picklists 
streamline the repetitive data entry tasks and ensure consistent valid data entry. 
Traditionally Picklist can be created directly in Discover Mobile or from a text 
editor interface (see Picklists section in Attributing Field Data chapter), the Picklist 
Editor provides a more functional user interface.

The Picklist Editor tool is separated into two sections:

• The Table Options controls the creation of tables and selection of table 
for creating Picklists from, as well as renaming tables and Picklists. The 
directory of the Picklists and new tables are specified by the Data 
Manager tool.

• The Table Fields allows the customisation of table structures and also the 
defining of Picklists.

To create a Range Style from an existing file, click the Open existing range style 
and an existing Named Style (*.styles). The text file will need to conform to a 
particular structure; based on a previously created Named Style.

To create a new style definition click the New Style button, this will insert a new 
record for style definition.

To delete a style definition, highlight the designated field and click the Delete 
Style button.

To reorder the current Named Style, highlight the designated field and use either 
the Move Up or Move Down button.

Note To edit an existing picklist file, you need to set the current Working directory to 
the appropriate folder containing the picklists, and open the associated Tables. 
Select the corresponding table and you will then be bale to edit the picklists.
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Table and Picklist Manager dialog

Create Table

The first step in creating a Picklist is to either have an existing MapInfo 
Professional table for which the Picklist will be utilised or to create MapInfo 
Professional table.

If you select an existing open table from the drop down list, it will be automatically 
copied to the DiscoverMobile working directory, and a prompt displayed to enter 
the name for the DiscoverMobile copy. The original table will be closed.

To create a table click the Create button and type in a Table Name into the New 
Table dialog, specify a projection for the new table, and click OK. This will create 
a table with two fields called ID (Integer) and Modified (Logical). 
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If desired the structure of another MapInfo Professional table can be duplicated 
by selecting the table from the Clone from dropdown.

Modify Table Structure

Numerous controls are provided to modify the structure of a MapInfo Professional 
Table; reordering, adding fields, changing field types, field widths and field name.

Note If a table contains unsupported fields types for Discover Mobile such as Time 
and Date/Time a warning message will appear and omit these fields in the 
DiscoverMobile Table directory copy.

 

To reorder the current table field highlight the designated field and use either the 
Move Up or Move Down button.

To add another field into the table structure click the Add button and specify the 
field name, type and width (if required).

If GPS derived data needs to be recorded the special fields button allows the 
addition of fields which will be automatically populated which the respective data 
type. Examples of this include Map_X, Map_Y, Fix_Quality and FixNumSat.

To delete a table field highlight the designated field and click the Delete button.
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Picklist Field Types

New table definition with special fields

New indicates no Picklist has been defined for this field table.

A tick indicates this filed is a special field which will be automatically populated 
from the mobile GPS data.

Edit indicates a Picklist has been defined for this field table.
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Create Picklist

Once all of the table fields have been defined Picklists can be created for the 
allocated fields. 

Several controls are available to create Picklists these include adding Picklist 
items, reordering and importing.

To create a Picklist click on the New button next to the field you wish to create 
the Picklist.

 

To reorder the current Picklist highlight the designated item and use either the 
Move Up or Move Down button.

To add another item into the Picklist click the Add button and specify the item 
name.

If GPS derived data needs to be recorded the special fields button allows the 
addition of items which will be automatically populated which the respective data 
type. Examples of this include Map_X, Map_Y, Fix_Quality and FixNumSat.

Picklist item can be further subdivided into Categories, these allow a Picklist item 
to have sub-items. An example of this would be a rock type Picklist, within the 
Picklist a category may be called volcanic, this category may contain items such 
as tuff, rhyolite, basalt etc.

If a validation or value list is available in either *.CSV or *.TXT format the Picklist 
importer can import and automatically create a Picklist.

Picklist items can be deleted by clicking the Delete button.
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Example Picklist with associated Category

Editing a Category

To edit the contents in a category, click on the Edit button in the category column 
of the picklist editor. Further Sub-Categories can be added within each category.

Assign Default Picklist Value

Default Picklist behaviour can be controlled by numerous options on the dialog.

If only one item exists you can enforce this value to be the default by either 
checking the Default check box next to the item or check the box next to the 
Automatically set all single item assignments as default behaviour.

Note If only one default Special Items GPS auto-field is set in a pick list, it is identical 
to adding a Special Field to the table structure.
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If several Picklist items are present the default value can be assigned by checking 
the Default check box next to the item.

Make Picklist Read-Only

To ensure the integrity of the Picklist check the box next to This list is not 
editable on mobile device option.

Picklist Format

The pick list file name must conform to one of the following formats:

• TableName_FieldName.txt – this naming convention means that the 
pick list file will only be available for the field name in the specified table 
name. For example, if your table is called Geology and the field you want 
to use the pick list with is called Lithology, then you would give the pick list 
the name Geology_Lithology.txt. This is the default convention for 
pick list files which are automatically created in Discover Mobile.

• FieldName.txt – this naming convention means that the pick list file will 
be available for all tables which contain the specified field name. For 
example if you call your pick list Comments.txt then that pick list will be 
available for all tables which contain a field called Comments. This Picklist 
convention is referred to as a global Picklist.

To create a global Picklist check the box next to the option Make this picklist as a 
FieldName-only picklist. It will be available globally for any table with the matching 
field name..

Rename Picklist and Table

Saving Table and Picklists

When all the table fields have been defined and Picklists created click the Save 
button. You will be prompted to add an ID and Modified field, if they do not exist 
in the table, which are required for Discover Mobile and the ID will be populated 
with the row number.  

Note A Category or a Category’s contents cannot be set to a default.

To rename a MapInfo Professional Table and associated Picklists click the 
Rename button.
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Table Merge

The Table Merge tool enables modifications performed on a copy of a MapInfo 
Professional table on a single Discover Mobile device to be updated into the un-
changed original copy residing on a local disk.  

The advantage of this tool over a file overwrite, is it allows a user to select only 
certain modifications and preview any changes before the original table is 
updated with the changes.

The most useful application of this tool is for when a table is modified on a 
Discover Mobile device in a number of periods.  After each period, the user can 
retrieve and analyse a summary of the updates performed on the table, and select 
which one to accept.  For example, a user can prevent any records that had been 
deleted from being lost in the original table.

It is important that the assumptions of the tool are followed including:

• Original/Output Table had a field called “Modified” of Boolean type

• Original/Output Table had a field called “ID” of Integer type 

• The ID field was populated sequentially with the row number, with no 
gaps.

• Original/Output table has been unchanged during the period it was used 
on the device

• Only a single copy of the table has been modified

• The copy of the table has not been packed e.g. Do not Save a second 
copy of the mobile copy

• The copy of the table has only been modified within Discover Mobile

• The structure of either table has not changed

Input Table

Select the table from the mobile device (downloaded previously) to merge the 
changes into the original table.

Output Table

Select the original and un-modified copy of the table from the local disk to perform 
the merge action.
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Merge Actions

The merge actions can be modified by either selecting or deselecting the 
appropriate action.

The following merge actions are available:

• Append New Rows

The Input and Output table ID fields are compared, if an ID record doesn’t 
exist in the Output table it will be appended to the Output table. Note if 
there is multiple ID values they will be overwritten and only the last one 
used.

• Update Changed Field Values

The Input and Output table Modified fields are compared, if a Modified 
record is flagged with a T this will indicate a modification and this record 
will be changed in the Output table.

• Scan Geometry for Changes

The geometry of the Input and Output tables are compared using the ID 
field as the join. If the maps object geometry is modified from the Input 
table this is reflected in the Output table, only records with the same ID will 
be modified.

• Remove Deleted Rows

The Input and Output table ID fields are compared, if an ID record doesn’t 
exist in the Input table it will be deleted from the Output table.
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Save Registered Raster

The Save Registered Raster tool will convert the select map window view into a 
raster image in a number of compressed formats, including ECW, at the selected 
level of detail and resolution.

To convert any data into a registered raster, open a new map window in MapInfo 
Professional that contains the required tables or make an existing map window 
the active window

1. Set the window dimensions and scale so the map window contains the 
information to save. Whatever is visible within the map window will be 
saved as the raster image. 

2. Select the menu DiscoverMobile>Save to Registered Raster option to 
display the Create Registered Raster dialog:
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3. Select the window you to wish to convert to a raster image from the Select 
Window to Save list. 

4. Select the raster format from the Image Type drop down list. Available 
formats include .ECW, .PNG, .BMP, .JPEG, .TIF, .GEOTIFF (note though 
that Discover Mobile does not support .PNG). For best compression, save 
the window as an ECW. 

5. Use the Detail drop-down list to increase the level of detail in the image 
from the fixed screen resolution (96 dpi). By default Discover will save an 
image which is double (2x) the size (width and height) of the map window 
on the screen. 

6. Enter a value into the Image Transparency window to apply a 
transparency to the entire image (enter 0% for an opaque image).  

7. Check the Set background transparent box to change the white 
background default. 

8. Check the Create World File box to create an associated world file for the 
image which contains the registration information – this is useful for 
opening in programs without using the TAB file.

9. Click OK for the conversion to raster image to proceed.
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4 Getting Started
The Discover Mobile interface is easy to understand and simple to use, so the 
best way to learn how to use Discover Mobile is to start using it. For a quick 
introduction to starting and using Discover Mobile see:

• Starting Discover Mobile

• The User Interface

• Interacting with the Software

• Data Formats

• Map Window

• Saving and Restoring Your Workspace

Starting Discover Mobile

Start your Pocket PC device and check that you have sufficient battery power for 
your intended session. It is important that the battery has sufficient charge as 
most devices which connect to the PPC, such as GPS receivers can significantly 
reduce the operating time of the onboard battery. If you intend to use your PPC 
with an integrated GPS receiver you are strongly advised to carry or use an 
external or backup battery. This will help extend the effective operating time of the 
device and minimise the possibility of any data loss. 

To start Discover Mobile:

• Tap the Start menu and then the Discover Mobile menu item.

If the Discover Mobile menu is not shown on the Start menu then:

• Tap the Programs menu and tap the Discover Mobile icon.
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Select the Start>Discover Mobile menu item or the Start>Programs>Discover Mobile icon

If the Discover Mobile icon is not visible among the installed programs, check to 
make sure the software is properly installed. See Installing Discover Mobile for 
further information.

When Discover Mobile starts, the main screen and main toolbar are displayed.

Note To ensure that Discover Mobile always appears on the Start Menu, browse to 
Start>Settings>Menus, and in the following list, tick/enable Discover Mobile. 
Press OK. Note that any applications visible under the Start Menu will not be 
listed in the Programs display.
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Discover Mobile main screen and main toolbar

The User Interface

The Discover Mobile user interface provides a simple and intuitive method for 
interacting and working with your mapping data. Most commonly used tasks can 
be directly accessed via the shortcut button toolbars located along the bottom of 
the screen. There is a complete menu system accessible via the GO menu in the 
lower left corner of the screen. This menu provides access to all shortcut button 
functions as well as a number of additional functions. 

The Discover Mobile interface includes three user-controllable toolbars plus the 
Main Toolbar. The three controllable toolbars are accessed via the main toolbar 
and can be turned on or off by tapping the toggle buttons. The main toolbar is 
located at the bottom of the Discover Mobile display and is always visible. The 
user-controllable toolbars include: 

• Select/View Toolbar

• Draw/Edit Toolbar

• GPS Toolbar 

All operations performed by the toolbar buttons, plus a number of additional 
functions, can be accessed from the GO menu. For more information, see Using 
the GO Menu system.
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Interacting with the Software

Interaction with the Discover Mobile software is similar to most PPC applications. 
The user interacts with the software using a handheld stylus. The stylus is the 
primary input method and is used throughout the software for pointing, selecting 
and data or text entry. The stylus is generally used to tap or tap and drag an item, 
such as when making a selection, editing text or objects, manipulating a list or 
drawing a polyline or polygon. A tap is simply the act of gently touching the display 
screen surface with the plastic stylus (never use a conventional writing pen). To 
tap and drag, place the stylus gently on the screen  and drag it across to the 
desired position while maintaining contact with the display surface.

Applying, cancelling, and closing application dialogs on a PPC can be slightly 
different to a desktop computer. Usually screen interaction is performed by one 
of two methods:

• Tapping on a displayed button (labelled with text such as OK, Apply or 
Cancel) or,

• Tapping on the OK button in the top right corner of the screen. Most 
dialogs will have an OK button in the top right of the screen (located in the 
Title bar). Some windows may not have a separate Cancel button and rely 
completely on the OK button to dismiss the window.

The Discover Mobile software has been especially designed for users familiar 
with MapInfo Professional. Existing MapInfo Professional users will find many 
similarities between the Discover Mobile interface and the desktop MapInfo 
Professional application.
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Data Formats

Discover Mobile reads and writes native MapInfo Professional Tab files and can 
access raster data stored in .BMP, .TIFF, .JPG, .GIF or .ECW file formats 
providing the images have an associated .TAB file. Discover Mobile cannot 
directly open files which do not have .TAB files already associated with them. The 
only exception to this is raster images saved in GeoTIFF format. Any Tab files 
which reference non-native MapInfo Professional data such as Excel (.XLS), Text 
(.TXT) or MS Access (.MDB) files cannot be opened in Discover Mobile. These 
non-native data types must first be converted into MapInfo Professional Native 
format (using File>Save Copy As menu) before copying the data to the PPC for 
use in Discover Mobile.

Map Window

The Discover Mobile desktop uses a layered map window display which is similar 
to MapInfo Professional, except that Discover Mobile has a single map window. 
Each open table is displayed in the map window as a Layer. The display order, 
visibility, selection and editing properties of these layers are controlled by a Layer 
Control dialog. For more information about creating and managing layers and 
other view control tasks, see Controlling Layers and the View.

Map Window Projection

Like MapInfo Professional, the map display window in Discover Mobile has an 
associated map projection. The default projection assigned to an empty Discover 
Mobile map window is Latitude Longitude WGS 84. Like MapInfo Professional, 
Discover Mobile will automatically adopt the map projection of the first table (.TAB 
file) which is added to the Map window. All other data, with the exception of Raster 
layers, will be added to the map window in this map window projection. If required, 
the coordinates of objects in other projections will be transformed on the fly to 
match the coordinate system of the map window. It is worth noting however that 
coordinate transformation is a processor intensive procedure and can 
significantly increase the time required to redraw the map window. For best 
performance you are encouraged to convert all TAB files into the same base 
projection before using them with Discover Mobile. The map window projection 
can be altered using the GO>Preferences>Map and User Projection menu 
options (see Controlling the Map Projection). An exception is when a raster image 
is open; in this case, the map window and all contained vector data will then take 
on the projection of the raster image.
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Saving and Restoring Your Workspace

Your Discover Mobile workspace can be saved to and restored from Geoset files. 
Geosets save the state of all open tables plus the characteristics of displayed 
objects, including style overrides, zoom layering, map projections and zoom 
details.

A Geoset is similar to a MapInfo Workspace; however, the two are not compatible. 
MapInfo Professional version 7.0 or later is shipped with two utilities to help you 
create and read Geoset files within MapInfo Professional. These utilities are 
called GEOSET.MBX and SEND2MXM.MBX, which are located in the 
MapInfo\Professional\Tools folder.

To save your workspace:

1. At least one table must be open in the map view.

2. Choose GO>File>Save Geoset.

3. Type the name (without the file extension) and folder for the Geoset.

Specify the name and folder location of the required Geoset

4. Tap OK to save the Geoset.

To open a recently opened Geoset:

1. Choose GO>File>Recent Files.
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2. Select the Geoset and tap OK, or double-tap the table name.

To open a Geoset file:

1. Choose GO>File>Open Table.

2. Change the Type to Geoset Files (.GST) using the pick list and select the 
Geoset to be opened

After the Geoset has been selected, Discover Mobile will automatically load all the 
associated tables and restore the display settings for that Geoset.

Searching and selecting one of the available Geoset files with .GST filename extension
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5 Mobile Interface
The Discover Mobile user interface provides a simple and intuitive method of 
interacting and working with your mapping data. Most tasks are accessed via 
button toolbars displayed at the bottom of the screen. 

The Discover Mobile interface comprises four main parts:

• Title bar

• Map Window

• Toolbars

• GO Menu (tap the GO button to display)

You can also assign Discover Mobile functions to hardware buttons. For more 
information, see Customizing the Hardware Buttons.

Layout and toolbars of Discover Mobile screen

For information on using the stylus and accessing the various items in the 
interface, refer to Interacting with the Software.
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Title bar

The Title bar displays useful information, such as the GPS signal status, time, and 
volume controls, plus the X button, which minimises Discover Mobile to the 
system tray.

Map Window

The Map window is used for a variety of purposes including:

• Displaying all data, text, dialogs, images and maps.

• On-screen editing, object selection and editing.

• Displaying the GO Menu system.

Toolbars

The toolbars are the primary method of operating Discover Mobile. There are four 
toolbars. The Main toolbar is always visible. However, you can hide and show the 
Select, Drawing and GPS from the main toolbar at the bottom of the screen or 
from the GO menu:

Note To exit or terminate Discover Mobile, select the GO>Exit menu. The X button in 
the Title bar will only minimise the Discover Mobile application. It does not exit or 
shutdown the software. This means that the application will still be operational, 
even though it may not be visible on the screen. To close running programs, see 
Exit Menu.

• Main Toolbar (always visible)

• Select/View Toolbar

• Draw/Edit Toolbar

• GPS Toolbar
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Tapping the arrow next to a toolbar button, such as the Select tool, will display 
additional options in a pop-up menu:

Main Toolbar

Use the Main toolbar to:

• Display the GO menu system.

• Open, close and maintain tables and views.

• Control the selection, visibility and editing properties of a layer.

• Hide and show other toolbars.

• Display Status window to show GPS position and map information.

• Display screen coordinates.

• Select the data entry method.

Tap the GO button to display the Discover Mobile menu system. When selected, 
a menu and sub-menu list is displayed. See GO Menu for additional details.

Use the Open file button to browse for and select files to display. When a .TAB 
file is opened it will be automatically added to the Layer control list and the map 
objects will be added to the map display.

Use the Layer Control button to add extra tables, change the display order, 
control visibility, editability and override display attributes.

Hide and show the Select/View Toolbar.
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When installing Discover Mobile, an additional input method will be added to the 
PPC device. This input method is called Stop Map. The Stop Map input method 
is used to terminate or stop a long screen redraw. The Stop Map input method is 
a non-standard input method and is not used by any other application. 

Select/View Toolbar

Use the Select/View toolbar to:

• Select item(s) in the map display area.

• Zoom in and zoom out .

• Restore a previous zoom level, save or set a map scale .

• Select pan or centre mode.

• Obtain tabular information for a selected item.

Hide and show the Draw/Edit Toolbar.

Hide and show the GPS Toolbar.

Display a Status Window showing GPS information and other map properties 
used by Discover Mobile. Items such as the zoom level of the map window, 
current GPS position and other user-definable GPS parameters. By tapping and 
holding the stylus within the bounds of the Status window you can access the 
Status Window Setup menu  to configure the items which are displayed (see 
Display View Settings). It can be resized by dragging the red square at the 
bottom right of the window.

Display the Coordinates of the stylus as a map easting (X) and northing (Y)l in a 
moveable text display window. The map coordinates are displayed using the 
current projection, which is defined by GO>Preferences>Session.

Select the Input Method for character and number entry. The default method is 
a keyboard however additional options as described below are available. Refer 
to the PPC user documentation for detailed descriptions of each of the data entry 
modes.
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• Delete a selected item.

 The Selection button has four modes for selecting object(s) in the display area. 
To change mode, select the arrow next to the currently selected mode button.

Point – Select a single object or item. This default mode is used for data 
entry, object selection and editing. Selection is done by positioning the 
stylus over the required object and tapping. A selected object is 
highlighted.

Radius – Selects objects within a circular area. All selectable objects 
within the radius are highlighted. The origin of the radius is centred where 
the stylus was first placed on the screen. Locate the stylus at a point on 
the screen and then drag it away from the point to define the radial search 
area.

Rectangular - Selects objects within a rectangular area. All selectable 
objects whose centroid is within the area are highlighted. Locate the stylus 
at one corner and then drag out a rectangle.

Polygonal - Select objects within a polygonal area. Use the polygon 
select tool to enclose the required objects by tapping out a series of 
vertices. All selectable objects within the polygon are highlighted. Tap the 
stylus at a start point and then tap additional vertices to enclose the 
objects. Close the polygon by double-tapping the last point.

The Zoom In button increases the view of the display area. Tapping once in the 
Display Area will operate the tool. The tool magnifies the view by a factor of 2x 
and uses the point of the stylus tap as the centre of magnification. Alternatively, 
you can tap a location with the stylus then drag it to create a dotted rectangle. 
When the stylus is removed, the Display Area view zooms to fill the selected 
area.

The Zoom Out button increases the view of the display area. A single tap of the 
stylus will halve the view area centred on the stylus tap point. 
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The Previous Zoom button will restore multiple previous views. To operate, tap 
the button once per view. 

Tap the arrow button to display other functions available from this tool:

Save View – Saves the current view properties with a unique name. 
Multiple views can be defined and restored directly from the pop-up menu. 
Note that only the display area properties are saved, not the view 
contents. Restoring a view will return the map display to the same scale 
and map centre at the time it was saved. It will not reopen layers that were 
in use when the view was originally saved. If you wish to save a view 
which includes all associated map layers and display properties you need 
to save a Geoset (see Saving and Restoring Your Workspace).

Delete View – Deletes a saved view from the display list. 

Zoom Level – You can specify a precise zoom level by selecting a screen 
width value (in metres) or map scale from the pop-up menu. The zoom 
level tool can be used in either the Width mode or Scale mode. When you 
switch between modes the corresponding scale or width value will be 
shown in the list. If you need to set the screen width or map scale to a 
value which is not available in the list, you can type the value using the 
keyboard or one of the other input methods.

View Entire Layer – Redraws the map to show the full data extents for a 
selected layer. Choose a layer or All Layers from the Zoom to selection 
dialog.

Pan and Center tools share the same button position and can be switched with 
the arrow button next to the displayed tool.

Pan button moves the view around the map display area. Position the 
stylus on the map and drag it in the direction you want the map to move.

Center tool repositions the map display so that it is centred on the position 
where you tap the stylus.
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The Distance Measurement tool has two modes. To change mode, select the 
arrow next to the currently selected mode button.

The default mode is a freehand polyline measure tool which will measure 
the cumulative distance along a polyline as you draw on the screen. The 
distance is shown in the units set in GO>Preferences>Session.

The straight-line distance mode measures the distance between 
consecutive points. The information displayed shows the distance 
between the last two consecutive points of the polyline as well as the total 
accumulated distance between the origin and the last point. The distance 
is shown in the units set in GO>Preferences>Session.  Double tap the 
screen to complete a line and reset the measurement.

The Information and Hotlink tools share the same button position and can be 
toggled with the arrow button next to the display tool.

Use the Information button to display and edit object attributes (field values) in 
the table browser. If the selected item does not have any associated attribute 
information, blank data fields will be displayed. If more than one table has an 
object at the selected point, use the drop-down list to select the table of interest.

Use the Hotlink button to open a hotlink image from the target map object. If a 
MapInfo table contains multiple hotlink fields only the first one will be displayed. 
The Hotlink button streamlines the display of images taken from your in built 
PPC camera.

Delete button deletes any selected object(s) from an editable layer (see 
Managing Layers).



62 Encom Discover Mobile User Guide

Draw/Edit Toolbar

Use the Draw/Edit toolbar to:

• Place a symbol.

• Draw a straight line .

• Draw a polyline or freehand polyline.

• Draw a polygon or a freehand polygon.

• Add labels or annotations to selected objects.

• Edit or add object vertices.

• Modify object styles, including symbol style, line style or fill patterns of 
selected objects.

Objects can be modified on any layer which is set as Editable (see Managing 
Layers). Unlike MapInfo Professional, Discover Mobile allows simultaneous 
editing of multiple layers. If a layer is open and editable then any objects in that 
layer can be moved, repositioned, resized or deleted. Different line styles or 
polygon fills can also be applied.

New objects can only be added to one layer (i.e. table) at a time. You can set a 
layer to receive new drawing objects (points, lines or polygons) by setting that 
layer as the insertion layer (see Setting the Insertion Layer). If an insertion layer 
has not been set you will be prompted to select one the first time you use any of 
the drawing tools. This layer will then remain as the insertion layer until you either 
close it or select another layer. For more information on working with layers refer 
to Managing Layers. The insertion layer setting does not affect the storage of 
GPS-located objects (see Assigning GPS Capture Layers).

Discover Mobile provides a cosmetic layer for storing temporary map objects. 
Unlike MapInfo Professional, the cosmetic layer is optional in Discover Mobile. 
For information about ding a cosmetic layer, see Adding a Cosmetic Layer. You 
can use the cosmetic layer to store temporary map objects rather than add them 
to an existing layer. Any objects placed into the cosmetic layer will be permanently 
deleted if you exit Discover Mobile without saving them. To save Cosmetic 
objects to a new table (.TAB), use GO>File>Save Table Copy As.

Using the Drawing tools is further discussed in Working with Objects.
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The tools available from the Draw/Edit toolbar are:

 

Use the Symbol button to add a symbol (point). Tap the screen to insert the 
symbol. See Creating Points and Symbols..

Use the Structure Symbol button to add a structural symbol. Tap the screen to 
insert the symbol. See Creating Structure Objects.

Use the Line tool to draw a straight line. Tap the stylus at the line start point and 
then drag to an end point. See Creating Lines and Polygons.

Use the Polyline tool to draw a polyline node-by-node. Tap the screen to add 
the first node, then move the stylus off the screen surface and tap another point. 
Continue tapping vertices until the polyline is complete. To finish double tap the 
last node. See Creating Lines and Polygons.

 
Use the Freehand Polyline tool to draw a free-hand polyline. Place the stylus at 
the start of the line and then while holding the stylus on the surface, draw the 
line. To finish, remove the stylus from the screen. See Creating Lines and 
Polygons.

Use the Polygon tool to draw a polygon node-by-node. Tap the stylus on the 
screen at the first node and then tap the subsequent nodes in sequence. 
Complete the polygon by double tapping the the final node. See Creating Lines 
and Polygons.

 

Use the Freehand Polygon tool to draw a closed free-hand polygon. Place the 
stylus at the start of the line and then while holding the stylus on the surface, 
draw the line. To finish and close, remove the stylus from the screen. See 
Creating Lines and Polygons.

Use the Add Label button to label objects with selected attributes. See Labels 
and Annotation.

Use the Add Annotation button o add text to the display. Ensure the pop-up 
keyboard is open before selecting this tool. See Labels and Annotation.

Use the Vertex Edit tool select and edit vertices of polyline and polygon objects. 
Each vertex can be moved, relocated or deleted. See Edit and Delete Nodes.

Use the Add Vertex button to insert nodes on a selected polyline or polygon. To 
use, first select the object and tap the Vertex Edit button. The vertices of the 
selected object are displayed. Tap the stylus at the required position on the 
polyline or polygon to add a node. Hold the stylus on the screen to drag the new 
node to the desired position. Add Nodes.
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GPS Toolbar

The GPS toolbar is used to:

• Connect to a GPS receiver.

• Record a GPS Point Track Log.

• Record a GPS Line Track Log.

• Capture points. polylines, and polygons via the GPS.

• Navigate to a known location.

• Activate the North Up or Auto Rotate map function.

• Modify the GPS information display properties for the Status Window 
readout.

See the Connecting to the GPS and Creating GPS-Located Objects for a detailed 
description of these tools. To automatically prompt for a named style, or to edit 
attributes or coordinates, see Object Creation.

Discover Mobile provides inbuilt support for a wide selection of standard GPS 
devices. Discover Mobile can connect to any GPS receiver which outputs data in 
the NMEA 0183 version 2.0 protocol format and has a serial (COM) port 
connection.

Use the Object Style button to modify the display properties of a selected 
object. The style properties dialog will change depending on the type of object 
selected. To alter the appearance of an object, first select it using one of the 
select tools and then tap the Object Style button. See Formatting Drawing 
Objects.

Note The first time you use Discover Mobile you will need to configure the GPS 
communication settings for your particular receiver. You can do this from 
GO>GPS>Setup Connection or GO>Preferences menu. It is important that you 
set the correct port number, communication format and speed for your GPS 
receiver. If these settings are incorrect Discover Mobile will not be able to 
communicate with the receiver. Refer to your GPS User Guide for details on the 
GPS communication settings and Working with the GPS in this guide.
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GPS Connect button is used to connect/disconnect the GPS port. Tap the 
connect button to open the GPS connection. You will need to make sure that 
your GPS has been properly configured, is turned on and that appropriate 
communication settings have been made under the Discover Mobile 
GO>Preferences>GPS>Connection menu before opening the connection.

GPS Point Track Log button turns on/off the Point Track Log function. Discover 
Mobile can record a continuous Track Log showing your path as a series of 
points. See GPS Point Log.

GPS Line Track Log button turns on/off the Line Track Log function. The Line 
Track Log is made up of a series of consecutive line segments rather than one 
continuous polyline. If you want to record a single continuous line (e.g. a fault 
trace or track) then use the GPS Line Capture function instead. See GPS Line 
Log.

GPS Point Capture button captures a single point at the current position 
coordinates from the GPS receiver. See Capturing Points.

GPS Structure Symbol button captures structural measurements readings 
using the current position coordinates from the GPS receiver. See Capturing 
Structure Objects.

GPS Insert Node button adds a new node to the current GPS polyline or 
polygon while the pause button is active. To use, tap the Insert Node button 
when you wish to add a node to your line. You can return to continuous node 
logging mode at any time by turning off the Pause button.

GPS Polyline Capture button captures a continuous polyline using the GPS 
position coordinates. Tap the button again to stop the polyline capture. The node 
separation is controlled by the Tolerance Min and Tolerance Max settings on the 
Preferences menu. 

GPS Polygon Capture button captures a polygon using GPS position 
coordinates. Tap the button again to stop the polgon capture. The polygon will 
automatically close by joining the last captured node to the first. The node 
separation is controlled by the Tolerance Min and Tolerance Max settings on the 
Preferences menu.

GPS Polyline/Polygon Pause pauses the capturing of a polygon or polyline 
without terminating the current capture. Tap the Pause button once to pause the 
current capture (the button is depressed). With the pause button depressed you 
can move without capturing further data. When you are ready to capture the next 
node tap the pause button again to restart the capture. 



66 Encom Discover Mobile User Guide

GO Menu

The GO menu system of Discover Mobile is used to control and configure the 
application. Many of the functions in the menu system are also available from the 
toolbars. To display the menu, tap the GO button in the lower left corner of the 
main toolbar.

For details of the commands available from the Go Menu, see Using the GO 
Menu.

Customizing the Hardware Buttons

GO>Edit>Hardware Button Options

To customize the hardware buttons, choose GO>Preferences and under 
System Settings, select the Hardware Buttons option. Choose a function from 
the Select Function pull-down list and then press the desired hardware button 
on the hand-held device.

To use an existing button mapping configured through Windows 
(Start>Settings>Buttons, eg for Word or Excel), ensure that the Check for 
Mapped Buttons option is unticked/disabled.

Auto Rotate Map - North Up  button turns on and off the Auto Map Rotate 
function. The Auto Rotate Map function will automatically rotate the map view so 
that the top of the map is oriented towards the direction of travel. The auto map 
rotation preferences can be configured from GO>Preferences>GPS>Map 
Rotation.

Center Map on GPS option will re-center the map window so the GPS position 
symbol is in the center if the map window.

Waypoint Navigation enables you to select an existing map object (eg point, 
polygon) as a destination waypoint and Discover Mobile will then report the 
distance and bearing between your current GPS location and the selected 
waypoint feature to the waypoint readout window. 

GPS Display Settings configures the GPS information displayed in the Status 
window. See Display View Settings. Tap the button to display the GPS display 
configuration dialog. Select or clear the information you want displayed.
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6 Using the GO Menu
The GO menu system of Discover Mobile is used to control and configure the 
application. Many of the functions in the menu system are also available from the 
toolbars. The main menu is displayed by tapping the GO button in the lower left 
corner of the main toolbar. Additional functions are available on some toolbar 
buttons (see Toolbars).

• Exit Menu – exit and close the application

• About Menu – description of Discover Mobile

• Licensing Menu – User information and licensing details

• Preferences Menu – GPS communications, system and session 
preferences and maintenance

• Tools Menu – controls the buttons on the Draw/Edit toolbar 

• Query Menu – create queries on data tables, find objects by attributes 

• Map Menu – Create Cosmetic Layer, Set Insertion Layer, Save window, 
Add/Modify Theme, Map Projection

• GPS Menu – connect to a GPS, monitor/check a GPS connection, capture 
data and define preferred styles

• XRF Menu – connect to the Olympus Innov-X and Niton portable XRF 
devices

• View Menu – Layer control, Map zoom level, Map Rotation, Table 
structure

• Edit Menu – accesses layer editing, labelling, annotation, and styles

• File Menu – New Table, Open Table, Save Geoset, Save Table Copy As, 
Recent files, Edit Table Structure, and Pack Tables
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Exit Menu

GO>Exit

Use the Exit command to terminate the Discover Mobile application and remove 
it from the PPC memory. If you intend to restore your data and map display to the 
same state as when you closed the application, you must save the state to a 
Geoset file before you exit Discover Mobile (see Saving and Restoring Your 
Workspace ). 

The GO>Exit command is not the same as the X button on the Title bar of 
Discover Mobile. Tapping the X button on the Title bar will only minimise Discover 
Mobile to the system tray of the device. It does not exit from the application or 
remove it from main memory. This means that the application is still operational, 
even though it may not be visible on the screen. If you power off the PPC by 
pressing the power button Discover Mobile will remain in main memory and be 
ready for use when you next turn the device on. However, the running 
applications will still consume power while the device is switched off.

To close all applications:

1. Tap Start>Settings, navigate to the System tab, and then tap the 
Memory icon.

2. Select the Running Programs tab and stop all running applications on 
the device.

Alternatively perform a Soft Reset.

Note To preserve battery power when you are not using your mobile device, make 
sure all applications are closed before turning the power off. 
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About Menu

GO>About

Use the About command to display information about the Discover Mobile 
installation (version and copyright details).

About dialog 

Licensing Menu

GO>Licensing

Use the Licensing command to display information about the Discover Mobile 
licence including version, UnitID and Licence No. details.
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Licensing dialog

Preferences Menu

GO>Preferences

The Preferences menu is used to control various systems, session and display 
settings in Discover Mobile. It is also used to configure the communication 
settings for an attached GPS receiver. The GPS configuration settings are 
described in the GPS Connection section of this chapter.

The Preferences dialog allows you to configure the following parameters:

• Connection - GPS Protocol, Setup, Update Interval, Preferred Interval, 
Stop after error, SSF Logging, Post Processing

• Point Capture – Tolerance Minimum and Tolerance Maximum, Minimum 
Sample Points, Precision Filter

• Display – Re-centre GPS, Altitude units, Speed units, Default Scale, GPS 
Position Style

• Map Rotation – Degree Tolerance, Speed Tolerance, When Off

• Object Creation – Edit Attributes, Named Styles, Point XY Editing

• Session – Autoload last, Map Projection, User Projection,  Distance Units, 
Area Units, Grid Overlay, Waypoint Tolerance
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• System Settings – Busy Cursor, Font Size, Confirm Deletion, Hardware 
Buttons, Alert Configuration

• Directories – Project Root, Current Project, Track Log, Pick Lists, Named 
Styles, Hotlink files, New Tables, Image Files

Preferences dialog

A summary of all the settings available from this dialog is available at Preference 
Settings.

Connection

GO>Preferences>GPS>Connection

The configuration and use of these parameters in discussed Working with the 
GPS and Working with Differential GPS (DGPS). Consult these topics before 
adjusting the various GPS Connection parameters.

• GPS Protocol

• Setup

• Update Interval

• Preferred Interval

• Stop After Error
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• SSF Logging

• Post Processing

GPS Protocol

The GPS Protocol option allows specification of:

• NMEA (US-based National Marine Electronics Association) protocol

• Trimble protocol (only for use with Trimble Post-Process DGPS receivers) 

• A log file option, available for troubleshooting NMEA connections

• A Trimble simulation mode

Typically, this will be set to default NMEA option.

Setup

The Setup dialog will vary depending on which GPS Protocol has been selected

NMEA Protocol

See Connecting to an NMEA GPS Receiver for a full description of the use of 
these options.

Port

Port setting refers to the serial communication (COM) port on the Pocket 
PC device to which the GPS receiver is connected. The COM port on 
which the GPS receiver is connected may change depending on the type 
of PPC device and the communication options it supports. By default, 
Discover Mobile will attempt to connect on COM 4, however if this should 
be unsuccessful you may need to try different COM ports. Generally CF 
(Compact Flash) type receivers will connect on COM 4 or COM 6 and 
Bluetooth GPS receivers on COM 5 or COM 8. To determine which COM 
port your GPS is connected to start the GPS and make sure it is set to 
output NMEA data.  Connect the GPS and use the “Scan” function in the 
Discover Mobile GO>GPS>Setup Connection dialog to scan the available 
COM ports for valid GPS data.  
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Speed

The speed setting allows you to adjust the communication speed for the 
serial COM port to match the communication speed of the GPS receiver. It 
is important that you set the appropriate communication speed so 
Discover Mobile can communicate properly with your GPS receiver. Most 
GPS units, which output NMEA data, will communicate between 4800-
9600 baud rate. The default setting is 4800 baud. Consult your GPS user 
guide to determine the correct communication speed for your GPS device. 
Some example speeds are listed below:

Garmin 12XL = 4800 baud

Socket Bluetooth GPS = 38600 baud

Navman GPS Sleeve = 57500 baud

Parity

Parity is a form of error checking used in serial communication. Most 
modern devices use more advanced forms of software error checking and 
no longer use hardware parity. Set this value to match your GPS receiver. 
Consult your GPS user guide to determine the appropriate parity setting 
for your GPS receiver. Most modern GPS devices will use null Parity or 
“None” so this is the default setting for Discover Mobile. If you are not sure 
what the parity setting for your GPS should be then try setting it to none.

Trimble Protocol

(only for use with Trimble Post-Process DGPS receivers)

See Connecting to a Trimble Receiver for a full description of the use of these 
options.

Port

Specify the Port to which the DGPS receiver is connected.
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DOP Type

Dilution of Precision (DOP) is an indication of the current satellite 
geometry. It is the result of a calculation that takes into account each 
satellite’s location relative to the other satellites in the constellation. A low 
DOP indicates that the visible satellites are widely separated in the sky, 
which allows better position information to be recorded. When the DOP 
value rises above the DOP mask (set in the following options), the GPS 
receiver stops generating positional data until the DOP value falls below 
the DOP mask. 

This option allows the DOP type to be specified either as Position (PDOP) 
or Horizontal (HDOP). The HDOP mask is useful when you are more 
concerned with horizontal accuracy rather than vertical accuracy.

Max PDOP

Use this field to set the Position (PDOP) mask. PDOP refers to horizontal 
and vertical measurements (latitude, longitude, and altitude). A PDOP 
value of 6 is recommended.

Max HDOP

Use this field to set the Horizontal (HDOP) mask. HDOP refers to 
horizontal measurements (latitude and longitude). A HDOP value of 4 is 
recommended.

Min Elevation

Use this field to set the elevation mask. Use the elevation mask to allow 
the GPS receiver to only use those satellites above a specified elevation 
in the sky. The GPS receiver does not use satellites below the set 
elevation mask to compute positions. A minimum elevation of 15° is 
recommended.

Min SNR

Use this field to set the Signal to Noise Ratio (SNR) mask, measured in 
decibel-Hertz (dBHz). The SNR value is used to determine whether the 
signal strength of each satellite is sufficient for that satellite to be used by 
the GPS receiver. If a satellite’s SNR is below the SNR mask, it is not 
used to compute positions. An SNR value of 39 is recommended.

Min Satellites

Specify the minimum number of satellites required for a position fix. A 
value of 5 is recommended.
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Apply Velocity Filter

Use this check box to enable or disable the velocity filter. Velocity filtering 
smooths the positions from the GPS receiver as they are generated, using 
velocity information. This filter reduces the effects of multipath error on 
positions computed by the GPS receiver.

Use GLONASS

Enables tracking of GLONASS  satellites in the connected GPS receiver if 
the receiver is GLONASS-capable.

Tracking both GLONASS and GPS satellites can improve productivity by 
reducing the time required to achieve real-time or post-processed 
decimeter or subfoot solutions and increasing the amount of data 
collected (increased yield), particularly in tough environments such as 
around tall buildings and under heavy tree canopy.

For more information, see Trimble documentation.

Trimble Simulation

Once enabled via the top-most tick box, Discover Mobile can simulate a live 
Trimble DGPS connection, either by sourcing a data file (.txt) previously 
generated, or via simulating a circular movement path. The latter option requires 
user-specified latitude, longitude, altitude and radius parameters.

Update Interval

The update interval controls the time interval or rate at which Discover Mobile 
updates the current GPS position location on the map. This value is set to 2 
seconds by default, which is generally adequate for most situations. If you do not 
need have your current position location updated as often then you may find it 
more appropriate to set this value to a higher interval, say 10 or 20 seconds as 
this will reduce the amount of information that Discover Mobile has to process and 
may improve overall performance. 
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Preferred Interval

Each time Discover Mobile updates your current location on the map with a new 
GPS position it must redraw the entire contents of the Map window to show the 
updated information. If it takes longer to redraw the map window than the time set 
in the Update Interval control, then Discover Mobile will not be able to redraw the 
map window quickly enough to keep up with the GPS. In this situation Discover 
Mobile will automatically adjust the rate at which it polls the GPS for position 
information to match the re-draw speed of the map window. The Preferred Update 
Interval setting allows you to set a preferred update interval for the current GPS 
position and where possible Discover Mobile will attempt to honour this value. If 
you find the map redraw speed is too slow for your current needs try zooming in 
on the working area in the map window as this may improve re-draw time and 
restore the GPS update interval to the preferred value. Whenever Discover 
Mobile decreases or increases the update interval of the GPS to match the map 
redraw speed it alerts you with a warning sound. These warning sounds can be 
configured via the GO>Preferences>Alert Configuration control.

Stop After Error

This item controls the number of consecutive errors (or poor data) that Discover 
Mobile will accept before terminating the GPS connection. If you are working in 
areas with poor GPS signal (e.g. heavily forested terrain, in valleys or near cliffs) 
it is recommended you increase the stop error to a high value (e.g. 30 or 50). If 
you still experience connection difficulties you can further increase this value by 
typing an alternative value in the box.

SSF Logging

This option is only available with the Trimble GPS Protocol enabled.

Set this option to On to create a Trimble .SSF format Rover file with the same 
name as the file into which data is being captured. 

This rover file is required to allow post-processing differential correction to be 
carried out on captured data.

For recommended settings for Postprocessed DGPS, see Working with 
Differential GPS (DGPS).

Note This option is only designed for use with Trimble Post-Process DGPS units.
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Post Processing

This enables the Carrier phase signal of the Trimble output to be logged. Utilizing 
this signal (in tandem with the default Code phase signal) will increase the 
accuracy of the post-processing correction; however it requires the user to be 
within 50 kilometres of the base station, and to maintain continuous Carrier phase 
lock for 10 minutes.

Three logging modes are available:

• None: no carrier phase data is logged. The data set will not be able to be 
post-processed.

• Continuous: carrier phase data is logged at 1 second intervals

• Classic: carrier phase data is logged at heat beat rate when not capturing 
an object location, and at the object logging rate when logging an object.

See Carrier Phase Logging for further information.

Point Capture

GO>Preferences>GPS>Point Capture

• Tolerance Min

• Tolerance Max

• Min Sample Points

• Precision Filter

Tolerance Min

Controls the minimum separation distance Discover Mobile will accept before 
recording a new point or line segment. For example, if the distance value is set to 
5m then Discover Mobile will only record a new line segment in a polyline or 
polygon if the distance travelled between the previous position and the current 
position is greater than 5m. Any position data received which is closer than 5m 
will be filtered out. The default Tolerance value is 10m (the approximate accuracy 
of standard GPS receivers).

Note This option is only designed for use with Trimble Post-Process DGPS units.
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The minimum tolerance should be set at a value which is appropriate for your 
mapping requirements and GPS receiver accuracy. If you are using Discover 
Mobile with a conventional GPS receiver to walk out object boundaries, then a 
minimum tolerance of 10m should be sufficient. If you were using a differential 
GPS you may reduce the value to 1m or 5m. This will allow you to stop and take 
notes without Discover Mobile adding a series of unwanted points to your 
polyline. If you were mapping out roads or tracks with Discover Mobile using a 
vehicle then a minimum tolerance between 20m to 100m would be more 
appropriate.

Tolerance Max

This option controls the maximum separation distance that Discover Mobile will 
accept when recording a new point or line segment. For example, if the maximum 
tolerance distance value is set to 100m, Discover Mobile will only record a new 
point if the distance between the current position and the previous position is less 
than 100m. Use this function to filter out unwanted points caused by bad GPS 
signal reception. The default value is 10000m.

Be careful not to set the GPS Maximum Tolerance value too small, particularly if 
the GPS signal quality is poor. Ideal values are between 500m and 10000m. If the 
Maximum Tolerance value is set to small (say 100m) and you are travelling in a 
car at 80-100 km/hr, it is possible that you could travel further than the tolerance 
value between consecutive points, especially if an error was encountered in one 
of the readings. In this case, Discover Mobile would consider any additional point 
to be outside the maximum tolerance and would not continue to record the 
polyline.

Min Sample Points

This setting defines the number of point calculations required before a position is 
established.  A position is calculated by averaging the specified number of point 
calculations; thus the higher this parameter is set, the longer it will take to 
generate a position, but the more precise the position will be. It is recommended 
to use a setting of 15 points.

Note This option is only designed for use with Trimble DGPS units.
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Precision Filter

Various quality levels of position fix can be output by DGPS receivers, depending 
on factors such as the number of satellites, the quality of the satellite signal 
(influenced by the amount of satellite coverage and overhead cover), the quality 
of radio reception (for Real-Time DGPS) and the parameters assigned in the 
Setup dialog. The quality of the current position fix is indicated at the bottom left 
of the map screen.

Discover Mobile allows a Precision Filter to be selected, which prevents data 
capture when the position fix quality falls below a designated level. These Filter 
levels are detailed below; select the DGPS filter.

GPS - Any current position fix (GPS or DGPS) will be accepted

DGPS - Requires a Differential GPS fix (Real-time or Post-processed)

RTK LOW - Requires a low-quality Real-time Differential solution

RTK HIGH - Requires a high-quality Real-time Differential solution

Display

GO>Preferences>GPS>Display

• Re-centre GPS

• Altitude in

• Speed in

• Default Scale 1:

• GPS Position Style

Re-centre GPS

This option controls how the map window display redraws when the Current GPS 
Position marker approaches the edge or leaves the map window display. The 
options are:

• Off Map – Window will re-centre only when the Current GPS Position 
moves outside the display area.

Note This option is only designed for use with Trimble DGPS units.
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• Always – Current GPS Position will stay fixed in the centre of the map. 
The map window contents will redraw at the rate of the GPS Interval. 

• Never – Window will never re-centre even when the Current GPS Position 
moves outside the map display.

• n% Border – Window will re-centre when the Current GPS Position is 
within a n% border of the map window. The default setting is 5%.

Altitude in

This option allows you to specify the preferred units of measure for displaying 
GPS altitude in the Status window. The available options are metres or feet.

Speed in

This option allows you to specify the preferred units of measure for displaying 
GPS altitude in the Status window. The available options are metres per second 
(m/s), kilometres per hour (km/h), miles per hour (mph) and knots (kt).

Default Scale 1:

A default scale for the map view can be assigned for when a GPS connection is 
established and no data tables are open (between 1:1000 and 1:10000). If data 
is open in the map window when a GPS connection is established, the current 
view scale will be preserved (and the default scale will be ignored).

GPS Position Style

A default symbol style for the current GPS location point can be defined. This is 
the same as defining it under GO>GPS>Default Styles>Current Position Style.

Note The Always setting can slow down map redraw performance significantly. Only 
use this setting with simple vector maps or GPS Track Log function.
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Map Rotation

GO>Preferences>GPS>Map Rotation

Discover Mobile provides a display option to automatically rotate the map window 
contents so that the top of the screen is always in the direction of travel as defined 
by the GPS. The Auto Rotate function only works with vector maps and is only 
enabled when the GPS is active. The map rotation function cannot be used if a 
raster table is loaded in the map window. See Auto-Rotate and Auto-Centre for 
further information.

Deg Tolerance

This control sets the angular tolerance for the Map Auto Rotate function. An 
angular tolerance value refers to the angular difference between two consecutive 
GPS locations. If the angle between two points is greater than the degree 
tolerance value then the map will rotate so the direction of travel is towards the 
top of the screen. The default value is 45 degrees and is generally sufficient for 
most situations. If you set a lower value, the map display will rotate more 
frequently. If your map is relatively complex and takes considerable time to 
redraw you may notice a performance decrease if the Auto Rotate function is 
turned on.

Speed Tolerance

The speed tolerance control is used to set the minimum speed over ground below 
which the Auto Rotate function will be deactivated. The default setting is 2 
kilometres per hour, however you can set it to any integer value. For most 
situations 2 km/h is generally adequate, however you may find increasing the 
value to 30 or 50km/h more appropriate when you are travelling in a vehicle.

When Off

Determines what happens to the map window contents when the Auto Rotate 
map function is turned off. The options are:

• Rotate North – this will return the map window display to its original 
position with north up.

• Keep Rotation – will keep the map window positioned at the current 
rotation angle. If you need to reset the map window later so that north is 
towards the top of the screen you can do this using the GO>View>Map 
Rotation control.
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Object Creation

GO>Preferences>Object Creation

The following editable criteria are available when capturing object data.

• Edit Attributes

• Named Styles

• Point XY Editing

The preferences for these can be set as follows:

• Always – Upon data capture, the user is taken directly to the appropriate 
editing dialog

• Ask – The user is prompted as to whether the specified criteria is to be 
edited. If Yes, the appropriate editing dialog is opened; if No, the dialog is 
skipped. 

• Never - The criteria is skipped, without display of a prompt or the editing 
dialog.

Edit Attributes

The Edit Attributes option opens a browser for the new object, allowing the user 
to edit any of the object’s attributes, as well as assign attributes from predefined 
Pick Lists.

Named Styles

An existing style can be applied to the new object from the Named Styles library. 
This is an excellent way to visually differentiate identical object types; eg point 
samples such as rock-chips, lag and soil samples can have differing existing 
symbol types applied during data capture. See Named Styles for further 
information.

Point XY Editing

After data capture, an object’s X and Y coordinates can be manually edited 
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Session

GO>Preferences>Session

• Autoload last

• Map Projection

• User Projection

• Distance In

• Area In

• Grid Overlay

• Waypoint Tolerance

Autoload last

This option functions in a similar manner the Quick Start dialog in MapInfo 
Professional.  Each time you exit Discover Mobile it saves a default Geoset 
(called DiscoverMobile.gst) to the \MY DOCUMENTS folder on your PPC. When 
you start the application you can configure the Autoload last function to perform 
one of the following functions:

• Never – the application will never load the Default Geoset file.

• Ask – the application will prompt you to load the last saved Geoset file. 
You can then elect to either load or cancel the operation.

• Always – the application will always load the default Geoset file on 
startup.

Map Projection

This option governs the projection to be used for capturing GPS data as well as 
for displaying the Map Grid.  This can be set as either the (Default) system 
projection or a (User) preferred projection. The Default option will display 
coordinates using the default map window projection (Latitude/Longitude WGS 
84 GPS). 
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If you wish to display the current GPS position coordinates or the map Grid 
coordinates in a different projection to the map window (e.g. Australian Map Grid 
AGD 66, Zone 55) then you can set the Map Projection to User Defined. Discover 
Mobile will then display all coordinates (e.g. GPS Map X & Map Y in the Status 
window, the Map X and Map Y attribute coordinates in the browser and the Map 
Grid coordinates) in this projection. The GPS Lat/Long values in the Status 
Window and browser will always be displayed in Latitude/Longitude WGS 84 
projection.

A user-defined map projection also overrides the coordinate units, which are 
displayed when using the XY cursor point tool on the main button bar.

User Projection

The user projection dialog allows you to select a preferred projection for the Map 
Grid and for capturing GPS data. To enable a user projection, select the 
appropriate projection category from the user projection dialog and then set the 
Map Projection (above) control to User Projection.

Distance In

The Distance In option allows you to select a preferred unit for displaying distance 
measurements. This controls the display units of the Distance and Measurement 
tool, the Scalebar, and the various Quick Pick measurement options (Object 
Length and Perimeter).

Area In

The Area In option allows specification of the preferred area units for area 
measurements (eg using the Quick Pick Object Area option).

Grid Overlay

The grid overlay dialog is used to override the default display settings for Discover 
Mobiles dynamic Map Grid. The display properties for grid label size and colour, 
grid line width, line colour and line style and the preferred number of displayed 
grid lines can be modified using this dialog. Although you can set a preferred 
value for the number of grid lines you want Discover Mobile to display, the grid 
spacing is automatically calculated to provide the best grid spacing for the current 
map scale so you may find that the actual number of lines displayed on the map 
may vary from the number specified.

The display properties for the Map Grid are also applied to the Discover Mobile 
Scale Bar.
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Dynamic map grid setup dialog

Waypoint Tolerance

The waypoint tolerance control is used to set a minimum radial distance around 
a selected waypoint. When you approach to within the specified distance of the 
selected waypoint Discover Mobile will prompt you with a message saying that 
the waypoint has been reached. The default distance value is 10m which means 
Discover Mobile will report that you have arrived at your selected location when 
the distance between the GPS current position and the waypoint location is 10m 
or less. 

See Navigating to a Known Point for further information.

System Settings

GO>Preferences>System Settings

Provides some control over the following system settings.

• Busy Cursor

• Font Size

Note The projection of the displayed map grid is controlled via the Map Projection 
section of the Preferences menu.
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• Confirm Deletion

• Hardware Buttons

• Alert Configurations

Busy Cursor

Font Size

The font size setting controls the size of the font used for displaying data in the 
Status and Browser windows. The default size is 8 point, however if you find this 
size text difficult to read you can increase the text size by adjusting this control.

Confirm Deletion

This controls whether Discover Mobile will provide a Confirmation dialog before 
attempting to delete an object from a table. The default value is set to YES. If you 
do not want to be prompted before deleting an object you can set this option to 
NO.

When Discover Mobile is processing a request from the user such as reading 
data from a file, processing a query, redrawing a map or loading a dialog, it will 
generally display a system busy cursor. Opening large datasets or raster images 
may take considerably longer on Discover Mobile than it does on you desktop or 
laptop computer. This is mainly because the system resources (memory and 
CPU speed etc) are considerably less powerful on the PPC. The busy cursor can 
be recognised as a spinning colour wheel button . On some PPC devices this 
icon may remain (i.e. appear to get stuck) on the screen after the PPC has 
completed a requested task. If this occurs you can generally clear it by tapping 
on the screen with the select tool. If you find that the busy cursor seems to get 
stuck on the screen regularly you can disable it by setting this option to off. In 
most cases Discover Mobile will then suppress the busy cursor from symbol. 

Warning If you turn the busy cursor off you will no longer have any visual indication when 
Discover Mobile is processing data.

Warning There is no undo function in Discover Mobile, so when you delete an object from 
a table it is permanently removed and cannot be recovered.
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Hardware Buttons

The hardware button mapping dialog allows you to configure the hardware 
buttons on your PPC device so that they can be used to perform certain Discover 
Mobile functions. For example you can assign a hardware button to capture a 
GPS point, toggle the zoom tool, pan tool or selection tool or even to power off 
the screen to help conserve battery power. In Discover Mobile you can map 
virtually any inbuilt function to a hardware button on the device. To setup the 
hardware buttons on the device:

2. Select the particular function you want to map to a hardware button from 
the Select Function pick list at the top of the dialog.

3. Press an appropriate hardware button on the device to which you want to 
assign the particular Discover Mobile function.

4. Repeat the above process for any other hardware buttons you wish to 
map on your device.

To clear a function from one of the hardware buttons select the Clear Button 
Assignment entry from the Select Function pick list at the top of the dialog and 
then press the button you wish to clear. You should note the button assignment 
description is then removed from the list at the bottom of the dialog.

1. Tap the Browse button next to the System Settings Hardware Buttons 
entry to bring up the hardware mapping dialog
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If the Hardware Button assignments set via Windows (Start>Settings>Buttons) 
are to be used (eg to access Word or Excel), ensure that the Check for Mapped 
Buttons option is unselected (disabled).

Alert Configurations

Alerts such as sounds or warning messages can be setup to inform users when 
certain situations with their GPS unit arise. These situations include instances 
when the GPS is reporting values derived from a bad position fix, the user is trying 
to record a point outside the set distance tolerance limits, an XRF measurement 
has been received, or the GPS recording interval has been increased or reduced. 

Directories

GO>Preferences>Directories

• Project Root

• Current Project

• Set Individually (advanced users only)

Project Root

The Project root setting will define where all Discover Mobile project data will be 
stored.  By default this is set to the \My Documents\ folder, however it is strongly 
recommended this is changed to a removable storage card (e.g. SD or CF 
memory card) so that your data will not be lost if the battery on the PPC becomes 
fully drained.

Current Project

This sets the current project folder.  By default after data is transferred using the 
Desktop DiscoverMobile Manager tool, it will be set to the last transferred project 
directory.

Set Individually (advanced users only)

The following settings will be automatically set when the Project Root and Current 
Project is set - they should only be modified by advanced users.  By default they 
will be placed in the Project directory or relevant sub-folders.

To manually over-ride the project settings, first change the Project settings to 
'none set'.
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Track Log

You can specify a preferred directory in which to save your GPS Track Log files. 
By default this is in the current project directory.

Pick Lists

You can specify a preferred directory in which to store and save pick list files 
which can be used in the Discover Mobile browser. By default Discover Mobile 
will store the picklist files in the \Encom_DM_Picklists directory in the current 
project directory.

Named Styles

You can specify a preferred directory in which to save your Named Style Library 
files. By default Discover Mobile will store the Named Style Library files in the 
\Encom_DM_Namestyles directory in the current project directory. Range Styles 
will also be stored and loaded in this directory.

Hotlink Files

You can specify a preferred directory in which to save your Hotlink files. By default 
Discover Mobile will store the Hotlink files in the \Encom_DM_Hotlinks directory 
in the current project directory. Keeping all the hotlink files together in a hotlink 
directory will also help maintain the links when the files are copied back to the 
desktop computer.

New Tables

The File>New Table or Save Copy As commands will automatically create new 
tables in the location specified by this option. By default this is in the current 
project directory.

Image Files

You can specify a preferred directory where the in-built PPC camera saves 
images. This directory is used by Discover Mobile when linking PPC camera 
images to a map object.
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Tools Menu

GO>Tools

Tools menu 

The Tools menu item is divided into two groups. The upper group controls the 
tools that are available on the Main and View toolbars. Items in the second group 
relate to tools on the Draw/Edit toolbar. These menu options all replicate buttons 
available on the relevant toolbars.

• Select

• Zoom In

• Zoom Out

• Pan

• Center

• Info

• Cursor Position

• Add Point

• Add Structure Symbol
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• Add Node

• Add Line

• Add Polyline Freehand

• Add Polygon Freehand

• Add Polyline Freehand

• Add Polygon

• Add Polyline

• Add Annotation

• Add Label

Select

GO>Tools>Select

• Radius Select – selects objects within a radius around an initially located 
point. All selectable objects within the radius are selected and highlighted. 
Operate by placing the stylus at a point on the map and then dragging the 
stylus away from the point until the radial search area increases to the 
required diameter.

• Polygon Select - select objects within a user-drawn polygon area.  Place 
the stylus at a start point and then tap out an enclosing polygon of any 
shape by tapping a series of vertices. Complete the polygonal area by 
tapping twice. All selectable objects within the polygon are selected and 
highlighted. 

• Rectangular Select - select objects within a rectangular area drawn from 
an initially located point. All selectable objects within the area are 
highlighted. Operate by locating the stylus at a rectangle corner point and 
then drag the stylus away from the point until the search area increases to 
the required size.

• Point Select - activates the point select tool, which allows single point 
picking of objects.  This is the default mode used for data entry, object 
selection and editing. Selection is done by positioning the stylus over the 
required object and tapping. A selected object is identified by a change of 
colour, pattern change or highlighting.
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• Annotation Select – allows existing annotation to be selected and edited.

Zoom In

GO>Tools>Zoom In

The Zoom-In tool increases the view of the display area. The tool is operated by 
simply tapping once in the Display Area. This magnifies the view by a factor of 2x 
and uses the point of the stylus tap as the centre of magnification. Alternatively, 
place the stylus on the screen and drag out a dotted rectangle. When the stylus 
is removed, the Display Area will zoom to fill the extents of the rectangle area.

Zoom Out

GO>Tools>Zoom Out

The Zoom-Out tool operates identically to the Zoom-In function, but in a reverse 
sense such that the display area shrinks instead of magnifies. A single tap of the 
stylus decreases the view by a factor of 2x with the view centred on the located 
point.

Pan

GO>Tools>Pan

The Pan tool is used to move the view around the Display Area. To operate, 
position and hold the stylus on the screen. As you move the stylus on the screen, 
the map view display moves with the stylus movement. 

Center

GO>Tools>Center

The Center tool is another useful tool for navigating around the map view. This 
tool operates by re-centering the map display to show the tapped location at the 
centre of the view.
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Info

GO>Tools>Info

The Information tool operates similarly to the Arrow tool, but instead of selecting 
an item, this tool displays any available attribute information about the object. An 
item must have associated attribute information for it to be displayed in a browser 
view.

Cursor Position

GO>Tools>Cursor Position

The Cursor Position tool displays the easting (X) and northing (Y) location of the 
stylus when it is placed within the map display area. The location is shown in a 
moveable text display dialog. The coordinate display units are shown in the 
Session Coordinate Projection which can be defined from 
GO>Preferences>Session.. 

Add Point

GO>Tools>Add Point

Add a located symbol to the current Insertion Layer. To add symbols, tap the 
stylus at the required location on the screen.

Add Structure Symbol

GO>Tools>Add Structure Symbol

The Add Structure Symbol tool will activate the Structure symbol dialog, and 
place the appropriate symbol in the current Insertion Layer. Tap the stylus at the 
required location on the screen: the structure symbol dialog will then appear, 
allowing the user to select the appropriate symbol and enter in the structure 
measurements.  See Creating Structure Objects.
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Add Node

GO>Tools>Add Node

The Add/Insert Node tool allows extra nodes to be added to completed editable 
polyline or polygon. Select the object, and then select the Add Nodes menu option 
or toolbar button. Tap with the stylus on a line segment (between two existing 
nodes) within the selected object to add a new node at this location. See Edit 
Modes for more information.

This function also allows a new node to be added to the current polyline or 
polygon being captured via the GPS. The Add Node tool is only used when a 
polyline or polygon is being captured and the Pause button is active. To add new 
nodes, walk to the required location and tap the button. The new node will be 
added to the current polyline or polygon. See Creating GPS-Located Objects.

Add Line

GO>Tools>Add Line

Draws a Straight line into the current Insertion Layer. To use, place the stylus at 
the line start point and drag the stylus across the screen to the endpoint. When 
the stylus is removed, a straight line will be drawn between the two points.

Add Polyline Freehand

GO>Tools>Add Polyline Freehand

This tool allows a Polyline to be drawn into the current Insertion Layer in freehand 
mode. Place the stylus at the start of the line, and then trace the line extent, 
keeping the stylus in continuous contact with the screen. Removing the stylus 
from the screen will complete the polyline.

Add Polygon Freehand

GO>Tools>Add Polygon Freehand

This tool allows a polygon to be drawn into the current insertion layer in freehand 
mode. Place the stylus at the start of the region, and then trace the region’s 
extent, keeping the stylus in continuous contact with the screen. Removing the 
stylus from the screen will complete and close the polygon.
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Add Polygon

GO>Tools>Add Polygon

Draw a Polygon into the current Insertion layer using the point and tap polygon 
mode. Use by tapping the first vertex of the polygon and then continue by tapping 
in a second and subsequent vertices. Complete the polygon by double tapping 
the final vertex.

Add Polyline

GO>Tools>Add Polyline

Draw a Polyline using the point and tap Polyline mode. To use, tap a start 
location, then move the stylus to another point and tap the next vertex. Continue 
tapping vertices until complete. To finish the line, double tap the last point.

Add Annotation

GO>Tools>Add Annotation

The Annotation tool allows text annotations to be added to or removed from the 
annotation layer. Text labels placed in the annotation layer are temporary and 
cannot be saved. To remove all annotations use the Clear Annotations sub menu 
accessible via the Label button on the Draw/Edit toolbar or the GO>Edit>Clear 
Annotations menu.

Add Label

GO>Tools>Add Label

The Label tool allows text labels to be placed on individual objects. The 
information for the labels is retrieved from an attribute column in the associated 
table. To alter the source column used for labelling use the Labels button on the 
Layer Control dialog. To remove all labels from the annotation layer use the Clear 
Custom Labels sub menu accessible via the Label button on the Draw/Edit 
toolbar or the GO>Edit>Clear Custom Labels menu.



96 Encom Discover Mobile User Guide

Query Menu

GO>Query

The Query menu items are used to create and maintain queries that may be used 
in interrogation of data tables. 

Query menu

• Select

• Select All

• Clear Selection

• Find

• Find Selection

• Browse Selection
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Select

GO>Query>Select

The Select query dialog enables the concise construction of SQL queries within 
Discover Mobile. The first step to creating a query is to select a Layer or base 
table to query.

The Query dialog with layer and query specified

Construct the query using the appropriate columns and operators and then tap 
the Run button to initiate the query. When Discover Mobile has found all the items 
which meet the selection criteria a prompt will appear asking you to either select 
the objects in the map or cancel the query.

If you choose to select the items, Discover Mobile will extract the data from your 
base table and store the results in a temporary selection table. The selection table 
contains only the rows and columns that meet your criteria. The default name of 
the results table is Selection.

If you wish to save your query for re-use at a later time then use the Save button 
and assign an appropriate name for the query. To re-use the query, tap the Load 
button, select the appropriate query file and the query will be restored.

Columns

After you have chosen the layer to be queried, the column drop down list displays 
the available data fields in the layer. If you place the stylus over a field and select 
it, the entry will be placed in the query expression area.
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Operations

Quite complex queries can be created using the operators and functions in 
Discover Mobile. A drop-down list of operators is available to assist in creating the 
query expression. 

For information on Query operators, see Operators.

Functions

A drop-down list of functions is available to assist in creating the SQL text of the 
query.

For information on Query functions, see Functions.

Select All

GO>Query>Select All

The Select All menu item selects all records from a table and places the items in 
the Selection table. The selection will only select objects from a single layer. 
Discover Mobile displays a dialog to allow you to choose which table to apply the 
Select All query to.

After a Select All command is given, all the objects in the selected layer will be 
highlighted and the items placed in the Selection table.

Clear Selection

GO>Query>Clear Selection

The Selection table can be populated from a query or a Select All menu command 
(as described above). If you wish to unselect the various items in the Selection 
table, use this option (GO>Query>Clear Selection).

Find

GO>Query>Find

The Find menu item allows a fast method of interrogating data and viewing the 
selection results. With the Find dialog you can specify the target Layer and search 
for a keyword in the selected column. The keyword needs to match exactly (in 
case and spelling) with the word in the search column. 
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When items are found and the search is successfully completed, the number of 
found items is displayed in a message box. The items are also shown in a preview 
window with the found objects highlighted. You can then view and interrogate the 
objects found by the search.

Find Selection

GO>Query>Find Selection

Occasionally a query may be run and although the query successfully found one 
or more items, it may not be obvious where they are in the map window (due to 
the map zoom level). In these circumstances, the Find Selection command 
centres the display to indicate the location of the items in the Selection table.

Browse Selection

GO>Query>Browse Selection

The Browse Selection tool enables the viewing of selected map objects in a 
Browser Window. Only the map objects which were selected will be displayed in 
the Selection Browser.
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Map Menu

GO>Map

The Map menu items are used to set the Insertion Layer, add a Cosmetic Layer 
to the map display, create themes for a given layer or modify the projection of the 
map window.

Map menu

For more information, see:

• Save Window As

• Add Cosmetic Layer

• Set Insertion Layer

• Create Theme

• Modify Themes

• Map Projection
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Save Window As

GO>Map>Save Window As

Any display can be saved as a Windows compatible bitmap. The GO>Map>Save 
Window As menu option requires that a filename and folder be specified. The 
output filename specifies a bitmap having a default .BMP file extension. 

Specify the name and location to save a display window as a bitmap file

Add Cosmetic Layer

GO>Map>Add Cosmetic Layer

The cosmetic layer is a temporary layer which can be used to hold graphic 
objects. When a cosmetic layer is created it will be placed at the top of the Layer 
Control list and is set as the insertion layer.

For more information, see Adding a Cosmetic Layer

Set Insertion Layer

GO>Map>Set Insertion Layer

The Insertion Layer is where drawing objects created with the Drawing tools are 
stored. Drawing objects will be stored on the selected layer until a new layer is 
selected.
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For more information, see Setting the Insertion Layer.

Create Theme

GO>Map>Create Theme

You can change the appearance of maps with themes. For more information, see 
Thematic Mapping.

Dataset

The dataset specifies the layer to be used for the theme. The various fields 
(columns) of the dataset are shown in the list box.

Type

The theme Type determines the method of distributing the values within the 
nominated data field. Select a theme type from:

• Auto – An automatically scaled data range determined from the numerical 
data field selected.

• Ranged – A type of thematic map which displays numerical data 
according to data ranges set by the user. The ranges are shaded using 
colours or patterns.

• Bar Chart – A type of thematic map, which displays a bar chart of 
thematic variables for each record in the table.

• Pie Chart - A type of thematic map which displays a pie chart of thematic 
variables for each record in the table.

• Graduated Symbol – A type of thematic map that shows symbols (point 
objects) sized by order of magnitude representing specified threshold 
values.

• Dot Density – A type of thematic map which displays data as a series of 
tiny dots, where each dot represents some specific quantity. For example, 
in a dot-density map of rock age, each dot might represent 10,000 years.

• Individual Value - A type of thematic map that shades records according 
to individual values. 

For more information, see Theme Type.
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Theme Fields

Select the fields that the selected theme is applied to. Theme types that involve 
comparison of field values allow multiple data field selection (for example, pie and 
bar charts).

Compact Legend

The normal sized legend shows the entire sampling and the ranges used. The 
compact format shows less detail of theme style and data range. For more 
information, see Thematic Legend.

Modify Themes

GO>Map>Modify Themes

Opens the Themes dialog, from where you can modify and remove existing 
themes. 

Modify

Tap the Modify button to change the data specification, symbols, annotation and 
appearance. The displayed dialog and associated controls vary depending on the 
thematic Type being used. For more information, see Modifying Themes.

Legend

Tap the Legend button to modify the title, subtitle, text appearance, and to select 
compact or normal format. For more information, see Thematic Legend.

Remove

Removes the selected theme.

Remove All

Removes all themes.
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Map Projection

GO>Map>Map Projection

For information about the native map projection, and how this changes as you 
open tables and raster images, see Controlling the Map Projection.

Use the GO>Map>Map Projection command to specify the map projection. This 
is the projection into which objects are captured with the Drawing tools. Discover 
Mobile supports the same range of map projections as MapInfo Professional.

GPS Menu

GO>GPS

The GPS menu provides full control of GPS connections, data capture, logging, 
GPS object display styles and GPS debugging. 

• Connect

• Monitor Satellite Status

• Setup Connection

• Setup Data Capture Tables

• Default Styles
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• Center Map on GPS

• Orient Map Ahead

• Waypoint Navigation

• Capture Point

• Capture Polyline

• Capture Polygon

• Capture Structure Symbol

• Point Log

• Line Log

Connect

Go>GPS>Connect

Make a GPS connection. For instructions on setting up and connecting the GPS, 
see Connecting to the GPS.

Monitor Satellite Status 

GO>GPS>Monitor Satellite Status

The Monitor Satellite Status dialog shows the number and position of satellites 
currently in view. If a satellite is red it is not used in the GPS fix. Each available 
satellite is numbered and the corresponding signal strength is displayed as a bar 
in the Satellite Strength Plot. 

Setup Connection

GO>GPS>Setup Connection

Configure the GPS connection. For instructions on setting up and connecting the 
GPS, see Connecting to the GPS.
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Setup Data Capture Tables

GO>GPS>Setup Data Capture Tables

This option is similar to the Map>Set Insertion Layer function, but is specific to 
GPS data capture. It allows a default capture table to be specified for each GPS 
object type (point, polyline and polygon).  See Assigning GPS Capture Layers.

Default Styles

GO>GPS>Default Styles

Define default styles for different types of GPS-located objects. For more 
information, see Setting Default Styles for GPS-Located Objects.

Center Map on GPS

GO>GPS>Center Map on GPS

If GO>Preferences>Re-Center GPS is set to Never, this command will redraw 
the view with the current GPS location at the center. 

Orient Map Ahead

GO>GPS>Orient Map Ahead

The Orient Map Ahead menu option (or GPS toolbar button) will turn On/Off the 
Auto Map Rotate function. The Auto Map Rotate function will automatically 
rotate the map view so that the top of the map is oriented towards the direction of 
travel. The sensitivity of the auto map rotation can be configured using the 
GO>Preferences>GPS>Map Rotation options.

Waypoint Navigation

GO>GPS>Waypoint Navigation

The waypoint navigation tool allows the selection of an existing map object (eg 
point, polygon) as a destination waypoint; it will then report the distance and 
bearing between the current GPS location and the selected waypoint feature in a 
waypoint message window.

For more information, see Navigating to a Known Point.



6 Using the GO Menu 107

Capture Point

GO>GPS>Capture Point

Capture a GPS-located point. For more information, see Creating GPS-Located 
Objects.

Capture Polyline

GO>GPS>Capture Polyline

Capture a GPS-located polyline. For more information, see Creating GPS-
Located Objects.

Capture Polygon

GO>GPS>Capture Polygon

Capture a GPS-located polygon. For more information, see Creating GPS-
Located Objects.

Capture Structure Symbol

GO>GPS>Capture Structure Symbol

Capture a GPS-located structure symbolt. For more information, see Creating 
GPS-Located Objects.

Point Log

GO>GPS>Point Log

Record a log of the travelled path as a series of points. For more information, see 
GPS Point Log.

Line Log

GO>GPS>Line Log

Record a log of the travelled path as a series of line segments. For more 
information, see GPS Line Log.
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XRF Menu

GO>XRF

• Setup

• Connect

• Open XRF Table

Setup

GO>XRF>Setup

Setup a connection to either an Olympus Innov-X or Niton portable XRF device. 
For detailed instructions, see Appendix D:Configure the XRF Connection.

The Bluetooth COM port needs to be specified (a higher number such as 7, 8 or 
9 is recommended). This can also be setup via the Bluetooth Manager. For 
detailed instructions, see Appendix D:Setting Up the Bluetooth Connection to an 
XRF Device.

A short list of summary elements can be selected: these are the elements that will 
be listed on the second tab of the XRF output (Summary tab). All elements will 
still be listed in the following data tabs: this Summary is an excellent way of 
quickly examining just the key indicator elements of interest as each sample is 
measured.
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Connect

GO>XRF>Connect

After the Setup option has been configured, use this option to connect to the 
portable XRF device. For detailed instructions, see Appendix D:Connect to the 
XRF device.

Open XRF Table

GO>XRF>Open XRF Table

Open and view previously created XRF batch files. Note that XRF batch files do 
not need to be open to be selectable in the XRF>Connect dialog.

View Menu

GO>View

The View menu provides controls to adjust the appearance (displayed layers and 
zoom level) of the map display.

View menu

• Layer Control

• Zoom Level
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• View Entire Layer

• Map Rotation

• Map Grid

• GPS Overlay

• Scale Bar

• Show Toolbars

• Status Window

• Table Browser

• Table Structure

Layer Control

GO>View>Layer Control

The Layer Control command (also available from the Main toolbar) displays the 
Layer control dialog, from where you can control the display properties of a layer 
(.TAB file). From the Layer control dialog you can add tables, change the display 
order, control visibility, turn on editing, and display labels. 

For information on adding and removing layers, and changing the properties of 
layers in the display list, see Managing Layers.
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Dialog of the Layer Control

Display List

The Layer list controls the drawing order of the layers within it. The layers are 
drawn in order from bottom-to-top The layer order can be modified using the Up 
or Down buttons. You can add and remove layers from the list with the Add and 
Remove buttons. 

Visible

Hide and show the layer selected in the display list.

Selectable

Make objects on the layer selected in the display list selectable with tools like 
Select, Label and Info.

Editable

Make objects on the layer selected in the display list editable.

Automate labels

Annotate objects on the selected layer using the settings controlled from the 
Label button.
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Display

Change the display settings of the layer selected in the display list. With this 
option you can override the style properties of objects on the layer, hide objects 
when you zoom out from the map, and control line direction, node display and 
centroid display of polygons. For more information, see Layer and Object 
Visibility.

Labels

Change the automatic label settings on the selected layer. To apply these 
changes, the Automate labels option must be selected.

Label dialog for controlling automatic labelling

Dataset and Field

The layer (table) and field (column) to be used when labelling.

Label lines

The format of callout lines drawn between the object and the label (no line, 
simple or arrowed).

Display within range

Show labels only within a specified zoom range.
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Style

Label text style (font, size, boldness, italic, colour etc).

Allow overlapped

Allow labels to overlap.

Allow duplicates

Allow duplicated labels.

Label partial objects

Label objects that are only partially displayed.

Orientation

The orientation of the label around the object.

Maximum labels

Restrict the number of labels to be drawn.

Rotate label with line

Rotate the label with the call-out line.

Label offset

Offset the position of the label in pts.

Zoom Level

GO>View>Zoom Level

Set a precise zoom level or map scale for the map window.

Width

Set the display distance (measured in metres) for the screen width. Select from 
the preset values or type a value in the box. 

Scale

Set map window scale. Select from the preset values or type a value in the box.
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View Entire Layer

GO>View>View Entire Layer

Show the full extents of a selected layer or all layers.

Map Rotation

GO>View>Map Rotation

Rotate the map view. Adjust the slider bar or type a value into the rotation box. To 
return the map view to default (north up), drag the slider back to zero degrees or 
type 0 (zero) in the rotation value box.

Map Grid

GO>View>Map Grid

Show and hide the map grid. The map grid is displayed in the native projection of 
the current map window and is always positioned as the top most layer in the 
map. The grid interval is determined automatically by Discover Mobile to provide 
best grid spacing for the current zoom level and will be dynamically updated as 
you zoom in/out or pan around the map. 

GPS Overlay

GO>View>GPS Overlay

Show and hide the Satellite Strength Plot information in the bottom left hand 
corner of the map window. 

Scale Bar

GO>View>Scale Bar

Show and hide a dynamic scale bar on the map window. Like the map grid, the 
scale bar is automatically updated to the most appropriate distance interval as 
you zoom in and out of the map window.

Note Map rotation is not available if there are any raster image layers in the display list 
(even when the raster image is not visible in the map window).
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The scale bar is always displayed as the top most layer in the map window and 
its position is fixed in the lower right corner of the screen.

Show Toolbars

GO>View>Select Toolbar

GO>View>Drawing Toolbar

GO>View>GPS Toolbar

Use these commands to hide and show the Discover Mobile toolbars. You can 
also hide and show toolbars from the Main toolbar (see Main Toolbar).

Status Window

GO>View>Status Window

Displays a floating Status window which displays information about the view and 
GPS data.

You can customize the Status window from the Setup dialog. To open the Setup 
dialog, hold the stylus over the Status window.

Some of the Setup options displayed from the Status Window
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Map Window

• Screen Width – displays the distance across the screen in metres

• Insertion Layer – displays the name of the current Insertion Layer

GPS Map Coordinates

• Map X – displays the current X (Easting or Longitude) position received 
from the GPS in the map Session Projection. To change the coordinate 
display to another projection use the GO>Preferences menu and change 
the Session Projection to the required format.

• Map Y - displays the current Y (Northing or Latitude) position value 
received from the GPS in the map Session Projection. To change the 
coordinate display to another projection use the GO>Preferences menu 
and change the Session Projection to the required format.

GPS Recommended Min Data (RMC)

The information in this section includes GPS data received from the RMC 
(Recommended minimum data) sentence of the NMEA data stream. An example 
of this data sentence in provided below:

$GPRMC,044912.280,A,3753.0880,S,14500.0965,E,0.19,,210503,,*05

The information reported from the RMC sentence includes:

• Lat – Latitude position in decimal degrees referenced to the WGS84 
ellipsoid

• Long – Longitude position in decimal degrees referenced to the WGS84 
ellipsoid

• Date – Date taken from the GPS and converted into the current date 
format on the PPC

• Time – Time taken from the GPS and converted into the current time zone 
format on the PPC

• Full Time – Date and Time taken from the GPS and converted into the 
current data and time format on the PPC

• Speed – Speed over the ground and reported in kilometres per hour

• Course – Course over the ground measured in degrees clockwise from 
north
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• Warning – Current status of RMC data from the GPS. Possible values 
include: 

True = No RMC data available

False = Valid RMC data available

• Mag Variation - magnetic variation between true north and magnetic 
north reported from the GPS 

GPS Fix Information (GGA)

Contains GPS information received from the GGA sentence of the NMEA data 
stream. The GGA sentence provides 3D position location data and accuracy 
information. An example of this data sentence in provided below:

$GPGGA,044913.280,3753.0882,S,14500.0964,E,1,04,7.8,19.5,M,,M,,0000*63

The information reported from the GGA sentence includes:

• Lat – Latitude position in decimal degrees referenced to the WGS84 
ellipsoid

• Long – Longitude position in decimal degrees referenced to the WGS84 
ellipsoid

• Altitude – Altitude measured in metres above sea level

• GMT – Time GPS fix was obtained in Universal Time (UTC) or Greenwich 
Mean Time (GMT) format

• Quality – Quality of the GPS fix. 

• No Fix = no GGA data available 

• GPS = Standard GPS fix

• DGPS = Differential GPS fix

• Num Sats. – Number of satellites currently being tracked

• H. Dilution – Horizontal dilution of precision
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GPS GNSS DOP (GSA)

Contains GPS information received from the GSA sentence of the NMEA data 
stream. The GSA sentence provides details on the nature of the GPS fix, the 
number of satellites being used to calculate the current position and the dilution 
of precision (DOP). The DOP is an indication of the effect of satellite geometry on 
the accuracy of the fix. The DOP is a unit less number where the smaller the value 
the better. For a 3D fix, a value of 1.0 would be considered almost perfect.

An example of this data sentence in provided below:

$GPGSA,A,3,28,07,08,04,,,,,,,,,12.5,7.8,9.8*0B

The information reported from the GSA sentence includes:

• Mode – GPS selection mode. Options are Auto 2D/3D or Forced 2D/3D

• Fix Type – GPS fix type. Values include: No Fix, 2D Fix or 3D Fix. To 
obtain a 3D fix the GPS must be tracking 4 or more satellites.

• P. Dilution – Dilution of Precision (PDOP)

• H. Dilution – Horizontal Dilution of Precision (HDOP)

• V. Dilution – Vertical Dilution of Precision (VDOP)

GPS Satellites in View (GSV)

Contains GPS information received from the GSV sentence of the NMEA data 
stream. The GSV sentence provides data about which satellites may be able to 
provide GPS information, based on its viewing mask and almanac data.

Examples of this data sentence are provided below:

$GPGSV,2,1,08,07,83,111,36,28,42,115,43,26,38,283,,29,32,313,*79

$GPGSV,2,2,08,08,24,047,45,09,24,226,,04,20,026,44,11,08,138,*74

The information reported from the GSV sentence includes:

• Sats – Unique satellite numbers used for the position solution
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Table Browser

GO>View>Table Browser 

Use this command to view data records within a table. You can enter new data or 
modify existing data in this browser view. To display the attributes for a single map 
object, use the Info icon on the Select/View Toolbar.

Table Structure

GO>View>Table Structure

Use this command to display a summary view of the fields (columns) within a 
layer and their associated data types. You can view the structure of different 
tables but you cannot modify the table structure.

Edit Menu

GO>Edit

The Edit menu consists of five grouped options and appears as shown: 

The Edit menu options

• Buffer

• Edit Mode
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• Clear Custom Labels and Annotations

• Delete

• Raster Transparency

• Selected Point Location

• Selected Object Style

• Quick Pick Options

• Hardware Button Options

• Named Styles

• New Object Styles

• Range Styles

• Apply Range Style

Buffer

GO>Edit>Buffer

A buffer selects objects that fall within a given distance of one or more selected 
objects. 
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Buffer each object separately

Create a buffer around each selected object.

Buffer all objects into one per layer

Create a single buffer around all selected objects.

Distance

Type the buffer distance.

Unit

Choose the unit of measurement for the buffer distance.

Edit Mode

GO>Edit>Edit Mode>Feature Edit Mode

GO>Edit>Edit Mode>Add Edit Mode

GO>Edit>Edit Mode>Node Edit Mode

The edit modes enable different editing operations on selected objects. For 
information on how to use these modes, see Editing Objects.
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Clear Custom Labels and Annotations

GO>Edit>Clear Custom Labels

GO>Edit>Clear Annotations

Removes all custom labels or annotations from the Annotation Layer. Individual 
labels and annotations cannot be removed.

Delete

GO>Edit>Delete

Removes all selected objects from editable layers. 

Raster Transparency

GO>Edit>Raster Transparency

Controls the level of transparency of a selected layer. Use the slider bar or type a 
percentage value into the box between 0 (opaque) and 100 (transparent).
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Selected Point Location

GO>Edit>Selected Point Location

Edit the coordinates of a selected object.

Selected Object Style

GO>Edit>Selected Object Style

Modify the appearance of a symbol, line or polygon object. The dialog displayed 
depends on the type of object selected. For more information about using the 
style dialogs, see Formatting Drawing Objects.

Symbol Style

Modify symbol style, size and colour and symbol rotation. 

Line Style

Modify line style, line thickness (in either pixels or points (32 points equals 2.54 
cm or 1 inch) and colour. A preview sample of the line style is displayed.

Fill Style

Modify fill patterns, colour and outline style of polygon objects.

Quick Pick Options

GO>Edit>Quick Pick Options

The Quick Pick menu option allows users to set actions for data entry fields prior 
to capturing or creating map objects. These actions may include incrementing or 
decrementing values from a starting value, updating fields with an object X and Y 
centroid coordinate, object area, perimeter, length or object rotation angle. If you 
do not wish to assign an action to a field in the table select Quick Pick as the 
default action.

Note It is recommended you use the Desktop Picklist Editor tool to create and edit 
picklists (Quick Pick options, auto-picks and special fields are synonyms).
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Quick Pick Table Setup

For more information, see Quick Pick Fields.

Hardware Button Options

GO>Edit>Hardware Button Options

Select Function

Choose a function from the pull-down list and then press the desired hardware 
button on the hand-held device.

Check for Mapped Buttons

Select to use an existing button mapping configured through Windows 
(Start>Settings>Buttons).

Named Styles

GO>Edit>Named Styles

Assign named styles when creating new objects such as points, lines and 
polygons. Styles can also be linked to specific tables, with specific Quick Pick 
options for each style. 

For more information, see Applying Named Styles.
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New Object Styles

GO>Edit>New Object Styles

Set the default display style for newly created objects. The default styles can be 
applied to symbols, lines and polygons.

For more information, see Setting Default Styles for New Drawing Objects.

Range Styles

GO>Edit>Range Styles

The symbol style of numeric point data can be permanently altered with a Range 
Style library. This functionality is similar to the Point Classification tool in the 
Discover Geochem module.

A Range Style library consists of a series of user-defined numeric ranges, each 
with an assigned symbol style. These libraries can be created within Discover 
Mobile with the Go>Edit>Range Styles option (see Range Styles for more 
information), or (recommended) via the Discover Mobile desktop Range Style 
Editor.

Apply Range Style

GO>Edit>Apply Range Styles

Apply a Range Style library to a numeric field of a selected table. This is a one-
off permanent style change (see Range Styles for more information).

Range Styles can also be automatically applied as XRF data is captured (see 
Appendix D:Applying Range Styles for more information)

File Menu

GO>File

The File menu item is used to:

• open and restore  recently accessed files

• create and open tables

• close individual or all open tables
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• make copies of a table

• save a map session (Geoset) describing all opened tables and their 
display characteristics.

File menu

• Recent Files

• New Table

• Open Table

• Close Table

• Close All Tables

• Save Table Copy As

• Save Geoset

• Edit Table Structure

• Pack Table
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Recent Files

GO>File>Recent Files

Any recently used Tables or Geosets are listed in the Recent Files option of the 
File menu. Highlight the required table or Geoset, and press OK to open the file 
into Discover Mobile. Alternatively, double click on the target file to open it.

New Table

GO>File>New Table

Use this command to create new (.TAB) tables directly in Discover Mobile. Tables 
used in Discover Mobile are identical to those used in MapInfo Professional. You 
can also create and maintain tables on your desktop PC using MapInfo 
Professional and then transfer these to Discover Mobile for use in the field. 

New Table dialog accessed from the File>New Table menu item

Create Layer

The name and location of the new table is displayed in the File box. To edit, tap 
the browse button.

Fields

Displays the fields in the new file. Tap the Setup Fields button to add and remove 
fields (columns) in a table.
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Setup Fields

Creation of new data fields for a new table

Add

To add a user-defined field, tap the Add button. A new entry titled 
NewField will be added to the field grid. You can assign a name to the field 
by tapping on the NewField entry and typing in the required field name.

Delete

If a field is added by mistake or is not required you can remove it by first 
selecting it with the stylus and then tapping the Delete button. Removal of 
a field is permanent and a message confirming the deletion is displayed.

Auto Fields

You can also choose to add Auto fields from the drop-down list next to the 
Add button. Auto fields are predefined fields which automatically capture 
information from the attached GPS receiver. To add an auto field, select 
the required field name from the list and the entry will be added to the field 
grid. The data type and size will then be set for that field type. Any Auto 
Fields which exist in a table will be automatically updated when capturing 
objects via the GPS.
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Name

The default name for a new field is NewField. A field name can be up to 31 
alphanumeric characters in length. You can use any combination of letters, 
numbers or an underscore.  Any spaces in a field name will be automatically 
replaced with underscore character ("_"). Field names cannot start with a number 
and cannot contain any reserved characters (eg $,%, *, &,?,<,> etc). You can use 
upper and lowercase for legibility but Discover Mobile ignores case when 
referring to column names.

Type

The field type is displayed. The following types are available from the drop-down 
list:

• String - Stores up to 254 alphanumeric characters. You cannot perform 
arithmetic operations on character fields. 

• Decimal - Stores numbers in decimal form. Do not use commas when 
entering numeric values. 

• Date - These fields can contain a calendar date in the format MM/DD/
YYYY. The year can be specified by two or four digits and is optional. Use 
slashes or hyphens to separate components of a date. The following are 
valid dates: 01/23/91, 5-6-1989, 10/07. 

• Integer - Stores integers or whole numbers (numbers without a decimal). 
The range is from approximately -2 billion to +2 billion.  

• Small Integer - Integers between -32,767 and +32,767.

• Float - Stores numbers in floating-point decimal form.

• Logical - These fields contain only True/False or yes/no information, 
stored as integer values. A True/Yes value is stored as "1" and a False/No 
value as "0".

Note The Map_X & Map_Y auto fields will automatically capture object coordinates in 
the user-defined projection set with GO>Preferences>Session (the default is 
Longitude/Latitude WGS84). 

The Pos_Lat and Pos_Long fields will always automatically capture object 
coordinates in Longitude/Latitude WGS84. 

These GPS fields can be assigned automatically to custom fields (of the 
appropriate type) using the Auto Fields options.
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Size

Type the number of characters in the field (string and decimal fields only). 
Maximum field width is 254 for character fields and 10 for numeric fields. The 
width of a decimal value includes the total number of numeric characters, 
including the decimal point.

Projection

All table (*.TAB) files in MapInfo Professional which have graphic objects (i.e. a 
*.MAP file) have an assigned native map projection. When you create a new table 
in Discover Mobile the native map window projection will initially default to 
Latitude/Longitude (WGS84). You can specify an alternative projection for the 
table by selecting Set Projection option in the New Table dialog. Discover Mobile 
supports the same range of map projections that are used in MapInfo 
Professional. 

Select the projection Category and then the Category Member

When creating new tables in Discover Mobile it is strongly recommended to use 
the same map projection for all tables. Although Discover Mobile can dynamically 
transform map objects from one projection to another on-the-fly, this process is 
very resource intensive and can significantly increase the time taken to redraw 
the map window. If you wish to capture data from a GPS it is recommended that 
you set the native map projection for the table to be Latitude/Longitude WGS84. 
You will then be able to capture new objects in their native projection (raw GPS 
position information references the WGS 84 ellipsoid). These objects can then be 
converted into any other map projection using MapInfo’s File>Save Copy As 
command.
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Set Bounds

The Set Bounds button is used primarily when a non-earth projection is selected. 
The Easting and Northing table bounds can be set using this option.

Clone From

When creating new tables it is often convenient to use the structure and projection 
of an existing table as a template, particularly if you wish to add several new fields 
to an existing table. To use an existing table as a template tap the Clone File 
button. Discover Mobile will then prompt you to choose any one of the open tables 
as a template for the new table. Discover Mobile will then clone structure of this 
table and use it for the new table.

Open Table

GO>File>Open Table

Use this command to open .TAB tables (created with Discover Mobile, MapInfo 
Professional, or Discover), .TAB files with referenced raster files (.BMP, .TIFF, 
.GIF, JPG, .PCX, .SPOT, .ECW), GeoTIFF images (without an associated TAB 
file), and Geoset files.

Close Table

GO>File>Close Table

Use this command to close any open table. 

Close All Tables

GO>File>Close All Tables

Use this command to close all open tables. Note that when closing all tables, the 
map display will show no data.

Note Any Quick Pick options setup for the source table will be copied across for the 
cloned table. 

Note No data will be transferred to the new table from the old table; only the table 
structure will be copied.
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Save Table Copy As

GO>File>Save Table Copy As

A new table can be created from any open table providing it is not a raster table. 
The original table remains unchanged and open for all further edits. 

Save a copy of a table dialog

Layer

The layer that you want to copy.

File

The name of the new layer and where the table is stored. Tap the browse button 
to edit.

Fields

The fields to be copied to the new table are displayed. To add or remove fields, 
tap the Setup Fields button.

Note Using Close All Tables will also disconnect a GPS connection.
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Setup Fields

For information about fields and their properties, see Fields.

Set Bounds

Use this button to change the coordinate bounds of the new table.

Set Projection

Use this option to change the map projection of the new table.

Save Geoset

GO>File>Save Geoset

A Geoset is a table where a workspace is saved. A Geoset saves the state of all 
open tables plus the characteristics of displayed objects, including style 
overrides, zoom layering, map projections and zoom details.

For more information, see Saving and Restoring Your Workspace.

Edit Table Structure

GO>File>Edit Table Structure

An pre-existing MapInfo Professional vector table structure can be edited. Fields 
can be either added, deleted, renamed, field size changed.

Important Make sure that you fully define the table structure when it is first created or 
copied, because it cannot be changed later.

Note The Save Table Copy As function will copy both the source tables structure and 
data into the new table.

Note When modifying large tables this process make take sometime to complete so 
you will need to be patient, or perform on a subset of the table.
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Pack Table

GO>File>Pack Table

When map objects are deleted from the Map Window the record in the Browser 
Window remains as an undeleted row and therefore the row and map object 
counts can be different. It is also a good idea to pack a table to make it perform 
more efficiently.
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7 Controlling Layers and the View
In this section:

• About Layers

• Managing Layers

• Layer and Object Visibility

• Managing Objects in Layers

• View Controls

• Display View Settings

About Layers

A layer is a table (.TAB) which contains data objects (points, lines, and polygons) 
with attributes (fields). For information on creating and managing tables, see 
Managing Tables. You can add tables to the display, change the order of display, 
control visibility, make the layer editable, and display labels. For information on 
controlling layers, see Managing Layers.

Editable Layers

Editing of objects can be done on any layer specified as editable. Discover Mobile 
operates differently from MapInfo Professional in that it allows simultaneously 
editing of multiple layers. You can move, reposition, resize, format, and delete 
objects on any editable layer. To make a layer editable, see Managing Layers.

Selectable Layers

Many Discover Mobile functions require that map objects be selected before 
performing a particular operation. To use the Select tool, Label tool or Info tool 
you must first make the layer selectable. Like layer editing, more than one layer 
may be selectable at the same time. However, you can only select an object from 
one layer at a time. If two objects overlap and you need to select one of those 
objects then you will need to turn off the table selection property for the object 
which is not required. To make a layer selectable, see Managing Layers.
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Insertion Layer

New drawing objects are added to the current insertion layer. Discover Mobile 
operates slightly differently to MapInfo Professional in that it supports the editing 
of multiple layers, so the user must specify which one of the editable layers to add 
the new objects to. For information on setting the insertion layer for drawing 
objects, see Setting the Insertion Layer.

GPS Capture Layers

New GPS-located objects are added to capture layers specific to each object 
type. For information on setting GPS capture layers, see Assigning GPS Capture 
Layers.

Cosmetic Layer

The Cosmetic Layer is a temporary layer which can be used to hold graphic 
objects. Unlike MapInfo Professional, the Cosmetic Layer in Discover Mobile is 
an optional layer. If a Cosmetic Layer has been added to the map then it will be 
automatically set as the Insertion Layer. For more information, see Adding a 
Cosmetic Layer.

Managing Layers

Tap the Layer Control tool (or choose GO>View>Layer Control) to display the 
Layer Control dialog, from where you can control the display properties of 
selected tables.
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Layer Control dialog

The display list shows the drawing order of the current layers. Layers are drawn 
from bottom-to-top. Image layers should be placed at the bottom of the list to 
prevent them from obscuring vectors, drawing objects, and text.

To change the display order:

• In the display list, select a layer, and then tap the Up and Down buttons.

To add new layers:

• Tap the Add button.

Adding a layer from the Layer Control dialog is the same as opening a 
table with the GO>File>Open command (see Opening Tables).

To remove a layer from the display:

• In the display list, select a layer, and then tap the Remove button.

Removing a layer from the Layer Control dialog is the same as closing a 
table with the GO>File>Close Table command (see Closing Tables).

To make a layer editable:

1. Tap the Layer Control tool (or choose GO>View>Layer Control) to display 
the Layer Control dialog.
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2. In the display list, select a layer, and then tap the Editable check box.

When you close the Layer Control dialog, the layer will be editable and the 
appropriate tools on the Draw/Edit toolbar are available.

To make a layer selectable:

2. In the display list, select a layer, and then tap the Selectable check box.

Layer and Object Visibility

Often it is convenient to have a layer open but not visible. The layer control can 
be used to turn the visibility of a layer off, removing it from the display without 
closing the table.

You can also control the visibility of objects on a layer based on a zoom range. 
Specifying the zoom range for which a raster layer is visible can greatly increase 
map redraw speed and remove unnecessary detail from the map display at larger 
zoom levels, particularly when dealing with complex or detailed map layers.

To change the visibility of a layer:

2. In the display list, select a layer, and then tap the Visible check box.

To change the visibility of objects when zooming:

2. In the display list, select a layer, and then tap the Display button.

3. Select the Display withing range check box and type the range in the 
Min and Max boxes.

4. Ensure the Automate labels check box is selected for the layer.

1. Tap the Layer Control tool (or choose GO>View>Layer Control) to display 
the Layer Control dialog.

1. Tap the Layer Control tool (or choose GO>View>Layer Control) to display 
the Layer Control dialog.

1. Tap the Layer Control tool (or choose GO>View>Layer Control) to display 
the Layer Control dialog.
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Managing Objects in Layers

New drawing objects are added to the current insertion layer. You can also create 
a temporary cosmetic layer which can be used to hold graphic objects. If a 
cosmetic layer has been added to the map then it will be automatically set as the 
insertion layer. You can add labels to objects with any field in the table, and 
control the format and visibility of the labels.

GPS-located objects are not added to the insertion layer, but are added to GPS 
capture tables assigned for each type of GPS object.

• Setting the Insertion Layer

• Assigning GPS Capture Layers

• Adding a Cosmetic Layer

• Labelling Objects

Setting the Insertion Layer

Before adding drawing objects to the map window, you must choose which layer 
the objects are added to.

The current insertion layer will remain selected for as long as the current object 
type (point, polyline or polygon) remains active. For instance, if the Point capture 
button is enabled when the insertion layer is set to ‘soils’, all points captured will 
be automatically inserted into the ‘soils’ table. As soon as a different object type 
is selected (e.g. polygon), the Insertion Layer dialog will be displayed so that you 
can select another table. 

To change the insertion layer:

1. Choose GO>Map>Set Insertion Layer.

The current insertion layer is highlighted.

Note Zoom layering can also be set in MapInfo before transferring data to Discover 
Mobile. Zoom layering is set in the Display option of the MapInfo Professional 
Layer Control.

To determine which layer is currently set as the insertion layer, tap the Status 
Window tool on the Main toolbar, or choose GO>View>Status Window 
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2. From the list of displayed layers, select the required layer.

3. If you want to store all data types on the same layer (e.g. the “geology” 
table), select the Set as Default Layer option. Otherwise the selected 
table will only remain as the insertion layer for as long as the current 
drawing object type is selected.

4. Press OK.

Insertion dialog used to specify a layer for editing

To add objects to a different layer, reopen the Insertion Layer dialog and select a 
different layer from the list.

Assigning GPS Capture Layers

A default capture table needs to be specified for each GPS object type (point, 
polyline and polygon). This can simplify field data capture, removing the need to 
respecify the capture table for each new data type. For example, all polygonal 
objects captured by the GPS can be assigned to a geological mapping polygon 
table, whilst point data can be assigned to a soil sample table. If a number of 
tables are being used to enter objects into choose the “Prompt for Layer Name” 
option to enable different tables to be selected to store captured data.

Note When a layer is selected as the insertion layer, it is automatically made editable 
and the Draw/Edit tools are made available.
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To setup capture tables:

1. Choose GO>GPS>Setup Data Capture Tables.

2. Under Points, Lines and Regions, select the default capture layer for 
new GPS-located objects.

Setting default tables for each object type can simplify field data collection

Adding a Cosmetic Layer

To add a cosmetic layer to the map window use GO>Map>Add Cosmetic Layer. 
When a cosmetic layer is created it is placed at the top of the display list (i.e. it is 
drawn last). You can alter the position of the cosmetic layer like any other layer 
(see Managing Layers). 

When a cosmetic layer is added to the map window it is automatically set to be 
the insertion layer even if another layer has been previously been set as the 
insertion layer.

The cosmetic layer is a temporary layer and all inserted objects are held in 
memory. If Discover Mobile is shutdown, then the contents of the cosmetic layer 
are discarded.

Note To automatically use multiple insertion tables for a single object type (such as 
point data into various soil, lag and rock-chip tables), utilise the auto-table 
assignment functionality within Named Styles.
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To save objects in the cosmetic layer:

1. Choose GO>File>Save Table Copy As.

2. Select the cosmetic layer from the list of available tables, and save it as a 
new table.

To remove objects from the cosmetic layer:

1. Select the objects using one of the select tools or, to select all objects in 
the layer, choose GO>Query>Select All

2. Tap the Delete tool or choose GO>Edit>Delete.

Labelling Objects

The Layer Control provides an option for automatically labelling objects within a 
layer using an attribute column in the table. Select the layer you wish to label and 
then tap the Labels button. The Labels dialog is displayed from where you can 
adjust the label placement options. After setting the label properties, return to the 
Layer Control dialog and select the Automate Labels check box.. All objects in 
the selected layer table will be labelled with their corresponding attribute.

Label dialog accessed from the Layer Control for automatic labels

For information about the labelling options on this dialog, see Labels.
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View Controls

• Zoom and Scale

• Pan and Center

• Rotate

• Map Grid

• GPS Overlay

• Scale Bar

• Save and Restore View

Zoom and Scale

A selection of tools are provided for controlling the scale or zoom level of the 
display.

• Set Zoom Width and Scale

• Zoom In and Out

• View Extents

Set Zoom Width and Scale

Zoom Level dialogs – setting zoom level by screen width or map scale

The zoom level can be set either from the Previous Zoom tool on the Select 
toolbar (tap the arrow button next to the tool) or by choosing GO>View>Zoom 
Level. This allows you to specify a precise zoom level or map scale for the map 
window.
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The map zoom level can be set using one of two methods:

• The Width option allows you to set the display distance (measured in 
metres) for the screen width. A range of preset values are available via the 
selection list, however you can also type any value you require in the box.

• Alternatively, the map window display can be specified using a preferred 
Scale. A range of preset scales are available via the selection list, 
however, you can also enter an alternative scale in the box if required. The 
Scale option will adjust the map zoom level so the contents are displayed 
at the selected scale.

Zoom In and Out

View Extents

Choose GO>View>View Entire Layer to display the full extents of a selected layer 
or all layers.

Pan and Center

Rotate

Discover Mobile provides an option to interactively rotate the map view. This 
option is only available for vector layers and cannot be used if a raster layer is 
present in a map window. Choose GO>View>Map Rotation to display the 
rotation dialog. Adjust the slider bar to set the map rotation angle or type a value 
into the rotation box. To return the map view to default (north up), drag the slider 
back to zero degrees or type 0 (zero) in the rotation value box.

The Zoom In and Zoom Out buttons on the Select toolbar increase and 
decrease the view scale. To use, select one of the tools and then tap inside the 
display. The view magnifies by a factor of 2x or 0.5x centred at the point of the 
stylus tap. Alternatively, tap and drag the stylus to define a zoom rectangle.

Note For large or complex datasets, it may take a long time to draw the entire layer.

The Pan and Center tools share the same position on the Select toolbar. Tap 
the arrow button next to the tool to select the other tool. To pan the view, tap the 
tool button, and then tap and drag the stylus on the map in the direction you want 
the map to move. To centre the view, tap the tool button, and then tap the display 
where you want the new centre of the display to be positioned.
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Map Rotation dialog and slider bar

The rotation angle is measured in degrees and can range in value from 0 – 360. 
The bearing is measured clockwise from North. 

Auto-Rotate and Auto-Centre

These functions are only available when the GPS is connected.

Note Map rotation is not possible when a raster image layer is listed in the Layer 
Control dialog (even when the raster image is not visible in the map window).
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Auto-Rotate View

Auto-Centre View

Set the GO>Preferences>Re-Center GPS setting to Always, to keep the current 
location centred in the map window. If this option is set to Never, you can also 
manually recentre the view by choosing GO>GPS>Center Map on GPS. If you 
wish to quickly re-center the map on the GPS navigate to the Auto Rotate Map 
button and select the option Center Map on GPS.

Map Grid

You can display a dynamic map grid over the contents of the map window. The 
map grid is displayed in the native projection of the current map window and is 
always positioned as the top-most layer in the map. The grid interval is 
determined automatically by Discover Mobile to provide best grid spacing for the 
current zoom level and will be dynamically updated as you zoom in/out or pan 
around the map.

Auto Rotate Map button will turn on/off the Auto Map Rotate function. The Auto 
Rotate Map function will automatically rotate the map view so that the top of the 
map is oriented towards the direction of travel. The auto map rotation 
preferences can be configured using the GO>Preferences menu. Two settings 
are available for the auto rotate function.

• Rotation Degree Tolerance - specifies the angular difference required 
between two consecutive points before the map view will rotate. The 
recommended and default value is 45 degrees although the value can be 
set to any integer between 0 and 360 degrees. 

• Speed Tolerance – specifies a speed value below which the map view 
will not rotate. By adjusting the Speed Tolerance you can control the 
rotation so that the map view will only rotate if the GPS speed across 
ground is greater than the set value. This setting is useful to prevent the 
map view from rotating when you are standing still or travelling slowly. The 
default value is 2 km/hour.
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Discover Mobile map window showing the dynamic map grid displayed over a geology map

To show and hide the map grid:

1. Choose GO>View>Map Grid and turn on or off the map grid display.

Grid Format

You can set preferences for the number of grid lines which are displayed on the 
map, the size and colour of the grid labels and the style, width and colour of the 
grid lines on the Grid Overlay properties dialog. The actual number of grid lines 
which are displayed on the map may vary at different zoom levels from the 
preferred number entered on the setup dialog to maintain an even grid spacing 
interval for the current zoom level and map window extents.

To change the display properties of the grid:

1. Choose GO>Preferences.

For more information, see Grid Overlay.

2.  Under Session, select Grid Overlay and open the setup dialog.

3. Set the number of lines, label size, label colour, and line style. width and 
colour.
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Grid Projection

You can override the default grid projection so that it is displayed in a different 
coordinate system to the map window. The user projection will override the native 
map window projection so that the map grid will always be displayed in the user 
coordinate system rather than the native map projection.

To change the map grid projection:

1. Choose GO>Preferences.

2. Under Session, select User Projection and open the setup dialog.

For more information, see User Projection.

Rotated Grids

The dynamic map grid can be used when the Map Rotation function is active (see 
Rotate) providing there are no raster layers present in a map window. When the 
Map Rotation function is active and the map grid is displayed, you may not be able 
to see all the text labels for each grid line as they may be positioned off the screen.

Important Take care when overriding the Default Map Projection with a User Projection. 
This may reduce map redraw performance and it will also override the default 
map projection when creating or capturing new objects to a table.
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GPS Overlay

You can display the Satellite Strength Plot information in the bottom left hand 
corner of the map window. Use the GO>View>GPS Overlay command to hide 
and show the GPS information.

Discover Mobile map window showing the Satellite Strength Plot as series of green bars 
in bottom left of screen. 

Scale Bar

You can display a dynamic scale bar on the map window. Like the map grid, the 
scale bar is automatically updated to the most appropriate distance interval as 
you zoom in and out of the map window.

The scale bar is always displayed as the top most layer in the map window and 
its position is fixed in the lower right corner of the screen. The Scale Bar uses the 
same line colour and label size properties as the map grid (see Map Grid).

To change the distance units:

1. Choose GO>Preferences.

2. Under Session, select Distance In and choose the distance units.

Note Changing the distance units will also affect the operation of the distance 
measurement tools on the Select/View toolbar.
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Discover Mobile map window showing the dynamic Scale Bar in the lower right corner of 
the map window

Save and Restore View

Restoring a view will return the map display to the same scale and map centre at 
the time it was saved. It will not reopen layers that were in use when the view was 
originally saved. If you want to save a view which includes all associated map 
layers and display properties you need to save a Geoset. For details refer to the 
Saving and Restoring Your Workspace.

Tap the arrow button to select a saved view and to display the functions available 
from this tool:

Save View – saves the current view properties with a unique name. Multiple 
views can be defined and restored directly from the pop-up menu. Note that only 
the display area properties are saved, not the view contents. 

Delete View – deletes a saved view from the list.

Display View Settings

Information about the view settings is available from the Status Window.This is a 
floating window displays the following information:

The Previous Zoom button on the Select/View toolbar provides a selection of 
options for saving and restoring multiple views.



7 Controlling Layers and the View 151

• The screen width (in metres) of the map window display .

• The current object Insertion Layer.

• GPS information such as GPS position, GPS Map Position, Date, Time, 
Speed, Fix Dilution, Number of Satellites etc.

Floating Status Window displayed

The display and contents of the Status window can be customized.

To hide and show the Status window:

To change the window size and font:

• You can adjust the size of the Status window by dragging the red box in 
the lower right corner. Discover Mobile will remember the size and position 
of the window when you next activate the Status Window.

• You can also adjust the display size of the text in the Status Window with 
the Font Size setting under the GO>Preferences>System Settings 
command.

• Tap the Status Window tool on the Main toolbar or choose 
GO>View>Status Window.
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To change the information displayed in the Status window:

1. Hold the stylus over the Status window until the the Setup dialog is 
displayed.

2. Check or clear a check box to add or remove that item from the Status 
Window.

Some of the Setup options displayed from the Status Window

The items available for display in the Status Window are described in Status 
Window.

You can also tap GPS Display Settings  button on the GPS toolbar to configure 
the GPS information in the Status window.
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8 Working with Maps
In this section:

• Thematic Mapping

• Controlling the Map Projection

• Raster Transparency

For information about individual commands used to control the map display, see 
Map Menu

Thematic Mapping

The display of map objects (points, lines and polygons) can be modified with a 
temporary fill pattern or colour based on the value of attributes associated with an 
object (eg. geology type, size, geological age, date). Such shading is called 
"thematic mapping" or "theme” mapping.. An example of a thematic map display 
is shown below:

Thematic geology map based on the ages of mapped unit

• Creating a Theme

• Theme Type
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• Thematic Legend

• Modifying Themes

Creating a Theme

When creating a theme, objects with attributes of similar value are shaded with 
the same thematic colour. To add a theme layer to a map use the 
GO>Map>Create Theme command. The following dialog will be displayed:

The dialog to specify a theme

The dataset specifies the layer to be used for the theme. The various fields 
(columns) of the dataset are shown in the list box. The type of theme is defined 
by the Theme Type pick list.

The Theme Type determines the method of distributing the values within the 
nominated data field.

Note For a permanent style modification, use Range Styles.
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Available theme Types

Depending on the theme Type selected, one or more layers may be selectable 
from the available list. Theme types that involve comparison of data field values 
allow multiple data field selection (eg pie and bar charts).

Theme Type

• Ranged Thematic Maps

• Bar Chart Thematic Maps

• Pie Thematic Maps

• Graduated Symbol Thematic Maps

• Dot Density Thematic Maps

• Individual Value Thematic Maps

Ranged Thematic Maps

A Ranged Thematic Map displays table data according to ranges you specify.  
The ranges are shaded with colours and/or patterns. Ranged thematic maps 
allow you to illustrate data values across points, lines and regions. They are used 
to show a relationship between the data values and geographical area (e.g. assay 
figures, geochemical sampling results) or to present ratio information such as 
assay result density (copper geochemical results divided by area). 
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Below is an example of a range thematic map showing the use of colour to 
modulate the copper data value at each sample site in a geochemical sampling 
grid.

Ranged thematic map of geochemical sampling for copper using colour

Bar Chart Thematic Maps

Bar charts can be used to analyse multiple variables per record. Comparing the 
size of bars in each chart can be useful for obtaining information about a set of 
values in a table or comparing one bar in all the bar charts can also help draw 
conclusions about a variable across all records in a table. Thin lines extending in 
the opposite direction to the bar chart orientation indicate negative values in the 
column. Negative values do not display in stacked bar charts.

An example of a bar chart thematic map using assay geochemical sample results 
is shown below.
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Example bar chart thematic map with expanded legend

Pie Thematic Maps

Pie charts are multi-variable displays and can be used on a map to analyse 
several variables at a time. You can compare the size of the pie wedges in each 
chart to obtain information about a record in the table, or compare one pie wedge 
in all of the pie charts to draw conclusions about a variable across all the records. 
Pie chart diameters can also be compared to obtain information about the entire 
data set.

An example of a pie chart map is shown below relating various assay values.
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Example pie chart thematic map with expanded legend

Graduated Symbol Thematic Maps

Graduated symbol maps show data points with specific numerical values such 
that the size of the symbol for each record in your table is directly proportional to 
the data values. It is useful for illustrating quantitative information, such as high-
to-low rankings. The size of the symbols is proportional to the data values of the 
points. Points that have larger data values appear larger and points that have 
smaller data values appear smaller..

Dot Density Thematic Maps

Displays the data values as dots on your map where each dot is equal to a 
number and the total number of dots in a region is proportional to the data value 
for that region. A dot density map allows you to examine raw counts of data (e.g. 
gold assays or stream sediment samples). Each dot represents a number of units. 
That number, multiplied by the total number of dots in the region, equals the data 
value for that region.
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Individual Value Thematic Maps

Individual value thematic maps allow you to shade records according to unique 
attribute values in the table. Individual value templates can be multi-variable. 
Choose from shaded lines, points or regions. A thematic map that draws map 
objects according to individual values is useful when you want to emphasise 
categorical differences in the data rather than show quantitative information (for 
example types of samples in a given area, zoning classifications in a given area 
etc.).

Thematic Legend

The legend associated with thematic maps can be in either a compacted or 
normal presentation style, which can be selected when either creating the theme 
or from the Themes dialog (see GO>Map>Modify Themes).

Types of legends both Compacted and Normal

The compact format shows only the minimal information of theme style and data 
range. The normal sized legend shows the entire sampling and the various 
ranges used.

To reposition the legend:

• Legends can be positioned on the screen by selecting and dragging the 
stylus to a new, more convenient location. Similarly, by selecting a legend 
corner, you can resize the area covered by the legend.
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To edit the legend:

1. Display the legend format dialog in two ways:

• Double-tap the legend.

• Choose GO>Map>Modify Themes, select a theme, and tap the 
Legend button.

2. Modify the title, subtitle, text appearance, and choose compact or normal 
format.

Legend format dialog

3. Tap OK.

Note The controls provided in the legend dialog may alter depending on the legend 
and Theme Type used.
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Modifying Themes

Themes can be modified from the modify themes dilaog, which displays a list of 
existing themes.

Modify themes dialog

To modify a theme:

1. Choose GO>Map>Modify Themes to display the modify themes dialog.

2. Select a theme from the list, and tap Modify.

3. Edit the data specification, symbols, annotation and appearance. The 
displayed dialog and associated controls vary depending on the thematic 
type being used. Below are examples of two such dialogs.
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Theme modification dialogs

To remove themes:

1. Choose GO>Map>Modify Themes to display the modify themes dialog.

2. Select a theme from the list, and tap Remove. To remove all themes (not 
just the selected theme), tap Remove All.

Controlling the Map Projection

The Discover Mobile map window has a native map projection which determines 
how all objects in the window are displayed. By default, an empty map window 
(i.e. one with no tables loaded) is initially assigned a projection of Latitude/
Longitude WGS84. If you connect and start a GPS with a blank map window then 
the current position symbol will be displayed in the native Latitude/Longitude 
WGS84 projection (the default projection of the window and GPS coordinate 
system). 

Note Once the themes have been removed, they cannot be restored.

Note The display style of point objects can also be permanently changed by applying 
Range Styles.
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The first time you open a data table into an empty map window, Discover Mobile 
will check the native projection of the table and compare it with the projection of 
the map window. If the native projection of the table is different to projection of the 
map window then Discover Mobile will automatically change the map window 
projection to match the native projection of the first opened table. This only occurs 
for the first table that is opened. All subsequently data tables which are loaded 
into the map window will be added in the map window projection, regardless of 
their native projection. If the native projection of any of these tables is different to 
the map window projection, then Discover Mobile will dynamically convert the 
map objects on-the-fly so they are displayed in their correct relative position on 
the map. 

The only exception to this behaviour occurs with raster tables. If a raster table is 
opened in Discover Mobile, the map window projection will automatically change 
to the native projection of the raster table, even it there are already vector tables 
open in the window. Any open vector tables, which have a different native 
projection to the raster table, will be dynamically reprojected on-the-fly so that the 
map objects are displayed in the correct position relative to the raster image.

Although dynamic re-projection can be a very powerful feature, it can also have 
adverse effects on map redraw performance on PPC devices. Dynamic map re-
projection requires considerable system resources to perform the necessary 
projection calculations for each map object and can therefore slow down the 
redraw performance of the map window by as much as 70%.  If you experience 
slow map redraw performance then check your data to make sure that the native 
projection of all your data tables are the same. Refer to Chapter 3 Desktop Data 
Preparation for Discover Mobile for more information on improving map redraw 
performance. 

Discover Mobile provides two methods for altering the data projection, depending 
on whether data is being captured using the Drawing tools or GPS tools.

To set the map projection for capturing drawing objects:

1. Choose GO>Map>Map Projection.

2. Select the projection Category and Category Member. Discover Mobile 
supports the same range of map projections as MapInfo Professional.

Note Dynamic re-projection of map objects from one projection to another requires 
considerable system resources and can therefore have adverse effects on map 
redraw performance. It is highly recommended that you convert all large data 
tables (e.g. with more than 1000 objects) which are to be used in Discover 
Mobile to the same native map projection.
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Projection Selection dialog showing Projection Category and then the Category Member

To set the map projection for capturing GPS objects:

1. Choose GO>Preferences.

2. On the Preferences dialog navigate to the Session entry and change the 
Map Projection entry to User Defined.

4. Tap OK on the dialog and then OK in the Title bar to return to the main 
window.

The Map Grid and Status Window display units should then be displayed in your 
user-defined projection rather than the map window projection.

Raster Transparency

Choose GO>Edit>Raster Transparency to adjust the transparency of raster 
images.

3. Tap the button next to the User Projection entry and change the 
projection category by selecting the required projection from the drop-
down list.
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Raster images displayed by Discover Mobile can have their degree of opacity or 
transparency altered. This is useful when you have multiple images displayed 
such as a scanned geological map overlain by a Landsat image. In these 
circumstances you can adjust the transparency of the overlying image so that 
information from the underlying raster can be seen.

An example of this is shown below where a partially transparent scanned geology 
map overlays a Landsat image.

Transparent geology map overlying a Landsat image

You can control the level of transparency of a selected layer using the slider bar 
or by entering a specific percentage value into the central text box. Note that no 
transparency will be applied to the image if the level is set to 0 (zero). A value of 
100 will make the image completely invisible or transparent.
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Raster Transparency controls
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9 Working with Tables
In this section:

• Adding Tables, Maps, and Fields

• Defining Field Properties

• Managing Tables

• Searching for Data

Adding Tables, Maps, and Fields

You can add a new table by either:

• Using MapInfo Tables and Raster Images

• Creating a New Table with Discover Mobile

• Cloning Tables

• Using Templates

Using MapInfo Tables and Raster Images

Discover Mobile supports standard MapInfo Professional table formats (.TAB 
files). These include MapInfo Professional native .TAB files as well as .TAB files 
which reference raster files (.BMP, .TIFF, .GIF, JPG, .PCX, .SPOT, .ECW). 
Discover Mobile can also open GeoTIFF images directly even if they do not have 
an associated .TAB file.

When the table is opened (see Opening Tables), it is placed at the top of the Layer 
Control list. When a GeoTIFF is opened, Discover Mobile loads the image and 
creates a .TAB file in the same directory. If Discover Mobile does not recognise 
the registration parameters, then an error will be displayed. If this happens, you 
will need to manually register the image in MapInfo Professional and then copy 
the image file and .TAB file back to the PPC.

For information on copying files to the PPC, see Transferring Data Between 
Devices.
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Creating a New Table with Discover Mobile

You can create a new table and create the field structure, or you can clone the 
new table from an existing table. Table fields can be user defined, or you can add 
a predefined Auto field for capturing GPS data. When you create the table, you 
can select where the table is stored. The default folder for tables can be changed 
with GO>Preferences>Directories. You can also select the map projection for 
each table, or use the default projection. For more information about map 
projections, see Controlling the Map Projection.

To create a new table:

1. Choose GO>File>New Table command. The New Table dialog is 
displayed.

New Table dialog 

2. Under Create Layer, tap the browse button and type a name for the new 
table and select a folder in which to store the table.

3. To define fields, tap the Setup Fields button.

Important Make sure that you fully define the table structure when it is first created, 
because it cannot be changed later.
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Creation of new data fields for a new table

4. To add a user-defined field, tap the Add button.

A new entry titled NewField will be added to the field grid. You can assign 
a name to the field by tapping NewField in the Name column and typing 
the required field name. In the Type and Size columns, select the field 
properties. For more information about fields and their properties, see 
Field Types.

To remove a field, tap the field name and then tap the Delete button. 
Removal of a field is permanent and a message confirming the deletion is 
displayed.

5. To add an Auto field, which automatically captures data from the GPS, 
select a field from the pick list next to the Add button. The name and 
properties of Auto fields are predefined. For more information about Auto 
fields, see Auto Fields.

6. To select the map projection, tap Set Projection. If you do not set the 
projection, the default map projection will be used. For more information 
about map projection, see Projection.

Important When creating new tables in Discover Mobile it is strongly recommended that 
you use the same map projection for all tables. 
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7. To set the easting and northing table bounds, tap the Set Bounds button. 
For more information, see Set Bounds.

Cloning Tables

When creating new tables it is often convenient to use the structure and projection 
of an existing table as a template, particularly if you wish to add several new fields 
to an existing table. You can use any open table as a template for the new table. 

To clone a table from an existing table:

1. Choose GO>File>New Table command. The New Table dialog is 
displayed.

2. Under Create Layer, tap the browse button and type a name for the new 
table and select a folder in which to store the table.

3. Tap the Clone From button.

4. Select the table you want to clone and tap OK.

5. To add and remove fields in the new table, tap the Setup Fields button.

6. When you are finished modifying the table structure tap OK and the new 
.TAB file will be created.

Important Make sure that you fully define the table structure when it is cloned, because it 
cannot be changed later.

Note Any Quick Pick Fields setup for the source table will be copied across for the 
cloned table. 

Note No data will be transferred to the new table from the old table; only the table 
structure will be copied. To copy the data and structure, see Copying Tables.
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Using Templates

It is good practice to create a standard set of templates, from which tables are 
cloned (see Cloning Tables). This saves time when creating new tables, and 
these templates can be provided to all field users to ensure that field data 
collection is standardised. It also minimises data loss in the case of user error: 
multiple daily or weekly files provide more redundancy that a single file for a 
month-long field campaign.

For example, create a series of field data collection template tables, e.g. 
soil_template, lag_template, streams_template, etc. Ensure that the required 
Quick Pick Fields have been set for these templates (e.g. incrementing sample 
numbers by 1, sample type field set to a constant “soil”, geologist set to constant 
“BJ”, etc). Save these to a template directory on the storage card. Then clone a 
new table from these templates (e.g. soils_240507, lag_240507, etc.) as required 
and capture the field data into these cloned tables.

Defining Field Properties

• Field Types

• Quick Pick Fields

• Pick Lists

• Auto Fields

• Structural Data Fields

Field Types

The following field types are available when creating fields in a new table (see 
Creating a New Table with Discover Mobile):

• String

• Decimal

• Date

• Integer 

• Small Integer

• Float 
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• Logical 

For more information about each field type, see New Table.

Quick Pick Fields

You can set actions for data entry fields prior to capturing or creating map objects. 
These actions may include incrementing or decrementing each new object from 
a starting value, updating fields with an object X and Y centroid coordinate, object 
area, perimeter, length or object rotation angle. If you do not wish to assign an 
action to a field in the table select Quick Pick default action.

Quick Pick Table Setup

Users can also create and use custom Quick Pick lists for streamlined entry of 
attribute information. See Pick Lists.

Note Only use the following creation and editing procedures in Discover Mobile if you 
do not have access to the desktop Picklist Editor tool, which is much quicker 
andeasier to use.
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Pick Lists

Discover Mobile supports the use of fully customisable pick lists in the table 
browser window to simplify repetitive data entry tasks and to permit you to use 
standard look-up codes.

Format

The pick list files used in Discover Mobile are standard ASCII text files and can 
either be created on a Desktop computer using the desktop Picklist Editor tool or 
a text editor such as Notepad or exported from a database, spreadsheet or 
MapInfo Professional as a text file and then loaded into Discover Mobile. 
Alternatively, pick lists can also be created and edited on-the-fly in Discover 
Mobile. If intending to create a pick list file on a desktop computer, it must conform 
to the format expected by Discover Mobile. The pick list files must be ASCII text 
files with each attribute on a separate line.The pick list file name must also 
conform to one of the following formats:

• TableName_FieldName.txt – this naming convention means that the pick 
list file will only be available for the field name in the specified table name. 
For example, if your table is called Geology and the field you want to use 
the pick list with is called Lithology, then you would give the pick list the 
name Geology_Lithology.txt. This is the default convention for pick list files 
which are automatically created in Discover Mobile.

• FieldName.txt – this naming convention means that the pick list file will 
be available for ALL tables which contain the specified field name. For 
example if you call your pick list Comments.txt then that pick list will be 
available for all tables which contain a field called Comments.

Picklists are stored in the Picklist Directory specified under the GO>Preferences 
menu option (default \My Documents). It is recommended to set this location to 
a location such as a storage card.

Use

To use a Picklist to add attribute data to an object, open the object browser 
window (accessed for a new object via the Edit Attributes option, or via the Info 
tool or View Browser options for existing objects). Select the pull-down arrow 
adjacent to the relevant field; the contents of the appropriate pick list will be 
displayed. Selecting an entry will auto-populate the field.

Note Only use the following creation and editing procedures in Discover Mobile if you 
do not have access to the desktop Picklist Editor tool, which is much quicker 
andeasier to use.
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If the Picklist does not appear, check that it is in the correct format, has been 
placed in the assigned Pick List directory and that it has the same name as the 
target field (and same prefix as the Table name if required).

Example Pick Lists

The Discover Mobile desktop installation includes an Example dataset. This data 
is installed to an ‘Example Data’ directory under the Discover Mobile folder 
(default location C:\Program Files\Encom\Discover Mobile\Example 
Data).  

The example dataset includes a number of standard geological Pick List text files 
in an Example Data\PickList subdirectory:

• Grain_clast_size

• Lithology

• Lithology_example

• Occurrence

• Percentage

• Regime

• Regolith_example

• Sample_Type

To use these files, copy them to the mobile device’s Pick List directory (as set via 
GO>Preferences>Directories>Pick Lists). Then ensure that the appropriate 
field name in the capture table and the pick list name patch. It is recommended to 
truncate/edit the longer Pick Lists down to only those entries commonly used, and 
then save these files with a new name (e.g. Lithology) to the removable storage 
card. This will allow easier attribute selection within the Discover Mobile interface, 
without having to scroll through the entire list.

Create a Pick List in Discover Mobile

Note Only use the below creation and editing procedures in Discover Mobile if you do 
not have access to the desktop Picklist Editor tool – this is much quicker and 
simplified tool.
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1. Bring up the table browser either by using the Information icon or the 
GO>View>Table Browser menu.

2. Tap on the down arrow to the right of the field in the browser for which the 
pick list file is to be created. The edit list dialog will then display.

Selecting the Edit List option from the table browser

3. Type in the attributes required for the field.

Note Quick Pick auto-fields can also be added to the picklist – see Auto Fields for 
more information.  
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Entering a custom quick pick list

4. When the Pick List of items is complete tap the OK button in the top right 
of the dialog to save the pick list file.

5. The browser dialog will redisplay, allowing the user to select any of the 
entries just created from the drop-down menu.

Auto Fields

GO>Edit>Quick Pick Options

Discover Mobile provides a range of Quick Pick options. These allow specified 
fields to be automatically incremented or decremented, or to be populated with a 
constant value. Quick Pick options can also be used to assign object statistics 
such as region area or line length, as well as assigning GPS data to custom fields.

To set a Quick Pick option, select the GO>Edit>Quick Pick Options menu option. 
Select the required table from the pull-down list at the top of the following dialog. 
The table view will show three columns: Field name, Action, and Value. Quick 
Pick options can only set for custom fields (not preset GPS fields). Custom fields 
will have a ‘Quick Pick’ option displayed in the Action column (though it is not 
recommended to set Quick Pick options for Structural fields).

Note Only use the following creation and editing procedures in Discover Mobile if you 
do not have access to the desktop Picklist Editor tool, which is much quicker 
andeasier to use.
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Tap the Quick Pick pull-down arrow adjacent to the target field (e.g. 
Sample_number). A list of available Quick Pick options will be displayed. Select 
the required option (e.g. ‘Increment by’). If a value or character string is required 
by the Quick Pick option (‘Set as Constant Value’, ‘Increment by’ and ‘Decrement 
by’), type this into the adjacent Value column. Both the ‘Increment by’ and 
‘Decrement by’ options will automatically set a default value of 1. 

The Quick Pick list

Press OK to save these settings. Upon capturing a new object into the table, the 
Quick Pick options will be used to populate the specified fields. Note that for the 
‘Increment/Decrement by’ and ‘Same as previous’ options, an initial field value 
will need to be specified; otherwise numeric fields will start incrementing from 0.

The following Auto Fields are available for use:

• System Date – populates the field with the current date as set on the 
Mobile device (Start>Settings>System>Clock). This capture field must 
have a Date type. Alternatively a string field (of 20 characters width) can 
be utilised.

• System Time - populates the field with the current time as set on the 
Mobile device (Start>Settings>System>Clock). This field must be a 
string field (of 20 characters width).

Note An easier way to add QuickPick Auto field to Create a Pick List in Discover 
Mobile.
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• Set Constant Value – assigns the user specified value  every time a new 
object is created (e.g. date, sampler, data type, mesh size, etc). This value 
must entered into the Value column.

• Same As Previous – will update the current field with the same attribute 
as the previous record. This function will only work if there is an existing 
record in the table with an attribute value.

• Increment by – increments the current numeric value by any user 
specified value. The increment value must be entered in the Value column 
(default of 1). This function will work for both numeric and character 
(string) data fields. For string fields, it will add the increment value after 
any characters; e.g. if the initial string value is CHRC, following entires will 
be CHRC1, CHRC2, etc. If the string value already incorporates a numeric 
suffix, this suffix will be incremented; e.g. FAN345, FAN346, etc.

• Decrement by – decrements the current numeric value by any user 
specified value. The decrement value must be entered in the Value 
column (default of 1).  This function will work for both numeric and 
character (string) data fields (see the “Increment by’ option above for 
further information.

• Object Area – updates the attribute field with the Area value of the current 
object if it can be computed. The Object Area function can only be used 
with closed polygon objects.

• Object Perimeter – updates the attribute field with the Perimeter of the 
current object if the perimeter value can be computed. The Perimeter 
function can only be used with closed polygon objects.

• Object Length – updates the attribute field with the Length value of the 
current object if it can be computed. The Length function can only be used 
with line or polyline objects.

• Object X – updates the attribute field with the Centroid X value of the 
current object. The Object X function can be computed for all object types.

• Object Y – updates the attribute field with the Centroid Y value of the 
current object. The Object Y function can be computed for all object types.

• Object Rotation – updates the attribute field with the Rotation value of the 
current object. The rotation function can only be used with point objects.
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• GPS-specific output – the various GPS specific output streams can be 
linked to custom fields of the appropriate formats (i.e. Float fields for most 
GPS data types such as Map_X, Pos_Lat, etc, Date field for Pos_Date, 
etc). These special fields record the data as displayed in the GPS Status 
Window.

The following additional options are available when the Quick Pick tag is set. 
Press the adjacent browse button, select the Auto Field List tab, and choose a 
Quick Pick option:

• Link File – hotlink the file path of any file on the PPC device to a map 
object.

• Link Image – hotlink the file path of an image file on the PPC device to a 
map object.

• Link New Audio – hotlink the file path of a new Audio file (such as a voice 
recording) as an attribute to a map object. This can be particularly useful 
for recording voice notes at sample locations.

• Link New Pocket Word – hotlink the file path of a new Pocket Word 
document as an attribute to a map object.

• Link New Pocket Excel – hotlink the file path of a new Pocket Excel 
document as an attribute to a map object.

• Link New Custom – hotlink the file path of any file on the PPC device an 
attribute to a map object.

• [Read Only] – set the pick list file to be read only. If the read-only flag is 
added to the pick list you cannot edit the pick list using the Edit List menu 
in Discover Mobile. If you set a pick list to be read-only and you want to 
edit it in Discover Mobile you will have to directly open the pick list file 
using a text editor and remove the Read Only flag.

Structural Data Fields

Discover Mobile has a structural data mapping utility which enables you to record 
structural measurements manually by tapping on the map in the appropriate 
location or by using your current GPS position. When you capture a structure 
measurement Discover Mobile will automatically prompt you for the data type (eg 
bedding, cleavage etc) and then allow you to enter in the appropriate orientation 
data and finally display the appropriate structure symbol for the measurement in 
the map window. By using the structure mapping tool in Discover Mobile features 
such as fold axes, bedding or cleavage orientations can all be displayed 
immediately on your map. 
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Capturing structural-specific data using the GO>GPS>Capture Structure 
Symbol or GO>Tools>Add Structure Symbol tools requires the insertion table 
to have been created using the preset Structural fields, as provided in the pull-
down list in the Setup Fields dialog of the GO>File>New Table option 
(Struct_Strike or Struct_DipDir, Struct_Dip, & Struct_Code). See Creating a New 
Table with Discover Mobile for further information.

Before you can collect structure measurements in Discover Mobile you first need 
to create a structural data table to store the point objects and attribute data. 

Structure measurements can be recorded to any open map table in Discover 
Mobile providing the table contains the required Custom Fields for structure 
mapping. The following numeric fields must be present in the table in order to 
record structure data:

Map_X

Map_Y

Struct_Strike 

Struct_DipDir

Struct_Dip

Struct_Code

The Map_X and Map_Y fields are used to store the easting and northing values 
of the structural data measurement and are automatically read from the GPS if it 
is connected and turned on.

For more information, see:

• Azimuth Measurements

• Structure Dip and Plunge Angles

• Structure Codes and Symbol Libraries

• Adding Structural Data Fields

• Customizing the Structure Symbol Picklist
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Azimuth Measurements

The orientation information for structural measurements may be recorded using 
either a Strike or Dip Direction measurement. Strike orientation measurements 
are interpreted by Discover Mobile using the right-hand rule convention. 
Therefore, all strike measurements are converted to dip directions by adding 90º. 
If you intend to record data using the Strike convention you need to make sure 
the structure data table contains at least the Map_X, Map_Y, Struct_Strike, 
Struct_Dip, Struct_Code fields.

To record data using a Dip direction measurement make sure the table contains 
at least the Map_X, Map_Y, Struct_DipDir, Struct_Dip, Struct_Code fields. If you 
include both the Struct_DipDir and Struct_Strike fields in a table Discover Mobile 
will automatically calculate and populate both fields from the measurement data 
you enter.

Many structural codes measure the direction of plunge rather than a strike or dip 
direction (for example a lineation or fold axis). For these codes, the azimuth 
information is always used as plunge direction regardless of whether strike or dip 
direction has been selected.

Structure Dip and Plunge Angles

A dip or plunge value may be entered for most of the structural types that Discover 
Mobile supports. Selected structural types such as wrench faults, trend lines, 
monoclines, etc. do not require a dip value.

Discover Mobile expects a numeric value of between 0 and 90 degrees to be 
entered for the dip. However, there may be instances where a dip measurement 
cannot be measured for a variety of reasons. Because dip values are stored in 
numeric columns, the field value cannot be blank. Therefore, if you leave the dip 
entry box blank (to indicate no dip measurement was taken) Discover Mobile will 
automatically store a value of –99 in the dip column to represent a blank entry. If 
you subsequently process the structural measurements table using the Structure 
Symbol utility in Discover, it will interpret a value of -99 as a null dip value and will 
not display a dip value label next to the measurements.

Structure Codes and Symbol Libraries

In order for Discover Mobile to store your structural measurements correctly the 
structure data table must contain a Struct_Code field. This field will store the 
corresponding Discover Structure Code for the nominated structural 
measurement type. 

In accordance with Discover, Discover Mobile provides three structural symbol 
font files for Australian, Canadian and US structural symbols. 
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• Australian Structural Symbols (modified by AGSO)

• Canadian Structural Symbols (modified by the GSC) 

• USA Structural Symbols (modified by USGS)

Structure symbols are based on those described in the Australian Geological 
Survey Organisation (AGSO) mapping style guide with the addition of extra 
symbols such as schistosity, L1-L3 lineation and general trend lines. A full table 
of symbols for the Australian, US and Canadian symbol sets, together with 
Discover structural codes and keyboard codes, is given in Appendix A of this 
manual.

Adding Structural Data Fields

The structural data tables may be created in MapInfo Professional prior to being 
transferred to Discover Mobile or they may be created directly in Discover Mobile 
as required. If you create the tables in MapInfo Professional you must ensure that 
the field names and data types conform to the standard convention expected by 
Discover Mobile. Because Discover Mobile uses a standard set of field names to 
internally match the data columns in the structure data table with the appropriate 
information entered in the structure dialog, you need to make sure the field names 
in the structure table are consistent with the default field names listed above.

If you intend to create a structure table directly in Discover Mobile, perform the 
following steps:

1. Tap the GO>FILE>New Table menu

2. Type a file name in the name box and select a location for the new table

Note For a number of structure types, such as bedding or cleavage, Discover uses 
different symbols for horizontal and vertical dip.
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Setting a name for a new structural table.

3. Tap the Setup Fields button to bring up the setup fields dialog. From the 
Custom Field pull-down list select the mandatory structural data fields 
Map_X, Map_Y, Struct_Strike, Struct_Dip, Struct_Code.  You can then add 
any other additional attribute fields you wish to populate to the table.

 
Setting up the fields for a structural table.
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4. Tap the Projection button to assign an appropriate projection for the table 
and then tap OK to create the table.

Customizing the Structure Symbol Picklist

Discover Mobile stores the picklist of Structure Symbols in the designated Pick 
List directory as an Encom_StructureCodes.txt file (this file is installed to the 
default example data on the desktop, Example Data\Picklists. This contains 
every structure symbol in the Discover library (see Appendix B: Structural 
Symbols  for a complete listing) listed alphabetically.

This list can be customized to a user specific order an/or to display only those 
structure types commonly used in the field area (thus the drop down list may be 
setup to display only 15 structure types rather than the entire 79, saving the user 
having to scroll up and down a long list every time a structural measurement is 
made). Open the file into a text editor such as Notepad or WordPad, and reorder 
or delete entries as required. For each structure type, the entire row entry must 
be deleted or preserved (including the integer value at the end of each row). 
When completed, the original file name must also be preserved 
(Encom_StructureCodes.txt) for the Structural Symbols tool to recognize the 
file.

Copy this customized file into your project's picklist folder, and ensure this file is 
copied to the Discover Mobile picklist directory on the device.

Managing Tables

Tables are used to store the attributes of all types of objects, including data 
captured from the GPS. Tables used in Discover Mobile are .TAB files—identical 
to the tables used in MapInfo Professional. You can create and maintain tables 
on your desktop PC using MapInfo Professional and then transfer them to 
Discover Mobile for use in the field. You can also create new MapInfo 
Professional tables directly in Discover Mobile.

For information about managing tables, see:

• Cloning Tables

• Using Templates

• Opening Tables

• Closing Tables

• Copying Tables
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• Viewing Tables

• Modifying Table Structure

• Packing Tables

For information about individual commands, see File Menu.

Opening Tables

Discover Mobile supports standard MapInfo Professional table formats (.TAB 
files). These include MapInfo Professional native .TAB files as well as .TAB files 
which reference raster files (.BMP, .TIFF, .GIF, JPG, .PCX, .SPOT, .ECW). 
Discover Mobile can also open GeoTIFF images directly even if they do not have 
an associated .TAB file.

To open a .TAB file in Discover Mobile:

2. From the displayed file list of .TAB files, select the table to be opened

After the table has been selected, Discover Mobile automatically places it at the 
top of the Layer Control list and displays the table.

To open a recently opened table:

1. Choose GO>File>Recent Files.

2. Select the table and tap OK, or double-tap the table name.

To open a GeoTiff file:

1. Choose GO>File>Open Table.

2. Change the Type to GeoTiff Files (.TIF) using the pick list and select the 
GeoTiff to be opened.

After the GeoTiff has been selected, Discover Mobile will automatically load the 
image into the map window and create a .TAB file in the same directory. If 
Discover Mobile cannot recognise the registration parameters then an error will 
be displayed. In this situation you will need to manually register the image in 
MapInfo Professional and then copy the image file and .TAB file over to the PPC.

1. Choose GO>File>Open Table or tap the Open Table button on the main 
toolbar
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Closing Tables

Any open table can be closed using the Close Table command.

To close a table:

1. Choose GO>File>Close Table.

2. From the list of open tables, tap on the required table to be closed.

3. Tap OK and the table is then closed and removed from the display.

Alternatively,

1. Tap the Layer Control button or select GO>View>Layer Control.

2. Select the layer you wish to close and then tap the Remove button. The 
table will be removed from the layer control and the file closed.

To close all open tables:

• Choose GO>File>Close Table.

When you close all tables, the map display will show no data.

Copying Tables

A new table can be created from any open table providing it is not a raster table. 
The original table remains unchanged and open for all further edits.

To save a copy of a table as a new file:

1. Choose GO>File>Save Table Copy As.

Important The Close All Tables command will disconnect the GPS connection.
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Save a copy of a table dialog

2. In the Layer box, select the layer to use as the source table.

3. Tap the browse button next to the File box, and then type a new layer 
name and select the folder where the new table is to be saved.

4. If you want to change the table structure, tap the Setup Fields button and 
modify and delete fields as required.

5. If a different projection is to be used for the copy, tap the Set Projection 
button.

6. Tap OK.

The new table is added to the Layer Control and is immediately displayed.

Important Make sure that you fully define the table structure when it is copied, because it 
cannot be changed later.

Note The Save Table Copy As function will copy both the source tables structure and 
data into the new table. To copy just the structure without the data, see Cloning 
Tables.
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Viewing Tables

Use GO>View>Table Browser to view the data records within a table. You can 
enter new data or modify existing data in this browser view.

Use GO>View>Table Structure to display the fields (columns) within a layer and 
their associated data types. You can view the structure of different tables but you 
cannot modify the table structure.

Structure of a table 

Modifying Table Structure

An existing table structure can be modified which includes adding fields, deleting 
fields, changing field type, changing field size and renaming fields.

To modify the structure of a table:

1. Choose GO>File>Edit Table Structure.

2. In the Layer box, select the layer to modify.

Tip The operation of saving a copy of a specified layer can be especially useful 
when used with the Cosmetic Layer. All objects in the Cosmetic Layer can be 
permanently saved using the Save Table Copy As option. 
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3. If you want to change the table structure, tap the Setup Fields button and 
modify and delete fields as required.

4. Tap OK to save the modifications.

Packing Tables

When records or objects are deleted from a MapInfo Professional Table the 
deleted records remain as unpacked or deleted records. This will cause an 
apparent mismatch between the map objects and browser records. Unpacked 
rows also reduce the efficiency of a table.

To pack a table:

1. Choose GO>File>Pack Table.

2. On the Pack Table dialog select the table to pack and tap OK.

Searching for Data

In this section:

• Searching Tables by Query

• Searching Tables by Keyword

For information about individual commands used to search tables, see Query 
Menu.

Note Due to the limited computing power of PPC devices it is recommended to only 
modify tables no more than couple of Mega Bytes (MB). If a large table is 
modified it may complete within a couple of minutes so you will need to be 
patient.

Note Due to the limited computing power of PPC devices it is recommended to only 
pack tables no more than couple of Mega Bytes (MB). If a large table is packed it 
may complete within a couple of minutes so you will need to be patient.



190 Encom Discover Mobile User Guide

Searching Tables by Query

The general procedure for using queries is to specify a query statement that is 
then applied to nominated layers. Where the items within the nominated layers 
meet the selection criteria of the query, the results are temporarily stored and 
highlighted in the display. 

To create a query: 

1. Choose GO>Query>Select and select the table you wish to query. This 
table is referred to as the base table.

The Query dialog with layer and query specified

2. Construct the query using the available columns and operators and then 
tap the Run button to initiate the query.

3. When Discover Mobile has found all the items which meet the selection 
criteria a prompt will appear asking you to either select the objects in the 
map or cancel the query.

If you choose to select the items, Discover Mobile will extract the data 
from your base table and store the results in a temporary selection table. 
The selection table contains only the rows and columns that meet your 
criteria. The default name of the results table is Selection.
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Items found by a query and highlighted in the display

To save and re-use a query:

• To save the query, tap the Save button and assign an appropriate name.

• To re-use a saved query, tap the Load button and select the query.

Using Query Operators and Functions

At the base of the Query dialog are drop-down lists that can be used to build 
queries. Quite complex queries can be created using the operators and functions 
in Discover Mobile. A drop-down list of operators is available to assist in creating 
the query expression. 
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A selection of the operations available from the Query dialog

Operators

• Comparison Operators

• Logical Operators

• Operator Precedence

Comparison Operators

A comparison operator is often used in creating query expressions to describe 
differences between values. The following shows the comparison operators and 
a description.

= equals
<> not equal
> greater than
< less than
>= greater than or equal to
Like like (a wildcard for selecting subsets of multiple characters)
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Logical Operators

"And", "or", and "not" are logical operators. They are used to combine 
expressions.  Discover Mobile treats these expressions as a test and applies it to 
each record in the table. Each test will evaluate to a yes/no (true/false) answer. 
Discover Mobile uses the logical operators to tell it how to combine the individual 
yes/no answers. For example, does the current record meet the selection 
condition? 

And is "true" when (and only when) both of its arguments (the expressions 
it joins together) are true. A record must satisfy both of these conditions to 
be selected.

Or is "true" when either one, or both, of its arguments (the expressions it 
joins together) are true. A record need satisfy only one of these conditions 
to be selected.  It is also selected when both of its conditions are satisfied.

Not is "true" when its argument (the expression it applies to) is false. A 
record is selected when it does not meet the stated condition.

Operator Precedence

When Discover Mobile evaluates a query, it needs to know which components of 
an expression to evaluate first. This is called precedence. By convention, certain 
operators are assigned different levels of precedence. Those with the highest 
level are evaluated first. The following table lists the Discover Mobile operators in 
the order in which they are evaluated. Operators at the same level of precedence 
are evaluated from left to right.

parenthesis
exponentiation
negation
multiplication, division
addition, subtraction
not
and
or

Highest priority

Lowest priority
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Functions

A drop-down list of functions is available to assist in creating the SQL text of the 
query. 

Functions available in a drop-down list from the Query dialog

A query can include one or more function calls. In the following list, num is any 
numeric expression or value (e.g. 5 or a column in a table containing numeric 
values), str is any string expression (e.g. "km" or a column in a table containing 
strings), and obj is any object expression (e.g. an object in a table). 

Math Functions Description

Abs (num) Returns the absolute value of a number.

Cos (num) Returns the cosine of a number; num is in radians.

Int (num) Returns the integer (whole number) portion of a 
number.

Maximum (num, num) Returns the larger of two numbers.

Minimum (num, num) Returns the smaller of two numbers.

Round (num1, num2) Returns a number (num1), rounded off to the 
nearest value of num2 (e.g. if num2 is ten, then 
num1 is rounded to the nearest ten).
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Sin (num) Returns the sine of a number; num is in radians.

Tan (num) Returns the tangent of a number; num is in radians.

Date Functions Description

CurDate ( ) Returns the current date.

Day (date) Returns the day-of-month (1 - 31) portion of the 
date.

Month (date) Returns the month (1 - 12) portion of the date.

Weekday (date) Returns the day-of-week (1 - 7) portion of the date; 
1 represents Sunday. 

Year (date) Returns the year portion (e.g. 2001) of the date.

String Function Description

Chr$ (num) Returns a character that corresponds to a 
character code (e.g. Chr$(65) returns the string 
"A").

DeformatNumber$(str) Reverses the effect of the FormatNumber$ 
function, returning a string that does not include 
thousands separators.

Format$(num, str) Returns a string representing a formatted number. 
Example: Format$( 12345.678, ”$,#.##”) returns 
“$12,345.68”.

FormatNumber$(num) Returns a string representing a formatted number. 
This function is simpler to use than Format$, but it 
gives you less control over formatting (e.g. you 
always get thousands separators).

Instar(num, str1, str2) Searches the string str1 starting at character 
position num, and looks for an occurrence of the 
string str2. Returns the position where str2 was 
found, or zero if not found. To start search at 
beginning, use a num value of one (1).

Laces$(str) Returns a lowercase version of the string str.

Math Functions Description (Continued)
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Left$(str , num) Returns the first  num  characters of the string str.

Len(str) Returns the number of characters in a string.

Trim$(str) Trims any spaces from the start of str and returns 
result.

Mid$(str, num1, num2) Returns a portion of the string str starting at 
character position num1 and extending for num2 
characters.

Proper$(str) Returns a string with proper capitalisation (first 
letter of each word capitalised).

Right$(str , num) Returns the last num characters of the string str.

Trim$(str) Trims any spaces from the end of str and returns 
result.

Str$(expert) Returns a string approximation of an expression.

Ukase$(str) Returns an uppercase (all capitalised) version of 
str.

Val(str) Returns the numeric value of the string; for 
example, Val("18") returns the number 18.

Geographical Functions Description

Area(obj,str) Returns the area of the object. The str parameter 
specifies an area unit name, such as "sq mi" or "sq 
km".

CentroidX(obj) Returns the x-coordinate of the object centroid.

CentroidY(obj) Returns the y-coordinate of the object centroid.

Distance(num_x, num_y, 
num_x2, num_y2, str)

Returns the distance between two locations. The 
first two parameters specify the x and y value of the 
start location; the next two parameters specify the x 
and y value of the end location; the str parameter is 
a distance unit name, such as "mi" or "km".

String Function Description (Continued)
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Searching Tables by Keyword

Use the GO>Query>Find command to quickly search for a keyword and view the 
selection results.

The Find dialog and the result of successfully interrogating the data

To find a keyword in a table:

1. Select GO>Query>Find.

ObjectLen(obj , str) Returns the length of the object. The str value 
specifies a distance unit name such as "mi" or "km". 
Only line, polyline and arc objects have non-zero 
lengths.

Perimeter(obj , str) Returns the perimeter of the object. The str value 
specifies a distance unit name, such as "mi" or 
"km". Only region, ellipse and rectangle objects 
have non-zero perimeters.

Object Functions Description

Centroid(obj ) Returns a point object located at the centroid of obj.

Geographical Functions Description (Continued)
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2. Choose a Layer.

3. Choose the search Column.

4. In the Find box, type in a keyword to search for in the selected column. 
The keyword needs to match exactly (in case and spelling) with the word 
in the search column. 

5. Tap the Find button to start the search.

When items are found and the search is successfully completed, the 
number of found items is displayed in a message box. The items are also 
shown in a preview window with the found objects highlighted.

6. Pan and zoom the sub-window to view the found objects.

7. Tap the Info button and tap on an object to display attribute information for 
the selected records.

The attribute items of a layer displayed in the Info tool 
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10 Working with Objects
In this section:

• Creating Objects

• Field Data Entry and Editing

• Selecting Objects

• Editing Objects

• Formatting Objects

• Named Styles

• Range Styles

• Labels and Annotation

• Hotlinking Files to Map Objects

Creating Objects

Before creating objects, open and select the layer in which you want the object 
stored (see Controlling Layers and the View). The attributes of the object are 
determined by the structure of the layer table in which it is created (see Adding 
Tables, Maps, and Fields).

• Setting Object Creation Preferences

• Creating Drawing Objects

• Creating GPS-Located Objects

Note Fields cannot be added to existing tables (and hence objects). They must be 
defined when the table is first created.
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Setting Object Creation Preferences

The procedure followed when creating objects is controlled by the preference 
settings available from the GO>Preferences>Object Creation command. The 
following editable criteria are available when capturing object data.

• Edit Attributes

• Named Styles

• Point XY Editing

The preferences for these can be set as follows:

• Always – Upon data capture, the edit dialog is opened.

• Ask – The user is prompted to open the edit dialog. 

• Never – The edit dialog is not opened.

Edit Attributes

The Edit Attributes option opens a browser for the new object, allowing the user 
to edit any attributes, as well as assign attributes from predefined Pick Lists.

Named Styles

An existing style can be applied to the new object from the Named Styles library. 
This is an excellent way to visually differentiate identical object types; eg point 
samples such as rock-chips, lag and soil samples can have differing existing 
symbol types applied during data capture. See Named Styles.

Point XY Editing

After data capture, the X and Y coordinates can be edited.

Creating Drawing Objects

Use the Draw/Edit Toolbar to:

• Place a symbol.

• Place a structural symbol

• Draw a straight line.
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• Draw a polyline or freehand polyline.

• Draw a polygon or a freehand polygon.

New objects can only be added to one layer (or table) at a time.

You can set a layer to receive new objects (points, lines or polygons) by setting 
that layer as the insertion layer (see Setting the Insertion Layer). If an insertion 
layer has not been set you will be prompted to select one the first time you use 
any of the drawing tools. This layer will then remain as the insertion layer until you 
either close it or select another layer. For additional information on working with 
insertion layers refer to Managing Layers.

Discover Mobile provides a Cosmetic Layer for storing temporary map objects. 
Unlike MapInfo Professional, the Cosmetic Layer is optional in Discover Mobile 
and can be added to the map window with GO>Map>Add Cosmetic Layer. You 
can use the Cosmetic Layer to store temporary map objects rather than add them 
to an existing layer. Any objects placed into the Cosmetic Layer will be 
permanently deleted if you exit Discover Mobile without saving them.

The tools available from the Draw/Edit toolbar are described in:

• Creating Points and Symbols

• Creating Lines and Polygons

• Creating Structure Objects

Creating Points and Symbols

Before creating objects, you should open and set the insertion layer. If an 
insertion layer has not been assigned, when objects are created, a dialog will 
appear allowing selection of the insertion layer.

1. To select or change the symbol style, see Setting Default Styles for New 
Drawing Objects.
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Creating Lines and Polygons

Before creating objects, you should open and set the insertion layer. If an 
insertion layer has not been assigned, when objects are created, a dialog will 
appear allowing selection of the insertion layer.

Line creation tools available from the Draw/Edit toolbar:

2. Tap the Symbol tool or choose Go>Tools>Add Point.

3. Tap on the display to locate the point.

4. Depending on the options selected under GO>Preferences>Object 
Creation, a number of dialogs may appear which will allow you to select 
and enter line style, field values, and coordinates. For more information 
about object creation options, see Setting Object Creation Preferences 
and Field Data Entry and Editing.

1. To select or change the line and fill style, see Setting Default Styles for 
New Drawing Objects.

2. Tap one of the line object tools (see below) or choose from the Go>Tools 
menu.

3. In the display, tap or tap-and-drag (see below for a description on the 
operation of each tool) to create and terminate the line object.

4. Depending on the options selected under GO>Preferences>Object 
Creation, a number of dialogs may appear which will allow you to select 
and enter line style, field values, and coordinates. For more information 
about object creation options, see Setting Object Creation Preferences 
and Field Data Entry and Editing.

The Line Tool draws a straight line into the Insertion Layer. To use position and 
tap the stylus at the line start point and then drag a line to an end point. When 
you remove the stylus, a straight line is drawn between the two points.

The Polyline Line tool is used to draw polylines by tapping the location of 
vertices (nodes) on the screen. To use, first tap a point on the screen to add the 
first node, then move the stylus off the screen surface and tap another point. 
Continue tapping vertices until the polyline is complete. To finish double tap the 
screen at the position of the last node.
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Creating Structure Objects

First ensure that you have created a table containing all the mandatory structure 
field columns to collect GPS and structural measurement attribute information. 

2. Select the appropriate Structure Type (e.g. Bedding) from the pull-down 
list at the top of the dialog.

Entering structural data

The Freehand Polyline tool is used to draw polylines on the screen using 
freehand drawing. To use, place the stylus at the start of the line and then while 
holding the stylus on the surface, draw the required line. To finish, remove the 
stylus from the screen and the polyline will be automatically created.

The Polygon tool is used to draw a polygon node-by-node. To use, tap the stylus 
on the screen at the location of the first vertex and then continue by tapping the 
second and subsequent vertices. Complete the polygon by double tapping the 
location of the final vertex.

 

The Freehand Polygon tool is used to draw polygons on the screen using 
freehand drawing. To use, place the stylus on the screen at the start location of 
the polygon and while holding the stylus on the surface, draw the required shape. 
To finish, remove the stylus from the surface and the polygon will be 
automatically created.

1. Tap Add Structure Symbol tool on the Drawing toolbar or choose 
GO>Tools>Add Structure Symbol.
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3. In the Structural Data entry boxes, type the Strike or Dip Direction using 
the number pad on the right, and also the Dip box. Dip values must be 
between 0 and 90 degrees. If you leave the box empty Discover Mobile 
will assume no dip is to be recorded and will enter a value of -99 in the 
table.

4. To change between the Strike and Dip Direction conventions, tap the 
Setup button to display the configuration dialog. Select the appropriate 
option to record azimuth using Dip Direction and Dip or Strike and Dip 
(right-hand rule).

Specifying the Symbol Set and preferred Structure Orientation.

5. To change the symbol library between the Australian, US or Canadian 
symbol set, select the required Symbol Set from the Structure Symbol 
Library pull-down list.

6. To change the symbol style and size tap the Advanced Symbol Style 
button to display the Structure Symbol Styles options. Here the structure 
symbol size, colour and background and effects can be modified. Any 
changes made to the Font or Symbol text boxes will be overridden by the 
Structure Type and Structure Symbol Library selected.

To add more structure measurements to the map repeat the above steps.

Creating GPS-Located Objects

Use the GPS toolbar to:
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• Record a GPS Point Track Log.

• Record a GPS Line Track Log.

• Capture points. polylines, and polygons via the GPS.

See Working with the GPS for information on connecting the GPS. and other 
GPS-related tasks.

The tools available from the GPS toolbar are summarised below and described in 
more detail in:

• Capturing Points

• Capturing Lines

• Capturing Elevation Data

• Capturing Structure Objects

Note The first time you use Discover Mobile you will need to configure the GPS 
communication settings for your particular receiver. You can do this from 
GO>GPS>Setup Connection or GO>Preferences command. It is important that 
you set the correct port number, communication format and speed for your GPS 
receiver. If these settings are incorrect Discover Mobile will not be able to 
communicate with the receiver. Refer to your GPS User Guide for details on the 
GPS communication settings and Working with the GPS in this guide.

GPS Point Track Log button turns on/off the Point Track Log function. Discover 
Mobile can record a continuous Track Log showing your path as a series of 
points. The point track log is recorded to a GPS_Point_Log table. The log table 
can be configured to record some or all of the GPS attribute information 
available for each point. The points are collected at the same rate as the GPS 
Connection interval which can be configured under the GO>Preferences 
command. For more information, see GPS Point Log.
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GPS Line Track Log button turns on/off the Line Track Log function. To activate 
the function tap the button and then setup the GPS attribute fields you wish to 
log. Discover Mobile will then record a Line Track Log showing your path. The 
Line Track Log is made up of a series of consecutive line segments rather than 
one continuous polyline. The reason for this is that GPS Line Track Log function 
needs to record GPS attribute information for each segment in your travelled 
path. Therefore, if you wish to examine the GPS attribute information for any 
segment of your path at a later date, the information is readily available. If you 
wish to record a single continuous line (e.g. a fault trace or track) then use the 
GPS Line Capture function instead. You can use the Track Log and GPS 
Polyline capture functions simultaneously. For more information, see GPS Line 
Log.

GPS Point Capture button will capture a single point to any chosen layer in the 
map using the current position coordinates from the GPS receiver. To use this 
function, first create a layer containing default columns for each GPS attribute 
field you wish to capture, as well as any additional custom fields you wish to 
populate. This layer must be created before you capture the point so that the 
required attribute information can be recorded for the point. Alternatively you can 
add the GPS point to an existing layer, however only attribute information for the 
fields in that table will be recorded. When you are ready to capture the point 
object tap the GPS Point button once. A symbol will be placed on the screen at 
the current GPS location.

To automatically prompt for a named style, or to edit attributes or coordinates, 
see Object Creation on the Preferences menu.

GPS Structure Symbol button is used to capture structural measurements 
readings to any chosen layer in the map using the current position coordinates 
from the GPS receiver. To use this function, first create a table containing default 
columns for each structure measurement field you wish to collect as well as any 
GPS attribute data you wish to capture. You can also add any other custom 
fields you wish to populate. This table must be created before you capture the 
structure reading so that Discover Mobile can also record the required attribute 
information for the point.

Alternatively, you can add the structure symbol to an existing layer, however 
attribute information will only be recorded if the appropriate fields exist in the 
table. When you are ready to capture a structural object, tap the GPS Structure 
Symbol button once. You will then be presented with the structure symbol dialog 
enabling you to assign the appropriate symbol type and orientation 
measurements. When complete, the appropriate symbol will be placed on the 
map at the current GPS location. The preferred method for recording structural 
symbols can be modified by tapping on the Setup button on the dialog.

For more information, see Capturing Structure Objects.
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GPS Insert Node button is used to add a new node to the current GPS polyline 
or polygon while the pause button is active. To use, tap the Insert Node button 
when you wish to add a node to your line. You can return to continuous node 
logging mode at any time by turning off the Pause button.

GPS Polyline Capture button will capture a continuous polyline to a chosen 
table using the GPS position coordinates. To use this function, first create a layer 
containing default columns for all GPS attribute information you which to capture 
as well as any additional custom fields you wish to populate. Alternatively, you 
can add the new polyline to an existing layer. When you are ready to capture the 
polyline tap the GPS Polyline button to start the line recording. You will see the 
line draw on the screen as you map out the polyline path. Tap the button again to 
stop the polyline capture. You will be prompted for a table in which to save the 
line. 

The node separation is controlled by the Tolerance Min and Tolerance Max 
settings on the Preferences menu.

To automatically prompt for a named style, or to edit attributes or coordinates, 
see Object Creation on the Preferences menu.

GPS Polygon Capture button will capture a polygon to a chosen table using 
GPS position coordinates. To use this function, first create a layer containing 
columns for all the default GPS attribute fields you wish to record as well as any 
additional custom fields you wish to populate. Alternatively, you can add the new 
polygon to an existing layer. Tap the GPS Polygon button when you are ready 
to capture the polygon object. You may need to toggle between the polyline and 
polygon tools first. A line will then draw on the screen as you map out the 
polygon boundary. To finish the polygon tap the button again. The polygon will 
automatically close by joining the last captured node to the first.

The node separation is controlled by the Tolerance Min and Tolerance Max 
settings on the Preferences menu.

To automatically prompt for a named style, or to edit attributes or coordinates, 
see Object Creation on the Preferences menu.
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Capturing Points

Open the point capture table (see Opening Tables) containing fields for recording 
the GPS point data and custom fields (see Assigning GPS Capture Layers). If a 
GPS capture table has not been assigned, when data is captured, a dialog will 
appear allowing selection of the capture layer.

Depending on the options selected under GO>Preferences>Object Creation, a 
number of dialogs may appear which will allow you to select and enter symbol 
style, field values, and coordinates. For more information about object creation 
options, see Setting Object Creation Preferences and Field Data Entry and 
Editing.

The GPS settings and the quality of the satellite signal will influence the time 
taken to capture a point. For accurate point capture, wait until the “Please wait” 
message disappears before moving to the next point.

GPS Polyline/Polygon Pause  button is used to pause the capturing of a 
polygon or polyline without actually terminating the current line capture. To use 
this function, either the GPS polyline or Polygon capture tool must be active. 
To pause the capture of a polyline or polygon tap the Pause button once to 
activate it (depressed). Discover Mobile will then temporarily stop adding new 
nodes to the object.  With the pause button depressed you can then walk around 
and examine where the next node should be placed without actually capturing 
any data. When you are ready to capture the next node tap the pause button 
again to restart the GPS polyline or polygon capture. 

By toggling the pause button on and off after you capture each node you can 
build up a polyline or polygon one node at a time. When you want to finish 
capturing a polyline or polygon simply turn the pause button off and then tap the 
appropriate polyline or polygon capture button to end the line capture and save 
the object to a table.

You can record point objects (such as structural measurements) while the pause 
button is active. To do so simply walk to the desired location and tap the button 
for the appropriate point capture tool. You will then be asked for a table in which 
to save the new object 

You can also add a new node to a polyline or polygon while the pause button is 
active the Insert Node tool on the GPS toolbar.

To capture a point at the current GPS position, tap the GPS Point Capture 
button on the GPS toolbar, or choose GO>GPS>Capture Point. 
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Capturing Lines

Open the line capture table (see Opening Tables) containing fields for recording 
the GPS line data and custom fields (see Assigning GPS Capture Layers). If a 
GPS capture table has not been assigned, when data is captured, a dialog will 
appear allowing selection of the capture layer.

Discover Mobile will then commence capturing the polyline node-by-node using 
the current GPS interval and minimum/maximum tolerance values. An audible 
beep from the PPC will be heard each time a new node is captured. The beep 
sound cannot be disabled; however, the sound on the PPC can be turned down.

To control the node separation review the Tolerance Min and Tolerance Max 
values under the GO>Preferences>Point Capture option:

• The minimum tolerance value should be set to a value that matches the 
mapping requirements and the accuracy of the GPS receiver. If you are 
walking out a boundary with a conventional GPS receiver, then a minimum 
tolerance of 10m should be adequate. If you using DGPS, you can reduce 
the minimum tolerance to 1m. If mapping out roads or tracks using a 
vehicle, then setting a minimum tolerance of 20 m to 100 m would be 
more appropriate.

• When capturing a polyline be careful not to set the maximum tolerance to 
a small value. Ideal values are 500 m to 1000 m. If the Maximum 
Tolerance value is set too small (say 100 m) the polyline may terminate 
between points. If this occurs, tap the GPS Polyline button once to turn it 
off and then tap it again to commence a new polyline.

The GPS settings and the quality of the satellite signal will influence the time 
taken to capture a point. For accurate point capture, wait until the “Please wait” 
message disappears before moving to the next point.

To pause the capture of a polyline, tap the Pause button on the GPS toolbar. This 
allows the user to move around and determine where the feature being mapped 
extends (e.g. where precisely the fault trend continues). When this has been 
determined, return to the position where the next node is to be added and then 
tap the Pause button again to continue capture. You can also use the Pause 
button to capture polylines one node at a time by pausing capture while moving 
to the new node position.

To capture points along a path, tap the GPS Polyline Capture button on the 
GPS toolbar, or choose GO>GPS>Capture Polyline. 
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To complete polyline capture, tap the GPS Polylines Capture button again. If the 
capture layer has not been assigned, you are prompted to select a table. 
Depending on the options selected under GO>Preferences>Object Creation, a 
number of dialogs may appear which will allow you to select and enter line style 
and field values. For more information about object creation options, see Setting 
Object Creation Preferences and Field Data Entry and Editing.

Capturing Regions

Open the region capture table (see Opening Tables) containing fields for 
recording the GPS polygon data and custom fields (see Assigning GPS Capture 
Layers). If a GPS capture table has not been assigned, when data is captured, a 
dialog will appear allowing selection of the capture layer.

Discover Mobile will then commence capturing the polygon node-by-node using 
the current GPS interval and minimum/maximum tolerance values. An audible 
beep from the PPC will be heard each time a new node is captured. The beep 
sound cannot be disabled; however, the sound on the PPC can be turned down.

To control the node separation review the Tolerance Min and Tolerance Max 
values under the GO>Preferences>Point Capture option:

• The minimum tolerance value should be set to a value that matches the 
mapping requirements and the accuracy of the GPS receiver. If you are 
walking out a boundary with a conventional GPS receiver, then a minimum 
tolerance of 10m should be adequate. If you using DGPS, you can reduce 
the minimum tolerance to 1 m. If mapping in a vehicle, then setting a 
minimum tolerance of 20 m to 100 m would be more appropriate.

• When capturing a polyline be careful not to set the maximum tolerance to 
a small value. Ideal values are 500 m to 1000 m. If the Maximum 
Tolerance value is set too small (say 100 m) the polyline may terminate 
between points. If this occurs, tap the GPS Polygon button once to turn it 
off and then tap it again to commence a new polygon.

The GPS settings and the quality of the satellite signal will influence the time 
taken to capture a point. For accurate point capture, wait until the “Please wait” 
message disappears before moving to the next point.

To add a node to the polyline, tap the Insert Node icon once and a new node will 
be added using the current GPS coordinates.

To capture points along a closed boundary (regions, outcrops, paddocks, etc.), 
tap the GPS Polygon Capture button on the GPS toolbar, or choose 
GO>GPS>Capture Polygon. 
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To pause the capture of a polygon, tap the Pause button on the GPS toolbar. This 
allows the user to move around and determine where the feature being mapped 
extends (e.g. where precisely the fault trend continues). When this has been 
determined, return to the position where the next node is to be added and then 
tap the Pause button again to continue capture. You can also use the Pause 
button to capture polylines one node at a time by pausing capture while moving 
to the new node position.

To complete polylgon capture, tap the GPS Polygons Capture button again. If 
the capture layer has not been assigned, you are prompted to select a table. 
Depending on the options selected under GO>Preferences>Object Creation, a 
number of dialogs may appear which will allow you to select and enter line style 
and field values. For more information about object creation options, see Setting 
Object Creation Preferences and Field Data Entry and Editing.

Capturing Elevation Data

If collecting field data for which elevation information is important (for instance to 
create a topographic surface or contour file), the data should be captured as 
points. If data is collected as polylines or regions (for instance a track or fence-
line), only a single elevation value is recorded for the object, not for each vertex.

Data collected as points will preserve point elevation data, and can be converted 
into polylines or polygons in MapInfo Professional, especially if a unique attribute 
has been specified for each group of points (by using GO>Edit>Quick Pick 
Options and selecting Set Constant Value or Same As Previous). If the 
ordering of the points is important to the object creation, automatically increment 
a second attribute field in Discover Mobile with an integer (Increment By). For 
instance, points representing two lines could be captured as:

To add a node to the polygon, tap the Insert Node icon once and a new node 
will be added using the current GPS coordinates.

Point ObjectID Order
345 TrackA 1
346 TrackA 2
347 TrackA 3
348 DrainH 1
349 DrainH 2
350 TrackA 4
351 DrainH 3
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Capturing Structure Objects

1. First ensure that you have created a table containing all the mandatory 
structure field columns to collect GPS and structural measurement 
attribute information (Struct_Strike and/or Struct_DipDir, Struct_Dip and 
Struct_Code). 

3. Select the appropriate Structure Type (e.g. Bedding) from the pull-down 
list at the top of the dialog.

Entering structural data

4. In the Structural Data entry boxes, type the Strike or Dip Direction using 
the number pad on the right, and also the Dip box. Dip values must be 
between 0 and 90 degrees. If you leave the box empty Discover Mobile 
will assume no dip is to be recorded and will enter a value of -99 in the 
table.

5. To change between the Strike and Dip Direction conventions, tap the 
Setup button to display the configuration dialog. Select the appropriate 
option to record azimuth using Dip Direction and Dip or Strike and Dip 
(right-hand rule).

2. To add a structure measurement using coordinates from the GPS position 
either select the GO>GPS>Capture Structure Symbol menu option or 
tap the pop-up menu arrow next to the GPS Point button on the GPS 
toolbar and select the Structure Symbol option. When the Structure 
Symbol icon appears, tap the button once to add the point to the table. 
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Specifying the Symbol Set and preferred Structure Orientation.

6. To change the symbol library between the Australian, US or Canadian 
symbol set, select the required Symbol Set from the Structure Symbol 
Library pull-down list.

7. To change the symbol style and size tap the Advanced Symbol Style 
button to display the Structure Symbol Styles options. Here the structure 
symbol size, colour and background and effects can be modified. Any 
changes made to the Font or Symbol text boxes will be overridden by the 
Structure Type and Structure Symbol Library selected.

To add more structure measurements to the map repeat the above steps.

Field Data Entry and Editing

Field data captured with the GPS or the Drawing tools generally need text and 
numeric information recorded during the capture process (sample number, 
regolith type, date collected, coordinates, weight or size, etc).

The type of information that you can record depends on the structure of the table 
selected as the insertion layer where objects are stored. For information about 
defining tables and fields, see the topics in Working with Tables.

The simplest way to add attributes to a new object is to display the Edit Attributes 
browser after object capture by setting the Edit Attributes option under 
GO>Preferences>Object Creation to Ask or Always. You can then manually type 
values into the relevant attribute fields appropriate for the sample/data type.
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However, much of this attribute information is repetitive (incrementing sample or 
grid peg numbers), constant (sampler, date) or has a discrete number of possible 
values (eg rock type code). Discover Mobile has a number of tools to simplify 
object attributing, allowing many fields to be automatically attributed. For more 
information about automatically populated field values see Populating Fields

You can also streamline the capture of object attributes with Named Styles.

Populating Fields

The data table to be populated must include the required field types (e.g. an 
integer field for Sample numbers, a string field of 20 characters size for Lithology 
type, a date field of date capture, etc). For information on creating tables and 
fields, see Adding Tables, Maps, and Fields.

There are five methods of populating fields in Discover Mobile:

Select Value from Pick List

For instance, a Lithology picklist might include Granite, Basalt, Sandstone and 
Limestone. Each time a rock-chip is collected, the user populates the Lithology 
column by selecting a rock type from the picklist. The list can also contain sub-
categories, for example a BIF category may contain the sequence numbers for 
each of the BIF layers.

Automatically Populate with User-Defined Data

Various automatically populating fields can be set as QuickPick Fields within a 
picklist: a range of automatic functions can be applied, such as ‘Set as Constant’ 
(e.g. for populating a sample type, geologist or date column), ‘Increment by’ (e.g. 
for incrementing sample numbers), ‘Same As Previous’, etc. This functionality 
can also be used to populate custom fields with GPS specific data (e.g. a custom 
‘Easting’ field could be assigned the GPS-specific Map_X output data).

Automatically Populate with GPS Data

Auto-attribute with GPS-specific information, by assigning the preset GPS fields 
during the table creation process. These include the Map_X, Map_Y, Pos_Lat, 
Pos_Long, etc fields.

Note Fields cannot be added to existing tables. They must be defined when the table 
is first created.
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Auto-prompt for Structural Data

Auto-prompting for Structural-specific information, using either the 
GO>GPS>Capture Structure Symbol or GO>Tools>Add Structure Symbol tools. 
Both of these options require the addition of the preset structure -specific fields 
during the table creation process: these are Struct_Strike or Struct_DipDir, 
Struct_Dip, and Struct_Code fields.

Ad Hoc Values

Custom fields can be attributed manually by the user using the popup keyboard

Selecting Objects

• Using the Selection Tools

• Viewing Graphical Selections

• Selecting Objects Within a Buffer

Using the Selection Tools

The Selection tools on the Select/View toolbar has four modes for selecting 
object(s) in the display area. To change mode, tap the arrow next to the currently 
selected mode button.

Note If only one default QuickPick GPS auto-field is set in method 2, it is identical to 
setting the GPS field type in step 3

Point – Select a single object or item. This default mode is used for data entry, 
object selection and editing. Selection is done by positioning the stylus over the 
required object and tapping. A selected object is highlighted.

Radius – Selects objects within a controllable radius. All selectable objects 
within the radius are highlighted. The origin of the radius is centred where the 
stylus was first placed on the screen. Operate by locating the stylus at a point on 
the screen and then drag it away from the point until the radial search has 
reached the required diameter.

Rectangular - Selects objects within a rectangular area drawn from an initially 
located point. All selectable objects whose centroid is within the area are 
highlighted. Operate by locating the stylus at a start point and then drag out a 
rectangle until the search area reaches the required size.
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Viewing Graphical Selections

To easily view selected map objects in a Browser Window navigate to the 
GO>Query>Browse Selection. A  Browser Window will be presented only 
displaying records for map object selected.

Selecting Objects Within a Buffer

You can create a buffer around a single object, or around a collection of objects. 
Creating a buffer around an object defines an area of influence around that object 
to a user-specified distance. A buffer can be used to select objects that fall within 
a given distance of one or more selected objects. 

The Buffer option allows you to quickly identify objects of interest within a given 
distance of other objects. For example, you may wish to identify all mineral 
occurrences which fall within 2 km of a mapped fault.

To create a buffer:

1. Open the table and set as the insertion layer.

2. Select the object or objects you want to create a buffer around. 

3. Choose GO>Edit>Buffer. The Buffer Objects dialog is displayed: 

Polygonal - Select objects within a polygonal area. Use the polygon select tool 
to enclose the required objects by tapping out a series of vertices. All selectable 
objects within the polygon are highlighted. Operate by tapping the stylus at a 
start point and then tapping additional vertices to enclose the required objects. 
Complete the polygonal area by tapping twice on the screen.
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Specify a buffer distance around the selected object(s)

4. Choose to either Buffer each object separately, or Buffer all objects 
into one per layer.

5. In the Distance box, type the buffer distance.

6. In the Unit box, choose the unit of measurement for the buffer distance.

7. Tap OK.

The object buffers are created and displayed in the Insertion layer. All objects 
located within the buffers are selected.
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An example display of a set of faults being buffered using a 500 metre buffer

Editing Objects

Discover Mobile allows simultaneous editing of multiple objects in multiple layers. 
Objects in any selectable and editable layer can be moved, repositioned, resized, 
formatted, or deleted (see Managing Layers). Most editing tools require you to 
first select the object before choosing the tool (see Selecting Objects). If the tool 
you need is not displayed on the toolbar, tap the arrow button next to the current 
tool and change the mode.

• Move an Object

• Edit and Delete Nodes

• Add Nodes

• Edit Attributes

• Edit Coordinates

• Edit Object Style

• Delete Objects
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Move an Object

Edit and Delete Nodes

Add Nodes

Edit Attributes

You can also choose Go>View>Table Browser, to browse a selected table row-
by-row (i.e. object-by-object).

Tap the Point Select tool on the Select/View Toolbar. If the Point tool is not 
active, tap the arrow button to change the selection mode or choose 
GO>Edit>Edit Mode>Feature Edit Mode. When you select the object, handles 
appear which you can drag to another location.

Select the polygon or polyline, and then tap the Vertex Edit tool on the Draw/
Edit Toolbar or choose GO>Edit>Edit Mode>Node Edit Mode. The polygon or 
polyline vertices are then displayed. Move or delete each vertex as required by 
selecting and dragging or by tapping the delete button.

Select the polygon or polyline, and then tap the Add Vertex tool on the Draw/
Edit Toolbar or choose GO>Edit>Edit Mode>Add Node Mode. The polygon or 
polyline vertices are then displayed. Tap the stylus on the polyline or polygon in 
the position where you want the new node to be added. You can also drag the 
node to a new position with the stylus as you add it.

Use the Information button to display and edit attributes (field values) of an 
object in the table browser.

1. Tap the Information tool.

2. Tap the object you want to edit.

The table browser is displayed. If the object does not have any associated 
attribute information, blank data fields will be displayed. If more than one 
table has an object at the selected point, use the drop-down list to select 
the table of interest.

3. Edit the field values as required. 

4. Close the browser dialog when you have finished.
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Edit Coordinates

Select the object, and then choose GO>Edit>Selected Point Location to display 
the Point XY dialog, where you can edit the coordinates of a selected object.

Edit Object Style

For more information, see Formatting Objects.

Delete Objects

Formatting Objects

• Setting Default Styles for New Drawing Objects

• Formatting Drawing Objects

• Setting Default Styles for GPS-Located Objects

• Applying Named Styles

• Applying Range Styles

• Applying a Range Style Library During XRF Data Capture

To change the appearance of an object, first select it using one of the select tools 
and then tap the Object Style button or choose GO>Edit>Selected Object 
Style. The style properties dialog will change depending on the type of object 
selected.

To delete an object, select the object (or objects) and tap the Delete button on 
the Select/View toolbar. You can also delete selected objects by choosing 
GO>Edit>Delete.

Warning Deleted objects cannot be restored.
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Setting Default Styles for New Drawing Objects

Default styles can be applied to symbols, lines and polygons.

To modify the default style for an object type:

2. Choose GO>Edit>New Object Styles.

3. Modify the preferred display settings for the object type. See Formatting 
Drawing Objects for details on the various dialog controls.

4. Tap OK on the Title bar

Formatting Drawing Objects

Before an object can be formatted, the layer that contains the object must be 
editable and selectable (see Managing Layers).

To format one or more objects:

1. Select the object or objects (see Selecting Objects).

2. Choose GO>Edit>Selected Object Style.

A style dialog is displayed. The dialog depends on the type of object selected. If 
multiple items are selected then the first item in the selection will configure the 
display property dialog.

• Symbol Style

• Line Style

• Fill Style

 

1. Select a Symbol, Line or Polygon object tool.

Note The default object styles are not saved between Discover Mobile sessions.
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Symbol Style

The Symbol style dialog allows the symbol style, size and colour and symbol 
rotation properties to be controlled. 

Style dialog to control displayed symbols

Character effects such as bolding, halos, drop shadows and italics are also 
available. 
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Line Style

Line style properties can be modified for all line types. When a line is selected the 
line style dialog appears:

Line style dialog

Available controls include line style, line thickness (in either pixels or points (32 
points equals 2.54 cm or 1 inch) and colour. A preview sample of the line style is 
also displayed.
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Fill Style

This style controls fill patterns, colour and outline style of polygon objects.

Fill style dialog

All standard MapInfo Professional fill patterns and colours are available. The 
colour of both the pattern foreground and background can be modified. The line 
style of the polygon border can also be adjusted using similar controls to the Line 
Style dialog.

Setting Default Styles for GPS-Located Objects

Choose GO>GPS>Default Styles to define graphical styles of various GPS 
object types (point, polyline, polygon, track logs, etc).

• Current Position Style
Sets a preferred display style for the Current Position Symbol. The default 
symbol is a hollow red circle. The symbol style can be adjusted for the 
Current Position to any symbol style supported by Discover Mobile. 

• Track Log Point Style
Sets a preferred display style for the Point Track Log. The default style is a 
gray circle . The symbol style can be adjusted for the Point Track Log to 
any symbol style supported by Discover Mobile.
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• Track Log Line Style
Sets a preferred display style for the Line Track Log. The default style is a 
single point black line. The line style can be adjusted for the Line Track 
Log to any line style supported by Discover Mobile.

• Capture Point Style
Sets a preferred display style for the Capture Point. The default style is a 
black flag. The symbol style can be adjusted for the Capture Point tool to 
any symbol style supported by Discover Mobile. 

• Capture Line Style
Sets a preferred display style for the Capture Line. The default style is a 
single point black line. The line style can be adjusted for the Capture Line 
tool to any line style supported by Discover Mobile. 

• Capture Polygon Style
Sets a preferred display style for the Capture Polygon. The default style is 
a filled white polygon with a single point black outline. The polygon style 
can be adjusted for the Capture Polygon tool to any line and fill pattern 
style supported by Discover Mobile.

Applying Named Styles

Named styles can be applied to any type of object, including drawing objects and 
GPS objects. Before you can apply named styles, you must create a style library. 
For information on creating and assigning names styles, see Named Styles.

To apply named styles to new objects:

1. Set the GO>Preferences>Object Creation>Named Styles option to 
Always. The Named Styles dialog is then displayed when a drawing 
object or GPS object is created.

2. When an object is created, the Named Styles dialog is displayed.

Note A Named Style can also be assigned to any object captured via the GPS. This 
Named Style will override the default capture point, polyline or polygon style (see 
Named Styles).

• Way Point Navigation Style
Sets a preferred display style for the Way Point Navigation - The default 
style is an orientated red triangle. The symbol style can be adjusted for the 
Way Point Navigation tool to any symbol style supported by Discover 
Mobile.
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3. In the Style drop-down list, choose a Syle Library from the top pull-down 
list. The available named styles are displayed. Only those styles 
applicable to the object type are displayed, i.e. if a point object is created, 
only the point-type named styles will be displayed.

4. Either double-tap a named style, or select the style and tap the Use 
button.

The Named Styles dialog after capturing a point object: the list has been filtered to display 
only point-type styles

The object is then added to the table assigned to the selected named style.

Any preset Quick Pick field values will also be populated in the table, and if the 
Edit Attributes option is enabled, additional field values may be added (see 
Populating Fields).

Applying Range Styles

For information on creating and assigning range styles, see Range Styles.

Note The current insertion layer for drawing objects and data capture table for GPS 
objects are ignored when using named styles. However, the standard insertion 
tables are used if a named styles is not selected and the Named Styles dialog is 
cancelled. If the insertion layer has not been set, you will be prompted to select a 
table. Selecting None here will terminate the object capture.
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To apply an existing Range Style library to a numeric dataset open in Discover 
Mobile, select the Go>Edit>Apply Range Style menu option.

In the following dialog, from each appropriate pull-down list:

1. Select the target table/layer.

2. Select the numeric field to apply the range style to.

3. Select the Range Style to apply.

4. Press OK.

Applying a Range Style Library During XRF Data Capture

Range Style libraries can be automatically applied to data points as they are 
captured using Discover Mobiles XRF connection functionality. 

1. Connect to the GPS

2. Ensure your XRF connection is Setup (Go>XRF>Setup)

Note This is a one-off application; any new data points added to the target table will 
not be modified by the Range Style library until this process is repeated.
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3. Connect to the portable XRF (Go>XRF>Connect) and after entering a 
batch number (or selecting an exisitng one), specify the Element, and 
Range Style library to apply to it (under the XRF Style pull-down). Press 
OK.

4. Each XRF data point will now be automatically styled as it's captured.

A Range Style library applied to XRF data automatically as field measurements are carried 
out.

For more information, see Appendix D: Connect to the XRF device.

Named Styles

Named styles allows you to create a library of graphical styles, which can then be 
applied when creating objects. Additionally, Quick Pick options and tables can be 
assigned to each object style (rather than relying on table-specific Quick Pick 
options). 

For example, four soil mesh sizes are to be collected into a soil_sampling table. 
Each soil mesh size would be assigned a unique symbol (e.g. different coloured 
circles), and these would all automatically populate the soil_sampling table, 
maintaining the same sample number series. However, selecting an -80 mesh 
size from the Named Style dialog will automatically populate a size field in this 
table with the ‘-80’ string, rather than requiring the user to select this from a Pick 
List.

• Creating a Named Style Library
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• Creating Named Styles on the Desktop

• Sample Named Styles Dataset

• File Management with Named Styles

• Setting up Named Styles for Multiple Users

For information on applying named styles, see Applying Named Styles.

Creating a Named Style Library

Prior to assigning a Named Style to an object, a Named Style library needs to be 
created. Select the GO>Edit>Named Styles menu option, and in the following 
dialog, press the New File button to name and create a new library. This will be 
saved to the Named Styles directory as a text file. The default library is named 
NamedStyles.txt. The named styles directory is set under the 
GO>Preferences>Directories>Named Styles command (it is recommended to 
set this to a location such a Storage Card rather than the default \My Documents 
location).

In the Named Styles dialog, press the Add button to add a new style. For each 
Named Style, the following can be defined:

• Name: the style name e.g. ‘-80 mesh’. This name is used solely for user 
reference/convenience, and is not used as an attribute.

• Object Type: point, polyline or polygon e.g. point.

• Object Style: for the specified object Type, the adjacent browse button 
allows the appropriate graphical style to be set (e.g. blue triangles for 
rock-chips, red cross-hatched region for granite outcrop).

• Capture Table (optional): specify the open table into which this named 
style will be captured e.g. ‘soil_sampling’.

• Quick Pick options (optional): for the specified capture table, define 
Quick Pick options relevant for this data type.  For example, a size field in 
the table may assigned as ‘Set Constant Value’ of ‘-80’.

To remove a Named Style,select the style and tap the Delete button. Multiple 
Named Style Libraries can be created and edited using the pull-down list at the 
top of the dialog.

If the Capture Table option is not set, the styles are not table specific and the new 
object will be stored in the current insertion table, regardless of the object type.
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If the Quick Pick option is not set, the only Quick Pick options that will be applied 
are those that have been set in the table with GO>Edit>Quick Pick Options. 

Creating Named Styles on the Desktop

For non-table specific named styles, the structure of the Named Styles file used 
by Discover Mobile is identical to a ColourMap table used in Discover. You can 
use the ColourMap function in Discover to create a Named Style file for Discover 
Mobile. The procedure for creating a Named Style file from Discover is a follows:

1. Start the ColourMap function in Discover using the Discover>ColourMap 
menu. 

2. Select Setup from the ColourMap menu and choose the Select Colour 
Table option from Colour Table Options on the left of the dialog. Select 
the colour table you wish to use from the selection list on the right of the 
dialog and assign the column you wish to use as the unique code and 
click OK.

3. Select Export to Discover Mobile from the ColourMap menu and assign 
an appropriate file name for the Named Style file and click OK.

4. Copy the newly created .TXT file to the Named Style directory on your 
mobile device.

Sample Named Styles Dataset

The Discover Mobile desktop installation includes a sample dataset. This data is 
installed to an ‘Example Data’ directory under the Discover Mobile folder (default 
location C:\Program Files\Encom\Discover Mobile\Example Data).  

This example dataset contains the tables (and associated Geoset Field_Data) 
used in the previous screenshots. It also contains the Named Styles example 
(Regional_Sampling.txt) and associated Pick Lists in the relevant subdirectories. 

To setup the sample on the mobile device:

1. Ensure that Discover Mobile is not running on the mobile device.

2. Copy the various data tables (soils, lag, rockchip, etc) and the 
Field_Data.gst geoset file into a PPC data directory. 
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3. Then copy the contents of the Example Data\NamedStyles and 
Example Data\PickLists subdirectories into the appropriate 
directories on the PPC as defined under GO>Preferences>Directories. 
Alternatively, copy these subdirectories in their entirety to the root level of 
the PPC storage card, and then point the Directories settings to these new 
directories.

Example data and the named Styles and PickLists subdirectories placed onto the 
Storage Card
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Configuring the Named Styles and Pick Lists directories within Discover Mobile to 
the Storage Card locations

4. Under GO>Preferences>Object Creation, set both the Named Styles 
and Edit Attributes dialogs to Always appear during data capture, and 
the Point XY Editing dialog to Never appear.
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5. To examine the Regional_Sampling Named Style library and its related  
Quick Pick options, select the GO>Edit>Named Styles menu option, and 
select this library from the pull down list.  At this point do not modify any 
settings.

6. Finally, choose GO>Map>Set>Insertion Layer and set to None. Named 
Styles will ignore any insertion layer set; however, if the user cancels out 
of the Named Styles dialog, Discover Mobile will utilise any Insertion Layer 
set to capture the object. Switching between Drawing object types (e.g. 
from point to region) during the object capture process will still result in the 
Insertion Layer prompt being displayed.
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Using the example named styles dataset:

1. To capture a soil sample location in the map window, display the Drawing 
toolbar, and tap the Capture Point button. Tap on any location in the map 
window (records where this soil sample was collected). 

In the field, the user would have a GPS receiver configured and 
connected to Discover Mobile, and would use the Capture GPS Point 
button to capture their current location as the soil sample location. 
However, unless you are in the Mt Isa region of Australia, a GPS location 
will not place the user within the example dataset.

2. The Named Styles dialog will appear, automatically filtered to only display 
the object type selected, in this case points.

Note When using the various GPS Capture options with Named Styles, ensure to first 
set the GO>GPS>Setup Data Capture Tables for each of the object types 
(points, polylines and polygons). For instance, create a ‘General’ table with 
suitable generic fields (particularly a large ‘Comments’ field), and set this as the 
default for all three object types. Then if the Named Styles dialog is cancelled by 
the user during the GPS capture process for any object type (i.e. no style is 
appropriate for the captured object), the object will be nevertheless captured into 
this general table; e.g. for unanticipated data types such as waterholes, historic 
workings, meteorite impact craters, sites of cultural significance, etc.
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3. Our soil sample has been sampled to the -20 mesh fraction, so choose the 
‘Soil -20’ option, and press OK (or double tap on the style).

4. The Edit Attributes browser will open for the Soil table, with all the Quick 
pick attributes auto-filled (including the current date). Note that an initial 
SampleID needs to be entered, otherwise the “Increment by 1’ option set 
for this filed will begin at 0. To continue an existing number series type 
2560. Also, the Comments field is a free text field for any additional 
comments the sampler may wish to make. 
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5. Press OK when finished. A yellow circle representing the soil sample will 
have been placed at the position tapped. Try capturing a few more soil 
samples of different mesh sizes) and note that they share the same 
sample number series, but that the Mesh attribute changes depending on 
the initial style selected.

6. Now record a rock-chip sample; the Edit Attributes dialog will now open 
the CRC browser. Note that in addition to the various Quick Pick options 
assigned (and again needing an initial SampleID), the Lithology field has 
an associated Pick List: tap on the pull-down arrow to the far right of this 
field to select from a list of available rock types.

7. Experiment with the other object styles: Fault (polyline) and Granite and 
Basalt (Region). Note that the Outcrop table (regions) has both Lithology 
and Occurrence pick lists.
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File Management with Named Styles

Intelligent table naming and handling will allow a Named Styles library to be 
preserved without file name changes over multiple days/months of use. 
Additionally it can allow the library to be utilised on multiple mobile devices (i.e. 
multiple field workers). 

1. Create the source tables as templates, from which field tables are cloned. 
For example, have a Soil_template and Lag_template stored under a 
separate ‘templates’ directory on the storage card. In this way the source 
table structures are preserved; the user never captures data into these 
template tables. 

2. At the start of the field collection campaign, each user clones the 
necessary data tables from the templates using the Clone From table 
option under the GO>File>New Table menu option. These could be 
saved into for example a ‘Field Data’ directory on the storage card. Thus a 
Lag table would be created from the Lag_template, and a Soil table form 
the Soil_template.

3. As illustrated previously, the Named Styles library will have been 
configured to capture data into these standard names Lag and Soil. If say 
date specific names were used, then the Named Styles library would have 
to be reconfigured regularly to point to date specific table names, which 
would be painful.

4. If multiple mobile devices are in use, ensure that any quick pick options 
involving user name attributes has been edited to reflect the user’s name. 
For instance in the example dataset, most of the tables have a ‘Geologist’ 
field with a ‘Set Constant Value’ of “MJ”. This would need to be altered on 
Andrew Smith’s device to “AS”.

5. Ensure the first sample number for each data type is set correctly on each 
device, particularly when multiple field workers (and therefore devices) are 
involved. For example, sampler A may have an initial rock-chip sample 
bag series starting at 38900, whilst sampler B may start their rock-chip 
bag series at 39500. 

6. Capture field data using the relevant style types in the named style library. 

7. At regular time periods (e.g. daily or weekly), make backups of the various 
field data files with date and user name suffixes into say a ‘Backups’ folder 
on the storage card. 
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For example, Mike Jones backs up his data files on 22/01/07. He uses the 
GO>File>Save Table Copy As option, and saves the Lag and Soil tables 
as Lag_MJ220107 and Soil_MJ220107. The user’s initials are important if 
multiple samplers are working with multiple devices, otherwise the 
database administrator may receive three Lag_22/01/07 tables from three 
different users. If or when possible, download them to a PC or email them 
to the data administrator.

8. At the end of a field campaign, the main field data tables (e.g. Lag and 
Soil) can be saved as say Soil_MJ15/02/02_final, and sent to the office. 
These tables will contain all the data for the period of the field campaign.

9. To start a new field campaign, delete the existing field data tables (e.g. 
Lag and Soil), then clone new ones from the templates. 

10. Alternatively, to utilise a new (empty) data table each day, save the 
previous days field tables off with a date and sampler suffix 
(GO>File>Save Table Copy As), close the field tables then clone new 
tables from the templates. This will result in a series of date stamped 
tables with data just for the date indicated. This is a little more complex to 
get right (particularly with continuation of sample number series), and is 
not generally recommended to save user confusion. Nevertheless it is 
another way of handling field data. 

Neither method requires any user modification of the Named Styles library nor its 
Quick options, except for the user name and sample number setups discussed in 
steps 4 and 5.

Setting up Named Styles for Multiple Users

As demonstrated in the sample Named Styles dataset section previously, 
migrating Named Styles libraries and related Quick Pick options between mobile 
devices is straight-forward process. Additionally field data templates and the 
necessary data and backup directories can also be replicated onto multiple 
devices, using the procedure outlined below:

1. On one device, create the following directories on the storage card:

• Field Templates – stores templates for each field data table (e.g. 
Soil_template). These are not to be altered by the field user

• Field Data – contains the working data files, cloned from the 
templates (e.g. Soil, Lag, etc)
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• Backups – daily or weekly backups of the working data files are 
saved here using GO>File>Save Table Copy As, e.g. Soil_AZ23/
01/07

• Config – all named style libraries and associated quick pick files 
are stored here. Alternatively separate PickList and NamedStyles 
directories could be created (as with the example data).

2. Either on the desktop, or on Discover Mobile, create the various 
templates. It is generally easiest to create the most complex one first, then 
clone the other templates from this first table, altering each as necessary. 
Save or transfer these templates into the ‘Field Templates’ directory on the 
mobile device.

3. Clone these templates and create the appropriate field data files (soil, lag, 
etc). Save these into the ‘Field Data’ directory.

4. Open these field tables into either a MapInfo Professional or Discover 
Mobile window, and create a Geoset session file. On the desktop, use the 
Tools>Tool Manager>MapX Geoset Utility; in Discover Mobile, use the 
GO>File>Save Geoset function. Place this Geoset in the ‘Field Data’ 
directory.

5. In Discover Mobile, set the GO>Preferences>Directories>Named 
Styles options for Named Styles and Pick Lists to point to the ‘Config’ 
directory (or whatever directories will be used for these files).

6. Create any required Pick Lists and name them after their destination fields 
in the existing tables. Place them in the Pick List directory (e.g. ‘Config’)

7. Create a Named Style library, and set the required Quick Pick options for 
each style type. 

8. Setup is now complete. Close Discover Mobile, and copy the four 
directories created in step 1 to a directory on the desktop PC (‘Field 
Setup’).

9. Disconnect the mobile device from the PC, and connect the next PPC to 
the PC. Ensure that Discover Mobile is not running on the PPC, and then 
copy the four directories from the PC to the mobile device.

10. On the mobile device, set the GO>Preferences>Directories>Named 
Styles options for Named Styles and Pick Lists to point to the new ‘Config’ 
directory.
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11. Ensure that any user specific Quick Pick options (i.e. sampler name or 
initials) are configured via GO>Edit>Named Styles), as well as initial 
sample numbers for each data type.

Range Styles

The symbol style of numeric point data can be permanently altered with a Range 
Style library. This functionality is similar to the Point Classification tool in the 
Discover Geochem module.

A Range Style library consists of a series of user-defined numeric ranges, each 
with an assigned symbol style.

• Creating a Range Style Library

• Editing a Range Style Library

• Creating a Range Style Library on the Desktop

For information on applying range styles, seeApplying Range Styles and Applying 
a Range Style Library During XRF Data Capture.

Creating a Range Style Library

1. To create a Range Style library within Discover Mobile, select the 
Go>Edit>Range Styles menu option.

2. Select the New Style button (top left)

3. Enter a name for the library; it will be saved into the Current Project 
directory (as set under Preferences>Directories)
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4. Press the Add button (bottom right); a new range will be added to the 
library. Enter the desired lower (>=)  and upper/high (<) values. Also set 
an appropriate symbol style by pressing the adjacent symbol button.

5. Repeat step 4 for each additional required range:

6. Range values can treated as percentiles by enabling the Percentile 
option at the bottom of the dialog.
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7. Press OK to finish creating the library.

Editing a Range Style Library

1. Select the Go>Edit>Range Styles menu option.

2. From the pull-down list at the top right, select the library to edit.

3. Add or Delete ranges as necessary, or edit existing range values and 
styles.

4. Press OK to finish editing the library.

Creating a Range Style Library on the Desktop

The Range Style Editor installed with Discover Mobile's desktop tools is an easier 
way of creating Range Style libraries. See the Range Style Editor for more 
information.

Labels and Annotation

• Adding Labels and Annotation

• Removing Labels and Annotations

Adding Labels and Annotation

Note Ranged Styles created as Percentile ranges cannot be auto-applied to XRF 
data. Percentile-based ranged styles will not be displayed in the list of available 
styles displayed in GO>XRF>Connect

The Add Label button places automatic labels (from a selected column in the 
browser) for selected objects. The labels are placed in a special layer called the 
Annotation Layer. The source of the labels and their display properties can be 
modified using the Layer Control dialog. The labels are placed in the Annotation 
Layer and cannot be permanently saved. To remove annotations/labels from the 
map use the Clear Custom Labels popup menu on the Add Label button.
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Removing Labels and Annotations

To remove all labels from the annotation layer, choose GO>Edit>Clear Custom 
Labels.

To remove all annotations from the annotation layer, choose GO>Edit>Clear 
Annotations.

Individual labels and annotations cannot be removed.

Hotlinking Files to Map Objects

Information located in external files can be linked as attributes to map objects in 
Discover Mobile using the table Hotlink function. For example, if you wish to 
record a detailed description of a sample site, you can record this information 
using Pocket Word and then store the file path and file name as an attribute in the 
browser for the sample. Similarly, Pocket Excel spreadsheets, Audio files or 
image files can also be hotlinked.

• Adding Hotlink Field to Table

• Creating a Hotlink

• Editing a Hotlink File

• Using the Hotlink Files in MapInfo

• Hotlink Images from the PPC Camera

Adding Hotlink Field to Table

To attach a hotlink file to a map object you must first add an attribute field to your 
table to store the pathway for the hotlink object. This can either be done on your 
desktop computer in MapInfo Professional and copied to Discover Mobile or you 
can create a new table in Discover Mobile using the GO>File>New Table menu 
to create a new table.

The Add Annotation button allows additional text to be placed in the Annotation 
Layer at a set location on a map. This text is placed in the Annotation layer and 
cannot be transferred or saved to a specified layer. Ensure the pop-up keyboard 
is open before selecting this tool.
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Creating a Hotlink

To create hotlink attribute:

1. Add a map object to your table. 

3. Click the dropdown button located next to the hotlink field. You will be 
presented with an Edit List. Click the Edit List option.

Hotlinking a field

4. Tap on the Auto Field list at the bottom of the screen. Use the scroll bar to 
display the available hotlink options:

• Link File

• Link Image

• Link New Audio

• Link New Pocket Word

• Link New Pocket Excel

• Link New Custom

2. Tap on the map object with the Information Tool to display the current 
objects attributes.
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Selecting the Hotlink type

5. Select the appropriate hotlink file type and tap OK to return to the attribute 
list. In the pull-down list next to the column designated to store the hotlink 
path, select the link new file entry (e.g. Link New Pocket Excel document 
is displayed if the Link New Pocket Excel Auto Field was selected).

6. Pocket Excel will then load and ask you for a file name or new file. To 
create a new file tap the New button and enter the desired information into 
Pocket Excel. 
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7. When data entry is complete, save the file in the Discover Mobile Hotlink 
directory (set under GO>Preferences menu) with a preferred name and 
then click OK. A dialog with the new Discover Mobile link filename and 
pathway will be displayed. Tap OK to exit this dialog and check that the 
new file name and path are stored in the hotlink column.

Editing a Hotlink File

To return to a hotlink file for editing bring up the browser window and tap on the 
hotlink field. A menu will appear with an Open and Expand entry. Select the Open 
menu to open the file.

Using the Hotlink Files in MapInfo

In order to use the hotlink files created in Discover Mobile back in MapInfo 
Professional on the desktop, you need to copy both the .TAB file and the hotlink 
files to the desktop computer. If you store all your hotlink files in the Discover 
mobile hotlinks directory (configured under the GO>Preferences menu) then you 
can simply copy the entire contents of this directory back to your desktop 
computer. 

To make this process as simple as possible, it is recommended that you store the 
.TAB file containing the hotlink attribute and the linked files in the same directory. 
Once the files are copied back to your desktop computer you can use the 
DiscoverMobile>Convert Hotlinks tool to remap the file paths and extensions 
so they will work on the desktop computer.



10 Working with Objects 247

Hotlink Images from the PPC Camera

To create image hotlink from camera:

1. Navigate to GO>Preferences>Directories>Image Files ensure that the 
path for the Images files is set to the path where images created from the 
PPC camera are stored.

2. Using the PPC camera take a photo.

3. Create a new map object within a specified layer. The object can be a 
point, line or polygon. After the graphical object has been created the table 
browser record is presented. Alternatively, an existing map object can be 
used and selected.

4. Ensuring a Hotlink field is present in the layer (preferably string field 254 
width). Click the dropdown button located next to the hotlink field. You will 
be presented with an Edit List. Click the Edit List option.

5. Tap on the Auto Field list at the bottom of the screen. Use the scroll bar to 
display the Link Image option and select. Click OK to have this as a Quick 
Pick option.
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6. Click on the => Link Image option. This will open a directory where the 
camera images were saved. Select the relevant image. Click OK within 
the Browser Window to commit the image linking.
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8. To inherit the image links when transferring the PPC data to the desktop/
laptop use the DiscoverMobile>Convert Hotlinks tool.

7. To simply view the hotlink camera image navigate to the Select Toolbar 
Info icon and select Image. This tool can be used to display the linked 
image by clicking on the object with the linked image. If an object to select 
with no image link the following message is displayed "No image to 
display".
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11 Working with the GPS
Discover Mobile has been designed to connect to a wide selection of GPS 
receivers, including handheld devices from Garmin, Magellan and Trimble. 
Receiver types include Compact Flash (CF) card GPS units, Bluetooth units and 
backpack differential DGPS receivers. 

Discover Mobile supports the industry standard NMEA (National Marine 
Electronics Association)  0183 version 2 protocol, so any GPS receiver which 
outputs data using this protocol should work efficiently with Discover Mobile.  

It also supports Trimble’s proprietary TSIP protocol, allowing the collection of high 
precision and differential GPS data (both real-time and post-processed) with the 
appropriate receivers.

• Connecting to the GPS

• Displaying the Current Position

• Monitoring Satellite Status

• Navigating to a Known Point

• Tracking Your Path

For information on setting up a DGPS connection and how to correct DGPS data, 
see Working with Differential GPS (DGPS).

For information on controlling the view with the GPS, see Auto-Rotate and Auto-
Centre.

For information on capturing GPS-located objects, see Creating GPS-Located 
Objects.

Connecting to the GPS

• Connecting to an NMEA GPS Receiver

• Troubleshooting an NMEA GPS Connection

• Connecting to a Trimble Receiver

• Connection Hardware
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Connecting to an NMEA GPS Receiver

The basic process to connect Discover Mobile to a GPS for the first time is as 
follows:

1. Under the GO>Preferences menu option, ensure that the GPS Protocol is 
set to NMEA.

2. If necessary, turn on the GPS, and check that it is connected correctly to 
the PPC device (via the appropriate cables or connections, e.g. a 
Bluetooth or serial port connection). See Connection Hardware for further 
information.

3. Ensure that no other third party GPS software is running on the PPC; most 
PPC devices will only allow one software application to access the GPS 
communication port at a time.

4. From GO>Preferences>Connection>Setup or GO>GPS>Setup 
Connection, open the GPS setup screen. The connection port for the 
GPS receiver needs to be set manually, as do the port settings Speed, 
Parity, Data and Stop. The settings are typically provided by the 
manufacturer of the GPS receiver in the accompanying documentation. 
Once these settings are set, press Start to test the connection. After a 
short period of time (up to about 30 seconds), a continuous NMEA data 
stream should be displayed—each line starts with ‘$GP….’, which 
indicates a successful connection with the receiver. 

Example of Setup Connection dialog with a valid GPS connection
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5. If uncertain about the receiver settings, or the data stream fails to appear, 
or a message ‘Bad Data’ is displayed, the settings are incorrect. Try 
pressing the Scan button at the bottom of the dialog; Discover Mobile will 
run through every permutation of settings attempting to establish a 
connection to your GPS receiver. See Troubleshooting an NMEA GPS 
Connection for further information.

6. Once a valid data stream from the GPS is displayed, press the Stop 
button. Make a note of the various settings for future reference, and close 
the dialog. These settings will be automatically retained unless Discover 
Mobile is reinstalled or the settings are changed (for instance if a different 
GPS receiver is used).

7. Select the GO>GPS>Connect menu option to connect to the GPS 
receiver. Once the receiver has found sufficient valid satellites (use 
GO>GPS>Monitor Satellite Status to observe the current visible 
satellites), a current position fix will be displayed. A ‘GPS – Fix 2D’ or 
‘GPS – Fix 3D’ message will be displayed at the top of the map window. 

Discover Mobile is now ready for data capture.

Troubleshooting an NMEA GPS Connection 

The Setup Connection dialog is used to help configure and debug a NMEA GPS 
connection. To display the setup dialog, choose GO>GPS>Setup Connection or 
tap Setup from the Connection dialog. The Setup Connection dialog displays raw 
data as it is received from the GPS receiver (and gives an estimate of the signal 
quality if satellites are in view). Discover Mobile will only be able to read and 
display the GPS data in the output window if the serial port communication 
settings are set correctly.

There are several controls available on this dialog:

• Start – opens the GPS port using the settings selected at the top of the 
dialog. If the port is successfully opened and valid data is found it will be 
displayed in the output window.

• Stop – closes the GPS port.

• Clear – clears the data stream from the display window.

Note After this initial GPS connection setup, the user only has to enable the 
GO>GPS>Connect option to reconnect to the same GPS receiver (assuming 
that the connection settings discussed in step 3 have not been altered). 
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Once the connection Port for the GPS receiver and the appropriate settings 
(Speed, Parity, Data and Stop) have been specified, press the Start button. If 
Discover Mobile detects NMEA format data on the selected COM port, it will 
display the raw sentence information in the window (see below). 

Example of Setup Connection dialog with a valid GPS connection

If there is no NMEA data available on the selected COM port, the display window 
will remain blank except for a message “Output will be displayed here” (see figure 
below) or an error “Bad Data”.
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Setup Connection dialog indicating that no NMEA data is available on the specified 
communication port and settings

If the communication parameters are unknown, or no NMEA data is found with 
the specified setting, use the Scan button: 

• Scan - can be used when first attempting to connect a GPS receiver to 
Discover Mobile. Discover Mobile will scan all selected COM ports and 
communication settings on the PPC looking for a valid NMEA GPS signal. 
If a valid connection port and signal is found, the scan will stop and the 
raw GPS data will be output to the display window. The communication 
settings will then be saved to the Connection preferences when the dialog 
is exited.

• Before commencing a scan, the list of COM ports, Speed, Data, Parity and 
Stop bit combinations checked by Discover Mobile may need to be 
modified. This can be done by tapping on the Browse button in the top 
right of the Setup Connection dialog. All settings that are highlighted in 
the configuration dialog will be scanned by Discover Mobile. If it is known 
that the particular GPS does not communicate at speeds less than 4800 
baud or greater than 19200 baud, then remove (deselect) those speed 
settings from the list. Discover Mobile will skip those options during the 
scan. Certain COM ports can also be deselected to prevent Discover 
Mobile from scanning these. This can be particularly useful if the GPS is 
connected via a Serial Cable and the Bluetooth Port (generally COM port 
8) is to be bypassed during the scan.
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Example of the Scan configuration dialog showing a subset of the available options 
selected for scanning by Discover Mobile

If raw GPS information is displayed in the output screen, some extra status 
information will also appear along the bottom of the screen between the output 
display window and the buttons. This information describes the status of the GPS 
connection. The DATA [++ - -] indicator on the right indicates the quality of the 
data stream. The quality is measured as the number of GPS sentences Discover 
Mobile can process without error. Possible values are:

Data [- - - -] = no valid data

Data [+ - - -] = many errors, very poor data

Data [++ - -] = some errors, data connection OK

Data [+++ -] = occasional error, data good

Data [++++] = No errors, data excellent

Note The Scan function in Discover Mobile should be capable of detecting which 
COM port the GPS receiver is attached to. However if the correct settings are 
already known for the GPS unit (.e.g. from GPS user manual), it is 
recommended that the Speed, Parity, Data and Stop Bits parameters are 
manually set. 
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Most GPS units will output valid NMEA data regardless of whether they have a 
current position fix or not. If the connected GPS has obtained a position fix, the 
third status indicator will show the raw GPS Latitude and Longitude position.

• Enable RTS – this tick box can be used to enable the Request to Send 
option. When enabled the mobile device will send a signal to the GPS to 
instruct it to start transmitting. This option should be enabled when 
working with GPS receivers connected via a serial device such as DGPS 
units.  

• Log to file - tick box can be used to save a log of the raw GPS data to a 
text file. The text file is saved to the \MY DOCUMENTS folder on the PPC 
and is called GPSLog.txt.

Note When using Discover Mobile with a GPS is very important that you do not have 
any third party GPS software running. This includes any software (other than the 
necessary drivers) that came with the GPS receiver. Most PPC devices will only 
allow one software application to access the serial port at a time. Therefore, if 
you have two pieces of software trying to read data from the GPS port at the 
same time, they will generally cause the connection to fail.
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Connecting to a Trimble Receiver

Trimble’s high precision receivers (e.g. the GeoExplorer series of integrated 
mobile device and receivers) and DGPS receivers (e.g. the ProXT) utilize 
Trimble’s proprietary TSIP protocol. To setup a connection with a receiver using 
this protocol:

1. Under the GO>Preferences menu option, ensure that the GPS Protocol 
is set to Trimble.

2. If necessary, turn on the GPS, and check that it is connected correctly to 
the PPC device (via the appropriate cables or connections, e.g. a 
Bluetooth or serial port connection). See Connection Hardware for further 
information.

3. Ensure that no other third party GPS software is running on the PPC; most 
PPC devices will only allow one software application to access the GPS 
communication port at a time.

4. Either via GO>Preferences>Connection>Setup, or via GO>GPS>Setup 
Connection, open the GPS setup screen.

5. Set the required communication Port that the receiver is connected to 
(e.g. Bluetooth or serial port). Certain devices (such as Trimble 
GeoExplorer units running Windows Mobile 5) have a GPS Connector (or 
similar) application (under Start>Settings>Connections) which clearly 
identify the COM ports for the GPS receiver (and the various protocols).

6. The various Masks available in this dialog allow poor satellite data to be 
filtered out (e.g. satellites low on the horizon, or those resulting in a high 
signal-to-noise ratio), improving the precision on the position fix. These 
are discussed fully under the Trimble Protocol section of the 
Preferences menu.

7. These settings will be automatically retained unless Discover Mobile is 
reinstalled or the settings are changed (for instance if a different GPS 
receiver is used).

Note Only use the log to file option to assist with debugging a GPS connection. If 
difficulties are experienced maintaining a GPS connection or errors are 
encountered using the GPS encounter, record a 1 minute log file under normal 
operation. Email this text file as an attachment to pbbi.support@pb.com along 
with a description of the problem so Piney Bowes Business Insight can assist in 
resolving the issue.

mailto:pbbi.support@pb.com
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8. Select the GO>GPS>Connect menu option to connect to the GPS 
receiver. Once the receiver has found sufficient valid satellites (use 
GO>GPS>Monitor Satellite Status to observe the current visible 
satellites), a current position fix will be displayed. A ‘GPS – Fix 2D’ or 
‘GPS – Fix 3D’ message will be displayed at the top of the map window. 

Discover Mobile is now ready for data capture.

Connection Hardware

If you have a Compact Flash card (CF) GPS, Navman sleeve GPS or a Bluetooth 
GPS you do not require any cables to connect the GPS receiver to the PPC 
device. These GPS units are designed to attach and communicate directly with 
the PPC using a standard expansion slot or communication protocol. If you intend 
to use a Bluetooth GPS receiver you will also need a Bluetooth-equipped PPC 
device or you will need to purchase a separate Bluetooth expansion card. 

Conventional hand held GPS units such as those from Garmin or Magellan will 
also require an accessory cable to connect the GPS receiver to the PPC device. 
Many GPS and mobile devices have unique fittings so you may have to shop 
around to find the appropriate serial cable and adapter to connect the two units.

Most serial cables which connect a GPS to a desktop PC are designed to connect 
directly to the serial port using a standard 9 pin (DB9) serial connector. Most PPC 
devices have proprietary data connections so a special serial cable is generally 
required to connect a GPS to these devices.  Most GPS serial cables and 
proprietary PPC serial cables have 9-pin DB9 female connectors on their ends. 
Therefore, to connect these two female cables together, you may need a 9-pin 
male to male gender changer. These can be purchased from most electronics 
stores.

In some cases a null modem adapter may also be needed to connect the GPS 
receiver to the sync cable on the PPC device. The reason for this is that both 
mobile PPC devices and PC computers use pin 2 on their serial ports to receive 
data and pin 3 to transmit data. Therefore a PPC could not communicate with a 
desktop PC using a standard serial cable because both devices would be trying 
to send and receive data on the same pins. To overcome this problem most PPC 
devices use special sync serial cables. These cables differ from standard serial 
cables in that pins 2 and 3 have been swapped on the end which connects to the 
PC computer. This enables the PC and PPC to communicate because data is 
now being sent and received between the two machines on the correct pins. 

Note After this initial GPS connection setup, the user only has to enable the 
GO>GPS>Connect option to reconnect to the same GPS receiver (assuming 
that the connection settings discussed in step 3 have not been altered). 
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Because most GPS serial cables are designed to connect directly to the serial 
port on a PC computer, they too have pins 2 and 3 swapped on the end which 
connects to the PC. This enables the GPS to communicate with the computer in 
exactly the same way a PPC would do using a sync cable. However this poses a 
problem again when the GPS cable is connected to the sync cable on the PPC. 
In this case both the GPS and the PPC serial cables have pins 2 and 3 swapped 
and therefore send and receive data on the same pins again. To overcome this 
problem a null modem adapter is available. 

The purpose of a null modem adapter is to cancel the reversal of pins 2 and 3 on 
the sync cable so that both devices can communicate again. There is no easy way 
of telling if a PPC serial cable is a sync cable, however, in general, if the PPC 
serial cable has a 9-pin (DB9) female connector on one end it is probably a sync 
cable and will therefore require a null modem adapter to communicate with a GPS 
serial cable. Null modem adapters can be purchased from most electronics 
stores.

Displaying the Current Position

To display the current position on a map:

1. Make sure the GPS receiver is turned on and that it has been configured 
to connect to Discover Mobile (see the sections above for establishing a 
connection to either a NMEA or Trimble receiver).

2. Activate the GPS toolbar by tapping the GPS icon on the main toolbar. 
You should then see the GPS toolbar appear. All buttons on the GPS 
toolbar should be inactive (grey) except for the Connect button, the Rotate 
North and Setup buttons.

3. Connect to the GPS by tapping the Connect button on the far left of the 
GPS tool bar. Alternatively, use the GO>GPS>Connect menu item.

4. Discover Mobile will attempt to open the appropriate COM port (using the 
previously configured settings) and establish a connection with the GPS. 
If this step is successful all the buttons on the GPS toolbar will become 
active and you will see a red hollow circle appear in the centre of the map 
display.
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A successful GPS connection, indicated by a red circle in the centre of the map display and 
all buttons on the GPS button bar are active.

To change the zoom level of the map window tap the small arrow next to the multi 
zoom button on the Select toolbar and choose the zoom scale menu. Adjust the 
zoom scale to an appropriate level (e.g. width 1000m).

If Discover Mobile cannot establish a valid connection to the GPS receiver, or if it 
detects a large number of errors in the incoming data stream, an error message 
will appear. If this occurs, check the following and try again:

• The GPS is turned on.

• If the receiver is a Trimble unit, ensure that is outputting the desired 
protocol (NMEA or Trimble: see the receivers documentation and 
configuration software such as GPS Controller).

• The receiver is connected to the mobile device (cables are correctly 
connected or Bluetooth connection established).

• The appropriate protocol and communication settings have been set in 
Discover Mobile to match the GPS unit.

To view your current position coordinates and determine the zoom scale of your 
map display, tap the Status window button, which is located next to the GPS 
button on the main toolbar. The floating Status window will appear on the map 
displaying the current position fix and other information from the GPS. It will also 
indicate the current zoom level of the map window.
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• No other applications on the PPC are sourcing the GPS data.

• If using NMEA protocol, the raw GPS data is visible in the Setup 
Connection dialog after pressing the Start button.

If the above settings appear correct and you still have difficulties connecting to the 
GPS receiver, perform a soft reset of the PPC device and try again.

Error message indicating that communication cannot be established between Discover 
Mobile and the GPS receiver

Monitoring Satellite Status 

Choose GO>GPS>Monitor Satellite Status to display the Monitor Satellite 
Status dialog, which shows the number and position of satellites currently in view. 
If a satellite is red it is not used in the GPS fix. Each available satellite is numbered 
and the corresponding signal strength is displayed as a bar in the Satellite 
Strength Plot. 

Example of the available satellites and their signal strength
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A mini-version of this bar graph can be displayed at the bottom left of the map 
window using the GO>View>GPS Overlay menu option.

Map window with GPS Overlay (mini-Satellite Status) displayed (highlighted in red).

Navigating to a Known Point

Discover Mobile provides a Waypoint Navigation tool for use with a GPS receiver. 
The waypoint navigation tool allows the selection of an existing map object (eg 
point, polygon) as a destination waypoint; it will then report the distance and 
bearing between the current GPS location and the selected waypoint feature in a 
waypoint message window.

1. Open an existing layer that already contains the destination point or add a 
Cosmetic Layer to the map window and then add a point to the cosmetic 
layer which represents the destination location. 

2. Connect and start the GPS.

The waypoint navigation tool is accessed from the Waypoint Navigation button 
on the GPS button bar (or choose GO>GPS>Waypoint Navigation). To use the 
waypoint navigation tool:

3. Tap the Waypoint Navigation button on the GPS button bar. A status 
window should appear prompting the selection of the destination 
waypoint. 
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4. Select the destination point (the black flag in the above screenshot) to 
select it. The waypoint status window will change to show the distance 
and bearing from the current position to the waypoint. 

5. The current position symbol will also change from the default symbol to an 
orientated red triangle. This will point in the direction of the waypoint as 
long as the waypoint navigation function is active. The default waypoint 
symbol can be changed under the GO>GPS>Default Styles>Way Point 
Navigation Style menu option. By default Discover Mobile reports the 
waypoint bearing as an angular value clockwise from North. The distance 
value will be reported in the distance units specified under the 
Preferences menu. 
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When the user arrives within the tolerance distance of the selected waypoint, 
Discover Mobile will display a message indicating arrival at the destination and 
will automatically turn off the waypoint navigation tool. The default waypoint 
tolerance value is 10m; this can be modified in the GO>Preferences>Waypoint 
Tolerance value option.

To navigate to a different waypoint, turn the waypoint navigation tool off and then 
on again by tapping the Waypoint Navigation button. Select the new destination 
point and Discover Mobile will re-compute the distance and bearing from the 
current location to the new waypoint. 
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Tracking Your Path

• GPS Point Log

• GPS Line Log

GPS Point Log

Choose GO>GPS>Point Log to record a log of the travelled path as a series of 
points. The frequency at which the points will be collected is determined by the 
GPS Connection Interval and the GPS Point Capture Tolerance Min values 
(under the GO>Preferences>GPS menu). If a minimum tolerance value of 20m 
is set then the Point Track Log will only be updated with a new point when the 
distance between the last point and the new point exceeds the 20m minimum. 
This enables the user to remain stationary and take notes or enter data while the 
Track Log function is still running and not have a series of unnecessary points 
added to the log file.

Starting the GPS Point Track Log function for the first time in a Discover Mobile 
session, will prompt for a table name and location in which to save the data. Either 
a new table can be created, or a previously created Track Log table may be 
selected. By default the Point Track Log is saved to a GPS_Point_Log.TAB file 
in the \My Documents folder in main memory. This default can be accepted or a 
new name and file location can be specified. 

The Point Track Log can also save any information available from the GPS 
receiver as attributes for each point in the log. The attribute data is automatically 
added to the appropriate column (or field) in the point track log table. A default set 
of common fields is automatically added when a new Point Track Log table is 
created. To change the fields or to add additional fields tap the Setup button. 
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The Setup dialogs for the Point Track Log function. Any attribute fields listed in the Data to 
be logged list will be added to the Point Track Log table and will be automatically populated 
with data from the GPS. Use the Setup… button to change the list of fields to be logged.

Within this dialog, the list of output fields can be customised. When finished, tap 
OK to create the table and start the Point Track Log function.

Note Once a Point Track Log table is created, additional fields cannot be added to the 
table in Discover Mobile. Either add these fields on a PC using MapInfo 
Professional or to save a copy of the Point Track Log table and add the extra 
fields to the copied table.

To stop the Point Track Log tap the Point Track Log button on the toolbar to 
toggle it off. Turn it on again at any time by tapping the same button again. If an 
existing Point Track Log table is already open, a prompt will be displayed to 
either continue appending to the existing table or to create a new table.
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Left image shows a Point Track Log with Current position (Red Circle) and a point log (grey 
circles) of path travelled. Right image shows the GPS attributes associated with one of the 
points

GPS Line Log

GO>GPS>Line Log

Choose GO>GPS>Line Log to record a log of the travelled path as a series of 
line segments. The Line Track Log will look like a continuous line on the screen, 
however, it is actually made up of a series of line segments rather than one 
continuous line. This way, the GPS attribute information can be stored for each 
segment of the Line Track Log; any segment of the Line Log can therefore be 
queried to determine the GPS coordinates, time, date, speed etc of that segment.

See the GPS Point Track Log section above for setup and use of the GPS Line 
Track log.



11 Working with the GPS 269

  
Left image shows a Line Track Log (black line) of path the travelled with Current position 
(Red circle) and a line segment selected point. Right image shows the GPS attributes 
associated with the selected line segment. 

Working with Differential GPS (DGPS)

Differential GPS allows very accurate (sub-meter) positioning by calculating the 
current GPS error at a base station, and then applying this as a correction to the 
field data. Differential GPS therefore requires two receivers to operate 
simultaneously; field data is collected with a rover unit, whilst the other receiver is 
placed at a base station for which the position is accurately known. 

The base station GPS position data is compared to it’s known (surveyed) position, 
and a position error is calculated. Using this known error, a correction can then 
be applied to the field unit data to provide a more accurate field position. This 
correction can be applied either in real time (Real-time DGPS/RTK) via radio 
signal or after field work/data collection has been completed (Post-processed 
DGPS).

Post-processed DPGS only requires the user to have direct access to one 
receiver (the field/rover unit eg a Trimble Pro XRS or XT). The base station data 
is generally provided via a continuously-operating commercial reference station. 
This data is normally accessed via the internet based on the timeframe and 
location of the field data collection. Discover Mobile supports Postprocess DGPS 
work using the Trimble Protocol.
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There are three distinct phases to DGPS usage:

1. Configuring Discover Mobile for DGPS Work.

2. Field Data Collection - The field rover DGPS unit generates a Trimble 
Rover SSF file, which is captured by Discover Mobile along with the 
MapInfo Professional TAB files containing the field data (geochemical 
samples, structural and geological mapping, etc).

3. Post-processing

• Rover SSF File Correction: At the conclusion of data collection, 
the relevant (closest) reference base station is accessed via 
internet (or the data is accessed electronically), and the appropriate 
Trimble Base Station SSF file is acquired (with reference to the field 
data time stamp). The Base Station SSF file (which incorporates the 
base station’s known position coordinates) is used to calculate a 
GPS-error correction. This correction is then applied to the Rover 
SSF file.

• Rover File Export: the corrected SSF file is exported as a MapInfo 
Professional MIF file to allow field data correction

• Field data correction: the field data TAB files are corrected using 
the corrected Rover SSF file (now a MIF file).

Configuring Discover Mobile for DGPS Work

The Discover Mobile Preferences screen (GO>Preferences) contains a number 
of options under the GO>GPS>Connection section integral to DGPS 
configuration and Rover file generation.

GPS Protocol

Ensure that this option is set to Trimble. 

Note Desktop post-processing of field data requires installation of Discover 10.1 or 
later, as well as Trimble GPS Pathfinder Office 4.00 or later.

Note This section only details Discover Mobile setup/configuration and data correction 
for Post Processing DGPS with a Trimble DGPS unit; it does not cover setup/
configuration for Real Time (RTK) DGPS.
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Setup

After assigning the GPS Protocol as Trimble, the Setup option should now 
indicate Trimble. Select the ‘…’ button adjacent to this option to open the General 
tab of the Trimble DGPS Configuration dialog:

This screen allows the control of various parameters which affect the efficiency 
and precision of the DGPS position. These parameters are fully detailed in 
Trimble Protocol. When these parameters have been set, press OK to return to 
the main Preferences screen. 

SSF Logging

Set this option to On to create a Trimble SSF format Rover file with the same 
name as the file into which data is being captured. 

This rover file is required to allow postprocessing differential correction to be 
carried out on captured data, but needs to be populated with one of the following 
options.

Recommended settings for post-processed DGPS use (with carrier phase logging 
enabled)
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Post Processing

This enables the enable the Carrier phase signal of the Trimble output to be 
logged. Utilizing this signal (in tandem with the default Code phase signal) will 
increase the accuracy of the post-processing correction; however it requires the 
user to be within 50 kilometres of the base station, and to maintain continuous 
Carrier phase lock for 10 minutes.

Three logging modes are available:

• None: no carrier phase data is logged. The data set will not be able to be 
post-processed.

• Continuous: carrier phase data is logged at 1 second intervals

• Classic: carrier phase data is logged at heat beat rate when not capturing 
an object location, and at the object logging rate when logging an object.

See Carrier Phase Logging for further information.

Min Sample Points

This setting defines the number of point calculations required before a position is 
established.  A position is calculated by averaging the specified number of point 
calculations; thus the higher this parameter is set, the longer it will take to 
generate a position, but the more precise the position will be. It is recommended 
to use a setting of 15 points.

Precision Filter

Various quality levels of position fix can be output by DGPS receivers, depending 
on factors such as the number of satellites, the quality of the satellite signal 
(influenced by the amount of satellite coverage and overhead cover), the quality 
of radio reception (for Real-Time DGPS) and the parameters assigned in the 
Setup dialog. The quality of the current position fix is indicated at the bottom left 
of the map screen.

Discover Mobile allows a Precision Filter to be selected, which will display a 
warning when data capture is attempted with a fix quality lower than the set 
Precision Filter. These Filter levels are detailed below; select the DGPS filter for 
post-processed DGPS work.

• GPS - Any current position fix (GPS or DGPS) will be accepted

• DGPS - Requires a Differential GPS fix (Real-time or Post-processed)

• RTK LOW - Requires a low-quality Real-time Differential solution
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• RTK HIGH - Requires a high-quality Real-time Differential solution

Field Data Collection

• Data Storage

• GPS Connection

• Carrier Phase Logging

For information on capturing objects, see Creating GPS-Located Objects.

Data Storage

It is strongly recommended that all field data (capture) tables are created and 
saved onto the memory card rather than main memory. This ensures that in the 
event of a flat battery or system crash, the collected data is not lost.  A high speed 
memory card is recommended; low speed memory cards can significantly impact 
data handling and processing efficiency.

The Trimble SSF format Rover file created when the SSF Logging option is set to 
On (in Preferences) will also be saved to the same location as its parent file, with 
the same file name and a .SSF suffix.

GPS Connection

 
To connect to the DGPS, either select GO>GPS>Connect, or open the GPS 
toolbar by selecting the GPS button and then select the Connect button. 
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The initial GPS connection screen; tap the screen once to refresh the display

This will display a “Connecting to GPS” message; tap the screen once to refresh. 
Once connected a GPS Overlay (red target) will be placed on the screen with a 
“Waiting for GPS Time” message whist a position fix is acquired. This may take 
some time depending on the GPS preferences set, number of satellites available, 
amount of overhead cover (eg foliage) and the amount of sky visible (due to cliffs, 
buildings, etc). To monitor the current number of acquired satellites and their 
strength, select GO>GPS>Monitor Satellite Status.



11 Working with the GPS 275

Initial display while DGPS unit acquires satellite feed

Monitor Satellite Status screen

Once a position fix is calculated, the “Waiting for GPS Time” message will 
disappear, and the GPS Overlay will be positioned accordingly.
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Carrier Phase Logging

Once a position fix is calculated, the position quality status indicator (bottom left 
of the map screen) will be followed by a “Disabled” message if Carrier phase data 
logging is enabled (see the GPS>Connection>Log Carrier option under Trimble 
DGPS Configuration). This indicates that Carrier phase logging is yet to be 
initialized. Capturing a point (see below, Point Capture) will initialize Carrier 
phase logging, changing this status message to “Locked”, followed by the time in 
seconds (bracketed) since this locked status was acquired. 

Status message at the bottom left of screen indicates Carrier Lock is Disabled, awaiting 
initialization by point capture
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Carrier Lock Initialization by point capture; the status message now displays “Locked” 
followed by the time in seconds since lock acquisition

Use of the Carrier phase signal for post-processing requires the base station and 
rover unit to be within 50 kilometres of each other. Carrier wave data must also 
be continuously logged for a minimum of 10 minutes (600 seconds) for sufficient 
data to be acquired to allow high precision post-processing. During this time, data 
must be logged from the minimum number of satellites set in the Min Satellites 
option of the Setup dialog (4 or 5). If the number of satellites falls below this 
parameter, the “Carrier Lock” is broken; the “Locked” message will change to “No 
Lock”, with the timer reset to 0 seconds. Once the minimum time (10 minutes) has 
elapsed, all data captured within this period of Carrier Lock can be more precisely 
post-processed. If Carrier Lock is broken and the timer reset within 10 minutes of 
initialization, the carrier phase data captured may not be sufficient to ensure high 
precision post-processing for this block of data.
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“No Lock” Carrier status message indicates Carrier Lock has been lost; timer has been 
reset to 0

Efficient logging of Carrier phase data therefore requires an uninterrupted view of 
the sky (no buildings or overhead cover) to ensure that Carrier Lock is maintained. 
It is recommended to not move to the next data capture location before the 
minimum time (10 minutes) unless the user is certain Carrier Lock will not be lost. 
Lowering some of the Setup parameters (eg Min SNR, Min Satellites, Max HDOP 
and PDOP and Min Elevation) will allow better maintenance/continuity of Carrier 
Lock, but with a loss of precision.

Post-processing

Transfer the relevant field data files and their associated Rover SSF files from the 
PPC/PDA to the desktop. Run MapInfo Professional, and run the 
PostProcess.MBX (Tools>Run MapBasic Program, browse to the C:\Program 
Files\Encom\Discover Mobile folder [default location] and select this MBX). 
This will open the PostProcess menu (below).
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There are 3 steps involved in post-processed differential correction:

1. Correct Rover SSF File

2. Export Corrected Rover file

3. Post-process Field Data File

Correct Rover SSF File

Select the Correct Rover SSF File option form the PostProcess menu. This will 
open the Differential Correction dialog:

Differential Correction dialog
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In the Rover Files section browse for the Rover SSF files that have been 
transferred from the PPC. Then select the relevant Base files via the Internet 
Search button. 

If this is the first time the Internet Search has been accessed, you will need to 
update the list of Internet base data providers. After this is complete, select the 
appropriate Base Data Provider from the drop down list.

A Confirm Internet Setup dialog will appear; press Yes to continue. In the 
following Select a Base Provider dialog, select the appropriate provider from the 
list. This will open the Provider Properties dialog: press OK to accept these 
settings.

The Internet Search dialog will appear; from now on this will dialog will appear 
directly after the Internet Search button has been pressed, as this utility has now 
been configured. Press OK to begin the search with the current settings.

The Confirm Internet Setup dialog will again appear; press Yes to continue. The 
Copying files from Internet dialog will appear:
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Confirm Internet Setup dialog

Followed by the Confirm Selected Base Files dialog:

Confirm Base files dialog

This dialog details the temporal extents of the rover and matching downloaded 
base files. If a rover file is not fully covered by the base file(s), positions outside 
of the coverage will not be differentially corrected. Select OK to continue, or 
Cancel to back and reselect the base files.

Press OK to close the following Reference Position dialog (base files sourced 
from a public data source such as a Trimble Reference Station (TRS) or 
Community Base Station (CBS) will likely have an accurate reference position).
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The Corrected Files group lets you specify the path and folder that the output files 
will be written to. The current path and folder is displayed beside the Output 
Folder button. Press OK to run the differential correction; once completed, a 
message similar to the following will appear.

Differential Correction Completed dialog

Export Corrected Rover file

The corrected Rover SSF file requires export as a MapInfo Professional MIF file 
to be usable by MapInfo Professional. Run the Export utility by selecting the 
PostProcess>Export Corrected Rover File. By default the most recently used 
data files are selected as input files.
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Export Rover file dialog

If necessary, Browse for the appropriate corrected Rover files, and specify the 
Output folder. Select the “Sample MapInfo Professional MIF Setup” option from 
the Choose an Export Setup pull-down list and press OK.

An Export progress dialog will appear, followed by an Export Completed dialog.
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Export Completed dialog

Post-process Field Data File

Open the field data TAB file in MapInfo Professional. Select the 
PostProcess>Post-Process Field TAB file menu option.

Select the field data TAB file in the Table to Correct pull-down list. Press the 
Browse button adjacent to the Correction File option to browse for the 
appropriate corrected Rover MIF file (as previously exported).
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By default the corrected object file (post processed field data file) will be suffixed 
“_corrected” and created in the same directory as the field data. Use the ‘…’ 
adjacent to the Corrected Object File option to change this if desired. Press OK 
to run the Post Processing utility.

Upon completion, the Status window will update with relevant information. If 
successful, the postprocessed field data file will be opened in a new map window.

Note For further information on any of these topics, please consult the detailed 
Trimble Help files built into the relevant utility. This guide draws extensively on 
these Help files.
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A Discover Mobile Quick Reference Guide

Toolbars

• Main Toolbar

• Select/View Toolbar

• Draw/Edit Toolbar

• GPS Toolbar

Main Toolbar

GO Button Accesses menu system

Open Open .TAB or .GST or .TIF files

Layer Control Control display and properties of objects in map view

Select/View Shows/Hides Select/View toolbar

Draw/Edit Shows/Hides Draw/Edit toolbar

GPS Shows/Hides GPS toolbar

Status Window Shows/Hides Status Window

XY Shows map coordinates at location of stylus tap

Keyboard Selects input method for alphanumeric data entry
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Select/View Toolbar

Point Selection Select a single object or item.

Radius selection Selects objects within a controllable radius

Rectangular 
selection

Selects objects within a rectangular area

Polygonal 
selection

Select objects within an polygonal area.

Zoom-In Zooms in on current view by a factor of 2x

Zoom-Out Zooms out on current view by a factor of 1/2x

Previous Zoom Restores previous view history

Other functions available via the Previous Zoom tool:

Save View Saves the current view properties

Delete Deletes a saved view from the display list.

View Zoom LevelAdjust map zoom level by Screen Width or Map Scale

View Entire Layer Redraws the map to show full extents for a layer 

Pan Move the view around the map display area

Center Centers the view where the stylus is tapped

Distance 
Measurement

Measures the distance along a freehand polyline

Polyline 
Measurement

Measures the straight-line distance between points in a 
polyline

Information Displays attribute information for an object
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Draw/Edit Toolbar

Hotlink Open hotlinked image from target map object

Delete Deletes all selected objects

Symbol Used to place symbols in the insertion layer

Structure
Symbol

Used to place structure symbols in the insertion layer

Line Used to draw straight lines in the insertion layer

Polyline Used to draw polylines in the insertion layer

Freehand 
Polyline

Used to draw freehand polylines in the insertion layer

Polygon Used to draw polygons in the insertion layer

Freehand 
Polygon

Used to draw freehand polygons in the insertion layer

Add Label Labels selected objects in the annotation layer

Add Annotation Used to place additional text in the annotation layer

Vertex Edit Select and control vertices of polylines and polygons

Add Vertex Used to add additional vertices to polylines and polygons

Object Style Modify display properties of selected objects
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GPS Toolbar

Preference Settings

GPS Connect Connect/Disconnect the GPS port

Point Track Log Turn point log tracking on/off

Line Track Log Turns line log tracking on/off

Point Capture Captures a single point from GPS to selected map layer

Structure SymbolCaptures a structural measurement from GPS to selected map 
layer

Insert Node Used to add nodes to GPS polygons and lines while in pause 
mode

GPS Polyline 
Capture

Create polylines from GPS coordinates

GPS Polygon 
Capture

Create polygons from GPS coordinates

GPS Pause Pause polyline or polygon capture without terminating object

Waypoint 
Navigation

Reports distance and bearing to a selected point from current 
position

Auto Rotate Map Rotates the map so that the top of screen is the direction of 
travel

GPS Display 
Settings

Configures GPS display options for floating Status Window

Preference Option Description

Connection GPS Protocol Sets the GPS Protocol as either NMEA or Trimble

Setup GPS configuration/connection options dependent on 
assigned protocol
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Update Interval Minimum communication speed with GPS

Preferred Interval Sets preferred communication speed with GPS - may vary 
depending on Map redraw speed

Stop after error Number of consecutive bad data readings before GPS 
connection is disconnected

SSF Logging Enables recording of an Trimble SSF rover file for DGPS 
post-processing

Post Processing Enables the capture of Carrier phase data for high-
precision DGPS, either in Continuous or Classic modes.

Point Capture Tolerance Min Sets the minimum distance between GPS data points

Tolerance Max Sets the maximum distance between GPS data points

Min Sample points Specifies the minimum number of sample  points to be 
used to calculate the DGPS position

Precision Filter Assign a precision filter, displaying a warning if an object 
is captured using a low-quality fix

Display Re-Center GPS Configures options for re-centering the map when using 
GPS

Altitude in Sets units of measure for GPS altitude

Speed in Sets units of measure for GPS Speed

Default Scale 1: Sets the default map window scale

GPS Position Style Sets default GPS position symbol

Map Rotation Deg. Tolerance Sets minimum angular deviation in course required to 
cause the map to rotate

Speed Tolerance Sets minimum speed below which the Auto Rotate 
function will be suspended

When Off Sets behaviour for map window when Auto Rotate 
function is deactivated

Object Creation Edit Attributes Specify data entry options when attributing new objects

Named Styles Specify object style options when creating new object

Preference Option Description (Continued)
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Point XY Editing Specify coordinate/position options when capturing new 
objects

Session Autoload last Sets quick-start workspace settings

Map Projection Configures map projection settings (GPS capture 
projection, map grid)

User Projection Selects a preferred map projection to be used if User 
Projection is selected above

Distance in Sets preferred units for distance measurements (eg 
scalebar)

Area in Sets preferred units for area measurements

Grid Overlay Configures map grid overlay

Waypoint Tolerance Defines minimum distance for waypoint  navigation

System Settings Busy Cursor Turns On/Off the system busy cursor

Font Size Sets the default fonts size for the Status window

Confirm Deletion Controls confirmation options when deleting objects

Hardware Buttons Setup options for PPC device hardware buttons

Alert Configuration Setup alert sounds or warning messages

Directories Project Root Select directory to save all Discover Mobile data

Current Project Select folder in Project Root to save all Discover Mobile 
data

Set Individually If required default Project Root and Current project 
Folders can be overwritten

Track Log Select directory to save Track Log files

Pick Lists Select directory to save Pick List files

Named Styles Select directory to save Named Style files

Hotlink Files Select directory to save Hotlink files

New Tables Select directory to save New Table files

Preference Option Description (Continued)
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Image Files Select directory where in-built PPC camera stores image 
files

Preference Option Description (Continued)
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B Structural Symbols 
The Structural True Type symbol fonts are installed onto your system when you 
install Discover Mobile. The application can then make these fonts available for 
general use (for example in PPC Word).

The symbols may be referred to in one of a number of ways: 

• Symbol Name - Used with the Discover Mobile Structural Data Map 
Window when placing individual symbols (refer to Custom Symbols).

• There are 3 separate structural symbol fonts available.

Australian – ET Structural Australia

Canadian – ET Structural Canada

USA – ET Structural USA

• Key and ASCII - Use this keystroke to display the appropriate symbol 
when entering text.

• Discover Code - Used when entering data into a spreadsheet for display.

• AGSO Code - The equivalent code as defined by the Australian 
Geological Survey Organisation (AGSO). Not all symbols have equivalent 
AGSO codes.

Symbol Name Australia Canada USA Key ASCII Discover 
Code

AGSO 
Code

Bedding ! ! ! ! 33 1 621

Bedding Horizontal " " " " 34 1 624

Bedding Vertical # # # # 35 1 625

Bedding Overturned $ $ $ $ 36 2 626

Overturned horizontal % % % % 37 2 627

Bedding Facing & & & & 38 3 628

Facing vertical ' ' ' ' 39 3 629
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Facing overturned ( ( ( ( 40 3 6210

Cleavage (s1) ) ) ) ) 41 4 921

Cleavage (s1) vertical * * * * 42 4 924

Cleavage (s1) horizontal + + + + 43 4 925

Cleavage (s2) , , , "," 44 5 n/a

Cleavage (s2) vertical - - - - 45 5 n/a

Cleavage (s2) horizontal . . . . 46 5 n/a

Cleavage (s3) / / / / 47 6 n/a

Cleavage (s3) vertical 0 0 0 0 48 6 n/a

Cleavage (s3) horizontal 1 1 1 1 49 6 n/a

Lineation 2 2 2 2 50 8 1021

Lineation vertical 3 3 3 3 51 8 1022

Lineation horizontal 4 4 4 4 52 8 1023

Lineation (l1) 5 5 5 5 53 9 n/a

Lineation (l2) 6 5 6 6 54 10 n/a

Lineation (l3) 7 7 7 7 55 11 n/a

Bedding-Cleavage 8 8 8 8 56 12 1031

Bedding-Cleavage 9 9 9 9 57 12 1032

Crenulation : : : : 58 13 1041

Crenulation horizontal ; ; ; ; 59 13 1042

Mineral alignment < = < < 60 14 1051

Mineral alignment = = = = 61 14 1052

Symbol Name Australia Canada USA Key ASCII Discover 
Code

AGSO 
Code
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Banding/Platy Alignment > > > > 62 15 1121

Banding/Platy vertical ? ? ? ? 63 15 1124

Banding/Platy horizontal @ @ @ @ 64 15 1125

Joint A A A A 65 16 721

Joint vertical B B B B 66 16 723

Joint horizontal C C C C 67 16 724

Foliation D D D D 68 17 821

Foliation vertical E E E E 69 17 824

Foliation horizontal F F F F 70 17 825

Anticline (f1) P P P P 80 18 n/a

Anticline (f1) horizontal Q Q P Q 81 18 n/a

Anticline (f2) R R R R 82 19 n/a

Anticline (f2) horizontal S S S S 83 19 n/a

Anticline (f3) T T R T 84 20 n/a

Anticline (f3) horizontal U U S U 85 20 n/a

Anticline overturned V V V V 86 21 551

Anticline recumbent W W W W 87 22 571

Syncline (f1) Z Z Z Z 90 23 n/a

Syncline (f1) horizontal [ [ [ [ 91 23 n/a

Syncline (f2) \ \ \ \ 92 24 n/a

Syncline (f2) horizontal ] ] ] ] 93 24 n/a

Syncline (f3) ^ ^ ^ ^ 94 25 n/a

Symbol Name Australia Canada USA Key ASCII Discover 
Code

AGSO 
Code
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Syncline (f3) horizontal _ _ _ _ 94 25 n/a

Syncline overturned ` ` ` ` 96 26 556

Syncline recumbent a a a a 97 27 575

Normal fault e e e e 101 28 341

Normal fault - Low angle f f f f 102 29 344

Normal fault - High angle g g g g 103 30 345

Thrust fault h h h h 104 31 351

Shear zone i i i i 105 32 365

Shear zone - Wide j j j j 106 33 366

Fault zone breccia k k k k 107 34 363

Trend line l l l l 108 35 671

Parallel lines m m m m 109 36 n/a

Vein (closed) n n n n 110 37 n/a

Vein (vein) o o o o 111 38 n/a

Dipping vein (closed) p p p 112 37 n/a

Dipping vein (open) q q q q 113 38 n/a

Dipping shear r r r r 114 32 n/a

Dipping fault gouge s s s s 115 42 n/a

Glacial striae t t t t 116 79 653

Glacial striae u u u u 117 79 654

Oriented drill collar y y y y 121 39 n/a

Oriented drill collar z z z z 122 40 n/a

Symbol Name Australia Canada USA Key ASCII Discover 
Code

AGSO 
Code
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Oriented drill collar { { { 123 41 n/a

Bedding facing unknown ? ? ? 130 46 6211

Bedding vertical ? ? ? 131 46 6212

Younging ? ? ? 132 7 641

Undulating bedding dip ? ? ? 133 47 632

Deformed bedding dip ? ? ? 134 48 633

Minor anticline ? ? ? 140 59 n/a

Minor anticline with � � � 141 60 n/a

Minor syncline ? ? ? 142 61 n/a

Minor syncline with � � � 143 62 n/a

Minor fold with dip � � � 144 63 n/a

Minor fold with plunge ? ? ? 145 64 n/a

Kink fold with plunge ? ? ? 146 65 51420

Asymmetric verge left ? ? ? 147 66 n/a

Asymmetric verge right ? ? ? 148 67 n/a

Fold verge left ? ? ? 149 68 5156

Fold verge right ? ? ? 150 69 5155

Recumbent fold verge left ? ? ? 151 70 5154

Recumbent fold verge right ? ? ? 152 71 5153

Minor fold s verge ? ? ? 153 72 5159

Minor fold z verge ? ? ? 154 73 51510

Minor fold m verge ? ? ? 155 74 51511

Symbol Name Australia Canada USA Key ASCII Discover 
Code

AGSO 
Code
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Boudin plunge ? ? ? 156 75 5157

Chert contortion plunge � � � 157 76 5158

Mylonitic foliation ? ? ? 158 77 n/a

Mylonitic foliation ? ? ? 159 77 n/a

Eutaxitic foliation ¡ ¡ ¡ 161 78 n/a

Eutaxitic foliation vertical ¢ ¢ ¢ 162 78 n/a

Foliation d1 £ £ £ 163 49 831

Foliation d2 ¤ ¤ ¤ 164 50 832

Foliation d3 ¥ ¥ ¥ 165 51 833

Symbol Name Australia Canada USA Key ASCII Discover 
Code

AGSO 
Code
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C Geological Symbols 
Discover Mobile includes a True Type font set of non-rotatable geological 
symbols. These symbols may be used with the Discover Mobile symbol style 
picker (refer to Set Styles).

Contained below are the Discover Mobile Map Styles used by default. This list 
contains descriptive text and symbol equivalent list of all geological symbols 
available in the Discover Mobile font called ET GeoExplore. 

Name Symbol ASCII

Petroleum exploration well, proposed site ! 33

Petroleum exploration well, dry, abandoned " 34

Petroleum exploration well with show of oil # 35

Petroleum exploration well with show of oil, abandoned $ 36

Petroleum exploration well with show of gas % 37

Petroleum exploration well with show of oil and gas, abandoned & 38

Petroleum exploration well with show of oil ' 39

Petroleum exploration well with show of oil and gas ( 40

Stratigraphic hole for petroleum exploration ) 41

Oil well, shut in or suspended * 42

Oil well, abandoned + 43

Gas well , 44

Gas well, shut in or suspended - 45

Gas well, abandoned . 46

Oil and gas well / 47

Oil and gas well, shut in or suspended 0 48

Oil and gas well, abandoned 1 49
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Gas and condensate well 2 50

Gas and condensate well, shut in or suspended 3 51

Gas and condensate well, abandoned 4 52

Fossil locality 5 53

Macrofossil locality 6 54

Microfossil locality 7 55

Trace fossil locality 8 56

Fossil wood locality 9 57

Oncolite locality : 58

Palynomorph locality ; 59

Plant fossil locality < 60

Stromatolite locality = 61

Vertebrate fossil locality > 62

Sample location for isotopic age determination ? 63

Type locality @ 64

Drill hole A 65

Unworked deposit B 66

Prospect or mine with little production C 67

Abandoned prospect or mine with little production D 68

Mine; may be abandoned E 69

Major mine F 70

Mine abandoned or not being worked G 71

Minor open cut or quarry H 72

Name Symbol ASCII
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Major open cut or quarry I 73

Abandoned open cut or quarry, or not being worked J 74

Minor alluvial workings K 75

Major alluvial workings L 76

Abandoned alluvial workings, or not being worked M 77

Treatment plant N 78

Treatment plant not operating, or abandoned, or former site O 79

Main shaft showing number of compartments P 80

Shaft extending above and below plan level Q 81

Accessible shaft extending below plan level R 82

Accessible shaft extending above plan level S 83

Head of rise or winze T T 84

Foot of rise or winze U 85

Rise or winze extending through level V 86

Inclined accessible shaft extending below plan level (small scale) W 87

Inclined accessible shaft extending below plan level (large scale) X 88

Cross section of cross-cut or drive; same side of plane of section as observer Y 89

Cross section of cross-cut or drive; opposite side of plane of section Z 90

Cross section of cross-cut or drive extending across plane of section [ 91

Ore chute \ 92

Filled workings ] 93

Portal and approach of tunnel or adit ^ 94

Natural surface _ 95

Name Symbol ASCII
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Grab-sample locality ` 96

Costean or trench a 97

Oil seep b 98

Gas seep c 99

Oil and gas seep or show d 100

Oil seep reported (by geoscientist) but not relocated e 101

Gas seep reported (by geoscientist) but not relocated f 102

Oil and gas seep reported (by geoscientist) but not relocated g 103

Mud volcano or mud volcano without with hydrocarbons h 104

Mud volcano with hydrocarbons i 105

j

Relative gravity high k 107

Relative gravity low l 108

Proterozoic symbol m 109

Cambrian symbol n 110

Photo point o 111

Drillhole p 112

Registration cross q 113

Scarp r 114

Inclined drill hole s 115

Inclined drill hole t 116

Inclined drill hole u 117

Inclined drill hole v 118

Name Symbol ASCII
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Major eruptive centre with recorded eruption w 119

Major eruptive centre with no recorded eruption x 120

Minor eruptive centre with recorded eruption y 121

Minor eruptive centre with no recorded eruption z 122

Astrobleme or impact structure or cryptoexplosive structure { 123

Trigometrical | 124

Astronomical station } 125

Major volcanic centre ~ 126

Volcanic plug residual � 127

?

Basalt capped residual hill � 129

Residual hill ? 130

Crater wall ? 131

Pediment ? 132

Landslips ? 133

Name Symbol ASCII
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D Working with Portable XRF Devices
Discover Mobile provides the ability to link directly to both Olympus Innov-X and 
Niton field-portable XRF (X-Ray Fluorescence) devices, allowing real-time field 
geochemical analysis to be captured, displayed and analyzed directly in your 
mobile GIS environment. 

This section details the steps required to enable Discover Mobile to connect to 
and capture portable XRF data:

• Setting Up the Bluetooth Connection to an XRF Device

• Connecting to the GPS Receiver

• Connecting and Configuring Discover Mobile and the XRF device

• Capturing XRF Data

Photo courtesy of Olympus Innov-X
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Setting Up the Bluetooth Connection to an XRF 
Device

• Connecting a Niton XRF device with the PPC on Windows Mobile 5 or 6

• Connecting an Olympus Innov-X XRF device with the PPC on Windows 
Mobile 2003

Connecting a Niton XRF device with the PPC on Windows 
Mobile 5 or 6

1. On the PPC, select the Menu>Bluetooth Settings option, and then 
enable the Turn on Bluetooth and Make this device visible to other 
devices options.

2. Start the Niton XRF device and log in.

3. On the PPC, select the Menu>Bluetooth Settings option again. 

4. If the Niton device is not visible in the Device tab, select the Add New 
Device option, and select the Niton device once the device list is 
populated. Press Next.

5. Leave the Passcode empty and press Next.

6. The Niton device will now request connection with the PPC. Press Yes, 
enter the Niton Passcode “0000”, and then press Done.

Entering the XRF password to open the Bluetooth connection
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7. Back in the Device tab, select the Niton device and in the Partnership 
Settings dialog, enable the Serial Port option and press Save. If the 
Serial Port option is not displayed in the Services list, press Refresh.

Enabling the Serial Port service

8. In the COM Ports tab, select New Outgoing Port, then select the Niton 
Device and press Next. Set the Port to “COM8” and press Finish.

Configuring the Outgoing Port

9. Gently select the Niton entry (but don’t proceed to the next dialog). Then 
select and hold down on the New Outgoing Port option, and choose 
Edit. Set “Port 7” and press Finish. A new Incoming Port (COM 7) will be 
created. Press OK.
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Creating and configuring a New Incoming Port 1) Hold down and press on the New 
Outgoing Port option, and select the Edit option from the pop-up menu.

Creating and configuring a New Incoming Port 2) Set COM port 7.



Appendix D Working with Portable XRF Devices 313

Creating and configuring a New Incoming Port 3) The final port configuration.

10. On the Niton device, go to System>Bluetooth and press the Search 
option.

11. Highlight the PPC device name from the list, press the Config button, and 
set the Type to “GIS”. Press Save.

12. Select the PPC device name from the list, and press Connect.

13. On the PPC, enter the Niton Passcode “0000” when prompted, and press 
Done.

Connecting an Olympus Innov-X XRF device with the PPC on 
Windows Mobile 2003

Follow these steps to set up the Bluetooth connection between the PPC and an 
Olympus Innov-X XRF device:

1. Switch on the XRF device and ensure that the Bluetooth Wireless Radio is 
switched on.

2. Switch on the PPC and ensure that the PPC Bluetooth Wireless Radio is 
switched on.

3. Pair the Olympus Innov-X XRF with the PPC (see Pairing an Olympus 
Innov-X XRF device with the PPC).

4. Check the serial port settings on the PPC (see Configuring the Serial Port 
on the PPC).
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5. Pair the PPC with the Olympus Innov-X XRF (see Pairing the PPC with 
the Olympus Innov-X XRF)

Pairing an Olympus Innov-X XRF device with the PPC

Start the PPC. The Windows Mobile Today Screen is displayed.

1. Tap the Start button and select Settings.

2. Tap the Connections tab and select the Bluetooth icon.
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3. On the General tab, tap the Bluetooth Manager option.

4. Tap New to open the Connection Wizard
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5. From the Connection Wizard, select Explore a Bluetooth device and 
tap Next to proceed.

6. Wait for the list of detected Bluetooth devices to display, and then select 
the Olympus Innov-X and then tap Next to proceed.
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7. Under Service Selection, select ActiveSync Serial Port and then click 
Next to proceed.

8. Tap Finish to complete.

The Olympus Innov-X is now a registered Bluetooth device on the PPC.
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9. Open the Bluetooth Manager again (repeat steps 1 through 3), tap the 
Tools menu, and select Paired Devices.

Note If you have not previously given your Olympus Innov-X a device ID name, it will 
appear as a factory setting name, usually appearing as “Windows CE”. This can 
be changed within the Windows CE settings on the Olympus Innov-X.
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10. From the Bluetooth: Paired devices screen, tap the Add button.

11. Tap the browse button to display registered Bluetooth devices.
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12. Select the Olympus Innov-X Bluetooth device and then tap OK to 
proceed.

13. Using the PPC keyboard, type the Olympus Innov-X password in the 
Passkey box. The factory default password is “1”.

14. Click OK to complete the pairing.
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The Olympus Innov-X is now a paired Bluetooth device.

Configuring the Serial Port on the PPC

1. Open the Bluetooth Manager (see steps 1 through 3 in Pairing an 
Olympus Innov-X XRF device with the PPC) and select the Services tab.

2. Under Services, select Serial Port, and then tap the Advanced button to 
configure the COM Port settings.



322 Encom Discover Mobile User Guide

3. Check that the Inbound COM Port setting is the default value of 8, and 
the Outbound COM Port setting is 7.

4. Click OK to finish.



Appendix D Working with Portable XRF Devices 323

Pairing the PPC with the Olympus Innov-X XRF

1. On the Olympus Innov-X device, select the Setup tab on the control 
screen.

2. Scroll to the bottom of the Setup screen and select the Bluetooth 
Options icon.

Note If the Bluetooth icon is not available, select Factory Settings and Enable 
Bluetooth Streaming. Refer to the Olympus Innov-X XRF Manual for more 
details on this feature.
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3. Under Bluetooth Radio, select Enabled. An hourglass is displayed while 
the Olympus Innov-X searches for available Bluetooth devices.

 

4. Select the PPC from the list and ensure that the Stream Analysis 
Results check box is selected.

5. Tap the Select Device button. 
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Connecting to the GPS Receiver

If you have previously made a successful connection to the GPS receiver in 
Discover Mobile, you do not need to setup the connection again. Choose the 
GO>GPS>Connect menu option to reconnect to the GPS receiver, and proceed 
to the next section Connecting and Configuring Discover Mobile and the XRF 
device.

Otherwise, you will need to setup the connection to an internal or external GPS 
receiver and select the appropriate GPS Protocol:

• Connecting to an NMEA GPS receiver

• Connecting to a Trimble GPS receiver

Note If you have not previously given your PPC a device ID name, it will appear as a 
factory setting name, usually appearing as “PPC” or a Bluetooth address. This 
can be changed within the Windows Mobile settings on the PPC.
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Connecting to an NMEA GPS receiver

To connect Discover Mobile to an NMEA GPS receiver:

1. Choose the GO>Preferences menu option and ensure that the GPS 
Protocol is set to NMEA.

2. Turn on the GPS, and check that it is connected correctly to the PPC 
device e.g. a Bluetooth connection or serial cable.

3. Ensure that no other third party GPS software is running on the PPC. Most 
PPC devices will only allow one software application to access the GPS 
communication port at a time.

4. Choose GO>Preferences>Connection>Setup or GO>GPS>Setup 
Connection to open the GPS setup screen. The connection Port for the 
GPS receiver needs to be set manually, as do its various settings (Speed, 
Parity, Data and Stop). The settings are typically provided by the GPS 
receiver manufacturer in its accompanying documentation. Once these 
settings are set, press Start to test the connection. After a short period of 
time (up to about 30 seconds), a continuous NMEA data stream should be 
displayed (each line will start with ‘$GP….’ indicating a successful 
connection with the receiver.
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If uncertain about the receiver’s settings, or the data stream fails to 
appear, or a message ‘Bad Data’ is displayed, the settings are incorrect. 
Try pressing the Scan button at the bottom of the dialog; Discover Mobile 
will run through every permutation of settings attempting to establish a 
connection to your GPS receiver. Once a valid data stream from the GPS 
is displayed, press the Stop button. Make a note of the settings for future 
reference, and close the dialog. These settings will be automatically 
retained unless Discover Mobile is reinstalled or the settings are changed 
(for instance, if a different GPS receiver is used).

Refer to Connecting to the GPS Receiver for more information and how to 
troubleshoot the GPS connection.

5. Select the GO>GPS>Connect menu option to connect to the GPS 
receiver. Once the receiver has found sufficient valid satellites (see View 
Satellite Positions and Status), a current position fix will be displayed. A 
“GPS – Fix 2D” or “GPS – Fix 3D” message will be displayed at the top of 
the map window. Discover Mobile is now ready for GPS data capture.

Connecting to a Trimble GPS receiver

Trimble’s high precision receivers (e.g. the GeoExplorer series of integrated 
mobile device and receiver’s) and DGPS receivers (e.g. the ProXT) utilize 
Trimble’s proprietary TSIP protocol. To connect Discover Mobile to Trimble 
receiver:

1. Choose GO>Preferences menu option and ensure that the GPS 
Protocol is set to Trimble.

2. Turn on the GPS, and check that it is connected correctly to the PPC 
device e.g. a Bluetooth connection or serial cable.

3. Ensure that no other third party GPS software is running on the PPC. Most 
PPC devices will only allow one software application to access the GPS 
communication port at a time.

4. Choose GO>Preferences>Connection>Setup or GO>GPS>Setup 
Connection to open the GPS setup screen. Set the required 
communication port that the receiver is connected to (e.g. Bluetooth or 
serial port). Certain devices (such as Trimble GeoExplorer units running 
Windows Mobile 5) have a GPS Connector (or similar) application (under 
Start>Settings>Connections) which clearly identify the COM ports for 
the GPS receiver (and the various protocols).



328 Encom Discover Mobile User Guide

The various Masks available in this dialog allow poor satellite data to be 
filtered out (e.g. satellites low on the horizon, or those resulting in a high 
signal-to-noise ratio), improving the precision on the position fix.

These settings will be automatically retained unless Discover Mobile is 
reinstalled or the settings are changed (for instance if a different GPS 
receiver is used).
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5. Select the GO>GPS>Connect menu option to connect to the GPS 
receiver. Once the receiver has found sufficient valid satellites (see View 
Satellite Positions and Status), a current position fix will be displayed. A 
“GPS – Fix 2D” or “GPS – Fix 3D” message will be displayed at the top of 
the map window. Discover Mobile is now ready for GPS data capture.

View Satellite Positions and Status

The GPS will commence acquiring of satellites and downloading of the almanac. 
This can sometimes take up to several minutes depending on atmospheric 
conditions. Once the GPS starts to acquire satellites, choose GO>GPS>Monitor 
Satellite Status to view the position and status.

• The message Fix None, displayed at the top of the Discover Mobile 
Screen, indicates that there are insufficient satellites to triangulate a 
position.

• When the GPS has obtained enough satellites to triangulate a position, 
the message changes to Fix 3D.

• If not enough satellite have been located for an accurate fix, the message 
Fix 2D is displayed.

A 3D fix is required for accurate positioning.
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Connecting and Configuring Discover Mobile and the 
XRF device

Once a Bluetooth connection to the XRF device is established, the following items 
need to be set to allow Discover Mobile to interact with the portable XRF device, 
prior to data capture:

• Specify the XRF Project Path

• Configure the XRF Connection

• Connect to the XRF device

• Enhance the Map Window Display

Specify the XRF Project Path

The Project Path controls the location of the output XRF data files. To configure:

1. Select the GO>Preferences>Directories option.

2. Under the Project Root option select a root directory. 

3. Under the next Current Project option select a folder to store the data 
tables and Sample Batch folders.

The structure under the Current Project folder will be:

Olympus Innov-X XRF devices

These correspond to the two different modes the Olympus Innov-X XRF runs in. 
Soil Mode is used for concentrations of up to 2-3%, and as Mining Mode is for 
concentrations above 2-3%. For soil geochemistry surveys, Soil Mode is usual.
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Niton XRF devices

Configure the XRF Connection

1. Select the Go>XRF>Setup menu option. 

2. In the following dialog, set the appropriate Device (Niton or Olympus 
Innov-X)

3. Select the Incoming COM Port (e.g. COM 7 for the Niton Bluetooth 
connection detailed above) 

4. Move your desired Summary Elements to the Selected list. These 
elements will be displayed in the initial Summary page when an XRF 
measurement is completed: all other elements will be displayed in the 
following Data pages. Press OK.

Once setup, these configuration options are remembered between XRF device 
connections (see Connect to the XRF device) and do not need to be reconfigured 
for each connection.
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Connect to the XRF device

Once the XRF connection has been setup (see Configure the XRF Connection) 
in Discover Mobile, you can connect to the XRF device. 

1. Select the GO>XRF>Connect menu option

Batch Files

2. In the Select a Layer section, enter a Batch Name, or select an existing 
Batch Name in the pull-down list if you wish to append to an existing data 
file. Existing batch files do not need to be open in Discover Mobile; this will 
list any XRF datafiles on your PPC.

XRF data is stored into data files and directories named by Sample 
Batch; this allows data to be separated/stored by date/location/etc. See 
Specify the XRF Project Path for more information on batch file naming 
and storage locations. This function is extremely useful for jobs that span 
multiple field sessions (ie. before and after lunch) or days, working on the 
same project. It also enables recommencement at any time in case of an 
unscheduled break or technical difficulties.

Olympus Innov-X XRF devices create two data files per batch, for Soil and 
Mining modes. Soil Mode is used for concentrations of up to 2–3%, and 
as Mining Mode is for concentrations above 2–3%. For soil geochemistry 
surveys, Soil Mode is usual. Niton XRF devices generate only one datafile 
per batch.

Applying Range Styles

XRF point data can be coloured/styled automatically as the data is 
captured using a Range Style library (see Range Styles). This allows 
geochemical trends to be instantly visualized in the field, for example 
enabling the user to conduct real-time infill or verification sampling in 
response to anomalous results or trends.

3. To apply a range style, first select the target numeric XRF element field in 
the Style by Field drop-down list. 

4. Then select the desired Range Style library from the Style drop-down list 
and press OK

Note Range Styles created as Percentile ranges cannot be auto-applied to XRF data. 
Percentile-based range styles will not be displayed in the list.
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Custom Fields

XRF batch files contain an extensive range of preset XRF element and 
error fields, as well as various ancillary fields, all of which are auto-
populated by the XRF data stream when a measurement is taken. The 
user can additionally add Custom Fields to these batch tables, for 
attribution with information like geology, regolith, soil type, colour, etc. 

5. Select Yes in the next dialog to add Custom fields (selecting No will 
complete the batch file creation).
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6. Use the Add button to add a custom field. See Defining Field Properties 
for information on the various field types. See Working with Tables for 
more information about working with tables.

7. Press OK to complete the XRF connection.
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Enhance the Map Window Display

When the Sample Batch has been created, Discover Mobile displays a point 
object at the centre of the map window, this is your current GPS location. A wide 
variety of grids, aerial photos, geological maps or any thematic, layered data can 
be added to the map window to help you during the sampling program. For 
information on how to display other map data and control the map window, refer 
to the relevant sections in the Discover Mobile User Guide.

Capturing XRF Data

Photo courtesy of Thermo Fisher Scientific

You are now ready to begin streaming analysis from the XRF device to the PPC:

• Run an Analysis on the XRF device

• Record the GPS Location

• Review XRF Data and Record Comments and Observations

• Save Reading in Discover Mobile
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Run an Analysis on the XRF device

1. Ensure that the XRF instrument is correctly configured to suit the sample 
program. Items such as mode, test timings and sample information may 
need to be entered (depending on the device) prior to running the 
instrument. Refer to the XRF device User Guide for more information.

2. Perform an XRF analysis. Refer to the XRF device User Guide for detailed 
information, including safety aspects.

3. When the XRF has finished running the analysis, the final result will be 
displayed on the XRF device screen, and a Bluetooth Stream will be sent 
to Discover Mobile a few seconds later.

Record the GPS Location

A message is displayed by Discover Mobile when the Bluetooth streamed result 
is received from the  XRF device. Hold the PPC or DGPS antenna over the 
sample location to accurately record the location of the sample and then tap OK.

Note An alert sound can be enabled to indicate when the XRF Data is Received, 
under Go>Preferences>System Settings>Alert Configurations.
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Review XRF Data and Record Comments and Observations

The streamed XRF data populates fields into the XRF Data Forms on the PPC. 
All of the elemental data, including the associated errors are recorded into the 
active table, together with derived GPS coordinates. Due to the large amount of 
data received, the data is separated into several tabs (i.e. “Information” 
“Summary”, “XRF Data1”, “XRF Data 2”…“Geography”).

Information Tab

The Information tab lists summary information about the analysis. A Comments 
field is also available for operator descriptions, such as sample horizon types, 
regolith, geology or any other useful and relevant field observations. Additional 
Custom Fields can be added to the standard XRF tables and populated by the 
user (for example with manual entries, or via named styles and picklists). 
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XRF datasheet Information tab

Summary Tab

The Summary tab lists the elements selected via Go>XRF>Setup, providing a 
quick way of browsing primary/indicator elements/pathfinders of interest.

XRF datasheet Summary tab
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XRF Data Tabs

The elemental concentration data from the XRF device is stored in the XRF Data 
forms with the associated analytical errors (red). The XRF Data tabs have been 
pre-configured to receive all elements from Sodium (Na) through to Uranium (U), 
depending on the element suite and individual XRF Analyzer configuration. The 
XRF Data 3 tab also contains instrument-specific information, such as the 
manufacturer, serial number and model.

XRF Data Form 1

Geography Tab

In addition to the XRF Data tabs, there is a Geography tab which contains the X, 
Y and Z coordinate positions obtained from the GPS.
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XRF data sheet Geography tab

Save Reading in Discover Mobile

To save the analysis results and GPS location, tap OK. The data is written to a 
MapInfo Professional table (*.TAB) and a location point is displayed on the 
screen.

Browser view of XRF data
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fill patterns 224
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connecting 325
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GPS menu 104
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Make a layer editable 137
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Microsoft 9
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connecting 313
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Open files button 57
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Operating systems 2
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Outline line style 123, 224
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Pan button 144
Pan mode 58
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Remove All button
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Remove annotations 122
Remove button
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Saving Views 60, 150
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Table copy 132, 186
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Theme Type 154
Title bar 50, 55
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Tools menu 90
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Tools>Add Label 95
Tools>Add Line 94
Tools>Add Node 94
Tools>Add Point 93
Tools>Add Polygon 95
Tools>Add Polygon Freehand 94
Tools>Add Polyline Freehand 94
Tools>Add Structure Symbol 93
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Tools>Center 92
Tools>Cursor Position 93
Tools>Info 93
Tools>Pan 92
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Tools>Zoom In 92
Tools>Zoom Out 92
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Transparency controls 165
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U
Universal Serial Bus (USB) connections 8
Up button

on Layer Control 111, 137
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Vector display
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Vertex Edit tool 63
Vertex point 63
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View>Map Rotation 114
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View>Table Browser 119
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View>View Entire Layer 114
View>Zoom Level 113
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visibility 135

W
Width mode 60
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Windows Explorer 8
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XRF 309

configure 331
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project path 330

XRF data capture 335
XRF devices 309
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XRF>Connect 109
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