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1 Introduction 1

1 Introduction
Encom Discover 3D 2013

Encom® Discover 3D  is designed to work seamlessly with Encom Discover, 
allowing you to rapidly visualize, model and analyze your drillhole and related 
datasets in 3D, and then dynamically plan follow-up drilling to test your theories. 
Encom Discover 3D is installed with Encom Discover and  requires an upgraded 
licence to activate its full functionality. 

All Discover users can access the viewer mode of this application; map windows 
views can be draped over gridded surfaces in 3D, and existing 3D sessions from 
other users can be viewed.

A full Encom Discover 3D licence allows gridded surfaces representing 
topography, geochemistry and geophysics, drillholes containing assays or 
lithological data or any other mapped data combinations created using MapInfo® 
Professional and Encom Discover to be transferred to an interactive three-
dimensional environment. Additional objects such as 3D DXFs, grid surfaces and 
raster images plus point and line data can also be added to the 3D displays from 
MapInfo Professional or independently.

The display below is typical of the type of displays derived from various data 
types.
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A complex 3D view incorporating an airphoto image draped over a DEM, colour and 
thickness modulated drillholes, ore body and development drive vector models, and a 
voxel model of magnetic susceptibility displayed as an isosurface.

Encom Discover 3D enables data to be viewed interactively with zooming, 
panning and fly-through capability controlled by either a regular mouse or the 
intuitive SpaceNavigator 3D mouse. 3D views can be captured as images and 
either displayed in MapInfo Professional in a layout for presentation purposes, or 
used in other applications (such as PowerPoint). Or, for a more powerful and 
effective presentation, create dynamic 3D movies for shareholder and 
management presentations.

Encom Discover 3D puts a powerful suite of modelling tools at your fingertips, 
whether you are developing mineralization, structural or geological models. Not 
only can 3D objects be created from your 2D datasets; points, polylines and 
polygons can be digitized directly into the 3D environment, accurately snapping 
to drillhole intervals or outlining trends. These 3D objects can then be extruded 
and wireframed to create triangulated (TIN) surfaces and polyhedral solids. A 
toolbox of advanced editing functionality allows these TIN surfaces and solids to 
be further manipulated; for instance modelling fault truncation of an orezone.



1 Introduction 3

Encom Discover 3D operates seamlessly with Encom Discover. If you know how 
to create a map, a drillhole project and sections in Encom Discover, this is all you 
need to operate Encom Discover 3D. No additional project specification or data 
setup is required since the displays within MapInfo Professional, created by 
Encom Discover, are passed directly to Encom Discover 3D for presentation and 
interactive use.
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About this Guide

This guide describes existing features in this version of Encom Discover 3D. The 
manual is organised into chapters containing logically grouped functions that 
relate to the Discover 3D menu structure.

This guide applies to Encom Discover 3D version 2013 only. Pitney Bowes 
Software has taken care to ensure that the information presented here is accurate 
but reserves the right to make alterations to Encom Discover 3D at any time.

This is not an Encom Discover manual and knowledge of both Encom Discover 
and MapInfo Professional is required for Encom Discover 3D to be used to its best 
advantage. We recommend that you refer to the user guides available with 
Encom Discover and MapInfo Professional.

Conventions Used in this Guide

Certain conventions are used throughout this guide.

• Keys on the keyboard appear in small capital letters. For example, the Ctrl 
key appears as CTRL in the text.

• Menu options and dialog items are in normal text but bolded. For example, 
choose File>Run MapBasic Program.

• Buttons to be clicked are bolded. For example, click the Remove Entry 
button.
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• References to other sections in the documentation are italicised. For 
example, see the Display 3D Surfaces chapter.

Obtaining Help

The Discover 3D Help menu provides access to the Discover 3D Help, Tutorials 
(PDF), and User Guide (PDF). The Help is an interactive version of the User 
Guide.

When contacting product support for Encom Discover 3D, please have the 
following details available:

• Licence Number (use Discover Help>About Discover tool in the 2D 
environment).

• Encom Discover version number.

• MapInfo Professional Version (use Help>About this MapInfo Product).

• A full description of the problem or query. This should include any system 
messages (from Encom Discover 3D, MapInfo Professional or the 
operating system) and other pertinent information detailing the 
circumstances.

Contact details are:

If you experience any problems with Encom Discover 3D, or have suggestions or 
comments, Pitney Bowes Software would be pleased to hear from you.

System Requirements

Encom Discover 3D is installed with the Encom Discover 2013 software. Encom 
Discover 2013 requires MapInfo Professional version 10.5 or later.

E-mail software.support@pb.com

Web www.pbencom.com

mailto:software.support@pb.com
http://www.pbencom.com
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Encom Discover 3D is supported on Windows® XP Professional (Service Pack 3) 
and Windows 7 and 8 32-bit and 64-bit operating systems but not on earlier 
Windows systems.

Minimum requirements

• Core 2 series or equivalent CPU processor

• 2 gigabyte of RAM memory

• A monitor of at least XGA capability (1024 x 768 resolution)

Recommended requirements

• Core 2 series or equivalent CPU processor (note that Discover 3D does 
not utilise multiple CPU cores)

• 4 gigabytes of RAM memory

• Dedicated graphics card with 256 MB dedicated VRAM memory, and with 
OpenGL optimised drivers, such as Nvidia Quadro or ATI FireGL series.

• A monitor of at least SXGA capability (1280 x 1024 resolution)

Licensing Encom Discover 3D

Encom Discover 3D is accessible to any Encom Discover user in a viewer-only 
mode. To access all disabled or unavailable options, an Encom Discover 3D 
licence is required to be added to the existing Encom Discover licence.

For details on activating, upgrading or transferring Encom Discover 3D on your 
Encom Discover licence, refer to the licensing pocedure in the Encom Discover 
User Guide.

Note that it is not possible to transfer a Encom Discover 3D licence between 
computers independently; it must be transferred in conjunction with the 
associated Encom Discover licence.
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Access to Tutorials

To assist you in learning how to use Encom Discover 3D, a set of tutorials is 
provided as part of the installation. The tutorials comprise of a descriptive 
document that explains the operation and steps to follow, plus data that are used 
in the tutorial exercises. All tutorials are based on real exploration situations in 
which Encom Discover 3D can be used to display, enhance and visualise field 
data.

The tutorial is available as a PDF document. The PDF file can be accessed from 
the Help menu within the Discover 3D window.

Discover 3D tutorials are installed from the Encom DVD-ROM. A total of 80 Mb of 
disk space is required to install the tutorial data. For information on viewing and 
printing PDF documentation, see the Encom Discover User Guide.
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2 Getting Started in 3D
If you new to Discover 3D, the following steps will guide you through the essential 
sections of this User Guide to quickly get you displaying and visualising your data 
in the 3D environment. 

What Data Formats are Supported by Discover 3D?

The various formats for displaying data within the 3D environment are 
summarised in Choosing a 3D Display Type. Each format (e.g. raster image, 
vector, 3D points, etc) has benefits and limitations, and understanding these is 
essential to working efficiently and effectively in Discover 3D.

How Do I Display My MapInfo Data in the 3D Environment

Once you have decided how you would like to display your data in 3D (i.e. what 
format as discussed above), use the appropriate menu option on the Discover 3D 
menu (Viewing Mapinfo/Discover Data in 3D). 

Discover 3D has been designed so that if you can display your data within the 2D 
MapInfo window, you can quickly and painlessly display it in 3D using the options 
on this menu (e.g. using Displaying Map Window Views as 3D Images, Displaying 
Surfaces in 3D or Displaying Drillhole and Trench Data in 3D).

Certain data formats can also be drag and dropped into the 3D window, or opened 
from directly within Discover 3D – these options are discussed fully in each data 
format’s particular chapter.

Navigating the 3D Environment

With your data displayed in 3D, use the navigation controls (Understanding the 
Discover 3D Interface) to zoom, rotate and navigate around the 3D environment 
to start getting a better feel for the spatial relationships between your datasets. 
Perhaps toggle the Orthographic View mode to remove the distance bias 
associated with the default Perspective View.

Discover 3D also supports the 3DConnexion SpaceNavigator (see Using the 
3DConnexion SpaceNavigator™) for smooth intuitive “fly-through”-style 
navigation.

Note It is recommended to work through the Discover 3D Tutorials before accessing 
this more detailed User Guide.
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The Cursor Plane allows you to view just portion of your data (clipping the data 
view), for example only the data behind the cursor plane, or a preset distance 
either side the cursor plane (envelope).

Modifying Data Displays in 3D

The display properties of the various 3D data formats are discussed in the 
sections devoted to each data format—for example, Displaying Gridded Surfaces 
in 3D and Displaying Voxel Models—and include general purpose controls for:

• Transparency.

• Scaling – for instance, to allow various geophysical grids of differing 
magnitudes to be sensibly displayed in the same 3D environment.

• Z offset – absolute positioning of datasets in the vertical dimension with 
respect to each other.

Other data-specific controls include options such as colour (and/or colour 
modulation by a data field), size (and/or colour modulation by a data field), 
labelling, width, decimation, etc.

Interrogating Data

The data tab of the Information window allows attribute information for data sets 
that are linked to MapInfo TAB files (i.e. 3D Points and 3D Lines, Drillhole 
downhole data) to be examined dynamically. The dataset needs to be set as both 
Selectable and Browsable in the Workspace Tree: moving the cursor over an 
object will highlight it’s attributes.

Interpolating and Modelling Data in 3D

Discover 3D not only allows the user to visualise and modify the way 3D data is 
displayed, but allows interpretations to be made from this information in the 3D 
environment. 

Points, polylines and polygons can be drawn in any orientation using the Cursor 
Plane, and saved into a Feature database (see Digitizing and Managing 3D 
Features). These feature objects can be edited, resized, moved and attributed. 
They can also be exported to a number of common 3D vector formats (such as 
.DXF). Discover 3D can also import vector linework into a Feature Database, 
such as interpreted section boundaries in a Discover Drillhole Project.

Accurate 3D digitization is aided with options such as:

• Snap mode (Features Toolbar) – feature object nodes can be snapped to 
an existing object’s nodes.
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• Orthographic View mode (Zoom Controls Toolbar) - all objects are the 
same size regardless of their distance from the viewer.

• Perpendicular View mode (Cursor Plane) - shifts the view perpendicular to 
the cursor plane.

Examples of feature objects digitized in 3D include mineralization intercepts or 
zones deduced from downhole assays, fault trends interpreted by spatially 
comparing downhole geological logging with magnetics grids and voxel models, 
or proposed drillholes/drilling targets.

Discover 3D can then wireframe between these feature objects, creating complex 
solids using a range of powerful modelling tools (see Modelling Triangulated 
Surfaces and Solids). Alternatively, Discover 3D can smoothly interpolate 
between your feature objects with the Surface Gridding tool (see Creating 
Gridded Surfaces), using methods such as Minimum Curvature and Inverse 
Distance Weighting. This powerful tool includes tie-line controls (see Using Tie 
Lines to Control Wireframing) as well as multi-body support. Your interpretations 
can thus be used to build 3D complex fault surfaces, mineralization grade shells, 
alteration halos, etc. 

Discover 3D can also create voxel (block) models (see Creating and Manipulating 
Voxel Models), from your drillhole project downhole data using powerful 3D 
gridding methods such as Kriging and Inverse Distance Weighting. These 
mathematically interpolated models can then be visualised with a host of options, 
such as isosurfaces (i.e. gold grade shells), slices, thresholding, etc. 

Producing Output from Discover 3D

Your Discover 3D view can be exported with a range of options:

• In Page Layout Mode, you can use the standard printing controls 
(File>Print) to produce hardcopy of the 3D view.

• A simple screenshot of the current 3D view can be created using the 
File>Save View As menu option (.JPG, .BMP, etc.)

• The current view can be sent to MapInfo as a mapper window using the 
View>Send to MapInfo menu option. This map window could therefore be 
added to a Layout window as a Frame Object: for instance a 2D cross 
section could have a small 3D view of the drillhole project added to give a 
3D spatial perspective. 
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• All data in the envelope of a drillhole project’s cross-section can be 
captured as a Georeferenced Image and exported to that section in 2D 
using Tools>Georeferenced Image Export. This allows 3D data such as 
voxel models and solids interpolated from digitization to be displayed in 
2D cross-sections.

• Fly-through movies of your 3D environment (see Creating a Fly-Through 
Animation) can be created, with full control over the data display as the 
movie progresses (i.e. data visibility can be turned on/off and properties 
altered such as transparency, colour, etc throughout the movie).



3 What’s New in Encom Discover 3D 13

3 What’s New in Encom Discover 3D
New features available in Encom Discover 3D 2013 include:

General

• 3D display support – With support for 3D televisions, your project and 
management teams can now visualise and fully appreciate your 
interpretations, models and complex projects in stunning and immersive 
full 3D (via HDMI graphics output).

Modelling 

• New rotated voxel model support – Interactively create, render and 
export rotated voxel/block models for far faster and more flexible block 
modelling (as well as much smaller file sizes), particularly when 
mineralisation is at a significant angle to the principal axial planes.
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• New 3D Batch Transform DXF tool – Bring your Discover 3D 
presentations to life by easily populating the 3D environment with multiple 
instances of a DXF model (such as a vehicle, tree or house) using a TAB 
file of XYZ, dip, azimuth and scale parameters.
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4 Choosing a 3D Display Type
The Discover 3D module comprises both a Discover 3D menu within the MapInfo 
2D interface, as well as its own separate 3D interface/window. These allow the 
3D environment to be populated both from datasets already open within 2D 
MapInfo/Discover interface, and/or by opening applicable data directly into the 3D 
window. This allows a large range of data formats to be created and supported by 
Discover 3D.

When choosing the data format that best suits your data, the following should be 
considered:

3D rendering and graphics memory

Certain formats are very efficient for displaying in 3D compared with others. For 
instance, multiple isosurfaces of a voxel model (e.g. grade shells) are very 
memory intensive and will slow navigation in 3D, whereas displaying the same 
isosurfaces as DXF vector files will have a negligible impact on 3D memory 
consumption

3D display properties available for the format

Generally the formats with more powerful visualisation options are less efficient 
to display in 3D. Displaying a .TAB file as 3D Points provides a myriad of display 
options such as colour and size modulation, labelling, etc, but is much slower to 
render than displaying the same dataset as a vector .DXF file (but this option has 
very limited display options).

Often the same dataset can be displayed in Discover 3D in a number of different 
formats; for example, point data in a MapInfo table can be displayed in 3D as 
either an image, a vector DXF file, 3D Points, 3D Symbols or a Feature Database. 
Understanding which of these formats can be applieed to your data can improve 
grapics performance in the 3D environment.

The benefits and limitations of each format supported by Discover 3D are 
discussed in the following topics:

• Raster Images

• DXF Vector Data

• Points and Lines

• Gridded Surfaces

• Drillholes



16 Encom Discover 3D User Guide

• Voxel (Block) Models

• Feature Database

Raster Images

Raster Images are a quick and simple way to display large amounts of data in 3D. 
The two primary image creation/registration tools are:

Capture all visible content of any MapInfo map window and display within the 3D 
environment as a geo-located image, using the View Map in 3D menu option (see 
Displaying Map Window Views as 3D Images). This can be draped over a gridded 
surface (e.g. topographic surface) or assigned a constant RL value.

From within Discover 3D, register an existing image (e.g. a scanned cross 
section) using the Georeferencing Image File Creation Wizard (see Using the 
Georeferenced Image File Creation Wizard).

Considerations:

• A single image can be used to display multiple datasets.

• Quick and easy to create an image from a mapper window.

• High resolution images (and therefore large file sizes) are required to 
preserve vector linework and labels.

• Data cannot be interrogated for attribute information; display options are 
therefore also limited.

• Multiple high resolution images may degrade rendering efficiency in 3D.

DXF Vector Data

The .DXF vector file format (AutoCAD) is a very efficient way of displaying vector 
data in 3D. This can include:

• MapInfo vector data such as points, lines and polygons displayed with the 
View Objects in 3D menu option (see Displaying Map Objects as 3D 
Vectors). For example infrastructure (roads), contour lines or orebody 
boundaries interpreted on drillhole cross sections (display in 3D using the 
Viewing Section Layers option).
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• Extruding objects to create .DXF solids using the Extrusion Wizard (see 
Extruding Models from Points, Lines and Polygons). For example, surface 
traces of faults or polygons of building outlines extruded to create the 
objects in 3D.

• Existing DXF files (e.g. the output from modelling programs) can be 
opened directly into Discover 3D via a number of menu options, or by 
simply dragging and dropping the DXF from Windows Explorer.

• Visualising point data as 3D vector symbols (see 3D Point Symbols).

Considerations:

• DXFs are a very efficient way of displaying a large amount of vector data, 
particularly points and polylines or complex bodies such as orebody 
models.

• Linework is honoured (without the pixelation seen in images).

• They have limited display options .

• Vector DXFs cannot be interrogated for attribute information.

Points and Lines

Point data in MapInfo tables can be displayed in Discover 3D as 3D points (see 
Working with 3D Points) or 3D lines (see Working with 3D Lines). These display 
types directly reference the source MapInfo TAB file, and therefore provide 
powerful display controls. These include point labelling, colour, size and rotation 
modulation by data values, offset controls and support for True Type fonts. 
Examples of these display formats:

• Colour modulating regional geochemical point datasets.

• Displaying prospect scale geochemical data as lines offset by an assay 
value (e.g. Cu) above a DEM surface. 

• Displaying flight lines coloured by date.

Considerations:

• 3D Points and Lines provide powerful display and control options.

• Applying these options to larger datasets can severely affect 3D rendering 
performance.
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Gridded Surfaces

Grids created using either the Discover>Surfaces menu or other products (e.g. 
topographic or geochemical surfaces in formats such as Geosoft, ER Mapper, 
Surfer etc.) can displayed in Discover 3D either directly or via the View Surface 
in 3D menu option (see Displaying Surfaces in 3D). A large range of grid types 
are supported.  Support is also provided for the draping of ER Mapper ECW and 
.ALG files.

Considerations:

• Powerful display and control options.

• Multiple large grids can severely affect 3D rendering performance. 
Perhaps consider displaying some grids as .DXF contour lines.

Drillholes

Drillholes present in an open Discover Drillhole Project can be displayed in 
Discover 3D using the View Drillholes menu option (see Displaying Drillhole and 
Trench Data in 3D). The display of 3D drillholes can be modified by colour and 
thickness modulation, as well as labelling and annotation options.

Considerations:

• Powerful display and control options.

• Drillhole downhole information can be dynamically interrogated.

• Applying some of these options to large numbers of drillholes can severely 
affect 3D rendering performance.

Voxel (Block) Models

Discover 3D can create, display and manipulate Voxel block models (e.g. IP 
resistivity), supporting formats such as UBC, CEMI, and Noddy, as well as 
preliminary support for Datamine, Surpac, Vulcan and Gocad Voxet.

Considerations:

• Powerful display and analysis options

• Graphics memory intensive.



4 Choosing a 3D Display Type 19

Feature Database

Points, polylines and polygons can be digitized and attributed directly into the 3D 
environment as part of a Feature Database. Additionally, dxf vector or MapInfo 
TAB files can be imported as feature database objects, and then edited from 
within the 3D environment. This allows the geoscientist to create interpretations 
and build complex models in the 3D environment using all relevant datasets (e.g. 
drillholes, geochemical and/or geophysical grids, voxel models, etc) without the 
being limited to traditional 2D cross-sections. 
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5 Viewing Mapinfo/Discover Data in 3D
The Discover 3D menu in the MapInfo/Discover interface provides the tools you 
need to display 2D data from a map window or MapInfo table in the Discover 3D 
window. The tools available from the Discover 3D menu are described in Discover 
3D Menu (MapInfo/Discover).

For information on how to use these tools to manage the 3D workspace and view 
data in 3D, see the following sections:

• Managing the 3D Workspace

• Using the 3D Display Wizard

• Refreshing Data from MapInfo/Discover

• Displaying Map Window Views as 3D Images

• Displaying Map Objects

• Displaying Drillhole and Trench Data in 3D

• Extruding Objects in 3D

• Displaying Other Types of Sections

• Draping Images Over a Grid

• Adding Landscape and Ornamental Features

Discover 3D Menu (MapInfo/Discover)

To show the Discover 3D Menu:

• In MapInfo, select Discover>Discover 3D Menu to add the Discover 3D 
menu to the MapInfo Professional menu bar.
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The following tools are available from the Discover 3D menu:

• Open 3D Window Tool

• Open 3D Workspace Tool

• Save 3D Workspace Tool

• Refresh All 3D Data Tool

• View Map in 3D Tool
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• View Objects in 3D Tool

• View Surface in 3D Tool

• Create 3D Points Tool

• Create 3D Lines Tool

• View Drillholes Tool

• View Trenches Tool

• View Sections Tool

• View Logs Tool

• View Section Layers Tool

• View Intervals as 3D Points

• View Seismic Sections Tool

• 3D Display Wizard

• 3D Extrusion Wizard

• 3D Utilities Menu

• Toggle Auto 3D Selection Tool

• Options Tool

Open 3D Window Tool

Opens the Discover 3D Window. See Understanding the Discover 3D Interface 
for information on using the 3D window.

See also
...Opening the 3D Window

Open 3D Workspace Tool

Opens a saved 3D session including data in the 3D window and associated tables 
and map windows in MapInfo Professional. Navigate to the folder where the 
Discover 3D workspace was saved, and select the .D3D workspace file.
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See also
...Opening a Saved 3D Workspace

Save 3D Workspace Tool

Saves the current workspace in both MapInfo Professional and Discover 3D. In 
the Save 3D Workspace dialog, type a name for the 3D Workspace file and 
browse to a folder location.

See also
...Saving the 3D Workspace

Refresh All 3D Data Tool

Updates the 3D Window with changes made to associated tables that are open 
in MapInfo/Discover (a drillhole project, for example).

See also
...Refreshing Data from MapInfo/Discover

View Map in 3D Tool

Displays data visible in a MapInfo map window as a georeferenced bitmap image 
in Discover 3D. These raster images may include surface layers such as DEM or 
topography grids or other raster files such as aerial photography or satellite 
imagery, vector data or annotation layers. 

See also
...Displaying Map Window Views as 3D Images

View Objects in 3D Tool

Displays point, line or polygon map objects in a Discover 3D as 3D DXF vectors. 
A number of different options are available for assigning the Z values. The target 
objects can be either a selection or an entire open MapInfo table.

See also
...Displaying Map Objects as 3D Vectors

View Surface in 3D Tool

Displays selected grid files in Discover 3D. Only grid files that are currently open 
in MapInfo Professional can be displayed.
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See also
...Displaying Surfaces in 3D

Create 3D Points Tool

Displays point data tables in Discover 3D. Point data tables require each record 
to have an X (Easting), Y (Northing) and Z (RL) field; a line identifier field is 
optional. A geochemical soil sampling program is an example of a point data file 
that can be viewed in Discover 3D.

See also
...Displaying Points in 3D

Create 3D Lines Tool

Displays line data tables in Discover 3D. Line data tables require each record to 
have an X (Easting), Y (Northing) and Z (RL) field along with a line identifier field. 
Geophysical survey line profiles are an example of a line data file that can be 
viewed in Discover 3D.

See also
...Displaying Lines in 3D

View Drillholes Tool

Displays selected drillholes from an open Discover drillhole project in Discover 
3D. Only drillholes that are part of a drillhole project can be displayed. See the 
Discover User Guide for information on Discover drillhole projects.

See also
...Viewing Drillholes in 3D

View Trenches Tool

Trenches/Costeans in a open drillhole project can be migrated into 3D. See the 
Discover User Guide for information on Discover drillhole projects.

View Sections Tool

Displays drillhole sections created in a Discover drillhole project as 
georeferenced bitmap images in Discover 3D. Section images can include 
downhole display attributes or ore body boundary polygons along with annotation 
data.



26 Encom Discover 3D User Guide

See also
...Viewing Drillhole and Trench Sections

View Logs Tool

Displays drillhole logs created in a Discover drillhole project as georeferenced 
bitmap images in Discover 3D. Drillhole log images can include up to 16 columns 
of downhole lithological information, assay values or geophysical readings 
displayed as text, linegraphs or histograms.

See also
...Viewing Drillhole Logs

View Section Layers Tool

Displays drillhole section boundaries created in a Discover drillhole project as 
either 3D vectors or as 3D features in Discover 3D. Section layer files can 
represent lithological or ore body boundaries, or other geological interpretations.

See also
...Viewing Section Layers

View Intervals as 3D Points

Converts a 2D downhole drillhole dataset (such as a lithology or assay table) 
directly into a 3D Point dataset displayed in Discover 3D. 

The resulting mappable MapInfo Professional table can also be queried (e.g. with 
Select by Group or SQL Select) to select a subset such as only fault intercepts 
or copper values above 10,000 ppm); these can then be viewed in 3D with the 
Create 3D Points Tool , for modelling/interpolation with the 3D Gridding or 
Surface Gridding tools.

See also
...Viewing Drillhole Intervals as 3D Points

View Seismic Sections Tool

Interpret velocity profiles on seismic SEGY sections in the 2D environment, then 
generate depth profiles from these for viewing in Discover 3D.

See also
...Viewing Seismic Sections
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3D Display Wizard

The 3D Display Wizard provides a user-friendly step-by-step guide to displaying 
either the entire current map view or individual map objects in Discover 3D. If the 
entire map window is selected it is displayed as a georeferenced raster image, 
whereas map objects are displayed as a 3D vector file. The wizard displays a 
series of dialogs. Use the Next and Previous buttons to navigate through the 
dialogs and make your selections. Click Finish to display your selections.

See also
...Using the 3D Display Wizard

3D Extrusion Wizard

The 3D Extrusion Wizard allows you to extend (extrude) the shape of a 2D or 3D 
feature (a polygon or polyline, for example) from a base surface to a second upper 
or lower surface. This allows visualisation of various bodies such as fault 
surfaces, mine shafts and workings, vein systems and buildings in three 
dimensions. This tool is fully documented in .

See also
...Extruding Objects in 3D
...Extruding Models from Points, Lines and Polygons

3D Utilities Menu

• Multi Section Creator Tool

• Image on Grid Creator Tool

• Object Manager Tool

Multi Section Creator Tool

This tool is specifically designed for viewing cross-section images in 3D that are 
not part of a drillhole project. For example, geological sections which have been 
scanned from geological map sheets or company reports or images of vertical 
slices cut through a geophysical model can be displayed in the correct 3D 
geographical space using this utility.

The cross-ections must be in PNG, BMP or JPG image format. A MapInfo 
Professional table containing polylines representing the position of each cross-
section in plan view is also required. Each polyline must be attributed with the 
cross-section image file name and the top and bottom elevations of the image.
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When the Multi Section Creator tool is run, select the table containing the 
attributed cross-section polylines, and corresponding image name, top and 
bottom fields. An optional group field allows images to be grouped into sub-layers 
in the output EGB file. Then choose an output EGB file name and location 
(defaults to the same directory as the source polyline table) and the format of the 
cross-sectional images. If images of differing formats are involved, specify the 
image file name extension in the section name field, and select the Section name 
includes extension format option. A single EGB file can be generated for all 
sections, or separate EGB file for each section.

See also
...Displaying Other Types of Sections

Image on Grid Creator Tool

This tool creates an EGB file for an image draped over a grid, similar to the View 
in 3D/View Map In 3D options. This EGB file can then be displayed in 3D.  
However unlike the View in 3D/View Map In 3D options, the EGB file output by 
Image on Grid Creator references the input image file, rather than creating a 
new associated PNG file. In this way, the resolution of the image is maintained, 
without having to maximise the size and alter the shape of the image map window 
to fit the image.

See also
...Draping Images Over a Grid

Object Manager Tool

This tool allows the 3D environment to be quickly populated with multiple image 
objects. Examples of use include displaying multiple images of trees and other 
vegetation, signposts and people in a landscape, texturing walls and simple 
structures (e.g. buildings) and placing signboards on buildings. This adds realism 
to the 3D environment and is particularly useful for creating animations.

See also
...Adding Landscape and Ornamental Features
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Toggle Auto 3D Selection Tool

After the initial display of objects in a layer, selecting this option will automatically 
display subsequent map object selections from the same layer in Discover 3D 
without having to reselect a Z value. 

Selections created in Auto 3D Selection mode are temporary and will be 
overwritten each time a new selection is made. To save a selection to a 3D DXF 
file, use Discover 3D>Show Current Selection.

See also
...Selecting Map Objects to Display

Options Tool

The Options dialog provides various controls for converting 2D data into the 3D 
window.

Some of the available controls include:

• Output image resolution

• Default grid compression

• Temporary directory location

See also
...Customising 2D Interface Settings
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Managing the 3D Workspace

• Opening the 3D Window

• Opening a Saved 3D Workspace

• Saving the 3D Workspace

Opening the 3D Window

From the MapInfo menu bar, on the Discover 3D menu, click Open 3D Window 
to open the Discover 3D Window.

Opening a Saved 3D Workspace

From the MapInfo menu bar, on the Discover 3D menu, click Open 3D 
Workspace to open a previously saved 3D workspace. Navigate to the folder 
where the Discover 3D workspace was saved, and select the .D3D workspace 
file. This opens data in the 3D window and associated tables and map windows 
in MapInfo Professional. For more information about the files saved in the 3D 
workspace, see Saving the 3D Workspace.

Saving the 3D Workspace

From the MapInfo menu bar, on the Discover 3D menu, click Save 3D 
Workspace to save the current workspace in both MapInfo Professional and 
Discover 3D. In the Save 3D Workspace dialog, type a name for the 3D 
Workspace file and browse to a folder location.

When a 3D Workspace is saved, a number of files are created in the designated 
folder:

Note Most Discover 3D menu tools will open the Discover 3D window if it is not 
already open. However, for very large datasets, this may cause memory 
problems. It is recommended to open the Discover 3D window with the Open 3D 
Window tool before loading large datasets with any of the other Discover 3D 
menu options.



5 Viewing Mapinfo/Discover Data in 3D 31

WOR file

The .WOR file is a standard MapInfo Professional workspace file. The workspace 
lists all the tables open in the current MapInfo Professional session and their 
associated file paths, the map window dimensions, layer order, graphical 
displays, labelling and any printer information. The workspace created when 
saving a Discover 3D Workspace can be opened using MapInfo Professional 
File>Open Workspace.

EGS file

For more details on EGS Discover 3D session files, see Discover 3D Session 
Files.

D3D file

The .D3D file is a text file that lists the pathways to the associated .WOR and 
.EGS files. The .D3D file is opened through the Discover 3D> 
Open 3D Workspace menu option and results in the saved work session being 
opened up in both MapInfo Professional and Discover 3D. To edit a .D3D file 
simply modify the tables and views in either MapInfo Professional or Discover 3D 
and re-save the 3D Workspace.

See also
...Opening a Saved 3D Workspace

Using the 3D Display Wizard

The 3D Display Wizard provides a user-friendly step-by-step guide to displaying 
either the entire current map view or individual map objects in Discover 3D. If the 
entire map window is selected it is displayed as a georeferenced raster image; 
map objects are displayed as a 3D Vector file. The menu option Discover 3D>3D 
Display Wizard opens the 3D Display Wizard. 
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3D Display Wizard

The wizard displays a series of screens with Next and Back buttons to progress 
through the various choices. Use these buttons to navigate forward and 
backwards through the entry screens if modifications need to be made to initial 
selections. 

Initial 3D Display Wizard screen. 
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Select the type of data to view in 3D. To display an entire map window as a raster 
mapper image (Georeferenced Bitmap Image) choose Entire Map Window. To 
display individual map objects as 3D vectors select Objects from a Table. Click 
Next to continue.

Entire Map Window

Select map window to display in 3D

If the Entire Map Window 3D data view is selected then a list of available map 
windows for transfer to 3D is displayed. Only one mapper can be selected at a 
time. Click Next to continue.
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Select the Z value or height

In order to view the mapper in the 3D window it must be assigned a Z value or 
height. To display the mapper image as a flat image at a constant height select 
the By assigning it a constant value option and enter a value.   

Alternatively, the mapper image Z value or height may be derived from a gridded 
surface such as a Digital Terrain Model (DTM) or other gridded surface which 
covers the mapper image extents.  The gridded surface must be open in MapInfo 
Professional to be available for selection. Choose Using a Grid as the 3D 
surface and highlight the gridded surface in the available surface window. The 
mapper image displays in the Discover 3D map window as a variable Z value or 
height image which appears to be “draped” over the gridded surface.  
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Objects from a Table

If the Objects from a Table 3D data view is selected the next dialog containing 
a list of the currently open tables is displayed.

Select Data to View dialog

Choose the table that contains the data objects to display as vector objects in the 
Discover 3D map window. To display only a subset of data from a table use any 
of the standard MapInfo Professional or Discover Selection or Query tools and 
choose *Selection* from the list of available tables. 

Once the table selection has been made the Select Object Type dialog is 
displayed:
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Select Object Type dialog

The Select Object Type dialog contains two options to display data objects in the 
Discover 3D map window. Data objects may be displayed as one of the following:

• Point Data – Individual objects or data locations are displayed in Discover 
3D as isolated points. The points can have their size, shape, and colour 
modified based on the data in a selected data table.

• Line Data – Data reading points can be joined by a line. The colour and 
thickness of the line can be controlled depending on the data in a selected 
data table.

Select the appropriate Object Type and click on the Next button to continue.



5 Viewing Mapinfo/Discover Data in 3D 37

Select Point and Line Style property dialogs

Regardless of which Object Type is selected, the following Select Style property 
dialogs allow the choice of the method for determining the Z value or height for 
the data objects from the following options:

Simple – The Z value or height for the data objects may be derived from a gridded 
surface, a column in the data table or from a specified constant value. 

Clicking Next with this option selected the Specify Z or Height Value options 
dialog will open. This dialog allows selection of the appropriate methods for 
determining the Z value from those above. The Z value or height may also be 
derived from a combination these options. i.e. data objects that fall within a 
gridded surface will be assigned a Z value or height from the grid, data objects 
outside of a gridded surface will be assigned values from a column in the table 
otherwise any data objects which do not meet any of the above criteria will be 
assigned a specified constant Z value or height value.
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Simple method Z value or height options

Advanced – The data objects using this option use a height determined by a data 
value or the location (Z value) of the objects.

Final screen of the 3D Display Wizard
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The final screen of the wizard is displayed before the mapper raster image or data 
objects are transferred to Discover 3D. If you wish to change any of the selections 
made in the wizard select the Back button. To proceed with the 3D display 
operation, click the Finish button.

If there is no Discover 3D map window currently open a new 3D map window will 
be opened with the mapper raster image or data objects displayed. Otherwise the 
3D data will be added to the current 3D map window display. 

Refreshing Data from MapInfo/Discover

The Discover 3D>Refresh All 3D Data tool updates the 3D Window with 
changes made to datasets tables that are open in both Mapinfo/Discover and 
Discover3D (this includes Points, Lines, Drillholes, Trenchs in the 3D Window). 
Alternatively, you can use Discover 3D>Create 3D Points or Discover 
3D>Create 3D Lines and Discover 3D>View Drillholes to reload the currently 
opened dataset in the 3D Window.

Displaying Map Window Views as 3D Images

Datasets visible in a MapInfo mapper window views can be viewed in Discover 
3D as georeferenced bitmap images. These raster images may include surface 
layers such as DEM or topography grids or other raster files such as aerial 
photography or satellite imagery, vector data or annotation layers. 

To visualise data in 3D as a raster image:

1. Open all the tables to be displayed into one map window in MapInfo 
Professional. Re-order the layers as necessary (using the MapInfo 
Professional Layer Control) and apply annotations as desired.

2. Ensure that the mapper window view encompasses the area of interest 
(dimensions and scale).

3. Either right-click in the mapper window, and from the shortcut menu, 
choose View in 3D or select Discover 3D>View Map in 3D menu option. 
The dialog appears:
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View Map in 3D dialog

4. Select the map window from the list in Select mapper to view in 3D. If the 
View in 3D menu option is selected, the map window from which this was 
activated is automatically selected as the map window and shows only the 
3D surface controls.

5. Two options are available to control the Z value of the 3D image:

• To display the entire image at a fixed elevation, check the Constant 
value (flat) control and enter a specific height. 

• Alternatively, the image can be ‘draped’ over a grid file such as an 
elevation grid. Check the Grid file control and select the 
appropriate grid file from the pull-down list. Only grid files that are 
currently open in MapInfo Professional will be listed. 

6. Enabling the Permanently Save tick box at the bottom of the dialog will 
open the Save 3D Information as dialog upon pressing OK. This allows 
the output (a georeferenced image: see below) to be named and saved to 
a selected directory. Pressing OK without enabling this option will create 
an georeferenced image using the map window’s name, and save this into 
the Discover 3D Temporary directory (set under Discover 3D>Options). 
See Customising 2D Interface Settings; these temporary files will be 
deleted on exiting 3D if the Remove temporary files on exit option is 
enabled).

The map window is now displayed in a 3D map window as a georeferenced 
bitmap image (if the Discover 3D window was not already open, it will 
automatically open prior to displaying the image). A georeferenced bitmap image 
is made up of two files:
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• The first file is a raster image file of the map window with a .PNG (Portable 
Network Graphics) extension. 

• The second file is a text header file with an .EGB (Encom Georeferenced 
Bitmap) extension. This header file stores information relating to image 
files such as the image name, format and projection details. 

 

A map window displayed in Discover 3D draped over a topographic surface

To modify 3D image parameters such as transparency, scaling or offset refer to 
the Changing Image Display Properties section of the Raster Images chapter.

Maximising Image Resolution

The quality of the output 3D georeferenced image can be improved via:

• Utilising a larger MapInfo mapper window (but do not maximise it).

• Ensuring that your MapInfo mapper window is zoomed to the extents of 
the required data.
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• Under Discover 3D>Options, increase the Create Raster Images at 
…Screen Resolution factor set in the Display tab of the dialog. This will 
increase the output image resolution. However it will also result in a larger 
output PNG image file size; displaying multiple high resolution images 
within Discover 3D may reduce the redraw speed and efficiency.

• If your input dataset in the map window is already an image (e.g. an air 
photo), and it will be draped over a grid (and no other data is involved), 
perhaps use the use the Image on Grid Creator Tool utility. This will create 
a .EGB header file referencing directly to the source image, thus 
preserving the source image’s resolution. 

Displaying Map Objects

• Selecting Map Objects to Display

• Displaying Map Objects as 3D Vectors

• Displaying Surfaces in 3D

• Displaying Points in 3D

• Displaying Lines in 3D

Selecting Map Objects to Display

If a number of map object selections are to be viewed consecutively in Discover 
3D, the Auto 3D Selection mode can be activated using the Discover 
3D>Toggle Auto 3D Selection menu option. A tick next to this menu option 
denotes Auto 3D Selection mode has been activated.

This option will enable the Discover - Show Current Selection dialog to be 
displayed after the first map object selection from a layer is made and any 
subsequent map object selections from the same layer will automatically be 
displayed in Discover 3D without having to select a Z value option each time. 
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If a subsequent selection involves map objects from a different layer, the 
Discover - Show Current Selection dialog will displayed after the first selection 
to select the appropriate Z value option and then each subsequent selection in 
the new layer will be automatically displayed in Discover 3D. 

Selections created in Auto 3D Selection mode are displayed as Temporary 
selections (Selection.dxf) in Discover 3D and will be overwritten each time a new 
selection is made. To save a Permanent Selection to a 3D DXF file use the 
Discover 3D>Show Current Selection menu option.

To de-activate Auto 3D Selection select the Discover 3D>Toggle Auto 3D 
Selection menu option again.

Displaying Map Objects as 3D Vectors

The Discover 3D>View Objects in 3D menu option enables point, line or 
polygon map objects to be displayed in a Discover 3D as 3D Vector files, with a 
number of different options available for assigning the Z values. The target 
objects can be either a selection or an entire open MapInfo table.

To display MapInfo data as vector objects in 3D:

1. If the input data is to be a selection, select the objects using any of the 
available MapInfo Professional or Discover selection tool

2. Select the Discover 3D>View Objects in 3D menu option. The View 
Objects in 3D dialog is displayed:
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View Objects in 3D dialog

3. Select data to display in 3D from the list of layers available: either the 
*Selection* layer or a table.

4. Assign the Z value for the selected data by either:

• Selecting the from Field to use for Z values in the pull-down list.

• Selecting a Surface grid from Grid pull-down list. In order for a 
surface grid to be available for selection, the grid must be open in a 
map window.

• Manually entering a Constant Z value.

If the Z value for a selection is to be taken from a column or a constant value, 
make sure that a surface grid has not already been selected from the pull-down 
list as a grid Z value entry will automatically override any other Z value options. 
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5. Offset and Scale parameters can also be specified for the 3D display. The 
Update Z Range button allows the Z range display for the selected data to 
be updated. 

6. Enabling the Save Permanently option at the bottom of the dialog will 
open the Save 3D DXF as dialog upon pressing OK. This allows the 
output DXF vector file to be named and saved to a specified directory. 
This is of particular use when the selection layer is chosen for input; if the 
Save option is not enabled, the output DXF is named using the 
consecutive Query(n) (eg. Query1.dxf) from MapInfo Professional and is 
stored in the nominated Discover 3D temporary folder (set under 
Discover 3D>Options. See Customising 2D Interface Settings; these 
temporary files will be deleted on exiting 3D if the Remove temporary 
files on exit option is enabled).

7. Pressing OK without enabling the Save option will create a DXF based on 
the input file name and save this into the same directory as the input file. 
The selected map objects are displayed in the Discover 3D map window in 
a new Vector branch.

To modify 3D Vector parameters such as transparency, scaling or offset refer to 
the Changing 3D Vector Display Properties section of the Vector Objects in 3D 
chapter.

Displaying Surfaces in 3D

The Discover 3D>View Surface in 3D menu option allows the display of 
selected grid files in 3D. This feature will only allow display of grid files that are 
currently open within MapInfo Professional. Selecting this option opens the View 
Surface in 3D dialog:

Note If multiple Z options are selected, they are processed sequentially. Thus if all 
options are ticked, the utility will first check for a Z value in the assigned field. If 
no value exists, it will then check the selected grid for a value. If no grid value 
exists, it will then use the specified constant value.

Note Another way to generate 3D vector files from Mapinfo is using the 3D Extrusion 
Wizard. See Extruding Models from Points, Lines and Polygons. Also, the 
Discover>Import or Export>Vector Export provides a Z field option for 3D 
formats.
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View Surface in 3D dialog

Select the desired surface, and press OK to display in 3D. 

3D gridded surface display

See the Changing Surface Display Properties section of the Gridded Surfaces 
in 3D chapter for further information of modifying and controlling surfaces in 3D.

Displaying Points in 3D

Point data tables require each record to have an X (Easting), Y (Northing) and Z 
(RL) field; a line identifier field is optional. A geochemical soil sampling program 
is an example of a point data file that can be viewed in Discover 3D.
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To view point data as 3D Points:

1. Open a point data table into a mapper window. To view only a subset of 
the point data table make a selection in the map window.

2. Select Discover 3D>Create 3D Points. The Discover Show 3D Points 
dialog is displayed:

 
Discover – Show 3D Points dialog

3. Select the point data table or Selection from the list of open tables. 
Select Overwrite existing objects to reset the current field mappings for 
the X, Y, Z and Line fields in Disover3D.

4. Click OK to load the data into Discover 3D. The point data table is 
displayed in the 3D map window. A dialog is displayed prompting for the 
X, Y, Z and optionally a line field.

If a map window selection is used, for future reference a copy of a point 
data selection is stored in the same folder as the original point table and 
given a file name such as ~MAP0330.TAB.

To modify point symbol type, colour, size, rotation and labelling refer to Changing 
Point Display Properties. 

Note When a point table is opened in Discover 3D for the first time, an .EHF (Encom 
Header File) is added to the directory where the table is located. This file 
contains the X, Y and Z fields to use in the 3D display.
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Displaying Lines in 3D

In Discover 3D, line data generally refers to data that has been collected 
systematically along linear traverses with samples or measurements taken at 
discrete intervals. The data format is exactly the same as a point data table except 
whereas point data is displayed as individual points in Discover 3D, line data is 
represented by a single linear feature for each sample line. Line data tables 
require each record to have an X (Easting), Y (Northing) and Z (RL) field along 
with a line identifier field. Geophysical survey line profiles are an example of a line 
data file that can be viewed in Discover 3D.

To view point data as 3D Lines:

1. Open a line data table into a map window. To view only a subset of the line 
data table make a selection in the map window.

2. Select Discover 3D>Create 3D Lines. . The Discover Show 3D Lines 
dialog is displayed:

Discover – Show 3D Lines dialog

3. Select the line data table or *Selection* from the list of open tables. Select 
Overwrite existing objects to reset the current field mappings for the X, 
Y, Z and Line fields in Disover3D

4. Click OK to load the data into Discover 3D. The line data table is displayed 
in the 3D map window. A dialog is displayed prompting for the X, Y, Z and 
optionally a line field.
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If a map window selection is used, for future reference a copy of a line 
data selection is stored in the same folder as the original lien table and 
given a file name such as ~MAP0386.TAB.

To modify line parameters such as colour modulation, labelling, displaying 
reading or sample locations, applying fill colours above or below a nominated 
threshold or removing lines from the 3D map view, refer to Changing Line Display 
Properties. 

Offset line data using the copper data channel

Note When a line table is opened in Discover 3D for the first time, an EHF (Encom 
Header File) is added to the directory where the table is located. This file 
contains the X, Y and Z fields to use in the 3D display.
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Displaying Drillhole and Trench Data in 3D

• Viewing Drillholes in 3D

• Viewing Drillhole Intervals as 3D Points

• Viewing Drillhole and Trench Sections

• Viewing Drillhole Logs

• Viewing Section Layers

• Viewing Trenches

Viewing Drillholes in 3D

In order to view drillholes in Discover 3D from the Discover/MapInfo interface the 
drillholes must be part of a Drillhole Project.  See the Discover User Guide for 
information on Creating a Drillhole Project.

Open a drillhole project using the Drillholes>Project Manager dialog and select 
the appropriate drillhole project from the pull-down list. Once the drillhole project 
is open, the drillholes to display in Discover 3D may be selected from a list of 
available drillholes or from a map window selection.
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To view drillholes in 3D:

1. Select Discover 3D>View Drillholes. The 3D Drillhole Wizard dialog 
appears:

The Drillhole Wizard dialog with drillhole selection to be created as a new subset

2. The Available box contains a list of all the drillholes in the collar table. Any 
drillholes listed in the Selected box will be automatically displayed in 
Discover 3D. 

Use the Select All button to copy all the drillholes in the list to the 
Selected box.

Use the Select button to select individual drillholes. Hold down the left-
mouse button and drag or hold down the SHIFT key to select consecutive 
drillholes.

Use the Deselect All button to remove All drillholes from the Selected 
box list.
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Alternatively, select the desired drillholes from a collar browser or map 
window and then select the Discover 3D>View Drillholes menu option. 
The selected drillholes are automatically listed in the Selected box.

3. The Options section at the bottom of this dialog controls the size of the 
drillhole dataset imported into Discover 3D (as opposed to what is 
displayed in 3D). This is of particular use when dealing with very large 
drillhole projects comprising thousands of holes. By default the entire 
drillhole project is imported into 3D, but for large datasets this may slow 
down rendering and navigation in 3D. 

Ticking the Subset based on selection option will import (and display) 
into 3D only the Selected holes. The relevant file subsets (collars, 
assays, etc) will be created with the selected Suffix for tables applied.  
Choosing the Save Permanently option will enable the data subsets to be 
saved to a specified directory, otherwise these files will be saved to the 
Discover 3D temporary folder (set under Discover 3D>Options. See 
Customising 2D Interface Settings; these temporary files will be deleted 
on exiting 3D if the Remove temporary files on exit option is enabled).

4. Click OK and view the selected drillholes in Discover 3D. The selected 
drillholes are displayed in the 3D map window. To display downhole 
attributes, colour patterns, labels, etc. refer to the Changing Drillhole 
Display Properties section of the Drillholes in 3D chapter. An example of 
a 3D drillhole display is shown below.

 

Use the Deselect button to remove individual drillholes. Hold down the 
left-mouse button and drag or hold down the SHIFT key to select 
consecutive drillholes.

Note If the drillhole project or a subset is already open in 3D, a prompt to replace the 
data will be displayed. Accepting this will automatically reapply any existing 3D 
display settings (e.g. colour or thickness modulation) to the new data.
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Display of drillholes beneath the air photo with lithology modulation

Viewing Drillhole Intervals as 3D Points

The View Intervals as 3D Points tool converts a 2D drillhole downhole table 
(such as a lithology or assay table) directly into a 3D Point dataset displayed in  
Discover 3D, using either the downhole table interval top, middle or bottom 
locations.

The resulting mappable MapInfo Professional table can also be queried (e.g. with 
Select by Group or SQL Select) to select a subset such as only fault intercepts 
or copper values above 10,000 ppm). These can then be viewed in 3D with the 
Create 3D Points Tool), for more advanced modelling including:

• Precise digitisation targets by snapping to the 3D Point downhole subset.

• Block model interpolation 3D Point downhole subset with the 3D Gridding 
tool (see Interpolating a Gridded Surface from Digitized Drillhole 
Intercepts). 
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• Surface interpolation (e.g. unconformity, water table, fault plane) of an 
appropriate 3D Point downhole subset using the 3D Solid Genertator tool 
(see Wireframing Models from Polylines, Polygons and Surfaces).

Mapping downhole data in 3D:

1. Ensure a drillhole project is open in the 2D environment 
(Drillholes>Project Manager). It is also generally useful if the drillhole 
traces are already displayed in 3D (View Drillholes Tool ).

2. Select Discover 3D>View Intervals as 3D Points.

3. Select the target Downhole Data table from the top pull down list.

4. Select the interval position on each downhole sample interval to calculate 
3D coordinates, either:

• Top

• Midpoint (the midpoint of a straight line between the top and bottom 
positions; this should be used cautiously for longer intervals such 
as when logging by stratigraphic unit)   

• Bottom 

5. The output file is automatically placed into the Drillhole Projects root 
directory, and includes a suffix indicating which interval position was 
selected in step 4.

6. By default the resulting mappable MapInfo table will be automatically 
displayed in 3D as 3D points with the View in 3D option (bottom left of 
dialog)enabled. If you wish to view a subset of the downhole table in 3D 
(see below) rather than the complete table, disable this option .

7. Press OK

8. The new table will be auto-opened into MapInfo Professional, with the 
following components:

• XYZ coordinate fields will be created and populated within the table 
for each intervals:

Top (FromX/FromY/FromZ)

Midpoint (MidX/MidY/MidZ) and 

Bottom (ToX/ToY/ToZ) locations
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• The table will be automatically mapped on the selected interval 
positons coordinates

• Both the populated coordinates and the table mapping utilise the 
drillhole collar table's projection

9. If the View in 3D option was checked, the dataset will also load into 
Discover 3D, using the selected interval position's XYZ coordinates.

Displaying a subset of downhole data in 3D:

(follows on from previous procedure)

10. Perform a query on the mappable table created with the previous 
procedure (not the source downhole data table). The following query tools 
are recommended:

• Discover>Data Utilities>Select by Group tool, particularly for 
geological/lithological selections (e.g. to display all occurrences of 
limestone).

• Query>SQL Select tool, particularly for selections involving 
numeric data (eg Au assays > 50 ppm, or quartz vein intensity > 
25%).

11. Run Discover 3D>Create 3D Points, and select the query generated in 
step 10. Ensure the Z field used (FromZ/MidZ/ToZ) is the same as 
selected in step 4 (inherent in the target table name)
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Display of a drillhole data subset (fault intercepts) in 3D using View Intervals as 3D Points

Applying the Surface Gridding tool in 3D to interpolate the same 3D Point dataset as a 
gridded surface.

Note Drillhole selections can also be displayed dynamically in the 3D environment by 
filtering the drillhole dataset using the Field Data Conditioning Tool) in tandem 
with Colour Modulation or Thickness Modulation.
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Viewing Drillhole and Trench Sections

Drillhole and trench sections created in Discover can be viewed in Discover 3D 
as georeferenced bitmap images. These section images may include downhole 
display attributes or ore body boundary polygons along with annotation data. See 
the Discover User Guide for information on creating drillhole and trench sections.

Create a drillhole or trench section in Discover using the Drillholes>Define New 
Section or Plan menu option. Or you can open an existing section into a map 
window via the Drillholes>Section Manager menu option. Alternatively, open all 
of the associated section files into a map window using the File>Open command 
or from a previously saved workspace.

To view a drillhole or trench section as a georeferenced bitmap image in 
Discover 3D:

1. Either right-mouse click in the drillhole or trench section map window and 
choose View in 3D from the shortcut menu or select Discover 3D>View 
Sections. The Discover – Export Located Bitmap dialog appears:

Discover – Export located bitmap dialog

2. Select one or more section map windows from the list of available map 
windows. 

Note This option takes a screenshot image of the section map window. To view the 
section as 3D vectors, see Viewing Section Layers.
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3. Enabling the Permanently Save tick box at the bottom of the dialog will 
open the Save Sections for 3D display dialog upon pressing OK. This 
allows the output georeferenced image to be named and saved to a 
selected directory. Pressing OK without enabling this option will create an 
georeferenced image using the map window’s name, and save this into 
the Discover 3D Temporary directory (set under Discover 3D>Options. 
See Customising 2D Interface Settings; these temporary files will be 
deleted on exiting 3D if the Remove temporary files on exit option is 
enabled).

4. The sections are displayed in the 3D map window. As the section is 
created as a georeferenced bitmap image, two files are created - a .PNG 
(Portable Network Graphics) raster image file and a text header file with 
an .EGB (Encom Georeferenced bitmap) extension.

Drillhole section images displayed in 3D

To modify section parameters such as transparency, image processing refer to 
the Changing Image Display Properties section of the Raster Images chapter.
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Maximising Image Resolution

The quality of the output 3D georeferenced image can be improved via:

• Utilising a larger MapInfo mapper window (but do not maximise it).

• Ensuring that your MapInfo mapper window is zoomed to the extents of 
the required data.

• Using Discover 3D>Options, increase the Create Raster Images at 
…Screen Resolution factor set in the Display tab of the dialog. This will 
increase the output image resolution. However it will also result in a larger 
output PNG image file size; displaying multiple high resolution images 
within Discover 3D may reduce the redraw speed and efficiency.

Viewing Drillhole Logs

Drillhole Log Profiles created in Discover can be viewed in Discover 3D as 
georeferenced bitmap images. These drillhole log images may include up to 16 
columns of downhole lithological information, assay values or geophysical 
readings displayed as text, linegraphs or histograms. See the Discover User 
Guide for information on Creating a Drillhole Log.

Create a drillhole log in Discover using the Drillholes>Log Display menu option 
or open an existing drillhole log in MapInfo Professional.

To view a drillhole log as a georeferenced bitmap image in Discover 3D:

1. Select the Discover 3D>View Logs menu option. The Discover – Export 
DH Logs to 3D dialog appears:
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Discover – Export DH Logs to 3D dialog

2. Highlight the logs to display in 3D from the available list. If drillhole log 
images are already displayed within Discover 3D, enabling the Overwrite 
existing images option will replace them with these newly selected logs. 
Otherwise, the newly selected logs will simply be added to the 3D display 
in addition to those already displayed.

3. Selecting Best Fit will increase the resolution and accuracy of the log 
image displayed in 3D. This option is on by default, and is recommended.

4. Enabling the Save Permanently option allows the user to specify the 
names and output directory (this defaults to the drillhole project directory) 
for these files and retain these images at the end of the 3D session. 
Pressing OK without enabling this option will create georeferenced 
images using each map window’s name, and save these into the Discover 
3D Temporary directory (set under Discover 3D>Options. See 
Customising 2D Interface Settings; these temporary files will be deleted 
on exiting 3D if the Remove temporary files on exit option is enabled). 
Press OK to display the logs in Discover 3D.

5. Alternatively, place the cursor in the log display window and right click to 
select the View in 3D menu item. This will add just the selected log 
display to the 3D window, in a cumulative fashion.

To modify log image parameters such as transparency, image processing or 
orientation refer to the Display Drillhole Logs Images section.
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Viewing Section Layers

Drillhole section layers created in a Discover drillhole project can be viewed in 
Discover 3D as either 3D vectors (see Displaying 3D Vectors) or 3D features (see 
Digitizing and Managing 3D Features). These section layer files may contain 
lithological or ore body boundaries or polylines, or other geological interpretations 
such as faults and structural interpretations.

Create a drillhole section layer in Discover using the Drillholes>Section 
Manager>Advanced>Add section layer menu option or open an existing 
drillhole section that contains custom layers. See the Discover User Guide for 
more information on creating a section layer.

Note To increase the output resolution of an image created within Discover, increase 
the Create Raster Images at …Screen Resolution factor set in the Display tab 
of the Discover 3D>Options dialog. This will however result in a larger output 
PNG image file size; displaying multiple high resolution images within Discover 
3D will reduce redraw speed and efficiency.

Note Polyline sections are not supported by this tool.



62 Encom Discover 3D User Guide

Section layers (red, orange and green linework) displayed as 3D vector files over 
modulated drillholes in 3D

Displaying section layers as 3D vectors (see Displaying 3D Vectors) in 3D allows 
attributed interpretations to be coloured individually (e.g. red ore body, blue 
supergene zone, green south_fault), etc). Vector files are also a far more efficient 
way of displaying this information than as an image (eg. via the Viewing Drillhole 
and Trench Sections menu option). 

To create a 3D vector file from a drillhole section layer, use the Discover 
Drillholes>External Data Formats>Export Section Layer as 3D DXF menu 
option. If the 3D vector file already exists, open up the 3D vector file directly from 
within the Discover 3D application.
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Section vector layers displayed in 3D as Feature Objects (left), and then converted into 3D 
solids using the Solid Generator (right: the colour scheme is identical to the previous 
image)

Displaying section vector layers as 3D features (see Digitizing and Managing 3D 
Features) allows 3D Solids to be built from the source data vector layers; the 3D 
Solid Generator (see Wireframing Models from Polylines, Polygons and 
Surfaces) is used to wireframe between the existing vector layers. This is a 
powerful way to convert 2D interpretations into truly 3D geological bodies. 

To view a drillhole section vector layers table as 3D Feature Objects:

1. Open the drillhole project, and the necessary cross-sections.

2. Use the Discover 3D>View Section Layer menu option. The Export 
Layer to 3D Feature dialog is displyed.

3. Select one or more drillhole section layers from the list.

4. By default the output Feature database file is named FeatureExport.fdb 
and is saved to the drillhole project root directory although this location 
can be altered if required. Attribute information (e.g. the Feature Code 
field) will be preserved in the .FDB file.

5. Select the output File format; the “Multiple files based on Feature Code 
field” option is recommended, as it will generate one feature database for 
each unique attribute in all selected sections. 

For example, if multiple 'shale' and 'limestone' bodies have been digitised 
into the custom layers of 20 sections, and attributed as such in the 
inherent 'Feature Code' field, this will generate two feature databases, one 
containing all shale bodies in the 20 sections, the other the limestone 
bodies. this is invaluable for 3D solid generation.

The single File option will simply place all custom layer objects from all 
selected sections into the one (fully attributed) feature database.
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6. Press OK. The new Feature Database is displayed in the 3D window.

See Digitizing and Managing 3D Features for further information on exporting 
drillhole section layers as Feature Objects.

Viewing Trenches

To view trenches in Discover 3D from the Discover/MapInfo interface, the 
trenches must be part of a Drillhole Project. See the Discover User Guide for 
information on creating a drillhole project with trenches.

Open a drillhole project using the Drillholes>Project Setup dialog and select the 
appropriate drillhole project from the pull-down list. Once the trenches project is 
open, the trenches to display in Discover 3D may be selected from a list of 
available trenches.

To view trenches in 3D:

1. Select Discover 3D>View Trenches. The 3D Trench Wizard dialog is 
displayed:

Note Trenches in 3D does not support Bearing and Distance Trench project with 
Segment distances. It also does not support Bearing and Distance Survey 
(either cumulative or segments) when a Topographic DEM surface grid is 
associated with the project.
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2. The Available box contains a list of all the trenches in the collar table. Any 
trenches listed in the Selected box will be automatically displayed in 
Discover 3D.

• Use the Select All button to copy all the trenches in the list to the 
Selected box. Use the Select button to select individual trenches . 
Hold down the left-mouse button and drag or hold down the SHIFT 
key to select consecutive trenches .

• Use the Deselect All button to remove all trenches from the 
Selected box list. Use the Deselect button to remove individual 
trenches . Hold down the left-mouse button and drag or hold down 
the SHIFT key to select consecutive trenches .

3. The Options section at the bottom of this dialog controls the size of the 
trenches dataset imported into Discover 3D (as opposed to what is 
displayed in 3D). This is of particular use when dealing with very large 
trenches projects comprising thousands of holes. By default the entire 
trenches project is imported into 3D, but for large datasets this may slow 
down rendering and navigation in 3D.

Selecting the Subset based on selection option will import (and display) 
into 3D only the selected holes. The relevant file subsets (collars, assays, 
etc) will be created with the selected suffix for tables applied.

Choosing the Save Permanently option will enable the data subsets to be 
saved to a specified directory, otherwise these files will be saved to the 
Discover 3D temporary folder (set under Discover 3D>Options, see 
Customising 2D Interface Settings). These temporary files will be deleted 
on exiting 3D if the Remove temporary files on exit option is enabled.

4. Click OK and view the selected trenches in Discover 3D. The selected 
trenches are displayed in the 3D map window. To display trench attributes, 
colour patterns, labels, etc. see Changing Trench Display Properties.

Note If the trenches project or a subset is already open in 3D, a prompt to replace the 
data will be displayed. Accepting this will automatically reapply any existing 3D 
display settings (e.g. colour or thickness modulation) to the new data.
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Extruding Objects in 3D

The 3D Extrusion Wizard allows you to extend (extrude) the shape of a 2D or 
3D object (e.g. a polygon or polyline) from a base surface to a second or upper/
lower surface. This allows meaningful and useful visualisation of various bodies 
such as fault surfaces, mine shafts and workings, vein systems and buildings in 
three dimensions. 

The Extrusion Wizard can be accessed from both the 2D and 3D windows. It can 
operate on objects either within a mapped MapInfo Professional table (or a map 
window selection) or a Feature database (see Digitizing and Managing 3D 
Features). Height information can be specified from fields within the MapInfo 
Professional table/Feature dataset or manually set by the user. The sides of the 
extruded shape can be created as polygonal walls that give the impression of an 
enclosed volume within the extruded outline of the source object(s). 

Fault visualisation using the 3D Extrusion Wizard

This tool is fully documented in Extruding Models from Points, Lines and 
Polygons.
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Displaying Other Types of Sections

Multiple geological or geophysical cross-sectional profiles can be easily 
georeferenced and displayed in 3D as an EGB file using the Multi Section 
Creator.

This utility is specifically designed for viewing cross-section images in 3D that are 
not part of a drillhole project. For example, geological sections which have been 
scanned from geological map sheets or company reports or images of vertical 
slices cut through a geophysical model can be displayed in the correct 3D 
geographical space using this utility.

Example of a 2D geological cross-section (courtesy PIRSA, Australia)

A MapInfo Professional table containing polylines representing the position of 
each cross-section in plan view is also required. Each polyline must be attributed 
with the cross-section image file name and the Top and Bottom elevations of the 
image. An example is displayed below.

Example of attributed polyline table required for georeferencing of multiple geological 
cross-sections (courtesy PIRSA Australia)
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Run the Discover 3D>3D Utilities>Multi Section Creator. Specify the Table 
containing the attributed cross-section polylines, and then specify the appropriate 
image Name, Top and Bottom Height fields. An optional Group field can also 
be specified, grouping images with a shared attribute in this field into sub-layers 
in the output EGB file.

Choose an Output EGB file name and location (this defaults to the same directory 
as the source polyline table), and the Format of the cross-sectional images. If 
images of differing formats are involved, the image format suffix can be specified 
(in addition to the image name) in the Section Name field, and the Format set to 
Section Name Includes Extension. The Output Type pull-down list allows the 
choice of either one EGB file for all the sections, or separate EGB file for each 
section. Select OK.

Multi Section Creator dialog

A dialog indicating the percentage completion status will appear.  At the 
completion of this process, and the EGB file will be opened and displayed in the 
3D window as a new image branch.
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3D view of multiple geological sections with a transparent geological map (courtesy PIRSA 
Australia)

Draping Images Over a Grid

This utility creates an EGB file for an image draped over a grid, in a similar fashion 
to using the View in 3D/View Map In 3D options. This EGB file can then be 
displayed in 3D.  However unlike the View in 3D/View Map In 3D options, the 
Image on Grid Creator output EGB directly references the input image file, 
rather than creating a new associated PNG image file. Thus the resolution of the 
image is maintained, without having to maximise the size and alter the shape of 
the image map window to fit the image.
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Image on Grid Creator dialog

To drape an image over a grid:

1. Ensure both the image and grid files are open within MapInfo 
Professional. 

2. Select Discover 3D>3D Utilities>Overlay Image on Grid.

3. In the Overlay Image on Grid dialog, select these files in the appropriate 
pull-down lists. 

4. Select an output file name and directory, and press OK. 

5. The EGB file is opened and displayed in the 3D window as a new image 
branch.

Adding Landscape and Ornamental Features

The Object Manager allows the 3D environment to be easily and rapidly 
populated with multiple image objects. Examples of use include displaying 
multiple images of trees and other vegetation, signposts and people in a 
landscape, texturing walls and simple structures (e.g. buildings) and placing 
signboards on buildings. These can be a useful way of giving a 3D environment 
a sense of scale (particularly useful for Creating a Fly-Through Animation)
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Example of a 3D environment populated with image objects

The Object Manager is accessed via the Discover 3D>3D Utilities>Object 
Manager menu option. Use the Select Table pull-down list to select either a point 
or polyline TAB file representing the desired image locations. Specify an Output 
File name and location (this will be an EGB file).
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Object Manager dialog

The following parameters can be specified:

• The Object Style parameters can be specified via either appropriate 
attribute fields within the source file, or using default values assigned 
within the Object Manager dialog. 

• The Picture parameter controls the image used to represent the object. 
Using the Default Value allows image selection from all available images 
within the Image Location directory specified using the Options button at 
the bottom left of the dialog. A field can also be selected to specify the 
image; for each object, this must contain either a full image filename (if the 
image is in the same directory as the object location file), or a relative or 
full directory path as well as the image file name.

• The Shape parameter provides 3 default value options for the shape of 
the displayed image: Plane (a single image presented as a vertical plane), 
Cross (two perpendicular images crossing centrally, creating an illusion of 
a 3D image object from a distance) or Box (four images placed in a square 
around the object location). Alternatively, a field containing these 
parameters as text attributes can be specified.
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• The Width of the image object can be set as a Default Value, assigned 
from a specified field, or for polyline objects, set as the Line Segment 
Width.

• The Height of the image object can also be set either as a Default Value, 
or assigned from a specified field.

• The Object Location parameters control the positioning and orientation 
of the image objects.

• The Location X & Y parameters provide options to Centre On Object 
(recommended option for point objects), Centre On Line Segments 
(recommended option for polyline objects), Use a Default Value or specify 
a field from which to read location data.

• The Location Z parameter can be specified as a field or set as a default 
value. If the image objects are to be placed on a Surface (e.g. a DEM or 
topographic surface), set the Default Value as 0, and once the images are 
displayed in the 3D window, use the Offset tab of the Images Properties 
dialog to Add a DTM offset using the appropriate surface.

• The Orientation of the output image objects can be specified as a Default 
Value, selected from a defined field or for polyline objects, calculated 
using the Line Segment Angles.

When these parameters are set, press OK to generate the EGB file. The EGB file 
will be opened and displayed in the 3D window as a new image branch.
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6 Understanding the Discover 3D Interface
• Discover 3D Window

• Discover 3D Menus

• Discover 3D Toolbars

• Customising the 3D Window

• Workspace Tree

• Projections in 3D

• Navigating in 3D

• 3D Display Modes

• Cursor Plane

• Floating Colour Bar

• Sky Map

Discover 3D Window

For information on opening the 3D window, see Opening the 3D Window.
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Discover 3D window

The 3D window is divided into six main regions:

• The Workspace Tree (see Workspace Tree) provides a hierarchal view of 
all 3D data objects, data sources and controls. The Workspace Tree is the 
primary window for annotating, editing, ordering objects and general 3D 
window defaults.

• The Display Window is the main region for displaying 3D data, navigating 
and digitising.

• Dockable Toolbars are grouped into common operation commands used 
in Discover 3D. The toolbars are fully customisable and can be displayed 
as either floating or docked. For more information about the tools 
available, see Discover 3D Toolbars.
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Discover 3D Menus

• File Menu

• View Menu

• Display Menu

• Features Menu

• The Main menu contains a more detailed list of Discover 3D tools than 
displayed on the dockable toolbars, the following menus are available:

• File menu: Control the opening and saving of session files, 
exporting imagery, data packaging and printing.

• View menu: Options to view/hide Information Windows, Toolbars, 
view modes, and status bar. 

• Display menu: Select vector or raster object types to insert into 3D 
window display.

• Features menu: Controls for creating, editing, saving and querying 
Feature Databases.

• Tools menu: Additional tools for vector and raster datasets and 
options for 3D global preferences.

• Grids menu: Tools for creating, importing and querying Voxel 
models and surface grids.

• Utilities menu: Additional productivity tools for creating AVI's, solid 
generating, extruding etc.

• Help menu: Help and reference material.

For more information, see Discover 3D Menus.

• A Status Bar at the base of the screen displays 3D navigation and cursor 
coordinates bearing and inclination information and tool tips.

• The Information Windows are composed of the Explorer, Data, and 
Feature Data windows. These windows display dynamic information for 
data contained in the Display Window..
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• Tools Menu

• Grids Menu

• Utilities Menu

• Help Menu

File Menu

File>Open

Open supported data types into Discover 3D.

Supported file types include:

• Discover Downhole files

• Geosoft Downhole files (before OASIS v 4.2)
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• Geosoft Downhole files (after OASIS v 4.2)

• All supported Surface files

• All supported Image files

• All supported 3D Vector files

• All supported 2D Vector files

• All supported Session files

• All supported Fly-Through files

• Encom Voxel Model files

File>Close Datasets

Close selected drillhole datasets in Discover 3D

File>Close All

Close all open datasets in Discover 3D

File>Open Session

Open a Discover 3D Session file.

Session files do not contain data, objects or bitmaps. Consequently, if a session 
is opened but the data or object access are not available, Discover 3D will not be 
able to restore the session completely. A message is displayed in this 
circumstance indicating which source file is unreadable. 

Session file restoration has a lost file recovery mechanism. If Discover 3D cannot 
locate some data or other necessary files, it alerts you and offers the option of 
browsing. This applies to all component file types that may have been saved with 
the session.

In the event that the requested file is not available, from the Open File dialog, 
select the Cancel button and the session will continue through its list of files to 
restore what it can.

File>Save Session

Save currently open dataset and Display Window views into a Discover 3D 
session file, or save edits to a currently open session. A 3D session file is a 3D 
equivalent of a MapInfo Professional Workspace file.
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File>Save Session As

Save currently open dataset and Display Window views into a Discover 3D 
session file.

File>Save View As

Save current Display Window contents into an image file for presentation 
purposes.

File>Save to Package

Save currently open dataset and Display Window views into a Discover 3D 
session file, and also save all currently open datasets into a designated folder. 
Packaging enables the easy transfer or sessions files and data between 
worksites or computers.

File>Print

Print the current Display Window to hardcopy or PDF format.

File>Page Setup

Define page size for hardcopy prints and page size for the page layout mode.

File>Modify Dataset Field and Survey Properties

Modify the field properties for all open drillhole datasets or modify the desurvey 
methods for downhole trace construction. Survey method to choose from include; 
Segments, Akima Spline, Bezier Spline, Back Calculation and Minimum 
Curvature. For changes to take effect, any existing drillhole branch containing the 
drillhole project must be deleted first and a new branch opened.

Note Sessions created in Discover 3D are not backward compatible. For example, a 
session created in Discover 3D 2012 will not open in Discover 3D 6.0.

Note A packaged session file is equivalent to packing a workspace in MapInfo 
Professional using the tool located under Discover>Table Utilities>Save 
Tables and Workspace.
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File>Delete User Defined Projections

Delete user-selected projections for individual files that have previously been 
opened in Discover3D. You can also clear the list of most recently used (selected) 
projections.

File>Exit

Exit Discover 3D application.

View Menu

View>Send to MapInfo

Export the current 3D Display Window to MapInfo Professional.
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View>Fit to Page

Restore 3D Display Window size in page layout mode to fit the page.

View>Normal

Display 3D Display Window in normal mode for navigating, digitising and 
analysis.

View>Page Layout

Display 3D Display Window in page layout mode for hardcopy printouts and 
export.

View>Actual Size

Display the 3D Display Window in page layout mode at the actual page on 
screen.

View>Full Screen

Display the 3D Display Window in full screen mode.

View>3D Stereo

Open the 3D Stereo wizard.

View>Save Default Map Settings

Save modified properties for the 3D Map and Axis Workspace Tree items, to 
load for subsequent Discover 3D sessions.

View>Reset Default Map Settings

Restore factory defaults for the 3D Map and Axis Workspace Tree items.

View>Toolbars

Display or hide Discover 3D toolbars.

View>Toolbars>Main

Display or hide main toolbar.

View>Toolbars>Data Objects

Display or hide data objects toolbar.
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View>Toolbars>Zoom Controls

Display or hide zoom controls toolbar.

View>Toolbars>Cursor Plane

Display or hide cursor plane toolbar.

View>Toolbars>Features

Display or hide features toolbar.

View>Toolbars>Feature Editing

Display or hide feature editing toolbar.

View>Toolbars>Reset Arrangement

Restore toolbar and window placement to factory settings.

View>Toolbars>Save Arrangement

Save toolbar and window placement, to load for subsequent Discover 3D 
sessions.

View>Toolbars>Restore Arrangement

Restore toolbar and information window placement to last saved arrangement 
settings.

View>Appearance

Select skin to display Discover 3D, settings include; Office 2000, Office XP, Office 
2003, Windows XP, Office 2007.

View>Workspace

Display or hide Workspace Tree window.

View>Data Window

Display or hide Data Window.

View>Explorer Window

Display or hide Explorer Window.
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View>Feature Data Window

Display or hide Feature Data Window.

View>Status Bar

Display or hide Status Bar.

Display Menu

Discover 3D allows various external objects to be added to an existing 3D 
Display Window.

Display>Points

Add a Points display object to the Workspace Tree to display and annotate 3D 
point data.

Display>Directional Vectors

Add a Directional Vector object to the Workspace Tree to display and annotate 
3D directional vector data. Directional vector data can typically be sourced from 
a drillhole or survey dataset, which contains a directional magnetic component.
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Display>Lines

Add a Lines display object to the Workspace Tree to display and annotate 3D 
line data.

Display>Drillholes

Add a Drillhole display object to the Workspace Tree to display and annotate 3D 
drillhole data.

Display>Trench

Add a Trench display object to the Workspace Tree to display.

Display>Located Image

Add a georeferenced Image object (*.egb) to the Workspace Tree to display and 
annotate a georeferenced image. An example of a located image is an aerial 
photograph draped over a terrain grid

Display>3D Vector

Add a 3D vector layer to the Workspace Tree to display and annotate 3D vector 
data. 3D vector datasets can range from a 3D ore-body model to a contour 
dataset.

Display>2D Vector

Add a 2D vector layer to the Workspace Tree to display and annotate 2D vector 
data.

Display>Surface

Add a Surface layer to the Workspace Tree to display and annotate 3D surface 
data, such as a topographic surface.

Display>Voxel Model

Add a Voxel Model layer to the Workspace Tree to display and annotate 3D voxel 
data, such as ore block model derived from modelling packages.

Display>Axis

Add additional Axis layer to the Workspace Tree.

The Axis Properties dialog controls all aspects of the displayed axes. Manual 
and automatic options are available for:
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• Axis origins (as related to axis locations) and styles.

• Axis extents and bounding box settings

• Axis tick display and intervals

• Axis title and tick labelling

Display>Sky Map

Add a Sky Map image layer to the Workspace Tree to display a photo-realistic 
sky view backdrop to your 3D environment. This can be particularly valuable for 
producing impressive image/video output.

Display>Floating Colour Bar

Displays a colour bar (or legend) for any open drillhole project, grid surface or 
voxel model. 

Features Menu

Features are point, line, polygon or surface objects imported or created in the 3D 
environment which represent various entities such as geological or ore zone 
boundaries or structural interpretations.
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Features>Open

Open 3D Feature database file (*.fdb).

Features>Create

Create a 3D Feature database file (*.fdb).

Features>Modify

Modify an existing Feature database name or field structure.

Features>Import

Import Vector or grid files into a Feature database.
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Features>Export

Export objects from a Feature database into numerous vector formats.

Features>Close

Close selected Feature database.

Features>Create Query

Select objects from a Feature database by attribute query.

Features>Edit

Numerous editing tool for Feature Objects.

Features>Edit>Combine/Union

Combines or fuses multiple selected features into a single feature; the original 
geometries of the features are lost.

Features>Edit>Intersect

Outputs the intersection of any selected features (except points).

Features>Edit>Consolidate

Recombines a selected multi-part feature object.

Features>Edit>Triangulate

Primarily used to convert selected polygons into triangulated surfaces (3D 
polygon mesh or TINs). Can also be used to convert any object type into a 
Surface (TIN), such as a elevation point cloud or contours.

Features>Edit>Aggregate

Combines multiple selected features into one feature, but preserves the spatial 
geometry of each feature.

Features>Edit>Disaggregate

Ungroups or explodes aggregated features into individual features. Also detects 
any disconnected parts of a feature (created using the Break tool) and creates 
individual feature objects for each part.
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Features>Edit>Resize

Resize selected Feature Objects by scale factor.

Features>Edit>Delete

Delete selected Feature Object.

Features>Edit>Cut

Create new feature by cutting the first selected feature along intersections with 
other selected features. Cut can be used for any of the following operations.

Selected objects in the same plane:

• Cut (or remove) part of a polygon feature where it overlaps other polygon 
feature(s).

• Cut a polygon feature along the intersection with other polyline feature(s).

Selected objects in different planes:

• Cut a polygon feature along intersections with other polygon feature(s).

• Cut a feature surface along intersections with other feature surface(s).

Features>Edit>Copy

Copy selected Feature Object onto clipboard.

Features>Edit>Paste

Paste selected Feature Object from clipboard into Feature database.

Features>Feature Options

Define default options for the behaviour and appearance of Feature databases.

Features>Save Cosmetic Features

Save digitized objects from the Cosmetic Feature database into a new or existing 
Feature database.

Features>Clear Cosmetic Features

Clear digitized objects from the Cosmetic Feature database.
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Tools Menu

Tools>Options

Display options for Discover 3D defaults.

Tools>Grid Flipper

Open Grid Flipper to quickly toggle between grids surfaces with a single surface 
group.

Tools>Georeferenced Image Export

Open Georeferenced Image Exporter to capture and display 3D image renders 
from the Cursor Plane or Drillhole section.

Tools>3D View Manager

Open 3D View Manager to save and restore 3D image view points.

Tools>Clip 3D Points to Vector Volume

Clip and select point objects from a Feature Database or points dataset using a 
vector volume in a Feature database or 3D Vector file.

Tools>NotePad

Open Windows Notepad.
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Tools>Windows Calculator

Open Windows Calculator.

Tools>LookUp Table Editor

Open Colour Table Editor to create and modify lookup colour schemes for surface 
or drillhole rendering.

Tools>Legend Editor

Open Legend Editor to create and modify drillhole legend pattern and colour 
schemes.

Tools>TubeShape Manager

Open Tube Shape Manager to modify 3D data line styles.

Grids Menu

Grids>Voxel Manager

Open Voxel Manager to load, import, save and convert grids.

Grids>Voxel Display Assistant

Open Voxel Display Assistant to help display a voxel model thresholded, clipped 
or with an isosurface applied.
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Grids>Voxel Utilities

A powerful range of utilities for advanced vector/voxel analytics, voxel resampling 
and merging and clipping voxels to vector surfaces/volumes. 

Grids>Voxel Gridding

Open Voxel Gridding to create 2D (Planar) and 3D (Block Model) grids.

Grids>Voxel Filter

Open Voxel Filtering to apply filters to simply grids.

Grids>Voxel Calculator

Open Voxel Calculator to modify or process a grid.

Grids>Surface Gridding

Open Interactive Gridding to create a 3D surface grid.

Utilities Menu

Utilities>Fly Through Wizard

Open Fly Through Wizard to create 3D animations and movies.
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Utilities>3D Solid Generator

Open 3D Solid Generator tool to wireframe models and calculate the volume of 
generated solids.

Utilities>Topology Checker

Open Topology Checker tool to analyse and correct the integrity of 3D vector 
models.

Utilities>Transform Vector File

Open the Transform Vector File tool to convert vector formats along with 
transforms for scaling, offset and rotation.

Utilities>Combine DXFs

Open Combine DXF tool to combine two or more DXF files.

Utilities>Batch DXF Transform

Multiple external DXF files can be positioned, scaled and rotated using a control 
table, and combined into one output file.

Utilities>Extrusion Wizard

Open Extrusion Wizard to extrude models.

Utilities>3D Point Symbols

Open 3D Point Symbols tool to create 3D point objects.

Utilities>Drillhole Planner

Open Drillhole Planner tool to plan and position new drillholes directly in 3D.

Help Menu
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Help>Help Topics

View Discover 3D interactive help topics.

Help>Tutorials

Open Discover 3D tutorial documentation (PDF format).

Help>User Guide

Open Discover 3D User Guide documentation (PDF format).

Discover 3D Toolbars

Discover 3D toolbars are fully customisable and can be displayed in either docked 
or floating mode.

• Main Toolbar: commonly used 3D tools. 

• Data Objects Toolbar: display 3D objects.

• Zoom Controls Toolbar: 3D navigational tools.

• Cursor Plane Toolbar: tools for digitising and clipping objects.

• Features Toolbar:digitising and selecting in Feature Databases.

• Feature Editing Toolbar: advanced Feature Database object editing.

For information on arranging and customising toolbars, see:

• Showing and Hiding Toolbars

• Docking and Undocking Toolbars and Windows

• Customising Toolbars and Window Views

• Customizing Toolbars

Note A brief description of the toolbar tool is displayed when hovering the mouse over 
a tool button, Alternatively, a description of the tool is displayed in the Status 
Bar.
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Showing and Hiding Toolbars

To display or hide a toolbar navigate to View>Toolbars and select the toolbar to 
either display or hide.

Display toolbars from Main menu.

Alternatively, right-click in the Main menu bar to display the toolbar shortcut 
menu.
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Main Toolbar

Open Session - Open a Discover 3D Session file (*.egs). A session file is an 
equivalent 3D version of MapInfo Workspace.

Save Session - Save a session file (*.egs). A session file is an equivalent 3D 
version of MapInfo Workspace which enables Display Window and object 
states to be preserved for future reference.

Undo/Redo - Undo or redo the last change committed in the 3D Display 
Window.

Show 3D Properties - Display Properties dialogs for all object, axis and 3D 
Map items in the Workspace Tree.

Send to MapInfo - Export the current view displayed in the 3D Display Window 
as an image for presentation or analytical purposes into MapInfo Professional.

Background colour - Modify the default background colour in the 3D Display 
Window.

Open Discover drillholes - Open Discover drillhole data from MapInfo 
Professional TAB files.

Open Geosoft drillholes - Open Geosoft WHOLEPLOT drillhole Database.

Full Screen - Display the 3D Window in full screen mode.

3D Stereo View - Display 3D window in 3D stereo mode on HDMI enabled 
monitor.

Normal View/Page Layout - Toggle the Display Window between Normal and 
Page Layout views. The Normal view is used to perform most navigational, 
editing analytical operating in 3D. The Page Layout view is used for 
presentation of hardcopy outputs, however, standard navigational, editing 
analytical operations can be performed in this mode.
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Data Objects Toolbar

Distance/Bearing Measuring Tool - The ruler tool enables the measurement of 
distance, bearing, inclination and total distance for objects on the Cursor plane. 
Measurement of can be performed from one point to another by a single left 
mouse button click, or can be cumulative by left mouse button clicking along 
segments continuously. If the left mouse button is continuously held down whilst 
the cursor is moved, the measurements are read from the path of the mouse 
cursor. Enabling Snapping by pressing S on the keyboard can assist in 
measuring between vertices.

Workspace Tree - Display or hide the Workspace Tree.

Data Window - Display or hide the Data Window which interactively displays 
data from the following object types; Drillholes, Lines, Directional Vectors and 
Points.

Explorer Window - Display or hide the Explorer Window which is used to 
navigate and locate data to open in the 3D Display Window.

Feature Data Window - Display or hide the Feature Data Window which 
displays interactive information contained in a Feature Database.

Display Points - Add a Points display object to the Workspace Tree to display 
and annotate 3D point data.

Display Directional Vectors - Add a Directional Vector object to the 
Workspace Tree to display and annotate 3D directional vector data. Directional 
vector data can typically be sourced from a drillhole or survey dataset, which 
contains a directional magnetic component.

Display Lines - Add a Lines display object to the Workspace Tree to display 
and annotate 3D line data.

Display Drillholes - Add a Drillhole display object to the Workspace Tree to 
display and annotate 3D drillhole data.

Display Trenches - Add a Trench display object to the Workspace Tree to 
display and annotate 3D trench data.
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Zoom Controls Toolbar

The Zoom Controls Toolbar controls navigation, zooming and custom view 
management in the 3D Display Window. 

Display Located Image - Add a georeferenced Image object (*.egb) to the 
Workspace Tree to display and annotate a georeferenced image. An example 
of a located image is an aerial photograph draped over a terrain grid.

Display 3D Vectors - Add a 3D vector layer to the Workspace Tree to display 
and annotate 3D vector data. 3D vector datasets can range from a 3D ore-body 
model to a contour dataset. 

Display Surface - Add a Surface layer to the Workspace Tree to display and 
annotate 3D surface data, such as a topographic surface.

Display Voxel Model - Add a Voxel Model layer to the Workspace Tree to 
display and annotate 3D voxel data, such as ore block model derived from 
modelling packages.

Display Floating Colour Bar - Add a Floating Colour Bar or data legend which 
can be link to the following object types; surface, voxel or drillhole.

Select/Navigate - Select/Navigate is used as the primary control for selecting 
and navigating in the 3D environment. Holding the left mouse button down and 
moving the mouse cursor will pivot the view are the central display axes. 

When a Workspace Tree object select option is enabled the Select/Navigate 
control can be used to display attribute information in the Information 
Windows.

3D Navigation - The 3D Navigation control is primarily used to navigate around 
the 3D Display Window. Holding the left mouse button down and moving the 
mouse cursor will pivot the view are the central display axes. Holding the right 
mouse button down and moving the mouse cursor will either zoom in or out from 
the central display axis. Refer to Navigating in 3D for more detailed operations.
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• Perspective – Objects that are further away from the viewer are scaled so 
they appear smaller than closer objects. Perspective view provides more 
information about depth and is often easier to work with because it 
simulates the real life view.

• Orthographic – A form of parallel projection (also known as an isometric 
or axonometric projection) where identically sized objects are displayed 
with the same size regardless of the distance they are positioned from the 
viewer. Orthographic view is best used when it is important to be able to 
judge proportion and size, such as, when digitizing or drawing features, 
and is particularly useful for measuring distances.

Zoom in, Zoom out, Pan - The zoom controls either zoom in or out in the 3D 
Display Window, holding the Shift key will perform the opposite zoom function.  
With either the Zoom in or Zoom out control activated, when the left mouse 
button is held down and the mouse cursor is dragged, the Display Window will 
zoom in or out to the specified zoom field. The Pan control enables panning in 
the Display Window.

Reset View - Reset 3D View restores the 3D Display Window so objects are 
centred and displayed within the window.

View Manager - The 3D View Manager allows the user to save custom views 
within the 3D Display Window. See 3D View Manager Tool.

Change View Direction - Rotate view direction of the 3D Display Window to the 
specified direction (North, South, East, West, Up and Down). For example, 
selecting Look North orientates the view to be looking to the north.

Fit to Page - Only available in Page Layout view; automatically resizes the 
page to fit to the extents of the view.

Perspective/Orthographic - 3D display modes
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3D View Manager Tool

3D View Manager dialog

Add new 3D view to the 3D View Manager.

Delete the selected 3D view from the 3D View Manager.

Display the selected 3D view from the 3D View Manager.

Display the selected 3D view from the 3D View Manager and restore the 3D 
data window to the select view extents and dimensions.

Rename the selected 3D view from the 3D View Manager.
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Cursor Plane Toolbar

The Cursor plane toolbar contains tools required for the operation of the Cursor 
plane. The Cursor plane operates as a drawing plane upon which Feature 
Objects are digitized in the 3D environment. The Cursor plane can also be used 
as a clipping plane to hide or obscure object data. 

Show Cursor plane - The Show Cursor plane option displays or hides the 
Cursor plane in preparation for digitizing or clipping operations.

Lock Cursor plane - Disables all Cursor plane movement controlled by the 
keyboard shortcuts, preventing the Cursor plane from being accidentally moved 
during digitization. This feature locks the Cursor plane origin X, Y and Z 
coordinate.

Cursor plane orientation - Toggles the Cursor plane orientation around the X, 
Y and Z axes.

Bond - Bonds the Cursor plane to a selected georeferenced image or dataset 
(e.g. drillholes) in the Workspace Tree. This feature is useful for aligning the 
Cursor plane with images georeferenced in 3D for digitizing. It is also auto-
enabled when selecting data in Spreadsheet mode—for interrogating drillholes 
dynamically, for example (see Browse tool in Workspace Tree).

Plane clipping - Plane clipping hides all 3D data objects in front of the Cursor 
plane. This is useful when a slice view is required of the 3D datasets when 
digitizing. 

Defined clipping - Enables the supplementary clipping of a 3D dataset as 
defined by the current position of the Cursor plane. This option enables the 
current position of the Cursor plane to temporarily clip the 3D dataset whilst 
being able to move the Cursor plane to another position. This is useful when 
digitizing through a complex geometric object, or to reveal obscured features.

Perpendicular - This will orientate the view direction perpendicular to the 
Cursor plane. This is very useful when digitizing interpretations on adjacent 
sections, particular when used in tandem with the Orthographic View mode 
and Envelope or Slice clipping mode.
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Features Toolbar

The Features toolbar provides numerous controls for the creation and selection 
of Feature Objects on the Cursor plane. This enables the user to digitize points, 
polylines and polygons directly into the 3D environment.

A Feature database must be editable for the Feature toolbar to be enabled.

Example objects include geological interpretations, ore body outlines, faults and 
alteration zones.

Shrink, Enlarge and Fit Cursor plane - The Shrink, Enlarge and Fit Cursor 
plane controls resize the Focus Box. The Focus Box is the bounding extents of 
the Cursor plane.

Cursor Plane Properties - Global properties for appearance and Cursor plane 
behaviour can be modified on the Cursor Plane Properties dialog.

Confirm feature - Option to display a dialog after each feature object is created 
to enable input of attribute data. 

Polygonal Select - Create a selection region to select all Feature Objects that 
intersect or lie within the region. This selection region is independent of the 
Cursor Plane. It is drawn in the screen plane and will select all objects below it. 
The selected object attributes are listed in the Data Window.

The Select/Navigate control can be used to select individual feature objects. 
When holding down the keyboard CTRL key multiple object selections can be 
made.

Create New Point Feature - Create a point object by clicking with left mouse 
button at the desired location on the Cursor plane.

Create New Line Feature - Create a polyline on the Cursor plane by clicking the 
left mouse button to create line inflections. Holding down the left mouse button 
and moving the mouse will create sinuous polyline. Double click to terminate the 
polyline creation.

Shrink

Fit

Enlarge
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Create New Polygon Feature - Create a polygon on the Cursor plane by 
clicking the left mouse button to create line inflections. Holding down the left 
mouse button and moving the mouse will create sinuous polygon boundary. 
Double click to terminate the polygon creation.

Feature Information - Display information for a Feature Object. Click the left 
mouse button to display attribute information in the Data Window.

Snapping - Snapping enables the precise interrogation, modification or 
digitization of points, polylines or polygons on a feature object or drillhole trace. 
Snapping will ensure the exact point, drillhole or surface is selected.

To assist snapping an audible beep is generated, the duration of the beep can 
be adjusted.

When snapping is enabled a circle will appear in the centre of the Cursor plane 
crosshairs, the radius of the circle can be controlled by the Pixel Tolerance 
value.

The Snap to ... options allow precise control on what is targeted:

• Snap to Points - Snap to points or vertices on any feature  object

• Snap to Drillholes/Lines - Snap to drillhole traces. Also snap to internal 
and external edges of feature polylines, polygons, surfaces and 
polyhedrons solids.

• Snap to Surfaces - Snap to the surfaces (triangulated faces) of feature 
polygon, surface or 3D solid polyhedrons.



104 Encom Discover 3D User Guide

Feature Editing Toolbar

The Feature Editing toolbar includes all tools required for advanced editing for 
Feature Objects.

Edit - Modify the selected Feature Object on the Cursor plane. The Edit control 
displays the object vertices; individual nodes can be selected and moved or 
deleted by pressing the keyboard DEL key. Entire objects can be moved by 
holding the SHIFT keyboard key and moving to the intended location on the 
Cursor plane.

Elasticity - When moving a node on a feature object, the Elasticity option 
enables the automatic movement of adjacent object nodes. The area or region of 
nodes to be moved elastically is defined with the Radius X control. To define a 
variable region of elastic movement, uncheck the Isotropic option and set the Y 
and Z radii as desired. The type or shape of elastic movement can be set as 
Gaussian, Square, Triangle, Sine and Inverse Distance (Sine is a good starting 
point).

Add Mode - Add vertex to a polyline, polygon, surface or solid 3D Feature 
Object. Adding a vertex will allow the shape to be modified; after adding a vertex 
left mouse click and hold on the selected vertex to move.
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Delete Mode - Delete vertex from a polyline, polygon, surface or solid 3D 
Feature Object. Deleting a vertex will allow the shape to be modified; to delete, 
select the vertex and press DEL on the keyboard.

Break Mode - Split polyline or surface Feature Objects.

Polylines are split at connecting vertices.

Surface feature objects are split along connected internal edges.

Combine - Combines or fuses multiple selected features into a single feature; 
the original geometries of the features are lost.

Intersect - Outputs the intersection of any selected features (except points).

Cut - Create new feature by cutting the first selected feature along intersections 
with other selected features. Cut can be used for any of the following operations.

Selected objects in the same plane:

• Cut (or remove) part of a polygon feature where it overlaps other polygon 
feature(s).

• Cut a polygon feature along the intersection with other polyline feature(s).

Selected objects in different planes:

• Cut a polygon feature along intersections with other polygon feature(s).

• Cut a feature surface along intersections with other feature surface(s).

Triangulate - Primarily used to convert selected polygons into triangulated 
surfaces. It can also be used for re-triangulating a modified feature surface.

Aggregate - Combines multiple selected features into one feature, but 
preserves the spatial geometry of each feature.

Disaggregate - Ungroups or explodes aggregated features into individual 
features. Also detects any disconnected parts of a feature (created using the 
Break tool) and creates individual feature objects for each part.
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Discover 3D Session Files

A 3D session file is the 3D equivalent of a MapInfo Professional Workspace file. 
Its is stored as a binary .EGS file that is used to save and restore a Discover 3D 
session. Session files store the file path to all open drillhole, point and line data 
selections, surface grids, 3D vector files, georeferenced bitmap images and 
associated properties such as downhole attributes, colour tables, labels, 
translucency, 3D Axes, etc. 

• Open session files using either:

• File>Open Session 

• Drag-and-drop the .EGS file into the 3D window

• Create session files with the File>Save Session As tool

• Save (and update) session files with the File>Save Session

• A default backup 3D session is automatically saved at regular intervals, as 
specified  by the Autosave Session option under the 
Tools>Options>View tab (5 minutes by default). This backup session 
can be reopened at any time via the File>Restore Autosaved Session 
menu option. If Discover 3D closes unexpected, upon restarting you will 
be prompted to open the last autosaved session.

The autosaved session file is called Discover 3D_auto_save_tmp and is 
saved under C:\Users\username\AppData\Local\Temp (Windows 7 
and 8) or C:\Documents and Settings\username\Local 
Settings\Temp (Windows XP)

• Export session files and all contained datasets to another Discover 3D 
user with the File>Save to Package menu option. This is similar in 
functionality to the Discover Save Tables and Workspace option; all 
datasets in the session will be copied into the specified package directory 
(creating a new empty directory is recommended) as well as the .EGS 
session file, and the dataset file paths are set to relative. This directory 
can then by sent to another user (e.g. zip up and email the directory) and 
the contained session file opened on another computer

For more information, see the Discover 3D File Menu.

Note Sessions created in Discover 3D are not backwards compatible. For example a 
session created in Discover 3D 2012 will not open in Discover 3D 6.0.
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Customising the 3D Window

Discover 3D can be customised to suit the requirements of each individual to 
improve the user experience.

• Docking and Undocking Toolbars and Windows

• Auto-hide Windows

• Customising Toolbars and Window Views

Other customisations can be found in Customising Discover 3D.

Docking and Undocking Toolbars and Windows

The toolbars are dockable and can be freely dragged around the Discover 3D 
application and displayed as either docked or floating.

The Information Windows and Workspace Tree can be displayed as docked or 
floating windows. To dock these windows around the 3D window click and hold 
down the left mouse button in the title bar region for any of the windows. When 
the window is moved a series of docking indicators will appear in the 3D window. 
To dock the window, simply hover the mouse over one of the docking indicators 
and release the mouse button.

Alternatively, the window can be dragged and placed into an appropriate location 
as a floating window. The positions of these windows will be save upon exiting 
Discover 3D.
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Discover 3D with window docking indicators.

Auto-hide Windows

• Located on the Information Windows and Workspace Tree is an Auto-
hide control. Instead of displaying the windows as either floating or 
docked the windows can be temporarily hidden and displayed when the 
mouse cursor is hovered over. To enable or disable the auto-hide function, 
click the Auto-hide control (pincushion).
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Customising Toolbars and Window Views

To control the display of Toolbars and Information 
Windows, right click in the toolbar region to display a list 
of items. Click the item to display or hide.

Click Customize on this shortcut menu to customize 
individual menus and toolbars (see Customizing 
Toolbars).

Located on the right of every toolbar is a dropdown 
control which enables the customisation of each 
toolbar. Left mouse click to access this option and 
select tools to display or hide.

Workspace Tree

The Workspace Tree is the primary control of data used in Discover 3D. The 
Workspace Tree operates by listing all objects shown in a display. These entities 
are listed as a hierarchy with various tree branches.

Workspace Tree with data objects

Each branch is subordinate to a higher branch, such that control properties of a 
higher branch overrule the same properties of a lower branch. The Workspace 
Tree grows incrementally as various objects are added or modified.

To the right of many branches are several selectable controls:

Edit – Enables objects to be added or modified in a selected Digitizing and 
Managing 3D Features. Only one Feature Database can be editable at a time. 
Making a feature database editable will automatically turn on the Cursor Plane 
for object digitization.
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Each object branch in the Workspace Tree has a visibility check box. To turn off 
the visibility of an object branch in the 3D display window uncheck the visibility 
box. Turning off the visibility for an object branch will also turn off the visibility of 
any sub-branches.

To the left of each subordinate branch is a  or  control. These controls indicate 
lower levels exist for that branch. By clicking on these boxes you can expand or 
collapse the object contents.

For more information, see:

• Working with the Workspace Tree

• Workspace Branch Properties

• 3D Map Properties

Select – Enables objects within the selected dataset to be selected for the 
purpose of querying information. For example information can be displayed for 
individual drillhole samples, vector linework, points or Feature Databases. 

Browse – Attribute information for a selectable datasets can be dynamically 
viewed in the Data Window. Objects types which are browsable include 
drillholes, lines, directional vectors and points. The Cursor Plane is automatically 
enabled in this mode and bonded to the Browsable dataset (see Bond tool on 
Cursor Plane Toolbar).

Zoom Extents – Zoom the 3D view to the extents of the selected dataset.

Zoom All – Zoom the 3D view to the extents of all data in the 3D Data Window.

Projection Information – View the embedded projection of the branch's data 
file. For data files that do not support embedded projections (files that do not 
have an associated TAB file or EGB 3D image header), you can define a new 
projection for the objects coordinates in the branch.

There are three states of the Projection 

•  Projection defined – it matches the 3D Map's projection

•  Projection defined – does not match the 3D Map's projection. 
Reprojection on the fly is active.

•  Projection not defined – the branch is assumed to be in the same 
projection as the map window. Click to define a projection.
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Working with the Workspace Tree

Selecting a tree branch and clicking the right mouse button displays a shortcut 
menu that has available operations applicable to that object type.

A complete list of all shortcut menu items for each branch is provided below. 

Right click To display shortcut menu
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Right click To display shortcut menu
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Right click To display shortcut menu
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Workspace Branch Properties

The workspace branch property dialogs controls many of the options settings 
required for the workspace objects. Several methods are provided to display the 
properties of objects in the Workspace Tree, including:

In most cases, the Properties dialog has tabs displayed at the top. Each tab 
controls a separate aspect of the item selected.

Example Properties dialog

If the Auto Apply option is disabled, changes to properties are not made until the 
Apply button is clicked. This is a useful feature that enables changes in various 
tabs of a Properties dialog to be setup before they are applied (particularly for 
large datasets where redraw times may be significant).

• Right click the object in the Workspace Tree.

• Double click the object in the Workspace Tree.

• Click the Show 3D Properties button on the Main toolbar and select the 
object type.
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If a mistake is made while entering changes, select the Restore button to return 
the control settings to their original state. In contrast, enabling the Auto Apply 
option will apply any changes immediately.  Property changes can also be applied 
by clicking the OK button, which will also close the dialog. 

3D Map Properties

The options specified in the 3D Map Properties dialog control the title, 
appearance, lighting and scaling of the 3D Display Window.

• Title Tab

• Appearance Tab

• Lighting Tab

• Scale Tab

Title Tab

3D Map Properties Title Tab dialog
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The Title tab of the 3D Map Properties dialog controls the placement, content 
and font of the map title displayed within the Page Layout mode. The 3D window 
mode is toggled from the View>Normal or View>Page Layout menus. This can 
be particularly useful when generating titled images from File>Save View As or 
when printing hard-copies.

The Coded Title String provides variable title string syntax which automatically 
inserts values from the 3D dataset. Select the variable from the list and press the 
Add button to add the syntax to the title. Alternatively, a title can be manually 
entered into the title box.

Appearance Tab

3D Map Properties Appearance Tab dialog

The Appearance tab of the 3D Map Properties dialog controls the border styles, 
colours and margins for 3D displays in the Page Layout mode along with 
numerous other general appearance settings.

Options for toggling the background colour of the 3D Display Window are 
available, along with the display option for a 3D bounding data box. The bounding 
box displays a minimum bounding rectangle around the 3D dataset.
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To smooth lines and edges of all objects in 3D, enable the anti-aliasing option. 
The Advanced button provides default colour options for vector objects in 3D.

Lighting Tab

3D Map Properties Lighting Tab dialog

The Lighting tab of the 3D Map Properties dialog controls the lighting displays 
for the 3D Display Window. Two light modes exist, Directional and Global 
Ambient.

Directional lighting enables a choice of three lighting modes. Directional light 
enables the casting of shadows and can give the 3D display the appearance of 
depth, and highlight variability in terrain.

Note The 3D window mode is toggled from the View>Normal or View>Page Layout 
menus.
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• Ambient: Select a colour for the general light or illumination of objects 
displayed in the 3D Display Window. For example, if white is selected the 
objects in 3D will appear very bright and illuminated; if black is selected 
objects in 3D will appear dark with a low brightness level, independent of 
the light direction.

• Diffuse: Select a colour which will be used to cast shadow effects on 
undulating objects or topography. Generally, shades of grey produce the 
best effects. Diffuse light gives the appearance of a unidirectional light 
source.

• Specular: Select a colour to be used for highlights in the 3D Display 
Window. Highlights are objects or surface facets perpendicular to the 
lighting direction.

The Light Position Angles control contains a dynamic ellipse to define the 
Horizontal and Vertical positions of the directional light. The light source 
direction can be modified by pressing and holding down the left mouse cursor 
over the red cross on the ellipse and moving to an appropriate position; or by 
manually adjusting the Horizontal and Vertical values.

The Fixed direction option will fix the light source direction as specified on the 
ellipse independent of the position of the 3D Display Window axes. If the option 
is not selected the light position is defined by the axes position in the 3D Display 
Window.

Global Ambient lighting enables one lighting mode, and refers to the general 
light conditions. Global ambient light doesn't allow the generation of shadows or 
highlights.

• Ambient: Select a colour for the general light or illumination of objects 
displayed in the 3D Display Window. For example if white is selected the 
objects in 3D will appear very bright and illuminated; if black is selected 
objects in 3D will appear dark with a low brightness level.
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Scale Tab

3D Map Properties Scale Tab dialog

The Scale tab of the 3D Map Properties dialog allows the X, Y and Z axes along 
with the 3D objects to be scaled independently along each axis. This can be 
achieved by manually entering a scale factor or by adjusting the slider bar.

The Scale Z to projection's XY units enables automatic scaling of the Z units 
(as listed in Assumed Z units) to the XY Units. The XY units are automatically 
set from the map's Projection, however there is an assumption for what the Z 
units are. In general, these are the same as the XY units, but for some projections, 
such as lat/lon (which is degree units), a guess is made. If the Assumed Z units 
are incorrect, do not enable this option. Instead manually scale the Z axis.

The Projection list defines the coordinate system shown for all coordinates and 
the map axis in the 3D Map window.

Note The scaling factors will apply to all datasets within the 3D data window. To scale 
a dataset independent of the global scaling, use the appropriate scale options 
within specified object property dialog.
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Projections in 3D

Discover3D supports coordinate systems defined by Mapinfo (TAB files) as well 
as ESRI .PRJ or Geosoft metadata.

The 3D window behaves similarly to Mapinfo Map windows. Once the first file is 
opened that has a known projection, the map window's coordinate system is set 
to this file's projection. All other files with known projections will be reprojected on-
the-fly to this coordinate system. File with no known projection (such as DXF) will 
be displayed with the raw coordinate and assumed to be in the same coordinate 
system as the map window.

For certain data types, such as drillholes, points, and lines data series, you cannot 
override or define a projection. The same is true with images (EGB file) and 
Feature database layers. But all other data types, such as voxels and vectors, can 
override the embedded projection. Or the projection can be defined if the 
embedded projection is unknown.

Note that overriding the projection via the workspace tree will not reproject the file. 
This only defines a coordinate system for the units. It is not recommended to do 
this unless you are sure there is erroneous projection metadata for the file.

If known, the parameters for a coordinate system will be displayed in a readable 
description—if the coordinate system is a known system. A list of known systems 
with their descriptive name and parameters are stored in the Encom.prj file.

Navigating in 3D

• 3D Navigation Modes

• 3D Navigation Controls

• Using the 3DConnexion SpaceNavigator™

• 3D Display Modes

Note Discover3D only supports the 2D coordinate system and does not recognise a 
vertical datum or Z shifts which may occur between different datums or 
ellipsoids. Only the X and Y coordinate will be reprojected.
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3D Navigation Modes

There are two navigation modes, which can be selected from the Zoom Controls 
toolbar:

3D Navigation Controls

To navigate in 3D, click the  3D Navigation button on the Zoom Controls 
toolbar.

All 3D navigation is orientated about the view point. The view point is the black 
cube at the intersection of the XYZ axis lines that appears when clicking in the 
Display Window.

3D Navigate—This is the primary navigation control and provides the most 
precise control in 3D. When selected, the 3D Navigation tool is displayed in the 
top-right corner of the Display Window. See 3D Navigation Controls for details.

Select/Navigate—Use this mode to create, edit and interrogate objects in the 
3D environment. When selected, position the cursor inside the Display Window, 
then hold the left mouse button down and drag the cursor to rotate pivot the view 
about the centre of the display. You can use the other controls on the Cursor 
Plane Toolbar (Zoom In, Zoom Out, Pan, Change View Direction, and such) in 
conjunction with the Select/Navigate tool.
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The 3D navigation view point

The 3D Navigation tool is displayed in the top-right corner of the Display Window. 
This tool fades when there is no movement after approximately 5 seconds. To 
redisplay, move the cursor into the top-right corner. This tool controls the eye 
position and the view point (the rotation point). Similar (and some additional) 
functions can also be performed by combinations of mouse button and keyboard 
keys, as described below.

The 3D navigation tool is displayed in 3D Navigation mode.

The X, Y and Z coordinates of the view point and the bearing and inclination of 
the view direction (from the eye position) are displayed in the Status Bar.
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Movement Using the 
3D Navigation Tool

Using the 
Mouse/Keyboard

Zoom
in and out

Zoom: Zooms in and out from 
the view point.

Zoom: Hold down the right 
mouse button with the cursor 
positioned above (to zoom 
in) or below (to zoom out) the 
view point. Alternatively, roll 
the mouse wheel.

Rotate 
around view 

point

Z-rotate: Rotates around the 
Z-axis.

Free rotate around view 
point: Hold down the left 
mouse button. The view will 
rotate freely as if you are 
pressing on a basketball: 
whichever side of the view 
point you click, the view will 
rotate away in that direction.

Rotate 
around eye 

point

Free rotate around eye 
point: Hold down the CTRL 
key and the left mouse 
button. The view rotates in 
the direction of the cursor 
about the current eye 
position. 
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The Reset 3D View, View Manager and Change View Direction can also be 
used when in 3D Navigation mode (see Zoom Controls Toolbar).

Vertical
pan

Z-pan: Moves the view point 
vertically (in the Z-direction)

Z-pan: Hold down the SHIFT 
key and the left mouse 
button. The view point moves 
along the vertical axis in the 
screen plane in the direction 
of the cursor.

Horizontal
pan

XY-pan: Moves the view point 
horizontally (in the XY-plane)

XY-pan: Hold down both the 
left and right buttons. The 
view point moves within the 
XY-plane in the direction of 
the cursor.

Speed/
sensitivity

Sensitivity: Use the slider 
control to adjust the speed of 
rotation, zooming, and 
movement. Clicking the bar 
selects that setting. Clicking 
the snail or rabbit changes the 
setting by one increment in 
either direction.

Speed: Speed is controlled 
by the distance of the cursor 
location from the view point: 
the further this distance, the 
faster the movement.

Sensitivity: The numeric 
keys (1-0) can be used for 
more precise speed control: 
1 is the slowest speed and 9 
and 0 are fastest.

Refer to 3D Cursor Keyboard 
Shortcuts for a complete list 
of mouse/keyboard controls.

Movement Using the 
3D Navigation Tool

Using the 
Mouse/Keyboard
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Using the 3DConnexion SpaceNavigator™

Discover 3D Viewer supports navigation using the 3DConnexion 
SpaceNavigator™ device. With this device, both the eye position and view point 
can be moved simultaneously. This results in easy and intuitive “fly-though” style 
movement.

To use a SpaceNavigator device:

1. Install the 3D Connexion driver software, and upgrade to the latest 
version.

2. Connect the device via a USB port.

3. Start Discover 3D Viewer window. Select the Tools>Options menu 
option, and go to the View tab. Select the Enable 3D Connexion devices 
option.

4. Close and restart the 3D window.

The following SpaceNavigator™ controls are supported within Discover 3D 
Viewer:

Action Device Movement

Push/Pull Move eye and view 
points forwards and 
backwards.
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3D Display Modes

The 3D Display Window in Discover 3D can be configured to operate using 
several view modes. The following view modes are available:

• Normal View Mode

Slide Move eye and view 
points to the left and 
right.

Tip Rotate eye point 
downwards and 
upwards.

Spin Rotate eye point around 
static view point.

CTRL + Push/Pull Zoom in and out (move 
the eye point closer to 
and farther from the 
view point.

SHIFT + Spin Rotate the eye position

Reset LEFT Press the left button to 
reset the 3D view.

Settings RIGHT Press the right button to 
display the device 
settings

Action Device Movement
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• Page Layout Mode

• Full Screen Mode

• 3D Stereo Visualisation

Normal View Mode

View>Normal 

In normal mode, the 3D Display Window is maximised to fill the extents of the 
view area and provide optimal display of 3D objects. 

Page Layout Mode

View>Page Layout

Page Layout mode enables you to see how objects are positioned on a printed 
page. This view can be used to modify the size and positioning of the 3D frame 
border, page margins and colour legend objects prior to printing. The size and 
orientation of the default page is defined by the printer settings specified under 
the File>Page Setup option.

Full Screen Mode

Discover 3D can be switched into full screen mode, where the 3D Map window 
will display full screen on the monitor that the Discover 3D window is currently 
positioned on.

To switch to full screen mode:

• Select View>Full Screen or select the toolbar button.

In this mode, the toolbars, status bar and workspace tree will be hidden. 
However by default the menu bar will remain. To re-enable controls such as the 
workspace tree, while in full screen mode, right-click on the menu toolbar and 
select the option.

To enable the 3D Navigation mode and button pad, Right click in the fullscreen 
map window and select the option.
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To exit full screen mode:

• Locate the Close Full Screen floating toolbar button, or press ESC on the 
keyboard. 

Additional options for fullscreen mode are available from 
Tools>Options>Fullscreen.

3D Stereo Visualisation

Discover3D supports three methods of stereo visualisation:

• HDMI 3D

• Dual Projectors

• Anaglyph Mode

HDMI 3D

This method will output the 3D map window to an external display connected by 
HDMI. The HDMI standards later than 1.4a support side-by-side viewing of 3D 
stereo. HDMI 3D ready devices include TVs, home theatre projectors and PC 
monitors. These generally are provided with Active shutter glass.

To enable 3D stereo on an external HDMI monitor:

1. Connect a HDMI 3D ready device to your computer, and extend the 
desktop to this.

2. Select View>3D Stereo or right click on the 3D Map branch in the 
workspace tree, and select Stereo View.

3. In the Stereo Display dialog select the HDMI 3D mode.

Discover 3D is capable of displaying full colour 3D stereo projection systems to 
create a semi immersive 3D visualization environment. The use of full colour 3D 
stereo visualisation is quickly becoming the preferred way for geoscientists to 
communicate and collaborate with each other. It allows the user to analyses and 
detect very subtle geometric relationships that are often overlooked in 
conventional 3D views. It is also a powerful presentation tool to display fly-
through animations.

Note Do not duplicate or mirror the desktop to the 3D display.
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4. Select the 3D ready HDMI device in the 3D Display list.

5. Click OK.

6. The 3D Map will be duplicated as a side-by-side 3D stereo pair on the 3D 
display.

7. On your devices remote control, enable the 3D Mode and select the 
corresponding side-by-side mode, and wear the device's 3D glasses. 
Consult the device's documentation for help on doing this.

8. On your primary monitor you will be able to navigate and adjust the 3D 
display. It will also open a Stereo Control dialog. This allows adjustment 
of the separation (depth of view) and convergence (focus) angles. Adjust 
these as necessary to achieve a good display.

Dual Projectors

This method outputs the stereo pair to twoseparate external display. These will 
be two projectors in a specialized 3D projection cage. The cage aligns the two 
projectors to overlay the output frames exactly. They generally also have 
polarized filters on the projectors, and use passive polarized glasses. This is 
similar to what is used in commercial movie cinemas.

To enable 3D stereo on an dual 3D projector system:

1. Connect the two devices device to your computer, and extend the desktop 
to these.

2. Select View>3D Stereo or right click on the 3D Map branch in the 
workspace tree, and select Stereo View.

3. In the Stereo Display dialog select the Dual Projector mode.

4. Select the two projectors in the two display lists.

5. Click OK.

6. The 3D Map will be duplicated as a side-by-side 3D stereo pair on the 
projectors. 

7. Wear the projector polarized glasses to view in 3D.

Note Do not duplicate or mirror the desktop to the 3D display.
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8. On your primary monitor you will be able to navigate and adjust the 3D 
display. It will also open a Stereo Control dialog. This allows adjustment 
of the separation (depth of view) and convergence (focus) angles. Adjust 
these as necessary to achieve a good display.

Anaglyph Mode

This mode creates a pair of composite red and blue images in the 3D Display 
Window, which are slightly offset from each other. The composite anaglyph view 
is then visualised through a pair of red-blue glasses, which filter out the red image 
in the red eye and the blue image in the blue eye. The main disadvantage of 
anaglyph mode is that it does not allow the image to be viewed in true colour.

Cursor Plane

The Cursor plane is a user controllable and customizable plane in the 3D view, 
which has two main functions:

Digitizing

The Cursor plane operates as a drawing plane upon which Feature Objects are 
digitized in the 3D environment. Making a Feature Dataset editable automatically 
enables the Cursor Plane. For example, geological boundaries could be digitized 
from cross sections and subsequently formed in a solid object using the 3D Solid 
Generator.

Clipping

The Cursor plane can be used as a clipping plane to hide or obscure object data. 
This can be useful in complex datasets where a mass of drillholes obscures the 
data of interest. Alternatively, only a user-specified envelope or slice of data about 
the plane can be displayed; this is very useful when digitizing along sections, 
ensuring that only data within the specified envelope used in the interpretation.

Note The Cursor Plane is not visible in Bond mode.
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Cursor plane (red outline) with bounding box (green box) and, 3D Cursor crosshairs (light 
red).

For more information on controlling and using the cursor plane, see:

• Controlling the Cursor Plane Display

• Controlling the Cursor Plane Position and Orientation

• Navigating on the Cursor Plane

• Changing Cursor Plane Properties

Controlling the Cursor Plane Display

The Cursor plane toolbar contains tools required for the operation of the Cursor 
plane. 

Press the Show Cursor Plane button to display the default Cursor Plane 
location surrounded by a bounding Focus Box.

Press the Cursor Plane Properties button to modify the appearance of the 
Cursor Plane. For more information, see Appearance section of the Cursor 
Plane Properties dialog.
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Controlling the Cursor Plane Position and Orientation

Press the Plane clipping button to hide all 3D data objects in front of the Cursor 
plane. This is useful when a slice view is required of the 3D datasets when 
digitizing. 

Press the Defined clipping button to enable the supplementary clipping of a 3D 
dataset as defined by the current position of the Cursor plane. This option 
enables the current position of the Cursor plane to temporarily clip the 3D 
dataset whilst being able to move the Cursor plane to another position. This is 
useful when digitizing through a complex geometric object, or to reveal obscured 
features.

Press the Bond button to bond the Cursor plane to a selected georeferenced 
image or dataset (e.g. drillholes) in the Workspace Tree. This feature is useful 
for aligning the Cursor plane with images georeferenced in 3D for digitizing. It is 
also auto-enabled when selecting data in Spreadsheet mode—for interrogating 
drillholes dynamically, for example (see Browse tool in Workspace Tree).

Press the Cursor Plane Properties button to modify the position and orientation 
of the Cursor Plane. For more information, see Plane section of the Cursor Plane 
Properties dialog.

Press the Lock Cursor plane button to disable all Cursor plane movement 
controlled by the keyboard shortcuts, preventing the Cursor plane from being 
accidentally moved during digitization. This feature locks the Cursor plane origin 
X, Y and Z coordinate.

Press the Cursor plane orientation button to toggle the Cursor plane 
orientation around the X, Y and Z axes.

Press the Perpendicular button to orientate the view direction perpendicular to 
the Cursor plane. This is very useful when digitizing interpretations on adjacent 
sections, particular when used in tandem with the Orthographic View mode and 
Envelope or Slice clipping mode.

Press the Shrink, Enlarge and Fit Cursor plane button to Shrink, Enlarge and 
Fit Cursor plane controls resize.Shrink

Fit

Enlarge
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Navigating on the Cursor Plane

3D navigation and selection on the Cursor plane can be achieved using the 
Select/Navigate control. When this control is enabled a set of crosshairs will 
appear on the Cursor plane, the crosshairs assist in the precise selection and 
digitisation on the Cursor plane. X, Y & Z coordinates for the crosshair position 
displayed are on the Status Bar.

The up and down keyboard arrow keys control the inclination of the Cursor 
plane. This can change the X, Y and Z coordinates of the plane, as the rotation is 
applied about the centre of the bounding box, not the current centre point of the 
plane.

The left and right keyboard arrow keys control the bearing of the Cursor plane. 
This can change the X, Y and Z coordinates of the plane, as the rotation is 
applied about the centre of the bounding box, not the current centre point of the 
plane.

The page up and page down keyboard keys move the Cursor plane laterally. 
The Cursor plane is kept parallel to but shifted left or right (up or down) from the 
current position, maintaining a fixed inclination and bearing. 

Up
Down

Left
Right

Pg Up
Pg Dn
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Changing Cursor Plane Properties

Cursor Plane Properties dialog.

The Cursor plane properties dialog is divided into two sections:

• Plane

• Appearance
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Plane

The 3D position of the Cursor plane can be set manually via the Origin, 
Inclination and Bearing options.

The cursor plane Step Distance option controls the distance it is shifted with each 
PAGE UP and PAGE DOWN key press. This is an excellent way to ensure feature 
object digitization occurs at a uniform spacing (e.g. 100m intervals).

The Clip option refines the operation of the Plane clipping tool. Clipping is 
dynamic: if the cursor is moved (e.g. dip and azimuth, or lateral movement), the 
clipping region will follow. 

Six clipping modes are available:

• None - No clipping is applied, replicates having the Plane clipping option 
disabled.

• Nearest - Hides all data in front of the Cursor plane, applies the clip 
dynamically when the Display Window is rotated.

• Positive - Hides all data in front of the Cursor plane from the current view 
point. Data clip is maintained even when rotating the Display Window.

• Negative - Hides all data behind the Cursor plane from the current view 
point. Data clip is maintained even when rotating the Display Window.

• Envelope - Displays data within a defined clip envelope from the Cursor 
plane. For example, setting a a +/-25 m envelope width will display a 50 m 
thick envelope (total) of data centred on the Cursor plane or 25 m either 
side of the Cursor plane..

• Slice - Displays data within a defined clip width behind the Cursor plane. 
For example, setting a 25m slice will display data up to 25m behind the 
Cursor plane.
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A skarn model (vector) and drillhole dataset before (left) and after application of a 40m wide 
clipping envelope centred on an inclined Cursor plane.

Dynamic clipping by using the Page Up/Down keys to shift the Cursor plane laterally whilst 
a clipping envelope is enabled.
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Appearance

The Appearance section provides a range of cosmetic controls for the Cursor 
plane, cross hair and focus box colouring, size, style and transparency.

The Grid option (highlighted in the above image) allows the user to visualise a 
continuous square grid across the cursor plane surface, with a line spacing as set 
next next to the Manual option (dialog below has 50 map units set). This can be 
a powerful aid when interpreting/digitising to help visualise distances/sizes.

Disabling the Align/Attach to a series by mouse click option prevents the 
Cursor plane bonding to an image. This is useful when digitizing if a background 
image is behind an intended feature node. 

The Lock Bearing and Inclination Control options are provided to prevent the 
user inadvertently altering these parameters via the keyboard arrows during 
feature digitization. When a lock is enabled, the appropriate buttons will have no 
effect until the lock is disabled.

The Keyboard Tips and Click Tips tabs under the Cursor Plane Properties 
dialog provide a listing a keyboard shortcuts and mouse button combinations for 
Cursor plane control and feature editing. Refer to 3D Cursor Keyboard Shortcuts 
for a complete list of shortcuts.
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Floating Colour Bar

The Floating Colour Bar button enables a Colour Scale to be created for any open 
drillhole project, grid surface or voxel model. This makes it easy for the user to 
see the corresponding value for a particular grid colour (eg. DEM or magnetic 
susceptibility) or the corresponding lithology for a particular colour pattern in a 
drillhole series. Floating Colour Bars can be viewed in both and are particularly 
useful in 3D hard copy or digital Output.

Once a Floating Colour Bar is created a corresponding branch is added to the 
Workspace Tree, with a Colour Legend sub-branch. A Floating Colour Bar can 
be deleted by highlighting this branch, and pressing the keyboard Delete key.

The Connection tab of the Colour Legend Properties dialog enables the 
selection of the source dataset, for example a drillhole project, voxel model or grid 
surface. Only one bolded dataset can be selected for each Floating Colour Bar. 
The remaining dialog tabs contain controls to apply and modify the Stretch (eg 
linear or non-linear), Appearance, Title, Divisions and Ticks of the colour axis.

The Title tab of the Colour Legend Properties dialog enables a Title to be added 
(via a user text string) and positioned for the entire Floating Colour Bar (note axis 
specific Title option in the Colour Legend Properties dialog).

Display>Floating Colour Bar – Add a Floating Colour Bar or data legend which 
can be link to surface, voxel or drillhole data types.

Activating the Floating Colour Bar button changes the cursor to the colour bar 
creation mode. This mode enables the position and size/shape of the Floating 
Colour Bar to be determined on the screen.

To modify the Floating Colour Bar single mouse click on the blue bounding box 
with the Select/Navigate tool. Click on a bounding box corner to resize the box 
or click and drag on a side wall of the bounding box to move the Floating Colour 
Bar to a new location.
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Example of a Floating Colour Bar linked to a drillhole project colour modulated by geology. 
The displayed colour legend contains an entry for each rock type.

Example of a Floating Colour Bar showing elevation values  linked to a DEM grid surface.
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Sky Map

The Sky Map option (on the Insert menu) allows you to add a photo-realistic sky 
view backdrop to your 3D environment. This can be particularly valuable for 
producing impressive image/video output.

Selecting the Sky Map option from the Insert menu will prompt the user to select 
from the available sky map images (located in the C:\Program 
Files\Encom\Common\SKYMAP directory). Each image can be previewed within 
the selection dialog. Press OK to display the selected image. A Sky Map branch 
will be added to the Workspace Tree: its visibility can be toggled, and it can be 
either reordered (eg multiple Sky Maps listed) or deleted by accessing the right-
click pop-up menu.

Example Sky Map to select for display.
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Example of SkyMap background in complex 3D cityscape view.
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7 Working with Raster Images in 3D
Bitmaps are simple images usually derived from a screen capture of a view or 
display. The view may be derived from Encom Discover or it may come from 
some other source, for example a scanned geological section or a scanned 
geophysical pseudosection such as IP or resistivity. 

If an image is to be used in a three dimensional display in Discover 3D, the image 
is required to be accompanied by an Encom Georeferenced Bitmap (EGB) 
Format file . This small ASCII file defines the image source file by name, its type 
and its corner locations. The bitmaps formats available for display include BMP, 
PNG, JPG, TIFF, GIF and Windows Metafiles (.WMF).

A number of methods are available to create and display georeferenced bitmap 
images in Discover 3D:

• Converting a Map Window into a 3D Image.

Organise multiple data tables in a mapper window in MapInfo, including 
vector, raster images, grid and/or  labels, and automatically transfer an 
image of this mapper to Discover 3D using the 
Discover 3D>View Map in 3D menu option. 
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• Draping Images Over a Grid.

If you have open in MapInfo a high resolution image (e.g. airphoto) and a 
gridded surface (e.g. topographic grid) of the same area, use the 
Discover 3D>3D Utilities>Overlay Image on Grid tool to create an 
.EGB header file linked directly to the source image file, thus preserving 
the image resolution.

• Add an existing georeferenced bitmap image to Discover 3D.

Previously created EGB files can be opened directly from within Discover 
3D, either by:

• Dragging and dropping the .EGB file into the 3D window.

• Using the Display>Located Image menu tool in Discover 3D.

• Using the Display Located Image button in Discover 3D.

• Georeference an image from within Discover 3D.

Vertical orientated images (such as scanned geophysical or historical 
cross sections) can be 3D georeferenced from directly within Discover 3D 
using the Using the Georeferenced Image File Creation Wizard to define 
the origin and location of one or more raster images.

• Georeference multiple vertical sections using MapInfo polylines.

The Multi Section Creator (see Displaying Other Types of Sections) 
allows multiple vertical images (such as scanned long section from a 250K 
fact geology map) to be georeferenced. It requires a MapInfo table of 
polylines indicating these images spatial extents for georeferencing.
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Encom Georeferenced Bitmap (EGB) Format

The .EGB file locates and references the bitmap. Below is an example of an .EGB 
format file. 

GeoreferenceImage Begin
Comments = "Example Bitmap Section derived from Discover - MapInfo" 
Version = "1.0" 
Image = "Section2Map.bmp" 
ImageFormat = "Bitmap" 
CoordinateSpace Begin 
Projection = "Non-Earth (meters)" 
Datum = "" 
Units = "m" 
CoordinateSpace End 
Registration Begin 
TopLeft = 520814.36, 6302870.36, 340.418 
TopRight = 522014.09, 6303861.59, 340.418 
BottomLeft = 520814.36, 6302870.36, -597.606 
BottomRight = 522014.09, 6303861.59, -597.606 
Registration End 
GeoreferenceImage End

The CoordinateSpace and Datum parameters are identical to those used within 
ER Mapper and can accommodate a wide range of projections. 

Converting a Map Window into a 3D Image

Discover mapper windows (containing raster imagery, vector drawings, 
interpretative sections, drillhole sections or drillhole logs) can all be displayed in 
Discover 3D as georeferenced or located bitmap images. The best method of 
transferring a 2D display to 3D is to use the Discover 3D menu options.

The primary tool is the View Map in 3D tool (see Displaying Map Window Views 
as 3D Images). All data sets visible in the selected map window (e.g. grids, 
images, vector data, labels) will be incorporated into the 3D image. The image’s 
RL can be assigned manually, or it can be ‘draped’ over a gridded surface (e.g. a 
DEM grid).

Additionally, the Viewing Drillhole and Trench Sections and Viewing Drillhole 
Logs options on the Discover 3D menu allow drillhole cross sections and logs 
displays to be converted into 3D images .
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These options create a .PNG image of the source mapper window with an 
accompanying Encom Georeferenced Bitmap (EGB) Format file into either a 
temporary or permanent directory (enable the Save Permanently option in the 
appropriate dialog).

Once an image is displayed within Discover 3D, various properties such as 
transparency can be applied.

Maximising Image Resolution

The quality of the output 3D georeferenced image can be improved via:

• Utilising a larger MapInfo mapper window (but do not maximise it).

• Ensuring that your MapInfo mapper window is zoomed to the extents of 
the required data.

• Under Discover 3D>Options, increase the Create Raster Images at 
…Screen Resolution factor set in the Display tab of the dialog. This will 
increase the output image resolution. However it will also result in a larger 
output PNG image file size; displaying multiple high resolution images 
within Discover 3D may reduce the redraw speed and efficiency.

• If your input dataset in the map window is already an image (e.g. an air 
photo), and it will be draped over a grid (and no other data is involved), 
perhaps use the Image on Grid Creator Tool. This will create a .EGB 
header file referencing directly to the source image, thus preserving the 
source image’s resolution. 

Opening an Existing Georeferenced Bitmap Image

Previously created .EGB files (for instance, created in a previous session of 
Discover 3D or using utilities such as the Multi Section Creator Tool or Object 
Manager Tool) can be opened from directly within Discover 3D using any of the 
following options:

• Dragging the .EGB file from File Explorer or the Explorer tab of the 
Information window and dropping it into the 3D window.

• Using the Display>Image menu option to add an Images branch to the 
Workspace Tree. Within the File tab of the Images Properties dialog, use 
the Browse button to locate the target .EGB file.
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Using the Georeferenced Image File Creation Wizard

Images Properties dialog with the Georeferencing Wizard button highlighted

To georeference one or more vertical, planar images:

2. Display the properties dialog from the created Image branch in the 
Workspace Tree and select the Georeferencing Wizard button.

• Using the Display Located Image button to add an Images branch to 
the Workspace Tree. Within the File tab of the Images Properties dialog, 
use the Browse button to locate the target .EGB file.

Vertically orientated images, such as scanned cross-sections from open file 
reports are other applications, can be displayed in Discover 3D using the 
Georeferencing Wizard button (shown left), available in the Images Properties 
dialog. 

1. Create an Image branch in the Workspace Tree within Discover 3D by 
clicking the Display Located Image button on the Data Objects toolbar 
or the Display>Image item from the menu options. 
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3. Select the Georeferencing Wizard button and select the files required to 
be defined in an .EGB file. Note that a single .EGB file can specify the 
path, filename, location and type of any number of bitmap files. Choose 
the required files and add them to the screen as shown below:

Georeferencing Wizard screen 1

4. With the required image files selected in the list on Screen 1, click the 
Next button to access Screen 2. To pick your image registration points 
interactively (recommended), including using registration points inside the 
image boundary, select the interactive button at the bottom right of the 
dialog, which opens the Image registration dialog (see Interactive Image 
Registration).

• To register your image as a vertical section/plane, enter the top right 
and bottom left corner XYZ coordinates.

• To register your image as a horizontal non-rotated map or plan, 
enable the Register for map option, and enter the top right and 
bottom left corner XYZ coordinates (the Z values should be 
identical).

• To register your image as as an inclined plane (e.g. inclined 
section), enable the Display all coordinates entry fields option, 
and enter all four corner XYZ coordinates.
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If multiple images were selected in Step 1, click the Next button when the 
first image has been specified.  The Step 2 screen will cycle through each 
of the selected bitmaps. To assist in defining their location, the corner 
coordinates are retained from the previous bitmap entries.

Screen 2 of the Georeferencing Wizard

5. Screen 3 of the Georeferencing Wizard requests an output .EGB file and 
path name as well as defining a projection for the output. You can use the 
Open File button to navigate to a suitable location and name the file. 
When completed, click the Finish button to create the .EGB file.
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Output the .EGB file for use in a 3D display

6. After the .EGB file has been created, return to the File tab of the Images 
Properties dialog and use the Browse button to find and display the new 
file.

Interactive Image Registration

Interactive image registration in Discover 3D is very similar to the image 
registration process in MapInfo Professional:

• Allows control points anywhere on the image to be specified, unlike the 
other methods available, which can only use the image corner points

• Requires at least 3 control points to be specified, which must not lie on a 
straight line.

• For each control point, appropriate real world X, Y and Z coordinates must 
be specified
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Interactive Image registration Dialog (Data courtesy of PIRSA).
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To register an image interactively

Directly Importing Data as EGB Images

Discover can directly load the following data formats using the browse button in 
the Image Properties dialog:

1. Pan and zoom to the first control point on the image. Zoom, Fit to image 
and 1:1 view buttons are available at the bottom left of the dialog to help 
control the image preview window. The mouse wheel also functions as a 
zoom control. When not in Add control point mode, left-clicking and 
dragging the image will pan the image view

2. Press the Add control point button  at the top of the dialog

3. Click on the image: a red cross with the control point name will be added, 
as well as a new row in the data sheet at the top of the dialog

4. Type in the real world X,Y & Z coordinates in the appropriate columns in 
the data sheet (double-click in the target cell to edit).

5. Repeat steps 1-4 for each additional control point

6. Incorrectly placed or unnecessary control points can be deleted by 
highlighting the appropriate data sheet row, and pressing the Delete 
button

7. When all control points have been added, press the OK button to return to 
the main dialog

3D DXF vector (.DXF) Geosoft grid (.GRD)
3DS vector (.3DS) GeoTIFF (.TIF .TIFF)
Arc ASCII grid (.ASC) JPEG (.JPG)
Arc binary grid (.ADF) Landmark grid (.GRD)
ASEG GXF grid (.GXF) MapInfo grid (.MIG)
BIL (.BIL) Minex grid (.XYZ)
Compuserve GIF (.GIF) ModelVision TKM (.TKM)
Datamine vector (.DM) Portable network graphics (.PNG)
Encom georeferenced image (.EGB) Surfer ASCII grid (.GRD)
Encom grid (.GRD) Surfer binary grid (.GRD)
ERMapper ECW (.ECW) TAB raster (.TAB)
ERMapper algorithm (.ALG) TIFF (.TIF)
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Changing Image Display Properties

When a Georeferenced Image is displayed in Discover 3D an Images branch 
appears in the Workspace Tree. To display the properties dialog of the image, 
select the Images branch and either double click with the left mouse button or 
highlight and click right. From the displayed shortcut menu, select the Properties 
item.

The Image Properties dialog is a dynamic dialog; the property tabs displayed will 
vary depending on the data types incorporated into the EGB file. The following 
screenshot illustrates the full range of property tabs available when an EGB 
created by draping the contents of a map window over a grid is selected:

ERMapper grid (.ERS) USGS DEM grid (.DEM)
ESRI TIN (TDENV.ADF) USGS grid (.USG)
Gemcom vector (.BT2) USGS SDTS grid (.TAR)
GeoTIFF (.TIF .TIFF) Vertical Mapper grid (.GRD .GRC)
GoCAD vector (.TS .PL .VS) Vulcan vector (.00T)
Geopak grid (.GRD) Windows bitmap (.BMP)
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The Image Properties dialog with the various controlling tab sections.

The Images Properties dialog provides various control tabs for image display. 
These are divided into:

• File -  initially displayed, allows file selection, group controls and image 
registration.

• Display Tab – provides clipping options.

• Surface Tab – provides options for image colour, modulation and lighting.

• DTM Tab – allows vertical section images to be offset using a digital 
terrain model (DTM).

• Transparency Tab – controls the image transparency.

• Transform Tab – provides scaling and translation controls.

The bitmap source path and file is listed under the Source File section. If you 
need to display an alternative Georeferenced Image, use the Browse button 
(shown left). The Georeferencing Wizard is also available (see Using the 
Georeferenced Image File Creation Wizard).
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• Image Tab – image stretch and interpolation controls, as well as 
transparent colour assignment.

• Grid Tab – incorporates grid compression controls.

Display Tab

The Display tab allows the image to be clipped above and/or below two user-
specified horizontal planes (i.e. Z values). 

For instance, if a Clip below value of 235 was set, an airphoto draped over a DEM 
grid would have all portions of the image with Z value less than 235 hidden.

An airphoto draped over a DEM grid

The same .EGB with all portions below 5500 clipped.
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Surface Tab

The Surface tab specifies aspects of colour, modulation and lighting.

Surface tab defining colour usage and appearance of Located Images

Parameters that can be controlled include:

• Style – Controls the basic surface rendering style and allows the triangle 
meshes to be displayed using fill (colour or textured), fill with triangle 
mesh wireframes or simply as coloured wireframes.

• Fill – Controls the source of the fill colour, if used. There are three 
possible colour sources – an image, a user-defined solid colour or solid 
colour modulated by a field in any of the ancillary data tables (Object, 
Mesh, Surface, Face and Vertex). In the latter case you must select a field 
from the table and define a colour table and colour mapping. If you are 
only displaying wireframes then the settings will apply to the line colour.

• Scope – Allows you to override default settings (defined in the source 
files) or only apply the settings to those meshes for which no defaults were 
specified in the source file.
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• Modulation Data Field – Lists the fields in the ancillary data table, if 
selected. Note that the system will create many fields automatically. One 
such field is the ‘_Colour’ field which will contain any colour information 
recovered from the source file. 

• Lighting – Provides None, Smooth or Flat and affects the display of the 
facets of the objects.

• Default fill and line colours – Specifies the user-defined colours for solid 
fill and wireframes.

• Colour scale – Control of the colour look-up table is provided.

• Colour mapping – The colour mapping controls the mapping of the 
colour modulation field data to the colour table. In general this will be a 
linear transform but other options such as histogram equalisation can be 
chosen to stretch the colour table. Note that a special transform called 
‘None’ is available. This will bypass the colour table and is automatically 
used when the ‘_Colour’ field is selected.

Colour mapping applies a transform to the distribution of colours assigned by the 
specified look-up table.  The dialog is displayed from the Edit button of Colour 
Mapping and offers band-pass cut-off of colour plus a range of transforms to map 
the colours. Band-pass operations determine the percentage of attribute data that 
is colour scaled. You can specify an upper and lower cut-off as required.

Available Colour Mapping transforms include:

• None – The source data is used as an RGB colour value directly with no 
modification or reference to the colour table.

• Linear (Increasing) – Within the prescribed colour range (as determined 
by the Band-Pass Cut  Off) the data (from the attributes of the voxel 
model) are linearly stretched from lowest data value to lowest mapped 
colour, to highest value mapped to highest mapped colour.

• Linear (Decreasing) – The colour values are inversely mapped to the 
Linear Increasing option.

• Log (Increasing) – The log value of the data are linearly mapped from the 
lowest ranked colour, to the highest.

• Log (Decreasing) – The converse of the Log – Increasing option.

• Histogram – An equal area histogram operation to map the display.
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• User Defined – Specify the range from the settings in the colour scale. To 
enable this feature use the ..specified in data values option and enter 
appropriate data values in the Lower and Upper Value entries.

DTM Tab

The DTM tab is used solely for offsetting planar vertical  images (such as scanned 
geophysical sections imported using the Georeferencing Wizard)  using a DTM 
(Digital Terrain Model) grid. 

The offset can be computed for each vertex of the image or an offset for the centre 
of the image can be computed and applied equally to all vertices. The vertical 
image can sit on top of the DTM, hang from it or be centred on the DTM. 

The DTM tab and defining a surface to alter the top surface
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Transparency Tab

Image Transparency is controlled from the slider bar or by entering a specific 
percentage entry. An entry of 0% has no transparency while 100% displays the 
object with total transparency (invisible).

For certain objects (such as a sphere, that has a surface behind any other point), 
you can remove the effect of seeing a second surface behind the first.

The Transparency property tab
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Transform Tab

The Transform tab provides image scaling and translation controls. The scaling 
is applied as the last transformation prior to the DEM offset transform. The 
translation operation is applied as the first transformation after the DEM offset 
transform. 

The Transform property tab
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Image Tab

The Image tab provides Image Stretch and Texture Interpolation controls, as well 
as allowing the specification of a colour or colour range to set as transparent.

The Image Processing tab

Image Stretch allows for the preservation of either Colour, Black or White data, 
or for these to be displayed in the highest possible quality. Texture Interpolation 
Modes of an image can be:

• High Quality – displays interpolated images at suitable levels of 
resolution at all times to prevent aliasing artefacts.

• Interpolate – applies an interpolation algorithm to ‘smooth’ the display.

• None – displays the bitmap as is with no interpolation applied.

The Specify transparent colour option allows the selected colour to be rendered 
transparent. This is particularly useful when the image has been captured with a 
homogenously coloured mask (typically a white mask, e.g. scanned government 
250000 interpreted geology maps). 
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Also available is a transparency range, allowing a ‘range’ of colours to be made 
clear. If you set this value, the RGB combinations above the colour specified to 
be transparent are also set transparent. For example, if you request the colour 
white to be transparent (RGB colour 255:255:255), and set a range of 5, then all 
colour combinations with RGB from 250 are set transparent (that is, 250:255:255 
and 251:255:255 etc). This option is especially useful when some pixels of a 
bitmap are nearly white but not exactly as is often the case in a scanned product.

Grid Tab

The Grid tab is only displayed when a grid surface is incorporated into the EGB 
file, e.g. when a map window had been draped over a grid surface.

The range of grid compression options available allow Discover 3D to display and 
manipulate large, complex surfaces quickly with little loss of surface detail. Grid 
compression reduces the complexity of a grid, thereby improving display redraw 
speeds and navigation efficiency.

The Grid Compression tab

The Compression Mode pull-down list provides five compression options:

• None - No compression is performed and the grid is displayed at full 
resolution.
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• Decimate to System size - The grid is decimated to the System size set 
via the Discover 3D> Options menu option, under the System tab.

• Decimate to User size - The grid is decimated to the X and Y Size values 
assigned by the user within this dialog

• Decimate to User Factor - The grid is decimated according to the X Skip 
and Y Skip values assigned by the user.

• Variable Compression - Attempts to retain the boundary of the grid, 
including internal holes. The compression level is adjusted via the slider 
bar. Three clipping levels are available:

• Complete - the grid boundary and holes are preserved,

• Partial - the grid boundary and holes may not be perfectly 
preserved, or

• None - the grid is rendered as a convex hull with no holes 
preserved.
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8 Working with Vector Data in 3D
Discover 3D can display objects as both 3D and 2D vector files. An example of 
3D vector models imported into a 3D space is shown below and illustrates the use 
of 3D vector files with other data types.

An example of underground workings (light blue) and an ore body outline (light green) 
displayed as 3D vector files with drillholes, located bitmaps, and a voxel model isosurface 
(red).

• Displaying 3D Vectors

• Changing 3D Vector Display Properties

• Displaying 2D Vectors in 3D

• Manipulating, Transforming and Reprojecting Vectors

• Creating Orientated 3D Vector Symbols

• Extruding 2D Vectors into 3D
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• Generating 3D Models from Vectors

Displaying 3D Vectors

There are four options for displaying 3D vector files in Discover 3D:

Discover 3D supports the following 3D vector file formats:

AutoCAD (.DXF)
GoCAD vector files (.TS, .PL, .VS) 
Gemcom (.BT2)
ESRI TIN (.ADF)
ESRI 3D shapefiles (.SHP)
Datamine  wireframe (.DM)
Surpac DTM files (.DTM)
Surpac string files (.STR)
Vulcan triangulation files (.00T)
3D Studio files (.3DS)

When opening 3D vector files from within Discover 3D (using the import options 
2 & 3 above) a new, empty Vectors branch is added to the Workspace Tree. 
Display the Vectors Properties dialog of this layer and use the Browse button 
under the 3D Vector File tab to specify a 3D vector file after navigating to the 
appropriate location. Click the Apply button after selection and the 3D object file 
is displayed in Discover 3D.

1. From within Discover, 3D DXF tables or selections may be created using 
the Discover 3D>View Objects in 3D tool (see Displaying Map Objects 
as 3D Vectors), which then transfers the output to Discover 3D 
automatically.  The DXF files created via this option can also be opened 
directly into Discover 3D at a later time.

2. By selecting the Display Vector button from the Main toolbar.

3. Using the Display>3D Vector menu option.

4. Selecting the File>Open menu option and setting the File of Type to All 
supported 3D Vector formats.

Note Additional vector file formats can be imported and converted using the 
Transform Vector File tool detailed in the 3D Utilities chapter. 
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Vectors Properties dialog used for specifying a 3D vector format file
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Changing 3D Vector Display Properties

The Vectors Properties dialog provides a number of controls (in four tabs) to 
improve or alter the appearance of displayed 3D vector files.

Display of an ore body 3D vector file with altered appearance

The File tab has the following options:

• Apply a Smooth Surface to the object if the surface is faceted. The 
smoothing can be applied to facet angles sharper than a defined angle 
(Sharp Angle in degrees).

• Reverse Facing - The defining facets can be reversed to allow the 
internal surface of the 3D file to be viewed. 

• Cull Back - To improve the speed of rendering, the back (away from the 
display), can be culled.

A 3D vector file can be composed of multiple layers, the display attributes of which 
can be controlled via the Surface tab. For each layer, the following options are 
available:

• Specification of an Override Fill .
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• Specification of an Override Line colour, weight and pattern.

• Display a Wireframe of the surface faceted shape in addition to the 
surface.

The Transparency tab enables the transparency of a vector object to be altered 
via a slider bar or manual entry of a transparency percentage. An option to 
prevent the vector object being visible through itself is also available.

The Transform tab allows Scaling and Translation parameters to be assigned 
individually to the X, Y and Z axes. A Reset button allows these values to be 
restored to their original (un-transformed) values.

3D Vectors Transform tab, incorporating scaling and translation controls

Displaying 2D Vectors in 3D

Discover 3D enables the display of vector data as 2D vectors without creating a 
DXF file. Vector data text, line and fill colours can be modified within the 3D view. 
Discover 3D supports the following formats for display as 2D vector files:
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AutoCAD 2D DXF
Encom GSF files
ERMapper ERV file
ESRI SHP files
MapInfo Professional MIF and TAB files

There are three options for importing data into Discover 3D as 2D vectors:

• Use the Display>2D Vector menu option,

• Right-click on the 3D Map branch in the Workspace Tree and select 
Display>2D Vectors option, or

• Select the File>Open menu option and set the Files of Types to All 
supported 2D Vector Files. Browse for the relevant file. 

2D Vectors Properties dialog

These import options will place a new 2D Vectors branch in the Workspace 
Tree. Double click on this branch to open the 2D Vectors Properties dialog. The 
first two import options require data file selection using the Browse button  in the 
Vector File tab of this dialog. 
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The Override tab of the 2D Vectors Properties dialog provides override controls 
for the text, line, fill and background fill colours. Polygons with a solid fill colour 
can be instantly made hollow using the Make Hollow Fill option.

The Z tab incorporates Offset options (DTM offset via a specified grid, or a 
Constant Offset), as well as allowing Z scaling specification. 

Manipulating, Transforming and Reprojecting Vectors

Discover 3D provides the following additional tools for vector file manipulation:

Transform Vector File

This tool allows the following functionality:

• Import and conversion of a wide range of vector file formats.

• Reprojection of vector files to different coordinates systems.

• Positioning in 3D of vector objects such as vehicle models, including 
separate rotation and scaling options along each axis.

See the Transform Vector File section of the 3D Utilities chapter for further 
information.

Combine DXF

Combines separate DXF data files into a single DXF file, preserving the location 
and properties of objects. See the Combine DXFs section of the 3D Utilities 
chapter for further information. 

Creating Orientated 3D Vector Symbols

This tool converts 2D point data into 3D symbols in an output DXF vector file.  It 
includes controls for Bearing and Inclination of the symbols, as well as shape, 
colour, and size controls for the symbols. See the 3D Point Symbols section of 
the 3D Utilities chapter for further information.
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Extruding 2D Vectors into 3D

Converts 2D input objects into a 3D objects in a vector DXF file, by extruding the 
objects in the Z axis.  This is a powerful way of visualising faults from surface trace 
mapping, or buildings from polygon outlines. This tool includes controls for the 
primary and secondary heights, bearing and inclination options, etc. See 
Extruding Models from Points, Lines and Polygons for more information.

Generating 3D Models from Vectors

Produces interpolated solid 3D objects (e.g. fault planes, ore zones) from input 
polygons or polylines. See the Modelling Triangulated Surfaces and Solids 
chapter for further information
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9 Working with 3D Points
Point data may include data that has been collected systematically at sample 
locations along linear traverses or measurements taken randomly across an area. 
Point data tables require each record to have an X (Easting), Y (Northing) and Z 
(RL) field, with an optional line identifier field. A soil sampling survey or traverses 
of height measurements are examples of point data tables that can be viewed in 
Discover 3D.

To display point data in Discover 3D, use the Discover 3D>Create 3D Points 
tool (see Displaying Points in 3D) on the MapInfo/Discover 2D interface.

The source of data to be used can be from a table in MapInfo Professional or a 
data *Selection*. When you request Points be added to the Workspace Tree, a 
Points branch is created.

This is a powerful way of visualising surface geochemical datasets (e.g. soils or 
rock-chips) over your drillholes, gridded surfaces and imagery.It can also be 
utilised to indicate points of interest (e.g. prospect locations). Displaying data as 
3D Points provides the following capability: 

• Change the point Symbol Style type, colour and size.

• Display points as 3D symbols based on True Type fonts, with controls over 
symbol orientation, extrusion and positioning.

• Display Labels for the dataset.

• Modulate point data colour (Colour Modulation) or symbol size (Size 
Modulation) using values from other fields in the table and colour tables 
and legends.

• Rotating Point Symbols to modulate point by independent Bearing, 
Inclination and Tilt fields (ZXY components).

To control these and many other parameters, see the Changing Point Display 
Properties section below.

Alternatively within Discover 3D window, use the Display Points tool from the 
Data Objects toolbar or the Display>Points menu item to display data already 
open in the 3D window. 
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Interrogating Point Information

3D Point datasets displayed in Discover 3D can be dynamically interrogated, 
allowing a particular point’s attributes in the source .TAB file to be instantly 
viewed.

To enable point interrogation:

The fields displayed and their order in the Data window spreadsheet can 
be customised by right clicking in the Data window and selecting the 
Customise option. These Data window customisation options (including 
field widths) are preserved as long as the current Discover 3D session is 
open.

Changing Point Display Properties

The display of points in 3D is controlled from the Points Properties dialog as 
shown below. To display the Points Properties dialog highlight the Points 
branch in the Workspace Tree and select Properties from the right-mouse click 
shortcut menu (or double-click on the branch). 

Clicking the Apply button will update the 3D display to reflect chosen options. 
Enabling the Auto Apply option will automatically update the display after every 
change. For large datasets it is recommended this feature be disabled, allowing 
multiple changes to be applied at the one time rather than waiting for the display 
to redraw between each change.

The following parameters can be controlled with this dialog:

• Data Selection

• Offsetting and Scaling Data

• Symbol Style

1. In the Workspace Tree, make the Point branch both Selectable and 
Browsable.

2. Display the Data Window using either the toolbar button or the View>Data 
Window menu option.

3. Enable the Select/Navigate button on the Zoom Controls Toolbar. Place 
the mouse cursor over a point location – the Data tab will scroll to the 
appropriate point record. The Cursor Plane and its Bond (see Bond option 
on Cursor Plane Toolbar) function will be auto-enabled  for this process.
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• Labels

• Colour Modulation

• Size Modulation

• Rotating Point Symbols

• Decimation

Saving or Loading Point Display Settings

Any display settings customized in the following tab controls can be saved for 
later reuse. To save or load any current settings, move the cursor over the Points 
branch in the Workspace tree and right click. Select either Save Properties or 
Load Properties from the menu.

Data Selection

Lines selection dialog

The Lines tab provides data subsetting control. Select the Lines dataset (if more 
than one is open) from the Dataset pull-down list. 
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Select the lines to display in the 3D window from the Line Selection list. Use the 
arrows to select or deselect lines by moving them between the Hide and Display 
windows.

Offsetting and Scaling Data

The Fields tab allows the user to set both:

• Z field – typically an RL or Elevation field in the dataset. If this does not 
exist, perhaps use the Discover>Surfaces>Assign Values from grid 
tool to populate a field with RL values from a coincident topographic grid.

• Offset field – a separate field to offset the points (in the vertical) from the Z 
value. For example, using a geochemical assay field to in essence create 
a stacked profile view.

You can quickly select every 2nd line from the dataset by using the subset 
arrows button.  At 1 this selects every line, 2 every second, 3 every third line etc.

Alternatively, use the button to make a map window selection of point data to 
display.

The Field Data Conditioning button adjacent to each of the field selection lists 
opens the Field Data Conditioning dialog. This dialog allows the selected field 
to be transformed via a number of methods:

• It is of most use for applying a scaling factor to the Offset field, as it is 
unlikely that the magnitude of the offset field (e.g. an assay or geophysical 
field) will be comparable to the Z field. 

• It may also be useful in applying a Translation factor to your Z field when 
data is coincident with a draped aerial photo (and therefore partially 
obscured: e.g. translating the data by 2m above the Z field value.

For more information on data conditioning, see Field Data Conditioning Tool.
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To scale the Offset field:

Setting an Offset field in the Fields tab

1. Enable the Offset tick box.

2. Select the field you wish to Offset the point data with (e.g. a geochemical 
field) from the adjacent pull-down list.

4. In the following dialog, select the Scale option from the pull-down list at 
the bottom left of the dialog.

3. Select the adjacent Field Data Conditioning button. See Field Data 
Conditioning Tool for more information.

5. Set the scaling factor in the window below this list, and press the adjacent 
Add button to add this setting to the right hand list. Press OK to close the 
Field Data Conditioning dialog.
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Setting a Scale factor in the Field Data Conditioning dialog

6. Press Apply to visualise this in 3D.

Symbol Style

The point symbol style is controlled under the Symbol tab of the point properties 
dialog.

To access the symbol controls ensure the Show Symbols option is ticked. To 
quickly display point data using the default square symbol check the Fast 
Symbol option. This is a memory-efficient display method, and recommended 
when using very large datasets. 

To customise the symbol display, deselect the Fast Symbol option and click in 
the Symbol box. This will open the Symbol Selector dialog, allowing you to 
choose from an extensive library of symbols based on installed True Type fonts. 
Choose a symbol from the list; it will be previewed to the right. The symbol Size 
and Fill Colour can also be altered here. 



9 Working with 3D Points 179

Symbol Selector dialog

Advanced Symbol Style Options are available via the Advanced button. 

Advanced Symbol Style Options dialog
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A range of symbol orientation options is presented in the pull-down list at the top 
right of the dialog:

• Facing Viewer (default) – Symbols are aligned parallel to the viewing/
screen plane, so that they always face the viewer. 

• Fixed 3D – Symbols are fixed in the 3D environment. The pull-down list in 
the Rotation panel at the bottom of the dialog controls the initial 
orientation: Flat (the XY plane) or Upright (XZ plane).

• Fast 3D – identical to the Fixed 3D except that no Style controls are 
available; this is a very fast and memory-efficient option.

The Style button is only available for the Facing Viewer and Fixed 3D orientation 
options. It enables symbols to be extruded either as filled Polygons or Line 
Segments (wireframe) using the Format pull-down list. The depth of the symbol 
is set using the Extrusion control, expressed as a percentage of the symbol size. 
To display a flat symbol, set the Extrusion to 0%. The symbol is extruded 
perpendicular to its display plane. 

A range of Size Controls is available. For the Fast 3D orientation option, only the 
Font Size control is available (in points). Enabling the Constant checkbox (for 
the other orientation options) will keep the symbols at the specified size (relative 
to the screen) regardless of zoom level. If the Constant option is disabled, Lower 
and Upper Limits can instead be set:

• Block: symbols will disappear when the applied zoom level takes the 
symbol past the specified limit,

• Clamp: symbols will be locked to the specified limit when the applied 
zoom level takes the symbols past the specified limit.

The symbol position relative to the data location can be altered using the 
Alignment controls (either preset or manual positioning). The first row of controls 
concern symbol positioning in the symbol plane (i.e. the relative XY components), 
whilst the second row controls the vertical height of the symbol with respect to its 
initial plane (i.e. the relative Z component).

The angle of the symbols can also be set by moving the red-tipped arrow on the 
compass in the Rotation panel at the bottom of the dialog. The Fixed and Fast 
3D labelling options also provide a Dip control (half-compass) in this panel.
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Labels

The labelling of data points in a 3D window display is useful for applications where 
visualising the actual values is important. 

The Label control dialog, with 1 in every 10 points to be displayed with an arsenic value

Enable the Show Labels tick box to activate the dialog. From the adjacent pull-
down menu, select the data field to display as a label. 

The Label Skip Factor controls how often labels are displayed. For large 
datasets, it may be necessary to display the labels for only 1 in every 5 or 10 
points.

The Appearance button opens the Advanced Arrangement dialog. 

Specific ranges or attributes of the dataset can be selected with the adjacent 
Data Conditioning button, as well as null values removed. See Field Data 
Conditioning Tool for detailed information on this tool.

Note Rendering labels as extrusions is memory intensive and may affect 3D 
performance. It is not recommended for large numbers of labels: the Label Skip 
Factor control can help minimise this issue.
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The Advanced Arrangement dialog for line labels

The Format button provides numeric formatting options (scientific, various DMS 
formats, general, etc), decimal place allocation as well as suffix and prefix 
specification. 

Standard Font controls are provided, as well as the following range of orientation 
options in the adjacent pull-down list:

1. Facing Viewer (default) – Labels are aligned parallel to the viewing/
screen plane, so that they always face the viewer. 

2. Fixed 3D – Labels are fixed in the 3D environment. The pull-down list in 
the Rotation panel at the bottom of the dialog controls the initial 
orientation: Flat (the XY plane) or Upright (XZ plane).
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• Fast 3D – identical to the Fixed 3D except that no Style controls are 
available; this is a very fast and memory-efficient labelling option.

The Style button is only available for the Facing Viewer and Fixed 3D orientation 
options. It enables labels to be extruded either as filled Polygons or Line 
Segments (wireframe) using the Format pull-down list. The depth of the label is 
set using the Extrusion control, expressed as a percentage of the label size. To 
display a flat label, set the Extrusion to 0%. The label is extruded perpendicular 
to its display plane. 

A range of Size Controls is available. For the Fast 3D orientation option, only the 
Font Size control is available (in points). Enabling the Constant checkbox (for 
the other orientation options) will keep the labels at the specified size (relative to 
the screen) regardless of zoom level. If the Constant option is disabled, Lower 
and Upper Limits can instead be set:

• Block: labels will disappear when the applied zoom level takes the label 
past the specified limit, 

• Clamp: labels will be locked to the specified limit when the applied zoom 
level takes the label past the specified limit.

The label position relative to the data (collar) location can be altered using the 
Alignment controls (either preset or manual positioning). The first row of controls 
concern label positioning in the label plane (i.e. the relative XY components), 
whilst the second row controls the vertical height of the label with respect to its 
initial plane (i.e. the relative Z component).

The angle of the labels can also be set by moving the red-tipped arrow on the 
compass in the Rotation panel at the bottom of the dialog. The Fixed and Fast 
3D labelling options also provide a Dip control (half-compass) in this panel.

Colour Modulation

The Colour tab allows point data to be coloured modulated using a specified field.

To colour modulate point data:

1. Enable the Colour option, and select the source data field from the 
adjacent pull-down list. 

2. Specific ranges or attributes of the dataset can be selected with the 
adjacent Data Conditioning button, as well as null values removed. See 
Field Data Conditioning Tool for detailed information on this tool. 
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4. Select one of the four methods of colour scale definition:

• RGB Interpolation - interpolates between two colours in 
Red:Green:Blue colour space.

• HSL Interpolation - interpolates between two colours in 
Hue:Saturation:Luminosity colour space.

Size Modulation

The point symbols can be size modulated using the controls in the Symbol tab. 

1. Enable the Size option.

2. Enter the desired minimum and maximum point sizes in the From and To 
areas.

3. Specify a colour lookup table from the Edit Colour Scale button: this will 
open the Colour Scale dialog. 

For the RGB and HSL Interpolations, set the first and last colours of the 
colour scale by selecting the Colour Browse buttons at the bottom or top 
of the colour bar. When clicked, a standard Windows colour 
selection dialog is displayed allowing colour specification. These can be 
reset by clicking the Set Default Colours button.

• Look Up Tables - the standard look-up table formats are supported 
and are installed as part of your Discover 3D installation. These can 
be created or edited using the Colour Look-Up Table Editor (see 
Using the Colour Look-Up Table Editor).

• A custom Legend created using the Legend Editor (see Using the 
Legend Editor).

5. Specify a non-linear mapping of the data, such as histogram or log, by 
selecting the Edit Colour Mapping button. This can assist in achieving an 
even stretch of the colour scale across the data range. See Advanced 
Colour Mapping for more details.

6. Press OK twice to apply.

3. Advanced size mapping options are available from the adjacent button 
which opens the Data Mapping dialog. See Advanced Colour Mapping for 
more details
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4. Select the field to size modulate by from the associated pull-down list.

Rotating Point Symbols

The Rotation tab allows point symbols to be rotated by up to 3 fields using:

• Bearing (i.e azimuth)

• Inclination (i.e. dip)

• Tilt

Drilling downhole structural measurements displayed as orientated points using azimuth 
and dip fields, with colour modulation by type (e.g. fault, bedding,vein). The point data was 
spatially referenced using the Drillholes>Calculate 3D Coordinates tool (see the  Discover 
Reference Manual)

To apply rotation:

1. Enable the rotation types required.

2. Set the appropriate fields to each rotation type.

Specific ranges or attributes of the dataset can be selected with the adjacent 
Data Conditioning button, as well as null values removed. See Field Data 
Conditioning Tool for detailed information on this tool. 
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3. Modulate Rotation select the data field to use for the modulation.  

The Rotation tab configured for a dataset of structural measurements

The adjacent Pi button opens the Rotation Parameters dialog.  This allows the 
direction of rotation to be altered (for instance to orientate positive dip values 
downwards, set this to -1 to reverse the angle direction).  The angle units can 
also be set to radians or a fixed offset applied.

Specific ranges or attributes of the dataset can be selected with the adjacent 
Data Conditioning button, as well as null values removed. See Field Data 
Conditioning Tool for detailed information on this tool.

Use the 3D Point Symbols utility with point or line data to create orientated 
vector symbols for display in Discover 3D.  This can be a less memory intensive 
way to display large amounts of orientated point data in 3D.
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Decimation

Your dataset can be decimated using the options at the bottom of the Fields tab. 
The Decimation or station selection options allow the 3D rendering performance 
to be improved when dealing with very large datasets. A number of decimation 
options are available, including Fixed rate (where you specify a sample ‘skip’ 
factor) and Compression.
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10 Working with 3D Lines
In Discover 3D, line data generally refers to data that has been collected 
systematically along linear traverses with samples or measurements taken at 
discrete intervals. The data is stored in exactly the same way as a MapInfo 
Professional point data table and requires a data field that can be used as a Line 
descriptor. When point data is displayed in Discover 3D it is presented as a single 
continuous line for each sample traverse. 

Line data tables require each record to have an X (Easting), Y (Northing) and Z 
(RL) field along with a line identifier field. Elevation or geochemical survey line 
profiles are examples of line data that can be viewed in Discover 3D.

To display line data in Discover 3D use the Discover 3D>Create 3D Lines tool 
(see Displaying Lines in 3D) in the MapInfo/Discover 2D interface.

The source of data to be used can be from a table in MapInfo Professional or a 
data *Selection*. When you request Lines be added to the Workspace Tree, a 
Lines branch is created. 

To modify line parameters such as applying colour modulation, tube styles,  
applying fill colours above or below a nominated threshold or removing lines from 
the 3D map view, refer to Changing Line Display Properties below.

Interrogating Line Information

3D Line datasets displayed in Discover 3D can be dynamically interrogated, 
allowing a each particular point’s attributes in the source .TAB file to be instantly 
viewed. To enable this:

Alternatively use the Display Lines tool from the Data Objects Toolbar, or the 
Display>Lines menu item to display data already open in the 3D window.

1. In the Workspace Tree, make the Line branch both Selectable and 
Browsable.

2. Display the Data Window using either the toolbar button or the 
View>Data Window menu option.

3. Enable the Select/Navigate button on the Zoom Controls Toolbar. Place 
the mouse cursor over a point location along a line – the Data tab will 
scroll to the appropriate point record. The Cursor Plane and its Bond (see 
Bond option on Cursor Plane Toolbar) function will be auto-enabled  for 
this process.
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The fields displayed and their order in the Data window spreadsheet can be 
customised by right clicking in the Data window and selecting the Customise 
option. These Data window customisation options (including field widths) are 
preserved as long as the current Discover 3D session is open.

Displaying Lines as 3D Tubes

Closely related to the display of lines in three dimensions is the conversion of lines 
to a different object type called Tubes. A tube display may be useful in situations 
where a zone or 3D volume display is required that follows a line trace but has 
thickness represented by a cylindrical column surrounding the line.

The representation of data collected along a line by 3D tubes can often be used 
to advantage. The Lines Properties dialog enables the 3D tubes to be displayed 
and provides the following capability: 

• Modify and import the tube shape 

• Change the size and colour of the 3D tube

• Modulate line data colour, tube thickness or from other fields in the table 
and colour tables and legends.

The conversion of Line objects to Tubes is controlled from the Appearance tab 
of the Lines Properties dialog (see Changing Line Display Properties). 

In the Appearance tab the tube thickness and shape can be modified. All other 
line options are available to alter the tube display, including colour and modulation 
options under the Lines Properties dialog. See the Line and 3D Tube Style section 
for displaying 3D Tubes.

An example of a patterned tube presentation where the tubes represent flight 
paths of specific aircraft types above an airport are shown below.

The TubeShape Manager is used to import and manage the tube shapes that 
are used to display both 3D Lines and drillhole traces. 

Note The Tube Style button is only available when the Discrete samples option is 
disabled.
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Aircraft flight paths presented as 3D tubes with pattern

TubeShape Manager

In the example below a cross-shaped tube has been used to display a series of 
flight lines in the Discover 3D map window. 

Example flight lines using a colour modulated “cross” tube shape

3D data lines can be displayed as tubes using a variety of tube shapes. The tube 
shapes can be either open or closed and any number of tube shapes can be 
created. The TubeShape Manager is used to import and manage the tube 
shapes that are used to display the 3D traces of any linear data, e.g. grid sample 
lines. 
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The TubeShape Manager dialog displays a list of available tube shapes and 
enables new tube shapes to be added or deleted. The tube shapes are saved to 
the .ETS file located in the (Windows XP) C:\Documents and Settings\All 
Users\Application Data\Encom\Common\TubeShapes or (Windows 7 and 
8) C:\Users\All Users\Encom\Common\TubeShapes directory. 

Tube Shape Manager showing selection of tube shapes

To alter the name and description of individual shapes use the Edit shape 
properties button. Click on the Import New Shape button to import a tube shape 
created in a MapInfo Professional TAB or MIF file. Remove any shapes using the 
Delete shape button.

Linear data (including drillhole traces) is displayed in the Discover 3D map 
window from a Lines or Drillholes data type entry in the Workspace Tree. To 
select a tube shape to display with line data select the Appearance tab from the 
Properties dialog. See Displaying Lines as 3D Tubes for more information.
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Changing Line Display Properties

The display of lines is controlled from the Lines Properties dialog as shown 
below. To display the Lines Properties dialog highlight the Lines branch in the 
Workspace Tree and select Properties from the right-mouse click shortcut menu. 
The Lines Properties dialog contains eight tabs to modify or control line data in 
the Discover 3D window.

Clicking the Apply button will change the display to reflect chosen options. 
Enabling the Auto Apply option will automatically update the display after every 
change. For large datasets it is recommended this feature be disabled, allowing 
multiple changes to be applied at the one time rather than waiting for the display 
to redraw between each change.

The following parameters can be controlled with this dialog:

• Line Selection

• Offsetting and Scaling Data

• Line and 3D Tube Style

• Colour Modulation

• Thickness Modulation

• Colour Filling Line Profiles

• Decimation

Saving or Loading Line Display Settings

Any display settings customized in the following tab controls can be saved for 
later reuse. To save or load any current settings, move the cursor over the Lines 
branch in the Workspace tree and right click. Select either Save Properties or 
Load Properties from the menu.
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Line Selection

Lines selection dialog

The Lines tab provides data subsetting control. Select the Lines dataset (if more 
than one is open) from the Dataset pull-down list. 

Select the lines to display in the 3D window from the Line Selection list. Use the 
arrows to select or deselect lines by moving them between the Hide and Display 
windows.

You can quickly select every 2nd line from the dataset by using the subset 
arrows button.  At 1 this selects every line, 2 every second, 3 every third line etc.

Alternatively, use the button to make a map window selection of point data to 
display.
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Offsetting and Scaling Data

An Offset can be applied to line data; for example by using a geochemical assay 
field as an offset.

Using the Fields tab to offset line data by the Copper field

The Fields tab allows the user to set both:

• Z field – typically an RL or Elevation field in the dataset. If this does not 
exist, perhaps use the Discover>Surfaces>Assign Values from grid 
tool to populate a field with RL values from a coincident topographic grid.

• Offset field – a separate field to offset the points (in the vertical) from the Z 
value. For example, using a geochemical assay field to in essence create 
a stacked profile view.
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An example of Offset field scaling. The left image shows soil samples offset from an 
airphoto by the Fe field. Due to the difference in magnitude between the Fe assays and the 
RL values, the soil lines appear very flat and uninformative. Using the Offset Field 
Selection dialog (right), this offset has been scaled by a factor of 10 (1000%) to give the 
viewer a better appreciation of the Fe distribution over the project area.

To scale the Offset field:

1. Enable the Offset tick box.

2. Select the field you wish to Offset the point data with (e.g. a geochemical 
field) from the adjacent pull-down list.

The Field Data Conditioning button adjacent to each of the field selection lists 
opens the Field Data Conditioning dialog. This dialog allows the selected field 
to be transformed via a number of methods:

• It is of most use for applying a scaling factor to the Offset field, as it is 
unlikely that the magnitude of the offset field (e.g. an assay or geophysical 
field) will be comparable to the Z field. 

• It may also be useful in applying a Translation factor to your Z field when 
data is coincident with a draped aerial photo (and therefore partially 
obscured: e.g. translating the data by 2m above the Z field value.

For more information on data conditioning, see Field Data Conditioning Tool.
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Setting an Offset field in the Fields tab

4. In the following dialog, select the Scale option from the pull-down list at 
the bottom left of the dialog.

3. Select the adjacent Field Data Conditioning button. For more 
information, see Field Data Conditioning Tool.

5. Set the scaling factor in the window below this list, and press the adjacent 
Add button to add this setting to the right hand list. Press OK to close the 
Field Data Conditioning dialog.
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Setting a Scale factor in the Field Data Conditioning dialog

6. Press Apply to visualise this in 3D.

Line and 3D Tube Style

Under the Appearance tab the line style options can be set.  Choose from either 
Line or 3D tube to display.  The style of these can be set under the Line Style or 
Tube Style buttons.

Note that Line thickness is set in the Line Style dialog, but the Tube thickness is 
set in the Appearance tab.

Note The Tube Style button is only available when the Discrete samples option is 
disabled.

To edit the available list of tube shapes, use the TubeShape Manager.
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Data gaps can be including or ignored in the line by the Show Gaps and Discrete 
Samples options.

Colour Modulation

The Colour tab allows line data to be coloured modulated using a specified field. 

Line style controls with Au HSL lookup table and a histogram colour map applied

To colour modulate line data:

1. Enable the Colour option in the Colour tab, and select the source data 
field from the adjacent pull-down list. 

4. Select one of the four methods of colour scale definition:

• RGB Interpolation - interpolates between two colours in 
Red:Green:Blue colour space.

2. Specific ranges or attributes of the dataset can be selected with the 
adjacent Data Conditioning button, as well as null values removed. See 
Field Data Conditioning Tool for detailed information on this tool. 

3. Specify a colour lookup table from the first Edit Colour Scale button: this 
will open the Colour Scale dialog.
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• HSL Interpolation - interpolates between two colours in 
Hue:Saturation:Luminosity colour space.

Thickness Modulation

3D Lines displayed as 3D Tubes (not Lines) can have their thickness modulated 
by a field, using the controls under the Appearance tab.  

1. Enable the 3D Tube style from the pull-down list.

2. Enable the Modulate thickness option.

3. Enter the desired minimum and maximum thickness in the From and To 
areas.

5. Select the field to thickness modulate by from the associated pull-down 
list.

For the RGB and HSL Interpolations, set the first and last colours of the 
colour scale by selecting the Colour Browse buttons at the bottom or top 
of the colour bar. When clicked, a standard Windows colour 
selection dialog is displayed allowing colour specification. These can be 
reset by clicking the Set Default Colours button.

• Look Up Tables - the standard look-up table formats are supported 
and are installed as part of your Discover 3D installation. These can 
be created or edited using the Colour Look-Up Table Editor (see 
Using the Colour Look-Up Table Editor).

• A custom Legend created using the Legend Editor (see Using the 
Legend Editor).

5. Specify a non-linear mapping of the data, such as histogram or log, by 
selecting the Edit Colour Mapping button. This can assist in achieving an 
even stretch of the colour scale across the data range. See Advanced 
Colour Mapping for more details.

6. Press OK twice to apply. 

4. Advanced size mapping options are available from the adjacent button 
which opens the Data Mapping dialog. See Advanced Colour Mapping for 
more details.
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Colour Filling Line Profiles

Lines can also be colour filled under the Fill tab.  This is similar to applying a 
colour fill to ‘Stacked Profiles’ in 2D (see the Table Utilities>Create Stacked 
Profiles section of the Discover Reference Manual), but with the 2D profiles 
displayed in the 3D space.

An example might be displaying the copper results of a prospect-scale soil 
sampling program as 3D Lines, and colour filling all sections of the profiles above 
a certain anomalous copper value.

Copper soil profiles colour filled above an anomalous value.

To colour fill your 3D line profiles:

1. Ensure the target data field is set as the Z field in the Fields tab, with no 
offset field assigned.

2. Enable the Show Fill option in the Fill tab.

3. Select to colour fill either above or below a base level.

6. Specific ranges or attributes of the dataset can be selected with the 
adjacent Data Conditioning button, as well as null values removed. See 
Field Data Conditioning Tool for detailed information on this tool. 
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4. Define the Base level position.  This can be a user set value (eg 50ppb) 
or a number of Data options based on the Z value of the line.  This 
includes the minimum, maximum and average data values. 

5. Enable the Constant colours option, and set the colour using the 
appropriate button.

6. Press Apply or OK to visualise the colour fill.

Decimation

Your dataset can be decimated using the options at the bottom of the Fields tab. 
The Decimation or station selection options allows the rendering performance of 
Discover 3D to be improved when dealing with very large datasets. A number of 
decimation options are available, including Fixed rate (where you specify a 
sample ‘skip’ factor) and Compression.

Note If a Scale or Translate factor has been applied to the Z field, and/or an Offset 
field set, the User Defined Base value will need accommodate these 
modifications.
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11 Working with Directional Vectors
A Directional Vector data object type is available in Discover 3D, designed to 
display vector and tensor data:

A 3D vector is defined by its origin and the x, y, z components or an origin with 
amplitude, dip and azimuth. The first is used to visualise vector magnetometer 
data and the second for dip and strike style measurements. 

A tensor on the other hand can be thought of as a collection of three vectors all 
located at the same origin.

Discover 3D uses a database to provide the X, Y, Z coordinates and component 
fields. The direction of the vector can be defined by rotation angles (origin and 
rotations), requiring two angles – a Y-axis rotation and a Z-axis rotation. 

An example of 3D Vector series with modulated colour and size applied.

Use the Display Directional Vectors tool from the Data Objects toolbar, or the 
Display>Directional Vectors menu item to display data already open in the 3D 
window.
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Changing Directional Vector Display Properties

The display of directional vectors is controlled from the Directional Vectors 
Properties dialog. To display the Directional Vectors Properties dialog 
highlight the Directional Vectors branch in the Workspace Tree and select 
Properties from the right-mouse click shortcut menu. The Directional Vectors 
Properties dialog contains eight tabs to modify or control vector data in the 
Discover 3D window:

• Vector Tab

• Lines Tab

• Origin Tab

• Components Tab

• Tail Tab

• Head Tab

• Colour Tab

Clicking the Apply button will apply the chosen options to the display. Selecting 
the Auto Apply option will automatically update the display after every change. 
For large datasets, turn off Auto Apply so that multiple changes are applied at the 
one time rather than waiting for the display to redraw between each change.

Vector Tab

The following parameters can be controlled with this dialog:

Mode

• Vector rendering: When rendering vectors, define the origin coordinate 
and the components. The components can be sourced from different 
fields.

• Tensor rendering: When rendering tensors, define the origin coordinate 
and up to three sets of components (one for each vector in the tensor). 
The components for each vector in the tensor must be sourced from a 
single field. It follows that field needs to be multi-banded.
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Data source

Click the box and select how the vectors are defined. A vector can be defined by 
two points in space (origin and head positions). In this case the ‘components’ 
specify an additional point in space. It can be defined by vector components 
(origin and components) where each component specifies the displacement of 
the head from the origin in a certain dimension. Finally, the direction of the vector 
can be defined by rotation angles (origin and rotations). In 3D this requires two 
angles – a Y axis rotation and a Z axis rotation. In 2D this requires a single Z axis 
rotation.

In the first two cases, the length of the vector is defined by the specification of the 
origin and components. In the last case the length remains undefined and will 
initially be assigned a unit length.

Centre the vectors on the origin position

Moves the origin and head positions after the vector has been defined so that the 
vector is centred on the origin position. This is useful when displaying tensors and 
will result in the familiar tensor ‘hedgehog’ display.

Reverse the head and tail positions

As a final processing step, reverses the head and tail positions so that the head 
is rendered at the origin.

Apply global axis scales to the vectors

Generally we want to see vectors displayed in isotropic space. If this option is ‘off‘ 
then regardless of the scaling of the X, Y or Z axes, the vectors will always be 
displayed in isotopic space. If turned on the vectors will be scaled along with the 
space.
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The Vector tab dialog specifying the mode and data source.

Lines Tab

Lines selection dialog
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The Lines tab provides data subsetting control. Select the Lines dataset (if more 
than one is open) from the Dataset pull-down list. 

Select the lines to display in the 3D window from the Line Selection list. Use the 
arrows to select or deselect lines by moving them between the Hide and Display 
windows.

Origin Tab

The source data for the origin of the vector or tensor are defined on the Origin 
tab dialog.  Specify the X, Y and Z fields if these have not been automatically 
selected for you. The optional offset field defines an additional offset which is 
applied to the Z coordinate by simple addition. If the vector components are 
defined as an additional coordinate then this offset will be added to the Z 
coordinate of the component data as well.

The Origin tab for the allocation of the spatial fields

You can quickly select every 2nd line from the dataset by using the subset 
arrows button.  At 1 this selects every line, 2 every second, 3 every third line etc.

Alternatively, use the button to make a map window selection of point data to 
display.
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Decimation

On the Origin tab, the Decimation or station selection options allows the 
rendering performance of Discover 3D to be improved when dealing with very 
large datasets. A number of decimation options are available, including Fixed 
rate (where you specify a sample ‘skip’ factor) and Compression.

Components Tab

The Components property tab allows you to define the data source for up to 
three vector components or the data source for up to three vectors of a tensor.

When rendering a vector select the field  combination for each of the components. 
If specifying rotations the X field buttons will be grayed out. 

When rendering tensors you can specify the components or rotations for up to 
three vectors which comprise the tensor. 

The Field Data Conditioning button adjacent to each of the field selection lists 
opens the Field Data Conditioning dialog. This dialog allows the selected field 
to be transformed via a number of methods:

• It is of most use for applying a scaling factor to the Offset field, as it is 
unlikely that the magnitude of the offset field (e.g. an assay or geophysical 
field) will be comparable to the Z field. 

• It may also be useful in applying a Translation factor to your Z field when 
data is coincident with a draped aerial photo (and therefore partially 
obscured: e.g. translating the data by 2m above the Z field value.

For more information on data conditioning, see the Field Data Conditioning Tool 
section in this chapter.

Specific ranges or attributes of the dataset can be selected with the adjacent 
Data Conditioning button, as well as null values removed. See Field Data 
Conditioning Tool for detailed information on this tool. 
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The Components tab dialog for specifying the X, Y and Z components of the vectors.

The Components tab dialog for specifying the Y and Z rotations of the vectors. 
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Length Modulation

The total length of the vector or tensor will be determined by the choice of 
components or set to a unit length if the components are defined by angles. For 
display purposes this is usually inappropriate and so the length of the vector can 
be set, scaled and modulated in a variety of ways. 

On the Components property tab the total length of the vector/tensor can be set 
to:

• Fixed Value – with user defined scale and length.

• Defined by Component data – calculated from input components with 
user defined scaling.

• Defined by field – length of each vector is defined in another dataset field 
using the absolute value with user defined scaling applied.

• Modulated by field - length of each vector is defined in another dataset 
field mapped to a user entered maximum and minimum length and 
scaling.

Tail Tab

The Tail tab page allows you to define if the vector tail is shown as a Line or 3D 
Tube.

The style of the Line or the 3D tube shape is set under the Line Style or Tube Style 
button.

In rotation mode, the adjacent Pi button opens the Rotation Parameters dialog.  
This allows the direction of rotation to be altered (for instance to orientate 
positive dip values downwards, set this to -1 to reverse the angle direction).  The 
angle units can also be set to radians or a fixed offset applied.

Specific ranges or attributes of the dataset can be selected with the 
adjacent Data Conditioning button, as well as null values removed. See 
Field Data Conditioning Tool for detailed information on this tool. 

Advanced size mapping options are available from the adjacent button 
which opens the Data Mapping dialog. For more information, see 
Advanced Colour Mapping.
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If you are rendering a tensor then there will be three buttons allowing you to set 
the colours of each vector in the tensor individually. This is useful when rendering 
tensor ‘hedgehogs’ as the X, Y and Z vectors can be rendered using a different 
colour or style. 

The thickness of the tail can either be a fixed value or it can be proportional to the 
length of the tail. In this case you must specify the minimum and maximum 
thickness values. Thickness modulation is only available when rendering the tails 
as tubes.

Head Tab

The Head tab page allows you to specify both the size and the rendering style of 
the head.

There are two rendering styles: 

• Display at tip - the most common style where the head symbol will be 
rendered at the tip of the vector. 

• Display tail to tip - the tail of the vector is not displayed and the head is 
rendered at the origin position and stretched over the length of the vector. 
You can use this option to create a ‘solid’ vector display.

When activated the Anchor at head tip check box option will ensure the tip of the 
head coincides with the head of the vector, hence the head symbol will not 
“lengthen” the vector. If this option is turned off the symbol is rendered beyond the 
end of the vector. 

The head can be rendered using a variety of symbols listed below. Some of these 
symbols are simple line-work, others are flat filled polygons and others are 3D 
shapes. Only the 3D shapes use lighting.
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The Vector head symbol style options list.

If you are displaying tensors and you choose the Tail to tip style option then only 
the Diamond 3D symbol option is available from the list. In this case a diamond is 
constructed from the three vectors of the tensor. The diamond is centred on the 
origin in this case. 

The head size can either be a fixed size, or it can be proportional to the length of 
the tail. In this case you must specify the minimum and maximum size values.  
The size can also be modulated by a dataset field.

Advanced size mapping options are available from the adjacent button which 
opens the Data Mapping dialog.

Specific ranges or attributes of the dataset can be selected with the adjacent 
Data Conditioning button, as well as null values removed. See Field Data 
Conditioning Tool for detailed information on this tool. 
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Colour Tab

The Colour tab dialog of Directional Vector Properties.

The Colour tab page allows you to define the colour modulation setting for both 
the tail and the head individually.

Colouring options for the Vector/Tensor Tail and Head include: 

• None - the element (either tail or head) will be rendered using the line 
style properties defined in the Tail tab dialog.

• By Length - the colour of the head or tail is modulated by the length of the 
vector. Data mapping can be applied but note that the mapping dialog will 
only be able to display statistics of the data in this case if the vectors have 
already been displayed. Prior to this no length information is available.

• By Field - choose any field in the loaded database to colour modulate the 
tails and heads by. Data conditioning can be applied to the field and a data 
transform and mapping must be specified. 

The colour scale used and colour mapping for modulating by length or a field, 
can be set under the respective buttons for both the head and the tail.
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Specific ranges or attributes of the dataset can be selected with the adjacent 
Data Conditioning button, as well as null values removed. See Field Data 
Conditioning Tool for detailed information on this tool. 
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12 Displaying Gridded Surfaces in 3D
Discover 3D allows gridded surfaces created with Discover (Surfaces>Create 
Grid) or Discover 3D (Grids>Surface Gridding) to be displayed and modified in 
the 3D environment in association with other data sets (e.g. drillholes, imagery, 
etc). Surfaces may represent topography, geochemistry, geophysics, depth-to-
basement modelling, etc., with a wide range of supported grid formats (see 
Supported Grid Formats).

Initial view of a 3D magnetics surface

In this section:

• Supported Grid Formats

• Loading a Grid into 3D

• Grid Flipper

• Creating a Grid Legend

• Grid Groups and Surfaces Branches

• Viewing Grid Information

• Changing Surface Display Properties

For information on creating surface grids with Discover 3D, see Creating Gridded 
Surfaces. For information on creating grids with the Discover Surfaces module, 
refer to the Discover User Guide.
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Supported Grid Formats

A wide range of industry-standard grid formats are supported and can be 
imported for use in Discover 3D. Compatible grids include:

Loading a Grid into 3D

The easiest way to display a gridded surface in 3D is to have it open in MapInfo/
Discover, and use the Discover 3D>View Surface in 3D tool (see Displaying 
Surfaces in 3D). Alternatively, you can drag-and-drop surface files into the 3D 
window from File Explorer.

Gridded surfaces can also be opened from directly within Discover 3D by adding 
a Surface branch to the Workspace Tree and browsing for the target grid. There 
are three methods of creating a Surface branch:

Double click on this Surface branch to open the Surface Properties dialog.

ASEG GXF (.GXF) Landmark (.GRD)
Band Interleaved by Line (.BIL including .HDR) MapInfo grid (.MIG)
Encom grid (.GRD) Minex (.XYZ)
ERMapper (.ERS) Surfer ASCII (.GRD)
ESRI/Arc Binary (.ADF) Surfer binary (.GRD)
ESRI/Arc ASCII (.ASC) USGS (.USG)
Geopak (.GRD) USGS DEM (.DEM)
Geosoft (.GRD) USGS SDTS (.TAR)

Vertical Mapper (.GRD)

• Using the Display Surface button.

• Using the Display>Surface menu option.

• Right-clicking on the 3D Map branch in the Workspace Tree and selecting 
Display Data>Surface.
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Surface properties dialog with the File Open button highlighted

Use the File Open button within this dialog (middle of the dialog) to browse for 
the target grid file. Access to a range of different grid formats is possible (see 
Supported Grid Formats). Once a grid file is specified and the Open button is 
clicked, a preview of the image is displayed in the right of the dialog.

Grid Flipper

Note Control changes made in the Surface Properties dialog can be invoked 
immediately they are changed if the Auto-Apply option (at the base of the 
dialog) is enabled. This option allows real time manipulation of imagery 
enhancement such as shading, colour changes etc. 

If experimenting with the display options of a large grid, disable the Auto Apply 
option to prevent having to wait for the 3D Display to update/redraw after each 
change. Instead use the Apply button when the previewed image is satisfactory.

Within the Discover 3D window, the Grid Flipper allows the view to be rapidly 
switched between any open grid surfaces within a single Surface group (see 
Grid Groups and Surfaces Branches), i.e. multiple surfaces need to have been 
added to a single Grid Group as for example 3D Depth or Pseudocolour 
Surfaces. This tool can be accessed via right-clicking on the Surface branch in 
the Workspace Tree and choosing Open Grid Flipper, or by selecting 
Tools>Grid Flipper. It requires multiple grid surfaces to be available in the 
selected Grid Group before being enabled.
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Grid Flipper dialog

Three modes are available once the Activate button is pressed:

Creating a Grid Legend

A floating Colour Bar can be added to the 3D display and referenced to a grid 
surface, allowing easy visualisation of the relationship between colours and 
numeric data ranges. This is detailed in the Floating Colour Bar section of the 
Discover 3D Interface chapter for further information.

• Manual mode allows grid selection either via Previous and Advance 
buttons, or through the pull-down list.

• Continuous mode will flip through each grid in turn with a user specified 
delay. The delay control has 2 time types: fps (flips per second) and spf 
(seconds delay per flip).

• Strobe mode flips to the next grid and then back to the starting grid again. 
The delay control has two time types: ‘fps’ (flips per second) and ‘spf’ 
(seconds delay per flip).
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Example of a Floating Colour Bar linked to a DEM grid surface. A colour scale indicating 
elevation values is displayed

Grid Groups and Surfaces Branches

A Grid Group consists of a variable number of surfaces, image layers and 
vectors (such as contours) that make up a surface display. The structure of the 
display is shown in the tree view of the dialog. By selecting any item in the tree, 
the displayed controls change to show the properties of the selected item. 

A view is rendered by drawing all surfaces from the bottom branch of the tree 
upwards. Surfaces at the top of the tree obscure surfaces lower down the tree 
(although the transparency control can modify this).

There are four types of image surfaces that can be draped over a 3D Depth 
Surface and each can have one or more layers. These types include:

• Pseudocolour with Colour and Intensity layers.

• RGB surface has Red, Green, Blue and Intensity layers.

• Located Bitmap surface contains a layer that is assigned an ER Mapper 
algorithm/ECW.

• Contour surface with a Vector layer.

Surfaces branches can be moved up or down the Grid Group to control the draw 
order. Visibility of individual surfaces and layers can also be turned on or off from 
the tree branch shortcut menu.
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Image surface control.

The dialog allows you to directly add one of the supported display types to the 
surface tree by selecting one of the following buttons:

Other buttons in the control area provide the following functions:

Add a new Pseudocolour surface to the surface tree.

Add a new Contour surface to the surface tree.

Add a new Red:Green:Blue surface to the surface tree.

Add a Located Bitmap surface (ER Mapper) to the surface tree.

Add a 3D Depth Surface to the surface tree.

Add a new surface to a view.

Delete the selected surface.

Duplicate the selected surface.
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The surface tree provides access to properties of the various branches of 3D 
Surfaces. If you select the Pseudocolour layer and right click a shortcut menu is 
presented as shown.

Options provided by the shortcut menu are:

Move the selected surface up or down.

Display Information (location extent and row/column details) about the selected 
grid.

Turn On
Turn Off

A selected plot, surface or layer can be switched on 
or off.  If switched off, it will not be rendered.

Move Up
Move Down

Move Up and Move Down duplicate the 
functionality of the arrow buttons shown above.  
Move surfaces up to ensure they overdraw 
surfaces lower down.  Contours should generally 
be at the top of the tree.

Duplicate Surface Duplicates a surface. Duplication of a surface 
copies all the attributes of the original surface and 
layers. 

Delete Surface Deletes the selected surface.  Identical function to 
Delete button shown above.
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Transparency and Colour-Intensity Balance

There are Transparency and Colour–Intensity balance slider controls on the 
Surfaces Properties dialog. Transparency is not available for contour surfaces. 
Colour-Intensity balance is not available for ER Mapper algorithm surfaces and 
contour surfaces.

Located Bitmap Surface Change the surface type to ER Mapper Algorithm 
or ECW file. An existing ER Mapper algorithm 
(.ALG) or .ECW file can be used to display an 
image layer. Refer to Draping Located Images for 
additional information

Pseudocolour Change the surface type to Pseudocolour.

The Pseudocolour image representation uses both 
colour and intensity control branches to render an 
image. The colour of the image is determined by a 
look-up table specified in the colour branch. This 
form of image display is the default style. Refer to 
Pseudocolour Surfaces.

Red:Green:Blue Change the surface type to RGB.

This form of display uses multi-band grid files (or 
multiple grid files) to present images. Examples of 
this form of display include satellite or digital 
photography. Refer to RGB Image Surfaces.

Contours Change the surface type to Contour.

Contours can be added to image maps to enhance 
displays. Refer to Surface Contours for additional 
details.

3D Surface Change the surface type to 3D Surface.

Export to EGB
(only available for 3D Surface)

Opens the Located Image Settings dialog 
allowing the selected  surface to be saved as a 
Georeferenced Image at a user-defined resolution 
and image type.
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Each surface is combined with the underlying surfaces using a transparency 
transform that allows underlying imagery to be seen through overlying surfaces. 
To ensure a surface completely obscures underlying surfaces, set the 
transparency value to minimum (opaque). To view underlying surfaces and hide 
the selected surface, set the transparency value to maximum (invisible).

Pseudocolour and RGB surfaces have colour-intensity balance slider controls on 
the Surfaces Properties dialog. This allows you to easily adjust the balance the 
contributions the colour and intensity layers make to the final image. When set to 
minimum, colour and intensity are in balance. As the balance level is increased 
the intensity is progressively washed out and the colour saturation increases. 

Pseudocolour Properties dialog for a 3D surface display

Select the button to specify a grid to be assigned to a Pseudocolour draped 
surface. Note that Colour and Intensity levels appear beneath the 
Pseudocolour surface.

Texture Mapping

Within Discover 3D a computer display method called ‘texture mapping’ is used 
to quickly render images that drape over a surface. A compromise is made 
between the quality (resolution) of the drawn image and the speed of drawing. An 
upper limit on the resolution that can be physically supported is imposed.

This limit is imposed by the installed graphics card drivers not by the software or 
its OpenGL display system. An upper display limit (not data limit) of 1024 x 1024 
was found to be the maximum reliable texture size several years ago. Limits 
imposed by modern graphics cards are now higher.
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Two options within Discover 3D are provided to control texture map size:

• One method uses a simple Texture Quality setting in the properties 
dialog of the 3D Surface. This allows Low/Medium/High Quality settings.

• The second method provides greater control and is available via the 
texture size option on the System tab of the Options dialog in the 
Discover 3D menu in the 2D interface.

Viewing Grid Information

Grid information resulting from selecting the button on the Grid Display dialog

It is often useful to obtain information about a grid prior its use in a display. The 
Grid Information button can be used to obtain statistics that detail the location, 
projection and grid attributes.
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Changing Surface Display Properties

• Scaling Grids

• Grid Compression

• Offsetting a Grid

• Rendering Surfaces

• Pseudocolour Surfaces

• RGB Image Surfaces

• Draping Located Images

• Surface Contours

Scaling Grids

You may wish to exaggerate the vertical scale of a surface by changing the Z axis 
scaling. This can be done on the Surface Properties dialog by either manually 
entering a Scale value or by using Scale slider bar. For application of larger 
scaling factors, entering a Multiplier will multiply the Scale factor by this value. 
Note that when adjusting a Z Scale, this applies only to the 3D Surface of that 
surface layer.

Once a scale is determined it can be locked by enabling the Lock scale + offset 
box. This will ensure that introducing other objects (like lines, other surfaces or 
graphical objects) does not readjust the scale.

Note Surface scaling applies an exaggeration to the surface, by subtracting the 
minimum values of the grid before mulitplying:
Zfinal = ((Zinitial - Zmin) * Zscale) + Zmin + offset
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Surface dialog controls for scaling applied

If you want to adjust the Z scaling of all surfaces in a view, this can be done from 
the Scale tab of the 3D Map Properties using the Z slider bar. 

Adjusting the 3D Scaling item in the 3D Map Properties dialog
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Grid Compression

Another control on the Surface tab allows compression of grid surfaces. This 
feature permits Discover 3D to display and manipulate large, complex surfaces 
quickly with little loss of surface detail. When Discover 3D displays surfaces, it 
applies a display algorithm that by default allows the presentation to be 
exceptionally fast but also accurate in its representation of a surface.

The Compression Mode pull-down list provides three compression options:

• None - no compression is performed and the grid is displayed at full 
resolution.

• Constant - a simple compression algorithm decimates the grid in X and Y. 
See Constant Compression.

• Variable - attempts to retain the boundary of the grid, including internal 
holes. See Variable Compression.

Once a mode is selected, click the adjacent Properties button to open the 
relevant compression controls.

Constant Compression

A simple compression algorithm decimates the grid in X and Y. The decimation 
parameters can be based on the System size, User size or User decimation. 
The final two options require user definition of parameters.
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Line display of a grid illustrating Constant compression

Variable Compression

Variable compression uses the Tomek algorithm, which variably adjusts to the 
data; this attempts to retain the boundary of the grid, including internal holes. The 
compression level is adjusted via a slider bar and three clipping levels are 
available:

• Complete - the grid boundary and holes are preserved,
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• Partial - the grid boundary and holes may not be perfectly preserved, and

• None - the grid is rendered as a convex hull with no holes preserved.

The degree of compression can also be assessed by displaying the Lines 
(triangulation) used in the surface display.

It is recommended you maintain surface compression above 80% for best data 
results. If you want less than 80% compression, switch all compression off. 

Line display of a grid illustrating Variable compression

Offsetting a Grid

The position of a grid surface in space depends on the data values assigned to 
the Z field of that surface. For example, the effective elevation of a topography 
surface may be, say 300 metres. However, it may be desirable to place a soil 
geochemical surface above the topographic surface and the amplitude or Z 
values of the geochemical surface may be for example, 2,000.

You can control the Z offset of surfaces by entering a specific offset amount in the 
Surface tab, or by interactively raising or lowering the surface using the slider bar. 
Alternatively, alter the Z offset automatically to the grid surface minimum, 
maximum or average value by selecting the appropriate check box. 
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Scale and Offset controls in the Surface Properties dialog

Once an offset is determined it can be locked by enabling the Lock scale + offset 
box. This will ensure that introducing other objects (like lines, other surfaces or 
graphical objects) does not readjust the offset.

Using the Stack, Scale and Reset buttons of the Plot image dialog

Note To automatically allow these surfaces to be brought together and stacked for 
viewing, select the Grid Group branch of the image tree and click the Stack 
button followed by the Apply button. Similarly, to present the surfaces with 
suitable scaling for the display window chosen, you can click the Scale button. 
The Reset button returns the surfaces to their initial default scales and offsets. 
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The Stack button effectively adjusts the surface offsets to force all surfaces to lie 
within the display area. If you need to slightly move them up or down from their 
recomputed positions use the Z Offset controls (see above).

The Scale button operation adjusts the vertical exaggeration of the surfaces to 
optimally suit the 3D display. If adjustments to the exaggeration are still required, 
use the Z Scale slider controls (see above).

Rendering Surfaces

The 3D Surface tab of the Surface Properties dialog has three options for Fill, 
Fill + Lines and Lines. These options relate to displaying the surface as a filled 
surface, or with the surface being presented as the triangulated surface when 
compression is used. By displaying the Line option only, you can make a 
judgement about the level of grid compression that is being used by the Surface 
Compress option (see above). The grid display compression tends to have few 
triangular facets in a presentation in low gradient areas and a high number in 
steep gradient areas. An example of Line display is shown below.

Lines displayed instead of the filled surface to assess the grid compression

On the top level branch in Surfaces, there are controls to:

• Display Null Values as transparent – any null values in the grid, which 
normally appear as white background, will be automatically set to 
transparent

• Apply Nearest Neighbour Smoothing – applies a real time smoothing 
filter 
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Pseudocolour Surfaces

A pseudocolour surface consists of one or both of:

• A Colour layer in which a predefined RGB or HSL colour table is used to 
render the data from a single banded grid or a single band of a multi-
banded grid. Colours can be assigned from user-specified RGB or HSL 
colour space stretches or from colour look-up tables which can display 
any colour combinations including greyscales. For more information see 
Controlling the Colour Layer.

• An Intensity layer that introduces a greyscale shading scheme based on 
an artificial sun azimuth and inclination. This feature is a powerful method 
of introducing colour gradients to an image to highlight trends and patterns 
in the data. Usually the grid used as a data source for the intensity layer 
will match the colour layer, but a different grid or grid band may be used if 
required. Note that with the Auto-Apply option enabled, real time sun 
shading is available in the displayed image plot as well as the preview. For 
more information see Controlling the Intensity Layer.

To create a Pseudocolour image:

Note 3D Surfaces are always smoothed, instead display the layer as a psuedocolour 
surface along with the 3D surface to display unsmoothed.

1. Create a Surface branch in the Workspace Tree as described above.

2. Highlight the created Surface branch and access the Properties dialog.

3. Click the Pseudocolour button to create a new Pseudocolour branch in 
the image tree. Select the Grid Selection button to specify a grid for both 
the Colour and Intensity layers (see Supported Grid Formats).

4. Once a grid is specified, a Pseudocolour preview image appears in the 
right side of the Surface Properties dialog. 
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Controlling the Colour Layer

Select the Colour branch  in the surface tree to show the layer colour properties. 

Colour layer controls for the Pseudocolour image

The properties available include:

• Specify the upper and lower colours and interpolate a specified number of 
colours in RGB colour space. 

• Specify the upper and lower colours and interpolate a specified number of 
colours in HSL colour space. 

• Load a colour look-up table that defines the RGB colours. The number of 
colours in the table is defined by the number of colour entries in the LUT 
file. This option can also be accessed from the pull-down list to the right of 
the Advanced Colour Properties button. If there are no colour tables in the 
list, Discover 3D has failed to identify any LUT files on your system.

Data Source – You can select and load a grid using the Load button. In most 
cases it is sufficient to load a grid from the Pseudocolour surface property page 
which loads the same grid into the colour and intensity layers. If the grid has 
multiple bands, the required band can be selected.

Colour – There are three methods of colour table specification, all of which can 
be accessed via the Advanced Colour Properties button:
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A histogram of the data distribution is displayed. The histogram shows the 
frequency of data values in the grid as well as the colour of the data values. The 
cumulative value of the histogram is also shown as a black line on the histogram 
graph. The transform from data to colour space is defined by the transform line 
that is shown on the histogram. By modifying the transform you can change the 
colour distribution across the image. Three simple options are available to do this:

Controlling the Intensity Layer

The Intensity layer of a Pseudocolour image is used for applying shading to the 
display. The shading applies a greyscale colour modulation to the pseudocolour 
surface.

• Linear Colour Mapping – Click the button to enable linear colour 
mapping. 

• Band Pass Mapping – Click the button to apply a bandpass filter to the 
transform (either Linear or Histogram). The percentage or value limits of 
the bandpass range can be specified in the Colour Mapping dialog 
accessed via Advanced Colour Mapping button (below). All data values 
outside the specified range will be assigned the minimum or maximum 
colour value and the colour stretch will then be restricted to the data within 
the bandpass. Bandpass mapping replaces a linear transform, but can be 
combined with a histogram colour mapping (as described below).

• Histogram Colour Mapping – Click the button to apply a histogram 
equalised colour transform.

More advanced data transform controls are accessed via the Advanced Colour 
Mapping button. This opens the Colour Mapping dialog, which can also be 
opened by double-clicking in the histogram preview area. For more information, 
see Advanced Colour Mapping.



12 Displaying Gridded Surfaces in 3D 235

Pseudocolour Intensity control dialog

Properties available include:

Intensity – The shading control of an intensity layer is interactive. A red cross 
displayed in a mapped ‘shade ball’ is used to control the graphic location of 
azimuth and altitude of a virtual sun. These two angles control the sun shading 
process. Specific angles can be entered in the appropriate fields beneath the 
‘shade ball’. To graphically operate, select the red cross with the cursor and with 
the left mouse button pressed move the cross to an azimuth/altitude combination 
that best enhances the features required. The image displayed in the Preview 
window updates in real-time. If the Auto-Apply option is enabled, the main 
display window is updated in real-time similarly to the Preview area.

Data Source – You can select and load a grid using the Load New Grid button. 
In most cases it is sufficient to load a grid from the Pseudocolour tab in the 
Surface Properties dialog which loads the same grid into the colour and 
intensity layers. If the grid has multiple bands, the required band can be 
selected.

Note If the Auto-Apply option is enabled, adjustments to the shading intensity can be 
viewed in real-time.
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The intensity of the shadow can be enhanced using the Shadow Depth slider bar 
and the Enhance setting. The shadow depth option can increase or decrease the 
intensity of the shadows and the result is displayed after you move the slider 
control. For a large grid, this update may take a few seconds. The Enhance 
setting can improve the shadow intensity of grids that have a very high dynamic 
range – for example, derivatives of magnetic data. Generally, this setting is not 
required.

The Show Highlight option allows the application of a second virtual sun/light 
source. This allows the lightening of desired shadow regions and further 
lightening of illuminated regions. The graphical location of the azimuth and 
altitude of this Highlight source is represented by the yellow cross in the ‘shade 
ball’. The Highlight positioning can only be altered by entering parameters into 
the Highlight Azimuth and Altitude fields. 

RGB Image Surfaces

Red:Blue:Green (RGB) imagery surfaces are used when more than one band of 
data is to be used in the image display. RGB colour mode uses the fact that Red, 
Green, Blue and Intensity colour receptors are used to display up to four separate 
bands or layers of data at the same time. 

Areas in an RGB image that appear predominantly red would have high values in 
the red layer of data and low values in the other layers and similarly for the other 
colours. Interpretation becomes more difficult when there are high values in two 
or more layers of data at the same time because composite colours are created 
that are not intuitive to understand. If the same image is loaded into each of the 
Red, Green and Blue layers the resulting image appears as shades of grey.

The RGB image format is especially useful for presentation of multi-band 
datasets such as Landsat or Spot satellite imagery or for geophysical 
interpretation, the multi-band data of radiometrics (Potassium, Uranium and 
Thorium) can be mapped to the various colours.

To create a Red:Green:Blue image:

1. Create a Surface branch in the Workspace Tree (see Loading a Grid into 
3D).

2. Highlight the created 3D Surface branch and display the Surface 
Properties dialog.

3. Select the 3D Surface in the Grid Group (see Grid Groups and Surfaces 
Branches).
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The Red:Green:Blue layer has Red, Green, Blue and Intensity layers associated 
with it. By default, the Intensity layer is switched OFF (see Controlling the Intensity 
Layer).

Example of the Green Layer controls of a Red:Green:Blue image

Branches – Each of the Red, Green and Blue branches need to have their 
individual colour distributions adjusted according to a Linear, Band Pass or 
Histogram Equalisation process. Refer to Controlling the Colour Layer for details 
on this. In each case the look-up table appropriate to the colour layer is fixed.

4. Click the grid selection button to choose the required input multi-band grid 
(see Supported Grid Formats). Discover 3D assigns grid bands to the 
Red, Green and Blue layers by default.

5. Once a grid is specified, select the Red:Green:Blue layers to display the 
properties of the relevant layer. A preview image appears in the right side 
of the dialog.

Data Source – Select and load a grid using the Load button. In most cases it is 
sufficient to load a grid from the RGB Surface Properties tab that loads a multi-
banded grid and assigns grid bands to the red, green, blue and intensity 
branches. If the grid has multiple bands, the required band can be selected.

Note You can only preview the combined RGB surface from the RGB Surface 
Properties tab (or the main plot window if Auto-Apply is enabled). Select the 
surface and ensure the Show Preview setting is enabled.



238 Encom Discover 3D User Guide

Draping Located Images

The Add Located Bitmap Surface option allows GeoTIFF, ERMapper Algorithm 
(.alg) , JPEG 200 (.jp2) and ECW georeferenced images (as well as images with 
a MapInfo Professional TAB file) to be draped over a grid. 

Discover 3D makes use of an ER Mapper software plug-in that displays ER 
Mapper algorithms and imaging including ER Mapper Compressed Wavelet 
(ECW) imagery. Also provided with the ER Mapper software support are a wide 
range of look-up tables that can be used in colouring images in Discover 3D.

The main benefit of ER Mapper support is to provide direct interpretation of ER 
Mapper algorithms. This means the complex image processing techniques made 
available from ER Mapper can be read and displayed within Discover 3D.

To display a georeferenced image over a grid surface:

1. Create a Surface branch in the Workspace Tree.

2. Highlight the created Surface branch and access the Surface Properties 
dialog.

3. Select the 3D Surface branch and click the Add Located Bitmap 
Surface button.

4. Select the Grid Selection button and choose the appropriate file type 
(.TIF, .ALG, .ECW or .TAB). Browse for the appropriate file and click Open 
when selected. Alternatively, a URL can be entered from which to 
download an ECW image.
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Bitmap selection and preview of the image

Once an image has been loaded a preview of the surface is displayed. Click the 
Apply button to redraw the Map.

Note that an ER Mapper algorithm cannot be modified. You cannot modify the 
histogram, colour look-up tables or data content. However, you can zoom, roam 
and pan in the same manner as other displayed images and maps.

Surface Contours

Grid files can be displayed in a Grid Group as an imaged contour vector layer. 

Note Contours can be also be displayed as vector data. Create contours for the grid 
surface using the Contour a Grid option in the Discover Surfaces module. Then 
use the Discover 3D>View Map Objects in 3D tool to convert these contours 
into a 3D vector file. This option is recommended as it prevents the pixilation/
rasterization of contour lines as apparent with a Vector Contour branch.
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To create a Vector Contour branch:

Controlling the Contour Layer

A large range of controls for contours is available. They can be displayed as 
monochrome or coloured (according to a colour mapping scheme) and the 
contour interval and dropout can be specified. The contour dialog is shown below:

Vector layers (such as contours) and image layers are treated separately 
because an image occupies all pixels of its display area and therefore it can hide 
any vector layers drawn below it. Consequently, the drawing order of images 
and contours is important. To ensure vectors are visible, they should lie ABOVE 
images in the plot tree. The Move Up and Move Down buttons (or shortcut 
menu options) should be used to ensure the correct order is created.

Note also that Transparency and Colour-Intensity Balance slider controls are 
not available for contour surfaces.

1. Create a Surface branch in the Workspace Tree using the Surface button 
or the Display>Surface menu item. 

2. Highlight the new Surface branch and display the Properties.

3. Create a new surface using the New Surface button.  

4. Add a Vector branch in the surface tree by clicking the Add Contour 
Surface button (shown left) or clicking the right mouse button with the 
Grid Group highlighted and selecting the Contours option. 

Click the Grid Selection button to choose the required input multi-band 
grid (see Supported Grid Formats). 

5. Once a grid is specified, select the Contour layer to display the properties 
of the contours. A preview contour image appears in the right side of the 
Properties dialog. As contours can take some time to generate, disabling 
the Auto Apply option will prevent the 3D window display updating with 
any changes until the Apply button is selected.
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Contour control dialog and specifications for look-up tables

Available controls include:

Select the distribution, contour levels or save/restore from a file

Contours can be distributed linearly, logarithmically or from an external file 
defining the contour levels (a .LVL file). Contour levels can also be limited to a 
range of data specified in the First and Last contour values.

Data Source - Select and load a grid using the button. It is convenient to load a 
grid from the Contour tab of the Surface Properties dialog. If the grid has 
multiple bands, the required band can be selected.

Contour Levels - You can specify contour intervals, levels and their distribution 
from the dialog displayed when this button is selected. 
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Appearance of labels of contours

The Line styles of major and minor contours can be defined and their 
smoothness determined by one of three types of contour Line Smoothing (None, 
Akima or Bezier). 

The Major and/or Minor Labels drawn along contours can have a specific style 
and be either straight text or follow the curve of the contour (Follow baseline 
option). By default, contour labels are created relative to the gradient of the slope 
they represent, however, if you would rather they all be drawn such that the text 
is read from the base of a map, the Keep text vertical option can be used.

The density of contour labels within a map area and/or along contour lines is 
controlled by slide bars.

Contour Appearance – Control of the contour appearance and labelling is 
provided in a dialog when the appearance button is clicked.

Contour Dropout – Options are accessed by clicking the button. When contour 
dropout is applied, contours are not drawn in areas of high data gradient to 
improve the look of the final contour view. The dialog used to control dropout is 
shown here. 
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Control dialog for contour dropout and grid decimation

Parameters that can be specified from this dialog include:

Dropout Threshold – Specifies the maximum number of contours that is 
rendered in a centimetre on the page. A setting of 20 is the default that allows 
each contour line half a millimetre of page space. Decrease the setting to dropout 
contours more frequently and increase it to dropout contours less frequently.

Dropout Frequency – Specifies how contours are dropped. The default is a 
setting of two (2). If Discover 3D decides dropout should occur it will dropout every 
second contour, then three in four, then seven in eight, 15 in 16 etc until sufficient 
dropout has been achieved. A setting of 10 would dropout every 9 in 10, then 
every 99 in 100 etc.

Grid Decimation can be used to enhance redraw and refresh performance on 
large grids. It operates by using only every 2nd, 3rd etc cell/row of an image when 
drawing. The Decimation entry is always a compromise between speed of 
redrawing and image honouring. 

A Colour scale can be applied to a Contour surface by enabling the Use 
Colour option and selecting a colour scale from the pull-down list or via the 
Advanced Colour Properties dialog (shown left). A colour histogram graph is 
displayed and full control of the colour tables and colour transform is available. 
The colour controls are exactly the same as for a Pseudocolour image (see 
Controlling the Colour Layer).
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Mask – Above the Preview window is the Mask check box. It is disabled by 
default. When enabled, a contour surface will erase the grid image area before it 
renders the contours. Consequently, when multiple contour surfaces are overlain, 
the contour lines from overlapping grids do not overdraw each other. It is purely 
a cosmetic feature. However, when enabled, any contour surface obliterates 
underlying surfaces of all types and so this option generally cannot be used in 
conjunction with colour grid images.

Exporting Contours

When contours are overlaid on a grid surface, gradients of the 3D display may 
distort the contour appearance since a contour vector line may be required to 
draw across grid cells many pixels wide but which represent a constant contour 
value. 

A method of displaying ‘clean’ contours, or for use in other software, is to export 
the derived contours. The supported export formats include:

• Attributed .DXF (contour values are saved within the DXF file)

• ESRI .SHP files

• MapInfo Professional .TAB format

• MapInfo Professional .MIF format

To export the contours, use the Export Contours button  and select the desired 
output format. If a MapInfo Interchange (.MIF) or TAB format is selected, a 
Choose Projection dialog appears after clicking the Save button. This allows 
the exported file to be assigned a projection for use within MapInfo Professional 
or other software.
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13 Creating Gridded Surfaces
Discover 3D's extensive modelling capabilities include the ability to smoothly 
interpolate between 3D datasets to create gridded surfaces, using interpolation 
algorithms such as Minimum Curvature and Inverse Distance Weighting. This is 
a powerful way of constructing fault planes or water table boundaries from 
digitized drillhole intercepts.

This capability is an excellent alternative to wireframe modelling (see Modelling 
Triangulated Surfaces and Solids). Unlike wireframing, surface interpolation:

• produces a smoother and more realistic looking model between data 
points

• is not limited to the bounds/extents of the data points, so a continuous 
model can be created to cover the zone of interest

Discover 3D's Surface Gridding module under the Grids menu can support the 
following data sources:

• Feature Points, Polylines, Polygons and other objects (e.g. snapped to 
drillholes in 3D).

• 3D Points (e.g. specific downhole intervals visualized with View Intervals 
as 3D Points).

• 3D Lines

The basic gridding work-flow is described in Interpolating a Gridded Surface from 
Digitized Drillhole Intercepts, and additional detail about the options avaialbale 
from the gridding tool can be found in Using the Surface Gridding Tool.

Examples of input datasets include: 

• Snapping feature points, polylines or polygons to drillholes in 3D to 
digitise:

• particular fault or water table intercepts

• the bottom of supergene mineralisation (aided by drillhole colour 
and thickness modulation)

• a primary quartz vein/gold mobilisation system (interpreted between 
lithology colour modulation and thickness modulated assay results)
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• Querying out the intervals at the top of a heavy mineral sands layer in a 
2D drillhole project, and the viewing these as 3D Points (using the View 
Intervals as 3D Points menu in 2D).

A comparison of the modelling techniques: 1/. Initial digitised feature points snapped to 
drillhole fault intercepts in 3D 2/. Wireframing requires join lines and tielines to be created 
by the user to help define the structure 3/. Wireframing with the 3D Solid Generator creates 
a triangulated surface: the surface displays large triangular facets and is limited to the data 
bounds 4/. Using the Surface Gridding tool, a smooth grid is interpolated from the source 
feature point intercepts (there is no need for user-created tie-lines).

If there are multiple gridded surfaces generated for a body of interest (e.g. top and 
bottom surfaces), these can be converted to triangulated (TIN) surfaces and used 
to build a closed polyhedral volume.

1 2

43
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A 3D volume constructed from 2 surface grids generated from drillhole intercepts

The Surface Gridding tool can create grids in the ER Mapper (.ERS), Geosoft 
(.GRD) and Surfer Binary (.GRD) uncompressed grid formats.

Interpolating a Gridded Surface from Digitized 
Drillhole Intercepts

Digitising intercept locations

1. Load your 2D drillhole project into Discover3D using Discover3D>View 
Drilllholes.

2. Adjust the drillhole display properties to visualise the desired downhole 
data (e.g. colour and/or thickness modulation), and/or enable browsing for 
the drillholes in the datasheet window. Note that you may instead simply 
load a previously saved display setting (see Saving and Applying Display 
Settings).

3. In the workspace tree, make the feature database into which you will 
digitize Editable (i.e. either the cosmetic layer or a new feature database). 
Also make the drillhole branch Selectable.

5. Digitize the appropriate intercept locations. Using a 3DConnexion 
SpaceNavigator (see Using the 3DConnexion SpaceNavigator™) can 
help to precisely identify and snap to the intercept location in more 
complex 3D environments, and is essential when digitising polylines. 

4. Enable either the points or polylines tool in the feature toolbar. Also enable 
snapping by pressing the S key or the Snapping button.
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Digitizing the top and bottom of a heavy mineral layer in a mineral sands project as 
polylines. The red (top) and green (bottom) polylines have been digitized into two 
separate feature databases.

Interpolating a gridded surface

6. Select the Grids>Surface Gridding menu option.

7. In the Gridding Tool Input Tab, select the feature database containing the 
digitized intercepts under Input data set. Under the Fields area, select 
the Z_VERTEX option; as this will produce a grid using the elevation of 
the digitized features.

8. In the Gridding Tool Method Tab, select an appropriate method to use; 
Minimum Curvature is recommended as the initial method to experiment 
with, in order to quickly create a viable surface. Adjust the method's 
various parameters as required in the following tabs.

9. In the Gridding Tool Output Tab, specify a location and filename for the 
output grid using the Browse button at the bottom right of the dialog. If 
required, enable smoothing and clipping if required. Press Save to create 
the grid in the 3D window.
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Two gridded surfaces created from the poylines in the previous example 
(representing the top and bottom of a heavy mineral layer). Minimum curvature 
interpolation was used.

Converting grids into triangulated surfaces, and building polyhedral solids

10. Converting a gridded surface into a triangulated feature surface means it 
can be processed with Discover 3D's Advanced Editing Functions. For 
example, to use a fault surafce to clip a mineralisation solid model. 

• Open the Features>Import menu option

• In Step 1, set the type of file to import as Grid files.

• In Step 2, browse for the gridded surface created previously. Also 
specifiy an output feature database for the new triangulated 
surface: it is recommended to create a new FDB rather than add 
the output to the cosmetic layer

• In Step 3, leave the default option enabled (“Let the Import 
System...") and press Finish to create the TIN surface.

The two gridded surfaces created for the heavy mineral layer imported as two 
triangulated feature surfaces in the same new feature database

11. If multiple surfaces have been generated for an anomaly/rock unit/target, 
these can be converted into a closed TIN/polyhedral surface (i.e. a 
volume) by using the 3D Solid Generator (see Modelling Triangulated 
Surfaces and Solids).
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Loading the two feature TIN surfaces into the Solid Generator (both are in the same 
feature database)

The resulting closed polyhedral surface (volume) with the original digitized polylines 
displayed for reference.

Using the Surface Gridding Tool

The Surface Gridding tool is accessed via the Grids>Surface Gridding menu 
option. The gridding tool is controlled via a series of tab pages along the top of 
the dialog. The number of visible tabs in the dialog varies depending on the 
gridding method selected, however four main tabs (Input, Method, Grid Geometry 
and Output) are always visible irrespective of the gridding method selected. 
Operation of each tab control is described in:

• Gridding Tool Input Tab

• Gridding Tool Method Tab

• Gridding Tool Geometry Tab

• Gridding Tool Output Tab
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The Surface Gridding tool in Discover3D

On the bottom-left side of the dialog are Save, Cancel and Help buttons:

• The Save button creates an output surface as specified on the Output tab. 
The preview window does not have to complete drawing before saving the 
output grid file. If the initial appearance of the grid is satisfactory click the 
Save button and the grid is saved in the same folder as the input data 
points. The saved grid is then loaded automatically into Discover3D. 

• The Cancel button dismisses the grid tool without creating an output 
surface

• The Help button displays the on-line help.

Two additional controls at the base of the dialog determine the operational mode 
of the Gridding. The two operational modes are described below:

• Automatic mode - This is specified with the Auto Apply checkbox 
enabled and is the default behaviour. As changes to any control 
parameter are made, the gridding process automatically re-computes and 
updates the preview display. The Gridding Tool can detect when a 
parameter change has been made and will apply this change when the 
cursor is moved to another tab page or field in the dialog. 

• On Demand mode – Disabling the Auto Apply checkbox places the 
gridding tool in manual mode. No grid processing is commenced until the 
Apply button is selected or the Auto Apply mode is enabled. This mode is 
best used for situations where a number of parameters are to be modified 
prior to gridding, or the dataset is very large and the gridding operation 
may take some time. If the button is disabled then no changes are 
pending and no grid computation is performed.
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A vertical progress bar is displayed next to the preview window in both modes and 
will show the percentage progress of the gridding operation. The progress can 
also be monitored by observing the grid re-draw in the preview area. See Gridding 
Tool Preview Display for a description of the controls available.

Gridding Tool Preview Display

The appearance of the preview display can be controlled by four toggle buttons 
and a pull-down list located above the preview window.

These control buttons are:

A pop-up menu can also be accessed by right-clicking with the mouse in the 
preview window:

Note The Gridding tool will automatically switch to On Demand mode if a large 
dataset is loaded. In this mode, select a field to grid and press the Apply button 
to display the grid before proceeding beyond the Input tab page.

View input points in the preview window. Click button to remove input points 
from view.

View search ellipse in the preview window. Only available if Inverse Distance 
Gridding method is selected.

Apply a Histogram Equalisation stretch to the image in the preview window. 
This button can be used to distribute colours more evenly across the image and 
is particularly useful for data with poor dynamic range.

Display images in the preview window as either coloured or monochrome (e.g. 
greyscale from black to white). This button toggles the image between 
monochrome and colour.

 
Apply a sun illumination to the image in the preview window. This can be used 
to enhance detail within a gridded image. The sun angle is fixed from the north-
east direction.
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Preview window right-click mouse options

The Zoom and Pan controls enable the grid to be examined prior to saving. To 
zoom in (x4 magnification) on an area position the cursor over the area of interest 
and click the left mouse button. Click the left mouse button again to zoom out. The 
zoom factor can be changed by selecting the Settings menu option.

Pan a zoomed image by selecting Pan Mode and holding down the left mouse 
button. The cursor will change to a hand when in Pan Mode. When the button is 
released the image redisplays at the panned location. Other options include 
Show Value at Cursor when the cursor is placed over a grid cell and View Input 
Points to display the original data point locations. If the interpolation method 
chosen is Inverse Distance Weighting the View Search Ellipse option is enabled 
to view the search radius used to calculate the grid cell values.

Gridding Tool Input Tab

Data fields from the Input dataset are listed in the Fields (bands) to grid list. To 
change the column to be gridded select the column name so it is highlighted. 
Multiple fields (or bands) may be gridded at the same time. The data range for the 
selected column(s) is automatically displayed in the text boxes to the right and if 
the Auto Apply option is enabled the grid is regenerated for the new column. If 
the Auto Apply option is turned off then click the Apply button to display the grid 
in the preview window. To view multiple gridded fields select the field from the 
pull-down list displayed above the preview window.

Breaklines

Breakline data can be read from a MapInfo TAB file. Break lines are defined as 
multi-segment lines in which the slope is monotonically increasing or decreasing 
along each segment. Examples of breaklines include stream or river traces, 
topographic ridge lines or roadways. By incorporating break lines into the gridding 
process the output grid can be forced to conform to certain slope requirements in 
critical areas.

A sub-selection of certain Lines or Drillholes from the dataset can be selected by 
clicking the Lines button.
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The Breakline options dialog

The Breakline Advanced Options dialog enables you to browse and select an 
input TAB file. To identify the breaklines it is necessary to select a Line field from 
the TAB file. All vertices from all features with the same LINE identifier will be 
considered to be a single break line. This means that a collection of points can be 
grouped into polylines but it also means that polylines will need to have a unique 
LINE identifier if they are to be considered unique. A Z field must also be 
specified. It is assumed that the Z data will be compatible with the data field 
selected to grid. In order to define breaklines with a variable Z attribute for each 
node (or vertex) in MapInfo the data must be represented as a collection of points. 
These points must be assigned a LINE identifier to distinguish them as being part 
of a particular break line. By defining the break lines in MapInfo as a collection of 
points identified using a LINE identifier it is possible to represent complex 3D 
geometries such as streams, slope ridgelines or cliffs.

Coincident points

The Coincident points pull-down list controls the handling of multiple data points 
at the same location. Coincident points may be averaged, the first or last point 
value that does not contain a null value used, the minimum or maximum point 
value taken or all points kept.

Statistics Explorer

The Statistics Explorer is a utility for examining and understanding the spatial and 
statistical aspects of a data set. It has been designed in a way that allows for 
intelligent interrogation of a data set to help identify spatial and frequency 
relationships which may be important when choosing and configuring an 
appropriate gridding method. The operation and functionality of the Statistics 
Explorer is described in Statistics Explorer Tool.
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Data Conditioning

The Data Conditioning options enable data to be modified prior to gridding by 
applying one or more of the following processes:

• Clip Input Data - Specify maximum and minimum X and Y extents to 
conduct a data clip. The source dataset is clipped to the X and Y extents 
by checking the Apply data clip option. These values can be reset to the 
initial dataset extents by pressing the Reset extents to input button. All 
source data points outside the defined region are ignored and do not 
contribute to the gridding.

• Define NULL Values - Null values are used to flag specific values in a 
dataset that are not to be included in gridding process. These may include 
values indicating Sample Not Received (SNR) or Below Detection limit 
(BDL), etc. These samples may be attributed with a negative numerical 
value such as -9999 or -0.5 (detection limit). Failure to remove such 
artefacts can result in meaningless output grids. The Null values are set 
for one or all bands in data to be gridded in the Field Data Conditioning 
tool (see Field Data Conditioning Tool)..

• Cap Input Data Bands - Data capping options can be set to prevent 
outlier values in the dataset from being included in the gridding process. 
For example a maximum cap value can be set for gold assays which 
occur in mineralisation systems prone to nugget effects. Capping data to 
remove very high or very low values is used to remove samples which 
may unduly influence the cell values in the output grid. Setting a Cap 
minimum or maximum value will cap source data outside the set limit to 
the limiting value. For example, if the Cap maximum value is set to 500, a 
gold assay with a value of 725 ppm will be handled during gridding as 
having a value of 500 ppm value. 

• Specifying background values - It is also possible to check the Convert 
NULL to background box and enter a user specified  value in order to 
constrain the gridding. For example, if gridding drillhole geochemical 
assays, much of the hole may not have been sampled and in these areas 
the assay result may be assumed to be equal to the background value. 
This helps prevent anomalies ‘ballooning’ into areas with no source data 
coverage.

The options presented in the Grid Conditioning dialog are global settings. If 
multiple data fields have been selected in the Gridding Tool Input Tab (i.e. in order 
to create a multi-banded grid), these settings will affect all fields equally.
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Field Data Conditioning

Gridding Tool Method Tab

Eight gridding methods are available in Discover3D. The methods can be 
selected via the Method tab on the gridding tool dialog. The gridding method 
chosen will determine the number of additional dialog tabs and control properties 
that are displayed along the top of the gridding tool.

Located on the Method tab is an option to save the grid parameters or to apply 
pre-defined parameters.

The available methods are described below:

• Minimum Curvature

• Kriging

• Inverse Distance Weighting

• Spatial Neighbour

• Triangulation

• Density Grid

Further data conditioning options for each individual field selected fro gridding 
are available under the Field Data Conditioning button. See Field Data 
Conditioning Tool for more information.

The Load Settings button will present the user with a list of user-defined grid 
parameters. 

The Save Settings button is used to save settings from the existing Create Grid 
session, such as gridding method and search parameters (it does not save the 
grid cell size). These settings can therefore be applied to different bands or 
different datasets. 

The Load From Existing Grid option is designed to load gridding parameters 
from an existing grid file. By default a Discover-created grid will have an 
associated XML configuration file located in the same folder as the parent grid; 
to load these settings navigate to the associated XML file. Note that this option 
should only be used on the same dataset, as it will load all settings for the grid 
such as grid extents, cell size and band used.
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• Distance Grid

• Bi-Directional Spline

Minimum Curvature

The Minimum Curvature gridding method is widely used in many branches of 
science and research. This method creates an interpolated surface similar to a 
thin, linearly elastic plate passing through each of the data values defined in the 
input dataset. An important criterion in creating a surface is that it has a minimum 
amount of bending forced upon it to conform to the data points. The degree of 
bending is constrained by a ‘tension’ parameter and this can be specified both 
within the data area and along the edges. Minimum curvature gridding generates 
the smoothest surface possible while attempting to honour the data as closely as 
possible. Like all gridding methods, minimum curvature gridding is not an exact 
interpolation technique and therefore some error may occur between the input 
data point values and the interpolated surface values.

The Minimum curvature algorithm attempts to fit a surface through all of the data 
points without putting any abrupt kinks in the surface. Between the fixed 
observation points, the surface bends according to the Interior tension. This 
parameter is used to control the amount of distortion on the interior with the higher 
the tension, the less the distortion. The Boundary tension controls the amount of 
distortion at the edges. By default, the boundary tension is set to 0.

The minimum curvature method produces a grid by repeatedly applying an 
equation over the data in an attempt to produce a smoothly varying grid. Iteration 
is used to describe the number of times the equation is to be applied to the grid. 
The Maximum iterations number can be specified in the Minimum Curvature tab. 
The grid node values are recalculated until successive changes in the error 
between successive iterations are minimised, or the maximum number of 
iterations is reached.

Kriging

Kriging is a geostatistical gridding method which has proven popular across a 
variety of industries due to its flexibility and data driven approach to surface 
interpolation. Kriging is an advanced technique which is based on the assumption 
that the spatial variability in the measured property of a data set is neither due to 
totally random nor deterministic constraints. The main advantage of Kriging over 
simpler interpolation techniques such as IDW (Inverse Distance Weighting), is 
that it uses a weighting model which is adaptive to the inherent trends in a data 
set rather than imposing a set of fixed conditions upon them.  The process of 
using Kriging in interpolation can be complex and requires an intimate knowledge 
of the structure and variability in the data set so that an appropriate sample model 
and set of gridding properties can be chosen.
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Over the past several decades kriging has become a fundamental tool in the field 
of geostatistics. The method of interpolating a surface using kriging is generally 
performed as a two stage process: 

1. Analyse the input data to establish the spatial predictability of the 
measured values in the study area. This analysis generally focuses on the 
spatially correlated component of the data by means of determining the 
degree of spatial dependence among the sample points. The average 
degree of spatial dependence among variables is summarised in a plot 
known as the semi-variogram. The semi-variogram is a concise means of 
representing the average intersample variation according to sample 
separation distance and direction. In order to use the sample variance as 
part of the interpolator in the Kriging process it is necessary to model the 
semi-variogram in order to define a mathematical function which optimally 
describes the underlying structure in the data. This process is known as 
variogram modelling which in itself and can be a very involved and 
complex task. Once an appropriate model has been chosen it can then be 
used to estimate the semivariance or weighting at any given sample 
distance. 

2. Interpolation or estimation of values at locations which have not been 
adequately sampled. This process is known as interpolation ‘kriging’. The 
simplest technique known as “ordinary kriging” uses a weighted average 
of the neighbouring samples to estimate the unknown value at a given grid 
node. The weights are optimized for each node using the variogram 
model, the distance to the surrounding samples and the inter-sample 
variance.

The first step in kriging is to construct a variogram (or semivariogram) from the 
input data which describes the spatial correlation between the sample points. A 
variogram generally consists of two parts: 

• an experimental (or sample) variogram and 

• a model variogram (a descriptive function which mathematically models 
the experimental variogram). 

The degree of spatial dependence among sample points is measured by the 
average semi-variance:
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Where h is the distance or lag between sample points, n is the number of samples 
separated by h and z is the attribute value of interest. The computation of γ(h) is 
performed in two steps. First pairs of sample points are grouped together by 
distance. For example, if the distance interval (or lag) is 1000m then pairs of 
points separated by less than 1000m are grouped together into a 0-1000m lag, 
samples separated by a distance of between 1000 and 2000m would be grouped 
into a lag of 1000-200m and so on.  Next the average distance h and the average 
semivariance γ(h) is calculated for each group. If spatial dependence exists 
among the samples, then pairs of points closer together will have more similar 
values than pairs that are further apart. The semivariogram is a plot which has the 
average semivariance γ(h) along the y-axis and the separation distance h along 
the x-axis. 

 
Experimental and Model Variogram used in kriging

The semi-variogram can be broken down into thee main components; the Nugget, 
Sill and Range.

• Nugget - is the semi-variance at a distance of zero and represents the 
degree of sample repeatability or spatially uncorrelated noise.

• Range – is the spatially correlated portion of the semi-variogram that 
exhibits an increase in the semi-variance with distance. Towards the limit 
of the range the semi-variance levels off such that with additional 
increases in distance it is indistinguishable from one point to the next. This 
point of flattening is called the sill.

• Sill – is the point at which the semivariance (range) levels off to a relatively 
constant value.

Once an experimental variogram has been computed, the next step is to define a 
model variogram. A model variogram is a mathematical function that models the 
trend in the experimental variogram. Once the model variogram is constructed, it 
is used to compute the weights which are used in the kriging interpolator. The 
basic equation used in ordinary kriging can be described as follows:
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Where n is the number of points in the data set, fi are the attribute values of these 
points, and wi are weights assigned to each point. This equation is essentially the 
same as the equation used for inverse distance weighted interpolation except that 
rather than using weights based on an arbitrary function of distance, the weights 
used in kriging are based on the model variogram.

The creation and analysis of the sample and model variograms is done using the 
Statistics Explorer Tool.

Selection of Kriging on the Method tab opens both the Search and Kriging tabs 
on the gridding tool interface. Kriging uses the same searching mechanism as the 
Inverse Distance Weighting method.

The gridding tool supports two types of kriging estimation; Point and Block. Point 
kriging estimates the values of the points at each of the grid nodes. Block kriging 
on the other hand estimates the average value of points which fall within a 
rectangular block centred on each of the grid nodes. Because Block kriging 
estimates the average point value for each block it tends to generate smoother 
grids. In addition because block kriging uses an average of the input sample 
points it is considered an imperfect interpolator even when an input sample falls 
exactly on a grid node. The Block Kriging method provides controls to decimate 
(or break up) the blocks into a smaller mesh of sub cells, defined by the X and Y 
increment values. When a decimation factor is applied in Block Kriging the value 
assigned to each block is determined as the average of the sub cells inside the 
block rather than the average of the entire block.

In addition to the point and block estimation types the Interactive gridding tool 
supports two methods of Kriging; Ordinary and Simple. Ordinary Kriging focuses 
on the spatial correlation component between the measured values but ignores 
drift (drift is a regional trend in the data which exists is addition to spatial 
correlation between samples). Simple Kriging is similar to Ordinary Kriging with 
the exception that the weights used do not sum to unity and the average of the 
entire data set is used in the interpolation of each grid node rather than the local 
average of points that fall within the Search Distance of the node. Consequently 
Simple Kriging can be less precise than Ordinary Kriging but generally produces 
smoother grids.



13 Creating Gridded Surfaces 261

Inverse Distance Weighting

Inverse Distance Weighting (IDW) is a universal technique that can be applied to 
a wide range of spatial data. IDW uses weighted average interpolation to estimate 
grid cell values and can be used as either an exact or a smoothing interpolator. 
Each grid cell value in an output surface is calculated using a weighted average 
of all data point values surrounding the grid cell that lie within a specified search 
radius. 

The IDW method is optimal when the data has a fairly uniform distribution of input 
points across the area to be gridded, and some degree of smoothing is beneficial; 
for example soil samples taken over a regular grid. With this type of data, a repeat 
measurement at a point does not necessarily give the same results as the first 
measurement. If the input data points are not evenly distributed then using an 
oriented search ellipse may produce a more representative grid. 

Selection of the Inverse Distance Weighting method opens both the Search and 
Inverse Distance tabs. 

The weighting value assigned to each point within the search ellipse is 
determined by the distance from the data point to the grid node being interpolated. 
The further away a data point lies from the grid node, the less the point value will 
contribute to the final value assigned to that node. The distance weighting 
parameters can be adjusted under the Weighting Model controls in the Inverse 
Distance tab.

A search ellipse of fixed size and orientation can be defined in a similar manner 
to the Kriging method using the Search tab (below); a grid cell value is then 
calculated from the weighted average of all data points that lie within the ellipse 
centred on that grid cell.

Weighting Model

The weighting of an input data point is (by default) inversely proportional to its 
distance from the grid node (a Power weight model). This can be varied by 
choosing a different Weight Model on the Inverse Distance tab, and altering the 
model’s parameters where applicable. The following models are available for 
selection:

• Linear



262 Encom Discover 3D User Guide

Each input point’s weight is proportional to its Euclidian distance from the 
grid node being interpolated. The linear weight model enables the Nugget 
and Range parameters to be adjusted in order to vary the weight 
assignments. At distances less than the Nugget distance the weight model 
will be 1 – i.e. all data will contribute equally. The Range parameter is 
used to set the outer distance threshold for which the weight model is 
applied. Any samples which exceed the Range and are less than the 
Search Distance (Search tab) will be assigned an equal weight.

• Exponential

Each input point’s weight is proportional to its distance from the grid node 
being interpolated raised to the specified power. Increasing the power 
value will cause smaller weights to be assigned to closer points and more 
distant points to be assigned equal but large weights. Increasing power 
values will therefore cause each interpolated grid node to more closely 
approximate the sample values closest to it. As with the Linear model the 
Nugget and Range properties can be modified to constrain that distance 
over which the exponential weight model is most effective.

• Power

The default option, each input point’s weight is proportional to the inverse 
of its distance to the specified Power from the grid node. Increasing the 
weighting power reduces the influence distant points have on the 
calculated value of each grid node. Large power values cause grid cell 
values to approximate the value of the nearest data point, while smaller 
power values will result in data values being more evenly distributed 
among neighbouring grid nodes. The weighting value defaults to 2 (i.e. the 
weight of any data point is inversely proportional to the square of its 
distance from the grid cell) which is appropriate for most situations. If 
required, the weighting value can be altered to any positive value.

• Gaussian

The weight assigned to each input value is determined according to a 2D 
Gaussian function centred on the grid node. The shape and standard 
deviation of the Gaussian function is proportional to the Range with larger 
values producing a flatter function and a smoother grid.
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Weighting Options

The Elliptical weighting option is only available when the Elliptical Search 
option is enabled (in the Search tab). It adjusts the distance weighting function 
for data points within the search ellipse depending on their relative position with 
respect to the elliptical shell. Points located on the same elliptical shell will be 
assigned equivalent weighting even though their distance from the ellipse 
centroid may be different.  

The Density corrections control dynamically adjusts the search algorithm to 
optimise grid cell interpolation in areas of data clustering. Activating density 
corrections can help to enhance detail in datasets where sample points are 
unevenly spaced (e.g. regional geochemistry sampling) and may in some cases 
produce a smoother or more representative grid. The density correction modifies 
the weights for each contributing point based on the sample density at that point.

The Exact hit distance is a tolerance distance for assigning actual input data 
values to coincident grid nodes. As the inverse distance gridding technique is 
attempting to interpolate a continuous surface through the data, a certain number 
of grid nodes coincide with the input data points. Where grid nodes and data 
points coincide, the distance between them is zero, so by default the data value 
is assigned a weighting of 1.0 and all other data points in the search radius are 
given a weight value of zero. This means that grid nodes that are coincident with 
input data points are assigned the value of the coincident data point rather than 
an interpolated (averaged) value derived from the data points surrounding it. 

This effect can produce significant ‘spotting‘ in the output grid, particularly if the 
data value of the coincident point/grid cell deviates significantly from the points 
surrounding it. By adjusting the exact hit distance it is possible to increase the 
tolerance distance in which input data values are assigned to grid nodes. 
Assigning this value to a high number can produce unacceptable spotting or 
concentric banding in the output grid, while reducing the value below 1 has little 
or no effect.

Note If you have enabled the Use nearest neighbours option (in the Search tab) in 
conjunction with four search sectors then you will have effectively removed 
clustering from the input data point distribution. The Density corrections option is 
not available when the Use nearest neighbours option is enabled.
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The Taper controls allow you to apply a taper function to the interpolated value of 
each grid node based on its distance to the nearest valid sample point. The taper 
function is applied using a linear weighting model thereby adjusting the expected 
grid node values towards the background value. Between a distance of zero and 
the FROM distance the taper function is assigned a constant value of 1 (i.e. no 
modification is made to the grid node). Between the FROM and TO distance the 
taper function is applied as a linear weighting between the grid node value and 
the background value. Beyond the TO distance grid nodes are assigned the 
background value.

Search Tab

The Kriging and IDW methods, when selected, both display the Search tab, along 
with their individual control tabs. These methods, if not optimised, can quickly 
becomes unworkable as the number of input data points increases beyond a few 
thousand. To improve the performance of these algorithms and to ensure these 
methods are suitable for large datasets, a search radius can be used to restrict 
the number of input points that contribute to each interpolation. This introduces a 
number of problems. For example the algorithm may not find a sufficient number 
of points within the search radius to make a reasonable estimation or, the spatial 
distribution of the points within the search radius may not be uniform so that the 
estimation becomes directionally biased. 

The Search dialog
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The Search tab provides controls to resolve these issues by determining the 
shape, size and orientation of the search ellipse used to locate data points during 
interpolation. Specifying an appropriate size and orientation for the search ellipse 
is important. Setting it smaller than the average data spacing may result in a large 
number of the interpolated grid cells being assigned a null value and therefore 
displayed as white in the output grid. Conversely, if the search ellipse is set to be 
too large then significant edge effects or grid artefacts may result around the edge 
of the grid. The Search tab is subdivided into a number of sections:

• Searching

• Anisotropy

• Sample Selection

• Gridding Rule

Searching

By default Discover3D uses a circular search with a radius specified via the 
Search Distance option. If the node cannot be estimated from the points located 
within the search radius then the search radius can be incrementally increased 
and the searching repeated using Search Expansions. The increased radius is 
likely to encompass more input points and consequently the node may be able to 
be interpolated. At each stage the actual search radius used will be equal to the 
stage number multiplied by the initial search radius. The number of allowable 
increments is limited because after a while this process becomes self defeating 
and it is wiser to specify a larger initial search radius.

To optimise performance, choose an initial search radius that is likely to 
encompass the minimum number of required input points most of the time. It can 
sometimes be very difficult to make this decision but the tool will always make a 
suggestion to get started with.

If the spatial distribution of the data points is not uniform (or not uniformly random) 
then the use of search expansions may not be enough to populate the grid 
successfully. For example, a dataset may have regional data located on two 
kilometre centres and local data in parts of the study area on 100 metre centres. 
To produce a suitable grid of the whole region that characterises the detail in the 
high resolution areas would require small search radius in these areas and a large 
search radius elsewhere.



266 Encom Discover 3D User Guide

The solution is to use additional refinement Grid Passes which grid the data 
multiple times - once for each pass - at increasingly higher resolution. The gridded 
results from each pass are then used as additional input data for the next pass. 
The grid cell size and search parameters are scaled up by a factor of two for each 
additional grid pass – for example if you use three additional passes then the first 
pass scales up these parameters by a factor of eight, the second by a factor of 4, 
the third by a factor of two. The final pass grids the data at the requested 
resolution with the specified searching parameters.   

Anisotropy

By default the search radius is isotropic creating a circular search area. However 
directional bias can be applied by enabling an Elliptical Search.

The dimensions of the search ellipse can be controlled by specifying the length of 
the major and minor axes. The major axis is defined by the Search Distance value 
in the Searching section (above), whilst the minor axis is governed by the Minor 
search distance option. The Major axis Orientation control determines the rotation 
angle of the major axis.

If elliptical searching is used with the Inverse Distance Weighting method, it also 
allows the use of the Elliptical weighting option under the Inverse Distance tab. 
This option modifies the data point weighting so that they are isotropic with 
respect to angle within the search ellipse – in other words it removes the 
directional bias from the weighting

Sample Selection

Input points ‘close’ to the grid node may not be uniformly distributed, e.g. they 
may all be on one side of it. This will introduce a directional bias into the 
estimation. This can be resolved by using search sectors.

Discover3D provides options for specifying 1, 2 or 4 search sectors. By adjusting 
the Number of search sectors and Minimum points required (in each sector) the 
appearance and smoothness of the output grid can be varied. If any of the sectors 
contain fewer than the minimum number of specified points, the interpolated grid 
cell value for that node is assigned a null value.

If four sectors are used then each covers 90 degrees of arc (centred about NE, 
NW, SE, SW). If two sectors are used then each covers 180 degrees of arc 
(centred about North, South). Using only one search sector effectively turns the 
option off. 
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Using 2 or 4 search sectors can significantly improve the appearance of a grid if 
the input data has been collected on widely spaced lines. Using a one sector 
search ellipse may result in grid node values being estimated from data points 
from a single direction. This might generate unrealistic or sharp slopes between 
the lines producing a rough or stepped grid. Using a two or four sector search with 
an appropriate search distance should generally eliminate or reduce this effect. 
Experiment with the use of search sectors and examine the difference these can 
have on the output grid. 

Specifying the Use nearest neighbours option enables you to use only the 
closest Maximum number of samples found within each search sector in each 
estimation. Contributions from other points within the search radius are ignored.

The Use nearest neighbours option controls the Maximum number of samples 
that are used in each sector when interpolating each grid node value. When this 
option is selected Discover3D uses the closest points (up to the maximum 
specified in each sector) to interpolate each grid cell. Any excess data points 
within the search ellipse are ignored in the calculation.

Gridding Rule

Enabling the Customise gridding rule option allows a node to be gridded only if 
a specified minimum number of sample points are located in at least a specified 
minimum number of sectors. If a node fails to meet this rule, it will be assigned a 
null value.

Spatial Neighbour

This method is similar to the Inverse Distance Weighting method described above 
but does not use the search radius to interpolate data values from surrounding 
cells. For each grid cell, neighbouring input points are located based on a ‘spatial 
neighbours’ selection criterion. The value of the computed grid cell is the average 
of the neighbours, weighted such that the closer the neighbouring point, the 
greater the influence than points further away.

Search criteria are only radial in this method but the distance and applied 
weighting can be specified in the Spatial Neighbour tab displayed when this 
gridding method is selected.
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Triangulation

The Triangulation method produces a regular gridded surface through a set of 
data points by using an optimised Delaunay triangulation algorithm. The 
triangular mesh is created by drawing lines between adjacent input data points 
and forming an irregular network such that no triangle edges are intersected by 
other triangles. A regular grid is then computed from the triangular irregular 
network and grid cell values computed using a natural neighbour interpolation 
process. As the original data are used to define the triangles, this method is very 
useful for situations where the data must be honoured very closely (e.g. elevation 
data in a digital terrain model). 

The triangulation method is best applied to data that is evenly distributed over the 
gridded area. If there are large areas of sparse or missing data distinct triangular 
facets may appear in the output grid. As triangulation uses all the input data to 
construct the triangular mesh, the only parameter that needs to be adjusted is the 
grid cell size. Grid cell size can be adjusted to an appropriate value for the 
dataset.

Density Grid

The Density gridding method produces a grid which records a measure of the 
point density at each grid node. The density at each grid node is determined 
independently using an estimator function. Two estimators are available:

• Radial Density Estimator 

• Kernel Density Estimator (KDE)

The Radial Density Estimator method returns a true measure of the point 
density at each grid node (measured as the number of samples per square area 
unit – usually metres). It is a simple method that counts the number of input 
samples within a specified radius of the grid node position and then normalizes 
that count by the area of the search.

The Kernel Density Estimator method is a non-parametric density estimator. It 
uses a similar approach but it weights the input samples by a kernel function that 
is normally a function of the normalized distance of the sample to the grid node. 
To achieve a good result with the KDE function it is more important to choose an 
appropriate search radius – sometimes referred to as the bandwidth – than to 
choose an appropriate kernel function. If the bandwidth is too small the density 
will be under-smoothed whereas if the bandwidth is too large the density will be 
over-smoothed and lacking in resolution.

Given a kernel function K and a search radius (or bandwidth) h, the estimated 
density at any point x is given by – 
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where n  is the number of samples. The following kernel functions are supported:

If you have taken multiple samples at each input data location and this information 
is recorded in the input data then you can use this information to bias the density 
estimation. To enable this option, check the Interpret selected data channel as a 
count frequency box and on the Gridding Tool Input Tab ensure the frequency or 
count field is selected as the input data field. 

Distance Grid

The Distance gridding method produces a grid which records the minimum 
distance to the input data features at every grid node. A distance envelope can 
be specified to clip the grid at a maximum distance from the nearest feature. Any 
grid node that is outside this envelope will be assigned a null value.

Kernel Κ(u)

Uniform

Triangle

Epanechnikov

Quartic

Triweight

Gaussian

Cosinus
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When the input data is loaded it is classified as either point data or polyline data 
depending on the source of the data and the type of object that was loaded. By 
default the method will consider all input data as point locations. Optionally, you 
can add to this the input polyline data. In this case the method will also check the 
perpendicular distance to the nearest polyline in addition to looking at all point 
data.

 In the examples below the first grid has been computed considering all the input 
data as point locations. The second grid has added to this the polyline 
information. In both cases a distance envelope has been applied. 

Distance Grid points only  Distance Grid points and polylines

Bi-Directional Spline 

This method of gridding is fast and uses an accurate approach with few side 
effects. It has a small memory foot print and is suitable for gridding very large 
datasets collected on lines with a common azimuth.

The bi-directional spline employs a form of damping called the Akima spline. The 
Akima spline interpolates a smoothed curve through a series of given points. The 
interpolation approximates a manually drawn curve better than many other 
ordinary splines. In the Gridding Tool, an Akima spline is applied first along input 
data lines and then across them in alignment with the grid cells in either the North, 
North East or East directions. 

For best results, choose multiple lines of data that have similar direction azimuths. 
Best results will be obtained for lines that have azimuths close to North, North 
East or East. 

No additional tabs are displayed for this option because it does not require any 
parameters.
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Gridding Tool Geometry Tab

This tab controls the main parameters for determining the geometry of the output 
grid. The Cell Parameters control determines the size of each grid cell in the 
output image and is measured in the same data units as the input dataset. For 
most geographic data these units are in metres; however Discover3D supports all 
of the MapInfo units of measurement. During the loading process, Discover3D 
automatically computes an optimised grid cell size based on the distribution and 
density of the input data. This is displayed in the first pair of boxes. The cell size 
can be adjusted in the second pair of boxes.

The Grid Geometry dialog

When a large dataset is loaded the Auto Apply box is disabled and the Compute 
Best Parameters button is active. Use this button to calculate an optimal grid cell 
size.

The extents of the Data coverage to be gridded can be modified by entering new 
co-ordinates into the Min and Max X and Y columns. The full extents of the 
original data coverage are displayed by default. If the coordinates have been 
modified select the Reset to Input Extents button to return to the original data 
coverage.

Note It is recommend to define a square cell size, as Discover and MapInfo 
Professional only supports square grid cells.
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The Grid bounds parameters control the boundary extents of the output grid and 
can be used to reduce the size of the output grid if required. The number of Rows 
and Columns in the output grid is also displayed. These values are calculated 
from the grid extents and cell size and cannot be edited.

Gridding Tool Output Tab

The Output tab provides a number of controls for saving the gridded image. The 
left side of the dialog provides a summary report for the grid process and lists the 
primary gridding parameters chosen. This information may be copied to the 
windows clipboard by selecting the information with the mouse and using the 
Windows Copy and Paste commands. This may be useful for reporting or archive 
purposes. 

Below the summary box is a pull-down list containing the Discover3D supported 
grid formats. Discover3D currently creates grids in ER Mapper (.ERS), Geosoft 
(.GRD) and Surfer Binary (.GRD) uncompressed grid formats. To save a grid, 
select the appropriate format from the list. Click the Save button. The output grid 
file is assigned a default name. The file name and directory path by clicking on 
the small button at the right end of the path name box. The Output tab is 
accessible at any stage during the gridding process so it is not necessary to wait 
for the preview window to complete drawing before saving the final grid. 

The Smooth grid control allows the appearance of the output image to be 
smoothed by applying a Gaussian smoothing filter to the grid. In most situations, 
enabling the smooth grid function removes high frequency noise in the grid and 
enhances the appearance of your image.

Note When creating a surface, the grid cell size selected is important. As a general 
rule of thumb the grid cell size should not be made smaller than approximately 
one fifth of the average data spacing. Reducing the grid cell size beyond this 
limit may cause the grids appearance to become smoother but can also 
introduce unwanted irregularities in the output image. Assigning an excessively 
small grid cell size will also increase computation time and file size. Discover3D 
suggests an optimal grid cell size for the data but experiment with alternative 
values.
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The grid output dialog, showing the clip options availble

The Clip control provides a number of options for clipping the extents of the 
interpolated grid, so that it more closely approximates the distribution of the input 
data. Enabling this option can improve the appearance of the output grid for 
irregular input data where the gridding method (usually Triangulation or Minimum 
Curvature) has interpolated the grid over large gaps within the data. Options 
available include:

• Creating a Buffer around the input data at a user-specified distance. The 
gridded data outside the buffer is then removed.

• The Near value of the Near/Far option is the distance the grid is to be 
clipped back to from the convex hull of the data points. The Far distance is 
the distance between the points to interpolate between. Areas in the grid 
which lie between data points greater than the Far distance value grid will 
be displayed as null or “white”.

• The Convex Hull option clips the output grid to the smallest convex 
region/polygon enclosing the dataset. This convex region is found 
conceptually by stretching a rubber band around the points so that all of 
the points lie within the band. The convex region can be expanded by a 
specified Buffer value.

• The Concave Hull option starts with a Convex Hull region, and then 
removes/erodes triangles on its edge that have an outward facing angle 
greater than a defined tolerance (specified under the Options button). This 
new concave region can then be expanded by a specified Buffer value.
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If multiple fields have been selected for gridding then three output options are 
available:

• Separate grids - each selected field is created as a separate grid which is 
named using the original source table with the field name extension. E.g. 
Geochem_Cu, Geochem_Pb, etc.

• Multi-banded grid - multiple fields are gridded and saved to a single 
ERMapper Multi-banded grid.

• Create RGB Image - if three fields are selected for gridding they can be 
saved as an RGB image. Each field is saved as a red, green or blue 
channel in the resulting image. 

When the Gridding Tool parameters have been selected and the grid surface is 
completed, press the Save button. This button closes the Gridding Tool dialog, 
saves the grid surface into the specified file and updates the original map window 
with the surface grid. The surface grid is displayed using the same look-up table 
as selected in the Gridding Tool dialog prior to saving.
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14 Working with Drillholes and Trenches in 
3D
Discover 3D allows drillholes and trenches and their associated downhole 
datasets to be quickly and easily displayed, allowing you to view your drilling in 
‘real-space’. 

Combining this with gridded surfaces, raster images, voxel models and point/line 
data allows the geologist to view their exploration projects in a complete and 
coherent 3D environment.  This allows the geologist to start assessing and 
interpreting their drillhole project’s geology and mineralization in the 3D world only 
previously accessible in high-end mining packages.

In addition to Discover Drillholes projects, any Trenches or Costeans associated 
with these project can also be visualized in 3D, including face/chip sampling, or 
well sampling. It is also an effective method to display Boreholes/Drillholes with 
XYZ gyroscopic coordinates provided.
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Drillhole and trench data can be displayed in 3D via:

• Opening a Drillhole Project in MapInfo/Discover and using the Discover 
3D>View Drillholes tool (see Displaying Drillhole and Trench Data in 3D), 
or

• Directly opening a Discover Drillhole Project or a Geosoft WHOLEPLOT 
Database in Discover 3D.

• Opening a Drillhole Project with associated Trenches/Costeans in 
MapInfo/Discover, then use the Discover 3D>View Trenches (see 
Displaying Drillhole and Trench Data in 3D)

Once drillhole or trench data is displayed in Discover 3D, there is an extensive 
range of display controls available for both the drillholes and the data that may be 
associated with them. For example:

Drillholes

(see Changing Drillhole Display Properties)

• Trace Style - trace paths can be displayed to show the accurate location 
of the drillholes.

• Labelling - drillholes can be labeled with information such as hole names, 
EOH depths, downhole depths, etc.

• Colour Modulation - drillhole traces can be colour modulated (including 
patterns) using  downhole attribute (e.g. geology) or numeric (e.g. mag 
sus) information.

• Thickness Modulation - drillhole traces can be thickness modulated using 
one or more downhole numeric fields, such as assay or geophysical 
measurements.

• Display Drillhole Logs Images - Logs can be quickly displayed as 
georeferenced images in 3D This function is not available with trenches 
and costeans.

Trenches

(see Changing Trench Display Properties)

• Trace Style - trace paths can be displayed to show the accurate location 
of the drillholes.
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• Labelling - trenches can be labeled with information such as names, 
lengths, etc.

• Colour Modulation - trench traces can be colour modulated (including 
patterns) using attributes or numeric information.

• Thickness Modulation - trench traces can be thickness modulated using 
one or more numeric fields, such as assays.

Displaying Drillholes and Trenches in 3D

A drillhole or trench dataset can be displayed in Discover 3D via two methods:

• From the within the 2D MapInfo/Discover interface.

If a Discover Drillhole Project has been created and is open in MapInfo 
(Drillholes>Project Setup), use the Discover 3D>View Drillholes tool 
(see Displaying Drillhole and Trench Data in 3D). This is generally the 
easiest and the recommended method or drillhole loading.

Upon loading into Discover 3D, a new Drillhole branch will be added to the 
Workspace Tree, and all drillholes within the project will be displayed in 
the 3D view. See the Changing Drillhole Display Properties section below 
for visualising and controlling the drillholes.

The same method can be used to display any Trench associated with the 
Drillhole project, by using Discover 3D>View Trenches and a Trench 
branch will be added to the workspace tree.

• From within the Discover 3D window.

Discover 3D supports the direct loading of two drillhole data base types:

Note Trenches in 3D does not support Bearing and Distance Trench project with 
Segment distances. It also does not support Bearing and Distance Survey 
(either cumulative or segments) when a Topographic DEM surface grid is 
associated with the project.

• Discover Drillhole Projects. Select the Open Discover 
Drillholes…button of the main toolbar to browse the target drillhole tables 
and click Open. See the Discover Drillhole Project section below for 
further information.
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A Drillholes branch is created in the Workspace tree and the first of the 
available holes is displayed as a 3D hole. 

Drillhole Dataset Format

Typically drillholes and associated data require the following information:

• Collar positions in X, Y and vertically (Z) referenced elevation. Names of 
the drillholes are also associated with drillhole collars. Usually the total 
distance along the hole axis from the collar to the base of the hole is 
included in this file.

• Downhole Survey data must be associated with each Hole_ID to define 
the location of points down the hole. This data defines the shape of the 
hole and is usually derived from a survey undertaken in the field using a 
downhole camera and survey software. The data requires a distance 
down the hole axis, a dip and a compass azimuth reading at the measured 
survey point.

A minimum number of two points can be used to survey a hole. For a 
straight hole, only a single entry is required as the azimuth and dip at the 
collar is assumed to the base of the hole. Note that the survey describes 
the shape of the drillhole, not the points at which assays or data readings 
or samples are made.

• Downhole Data such as assay samples, readings or analyses can be 
done at measured depths of the hole. These readings may be geophysical 
(eg magnetic susceptibility, density, gamma etc) or they may be geological 
(eg lithological, assay or geochemical). Readings can be taken at a 
specific distance point down the axis of the hole, or over an interval that is 
using from-to terminology (for example, lithology between 50.0 and 50.5 
metres distance the hole intersected mudstone).

• Geosoft WHOLEPLOT databases Select the Open Geosoft 
Drillholes…button of the main toolbar to browse the target drillhole tables 
and click Open. See the Geosoft WHOLEPLOT Database section below 
for further information.

Once a drillhole database is loaded , add a new Drillholes branch to the 
Workspace tree by selecting the Drillholes button (on the Data Objects 
toolbar)or choose the Display>Drillhole menu item.

Note To update a 3D Drillhole display after altering drillhole data in MapInfo/Discover, 
use the Discover 3D>Refresh All 3D Data option in the 2D interface
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Discover Drillhole Project

Refer to the Discover documentation for information regarding how to create a 
Drillhole Project. Usually, the Drillhole Project consists of three or more MapInfo 
Professional .TAB files similar to:

• COLLARS.TAB – defines the Hole_ID, collar location (XYZ) and depth of 
holes.

• SURVEY.TAB – specifies the survey points down the various holes. This 
file defines the shape of the drillholes.

• DATA.TAB – typically these files contain assay or lithological data.

Selecting the Discover Downhole database files

Select File>Open>Discover Downhole or click on the button (shown left)) on 
the Main Toolbar.  Browse to the drillhole folder, choose the MapInfo Drillhole 
tables and click Open.
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Geosoft WHOLEPLOT Database

Geosoft drillhole databases are created by the WHOLEPLOT option of Oasis 
montajTM and usually have a .GDB name extension. Depending on the version of 
montajTM used to create the database, the collar, survey and data content may 
be contained in a single .GDB file or multiple .GDB files.

Selecting the Geosoft WHOLEPLOT database file

Geosoft databases generally define downward dipping drillholes as negative 
values so Discover 3D assumes the Geosoft database adheres to this format. If 
this needs to be reversed, the File>Modify Dataset Field and Survey 
Properties tool (from the 3D interface) provides an option to do so for any 
Geosoft drillhole database loaded.

For additional information on this data format, please refer to the Geosoft 
WHOLEPLOT documentation.

Select File>Open>Geosoft Downhole…or click on the button (shown left) on 
the Main Toolbar. Browse to the drillhole folder, choose the Geosoft Database 
and click Open.

Note For the above changes to take effect any existing drillhole branch containing the 
Geosoft drillhole project must be deleted first and a new branch opened.
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Desurvey Methods

Upon loading a drillhole project into Discover 3D, the drillholes are desurveyed 
using the Back Calculation method (detailed below) by default, as this is the 
method used by Discover.

The user can however choose a different method by opening the File>Modify 
Dataset Field and Survey Properties dialog, and selecting the desired method 
from the pull-down list of Desurvey Methods at the bottom of the dialog. This 
change will apply permanently to the drillhole project each time it is opened into 
Discover 3D, until a further change is made in this dialog. 

The methods available are:

• Back Calculation (Discover)

• Segments

• Minimum Curvature

• Akima Spline

• Bezier Spline

• XYZ (trenches only)

Back Calculation

This is the only method offered in Discover and is the default method in Discover 
3D. Although it is a simple method it does produce reasonable results. This 
method is also known as mid-point tangential averaging.

Each survey point is considered to lie in the middle of a drillhole segment which 
has the dip and azimuth of the survey location. The dip and azimuth of the hole 
changes automatically halfway between each survey point. This has the affect of 
intersecting a midpoint in between the actual survey points, and may not actually 
intersect a survey point. It also means that the first and last interval of the trace 
will be half their expected length.

Put simply, if your collar is at 0 m and finishes at 40 m and you have down hole 
surveys at depth intervals of 10 m, 20 m and 30 m, then Discover will compute 
the the end X,Y,Z coordinate of the first line segment using the midpoint distance 
between each depth interval (e.g. 0-5 m). It then uses corresponding dip and 
azimuth values from the surveys (10 m measurement), to project the second line 
segment (5-15 m). At this point it then uses the next Survey dip and azimuth 
record (20 m) to generate the next segment.
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This has the effect of making 'curved' holes more curved and a hole will diverge 
further from the 'straight line'  (called segments in Discover 3D) location at 
increasing depth.

Note that if you have a high frequency of survey data (e.g. 1 m intervals), then the 
effect of the interpolation will be negligible. 

Segments

This is the simplest method available. It is similar to back calculation but produces 
less acceptable results.

Each survey point is considered to be the start of a drillhole segment which has 
the dip and azimuth of the survey location. The dip and azimuth of the hole 
changes automatically at each survey point.

The Segments method is also used to display Trenches measured by distance 
and bearing in 3D.

Minimum Curvature

This is the most robust method and is highly recommended. It is also known as 
radius of curvature and is considered the standard method in the oil and gas 
industry.

Each survey point is considered to lie at the start point on a spherical arc (or 
straight line) whose radius is defined by the change in the direction of the hole 
from the survey point to the next survey point. The dip and azimuth of the hole 
varies smoothly between survey points.

The Discover 3D implementation is based on the formulae presented by Sawaryn 
& Thorogood; A Compendium of Directional Calculations Based on the Minimum 
Curvature Method presented in the Society of Petroleum Engineers Journal.

Note If performing data interpretation on a drillhole project in both the 2D (MapInfo/
Discover) and 3D environments, it is recommended to utilise the default Back 
Calculation method.
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Akima Spline

This method is also very robust and produces very similar results to the minimum 
curvature method.

Smooth Akima spline functions are fitted to the dip and azimuth survey data for 
the length of the hole. The hole is then desurveyed using the segment method 
and a small, constant depth interval where the dip and azimuth for each segment 
is acquired from the spline functions.

Bezier Spline

This method is exactly the same as the Akima spline method except that a Bezier 
spline function is used instead of an Akima spline.

Use of this method is not recommended.

XYZ (trenches only)

This method is only available for trenches, measured by XYZ coordinates for 
each survey point.

It simply plots each survey point's XYZ coordinates, and then join these with a 
straight line.

Interrogating Downhole Information

Two modes of dynamic drillhole information are available in 3D:

• Advanced – allows detailed downhole data to be dynamically displayed in 
the Information sheet, including 3D coordinates, from/to intervals, geology, 
assays, etc.

To enable advanced interrogation:

• Basic - when the Select/Navigate button is enabled on the Zoom 
Controls Toolbar, place the mouse cursor over a drillhole trace to display 
the drillhole name and the downhole depth of the drillhole. The results are 
continuously displayed in the status bar at the bottom left corner of the 3D 
window.

1. In Workspace Tree, make the Drillhole branch both Selectable and 
Browsable. 
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Using the Data tab of the Information sheet to evaluate downhole data.

The Data window provides a single combined spreadsheet view for all downhole 
data tables for the drillhole project. Discover 3D segments the various tables to 
the shortest interval over each segment and provides the following information at 
the start of the spreadsheet, in addition to the fields inherent in each table:

• Hole ID

• From/To fields for the segment intervals

• 3D coordinates (DH_X, DH_Y and DH_Z fields)

This single combined spreadsheet can result in a large number of fields being 
displayed, with the actual desired fields scrolling out of view. The spreadsheet 
can be customised in terms of actual downhole fields displayed and their order, 
by right clicking in the Data window and selecting the Customise option. These 
Data window customisation options (including field widths) are preserved as long 
the as the current Discover 3D session is open.

2. Display the Data Window using either the toolbar button or the View>Data 
Window menu option.

3. Enable the Select/Navigate button on the Zoom Controls Toolbar.and 
click on a drillhole trace (this will auto-enable both the Cursor Plane and 
its Bond function on the Cursor Plane Toolbar. The Data window will scroll 
to the appropriate downhole record for the coincident hole interval.
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Customising the Data tab view

If a group of cells is highlighted in the data window, right-clicking will present a 
Copy selected cells to clipboard menu option. This can be useful for extracting 
data into Excel for data analysis or other uses. 

This is also a useful way of merging multiple downhole datasets into a combined 
table processed to the smallest interval in every table.

Changing Drillhole Display Properties

Most aspects of drillhole displays can be controlled from the Properties dialog 
opened from the Drillholes branch of the Workspace Tree. To display the 
Drillholes Properties dialog, either:

• Move the cursor over the Drillholes branch in the Workspace tree and 
double click with the left mouse button, or

• Highlight the Drillholes branch in the Workspace tree and click the right 
mouse button. From the resulting shortcut menu, select the Properties 
item.

The display settings made on the Drillholes Properties dialog box can be saved 
or loaded from a settings file (see Saving and Applying Display Settings). The 
display controls available depend on the type of data and may include:

• Selecting Drillholes
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• Trace Style

• Labelling

• Symbols

• Colour Modulation

• Thickness Modulation

• Display Drillhole Logs Images

• Data Compression

An example of a downhole display with lithology is shown below.

Example drillholes with downhole lithology displayed

Saving and Applying Display Settings

Any display settings customized in the Drillhole Properties tab controls (e.g. 
colour or thickness modulation) can be saved for later reuse. This is an excellent 
way to maintain the same display settings between drillhole project data updates, 
or between projects sharing the same data structure.
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 To save any current display settings, move the cursor over the Drillholes branch 
in the Workspace tree and right click. Select the Save Properties option, and 
specify a name and location for the output display settings .XML file (e.g. a under 
the drillhole project root directory, or in a user-created settings folder elsewhere). 

To reapply display settings at a later date (e.g. for an updated version of the same 
drillhole project, or another project ), first load the drillhole project into 3D. Move 
the cursor over the Drillholes branch in the Workspace tree and right click. Select 
the Load Properties option, and browse for the desired settings .XML.

Selecting Drillholes

The Holes tab of the Drillholes Properties dialog allows the user to control which 
holes are displayed. 

Drillhole selection using the Holes tab

Note Display Settings can ONLY be applied to drillhole projects that have exactly the 
same  table names and field names and types. Any differences in table names or 
structure will likely cause settings to not display.
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Drillhole graphical collar selection

Specify the holes to be displayed by moving the drillhole name(s) from the Hide 
to the Show list. Alternatively, you can graphically select the holes to be 
displayed from a collar map using the Graphical Selection button.

Note Drillhole collar names can be displayed in the graphical selection dialog by 
placing the cursor over a drill hole and viewing the name in the left corner of the 
status bar at the bottom of the dialog.
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Trace Style

The Appearance tab allows the trace style of drillholes to be altered.

Appearance tab of Drillhole Properties

To alter the Trace Style, ensure the Show Line option is enabled, and choose 
one of the following styles from the adjacent pull-down list:

• Line - This is the most efficient display style, and is recommended as the 
initial style when displaying large datasets. Hole traces are displayed as a 
simple line, with colour, line weight and basic pattern options under the 
adjacent Line Style button. Colour Modulation is possible but thickness 
modulation is not.

• 3D Tube - Drillholes can be displayed as solid tubes, with a cross-section 
profile (and colour) set via the adjacent Tube Style button (only available 
when the Discrete samples option is disabled: default Tube_Medium 
style). Tube thickness (in projection units) and colour can also be 
specified. Colour Modulation is possible, as well as Thickness Modulation 
by a single field. 
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• 3D Rose - This is the most memory intensive of the trace styles, allowing 
the width of the trace to be modulated based on multiple downhole 
numeric data fields (such as an assay or geophysical fields). These are 
set using the adjacent Petals button as discussed in the Thickness 
Modulation section below. It requires specification of the Thickness range 
(minimum and maximum widths) at the bottom of the tab. An Initial Angle 
control is also available, controlling the initial starting angle for rose 
segments when more than one numeric field is specified. A Colour 
Modulation can also be applied, or a constant colour set via the Colour 
button.

Different drillhole appearances are shown here:

Examples of colour modulation of drillholes as applied to Line, 3D Tube and 3D Rose 
traces using lithological data. The thickness modulation of the 3D Rose traces has been 
applied using an assay field.

The Show Gaps option is only available (not greyed out) when a Colour 
Modulation and/or one or more Thickness Modulation fields has been assigned. 
Deselecting this option (un-ticking it) will result in any sampling gaps not being 
displayed; i.e. drillhole traces will be discontinuous if sampling gaps exist. This is 
an excellent way of visualising only populated sample intervals, particularly after 
using Data Conditioning (see Field Data Conditioning Tool) e.g. nulls removed or 
only anomalous data intervals displayed.

Tip If after applying Data Conditioning in tandem with disabling Show Gaps, you 
see only isolated downhole intervals and require the spatial reference of the 
entire drillhole trace, try adding another Drillhole branch to the workspace tree, 
and populating it with the same drillhole dataset. Set the display Style of this 
second branch as Lines- it will present your entire dataset as drillhole trace 
‘skeletons’ over which your isolated intervals will be located, as pictured below.
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The same drillhole dataset displayed in two separate branches in the workspace tree. One 
branch utilises a thin Line Style display to show the drillhole skeletons (thin grey lines); the 
other is both thickness and colour modulated, with the Show Gaps option disabled and 
Discrete samples enabled.

Discrete samples are only applicable to the 3D Tube or 3D Rose trace styles. 
When enabled, each sample interval is displayed as a uniform thickness across 
the interval (i.e. discs as pictured above).  Assay intervals are displayed as steps/
disks of varying thicknesses. Disabling this option enables the hole thickness to 
be altered gradually/ continuously across sample intervals. Examples of these 
modes are presented below.

Examples of Gradual and Discrete thickness modulated (3D Rose) downhole assay 
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displays

The Override background colour option will only have an effect when a Legend 
is applied as Colour Modulation (3D Tube or 3D Rose styles). It will replace the 
background colour of each legend entry with the colour assigned in either the 
Tube Style or Colour buttons. Foreground colours will be preserved.

Labelling

Drillhole collars and bottoms can be annotated with labels by enabling the 
appropriate tick box in the Symbols tab. To change or customise the label 
display, click the adjacent Collar Label, Bottom Label or Depth Label button to 
open the Advanced Arrangement dialog. 
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The Advanced Arrangement dialog for applying drillhole collar and bottom labels

The Depth Label button relaces the text box with a Format button; this can be 
used to set numeric formatting, prefixes and suffixes. Activating the Depth Label 
option also requires setting a Depth Interval in the Appearance tab (i.e how 
often downhole depths are displayed).

For all label types, standard Font controls are provided, as well as the following 
range of orientation options in the adjacent pull-down list:

• Facing Viewer (default) – Labels are aligned parallel to the viewing/
screen plane so that they always face the viewer. 

The Collar and Bottom Label buttons display the current label in a text box at 
the top of the dialog; to change this, highlight the entire text entry and click the 
Field Selection button (shown left).  Select the desired field from the displayed 
list (populated from the drillhole collar file). Multiple fields can be displayed 
together by placing the cursor at the desired insertion point within the text 
window (without highlighting any existing text) and then selecting extra fields 
from the field selection list (without highlighting any existing text) and then 
selecting extra fields from the filed selection list.
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• Fixed 3D – Labels are fixed in the 3D environment. The pull-down list in 
the Rotation panel at the bottom of the dialog controls the initial 
orientation: Flat (the XY plane) or Upright (XZ plane).

• Fast 3D – identical to the Fixed 3D except that no Style controls are 
available. This is a very fast and memory-efficient labelling option.

The Style button is only available for the Facing Viewer and Fixed 3D orientation 
options. It allows labels to be extruded either as filled Polygons or Line Segments 
(wireframe) using the Format pull-down list. The depth of the label is set using 
the Extrusion control, expressed as a percentage of the label size. To display a 
flat label, set the Extrusion to 0%. The label is extruded perpendicular to its 
display plane. 

A range of Size Controls are available. For the Fast 3D orientation option, only 
the Font Size control is available (in points). Enabling the Constant checkbox 
(for the other orientation options) will keep the labels at the specified size (relative 
to the screen) regardless of zoom level. If the Constant option is disabled, Lower 
and Upper Limits can instead be set:

• Block - labels will disappear when the applied zoom level takes the label 
past the specified limit,

• Clamp - labels will be locked to the specified limit when the applied zoom 
level takes the label past the specified limit.

The label position relative to the data (collar) location can be altered using the 
Alignment controls (either preset or manual positioning). The first row of controls 
concern label positioning in the label plane (i.e. the relative XY components), 
whilst the second row controls the vertical height of the label with respect to its 
initial plane (i.e. the relative Z component).

The angle of the labels can also be set by moving the red-tipped arrow on the 
compass in the Rotation panel at the bottom of the dialog. The Fixed and Fast 
3D labelling options also provide a Dip control (half-compass) in this panel.

Note Rendering labels as extrusions is memory intensive and will affect 3D 
performance. It is not recommended for large numbers of labels.
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Symbols

The collars and/or bottoms of drillholes can be annotated with a symbol by 
enabling the Collar Symbol or Bottom Symbol options in the Symbol tab. The 
adjacent buttons open the Symbol Selector dialog allowing you to choose from 
an extensive library of symbols. Choose a symbol from the list to view a preview 
on the right side of the dialog. The symbol Size and Fill Colour can also be 
modified. 

Symbol Selector dialog

Advanced Symbol Style Options are available via the Advanced button. 
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Advanced Symbol Style Options dialog

A range of symbol orientation options are presented in the pull-down list at the top 
right of the dialog:

• Facing Viewer (default) – Symbols are aligned parallel to the viewing/
screen plane so that they always face the viewer. 

• Fixed 3D – Symbols are fixed in the 3D environment. The pull-down list in 
the Rotation panel at the bottom of the dialog controls the initial 
orientation: Flat (the XY plane) or Upright (XZ plane).

• Fast 3D – identical to the Fixed 3D, except that no Style controls are 
available. This is a very fast and memory-efficient option.

The Style button is only available for the Facing Viewer and Fixed 3D orientation 
options. It allows symbols to be extruded either as filled Polygons or Line 
Segments (wireframe) using the Format pull-down list. The depth of the symbol 
is set using the Extrusion control, expressed as a percentage of the symbol size. 
To display a flat symbol, set the Extrusion to 0%. The symbol is extruded 
perpendicular to its display plane. 
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A range of Size Controls are available. For the Fast 3D orientation option, only 
the Font Size control is available (in points). Enabling the Constant checkbox 
(for the other orientation options) will keep the symbols at the specified size 
(relative to the screen) regardless of zoom level. If the Constant option is 
disabled, Lower and Upper Limits can instead be set:

• Block: symbols will disappear when the applied zoom level takes the 
symbol past the specified limit,

• Clamp: symbols will be locked to the specified limit when the applied 
zoom level takes the symbols past the specified limit.

The symbol position relative to the data location can be altered using the 
Alignment controls (either preset or manual positioning). The first row of controls 
concern symbol positioning in the symbol plane (i.e. the relative XY components), 
whilst the second row controls the vertical height of the symbol with respect to its 
initial plane (i.e. the relative Z component).

The angle of the symbols can also be set by moving the red-tipped arrow on the 
compass in the Rotation panel at the bottom of the dialog. The Fixed and Fast 
3D labelling options also provide a Dip control (half-compass) in this panel.

Colour Modulation

Drillhole traces can be colour modulated using controls provided under the 
Colour tab of the Drillholes Properties dialog. For example, colour drillholes 
based on a downhole lithology, assay, or alteration field. 

Note Rendering symbols as extrusions is memory intensive, and will effect 3D 
performance. It is not recommended for large numbers of symbols.
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The Colour tab configured to colour modulate drillhole traces using a lithology field and a 
custom colour legend.

Enable the Colour tick box and set the desired data field from the adjacent pull-
down list (available data fields are named with the following convention: 
Tablename_Fieldname). Click the first Edit button to open the Colour Scale 
dialog. 

In the Colour Scale dialog, select a custom Legend if one has already been 
created using the Legend Editor (see Using the Legend Editor), either in 3D or 
more typically in 2D as part of Discover Drillhole Project. A range of standard 
colour interpolations (RGB & HSL) and Look-Up Tables (see Using the Colour 
Look-Up Table Editor) are also available. 

The Field Data Conditioning button at the far right of the Colour tab is used to 
apply conditions to the selected colour field. Conditions available include data 
capping (i.e. setting upper data limits to minimise nugget effect for assay data) or 
excluding unwanted categories from the display (e.g. overburden such as soil 
and alluvials). See Field Data Conditioning Tool for use of this tool.



14 Working with Drillholes and Trenches in 3D 299

Displaying only particular colour modulated geological intercepts by i/. Selecting only target 
rock types using Field Data Conditioning; ii/. Disabling the Show Gaps option in the 
Appearance tab & iii/. Displaying the same drillhole project as another branch in the 
workspace tree, using a Lines display style.

Note The Field Data Conditioning dialog is also an excellent way to visualise only 
the desired subset of a dataset: for instance only Quartz_Vein and Fault 
lithological intercepts, or only Au assays between 5 & 15g/t. Once a subset is 
specified, try turning the Show Gaps option Off (under the Appearance tab), 
then add another Drillholes branch to the Workspace Tree populated with the 
entire dataset, but displayed as simple Lines.

Note Activating the Override background colour option in the Colour tab will 
replace any background colours applied via a Legend in the Appearance tab 
with the colour specified in the Appearance tab.
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Drillhole Colour Legends

An onscreen colour legend Floating Colour Bar can be added to the 3D display 
which is referenced to a colour modulated drillhole project. This enables the user 
to easily visualise the relationship between different drillhole colours and the 
corresponding lithology or assay range values. See the Floating Colour Bar 
section of the 3D Interface chapter for further information.

Example of a Floating Colour Bar linked to a drillhole project colour modulated by geology; 
a colour legend with an entry for each rock type is displayed

Thickness Modulation

Drillholes can be thickness modulated in the Appearance tab either by:

• Single field modulation using the 3D Tube style.

• Multiple field modulation using the 3D Rose style.
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To vary thickness of drillholes by a single numeric field:

(e.g. assay or geophysical downhole data)

1. In the Appearance tab set the hole style to 3D Tube.

2. Enable the Modulate Thickness option at the bottom left of the dialog

3. Select the required downhole value field from the adjacent pull-down list

5. The thickness range can be applied either by:

4. Use the adjacent Field Data Conditioning button (see Field Data 
Conditioning Tool) to remove any null values from the dataset, or to limit 
the data range to that of interest (e.g. all Au values above 50ppb)

• A default linear transform between the set From and To values. 
The transform method can be altered using the adjacent Data 
Mapping button (options include log and histogram transforms). For 
more information, see Advanced Colour Mapping.

• A custom legend of data ranges and associated line thicknesses 
selected using the adjacent Legend selector button, created with 
the Legend Editor (see Using the Legend Editor).
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6. Press Apply or OK to complete this process.

An example of drillhole thickness modulation using a single assay field. This dataset has 
also been colour modulated to reinforce the visual display. Additionally data conditioning 
has been applied to remove all non-anomalous results (and the Show Gaps option 
disabled), thereby focussing attention on the significant intercepts. The same dataset was 
also displayed as a second Drillhole branch in the Workspace Tree, using a Line display 
style, to provide a continuous spatial reference/skeleton for each hole.

To vary thickness of drillholes by multiple numeric fields simultaneously:

(e.g. assay or geophysical downhole data)
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1. In the Appearance tab set the hole style to 3D Rose.

2. In the Thickness section of the tab, leave the modulation to By default, 
and set the From and To values as required (these are the minimum and 
maximum thickness values for the drillholes). 

3. Press the Petals button (top right of the dialog) to open the Petal 
Channels dialog.

Note It is not recommended to use the By legend option for multiple field modulation.
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Specify the thickness of selected drillhole database fields for 3D Hole display

Up to 8 numeric downhole data fields can be specified by checking a 
Show box and selecting the required field to display from the adjacent 
pull-down lists. Available data fields are named with the following 
convention: Tablename_Fieldname. For each field the following options 
are available:

• Colour - specify a standard or customised colour to display the 
data in the selected field.

• Sharpen - this option squares the data to give greater weighting to 
larger values. This is a useful way of exaggerating the visual display 
of high grade intercepts.

• Enhance - display the value for each depth using a logarithmic 
expansion.

• Global - this option scales the data in each hole with respect to the 
entire dataset (as imported into Discover 3D), rather than scaling 
each hole individually.



14 Working with Drillholes and Trenches in 3D 305

The Appearance tab also contains the Thickness range, Initial angle and 
Discrete samples controls relating to this thickness modulation functionality.

Display Drillhole Logs Images

A useful 3D display technique for drillholes is to show a downhole log of measured 
drillhole data. This can be done by adding a bitmap of a drillhole log that has 
already been created using Encom Discover into the Discover 3D display, using 
the Discover 3D>View Logs menu option. The Drillhole Log is created as a 
georeferenced bitmap image (.EGB) and is rendered as an image curtain next to 
the 3D Drillhole.

In addition each field has a Field Data Conditioning button which can be used 
to condition the source data. Type of conditioning available include data capping 
(removing nugget effects), null value handling and invalid data assignment (e.g. 
removal of large negative values representing BDL or SNR that affect thickness 
distribution). See Field Data Conditioning Tool for use of this tool.

Note The Field Data Conditioning dialog is also an excellent way to visualise only the 
desired subset of a dataset: for instance only Au assays between 5 and 15g/t. 
Once a subset is specified, try turning the Show Gaps option Off (under the 
Appearance tab), then add another Drillholes branch to the Workspace Tree 
populated with the entire dataset, but displayed as simple Lines.

Note The colours set in the Thickness tab will be overwritten if a colour Legend has 
been selected in the Fields tab. Setting multiple downhole fields to display using 
thickness modulation in this instance is not recommended as it will be impossible 
to determine the individual thickness modulation fields in the 3D display. 
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Multiple drillhole logs displayed in Discover 3D

Step 1 - Open the drillhole project

Open the Drillhole Project using the Encom Discover>Drillholes>Project Setup 
menu option.

Step 2 - Select drillholes

Select the drillhole(s) in the collar map window to create a log display. The hole 
trace selected must also be visible in Discover 3D before a drill log can be 
displayed or rendered.  Use the Discover 3D>View Drillhole menu item in 
Encom Discover to display the selected drillhole trace(s).

Step 3 - Create drillhole logs

Select the Discover>Drillholes>Log Display menu option. Using the dialog, 
create a log using the settings available. Refer to the Drillhole Log Display section 
of the Discover Reference Manual for instructions on defining a log display. 
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Step 4 - View logs in 3D

When the drillhole log displays open in a map windows in Discover, select the 
Discover 3D>View Logs menu option. This will open the Export DH Logs to 3D 
dialog. Highlight the logs to be displayed in the 3D environment.

View Logs dialog

If drillhole log images are already displayed within Discover 3D, enabling the 
Overwrite existing images option will replace them with these newly selected 
logs. Otherwise, the newly selected logs will simply be added to the 3D display in 
addition to those already displayed. Enabling the Save Permanently option 
allows you to specify the output directory for these files (this defaults to the 
drillhole project directory) and retain these images at the end of the 3D session; 
otherwise the files will be saved to the assigned temporary directory. Click OK to 
display the selected logs in Discover 3D.

Alternatively, place the cursor in the log display window and right click to select 
the View in 3D menu item. This will add just the selected log display to the 3D 
window in a cumulative fashion.

Note The zoom level used for the display of the log in Discover determines the 
resolution of the log in Discover 3D. If the highest resolution is required in 
Discover 3D, zoom into the view in Discover.

Note If you do not have the selected drillhole trace displayed in Discover 3D before 
trying to display a drill log, the log is not displayed in Discover 3D.
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Step 5 - Set the display properties

Within Discover 3D you can use the Image tab of the Drillhole Properties dialog 
to control the orientation, scale and quality of the view.

Image tab of the drillhole property dialog

Note To place log displays directly adjacent to their associated drillholes (without a 
transparent buffer between them), enable the Best Fit option.

The bitmap created by Discover is automatically listed and the colour of ‘white’ is 
selectable to be transparent. Other colours can be chosen using the Browse 
button (shown left).  The degree of transparency can be controlled with the 
Transparency slider to allow view of items behind the log.

The log images are automatically orientated in Discover 3D according to the 
average azimuth of the corresponding drillhole. The Azimuth slider enables this 
initial azimuth to be modified by a constant value. Enabling the Uniform 
Azimuth option will force all images to orient along the same specified azimuth 
as set with the Azimuth slider (0o and 360o is north). The horizontal Scale can 
also be adjusted either via the Scale slider, or the Precision Scale button 
(shown left).
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Curtain width dialog enabling precise control of the image curtain scale

The Curtain Width dialog enables the width of the image curtain to be precisely 
controlled via one of three options:

• As Defined in the located bitmap header file.

• Related Quantity Defined by applying a user-defined Multiplier to the 
header file definition.

• Undefined - the width is calculated using the formula: Width = Constant + 
Multiplier * Image_Width, with the highlighted parameters user-defined.

Additional Image tab controls include:

• Option to Centre the curtain on the drillhole trace, or having its margin lie 
along the trace.

• Refine the quality of the bitmap .

• Adjust the Texture Interpolation Mode of the log. Lower quality texturing 
provides faster bitmap display and manipulation.
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Data Compression

The Decimation Scheme option in the Fields tab enables the display rendering 
performance to be improved by reducing the number of samples displayed down 
the hole. This option is generally only appropriate for larger datasets where 
geophysical data has been collected at a small scale (e.g. centimetre or 
decimetre) rather then geological data collected at a larger scale (eg metre). 

Three options are available:

• No decimation – all samples are utilised i.e. no compression applied (the 
default option).

• Fixed rate decimation – utilises 1 in every n samples, where n is a user-
defined value.

• Compressed - applies variable compression using the Tomek algorithm, 
which variably adjusts to the data via a user-specified compression factor.

Changing Trench Display Properties

Most aspects of Trench displays can be controlled from the Properties dialog 
opened from the Trenches branch of the Workspace Tree. To display the 
Trenches Properties dialog, either:

• Move the cursor over the Trench branch in the Workspace tree and double 
click with the left mouse button, or
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• Highlight the Trench branch in the Workspace tree and right-click to 
display the shortcut menu, and then select Properties.

Most settings available for Trench Properties are also found for the Drillholes 
Properties.

The display settings made on the Trench Properties dialog box can be saved or 
loaded from a settings file (see Saving and Applying Display Settings). The 
display controls available depend on the type of data and may include:

• Selecting Trenches

• Trace Style

• Colour Modulation

• Thickness Modulation

• Labelling

• Symbols

Saving and Applying Display Settings

Any display settings customized in the Trench Properties tab controls (e.g. 
colour or thickness modulation) can be saved for later reuse. This is an excellent 
way to maintain the same display settings between Trench project data updates, 
or between projects sharing the same data structure.

To save any current display settings, move the cursor over the Trench branch in 
the Workspace tree and right-click. Select the Save Properties option, and 
specify a name and location for the output display settings .XML file (e.g. a under 
the Trench project root directory, or in a user-created settings folder elsewhere).

To reapply display settings at a later date (e.g. for an updated version of the same 
drillhole project, or another project ), first load the Trench project into 3D. Move 
the cursor over the Trench branch in the Workspace tree and right click. Select 
the Load Properties option, and browse for the desired settings .XML.

Note Display settings can only be applied to Trench projects that have exactly the 
same table names and field names and types. Any differences in table names or 
structure will likely cause settings to not display.
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Selecting Trenches

The Trench tab of the Trench Properties dialog allows the user to control which 
trenches are displayed. Specify the trenches to be displayed by moving the trench 
name(s) from the Hide to the Show list. Alternatively, you can graphically select 
the holes to be displayed from a collar map using the Graphical Selection button.

Trace Style

The trench trace styles are the same as for Drillholes; see Trace Style for more 
information.

Colour Modulation

The trench trace styles are the same as for Drillholes; see Colour Modulation for 
more information.

Thickness Modulation

The trench trace styles are the same as for Drillholes; see Thickness Modulation 
for more information.

Labelling

Trench start and ends can be annotated with labels by enabling the appropriate 
tick box in the Symbols tab. To change or customise the label display, click the 
adjacent Start Label, End Label or Distance Label button to open the 
Advanced Arrangement dialog.

The Start and End Label buttons display the current label in a text box at the top 
of the dialog; to change this, highlight the entire text entry and click the Field 
Selection button (shown left). Select the desired field from the displayed list 
(populated from the trench collar file). Multiple fields can be displayed together by 
placing the cursor at the desired insertion point within the text window (without 
highlighting any existing text) and then selecting extra fields from the field 
selection list (without highlighting any existing text) and then selecting extra fields 
from the filed selection list.

The Distance Label button replaces the text box with a Format button; this can 
be used to set numeric formatting, prefixes and suffixes. Activating the Distance 
Label option also requires setting a Distance Interval in the Appearance tab (i.e 
how often trench distances are displayed).
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For all label types, standard Font controls are provided, as well as a range of 
orientation options in the adjacent pull-down list.

Symbols

The collars and/or bottoms of trenches can be annotated with a symbol by 
enabling the Start Symbol or End Symbol options in the Symbol tab. The 
adjacent buttons open the Symbol Selector dialog allowing you to choose from 
an extensive library of symbols. Choose a symbol from the list to view a preview 
on the right side of the dialog. The symbol Size and Fill Colour can also be 
modified.

Advanced Symbol Style Options are available via the Advanced button.

Drillhole Planner

Utilities>Drillhole Planner

Discover 3D provides the powerful capability to dynamically position and plan 
new drillholes directly within the 3D environment. This allows the user to target 
3D objects such as voxel isosurface grade shells, extruded quartz veins, .DXF 
solids (such as alteration zone volumes generated from digitized section 
boundaries) or feature object interpretations. Additionally, the drillhole planner 
can automatically calculate a collar location using a specified target’s 
coordinates, intercept dip and azimuth, and will take into account real-world hole 
deviations.
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The Drillhole Planner is accessed from the Utilities menu in the 3D interface.

Planning Drillholes in 3D

1. Open all required targeting data into the 3D window (e.g. existing drillhole 
project, grade shell isosurfaces, mineralization solids, etc). 

2. If a topographic/DEM grid is to be used for for the collar location, see the 
Collar RL/Z Value Assignment section:

3. In 3D, open the Utilities>Drillhole Planner menu option.

5. Set the required Dip Sense (i.e. whether down dip is negative or positive) 
and Drillhole Units (default metres).

The Drillhole Planner can construct drillholes either from a specified collar 
or to a specified target.

Planning a drillhole from a specified collar location.

1. Use the 3D Navigation controls (see Navigating in 3D) to orientate the 
view to the first proposed collar location and press the Create button on 
the Plan Holes tab of the Drillhole Planner dialog.

4. On the Manage Project tab, use the New button to create a new 
Drillhole Planner Project to add the new drillholes to. Specify a project 
name and location and click Save. This will create two files: 
projectname_collars.TAB and projectname_surveys.TAB.
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2. The New Drillhole dialog will open, with a default Hole ID ‘DH1’ 
populated. Change this if required and select the Specify collar position 
option. Press Create. The new hole will be listed in the Drillhole Planner 
dialog, with various default attributes.

3. The drillhole collar can be positioned either: 

• Manually by entering the Collar X & Y coordinates (and Z value if 
no grid is being utilised - see Collar RL/Z Value Assignment). Press 
the Update button to visualise the planned hole location (a point 
symbol will be added to a new temporary Feature Database called 
DHPlanner_Collars)

4. Set the hole Type as either Straight, Constant Deviation or Variable 
Deviations. Drillhole Types are discussed fully below; this example will 
use the straight type.

5. Type the desired Collar Azimuth, Collar Dip and Total Depth (Length) 
values. The current view direction bearing and inclination is displayed at 
the bottom right of the 3D window in the status bar; this can be used as a 
guide to the required azimuth and dip parameters.

6. Press the Apply button at the bottom of the dialog to create the drillhole. A 
new Drillhole item will be added to the workspace tree, called 
projectname_collars, and the planned drillhole will be displayed. 

7. If any aspect of the drillhole is incorrect, modify as necessary on the Plan 
Holes tab (e.g. Total Depth/Azimuth/Dip) and press Apply again to 
recreate the hole.

8. Repeat steps 1 through 8 for each additional drillhole required.

• Dynamically by pressing the Pick Point button, and clicking on 
the desired location in the 3D window. If no gird is being utilized 
(see Collar RL/Z Value Assignment), the collar Z value will be 
populated using the z value of the cursor plane at the location 
selected. A point symbol will be added to a new temporary Feature 
Database called DHPlanner_Collars. The hole location can be 
then manually edited or dynamically repositioned again using the 
Pick Point button. Press Update to preview any manual changes 
to the location (e.g. subtle RL changes).
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Planning a drillhole using a specified target location.

1. Press the Create button on the Plan Holes tab of the Drillhole Planner 
dialog; the New Drillhole dialog will open, with a default Hole ID ‘DH1’ 
populated. Change this if required and select the Specify target position 
option. Press Create. The new hole will be listed in the Drillhole Planner 
dialog, with various default attributes.

2. The drillhole target can be positioned either:

• Manually by entering the Target X, Y & Z coordinates . (To visualize 
your target location in 3D, select the Pick Point button, click roughly 
in the area of interest, then manually edit the X, Y & Z coordinates 
and press the Update button. A point symbol will be added to a new 
temporary Feature Database called DHPlanner_Collars)

• Dynamically by pressing the Pick Point button, and clicking on the 
desired location in the 3D window. The target Z value will be 
populated from the cursor plane Z value at that location. A point 
symbol will be added to a new temporary Feature Database called 
DHPlanner_Collars. The target location can be then manually 
edited (press Update to alter the corresponding 3D location) or 
dynamically repositioned again using the Pick Point button.

3. Select the hole Type as either Straight or Constant Deviations. Drillhole 
Types are discussed fully below; this example will use the straight type.

4. Enter the desired Target Intercept Azimuth and Target Intercept Dip 
angles. These represent the orientation of the hole when it intercepts the 
target location; this is particularly useful when trying to intercept planar 
features at a right angle (e.g. quartz vein). 

5. To ensure the hole adequately penetrates the target body, enter an 
appropriate Extension Depth (Length); this is the distance the hole will 
continue past the target location. A value of 0 will terminate the hole at the 
target coordinates.

Note The current view direction bearing and inclination is displayed at the bottom right 
of the 3D window in the status bar; this can be used as a guide to the required 
azimuth and dip parameters.
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6. The drillhole planner will construct a drillhole upwards from the target 
location; it therefore requires a collar RL to finish the hole construction at. 
The recommended option is to specify a topographic grid surface (e.g. 
such as a digital elevation mode (DEM) created or imported with 
Discover's Surfaces module) by enabling the Use surface for collars 
option at the top of the dialog, and browsing for the grid file.  If no surface 
grid is specified for the collars, you will need to manually enter a Collar 
Elevation. More information on these options can be found under Collar 
RL/Z Value Assignment.

7. Press the Apply button at the bottom of the dialog; the drillhole planner 
will calculate (using all hole parameters specified) a hole upwards from 
the target location to either the specified topographic surface or collar 
elevation. A new Drillhole item will be added to the workspace tree, called 
projectname_collars (i.e. the project name specified in Step 4 above), 
and the calculated drillhole will be displayed.

8. If any aspect of the drillhole is incorrect, modify as necessary in the 
Drillhole Planner (e.g. Azimuth/Dip parameters) and press Apply again to 
recreate the hole.

9. Repeat steps 1 through 8 for each additional drillhole required.

Note If you are evaluating possible collar locations for different azimuth/dip 
parameters on the same target, simply create a series of  potential holes (e.g. 
12A, 12B, 12C 12D) using the same target location information. Select the first 
hole containing the target location information in the Drillhole Planner, press 
Create and enable the Copy settings from current drillhole option in the New 
Drillhole dialog. This will create a new hole duplicating the selected holes target 
parameters; modify the azimuth/dip parameters.
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Experimenting with different hole orientations and their resulting collar locations in order to 
intercept a fault plane target location.

Collar RL/Z Value Assignment

Collar Z/RL values can be assigned to your planned collar locations in four ways:

1. By utilising a topographic/DEM grid imported as an image. When the Pick 
Point button on the Plan Holes tab is used, the drillhole location is 
snapped to the image and therefore uses the images Z value (i.e. the Z 
value of the grid the image is draped over). To utilise a surface grid in this 
way -

• In 2D, open the topographic grid into a MapInfo map window, and 
use the View Map in 3D menu option to capture a view of the grid 
draped over itself.
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• In 3D, alter the transparency of this image to between 40% and 
60%.

• Make the image Selectable in the Workspace Tree.

• Click the Bond to Image button on the Cursor Plane toolbar. The 
cursor plane is now bonded to the DEM image. 

2. Manually by entering the required value in the Collar Z or Collar Elevation 
field on the Plan Holes tab. This also allows an existing Z value (e.g. one 
captured using a grid in first method above) to be modified

3. By specifying an alternative grid from within the Manage Project tab of 
the Drillhole Planner dialog via enabling the Use surface for collars 
option. This allows grids that have not been imported into MapInfo 
Professional/Discover to be utilised for the Z value. When using the Pick 
Point button, Discover 3D will first determine the XY coordinates of the 
selected point on the horizontal cursor plane, and then determine the Z 
value for the selected grid for these coordinates. Therefore the most 
accurate way of dynamically capturing a point location for this method is to 
use the Down view button on the View Direction toolbar.



4. Using Pick Point button on the Plan Holes tab to select a location on the 
cursor plane and capture this points RL value (as displayed in the bottom 
middle of the 3D window). See Cursor Plane for more information on 
controlling the cursor plane position.

Drillhole Types

The Drillhole Planner allows 3 types of drillholes to be created. All types require 
a collar or target Azimuth and Dip value to be specified, as well as the Total Depth 
of the drillhole.

Straight

A simple straight-line drillhole from the collar location, requiring only collar 
azimuth and dip values to be specified, as well as the total depth/length of the 
hole. Examples include boreholes, vacuum drilling and possibly RAB (Rotary Air 
Blast) reconnaissance drilling.

Constant Deviation

This allows a planned hole to accommodate a constant dip and/or azimuth 
change per specified over distance (over the entire length of the drillhole). For 
example, an expected shallowing/rising hole might have a dip change of 0.8 
degrees every 25m set (based on previous drilling in the area).
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A constant deviation hole set to rise 0.8 degrees every 25m.

Variable Deviations

Individual downhole azimuths and dips can be set at specific depths for the 
planned drillhole. This allows a drillhole to mirror an existing drillholes downhole 
variations. 

Note Changes are added to the existing azimuth/dip value. For instance if the collar 
dip is -60, and a dip change of +1.1 degrees is set every 25m, at 50m downhole 
depth the dip will be -47.8.

Note This option is currently not available when when specifying a target XYZ location
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A variable deviation hole with a series of downhole variations entered.

Targeting Example

The following images illustrate a simple but powerful use of the Drillhole Planner. 
They present a common situation where the geologist is using an existing drill pad 
to target mineralization at depth. In this case the target is a 5g/t gold grade shell 
generated by exporting an isosurface from a drillhole gold distribution voxel model 
(created by 3D gridding of existing drilling).

Use the Add row button to add each required downhole survey entry, and enter 
the appropriate Distance, Azimuth and Dip values.
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Image 1: Initial hole generation as a straight hole, using the standard collar dip of -60 
degrees orientated towards the target. 
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Image 2: Using existing drillhole variations as a guide, the proposed hole is changed to a 
Constant Variation type, and set to rise 1.2 degrees every 25m. The hole now intersects 
the target, but barely.
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Image 3: The collar dip angle is now refined to maximise target intersection, eventually 
settling on a -58 degree dip. 
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Image 4: The proposed hole depth is extended to 480m to ensure the target is fully tested.

Drillhole Planner Projects

After a hole’s attributes have been specified on the Plan Holes tab, pressing the 
Apply button uses the .DPP file to generate the necessary MapInfo collar and 
survey tables; these can then be used to visualise these holes both Discover and 
Discover 3D. The output .TAB names and location are displayed on the Manage 
Project tab:

The Drillhole Planner tool creates Drillhole Planner Project (.DPP) files to 
dynamically handle drillholes. These can be created and reopened using the 
New and Open buttons on the Manage Project tab. 
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A drillhole planner project can also be created from an existing Discover Drillhole 
Project. This allows a number of existing real-world holes to be utilised as 
templates for proposed holes i.e. to mirror an existing drillholes downhole azimuth 
and dip variations for a hole planned in a proximal location. It can also be used to 
design daughter or wedge holes off an existing drillhole. 

To use existing drillholes as templates:

1. On the Manage Project tab, click the Import button and browse for the 
source collar and survey files (these must be part of an existing Discover 
drillhole project).

2. A drillhole Selection dialog will then be displayed- select only the required 
drillholes to be used as templates.

3. Specify a new .DPP file to store these templates in.

4. The selected holes will be displayed on the Plan Holes tab. It is 
recommended to use the Rename button to rename these holes (to save 
confusion with the original holes (e.g. rename CHRC112 to CHRC112A).

5. If designing multiple daughter or wedge holes off a parent hole, select the 
parent hole in the Drillholes list, and press Create. Assign a new hole 
name (e.g. CHRC035B) and enable the Copy settings from current 
drillhole option – this will copy the parent holes deviation data to the new 
hole. Disable the Use Offset option. Press Create.

6. Alter the holes as necessary and visualise.

An open drillhole planner project can be renamed and saved as a new project on 
the Manage Project tab. 

Note You should only copy settings from Target specified holes to Target specified 
holes and Collar specified holes to Collar specified holes.
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15 Viewing Seismic Sections
Discover3D>View Seismic Sections

The Seismic Sections tool allow you to create projects by directly opening SGY 
files (also known as SEG-Y), along with support for various navigation or velocity 
models files. Sections can be viewed as either two way travel time or a depth axis. 
You can then manually or auto-pick horizons and define velocities for each facies 
or region within the horizons. Sections can be exported as 3D geo-located vectors 
and images or a 2D Plan map of the survey lines.

Seismic Workflow

When seismic data is received, in the form of SEG-Y (.SGY, .SEG or .SEGY files), 
there is a general workflow to generate Discover 2D plan maps or Discover3D 
depth image of this data.

The key steps are:

A. Create and configure a new seismic project and add SEG-Y files:
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B. Assign navigation and coordinate information

C. Visualise section data

D. Digitize horizons on a section

E. Assign velocity values to a section.

F. Generate 2D plan of the track lines

G. Generate 3D output for the depth sections

A. Create and configure a new seismic project and add SEG-Y files:

1. Select Discover3D>View Seismic Sections

2. Start a new project with File>New Project, or open an existing project 
with the File>Open Project. When Seismic Sections starts up it will 
automatically load the last project worked on.

3. Set a project name (SPR file) in the project directory, under which all the 
SGY files are located.

4. Tick the Find and add all SGY files for auto import of SGY files already in 
the project directory.

5. Set the Line Name Pattern to assist in file name matching. For example if 
your lines are ordered -

WB-401, WB-402, WB-403 etc

6. Then set the line pattern to be

AA-NNN where A=alpha and N=numeric and *=skip(wildcard)

7. Any SGY files with suffixes after the Line name will be included in the 
line's metadata, for example -

WB-401.sgy, WB-401_part2.sgy, WB-401_part3.sgy

8. Will all be reduced to the line number WB-401 and used to match other 
files like WB-401.west and extract coordinates from a Nav text file that 
has columns containing line number (WB-401) and trace (shot) number.

Note The SGY file must begin with the line number. If you have files like “lineWB-
401.sgy” then remove the prefix, i.e. ****AA-NNNN



15 Viewing Seismic Sections 331

9. If WEST files are present, tick the Find West file per SGY so that .west 
files matching SGY files will be imported. The scanning of files by default 
will look for both <linenumber>.west and <SGYFile>.west files (i.e. 
the asterisk implies both <linenumber> and <SGYFile> names will be 
attempted).

10. You can use one Navigation (text) file for every SGY file in the project, or 
you can let the dialog scan for a file per SGY file for the available 
navigation types.  See B. Assign navigation and coordinate information for 
more details.

11. The scanning of per-SGY navigation files by default will look for both 
<linenumber>.west and <SGYFile>.west files (i.e. the asterisk 
implies both <linenumber> and <SGYFile> names will be attempted).

12. Select Projection Override and define  projection to use for all sections in 
the project.

13. Select Test Line Name to Nav matching, to ensure all SGY files and 
lines have valid navigation information.

14. If new data is received, you can use File>Open Section or Section>Add 
to add SEG-Y files to your existing project (select multiple by holding the 
Ctrl key).

B. Assign navigation and coordinate information

1. After a project is created you can review and edit the Coordinate 
information for individual Sections by selecting Section>Properties. 

2. The Coordinates formats supported per Section file are: 

• SGY: The SGY file  contains typically long integers at trace header 
bytes 73,77

• West: A supplied .west file

Note If new SGY or metadata files are added to the project, the File>Project Settings 
can be re-run at any time to create a new project, which will allow batch 
importing and editing of Section Properties.

Note If you wish to batch edit section coordinates settings, new the File>Project 
Settings can be re-run at any time to create a new project, which will allow batch 
importing and editing of Section Properties. 
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• Nav: A column delimited text file

• UKOOA: A UKO format file

• Ends: Manually enter the coordinates of 2 traces in the section.

3. For all coordinates types select the Config… button to configure the 
format of the source regarding the decoding of values (decimal, DMS, 
Easting/Northing). The following formats of coordinate data can be 
decoded

• Easting / Northing

• Longitude / Latitude from decimal

• Longitude / Latitude from [D]DDMMSS

• Longitude / Latitude from [D]DDMMSSF  (fraction tenths)

• Longitude / Latitude from [D]DDMMSS.FFA  A=N/S or E/W

4. For Text Files (Nav) select Config to specify the header size as Skip 
Lines. Also specify any comments by the Comment character. Select the 
applicable Delimited characters or Fixed width sizes between the 
columns (separate the sizes with commas).

5. In the Header text box, you will need to provide names for each column/
field in the file, separated by a comma. The Header column names must 
include following column names:

• LINE
The line number column (also known as Track)

• TRACE
The trace number column (also known as Shot, for example in un-
stacked data)

• X
The source of Longitude or Easting

• Y
The source of Latitude or Northing 

• SKIP
All other columns should be labelled as skip 
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6. If the SGY data file does not start at the first shot (trace) recorded in the 
navigation, define the shot that it does start at in the First Trace box.

C. Visualise section data

1. Select the section file to view from the list on the toolbar.

2. The current view style can be changed by selecting from View>Wiggle 
Trace (time axis), View>Time or View>Depth.

3. The velocity value can be visualised by selecting View>Velocity tint.

4. Zoom and pan the view by selecting the various controls from the toolbar.

5. The view can also be scrolled using the horizontal scrollbar located below 
the section.

6. A dynamic profile of individual traces can be viewed by select 
View>Profile.

D. Digitize horizons on a section

1. With the auto-pick tool, simply click on the event (pick) in any trace in the 
section, and the horizon will be automatically generated for this event 
across the section.

2. Alternatively you can create the polylines (horizons) manually by creating 
a series picks (points). Make sure you draw past the edges of the data or 
cut though another horizon so the horizons define enclosed velocity 
regions. You can cut lines, and you can join lines by moving the end point 
of one line onto the end point of another line.

Note It is strongly recommond to define a Project Navigation under File>Project 
Settings>Nav



334 Encom Discover 3D User Guide

3. You can undo any changes by selecting Edit>Undo or Edit>Redo.

4. Label your horizons and change their line style by double-clicking on a 
horizon line.

E. Assign velocity values to a section

1. By default a section will display with a single default velocity as set under 
the project settings. Alternatively if a .WEST file is available for the 
section, this information will be displayed.

2. Define the available velocities for the project by selecting the edit 
velocities button on the toolbar. Velocities can be given a name, as well as 
the speed and colour to display. 

3. To assign a velocity to an area in the section, enclosed by horizons and/or 
the edge of the section, select the velocity from the list and use the colour 
fill tool to click in the area.

F. Generate 2D plan of the track lines

1. Select View>Plan View to open a plan view of the sections navigation/
coordinate data.

2. Select the Open tick box to auto-open the output TAB file in MapInfo 
Professional.

3. Click Make TAB file to generate a MapInfo vector file for the seismic lines.

4. After the TAB file is created, the Section SEG-Y files can be reopened 
form within MapInfo Professional and Discover, by selecting the SEG-Y 
line, then select Discover>Table Utilities>Open Linked Documents. 
The associated section will be automatically opened for viewing.

G. Generate 3D output for the depth sections

1. Select Section>Generate 3D 
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2. To generate an image for the currently viewed SGY select Current. To 
generate image layers for all sections in the project select All.

3. Select the output style as Depth (Greyscale).

4. (Optional) For the output style, select Velocity Tint .The tint transparency 
will be the same as defined under File>Project Settings>Appearance.

5. Select an output directory for the files. By default, it will in the project 
directory in a new "out" folder. The files will be automatically named by the 
seciton or the project.

6. Select an output type: Horizons lines, Velocity regions or Images of the 
section. The digitized horizons and velocity regions can be output as 
either DXF vectors or an editable FDB file.

7. Select Generate 3D to create the image files.

Seismic Project Files

A project (.spr file) can contain many seismic lines (.sgy files), as well as 
associated files for coordinate information and velocity models.

In addition the following files may be present:

•  A source of velocity for time to depth conversion (.west file or manual 
velocity creation in .vel).

•  A source of navigation coordinates (in SEGY, .nav, UKOOA or manual 
input)

• A file to store any digitized horizons, .bdy.

• A file to save the current view, .spv.

If your section file has a matching .west velocity file it will be loaded and the 
velocity tint displayed by default. You can change a section’s velocity and 
coordinates source using Section>Properties. If there are no velocity files you 
can create horizon boundaries and colour fill between the boundaries with a 
velocity value.

File format details of .west  

West navigation files do not strictly follow a standard format. In standard files the 
trace index is read from columns 5-15 (in bold):
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In non-standard files the trace index is read from columns shown in bold:

For these cases with VELF data, it is consistently located as a maximum of 5 pairs 
(5 chars per value) from column 21

If neither of these are present, then often SPNT X and Y data is present instead 
of VELF. SPNT is inconsistent and so is scanned in from column 29 (in bold):

File Format details of layers

The layers are stored in the .SPR XML project file.

File Format details of .vel

The .vel file is a run length encoded grid of velocity pairs following a 16 byte 
header (Intel LSB). The 16 byte header consists of 8 zero bytes then the width 
and height in 2 four byte unsigned int. The values of width and height will be much 
less than the number of traces and samples. The data follows the header as pairs 
of count (four byte integer) and value (four byte float). The data runs row by row 
downwards. 

Coordinates

The source of coordinates for a SGY line is determined by the following sources: 

• SGY: The SGY file  contains typically long integers at trace header 
bytes 73,77

SPNT 72 100 0 0 
VELF 72 100 5000 600 5900 1400 … 
VELF 72 3000 9800 400010800 580011800 

CDFN 40
VELF 0 1891  212 2054  455 2289 …
VELF 1864 4211 2992 5029

VELF 216 100 5000  500 6100  800 6225 1100 6525 …
VELF 0 1921  208 2116  476 2535  627 3209 …

SPNT 119.00 631317 8057146
SPNT 72 100 0 0
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• West: A supplied .west file

• Nav: A column delimited text file

• UKOOA: A UKO format file

• Ends: Manually enter the coordinates of 2 traces in the section.

For all coordinates types select the Config button to configure the format of the 
source regarding the decoding of values (decimal, DMS, Easting/Northing). The 
following formats of coordinate data can be decoded

• Easting / Northing

• Longitude / Latitude from decimal

• Longitude / Latitude from [D]DDMMSS

• Longitude / Latitude from [D]DDMMSSF  (fraction tenths)

• Longitude / Latitude from [D]DDMMSS.FFA  A=N/S or E/W

For Text Files (Nav) select the Config… to specify the header size as Lines to 
Skip. Also specify any comment lines by the Comment character.

Select the applicable Delimited characters (note not consecutive) or fixed 
width sizes between the columns (separate the sizes with commas).

In the Header text box, you will need to provide names for each column/field in 
the file, separated by a comma. The Header column names must include 
following column names:

• LINE
The line number column (also known as Track)

• TRACE
The trace number column (also known as Shot, for example in un-stacked 
data)

• X
The source of Longitude or Easting

• Y
The source of Latitude or Northing 

• SKIP
All other columns should be labelled SKIP 
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Managing Views and Appearance

In the Seismic sections tool, the View menu provides the following options for 
displaying SGY data:

• Wiggle Trace – Wiggle trace profiles with two way time axis

• Time (greyscale) – view a rasterized image of the SGY data with black 
representing high peaks and white representing low peaks.

• Time (colour) – view a rasterized image of the SGY data, low and high 
peak colours are set under File>Project Settings>Appearance>Trace 
Colour.

• Depth (greyscale) – view rasterized SGY data depth corrected based on 
assigned velocities, with black representing high peaks and white 
representing low peaks.

• Depth (colour) – view rasterized SGY data depth corrected based on 
assigned velocities, low and high peak colours are set under File>Project 
Settings>Appearance>Trace Colour.

• Plan – view the project's section lines in a plan map, and export to 
MapInfo Professional.

For each view, the High Peak and Low peaks can be reversed, by toggling 
View>Invert.

For each view type, a velocity "tint" background colour can be applied by selecting 
View>Velocity Tint. The Transparency of this layer can be adjusted under 
File>Project Settings>Appearance>Velocity Opacity.

To view the SGY data in close detail, a trace profile can also be displayed (see 
Viewing Profiles).

To enhance the display of the seismic data, increase the contrast or AGC 
(automatic gain control) under File>Project Settings>Appearance. This will aid 
in interpreting weaker or noisy data.
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Digitizing Horizons

You can create horizons by drawing and editing polylines with the editing tools. 
You can draw the lines manually and colour fill between them with a velocity 
value/color. Make sure horizons are drawn past the edges of the data or cut 
through another horizon so that they define an enclosed region. You can cut lines, 
and you can join lines by moving the end node (pick) of one line onto the end node 
of another line. In auto pick mode you can click on the section and have a horizon 
generated.

• Autopick: Click on a trace sample to autopick a horizon. Clean up 
autopick’s attempt by using the following tools to edit, remove, cut and join 
lines. The sensitivity of Autopick can be adjusted under File>Project 
Settings>Auto Pick.

Note You can digitize faults by simply using the Pen tool to manually draw a sub-
vertical line. Then horizons can terminate where they intersect the fault line.
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• Pen: Click to start drawing a horizon (polyline). Each click adds a pick to 
the section appending to the current horizon that was last clicked. Right 
click to end the current polyline.

• Starting on the end of an existing horizon appends to it.

• Ending on the end of an existing horizon joins to it.

• Erase: Click on an existing horizon to erase the entire polyline, or click 
anywhere to reset to default velocity.

• Move Pick: Move a pick. Moving the end of a horizon onto the end of 
another horizon joins them as one continuous horizon.

• Insert Pick: Click on a horizon line section to insert a new point within the 
existing line.

• Remove Pick: Click on a point to remove.

• Line Break: Click on a horizon’s line section to break the horizon into two.

• Fill: Click between boundaries to colour fill the region with a velocity (as 
currently selected in the toolbar velocity combobox).

• Edit>Undo: Undo any edit operation above.

• Edit>Redo: Redo any edit operation above.

Before digitizing, it is recommended to setup your velocities and colours under 
File>Project Settings>Velocities. Each Velocity can be given a text name, 
colour and velocity value (m/s). These are saved in the project file.

Managing Horizons

After digitizing your horizons, change the line style and labels by hovering the 
cursor on a horizon and double left clicking.

Alternatively, review the entire set of horizons in a project by selecting 
Edit>Horizon List. You can change the labels, description and style here as well.

If the location of a Section changes , such as updated navigation data, the 
horizons may become mismatched. To rectify this, they can be shifted by 
selecting Section>Properties, and select the Edit button. Alternatively, you can 
remove all horizons from the section using Section>Remove all horizons.
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Viewing Profiles

Use the View>Profile Vertical or  View>Profile Horizontal to display a dynamic 
wiggle trace profile, when viewing the section in time mode.

The profile will automatically change the trace (shot) profile as you move the 
cursor horizontally across the section. The current cursor position is represented 
by a red dot on the trace.

It displays the Trace (shot) number from the X axis and the two-way-time from the 
Y axis. It also displays the sample (hydrophone/band/station) number. 

Dialog Help

• Project Settings Dialog Box

• Section Properties Dialog Box

• Digitizing Horizons

Note The profile is always displayed at 1:1 samples to pixel ratio. Increase the window 
size to view the entire trace.
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Project Settings Dialog Box

The File>Project Settings dialog contains tab to control setting that apply across 
all lines in the project. The settings are saved in the .SPR xml file. 

Appearance

• Trace Width: The width of space in between each wiggle trace, at 1:1 
zoom (when one SEGY sample (receiver) is one pixel).

• Wiggle Scale: The width of the maximum amplitude wiggle trace at 1:1 
zoom.

• Velocity Opacity: The transparency of the velocity tint over over the data. 
100% produces a solid (opaque) colour over the seismic data.

• Default Velocity: The default velocity when no velocity is supplied and no 
manual edits have been made. 

• Depth X: Is the maximum height of the depth display where: 

 (Max time) * (default velocity) * 0.5 (two-way time) * 1.5 (Depth X) = 1200m

Nav

• Line Pattern: Define the alphanumeric pattern for Lines based on SGY 
file names:

A = alphabetical character

N = numerical character

* = skip character

- = hyphen 

All other characters will be ignored. Spaces are not allowed.

• Project Navigation: Define a single delimited text file that defines 
navigation for all lines in a project.

• Projection Override: Define a fixed projection for all lines in the project.
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Layer Table

The layer table is a place to make a layer cake of velocities that will be used by 
SEGY lines that don’t yet have an associated velocity file (.west) or (.vel) from 
user edits. The layer cake is a good starting point for providing velocities before 
the user starts full editing. The layer cake is better than the single default velocity.  
Specify the thickness of each layer in two way time, and assign any velocity value. 
The depth of each layer is automatically calculated. 

These are stored in the project's .SPR XML file.

Velocities

The velocity table holds the discrete velocities and their associated colors that the 
project can use to render velocity tints. All table cells are editable by clicking. The 
name cell can be edited to a geological name like “Granite”. Use the generate 
function to create a range of colors suitable to the geology of the project’s dataset. 
All velocities are interval velocities.

These are stored in the project's .spr XML file.

Auto Pick

   The auto pick settings are used to control the sensitivity of the autopick function.

• Detect:  Snap the user’s click to the maxima or minima (note you can also 
invert the data's phase by selecting View>Invert)

• Window: The number of samples used to correlate one trace with its 
neighbors.

•  Likeness: The sensitivity of the neighbor correlation, on a range of 0 (off) 
to 100 (exactly identical). If set to 0 the autopick will continue to the end of 
the section.

• Look Ahead: The maximum number of bad traces that the autopick can 
jump over to continue.

• Trace Span:  The ideal spacing between picks on the horizon.

Section Properties Dialog Box

The Section Properties dialog controls how velocity and navigation data is 
sourced for a SEGY file. The velocity is needed for viewing time data with velocity 
tint and for time to depth conversion. Coordinate data is required for the 
generation of 3D view data.
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Time

• SGY File: Name of the seismic data file

• Line Name: Override the line name automatically determined from the file 
name, based on File>Project Settings>Nav>Line Pattern

• First Trace: Used to adjust the position of the SGY segment file along the 
shot line.

• Info (button): Display header of SGY, containing useful metadata.

Velocity

• West: The velocity is provided by a .west file. Specify whether the source 
contains Average (from surface to the bottom horizon) or Interval  (within 
the current horizons) velocities.

• Layers: Use the project’s layer cake for velocity.

• Editable: The velocity is editable and stored in a .vel file. This information 
can be changed by digitizing horizons and assigning different velocities, 
see Digitizing Horizons. When switching to Editable mode the user may 
choose how the editable data is initialized. It can be initialized from -

• Default Velocity  - the single default velocity for File>Project 
Settings>Project

• Copy from Layer Table - the Layers defined for File>Project 
Settings>Layers

• Copy from West - the West file information defined under the 
specified West option

•  Load Edit File - the current .vel file

Horizon

• Boundary: Edit the collection of horizons stored in the section Boundary 
file.

• Coordinates: Use either the Project navigation file, or define navigation 
data for the section. See {Coordinates} for more information.
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Plan View Dialog Box

The plan view shows the cruise/track plan of the SEGY lines and you can make 
a TAB file of the plan for viewing in MapInfo Professional. You will not see any 
plan if your SGY data is not yet associated with navigation data. Use the table at 
the top of the dialog to select sections and edit them to associate navigation data. 

• View coordinates as text to help verify that coordinates are being 
decoded correctly from Navigation data. 

• Make Tab file button will generate a TAB file of the plan for viewing in 
MapInfo Professional. It will be given the Project name and saved in the 
project folder.

Generate 3D Dialog Box

Use the toolbar button or select Section>Generate 3D to generate 3D vector, 
feature and image output of the sections, picks and velocity.

• Current: Generate output for the currently viewed section.

• All: Generate output for all sections in the project.

• Style: Select the display style for the output which corresponds to the 
section display Seismic Sections. This will affect the Z axis for every 
output (time or depth), and the colouring of the Section Images output.

In addition to the style, you can also apply the velocity tint layer (using the 
same transparency as in the main window).

• Projection: Override the project's navigation/coordinate projection. This is 
useful for lat/lon data, as it is recommended to use only projected data in 
Discover3D.

• Section Navigation:

• Strict: The navigation file must provide coordinates for exactly the 
first and last trace of the section.

• Truncate: Remove traces from the start and end of the section 
before the first navigation coordinates and after the last navigation 
coordinate.

• Extrapolate: Automatically generate coordinates for the first and 
last trace, based on the bearing of the first/last segment in the 
navigation file.
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• Curtain Segmented every: Define the gap width between inflexion points 
in the Line. This defines the resolution for the bends of the seismic lines. 
For long or straight limes, this can be increased.

• Image: Define the resolution for the Section Image file.

• Output Type: Select the output file type, as either -

• Horizon Polylines: 3D Polylines vectors for the digitized horizons 
and picks.

• Velocity Mesh: 3D triangular mesh for the regions enclosed by the 
horizons. Coloured by their assigned velocity colour.

• Section Image: Registered raster image in 3D, optionally define a 
DEM Grid to "hang" the image off.
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16 Digitizing and Managing 3D Features
The Discover 3D Features menu provides access to a powerful set of utilities for 
creation, storage, manipulation and display of 3D Features. 

A 3D Feature is a three dimensional geometric entity which consists of one or 
more 3D point objects. Features can be:

• Simple geometric entities such points and line objects.

• More complex 3D objects such as polylines and polygons.

• Triangulated irregular network (TIN) surfaces, both open surfaces (e.g. 
fault planes) and closed polyhedral surfaces (i.e. solids/volumes).

Features can be easily used to represent real world entities such as geological 
boundaries, orebody grade shells, structural/fault surfaces and intersections or 
any other general three dimensional feature of interest. Features can be created 
in many ways:

• Digitised directly into Discover 3D (e..g snapping to drillhole intercepts) as 
points, polylines and polygons

• Created from vector data in MapInfo/Discover, such as  drillhole section 
boundaries

• Extruded from 2D vector objects to create open and closed triangulated 
surfaces such as fault planes and buildings

• By wireframing (with tieline controls) between features in 3D to create 
complex triangulated surfaces and volumes such as watertable levels and 
orebody models

• Importing existing triangulated models/objects from other applications 
such as AutoCAD DXF, Datamine wireframe and Vucan triangulation files

• Importing and converting gridded surfaces (as created with Discover's 
Surfaces module) such as topographic grids into triangulated surfaces
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Features are stored in a Feature Database. A Feature Database is a special type 
of relational database that supports complex three dimensional geometric objects 
and associated attributes. Each Feature Database contains one or more features, 
e.g. supergene ore boundaries, interpreted fault lines, etc. Features can contain 
both geometric information and accompanying attribute information which is 
stored in related fields within the database.  Feature Databases can be queried 
using a simple SQL based query language to extract subsets of the database 
using a combination of attributes and/or geometric properties.

Aside from viewing in Discover 3D, features can be used with the 3D Solid 
Generator (see Modelling Triangulated Surfaces and Solids). The 3D Solid 
Generator joins a number of features together to produce a three-dimensional 
enclosed or planar surface; i.e. a solid body to represent an ore body zone or fault 
plane. Volumes can be calculated for enclosed 3D Solid bodies. 

Features can also be exported into Discover Drillhole Sections (as MapInfo 
Professional TAB files), as well as a range of other formats.

Features are managed from the Features menu in the 3D interface, from which 
you can:

• Open and close an existing feature database (see Opening an Existing 
Feature Database).

• Create a new feature database (see Creating a New Feature Database).

• Modify the structure of any existing open feature database. For example, 
adding new fields or changing field names or types (see Modifying the 
Structure of a Feature Database).

• Import data in a range of vector and grid file formats (see Importing Data 
into a Feature Database).

• Export features to a range of industry-standard 2D and 3D file formats 
(see Exporting Feature Databases).

• Query a feature database using SQL expressions (see Select by SQL 
Query).

• Combine, Intersect, Erase, Merge, Triangulate, Aggregate, Disaggregate 
Resize, Delete, Cut, Copy and Paste features (see Editing Features).

• Set default fill and selection colours (see Feature Options).

• Manage features in the cosmetic layer (see Saving Cosmetic Features to 
a Feature Database).
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Feature Object Types

Discover 3D can create, import, export, edit  and manipulates five types of feature 
geometric objects. These are explicitly attributed in the Type field of the Feature 
Data Window, which also automatically and dynamically reports geometric 
information such as object centroid (and node) XYZ coordinates, length, area and 
volume. The five object types are: 

• Points - Individual nodes with solely an XYZ location. These can be 
digitised in 3D with the Create New Point Feature tool, or imported from 
a vector file.

• Polylines - Single or multi-segment line (linking nodes), These can be 
digitized in 3D with the Create New Line Feature tool, or imported from a 
vector file

• Polygons - Planar region/area consisting of multiple exterior nodes joined 
by external edges, with an internal planar fill. These can be digitized with 
the Create New Polygon Feature tool, or imported from a vector file.

(a) An example of a Polygon
(b) Triangulating a polygon to form a surface
(c) Moving nodes to form a non-planar surface

• Surfaces - A vast range of shapes are handled as surfaces, from semi-
planar fault planes and unconformities, to shapes with holes and unclosed 
regions (e.g. 'open' cylinders). Essentially, any object consisting of a 
network of triangular faces (facets) that does not fully enclose a volume.

(c)

(b)

(a)
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Surfaces can be created by:

• Triangulating a polygon (see Feature Editing Toolbar).

• Importing a gridded surface.

• Wireframing (solid generation) from polylines or polygons/surfaces 
(unclosed).

• Importing from a vector file.

• Solids (or polyhedron volumes) - An object fully enclosing a volume, with 
a calculable volume, such a an aquifier volume or orebody.

Solids can be generated by:

• Wireframing (solid generation) from polygons/surfaces (closed).

• Importing from a vector file.

Examples of solids/polyhedron volumes

Opening an Existing Feature Database

Features are stored and maintained in a Feature Database. A Feature Database 
is a  relational database that supports complex 3D objects and associated 
attributes. A Feature database can be identified by its .fdb file extension. Discover 
3D has the ability to open and maintain multiple feature databases concurrently. 
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Browse to the location of an existing Feature database and click Open. A new 
Features branch is added to the Workspace Tree. 

The Feature Database will be opened and displayed as a new Feature item in 
the Workspace Tree.  

When an existing Features Database is opened into the 3D window the Feature 
Properties dialog should be automatically displayed to enable various 
parameters to be set for the display of the features including symbol, line and fill 
styles and label options. If the Feature Properties dialog does not automatically 
appear you may need to enable this feature on the View tab of the general 
Options dialog (see Customising 3D Interface Settings). Also see Changing 
Feature Display Properties for more information.

New Feature items are always displayed below the Feature [Cosmetic] entry in 
the Workspace Tree. The Feature [Cosmetic] item is always present in the 
Workspace Tree and it operates in a similar manner to the Cosmetic layer in 
MapInfo Professional as it enables 3D features to be easily created at any time 
and stored  in a temporary feature database. Features that are created in the 
Cosmetic Feature database will only persist while the 3D session is open.  If you 
wish to keep any features that have been created in the cosmetic layer  you will 
need to save them to a permanent feature database for later use.

Interacting with Features

The display, selection and editing properties of a Feature database are 
configured using the Workspace tree. 

The icons to the left and right of each Feature Database item in the Workspace 
Tree control the following properties:

To open a Feature Database select the Features>Open menu option. The 
Open dialog will be displayed:

  
Visibility - toggles the visibility of the features in the 3D window on and off.
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Creating a New Feature Database

A new Feature Database can be created by any of the following methods:

• Features>Create menu option – creates a new empty Feature Database 
using the Feature Database Creation Wizard.

• Features>Import menu option - imports a variety of supported vector and 
grid file formats from external third party software programs into a new 
Feature Database (see Importing Data into a Feature Database).

• Interactive Drawing -  allows new features to be directly drawn onto the 
cursor plane in 3D and stored in any open Feature database that is set to 
be editable, including he Cosmetic Feature branch in the Workspace Tree 
(see Creating and Editing Features). For information on saving cosmetic 
features, see Saving Cosmetic Features to a Feature Database.

• Use the 3D Solid Generator (see Modelling Triangulated Surfaces and 
Solids) to wireframe multiple features to build open TIN surfaces (e.g. fault 
planes) or closed polyhedral solids (e.g. zones of mineralisation). The 
solid generator can use polyline, polygon and TIN surface features as 
input, and the output model can be refined using user-created tie-lines. 
These triangulated features can be output directly to an existing or new 
Feature database.

Editability – enables editing for the selected Feature database. With editing 
mode enabled new features can be added to the database and existing features 
can be edited or deleted from the Feature database. Only one Feature database 
at a time can be made editable.

Selectability – enables features within a selected Feature Dataset to be 
interactively selected using the mouse. Selectability can be used to limit which 
Feature database(s) can be interrogated when multiple complex feature 
databases are open in the 3D view.

Zoom Extents – zoom the 3D view to the extents of the features in the selected 
Feature database.

Closes a selected Feature Database. The Features>Close menu option 
displays the Close Feature Databases dialog which provides the ability to 
select individual feature databases to close when the  Close button is clicked 
(shown left).
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• Use the Extrusion Wizard (see Extruding Models from Points, Lines and 
Polygons) to extrude 2D or 3D features, including points, lines, polylines 
and polygons into triangulated 3D mesh features. The output features 
from the Extrusion Wizard can be directed into a new or an existing 
Feature database. 

Feature Database Creation Wizard

The Feature Database Creation Wizard  creates a new empty Feature 
Database. 

To create a new Feature Database:

1. Select the Features>Create (shown left) menu option. The Feature 
Database Creation Wizard dialog is displayed at Step 1:

2. Use the browse button (shown left) to navigate to a folder to save the file  
and enter a name for the new Feature database. Click Next.
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4. Enter a name for the new field and select an appropriate Data Type for 
the information that you wish to store. A number of data types  are 
available. 

• Boolean – can contain binary information only (i.e. Yes/No).

• Byte – can contain byte values, ranging between 0 and 255.

3. Each new feature database is created with the following set of default  
fields : ID, X, Y Z, Value and Description. All Feature databases must 
contain these default fields so their name and type properties cannot be 
modified. Any number of additional user-defined fields can be added to a 
new feature database using the creation wizard. To add a new field to the 
database click the new field button shown left.
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• Short Integer – can contain small integer values ranging in value 
from  -32768 to 32767.

• Long Integer – can contain large integer values ranging in value 
from -2,147,483,648 to 2,147,438,647 .

• Currency – can contain numeric data in currency format to enable 
accurate fixed-point calculations to be performed where fractional 
accuracy is important.

• Single Precision Float – can contain numeric values in single-
precision 32-bit floating point format ranging in value from -
3.402823E38 to 3.402823E38.

• Double Precision Float – can contain numeric values in double-
precision 64-bit floating point format ranging in value from 
approximately -1.797E308 to -4.940E324 (negative), from 4.94E-
324 to 1.797E308 (positive), and zero.

• Date – can contain date information .

• Text – can contain text to a maximum of 255 characters.

• Memo – can contain text to a maximum of 65,535 characters.

If a text or memo data type is selected enter an appropriate size: this 
property relates to the maximum number of characters that can be stored 
by the field. Click OK to create the new field.

5. Click Finish to create the new Feature Database. A new Features item is 
added to the Workspace Tree. See Creating Features for information on 
how to add features to a database.

Importing Data into a Feature Database

The Import File Wizard allows a range of Vector file formats and Grid file formats 
to be imported into either an existing or new Feature Database.  This wizard is 
accessed via the Features>Import menu option. 

• Supported Import Formats

• Using the Import Feature Database Wizard
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Supported Import Formats

Vector formats:

Grid formats:

Using the Import Feature Database Wizard

3D Studio .3DS
AutoCAD .DXF
Datamine wireframe .DM
Encom .TKM
ESRI .SHP and .TIN
Gemcom .BT2
GoCAD .TS, .PL and .VS
MapInfo .TAB and .MIF
Surpac .DTM and .STR
Vulcan triangulation .00T

ASEG GXF (.GXF) MapInfo grid (.MIG)
Band Interleaved by Line (.BIL 
including .HDR)

Minex (.XYZ)

Encom grid (.GRD) Surfer ASCII (.GRD)
ERMapper (.ERS) Surfer Binary (.GRD)
ESRI/Arc Binary (.ADF) USGS (.USG)
ESRI/Arc ASCII (.ASC) USGS DEM (.DEM)
Geopak (.GRD) USGS SDTS (.TAR)
Geosoft (.GRD) Vertical Mapper (.GRD)
Landmark (.GRD)

1. Select the Features>Import (shown left) menu option. The Feature 
Database Import Wizard dialog is displayed at Step 1:
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The Import File to Feature Database Wizard

2. Select the type of files to import. Two options are provided, Vector files or 
Grid files. See Supported Import Formats for a complete list of supported 
formats. Press Next.

 
Importing a DXF file into a new feature database called ‘Structures’



358 Encom Discover 3D User Guide

 
Importing a grid file into a new feature database called ‘Voxel Isosurface’

If importing a Vector file, you can import any contained layers into 
separate features by enabling this option

If importing a Grid file, a number of Compression Modes are available to 
facilitate efficient importing and handling of larger grids. See the Grid 
Compression section of the Gridded Surfaces in 3D chapter for a full 
explanation of the available options.

The imported files can either be:

• Appended to an existing open feature database by enabling this 
option and selecting the target database from the pull-down list or 

3. For either the Vector or Grid formats, the second dialog allows selection of 
the source file using the Browse button. 

• Multiple files can be imported simultaneously by selecting them 
consecutively with the Add Files button (shown left).

• If multiple attributed Vector files are being imported, only one file can 
be used to define any extra custom fields. Highlight this file in the 
import list, and click the Attribute button (shown left); the selected 
file will be moved to the top of the list.
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• Created in a new feature database (or existing feature database 
can be overwritten) using the Browse button adjacent to the 
Feature Database option. Click Next to advance the wizard.

The final dialog of the Import wizard, controlling the Z value assignment.

4. The final dialog of the wizard (Step 3) allows the Z field handling to be 
controlled. Generally this is best left as the default option (auto initialise 
the Z field), capturing this information automatically from the input file. 
However, you can instead specify either an attribute field or constant value 
to use for Z information. 

5. Click Finish to start the import process. If a new feature database was 
created, it will be added to the workspace tree.

If importing a vector file composed of 3D facets (e.g. planar or volume solids), 
Discover 3D will automatically perform a check of each surface, examining 
whether all facets are closed, and whether the order of vertices needs to be 
reversed. If any issues are found, the user will be presented with the Import 
Warning Report dialog (pictured below). The user can either:

• Continue the import – all surfaces will be displayed in Discover 3D, but 
using some of the feature editing tools (see Editing Features ), such as 
Combine, Intersect, Erase, etc., on any surfaces with unclosed facets will 
result in errors.
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• Cancel the Import. Then use the Topology Checker utility (in the Utilities 
menu) to export from the source vector file only the surfaces whose facets 
are closed, and reverse the order of vertices as necessary. Import this 
new vector file using the Feature Import tool.

Result of the automatic vector check performed by the Feature Import tool.

Saving Cosmetic Features to a Feature Database

If features are created in the Feature [Cosmetic] database they can be saved off 
to a permanent Feature Database (or overwrite an existing one) by selecting the 
Features>Save Cosmetic Features menu option. The Save Cosmetic Feature 
Set Wizard - Step 1 dialog is displayed:
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When the new Features Database is opened into the 3D window the Feature 
Properties dialog is automatically displayed to enable various parameters to be 
set for the display of the features including symbol, line and fill styles and label 
options. See Changing Feature Display Properties for more information.

Use the browse button to navigate to a folder to save the new Feature database 
and enter a name. Click Next.
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The structure of a new feature database created from the cosmetic layer can also 
be modified later using the Modify Feature Database tool (see Modifying the 
Structure of a Feature Database).

Modifying the Structure of a Feature Database

Feature databases can be modified in a number of ways:

• Feature databases can be renamed.

• The name and data type of any existing fields can be altered.

• New fields can be added.

To modify an existing feature database:

1. Ensure that the feature database is open in Discover 3D 

2. Select the Features>Modify menu option

3. From the Select Feature Set dialog, select the database to modify and 
press OK

4. To rename the database, enter the new name in the Feature set name 
field on the Name and Description tab. If desired, description metadata 
can be added at the bottom of this tab.

5. Fields can be added and modified in the Fields tab. See steps 3 and 4 of 
the How to create a new Feature Database: section above [Tim either that 
or copy these sections ot this location. Note the default fields cannot be 
modified)

Note The cosmetic feature database cannot be modified.

6. Each new feature database is created with the following set of default  
fields : ID, X, Y Z, Value and Description. All Feature databases must 
contain these default fields so their name and type properties cannot be 
modified. Any number of additional user-defined fields can be added to a 
new feature database using the creation wizard. To add a new field to the 
database click the new field button shown left.
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7. Enter a name for the new field and select an appropriate Data Type for 
the information that you wish to store. A number of data types  are 
available. 

• Boolean – can contain binary information only (i.e. Yes/No).

• Byte – can contain byte values, ranging between 0 and 255.

• Short Integer – can contain small integer values ranging in value 
from  -32768 to 32767.

• Long Integer – can contain large integer values ranging in value 
from -2,147,483,648 to 2,147,438,647 .

• Currency – can contain numeric data in currency format to enable 
accurate fixed-point calculations to be performed where fractional 
accuracy is important.

• Single Precision Float – can contain numeric values in single-
precision 32-bit floating point format ranging in value from -
3.402823E38 to 3.402823E38.

• Double Precision Float – can contain numeric values in double-
precision 64-bit floating point format ranging in value from 
approximately -1.797E308 to -4.940E324 (negative), from 4.94E-
324 to 1.797E308 (positive), and zero.

• Date – can contain date information .

• Text – can contain text to a maximum of 255 characters.

• Memo – can contain text to a maximum of 65,535 characters.
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If a text or memo data type is selected enter an appropriate size: this 
property relates to the maximum number of characters that can be stored 
by the field. Click OK to create the new field.

8. Press OK to complete the changes.

Exporting Feature Databases

The Feature Exporter (accessed via the Features>Export menu option) allows 
a selected Feature Database to be exported as one of the following formats:

The output format is set with the Browse button in the Output Files section

If a feature database comprises multiple object types (such as points, polygons 
and solids), these can be exported to a separate file for each object type:

The Output Colour of the exported objects can be set to the following:

• From input feature database -  uses the colour of the feature objects in 
Discover 3D. This does not support features colour-modulated by a 
legend.

• Fixed - select a colour from the adjacent palette

• Modulated by field - set a field and a colour table/LUT to colour modulate 
the exported objects with.

Changing Feature Display Properties

The display style and labelling options of all features in a Feature Database can 
be modified in the Feature Properties dialog (double-click on the appropriate 
Feature item in the Workspace Tree to open, or right click on the Feature layer 
and choose the Properties menu option).

ArcView .SHP
ASCII .CSV
AutoCAD .DXF
GoCAD .TS, .PL and .VS
MapInfo Professional .TAB
MapInfo Professional .MIF



16 Digitizing and Managing 3D Features 365

Feature Appearance

The Appearance tab of the Feature Properties dialog provides controls for point, 
polyline and polygon style control, including:

• Symbol type, size and colour

• Fill colour and transparency

• Line colour, weight and pattern. 

Polygon colour fill can be disabled by deselecting the Fill tick box.

Alternatively, all features in the database can be colour modulated:

Labelling Features

Feature Labels can be displayed by specifying an appropriate data field in the 
Data tab of the Feature Properties dialog. A Label Skip Factor can also be set 
under the Appearance tab. The Advanced Arrangement dialog (accessed via 
the Appearance button under the Appearance tab) provides powerful controls 
for modifying and controlling labels.

Important Any style applied will affect all features in the database.

1. Specify a numeric field to colour modulate the features by using the 
Colour control under the Data tab.

2. Use the Colour Table Edit button under the Appearance tab to either set 
a Look-Up Table or custom Legend, or customise and apply an RBG or 
HSL interpolation. See the Colour Table selection section of Voxel Models 
for a detailed description of this dialog.

3. Click Apply (or enable the Auto Apply option) to display the changes.
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The Advanced Arrangement dialog for line labels

The Format button provides numeric formatting options (scientific, various DMS 
formats, general, etc), decimal place allocation as well as suffix and prefix 
specification 

Standard Font controls are provided, as well as the following range of orientation 
options in the adjacent pull-down list:

Facing Viewer (default) – Labels are aligned parallel to the viewing/screen plane, 
so that they always face the viewer. 

• Fixed 3D – Labels are fixed in the 3D environment. The pull-down list in 
the Rotation panel at the bottom of the dialog controls the initial 
orientation: Flat (the XY plane) or Upright (XZ plane).

• Fast 3D – identical to the Fixed 3D except that no Style controls are 
available; this is a very fast and memory-efficient labelling option.
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The Style button is only available for the Facing Viewer and Fixed 3D orientation 
options. It enables labels to be extruded either as filled Polygons or Line 
Segments (wireframe) using the Format pull-down list. The depth of the label is 
set using the Extrusion control, expressed as a percentage of the label size. To 
display a flat label, set the Extrusion to 0%. The label is extruded perpendicular 
to its display plane. 

A range of Size Controls are available. For the Fast 3D orientation option, only 
the Font Size control is available (in points). Enabling the Constant checkbox 
(for the other orientation options) will keep the labels at the specified size (relative 
to the screen) regardless of zoom level. If the Constant option is disabled, Lower 
and Upper Limits can instead be set:

• Block: labels will disappear when the applied zoom level takes the label 
past the specified limit,

• Clamp: labels will be locked to the specified limit when the applied zoom 
level takes the label past the specified limit.

The label position relative to the data (collar) location can be altered using the 
Alignment controls (either preset or manual positioning). The first row of controls 
concern label positioning in the label plane (i.e. the relative XY components), 
whilst the second row controls the vertical height of the label with respect to its 
initial plane (i.e. the relative Z component).

The angle of the labels can also be set by moving the red-tipped arrow on the 
compass in the Rotation panel at the bottom of the dialog. The Fixed and Fast 
3D labelling options also provide a Dip control (half-compass) in this panel.

Selecting Features

• Graphical Selection

• Select by SQL Query

• Browser Selection

Note Rendering labels as extrusions is memory intensive and will affect 3D 
performance. It is not recommended for large numbers of labels.
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Graphical Selection

A number of feature selection methods are available:

Alternatively, one or more features can be selected from the Features tab of the 
Information window by selecting their row entries (multiple selections are possible 
using the SHIFT or CTRL keyboard keys).

Select by SQL Query

The Create Feature Database Query dialog (accessed via the Features>Query 
menu option) allows features to be queried by attribute using basic SQL syntax. 
The output of a query is a new Feature Database as specified in the Name option 
of the dialog. This is a useful way to separate a multi-attributed database (e.g. that 
pictured under the Feature Database Window section) into a number of 
databases each populated with features of a single attribute.

Feature editing and SQL query both require one or more features to be selected. 
A feature database must be Selectable before features within it can be selected; 
this is enabled in the Workspace Tree. This control is useful when multiple dense 
databases exist in the same area; you can disable the selectability of all 
databases except the target database.

Enable the Select button on the Zoom Controls Toolbar, and click on the feature 
to edit. When selected, a feature will be highlighted in red (unselected features 
are displayed in a default blue colour). The Cursor Plane will snap to the feature’s 
plane. To select multiple features, hold down the keyboard CTRL key whilst using 
the Select button; the Cursor Plane will snap to the last selected feature.

The Polygonal Selection button allows you to draw a selection region in the 3D 
window; all features that lie entirely within this region will be selected. The 
selection region is independent of the Cursor Plane; it is actually drawn within the 
screen plane, and selects all features behind this plane,  regardless of feature 
orientation.
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Pull-down Field and Operator selection dialogs to the right of the Expression 
pane allow SQL syntax creation.

SQL syntax examples

Rock = "sand" 

Returns entries in the Rock field where the only text is “sand”.

Rock Like "sand*" 

Returns any entries in the Rock field prefixed with “sand”; for example, 
sandstone, sand and sandy cobbles.

Rock Like "*stone*" 

Returns any entries in the Rock field with “stone” anywhere in the text string; for 
example, sandstone, siltstone, stoney cobbles and stone.

Browser Selection

Features can be selected from the Feature Spreadsheet; see the Feature 
Selection section below.

Note Discover 3D uses the asterix (*) as a wildcard, unlike MapInfo's % wildcard. The 
* wildcard is only activated by using the LIKE operator.
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Creating and Editing Features

• Creating Features

• Snapping Features to Other Data

• Editing Features

• Advanced Editing Functions

Creating Features

When a feature database is made editable, both the Cursor Plane and Feature 
toolbars are enabled, and the Cursor Plane is displayed. The Cursor Plane is 
used as a drawing plane onto which features are digitized: for detailed information 
on controlling the Cursor Plane, see the Cursor Plane section.

To draw point, polyline or polygon features in 3D:

1. Make the target feature database Editable.

2. Use the Cursor Plane controls to position and orientate the Cursor Plane 
in the required location.

3. Select the appropriate feature button form the Feature Toolbar, and click 
on the point location or polyline/polygon start point in the Cursor Plane. 

4. For polylines/polygons, click on consecutive points to outline the feature, 
or hold down the left mouse key whilst moving the cursor to create a 
continuous series of nodes. 

• Press the ESC key at anytime to cancel the feature creation.

• Press the BACKSPACE key at anytime to delete the last added node.

5. Complete polyline features by pressing the ENTER key or double-clicking; 
polylines will end at the current cursor location

Creation of features requires an Editable Feature Database (enabled via the 
pencil icon in Workspace Tree); this can be either the cosmetic or a user-created 
or imported database. 

The Feature Toolbar provides the tools for the creation and editing of features, 
including Points, Polylines and Polygons. A detailed description of each 
buttons’ functionality is presented in the Features Toolbar section. 
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6. Complete polygon features by pressing the ENTER key or double-clicking; 
polygons will close back to the start point whilst using the current cursor 
location as an intermediary node/vertice. Alternatively, pressing the 
CTRL+ENTER key combination will complete the polygon and ignore the 
current cursor location.

To create a feature surface:

Polygons are planar objects; the external nodes cannot be moved out of the 
objects plane. Polygons can however be converted into a feature Surface using 
by triangulating the internal area, forming a  continuous network of triangular 
faces.

1. Select a polygon, polyline, or group of points in an editable feature 
database.

2. Press the Triangulate button on the Feature Editing toolbar.

3. Make the triangulated surface reshapable, and holding down the CTRL 
key, select a node and move it outside the orignal polygon plane.

7. Enabling the Confirm Pick button prior to feature creation will display a 
Confirm Feature Description dialog. This allows the feature’s default 
fields (and custom fields if any) to be attributed with either text or values. 
For instance, the Description field could be attributed with the feature’s 
geology, e.g. south_fault, supergene or zone_1, allowing a single Feature 
Database to hold multiple geological features.

8. Upon completion of a feature, it is highlighted in red as the current 
selected feature (see Selecting Features), allowing editing (see Editing 
Features). 

The Ruler tool on the Main Toolbar can be a useful guide for distances, 
bearings and dip angles between features on the cursor plane. Also, the Grid 
option on the Cursor Plane Properties dialog (see Changing Cursor Plane 
Properties) can also be a very useful visual guide to distances/sizes.

Snapping – Allows the current feature’s node (new feature or editing an existing 
feature) to be snapped to any dataset set as Selectable in the workspace tree. 
See Snapping Features to Other Data.
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(a) An example of a Polygon
(b) Triangulating a polygon to form a surface
(c) Moving nodes to form a non-planar Surface

See Triangulate below for futher information.

Snapping Features to Other Data

Use the Snapping tool to snap the current feature’s node (new feature or editing 
an existing feature) to any dataset that is set as Selectable in the workspace 
tree. The following data types can be snapped to:

• Drillholes/Trenches

• Feature databases (surfaces, polyhedral solids, polygons, etc)

• Images

• 3D Points

• 3D Lines

Upon activation, the cursor will change to a circle in the middle of the cross-
hairs.  When the cursor is close to an existing node, it will change to the standard 
cross-hair: left-click to snap to this node.

(c)

(b)

(a)
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To the right of the Snap toolbar button is a pull-down options dialog. This allows 
the Pixel Tolerance to be set (i.e. how close the cursor needs to be to an existing 
node before it can be snapped to that node). A high-pitched audible Beep (‘dee’) 
can also be enabled for when the cursor is within the set pixel tolerance: when the 
cursor moves outside the tolerance, a low pitched ‘doh’ will sound. The Duration 
of these beeps can be set in milliseconds.

This dialog also provides options for snapping to nodes/points, lines/drillholes/
edges or surfaces.

To snap nodes to drillholes, images, points, lines, and surfaces:

3. Ensure the cursor plane is on by toggling the cursor plane button.

1. Enable snapping. In the adjacent drop down dialog, enable the 
appropriate snap option:

• Snap to Points for 3D points or nodes in polylines, polygons or 
solids.

• Snap to Drillholes/Lines to snap anywhere along drillhole traces 
or 3D lines, or to snap to the edges of solids/polygons.

• Snap to Surfaces to snap anywhere on interior faces/surfaces of a 
polygon/solid.

This setting does not affect snapping to images.

2. Make the relevant item (Lines, Points, Drillholes, Feature database, or 
Image) in the Workspace Tree Selectable.

In complex 3D sessions, it is recommended to turn the selectability OFF 
for all other datasets, to ensure the correct dataset is snapped to. It is also 
recommended to turn on the spreadsheet/browser view for the item, to 
dynamically visualise the attributes.
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4. Optionally, click the Bond button to fix the cursor plane to the selected 
item. Note that the cursor plane is not visible in this mode, but you can still 
digitize and snap.

5. Make a feature database layer editable and enable the required drawing 
tool. Move the cursor over an object location: the red crosshairs  will snap 
to that location.

6. This is particularly powerful for 3D interpretation of downhole data; for 
instance, digitizing a series of points, polylines or polygons outlining 
mineralization or geological features for use in the 3D Solid Generator 
(see Modelling Triangulated Surfaces and Solids) or surface gridding tools 
(see Creating Gridded Surfaces).

• Use the PGUP and PGDN keys to offset the Cursor Plane perpendicularly 
from its existing position, in order to keep digitized features parallel. Use 
the User-defined step option to set the distance the PGUP/PGDN keys 
move the Cursor Plane.

• The exact location of the Cursor Plane can be set via the Origin (X, Y and 
Z), Inclination and Azimuth controls.

Some digitization tips which are controlled via the Cursor Plane tab of the 
Cursor Plane Properties dialog:
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• To limit the amount of existing data visible either side of the Cursor Plane 
(i.e. simulate a 2D section envelope), enable either the Envelope or Slice 
Clipping options.  These enable only a user-defined Slice Width of data 
to be viewed either side (envelope) or behind (slice) the Cursor Plane.  
This is an excellent way to ensure that interpreted boundaries are based 
only on data within, for example, 50 m of the Cursor Plane.

• If digitizing onto georeferenced images (e.g. geophysical profiles), use the 
Bond to Image option on the Cursor Plane.

Editing Features

Feature can be duplicated, repositioned, resized and deleted. Individual or 
multiple nodes within a feature can be added, moved or deleted. Feature 
attributes can also be edited.

The following basic editing functionality is available:

Editing an entire feature:

• Moving features within the curosr plane

• Moving features perpendicular to the cursor plane

• Resizing features

• Deleting features

• Cut, copy and pasting features

Editing individual nodes/vertices:

• Repositioning nodes within the cursor plane

• Repositioning nodes  perpendicular to the  cursor plane

• Add nodes

• Delete nodes

Note Using a 3DConnexion SpaceNavigator (see Using the 3DConnexion 
SpaceNavigator™) can help to precisely identify and snap to the intercept 
location in more complex 3D environments, and is essential when digitising 
polylines.
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• Elastic movement of nodes/regions

• Extending polylines from end nodes

To enable editing of a feature or its nodes:

Editing an entire feature:

Moving a feature within the Cursor Plane – press the SHIFT key and left click 
on the feature, then drag it to its new location. The feature will be moved within 
the Cursor Plane. If more than one feature is selected, all features will be moved 
parallel to the plane of the last selected feature (i.e. the feature to which the 
Cursor Plane has snapped).

Offsetting a feature with respect to its Cursor Plane – press the CTRL+SHIFT 
keys and left click on the feature, then drag it to its new location.. The feature will 
be positioned and remain parallel to its initial orientation, i.e. it will be offset. If 
multiple features are selected, they will be offset to the plane of the last selected 
feature.

Deleting a feature – select a feature object or objects and, press the keyboard 
DEL key to remove a feature. Ensure you do not select a node (this will delete the 
node instead). Alternatively, right click on the feature (not a node) and select the 
Delete option from the shortcut menu.

1. Feature editing requires one or more features to be selected in an 
Editable feature database (ensure the Editable icon shown left is 
enabled in the Workspace Tree).

2. Enable the Edit mode button on the Features Toolbar; all nodes/vertices 
on the selected features will be displayed. Double clicking on a editable 
feature will also enable the Edit mode for the feature:

The following Editing functionality is available for an editable feature, whether 
points, polylines, polygons or triangulated surfaces.
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Object Cut, Copy, Paste and Delete commands are also available from the 
Features Menu.

The Resize Feature dialog provides both a slider bar and manual entry to specify 
the new feature size, as a percentage of its current size. Press Apply to visualise 
the new size (this can be dynamic if the Auto Apply option is enabled). The 
original feature size can be restored (if the dialog has not been closed) by 
pressing the Restore button.  A number of statistics and parameters can be 
examined by selecting the Expand button.

Editing individual nodes/vertices:

The following controls apply to nodes or vertices in the following feature types;  
polylines, polygons and open and closed triangulated surfaces. These tools give 
the user the ability to precisely experiment with and refine the shape of their 
models, either intricately (on a node by node basis) or regionally (using the 
elasticity option).

Resizing a feature – with a single feature selected and editable, select the 
Resize command from the Features>Edit menu.

Note Resizing can only be performed on polylines and polygons, but not open or 
closed polyhedral surfaces.

These functions require the target feature to be selected and have Reshape 
enabled

Repositioning a node within the cursor plane – placing the cursor over a 
node will change the cursor to the Move cursor (shown left). Click and drag the 
node to its new location within the Cursor Plane.
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Repositioning a node perpendicular to the cursor plane – placing the cursor 
over a node will change the cursor to the Move cursor (shown left). Press the 
CTRL key then move the node as required. This functionality will not operate on 
polygons: use the Triangulate button to convert the polygon into a triangulated 
surface, then move the node as desired

Add a node – Ensure that the Add Mode button is enabled in the Feature 
Editing toolbar. Place the cursor over a segment (between two nodes) on a 
polyline or over an edge of a polygon or triangulated surface will change to 
cursor to an Add Node cursor. Click to add a node at this location; this node can 
then be repositioned as above. Alternatively, right-click when the cursor is over 
the segment, and choose Insert Point from the shortcut menu.

Triangulated feature surfaces will be automatically re-triangulated to 
accommodate the new vertice.

Delete a node – either:

• Select a node by clicking on it (the Cursor Plane cross-hairs will converge 
on the selected node) and press the keyboard DEL key or

• Right click on the node and choose the Delete Point option from the 
shortcut menu or

• Select the Delete Node button from the Features Editing toolbar, and click 
on the node to delete. this option allows multiple nodes to be deleted 
quickly. Note that whilst in Delete mode, new nodes cannot be added, nor 
existing nodes moved

Upon deleting a vertice in a feature surface, the surface will be automatically re-
triangulated

Elastic movement of nodes – Moving a node whilst the Elasticity button is 
enabled will move its neighbouring nodes. This is a powerful way of reshaping 
entire regions of features, whether modifying the edges of a polygon or an area 
within a triangulated surface. Elasticity can be applied to node movement both 
within or perpendicular to the cursor plane.

The Radius of this effect is set via the options button adjacent to the Elasticity 
button. This dialog also contains options controlling how the affected nodes are 
moved: this effect is represented graphically next to each option (Gaussian, 
Square, etc).
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Elastically reshaping a region of a triangulated surface using the Sine distribution applied 
over a user-specified radius of effect."]

Editing node XYZ coordinates manually - The node coordinates can be edited 
within the Information Sheet>Features tab. Select the feature to edit, and in the 
spreadsheet, right click on it and select Start Edit from the pop-up menu. Select 
the node to edit either from the spreadsheet list or graphically, and alter the X, Y 
or Z coordinates as desired. Note that as feature polygons and polylines must be 
planar, there is a tolerance limit on how far nodes can be moved via this method: 
Discover 3D will perform a check to ensure that the new node position retains the 
features planar state. If it does not, the newly entered value will be ignored.

Advanced Editing Functions

A range of powerful multiple feature processing tools are available on the 
Features Editing toolbar. 

By combining these advanced feature manipluations with Discover 3D’s fast 
automated wireframing (see Modelling Triangulated Surfaces and Solids) and 
extrusion (see Extruding Models from Points, Lines and Polygons) capabilities 
you can easily experiment with creating multiple, complex geological 
interpretations to test your theories or evaluate your information in as much, or as 
little, detail as you need.

This following advanced editing and processing tools are available:

• Triangulate - triangulates selected objects to form TIN surfaces.

Append - An existing polyline can be extended/continued by selecting an end 
node,  right clicking, and choosing the Append option. Simply start drawing the 
polyline extension required, and finish the polyline when required.

This can be a useful way to edit an existing line in combination with the Break 
function (see Advanced Editing Functions).

The Ruler tool on the Main toolbar can be a useful guide to distances, bearings 
and dip angles between objects on the cursor plane.
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• Combine - combines or fuse multiple selected features into a single 
feature; the original features' geometries are lost.

• Intersect - outputs the intersection of any selected features (except 
points).

• Cut - cuts the first selected feature along the intersections with any other 
selected features.

• Aggregate - combines multiple selected features into one feature, but 
preserves each source feature's spatial geometry.

• Disaggregate - ungroup or explode aggregated features into individual 
features. Also detects any disconnected parts of an feature (created using 
the Break tool) and creates individual feature objects for each part.

• Break Mode - breaks a polyline into multiple parts at the selected node, as 
well as select multiple  edges along a surface to preform a cut operation.

• Consolidate - recombines a selected multi-part feature object

Triangulate

• Convert 2D planar polygons into a 3D Polygon equivalent (a Surface). 
This enables moving nodes outside of the polygon plane and inserting 
internal nodes.

• Convert 3D polylines into a surface.

• Convert a point cloud of elevation measurements into a surface (TIN).

The last two functions can also be achieved using surface gridding (see Creating 
Gridded Surfaces), however, this produces a gridded surface file which then 
needs to be imported into a Feature Database. Instead, the Triangulate option 
provides a direct vector wireframe surface result.

One prime example of the use of this function is the 3D modification of imported 
drillhole section boundary polygons from a 2D drillhole project. These polygon 
features cannot be modified outside of the polygon plane, but the geoscientist 
may wish to snap these to the actual drillhole locations in 3D. 

Triangulate will convert any selected feature objects, such as 2D polygons, 
polylines or points; into a 3D triangulated surface (a Triangulated wireframe 
mesh or TIN). This function is an essential tool to:
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A feature polygon: (a) triangulated into a feature surface (b) Individual nodes or even 
regions of the feature surface can then be moved outside the original polygons plane (c) 
using the vertice/node editing tools and/or the elasticity controls.

Converting these polygons using the triangulate tool allows the user to start 
accurately snapping not only the edge nodes to drillhole intervals, but also to add 
internal nodes  and snap these to drillholes. Both node snapping operations can 
be performed elastically allowing a specified region around each node to be very 
easily and realistically shaped to conform to the new node posiiton.

Combine

To combine features:

1. Make the feature database containing the features editable.

2. Using the Select tool, select the first feature. 

3. While pressing the keyboard CTRL key, select the additional features.

Combine will combine any selected features (points, polylines, polygons, 
surfaces and volumes) into a single feature. This is a useful for managing more 
complex feature databases e.g. combining features with the same attributes into 
a single feature, allowing easy graphical selection of a particular attribute type.

This function fuses the selected features so that overlapping boundaries and 
regions are lost; and the original features' spatial geometries are lost.

(c)

(b)

(a)
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4. Press the Combine button.

5. In the Operation Options dialog, select the output feature database to 
create the single combined feature in. Ensure that the Delete original 
features option is disabled if you want to preserve the input features. 
Press OK.

Intersect

• The portion of a fault plane that intersects an orebody.

• The lineation intersection of a quartz vein with a fault surface.

• The surface trace of a fault plane (interpreted from drilling) with a 
topographic surface (a DEM grid imported into a feature database, see 
Importing Data into a Feature Database).

To display the intersection of one TIN feature surface with another:

1. Make the feature database containing the intersecting features editable

2. Using the Select tool, select the first feature. 

3. While pressing the keyboard CTRL key, select the additional features.

4. Press the Intersect button.

5. In the Operation Options dialog, select the output feature database to 
create the intersection feature in. Ensure that the Delete original 
features option is disabled if you want to preserve the input features. 
Press OK.

It is recommended that any bodies being intersected are enclosed bodies (i.e. if 
created with the 3D Solid Generator (see Modelling Triangulated Surfaces and 
Solids), ensure an end capping is applied such as  ‘flat’). This will result in the 
output intersection being displayed as a triangulated surface, rather than a closed 
polyline.

Intersect creates new features representing the shared (or common) areas of 
the selected features. This can be the intersection of any selected feature 
polyhedrons (surfaces and volumes) or polygons. Some examples of use:
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An example of an Intersection operation

Cut

Selected features in the same plane:

• Cut (or remove) part of a polygon feature where it overlaps with other 
polygon feature(s)

• Cut a polygon feature along the intersection with other polyline feature(s)

Selected features in different planes:

• Cut a polygon feature along intersections with other polygon feature(s)

• Cut a TIN surface along intersections with other TIN surface(s)

Some examples of the powerful modelling uses of this function:

• Viewing the portion of an orebody volume solid (created with the 
Modelling Triangulated Surfaces and Solids) above a proposed open cut 
surface (a DEM grid of the open cut imported into a feature database, see 
Importing Data into a Feature Database).

Cuts the first selected feature along intersections with any other selected 
features. All feature types except points are supported. Cut can be used for any 
of the following operations.
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• Viewing the portion of an orebody volume solid between two fault planes, 
then calculating the volume of this region.

• Cutting a older fault plane with a more recent fault plane (e.g. extruded 
from surface traces using the Extruding Models from Points, Lines and 
Polygons).

Some examples of cut operations with the two solids shown above follow:
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Result of cutting the blue solid with the green solid.

Result of cutting the green solid with the blue solid.
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To cut one feature with another:

1. Make the feature database containing the features editable (the features 
must all be in the same feature database).

2. Using the Select tool, select the target feature to be cut.

3. While pressing the keyboard CTRL key, select the second feature (i.e. the 
cutting surface).

4. Click the Cut button (or use Features>Edit>Cut).

5. In the Operation Options dialog, select the output feature database to 
create the Cut feature in.

Ensure that the Delete original features option is disabled if you want to 
preserve the input features.

6. Press OK.

Note The output feature database will likely have two or more features (the target 
feature cut into sub-portions). Select and Delete the unwanted features.

Note It is recommended that any bodies being cut are enclosed bodies (i.e. if created 
with the 3D Solid Generator (see Modelling Triangulated Surfaces and Solids), 
ensure an end capping is applied such as  ‘flat’). This will result in the output 
body being displayed as a closed volume, rather than a open/hollow surface; a 
volume can then be calculated for a closed volume using the Topology Checker.
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1

Examining the volume of a 
skarn orebody (green) 
between a BOPO gridded 
surface and an inclined fault 
plane (brown). The BOPO 
grid surface is first imported 
as a feature (blue object in 
step 3)), then the skarn is cut 
using the Erase tool by both 
the fault and BOPO planes 
(step 4), leaving the final 
skarn volume (step 5)

2

3

45
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Aggregate

To aggregate multiple features:

1. Make the feature database containing the features editable.

2. Using the Select tool, select the first object.

3. While pressing the keyboard CTRL key, select the additional features.

4. Press the Aggregate button.

5. In the Operation Options dialog, select the output feature database to 
create the single resulting feature in. Ensure that the Delete original 
features option is disabled if you want to preserve the input objects. Press 
OK.

Disaggregate

To disaggregate a feature:

1. Make the feature database containing the target features editable.

2. Using the Select tool, select the target feature.

3. While pressing the keyboard CTRL key, select any additional features if 
desired.

4. Press the Disaggregate button.

5. In the Operation Options dialog, select the output feature database to 
create the resulting multiple features in. Ensure that the Delete original 
features option is disabled if you want to preserve the input objects. Press 
OK.

Aggregate groups multiple selected features into a single feature, whilst 
preserving the spatial geometry of all the original features.

Disaggregate ungroup or explode aggregated features into individual features. 
Also detects any disconnected parts of an feature (created using the Break tool) 
and creates individual feature objects for each part.
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Break Mode

To break a feature polyline:

1. Make the feature database containing the feature polyline editable.

Optional steps:

• If necessary, delete the unrequired/surplus feature polylines

• If required, the endpoint of one of the new features can now be extended 
from, by right clicking on it at choosing the Append option

To break a triangulated feature surface:

1. Make the feature database containing the feature surface editable.

There are two modes of operation:

• Break a polyline into multiple parts at the selected node

• Manually cut a triangulated feature surface along mutiple contiguous 
selected edges/segments.

2. Using the Select tool, select the target feature and make it Reshapable.

3. Hover the cursor over the node at which you wish to break the polyline: if 
no node exists, first insert a node. The cursor will change to a knife symbol 
when over a node. Click the mouse. This can be repeated for multiple 
nodes if desired

4. Select the Disaggregate button.

5. In the Operation Options dialog, select the output feature database to 
create the resulting multiple feature polylines in. Ensure that the Delete 
original features option is disabled if you want to preserve the input 
objects. Press OK.

2. Using the Select tool, select the target feature and make it Reshapable.

3. Enable the Break mode on the Feature Editing toolbar.
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Optional step:

• If necessary, delete any unrequired/surplus feature polygons/surfaces

Example of a triangulated surface having an internal region clipped using the Break 
function

4. Hover the cursor over the first interior edge delineating the desired cut 
line; the cursor will change to a knife symbol. Click. The edge will be 
bolded to indicate its selection.

5. Repeat step for for each additional interior edge until a continuous line 
from one side of the surface to another has been traced, or an internal 
region outlined (see example below).

6. Select the Disaggregate button.

7. In the Operation Options dialog, select the output feature database to 
create the resulting multiple feature polylines in. Ensure that the Delete 
original features option is disabled if you want to preserve the input 
objects. Press OK.
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Consolidate

To recombine a multi-part feature:

1. Make the feature database containing the feature editable.

2. Using the Select tool, select the multi-part feature (as created in Break 
Mode).

3. Select the Consolidate option from the Features>Edit menu 

Feature Attributes

Feature attributes will include the following default fields, plus any additional user-
created fields (and attributes). These default fields are automatically updated 
after any object edit/change:

• XYZ coordinates of the object's centroid.

• A user-defined Description field.

• Type of object (see Feature Object Types).

• Length of the object (polyline length, perimeter length for polygons and 
surfaces).

• Area of the object (one side of polygons and surfaces only, exterior 
surface area of solid/polyhedron volumes).

• Volume of the object (closed solid/polyhedron volumes only).

These windows are accessed via the icons on the Main Toolbar and the View 
menu. More information on accessing and positioning these windows can be 
found in Docking and Undocking Toolbars and Windows.

Consolidate is primarily used to recombine features that have been broken into 
multiple parts with the Break tool.

Feature attributes can be examined via either the Feature or Data Windows; 
individual feature attributes can also be edited in the Feature Database Window.
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Data Window

Feature Database Window

If a group of cells is highlighted in the feature spreadsheet, right-clicking will 
display the Copy selected cells to clipboard menu option. This can be useful 
for extracting data into Excel for data anlaysis or other uses.

The Data window displays the attributes of only the selected feature (the Feature 
Database must therefore be Selectable in the Workspace Tree; if the database 
is Editable, multiple features can be selected and displayed). It does not require 
you to choose the database within the tab to display; therefore multiple 
databases can be made selectable and can be easily and rapidly interrogated. 
However it does not allow attribute editing. 

Alternatively, the Feature Information button (on the Features Toolbar) can be 
used to select features regardless of whether their database is selectable or not.

The Feature Database window displays a spreadsheet view of the attributes of 
every feature in a selected Feature Database. This allows multiple feature 
attributes to be examined and edited after creation; alternatively, individual 
features can be attributed during creation by enabling the Confirm Pick button 
on the Features Toolbar.
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Feature Selection

Attribute Editing

Individual attributes of an Editable Feature Database can be edited directly within 
Feature Database window cells (including the X, Y and Z values). Right clicking 
within the attribute spreadsheet displays a shortcut menu, providing options for 
automatic heading and/or data spacing operations: note that these spacings can 
also be set manually by selecting and moving the header column and row widths.  
Right-clicking on a column header provides additional ascending or descending 
sort operations for the selected column. 

Selected rows can be deleted by either pressing the keyboard DELETE button, or 
by right-clicking on the row header and choosing the Delete Selection option. 
This shortcut menu also contains options to Cut, Copy and Paste the current 
selection, allowing feature duplication (duplicated features could then be offset 
using the controls discussed in Editing Features).

Node Editing

The X,Y and Z values in the attribute spreadsheet only represent the centroid 
locations for polyline and polygon features: to edit individual node co-ordinates, 
right click within a selected row, and select the Start Edit option from the shortcut 
menu. An editable list of the co-ordinates for every node comprising the feature 
will be displayed: selecting a row entry will snap the crosshairs in the 3D display 
to corresponding node. Conversely, selecting a node within the 3D display will 
highlight the corresponding row entry.

Select the required Feature Database from the pull-down list at the top of the 
Feature Database window. The attributes for all default and custom fields will be 
displayed. With Select mode enabled (shown left), click within a row to highlight 
(in blue) a record; its corresponding feature will be highlighted in the 3D window. 
Multiple features can be chosen using the SHIFT and CTRL keys.

If the selected Feature Database is Editable in the Workspace Tree, selecting a 
feature within the 3D display will highlight the corresponding records in the 
Feature Spreadsheet tab. If the Show selected features only option is enabled 
at the top of the Feature Spreadsheet view, only records for the currently 
selected features will be displayed in the spreadsheet.
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Right-clicking within this mode will display a shortcut menu with three mode-
specific options:

• Insert Node: inserts a new node below the currently selected node, 
populated with the currently selected nodes coordinates,

• Delete Point: deletes the selected node, or

• Stop Edit: finishes node editing and returns the view to the attribute 
spreadsheet.

Feature Options

Feature Options dialog



16 Digitizing and Managing 3D Features 395

The Features>Features Options menu item enables the following default 
options to be set:

1. Turn on/off the feature pick confirmation dialog which is displayed at the 
end of the creation of each feature. This dialog enables the entry of data 
into the default Description field and any other user-defined fields in the 
Feature Database. This is identical to the Confirm Pick button in the 
Features Toolbar.

2. Set default colour for feature polygon Fill.

3. Set default colour for Queried feature.

4. Control whether feature surfaces are auto-triangulated when nodes are 
added to internal edges (Default on). 

Note It is recommended to have this option enabled; disabling it is only recommended 
for advanced users who wish to add a number of internal nodes and then 
perform a triangulation incorporating all new nodes simultaneously, resulting in a 
subtly different triangulation geometry (compared with triangulation performed 
after each node is added).
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17 Displaying Voxel Models
Discover 3D allows voxel models (also known as 3D meshes, block models or 3D 
grids) to be displayed with a variety of options, such as slices, threshold range or 
isosurfaces. Voxel models can be imported from third-party software such as 
mine simulation or inversion packages, or created in the Discover 3D (see 
Creating and Manipulating Voxel Models).

• What are Voxel Models?

• Supported Voxel Model Formats

• Creating a 3D Voxel Model Display

• Importing and Exporting Voxel Models

• Viewing Voxel Model Information

• Changing Voxel Model Display Properties

• Displaying a Floating Colour Legend

• Displaying Multiple Voxel Models

• Integrating Voxel Model Displays with Other Objects

What are Voxel Models?

The term voxel refers to a volume element and is the three-dimensional 
equivalent of the two-dimensional grid cell. As used in geological or geophysical 
modelling, voxel models represent volumes of the earth which are subdivided in 
a regular way into sub-volumes, or cells. Each cell, created from six sides, 
contains an earth volume of uniform property attribute. Such properties as 
magnetic susceptibility, density, conductivity or IP property (eg chargeability or 
phase) can be used. Certain software products (such as Vulcan, Gemcom, 
Surpac) and geophysical software from inversion applications (eg UBC) can 
create 3D voxel files.

Note Discover 3D can also create 3D voxel model outputs, for example for a 3D 
drillhole dataset (see Creating and Manipulating Voxel Models).
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Example of complex voxel shape

Supported Voxel Model Formats

The following exclusions apply to all supported voxel model formats:

• Rotated models are not supported, except for native Encom 3D grid 
format. The rows/columns of the model need to be parallel to the X and Y 
axis. If you wish to import a rotated model, an ASCII (CSV) version of the 
file must be obtained, and then converted to an Encom3D grid using the 
Generic ASCII Import (Importing ASCII Voxel Models).

• The model must be continuous with no missing cells, and include all null 
values. This includes cells and padding around the edge of the data. For 
example if the model is 10 rows by 10 columns by 10 planes, then there 
must be 1000 cells defined. If you wish to import a model which is missing 
null values, an ASCII (CSV) version of the file must be obtained, and then 
converted to an Encom3D grid using the Generic ASCII Import 
(Importing ASCII Voxel Models).

• Terrain or DEM offset is not supported. The planes must be parallel.

Discover 3D currently has direct read support (see Importing and Exporting Voxel 
Models) for five voxel/block model formats:

• UBC (University of British Columbia)

• CEMI (Consortium of Electromagnetic Modelling and Inversion – 
University of Utah)

• ASCII XYZ Simple (centred and uniform mesh only)
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• Encom3D Grid (native format)

• Noddy (developed under AMIRA grant by Dr Mark Jessell at Monash 
University) formats

Additionally, Discover 3D has limited support for the following voxel formats:

• Datamine – single precision only.

• Gemcom – Gemcom cell data types are supported: 16-bit integer, 32-bit 
integer and 32-bit floating point.

• Geosoft Voxel.

• GoCAD Voxel.

• Micromine block model - ASCII file and single precision only. Sub-blocks 
are not supported.

• Surpac – version 3 supported, with preliminary support for versions 1 and 
2. The following Surpac cell data types are supported: 32-bit integer, 64-
bit real and string. 

• Vulcan – single and multi-parameter support.

The files used as input to the Voxel Model are the result of modelling and 
inversion simulation software programs. In some cases the Voxel Model can be 
used to display the input models of the research programs or, alternatively, the 
output inversion results of the programs. The supported formats for UBC, CEMI 
and Noddy are ASCII with relatively simple specifications. For more inforamtion 
about these formats, see:

• UBC Model Format

• CEMI Models

• Noddy Models

• ASCII XYZ Models

Note Generic ASCII model formats that contain variable sized cells or non-centred 
coordinates or are non-continuous or are rotated can be imported and converted 
to the native Encom3D format using the Grids>Voxel Manager. See Importing 
ASCII Voxel Models.
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UBC Model Format

The UBC model requires two separate ASCII files. These are:

• Mesh file – 3D mesh defining the discretisation of the 3D model region, 
and

• Property file – the assignment of the property (eg magnetic susceptibility, 
density etc) for each cell of the model.

Mesh File

This file contains the 3D mesh which defines the model region. Mesh has the 
following structure:

NE NN NV
Eo No Vo
ΔE1 ΔE2 … ΔENE
ΔN1 ΔN2 … ΔNNE
ΔV1 ΔV2 … ΔVNE

where:

NE Number of cells in the East direction
NN Number of cells in the North direction
NV Number of cells in the vertical direction

Eo No Vo Coordinates, in metres, of the southwest top corner, 
specified in Easting, Northing and Elevation. The elevation can be 
relative, but it needs to be consistent with the elevation used to specify the 
observation position in additional location files (called OBS.DAT and 
OBS.LOC).

ΔEn Cell widths in the easting direction (from West to East)
ΔNn Cell widths in the northing direction (from South to North)
ΔVn Cell depths (top to bottom)

The mesh can be designed in accordance with the area of interest and the 
spacing of the data available in the area. In general, the mesh consists of a core 
region which is directly beneath the area of available data, and a padding zone 
surrounding this core mesh. Within the core mesh, the size of the cells should be 
comparable with the spacing of the data. There is no restriction on the relative 
position of data location and nodal points in the horizontal direction. 

An example of a mesh file where each cell is 50m by 50m by 50m in size:



17 Displaying Voxel Models 401

10 10 5
0 0 0
50.0 50.0 50.0 50.0 50.0 50.0 50.0 50.0 50.0 50.0
50.0 50.0 50.0 50.0 50.0 50.0 50.0 50.0 50.0 50.0
50.0 50.0 50.0 50.0 50.0

Property File

To illustrate and describe the properties of a model, this example uses Magnetic 
Susceptibility, but all UBC property files are of this format irrespective of the 
property being displayed. The following details the file structure:

sus1,1,1
sus1,1,2
sus1,1,NV
sus1,2,1
susi,j,k
susNN,NE,NV

where:

susi,j,k is susceptibility at location i,j,k

[i j k]=[1 1 1] is defined as the cell at the top south-west corner of 
the model. The total number of lines in this file should equal NN NE NV, 
where NN is the number of cells in the North direction, NE is the number 
of cells in the East direction, and NV is the number of cells in the vertical 
direction. The lines must be ordered so that k changes the quickest (from 
1 to NV), followed by j (from 1 to NE), then followed by i (from 1 to NN). 
If the surface topography (Topo.DAT) file is supplied, the values above the 
surface will be ignored. These values should be assigned –1.0 (nulls) to 
avoid confusion with the other model elements.

CEMI Models

Voxel models used by the Consortium of EM Inversion (University of Utah) are 
similar in format to those of UBC. The CEMI format uses a separate header file 
to describe inverse model parameters. Separate values of the key parameters are 
used to specify the required spatial and model properties. The key parameter 
begins with the "#" character in the first position of the line, and the values follow 
till the next "#" character. The example below includes the required parameters 
(dimensions and steps in the X, Y, and Z directions). The values in the model file 
may be resistivity, density or magnetic susceptibility and so on. 

Example of MYMODEL.CEM header:
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!CEMI Model Header - 27th Feb 2003 (Software Version 2.3) 
#xdim  

50 
#ydim

40 
#zdim

12 

#xcell          ! X cell widths 
50

#ycell          ! Y cell widths 
50

#zcell          ! Z cell widths (variable) 
50     50     100     100     100    100    100    100    100    100    
100    100
#invpar

stg = 1:5; % List of stages to execute
wordy = 2; % Messages: 0-silence, 2-very wordy
mfit = 0.03; % level of fit in the inversion
srcpar{1} = 1 % source parameters
sig0 = [1/305 1/283 1/452 1/461 1/607 1/452 1/556]; % conductivity 

of layers of the normal section
hh0 = [100 200 200 100 100 200];  %  of layers of the normal section 

(m) 
an0 = [1 1 1 1 1 1 1];   % vector of background layer anisotropies
x = 1000:100:6500;  % Cell center x-coordinates of the inverted 

area (m)
y = 3200:100:8100;  % Cell center y-coordinates of the inverted 

area (m)
z = [25 75 150 250 350 450 550 650 750 850 950 1050];  % Cell 

center z-coordinates of the inverted area (m)
dz = [50 50 100 100 100 100 100 100 100 100 100 100];  % Vertical 

cell sizes (m)
iflag = 2 % Inversion flag: 1-Born 2-DQA 3-QA
ma = 0 % A priori model
Nit = [50 20 10] % Number of iteration at each stage of focusing
uconst = 10000 % Upper constraint of anomalous conductivity
lconst = 0.001; % lower constraint of anomalous conductivity
Pfsteep = 0.01 % Parametric functional steepness
qalpha = 0.5 % Updating multiplier for regularization 

parameter
amlt = 0.1 % Updating multiplier for regularization parameter
qmlt = 0.95 % Updating multiplier for regularization parameter
keyq=0
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KEYZ=1
#comment

iterstage=3
Conductivity
Example inversion results

The MYMODEL data file has the structure of a set of four columns defining an 
order of data in any line of X, Y, Z, Value 

3.2000000e+003  1.0000000e+003  2.5000000e+001  3.0490700e+002
3.2000000e+003  1.1000000e+003  2.5000000e+001  3.0490700e+002
3.2000000e+003  1.2000000e+003  2.5000000e+001  3.0490700e+002
3.2000000e+003  1.3000000e+003  2.5000000e+001  3.0490700e+002
3.2000000e+003  1.4000000e+003  2.5000000e+001  3.0490700e+002

Usually geographical coordinates are used consistent with the input inversion 
source data, but coordinates could be a local system, even rotated with respect 
to the geographical coordinates.

Noddy Models

Noddy models can be viewed in the Voxel Modelling facility. Two files are 
necessary. These are a mesh file (G00) and a property and lithology file (Gnn). 
The property file reflects the number of different lithological units within the model 
(eg G12 etc). 

An example of a .G00 file is shown below:

VERSION = 7.11
FILE PREFIX = Noddy Block Format
DATE = 01/01/05
TIME = 12:00:00
UPPER SW CORNER (X Y Z) = -900.0 -900.0 5001.0
LOWER NE CORNER (X Y Z) = 10800.0 7800.0 201.0
NUMBER OF LAYERS = 16

LAYER 1 DIMENSIONS (X Y) = 39 29
   LAYER 2 DIMENSIONS (X Y) = 39 29
   LAYER 3 DIMENSIONS (X Y) = 39 29
   LAYER 4 DIMENSIONS (X Y) = 39 29
NUMBER OF CUBE SIZES = 16
   CUBE SIZE FOR LAYER 1 = 300
   CUBE SIZE FOR LAYER 2 = 300
   CUBE SIZE FOR LAYER 3 = 300
   CUBE SIZE FOR LAYER 4 = 300
CALCULATION RANGE = 3
INCLINATION OF EARTH MAG FIELD = -67.00
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INTENSITY OF EARTH MAG FIELD = 63000.00
DECLINATION OF VOL. WRT. MAG NORTH = 0.00
DENSITY CALCULATED = Yes
SUSCEPTIBILITY CALCULATED = Yes
REMANENCE CALCULATED = No
ANISOTROPY CALCULATED = No
INDEXED DATA FORMAT = Yes
NUM ROCK TYES = 8
ROCK DEFINITION = 1
   Density = 2.000000
   Sus = 0.001000
ROCK DEFINITION = 2
   Density = 2.200000
   Sus = 0.001100

The file PROPERTY.ROX details the lithology in the Noddy model. An example 
of its format is:

Version = 7.100000
Number of Rocks = 19
   Unit Name   = Amphibolite
   Height   = 0
   Apply Alterations   = ON
   Density   = 2.96e+000
   Anisotropic Field   = 0
   MagSusX   = 6.00e-005
   MagSusY   = 0.00e+000
   MagSusZ   = 0.00e+000
   MagSus Dip   = 0.00e+000
   MagSus DipDir   = 0.00e+000
   MagSus Pitch   = 0.00e+000
   Remanent Magnetization   = 0
   Inclination   =   0.00
   Angle with the Magn. North   =   0.00
   Strength   = 0.00e+000
   Color Name   = Dodger Blue
   Red   = 30
   Green   = 144
   Blue   = 255

   Unit Name   = Andesite
   Height   = 0
   Apply Alterations   = ON
   Density   = 2.61e+000
etc….
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ASCII XYZ Models

This format is a simple text representation of a voxel model which allows data to 
be imported from and exported to other software packages. The file starts with a 
header line containing the names X Y Z followed by the names of the attributes. 
The format for each subsequent line is X Y Z Attribute1 Attribute2 Attribute3 etc… 
The X, Y, and Z coordinates are the centre positions of each cell, while the 
attributes are the numeric data values for each cell. The fields may be separated 
by either spaces or commas. Every cell in the rectangular prism model must be 
stored – even null cells. The mesh must be regular – i.e. cell widths, heights and 
depths are uniform across the model. The data should be stored row by row and 
plane by plane. (i.e. X is the fastest changing field, followed by Y, and then Z). 
Planes can be stored in either an upwards or downwards sequence.

An example is repesented below:

X Y Z susceptibility
-287.5 -287.5 -387.5 0.0001272899972
-262.5 -287.5 -387.5 0.0001027179969
-237.5 -287.5 -387.5 9.764270362e-005
-212.5 -287.5 -387.5 7.809209637e-005
-187.5 -287.5 -387.5 4.203460048e-005
-162.5 -287.5 -387.5 2.547840086e-005
-137.5 -287.5 -387.5 2.742360084e-005
-112.5 -287.5 -387.5 2.43577997e-005
-87.5 -287.5 -387.5 2.702029997e-005
-62.5 -287.5 -387.5 2.904669964e-005

Creating a 3D Voxel Model Display

Note Generic ASCII model formats that contain variable sized cells or non-centred 
coordinates can be imported and converted to a standard format using the 
Grids>Voxel Manager. See Importing ASCII Voxel Models.

To add a Voxel Model to Discover 3D you can either click the Display Voxel 
Model button  or select the Display>Voxel Model menu item. Both of these 
operations add a Voxel Model branch to the Workspace Tree.
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Importing and Exporting Voxel Models

• Using the Load Model Wizard

• Using the Export Model Wizard

• Import and Export Voxel Models with the Grid Management Tool

Using the Load Model Wizard

Voxel Models are also produced by the Discover 3D Voxel Gridding Toolkit 
(see Creating and Manipulating Voxel Models), for example from gridding 
dirllhole’s donwhole assay data.

The Data tab of the Voxel Model Properties dialog contains the Load Model 
Wizard button . This wizard allows the selection of all model types, except for 
generic ASCII files.

Click Import Other ASCII Formats to open the Grid Manager tool to convert 
generic ASCII files into an Encom Voxel model. See Importing ASCII Voxel 
Models for more information.

Important Rotated models are not support for any format other than Encom3D Grid. The 
bounds of the model need to be parallel with the X and Y axis. If you wish to 
import a rotated model, you will need to obtain an ASCII (CSV) version of it. 
Refer to Importing ASCII Voxel Models to import and convert this rotated ASCII 
model to an Encom3D Grid.

Note Generic ASCII model formats that contain variable sized cells or non-centred 
coordinates or is non-continuous can be imported and converted to a standard 
format using the Grids>Voxel Manager.
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Using the Voxel Model wizard to select the model type and relevant model files

Note that only a single model can be specified at one time and this is listed in the 
Data tab after being specified. If the Auto-Apply option (at the base of the dialog) 
is enabled, upon reading the model file, Discover 3D automatically displays the 
model.
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Initial display of the Voxel Model

Using the Export Model Wizard

The Data tab also allows the export of Voxel Models in the UBC format. The 
Export button (shown left) will open the Voxel Export Wizard.
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Voxel Model Export Wizard

The export options are:

• Voxel model to 3D vector or ASCII file - export the thresholded model to 
either a DXF vector of individual cells, or a UBC or XYZ model format.

• Single Horizontal depth layer to surface grid -  export a horizontal (Z) 
slice as a 2D surface grid

• Minimum/Maximum value depth surface grid - This option produces a 
2D band surface grid with one band representing the minimum or 
maximum value vertically in the voxel model, and the second band 
indicates the Z depth that this occurs in the voxel model.

• Threshold top/bottom to surface grid - produces a 2 banded 2D 
surface grid, with a "top" and "bottom" band defining the Z value of the top 
and bottom extents of the thresholded model.

• Isosurface to 3D vector file - Export an Isosurface to a DXF vector.
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• Isosurface slice - Export the intersection of an isosurface with defined X/
Y/Z slice planes.

• Slices to Images - Export the current slices to an 3D registered EGB 
images.

• Section Slices to vector files - Export the current Discover section slices 
to vector TAB files which are opened in the 2D Discover sections.

• Horizontal depth slices to surface grid - creates a multi-banded grid 
which has one band for each current Horizontal (Z) slice.

The Isosurface and Horizontal Depth Slice export options are only available if 
these rendering options have been applied to the voxel model. 

Import and Export Voxel Models with the Grid Management 
Tool

The Grid Management tool in the Voxel Toolkit can also be used to import and 
export voxel models. It includes a powerful ASCII import wizard (see Importing 
ASCII Voxel Models) that loads delimited ASCII data and generates multi-banded 
3D grids.

The tool can also be used to export grids in UBC, Encom 3D grid, Encom 
ModelVision TKM, and ASCII formats. 

Viewing Voxel Model Information

In addition to voxel geometric statistics such as the cell size, volume and data 
mean/range values, information report also contains the following calculations, 
useful for more advanced voxel analytics:

• sum*volume (clipped) = sum[value(i)*volume(i)]
where i is every cell unclipped

• thresholded sum*volume (clipped) = sum[value(i)*volume(i)] 
where i is every cell unclipped and in the threshold range

Note Discover polyline sections are not supported by this option. Vertically 
exaggerated section are not supported.

The Model Information button opens a text report which can be saved for the 
model geometery and properties.
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• thresholded mean(by cell) = [sum[value(i)]]/count(i)
where i is every cell unclipped and in the threshold range

• thresholded mean(by volume) = [sum[value(i)*volume(i)]]/[sum(volume(i))] 
where i is every cell unclipped and in the threshold range

This is also a useful tool for seeing the lithology layers included in the model. For 
more details on lithology layers, see Lithology Control.

Changing Voxel Model Display Properties

The display of volume elements (voxels) in the Voxel Model is controlled by the 
properties of the Voxel Model branch in the Discover 3D Workspace Tree. Once 
a Voxel Model branch exists in the tree, double clicking it or highlighting it and 
right-clicking allows you to display the Properties dialog. 

Voxel Model Properties dialog

The text report can be saved using the Save Report button. 

Detailed statistical information can be viewed about the model by clicking the 
Statistics Explorer button (see Statistics Explorer Tool).
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The Properties dialog uses different tabs to control various aspects of the voxel 
model display. These are:

• File Tab – enables import and export of the supported format models and 
viewing model information. 

• Offset Tab – allows the voxel model to be offset and scaled using a Z 
offset and surface grid.

• Lithology Tab – specify the lithology legend table containing the lithology 
string names and colour patterns for the voxel model.

• Clipping Tab – externally clip the model in each of the three principal 
axes.

• Chair Clipping Tab – controls the primary axis slicing to reveal internal 
attribute distribution in three dimensions.

• Slices Tab – allows multiple slices of the model to be displayed at 
intervals along any of the three principal axes or on any user-defined 
plane.

• Threshold Tab – specifies an upper and lower range of attribute values 
that control which voxel cells are displayed.

• Isosurface Tab – specify one or more data values to visualise as 3D 
surfaces through the voxel model. This is the 3D equivalent of contour 
lines.

• Colour Tab – controls the colour and transparency of the voxels.

• Appearance Tab – toggles the display of thresholding, slices, colour fill, 
isosurfaces and wireframing.

Use the controls on these tabs to do these tasks:

• Turning Model Rendering Options On and Off

• Offsetting and Exaggerating

• Clipping Along Principal Axes

• Chair Clipping

• Colour and Transparency

• Lithology Control



17 Displaying Voxel Models 413

• Thresholding

• Isosurfaces

• Slice View

Turning Model Rendering Options On and Off

The Appearance tab of the Voxel Model Properties dialog functions as the 
primary display control for the various voxel rendering types:

• Thresholded view (see Thresholding)

• Isosurface view (see Isosurfaces)

• Slice view (see Slice View)

These display types can be toggled on/off from this tab, whilst still preserving their 
tab-specific display configurations. Each option can additionally be toggled with 
colour fill and/or wireframe views.

Appearance tab of Voxel Model Properties dialog
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Examples of the above options are shown below:

The various Voxel Model appearance settings

Offsetting and Exaggerating

Some voxel models have no information that determines their upper surface 
shape. Instead, they are composed of horizontal layers meaning that their top 
surface is flat.

The Offset tab provides two options to control the offset of the voxel model:

• Add Grid offset – add Z offset values based on a specified grid, or

• Add Contstant Offset – allows constant offsets to be specified separately 
for the X, Y and Z values.

Note You can also clip a voxel model cells above or below a specified surface grid 
using the Grids>Voxel Utilities>Clip to DEM tool.
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The Offset tab and defining a surface to alter the top surface

As well as offsetting the voxel model, you can also apply a Scaling factor that can 
be used to exaggerate the vertical size of the voxel model.

Clipping Along Principal Axes

The Voxel Model display allows you to interactively clip the rows, columns and 
layers of the displayed volume. You can remove individual voxel slices in any of 
north-south, east-west or top-bottom directions. The clipping controls are 
available from the Clipping tab.
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Clipping tab of the Voxel Model Properties dialog

Enable the clipping process by selecting the Clip model option in the Clipping 
tab. Two slider bars are provided for each of the Easting, Northing and 
Elevation directions. So long as the Auto-Apply option is checked, changes to 
any of the slider bars removes or makes volumes of the model appear or 
disappear.
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Slice the mesh of the voxel model in any of the three principal coordinate directions

The entire model is displayed if the slider bars for each direction are on opposite 
sides of their extent. Specific positions of slicing can be entered into the various 
entry fields if desired.

Clipping layers from the model reveals internal structure

The clipping operation either reveals or hides the various rows, columns or layers. 
No gradation of display is provided. Each row, column or layer is either displayed 
or not.
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Chair Clipping

The Chair Clipping tab provided in Voxel Model Properties dialog is an 
extension of the logic used for Clipping. Chair Clipping enables clipping in any of 
the three primary coordinate directions (East, North and Vertical – X, Y and Z) 
resulting in a rectangular prism block being removed from the overall model 
shape.

Chair Clipping showing a portion clipped in each coordinate direction

Chair Clipping provides a method of identifying patterns of the displayed 
attribute within the voxel model and visualising how these trends migrate through 
the volume. The various clipping in any of the three coordinate directions can be 
controlled from slider bars and updated automatically if the Auto-Apply option is 
enabled in the Chair Clipping tab of the Properties dialog.
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Chair Clipping of the model to reveal internal structure

Colour and Transparency

The Colour tab allows the colour and transparency of a voxel model to be 
modified. 

Select the data field to Colour modulate from the top pull-down list; this can either 
be a numeric field (such as an assay value or geophysical property) or the 
Lithology mode when handling discretised voxel models (i.e. voxel models 
comprising a number of unique lithological codes - see Discretised Gridding 
Method).

The standard chair clips can be easily visualized and controlled using the button 
at the top right of the Chair Clipping tab. In the following dialog, the arrow 
buttons will sequentially highlight the standard cuts. Enable Auto Apply to 
visualise the cut dynamically, or press OK to close the dialog and visualise the 
cut.

Chair clipping can be used in combination with model clipping (see Clipping 
Along Principal Axes) to further add interactive viewing control.
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If transparency modulation is required, enable the Transparency check box and 
select a data field from the adjacent pull-down list. (Transparency modulation is 
not available when in lithology mode.)

Two tools are provided:

• A choice of colour or opacity tables.

• Transformation of the selected table via colour or transparency mapping.

The Colour Properties tab to control the colour or opacity table and transform applied to a 
model

Colour Table

Four methods of colour scale definition are available:

• RGB Interpolation - interpolates between two colours in Red:Green:Blue 
colour space.

The Colour Scale button to the right of the Tables colour bar opens the Colour 
Scale dialog which allows the creation and/or loading of colour tables
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• HSL Interpolation - interpolates between two colours in 
Hue:Saturation:Luminosity colour space.

• Look Up Tables - the standard look-up table formats are supported and 
are installed as part of your Discover 3D installation. These can be 
created or edited using the Colour Look-Up Table Editor (see Using the 
Colour Look-Up Table Editor).

• A custom Legend created using the Legend Editor (see Using the Legend 
Editor) in Discover 3D or the Legend Editor in the Drillhole module of 
Discover. This is of particular use for colouring discretised voxel models 
(see Discretised Gridding Method) created using, for example, a series of 
lithology/rock codes. 

Thresholded lithology voxels coloured with by applying a custom legend table

Set the first and last colours of the colour scale by selecting the Colour 
Browse buttons at the bottom or top of the colour bar. When clicked, a 
standard Windows colour selection dialog is displayed allowing colour 
specification. These can be reset by clicking the Set Default Colours 
button.
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Colour Mapping

Transparency Tables and Opacity Mapping

Lithology Control

Discretised voxel models (where a series of unique attributes, e.g. rock or 
alteration codes, have been used to create the block model - see Discretised 
Gridding Method) can be coloured using an appropriate Colour Legend via the 
Colour Scale Selection dialog under the Colour tab. It is also possible to control 
and display individual attributed components via either the Isosurface (see 
Isosurfaces) or Threshold (see Thresholding) tabs, utilising the appropriate 
Lithology mode controls.

The Colour Mapping button to the right of the Mapping colour bar opens the 
Colour Mapping dialog. This enables a range of Data Transforms to be 
applied to the previously selected colour table. For more information, see 
Advanced Colour Mapping.

Note The Colour Mapping dialog is unavailable for voxel models in Lithology mode.

The Transparency Table button to the right of the Tables colour bar opens the 
Opacity Table dialog (this button is only active when the Transparency check-
box is enabled). Use this dialog to create a simple opacity table defined by one 
to four control points. A number of simple predefined tables are available which 
should cover the requirements of most users. The table is displayed graphically 
on a data Percentage vs. Opacity graph. This graph can be modified either by 
selecting and dragging the graph vertices (red crosses) in the graph, or manually 
altering the appropriate Percent and Opacity values to the right of the graph.

The Transparency Mapping button to the right of the Mapping colour bar 
opens the Opacity Mapping dialog (this button is only active when the 
Transparency check-box is enabled). The dialog is identical in content and 
controls to the Colour Mapping dialog above but is applied instead to the 
transparency option selected previously in the Opacity Table dialog. For more 
information, see Advanced Colour Mapping.



17 Displaying Voxel Models 423

Displaying multiple lithology layers from a discretised voxel model as  isosurfaces, with a 
Colour Legend applied

Note If no lithological field is present in the voxel model file, a default set of 
approximately 32-36 lithology bands will be constructed. For a single band/
attribute voxel model, these will simply be the bins from a histogram equalized 
distribution of the data. For multi-band models, it will be divided into subsections 
that reflect each combination possible. For example, in a two-band model 36 
combinations with 6 bins in each band will be generated. I.e. Band1(Bin1) + 
Band2(Bin1); Band1(Bin1)+Band2(Bin2).. etc. These bins values can be 
checked within the Value, Min and Max boxes for each Lithology and band 
combination.

In order to allow the Threshold and Isosurface tabs to display the attribute 
codes for individual layer control in Lithology mode (as pictured above), the 
appropriate Colour Legend must be loaded via the Browse button (shown left) 
under the Lithology tab. If a colour legend is not set, these dialogs will simply 
display a list of index codes (i.e. Index 1, Index 2, etc) instead of the appropriate 
rock/alteration codes.
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Colour Legend selection dialog accessed via the Lithology tab

Thresholding

Thresholding of voxel models allows voxels (cells) to be displayed only if their 
specified attribute lies within the chosen data range. The threshold feature 
operates in two modes:

• Interactive mode – use slider bars to control the displayed voxels by 
dynamically altering the upper and lower data range.

• Lithology mode – display voxels with only predetermined data ranges/
unique attributes i.e. voxel models created with the Discretised Gridding 
Method. 

Interactive Mode

The interactive mode of thresholding enables you to dynamically specify an upper 
and lower range of data attributes and their corresponding voxels for display.

Note After Colour Legend selection, click the Apply button to ensure the changes are 
applied to the threshold/isosurface tabs.



17 Displaying Voxel Models 425

To use this form of thresholding, select the attribute from the list and enable the 
Threshold checkbox for the attribute.. When selected, two slider bars and two 
entry fields become available. With the Auto-Apply option on, if you move either 
of the upper range or lower range slider bars, the voxels displayed automatically 
vary. Operation of the slider bars also adjusts the upper and lower data values of 
the two entry fields. Conversely, you can enter specific values in these entry 
fields. By default a histogram equalized data range is used across the slider 
control. Enabling the Linear Slider checkbox will change this to a linear slider 
across the data range.

Interactive voxel thresholding with normal opacity

Two Opacity modes are available:

• Normal – only the Accepted Voxel Range is displayed, with its 
transparency governed by the adjacent transparency slider bar, or

• Cloud – the Accepted Voxel Range is displayed as solid or opaque, whilst 
the Rejected Voxel Range is displayed with the level of transparency set 
by the adjacent slider bar.
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Interactive voxel thresholding with cloud opacity

Lithology Mode

The Lithology mode allows a selected number of predetermined data ranges or 
attributes to be displayed. These may represent rock types or attribute ranges 
relating to conductivity, magnetic susceptibility etc. To effectively utilise this 
mode, ensure that an appropriate Colour Legend has been assigned in the 
Lithology tab. 

To access this mode, select the Lithology option from the top pull-down list in the 
Threshold tab, and tick the Threshold by option.
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Lithology control of voxel thresholding using cloud opacity

From the Lithology table listing provided, choose the items to be displayed and 
move these into the right hand list area with the arrow buttons. If the Auto-Apply 
option is enabled, the items with the specified attribute ranges should immediately 
display.

Two Opacity modes are available:

• Normal – only the selected Lithologies are displayed; their grouped 
transparency is governed by the adjacent slider bar.

Note Using the Normal mode when applying lithology thresholds produces identical 
results to displaying lithologies as Isosurfaces. However lithological isosurfaces 
allow individual transparency control for each lithological layer and is thus the 
recommended option.
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• Cloud – the selected Lithologies are displayed opaque, whilst the 
unselected Lithologies are displayed with the level of transparency set by 
the adjacent slider bar.

Lithology control of voxel thresholding using cloud opacity

Note Applying a Colour Legend as a Colour Table is not recommended when using 
Cloud mode to display lithology thresholds, as it is very processor intensive 
(particularly colour legends incorporating patterns). Instead it is recommended to 
colour the voxel model using a standard LUT or RGB/HSL interpolation.
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Isosurfaces

Similar to threshold settings, the Voxel Model can be made to display a surface 
of a single attribute data value. The isosurface generator positions the surface 
similarly to a contour map by examining the enclosing voxels and determining the 
correct location for each intersection point of the surface throughout the volume. 
It then triangulates these points and computes the surface. 

As for thresholding, the isosurfaces can be created using the:

• Lithology data - the isosurface is mapped by the data ranges of the 
lithological bands. Note that the created isosurface uses only the lower of 
the data range values. Lithology Isosurfaces cannot be exported as an 
isosurface DXF from the Export tab.

• Interactive mode - this mode allows a particular attribute value to be used 
to create the isosurface. 

Lithology Mode

Note Ensure the Render thresholded voxel model option is disabled in the 
Appearance tab otherwise you may not be able to see the results of creating 
the isosurface as it may be buried within the thresholded or full model display.

To effectively display lithologies as individual isosurfaces, ensure that an 
appropriate Colour Legend has been assigned in the Lithology tab. Also setting 
this Colour Legend in the Colour Table button under the Colour tab allows the 
preset colours/patterns to be used. In the Isosurface tab select the ‘Lithology’ 
option from the top pull-down list and add as layer by clicking the Add button 
(shown left). To alter the layer, highlight it and select the required  lithology entry 
from the Lithology pull-down in the middle of the dialog. 

Note Multiple lithology table entries can be added (as pictured below); the 
transparency of individual layers can be controlled via the Transparency slider 
bar.
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Displaying multiple lithology layers from a discretised voxel model as isosurfaces

You can remove a selected layer by using the Delete button. The Isosurface 
slider bar and entry field are inactive when in Lithology mode.

Interactive Mode

The Interactive mode allows you to specify the attribute value of the isosurface. 
The created isosurface is also triangulated to produce a smooth surface of 
constant attribute value. Colouring of the surface is controlled by the Colour tab.

Note Displaying lithologies (e.g. rock types) as isosurfaces is identical to displaying 
them as thresholds (see Thresholding), except that you can control each layers 
transparency individually as isosurfaces.
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Displaying multiple Property isosurfaces in Interactive mode

The Surfaces button allows individual parts of a Property isosurface to be 
displayed or hidden, when these parts are a distinct mesh separate from other 
parts of the isosurface. 

To create an Isosurface, select the required voxel model data (or properties) 
from the pull-down list. Click the Add button (shown left) and a default attribute 
value is added to the list. Additional values can be added if more than one 
isosurface is to be created. Once a layer is available, the Voxel Model displays 
a surface corresponding to the data value shown. You can use the slider bar, or 
enter a specific data value if desired. The display automatically updates if the 
Auto-Apply option is enabled.

Note Numeric isosurfaces cannot be coloured by a legend. They can be coloured by 
Look-up tables, or alternatively exported to a DXF and the colour changed in the 
DXF vector layer.
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The isosurface Surface Selection dialog, allowing display control of individual components 
of an isosurface

It is also possible to combine both Lithology and Interactive modes by adding 
isosurface layers from both the Lithology band and other data bands.  Separate 
numerical and lithology voxels can be merged using Grids>Voxel Utilities menu 
option.
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A combination Property/Lithology isosurface display

Using Wireframes

Occasionally it is useful to use wireframes instead of isosurfaces alone. 
Wireframing provides a means of seeing through one surface to a second that 
would otherwise be obscured. An example is shown below:
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Two isosurfaces used with the outer one represented only as wireframed, the inner solid

The wireframes also provide information about the control points used in the 
triangulation process to create the isosurfaces.

To apply wireframes to Isosurfaces, enable the Show wireframe option under 
the Isosurface rendering options of the Appearance tab.

Slice View

Voxel models can be visualized as either individual slices or a series of slices 
though the model (i.e. a series of sections through the dataset).  This can be an 
effective method of visualizing the interior of larger or more complex block models 
coincident with other datasets such as drill holes, solid models, etc.

Slice location, orientation and spacing is controlled with the Slices tab of the 
Voxel Model Properties dialog.

• Slice Orientation

• Slice Display Settings

• Viewing Slices as Georeferenced Images (EGB)
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Slice Orientation

There are two options for specifying slice orientation: parallel to a principal plane 
(XY, YZ, ZX) or user defined.

To slice parallel to a principal plane:

1. On the Slices tab, enable the Show option for the orientation required – 
Horizontal or Vertical (E-W or N-S). Note that more than one orientation 
can be enabled simultaneously.

2. If multiple slices are required in the same orientation, enable the Multiple 
tick box

3. Edit the First and Last coordinates for the orientation if desired. If the 
Multiple option is disabled for the slice orientation, the coordinates value 
for the single slice can be adjusted using the slider bar.

4. If multiple sections in one orientation are being displayed, the distance 
between slices can be adjusted using the Step value.

Example of multiple slices displayed in both vertical orientations in tandem with a drillhole 
project.

To slice on the cursor plane:

1. On the Slices tab, select the Arbitrary option.
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2. Select Cursor Plane.

3. Enable and orientate the cursor plane to the desired slice orientation (see 
Cursor Plane). 

4. Click the Synchronize button (far left) to capture the cursor plane 
parameters. 

• Permanently Synchronising the cursor plane  updates the slice 
position continuously as the cursor plane is moved. This mode does 
not allow Multiple Slices to be rendered

• Choosing to a non-permanent synchronisation updates the slice 
position once only, and allows multiple slices to be visualized.

5. Click Apply to display the slice.

To slice on Discover drillhole sections:

1. Open the Discover drillhole project and the sections in MapInfo/Discover 
2D.

2. On the Slices tab, select the Arbitrary option.

3. Select Discover Section.

4. Select from the list the Discover sections to use.

5. Click OK and Apply to display the slices.

6. To edit the sections shown/displayed in 3D, repeat steps 1–5.

To slice on a user-defined plane (manual):

1. On the Slices tab, select the Arbitrary option.

2. Select Manual.

3. Use the dip, azimuth and slider controls in the Slice tab, or click the 
Configuration button. The configuration dialog allows more explicit 
definition of the arbitrary slice’s  X, Y, Z, dip and azimuth parameters, 
including a dynamic preview window of the planes orientation
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Example of an arbitrary slices synchronized to the orientation of the cursor plane. The 
slices are displayed as a wireframe with no fill colour (see Slice Display Settings) 

Slice Display Settings

The display properties of slices are controlled from the Slices and Appearance 
tabs of the Voxel Model Properties dialog.

To turn on and off slices:

• Voxel model slices can be turned off without disabling any options within 
the Slice tab itself by toggling the Render Slices option in the 
Appearance tab.

To change the slice transparency:

• The Transparency of slices can be adjusted using the slider at the bottom 
of the Slices tab.

To change the cell outline and fill:

• Individual cell outlines and fill can be turned on and off with the Show 
Wireframe and Show colour fill options under Slice rendering options 
of the Appearance tab.

To limit the cells displayed to a target data range:

1. Enable the Apply threshold option at the bottom of the Slices tab

2. In the Threshold tab, set the appropriate dataset  and enable the 
Threshold by option. Use the sliders to constrain the data range
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3. In the Appearance tab, disable the Render thresholded voxel model 
option, and press Apply.

Example of multiple slices presented with thresholded data range highlighting regions of 
interest.

Viewing Slices as Georeferenced Images (EGB)

Any voxel sliced view configured in the Slices tab can be converted into a 
georeferenced EGB image series.  This allows large memory-intensive voxel 
models to be handled as much more efficient rasterised cross-sectional images

1. Configure and display the desired voxel slice view in the Slices tab.

2. Go to the File tab of the Voxel Properties dialog, and select the Export 
Model Wizard.

3. In step 1 of the wizard, select the Slices to Images option and press 
Next.

4. In step 2 of the wizard, change the output EGB file location and name if 
desired. The output image X and Y dimensions (quality) can also be 
altered, as well as the image format. Press Finish when complete.

5. Add an Image branch to Discover 3D window, and browse to and open the 
output EGB file.

6. Turn off the visibility of the source voxel model.
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Viewing Slices on 2D Discover Drillhole Cross-Sections

A voxel model can be sliced to opened Discover cross seciton and also exported 
as TAB vector files onto these sections.

1. Configure and display the voxel model.

2. Open the Discover Drillhole project.

3. On the Slices tab, select Show Arbitrary.

4. Click the Populate Sections icon.

5. Click Apply and visualise the slices in 3D.

6. On the File tab, select Export Model Wizard.

7. Select Export section slices to vector files.

8. Click OK and the output 2D vector files will be opened in Mapinfo in the 
corresponding section windows.

Displaying a Floating Colour Legend

A Floating Colour Bar can be added to the 3D window and referenced to a voxel 
model, allowing easily visualisation of the relationship between colours and 
numeric data ranges.

An example of a Floating Colour Bar displayed for a thresholded voxel model



Displaying Multiple Voxel Models

The Isosurface section (see Isosurfaces) described multiple voxel displays 
showing the distribution of two or three voxel layers. In this case, the multiple 
displays are derived from the same voxel model.

Using the Voxel Model within Discover 3D you can also have voxel displays from 
multiple model sources. This is particularly useful if you have results from different 
methods that need to be compared. For example, if a survey area has results from 
a gravity survey inverted and for the same area, a magnetic survey has been used 
to derive an inversion model, the model output results can be compared directly 
in the one display.

Similarly, if a model is prepared as a seed model for an inversion, this technique 
provides a method of directly comparing the seed model with the results 
computed from an inversion process using the seed model.

In the section Creating a 3D Voxel Model Display it was shown how to display a 
3D Map and insert a layer for a Voxel Model. To create additional Voxel Model 
layers and associate them with multiple models, the process is the same but extra 
Voxel Model layers are added to the Workspace Tree.

The steps involved are:

1. Create a Voxel Model in the 3D Map as described in Creating a 3D Voxel 
Model Display.

2. Select the appropriate model as described in Using the Load Model 
Wizard. 

3. Repeat steps 1 and 2 to add extra voxel model branches. The Workspace 
Tree should appear similar to that below:

Integrating Voxel Model Displays with Other Objects

Once the Voxel Model display is used for importing and displaying models as 
described, you can take advantage of Discover 3D’s ability to create powerful 
interpretational displays by integrating other display objects. Other object types 
supported include:
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• Gridded surfaces.

• Drillholes.

• External 3D graphics files such as DXF format.

• Located bitmaps derived from scanned or captured imagery.

• GIS layers derived from MapInfo Professional.

• Models derived from third-party packages such as ModelVision Pro, EM 
Gui etc.

An example of the complexity of display that is possible with integration in the 
Voxel Model and Discover 3D is shown here:

Display of drillholes, located bitmap, model and isosurface using the Voxel Model

For information on importing and displaying any of these additional objects, refer 
to the relevant sections of this guide.
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18 Creating and Manipulating Voxel Models
The voxel tools on the Grids menu provide the ability to create and process voxel 
models (often referred to as 3D meshes, block models or 3D grids) from drillhole 
or 3D point data. Gridding interpolates between the existing data points/intervals, 
creating a continuous 3D mesh of cells, each of which is assigned a value (either 
numeric e.g. geochemical assay or character e.g. lithology). The 3D interpolation 
process allows dispersed source data to be visualised as a continuous dataset 
(e.g. a voxel model isosurface), providing the geoscientist with a powerful 
analytical tool.

For example, the image below shows a small collection of drillholes with colour 
modulation based on gold assay data.

Example of drillholes to be gridded using gold assay intervals

The dataset was gridded with the Voxel Gridding tool, producing a 3D grid/voxel 
model. Discover 3D can display voxel models as thresholded (see Thresholding) 
block models or as Isosurfaces (amongst other visualisation options). In this case 
(below) an isosurface was extracted from the voxel model to show the distribution 
of the gold above a certain threshold. The isosurface is semi-transparent to 
enable the drillholes within to be visualised.
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Isosurface of gridded gold values from sampling of the drillholes

Another example (below) is produced from a larger dataset and shows the 
continuity of the gold mineralization across the drillholes.

Example of the continuity of gold assays from the drillhole dataset
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The voxel tools available on the Grids menu are:

• Grids>Voxel Gridding – create 2D grids (surfaces) or 3D grids (voxel 
models) from 3D point or segment data, such as a drillhole database. The 
use of the Voxel Gridding tool is described in:

• Creating a Voxel Grid

• 3D Gridding Methods

• 3D Gridding Parameters

• Grids>Voxel Filter – apply convolution filtering to Voxel Models.

• Grids>Voxel Utilities – A powerful range of utilities for advanced vector/
voxel analytics, voxel resampling and merging and clipping voxels to 
vector surfaces/volumes.

• Grids>Voxel Calculator – conduct mathematical operations on Voxel 
Models.

• Grids>Display Assistant – load and display Voxel Models in Discover 3D.

• Grids>Voxel Manager – import and export Voxel Models in a variety of 
formats.

Voxel tools will automatically load voxel models that are open in Discover 3D. The 
list of grids presented in the various function dialogs will display an icon indicating 
whether a grid is on-disk, in memory or in memory and unsaved. Grid information 
can be viewed for any file by selecting the information icon in the list. Grids listed 
in the current tool are available to all other voxel tools.

On closing a voxel tool, the Voxel Toolkit dialog will open, providing direct access 
to the other voxel tools."
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The Properties button accesses advanced settings for the Grid calculator and 
Gridding tools. For more information, see Advanced Gridding Properties.

Creating a Voxel Grid

Grids>Voxel Gridding

The input data may be either a collection of three dimensional points or drillhole 
intervals. An interval must be defined by two 3D points – the beginning and end 
of the interval. The value of the sampled interval is assumed to be constant 
between its end points.

The gridding operations in the Voxel Toolkit interpolates 3D spatial data into a 
regular 3D grid (voxel model or block model – terms commonly used in the 
mining industry). The 2D gridding operations generate horizontal surfaces (in 
the X, Y plane) at a user-specified RL level. These grids can then be exported 
as ER Mapper format files.
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To simplify the process of creating 2D or 3D grids the gridding operations are 
presented with a wizard interface. The gridding methods and controls available 
are described in 3D Gridding Methods.

Creating a voxel model from drillhole or sample data:

The following steps guides the user through process required to apply 3D gridding 
to a drillhole projects. This will apply an interpolation (in this case Inverse 
Distance Weighting) to a downhole data field (e.g. an assay field), the creating a 
voxel model. This can then be used to visualise high assay value correlation 
between holes (see Changing Voxel Model Display Properties).

1. Ensure that the drillhole project is displayed in 3D (see Displaying Drillhole 
and Trench Data in 3D).

2. In the 3D window, select Grids>Voxel Gridding.

3. Select the Continuously Variable technique. Set this to Inverse 
distance weighting. Press OK. 

4. In the Input Data tab, select the Dataset to grid, and check that the XYZ 
field assignments are correct.  Select the Data Field to grid, such as an 
assay or geophysical field. Enable the From-To segments option (will 
handle drillhole intervals as segments rather than as points).

Note Voxel Gridding also provides the option for 2D grid, however it is recommended 
to use the Grids>Surface Gridding which contains more powerful interpolation 
methods options as well as an dynamic preview window.

Note If you wish to grid different fields in the dataset using a different method, such as 
lithology with Discrete, these separate voxel models can then be merged using 
Grids>Voxel Utilities.

Optionally, prior to gridding, you can reduce the input drillholes to just 
those with good assay sampling and are closely spaced.  Selecting a 
subset of drillholes will improve the speed of the gridding process.

5. On the Conditioning tab use the Data Conditioning button to remove 
abnormal or invalid data, such as negative values representing missing 
samples and spurious outliers, as well as providing Null value assignment 
and handling. It can also be utilised to query out and display specific 
portions of a dataset, for example all downhole gold assays between 2g/t 
and 5g/t, or only intervals with a QBX or QV lithological code.
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6. In the Size tab, use the Auto button to set the cell sizes to Low 
resolution (i.e. larger grid cell sizes).  Higher resolutions (smaller grid cell 
sizes) should only be set after the gridding parameters have been 
extensively refined- they will create a much larger block model (memory 
consumption) as well as significantly increase the processing time.

7. In the Size tab, click Detect Rotation. This will set a default rotation 
angles to match the trend in the input dataset. Click the Preview button to 
visualise this mesh.

8. In the Search tab, select Elliptical Search. 

• Leave the default Strike, Plunge and Dip orientations of 0. 

• Set the Major and Minor axis search values at approximately a 
third to half the average spacing between the holes. 

• Set a Depth axis value of approximately half of the XY axes, which 
corresponds to the much higher sampling downhole.  

• Set a Search Expansion of 3. This will result in the gridding 
algorithm using the initial search radius defined; if it cannot find any 
data points or meet the sample selection criteria within this radius, it 
will then try a double size radius and finally a triple sized radius. If it 
still cannot calculate a cell value with data points within this volume, 
the cell value will be set to Null.  

• Also set Grid passes to 3.  This is useful for uneven data as initial 
‘rough’ pass is performed at 1/3 the resolution to determine areas 
where to perform subsequent half and full resolution passes will be 
calculated.

9. Still in the Search tab, set the Sample Selection parameters to 2 Z 
sectors, and 2 points for both minimum and maximum.  These set the 
required number and distribution of data points in the search area before a 
cell will be calculated. The more stringent these rules, the more likely the 
output model will reflect the input data.

The Sample Selection criteria can be relaxed by enabling the Gridding 
Rule option. 

Note If custom cell sizes are entered, ensure that the Auto>Fit to extents option is 
then applied to recalculate the number of cells to cover the input dataset.
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10. The Preview button at the top of the Search tab allows the user to 
visualise the resulting search volume with an overlay of the input data 
points in a rotatable 3D view. The search distance and number of search 
expansions can be dynamically altered from within this view.  Press Next 
to advance to the final dialog.

11. The Method tab provides a number of Weight Models; leave the default 
Power model selected. These control how the data points within the 
search volume are weighted in the final cell value calculation, based on 
their distance from the cell centre. Press Finish to start the gridding 
process.

12. Upon gridding completion, a Save grid dialog will appear, prompting for a 
file name and location. The output grid is saved as an Encom 3D format 
(.E3D). Upon closing this dialog, the new grid will be displayed in the 3D 
window and also the Display Assistant dialog.

For more information about inverse distance weighting and other gridding 
methods available, see 3D Gridding Methods.

3D Gridding Methods

• Continuously Variable Gridding Methods

• Discretised Gridding Method

• Distance Gridding Method

• Density Gridding Method

Continuously Variable Gridding Methods

This technique is used to grid variably spaced numeric data such as drillhole 
assay values. It smoothly interpolates values at each grid node based on a 
weighted function of the surrounding data. Two weighting methods are available: 

• Inverse Distance Weighting

• Kriging
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Inverse Distance Weighting

Inverse Distance Weighting (IDW) is a universal technique that can be applied to 
a wide range of spatial data. IDW uses weighted averages to estimate new grid 
cell values and can be used as either an exact or a smoothing interpolator. The 
value assigned to each grid cell in an output grid is calculated using a distance 
weighted average of all data point values that fall within a specified search radius 
if the grid cell.

The IDW method is optimal when the input data is uniformly distributed 
throughout the volume to be gridded, and some degree of smoothing is required 
in the output grid. 

IDW gridding provides the following wizard dialogs:

1. Input Data

2. Data Conditioning

3. Grid Size

4. Search Parameters 

5. Method

Kriging

Kriging is a geostatistical gridding method originating from resource geostatistics, 
which is used due to its flexibility and data-driven approach to surface 
interpolation. Kriging is an advanced technique which is based on the assumption 
that the spatial variability in a measured property is neither due to totally random 
or deterministic constraints. The main advantage of Kriging over simpler 
interpolation techniques such as IDW is that it is data driven and uses a weighting 
model which is adaptive to the inherent trends in a data set rather than imposing 
a set of fixed conditions upon them.  Using Kriging in interpolation can be a 
complex process as it requires an intimate knowledge of the structure and 
variability in the data set in order to choose an appropriate sample model and set 
of gridding properties.

Over the past several decades Kriging has become a fundamental tool in the field 
of geostatistics. The method of interpolating a surface using Kriging is generally 
performed as a two stage process: 
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Stage 1

The input data is analysed to establish the spatial predictability of the measured 
values in the study area. This analysis generally focuses on the spatially 
correlated component of the data by means of determining the degree of spatial 
dependence among the sample points. The average degree of spatial 
dependence among variables is summarised in a plot known as the semi-
variogram. The semi-variogram is a concise means of representing the average 
intersample variation according to sample separation distance and direction. In 
order to use the sample variance as part of the interpolator in the Kriging process 
it is necessary to model the semi-variogram in order to define a mathematical 
function which optimally describes the underlying structure in the data. This 
process is known as variogram modelling which in itself can be a very involved 
and complex task. Once an appropriate model has been chosen it can then be 
used to estimate the semivariance or weighting at any given sample distance. 

Stage 2

New values are interpolated or estimated at locations which have not been 
adequately sampled. This process is known as interpolation ‘Kriging’. The 
simplest technique, known as “ordinary kriging” uses a weighted average of the 
neighbouring samples to estimate the unknown value at a given grid node. The 
weights are optimised for each node using the variogram model, the distance to 
the surrounding samples and the inter-sample variance.

The first step in kriging is to construct a variogram  (or semivariogram) from the 
input data which describes the spatial correlation between the sample points. A 
variogram generally consists of two parts: 

• The experimental (or sample) variogram, and

• The model variogram (a descriptive function which mathematically models 
the experimental variogram). 

The degree of spatial dependence among sample points is measured by the 
average semivariance:
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Where h is the distance or lag between sample points, n is the number of samples 
separated by h and z is the attribute value of interest. The computation of γ(h) is 
performed in two steps. First pairs of sample points are grouped together by 
distance. For example, if the distance interval (or lag) is 1000m then pairs of 
points separated by less than 1000m are grouped together into a 0-1000m lag, 
samples separated by a distance of between 1000 and 2000m would be grouped 
into a lag of 1000-2000m and so on.  Next the average distance h and the average 
semivariance γ(h) is calculated for each group. If spatial dependence exists 
among the samples, then pairs of points closer together will have more similar 
values than pairs that are further apart. The semivariogram is a plot which has the 
average semivariance γ(h) along the y-axis and the separation distance h along 
the x-axis. 

Experimental and Model Variogram used in kriging

The semivariogram can be broken down into thee main components; the Nugget, 
Sill and Range.

Nugget – is the semivariance at a distance of zero and represents the degree of 
sample repeatability or spatially uncorrelated noise.

Range – is the spatially correlated portion of the semivariogram that exhibits an 
increase in the semivariance with distance. Towards the limit of the range the 
semivariance levels off such that with additional increases in distance it is 
indistinguishable from one point to the next. This point of flattening is called the 
sill.

Sill – is the point at which the semivariance (range) levels off to a relatively 
constant value.

Once an experimental variogram has been computed, the next step is to define a 
model variogram. A model variogram is a mathematical function that models the 
trend in the experimental variogram. Once the model variogram is constructed, it 
is used to compute the weights which are used in the Kriging interpolator. The 
basic equation used in ordinary kriging can be described as follows:
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Where n is the number of points in the data set, fi are the attribute values of these 
points, and wi are weights assigned to each point. This equation is essentially the 
same as the equation used for inverse distance weighted interpolation except that 
rather than using weights based on an arbitrary function of distance, the weights 
used in Kriging are based on the model variogram. The creation and analysis of 
the sample and model variogram is done using the Variogram dialog on the 
Statistics Explorer Tool , which is accessed from the Kriging dialog (see 
Computing a Sample Variogram and Defining a Model Variogram).

The gridding wizard dialogs utilised by Kriging are virtually identical to IDW:

1. Input Data

2. Data Conditioning

3. Grid Size

4. Search Parameters 

5. Kriging Estimation Method

The main difference is the final Method tab, which provides Kriging-specific 
options.

Discretised Gridding Method

This method uses Inverse Distance Weighting to interpolate discrete or 
classified data. An example would be to classify geological rock codes recorded 
for drillhole samples and assign these to a voxel model. Both string and numeric 
data can be classified by this method. Once the data has been classified it is then 
interpolated into a grid using similar techniques to the continuous interpolation 
method. The main difference being the value assigned at each grid node 
represents a specific classification code rather than a weighted value. The 
classification code which is assigned to each node is the one with the highest 
probability of occurring at the interpolation point. 

The method produces a legend file as one of the products of the gridding process. 
This legend file can define surface and line colour and pattern for each 
classification. It can be used as a rendering guide when the grid is displayed.

Discretised gridding presents the following gridding dialogs:
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1. Input Data

2. Data Conditioning

3. Classification

4. Grid Size

5. Search Parameters 

6. Method

Distance Gridding Method

This produces a grid that records the distance from the centre of each grid cell to 
the nearest valid data point. It is useful for identifying gaps in data coverage. It is 
also used as an input to some filtering processes because it can be used to define 
nodes in the output grid that are ‘near’ to input data points.

Distance gridding utilises the following wizard dialogs:

1. Input Data

2. Data Conditioning

3. Grid Size

In addition, the final dialog is the Distance Parameters dialog. In this, a 
maximum distance envelope can be specified to clip the grid to from the nearest 
input data. Any grid node that is outside this envelope is assigned a null value.
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Anistropic distance options can be defined which works in a similar way as 
discrete search parameters.  See Anisotropic Search for more detail.

If you have checked From-to segments in the Input Data, a more accurate 
solution can be obtained by also considering the perpendicular distance to each 
segment as well as the end points (the distance-to-line enhancement option). 
This has the unfortunate side-effect of severely reducing the speed of operation. 
If the segments have been discretised (see Discretised Gridding Method) 
sufficiently then it is usually sufficient to use just the point data. Note that the 
performance of the algorithm can be improved by specifying an envelope 
distance. 

Density Gridding Method

The Density gridding method produces a grid which records a measure of the 
point density at each grid cell.

As with Distance gridding, it utilises the following gridding wizard dialogs:

1. Input Data
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2. Data Conditioning

3. Grid Size

Additionally a Density Parameters dialog provides two estimator function options 
for the independent calculation for each grid node: the Radial density estimator 
and the Kernel density estimator (KDE).

The Radial method returns a true measure of the point density at each grid cell 
(measured as the number of samples per cubic volume unit – usually metres). It 
is a simple method that counts the number of input samples within a specified 
radius of the grid cell position and then normalises that count by the area of the 
search.

The Kernel density estimator is a non-parametric density estimator. It uses a 
similar approach but it weights the input samples by a kernel function that is 
normally a function of the normalised distance of the sample to the grid cell. To 
achieve a good result with the KDE function it is more important to choose an 
appropriate search radius – sometimes referred to as the bandwidth – than to 
choose an appropriate kernel function. If the bandwidth is too small the density 
will be under-smoothed whereas if the bandwidth is too large the density will be 
over-smoothed and lacking in resolution.
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Given a kernel function K and a search radius (or bandwidth) h, the estimated 
density at any point x is given by:

Where n  is the number of samples.

The following kernel functions are supported:

If you have taken multiple samples at each input data location and this information 
is recorded in the input source data you can use this information to bias the 
density estimation. 

Often a density grid will contain a large number of cells with zero density. These 
can be converted to NULL values via the grid calculator using an expression like 
NEW = if (OLD == 0, null, OLD) which will make visualising the grid easier.

Kernel K(u)

Uniform

Triangle

Epanechnikov

Quartic

Triweight

Gaussian

Cosinus
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Note that this method only uses point samples, so to ensure that segment 
sampled data is accurately represented, use the Advanced Gridding Properties 
options to set a suitable Segment break length.

3D Gridding Parameters

The parameters used in voxel gridding are controlled from a series of dialog 
boxes displayed by the Gridding Wizard. Some dialogs are common to several 
methods and some are specific to one or another method (see Continuously 
Variable Gridding Methods, Discretised Gridding Method, Distance Gridding 
Method, and Density Gridding Method):

• Input Data

• Data Conditioning

• Classification

• Grid Size

• Search Parameters

• Method

• Kriging Estimation Method

Input Data

The second dialog (Input Data) of the Gridding Wizard requires a source 
dataset to be selected from those currently loaded in Discover 3D. Both 
drillhole, 3D point and 3D line datasets can be used. The input lines or drillholes 
can be specified manually or via a graphical selection dialog by clicking the Line 
Selection button.
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Specify the input dataset to be gridded plus the data fields

By default the input data is assumed to be 3D point source data. Alternatively, you 
can specify that the input data are From-To Segments, i.e. drillhole intervals. In 
this case, each sample is defined by a beginning and end point location, and the 
value of the data over the segment is assumed to be constant. This results in 
more accurate solutions as the distance from the interpolation point to the sample 
may be less than the distance to either of the sample end points.

X, Y and Z (RL) fields need to be specified from the appropriate pull-down lists, 
as well as a Data field (e.g. an assay field for Continuously Variable gridding, or 
a lithology field for Discretised gridding). Alternatively a multi-banded grid can be 
created by selecting multiple data fields (use the CTRL or SHIFT keys for multiple 
selections); the output grid will have multiple independent properties stored at 
each grid cell. Note that not all export formats support multi-banded grids.

A range of Coincident point handling options are provided in a pull-down list 
(average, minimum etc). If using drillhole interval data with the From-To 
Segments option enabled, it is recommended that this is set to Do not modify. 
Using any other option in this instance may result in modification of the value of 
the assay along the entire interval, as the first point of each interval is likely to be 
coincident with the last point of the previous interval. 
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Data Conditioning

Conditioning of data to be gridding using the 3D Toolkit

This dialog also provides a range of options for data conditioning prior to 3D 
gridding. This process is essential to eliminate poorly defined data from the input 
dataset, such as negative values representing missing samples (e.g. Sample Not 
Received (SNR), Below Detection limit (BDL), etc). It also provides data capping 
options (e.g. capping gold assays in mineralization systems prone to nugget 
effects), as well as conversion of Null values to a user-defined background value. 
Failure to remove such artefacts can result in meaningless output grids.

The Conditioning (third) dialog of the Gridding wizard allows the source dataset 
to be clipped to specified X, Y and Z extents by enabling the Apply data clip 
option. These values can be reset to the initial dataset extents by clicking the 
Reset extents to input button. All source data points outside the defined region 
are ignored and do not contribute to the gridding. The Line Selection button 
(see Input Data) can be also used to remove lines and holes that are not to be 
used in the gridding process.



18 Creating and Manipulating Voxel Models 461

Setting a Cap values below or above value will cap source data outside the set 
limit to the limiting value. For example, with Cap values above set to 500, a gold 
assay on 725ppm will be handled during 3D gridding as a 500ppm value. It is also 
possible to Convert null values to a background value specified by the user, in 
order to constrain the gridding. For example, if gridding drillhole geochemical 
assays, much of the hole may not have been sampled and in these areas the 
assay result may be assumed to be equal to the background value. This helps 
prevent anomalies ‘ballooning’ into areas with no source data coverage.

These conditioning options presented in the main dialog are global settings: if 
multiple data fields have been selected in the Input Data dialog (i.e. in order to 
create a multi-banded grid), these settings will affect all fields equally. 

Further conditioning controls are available via the Advanced Settings button 
(shown left) to the right of the listed data field.  This opens the Field Data 
Conditioning dialog (see Data Conditioning). If multiple data fields have been 
selected in the Input Data dialog (see Input Data), the Advanced Settings 
button can be used to set individual capping and background values for each 
field by selecting the required field from the pull-down list.
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Classification

The Classification dialog provides two options for classifying unique values:

• Classify from Legend: use an existing .leg file to classify the input data. 
Existing legend files which have been created (for example to colour 
downhole lithologies in a drillhole project) can be used. For the location, 
ensure you select System and define a Legend name. They will then be 
available in the Legend Editor and other dialogs. Any data which does not 
match a record contained in the legend file will be treated as a NULL value 
in the output.

• Auto-classify: creates a new legend using the entire input dataset. All 
input data will be classified unless it has been set as Null in the Field 
Data Conditioning dialog. For the location, ensure you select System 
and define a Legend name. They will then be available in the Legend 
Editor and other dialogs.
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Grid Size

The Gridding Wizard Size dialog allows the dimensions and extents of the output 
3D grid to be specified. Required parameters are:

• Basic grid cell size (individual X (column), Y (row) and Z (plane) 
dimensions).

• Number of cells in the X, Y and Z orientations.

• The grid origin: by default this is set to the centre of the model.

• Start and End extent: the relative distance of the first and last cell centre-
point in the model.

• Rotation of X/Y/Z axis about the Origin point.

3D grid size specified using the Auto Med Res option
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In addition to the Auto size options, there is also an option to Detect Rotation of 
the input dataset. This optimizes the coverage of the grid mesh to cover the 
dataset.

Once parameters are set, the wireframe mesh can be previewed at any time by 
selecting the Preview button. Or enable the Auto Preview option to dynamically 
update the preview any changes are made to the Size dialog.

Alternatively the basic grid cell size can be set manually by setting the desired 
Column, Row and Plane cell sizes and then using the Auto button’s Fit to 
Extents option to calculate the corresponding origin and number of cells in the 
three dimensions to cover the source data appropriately. 

The cell size can be fixed or variable. For example, a larger cell size can be 
specified on the edges of the 3D grid and a finer cell size in the centre. A variable 
cell size can be set by checking the Variable cell size option and defining the cell 
sizes in all three dimensions using a count*size notation. For example 5*200 
10*50 5*200 specifies a total of 5 cells with width 200 metres on both outside 
surfaces and 10 cells of 50 metres width in the middle.

It is also possible to manually set the Number of cells and/or Origin coordinates 
in each of the three dimensions. Note that manually altering the Number of cells, 
Origin coords or applying Variable cell sizes can easily result in an 
inappropriately sized output grid: for example by gridding only a small portion of 
the source data extents (if any at all) or alternatively creating a grid far larger than 
the source data extents. Comparison of the Grid Range extents to the Valid Data 
Range extents is essential when altering these parameters manually.

The definition of 2D grids is similar except that variable cell sizes are not 
supported and only a single plane can be generated.

The simplest option for setting these parameters is by using the Auto button 
(shown left). It has three settings (High, Medium and Low Res) for calculating the 
appropriate origin, cell size and cell count to cover the source data extents at the 
specified resolution.

The Load and Save options under the Auto button retrieve or save settings to a 
grid Extents file (.E3X). The Match Grid option allows you to browse to an 
existing grid on disk and retrieve the grid size from that.
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Search Parameters

The Search Parameters dialog is displayed for the Continuously Variable 
Gridding Methods (Kriging or IDW) and Discretised Gridding Method. It provides 
a plethora of options (similar to those in the 2D gridding tool in Discover) for 
refining the search algorithm, allowing the speed of grid creation to be balanced 
against the quality of the output grid.

Specifying the Inverse Distance Weighting parameters using a Simple Search

The interpolation algorithm proceeds by examining each grid cell in turn. It finds 
the distance from the grid cell centre to all source data points. Using one of a 
variety of weighting schemes, it interpolates a value at the node by summing the 
contribution from all data points, weighted according to the distance between the 
grid cell and the data point. The weighting scheme ensures that data close to the 
grid cell contributes more to the final value at that cell than data far from the cell.
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This is a simple technique that suffers from one major problem – it is slow and 
runs in a time proportional to the number of grid nodes multiplied by the number 
of input data points. In many cases, it is simply too slow and so a variety of 
techniques are used to improve performance. Unfortunately all of these 
techniques degrade the quality of the solutions. The key to generating a quality 
grid is to balance speed requirements against quality requirements and 
experimentation is almost always necessary. For this reason it is recommended 
to experiment with a low resolution grid first and then generate the final grid at the 
required resolution once the appropriate gridding parameters have been  
determined.

Searching

The first option designed to improve gridding performance is to introduce a search 
Distance. The algorithm will only search for contributing data points within this 
specified distance of the grid cell. Data points outside of this distance will be 
ignored.

However, this can result in a node failing to be gridded (i.e. assigned a null value) 
if insufficient data points are found within the search distance to satisfy the 
algorithm. Two additional options can help resolve this: 

• A Search Expansion (up to 5 expansions) can be specified. If an 
insufficient number of data points are found within the search distance, the 
search distance is increased (by the initial radius) and the search is 
repeated. This occurs up to ‘n’ times – as specified by the user. The final 
search distance therefore is the number of expansions multiplied by the 
initial search distance: i.e. specifying a search distance of 15m with three 
search expansions would result in three consecutive searches of 15m, 
30m and 45m.

• By setting the number of Grid Passes to greater than one (5 maximum), 
the gridding algorithm will conduct the specified number of passes over 
the dataset, adding the grid nodes populated in the first pass as input data 
for the next pass. With each successive pass, the gridding resolution will 
increase: the search radius for any pass is equal to the pass number 
(which is decreasing e.g. 3, 2, 1) multiplied by the specified search 
distance.  Thus with a search distance of 25m and three grid passes, the 
first search pass would utilise a 75m search radius, the second 50m 
(incorporating any nodes gridded in the first pass as additional input data), 
and the last 25m (again with the output nodes of the second pass as 
additional input data). This feature is useful if the input data points are 
unevenly distributed as it fills in the gaps in coverage more efficiently.
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The 3D Gridding also includes a Simple mode that does not restrict the search 
radius and allows all input data to contribute to each solution. This may, however, 
take a long time to run, but the grid generated is often quite smooth and may 
serve as a guide for further gridding attempts.

Anisotropic Search

When gridding data that is sampled sparsely in one or two dimensions and 
densely in another, it is advisable to use an Elliptical search. This can also be a 
powerful tool when a regional trend is interpreted to be influencing data 
distribution, e.g. a regional NE-trending fault/fluid conduit system may affect the 
soil sample geochemical trends. You may wish to weight samples along strike of 
a grid node more than those parallel to it. 

Elliptical searches use the search Distance as the default ellipsoid axes lengths 
(ie spherical search). 

The orientation of the ellipse from the XYZ axes is denoted by the Bearing 
(orientation or azimuth of the major axis), Inclination (the dip or plunge of the 
major axis, which is the angle above the horizontal plane), and Tilt (the dip or 
plunge of the minor axis, which is the angle above the horizontal plane) of the 
elliptical search area.

You can specify a Major axis length (or search distance), a Minor axis length 
and a Depth axis length. For the default orientations of 0 degrees, these 
correspond to the X, Y and Z axis respectively.

Preview

Note The orientation of the Anistropic search ellipse is independent of the Grid Size 
(mesh wireframe) orientation. For example if Z is 0 degrees, then the search axis 
will be vertical, regardless of the grid's rotation.

Note The convention for ellipses is that the Major Axis>Minor Axis>Depth Axis. You 
can use the orientation controls to place these axes in the desired position for 
your data.

The current search spheroid or ellipsoid can be viewed in a simple 3D preview 
window with the source dataset by clicking the Preview button at the top right of 
the Search dialog. 
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The controls at the base of this dialog link directly back to those in the Search 
dialog. You can therefore modify ‘on-the-fly’ the search distance, ellipsoid axis 
lengths and orientation, as well as the number of grid passes and expansions, 
visualising these changes immediately with respect to the source data 
distribution.

The View All button will reset the preview screen to the extents of the entire 
dataset.

Search parameters can be saved and reloaded as a grid Parameters file (.e3g) 
using the Load and Save options under the Auto button.
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Sample Selection

Using a search distance can result in the contributing data points not being evenly 
distributed about the grid cell, resulting in poor solutions. Search sectors are a 
powerful way to ensure that input data is evenly spatially distributed about the grid 
cell. 1, 2, 4 or 8 sectors can be specified; for 2 or 4 sectors the axis (or axes) which 
separate the sectors is also specified. The higher the number of sectors specified, 
the more evenly distributed the source data must be about the grid node, but the 
more likely the gridding will fail for the node. This criteria can be made even more 
rigorous by specifying the Minimum points required in each sector.  In densely 
distributed datasets with multiple points in each sector, the Maximum number of 
samples per sector to be used in the grid node calculation can also be 
controlled.

Gridding Rule

In cases where rigorous search sector parameters result in too few nodes being 
gridded, it is possible to relax these rules using the Customised gridding rule. 
This option allows the node to be gridded if at least n samples are located in each 
of at least m sectors, where either n or m (or both) can be less than the values 
specified in the Sample Selection section of the dialog.

Method

The final Method dialog is presented only for the Inverse Distance Weighting and 
Discretised Gridding Method techniques. This dialog provides a choice of 
weighting schemes and associated parameters which are applied to the input 
data after the Search Parameters have been applied. Weighting models include: 
Linear, Exponential, Power law and Gaussian. The default option is a Power 
Law.

The specific weighting schemes are described below. A graph depicting the 
variation in Weight with Distance is provided at the bottom of the dialog for visual 
reference. The graph is dynamically updated whenever the method changes.
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The Method tab for the IDW technique

Weighting Models

Linear

The weight assigned to each data point which is used to interpolate the value at 
a grid node is proportional to its Euclidian distance from the node being 
interpolated. If a simple linear (to cut-off) weight model is selected, the Nugget 
and Range parameters are enabled. These parameters can be adjusted to vary 
the weighting assignments that are applied within a Range and Nugget distance. 
At distances less than the Nugget distance, the maximum weight is applied to the 
input points (i.e. all data values will contribute equally to the averaged node 
value). The Range defines an outer distance threshold for the weight model. Any 
data points which exceed the Range distance but are less than the Search 
Distance (see Search Parameters) will be proportionally weighted by their 
distance from the grid node such that:

Distance < Range: Weight =      

Distance >= Range: Weight = 1

Range
DistNugget −
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Exponential   

The weight assigned to each data point is proportional to its distance from the grid 
node being interpolated raised to a specified power. Increasing the power value 
will result in smaller weights being assigned to closer points and more distant 
points being assigned equal but large weights. Increasing the power value will 
cause each interpolated grid node to more closely approximate the value of the 
sample which is closest to it. As with the Linear model the Nugget and Range 
properties can be modified to constrain the distance over which the exponential 
weight model is applied.

Distance < Range: Weight  

Distance >= Range: Weight = 0

Power   

The weight assigned to each data point is proportional to the inverse of its 
distance to the grid node, raised to a specified Power. Increasing the power value 
reduces the amount of influence distant points have on the calculated value of 
each grid node. Like the exponential weighting model, large power values cause 
grid cell values to approximate the value of the nearest data point. Smaller power 
values will result in a higher degree of averaging such that their values will be 
more evenly distributed among neighbouring grid nodes. The default weighting 
value is 2 (i.e. the weight of any data point is inversely proportional to the square 
of its distance from the grid cell). This is appropriate for most situations. If 
required, the weighting value can be altered to any positive value.

Weight 

Gaussian 

The weight assigned to each data value is determined according to a 1D 
Gaussian function centred on the grid node. The shape and standard deviation of 
the Gaussian function is proportional to the Range with larger values producing 
a flatter function and a smoother grid.

Weight 
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Elliptical weighting is available when the Elliptical Search option is enabled in 
the Search Parameters dialog. It adjusts the distance weighting function for data 
points within the search ellipse depending on their relative position with respect 
to the elliptical shell defined by the search ellipse. Points located on the same 
elliptical shell will be assigned equivalent weights, even though their distance 
from the ellipse centroid may be different.  

Tapering (only available for the Inverse Distance Weighting technique) allows 
interpolated values to be reduced to a background value at large distances from 
a grid node. It can be used to modify the weighting function in situations where 
the search distance is greater than the Range but there is considered to be little 
correlation with the source data: 

• Between a distance of zero and the From distance the taper function is 
assigned a constant value of 1 (i.e. no modification is made to the grid 
node value). 

• Between the From and To distance the taper function is applied as a 
linear weighting between the grid node value and the background value. 

• Beyond the To distance grid nodes are assigned the background value 
only. 

Apply Density corrections dynamically adjusts the search algorithm to optimise 
grid cell interpolation in areas of data clustering. Activating density corrections 
can help to enhance detail in datasets where sample points are unevenly spaced 
(e.g. drillhole geochemical assays) and may, in some cases, produce a smoother 
or more representative grid. The density correction modifies the weights for each 
contributing point based on the sample density at that point.

Exact hit distance is a distance tolerance which is used for assigning real data 
values to grid nodes. As the inverse distance gridding technique attempts to 
interpolate a continuous function through the data, a certain number of grid nodes 
will coincide exactly with the position of some of the input data points. Where grid 
nodes and data points coincide, the distance between them is zero, so by default 
the data value is assigned a weighting of 1.0 and all other data points in the 
search radius are given a weight value of zero. This means that grid nodes that 
are coincident with input data points are assigned the value of the coincident data 
point rather than an interpolated (averaged) value derived from the data points 
surrounding it. The Exact hit distance defines the distance below which a grid 
node and data point are considered to be coincident.

Note Enabling the Use nearest neighbours option (in the Search Parameters dialog) 
is a simple form of declustering. If the Use nearest neighbours option is 
enabled the Apply density corrections option will be unavailable.
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The process of assigning the input data value to grid a nodes can produce 
significant ‘spotting‘ in the output grid, particularly if the data value of the 
coincident point/grid node deviates significantly from the points surrounding it. By 
adjusting the exact hit distance it is possible to increase the tolerance distance for 
which input data values are assigned to grid nodes. Assigning this value to a high 
number can produce unacceptable spotting or concentric banding in the output 
grid, while reducing the value below 1 has little or no effect.

Kriging Estimation Method

Two types of Kriging estimation are provided; Point and Block. Point Kriging 
estimates a point value at each grid node. Block Kriging on the other hand 
estimates the average value from all points which fall within a rectangular block 
centred on each of the grid node. Because Block Kriging estimates the average 
point value for each block it tends to generate smoother grids. Because Block 
Kriging uses an average of the input sample points in a given region, it is 
considered to be an imperfect interpolator even when an input sample falls 
exactly on a grid node. The Block Kriging method provides controls to decimate 
(or break up) the blocks into a smaller mesh of sub cells, defined by the X, Y and 
Z increment values. When a decimation factor is applied in Block Kriging, the 
value assigned to each block is determined as the average of the sub cells inside 
the block rather than the average of the entire block.

In addition to the point and block estimation types the 3D gridding tool supports 
two Kriging methods; Ordinary and Simple. Ordinary Kriging focuses on the 
spatial correlation component between the measured values but ignores drift (drift 
is a regional trend in the data which exists is addition to spatial correlation 
between samples). Simple Kriging is similar to Ordinary Kriging with the 
exception that the weights used do not sum to unity and the average of the entire 
data set is used in the interpolation of each grid node rather than the local average 
of points that fall within the Search Distance of the node. Consequently, Simple 
Kriging can be less precise than Ordinary Kriging and generally produces 
smoother grids.

Computing a Sample Variogram

Selecting the Variogram button from the Kriging method tab opens the 
Variogram dialog on the Statistics Explorer Tool. This utilises the assigned data 
field in tandem with the spatial coordinates to compute a Sample variogram. A 
variogram shows the degree of correlation between data in a spatial dataset in 
different directions and at different distances.

Search parameters can be saved to and reloaded from a Parameter file 
(parameter files are assigned the file extension .e3g) using the Load and Save 
options under the Auto button.
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Computing a sample variogram is a laborious task and can take a very long time 
as the number of samples increases. In order to construct a variogram it is first 
necessary to compute the distances between every possible pair of points in the 
dataset. In most cases it will be impractical to do this unless the dataset is 
relatively small (< 30,000 samples).  In order to speed up sample variogram 
calculations, several restrictions are imposed. These are:

• Capping the maximum range (distance between points) that will be 
considered.

• Capping the number of input samples that will be considered.

Display of the calculated variogram
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A default variogram is computed using parameters that should ensure that the 
computation time is of the order of a few seconds. Thereafter, the range and 
maximum number of samples being considered can be modified and the 
variogram recomputed by clicking the Recompute Variogram button. Note that 
if the maximum number of samples is set to negative one (-1), then all samples in 
the dataset will be used to compute the sample variogram.

It is not advisable to include all samples in the data set if it exceeds 30,000 
samples as the computation time required to build the variogram could be 
extremely long. If the number of samples is restricted, the algorithm will look at a 
sub-set of samples that are evenly distributed spatially within the dataset. In some 
cases it may be desirable to increase the range and increase the maximum 
number of samples to improve the statistical reliability of the variogram.

Once computed, the sample variogram is plotted in the left lower corner of the 
Statistics Explorers Sample dialog as a radial grid. The default display is the 
Moment of Inertia (or semivariance). The moment of inertia is defined as half the 
average squared difference between the x and y coordinates of each pair of 
points. This is equivalent to the spread (separation distance) of the lagged points 
from the 45 degree line (1 to 1) on a h-scatter plot. A directional variogram is 
extracted from this grid and is plotted in graphical format on the right of the dialog. 
The source data is shown in a spreadsheet at the top of the dialog. The red 
wedges represent the area of the grid that is used to extract the directional 
variogram. This volume is controlled via Direction (0 to 360 degree clockwise 
from North), Plunge (-90 to 90 degrees via the control adjacent to the Direction 
control) and Width (degrees of arc) controls. If the width is set to 180 degrees 
then direction is ignored and an omni-directional variogram is extracted. 
Otherwise a direction-dependent variogram is extracted. The variogram records 
several parameters including the moment of inertia (semi-variogram), covariance 
and pair count.

The 3D preview is a spatial representation of the statistical measures of the 
dataset (it’s a 3D semivariogram grid). It has X (red), Y (green) and vertical (blue) 
axes indicators to show orientation in Cartesian space. In the 3D preview you can 
choose to display ‘moment of inertia’, ‘covariance’ or ‘sample count’. The colours 
represent the values of the chosen statistic in 3D space. It uses a linear colour 
stretch over a HSL Blue-Red colour scale. The radius of the sphere corresponds 
to the range. The colour at any point in space represents the chosen statistical 
measure value of data pairs that have that separation in that direction. For many 
datasets you will often see much of the sphere is blank as there are no data pairs 
in that direction at that range. The 3D view is intended to help you identify the 
dominant directions of correlation in your dataset. Depending on the dataset it 
may not be particularly helpful and you may only want to look at the isotropic 
variogram. However for other datasets the anisotropy of the correlation can be 
clearly seen in the 3D sphere.
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The extraction plane is the intersecting statistic values from the 3D sphere 
displayed opaquely on the plane. All other value are displayed semi-
transparently. It is designed to help you see the dominant directions of correlation 
in your dataset. The 2D graph of the semi-variogram is derived from the 
variogram grid by extracting data in a particular direction over an angular range. 
This is shown as the pair of red tetrahedrons in the 3D preview. The data that falls 
within the tetrahedrons is averaged by range and displayed as a graph. If you 
choose an angular range of 180 degrees then you get the isotropic semi-
variogram which averages all the data over the range.

Defining a Model Variogram

Once the Sample variogram has been computed a Model Variogram can be 
constructed or edited using the Model tab on the Statistics Explorers 
Variogram dialog. The model variogram will be automatically initialised to a 
default linear model with a nugget to fit the data. You can click the Initialise 
Model button at any time to reset the model to this default.

The model is plotted to a range controlled via the Range edit parameter. By 
default this is equal to the sample variogram range.

The model variogram is displayed as a grid and also as a directional extraction – 
just like the sample variogram. The sample variogram curve can be plotted for 
comparison. In the upper right corner of the Model dialog the model variogram 
nests are displayed. Each nest corresponds to an individual component of the 
model. Individual nests can be edited, added, cloned and deleted via the buttons 
on the right or by double clicking on a nest in the list. The final variogram model 
is generated from the accumulated nests.

The basic parameters of each nest can be altered directly from the ‘model’ graph. 
To do so select the appropriate nest from the list of models at the top of the dialog 
and then adjust the parameters by moving the blue edit (triangle) tags on the 
variogram graph.
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The Model dialog of the Statistics Explorer showing three individual nests of a model 
variogram. The top portion of the dialog lists the type and parameters of each nest and the 
corresponding plot at the bottom shows the selected nest graphically.

Editing a nest in the model presents the following Edit Variogram Nest dialog. If 
a new nest is added the dialog is presented in a wizard mode rather than a tabbed 
mode.
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Edit Variogram Nest dialog showing the various Model Types that are available

The Model Type tab allows you to select an appropriate theoretical model to use 
as the basis of the nest. A graph is displayed on the Model Type tab to show the 
selected function. The coordinates used in the example graph are theoretical and 
are not representative of the actual model coordinates.
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Controlling the parameters of the variogram

The Parameters tab provides controls for editing the model parameters. At the 
top right of the dialog is a selection control for switching between the available 
model types. The graph below it shows the sample variogram, the model 
variogram excluding the current nest you are editing or adding, the currently 
selected nest and the final model variogram including the current nest. The model 
parameters are presented below the graph and can be edited directly. Most of the 
model parameters can also be adjusted graphically by dragging the blue 
triangular handles that are presented on the graph axes. For example, when a 
spherical model is selected the left vertical (Y) axes handle allows the editing of 
the sill and the bottom horizontal (X) axis handle allows the range to be edited.



480 Encom Discover 3D User Guide

The sample variogram grid is displayed in the bottom left corner of the dialog. The 
view direction for the grid can be changed by clicking on the plot and dragging the 
cursor to spin the view in 3D. Changing the view direction of model variogram grid 
does not change the direction parameters used to extract the model variogram. 
The grid graph rotation and spin controls are provided for visualisation purposes 
only. Note that the width of the extraction is equal to the width of the extraction on 
the main Sample tab and cannot be modified here.

Editing the variogram nest

The Anisotropy page controls the range of the model along three axes – the 
Primary, Minor and Depth axes. A preview of the currently selected nest is 
shown on the left, whilst the final model preview is shown on the right of the 
dialog. 

The default Primary Axis range is equal to the range established on the 
Parameters tab. The Minor and Depth Axis ranges are used to introduce 
anisotropy into the model. If the minor and depth axes ranges are set equal to the 
primary axis range then the model is isotropic. 
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Advanced Gridding Properties

Load entire hole length: when disabled, Discover 3D will only use that portion 
of the hole that has valid data. As NULL values can be converted to background 
and used to constrain the gridding (see Data Conditioning), this option is enabled 
by default.

Segment break length: used when loading drillhole data and the From-to 
segment option is enabled (see Input Data Specification). Each segment is sub-
sampled so that there is a point location along the segment every specified unit 
of distance. This can be used to speed up the distance to data gridding method 
and to return more accurate point density grids.

Default numeric null: allows user-definition of the global null value for the input 
X, Y, Z and data fields. 

Default text null: allows user-definition of the global null string for input string/
character fields; only applicable when using Discretised Gridding.

Convolution Filtering

Grids>Voxel Filter

Basic filter properties include:

Advanced Gridding properties can be accessed via the Properties button on 
the Voxel Toolkit main window. 

The Convolution filtering function on the Voxel Toolkit main menu allows one 
or more 3D filters to be applied to a 3D grid.

The tool enables you to load/import and unload grids from the top grid manager 
(using the Load and Unload Grid buttons (shown left)).

Filters can then be applied by clicking the Add filter button.  Multiple filters can 
be applied to the grid in a user-specified order. The filter properties are 
accessible via the Filter button in the Filter column. Ensure the target grid is 
highlighted prior to clicking OK.
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• Data honouring - When used, grid nodes that are ‘close’ to a known data 
point will not be modified by the filter operation. Currently a distance grid is 
used to measure the ‘closeness’ of a node to the input data. The distance 
grid can easily be generated using the 3D gridding tool.

• Result - Either the convolved or residual result can be output.

• Iterations - You can apply the filter one or more times.

Convolution filtering applied to a selected 3D grid

Voxel Utilities

Grids>Voxel Utilities

Discover 3D provides a range of powerful Voxel Utilities, from simple voxel cell 
size resampling through to advanced analytics and calculations between voxels 
and polyhedron volumes. 

This functionality can aid in determining the average voxel cell value (e.g. gold 
grade) within a user-modelled polyhedron volume, allowing simple resource 
calculations;  clip a voxel to a mineralisation  volume's extents or interpolated 
unconformity surface; or convert lithological vector volumes into a voxel model of 
densities.
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 These utilities are accessible via the Grids>Voxel Utilities menu option in the 
3D application:

Assign Values to Features

For example, this can be used for calculating the average gold grade of a number 
of wireframed supergene volumes from their contained cell values of an 
encompassing voxel model.

Requirements:

• A voxel model (preferably open in Discover 3D).

• A feature database open in Discover 3D containing either point or solid 
(polyhedron volumes) objects only.

• Assign Values to Features – Attribute multiple feature objects with any 
coincident voxel cell values.

• Clip to Surface – Clip a voxel model with a surface, producing two output 
voxel models.

• Clip to Vector Volume – Clip a voxel model to one or more vector 
volumes, producing two output voxel models.

• Convert Nulls – This utility converts the NULL value in the input voxel 
model to a specified value.

• Convert Vector to Voxel – Convert one or more polyhedron volumes into 
a voxel model.

• Create Mesh – Create a blank voxel mesh, either from an existing voxel 
model or via user-specified parameters.

• Merge – Merge two or more voxel models into a single multi-banded 
voxel model.

• Resample – Resample and/or resize an existing voxel model into a new 
voxel mode

Attribute multiple feature objects with the statistical aggregation of any 
coincident (for feature points) or contained (for polyhedorn volumes) voxel cells. 
The following statistical calculations are available for polyhedrons: Mean, 
Minimum, Maximum and Sum.
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To assign values from a voxel model to a features database:

1. Open the source voxel model and coincident feature database into 
Discover 3D.

2. From the Grids>Voxel Utilities menu, select Assign Values to 
Features.

3. Select the source voxel model in the File Selection dialog and press 
Next. If not already open, a voxel model can also be loaded into Discover 
3D via the browse button at the top right of this dialog.

4. In the Assign Values to Features dialog, select the Feature database 
that values will be assigned to.

5. Select the fields in the feature database to be attributed:

• For multi-banded voxel models, select the Voxel field.

• For polyhedron feature datasets, under Assign variable, select the 
desired fields to attribute with any of the Mean, Minimum, Maximum 
or Sum operations. If an appropriate field does not exist, use the 
adjacent New Field button to add and name new numeric fields.

Polyhedron volume feature datasets can be attributed from only 
numeric voxel models.

• For point feature datasets, use the Assign value pull down to set 
the target field for coincident cell numeric or text attributes. If an 
appropriate field does not exist, use the adjacent New Field button 
to add and name a new field.

Point feature datasets can be attributed from either numeric or 
lithological voxel models.

6. Select the desired Test rule and Acceptance test (if appropriate)  (see 
Volume Selection Method) and press Finish.

When processing has finished, open the Feature Data Window, and select the 
target feature database selected in step 4. Note the selected fields have now 
been statistically attributed.

Note Feature datasets with mixed object types, or any invalid object types such as 
polylines, polygons and surfaces will be rejected.
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Clip to Surface

This could be used to restrict an interpolated downhole-copper voxel model to the 
volume below an unconformity surface.

Requirements:

• A voxel model (preferably open in Discover 3D).

• A gridded surface or a feature database (preferably open in Discover 3D) 
containing a single surface.

• The extents of the surface (perpendicular to the intersection direction) 
must fully encompass the extents of the voxel model in the direction

• The surface must fully truncate the voxel model

• If using a feature database, it must contain only a single surface object. 
Feature databases with any other feature type, or multiple objects, will be 
rejected.

To clip a voxel model with a feature surface:

1. Open the voxel model in Discover 3D.

2. Open the feature database in Discover 3D.

3. From the Grids>Voxel Utilities menu, select Clip to Surface.

4. Select the voxel model in the File Selection dialog and click Next. If not 
already open, a voxel model can also be loaded into Discover 3D via the 
browse button at the top right of this dialog.

5. In the Clip to Surface dialog, select the appropriate feature database 
from the Use an open feature database option. 

Note Attributable feature database fields (such as MaxCu, MeanCu or Lithology) can 
be pre-added to the database (use the Features>Modify tool) or added from 
within this utility.

Cut a voxel model with a surface, producing two output voxel models (one either 
side of the surface). The clipping surface can be either a triangulated feature 
surface (e.g. a fault plane), or a 2D gridded surface (e.g. DEM topographic grid).



6. Set the Intersection direction. This controls the 'ray' or 'hit' test direction 
for each voxel cell to the feature surface, with options for testing along 
either the X, Y or Z axis directions. 

This should be as close to perpendicular to the plane of the feature 
surface as possible. For instance, a relatively horizontal unconformity 
surface would be best tested against with a Z axis intersection direction, 
whilst a near vertical fault surface orientated north-south would require an 
X axis intersection direction.

7. This will generate two voxel models; the locations and names of these can 
be altered at the bottom of the dialog. The user can elect to prevent the 
generation of either output grid via the check boxes. Press Finish to run 
the clipping process.

To clip a voxel model with a gridded surface:

1. Open the voxel model in Discover 3D

2. From the Grids>Voxel Utilities menu, select Clip to Surface.

3. Select the voxel model in the File Selection dialog and press Next. If not 
already open, a voxel model can also be loaded into Discover 3D via the 
browse button at the top right of this dialog.

4. In the Clip to Surface dialog, select the Use DEM surface option. 
Browse for the gridded surface via the adjacent Open button. If using a 
multiple-banded grid, also select the band from the Band pull-down list

5. Set the Intersection direction. This controls the 'ray' or 'hit' test direction 
for each voxel cell to the feature surface, with options for testing along 
either the X, Y or Z axis directions. 

This should be as close to perpendicular to the plane of the feature 
surface as possible. For instance, a relatively horizontal unconformity 
surface would be best tested against with a Z axis intersection direction, 
whilst a near vertical fault surface orientated north-south would require an 
X axis intersection direction.

Note The intersection/hit test is performed on the cell centres only.

Note The intersection/hit test is performed on the cell centres only.



18 Creating and Manipulating Voxel Models 487

6. This will generate two voxel models; the locations and names of these can 
be altered at the bottom of the dialog. The user can elect to prevent the 
generation of either output grid via the check boxes. Press Finish to run 
the clipping process.

Clip to Vector Volume

This is an excellent means of visualising/restricting a voxel model to only those 
portions within a wireframed mineralisation volume/s, perhaps as a precursor to 
using the Assign Values to Features tool.

Requirements:

• A voxel model (preferably open in Discover 3D) and 

• A feature database volume or volumes open in Discover 3D or one or 
more 3D volume third-party vector files (eg AutoCAD DXF)

To clip a voxel model with a vector volume:

1. Open the source voxel model.

2. If using a feature volume, open the coincident feature database in 
Discover 3D.

3. From the Grids>Voxel Utilities menu, select Clip to Vector.

4. Select the source voxel model in the File Selection dialog and press 
Next. If not already open, a voxel model can also be loaded into Discover 
3D via the browse button at the top right of this dialog.

5. In the Clip to Vector dialog, choose one of:

• Use a feature dataset and then select the feature database 
containing the polyhedron volume/s from the pull-down list.

• Use a 3D vector file and then use the adjacent Browse button to 
select one or more vector files.

Clip a voxel model to one or more vector volumes, producing two output voxel 
models. This functionality supports both feature database polyhedrons as well 
as 3rd-party vector formats such as AutoCAD (.DXF) volumes.

Note Only polyhedron volumes (i.e. 'solids') will be processed; any other object types 
will be ignored in the input feature dataset or vector files will be ignored.
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6. Select the appropriate Test rule and Acceptance test (if appropriate); 
see Volume Selection Method for more information.

7. This process will generate two output voxel models, one with valid cells 
within the clipping volumes, and the second with valid cells external to the 
clipping volumes. Change the voxel names and output location if desired, 
and press Finish. 

Convert Nulls

Convert Vector to Voxel

This allows the conversion of a polyhedron volumes into voxel regions of constant 
values, perhaps  as a precursor for more advanced voxel processing/calculations 
such as using the Voxel Calculator. For instance, convert a series of modelled 
lithogical wireframe volumes into a voxel model of appropriate specific gravities, 
allowing further processing against a gold grade voxel to calculate basic resource 
estimates.

The Convert Vector to Voxel tool also supports Encom ModelVision TKM 
models. 

Requirements:

• A feature database with one or more polyhedron volumes open in 
Discover 3D, or

• One or more third-party 3D vector files (eg AutoCAD DXF) containing 
volumes to be selected by the user.

To convert vector volumes to voxels:

1. If using a feature volume, open the feature database into Discover 3D

2. From the Grids>Voxel Utilities menu, select Convert Vector to Voxel.

This utility converts the NULL value in the input voxel model to a specified value 
(e.g. a different null value). Existing NULL values will be converted.

Convert one or more polyhedron volumes into a voxel model. This utility 
supports volumes in either a feature database or multiple input vector files (e.g. 
DXF and TKM). Output voxel values can be sourced from a feature database 
field, or set via a single global value. 
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3. In the Convert Vector to Voxel dialog, choose one of:

• Use an open feature database and then select the feature 
database containing the polyhedron volume/s from the pull-down 
list or

• Use vector files and then use the adjacent Browse button to select 
one or more vector files.

4. Select the value/s to assign to the resulting output voxel:

• Individually per polyhedron volume (feature objects only): 
Enable the Select data fields tick box, and select the numeric 
feature field to populate the voxel model from. Determination of 
overlapping volumes voxel cells can be handled via a range of Cell 
overlap rules (such as average, minimum, maximum, etc)

• Globally (both feature databases and third-party 3D vector files): 
Set the Global value parameter at the bottom left of the dialog.

5. Select the appropriate Test rule and Acceptance test (if appropriate); 
see Volume Selection Method for more information.

6. Press Next.

7. In the following dialog, select one of:

• Create a new grid with the XYZ extents of the input polyhedron 
volumes (recommended)

• Copy the extents of an existing grid

8. Press Finish. 

Encom ModelVision TKM models

Selecting files of this type will ignore any global value assigned, and instead use 
the TKM files internal attributes (if they exist), in the following order, generating a 
multi-banded voxel model:

• Susceptibility 

Note Only polyhedron volumes (i.e. 'solids') will be processed; any other object types 
will be ignored in the input feature dataset or vector files will be ignored.
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• Density 

• Remanence - Q Ratio 

• Remanence - Magnetization 

• Remanence - Azimuth 

• Remanence - Dip 

Create Mesh

Merge

The output merged grid is a multi-banded voxel, with one band per input voxel. 
Band visualisation can be controlled via the pull-down list in the COlour tab of the 
Voxel Properties dialog (see Changing Voxel Model Display Properties ). 

Requirements:

• Open the utility from the Grids>Voxel Utilities menu

• Select the voxel models to merge and press Finish.

Resample

Volume Selection Method

All utilities involving processing between feature objects and voxel models need 
to determine whether a voxel cell is within the feature volume or not. The accuracy 
and speed of this calculation is controlled via the Test Rule and related 
Acceptance Test options. 

Create a blank voxel mesh, either from an existing voxel model or via user-
specified parameters.

Merge two or more voxel models into a single multi-banded voxel model. All 
input bands are preserved and all cell boundaries are preserved without 
interpolation.

Resample and/or resize an existing voxel model into a new voxel model; a 
number of interpolation options are available.
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In general, the more accurate the method chosen, the more iterations/tests that 
need to be performed, and therefore the slower the processing time.

Test Rule

Four  levels of density testing are available for determination of whether a voxel 
cell is within a polyhedron volume:

• Test centre: Only the voxel cell centre position is evaluated. Fastest but 
least accurate method.
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• Test volume – low accuracy: Each voxel cell is subdivided into 8 regions 
(2X x 2Y x 2Z) and the centre position of each of these is evaluated

• Test volume – medium accuracy: Each voxel cell is subdivided into 27 
regions (3X x 3Y x 3Z) and the centre position of each of these is 
evaluated.
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• Test volume – High Accuracy: Each voxel cell is subdivided into 64 
regions (4X x 4Y x 4Z) and the centre position of each of these is 
evaluated (i.e. slowest but most accurate method)

Acceptance Test

If any of the Test volume options are selected, a range of Acceptance tests are 
enabled. These allow the user to specify how many of the subdivided regions 
(samples) need to be within the volume for the voxel cell to be accepted:

• One or more samples within the volume: Fastest but least accurate 
method.



• >= 50% of the samples within the volume: Medium accuracy.

• All samples within the volume: Slowest but most accurate method.

Voxel Calculator

Grids>Voxel Calculator

The Voxel Calculator is a powerful tool for modifying voxel models. To operate 
the calculator, build an expression using the following syntax:

NewName = exp<Name1>…exp<Name2>

The syntax is fully described in Voxel Calculator Syntax.
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3D Grid Calculator dialog

The calculator uses the grid names as arguments for the expression. These grid 
names are shown in the grid list and are assigned a default when the grid is 
loaded, saved or created. To ensure that the names are easy to use and are not 
too verbose, you can edit the name at any time by double clicking on it and 
overtyping the original name. Note that this does not affect the grid file on disk and 
is only stored locally.

The calculator can employ a full range of mathematical, scientific and Boolean 
operations. Use the Load and Save buttons to the right of the expression text to 
retrieve and store expressions for easy reuse.

The calculator recognises NULL values in the input grids. At any cell, if any of the 
input values are NULL then the result of the expression will be NULL. You can 
test for NULL values using the Boolean operators and the ‘null’ keyword.

Click Apply to run the calculator on the expression. This creates an output grid 
that is not automatically saved to disk. You can save it manually from the 
calculator or when Import and Export Voxel Models with the Grid Management 
Tool. 



496 Encom Discover 3D User Guide

Click OK to run the calculator on the expression. This creates an output grid which 
you are prompted to immediately save to disk. If you choose to save the grid you 
are then directed to the Display Assistant that displays the new voxel model.

Advanced Calculator Properties

• A super-set of all input meshes.

This option is the default and produces an output grid that fully 
encompasses all the input meshes. The mesh incorporates all the mesh 
boundaries of the original input meshes.

• The intersection of all input meshes.

This alternative can choose to output the area that is the common 
intersection of all the input meshes. In many cases this is a more logical 
choice since unless you implement Boolean operations to prevent it, the 
expression always evaluates to NULL when the target cell is outside one 
or more of the input meshes.

The advanced properties also allow you to control the NULL handling. By default, 
strict NULL handling is tuned off. This means that the outcome of simple 
expressions using the +, - , * and / operators will be valid if one of the operands 
is NULL and it will be equal to the non-NULL operand. If strict null handling is 
turned on, the outcome of any expression where any operand is NULL will be 
NULL. 

Note When a lithology/discretized model is processed with the grid calculator, the 
existing discretized field is automatically converted into a numeric Band 
containing integer values that match the lithology classes. The lithology band in 
the output model will be reset to the 32-bin histogram that a model with no 
lithology/discretized information contains.

Advanced calculator properties are accessed via the Properties button on the 
Voxel Toolkit main menu. This allows you to control the output mesh size. There 
are two options:
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Display Assistant

Grids>Display Assistant

Display Assistant dialog with two voxel model files selected

The Display Assistant dialog allows you to do most of the basic display functions 
of voxels within Discover 3D. You can:

• Create a chair display by selecting the section of the model to be clipped 
from a drop-down menu,

• Display the voxel model with slices (not available for isosurface displays), 
and

The Display Assistant allows direct access to voxel model displays within 
Discover 3D.
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• Have the voxel model display in Voxel, Threshold or Isosurface format. 
The Threshold and Isosurface styles use a slider bar to control the 
property threshold to remove or display.

For greater and more precise control over a displayed voxel model, refer to the 
descriptions of the various properties in Changing Voxel Model Display 
Properties.

Specify the input data file

If the cell extent is specified it can also be loaded. Otherwise you can specify a 
constant cell size or no known cell size. In the latter case all cell boundaries are 
detected and the import is assumes that the cells lie between the imported 
boundaries.



18 Creating and Manipulating Voxel Models 499

Specify the East, North and Vertical fields plus any sizes of cells known

Finally, you can specify one or more data fields which are each saved as a band 
in the 3D grid. Note only the Encom 3D Grid format can support multi-banded 3D 
grids.

Specify the data fields to read for the gridding
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Grid Management

Grids>Voxel Manager

The Grid Management tool for opening, loading and saving 3D grids

The program uses a grid management scheme that only loads grids into memory 
when they are required. The Status icon in the list indicates whether a grid is on 
disk, in memory (saved) or in memory (unsaved). Grids that are on disk or in 
memory (saved) can be safely unloaded. This does not modify the grid file on 
disk.

The Voxel Management tool enables you to load, import, save, export and 
unload voxel models.
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The Voxel Manager tool can load the same grid formats as are available in the 
Voxel Properties dialog via the Load Model Wizard option (see Using the Load 
Model Wizard).

The information button allows the properties of an Encom3D grid file (native voxel 
format) to be edited. This allows the grid's registration to be shifted, as well as a 
rotation applied.

Importing ASCII Voxel Models

The ASCII Import tool can import delimited ASCII block model data (e.g. comma, 
tab or space delimited) as a standard Encom3D voxel model. The Encom3D 
format supports variable cell sizes and multiple bands, non-continuous and 
rotated models.

ASCII file format

• The ASCII file can contain multiple header lines or have no header lines; if 
a header line is present it can be used to assign field names. If no header 
line is specified (by setting the header line to line 0) then the fields are 
referred to using column numbers where the first column is column 1.

• The ASCII data XYZ coordinates can be either centred or non-centred.

• Block model cell sizes can be:

• contained in the ASCII file for any of the X, Y and Z axes

• a user-specified constant value for each axis

• automatically calcualted by the import tool

Note The Voxel Manager tool can import and convert any generic formatted ASCII file 
to a standard Encom3D grid format, which then can be loaded. See Importing 
ASCII Voxel Models.

The tool can also save or export grids. Grids can be saved in UBC and Encom 
3D formats.

Grids can be exported to ASCII file in either a simple delimited XYZ Data,Data… 
format where the coordinate is the centre of the cell or to a XYZ NX NY NZ 
Data,Data… format where the coordinate is the origin of the cell and the cell 
dimensions are specified. You can also export to an Encom ModelVision TKM 
file.
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• Any missing cells from the ASCII file will be automatically assigned as Null 
values, to ensure the model is contiguous.

To import an ASCII Voxel Model file

1. In Discover 3D, select the Grids>Voxel Manager menu option.

2. Select the Open file button.

3. From the Format list, select ASCII Import and click Next.

4. Select the Open file button and navigate to the input ASCII file.

5. If there is a header present in the file, alter the Header Line number until 
the column titles appear in the preview area at the bottom of the dialog. If 
there is no header line, set this to 0. Click Next.

6. Check the X, Y &  Z column assignments, and adjust if necessary using 
the Up/Down controls. Set the position type of the XYZ coordinates as 
appropriate. Minimum and Maximum refer to the respective XYZ corner 
coordinates in each cell, while centre refers to the cell centre.
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7. Cell sizes for each of the X, Y & Z dimensions can be set independently 
as:

• Defined: if the ASCII file contains X, Y or Z cell size fields for each 
record, set these fields as  appropriate and select the Defined 
option

• Constant: if a X, Y or Z cell sizes are a knwon constant vlaue, 
enster the value/s as appropriate and set to Constant

• Unknown: If no cell size information is known, set the dimension to 
Unknown

8. If there is a known null data value in the ASCII data, enter this value into 
the NULLString identifier section at the bottom of the dialog. Click Next.

Note A different definition can be set for each or the X, Y, Z axis.

Note A different definition can be used for each axis.
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9. Select each data column used by navigating to the field and clicking Add. 
To remove any data columns form the list, select the field and click the 
Delete button. It is recommended to import only one data field per model, 
rather than multiple fields, to reduce the output block model size and 
optimise 3D rendering/handling. Click Finish once the data field/s have 
been selected.

10. You will be prompted to save the imported grid.

11.  The grid has now been saved to disk. Close the voxel tools.

12. This voxel model can now be opened into Discover 3D by drag and 
dropping the .E3D file, or using the Display>Voxel Model menu option

Note This NULL value is used in each selected data band for the model (excluding the 
XYZ fields). If there is a null value in one column which may conflict with the data 
in another data column, leave this blank or import each data band one at a time 
into separate voxel models.
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19 Modelling Triangulated Surfaces and 
Solids
Discover 3D provides the geoscientist with a powerful suite of modelling 
capabilities. These allow you to convert your 2D and 3D interpretations into fully 
three-dimensional models, such as fault planes, unconformity surfaces, water 
table interfaces, mineralization volumes, alteration haloes, stratigraphic volumes, 
etc. Additionally, these models can be extensively manipulated, refined and 
experimented with, in order to test concepts such as possible mineralisation 
extensions, examine spatial relationships between models, update models with 
new drilling information, etc.

Advanced tools allow analysis between voxel and vector volumes, such as 
assigning the average grade to a wireframed volume from the contained voxel 
cells values, or creating voxel models from solids. Combining these capabilities 
with dynamic geometric statistics for feature objects allows basic resource 
calculations to be performed.

• Modelling Methods and Tools

• Extruding Models from Points, Lines and Polygons

• Wireframing Models from Polylines, Polygons and Surfaces

• Selecting Points Within a 3D Wireframe Model

Modelling Methods and Tools

Extruding Models from Points, Lines and Polygons

Discover 3D's Extrusion Wizard can extrude lines, surfaces and volumes from 
simple objects such as :

• MapInfo vector objects (points, polylines and polygons).

• Feature objects digitized directly in 3D, such as points, polylines and 
polygons snapped to drillhole intervals.

For more information, see Extruding Models from Points, Lines and Polygons.
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Wireframing Models from Polylines, Polygons and Surfaces

The Solid Generator can wireframe between feature polylines, polygons or 
surfaces, to create open triangulated surfaces or closed polyhedron volumes. The 
source feature objects can be created from:

• Importing 2D drillhole section layer (see Viewing Section Layers).

• Digitizing directly in 3D (in particular by snapping to drillhole intercepcts 
(see Creating and Editing Features).

• An extensive range of vector formats can be imported (see Importing Data 
into a Feature Database) as feature objects.

• Gridded surfaces can be imported (see Importing Data into a Feature 
Database) as feature objects.

For more information, see Wireframing Models from Polylines, Polygons and 
Surfaces,

Smoothly Interpolating Models as Gridded Surfaces

Point and polyline feature objects and 3D Point datasets can be smoothly 
interpolated to create realistic surfaces using algorithms such as triangulation, 
inverse distance weighting, etc. The source data may be:

• Digitizing feature objects directly in 3D (in particular by snapping to 
drillhole intercepts (see Creating and Editing Features)

• A vector format imported as feature objects (see Importing Data into a 
Feature Database)

• A MapInfo Professional 2D point dataset visualised in 3D as a 3D Point 
dataset (see Create 3D Points Tool and View Intervals as 3D Points), 
such as a mappable subset of  downhole drillhole data (e.g. unconformity 
intercepts or water table depths).

For more information, see Creating Gridded Surfaces.

Create a Triangulated Mesh Surface (TIN)

All types of vector data imported or digitized in a Feature Database can be used 
to create a triangulated surface (TIN). This is useful for example, point clouds or 
counters, to perform a quick triangulation where interpolation is undesirable (see 
Creating and Editing Features).
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Block or Voxel Modelling

Drillhole and feature point and polyline data can be interpolated mathematically 
to build block or voxel models. Components of these can then be exported for use 
with other models, such as isosurface DXFs.

For more information, see Creating and Manipulating Voxel Models)

Model Editing and Modification

Once models have been created as feature objects, they can be extensively 
modified and/or multi-object operations performed with Discover 3D's Advanced 
Editing Functions. Capabilities include cutting one feature surface or solid with 
another (e.g. truncating an orebody with a fault plane), and elastically reshaping 
regions of a feature surface. 

For example, to convert a 2D drillhole section layer polygon into an accurate 3D 
surface:

1. Import the section layer polygon Viewing Section Layers.

2. Triangulate the polygon to convert it into a feature surface (so its nodes 
can be moved outside the plane of the polygon.

3. Visualise the drillhole project in 3D, enabling colour or thickness 
modulation for the attribute related to the section boundary (eg Cu assays 
or lithology). Make the 3D drillholes Selectable in the Workspace Tree.

4. Turn on Snapping.

5. Make the boundary surface Editable.

6. Enable Elasticity, and change the elasticty type to Sine, with an 
appropriate radius of effect.

7. Select a vertice on the surface, and drag it to snap to an appropriate 
drillhole intercept. Depending on the Elasticity radius, the surrounding 
nodes will also be displaced to conform with the snapped nodes new 
location.
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Extruding Models from Points, Lines and Polygons

The Extrusion Wizard allows you to extend (extrude) the shape of a 2D or 3D 
object (e.g. a polygon or polyline) from a base surface to a second or upper/lower 
surface. This allows meaningful and useful visualisation of various bodies such 
as fault surfaces, mine shafts and workings, vein systems and buildings in three 
dimensions. 

The Extrusion Wizard can be accessed from both the 2D and 3D windows. It can 
operate on objects either within a mapped MapInfo Professional table (or a map 
window selection) or a Feature database (see Digitizing and Managing 3D 
Features). Height information can be specified from fields within the MapInfo 
Professional table/Feature dataset or manually set by the user. The sides of the 
extruded shape can be created as polygonal walls that give the impression of an 
enclosed volume within the extruded outline of the source object(s). 

Fault visualisation from polylines in a MapInfo table using the 3D Extrusion Wizard
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To activate the Extrusion Wizard in MapInfo/Discover (2D):

• Select the Discover 3D>3D Extrusion Wizard in the MapInfo 
Professional interface. In the following dialog, select the table from which 
to create a 3D extrusion. This table should have suitable map object 
outlines such as polygons, closed polylines (eg. contours) or regular 
objects such as rectangles, squares or circles. If the table or selection 
contains point objects the 3D Extrusion Wizard can create three 
dimensional objects such as curtains or vertical bars using point data. 
Click OK. If not already open, 3D window will open.

Extrude in 3D dialog

To activate the Extrusion Wizard in Discover 3D Window:

Using the Extrusion Wizard

Step 1 – Choose Input Data

The first dialog of the Extrusion Wizard allows data source selection. If running 
the wizard from the MapInfo Professional 2D interface, this will be auto-populated 
by the preceding selection dialog (the File option is enabled by default, allowing 
the selection of MapInfo Professional TAB or MIF or ESRI shape files). 

• Select the Extrusion Wizard option from the 3D Utilities menu
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 Step 1 of the Extrusion Wizard configured for a MapInfo Professional TAB source file

If running the wizard from the 3D interface, enable the Feature Dataset option to 
select a data source of this type. Pull-down lists will be displayed allowing the 
selection of the correct database and feature set.

Note The Extrusion Wizard can only utilise a single base RL/Z value per object 
(unless these values are sourced from a grid surface). Therefore, it can only 
correctly extrude Feature databases that are planar and in the XY plane (i.e. the 
horizontal plane).
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Step 1 of the Extrusion Wizard configured for a 3D Feature Database source file

An Enable sub-sampling of input data option is available; this can improve the 
quality of the output extrusion by inserting extra points along any straight edges 
of the source object. 

Step 2 - Set Primary Surface Properties

The Primary Z (or base) value of the objects to be extruded can be specified in 
three ways:

• Primary Z - enter a fixed primary Z value to be applied to the objects to be 
extruded. Note that the elevation uses a positive up sense of height.

• Plus Field Value - use a primary Z value from a field contained within the 
MapInfo Professional table for each map object to be extruded. For 
example, if building base levels were to be used, these could be stored in 
the selected table with a data column called bldg_base or base_RL. The 
values are in metres.

• Plus Grid Value - use a primary Z value calculated from a surface grid for 
each map object to be extruded. For items that you wish to lie on top of a 
topographic surface, use this surface as the base height. The values are 
in metres. Check the Generate flat surface using centre grid line to use 
a constant grid value as the primary Z value.
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You can apply a scaling or add field or grid values to the data values of the base. 
This is useful when attempting to match the elevations of other objects you may 
wish to import into your three dimensional views. The Scale factor is multiplicative 
such that a value of 2 doubles the offset height of the base of the object. To use 
field or grid Base Z values only leave primary Z as 0.

The Generate Primary Surface option will create a base for the extruded object. 
If this option is left unchecked the extruded object will be open at the base. Click 
Next to continue.

Step 2 of the Extrusion Wizard

Step 3 - Set Extruded Surface Properties

The Extruded Z value (or upper surface value) of the objects to be extruded can 
be specified in one of three ways:

• Extruded Z - enter a fixed value of height to be applied to the objects to 
be extruded. Note that the elevation uses a positive up sense of height.

• Plus Field Value - use an extruded Z value from a field contained within 
the MapInfo Professional table for each map object to be extruded. For 
example, if building height levels were to be used, these could be stored in 
the selected table with a data column called bldg_height or height.

Note The Z value units are in the same units as the coordiante system XY units. 
Typically this is metres.
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• Plus Grid Value - use an Extruded Z value calculated from a surface grid 
for each map object to be extruded. The values are in metres. Check the 
Generate flat surface using centre grid line to use a constant grid value as 
the Extruded Z value.

You can apply a scaling or add field or grid values to the data values of the 
Extruded surface. This is useful when attempting to match the elevations of other 
objects you may wish to import into your three dimensional views. The Scale 
factor is multiplicative such that a value of 2 doubles the offset height of the base 
of the object. To use field or grid Extruded Z values only leave Extruded Z as 0.

The height of the upper surface can also be chosen Relative to primary Z (i.e. 
an object height from bottom to top) or in Absolute terms such that the actual 
elevation of the top surface is defined.

The Generate Extruded Surface option is turned off by default. This option will 
create a top for the extruded object. If this option is left unchecked the extruded 
object will be open at the top. Click Next to continue.

Step 3 - Define the upper surface of the extruded objects

Step 4 – Choose Inclination

Ticking the Specify a direction and inclination option allows these parameters 
to be applied to the extruded objects. This allows faults and veins to be displayed 
in their correct structural orientations. Likewise buildings, shafts and pipelines can 
be visualised with a specified tilt angle.
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Bearing and Inclination values can be specified either as fixed/constant values, 
or from appropriate fields in the object table:

1. Specify whether your direction/azimuth measurement is the dip direction, 
or a strike reading (i.e. using the right-hand rule: 90 degrees anti-
clockwise from the dip-direction).

2. Set the direction type (as set in step 1) to be either a fixed value (manually 
enter the value) or a selected numeric field in the table.

3. Specify the inclination as either a constant (user-input) value, or a 
selected numeric field in the table (e.g. dip, plunge, etc). The inclination 
can be set either as measured from the horizontal (0 degrees for a 
horizontal or flat inclination, negative values dip downwards) or from the 
vertical (dips of 90 or -90 will therefore be horizontal).

Step 4 – Specify bearing and inclination parameters

Step 5 – Choose grid compression

This dialog allow the Primary and Extruded grids (if specified in steps 2 and 3) to 
be compressed. It is generally recommended to leave the compression factors at 
their default levels, unless dealing with very large grids (e.g. a very large and 
detailed DEM grid).

Applying compression uses the Tomek algorithm, which variably adjusts to the 
data; this attempts to retain the boundary of the grid, including internal holes. This 
will decrease the processing time required to create the output extruded vector 
file, but may lead to discrepancies between the vector file and the original grid.
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After setting a compression level using the slider bar, press the Compute % 
button to return the actual percentage compression factor to be applied.

Step 6 - Set Appearance

The colour and appearance of individual extruded objects can be controlled by 
the following wizard screen.

Step 6 - Specify the surface properties of the extruded objects

The extruded objects are drawn as 3D DXF objects in the 3D display. Four 
options are provided to allow the colour of the objects to be controlled:

1. From input - the individual objects obtain their colour from the default list 
of standard colours

2. Fixed - all the created objects are of the same colour. Select the required 
colour from the pull-down palette.

3. Cycle through standard DXF colours - apply colours from the 16 
standard colours provided for DXF support 

4. Modulated by Field - individual objects are coloured using the data value 
in the specified field and a selected look-up Colour table. A wide range of 
look-up tables are provided. The field selected must be a numeric field.

If the original data specified for extrusion is points rather than polygons, the point 
data can be extruded as Lines, Tubes, and Square or Triangular prisms.
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By default the Generate Sides option is ticked to create an enclosed object. 

Step 7 - Choose Output File

The Output File screen allows the extruded shapes to be saved as:

• DXF vector file output, or

• Feature dataset output

DXF vector file output

Enabling the File option will create an output DXF vector file utilising the same 
name and directory (default) as the input file. These can be altered using the 
Browse button.

The output file can include Output RGB colours. However, not all DXF-
compatible programs can handle RGB colours within a DXF file. 

The Output File screen configured to generate a DXF Vector file.  

An option is also provided to generate a text report of each output 3D solid’s 
extents, surface area and volume (this only applies to extruded polygons). 
Selecting the Report option in this screen allows the creation of this report as a 
.CSV file in the output file directory.

Press Next to progress to Step 8 (only applicable for DXF output).
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Feature dataset output

Selecting the Feature Dataset option allows the extruded objects to be added to 
either a new or existing Digitizing and Managing 3D Features. These can then be 
edited in 3D using the feature editing tools (see Editing Features).

Either select a feature database already open in 3D from the pull down list, or 
create a new feature database using the new file button to the right.

By default, the extruded objects will Overwrite existing objects in an existing 
feature database.

The Output File screen configured to generate the extruded objects in a feature database.  

If the Finish button is clicked, the extruded objects are created in the defined 
feature database and added to the Discover 3D map window. The Extrusion 
Wizard is then exited.

If the Apply button is clicked, the wizard creates the feature database and 
automatically displays it in the Discover 3D map window but leaves the Extrusion 
Wizard operating. It also activates additional Apply buttons on each of the 
previous wizard screens. This allows the outputted extrusion to be modified by 
using the Back and Next buttons to make changes. To view changes click the 
Apply buttons. The objects are then updated in the Discover 3D map window.

Step 8 - Choose Output Layers

If DXF output was selected in step 7, the extruded 3D DXF objects can be saved 
either:
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• To single layer within the output DXF file by selecting the Default Layer 
option or

• If field is selected from the pull-down list, a separate layer will be created 
in the output DXF for each unique attribute in this field. It is also possible 
to Create a separate DXF file for each of these layers, resulting in an 
output DXF file for each unique attribute in the specified field.

Step 8 of the Extrusion Wizard , configured to create a separate DXF file for each 
group of objects sharing a unique attribute in the Generation field

• If the Finish button is clicked, the extruded objects are created in the 
defined DXF file(s) and added to the Discover 3D map window. The 
Extrusion Wizard is then exited.

• If the Apply button is clicked, the wizard creates the DXF file and 
automatically displays it in the Discover 3D map window but leaves the 
Extrusion Wizard operating. It also activates additional Apply buttons on 
each of the previous wizard screens. This allows the outputted extrusion 
to be modified by using the Back and Next buttons to make changes. To 
view changes click the Apply buttons. The objects are then updated in the 
Discover 3D map window.
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Example of a cityscape created by extruding polygons outlining buildings

Example of stratigraphic modelling using the Extrusion Wizard



520 Encom Discover 3D User Guide

Wireframing Models from Polylines, Polygons and 
Surfaces

The input data for the Solid Generator consists of a variety of feature types. This 
commonly includes:

• Polylines - a series of feature polylines can be wireframed into a feature 
surface. For example a series of polylines snapped to drillhole fault 
intercepts can be used to model this fault surface in 3D.

• Polygons - a series of digitized feature polygons can be wireframed into a 
3D solid. For example, boundaries digitized on a series of 2D drillhole 
cross-sections can converted into a 3D solid connecting these sections.

The 3D Solid Generator is useful for creating triangulated 3D objects, such as an 
ore body, fault or other geological solids (e.g. aquifers); as well as infrastructure 
such as dams or open cut extents. This utility joins across areas between objects 
in the Feature databse (polylines, polygons or surfaces) to produce simple 
triangulated open 3D surfaces (e.g. faults), or closed polyhedral solids (e.g. 
alteration zones or ore bodies).
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• Surfaces - a series of feature surfaces (or triangulated surfaces) can be 
wireframed to create a closed solid. For example, 2 or more separate grid 
surfaces representing the top and bottom of the water table could be 
imported as feature surfaces, then an enclosed volume generated from 
them.

Individual slices of interpreted regions are used to create a solid object DXF

The 3D Solid Generator uses an improved algorithm with the following 
capabilities:

• Ability to handle Feature Objects digitized into a series of planes/sections 
with no dominant axis.

• Automatically detect body bifurcations.

• Automatically detect and build disconnected parts of the solid.

• Ability to handle multiple bodies contained in a single dataset if an 
attribute field is specified by the user.

Note Polygons must be completely closed regions. Triangulated Surfaces  (TINs) 
must be open and continuous - they cannot have internal holes or breaks.
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The 3D Solid Generator’s algorithm can process bifurcating shapes.

To create a 3D solid ore body from digitized 2D section layers:

1. Create the boundaries (see Digitizing Section Vectors) - this can be by 
digitizing in 2D and viewed in 3D, or by digitizing in 3D.

2. Use the 3D Solid Generator to create the 3D solid (see Creating a 
Wireframe Model).

3. If the output is not satisfactory, you may need to add tie lines (see Using 
Tie Lines to Control Wireframing) by digitizing in the cosmetic layer or by 
adjusting the wireframing parameters (see Using Algorithm Parameters to 
Control Wireframing).

To create an enclosed solid from surface grids:

1. Two surface grids may be generated from top and bottom intercept points 
on drillholes. These can then be digitized as points and a 2D surface grid 
created from these. See Creating Gridded Surfaces for more information.

2. Import the surface grids into a Feature database using Features>Import 
(see Importing Data into a Feature Database).

3. Use the 3D Solid Generator to create the 3D solid (see Creating a 
Wireframe Model).

4. If the output is not satisfactory, you may need to add tie lines (see Using 
Tie Lines to Control Wireframing) by digitizing in the cosmetic layer or by 
adjusting the wireframing parameters (see Using Algorithm Parameters to 
Control Wireframing).



19 Modelling Triangulated Surfaces and Solids 523

Digitizing Section Vectors

The source Feature database containing polygons/polylines representing 
interpreted/inferred geological/structural/infrastructure vectors can be created in 
two ways:

• Digitizing Layers in 2D – digitizing into multiple Discover drillhole sections/
plans as Digitized Section Layers. These can then be exported from 
MapInfo/Discover as a Feature Database for use by the Solid Generator.

• Digitizing Sections in 3D -  digitizing directly in the 3D environment into an 
editable Feature Database (either the cosmetic layer or a new database) 
using the tools on the Cursor Plane. 

Digitizing Layers in 2D

For steps and information on digitizing sections in 2D and viewing in these 3D, 
see Viewing Section Layers.

Digitizing Sections in 3D

To digitize vectors directly into the 3D environment ensure that the appropriate 
base datasets are open in 3D (e.g. Drillholes, voxel models, etc). Ensure that the 
Feature database into which the boundaries are to be digitized is editable (either 
the cosmetic layer or a new database). Align the Cursor Plane (using the tools on 
the Cursor Plane) as required and use the Feature drawing tools to digitize the 
appropriate polygon and/or polyline vertices.

The Creating and Editing Features section of the Feature Database chapter 
discusses many of the tools needed for 3D digitizing. In particular, the ability to 
snap to drillhole intervals is a important function.

• Use the keyboard PGUP and PGDN keys to offset the Cursor Plane 
perpendicularly from its existing position, in order to keep digitized 
features parallel.

• Use the User-defined step option to set the distance the PGUP and PGDN 
keys move the Cursor Plane.

• The exact location of the Cursor Plane can be set via the Origin (X, Y and 
Z), Inclination and Bearing controls.

Some digitization tips which are controlled via the Cursor Plane tab of the 
Cursor Plane Properties dialog (see Changing Cursor Plane Properties) are:
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• To limit the amount of existing 3D data visible either side of the Cursor 
Plane (i.e. simulate a 2D section envelope), enable either the Envelope or 
Slice Clipping options.  These enable only a user-defined Slice Width of 
data to be viewed either side (envelope) or behind (slice) the Cursor 
Plane.  This is an excellent way to ensure that interpreted boundaries are 
based only on data within, for example, 50m of the Cursor Plane.

• If digitizing onto georeferenced images (e.g. geophysical profiles), use the 
Bond to Image option on the Cursor Plane.

Creating a Wireframe Model

The 3D Solid Generator is accessed via the 3D Utilities menu within the 3D 
interface. It requires two or more individual Feature Objects (not in the same 
plane) in a single Feature Database in order to create an output model. 

Select the Perpendicular button on the Cursor Plane toolbar to orientate 
the view direction perpendicular to the cursor plane., thereby increasing 
the accuracy of your digitization.

Try enabling the Orthographic view mode (on the Zoom Controls Toolbar) 
to remove object scaling due to distance bias (as occurs in the default 
Perspective view). This will allow accurate object size comparison.

The Ruler tool on the Main Toolbar can be a useful guide to distances, 
bearings and dip angles between objects on the cursor plane.

Note When creating very simple shapes for use by the 3D Solid Generator, it is 
recommended to use more than just the bare minimum on nodes/vertices to 
create the shape (i.e. more than say just 6 or 10 nodes to create a ‘banana’ 
shaped polygon). Solids created out of shapes with too few nodes generally 
result in some ‘ugly’ triangulations (as the 3D Solid Generator has very few 
nodes with which to work), particularly through bends/curves, which are very 
difficult to model satisfactorily without a good distributions of nodes. The 
Refinement control of the Solid Generator can help overcome this problem 
automatically (see the Using Algorithm Parameters to Control Wireframing 
section below) 
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3D Solid Generator dialog

In the 3D Solid Generator dialog, the top Feature pull-down list enables the 
choice of the Feature Dataset containing the source objects (including the 
cosmetic layer). 

The Body ID Field option enables a field in the feature database to be used to 
separate the output into separate bodies/solids. For instance, a series of 2D 
drillhole project section boundaries are created and attributed using the 
Feature_Code field (see Digitizing Layers in 2D above) with “ore body”, 
“supergene” and “south_fault”. The boundaries are exported from 2D as a feature 
dataset. Within the Solid Generator utility the Body ID Field would be set to the 
Feature_Code field, in order to build a separate object for each of the unique 
attributes in this field.

The 3D Solid Generator configured to create separate output bodies (using the Body ID 
Field selector) for each unique attribute in the Feature_Code field of a “FeatureExport” 



dataset. This dataset was created by exporting a Discover drillhole project’s attributed 
section boundaries (Discover 3D>View Section Boundaries).

The 3D Solid Generator supports the optional use of Tie Lines. These allow you 
to control both individual vertex-vertex joins on adjacent objects, as well as the 
overall join order of the source objects. To use tie lines, enable the Tie Lines 
option and specify the feature database containing the tie lines from the adjacent 
pulldown list. See the Using Tie Lines to Control Wireframing section below for 
further information on creating and using tie lines.

An Output file can be either a:

• DXF File by enabling the File option. By default this utilises the same 
name and location as the source file (the cosmetic feature layer is created 
in the Discover 3D temporary directory, as set via the Options dialog (see 
Customising 2D Interface Settings). 

• Feature Dataset. Select the output shapes to be created in an open 
feature database from the pull-down list, or create a new feature database 
using the adjacent Browse button. If adding to an open database, the 
default option is to Overwrite any existing feature objects in the 
database.

If a BodyID field (e.g. Feature_Code) has been specified, the Solid Generator can 
create a separate output file for each unique attribute by enabling the Create 
separate files for each body option.

The Preview window of the dataset can be rotated by holding down the left 
mouse button whilst moving the mouse. Hold down the right mouse button (whilst 
moving the mouse) to alter the zoom level.

A Surface Colour can be set for output solid/s, as well as an End capping style 
(only applicable to closed polyhedral objects). The available end capping styles 
are None, Flat, Point or Smooth; however, selecting None will not produce a 
volume calculation in the output report generated at the bottom of the dialog. For 
most volume calculations a Flat end-capping style is recommended.
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Completed DXF solid with a Flat end capping style previewed in the 3D Solid Generator, 
including surface area and volume calculations in the report screen

Once the 3D Solid Generator dialog has been configured click the Apply button 
to generate the output solid/s. Depending on the number of Feature Objects 
involved, their complexity, and whether a Body ID Field has been specified, this 
may take some time. During processing, lines indicating the drawing/join order 
between Feature Objects are displayed and eventually the solid outlines are 
displayed in the preview screen. 

Either a new Feature or Vector branch will also be displayed in the Workspace 
Tree populated with the output solid (see Working with Vector Data in 3D or 
Changing Feature Display Properties for controlling and altering the solid’s 
display). 

If enabled in the  Output Options, a summary report file will also be generated in 
the output directory, with the suffix "_rpt.txt". This contains information about the 
output model extents, dimensions, area and volume is applicable. It will also 
indicate if any errors were encountered. 

The 3D Solid Generator dialog can be kept open while changes are made to a 
Feature Dataset (see Editing Features), allowing the shape of the input objects 
or tie-lines to be refined prior to reprocessing.

Note A volume cannot be calculated for a solid created from a series of polylines, 
even if the end points of each polyline are coincidental. Volumes can only be 
created for solids created from a series of polygons.
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Output Options

The Output Options dialog controls the following components of the generated 
output solid and their display colour:

• Surface – it is recommended that this option be enabled (default) as it 
creates the surface planes between joined vertices,

• Edges – displays only the linework representing the joins between 
vertices,

• Structure – shows the connections between objects (sections) used to 
interpolate the solid, and

• Diagnostics – contains duplicates of any erroneous/self-intersecting 
facets.

Enable the Create seperate file for each body if a BodyID field (e.g. 
Feature_Code) has been specified, by default the Solid Generator can create a 
separate output file for each unique attribute.

An option to use RGB colours in an output DXF file is available. Note, however, 
that not all DXF-compatible programs can handle RGB colours within a DXF file.

Enable the Dynamically update view option to update the 3D view during solid 
generation (once per facet).

Generate summary report will generate a report containing information about 
the output model extents, dimensions, area and volume is applicable. It will also 
indicate if any errors were encountered.

Automatically open report file will open a pop-up dialog after Apply has been 
pressed, showing the contents of the report.

Using Algorithm Parameters to Control Wireframing

The Algorithm Properties dialog contains a number of advanced functions that 
can help to improve the quality of the output shapes, particularly when applied in 
conjunction with tie-lines (see Using Tie Lines to Control Wireframing).

The Refresh button allows any such changes to be updated in the preview 
window of the dataset within the 3D Solid Generator.
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Compression

Applying compression to an object/shape database reduces the number of 
nodes/vertices utilised by the 3D Solid Generator. This can be useful for dealing 
with high density datasets (e.g. objects with 100’s or 1000’s of nodes/vertices) 
where each object is separated by relatively large distances (with respect to the 
distance between nodes in each object), which would result in very long and thin 
triangular facets being generated.

This option should be used with caution, and only applied when the dataset meets 
the above criteria and processing is very slow and/or generates a large number 
of errors. Generally using a compression value of up to 5 is sufficient: a value of 
1 often solves most issues.

Refinement

The Refinement option allows the user to control the degree to which extra points 
are added to polygon edges in order to produce higher quality triangulations in 
connecting surfaces. 

Note Variable compression uses the Tomek algorithm, which variably adjusts to the 
data. Applying compression will naturally result in not all of the input object 
nodes being utilised in the output triangulation, possibly creating discrepancies 
between the output surfaces and the input shapes. Minimise the compression 
factor applied to reduce this problem.
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A setting of zero (0) results in no new points added to edges. 

A setting of 100 results in points being added to edges to ensure that no edge is 
longer than 10 percent of the longest edge in the original polygon. In this case the 
longest edge will have approximately 10 points inserted.

The control is linear from 0 to 100 and is described in the following formula:

Max. Segment Length % = 100 – (Refinement * 0.9)

The following table shows some example settings and the resulting maximum 
output segment length expressed as a percentage of the maximum input segment 
length for that polygon:

Structure Analysis

The Structure Analysis option will only join objects when there is some degree 
of overlap between the objects on a common plane (default option). Where no 
common plane exists, an averaged plane is calculated between the various object 
planes involved. 

Disabling this option allows the Solid Generator to search laterally (parallel to the 
common section plane) for objects to incorporate into the processing; this will, 
however, increase the processing time of the 3D Solid Generator. The images 
below illustrate this functionality. 

Refinement Maximum 
segment 
length %

0 100

20 82

40 64

60 46

80 28

100 10
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The effect of the Structure Analysis option. Figure 1: three parallel polygons, with the 
intermediate polygon substantially offset along the common plane. Figure 2: With Structure 
Analysis enabled, the intermediate shape is ignored in the solid generation process, as it 
does not overlap with the other two polygons. Figure 3: Disabling the Structure Analysis 
option allows the Solid Generator to find and utilise the intermediate shape.

The lateral search radius utilised (by disabling the Structure Analysis option) 
depends on a number of factors, primarily relating to the distance between the 
object planes. If disabling the Structure Analysis option fails to incorporate 
‘outlying’ objects into the final solid, you will need to create and apply tie-lines (see 
Using Tie Lines to Control Wireframing) to force the source objects to be joined 
in the required order.

Shape Matching

The Shape Matching option will only be applied (if enabled) when the 3D Solid 
Generator detects two or more tie-lines (see Using Tie Lines to Control 
Wireframing). It is recommended to always have this option enabled.

Shape matching is performed on 2D projections of the original objects. The 
algorithm constructs a warping transformation that makes the vertices of the 
projections corresponding to the tie lines’ ends coincide. This transformation 
affects all vertices by moving them closer to the points of exact match and 
improves the edge detection procedure.
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Figure 1: A wire-framed solid dxf (green) created between three polygons without using tie 
lines. Note the poor correlation between peaks and troughs

Figure 2: Tie lines (red) created to control the join of major structures
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Figure 3: The output solid created using tie lines from the previous step, and Shape 
Matching disabled. There is a good correlation between peaks and troughs at tie line 
locations, but it is less robust between these locations.

Figure 4: The output solid with Shape Matching enabled and the tie line input from the 
previous steps. This displays an excellent correlation between peaks and troughs, and 
realistic surface creation elsewhere.

Using Tie Lines to Control Wireframing

Whilst the 3D Solid Generator will generally produce satisfactory results for 
simpler shapes, for more complex shapes you may notice incorrect vertex joins 
occurring. These issues can be resolved via the use of Tie Lines, allowing you to: 

• Manually control/specify multiple individual vertex-vertex joins between 
objects (e.g. significant inflexion points such as splay separations, related 
peaks and troughs, etc).
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• Control the join order of objects in complex datasets, such as those with 
large distances between objects, large lateral offsets between objects, or 
complicated joining orders. 

An example of the use of tie lines to guide solid generation between two different 
shapes is presented below. Each figure portrays the same dataset, viewed from 
different angles.

 
Figure 1: Two adjacent parallel polygons, the left a simple polygon, whilst the right hand 
shape splays into two lenses

Figure 2: The resulting semi-transparent and wireframed dxf solid generated by the 3D 
Solid Generator without using tie lines. Whilst the bottom lens of the right-hand polygon 
has been joined satisfactorily to the left-hand shape, the upper lens on the right hand 
shape has not.



19 Modelling Triangulated Surfaces and Solids 535

Figure 3: The preferred solid would have both these lenses joined to the near end of the 
left-hand shape. Red tie lines have been added indicating the user-required vertex-vertex 
joins between the two objects.

Figure 4: With the original (unsatisfactory) output solid removed, the tie line joins are 
clearer, linking the most prominent inflexion points (troughs and peaks) on the right-hand 
shape with the corresponding vertices on the left-hand polygon.
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Figure 5: The resulting wireframed and semi-transparent solid incorporating the user-
specified tie lines. The twin-lensed shape now clearly joins the left-hand polygon as 
desired. The red tie-lines are displayed for reference.

Before creating tie lines, it is recommended that the source shapes are put 
through the 3D Solid Generator by themselves to see what output is possible, and 
then utilise tie lines to refine this output. Experiment with the following options 
before applying tie lines:

• If the dataset contains multiple shapes relating to different attributes (e.g. 
different alteration haloes, fault sets, etc, ensure that an appropriate 
BodyID field is specified so that each series of shapes is handled 
separately 

• If shapes are offset laterally, try disabling the Structure Analysis option 
under the Algorithm Options button.

Creating Tie Lines

The following points are critical to the correct use of tie lines:

• Tie lines must be placed in a separate feature database to the source 
polygon/polyline objects being joined (commonly the Cosmetic layer is 
used for initial tie line creation, and then saved using the Save Cosmetic 
Features command). 

• Each tie line must be a line, not a polyline (i.e. each tie line must 
comprise of exactly two nodes only). 

• Each end of a tie line must be snapped to a node on a separate object. 

Note Using a tie line dataset may significantly increase the processing time of the 3D 
Solid Generator.
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To create tie-lines:

1. Run the source dataset through the 3D Solid Generator (with and without 
the Structure Analysis option enabled) to visualise the solid output as a 
.DXF. In the 3D window, make this output DXF semi-transparent, and 
enable the wireframe view.

Enabling the wireframe view of a vector file

2. Examine in detail via the wireframe view the various vertex-vertex joins 
created by the 3D Solid Generator algorithm. 

3. Make the Cosmetic Layer editable, and set its line colour to red, with a 
weight of 3 points.
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Setting the line style of the tie lines in the Cosmetic Layer to stand out

4. Make the source object feature database selectable, and perhaps turn off 
the Fill appearance option for the source shapes to more clearly see their 
boundaries.
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The polygon Fill tick box on the Feature Properties dialog (red circle) allows the fill of 
polygons to be disabled, allowing their boundaries to be more clearly visualised when a 
high density of polygons is involved.

6. Rotate the 3D View to encompass the first two nodes (on adjacent 
objects) to be joined. 

8. Repeat steps 6 and 7 for the most prominent vertice joins required.

9. Rerun the 3D Solid Generator, enabling the Tie Lines option and setting 
the Cosmetic Layer as the tie line dataset.

5. Enable the Snap tool.

7. Enable the Create Line tool, and hover the cursor near the first node. 
When the snap beep sounds, click to snap to the point. Move the cursor to 
the second node, and double click when the snap beep sounds to snap to 
this node and finish the line.
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10. Re-examine the output, noting the effect the input tie lines have had on 
the resulting wireframe. If necessary, repeat steps 6-9, adding further tie 
lines to refine the output wireframe.

An example of simple wireframe modelling

Selecting Points Within a 3D Wireframe Model

After you have created a 3D wireframe model that represents an enclosed solid 
area, you can select points from datasets that lie within the bounds of the 3D 
polyhedron volume.

The Clip 3D Points to Vector Volume tool allows you to use a Feature database 
or 3D Vector file to clip and select points object from a Feature Database (see 
Creating and Editing Features) or points dataset (such as one created by 
Discover3D>Create 3D Points or Discover3D>View Intervals as 3D Points).

Note The 3D Solid Generator can be kept open through this entire process. It will 
automatically refresh any changes to the updated source and tie line datasets 
when the Apply button is clicked. To refresh the preview screen in the 3D Solid 
Generator at any time, click the Refresh  button.
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To clip 3D points to vector volume:

1. Open the points feature database or points dataset.

2. Select Tools>Clip 3D Points to Vector volume. The Clip 3D Points to 
Vector Volume dialog is displayed.

3. Under Points Input, select the points feature database or points dataset.

4. Under Vector Volume Input, select the vector volume to clip the points to. 
This can be either a Feature Database or 3D Vector file.

5. Optionally, select a Volume attribute field from the available attributes in 
the selected vector volume. This will be added to the output clipped file. 
This is useful for when there are multiple solid objects that you are clipping 
to.

6. Under Output, select the output file containing the selected points. 
Choose to save as a new Feature database file or a new TAB file.

7. Click Process and the output will be opened in Discover3D window.

Viewing Models in 2D MapInfo/Discover

Once your 3D model is generated, imported or refined, then you able to export or 
import this 3D wireframe vector model, or voxel/block model, into 2D Discover 
sections and Maps.

This can be achieved with the following:

• Voxel models to 2D Discover sections. See Using the Export Model 
Wizard.

• DXF or FDB Vector models to 2D Discover sections. These can be 
imported by the Discover Section Manager. See the Discover User Guide, 
Chapter 18 “Working with Drillholes: Managing Sections and Plans: 
Display 3D Model”.

• 2D Discover section "screenshot" of 3D view. See Creating a Drillhole 
Cross-section Image.

• 2D MapInfo map "screenshot" of 3D view. See Creating an Image Using 
the Cursor Plane.
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20 3D Utilities

Discover 3D Utilities menu.

The Discover 3D Utilities menu provides the following functionality:

• Fly Through Wizard – Create 3D Fly Through animations and AVI movies.

• 3D Solid Generator – Create 3D solid objects and calculate their volume 
from digitized or imported feature objects (e.g. drillhole section or plan 
lithological/ore body boundaries).

• Topology Checker - Analysis tool for 3D vector models. Models with 
incorrect vertex orders can modified, and only layers with closed facets 
exported, allowing error free import into a feature database.

• Transform Vector File – Import and modify the origin, projection and 
scaling of objects in a variety of vector formats. Also allows vector file 
format conversion.

• Batch DXF Transform – Multiple external DXF files can be positioned, 
scaled and rotated using a control table, and combined into one output 
file.

• Combine DXFs – Combine two or more DXF files into single DXF file.

• Extrusion Wizard – Allows certain feature objects to be extruded vertically 
or using strike/dip information. An example of use is for creating 3D fault 
planes from surface traces.
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• 3D Point Symbols – Use the 3D Symbol Generator utility with point data to 
create orientated DXF symbols for display in Discover 3D.

• Drillhole Planner – Allows drillholes to be dynamically positioned and 
targeted in the 3D environment, allowing the geo-scientist to test their 3D 
interpretations/interpolations.

Fly Through Wizard

Discover 3D allows 3D views to be captured for replay using a Fly-Through 
Creation Wizard. An automatic transition between view positions allows the 
playback to be smooth and provide the visual appearance of a ‘movie’. The 
‘flythrough’ effect can follow a predetermined track or a series of joined view 
points with gradual transition between each.

Refer to Creating a Fly-Through Animation for further details.

3D Solid Generator

The 3D Solid Generator is useful for creating interpreted 3D objects such as ore 
body, fault or other geological solids (e.g. aquifers), as well as infrastructure such 
as dams or open cut extents. This utility interpolates between objects in the 
Feature Database (polygons or polylines) to produce simple, open 3D surfaces 
(e.g. faults) or closed polyhedral objects (e.g. alteration zones).

Refer to Modelling Triangulated Surfaces and Solids for further details.

Topology Checker

Discover 3D can check the integrity of 3D vector models prior to import into a 
Feature Database. This is important if advanced feature object editing (see 
Creating and Editing Features) functionality is to be used on the model (such as 
the Combine, Intersect and Erase tools). These tools require a consistent method 
of ordering the vertices of every face and that all surfaces are closed; any gaps 
or incorrectly defined faces in a model will lead to errors.

The Topology Checker utility collates all faces and organises them into closed 
surfaces reporting any that break the rules. It can then correct errors and export 
the intact surfaces as a new DXF file. It has its own 3D visualiser with many 
features to identify and examine anything from the entire model right down to 
individual facets and their coordinates.

The Topology Checker can create an output file which either omits or displays 
incorrect object topology.
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• Using the Topology Checker

• Topology Checker Controls

Using the Topology Checker

The Topology Checker will only need to be run after errors have been detected 
during Importing Data into a Feature Database (e.g. planar or volume surface) 
into a Feature Database. Errors in each surface will be indicated by the following 
Import Warning Report dialog, detailing which triangles or polygon edges are 
unclosed, and which need their vertices reversed. 

Errors reported in the Import Warning Report.

1. If you are intending using the Feature Editing tools on the model, press 
the Cancel Import button, and run the Topology Checker from the 
Utilities menu in the 3D interface.

Note Unclosed edges refer to when there is not an adjacent polygon/triangle facet 
along the edge. Reversing refers to where the order of the nodes around a 
polygon/triangle conflicts with the standard ordering for the file (e.g. clockwise 
vs. counter-clockwise).
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2. Use the Browse button at the top right of the dialog to select the source 
vector model file. The various layers comprising the model will be listed, 
and attributes detailed including whether they are closed, number of 
facets, volumes, areas, etc.

3. The last Export column allows the user to select which of the model’s 
layers will be exported. By default all Closed layers will be enabled for 
export (i.e. unclosed layers will not be exported). This will therefore result 
in new vector file comprised solely of closed layers. Unclosed layers can 
be visualised in the preview area by enabling the Show Unclosed option, 
and setting an appropriate colour.

4. Any layers requiring the Reversing of their vertex order will have this 
applied automatically when the output file is generated.

5. Press the Save button to export the selected layers to a new vector file.

6. Rerun the Feature Database Creation Wizard, using this new vector file as 
the source file.

The Topology Checker dialog
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Topology Checker Controls

The Topology Checker utility is accessed from the Utilities menu in the 
3Dinterface. The Topology Checker dialog that appears consists of the following 
properties:

• Input File - Selects the model file to load into the Topology Checker utility.

• List View - The list view displays all surfaces for the input model. Right 
clicking on the list view will activate a context menu with various options 
on how to sort and select cells with the list view columns.

List View Columns

• Layer - Name of the layer in the input file.

• Surface - The surface number contained in a Layer.

• Show - Show/hide the selected surface.

• # Facets - The number of facets (triangles) composing the mesh for a 
surface.

• Area - The area of the surface.

• Volume - The volume of the surface.

• Closed - Green tick indicates that the surface closed. Blue tick indicates 
the surface is closed but has a negative volume. Red cross indicates that 
the surface is not closed. A surface is closed if all edges of the triangles in 
the surfaces mesh are shared by another triangle in the mesh.

• # Unclosed Edges - The number of edges that are not shared in the 
surface.

• Export - Select which surfaces are to be exported when saving the output 
file.

• Reverse - Indicates that the vertex order of the 3D faces for the selected 
layer is to be reversed. Press the Rev button to execute the reverse 
process for all enabled layers. Any layers requiring vertex reordering to 
facilitate use in Discover 3D will automatically have their vertex order 
reversed when the Save button is pressed.
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Surface Options

• Properties button - The properties button will open the Surface 
Properties dialog for the currently selected surface in the list view. This 
dialog displays a spreadsheet containing the X, Y, and Z coordinate for 
each vertex in each triangle for the surface. Triangles that are not closed, 
that is, have an edge that does not join another triangle are displayed in a 
different colour.

Global Options

• Define each layer in a separate mesh - This control will determine 
whether a defined layer in the input file should be defined in its own mesh 
or whether all layers should be defined in a single mesh. This is done on 
loading the input file.

• Coincident Point Tolerance - Tolerance value that is used to improve the 
mesh by detecting coincident points and reassigning the triangles to use 
the first instance of any repeated point. Set this to -1 for the Topology 
Checker to automatically calculate this value.

• Advanced button - Opens Advanced Options dialog, the option Surface 
Triangles are Counter Clockwise can be toggled. This option will 
reverse the direction a triangles composing a surface will be drawn. The 
reversing of this can be observed by checking the Show Selection 
Normals option. The direction of the Normals arrows indicate direction.

Rendering Options

• Cull reverse facing - Turn on/off display of any back facing triangles in 
the mesh.

• Wireframe - Turn on/off display of the wireframe mesh for the model. The 
colour of the wireframe mesh can be chosen by using the Set button.

• Show Unclosed - If this option is turned on the colour of any triangle 
faces that are not closed, will be overridden with the set colour. The 
override colour can be set using the appropriate Set button.

• Show Selection Bounding Box - Turn on/off the bounding box for the 
model. The bounding box is defined for the currently selected surface in 
the list view.
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• Show Selection Normals - Turn on/off the display of normals for the 
model. The normals are defined for the currently selected surface in the 
list view only. The size of the normals can be modified using the size slider 
control. A normal is defined by the centroid of a triangle in a mesh and the 
perpendicular angle to this facet.

• Transparency - Turn on/off transparency for the model. The percentage 
of transparency can be modified using the appropriate slider control.

3D View Controls

Transform Vector File

The Transform Vector File utility can transform, reproject, and convert a wide 
range of vector file formats. The following input file formats are supported:

Fit view to window - Zooms the view so that the entire model can be seen.

Fit view to bounding box of selected surface - zooms the view so that the 
selected surface is the focus of the view.

Advanced settings for the axes scale - Allows the user to apply individual 
scales to the X, Y and Z axes, as well as defining the position where the user 
wants the view to look at.

Zoom speed - Changes the speed at the which the user can zoom in/out to/from 
the model.

Background colour - Sets the colour of the background window for the 3D 
view.

3D Studio .3DS
AutoCAD .DXF 
Datamine wireframe (point and triangle) .DM
ER Mapper vector .ERV
ESRI shapefiles .SHP
ESRI TIN .ADF
Gemcom .BT2  
GOCAD vector .TS, .PL, .VS
Google Keyhole Markup Language .KML
GPS exchange .GPX
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When converting between file formats (with or without transformation and/or 
reprojection), the following output vector file formats can be created:

LizardTech MrSID .SID
MapInfo Professional .MIF
MapInfo Professional .TAB
Surpac string .STR
Surpac wireframe .DTM , .STR
Vulcan triangulation .00T

AutoCAD .DXF
CSV text file .CSV
Encom .TKM
ESRI shapefiles .SHP
GOCAD vector .TS
Google Keyhole Markup Language .KML
GPS exchange .GPX
MapInfo Professional .MIF
MapInfo Professional .TAB
Surpac string .STR
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The Transform Vector File dialog

A range of Transformation options are available as independent X, Y and Z 
operations, allowing vector objects to be scaled, offset and rotated. 

Transform options available are:

• Transform coordinates – enable the options button for Scale, offset and 
rotation settings. This is useful for converting feet units to metres or 
transforming from a local grid to UTM.

• Convert to 2D, viewed from – converts an appropriate 3D input Vector 
file into a 2D view. It can be viewed from each primary axis direction.

• Reproject coordinates – reprojection applied to coordinates. Note the 
from field is automatically populated with the first input file's projection if it 
found.

• Name field – certain formats only support a single attribute or label field 
for the vector objects. If enabled, select the desired field for labelling the 
points.
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• Elevation field – when converting form a 2D (i.e. TAB file) to a 3D file 
format (i.e. DXF), this field is enabled to define the elevation of the object. 
For example this could be populated by using Surfaces>Assign Grid 
Values from a DEM.

Other processing options include:

• Convert to point cloud – converts all nodes/vertices in the input vector 
object to individual point objects in the output vector file.

• Smooth polylines and polygons – applies a line smoothing filter, with a 
width defined over the nearest nodes.

• Correct polygon vertex order problems – checks the node order in all 
polygon objects. Outer parts will be stored clockwise and inner holes will 
be stored counter-clockwise.

• Compress polylines and polygons – removes any nodes with a spacing 
less than the defined distance.

• Convert closed polylines to polygons – converts any closed polyline 
objects to a polygon object. This is particularly useful for formats such as 
DXF which do not have a polygon object type, but do have closed polyline 
objects.

• Convert polylines with one point to point objects and polygons with 
two points to polylines – removes any erroneous objects.

Vector files can also be Reprojected to accommodate absolute coordinate 
handling in Discover 3D. For instance, if all of your MapInfo data is in a UTM 
projection, but an ore body DXF model from a CAD program is in a different 
projection, this option will enable the DXF to be reprojected into the same 
projection as the rest of the 3D data. Enable the Reproject Coordinates option, 
and set the appropriate Source and Target projections using the Choose 
buttons.

Note The projection list available in the Discover Vector Import utility is stored in a 
separate file to the MapInfow.prj file. If you wish to reporejct into a custom 
coordinate system which has been added to the MapInfow.prj file then copy 
the custom projection line into the Encom.prj file located in the 
...\Program Files\Encom\Common\Projections folder.
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3DS tanker ship models transformed (offset, rotation and scaling) into a 3D session to 
illustrate the scale over a shipping channel dredging project.

To use the Transform Vector File tool:

1. Under Files, select the input file and output file names and locations.

2. If a different output file format is required, select the format from the 
Output format box.

3. To explicitly position, scale and/or rotate the input file, select the 
Transform coordinates option, and specify the appropriate parameters.

4. If converting into a 2D vector file format (e.g. a TAB), enable the Convert 
to 2D option, and specify the desired view direction of the output file 
(default view from the Top).

5. To reproject the input file, enable the Reproject coordinates option, and 
specify the input (From) and output (To) projections. See Projections in 3D 
for more information about reprojecting data.

6. A range of additional advanced transformation options (described above) 
are also available via the Other processing options button.
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Batch DXF Transform

This is a useful way to rapidly populate a 3D environment with multiple individually 
positioned, scaled and rotated vector objects, based on a number of source DXF 
models. An example of this utility’s use would be to create multiple vehicle objects 
from a single automobile DXF model. Similarly if a number of DXF models were 
available (e.g. car, truck and helicopter models), multiples of each model could be 
created.

Multiple cars (behind the truck) in a cityscape produced using the Batch DXF Transform 
utility

This utility requires a Control table (TAB file) with the following attributes:

The Batch DXF Transform utility allows one or more vector models to be 
transformed into a large number of vector objects and placed into the 3D 
window. These vector objects are outputted into a single DXF file.

X (compulsory) The X coordinate of the output object

Y offset (compulsory) The Y coordinate of the output object

Z offset (optional) The Z coordinate of the output object
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Example control table

Batch DXF Transform dialog

Scale (optional) The scale factor to be applied

Rotation (optional) The degree of rotation to be applied 
(positive value are anticlockwise)

File (compulsory) The file path and name of the source 
DXF model

Use the Browse button in the Batch DXF Transform dialog to open the control 
table. This dialog will attempt to automatically populate the various parameters 
based on field names; otherwise use the drop-down menus to assign the various 
fields correctly. If the optional fields are not present in the control table, they will 
need to be assigned Fixed values by ticking the relevant option to the right, and 
assigning a value.
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Clicking the Transform button will prompt for an output DXF file name and 
location. When this file has been created, it can be opened in the 3D window by 
dragging and dropping from Windows Explorer, or using the Display>3D Vector 
menu option.

Combine DXFs

Combine multiple DXF files.

Click OK. In the following dialog choose a new file name and location for the 
combined DXF file and click Save. The combined DXF file is not automatically 
displayed in the Discover 3D map window. Use the Display>3D Vector or 
Display>2D Vector menu option to display the combined DXF data.

Extrusion Wizard

The Extrusion Wizard allows you to extend (extrude) the shape of a 2D or 3D 
object (e.g. a polygon or polyline) from a base surface to a second or upper/lower 
surface. This allows meaningful and useful visualisation of various bodies such 
as fault surfaces, mine shafts and workings, vein systems and buildings in three 
dimensions.

Refer to Extruding Models from Points, Lines and Polygons for further details.

The Combine DXFs utility enables multiple 3D DXF files to be combined into 
create a single 3D DXF file.

If there are a number of 3D DXF files that are generally opened in Discover 3D 
together, to save having to open each of them separately, a single DXF can be 
created. The DXF files must be in the same directory prior to combining.

On the Combine DXF Files dialog click on the button and browse to the 
directory containing the 3D DXF files to combine. Select all the DXF files to 
combine using the CTRL and SHIFT keys depending on whether they are 
consecutive in the file list.
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3D Point Symbols

The 3D Point Symbols utility can be used with any data table accessed by 
Discover 3D or with an external MapInfo Professional .TAB or .MIF file. The data 
table may be of line or point data type and should contain at a minimum Easting, 
Northing and Elevation or depth fields. For oriented data (eg. Downhole structure 
data), additional fields for Bearing and Inclination can be selected. Discover 3D 
uses these fields to create individually oriented symbols for each data entry.

3D Symbol Generator dialog with oriented data from TAB file

Use the 3D Symbol Generator utility with point data to create orientated DXF 
symbols for display in Discover 3D.
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The following controls are provided:

Input Points

• Load from file - Location and attribute information can be converted to 
point symbols using MapInfo Professional .TAB or .MIF format files. Select 
this option and specify the input file location.

• Read from Discover 3D dataset - If dataset that has been opened 
directly into Discover 3D can be used for symbol creation at each data 
point selected by line.

• Output File - The created symbols are stored in an AutoCAD DXF format 
file. By default the output file is saved using the same name and location 
as the input file with a “_Point3D” extension. The name and location of the 
output file can be modified if required.

• Direction - 3D points can be orientated either via specification of Bearing 
and Inclination fields, or Vector component (u, v, w) fields.

• Fields - Data fields used for location (X and Y) and depth (Z) must be 
selected. The Direction option set (above) will control either Bearing and 
Inclination, or Vector (u, k, w) fields to be assigned.

• Symbols - The Width, Length and Thickness of the 3D symbols created 
can be specified (in scaled metres). The following 3D Shape symbols are 
available:

Triangle
Rectangle
Tabular
Arrow head
Arrow with tail

• A Colour can also be set for the output point symbols. Setting this option 
to Modulated from Field allows each unique attribute in the specified 
Colour field to be coloured according to a selected Colour table.

• If Vector direction fields have been specified (u, v, w), an option to 
Multiply by vector scalar length is available.

• Decimation - Only available when a 3D dataset is being used. Displays 
only every Nth sample/point, where N is a user-specified value. For 
example, specifying 3 with display only every 3rd sample.
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Click Apply to create the 3D symbols. When processing is complete the output 
DXF file is created and the symbols are automatically displayed in Discover 
3D.Surfaces, other vector files, located bitmap images, drillholes, points, lines 
and voxel models can be added to this new 3D window.

Displaying soil geochemical points as .DXF objects using the 3D Symbol Generator

Drillhole Planner

Discover 3D provides the powerful capability to dynamically position and plan 
new drillholes directly within the 3D environment. This allows the user to target 
3D objects such as voxel isosurface grade shells, extruded quartz veins, .DXF 
solids (such as alteration zone volumes generated from digitized section 
boundaries) or feature object interpretations.

Refer to Drillhole Planner for further details.
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21 Creating Images and Movies
Discover 3D includes a range of output options for your 3D views:

• Capturing the 3D View as an Image (.BMP, .PNG, etc) for use externally 
(e.g. PowerPoint presentation).

• Adding the 3D View to a 2D Map Window, for use in a layout Frame 
Object.

• Printing using the Page Layout mode.

• Creating a Geolocated Image, either for use in 3D, or for adding to an 
existing drillhole project section.

• Creating a Fly-Through Animation of your 3D environment.

Capturing the 3D View as an Image

File>Save View As

This allows the current 3D view to be saved as an image at a user-specified 
resolution. A range of output image formats are available, including BMP, JPG, 
PNG, and TIF & EMF. This image is not georeferenced i.e. it is essentially a 
screenshot. These images could be used in a Word or PowerPoint document.

The Save View As dialog allowing output resolution specification

Consider the Orthographic View mode (see 3D Display Modes) for output image 
for technical evaluations (i.e. without the distance distortion of the default 
perspective view).
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Adding the 3D View to a 2D Map Window

View>Send to MapInfo

It is possible to transfer a 3D view back into a new MapInfo Professional mapper 
window. This is a useful function if you wish to have a snapshot of a particular 
display that can be used in a MapInfo Professional layout as a Frame Object (e.g. 
a cross-section layout with a small 3D snapshot to give the drillhole project a 3D 
perspective). 

The transfer creates a bitmap of the Discover 3D screen display with an 
associated non-earth projection TAB file that is then displayed in a new mapper 
in MapInfo Professional.

To transfer a view from Discover 3D to MapInfo Professional:

1. Organise the layers and view position as required in Discover 3D.

2. Select the Add 3D View to MapInfo button or use the View>Add 3D 
View to MapInfo menu option.

3. Return to MapInfo Professional and a new mapper display window should 
open containing the Discover 3D view.

Add 3D View to MapInfo button.

Note The MapInfo Professional mapper view of the Discover 3D display is static and is 
not related in real-time to that of Discover 3D. To modify the view, return to 
Discover 3D, alter the view and repeat the above steps.

The TAB and bitmap files used for the Discover 3D view as displayed in MapInfo 
Professional are stored in the folder defined by the Discover Temp file type 
under the Discover 3D Tools>Options>File Locations tab. The files are named 
with a unique filename.
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Printing

Every aspect of the current 3D view can be printed directly to a printer or plotter 
using the File>Print menu option, with printer and page size options configured 
via the standard File>Page Setup menu option. 

Printer and Rasterize options

Note Discover 3D can use standard Windows drivers directly for printing OR it can use 
a rasterizing option to speed up and produce higher quality printed output. The 
rasterize option is included on the Print dialog and is recommended for routine 
use in printing. It is recommended that a rasterizing level of between 150 and 
200 dpi is optimal for speed and quality.

However professional looking results are better achieved when Discover 3D is in 
Page Layout mode (see 3D Display Modes): this allows the actual output 3D 
display for the currently set page size and orientation to be previewed and 
modified prior to printing.
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The Page Layout view of the current 3D environment.

Within Page Layout mode, the full set of buttons for Navigating in 3D are available 
to precisely position the view within the page frame. Additionally, Discover 3D 
provides a number of controls on the Zoom Controls Toolbar specific to this view 
mode:

The Zoom In and Zoom Out controls allow adjustment of the overall zoom ratio 
of the page display.

The Pan button allows you to pan around the page view, useful when zoomed 
into larger page sizes (e.g. A1).

The Fit to Page button is only available in Page Layout view, and automatically 
resizes the page to fit to the extents of the view.

The 3D View Manager Tool allows the user to save custom views within the 3D 
window.

The Orthographic View mode functions in Page Layout mode (see 3D Display 
Modes), allowing hardcopy production for technical evaluations (i.e. without the 
distance distortion of the default perspective view).
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Customising the Page Layout

The Page Layout view can be fully customised with titles, modified frame colours/
thickness, modified margins, etc via the 3D Map Properties dialog in the 
Workspace Tree. Options include:

• Title -  the Title tab allows the addition of a title string in the Coded Title 
String area with a selected Font. The Horiz and Vert options control the 
Title Position with respect to the 3D window display. The Anchor options 
locate the title locally (this can be fine tuned using the Add Offset 
controls).

• Border – the Appearance tab allows Inner and Outer borders to be 
displayed, with colour, thickness and line style options.

• Background - Data Area and Border (the area between the inner and 
outer borders) colours can be specified in the Appearance tab. The Data 
Area control is the same control as the Background Colour button on the 
Main Toolbar.

• Minimum Plot Margins – these can be set as millimeters recessed from 
the Outer Border position.

The position and size of the 3D view frame inside the page layout can be modified 
by enabling the Select button.

Default and Offline Printer Configuration

The Page Setup Tab of the Tools>Options dialog in the 3D Window allows the 
default printer and page size/orientation to be configured.

It also allows a default offline page size to be set. 

The position and size of the 3D view frame inside the page layout can be 
modified whilst in Select mode. Click on a border of the 3D view frame (the 4 
corner points should display square nodes), and drag either a corner point (to 
resize) or an edge (to move).



566 Encom Discover 3D User Guide

Creating a Geolocated Image

Tools>Georeferenced Image Export

Discover 3D’s Georeferenced Image Export tool allows a geolocated image of 
the Cursor Plane to be created (i.e. a .PNG image with associated Encom 
Georeferenced Bitmap (EGB) Format header file). The image is created 
perpendicular to the cursor plane in Orthographic view mode (see 3D Display 
Modes), and the width/extent of data captured can be controlled by the standard 
cursor plane Clipping options (see Changing Cursor Plane Properties).

This is a powerful way to capture one or more slices through your dataset (e.g. 
voxel models, .DXF solid models) as georeferenced images, for:

• Displaying in other applications (e.g. PowerPoint or Word).

• Efficient display in Discover 3D of more complex and memory-intensive 
datasets (e.g. displaying a voxel model as a series of image slices).

• Exporting to associated Discover drillhole cross-sections for detailed data 
comparison and interpretation (e.g. exporting to each section it’s 
associated envelope through a voxel model).

The Georeferenced Image Export tool can orientate the cursor plane via two 
methods:
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• Creating an Image Using the Cursor Plane: use either the normal 
keyboard controls or individual specification of the necessary parameters 
(origin XYZ, inclination, azimuth).

• Creating a Drillhole Cross-section Image: use an open Cross-section in a 
Discover drillhole project to align the cursor plane.

Creating an Image Using the Cursor Plane

1. Open the Georeferenced Image Export tool (on the Tools menu in 
Discover 3D).

2. Set the ‘Locate image using’ to Cursor Plane Position.

Geolocated Image Export dialog configured to capture the manually positioned 
cursor  plane with a 200m data envelope width
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3. Orientate the cursor plane as required, using either the various parameter 
fields presented in the dialog, or the normal cursor plane keyboard 
controls (see 3D Cursor Keyboard Shortcuts).

4. Set the desired data Clip type from the pulldown list (see Changing Cursor 
Plane Properties). The Envelope and Slice options (with appropriate 
Widths) are generally the most effective options.

5. Press the Preview button. The 3D view will change to orthographic mode 
(see 3D Display Modes), and orientate perpendicular to the cursor plane. 
If the view is on the wrong side of the cursor plane, press the Flip View 
button to swap to the opposite side.

6. If the clipping options are not correct, alter these and repress Preview to 
visualise the result. The Reset button will take the view back prior to being 
perpendicular to the cursor plane, allowing the cursor plane be further 
manipulated. 

7. The output image Format, Resolution and DPI can all be modified. The 
higher the resolution and DPI, the better the quality of the image, but the 
larger the image size (MB).

8. Ensure the Automatically open exported image option is enabled.

9. Specify an output directory and file name using the Browse button at the 
bottom right of the dialog, and press Apply. 

The image will be displayed in the 3D view.

Creating a Drillhole Cross-section Image

1. In MapInfo/Discover, if the drillhole project is not already open, open it with 
Drillholes>Project Manager.

2. Still in MapInfo/Discover, use the Section Manager to open the 
destination cross-sections.

Note This EGB can be imported into Discover using Discover>Import or 
Export>Encom PA located Image Import only if the cursor plane is aligned 
exactly in the XY plane, by pressing the Z key.  This is useful for generated 
surface map top down views of 3D objects.
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In Discover 3D, open the Georeferenced Image Export tool (on the Tools menu)

3. Set the ‘Locate image using’ to Discover Section.

Note Horizontal plans are not supported. They can however be exported using the 
cursor plane method described above and align the cursor plane to the 
horizontal plane by pressing the Z key.
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Selecting a target cross-section from the Geolocated Image Export dialog

4. Choose the required destination Discover Section from the pull-down list.

5. The Clip type will be automatically set to Envelope (see Changing Cursor 
Plane Properties), with the Width set as per the cross-sections envelope 
width.  These can be modified.

6. Press the Preview button. The cursor plane will reorientate to mirror the 
specified cross-section. Simultaneously the 3D view will change to 
orthographic mode (see 3D Display Modes), and orientate to the cross-
section’s view direction (perpendicular to the cursor plane/section).

7. If the clipping options are not correct, alter these and repress Preview to 
visualise the result. The Reset button will take the view back prior to being 
perpendicular to the cursor plane. 
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8. The output image Format, Resolution and DPI can all be modified. The 
higher the resolution and DPI, the better the quality of the image, but the 
larger the image size (MB)

9. The image file will be automatically created in the cross-section or drillhole 
project folder (depending on your project settings) with a name 
sectionname_D3DImage. These can be changed using the Browse 
button at the bottom right of the dialog, and press Apply. 

10. Press Apply. A successful creation message will be displayed. After 
pressing OK, the image will be automatically opened in the section 
mapper window in MapInfo/Discover if the Automatically open exported 
image option is enabled. It will also be displayed in the 3D view if the 
Create companion egb file for Discover section option is enabled.

Creating a Fly-Through Animation

Creation of a 3D Fly-Through Animation is controlled by a wizard that generates 
a script. Within the script are a series of 3D location points that view the display 
with different angles and elevations. Smoothly moving from one position to the 
next creates the animation. 

The 3D Fly-Through Animation track can be specified by:

• MapInfo Professional® .TAB file.

• Flight path specified from data open in Discover 3D.

• Manually specifying various predefined views.

• Edit an existing Fly-Through (.FLY) file.

Other features of the 3D Fly-Through Animation feature include:

• Ability to repeat operation or reverse to replay backwards.

• Smooth view along predefined track using a Bezier curve approximation.

• Control frame rate, flight speed, view pause, view rotate and point 
examination.

Discover 3D allows 3D views to be captured for replay using a Fly-Through 
Creation Wizard. An automatic transition between view positions allows the 
playback to be smooth and provide the visual appearance of a ‘movie’. The ‘fly-
through’ effect can follow a predetermined track or a series of joined view points 
with gradual transition between each.
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• Create 3D DXF file of a created flight track including definable points to 
mark view points.

• Capture fly-through as an Video movie for later viewing. Selection of video 
compression (CODEC) provided.

• Audio identification at set points. These sound effects are heard while a 
script is being replayed through the computer sound system. Sound cues 
such as “Note the surface anomalism coincident with this drilling…” can 
be a useful adjunct to seeing the 3D display replayed. Note that when 
recorded to an Video movie file, the sound is not transferred.

To create a simple 3D animation

1. Ensure the required datasets are open and visible in the 3D window

2. Select the Utilities>Fly Through Wizard menu option

3. In the Fly Through Creation Wizard dialog that opens (Step 1) select the 
Manually from the current Discover 3D view option. Press Next

4. In the Step 3 dialog, ensure that the Loop Style is set to None, and 
Bezier Smoothing is enabled with a Low Tension. Press Next.

6. Use the 3D nVideogation controls to move to the next view point and 
again use the Camera Capture button to capture this location. In this view 
point’s row entry, specify the Duration in seconds the animation will take to 
travel between the previous (start) point and this location. 

7. Repeat step 6 until all required view points have been captured and 
durations entered.

9. Edit the animation by adding, inserting, modifying or deleting the 
necessary view points. These controls and additional are discussed fully 
in The Fly-Through Creation Wizard section below. 

5. In Step 5, use the 3D nVideogation controls (see Navigating in 3D) to 
orientate the 3D view at the starting view for your animation. Press the 
Camera Capture button to capture this – a new row will be added to the 
dialog with this point’s details.

 
8. Play the animation in the 3D window by pressing the Play button. A 

selected number of view points can be previewed using the Preview 
button to the right of the Play button.



21 Creating Images and Movies 573

10. If the overall speed of the animation is too fast, rather than respecifying 
each individual duration, use the Back button to go to the Step 3 – 
Options dialog, and alter the Playback Speed accordingly (e.g. reduce it 
from 1 to 0.5 to double the time taken between each view point).

11. When satisfied with the flight path and durations, press Next to open the 
final Step 5 dialog.

12. Specify an Output FLY file using the adjacent Save button (this file will 
allow you to come back and modify your flight path, add new datasets, 
etc). Also specify the name of an output Video file.

13. Press the Compressor button, and select the compression CODEC to 
use for your output movie (see Step 5 - Output Formats below for further 
details). Once selected, press the Create Video button to generate an 
.Video movie file. The quality of the output movie can be altered by 
adjusting the Frame Rate (i.e. frames per second) in the Step 3 – 
Options dialog.

How Fly-Through Animation Works

A fly-through animation operates by positioning an Eye Point, (also called a 
Capture Point or Position) and directing the view to a Look At point. When 
played back, the view is defined from each Eye Point towards the Look At point 
and then a gradual change of view to the next successive Eye Point to the next 
Look At point. Both point types require an X, Y and Z specification as shown in 
the diagram below:

Flight path of ‘joined’ Capture Points as they direct their view to Look At points
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Each Eye Point can be recorded from a manually positioned location in the 3D 
map display or at interpolated locations from a predefined flight path defined from 
a database or MapInfo Professional TAB file. The Eye Points look directly to their 
associated Look At point and then gradually move and update with the next Eye 
and Look At points during the animation. The movement from one Eye point to 
the next can be smoothed or direct (determined by the Smoothing and Tension 
settings). The speed at which the fly-through travels is dependent on the 
Playback Speed and Flight Speed (see Step 3 - General Playback Options).

Each Eye Point (Capture Point) can have a number of events and properties 
associated with it. An event may be a pause, sound, change of display property 
(eg transparency, application of a different LUT, etc) or a rotation of the view 
about an Eye Point or Look At point.

The individual Eye Points and their associated Look At point, including any 
associated events, are saved to a script file called a FLY file. These files, created 
for a given project area, provide the mechanism to replay the fly-through 
animation as desired.

The Fly-Through Creation Wizard

The following sections describe in detail the controls available within this tool.

Step 1 - Select Input Type

The Fly-Through Wizard can be accessed from the Utilities menu. The Fly-
through Creation Wizard: Step 1 – Input Type dialog is displayed:
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Fly-Through Wizard dialog and options to create a flight path script

A fly-through operates by different views being displayed along a predetermined 
path. The positions of the views are recorded in a script file (FLY file extension).  
The flight path may be specified by one of the four following methods: 

• From a TAB file – MapInfo table that contains XYZ coordinates 
representing the flight path course.

• From Discover 3D Dataset – XYZ coordinates for flight path based on 
values in fields in a Discover 3D dataset.

• Manually from current 3D view – Specify a number of 3D map window 
views to use as Eye and Look At points which are linked together to form 
the flight path.

• Edit Existing Fly-through file – Modify a previously created fly-through 
script file (FLY).

Depending on the flight path generation option selected, a different series of 
dialogs may be displayed.
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Step 2 - Input Parameters

MapInfo TAB File

Select the From a TAB file option and click the Next button. In the Fly-through 
Creation Wizard: Step 2 dialog use the Browse button to locate the appropriate 
MapInfo TAB file. This TAB file must be mappable and contain points, polyline or 
polygon map objects which represent the course the fly-through will follow. The X 
and Y coordinates do not need to be attributes in the browser but if Z values are 
to be used for individual locations there must be appropriate Z field in the flight 
path table.

Select MapInfo table and Z values

Select the Z Field in the table that contains the height or elevation to use in the 
fly-through path. The Z field must be of numeric datatype. A constant value can 
be added to the existing Z values i.e. to convert local RLs to AHD. If there is no Z 
field in the table or all the Eye and Look At points are to viewed from the same 
elevation, check the Flat Height box and manually enter a Z value.

Discover 3D Dataset

Fly-through animations can be created from point or line data open in Discover 
3D. Select the From Discover 3D Dataset option and click the Next button. In 
the Fly-through Creation Wizard: Step 2 dialog use the Dataset pull-down list 
to locate the appropriate 3D dataset and assign the X and Y fields. 
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The Z values may be selected from a Z Field in the dataset or by checking the 
Flat Height box and entering in a constant Z value for all lines.  A constant value 
can be added to the existing Z values i.e. to convert local RLs to AHD.

Select 3D dataset and assign XYZ fields

Manually from Current 3D View

This Fly-Through Wizard option is the simplest to use as the flight-path is 
compiled from a list of Capture Points (Eye and Look At points) which are 
specified by rotating and zooming to different views in the current Discover 3D 
map window. The Capture Points are then displayed in the capture order to 
simulate the flight-path. There are no additional setup parameters for this option.

Edit Existing Fly-Through File

To load an existing fly-through file (FLY) into the Fly-through Wizard select the 
Edit Existing Fly-Through File option. In the Fly-Through Creation Wizard: 
Step 2 dialog browse to an existing (FLY) script file. 

The (FLY) script file specifies the flight path and the general playback and 
recording options including capture point information. 

Note If you use a script file with flight path capture points which are for a region that is 
not in the same area as the displayed in the 3D map window, when you play 
back the script, no image animation will be seen.
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Step 3 - General Playback Options

General playback and flight path options dialog

These options relate to the recording Mode, Playback controls and Flight Path 
Creation.

Mode

The default capture behVideoour of this tool is dynamic mode, allowing 
movement within 3D space.

Static view mode is designed solely for capturing the movement of the cursor  
clipping plane through your 3D dataset (e.g. clipping into a complex dataset over 
a period of time to highlight core area). In this mode, movement of either the eye 
or look-at positions in 3D is not possible. Enabling this option will disable many 
functions of the wizard.

Playback

The following Playback controls are available:

• The Loop Style options control the way a script is re-played. Use the pull-
down list to select the desired option. A script can be set to:

• Repeat - the fly-through script is played and then repeated from the start 
continuously,

• Repeat Reverse - replay the script continuously but in reverse, or
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• Repeat Reverse Look - replay the script continuously and in reverse but 
from the view looking back to the capture point.

• Smoothing – As each capture point is a location in three dimensional 
space, the flight path joining these points can be a smoothed line (Bezier) 
or straight line (None) between each point. If smoothing is selected, a 
Bezier smoothing algorithm with Tension is applied. The higher the degree 
of tension, the more closely the replayed flight path will be to the direct 
path between capture points.

• Playback Speed – Actual speed the playback is performed. For example, 
a playback speed of 1 is normal, a value of 0.5 would take twice as long as 
normal, a value of 2 would play twice as quickly as normal, etc. If a script 
takes 10 seconds playback then changing the Playback Speed to 0.5 
would change the playback to 20 seconds. Similarly, if a value of 2 were 
assigned, the playback time would be 5 seconds.

• Frame Rate – Number of display captures in one second. The higher the 
Frame Rate, the smoother the animation. Note the smoother the 
animation, the greater the amount of storage required, especially if 
outputting to an Video movie.

Flight Path Creation

• Flight Speed – Time taken to move between two capture points. Speed is 
expressed in units per second (normally in metres per second). If you find 
that the time being calculated for movements is too large then increasing 
the flight speed shortens the movement times. All replay times get 
recalculated with new values when this property is altered. 

The speed of the replay is set in Playback Speed. 

• Create Eye and Look Path DXF Files – The flight path and capture 
points of a script can be saved to 3D DXF files. Two DXF files get created, 
one for the Eye points and one for the Look At points. The DXF filenames 
are dependent on the name given to the fly-through file. The DXF files are 
created in the same directory as the fly-through file. For example, if the 
output fly-though file path is: C:\DATA\FLY1.FLY, then the DXF files 
created would be called:

C:\DATA\FLY1_EYE.DXF and C:\DATA\FLY1_LOOK.DXF

• Point Symbol Size – This parameter defines the size of a symbol to 
represent the Eye and Look At points in the created DXF files.
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Step 4 - Capture Points and Event Details

The Fly-Through Creation Wizard: Step 4 – Path dialog is made up of three 
components:

• Capture Point List – The details and properties of the various capture 
points are listed with replay duration and icons to indicate events. If you 
select any of the capture point records by clicking on the corresponding 
row number, the Discover 3D map updates to that view.

• Capture Point Events – Controls to capture a point view, pause 
playback, rotate view, preview fly-through and stop a playback.

• Event Details – Control parameters for position and time specification, 
plus any audio accompaniment to a 3D Fly-Through Animation.

Specifying and assigning events to the capture points of a fly-through script

Capture Point List

If a flight path is specified from a MapInfo TAB or MIF file, Discover 3D dataset or 
existing fly-through file (FLY), the capture point details are automatically added to 
the Capture Point List. New points can be added or existing points modified in 
this list. If the Manually from 3D view input option was selected in Fly-through 
Creation Wizard: Step 1 – Input dialog, new capture points must be created. 
See Capturing Point Events for more information.
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The Capture Points are listed incrementally with Duration, Event, Audio and 
Property field for each view.

• Duration – The time in seconds that it takes to move from one Capture 
Point record to the next.

Capturing Point Events

• Event – The type of capture point is indicated by one of four Events:  
Capture Point, Pause, Rotate Eye and Rotate Look At. See Capture 
Point Events for more information.

• Audio – If an audio entry is to be used at a Capture Point, an audio 
symbol is displayed. Enter some text in the Audio entry line or specify a 
pre-recorded sound file in WAV format. If you type an entry, such as “The 
value at this location is high”, when the animation script is replayed, the 
computer will repeat the text through voice recognition processing and the 
text is spoken from the computer. Alternatively, if a WAV file is selected the 
content of this file is played.

The Camera button adds a new Capture Point to the Capture Point List. Each 
entry in the list represents a point along the flight path that is saved in the (FLY) 
script file. The script replays the capture points in sequential order (forward or 
reverse depending on the Loop Style). 

To create a new capture point use the 3D nVideogation tools (see Navigating in 
3D) in the 3D view to rotate and zoom to the next view point:

To insert a new capture point view between two existing views, check the Insert 
Mode box and click the Camera button to insert the current 3D view immediately 
after the highlighted record in the Capture Point List.

This button causes the replay script to Pause for a specified duration of time. By 
default, the time is 1 second, but using the Duration entry field, you can modify 
this time. Note that a record of this type in the list uses the last Capture Point 
and then pauses for the required time with no movement.

The Rotate View button causes the replay script to halt at the last used Eye 
position (determined by the previous capture point record) and then rotate the 
display by an amount determined by an Azimuth and Inclination (looking from 
the top down). The time to complete the rotation is specified by the Duration.
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Event Details

The Event Details controls are concerned with the Capture Point attributes. 
Depending on the Capture Point record selected, the content of the Event 
Details may differ. 

The three buttons included under Event Details are: 

The Rotate Around button causes the replay to rotate the 3D view around the 
last Look At position (determined by the previous capture point record).The time 
taken to complete a rotation (as defined by the Azimuth and Inclination 
settings) is defined by the Duration.

The Properties for the current event can be captured using this button. This will 
save any changes made to any data objects in the Workspace Tree since the 
previous event (e.g. visibility/transparency/legends/object thickness or size/etc). 
To refresh this, select the point event, make the necessary changes in the 
Workspace Tree, and press the Properties button. 

This allows, for example, different datasets to turned on and off throughout your 
animation, e.g. a large scale satellite image could be displayed at the start (while 
you are zoomed out), then turned off, and a small scale image made visible 
when zoomed into the prospect scale.

Note Properties applied to a Capture Point Event are also applied to all successive 
Events, unless a following Properties entry alters this.

• Delete the selected Capture Point from the flight path. 

• Update the Eye and Look Positions for the current event with the current 
3D view.
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The attributes of each Capture Point Event are displayed here and can be 
manually edited: 

• Look Position – The X, Y and Z location of the Look At point in Relative 
or Absolute coordinates. 

• Eye Position – The X, Y and Z location of the Eye point in Relative or 
Absolute coordinates. 

• Duration – The time in seconds that it takes to move from one Capture 
Point record to the next.

• Audio – Either a text entry or specification of a pre-recorded WAV file.

Each entry in the Capture Point List contains two pairs of position points (the 
Eye Position and the Look At point which determines the direction the fly-through 
path will follow). The points can be in either Relative or Absolute coordinates.

Absolute values are used to display a capture point view in real world 
coordinates. Relative values are used to display a capture point view relative to 
the previous capture view coordinates. For example, if a point capture view has a 
relative coordinate of (10, 10, 10) then the view will be moved 10 units in the X, 
10 units in the Y and 10 units in Z direction from the previous capture position. 
Units are map distance units  e.g. metres. If the previous capture position is in 
Absolute values the new view will move in world coordinates by 10 m in the X, Y 
and Z directions.

To get around this problem:

1. Add an appropriate offset to the flight path to re-locate the flight path 
height to the new surface values.

• Displays the Properties of all 3D objects for the selected event, including 
display, transparency, lighting, line and fill colours, etc. To modify this, 
make the appropriate changes in the necessary items of the Workspace 
tree, then press the Properties Capture button (see Capturing Point 
Events above).

Note The flight path created using one of the various options should optimally be 
above or close to the 3D objects in the Discover 3D map window. For example, a 
flight path created over a topographic surface would not be appropriate to use in 
a fly-through of a non-topographic gridded surface representing assays for the 
same area as the Z values will be quite different.
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2. Display the surface in the Discover 3D map window and in the Enhanced 
Layer Control highlight the Surface branch. Choose Properties from the 
right-mouse shortcut menu. In the Vertical Scaling and Offset controls 
select either the Offset to grid maximum or Offset to grid average. This 
operation relocates the grid surface automatically to a level that should be 
approximately zero. 

Previewing your 3D Fly-Through

Once a Fly-Through file has been saved, it can be played back via a number of 
options within Discover 3D: see Playing an Existing Fly-Through File below.

Step 5 - Output Formats

Two output formats are available in the Fly-through Creation Wizard: Step 5 – 
Output dialog:

• Save the Capture Points and settings of the fly-through script by 
assigning a file name and location in an Output File. The settings are 
saved as a FLY file and can be restored for later use with the same 
project dataset. A FLY file can be activated via the Display Fly-through 
option on the Discover 3D map window right-mouse click shortcut menu.

• Save the fly-through as an Video Output movie file. Movie files allow 
replay of a fly-through animation completely separated from Discover 3D 
and are therefore useful for management and overview of a project. For 
more information, see Codecs and Movie File Format.

When more than one Capture Point record is present, you can Replay or 
preview the fly-through script. Click the Play button to activate the fly-through. 
The replay uses the Capture Points according to the Loop Style setting and the 
various speed and event controls (see Step 3 - General Playback Options). 

To halt the replay, use the Stop button.

To display selected capture points in the fly-through replay use the button shown 
left. Only the capture points highlighted in the list will be included in the replay. 
This is useful for editing a long fly-through without hVideong to view the entire 
flight path every time.
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Retain the fly-through script and create a movie of the replay

Static View Mode

The Fly Through Creation Wizard can also capture the movement of the cursor 
clipping plane over a period of time, for instance gradually clipping into a voxel 
model to incrementally expose slices of the interior cells values.

1. To activate this, enable the Static view mode option in the Step 3 dialog. 

2. In 3D, align the view to the desired position. 

3. Enable the cursor plane and position it at the desired start location. Setup 
the required clipping options (Envelope or Slice width, Near, plane 
Appearance etc) in the Cursor Plane Properties dialog. It is also 
recommended to set the Move by user defined step value to a useful 
value (for instance, if the cursor clip plane will be moving 500 m, try a 
value of 20-50 m).

4. In the Step 4 Path dialog, capture the initial point location (recommend 
unclipped, with or without the cursor plane enabled). 
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Notes

• Once the initial view point is set (step 4 above), the view orientation 
cannot be moved in any successive view capture

• The orientation and position of the cursor clipping plane can be modified 
throughout the process

• Datasets can be modified throughout the process (visibility, transparency, 
etc)

• If a static clipping move is required as part of a normal dynamic movie, it 
will need to be merged with the separate dynamic movie using a movie 
editing package such Camtasia Studio or similar. It is recommended to 
save the initial view position using the 3D View Manager, to ensure view 
continuity in the final product.

Codecs and Movie File Format

When creating a movie file, Discover 3D will display a list of any Codecs installed 
on your operating system, whether installed by the operating system or 
downloaded from a  third-party vendor.

To create an video movie:

1. Specify an Video path and file name. 

5. Then enable the cursor plane, and move to the final clipping position (i.e. 
in the depths of the data). Capture this point. Set an appropriate duration 
for the cursor clip plane to move from the start point to this location (e.g. 4 
seconds)

6. Preview the result.

Important Discover 3D does not install any codecs.

Note Most default codecs included with Windows will return an error message, 
because they are Decodes only, and do not support encoding or creating your 
own movies. It is recommended to download and use a codec pack which 
includes the open source FFDShow standard encoders, such as the CCCP pack 
(http://www.cccp-project.net/).

http://www.cccp-project.net
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2. Specify the desired width and height for the movie. By default the pixel 
size is 512 x 512; increasing this will increase the quality of the output 
movie, but also increase both the output file size and processing time 
required to create the movie.

3. Leave the Capture Mode at normal. If you experience problems such as 
corrupted output or it is taking along time, you can adjust this to 
Advanced and lastly, Expert levels to troubleshoot. This reduce the 
amount of memory required and the complexity of the recording process. 
Note that you will need to leave the Discover3D window front most ontop 
of other applications when using these modes.

4. Select the Compressor button. Choose the Codec to use in the Video 
Compression dialog from the Compressor pull-down list. (see Codecs 
and Movie File Format for more information). A slider bar controlling the 
Compression Quality is also displayed. While an Video is being created, 
it can be halted by clicking the Cancel button.

Selection of a codec for Video movie creation

It is recommended that an ffdshow codec is selected (if available) as this 
codec generally offers the best video compression.

5. Adjust the quality, file size, and speed of the output file under the Codec 
configuration by clicking Configure. The most important parameter is the 
bit-rate, which determines how much information is stored for each 
second of playback.

6. Select the Create Video button. A progress bar should commence being 
written as the frames of the movie are created. The rotation and display of 
the Discover 3D map window will also update as the movie scenes are 
captured. When the movie is completed, you can see the movie by 
clicking the View Video button.
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7. When the Video file is created, you can display this movie file using a wide 
range of free movie players. Such players include the GOM Player (http://
www.gomlab.com/eng/GMP_download.html):

Playing an Existing Fly-Through File

There are three ways of replaying a fly-through (*.FLY) file created using the Fly-
Through Creation Wizard:

• Open the file using the Fly-Through Creation Wizard, by selecting the Edit 
Existing Fly-Through File option. This allows the file to be edited as well 
as played.

• Using the File>Open menu option, and setting the Files of Type to “All 
supported Fly-Through Files”. Browse for the required .fly file and click 
Open.

• Right-clicking on the 3D Map branch in the Workspace Tree, and selecting 
Display Fly-through.

The second and third options will display a Flight Control bar upon opening the 
Fly-Through file, allowing playback control.

Note If you receive an ERROR message after selecting a codec and clicking the OK 
and Create Video buttons it is likely that the Codec you have selected is for 
decoding rather than encoding (i.e. for the playback of an Video movie rather 
than the creation/writing of an Video file). Select another codec and try again.

http://www.gomlab.com/eng/GMP_download.html
http://www.gomlab.com/eng/GMP_download.html
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22 Working with Colour Tables and 
Legends
When displaying data such as an elevation, geochemical or geophysical gridded 
surface, it is useful to colour the grid using a Colour Look-Up Table (LUT) in order 
to show the variation in data values. Instead of creating colours for individual data 
values a colour look-up table is used which is made up of a number of colour 
shades to form a continuous colour spectrum. When a colour look-up table is 
applied to the gridded data the colours are applied evenly between the minimum 
and maximum values. 

For data which is to be displayed visually according to individual data categories 
or data ranges, a Legend table can be created. For example, Downhole drillhole 
data can be displayed showing patterned lithological units or discrete coloured 
assay ranges. Geochemical data can be displayed according to mesh size or 
sample type. Legends can be created manually or automatically from a selected 
dataset field.

To apply LUT and Legends to datasets use the Colour Scale or Colour Lookup 
Selection dialogs (below). Access to these dialogs is via the relevant Properties 
dialog. In addition these dialogs provide standard HSL and RGB Interpolation 
options with end member colour control.

The Colour Scale dialog
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In this section:

• Using the Colour Look-Up Table Editor

• Using the Legend Editor

• Advanced Colour Mapping

Using the Colour Look-Up Table Editor

LUT files are stored by default in the C:\Program Files\Encom\Common\LUT 
(Windows XP) or C:\ProgramData\Encom\ Common\LUT (Windows Vista or 
Windows 7) directory. The format of LUT files varies depending on the saved 
format type. Supported types include:

• ER Mapper (files with extension .LUT)

• MapInfo Professional (extension .CLR)

• Geosoft Oasis (extension .TBL)

The LUT Editor dialog is divided into functional areas. On the left is a scrollable 
list with the available Lookup Tables. Beneath this list are New and Delete 
buttons for creating a new LUT and removing lookup tables from this list. In the 
centre of the dialog are the various colour settings for the number of rows 
specified in the selected LUT with descriptive comments if available. 

The lookup Table name, Description and the corresponding Filename are 
displayed at the top of the dialog. Underneath the Colour interpolation can be 
selected from RGB or HSL with an option to show the individual RGB values for 
each row. The Settings button shows the file path of the stored LUT and can be 
changed to another location such as a server directory if required. A preview of 
the selected LUT is displayed on the right of the dialog showing the entire LUT 
colour spectrum. 

At the base of the dialog is a series of buttons used to control the distribution of 
colours in a new or existing lookup table. Once a LUT has been specified it can 
be stored using the Save button. To save an existing LUT under a different name, 
location or file format use the Save As button. The above LUT formats are 
provided as options when the Save As dialog is displayed. The LUT Editor dialog 
appears as below:

The Colour Look-Up Table (LUT) Editor is accessed from the Tools menu in 
the 3D interface. It can also be accessed from the Colour Lookup Selection 
dialogs (via the Point and Line Properties dialogs).  
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The dialog of the LUT Editor

A colour lookup table can contain any number of rows. Usually, this number is 16, 
32, 64, 128, 256 etc. to enable an even colour spread. Each row can have a 
colour individually assigned or a number of rows can be selected and the colours 
graduated over the entire row range. 

To create a new colour look-up table:

1. Click the New button. 

Dialog for creating a new LUT
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2. The Create new lookup table dialog requires a Name plus the Number 
of entries of rows (colours) to be assigned.

3. Check the Specify the data value corresponding to each colour box to 
precisely match data values with a colour from the table. For example, if 
the data has a range from 51,000 to 51,500, you could evenly space 500 
definable colours for each of the 500 data values. Note that if this utility is 
used, you cannot use the created LUT within ER Mapper.

When the new table is created it is added to the available LUT list but all the 
colours are blank. Double click on any of the Colour cells of a row and a list of 
available, standard colours is displayed. If you select the Custom option, any of 
the Windows-supported RGB or HSL colour specifications can be created. 

By selecting two end-member cells (indicated by highlighting the cells in two non-
adjacent rows); you can use the Interp Selection button to fill any intermediate 
blank cells. In a similar way, you can make blank any highlighted cells by using 
the Clear Cells button or interpolate colours between specified colours using the 
Interp Gaps button. Selected cells can be all set to match the FIRST cell using 
the Duplicate button. This always operates from the top-most selected cell down, 
irrespective of the order in which the cells were selected. Extra rows can be added 
or deleted using the Insert or Delete Rows buttons. To store the current LUT 
settings click the Save button.

Using the Legend Editor

The Legend Editor can be used for the following:

• Create colour legends for numeric or text fields.

• Create thickness legends for numeric fields (e.g. for custom thickness 
modulation of drillholes by an assay field).

The Legend Editor is accessed from the Tools menu in the Discover 3D 
interface. 
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• Modify and maintain existing legends.

To create a new legend:

1. Ensure an appropriate dataset is open in Discover 3D (e.g. a drillhole 
project or 3D points/lines dataset).

2. Select the Tools>Legend Editor menu option.

3. Press the New button at the bottom left of the dialog. This will open the 
New Legend dialog.

4. Enable the Populate legend from dataset… option, and select the 
Normal dataset option.

5. Select the Dataset and target Field from the pull-down lists.

6. The field Data Type can be either a numeric or text field- the dialog will 
automatically recognise this.
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7. If numeric, set the Number of rows to be the required number of ranges. 
Do not alter this value if a text field - the Legend Editor will have 
determined the number of unique attributes on the selected field.

8. Specify an output Legend Name (or leave as the default) and press OK. 
The legend will be displayed in the Legend Editor.

To edit a legend:

1. In the Legend Editor dialog, select the required legend from the list on the 
left. It’s attributes will be displayed on the right.

2. Numeric legends will display a From (>=) and To (<) field. Click in the 
appropriate cell and enter a value to alter the ranges as required. Enabling 
the Auto-populate From fields option at the top of the dialog will fill the 
next range’s From value from the previous ranges To value after it has 
been entered. Extra ranges can be added/deleted using the Row controls 
at the bottom right of the dialog (Add/Insert/Delete Rows).

3. Text legends will have a String field. If the legend has been auto-populated 
in the New legend dialog, it is not recommended to alter the string entries, 
as altered entires may not match dataset attributes.
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4. If the legend is to be used for colour modulation (e.g. drillholes), the 
primary foreground colour can be set for each row using the colour palette 
under the Fg field. If patterns are to be applied (e.g. geology), these can 
be set using the palette available under the Pattern field, in tandem with a 
background (Bg) colour (if applicable). Colour schemes can also be 
automatically applied using the RGB/HSL Interpolation buttons.

5. If a numeric legend is to be used for thickness modulation (e.g. drillholes), 
alter the LThick column entries to the required thicknesses.

6. Press the Save button when complete, and close the dialog.

Legend Editor Controls

The Legend Editor dialog lists the available legends down the left side and the 
details of the currently highlighted Legend including colours, patterns and 
associated string entries on the right side.
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At the top of the Legend Editor dialog the selected Legend name is displayed 
with a Description, the Filename and the legend Data Type which may be text 
or numeric. Next to these entries are buttons to save and/or Close the dialog.  By 
default, the Save button overwrites and saves the legend file into the folder as set 
by the Tools>Options default path. The Save As button allows you to save a 
legend in a new folder and with a different filename if required.

Column headings indicate the display attribute of a row. These are:

• Row – incremental row number.

• String – a text string to describe the item of the legend row. Double-click 
to edit.

• From/To – the range end values for numeric-based legends. Double-click 
to edit the value.

• Fg (Foreground colour) – placing the cursor over the Fg cell of this row 
and clicking the left mouse button displays the colour pick options. 

Standard colours are available but if you wish to create or chose custom 
colours, click the Custom item. The legend item can also be set to 
Transparent which renders items with this legend entry see-through. 

• Bg (Background colour) – setting a background colour highlights 
patterns when assigned. Selection of background colours is identical to 
selection of foreground colours (see above).

• Pattern – specify the pattern to be displayed for a legend row. Place the 
cursor in the Pattern row location and click the left mouse button. A 
scrollable list of available patterns is displayed and allows individual 
pattern selection. 
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The pattern selected is drawn with the colour of the nominated 
Background Colour (see above). 

Pattern styles are stored in bitmap files located as specified in 
Tools>Options>File Locations tab.  

• LCol (Line Colour) – used to form a drawn line boundary around the 
specified legend row entry. Selection of Line Colours is identical to 
selection of foreground colours (see above).

• LStyle – Double-click to select an appropriate boundary Line Style.

• LThick – Input value defines the boundary Line Thickness, used in 
Thickness Modulation of drillholes.

• Comment – a descriptive text entry for each legend row can be stored 
with the legend if required.
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Operational buttons along the base of the dialog enable you to:

• Create New legend files.

• Import a .TAB file used by Encom Discover 3D to populate a new legend.

• Delete an existing legend file.

Various operations can be performed over a selected range of legend rows within 
a column. Select the first cell then, holding the SHIFT or CTRL keys, click on the 
last cell for the desired range. Selected cells are highlighted in the editor. The 
following operations relate to selected cells: 

• RGB Interpolation automatically interpolates Red:Green:Blue data 
values across rows of selected cells. To use this feature, select a vertical 
column of cells.

• HSL Interpolation automatically interpolates Hue:Saturation:Lightness 
colour data across selected legend rows. Its operation is identical to the 
RGB Interpolation option.

• Step Patterns assigns patterns from the pattern list incrementally from 
the first selected pattern cell to the last selected cell.

• Duplicate Patterns copies the pattern of the first selected cell to the last 
selected cell.

• Insert row places an empty row before a selected row or cell.

• Delete rows removes single or multiply selected rows. Any cell selection 
that is highlighted is removed with this operation. A confirmation message 
is displayed before the rows are deleted.

Legend Location

Legend information is stored in a file with a .LEG extension. Legend files are 
stored in the C:\Program Files\Encom\Common\LUT (Windows XP/2000) or 
C:\ProgramData\Encom\ Common\LUT (Windows Vista or Windows 7) 
directory or the directory as specified in the Tools>Options>File Locations tab. 

Warning When rows are deleted, and the modified legend has been saved, the deleted 
rows cannot be restored.
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In addition to the legend files, associated patterns are stored in the C:\Program 
Files\Encom\Common\Patterns (Windows XP/2000) or 
C:\ProgramData\Encom\ Common\Patterns(Windows Vista or Windows 
7) directory. 

Advanced Colour Mapping

In many properties dialogs, wherever a Colour or other property such as 
Thickness or Transparency is selected to be modulated, an Advanced data 
mapping dialog is provided.

The Colour Mapping dialog configured for an increasing logarithmic data transform, with 
bandpass cut-off limits set in data values

This dialog presents a preview screen of the data distribution, with the Cumulative 
histogram displayed as a green line, and the applied data transform a red line 
(and are also replicated in the main Surface Properties dialog preview screen), as 
well as the bandpass cut-off limits (dashed lines). The colour distribution for the 
specified data transform is also displayed around the preview edges as colour 
bars. A spreadsheet displays transform inflexion points as a series of coordinates, 
where X is the data value and Y is frequency. The preview screen can be 
controlled using the buttons at the bottom left (Zoom, Pan, Fit view to data).
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The following transform options are available in this dialog from the pull-down list:

• Linear (increasing or decreasing) - the transform linearly distributes 
colour between the minimum and the maximum data values.

• Log (increasing or decreasing) - colour is distributed logarithmically 
between the minimum and the maximum data values.

• Histogram - this transform produces an image with an equal amount of 
colour area across an image.

• User-defined – having set one of the above transforms (with or without a 
bandpass cut-off), choosing this option allows you to customise the 
transform curve. A series of inflexion points are displayed as black icons 
along the curve; additional control points can be added by placing the 
cursor over the transform and clicking when it changes to the Add Point 
cursor. Control points can be edited via the following methods:

• Clicking on a control point in the graph and moving it moves all 
control points in an elastic motion. This move is reversible; moving 
a control point and then returning it to its original position will return 
all other control points to their original positions. The editing mode 
compresses control points in front of the selected point and 
expands them behind the selected point. This mode allows quick 
modification of the shape of the transform curve whilst retaining the 
flavour of the original curve.

• Clicking on a control point with the CTRL key held down and moving 
it moves the selected control point only. Points cannot be moved 
horizontally beyond the two adjacent control points. Directly editing 
a control point in the spreadsheet applies the same rules. This 
mode allows control over the exact coordinates of individual control 
points.

• Clicking on a control point with the SHIFT key held down and moving 
it. This editing mode compresses control points in front of the 
selected point but does not modify control points behind the 
selected point. The same effect can be achieved by moving a 
control point in one of the colour bars.

Moving a control point horizontally is equivalent to moving a 
selected colour to a new data value. Moving a control point 
vertically is equivalent to moving a selected data value to a new 
colour. 
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• Clicking between two control points in a colour bar and dragging 
moves the control points to the left and right of the cursor. The 
distance between these two points will not be modified but control 
points in front of the leading point will be compressed. Control 
points behind the trailing point will not be modified.

Moving a segment horizontally is equivalent to moving the selected 
colour range to a new data range. Moving a segment vertically is 
equivalent to moving the selected data range to a new colour range.

Creation of a User-defined transform

For each of these options (except User-defined), a Bandpass cut-off can be 
applied either as percentage or data values. All data values outside the specified 
range will be assigned the minimum or maximum colour value and the colour 
stretch will then be restricted to the data within the bandpass.
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23 Customising Discover 3D
In this section:

• Customising 2D Interface Settings

• Customising 3D Interface Settings

• Customizing Toolbars

• Assigning Custom Keyboard Shortcuts

Customising 2D Interface Settings

The Discover 3D>Options menu item (accessed from the 2D MapInfo menu 
system) opens the 3D Options dialog, which allows control of various system and 
display settings.

• System Tab

• Display Tab

System Tab

Options available from the Systems tab include:

File Locations

• Temporary Directory - During a work session various files are created for 
display and management of the 3D displays. By default, this is the same 
directory as the Discover Temp directory.

• Remove Temporary Files on Exit - When the Discover 3D window is 
closed, any files present in the nominated Temporary Directory are 
removed if this option is enabled.

XYZ Compass

A small principal compass indicator is displayed in Discover 3D to assist in 
orientation of the three dimensional view. The XYZ axis directions can be 
displayed all the time, only when rotating or never. In addition, the axis labels can 
be renamed (e.g. Up, East, and North).
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3D Surface Display Options

A number of methods are provided to vary the default compression factor applied 
to grid surfaces. For speed considerations, surface grids are decimated in their 
display i.e. not all rows and columns are displayed depending on the compression 
selected. The higher the degree of Compression, the faster the redraw speed with 
an associated decline in the level of surface detail displayed.

• Loading Max Columns - Maximum number of columns in a grid which 
will be used to load the grid into system memory. If the grid exceeds the 
column number Discover 3D will use large grid handlers to load the grid 
into Discover 3D. It is recommended that only small grids e.g. <50 MB are 
loaded into system memory and large grids e.g. >50 MB employ the large 
grid handlers.

• Loading Max Rows - Maximum number of rows in a grid which will be 
used to load the grid into system memory. If the grid exceeds the row 
number Discover 3D will use large grid handlers to load the grid into 
Discover 3D. It is recommended that only small grids e.g. <50 MB are 
loaded into system memory and large grids e.g. >50 MB employ the large 
grid handlers.

• Rendering Max Columns - Maximum number of columns in a grid before 
the grid will be decimated for display in Discover 3D Display Window. 
Decimation is employed to reduce the system overhead and speed up the 
refresh rate of the 3D Display Window. The decimation will only be used 
when surface compression mode is set to Constant and the level of 
decimation is set to System size, refer to Gridded Surfaces in 3D chapter 
for more details on compression.

• Rendering Max Rows - Maximum number of rows in a grid before the 
grid will be decimated for display in Discover 3D Display Window. 
Decimation is employed to reduce the system overhead and speed up the 
refresh rate of the 3D Display Window. The decimation will only be used 
when surface compression mode is set to Constant and the level of 
decimation is set to System size, refer to Gridded Surfaces in 3D chapter 
for more details on compression.

• Normal texture size - Pixel resolution of rendered surface in Discover 3D. 
When a surface file is imported into Discover 3D the display is actually 
composed of a bitmap image, the resolution of the bitmap image is 
determined by the normal texture size setting, a higher resolution setting 
the greater the detail, however, the slower the refresh rate of the 3D 
Display Window.
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• Maximum texture size - Pixel threshold set for a georeferenced image 
imported into Discover 3D, before the image will be tiled. If a 
georeferenced image does not reach the maximum texture size a single 
image drape is displayed. If a georeferenced image imported into 
Discover 3D exceeds the maximum texture size a series of seamless 
image tiles will be created. Tiling an image is generally conducted due to 
limitations in graphics cards and allows the display of very high resolution 
images in the 3D Display Window. Generally, set the maximum texture 
size to 1024 as most graphics card support this texture size.

Display Tab

The Display tab allows control of the following options:

3D Window Display Options

Raster images are used to show draped pictures over surfaces or at defined 
elevations etc. The amount of detail used in these images impacts on the drawing 
speed of Discover 3D. If the detail of an image is increased the redraw speed is 
decreased but the information provided in the images is increased. If you select 
a value of 2x, Discover 3D creates an off-screen bitmap that is 2x the size (in 
width and height) and 4x the size in pixels of the selected Map window.

The 3D Point Symbol Size option sets a default size for 3D Point symbols in 
Discover 3D displays. 

Customising 3D Interface Settings

The Tools menu in the Discover 3D window provides access to the 3D Interface 
Options dialog, which enables the control of numerous 3D window settings. 

Options that can be specified include:

• Paths for data and templates.

• Default page size (in the absence of an installed printer).

• Preferred view options.

• Specific file locations.

• Default printer page size and orientation.

• Auto-reloading of modified files in use.
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For more information, see:

• File Tab

• Size Tab

• View Tab

• File Locations Tab

• Page Setup Tab

• Fullscreen Tab

File Tab

Record accessed directories enables or disables the last used file paths when 
using open or save dialogs. These include the general Global directory and 
session open/save, as well as survey database (drillholes) and grid files.

Monitor data files for changes and reload adds support for automatic update/
refresh when data files are edited.

The Autosave session setting defines how frequently the recoverable autosaved 
session file (File>Restore Autosave Session) is updated.

Show file loading report after session loading enables a list of files 
automatically found or skipped after opening a session.

Use relative paths to resolve files in sessions improves the automatic 
resolving of moved or missing files when opening session files.
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Size Tab

Raster grid size limits the largest surface grid that will be loaded by default in a 
surface or image branch. In Discover3D, as there is only a 3D map the Loading 
option is not applicable. Only the 3D Rendering limit applies.

Texture size defines the resolution or raster images such as JPG, bitmaps or 
ECW files which are usually loaded in an Image branch. Generally only up to 
4096x4096 is supported by graphics cards. Image files larger than 4096x4096 
pixel resolution will be decimated to this size.



608 Encom Discover 3D User Guide

View Tab

Support for the 3DConnexion SpaceNavigator™ device is enabled in this dialog: 
see Using the 3DConnexion SpaceNavigator™for use of this device in navigating 
Discover 3D.

Show navigation pads enables the navigation buttons that are embedded in the 
3D window when 3D navigation cursor mode is selected.

Show frame rate displays frames per second at the top left of the 3D window.

Show properties of new objects on creation automatically opens the 
properties of a branch when a new branch is added/opened in the 3D Map.

The position of the XYZ indicator is also controlled on this tab.

Note These XYZ compass options are replicated in the Discover 3D>Options dialog 
accessed in Discover under the System tab. Changes applied in either dialog 
are automatically updated in both dialogs.
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File Locations Tab

Preferred datasets, sessions, surface grids, colour tables and patterns can be 
saved in specified default locations. These locations usually are defaulted but 
these values can be overridden by selecting the item to be specified from the 
displayed list and then using the Modify button.
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Specify the default locations of various files

The option to Use Global Directory is enabled by default. This setting is used for 
accessing all file types from a single source folder. The folder is defined by 
selecting the Global Directory item and clicking the Modify button to set the 
Global Directory location.

Page Setup Tab

The Page Setup tab of the Options dialog provides support for default printers 
when Discover 3D is connected to or remote from printers or plotters. This default 
sets the automatically displayed page when a Page Layout display is presented. 
The layout may alter depending on whether Discover 3D can find the specified 
drivers for the defined printer/plotter. If these Windows drivers cannot be found on 
the machine, the Windows default printer settings are used. 

To modify the printer default setting for Online printers, select the Page Setup 
button. 

Note The Discover Temp directory cannot be modified from this dialog. The Temp 
directory can only be changed in the Discover>Configuration>Settings dialog 
within Discover. 
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Page Setup tab of the Options dialog

Fullscreen Tab

This dialog allows you to specify Show Main Menu, which will include the main 
menu toolbar when in fullscreen view.

Customizing Toolbars

• Adding and Removing Tools

• Restoring Toolbar Settings

• Toolbar Button Size

• Show and Hide Tool Labels

• Creating New Toolbars

• Other Customizations
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Adding and Removing Tools

Existing tools on the toolbars can be quickly displayed or hidden by clicking on 
the dropdown arrow on the selected toolbar. Select Add or Remove Buttons and 
the appropriate toolbar to customise. And then select or deselect the tool to 
display or hide.

The tools available on ioolbars can also be customized to suit the user 
requirements. To open the Customize dialog either right mouse click on the Main 
menu bar and select the Customize option or from a toolbar navigate to 
dropdown arrow on the selected toolbar and select Add or Remove Buttons 
followed by the Customize option.

From the Customize dialog navigate to the Commands tab, select a tool, from 
the Commands list drop and drag a select command into an existing toolbar. 
Next time Discover 3D is started the customized toolbar will appear.

Drop and drag tool into toolbar.
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Restoring Toolbar Settings

To restore a toolbar to factory settings, click on the dropdown arrow on the 
selected toolbar. Select Add or Remove Buttons and the appropriate toolbar to 
customise. And then select or Reset Toolbar.

You can also reset one or all toolbars by selecting the Customize option on any 
toolbar dropdown menu, and selecting the Toolbars tab.

Toolbar Button Size

To display toolbar icons in a larger style, navigate to the Customize dialog by 
right mouse clicking on the Main menu bar. On the Options tab check the Large 
Icons option.

Show and Hide Tool Labels

To hide and show tool labels, navigate to the Customize dialog by right mouse 
clicking on the Main menu bar. Check the Show text labels option on the 
Toolbars tab of the Customize dialog, the selected toolbar will display the tool 
label as well as the icon.

Creating New Toolbars

As well as customising existing toolbars up to ten user-defined toolbars can be 
created. To create a toolbar navigate to the Toolbars tab on the Customize 
dialog and press the New button, type in an appropriate name for the toolbar. 
Using the procedure for customizing individual toolbars navigate to the 
Commands tab, select a tool, from the Commands list drop and drag a select 
command into the new toolbar.
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Create new toolbar with custom tools.

Other Customizations

Located on the Menu tab of the Customize dialog are options for menu list effects 
and shadows.

Located on the Options tab of the Customize dialog are options for displaying 
screen tips, shortcut keys and enlarging the toolbar icons.

Assigning Custom Keyboard Shortcuts

The Customize dialog also allows you to link existing Discover 3D menu 
commands with a keyboard shortcut. Some commands already contain built-in 
shortcuts, such as Print (CTRL+P). Additional shortcuts can also be set up for 
these menu commands using the Keyboard tab in the Customize dialog.

To add a keyboard shortcut to Discover 3D open the Customize dialog and select 
the Keyboard tab. Select a Category from the pull-down list and select a 
Command from the list displayed. Click the mouse cursor in the Press New 
Shortcut Key box and select the keyboard shortcut (use CTRL and SHIFT keys 
if desired). Click the Assign button to complete the shortcut creation.
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To remove a keyboard shortcut, select a command click the Remove button. To 
remove all custom shortcuts click Reset All.

To display the custom shortcut in the menu system navigate to the Customize 
dialog and select the Options tab, check the Show shortcut keys in Screen 
Tips option.

Create keyboard shortcut for a tool.
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E Voxel Calculator Syntax
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A 3D Cursor Keyboard Shortcuts

Encom Discover 3D Keyboard Shortcuts

Using this Card
This card can be used as a quick reference for 

the Encom Discover 3D keyboard and cursor 

shortcut keys. As an  aid to productivity, 

these can be used in conjunction with the 

standard menu items and toolbar icons.

Key

Shortcut keys apply once functions have been activated.

Navigation

Snapping

Cursor Plane Display

Cursor Plane Position and Orientation

Bonding Cursor Plane to Images

Toggles snapping on and off

Note: The position/orientation of the cursor 

plane changes at a slower/faster rate if 

the Shift/Ctrl keys are pressed.

Toggles cursor plane display

Centres the 3D view at the 
current cursor position

Extends the focus box to 
encompass the current 3D 
cursor location (does not 
move the cursor plane)

Switches the cursor plane 
orientation between 
three standard view 
planes: XY, YZ and XZ

(hold the Shift key) 
Decreases and increases 
the cursor plane size

Toggles the cross-hair style 
between none, 2D and 3D

Orientates the cursor plane 
parallel to YZ plane

Orientates the cursor plane 
parallel to XZ plane

Orientates the cursor plane 
parallel to XY plane

Moves the cursor plane 
towards or away from 
the view point

Changes the cursor plane 
inclination/dip

Changes the cursor plane 
azimuth/bearing

Centres the cursor plane 
without changing 
its orientation

Bonds or unbonds the cursor 
plane to the selected image

(numeric keypad) Iterates 
through all selected images

Switches bonding between the 
first and last images in a series

Navigation

Feature Editing

Cursor Plane Position 
and Orientation

Snapping

Bonding Cursor 
Plane to Images

Cursor Plane Display

Clip with Cursor Plane

Left button click

Rotates the view

Right button click

Zooms in and out

Dragging mouse with the 
left button pressed down

Dragging mouse with the 
right button pressed down

Moves the viewing centroid 
horizontally in the XY plane

Pans the view from a fixed 
“look from” position

Moves the viewing centroid 
vertically and parallel 
to the screen plane

Dragging mouse with 
the left and right buttons 
pressed down

Mouse Symbology
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Creating Features

Selecting Features

Selects a feature

Adds a feature to the 
current selection

Encom Discover 3D Keyboard Shortcuts

Feature Operations
With two or more features selected

(minus key) Cuts the first 
selected feature with all 
other selected features

Aggregates the selected 
features, preserving the 
original geometries

Disaggregates or ungroups 
aggregated features into 
individual features

Consolidates the selected 
features by removing identical 
elements (nodes, edges, faces)

Creates the intersection 
of the selected features

Creates the union of the 
selected features

Triangulates the selected 
features (breaks each 
polygonal face into a set 
of triangular faces)

Creates the exclusive union 
of the selected features 
(overlapping areas removed)

When at least one of the 
selected features is a point 
or a line, creates a surface 
by triangulating all nodes 
from all selected features

Toggles edit mode between 
Add, Delete, Break and None

Depends on the current 
edit mode (Add, Delete, 
Break, None) and the type of 
element (node, edge, face)

Node: moves node on 
the cursor plane
Edge: inserts a node

Node: moves node 
perpendicular to the 
cursor plane
Edge: inserts a new node 
and moves it perpendicular 
to the cursor plane

Moves feature on the 
cursor plane

Moves feature perpendicular 
to the cursor plane

Creates a point feature 
or new points of polygon/
polyline (depending on 
the current default)

Creates a polygon/
polyline feature (if it is the 
current default type)

Cancels creating a feature

Removes the last created 
point of a multi-point feature

Editing Features
Applies to a reshapable feature
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B Statistics Explorer Tool
The Statistics Explorer is a series of dialogs that enables you to examine any 
dataset both statistically and spatially. 

The components of the Statistics Explorer window

The Statistics Explorer window is divided into two main sections; the upper 
Spreadsheet window and the lower Property Page window. The contents of these 
depend on the view selected; the Statistics Explorer has four views, selectable 
from drop list at the top left of the window. These present graphical and statistical 
information using different Property Pages, which can be controlled using the 
Property Page tabs in the middle of the window.

The Statistics Explorer can be accessed via the statistics button in the various 
Field Data Conditioning dialogs accessed from many Properties dialogs, as well 
as the 3D gridding tool.
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These views are:

• The Univariate view examines a single field in the input data and presents 
basic summary statistics and histogram analysis.

• The Bivariate view examines any two fields in the input data and presents 
scattergram plots and basic summary statistics.

• The Spatial view plots the data using its spatial X, Y and Z coordinates 
and presents basic summary statistics.

• The Variogram view computes a variogram grid and displays directional 
semi-variogram data. This allows the creation of sample variograms, and 
creation and editing of model variograms.

The Statistics Explorer allows data to be selected in the spreadsheet or any of the 
univariate, bivariate or spatial views using the Selection Tools at the base of the 
window. The explorer can then ‘collapse’ the dataset to the current selection, and 
display the statistics for this new data subset.

Spreadsheet

The Spreadsheet comprises the top half of the Statistics Explorer dialog, and 
displays the records for the currently viewed selection.

It uses the following colour codes to highlight records: 

• The currently selected data points are highlighted red.

• The currently selected data point is highlighted purple.

• Invalid data is highlighted orange (e.g. coincident data).

• The current key and ancillary fields are highlighted purple.

The spreadsheet shortcut menu can be accessed by right clicking on any column 
header. This provides a number of column resizing options (including the various 
‘Fit to’ options). Alternatively, columns and rows can be resized by clicking on 
their boundaries and dragging. 
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The Spreadsheet shortcut menu

The spreadsheet can also be sorted by any column using the Sort menu options. 
The Statistics option returns a basic statistical summary of any field.

The statistics summary for an arsenic field

Data points can be selected from the spreadsheet (if valid for the current view) by 
clicking on the row header; use the CTRL and SHIFT keys to unselect stations 
and make multiple selections. A range of cells can be also be selected by clicking 
and dragging the mouse. These selection operations are treated exactly the same 
way as graphical selections and the undo/redo operations can be applied.

The key field (whilst in univariate mode) or the ancillary field (whilst in bivariate 
mode) can be changed by double clicking on the field header in the spreadsheet.

When a single data point is selected in any graph (using the Pointer tool, see 
Selection Tools) the spreadsheet will scroll to the appropriate record.
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Zoom, Selection and Display Controls

Each of the view types incorporates a number of property pages, discussed 
further under the relevant view sections. Depending on the view type, some or all 
of the following controls may be available within a property page window: 

Zoom controls

The Zoom controls toolbar

• Use the three buttons in the middle to Zoom In, Zoom Out and Pan.

• The Restrict Zoom button on the left restricts zooming and panning to the 
horizontal dimension only.

• The Fit to Data button on the right cancels any zoom and returns to the 
default view showing all data.

Selection Tools

The Selection controls toolbar

The Selection tools provide a powerful data selection capability. The Pointer 
button displays a cursor which can dragged through the graph. It may be 
displayed as either a vertical bar or a cross hair depending on graph type. In all 
cases, the pointer ‘snaps’ to the closest station and this station is then 
highlighted purple in the spreadsheet.

 

Data can also be selected using Rectangle or Polygon selection, although the 
polygon selection is not available in all graphs. Selected stations are coloured 
red unless colour modulation is enabled in which case they are coloured black. 
Each selection operation can either select the enclosed stations (include option) 
or unselect the enclosed stations (exclude); this is toggled using the Include/
Exclude button.

 

Each selection operation is placed onto a stack which allows you to Undo and 
Redo operations. Buttons are also provides to Unselect All and Select All. The 
selection can also be Inverted.
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Display Modulation

The graph can be also be Colour and/or Size Modulated by any field in the 
dataset. Select the required fields from the drop lists at the base of the graph. To 
cancel colour or size modulation, select <None>. A simple pseudocolour look-up 
table is used and a linear colour stretch is employed.

Subsetting

Univariate

The univariate view examines a single field in the input data and presents basic 
summary statistics and histogram analysis. It incorporates three property pages:

• A Scattergram graph of the data point index verses key field.

• Statistical information for the key field. 

• A Histogram of the key field. When this is displayed, the spreadsheet will 
show a detailed breakdown of the histogram data.

The univariate view requires a key field to be defined. This field is selected from 
the second drop list at the top of the dialog. The key field can be changed at any 
time to examine any field in the dataset.

Making a selection within a graph (which supports selections) or the spreadsheet 
view will activate the Collapse button at the top of the Statistics Explorer 
window.

This button extracts the selected data points from the dataset to create a new 
subset. The spreadsheet and graph views will be redrawn to focus on this 
subset. Only the subset will be considered in any statistical computations or 
graphs. Further selections can be made to examine the data in greater detail. 
The Expand button allows a previous level/subset to be redisplayed. If this 
button is disabled then the view has returned to the original dataset.
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Univariate graph display

The Graph page plots the key field versus station index. Graph controls are 
detailed in Zoom, Selection and Display Controls above.

The properties of the graph can be obtained by double clicking on an appropriate 
area of the graph. For example, click in the bottom and left margins to obtain 
properties of the X and Y axes. This property page enables you to change the axis 
extents and change the axis mapping between linear and logarithmic. When 
using logarithmic axes, you must elect to leave some data space surrounding 
zero as linear.
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Specifying an axis range

Statistics of the chosen field
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The Statistics page presents basic summary statistics for the key field, as detailed 
below: 

Sample Count The total number of samples in the dataset.

Valid Sample Count The total number of valid (non-null/selected) 
samples in the dataset.

Invalid Sample Count The total number of invalid (null/unselected) 
samples in the dataset.

Minimum The minimum value of all valid samples.

Maximum The maximum value of all valid samples

Mean The mean (average) value of all valid samples.

Variance The variance of all valid samples.

Standard Deviation The standard deviation of all valid samples.

S/N Ratio The signal to noise ratio of all valid samples.

Coefficient of skewness The skewness of all valid samples.

Skew direction The skew direction (positive/negative) of all valid 
samples.

Median The value of the centre value in the sorted dataset.

Mode The most frequently occurring valid value in the 
dataset.

Lower quartile The value of the dataset at the 25 percent quartile.

Upper quartile The value of the dataset at the 75 percent quartile.

Interquartile range The range of the data between the lower and upper 
quartiles.
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Histogram distribution of the selected field

The Histogram page presents an ‘equal width’ histogram of the key field. An 
equal width histogram is one built by dividing the valid data range into a large 
number of equal width bins and then computing the frequency of occurrence of 
key field values in each bin.

To be effective a large number of bins are used and these are grouped together 
depending on the scale at which the histogram is viewed. When multiple bins are 
being grouped together each consolidated bin is drawn with a back border. When 
zoomed in sufficiently to see individual bins, no black border is drawn. Also, the 
thickness of the bin is no longer equal to the assigned min/max values of the bin; 
it now relates to the actual min/max values of the data assigned to the bin.

The cumulative histogram is also displayed as a heavy green line. This indicates 
the percentage of data that is below the current value at any point. The upper and 
lower quartiles are displayed against the X and Y axes as dotted lines.

The spreadsheet displays the bin information including the bin data range, 
number of samples in each bin and the range of the actual data assigned to the 
bin. It also displays the cumulative histogram values.

The Selection Tools work normally in this graph. The selections are indicated as 
a percentage of stations selected in each bin. This is displayed as a red base. 
Note that no selections can be made from the spreadsheet in this mode.
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Bivariate

Display of Bivariate data distribution with Key and Ancillary selection fields indicated

The Bivariate view requires the user to define two input fields – the key 
(horizontal) field and the ancillary (vertical) field. Make these selections from the 
drop lists at the top of the explorer (indicated in screenshot above).

Two property pages are presented. The Graph page shows a scattergram of the 
ancillary field plotted against the key field. The Statistics page presents summary 
statistics for the bivariate distribution as well as a spreadsheet of the conditional 
expectation. You can copy and paste from this spreadsheet into Microsoft Excel.

The Graph page displays a linear regression as a blue line. A conditional 
expectation curve is also displayed as a green line. It also displays a quantile vs. 
quantile (q-q) curve as a purple line from 5% to 95% at steps of 5%.
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For both pages, the Spreadsheet displays the complete dataset. A full range of 
selection tools are available both graphically and in the spreadsheet.

The following statistical definitions are used: 

Sample Count The minimum number of samples in both fields.

Valid Sample Count The total number of valid (non-null/selected) 
samples in one or both fields.

Invalid Sample Count The total number of invalid (null/unselected) 
samples in one or both fields.

Valid data range The range of valid common samples in the key and 
ancillary fields (X,Y).

Minimum The minimum value of all valid samples.

Maximum The maximum value of all valid samples.

Mean The mean (average) value of all valid samples.

Covariance Sum of squares of product of the difference 
between the field mean and each sample.

Correlation coefficient Covariance normalised by the product of the fields 
standard deviations.

Inertia Half the sum of squares of difference between the 
two fields.

Rank coefficient Spearman rank coefficient.

Regression Linear regression fit to all valid samples.

Intercept Value of the ancillary field at the origin.

Slope Slope of the ancillary field versus the key field.

Conditional Expectation Expected value of V at any U.
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Bivariate statistical data ranges and distribution

Spatial

The Spatial view does not require the user to define any fields (unless the View 
Extraction option on the Statistics page is used; see below). The data will be 
automatically plotted using its spatial coordinates in an isotropic view. If the data 
has less than two spatial dimensions no spatial view will be available.

A Graph page showing the spatial plot is presented. All Zoom, Selection and 
Display Controls are available. Data points can be colour or size modulated. 
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Displaying the Spatial distribution of the data

The Spatial Statistics pages
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The Statistics page displays basic summary statistics for the spatial fields. It also 
has a Regular spatial extraction export option. This creates a new dataset using 
multiple regular sized cells covering the entire spatial extents of the existing 
dataset. The size of these cells are defined using the X and Y Extent windows. 
The Region Overlap control allows cells to overlap adjacent cells by up to 50%. 

Regular spatial extraction requires the prior specification of a Key field in order 
to calculate summary statistics for each new output cell. The output dataset can 
be viewed using the View extraction button, which opens it in a new instance of 
the Statistics Explorer. The Save Extraction button allows this output dataset to 
be saved as a multi-banded ERMapper grid file.

Variogram

The Variogram view requires the user to define a key field which will be used in 
tandem with the spatial coordinates to compute a sample variogram. If the data 
has less than two spatial dimensions no variogram view will be available.

A variogram shows the degree of correlation between data in a spatial dataset in 
different directions and at different distances.

It can take a long time to compute a variogram and in most cases it will not be 
possible to compute the complete variogram for the entire data set unless it is 
relatively small (< 10,000 samples). Variogram computations are restricted by:

• Capping the maximum range (distance between points) that will be 
considered.

• Capping the number of input samples that will be considered.
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Display of the calculated variogram

A default spatial variogram is computed using parameters that should ensure that 
the computation time is of the order of a few seconds. Thereafter the range and 
maximum sample number can be modified and the variogram can be recomputed 
by hitting the Recompute Variogram button. Note that if the maximum number 
of samples is set to minus one, then all samples will be computed. It is not advised 
to include all samples in the data set if it exceeds 10,000 samples as the 
computation time required to build the variogram could be extremely long. If the 
number of samples is restricted the algorithm will look at a sub-set of samples that 
are evenly distributed spatially within the dataset. In many cases it is desirable to 
increase the range and increase the maximum number of samples to improve the 
statistical reliability of the variogram.

This procedure generates a radial variogram grid (lower left). The directional 
variogram can then be quickly extracted from this grid. The directional variogram 
is plotted on the right and the source data is shown in the spreadsheet. Only the 
zoom tools are available in this graph (no data selection is possible).
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The plot on the left shows the variogram grid. The red sectors represent the area 
of the grid that was used to extract the directional variogram. This area is 
controlled via Direction (0 to 360 degree clockwise from North) and Width 
(degrees of arc) controls. If the width is 180 degrees then you have obtained the 
omni-directional variogram and direction is irrelevant. Otherwise, you will obtain 
a direction dependent variogram. You can change the direction of the variogram 
from the Direction spin buttons or simply click and drag you mouse across the 
variogram grid plot. The width can only be changed via the Width spin control.

The variogram records several parameters including the moment of inertia (semi-
variogram), covariance and pair count. Both the variogram grid plot and the 
directional variogram plot display the parameter selected in the Display drop list.

Model Variograms

If the Statistics Explorer has been opened via the Variogram button within the 
Kriging wizard of the Gridding Tool, a Model Variogram also can be created, 
edited and displayed. In this case an option is added to the Sample page to show 
the model variogram curve in addition to the sample variogram curve.

A Model property page is also available to manipulate the model variogram. The 
model variogram will be automatically initialised to a reasonable model fitting the 
data. You can press the Initialise Model button at any time to reset the model to 
this default.

The model is plotted to a range controlled via the range edit parameter. By default 
this is equal to the sample variogram range.

The model variogram is displayed as a grid and also as a directional extraction – 
just like the sample variogram. The sample variogram curve can be plotted for 
comparison. As before, the extraction direction can be controlled via the edit 
buttons or by dragging the cursor across the variogram grid display.

In the upper right the model nests are displayed. Each nest corresponds to 
semivariogram model. Individual nests can be edited, added, cloned and deleted 
via the buttons on the right. Alternatively double clicking on a nest in the list allows 
editing.
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Displaying the sample and model variograms

Editing or adding a nest presents the following dialog; if adding a new nest the 
dialog is presented as a wizard.

Select the Model Type from the range available
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The Model Type page allows you to change or select an appropriate model for 
the nest. A description of the model is presented. The coordinates displayed for 
the model are not representative of the actual model coordinates.

Controlling the parameters of the variogram

The Parameters page allows the editing of the model parameters. At the top right 
is a drop-list of model types. 

The graph presents the sample variogram, the model variogram excluding the 
current nest you are editing or adding, the current nest and the final model 
variogram including the current nest. The model parameters are presented below 
the graph and can be directly edited. Also, most model parameters can be edited 
graphically by dragging the blue tags that are presented on the graph axes. For 
example, with the spherical model the left vertical axes allows the editing of the 
sill and the bottom horizontal axis allows range to be edited.



Appendix B Statistics Explorer Tool 639

The sample variogram grid is displayed in the bottom left. Drag the cursor in this 
graph to edit the direction of the model variogram. This will also change the 
direction for the sample variogram extraction. Note that the width of the extraction 
is equal to the width of the extraction on the main ‘Sample’ page and cannot be 
modified here.

Editing the variogram nest

The Anisotropy tab controls the range of the model along two axes – the major 
and minor axes. The direction of the major axis is shown on the nest grid preview 
on the left. The final model preview is shown on the right. 

The major axis range will be equal to the range established on the ‘Parameters’ 
page. The minor axis range can be used to introduce anisotropy to the model. If 
the minor axis range is equal to the major axis range then the model is isotropic. 
If it is larger than the major axis range then the model will have a smaller 
contribution in the minor axis direction.
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The principal parameters of each nest can be altered graphically via the ‘model’ 
page. Select the nest from the model list and manipulate the principal parameters 
via the blue edit tags in the variogram plot.
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C Field Data Conditioning Tool

The Field Data Conditioning dialog

The Field Data Conditioning dialog can be accessed from a number of 
Discover 3D tools using the Advanced Settings button (shown left). It allows 
you to remove abnormal or invalid data, such as negative values representing 
missing samples and spurious outliers, as well as providing Null value 
assignment and handling. It can also be utilised to query out and display 
specific portions of a dataset, for example all downhole gold assays between 
2g/t and 5g/t, or only intervals with a QBX or QV lithological code.
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The Graph view of the Statistics Explorer

The Statistics button at the top of the dialog opens the Statistics Explorer Tool. 
This tool provides a powerful means of analysing the dataset for geochemical 
outliers, invalid data ranges, data distribution, etc via Graphical, Statistical and 
Histogram views. This dialog is dynamic: it will reflect any invalid data ranges or 
cap values set in the Field Data Conditioning dialog, allowing the effect of any 
conditioning applied to the data range to be checked.

Within the Graph and Histogram views of the Statistics Explorer Tool, data 
subsets can be selected using the Rectangle Selection tool.

Then viewed using the View Current Selection button.

Return to the previous selection (or entire dataset) using the View Previous 
Selection button.
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The central part of the Field Data Conditioning dialog allows the specification of 
invalid data and/or data ranges. The first option auto-populates with the dataset’s 
default null value: generally -1.0×1032. Invalid data (either user-defined or pre-
existing null input data) will be handled as a null value internally and not 
displayed. 

Specifying individual invalid data values. This is appropriate for removing negative values 
representing BDL (Below Detection Limit), SNR (Sample Not Received), etc.

The following options allow specification of a list of user-defined invalid data 
values and/or ranges specific to the data field. Enter the invalid value or range 
at the left and then click the green cross to add it to the list at the right.

List entries can be removed using the Delete button. Some examples of use are 
presented below:
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Specifying an invalid data range to remove a range of negative values in the dataset from 
the 3D gridding process. This is a useful way to remove multiple negative values, rather 
than entering each one individually.
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Using the Field Data Conditioning dialog to display only a data range of interest, in this 
case only gold assays between 2 and 5g/t. This is done by specifying all data outside this 
range as a series of invalid ranges.

Setting a Cap values below or values above will cap source data outside the set 
limit to the limiting value. For example, with Cap values above set to 500, a gold 
assay on 725ppm will be handled as a 500ppm value. It is also possible to 
Convert null values to a background value specified by the user, in order to 
constrain the invalid data. For example, if plotting geochemical assays, much of 
the data may not have been sampled for and in these areas the assay result may 
be assumed to be equal to the background value. This helps prevent anomalies 
‘ballooning’ into areas with no source data coverage.

Various other numerical functions are available for most datasets from the drop 
down at the bottom; including scaling, translate (offset) and averaging functions.
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The Field Data Conditioning dialog when the source data field is a text field

If the data field is a text field (e.g. lithology codes for use in drillhole colour 
modulation, or voxel gridding), the Field Data Conditioning dialog display will be 
altered accordingly.

This allows individual text strings to be specified. The null value for invalid data 
can be set, and a background value to set nulls to.

Data conditioning parameters (invalid data ranges, cap values, etc) can be 
saved and reused by using the Save and Load buttons at the top of the dialog. 
These create and handle Data conditioning files (.edc) that store the user-
defined parameters.
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D Voxel Calculator Syntax
A series of advanced Boolean and algebraic operators are available for use in the 
Voxel Calculator tool to enable data merging, decision logic and complex 
arithmetic operations. The operators are implemented by applying a specified 
syntax that describes the input, output and required operation.

• Logical Operators

• Arithmetic Operators

• Anti-Log Functions

• Comparison Operators

• Boolean Operators

• Trigonometric Operators

Logical Operators

• AND Operator

• NOT Operator

• OR Operator

• XOR Operator

• IF Operator

AND Operator

Returns TRUE if both its arguments are TRUE; returns FALSE if one or both 
arguments are FALSE.

Syntax

AND(logical1,logical2)

Logical1 and logical2 are conditions you want to test that can be either TRUE or 
FALSE. The arguments must evaluate to logical values such as TRUE or FALSE. 
An alternative to the AND function is the operator ‘&’ (‘&&’ is interpreted as ‘&’).
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Example 1

Out = IF(AND(A>5, B<=10), 1, 2)

The output Out is set to 1 if both A>5 and B<=10 otherwise it is set to 2

Example 2

Out = IF(A>5 & B<=10), 1, 2)
Out = IF(A>5 && B<=10), 1, 2)

This is an alternative syntax. These examples produce the same output as 
example 1.

NOT Operator

Reverses the value of the argument. Use NOT when you want to make sure a 
value is not equal to one particular value.

Syntax

NOT(logical)

Logical is a value or expression that can be evaluated to TRUE or FALSE. If 
logical is FALSE, NOT returns TRUE; if logical is TRUE, NOT returns FALSE.

Example 1

Out = IF( NOT(A<100), A, 100)

The output Out is set to A if A > 100 and is set to 100 otherwise. This is a trivial 
example which could be replaced with the >= operator

OR Operator

Returns TRUE if either argument is TRUE; returns FALSE if both arguments are 
FALSE.

Syntax

OR(logical1,logical2)
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Logical1 and logical2 are conditions you want to test that can be either 
TRUE or FALSE. 

The arguments must evaluate to logical values such as TRUE or FALSE. The ‘|’ 
operator is an alternate to the OR function. ‘||’ is an alternative to ‘|’

Example 1

Out = IF( OR(A<100, B<100), C, D)

This example sets the output Out to C if either A or B is less than 100. The output 
is set to D otherwise.

Example 2

Out = IF( A<100 | B<100), C, D)
Out = IF( A<100 || B<100), C, D)

This is an alternative syntax where these examples produce the same output as 
example 1.

XOR Operator

Returns TRUE if only 1 argument is TRUE; returns FALSE if both arguments are 
FALSE or both are TRUE.

Syntax

XOR(logical1,logical2)

Logical1 and logical2 are conditions you want to test that can be either TRUE or 
FALSE.  The arguments must evaluate to logical values such as TRUE or FALSE

Example

Out = IF( XOR(A<100, B<100), C, D)

This examples sets the output ‘Out’ to C if one and only one of A and B is less 
than 100. The output is set to D otherwise.
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IF Operator

Returns one value if a condition you specify evaluates to TRUE and another value 
if it evaluates to FALSE.

Use IF to conduct conditional tests on values and formulas.

Syntax

IF(logical_test,value_if_true,value_if_false)

Logical_test is any value or expression that can be evaluated to TRUE or FALSE. 
For example, A=100 is a logical expression; if the value in A is equal to 100, the 
expression evaluates to TRUE. Otherwise, the expression evaluates to FALSE. 
This argument can use any comparison calculator operator.

Value_if_true is the value that is returned if logical_test is TRUE. For example, if 
this argument B and the logical_test argument evaluates to TRUE, then the IF 
function returns the value stored in B. 

Value_if_false is the value that is returned if logical_test is FALSE. For example, 
if this argument is C and the logical_test argument evaluates to FALSE, then the 
IF function returns the value stored in B.

Up to seven IF functions can be nested as value_if_true and value_if_false 
arguments to construct more elaborate tests. See the last of the following 
examples. When the value_if_true and value_if_false arguments are evaluated, 
IF returns the value returned by those statements. 

Example 1

Out = IF( A<100, A, 100 )

This example will set the output to A when A is less than 100 and set it to 100 
otherwise.

Example 2

Out = IF( A<100, IF( B>A, B+100, A+100), IF(C>0, C, A) )

This example shows how the two output expressions of the first IF can 
themselves be IF functions.

Operators specify the type of calculation that you want to perform on the elements 
of a formula. Two types of calculation operators are available: arithmetic, 
comparison.
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Arithmetic Operators

To perform basic mathematical operations such as addition, subtraction, or 
multiplication; and produce numeric results, use the following arithmetic 
operators.

Anti-Log Functions

To perform anti-log operations (opposite in operation to logarithmic function 
equivalents) the following are available:

Syntax

aln(x)

Anti-logarithm (base e) of x, that is e^x

alog(x)

Anti-logarithm (base 10) of x, that is 10^x 

Arithmetic operator Meaning (Example)

+ (plus sign) Addition (3+3)

– (minus sign) Subtraction (3–1) 
Negation (–1)

* (asterisk) Multiplication (3*3)

/ (forward slash) Division (3/3)

^ (caret) Exponentiation (3^2)
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Comparison Operators

You can compare two values with the following operators. When two values are 
compared by using these operators, the result is a logical value either TRUE or 
FALSE.

Null support is also provided in the calculators. 

Boolean Operators

Note that the following Boolean logic operators apply only to the Grid Calculator. 
Some examples:

OUT = IF(A>0, A, B)

OUT = IF(A>0 & B<(C/2), D, E+F)

OUT = IF(AND(A>0, B<(C/2)), D, E+F)

OUT = IF(A<100, Null, A)

OUT = IF(A=Null, B, C)

Note that the second and third examples above are identical, the first using the & 
operator and the second using the AND function.

Comparison operator Meaning (Example)

= (equal sign) Equal to (A=B)

> (greater than sign) Greater than (A>B)

< (less than sign) Less than (A<B)

>= (greater than or equal to sign) Greater than or equal to (A>=B)

<= (less than or equal to sign) Less than or equal to (A<=B)

<> (not equal to sign) Not equal to (A<>B)

MIN(value1, value2) Smaller of two values

MAX(value1, value2) Larger of two values
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Trigonometric Operators

The following trigonometric operators are available for both Line and Grid 
Calculators.

DEGTORAD(degree_value)

Convert degree values to radians.

RADTODEG(radian_value)

Convert radian values to degrees

SINH(a)

Hyperbolic sine of an argument in radians (Y = sinh(x))

COSH(a)

Hyperbolic cosine of an argument in radians (Y = cosh(x))

TANH(a)

Hyperbolic tangent of an argument in radians (Y = tanh(x))

Note that standard geometric operations such as SIN, COS and TAN are 
available from the Line and Grid Calculator standard interfaces. 
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Symbols
.00T 153, 166, 356
.3DS 152, 166
.ADF 152, 153, 166, 216, 356
.ALG 152
.ASC 152, 216, 356
.BIL 152, 216, 356
.BMP 153
.BT2 153, 166, 356
.CSV 364
.DEM 153, 216, 356
.DM 152, 166
.DTM 166, 356
.DXF 152, 244, 356, 364
.ECW 152
.EGB 152
.ERS 153, 216, 356
.FLY 571
.FLY animation script 575
.GIF 152
.GRC 153
.GRD 152, 153, 216, 356
.GXF 152, 216, 356
.HDR 216, 356
.JPG 152
.MIF 170, 244, 356, 364
.MIG 152, 216, 356
.PL 153, 166, 356
.PNG 152
.SHP 166, 244, 356, 364
.STR 166, 356
.TAB 152, 170, 244, 356, 364
.TAR 153, 216, 356
.TIF 152, 153
.TIFF 152
.TIN 356
.TKM 152, 356
.TS 153, 166, 356, 364

.USG 153, 216, 356

.VS 153, 166, 356

.WAV format 581

.XYZ 152, 216, 356

Numerics
3D animation 571
3D cursor keyboard shortcuts 619
3D DXF models 165
3D Extrusion Wizard 27, 66, 508
3D Grid Toolkit 443
3D Gridding

block kriging 473
capping data 461
cell size 463
classification 453
Continuously variable method 449
Convert null values to background 255, 461, 

645
creating 3D or 2D grids 446
Default numeric null 481
Default text null 481
elliptical search 467
geology 453
grid extents 463
grid origin 463
grid passes 466
Inverse Distance Weighting 450
lithology 453
Load entire hole length 481
nugget effects 461
Null value handling 460
ordinary kriging 473
point kriging 473
search expansion 466
Segment break length 481
simple kriging 473
simple mode 467
weighting models 469

3D Grids 443
3D Map 440

Index
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3D Stereo Visualization 128
3D Studio 166

vector 152, 356
3D Tube

of drillholes 289
3DConnexion SpaceNavigator™ 125

A
Absolute

for animation 583
Absolute position

in Extrusion Wizard 513
Add 3D View to MapInfo button 562
Add a lines display object 85, 97
Add a located bitmap layer 85, 98
Add a points display object 84, 97
Add a surface layer 85, 98
Add a vector layer 85, 98
Add a voxel model layer 85, 98
Add button 429
Add Image button 144
Add layers to an image 220, 221, 222
Add Points tool 173, 189, 203
Add Vector button 166
Advanced option 38
Advanced Settings

3D Gridding 461
Akima 242
Akima Spline

drillhole desurvey method 283
Algorithm Options

3D Solid Generator 528
animation 571
anisotropy

kriging model variogram 480, 639
Appearance Tab

of voxels 412
Appearance tab 413

of drillholes 289
Apply button 114
Arc

grid 152
ASCII 364
ASCII files

import 400

ASCII XYZ voxel 405
ASCII XYZ voxel model 398
ASEG

grid 356
GXF 216
GXF grid 152

attribute ranges 427
Audio

for animation 583
audio accompaniment 580
Audio entry line 581
audio identification

in animation 572
Auto-Apply

option 407
Auto-Apply option 217, 416, 427
Available window 51
AVI movie 572
Azimuth

for animation 581

B
Back buttons 32
Back calculation

drillhole desurvey method 281
Background colour 596
Band Pass Mapping

of images 234
Band-pass operations

for colouring 157
base of extruded object 511, 513
Bezier smoothing

for animation 579
Bezier Spline

drillhole desurvey method 283
BIL 152, 216, 356
bitmap 153
bitmap display and manipulation 309
Bitmap tab 308
bitmaps formats 143
Bivariate view

gridding Statistics Explorer 630
block kriging

3D gridding 473
block models

creating 443
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breaklines
Gridding Tool 253

C
calculator for 3D models 494
Camera button 581
Cancel button 79

for animation 587
capping data

3D Gridding 461
capture a point 580
Capture Point List 580
cell size

3D Gridding 463
CEMI 398, 401
Centre the bitmap 309
centred 99
Chair Clipping 412
Chair View option 418
Clear Cells button 592
Clip model option 416
Clipping

of voxels 412
clipping operation 417
Clipping tab 415
closed polyhedral object 520
collar positions 278
COLLARS.TAB 279
Colour

option of images 233
Colour and Intensity layers 219
Colour cells of a row 592
colour gradients 232
Colour layer 232, 233
Colour Look-Up Table (LUT) Editor 590, 592
Colour mapping 157
colour mapping 420
Colour Tab

of voxels 412
column

slicing 415
Compression

3D Solid Generator 529
compression 229
Compuserve GIF 152

Continuously variable
3D gridding 449

Contour 222
Contour Dropout 242
contour labels 242
Contour surface 219
contour surfaces 222
contour vector layers 239
Contours 222
Convert null values to background

3D Gridding 255, 461, 645
Convolution filtering

3D Gridding 481
core mesh 400
Cosinus kernel function

density grid 269
Create a movie 584
Create a new LUT 592
Create AVI button 587
Create Eye and Look Path DXF Files 579
create objects See Feature Database
cumulative value of the histogram 234
Custom option 592

D
Data Conditioning

3D Gridding 460
Gridding Tool 255

data field
in Extrusion Wizard 511

Data honouring
Convolution filtering 482

Data Source
of images 233

Data tab 406
DATA.TAB 279
Datamine

vector 152
voxel 399
wireframe 166

Datemine
wireframe 356

Decimation entry 243
default locations 609
Default numeric null

3D Gridding 481
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default page size 605
default printer page size 605
Default text null

3D Gridding 481
defining the flight path 575
Delete an image layer 220
Delete rows

legends 598
density correction

IDW gridding 472
Density method

3D Gridding 455
Depth Axis 480
descriptive text entry 597
digitization See Feature Database
dimensions

3D Gridding 464
direction selected 99
Discover3D>Options 603
Discover3D>Toggle Auto 3D Selection menu 42
Display

option described 77
Display Assistant

3D Gridding 497
Display list 288
display the Properties Dialog 96
Display Window area 76
Display>Drillhole menu 278
Display>Image 144, 146
Display>Image item 147
Distance

3D Gridding 466
distance grid 482
dockable toolbars 76
downhole log 305
downhole survey data 278
draw objects See Feature Database
drillhole

selection 52
drillhole appearances 290
drillhole data 276
drillhole display object 85, 97
drillhole log 26, 59
Drillhole Project 279, 306
drillhole project 276
Drillhole Properties 308

drillhole trace 306
drillholes

appearance 289
Drillholes button 278
Drillholes entry 278
dropout contours 243
Dropout Frequency 243
Dropout Threshold 243
DTM tab 158
Duplicate an existing surface 220
Duplicate button

of LUT Editor 592
Duplicate Patterns 598
Duration

for animation 581, 583
DXF 152, 166, 170, 244, 356, 364
DXF file of a created flight track 572

E
Edit button 157
Edit Existing Fly-through File option 577
elevation of a topography surface 229
Elliptical search

3D Gridding 467
elliptical weighting

IDW gridding 472
Encom

3D grid 399
georeferenced image 152
grid 152, 216, 356
GSF 170
vector 356

Encom 3D Grid format 499
Encom Georeferenced Bitmap file 143
Enhance

option 236
Enhance displays

of drillholes 304
Epanechnikov kernel function

density grid 269
ER Mapper algorithm 222
ER Mapper Algorithm button 238, 240
ER Mapper software 238
ER Mapper support 238
ERMapper
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algorithm 152
ECW 152
ERV 170
grid 153, 216, 356

ERMapper surface 219
ESRI

3D shapefiles 166
grid 216, 356
SHP 170
TIN 153, 166
vector 356

ESRI .SHP files 244
Event Details 582

for animation 580
Event type 581
exact hit distance

IDW gridding 472
examples of point data 173
experimental variogram

Kriging gridding 451
Exponential weighting

IDW gridding 471
Export DH Logs to 3D 59
extrude regular shapes 515
Eye points 579
Eye Position 583

of animation 573

F
Feature Database

cosmetic layer 360
Create 353
digitization 370
editing 375
export 364
Import 355
interrogating 391
labelling 365
object attributes 364
querying 368
selecting objects 368

feature databases 350
File Tab

of voxels 412
File types

.FLY 575

.WAV 581
Fill 156
fill colours

of lines 189
filtering

3D Gridding 481
Finish button 39

in Extrusion Wizard 517, 518
fixed value of height

Extrusion Wizard 512
flight path specified

for animation 571
FLY file type 575
fly-through wizard 571
Follow baseline 242
Foreground colour 596
formats 398
Frame Rate 579
From input

in Extrusion Wizard 515
From-to segment option 481
Fullscreen mode

3D view 127

G
Gaussian kernel function

density grid 269
Gaussian weighting

IDW gridding 471
GDB file 280
Gemcom 166

vector 153, 356
voxel 399

Geopak
grid 153, 216, 356

Georeferenced Image 153
Georeferencing Wizard 144
Geosoft

grid 152, 216, 356
voxel 399

Geosoft drillhole database
modify dip 280, 281

Geosoft Wholeplot Databases 280
GeoTIFF 152
GoCAD 364

vector 153, 166, 356
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voxel 399
Grid Calculator Syntax 647
Grid Compression 604
grid creation See 3D Gridding
Grid Flipper 217
grid formats 217
Grid Information button 224
Grid Management 500
Grid Passes

3D Gridding 466
Grid Selection button 238
gridding methods 256
gridding See 3D Gridding
Gridding Tool

Input Tab 253
Preview Display 252

grids
gridding methods 256

H
Histogram

transform 157
histogram 234
Histogram Colour Mapping

of images 234
histogram equalisation

GriddingTool 252
hole name 288
hole tops 292
Holes tab 287
horizontal Scale 308
HSL Interpolation 184, 200, 421, 598
Hue:Saturation:Lightness colour 598

I
Image layer 147
Image Properties dialog 153
Images 3D

Object Manager 28, 70
Import a .TAB file 598
Inclination

for animation 581
individual drillholes 51
Input Data

3D Gridding 458

Input Tab
Gridding Tool 253

Insert
option described 77

Insert row
legends 598

integration 441
Intensity layer 232, 234
Interactive mode

of thresholding 424
interactive mode of thresholding 424
Interp Gaps button 592
Interp Selection button 592
Interpolation Mode of an image 161
interpretational displays 440
inversion 399
inversion packages 397
isosurface

creation 429
using interactive mode 429
using lithologies 429

Isosurface slider bar 430
Isosurface Tab

of voxels 412
Isosurface tab 429

J
joining shapes

tie lines 536

K
Kernel density estimator

density gridding 456
keyboard shortcut 619
Kriging

experimental variogram 451
model variogram 451, 452
nugget 452
range 452
sample variogram 451
semivariance 451
sill 452

kriging
equation 452
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L
labelling of data 181
Landmark

grid 152, 216, 356
layer property 234
Layout Mode 127
LEG extension 598
Legend information 598
Lighting

of Located Images 157
Line Colour 597
Line Data 36
line data 189
Line descriptor 189
Line display 231
line identifier field 189
line parameters 189
Linear (Decreasing)

transform 157
Linear (Increasing)

transform 157
Linear Colour Mapping

of images 234
linear traverses 189
Linear weighting

IDW gridding 470
lithological boundaries 26
Lithology mode

of thresholding 424, 426
Lithology pull-down

list 429
Lithology Tab

of voxels 412
Load entire hole length

3D Gridding 481
log

of drillholes 59
Log (Decreasing)

transform 157
Log (Increasing)

transform 157
Log Display 305
Log profiles 59
logs displayed 308
Look At point 573, 583
Look At points 579

Look Position 583
look-up tables 515
Loop Style 581

for animation 578
lost file 79
low gradient areas 231
LUT Editor 590

M
Manual

transform 158
manually pick anomalies 97
manually specified views

for animation 571
MapInfo 364

grid 152, 216, 356
MIF 170
TAB 170
vector 356

MapInfo Professional
views 562

Mask check box 244
Match Grid option 464
measured depths of the hole 278
mesh

model 400
UBC model 400

Micromine
voxel 399

mine simulation 397
Minex

grid 152, 216, 356
Minimum Curvature

drillhole desurvey method 282
minor contours 242
model variogram

kriging 476, 636
Kriging gridding 451, 452

ModelVision 152
Modify Database Properties

Geosoft drillhole database 280, 281
modulate the colours

in Extrusion Wizard 515
Modulated rotation 186
Moment of Inertia See Sample Variogram
Move the selected surface 221



662 Encom Discover 3D User Guide

MPEG-4 Video codec 587
multiple image objects 28, 70
multiple isosurfaces 429
multiple voxel displays 440

N
nests

variogram 476
New button

for LUTs 591
New legend files 598
Next buttons 32
Noddy 399, 403
Normal View Mode 127
nugget

inverse distance weighting 470
Kriging 452

nugget effects
3D Gridding 461

Null value handling
3D Gridding 460

nulls 401
number of cells

UBC model 401
number of colours 184, 199, 420
Number of entries 592

O
Oasis montajTM

Geosoft drillhole database 280
Object Manager 28, 70
offset

of Located Images 158
Offset Tab

of voxels 412
Offset to grid maximum

for animation 584
Online printers 610
Open button

of grids 217
operator

AND 647
arithmetic 651
boolean 652
comparison 652

IF 650
NOT 648
OR 648
trigonometric 653
XOR 649

Options tab 608
ordinary kriging

3D gridding 473
ore body outlines 26
Orthographic view 99

P
padding zone 400
Page Layout display 610
Page Setup tab 610
Pan button 564
pattern 596
pause

for animation 580
Pause for a specified duration 581
Perspective view 99
Play button 584
playback

animation 580
Point Data 36
point data 173
point data tables 173
point kriging

3D gridding 473
Point Size 605
Point Symbol Size

for animation 579
Points display 174
pop-up menu items

described 111
Power weighting

IDW gridding 471
preferred view options 605
preview

for animation 580
preview display

Gridding Tool 252
Primary Axis 480
primary coordinate directions 418
properties
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examples 397
properties of a model

UBC 401
property attribute 397
Property colour controls

of isosurfaces 430
Pseudocolour 219
Pseudocolour image 222, 223, 232
pseudosection 143

Q
quality of the bitmap 309
quality texturing 309
Quartic kernel function

density grid 269
query

display data subset 447, 641
query data

Field Data Conditioning 645

R
Radial density estimator

density gridding 456
range

Kriging 452
raster 152
Raster Detail 605
raster imagery 145
rasterise option 563
recorded lithologies

of drillholes 276
Red, Green and Blue branches 237
Red:Blue:Green (RGB) imagery 236
Red:Green:Blue

images 222
Remove Temporary Files on Exit 603
removing lines 189
Render thresholded voxel model option 429
Repeat Reverse Look 579
Repeat Reverse replays 578
replay

of animation 571
Reset button

in 3D displays 230
Restore button 115

RGB colour mode 236
RGB Interpolation 184, 199, 420, 598
RGB surfaces 223
Rotate Around button

for animation 582
Rotate View button

for animation 581
rotation

for animation 580
row

slicing 415

S
Sample Variogram

Kriging 473
sample variogram

Kriging gridding 451
Scale button

in 3D displays 230
Scale factor

in Extrusion Wizard 512, 513
scaling

in Extrusion Wizard 512, 513
scanned product 162
Scope

of Located Images 156
script file

for animation 575
search expansion

3D Gridding 466
Search Parameters

3D Gridding 465
search sectors

3D Gridding 469
seed model

for inversion 440
Segment break length

3D Gridding 481
Segments

drillhole desurvey method 282
Select points within a 3D wireframe 540
Selected window 51
semivariance

Kriging method 451
session file restoration 79
set transparent 162
shade ball



664 Encom Discover 3D User Guide

intensity 235
shading control 235
shading to the display 234
Shape Matching

3D Solid Generator 531
Sharpen

drillholes 304
sides of the extruded shape 66, 508
sill

Kriging 452
simple kriging

3D gridding 473
Simple mode

3D Gridding 467
Simple option 37
single model

only 407
slice

model 415
Slices Tab

of voxels 412
slider bars

for chair view 418
of Clipping 417

Smoothing 242
for animation 579
of 3D vectors 168

smoothing
in Grid Wizard 450

SpaceNavigator
controls 125
device 125

Spatial view
gridding Statistics Explorer 632

specific file locations 605
Specify the data value

of colours 592
spreadsheet

Gridding Tool 622
Stack button 230
standard colours

in Extrusion Wizard 515
Statistics Explorer 254, 621

Gridding Tool 621
status bar 77
Step Patterns 598
Structure Analysis

3D Solid Generator 530
Style

of Located Images 156
Subsetting 625
sun illumination

GriddingTool 252
Surface Compress option 231
surface display 229
surface grid

in Extrusion Wizard 511
Surfer

grid 152, 216, 356
Surpac

DTM 166
string 166
vector 356
voxel 399

survey data
of drillholes 278

survey points
of drillholes 279

SURVEY.TAB 279
Symbol Generator utility 186

T
tab controls 114
Tapering

IDW gridding 472
Temporary Directory 603
Tension

of smoothing for animation 579
texture mapping 223
Texture Quality 224
texturing

images 28, 70
threshold

lines 189
Threshold by checkbox 425
Threshold Tab

of voxels 412
Thresholding 424
Tie Lines

3D Solid Generator 533
Tools

option described 77
Tools option 605
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topography 401
Total Colours item 184, 199, 420
transfer a view from Discover 3D 562
Transparency 222
transparency

of drillholes 58, 60
transparency value 223
transparent 162
tree branch 111
trench display object 85
Triangle kernel function

density grid 269
Triweight kernel function

density grid 269

U
UBC 398, 400
UBC model 400
Uniform kernel function

density grid 269
Univariate view

gridding Statistics Explorer 625
University of Utah 401
Use Global Directory 610
USGS

grid 153, 216, 356
Utilities menu 77

V
Variable cell size option 464
Variogram view

gridding Statistics Explorer 634
Vector Contour branch 240
vector files 165
Vector item 166
vector layers 240
Vectors layer 166
vertical bars using point data 509
Vertical Mapper

grid 153, 216, 356
Video codec 587
View AVI button 587
View Drillhole 306
View Logs menu 60, 307

view modes
Full screen 127
Normal 127
Orthographic 99
Page Layout 127
Perspective 99

View Section Boundary 63
View>Add 3D View to MapInfo 562
voxel

defined 397
Voxel Calculator 494
Voxel Model properties 406
Voxel models

creating 443
voxels 411
Vulcan

triangulation 166
vector 153, 356
voxel 399

W
WAV file type 581
Weighting Models 470
weighting schemes

IDW gridding 469
WHOLEPLOT 280
wireframes 433
wizard button

for models 406
Workspace toolbar

described 109
Workspace tree growth 109

Z
Z Scale

of 3D displays 225
Zoom Toolbar controls 98
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